Introduction

MindFusion.Scheduling for ASP.NET Programmer's Guide
Introduction

MindFusion.Scheduling for ASP.NET is a software component that can be used to present calendars and timetables to users and let them edit the schedule information interactively. It is implemented as a .NET Web control and can be easily integrated into any web application targeting the Microsoft .NET platform. By providing your software with ready to use capabilities for visualizing and editing schedule data, MindFusion.Scheduling for ASP.NET saves you from hundreds of hours of coding and debugging efforts. MindFusion.Scheduling for ASP.NET can display a schedule in several view types, such as:

  • Single or multiple month views, displaying the days of one or more months and allowing scrolling to previous or next month range;
  • Range of weeks, displaying days in a grid in which the days of a week occupy a single row;
  • Range of time intervals (hours, days, weeks, etc.), displayed in columns or rows;
  • Timetable view, displaying the allotment of resources to distinct hours of a day;
  • Resource view, displaying the distribution of resources over a period of time;

MindFusion.Scheduling for ASP.NET provides intuitive user-interaction model for creating or editing appointments and events in a schedule. In addition, its programming interface places at your disposal many useful functions, ranging from XML serialization to displaying reminders and checking what occurrences of recurrent events happen in a specified time interval.

Note: MindFusion.Scheduling for ASP.NET relies on the jQuery library. The following copyright notice must be included in the documentation and/or other materials provided with the application.

© 2015 MindFusion


General Information

General Information

The MindFusion.Scheduling control

  • Redistribution is royalty free
  • Assembly is strong-named
  • Can be purchased with source code
  • Is written in C#

The Schedule component

  • Allows definition of custom-typed events
  • Supports recurring events
  • Can be persisted into binary streams and XML documents

Views

  • Timetable view
  • List view
  • SingleMonth view
  • MonthRange view
  • WeekRange view
  • Resource view

User interaction

  • Interactive item creation
  • Drag&drop item modification (move, resize)
  • Scrolling
  • Tool-tips
  • Moving to the next / previous day or month

Programming

  • Programmatic access to both schedule objects and the calendar methods and properties
  • Numerous properties for customizing the appearance and behavior of every calendar view
  • Rich client-side event set and API

Appearance

  • Fully customizable style-based appearance
  • Customizable fonts, colors and alignments of displayed text
  • Built-in themes

Built-in forms

  • NewForm and EditForm for appointment creation and editing
  • RecurrenceForm for event recurrence creation and editing
  • ItemsCueForm for displaying items not visible in the current viewport


What's New in this Release

What's New in this Release

The list below describes recent changes and additions to MindFusion.Scheduling for ASP.NET:

New in version 3.2

Horizontal Timetable view

Horizontal layout has been added to the Timetable view. The horizontal timetable view displays a collection of rows where each row represents the allotment of resources to distinct hours of a day; the rows in this view represent dates, tasks, locations, contacts or resources. The rows can be grouped by location, task, contact or resource. Each column represents an hour or a custom time interval. You can switch between horizontal and vertical layouts of the Timetable view by setting its Orientation property.

License keys

There is no separate trial build of the control assemblies anymore. Instead, set the LicenseKey property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one Calendar instance or other controls by MindFusion, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) to specify the key once instead of setting it per each control. License key strings are listed on the Keys & Downloads page at MindFusion's customer portal.

Miscellaneous

  • Visual Studio 2013 toolbox support.
  • The bundled jQuery version has been upgraded to 1.11.2.
  • getViewDom method has been added to the Calendar's client API.


Version History

Version History

The list below describes recent changes and additions to MindFusion.Scheduling for ASP.NET:

New in version 3.1

Miscellaneous

  • Interactive resize of items is now available in all views.
  • Some of the CSS classes have been renamed to provide better consistency across themes. Check the updated CSS Classes topic for details.
  • Visual Studio 2012 support.
  • The bundled jQuery version has been upgraded to 1.9.

New in version 3.0

Resource View

This view displays the distribution of items over a period of time for particular contacts, locations, tasks or resources. The view displays a single row for each individual contact, location, task or resource and up to three timelines. In order to view associated items in this view, the GroupType property of the Calendar must be set to GroupByContacts, GroupByLocations, GroupByTasks or GroupByResources.

Vertical List View

Vertical layout has been added to the List view. The vertical list view displays a collection of rows where each row represents a single second, minute, hour, day, week, month or year. You can switch between horizontal and vertical layouts of the List view by setting its Orientation property. Grouping is available in both layouts of the view.

Miscellaneous

  • Some of the Style-related properties and classes have been altered in order to provide more clear and straightforward ways to style the Calendar. The Style class is designed for styling non-header elements, such as day cells. The HeaderStyle class is intended for styling different header elements, like day cells headers, timelines, the main and the additional headers within the view. The ItemStyle class is designed exclusively for applying styles to Calendar's items. Check the Customizing the appearance of Views and Customizing the appearance of Items topics to see how the new classes are used. Examples are also available in some of the samples, including Customization, Google Calendar and Tutorial5.
  • Some properties have been renamed to ensure consistency across similar classes. The complete list of renamed properties is available in the Upgrading from version 2.x topic.
  • The bundled jQuery version has been upgraded to 1.7.
  • getStartDate, getEndDate, getViewCells and getViewOrientation methods have been added to the Calendar's client API.

New in version 2.1

Localization

Localization support has been added to MindFusion.Scheduling for ASP.NET built-in forms. All captions and control values can be customized by setting the corresponding property of the LocalizationInfo class. The localization data can also be exported to and loaded from XML.

Miscellaneous

  • client-side Calendar methods added: getAllDayCells - gets the collection of all-day calendar cells in the Timetable view; getItemDom - returns the collection of Dom elements for the specified item;
  • time indicator for Timetable non-all day items;
  • continuation arrows added for Timetable all-day items within an ItemsCue form;
  • Selection.AllowMultiple enabled for Timetable view;
  • various bugfixes.


Programming Interface Overview

Programming Interface Overview


The Schedule

The Schedule

The Schedule class represents the data displayed by MindFusion.Scheduling for ASP.NET calendar views. The schedule contains a collection of schedule items defined by the Item abstract class and implemented by the Appointment class. Appointment objects contain references to instances of the miscellaneous Task, Location, Contact and Resource classes, which are also contained in the respective collection members of the Schedule class. Items, resources and other classes are also available on the client, implemented as JavaScript objects, contained within the Calendar.

If your application has to process other types of schedule data items, create a class for each item type and inherit it from Item or Appointment. All methods and properties defined in Item are abstract, so if a class inherits from it, that class must implement all members of the Item class. On the other hand, if a class derives from Appointment, it can just add its own distinct properties and override the SaveTo and LoadFrom methods to implement serialization of the new members of the class. Custom schedule item classes must be registered for serialization via the RegisterItemClass method of the Schedule.


Schedule Items on the Server

Schedule Items on the Server

Events scheduled to occur at an appointed time are represented in MindFusion.Scheduling for ASP.NET by the abstract class Item. Item comprises the information that should be defined for all schedule events. For example, the StartTime and EndTime properties specify the time and duration of an event. The Recurrence property lets you create recurrent events that occur repeatedly following some recurrence pattern. There are several descriptive properties that define additional information about an item, such as Priority, HeaderText and DescriptionText. The class also defines methods that support serialization in binary format and XML.

It is possible to associate resources with scheduled events via the Resources, Contacts, Location and Task properties of Item. These properties contain objects from the Resource, Contact, Location and Task classes respectively.

The appearance of items when viewed in the Calendar can be set via the calendar's ItemSettings Style property. It lets you define the color, alignment and style of various elements of the item visualization, fill, header and description texts, icon images, and so on.

The abstract class Item is derived by the concrete class Appointment, which can be readily used in your applications. You could also define your own event class, which derives either from Appointment or Item. In order to integrate your custom class into the calendar API and user interface, you must do the following:

  • Provide parameterless constructor to let users create items of the custom class interactively;
    Override the SaveTo / LoadFrom methods if you have any additional data fields in your custom class and register the class for serialization using the Schedule.RegisterItemClass method;
  • Override SaveViewState / LoadViewState methods to save any additional data fields in the control's ViewState.
  • Override CopyOccurrence to support recurrence of the custom item. Also ensure you call MarkException on the associated recurrence whenever a custom property of the new item changes.
  • Detailed information and examples on how to use your custom items in MindFusion.Scheduling for ASP.NET can be found here.


Manipulating Items on the Client

Manipulating Items on the Client

Events scheduled to occur at an appointed time are represented on the client side in MindFusion.Scheduling for ASP.NET by the Item class. Item comprises the information that should be defined for all schedule events. For example, the values returned from the getStartTime and getEndTime methods represent the time and duration of an event. The getRecurrence method lets you view the Recurrence object, associated with this item instance. There are several other descriptive functions that can provide additional information about an item, such as getPriority, getHeaderText, getDescriptionText and so forth.

It is possible for an Item to be associated with resources such as Resource, Contact, Location or Task. The id(s) of the associated resource(s) can be obtained by calling getResources, getContacts, getLocation or getTask respectively.

Getting a reference to an item

There are various ways to access one or more items defined in a MindFusion.Scheduling for ASP.NET Calendar from the client. The getItems method returns a collection, containing all the items, currently present in the calendar's schedule. Currently selected items are accessible from the getItemSelection function. Cell objects also contain references to their associated items, which can be accessed through the getCellItems, getCueCellItems, getHeaderItems or getCueHeaderItems. Particular item or items can be accessed through id by calling getItemById or through the id of an associated resource with getItemsByResourceId.

Item object table

In order to programatically set values to one or more of the Item's properties, the createItem and editItem methods should be used, by passing as argument an object which defines the values of some of these properties.

This is a complete table of the names of the item's properties, which can be set programatically from the client side:

Name | Value type | Description
startTime | DateTime | Represents the start time of an event.
endTime | DateTime | Represents the end time of an event.
contacts | Array | Represents a collection, containing the ids of any associated Contact objects.
location | String | Represents the id of an associated Location object.
task | String | Represents the id of an associated Task object.
resources | Array | Represents a collection, containing the ids of any associated Resource objects.
cssClass | String | Represents the name of a user defined CSS Class, used to visually style the item.
allowChangeStart | Boolean | Specifies whether the item's start time can be modified by interactive resize.
allowChangeEnd | Boolean | Specifies whether the item's end time can be modified by interactive resize.
allowMove | Boolean | Specifies whether the item can be moved interactively.
locked | Boolean | Specifies whether the user can interact with the item.
allDayEvent | Boolean | Specifies whether the item is defined as an all-day event or not.
subject | String | Represents the item's header text.
details | String | Represents the item's description text.
reminder | Reminder | Represents a Reminder object, associated with the item.
recurrence | Recurrence | Represents a recurrent pattern, associated with the item.
priority | Number | Represents a user defined priority, used in the order in which items appear in the calendar.
visible | Boolean | Specifies whether the item is visible in the calendar.
tag | Object | Represents a custom field used for storing user defined data.

Creating items

New items can be added programatically on the client side by calling Calendar's createItem method.

The following function will create and add to the calendar an Item, which starts at 09:00 of the current day, with a duration of 9 hours, its header text will display "new item".

JavaScript [image] Copy Code

function create() {
// gets a reference to the calnedar, assuming the value of the Calendar's WebControl.ID property is set to "Calendar1"
var calendar = $find('Calendar1');

// creates an object holding the properties of the new item
var data = {
startTime: MindFusion.Common.DateTime.today().addHours(9),
endTime: MindFusion.Common.DateTime.today().addHours(18),
subject: 'new item'
};

// creates the item and adds it to the Calendar.
calendar.createItem(data);
}

Editing items

Items can be edited programatically on the client side by calling Calendar's editItem method. The item parameter should be the edited item, and the args parameter should be an Object, containing the changed properties.

The following function will edit the currently selected item, by assigning a recurrence pattern to it and changing its description text:

Note

You can find details about programatically creating recurrence patterns in the Recurrences on the Client topic.

JavaScript [image] Copy Code

funcion edit() {
// gets a reference to the calendar, assuming the value of the Calendar's WebControl.ID property is set to "Calendar1"
var calendar = $find('Calendar1');

// gets a reference to the calendar's item selection.
var itemSelection = calendar.getItemSelection();

if (itemSelection.length > 0) {
// gets a reference to the currently selected item.
var item = itemSelection[0];

// define the recurrence pattern data.
// The exact time on which the occurrences of this recurrent pattern will occur and their duration are defined by the Time component of the item's start and end time.
var recurrenceData = {
pattern: MindFusion.Scheduling.RecurrencePattern.Daily,
dailyRecurrence: MindFusion.Scheduling.DailyRecurrence.EveryWorkday,
startDate: MindFusion.Common.DateTime.fromDateParts(2010, 1, 8),
recurrenceEnd: MindFusion.Scheduling.RecurrenceEnd.Never
};

// defines the values of the edited properties.
var data = {
recurrence: new Recurrence(recurrenceData),
details: 'Working hard!'
};

// edits the item and updates the Calendar accordingly.
// In this particular case all the visible occurrences of the newly defined recurrence pattern will be displayed.
calendar.editItem(item, data);
}
}

Deleting items

Items can be deleted programatically on the client side by calling Calendar's deleteItem method. For example:

JavaScript [image] Copy Code

function delete() {
// gets a reference to the calendar, assuming the value of the Calendar's WebControl.ID property is set to "Calendar1"
var calendar = $find('Calendar1');

// gets all items defined in the calendar
var items = calendar.getItems();

if (items.length > 0) {
//gets a reference to the first item defined in the calendar
var item = items[0];

//deletes the item
calendar.deleteItem(item);
}
}

Recurrence series can also be removed from the Calendar by deleting the Recurrence master:

JavaScript [image] Copy Code

function deleteRecurrence() {
// gets a reference to the calendar, assuming the value of the Calendar's WebControl.ID property is set to "Calendar1"
var calendar = $find('Calendar1');

// gets all items defined in the calendar
var items = calendar.getItems();

if (items.length > 0) {
//gets a reference to the first item defined in the calendar
var item = items[0];

if (item.getRecurrence()) {
var masterItem = item.getRecurrence().getMaster();
// delete the recurrence series and the original item.
calendar.deleteItem(masterItem);
}
}
}


Recurrences on the Client

Recurrences on the Client

Schedule items can recur in time, following a specific recurrence pattern. For example an event could be set to occur each Monday, on the third day of each month, and so on. Associate a Recurrence object with an Item instance to specify the time period, pattern, and other properties for the repetition of that item in time.

Once a recurrent item is created in a Calendar instance, the calendar creates multiple occurrences of the item in the time period being visualized. Occasionally you will get references to these occurrences passed as arguments to the calendar events or returned by the calendar methods. Occurrences are instances of the same class as of the item that was set recurrent, however their recurrence state is set to Occurrence - visible through the item's getRecurrenceState method. If a user moves a recurrent event's occurrence in the calendar, thus changing its start or end time, or changes the occurrence text, an exception is created. RecurrenceExceptions contain data about these item instances whose recurrence state is set to Exception.

Creating recurrent patterns on the client

In order to programmatically create a recurrent pattern on the client, a Recurrence object must be created and then create a new or choose an already existing Item as its Master item. To create a new Recurrence instance, a special Object, containing information about the values of its properties must be passed as argument to the Recurrence constructor.

This is a complete table of the names of the recurrence's properties, which can be set programmatically from the client side:

Name | Value type | Description
pattern | RecurrencePattern | Specifies the interval at which recurring events occur.
dailyRecurrence | DailyRecurrence | Specifies the type of daily occurrence pattern, when pattern is set to Daily.
monthlyRecurrence | MonthlyRecurrence | Specifies the type of monthly occurrence pattern, when pattern is set to Monthly.
yearlyRecurrence | YearlyRecurrence | Specifies the type of yearly occurrence pattern, when pattern is set to Yearly.
days | Number | Specifies the number of days between two consecutive occurrences of the same event. Used when pattern is set to Daily.
weeks | Number | Specifies the number of weeks between two consecutive occurrences of the event. Used when pattern is set to Weekly.
daysOfWeek | DaysOfWeek | Specifies the days of the week when the event occurs. Used when pattern is set to Weekly.
dayOfMonth | Number | Specifies the day of the month when the event occurs. Used when pattern is set to Monthly or Yearly.
months | Number | Specifies the number of months between two consecutive occurrences of the same event. Used when pattern is set to Monthly.
occurrence | Occurrence | Specifies on which occurrence of the week within the month the event occurs. Used when pattern is set to Monthly or Yearly and the monthlyRecurrence or yearlyRecurrence properties are set to ByDayType or ByDayType.
day | DayOfWeekType | Specifies the day of the week when the event occurs. Used when pattern is set to Monthly or Yearly and the monthlyRecurrence or yearlyRecurrence properties are set to ByDayType or ByDayType.
monthOfYear | Number | Specifies the month of the year when the event occurs. Used when pattern is set to Yearly.
interval | Number | Specifies the number of hours between two consecutive occurrences of the same event. Used when pattern is set to ByTimeInterval.
recurrenceEnd | RecurrenceEnd | Specifies when to stop repeating the recurring event.
numOccurrences | Number | Specifies how many times a recurring event should occur. Used when recurrenceEnd is set to NumOccurrences.
startDate | DateTime | Specifies the start date of the recurrence series.
endDate | DateTime | Specifies the end date of the recurrence series. Used when recurrenceEnd is set to EndDate.

To programmatically create and visualize a recurrent event, a Recurrence object must be created and assigned to a newly created or already existing Item in a Calendar. For example:

Note

More information about programmatically creating or accessing items on the client side, see here.

JavaScript [image] Copy Code

function createRecurrentEvent() {
// creates the arguments object defining the recurrence series.
var recurrenceData = {
startDate: MindFusion.Common.DateTime.today(),
pattern: MindFusion.Scheduling.RecurrencePattern.Monthly,
monthlyRecurrence: MindFusion.Scheduling.MonthlyRecurrence.ByDayType,
occurrence: MindFusion.Scheduling.Occurrence.Second,
day: MindFusion.Scheduling.DayOfWeekType.Wednesday,
months: 2,
recurrenceEnd: MindFusion.Scheduling.RecurrenceEnd.EndDate,
endDate: MindFusion.Common.DateTime.fromDateParts(2012, 11, 21)
};

// creates a new Recurrence from the arguments object.
// This recurrent series will occur the second Wednesday of every 2 months effective 10/04/2011 until 12/21/2012.
var recurrence = new MindFusion.Scheduling.Recurrence(recurrenceData);

// creates the new item arguments data.
var itemData = {
subject: 'recurring event',
startTime: MindFusion.Common.DateTime.today().addHours(12),
endTime: MindFusion.Common.DateTime.today().addHours(14),
recurrence: recurrence
};

// creates the new recurring event and generates its visible occurrences in the Calendar.
var calendar = $find('Calendar1');
calendar.createItem(itemData);
}

To assign a new recurrence series to an already existing item, use the editItem method of the Calendar. For example:

JavaScript [image] Copy Code

// the Item object to assign the recurrence series to is passed as parameter to this sample function.
function assignRecurrenceSeries(item) {
// creates the arguments object defining the recurrence series.
var recurrenceData = {
startDate: MindFusion.Common.DateTime.today().addDays(1),
pattern: MindFusion.Scheduling.RecurrencePattern.Daily,
dailyRecurrence: MindFusion.Scheduling.DailyRecurrence.EveryWorkday,
recurrenceEnd: MindFusion.Scheduling.RecurrenceEnd.NumOccurrences,
numOccurrences: 25
};

// creates a new Recurrence from the arguments object.
// This recurrent series will occur every weekday effective 10/05/2011 until 11/08/2011.
var recurrence = new MindFusion.Scheduling.Recurrence(recurrenceData);

// wraps the recurrence as item changes in an object, passed as parameter to the editItem method.
var itemData = {
recurrence: recurrence
};

// attaches the new recurring series to the existing and generates its visible occurrences in the Calendar.
var calendar = $find('Calendar1');
calendar.editItem(item, itemData);
}

Editing recurrences

In order to edit a recurrence pattern, you must first update the original Recurrence object by calling editRecurrence and then update the master Item of the recurrence series by calling editItem. The following example shows how to change the RecurrenceEnd of an existing recurrence:

JavaScript [image] Copy Code

function editRecurrenceSeries(itemWithRecurrence) {
var calendar = $find('Calendar1');

// get a reference to the original recurrence object.
var originalRecurrence = itemWithRecurrence.getRecurrence();

// get a reference to the recurrence master item.
var masterItem = originalRecurrence.getMaster();

// edit the original recurrence/
var editedRecurrence = calendar.editRecurrence(originalRecurrence, {recurrenceEnd: MindFusion.Scheduling.RecurrenceEnd.Never});

// finally edit the master item by providing the edited recurrence as argument.
calendar.editItem(masterItem, {recurrence: editedRecurrence});
}

Deleting recurrences

To remove a recurrent series from an Item, just call editItem and set recurrence to null in the args parameter. Like this:

Note

After removing a Recurrence from an Item, the original item used for creating the recurrent series will be restored. To delete the recurrence series and the original item use deleteItem instead (see Manipulating Items on the Client).

JavaScript [image] Copy Code

// the occurrence parameter is an Item instance, representing an occurrence in the recurrence series to be removed.
function removeRecurrence(occurrence) {
// gets a reference to the calendar object.
var calendar = $find('Calendar1');

// edits the item by removing the recurrence.
calendar.editItem(occurrence, {recurrence: null});
}

Accessing occurrences. Exceptions

Items, which are part of a recurrence series are easily distinguishable from regular events by checking the value of their getRecurrenceState method. Occurrences defined in the time range, currently presented by the Calendar, can be obtained by calling getItems and filter the result by the master item's id and the occurrence's occurrenceIndex. Exceptions can be retrieved through the getExceptions function.


Resources

Resources

Resources on the server side

MindFusion.Scheduling for ASP.NET lets you associate resources with scheduled events via the Resources, Contacts, Location and Task properties of Item objects. These properties contain objects from the Resource, Contact, Location and Task classes respectively. If you need to assign a resource to schedule items, you must also add the resource to the appropriate collection in the Schedule class, namely Resources, Contacts, Locations or Tasks.

Timetable, List and Resource views let you display distinct rows or columns for selected resources and to group items by their associated resources. To enable that, add the resources of interest to the appropriate resource collection of the Calendar object (that is, Resources, Contacts, Locations and Tasks respectively) and set the Calendar.GroupType property to the appropriate value.

The class Resource is the base class of Contact, Location and Task. It defines an Id property, which must be unique among all resources in the schedule, and a pair of SaveTo and LoadFrom methods, which implement serialization.

You can define custom resources by deriving from Resource or from any of the Resource-derived classes. Custom resources are added to the schedule by adding them to the Calendar.Schedule.Resources collection. In order to enable serialization of custom resources, you have to provide a parameterless constructor and override the SaveTo / LoadFrom methods in the custom resource class. In addition you must register that class by calling Schedule.RegisterResourceClass before any deserialization code takes place.

Resources on the client side

Resources are also available on the client side, implemented as JavaScript objects. All resources defined for the Calendar can be obtained by calling the getResourceCollections or each separate collection of Resources, Contacts, Locations and Tasks is available through getResources, getContacts, getLocations and getTasks methods respectively.

All calendar views provide means to filter out items, based on resources they contain. Timetable, List and Resource views can group items in separate columns / rows. To see if there is any filtering or grouping enabled on the client, check the value of the getGroupType method and to obtain a collection of the currently filtered / grouped resources, call getFilteredResources or getGroupedResources. Different resources, set up for filter or grouping are available also by type through getCalendarResources, getCalendarContacts, getCalendarLocations and getCalendarTasks.


Custom Items and Resources

Custom Items and Resources

MindFusion.Scheduling for ASP.NET gives you the possibility of extending the available Item and Resource classes to include your own business logic in a Schedule.

Custom Items

In order to integrate your custom class into the calendar API, you must do the following:

1. Derive from either Item or Appointment and provide a parameterless constructor to your custom class and extend it to your liking.

For example:

C# [image] Copy Code

using MindFusion.Scheduling;

public class MyCustomItem: Appointment
{
public MyCustomItem()
{
}

public int RecordedValue
{
get { return recordedValue; }
set { recordedValue = value; }
}

private int recordedValue;
}

Visual Basic [image] Copy Code

Imports MindFusion.Scheduling

Public Class MyCustomItem
Inherits Appointment

Public Sub New()
End Sub

Public Property RecordedValue() As Integer
Get
Return recValue
End Get
Set(ByVal value As Integer)
recValue = value
End Set
End Property

Private recValue As Integer
End Class

2. Enable ViewState on your custom item.

In order to save your custom properties in the ViewState of your custom item you should override the SaveViewState and LoadViewState methods of the Item class.

C# [image] Copy Code

public override object SaveViewState()
{
ViewState["_recordedValue"] = RecordedValue;
return base.SaveViewState();
}

public override void LoadViewState(object state)
{
base.LoadViewState(state);
if (ViewState["_recordedValue"] != null)
{
RecordedValue = (int)ViewState["_recordedValue"];
}
}

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState() As Object
ViewState("_recordedValue") = RecordedValue
Return MyBase.SaveViewState()
End Function

Public Overrides Sub LoadViewState(state As Object)
MyBase.LoadViewState(state)
If ViewState("_recordedValue") IsNot Nothing Then
RecordedValue = CInt(ViewState("_recordedValue"))
End If
End Sub

3. Serialization

Serialization of custom items requires additional efforts. Attempts to save a schedule containing items of type MyCustomItem will result in an InvalidOperationException exception. In order to support serialization, we have to register MyCustomItem with the schedule. For this purpose, add the following line of code somewhere in the page's Load event handler:

C# [image] Copy Code

Schedule.RegisterItemClass(typeof(MyCustomItem), "myitem", 1);

Visual Basic [image] Copy Code

Schedule.RegisterItemClass(GetType(MyCustomItem), "myitem", 1)

Now the exception won't be thrown, but we still need to override the SaveTo and LoadFrom methods of the Appointment class in order to serialize the custom property RecordedValue. The code below illustrates how this is done for the SaveTo and LoadFrom overloads that serialize item's contents in binary streams.

C# [image] Copy Code

public override void SaveTo(System.IO.BinaryWriter writer, BinarySerializationContext context)
{
base.SaveTo(writer, context);
context.WriteInt(writer, recordedValue);
}

public override void LoadFrom(System.IO.BinaryReader reader, BinarySerializationContext context)
{
base.LoadFrom(reader, context);
recordedValue = context.ReadInt(reader);
}

Visual Basic [image] Copy Code

Public Overloads Overrides Sub SaveTo(ByVal writer As System.IO.BinaryWriter, ByVal context As BinarySerializationContext)
MyBase.SaveTo(writer, context)
context.WriteInt(writer, recValue)
End Sub

Public Overloads Overrides Sub LoadFrom(ByVal reader As System.IO.BinaryReader, ByVal context As SerializationContext)
MyBase.LoadFrom(reader, context)
recValue = context.ReadInt(reader)
End Sub

A code that implements serialization of items in XML format would look similar to the above, but it will override the other SaveTo and LoadFrom method overloads.

4. Recurrences

Recurrence of items from a custom class is not handled wholly automatically. Let's take a closer look at how recurrence works in MindFusion.Scheduling for ASP.NET. When a recurrence pattern is associated with an existing item, the item is said to become the master of the recurrence. Every time the occurrences of a master item must be displayed in a given time range, they are generated by instantiating new objects of the same type as that of the master. This is necessary in order to support infinite recurrences, where the generation of all recurrence instances is not possible. When the occurrences are generated, their properties are copied from the master item. This is done automatically for the built-in item properties, but not for those added by a derived item class. In order to copy the custom properties from the master item to a particular occurrence, you need to override the CopyOccurrence method. The following code sample shows how to do this.

C# [image] Copy Code

protected override void CopyOccurrence(Item master)
{
base.CopyOccurrence(master);
recordedValue = (master as MyCustomItem).RecordedValue;
}

Visual Basic [image] Copy Code

Protected Overloads Overrides Sub CopyOccurrence(ByVal master As Item)
MyBase.CopyOccurrence(master)
recValue = CType(master, MyCustomItem).RecordedValue
End Sub

In addition, it is recommended to mark an item from a recurrent series as an exception when the value of a custom property changes. Otherwise, the change will be lost the next time the instance is generated.

C# [image] Copy Code

// ...
public int RecordedValue
{
get { return recordedValue; }
set
{
recordedValue = value;

if (Recurrence != null)
Recurrence.MarkException(this, false);
}
}
// ...

Visual Basic [image] Copy Code

' ...
Public Property RecordedValue() As Integer
Get
Return recordedValue
End Get
Set(ByVal value As Integer)
recValue = value

If Not Recurrence Is Nothing Then
Recurrence.MarkException(Me, False)
End If
End Set
End Property
' ...

5. Accessing your custom properties from the client

In order to transfer the custom properties of your items to the client side, you must supply a JavaScriptConverter that will handle the serialization to a JSON string, that will be used by the Calendar to recreate the items, created on the server. The easiest way to do that is to derive from ItemConverter, override the SupportedTypes property and include the serialization logic in the Serialize override. For example:

C# [image] Copy Code

using MindFusion.Scheduling.WebForms;

class MyCustomItemConverter : ItemConverter
{
public MyCustomItemConverter(Calendar calendar) : base(calendar)
{
}

public override List<Type> SupportedTypes
{
get
{
return new List<Type>() { typeof(MyCustomItem) };
}
}

public override IDictionary<string, object> Serialize(object obj, System.Web.Script.Serialization.JavaScriptSerializer serializer)
{
MyCustomItem item = obj as MyCustomItem;
if (item != null)
{
IDictionary<string, object> json = base.Serialize(obj, serializer);
if (json != null)
{
json.Add("recordedValue", item.RecordedValue);
return json;
}
}
return null;
}
}

Visual Basic [image] Copy Code

Imports MindFusion.Scheduling.WebForms

Class MyCustomItemConverter
Inherits ItemConverter

Public Sub New(calendar As Calendar)
MyBase.New(calendar)
End Sub

Public Overrides ReadOnly Property SupportedTypes() As List(Of Type)
Get
Return New List(Of Type)(New Type() {GetType(MyCustomItem)})
End Get
End Property

Public Overrides Function Serialize(obj As Object, serializer As System.Web.Script.Serialization.JavaScriptSerializer) As IDictionary(Of String, Object)
Dim item As MyCustomItem = TryCast(obj, MyCustomItem)
If item IsNot Nothing Then
Dim json As IDictionary(Of String, Object) = MyBase.Serialize(obj, serializer)
If json IsNot Nothing Then
json.Add("recordedValue", item.RecordedValue)
Return json
End If
End If
Return Nothing
End Function
End Class

After you have created your custom JavaScriptConverter, you must register it for serialization with the Schedule, by handling the ItemSerialization event of the Calendar class:

C# [image] Copy Code

// ...

Calendar1.ItemSerialization += new EventHandler<SerializationEventArgs>(Calendar1_ItemSerialization);

// ...

protected void Calendar1_ItemSerialization(object sender, SerializationEventArgs e)
{
e.Serializer.RegisterConverters(new JavaScriptConverter[] { new MyCustomItemConverter(Calendar1) });
}

Visual Basic [image] Copy Code

' ...

AddHandler Calendar1.ItemSerialization, AddressOf Calendar1_ItemSerialization

' ...

Protected Sub Calendar1_ItemSerialization(sender As Object, e As SerializationEventArgs)
e.Serializer.RegisterConverters(New JavaScriptConverter() {New MyCustomItemConverter(Calendar1)})
End Sub

Now, all you need to do is crate a new instance of your custom item and add it to the Schedule.Items collection.

C# [image] Copy Code

MyCustomItem myItem = new MyCustomItem();
myItem.StartTime = DateTime.Today;
myItem.EndTime = myItem.StartTime.AddHours(10);
myItem.HeaderText = "My Custom Item!";
myItem.RecordedValue = 42;

Calendar1.Schedule.Items.Add(myItem);

Visual Basic [image] Copy Code

Dim myItem As New MyCustomItem()
myItem.StartTime = DateTime.Today
myItem.EndTime = myItem.StartTime.AddHours(10)
myItem.HeaderText = "My Custom Item!"
myItem.RecordedValue = 42

Calendar1.Schedule.Items.Add(myItem)

Then you can read the value stored in RecordedValue:

JavaScript [image] Copy Code

function showRecordedValue() {
var calendar = $find('Calendar1');

var myCustomItem = calendar.getItems()[0];

alert(['This is my custom value: ', myCustomItem.recordedValue]);
}

Resources

The same pattern can be followed in order to use custom resource classes with MindFusion.Scheduling for ASP.NET.

The following is a full example on how to create a custom resource class:

ASPX [image] Copy Code

<%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="CustomResourceSample._Default" %>
<%@ Register Assembly="MindFusion.Scheduling.WebForms" Namespace="MindFusion.Scheduling.WebForms"
TagPrefix="MindFusion" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
<title>Custom Resources</title>
</head>
<body>
<form id="form1" runat="server">
<asp:ScriptManager ID="ScriptManager1" runat="server">
</asp:ScriptManager>
<div>
<MindFusion:Calendar ID="Calendar1" runat="server" Height="600px" Width="800px"
OnResourceSerialization="Calendar1_ResourceSerialization">
</MindFusion:Calendar>
</div>
</form>
</body>

C# [image] Copy Code

using System;
using System.Collections.Generic;
using System.Web.Script.Serialization;
using MindFusion.Scheduling;
using MindFusion.Scheduling.WebForms;

namespace CustomResourceSample
{
public partial class _Default : System.Web.UI.Page
{
protected void Page_Load(object sender, EventArgs e)
{
if (Schedule.IsClassRegistered("customres"))
Schedule.UnregisterClass("customres");
Schedule.RegisterResourceClass(typeof(MyCustomResource), "customres", 1);

if (!IsPostBack)
{
MyCustomResource myResource = new MyCustomResource();
myResource.Name = "myresource";
myResource.ResourceDescription = "Short description of my resource.";

Calendar1.Schedule.Resources.Add(myResource);

Appointment myResourceHolder = new Appointment();
myResourceHolder.StartTime = DateTime.Now;
myResourceHolder.EndTime = myResourceHolder.StartTime.AddHours(2);
myResourceHolder.HeaderText = "Item with custom resource";
myResourceHolder.Resources.Add(myResource);

Calendar1.Schedule.Items.Add(myResourceHolder);
}
}

protected void Calendar1_ResourceSerialization(object sender, SerializationEventArgs e)
{
e.Serializer.RegisterConverters(new JavaScriptConverter[] { new MyCustomResourceConverter(Calendar1) });
}
}

class MyCustomResource : Resource
{
public MyCustomResource()
: base()
{ }

public string ResourceDescription { get; set; }

public override object SaveViewState()
{
if (!String.IsNullOrEmpty(ResourceDescription))
ViewState["_resourceDescription"] = ResourceDescription;
return base.SaveViewState();
}

public override void LoadViewState(object state)
{
base.LoadViewState(state);
if (ViewState["_resourceDescription"] != null)
ResourceDescription = ViewState["_resourceDescription"].ToString();
}

public override void SaveTo(System.Xml.XmlElement element, XmlSerializationContext context)
{
base.SaveTo(element, context);
context.WriteString(ResourceDescription, "ResourceDescription", element);
}

public override void LoadFrom(System.Xml.XmlElement element, XmlSerializationContext context)
{
base.LoadFrom(element, context);
ResourceDescription = context.ReadString("ResourceDescription", element);
}
}

class MyCustomResourceConverter : ResourceConverter
{
public MyCustomResourceConverter(Calendar calendar)
: base(calendar)
{ }

public override IEnumerable<Type> SupportedTypes
{
get
{
return new List<Type>() { typeof(MyCustomResource) };
}
}

public override IDictionary<string, object> Serialize(object obj, JavaScriptSerializer serializer)
{
MyCustomResource resource = obj as MyCustomResource;
if (resource != null)
{
IDictionary<string, object> json = base.Serialize(obj, serializer);
if (json != null)
{
if (!String.IsNullOrEmpty(resource.ResourceDescription))
json.Add("resourceDescription", resource.ResourceDescription);
return json;
}
}
return null;
}
}
}

Visual Basic [image] Copy Code

Imports System.Collections.Generic
Imports System.Web.Script.Serialization
Imports MindFusion.Scheduling
Imports MindFusion.Scheduling.WebForms

Public Partial Class _Default
Inherits System.Web.UI.Page

Protected Sub Page_Load(sender As Object, e As EventArgs)
If Schedule.IsClassRegistered("customres") Then
Schedule.UnregisterClass("customres")
End If
Schedule.RegisterResourceClass(GetType(MyCustomResource), "customres", 1)

If Not IsPostBack Then
Dim myResource As New MyCustomResource()
myResource.Name = "myresource"
myResource.ResourceDescription = "Short description of my resource."

Calendar1.Schedule.Resources.Add(myResource)

Dim myResourceHolder As New Appointment()
myResourceHolder.StartTime = DateTime.Now
myResourceHolder.EndTime = myResourceHolder.StartTime.AddHours(2)
myResourceHolder.HeaderText = "Item with custom resource"
myResourceHolder.Resources.Add(myResource)

Calendar1.Schedule.Items.Add(myResourceHolder)
End If
End Sub

Protected Sub Calendar1_ResourceSerialization(sender As Object, e As SerializationEventArgs)
e.Serializer.RegisterConverters(New JavaScriptConverter() {New MyCustomResourceConverter(Calendar1)})
End Sub
End Class

Class MyCustomResource
Inherits Resource

Public Sub New()
MyBase.New()
End Sub

Public Property ResourceDescription() As String
Get
Return description
End Get
Set(ByVal value As String)
description = Value
End Set
End Property
Private description As String

Public Overrides Function SaveViewState() As Object
If Not [String].IsNullOrEmpty(ResourceDescription) Then
ViewState("_resourceDescription") = ResourceDescription
End If
Return MyBase.SaveViewState()
End Function

Public Overrides Sub LoadViewState(state As Object)
MyBase.LoadViewState(state)

If ViewState("_resourceDescription") IsNot Nothing Then
ResourceDescription = ViewState("_resourceDescription").ToString()
End If
End Sub

Public Overrides Sub SaveTo(element As System.Xml.XmlElement, context As XmlSerializationContext)
MyBase.SaveTo(element, context)
context.WriteString(ResourceDescription, "ResourceDescription", element)
End Sub

Public Overrides Sub LoadFrom(element As System.Xml.XmlElement, context As XmlSerializationContext)
MyBase.LoadFrom(element, context)
ResourceDescription = context.ReadString("ResourceDescription", element)
End Sub
End Class

Class MyCustomResourceConverter
Inherits ResourceConverter
Public Sub New(calendar As Calendar)
MyBase.New(calendar)
End Sub

Public Overrides ReadOnly Property SupportedTypes() As IEnumerable(Of Type)
Get
Return New List(Of Type)(New Type() {GetType(MyCustomResource)})
End Get
End Property

Public Overrides Function Serialize(obj As Object, serializer As JavaScriptSerializer) As IDictionary(Of String, Object)
Dim resource As MyCustomResource = TryCast(obj, MyCustomResource)
If resource IsNot Nothing Then
Dim json As IDictionary(Of String, Object) = MyBase.Serialize(obj, serializer)
If json IsNot Nothing Then
If Not [String].IsNullOrEmpty(resource.ResourceDescription) Then
json.Add("resourceDescription", resource.ResourceDescription)
End If
Return json
End If
End If
Return Nothing
End Function
End Class


Serializing the Schedule

Serializing the Schedule

The SaveTo and LoadFrom methods of the Schedule class let you save and load complete schedules to/from binary streams and files or XML documents. The SaveToString and LoadFromString methods let you encode or decode a schedule into/from an ASCII string, which could be used to store the whole schedule in a database table field or as a part of a larger file.

The serialization methods of the Schedule work by invoking the SaveTo and LoadFrom methods of the Item and Resource classes or the classes derived from them. If you define your own Item or Resource-derived classes, you must override the SaveTo and LoadFrom methods and register the classes for serialization by calling the RegisterItemClass and RegisterResourceClass methods of the Schedule.


Calendar and Timetable Views

Calendar and Timetable Views

The Calendar class implements several types of views that can be enabled by setting the calendar's CurrentView property. These views provide different outlooks over the schedule data and allow for different user interaction behavior. By changing the views from more general ones to more specialized ones, your application can implement drilling down through the schedule data. At this time MindFusion.Scheduling for ASP.NET supports the following views:

  • The Month Range View displays a range of months or years.
  • The Single Month View displays a single month and lets the user scroll to the previous or next month.
  • The Week Range View displays a grid in which the days of a week occupy a single row.
  • The List View displays a list of cells where each cell represents an arbitrary time interval, such as second, minute, hour, and so on.
  • The Timetable View displays the allotment of resources to distinct hours of a day; the columns of this view can be grouped by location, task, contact or resource.
  • The Resource View displays the distribution of items over a period of time for particular contacts, locations, tasks or resources.


Month Range View

Month Range View

The Month Range view displays an arbitrary long sequence of months arranged in rows and columns. Each month represents a grid of day cells, each of which displays the day number and the schedule events set to occur on its respective date. The months in the view can be scrolled back or forth in time by using the navigation buttons in the view header.

In order to enable the Month Range view, set the CurrentView property of the Calendar class to MonthRange. Use the MonthRangeSettings and the MonthSettings properties of the Calendar class to adjust the appearance of the view. The ItemSettings property affects how schedule items will be displayed.

Use the MonthSettings.DaySettings.Style, property to specify common appearance style for all cells in the view. Use the MainHeaderStyle property of the MonthRangeSettings class to specify the appearance of the view's main header, and the MainHeaderStyle property of the MonthSettings class to specify the style of the month's individual headers. Use MonthRangeSettings.Style to set the style of the entire view.


Single Month View

Single Month View

The Single Month view displays one month at a time and lets the user scroll to the previous or next month or the previous or next year by using the navigation buttons optionally displayed in the view header. The month represents a grid of day cells, which display the day number and the schedule events set to occur on the specific date.

In order to enable the Single Month view, set the CurrentView property of the Calendar class to SingleMonth. Use the MonthSettings property of the Calendar class to set the appearance of the view. The ItemSettings property affects how schedule items will be displayed.

The Style property of the associated DaySettings object specifies a common appearance style to be used for all cells in the view and the HeaderStyle property specifies the styles for the cell's headers. Specific styles can be applied to day cells, representing days from the previous/next month through the PaddingDaysStyle and PaddingDaysHeaderStyle properties. Set styles for the main, day names and week numbers headers through MainHeaderStyle, DayNamesHeaderStyle and WeekNumbersHeaderStyle properties. Use MonthSettings.Style to set the style of the entire view.


Week Range View

Week Range View

The Week Range view displays a range of weeks. Each week occupies a whole row whose cells represent days. The day cells display the day name or number according to the GeneralFormat, FirstDayOfMonthFormat and FirstDayOfYearFormat properties of the associated DaySettings, and the schedule items set to occur on the corresponding date.

In order to enable the Week Range view, set the CurrentView property of the Calendar class to WeekRange. Use the WeekRangeSettings property of the Calendar class to adjust the appearance of the view. The ItemSettings property lets you specify how schedule items should be displayed.

Use the DaySettings.Style property to specify individual styles for cells and DaySettings.HeaderStyle for cell's headers. Style the main and the day names headers through MainHeaderStyle and DayNamesHeaderStyle properties. Use WeekRangeSettings.Style to set the style of the entire view.

The Week Range view supports two different layouts, specified in the WeekRangeSettings.ViewStyle property of the Calendar class. WeekPerRow is the default view, where each week occupies a whole row whose cells represent days. SingleWeek view provides a more detailed look, where the days of the week are divided into two columns and four rows.


List View

List View

Set the CurrentView property of the Calendar class to List to select the list view. This view displays several rows or columns where each row or column represents a single second, minute, hour, day, week, month or year. The day cells display the represented time in a user-specified format to the GeneralFormat, FirstDayOfMonthFormat and FirstDayOfYearFormat properties of the associated CellSettings, and the schedule items set to occur on the corresponding date.

The List view supports two different layouts, specified in the ListViewSettings.Orientation property of the Calendar class. The Horizontal layout displays the day cells as columns, and the Vertical layout - as rows.

Use the ListViewSettings property of the of the Calendar class to set the appearance of the list view. The ItemSettings property lets you specify how schedule items should be displayed.

The Style property of the associated CellSettings specifies a common appearance style to be used for all cells in the view and the HeaderStyle property - for the cell's headers. Style the main and the group headers through MainHeaderStyle and GroupHeaderStyle properties. Use ListViewSettings.Style to set the style of the entire view.


Timetable View

Timetable View

Set the CurrentView property of the Calendar class to Timetable to select the timetable view. This view displays the allotment of resources to distinct hours of a day; the columns in this view represent dates, tasks, locations, contacts or resources. The columns can be grouped by location, task, contact or resource. Each row represents an hour or a custom time interval. The cells in the view display information about the schedule items allocated to the task, contact, location or resource for the specific time interval.

The Timetable view supports two different layouts, specified in the TimetableSettings.Orientation property of the Calendar class. The Vertical layout displays dates and resources as columns, and the Horizontal layout - as rows.

Use the TimetableSettings property of the Calendar class to set the appearance of the timetable view. The ItemSettings property lets you specify how schedule items should be displayed.

The CellStyle property specifies a common appearance style for all cells in the view, while the WorkTimeCellStyle property defines the style of cells in the work time interval. Style the main and the group headers through MainHeaderStyle and GroupHeaderStyle properties. Use TimetableSettings.Style to set the style of the entire view.


Resource View

Resource View

Set the CurrentView property of the Calendar class to ResourceView to select the resource view. This view displays the distribution of items over a period of time for a particular contacts, locations, tasks or resources. The view displays a single row for each individual contact, location, task or resource and up to three timelines. In order to view associated items in this view, the GroupType property of the Calendar must be set to GroupByContacts, GroupByLocations, GroupByTasks or GroupByResources.

Use the ResourceViewSettings property of the Calendar class to set the appearance of the resource view. The ItemSettings property lets you specify how schedule items should be displayed.

The GridStyle property specifies a common appearance style for all cells in the view. Style the main and the group headers through MainHeaderStyle and GroupHeaderStyle properties. You can specify individual styles for the timelines headers by using the HeaderStyle property of the corresponding TimelineSettings class. Use ResourceViewSettings.Style to set the style of the entire view.


Grouping

Grouping

Views that can be grouped are Timetable, List and Resource. The Resource view can only operate when grouping is enabled. The other views do not support grouping.

In order to enable grouping the following steps should be done:

  • The resources should be created and added to the appropriate collection in the schedule: Calendar.Schedule.Contacts for contacts, Calendar.Schedule.Locations for locations, Calendar.Schedule.Tasks for tasks and Calendar.Schedule.Resources for general and custom resources.
  • The selected resources by which to group should be added to the appropriate collection in the control: Calendar.Contacts for contacts, and so on. The selected resources are a subset of all resources defined in the schedule.
  • The Calendar.GroupType should be set to the appropriate value, for example GroupType.GroupByContacts to group by contacts.

The following code illustrates how to enable grouping by contacts:

C# [image] Copy Code

// Define two contacts to group by
Contact c1 = new Contact();
c1.FirstName = "John";

Contact c2 = new Contact();
c2.FirstName = "Jack";

// Add the contacts to the schedule
calendar.Schedule.Contacts.Add(c1);
calendar.Schedule.Contacts.Add(c2);

// Select these contacts for grouping by adding them to
// the appropriate Calendar collection
calendar.Contacts.Add(c1);
calendar.Contacts.Add(c2);

// Enable grouping by contacts
calendar.GroupType = GroupType.GroupByContacts;

Visual Basic [image] Copy Code

' Define two contacts to group by
Dim c1 As New Contact()
c1.FirstName = "John"

Dim c2 As New Contact()
c2.FirstName = "Jack"

' Add the contacts to the schedule
calendar.Schedule.Contacts.Add(c1)
calendar.Schedule.Contacts.Add(c2)

' Select these contacts for grouping by adding them to
' the appropriate Calendar collection
calendar.Contacts.Add(c1)
calendar.Contacts.Add(c2)

' Enable grouping by contacts
calendar.GroupType = GroupType.GroupByContacts

The text displayed in the header of the corresponding resource depends on the type of the resource and is as follows:

  • A string formatted according to Calendar.ContactNameFormat for contacts.
  • The Resource.Name for general and custom resources, and locations.
  • The Task.Subject for tasks.

Grouping and appearance

In Timetable view each column that represents a day is additionally subdivided to the number of grouped resources. For example if there are 3 resources selected to group by, each day column in the view is subdivided to 3 columns. The sub-columns represent individual resources and contain only the items specific for them. The sub-columns have headers containing the resource text. The header of the day column is displayed above the headers of its underlying resource columns.

In Resource view a single row is dedicated to each individual resource. The row has a header, displaying the text for that resource and contains all items, associated with that resource for the specified time interval. The row is additionally subdivided to lanes.

In List view the resources are represented by additional rows (in Horizontal layout) or columns (in Vertical layout). The row/column has a header, displaying the text for that resource and contains all items, associated with that resource for the specified time interval.

Note

Additional examples on filtering and grouping can be found in Tutorial 2: Filtering and grouping.


DOM View Elements

DOM View Elements

The DOM elements structure of different calendar views is exposed through the Object returned from the Calendar.getViewDom method. The following tables contain information about the structure of this object in the different views.

Month Range View

Element | Description
element | The root div element of the view.
header | The root div of the header of the view.
monthRows | An array containing every month's root div element.
scroller | The scrollable div element of the view.

Single Month View

Element | Description
bgCells | An array containing background cells of the view.
element | The root div element of the view.
header | The root div of the header of the view.
itemCellHeaders | An array containing all cell headers of the view.
itemCells | An array containing item cells.
itemTables | An array containing the items tables.
rows | An array containing the rows in the view.
scroller | The scrollable div element of the view.
titles | An array with cells header titles.
weekNumHeaderLeft | The week numbers header.

Week Range View

Element | Description
bgCells | An array containing background cells of the view.
element | The root div element of the view.
header | The root div of the header of the view.
itemCellHeaders | An array containing all cell headers of the view.
itemCells | An array containing item cells.
itemTables | An array containing the items tables.
rows | An array containing the rows in the view.
scroller | The scrollable div element of the view.
titles | An array with cells header titles.

List View

Element | Description
bgCells | An array containing background cells of the view.
element | The root div element of the view.
header | The root div of the header of the view.
itemCellsHeaders | An array containing all cell headers of the view.
itemCells | An array containing item cells.
itemTables | An array containing the items tables.
outerBgCells | An array containing outer the background cells of the view
rows | An array containing the rows in the view.
scroller | The scrollable div element of the view.
titleTexts | An array with cells header title texts.
titles | An array with cells header titles.
weekNumHeaderLeft | The week numbers header.

Horizontal Timetable View

Element | Description
content | The timetable portion of the view.
element | The root div element of the view.
header | The root div of the header of the view.
headerCueCells | An array containg table cells with cue items in the all-day header.
headerEmtpyRow | A table cell representing the empty collumn in the all-day items header.
headerItemsCells | An array containing item cells in the all-day items header.
headerItemsTable | An array containing the all-day items tables.
headerRows | An array with table rows containing header titles in the all-day items header.
headerTable | The main all-day items header table.
nextBtn | The 'next' navigation button.
prevBtn | The 'previous' navigation button.
scheduleTable | The schedule table element of the view.
scroller | The scrollable div element of the view.
switchBtn | The 'expander' button in the all-day items header.
timeline | The timeline of the view.

Vertical Timetable View

Element | Description
content | The timetable portion of the view.
element | The root div element of the view.
groupRow | The group row element.
header | The root div of the header of the view.
headerEmptyRow | A table row representing the empty row in the all-day items header.
headerItemRow | A table row containing items in the all-day items header.
headerItemsCell | An array containing item cells in the all-day items header.
headerRow | A table row containing header titles in the all-day items header.
headerTable | The main all-day items header table.
nextBtn | The 'next' navigation button.
prevBtn | The 'previous' navigation button.
scheduleTable | The schedule table element of the view.
scroller | The scrollable div element of the view.
switchBtn | The 'expander' button in the all-day items header.

Resource View

Element | Description
bgCells | An array containing background cells of the view.
bgTables | An array containing the tables with background cells.
element | The root div element of the view.
groupCells | The group header cells.
groupHeader | The group header table of the view.
header | The root div of the header of the view.
itemCellHeaders | An array containing all cell headers of the view.
itemCells | An array containing item cells.
itemTables | An array containing the items tables.
laneTables | An array containing the lane tables.
rows | An array containing the rows in the view.
scroller | The scrollable div element of the view.
timelines | An array containing the view timelines.


Customizing Appearance

Customizing Appearance


MindFusion.Scheduling Themes

MindFusion.Scheduling Themes

The following table illustrates how various views would look like when particular appearance Theme is applied to them.

 | Standard | Windows2003 | Lila | Silver | Vista
List View |  |  |  |  |
Week Range |  |  |  |  |
Month Range |  |  |  |  |
Single Month |  |  |  |  |
Timetable |  |  |  |  |
Resource |  |  |  |  |


Customizing the Appearance of Views

Customizing the Appearance of Views

ViewSettings.Style properties

The Style property of the corresponding Settings class is responsible for general styling of the Calendar's view. You can use Borders property to set the outer border of the Calendar and the Brush property to define the color with which the Calendar's content will be painted.

Different headers within the Calendar can be styled though their corresponding Style properties. For example, MainHeaderStyle property is responsible for styling the view's main header, GroupHeaderStyle - for the group header and so on.

For styling the date/time cells in the month and week views use the DaySettings.Style property of the MonthSettings and WeekRangeSettings members respectively. DaySettings.Style is responsible for the cells customization in the MonthRange view too. You can also apply additional customization to the padding day cells in a month view by using the PaddingDaysStyle property. Use the DaySettings.HeaderStyle property for styling the cell's headers.

The Timetable view offers customization of the time cells through the CellStyle property and additional customization of work-time cells through the WorkTimeCellStyle property. Styling of the timeline header is also available by using the TimelineStyle property.

Styling of the List view cells is available through its' CellSettings.Style and CellSettings.HeaderStyle properties.

Timetable, List and month views also expose the ButtonStyle property which affects the customization of the navigation buttons in the main header of the view.

Example

The following example shows how to style the Single Month view by setting different borders and backgrounds to the Style, HeaderStyle, DaySettings.Style, DaySettings.HeaderStyle and ButtonStyle properties:

C# [image] Copy Code

CssBorderStyle border = new CssBorderStyle()
{
BottomColor = Color.LightGray,
BottomStyle = BorderStyle.Solid,
BottomWidth = new Unit(1.0, UnitType.Pixel)
};
CssBackground background = new CssBackground()
{
Color = System.Drawing.ColorTranslator.FromHtml("#7E7C94")
};
CssBorderStyle headerBorder = new CssBorderStyle()
{
AllStyle = BorderStyle.None
};
CssBackground headerBackground = new CssBackground()
{
Image = "none",
Color = System.Drawing.ColorTranslator.FromHtml("#413657")
};
CssBorderStyle cellHeaderBorder = new CssBorderStyle()
{
TopStyle = BorderStyle.Solid,
TopColor = Color.SlateGray,
TopWidth = new Unit(1.0, UnitType.Pixel)
};
CssBackground cellHeaderBackground = new CssBackground()
{
Image = "none",
Color = System.Drawing.ColorTranslator.FromHtml("#5E5A78")
};

// Get references to the calendars' settings objects.
MonthSettings mSettings = Calendar1.MonthSettings;

// General style
Style style = mSettings.Style;
style.Borders.CopyFrom(headerBorder);
style.Brush.SetProperties(headerBackground.GetProperties());

//MainHeaderStyle
HeaderStyle hstyle = mSettings.MainHeaderStyle;
hstyle.Borders.CopyFrom(headerBorder);
hstyle.Brush.SetProperties(headerBackground.GetProperties());

// Cells style
style = mSettings.DaySettings.Style;
style.Borders.CopyFrom(border);
style.Brush.SetProperties(background.GetProperties());

// Cells headers
hstyle = mSettings.DaySettings.HeaderStyle;
hstyle.Borders.CopyFrom(cellHeaderBorder);
hstyle.Brush.SetProperties(cellHeaderBackground.GetProperties());
hstyle.TextColor = Color.White;

// Buttons style
ButtonsStyle bStyle = mSettings.ButtonStyle;
bStyle.Brush.Image = "none";
bStyle.Brush.Color = System.Drawing.ColorTranslator.FromHtml("#4C4662");
mSettings.ButtonStyle.Brush.SetProperties(bStyle.Brush.GetProperties());

Visual Basic [image] Copy Code

Dim border As New CssBorderStyle() With { _
.BottomColor = Color.LightGray, _
.BottomStyle = BorderStyle.Solid, _
.BottomWidth = New Unit(1.0, UnitType.Pixel) _
}
Dim background As New CssBackground() With { _
.Color = System.Drawing.ColorTranslator.FromHtml("#7E7C94") _
}
Dim headerBorder As New CssBorderStyle() With { _
.AllStyle = BorderStyle.None _
}
Dim headerBackground As New CssBackground() With { _
.Image = "none", _
.Color = System.Drawing.ColorTranslator.FromHtml("#413657") _
}
Dim cellHeaderBorder As New CssBorderStyle() With { _
.TopStyle = BorderStyle.Solid, _
.TopColor = Color.SlateGray, _
.TopWidth = New Unit(1.0, UnitType.Pixel) _
}
Dim cellHeaderBackground As New CssBackground() With { _
.Image = "none", _
.Color = System.Drawing.ColorTranslator.FromHtml("#5E5A78") _
}

' Get references to the calendars' settings objects.
Dim mSettings As MonthSettings = Calendar1.MonthSettings

' General style
Dim style As Style = mSettings.Style
style.Borders.CopyFrom(headerBorder)
style.Brush.SetProperties(headerBackground.GetProperties())

'MainHeaderStyle
Dim hstyle As HeaderStyle = mSettings.MainHeaderStyle
hstyle.Borders.CopyFrom(headerBorder)
hstyle.Brush.SetProperties(headerBackground.GetProperties())

' Cells style
style = mSettings.DaySettings.Style
style.Borders.CopyFrom(border)
style.Brush.SetProperties(background.GetProperties())

' Cells headers
hstyle = mSettings.DaySettings.HeaderStyle
hstyle.Borders.CopyFrom(cellHeaderBorder)
hstyle.Brush.SetProperties(cellHeaderBackground.GetProperties())
hstyle.TextColor = Color.White

' Buttons style
Dim bStyle As ButtonsStyle = mSettings.ButtonStyle
bStyle.Brush.Image = "none"
bStyle.Brush.Color = System.Drawing.ColorTranslator.FromHtml("#4C4662")
mSettings.ButtonStyle.Brush.SetProperties(bStyle.Brush.GetProperties())

The image below depicts how the Calendar's SingleMonth view will look like after applying these styles:


Customizing the Appearance of Items

Customizing the Appearance of Items

Items' appearance can be customized on the server-side by setting various properties.

ItemSettings class

A set of properties for customizing items' appearance is provided by the ItemSettings class. Use the Size and HeaderSize properties to adjust the items' dimensions. Spacing property can be used to change the amount of space between adjacent items. The display of different visual elements within the item can be modified by using the ShowReminderIcons, ShowRecurrenceIcons and ShowRecurrenceExceptionIcons properties. You can also choose whether or not to use the built-in functionality of the item cues by setting the ShowMoreItemsCue property accordingly.

ItemSettings.Style

Use the ItemSettings.Style property to change the visual appearance of the items from the server side.

C# [image] Copy Code

ItemStyle style = Calendar1.ItemSettings.Style;
style.HeaderTextColor = Color.White;
style.Brush.Image = "none";
style.Brush.Color = Color.OrangeRed;

Visual Basic [image] Copy Code

Dim style As ItemStyle = Calendar1.ItemSettings.Style
style.HeaderTextColor = Color.White
style.Brush.Image = "none"
style.Brush.Color = Color.OrangeRed

The code above will produce the following result in the Standard theme:

Customizing the ItemSettings.Style property will affect all appointments defined in the Calendar, including the newly created from the client-side items. For styling individual appointments use the Appointment.Style property.

Appointment.Style

By setting the Appointment.Style property you can style individual items.

C# [image] Copy Code

ItemStyle style = appointment.Style;
CssBorderStyle borders = new CssBorderStyle()
{
TopColor = Color.White,
LeftColor = Color.White,
TopStyle = BorderStyle.Solid,
LeftStyle = BorderStyle.Solid,
BottomColor = Color.Black,
RightColor = Color.Black,
BottomStyle = BorderStyle.Solid,
RightStyle = BorderStyle.Solid,
AllWidth = new Unit(1.0, UnitType.Pixel)
};
style.Borders.CopyFrom(borders);
CssBackground background = new CssBackground()
{
Image = "none",
Color = Color.DodgerBlue
};
style.Brush.SetProperties(background.GetProperties());
style.HeaderFont.Name = "Lucida Handwriting";
style.HeaderFont.Italic = true;
style.HeaderTextAlignment = TextAlignment.MiddleRight;
style.HeaderTextColor = Color.White;

Visual Basic [image] Copy Code

Dim style As ItemStyle = appointment.Style
Dim borders As New CssBorderStyle() With { _
.TopColor = Color.White, _
.LeftColor = Color.White, _
.TopStyle = BorderStyle.Solid, _
.LeftStyle = BorderStyle.Solid, _
.BottomColor = Color.Black, _
.RightColor = Color.Black, _
.BottomStyle = BorderStyle.Solid, _
.RightStyle = BorderStyle.Solid, _
.AllWidth = New Unit(1.0, UnitType.Pixel) _
}
style.Borders.CopyFrom(borders)
Dim background As New CssBackground() With { _
.Image = "none", _
.Color = Color.DodgerBlue _
}
style.Brush.SetProperties(background.GetProperties())
style.HeaderFont.Name = "Lucida Handwriting"
style.HeaderFont.Italic = True
style.HeaderTextAlignment = TextAlignment.MiddleRight
style.HeaderTextColor = Color.White

This image shows how the appointment will look like:

Styling Items through CSS

Items can be styled also through the use of CSS classes. This topic is discussed at length here.


CSS Classes

CSS Classes

Besides customizing the appearance of calendar views and items by using techniques described in Customizing the Appearance of Views and Customizing the Appearance of Items you can override the built-in CSS classes by providing your own. There are several ways to do that. The Item class exposes a CssClass property where the name of a particular user defined CSS class can be set, thus changing the appearance of individual items. To change the look of all visible items in a Calendar you may override directly the predefined visual styles of items.

Styling items

The following table lists the names of the predefined CSS classes, used to style items in a Calendar view:

Note

The tables below show the classes defined in the built-in Vista theme. The other themes use the same class names, just with a different theme identifier - for example instead of the .Vista class, the Windows2003 theme uses .Windows2003 as root class name; .WebPlannerPopupFormVista is named .WebPlannerPopupFormSilver in the Silver theme and so on.

Css class name | Description
.Vista .appointment .frame | Styles the background of items in non Timetable views.
.WebPlannerPopupFormVista .appointment .frame | Styles the background of items inside an ItemsCueForm.
.Vista .appointment.timetable .wrapper | Styles the background of items in Timetable view.
.Vista .appointment .borders | Styles borders of items.
.WebPlannerPopupFormVista .appointment .borders | Styles borders of items inside an ItemsCueForm.
.Vista .appointment .subject | Styles the header text of items.
.WebPlannerPopupFormVista .appointment .subject | Styles the header text of items inside an ItemsCueForm.
.Vista .appointment .details | Styles the description text of items in a Timetable view.

Example

The following example shows how to style all items in the calendar by removing the default background image, setting different background, border and font of the header text:

CSS [image] Copy Code

.appointment .frame,
.appointment .wrapper
{
background-image: none !important;
background-color: Red !important;
}
.appointment .wrapper .borders
{
border: solid 1px Blue !important;
}
.appointment .frame .subject
{
font-family: Verdana !important;
}

The code above will produce the following result in the Standard theme:

The next example uses the same style from above, but defined only for particular item(s) by assigning to the CssClass property:

C# [image] Copy Code

Appointment appointment = new Appointment();
appointment.StartTime = DateTime.Now;
appointment.EndTime = appointment.StartTime.AddHours(5);
appointment.HeaderText = "CSS Styled Item";
appointment.CssClass = "MyCustomCssClass";

Calendar1.Schedule.Items.Add(appointment);

Visual Basic [image] Copy Code

Dim appointment As New Appointment()
appointment.StartTime = DateTime.Now
appointment.EndTime = appointment.StartTime.AddHours(5)
appointment.HeaderText = "CSS Styled Item"
appointment.CssClass = "MyCustomCssClass"

Calendar1.Schedule.Items.Add(appointment)

CSS [image] Copy Code

.MyCustomCssClass .frame,
.MyCustomCssClass .wrapper
{
background-image: none !important;
background-color: Red !important;
}
.MyCustomCssClass .appointment .wrapper .borders
{
border: solid 1px Blue !important;
}
.MyCustomCssClass .appointment .frame .subject
{
font-family: Verdana !important;
}

Styling calendar views

Single Month view

The following table lists the names of the predefined CSS classes, used to style the Single Month calendar view:

Css class name | Description
.WebPlannerSingleMonth .Vista | Styles the background of the view.
.WebPlannerSingleMonth .Vista .header .title td | Styles the main header element of the view.
.WebPlannerSingleMonth .Vista .navButton td.year, .WebPlannerSingleMonth .Vista .navButton td.month | Styles the navigation buttons of the view.
.WebPlannerSingleMonth .Vista .header .weekDays .days td | Styles the week day names subheader of the view.
.WebPlannerSingleMonth .Vista .weekNumberLeft | Styles the week numbers subheader of the view.
.WebPlannerSingleMonth .Vista .month | Styles regular day cells.
.WebPlannerSingleMonth .Vista .padding | Styles padding day cells.
.WebPlannerSingleMonth .Vista .month .title | Styles regular day cells' headers.
.WebPlannerSingleMonth .Vista .padding .title | Styles padding day cells' headers.

Month Range view

The following table lists the names of the predefined CSS classes, used to style the Month Range calendar view:

Css class name | Description
.WebPlannerMonthRange .Vista | Styles the background of the view.
.WebPlannerMonthRange .Vista .mainHeader .title td | Styles the main header element of the view.
.WebPlannerMonthRange .Vista .navButton td.year | Styles the year navigation buttons of the view.
.WebPlannerMonthRange .Vista .header .title td | Styles the month header elements of the view.
.WebPlannerMonthRange .Vista .header .weekDays .days td | Styles the week day names subheader of the view.
.WebPlannerMonthRange .Vista .weekNumberLeft | Styles the week numbers subheader of the view.
.WebPlannerMonthRange .Vista .month | Styles regular day cells.
.WebPlannerSingleMonth .Vista .padding | Styles padding day cells.
.WebPlannerSingleMonth .Vista .month .title | Styles regular day cells' headers.
.WebPlannerSingleMonth .Vista .padding .title | Styles padding day cells' headers.

Week Range view

The following table lists the names of the predefined CSS classes, used to style the Week Range calendar view:

Css class name | Description
.WebPlannerWeekRange .Vista | Styles the background of the view.
.WebPlannerWeekRange .Vista .header .title td | Styles the main header element.
.WebPlannerWeekRange .Vista .header .week .days td | Styles the week days subheader.
.WebPlannerWeekRange .Vista .day | Styles the time cells.
.WebPlannerWeekRange .Vista .day .title | Styles the time cells' headers.

Timetable view

The following table lists the names of the predefined CSS classes, used to style the Timetable calendar view:

Css class name | Description
.WebPlannerTimetable .Vista | Styles the background of the view.
.WebPlannerTimetable .Vista .header .title .headerRow th | Styles the main header cells.
.WebPlannerTimetable .Vista .header .title .groupRow th | Styles the group header cells.
.WebPlannerTimetable .Vista .header .title .itemsRow td, .WebPlannerTimetable .Vista .header .title .emptyRow td | Styles the items header cells.
.WebPlannerTimetable .Vista .timeline, .WebPlannerTimetable .Vista .cornerCell | Styles the timeline.
.WebPlannerTimetable .Vista .navButton td.button | Styles the view's navigation buttons.
.WebPlannerTimetable .Vista .cell | Styles the time cells.
.WebPlannerTimetable .Vista .workCell | Styles the work-time time cells.

List view

The following table lists the names of the predefined CSS classes, used to style the List calendar view:

Css class name | Description
.WebPlannerListView .Vista | Styles the background of the view.
.WebPlannerListView .Vista .mainHeader .dates | Styles main header's cells.
.WebPlannerListView .Vista .navButton td.button | Styles the view's navigation buttons.
.WebPlannerListView .Vista .groupHeader td | Styles group header's cells.
.WebPlannerListView .Vista .day | Styles the time cells.
.WebPlannerListView .Vista .day .title | Styles the time cells' headers.

Resource view

The following table lists the names of the predefined CSS classes, used to style the Resource view:

Css class name | Description
.WebPlannerResourceView .Vista | Styles the background of the view.
.WebPlannerResourceView .Vista .mainHeader .dates, .WebPlannerResourceView .Vista .corner | Styles the timelines of the view.
.WebPlannerResourceView .Vista .groupHeader td | Styles group header's cells.
.WebPlannerResourceView .Vista .laneCell | Styles lane cells.

Styling selection

The following table lists the names of the predefined CSS classes, used to style the selection of cells in a calendar view:

Css class name | Description
.WebPlannerSingleMonth .Vista .content .frame .monthDays .week .bgRow .month .dayWrapper .borders.selection | Styles the selection of regular days in Single Month view.
.WebPlannerSingleMonth .Vista .content .frame .monthDays .week .bgRow .padding .dayWrapper .borders.selection | Styles the selection of padding days in Single Month view.
.WebPlannerMonthRange .Vista .content .frame .monthDays .week .bgRow .month .dayWrapper .borders.selection | Styles the selection of regular days in Month Range view.
.WebPlannerMonthRange .Vista .content .frame .monthDays .week .bgRow .padding .dayWrapper .borders.selection | Styles the selection of padding days in Month Range view.
.WebPlannerWeekRange .Vista .content .wrapper .weekRow .bgDays .day .dayWrapper .borders.selection | Styles the selection of days in Week Range view.
.WebPlannerListView .Vista .horizontal .wrapper .content .row .bgDays .day .dayWrapper .borders.selection | Styles the selection of cells in List view.
.WebPlannerTimetable .Vista .schedule .scheduleTable .column .row.selection .cell | Styles the selection of regular cells in Timetable view.
.WebPlannerTimetable .Vista .schedule .scheduleTable .column .row.selection .workCell | Styles the selection of working hours cells in Timetable view.

The following table lists the name of the predefined CSS class, used to style the indicator, visible when a drag operation is taking place:

Css class name | Description
.Vista .dragIndicator | Styles the overlay shown in time cells during dragging operations.

Example

The following example shows how to customize the selection in Single Month view, by settings its color to Yellow and the color of the titles of selected cell to Orange:

CSS [image] Copy Code

.WebPlannerSingleMonth .Vista .content .frame .monthDays .week .bgRow .padding .dayWrapper .borders.selection,
.WebPlannerSingleMonth .Vista .content .frame .monthDays .week .bgRow .month .dayWrapper .borders.selection
{
background-color: Yellow !important;
}
.WebPlannerSingleMonth .Vista .content .frame .monthDays .week .bgRow .padding .dayWrapper .borders.selection .title,
.WebPlannerSingleMonth .Vista .content .frame .monthDays .week .bgRow .month .dayWrapper .borders.selection .title
{
background-color: #ffa500 !important;
}

Styling built-in forms

The following table lists the names of the predefined CSS classes, used to style built-in popup forms in a calendar view:

Css class name | Description
.WebPlannerPopupFormVista .frame | Styles the outer frame of a form.
.WebPlannerPopupFormVista .frame #header | Styles the header of a form.
.WebPlannerPopupFormVista .frame #main-content | Styles the main content of a form.
.WebPlannerPopupFormVista .frame #main-content .dates-text | Styles the dates header in a NewForm.
.WebPlannerPopupFormVista .frame #main-content .buttons-row | Styles the buttons container in a form.
.WebPlannerPopupFormVista .frame #main-content .buttons-row a.button | Styles the buttons in a form.
.WebPlannerPopupFormVista .frame #main-content .text-area | Styles textarea elements in a form.
.WebPlannerPopupFormVista .frame #main-content .text-box | Styles textbox elements in a form.
.WebPlannerPopupFormVista .frame #main-content .dropDown-list | Styles drop-down elements in a form.
.WebPlannerPopupFormVista .frame #main-content .checkbox-list | Styles checkboxes in a form.
.WebPlannerPopupFormVista div.time-view-Vista table.timesHeader | Styles the header of a drop-down calendar in a form.
.WebPlannerPopupFormVista div.time-view-Vista table.times | Styles the contents of a drop-down calendar in a form.
.WebPlannerPopupFormVista div.time-view-Vista div.todayButton | Styles the 'today' button of a drop-down calendar in a form.
.WebPlannerPopupFormVista div.time-view-Vista td.button | Styles navigation buttons of a drop-down calendar in a form.
.WebPlannerPopupFormVista div.time-view-Vista table.times td.today | Styles the current day in a drop-down calendar in a form.
.WebPlannerPopupFormVista div.time-view-Vista table.times td.selected | Styles selected current day in drop-down calendar in a form.

Styling overlays

The following table lists the names of the predefined CSS classes, used to style the calendar's overlay elements:

Css class name | Description
.Vista .WebPlannerLoader | Styles the div overlay applied over the calendar before rendering on the client side is complete.
.WebPlannerDisabled | Styles the div overlay applied over the calendar when its Enabled property is set to false.


Tooltips

Tooltips

Tooltips are displayed for items, time cells and headers in the calendar views. Tooltips are only displayed if the Calendar.ShowToolTips property is set to true. The item tooltip is formatted according to Calendar.ItemTooltipFormat property.


Manipulating Cells on the Client

Manipulating Cells on the Client

Each of the calendar views present visually different spans of time in time cells. Time cells are defined by their start time and their end time. For example, in Single Month, Month Range and Week Range views a time cell is one full day in the time interval, presented by the view. In List view a time cell represents a single second, minute, hour, day and so on, as specified by the CellUnits property of the Calendar.ListViewSettings. In Timetable time cells represent the time periods in the view's columns, specified by the Calendar.TimetableSettings.CellTime property.

References to time cell objects can be obtained through their planar position in the view, by calling the calendar's getCellAt method, by their start and end time values through either getTimeCell (for a single cell) or getTimeCells (for a collection of cells), or through the CellEventArgs, passed as arguments to some of the events, raised by the Calendar.

Items in a view can also be identified by the cell they are situated in by calling getCellItems - for the visible items in a time cell or getCueCellItems - for items which are not visible in a view, due to the lack of available space.

The following table lists the cell object's properties:

Property name | Type | Description
startTime | DateTime | The start time of the cell.
endTime | DateTime | The end time of the cell.
index | Number | The zero-based position of the cell within a view.
rowIndex | Number | The zero-based parent row index. (Not in Timetable view.)
columnIndex | Number | The zero-based parent column index. (Only in Timetable view.)
monthCellIndex | Number | The zero-based parent month cell index. (Only in Month Range view.)
bgCell | TD HTML element / DIV HTML element* | The HTML element, representing the cell within the Calendar. (*For Timetable view.)
title | DIV HTML element | The HTML element, representing the cell's header. (Not in Timetable view.)
titleText | TD HTML element | The HTML element, representing the cell's header text. (Not in Timetable view.)

Examples

The following example shows how particular time cells can be customized:

JavaScript [image] Copy Code
function markCells()
{
var start = MindFusion.Common.DateTime.today();
var end = start.clone().addDays(3);
// Gets reference to the calendar object.
var calendar = $find('Calendar1');
// Gets the cells in the predefined time range.
var cells = calendar.getTimeCells(start, end, true);
for (var i = 0, l = cells.length; i < l; i++) {
// colors the background of the cell red.
cells[i].bgCell.style.backgroundColor = 'red';
}
}

This example shows how references to cells can be obtained by handling certain Calendar events.

C# [image] Copy Code

// Prevent showing of the built-in popup forms.
Calendar1.UseForms = false;
// Provide the name of a JavaScript function, that will handle the DateClick event.
Calendar1.DateClickScript = "onDateClick";

Visual Basic [image] Copy Code

' Prevent showing of the built-in popup forms.
Calendar1.UseForms = False
' Provide the name of a JavaScript function, that will handle the DateClick event.
Calendar1.DateClickScript = "onDateClick"

JavaScript [image] Copy Code

// Handle the DateClick event to display a message showing the number of items presentily in this cell.
function onDateClick(sender, args) {
var cell = args.get_cell();
var cellItems = sender.getCellItems(cell);

if (cellItems.length > 0) {
alert(String.format('There are {0} items in this cell', cellItems.length));
}
else { alert('There are no items in this cell.'); }
}


Client Side Events

Client Side Events

Creating event handlers in JavaScript

To handle a client-side event, create a JavaScript event handler function and assign its name to the respective script property of the Calendar class. The properties that contain the names of the JavaScript event handlers have the same name as the event with a Script suffix added, in the form of [EventName]Script. The signature of the handler must contain the sender and args parameters, where sender is always the Calendar and args are the event arguments associated with the event. For example, add a "function onItemDoubleClick(sender, args)" script to handle the ItemDoubleClick event.

Almost every element in the Calendar has certain events which can trigger JavaScript functions. For example, when a Item is created by a user action, the ItemCreated event will be raised invoking the function whose name is specified in the ItemCreatedScript property. For each client-side event, there is a string property of the form [EventName]Script that specifies the respective JavaScript event handler function that should be called. In the Visual Studio Properties window, type in the name of the event handler function in the field of the respective event property, for example [EventName]Script = "onEventName".

Notification events

Most events are raised to notify you that the user has performed some action. A modification event is raised to let your application know about the modified item (for example ItemModified). When a user presses the DEL key, an item-deleted event is raised (for example ItemDeleted). The events ItemClicked, ItemDoubleClicked, DateClicked occur when an item or other element is clicked. There are many other events related to various activities a user could carry out in the Calendar.

Validation events

Validation events let you approve or reject users actions. The event handler functions are expected to set the value of the Sys.CancelEventArgs cancel property accessible through the args parameter of the handler, either set_cancel(false) if an action should be accepted, or set_cancel(true) if it should be rejected.

While the user is holding down the mouse button and dragging an item, a modification validation event is raised continuously (for example ItemModifying). There are events raised when users creates items, for example ItemCreating. When the user presses the Delete key, the ItemDeleting or RecurringItemDeleting events are raised to let you confirm the operation.

Mouse motion tracking events

The following events occur when the mouse pointer enters or leaves an Item: ItemMouseEnter or ItemMouseLeave. Respectively, the following event is raised when the mouse pointer moves over an Item: ItemMouseMove.

The following table presents all client side events with their associated event arguments, the respective Calendar Script property and a short description:

Event | Event arguments | Script property | Description
CalendarLoad | null | CalendarLoadScript | Raised just after the calendar has finished loading and is ready for interaction.
MouseMove | MouseEventArgs | MouseMoveScript | Raised when the user moves the mouse over the Calendar area.
MouseEnter | MouseEventArgs | MouseEnterScript | Raised when the user enters the area over the Calendar with the mouse.
MouseLeave | MouseEventArgs | MouseLeaveScript | Raised when the user leaves the area over the Calendar with the mouse.
Click | MouseEventArgs | ClickScript | Raised when the user clicks anywhere on the Calendar with the mouse.
DoubleClick | MouseEventArgs | DoubleClickScript | Raised when the user double-clicks anywhere on the Calendar with the mouse.
MonthHeaderClick | HeaderEventArgs | MonthHeaderClickScript | Raised when the user clicks with the mouse on the main header of the Single Month view of the Calendar.
TimetableColumnHeaderClick | HeaderEventArgs | TimetableColumnHeaderClickScript | Raised when the user clicks with the mouse on the column header of the timetable view of the Calendar.
WeekRangeHeaderClick | HeaderEventArgs | WeekRangeHeaderClickScript | Raised when the user clicks with the mouse on the main header of the Week Range view of the Calendar.
ListViewHeaderClick | HeaderEventArgs | ListViewHeaderClickScript | Raised when the user clicks with the mouse on the main header of the list view of the Calendar.
MonthRangeHeaderClick | HeaderEventArgs | MonthRangeHeaderClickScript | Raised when the user clicks with the mouse on the main header of the Month Range view of the Calendar.
SelectionStart | SelectionEventArgs | SelectionStartScript | Raised when cell selection starts.
SelectionEnd | SelectionEventArgs | SelectionEndScript | Raised when cell selection ends.
SelectionChanged | SelectionChangedEventArgs | SelectionChangedScript | Raised when cell selection has changed.
ItemSelectionChanged | ItemSelectionEventArgs | ItemSelectionChangedScript | Raised when item selection has changed.
DateClick | CellEventArgs | DateClickScript | Raised when the user clicks a time cell in a calendar view.
DateHeaderClick | CellEventArgs | DateHeaderClickScript | Raised when the user clicks the header of a time cell in a calendar view.
DateDoubleClick | CellEventArgs | DateDoubleClickScript | Raised when the user double-clicks a time cell in a calendar view.
DateMouseDown | CellEventArgs | DateMouseDownScript | Raised when the user presses a mouse button down over a time cell in a calendar view.
DateMouseUp | CellEventArgs | DateMouseUpScript | Raised when the user releases a mouse button oven a time cell in a calendar view.
ItemClick | ItemLocationEventArgs | ItemClickScript | Raised when the user clicks an Item.
ItemDoubleClick | ItemLocationEventArgs | ItemDoubleClickScript | Raised when the user double-clicks an Item.
ItemMouseDown | ItemLocationEventArgs | ItemMouseDownScript | Raised when the user presses a mouse button down over an Item.
ItemMouseUp | ItemLocationEventArgs | ItemMouseUpScript | Raised when the user releases a mouse button over an Item.
ItemMouseEnter | MouseEventArgs | ItemMouseEnterScript | Raised when the user enters the area over an Item with the mouse.
ItemMouseLeave | MouseEventArgs | ItemMouseLeaveScript | Raised when the user leaves the area over an Item with the mouse.
ItemMouseMove | MouseEventArgs | ItemMouseMoveScript | Raised when the user moves the mouse in the area over an Item.
ItemDragStart | ItemLocationEventArgs | ItemDragStartScript | Raised when the user starts to drag an Item with the mouse.
ItemDragEnd | ItemChangedEventArgs | ItemDragEndScript | Raised when the user finishes to drag an Item with the mouse.
ItemInplaceEditStarting | ItemEventArgs | ItemInplaceEditStartingScript | Raised just before the user starts an inplace edit operation on an Item.
ItemInplaceEditEnding | ItemEventArgs | ItemInplaceEditEndingScript | Raised just before the user commits an inplace edit operation on an Item.
ItemReminderTriggered | ItemEventArgs | ItemReminderTriggeredScript | Raised when a Reminder associated with an Item is triggered.
ItemCreating | ItemEventArgs | ItemCreatingScript | Raised just before an Item is created.
ItemCreated | ItemEventArgs | ItemCreatedScript | Raised when an Item is created.
ItemModifying | ItemChangedEventArgs | ItemModifyingScript | Raised when an Item is being modified.
ItemModified | ItemModifiedEventArgs | ItemModifiedScript | Raised when an Item is modified.
ItemDeleting | ItemEventArgs | ItemDeletingScript | Raised just before an Item is deleted.
RecurringItemDeleting | ItemEventArgs | RecurringItemDeletingScript | Raised just before a recurring Item is deleted.
ItemDeleted | ItemEventArgs | ItemDeletedScript | Raised when an Item is deleted.
MoreItemsCueMouseDown | CellEventArgs | MoreItemsCueMouseDownScript | Raised when the user presses a mouse button over a more items cue.
MoreItemsCueMouseUp | CellEventArgs | MoreItemsCueMouseUpScript | Raised when the user releases a mouse button over a more items cue.
FormShow | FormEventArgs | FormShowScript | Raised just before a popup form is shown.
TaskReminderTriggered | TaskEventArgs | TaskReminderTriggeredScript | Raised when a Reminder associated with a Task is triggered.

Examples

Handle the ItemModifying event to perform validation:

ASPX [image] Copy Code

<!-- Assign the name of the JavaScript function that will handle the ItemModifying event. -->
<mindfusion:Calendar ID="Calendar1" runat="server" ItemModifyingScript="onItemModifying" />

C# [image] Copy Code

// Assign the name of the JavaScript function that will handle the ItemModifying event.
Calendar1.ItemModifyingScript = "onItemModifying";

Visual Basic [image] Copy Code

' Assign the name of the JavaScript function that will handle the ItemModifying event.
Calendar1.ItemModifyingScript = "onItemModifying"

JavaScript [image] Copy Code

<script type="text/javascript">

// Handle the ItemModifying client event to deny interactive resizing of items.
function onItemModifying(sender, args) {
// determine the type of interactive operation.
var action = args.get_action();

if (action == MindFusion.Scheduling.ItemModifyAction.Resize) {
args.set_cancel(true);
}
}

</script>

Handle the Load event to perform coloring of the title text of time cells, that contain items:

ASPX [image] Copy Code

<!-- Assign the name of the JavaScript function that will handle the Load event. -->
<mindfusion:Calendar ID="Calendar1" runat="server" CalendarLoadScript="onCalendarLoad" />

C# [image] Copy Code

// Assign the name of the JavaScript function that will handle the Load event.
Calendar1.CalendarLoadScript = "onCalendarLoad";

Visual Basic [image] Copy Code

' Assign the name of the JavaScript function that will handle the Load event.
Calendar1.CalendarLoadScript = "onCalendarLoad"

JavaScript [image] Copy Code

<script type="text/javascript">

function onCalendarLoad(sender) {
// get the items defined for this calendar.
var items = sender.getItems();

for (var i = 0; i < items.length; i++) {
var start = items[i].getStartTime().clone();
var end = items[i].getEndTime().clone();
// identify the cell(s) that contain that item.
var cells = sender.getTimeCells(start, end);
for (var k = 0; k < cells.length; k++) {
if (cells[k].titleText) {
// apply different style to the header of the cell.
cells[k].titleText.style.color = 'red';
}
}
}
}

</script>


Using Built-In Forms

Using Built-In Forms

In MindFusion.Scheduling for ASP.NET interactive creating, modifying and deleting of items in a calendar view is facilitated by using the built-it popup Forms - namely NewForm - for quickly creating items, EditForm - for detailed creation of items or editing, RecurrenceForm - for specifying / editing / removing a recurrence pattern for an item, ItemsCueForm - a container form, used for displaying items, which are not visible in a time cell. To disable the forms set the Calendar.UseForms property to false. You can style the default forms and customize them to your liking. More information on the CSS classes used to style forms in different Themes can be found in the CSS Classes topic.

All of the included forms derive from the BaseForm class, and share some similar functionality. When a form is about to be opened in a Calendar, the FormShow event is raised, where the FormEventArgs argument, contains information about the opening form - its type, its header text, the item it's associated with and so on. By handling the FormShow event, you can choose to not show a particular form, or to show a modified or completely different version of it.

The following example shows how you can modify an opening form by handling the FormShow event.

ASPX [image] Copy Code

<MindFusion:Calendar ID="Calendar1" runat="server" FormShowScript="onFormShow" />

JavaScript [image] Copy Code

<script type="text/javascript">

function onFormShow(sender, args) {
var form = args.get_form();

if (form.getId() == 'EditForm') {
if (!form.customizedForm) {
args.set_cancel(true);

var customForm = new MindFusion.Scheduling.EditForm(sender, form.getItem());
customForm.customizedForm = true;
customForm.setHeaderText('my custom form!');

customForm.showForm();
}
}
}

</script>

Through the BaseForm.getControls method you can obtain references to the HTML elements, used in a particular form.

For example, you may wish to forbid interactive recurrence pattern creation through forms. In order to do that, you can hide the Recurrence button, used to show the RecurrenceForm in the EditForm:

JavaScript [image] Copy Code

function onFormShow(sender, args) {
var form = args.get_form();
if (form.getId() == 'EditForm') {
var btnRec = form.getControls()['btnRecurrence'].element;
btnRec.style.display = 'none';
}
}

The following tables show a complete list of the ids and types of the HTML elements, used in the built-in forms.

NewForm

Id of the element | Element type | Description
headerElement | div | The header of the form.
headerClose | a | The header close button in the upper right corner of the form.
subject | textarea | The subject text area of the form.
btnSave | a | The Save button.
btnOptions | a | The Options button.

EditForm

Id of the element | Element type | Description
InfoDiv | div | Div showing information about recurrence patterns.
TimeDiv | div | The area containing start and end time related elements.
allDayEvent | checkbox | The 'All day event' checkbox.
btnCancel | a | The Cancel button.
btnRecurrence | a | The Recurrence button.
btnSave | a | The Save button.
contacts | div | The Contacts area.
details | textarea | The Details area.
endDate | div | The end time date component.
endTime | div | The end time time component.
headerClose | a | The header close button in the upper right corner of the form.
headerElement | div | The header of the form.
location | select | The Location drop-down.
reminder | select | The Reminder drop-down.
reminderCheck | checkbox | The Reminder checkbox.
startDate | div | The start time date component.
startTime | div | The start time time component.
subject | text | The Subject area.

RecurrenceForm

Id of the element | Element type | Description
DayDiv | div | The daily recurrence pattern area.
IntervalDiv | div | The time interval recurrence pattern area.
MonthDiv | div | The monthly recurrence pattern area.
WeekDiv | div | The weekly recurrence pattern area.
YearDiv | div | The yearly recurrence pattern area.
btnCancel | a | The Cancel button.
btnSave | a | The Save button.
btnDelete | a | The Delete button.
daily | radio | The 'Daily' pattern selection radio button
weekly | radio | The 'Weekly' pattern selection radio button
monthly | radio | The 'Monthly' pattern selection radio button
yearly | radio | The 'Yearly' pattern selection radio button
interval | radio | The 'By time interval' pattern selection radio button
startDate | div | The start date element.
noEnd | radio | The RecurrenceEnd.Never radio button.
endAfter | radio | The End after radio button.
numOccurences | div | The number of occurrences up/down.
endDate | div | The end date element.
endBy | radio | The End by radio button.
dailyEvery | radio | The every day radio button. (Daily pattern)
dailyEveryDay | div | The every day up/down. (Daily pattern)
dailyWeekDay | radio | The weekday radio button. (Daily pattern)
dailyWeekendDay | radio | The weekend radio button. (Daily pattern)
weekEvery | div | The every week up/down. (Weekly pattern)
dayOfWeek0 | checkbox | The first day of week. (Weekly pattern)
dayOfWeek1 | checkbox | The second day of week. (Weekly pattern)
dayOfWeek2 | checkbox | The third day of week. (Weekly pattern)
dayOfWeek3 | checkbox | The fourth day of week. (Weekly pattern)
dayOfWeek4 | checkbox | The fifth day of week. (Weekly pattern)
dayOfWeek5 | checkbox | The sixth day of week. (Weekly pattern)
dayOfWeek6 | checkbox | The seventh day of week. (Weekly pattern)
monthDate | radio | The BySpecificDate radio button. (Monthly pattern)
monthDateEdit | div | The day of month up/down. (Monthly pattern)
monthDateMonth | div | The months up/down. (Monthly pattern)
monthWeekDay | radio | The ByDayType radio button. (Monthly pattern)
monthWeekDayOptions | select | The occurrence drop-down. (Monthly pattern)
monthWeekDayExactOptions | select | The day of week drop-down. (Monthly pattern)
monthWeekDayMonth | div | The months up/down. (Monthly pattern)
yearExact | radio | The BySpecificDate radio button. (Yearly pattern)
yearExactOption | select | The month of year drop-down. (Yearly pattern)
yearExactEdit | div | The day up/down. (Yearly pattern)
yearWeekDay | radio | The ByDayType radio button. (Yearly pattern)
yearWeekDayPosOptions | select | The occurrence drop-down. (Yearly pattern)
yearWeekDayExactOptions | select | The day of week drop-down. (Yearly pattern)
yearMonthExactOptions | select | The month of year drop-down. (Yearly pattern)
intervalDays | div | The days up/down. (ByTimeInterval pattern)
intervalHours | div | The hours up/down. (ByTimeInterval pattern)
intervalMinutes | div | The minutes up/down. (ByTimeInterval pattern)
intervalSeconds | div | The seconds up/down. (ByTimeInterval pattern)

ItemsCueForm

Id of the element | Element type | Description
headerElement | div | The header of the form.
headerClose | a | The header close button in the upper right corner of the form.


Localization

Localization

Use Calendar.LocalizationInfo property to customize captions and non-Culture dependent control values present in the built-in forms of MindFusion.Scheduling for ASP.NET. The defined data can be easily reused by using the SaveToXML and LoadFromXML methods.

The image below shows localized Edit and Recurrence forms.


Tutorials

Tutorials


Adding the control

Adding the control

1. Customize the Visual Studio toolbox

Assuming you have already installed MindFusion.Scheduling for ASP.NET, your next goal is to add the components from the MindFusion.Scheduling package to the Visual Studio toolbox. Follow these steps to customize the toolbox:

1.1 Create a new ASP.NET Web Site

Select File -> New Website from the Visual Studio menu. In the dialog that appears, select ASP.NET Web Site from the list of installed templates. Type in the name of your web site (this tutorial uses Tutorial1) and click 'OK'.

1.2 Add the Calendar control to the Toolbox

Note

The MindFusion.Scheduling.WebForms.dll file is usually found in the 'C:\Program Files\MindFusion\MindFusion.Scheduling for ASP.NET' folder or in the folder where you have installed the product.

Choose the 'View\Toolbox' menu item. Right-click the toolbox to show its context menu:

  • Select the 'Choose Items...' entry.
  • In the 'Choose Toolbox Items' dialog select the '.NET Framework Components' tab.
  • Click the 'Browse' button.
  • Navigate to the MindFusion.Scheduling for ASP.NET installation folder.
  • Navigate to the subfolder appropriate for the .NET version you are using.
  • Select MindFusion.Scheduling.WebForms.dll - the assembly file that contains the Calendar component.
  • Click the 'OK' button to close the 'Choose Toolbox Items' dialog.

2. Add the Calendar control

2.1 Drag and drop the control

A Calendar icon should appear in the selected category in the toolbox. Click on the icon and drag it to the form's working area. This creates a new MindFusion.Scheduling.WebForms Calendar control on the form.

2.2 Change the initial settings

The 'Calendar Tasks' pane appears when the Calendar control is dropped. From there you can choose the View, Theme and others:

2.3 Add a ScriptManager

You must also add a System.Web.UI.ScriptManager control, which is located in the AJAX Extensions tab.


Tutorial 1: Creating appointments

Tutorial 1: Creating appointments

This tutorial will show you how to create Contact, Location and Appointment objects.

1. Initial preparations

Follow the steps from 'Adding the control' topic - create a web site, add a Calendar control and a System.Web.UI.ScriptManager.

2. Set the control's properties

Select the Calendar control and click View -> Properties Window from the menu. In the Properties window change the CurrentView property to Timetable and Theme to Vista. Set the Calendar's Height and Width to 400px.
Click to expand 'Timetable Settings'. Set the StartTime property to '420' and EndTime property to '1260'. These designate minutes from the start of the day and mean from 7 AM to, but not including, 21 PM respectively.

3. Create data for the schedule

Switch to Code view and the following method to the page's code. Within this method we will define some items and resources to display in the calendar.

C# [image] Copy Code

private void CreateScheduleData()
{
}

Visal Basic [image] Copy Code
Private Sub CreateScheduleData()
End Sub

3.1 Creating contacts

Add the following code to the body of CreateScheduleData method:

C# [image] Copy Code

Contact contact1 = new Contact();
contact1.FirstName = "James";
contact1.LastName = "Jones";
Calendar1.Schedule.Contacts.Add(contact1);

Contact contact2 = new Contact();
contact2.FirstName = "Mary";
contact2.LastName = "Brown";
Calendar1.Schedule.Contacts.Add(contact2);

Visual Basic [image] Copy Code

Dim contact1 As New Contact()
contact1.FirstName = "James"
contact1.LastName = "Jones"
Calendar1.Schedule.Contacts.Add(contact1)

Dim contact2 As New Contact()
contact2.FirstName = "Mary"
contact2.LastName = "Brown"
Calendar1.Schedule.Contacts.Add(contact2)

This code will create two contacts - James Jones and Mary Brown and add them to the Schedule's Contacts collection.

3.2 Creating locations

Add the following code to the body of CreateScheduleData method:

C# [image] Copy Code

Location location1 = new Location();
location1.City = "London";
location1.Name = "London";
Calendar1.Schedule.Locations.Add(location1);

Location location2 = new Location();
location2.City = "Paris";
location2.Name = "Paris";
Calendar1.Schedule.Locations.Add(location2);

Visual Basic [image] Copy Code

Dim location1 As New Location()
location1.City = "London"
location1.Name = "London"
Calendar1.Schedule.Locations.Add(location1)

Dim location2 As New Location()
location2.City = "Paris"
location2.Name = "Paris"
Calendar1.Schedule.Locations.Add(location2)

This code will create two locations - London and Paris and add them to the Schedule's Locations collection.

3.3 Creating appointments

Add the following code to the body of CreateScheduleData method:

C# [image] Copy Code

Appointment app1 = new Appointment();
app1.StartTime = new DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 8, 0, 0);
app1.EndTime = app1.StartTime.AddHours(2);
app1.Subject = "Meeting";
app1.DescriptionText = "I really must be there on time.";
app1.Locked = true;
app1.Location = location1;
app1.Contacts.Add(contact1);
Calendar1.Schedule.Items.Add(app1);

Appointment app2 = new Appointment();
app2.StartTime = new DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 13, 0, 0);
app2.EndTime = app2.StartTime.AddHours(1);
app2.Subject = "Lunch";
app2.DescriptionText = "Yummy!";
app2.Location = location1;
app2.Contacts.Add(contact1);
Calendar1.Schedule.Items.Add(app2);

Appointment app3 = new Appointment();
app3.StartTime = new DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 7, 30, 0);
app3.EndTime = app3.StartTime.AddHours(3);
app3.Subject = "Yoga class";
app3.DescriptionText = "Yeah!";
app3.Location = location2;
app3.Contacts.Add(contact2);
Calendar1.Schedule.Items.Add(app3);

Appointment app4 = new Appointment();
app4.StartTime = new DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 20, 0, 0);
app4.EndTime = app4.StartTime.AddHours(1);
app4.Subject = "Dinner";
app4.DescriptionText = "with the family";
app4.Location = location2;
app4.Contacts.Add(contact2);
Calendar1.Schedule.Items.Add(app4);

Visual Basic [image] Copy Code

Dim app1 As New Appointment()
app1.StartTime = New DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 8, 0, 0)
app1.EndTime = app1.StartTime.AddHours(2)
app1.Subject = "Meeting"
app1.DescriptionText = "I really must be there on time."
app1.Locked = True
app1.Location = location1
app1.Contacts.Add(contact1)
Calendar1.Schedule.Items.Add(app1)

Dim app2 As New Appointment()
app2.StartTime = New DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 13, 0, 0)
app2.EndTime = app2.StartTime.AddHours(1)
app2.Subject = "Lunch"
app2.DescriptionText = "Yummy!"
app2.Location = location1
app2.Contacts.Add(contact1)
Calendar1.Schedule.Items.Add(app2)

Dim app3 As New Appointment()
app3.StartTime = New DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 7, 30, 0)
app3.EndTime = app3.StartTime.AddHours(3)
app3.Subject = "Yoga class"
app3.DescriptionText = "Yeah!"
app3.Location = location2
app3.Contacts.Add(contact2)
Calendar1.Schedule.Items.Add(app3)

Dim app4 As New Appointment()
app4.StartTime = New DateTime(DateTime.Now.Year, DateTime.Now.Month, DateTime.Now.Day, 20, 30, 0)
app4.EndTime = app4.StartTime.AddHours(1)
app4.Subject = "Dinner"
app4.DescriptionText = "with the family"
app4.Location = location2
app4.Contacts.Add(contact2)
Calendar1.Schedule.Items.Add(app4)

This code will create four appointments and add them to the Schedule's Items collection.

Finally, add a call to the CreateScheduleData method to the page's Load event handler:

C# [image] Copy Code

protected void Page_Load(object sender, EventArgs e)
{
if (!IsPostBack)
{
CreateScheduleData();
}
}

Visual Basic Copy Code

Protected Sub Page_Load(ByVal sender As Object, ByVal e As EventArgs)

If Not IsPostBack Then
CreateScheduleData()
End If

End Sub

4. Build and run

Run the web page. The image below depicts what the page output would look like:


Tutorial 2: Filtering and grouping

Tutorial 2: Filtering and grouping

This tutorial shows how to programmatically filter and group appointments using MindFusion.Scheduling for ASP.NET.

1. Initial preparations

Read Adding the control tutorial for detailed instructions on how to create a web site and add the Calendar control to it. Follow the steps in Tutorial 1: Creating appointments to add contacts, locations and appointments.

2. Filtering the Calendar

For the purpose of this tutorial add a ListBox control and three buttons to the page. Set the ListBox's ID to 'lbContacts' and its SelectionMode property to 'Multiple'. Set the buttons' Text property to 'Apply filter', 'Apply grouping' and 'Clear grouping/filtering'.

Switch to code view and add the following code at the end of CreateScheduleData method:

C# [image] Copy Code

//fill the list of contacts
lbContacts.Items.Clear();
lbContacts.Items.Add(new ListItem(contact1.LastName + ", " + contact1.FirstName));
lbContacts.Items.Add(new ListItem(contact2.LastName + ", " + contact2.FirstName));
lbContacts.Items[0].Selected = true;

Visual Basic [image] Copy Code

'fill the list of contacts
lbContacts.Items.Clear()
lbContacts.Items.Add(New ListItem(contact1.LastName + ", " + contact1.FirstName))
lbContacts.Items.Add(New ListItem(contact2.LastName + ", " + contact2.FirstName))
lbContacts.Items(0).Selected = True

This code adds the contacts, created in Tutorial1 to the ListBox control. We will use them to select by which resource(s) the Calendar will be filtered or grouped.

Double click on the first (Apply filter) button and in the code-behind add the following code to its Click handler:

C# [image] Copy Code

//clear the contacts
Calendar1.Contacts.Clear();

//add the selected contacts to the Calendar's Contacts collection
for (int i = 0; i < lbContacts.Items.Count; i++)
{
var li = lbContacts.Items[i];
if (li.Selected)
{
Contact c = Calendar1.Schedule.Contacts[i];
if (!Calendar1.Contacts.Contains(c))
Calendar1.Contacts.Add(c);
}
}

//apply filter
Calendar1.GroupType = GroupType.FilterByContacts;

Visual Basic [image] Copy Code

'clear the contacts
Calendar1.Contacts.Clear()

If lbContacts.SelectedIndex <> -1 Then

'add the selected contacts to the Calendar's Contacts collection
For i As Integer = 0 To lbContacts.Items.Count - 1
Dim li = lbContacts.Items(i)
If li.Selected Then
Dim c As Contact = Calendar1.Schedule.Contacts(i)
If Not Calendar1.Contacts.Contains(c) Then
Calendar1.Contacts.Add(c)
End If
End If
Next

'apply filter
Calendar1.GroupType = GroupType.FilterByContacts

End If

This code gets all contacts, which are selected in the ListBox and adds them to the Calendar's Contacts collection. Finally it sets the GroupType property of the Calendar to GroupType.FilterByContacts.

3. Grouping the Calendar

Double click on the second (Apply grouping) button and in the code-behind add the following code to its Click handler:

C# [image] Copy Code

//clear the contacts
Calendar1.Contacts.Clear();

//add the selected contacts to the Calendar's Contacts collection
for (int i = 0; i < lbContacts.Items.Count; i++)
{
var li = lbContacts.Items[i];
if (li.Selected)
{
Contact c = Calendar1.Schedule.Contacts[i];
if (!Calendar1.Contacts.Contains(c))
Calendar1.Contacts.Add(c);
}
}

//apply grouping
Calendar1.GroupType = GroupType.GroupByContacts;

Visual Basic [image] Copy Code

'clear the contacts
Calendar1.Contacts.Clear()

'add the selected contacts to the Calendar's Contacts collection
For i As Integer = 0 To lbContacts.Items.Count - 1

Dim li = lbContacts.Items(i)
If li.Selected Then
Dim c As Contact = Calendar1.Schedule.Contacts(i)
If Not Calendar1.Contacts.Contains(c) Then
Calendar1.Contacts.Add(c)
End If
End If

Next

'apply grouping
Calendar1.GroupType = GroupType.GroupByContacts

This code gets all contacts, which are selected in the ListBox and adds them to the Calendar's Contacts collection. Finally it sets the GroupType property of the Calendar to GroupType.GroupByContacts.

4. Clear all grouping and filtering

Double click on the last (Clear grouping/filtering) button and in the code-behind add the following code to its Click handler:

C# [image] Copy Code

Calendar1.Contacts.Clear();
Calendar1.GroupType = GroupType.None;

Visual Basic [image] Copy Code

Calendar1.Contacts.Clear()
Calendar1.GroupType = GroupType.None

The code above will remove any existing filtering or grouping by setting the Calendar's GroupType property to GroupType.None.

5. Build and run

Run the web page. The image below depicts what the page output would look like when the Calendar is grouped by both contacts:


Tutorial 3: Recurrences and reminders

Tutorial 3: Recurrences and reminders

This tutorial shows how to create recurrences and reminders either programmatically or by using the built-in forms.

1. Initial preparations

Follow the steps described in Tutorial1: Creating appointments and Tutorial 2: Filtering and grouping.

2. Create a reminder

Switch to code view and add the following code at the end of CreateScheduleData method:

C# [image] Copy Code

Reminder reminder = new Reminder();
reminder.Message = "Get ready for the very important meeting!";
reminder.Type = ReminderType.Leading;
reminder.TimeInterval = TimeSpan.FromMinutes(15);
//set the Reminder property of the first appointment to the newly created Reminder
app1.Reminder = reminder;

Visual Basic [image] Copy Code

Dim reminder As New Reminder()
reminder.Message = "Get ready for the very important meeting!"
reminder.Type = ReminderType.Leading
reminder.TimeInterval = TimeSpan.FromMinutes(15)
'set the Reminder property of the first appointment to the newly created Reminder
app1.Reminder = reminder

This code creates a Reminder that will trigger 15 minutes before the corresponding appointment's start time.
In order to show reminder messages, you must handle the Calendar's ItemReminderTriggered event. Switch to 'Design view' and find the 'Client events' section in the 'Properties' pane of the control. Set the value of the ItemReminderTriggeredScript property to 'onReminder' - this will be the name of the JavaScript function that will handle the event. Add the following code to the *.aspx file that contains the Calendar control:

JavaScript Copy Code

<script type="text/javascript">

function onReminder(sender, args) {
alert(args.get_item().getReminder().getMessage());
}

</script>

3. Create a recurrence

Switch to code view and add the following code at the end of CreateScheduleData method:

C# [image] Copy Code

Recurrence recurrence1 = new Recurrence()
{
Pattern = RecurrencePattern.Daily,
DailyRecurrence = DailyRecurrence.EveryWorkday,
StartDate = app2.StartTime,
RecurrenceEnd = RecurrenceEnd.EndDate,
EndDate = new DateTime(2011,12,31)
};
app2.Recurrence = recurrence1;

Recurrence recurrence2 = new Recurrence()
{
Pattern = RecurrencePattern.Weekly,
DaysOfWeek = DaysOfWeek.Monday | DaysOfWeek.Wednesday,
StartDate = app3.StartTime,
NumOccurrences = 30
};
app3.Recurrence = recurrence2;

Visual Basic [image] Copy Code

Dim recurrence1 As New Recurrence() With { _
.Pattern = RecurrencePattern.Daily, _
.DailyRecurrence = DailyRecurrence.EveryWorkday, _
.StartDate = app2.StartTime, _
.EndDate = New DateTime(2011, 12, 31)}
app2.Recurrence = recurrence1

Dim recurrence2 As New Recurrence() With { _
.Pattern = RecurrencePattern.Weekly, _
.DaysOfWeek = DaysOfWeek.Monday Or DaysOfWeek.Wednesday, _
.StartDate = app3.StartTime, _
.NumOccurrences = 30}
app3.Recurrence = recurrence2

This code creates two Recurrence objects. The first Recurrence has a daily pattern with occurrences on every working day and it's end date set to a specific date. The second one has a weekly pattern with occurrences every Monday and Wednesday and will end after a specified number of occurrences is reached.

Recurrences can also be created during run-time by using the built-in RecurrenceForm. Here a snapshot of the form set to create a weekly recurrence.

4. Change displayed dates

Switch to code view and add the following code to the Page_Load event handler, right above the call of the CreateScheduleData method:

C# [image] Copy Code

DateTime startDate = DateTime.Now;
DateTime endDate = startDate.AddDays(7);

while (startDate < endDate)
{
TimetableDate date = new TimetableDate(startDate);
Calendar1.TimetableSettings.Dates.Add(date);
startDate = startDate.AddDays(1);
}

Visual Basic [image] Copy Code

Dim startDate As DateTime = DateTime.Now
Dim endDate As DateTime = startDate.AddDays(7)

While startDate < endDate
Dim [date] As New TimetableDate(startDate)
Calendar1.TimetableSettings.Dates.Add([date])
startDate = startDate.AddDays(1)
End While

This code will add six new dates to the collection of displayed dates in the Timetable.

5. Handle the SelectionEnd event

In order to change easily the displayed dates in run-time we will add another Calendar and use it as a date range selector. Add a second Calendar control to the page and set its ID to 'Calendar2', CurrentView property to SingleMonth and Theme to Vista. Set the UseForms property to false, then expand the 'ItemSettings' section and set the ShowMoreItemsCue and ItemsVisible properties to Disabled. These changes will ensure items could not be created or be visible in this calendar. Set the SelectionEndScript property to 'onSelectionEnd' - this will be the name of the JavaScript function that will handle the event. Add the event-handling code somewhere in the *.aspx file, for example after the 'onReminder' method:

JavaScript [image] Copy Code

function onSelectionEnd(sender, args) {
__doPostBack('__Page');
}

This code will postback the page every time the client-side SelectionEnd event is triggered. Once the page is posted back to the server we will be able to read the range of selected dates in the second calendar and add it as a range of displayed dates in the main calendar.
Switch to code view and add the following code in the Page_Load event handler, right after the if (!IsPostBack) block:

C# [image] Copy Code

else
{
//check if Calendar2 has any selection
if (Calendar2.Selection.Ranges.Count != 0)
{
//clear the dates
Calendar1.TimetableSettings.Dates.Clear();
//get the start and end time of the selection
DateTime startDate = Calendar2.Selection.Ranges[0];
DateTime endDate = Calendar2.Selection.Ranges[1];
//create and add the new dates to the Dates collection
while (startDate < endDate)
{
TimetableDate date = new TimetableDate(startDate);
Calendar1.TimetableSettings.Dates.Add(date);
startDate = startDate.AddDays(1);
}
}
}

Visual Basic [image] Copy Code

Else
'check if Calendar2 has any selection
If (Calendar2.Selection.Ranges.Count <> 0) Then
'clear the dates
Calendar1.TimetableSettings.Dates.Clear()
'get the start and end time of the selection
Dim startDate = Calendar2.Selection.Ranges(0)
Dim endDate = Calendar2.Selection.Ranges(1)
'create and add the new dates to the Dates collection
While (startDate < endDate)
Dim [date] As New TimetableDate(startDate)
Calendar1.TimetableSettings.Dates.Add([date])
startDate = startDate.AddDays(1)
End While
End If
End If

This code checks if there is any selected range in the second calendar, and if so creates and adds the new range of dates to the main Calendar's displayed dates collection.

6. Run the tutorial

Build and run the tutorial. The image below depicts how the output should look like:

Select arbitrary dates and date ranges in the calendar to the right to see how the displayed dates collection in the calendar to the left updates to the corresponding range.


Tutorial 4: Client events

Tutorial 4: Client events

This tutorial demonstrates how to handle client-side events.

1. Initial preparations

Follow Tutorial 1: Creating appointments on how to create a web site that contains two instances of the Calendar control and add appointments to it. Follow Tutorial 2: Filtering and grouping on how to set filtering and grouping. Follow Tutorial 3: Recurrences and reminders on how to add recurrences and reminders.

2. Handling the ItemCreating and ItemDeleting events

In the 'Properties' pane find the ItemCreatingScript and ItemDeletingScript properties and set them to 'onItemCreating' and 'onItemDeleting'. Add the corresponding functions to the JavaScript script block:

JavaScript [image] Copy Code

function onItemCreating(sender, args) {
//get the list of contacts id-s associated with the item
var contacts = args.get_item().contacts;
if (contacts && contacts.length > 0) {
//get the first contact
var contact = sender.getResourceById(contacts[0]);
//get all items
var items = sender.getItems();
//get the start and end time of the item to be created
var d1 = args.get_item().startTime.valueOf();
var d2 = args.get_item().endTime.valueOf();
//check if another, associated with this contact, item is present within the same time range
for (var i = 0, l = items.length; i < l; i++) {
var item = items[i];
var id1 = item.getStartTime().valueOf();
var id2 = item.getEndTime().valueOf();
//if another item is present display a warning and cancel the creation of the item
if ((d1 < id2) && (d2 > id1) && Array.indexOf(item.getContacts(), contact) > -1) {
alert('{0} {1} is busy at this time'.format(contact.getFirstName(), contact.getLastName()));
args.set_cancel(true);
return;
}
}
}
}

function onItemDeleting(sender, args) {
//check the subject of the item to be deleted
//display a warning and cancel the event
if (args.get_item().getSubject() == 'Meeting') {
alert('This appointment cannot be deleted!')
args.set_cancel(true);
}
}

When an item, associated with a Contact is created on the client-side it will be checked against all items, present in the Calendar. If the contact has another appointment within the same time range the event will be cancelled and no item will be created.

Upon deleting an item from the client-side the subject of the item will be checked and if it equals 'Meeting' the event will be cancelled and the item will not be deleted.

3. Handling the ItemDragEnd event

In the 'Properties' pane find the ItemDragEndScript property and set its value to 'onItemDragEnd' Add the corresponding function to the JavaScript script block:

JavaScript [image] Copy Code

function onItemDragEnd(sender, args) {
//get the list of contacts associated with the item
var contacts = args.get_item().getContacts();
if (contacts.length > 0) {
//get the first contact
var contact = contacts[0];
//get all items associated with this contact id
var items = sender.getItemsByResourceId(contact.getId());
// get the start and end time of the dragged item
var d1 = args.get_changes().startTime.valueOf();
var d2 = args.get_changes().endTime.valueOf();
//check if another, associated with this contact, item is present within the same time range
for (var i = 0, l = items.length; i < l; i++) {
var item = items[i];
var id1 = item.getStartTime().valueOf();
var id2 = item.getEndTime().valueOf();
//if another item is present display a warning and cancel the modification of the item
if ((d1 < id2) && (d2 > id1) && (Array.indexOf(item.getContacts(), contact) > -1) && (item != args.get_item())) {
alert('{0} {1} is busy at this time'.format(contact.getFirstName(), contact.getLastName()));
args.set_cancel(true);
return;
}
}
}
}

When an item, associated with a Contact is dragged on the client-side it will be checked against all items, which are associated with the same Contact. If the contact has another appointment within the same time range the event will be cancelled and the item will be returned back to its initial position.

4. Handling the HeaderClick event

In the 'Properties' pane find the TimetableColumnHeaderClickScript property and set its value to 'onHeaderClick'. Add the corresponding function to the JavaScript script block:

JavaScript [image] Copy Code

function onHeaderClick(sender, args) {
//get the resources by which the calendar is filtered
var resources = sender.getFilteredResources();
if (resources.length > 0) {
var contact = resources[0];
//get the list of all items defined in the calendar
var items = sender.getItems();
var cnt = 0;
for (var i = 0, l = items.length; i < l; i++) {
var item = items[i];
var date1 = item.getStartTime().getDate();
var date2 = item.getEndTime().getDate();
var date = args.get_date().getDate();
//check if the item is associated with the resource
if (Array.indexOf(item.getContacts(), contact) > -1) {
//increase the counter if the item is within the specified time range
if ((date1 == date) || (date2 == date) || (date1 <= date && date2 >= date)) {
cnt += 1;
}
}
}
//display the count of appointments associated with the resource
alert('{0} has {1} appointment(s) on {2}'.format(contact.getFirstName(), cnt, args.get_date().toString('dd MMMM')));
}
}

If the Calendar is currently filtered by some resource clicking on a date's header will display the number of the appointments for the corresponding resource and date range.

5. Build and run the sample

Run the web page. The image below depicts what the page output would look like when we try to delete the 'Meeting' appointment.


Tutorial 5: Styling

Tutorial 5: Styling

This tutorial shows you how to customize the visual appearance of a calendar.

1. Initial preparations

Follow the previous tutorials for detailed instructions on how to create a web site, add the control and create appointments (Tutorial 1), filter and group items (Tutorial 2), add recurrences and reminders (Tutorial 3) and handle client events (Tutorial 4).

2. Styling the Calendar

Switch to code view and add the following method:

C# [image] Copy Code

private void CustomizeBlue()
{
// Common resources
CssBorderStyle commonBorder = new CssBorderStyle()
{
BottomColor = Color.LightGray,
BottomStyle = BorderStyle.Solid,
BottomWidth = new Unit(1.0, UnitType.Pixel)
};
CssBackground commonBackground = new CssBackground()
{
Color = Color.LightSteelBlue,
};
CssBorderStyle commonHeaderBorder = new CssBorderStyle()
{
BottomColor = Color.White,
BottomStyle = BorderStyle.Solid,
TopColor = Color.MidnightBlue,
TopStyle = BorderStyle.Solid,
LeftStyle = BorderStyle.None,
AllWidth = new Unit(1.0, UnitType.Pixel),
};
CssBackground commonHeaderBackground = new CssBackground()
{
Image = "none",
Color = Color.SlateGray
};

// Get references to the calendars' settings objects.
TimetableSettings tSettings = Calendar1.TimetableSettings;
MonthSettings mSettings = Calendar2.MonthSettings;

// General styles.
Style style = tSettings.Style;
style.Borders.CopyFrom(commonBorder);
style.Brush.SetProperties(commonBackground.GetProperties());

// Main header style.
tSettings.MainHeaderStyle.Borders.CopyFrom(commonHeaderBorder);
tSettings.MainHeaderStyle.Brush.SetProperties(commonHeaderBackground.GetProperties());
tSettings.MainHeaderStyle.TextColor = Color.White;

// Transfer general style to single month view.
mSettings.Style.SetProperties(style.GetProperties());
mSettings.MainHeaderStyle.SetProperties(tSettings.MainHeaderStyle.GetProperties());

// Cell styles.
style = tSettings.CellStyle;
style.Borders.CopyFrom(commonBorder);
style.Brush.SetProperties(commonBackground.GetProperties());

// Transfer cell style to single month view.
mSettings.DaySettings.Style.SetProperties(style.GetProperties());

// Cell headers styles.
style = tSettings.HeaderCellStyle;
style.Borders.CopyFrom(commonHeaderBorder);
style.Brush.SetProperties(commonHeaderBackground.GetProperties());

// Transfer cell style to single month view.
mSettings.DaySettings.HeaderStyle.SetProperties(style.GetProperties());
mSettings.DaySettings.HeaderStyle.TextColor = Color.White;

// Timeline style.
HeaderStyle hstyle = tSettings.TimelineStyle;
hstyle.Borders.CopyFrom(new CssBorderStyle()
{
AllColor = Color.LightGray,
AllStyle = BorderStyle.Solid,
AllWidth = new Unit(1.0, UnitType.Pixel)
});
hstyle.Brush.Image = "none";
hstyle.Brush.Color = Color.SlateGray;
hstyle.TextColor = Color.White;

// Group header style.
tSettings.GroupHeaderStyle.Brush.Color = Color.SlateGray;

// Timetable work cell styles.
style = tSettings.WorkTimeCellStyle;
style.Borders.CopyFrom(commonBorder);
style.Brush.SetProperties(commonBackground.GetProperties());
style.Brush.Color = Color.SteelBlue;

// Button styles
ButtonsStyle bStyle = tSettings.ButtonStyle;
bStyle.Borders.CopyFrom(commonHeaderBorder);
bStyle.Brush.Image = "none";
bStyle.Brush.Color = Color.PapayaWhip;
mSettings.ButtonStyle.Borders.CopyFrom(bStyle.Borders);
mSettings.ButtonStyle.Brush.SetProperties(bStyle.Brush.GetProperties());
}

Visual Basic Copy Code

Private Sub CustomizeBlue()
' Common resources
Dim commonBorder As New CssBorderStyle() With { _
.BottomColor = Color.LightGray, _
.BottomStyle = BorderStyle.Solid, _
.BottomWidth = New Unit(1.0, UnitType.Pixel) _
}
Dim commonBackground As New CssBackground() With { _
.Color = Color.LightSteelBlue _
}
Dim commonHeaderBorder As New CssBorderStyle() With { _
.BottomColor = Color.White, _
.BottomStyle = BorderStyle.Solid, _
.TopColor = Color.MidnightBlue, _
.TopStyle = BorderStyle.Solid, _
.LeftStyle = BorderStyle.None, _
.AllWidth = New Unit(1.0, UnitType.Pixel) _
}
Dim commonHeaderBackground As New CssBackground() With { _
.Image = "none", _
.Color = Color.SlateGray}

' Get references to the calendars' settings objects.
Dim tSettings As TimetableSettings = Calendar1.TimetableSettings
Dim mSettings As MonthSettings = Calendar2.MonthSettings

' General styles.
Dim style As Style = tSettings.Style
style.Borders.CopyFrom(commonBorder)
style.Brush.SetProperties(commonBackground.GetProperties())

' Main header style.
tSettings.MainHeaderStyle.Borders.CopyFrom(commonHeaderBorder)
tSettings.MainHeaderStyle.Brush.SetProperties(commonHeaderBackground.GetProperties())
tSettings.MainHeaderStyle.TextColor = Color.White

' Transfer general style to single month view.
mSettings.Style.SetProperties(style.GetProperties())
mSettings.MainHeaderStyle.SetProperties(tSettings.MainHeaderStyle.GetProperties())

' Cell styles.
style = tSettings.CellStyle
style.Borders.CopyFrom(commonBorder)
style.Brush.SetProperties(commonBackground.GetProperties())

' Transfer cell style to single month view.
mSettings.DaySettings.Style.SetProperties(style.GetProperties())

' Cell headers styles.
style = tSettings.HeaderCellStyle
style.Borders.CopyFrom(commonHeaderBorder)
style.Brush.SetProperties(commonHeaderBackground.GetProperties())

' Transfer cell style to single month view.
mSettings.DaySettings.HeaderStyle.SetProperties(style.GetProperties())
mSettings.DaySettings.HeaderStyle.TextColor = Color.White

' Timeline style.
Dim hstyle As HeaderStyle = tSettings.TimelineStyle
hstyle.Borders.CopyFrom(New CssBorderStyle() With { _
.AllColor = Color.LightGray, _
.AllStyle = BorderStyle.Solid, _
.AllWidth = New Unit(1.0, UnitType.Pixel) _
})
hstyle.Brush.Image = "none"
hstyle.Brush.Color = Color.SlateGray
hstyle.TextColor = Color.White

' Group header style.
tSettings.GroupHeaderStyle.Brush.Color = Color.SlateGray

' Timetable work cell styles.
style = tSettings.WorkTimeCellStyle
style.Borders.CopyFrom(commonBorder)
style.Brush.SetProperties(commonBackground.GetProperties())
style.Brush.Color = Color.SteelBlue

' Button styles
Dim bStyle As ButtonsStyle = tSettings.ButtonStyle
bStyle.Borders.CopyFrom(commonHeaderBorder)
bStyle.Brush.Image = "none"
bStyle.Brush.Color = Color.PapayaWhip
mSettings.ButtonStyle.Borders.CopyFrom(bStyle.Borders)
mSettings.ButtonStyle.Brush.SetProperties(bStyle.Brush.GetProperties())
End Sub

The code above defines four common resources - border, background, header border and header background. These resources are distributed to the various Style properties of the Calendar to create a new look and feel of the control. The Style property is used for general styling of the Calendar view. The CellStyle property is used for styling the view's Date/Time cells. The TimelineStyle is responsible for styling the Timeline header in the Timetable view of the Calendar. The WorkTimeCellStyle is applied to the Date/Time cells which correspond to the time range, defined by WorkTimeStartHour and WorkTimeEndHour properties in TimetableSettings. The ButtonStyle property affects the navigation buttons in the header of the view.
We will add one more method for styling the Calendar in a different color palette:

C# [image] Copy Code

private void CustomizeRed()
{
// Common resources
CssBorderStyle commonBorder = new CssBorderStyle()
{
TopColor = Color.PaleVioletRed,
TopStyle = BorderStyle.Solid,
TopWidth = new Unit(1.0, UnitType.Pixel)
};
CssBackground commonBackground = new CssBackground()
{
Color = Color.Pink,
};
CssBorderStyle commonHeaderBorder = new CssBorderStyle()
{
TopColor = Color.Indigo,
TopStyle = BorderStyle.Solid,
BottomColor = Color.DeepPink,
BottomStyle = BorderStyle.Solid,
LeftStyle = BorderStyle.None,
RightStyle = BorderStyle.None,
AllWidth = new Unit(1.0, UnitType.Pixel)
};
CssBackground commonHeaderBackground = new CssBackground()
{
Image = "none",
Color = Color.DarkMagenta,
};

// Get references to the calendars' settings objects.
TimetableSettings tSettings = Calendar1.TimetableSettings;
MonthSettings mSettings = Calendar2.MonthSettings;

// General styles.
Style style = tSettings.Style;
style.Borders.CopyFrom(commonBorder);
style.Brush.SetProperties(commonBackground.GetProperties());

// Main header style.
tSettings.MainHeaderStyle.Borders.CopyFrom(commonHeaderBorder);
tSettings.MainHeaderStyle.Brush.SetProperties(commonHeaderBackground.GetProperties());
tSettings.MainHeaderStyle.TextColor = Color.White;

// Transfer general style to single month view.
mSettings.Style.SetProperties(style.GetProperties());
mSettings.MainHeaderStyle.SetProperties(tSettings.MainHeaderStyle.GetProperties());

// Cell styles.
style = tSettings.CellStyle;
style.Borders.CopyFrom(commonBorder);
style.Brush.SetProperties(commonBackground.GetProperties());

// Transfer cell style to single month view.
mSettings.DaySettings.Style.SetProperties(style.GetProperties());

// Cell headers styles.
style = tSettings.HeaderCellStyle;
style.Borders.CopyFrom(commonHeaderBorder);
style.Brush.SetProperties(commonHeaderBackground.GetProperties());

// Transfer cell style to single month view.
mSettings.DaySettings.HeaderStyle.SetProperties(style.GetProperties());
mSettings.DaySettings.HeaderStyle.TextColor = Color.White;

// Timeline style.
HeaderStyle hstyle = tSettings.TimelineStyle;
hstyle.Borders.CopyFrom(new CssBorderStyle()
{
AllColor = Color.DeepPink,
AllStyle = BorderStyle.Solid,
AllWidth = new Unit(1.0, UnitType.Pixel)
});
hstyle.Brush.Image = "none";
hstyle.Brush.Color = Color.DarkMagenta;
hstyle.TextColor = Color.White;

// Group header style.
tSettings.GroupHeaderStyle.Brush.Color = Color.DarkMagenta;

// Timetable work cell styles.
style = tSettings.WorkTimeCellStyle;
style.Borders.CopyFrom(commonBorder);
style.Brush.SetProperties(commonBackground.GetProperties());
style.Brush.Color = Color.Plum;

// Button styles
ButtonsStyle bStyle = tSettings.ButtonStyle;
bStyle.Brush.Image = "none";
bStyle.Brush.Color = Color.DarkMagenta;
mSettings.ButtonStyle.Borders.CopyFrom(bStyle.Borders);
mSettings.ButtonStyle.Brush.SetProperties(bStyle.Brush.GetProperties());
}

Visual Basic Copy Code

Private Sub CustomizeRed()
' Common resources
Dim commonBorder As New CssBorderStyle() With { _
.TopColor = Color.PaleVioletRed, _
.TopStyle = BorderStyle.Solid, _
.TopWidth = New Unit(1.0, UnitType.Pixel) _
}
Dim commonBackground As New CssBackground() With { _
.Color = Color.Pink _
}
Dim commonHeaderBorder As New CssBorderStyle() With { _
.TopColor = Color.Indigo, _
.TopStyle = BorderStyle.Solid, _
.BottomColor = Color.DeepPink, _
.BottomStyle = BorderStyle.Solid, _
.LeftStyle = BorderStyle.None, _
.RightStyle = BorderStyle.None, _
.AllWidth = New Unit(1.0, UnitType.Pixel) _
}
Dim commonHeaderBackground As New CssBackground() With { _
.Image = "none", _
.Color = Color.DarkMagenta _
}

' Get references to the calendars' settings objects.
Dim tSettings As TimetableSettings = Calendar1.TimetableSettings
Dim mSettings As MonthSettings = Calendar2.MonthSettings

' General styles.
Dim style As Style = tSettings.Style
style.Borders.CopyFrom(commonBorder)
style.Brush.SetProperties(commonBackground.GetProperties())

' Main header style.
tSettings.MainHeaderStyle.Borders.CopyFrom(commonHeaderBorder)
tSettings.MainHeaderStyle.Brush.SetProperties(commonHeaderBackground.GetProperties())
tSettings.MainHeaderStyle.TextColor = Color.White

' Transfer general style to single month view.
mSettings.Style.SetProperties(style.GetProperties())
mSettings.MainHeaderStyle.SetProperties(tSettings.MainHeaderStyle.GetProperties())

' Cell styles.
style = tSettings.CellStyle
style.Borders.CopyFrom(commonBorder)
style.Brush.SetProperties(commonBackground.GetProperties())

' Transfer cell style to single month view.
mSettings.DaySettings.Style.SetProperties(style.GetProperties())

' Cell headers styles.
style = tSettings.HeaderCellStyle
style.Borders.CopyFrom(commonHeaderBorder)
style.Brush.SetProperties(commonHeaderBackground.GetProperties())

' Transfer cell style to single month view.
mSettings.DaySettings.HeaderStyle.SetProperties(style.GetProperties())
mSettings.DaySettings.HeaderStyle.TextColor = Color.White

' Timeline style.
Dim hstyle As HeaderStyle = tSettings.TimelineStyle
hstyle.Borders.CopyFrom(New CssBorderStyle() With { _
.AllColor = Color.DeepPink, _
.AllStyle = BorderStyle.Solid, _
.AllWidth = New Unit(1.0, UnitType.Pixel) _
})
hstyle.Brush.Image = "none"
hstyle.Brush.Color = Color.DarkMagenta
hstyle.TextColor = Color.White

' Group header style.
tSettings.GroupHeaderStyle.Brush.Color = Color.DarkMagenta

' Timetable work cell styles.
style = tSettings.WorkTimeCellStyle
style.Borders.CopyFrom(commonBorder)
style.Brush.SetProperties(commonBackground.GetProperties())
style.Brush.Color = Color.Plum

' Button styles
Dim bStyle As ButtonsStyle = tSettings.ButtonStyle
bStyle.Brush.Image = "none"
bStyle.Brush.Color = Color.DarkMagenta
mSettings.ButtonStyle.Borders.CopyFrom(bStyle.Borders)
mSettings.ButtonStyle.Brush.SetProperties(bStyle.Brush.GetProperties())
End Sub

3. Styling calendar items

Calendar items, as well as the views can be styled in a number of ways: by using ItemSettings.Style property, by assigning a particular css class name to the Appointment's CssClass property or by defining css classes the different item visual elements.

3.1 Styling items through the ItemSettings.Style property

Setting the ItemSettings.Style property will affect all items, including the newly created items on the client-side. You can override the style set through this property for specific items by modifying their CssClass property.
Switch to code view and add the following method to the page code:

C# [image] Copy Code

private void CustomizeItems()
{
ItemSettings settings = Calendar1.ItemSettings;
settings.Style.Borders.CopyFrom(new CssBorderStyle()
{
AllColor = Color.DimGray,
AllStyle = BorderStyle.Double,
AllWidth = new Unit(1.0, UnitType.Pixel)
});
settings.Style.TextColor = Color.White;
settings.Style.HeaderTextColor = Color.White;
}

Visual Basic [image] Copy Code

Private Sub CustomizeItems()
Dim settings As ItemSettings = Calendar1.ItemSettings
settings.Style.Borders.CopyFrom(New CssBorderStyle() With { _
.AllColor = Color.DimGray, _
.AllStyle = BorderStyle.[Double], _
.AllWidth = New Unit(1.0, UnitType.Pixel) _
})
settings.Style.TextColor = Color.White
settings.Style.HeaderTextColor = Color.White
End Sub

The code above creates a new style for items' border, text color and header text color.

3.2 Styling items by setting the CssClass property

In the CreateScheduleData method set the CssClass property of the defined items as follows:

C# [image] Copy Code
app1.CssClass = "blue";
app2.CssClass = "blue";
app3.CssClass = "red";
app4.CssClass = "red";

Visual Basic [image] Copy Code

app1.CssClass = "blue"
app2.CssClass = "blue"
app3.CssClass = "red"
app4.CssClass = "red"

The value of the CssClass property should be the name of a valid CSS class defined within the website. To define the 'blue' and 'red' CSS classes switch to HTML view and add the following CSS declarations between the <head> opening and closing tags:

CSS [image] Copy Code

<style type="text/css">

.blue .wrapper,
.blue .frame
{
background: none #003366 !important;
}
.red .wrapper,
.red .frame
{
background: none #990066 !important;
}

</style>

The code above defines two CSS classes, namely 'blue' and 'red'. After setting these names as a value of the CssClass property, the items with the 'blue' CssClass will be painted dark-blue, and the items with the 'red' CssClass will be painted purple.

Finally, calls to the customization methods should be added to the pages' code. Switch to code view and add the following method:

C# [image] Copy Code

private void Customize()
{
if (lbContacts.SelectedIndex == 0)
CustomizeBlue();
else
CustomizeRed();
CustomizeItems();
}

Visual Basic [image] Copy Code

Private Sub Customize()
If lbContacts.SelectedIndex = 0 Then
CustomizeBlue()
Else
CustomizeRed()
End If
CustomizeItems()
End Sub

Also, add a call to the Customize method at the end of the Page_Load event handler.

4. Build and run

Build and run the sample. The image below depicts what the output should look like:

Try changing the contact by which the Calendar is filtered to see how the corresponding styles will be applied to both calendars.


Reference

Reference


Client Side Reference

Client Side Reference


MindFusion.Common Namespace

MindFusion.Common Namespace
Classes

Classes

Class | Description
DateTime | A JavaScript Date object wrapper that extends the functionality of the JavaScript Date object. It has all the capabilities of the Date class, plus it adds several helper methods to manipulate its date and time components. All date and time objects in the calendar are represented by this class.
Dictionary | Represents a collection of keys and values.
IdGenerator | A unique id generator.


MindFusion.Common.DateTime Class

DateTime Class
Remarks See Also
[image]

A JavaScript Date object wrapper that extends the functionality of the JavaScript Date object. It has all the capabilities of the Date class, plus it adds several helper methods to manipulate its date and time components.
All date and time objects in the calendar are represented by this class.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

// class
DateTime.prototype = {}

Remarks

The functionality of the inner JavaScript Date object is accessible through the __functionName methods.

See Also

DateTime Members
MindFusion.Common Namespace


MindFusion.Common.DateTime Members

DateTime Members
Constructors Methods
[image]

A JavaScript Date object wrapper that extends the functionality of the JavaScript Date object. It has all the capabilities of the Date class, plus it adds several helper methods to manipulate its date and time components.
All date and time objects in the calendar are represented by this class.

The following tables list the members exposed by the DateTime type.

Public Constructors

Name | Description
DateTime | Initializes a new instance of the DateTime class.

Public Methods

Name | Description
__getDate | Gets the day component of this DateTime instance.
__getDay | Gets the day of the week component of this DateTime instance.
__getFullYear | Gets the year component of this DateTime instance.
__getHours | Gets the hours component of this DateTime instance.
__getMilliseconds | Gets the milliseconds component of this DateTime instance.
__getMinutes | Gets the minutes component of this DateTime instance.
__getMonth | Gets the month component of this DateTime instance.
__getSeconds | Gets the seconds component of this DateTime instance.
__getTime | Gets the number of milliseconds between Jan 1 1970 00:00:00 and this DateTime instance.
__getTimezoneOffset | Gets the difference between GMT and local time in minutes.
__getUTCDate | Gets the day component of this DateTime instance, according to universal time.
__getUTCDay | Gets the day of the week component of this DateTime instance, according to universal time.
__getUTCFullYear | Gets the year component of this DateTime instance, according to universal time.
__getUTCHours | Gets the hours component of this DateTime instance, according to universal time.
__getUTCMilliseconds | Gets the milliseconds component of this DateTime instance, according to universal time.
__getUTCMinutes | Gets the minutes component of this DateTime instance, according to universal time.
__getUTCMonth | Gets the month component of this DateTime instance, according to universal time.
__getUTCSeconds | Gets the seconds component of this DateTime instance, according to universal time.
__setDate | Sets the day component of this DateTime instance.
__setFullYear | Sets the year component of this DateTime instance.
__setHours | Sets the hours component of this DateTime instance.
__setMilliseconds | Sets the milliseconds component of this DateTime instance.
__setMinutes | Sets the minutes component of this DateTime instance.
__setSeconds | Sets the seconds component of this DateTime instance.
__setTime | Sets a date and time by adding or subtracting a specified number of milliseconds to/from midnight 1 Jan 1970.
__setUTCDate | Sets the day component of this DateTime instance, according to universal time.
__setUTCFullYear | Sets the year component of this DateTime instance, according to universal time.
__setUTCHours | Sets the hours component of this DateTime instance, according to universal time.
__setUTCMilliseconds | Sets the milliseconds component of this DateTime instance, according to universal time.
__setUTCMinutes | Sets the minutes component of this DateTime instance, according to universal time.
__setUTCSeconds | Sets the seconds component of this DateTime instance, according to universal time.
__toDateString | Converts the date component of this DateTime instance to a readable string.
__toLocaleDateString | Converts the date component of this DateTime instance to a readable string, using locale conventions.
__toLocaleString | Converts this DateTime instance to a readable string, using locale conventions.
__toLocaleTimeString | Converts the time component of this DateTime instance to a readable string, using locale conventions.
__toString | Converts this DateTime instance to a readable string.
__toTimeString | Converts the time component of this DateTime instance to a readable string.
__toUTCString | Converts this DateTime instance to a readable string, according to universal time.
addDays | Adds the specified number of days to the current DateTime object.
addHours | Adds the specified number of hours to the current DateTime object.
addMilliseconds | Adds the specified number of milliseconds to the current DateTime object.
addMinutes | Adds the specified number of minutes to the current DateTime object.
addMonths | Adds the specified number of months to the current DateTime object.
addSeconds | Adds the specified number of seconds to the current DateTime object.
clone | Returns a copy of the current DateTime object.
combine | Combines the date component of a DateTime object and the time component of another DateTime object into a new DateTime object.
compareTo | Compares the current DateTime instance with another DateTime object and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
equals | Checks if the values of two DateTime objects are equal.
fromDateParts | Creates a new DateTime object, by specifying its different date and time components.
fromDateString | Creates a new DateTime object from a provided date string.
fromMilliseconds | Creates a new DateTime object from the number of milliseconds since Jan 1st 1970.
getDate | Returns the JavaScript Date object, corresponding to the current DateTime object.
maxDate | Returns the latter of two DateTime objects.
maxValue | Returns the highest possible DateTime value.
minDate | Returns the former of two DateTime objects.
minValue | Returns the lowest possible DateTime value.
now | Returns a DateTime object representing the current DateTime.
today | Returns a DateTime object representing the current Date.
toString | Returns a string representation of the current DateTime object.

See Also

DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime Constructor

DateTime Constructor
See Also
[image]

Initializes a new instance of the DateTime class.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function DateTime ([date])

Parameters

date
Optional.
Type: Object
A JavaScript Date object.

Example

JavaScript [image] Copy Code

// create the Date object
var date = new Date();
// create the DateTime object
var dt = new MindFusion.Common.DateTime(date);

See Also

DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime Methods

DateTime Methods
[image]

Public Methods

Name | Description
__getDate | Gets the day component of this DateTime instance.
__getDay | Gets the day of the week component of this DateTime instance.
__getFullYear | Gets the year component of this DateTime instance.
__getHours | Gets the hours component of this DateTime instance.
__getMilliseconds | Gets the milliseconds component of this DateTime instance.
__getMinutes | Gets the minutes component of this DateTime instance.
__getMonth | Gets the month component of this DateTime instance.
__getSeconds | Gets the seconds component of this DateTime instance.
__getTime | Gets the number of milliseconds between Jan 1 1970 00:00:00 and this DateTime instance.
__getTimezoneOffset | Gets the difference between GMT and local time in minutes.
__getUTCDate | Gets the day component of this DateTime instance, according to universal time.
__getUTCDay | Gets the day of the week component of this DateTime instance, according to universal time.
__getUTCFullYear | Gets the year component of this DateTime instance, according to universal time.
__getUTCHours | Gets the hours component of this DateTime instance, according to universal time.
__getUTCMilliseconds | Gets the milliseconds component of this DateTime instance, according to universal time.
__getUTCMinutes | Gets the minutes component of this DateTime instance, according to universal time.
__getUTCMonth | Gets the month component of this DateTime instance, according to universal time.
__getUTCSeconds | Gets the seconds component of this DateTime instance, according to universal time.
__setDate | Sets the day component of this DateTime instance.
__setFullYear | Sets the year component of this DateTime instance.
__setHours | Sets the hours component of this DateTime instance.
__setMilliseconds | Sets the milliseconds component of this DateTime instance.
__setMinutes | Sets the minutes component of this DateTime instance.
__setSeconds | Sets the seconds component of this DateTime instance.
__setTime | Sets a date and time by adding or subtracting a specified number of milliseconds to/from midnight 1 Jan 1970.
__setUTCDate | Sets the day component of this DateTime instance, according to universal time.
__setUTCFullYear | Sets the year component of this DateTime instance, according to universal time.
__setUTCHours | Sets the hours component of this DateTime instance, according to universal time.
__setUTCMilliseconds | Sets the milliseconds component of this DateTime instance, according to universal time.
__setUTCMinutes | Sets the minutes component of this DateTime instance, according to universal time.
__setUTCSeconds | Sets the seconds component of this DateTime instance, according to universal time.
__toDateString | Converts the date component of this DateTime instance to a readable string.
__toLocaleDateString | Converts the date component of this DateTime instance to a readable string, using locale conventions.
__toLocaleString | Converts this DateTime instance to a readable string, using locale conventions.
__toLocaleTimeString | Converts the time component of this DateTime instance to a readable string, using locale conventions.
__toString | Converts this DateTime instance to a readable string.
__toTimeString | Converts the time component of this DateTime instance to a readable string.
__toUTCString | Converts this DateTime instance to a readable string, according to universal time.
addDays | Adds the specified number of days to the current DateTime object.
addHours | Adds the specified number of hours to the current DateTime object.
addMilliseconds | Adds the specified number of milliseconds to the current DateTime object.
addMinutes | Adds the specified number of minutes to the current DateTime object.
addMonths | Adds the specified number of months to the current DateTime object.
addSeconds | Adds the specified number of seconds to the current DateTime object.
clone | Returns a copy of the current DateTime object.
combine | Combines the date component of a DateTime object and the time component of another DateTime object into a new DateTime object.
compareTo | Compares the current DateTime instance with another DateTime object and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
equals | Checks if the values of two DateTime objects are equal.
fromDateParts | Creates a new DateTime object, by specifying its different date and time components.
fromDateString | Creates a new DateTime object from a provided date string.
fromMilliseconds | Creates a new DateTime object from the number of milliseconds since Jan 1st 1970.
getDate | Returns the JavaScript Date object, corresponding to the current DateTime object.
maxDate | Returns the latter of two DateTime objects.
maxValue | Returns the highest possible DateTime value.
minDate | Returns the former of two DateTime objects.
minValue | Returns the lowest possible DateTime value.
now | Returns a DateTime object representing the current DateTime.
today | Returns a DateTime object representing the current Date.
toString | Returns a string representation of the current DateTime object.

See Also

DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getDate Method

DateTime.__getDate Method
[image]

Gets the day component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getDate ()

Return Value

Type: Number
The day of month (1-31).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getDay Method

DateTime.__getDay Method
[image]

Gets the day of the week component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getDay ()

Return Value

Type: Number
The day of the week (0-6). 0 is Sunday, 1 is Monday, etc.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getFullYear Method

DateTime.__getFullYear Method
[image]

Gets the year component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getFullYear ()

Return Value

Type: Number
The year (four digits).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getHours Method

DateTime.__getHours Method
[image]

Gets the hours component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getHours ()

Return Value

Type: Number
The hours (0-23).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getMilliseconds Method

DateTime.__getMilliseconds Method
[image]

Gets the milliseconds component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getMilliseconds ()

Return Value

Type: Number
The milliseconds (0-999).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getMinutes Method

DateTime.__getMinutes Method
[image]

Gets the minutes component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getMinutes ()

Return Value

Type: Number
The minutes (0-59).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getMonth Method

DateTime.__getMonth Method
[image]

Gets the month component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getMonth ()

Return Value

Type: Number
The month (0-11). 0 is January, 1 is February, etc.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getSeconds Method

DateTime.__getSeconds Method
[image]

Gets the seconds component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getSeconds ()

Return Value

Type: Number
The seconds (0-59).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getTime Method

DateTime.__getTime Method
[image]

Gets the number of milliseconds between Jan 1 1970 00:00:00 and this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getTime ()

Return Value

Type: Number
The number of milliseconds since Jan 1 1970 00:00:00.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getTimezoneOffset Method

DateTime.__getTimezoneOffset Method
[image]

Gets the difference between GMT and local time in minutes.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getTimezoneOffset ()

Return Value

Type: Number
The difference between GMT and local time in minutes.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getUTCDate Method

DateTime.__getUTCDate Method
[image]

Gets the day component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getUTCDate ()

Return Value

Type: Number
The day of month (1-31).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getUTCDay Method

DateTime.__getUTCDay Method
[image]

Gets the day of the week component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getUTCDay ()

Return Value

Type: Number
The day of the week (0-6). 0 is Sunday, 1 is Monday, etc.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getUTCFullYear Method

DateTime.__getUTCFullYear Method
[image]

Gets the year component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getUTCFullYear ()

Return Value

Type: Number
The year (four digits).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getUTCHours Method

DateTime.__getUTCHours Method
[image]

Gets the hours component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getUTCHours ()

Return Value

Type: Number
The hours (0-23).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getUTCMilliseconds Method

DateTime.__getUTCMilliseconds Method
[image]

Gets the milliseconds component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getUTCMilliseconds ()

Return Value

Type: Number
The milliseconds (0-999).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getUTCMinutes Method

DateTime.__getUTCMinutes Method
[image]

Gets the minutes component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getUTCMinutes ()

Return Value

Type: Number
The minutes (0-59).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getUTCMonth Method

DateTime.__getUTCMonth Method
[image]

Gets the month component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getUTCMonth ()

Return Value

Type: Number
The month (0-11). 0 is January, 1 is February, etc.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__getUTCSeconds Method

DateTime.__getUTCSeconds Method
[image]

Gets the seconds component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __getUTCSeconds ()

Return Value

Type: Number
The seconds (0-59).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setDate Method

DateTime.__setDate Method
[image]

Sets the day component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setDate (day)

Parameters

day

Type: Number
The day of month (1-31).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setFullYear Method

DateTime.__setFullYear Method
[image]

Sets the year component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setFullYear (year, [month, [day]])

Parameters

year

Type: Number
A four-digit value representing the year.

month
Optional.

Type: Number
An integer between 0 and 11 representing the month.

day
Optional.

Type: Number
An integer between 1 and 31 representing the date.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setHours Method

DateTime.__setHours Method
[image]

Sets the hours component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setHours (hour, [min, [sec, [millisec]]])

Parameters

hour

Type: Number
An integer between 0 and 23 representing the hour.

min
Optional.

Type: Number
An integer between 0 and 59 representing the minutes.

sec
Optional.

Type: Number
An integer between 0 and 59 representing the seconds.

millisec
Optional.

Type: Number
An integer between 0 and 999 representing the milliseconds.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setMilliseconds Method

DateTime.__setMilliseconds Method
[image]

Sets the milliseconds component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setMilliseconds (millisec)

Parameters

millisec

Type: Number
An integer between 0 and 999 representing the milliseconds.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setMinutes Method

DateTime.__setMinutes Method
[image]

Sets the minutes component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setMinutes (min, [sec, [millisec]])

Parameters

min

Type: Number
An integer between 0 and 59 representing the minutes.

sec
Optional.

Type: Number
An integer between 0 and 59 representing the seconds.

millisec
Optional.

Type: Number
An integer between 0 and 999 representing the milliseconds.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setSeconds Method

DateTime.__setSeconds Method
[image]

Sets the seconds component of this DateTime instance.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setSeconds (sec, [millisec])

Parameters

sec

Type: Number
An integer between 0 and 59 representing the seconds.

millisec
Optional.

Type: Number
An integer between 0 and 999 representing the milliseconds.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setTime Method

DateTime.__setTime Method
[image]

Sets a date and time by adding or subtracting a specified number of milliseconds to/from midnight 1 Jan 1970.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setTime (millisec)

Parameters

millisec

Type: Number
The number of milliseconds to be added to, or subtracted from, midnight 1 Jan 1970.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setUTCDate Method

DateTime.__setUTCDate Method
[image]

Sets the day component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setUTCDate (day)

Parameters

day

Type: Number
The day of month (1-31).

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setUTCFullYear Method

DateTime.__setUTCFullYear Method
[image]

Sets the year component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setUTCFullYear (year, [month, [day]])

Parameters

year

Type: Number
A four-digit value representing the year.

month
Optional.

Type: Number
An integer between 0 and 11 representing the month.

day
Optional.

Type: Number
An integer between 1 and 31 representing the date.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setUTCHours Method

DateTime.__setUTCHours Method
[image]

Sets the hours component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setUTCHours (hour, [min, [sec, [millisec]]])

Parameters

hour

Type: Number
An integer between 0 and 23 representing the hour.

min
Optional.

Type: Number
An integer between 0 and 59 representing the minutes.

sec
Optional.

Type: Number
An integer between 0 and 59 representing the seconds.

millisec
Optional.

Type: Number
An integer between 0 and 999 representing the milliseconds.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setUTCMilliseconds Method

DateTime.__setUTCMilliseconds Method
[image]

Sets the milliseconds component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setUTCMilliseconds (millisec)

Parameters

millisec

Type: Number
An integer between 0 and 999 representing the milliseconds.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setUTCMinutes Method

DateTime.__setUTCMinutes Method
[image]

Sets the minutes component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setUTCMinutes (min, [sec, [millisec]])

Parameters

min

Type: Number
An integer between 0 and 59 representing the minutes.

sec
Optional.

Type: Number
An integer between 0 and 59 representing the seconds.

millisec
Optional.

Type: Number
An integer between 0 and 999 representing the milliseconds.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__setUTCSeconds Method

DateTime.__setUTCSeconds Method
[image]

Sets the seconds component of this DateTime instance, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __setUTCSeconds (sec, [millisec])

Parameters

sec

Type: Number
An integer between 0 and 59 representing the seconds.

millisec
Optional.

Type: Number
An integer between 0 and 999 representing the milliseconds.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__toDateString Method

DateTime.__toDateString Method
[image]

Converts the date component of this DateTime instance to a readable string.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __toDateString ()

Return Value

Type: String
A readable string representation of the date component of this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__toLocaleDateString Method

DateTime.__toLocaleDateString Method
[image]

Converts the date component of this DateTime instance to a readable string, using locale conventions.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __toLocaleDateString ()

Return Value

Type: String
A readable locale string representation of the date component of this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__toLocaleString Method

DateTime.__toLocaleString Method
[image]

Converts this DateTime instance to a readable string, using locale conventions.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __toLocaleString ()

Return Value

Type: String
A readable locale string representation of this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__toLocaleTimeString Method

DateTime.__toLocaleTimeString Method
[image]

Converts the time component of this DateTime instance to a readable string, using locale conventions.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __toLocaleTimeString ()

Return Value

Type: String
A readable locale string representation of the time component of this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__toString Method

DateTime.__toString Method
[image]

Converts this DateTime instance to a readable string.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __toString ()

Return Value

Type: String
A readable string representation of this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__toTimeString Method

DateTime.__toTimeString Method
[image]

Converts the time component of this DateTime instance to a readable string.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __toTimeString ()

Return Value

Type: String
A readable string representation of the time component of this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.__toUTCString Method

DateTime.__toUTCString Method
[image]

Converts this DateTime instance to a readable string, according to universal time.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function __toUTCString ()

Return Value

Type: String
A readable string representation of this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.addDays Method

DateTime.addDays Method
[image]

Adds the specified number of days to the current DateTime object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function addDays (days)

Parameters

days

Type: Number
The number of days to add.

Remarks

This function modifies this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.addHours Method

DateTime.addHours Method
[image]

Adds the specified number of hours to the current DateTime object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function addHours (hours)

Parameters

hours

Type: Number
The number of hours to add.

Remarks

This function modifies this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.addMilliseconds Method

DateTime.addMilliseconds Method
[image]

Adds the specified number of milliseconds to the current DateTime object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function addMilliseconds (milliseconds)

Parameters

milliseconds

Type: Number
The number of milliseconds to add.

Remarks

This function modifies this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.addMinutes Method

DateTime.addMinutes Method
[image]

Adds the specified number of minutes to the current DateTime object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function addMinutes (minutes)

Parameters

minutes

Type: Number
The number of minutes to add.

Remarks

This function modifies this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.addMonths Method

DateTime.addMonths Method
[image]

Adds the specified number of months to the current DateTime object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function addMonths (months)

Parameters

months

Type: Number
The number of months to add.

Remarks

This function modifies this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.addSeconds Method

DateTime.addSeconds Method
[image]

Adds the specified number of seconds to the current DateTime object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function addSeconds (seconds)

Parameters

seconds

Type: Number
The number of seconds to add.

Remarks

This function modifies this DateTime instance.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.clone Method

DateTime.clone Method
[image]

Returns a copy of the current DateTime object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function clone ()

Return Value

Type: DateTime
The cloned DateTime object.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.combine Method

DateTime.combine Method
[image]

Combines the date component of a DateTime object and the time component of another DateTime object into a new DateTime object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function combine (date, time)

Parameters

date

Type: DateTime
A DateTime object to get the date part from.

time

Type: DateTime
A DateTime object to get the time part from.

Return Value

Type: DateTime
The new combined DateTime object.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.compareTo Method

DateTime.compareTo Method
[image]

Compares the current DateTime instance with another DateTime object and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function compareTo (dateTime)

Parameters

dateTime

Type: DateTime
A DateTime object to compare with this instance.

Return Value

Type: Number
A value that indicates the relative order of the DateTime objects being compared.

Remarks

The return value has these meanings:
-1 - This instance precedes dateTime in the sort order.
0 - This instance occurs in the same position in the sort order as dateTime.
1 - This instance follows dateTime in the sort order.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.equals Method

DateTime.equals Method
[image]

Checks if the values of two DateTime objects are equal.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function equals (date)

Parameters

date

Type: DateTime
The DateTime object to compare with.

Return Value

Type: Boolean
True if the values are equal, otherwise false.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.fromDateParts Method

DateTime.fromDateParts Method
[image]

Creates a new DateTime object, by specifying its different date and time components.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function fromDateParts (year, month, [day, [hours, [minutes, [seconds, [milliseconds]]]]])

Parameters

year

Type: Number
The year component.

month

Type: Number
The month component (0-11).

day
Optional.

Type: Number
The day component (1-31). If not provided, a default value of 1 will be used.

hours
Optional.

Type: Number
The hours component (0-23). If not provided, a default value of 0 will be used.

minutes
Optional.

Type: Number
The minutes component (0-59). If not provided, a default value of 0 will be used.

seconds
Optional.

Type: Number
The seconds component (0-59). If not provided, a default value of 0 will be used.

milliseconds
Optional.

Type: Number
The milliseconds component (0-999). If not provided, a default value of 0 will be used.

Return Value

Type: DateTime
The new DateTime object.

Remarks

If a DateTime object was not possible to be created from the provided arguments, the return value will be null.

Example

JavaScript [image] Copy Code

// Creates a new DateTime object, representing 4th July 2011 at 4:30PM.
var dateTime = MindFusion.Common.DateTime.fromDateParts(2011,6,4,16,30,0);

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.fromDateString Method

DateTime.fromDateString Method
[image]

Creates a new DateTime object from a provided date string.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function fromDateString (dateString)

Parameters

dateString

Type: String
The date string to create the DateTime from.

Return Value

Type: DateTime
The new DateTime object.

Remarks

If a DateTime object was not possible to be created from the provided argument, the return value will be null.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.fromMilliseconds Method

DateTime.fromMilliseconds Method
[image]

Creates a new DateTime object from the number of milliseconds since Jan 1st 1970.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function fromMilliseconds (milliseconds)

Parameters

milliseconds

Type: Number
The number of milliseconds since Jan 1st 1970;

Return Value

Type: DateTime
The new DateTime object.

Remarks

If a DateTime object was not possible to be created from the provided argument, the return value will be null.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.getDate Method

DateTime.getDate Method
[image]

Returns the JavaScript Date object, corresponding to the current DateTime object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function getDate ()

Return Value

Type: Object
The JavaScript Date object, corresponding to the current DateTime object.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.maxDate Method

DateTime.maxDate Method
[image]

Returns the latter of two DateTime objects.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function maxDate (date1, date2)

Parameters

date1

Type: DateTime
A DateTime object.

date2

Type: DateTime
A DateTime object.

Return Value

Type: DateTime
The latter of two DateTime objects.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.maxValue Method

DateTime.maxValue Method
[image]

Returns the highest possible DateTime value.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function maxValue ()

Return Value

Type: DateTime
The highest possible DateTime value.

Remarks

Represents 31 Dec 9999 23:59:59.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.minDate Method

DateTime.minDate Method
[image]

Returns the former of two DateTime objects.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function minDate (date1, date2)

Parameters

date1

Type: DateTime
A DateTime object.

date2

Type: DateTime
A DateTime object.

Return Value

Type: DateTime
The former of two DateTime objects.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.minValue Method

DateTime.minValue Method
[image]

Returns the lowest possible DateTime value.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function minValue ()

Return Value

Type: DateTime
The lowest possible DateTime value.

Remarks

Represents 1 Jan 0001 00:00:00.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.now Method

DateTime.now Method
[image]

Returns a DateTime object representing the current DateTime.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function now ()

Return Value

Type: DateTime
The DateTime object representing the current DateTime.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.today Method

DateTime.today Method
[image]

Returns a DateTime object representing the current Date.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function today ()

Return Value

Type: DateTime
The DateTime object representing the current Date.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.DateTime.toString Method

DateTime.toString Method
[image]

Returns a string representation of the current DateTime object.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function toString ([format, [culture]])

Parameters

format
Optional.

Type: String
The DateTime format used for the string representation.

culture
Optional.

Type: Object
The culture object used for the string representation.

Return Value

Type: String
The string representation of the current DateTime object.

See Also

DateTime Members
DateTime Class
MindFusion.Common Namespace


MindFusion.Common.Dictionary Class

Dictionary Class
[image]

Represents a collection of keys and values.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

// class
Dictionary.prototype = {}

See Also

Dictionary Members
MindFusion.Common Namespace


MindFusion.Common.Dictionary Members

Dictionary Members
Constructors Methods
[image]

Represents a collection of keys and values.

The following tables list the members exposed by the Dictionary type.

Public Constructors

Name | Description
Dictionary | Initializes a new instance of the Dictionary class.

Public Methods

Name | Description
contains | Determines whether an element with the specified key exists in the Dictionary.
get | Gets the value with the specified key.
keys | Gets an Array with all keys present in the Dictionary.
remove | Removes the element with the specified key from the Dictionary.
set | Adds the specified key and value to the dictionary.

See Also

Dictionary Class
MindFusion.Common Namespace


MindFusion.Common.Dictionary Constructor

Dictionary Constructor
[image]

Initializes a new instance of the Dictionary class.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function Dictionary ()

See Also

Dictionary Class
MindFusion.Common Namespace


MindFusion.Common.Dictionary Methods

Dictionary Methods
[image]

Public Methods

Name | Description
contains | Determines whether an element with the specified key exists in the Dictionary.
get | Gets the value with the specified key.
keys | Gets an Array with all keys present in the Dictionary.
remove | Removes the element with the specified key from the Dictionary.
set | Adds the specified key and value to the dictionary.

See Also

Dictionary Class
MindFusion.Common Namespace


MindFusion.Common.Dictionary.contains Method

Dictionary.contains Method
[image]

Determines whether an element with the specified key exists in the Dictionary.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function contains (key)

Parameters

key

Type: Number, String, Object
The key of the element.

Return Value

Type: Boolean
Returns true if an element with the specified key is found, false otherwise.

See Also

Dictionary Members
Dictionary Class
MindFusion.Common Namespace


MindFusion.Common.Dictionary.get Method

Dictionary.get Method
[image]

Gets the value with the specified key.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function get (key)

Parameters

key

Type: Number, String, Object
The key of the element to get.

Return Value

Type: Object
The value of the element with the specified key.

Remarks

If no element with the specified key is found, exception will be thrown. If you are not sure that the element is contained in the dictionary, use the contains(key) function.

See Also

Dictionary Members
Dictionary Class
MindFusion.Common Namespace


MindFusion.Common.Dictionary.keys Method

Dictionary.keys Method
[image]

Gets an Array with all keys present in the Dictionary.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function keys ()

Return Value

Type: Array
An Array with all keys present in the Dictionary.

See Also

Dictionary Members
Dictionary Class
MindFusion.Common Namespace


MindFusion.Common.Dictionary.remove Method

Dictionary.remove Method
[image]

Removes the element with the specified key from the Dictionary.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function remove (key)

Parameters

key

Type: Number, String, Object
The key of the element to remove.

Return Value

Type: Object
The value of the removed element. Null if the element was not found.

See Also

Dictionary Members
Dictionary Class
MindFusion.Common Namespace


MindFusion.Common.Dictionary.set Method

Dictionary.set Method
[image]

Adds the specified key and value to the dictionary.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function set (key, value)

Parameters

key

Type: Number, String, Object
The key of the element to add.

value

Type: Object
The value of the element to add.

Remarks

If a value with this key is already present in the collection, it is replaced by the new value. The key can be a Number, a String or an Object. If other type is passed as key, exception will be thrown.

See Also

Dictionary Members
Dictionary Class
MindFusion.Common Namespace


MindFusion.Common.IdGenerator Class

IdGenerator Class
[image]

A unique id generator.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

// class
IdGenerator.prototype = {}

See Also

IdGenerator Members
MindFusion.Common Namespace


MindFusion.Common.IdGenerator Members

IdGenerator Members
Constructors
[image]

A unique id generator.

The following tables list the members exposed by the IdGenerator type.

Public Constructors

Name | Description
IdGenerator | Initializes a new instance of the IdGenerator class.

See Also

IdGenerator Class
MindFusion.Common Namespace


MindFusion.Common.IdGenerator Constructor

IdGenerator Constructor
[image]

Initializes a new instance of the IdGenerator class.

Namespace: MindFusion.Common
Assembly: Common.js

Syntax

JavaScript [image] Copy Code

function IdGenerator ([prefix])

Parameters

prefix
Optional.

Type: String
A prefix to insert at the beginning of the identifier.

See Also

IdGenerator Class
MindFusion.Common Namespace


MindFusion.Scheduling Namespace

MindFusion.Scheduling Namespace
Classes Enumerations

Classes

Class | Description
BaseForm | The BaseForm class is the base class for all built-in forms.
Calendar | The Calendar class.
CellEventArgs | Contains the arguments passed to handlers of the DateMouseUp, DateMouseDown, DateClick, DateDoubleClick and hidden items cue related event.
Contact | Instances of the Contact class contain contact information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.
EditForm | The EditForm class represents a built-in form for items editing.
FormEventArgs | Contains the arguments passed to handlers of the FormShow event.
HeaderEventArgs | Contains the arguments passed to handlers of the HeaderClick events.
Item | Represents events scheduled to occur at some point in time.
ItemChangedEventArgs | Contains the arguments passed to handlers of the ItemModifying and ItemDragEnd events.
ItemEventArgs | Contains the arguments passed to handlers of the item related events.
ItemLocationEventArgs | Contains the arguments passed to handlers of item mouse, click and drag related events.
ItemModifiedEventArgs | Contains the arguments passed to handlers of the ItemModified event.
ItemsCueForm | The ItemsCueForm class represents a dialog that gives details about items, which are present but not rendered in the cell, usually due to lack of space.
ItemSelectionEventArgs | Contains the arguments passed to handlers of the ItemSelectionChanged event.
Location | Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.
MouseEventArgs | Contains the arguments passed to handlers of the MouseEnter, MouseMove and MouseLeave calendar and item events.
NewForm | The NewForm class represents a dialog for creating new items.
Recurrence | Defines recurrence patterns for items scheduled to repeat.
RecurrenceException | The RecurrenceException class represents an exception from the recurrence patterns.
RecurrenceForm | The RecurrenceForm class represents a dialog for creating and modifying Recurrence objects.
Reminder | The Reminder class represents reminders associated with schedule items and tasks.
Resource | Instances of the Resource class contain information about arbitrary resources.
SelectionChangedEventArgs | Contains the arguments passed to handlers of the SelectionChanged event.
SelectionEventArgs | Contains the arguments passed to handlers of the SelectionStart and SelectionEnd events.
Task | Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.
TaskEventArgs | Contains the arguments passed to handlers of the TaskReminderTriggered event.
WebPlanner.RecurrenceStringValidationEventArgs | Contains the arguments passed to handlers of the RecurrenceStringValidation event.

Enumerations

Enumeration | Description
CalendarView | Specifies the type of view to display in a calendar control.
DailyRecurrence | Specifies the pattern of daily recurrence for a task.
DayOfWeekType | Specifies the day of the week.
DaysOfWeek | Specifies the day of the week.
GroupType | Specifies the type of grouping to apply at items in the calendar control.
ItemModifyAction | Specifies the type of modification action used, when an item is modified.
Keys | Identifies special Keys.
MonthlyRecurrence | Specifies the pattern of daily recurrence for a task.
Occurrence | Specifies the occurrence of the event.
Orientation | Specifies orientation for calendar items and views.
RecurrenceEnd | Specifies when the recurrence series ends.
RecurrencePattern | Specifies the pattern of recurrence for a task.
RecurrenceState | Specifies the recurrence state of items.
ReminderType | Specifies the type of a reminder.
TaskPriority | Specifies the priority of tasks.
TaskStatus | Specifies the status of the task.
ThemeType | Specifies the theme to be applied.
TimeUnit | Specifies the TimeUnit.
WeekRangeViewStyle | Specifies whether there are multiple weeks displayed in WeekRange view.
YearlyRecurrence | Specifies the yearly recurrence of an item.


MindFusion.Scheduling.BaseForm Class

BaseForm Class
Remarks See Also
[image]

The BaseForm class is the base class for all built-in forms.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

// class
BaseForm.prototype = {}

Remarks

For more information about using the built-in forms, please see here.

See Also

BaseForm Members
MindFusion.Scheduling Namespace
Using Built-In Forms


MindFusion.Scheduling.BaseForm Members

BaseForm Members
Constructors Methods
[image]

The BaseForm class is the base class for all built-in forms.

The following tables list the members exposed by the BaseForm type.

Public Constructors

Name | Description
BaseForm | Initializes a new instance of the BaseForm class.

Public Methods

Name | Description
addControl | Adds the specified control to the collection of controls.
clearControls | Clears all items from the collection of controls.
closeForm | Closes the form.
createButton | Creates a button with the specified options.
createCheckBox | Creates a check-box with the specified options.
createCheckBoxList | Creates a check box list with the specified options.
createDropDownList | Creates a drop-down list with the specified options.
createEditBox | Creates an edit box with the specified options.
createRadioButton | Creates a radio button with the specified options.
createTextArea | Creates a text area with the specified options.
createTextBox | Creates a text box with the specified options.
getControls | Returns the controls collection.
getControlValue | Gets the value of the control with the specified id.
getHeaderText | Gets the text which is displayed in the header of the form.
getId | Gets a value indicating the id of the form.
getType | Gets a value indicating the type of the form.
removeControl | Removes the specified control from the collection of controls.
setHeaderText | Sets the text which is displayed in the header of the form.
showForm | Renders the form.

See Also

BaseForm Class


MindFusion.Scheduling.BaseForm Constructor

BaseForm Constructor
[image]

Initializes a new instance of the BaseForm class.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function BaseForm (calendar, item)

Parameters

calendar

Type: Calendar
The Calendar.

item

Type: Item
The associated item.

See Also

BaseForm Class


MindFusion.Scheduling.BaseForm Methods

BaseForm Methods
[image]

Public Methods

Name | Description
addControl | Adds the specified control to the collection of controls.
clearControls | Clears all items from the collection of controls.
closeForm | Closes the form.
createButton | Creates a button with the specified options.
createCheckBox | Creates a check-box with the specified options.
createCheckBoxList | Creates a check box list with the specified options.
createDropDownList | Creates a drop-down list with the specified options.
createEditBox | Creates an edit box with the specified options.
createRadioButton | Creates a radio button with the specified options.
createTextArea | Creates a text area with the specified options.
createTextBox | Creates a text box with the specified options.
getControls | Returns the controls collection.
getControlValue | Gets the value of the control with the specified id.
getHeaderText | Gets the text which is displayed in the header of the form.
getId | Gets a value indicating the id of the form.
getType | Gets a value indicating the type of the form.
removeControl | Removes the specified control from the collection of controls.
setHeaderText | Sets the text which is displayed in the header of the form.
showForm | Renders the form.

See Also

BaseForm Class


MindFusion.Scheduling.BaseForm.addControl Method

BaseForm.addControl Method
[image]

Adds the specified control to the collection of controls.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function addControl (control)

Parameters

control

Type: Object
The control to add.

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.clearControls Method

BaseForm.clearControls Method
[image]

Clears all items from the collection of controls.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function clearControls ()

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.closeForm Method

BaseForm.closeForm Method
[image]

Closes the form.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function closeForm ([formId])

Parameters

formId
Optional.
Type: String
The Id of the form to be closed.

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.createButton Method

BaseForm.createButton Method
[image]

Creates a button with the specified options.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function createButton (options)

Parameters

options

Type: Object
Object, containing data for the new control.

Return Value

Type: Object
The newly created button.

Remarks

The options parameter should match the following pattern:

JavaScript [image] Copy Code

var options = { id: idValue, text: textValue, events: { eventName: handler } };

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.createCheckBox Method

BaseForm.createCheckBox Method
[image]

Creates a check-box with the specified options.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function createCheckBox (options)

Parameters

options

Type: Object
Object, containing data for the new control.

Return Value

Type: Object
The newly created check-box

Remarks

The options parameter should match the following pattern:

JavaScript [image] Copy Code

var options = { id: idValue, text: textValue, events: { eventName: handler } };

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.createCheckBoxList Method

BaseForm.createCheckBoxList Method
[image]

Creates a check box list with the specified options.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function createCheckBoxList (options)

Parameters

options

Type: Object
Object, containing data for the new control.

Return Value

Type: Object
The newly created check-box list.

Remarks

The options parameter should match the following pattern:

JavaScript [image] Copy Code

var options = { id: idValue, text: textValue, events: { eventName: handler } };

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.createDropDownList Method

BaseForm.createDropDownList Method
[image]

Creates a drop-down list with the specified options.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function createDropDownList (options)

Parameters

options

Type: Object
Object, containing data for the new control.

Return Value

Type: Object
The newly created drop-down list.

Remarks

The options parameter should match the following pattern:

JavaScript [image] Copy Code

var options = { id: idValue, text: textValue, events: { eventName: handler } };

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.createEditBox Method

BaseForm.createEditBox Method
[image]

Creates an edit box with the specified options.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function createEditBox (options)

Parameters

options

Type: Object
Object, containing data for the new control.

Return Value

Type: Object
The newly created edit box.

Remarks

The options parameter should match the following pattern:

JavaScript [image] Copy Code

var options = { id: idValue, text: textValue, events: { eventName: handler } };

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.createRadioButton Method

BaseForm.createRadioButton Method
[image]

Creates a radio button with the specified options.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function createRadioButton (options)

Parameters

options

Type: Object
Object, containing data for the new control.

Return Value

Type: Object
The newly created radio button.

Remarks

The options parameter should match the following pattern:

JavaScript [image] Copy Code

var options = { id: idValue, text: textValue, events: { eventName: handler } };

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.createTextArea Method

BaseForm.createTextArea Method
[image]

Creates a text area with the specified options.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function createTextArea (options)

Parameters

options

Type: Object
Object, containing data for the new control.

Return Value

Type: Object
The newly created text area.

Remarks

The options parameter should match the following pattern:

JavaScript [image] Copy Code

var options = { id: idValue, text: textValue, events: { eventName: handler } };

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.createTextBox Method

BaseForm.createTextBox Method
[image]

Creates a text box with the specified options.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function createTextBox (options)

Parameters

options

Type: Object
Object, containing data for the new control.

Return Value

Type: Object
The newly created text box.

Remarks

The options parameter should match the following pattern:

JavaScript [image] Copy Code

var options = { id: idValue, text: textValue, events: { eventName: handler } };

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.getControls Method

BaseForm.getControls Method
[image]

Returns the controls collection.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function getControls ()

Return Value

Type: Object
Object, containing references to all controls present in the form.

Remarks

For more information about the default controls present in the different forms, please refer to Using Built-In Forms.

See Also

BaseForm Members
BaseForm Class
Using Built-In Forms


MindFusion.Scheduling.BaseForm.getControlValue Method

BaseForm.getControlValue Method
[image]

Gets the value of the control with the specified id.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function getControlValue (controlId)

Parameters

controlId

Type: String
The id of the control to check.

Return Value

Type: Object
The value of the control.

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.getHeaderText Method

BaseForm.getHeaderText Method
[image]

Gets the text which is displayed in the header of the form.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function getHeaderText ()

Return Value

Type: String
The header text.

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.getId Method

BaseForm.getId Method
[image]

Gets a value indicating the id of the form.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function getId ()

Return Value

Type: String
The id of the form.

Remarks

For the default forms possible return values are "NewForm", "EditForm", "RecurrenceForm" or "ItemsCueForm".

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.getType Method

BaseForm.getType Method
[image]

Gets a value indicating the type of the form.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function getType ()

Return Value

Type: String
"edit" if an existing item or recurrence object is being modified through the form, otherwise "new".

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.removeControl Method

BaseForm.removeControl Method
[image]

Removes the specified control from the collection of controls.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function removeControl (control)

Parameters

control

Type: Object
The control to remove.

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.setHeaderText Method

BaseForm.setHeaderText Method
[image]

Sets the text which is displayed in the header of the form.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function setHeaderText (value)

Parameters

value

Type: String
The header text.

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.BaseForm.showForm Method

BaseForm.showForm Method
[image]

Renders the form.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function showForm ()

See Also

BaseForm Members
BaseForm Class


MindFusion.Scheduling.Calendar Class

Calendar Class
[image]

The Calendar class.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// class
Calendar.prototype = {}

See Also

Calendar Members


MindFusion.Scheduling.Calendar Members

Calendar Members
Methods
[image]

The Calendar class.

The following tables list the members exposed by the Calendar type.

Public Methods

Name | Description
adjust | Updates calendar's dimensions after resizing the control.
clearItemSelection | Clears the current item selection.
clearSelection | Clears the current time selection.
cloneItem | Clones the given item.
createItem | Creates a new item with the given data.
deleteItem | Deletes the specified item.
editItem | Edits the item.
editRecurrence | Edits a recurrence.
getAllDayCells | Gets the collection of all-day calendar cells in the Timetable view.
getAllowInplaceEdit | Gets a value indicating whether Calendar's items can be inplace-edited.
getAutoPostback | Gets a value indicating whether the Calendar should postback the page after an item is created, modified or deleted.
getCalendarContacts | Gets the contacts whose schedule to display when the GroupType property is set to GroupByContacts or FilterByContacts.
getCalendarLocations | Gets the locations whose schedule to display when the GroupType property is set to GroupByLocations or FilterByLocations.
getCalendarResources | Gets the resources whose schedule to display when the GroupType property is set to GroupByResources or FilterByResources.
getCalendarTasks | Gets the tasks whose schedule to display when the GroupType property is set to GroupByTasks or FilterByTasks.
getCellAt | Gets the date/time calendar cell that contains the specified coordinates.
getCellItems | Gets an array with all appointments which are placed in the specified cell.
getContacts | Gets all contacts defined in the calendar.
getCueCellItems | Gets an array with all appointments which are placed in the specified cell, but are hidden due to a lack of space.
getCueHeaderItems | Gets the items that are not visible in the header of the column with the specified index.
getCulture | Gets the current culture of the Calendar.
getCurrentView | Gets the type of the current view of the calendar.
getDate | Gets the date of the Calendar.
getDom | Gets an object containing references to calendar's header, content and scrolling content DOM objects.
getEnabled | Gets a value indicating whether user interactions are allowed in the Calendar.
getEndDate | Gets the end date of the Calendar's view.
getFilteredResources | Gets all the resources which are used in the current view's filter.
getGroupedResources | Gets all the resources which are used in current view's grouping.
getGroupType | Gets the grouping or filtering criteria for the Calendar.
getHeaderItems | Gets the items visible in the header of the column with the specified index.
getItemById | Returns the item with the specified id at the specified occurrence.
getItemDom | Gets the collection of Dom elements for the specified item.
getItems | Gets all scheduled items.
getItemsByResourceId | Gets all the items associated with a given resource.
getItemSelection | Gets the current item selection.
getLocations | Gets all locations defined in the calendar.
getMasterById | In a recurrence, gets the recurrence master item with the specified id.
getResourceById | Returns a resource from a schedule resource collection by a specified id.
getResourceCollections | Gets all resource collections defined in the calendar.
getResources | Gets all resources defined in the calendar.
getScroll | Gets the current horizontal and vertical scroll offsets of the contents of the calendar.
getSelection | Gets the current time selection.
getStartDate | Gets the start date of the Calendar's view.
getTasks | Gets all tasks defined in the calendar.
getTheme | Gets the current theme of the Calendar.
getTimeCell | Gets the date/time calendar cell that corresponds to the specified DateTime.
getTimeCells | Gets the date/time calendar cells that corresponds to the specified DateTime range.
getViewCells | Gets the collection of cells in current calendar view.
getViewDom | Gets an object containing references to various elements of the current view.
getViewOrientation | Gets the view orientation.
getWeekRangeViewStyle | Gets view style of the WeekRangeView.
hasItemsToRemind | Checks if there are items which reminder has not come yet.
hasTasksToRemind | Checks if there are tasks which reminder has not come yet.
postback | Performs a postback of the current window.
preparePostback | Prepares the view data and selections for postback.
scrollTo | Sets the current horizontal and vertical scroll offsets of the contents of the calendar.
setItemSelection | Sets the current item selection.
setSelection | Sets the current time selection.
useForms | Gets a value indicating whether the built-in forms for item editing will be used.

See Also

Calendar Class


MindFusion.Scheduling.Calendar Methods

Calendar Methods
[image]

Public Methods

Name | Description
adjust | Updates calendar's dimensions after resizing the control.
clearItemSelection | Clears the current item selection.
clearSelection | Clears the current time selection.
cloneItem | Clones the given item.
createItem | Creates a new item with the given data.
deleteItem | Deletes the specified item.
editItem | Edits the item.
editRecurrence | Edits a recurrence.
getAllDayCells | Gets the collection of all-day calendar cells in the Timetable view.
getAllowInplaceEdit | Gets a value indicating whether Calendar's items can be inplace-edited.
getAutoPostback | Gets a value indicating whether the Calendar should postback the page after an item is created, modified or deleted.
getCalendarContacts | Gets the contacts whose schedule to display when the GroupType property is set to GroupByContacts or FilterByContacts.
getCalendarLocations | Gets the locations whose schedule to display when the GroupType property is set to GroupByLocations or FilterByLocations.
getCalendarResources | Gets the resources whose schedule to display when the GroupType property is set to GroupByResources or FilterByResources.
getCalendarTasks | Gets the tasks whose schedule to display when the GroupType property is set to GroupByTasks or FilterByTasks.
getCellAt | Gets the date/time calendar cell that contains the specified coordinates.
getCellItems | Gets an array with all appointments which are placed in the specified cell.
getContacts | Gets all contacts defined in the calendar.
getCueCellItems | Gets an array with all appointments which are placed in the specified cell, but are hidden due to a lack of space.
getCueHeaderItems | Gets the items that are not visible in the header of the column with the specified index.
getCulture | Gets the current culture of the Calendar.
getCurrentView | Gets the type of the current view of the calendar.
getDate | Gets the date of the Calendar.
getDom | Gets an object containing references to calendar's header, content and scrolling content DOM objects.
getEnabled | Gets a value indicating whether user interactions are allowed in the Calendar.
getEndDate | Gets the end date of the Calendar's view.
getFilteredResources | Gets all the resources which are used in the current view's filter.
getGroupedResources | Gets all the resources which are used in current view's grouping.
getGroupType | Gets the grouping or filtering criteria for the Calendar.
getHeaderItems | Gets the items visible in the header of the column with the specified index.
getItemById | Returns the item with the specified id at the specified occurrence.
getItemDom | Gets the collection of Dom elements for the specified item.
getItems | Gets all scheduled items.
getItemsByResourceId | Gets all the items associated with a given resource.
getItemSelection | Gets the current item selection.
getLocations | Gets all locations defined in the calendar.
getMasterById | In a recurrence, gets the recurrence master item with the specified id.
getResourceById | Returns a resource from a schedule resource collection by a specified id.
getResourceCollections | Gets all resource collections defined in the calendar.
getResources | Gets all resources defined in the calendar.
getScroll | Gets the current horizontal and vertical scroll offsets of the contents of the calendar.
getSelection | Gets the current time selection.
getStartDate | Gets the start date of the Calendar's view.
getTasks | Gets all tasks defined in the calendar.
getTheme | Gets the current theme of the Calendar.
getTimeCell | Gets the date/time calendar cell that corresponds to the specified DateTime.
getTimeCells | Gets the date/time calendar cells that corresponds to the specified DateTime range.
getViewCells | Gets the collection of cells in current calendar view.
getViewDom | Gets an object containing references to various elements of the current view.
getViewOrientation | Gets the view orientation.
getWeekRangeViewStyle | Gets view style of the WeekRangeView.
hasItemsToRemind | Checks if there are items which reminder has not come yet.
hasTasksToRemind | Checks if there are tasks which reminder has not come yet.
postback | Performs a postback of the current window.
preparePostback | Prepares the view data and selections for postback.
scrollTo | Sets the current horizontal and vertical scroll offsets of the contents of the calendar.
setItemSelection | Sets the current item selection.
setSelection | Sets the current time selection.
useForms | Gets a value indicating whether the built-in forms for item editing will be used.

See Also

Calendar Class


MindFusion.Scheduling.Calendar.adjust Method

Calendar.adjust Method
[image]

Updates calendar's dimensions after resizing the control.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function adjust ()

Remarks

Use this method to recalculate the calendar's dimensions after resizing.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.clearItemSelection Method

Calendar.clearItemSelection Method
[image]

Clears the current item selection.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function clearItemSelection ()

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.clearSelection Method

Calendar.clearSelection Method
[image]

Clears the current time selection.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function clearSelection ()

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.cloneItem Method

Calendar.cloneItem Method
[image]

Clones the given item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function cloneItem (item)

Parameters

item

Type: Item
The item to clone.

Return Value

Type: Item
The new item.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.createItem Method

Calendar.createItem Method
[image]

Creates a new item with the given data.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function createItem (args)

Parameters

args

Type: Object
An object that holds the data for the new item.

Return Value

Type: Item
The created item.

Remarks

For more information about creating items on the client-side, please refer to Manipulating Items on the Client.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.deleteItem Method

Calendar.deleteItem Method
[image]

Deletes the specified item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function deleteItem (item)

Parameters

item

Type: Item
The item to delete.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.editItem Method

Calendar.editItem Method
[image]

Edits the item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function editItem (item, args)

Parameters

item

Type: Item
The item to be edited.

args

Type: Object
An object that holds the changed properties of the edited item.

Remarks

For more information about editing items on the client-side, please refer to Manipulating Items on the Client.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.editRecurrence Method

Calendar.editRecurrence Method
[image]

Edits a recurrence.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function editRecurrence (recurrence, args)

Parameters

recurrence

Type: Recurrence
The recurrence to be edited.

args

Type: Object
An object that holds the changed properties of the edited recurrence.

Remarks

For more information about editing recurrences on the client-side, please refer to Recurrences on the Client.

See Also

Calendar Members
Calendar Class
Recurrences on the Client


MindFusion.Scheduling.Calendar.getAllDayCells Method

Calendar.getAllDayCells Method
[image]

Gets the collection of all-day calendar cells in the Timetable view.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getAllDayCells ([startTime, [endTime, [resource]]])

Parameters

startTime
Optional.

Type: DateTime
The start time of the range.

endTime
Optional.

Type: DateTime
The end time of the range.

resource
Optional.

Type: Object
The resource to search for.

Return Value

Type: Array
The collection of all-day calendar cells in the Timetable view.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getAllowInplaceEdit Method

Calendar.getAllowInplaceEdit Method
[image]

Gets a value indicating whether Calendar's items can be inplace-edited.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getAllowInplaceEdit ()

Return Value

Type: Boolean
True if the Calendar's items can be inplace-edited, otherwise false.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getAutoPostback Method

Calendar.getAutoPostback Method
[image]

Gets a value indicating whether the Calendar should postback the page after an item is created, modified or deleted.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getAutoPostback ()

Return Value

Type: Boolean
True if the Calendar should postback, otherwise false.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getCalendarContacts Method

Calendar.getCalendarContacts Method
[image]

Gets the contacts whose schedule to display when the GroupType property is set to GroupByContacts or FilterByContacts.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCalendarContacts ()

Return Value

Type: Array
The contacts.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getCalendarLocations Method

Calendar.getCalendarLocations Method
[image]

Gets the locations whose schedule to display when the GroupType property is set to GroupByLocations or FilterByLocations.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCalendarLocations ()

Return Value

Type: Array
The locations.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getCalendarResources Method

Calendar.getCalendarResources Method
[image]

Gets the resources whose schedule to display when the GroupType property is set to GroupByResources or FilterByResources.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCalendarResources ()

Return Value

Type: Array
The resources.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getCalendarTasks Method

Calendar.getCalendarTasks Method
[image]

Gets the tasks whose schedule to display when the GroupType property is set to GroupByTasks or FilterByTasks.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCalendarTasks ()

Return Value

Type: Array
The tasks.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getCellAt Method

Calendar.getCellAt Method
[image]

Gets the date/time calendar cell that contains the specified coordinates.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCellAt (x, y)

Parameters

x

Type: Number
The X-coordinate of the point.

y

Type: Number
The Y-coordinate of the point.

Return Value

Type: Object
The date/time calendar cell that contains the specified coordinates.

Remarks

The structure of the cell object is discussed in detail in this topic.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getCellItems Method

Calendar.getCellItems Method
[image]

Gets an array with all appointments which are placed in the specified cell.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCellItems (cell)

Parameters

cell

Type: Object
The cell to look into.

Return Value

Type: Array
A list with the items.

Remarks

The structure of the cell object is discussed in detail in this topic.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getContacts Method

Calendar.getContacts Method
[image]

Gets all contacts defined in the calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getContacts ()

Return Value

Type: Array
List of all contacts defined in the calendar.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getCueCellItems Method

Calendar.getCueCellItems Method
[image]

Gets an array with all appointments which are placed in the specified cell, but are hidden due to a lack of space.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCueCellItems (cell)

Parameters

cell

Type: Object
The cell to look into.

Return Value

Type: Array
The list with the cue items.

Remarks

This function is not available for Timetable view and will return an empty array if used there. For Timetable use getCueHeaderItems instead.
The structure of the cell object is discussed in detail in this topic.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getCueHeaderItems Method

Calendar.getCueHeaderItems Method
[image]

Gets the items that are not visible in the header of the column with the specified index.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCueHeaderItems (columnIndex)

Parameters

columnIndex

Type: Number
The index of the column.

Return Value

Type: Array
A list with the items.

Remarks

This method is available only for the Timetable view of the Calendar and will return an empty array if used with other views. For views other than Timetable use getCueCellItems instead.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getCulture Method

Calendar.getCulture Method
[image]

Gets the current culture of the Calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCulture ()

Return Value

Type: Sys.CultureInfo
The culture.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getCurrentView Method

Calendar.getCurrentView Method
[image]

Gets the type of the current view of the calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCurrentView ()

Return Value

Type: CalendarView
The type of the current view.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getDate Method

Calendar.getDate Method
[image]

Gets the date of the Calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getDate ()

Return Value

Type: DateTime
The date of the Calendar.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getDom Method

Calendar.getDom Method
[image]

Gets an object containing references to calendar's header, content and scrolling content DOM objects.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getDom ()

Return Value

Type: Object
An object containing references.

Remarks

The returned object has the following structure: {content: Object, header: Object, scroller: Object}. The content property holds a reference to the Dom element representing the view's content. The header property holds a reference to the Dom element representing the view's main header. The scroller property holds a reference to the Dom element representing the view's scrolling content.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getEnabled Method

Calendar.getEnabled Method
[image]

Gets a value indicating whether user interactions are allowed in the Calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getEnabled ()

Return Value

Type: Boolean
True if user interactions are allowed, otherwise false.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getEndDate Method

Calendar.getEndDate Method
[image]

Gets the end date of the Calendar's view.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getEndDate ()

Return Value

Type: DateTime
The end date of the Calendar's view.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getFilteredResources Method

Calendar.getFilteredResources Method
[image]

Gets all the resources which are used in the current view's filter.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getFilteredResources ()

Return Value

Type: Array
The resources by which the current view is filtered.

Remarks

If there is no filter in place the result will be an empty Array.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getGroupedResources Method

Calendar.getGroupedResources Method
[image]

Gets all the resources which are used in current view's grouping.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getGroupedResources ()

Return Value

Type: Array
The resources by which the current view is grouped.

Remarks

If there is no grouping in place the result will be an empty Array.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getGroupType Method

Calendar.getGroupType Method
[image]

Gets the grouping or filtering criteria for the Calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getGroupType ()

Return Value

Type: GroupType
The grouping criteria.

Remarks

Grouping is available only for the Timetable view of the Calendar.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getHeaderItems Method

Calendar.getHeaderItems Method
[image]

Gets the items visible in the header of the column with the specified index.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getHeaderItems (columnIndex)

Parameters

columnIndex

Type: Number
The index of the column.

Return Value

Type: Array
A list with the items.

Remarks

This method is available only for the Timetable view of the Calendar.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getItemById Method

Calendar.getItemById Method
[image]

Returns the item with the specified id at the specified occurrence.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getItemById (id, [occurrenceIndex])

Parameters

id

Type: String
The id of the item.

occurrenceIndex
Optional.

Type: Number
The occurrence index of the item.

Return Value

Type: Item
The item; null if no item with the specified id and occurrence index has been found.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getItemDom Method

Calendar.getItemDom Method
[image]

Gets the collection of Dom elements for the specified item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getItemDom (item)

Parameters

item

Type: void

Return Value

Type: Array
The collection of Dom elements for the specified item.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getItems Method

Calendar.getItems Method
[image]

Gets all scheduled items.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getItems ()

Return Value

Type: Array
The list of items defined in the current calendar.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getItemsByResourceId Method

Calendar.getItemsByResourceId Method
[image]

Gets all the items associated with a given resource.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getItemsByResourceId (resourceId)

Parameters

resourceId

Type: String
The id of the resource.

Return Value

Type: Array
All items associated with a given resource.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getItemSelection Method

Calendar.getItemSelection Method
[image]

Gets the current item selection.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getItemSelection ()

Return Value

Type: Array
Array of currently selected items.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getLocations Method

Calendar.getLocations Method
[image]

Gets all locations defined in the calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getLocations ()

Return Value

Type: Array
List of all locations defined in the calendar.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getMasterById Method

Calendar.getMasterById Method
[image]

In a recurrence, gets the recurrence master item with the specified id.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getMasterById (id)

Parameters

id

Type: String
The id of the master item.

Return Value

Type: Item
The item; null if no master item with the specified id has been found.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getResourceById Method

Calendar.getResourceById Method
[image]

Returns a resource from a schedule resource collection by a specified id.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getResourceById (id)

Parameters

id

Type: String
The id of the resource.

Return Value

Type: Object
The resource object if found, null otherwise.

Remarks

The schedule resource collection (contacts, locations, tasks, resources) is determined automatically by the resource's id.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getResourceCollections Method

Calendar.getResourceCollections Method
[image]

Gets all resource collections defined in the calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getResourceCollections ()

Return Value

Type: Object
An object, containing all resource collections defined in the calendar.

Remarks

The returned object has the following structure: {contacts: Array, locations: Array, tasks: Array, resources: Array}.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getResources Method

Calendar.getResources Method
[image]

Gets all resources defined in the calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getResources ()

Return Value

Type: Array
List of all resources defined in the calendar.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getScroll Method

Calendar.getScroll Method
[image]

Gets the current horizontal and vertical scroll offsets of the contents of the calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getScroll ()

Return Value

Type: Object
An object containing the current horizontal and vertical scroll offsets.

Remarks

The returned object has the following structure: {scrollX: Number, scrollY: Number}.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getSelection Method

Calendar.getSelection Method
[image]

Gets the current time selection.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getSelection ()

Return Value

Type: Object
Object, containing the start and end time of the current selection.

Remarks

The returned object has the following structure: {start: DateTime, end: DateTime}.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getStartDate Method

Calendar.getStartDate Method
[image]

Gets the start date of the Calendar's view.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getStartDate ()

Return Value

Type: DateTime
The start date of the Calendar's view.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getTasks Method

Calendar.getTasks Method
[image]

Gets all tasks defined in the calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getTasks ()

Return Value

Type: Array
List of all tasks defined in the calendar.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getTheme Method

Calendar.getTheme Method
[image]

Gets the current theme of the Calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getTheme ()

Return Value

Type: ThemeType
The current theme

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getTimeCell Method

Calendar.getTimeCell Method
[image]

Gets the date/time calendar cell that corresponds to the specified DateTime.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getTimeCell (dateTime, [isEndTime, [resource]])

Parameters

dateTime

Type: DateTime
The time to search for.

isEndTime
Optional.

Type: Boolean
true if the index of the first interval is returned when the time is the boundary between two consecutive intervals; false if the index of the second interval is contained. The default is false.

resource
Optional.

Type: Object
The resource to search for.

Return Value

Type: Object
The cell that holds the specified DateTime.

Remarks

The structure of the cell object is discussed in detail in this topic.

See Also

Calendar Members
Calendar Class
Manipulating Cells on the Client


MindFusion.Scheduling.Calendar.getTimeCells Method

Calendar.getTimeCells Method
[image]

Gets the date/time calendar cells that corresponds to the specified DateTime range.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getTimeCells (startTime, [endTime, [isEndTime, [resource]]])

Parameters

startTime

Type: DateTime
The start time of the range.

endTime
Optional.

Type: DateTime
The end time of the range.

isEndTime
Optional.

Type: Boolean
true if the index of the first interval is returned when the time is the boundary between two consecutive intervals; false if the index of the second interval is contained. The default is false.

resource
Optional.

Type: Object
The resource to search for.

Return Value

Type: Array
The cells that corresponds to the specified DateTime range.

Remarks

The structure of the cell object is discussed in detail in this topic.

See Also

Calendar Members
Calendar Class
Manipulating Cells on the Client


MindFusion.Scheduling.Calendar.getViewCells Method

Calendar.getViewCells Method
[image]

Gets the collection of cells in current calendar view.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getViewCells ()

Return Value

Type: Array
The collection of cells.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getViewDom Method

Calendar.getViewDom Method
[image]

Gets an object containing references to various elements of the current view.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getViewDom ()

Return Value

Type: Object
An object containing references.

Remarks

For additional information about the different DOM elements in the different views, please see this topic.

See Also

DOM View Elements
Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getViewOrientation Method

Calendar.getViewOrientation Method
[image]

Gets the view orientation.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getViewOrientation ()

Return Value

Type: Orientation
The view orientation if the current view is List or Timetable, otherwise null.

Remarks

This property is available only for the List and Timetable views of the Calendar.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.getWeekRangeViewStyle Method

Calendar.getWeekRangeViewStyle Method
[image]

Gets view style of the WeekRangeView.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getWeekRangeViewStyle ()

Return Value

Type: WeekRangeViewStyle
The view style if the current view is WeekRange, otherwise null.

Remarks

This property is available only for the WeekRangeView view of the Calendar.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.hasItemsToRemind Method

Calendar.hasItemsToRemind Method
[image]

Checks if there are items which reminder has not come yet.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function hasItemsToRemind ()

Return Value

Type: Boolean
true if there are items with a future reminder; otherwise false.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.hasTasksToRemind Method

Calendar.hasTasksToRemind Method
[image]

Checks if there are tasks which reminder has not come yet.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function hasTasksToRemind ()

Return Value

Type: Boolean
true if there are tasks with a future reminder; otherwise false.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.postback Method

Calendar.postback Method
[image]

Performs a postback of the current window.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function postback ()

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.preparePostback Method

Calendar.preparePostback Method
[image]

Prepares the view data and selections for postback.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function preparePostback ()

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.scrollTo Method

Calendar.scrollTo Method
[image]

Sets the current horizontal and vertical scroll offsets of the contents of the calendar.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function scrollTo ([x, [y]])

Parameters

x
Optional.

Type: Number
The horizontal offset.

y
Optional.

Type: Number
The vertical offset.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.setItemSelection Method

Calendar.setItemSelection Method
[image]

Sets the current item selection.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function setItemSelection (item)

Parameters

item

Type: Item
The item to be added to the selection.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.setSelection Method

Calendar.setSelection Method
[image]

Sets the current time selection.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function setSelection (start, [end, [resource]])

Parameters

start

Type: DateTime
The start time of the selection.

end
Optional.

Type: DateTime
The end time of the selection.

resource
Optional.

Type: Object
The resource associated with the selection.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Calendar.useForms Method

Calendar.useForms Method
[image]

Gets a value indicating whether the built-in forms for item editing will be used.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function useForms ()

Return Value

Type: Boolean
True if the built-in forms will be used, otherwise false.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.CalendarView Enumeration

CalendarView Enumeration
[image]

Specifies the type of view to display in a calendar control.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
CalendarView = {}

Members

Member name | Description
List | Value: 3. The calendar displays several seconds, minutes, hours, days, weeks, months or years in a row.
MonthRange | Value: 0. The calendar displays several months in a grid.
SingleMonth | Value: 1. The calendar displays a single month at a time. The days of the month are displayed in a grid.
Timetable | Value: 4. The calendar displays a timetable where each row represents a fixed arbitrary time interval and each column represents a day.
WeekRange | Value: 2. The calendar displays a grid of days, with the columns representing the week days from Monday to Sunday and the rows representing weeks.

See Also


MindFusion.Scheduling.CellEventArgs Class

CellEventArgs Class
[image]

Contains the arguments passed to handlers of the DateMouseUp, DateMouseDown, DateClick, DateDoubleClick and hidden items cue related event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
CellEventArgs.prototype = {}

See Also

CellEventArgs Members


MindFusion.Scheduling.CellEventArgs Members

CellEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of the DateMouseUp, DateMouseDown, DateClick, DateDoubleClick and hidden items cue related event.

The following tables list the members exposed by the CellEventArgs type.

Public Constructors

Name | Description
CellEventArgs | Initializes a new instance of the CellEventArgs class.

Public Methods

Name | Description
get_cell | Gets the cell object associated with the event.

See Also

CellEventArgs Class


MindFusion.Scheduling.CellEventArgs Constructor

CellEventArgs Constructor
[image]

Initializes a new instance of the CellEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function CellEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of the DateMouseUp, DateMouseDown, DateClick, DateDoubleClick and hidden items cue related event.

See Also

CellEventArgs Class


MindFusion.Scheduling.CellEventArgs Methods

CellEventArgs Methods
[image]

Public Methods

Name | Description
get_cell | Gets the cell object associated with the event.

See Also

CellEventArgs Class


MindFusion.Scheduling.CellEventArgs.get_cell Method

CellEventArgs.get_cell Method
[image]

Gets the cell object associated with the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_cell ()

Return Value

Type: Object
The cell object associated with the event.

Remarks

The structure of the cell object is discussed in detail in this topic.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Scheduling.Contact Class

Contact Class
[image]

Instances of the Contact class contain contact information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// class
Contact.prototype = {}

See Also

Contact Members


MindFusion.Scheduling.Contact Members

Contact Members
Methods
[image]

Instances of the Contact class contain contact information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.

The following tables list the members exposed by the Contact type.

Public Methods

Name | Description
getAddress | Gets the address of the contact.
getEmail | Gets the e-mail of the contact.
getFirstName | Gets the first name of the contact.
getLastName | Gets the last name of the contact.
getMiddleName | Gets the middle name of the contact.
getPhone | Gets the phone of the contact.

See Also

Contact Class


MindFusion.Scheduling.Contact Methods

Contact Methods
[image]

Public Methods

Name | Description
getAddress | Gets the address of the contact.
getEmail | Gets the e-mail of the contact.
getFirstName | Gets the first name of the contact.
getLastName | Gets the last name of the contact.
getMiddleName | Gets the middle name of the contact.
getPhone | Gets the phone of the contact.

See Also

Contact Class


MindFusion.Scheduling.Contact.getAddress Method

Contact.getAddress Method
[image]

Gets the address of the contact.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getAddress ()

Return Value

Type: String
The address of the contact.

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.getEmail Method

Contact.getEmail Method
[image]

Gets the e-mail of the contact.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getEmail ()

Return Value

Type: String
The e-mail of the contact.

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.getFirstName Method

Contact.getFirstName Method
[image]

Gets the first name of the contact.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getFirstName ()

Return Value

Type: String
The first name of the contact.

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.getLastName Method

Contact.getLastName Method
[image]

Gets the last name of the contact.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getLastName ()

Return Value

Type: String
The last name of the contact.

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.getMiddleName Method

Contact.getMiddleName Method
[image]

Gets the middle name of the contact.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getMiddleName ()

Return Value

Type: String
The middle name of the contact.

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.getPhone Method

Contact.getPhone Method
[image]

Gets the phone of the contact.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getPhone ()

Return Value

Type: String
The phone of the contact.

See Also

Contact Members
Contact Class


MindFusion.Scheduling.DailyRecurrence Enumeration

DailyRecurrence Enumeration
[image]

Specifies the pattern of daily recurrence for a task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
DailyRecurrence = {}

Members

Member name | Description
ByDayInterval | Value: 0. The event occurs every day.
EveryWeekend | Value: 2. The event occurs every weekend.
EveryWorkday | Value: 1. The event occurs every work day.

See Also


MindFusion.Scheduling.DayOfWeekType Enumeration

DayOfWeekType Enumeration
[image]

Specifies the day of the week.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
DayOfWeekType = {}

Members

Member name | Description
AnyDay | Value: 0. Specifies any day of the week.
Friday | Value: 8. Specifies Friday.
Monday | Value: 4. Specifies Monday.
Saturday | Value: 9. Specifies Saturday.
Sunday | Value: 3. Specifies Sunday.
Thursday | Value: 7. Specifies Thursday.
Tuesday | Value: 5. Specifies Tuesday.
Wednesday | Value: 6. Specifies Wednesday.
Weekend | Value: 2. Specifies a day of the weekend.
Workday | Value: 1. Specifies a work day.

See Also


MindFusion.Scheduling.DaysOfWeek Enumeration

DaysOfWeek Enumeration
[image]

Specifies the day of the week.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
DaysOfWeek = {}

Members

Member name | Description
All | Value: 0x7F. Indicates all days of the week.
Friday | Value: 0x20. Indicates Friday.
Monday | Value: 0x2. Indicates Monday.
None | Value: 0x0. Indicates an undefined day value.
Saturday | Value: 0x40. Indicates Saturday.
Sunday | Value: 0x1. Indicates Sunday.
Thursday | Value: 0x10. Indicates Thursday.
Tuesday | Value: 0x4. Indicates Tuesday.
Wednesday | Value: 0x8. Indicates Wednesday.

Remarks

This enumeration is defined as Flag that allows a bitwise combination of its member values.

See Also


MindFusion.Scheduling.EditForm Class

EditForm Class
[image]

The EditForm class represents a built-in form for items editing.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

// class
EditForm.prototype = {}

See Also

EditForm Members


MindFusion.Scheduling.EditForm Members

EditForm Members
Constructors Methods
[image]

The EditForm class represents a built-in form for items editing.

The following tables list the members exposed by the EditForm type.

Public Constructors

Name | Description
EditForm | Initializes a new instance of the EditForm class.

Public Methods

Name | Description
getItem | Gets the item currently modified through the form
setItem | Sets the item currently modified through the form

See Also

EditForm Class


MindFusion.Scheduling.EditForm Constructor

EditForm Constructor
[image]

Initializes a new instance of the EditForm class.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function EditForm (calendar, item)

Parameters

calendar

Type: Calendar
The Calendar.

item

Type: Item
The item to be modified.

See Also

EditForm Class


MindFusion.Scheduling.EditForm Methods

EditForm Methods
[image]

Public Methods

Name | Description
getItem | Gets the item currently modified through the form
setItem | Sets the item currently modified through the form

See Also

EditForm Class


MindFusion.Scheduling.EditForm.getItem Method

EditForm.getItem Method
[image]

Gets the item currently modified through the form

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function getItem ()

Return Value

Type: Item
The item.

See Also

EditForm Members
EditForm Class


MindFusion.Scheduling.EditForm.setItem Method

EditForm.setItem Method
[image]

Sets the item currently modified through the form

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function setItem (value)

Parameters

value

Type: Item
The item.

See Also

EditForm Members
EditForm Class


MindFusion.Scheduling.FormEventArgs Class

FormEventArgs Class
[image]

Contains the arguments passed to handlers of the FormShow event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
FormEventArgs.prototype = {}

See Also

FormEventArgs Members


MindFusion.Scheduling.FormEventArgs Members

FormEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of the FormShow event.

The following tables list the members exposed by the FormEventArgs type.

Public Constructors

Name | Description
FormEventArgs | Initializes a new instance of the FormEventArgs class.

Public Methods

Name | Description
get_form | Gets the built-in form object associated with the event.

See Also

FormEventArgs Class


MindFusion.Scheduling.FormEventArgs Constructor

FormEventArgs Constructor
[image]

Initializes a new instance of the FormEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function FormEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of the FormShow event.

See Also

FormEventArgs Class


MindFusion.Scheduling.FormEventArgs Methods

FormEventArgs Methods
[image]

Public Methods

Name | Description
get_form | Gets the built-in form object associated with the event.

See Also

FormEventArgs Class


MindFusion.Scheduling.FormEventArgs.get_form Method

FormEventArgs.get_form Method
[image]

Gets the built-in form object associated with the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_form ()

Return Value

Type: Object
The form object associated with the event.

See Also

FormEventArgs Members
FormEventArgs Class


MindFusion.Scheduling.GroupType Enumeration

GroupType Enumeration
[image]

Specifies the type of grouping to apply at items in the calendar control.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
GroupType = {}

Members

Member name | Description
FilterByContacts | Value: 5. The items are filtered by contact.
FilterByLocations | Value: 6. The items are filtered by location.
FilterByResources | Value: 8. The items are filtered by resource.
FilterByTasks | Value: 7. The items are filtered by task.
GroupByContacts | Value: 1. The items are grouped by contacts.
GroupByLocations | Value: 3. The items are grouped by location.
GroupByResources | Value: 2. The items are grouped by resource.
GroupByTasks | Value: 4. The items are grouped by task.
None | Value: 0. No grouping is applied.

See Also


MindFusion.Scheduling.HeaderEventArgs Class

HeaderEventArgs Class
[image]

Contains the arguments passed to handlers of the HeaderClick events.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
HeaderEventArgs.prototype = {}

See Also

HeaderEventArgs Members


MindFusion.Scheduling.HeaderEventArgs Members

HeaderEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of the HeaderClick events.

The following tables list the members exposed by the HeaderEventArgs type.

Public Constructors

Name | Description
HeaderEventArgs | Initializes a new instance of the HeaderEventArgs class.

Public Methods

Name | Description
get_button | Gets a value indicating which mouse button have been pressed when the event was raised.
get_date | Gets the date associated with the event.

See Also

HeaderEventArgs Class


MindFusion.Scheduling.HeaderEventArgs Constructor

HeaderEventArgs Constructor
[image]

Initializes a new instance of the HeaderEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function HeaderEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of the HeaderClick events.

See Also

HeaderEventArgs Class


MindFusion.Scheduling.HeaderEventArgs Methods

HeaderEventArgs Methods
[image]

Public Methods

Name | Description
get_button | Gets a value indicating which mouse button have been pressed when the event was raised.
get_date | Gets the date associated with the event.

See Also

HeaderEventArgs Class


MindFusion.Scheduling.HeaderEventArgs.get_button Method

HeaderEventArgs.get_button Method
[image]

Gets a value indicating which mouse button have been pressed when the event was raised.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_button ()

Return Value

Type: Number
The button associated with the event.

See Also

HeaderEventArgs Members
HeaderEventArgs Class


MindFusion.Scheduling.HeaderEventArgs.get_date Method

HeaderEventArgs.get_date Method
[image]

Gets the date associated with the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_date ()

Return Value

Type: DateTime
The date.

See Also

HeaderEventArgs Members
HeaderEventArgs Class


MindFusion.Scheduling.Item Class

Item Class
[image]

Represents events scheduled to occur at some point in time.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// class
Item.prototype = {}

See Also

Item Members


MindFusion.Scheduling.Item Members

Item Members
Constructors Methods
[image]

Represents events scheduled to occur at some point in time.

The following tables list the members exposed by the Item type.

Public Constructors

Name | Description
Item | Initializes a new instance of the Item class.

Public Methods

Name | Description
getAllDayEvent | Gets a value, indicating whether the item represents an all day event.
getContacts | Gets the list of contacts, associated with this item.
getCssClass | Gets the css class of the item.
getDescriptionText | Gets the description text of the item.
getDetails | Gets the description text of the item.
getEndTime | Gets the end time of the item.
getHeaderText | Gets the header text of the item.
getId | Gets the id of the item.
getLocation | Gets the location, associated with this item.
getLocked | Gets a value indicating whether users are forbidden to modify this item.
getOccurrenceIndex | Gets the occurrence index of this item.
getPriority | Gets the priority of the Item.
getRecurrence | Gets the Recurrence object, associated with this item.
getRecurrenceState | Gets the recurrence state of this item.
getReminder | Gets the reminder of this item.
getResources | Gets the list of resources, associated with this item.
getSelected | Gets a value indicating whether the item is currently selected.
getStartTime | Gets the start time of the item.
getSubject | Gets the header text of the item.
getTag | Gets the tag of this item.
getTask | Gets the task, associated with this item.
getVisible | Gets a value indicating whether the item is visible.

See Also

Item Class


MindFusion.Scheduling.Item Constructor

Item Constructor
[image]

Initializes a new instance of the Item class.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function Item ()

See Also

Item Class


MindFusion.Scheduling.Item Methods

Item Methods
[image]

Public Methods

Name | Description
getAllDayEvent | Gets a value, indicating whether the item represents an all day event.
getContacts | Gets the list of contacts, associated with this item.
getCssClass | Gets the css class of the item.
getDescriptionText | Gets the description text of the item.
getDetails | Gets the description text of the item.
getEndTime | Gets the end time of the item.
getHeaderText | Gets the header text of the item.
getId | Gets the id of the item.
getLocation | Gets the location, associated with this item.
getLocked | Gets a value indicating whether users are forbidden to modify this item.
getOccurrenceIndex | Gets the occurrence index of this item.
getPriority | Gets the priority of the Item.
getRecurrence | Gets the Recurrence object, associated with this item.
getRecurrenceState | Gets the recurrence state of this item.
getReminder | Gets the reminder of this item.
getResources | Gets the list of resources, associated with this item.
getSelected | Gets a value indicating whether the item is currently selected.
getStartTime | Gets the start time of the item.
getSubject | Gets the header text of the item.
getTag | Gets the tag of this item.
getTask | Gets the task, associated with this item.
getVisible | Gets a value indicating whether the item is visible.

See Also

Item Class


MindFusion.Scheduling.Item.getAllDayEvent Method

Item.getAllDayEvent Method
[image]

Gets a value, indicating whether the item represents an all day event.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getAllDayEvent ()

Return Value

Type: Boolean
True if the item is all day event, otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getContacts Method

Item.getContacts Method
[image]

Gets the list of contacts, associated with this item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getContacts ()

Return Value

Type: Array
The list of contacts.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getCssClass Method

Item.getCssClass Method
[image]

Gets the css class of the item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCssClass ()

Return Value

Type: String
The name of the css class of the item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getDescriptionText Method

Item.getDescriptionText Method
[image]

Gets the description text of the item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getDescriptionText ()

Return Value

Type: String
The description text.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getDetails Method

Item.getDetails Method
[image]

Gets the description text of the item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getDetails ()

Return Value

Type: String
The description text.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getEndTime Method

Item.getEndTime Method
[image]

Gets the end time of the item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getEndTime ()

Return Value

Type: DateTime
The end time.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getHeaderText Method

Item.getHeaderText Method
[image]

Gets the header text of the item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getHeaderText ()

Return Value

Type: String
The header text.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getId Method

Item.getId Method
[image]

Gets the id of the item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getId ()

Return Value

Type: String
The id of the item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getLocation Method

Item.getLocation Method
[image]

Gets the location, associated with this item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getLocation ()

Return Value

Type: Location
The location, associated with this item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getLocked Method

Item.getLocked Method
[image]

Gets a value indicating whether users are forbidden to modify this item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getLocked ()

Return Value

Type: Boolean
True if the item cannot be modified, otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getOccurrenceIndex Method

Item.getOccurrenceIndex Method
[image]

Gets the occurrence index of this item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getOccurrenceIndex ()

Return Value

Type: Number
The occurrence index of the item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getPriority Method

Item.getPriority Method
[image]

Gets the priority of the Item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getPriority ()

Return Value

Type: Number
The priority of the item.

Remarks

Items with higher priority are rendered with preference over items with lower priority.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getRecurrence Method

Item.getRecurrence Method
[image]

Gets the Recurrence object, associated with this item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getRecurrence ()

Return Value

Type: Recurrence
The Recurrence object, associated with this item. If the item is not part of a recurrent series, the method returns null.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getRecurrenceState Method

Item.getRecurrenceState Method
[image]

Gets the recurrence state of this item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getRecurrenceState ()

Return Value

Type: RecurrenceState
The recurrence state of the item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getReminder Method

Item.getReminder Method
[image]

Gets the reminder of this item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getReminder ()

Return Value

Type: Reminder
The reminder associated with this item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getResources Method

Item.getResources Method
[image]

Gets the list of resources, associated with this item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getResources ()

Return Value

Type: Array
The list of resources, associated with this item

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getSelected Method

Item.getSelected Method
[image]

Gets a value indicating whether the item is currently selected.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getSelected ()

Return Value

Type: Boolean
True if the item is selected, otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getStartTime Method

Item.getStartTime Method
[image]

Gets the start time of the item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getStartTime ()

Return Value

Type: DateTime
The start time.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getSubject Method

Item.getSubject Method
[image]

Gets the header text of the item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getSubject ()

Return Value

Type: String
The header text.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getTag Method

Item.getTag Method
[image]

Gets the tag of this item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getTag ()

Return Value

Type: Object
The tag of the item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getTask Method

Item.getTask Method
[image]

Gets the task, associated with this item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getTask ()

Return Value

Type: Task
The task, associated with this item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.getVisible Method

Item.getVisible Method
[image]

Gets a value indicating whether the item is visible.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getVisible ()

Return Value

Type: Boolean
True if the item is visible, otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.ItemChangedEventArgs Class

ItemChangedEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemModifying and ItemDragEnd events.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
ItemChangedEventArgs.prototype = {}

See Also

ItemChangedEventArgs Members


MindFusion.Scheduling.ItemChangedEventArgs Members

ItemChangedEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of the ItemModifying and ItemDragEnd events.

The following tables list the members exposed by the ItemChangedEventArgs type.

Public Constructors

Name | Description
ItemChangedEventArgs | Initializes a new instance of the ItemChangedEventArgs class.

Public Methods

Name | Description
get_action | Gets the type of action through which the item was modified.
get_changes | Gets the changed properties of the item, associated with the event.
get_item | Gets the item associated with the event.

See Also

ItemChangedEventArgs Class


MindFusion.Scheduling.ItemChangedEventArgs Constructor

ItemChangedEventArgs Constructor
[image]

Initializes a new instance of the ItemChangedEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function ItemChangedEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of the ItemModifying and ItemDragEnd events.

See Also

ItemChangedEventArgs Class


MindFusion.Scheduling.ItemChangedEventArgs Methods

ItemChangedEventArgs Methods
[image]

Public Methods

Name | Description
get_action | Gets the type of action through which the item was modified.
get_changes | Gets the changed properties of the item, associated with the event.
get_item | Gets the item associated with the event.

See Also

ItemChangedEventArgs Class


MindFusion.Scheduling.ItemChangedEventArgs.get_action Method

ItemChangedEventArgs.get_action Method
[image]

Gets the type of action through which the item was modified.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_action ()

Return Value

Type: ItemModifyAction
The type of modification action.

See Also

ItemChangedEventArgs Members
ItemChangedEventArgs Class


MindFusion.Scheduling.ItemChangedEventArgs.get_changes Method

ItemChangedEventArgs.get_changes Method
[image]

Gets the changed properties of the item, associated with the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_changes ()

Return Value

Type: Object
The changed properties.

See Also

ItemChangedEventArgs Members
ItemChangedEventArgs Class


MindFusion.Scheduling.ItemChangedEventArgs.get_item Method

ItemChangedEventArgs.get_item Method
[image]

Gets the item associated with the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_item ()

Return Value

Type: Item
The item associated with the event.

See Also

ItemChangedEventArgs Members
ItemChangedEventArgs Class


MindFusion.Scheduling.ItemEventArgs Class

ItemEventArgs Class
[image]

Contains the arguments passed to handlers of the item related events.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
ItemEventArgs.prototype = {}

See Also

ItemEventArgs Members


MindFusion.Scheduling.ItemEventArgs Members

ItemEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of the item related events.

The following tables list the members exposed by the ItemEventArgs type.

Public Constructors

Name | Description
ItemEventArgs | Initializes a new instance of the ItemEventArgs class.

Public Methods

Name | Description
get_item | Gets the item associated with the event.

See Also

ItemEventArgs Class


MindFusion.Scheduling.ItemEventArgs Constructor

ItemEventArgs Constructor
[image]

Initializes a new instance of the ItemEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function ItemEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of the item related events.

See Also

ItemEventArgs Class


MindFusion.Scheduling.ItemEventArgs Methods

ItemEventArgs Methods
[image]

Public Methods

Name | Description
get_item | Gets the item associated with the event.

See Also

ItemEventArgs Class


MindFusion.Scheduling.ItemEventArgs.get_item Method

ItemEventArgs.get_item Method
[image]

Gets the item associated with the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_item ()

Return Value

Type: Item
The item associated with the event.

See Also

ItemEventArgs Members
ItemEventArgs Class


MindFusion.Scheduling.ItemLocationEventArgs Class

ItemLocationEventArgs Class
[image]

Contains the arguments passed to handlers of item mouse, click and drag related events.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
ItemLocationEventArgs.prototype = {}

See Also

ItemLocationEventArgs Members


MindFusion.Scheduling.ItemLocationEventArgs Members

ItemLocationEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of item mouse, click and drag related events.

The following tables list the members exposed by the ItemLocationEventArgs type.

Public Constructors

Name | Description
ItemLocationEventArgs | Initializes a new instance of the ItemLocationEventArgs class.

Public Methods

Name | Description
get_item | Gets the item associated with the event.

See Also

ItemLocationEventArgs Class


MindFusion.Scheduling.ItemLocationEventArgs Constructor

ItemLocationEventArgs Constructor
[image]

Initializes a new instance of the ItemLocationEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function ItemLocationEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of item mouse, click and drag related events.

See Also

ItemLocationEventArgs Class


MindFusion.Scheduling.ItemLocationEventArgs Methods

ItemLocationEventArgs Methods
[image]

Public Methods

Name | Description
get_item | Gets the item associated with the event.

See Also

ItemLocationEventArgs Class


MindFusion.Scheduling.ItemLocationEventArgs.get_item Method

ItemLocationEventArgs.get_item Method
[image]

Gets the item associated with the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_item ()

Return Value

Type: Item
The item associated with the event.

See Also

ItemLocationEventArgs Members
ItemLocationEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs Class

ItemModifiedEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemModified event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
ItemModifiedEventArgs.prototype = {}

See Also

ItemModifiedEventArgs Members


MindFusion.Scheduling.ItemModifiedEventArgs Members

ItemModifiedEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of the ItemModified event.

The following tables list the members exposed by the ItemModifiedEventArgs type.

Public Constructors

Name | Description
ItemModifiedEventArgs | Initializes a new instance of the ItemModifiedEventArgs class.

Public Methods

Name | Description
get_action | Gets the type of action through which the item was modified.
get_item | Gets the item related to the event.
get_oldItem | Gets the old item related to the event.

See Also

ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs Constructor

ItemModifiedEventArgs Constructor
[image]

Initializes a new instance of the ItemModifiedEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function ItemModifiedEventArgs (args)

Parameters

args

Type: Object
The arguments passed to handlers of the ItemModified event.

See Also

ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs Methods

ItemModifiedEventArgs Methods
[image]

Public Methods

Name | Description
get_action | Gets the type of action through which the item was modified.
get_item | Gets the item related to the event.
get_oldItem | Gets the old item related to the event.

See Also

ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs.get_action Method

ItemModifiedEventArgs.get_action Method
[image]

Gets the type of action through which the item was modified.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_action ()

Return Value

Type: ItemModifyAction
The type of modification action.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs.get_item Method

ItemModifiedEventArgs.get_item Method
[image]

Gets the item related to the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_item ()

Return Value

Type: Item
The item associated with the event.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs.get_oldItem Method

ItemModifiedEventArgs.get_oldItem Method
[image]

Gets the old item related to the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_oldItem ()

Return Value

Type: Item
The old item.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifyAction Enumeration

ItemModifyAction Enumeration
[image]

Specifies the type of modification action used, when an item is modified.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
ItemModifyAction = {}

Members

Member name | Description
Drag | Value: 1. Specifies that the item is modified through an interactive drag operation.
Edit | Value: 0. Specifies that the item was modified through a modification of one or more of its properties, excluding drag and resize interactive operations.
Resize | Value: 2. Specifies that the item is modified through an interactive resize operation.

See Also


MindFusion.Scheduling.ItemsCueForm Class

ItemsCueForm Class
Remarks See Also
[image]

The ItemsCueForm class represents a dialog that gives details about items, which are present but not rendered in the cell, usually due to lack of space.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

// class
ItemsCueForm.prototype = {}

Remarks

Click on the smart-tag glyph in the cell to show the ItemsCueForm for the hidden items.

See Also

ItemsCueForm Members


MindFusion.Scheduling.ItemsCueForm Members

ItemsCueForm Members
Constructors
[image]

The ItemsCueForm class represents a dialog that gives details about items, which are present but not rendered in the cell, usually due to lack of space.

The following tables list the members exposed by the ItemsCueForm type.

Public Constructors

Name | Description
ItemsCueForm | Initializes a new instance of the ItemsCueForm class.

See Also

ItemsCueForm Class


MindFusion.Scheduling.ItemsCueForm Constructor

ItemsCueForm Constructor
[image]

Initializes a new instance of the ItemsCueForm class.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function ItemsCueForm (calendar, items, cell)

Parameters

calendar

Type: Calendar
The Calendar.

items

Type: Array
The list of items to be shown in the form.

cell

Type: Object
The cell for which the smart-tag glyph is shown.

Remarks

Click on the smart-tag glyph in the cell to show the ItemsCueForm for the hidden items.

See Also

ItemsCueForm Class


MindFusion.Scheduling.ItemSelectionEventArgs Class

ItemSelectionEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemSelectionChanged event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
ItemSelectionEventArgs.prototype = {}

See Also

ItemSelectionEventArgs Members


MindFusion.Scheduling.ItemSelectionEventArgs Members

ItemSelectionEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of the ItemSelectionChanged event.

The following tables list the members exposed by the ItemSelectionEventArgs type.

Public Constructors

Name | Description
ItemSelectionEventArgs | Initializes a new instance of the ItemSelectionEventArgs class.

Public Methods

Name | Description
get_item | Gets the item associated with the event.
get_selected | Gets a value indicating whether the item has been added to or removed from the selection.

See Also

ItemSelectionEventArgs Class


MindFusion.Scheduling.ItemSelectionEventArgs Constructor

ItemSelectionEventArgs Constructor
[image]

Initializes a new instance of the ItemSelectionEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function ItemSelectionEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of the ItemSelectionChanged event.

See Also

ItemSelectionEventArgs Class


MindFusion.Scheduling.ItemSelectionEventArgs Methods

ItemSelectionEventArgs Methods
[image]

Public Methods

Name | Description
get_item | Gets the item associated with the event.
get_selected | Gets a value indicating whether the item has been added to or removed from the selection.

See Also

ItemSelectionEventArgs Class


MindFusion.Scheduling.ItemSelectionEventArgs.get_item Method

ItemSelectionEventArgs.get_item Method
[image]

Gets the item associated with the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_item ()

Return Value

Type: Item
The item associated with the event.

See Also

ItemSelectionEventArgs Members
ItemSelectionEventArgs Class


MindFusion.Scheduling.ItemSelectionEventArgs.get_selected Method

ItemSelectionEventArgs.get_selected Method
[image]

Gets a value indicating whether the item has been added to or removed from the selection.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_selected ()

Return Value

Type: Boolean
True if the item has been added to the selection, otherwise false.

See Also

ItemSelectionEventArgs Members
ItemSelectionEventArgs Class


MindFusion.Scheduling.Keys Enumeration

Keys Enumeration
[image]

Identifies special Keys.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
Keys = {}

Members

Member name | Description
Alt | Value: 3. The ALT modifier key.
Control | Value: 2. The CTRL modifier key.
None | Value: 0. No key pressed.
Shift | Value: 1. The SHIFT modifier key.

See Also


MindFusion.Scheduling.Location Class

Location Class
[image]

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// class
Location.prototype = {}

See Also

Location Members


MindFusion.Scheduling.Location Members

Location Members
Methods
[image]

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

The following tables list the members exposed by the Location type.

Public Methods

Name | Description
getAddress | Gets the address of the location.
getCity | Gets the city of the location.
getCountry | Gets the country of the location.
getState | Gets the state of the location.
getZipCode | Gets the zip code of the location.

See Also

Location Class


MindFusion.Scheduling.Location Methods

Location Methods
[image]

Public Methods

Name | Description
getAddress | Gets the address of the location.
getCity | Gets the city of the location.
getCountry | Gets the country of the location.
getState | Gets the state of the location.
getZipCode | Gets the zip code of the location.

See Also

Location Class


MindFusion.Scheduling.Location.getAddress Method

Location.getAddress Method
[image]

Gets the address of the location.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getAddress ()

Return Value

Type: String
The address of the location.

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.getCity Method

Location.getCity Method
[image]

Gets the city of the location.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCity ()

Return Value

Type: String
The city of the location.

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.getCountry Method

Location.getCountry Method
[image]

Gets the country of the location.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getCountry ()

Return Value

Type: String
The country of the location.

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.getState Method

Location.getState Method
[image]

Gets the state of the location.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getState ()

Return Value

Type: String
The state of the location.

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.getZipCode Method

Location.getZipCode Method
[image]

Gets the zip code of the location.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getZipCode ()

Return Value

Type: String
The zip code of the location.

See Also

Location Members
Location Class


MindFusion.Scheduling.MonthlyRecurrence Enumeration

MonthlyRecurrence Enumeration
[image]

Specifies the pattern of daily recurrence for a task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
MonthlyRecurrence = {}

Members

Member name | Description
ByDayNumber | Value: 0. The event occurs at the day with the specified number.
ByDayType | Value: 1. The event occurs at the specified day.

See Also


MindFusion.Scheduling.MouseEventArgs Class

MouseEventArgs Class
[image]

Contains the arguments passed to handlers of the MouseEnter, MouseMove and MouseLeave calendar and item events.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
MouseEventArgs.prototype = {}

See Also

MouseEventArgs Members


MindFusion.Scheduling.MouseEventArgs Members

MouseEventArgs Members
Constructors
[image]

Contains the arguments passed to handlers of the MouseEnter, MouseMove and MouseLeave calendar and item events.

The following tables list the members exposed by the MouseEventArgs type.

Public Constructors

Name | Description
MouseEventArgs | Initializes a new instance of the MouseEventArgs class.

See Also

MouseEventArgs Class


MindFusion.Scheduling.MouseEventArgs Constructor

MouseEventArgs Constructor
[image]

Initializes a new instance of the MouseEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function MouseEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of the MouseEnter, MouseMove and MouseLeave calendar and item events.

See Also

MouseEventArgs Class


MindFusion.Scheduling.NewForm Class

NewForm Class
[image]

The NewForm class represents a dialog for creating new items.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

// class
NewForm.prototype = {}

See Also

NewForm Members


MindFusion.Scheduling.NewForm Members

NewForm Members
Constructors
[image]

The NewForm class represents a dialog for creating new items.

The following tables list the members exposed by the NewForm type.

Public Constructors

Name | Description
NewForm | Initializes a new instance of the NewForm class.

See Also

NewForm Class


MindFusion.Scheduling.NewForm Constructor

NewForm Constructor
[image]

Initializes a new instance of the NewForm class.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function NewForm (calendar, item)

Parameters

calendar

Type: Calendar
The calendar.

item

Type: Object
An object containing the initial data for the item to be created.

See Also

NewForm Class


MindFusion.Scheduling.Occurrence Enumeration

Occurrence Enumeration
[image]

Specifies the occurrence of the event.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
Occurrence = {}

Members

Member name | Description
First | Value: 0. Specifies the first occurrence of the event.
Fourth | Value: 3. Specifies the first occurrence of the event.
Last | Value: 4. Specifies the last occurrence of the event.
Second | Value: 1. Specifies the first occurrence of the event.
Third | Value: 2. Specifies the first occurrence of the event.

See Also


MindFusion.Scheduling.Orientation Enumeration

Orientation Enumeration
[image]

Specifies orientation for calendar items and views.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
Orientation = {}

Members

Member name | Description
Horizontal | Value: 0. Indicates a horizontal orientation.
Unspecified | Value: -1. Unspecified.
Vertical | Value: 1. Indicates a vertical orientation.

See Also


MindFusion.Scheduling.Recurrence Class

Recurrence Class
[image]

Defines recurrence patterns for items scheduled to repeat.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

// class
Recurrence.prototype = {}

See Also

Recurrence Members


MindFusion.Scheduling.Recurrence Members

Recurrence Members
Constructors Methods
[image]

Defines recurrence patterns for items scheduled to repeat.

The following tables list the members exposed by the Recurrence type.

Public Constructors

Name | Description
Recurrence | Initializes a new instance of the Recurrence class.

Public Methods

Name | Description
equals | Compares two Recurrence objects.
getDailyRecurrence | Gets the type of daily recurrence.
getDay | Gets a value indicating on which day of a week the event occurs.
getDayOfMonth | Gets on which day of a month the event occurs.
getDays | Gets how many days should pass before the event occurs again.
getDaysOfWeek | Gets on which days of a week the event occurs.
getEndDate | Gets the end date of the recurrence.
getExceptions | Gets the list of all recurrence exceptions.
getInterval | Gets the recurrence interval in hours.
getMaster | Gets the master item of the recurrence.
getMonthlyRecurrence | Gets the type of monthly recurrence.
getMonthOfYear | Gets in which month of the year the event occurs.
getMonths | Gets how many months should pass before the event occurs again.
getNumOccurrences | Gets a value indicating how many times the recurring event should occur.
getOccurrence | Gets on which occurrence of the day type specified by getDay the event occurs.
getPattern | Gets the recurrence pattern.
getRecurrenceEnd | Gets a value, indicating when the event should stop recurring.
getStartDate | Gets the start date of the recurrence.
getWeeks | Gets how many weeks should pass before the event occurs again.
getYearlyRecurrence | Gets the type of yearly recurrence.
toLocalizedString | Returns a localized string that represents this Recurrence using the specified date and time formatting info and localization information.
toString | Returns a string that represents the current Recurrence object.

See Also

Recurrence Class


MindFusion.Scheduling.Recurrence Constructor

Recurrence Constructor
[image]

Initializes a new instance of the Recurrence class.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function Recurrence (recurrence)

Parameters

recurrence

Type: Object
The object containing the recurrence info.

Remarks

Detailed information on how to programatically create Recurrence instances on the client can be found here.

See Also

Recurrence Class
Recurrences on the Client


MindFusion.Scheduling.Recurrence Methods

Recurrence Methods
[image]

Public Methods

Name | Description
equals | Compares two Recurrence objects.
getDailyRecurrence | Gets the type of daily recurrence.
getDay | Gets a value indicating on which day of a week the event occurs.
getDayOfMonth | Gets on which day of a month the event occurs.
getDays | Gets how many days should pass before the event occurs again.
getDaysOfWeek | Gets on which days of a week the event occurs.
getEndDate | Gets the end date of the recurrence.
getExceptions | Gets the list of all recurrence exceptions.
getInterval | Gets the recurrence interval in hours.
getMaster | Gets the master item of the recurrence.
getMonthlyRecurrence | Gets the type of monthly recurrence.
getMonthOfYear | Gets in which month of the year the event occurs.
getMonths | Gets how many months should pass before the event occurs again.
getNumOccurrences | Gets a value indicating how many times the recurring event should occur.
getOccurrence | Gets on which occurrence of the day type specified by getDay the event occurs.
getPattern | Gets the recurrence pattern.
getRecurrenceEnd | Gets a value, indicating when the event should stop recurring.
getStartDate | Gets the start date of the recurrence.
getWeeks | Gets how many weeks should pass before the event occurs again.
getYearlyRecurrence | Gets the type of yearly recurrence.
toLocalizedString | Returns a localized string that represents this Recurrence using the specified date and time formatting info and localization information.
toString | Returns a string that represents the current Recurrence object.

See Also

Recurrence Class


MindFusion.Scheduling.Recurrence.equals Method

Recurrence.equals Method
[image]

Compares two Recurrence objects.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function equals (recurrence)

Parameters

recurrence

Type: Recurrence
A Recurrence object to compare with the current Recurrence object.

Return Value

Type: Boolean
True if the specified Recurrence is equal to the current Recurrence, otherwise false.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getDailyRecurrence Method

Recurrence.getDailyRecurrence Method
[image]

Gets the type of daily recurrence.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getDailyRecurrence ()

Return Value

Type: DailyRecurrence
The type of daily recurrence.

Remarks

This value is used when the recurrence Pattern is set to Daily.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getDay Method

Recurrence.getDay Method
[image]

Gets a value indicating on which day of a week the event occurs.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getDay ()

Return Value

Type: DayOfWeekType
The day of a week.

Remarks

This value is used when the recurrence Pattern is set to Monthly or Yearly and MonthlyRecurrence or YearlyRecurrence are set to ByDayType.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getDayOfMonth Method

Recurrence.getDayOfMonth Method
[image]

Gets on which day of a month the event occurs.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getDayOfMonth ()

Return Value

Type: Number
The value specifying at which day of month the recurring event occurs (1-31).

Remarks

This value is used when the recurrence Pattern is set to Monthly or Yearly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getDays Method

Recurrence.getDays Method
[image]

Gets how many days should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getDays ()

Return Value

Type: Number
The number of days.

Remarks

This value is used when the recurrence Pattern is set to Daily.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getDaysOfWeek Method

Recurrence.getDaysOfWeek Method
[image]

Gets on which days of a week the event occurs.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getDaysOfWeek ()

Return Value

Type: DaysOfWeek
The days of week.

Remarks

This value is used when the recurrence Pattern is set to Weekly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getEndDate Method

Recurrence.getEndDate Method
[image]

Gets the end date of the recurrence.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getEndDate ()

Return Value

Type: DateTime
The end date of the recurrence if the recurrence is set to expire or DateTime.maxValue if RecurrenceEnd is set to Never.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getExceptions Method

Recurrence.getExceptions Method
[image]

Gets the list of all recurrence exceptions.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getExceptions ()

Return Value

Type: Dictionary
The list of all recurrence exceptions.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getInterval Method

Recurrence.getInterval Method
[image]

Gets the recurrence interval in hours.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getInterval ()

Return Value

Type: Number
The recurrence interval in hours.

Remarks

This value is used when the recurrence Pattern is set to ByTimeInterval.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getMaster Method

Recurrence.getMaster Method
[image]

Gets the master item of the recurrence.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getMaster ()

Return Value

Type: Item
The master item of the recurrence.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getMonthlyRecurrence Method

Recurrence.getMonthlyRecurrence Method
[image]

Gets the type of monthly recurrence.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getMonthlyRecurrence ()

Return Value

Type: MonthlyRecurrence
The type of monthly recurrence.

Remarks

This value is used when the recurrence Pattern is set to Monthly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getMonthOfYear Method

Recurrence.getMonthOfYear Method
[image]

Gets in which month of the year the event occurs.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getMonthOfYear ()

Return Value

Type: Number
The month (0-11);

Remarks

The value of this property is used when the recurrence Pattern is set to Yearly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getMonths Method

Recurrence.getMonths Method
[image]

Gets how many months should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getMonths ()

Return Value

Type: Number
The number of months.

Remarks

The value of this property is used when the recurrence Pattern is set to Monthly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getNumOccurrences Method

Recurrence.getNumOccurrences Method
[image]

Gets a value indicating how many times the recurring event should occur.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getNumOccurrences ()

Return Value

Type: Number
The value indicating how many times the recurring event should occur.

Remarks

The value of this property is used when RecurrenceEnd is set to NumOccurrences.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getOccurrence Method

Recurrence.getOccurrence Method
[image]

Gets on which occurrence of the day type specified by getDay the event occurs.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getOccurrence ()

Return Value

Type: Occurrence
The day type.

Remarks

The value of this property is used when the recurrence Pattern is set to Monthly or Yearly and MonthlyRecurrence or YearlyRecurrence are set to ByDayType.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getPattern Method

Recurrence.getPattern Method
[image]

Gets the recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getPattern ()

Return Value

Type: RecurrencePattern
The recurrence pattern.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getRecurrenceEnd Method

Recurrence.getRecurrenceEnd Method
[image]

Gets a value, indicating when the event should stop recurring.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getRecurrenceEnd ()

Return Value

Type: RecurrenceEnd
A value, indicating when the event should stop recurring.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getStartDate Method

Recurrence.getStartDate Method
[image]

Gets the start date of the recurrence.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getStartDate ()

Return Value

Type: DateTime
The date when the recurring event should occur for the first time.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getWeeks Method

Recurrence.getWeeks Method
[image]

Gets how many weeks should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getWeeks ()

Return Value

Type: Number
The number of weeks.

Remarks

This value is used when the recurrence Pattern is set to Weekly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.getYearlyRecurrence Method

Recurrence.getYearlyRecurrence Method
[image]

Gets the type of yearly recurrence.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getYearlyRecurrence ()

Return Value

Type: YearlyRecurrence
The type of yearly recurrence.

Remarks

This value is used when the recurrence Pattern is set to Yearly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.toLocalizedString Method

Recurrence.toLocalizedString Method
[image]

Returns a localized string that represents this Recurrence using the specified date and time formatting info and localization information.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function toLocalizedString (info, localInfo)

Parameters

info

Type: Object
Specifies how date and time values are formatted and displayed.

localInfo

Type: Object
Specifies localized strings used in the representation.

Return Value

Type: String
A localized string representation of this Recurrence object.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.toString Method

Recurrence.toString Method
[image]

Returns a string that represents the current Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function toString ([info])

Parameters

info
Optional.

Type: Object
An object that contains an array of culture-sensitive formatting strings.

Return Value

Type: String
A string that represents the current Recurrence object.

Remarks

If no parameter is passed to this function, the recurrence info is formatted against Sys.CultureInfo.InvariantCulture.dateTimeFormat.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.RecurrenceEnd Enumeration

RecurrenceEnd Enumeration
[image]

Specifies when the recurrence series ends.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
RecurrenceEnd = {}

Members

Member name | Description
EndDate | Value: 2. The recurrence series ends at the specified date.
Never | Value: 0. The recurrence series does not end.
NumOccurrences | Value: 1. The recurrence series ends after the event is repeated the given number of times.

See Also


MindFusion.Scheduling.RecurrenceException Class

RecurrenceException Class
[image]

The RecurrenceException class represents an exception from the recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

// class
RecurrenceException.prototype = {}

See Also

RecurrenceException Members


MindFusion.Scheduling.RecurrenceException Members

RecurrenceException Members
Methods
[image]

The RecurrenceException class represents an exception from the recurrence patterns.

The following tables list the members exposed by the RecurrenceException type.

Public Methods

Name | Description
getDeleted | Gets a value indicating whether this occurrence has been deleted.
getIndex | Gets the index of the exception.
getItem | Gets the item associated with this exception.

See Also

RecurrenceException Class


MindFusion.Scheduling.RecurrenceException Methods

RecurrenceException Methods
[image]

Public Methods

Name | Description
getDeleted | Gets a value indicating whether this occurrence has been deleted.
getIndex | Gets the index of the exception.
getItem | Gets the item associated with this exception.

See Also

RecurrenceException Class


MindFusion.Scheduling.RecurrenceException.getDeleted Method

RecurrenceException.getDeleted Method
[image]

Gets a value indicating whether this occurrence has been deleted.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getDeleted ()

Return Value

Type: Boolean
True if the occurrence has been deleted, otherwise false.

See Also

RecurrenceException Members
RecurrenceException Class


MindFusion.Scheduling.RecurrenceException.getIndex Method

RecurrenceException.getIndex Method
[image]

Gets the index of the exception.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getIndex ()

Return Value

Type: Number
The index of the exception.

See Also

RecurrenceException Members
RecurrenceException Class


MindFusion.Scheduling.RecurrenceException.getItem Method

RecurrenceException.getItem Method
[image]

Gets the item associated with this exception.

Namespace: MindFusion.Scheduling
Assembly: Recurrence.js

Syntax

JavaScript [image] Copy Code

function getItem ()

Return Value

Type: Item
The item associated with this exception.

See Also

RecurrenceException Members
RecurrenceException Class


MindFusion.Scheduling.RecurrenceForm Class

RecurrenceForm Class
[image]

The RecurrenceForm class represents a dialog for creating and modifying Recurrence objects.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

// class
RecurrenceForm.prototype = {}

See Also

RecurrenceForm Members


MindFusion.Scheduling.RecurrenceForm Members

RecurrenceForm Members
Constructors
[image]

The RecurrenceForm class represents a dialog for creating and modifying Recurrence objects.

The following tables list the members exposed by the RecurrenceForm type.

Public Constructors

Name | Description
RecurrenceForm | Initializes a new instance of the RecurrenceForm class.

See Also

RecurrenceForm Class


MindFusion.Scheduling.RecurrenceForm Constructor

RecurrenceForm Constructor
[image]

Initializes a new instance of the RecurrenceForm class.

Namespace: MindFusion.Scheduling
Assembly: Popup.js

Syntax

JavaScript [image] Copy Code

function RecurrenceForm (calendar, item)

Parameters

calendar

Type: Calendar
The Calendar.

item

Type: Item
The item to be modified.

See Also

RecurrenceForm Class


MindFusion.Scheduling.RecurrencePattern Enumeration

RecurrencePattern Enumeration
[image]

Specifies the pattern of recurrence for a task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
RecurrencePattern = {}

Members

Member name | Description
ByTimeInterval | Value: 4. The event occurs by a specified time interval.
Daily | Value: 0. The event occurs daily.
Monthly | Value: 2. The event occurs monthly.
Weekly | Value: 1. The event occurs weekly.
Yearly | Value: 3. The event occurs yearly.

See Also


MindFusion.Scheduling.RecurrenceState Enumeration

RecurrenceState Enumeration
[image]

Specifies the recurrence state of items.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
RecurrenceState = {}

Members

Member name | Description
Exception | Value: 2. Specifies an exception of a recurring event.
Master | Value: 3. Specifies a recurring event.
None | Value: 0. Specifies a one-time non-recurring event.
Occurrence | Value: 1. Specifies a single occurrence of a recurring event.

See Also


MindFusion.Scheduling.Reminder Class

Reminder Class
[image]

The Reminder class represents reminders associated with schedule items and tasks.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// class
Reminder.prototype = {}

See Also

Reminder Members


MindFusion.Scheduling.Reminder Members

Reminder Members
Constructors Methods
[image]

The Reminder class represents reminders associated with schedule items and tasks.

The following tables list the members exposed by the Reminder type.

Public Constructors

Name | Description
Reminder | Initializes a new instance of the Reminder class.

Public Methods

Name | Description
getMessage | Gets the message of the reminder.
getTime | Gets the exact time when the reminder is triggered.
getTimeInterval | Gets how much time (in milliseconds) before the item's scheduled start time to raise the event that triggers the reminder.
getType | Gets the type of the reminder.

See Also

Reminder Class


MindFusion.Scheduling.Reminder Constructor

Reminder Constructor
[image]

Initializes a new instance of the Reminder class.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function Reminder (reminder)

Parameters

reminder

Type: Object
The object containing the reminder info.

See Also

Reminder Class


MindFusion.Scheduling.Reminder Methods

Reminder Methods
[image]

Public Methods

Name | Description
getMessage | Gets the message of the reminder.
getTime | Gets the exact time when the reminder is triggered.
getTimeInterval | Gets how much time (in milliseconds) before the item's scheduled start time to raise the event that triggers the reminder.
getType | Gets the type of the reminder.

See Also

Reminder Class


MindFusion.Scheduling.Reminder.getMessage Method

Reminder.getMessage Method
[image]

Gets the message of the reminder.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getMessage ()

Return Value

Type: String
The message of the reminder.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.getTime Method

Reminder.getTime Method
[image]

Gets the exact time when the reminder is triggered.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getTime ()

Return Value

Type: DateTime
The time to trigger the reminder.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.getTimeInterval Method

Reminder.getTimeInterval Method
[image]

Gets how much time (in milliseconds) before the item's scheduled start time to raise the event that triggers the reminder.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getTimeInterval ()

Return Value

Type: Number
The time interval of the reminder in milliseconds.

Remarks

Maximum value is 172 800 000 ms (2 days).

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.getType Method

Reminder.getType Method
[image]

Gets the type of the reminder.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getType ()

Return Value

Type: ReminderType
The type of the reminder.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.ReminderType Enumeration

ReminderType Enumeration
[image]

Specifies the type of a reminder.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
ReminderType = {}

Members

Member name | Description
Exact | Value: 0. Trigger the reminder at the exact time specified in its time property. Note: Recurring items cannot have exact reminders.
Leading | Value: 1. Trigger the reminder at the specified timeInterval before the item's scheduled start time. Note: Tasks cannot have leading reminders.

See Also


MindFusion.Scheduling.Resource Class

Resource Class
[image]

Instances of the Resource class contain information about arbitrary resources.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// class
Resource.prototype = {}

See Also

Resource Members


MindFusion.Scheduling.Resource Members

Resource Members
Methods
[image]

Instances of the Resource class contain information about arbitrary resources.

The following tables list the members exposed by the Resource type.

Public Methods

Name | Description
getId | Gets the id of the resource.
getName | Gets the name of the resource.
getTag | Gets the custom data associated with the resource.

See Also

Resource Class


MindFusion.Scheduling.Resource Methods

Resource Methods
[image]

Public Methods

Name | Description
getId | Gets the id of the resource.
getName | Gets the name of the resource.
getTag | Gets the custom data associated with the resource.

See Also

Resource Class


MindFusion.Scheduling.Resource.getId Method

Resource.getId Method
[image]

Gets the id of the resource.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getId ()

Return Value

Type: String
The id of the resource.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.getName Method

Resource.getName Method
[image]

Gets the name of the resource.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getName ()

Return Value

Type: String
The name of the resource.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.getTag Method

Resource.getTag Method
[image]

Gets the custom data associated with the resource.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getTag ()

Return Value

Type: Object
The custom data associated with the resource.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.SelectionChangedEventArgs Class

SelectionChangedEventArgs Class
[image]

Contains the arguments passed to handlers of the SelectionChanged event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
SelectionChangedEventArgs.prototype = {}

See Also

SelectionChangedEventArgs Members


MindFusion.Scheduling.SelectionChangedEventArgs Members

SelectionChangedEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of the SelectionChanged event.

The following tables list the members exposed by the SelectionChangedEventArgs type.

Public Constructors

Name | Description
SelectionChangedEventArgs | Initializes a new instance of the SelectionChangedEventArgs class.

Public Methods

Name | Description
get_newSelection | Gets the start and end time of the new selection.
get_oldSelection | Gets the start and end time of the old selection.

See Also

SelectionChangedEventArgs Class


MindFusion.Scheduling.SelectionChangedEventArgs Constructor

SelectionChangedEventArgs Constructor
[image]

Initializes a new instance of the SelectionChangedEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function SelectionChangedEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of the SelectionChanged event.

See Also

SelectionChangedEventArgs Class


MindFusion.Scheduling.SelectionChangedEventArgs Methods

SelectionChangedEventArgs Methods
[image]

Public Methods

Name | Description
get_newSelection | Gets the start and end time of the new selection.
get_oldSelection | Gets the start and end time of the old selection.

See Also

SelectionChangedEventArgs Class


MindFusion.Scheduling.SelectionChangedEventArgs.get_newSelection Method

SelectionChangedEventArgs.get_newSelection Method
[image]

Gets the start and end time of the new selection.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_newSelection ()

Return Value

Type: Array
The start and end time of the new selection.

Remarks

The returned Array contains two DateTime objects representing the start and the end time of the new selection.

See Also

SelectionChangedEventArgs Members
SelectionChangedEventArgs Class


MindFusion.Scheduling.SelectionChangedEventArgs.get_oldSelection Method

SelectionChangedEventArgs.get_oldSelection Method
[image]

Gets the start and end time of the old selection.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_oldSelection ()

Return Value

Type: Array
The start and end time of the old selection.

Remarks

The returned Array contains two DateTime objects representing the start and the end time of the old selection.

See Also

SelectionChangedEventArgs Members
SelectionChangedEventArgs Class


MindFusion.Scheduling.SelectionEventArgs Class

SelectionEventArgs Class
[image]

Contains the arguments passed to handlers of the SelectionStart and SelectionEnd events.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
SelectionEventArgs.prototype = {}

See Also

SelectionEventArgs Members


MindFusion.Scheduling.SelectionEventArgs Members

SelectionEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of the SelectionStart and SelectionEnd events.

The following tables list the members exposed by the SelectionEventArgs type.

Public Constructors

Name | Description
SelectionEventArgs | Initializes a new instance of the SelectionEventArgs class.

Public Methods

Name | Description
get_endTime | Gets the selection end time.
get_startTime | Gets the selection start time.

See Also

SelectionEventArgs Class


MindFusion.Scheduling.SelectionEventArgs Constructor

SelectionEventArgs Constructor
[image]

Initializes a new instance of the SelectionEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function SelectionEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of the SelectionStart and SelectionEnd events.

See Also

SelectionEventArgs Class


MindFusion.Scheduling.SelectionEventArgs Methods

SelectionEventArgs Methods
[image]

Public Methods

Name | Description
get_endTime | Gets the selection end time.
get_startTime | Gets the selection start time.

See Also

SelectionEventArgs Class


MindFusion.Scheduling.SelectionEventArgs.get_endTime Method

SelectionEventArgs.get_endTime Method
[image]

Gets the selection end time.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_endTime ()

Return Value

Type: DateTime
The selection end time.

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Scheduling.SelectionEventArgs.get_startTime Method

SelectionEventArgs.get_startTime Method
[image]

Gets the selection start time.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_startTime ()

Return Value

Type: DateTime
The selection start time.

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Scheduling.Task Class

Task Class
[image]

Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// class
Task.prototype = {}

See Also

Task Members


MindFusion.Scheduling.Task Members

Task Members
Methods
[image]

Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.

The following tables list the members exposed by the Task type.

Public Methods

Name | Description
getActualCost | Gets the actual cost of the task.
getActualDuration | Gets the actual duration of the task.
getActualEnd | Gets the actual end date of the task.
getActualStart | Gets the actual start date of the task.
getDetails | Gets the details of the task.
getDueDate | Gets the due date of the task.
getEstimatedCost | Gets the estimated cost of the task.
getEstimatedDuration | Gets the estimated duration of the task.
getPriority | Gets the priority of the task.
getProgress | Gets the progress of the task.
getStartDate | Gets the start date of the task.
getStatus | Gets the status of the task.
getSubject | Gets the subject of the task.

See Also

Task Class


MindFusion.Scheduling.Task Methods

Task Methods
[image]

Public Methods

Name | Description
getActualCost | Gets the actual cost of the task.
getActualDuration | Gets the actual duration of the task.
getActualEnd | Gets the actual end date of the task.
getActualStart | Gets the actual start date of the task.
getDetails | Gets the details of the task.
getDueDate | Gets the due date of the task.
getEstimatedCost | Gets the estimated cost of the task.
getEstimatedDuration | Gets the estimated duration of the task.
getPriority | Gets the priority of the task.
getProgress | Gets the progress of the task.
getStartDate | Gets the start date of the task.
getStatus | Gets the status of the task.
getSubject | Gets the subject of the task.

See Also

Task Class


MindFusion.Scheduling.Task.getActualCost Method

Task.getActualCost Method
[image]

Gets the actual cost of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getActualCost ()

Return Value

Type: Number
The actual cost of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getActualDuration Method

Task.getActualDuration Method
[image]

Gets the actual duration of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getActualDuration ()

Return Value

Type: Number
The actual duration of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getActualEnd Method

Task.getActualEnd Method
[image]

Gets the actual end date of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getActualEnd ()

Return Value

Type: DateTime
The actual end date of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getActualStart Method

Task.getActualStart Method
[image]

Gets the actual start date of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getActualStart ()

Return Value

Type: DateTime
The actual start date of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getDetails Method

Task.getDetails Method
[image]

Gets the details of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getDetails ()

Return Value

Type: String
The details of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getDueDate Method

Task.getDueDate Method
[image]

Gets the due date of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getDueDate ()

Return Value

Type: DateTime
The due date of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getEstimatedCost Method

Task.getEstimatedCost Method
[image]

Gets the estimated cost of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getEstimatedCost ()

Return Value

Type: Number
The estimated cost of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getEstimatedDuration Method

Task.getEstimatedDuration Method
[image]

Gets the estimated duration of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getEstimatedDuration ()

Return Value

Type: Number
The estimated duration of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getPriority Method

Task.getPriority Method
[image]

Gets the priority of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getPriority ()

Return Value

Type: TaskPriority
The priority of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getProgress Method

Task.getProgress Method
[image]

Gets the progress of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getProgress ()

Return Value

Type: Number
The progress of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getStartDate Method

Task.getStartDate Method
[image]

Gets the start date of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getStartDate ()

Return Value

Type: DateTime
The start date of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getStatus Method

Task.getStatus Method
[image]

Gets the status of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getStatus ()

Return Value

Type: TaskStatus
The status of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.getSubject Method

Task.getSubject Method
[image]

Gets the subject of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

function getSubject ()

Return Value

Type: String
The subject of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.TaskEventArgs Class

TaskEventArgs Class
[image]

Contains the arguments passed to handlers of the TaskReminderTriggered event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
TaskEventArgs.prototype = {}

See Also

TaskEventArgs Members


MindFusion.Scheduling.TaskEventArgs Members

TaskEventArgs Members
Constructors Methods
[image]

Contains the arguments passed to handlers of the TaskReminderTriggered event.

The following tables list the members exposed by the TaskEventArgs type.

Public Constructors

Name | Description
TaskEventArgs | Initializes a new instance of the TaskEventArgs class.

Public Methods

Name | Description
get_task | Gets the Task object associated with the event.

See Also

TaskEventArgs Class


MindFusion.Scheduling.TaskEventArgs Constructor

TaskEventArgs Constructor
[image]

Initializes a new instance of the TaskEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function TaskEventArgs ([args])

Parameters

args
Optional.

Type: Object
The arguments passed to handlers of the TaskReminderTriggered event.

See Also

TaskEventArgs Class


MindFusion.Scheduling.TaskEventArgs Methods

TaskEventArgs Methods
[image]

Public Methods

Name | Description
get_task | Gets the Task object associated with the event.

See Also

TaskEventArgs Class


MindFusion.Scheduling.TaskEventArgs.get_task Method

TaskEventArgs.get_task Method
[image]

Gets the Task object associated with the event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

function get_task ()

Return Value

Type: Task
The task associated with the event.

See Also

TaskEventArgs Members
TaskEventArgs Class


MindFusion.Scheduling.TaskPriority Enumeration

TaskPriority Enumeration
[image]

Specifies the priority of tasks.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
TaskPriority = {}

Members

Member name | Description
High | Value: 2. The task is with high priority.
Low | Value: 0. The task is with low priority.
Normal | Value: 1. The task is with normal priority.

See Also


MindFusion.Scheduling.TaskStatus Enumeration

TaskStatus Enumeration
[image]

Specifies the status of the task.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
TaskStatus = {}

Members

Member name | Description
Completed | Value: 2. The task is completed.
Deferred | Value: 4. The task is deferred.
InProgress | Value: 1. The task is still in progress.
NotStarted | Value: 0. The task has not started yet.
WaitingOther | Value: 3. The task is waiting another one.

See Also


MindFusion.Scheduling.ThemeType Enumeration

ThemeType Enumeration
[image]

Specifies the theme to be applied.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
ThemeType = {}

Members

Member name | Description
Lila | Value: 2. Specifies the Lila theme.
Silver | Value: 3. Specifies the Silver theme.
Standard | Value: 0. Specifies the Standard theme.
Vista | Value 4. Specifies the Vista theme.
Windows2003 | Value: 1. Specifies the Windows2003 theme.

See Also


MindFusion.Scheduling.TimeUnit Enumeration

TimeUnit Enumeration
[image]

Specifies the TimeUnit.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
TimeUnit = {}

Members

Member name | Description
Day | Type: Int32 Value: 3. The TimeUnit is a day.
Hour | Type: Int32 Value: 2. The TimeUnit is an hour.
Minute | Type: Int32 Value: 1. The TimeUnit is a minute.
Month | Type: Int32 Value: 5. The TimeUnit is a month.
Second | Type: Int32 Value: 0. The TimeUnit is a second.
Unspecified | Type: Int32 Value: -1. The TimeUnit is not specified.
Week | Type: Int32 Value: 4. The TimeUnit is a week.
Year | Type: Int32 Value: 6. The TimeUnit is an year.

See Also


MindFusion.Scheduling.WebPlanner.RecurrenceStringValidationEventArgs Class

WebPlanner.RecurrenceStringValidationEventArgs Class
[image]

Contains the arguments passed to handlers of the RecurrenceStringValidation event.

Namespace: MindFusion.Scheduling
Assembly: EventArgs.js

Syntax

JavaScript [image] Copy Code

// class
WebPlanner.RecurrenceStringValidationEventArgs.prototype = {}

See Also

WebPlanner.RecurrenceStringValidationEventArgs Members


MindFusion.Scheduling.WebPlanner.RecurrenceStringValidationEventArgs Members

WebPlanner.RecurrenceStringValidationEventArgs Members
[image]

Contains the arguments passed to handlers of the RecurrenceStringValidation event.

The following tables list the members exposed by the WebPlanner.RecurrenceStringValidationEventArgs type.

See Also

WebPlanner.RecurrenceStringValidationEventArgs Class


MindFusion.Scheduling.WeekRangeViewStyle Enumeration

WeekRangeViewStyle Enumeration
[image]

Specifies whether there are multiple weeks displayed in WeekRange view.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
WeekRangeViewStyle = {}

Members

Member name | Description
SingleWeek | Value: 1. The calendar view displays a single week at a time.
WeekPerRow | Value: 0. The calendar view displays several weeks at a time.

See Also


MindFusion.Scheduling.YearlyRecurrence Enumeration

YearlyRecurrence Enumeration
[image]

Specifies the yearly recurrence of an item.

Namespace: MindFusion.Scheduling
Assembly: Calendar.js

Syntax

JavaScript [image] Copy Code

// enum
YearlyRecurrence = {}

Members

Member name | Description
ByDayType | Value: 1. The event occurs by type of the day.
SpecificDate | Value: 0. The event occurs at a given date of the year.

See Also


Server Side Reference

Server Side Reference


MindFusion.Scheduling Namespace

MindFusion.Scheduling Namespace
Classes Enumerations

Classes

Class | Description
Appointment | Represents appointments within a schedule.
BinarySerializationContext | Contains methods that enable serialization/deserialization of MindFusion.Scheduling items to/from binary documents.
CollectionChangedEventArgs | Provides data for events raised when a collection has changed.
CollectionItemEventArgs(T) | A class that holds data for events that are raised when an item in a strongly-typed collection changes.
CollectionItemInsertEventArgs(T) | A class that holds event data for events raised when an item in a strongly typed collection is inserted.
CollectionItemSetEventArgs(T) | A class that provides event data for events raised when an item in a strongly typed collection is set.
Contact | Represents an object that holds contact data for a person.
CssBackground | Represents CSS background properties of calendar elements.
CssBorderStyle | Represents the CSS style of the border of calendar elements.
CultureEventArgs | Provides data for events raised when the culture has changed.
DateChangedEventArgs | Specifies data for the VisibleDateChanged event.
HeaderStyle | Specifies the appearance of calendar header elements.
InstantiateItemEventArgs(T) | Specifies data for the InstantiateItem event.
InstantiateResourceEventArgs | Specifies data for the InstantiateResource event.
Item | Represents events scheduled to occur at a specified date and time.
ItemCollection(T) | Represents a collection of Item objects.
ItemEventArgs | Provides data for item related events.
ItemModifiedEventArgs | Specifies data for the ItemModified event.
ItemStyle | Specifies the appearance of calendar items.
ItemTimeEventArgs | Specifies data for time related events.
Location | Specifies data that identifies a location.
Recurrence | Defines recurrence patterns for items scheduled to repeat over and over again.
RecurrenceException | Represents an exception of the recurrence pattern.
Reminder | Represents reminders associated with schedule items.
Resource | Instances of the Resource class contain information about arbitrary resources.
ResourceCollection(T) | Represents a strongly-typed collection of Resource objects.
Schedule | Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances, which are the views.
SerializationContext | This class contains information required to serialize a Schedule element to and from a binary stream or XML document.
SerializationEventArgs | Provides data for serialization events.
SerializeTagEventArgs | Provides data for the SerializeTag and DeserializeTag event handlers.
StateCollection(T) | Represents a strongly-typed collection of T objects.
Style | Specifies the appearance of calendar elements.
Task | Represents a task in the calendar.
ThemeEventArgs | Provides data for the ThemeChanged event.
Thickness | Describes the thickness of a frame around a rectangle. Four double values describe the four sides of the frame.
TimeSpans | Defines commonly used time spans to save memory allocations.
XmlSerializationContext | Provides methods that read/write primitive data types from/into an XML document.

Enumerations

Enumeration | Description
BackgroundAttachment | Specifies how the background image is attached to the object.
BackgroundRepeat | Specifies how the background image of an object is tiled.
BorderSide | Specifies the sides of an html element to apply a style border to. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.
CollectionChangedAction | Specifies the action that has changed the collection.
ContentType | Specifies the type of file contents.
DailyRecurrence | Specifies daily recurrence patterns.
DayOfWeekType | Specifies the type of week day to use with ByDayType monthly and yearly recurrence patterns.
DaysOfWeek | Specifies the day of the week. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.
GroupType | Specifies grouping or filtering criteria for views that support grouping.
MonthlyRecurrence | Specifies the types of various monthly recurrence patterns.
Occurrence | Specifies the index of occurrence.
RecurrenceEnd | Specifies when to stop repeating recurring events.
RecurrencePattern | Specifies the interval at which recurring events occur.
RecurrenceState | Specifies the recurrence state of items.
ReminderType | Specifies the type of a reminder.
TaskPriority | Specifies the priority of a Task.
TaskStatus | Specifies status values for a Task.
TextAlignment | Specifies the alignment of text in its layout rectangle. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.
TimeUnit | Specifies a time resolution.
YearlyRecurrence | Specifies types of yearly recurrence patterns.


MindFusion.Scheduling.Appointment Class

Appointment Class
[image]

Represents appointments within a schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class Appointment : Item

Visual Basic [image] Copy Code

Public Class Appointment
Inherits Item

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Item
MindFusion.Scheduling.Appointment

See Also

Appointment Members


MindFusion.Scheduling.Appointment Members

Appointment Members
Constructors Properties Methods
[image]

Represents appointments within a schedule.

The following tables list the members exposed by the Appointment type.

Public Constructors

Name | Description
Appointment | Initializes a new instance of the Appointment class.

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the appointment is an all-day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the appointment's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the appointment's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the appointment.
Attendees | Gets a list with all attendees of this appointment.
Contacts | Gets a list with all contacts associated with this appointment.
CssClass | Gets or sets the css class of the appointment.
DescriptionText | Gets or sets text with details displayed for this appointment by the scheduling control.
Details | Gets or sets the detailed description of this appointment.
EndTime | Gets or sets the appointment's scheduled end time.
HeaderText | Gets or sets header text displayed for this appointment by the calendar control.
Id | Gets or sets the string identifier of this appointment.
Location | Gets or sets the appointment location.
Locked | Gets or sets a value indicating whether users are allowed to modify this appointment.
Reminder | Gets or sets the reminder for this appointment.
Resources | Gets a list with all resources associated with this appointment.
StartTime | Gets or sets the appointment's scheduled start time.
Style | Gets or sets the style associated with this appointment.
Subject | Gets or sets the subject of this appointment.
Tag | Gets or sets custom data associated with the appointment.
Task | Gets or sets the task associated with this appointment.
Visible | Gets or sets whether the appointment is visible.

Public Methods

Name | Description
Clone | Creates an exact copy of this Appointment.
LoadFrom | Overloaded.
LoadViewState | Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Control.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | Control.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
getAllDayEvent | Gets a value, indicating whether the item represents an all day event. (Inherited from Item.)
getContacts | Gets the list of contacts, associated with this item. (Inherited from Item.)
getCssClass | Gets the css class of the item. (Inherited from Item.)
getDescriptionText | Gets the description text of the item. (Inherited from Item.)
getDetails | Gets the description text of the item. (Inherited from Item.)
getEndTime | Gets the end time of the item. (Inherited from Item.)
getHeaderText | Gets the header text of the item. (Inherited from Item.)
getId | Gets the id of the item. (Inherited from Item.)
getLocation | Gets the location, associated with this item. (Inherited from Item.)
getLocked | Gets a value indicating whether users are forbidden to modify this item. (Inherited from Item.)
getOccurrenceIndex | Gets the occurrence index of this item. (Inherited from Item.)
getPriority | Gets the priority of the Item. (Inherited from Item.)
getRecurrence | Gets the Recurrence object, associated with this item. (Inherited from Item.)
getRecurrenceState | Gets the recurrence state of this item. (Inherited from Item.)
getReminder | Gets the reminder of this item. (Inherited from Item.)
getResources | Gets the list of resources, associated with this item. (Inherited from Item.)
getSelected | Gets a value indicating whether the item is currently selected. (Inherited from Item.)
getStartTime | Gets the start time of the item. (Inherited from Item.)
getSubject | Gets the header text of the item. (Inherited from Item.)
getTag | Gets the tag of this item. (Inherited from Item.)
getTask | Gets the task, associated with this item. (Inherited from Item.)
getVisible | Gets a value indicating whether the item is visible. (Inherited from Item.)

See Also

Appointment Class


MindFusion.Scheduling.Appointment Constructor

Appointment Constructor
[image]

Initializes a new instance of the Appointment class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Appointment ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Appointment Class


MindFusion.Scheduling.Appointment Methods

Appointment Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this Appointment.
LoadFrom | Overloaded.
LoadViewState | Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Control.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | Control.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
getAllDayEvent | Gets a value, indicating whether the item represents an all day event. (Inherited from Item.)
getContacts | Gets the list of contacts, associated with this item. (Inherited from Item.)
getCssClass | Gets the css class of the item. (Inherited from Item.)
getDescriptionText | Gets the description text of the item. (Inherited from Item.)
getDetails | Gets the description text of the item. (Inherited from Item.)
getEndTime | Gets the end time of the item. (Inherited from Item.)
getHeaderText | Gets the header text of the item. (Inherited from Item.)
getId | Gets the id of the item. (Inherited from Item.)
getLocation | Gets the location, associated with this item. (Inherited from Item.)
getLocked | Gets a value indicating whether users are forbidden to modify this item. (Inherited from Item.)
getOccurrenceIndex | Gets the occurrence index of this item. (Inherited from Item.)
getPriority | Gets the priority of the Item. (Inherited from Item.)
getRecurrence | Gets the Recurrence object, associated with this item. (Inherited from Item.)
getRecurrenceState | Gets the recurrence state of this item. (Inherited from Item.)
getReminder | Gets the reminder of this item. (Inherited from Item.)
getResources | Gets the list of resources, associated with this item. (Inherited from Item.)
getSelected | Gets a value indicating whether the item is currently selected. (Inherited from Item.)
getStartTime | Gets the start time of the item. (Inherited from Item.)
getSubject | Gets the header text of the item. (Inherited from Item.)
getTag | Gets the tag of this item. (Inherited from Item.)
getTask | Gets the task, associated with this item. (Inherited from Item.)
getVisible | Gets a value indicating whether the item is visible. (Inherited from Item.)

See Also

Appointment Class


MindFusion.Scheduling.Appointment.Clone Method

Appointment.Clone Method
[image]

Creates an exact copy of this Appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

Type: Object
The newly created Appointment object.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.LoadFrom Method

Appointment.LoadFrom Method
[image]

Overload List

Name | Description
Appointment.LoadFrom (BinaryReader, BinarySerializationContext) | Loads appointment data from a binary stream.
Appointment.LoadFrom (XmlElement, XmlSerializationContext) | Loads appointment data from an XML document.

See Also

Appointment Members
Appointment Class
Serializing the Schedule


MindFusion.Scheduling.Appointment.LoadFrom Method (BinaryReader, BinarySerializationContext)

Appointment.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also
[image]

Loads appointment data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Type: BinaryReader
A System.IO.BinaryReader object that allows reading primitive data types from a binary stream.
context
Type: BinarySerializationContext
A BinarySerializationContext object that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

LoadFrom Method Overload List
Appointment Members
Appointment Class
Serializing the Schedule


MindFusion.Scheduling.Appointment.LoadFrom Method (XmlElement, XmlSerializationContext)

Appointment.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads appointment data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
A System.Xml.XmlElement object that allows reading data from the XML document.
context
Type: XmlSerializationContext
An XmlSerializationContext object that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

LoadFrom Method Overload List
Appointment Members
Appointment Class
Serializing the Schedule


MindFusion.Scheduling.Appointment.LoadViewState Method

Appointment.LoadViewState Method
[image]

Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.SaveTo Method

Appointment.SaveTo Method
[image]

Overload List

Name | Description
Appointment.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the appointment data to a binary stream.
Appointment.SaveTo (XmlElement, XmlSerializationContext) | Saves the appointment data to an XML document.

See Also

Appointment Members
Appointment Class
Serializing the Schedule


MindFusion.Scheduling.Appointment.SaveTo Method (BinaryWriter, BinarySerializationContext)

Appointment.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also
[image]

Saves the appointment data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Type: BinaryWriter
A System.IO.BinaryWriter object that allows writing primitive data types to a binary stream.
context
Type: BinarySerializationContext
A BinarySerializationContext object that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

SaveTo Method Overload List
Appointment Members
Appointment Class
Serializing the Schedule


MindFusion.Scheduling.Appointment.SaveTo Method (XmlElement, XmlSerializationContext)

Appointment.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the appointment data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
A System.Xml.XmlElement object that allows adding data to the XML document.
context
Type: XmlSerializationContext
An XmlSerializationContext object that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

SaveTo Method Overload List
Appointment Members
Appointment Class
Serializing the Schedule


MindFusion.Scheduling.Appointment.SaveViewState Method

Appointment.SaveViewState Method
[image]

Control.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.TrackViewState Method

Appointment.TrackViewState Method
[image]

Control.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment Properties

Appointment Properties
[image]

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the appointment is an all-day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the appointment's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the appointment's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the appointment.
Attendees | Gets a list with all attendees of this appointment.
Contacts | Gets a list with all contacts associated with this appointment.
CssClass | Gets or sets the css class of the appointment.
DescriptionText | Gets or sets text with details displayed for this appointment by the scheduling control.
Details | Gets or sets the detailed description of this appointment.
EndTime | Gets or sets the appointment's scheduled end time.
HeaderText | Gets or sets header text displayed for this appointment by the calendar control.
Id | Gets or sets the string identifier of this appointment.
Location | Gets or sets the appointment location.
Locked | Gets or sets a value indicating whether users are allowed to modify this appointment.
Reminder | Gets or sets the reminder for this appointment.
Resources | Gets a list with all resources associated with this appointment.
StartTime | Gets or sets the appointment's scheduled start time.
Style | Gets or sets the style associated with this appointment.
Subject | Gets or sets the subject of this appointment.
Tag | Gets or sets custom data associated with the appointment.
Task | Gets or sets the task associated with this appointment.
Visible | Gets or sets whether the appointment is visible.

See Also

Appointment Class


MindFusion.Scheduling.Appointment.AllDayEvent Property

Appointment.AllDayEvent Property
[image]

Gets or sets a value indicating whether the appointment is an all-day event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool AllDayEvent { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property AllDayEvent As Boolean

Property Value

true if this is an all-day event; otherwise false. Default value is false.

Remarks

All day events are displayed in a special header area when the Calendar displays a timetable view.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.AllowChangeEnd Property

Appointment.AllowChangeEnd Property
[image]

Gets or sets a value indicating whether users are allowed to change the appointment's end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool AllowChangeEnd { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property AllowChangeEnd As Boolean

Property Value

true if the appointment's end time can be changed interactively; otherwise false. Default value is true.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.AllowChangeStart Property

Appointment.AllowChangeStart Property
[image]

Gets or sets a value indicating whether users are allowed to change the appointment's start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool AllowChangeStart { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property AllowChangeStart As Boolean

Property Value

true if the appointment's start time can be changed interactively; otherwise false. Default value is true.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.AllowMove Property

Appointment.AllowMove Property
[image]

Gets or sets a value indicating whether users are allowed to move the appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool AllowMove { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property AllowMove As Boolean

Property Value

true if users can move the appointment by dragging it; otherwise false. Default value is true.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Attendees Property

Appointment.Attendees Property
[image]

Gets a list with all attendees of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Contact> Attendees { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Attendees As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection class specifying the appointment's attendees.

Remarks

This property is equivalent to Contacts.

Example

The following example creates a new contact and associates it with an existing appointment. The example assumes that app references an existing appointment. The last call is equivalent to app.Contacts.Add(c), since Attendees and Contacts both return a reference to the same collection.

C# [image] Copy Code

// Create the contact
Contact c = new Contact();
c.FirstName = "John";
c.LastName = "Silver";

// Associate the contact with the appointment
app.Attendees.Add(c)

Visual Basic [image] Copy Code

' Create the contact
Dim c As New Contact()
c.FirstName = "John"
c.LastName = "Silver"

' Associate the contact with the appointment
app.Attendees.Add(c)

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Contacts Property

Appointment.Contacts Property
[image]

Gets a list with all contacts associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override ResourceCollection<Contact> Contacts { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Contacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection class containing the contacts associated with this appointment.

Remarks

This property is equivalent to Attendees.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.CssClass Property

Appointment.CssClass Property
[image]

Gets or sets the css class of the appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override string CssClass { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property CssClass As String

Property Value

A string that identifies the Css class of this Appointment.

Remarks

For more information about styling items through the use of CSS, refer to the CSS Classes topic.

Example

The following example shows how an item's border color can be changed by assigning a predefined Css class to the CssClass property.

C# [image] Copy Code

Appointment app = new Appointment();
app.StartTime = DateTime.Today;
app.EndTime = DateTime.Today.AddDays(1);
app.AllDayEvent = true;
app.HeaderText = "CSS styled item";
app.CssClass = "MyCustomStyle";

Visual Basic [image] Copy Code

Dim app As New Appointment()
app.StartTime = DateTime.Today
app.EndTime = DateTime.Today.AddDays(1)
app.AllDayEvent = True
app.HeaderText = "CSS styled item"
app.CssClass = "MyCustomStyle"

CSS [image] Copy Code

.MyCustomStyle .wrapper .borders
{
border-color: Red !important;
}

See Also

Appointment Members
Appointment Class
CSS Classes


MindFusion.Scheduling.Appointment.DescriptionText Property

Appointment.DescriptionText Property
[image]

Gets or sets text with details displayed for this appointment by the scheduling control.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override string DescriptionText { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property DescriptionText As String

Property Value

A string containing the appointment's description. The default is an empty string ("").

Remarks

This property implements the DescriptionText property of the Item class and is equivalent to Details.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Details Property

Appointment.Details Property
[image]

Gets or sets the detailed description of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Details { get; set; }

Visual Basic [image] Copy Code

Public Property Details As String

Property Value

A string containing the appointment's description. The default is an empty string ("").

Remarks

This property is equivalent to DescriptionText.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.EndTime Property

Appointment.EndTime Property
[image]

Gets or sets the appointment's scheduled end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property EndTime As DateTime

Property Value

A .NET DateTime object specifying the appointment's end time.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.HeaderText Property

Appointment.HeaderText Property
[image]

Gets or sets header text displayed for this appointment by the calendar control.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override string HeaderText { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property HeaderText As String

Property Value

A string containing the appointment's header text. The default is an empty string ("").

Remarks

This property implements the Item's class HeaderText property and is equivalent to Subject.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Id Property

Appointment.Id Property
[image]

Gets or sets the string identifier of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override string Id { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Id As String

Property Value

A string value that identifies uniquely this appointment.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Location Property

Appointment.Location Property
[image]

Gets or sets the appointment location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Location Location { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Location As Location

Property Value

An instance of the Location class specifying the appointment's location. The default is null (Nothing in Visual Basic).

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Locked Property

Appointment.Locked Property
[image]

Gets or sets a value indicating whether users are allowed to modify this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Locked As Boolean

Property Value

true if users are not allowed to modify the appointment interactively; otherwise false. Default value is false.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Reminder Property

Appointment.Reminder Property
[image]

Gets or sets the reminder for this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Reminder Reminder { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Reminder As Reminder

Property Value

An instance of the Reminder class.

Remarks

If the reminder type is Exact, the ItemReminderTriggered event is raised at the time set in the reminder's Time property. If the reminder type is Leading, the ItemReminderTriggered event is raised certain amount of time prior to the item's StartTime, as specified in the reminder's TimeInterval property.

Note

Recurring items cannot have exact reminders.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Resources Property

Appointment.Resources Property
[image]

Gets a list with all resources associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override ResourceCollection<Resource> Resources { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Resources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection class containing the resources associated with this item.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.StartTime Property

Appointment.StartTime Property
[image]

Gets or sets the appointment's scheduled start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property StartTime As DateTime

Property Value

A .NET DateTime instance specifying the scheduled time for the item.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Style Property

Appointment.Style Property
[image]

Gets or sets the style associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override ItemStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Style As ItemStyle

Property Value

An instance of the ItemStyle class that defines the appearance of the item.

Remarks

More information about styling items' appearance can be found here.

See Also

Appointment Members
Appointment Class
Customizing the Appearance of Items


MindFusion.Scheduling.Appointment.Subject Property

Appointment.Subject Property
[image]

Gets or sets the subject of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Subject { get; set; }

Visual Basic [image] Copy Code

Public Property Subject As String

Property Value

A string that identifies the subject of the appointment. The default is an empty string ("").

Remarks

This is equivalent to the HeaderText property.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Tag Property

Appointment.Tag Property
[image]

Gets or sets custom data associated with the appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data. The tag can be a value from a primitive data type or a complex object from the .NET class library or a class defined by you. If the tag is an instance of a value type, it will be serialized together with the object containing it when saving / loading the schedule. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Task Property

Appointment.Task Property
[image]

Gets or sets the task associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Task Task { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Task As Task

Property Value

An instance of the Task class. The default is null (Nothing in Visual Basic).

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.Appointment.Visible Property

Appointment.Visible Property
[image]

Gets or sets whether the appointment is visible.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Visible As Boolean

Property Value

true if the appointment is visible; otherwise false. Default value is true.

See Also

Appointment Members
Appointment Class


MindFusion.Scheduling.BackgroundAttachment Enumeration

BackgroundAttachment Enumeration
[image]

Specifies how the background image is attached to the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum BackgroundAttachment

Visual Basic [image] Copy Code

Public Enum BackgroundAttachment

Members

Member name | Value | Description
None | 0 | No value for CSS background-attachment will be set.
Fixed | 1 | Background image stays fixed within the viewable area of the object.
Scroll | 2 | Background image scrolls with the object as the document is scrolled.

Remarks

These values can be assigned to the Attachment property of the CssBackground class.

See Also


MindFusion.Scheduling.BackgroundRepeat Enumeration

BackgroundRepeat Enumeration
[image]

Specifies how the background image of an object is tiled.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum BackgroundRepeat

Visual Basic [image] Copy Code

Public Enum BackgroundRepeat

Members

Member name | Value | Description
None | 0 | No value is set and the default css value is considered.
Repeat | 1 | Default. Image is repeated horizontally and vertically.
NoRepeat | 2 | Image is not repeated.
RepeatX | 3 | Image is repeated horizontally.
RepeatY | 4 | Image is repeated vertically.

Remarks

These values can be assigned to the Repeat property of the CssBackground class.

See Also


MindFusion.Scheduling.BinarySerializationContext Class

BinarySerializationContext Class
[image]

Contains methods that enable serialization/deserialization of MindFusion.Scheduling items to/from binary documents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class BinarySerializationContext : SerializationContext

Visual Basic [image] Copy Code

Public Class BinarySerializationContext
Inherits SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.BinarySerializationContext

See Also

BinarySerializationContext Members
Serializing the Schedule


MindFusion.Scheduling.BinarySerializationContext Members

BinarySerializationContext Members
Constructors Properties Methods Events
[image]

Contains methods that enable serialization/deserialization of MindFusion.Scheduling items to/from binary documents.

The following tables list the members exposed by the BinarySerializationContext type.

Public Constructors

Name | Description
BinarySerializationContext | Overloaded.

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.

Inherited Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded. (Inherited from SerializationContext.)
Schedule | Gets a reference to the schedule currently being serialized or deserialized. (Inherited from SerializationContext.)

Public Methods

Name | Description
ReadBool | Reads a bool value.
ReadByte | Reads a byte value.
ReadChar | Reads a char value.
ReadColor | Reads a System.Drawing.Color object.
ReadColorArray | Reads an array with System.Drawing.Color objects.
ReadDateTime | Reads a DateTime object.
ReadDecimal | Reads a decimal value.
ReadDouble | Reads a double value.
ReadEnum | Reads an enum value.
ReadFloat | Reads a float value.
ReadFloatArray | Reads an array with float values.
ReadFont | Reads a Font object.
ReadHashtable | Reads a hash table object.
ReadHeaderStyle | Reads a HeaderStyle object.
ReadImage | Reads an image.
ReadInt | Reads an integer value.
ReadItemStyle | Reads a ItemStyle object.
ReadLong | Reads a long number.
ReadObject | Reads an object.
ReadPointF | Reads a PointF object.
ReadRectangleF | Reads a RectangleF object.
ReadRecurrence | Reads a Recurrence object.
ReadReminder | Reads a Reminder.
ReadSByte | Reads a 8-bit signed integer value.
ReadShort | Reads a short number.
ReadSizeF | Reads a SizeF object.
ReadStream | Reads a stream.
ReadString | Reads a string value.
ReadStringFormat | Reads a StringFormat object.
ReadStyle | Reads a Style object.
ReadTag | Reads a tag.
ReadUInt | Reads an unsigned integer value.
ReadULong | Reads an unsigned long value.
ReadUShort | Reads an unsigned short value.
WriteBool | Writes a boolean value.
WriteByte | Writes a byte value.
WriteChar | Writes a char value.
WriteColor | Writes a Color object.
WriteColorArray | Writes an array with Color objects.
WriteDateTime | Writes a DateTime object.
WriteDecimal | Writes a decimal value.
WriteDouble | Writes a double value.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value.
WriteFloatArray | Writes an array of float numbers.
WriteFont | Writes the specified font.
WriteHashtable | Writes the specified hashtable.
WriteHeaderStyle | Writes the specified HeaderStyle object.
WriteImage | Writes the specified image.
WriteInt | Writes an integer value.
WriteItemStyle | Writes the specified ItemStyle object.
WriteLong | Writes a long value.
WriteObject | Writes the specified object.
WritePointF | Writes a PointF object.
WriteRectangleF | Writes a RectangleF object.
WriteRecurrence | Writes a Recurrence.
WriteReminder | Writes a Reminder.
WriteSByte | Write a 8-bit signed integer value to the stream.
WriteShort | Writes a short value.
WriteSizeF | Writes a SizeF object.
WriteStream | Writes the specified Stream.
WriteString | Writes a string.
WriteStringFormat | Writes the specified StringFormat object.
WriteStyle | Writes the specified Style object.
WriteTag | Writes the specified tag of the specified object.
WriteUInt | Writes an unsigned integer value.
WriteULong | Writes an unsigned long value.
WriteUShort | Writes an unsigned short value.

Inherited Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully. (Inherited from SerializationContext.)

See Also

BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext Constructor

BinarySerializationContext Constructor
[image]

Overload List

Name | Description
BinarySerializationContext (Schedule) | Initializes a new instance of the BinarySerializationContext class.
BinarySerializationContext (Schedule, Int32) | Initializes a new instance of the BinarySerializationContext class.

See Also

BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext Constructor (Schedule)

BinarySerializationContext Constructor (Schedule)
See Also
[image]

Initializes a new instance of the BinarySerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public BinarySerializationContext (
Schedule schedule
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule _
)

Parameters

schedule
Type: Schedule
The Schedule to serialize / deserialize.

See Also

BinarySerializationContext Constructor Overload List
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext Constructor (Schedule, Int32)

BinarySerializationContext Constructor (Schedule, Int32)
See Also
[image]

Initializes a new instance of the BinarySerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public BinarySerializationContext (
Schedule schedule,
int fileVersion
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
fileVersion As Integer _
)

Parameters

schedule
Type: Schedule
The Schedule to serialize/deserialize.
fileVersion

Type: Int32
The file version of the file to deserialize.

See Also

BinarySerializationContext Constructor Overload List
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext Methods

BinarySerializationContext Methods
[image]

Public Methods

Name | Description
ReadBool | Reads a bool value.
ReadByte | Reads a byte value.
ReadChar | Reads a char value.
ReadColor | Reads a System.Drawing.Color object.
ReadColorArray | Reads an array with System.Drawing.Color objects.
ReadDateTime | Reads a DateTime object.
ReadDecimal | Reads a decimal value.
ReadDouble | Reads a double value.
ReadEnum | Reads an enum value.
ReadFloat | Reads a float value.
ReadFloatArray | Reads an array with float values.
ReadFont | Reads a Font object.
ReadHashtable | Reads a hash table object.
ReadHeaderStyle | Reads a HeaderStyle object.
ReadImage | Reads an image.
ReadInt | Reads an integer value.
ReadItemStyle | Reads a ItemStyle object.
ReadLong | Reads a long number.
ReadObject | Reads an object.
ReadPointF | Reads a PointF object.
ReadRectangleF | Reads a RectangleF object.
ReadRecurrence | Reads a Recurrence object.
ReadReminder | Reads a Reminder.
ReadSByte | Reads a 8-bit signed integer value.
ReadShort | Reads a short number.
ReadSizeF | Reads a SizeF object.
ReadStream | Reads a stream.
ReadString | Reads a string value.
ReadStringFormat | Reads a StringFormat object.
ReadStyle | Reads a Style object.
ReadTag | Reads a tag.
ReadUInt | Reads an unsigned integer value.
ReadULong | Reads an unsigned long value.
ReadUShort | Reads an unsigned short value.
WriteBool | Writes a boolean value.
WriteByte | Writes a byte value.
WriteChar | Writes a char value.
WriteColor | Writes a Color object.
WriteColorArray | Writes an array with Color objects.
WriteDateTime | Writes a DateTime object.
WriteDecimal | Writes a decimal value.
WriteDouble | Writes a double value.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value.
WriteFloatArray | Writes an array of float numbers.
WriteFont | Writes the specified font.
WriteHashtable | Writes the specified hashtable.
WriteHeaderStyle | Writes the specified HeaderStyle object.
WriteImage | Writes the specified image.
WriteInt | Writes an integer value.
WriteItemStyle | Writes the specified ItemStyle object.
WriteLong | Writes a long value.
WriteObject | Writes the specified object.
WritePointF | Writes a PointF object.
WriteRectangleF | Writes a RectangleF object.
WriteRecurrence | Writes a Recurrence.
WriteReminder | Writes a Reminder.
WriteSByte | Write a 8-bit signed integer value to the stream.
WriteShort | Writes a short value.
WriteSizeF | Writes a SizeF object.
WriteStream | Writes the specified Stream.
WriteString | Writes a string.
WriteStringFormat | Writes the specified StringFormat object.
WriteStyle | Writes the specified Style object.
WriteTag | Writes the specified tag of the specified object.
WriteUInt | Writes an unsigned integer value.
WriteULong | Writes an unsigned long value.
WriteUShort | Writes an unsigned short value.

See Also

BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadBool Method

BinarySerializationContext.ReadBool Method
[image]

Reads a bool value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool ReadBool (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
reader As BinaryReader _
) As Boolean

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Boolean
The bool value that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadByte Method

BinarySerializationContext.ReadByte Method
[image]

Reads a byte value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public byte ReadByte (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
reader As BinaryReader _
) As Byte

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Byte
The byte that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadChar Method

BinarySerializationContext.ReadChar Method
[image]

Reads a char value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public char ReadChar (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
reader As BinaryReader _
) As Char

Parameters

reader

Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Char
The char value that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadColor Method

BinarySerializationContext.ReadColor Method
[image]

Reads a System.Drawing.Color object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Color ReadColor (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
reader As BinaryReader _
) As Color

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Color
The System.Drawing.Color object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadColorArray Method

BinarySerializationContext.ReadColorArray Method
[image]

Reads an array with System.Drawing.Color objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
reader As BinaryReader _
) As Color()

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Color[]
An array with the System.Drawing.Color objects that have been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadDateTime Method

BinarySerializationContext.ReadDateTime Method
[image]

Reads a DateTime object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime ReadDateTime (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadDateTime( _
reader As BinaryReader _
) As DateTime

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: DateTime
The System.DateTime object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadDecimal Method

BinarySerializationContext.ReadDecimal Method
[image]

Reads a decimal value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
reader As BinaryReader _
) As Decimal

Parameters

reader

Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Decimal
The decimal value that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadDouble Method

BinarySerializationContext.ReadDouble Method
[image]

Reads a double value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public double ReadDouble (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
reader As BinaryReader _
) As Double

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Double
The double value that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadEnum Method

BinarySerializationContext.ReadEnum Method
[image]

Reads an enum value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object ReadEnum (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
reader As BinaryReader _
) As Object

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Object
The enum value that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadFloat Method

BinarySerializationContext.ReadFloat Method
[image]

Reads a float value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public float ReadFloat (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
reader As BinaryReader _
) As Single

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Single
The float value that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadFloatArray Method

BinarySerializationContext.ReadFloatArray Method
[image]

Reads an array with float values.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public float[] ReadFloatArray (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadFloatArray( _
reader As BinaryReader _
) As Single()

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Single[]
An array with the float values that have been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadFont Method

BinarySerializationContext.ReadFont Method
[image]

Reads a Font object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Font ReadFont (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
reader As BinaryReader _
) As Font

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Font
The System.Drawing.Font object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadHashtable Method

BinarySerializationContext.ReadHashtable Method
[image]

Reads a hash table object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Hashtable ReadHashtable (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadHashtable( _
reader As BinaryReader _
) As Hashtable

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Hashtable
The System.Collections.Hastable object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadHeaderStyle Method

BinarySerializationContext.ReadHeaderStyle Method
[image]

Reads a HeaderStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle ReadHeaderStyle (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadHeaderStyle( _
reader As BinaryReader _
) As HeaderStyle

Parameters

reader

Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: HeaderStyle
The HeaderStyle object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadImage Method

BinarySerializationContext.ReadImage Method
[image]

Reads an image.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Image ReadImage (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadImage( _
reader As BinaryReader _
) As Image

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Image
The System.Drawing.Image object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadInt Method

BinarySerializationContext.ReadInt Method
[image]

Reads an integer value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int ReadInt (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
reader As BinaryReader _
) As Integer

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Int32
The integer value that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadItemStyle Method

BinarySerializationContext.ReadItemStyle Method
[image]

Reads a ItemStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemStyle ReadItemStyle (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadItemStyle( _
reader As BinaryReader _
) As ItemStyle

Parameters

reader

Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: ItemStyle
The ItemStyle object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadLong Method

BinarySerializationContext.ReadLong Method
[image]

Reads a long number.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public long ReadLong (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
reader As BinaryReader _
) As Long

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Int64
The long number that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadObject Method

BinarySerializationContext.ReadObject Method
[image]

Reads an object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object ReadObject (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
reader As BinaryReader _
) As Object

Parameters

reader

Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Object
The Object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadPointF Method

BinarySerializationContext.ReadPointF Method
[image]

Reads a PointF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public PointF ReadPointF (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
reader As BinaryReader _
) As PointF

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: PointF
The System.Drawing.PointF object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadRectangleF Method

BinarySerializationContext.ReadRectangleF Method
[image]

Reads a RectangleF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public RectangleF ReadRectangleF (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadRectangleF( _
reader As BinaryReader _
) As RectangleF

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: RectangleF
A System.Drawing.RectangleF object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadRecurrence Method

BinarySerializationContext.ReadRecurrence Method
[image]

Reads a Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Recurrence ReadRecurrence (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadRecurrence ( _
reader As BinaryReader _
) As Recurrence

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Recurrence
The Recurrence object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadReminder Method

BinarySerializationContext.ReadReminder Method
[image]

Reads a Reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Reminder ReadReminder (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadReminder ( _
reader As BinaryReader _
) As Reminder

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Reminder
The Reminder object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadSByte Method

BinarySerializationContext.ReadSByte Method
[image]

Reads a 8-bit signed integer value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
reader As BinaryReader _
) As SByte

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: SByte
The 8-bit signed integer value that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadShort Method

BinarySerializationContext.ReadShort Method
[image]

Reads a short number.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public short ReadShort (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
reader As BinaryReader _
) As Short

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Int16
The short number that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadSizeF Method

BinarySerializationContext.ReadSizeF Method
[image]

Reads a SizeF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public SizeF ReadSizeF (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadSizeF( _
reader As BinaryReader _
) As SizeF

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: SizeF
A System.Drawing.SizeF object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadStream Method

BinarySerializationContext.ReadStream Method
[image]

Reads a stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Stream ReadStream (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
reader As BinaryReader _
) As Stream

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Stream
The System.IO.Stream object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadString Method

BinarySerializationContext.ReadString Method
[image]

Reads a string value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ReadString (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadString( _
reader As BinaryReader _
) As String

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: String
The string that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadStringFormat Method

BinarySerializationContext.ReadStringFormat Method
[image]

Reads a StringFormat object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
reader As BinaryReader _
) As StringFormat

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: StringFormat
The System.Drawing.StringFormat object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadStyle Method

BinarySerializationContext.ReadStyle Method
[image]

Reads a Style object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Style ReadStyle (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadStyle ( _
reader As BinaryReader _
) As Style

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Style
The Style object that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadTag Method

BinarySerializationContext.ReadTag Method
[image]

Reads a tag.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object ReadTag (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadTag( _
reader As BinaryReader _
) As Object

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: Object
The object that has been read.

Remarks

Tags are read similarly to arbitrary objects.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadUInt Method

BinarySerializationContext.ReadUInt Method
[image]

Reads an unsigned integer value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public uint ReadUInt (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
reader As BinaryReader _
) As UInteger

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: UInt32
The unsigned int that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadULong Method

BinarySerializationContext.ReadULong Method
[image]

Reads an unsigned long value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ulong ReadULong (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
reader As BinaryReader _
) As ULong

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: UInt64
The unsigned long that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ReadUShort Method

BinarySerializationContext.ReadUShort Method
[image]

Reads an unsigned short value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ushort ReadUShort (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
reader As BinaryReader _
) As UShort

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class to read from.

Return Value

Type: UInt16
The unsigned short value that has been read.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteBool Method

BinarySerializationContext.WriteBool Method
[image]

Writes a boolean value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteBool (
bool boolValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteBool( _
boolValue As Boolean, _
writer As BinaryWriter _
)

Parameters

boolValue
Type: Boolean
The bool value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteByte Method

BinarySerializationContext.WriteByte Method
[image]

Writes a byte value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteByte (
byte byteValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteByte( _
byteValue As Byte, _
writer As BinaryWriter _
)

Parameters

byteValue
Type: Byte
The byte value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteChar Method

BinarySerializationContext.WriteChar Method
[image]

Writes a char value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteChar (
char charValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteChar( _
charValue As Char, _
writer As BinaryWriter _
)

Parameters

charValue
Type: Char
The char to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteColor Method

BinarySerializationContext.WriteColor Method
[image]

Writes a Color object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteColor (
Color color,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteColor( _
color As Color, _
writer As BinaryWriter _
)

Parameters

color
Type: Color
The System.Drawing.Color to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteColorArray Method

BinarySerializationContext.WriteColorArray Method
[image]

Writes an array with Color objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteColorArray (
Color[] array,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteColorArray( _
array() As Color, _
writer As BinaryWriter _
)

Parameters

array
Type: Color[]
The array with the System.Drawing.Color objects to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteDateTime Method

BinarySerializationContext.WriteDateTime Method
[image]

Writes a DateTime object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteDateTime (
DateTime dateTime,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteDateTime( _
dateTime As DateTime, _
writer As BinaryWriter _
)

Parameters

dateTime
Type: DateTime
The System.DateTime object to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteDecimal Method

BinarySerializationContext.WriteDecimal Method
[image]

Writes a decimal value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteDecimal (
decimal decimalValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteDecimal( _
decimalValue As Decimal, _
writer As BinaryWriter _
)

Parameters

decimalValue
Type: Decimal
The decimal value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteDouble Method

BinarySerializationContext.WriteDouble Method
[image]

Writes a double value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteDouble (
double doubleValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteDouble( _
doubleValue As Double, _
writer As BinaryWriter _
)

Parameters

doubleValue
Type: Double
The double value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteEnum Method

BinarySerializationContext.WriteEnum Method
[image]

Writes the specified enum value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteEnum (
Object enumValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteEnum( _
enumValue As Object, _
writer As BinaryWriter _
)

Parameters

enumValue
Type: Object
The enum value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteFloat Method

BinarySerializationContext.WriteFloat Method
[image]

Writes a float value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteFloat (
float floatValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteFloat( _
floatValue As Single, _
writer As BinaryWriter _
)

Parameters

floatValue
Type: Single
The float value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteFloatArray Method

BinarySerializationContext.WriteFloatArray Method
[image]

Writes an array of float numbers.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteFloatArray (
float[] array,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteFloatArray( _
array() As Single, _
writer As BinaryWriter _
)

Parameters

array
Type: Single[]
The array of float values to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteFont Method

BinarySerializationContext.WriteFont Method
[image]

Writes the specified font.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteFont (
Font font,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteFont( _
font As Font, _
writer As BinaryWriter _
)

Parameters

font
Type: Font
The System.Drawing.Font to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteHashtable Method

BinarySerializationContext.WriteHashtable Method
[image]

Writes the specified hashtable.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteHashtable (
Hashtable hashtable,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteHashtable( _
hashtable As Hashtable, _
writer As BinaryWriter _
)

Parameters

hashtable
Type: Hashtable
The System.Collections.Hashtable to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteHeaderStyle Method

BinarySerializationContext.WriteHeaderStyle Method
[image]

Writes the specified HeaderStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteHeaderStyle (
HeaderStyle style,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteHeaderStyle( _
style As HeaderStyle, _
writer As BinaryWriter _
)

Parameters

style

Type: HeaderStyle
The HeaderStyle object to write.

writer

Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteImage Method

BinarySerializationContext.WriteImage Method
[image]

Writes the specified image.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteImage (
Image image,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteImage( _
image As Image, _
writer As BinaryWriter _
)

Parameters

image
Type: Image
The System.Drawing.Image to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteInt Method

BinarySerializationContext.WriteInt Method
[image]

Writes an integer value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteInt (
int intValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteInt( _
intValue As Integer, _
writer As BinaryWriter _
)

Parameters

intValue
Type: Int32
The integer to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteItemStyle Method

BinarySerializationContext.WriteItemStyle Method
[image]

Writes the specified ItemStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteItemStyle (
ItemStyle style,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteItemStyle( _
style As ItemStyle, _
writer As BinaryWriter _
)

Parameters

style

Type: ItemStyle
The ItemStyle object to write.

writer

Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteLong Method

BinarySerializationContext.WriteLong Method
[image]

Writes a long value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteLong (
long longValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteLong( _
longValue As Long, _
writer As BinaryWriter _
)

Parameters

longValue
Type: Int64
The long value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteObject Method

BinarySerializationContext.WriteObject Method
[image]

Writes the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteObject (
Object objectValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteObject( _
objectValue As Object, _
writer As BinaryWriter _
)

Parameters

objectValue
Type: Object
The object to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WritePointF Method

BinarySerializationContext.WritePointF Method
[image]

Writes a PointF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WritePointF (
PointF point,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WritePointF( _
point As PointF, _
writer As BinaryWriter _
)

Parameters

point
Type: PointF
The System.Drawing.PointF to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteRectangleF Method

BinarySerializationContext.WriteRectangleF Method
[image]

Writes a RectangleF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteRectangleF (
RectangleF rectangle,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteRectangleF( _
rectangle As RectangleF, _
writer As BinaryWriter _
)

Parameters

rectangle
Type: RectangleF
The System.Drawing.RectangleF object to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteRecurrence Method

BinarySerializationContext.WriteRecurrence Method
[image]

Writes a Recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteRecurrence (
Recurrence recurrence,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteRecurrence ( _
recurrence As Recurrence, _
writer As BinaryWriter _
)

Parameters

recurrence
Type: Recurrence
The Recurrence to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteReminder Method

BinarySerializationContext.WriteReminder Method
[image]

Writes a Reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteReminder (
Reminder reminder,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteReminder ( _
reminder As Reminder, _
writer As BinaryWriter _
)

Parameters

reminder
Type: Reminder
The Reminder to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteSByte Method

BinarySerializationContext.WriteSByte Method
[image]

Write a 8-bit signed integer value to the stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteSByte (
sbyte byteValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteSByte( _
byteValue As SByte, _
writer As BinaryWriter _
)

Parameters

byteValue
Type: SByte
The signed integer value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteShort Method

BinarySerializationContext.WriteShort Method
[image]

Writes a short value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteShort (
short shortValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteShort( _
shortValue As Short, _
writer As BinaryWriter _
)

Parameters

shortValue
Type: Int16
The short value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteSizeF Method

BinarySerializationContext.WriteSizeF Method
[image]

Writes a SizeF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteSizeF (
SizeF size,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteSizeF( _
size As SizeF, _
writer As BinaryWriter _
)

Parameters

size
Type: SizeF
The System.Drawing.SizeF object to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteStream Method

BinarySerializationContext.WriteStream Method
[image]

Writes the specified Stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteStream (
Stream stream,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteStream( _
stream As Stream, _
writer As BinaryWriter _
)

Parameters

stream
Type: Stream
An instance of the System.IO.Stream class to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteString Method

BinarySerializationContext.WriteString Method
[image]

Writes a string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteString (
string stringValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteString( _
stringValue As String, _
writer As BinaryWriter _
)

Parameters

stringValue
Type: String
The string to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteStringFormat Method

BinarySerializationContext.WriteStringFormat Method
[image]

Writes the specified StringFormat object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteStringFormat (
StringFormat stringFormat,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteStringFormat( _
stringFormat As StringFormat, _
writer As BinaryWriter _
)

Parameters

stringFormat
Type: StringFormat
The System.Drawing.StringFormat object to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteStyle Method

BinarySerializationContext.WriteStyle Method
[image]

Writes the specified Style object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteStyle (
Style style,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteStyle ( _
style As Style, _
writer As BinaryWriter _
)

Parameters

style
Type: Style
The Style object to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteTag Method

BinarySerializationContext.WriteTag Method
[image]

Writes the specified tag of the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteTag (
Object tagValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteTag( _
tagValue As Object, _
writer As BinaryWriter _
)

Parameters

tagValue

Type: Object
The value of the tag to write.

writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

Remarks

Tags are written similarly to arbitrary objects.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteUInt Method

BinarySerializationContext.WriteUInt Method
[image]

Writes an unsigned integer value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteUInt (
uint uintValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteUInt( _
uintValue As UInteger, _
writer As BinaryWriter _
)

Parameters

uintValue
Type: UInt32
The unsigned int to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteULong Method

BinarySerializationContext.WriteULong Method
[image]

Writes an unsigned long value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteULong (
ulong ulongValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteULong( _
ulongValue As ULong, _
writer As BinaryWriter _
)

Parameters

ulongValue
Type: UInt64
The unsigned long value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.WriteUShort Method

BinarySerializationContext.WriteUShort Method
[image]

Writes an unsigned short value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void WriteUShort (
ushort ushortValue,
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub WriteUShort( _
ushortValue As UShort, _
writer As BinaryWriter _
)

Parameters

ushortValue
Type: UInt16
The unsighned short value to write.
writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class to write to.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext Properties

BinarySerializationContext Properties
[image]

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.

Inherited Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded. (Inherited from SerializationContext.)
Schedule | Gets a reference to the schedule currently being serialized or deserialized. (Inherited from SerializationContext.)

See Also

BinarySerializationContext Class


MindFusion.Scheduling.BinarySerializationContext.ClassVersion Property

BinarySerializationContext.ClassVersion Property
[image]

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int ClassVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer that specifies the class version. Default value is 0.

Remarks

This property is only useful when deserializing items.

See Also

BinarySerializationContext Members
BinarySerializationContext Class


MindFusion.Scheduling.BorderSide Enumeration

BorderSide Enumeration
[image]

Specifies the sides of an html element to apply a style border to. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum BorderSide

Visual Basic [image] Copy Code

Public Enum BorderSide

Members

Member name | Value | Description
None | 0 | No value is set.
Left | 1 | A border on the left side of the html element.
Top | 2 | A border on the top side of the html element.
Right | 4 | A border on the right side of the html element.
Bottom | 8 | A border on the bottom side of the html element.
All | 15 | A border on all four sides of the html element.

See Also


MindFusion.Scheduling.CollectionChangedAction Enumeration

CollectionChangedAction Enumeration
[image]

Specifies the action that has changed the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum CollectionChangedAction

Visual Basic [image] Copy Code

Public Enum CollectionChangedAction

Members

Member name | Value | Description
Add | 0 | An item has been added.
Remove | 1 | An item has been removed.
Replace | 2 | An item has been replaced.
Reset | 3 | The collection has been reset.

See Also


MindFusion.Scheduling.CollectionChangedEventArgs Class

CollectionChangedEventArgs Class
[image]

Provides data for events raised when a collection has changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class CollectionChangedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CollectionChangedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.CollectionChangedEventArgs

See Also

CollectionChangedEventArgs Members


MindFusion.Scheduling.CollectionChangedEventArgs Members

CollectionChangedEventArgs Members
Constructors Properties
[image]

Provides data for events raised when a collection has changed.

The following tables list the members exposed by the CollectionChangedEventArgs type.

Public Constructors

Name | Description
CollectionChangedEventArgs | Overloaded.

Public Properties

Name | Description
Action | Gets the action for this CollectionChangedEventArgs object.
NewItem | Gets the new item.
OldItem | Gets the old item.

See Also

CollectionChangedEventArgs Class


MindFusion.Scheduling.CollectionChangedEventArgs Constructor

CollectionChangedEventArgs Constructor
[image]

Overload List

Name | Description
CollectionChangedEventArgs (CollectionChangedAction) | Initializes a new instance of the CollectionChangedEventArgs class for events raised after the specified action.
CollectionChangedEventArgs (CollectionChangedAction, Object) | Initializes a new instance of the CollectionChangedEventArgs class for events raised for the specified action and changing the specified item.
CollectionChangedEventArgs (CollectionChangedAction, Object, Object) | Creates a new instance of the CollectionChangedEventArgs class for events raised for the specified action and changing the specified old item with the new one.

See Also

CollectionChangedEventArgs Class


MindFusion.Scheduling.CollectionChangedEventArgs Constructor (CollectionChangedAction)

CollectionChangedEventArgs Constructor (CollectionChangedAction)
See Also
[image]

Initializes a new instance of the CollectionChangedEventArgs class for events raised after the specified action.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CollectionChangedEventArgs (
CollectionChangedAction action
)

Visual Basic [image] Copy Code

Public New ( _
action As CollectionChangedAction _
)

Parameters

action
Type: CollectionChangedAction
One of the CollectionChangedAction enumeration values that specifies the action, which has triggered the event.

See Also

CollectionChangedEventArgs Constructor Overload List
CollectionChangedEventArgs Class


MindFusion.Scheduling.CollectionChangedEventArgs Constructor (CollectionChangedAction, Object)

CollectionChangedEventArgs Constructor (CollectionChangedAction, Object)
See Also
[image]

Initializes a new instance of the CollectionChangedEventArgs class for events raised for the specified action and changing the specified item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CollectionChangedEventArgs (
CollectionChangedAction action,
Object changedItem
)

Visual Basic [image] Copy Code

Public New ( _
action As CollectionChangedAction, _
changedItem As Object _
)

Parameters

action
Type: CollectionChangedAction
One of the CollectionChangedAction enumeration values that specifies the action, which has triggered the event.
changedItem

Type: Object
The item that has changed.

See Also

CollectionChangedEventArgs Constructor Overload List
CollectionChangedEventArgs Class


MindFusion.Scheduling.CollectionChangedEventArgs Constructor (CollectionChangedAction, Object, Object)

CollectionChangedEventArgs Constructor (CollectionChangedAction, Object, Object)
See Also
[image]

Creates a new instance of the CollectionChangedEventArgs class for events raised for the specified action and changing the specified old item with the new one.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CollectionChangedEventArgs (
CollectionChangedAction action,
Object newItem,
Object oldItem
)

Visual Basic [image] Copy Code

Public New ( _
action As CollectionChangedAction, _
newItem As Object, _
oldItem As Object _
)

Parameters

action
Type: CollectionChangedAction
One of the CollectionChangedAction enumeration values that specifies the action, which has triggered the event.
newItem

Type: Object
The new item.

oldItem

Type: Object
The old item.

See Also

CollectionChangedEventArgs Constructor Overload List
CollectionChangedEventArgs Class


MindFusion.Scheduling.CollectionChangedEventArgs Properties

CollectionChangedEventArgs Properties
[image]

Public Properties

Name | Description
Action | Gets the action for this CollectionChangedEventArgs object.
NewItem | Gets the new item.
OldItem | Gets the old item.

See Also

CollectionChangedEventArgs Class


MindFusion.Scheduling.CollectionChangedEventArgs.Action Property

CollectionChangedEventArgs.Action Property
[image]

Gets the action for this CollectionChangedEventArgs object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CollectionChangedAction Action { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Action As CollectionChangedAction

Property Value

One of the CollectionChangedAction enumeration values.

See Also

CollectionChangedEventArgs Members
CollectionChangedEventArgs Class


MindFusion.Scheduling.CollectionChangedEventArgs.NewItem Property

CollectionChangedEventArgs.NewItem Property
[image]

Gets the new item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object NewItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewItem As Object

Property Value

An instance of the System.Object class representing the new item.

See Also

CollectionChangedEventArgs Members
CollectionChangedEventArgs Class


MindFusion.Scheduling.CollectionChangedEventArgs.OldItem Property

CollectionChangedEventArgs.OldItem Property
[image]

Gets the old item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object OldItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldItem As Object

Property Value

An instance of the System.Object class representing the old item.

See Also

CollectionChangedEventArgs Members
CollectionChangedEventArgs Class


MindFusion.Scheduling.CollectionItemEventArgs(T) Class

CollectionItemEventArgs(T) Class
[image]

A class that holds data for events that are raised when an item in a strongly-typed collection changes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class CollectionItemEventArgs<T> : EventArgs

Visual Basic [image] Copy Code

Public Class CollectionItemEventArgs(Of T)
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.CollectionItemEventArgs(T)

See Also

CollectionItemEventArgs(T) Members


MindFusion.Scheduling.CollectionItemEventArgs(T) Members

CollectionItemEventArgs(T) Members
Constructors Properties
[image]

A class that holds data for events that are raised when an item in a strongly-typed collection changes.

The following tables list the members exposed by the CollectionItemEventArgs(T) type.

Public Constructors

Name | Description
CollectionItemEventArgs | Initializes a new instance of the CollectionItemEventArgs class.

Public Properties

Name | Description
Item | Gets the item that has changed.

See Also

CollectionItemEventArgs(T) Class


MindFusion.Scheduling.CollectionItemEventArgs(T) Constructor

CollectionItemEventArgs(T) Constructor
[image]

Initializes a new instance of the CollectionItemEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CollectionItemEventArgs<T> (
T item
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
item As T _
)

Parameters

item

Type: T
The item that has changed.

See Also

CollectionItemEventArgs(T) Class


MindFusion.Scheduling.CollectionItemEventArgs(T) Properties

CollectionItemEventArgs(T) Properties
[image]

Public Properties

Name | Description
Item | Gets the item that has changed.

See Also

CollectionItemEventArgs(T) Class


MindFusion.Scheduling.CollectionItemEventArgs(T).Item Property

CollectionItemEventArgs(T).Item Property
[image]

Gets the item that has changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public T Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As T

Property Value

The changed item.

See Also

CollectionItemEventArgs(T) Members
CollectionItemEventArgs(T) Class


MindFusion.Scheduling.CollectionItemInsertEventArgs(T) Class

CollectionItemInsertEventArgs(T) Class
[image]

A class that holds event data for events raised when an item in a strongly typed collection is inserted.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class CollectionItemInsertEventArgs<T> : EventArgs

Visual Basic [image] Copy Code

Public Class CollectionItemInsertEventArgs(Of T)
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.CollectionItemInsertEventArgs(T)

See Also

CollectionItemInsertEventArgs(T) Members


MindFusion.Scheduling.CollectionItemInsertEventArgs(T) Members

CollectionItemInsertEventArgs(T) Members
Constructors Properties
[image]

A class that holds event data for events raised when an item in a strongly typed collection is inserted.

The following tables list the members exposed by the CollectionItemInsertEventArgs(T) type.

Public Constructors

Name | Description
CollectionItemInsertEventArgs | Initializes a new instance of the CollectionItemInsertEventArgs class.

Public Properties

Name | Description
Index | Gets the zero based index where the item is inserted in the collection.
Item | Gets the item that is inserted.

See Also

CollectionItemInsertEventArgs(T) Class


MindFusion.Scheduling.CollectionItemInsertEventArgs(T) Constructor

CollectionItemInsertEventArgs(T) Constructor
[image]

Initializes a new instance of the CollectionItemInsertEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CollectionItemInsertEventArgs<T> (
int index,
T item
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
index As Integer, _
item As T _
)

Parameters

index

Type: Int32
The zero based index where the item is inserted in the collection.

item

Type: T
The item that is inserted.

See Also

CollectionItemInsertEventArgs(T) Class


MindFusion.Scheduling.CollectionItemInsertEventArgs(T) Properties

CollectionItemInsertEventArgs(T) Properties
[image]

Public Properties

Name | Description
Index | Gets the zero based index where the item is inserted in the collection.
Item | Gets the item that is inserted.

See Also

CollectionItemInsertEventArgs(T) Class


MindFusion.Scheduling.CollectionItemInsertEventArgs(T).Index Property

CollectionItemInsertEventArgs(T).Index Property
[image]

Gets the zero based index where the item is inserted in the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

An integer that represents the zero based index where the item is inserted.

See Also

CollectionItemInsertEventArgs(T) Members
CollectionItemInsertEventArgs(T) Class


MindFusion.Scheduling.CollectionItemInsertEventArgs(T).Item Property

CollectionItemInsertEventArgs(T).Item Property
[image]

Gets the item that is inserted.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public T Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As T

Property Value

The inserted item.

See Also

CollectionItemInsertEventArgs(T) Members
CollectionItemInsertEventArgs(T) Class


MindFusion.Scheduling.CollectionItemSetEventArgs(T) Class

CollectionItemSetEventArgs(T) Class
[image]

A class that provides event data for events raised when an item in a strongly typed collection is set.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class CollectionItemSetEventArgs<T> : EventArgs

Visual Basic [image] Copy Code

Public Class CollectionItemSetEventArgs(Of T)
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.CollectionItemSetEventArgs(T)

See Also

CollectionItemSetEventArgs(T) Members


MindFusion.Scheduling.CollectionItemSetEventArgs(T) Members

CollectionItemSetEventArgs(T) Members
Constructors Properties
[image]

A class that provides event data for events raised when an item in a strongly typed collection is set.

The following tables list the members exposed by the CollectionItemSetEventArgs(T) type.

Public Constructors

Name | Description
CollectionItemSetEventArgs | Initializes a new instance of the CollectionItemSetEventArgs class with the specified parameters.

Public Properties

Name | Description
Index | Gets the zero based index where the item is set.
NewItem | Gets the new item.
OldItem | Gets the old item.

See Also

CollectionItemSetEventArgs(T) Class


MindFusion.Scheduling.CollectionItemSetEventArgs(T) Constructor

CollectionItemSetEventArgs(T) Constructor
[image]

Initializes a new instance of the CollectionItemSetEventArgs class with the specified parameters.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CollectionItemSetEventArgs<T> (
int index,
T oldItem,
T newItem
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
index As Integer, _
oldItem As T, _
newItem As T _
)

Parameters

index

Type: Int32
The zero based index in the collection, where the item is set.

oldItem

Type: T
The old item.

newItem

Type: T
The new item.

See Also

CollectionItemSetEventArgs(T) Class


MindFusion.Scheduling.CollectionItemSetEventArgs(T) Properties

CollectionItemSetEventArgs(T) Properties
[image]

Public Properties

Name | Description
Index | Gets the zero based index where the item is set.
NewItem | Gets the new item.
OldItem | Gets the old item.

See Also

CollectionItemSetEventArgs(T) Class


MindFusion.Scheduling.CollectionItemSetEventArgs(T).Index Property

CollectionItemSetEventArgs(T).Index Property
[image]

Gets the zero based index where the item is set.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Index { get; }integer

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

An integer that specifies the zero-based index of the item that is set.

See Also

CollectionItemSetEventArgs(T) Members
CollectionItemSetEventArgs(T) Class


MindFusion.Scheduling.CollectionItemSetEventArgs(T).NewItem Property

CollectionItemSetEventArgs(T).NewItem Property
[image]

Gets the new item.

Namespace: MindFusioobjectn.Scheduling
Assembly: MindFusion.Scheduling

Syntax

C# [image] Copy Code

public T NewItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewItem As T

Property Value

An object of type T that specifies the new value of the item.

See Also

CollectionItemSetEventArgs(T) Members
CollectionItemSetEventArgs(T) Class


MindFusion.Scheduling.CollectionItemSetEventArgs(T).OldItem Property

CollectionItemSetEventArgs(T).OldItem Property
[image]

Gets the old item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public T OldItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldItem As T

Property Value

The old value of the item that is set.

See Also

CollectionItemSetEventArgs(T) Members
CollectionItemSetEventArgs(T) Class


MindFusion.Scheduling.Contact Class

Contact Class
Remarks See Also
[image]

Represents an object that holds contact data for a person.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class Contact : Resource

Visual Basic [image] Copy Code

Public Class Contact
Inherits Resource

Remarks

Instances of the Contact class contain contact information about individual people. They are used by schedule classes that have human resources associated with them.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Contact

See Also

Contact Members


MindFusion.Scheduling.Contact Members

Contact Members
Constructors Properties Methods
[image]

Represents an object that holds contact data for a person.

The following tables list the members exposed by the Contact type.

Public Constructors

Name | Description
Contact | Initializes a new instance of the Contact class.

Public Properties

Name | Description
Address | Gets or sets the address of the contact.
Email | Gets or sets the e-mail address of the contact.
FirstName | Gets or sets the first name of the contact.
LastName | Gets or sets the last name of the contact.
MiddleName | Gets or sets the middle name of the contact.
Phone | Gets or sets the phone of the contact.

Public Methods

Name | Description
LoadFrom | Overloaded.
LoadViewState | Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Control.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
ToString | Overloaded.

Inherited Public Methods

Name | Description
getId | Gets the id of the resource. (Inherited from Resource.)
getName | Gets the name of the resource. (Inherited from Resource.)
getTag | Gets the custom data associated with the resource. (Inherited from Resource.)

See Also

Contact Class


MindFusion.Scheduling.Contact Constructor

Contact Constructor
[image]

Initializes a new instance of the Contact class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Contact ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Contact Class


MindFusion.Scheduling.Contact Methods

Contact Methods
[image]

Public Methods

Name | Description
LoadFrom | Overloaded.
LoadViewState | Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Control.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
ToString | Overloaded.

Inherited Public Methods

Name | Description
getId | Gets the id of the resource. (Inherited from Resource.)
getName | Gets the name of the resource. (Inherited from Resource.)
getTag | Gets the custom data associated with the resource. (Inherited from Resource.)

See Also

Contact Class


MindFusion.Scheduling.Contact.LoadFrom Method

Contact.LoadFrom Method
[image]

Overload List

Name | Description
Contact.LoadFrom (BinaryReader, BinarySerializationContext) | Loads contact data from a binary stream.
Contact.LoadFrom (XmlElement, XmlSerializationContext) | Loads contact data from an XML document.

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.LoadFrom Method (BinaryReader, BinarySerializationContext)

Contact.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also
[image]

Loads contact data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class that reads primitive data types from a binary stream.
context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

LoadFrom Method Overload List
Contact Members
Contact Class


MindFusion.Scheduling.Contact.LoadFrom Method (XmlElement, XmlSerializationContext)

Contact.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads contact data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.Xml.XmlElement class that allows reading data from the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

LoadFrom Method Overload List
Contact Members
Contact Class


MindFusion.Scheduling.Contact.LoadViewState Method

Contact.LoadViewState Method
[image]

Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.SaveTo Method

Contact.SaveTo Method
[image]

Overload List

Name | Description
Contact.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the contact data to a binary stream.
Contact.SaveTo (XmlElement, XmlSerializationContext) | Saves the contact data to an XML document.

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.SaveTo Method (BinaryWriter, BinarySerializationContext)

Contact.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also
[image]

Saves the contact data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class that allows writing primitive data types to a binary stream.
context

Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

SaveTo Method Overload List
Contact Members
Contact Class


MindFusion.Scheduling.Contact.SaveTo Method (XmlElement, XmlSerializationContext)

Contact.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the contact data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.Xml.XmlElement class that allows adding data to the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

SaveTo Method Overload List
Contact Members
Contact Class


MindFusion.Scheduling.Contact.SaveViewState Method

Contact.SaveViewState Method
[image]

Control.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.ToString Method

Contact.ToString Method
[image]

Overload List

Name | Description
Contact.ToString () | Overrides Control.ToString()
Contact.ToString (IFormatProvider) | Converts this Contact to string using the specified format.

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.ToString Method ()

Contact.ToString Method ()
See Also
[image]

Overrides Control.ToString()

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual string ToString ()

Visual Basic [image] Copy Code

Public Overridable Function ToString () As String

Return Value

Type: String
The string representation of a contact.

See Also

ToString Method Overload List
Contact Members
Contact Class


MindFusion.Scheduling.Contact.ToString Method (IFormatProvider)

Contact.ToString Method (IFormatProvider)
See Also
[image]

Converts this Contact to string using the specified format.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override string ToString (
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Overrides Function ToString( _
provider As IFormatProvider _
) As String

Parameters

provider
Type: IFormatProvider
A System.IFormatProvider object that provides culture-specific formatting information.

Return Value

Type: String
A string that represents this Contact formatted with provider.

Remarks

The provider parameter is typically a DateTimeFormatInfo object or a CultureInfo object that contains a DateTimeFormatInfo object. If provider is null, the DateTimeFormatInfo associated with the current culture is used. For more information, see System.Globalization.CultureInfo.CurrentCulture.

See Also

ToString Method Overload List
Contact Members
Contact Class


MindFusion.Scheduling.Contact Properties

Contact Properties
[image]

Public Properties

Name | Description
Address | Gets or sets the address of the contact.
Email | Gets or sets the e-mail address of the contact.
FirstName | Gets or sets the first name of the contact.
LastName | Gets or sets the last name of the contact.
MiddleName | Gets or sets the middle name of the contact.
Phone | Gets or sets the phone of the contact.

See Also

Contact Class


MindFusion.Scheduling.Contact.Address Property

Contact.Address Property
[image]

Gets or sets the address of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Address { get; set; }

Visual Basic [image] Copy Code

Public Property Address As String

Property Value

A string containing address information. The default is an empty string ("").

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.Email Property

Contact.Email Property
[image]

Gets or sets the e-mail address of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Email { get; set; }

Visual Basic [image] Copy Code

Public Property Email As String

Property Value

A string containing an e-mail address. The default is an empty string ("").

See Also

Contact Members
Contact Class


MindFusion.Scheduling.Contact.FirstName Property

Contact.FirstName Property
[image]

Gets or sets the first name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string FirstName { get; set; }

Visual Basic [image] Copy Code

Public Property FirstName As String

Property Value

A string containing the first name of a person. The default is an empty string ("").

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
LastName Property
MiddleName Property


MindFusion.Scheduling.Contact.LastName Property

Contact.LastName Property
[image]

Gets or sets the last name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string LastName { get; set; }

Visual Basic [image] Copy Code

Public Property LastName As String

Property Value

A string containing person's last name. The default is an empty string ("").

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
FirstName Property
MiddleName Property


MindFusion.Scheduling.Contact.MiddleName Property

Contact.MiddleName Property
[image]

Gets or sets the middle name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MiddleName { get; set; }

Visual Basic [image] Copy Code

Public Property MiddleName As String

Property Value

A string containing person's middle name. The default is an empty string ("").

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
FirstName Property
LastName Property


MindFusion.Scheduling.Contact.Phone Property

Contact.Phone Property
[image]

Gets or sets the phone of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Phone { get; set; }

Visual Basic [image] Copy Code

Public Property Phone As String

Property Value

A string containing a phone number. The default is an empty string ("").

See Also

Contact Members
Contact Class


MindFusion.Scheduling.ContentType Enumeration

ContentType Enumeration
[image]

Specifies the type of file contents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum ContentType

Visual Basic [image] Copy Code

Public Enum ContentType

Members

Member name | Value | Description
Binary | 0 | Specifies that a file stores information in binary format.
Xml | 1 | Specifies that a file stores information in XML format.

See Also


MindFusion.Scheduling.CssBackground Class

CssBackground Class
[image]

Represents CSS background properties of calendar elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class CssBackground : IStateManager

Visual Basic [image] Copy Code

Public Class CssBackground
Implements IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.CssBackground

See Also

CssBackground Members


MindFusion.Scheduling.CssBackground Members

CssBackground Members
Constructors Properties Methods Events
[image]

Represents CSS background properties of calendar elements.

The following tables list the members exposed by the CssBackground type.

Public Constructors

Name | Description
CssBackground | Initializes a new instance of the CssBackground class.

Public Properties

Name | Description
Attachment | Gets or sets how the background image is attached to the object within the document.
Color | Gets or sets the color behind the contents of the object.
Image | Gets or sets the background image of the object.
IsEmpty | Gets a value indicating whether the collection is empty.
PositionX | Gets or sets the X-coordinate of the CSS background-position property.
PositionY | Gets or sets the Y-coordinate of the CSS background-position property.
Repeat | Gets or sets the repeat style of the background image.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page.

Public Methods

Name | Description
GetProperties | Gets CssBackground class properties as IDictionary<string, object> object.
SetProperties | Sets the properties of this CssBackground object from the specified IDictionary<string, Object> list.
ToJsonString | Gets the JSON representation of this CssBackground object.
ToString | Returns a System.String that represents the current CssBackground.

Public Events

Name | Description
Changed | Raised when a property value changes.

See Also

CssBackground Class


MindFusion.Scheduling.CssBackground Constructor

CssBackground Constructor
[image]

Initializes a new instance of the CssBackground class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CssBackground ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CssBackground Class


MindFusion.Scheduling.CssBackground Methods

CssBackground Methods
[image]

Public Methods

Name | Description
GetProperties | Gets CssBackground class properties as IDictionary<string, object> object.
SetProperties | Sets the properties of this CssBackground object from the specified IDictionary<string, Object> list.
ToJsonString | Gets the JSON representation of this CssBackground object.
ToString | Returns a System.String that represents the current CssBackground.

See Also

CssBackground Class


MindFusion.Scheduling.CssBackground.GetProperties Method

CssBackground.GetProperties Method
[image]

Gets CssBackground class properties as IDictionary<string, object> object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public IDictionary<string, Object> GetProperties ()

Visual Basic [image] Copy Code

Public Function GetProperties () As IDictionary(Of String, Object)

Return Value

Type: IDictionary<String, Object>
A System.Collections.Generic.IDictionary<TKey, TValue> list that holds the properties.

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground.SetProperties Method

CssBackground.SetProperties Method
[image]

Sets the properties of this CssBackground object from the specified IDictionary<string, Object> list.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SetProperties (
IDictionary<string, Object> dictionary
)

Visual Basic [image] Copy Code

Public Sub SetProperties( _
dictionary As IDictionary(Of String, Object) _
)

Parameters

dictionary
Type: IDictionary<String, Object>
A System.Collections.Generic.IDictionary<TKey, TValue> object that provides the properties.

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground.ToJsonString Method

CssBackground.ToJsonString Method
[image]

Gets the JSON representation of this CssBackground object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ToJsonString ()

Visual Basic [image] Copy Code

Public Function ToJsonString () As String

Return Value

Type: String
A string that gives the JSON representation of the object.

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground.ToString Method

CssBackground.ToString Method
[image]

Returns a System.String that represents the current CssBackground.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

Type: String
A System.String that represents the current CssBackground object.

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground Properties

CssBackground Properties
[image]

Public Properties

Name | Description
Attachment | Gets or sets how the background image is attached to the object within the document.
Color | Gets or sets the color behind the contents of the object.
Image | Gets or sets the background image of the object.
IsEmpty | Gets a value indicating whether the collection is empty.
PositionX | Gets or sets the X-coordinate of the CSS background-position property.
PositionY | Gets or sets the Y-coordinate of the CSS background-position property.
Repeat | Gets or sets the repeat style of the background image.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page.

See Also

CssBackground Class


MindFusion.Scheduling.CssBackground.Attachment Property

CssBackground.Attachment Property
[image]

Gets or sets how the background image is attached to the object within the document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public BackgroundAttachment Attachment { get; set; }

Visual Basic [image] Copy Code

Public Property Attachment As BackgroundAttachment

Property Value

One of the BackgroundAttachment enumeration values. Default value is BackgroundAttachment.None.

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground.Color Property

CssBackground.Color Property
[image]

Gets or sets the color behind the contents of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

An instance of the System.Drawing.Color structure. Default value is Color.Empty.

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground.Image Property

CssBackground.Image Property
[image]

Gets or sets the background image of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As String

Property Value

A string that specifies the URL to the image file. Default value is an empty string ("").

Remarks

The URL identifies the image file. When setting a background image, you can set a background color to use when the image is unavailable. When the image is available, it overlays the background color.

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground.IsEmpty Property

CssBackground.IsEmpty Property
[image]

Gets a value indicating whether the collection is empty.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if the collection is empty; otherwise false.

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground.PositionX Property

CssBackground.PositionX Property
[image]

Gets or sets the X-coordinate of the CSS background-position property.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string PositionX { get; set; }

Visual Basic [image] Copy Code

Public Property PositionX As String

Property Value

A string that represents the X-position. Default value is an empty string ("").

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground.PositionY Property

CssBackground.PositionY Property
[image]

Gets or sets the Y-coordinate of the CSS background-position property.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string PositionY { get; set; }

Visual Basic [image] Copy Code

Public Property PositionY As String

Property Value

A string that represents the Y-position. Default value is an empty string ("").

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground.Repeat Property

CssBackground.Repeat Property
[image]

Gets or sets the repeat style of the background image.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public BackgroundRepeat Repeat { get; set; }

Visual Basic [image] Copy Code

Public Property Repeat As BackgroundRepeat

Property Value

One of the BackgroundRepeat enumeration values. Default is BackgroundRepeat.None.

Remarks

The repeat-x and repeat-y values make the image repeat horizontally and vertically, respectively, creating a single band of images from one side to the other. This property can be set with other background properties by using the background composite property.

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground.ViewState Property

CssBackground.ViewState Property
[image]

Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual StateBag ViewState { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property ViewState As StateBag

Property Value

An instance of the System.Web.UI.StateBag class that contains the server control's view-state information.

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBackground Events

CssBackground Events
[image]

Public Events

Name | Description
Changed | Raised when a property value changes.

See Also

CssBackground Class


MindFusion.Scheduling.CssBackground.Changed Event

CssBackground.Changed Event
[image]

Raised when a property value changes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

See Also

CssBackground Members
CssBackground Class


MindFusion.Scheduling.CssBorderStyle Class

CssBorderStyle Class
[image]

Represents the CSS style of the border of calendar elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class CssBorderStyle : IStateManager, ICloneable

Visual Basic [image] Copy Code

Public Class CssBorderStyle
Implements IStateManager, ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.CssBorderStyle

See Also

CssBorderStyle Members


MindFusion.Scheduling.CssBorderStyle Members

CssBorderStyle Members
Constructors Properties Methods Events
[image]

Represents the CSS style of the border of calendar elements.

The following tables list the members exposed by the CssBorderStyle type.

Public Constructors

Name | Description
CssBorderStyle | Initializes a new instance of the CssBorderStyle class.

Public Properties

Name | Description
AllColor | Gets or sets the color of the left, right, top, and bottom borders of the object.
AllStyle | Gets or sets the style of the left, right, top, and bottom borders of the object.
AllWidth | Gets or sets the width of the left, right, top, and bottom borders of the object.
BottomColor | Gets or sets the color of the bottom border of the object.
BottomStyle | Gets or sets the style of the bottom border of the object.
BottomWidth | Gets or sets the width of the bottom border of the object.
IsEmpty | Returns a boolean value indicating whether all four border values are set.
LeftColor | Gets or sets the color of the left border of the object.
LeftStyle | Gets or sets the style of the left border of the object.
LeftWidth | Gets or sets the width of the left border of the object.
RightColor | Gets or sets the color of the right border of the object.
RightStyle | Gets or sets the style of the right border of the object.
RightWidth | Gets or sets the width of the right border of the object.
TopColor | Gets or sets the color of the top border of the object.
TopStyle | Gets or sets the style of the top border of the object.
TopWidth | Gets or sets the width of the top border of the object.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of this CssBorderStyle object.

Public Methods

Name | Description
Clone | Creates an exact copy of the current CssBorderStyle object.
CopyFrom | Copies the values for the properties of this CssBorderStyle object from the specified CssBorderStyle object.
GetBottomWidth | Gets the width of the bottom border.
GetLeftWidth | Gets the width of the left border.
GetProperties | Adds the properties of this CssBorderStyle object as <key, value> pairs in an IDictionary object.
GetRightWidth | Gets the width of the right border.
GetTopWidth | Gets the width of the top border.
SetProperties | Sets the values of the properties for this CssBorderStyle object from the specified IDictionary<string, Object> list.
ToJsonString | Gets the JSON representation of this CssBorderStyle object.

Public Events

Name | Description
Changed | Raised when a property value changes.

See Also

CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle Constructor

CssBorderStyle Constructor
[image]

Initializes a new instance of the CssBorderStyle class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CssBorderStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle Methods

CssBorderStyle Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of the current CssBorderStyle object.
CopyFrom | Copies the values for the properties of this CssBorderStyle object from the specified CssBorderStyle object.
GetBottomWidth | Gets the width of the bottom border.
GetLeftWidth | Gets the width of the left border.
GetProperties | Adds the properties of this CssBorderStyle object as <key, value> pairs in an IDictionary object.
GetRightWidth | Gets the width of the right border.
GetTopWidth | Gets the width of the top border.
SetProperties | Sets the values of the properties for this CssBorderStyle object from the specified IDictionary<string, Object> list.
ToJsonString | Gets the JSON representation of this CssBorderStyle object.

See Also

CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.Clone Method

CssBorderStyle.Clone Method
[image]

Creates an exact copy of the current CssBorderStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

Type: Object
A new CssBorderStyle object identical to the current one.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.CopyFrom Method

CssBorderStyle.CopyFrom Method
[image]

Copies the values for the properties of this CssBorderStyle object from the specified CssBorderStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool CopyFrom (
CssBorderStyle value
)

Visual Basic [image] Copy Code

Public Function CopyFrom ( _
value As CssBorderStyle _
) As Boolean

Parameters

value
Type: CssBorderStyle
The CssBorderStyle object to copy the properties from.

Return Value

Type: Boolean
true if the copy operation was successful; false otherwise.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.GetBottomWidth Method

CssBorderStyle.GetBottomWidth Method
[image]

Gets the width of the bottom border.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit GetBottomWidth ()

Visual Basic [image] Copy Code

Public Function GetBottomWidth () As Unit

Return Value

Type: Unit
A System.Web.UI.WebControls.Unit value representing the width of the bottom border.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.GetLeftWidth Method

CssBorderStyle.GetLeftWidth Method
[image]

Gets the width of the left border.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit GetLeftWidth ()

Visual Basic [image] Copy Code

Public Function GetLeftWidth () As Unit

Return Value

Type: Unit
A System.Web.UI.WebControls.Unit value representing the width of the left border.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.GetProperties Method

CssBorderStyle.GetProperties Method
[image]

Adds the properties of this CssBorderStyle object as <key, value> pairs in an IDictionary object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public IDictionary<string, Object> GetProperties ()

Visual Basic [image] Copy Code

Public Function GetProperties () As IDictionary(Of String, Object)

Return Value

Type: IDictionary<String, Object>
A System.Collections.Generic.IDictionary<TKey, TValue> list that holds the properties.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.GetRightWidth Method

CssBorderStyle.GetRightWidth Method
[image]

Gets the width of the right border.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit GetRightWidth ()

Visual Basic [image] Copy Code

Public Function GetRightWidth () As Unit

Return Value

Type: Unit
A System.Web.UI.WebControls.Unit value representing the width of the right border.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.GetTopWidth Method

CssBorderStyle.GetTopWidth Method
[image]

Gets the width of the top border.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit GetTopWidth ()

Visual Basic [image] Copy Code

Public Function GetTopWidth () As Unit

Return Value

Type: Unit
A System.Web.UI.WebControls.Unit value representing the width of the top border.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.SetProperties Method

CssBorderStyle.SetProperties Method
[image]

Sets the values of the properties for this CssBorderStyle object from the specified IDictionary<string, Object> list.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SetProperties (
IDictionary<string, Object> dictionary
)

Visual Basic [image] Copy Code

Public Sub SetProperties( _
dictionary As IDictionary(Of String, Object) _
)

Parameters

dictionary
Type: IDictionary<String, Object>
A System.Collections.Generic.IDictionary<TKey, TValue> list where each pair of data represents the name of a property and its respective value.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.ToJsonString Method

CssBorderStyle.ToJsonString Method
[image]

Gets the JSON representation of this CssBorderStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ToJsonString ()

Visual Basic [image] Copy Code

Public Function ToJsonString () As String

Return Value

Type: String
A string that is the JSON representation of this CssBorderStyle object.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle Properties

CssBorderStyle Properties
[image]

Public Properties

Name | Description
AllColor | Gets or sets the color of the left, right, top, and bottom borders of the object.
AllStyle | Gets or sets the style of the left, right, top, and bottom borders of the object.
AllWidth | Gets or sets the width of the left, right, top, and bottom borders of the object.
BottomColor | Gets or sets the color of the bottom border of the object.
BottomStyle | Gets or sets the style of the bottom border of the object.
BottomWidth | Gets or sets the width of the bottom border of the object.
IsEmpty | Returns a boolean value indicating whether all four border values are set.
LeftColor | Gets or sets the color of the left border of the object.
LeftStyle | Gets or sets the style of the left border of the object.
LeftWidth | Gets or sets the width of the left border of the object.
RightColor | Gets or sets the color of the right border of the object.
RightStyle | Gets or sets the style of the right border of the object.
RightWidth | Gets or sets the width of the right border of the object.
TopColor | Gets or sets the color of the top border of the object.
TopStyle | Gets or sets the style of the top border of the object.
TopWidth | Gets or sets the width of the top border of the object.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of this CssBorderStyle object.

See Also

CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.AllColor Property

CssBorderStyle.AllColor Property
[image]

Gets or sets the color of the left, right, top, and bottom borders of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Color AllColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property AllColor As Color

Property Value

One of the System.Drawing.Color structure values. Default value is Color.Empty.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.AllStyle Property

CssBorderStyle.AllStyle Property
[image]

Gets or sets the style of the left, right, top, and bottom borders of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual BorderStyle AllStyle { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property AllStyle As BorderStyle

Property Value

One of the System.Web.UI.WebControls.BorderStyle enumeration values. Default value is BorderStyle.NotSet.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.AllWidth Property

CssBorderStyle.AllWidth Property
[image]

Gets or sets the width of the left, right, top, and bottom borders of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Unit AllWidth { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property AllWidth As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure. Default value is Unit.Empty.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.BottomColor Property

CssBorderStyle.BottomColor Property
[image]

Gets or sets the color of the bottom border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Color BottomColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property BottomColor As Color

Property Value

One of the System.Drawing.Color structure values. Default value is Color.Empty.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.BottomStyle Property

CssBorderStyle.BottomStyle Property
[image]

Gets or sets the style of the bottom border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual BorderStyle BottomStyle { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property BottomStyle As BorderStyle

Property Value

One of the System.Web.UI.WebControls.BorderStyle enumeration values. Default value is BorderStyle.NotSet.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.BottomWidth Property

CssBorderStyle.BottomWidth Property
[image]

Gets or sets the width of the bottom border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Unit BottomWidth { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property BottomWidth As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure. Default value is Unit.Empty.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.IsEmpty Property

CssBorderStyle.IsEmpty Property
[image]

Returns a boolean value indicating whether all four border values are set.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if all border values are set; otherwise false.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.LeftColor Property

CssBorderStyle.LeftColor Property
[image]

Gets or sets the color of the left border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Color LeftColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LeftColor As Color

Property Value

One of the System.Drawing.Color structure values. Default value is Color.Empty.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.LeftStyle Property

CssBorderStyle.LeftStyle Property
[image]

Gets or sets the style of the left border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual BorderStyle LeftStyle { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LeftStyle As BorderStyle

Property Value

One of the System.Web.UI.WebControls.BorderStyle enumeration values. Default value is BorderStyle.NotSet.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.LeftWidth Property

CssBorderStyle.LeftWidth Property
[image]

Gets or sets the width of the left border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Unit LeftWidth { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LeftWidth As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure. Default value is Unit.Empty.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.RightColor Property

CssBorderStyle.RightColor Property
[image]

Gets or sets the color of the right border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Color RightColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property RightColor As Color

Property Value

One of the System.Drawing.Color structure values. Default value is Color.Empty.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.RightStyle Property

CssBorderStyle.RightStyle Property
[image]

Gets or sets the style of the right border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual BorderStyle RightStyle { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property RightStyle As BorderStyle

Property Value

One of the System.Web.UI.WebControls.BorderStyle enumeration values. Default value is BorderStyle.NotSet.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.RightWidth Property

CssBorderStyle.RightWidth Property
[image]

Gets or sets the width of the right border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Unit RightWidth { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property RightWidth As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure. Default value is Unit.Empty.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.TopColor Property

CssBorderStyle.TopColor Property
[image]

Gets or sets the color of the top border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Color TopColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TopColor As Color

Property Value

One of the System.Drawing.Color structure values. Default value is Color.Empty.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.TopStyle Property

CssBorderStyle.TopStyle Property
[image]

Gets or sets the style of the top border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual BorderStyle TopStyle { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TopStyle As BorderStyle

Property Value

One of the System.Web.UI.WebControls.BorderStyle enumeration values. Default value is BorderStyle.NotSet.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.TopWidth Property

CssBorderStyle.TopWidth Property
[image]

Gets or sets the width of the top border of the object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Unit TopWidth { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TopWidth As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure. Default value is Unit.Empty.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.ViewState Property

CssBorderStyle.ViewState Property
[image]

Gets a dictionary of state information that allows you to save and restore the view state of this CssBorderStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual StateBag ViewState { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property ViewState As StateBag

Property Value

An instance of the System.Web.UI.StateBag class that contains the view-state information.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle Events

CssBorderStyle Events
[image]

Public Events

Name | Description
Changed | Raised when a property value changes.

See Also

CssBorderStyle Class


MindFusion.Scheduling.CssBorderStyle.Changed Event

CssBorderStyle.Changed Event
[image]

Raised when a property value changes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

Event Data

An instance of the System.EventArgs class that contains data for the event.

See Also

CssBorderStyle Members
CssBorderStyle Class


MindFusion.Scheduling.CultureEventArgs Class

CultureEventArgs Class
[image]

Provides data for events raised when the culture has changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class CultureEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CultureEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.CultureEventArgs

See Also

CultureEventArgs Members


MindFusion.Scheduling.CultureEventArgs Members

CultureEventArgs Members
Properties
[image]

Provides data for events raised when the culture has changed.

The following tables list the members exposed by the CultureEventArgs type.

Public Properties

Name | Description
NewValue | Gets the new value of the culture property.
OldValue | Gets the old value of the culture property.

See Also

CultureEventArgs Class


MindFusion.Scheduling.CultureEventArgs Properties

CultureEventArgs Properties
[image]

Public Properties

Name | Description
NewValue | Gets the new value of the culture property.
OldValue | Gets the old value of the culture property.

See Also

CultureEventArgs Class


MindFusion.Scheduling.CultureEventArgs.NewValue Property

CultureEventArgs.NewValue Property
[image]

Gets the new value of the culture property.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CultureInfo NewValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewValue As CultureInfo

Property Value

An instance of the System.Globalization.CultureInfo class.

See Also

CultureEventArgs Members
CultureEventArgs Class


MindFusion.Scheduling.CultureEventArgs.OldValue Property

CultureEventArgs.OldValue Property
[image]

Gets the old value of the culture property.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CultureInfo OldValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldValue As CultureInfo

Property Value

An instance of the System.Globalization.CultureInfo class.

See Also

CultureEventArgs Members
CultureEventArgs Class


MindFusion.Scheduling.DailyRecurrence Enumeration

DailyRecurrence Enumeration
[image]

Specifies daily recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum DailyRecurrence

Visual Basic [image] Copy Code

Public Enum DailyRecurrence

Members

Member name | Value | Description
ByDayInterval | 0 | Repeats the item at regular intervals specified in the Recurrence.Days property.
EveryWorkday | 1 | Repeats the item each workday, Monday through Friday.
EveryWeekend | 2 | Repeats the item each Saturday and Sunday.

See Also


MindFusion.Scheduling.DateChangedEventArgs Class

DateChangedEventArgs Class
[image]

Specifies data for the VisibleDateChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class DateChangedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DateChangedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.DateChangedEventArgs

See Also

DateChangedEventArgs Members


MindFusion.Scheduling.DateChangedEventArgs Members

DateChangedEventArgs Members
Properties
[image]

Specifies data for the VisibleDateChanged event.

The following tables list the members exposed by the DateChangedEventArgs type.

Public Properties

Name | Description
NewDate | Gets the new visible date.
PreviousDate | Gets the previous visible date.

See Also

DateChangedEventArgs Class


MindFusion.Scheduling.DateChangedEventArgs Properties

DateChangedEventArgs Properties
[image]

Public Properties

Name | Description
NewDate | Gets the new visible date.
PreviousDate | Gets the previous visible date.

See Also

DateChangedEventArgs Class


MindFusion.Scheduling.DateChangedEventArgs.NewDate Property

DateChangedEventArgs.NewDate Property
[image]

Gets the new visible date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime NewDate { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewDate As DateTime

Property Value

An instance of the System.DateTime structure. Default value is DateTime.MinValue.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class


MindFusion.Scheduling.DateChangedEventArgs.PreviousDate Property

DateChangedEventArgs.PreviousDate Property
[image]

Gets the previous visible date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime PreviousDate { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PreviousDate As DateTime

Property Value

An instance of the System.DateTime structure. Default value is DateTime.MinValue.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class


MindFusion.Scheduling.DayOfWeekType Enumeration

DayOfWeekType Enumeration
[image]

Specifies the type of week day to use with ByDayType monthly and yearly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum DayOfWeekType

Visual Basic [image] Copy Code

Public Enum DayOfWeekType

Members

Member name | Value | Description
AnyDay | 0 | Indicates any day.
Workday | 1 | Indicates a workday.
Weekend | 2 | Indicates a weekend day.
Sunday | 3 | Indicates Sunday.
Monday | 4 | Indicates Monday.
Tuesday | 5 | Indicates Tuesday.
Wednesday | 6 | Indicates Wednesday.
Thursday | 7 | Indicates Thursday.
Friday | 8 | Indicates Friday.
Saturday | 9 | Indicates Saturday.

See Also


MindFusion.Scheduling.DaysOfWeek Enumeration

DaysOfWeek Enumeration
[image]

Specifies the day of the week. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum DaysOfWeek

Visual Basic [image] Copy Code

Public Enum DaysOfWeek

Members

Member name | Value | Description
None | 0 | Indicates an undefined day value.
Sunday | 1 | Indicates Sunday.
Monday | 2 | Indicates Monday.
Tuesday | 4 | Indicates Tuesday.
Wednesday | 8 | Indicates Wednesday.
Thursday | 16 | Indicates Thursday.
Friday | 32 | Indicates Friday.
Saturday | 64 | Indicates Saturday.
All | 127 | Indicates all days of the week.

See Also


MindFusion.Scheduling.GroupType Enumeration

GroupType Enumeration
[image]

Specifies grouping or filtering criteria for views that support grouping.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum GroupType

Visual Basic [image] Copy Code

Public Enum GroupType

Members

Member name | Value | Description
None | 0 | No grouping or filtering.
GroupByContacts | 1 | Group by contacts.
GroupByResources | 2 | Group by resources.
GroupByLocations | 3 | Group by locations.
GroupByTasks | 4 | Group by tasks.
FilterByContacts | 5 | Filter by contacts.
FilterByLocations | 6 | Filter by locations.
FilterByTasks | 7 | Filter by tasks.
FilterByResources | 8 | Filter by resources.

Remarks

For information about grouping and filtering in a Calendar, refer to the Grouping topic and Tutorial 2: Filtering and Grouping.

See Also

MindFusion.Scheduling Namespace
Grouping
Tutorial 2


MindFusion.Scheduling.HeaderStyle Class

HeaderStyle Class
[image]

Specifies the appearance of calendar header elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class HeaderStyle : Style

Visual Basic [image] Copy Code

Public Class HeaderStyle
Inherits Style

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Style
MindFusion.Scheduling.HeaderStyle
MindFusion.Scheduling.ItemStyle

See Also

HeaderStyle Members


MindFusion.Scheduling.HeaderStyle Members

HeaderStyle Members
Constructors Properties Methods Events
[image]

Specifies the appearance of calendar header elements.

The following tables list the members exposed by the HeaderStyle type.

Public Constructors

Name | Description
HeaderStyle | Overloaded.

Public Properties

Name | Description
Font | Gets the font in header elements.
TextAlignment | Gets or sets the alignment of text in header elements.
TextColor | Gets or sets the color of the text in header elements.
TextMargins | Gets the text margins in header elements.

Inherited Public Properties

Name | Description
Borders | Gets the border properties for the current Style object. (Inherited from Style.)
Brush | Gets or sets the brush that fills the interior. (Inherited from Style.)
IsTrackingViewState | Gets a value that indicates whether the Style object is saving changes to its view state. (Inherited from Style.)

Public Methods

Name | Description
Clone | Creates an exact copy of the current HeaderStyle object.
GetProperties | Gets the properties of this HeaderStyle instance as IDictionary<string, object> list.
LoadViewState | Restores view-state information from an object that was previously saved by the SaveViewState method.
Reset | Removes any style elements written in the state bag.
SaveViewState | Saves any view-state changes that have occurred on the HeaderStyle object.
SetProperties | Copies the values for the properties of this HeaderStyle object from the specified IDictionary<string, object> object.
ShouldSerialize | Gets a value that indicates whether this HeaderStyle object has changed from its default state.
TrackViewState | Causes tracking of view-state changes to the current HeaderStyle object so they can be stored for later use.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of the current Style object. (Inherited from Style.)
Equals | Determines whether the specified Style object is equivalent to the current one. (Inherited from Style.)
GetHashCode | Returns the hash code for this Style instance. (Inherited from Style.)
GetProperties | Gets the properties of this Style instance as IDictionary<string, object> list. (Inherited from Style.)
LoadViewState | Restores view-state information from an object that was previously saved by the SaveViewState method. (Inherited from Style.)
OnChanged | Raises the Changed event. (Inherited from Style.)
Reset | Removes any Style elements written in the state bag. (Inherited from Style.)
SaveViewState | Saves any view-state changes that have occurred on the Style object. (Inherited from Style.)
SetProperties | Gets the properties of this Style class as IDictionary<string, object> list. (Inherited from Style.)
ShouldSerialize | Gets a value that indicates whether this Style object has changed from its default state. (Inherited from Style.)
TrackViewState | Causes tracking of view-state changes to the current Style object so they can be stored for later use. (Inherited from Style.)

Inherited Public Events

Name | Description
Changed | Raised when the Style changes. (Inherited from Style.)

See Also

HeaderStyle Class


MindFusion.Scheduling.HeaderStyle Constructor

HeaderStyle Constructor
[image]

Overload List

Name | Description
HeaderStyle () | Initializes a new instance of the HeaderStyle class.
HeaderStyle (StateBag) | Initializes a new instance of the HeaderStyle class with property values taken from the specified StateBag object.

See Also

HeaderStyle Class


MindFusion.Scheduling.HeaderStyle Constructor ()

HeaderStyle Constructor ()
See Also
[image]

Initializes a new instance of the HeaderStyle class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HeaderStyle Constructor Overload List
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle Constructor (StateBag)

HeaderStyle Constructor (StateBag)
See Also
[image]

Initializes a new instance of the HeaderStyle class with property values taken from the specified StateBag object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle (
StateBag bag
)

Visual Basic [image] Copy Code

Public New ( _
bag As StateBag _
)

Parameters

bag

Type: StateBag
A System.Web.UI.StateBag object that provides values for the HeaderStyle properties.

See Also

HeaderStyle Constructor Overload List
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle Methods

HeaderStyle Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of the current HeaderStyle object.
GetProperties | Gets the properties of this HeaderStyle instance as IDictionary<string, object> list.
LoadViewState | Restores view-state information from an object that was previously saved by the SaveViewState method.
Reset | Removes any style elements written in the state bag.
SaveViewState | Saves any view-state changes that have occurred on the HeaderStyle object.
SetProperties | Copies the values for the properties of this HeaderStyle object from the specified IDictionary<string, object> object.
ShouldSerialize | Gets a value that indicates whether this HeaderStyle object has changed from its default state.
TrackViewState | Causes tracking of view-state changes to the current HeaderStyle object so they can be stored for later use.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of the current Style object. (Inherited from Style.)
Equals | Determines whether the specified Style object is equivalent to the current one. (Inherited from Style.)
GetHashCode | Returns the hash code for this Style instance. (Inherited from Style.)
GetProperties | Gets the properties of this Style instance as IDictionary<string, object> list. (Inherited from Style.)
LoadViewState | Restores view-state information from an object that was previously saved by the SaveViewState method. (Inherited from Style.)
OnChanged | Raises the Changed event. (Inherited from Style.)
Reset | Removes any Style elements written in the state bag. (Inherited from Style.)
SaveViewState | Saves any view-state changes that have occurred on the Style object. (Inherited from Style.)
SetProperties | Gets the properties of this Style class as IDictionary<string, object> list. (Inherited from Style.)
ShouldSerialize | Gets a value that indicates whether this Style object has changed from its default state. (Inherited from Style.)
TrackViewState | Causes tracking of view-state changes to the current Style object so they can be stored for later use. (Inherited from Style.)

See Also

HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.Clone Method

HeaderStyle.Clone Method
[image]

Creates an exact copy of the current HeaderStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

Type: Object
The newly created copy of the current HeaderStyle instance.

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.GetProperties Method

HeaderStyle.GetProperties Method
[image]

Gets the properties of this HeaderStyle instance as IDictionary<string, object> list.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> GetProperties ()

Visual Basic [image] Copy Code

Public Overrides Function GetProperties () As IDictionary(Of String, Object)

Return Value

Type: IDictionary(String, Object)
An IDictionary<string, object> list that holds the name of each property and its value.

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.LoadViewState Method

HeaderStyle.LoadViewState Method
[image]

Restores view-state information from an object that was previously saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state

Type: Object
A System.Object that represents the control state to be restored.

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.Reset Method

HeaderStyle.Reset Method
[image]

Removes any style elements written in the state bag.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void Reset ()

Visual Basic [image] Copy Code

Public Overrides Sub Reset ()

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.SaveViewState Method

HeaderStyle.SaveViewState Method
[image]

Saves any view-state changes that have occurred on the HeaderStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns a System.Object with the current view state. If there is no view state associated with the HeaderStyle, this method returns null (Nothing in VB.NET).

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.SetProperties Method

HeaderStyle.SetProperties Method
[image]

Copies the values for the properties of this HeaderStyle object from the specified IDictionary<string, object> object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void SetProperties (
IDictionary<string, Object> dictionary
)

Visual Basic [image] Copy Code

Public Overrides Sub SetProperties( _
dictionary As IDictionary(Of String, Object) _
)

Parameters

dictionary

Type: IDictionary(String, Object)
An IDictionary<string, object> list that contains <property value> pairs.

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.ShouldSerialize Method

HeaderStyle.ShouldSerialize Method
[image]

Gets a value that indicates whether this HeaderStyle object has changed from its default state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool ShouldSerialize ()

Visual Basic [image] Copy Code

Public Overrides Function ShouldSerialize () As Boolean

Return Value

Type: Boolean
true if the HeaderStyle has changed; otherwise false.

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.TrackViewState Method

HeaderStyle.TrackViewState Method
[image]

Causes tracking of view-state changes to the current HeaderStyle object so they can be stored for later use.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle Properties

HeaderStyle Properties
[image]

Public Properties

Name | Description
Font | Gets the font in header elements.
TextAlignment | Gets or sets the alignment of text in header elements.
TextColor | Gets or sets the color of the text in header elements.
TextMargins | Gets the text margins in header elements.

Inherited Public Properties

Name | Description
Borders | Gets the border properties for the current Style object. (Inherited from Style.)
Brush | Gets or sets the brush that fills the interior. (Inherited from Style.)
IsTrackingViewState | Gets a value that indicates whether the Style object is saving changes to its view state. (Inherited from Style.)

See Also

HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.Font Property

HeaderStyle.Font Property
[image]

Gets the font in header elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual FontInfo Font { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Font As FontInfo

Property Value

An instance of the System.Web.UI.WebControls.FontInfo class.

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.TextAlignment Property

HeaderStyle.TextAlignment Property
[image]

Gets or sets the alignment of text in header elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual TextAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TextAlignment As TextAlignment

Property Value

An instance of the TextAlignment enumeration.

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.TextColor Property

HeaderStyle.TextColor Property
[image]

Gets or sets the color of the text in header elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Color TextColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TextColor As Color

Property Value

An instance of the System.Drawing.Color structure.

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.HeaderStyle.TextMargins Property

HeaderStyle.TextMargins Property
[image]

Gets the text margins in header elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Thickness TextMargins { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property TextMargins As Thickness

Property Value

An instance of the Thickness class.

See Also

HeaderStyle Members
HeaderStyle Class


MindFusion.Scheduling.InstantiateItemEventArgs Class

InstantiateItemEventArgs Class
[image]

Provides data for the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class InstantiateItemEventArgs : InstantiateItemEventArgs<Item>

Visual Basic [image] Copy Code

Public Class InstantiateItemEventArgs
Inherits InstantiateItemEventArgs(Of Item)

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateItemEventArgs(Item)
MindFusion.Scheduling.InstantiateItemEventArgs

See Also

InstantiateItemEventArgs Members


MindFusion.Scheduling.InstantiateItemEventArgs Members

InstantiateItemEventArgs Members
Constructors Properties
[image]

Provides data for the InstantiateItem event.

The following tables list the members exposed by the InstantiateItemEventArgs type.

Protected Constructors

Name | Description
InstantiateItemEventArgs | Initializes a new instance of the InstantiateItemEventArgs class.

Inherited Public Properties

Name | Description
ClassId | Gets the class identifier of the item. (Inherited from InstantiateItemEventArgs.)
Item | Gets or sets the newly created item. (Inherited from InstantiateItemEventArgs.)

See Also

InstantiateItemEventArgs Class


MindFusion.Scheduling.InstantiateItemEventArgs Constructor

InstantiateItemEventArgs Constructor
[image]

Initializes a new instance of the InstantiateItemEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected InstantiateItemEventArgs (
string classId
)

Visual Basic [image] Copy Code

Protected New ( _
classId As String _
)

Parameters

classId
Type: String
A string that specifies the class id.

See Also

InstantiateItemEventArgs Class


MindFusion.Scheduling.InstantiateItemEventArgs(T) Class

InstantiateItemEventArgs(T) Class
[image]

Specifies data for the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class InstantiateItemEventArgs<T> : EventArgs

Visual Basic [image] Copy Code

Public Class InstantiateItemEventArgs(Of T)
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateItemEventArgs(T)
MindFusion.Scheduling.InstantiateItemEventArgs

See Also

InstantiateItemEventArgs(T) Members


MindFusion.Scheduling.InstantiateItemEventArgs(T) Members

InstantiateItemEventArgs(T) Members
Constructors Properties
[image]

Specifies data for the InstantiateItem event.

The following tables list the members exposed by the InstantiateItemEventArgs(T) type.

Protected Constructors

Name | Description
InstantiateItemEventArgs | Initializes a new instance of the InstantiateItemEventArgs class.

Public Properties

Name | Description
ClassId | Gets the class identifier of the item.
Item | Gets or sets the newly created item.

See Also

InstantiateItemEventArgs(T) Class


MindFusion.Scheduling.InstantiateItemEventArgs(T) Constructor

InstantiateItemEventArgs(T) Constructor
[image]

Initializes a new instance of the InstantiateItemEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected InstantiateItemEventArgs<T> (
string classId
)

Visual Basic [image] Copy Code

Protected New (Of T) ( _
classId As String _
)

Parameters

classId
Type: String
A string that specifies the class identifier.

See Also

InstantiateItemEventArgs(T) Class


MindFusion.Scheduling.InstantiateItemEventArgs(T) Properties

InstantiateItemEventArgs(T) Properties
[image]

Public Properties

Name | Description
ClassId | Gets the class identifier of the item.
Item | Gets or sets the newly created item.

See Also

InstantiateItemEventArgs(T) Class


MindFusion.Scheduling.InstantiateItemEventArgs(T).ClassId Property

InstantiateItemEventArgs(T).ClassId Property
[image]

Gets the class identifier of the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ClassId { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassId As String

Property Value

A string that represents the class identifier.

See Also

InstantiateItemEventArgs(T) Members
InstantiateItemEventArgs(T) Class


MindFusion.Scheduling.InstantiateItemEventArgs(T).Item Property

InstantiateItemEventArgs(T).Item Property
[image]

Gets or sets the newly created item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public T Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As T

Property Value

A System.Object of type T.

See Also

InstantiateItemEventArgs(T) Members
InstantiateItemEventArgs(T) Class


MindFusion.Scheduling.InstantiateResourceEventArgs Class

InstantiateResourceEventArgs Class
[image]

Specifies data for the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class InstantiateResourceEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class InstantiateResourceEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateResourceEventArgs

See Also

InstantiateResourceEventArgs Members


MindFusion.Scheduling.InstantiateResourceEventArgs Members

InstantiateResourceEventArgs Members
Properties
[image]

Specifies data for the InstantiateResource event.

The following tables list the members exposed by the InstantiateResourceEventArgs type.

Public Properties

Name | Description
ClassId | Gets the class identifier of the resource.
Resource | Gets or sets the newly created resource.

See Also

InstantiateResourceEventArgs Class


MindFusion.Scheduling.InstantiateResourceEventArgs Properties

InstantiateResourceEventArgs Properties
[image]

Public Properties

Name | Description
ClassId | Gets the class identifier of the resource.
Resource | Gets or sets the newly created resource.

See Also

InstantiateResourceEventArgs Class


MindFusion.Scheduling.InstantiateResourceEventArgs.ClassId Property

InstantiateResourceEventArgs.ClassId Property
[image]

Gets the class identifier of the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ClassId { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassId As String

Property Value

A string that represents the class identifier.

See Also

InstantiateResourceEventArgs Members
InstantiateResourceEventArgs Class


MindFusion.Scheduling.InstantiateResourceEventArgs.Resource Property

InstantiateResourceEventArgs.Resource Property
[image]

Gets or sets the newly created resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Resource Resource { get; set; }

Visual Basic [image] Copy Code

Public Property Resource As Resource

Property Value

An instance of the Resource class.

See Also

InstantiateResourceEventArgs Members
InstantiateResourceEventArgs Class


MindFusion.Scheduling.Item Class

Item Class
Remarks See Also
[image]

Represents events scheduled to occur at a specified date and time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract class Item : ICloneable, IStateManager

Visual Basic [image] Copy Code

Public MustInherit Class Item
Implements ICloneable, IStateManager

Remarks

Base class for Appointment.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Item

See Also

Item Members


MindFusion.Scheduling.Item Members

Item Members
Constructors Properties Methods
[image]

Represents events scheduled to occur at a specified date and time.

The following tables list the members exposed by the Item type.

Protected Constructors

Name | Description
Item | Initializes a new instance of the Item class.

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the Item represents an all day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the item's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the item's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the item.
Contacts | Gets references to all contacts associated with this item.
CssClass | Gets or sets the css class of the appointment.
DescriptionText | Gets or sets the description rendered for this item by the scheduling control.
EndTime | Gets or sets the item's scheduled end time.
HeaderText | Gets or sets the text rendered in the header for this item by the scheduling control.
Id | Gets or sets the string identifier of this item.
IsTrackingViewState | Gets a value that indicates whether the Item is saving changes to its view state.
Location | Gets or sets the location associated with this item.
Locked | Gets or sets a value indicating whether users are forbidden to modify this item.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1.
Priority | Gets or sets the priority of the Item.
Recurrence | Gets or sets the recurrence pattern of this item.
RecurrenceState | Gets the recurrence state of this item.
Reminder | Gets or sets the reminder for this item.
Resources | Gets references to all resources associated with this item.
StartTime | Gets or sets the item's scheduled start time.
Style | Gets or sets a style associated with the item.
Tag | Gets or sets custom data associated with the item.
Task | Gets or sets the task associated with this item.
Visible | Gets or sets a flag indicating whether the item is visible or not.

Public Methods

Name | Description
Clone | Creates an exact copy of this item.
Equals | Object.Equals() override. Determines whether two Object instances are equal.
GetHashCode | Returns a hash code for this Item.
LoadFrom | Overloaded.
LoadViewState | Loads a ViewState. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Saves the ViewState. Saves any server side view-state changes that have occurred at this Item since the time the page was posted back to the server.
SetRecurrence | Sets the recurrence of the item.
TrackViewState | Tracks the ViewState. Causes tracking of view-state changes to this Item so they can be stored in a StateBag object.

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is generated in order to populate the property fields of the instance with values from the master item.
OnVisualsChanged | Raises the VisualsChanged event.

See Also

Item Class


MindFusion.Scheduling.Item Constructor

Item Constructor
[image]

Initializes a new instance of the Item class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected Item ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Item Class


MindFusion.Scheduling.Item Methods

Item Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this item.
Equals | Object.Equals() override. Determines whether two Object instances are equal.
GetHashCode | Returns a hash code for this Item.
LoadFrom | Overloaded.
LoadViewState | Loads a ViewState. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Saves the ViewState. Saves any server side view-state changes that have occurred at this Item since the time the page was posted back to the server.
SetRecurrence | Sets the recurrence of the item.
TrackViewState | Tracks the ViewState. Causes tracking of view-state changes to this Item so they can be stored in a StateBag object.

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is generated in order to populate the property fields of the instance with values from the master item.
OnVisualsChanged | Raises the VisualsChanged event.

See Also

Item Class


MindFusion.Scheduling.Item.Clone Method

Item.Clone Method
[image]

Creates an exact copy of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract Object Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

Type: Object
The newly created object identical to the current one.

Remarks

The clone of a recurring item is not an occurrence but an ordinary item. Aside from this, the clone is an exact duplicate of the original item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.CopyOccurrence Method

Item.CopyOccurrence Method
[image]

Called by the recurrence whenever a new occurrence is generated in order to populate the property fields of the instance with values from the master item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void CopyOccurrence (
Item master
)

Visual Basic [image] Copy Code

Protected Overridable Sub CopyOccurrence ( _
master As Item _
)

Parameters

master
Type: Item
An Item that represents the master.

Remarks

Override this method in classes that derive from Item or Appointment to populate any custom property fields of the instance with values from the master item. For more information on how to do that, see the Custom Items and Resources topic.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Equals Method

Item.Equals Method
[image]

Object.Equals() override. Determines whether two Object instances are equal.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
Type: Object
The item to compare to for equality.

Return Value

Type: Boolean
true if this Item is equal to obj; otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.GetHashCode Method

Item.GetHashCode Method
[image]

Returns a hash code for this Item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

Type: Int32
An integer that represents the hash code for the current Item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.LoadFrom Method

Item.LoadFrom Method
[image]

Overload List

Name | Description
Item.LoadFrom (BinaryReader, BinarySerializationContext) | Loads the data for this Item from a binary stream.
Item.LoadFrom (XmlElement, XmlSerializationContext) | Loads item data from an XML document.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.LoadFrom Method (BinaryReader, BinarySerializationContext)

Item.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also
[image]

Loads the data for this Item from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class that reads primitive data types from a binary stream.
context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

LoadFrom Method Overload List
Item Members
Item Class


MindFusion.Scheduling.Item.LoadFrom Method (XmlElement, XmlSerializationContext)

Item.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads item data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.Xml.XmlElement class that allows reading data from the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

LoadFrom Method Overload List
Item Members
Item Class


MindFusion.Scheduling.Item.LoadViewState Method

Item.LoadViewState Method
[image]

Loads a ViewState. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.OnVisualsChanged Method

Item.OnVisualsChanged Method
[image]

Raises the VisualsChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected void OnVisualsChanged ()

Visual Basic [image] Copy Code

Protected Sub OnVisualsChanged ()

Remarks

The VisualsChanged event notifies the control that the appearance of the item has changes and it is repainted. Call the method from your class to repaint an item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.SaveTo Method

Item.SaveTo Method
[image]

Overload List

Name | Description
Item.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the item data to a binary stream.
Item.SaveTo (XmlElement, XmlSerializationContext) | Saves the item data to an XML document.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.SaveTo Method (BinaryWriter, BinarySerializationContext)

Item.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also
[image]

Saves the item data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Type: BinaryWriter
A System.IO.BinaryWriter object that writes primitive data types to a binary stream.
context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

SaveTo Method Overload List
Item Members
Item Class


MindFusion.Scheduling.Item.SaveTo Method (XmlElement, XmlSerializationContext)

Item.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the item data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.Xml.XmlElement class that allows adding data to the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

SaveTo Method Overload List
Item Members
Item Class


MindFusion.Scheduling.Item.SaveViewState Method

Item.SaveViewState Method
[image]

Saves the ViewState. Saves any server side view-state changes that have occurred at this Item since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overridable Function SaveViewState () As Object

Return Value

Type: Object
Returns the Item's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.SetRecurrence Method

Item.SetRecurrence Method
[image]

Sets the recurrence of the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SetRecurrence (
Recurrence value
)

Visual Basic [image] Copy Code

Public Sub SetRecurrence ( _
value As Recurrence _
)

Parameters

value
Type: Recurrence
An instance of the Recurrence class.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.TrackViewState Method

Item.TrackViewState Method
[image]

Tracks the ViewState. Causes tracking of view-state changes to this Item so they can be stored in a StateBag object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void TrackViewState ()

Visual Basic [image] Copy Code

Public Overridable Sub TrackViewState ()

See Also

Item Members
Item Class


MindFusion.Scheduling.Item Properties

Item Properties
[image]

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the Item represents an all day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the item's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the item's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the item.
Contacts | Gets references to all contacts associated with this item.
CssClass | Gets or sets the css class of the appointment.
DescriptionText | Gets or sets the description rendered for this item by the scheduling control.
EndTime | Gets or sets the item's scheduled end time.
HeaderText | Gets or sets the text rendered in the header for this item by the scheduling control.
Id | Gets or sets the string identifier of this item.
IsTrackingViewState | Gets a value that indicates whether the Item is saving changes to its view state.
Location | Gets or sets the location associated with this item.
Locked | Gets or sets a value indicating whether users are forbidden to modify this item.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1.
Priority | Gets or sets the priority of the Item.
Recurrence | Gets or sets the recurrence pattern of this item.
RecurrenceState | Gets the recurrence state of this item.
Reminder | Gets or sets the reminder for this item.
Resources | Gets references to all resources associated with this item.
StartTime | Gets or sets the item's scheduled start time.
Style | Gets or sets a style associated with the item.
Tag | Gets or sets custom data associated with the item.
Task | Gets or sets the task associated with this item.
Visible | Gets or sets a flag indicating whether the item is visible or not.

See Also

Item Class


MindFusion.Scheduling.Item.AllDayEvent Property

Item.AllDayEvent Property
[image]

Gets or sets a value indicating whether the Item represents an all day event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract bool AllDayEvent { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property AllDayEvent As Boolean

Property Value

true if the Item is an all day event; otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.AllowChangeEnd Property

Item.AllowChangeEnd Property
[image]

Gets or sets a value indicating whether users are allowed to change the item's end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract bool AllowChangeEnd { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property AllowChangeEnd As Boolean

Property Value

true if the users are allowed to change the end DateTime; otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.AllowChangeStart Property

Item.AllowChangeStart Property
[image]

Gets or sets a value indicating whether users are allowed to change the item's start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract bool AllowChangeStart { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property AllowChangeStart As Boolean

Property Value

true if the users are allowed to change the start DateTime; otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.AllowMove Property

Item.AllowMove Property
[image]

Gets or sets a value indicating whether users are allowed to move the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract bool AllowMove { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property AllowMove As Boolean

Property Value

true if the users are allowed to move the Item; otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Contacts Property

Item.Contacts Property
[image]

Gets references to all contacts associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract ResourceCollection<Contact> Contacts { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Contacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection class that contains the Contact objects associated with this Item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.CssClass Property

Item.CssClass Property
[image]

Gets or sets the css class of the appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract string CssClass { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property CssClass As String

Property Value

A string with the name of the Css class.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.DescriptionText Property

Item.DescriptionText Property
[image]

Gets or sets the description rendered for this item by the scheduling control.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract string DescriptionText { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property DescriptionText As String

Property Value

A string with the description.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.EndTime Property

Item.EndTime Property
[image]

Gets or sets the item's scheduled end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract DateTime EndTime { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property EndTime As DateTime

Property Value

An instance of the System.DateTime structure.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.HeaderText Property

Item.HeaderText Property
[image]

Gets or sets the text rendered in the header for this item by the scheduling control.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract string HeaderText { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property HeaderText As String

Property Value

A string that specifies the header. Default value is an empty string ("").

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Id Property

Item.Id Property
[image]

Gets or sets the string identifier of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract string Id { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Id As String

Property Value

A string value that specifies the identifier.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.IsTrackingViewState Property

Item.IsTrackingViewState Property
[image]

Gets a value that indicates whether the Item is saving changes to its view state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

true if the Item saves changes; otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Location Property

Item.Location Property
[image]

Gets or sets the location associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract Location Location { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Location As Location

Property Value

An instance of the Location class.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Locked Property

Item.Locked Property
[image]

Gets or sets a value indicating whether users are forbidden to modify this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract bool Locked { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Locked As Boolean

Property Value

true if users are forbidden to modify the Item; otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.OccurrenceIndex Property

Item.OccurrenceIndex Property
[image]

Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int OccurrenceIndex { get; set; }

Visual Basic [image] Copy Code

Public Property OccurrenceIndex As Integer

Property Value

the zero based index of the recurrence of the Item; -1 if this is not a recurrent Item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Priority Property

Item.Priority Property
[image]

Gets or sets the priority of the Item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Priority { get; set; }

Visual Basic [image] Copy Code

Public Property Priority As Integer

Property Value

An integer that specifies the priority; default value is 0.

Remarks

Items with higher priority are rendered with preference over items with lower priority.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Recurrence Property

Item.Recurrence Property
[image]

Gets or sets the recurrence pattern of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Recurrence Recurrence { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Recurrence As Recurrence

Property Value

An instance of the Recurrence class.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.RecurrenceState Property

Item.RecurrenceState Property
[image]

Gets the recurrence state of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public RecurrenceState RecurrenceState { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceState As RecurrenceState

Property Value

One of the RecurrenceState enumeration values.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Reminder Property

Item.Reminder Property
[image]

Gets or sets the reminder for this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract Reminder Reminder { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Reminder As Reminder

Property Value

An instance of the Reminder class.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Resources Property

Item.Resources Property
[image]

Gets references to all resources associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract ResourceCollection<Resource> Resources { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Resources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection class that contains Resource objects associated with this Item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.StartTime Property

Item.StartTime Property
[image]

Gets or sets the item's scheduled start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract DateTime StartTime { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property StartTime As DateTime

Property Value

An instance of the System.DateTime class that specifies the start date and time of this Item.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Style Property

Item.Style Property
[image]

Gets or sets a style associated with the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract ItemStyle Style { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Style As ItemStyle

Property Value

An instance of the ItemStyle class.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Tag Property

Item.Tag Property
[image]

Gets or sets custom data associated with the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract Object Tag { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Tag As Object

Property Value

A System.Object instance that specifies the tag.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Task Property

Item.Task Property
[image]

Gets or sets the task associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract Task Task { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Task As Task

Property Value

An instance of the Task class.

See Also

Item Members
Item Class


MindFusion.Scheduling.Item.Visible Property

Item.Visible Property
[image]

Gets or sets a flag indicating whether the item is visible or not.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract bool Visible { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Visible As Boolean

Property Value

true if the Item is visible; otherwise false.

See Also

Item Members
Item Class


MindFusion.Scheduling.ItemCollection(T) Class

ItemCollection(T) Class
[image]

Represents a collection of Item objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ItemCollection<T> : StateCollection<T> where T : Item

Visual Basic [image] Copy Code

Public Class ItemCollection(Of T As Item)
Inherits StateCollection(Of T)

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.StateCollection(T)
MindFusion.Scheduling.ItemCollection(T)

See Also

ItemCollection(T) Members


MindFusion.Scheduling.ItemCollection(T) Members

ItemCollection(T) Members
Constructors Properties Methods Events
[image]

Represents a collection of Item objects.

The following tables list the members exposed by the ItemCollection(T) type.

Public Constructors

Name | Description
ItemCollection | Overloaded. Initializes a new instance of the ItemCollection class.

Public Properties

Name | Description
Item | Overloaded.

Inherited Public Properties

Name | Description
Count | Gets the count of items in the collection. (Inherited from StateCollection.)
IsReadOnly | Gets a value that indicates if the collection is read only. (Inherited from StateCollection.)
IsTrackingViewState | Gets a value that indicates whether the collection is saving changes to its view state. (Inherited from StateCollection.)
Item | Returns the item at the specified index. This is the indexer of the collection. (Inherited from StateCollection.)

Public Methods

Name | Description
Add | Adds the specified item to the collection.
AddRange | Adds the specified items to the collection.
Clear | Removes all elements from the collection.
Contains | Checks if the item with the specified id is within the bounds of this collection.
Insert | Inserts the specified item at the specified position in the collection.
Remove | Removes the first occurrence of the specified item from the collection.
RemoveAt | Removes the item at the specified index in the collection.

Protected Methods

Name | Description
LoadItemViewState | Restores view-state information from an object that was saved by the SaveItemViewState method.
SaveItemViewState | Saves any server control view-state changes that have occurred for the specified item.

Inherited Public Methods

Name | Description
Add | Adds a new item to the collection. (Inherited from StateCollection.)
Clear | Removes all items from the collection. (Inherited from StateCollection.)
Contains | Checks if the specified item is contained within the collection. (Inherited from StateCollection.)
CopyTo | Copies the elements of the collection to an array, starting from the particular Array index. (Inherited from StateCollection.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from StateCollection.)
IndexOf | Returns the index of the first occurrence of the specified item in the collection. (Inherited from StateCollection.)
Insert | Inserts the specified item into the array at the specified index. (Inherited from StateCollection.)
LoadViewState | Restores view-state information from an object that was saved by the SaveViewState method (Inherited from StateCollection.)
OnChanged | Raises the Changed event. (Inherited from StateCollection.)
Remove | Removes the specified item from the collection. (Inherited from StateCollection.)
RemoveAt | Removes the item at the specified index. (Inherited from StateCollection.)
SaveViewState | Saves any view-state changes that have occurred for this collection. (Inherited from StateCollection.)
TrackViewState | Causes tracking of view-state changes made to the collection so they can be stored in an object. (Inherited from StateCollection.)

Inherited Protected Methods

Name | Description
LoadItemViewState | Restores view-state information for the item that was previously saved by the SaveItemViewState method. (Inherited from StateCollection.)
OnAdd | Raises the Add event. (Inherited from StateCollection.)
OnAddComplete | Raises the AddComplete event. (Inherited from StateCollection.)
OnClear | Raises the Clear event. (Inherited from StateCollection.)
OnClearComplete | Raises the ClearComplete event. (Inherited from StateCollection.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from StateCollection.)
OnInsert | Raises the Insert event. (Inherited from StateCollection.)
OnInsertComplete | Raises the InsertComplete event. (Inherited from StateCollection.)
OnRemove | Raises the Remove event. (Inherited from StateCollection.)
OnRemoveComplete | Raises the RemoveComplete event. (Inherited from StateCollection.)
OnSet | Raises the Set event. (Inherited from StateCollection.)
OnSetComplete | Raises the SetComplete event. (Inherited from StateCollection.)
SaveItemViewState | Saves any view-state changes that have occurred of the specified item. (Inherited from StateCollection.)
TrackItemViewState | Causes tracking of view-state changes made to the specified item. (Inherited from StateCollection.)

Inherited Public Events

Name | Description
AddComplete | Declares the AddComplete event. (Inherited from StateCollection.)
AddEvent | Declares the Add event. (Inherited from StateCollection.)
Changed | Declares the Changed event. (Inherited from StateCollection.)
ClearComplete | Declares the ClearComplete event. (Inherited from StateCollection.)
ClearEvent | Declares the Clear event. (Inherited from StateCollection.)
CollectionChanged | Declares the CollectionChanged event. (Inherited from StateCollection.)
InsertComplete | Declares the InsertComplete event. (Inherited from StateCollection.)
InsertEvent | Declares the Insert event. (Inherited from StateCollection.)
RemoveComplete | Declares the RemoveComplete event. (Inherited from StateCollection.)
RemoveEvent | Declares the Remove event. (Inherited from StateCollection.)
SetComplete | Declares the SetComplete event. (Inherited from StateCollection.)
SetEvent | Declares the Set event. (Inherited from StateCollection.)

See Also

ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T) Constructor

ItemCollection(T) Constructor
[image]

Initializes a new instance of the ItemCollection class.

Overload List

Name | Description
ItemCollection(T) () | Initializes a new instance of the ItemCollection class.
ItemCollection(T) (IEnumerable(T)) | Initializes a new ItemCollection from the specified strongly-typed collection.
ItemCollection(T) (Int32) | Initializes a new ItemCollection with the specified capacity.

See Also

ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T) Constructor ()

ItemCollection(T) Constructor ()
See Also
[image]

Initializes a new instance of the ItemCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

ItemCollection(T) Constructor Overload List
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T) Constructor (IEnumerable(T))

ItemCollection(T) Constructor (IEnumerable(T))
See Also
[image]

Initializes a new ItemCollection from the specified strongly-typed collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<T> (
IEnumerable<T> collection
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
collection As IEnumerable(Of T) _
)

Parameters

collection

Type: IEnumerable(T)
The initial collection.

See Also

ItemCollection(T) Constructor Overload List
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T) Constructor (Int32)

ItemCollection(T) Constructor (Int32)
See Also
[image]

Initializes a new ItemCollection with the specified capacity.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<T> (
int capacity
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
capacity As Integer _
)

Parameters

capacity
Type: Int32
The initial capacity of the new ItemCollection.

See Also

ItemCollection(T) Constructor Overload List
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T) Methods

ItemCollection(T) Methods
[image]

Public Methods

Name | Description
Add | Adds the specified item to the collection.
AddRange | Adds the specified items to the collection.
Clear | Removes all elements from the collection.
Contains | Checks if the item with the specified id is within the bounds of this collection.
Insert | Inserts the specified item at the specified position in the collection.
Remove | Removes the first occurrence of the specified item from the collection.
RemoveAt | Removes the item at the specified index in the collection.

Protected Methods

Name | Description
LoadItemViewState | Restores view-state information from an object that was saved by the SaveItemViewState method.
SaveItemViewState | Saves any server control view-state changes that have occurred for the specified item.

Inherited Public Methods

Name | Description
Add | Adds a new item to the collection. (Inherited from StateCollection.)
Clear | Removes all items from the collection. (Inherited from StateCollection.)
Contains | Checks if the specified item is contained within the collection. (Inherited from StateCollection.)
CopyTo | Copies the elements of the collection to an array, starting from the particular Array index. (Inherited from StateCollection.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from StateCollection.)
IndexOf | Returns the index of the first occurrence of the specified item in the collection. (Inherited from StateCollection.)
Insert | Inserts the specified item into the array at the specified index. (Inherited from StateCollection.)
LoadViewState | Restores view-state information from an object that was saved by the SaveViewState method (Inherited from StateCollection.)
OnChanged | Raises the Changed event. (Inherited from StateCollection.)
Remove | Removes the specified item from the collection. (Inherited from StateCollection.)
RemoveAt | Removes the item at the specified index. (Inherited from StateCollection.)
SaveViewState | Saves any view-state changes that have occurred for this collection. (Inherited from StateCollection.)
TrackViewState | Causes tracking of view-state changes made to the collection so they can be stored in an object. (Inherited from StateCollection.)

Inherited Protected Methods

Name | Description
LoadItemViewState | Restores view-state information for the item that was previously saved by the SaveItemViewState method. (Inherited from StateCollection.)
OnAdd | Raises the Add event. (Inherited from StateCollection.)
OnAddComplete | Raises the AddComplete event. (Inherited from StateCollection.)
OnClear | Raises the Clear event. (Inherited from StateCollection.)
OnClearComplete | Raises the ClearComplete event. (Inherited from StateCollection.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from StateCollection.)
OnInsert | Raises the Insert event. (Inherited from StateCollection.)
OnInsertComplete | Raises the InsertComplete event. (Inherited from StateCollection.)
OnRemove | Raises the Remove event. (Inherited from StateCollection.)
OnRemoveComplete | Raises the RemoveComplete event. (Inherited from StateCollection.)
OnSet | Raises the Set event. (Inherited from StateCollection.)
OnSetComplete | Raises the SetComplete event. (Inherited from StateCollection.)
SaveItemViewState | Saves any view-state changes that have occurred of the specified item. (Inherited from StateCollection.)
TrackItemViewState | Causes tracking of view-state changes made to the specified item. (Inherited from StateCollection.)

See Also

ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).Add Method

ItemCollection(T).Add Method
[image]

Adds the specified item to the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void Add (
T item
)

Visual Basic [image] Copy Code

Public Overrides Sub Add( _
item As T _
)

Parameters

item

Type: T
The item to add.

See Also

ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).AddRange Method

ItemCollection(T).AddRange Method
[image]

Adds the specified items to the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void AddRange (
ItemCollection<T> items
)

Visual Basic [image] Copy Code

Public Sub AddRange( _
items As ItemCollection(Of T) _
)

Parameters

items

Type: ItemCollection(T)
A collection of items to add.

See Also

ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).Clear Method

ItemCollection(T).Clear Method
[image]

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void Clear ()

Visual Basic [image] Copy Code

Public Overrides Sub Clear ()

See Also

ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).Contains Method

ItemCollection(T).Contains Method
[image]

Checks if the item with the specified id is within the bounds of this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool Contains (
string id
)

Visual Basic [image] Copy Code

Public Function Contains( _
id As String _
) As Boolean

Parameters

id

Type: String
The identifier of the item to search for in the collection.

Return Value

true if the item is found; otherwise false.

See Also

ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).Insert Method

ItemCollection(T).Insert Method
[image]

Inserts the specified item at the specified position in the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void Insert (
int index,
T item
)

Visual Basic [image] Copy Code

Public Overrides Sub Insert( _
index As Integer, _
item As T _
)

Parameters

index

Type: Int32
The zero-based index at which the item must be inserted.

item
Type: T
The item to insert.

See Also

ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).LoadItemViewState Method

ItemCollection(T).LoadItemViewState Method
[image]

Restores view-state information from an object that was saved by the SaveItemViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void LoadItemViewState (
Object state
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadItemViewState( _
state As Object _
)

Parameters

state

Type: Object
The state to load.

See Also

ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).Remove Method

ItemCollection(T).Remove Method
[image]

Removes the first occurrence of the specified item from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool Remove (
T item
)

Visual Basic [image] Copy Code

Public Overrides Function Remove( _
item As T _
) As Boolean

Parameters

item

Type: T
The item to remove.

Return Value

Type: Boolean
true if the item was successfully removed; false otherwise.

See Also

ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).RemoveAt Method

ItemCollection(T).RemoveAt Method
[image]

Removes the item at the specified index in the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overrides Sub RemoveAt( _
index As Integer _
)

Parameters

index

Type: Int32
The zero-based index of the item to remove.

See Also

ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).SaveItemViewState Method

ItemCollection(T).SaveItemViewState Method
[image]

Saves any server control view-state changes that have occurred for the specified item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override Object SaveItemViewState (
T item
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveItemViewState( _
item As T _
) As Object

Parameters

item

Type: T
The item whose changes are saved.

Return Value

Type: Object
An object that holds any view-state changes that have occurred.

See Also

ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T) Properties

ItemCollection(T) Properties
[image]

Public Properties

Name | Description
Item | Overloaded.

Inherited Public Properties

Name | Description
Count | Gets the count of items in the collection. (Inherited from StateCollection.)
IsReadOnly | Gets a value that indicates if the collection is read only. (Inherited from StateCollection.)
IsTrackingViewState | Gets a value that indicates whether the collection is saving changes to its view state. (Inherited from StateCollection.)
Item | Returns the item at the specified index. This is the indexer of the collection. (Inherited from StateCollection.)

See Also

ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).Item Property

ItemCollection(T).Item Property
[image]

Overload List

Name | Description
ItemCollection(T).Item (Int32) | Gets or sets the item located at the specified position within this collection.
ItemCollection(T).Item (String) | Gets the item identified by the specified string.

See Also

ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).Item Property (Int32)

ItemCollection(T).Item Property (Int32)
See Also
[image]

Gets or sets the item located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override T Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Item( _
index As Integer _
) As T

Parameters

index
Type: Int32
The zero based index in the collection.

Property Value

Type: T
The item located at the specified position in the collection.

See Also

Item Property Overload List
ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemCollection(T).Item Property (String)

ItemCollection(T).Item Property (String)
See Also
[image]

Gets the item identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public T Item [
string id
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
id As String _
) As T

Parameters

id
Type: String
A string that specifies the identifier of the item.

Property Value

Type: T
The item with the specified id.

See Also

Item Property Overload List
ItemCollection(T) Members
ItemCollection(T) Class


MindFusion.Scheduling.ItemEventArgs Class

ItemEventArgs Class
[image]

Provides data for item related events.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs

See Also

ItemEventArgs Members


MindFusion.Scheduling.ItemEventArgs Members

ItemEventArgs Members
Constructors Properties
[image]

Provides data for item related events.

The following tables list the members exposed by the ItemEventArgs type.

Public Constructors

Name | Description
ItemEventArgs | Initializes a new instance of the ItemEventArgs class.

Public Properties

Name | Description
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class


MindFusion.Scheduling.ItemEventArgs Constructor

ItemEventArgs Constructor
[image]

Initializes a new instance of the ItemEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemEventArgs (
Item item
)

Visual Basic [image] Copy Code

Public New ( _
item As Item _
)

Parameters

item
Type: Item
The Item for which the event is raised.

See Also

ItemEventArgs Class


MindFusion.Scheduling.ItemEventArgs Properties

ItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class


MindFusion.Scheduling.ItemEventArgs.Item Property

ItemEventArgs.Item Property
[image]

Gets the item for which the event is raised.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class.

See Also

ItemEventArgs Members
ItemEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs Class

ItemModifiedEventArgs Class
[image]

Specifies data for the ItemModified event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ItemModifiedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ItemModifiedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemModifiedEventArgs

See Also

ItemModifiedEventArgs Members


MindFusion.Scheduling.ItemModifiedEventArgs Members

ItemModifiedEventArgs Members
Constructors Properties
[image]

Specifies data for the ItemModified event.

The following tables list the members exposed by the ItemModifiedEventArgs type.

Public Constructors

Name | Description
ItemModifiedEventArgs | Initializes a new instance of the ItemModifiedEventArgs class.

Public Properties

Name | Description
Action | Gets the type of action that has modified the item.
Item | Gets the item that was modified.
OldItem | Gets the item before the modification has occurred.

See Also

ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs Constructor

ItemModifiedEventArgs Constructor
[image]

Initializes a new instance of the ItemModifiedEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemModifiedEventArgs (
Item item,
Item oldItem,
ItemModifyAction action
)

Visual Basic [image] Copy Code

Public New ( _
item As Item, _
oldItem As Item, _
action As ItemModifyAction _
)

Parameters

item
Type: Item
The new item.
oldItem
Type: Item
The old item.
action
Type: ItemModifyAction
The action that has modified the item.

See Also

ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs Properties

ItemModifiedEventArgs Properties
[image]

Public Properties

Name | Description
Action | Gets the type of action that has modified the item.
Item | Gets the item that was modified.
OldItem | Gets the item before the modification has occurred.

See Also

ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs.Action Property

ItemModifiedEventArgs.Action Property
[image]

Gets the type of action that has modified the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemModifyAction Action { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Action As ItemModifyAction

Property Value

One of the ItemModifyAction enumeration values.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs.Item Property

ItemModifiedEventArgs.Item Property
[image]

Gets the item that was modified.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemModifiedEventArgs.OldItem Property

ItemModifiedEventArgs.OldItem Property
[image]

Gets the item before the modification has occurred.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Item OldItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldItem As Item

Property Value

An instance of the Item class.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.ItemStyle Class

ItemStyle Class
[image]

Specifies the appearance of calendar items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ItemStyle : HeaderStyle

Visual Basic [image] Copy Code

Public Class ItemStyle
Inherits HeaderStyle

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Style
MindFusion.Scheduling.HeaderStyle
MindFusion.Scheduling.ItemStyle

See Also

ItemStyle Members


MindFusion.Scheduling.ItemStyle Members

ItemStyle Members
Constructors Properties Methods Events
[image]

Specifies the appearance of calendar items.

The following tables list the members exposed by the ItemStyle type.

Public Constructors

Name | Description
ItemStyle | Overloaded.

Public Properties

Name | Description
FillColor | Gets or sets the color used to paint elements, not part of the main item structure.
HeaderFont | Gets the font in the item's header.
HeaderTextAlignment | Gets or sets the alignment of text in the item's header.
HeaderTextColor | Gets or sets the color of the text in the item's header.
HeaderTextMargins | Gets the text margins in the item's header.
LineColor | Gets or sets the color used when lines not part of an element border are painted.

Inherited Public Properties

Name | Description
Borders | Gets the border properties for the current Style object. (Inherited from Style.)
Brush | Gets or sets the brush that fills the interior. (Inherited from Style.)
Font | Gets the font in header elements. (Inherited from HeaderStyle.)
IsTrackingViewState | Gets a value that indicates whether the Style object is saving changes to its view state. (Inherited from Style.)
TextAlignment | Gets or sets the alignment of text in header elements. (Inherited from HeaderStyle.)
TextColor | Gets or sets the color of the text in header elements. (Inherited from HeaderStyle.)
TextMargins | Gets the text margins in header elements. (Inherited from HeaderStyle.)

Public Methods

Name | Description
Clone | Creates an exact copy of the current ItemStyle object.
GetProperties | Gets the properties of this ItemStyle class as IDictionary<string, object> list.
LoadViewState | Restores view-state information from an object that was previously saved by the SaveViewState method.
Reset | Removes any style elements written in the state bag.
SaveViewState | Saves any view-state changes that have occurred on the ItemStyle object.
SetProperties | Copies the values for the properties of this ItemStyle object from the specified IDictionary<string, object> object.
ShouldSerialize | Gets a value that indicates whether this ItemStyle object has changed from its default state.
TrackViewState | Causes tracking of view-state changes to the current ItemStyle object so they can be stored for later use.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of the current HeaderStyle object. (Inherited from HeaderStyle.)
Equals | Determines whether the specified Style object is equivalent to the current one. (Inherited from Style.)
GetHashCode | Returns the hash code for this Style instance. (Inherited from Style.)
GetProperties | Gets the properties of this HeaderStyle instance as IDictionary<string, object> list. (Inherited from HeaderStyle.)
LoadViewState | Restores view-state information from an object that was previously saved by the SaveViewState method. (Inherited from HeaderStyle.)
OnChanged | Raises the Changed event. (Inherited from Style.)
Reset | Removes any style elements written in the state bag. (Inherited from HeaderStyle.)
SaveViewState | Saves any view-state changes that have occurred on the HeaderStyle object. (Inherited from HeaderStyle.)
SetProperties | Copies the values for the properties of this HeaderStyle object from the specified IDictionary<string, object> object. (Inherited from HeaderStyle.)
ShouldSerialize | Gets a value that indicates whether this HeaderStyle object has changed from its default state. (Inherited from HeaderStyle.)
TrackViewState | Causes tracking of view-state changes to the current HeaderStyle object so they can be stored for later use. (Inherited from HeaderStyle.)

Inherited Public Events

Name | Description
Changed | Raised when the Style changes. (Inherited from Style.)

See Also

ItemStyle Class


MindFusion.Scheduling.ItemStyle Constructor

ItemStyle Constructor
[image]

Overload List

Name | Description
ItemStyle () | Initializes a new instance of the ItemStyle class.
ItemStyle (StateBag) | Initializes a new instance of the ItemStyle class with property values taken from the specified StateBag object.

See Also

ItemStyle Class


MindFusion.Scheduling.ItemStyle Constructor ()

ItemStyle Constructor ()
See Also
[image]

Initializes a new instance of the ItemStyle class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ItemStyle Constructor Overload List
ItemStyle Class


MindFusion.Scheduling.ItemStyle Constructor (StateBag)

ItemStyle Constructor (StateBag)
See Also
[image]

Initializes a new instance of the ItemStyle class with property values taken from the specified StateBag object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemStyle (
StateBag bag
)

Visual Basic [image] Copy Code

Public New ( _
bag As StateBag _
)

Parameters

bag

Type: StateBag
A System.Web.UI.StateBag object that provides values for the ItemStyle properties.

See Also

ItemStyle Constructor Overload List
ItemStyle Class


MindFusion.Scheduling.ItemStyle Methods

ItemStyle Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of the current ItemStyle object.
GetProperties | Gets the properties of this ItemStyle class as IDictionary<string, object> list.
LoadViewState | Restores view-state information from an object that was previously saved by the SaveViewState method.
Reset | Removes any style elements written in the state bag.
SaveViewState | Saves any view-state changes that have occurred on the ItemStyle object.
SetProperties | Copies the values for the properties of this ItemStyle object from the specified IDictionary<string, object> object.
ShouldSerialize | Gets a value that indicates whether this ItemStyle object has changed from its default state.
TrackViewState | Causes tracking of view-state changes to the current ItemStyle object so they can be stored for later use.

Inherited Public Methods

Name | Description
Clone | Creates an exact copy of the current HeaderStyle object. (Inherited from HeaderStyle.)
Equals | Determines whether the specified Style object is equivalent to the current one. (Inherited from Style.)
GetHashCode | Returns the hash code for this Style instance. (Inherited from Style.)
GetProperties | Gets the properties of this HeaderStyle instance as IDictionary<string, object> list. (Inherited from HeaderStyle.)
LoadViewState | Restores view-state information from an object that was previously saved by the SaveViewState method. (Inherited from HeaderStyle.)
OnChanged | Raises the Changed event. (Inherited from Style.)
Reset | Removes any style elements written in the state bag. (Inherited from HeaderStyle.)
SaveViewState | Saves any view-state changes that have occurred on the HeaderStyle object. (Inherited from HeaderStyle.)
SetProperties | Copies the values for the properties of this HeaderStyle object from the specified IDictionary<string, object> object. (Inherited from HeaderStyle.)
ShouldSerialize | Gets a value that indicates whether this HeaderStyle object has changed from its default state. (Inherited from HeaderStyle.)
TrackViewState | Causes tracking of view-state changes to the current HeaderStyle object so they can be stored for later use. (Inherited from HeaderStyle.)

See Also

ItemStyle Class


MindFusion.Scheduling.ItemStyle.Clone Method

ItemStyle.Clone Method
[image]

Creates an exact copy of the current ItemStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override object Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

Type: Object
The newly created copy of the current ItemStyle instance.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.GetProperties Method

ItemStyle.GetProperties Method
[image]

Gets the properties of this ItemStyle class as IDictionary<string, object> list.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override IDictionary<string, object> GetProperties ()

Visual Basic [image] Copy Code

Public Overrides Function GetProperties () As IDictionary(Of String, Object)

Return Value

Type: IDictionary(String, Object)
An IDictionary<string, object> list that holds the name of each property and its value.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.LoadViewState Method

ItemStyle.LoadViewState Method
[image]

Restores view-state information from an object that was previously saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state

Type: Object
A System.Object that represents the control state to be restored.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.Reset Method

ItemStyle.Reset Method
[image]

Removes any style elements written in the state bag.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void Reset ()

Visual Basic [image] Copy Code

Public Overrides Sub Reset ()

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.SaveViewState Method

ItemStyle.SaveViewState Method
[image]

Saves any view-state changes that have occurred on the ItemStyle object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns a System.Object with the current view state. If there is no view state associated with the ItemStyle, this method returns null (Nothing in VB.NET).

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.SetProperties Method

ItemStyle.SetProperties Method
[image]

Copies the values for the properties of this ItemStyle object from the specified IDictionary<string, object> object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void SetProperties (
IDictionary<string, object> dictionary
)

Visual Basic [image] Copy Code

Public Overrides Sub SetProperties( _
dictionary As IDictionary(Of String, Object) _
)

Parameters

dictionary

Type: IDictionary(String, Object)
An IDictionary<string, object> list that contains <property value> pairs.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.ShouldSerialize Method

ItemStyle.ShouldSerialize Method
[image]

Gets a value that indicates whether this ItemStyle object has changed from its default state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool ShouldSerialize ()

Visual Basic [image] Copy Code

Public Overrides Function ShouldSerialize () As Boolean

Return Value

Type: Boolean
true if the ItemStyle has changed; otherwise false.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.TrackViewState Method

ItemStyle.TrackViewState Method
[image]

Causes tracking of view-state changes to the current ItemStyle object so they can be stored for later use.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle Properties

ItemStyle Properties
[image]

Public Properties

Name | Description
FillColor | Gets or sets the color used to paint elements, not part of the main item structure.
HeaderFont | Gets the font in the item's header.
HeaderTextAlignment | Gets or sets the alignment of text in the item's header.
HeaderTextColor | Gets or sets the color of the text in the item's header.
HeaderTextMargins | Gets the text margins in the item's header.
LineColor | Gets or sets the color used when lines not part of an element border are painted.

Inherited Public Properties

Name | Description
Borders | Gets the border properties for the current Style object. (Inherited from Style.)
Brush | Gets or sets the brush that fills the interior. (Inherited from Style.)
Font | Gets the font in header elements. (Inherited from HeaderStyle.)
IsTrackingViewState | Gets a value that indicates whether the Style object is saving changes to its view state. (Inherited from Style.)
TextAlignment | Gets or sets the alignment of text in header elements. (Inherited from HeaderStyle.)
TextColor | Gets or sets the color of the text in header elements. (Inherited from HeaderStyle.)
TextMargins | Gets the text margins in header elements. (Inherited from HeaderStyle.)

See Also

ItemStyle Class


MindFusion.Scheduling.ItemStyle.FillColor Property

ItemStyle.FillColor Property
[image]

Gets or sets the color used to paint elements, not part of the main item structure.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Color FillColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property FillColor As Color

Property Value

An instance of the System.Drawing.Color structure.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.HeaderFont Property

ItemStyle.HeaderFont Property
[image]

Gets the font in the item's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual FontInfo HeaderFont { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property HeaderFont As FontInfo

Property Value

An instance of the System.Web.UI.WebControls.FontInfo class.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.HeaderTextAlignment Property

ItemStyle.HeaderTextAlignment Property
[image]

Gets or sets the alignment of text in the item's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual TextAlignment HeaderTextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property HeaderTextAlignment As TextAlignment

Property Value

An instance of the TextAlignment enumeration.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.HeaderTextColor Property

ItemStyle.HeaderTextColor Property
[image]

Gets or sets the color of the text in the item's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Color HeaderTextColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property HeaderTextColor As Color

Property Value

An instance of the System.Drawing.Color structure.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.HeaderTextMargins Property

ItemStyle.HeaderTextMargins Property
[image]

Gets the text margins in the item's header.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Thickness HeaderTextMargins { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property HeaderTextMargins As Thickness

Property Value

An instance of the Thickness class.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemStyle.LineColor Property

ItemStyle.LineColor Property
[image]

Gets or sets the color used when lines not part of an element border are painted.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Color LineColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LineColor As Color

Property Value

An instance of the System.Drawing.Color structure.

See Also

ItemStyle Members
ItemStyle Class


MindFusion.Scheduling.ItemTimeEventArgs Class

ItemTimeEventArgs Class
[image]

Specifies data for time related events.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ItemTimeEventArgs : ItemEventArgs

Visual Basic [image] Copy Code

Public Class ItemTimeEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.ItemTimeEventArgs

See Also

ItemTimeEventArgs Members


MindFusion.Scheduling.ItemTimeEventArgs Members

ItemTimeEventArgs Members
Properties Methods
[image]

Specifies data for time related events.

The following tables list the members exposed by the ItemTimeEventArgs type.

Public Properties

Name | Description
Time | Gets the old value of the time property that has changed.

Inherited Public Methods

Name | Description
get_item | Gets the item associated with the event. (Inherited from ItemEventArgs.)

See Also

ItemTimeEventArgs Class


MindFusion.Scheduling.ItemTimeEventArgs Properties

ItemTimeEventArgs Properties
[image]

Public Properties

Name | Description
Time | Gets the old value of the time property that has changed.

See Also

ItemTimeEventArgs Class


MindFusion.Scheduling.ItemTimeEventArgs.Time Property

ItemTimeEventArgs.Time Property
[image]

Gets the old value of the time property that has changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime Time { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Time As DateTime

Property Value

An instance of the System.DateTime structure.

See Also

ItemTimeEventArgs Members
ItemTimeEventArgs Class


MindFusion.Scheduling.Location Class

Location Class
Remarks See Also
[image]

Specifies data that identifies a location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class Location : Resource

Visual Basic [image] Copy Code

Public Class Location
Inherits Resource

Remarks

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Location

See Also

Location Members


MindFusion.Scheduling.Location Members

Location Members
Constructors Properties Methods
[image]

Specifies data that identifies a location.

The following tables list the members exposed by the Location type.

Public Constructors

Name | Description
Location | Initializes a new instance of the Location class.

Public Properties

Name | Description
Address | Gets or sets the address of the location.
City | Gets or sets the city of this location.
Country | Gets or sets the country of this location.
State | Gets or sets the state of this location.
ZipCode | Gets or sets the zip-code of this location.

Public Methods

Name | Description
LoadFrom | Overloaded.
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Saves any server control view-state changes that have occurred for this Location since the time the page was posted back to the server.
ToString | Overloaded.

Inherited Public Methods

Name | Description
getId | Gets the id of the resource. (Inherited from Resource.)
getName | Gets the name of the resource. (Inherited from Resource.)
getTag | Gets the custom data associated with the resource. (Inherited from Resource.)

See Also

Location Class


MindFusion.Scheduling.Location Constructor

Location Constructor
[image]

Initializes a new instance of the Location class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Location ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Location Class


MindFusion.Scheduling.Location Methods

Location Methods
[image]

Public Methods

Name | Description
LoadFrom | Overloaded.
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Saves any server control view-state changes that have occurred for this Location since the time the page was posted back to the server.
ToString | Overloaded.

Inherited Public Methods

Name | Description
getId | Gets the id of the resource. (Inherited from Resource.)
getName | Gets the name of the resource. (Inherited from Resource.)
getTag | Gets the custom data associated with the resource. (Inherited from Resource.)

See Also

Location Class


MindFusion.Scheduling.Location.LoadFrom Method

Location.LoadFrom Method
[image]

Overload List

Name | Description
Location.LoadFrom (BinaryReader, BinarySerializationContext) | Loads location data from a binary stream.
Location.LoadFrom (XmlElement, XmlSerializationContext) | Loads location data from an XML document.

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.LoadFrom Method (BinaryReader, BinarySerializationContext)

Location.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also
[image]

Loads location data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class that allows reading primitive data types from the binary stream.
context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

LoadFrom Method Overload List
Location Members
Location Class


MindFusion.Scheduling.Location.LoadFrom Method (XmlElement, XmlSerializationContext)

Location.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads location data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
A System.Xml.XmlElement object that allows reading data from the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

LoadFrom Method Overload List
Location Members
Location Class


MindFusion.Scheduling.Location.LoadViewState Method

Location.LoadViewState Method
[image]

Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.SaveTo Method

Location.SaveTo Method
[image]

Overload List

Name | Description
Location.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the location data to a binary stream.
Location.SaveTo (XmlElement, XmlSerializationContext) | Saves the location data to an XML document.

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.SaveTo Method (BinaryWriter, BinarySerializationContext)

Location.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also
[image]

Saves the location data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class that allows writing primitive data types to the binary stream.
context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

See Also

SaveTo Method Overload List
Location Members
Location Class


MindFusion.Scheduling.Location.SaveTo Method (XmlElement, XmlSerializationContext)

Location.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the location data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.Xml.XmlElement class that allows adding data to the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

SaveTo Method Overload List
Location Members
Location Class


MindFusion.Scheduling.Location.SaveViewState Method

Location.SaveViewState Method
[image]

Saves any server control view-state changes that have occurred for this Location since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
The System.Object that contains the view state changes. Returns the System.Object that represents the current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.ToString Method

Location.ToString Method
[image]

Overload List

Name | Description
Location.ToString () | Returns a string representation of this Location.
Location.ToString (IFormatProvider) | Gets a string representation of this Location with the specified format.

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.ToString Method ()

Location.ToString Method ()
See Also
[image]

Returns a string representation of this Location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual string ToString ()

Visual Basic [image] Copy Code

Public Overridable Function ToString () As String

Return Value

Type: String
A string that describes the Location.

See Also

ToString Method Overload List
Location Members
Location Class


MindFusion.Scheduling.Location.ToString Method (IFormatProvider)

Location.ToString Method (IFormatProvider)
See Also
[image]

Gets a string representation of this Location with the specified format.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override string ToString (
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Overrides Function ToString( _
provider As IFormatProvider _
) As String

Parameters

provider
Type: IFormatProvider
A System.IFormatProvider that specifies the format of the string.

Return Value

Type: String
A string that represents this Location object.

See Also

ToString Method Overload List
Location Members
Location Class


MindFusion.Scheduling.Location Properties

Location Properties
[image]

Public Properties

Name | Description
Address | Gets or sets the address of the location.
City | Gets or sets the city of this location.
Country | Gets or sets the country of this location.
State | Gets or sets the state of this location.
ZipCode | Gets or sets the zip-code of this location.

See Also

Location Class


MindFusion.Scheduling.Location.Address Property

Location.Address Property
[image]

Gets or sets the address of the location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Address { get; set; }

Visual Basic [image] Copy Code

Public Property Address As String

Property Value

A string that represents the location's address. Default value is an empty string ("").

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.City Property

Location.City Property
[image]

Gets or sets the city of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string City { get; set; }

Visual Basic [image] Copy Code

Public Property City As String

Property Value

A string that represents the location's city. Default value is an empty string ("").

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.Country Property

Location.Country Property
[image]

Gets or sets the country of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Country { get; set; }

Visual Basic [image] Copy Code

Public Property Country As String

Property Value

A string that represents the location's country. Default value is an empty string ("").

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.State Property

Location.State Property
[image]

Gets or sets the state of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string State { get; set; }

Visual Basic [image] Copy Code

Public Property State As String

Property Value

A string that represents the location's state. Default value is an empty string ("").

See Also

Location Members
Location Class


MindFusion.Scheduling.Location.ZipCode Property

Location.ZipCode Property
[image]

Gets or sets the zip-code of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ZipCode { get; set; }

Visual Basic [image] Copy Code

Public Property ZipCode As String

Property Value

A string that represents the location's zip-code. Default value is an empty string ("").

See Also

Location Members
Location Class


MindFusion.Scheduling.MonthlyRecurrence Enumeration

MonthlyRecurrence Enumeration
[image]

Specifies the types of various monthly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum MonthlyRecurrence

Visual Basic [image] Copy Code

Public Enum MonthlyRecurrence

Members

Member name | Value | Description
ByDayNumber | 0 | The event occurs on the given day of the month.
ByDayType | 1 | The event occurs on a given type of day in the specified week of the month.

See Also


MindFusion.Scheduling.Occurrence Enumeration

Occurrence Enumeration
[image]

Specifies the index of occurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum Occurrence

Visual Basic [image] Copy Code

Public Enum Occurrence

Members

Member name | Value | Description
First | 0 | Indicates the first occurrence.
Second | 1 | Indicates the second occurrence.
Third | 2 | Indicates the third occurrence.
Fourth | 3 | Indicates the fourth occurrence.
Last | 4 | Indicates the last occurrence.

See Also


MindFusion.Scheduling.Recurrence Class

Recurrence Class
[image]

Defines recurrence patterns for items scheduled to repeat over and over again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class Recurrence : ICloneable, IStateManager

Visual Basic [image] Copy Code

Public Class Recurrence
Implements ICloneable, IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Recurrence

See Also

Recurrence Members


MindFusion.Scheduling.Recurrence Members

Recurrence Members
Constructors Properties Methods
[image]

Defines recurrence patterns for items scheduled to repeat over and over again.

The following tables list the members exposed by the Recurrence type.

Public Constructors

Name | Description
Recurrence | Initializes a new instance of the Recurrence class.

Public Properties

Name | Description
DailyRecurrence | Gets or sets the type of daily recurrence.
Day | Gets or sets a value indicating the day of the week when the event occurs.
DayOfMonth | Gets or sets the day of the month when the event occurs.
Days | Gets or sets the number of days between two consecutive occurrences of the same event.
DaysOfWeek | Gets or sets the days of the week when the event occurs.
EndDate | Gets or sets the end date of the recurrence.
Exceptions | Gets a list with all Recurrence exceptions.
Interval | Gets or sets the interval of recurrence.
IsTrackingViewState | Gets a value that indicates whether changes to the view state are saved.
Master | Gets the master Item for the recurrence.
MonthlyRecurrence | Gets or sets the type of monthly recurrence.
MonthOfYear | Gets or sets the month of the year when the event occurs.
Months | Gets or sets the number of months between two consecutive occurrences of the same event.
NumOccurrences | Gets or sets how many times a recurring event should occur.
Occurrence | Gets or sets on which occurrence of the week within the month the event occurs.
Pattern | Gets or sets the pattern of recurrence.
RecurrenceEnd | Gets or sets the last time when the event occurs.
StartDate | Gets or sets the date and time of the event's first occurrence.
Weeks | Gets or sets the number of weeks between two consecutive occurrences of the event.
YearlyRecurrence | Gets or sets the type of yearly recurrence.

Protected Properties

Name | Description
ViewState | Gets or sets the ViewState of this Recurrence.

Public Methods

Name | Description
ApplyPattern | Copies the property values of the specified Recurrence object as values for the properties of this Recurrence object.
ClearExceptions | Removes all exceptions of this Recurrence.
Clone | Creates an exact copy of this Recurrence object.
GenerateItems | Creates occurrence items for this Recurrence in the specified date range.
GetEndDate | Returns the end date for this recurrence.
GetOccurrence | Overloaded.
LoadFrom | Overloaded.
LoadViewState | Restores view-state information that was saved by the SaveViewState method.
MarkException | Marks the specified item as an exception in the Recurrence pattern.
SamePatternAs | Determines whether two Recurrence objects define the same recurrence pattern.
SaveTo | Overloaded.
SaveViewState | Saves any server side view-state changes that have occurred on this Recurrence item.
ToLocalizedString | Returns a localized string that represents this Recurrence using the specified date and time formatting info and localization information.
ToString | Overloaded.
TrackViewState | Causes tracking of view-state changes to this Recurrence.

See Also

Recurrence Class


MindFusion.Scheduling.Recurrence Constructor

Recurrence Constructor
[image]

Initializes a new instance of the Recurrence class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Recurrence ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Recurrence Class


MindFusion.Scheduling.Recurrence Methods

Recurrence Methods
[image]

Public Methods

Name | Description
ApplyPattern | Copies the property values of the specified Recurrence object as values for the properties of this Recurrence object.
ClearExceptions | Removes all exceptions of this Recurrence.
Clone | Creates an exact copy of this Recurrence object.
GenerateItems | Creates occurrence items for this Recurrence in the specified date range.
GetEndDate | Returns the end date for this recurrence.
GetOccurrence | Overloaded.
LoadFrom | Overloaded.
LoadViewState | Restores view-state information that was saved by the SaveViewState method.
MarkException | Marks the specified item as an exception in the Recurrence pattern.
SamePatternAs | Determines whether two Recurrence objects define the same recurrence pattern.
SaveTo | Overloaded.
SaveViewState | Saves any server side view-state changes that have occurred on this Recurrence item.
ToLocalizedString | Returns a localized string that represents this Recurrence using the specified date and time formatting info and localization information.
ToString | Overloaded.
TrackViewState | Causes tracking of view-state changes to this Recurrence.

See Also

Recurrence Class


MindFusion.Scheduling.Recurrence.ApplyPattern Method

Recurrence.ApplyPattern Method
[image]

Copies the property values of the specified Recurrence object as values for the properties of this Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void ApplyPattern (
Recurrence recurrence
)

Visual Basic [image] Copy Code

Public Sub ApplyPattern ( _
recurrence As Recurrence _
)

Parameters

recurrence
Type: Recurrence
The Recurrence object which fields to copy.

Remarks

This method is similar to the Clone method but does not create a new object.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.ClearExceptions Method

Recurrence.ClearExceptions Method
[image]

Removes all exceptions of this Recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void ClearExceptions ()

Visual Basic [image] Copy Code

Public Sub ClearExceptions ()

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.Clone Method

Recurrence.Clone Method
[image]

Creates an exact copy of this Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

Type: Object
A new Recurrence object, identical to the current one.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.GenerateItems Method

Recurrence.GenerateItems Method
[image]

Creates occurrence items for this Recurrence in the specified date range.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<Item> GenerateItems (
DateTime startDate,
DateTime endDate
)

Visual Basic [image] Copy Code

Public Function GenerateItems ( _
startDate As DateTime, _
endDate As DateTime _
) As ItemCollection(Of Item)

Parameters

startDate

Type: DateTime
The range start date.

endDate

Type: DateTime
The range end date.

Return Value

A collection of Item instances representing each occurrence of the recurrent event in the specified date range.

Remarks

The Calendar control uses this method to generate item occurrences when a recurrent item must be displayed in the current view.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.GetEndDate Method

Recurrence.GetEndDate Method
[image]

Returns the end date for this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime GetEndDate ()

Visual Basic [image] Copy Code

Public Function GetEndDate () As DateTime

Return Value

The end date of the recurrence if the recurrence is set to expire or DateTime.MaxValue otherwise.

Remarks

The end date is calculated from the specified repeat number if RecurrenceEnd is set to NumOccurrences.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.GetOccurrence Method

Recurrence.GetOccurrence Method
[image]

Overload List

Name | Description
Recurrence.GetOccurrence (Int32) | Returns the occurrence with the specified index.
Recurrence.GetOccurrence (Int32, Boolean@) | Returns the occurrence having the specified index.
Recurrence.GetOccurrence (Int32, Boolean@, Boolean) | Returns the occurrence with the specified index.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32)

Recurrence.GetOccurrence Method (Int32)
See Also
[image]

Returns the occurrence with the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index
)

Visual Basic [image] Copy Code

Public Function GetOccurrence ( _
index As Integer _
) As Item

Parameters

index

Type: Int32
The zero based index of the occurrence to retrieve.

Return Value

A reference to the occurrence with the specified index or null, if there is no such occurrence.

Remarks

This function might take considerable amount of time to execute if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Boolean@)

Recurrence.GetOccurrence Method (Int32, Boolean@)
See Also
[image]

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index,
ref bool isDeleted
)

Visual Basic [image] Copy Code

Public Function GetOccurrence ( _
index As Integer, _
ByRef isDeleted As Boolean _
) As Item

Parameters

index

Type: Int32
The zero based index of the occurrence to retrieve.

isDeleted

Type: Boolean@
If the specified occurrence is an exception, this parameter indicates upon function completion whether the exception is deleted or not.

Return Value

A reference to the occurrence with the specified index or null, if there is no such occurrence.

Remarks

This function might take considerable amount of time to execute if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Boolean@, Boolean)

Recurrence.GetOccurrence Method (Int32, Boolean@, Boolean)
See Also
[image]

Returns the occurrence with the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index,
ref bool isDeleted,
bool noException
)

Visual Basic [image] Copy Code

Public Function GetOccurrence ( _
index As Integer, _
ByRef isDeleted As Boolean, _
noException As Boolean _
) As Item

Parameters

index
The zero-based index of the occurrence to retrieve.
isDeleted

Type: Boolean@
If the specified occurrence is an exception, this parameter indicates upon function completion whether the exception is deleted or not.

noException

Type: Boolean
Specifies whether to return the original item, in case this occurrence is an exception.

Return Value

A reference to the occurrence with the specified index or null, if there is no such occurrence.

Remarks

This function might take considerable amount of time to execute if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.LoadFrom Method

Recurrence.LoadFrom Method
[image]

Overload List

Name | Description
Recurrence.LoadFrom (BinaryReader, BinarySerializationContext) | Loads the recurrence data from a binary stream.
Recurrence.LoadFrom (XmlElement, XmlSerializationContext) | Loads the recurrence data from an XML document.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.LoadFrom Method (BinaryReader, BinarySerializationContext)

Recurrence.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also
[image]

Loads the recurrence data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class that reads primitive data types from the binary stream.
context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

Loads the state of a recurrence from a binary stream where it was previously saved with SaveTo.

See Also

LoadFrom Method Overload List
Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.LoadFrom Method (XmlElement, XmlSerializationContext)

Recurrence.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads the recurrence data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.Xml.XmlElement class that allows reading data from the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

Loads the state of a recurrence from an XML document, where it was previously saved with the SaveTo method.

See Also

LoadFrom Method Overload List
Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.LoadViewState Method

Recurrence.LoadViewState Method
[image]

Restores view-state information that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.MarkException Method

Recurrence.MarkException Method
[image]

Marks the specified item as an exception in the Recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void MarkException (
Item item,
bool deleted
)

Visual Basic [image] Copy Code

Public Sub MarkException ( _
item As Item, _
deleted As Boolean _
)

Parameters

item
Type: Item
The Item to be marked as an exception.
deleted

Type: Boolean
Specifies whether the exception is created by deleting one occurrence from the recurrent pattern or by changing the occurrence time properties.

Remarks

The Calendar control calls this method when a user drags an occurrence item or edits its text, thus creating an exception of the recurrence.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.SamePatternAs Method

Recurrence.SamePatternAs Method
[image]

Determines whether two Recurrence objects define the same recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool SamePatternAs (
Recurrence recurrence
)

Visual Basic [image] Copy Code

Public Function SamePatternAs ( _
recurrence As Recurrence _
) As Boolean

Parameters

recurrence
Type: Recurrence
A Recurrence object to compare with this recurrence.

Return Value

Type: Boolean
true if the Recurrence instances have the same recurrence pattern; otherwise false.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.SaveTo Method

Recurrence.SaveTo Method
[image]

Overload List

Name | Description
Recurrence.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the recurrence data to a binary stream.
Recurrence.SaveTo (XmlElement, XmlSerializationContext) | Saves the recurrence data to an XML document.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.SaveTo Method (BinaryWriter, BinarySerializationContext)

Recurrence.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also
[image]

Saves the recurrence data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class that allows writing primitive data types to the binary stream.
context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method saves the recurrence properties as bytes in a binary stream. Use the LoadFrom method to restore the recurrence.

See Also

SaveTo Method Overload List
Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.SaveTo Method (XmlElement, XmlSerializationContext)

Recurrence.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the recurrence data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.Xml.XmlElement class that allows adding data to the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The recurrence properties are saved as elements of an XML document, and can later be restored with the LoadFrom method.

See Also

SaveTo Method Overload List
Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.SaveViewState Method

Recurrence.SaveViewState Method
[image]

Saves any server side view-state changes that have occurred on this Recurrence item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object SaveViewState ()

Visual Basic [image] Copy Code

Public Function SaveViewState () As Object

Return Value

Type: Object
The current view state of this Recurrence, if saved; otherwise null.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.ToLocalizedString Method

Recurrence.ToLocalizedString Method
[image]

Returns a localized string that represents this Recurrence using the specified date and time formatting info and localization information.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ToLocalizedString (
DateTimeFormatInfo info,
LocalizationInfo local
)

Visual Basic [image] Copy Code

Public Function ToLocalizedString( _
info As DateTimeFormatInfo, _
local As LocalizationInfo _
) As String

Parameters

info

Type: DateTimeFormatInfo
Specifies how date and time values are formatted and displayed.

local

Type: LocalizationInfo
Specifies localized strings used in the representation.

Return Value

Type: String
A localized string representation of this Recurrence object.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.ToString Method

Recurrence.ToString Method
[image]

Overload List

Name | Description
Recurrence.ToString () | Returns a string that represents this Recurrence using the date and time formatting information defined in the current culture.
Recurrence.ToString (DateTimeFormatInfo) | Returns a string that represents this Recurrence using the specified date and time formatting info.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.ToString Method ()

Recurrence.ToString Method ()
See Also
[image]

Returns a string that represents this Recurrence using the date and time formatting information defined in the current culture.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

Type: String
A string that represents this Recurrence object.

See Also

ToString Method Overload List
Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.ToString Method (DateTimeFormatInfo)

Recurrence.ToString Method (DateTimeFormatInfo)
See Also
[image]

Returns a string that represents this Recurrence using the specified date and time formatting info.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ToString (
DateTimeFormatInfo info
)

Visual Basic [image] Copy Code

Public Function ToString( _
info As DateTimeFormatInfo _
) As String

Parameters

info
Type: DateTimeFormatInfo
An instance of the System.Globalization.DateTimeFormatInfo class that specifies how date and time values are formatted and displayed.

Return Value

Type: String
A string that represents the Recurrence object.

See Also

ToString Method Overload List
Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.TrackViewState Method

Recurrence.TrackViewState Method
[image]

Causes tracking of view-state changes to this Recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void TrackViewState ()

Visual Basic [image] Copy Code

Public Sub TrackViewState ()

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence Properties

Recurrence Properties
[image]

Public Properties

Name | Description
DailyRecurrence | Gets or sets the type of daily recurrence.
Day | Gets or sets a value indicating the day of the week when the event occurs.
DayOfMonth | Gets or sets the day of the month when the event occurs.
Days | Gets or sets the number of days between two consecutive occurrences of the same event.
DaysOfWeek | Gets or sets the days of the week when the event occurs.
EndDate | Gets or sets the end date of the recurrence.
Exceptions | Gets a list with all Recurrence exceptions.
Interval | Gets or sets the interval of recurrence.
IsTrackingViewState | Gets a value that indicates whether changes to the view state are saved.
Master | Gets the master Item for the recurrence.
MonthlyRecurrence | Gets or sets the type of monthly recurrence.
MonthOfYear | Gets or sets the month of the year when the event occurs.
Months | Gets or sets the number of months between two consecutive occurrences of the same event.
NumOccurrences | Gets or sets how many times a recurring event should occur.
Occurrence | Gets or sets on which occurrence of the week within the month the event occurs.
Pattern | Gets or sets the pattern of recurrence.
RecurrenceEnd | Gets or sets the last time when the event occurs.
StartDate | Gets or sets the date and time of the event's first occurrence.
Weeks | Gets or sets the number of weeks between two consecutive occurrences of the event.
YearlyRecurrence | Gets or sets the type of yearly recurrence.

Protected Properties

Name | Description
ViewState | Gets or sets the ViewState of this Recurrence.

See Also

Recurrence Class


MindFusion.Scheduling.Recurrence.DailyRecurrence Property

Recurrence.DailyRecurrence Property
[image]

Gets or sets the type of daily recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DailyRecurrence DailyRecurrence { get; set; }

Visual Basic [image] Copy Code

Public Property DailyRecurrence As DailyRecurrence

Property Value

One of the DailyRecurrence enumeration values.

Remarks

The property is used when the Pattern is set to RecurrencePattern.Daily.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.Day Property

Recurrence.Day Property
[image]

Gets or sets a value indicating the day of the week when the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DayOfWeekType Day { get; set; }

Visual Basic [image] Copy Code

Public Property Day As DayOfWeekType

Property Value

One of the DayOfWeekType enumeration values.

Remarks

The property is used when Pattern is set to RecurrencePattern.Monthly or RecurrencePattern.Yearly and the MonthlyRecurrence or YearlyRecurrence properties are set to MonthlyRecurrence.ByDayType.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.DayOfMonth Property

Recurrence.DayOfMonth Property
[image]

Gets or sets the day of the month when the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int DayOfMonth { get; set; }

Visual Basic [image] Copy Code

Public Property DayOfMonth As Integer

Property Value

An integer that specifies the day of the month. Values should range from 1 to [28, 31] depending on which month it is.

Remarks

This property is used when the Pattern is set to RecurrencePattern.Monthly or RecurrencePattern.Yearly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.Days Property

Recurrence.Days Property
[image]

Gets or sets the number of days between two consecutive occurrences of the same event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Days { get; set; }

Visual Basic [image] Copy Code

Public Property Days As Integer

Property Value

An integer that specifies the number of days.

Remarks

This value is used when the recurrence Pattern is set to RecurrencePattern.Daily.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.DaysOfWeek Property

Recurrence.DaysOfWeek Property
[image]

Gets or sets the days of the week when the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DaysOfWeek DaysOfWeek { get; set; }

Visual Basic [image] Copy Code

Public Property DaysOfWeek As DaysOfWeek

Property Value

One of the DaysOfWeek enumeration values.

Remarks

This property is used when the Pattern is set to RecurrencePattern.Weekly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.EndDate Property

Recurrence.EndDate Property
[image]

Gets or sets the end date of the recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime EndDate { get; set; }

Visual Basic [image] Copy Code

Public Property EndDate As DateTime

Property Value

An instance of the System.DateTime structure.

Remarks

The property is used when RecurrenceEnd is set to RecurrenceEnd.EndDate.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.Exceptions Property

Recurrence.Exceptions Property
[image]

Gets a list with all Recurrence exceptions.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ICollection Exceptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Exceptions As ICollection

Property Value

A collection with the exceptions.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.Interval Property

Recurrence.Interval Property
[image]

Gets or sets the interval of recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimeSpan Interval { get; set; }

Visual Basic [image] Copy Code

Public Property Interval As TimeSpan

Property Value

An instance of the System.TimeSpan structure.

Remarks

The property is used when the Pattern is set to RecurrencePattern.ByTimeInterval.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.IsTrackingViewState Property

Recurrence.IsTrackingViewState Property
[image]

Gets a value that indicates whether changes to the view state are saved.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

true if changes to the view state are saved; otherwise false.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.Master Property

Recurrence.Master Property
[image]

Gets the master Item for the recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Item Master { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Master As Item

Property Value

An instance of the Item class or null if the recurrence is not associated with an item.

Remarks

To associate a Recurrence with an Item, set the Item's Recurrence property to the Recurrence object.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.MonthlyRecurrence Property

Recurrence.MonthlyRecurrence Property
[image]

Gets or sets the type of monthly recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public MonthlyRecurrence MonthlyRecurrence { get; set; }

Visual Basic [image] Copy Code

Public Property MonthlyRecurrence As MonthlyRecurrence

Property Value

One of the MonthlyRecurrence enumeration values.

Remarks

The property is used when the Pattern is set to RecurrencePattern.Monthly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.MonthOfYear Property

Recurrence.MonthOfYear Property
[image]

Gets or sets the month of the year when the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int MonthOfYear { get; set; }

Visual Basic [image] Copy Code

Public Property MonthOfYear As Integer

Property Value

An integer that specifies the month. Valid values range from [1, 12].

Remarks

The property is used when the Pattern is set to RecurrencePattern.Yearly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.Months Property

Recurrence.Months Property
[image]

Gets or sets the number of months between two consecutive occurrences of the same event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Months { get; set; }

Visual Basic [image] Copy Code

Public Property Months As Integer

Property Value

An integer that specifies the number of months.

Remarks

The property is used when the Pattern is set to RecurrencePattern.Monthly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.NumOccurrences Property

Recurrence.NumOccurrences Property
[image]

Gets or sets how many times a recurring event should occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int NumOccurrences { get; set; }

Visual Basic [image] Copy Code

Public Property NumOccurrences As Integer

Property Value

An integer that specifies the number of occurrences.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.Occurrence Property

Recurrence.Occurrence Property
[image]

Gets or sets on which occurrence of the week within the month the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Occurrence Occurrence { get; set; }

Visual Basic [image] Copy Code

Public Property Occurrence As Occurrence

Property Value

One of the Occurrence enumeration values.

Remarks

The property is used when the Pattern is set to RecurrencePattern.Monthly or RecurrencePattern.Yearly and the MonthlyRecurrence or YearlyRecurrence properties are set to MonthlyRecurrence.ByDayType.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.Pattern Property

Recurrence.Pattern Property
[image]

Gets or sets the pattern of recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public RecurrencePattern Pattern { get; set; }

Visual Basic [image] Copy Code

Public Property Pattern As RecurrencePattern

Property Value

One of the RecurrencePattern enumeration values.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.RecurrenceEnd Property

Recurrence.RecurrenceEnd Property
[image]

Gets or sets the last time when the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public RecurrenceEnd RecurrenceEnd { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceEnd As RecurrenceEnd

Property Value

One of the RecurrenceEnd enumeration values.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.StartDate Property

Recurrence.StartDate Property
[image]

Gets or sets the date and time of the event's first occurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime StartDate { get; set; }

Visual Basic [image] Copy Code

Public Property StartDate As DateTime

Property Value

An instance of the System.DateTime structure.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.ViewState Property

Recurrence.ViewState Property
[image]

Gets or sets the ViewState of this Recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual StateBag ViewState { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property ViewState As StateBag

Property Value

An instance of the System.Web.UI.StateBag class that contains the view-state information for the Recurrence.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.Weeks Property

Recurrence.Weeks Property
[image]

Gets or sets the number of weeks between two consecutive occurrences of the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Weeks { get; set; }

Visual Basic [image] Copy Code

Public Property Weeks As Integer

Property Value

An integer that specifies the number of weeks.

Remarks

The property is used when the Pattern is set to RecurrencePattern.Weekly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.Recurrence.YearlyRecurrence Property

Recurrence.YearlyRecurrence Property
[image]

Gets or sets the type of yearly recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public YearlyRecurrence YearlyRecurrence { get; set; }

Visual Basic [image] Copy Code

Public Property YearlyRecurrence As YearlyRecurrence

Property Value

One of the YearlyRecurrence enumeration values.

Remarks

This property is used when the Pattern is set to RecurrencePattern.Yearly.

See Also

Recurrence Members
Recurrence Class


MindFusion.Scheduling.RecurrenceEnd Enumeration

RecurrenceEnd Enumeration
[image]

Specifies when to stop repeating recurring events.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum RecurrenceEnd

Visual Basic [image] Copy Code

Public Enum RecurrenceEnd

Members

Member name | Value | Description
Never | 0 | Never stop repeating events.
NumOccurrences | 1 | Stop repeating events after a specified number of occurrences.
EndDate | 2 | The recurrence ends at a specified date.

See Also


MindFusion.Scheduling.RecurrenceException Class

RecurrenceException Class
[image]

Represents an exception of the recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class RecurrenceException : IStateManager

Visual Basic [image] Copy Code

Public Class RecurrenceException
Implements IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.RecurrenceException

See Also

RecurrenceException Members


MindFusion.Scheduling.RecurrenceException Members

RecurrenceException Members
Properties Methods
[image]

Represents an exception of the recurrence pattern.

The following tables list the members exposed by the RecurrenceException type.

Public Properties

Name | Description
IsDeleted | Gets or sets a value indicating whether this event occurrence has been deleted.
IsTrackingViewState | Gets a value that indicates whether the RecurrenceException is saving changes to its view state.
Item | Gets the Item representing the recurrence exception.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the RecurrenceException across multiple requests for the same page.

Public Methods

Name | Description
LoadViewState | Restores view-state information for this RecurrenceException from a previous page request that was saved by the SaveViewState method.
SaveViewState | Saves any view-state changes that have occurred in this RecurrenceException since the time the page was posted back to the server.
TrackViewState | Causes tracking of view-state changes to this RecurrenceException so they can be stored in a StateBag object.

See Also

RecurrenceException Class


MindFusion.Scheduling.RecurrenceException Methods

RecurrenceException Methods
[image]

Public Methods

Name | Description
LoadViewState | Restores view-state information for this RecurrenceException from a previous page request that was saved by the SaveViewState method.
SaveViewState | Saves any view-state changes that have occurred in this RecurrenceException since the time the page was posted back to the server.
TrackViewState | Causes tracking of view-state changes to this RecurrenceException so they can be stored in a StateBag object.

See Also

RecurrenceException Class


MindFusion.Scheduling.RecurrenceException.LoadViewState Method

RecurrenceException.LoadViewState Method
[image]

Restores view-state information for this RecurrenceException from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the state to be restored.

See Also

RecurrenceException Members
RecurrenceException Class


MindFusion.Scheduling.RecurrenceException.SaveViewState Method

RecurrenceException.SaveViewState Method
[image]

Saves any view-state changes that have occurred in this RecurrenceException since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overridable Function SaveViewState () As Object

Return Value

Type: Object
Returns the RecurrenceException's current view state. If there is no view state associated with it, this method returns null (Nothing in VB.NET).

See Also

RecurrenceException Members
RecurrenceException Class


MindFusion.Scheduling.RecurrenceException.TrackViewState Method

RecurrenceException.TrackViewState Method
[image]

Causes tracking of view-state changes to this RecurrenceException so they can be stored in a StateBag object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void TrackViewState ()

Visual Basic [image] Copy Code

Public Overridable Sub TrackViewState ()

See Also

RecurrenceException Members
RecurrenceException Class


MindFusion.Scheduling.RecurrenceException Properties

RecurrenceException Properties
[image]

Public Properties

Name | Description
IsDeleted | Gets or sets a value indicating whether this event occurrence has been deleted.
IsTrackingViewState | Gets a value that indicates whether the RecurrenceException is saving changes to its view state.
Item | Gets the Item representing the recurrence exception.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the RecurrenceException across multiple requests for the same page.

See Also

RecurrenceException Class


MindFusion.Scheduling.RecurrenceException.IsDeleted Property

RecurrenceException.IsDeleted Property
[image]

Gets or sets a value indicating whether this event occurrence has been deleted.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsDeleted { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsDeleted As Boolean

Property Value

true if the occurrence has been deleted; otherwise false.

See Also

RecurrenceException Members
RecurrenceException Class


MindFusion.Scheduling.RecurrenceException.IsTrackingViewState Property

RecurrenceException.IsTrackingViewState Property
[image]

Gets a value that indicates whether the RecurrenceException is saving changes to its view state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

true if changes to the view state are saved; otherwise false.

See Also

RecurrenceException Members
RecurrenceException Class


MindFusion.Scheduling.RecurrenceException.Item Property

RecurrenceException.Item Property
[image]

Gets the Item representing the recurrence exception.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Item Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class.

See Also

RecurrenceException Members
RecurrenceException Class


MindFusion.Scheduling.RecurrenceException.ViewState Property

RecurrenceException.ViewState Property
[image]

Gets a dictionary of state information that allows you to save and restore the view state of the RecurrenceException across multiple requests for the same page.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual StateBag ViewState { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property ViewState As StateBag

Property Value

An instance of the System.Web.UI.StateBag class that contains the server side view-state information.

See Also

RecurrenceException Members
RecurrenceException Class


MindFusion.Scheduling.RecurrencePattern Enumeration

RecurrencePattern Enumeration
[image]

Specifies the interval at which recurring events occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum RecurrencePattern

Visual Basic [image] Copy Code

Public Enum RecurrencePattern

Members

Member name | Value | Description
Daily | 0 | Repeats an event every day.
Weekly | 1 | Repeats an event every week.
Monthly | 2 | Repeats an event every month.
Yearly | 3 | Repeats an event every year.
ByTimeInterval | 4 | Repeats an event over a specified time interval.

Remarks

These values are assigned to the Pattern property of the Recurrence class.

See Also


MindFusion.Scheduling.RecurrenceState Enumeration

RecurrenceState Enumeration
[image]

Specifies the recurrence state of items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum RecurrenceState

Visual Basic [image] Copy Code

Public Enum RecurrenceState

Members

Member name | Value | Description
None | 0 | Specifies an one-time non-recurring event.
Occurrence | 1 | Specifies a single occurrence of a recurring event.
Exception | 2 | Specifies an exception of a recurring event.
Master | 3 | Specifies a recurring event.

See Also


MindFusion.Scheduling.Reminder Class

Reminder Class
[image]

Represents reminders associated with schedule items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class Reminder : ICloneable, IStateManager

Visual Basic [image] Copy Code

Public NotInheritable Class Reminder
Implements ICloneable, IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reminder

See Also

Reminder Members


MindFusion.Scheduling.Reminder Members

Reminder Members
Constructors Fields Properties Methods
[image]

Represents reminders associated with schedule items.

The following tables list the members exposed by the Reminder type.

Public Constructors

Name | Description
Reminder | Initializes a new instance of the Reminder class.

Public Fields

Name | Description
MaxInterval | The maximum time interval that can be set as value of TimeInterval for a Reminder object.

Public Properties

Name | Description
IsTrackingViewState | Gets a value that indicates whether this Reminder is saving changes to its view state.
Message | Gets or sets the message to display as a reminder.
Time | Gets or sets the time when the Reminder is triggered.
TimeInterval | Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.
Type | Gets or sets the type of this reminder.

Public Methods

Name | Description
Clone | Returns an exact copy of this Reminder object.
LoadFrom | Overloaded.
LoadViewState | Restores view-state information for this Reminder from a ViewState object that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Saves any server view-state changes that have occurred on this Reminder since the time the page was posted back to the server.
TrackViewState | Causes tracking of view-state changes to the Reminder so they can be stored in a StateBag object.

See Also

Reminder Class


MindFusion.Scheduling.Reminder Fields

Reminder Fields
[image]

Public Fields

Name | Description
MaxInterval | The maximum time interval that can be set as value of TimeInterval for a Reminder object.

See Also

Reminder Class


MindFusion.Scheduling.Reminder.MaxInterval Field

Reminder.MaxInterval Field
[image]

The maximum time interval that can be set as value of TimeInterval for a Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static readonly TimeSpan MaxInterval

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxInterval As TimeSpan

Remarks

This field is set to a TimeSpan of 2 days.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder Constructor

Reminder Constructor
[image]

Initializes a new instance of the Reminder class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Reminder ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Reminder Class


MindFusion.Scheduling.Reminder Methods

Reminder Methods
[image]

Public Methods

Name | Description
Clone | Returns an exact copy of this Reminder object.
LoadFrom | Overloaded.
LoadViewState | Restores view-state information for this Reminder from a ViewState object that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Saves any server view-state changes that have occurred on this Reminder since the time the page was posted back to the server.
TrackViewState | Causes tracking of view-state changes to the Reminder so they can be stored in a StateBag object.

See Also

Reminder Class


MindFusion.Scheduling.Reminder.Clone Method

Reminder.Clone Method
[image]

Returns an exact copy of this Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

Type: Object
The newly created Reminder object.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.LoadFrom Method

Reminder.LoadFrom Method
[image]

Overload List

Name | Description
Reminder.LoadFrom (BinaryReader, BinarySerializationContext) | Loads reminder data from a binary stream.
Reminder.LoadFrom (XmlElement, XmlSerializationContext) | Loads reminder data from an XML document.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.LoadFrom Method (BinaryReader, BinarySerializationContext)

Reminder.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also
[image]

Loads reminder data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Type: BinaryReader
An instance of the System.IO.BinaryReader class that reads primitive data types from the binary stream.
context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method loads reminder data from a binary stream where it was previously saved with the SaveTo method.

See Also

LoadFrom Method Overload List
Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.LoadFrom Method (XmlElement, XmlSerializationContext)

Reminder.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads reminder data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.Xml.XmlElement class that allows reading data from the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads reminder data from an XML document, where it was previously saved with the SaveTo method.

See Also

LoadFrom Method Overload List
Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.LoadViewState Method

Reminder.LoadViewState Method
[image]

Restores view-state information for this Reminder from a ViewState object that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.SaveTo Method

Reminder.SaveTo Method
[image]

Overload List

Name | Description
Reminder.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the reminder data to a binary stream.
Reminder.SaveTo (XmlElement, XmlSerializationContext) | Saves the reminder data to an XML document.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.SaveTo Method (BinaryWriter, BinarySerializationContext)

Reminder.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also
[image]

Saves the reminder data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer

Type: BinaryWriter
An instance of the System.IO.BinaryWriter class that allows writing primitive data types to the binary stream.

context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method saves reminder data as bytes in a binary stream. They can be restored later with the LoadFrom method.

See Also

SaveTo Method Overload List
Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.SaveTo Method (XmlElement, XmlSerializationContext)

Reminder.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the reminder data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.IO.XmlElement class that allows adding data to the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves reminder data as elements in an XML document. It can be restored later using the LoadFrom method.

See Also

SaveTo Method Overload List
Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.SaveViewState Method

Reminder.SaveViewState Method
[image]

Saves any server view-state changes that have occurred on this Reminder since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object SaveViewState ()

Visual Basic [image] Copy Code

Public Function SaveViewState () As Object

Return Value

Type: Object
Returns the Reminder's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.TrackViewState Method

Reminder.TrackViewState Method
[image]

Causes tracking of view-state changes to the Reminder so they can be stored in a StateBag object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void TrackViewState ()

Visual Basic [image] Copy Code

Public Sub TrackViewState ()

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder Properties

Reminder Properties
[image]

Public Properties

Name | Description
IsTrackingViewState | Gets a value that indicates whether this Reminder is saving changes to its view state.
Message | Gets or sets the message to display as a reminder.
Time | Gets or sets the time when the Reminder is triggered.
TimeInterval | Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.
Type | Gets or sets the type of this reminder.

See Also

Reminder Class


MindFusion.Scheduling.Reminder.IsTrackingViewState Property

Reminder.IsTrackingViewState Property
[image]

Gets a value that indicates whether this Reminder is saving changes to its view state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

true if this Reminder is tracking view state changes; otherwise false.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.Message Property

Reminder.Message Property
[image]

Gets or sets the message to display as a reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Message { get; set; }

Visual Basic [image] Copy Code

Public Property Message As String

Property Value

A string value representing a custom message. Default is an empty string ("").

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.Time Property

Reminder.Time Property
[image]

Gets or sets the time when the Reminder is triggered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime Time { get; set; }

Visual Basic [image] Copy Code

Public Property Time As DateTime

Property Value

An instance of the System.DateTime structure.

Remarks

The value of this property is considered only if the Type of the reminder is set to Exact.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.TimeInterval Property

Reminder.TimeInterval Property
[image]

Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimeSpan TimeInterval { get; set; }

Visual Basic [image] Copy Code

Public Property TimeInterval As TimeSpan

Property Value

An instance of the System.TimeSpan structure.

Remarks

The value of this property is considered only if the Type of the reminder is set to ReminderType.Leading.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.Reminder.Type Property

Reminder.Type Property
[image]

Gets or sets the type of this reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ReminderType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As ReminderType

Property Value

One of the ReminderType enumeration values. Default value is ReminderType.Leading.

See Also

Reminder Members
Reminder Class


MindFusion.Scheduling.ReminderType Enumeration

ReminderType Enumeration
[image]

Specifies the type of a reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum ReminderType

Visual Basic [image] Copy Code

Public Enum ReminderType

Members

Member name | Value | Description
Exact | 0 | Trigger the reminder at the exact time specified in its Date property. Note: Recurring items cannot have exact reminders.
Leading | 1 | Trigger the reminder at the specified TimeInterval before the item's scheduled start time. Note: Tasks cannot have leading reminders.

See Also


MindFusion.Scheduling.Resource Class

Resource Class
[image]

Instances of the Resource class contain information about arbitrary resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class Resource : IStateManager

Visual Basic [image] Copy Code

Public Class Resource
Implements IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource

See Also

Resource Members


MindFusion.Scheduling.Resource Members

Resource Members
Constructors Properties Methods
[image]

Instances of the Resource class contain information about arbitrary resources.

The following tables list the members exposed by the Resource type.

Public Constructors

Name | Description
Resource | Initializes a new instance of the Resource class.

Public Properties

Name | Description
Id | Gets or sets the string identifier for this resource.
IsTrackingViewState | Gets a value that indicates whether the Resource is saving changes to its view state.
Name | Gets or sets the name of the resource.
Tag | Gets or sets custom data associated with the resource.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the Resource across multiple requests for the same page.

Public Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object.
GetHashCode | Serves as a hash function for the Resource type.
LoadFrom | Overloaded.
LoadViewState | Restores view-state information for this Resource saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Saves any server view-state changes that have occurred on this Resource since the time the page was posted back to the server.
ToString | Converts the value of the Resource object to its equivalent string representation using the specified culture-specific format information.
TrackViewState | Causes tracking of view-state changes to the Resource so they can be stored in the server control's StateBag object.

See Also

Resource Class


MindFusion.Scheduling.Resource Constructor

Resource Constructor
[image]

Initializes a new instance of the Resource class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Resource ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Resource Class


MindFusion.Scheduling.Resource Methods

Resource Methods
[image]

Public Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object.
GetHashCode | Serves as a hash function for the Resource type.
LoadFrom | Overloaded.
LoadViewState | Restores view-state information for this Resource saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Saves any server view-state changes that have occurred on this Resource since the time the page was posted back to the server.
ToString | Converts the value of the Resource object to its equivalent string representation using the specified culture-specific format information.
TrackViewState | Causes tracking of view-state changes to the Resource so they can be stored in the server control's StateBag object.

See Also

Resource Class


MindFusion.Scheduling.Resource.Equals Method

Resource.Equals Method
[image]

Determines whether the specified Object is equal to the current Object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

Type: Object
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.GetHashCode Method

Resource.GetHashCode Method
[image]

Serves as a hash function for the Resource type.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

Type: Int32
A hash code for the current Object.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.LoadFrom Method

Resource.LoadFrom Method
[image]

Overload List

Name | Description
Resource.LoadFrom (BinaryReader, BinarySerializationContext) | Loads resource data from a binary stream.
Resource.LoadFrom (XmlElement, XmlSerializationContext) | Loads resource data from an XML document.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.LoadFrom Method (BinaryReader, BinarySerializationContext)

Resource.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also
[image]

Loads resource data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader

Type: BinaryReader
An instance of the System.IO.BinaryReader class that allows reading primitive data types from a binary stream.

context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method loads data from a stream saved with a previous call to the SaveTo method.

See Also

LoadFrom Method Overload List
Resource Members
Resource Class


MindFusion.Scheduling.Resource.LoadFrom Method (XmlElement, XmlSerializationContext)

Resource.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads resource data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.Xml.XmlElement class that allows reading data from the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads an XML document that was stored by a previous call to the SaveTo method.

See Also

LoadFrom Method Overload List
Resource Members
Resource Class


MindFusion.Scheduling.Resource.LoadViewState Method

Resource.LoadViewState Method
[image]

Restores view-state information for this Resource saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.SaveTo Method

Resource.SaveTo Method
[image]

Overload List

Name | Description
Resource.SaveTo (BinaryWriter, BinarySerializationContext) | Saves the resource data to a binary stream.
Resource.SaveTo (XmlElement, XmlSerializationContext) | Saves the resource data to an XML document.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.SaveTo Method (BinaryWriter, BinarySerializationContext)

Resource.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also
[image]

Saves the resource data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Type: BinaryWriter
An instance of the System.IO.BinaryWriter class that allows writing primitive data types to a binary stream.
context
Type: BinarySerializationContext
An instance of the BinarySerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

Call LoadFrom when you want to restore the Resource from the stream.

See Also

SaveTo Method Overload List
Resource Members
Resource Class


MindFusion.Scheduling.Resource.SaveTo Method (XmlElement, XmlSerializationContext)

Resource.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the resource data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
An instance of the System.Xml.XmlElement class that allows adding data to the XML document.
context
Type: XmlSerializationContext
An instance of the XmlSerializationContext class that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves Resource data as elements of an XML document.

See Also

SaveTo Method Overload List
Resource Members
Resource Class


MindFusion.Scheduling.Resource.SaveViewState Method

Resource.SaveViewState Method
[image]

Saves any server view-state changes that have occurred on this Resource since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overridable Function SaveViewState () As Object

Return Value

Type: Object
Returns the Resource's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.ToString Method

Resource.ToString Method
[image]

Converts the value of the Resource object to its equivalent string representation using the specified culture-specific format information.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual string ToString (
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Overridable Function ToString( _
provider As IFormatProvider _
) As String

Parameters

provider
Type: IFormatProvider
A System.IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
A string representation of value of the Resource object as specified by provider.

Remarks

The provider parameter is typically a DateTimeFormatInfo object or a CultureInfo object that contains a DateTimeFormatInfo object. If provider is null, the DateTimeFormatInfo associated with the current culture is used. For more information, see System.Globalization.CultureInfo.CurrentCulture.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.TrackViewState Method

Resource.TrackViewState Method
[image]

Causes tracking of view-state changes to the Resource so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void TrackViewState ()

Visual Basic [image] Copy Code

Public Overridable Sub TrackViewState ()

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource Properties

Resource Properties
[image]

Public Properties

Name | Description
Id | Gets or sets the string identifier for this resource.
IsTrackingViewState | Gets a value that indicates whether the Resource is saving changes to its view state.
Name | Gets or sets the name of the resource.
Tag | Gets or sets custom data associated with the resource.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the Resource across multiple requests for the same page.

See Also

Resource Class


MindFusion.Scheduling.Resource.Id Property

Resource.Id Property
[image]

Gets or sets the string identifier for this resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As String

Property Value

A string that represents the identifier.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.IsTrackingViewState Property

Resource.IsTrackingViewState Property
[image]

Gets a value that indicates whether the Resource is saving changes to its view state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

true if the Resource is tracking changes; otherwise false.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.Name Property

Resource.Name Property
[image]

Gets or sets the name of the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Name { get; set; }

Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string that represents the name. Default value is an empty string ("").

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.Tag Property

Resource.Tag Property
[image]

Gets or sets custom data associated with the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An object that represents the tag. Default value is null.

Remarks

Use the property to store your custom data. The tag can be anything from a primitive data type value to a complex object from the .NET class library to a class defined by you. If the tag is an instance of a value type, it will be serialized together with the object containing it when saving / loading the schedule. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.Resource.ViewState Property

Resource.ViewState Property
[image]

Gets a dictionary of state information that allows you to save and restore the view state of the Resource across multiple requests for the same page.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual StateBag ViewState { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property ViewState As StateBag

Property Value

An instance of the System.Web.UI.StateBag class that contains the server control's view-state information.

See Also

Resource Members
Resource Class


MindFusion.Scheduling.ResourceCollection(T) Class

ResourceCollection(T) Class
[image]

Represents a strongly-typed collection of Resource objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ResourceCollection<T> : StateCollection<T> where T : Resource

Visual Basic [image] Copy Code

Public Class ResourceCollection(Of T As Resource)
Inherits StateCollection(Of T)

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.StateCollection(T)
MindFusion.Scheduling.ResourceCollection(T)

See Also

ResourceCollection(T) Members


MindFusion.Scheduling.ResourceCollection(T) Members

ResourceCollection(T) Members
Constructors Properties Methods Events
[image]

Represents a strongly-typed collection of Resource objects.

The following tables list the members exposed by the ResourceCollection(T) type.

Public Constructors

Name | Description
ResourceCollection | Overloaded. Initializes a new instance of the ResourceCollection class.

Public Properties

Name | Description
Item | Gets the Resource identified by the specified string.

Inherited Public Properties

Name | Description
Count | Gets the count of items in the collection. (Inherited from StateCollection.)
IsReadOnly | Gets a value that indicates if the collection is read only. (Inherited from StateCollection.)
IsTrackingViewState | Gets a value that indicates whether the collection is saving changes to its view state. (Inherited from StateCollection.)
Item | Returns the item at the specified index. This is the indexer of the collection. (Inherited from StateCollection.)

Protected Methods

Name | Description
LoadItemViewState | Restores view-state information from an object that was saved by the SaveItemViewState method.
SaveItemViewState | Saves the ViewState of the specified item.

Inherited Public Methods

Name | Description
Add | Adds a new item to the collection. (Inherited from StateCollection.)
Clear | Removes all items from the collection. (Inherited from StateCollection.)
Contains | Checks if the specified item is contained within the collection. (Inherited from StateCollection.)
CopyTo | Copies the elements of the collection to an array, starting from the particular Array index. (Inherited from StateCollection.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from StateCollection.)
IndexOf | Returns the index of the first occurrence of the specified item in the collection. (Inherited from StateCollection.)
Insert | Inserts the specified item into the array at the specified index. (Inherited from StateCollection.)
LoadViewState | Restores view-state information from an object that was saved by the SaveViewState method (Inherited from StateCollection.)
OnChanged | Raises the Changed event. (Inherited from StateCollection.)
Remove | Removes the specified item from the collection. (Inherited from StateCollection.)
RemoveAt | Removes the item at the specified index. (Inherited from StateCollection.)
SaveViewState | Saves any view-state changes that have occurred for this collection. (Inherited from StateCollection.)
TrackViewState | Causes tracking of view-state changes made to the collection so they can be stored in an object. (Inherited from StateCollection.)

Inherited Protected Methods

Name | Description
LoadItemViewState | Restores view-state information for the item that was previously saved by the SaveItemViewState method. (Inherited from StateCollection.)
OnAdd | Raises the Add event. (Inherited from StateCollection.)
OnAddComplete | Raises the AddComplete event. (Inherited from StateCollection.)
OnClear | Raises the Clear event. (Inherited from StateCollection.)
OnClearComplete | Raises the ClearComplete event. (Inherited from StateCollection.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from StateCollection.)
OnInsert | Raises the Insert event. (Inherited from StateCollection.)
OnInsertComplete | Raises the InsertComplete event. (Inherited from StateCollection.)
OnRemove | Raises the Remove event. (Inherited from StateCollection.)
OnRemoveComplete | Raises the RemoveComplete event. (Inherited from StateCollection.)
OnSet | Raises the Set event. (Inherited from StateCollection.)
OnSetComplete | Raises the SetComplete event. (Inherited from StateCollection.)
SaveItemViewState | Saves any view-state changes that have occurred of the specified item. (Inherited from StateCollection.)
TrackItemViewState | Causes tracking of view-state changes made to the specified item. (Inherited from StateCollection.)

Inherited Public Events

Name | Description
AddComplete | Declares the AddComplete event. (Inherited from StateCollection.)
AddEvent | Declares the Add event. (Inherited from StateCollection.)
Changed | Declares the Changed event. (Inherited from StateCollection.)
ClearComplete | Declares the ClearComplete event. (Inherited from StateCollection.)
ClearEvent | Declares the Clear event. (Inherited from StateCollection.)
CollectionChanged | Declares the CollectionChanged event. (Inherited from StateCollection.)
InsertComplete | Declares the InsertComplete event. (Inherited from StateCollection.)
InsertEvent | Declares the Insert event. (Inherited from StateCollection.)
RemoveComplete | Declares the RemoveComplete event. (Inherited from StateCollection.)
RemoveEvent | Declares the Remove event. (Inherited from StateCollection.)
SetComplete | Declares the SetComplete event. (Inherited from StateCollection.)
SetEvent | Declares the Set event. (Inherited from StateCollection.)

See Also

ResourceCollection(T) Class


MindFusion.Scheduling.ResourceCollection(T) Constructor

ResourceCollection(T) Constructor
[image]

Initializes a new instance of the ResourceCollection class.

Overload List

Name | Description
ResourceCollection(T) () | Initializes a new instance of the ResourceCollection class.
ResourceCollection(T) (IEnumerable(T)) | Initializes a new instance of the ResourceCollection class and adds the members of the specified collection to it.
ResourceCollection(T) (Int32) | Creates a collection of ResourceCollection class with the specified capacity.

See Also

ResourceCollection(T) Class


MindFusion.Scheduling.ResourceCollection(T) Constructor ()

ResourceCollection(T) Constructor ()
See Also
[image]

Initializes a new instance of the ResourceCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

ResourceCollection(T) Constructor Overload List
ResourceCollection(T) Class


MindFusion.Scheduling.ResourceCollection(T) Constructor (IEnumerable(T))

ResourceCollection(T) Constructor (IEnumerable(T))
See Also
[image]

Initializes a new instance of the ResourceCollection class and adds the members of the specified collection to it.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<T> (
IEnumerable<T> collection
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
collection As IEnumerable(Of T) _
)

Parameters

collection

Type: IEnumerable(T)
A strongly-typed collection of objects to add.

See Also

ResourceCollection(T) Constructor Overload List
ResourceCollection(T) Class


MindFusion.Scheduling.ResourceCollection(T) Constructor (Int32)

ResourceCollection(T) Constructor (Int32)
See Also
[image]

Creates a collection of ResourceCollection class with the specified capacity.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<T> (
int capacity
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
capacity As Integer _
)

Parameters

capacity

Type: Int32
An integer that specifies the initial capacity of the collection.

See Also

ResourceCollection(T) Constructor Overload List
ResourceCollection(T) Class


MindFusion.Scheduling.ResourceCollection(T) Methods

ResourceCollection(T) Methods
[image]

Protected Methods

Name | Description
LoadItemViewState | Restores view-state information from an object that was saved by the SaveItemViewState method.
SaveItemViewState | Saves the ViewState of the specified item.

Inherited Public Methods

Name | Description
Add | Adds a new item to the collection. (Inherited from StateCollection.)
Clear | Removes all items from the collection. (Inherited from StateCollection.)
Contains | Checks if the specified item is contained within the collection. (Inherited from StateCollection.)
CopyTo | Copies the elements of the collection to an array, starting from the particular Array index. (Inherited from StateCollection.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from StateCollection.)
IndexOf | Returns the index of the first occurrence of the specified item in the collection. (Inherited from StateCollection.)
Insert | Inserts the specified item into the array at the specified index. (Inherited from StateCollection.)
LoadViewState | Restores view-state information from an object that was saved by the SaveViewState method (Inherited from StateCollection.)
OnChanged | Raises the Changed event. (Inherited from StateCollection.)
Remove | Removes the specified item from the collection. (Inherited from StateCollection.)
RemoveAt | Removes the item at the specified index. (Inherited from StateCollection.)
SaveViewState | Saves any view-state changes that have occurred for this collection. (Inherited from StateCollection.)
TrackViewState | Causes tracking of view-state changes made to the collection so they can be stored in an object. (Inherited from StateCollection.)

Inherited Protected Methods

Name | Description
LoadItemViewState | Restores view-state information for the item that was previously saved by the SaveItemViewState method. (Inherited from StateCollection.)
OnAdd | Raises the Add event. (Inherited from StateCollection.)
OnAddComplete | Raises the AddComplete event. (Inherited from StateCollection.)
OnClear | Raises the Clear event. (Inherited from StateCollection.)
OnClearComplete | Raises the ClearComplete event. (Inherited from StateCollection.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from StateCollection.)
OnInsert | Raises the Insert event. (Inherited from StateCollection.)
OnInsertComplete | Raises the InsertComplete event. (Inherited from StateCollection.)
OnRemove | Raises the Remove event. (Inherited from StateCollection.)
OnRemoveComplete | Raises the RemoveComplete event. (Inherited from StateCollection.)
OnSet | Raises the Set event. (Inherited from StateCollection.)
OnSetComplete | Raises the SetComplete event. (Inherited from StateCollection.)
SaveItemViewState | Saves any view-state changes that have occurred of the specified item. (Inherited from StateCollection.)
TrackItemViewState | Causes tracking of view-state changes made to the specified item. (Inherited from StateCollection.)

See Also

ResourceCollection(T) Class


MindFusion.Scheduling.ResourceCollection(T).LoadItemViewState Method

ResourceCollection(T).LoadItemViewState Method
[image]

Restores view-state information from an object that was saved by the SaveItemViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void LoadItemViewState (
Object state
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadItemViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the view state to be restored.

See Also

ResourceCollection(T) Members
ResourceCollection(T) Class


MindFusion.Scheduling.ResourceCollection(T).SaveItemViewState Method

ResourceCollection(T).SaveItemViewState Method
[image]

Saves the ViewState of the specified item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override Object SaveItemViewState (
T item
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveItemViewState( _
item As T _
) As Object

Parameters

item
Type: T
The item, which ViewState to save.

Return Value

Type: Object
The saved ViewState.

See Also

ResourceCollection(T) Members
ResourceCollection(T) Class


MindFusion.Scheduling.ResourceCollection(T) Properties

ResourceCollection(T) Properties
[image]

Public Properties

Name | Description
Item | Gets the Resource identified by the specified string.

Inherited Public Properties

Name | Description
Count | Gets the count of items in the collection. (Inherited from StateCollection.)
IsReadOnly | Gets a value that indicates if the collection is read only. (Inherited from StateCollection.)
IsTrackingViewState | Gets a value that indicates whether the collection is saving changes to its view state. (Inherited from StateCollection.)
Item | Returns the item at the specified index. This is the indexer of the collection. (Inherited from StateCollection.)

See Also

ResourceCollection(T) Class


MindFusion.Scheduling.ResourceCollection(T).Item Property

ResourceCollection(T).Item Property
[image]

Gets the Resource identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public T Item [
string id
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
id As String _
) As T

Parameters

id
Type: String
The string that identifies the Resource.

Property Value

The resource with the specified id.

See Also

ResourceCollection(T) Members
ResourceCollection(T) Class


MindFusion.Scheduling.Schedule Class

Schedule Class
[image]

Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances, which are the views.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class Schedule : IDisposable, IStateManager

Visual Basic [image] Copy Code

Public Class Schedule
Implements IDisposable, IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Schedule

See Also

Schedule Members


MindFusion.Scheduling.Schedule Members

Schedule Members
Constructors Fields Properties Methods Events
[image]

Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances, which are the views.

The following tables list the members exposed by the Schedule type.

Public Constructors

Name | Description
Schedule | Initializes a new instance of the Schedule class.

Public Fields

Name | Description
CurrentVersion | Defines the current version of the schedule file format.

Public Properties

Name | Description
Contacts | Gets a collection with all Contact objects defined in the Schedule.
IsTrackingViewState | Gets a value that indicates if the Schedule is saving changes to its view state.
Items | Gets a list with all Item objects in the Schedule.
Locations | Gets a list with all Location objects defined in the Schedule.
Resources | Gets a list with all Resource objects defined in the Schedule.
Tasks | Gets a list with all Task objects defined in this Schedule.

Public Methods

Name | Description
Clear | Clears all items, tasks, locations, contacts and resources from this Schedule.
Dispose | Disposes any resources used by this Schedule object.
GetAllItems | Overloaded. Retrieves a collection of events in a specified time interval.
GetFreePeriod | Overloaded. Returns a period of time with a specified duration, which is not occupied by items.
GetItemsToRemindOf | Overloaded. Retrieves a collection of all items whose reminders must be displayed.
GetTasksToRemindOf | Overloaded. Retrieves a collection of all tasks whose reminders must be displayed.
IsClassRegistered | Overloaded. Checks whether a class is registered for serializaiton.
LoadFrom | Loads the schedule data from a file.
LoadFromStream | Loads schedule data from a binary stream.
LoadFromString | Loads data for the schedule from a string.
LoadFromXml | Loads schedule data from an XML document.
LoadViewState | Restores view-state information for the Schedule from a ViewState object that was saved by the SaveViewState method.
RegisterItemClass | Registers a schedule Item class for serialization support.
RegisterResourceClass | Registers a Resource class for serialization support.
SaveTo | Saves the schedule to a file.
SaveToStream | Saves the schedule to a binary stream.
SaveToString | Saves the schedule data into a string.
SaveToXml | Saves the schedule to an XML document.
SaveViewState | Saves any changes in the ViewState of the Schedule.
TrackViewState | Causes tracking of view-state changes made to the Schedule.
UnregisterClass | Overloaded. Unregisters a class from the serialization system.

Protected Methods

Name | Description
OnDeserializeTag | Raises the DeserializeTag event.
OnExceptionCreated | Raises the ExceptionCreated event.
OnInstantiateItem | Raises the InstantiateItem event.
OnInstantiateResource | Raises the InstantiateResource event.
OnItemEndTimeChanged | Raises the ItemEndTimeChanged event.
OnItemStartTimeChanged | Raises the ItemStartTimeChanged event.
OnItemVisualsChanged | Raises the ItemVisualsChanged event.
OnRecurrenceReset | Raises the RecurrenceReset event.
OnSerializeTag | Raises the SerializeTag event.

Public Events

Name | Description
Changed | Raised when items are added or removed from the schedule or when the schedule is loaded.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of the tag values of Item and Resource objects.
ExceptionCreated | Raised when a recurrence exception item is created.
InstantiateItem | Raised when deserializing a custom Item whose type has not been registered.
InstantiateResource | Raised when deserializing a custom Resource whose type has not been registered.
ItemEndTimeChanged | Raised when the EndTime property of an Item in this Schedule has changed.
ItemStartTimeChanged | Raised when the StartTime of an Item has changed.
ItemVisualsChanged | Raised when the appearance of an Item in the schedule has changed.
RecurrenceReset | Raised when the recurrence pattern associated with an item has been reset, causing all associated exception items to be lost.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.

See Also

Schedule Class


MindFusion.Scheduling.Schedule Fields

Schedule Fields
[image]

Public Fields

Name | Description
CurrentVersion | Defines the current version of the schedule file format.

See Also

Schedule Class


MindFusion.Scheduling.Schedule.CurrentVersion Field

Schedule.CurrentVersion Field
[image]

Defines the current version of the schedule file format.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static int CurrentVersion

Visual Basic [image] Copy Code

Public Shared CurrentVersion As Integer

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule Constructor

Schedule Constructor
[image]

Initializes a new instance of the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Schedule ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Schedule Class


MindFusion.Scheduling.Schedule Methods

Schedule Methods
[image]

Public Methods

Name | Description
Clear | Clears all items, tasks, locations, contacts and resources from this Schedule.
Dispose | Disposes any resources used by this Schedule object.
GetAllItems | Overloaded. Retrieves a collection of events in a specified time interval.
GetFreePeriod | Overloaded. Returns a period of time with a specified duration, which is not occupied by items.
GetItemsToRemindOf | Overloaded. Retrieves a collection of all items whose reminders must be displayed.
GetTasksToRemindOf | Overloaded. Retrieves a collection of all tasks whose reminders must be displayed.
IsClassRegistered | Overloaded. Checks whether a class is registered for serializaiton.
LoadFrom | Loads the schedule data from a file.
LoadFromStream | Loads schedule data from a binary stream.
LoadFromString | Loads data for the schedule from a string.
LoadFromXml | Loads schedule data from an XML document.
LoadViewState | Restores view-state information for the Schedule from a ViewState object that was saved by the SaveViewState method.
RegisterItemClass | Registers a schedule Item class for serialization support.
RegisterResourceClass | Registers a Resource class for serialization support.
SaveTo | Saves the schedule to a file.
SaveToStream | Saves the schedule to a binary stream.
SaveToString | Saves the schedule data into a string.
SaveToXml | Saves the schedule to an XML document.
SaveViewState | Saves any changes in the ViewState of the Schedule.
TrackViewState | Causes tracking of view-state changes made to the Schedule.
UnregisterClass | Overloaded. Unregisters a class from the serialization system.

Protected Methods

Name | Description
OnDeserializeTag | Raises the DeserializeTag event.
OnExceptionCreated | Raises the ExceptionCreated event.
OnInstantiateItem | Raises the InstantiateItem event.
OnInstantiateResource | Raises the InstantiateResource event.
OnItemEndTimeChanged | Raises the ItemEndTimeChanged event.
OnItemStartTimeChanged | Raises the ItemStartTimeChanged event.
OnItemVisualsChanged | Raises the ItemVisualsChanged event.
OnRecurrenceReset | Raises the RecurrenceReset event.
OnSerializeTag | Raises the SerializeTag event.

See Also

Schedule Class


MindFusion.Scheduling.Schedule.Clear Method

Schedule.Clear Method
[image]

Clears all items, tasks, locations, contacts and resources from this Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.Dispose Method

Schedule.Dispose Method
[image]

Disposes any resources used by this Schedule object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Dispose ()

Visual Basic [image] Copy Code

Public Sub Dispose ()

Remarks

It is important to call Dispose on the Schedule object when you are done using it, in order to stop the timer from triggering reminder events.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetAllItems Method

Schedule.GetAllItems Method
[image]

Retrieves a collection of events in a specified time interval.

Overload List

Name | Description
Schedule.GetAllItems (DateTime, DateTime) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
Schedule.GetAllItems (DateTime, DateTime, Contact) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for the specified Contact object.
Schedule.GetAllItems (DateTime, DateTime, Location) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for the specified Location object.
Schedule.GetAllItems (DateTime, DateTime, Resource) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for the specified Resource object.
Schedule.GetAllItems (DateTime, DateTime, Task) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Task object.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime)

Schedule.GetAllItems Method (DateTime, DateTime)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<Item> GetAllItems (
DateTime startTime,
DateTime endTime
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startTime As DateTime, _
endTime As DateTime _
) As ItemCollection(Of Item)

Parameters

startTime

Type: DateTime
Time interval start.

endTime

Type: DateTime
Time interval end.

Return Value

Type: ItemCollection(Item)
A collection that contains the events scheduled to occur in the specified period.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to RecurrenceState.Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Contact)

Schedule.GetAllItems Method (DateTime, DateTime, Contact)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for the specified Contact object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<Item> GetAllItems (
DateTime startDate,
DateTime endDate,
Contact contact
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
contact As Contact _
) As ItemCollection(Of Item)

Parameters

startDate

Type: DateTime
Specifies the start of the time period.

endDate

Type: DateTime
Specifies the end of the time period.

contact
Type: Contact
A Contact instance that must be related to the items.

Return Value

Type: ItemCollection(Item)
A collection that contains the events scheduled to occur in the specified period for the specified contact.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to RecurrenceState.Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Location)

Schedule.GetAllItems Method (DateTime, DateTime, Location)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for the specified Location object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<Item> GetAllItems (
DateTime startDate,
DateTime endDate,
Location location
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
location As Location _
) As ItemCollection(Of Item)

Parameters

startDate

Type: DateTime
Specifies the start of the time period.

endDate

Type: DateTime
Specifies the end of the time period.

location
Type: Location
A Location instance that must be related to the items.

Return Value

Type: ItemCollection(Item)
A collection that contains the events scheduled to occur in the specified period for the specified location.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to RecurrenceState.Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Resource)

Schedule.GetAllItems Method (DateTime, DateTime, Resource)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for the specified Resource object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<Item> GetAllItems (
DateTime startDate,
DateTime endDate,
Resource resource
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
resource As Resource _
) As ItemCollection(Of Item)

Parameters

startDate

Type: DateTime
Specifies the start of the time period.

endDate

Type: DateTime
Specifies the end of the time period.

resource
Type: Resource
A Resource instance that must be related to the items.

Return Value

Type: ItemCollection(Item)
A collection that contains the events scheduled to occur in the specified period for the specified resource.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Task)

Schedule.GetAllItems Method (DateTime, DateTime, Task)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Task object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<Item> GetAllItems (
DateTime startDate,
DateTime endDate,
Task task
)

Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
task As Task _
) As ItemCollection(Of Item)

Parameters

startDate

Type: DateTime
Specifies the start of the time period.

endDate

Type: DateTime
Specifies the end of the time period.

task
Type: Task
A Task instance that must be related to the items.

Return Value

Type: ItemCollection(Item)
A collection that contains the events scheduled to occur in the specified period for the specified task.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to RecurrenceState.Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetFreePeriod Method

Schedule.GetFreePeriod Method
[image]

Returns a period of time with a specified duration, which is not occupied by items.

Overload List

Name | Description
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan) | Returns the next period after the specified date with the specified duration which is not occupied by items.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Contact)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified contacts.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Location)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified locations.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Resource)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified resources.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Task)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified tasks.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan)
See Also
[image]

Returns the next period after the specified date with the specified duration which is not occupied by items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration
)

Visual Basic [image] Copy Code

Public Function GetFreePeriod( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan _
) As DateTime

Parameters

from

Type: DateTime
The start date and time of the interval in which to search for a free period.

to

Type: DateTime
The end date and time of the interval in which to search for a free period.

duration

Type: TimeSpan
The required minimum duration of the period.

Return Value

Type: DateTime
An instance of the System.DateTime structure that represents the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items in the schedule, the function might take very long to execute especially if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Contact))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Contact))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified contacts.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Contact> contacts
)

Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
contacts As ResourceCollection(Of Contact) _
) As DateTime

Parameters

from

Type: DateTime
The start date and time of the interval in which to search for a free period.

to

Type: DateTime
The end date and time of the interval in which to search for a free period.

duration

Type: TimeSpan
The required minimum duration of the period.

contacts
Type: ResourceCollection(Contact)
The contacts whose items should be considered when looking for the free period.

Return Value

Type: DateTime
An instance of the System.DateTime structure that represents the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Location))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Location))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified locations.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Location> locations
)

Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
locations As ResourceCollection(Of Location) _
) As DateTime

Parameters

from

Type: DateTime
The start date and time of the interval in which to search for a free period.

to

Type: DateTime
The end date and time of the interval in which to search for a free period.

duration

Type: TimeSpan
The required minimum duration of the period.

locations
Type: ResourceCollection(Location)
The locations whose items should be considered when looking for the free period.

Return Value

Type: DateTime
An instance of the System.DateTime structure that represents the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Resource))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Resource))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Resource> resources
)

Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
resources As ResourceCollection(Of Resource) _
) As DateTime

Parameters

from

Type: DateTime
The start date and time of the interval in which to search for a free period.

to

Type: DateTime
The end date and time of the interval in which to search for a free period.

duration

Type: TimeSpan
The required minimum duration of the period.

resources
Type: ResourceCollection(Resource)
The resources whose items should be considered when looking for the free period.

Return Value

Type: DateTime
An instance of the System.DateTime structure that represents the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function might take very long to execute especially if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Task))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Task))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified tasks.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Task> tasks
)

Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
tasks As ResourceCollection(Of Task) _
) As DateTime

Parameters

from

Type: DateTime
The start date and time of the interval in which to search for a free period.

to

Type: DateTime
The end date and time of the interval in which to search for a free period.

duration

Type: TimeSpan
The required minimum duration of the period.

tasks
Type: ResourceCollection(Task)
The tasks whose items should be considered when looking for the free period.

Return Value

Type: DateTime
An instance of the System.DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method

Schedule.GetItemsToRemindOf Method
[image]

Retrieves a collection of all items whose reminders must be displayed.

Overload List

Name | Description
Schedule.GetItemsToRemindOf () | Retrieves a collection of all items whose reminders must be displayed at the current time.
Schedule.GetItemsToRemindOf (DateTime) | Retrieves a collection of all items whose reminders must be displayed at the specified date and time.
Schedule.GetItemsToRemindOf (DateTime, DateTime) | Retrieves a collection of all items whose reminders must be displayed in the specified time interval.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method ()

Schedule.GetItemsToRemindOf Method ()
See Also
[image]

Retrieves a collection of all items whose reminders must be displayed at the current time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<Item> GetItemsToRemindOf ()

Visual Basic [image] Copy Code

Public Function GetItemsToRemindOf () As ItemCollection(Of Item)

Return Value

Type: ItemCollection(Item)
An instance of the ItemCollection class that holds the items.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method (DateTime)

Schedule.GetItemsToRemindOf Method (DateTime)
See Also
[image]

Retrieves a collection of all items whose reminders must be displayed at the specified date and time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<Item> GetItemsToRemindOf (
DateTime time
)

Visual Basic [image] Copy Code

Public Function GetItemsToRemindOf ( _
time As DateTime _
) As ItemCollection(Of Item)

Parameters

time
Type: DateTime
An instance of the System.DateTime structure that specifies the date and time when the reminders should be displayed.

Return Value

Type: ItemCollection(Item)
An instance of the ItemCollection class that contains the items.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method (DateTime, DateTime)

Schedule.GetItemsToRemindOf Method (DateTime, DateTime)
See Also
[image]

Retrieves a collection of all items whose reminders must be displayed in the specified time interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<Item> GetItemsToRemindOf (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Function GetItemsToRemindOf ( _
start As DateTime, _
end As DateTime _
) As ItemCollection(Of Item)

Parameters

start

Type: DateTime
The start of the time interval, which must contain the reminders.

end

Type: DateTime
The end of the time interval, which must contain the reminders.

Return Value

Type: ItemCollection(Item)
An instance of the ItemCollection class that contains the items.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method

Schedule.GetTasksToRemindOf Method
[image]

Retrieves a collection of all tasks whose reminders must be displayed.

Overload List

Name | Description
Schedule.GetTasksToRemindOf () | Retrieves a collection of all tasks whose reminders must be displayed at the current moment.
Schedule.GetTasksToRemindOf (DateTime) | Retrieves a collection of all tasks whose reminders must be displayed at the specified date and time.
Schedule.GetTasksToRemindOf (DateTime, DateTime) | Retrieves a collection of all tasks whose reminders must be displayed in the specified time interval.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method ()

Schedule.GetTasksToRemindOf Method ()
See Also
[image]

Retrieves a collection of all tasks whose reminders must be displayed at the current moment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Task> GetTasksToRemindOf ()

Visual Basic [image] Copy Code

Public Function GetTasksToRemindOf () As ResourceCollection(Of Task)

Return Value

Type: ResourceCollection(Task)
An instance of the ResourceCollection class that contains the tasks.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method (DateTime)

Schedule.GetTasksToRemindOf Method (DateTime)
See Also
[image]

Retrieves a collection of all tasks whose reminders must be displayed at the specified date and time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Task> GetTasksToRemindOf (
DateTime time
)

Visual Basic [image] Copy Code

Public Function GetTasksToRemindOf ( _
time As DateTime _
) As ResourceCollection(Of Task)

Parameters

time
Type: DateTime
An instance of the System.DateTime structure that specifies when the reminders should be displayed.

Return Value

Type: ResourceCollection(Task)
An instance of the ResourceCollection class that contains the tasks.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method (DateTime, DateTime)

Schedule.GetTasksToRemindOf Method (DateTime, DateTime)
See Also
[image]

Retrieves a collection of all tasks whose reminders must be displayed in the specified time interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Task> GetTasksToRemindOf (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Function GetTasksToRemindOf ( _
start As DateTime, _
end As DateTime _
) As ResourceCollection(Of Task)

Parameters

start

Type: DateTime
The start of the time interval, which must contain the reminders.

end

Type: DateTime
The end of the time interval, which must contain the reminders.

Return Value

Type: ResourceCollection(Task)
An instance of the ResourceCollection class that contains the tasks.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.IsClassRegistered Method

Schedule.IsClassRegistered Method
[image]

Checks whether a class is registered for serializaiton.

Overload List

Name | Description
Schedule.IsClassRegistered (String) | Checks whether the class with the specified id is registered for serialization.
Schedule.IsClassRegistered (Type) | Checks whether the specified Item or Resource type is registered for serialization.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.IsClassRegistered Method (String)

Schedule.IsClassRegistered Method (String)
See Also
[image]

Checks whether the class with the specified id is registered for serialization.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static bool IsClassRegistered (
string classId
)

Visual Basic [image] Copy Code

Public Shared Function IsClassRegistered( _
classId As String _
) As Boolean

Parameters

classId
Type: String
A string that represents the id of the class.

Return Value

Type: Boolean
true if the class is registered; otherwise false.

See Also

IsClassRegistered Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.IsClassRegistered Method (Type)

Schedule.IsClassRegistered Method (Type)
See Also
[image]

Checks whether the specified Item or Resource type is registered for serialization.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static bool IsClassRegistered (
Type classType
)

Visual Basic [image] Copy Code

Public Shared Function IsClassRegistered( _
classType As Type _
) As Boolean

Parameters

classType
Type: Type
The System.Type of the class.

Return Value

Type: Boolean
true if the class is registered; otherwise false.

See Also

IsClassRegistered Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.LoadFrom Method

Schedule.LoadFrom Method
[image]

Loads the schedule data from a file.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadFrom (
string fileName,
ContentType contentType
)

Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
fileName As String, _
contentType As ContentType _
)

Parameters

fileName
Type: String
A string that specifies the name of the file, which holds the data.
contentType
Type: ContentType
An instance of the ContentType enumeration.

Remarks

This method loads the schedule data from a file where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the file are loaded.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.LoadFromStream Method

Schedule.LoadFromStream Method
[image]

Loads schedule data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadFromStream (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromStream( _
stream As Stream _
)

Parameters

stream
Type: Stream
An instance of the System.IO.Stream class that contains the data.

Remarks

This method loads data from a binary stream, which was created by calling SaveToStream. Any data contained in the schedule is discarded before the items stored in the stream are loaded.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.LoadFromString Method

Schedule.LoadFromString Method
[image]

Loads data for the schedule from a string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadFromString (
string content,
ContentType contentType
)

Visual Basic [image] Copy Code

Public Sub LoadFromString ( _
content As String, _
contentType As ContentType _
)

Parameters

content
Type: String
A string that contains the schedule data.
contentType
Type: ContentType
One of the ContentType enumeration values, which specifies the format of the data to load.

Remarks

This method loads data saved to string with the SaveToString method.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.LoadFromXml Method

Schedule.LoadFromXml Method
[image]

Loads schedule data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadFromXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XmlDocument _
)

Parameters

document
Type: XmlDocument
An instance of the System.Xml.XmlDocument that holds the schedule data.

Remarks

This method loads data from an XML file created by a previous call to SaveToXml. Any data contained in the schedule is discarded before the items stored in the reader are loaded.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.LoadViewState Method

Schedule.LoadViewState Method
[image]

Restores view-state information for the Schedule from a ViewState object that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the ViewState to be restored.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.OnDeserializeTag Method

Schedule.OnDeserializeTag Method
[image]

Raises the DeserializeTag event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeTag ( _
e As SerializeTagEventArgs _
)

Parameters

e
Type: SerializeTagEventArgs
An instance of the SerializeTagEventArgs class that contains data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.OnExceptionCreated Method

Schedule.OnExceptionCreated Method
[image]

Raises the ExceptionCreated event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnExceptionCreated (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnExceptionCreated ( _
e As ItemEventArgs _
)

Parameters

e
Type: ItemEventArgs
An object, containing the event data.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.OnInstantiateItem Method

Schedule.OnInstantiateItem Method
[image]

Raises the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnInstantiateItem (
InstantiateItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInstantiateItem ( _
e As InstantiateItemEventArgs _
)

Parameters

e
Type: InstantiateItemEventArgs
An instance of the InstantiateItemEventArgs class that contains the event data.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.OnInstantiateResource Method

Schedule.OnInstantiateResource Method
[image]

Raises the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnInstantiateResource (
InstantiateResourceEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInstantiateResource ( _
e As InstantiateResourceEventArgs _
)

Parameters

e
Type: InstantiateResourceEventArgs
An instance of the InstantiateResourceEventArgs class that contains the event data.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.OnItemEndTimeChanged Method

Schedule.OnItemEndTimeChanged Method
[image]

Raises the ItemEndTimeChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnItemEndTimeChanged (
ItemTimeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemEndTimeChanged ( _
e As ItemTimeEventArgs _
)

Parameters

e
Type: ItemTimeEventArgs
An instance of the ItemTimeEventArgs class that holds the event data.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.OnItemStartTimeChanged Method

Schedule.OnItemStartTimeChanged Method
[image]

Raises the ItemStartTimeChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnItemStartTimeChanged (
ItemTimeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemStartTimeChanged ( _
e As ItemTimeEventArgs _
)

Parameters

e
Type: ItemTimeEventArgs
An instance of the ItemTimeEventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.OnItemVisualsChanged Method

Schedule.OnItemVisualsChanged Method
[image]

Raises the ItemVisualsChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnItemVisualsChanged (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemVisualsChanged ( _
e As ItemEventArgs _
)

Parameters

e

An instance of the ItemEventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.OnRecurrenceReset Method

Schedule.OnRecurrenceReset Method
[image]

Raises the RecurrenceReset event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnRecurrenceReset (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRecurrenceReset ( _
e As ItemEventArgs _
)

Parameters

e
Type: ItemEventArgs
An instance of the ItemEventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.OnSerializeTag Method

Schedule.OnSerializeTag Method
[image]

Raises the SerializeTag event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeTag ( _
e As SerializeTagEventArgs _
)

Parameters

e
Type: SerializeTagEventArgs
An instance of the SerializeTagEventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.RegisterItemClass Method

Schedule.RegisterItemClass Method
[image]

Registers a schedule Item class for serialization support.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterItemClass( _
itemClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

itemClass
Type: Type
A System.Type instance identifying the Item class.
classId

Type: String
A class identifier to use when saving and loading items of the specified type.

classVersion

Type: Int32
A revision number of the item's class serialization format.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.RegisterResourceClass Method

Schedule.RegisterResourceClass Method
[image]

Registers a Resource class for serialization support.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static void RegisterResourceClass (
Type resourceClass,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterResourceClass( _
resourceClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

resourceClass
Type: Type
A System.Type instance identifying the Resource class.
classId

Type: String
A class identifier to use when saving and loading resources of the specified type.

classVersion

Type: Int32
A revision number of the resource's class serialization format.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.SaveTo Method

Schedule.SaveTo Method
[image]

Saves the schedule to a file.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SaveTo (
string fileName,
ContentType contentType
)

Visual Basic [image] Copy Code

Public Sub SaveTo ( _
fileName As String, _
contentType As ContentType _
)

Parameters

fileName

Type: String
The path of the file to save to.

contentType
Type: ContentType
One of the ContentType enumeration values that specifies the format of the file.

Remarks

Saves the schedule data into a binary or XML file. Use LoadFrom to restore the data later.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.SaveToStream Method

Schedule.SaveToStream Method
[image]

Saves the schedule to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SaveToStream (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub SaveToStream( _
stream As Stream _
)

Parameters

stream
Type: Stream
The System.IO.Stream to save the schedule to.

Remarks

Saves the schedule data as bytes in a binary stream. Use LoadFromStream to restore the data later.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.SaveToString Method

Schedule.SaveToString Method
[image]

Saves the schedule data into a string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string SaveToString (
ContentType contentType
)

Visual Basic [image] Copy Code

Public Function SaveToString ( _
contentType As ContentType _
) As String

Parameters

contentType
Type: ContentType
One of the ContentType enumeration values, which specifies the data format.

Return Value

Type: String
A string that represents the schedule data.

Remarks

Saves the schedule data into a base64-encoded string. Use LoadFromString to restore the data later.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.SaveToXml Method

Schedule.SaveToXml Method
[image]

Saves the schedule to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SaveToXml (
XmlDocument document
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
document As XmlDocument _
)

Parameters

document
Type: XmlDocument
An instance of the System.Xml.XmlDocument class that contains the data.

Remarks

Saves the schedule data as tags in an XML document. Use LoadFromXml to restore the schedule data later.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.SaveViewState Method

Schedule.SaveViewState Method
[image]

Saves any changes in the ViewState of the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object SaveViewState ()

Visual Basic [image] Copy Code

Public Function SaveViewState () As Object

Return Value

Type: Object
The current ViewState; null (Nothing in Visual Basic) if the ViewState was not saved.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.TrackViewState Method

Schedule.TrackViewState Method
[image]

Causes tracking of view-state changes made to the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void TrackViewState ()

Visual Basic [image] Copy Code

Public Sub TrackViewState ()

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.UnregisterClass Method

Schedule.UnregisterClass Method
[image]

Unregisters a class from the serialization system.

Overload List

Name | Description
Schedule.UnregisterClass (String) | Unregisters the Item or Resource with the specified class id from the system.
Schedule.UnregisterClass (Type) | Unregisters the Item or Resource with the specified class type from the system.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.UnregisterClass Method (String)

Schedule.UnregisterClass Method (String)
See Also
[image]

Unregisters the Item or Resource with the specified class id from the system.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static void UnregisterClass (
string classId
)

Visual Basic [image] Copy Code

Public Shared Sub UnregisterClass( _
classId As String _
)

Parameters

classId

Type: String
The id of the class to unregister.

See Also

UnregisterClass Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.UnregisterClass Method (Type)

Schedule.UnregisterClass Method (Type)
See Also
[image]

Unregisters the Item or Resource with the specified class type from the system.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static void UnregisterClass (
Type classType
)

Visual Basic [image] Copy Code

Public Shared Sub UnregisterClass( _
classType As Type _
)

Parameters

classType

Type: Type
The type of the class to unregister.

See Also

UnregisterClass Method Overload List
Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule Properties

Schedule Properties
[image]

Public Properties

Name | Description
Contacts | Gets a collection with all Contact objects defined in the Schedule.
IsTrackingViewState | Gets a value that indicates if the Schedule is saving changes to its view state.
Items | Gets a list with all Item objects in the Schedule.
Locations | Gets a list with all Location objects defined in the Schedule.
Resources | Gets a list with all Resource objects defined in the Schedule.
Tasks | Gets a list with all Task objects defined in this Schedule.

See Also

Schedule Class


MindFusion.Scheduling.Schedule.Contacts Property

Schedule.Contacts Property
[image]

Gets a collection with all Contact objects defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Contact> Contacts { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Contacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection class that contains the Contact objects.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.IsTrackingViewState Property

Schedule.IsTrackingViewState Property
[image]

Gets a value that indicates if the Schedule is saving changes to its view state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

true if changes are saved to the ViewState; otherwise false

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.Items Property

Schedule.Items Property
[image]

Gets a list with all Item objects in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemCollection<Item> Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As ItemCollection(Of Item)

Property Value

An instance of the ItemCollection class that contains the items.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.Locations Property

Schedule.Locations Property
[image]

Gets a list with all Location objects defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Location> Locations { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Locations As ResourceCollection(Of Location)

Property Value

An instance of the ResourceCollection class that contains the locations.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.Resources Property

Schedule.Resources Property
[image]

Gets a list with all Resource objects defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Resource> Resources { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection class that contains all resources.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.Tasks Property

Schedule.Tasks Property
[image]

Gets a list with all Task objects defined in this Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Task> Tasks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Tasks As ResourceCollection(Of Task)

Property Value

An instance of the ResourceCollection class that contains all tasks.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule Events

Schedule Events
[image]

Public Events

Name | Description
Changed | Raised when items are added or removed from the schedule or when the schedule is loaded.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of the tag values of Item and Resource objects.
ExceptionCreated | Raised when a recurrence exception item is created.
InstantiateItem | Raised when deserializing a custom Item whose type has not been registered.
InstantiateResource | Raised when deserializing a custom Resource whose type has not been registered.
ItemEndTimeChanged | Raised when the EndTime property of an Item in this Schedule has changed.
ItemStartTimeChanged | Raised when the StartTime of an Item has changed.
ItemVisualsChanged | Raised when the appearance of an Item in the schedule has changed.
RecurrenceReset | Raised when the recurrence pattern associated with an item has been reset, causing all associated exception items to be lost.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.

See Also

Schedule Class


MindFusion.Scheduling.Schedule.Changed Event

Schedule.Changed Event
[image]

Raised when items are added or removed from the schedule or when the schedule is loaded.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

Event Data

An instance of the System.EventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.DeserializeTag Event

Schedule.DeserializeTag Event
[image]

Raised during XML deserialization to enable users to perform custom deserialization of the tag values of Item and Resource objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> DeserializeTag

Visual Basic [image] Copy Code

Public Event DeserializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

An instance of the SerializeTagEventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.ExceptionCreated Event

Schedule.ExceptionCreated Event
[image]

Raised when a recurrence exception item is created.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ExceptionCreated

Visual Basic [image] Copy Code

Public Event ExceptionCreated As EventHandler(Of ItemEventArgs)

Event Data

An instance of the ItemEventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.InstantiateItem Event

Schedule.InstantiateItem Event
[image]

Raised when deserializing a custom Item whose type has not been registered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<InstantiateItemEventArgs> InstantiateItem

Visual Basic [image] Copy Code

Public Event InstantiateItem As EventHandler(Of InstantiateItemEventArgs)

Event Data

An instance of the InstantiateItemEventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.InstantiateResource Event

Schedule.InstantiateResource Event
[image]

Raised when deserializing a custom Resource whose type has not been registered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<InstantiateResourceEventArgs> InstantiateResource

Visual Basic [image] Copy Code

Public Event InstantiateResource As EventHandler(Of InstantiateResourceEventArgs)

Event Data

An instance of the InstantiateResourceEventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.ItemEndTimeChanged Event

Schedule.ItemEndTimeChanged Event
[image]

Raised when the EndTime property of an Item in this Schedule has changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<ItemTimeEventArgs> ItemEndTimeChanged

Visual Basic [image] Copy Code

Public Event ItemEndTimeChanged As EventHandler(Of ItemTimeEventArgs)

Event Data

An instance of the ItemTimeEventArgs class that provides data for the event.

Remarks

The ItemTimeEventArgs.Time property provides the previous EndTime value of the Item.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.ItemStartTimeChanged Event

Schedule.ItemStartTimeChanged Event
[image]

Raised when the StartTime of an Item has changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<ItemTimeEventArgs> ItemStartTimeChanged

Visual Basic [image] Copy Code

Public Event ItemStartTimeChanged As EventHandler(Of ItemTimeEventArgs)

Event Data

An instance of the ItemTimeEventArgs class that provides data for the event.

Remarks

The ItemTimeEventArgs.Time property provides the previous StartTime value of the Item.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.ItemVisualsChanged Event

Schedule.ItemVisualsChanged Event
[image]

Raised when the appearance of an Item in the schedule has changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemVisualsChanged

Visual Basic [image] Copy Code

Public Event ItemVisualsChanged As EventHandler(Of ItemEventArgs)

Event Data

An instance of the ItemEventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.RecurrenceReset Event

Schedule.RecurrenceReset Event
[image]

Raised when the recurrence pattern associated with an item has been reset, causing all associated exception items to be lost.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> RecurrenceReset

Visual Basic [image] Copy Code

Public Event RecurrenceReset As EventHandler(Of ItemEventArgs)

Event Data

An instance of the ItemEventArgs class that provides data for the event.

Remarks

The recurrence is reset when the value of a property that define it has changed. The recurrence is also reset when it is associated with or dissociated from an item.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.Schedule.SerializeTag Event

Schedule.SerializeTag Event
[image]

Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> SerializeTag

Visual Basic [image] Copy Code

Public Event SerializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

An instance of the SerializeTagEventArgs class that provides data for the event.

See Also

Schedule Members
Schedule Class


MindFusion.Scheduling.SerializationContext Class

SerializationContext Class
[image]

This class contains information required to serialize a Schedule element to and from a binary stream or XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class SerializationContext

Visual Basic [image] Copy Code

Public Class SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.BinarySerializationContext
MindFusion.Scheduling.XmlSerializationContext

See Also

SerializationContext Members


MindFusion.Scheduling.SerializationContext Members

SerializationContext Members
Constructors Properties Events
[image]

This class contains information required to serialize a Schedule element to and from a binary stream or XML document.

The following tables list the members exposed by the SerializationContext type.

Public Constructors

Name | Description
SerializationContext | Initializes a new instance of the SerializationContext class.

Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded.
Schedule | Gets a reference to the schedule currently being serialized or deserialized.

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully.

See Also

SerializationContext Class


MindFusion.Scheduling.SerializationContext Constructor

SerializationContext Constructor
[image]

Initializes a new instance of the SerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public SerializationContext (
Schedule schedule
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule _
)

Parameters

schedule

Type: Schedule
An instance of the Schedule class representing the schedule to associate with.

Remarks

Generally, you do not have to instantiate from SerializationContext explicitly unless you want to serialize only particular elements and not the entire schedule.

See Also

SerializationContext Class


MindFusion.Scheduling.SerializationContext Properties

SerializationContext Properties
[image]

Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded.
Schedule | Gets a reference to the schedule currently being serialized or deserialized.

See Also

SerializationContext Class


MindFusion.Scheduling.SerializationContext.FileVersion Property

SerializationContext.FileVersion Property
[image]

Gets the format revision number of the file being loaded.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

An integer that specifies the file version.

Remarks

During serialization this is the current file version of the MindFusion.Scheduling for ASP.NET control.

See Also

SerializationContext Members
SerializationContext Class


MindFusion.Scheduling.SerializationContext.Schedule Property

SerializationContext.Schedule Property
[image]

Gets a reference to the schedule currently being serialized or deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Schedule Schedule { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Schedule As Schedule

Property Value

An instance of the Schedule class.

See Also

SerializationContext Members
SerializationContext Class


MindFusion.Scheduling.SerializationContext Events

SerializationContext Events
[image]

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully.

See Also

SerializationContext Class


MindFusion.Scheduling.SerializationContext.Completed Event

SerializationContext.Completed Event
[image]

Raised when the serialization or deserialization has completed successfully.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler Completed

Visual Basic [image] Copy Code

Public Event Completed As EventHandler

Event Data

An instance of the System.EventArgs class that contains data for the event.

See Also

SerializationContext Members
SerializationContext Class


MindFusion.Scheduling.SerializationEventArgs Class

SerializationEventArgs Class
[image]

Provides data for serialization events.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class SerializationEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SerializationEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.SerializationEventArgs

See Also

SerializationEventArgs Members


MindFusion.Scheduling.SerializationEventArgs Members

SerializationEventArgs Members
Constructors Properties
[image]

Provides data for serialization events.

The following tables list the members exposed by the SerializationEventArgs type.

Public Constructors

Name | Description
SerializationEventArgs | Overloaded. Initializes a new instance of the SerializationEventArgs class.

Public Properties

Name | Description
AddDefaultConverter | Gets or sets a value, indicating whether to add the default converter.
Serializer | Gets or sets the JavaScriptSerializer.

See Also

SerializationEventArgs Class


MindFusion.Scheduling.SerializationEventArgs Constructor

SerializationEventArgs Constructor
[image]

Initializes a new instance of the SerializationEventArgs class.

Overload List

Name | Description
SerializationEventArgs () | Creates a new instance of the SerializationEventArgs class.
SerializationEventArgs (JavaScriptSerializer, Boolean) | Creates a new instance of the SerializationEventArgs class.

See Also

SerializationEventArgs Class


MindFusion.Scheduling.SerializationEventArgs Constructor ()

SerializationEventArgs Constructor ()
See Also
[image]

Creates a new instance of the SerializationEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public SerializationEventArgs ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SerializationEventArgs Constructor Overload List
SerializationEventArgs Class


MindFusion.Scheduling.SerializationEventArgs Constructor (JavaScriptSerializer, Boolean)

SerializationEventArgs Constructor (JavaScriptSerializer, Boolean)
See Also
[image]

Creates a new instance of the SerializationEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public SerializationEventArgs (
JavaScriptSerializer serializer,
bool addDefaultConverter
)

Visual Basic [image] Copy Code

Public New ( _
serializer As JavaScriptSerializer, _
addDefaultConverter As Boolean _
)

Parameters

serializer
Type: JavaScriptSerializer
An instance of the System.Web.Script.Serialization.JavaScriptSerializer class.
addDefaultConverter
Type: Boolean
true if a default converter should be added; otherwise false.

See Also

SerializationEventArgs Constructor Overload List
SerializationEventArgs Class


MindFusion.Scheduling.SerializationEventArgs Properties

SerializationEventArgs Properties
[image]

Public Properties

Name | Description
AddDefaultConverter | Gets or sets a value, indicating whether to add the default converter.
Serializer | Gets or sets the JavaScriptSerializer.

See Also

SerializationEventArgs Class


MindFusion.Scheduling.SerializationEventArgs.AddDefaultConverter Property

SerializationEventArgs.AddDefaultConverter Property
[image]

Gets or sets a value, indicating whether to add the default converter.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool AddDefaultConverter { get; set; }

Visual Basic [image] Copy Code

Public Property AddDefaultConverter As Boolean

Property Value

true if a default converter should be added; otherwise false.

See Also

SerializationEventArgs Members
SerializationEventArgs Class


MindFusion.Scheduling.SerializationEventArgs.Serializer Property

SerializationEventArgs.Serializer Property
[image]

Gets or sets the JavaScriptSerializer.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public JavaScriptSerializer Serializer { get; set; }

Visual Basic [image] Copy Code

Public Property Serializer As JavaScriptSerializer

Property Value

An instance of the System.Web.Script.Serialization.JavaScriptSerializer class.

See Also

SerializationEventArgs Members
SerializationEventArgs Class


MindFusion.Scheduling.SerializeTagEventArgs Class

SerializeTagEventArgs Class
[image]

Provides data for the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class SerializeTagEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members


MindFusion.Scheduling.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties
[image]

Provides data for the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets the context object that enables you to write and read data.
Handled | Gets or sets a value indicating whether the event was handled.
Object | Gets the Item or Resource whose Tag is being serialized/deserialized.
Representation | Gets or sets the string representation of the Tag being serialized / deserialized.
Tag | Gets or sets the Tag being serialized/deserialized.

See Also

SerializeTagEventArgs Class


MindFusion.Scheduling.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets the context object that enables you to write and read data.
Handled | Gets or sets a value indicating whether the event was handled.
Object | Gets the Item or Resource whose Tag is being serialized/deserialized.
Representation | Gets or sets the string representation of the Tag being serialized / deserialized.
Tag | Gets or sets the Tag being serialized/deserialized.

See Also

SerializeTagEventArgs Class


MindFusion.Scheduling.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property
[image]

Gets the context object that enables you to write and read data.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlSerializationContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlSerializationContext

Property Value

An instance of the XmlSerializationContext class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Scheduling.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event was handled.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

true if the event was handled; otherwise false.

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Scheduling.SerializeTagEventArgs.Object Property

SerializeTagEventArgs.Object Property
[image]

Gets the Item or Resource whose Tag is being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object Object { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Object As Object

Property Value

An instance of the System.Object class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Scheduling.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property
[image]

Gets or sets the string representation of the Tag being serialized / deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As XmlElement

Property Value

An instance of the System.Xml.XmlElement class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Scheduling.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property
[image]

Gets or sets the Tag being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of the System.Object class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Scheduling.StateCollection(T) Class

StateCollection(T) Class
[image]

Represents a strongly-typed collection of T objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class StateCollection<T> : IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable, IStateManager

Visual Basic [image] Copy Code

Public Class StateCollection(Of T)
Implements IList(Of T), ICollection(Of T), IEnumerable(Of T), IEnumerable, IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.StateCollection(T)
MindFusion.Scheduling.ItemCollection(T)
MindFusion.Scheduling.ResourceCollection(T)

See Also

StateCollection(T) Members


MindFusion.Scheduling.StateCollection(T) Members

StateCollection(T) Members
Constructors Properties Methods Events
[image]

Represents a strongly-typed collection of T objects.

The following tables list the members exposed by the StateCollection(T) type.

Public Constructors

Name | Description
StateCollection | Overloaded. Initializes a new instance of the StateCollection class.

Public Properties

Name | Description
Count | Gets the count of items in the collection.
IsReadOnly | Gets a value that indicates if the collection is read only.
IsTrackingViewState | Gets a value that indicates whether the collection is saving changes to its view state.
Item | Returns the item at the specified index. This is the indexer of the collection.

Public Methods

Name | Description
Add | Adds a new item to the collection.
Clear | Removes all items from the collection.
Contains | Checks if the specified item is contained within the collection.
CopyTo | Copies the elements of the collection to an array, starting from the particular Array index.
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Returns the index of the first occurrence of the specified item in the collection.
Insert | Inserts the specified item into the array at the specified index.
LoadViewState | Restores view-state information from an object that was saved by the SaveViewState method
OnChanged | Raises the Changed event.
Remove | Removes the specified item from the collection.
RemoveAt | Removes the item at the specified index.
SaveViewState | Saves any view-state changes that have occurred for this collection.
TrackViewState | Causes tracking of view-state changes made to the collection so they can be stored in an object.

Protected Methods

Name | Description
LoadItemViewState | Restores view-state information for the item that was previously saved by the SaveItemViewState method.
OnAdd | Raises the Add event.
OnAddComplete | Raises the AddComplete event.
OnClear | Raises the Clear event.
OnClearComplete | Raises the ClearComplete event.
OnCollectionChanged | Raises the CollectionChanged event.
OnInsert | Raises the Insert event.
OnInsertComplete | Raises the InsertComplete event.
OnRemove | Raises the Remove event.
OnRemoveComplete | Raises the RemoveComplete event.
OnSet | Raises the Set event.
OnSetComplete | Raises the SetComplete event.
SaveItemViewState | Saves any view-state changes that have occurred of the specified item.
TrackItemViewState | Causes tracking of view-state changes made to the specified item.

Public Events

Name | Description
AddComplete | Declares the AddComplete event.
AddEvent | Declares the Add event.
Changed | Declares the Changed event.
ClearComplete | Declares the ClearComplete event.
ClearEvent | Declares the Clear event.
CollectionChanged | Declares the CollectionChanged event.
InsertComplete | Declares the InsertComplete event.
InsertEvent | Declares the Insert event.
RemoveComplete | Declares the RemoveComplete event.
RemoveEvent | Declares the Remove event.
SetComplete | Declares the SetComplete event.
SetEvent | Declares the Set event.

See Also

StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T) Constructor

StateCollection(T) Constructor
[image]

Initializes a new instance of the StateCollection class.

Overload List

Name | Description
StateCollection(T) () | Initializes a new instance of the StateCollection class.
StateCollection(T) (IEnumerable(T)) | Initializes a new instance of the StateCollection class and adds the specified strongly-typed list to it.
StateCollection(T) (Int32) | Initializes a new instance of the StateCollection class with the specified initial capacity.

See Also

StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T) Constructor ()

StateCollection(T) Constructor ()
See Also
[image]

Initializes a new instance of the StateCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public StateCollection<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

StateCollection(T) Constructor Overload List
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T) Constructor (IEnumerable(T))

StateCollection(T) Constructor (IEnumerable(T))
See Also
[image]

Initializes a new instance of the StateCollection class and adds the specified strongly-typed list to it.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public StateCollection<T> (
IEnumerable<T> collection
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
collection As IEnumerable(Of T) _
)

Parameters

collection

Type: IEnumerable(T)
A strongly-typed list that holds initial items for the collection.

See Also

StateCollection(T) Constructor Overload List
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T) Constructor (Int32)

StateCollection(T) Constructor (Int32)
See Also
[image]

Initializes a new instance of the StateCollection class with the specified initial capacity.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public StateCollection<T> (
int capacity
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
capacity As Integer _
)

Parameters

capacity

Type: Int32
The initial capacity of the collection.

See Also

StateCollection(T) Constructor Overload List
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T) Methods

StateCollection(T) Methods
[image]

Public Methods

Name | Description
Add | Adds a new item to the collection.
Clear | Removes all items from the collection.
Contains | Checks if the specified item is contained within the collection.
CopyTo | Copies the elements of the collection to an array, starting from the particular Array index.
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Returns the index of the first occurrence of the specified item in the collection.
Insert | Inserts the specified item into the array at the specified index.
LoadViewState | Restores view-state information from an object that was saved by the SaveViewState method
OnChanged | Raises the Changed event.
Remove | Removes the specified item from the collection.
RemoveAt | Removes the item at the specified index.
SaveViewState | Saves any view-state changes that have occurred for this collection.
TrackViewState | Causes tracking of view-state changes made to the collection so they can be stored in an object.

Protected Methods

Name | Description
LoadItemViewState | Restores view-state information for the item that was previously saved by the SaveItemViewState method.
OnAdd | Raises the Add event.
OnAddComplete | Raises the AddComplete event.
OnClear | Raises the Clear event.
OnClearComplete | Raises the ClearComplete event.
OnCollectionChanged | Raises the CollectionChanged event.
OnInsert | Raises the Insert event.
OnInsertComplete | Raises the InsertComplete event.
OnRemove | Raises the Remove event.
OnRemoveComplete | Raises the RemoveComplete event.
OnSet | Raises the Set event.
OnSetComplete | Raises the SetComplete event.
SaveItemViewState | Saves any view-state changes that have occurred of the specified item.
TrackItemViewState | Causes tracking of view-state changes made to the specified item.

See Also

StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).Add Method

StateCollection(T).Add Method
[image]

Adds a new item to the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void Add (
T item
)

Visual Basic [image] Copy Code

Public Overridable Sub Add( _
item As T _
)

Parameters

item

Type: T
The item to add.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).Clear Method

StateCollection(T).Clear Method
[image]

Removes all items from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void Clear ()

Visual Basic [image] Copy Code

Public Overridable Sub Clear ()

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).Contains Method

StateCollection(T).Contains Method
[image]

Checks if the specified item is contained within the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual bool Contains (
T item
)

Visual Basic [image] Copy Code

Public Overridable Function Contains( _
item As T _
) As Boolean

Parameters

item

Type: T
The item to check.

Return Value

Type: Boolean
true if the given item is contained within the collection; otherwise false.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).CopyTo Method

StateCollection(T).CopyTo Method
[image]

Copies the elements of the collection to an array, starting from the particular Array index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void CopyTo (
T[] array,
int arrayIndex
)

Visual Basic [image] Copy Code

Public Overridable Sub CopyTo( _
array() As T, _
arrayIndex As Integer _
)

Parameters

array
Type: T[]
The one-dimensional array that is the destination of the elements copied from the collection. The array must have zero-based indexing.
arrayIndex
Type: Int32
The zero-based index in array at which copying begins.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).GetEnumerator Method

StateCollection(T).GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual IEnumerator<T> GetEnumerator ()

Visual Basic [image] Copy Code

Public Overridable Function GetEnumerator () As IEnumerator(Of T)

Return Value

Type: IEnumarator(T)
An IEnumerator object that can be used to iterate through the collection.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).IndexOf Method

StateCollection(T).IndexOf Method
[image]

Returns the index of the first occurrence of the specified item in the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual int IndexOf (
T item
)

Visual Basic [image] Copy Code

Public Overridable Function IndexOf( _
item As T _
) As Integer

Parameters

item

Type: T
The item to search.

Return Value

Type: Int32
The zero-based index of the first occurrence of the item; -1 if item was not founded.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).Insert Method

StateCollection(T).Insert Method
[image]

Inserts the specified item into the array at the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void Insert (
int index,
T item
)

Visual Basic [image] Copy Code

Public Overridable Sub Insert( _
index As Integer, _
item As T _
)

Parameters

index

Type: Int32
The zero-based index, where the item will be inserted.

item

Type: T
The item to insert.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).LoadItemViewState Method

StateCollection(T).LoadItemViewState Method
[image]

Restores view-state information for the item that was previously saved by the SaveItemViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void LoadItemViewState (
Object state
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadItemViewState( _
state As Object _
)

Parameters

state

Type: Object
An object that represents the view state to be restored.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).LoadViewState Method

StateCollection(T).LoadViewState Method
[image]

Restores view-state information from an object that was saved by the SaveViewState method

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnAdd Method

StateCollection(T).OnAdd Method
[image]

Raises the Add event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnAdd (
T item
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnAdd( _
item As T _
)

Parameters

item
Type: T
The item to add.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnAddComplete Method

StateCollection(T).OnAddComplete Method
[image]

Raises the AddComplete event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnAddComplete (
T item
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnAddComplete( _
item As T _
)

Parameters

item

Type: T
The item that was added.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnChanged Method

StateCollection(T).OnChanged Method
[image]

Raises the Changed event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void OnChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Public Overridable Sub OnChanged( _
e As EventArgs _
)

Parameters

e
Type: EventArgs
An instance of the System.EventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnClear Method

StateCollection(T).OnClear Method
[image]

Raises the Clear event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnClear ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnClear ()

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnClearComplete Method

StateCollection(T).OnClearComplete Method
[image]

Raises the ClearComplete event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnClearComplete ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnClearComplete ()

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnCollectionChanged Method

StateCollection(T).OnCollectionChanged Method
[image]

Raises the CollectionChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnCollectionChanged (
CollectionChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCollectionChanged( _
e As CollectionChangedEventArgs _
)

Parameters

e
Type: CollectionChangedEventArgs
A CollectionChangedEventArgs object that holds data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnInsert Method

StateCollection(T).OnInsert Method
[image]

Raises the Insert event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnInsert (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInsert( _
index As Integer, _
item As T _
)

Parameters

index

Type: Int32
The zero-based index in the collection where the item is inserted.

item

Type: T
The item to insert.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnInsertComplete Method

StateCollection(T).OnInsertComplete Method
[image]

Raises the InsertComplete event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnInsertComplete (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInsertComplete( _
index As Integer, _
item As T _
)

Parameters

index

Type: Int32
The zero-based index in the collection where the item has been inserted.

item

Type: T
The item that has been inserted.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnRemove Method

StateCollection(T).OnRemove Method
[image]

Raises the Remove event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnRemove (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRemove( _
index As Integer, _
item As T _
)

Parameters

index

Type: Int32
The zero-based index in the collection where the item was removed.

item

Type: T
The item to remove.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnRemoveComplete Method

StateCollection(T).OnRemoveComplete Method
[image]

Raises the RemoveComplete event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnRemoveComplete (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRemoveComplete( _
index As Integer, _
item As T _
)

Parameters

index

Type: Int32
The zero-based index in the collection from where the item was removed.

item

Type: T
The item that was removed.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnSet Method

StateCollection(T).OnSet Method
[image]

Raises the Set event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnSet (
int index,
T oldItem,
T newItem
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSet( _
index As Integer, _
oldItem As T, _
newItem As T _
)

Parameters

index

Type: Int32
The zero-based index in the collection where the item is being set.

oldItem

Type: T
The old item.

newItem

Type: T
The new item.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).OnSetComplete Method

StateCollection(T).OnSetComplete Method
[image]

Raises the SetComplete event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnSetComplete (
int index,
T oldItem,
T newItem
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSetComplete( _
index As Integer, _
oldItem As T, _
newItem As T _
)

Parameters

index

Type: Int32
The zero-based index in the collection where the item was set.

oldItem

Type: T
The old item.

newItem

Type: T
The new item.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).Remove Method

StateCollection(T).Remove Method
[image]

Removes the specified item from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual bool Remove (
T item
)

Visual Basic [image] Copy Code

Public Overridable Function Remove( _
item As T _
) As Boolean

Parameters

item

Type: T
The item to remove.

Return Value

Type: Boolean
true if the item has been successfully removed; otherwise false.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).RemoveAt Method

StateCollection(T).RemoveAt Method
[image]

Removes the item at the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overridable Sub RemoveAt( _
index As Integer _
)

Parameters

index

Type: Int32
The zero-based index of the item to remove.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).SaveItemViewState Method

StateCollection(T).SaveItemViewState Method
[image]

Saves any view-state changes that have occurred of the specified item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual Object SaveItemViewState (
T item
)

Visual Basic [image] Copy Code

Protected Overridable Function SaveItemViewState( _
item As T _
) As Object

Parameters

item

Type: T
The item, whose view-state changes are saved.

Return Value

Type: Object
The ViewState, if saved; otherwise null.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).SaveViewState Method

StateCollection(T).SaveViewState Method
[image]

Saves any view-state changes that have occurred for this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overridable Function SaveViewState () As Object

Return Value

Type: Object
Returns the ViewState that was saved; null if there is no ViewState associated with the collection.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).TrackItemViewState Method

StateCollection(T).TrackItemViewState Method
[image]

Causes tracking of view-state changes made to the specified item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void TrackItemViewState (
T item
)

Visual Basic [image] Copy Code

Protected Overridable Sub TrackItemViewState( _
item As T _
)

Parameters

item

Type: T
The item to track.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).TrackViewState Method

StateCollection(T).TrackViewState Method
[image]

Causes tracking of view-state changes made to the collection so they can be stored in an object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void TrackViewState ()

Visual Basic [image] Copy Code

Public Overridable Sub TrackViewState ()

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T) Properties

StateCollection(T) Properties
[image]

Public Properties

Name | Description
Count | Gets the count of items in the collection.
IsReadOnly | Gets a value that indicates if the collection is read only.
IsTrackingViewState | Gets a value that indicates whether the collection is saving changes to its view state.
Item | Returns the item at the specified index. This is the indexer of the collection.

See Also

StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).Count Property

StateCollection(T).Count Property
[image]

Gets the count of items in the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual int Count { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Count As Integer

Property Value

An integer that specifies the count.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).IsReadOnly Property

StateCollection(T).IsReadOnly Property
[image]

Gets a value that indicates if the collection is read only.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual bool IsReadOnly { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsReadOnly As Boolean

Property Value

true if the collection is read only; otherwise false.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).IsTrackingViewState Property

StateCollection(T).IsTrackingViewState Property
[image]

Gets a value that indicates whether the collection is saving changes to its view state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsTrackingViewState As Boolean

Property Value

Type: Boolean

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).Item Property

StateCollection(T).Item Property
[image]

Returns the item at the specified index. This is the indexer of the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual T Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Item( _
index As Integer _
) As T

Parameters

index

Type: Int32
The zero-based index of the item.

Property Value

Type: T
The item at index.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T) Events

StateCollection(T) Events
[image]

Public Events

Name | Description
AddComplete | Declares the AddComplete event.
AddEvent | Declares the Add event.
Changed | Declares the Changed event.
ClearComplete | Declares the ClearComplete event.
ClearEvent | Declares the Clear event.
CollectionChanged | Declares the CollectionChanged event.
InsertComplete | Declares the InsertComplete event.
InsertEvent | Declares the Insert event.
RemoveComplete | Declares the RemoveComplete event.
RemoveEvent | Declares the Remove event.
SetComplete | Declares the SetComplete event.
SetEvent | Declares the Set event.

See Also

StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).AddComplete Event

StateCollection(T).AddComplete Event
[image]

Declares the AddComplete event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<CollectionItemEventArgs<T>> AddComplete

Visual Basic [image] Copy Code

Public Event AddComplete As EventHandler(Of CollectionItemEventArgs(Of T))

Event Data

An instance of the CollectionItemEventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).AddEvent Event

StateCollection(T).AddEvent Event
[image]

Declares the Add event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<CollectionItemEventArgs<T>> AddEvent

Visual Basic [image] Copy Code

Public Event AddEvent As EventHandler(Of CollectionItemEventArgs(Of T))

Event Data

An instance of the class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).Changed Event

StateCollection(T).Changed Event
[image]

Declares the Changed event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

Event Data

An instance of the System.EventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).ClearComplete Event

StateCollection(T).ClearComplete Event
[image]

Declares the ClearComplete event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler ClearComplete

Visual Basic [image] Copy Code

Public Event ClearComplete As EventHandler

Event Data

An instance of the System.EventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).ClearEvent Event

StateCollection(T).ClearEvent Event
[image]

Declares the Clear event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler ClearEvent

Visual Basic [image] Copy Code

Public Event ClearEvent As EventHandler

Event Data

An instance of the System.EventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).CollectionChanged Event

StateCollection(T).CollectionChanged Event
[image]

Declares the CollectionChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<CollectionChangedEventArgs> CollectionChanged

Visual Basic [image] Copy Code

Public Event CollectionChanged As EventHandler(Of CollectionChangedEventArgs)

Event Data

An instance of the CollectionChangedEventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).InsertComplete Event

StateCollection(T).InsertComplete Event
[image]

Declares the InsertComplete event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<CollectionItemInsertEventArgs<T>> InsertComplete

Visual Basic [image] Copy Code

Public Event InsertComplete As EventHandler(Of CollectionItemInsertEventArgs(Of T))

Event Data

An instance of the CollectionItemInsertEventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).InsertEvent Event

StateCollection(T).InsertEvent Event
[image]

Declares the Insert event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<CollectionItemInsertEventArgs<T>> InsertEvent

Visual Basic [image] Copy Code

Public Event InsertEvent As EventHandler(Of CollectionItemInsertEventArgs(Of T))

Event Data

An instance of the CollectionItemInsertEventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).RemoveComplete Event

StateCollection(T).RemoveComplete Event
[image]

Declares the RemoveComplete event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<CollectionItemInsertEventArgs<T>> RemoveComplete

Visual Basic [image] Copy Code

Public Event RemoveComplete As EventHandler(Of CollectionItemInsertEventArgs(Of T))

Event Data

An instance of the CollectionItemInsertEventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).RemoveEvent Event

StateCollection(T).RemoveEvent Event
[image]

Declares the Remove event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<CollectionItemInsertEventArgs<T>> RemoveEvent

Visual Basic [image] Copy Code

Public Event RemoveEvent As EventHandler(Of CollectionItemInsertEventArgs(Of T))

Event Data

An instance of the CollectionItemInsertEventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).SetComplete Event

StateCollection(T).SetComplete Event
[image]

Declares the SetComplete event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<CollectionItemSetEventArgs<T>> SetComplete

Visual Basic [image] Copy Code

Public Event SetComplete As EventHandler(Of CollectionItemSetEventArgs(Of T))

Event Data

An instance of the CollectionItemSetEventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.StateCollection(T).SetEvent Event

StateCollection(T).SetEvent Event
[image]

Declares the Set event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<CollectionItemSetEventArgs<T>> SetEvent

Visual Basic [image] Copy Code

Public Event SetEvent As EventHandler(Of CollectionItemSetEventArgs(Of T))

Event Data

An instance of the CollectionItemSetEventArgs class that provides data for the event.

See Also

StateCollection(T) Members
StateCollection(T) Class


MindFusion.Scheduling.Style Class

Style Class
[image]

Specifies the appearance of calendar elements.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class Style : IStateManager, ICloneable

Visual Basic [image] Copy Code

Public Class Style
Implements IStateManager, ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Style
MindFusion.Scheduling.HeaderStyle

See Also

Style Members


MindFusion.Scheduling.Style Members

Style Members
Constructors Properties Methods Events
[image]

Specifies the appearance of calendar elements.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Overloaded. Initializes a new instance of the Style class.

Public Properties

Name | Description
Borders | Gets the border properties for the current Style object.
Brush | Gets or sets the brush that fills the interior.
IsTrackingViewState | Gets a value that indicates whether the Style object is saving changes to its view state.

Public Methods

Name | Description
Clone | Creates an exact copy of the current Style object.
Equals | Determines whether the specified Style object is equivalent to the current one.
GetHashCode | Returns the hash code for this Style instance.
GetProperties | Gets the properties of this Style instance as IDictionary<string, object> list.
LoadViewState | Restores view-state information from an object that was previously saved by the SaveViewState method.
OnChanged | Raises the Changed event.
Reset | Removes any Style elements written in the state bag.
SaveViewState | Saves any view-state changes that have occurred on the Style object.
SetProperties | Gets the properties of this Style class as IDictionary<string, object> list.
ShouldSerialize | Gets a value that indicates whether this Style object has changed from its default state.
TrackViewState | Causes tracking of view-state changes to the current Style object so they can be stored for later use.

Public Events

Name | Description
Changed | Raised when the Style changes.

See Also

Style Class


MindFusion.Scheduling.Style Constructor

Style Constructor
[image]

Initializes a new instance of the Style class.

Overload List

Name | Description
Style () | Initializes a new instance of the Style class.
Style (StateBag) | Initializes a new instance of the Style class with property values taken from the specified StateBag object.

See Also

Style Class


MindFusion.Scheduling.Style Constructor ()

Style Constructor ()
See Also
[image]

Initializes a new instance of the Style class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Style ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Style Constructor Overload List
Style Class


MindFusion.Scheduling.Style Constructor (StateBag)

Style Constructor (StateBag)
See Also
[image]

Initializes a new instance of the Style class with property values taken from the specified StateBag object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Style (
StateBag bag
)

Visual Basic [image] Copy Code

Public New ( _
bag As StateBag _
)

Parameters

bag
Type: StateBag
A System.Web.UI.StateBag object that provides values for the style properties.

See Also

Style Constructor Overload List
Style Class


MindFusion.Scheduling.Style Methods

Style Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of the current Style object.
Equals | Determines whether the specified Style object is equivalent to the current one.
GetHashCode | Returns the hash code for this Style instance.
GetProperties | Gets the properties of this Style instance as IDictionary<string, object> list.
LoadViewState | Restores view-state information from an object that was previously saved by the SaveViewState method.
OnChanged | Raises the Changed event.
Reset | Removes any Style elements written in the state bag.
SaveViewState | Saves any view-state changes that have occurred on the Style object.
SetProperties | Gets the properties of this Style class as IDictionary<string, object> list.
ShouldSerialize | Gets a value that indicates whether this Style object has changed from its default state.
TrackViewState | Causes tracking of view-state changes to the current Style object so they can be stored for later use.

See Also

Style Class


MindFusion.Scheduling.Style.Clone Method

Style.Clone Method
[image]

Creates an exact copy of the current Style object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Object Clone ()

Visual Basic [image] Copy Code

Public Overridable Function Clone () As Object

Return Value

Type: Object
The newly created Style instance identical to the current one.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.Equals Method

Style.Equals Method
[image]

Determines whether the specified Style object is equivalent to the current one.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
Type: Object
A Style object to compare with the current one.

Return Value

Type: Boolean
true if the two Style objects are the same; otherwise, false.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.GetHashCode Method

Style.GetHashCode Method
[image]

Returns the hash code for this Style instance.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

Type: Int32
An integer that represents the hash code.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.GetProperties Method

Style.GetProperties Method
[image]

Gets the properties of this Style instance as IDictionary<string, object> list.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual IDictionary<string, Object> GetProperties ()

Visual Basic [image] Copy Code

Public Overridable Function GetProperties () As IDictionary(Of String, Object)

Return Value

Type: IDictionary<String, Object>
An IDictionary<string, object> list that holds the name of each property and its value.

Remarks

The method reads the values for each property identified by its name in the given IDictionary and sets them as values for the identical properties in the current Style instance.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.LoadViewState Method

Style.LoadViewState Method
[image]

Restores view-state information from an object that was previously saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.OnChanged Method

Style.OnChanged Method
[image]

Raises the Changed event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void OnChanged (
Object sender,
EventArgs e
)

Visual Basic [image] Copy Code

Public Overridable Sub OnChanged( _
sender As Object, _
e As EventArgs _
)

Parameters

sender

Type: Object
The object that has raised the event.

e
Type: EventArgs
An instance of the System.EventArgs class that contains the event data.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.Reset Method

Style.Reset Method
[image]

Removes any Style elements written in the state bag.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void Reset ()

Visual Basic [image] Copy Code

Public Overridable Sub Reset ()

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.SaveViewState Method

Style.SaveViewState Method
[image]

Saves any view-state changes that have occurred on the Style object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overridable Function SaveViewState () As Object

Return Value

Type: Object
Returns a System.Object with the current view state. If there is no view state associated with the Style, this method returns null (Nothing in VB.NET).

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.SetProperties Method

Style.SetProperties Method
[image]

Gets the properties of this Style class as IDictionary<string, object> list.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void SetProperties (
IDictionary<string, Object> dictionary
)

Visual Basic [image] Copy Code

Public Overridable Sub SetProperties( _
dictionary As IDictionary(Of String, Object) _
)

Parameters

dictionary
Type: IDictionary<String, Object>
An IDictionary<string, object> list, where each property is presented with a string identical with its name and an object that represents its value.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.ShouldSerialize Method

Style.ShouldSerialize Method
[image]

Gets a value that indicates whether this Style object has changed from its default state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual bool ShouldSerialize ()

Visual Basic [image] Copy Code

Public Overridable Function ShouldSerialize () As Boolean

Return Value

Type: Boolean
true if the Style has changed; otherwise false.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.TrackViewState Method

Style.TrackViewState Method
[image]

Causes tracking of view-state changes to the current Style object so they can be stored for later use.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void TrackViewState ()

Visual Basic [image] Copy Code

Public Overridable Sub TrackViewState ()

See Also

Style Members
Style Class


MindFusion.Scheduling.Style Properties

Style Properties
[image]

Public Properties

Name | Description
Borders | Gets the border properties for the current Style object.
Brush | Gets or sets the brush that fills the interior.
IsTrackingViewState | Gets a value that indicates whether the Style object is saving changes to its view state.

See Also

Style Class


MindFusion.Scheduling.Style.Borders Property

Style.Borders Property
[image]

Gets the border properties for the current Style object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual CssBorderStyle Borders { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Borders As CssBorderStyle

Property Value

An instance of the CssBorderStyle class.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.Brush Property

Style.Brush Property
[image]

Gets or sets the brush that fills the interior.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual CssBackground Brush { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Brush As CssBackground

Property Value

An instance of the CssBackground class.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style.IsTrackingViewState Property

Style.IsTrackingViewState Property
[image]

Gets a value that indicates whether the Style object is saving changes to its view state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

true if the Style object tracks changes; otherwise false.

See Also

Style Members
Style Class


MindFusion.Scheduling.Style Events

Style Events
[image]

Public Events

Name | Description
Changed | Raised when the Style changes.

See Also

Style Class


MindFusion.Scheduling.Style.Changed Event

Style.Changed Event
[image]

Raised when the Style changes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

Event Data

An instance of the System.EventArgs class that provides data for the event.

See Also

Style Members
Style Class


MindFusion.Scheduling.Task Class

Task Class
[image]

Represents a task in the calendar.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class Task : Resource

Visual Basic [image] Copy Code

Public Class Task
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Task

See Also

Task Members


MindFusion.Scheduling.Task Members

Task Members
Constructors Properties Methods
[image]

Represents a task in the calendar.

The following tables list the members exposed by the Task type.

Public Constructors

Name | Description
Task | Initializes a new instance of the Task class.

Public Properties

Name | Description
ActualCost | Gets or sets the actual cost of this task.
ActualDuration | Gets or sets the actual duration for this task measured in minutes.
ActualEnd | Gets or sets the task's actual completion date.
ActualStart | Gets or sets the task's actual start date.
Details | Gets or sets the detailed description of the Task.
DueDate | Gets or sets the task's due date.
EstimatedCost | Gets or sets the estimated cost of the task.
EstimatedDuration | Gets or sets the estimated duration of the task measured in minutes.
ImageIndex | Gets or sets the index of the image associated with this task.
Priority | Gets or sets the task priority.
Progress | Gets or sets the task progress measured in percents.
Reminder | Gets or sets the reminder for this task.
StartDate | Gets or sets the task's start date.
Status | Gets or sets the status of the task.
Subject | Gets or sets the subject of the task.

Public Methods

Name | Description
LoadFrom | Overloaded.
LoadViewState | Restores view-state information that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Saves any view-state changes that have occurred at this task.
TrackViewState | Causes tracking of view-state changes to the Task object so they can be stored in a StateBag object.

Inherited Public Methods

Name | Description
getId | Gets the id of the resource. (Inherited from Resource.)
getName | Gets the name of the resource. (Inherited from Resource.)
getTag | Gets the custom data associated with the resource. (Inherited from Resource.)

See Also

Task Class


MindFusion.Scheduling.Task Constructor

Task Constructor
[image]

Initializes a new instance of the Task class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Task ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Task Class


MindFusion.Scheduling.Task Methods

Task Methods
[image]

Public Methods

Name | Description
LoadFrom | Overloaded.
LoadViewState | Restores view-state information that was saved by the SaveViewState method.
SaveTo | Overloaded.
SaveViewState | Saves any view-state changes that have occurred at this task.
TrackViewState | Causes tracking of view-state changes to the Task object so they can be stored in a StateBag object.

Inherited Public Methods

Name | Description
getId | Gets the id of the resource. (Inherited from Resource.)
getName | Gets the name of the resource. (Inherited from Resource.)
getTag | Gets the custom data associated with the resource. (Inherited from Resource.)

See Also

Task Class


MindFusion.Scheduling.Task.LoadFrom Method

Task.LoadFrom Method
[image]

Overload List

Name | Description
Task.LoadFrom (BinaryReader, BinarySerializationContext) | Loads task data from a binary stream.
Task.LoadFrom (XmlElement, XmlSerializationContext) | Loads task data from an XML document.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.LoadFrom Method (BinaryReader, BinarySerializationContext)

Task.LoadFrom Method (BinaryReader, BinarySerializationContext)
See Also
[image]

Loads task data from a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadFrom (
BinaryReader reader,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
reader As BinaryReader, _
context As BinarySerializationContext _
)

Parameters

reader
Type: BinaryReader
A System.IO.BinaryReader class that allows reading primitive data types from the binary stream.
context
Type: BinarySerializationContext
A BinarySerializationContext object that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method loads task data from a binary stream where it was previously saved by SaveTo.

See Also

LoadFrom Method Overload List
Task Members
Task Class


MindFusion.Scheduling.Task.LoadFrom Method (XmlElement, XmlSerializationContext)

Task.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also
[image]

Loads task data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
A System.Xml.XmlElement that allows reading data from the XML document.
context
Type: XmlSerializationContext
A XmlSerializationContext object that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads task data from an XML document where it was previously saved by SaveTo.

See Also

LoadFrom Method Overload List
Task Members
Task Class


MindFusion.Scheduling.Task.LoadViewState Method

Task.LoadViewState Method
[image]

Restores view-state information that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the view state to be restored.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.SaveTo Method

Task.SaveTo Method
[image]

Overload List

Name | Description
Task.SaveTo (BinaryWriter, BinarySerializationContext) | Saves task data to a binary stream.
Task.SaveTo (XmlElement, XmlSerializationContext) | Saves the task data to an XML document.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.SaveTo Method (BinaryWriter, BinarySerializationContext)

Task.SaveTo Method (BinaryWriter, BinarySerializationContext)
See Also
[image]

Saves task data to a binary stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void SaveTo (
BinaryWriter writer,
BinarySerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
writer As BinaryWriter, _
context As BinarySerializationContext _
)

Parameters

writer
Type: BinaryWriter
A System.IO.BinaryWriter class that allows writing primitive data types to the binary stream.
context
Type: BinarySerializationContext
A BinarySerializationContext object that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the stream.

Remarks

This method saves task data as elements in an XML document. Later they can be restored with the the LoadFrom method.

See Also

SaveTo Method Overload List
Task Members
Task Class


MindFusion.Scheduling.Task.SaveTo Method (XmlElement, XmlSerializationContext)

Task.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the task data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Type: XmlElement
A System.Xml.XmlElement object that allows adding data to the XML document.
context
Type: XmlSerializationContext
An XmlSerializationContext object that contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the task properties as elements in an XML document. Later they can be restored with the LoadFrom method.

See Also

SaveTo Method Overload List
Task Members
Task Class


MindFusion.Scheduling.Task.SaveViewState Method

Task.SaveViewState Method
[image]

Saves any view-state changes that have occurred at this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the current view state of the task. If there is no view state associated with the task, this method returns null (Nothing in VB.NET).

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.TrackViewState Method

Task.TrackViewState Method
[image]

Causes tracking of view-state changes to the Task object so they can be stored in a StateBag object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

Task Members
Task Class


MindFusion.Scheduling.Task Properties

Task Properties
[image]

Public Properties

Name | Description
ActualCost | Gets or sets the actual cost of this task.
ActualDuration | Gets or sets the actual duration for this task measured in minutes.
ActualEnd | Gets or sets the task's actual completion date.
ActualStart | Gets or sets the task's actual start date.
Details | Gets or sets the detailed description of the Task.
DueDate | Gets or sets the task's due date.
EstimatedCost | Gets or sets the estimated cost of the task.
EstimatedDuration | Gets or sets the estimated duration of the task measured in minutes.
ImageIndex | Gets or sets the index of the image associated with this task.
Priority | Gets or sets the task priority.
Progress | Gets or sets the task progress measured in percents.
Reminder | Gets or sets the reminder for this task.
StartDate | Gets or sets the task's start date.
Status | Gets or sets the status of the task.
Subject | Gets or sets the subject of the task.

See Also

Task Class


MindFusion.Scheduling.Task.ActualCost Property

Task.ActualCost Property
[image]

Gets or sets the actual cost of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public float ActualCost { get; set; }

Visual Basic [image] Copy Code

Public Property ActualCost As Single

Property Value

A float value. Default is 0f.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.ActualDuration Property

Task.ActualDuration Property
[image]

Gets or sets the actual duration for this task measured in minutes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int ActualDuration { get; set; }

Visual Basic [image] Copy Code

Public Property ActualDuration As Integer

Property Value

An integer representing the actual duration of the task.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.ActualEnd Property

Task.ActualEnd Property
[image]

Gets or sets the task's actual completion date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime ActualEnd { get; set; }

Visual Basic [image] Copy Code

Public Property ActualEnd As DateTime

Property Value

An instance of the System.DateTime structure.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.ActualStart Property

Task.ActualStart Property
[image]

Gets or sets the task's actual start date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime ActualStart { get; set; }

Visual Basic [image] Copy Code

Public Property ActualStart As DateTime

Property Value

An instance of the System.DateTime structure.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.Details Property

Task.Details Property
[image]

Gets or sets the detailed description of the Task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Details { get; set; }

Visual Basic [image] Copy Code

Public Property Details As String

Property Value

A string that specifies the description. Default value is an empty string ("").

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.DueDate Property

Task.DueDate Property
[image]

Gets or sets the task's due date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime DueDate { get; set; }

Visual Basic [image] Copy Code

Public Property DueDate As DateTime

Property Value

An instance of the System.DateTime structure.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.EstimatedCost Property

Task.EstimatedCost Property
[image]

Gets or sets the estimated cost of the task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public float EstimatedCost { get; set; }

Visual Basic [image] Copy Code

Public Property EstimatedCost As Single

Property Value

A float value. Default is 0f.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.EstimatedDuration Property

Task.EstimatedDuration Property
[image]

Gets or sets the estimated duration of the task measured in minutes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int EstimatedDuration { get; set; }

Visual Basic [image] Copy Code

Public Property EstimatedDuration As Integer

Property Value

An integer that specifies the duration of the task. Default value is 0.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.ImageIndex Property

Task.ImageIndex Property
[image]

Gets or sets the index of the image associated with this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int ImageIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ImageIndex As Integer

Property Value

An integer that specifies the index. Default value is -1.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.Priority Property

Task.Priority Property
[image]

Gets or sets the task priority.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TaskPriority Priority { get; set; }

Visual Basic [image] Copy Code

Public Property Priority As TaskPriority

Property Value

One of the TaskPriority enumeration values. Default is TaskPriority.Normal.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.Progress Property

Task.Progress Property
[image]

Gets or sets the task progress measured in percents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public float Progress { get; set; }

Visual Basic [image] Copy Code

Public Property Progress As Single

Property Value

A float value. Values should range from [0, 100]. Default value is 0f.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.Reminder Property

Task.Reminder Property
[image]

Gets or sets the reminder for this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Reminder Reminder { get; set; }

Visual Basic [image] Copy Code

Public Property Reminder As Reminder

Property Value

An instance of the Reminder class.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.StartDate Property

Task.StartDate Property
[image]

Gets or sets the task's start date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime StartDate { get; set; }

Visual Basic [image] Copy Code

Public Property StartDate As DateTime

Property Value

An instance of the System.DateTime structure.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.Status Property

Task.Status Property
[image]

Gets or sets the status of the task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TaskStatus Status { get; set; }

Visual Basic [image] Copy Code

Public Property Status As TaskStatus

Property Value

One of the TaskStatus enumeration values. Default is TaskStatus.NotStarted.

See Also

Task Members
Task Class


MindFusion.Scheduling.Task.Subject Property

Task.Subject Property
[image]

Gets or sets the subject of the task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Subject { get; set; }

Visual Basic [image] Copy Code

Public Property Subject As String

Property Value

A string that specifies the subject. Default is an empty string.

See Also

Task Members
Task Class


MindFusion.Scheduling.TaskPriority Enumeration

TaskPriority Enumeration
[image]

Specifies the priority of a Task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum TaskPriority

Visual Basic [image] Copy Code

Public Enum TaskPriority

Members

Member name | Value | Description
Low | 0 | Indicates low task priority.
Normal | 1 | Indicates normal task priority.
High | 2 | Indicates high task priority.

See Also


MindFusion.Scheduling.TaskStatus Enumeration

TaskStatus Enumeration
[image]

Specifies status values for a Task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum TaskStatus

Visual Basic [image] Copy Code

Public Enum TaskStatus

Members

Member name | Value | Description
NotStarted | 0 | Indicates that the task has not started yet.
InProgress | 1 | Indicates a task in progress.
Completed | 2 | Indicates a completed task.
WaitingOther | 3 | Indicates a task that depends on another task.
Deferred | 4 | Indicates a deferred task.

See Also


MindFusion.Scheduling.TextAlignment Enumeration

TextAlignment Enumeration
[image]

Specifies the alignment of text in its layout rectangle. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum TextAlignment

Visual Basic [image] Copy Code

Public Enum TextAlignment

Members

Member name | Value | Description
Unspecified | 0 | No alignment is specified.
TopLeft | 1 | Text is vertically aligned at the top, and horizontally aligned to the left.
TopCenter | 2 | Text is vertically aligned at the top, and horizontally aligned in the center.
TopRight | 4 | Text is vertically aligned at the top, and horizontally aligned to the right.
MiddleLeft | 16 | Text is vertically aligned in the middle, and horizontally aligned to the left.
MiddleCenter | 32 | Text is vertically aligned in the middle, and horizontally aligned in the center.
MiddleRight | 64 | Text is vertically aligned in the middle, and horizontally aligned to the right.
BottomLeft | 256 | Text is vertically aligned at the bottom, and horizontally aligned to the left.
BottomCenter | 512 | Text is vertically aligned at the bottom, and horizontally aligned in the center.
BottomRight | 1024 | Text is vertically aligned at the bottom, and horizontally aligned to the right.

See Also


MindFusion.Scheduling.ThemeEventArgs Class

ThemeEventArgs Class
[image]

Provides data for the ThemeChanged event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ThemeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ThemeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ThemeEventArgs

See Also

ThemeEventArgs Members


MindFusion.Scheduling.ThemeEventArgs Members

ThemeEventArgs Members
Properties
[image]

Provides data for the ThemeChanged event.

The following tables list the members exposed by the ThemeEventArgs type.

Public Properties

Name | Description
NewValue | Gets the new value of the Theme property.
OldValue | Gets the value of the Theme property before the change.

See Also

ThemeEventArgs Class


MindFusion.Scheduling.ThemeEventArgs Properties

ThemeEventArgs Properties
[image]

Public Properties

Name | Description
NewValue | Gets the new value of the Theme property.
OldValue | Gets the value of the Theme property before the change.

See Also

ThemeEventArgs Class


MindFusion.Scheduling.ThemeEventArgs.NewValue Property

ThemeEventArgs.NewValue Property
[image]

Gets the new value of the Theme property.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ThemeType NewValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewValue As ThemeType

Property Value

A member of the ThemeType enumeration.

See Also

ThemeEventArgs Members
ThemeEventArgs Class


MindFusion.Scheduling.ThemeEventArgs.OldValue Property

ThemeEventArgs.OldValue Property
[image]

Gets the value of the Theme property before the change.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ThemeType OldValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldValue As ThemeType

Property Value

A member of the ThemeType enumeration.

See Also

ThemeEventArgs Members
ThemeEventArgs Class


MindFusion.Scheduling.Thickness Class

Thickness Class
[image]

Describes the thickness of a frame around a rectangle. Four double values describe the four sides of the frame.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class Thickness : IStateManager, ICloneable

Visual Basic [image] Copy Code

Public Class Thickness
Implements IStateManager, ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Thickness

See Also

Thickness Members


MindFusion.Scheduling.Thickness Members

Thickness Members
Constructors Properties Methods Events
[image]

Describes the thickness of a frame around a rectangle. Four double values describe the four sides of the frame.

The following tables list the members exposed by the Thickness type.

Public Constructors

Name | Description
Thickness | Initializes a new instance of the Thickness class.

Public Properties

Name | Description
All | Gets all sets a uniform value for all four sides of this Thickness.
Bottom | Gets or sets the width, in Unit(s), of the lower side of the bounding rectangle.
IsAllThicknessSet | Checks if all four Thickness properties are set.
IsBottomSet | Checks if the Bottom property is set.
IsLeftSet | Checks if the Left property is set.
IsRightSet | Returns true if Right property is set.
IsTopSet | Checks if the Top property is set.
Left | Gets or sets the width, in Unit(s), of the left side of the bounding rectangle.
Right | Gets or sets the width, in Unit(s), of the right side of the bounding rectangle.
Top | Gets or sets the width, in Unit(s), of the upper side of the bounding rectangle.

Public Methods

Name | Description
Clone | Creates an exact copy of the current Thickness object.
CopyFrom | Reads the properties of the specified Thickness object and sets them as values of the current Thickness.
Equals | Determines if the specified object is equal to the current Thickness object.
GetAsJsonString | Gets a JSON string representation of the current Thickness object.
GetBottom | Gets the value of the Bottom property of this Thickness.
GetHashCode | Serves as hash function for the Thickness type.
GetLeft | Gets the value of the Left property of this Thickness.
GetProperties | Gets the properties of this Thickness as an IDictionary<string, object> list where each pair is the name of the property and its value.
GetRight | Gets the value of the Right property of this Thickness.
GetTop | Gets the value of the Top property of this Thickness.
SetProperties | Copies the values from the specified list to the properties of the current Thickness.
SetToDefault | Resets all Thickness properties to their default values.

Public Events

Name | Description
Changed | Raised when a property of the Thickness class has changed.

See Also

Thickness Class


MindFusion.Scheduling.Thickness Constructor

Thickness Constructor
[image]

Initializes a new instance of the Thickness class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Thickness ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Thickness Class


MindFusion.Scheduling.Thickness Methods

Thickness Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of the current Thickness object.
CopyFrom | Reads the properties of the specified Thickness object and sets them as values of the current Thickness.
Equals | Determines if the specified object is equal to the current Thickness object.
GetAsJsonString | Gets a JSON string representation of the current Thickness object.
GetBottom | Gets the value of the Bottom property of this Thickness.
GetHashCode | Serves as hash function for the Thickness type.
GetLeft | Gets the value of the Left property of this Thickness.
GetProperties | Gets the properties of this Thickness as an IDictionary<string, object> list where each pair is the name of the property and its value.
GetRight | Gets the value of the Right property of this Thickness.
GetTop | Gets the value of the Top property of this Thickness.
SetProperties | Copies the values from the specified list to the properties of the current Thickness.
SetToDefault | Resets all Thickness properties to their default values.

See Also

Thickness Class


MindFusion.Scheduling.Thickness.Clone Method

Thickness.Clone Method
[image]

Creates an exact copy of the current Thickness object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

Type: Object
The newly created Thickness object identical to the current one.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.CopyFrom Method

Thickness.CopyFrom Method
[image]

Reads the properties of the specified Thickness object and sets them as values of the current Thickness.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void CopyFrom (
Thickness value
)

Visual Basic [image] Copy Code

Public Sub CopyFrom ( _
value As Thickness _
)

Parameters

value
Type: Thickness
The Thickness object to copy from.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.Equals Method

Thickness.Equals Method
[image]

Determines if the specified object is equal to the current Thickness object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj
Type: Object
The object to compare the current Thickness instance to.

Return Value

Type: Boolean
true of this Thickness is equal to obj; otherwise false.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.GetAsJsonString Method

Thickness.GetAsJsonString Method
[image]

Gets a JSON string representation of the current Thickness object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string GetAsJsonString ()

Visual Basic [image] Copy Code

Public Function GetAsJsonString () As String

Return Value

Type: String
A JSON string representing this Thickness object.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.GetBottom Method

Thickness.GetBottom Method
[image]

Gets the value of the Bottom property of this Thickness.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string GetBottom ()

Visual Basic [image] Copy Code

Public Function GetBottom () As String

Return Value

Type: String
A string that represents the value of the bottom property.

Remarks

If the Bottom property is not set this method returns the value of the All property.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.GetHashCode Method

Thickness.GetHashCode Method
[image]

Serves as hash function for the Thickness type.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

Type: Int32
The hash code for this Thickness instance.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.GetLeft Method

Thickness.GetLeft Method
[image]

Gets the value of the Left property of this Thickness.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string GetLeft ()

Visual Basic [image] Copy Code

Public Function GetLeft () As String

Return Value

Type: String
A string that represents the value of the Left property.

Remarks

If the Left property is not set this method returns the value of the All property.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.GetProperties Method

Thickness.GetProperties Method
[image]

Gets the properties of this Thickness as an IDictionary<string, object> list where each pair is the name of the property and its value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public IDictionary<string, Object> GetProperties ()

Visual Basic [image] Copy Code

Public Function GetProperties () As IDictionary(Of String, Object)

Return Value

Type: IDictionary<String, Object>
An IDictionary<string, object> list that contains the properties.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.GetRight Method

Thickness.GetRight Method
[image]

Gets the value of the Right property of this Thickness.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string GetRight ()

Visual Basic [image] Copy Code

Public Function GetRight () As String

Return Value

Type: String
A string that represents the value of the Right property.

Remarks

If the Right property is not set this method returns the value of the All property.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.GetTop Method

Thickness.GetTop Method
[image]

Gets the value of the Top property of this Thickness.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string GetTop ()

Visual Basic [image] Copy Code

Public Function GetTop () As String

Return Value

Type: String
A string that represents the value of the Top property.

Remarks

If the Top property is not set this method returns the value of the All property.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.SetProperties Method

Thickness.SetProperties Method
[image]

Copies the values from the specified list to the properties of the current Thickness.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SetProperties (
IDictionary<string, Object> diction
)

Visual Basic [image] Copy Code

Public Sub SetProperties( _
diction As IDictionary(Of String, Object) _
)

Parameters

diction
Type: IDictionary<String, Object>
An IDictionary<string, object> list, where each property is presented with a string identical with its name and an object that represents its value.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.SetToDefault Method

Thickness.SetToDefault Method
[image]

Resets all Thickness properties to their default values.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SetToDefault ()

Visual Basic [image] Copy Code

Public Sub SetToDefault ()

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness Properties

Thickness Properties
[image]

Public Properties

Name | Description
All | Gets all sets a uniform value for all four sides of this Thickness.
Bottom | Gets or sets the width, in Unit(s), of the lower side of the bounding rectangle.
IsAllThicknessSet | Checks if all four Thickness properties are set.
IsBottomSet | Checks if the Bottom property is set.
IsLeftSet | Checks if the Left property is set.
IsRightSet | Returns true if Right property is set.
IsTopSet | Checks if the Top property is set.
Left | Gets or sets the width, in Unit(s), of the left side of the bounding rectangle.
Right | Gets or sets the width, in Unit(s), of the right side of the bounding rectangle.
Top | Gets or sets the width, in Unit(s), of the upper side of the bounding rectangle.

See Also

Thickness Class


MindFusion.Scheduling.Thickness.All Property

Thickness.All Property
[image]

Gets all sets a uniform value for all four sides of this Thickness.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Unit All { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property All As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure. Default value is Unit.Empty.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.Bottom Property

Thickness.Bottom Property
[image]

Gets or sets the width, in Unit(s), of the lower side of the bounding rectangle.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Unit Bottom { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Bottom As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure. Default value is Unit.Empty.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.IsAllThicknessSet Property

Thickness.IsAllThicknessSet Property
[image]

Checks if all four Thickness properties are set.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsAllThicknessSet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsAllThicknessSet As Boolean

Property Value

true if all properties are set; otherwise false.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.IsBottomSet Property

Thickness.IsBottomSet Property
[image]

Checks if the Bottom property is set.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsBottomSet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsBottomSet As Boolean

Property Value

true if the Bottom property is set; otherwise false.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.IsLeftSet Property

Thickness.IsLeftSet Property
[image]

Checks if the Left property is set.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsLeftSet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsLeftSet As Boolean

Property Value

true if the Left property is set; otherwise false.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.IsRightSet Property

Thickness.IsRightSet Property
[image]

Returns true if Right property is set.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsRightSet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsRightSet As Boolean

Property Value

true if the Right property is set; otherwise false.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.IsTopSet Property

Thickness.IsTopSet Property
[image]

Checks if the Top property is set.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTopSet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTopSet As Boolean

Property Value

true if the Top property is set; otherwise false.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.Left Property

Thickness.Left Property
[image]

Gets or sets the width, in Unit(s), of the left side of the bounding rectangle.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Unit Left { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Left As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure. Default value is Unit.Empty.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.Right Property

Thickness.Right Property
[image]

Gets or sets the width, in Unit(s), of the right side of the bounding rectangle.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Unit Right { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Right As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure. Default value is Unit.Empty.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness.Top Property

Thickness.Top Property
[image]

Gets or sets the width, in Unit(s), of the upper side of the bounding rectangle.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Unit Top { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Top As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure. Default value is Unit.Empty.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.Thickness Events

Thickness Events
[image]

Public Events

Name | Description
Changed | Raised when a property of the Thickness class has changed.

See Also

Thickness Class


MindFusion.Scheduling.Thickness.Changed Event

Thickness.Changed Event
[image]

Raised when a property of the Thickness class has changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

Event Data

An instance of the System.EventArgs class that provides data for the event.

See Also

Thickness Members
Thickness Class


MindFusion.Scheduling.TimeSpans Class

TimeSpans Class
[image]

Defines commonly used time spans to save memory allocations.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class TimeSpans

Visual Basic [image] Copy Code

Public NotInheritable Class TimeSpans

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.TimeSpans

See Also

TimeSpans Members


MindFusion.Scheduling.TimeSpans Members

TimeSpans Members
Fields Methods
[image]

Defines commonly used time spans to save memory allocations.

The following tables list the members exposed by the TimeSpans type.

Public Fields

Name | Description
Day | Represents a time span of one day.
Hour | Represents a time span of one hour.
MinusDay | Represents a time span of minus one day.
MinusWeek | Represents a time span of minus one week.
Minute | Represents a time span of one minute.
Second | Represents a time span of one second.
Tick | Represents a time span of one tick.
Week | Represents a time span of one week.

Public Methods

Name | Description
FromDays | Initializes a new instance of the TimeSpan class that represents the specified amount of days.
FromHours | Initializes a new instance of the TimeSpan class that represents the specified amount of hours.
FromMinutes | Initializes a new instance of the TimeSpan class that represents the specified amount of minutes.
FromSeconds | Initializes a new instance of the TimeSpan class that represents the specified amount of seconds.

See Also

TimeSpans Class


MindFusion.Scheduling.TimeSpans Fields

TimeSpans Fields
[image]

Public Fields

Name | Description
Day | Represents a time span of one day.
Hour | Represents a time span of one hour.
MinusDay | Represents a time span of minus one day.
MinusWeek | Represents a time span of minus one week.
Minute | Represents a time span of one minute.
Second | Represents a time span of one second.
Tick | Represents a time span of one tick.
Week | Represents a time span of one week.

See Also

TimeSpans Class


MindFusion.Scheduling.TimeSpans.Day Field

TimeSpans.Day Field
[image]

Represents a time span of one day.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static readonly TimeSpan Day

Visual Basic [image] Copy Code

Public Shared ReadOnly Day As TimeSpan

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans.Hour Field

TimeSpans.Hour Field
[image]

Represents a time span of one hour.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static readonly TimeSpan Hour

Visual Basic [image] Copy Code

Public Shared ReadOnly Hour As TimeSpan

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans.MinusDay Field

TimeSpans.MinusDay Field
[image]

Represents a time span of minus one day.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static readonly TimeSpan MinusDay

Visual Basic [image] Copy Code

Public Shared ReadOnly MinusDay As TimeSpan

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans.MinusWeek Field

TimeSpans.MinusWeek Field
[image]

Represents a time span of minus one week.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static readonly TimeSpan MinusWeek

Visual Basic [image] Copy Code

Public Shared ReadOnly MinusWeek As TimeSpan

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans.Minute Field

TimeSpans.Minute Field
[image]

Represents a time span of one minute.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static readonly TimeSpan Minute

Visual Basic [image] Copy Code

Public Shared ReadOnly Minute As TimeSpan

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans.Second Field

TimeSpans.Second Field
[image]

Represents a time span of one second.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static readonly TimeSpan Second

Visual Basic [image] Copy Code

Public Shared ReadOnly Second As TimeSpan

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans.Tick Field

TimeSpans.Tick Field
[image]

Represents a time span of one tick.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static readonly TimeSpan Tick

Visual Basic [image] Copy Code

Public Shared ReadOnly Tick As TimeSpan

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans.Week Field

TimeSpans.Week Field
[image]

Represents a time span of one week.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static readonly TimeSpan Week

Visual Basic [image] Copy Code

Public Shared ReadOnly Week As TimeSpan

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans Methods

TimeSpans Methods
[image]

Public Methods

Name | Description
FromDays | Initializes a new instance of the TimeSpan class that represents the specified amount of days.
FromHours | Initializes a new instance of the TimeSpan class that represents the specified amount of hours.
FromMinutes | Initializes a new instance of the TimeSpan class that represents the specified amount of minutes.
FromSeconds | Initializes a new instance of the TimeSpan class that represents the specified amount of seconds.

See Also

TimeSpans Class


MindFusion.Scheduling.TimeSpans.FromDays Method

TimeSpans.FromDays Method
[image]

Initializes a new instance of the TimeSpan class that represents the specified amount of days.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static TimeSpan FromDays (
long days
)

Visual Basic [image] Copy Code

Public Shared Function FromDays( _
days As Long _
) As TimeSpan

Parameters

days
Type: Int64
A long value that specifies the number of days.

Return Value

A new TimeSpan object.

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans.FromHours Method

TimeSpans.FromHours Method
[image]

Initializes a new instance of the TimeSpan class that represents the specified amount of hours.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static TimeSpan FromHours (
long hours
)

Visual Basic [image] Copy Code

Public Shared Function FromHours( _
hours As Long _
) As TimeSpan

Parameters

hours
Type: Int64
A long value that specifies the number of hours.

Return Value

A new TimeSpan object.

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans.FromMinutes Method

TimeSpans.FromMinutes Method
[image]

Initializes a new instance of the TimeSpan class that represents the specified amount of minutes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static TimeSpan FromMinutes (
long minutes
)

Visual Basic [image] Copy Code

Public Shared Function FromMinutes( _
minutes As Long _
) As TimeSpan

Parameters

minutes
Type: Int64
A long value that specifies the number of minutes.

Return Value

A new TimeSpan object.

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeSpans.FromSeconds Method

TimeSpans.FromSeconds Method
[image]

Initializes a new instance of the TimeSpan class that represents the specified amount of seconds.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public static TimeSpan FromSeconds (
long seconds
)

Visual Basic [image] Copy Code

Public Shared Function FromSeconds( _
seconds As Long _
) As TimeSpan

Parameters

seconds
Type: Int64
A long value that specifies the number of seconds.

Return Value

A new TimeSpan object.

See Also

TimeSpans Members
TimeSpans Class


MindFusion.Scheduling.TimeUnit Enumeration

TimeUnit Enumeration
[image]

Specifies a time resolution.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum TimeUnit

Visual Basic [image] Copy Code

Public Enum TimeUnit

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
Second | 0 | Specifies seconds.
Minute | 1 | Specifies minutes.
Hour | 2 | Specifies hours.
Day | 3 | Specifies days.
Week | 4 | Specifies weeks.
Month | 5 | Specifies months.
Year | 6 | Specifies years.

See Also


MindFusion.Scheduling.XmlSerializationContext Class

XmlSerializationContext Class
[image]

Provides methods that read/write primitive data types from/into an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class XmlSerializationContext : SerializationContext

Visual Basic [image] Copy Code

Public NotInheritable Class XmlSerializationContext
Inherits SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.XmlSerializationContext

See Also

XmlSerializationContext Members


MindFusion.Scheduling.XmlSerializationContext Members

XmlSerializationContext Members
Constructors Properties Methods Events
[image]

Provides methods that read/write primitive data types from/into an XML document.

The following tables list the members exposed by the XmlSerializationContext type.

Public Constructors

Name | Description
XmlSerializationContext | Overloaded. Initializes a new instance of the XmlSerializationContext class.

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
XmlDocument | Gets the XML document used for reading and writing XML data.

Inherited Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded. (Inherited from SerializationContext.)
Schedule | Gets a reference to the schedule currently being serialized or deserialized. (Inherited from SerializationContext.)

Public Methods

Name | Description
AddChildElement | Overloaded.
ReadBool | Overloaded.
ReadByte | Reads a byte value from the element with the specified name.
ReadChar | Reads a char value from the element with the specified name.
ReadColor | Reads a Color value from the element with the specified name.
ReadColorArray | Reads an array with Colors from the element with the specified name.
ReadDateTime | Reads a DateTime value from the element with the specified name.
ReadDecimal | Reads a decimal value from the element with the specified name.
ReadDouble | Reads a double value from the element with the specified name.
ReadEnum | Reads an enumeration object from the element with the specified name.
ReadFloat | Reads a float value from the element with the specified name.
ReadFloatArray | Reads a float array from the element with the specified name.
ReadFont | Reads a Font object value from the element with the specified name.
ReadHashtable | Reads a System.Collections.Hashtable object from the element with the specified name.
ReadHeaderStyle | Reads a HeaderStyle object from the element with the specified name.
ReadImage | Reads a System.Drawing.Image object from the element with the specified name.
ReadInt | Reads an integer value with the specified name.
ReadItemStyle | Reads a ItemStyle object from the element with the specified name.
ReadLong | Reads a long value from the element with the specified name.
ReadObject | Reads a System.Object from the element with the specified name.
ReadPointF | Reads a System.Drawing.PointF object from the element with the specified name.
ReadRectangleF | Reads a RectangleF object from the element with the specified name.
ReadRecurrence | Reads a Recurrence object from the element with the specified name.
ReadReminder | Reads a Reminder object from the element with the specified name.
ReadSByte | Reads an 8-bit signed integer from the element with the specified name.
ReadShort | Reads a short value from the element with the specified name.
ReadSizeF | Reads a SizeF object from the element with the specified name.
ReadStream | Reads a Stream from the element with the specified name.
ReadString | Reads a string from the element with the specified name.
ReadStringFormat | Reads a System.Drawing.StringFormat object from the element with the specified name.
ReadStyle | Reads a Style object from the element with the specified name.
ReadTag | Reads a System.Object from the element with the specified name.
ReadUInt | Reads an unsigned integer from the element with the specified name.
ReadULong | Reads an unsigned long value from the element with the specified name.
ReadUShort | Reads an unsigned short value from the element with the specified name.
WriteBool | Writes the specified boolean value as an XML element with the specified name and the specified parent.
WriteByte | Writes the specified byte value as an XML element with the specified name and the specified parent.
WriteChar | Writes the specified char value as an XML element with the specified name and the specified parent.
WriteColor | Writes the specified Color object as an XML element with the specified name and the specified parent.
WriteColorArray | Writes the specified Color array as an XML element with the specified name and the specified parent.
WriteDateTime | Writes the specified DateTime object as an XML element with the specified name and the specified parent.
WriteDecimal | Writes the specified decimal value as an XML element with the specified name and the specified parent.
WriteDouble | Writes the specified double value as an XML element with the specified name and the specified parent.
WriteEnum | Writes the specified Enumeration as an XML element with the specified name and the specified parent.
WriteFloat | Writes the specified float value as an XML element with the specified name and the specified parent.
WriteFloatArray | Writes the specified float array as an XML element with the specified name and the specified parent.
WriteFont | Writes the specified System.Drawing.Font object as an XML element with the specified name and the specified parent.
WriteHashtable | Writes the specified System.Collections.Hashtable object as an XML element with the specified name and the specified parent.
WriteHeaderStyle | Writes the specified HeaderStyle object as an XML element with the specified name and the specified parent.
WriteImage | Writes the specified System.Drawing.Image object as an XML element with the specified name and the specified parent.
WriteInt | Writes the specified integer value as an XML element with the specified name and the specified parent.
WriteItemStyle | Writes the specified ItemStyle object as an XML element with the specified name and the specified parent.
WriteLong | Writes the specified long value as an XML element with the specified name and the specified parent.
WriteObject | Writes the specified System.Object as an XML element with the specified name and the specified parent.
WritePointF | Writes the specified PointF object.
WriteRectangleF | Writes the specified RectangleF object.
WriteRecurrence | Writes the specified Recurrence.
WriteReminder | Writes the specified Reminder.
WriteSByte | Writes the specified signed integer.
WriteShort | Writes the specified short integer.
WriteSizeF | Writes the specified SizeF object.
WriteStream | Writes the specified Stream.
WriteString | Writes the specified string.
WriteStringFormat | Writes the specified StringFormat.
WriteStyle | Writes the specified Style in an XML element with the specified name and the specified parent.
WriteTag | Writes the specified Tag as an XML element with the specified name and the specified parent.
WriteUInt | Writes the specified unsigned integer as an XML element with the specified name and the specified parent.
WriteULong | Writes the specified unsigned long value as an XML element with the specified name and the specified parent.
WriteUnit | Writes the specified System.Web.UI.WebControls.Unit value as an XML element with the specified name and the specified parent.
WriteUShort | Writes the specified unsigned short value as an XML element with the specified name and the specified parent.

Inherited Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully. (Inherited from SerializationContext.)

See Also

XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext Constructor

XmlSerializationContext Constructor
[image]

Initializes a new instance of the XmlSerializationContext class.

Overload List

Name | Description
XmlSerializationContext (Schedule, Int32, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.
XmlSerializationContext (Schedule, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.

See Also

XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext Constructor (Schedule, Int32, XmlDocument)

XmlSerializationContext Constructor (Schedule, Int32, XmlDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Schedule schedule,
int fileVersion,
XmlDocument document
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
fileVersion As Integer, _
document As XmlDocument _
)

Parameters

schedule
Type: Schedule
A Schedule instance this class will operate on.
fileVersion

Type: Int32
The file version of the file being deserialized.

document
Type: XmlDocument
The System.Xml.XmlDocument class to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext Constructor (Schedule, XmlDocument)

XmlSerializationContext Constructor (Schedule, XmlDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Schedule schedule,
XmlDocument document
)

Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
document As XmlDocument _
)

Parameters

schedule

Type: Schedule
A Schedule instance this class will operate on.

document
Type: XmlDocument
An instance of the System.Xml.XmlDocument class to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext Methods

XmlSerializationContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded.
ReadBool | Overloaded.
ReadByte | Reads a byte value from the element with the specified name.
ReadChar | Reads a char value from the element with the specified name.
ReadColor | Reads a Color value from the element with the specified name.
ReadColorArray | Reads an array with Colors from the element with the specified name.
ReadDateTime | Reads a DateTime value from the element with the specified name.
ReadDecimal | Reads a decimal value from the element with the specified name.
ReadDouble | Reads a double value from the element with the specified name.
ReadEnum | Reads an enumeration object from the element with the specified name.
ReadFloat | Reads a float value from the element with the specified name.
ReadFloatArray | Reads a float array from the element with the specified name.
ReadFont | Reads a Font object value from the element with the specified name.
ReadHashtable | Reads a System.Collections.Hashtable object from the element with the specified name.
ReadHeaderStyle | Reads a HeaderStyle object from the element with the specified name.
ReadImage | Reads a System.Drawing.Image object from the element with the specified name.
ReadInt | Reads an integer value with the specified name.
ReadItemStyle | Reads a ItemStyle object from the element with the specified name.
ReadLong | Reads a long value from the element with the specified name.
ReadObject | Reads a System.Object from the element with the specified name.
ReadPointF | Reads a System.Drawing.PointF object from the element with the specified name.
ReadRectangleF | Reads a RectangleF object from the element with the specified name.
ReadRecurrence | Reads a Recurrence object from the element with the specified name.
ReadReminder | Reads a Reminder object from the element with the specified name.
ReadSByte | Reads an 8-bit signed integer from the element with the specified name.
ReadShort | Reads a short value from the element with the specified name.
ReadSizeF | Reads a SizeF object from the element with the specified name.
ReadStream | Reads a Stream from the element with the specified name.
ReadString | Reads a string from the element with the specified name.
ReadStringFormat | Reads a System.Drawing.StringFormat object from the element with the specified name.
ReadStyle | Reads a Style object from the element with the specified name.
ReadTag | Reads a System.Object from the element with the specified name.
ReadUInt | Reads an unsigned integer from the element with the specified name.
ReadULong | Reads an unsigned long value from the element with the specified name.
ReadUShort | Reads an unsigned short value from the element with the specified name.
WriteBool | Writes the specified boolean value as an XML element with the specified name and the specified parent.
WriteByte | Writes the specified byte value as an XML element with the specified name and the specified parent.
WriteChar | Writes the specified char value as an XML element with the specified name and the specified parent.
WriteColor | Writes the specified Color object as an XML element with the specified name and the specified parent.
WriteColorArray | Writes the specified Color array as an XML element with the specified name and the specified parent.
WriteDateTime | Writes the specified DateTime object as an XML element with the specified name and the specified parent.
WriteDecimal | Writes the specified decimal value as an XML element with the specified name and the specified parent.
WriteDouble | Writes the specified double value as an XML element with the specified name and the specified parent.
WriteEnum | Writes the specified Enumeration as an XML element with the specified name and the specified parent.
WriteFloat | Writes the specified float value as an XML element with the specified name and the specified parent.
WriteFloatArray | Writes the specified float array as an XML element with the specified name and the specified parent.
WriteFont | Writes the specified System.Drawing.Font object as an XML element with the specified name and the specified parent.
WriteHashtable | Writes the specified System.Collections.Hashtable object as an XML element with the specified name and the specified parent.
WriteHeaderStyle | Writes the specified HeaderStyle object as an XML element with the specified name and the specified parent.
WriteImage | Writes the specified System.Drawing.Image object as an XML element with the specified name and the specified parent.
WriteInt | Writes the specified integer value as an XML element with the specified name and the specified parent.
WriteItemStyle | Writes the specified ItemStyle object as an XML element with the specified name and the specified parent.
WriteLong | Writes the specified long value as an XML element with the specified name and the specified parent.
WriteObject | Writes the specified System.Object as an XML element with the specified name and the specified parent.
WritePointF | Writes the specified PointF object.
WriteRectangleF | Writes the specified RectangleF object.
WriteRecurrence | Writes the specified Recurrence.
WriteReminder | Writes the specified Reminder.
WriteSByte | Writes the specified signed integer.
WriteShort | Writes the specified short integer.
WriteSizeF | Writes the specified SizeF object.
WriteStream | Writes the specified Stream.
WriteString | Writes the specified string.
WriteStringFormat | Writes the specified StringFormat.
WriteStyle | Writes the specified Style in an XML element with the specified name and the specified parent.
WriteTag | Writes the specified Tag as an XML element with the specified name and the specified parent.
WriteUInt | Writes the specified unsigned integer as an XML element with the specified name and the specified parent.
WriteULong | Writes the specified unsigned long value as an XML element with the specified name and the specified parent.
WriteUnit | Writes the specified System.Web.UI.WebControls.Unit value as an XML element with the specified name and the specified parent.
WriteUShort | Writes the specified unsigned short value as an XML element with the specified name and the specified parent.

See Also

XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method

XmlSerializationContext.AddChildElement Method
[image]

Overload List

Name | Description
XmlSerializationContext.AddChildElement (String, XmlElement) | Adds a new child node with the specified name to the specified parent node.
XmlSerializationContext.AddChildElement (String, XmlElement, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method (String, XmlElement)

XmlSerializationContext.AddChildElement Method (String, XmlElement)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

elementName
Type: String
A string that specifies the name of the new node.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent of the new node.

Return Value

Type: XmlElement
An instance of the System.Xml.XmlElement class that represents the newly created elementName node.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method (String, XmlElement, String)

XmlSerializationContext.AddChildElement Method (String, XmlElement, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement,
string innerText
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XmlElement, _
innerText As String _
) As XmlElement

Parameters

elementName
Type: String
A string that specifies the name of the new node.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent of the new node.
innerText
Type: String
A string that specifies the value of the new node.

Return Value

Type: XmlElement
An instance of the System.Xml.XmlElement class that represents the newly created elementName node.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method

XmlSerializationContext.ReadBool Method
[image]

Overload List

Name | Description
XmlSerializationContext.ReadBool (String, XmlElement) | Reads the boolean value with the specified name.
XmlSerializationContext.ReadBool (String, XmlElement, Boolean) | Reads the boolean value with the specified name from the specified parent element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method (String, XmlElement)

XmlSerializationContext.ReadBool Method (String, XmlElement)
See Also
[image]

Reads the boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement _
) As Boolean

Parameters

elementName

Type: String
The name of the element to read.

parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

The bool value read; null (Nothing in Visual Basic) if reading has failed.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)

XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)
See Also
[image]

Reads the boolean value with the specified name from the specified parent element.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XmlElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName

Type: String
A string that represents the name of the element to read.

parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.
defaultValue

A boolean value that is returned if elementName is not found among the children of parentElement.

Return Value

The bool value read; null (Nothing in Visual Basic) if reading has failed.

Remarks

If no element with the specified name is found the method returns the default value specified.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadByte Method

XmlSerializationContext.ReadByte Method
[image]

Reads a byte value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As String, _
parentElement As XmlElement _
) As Byte

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Byte
The byte read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadChar Method

XmlSerializationContext.ReadChar Method
[image]

Reads a char value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As String, _
parentElement As XmlElement _
) As Char

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Char
The char read; the letter 'a' if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadColor Method

XmlSerializationContext.ReadColor Method
[image]

Reads a Color value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XmlElement _
) As Color

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Color
The System.Drawing.Color read; Color.Black if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadColorArray Method

XmlSerializationContext.ReadColorArray Method
[image]

Reads an array with Colors from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Color()

Parameters

elementName
Type: String
The name of the element containing the array.
subElementName
Type: String
The name of the elements containing the individual array values.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Color[]
The array read; null (Nothing in Visual Basic) if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadDateTime Method

XmlSerializationContext.ReadDateTime Method
[image]

Reads a DateTime value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime ReadDateTime (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDateTime( _
elementName As String, _
parentElement As XmlElement _
) As DateTime

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: DateTime
The System.DateTime value read; DateTime.MinValue if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadDecimal Method

XmlSerializationContext.ReadDecimal Method
[image]

Reads a decimal value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As String, _
parentElement As XmlElement _
) As Decimal

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Decimal
The decimal read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadDouble Method

XmlSerializationContext.ReadDouble Method
[image]

Reads a double value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Double
The double read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadEnum Method

XmlSerializationContext.ReadEnum Method
[image]

Reads an enumeration object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Object
The enumeration object read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadFloat Method

XmlSerializationContext.ReadFloat Method
[image]

Reads a float value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public float ReadFloat (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XmlElement _
) As Single

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Single
The float read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadFloatArray Method

XmlSerializationContext.ReadFloatArray Method
[image]

Reads a float array from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public float[] ReadFloatArray (
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloatArray( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Single()

Parameters

elementName
Type: String
The name of the element containing the array.
subElementName
Type: String
The name of the elements containing the individual array values.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Single[]
The float array read; null (Nothing in Visual Basic) if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadFont Method

XmlSerializationContext.ReadFont Method
[image]

Reads a Font object value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Font ReadFont (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
elementName As String, _
parentElement As XmlElement _
) As Font

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Font
The System.Drawing.Font object read; null (Nothing in Visual Basic) if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadHashtable Method

XmlSerializationContext.ReadHashtable Method
[image]

Reads a System.Collections.Hashtable object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Hashtable ReadHashtable (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadHashtable( _
elementName As String, _
parentElement As XmlElement _
) As Hashtable

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Hashtable
The System.Collections.Hashtable read; null (Nothing in Visual Basic) if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadHeaderStyle Method

XmlSerializationContext.ReadHeaderStyle Method
[image]

Reads a HeaderStyle object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle ReadHeaderStyle (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadHeaderStyle( _
elementName As String, _
parentElement As XmlElement _
) As HeaderStyle

Parameters

elementName

Type: String
A string that specifies the element to read.

parentElement

Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: HeaderStyle
The HeaderStyle read; null if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadImage Method

XmlSerializationContext.ReadImage Method
[image]

Reads a System.Drawing.Image object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Image ReadImage (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadImage( _
elementName As String, _
parentElement As XmlElement _
) As Image

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Image
The System.Drawing.Image read; null (Nothing in Visual Basic) if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadInt Method

XmlSerializationContext.ReadInt Method
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XmlElement _
) As Integer

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Int32
The integer that was read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadItemStyle Method

XmlSerializationContext.ReadItemStyle Method
[image]

Reads a ItemStyle object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemStyle ReadItemStyle (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadItemStyle( _
elementName As String, _
parentElement As XmlElement _
) As ItemStyle

Parameters

elementName

Type: String
A string that specifies the element to read.

parentElement

Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: ItemStyle
The ItemStyle read; null if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadLong Method

XmlSerializationContext.ReadLong Method
[image]

Reads a long value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As String, _
parentElement As XmlElement _
) As Long

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Int64
The long read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadObject Method

XmlSerializationContext.ReadObject Method
[image]

Reads a System.Object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object ReadObject (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Object
The Object read; null (Nothing in Visual Basic) if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadPointF Method

XmlSerializationContext.ReadPointF Method
[image]

Reads a System.Drawing.PointF object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public PointF ReadPointF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointF( _
elementName As String, _
parentElement As XmlElement _
) As PointF

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: PointF
The System.Drawing.PointF object read; PointF.Empty if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadRectangleF Method

XmlSerializationContext.ReadRectangleF Method
[image]

Reads a RectangleF object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public RectangleF ReadRectangleF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRectangleF( _
elementName As String, _
parentElement As XmlElement _
) As RectangleF

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: RectangleF
The System.Drawing.RectangleF object read; RectangleF.Empty if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadRecurrence Method

XmlSerializationContext.ReadRecurrence Method
[image]

Reads a Recurrence object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Recurrence ReadRecurrence (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRecurrence ( _
elementName As String, _
parentElement As XmlElement _
) As Recurrence

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Recurrence
The Recurrence read; null (Nothing in Visual Basic) if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadReminder Method

XmlSerializationContext.ReadReminder Method
[image]

Reads a Reminder object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Reminder ReadReminder (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadReminder ( _
elementName As String, _
parentElement As XmlElement _
) As Reminder

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Reminder
The Reminder object read; null (Nothing in Visual Basic) if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadSByte Method

XmlSerializationContext.ReadSByte Method
[image]

Reads an 8-bit signed integer from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As String, _
parentElement As XmlElement _
) As SByte

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: SByte
The 8-bit signed integer read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadShort Method

XmlSerializationContext.ReadShort Method
[image]

Reads a short value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XmlElement _
) As Short

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Int16
The short read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadSizeF Method

XmlSerializationContext.ReadSizeF Method
[image]

Reads a SizeF object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public SizeF ReadSizeF (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSizeF( _
elementName As String, _
parentElement As XmlElement _
) As SizeF

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: SizeF
The System.Drawing.SizeF object read; SizeF.Empty if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadStream Method

XmlSerializationContext.ReadStream Method
[image]

Reads a Stream from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Stream ReadStream (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
elementName As String, _
parentElement As XmlElement _
) As Stream

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Stream
The System.IO.Stream read;

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadString Method

XmlSerializationContext.ReadString Method
[image]

Reads a string from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XmlElement _
) As String

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: String
The string read; An empty string ("") if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadStringFormat Method

XmlSerializationContext.ReadStringFormat Method
[image]

Reads a System.Drawing.StringFormat object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
elementName As String, _
parentElement As XmlElement _
) As StringFormat

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: StringFormat
The System.Drawing.StringFormat read; null (Nothing in Visual Basic) if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadStyle Method

XmlSerializationContext.ReadStyle Method
[image]

Reads a Style object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Style ReadStyle (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStyle ( _
elementName As String, _
parentElement As XmlElement _
) As Style

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Style
The Style read; null (Nothing in Visual Basic) if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadTag Method

XmlSerializationContext.ReadTag Method
[image]

Reads a System.Object from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object ReadTag (
Object item,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTag( _
item As Object, _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

item
Type: Object
The Item or Resource whose Tag is being serialized/deserialized.
elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: Object
The object read; null (Nothing in Visual Basic) if reading has failed.

Remarks

Tags are read similarly to arbitrary objects except that the client of the schedule is given a chance to perform custom deserialization through event handling.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadUInt Method

XmlSerializationContext.ReadUInt Method
[image]

Reads an unsigned integer from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As String, _
parentElement As XmlElement _
) As UInteger

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: UInt32
The unsigned integer read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadULong Method

XmlSerializationContext.ReadULong Method
[image]

Reads an unsigned long value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As String, _
parentElement As XmlElement _
) As ULong

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: UInt64
The unsigned long read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ReadUShort Method

XmlSerializationContext.ReadUShort Method
[image]

Reads an unsigned short value from the element with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As String, _
parentElement As XmlElement _
) As UShort

Parameters

elementName
Type: String
A string that specifies the name of the element to read.
parentElement
Type: XmlElement
An instance of the System.Xml.XmlElement class that specifies the parent element.

Return Value

Type: UInt16
The unsigned short value read; 0 if reading has failed.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteBool Method

XmlSerializationContext.WriteBool Method
[image]

Writes the specified boolean value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteBool (
bool value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
value As Boolean, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

Type: Boolean
The boolean value to write.

elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteByte Method

XmlSerializationContext.WriteByte Method
[image]

Writes the specified byte value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteByte (
byte value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
value As Byte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: Byte
The byte value to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteChar Method

XmlSerializationContext.WriteChar Method
[image]

Writes the specified char value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteChar (
char value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
value As Char, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: Char
The char value to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteColor Method

XmlSerializationContext.WriteColor Method
[image]

Writes the specified Color object as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteColor (
Color color,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

color
Type: Color
The System.Drawing.Color to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteColorArray Method

XmlSerializationContext.WriteColorArray Method
[image]

Writes the specified Color array as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColorArray( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array
Type: Color[]
The array to write.
elementName
Type: String
The name of the element under which the array should be written.
subElementName
Type: String
The name of the XML elements under which the individual array values will be written.
parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteDateTime Method

XmlSerializationContext.WriteDateTime Method
[image]

Writes the specified DateTime object as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteDateTime (
DateTime value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDateTime( _
value As DateTime, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: DateTime
The System.DateTime object to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteDecimal Method

XmlSerializationContext.WriteDecimal Method
[image]

Writes the specified decimal value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteDecimal (
decimal value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
value As Decimal, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: Decimal
The decimal value to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteDouble Method

XmlSerializationContext.WriteDouble Method
[image]

Writes the specified double value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteDouble (
double value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
value As Double, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: Double
The double value to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteEnum Method

XmlSerializationContext.WriteEnum Method
[image]

Writes the specified Enumeration as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteEnum (
Object value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
value As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

Type: Object
The Enumeration to write.

elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteFloat Method

XmlSerializationContext.WriteFloat Method
[image]

Writes the specified float value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteFloat (
float value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloat( _
value As Single, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: Single
The float value to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteFloatArray Method

XmlSerializationContext.WriteFloatArray Method
[image]

Writes the specified float array as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteFloatArray (
float[] array,
string elementName,
string subElementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloatArray( _
array() As Single, _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array
Type: Single[]
The float array to write.
elementName
Type: String
The name of the element under which the array should be written.
subElementName
Type: String
The name of the XML elements under which the individual array values will be written.
parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

Remarks

The count of new children elements depends on the number of float values in the array.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteFont Method

XmlSerializationContext.WriteFont Method
[image]

Writes the specified System.Drawing.Font object as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteFont (
Font font,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFont( _
font As Font, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

font
Type: Font
The System.Drawing.Font to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteHashtable Method

XmlSerializationContext.WriteHashtable Method
[image]

Writes the specified System.Collections.Hashtable object as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteHashtable (
Hashtable hashtable,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteHashtable( _
hashtable As Hashtable, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

hashtable
Type: Hashtable
The System.Collections.Hashtable to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteHeaderStyle Method

XmlSerializationContext.WriteHeaderStyle Method
[image]

Writes the specified HeaderStyle object as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteHeaderStyle (
HeaderStyle style,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteHeaderStyle( _
style As HeaderStyle, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

style

Type: HeaderStyle
The HeaderStyle object to write.

elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteImage Method

XmlSerializationContext.WriteImage Method
[image]

Writes the specified System.Drawing.Image object as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteImage (
Image image,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteImage( _
image As Image, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

image
Type: Image
The System.Drawing.Image to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteInt Method

XmlSerializationContext.WriteInt Method
[image]

Writes the specified integer value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteInt (
int value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
value As Integer, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

Type: Int32
The integer to write.

elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteItemStyle Method

XmlSerializationContext.WriteItemStyle Method
[image]

Writes the specified ItemStyle object as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteItemStyle (
ItemStyle style,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteItemStyle( _
style As ItemStyle, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

style

Type: ItemStyle
The ItemStyle object to write.

elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteLong Method

XmlSerializationContext.WriteLong Method
[image]

Writes the specified long value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteLong (
long value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
value As Long, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: Int64
The long value to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteObject Method

XmlSerializationContext.WriteObject Method
[image]

Writes the specified System.Object as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteObject (
Object value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
value As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: Object
The System.Object value to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WritePointF Method

XmlSerializationContext.WritePointF Method
[image]

Writes the specified PointF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WritePointF (
PointF value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointF( _
value As PointF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: PointF
The System.Drawing.PointF to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteRectangleF Method

XmlSerializationContext.WriteRectangleF Method
[image]

Writes the specified RectangleF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteRectangleF (
RectangleF value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRectangleF( _
value As RectangleF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: RectangleF
The System.Drawing.RectangleF to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteRecurrence Method

XmlSerializationContext.WriteRecurrence Method
[image]

Writes the specified Recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteRecurrence (
Recurrence recurrence,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRecurrence ( _
recurrence As Recurrence, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

recurrence
Type: Recurrence
The Recurrence to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteReminder Method

XmlSerializationContext.WriteReminder Method
[image]

Writes the specified Reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteReminder (
Reminder reminder,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteReminder ( _
reminder As Reminder, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

reminder
Type: Reminder
The Reminder to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteSByte Method

XmlSerializationContext.WriteSByte Method
[image]

Writes the specified signed integer.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteSByte (
sbyte value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
value As SByte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: SByte
The signed integer to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteShort Method

XmlSerializationContext.WriteShort Method
[image]

Writes the specified short integer.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteShort (
short value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
value As Short, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: Int16
The short to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteSizeF Method

XmlSerializationContext.WriteSizeF Method
[image]

Writes the specified SizeF object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteSizeF (
SizeF value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSizeF( _
value As SizeF, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: SizeF
The System.Drawing.SizeF object to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteStream Method

XmlSerializationContext.WriteStream Method
[image]

Writes the specified Stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteStream (
Stream stream,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStream( _
stream As Stream, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stream
Type: Stream
The System.IO.Stream to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteString Method

XmlSerializationContext.WriteString Method
[image]

Writes the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteString (
string value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
value As String, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: String
The string to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteStringFormat Method

XmlSerializationContext.WriteStringFormat Method
[image]

Writes the specified StringFormat.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteStringFormat (
StringFormat stringFormat,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStringFormat( _
stringFormat As StringFormat, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringFormat

Type: StringFormat
The System.Drawing.StringFormat to write.

elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteStyle Method

XmlSerializationContext.WriteStyle Method
[image]

Writes the specified Style in an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteStyle (
Style style,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStyle ( _
style As Style, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

style
Type: Style
The Style to write.
elementName
Type: String
The name of the new XML element.
parentElement
Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteTag Method

XmlSerializationContext.WriteTag Method
[image]

Writes the specified Tag as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteTag (
Object item,
Object tagValue,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTag( _
item As Object, _
tagValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

item
Type: Object
The Item or Resource whose tag is being serialized.
tagValue
Type: Object
The tag object to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

Remarks

Tags are written similarly to arbitrary objects except that the client of the schedule is given a chance to perform custom serialization through event handling.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteUInt Method

XmlSerializationContext.WriteUInt Method
[image]

Writes the specified unsigned integer as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteUInt (
uint value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
value As UInteger, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

Type: UInt32
The unsigned integer to write.

elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteULong Method

XmlSerializationContext.WriteULong Method
[image]

Writes the specified unsigned long value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteULong (
ulong value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
value As ULong, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

Type: UInt64
The unsigned long value to write.

elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteUnit Method

XmlSerializationContext.WriteUnit Method
[image]

Writes the specified System.Web.UI.WebControls.Unit value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteUnit (
Unit value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUnit( _
value As Unit, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value
Type: Unit
The System.Web.UI.WebControls.Unit to write.
elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.WriteUShort Method

XmlSerializationContext.WriteUShort Method
[image]

Writes the specified unsigned short value as an XML element with the specified name and the specified parent.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlElement WriteUShort (
ushort value,
string elementName,
XmlElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
value As UShort, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

value

Type: UInt16
The unsigned short value to write.

elementName

Type: String
The name of the new XML element.

parentElement

Type: XmlElement
The parent of the new XML element.

Return Value

Type: XmlElement
The newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext Properties

XmlSerializationContext Properties
[image]

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
XmlDocument | Gets the XML document used for reading and writing XML data.

Inherited Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded. (Inherited from SerializationContext.)
Schedule | Gets a reference to the schedule currently being serialized or deserialized. (Inherited from SerializationContext.)

See Also

XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.ClassVersion Property

XmlSerializationContext.ClassVersion Property
[image]

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int ClassVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer that specifies the class version.

Remarks

This property is only useful when deserializing items.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.XmlSerializationContext.XmlDocument Property

XmlSerializationContext.XmlDocument Property
[image]

Gets the XML document used for reading and writing XML data.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public XmlDocument XmlDocument { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlDocument As XmlDocument

Property Value

An instance of the System.Xml.XmlElement class.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Scheduling.YearlyRecurrence Enumeration

YearlyRecurrence Enumeration
[image]

Specifies types of yearly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum YearlyRecurrence

Visual Basic [image] Copy Code

Public Enum YearlyRecurrence

Members

Member name | Value | Description
SpecificDate | 0 | The event occurs on a specific date of the year.
ByDayType | 1 | The event occurs on a specific type of day of the specified week and month of the year.

See Also


MindFusion.Scheduling.WebForms Namespace

MindFusion.Scheduling.WebForms Namespace
Classes Enumerations

Classes

Class | Description
ButtonsStyle | Specifies the appearance of calendar navigation buttons, displayed in the views' headers.
Calendar | The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.
CellSettings | Defines appearance settings for the cells representing time ranges in the calendar.
ElementSize | A class that stores width/height pairs.
ItemConverter | Provides a JavaScriptConverter to convert Item objects to and from other representations.
ItemSelection | Instances of the class represent sets of selected schedule items.
ItemSettings | Defines properties that enable appearance customization of schedule items in the calendar views.
ListViewSettings | Defines properties that allow customizing the appearance of the calendar in List view.
LocalizationInfo | Represents a container of localized strings, used by various UI elements accross the Calendar.
MonthRangeSettings | Defines appearance settings for the MonthRange view.
MonthSettings | Specifies appearance settings for the month(s) in SingleMonth and MonthRange view.
RecurrenceConverter | Provides a JavaScriptConverter to convert Recurrence objects to and from other representations.
ReminderConverter | Provides a JavaScriptConverter to convert Reminder objects to and from other representations.
ResourceConverter | Provides a JavaScriptConverter to convert Resource objects to and from other representations.
ResourceViewSettings | Defines properties that allow customizing the appearance of the calendar in Resource view.
Selection | Represents a set of selected calendar cells and defines a visualization style applied to the selected elements.
TimelineSettings | Encapsulates settings for a timeline in a Resource view.
TimetableDate | A class used for storing DateTime values.
TimetableDateCollection | Represents a strongly-typed sorted collection of TimetableDate objects.
TimetableSettings | Defines properties that allow customizing the visualization of the calendar in Timetable view.
ViewSettings | The base class for the different view settings classes.
WeekRangeSettings | Specifies appearance settings for the calendar in WeekRange view.

Enumerations

Enumeration | Description
CalendarView | Specifies the type of view to display in a calendar control.
ContinuationArrows | Gets or sets the type of the continuation arrows.
DayOfWeekFormat | Specifies the display format of a day of the week.
ItemModifyAction | Specifies the type of modification action used, when an item is modified.
Keys | Identifies special Keys.
ListViewHeaderStyles | Specifies the appearance and behavior of the header in a List view. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.
MinuteFormat | Specifies how to format and display minutes in the Timetable view.
MonthHeaderStyles | Specifies the appearance and behavior of month headers in a SingleMonth and MonthRange views. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.
MonthRangeHeaderStyles | Specifies the appearance and behavior of the header in a MonthRange view. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.
MonthWeekHeaderStyle | Specifies the alignment of the header that displays week numbers in a SingleMonth view.
Orientation | Specifies orientation for calendar items.
Position | Specifies the position of an element relative to its container.
State | Specifies the state of an object.
ThemeType | Specifies an appearance theme applied at the calendar.
WeekRangeHeaderStyle | Specifies the style of the time header in WeekRange view. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.
WeekRangeViewStyle | Specifies whether there are multiple weeks displayed in WeekRange view.


MindFusion.Scheduling.WebForms.ButtonsStyle Class

ButtonsStyle Class
[image]

Specifies the appearance of calendar navigation buttons, displayed in the views' headers.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ButtonsStyle : IStateManager, IAddAttributesToRender, ICloneable

Visual Basic [image] Copy Code

Public Class ButtonsStyle
Implements IStateManager, IAddAttributesToRender, ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ButtonsStyle

See Also

ButtonsStyle Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle Members

ButtonsStyle Members
Constructors Properties Methods Events
[image]

Specifies the appearance of calendar navigation buttons, displayed in the views' headers.

The following tables list the members exposed by the ButtonsStyle type.

Public Constructors

Name | Description
ButtonsStyle | Initializes a new instance of the ButtonsStyle class.

Public Properties

Name | Description
Borders | Gets the appearance settings of the button borders.
Brush | Gets the fill color of the button.
Margins | Gets the margins of the button.
Offset | Gets or set the offset of the button.
Size | Gets the size of the button.

Protected Properties

Name | Description
ViewState | Gets the view state.

Public Methods

Name | Description
Clone | Creates an exact copy of the current ButtonsStyle object.

Public Events

Name | Description
Changed | Raised when a property value changes.

See Also

ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle Constructor

ButtonsStyle Constructor
[image]

Initializes a new instance of the ButtonsStyle class.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ButtonsStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle Methods

ButtonsStyle Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of the current ButtonsStyle object.

See Also

ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle.Clone Method

ButtonsStyle.Clone Method
[image]

Creates an exact copy of the current ButtonsStyle object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

Type: Object
The newly created ButtonsStyle object identical to the current one.

See Also

ButtonsStyle Members
ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle Properties

ButtonsStyle Properties
[image]

Public Properties

Name | Description
Borders | Gets the appearance settings of the button borders.
Brush | Gets the fill color of the button.
Margins | Gets the margins of the button.
Offset | Gets or set the offset of the button.
Size | Gets the size of the button.

Protected Properties

Name | Description
ViewState | Gets the view state.

See Also

ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle.Borders Property

ButtonsStyle.Borders Property
[image]

Gets the appearance settings of the button borders.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CssBorderStyle Borders { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Borders As CssBorderStyle

Property Value

An instance of the CssBorderStyle class.

See Also

ButtonsStyle Members
ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle.Brush Property

ButtonsStyle.Brush Property
[image]

Gets the fill color of the button.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual CssBackground Brush { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Brush As CssBackground

Property Value

An instance of a CssBackground-derived class.

See Also

ButtonsStyle Members
ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle.Margins Property

ButtonsStyle.Margins Property
[image]

Gets the margins of the button.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Thickness Margins { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Margins As Thickness

Property Value

An instance of the Thickness class.

See Also

ButtonsStyle Members
ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle.Offset Property

ButtonsStyle.Offset Property
[image]

Gets or set the offset of the button.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Offset { get; set; }

Visual Basic [image] Copy Code

Public Property Offset As Integer

Property Value

An integer value.

See Also

ButtonsStyle Members
ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle.Size Property

ButtonsStyle.Size Property
[image]

Gets the size of the button.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual ElementSize Size { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Size As ElementSize

Property Value

An instance of an ElementSize-derived class.

See Also

ButtonsStyle Members
ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle.ViewState Property

ButtonsStyle.ViewState Property
[image]

Gets the view state.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual StateBag ViewState { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property ViewState As StateBag

Property Value

An instance of the System.Web.UI.StateBag class.

See Also

ButtonsStyle Members
ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle Events

ButtonsStyle Events
[image]

Public Events

Name | Description
Changed | Raised when a property value changes.

See Also

ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ButtonsStyle.Changed Event

ButtonsStyle.Changed Event
[image]

Raised when a property value changes.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

Event Data

An instance of the System.EventArgs class that specifies data for the event.

See Also

ButtonsStyle Members
ButtonsStyle Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar Class

Calendar Class
[image]

The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class Calendar : WebControl, IScriptControl, IPostBackDataHandler, IPostBackEventHandler

Visual Basic [image] Copy Code

Public Class Calendar
Inherits WebControl
Implements IScriptControl, IPostBackDataHandler, IPostBackEventHandler

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
MindFusion.Scheduling.WebForms.Calendar

See Also

Calendar Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar Members

Calendar Members
Constructors Properties Methods Events
[image]

The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.

The following tables list the members exposed by the Calendar type.

Public Constructors

Name | Description
Calendar | Initializes a new instance of the Calendar class.

Public Properties

Name | Description
AllowInplaceEdit | Gets or sets a value indicating whether users are allowed to edit items interactively.
AutoPostBack | Gets or sets a value specifying whether the calendar should automatically post back to the server each time an appointment is created, modified or deleted.
BackColor | Gets or sets the background color of this control.
BorderColor | Gets or sets the border color of this control.
BorderStyle | Gets or sets the border style of this control.
BorderWidth | Gets or sets the border width of this control.
CalendarLoadScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar is loaded
ClickScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar is clicked.
ContactNameFormat | Gets or sets how to format and display contact names in the timetable header.
Contacts | Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.
CssClass | Gets or sets the name of the CSS class applied to the control.
Culture | Gets or sets the CultureInfo object used to format and display time information in the calendar.
CurrentView | Gets or sets the type of the calendar view.
Date | Gets or sets the date currently displayed in the calendar.
DateClickScript | Gets or sets the name of a JavaScript function that should be invoked when a click event is raised from a calendar date cell.
DateDoubleClickScript | Gets or sets the name of a JavaScript function that should be invoked when a doubleclick event is raised from a calendar date cell.
DateHeaderClickScript | Gets or sets the name of a JavaScript function that should be invoked when a click event is raised from a calendar date cell header.
DateMouseDownScript | Gets or sets the name of a JavaScript function that should be invoked when a mousedown event is raised from a calendar date cell.
DateMouseUpScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseup event is raised from a calendar date cell.
DateTimeFormat | Gets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.
DoubleClickScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar is double-clicked.
EnableScheduleContactsState | Gets or sets whether Contacts are written in the current ViewState.
EnableScheduleItemsState | Gets or sets whether Items are written in the current ViewState.
EnableScheduleLocationsState | Gets or sets whether Locations are written in the current ViewState.
EnableScheduleResourcesState | Gets or sets whether Resources are written in the current ViewState.
EnableScheduleTasksState | Gets or sets whether Tasks are written in the current ViewState.
EnableViewSettingsState | Gets or sets whether ViewSettings are written in the current ViewState.
EndDate | Gets or sets the last date displayed in the calendar.
FirstWeekendDay | Gets or sets the first weekend day in the calendar.
Font | Gets the font associated with this control.
ForeColor | Gets or sets the foreground color (typically the color of the text) of this control.
FormShowScript | Gets or sets the name of a JavaScript function that should be invoked when a built-in form is about to be shown.
GroupType | Gets or sets the grouping criteria for the Timetable view.
Height | WebControl.Height override.
ItemChangeResourceKey | Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view.
ItemClickScript | Gets or sets the name of a JavaScript function that should be invoked when a click event is raised from an item.
ItemCloneKey | Gets or sets the modifier key, which when pressed allows users to interactively clone items.
ItemCreatedScript | Gets or sets the name of a JavaScript function that should be invoked while an item has been created.
ItemCreatingScript | Gets or sets the name of a JavaScript function that should be invoked while an item is being created.
ItemDeletedScript | Gets or sets the name of a JavaScript function that should be invoked when an item is deleted.
ItemDeletingScript | Gets or sets the name of a JavaScript function that should be invoked when an item is about to be deleted.
ItemDoubleClickScript | Gets or sets the name of a JavaScript function that should be invoked when a doubleclick event is raised from an item.
ItemDragEndScript | Gets or sets the name of a JavaScript function that should be invoked when a drag operation on an item is finished.
ItemDragStartScript | Gets or sets the name of a JavaScript function that should be invoked when a drag operation on an item is started.
ItemInplaceEditEndingScript | Gets or sets the name of a JavaScript function that should be invoked when inplace editing of item's text is about to be accepted.
ItemInplaceEditStartingScript | Gets or sets the name of a JavaScript function that should be invoked when inplace editing of item's text is about to begin.
ItemModifiedScript | Gets or sets the name of a JavaScript function that should be invoked when an item is modified.
ItemModifyingScript | Gets or sets the name of a JavaScript function that should be invoked while an item is about to be modified.
ItemMouseDownScript | Gets or sets the name of a JavaScript function that should be invoked when a mousedown event is raised from an item.
ItemMouseEnterScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseover event is raised from an item.
ItemMouseLeaveScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseout event is raised from an item.
ItemMouseMoveScript | Gets or sets the name of a JavaScript function that should be invoked when a mousemove event is raised from an item.
ItemMouseUpScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseup event is raised from an item.
ItemReminderTriggeredScript | Gets or sets the name of a JavaScript function that should be invoked when an item reminder is triggered.
ItemResizeEndScript | Gets or sets the name of a JavaScript function that should be invoked when a resize operation on an item is finished.
ItemResizeStartScript | Gets or sets the name of a JavaScript function that should be invoked when a resize operation on an item is started.
ItemSelection | Gets an ItemSelection object representing the current selection of items in the calendar.
ItemSelectionChangedScript | Gets or sets the name of a JavaScript function that should be invoked when the items selection changes.
ItemSettings | Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.
ItemTooltipFormat | Gets or sets the format of item tooltips.
LicenseKey | Gets or sets the license key of the control.
ListViewHeaderClickScript | Gets or sets the name of a JavaScript function that should be invoked when the header in the ListView is clicked.
ListViewSettings | Gets the ListViewSettings object used to customize the appearance of the List view.
LocalizationInfo | Gets or sets the LocalizationInfo object containing the settings used to customize various UI controls within the calendar.
Locations | Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.
MonthHeaderClickScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar's header is clicked.
MonthRangeHeaderClickScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar's header is clicked.
MonthRangeSettings | Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.
MonthSettings | Gets the MonthSettings object used to customize the appearance of a month range in the SingleMonth view.
MoreItemsCueMouseDownScript | Gets or sets the name of a JavaScript function that should be invoked when a mousedown event is raised from the items cue.
MoreItemsCueMouseUpScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseup event is raised from the items cue.
MouseEnterScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseover event is raised from the calendar.
MouseLeaveScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseout event is raised from the calendar.
MouseMoveScript | Gets or sets the name of a JavaScript function that should be invoked when a mousemove event is raised from the calendar.
RecurrenceStringValidationScript | Gets or sets the name of a JavaScript function that should be invoked after the recurrence information text in a popup form has changed.
RecurringItemDeletingScript | Gets or sets the name of a JavaScript function that should be invoked when a recurring item is being deleted.
Resources | Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.
ResourceViewSettings | Gets the ResourceViewSettings object used to customize the appearance of the Resource view.
Schedule | Gets or sets the schedule to be displayed inside the calendar control.
Selection | Gets a Selection object representing the current selection in the calendar.
SelectionChangedScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar date selection changes.
SelectionEndScript | Gets or sets the name of a JavaScript function that should be invoked when cells' selection has ended.
SelectionStartScript | Gets or sets the name of a JavaScript function that should be invoked when cells' selection has started.
ShowToolTips | Gets or sets a value indicating whether the calendar displays tooltips.
TaskReminderTriggeredScript | Gets or sets the name of a JavaScript function that should be invoked when a task reminder is triggered.
Tasks | Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.
Theme | Gets or sets the theme applied to the calendar control UI elements.
TimetableColumnHeaderClickScript | Gets or sets the name of a JavaScript function that is invoked when a column header is clicked in the Timetable view.
TimetableSettings | Gets the TimetableSettings object used to customize the appearance of days and hours in the Timetable view.
UseForms | Gets or sets a value indicating whether the control should use the built-in forms.
WeekRangeHeaderClickScript | Gets or sets the name of a JavaScript function that is invoked when the view header is clicked in the WeekRange view.
WeekRangeSettings | Gets the WeekRangeSettings object used to customize the appearance of weeks in the WeekRange view.
Width | WebControl.Width override.

Protected Properties

Name | Description
SecondWeekendDay | Gets the second day of the weekend.
TagKey | WebControl.TagKey override. Gets the HtmlTextWriterTag value that corresponds to this Calendar control.

Public Methods

Name | Description
LoadPostData | When implemented by a derived class, processes postback data for the Calendar server control.
OnContactSerialization | Raises the ContactSerialization event.
OnCultureChanged | Raises the CultureChanged event.
OnItemCreated | Raises the ItemCreated event.
OnItemDeleted | Raises the ItemDeleted event.
OnItemInplaceEdited | Raises the ItemInplaceEdited event.
OnItemModified | Raises the ItemModified event.
OnItemSerialization | Raises the ItemSerialization event.
OnLocationSerialization | Raises the LocationSerialization event.
OnRecurrenceSerialization | Raises the RecurrenceSerialization event.
OnReminderSerialization | Raises the ReminderSerialization event.
OnResourceSerialization | Raises the ResourceSerialization event.
OnTaskSerialization | Raises the TaskSerialization event.
OnThemeChanged | Raises the ThemeChanged event.
OnVisibleDateChanged | Raises the VisibleDateChanged event.
RaisePostBackEvent | When implemented by a derived class, enables a server control to process an event raised when a form is posted to the server.
RaisePostDataChangedEvent | When implemented by a derived class in the server control notifies the ASP.NET application that the state of the control has changed.

Protected Methods

Name | Description
AddAttributesToRender | WebControl.AddAttributesToRender override. Adds HTML attributes and styles that need to be rendered by the specified HtmlTextWriter.
LoadViewState | Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
OnPreRender | Control.OnPreRender override.
Render | Control.Render override.
RenderContents | WebControl.RenderContents override. Renders the contents of the control to the specified writer.
SaveViewState | Control.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | Control.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Public Events

Name | Description
ContactSerialization | Represents the method that will handle the ContactSerialization event.
CultureChanged | Raised when the calendar Culture has changed.
ItemCreated | Raised when a schedule item is created.
ItemDeleted | Raised when a schedule item is deleted.
ItemInplaceEdited | Raised when a schedule item's text is inplace-edited.
ItemModified | Raised when a schedule item is moved or resized by the user.
ItemSerialization | Raised when an item is about to be serialized.
LocationSerialization | Raised when a Location is about to be serialized.
RecurrenceSerialization | Raised when a Recurrence is about to be serialized.
ReminderSerialization | Raised when a Reminder is about to be serialized.
ResourceSerialization | Raised when a Resource is about to be serialized.
TaskSerialization | Raised when a Task is about to be serialized.
ThemeChanged | Raised when the calendar theme has changed.
VisibleDateChanged | Raised when the user selects another date using the month or year navigation controls on the calendar header area.

See Also

Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar Constructor

Calendar Constructor
[image]

Initializes a new instance of the Calendar class.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Calendar ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar Methods

Calendar Methods
[image]

Public Methods

Name | Description
LoadPostData | When implemented by a derived class, processes postback data for the Calendar server control.
OnContactSerialization | Raises the ContactSerialization event.
OnCultureChanged | Raises the CultureChanged event.
OnItemCreated | Raises the ItemCreated event.
OnItemDeleted | Raises the ItemDeleted event.
OnItemInplaceEdited | Raises the ItemInplaceEdited event.
OnItemModified | Raises the ItemModified event.
OnItemSerialization | Raises the ItemSerialization event.
OnLocationSerialization | Raises the LocationSerialization event.
OnRecurrenceSerialization | Raises the RecurrenceSerialization event.
OnReminderSerialization | Raises the ReminderSerialization event.
OnResourceSerialization | Raises the ResourceSerialization event.
OnTaskSerialization | Raises the TaskSerialization event.
OnThemeChanged | Raises the ThemeChanged event.
OnVisibleDateChanged | Raises the VisibleDateChanged event.
RaisePostBackEvent | When implemented by a derived class, enables a server control to process an event raised when a form is posted to the server.
RaisePostDataChangedEvent | When implemented by a derived class in the server control notifies the ASP.NET application that the state of the control has changed.

Protected Methods

Name | Description
AddAttributesToRender | WebControl.AddAttributesToRender override. Adds HTML attributes and styles that need to be rendered by the specified HtmlTextWriter.
LoadViewState | Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
OnPreRender | Control.OnPreRender override.
Render | Control.Render override.
RenderContents | WebControl.RenderContents override. Renders the contents of the control to the specified writer.
SaveViewState | Control.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | Control.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

See Also

Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.AddAttributesToRender Method

Calendar.AddAttributesToRender Method
[image]

WebControl.AddAttributesToRender override. Adds HTML attributes and styles that need to be rendered by the specified HtmlTextWriter.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void AddAttributesToRender (
HtmlTextWriter writer
)

Visual Basic [image] Copy Code

Protected Overrides Sub AddAttributesToRender( _
writer As HtmlTextWriter _
)

Parameters

writer
Type: HtmlTextWriter
A System.Web.UI.HtmlTextWriter that represents the output stream to render HTML content on the client.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.LoadPostData Method

Calendar.LoadPostData Method
[image]

When implemented by a derived class, processes postback data for the Calendar server control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool LoadPostData (
string postDataKey,
NameValueCollection postCollection
)

Visual Basic [image] Copy Code

Public Function LoadPostData( _
postDataKey As String, _
postCollection As NameValueCollection _
) As Boolean

Parameters

postDataKey

Type: String
The key identifier for the control.

postCollection

Type: NameValueCollection
The collection of all incoming name values.

Return Value

true if the server control's state changes as a result of the postback; otherwise, false.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.LoadViewState Method

Calendar.LoadViewState Method
[image]

Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void LoadViewState (
Object savedState
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadViewState( _
savedState As Object _
)

Parameters

savedState
Type: Object
An Object that represents the control state to be restored.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnContactSerialization Method

Calendar.OnContactSerialization Method
[image]

Raises the ContactSerialization event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void OnContactSerialization (
SerializationEventArgs e
)

Visual Basic [image] Copy Code

Public Overridable Sub OnContactSerialization ( _
e As SerializationEventArgs _
)

Parameters

e
Type: SerializationEventArgs
A SerializationEventArgs object that holds the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnCultureChanged Method

Calendar.OnCultureChanged Method
[image]

Raises the CultureChanged event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void OnCultureChanged (
CultureEventArgs e
)

Visual Basic [image] Copy Code

Public Sub OnCultureChanged ( _
e As CultureEventArgs _
)

Parameters

e
Type: CultureEventArgs
A CultureEventArgs object that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnItemCreated Method

Calendar.OnItemCreated Method
[image]

Raises the ItemCreated event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void OnItemCreated (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Public Sub OnItemCreated ( _
e As ItemEventArgs _
)

Parameters

e
Type: ItemEventArgs
An ItemEventArgs object, that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnItemDeleted Method

Calendar.OnItemDeleted Method
[image]

Raises the ItemDeleted event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void OnItemDeleted (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Public Sub OnItemDeleted ( _
e As ItemEventArgs _
)

Parameters

e

Type: ItemEventArgs
An ItemEventArgs object that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnItemInplaceEdited Method

Calendar.OnItemInplaceEdited Method
[image]

Raises the ItemInplaceEdited event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void OnItemInplaceEdited (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Public Sub OnItemInplaceEdited ( _
e As ItemEventArgs _
)

Parameters

e
Type: ItemEventArgs
An ItemEventArgs object that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnItemModified Method

Calendar.OnItemModified Method
[image]

Raises the ItemModified event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void OnItemModified (
ItemModifiedEventArgs e
)

Visual Basic [image] Copy Code

Public Sub OnItemModified ( _
e As ItemModifiedEventArgs _
)

Parameters

e
Type : ItemModifiedEventArgs
An ItemModifiedEventArgs object that holds the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnItemSerialization Method

Calendar.OnItemSerialization Method
[image]

Raises the ItemSerialization event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void OnItemSerialization (
SerializationEventArgs e
)

Visual Basic [image] Copy Code

Public Overridable Sub OnItemSerialization ( _
e As SerializationEventArgs _
)

Parameters

e
Type: SerializationEventArgs
A SerializationEventArgs object that contains the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnLocationSerialization Method

Calendar.OnLocationSerialization Method
[image]

Raises the LocationSerialization event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void OnLocationSerialization (
SerializationEventArgs e
)

Visual Basic [image] Copy Code

Public Overridable Sub OnLocationSerialization ( _
e As SerializationEventArgs _
)

Parameters

e
Type: SerializationEventArgs
A SerializationEventArgs object that holds the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnPreRender Method

Calendar.OnPreRender Method
[image]

Control.OnPreRender override.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnPreRender (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPreRender( _
e As EventArgs _
)

Parameters

e
Type: EventArgs
An instance of the System.EventArgs class that holds event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnRecurrenceSerialization Method

Calendar.OnRecurrenceSerialization Method
[image]

Raises the RecurrenceSerialization event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void OnRecurrenceSerialization (
SerializationEventArgs e
)

Visual Basic [image] Copy Code

Public Overridable Sub OnRecurrenceSerialization ( _
e As SerializationEventArgs _
)

Parameters

e
Type: SerializationEventArgs
A SerializationEventArgs object that holds the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnReminderSerialization Method

Calendar.OnReminderSerialization Method
[image]

Raises the ReminderSerialization event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void OnReminderSerialization (
SerializationEventArgs e
)

Visual Basic [image] Copy Code

Public Overridable Sub OnReminderSerialization ( _
e As SerializationEventArgs _
)

Parameters

e
Type: SerializationEventArgs
A SerializationEventArgs object that holds the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnResourceSerialization Method

Calendar.OnResourceSerialization Method
[image]

Raises the ResourceSerialization event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void OnResourceSerialization (
SerializationEventArgs e
)

Visual Basic [image] Copy Code

Public Overridable Sub OnResourceSerialization ( _
e As SerializationEventArgs _
)

Parameters

e
Type: SerializationEventArgs
A SerializationEventArgs object that holds the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnTaskSerialization Method

Calendar.OnTaskSerialization Method
[image]

Raises the TaskSerialization event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void OnTaskSerialization (
SerializationEventArgs e
)

Visual Basic [image] Copy Code

Public Overridable Sub OnTaskSerialization ( _
e As SerializationEventArgs _
)

Parameters

e
Type: SerializationEventArgs
A SerializationEventArgs object that holds the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnThemeChanged Method

Calendar.OnThemeChanged Method
[image]

Raises the ThemeChanged event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void OnThemeChanged (
ThemeEventArgs e
)

Visual Basic [image] Copy Code

Public Sub OnThemeChanged ( _
e As ThemeEventArgs _
)

Parameters

e
Type: ThemeEventArgs
A ThemeEventArgs object that holds the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.OnVisibleDateChanged Method

Calendar.OnVisibleDateChanged Method
[image]

Raises the VisibleDateChanged event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnVisibleDateChanged (
DateChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnVisibleDateChanged ( _
e As DateChangedEventArgs _
)

Parameters

e
Type: DateChangedEventArgs
A DateChangedEventArgs object that holds the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.RaisePostBackEvent Method

Calendar.RaisePostBackEvent Method
[image]

When implemented by a derived class, enables a server control to process an event raised when a form is posted to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void RaisePostBackEvent (
string eventArgument
)

Visual Basic [image] Copy Code

Public Sub RaisePostBackEvent( _
eventArgument As String _
)

Parameters

eventArgument
Type: String
A string that represents an optional event argument to be passed to the event handler.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.RaisePostDataChangedEvent Method

Calendar.RaisePostDataChangedEvent Method
[image]

When implemented by a derived class in the server control notifies the ASP.NET application that the state of the control has changed.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void RaisePostDataChangedEvent ()

Visual Basic [image] Copy Code

Public Sub RaisePostDataChangedEvent ()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Render Method

Calendar.Render Method
[image]

Control.Render override.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void Render (
HtmlTextWriter writer
)

Visual Basic [image] Copy Code

Protected Overrides Sub Render( _
writer As HtmlTextWriter _
)

Parameters

writer
Type: HtmlTextWriter
The System.Web.UI.HtmlTextWriter object that receives the server control content.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.RenderContents Method

Calendar.RenderContents Method
[image]

WebControl.RenderContents override. Renders the contents of the control to the specified writer.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void RenderContents (
HtmlTextWriter output
)

Visual Basic [image] Copy Code

Protected Overrides Sub RenderContents( _
output As HtmlTextWriter _
)

Parameters

output
Type: HtmlTextWriter
An instance of the System.Web.UI.HtmlTextWriter class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.SaveViewState Method

Calendar.SaveViewState Method
[image]

Control.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override Object SaveViewState ()

Visual Basic [image] Copy Code

Protected Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in Visual Basic).

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.TrackViewState Method

Calendar.TrackViewState Method
[image]

Control.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void TrackViewState ()

Visual Basic [image] Copy Code

Protected Overrides Sub TrackViewState ()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar Properties

Calendar Properties
[image]

Public Properties

Name | Description
AllowInplaceEdit | Gets or sets a value indicating whether users are allowed to edit items interactively.
AutoPostBack | Gets or sets a value specifying whether the calendar should automatically post back to the server each time an appointment is created, modified or deleted.
BackColor | Gets or sets the background color of this control.
BorderColor | Gets or sets the border color of this control.
BorderStyle | Gets or sets the border style of this control.
BorderWidth | Gets or sets the border width of this control.
CalendarLoadScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar is loaded
ClickScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar is clicked.
ContactNameFormat | Gets or sets how to format and display contact names in the timetable header.
Contacts | Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.
CssClass | Gets or sets the name of the CSS class applied to the control.
Culture | Gets or sets the CultureInfo object used to format and display time information in the calendar.
CurrentView | Gets or sets the type of the calendar view.
Date | Gets or sets the date currently displayed in the calendar.
DateClickScript | Gets or sets the name of a JavaScript function that should be invoked when a click event is raised from a calendar date cell.
DateDoubleClickScript | Gets or sets the name of a JavaScript function that should be invoked when a doubleclick event is raised from a calendar date cell.
DateHeaderClickScript | Gets or sets the name of a JavaScript function that should be invoked when a click event is raised from a calendar date cell header.
DateMouseDownScript | Gets or sets the name of a JavaScript function that should be invoked when a mousedown event is raised from a calendar date cell.
DateMouseUpScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseup event is raised from a calendar date cell.
DateTimeFormat | Gets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.
DoubleClickScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar is double-clicked.
EnableScheduleContactsState | Gets or sets whether Contacts are written in the current ViewState.
EnableScheduleItemsState | Gets or sets whether Items are written in the current ViewState.
EnableScheduleLocationsState | Gets or sets whether Locations are written in the current ViewState.
EnableScheduleResourcesState | Gets or sets whether Resources are written in the current ViewState.
EnableScheduleTasksState | Gets or sets whether Tasks are written in the current ViewState.
EnableViewSettingsState | Gets or sets whether ViewSettings are written in the current ViewState.
EndDate | Gets or sets the last date displayed in the calendar.
FirstWeekendDay | Gets or sets the first weekend day in the calendar.
Font | Gets the font associated with this control.
ForeColor | Gets or sets the foreground color (typically the color of the text) of this control.
FormShowScript | Gets or sets the name of a JavaScript function that should be invoked when a built-in form is about to be shown.
GroupType | Gets or sets the grouping criteria for the Timetable view.
Height | WebControl.Height override.
ItemChangeResourceKey | Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view.
ItemClickScript | Gets or sets the name of a JavaScript function that should be invoked when a click event is raised from an item.
ItemCloneKey | Gets or sets the modifier key, which when pressed allows users to interactively clone items.
ItemCreatedScript | Gets or sets the name of a JavaScript function that should be invoked while an item has been created.
ItemCreatingScript | Gets or sets the name of a JavaScript function that should be invoked while an item is being created.
ItemDeletedScript | Gets or sets the name of a JavaScript function that should be invoked when an item is deleted.
ItemDeletingScript | Gets or sets the name of a JavaScript function that should be invoked when an item is about to be deleted.
ItemDoubleClickScript | Gets or sets the name of a JavaScript function that should be invoked when a doubleclick event is raised from an item.
ItemDragEndScript | Gets or sets the name of a JavaScript function that should be invoked when a drag operation on an item is finished.
ItemDragStartScript | Gets or sets the name of a JavaScript function that should be invoked when a drag operation on an item is started.
ItemInplaceEditEndingScript | Gets or sets the name of a JavaScript function that should be invoked when inplace editing of item's text is about to be accepted.
ItemInplaceEditStartingScript | Gets or sets the name of a JavaScript function that should be invoked when inplace editing of item's text is about to begin.
ItemModifiedScript | Gets or sets the name of a JavaScript function that should be invoked when an item is modified.
ItemModifyingScript | Gets or sets the name of a JavaScript function that should be invoked while an item is about to be modified.
ItemMouseDownScript | Gets or sets the name of a JavaScript function that should be invoked when a mousedown event is raised from an item.
ItemMouseEnterScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseover event is raised from an item.
ItemMouseLeaveScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseout event is raised from an item.
ItemMouseMoveScript | Gets or sets the name of a JavaScript function that should be invoked when a mousemove event is raised from an item.
ItemMouseUpScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseup event is raised from an item.
ItemReminderTriggeredScript | Gets or sets the name of a JavaScript function that should be invoked when an item reminder is triggered.
ItemResizeEndScript | Gets or sets the name of a JavaScript function that should be invoked when a resize operation on an item is finished.
ItemResizeStartScript | Gets or sets the name of a JavaScript function that should be invoked when a resize operation on an item is started.
ItemSelection | Gets an ItemSelection object representing the current selection of items in the calendar.
ItemSelectionChangedScript | Gets or sets the name of a JavaScript function that should be invoked when the items selection changes.
ItemSettings | Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.
ItemTooltipFormat | Gets or sets the format of item tooltips.
LicenseKey | Gets or sets the license key of the control.
ListViewHeaderClickScript | Gets or sets the name of a JavaScript function that should be invoked when the header in the ListView is clicked.
ListViewSettings | Gets the ListViewSettings object used to customize the appearance of the List view.
LocalizationInfo | Gets or sets the LocalizationInfo object containing the settings used to customize various UI controls within the calendar.
Locations | Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.
MonthHeaderClickScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar's header is clicked.
MonthRangeHeaderClickScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar's header is clicked.
MonthRangeSettings | Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.
MonthSettings | Gets the MonthSettings object used to customize the appearance of a month range in the SingleMonth view.
MoreItemsCueMouseDownScript | Gets or sets the name of a JavaScript function that should be invoked when a mousedown event is raised from the items cue.
MoreItemsCueMouseUpScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseup event is raised from the items cue.
MouseEnterScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseover event is raised from the calendar.
MouseLeaveScript | Gets or sets the name of a JavaScript function that should be invoked when a mouseout event is raised from the calendar.
MouseMoveScript | Gets or sets the name of a JavaScript function that should be invoked when a mousemove event is raised from the calendar.
RecurrenceStringValidationScript | Gets or sets the name of a JavaScript function that should be invoked after the recurrence information text in a popup form has changed.
RecurringItemDeletingScript | Gets or sets the name of a JavaScript function that should be invoked when a recurring item is being deleted.
Resources | Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.
ResourceViewSettings | Gets the ResourceViewSettings object used to customize the appearance of the Resource view.
Schedule | Gets or sets the schedule to be displayed inside the calendar control.
Selection | Gets a Selection object representing the current selection in the calendar.
SelectionChangedScript | Gets or sets the name of a JavaScript function that should be invoked when the calendar date selection changes.
SelectionEndScript | Gets or sets the name of a JavaScript function that should be invoked when cells' selection has ended.
SelectionStartScript | Gets or sets the name of a JavaScript function that should be invoked when cells' selection has started.
ShowToolTips | Gets or sets a value indicating whether the calendar displays tooltips.
TaskReminderTriggeredScript | Gets or sets the name of a JavaScript function that should be invoked when a task reminder is triggered.
Tasks | Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.
Theme | Gets or sets the theme applied to the calendar control UI elements.
TimetableColumnHeaderClickScript | Gets or sets the name of a JavaScript function that is invoked when a column header is clicked in the Timetable view.
TimetableSettings | Gets the TimetableSettings object used to customize the appearance of days and hours in the Timetable view.
UseForms | Gets or sets a value indicating whether the control should use the built-in forms.
WeekRangeHeaderClickScript | Gets or sets the name of a JavaScript function that is invoked when the view header is clicked in the WeekRange view.
WeekRangeSettings | Gets the WeekRangeSettings object used to customize the appearance of weeks in the WeekRange view.
Width | WebControl.Width override.

Protected Properties

Name | Description
SecondWeekendDay | Gets the second day of the weekend.
TagKey | WebControl.TagKey override. Gets the HtmlTextWriterTag value that corresponds to this Calendar control.

See Also

Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.AllowInplaceEdit Property

Calendar.AllowInplaceEdit Property
[image]

Gets or sets a value indicating whether users are allowed to edit items interactively.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool AllowInplaceEdit { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInplaceEdit As Boolean

Property Value

true if interactive editing is allowed; otherwise false. Default value is true.

Remarks

If this property is disabled, users cannot edit item's text interactively. Handle the ItemInplaceEditStarting and ItemInplaceEditEnding events to control the editing of text.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.AutoPostBack Property

Calendar.AutoPostBack Property
[image]

Gets or sets a value specifying whether the calendar should automatically post back to the server each time an appointment is created, modified or deleted.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool AutoPostBack { get; set; }

Visual Basic [image] Copy Code

Public Property AutoPostBack As Boolean

Property Value

true if the auto post pack is enabled; otherwise false. Default value is false.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.BackColor Property

Calendar.BackColor Property
[image]

Gets or sets the background color of this control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Color BackColor { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property BackColor As Color

Property Value

An instance of System.Drawing.Color structure that specifies the background color of the control.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.BorderColor Property

Calendar.BorderColor Property
[image]

Gets or sets the border color of this control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Color BorderColor { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property BorderColor As Color

Property Value

An instance of the System.Drawing.Color structure that specifies the border color of the control.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.BorderStyle Property

Calendar.BorderStyle Property
[image]

Gets or sets the border style of this control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override BorderStyle BorderStyle { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property BorderStyle As BorderStyle

Property Value

One of the System.Web.UI.WebControls.BorderStyle enumeration values.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.BorderWidth Property

Calendar.BorderWidth Property
[image]

Gets or sets the border width of this control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Unit BorderWidth { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property BorderWidth As Unit

Property Value

A Unit that represents the border width of a Web server control. The default value is Empty, which indicates that this property is not set.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.CalendarLoadScript Property

Calendar.CalendarLoadScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when the calendar is loaded

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string CalendarLoadScript { get; set; }

Visual Basic [image] Copy Code

Public Property CalendarLoadScript As String

Property Value

A string that specifies a JavaScript function that will handle the CalendarLoad client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ClickScript Property

Calendar.ClickScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when the calendar is clicked.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property ClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the Click client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ContactNameFormat Property

Calendar.ContactNameFormat Property
[image]

Gets or sets how to format and display contact names in the timetable header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ContactNameFormat { get; set; }

Visual Basic [image] Copy Code

Public Property ContactNameFormat As String

Property Value

A string that identifies the name format. Default value is "F M L".

Remarks

Use the capital letters F, M and L as placeholders for the First, Middle and Last names. Any other character will be displayed unchanged.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Contacts Property

Calendar.Contacts Property
[image]

Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Contact> Contacts { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Contacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection class. Default value is an empty collection.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.CssClass Property

Calendar.CssClass Property
[image]

Gets or sets the name of the CSS class applied to the control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override string CssClass { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property CssClass As String

Property Value

A string that represents the CssClass. Default value is an empty sting ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Culture Property

Calendar.Culture Property
[image]

Gets or sets the CultureInfo object used to format and display time information in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CultureInfo Culture { get; set; }

Visual Basic [image] Copy Code

Public Property Culture As CultureInfo

Property Value

An instance of the System.Globalization.CultureInfo class. Default value is an instance of the invariant culture.

Remarks

Setting the culture info results in reinitialization of all culture-specific properties, such as day and month names, first day of the week, and so on.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.CurrentView Property

Calendar.CurrentView Property
[image]

Gets or sets the type of the calendar view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CalendarView CurrentView { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentView As CalendarView

Property Value

One of the CalendarView enumeration values. Default is CalendarView.SingleMonth.

Remarks

The control can display the schedule data in several different types of views. This property allows changing the current view and can be used to implement drill down into the schedule data by switching from more general to more specialized views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Date Property

Calendar.Date Property
[image]

Gets or sets the date currently displayed in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime Date { get; set; }

Visual Basic [image] Copy Code

Public Property Date As DateTime

Property Value

An instance of the System.DateTime enumeration that specifies the date currently displayed in the calendar. Default value is DateTime.Now.

Remarks

This value is not used in a timetable view. To specify the dates displayed in timetable view, use TimetableSettings.Dates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.DateClickScript Property

Calendar.DateClickScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a click event is raised from a calendar date cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DateClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property DateClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the DateClick client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.DateDoubleClickScript Property

Calendar.DateDoubleClickScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a doubleclick event is raised from a calendar date cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DateDoubleClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property DateDoubleClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the DateDoubleClick client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.DateHeaderClickScript Property

Calendar.DateHeaderClickScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a click event is raised from a calendar date cell header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DateHeaderClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property DateHeaderClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the DateHeaderClick client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.DateMouseDownScript Property

Calendar.DateMouseDownScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mousedown event is raised from a calendar date cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DateMouseDownScript { get; set; }

Visual Basic [image] Copy Code

Public Property DateMouseDownScript As String

Property Value

A string that specifies a JavaScript function that will handle the DateMouseDown client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.DateMouseUpScript Property

Calendar.DateMouseUpScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mouseup event is raised from a calendar date cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DateMouseUpScript { get; set; }

Visual Basic [image] Copy Code

Public Property DateMouseUpScript As String

Property Value

A string that specifies a JavaScript function that will handle the DateMouseUp client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.DateTimeFormat Property

Calendar.DateTimeFormat Property
[image]

Gets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual DateTimeFormatInfo DateTimeFormat { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property DateTimeFormat As DateTimeFormatInfo

Property Value

An instance of the DateTimeFormatInfo class. Default value is the DateTimeFormat value associated with the current Culture.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.DoubleClickScript Property

Calendar.DoubleClickScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when the calendar is double-clicked.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DoubleClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property DoubleClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the DoubleClick client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.EnableScheduleContactsState Property

Calendar.EnableScheduleContactsState Property
[image]

Gets or sets whether Contacts are written in the current ViewState.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool EnableScheduleContactsState { get; set; }

Visual Basic [image] Copy Code

Public Property EnableScheduleContactsState As Boolean

Property Value

true if the Schedule.Contacts collection is written in the ViewState; otherwise false. Default value is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.EnableScheduleItemsState Property

Calendar.EnableScheduleItemsState Property
[image]

Gets or sets whether Items are written in the current ViewState.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool EnableScheduleItemsState { get; set; }

Visual Basic [image] Copy Code

Public Property EnableScheduleItemsState As Boolean

Property Value

true if the Schedule.Items collection is written in the current ViewState; otherwise false. Default value is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.EnableScheduleLocationsState Property

Calendar.EnableScheduleLocationsState Property
[image]

Gets or sets whether Locations are written in the current ViewState.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool EnableScheduleLocationsState { get; set; }

Visual Basic [image] Copy Code

Public Property EnableScheduleLocationsState As Boolean

Property Value

true if the Schedule.Locations collection is written in the current ViewState; otherwise false. Default value is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.EnableScheduleResourcesState Property

Calendar.EnableScheduleResourcesState Property
[image]

Gets or sets whether Resources are written in the current ViewState.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool EnableScheduleResourcesState { get; set; }

Visual Basic [image] Copy Code

Public Property EnableScheduleResourcesState As Boolean

Property Value

true if Schedule.Resources collection is written in the current ViewState; otherwise false. Default value is false.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.EnableScheduleTasksState Property

Calendar.EnableScheduleTasksState Property
[image]

Gets or sets whether Tasks are written in the current ViewState.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool EnableScheduleTasksState { get; set; }

Visual Basic [image] Copy Code

Public Property EnableScheduleTasksState As Boolean

Property Value

true if Schedule.Tasks collection is written in the current ViewState; otherwise false. Default value is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.EnableViewSettingsState Property

Calendar.EnableViewSettingsState Property
[image]

Gets or sets whether ViewSettings are written in the current ViewState.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool EnableViewSettingsState { get; set; }

Visual Basic [image] Copy Code

Public Property EnableViewSettingsState As Boolean

Property Value

true if the ViewSettings are written in the current ViewState; otherwise false. Default value is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.EndDate Property

Calendar.EndDate Property
[image]

Gets or sets the last date displayed in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime EndDate { get; set; }

Visual Basic [image] Copy Code

Public Property EndDate As DateTime

Property Value

An instance of the System.DateTime structure that specifies the last date displayed in the calendar. Default value is the end date of the current month.

Remarks

This member is only valid in WeekRange view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.FirstWeekendDay Property

Calendar.FirstWeekendDay Property
[image]

Gets or sets the first weekend day in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DayOfWeek FirstWeekendDay { get; set; }

Visual Basic [image] Copy Code

Public Property FirstWeekendDay As DayOfWeek

Property Value

One of the System.DayOfWeek enumeration values that specifies the first weekend day in the calendar. Default value is DayOfWeek.Saturday.

Remarks

Specifies which day to regard as start of the weekend.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Font Property

Calendar.Font Property
[image]

Gets the font associated with this control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override FontInfo Font { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Font As FontInfo

Property Value

An instance of the System.Web.UI.WebControls.FontInfo class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ForeColor Property

Calendar.ForeColor Property
[image]

Gets or sets the foreground color (typically the color of the text) of this control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Color ForeColor { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property ForeColor As Color

Property Value

An instance of the System.Drawing.Color structure that specifies the foreground color of the control.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.FormShowScript Property

Calendar.FormShowScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a built-in form is about to be shown.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string FormShowScript { get; set; }

Visual Basic [image] Copy Code

Public Property FormShowScript As String

Property Value

A string that specifies a JavaScript function that will handle the FormShow client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.GroupType Property

Calendar.GroupType Property
[image]

Gets or sets the grouping criteria for the Timetable view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public GroupType GroupType { get; set; }

Visual Basic [image] Copy Code

Public Property GroupType As GroupType

Property Value

One of the GroupType enumeration values that specifies the grouping criteria of the calendar. Default value is GroupType.None.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemChangeResourceKey Property

Calendar.ItemChangeResourceKey Property
[image]

Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Keys ItemChangeResourceKey { get; set; }

Visual Basic [image] Copy Code

Public Property ItemChangeResourceKey As Keys

Property Value

One of the Keys enumeration values. Default value is Keys.None.

Remarks

By default an item dragged in a grouped view can be dropped into any column (associated with different or the original resource). This behavior can be overridden by setting this property to a value different from Keys.None so that the dragged item can be dropped only in a column, associated with the original contact, location, task or resource.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemClickScript Property

Calendar.ItemClickScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a click event is raised from an item.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemClick client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemCloneKey Property

Calendar.ItemCloneKey Property
[image]

Gets or sets the modifier key, which when pressed allows users to interactively clone items.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Keys ItemCloneKey { get; set; }

Visual Basic [image] Copy Code

Public Property ItemCloneKey As Keys

Property Value

One of the Keys enumeration values that specifies the modifier key for cloning items. Default value is Keys.Shift.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemCreatedScript Property

Calendar.ItemCreatedScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked while an item has been created.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemCreatedScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemCreatedScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemCreated client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemCreatingScript Property

Calendar.ItemCreatingScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked while an item is being created.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemCreatingScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemCreatingScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemCreating client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemDeletedScript Property

Calendar.ItemDeletedScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when an item is deleted.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemDeletedScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemDeletedScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemDeleted client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemDeletingScript Property

Calendar.ItemDeletingScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when an item is about to be deleted.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemDeletingScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemDeletingScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemDeleting client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemDoubleClickScript Property

Calendar.ItemDoubleClickScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a doubleclick event is raised from an item.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemDoubleClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemDoubleClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemDoubleClick client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemDragEndScript Property

Calendar.ItemDragEndScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a drag operation on an item is finished.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemDragEndScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemDragEndScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemDragEnd client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemDragStartScript Property

Calendar.ItemDragStartScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a drag operation on an item is started.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemDragStartScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemDragStartScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemDragStart client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemInplaceEditEndingScript Property

Calendar.ItemInplaceEditEndingScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when inplace editing of item's text is about to be accepted.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemInplaceEditEndingScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemInplaceEditEndingScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemInplaceEditEnding client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemInplaceEditStartingScript Property

Calendar.ItemInplaceEditStartingScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when inplace editing of item's text is about to begin.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemInplaceEditStartingScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemInplaceEditStartingScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemInplaceEditStarting client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemModifiedScript Property

Calendar.ItemModifiedScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when an item is modified.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemModifiedScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemModifiedScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemModified client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemModifyingScript Property

Calendar.ItemModifyingScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked while an item is about to be modified.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemModifyingScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemModifyingScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemModifying client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemMouseDownScript Property

Calendar.ItemMouseDownScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mousedown event is raised from an item.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemMouseDownScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemMouseDownScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemMouseDown client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemMouseEnterScript Property

Calendar.ItemMouseEnterScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mouseover event is raised from an item.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemMouseEnterScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemMouseEnterScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemMouseEnter client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemMouseLeaveScript Property

Calendar.ItemMouseLeaveScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mouseout event is raised from an item.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemMouseLeaveScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemMouseLeaveScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemMouseLeave client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemMouseMoveScript Property

Calendar.ItemMouseMoveScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mousemove event is raised from an item.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemMouseMoveScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemMouseMoveScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemMouseMove client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemMouseUpScript Property

Calendar.ItemMouseUpScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mouseup event is raised from an item.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemMouseUpScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemMouseUpScript As String

Property Value

A A string that specifies a JavaScript function that will handle the ItemMouseUp client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemReminderTriggeredScript Property

Calendar.ItemReminderTriggeredScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when an item reminder is triggered.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemReminderTriggeredScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemReminderTriggeredScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemReminderTriggered client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemSelection Property

Calendar.ItemSelection Property
[image]

Gets an ItemSelection object representing the current selection of items in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemSelection ItemSelection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemSelection As ItemSelection

Property Value

An instance of the ItemSelection class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemSelectionChangedScript Property

Calendar.ItemSelectionChangedScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when the items selection changes.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemSelectionChangedScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemSelectionChangedScript As String

Property Value

A string that specifies a JavaScript function that will handle the ItemSelectionChanged client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemSettings Property

Calendar.ItemSettings Property
[image]

Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemSettings ItemSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemSettings As ItemSettings

Property Value

An instance of the ItemSettings class. Default value is a new ItemSettings object with the default values for the class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemTooltipFormat Property

Calendar.ItemTooltipFormat Property
[image]

Gets or sets the format of item tooltips.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemTooltipFormat { get; set; }

Visual Basic [image] Copy Code

Public Property ItemTooltipFormat As String

Property Value

A string value. Default value is the string "%s[d] %s[t] - %e[d] %e[t] %h %d".

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ListViewHeaderClickScript Property

Calendar.ListViewHeaderClickScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when the header in the ListView is clicked.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ListViewHeaderClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property ListViewHeaderClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the ListViewHeaderClickScript client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ListViewSettings Property

Calendar.ListViewSettings Property
[image]

Gets the ListViewSettings object used to customize the appearance of the List view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ListViewSettings ListViewSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ListViewSettings As ListViewSettings

Property Value

An instance of the ListViewSettings class. Default value is a new ListViewSettings class with all fields set to their default values.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.LocalizationInfo Property

Calendar.LocalizationInfo Property
[image]

Gets or sets the LocalizationInfo object containing the settings used to customize various UI controls within the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public LocalizationInfo LocalizationInfo { get; set; }

Visual Basic [image] Copy Code

Public Property LocalizationInfo As LocalizationInfo

Property Value

Type: LocalizationInfo

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Locations Property

Calendar.Locations Property
[image]

Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Location> Locations { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Locations As ResourceCollection(Of Location)

Property Value

An instance of the ResourceCollection class. Default value is an empty collection.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.MonthHeaderClickScript Property

Calendar.MonthHeaderClickScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when the calendar's header is clicked.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MonthHeaderClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property MonthHeaderClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the MonthHeaderClick client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.MonthRangeHeaderClickScript Property

Calendar.MonthRangeHeaderClickScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when the calendar's header is clicked.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MonthRangeHeaderClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property MonthRangeHeaderClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the MonthRangeHeaderClick client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.MonthRangeSettings Property

Calendar.MonthRangeSettings Property
[image]

Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public MonthRangeSettings MonthRangeSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MonthRangeSettings As MonthRangeSettings

Property Value

An instance of the MonthRangeSettings class. Default value is a new MonthRangeSettings object.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.MonthSettings Property

Calendar.MonthSettings Property
[image]

Gets the MonthSettings object used to customize the appearance of a month range in the SingleMonth view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public MonthSettings MonthSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MonthSettings As MonthSettings

Property Value

An instance of the MonthSettings class. Default value is a new MonthSettings object.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.MoreItemsCueMouseDownScript Property

Calendar.MoreItemsCueMouseDownScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mousedown event is raised from the items cue.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MoreItemsCueMouseDownScript { get; set; }

Visual Basic [image] Copy Code

Public Property MoreItemsCueMouseDownScript As String

Property Value

A string that specifies a JavaScript function that will handle the MoreItemsCueMouseDown client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.MoreItemsCueMouseUpScript Property

Calendar.MoreItemsCueMouseUpScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mouseup event is raised from the items cue.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MoreItemsCueMouseUpScript { get; set; }

Visual Basic [image] Copy Code

Public Property MoreItemsCueMouseUpScript As String

Property Value

A string that specifies a JavaScript function that will handle the MoreItemsCuewMouseUp client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.MouseEnterScript Property

Calendar.MouseEnterScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mouseover event is raised from the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MouseEnterScript { get; set; }

Visual Basic [image] Copy Code

Public Property MouseEnterScript As String

Property Value

A string that specifies a JavaScript function that will handle the MouseEnter client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.MouseLeaveScript Property

Calendar.MouseLeaveScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mouseout event is raised from the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MouseLeaveScript { get; set; }

Visual Basic [image] Copy Code

Public Property MouseLeaveScript As String

Property Value

A string that specifies a JavaScript function that will handle the MouseLeave client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.MouseMoveScript Property

Calendar.MouseMoveScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a mousemove event is raised from the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MouseMoveScript { get; set; }

Visual Basic [image] Copy Code

Public Property MouseMoveScript As String

Property Value

A string that specifies a JavaScript function that will handle the MouseMove client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.RecurrenceStringValidationScript Property

Calendar.RecurrenceStringValidationScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked after the recurrence information text in a popup form has changed.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceStringValidationScript { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceStringValidationScript As String

Property Value

Type: String

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.RecurringItemDeletingScript Property

Calendar.RecurringItemDeletingScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a recurring item is being deleted.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurringItemDeletingScript { get; set; }

Visual Basic [image] Copy Code

Public Property RecurringItemDeletingScript As String

Property Value

A string that specifies a JavaScript function that will handle the RecurringItemDeleting client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Resources Property

Calendar.Resources Property
[image]

Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Resource> Resources { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection class. Default value is an empty collection.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ResourceViewSettings Property

Calendar.ResourceViewSettings Property
[image]

Gets the ResourceViewSettings object used to customize the appearance of the Resource view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceViewSettings ResourceViewSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ResourceViewSettings As ResourceViewSettings

Property Value

Type: ResourceViewSettings

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Schedule Property

Calendar.Schedule Property
[image]

Gets or sets the schedule to be displayed inside the calendar control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Schedule Schedule { get; set; }

Visual Basic [image] Copy Code

Public Property Schedule As Schedule

Property Value

An instance of the Schedule class. Default value is an empty Schedule.

Remarks

You can change the schedule displayed by the control at any time by simply assigning a new Schedule object to this property. You can also make two or more MindFusion.Scheduling controls display the same schedule.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.SecondWeekendDay Property

Calendar.SecondWeekendDay Property
[image]

Gets the second day of the weekend.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected DayOfWeek SecondWeekendDay { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property SecondWeekendDay As DayOfWeek

Property Value

One of the DayOfWeek enumeration values that specifies the second weekend day. Default value is DayOfWeek.Sunday.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Selection Property

Calendar.Selection Property
[image]

Gets a Selection object representing the current selection in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Selection Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As Selection

Property Value

An instance of the Selection class. Default value is a new Selection object.

Remarks

Use the ItemSelection property to get the selection of schedule items.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.SelectionChangedScript Property

Calendar.SelectionChangedScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when the calendar date selection changes.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string SelectionChangedScript { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionChangedScript As String

Property Value

A string that specifies a JavaScript function that will handle the SelectionChanged client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.SelectionEndScript Property

Calendar.SelectionEndScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when cells' selection has ended.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string SelectionEndScript { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionEndScript As String

Property Value

A string that specifies a JavaScript function that will handle the SelectionEnd client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.SelectionStartScript Property

Calendar.SelectionStartScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when cells' selection has started.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string SelectionStartScript { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionStartScript As String

Property Value

A string that specifies a JavaScript function that will handle the SelectionStart client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ShowToolTips Property

Calendar.ShowToolTips Property
[image]

Gets or sets a value indicating whether the calendar displays tooltips.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool ShowToolTips { get; set; }

Visual Basic [image] Copy Code

Public Property ShowToolTips As Boolean

Property Value

true if tooltips are displayed; otherwise false. Default value is false.

Remarks

Tooltips can be displayed for schedule items and for the headers of the timetable view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.TagKey Property

Calendar.TagKey Property
[image]

WebControl.TagKey override. Gets the HtmlTextWriterTag value that corresponds to this Calendar control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override HtmlTextWriterTag TagKey { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property TagKey As HtmlTextWriterTag

Property Value

One of the HtmlTextWriterTag enumeration values. Default value is HtmlTextWriterTag.Div.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.TaskReminderTriggeredScript Property

Calendar.TaskReminderTriggeredScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a task reminder is triggered.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string TaskReminderTriggeredScript { get; set; }

Visual Basic [image] Copy Code

Public Property TaskReminderTriggeredScript As String

Property Value

A string that specifies a JavaScript function that will handle the TaskReminderTriggered client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Tasks Property

Calendar.Tasks Property
[image]

Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceCollection<Task> Tasks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Tasks As ResourceCollection(Of Task)

Property Value

An instance of the ResourceCollection class. Default value is an empty collection.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Theme Property

Calendar.Theme Property
[image]

Gets or sets the theme applied to the calendar control UI elements.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ThemeType Theme { get; set; }

Visual Basic [image] Copy Code

Public Property Theme As ThemeType

Property Value

One of the ThemeType Enumeration values that specifies the theme applied to the calendar. Default value is ThemeType.Standard.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.TimetableColumnHeaderClickScript Property

Calendar.TimetableColumnHeaderClickScript Property
[image]

Gets or sets the name of a JavaScript function that is invoked when a column header is clicked in the Timetable view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string TimetableColumnHeaderClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property TimetableColumnHeaderClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the TimetableColumnHeaderClick client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.TimetableSettings Property

Calendar.TimetableSettings Property
[image]

Gets the TimetableSettings object used to customize the appearance of days and hours in the Timetable view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimetableSettings TimetableSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TimetableSettings As TimetableSettings

Property Value

An instance of the TimetableSettings class. Default value is a new TimetableSettings object.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.UseForms Property

Calendar.UseForms Property
[image]

Gets or sets a value indicating whether the control should use the built-in forms.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool UseForms { get; set; }

Visual Basic [image] Copy Code

Public Property UseForms As Boolean

Property Value

true if built-in forms are used; otherwise false. Default value is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.WeekRangeHeaderClickScript Property

Calendar.WeekRangeHeaderClickScript Property
[image]

Gets or sets the name of a JavaScript function that is invoked when the view header is clicked in the WeekRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string WeekRangeHeaderClickScript { get; set; }

Visual Basic [image] Copy Code

Public Property WeekRangeHeaderClickScript As String

Property Value

A string that specifies a JavaScript function that will handle the WeekRangeHeaderClick client event. The default value is an empty string ("").

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.WeekRangeSettings Property

Calendar.WeekRangeSettings Property
[image]

Gets the WeekRangeSettings object used to customize the appearance of weeks in the WeekRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public WeekRangeSettings WeekRangeSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property WeekRangeSettings As WeekRangeSettings

Property Value

An instance of the WeekRangeSettings class. Default value is a new WeekRangeSettings object.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Height Property

Calendar.Height Property
[image]

WebControl.Height override.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Unit Height { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Height As Unit

Property Value

Type: Unit

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemResizeEndScript Property

Calendar.ItemResizeEndScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a resize operation on an item is finished.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemResizeEndScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemResizeEndScript As String

Property Value

Type: String

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemResizeStartScript Property

Calendar.ItemResizeStartScript Property
[image]

Gets or sets the name of a JavaScript function that should be invoked when a resize operation on an item is started.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ItemResizeStartScript { get; set; }

Visual Basic [image] Copy Code

Public Property ItemResizeStartScript As String

Property Value

Type: String

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.LicenseKey Property

Calendar.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

Type: String

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.Width Property

Calendar.Width Property
[image]

WebControl.Width override.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Unit Width { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Width As Unit

Property Value

Type: Unit

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar Events

Calendar Events
[image]

Public Events

Name | Description
ContactSerialization | Represents the method that will handle the ContactSerialization event.
CultureChanged | Raised when the calendar Culture has changed.
ItemCreated | Raised when a schedule item is created.
ItemDeleted | Raised when a schedule item is deleted.
ItemInplaceEdited | Raised when a schedule item's text is inplace-edited.
ItemModified | Raised when a schedule item is moved or resized by the user.
ItemSerialization | Raised when an item is about to be serialized.
LocationSerialization | Raised when a Location is about to be serialized.
RecurrenceSerialization | Raised when a Recurrence is about to be serialized.
ReminderSerialization | Raised when a Reminder is about to be serialized.
ResourceSerialization | Raised when a Resource is about to be serialized.
TaskSerialization | Raised when a Task is about to be serialized.
ThemeChanged | Raised when the calendar theme has changed.
VisibleDateChanged | Raised when the user selects another date using the month or year navigation controls on the calendar header area.

See Also

Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ContactSerialization Event

Calendar.ContactSerialization Event
[image]

Represents the method that will handle the ContactSerialization event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<SerializationEventArgs> ContactSerialization

Visual Basic [image] Copy Code

Public Event ContactSerialization As EventHandler(Of SerializationEventArgs)

Event Data

An object of type SerializationEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.CultureChanged Event

Calendar.CultureChanged Event
[image]

Raised when the calendar Culture has changed.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<CultureEventArgs> CultureChanged

Visual Basic [image] Copy Code

Public Event CultureChanged As EventHandler(Of CultureEventArgs)

Event Data

An object of type CultureEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemCreated Event

Calendar.ItemCreated Event
[image]

Raised when a schedule item is created.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemCreated

Visual Basic [image] Copy Code

Public Event ItemCreated As EventHandler(Of ItemEventArgs)

Event Data

An object of type ItemEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemDeleted Event

Calendar.ItemDeleted Event
[image]

Raised when a schedule item is deleted.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemDeleted

Visual Basic [image] Copy Code

Public Event ItemDeleted As EventHandler(Of ItemEventArgs)

Event Data

An object of type ItemEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemInplaceEdited Event

Calendar.ItemInplaceEdited Event
[image]

Raised when a schedule item's text is inplace-edited.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemInplaceEdited

Visual Basic [image] Copy Code

Public Event ItemInplaceEdited As EventHandler(Of ItemEventArgs)

Event Data

An object of type ItemEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemModified Event

Calendar.ItemModified Event
[image]

Raised when a schedule item is moved or resized by the user.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<ItemModifiedEventArgs> ItemModified

Visual Basic [image] Copy Code

Public Event ItemModified As EventHandler(Of ItemModifiedEventArgs)

Event Data

An object of type ItemModifiedEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ItemSerialization Event

Calendar.ItemSerialization Event
[image]

Raised when an item is about to be serialized.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<SerializationEventArgs> ItemSerialization

Visual Basic [image] Copy Code

Public Event ItemSerialization As EventHandler(Of SerializationEventArgs)

Event Data

An object of type SerializationEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.LocationSerialization Event

Calendar.LocationSerialization Event
[image]

Raised when a Location is about to be serialized.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<SerializationEventArgs> LocationSerialization

Visual Basic [image] Copy Code

Public Event LocationSerialization As EventHandler(Of SerializationEventArgs)

Event Data

An object of type SerializationEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.RecurrenceSerialization Event

Calendar.RecurrenceSerialization Event
[image]

Raised when a Recurrence is about to be serialized.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<SerializationEventArgs> RecurrenceSerialization

Visual Basic [image] Copy Code

Public Event RecurrenceSerialization As EventHandler(Of SerializationEventArgs)

Event Data

An object of type SerializationEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ReminderSerialization Event

Calendar.ReminderSerialization Event
[image]

Raised when a Reminder is about to be serialized.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<SerializationEventArgs> ReminderSerialization

Visual Basic [image] Copy Code

Public Event ReminderSerialization As EventHandler(Of SerializationEventArgs)

Event Data

An object of type SerializationEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ResourceSerialization Event

Calendar.ResourceSerialization Event
[image]

Raised when a Resource is about to be serialized.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<SerializationEventArgs> ResourceSerialization

Visual Basic [image] Copy Code

Public Event ResourceSerialization As EventHandler(Of SerializationEventArgs)

Event Data

An object of type SerializationEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.TaskSerialization Event

Calendar.TaskSerialization Event
[image]

Raised when a Task is about to be serialized.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<SerializationEventArgs> TaskSerialization

Visual Basic [image] Copy Code

Public Event TaskSerialization As EventHandler(Of SerializationEventArgs)

Event Data

An object of type SerializationEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.ThemeChanged Event

Calendar.ThemeChanged Event
[image]

Raised when the calendar theme has changed.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<ThemeEventArgs> ThemeChanged

Visual Basic [image] Copy Code

Public Event ThemeChanged As EventHandler(Of ThemeEventArgs)

Event Data

An object of type ThemeEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Calendar.VisibleDateChanged Event

Calendar.VisibleDateChanged Event
[image]

Raised when the user selects another date using the month or year navigation controls on the calendar header area.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler<DateChangedEventArgs> VisibleDateChanged

Visual Basic [image] Copy Code

Public Event VisibleDateChanged As EventHandler(Of DateChangedEventArgs)

Event Data

An object of type DateChangedEventArgs that holds data for the event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CalendarView Enumeration

CalendarView Enumeration
[image]

Specifies the type of view to display in a calendar control.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum CalendarView

Visual Basic [image] Copy Code

Public Enum CalendarView

Members

Member name | Value | Description
MonthRange | 0 | The calendar displays several months in a grid. The days of each month are visible too.
SingleMonth | 1 | The calendar displays a single month at a time. The days of the month are displayed in a grid.
WeekRange | 2 | The calendar displays a grid of days, with the columns representing the week days from Monday to Sunday and the rows representing weeks.
List | 3 | The calendar displays several seconds, minutes, hours, days, weeks, months or years in a row.
Timetable | 4 | The calendar displays a timetable where each row represents a fixed arbitrary time interval and each column represents a day. This view allows further division by various grouping criteria such as contacts, locations or tasks.
ResourceView | 5 | The calendar displays the distribution of items over a period of time.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings Class

CellSettings Class
[image]

Defines appearance settings for the cells representing time ranges in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class CellSettings : ViewSettings, ICloneable

Visual Basic [image] Copy Code

Public Class CellSettings
Inherits ViewSettings
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ViewSettings
MindFusion.Scheduling.WebForms.CellSettings

See Also

CellSettings Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings Members

CellSettings Members
Properties Methods Events
[image]

Defines appearance settings for the cells representing time ranges in the calendar.

The following tables list the members exposed by the CellSettings type.

Public Properties

Name | Description
FirstDayOfMonthFormat | Gets or sets the string used to format and display the first day of each month in the calendar.
FirstDayOfYearFormat | Gets or sets the string used to format and display the first day of each year in the calendar.
GeneralFormat | Gets or sets the string used to format and display dates and times in the calendar.
HeaderSize | Gets or sets the size of the cell header in pixels.
HeaderStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
Margin | Gets or sets the distance between the outermost border of the cell and the cell contents.
ShowToday | Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TodayColor | Gets or sets the color used to paint the line that marks the current cell.
TodayFillColor | Gets or sets the color used to fill the header of the current cell.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

Public Methods

Name | Description
Clone | Creates a copy of the cell settings object.
LoadViewState | Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server Calendar control so they can be stored in the control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

Inherited Public Events

Name | Description
SettingsChanged | Raised when the view settings change. (Inherited from ViewSettings.)

See Also

CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings Methods

CellSettings Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of the cell settings object.
LoadViewState | Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server Calendar control so they can be stored in the control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

See Also

CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.Clone Method

CellSettings.Clone Method
[image]

Creates a copy of the cell settings object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

Type: Object
A new CellSettings object identical to the current one.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.LoadViewState Method

CellSettings.LoadViewState Method
[image]

Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.SaveViewState Method

CellSettings.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.TrackViewState Method

CellSettings.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server Calendar control so they can be stored in the control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings Properties

CellSettings Properties
[image]

Public Properties

Name | Description
FirstDayOfMonthFormat | Gets or sets the string used to format and display the first day of each month in the calendar.
FirstDayOfYearFormat | Gets or sets the string used to format and display the first day of each year in the calendar.
GeneralFormat | Gets or sets the string used to format and display dates and times in the calendar.
HeaderSize | Gets or sets the size of the cell header in pixels.
HeaderStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
Margin | Gets or sets the distance between the outermost border of the cell and the cell contents.
ShowToday | Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TodayColor | Gets or sets the color used to paint the line that marks the current cell.
TodayFillColor | Gets or sets the color used to fill the header of the current cell.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

See Also

CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.FirstDayOfMonthFormat Property

CellSettings.FirstDayOfMonthFormat Property
[image]

Gets or sets the string used to format and display the first day of each month in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string FirstDayOfMonthFormat { get; set; }

Visual Basic [image] Copy Code

Public Property FirstDayOfMonthFormat As String

Property Value

A string that represents the format of the first day of each month. Default value is "d".

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.FirstDayOfYearFormat Property

CellSettings.FirstDayOfYearFormat Property
[image]

Gets or sets the string used to format and display the first day of each year in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string FirstDayOfYearFormat { get; set; }

Visual Basic [image] Copy Code

Public Property FirstDayOfYearFormat As String

Property Value

A string that represents the format of the first day in each year. Default value is "d".

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.GeneralFormat Property

CellSettings.GeneralFormat Property
[image]

Gets or sets the string used to format and display dates and times in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string GeneralFormat { get; set; }

Visual Basic [image] Copy Code

Public Property GeneralFormat As String

Property Value

A string that represents the general format of dates in the calendar. Default value is "d".

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.HeaderSize Property

CellSettings.HeaderSize Property
[image]

Gets or sets the size of the cell header in pixels.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit HeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderSize As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure specifying the cells' header size. Default value is an empty structure.

Remarks

Specifying 0 for this property expands the header to fill the entire cell in SingleMonth, MonthRange and WeekRange views. In List view, setting the value to 0 will set the height of the header to 0 and it will not be visible.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.HeaderStyle Property

CellSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle HeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.Margin Property

CellSettings.Margin Property
[image]

Gets or sets the distance between the outermost border of the cell and the cell contents.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Margin { get; set; }

Visual Basic [image] Copy Code

Public Property Margin As Integer

Property Value

An int value that represents the margin. Default value is 0.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.ShowToday Property

CellSettings.ShowToday Property
[image]

Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowToday { get; set; }

Visual Basic [image] Copy Code

Public Property ShowToday As State

Property Value

One of the MindFusion.Scheduling.State enumeration members. Default value is State.Disabled.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.Style Property

CellSettings.Style Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Style Style { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Style As Style

Property Value

An instance of the MindFusion.Scheduling.Style class. Default value is null.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.TodayColor Property

CellSettings.TodayColor Property
[image]

Gets or sets the color used to paint the line that marks the current cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Color TodayColor { get; set; }

Visual Basic [image] Copy Code

Public Property TodayColor As Color

Property Value

An instance of the System.Drawing.Color structure that specifies the color used to paint the line that marks the current cell. Default value is Color.Orange.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.CellSettings.TodayFillColor Property

CellSettings.TodayFillColor Property
[image]

Gets or sets the color used to fill the header of the current cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Color TodayFillColor { get; set; }

Visual Basic [image] Copy Code

Public Property TodayFillColor As Color

Property Value

An instance of the System.Drawing.Color structure that specifies the color used to fill the current cell. Default value is Color #FFBE50.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ContinuationArrows Enumeration

ContinuationArrows Enumeration
[image]

Gets or sets the type of the continuation arrows.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum ContinuationArrows

Visual Basic [image] Copy Code

Public Enum ContinuationArrows

Members

Member name | Value | Description
None | -2 | No continuation arrows are drawn.
Previous | -1 | The continuation arrow points to the previous item.
Both | 0 | The continuation arrow points to both the previous and the next item.
Next | 1 | The continuation arrow points to the next item.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.DayOfWeekFormat Enumeration

DayOfWeekFormat Enumeration
[image]

Specifies the display format of a day of the week.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum DayOfWeekFormat

Visual Basic [image] Copy Code

Public Enum DayOfWeekFormat

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
SingleLetter | 0 | Only the first letter of the name of the day is displayed.
Abbreviated | 1 | The first three letters of the day of the week are displayed.
Full | 2 | The complete name of the day of the week is displayed.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize Class

ElementSize Class
[image]

A class that stores width/height pairs.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ElementSize : IStateManager, ICloneable

Visual Basic [image] Copy Code

Public Class ElementSize
Implements IStateManager, ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ElementSize

See Also

ElementSize Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize Members

ElementSize Members
Constructors Properties Methods Events
[image]

A class that stores width/height pairs.

The following tables list the members exposed by the ElementSize type.

Public Constructors

Name | Description
ElementSize | Initializes a new instance of the ElementSize class.

Public Properties

Name | Description
Height | Gets or sets the height.
IsEmpty | Gets a value that indicates whether the current ElementSize is empty.
IsHeightSet | Gets a value that indicates whether the height is set.
IsWidthSet | Gets a value that indicates whether the width is set.
Width | Gets or sets the width.

Public Methods

Name | Description
Clone | Creates a copy of this ElementSize object.

Public Events

Name | Description
Changed | Raised when a property value changes.

See Also

ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize Constructor

ElementSize Constructor
[image]

Initializes a new instance of the ElementSize class.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ElementSize ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize Methods

ElementSize Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this ElementSize object.

See Also

ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize.Clone Method

ElementSize.Clone Method
[image]

Creates a copy of this ElementSize object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

Type: Object
A new ElementSize object identical to the current one.

See Also

ElementSize Members
ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize Properties

ElementSize Properties
[image]

Public Properties

Name | Description
Height | Gets or sets the height.
IsEmpty | Gets a value that indicates whether the current ElementSize is empty.
IsHeightSet | Gets a value that indicates whether the height is set.
IsWidthSet | Gets a value that indicates whether the width is set.
Width | Gets or sets the width.

See Also

ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize.Height Property

ElementSize.Height Property
[image]

Gets or sets the height.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Unit

Property Value

A System.Web.UI.WebControl.Unit value that represents the height. Default value is Unit.Empty.

See Also

ElementSize Members
ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize.IsEmpty Property

ElementSize.IsEmpty Property
[image]

Gets a value that indicates whether the current ElementSize is empty.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if both Width and Height of this ElementSize are 0; otherwise false.

See Also

ElementSize Members
ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize.IsHeightSet Property

ElementSize.IsHeightSet Property
[image]

Gets a value that indicates whether the height is set.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsHeightSet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsHeightSet As Boolean

Property Value

true if Height is set; otherwise false.

See Also

ElementSize Members
ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize.IsWidthSet Property

ElementSize.IsWidthSet Property
[image]

Gets a value that indicates whether the width is set.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsWidthSet { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsWidthSet As Boolean

Property Value

true if the width is set; otherwise false.

See Also

ElementSize Members
ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize.Width Property

ElementSize.Width Property
[image]

Gets or sets the width.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Unit

Property Value

A System.Web.UI.WebControl.Unit value that represents the width. Default value is Unit.Empty.

See Also

ElementSize Members
ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize Events

ElementSize Events
[image]

Public Events

Name | Description
Changed | Raised when a property value changes.

See Also

ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ElementSize.Changed Event

ElementSize.Changed Event
[image]

Raised when a property value changes.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

Event Data

An instance of the System.EventArgs class.

See Also

ElementSize Members
ElementSize Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemConverter Class

ItemConverter Class
Remarks See Also
[image]

Provides a JavaScriptConverter to convert Item objects to and from other representations.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ItemConverter : JavaScriptConverter

Visual Basic [image] Copy Code

Public Class ItemConverter
Inherits JavaScriptConverter

Remarks

This class supports the internal Calendar infrastructure and is not intended to be used directly from your code.

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Scheduling.WebForms.ItemConverter

See Also

ItemConverter Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemConverter Members

ItemConverter Members
Constructors Properties Methods
[image]

Provides a JavaScriptConverter to convert Item objects to and from other representations.

The following tables list the members exposed by the ItemConverter type.

Public Constructors

Name | Description
ItemConverter | Creates a new instance of the ItemConverter class.

Public Properties

Name | Description
SupportedTypes | JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

Public Methods

Name | Description
Deserialize | Converts the provided dictionary into an object of the specified type.
Serialize | JavaScriptSerializer.Serialize override. Builds a dictionary of name/value pairs.

See Also

ItemConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemConverter Constructor

ItemConverter Constructor
[image]

Creates a new instance of the ItemConverter class.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemConverter (
Calendar calendar
)

Visual Basic [image] Copy Code

Public New ( _
calendar As Calendar _
)

Parameters

calendar
Type: Calendar
The Calendar object that holds the item to convert.

See Also

ItemConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemConverter Methods

ItemConverter Methods
[image]

Public Methods

Name | Description
Deserialize | Converts the provided dictionary into an object of the specified type.
Serialize | JavaScriptSerializer.Serialize override. Builds a dictionary of name/value pairs.

See Also

ItemConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemConverter.Deserialize Method

ItemConverter.Deserialize Method
[image]

Converts the provided dictionary into an object of the specified type.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary
Type: IDictionary<String, Object>
An IDictionary<string, object> list with property data stored as name/value pairs.
type
Type: Type
The System.Type of the resulting object.
serializer
Type: JavaScriptSerializer
The System.Web.Script.Serialization.JavaScriptSerializer instance.

Return Value

Type: Object
Always returns null.

See Also

ItemConverter Members
ItemConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemConverter.Serialize Method

ItemConverter.Serialize Method
[image]

JavaScriptSerializer.Serialize override. Builds a dictionary of name/value pairs.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

Type: Object
The item to serialize.

serializer

Type: JavaScriptSerializer
The object that is responsible for the serialization.

Return Value

Type: IDictionary(String, Object)
An object that contains key/value pairs that represent the object’s data.

See Also

ItemConverter Members
ItemConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemConverter Properties

ItemConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

See Also

ItemConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemConverter.SupportedTypes Property

ItemConverter.SupportedTypes Property
[image]

JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

A collection with Item and Appointment types that are supported by the ItemConverter.

See Also

ItemConverter Members
ItemConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemModifyAction Enumeration

ItemModifyAction Enumeration
[image]

Specifies the type of modification action used, when an item is modified.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum ItemModifyAction

Visual Basic [image] Copy Code

Public Enum ItemModifyAction

Members

Member name | Value | Description
Edit | 0 | Specifies that the item was modified through a modification of one or more of its properties, excluding drag and resize interactive operations.
Drag | 1 | Specifies that the item is modified through an interactive drag operation.
Resize | 2 | Specifies that the item is modified through an interactive resize operation.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection Class

ItemSelection Class
[image]

Instances of the class represent sets of selected schedule items.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class ItemSelection : IStateManager

Visual Basic [image] Copy Code

Public NotInheritable Class ItemSelection
Implements IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ItemSelection

See Also

ItemSelection Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection Members

ItemSelection Members
Properties Methods
[image]

Instances of the class represent sets of selected schedule items.

The following tables list the members exposed by the ItemSelection type.

Public Properties

Name | Description
Count | Gets the number of selected items.
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.
Items | Gets the selected items.

Public Methods

Name | Description
Add | Adds the specified Item to the selection.
Clear | Clears the selection.
Contains | Checks if the specified item is in the collection.
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
Remove | Removes the specified Item from the selection.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

See Also

ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection Methods

ItemSelection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified Item to the selection.
Clear | Clears the selection.
Contains | Checks if the specified item is in the collection.
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
Remove | Removes the specified Item from the selection.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

See Also

ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection.Add Method

ItemSelection.Add Method
[image]

Adds the specified Item to the selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Add (
Item item
)

Visual Basic [image] Copy Code

Public Sub Add( _
item As Item _
)

Parameters

item
Type: Item
The Item to add.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection.Clear Method

ItemSelection.Clear Method
[image]

Clears the selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection.Contains Method

ItemSelection.Contains Method
[image]

Checks if the specified item is in the collection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool Contains (
Item item
)

Visual Basic [image] Copy Code

Public Function Contains( _
item As Item _
) As Boolean

Parameters

item
Type: Item
The Item instance to check.

Return Value

true if the item is contained in the collection; otherwise false.

Remarks

If the item is in the collection then it is selected.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection.LoadViewState Method

ItemSelection.LoadViewState Method
[image]

WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection.Remove Method

ItemSelection.Remove Method
[image]

Removes the specified Item from the selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Remove (
Item item
)

Visual Basic [image] Copy Code

Public Sub Remove( _
item As Item _
)

Parameters

item
Type: Item
The Item instance to be removed from the selection.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection.SaveViewState Method

ItemSelection.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object SaveViewState ()

Visual Basic [image] Copy Code

Public Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection.TrackViewState Method

ItemSelection.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void TrackViewState ()

Visual Basic [image] Copy Code

Public Sub TrackViewState ()

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection Properties

ItemSelection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of selected items.
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.
Items | Gets the selected items.

See Also

ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection.Count Property

ItemSelection.Count Property
[image]

Gets the number of selected items.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value specifying the number of selected items.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection.IsTrackingViewState Property

ItemSelection.IsTrackingViewState Property
[image]

IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

true if the control saves its state; otherwise, false.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSelection.Items Property

ItemSelection.Items Property
[image]

Gets the selected items.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Item[] Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As Item()

Property Value

An array of selected Item objects.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings Class

ItemSettings Class
[image]

Defines properties that enable appearance customization of schedule items in the calendar views.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ItemSettings : IStateManager

Visual Basic [image] Copy Code

Public Class ItemSettings
Implements IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ItemSettings

See Also

ItemSettings Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings Members

ItemSettings Members
Properties Methods Events
[image]

Defines properties that enable appearance customization of schedule items in the calendar views.

The following tables list the members exposed by the ItemSettings type.

Public Properties

Name | Description
CssClass | Gets or sets the default CSS class for all appointments whose CSS is not explicitly specified.
EnableTags | Gets or sets a value indicating whether whether tags are allowed in the header text of the item.
HeaderSize | Gets or sets the size of the item header for non-all day items in the Timetable view.
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.
ItemsVisible | Gets or sets a value indicating whether to display schedule items in the calendar.
ResizeBandSize | Gets or sets the width of the resize handle.
ShowContinuationArrows | Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' link in a calendar cell which isn't big enough to contain all of its items.
ShowRecurrenceExceptionIcons | Gets or sets a value indicating whether the icon of recurrence exception items is displayed.
ShowRecurrenceIcons | Gets or sets a value indicating whether the icon of recurring items is displayed.
ShowReminderIcons | Gets or sets a value indicating whether the reminder icon of items is displayed.
Size | Gets or sets the size of schedule items drawn in the calendar.
Spacing | Gets or sets the amount of space between adjacent items.
Style | Gets or sets the Style used to paint schedule items that don't have a distinct style assigned to them.

Protected Properties

Name | Description
ViewState | Gets the ViewState. Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server side view-state changes that have occurred in the ItemSettings since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Protected Methods

Name | Description
OnSettingsChanged | Fires the SettingsChanged event.

Public Events

Name | Description
SettingsChanged | Raised when an ItemSettings object has changed.

See Also

ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings Methods

ItemSettings Methods
[image]

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server side view-state changes that have occurred in the ItemSettings since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Protected Methods

Name | Description
OnSettingsChanged | Fires the SettingsChanged event.

See Also

ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.LoadViewState Method

ItemSettings.LoadViewState Method
[image]

WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.OnSettingsChanged Method

ItemSettings.OnSettingsChanged Method
[image]

Fires the SettingsChanged event.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual void OnSettingsChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSettingsChanged( _
e As EventArgs _
)

Parameters

e
Type: EventArgs
An instance of the System.EventArgs class that contains the event data.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.SaveViewState Method

ItemSettings.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server side view-state changes that have occurred in the ItemSettings since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object SaveViewState ()

Visual Basic [image] Copy Code

Public Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.TrackViewState Method

ItemSettings.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void TrackViewState ()

Visual Basic [image] Copy Code

Public Sub TrackViewState ()

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings Properties

ItemSettings Properties
[image]

Public Properties

Name | Description
CssClass | Gets or sets the default CSS class for all appointments whose CSS is not explicitly specified.
EnableTags | Gets or sets a value indicating whether whether tags are allowed in the header text of the item.
HeaderSize | Gets or sets the size of the item header for non-all day items in the Timetable view.
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.
ItemsVisible | Gets or sets a value indicating whether to display schedule items in the calendar.
ResizeBandSize | Gets or sets the width of the resize handle.
ShowContinuationArrows | Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' link in a calendar cell which isn't big enough to contain all of its items.
ShowRecurrenceExceptionIcons | Gets or sets a value indicating whether the icon of recurrence exception items is displayed.
ShowRecurrenceIcons | Gets or sets a value indicating whether the icon of recurring items is displayed.
ShowReminderIcons | Gets or sets a value indicating whether the reminder icon of items is displayed.
Size | Gets or sets the size of schedule items drawn in the calendar.
Spacing | Gets or sets the amount of space between adjacent items.
Style | Gets or sets the Style used to paint schedule items that don't have a distinct style assigned to them.

Protected Properties

Name | Description
ViewState | Gets the ViewState. Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.

See Also

ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.CssClass Property

ItemSettings.CssClass Property
[image]

Gets or sets the default CSS class for all appointments whose CSS is not explicitly specified.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string CssClass { get; set; }

Visual Basic [image] Copy Code

Public Property CssClass As String

Property Value

A string that identifies the CSS class. Default value is an empty string.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.EnableTags Property

ItemSettings.EnableTags Property
[image]

Gets or sets a value indicating whether whether tags are allowed in the header text of the item.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State EnableTags { get; set; }

Visual Basic [image] Copy Code

Public Property EnableTags As State

Property Value

One of the State enumeration values that specifies whether tags are allowed in the header text of the items. Default is State.Disabled.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.HeaderSize Property

ItemSettings.HeaderSize Property
[image]

Gets or sets the size of the item header for non-all day items in the Timetable view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit HeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderSize As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure specifying the header size of non-all day items in Timetable view. Default value is 20px.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.IsTrackingViewState Property

ItemSettings.IsTrackingViewState Property
[image]

IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

Type: Boolean
true if the control is saving changes to its ViewState; otherwise false.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.ItemsVisible Property

ItemSettings.ItemsVisible Property
[image]

Gets or sets a value indicating whether to display schedule items in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ItemsVisible { get; set; }

Visual Basic [image] Copy Code

Public Property ItemsVisible As State

Property Value

One of the State enumeration values that specifies whether to display items in the calendar. Default value is State.Enabled.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.ResizeBandSize Property

ItemSettings.ResizeBandSize Property
[image]

Gets or sets the width of the resize handle.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int ResizeBandSize { get; set; }

Visual Basic [image] Copy Code

Public Property ResizeBandSize As Integer

Property Value

A non-negative integer value specifying the width of the items' resize handle in pixels. Default is 5.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.ShowContinuationArrows Property

ItemSettings.ShowContinuationArrows Property
[image]

Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowContinuationArrows { get; set; }

Visual Basic [image] Copy Code

Public Property ShowContinuationArrows As State

Property Value

One of the State enumeration values that specifies whether to display items' continuation arrows. Default value is State.Enabled.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.ShowMoreItemsCue Property

ItemSettings.ShowMoreItemsCue Property
[image]

Gets or sets a value indicating whether to display a 'more items' link in a calendar cell which isn't big enough to contain all of its items.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowMoreItemsCue { get; set; }

Visual Basic [image] Copy Code

Public Property ShowMoreItemsCue As State

Property Value

One of the State enumeration values that specifies whether to display the 'more items' link in a calendar cell. Default value is State.Enabled.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.ShowRecurrenceExceptionIcons Property

ItemSettings.ShowRecurrenceExceptionIcons Property
[image]

Gets or sets a value indicating whether the icon of recurrence exception items is displayed.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowRecurrenceExceptionIcons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowRecurrenceExceptionIcons As State

Property Value

One of the State enumeration values that specifies whether to display recurrence exceptions icons. Default value is State.Enabled.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.ShowRecurrenceIcons Property

ItemSettings.ShowRecurrenceIcons Property
[image]

Gets or sets a value indicating whether the icon of recurring items is displayed.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowRecurrenceIcons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowRecurrenceIcons As State

Property Value

One of the State enumeration values that specifies whether to display recurrence icons. Default value is State.Enabled.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.ShowReminderIcons Property

ItemSettings.ShowReminderIcons Property
[image]

Gets or sets a value indicating whether the reminder icon of items is displayed.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowReminderIcons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowReminderIcons As State

Property Value

One of the State enumeration values that specifies whether to display reminder icons. Default value is State.Enabled.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.Size Property

ItemSettings.Size Property
[image]

Gets or sets the size of schedule items drawn in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As Integer

Property Value

A non-negative integer value specifying the items' size in pixels. Default is 17.

Remarks

The size of an item is its height when the items are positioned horizontally or its width when positioned vertically.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.Spacing Property

ItemSettings.Spacing Property
[image]

Gets or sets the amount of space between adjacent items.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Spacing { get; set; }

Visual Basic [image] Copy Code

Public Property Spacing As Integer

Property Value

A non-negative integer value specifying the space between adjacent items in pixels. Default value is 1.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.Style Property

ItemSettings.Style Property
[image]

Gets or sets the Style used to paint schedule items that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ItemStyle Style { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Style As ItemStyle

Property Value

An instance of the Style class. Default value is null.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.ViewState Property

ItemSettings.ViewState Property
[image]

Gets the ViewState. Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual StateBag ViewState { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property ViewState As StateBag

Property Value

An instance of the System.Web.UI.StateBag class that contains the server control's view-state information.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings Events

ItemSettings Events
[image]

Public Events

Name | Description
SettingsChanged | Raised when an ItemSettings object has changed.

See Also

ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ItemSettings.SettingsChanged Event

ItemSettings.SettingsChanged Event
[image]

Raised when an ItemSettings object has changed.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler SettingsChanged

Visual Basic [image] Copy Code

Public Event SettingsChanged As EventHandler

Event Data

An instance of the System.EventArgs class that provides data for the event.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Keys Enumeration

Keys Enumeration
[image]

Identifies special Keys.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum Keys

Visual Basic [image] Copy Code

Public Enum Keys

Members

Member name | Value | Description
None | 0 | No key pressed.
Shift | 1 | The SHIFT modifier key.
Control | 2 | The CTRL modifier key.
Alt | 3 | The ALT modifier key.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewHeaderStyles Enumeration

ListViewHeaderStyles Enumeration
[image]

Specifies the appearance and behavior of the header in a List view. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum ListViewHeaderStyles

Visual Basic [image] Copy Code

Public Enum ListViewHeaderStyles

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
None | 0 | Do not display a header.
Title | 1 | Display the cells' dates in the header.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings Class

ListViewSettings Class
[image]

Defines properties that allow customizing the appearance of the calendar in List view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class ListViewSettings : ViewSettings

Visual Basic [image] Copy Code

Public NotInheritable Class ListViewSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ViewSettings
MindFusion.Scheduling.WebForms.ListViewSettings

See Also

ListViewSettings Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings Members

ListViewSettings Members
Properties Methods Events
[image]

Defines properties that allow customizing the appearance of the calendar in List view.

The following tables list the members exposed by the ListViewSettings type.

Public Properties

Name | Description
ButtonStyle | Gets the ButtonsStyle object used to specify appearance settings for the navigation buttons.
CellSettings | Gets a CellSettings object used to customize the visualization of cells in the List view.
CellSpacing | Gets or sets the amount space between adjacent cells.
CellUnits | Gets or sets the resolution of the list view.
EvenWeeksFillColor | Gets or sets the color used to paint the background of the contents of weeks with even number.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the group header.
HeaderStyle | Gets or sets the style of the ListView header.
MainHeaderSize | Gets or sets the main header size.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header
MaxItems | Gets or sets the maximum number of items to be displayed in a day cell.
NumberOfCells | Gets or sets the total number of cells to be displayed in the ListView.
OddWeeksFillColor | Gets or sets the color used to paint the background of the contents of weeks with odd number.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
ShowNavigationButtons | Gets or sets a value indicating whether the ListView displays navigation buttons.
Style | Gets or sets the appearance style used to paint the calendar.
TitleFormat | Gets or sets a string used to format the title of cells.
VisibleCells | Gets or sets the number of cells visible at the same time.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

Inherited Public Events

Name | Description
SettingsChanged | Raised when the view settings change. (Inherited from ViewSettings.)

See Also

ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings Methods

ListViewSettings Methods
[image]

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

See Also

ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.LoadViewState Method

ListViewSettings.LoadViewState Method
[image]

WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.SaveViewState Method

ListViewSettings.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.TrackViewState Method

ListViewSettings.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings Properties

ListViewSettings Properties
[image]

Public Properties

Name | Description
ButtonStyle | Gets the ButtonsStyle object used to specify appearance settings for the navigation buttons.
CellSettings | Gets a CellSettings object used to customize the visualization of cells in the List view.
CellSpacing | Gets or sets the amount space between adjacent cells.
CellUnits | Gets or sets the resolution of the list view.
EvenWeeksFillColor | Gets or sets the color used to paint the background of the contents of weeks with even number.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the group header.
HeaderStyle | Gets or sets the style of the ListView header.
MainHeaderSize | Gets or sets the main header size.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header
MaxItems | Gets or sets the maximum number of items to be displayed in a day cell.
NumberOfCells | Gets or sets the total number of cells to be displayed in the ListView.
OddWeeksFillColor | Gets or sets the color used to paint the background of the contents of weeks with odd number.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
ShowNavigationButtons | Gets or sets a value indicating whether the ListView displays navigation buttons.
Style | Gets or sets the appearance style used to paint the calendar.
TitleFormat | Gets or sets a string used to format the title of cells.
VisibleCells | Gets or sets the number of cells visible at the same time.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

See Also

ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.ButtonStyle Property

ListViewSettings.ButtonStyle Property
[image]

Gets the ButtonsStyle object used to specify appearance settings for the navigation buttons.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ButtonsStyle ButtonStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ButtonStyle As ButtonsStyle

Property Value

An instance of the ButtonsStyle class. Default value is a new ButtonsStyle object.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.CellSettings Property

ListViewSettings.CellSettings Property
[image]

Gets a CellSettings object used to customize the visualization of cells in the List view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CellSettings CellSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CellSettings As CellSettings

Property Value

An instance of the CellSettings class.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.CellSpacing Property

ListViewSettings.CellSpacing Property
[image]

Gets or sets the amount space between adjacent cells.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int CellSpacing { get; set; }

Visual Basic [image] Copy Code

Public Property CellSpacing As Integer

Property Value

A non-negative integer value specifying the amount of space between adjacent cells in pixels. Default value is 0.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.CellUnits Property

ListViewSettings.CellUnits Property
[image]

Gets or sets the resolution of the list view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimeUnit CellUnits { get; set; }

Visual Basic [image] Copy Code

Public Property CellUnits As TimeUnit

Property Value

One of the TimeUnit Enumeration values that specifies the resolution of the view. Default value is TimeUnit.Unspecified.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.EvenWeeksFillColor Property

ListViewSettings.EvenWeeksFillColor Property
[image]

Gets or sets the color used to paint the background of the contents of weeks with even number.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CssBackground EvenWeeksFillColor { get; set; }

Visual Basic [image] Copy Code

Public Property EvenWeeksFillColor As CssBackground

Property Value

An instance of the CssBackground class that specifies the color used to paint the even weeks. Default value is null.

Remarks

If this property is set to null, the color from the associated style is used.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.GroupHeaderSize Property

ListViewSettings.GroupHeaderSize Property
[image]

Gets or sets the size of the group header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit GroupHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property GroupHeaderSize As Unit

Property Value

Type: Unit

Remarks

A value of 0 causes the calendar to automatically calculate a header size based on the size of the header font.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.GroupHeaderStyle Property

ListViewSettings.GroupHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the group header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle GroupHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property GroupHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.HeaderStyle Property

ListViewSettings.HeaderStyle Property
[image]

Gets or sets the style of the ListView header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ListViewHeaderStyles HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As ListViewHeaderStyles

Property Value

One of the ListViewHeaderStyles enumeration members. Default value is ListViewHeaderStyles.Title

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.MainHeaderSize Property

ListViewSettings.MainHeaderSize Property
[image]

Gets or sets the main header size.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit MainHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property MainHeaderSize As Unit

Property Value

Type: Unit

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.MainHeaderStyle Property

ListViewSettings.MainHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the main header

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle MainHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MainHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.MaxItems Property

ListViewSettings.MaxItems Property
[image]

Gets or sets the maximum number of items to be displayed in a day cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int MaxItems { get; set; }

Visual Basic [image] Copy Code

Public Property MaxItems As Integer

Property Value

A non-negative integer value specifying the number of items to be displayed in a day cell. Default value is 0.

Remarks

If the value of the MaxItems property is set to 0 then the number of items to be displayed will be calculated on the client side.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.NumberOfCells Property

ListViewSettings.NumberOfCells Property
[image]

Gets or sets the total number of cells to be displayed in the ListView.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int NumberOfCells { get; set; }

Visual Basic [image] Copy Code

Public Property NumberOfCells As Integer

Property Value

A non-negative integer value specifying the total number of cells to be displayed in the ListView. Default value is 14.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.OddWeeksFillColor Property

ListViewSettings.OddWeeksFillColor Property
[image]

Gets or sets the color used to paint the background of the contents of weeks with odd number.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CssBackground OddWeeksFillColor { get; set; }

Visual Basic [image] Copy Code

Public Property OddWeeksFillColor As CssBackground

Property Value

An instance of the CssBackground class that specifies the color used to paint odd weeks. Default value is null.

Remarks

If this property is set to null, the color from the associated style is used.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.Orientation Property

ListViewSettings.Orientation Property
[image]

Gets or sets a value indicating whether the cells are displayed horizontally or vertically.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

Type: Orientation

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.ShowNavigationButtons Property

ListViewSettings.ShowNavigationButtons Property
[image]

Gets or sets a value indicating whether the ListView displays navigation buttons.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowNavigationButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowNavigationButtons As State

Property Value

One of the State enumeration values that specifies whether navigation buttons are displayed in the view. Default value is State.Disabled e.g. navigation buttons are not shown.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.Style Property

ListViewSettings.Style Property
[image]

Gets or sets the appearance style used to paint the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Style Style { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Style As Style

Property Value

An instance of the Style class. Default value is null.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.TitleFormat Property

ListViewSettings.TitleFormat Property
[image]

Gets or sets a string used to format the title of cells.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string that specifies the format used for cells' titles. Default value is "ddd,<br />dd MMM".

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ListViewSettings.VisibleCells Property

ListViewSettings.VisibleCells Property
[image]

Gets or sets the number of cells visible at the same time.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int VisibleCells { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleCells As Integer

Property Value

A non-negative integer value specifying the number of cells visible at the same time. Default value is 7.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo Class

LocalizationInfo Class
[image]

Represents a container of localized strings, used by various UI elements accross the Calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class LocalizationInfo : IStateManager

Visual Basic [image] Copy Code

Public Class LocalizationInfo
Implements IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.LocalizationInfo

See Also

LocalizationInfo Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo Members

LocalizationInfo Members
Constructors Properties Methods
[image]

Represents a container of localized strings, used by various UI elements accross the Calendar.

The following tables list the members exposed by the LocalizationInfo type.

Public Constructors

Name | Description
LocalizationInfo | Initializes a new instance of the LocalizationInfo class.

Public Properties

Name | Description
AllDayEventCaption | Gets or sets the string representing a 'all day event' caption.
CancelButtonCaption | Gets or sets the string to be displayed as a caption for a 'cancel' button.
ContactsCaption | Gets or sets the string representing a 'contacts' caption.
CueFormHeader | Gets or sets the string to be displayed in the header of the Cue items form.
DailyValue | Gets or sets the string representing a 'daily' value.
DateCaption | Gets or sets the string representing a 'date' caption.
DatesCaption | Gets or sets the string representing a 'dates' caption.
DaysValue | Gets or sets the string representing a 'days' value.
DayValue | Gets or sets the string representing a 'day' value.
DeleteButtonCaption | Gets or sets the string to be displayed as a caption for a 'delete' button.
DetailsCaption | Gets or sets the string representing a 'details' caption.
EditFormHeader | Gets or sets the string to be displayed in the header of the Edit item form.
EditRecurrenceFormHeader | Gets or sets the string to be displayed in the header of the Edit recurrence form.
EndAfterCaption | Gets or sets the string representing a 'end after' caption.
EndDateCaption | Gets or sets the string representing a 'end date' caption.
EndTimeCaption | Gets or sets the string representing a 'end time' caption.
EveryCaption | Gets or sets the string representing an 'every' caption.
FirstValue | Gets or sets the string representing a 'first' value.
FourthValue | Gets or sets the string representing a 'fourth' value.
HoursValue | Gets or sets the string representing a 'hours' value.
HourValue | Gets or sets the string representing a 'hour' value.
IntervalValue | Gets or sets the string representing a 'interval' value.
IsTrackingViewState | Gets a value that indicates whether changes to the view state are saved.
LastValue | Gets or sets the string representing a 'last' value.
LocationCaption | Gets or sets the string representing a 'location' caption.
MinutesValue | Gets or sets the string representing a 'minutes' value.
MinuteValue | Gets or sets the string representing a 'minute' value.
MonthlyValue | Gets or sets the string representing a 'monthly' value.
MonthValue | Gets or sets the string representing a 'month' value.
NewFormHeader | Gets or sets the string to be displayed in the header of the New item form.
NewRecurrenceFormHeader | Gets or sets the string to be displayed in the header of the New recurrence form.
NoEndCaption | Gets or sets the string representing a 'no end' caption.
OfEveryCaption | Gets or sets the string representing an 'of every' caption.
OptionsButtonCaption | Gets or sets the string to be displayed as a caption for a 'options' button.
PatternCaption | Gets or sets the string representing a 'pattern' caption.
RangeCaption | Gets or sets the string representing a 'range' caption.
RecurrenceButtonCaption | Gets or sets the string to be displayed as a caption for a 'recurrence' button.
RecurrenceDailyFourPattern | Gets or sets the pattern used for daily recurrences with DailyRecurrence set to EveryWeekend.
RecurrenceDailyOnePattern | Gets or sets the pattern used for daily recurrences with DailyRecurrence set to ByDayInterval and Days value set to 1.
RecurrenceDailyThreePattern | Gets or sets the pattern used for daily recurrences with DailyRecurrence set to EveryWorkday.
RecurrenceDailyTwoPattern | Gets or sets the pattern used for daily recurrences with DailyRecurrence set to ByDayInterval and Days value set to more than 1.
RecurrenceEndDatePattern | Gets or sets the pattern used for denoting the end date of a recurrence.
RecurrenceIntervalPattern | Gets or sets the pattern used for recurrences with RecurrencePattern set to TimeInterval.
RecurrenceMonthlyOnePattern | Gets or sets the pattern used for monthly recurrences with MonthlyRecurrence set to ByDayNumber.
RecurrenceMonthlyTwoPattern | Gets or sets the pattern used for monthly recurrences with MonthlyRecurrence set to ByDayType.
RecurrenceStartDatePattern | Gets or sets the pattern used for denoting the start date of a recurrence.
RecurrenceTimeOnePattern | Gets or sets the pattern used for denoting the start and end time of a recurrence.
RecurrenceTimeTwoPattern | Gets or sets the pattern used for denoting the time of a recurrence.
RecurrenceWeeklyOnePattern | Gets or sets the pattern used for weekly recurrences with Weeks value set to 1.
RecurrenceWeeklyTwoPattern | Gets or sets the pattern used for weekly recurrences with Weeks value set to more than 1.
RecurrenceYearlyOnePattern | Gets or sets the pattern used for yearly recurrences with YearlyRecurrence set to SpecificDate.
RecurrenceYearlyTwoPattern | Gets or sets the pattern used for yearly recurrences with YearlyRecurrence set to ByDayType.
ReminderCaption | Gets or sets the string representing a 'reminder' caption.
SaveButtonCaption | Gets or sets the string to be displayed as a caption for a 'save' button.
SecondsValue | Gets or sets the string representing a 'seconds' value.
SecondValue | Gets or sets the string representing a 'second' value.
StartCaption | Gets or sets the string representing a 'start' caption.
StartTimeCaption | Gets or sets the string representing a 'start time' caption.
SubjectCaption | Gets or sets the string representing a 'subject' caption.
ThirdValue | Gets or sets the string representing a 'third' value.
TodayCaption | Gets or sets the string representing a 'today' caption.
WeekdayValue | Gets or sets the string representing a 'weekday' value.
WeekendValue | Gets or sets the string representing a 'weekend' value.
WeeklyValue | Gets or sets the string representing a 'weekly' value.
WeeksValue | Gets or sets the string representing a 'weeks' value.
YearlyValue | Gets or sets the string representing a 'yearly' value.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of this LocalizationInfo across multiple requests for the same page.

Public Methods

Name | Description
LoadFromXml | Loads localization info from an XML document.
LoadViewState | Restores view-state information that was saved by the SaveViewState method.
SaveToXml | Saves the localization info to an XML document.
SaveViewState | Saves any server side view-state changes that have occurred on this object.
TrackViewState | Causes tracking of view-state changes to this object.

See Also

LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo Constructor

LocalizationInfo Constructor
[image]

Initializes a new instance of the LocalizationInfo class.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public LocalizationInfo ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo Methods

LocalizationInfo Methods
[image]

Public Methods

Name | Description
LoadFromXml | Loads localization info from an XML document.
LoadViewState | Restores view-state information that was saved by the SaveViewState method.
SaveToXml | Saves the localization info to an XML document.
SaveViewState | Saves any server side view-state changes that have occurred on this object.
TrackViewState | Causes tracking of view-state changes to this object.

See Also

LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.LoadFromXml Method

LocalizationInfo.LoadFromXml Method
[image]

Loads localization info from an XML document.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

Type: String
The path of the file to load from.

Remarks

This method loads data from an XML file created by a previous call to SaveToXml.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.LoadViewState Method

LocalizationInfo.LoadViewState Method
[image]

Restores view-state information that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Sub LoadViewState( _
state As Object _
)

Parameters

state

Type: Object
An Object that represents the control state to be restored.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.SaveToXml Method

LocalizationInfo.SaveToXml Method
[image]

Saves the localization info to an XML document.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

Type: String
The path of the file to save to.

Remarks

Saves the localization info as tags in an XML document. Use LoadFromXml to restore the localization info later.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.SaveViewState Method

LocalizationInfo.SaveViewState Method
[image]

Saves any server side view-state changes that have occurred on this object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object SaveViewState ()

Visual Basic [image] Copy Code

Public Function SaveViewState () As Object

Return Value

Type: Object
The view state of this object, if saved; otherwise null.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.TrackViewState Method

LocalizationInfo.TrackViewState Method
[image]

Causes tracking of view-state changes to this object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void TrackViewState ()

Visual Basic [image] Copy Code

Public Sub TrackViewState ()

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo Properties

LocalizationInfo Properties
[image]

Public Properties

Name | Description
AllDayEventCaption | Gets or sets the string representing a 'all day event' caption.
CancelButtonCaption | Gets or sets the string to be displayed as a caption for a 'cancel' button.
ContactsCaption | Gets or sets the string representing a 'contacts' caption.
CueFormHeader | Gets or sets the string to be displayed in the header of the Cue items form.
DailyValue | Gets or sets the string representing a 'daily' value.
DateCaption | Gets or sets the string representing a 'date' caption.
DatesCaption | Gets or sets the string representing a 'dates' caption.
DaysValue | Gets or sets the string representing a 'days' value.
DayValue | Gets or sets the string representing a 'day' value.
DeleteButtonCaption | Gets or sets the string to be displayed as a caption for a 'delete' button.
DetailsCaption | Gets or sets the string representing a 'details' caption.
EditFormHeader | Gets or sets the string to be displayed in the header of the Edit item form.
EditRecurrenceFormHeader | Gets or sets the string to be displayed in the header of the Edit recurrence form.
EndAfterCaption | Gets or sets the string representing a 'end after' caption.
EndDateCaption | Gets or sets the string representing a 'end date' caption.
EndTimeCaption | Gets or sets the string representing a 'end time' caption.
EveryCaption | Gets or sets the string representing an 'every' caption.
FirstValue | Gets or sets the string representing a 'first' value.
FourthValue | Gets or sets the string representing a 'fourth' value.
HoursValue | Gets or sets the string representing a 'hours' value.
HourValue | Gets or sets the string representing a 'hour' value.
IntervalValue | Gets or sets the string representing a 'interval' value.
IsTrackingViewState | Gets a value that indicates whether changes to the view state are saved.
LastValue | Gets or sets the string representing a 'last' value.
LocationCaption | Gets or sets the string representing a 'location' caption.
MinutesValue | Gets or sets the string representing a 'minutes' value.
MinuteValue | Gets or sets the string representing a 'minute' value.
MonthlyValue | Gets or sets the string representing a 'monthly' value.
MonthValue | Gets or sets the string representing a 'month' value.
NewFormHeader | Gets or sets the string to be displayed in the header of the New item form.
NewRecurrenceFormHeader | Gets or sets the string to be displayed in the header of the New recurrence form.
NoEndCaption | Gets or sets the string representing a 'no end' caption.
OfEveryCaption | Gets or sets the string representing an 'of every' caption.
OptionsButtonCaption | Gets or sets the string to be displayed as a caption for a 'options' button.
PatternCaption | Gets or sets the string representing a 'pattern' caption.
RangeCaption | Gets or sets the string representing a 'range' caption.
RecurrenceButtonCaption | Gets or sets the string to be displayed as a caption for a 'recurrence' button.
RecurrenceDailyFourPattern | Gets or sets the pattern used for daily recurrences with DailyRecurrence set to EveryWeekend.
RecurrenceDailyOnePattern | Gets or sets the pattern used for daily recurrences with DailyRecurrence set to ByDayInterval and Days value set to 1.
RecurrenceDailyThreePattern | Gets or sets the pattern used for daily recurrences with DailyRecurrence set to EveryWorkday.
RecurrenceDailyTwoPattern | Gets or sets the pattern used for daily recurrences with DailyRecurrence set to ByDayInterval and Days value set to more than 1.
RecurrenceEndDatePattern | Gets or sets the pattern used for denoting the end date of a recurrence.
RecurrenceIntervalPattern | Gets or sets the pattern used for recurrences with RecurrencePattern set to TimeInterval.
RecurrenceMonthlyOnePattern | Gets or sets the pattern used for monthly recurrences with MonthlyRecurrence set to ByDayNumber.
RecurrenceMonthlyTwoPattern | Gets or sets the pattern used for monthly recurrences with MonthlyRecurrence set to ByDayType.
RecurrenceStartDatePattern | Gets or sets the pattern used for denoting the start date of a recurrence.
RecurrenceTimeOnePattern | Gets or sets the pattern used for denoting the start and end time of a recurrence.
RecurrenceTimeTwoPattern | Gets or sets the pattern used for denoting the time of a recurrence.
RecurrenceWeeklyOnePattern | Gets or sets the pattern used for weekly recurrences with Weeks value set to 1.
RecurrenceWeeklyTwoPattern | Gets or sets the pattern used for weekly recurrences with Weeks value set to more than 1.
RecurrenceYearlyOnePattern | Gets or sets the pattern used for yearly recurrences with YearlyRecurrence set to SpecificDate.
RecurrenceYearlyTwoPattern | Gets or sets the pattern used for yearly recurrences with YearlyRecurrence set to ByDayType.
ReminderCaption | Gets or sets the string representing a 'reminder' caption.
SaveButtonCaption | Gets or sets the string to be displayed as a caption for a 'save' button.
SecondsValue | Gets or sets the string representing a 'seconds' value.
SecondValue | Gets or sets the string representing a 'second' value.
StartCaption | Gets or sets the string representing a 'start' caption.
StartTimeCaption | Gets or sets the string representing a 'start time' caption.
SubjectCaption | Gets or sets the string representing a 'subject' caption.
ThirdValue | Gets or sets the string representing a 'third' value.
TodayCaption | Gets or sets the string representing a 'today' caption.
WeekdayValue | Gets or sets the string representing a 'weekday' value.
WeekendValue | Gets or sets the string representing a 'weekend' value.
WeeklyValue | Gets or sets the string representing a 'weekly' value.
WeeksValue | Gets or sets the string representing a 'weeks' value.
YearlyValue | Gets or sets the string representing a 'yearly' value.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of this LocalizationInfo across multiple requests for the same page.

See Also

LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.AllDayEventCaption Property

LocalizationInfo.AllDayEventCaption Property
[image]

Gets or sets the string representing a 'all day event' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string AllDayEventCaption { get; set; }

Visual Basic [image] Copy Code

Public Property AllDayEventCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.CancelButtonCaption Property

LocalizationInfo.CancelButtonCaption Property
[image]

Gets or sets the string to be displayed as a caption for a 'cancel' button.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string CancelButtonCaption { get; set; }

Visual Basic [image] Copy Code

Public Property CancelButtonCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.ContactsCaption Property

LocalizationInfo.ContactsCaption Property
[image]

Gets or sets the string representing a 'contacts' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ContactsCaption { get; set; }

Visual Basic [image] Copy Code

Public Property ContactsCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.CueFormHeader Property

LocalizationInfo.CueFormHeader Property
[image]

Gets or sets the string to be displayed in the header of the Cue items form.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string CueFormHeader { get; set; }

Visual Basic [image] Copy Code

Public Property CueFormHeader As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.DailyValue Property

LocalizationInfo.DailyValue Property
[image]

Gets or sets the string representing a 'daily' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DailyValue { get; set; }

Visual Basic [image] Copy Code

Public Property DailyValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.DateCaption Property

LocalizationInfo.DateCaption Property
[image]

Gets or sets the string representing a 'date' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DateCaption { get; set; }

Visual Basic [image] Copy Code

Public Property DateCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.DatesCaption Property

LocalizationInfo.DatesCaption Property
[image]

Gets or sets the string representing a 'dates' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DatesCaption { get; set; }

Visual Basic [image] Copy Code

Public Property DatesCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.DaysValue Property

LocalizationInfo.DaysValue Property
[image]

Gets or sets the string representing a 'days' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DaysValue { get; set; }

Visual Basic [image] Copy Code

Public Property DaysValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.DayValue Property

LocalizationInfo.DayValue Property
[image]

Gets or sets the string representing a 'day' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DayValue { get; set; }

Visual Basic [image] Copy Code

Public Property DayValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.DeleteButtonCaption Property

LocalizationInfo.DeleteButtonCaption Property
[image]

Gets or sets the string to be displayed as a caption for a 'delete' button.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DeleteButtonCaption { get; set; }

Visual Basic [image] Copy Code

Public Property DeleteButtonCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.DetailsCaption Property

LocalizationInfo.DetailsCaption Property
[image]

Gets or sets the string representing a 'details' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string DetailsCaption { get; set; }

Visual Basic [image] Copy Code

Public Property DetailsCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.EditFormHeader Property

LocalizationInfo.EditFormHeader Property
[image]

Gets or sets the string to be displayed in the header of the Edit item form.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string EditFormHeader { get; set; }

Visual Basic [image] Copy Code

Public Property EditFormHeader As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.EditRecurrenceFormHeader Property

LocalizationInfo.EditRecurrenceFormHeader Property
[image]

Gets or sets the string to be displayed in the header of the Edit recurrence form.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string EditRecurrenceFormHeader { get; set; }

Visual Basic [image] Copy Code

Public Property EditRecurrenceFormHeader As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.EndAfterCaption Property

LocalizationInfo.EndAfterCaption Property
[image]

Gets or sets the string representing a 'end after' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string EndAfterCaption { get; set; }

Visual Basic [image] Copy Code

Public Property EndAfterCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.EndDateCaption Property

LocalizationInfo.EndDateCaption Property
[image]

Gets or sets the string representing a 'end date' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string EndDateCaption { get; set; }

Visual Basic [image] Copy Code

Public Property EndDateCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.EndTimeCaption Property

LocalizationInfo.EndTimeCaption Property
[image]

Gets or sets the string representing a 'end time' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string EndTimeCaption { get; set; }

Visual Basic [image] Copy Code

Public Property EndTimeCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.EveryCaption Property

LocalizationInfo.EveryCaption Property
[image]

Gets or sets the string representing an 'every' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string EveryCaption { get; set; }

Visual Basic [image] Copy Code

Public Property EveryCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.FirstValue Property

LocalizationInfo.FirstValue Property
[image]

Gets or sets the string representing a 'first' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string FirstValue { get; set; }

Visual Basic [image] Copy Code

Public Property FirstValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.FourthValue Property

LocalizationInfo.FourthValue Property
[image]

Gets or sets the string representing a 'fourth' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string FourthValue { get; set; }

Visual Basic [image] Copy Code

Public Property FourthValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.HoursValue Property

LocalizationInfo.HoursValue Property
[image]

Gets or sets the string representing a 'hours' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string HoursValue { get; set; }

Visual Basic [image] Copy Code

Public Property HoursValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.HourValue Property

LocalizationInfo.HourValue Property
[image]

Gets or sets the string representing a 'hour' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string HourValue { get; set; }

Visual Basic [image] Copy Code

Public Property HourValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.IntervalValue Property

LocalizationInfo.IntervalValue Property
[image]

Gets or sets the string representing a 'interval' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string IntervalValue { get; set; }

Visual Basic [image] Copy Code

Public Property IntervalValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.IsTrackingViewState Property

LocalizationInfo.IsTrackingViewState Property
[image]

Gets a value that indicates whether changes to the view state are saved.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

Type: Boolean

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.LastValue Property

LocalizationInfo.LastValue Property
[image]

Gets or sets the string representing a 'last' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string LastValue { get; set; }

Visual Basic [image] Copy Code

Public Property LastValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.LocationCaption Property

LocalizationInfo.LocationCaption Property
[image]

Gets or sets the string representing a 'location' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string LocationCaption { get; set; }

Visual Basic [image] Copy Code

Public Property LocationCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.MinutesValue Property

LocalizationInfo.MinutesValue Property
[image]

Gets or sets the string representing a 'minutes' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MinutesValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinutesValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.MinuteValue Property

LocalizationInfo.MinuteValue Property
[image]

Gets or sets the string representing a 'minute' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MinuteValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinuteValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.MonthlyValue Property

LocalizationInfo.MonthlyValue Property
[image]

Gets or sets the string representing a 'monthly' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MonthlyValue { get; set; }

Visual Basic [image] Copy Code

Public Property MonthlyValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.MonthValue Property

LocalizationInfo.MonthValue Property
[image]

Gets or sets the string representing a 'month' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string MonthValue { get; set; }

Visual Basic [image] Copy Code

Public Property MonthValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.NewFormHeader Property

LocalizationInfo.NewFormHeader Property
[image]

Gets or sets the string to be displayed in the header of the New item form.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string NewFormHeader { get; set; }

Visual Basic [image] Copy Code

Public Property NewFormHeader As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.NewRecurrenceFormHeader Property

LocalizationInfo.NewRecurrenceFormHeader Property
[image]

Gets or sets the string to be displayed in the header of the New recurrence form.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string NewRecurrenceFormHeader { get; set; }

Visual Basic [image] Copy Code

Public Property NewRecurrenceFormHeader As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.NoEndCaption Property

LocalizationInfo.NoEndCaption Property
[image]

Gets or sets the string representing a 'no end' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string NoEndCaption { get; set; }

Visual Basic [image] Copy Code

Public Property NoEndCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.OfEveryCaption Property

LocalizationInfo.OfEveryCaption Property
[image]

Gets or sets the string representing an 'of every' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string OfEveryCaption { get; set; }

Visual Basic [image] Copy Code

Public Property OfEveryCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.OptionsButtonCaption Property

LocalizationInfo.OptionsButtonCaption Property
[image]

Gets or sets the string to be displayed as a caption for a 'options' button.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string OptionsButtonCaption { get; set; }

Visual Basic [image] Copy Code

Public Property OptionsButtonCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.PatternCaption Property

LocalizationInfo.PatternCaption Property
[image]

Gets or sets the string representing a 'pattern' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string PatternCaption { get; set; }

Visual Basic [image] Copy Code

Public Property PatternCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RangeCaption Property

LocalizationInfo.RangeCaption Property
[image]

Gets or sets the string representing a 'range' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RangeCaption { get; set; }

Visual Basic [image] Copy Code

Public Property RangeCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceButtonCaption Property

LocalizationInfo.RecurrenceButtonCaption Property
[image]

Gets or sets the string to be displayed as a caption for a 'recurrence' button.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceButtonCaption { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceButtonCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceDailyFourPattern Property

LocalizationInfo.RecurrenceDailyFourPattern Property
[image]

Gets or sets the pattern used for daily recurrences with DailyRecurrence set to EveryWeekend.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceDailyFourPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceDailyFourPattern As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceDailyOnePattern Property

LocalizationInfo.RecurrenceDailyOnePattern Property
[image]

Gets or sets the pattern used for daily recurrences with DailyRecurrence set to ByDayInterval and Days value set to 1.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceDailyOnePattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceDailyOnePattern As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceDailyThreePattern Property

LocalizationInfo.RecurrenceDailyThreePattern Property
[image]

Gets or sets the pattern used for daily recurrences with DailyRecurrence set to EveryWorkday.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceDailyThreePattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceDailyThreePattern As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceDailyTwoPattern Property

LocalizationInfo.RecurrenceDailyTwoPattern Property
[image]

Gets or sets the pattern used for daily recurrences with DailyRecurrence set to ByDayInterval and Days value set to more than 1.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceDailyTwoPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceDailyTwoPattern As String

Property Value

Type: String

Remarks

Use the [Days] parameter as a placeholder for the Recurrence.Days value.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceEndDatePattern Property

LocalizationInfo.RecurrenceEndDatePattern Property
[image]

Gets or sets the pattern used for denoting the end date of a recurrence.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceEndDatePattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceEndDatePattern As String

Property Value

Type: String

Remarks

Use the [EndDate] parameter as a placeholder for the return value from the Recurrence.GetEndDate() method.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceIntervalPattern Property

LocalizationInfo.RecurrenceIntervalPattern Property
[image]

Gets or sets the pattern used for recurrences with RecurrencePattern set to TimeInterval.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceIntervalPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceIntervalPattern As String

Property Value

Type: String

Remarks

Use the [Interval.Days], [Interval.Hours], [Interval.Minutes] and [Interval.Seconds] parameters as placeholders for the Recurrence.Interval.Days, Recurrence.Interval.Hours, Recurrence.Interval.Minutes and Recurrence.Interval.Seconds values respectively.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceMonthlyOnePattern Property

LocalizationInfo.RecurrenceMonthlyOnePattern Property
[image]

Gets or sets the pattern used for monthly recurrences with MonthlyRecurrence set to ByDayNumber.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceMonthlyOnePattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceMonthlyOnePattern As String

Property Value

Type: String

Remarks

Use the [DayOfMonth] and [Months] parameters as placeholders for the Recurrence.DayOfMonth and Recurrence.Months values respectively.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceMonthlyTwoPattern Property

LocalizationInfo.RecurrenceMonthlyTwoPattern Property
[image]

Gets or sets the pattern used for monthly recurrences with MonthlyRecurrence set to ByDayType.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceMonthlyTwoPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceMonthlyTwoPattern As String

Property Value

Type: String

Remarks

Use the [Occurrence], [Day] and [Months] parameters as placeholders for the Recurrence.Occurrence, Recurrence.Day and Recurrence.Months values respectively.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceStartDatePattern Property

LocalizationInfo.RecurrenceStartDatePattern Property
[image]

Gets or sets the pattern used for denoting the start date of a recurrence.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceStartDatePattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceStartDatePattern As String

Property Value

Type: String

Remarks

Use the [StartDate] parameter as a placeholder for the Recurrence.StartDate value.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceTimeOnePattern Property

LocalizationInfo.RecurrenceTimeOnePattern Property
[image]

Gets or sets the pattern used for denoting the start and end time of a recurrence.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceTimeOnePattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceTimeOnePattern As String

Property Value

Type: String

Remarks

Use the [StartTime] and [EndTime] parameters as placeholders for the StartTime and EndTime of recurrences.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceTimeTwoPattern Property

LocalizationInfo.RecurrenceTimeTwoPattern Property
[image]

Gets or sets the pattern used for denoting the time of a recurrence.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceTimeTwoPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceTimeTwoPattern As String

Property Value

Type: String

Remarks

Use the [StartTime] parameter as a placeholder for the StartTime of recurrences.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceWeeklyOnePattern Property

LocalizationInfo.RecurrenceWeeklyOnePattern Property
[image]

Gets or sets the pattern used for weekly recurrences with Weeks value set to 1.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceWeeklyOnePattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceWeeklyOnePattern As String

Property Value

Type: String

Remarks

Use the [DaysOfWeek] parameter as a placeholder for the Recurrence.DaysOfWeek value.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceWeeklyTwoPattern Property

LocalizationInfo.RecurrenceWeeklyTwoPattern Property
[image]

Gets or sets the pattern used for weekly recurrences with Weeks value set to more than 1.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceWeeklyTwoPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceWeeklyTwoPattern As String

Property Value

Type: String

Remarks

Use the [DaysOfWeek] and [Weeks] parameters as placeholders for the Recurrence.DaysOfWeek and Recurrence.Weeks values respectively.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceYearlyOnePattern Property

LocalizationInfo.RecurrenceYearlyOnePattern Property
[image]

Gets or sets the pattern used for yearly recurrences with YearlyRecurrence set to SpecificDate.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceYearlyOnePattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceYearlyOnePattern As String

Property Value

Type: String

Remarks

Use the [MonthOfYear] and [DayOfMonth] parameters as placeholders for the Recurrence.MonthOfYear and Recurrence.DayOfMonth values respectively.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.RecurrenceYearlyTwoPattern Property

LocalizationInfo.RecurrenceYearlyTwoPattern Property
[image]

Gets or sets the pattern used for yearly recurrences with YearlyRecurrence set to ByDayType.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string RecurrenceYearlyTwoPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RecurrenceYearlyTwoPattern As String

Property Value

Type: String

Remarks

Use the [Occurrence], [Day] and [MonthOfYear] parameters as placeholders for the Recurrence.Occurrence, Recurrence.Day and Recurrence.MonthOfYear values respectively.

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.ReminderCaption Property

LocalizationInfo.ReminderCaption Property
[image]

Gets or sets the string representing a 'reminder' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ReminderCaption { get; set; }

Visual Basic [image] Copy Code

Public Property ReminderCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.SaveButtonCaption Property

LocalizationInfo.SaveButtonCaption Property
[image]

Gets or sets the string to be displayed as a caption for a 'save' button.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string SaveButtonCaption { get; set; }

Visual Basic [image] Copy Code

Public Property SaveButtonCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.SecondsValue Property

LocalizationInfo.SecondsValue Property
[image]

Gets or sets the string representing a 'seconds' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string SecondsValue { get; set; }

Visual Basic [image] Copy Code

Public Property SecondsValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.SecondValue Property

LocalizationInfo.SecondValue Property
[image]

Gets or sets the string representing a 'second' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string SecondValue { get; set; }

Visual Basic [image] Copy Code

Public Property SecondValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.StartCaption Property

LocalizationInfo.StartCaption Property
[image]

Gets or sets the string representing a 'start' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string StartCaption { get; set; }

Visual Basic [image] Copy Code

Public Property StartCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.StartTimeCaption Property

LocalizationInfo.StartTimeCaption Property
[image]

Gets or sets the string representing a 'start time' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string StartTimeCaption { get; set; }

Visual Basic [image] Copy Code

Public Property StartTimeCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.SubjectCaption Property

LocalizationInfo.SubjectCaption Property
[image]

Gets or sets the string representing a 'subject' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string SubjectCaption { get; set; }

Visual Basic [image] Copy Code

Public Property SubjectCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.ThirdValue Property

LocalizationInfo.ThirdValue Property
[image]

Gets or sets the string representing a 'third' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ThirdValue { get; set; }

Visual Basic [image] Copy Code

Public Property ThirdValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.TodayCaption Property

LocalizationInfo.TodayCaption Property
[image]

Gets or sets the string representing a 'today' caption.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string TodayCaption { get; set; }

Visual Basic [image] Copy Code

Public Property TodayCaption As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.ViewState Property

LocalizationInfo.ViewState Property
[image]

Gets a dictionary of state information that allows you to save and restore the view state of this LocalizationInfo across multiple requests for the same page.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected virtual StateBag ViewState { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property ViewState As StateBag

Property Value

Type: StateBag

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.WeekdayValue Property

LocalizationInfo.WeekdayValue Property
[image]

Gets or sets the string representing a 'weekday' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string WeekdayValue { get; set; }

Visual Basic [image] Copy Code

Public Property WeekdayValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.WeekendValue Property

LocalizationInfo.WeekendValue Property
[image]

Gets or sets the string representing a 'weekend' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string WeekendValue { get; set; }

Visual Basic [image] Copy Code

Public Property WeekendValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.WeeklyValue Property

LocalizationInfo.WeeklyValue Property
[image]

Gets or sets the string representing a 'weekly' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string WeeklyValue { get; set; }

Visual Basic [image] Copy Code

Public Property WeeklyValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.WeeksValue Property

LocalizationInfo.WeeksValue Property
[image]

Gets or sets the string representing a 'weeks' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string WeeksValue { get; set; }

Visual Basic [image] Copy Code

Public Property WeeksValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.LocalizationInfo.YearlyValue Property

LocalizationInfo.YearlyValue Property
[image]

Gets or sets the string representing a 'yearly' value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string YearlyValue { get; set; }

Visual Basic [image] Copy Code

Public Property YearlyValue As String

Property Value

Type: String

See Also

LocalizationInfo Members
LocalizationInfo Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MinuteFormat Enumeration

MinuteFormat Enumeration
[image]

Specifies how to format and display minutes in the Timetable view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum MinuteFormat

Visual Basic [image] Copy Code

Public Enum MinuteFormat

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
NoLeadingZero | 0 | No leading zero for single digit minutes.
LeadingZero | 1 | Display a leading zero for single digit minutes.
Colons | 2 | Display a colon and a leading zero.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthHeaderStyles Enumeration

MonthHeaderStyles Enumeration
[image]

Specifies the appearance and behavior of month headers in a SingleMonth and MonthRange views. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum MonthHeaderStyles

Visual Basic [image] Copy Code

Public Enum MonthHeaderStyles

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
None | 0 | Do not display the header.
Title | 1 | Display the date of the month in the header.
MonthButtons | 16 | Display buttons for scrolling to previous or next month.
YearButtons | 32 | Display buttons for scrolling to previous or next year.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeHeaderStyles Enumeration

MonthRangeHeaderStyles Enumeration
[image]

Specifies the appearance and behavior of the header in a MonthRange view. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum MonthRangeHeaderStyles

Visual Basic [image] Copy Code

Public Enum MonthRangeHeaderStyles

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
None | 0 | The header is not displayed.
Title | 1 | The header displays the start and end dates.
Buttons | 240 | The header displays buttons that can be used to scroll to previous and following moths.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings Class

MonthRangeSettings Class
[image]

Defines appearance settings for the MonthRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class MonthRangeSettings : ViewSettings

Visual Basic [image] Copy Code

Public NotInheritable Class MonthRangeSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ViewSettings
MindFusion.Scheduling.WebForms.MonthRangeSettings

See Also

MonthRangeSettings Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings Members

MonthRangeSettings Members
Properties Methods Events
[image]

Defines appearance settings for the MonthRange view.

The following tables list the members exposed by the MonthRangeSettings type.

Public Properties

Name | Description
ButtonStyle | Gets or sets the ButtonStyle object used to specify appearance settings for the buttons in the current view.
HeaderHeight | Gets or sets the height of the header in a MonthRange view.
HeaderSpacing | Gets or sets the amount of space between headers.
HeaderStyle | Gets or sets the style of the MonthRangeView's header.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header.
MaxItems | Gets or sets the maximum number of items to be displayed in a day cell.
MonthSpacing | Gets or sets the amount of space between adjacent months.
MonthsPerRow | Gets or sets the number of months to be displayed in a row.
NumberOfMonths | Gets or sets the number of months to display in the MonthRange view.
Style | Gets or sets the appearance Style used to paint calendar elements that don't have a distinct style assigned to them.
TitleFormat | Gets or sets the string used to format the month titles.
TitleSeparator | Gets or sets the string used as a title separator in a MonthRange view that displays more than one month at a time.
VisibleRows | Gets or sets the number of rows to display at the same time.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

Inherited Public Events

Name | Description
SettingsChanged | Raised when the view settings change. (Inherited from ViewSettings.)

See Also

MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings Methods

MonthRangeSettings Methods
[image]

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

See Also

MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.LoadViewState Method

MonthRangeSettings.LoadViewState Method
[image]

WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.SaveViewState Method

MonthRangeSettings.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.TrackViewState Method

MonthRangeSettings.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings Properties

MonthRangeSettings Properties
[image]

Public Properties

Name | Description
ButtonStyle | Gets or sets the ButtonStyle object used to specify appearance settings for the buttons in the current view.
HeaderHeight | Gets or sets the height of the header in a MonthRange view.
HeaderSpacing | Gets or sets the amount of space between headers.
HeaderStyle | Gets or sets the style of the MonthRangeView's header.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header.
MaxItems | Gets or sets the maximum number of items to be displayed in a day cell.
MonthSpacing | Gets or sets the amount of space between adjacent months.
MonthsPerRow | Gets or sets the number of months to be displayed in a row.
NumberOfMonths | Gets or sets the number of months to display in the MonthRange view.
Style | Gets or sets the appearance Style used to paint calendar elements that don't have a distinct style assigned to them.
TitleFormat | Gets or sets the string used to format the month titles.
TitleSeparator | Gets or sets the string used as a title separator in a MonthRange view that displays more than one month at a time.
VisibleRows | Gets or sets the number of rows to display at the same time.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

See Also

MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.ButtonStyle Property

MonthRangeSettings.ButtonStyle Property
[image]

Gets or sets the ButtonStyle object used to specify appearance settings for the buttons in the current view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ButtonsStyle ButtonStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ButtonStyle As ButtonsStyle

Property Value

An instance of the ButtonsStyle class.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.HeaderHeight Property

MonthRangeSettings.HeaderHeight Property
[image]

Gets or sets the height of the header in a MonthRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit HeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderHeight As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure that specifies the height of the header. Default value is Unit.Empty.

Remarks

A value of 0 causes the calendar control to automatically calculate the header height based on the size of the header font.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.HeaderSpacing Property

MonthRangeSettings.HeaderSpacing Property
[image]

Gets or sets the amount of space between headers.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int HeaderSpacing { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderSpacing As Integer

Property Value

A non-negative integer value specifying the amount of space between headers in pixels. Default value is 0.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.HeaderStyle Property

MonthRangeSettings.HeaderStyle Property
[image]

Gets or sets the style of the MonthRangeView's header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public MonthRangeHeaderStyles HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As MonthRangeHeaderStyles

Property Value

One of the MonthRangeHeaderStyles enumeration values. Default value is MonthRangeHeaderStyles.Title | MonthRangeHeaderStyles.Buttons.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.MainHeaderStyle Property

MonthRangeSettings.MainHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the main header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle MainHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MainHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.MaxItems Property

MonthRangeSettings.MaxItems Property
[image]

Gets or sets the maximum number of items to be displayed in a day cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int MaxItems { get; set; }

Visual Basic [image] Copy Code

Public Property MaxItems As Integer

Property Value

A non-negative integer value specifying the maximum number of items to be displayed in a date cell. Default value is 0.

Remarks

If the value of MaxItems is 0 then the number of items to be displayed will be calculated on the client side.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.MonthSpacing Property

MonthRangeSettings.MonthSpacing Property
[image]

Gets or sets the amount of space between adjacent months.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int MonthSpacing { get; set; }

Visual Basic [image] Copy Code

Public Property MonthSpacing As Integer

Property Value

A non-negative integer value specifying the amount of space between adjacent months in pixels. Default value is 0.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.MonthsPerRow Property

MonthRangeSettings.MonthsPerRow Property
[image]

Gets or sets the number of months to be displayed in a row.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int MonthsPerRow { get; set; }

Visual Basic [image] Copy Code

Public Property MonthsPerRow As Integer

Property Value

A non-negative integer value specifying the number of months to be displayed in a row. Default value is 2.

Remarks

The value ranges from 1 up to 12.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.NumberOfMonths Property

MonthRangeSettings.NumberOfMonths Property
[image]

Gets or sets the number of months to display in the MonthRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int NumberOfMonths { get; set; }

Visual Basic [image] Copy Code

Public Property NumberOfMonths As Integer

Property Value

A non-negative integer value specifying the number of months to display in the MonthRange view. Default value is 4.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.Style Property

MonthRangeSettings.Style Property
[image]

Gets or sets the appearance Style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Style Style { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Style As Style

Property Value

An instance of the Style class.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.TitleFormat Property

MonthRangeSettings.TitleFormat Property
[image]

Gets or sets the string used to format the month titles.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string value that specifies the format used for month titles. Default value is "MMMM, yyyy".

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.TitleSeparator Property

MonthRangeSettings.TitleSeparator Property
[image]

Gets or sets the string used as a title separator in a MonthRange view that displays more than one month at a time.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string TitleSeparator { get; set; }

Visual Basic [image] Copy Code

Public Property TitleSeparator As String

Property Value

A string value that specifies the title separator. Default value is " - ".

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthRangeSettings.VisibleRows Property

MonthRangeSettings.VisibleRows Property
[image]

Gets or sets the number of rows to display at the same time.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int VisibleRows { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleRows As Integer

Property Value

A non-negative integer value specifying the number of rows to display at the same time. Default value is 2.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings Class

MonthSettings Class
[image]

Specifies appearance settings for the month(s) in SingleMonth and MonthRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class MonthSettings : ViewSettings, ICloneable

Visual Basic [image] Copy Code

Public NotInheritable Class MonthSettings
Inherits ViewSettings
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ViewSettings
MindFusion.Scheduling.WebForms.MonthSettings

See Also

MonthSettings Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings Members

MonthSettings Members
Properties Methods Events
[image]

Specifies appearance settings for the month(s) in SingleMonth and MonthRange view.

The following tables list the members exposed by the MonthSettings type.

Public Properties

Name | Description
ButtonStyle | Gets or sets the ButtonsStyle object used to specify appearance settings for the buttons in the current view.
DayNamesHeader | Gets or sets a value indicating whether the day names are displayed in the month's header.
DayNamesHeaderHeight | Gets or sets the height of the day names header in a SingleMonth view.
DayNamesHeaderStyle | Gets or sets the appearance style used to paint the day names header.
DayOfWeekFormat | Gets or sets the format of the day names displayed in the week header.
DaySettings | Gets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.
DaySpacing | Gets or sets the amount of space between adjacent days.
HeaderSpacing | Gets or sets the amount of space between headers.
HeaderStyle | Gets or sets the style of the month's header.
HideTrailingWeeks | Gets or sets a value indicating whether to hide trailing weeks, which do not contain days from the current month.
LeadingWeekCount | Gets or sets the number of full weeks to display from the previous month.
MainHeaderHeight | Gets or sets the height of the main header in a month view.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header.
MaxItems | Gets or sets the maximum number of items to be displayed in a day cell.
PaddingDaysHeaderStyle | Gets or sets the Style object used to specify appearance settings for the headers of the days from previous and next months, shown when the ShowPaddingDays property is enabled.
PaddingDaysStyle | Gets or sets the Style object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
ShowPaddingDays | Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.
ShowPaddingItems | Gets or sets a value that specifies whether items are shown in padding days.
Style | Gets or sets the appearance style used to paint the calendar.
TitleFormat | Gets or sets the string used to format the month titles.
TrailingWeekCount | Gets or sets the number of full weeks to display from the next month.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderStyle | Gets or sets the style of the header that displays week numbers.
WeekNumbersHeaderStyle | Gets or sets the appearance style used to paint the week numbers header.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

Inherited Public Events

Name | Description
SettingsChanged | Raised when the view settings change. (Inherited from ViewSettings.)

See Also

MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings Methods

MonthSettings Methods
[image]

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

See Also

MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.LoadViewState Method

MonthSettings.LoadViewState Method
[image]

WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object savedState
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
savedState As Object _
)

Parameters

savedState
Type: Object
A System.Object that represents the control state to be restored.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.SaveViewState Method

MonthSettings.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.TrackViewState Method

MonthSettings.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings Properties

MonthSettings Properties
[image]

Public Properties

Name | Description
ButtonStyle | Gets or sets the ButtonsStyle object used to specify appearance settings for the buttons in the current view.
DayNamesHeader | Gets or sets a value indicating whether the day names are displayed in the month's header.
DayNamesHeaderHeight | Gets or sets the height of the day names header in a SingleMonth view.
DayNamesHeaderStyle | Gets or sets the appearance style used to paint the day names header.
DayOfWeekFormat | Gets or sets the format of the day names displayed in the week header.
DaySettings | Gets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.
DaySpacing | Gets or sets the amount of space between adjacent days.
HeaderSpacing | Gets or sets the amount of space between headers.
HeaderStyle | Gets or sets the style of the month's header.
HideTrailingWeeks | Gets or sets a value indicating whether to hide trailing weeks, which do not contain days from the current month.
LeadingWeekCount | Gets or sets the number of full weeks to display from the previous month.
MainHeaderHeight | Gets or sets the height of the main header in a month view.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header.
MaxItems | Gets or sets the maximum number of items to be displayed in a day cell.
PaddingDaysHeaderStyle | Gets or sets the Style object used to specify appearance settings for the headers of the days from previous and next months, shown when the ShowPaddingDays property is enabled.
PaddingDaysStyle | Gets or sets the Style object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
ShowPaddingDays | Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.
ShowPaddingItems | Gets or sets a value that specifies whether items are shown in padding days.
Style | Gets or sets the appearance style used to paint the calendar.
TitleFormat | Gets or sets the string used to format the month titles.
TrailingWeekCount | Gets or sets the number of full weeks to display from the next month.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderStyle | Gets or sets the style of the header that displays week numbers.
WeekNumbersHeaderStyle | Gets or sets the appearance style used to paint the week numbers header.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

See Also

MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.ButtonStyle Property

MonthSettings.ButtonStyle Property
[image]

Gets or sets the ButtonsStyle object used to specify appearance settings for the buttons in the current view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ButtonsStyle ButtonStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ButtonStyle As ButtonsStyle

Property Value

An instance of the ButtonsStyle class.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.DayNamesHeader Property

MonthSettings.DayNamesHeader Property
[image]

Gets or sets a value indicating whether the day names are displayed in the month's header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State DayNamesHeader { get; set; }

Visual Basic [image] Copy Code

Public Property DayNamesHeader As State

Property Value

Type: State

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.DayNamesHeaderHeight Property

MonthSettings.DayNamesHeaderHeight Property
[image]

Gets or sets the height of the day names header in a SingleMonth view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit DayNamesHeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property DayNamesHeaderHeight As Unit

Property Value

Type: Unit

Remarks

A value of 0 causes the Calendar control to automatically calculate the header size based on the header font size.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.DayNamesHeaderStyle Property

MonthSettings.DayNamesHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the day names header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle DayNamesHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DayNamesHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.DayOfWeekFormat Property

MonthSettings.DayOfWeekFormat Property
[image]

Gets or sets the format of the day names displayed in the week header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DayOfWeekFormat DayOfWeekFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

One of the DayOfWeekFormat enumeration values specifying the format of day names in the week header. Default value is DayOfWeekFormat.Abbreviated.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.DaySettings Property

MonthSettings.DaySettings Property
[image]

Gets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CellSettings DaySettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DaySettings As CellSettings

Property Value

An instance of the CellSettings class.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.DaySpacing Property

MonthSettings.DaySpacing Property
[image]

Gets or sets the amount of space between adjacent days.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int DaySpacing { get; set; }

Visual Basic [image] Copy Code

Public Property DaySpacing As Integer

Property Value

A non-negative integer value specifying the amount of space between adjacent days in pixels. Default value is 0.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.HeaderSpacing Property

MonthSettings.HeaderSpacing Property
[image]

Gets or sets the amount of space between headers.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int HeaderSpacing { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderSpacing As Integer

Property Value

A non-negative integer value specifying the amount of space between headers in pixels. Default value is 0.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.HeaderStyle Property

MonthSettings.HeaderStyle Property
[image]

Gets or sets the style of the month's header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public MonthHeaderStyles HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As MonthHeaderStyles

Property Value

One of the MonthHeaderStyles enumeration values. Default is MonthHeaderStyles.Title | MonthHeaderStyles.MonthButtons.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.HideTrailingWeeks Property

MonthSettings.HideTrailingWeeks Property
[image]

Gets or sets a value indicating whether to hide trailing weeks, which do not contain days from the current month.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State HideTrailingWeeks { get; set; }

Visual Basic [image] Copy Code

Public Property HideTrailingWeeks As State

Property Value

One of the State enumeration values specifying whether to hide trailing weeks. Default is State.Disabled.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.LeadingWeekCount Property

MonthSettings.LeadingWeekCount Property
[image]

Gets or sets the number of full weeks to display from the previous month.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int LeadingWeekCount { get; set; }

Visual Basic [image] Copy Code

Public Property LeadingWeekCount As Integer

Property Value

A non-negative integer value specifying the number of full weeks to display from the previous month. Default value is 0.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.MainHeaderHeight Property

MonthSettings.MainHeaderHeight Property
[image]

Gets or sets the height of the main header in a month view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit MainHeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MainHeaderHeight As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure specifying the height of the main header. Default value is Unit.Empty.

Remarks

A value of 0 causes the Calendar control to automatically calculate the header size based on the header font size.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.MainHeaderStyle Property

MonthSettings.MainHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the main header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle MainHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MainHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.MaxItems Property

MonthSettings.MaxItems Property
[image]

Gets or sets the maximum number of items to be displayed in a day cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int MaxItems { get; set; }

Visual Basic [image] Copy Code

Public Property MaxItems As Integer

Property Value

A non-negative integer value specifying the maximum number of items to be displayed in a day cell. Default value is 0.

Remarks

If MaxItems is set to 0, the number of items to be displayed will be calculated on the client side.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.PaddingDaysHeaderStyle Property

MonthSettings.PaddingDaysHeaderStyle Property
[image]

Gets or sets the Style object used to specify appearance settings for the headers of the days from previous and next months, shown when the ShowPaddingDays property is enabled.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle PaddingDaysHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PaddingDaysHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.PaddingDaysStyle Property

MonthSettings.PaddingDaysStyle Property
[image]

Gets or sets the Style object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Style PaddingDaysStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PaddingDaysStyle As Style

Property Value

One of the State enumeration values. Default is State.Enabled.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.ShowPaddingDays Property

MonthSettings.ShowPaddingDays Property
[image]

Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowPaddingDays { get; set; }

Visual Basic [image] Copy Code

Public Property ShowPaddingDays As State

Property Value

One of the State enumeration values. Default value is State.Enabled.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.ShowPaddingItems Property

MonthSettings.ShowPaddingItems Property
[image]

Gets or sets a value that specifies whether items are shown in padding days.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowPaddingItems { get; set; }

Visual Basic [image] Copy Code

Public Property ShowPaddingItems As State

Property Value

One of the State enumeration values. Default value is State.Enabled.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.Style Property

MonthSettings.Style Property
[image]

Gets or sets the appearance style used to paint the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Style Style { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Style As Style

Property Value

An instance of the Style class.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.TitleFormat Property

MonthSettings.TitleFormat Property
[image]

Gets or sets the string used to format the month titles.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string that specifies the format of the title. Default value is "MMMM, yyyy".

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.TrailingWeekCount Property

MonthSettings.TrailingWeekCount Property
[image]

Gets or sets the number of full weeks to display from the next month.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int TrailingWeekCount { get; set; }

Visual Basic [image] Copy Code

Public Property TrailingWeekCount As Integer

Property Value

A non-negative integer value specifying the number of full weeks to display from the next month. Default value is 0.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.WeekHeaderFormat Property

MonthSettings.WeekHeaderFormat Property
[image]

Gets or sets the format of the text displayed for each week in the week header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string WeekHeaderFormat { get; set; }

Visual Basic [image] Copy Code

Public Property WeekHeaderFormat As String

Property Value

A string that specifies the format used in the week numbers header. Default value is "%w".

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.WeekHeaderStyle Property

MonthSettings.WeekHeaderStyle Property
[image]

Gets or sets the style of the header that displays week numbers.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public MonthWeekHeaderStyle WeekHeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property WeekHeaderStyle As MonthWeekHeaderStyle

Property Value

One of the MonthWeekHeaderStyle enumeration values. Default value is MonthWeekHeaderStyle.None.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.WeekNumbersHeaderStyle Property

MonthSettings.WeekNumbersHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the week numbers header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle WeekNumbersHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property WeekNumbersHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthSettings.WeekNumbersHeaderWidth Property

MonthSettings.WeekNumbersHeaderWidth Property
[image]

Gets or sets the width of the header, which displays week numbers.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit WeekNumbersHeaderWidth { get; set; }

Visual Basic [image] Copy Code

Public Property WeekNumbersHeaderWidth As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure that specifies the width of the week numbers header. Default value is Unit.Empty.

Remarks

A value of 0 causes the Calendar control to automatically calculate the header size based on the header font size.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.MonthWeekHeaderStyle Enumeration

MonthWeekHeaderStyle Enumeration
[image]

Specifies the alignment of the header that displays week numbers in a SingleMonth view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum MonthWeekHeaderStyle

Visual Basic [image] Copy Code

Public Enum MonthWeekHeaderStyle

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
None | 0 | Do not display a week numbers header.
Left | 1 | Display the header on the left side of the calendar.
Right | 2 | Display the header on the right side of the calendar.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Orientation Enumeration

Orientation Enumeration
[image]

Specifies orientation for calendar items.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum Orientation

Visual Basic [image] Copy Code

Public Enum Orientation

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
Horizontal | 0 | Indicates a horizontal orientation.
Vertical | 1 | Indicates a vertical orientation.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Position Enumeration

Position Enumeration
[image]

Specifies the position of an element relative to its container.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum Position

Visual Basic [image] Copy Code

Public Enum Position

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
None | 0 | The element is not displayed.
Left | 1 | The element is docked at the left side.
Top | 2 | The element is docked at the top side.
Right | 3 | The element is docked at the right side.
Bottom | 4 | The element is docked at the bottom side.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.RecurrenceConverter Class

RecurrenceConverter Class
[image]

Provides a JavaScriptConverter to convert Recurrence objects to and from other representations.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class RecurrenceConverter : JavaScriptConverter

Visual Basic [image] Copy Code

Public Class RecurrenceConverter
Inherits JavaScriptConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Scheduling.WebForms.RecurrenceConverter

See Also

RecurrenceConverter Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.RecurrenceConverter Members

RecurrenceConverter Members
Constructors Properties Methods
[image]

Provides a JavaScriptConverter to convert Recurrence objects to and from other representations.

The following tables list the members exposed by the RecurrenceConverter type.

Public Constructors

Name | Description
RecurrenceConverter | Creates a new instance of the RecurrenceConverter class.

Public Properties

Name | Description
SupportedTypes | JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

Public Methods

Name | Description
Deserialize | JavaScriptConverter.Deserialize override. Converts the provided dictionary into a Recurrence object.
Serialize | JavaScriptConverter.Serialize override. Builds a dictionary of name/value pairs.

See Also

RecurrenceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.RecurrenceConverter Constructor

RecurrenceConverter Constructor
[image]

Creates a new instance of the RecurrenceConverter class.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public RecurrenceConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RecurrenceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.RecurrenceConverter Methods

RecurrenceConverter Methods
[image]

Public Methods

Name | Description
Deserialize | JavaScriptConverter.Deserialize override. Converts the provided dictionary into a Recurrence object.
Serialize | JavaScriptConverter.Serialize override. Builds a dictionary of name/value pairs.

See Also

RecurrenceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.RecurrenceConverter.Deserialize Method

RecurrenceConverter.Deserialize Method
[image]

JavaScriptConverter.Deserialize override. Converts the provided dictionary into a Recurrence object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary
Type: IDictionary<String, Object>
An IDictionary<string, object> instance of property data stored as name/value pairs.
type
Type: Type
The System.Type of the resulting object.
serializer
Type: JavaScriptSerializer
A System.Web.Script.Serialization.JavaScriptSerializer instance.

Return Value

Type: Object
The deserialized object.

See Also

RecurrenceConverter Members
RecurrenceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.RecurrenceConverter.Serialize Method

RecurrenceConverter.Serialize Method
[image]

JavaScriptConverter.Serialize override. Builds a dictionary of name/value pairs.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

Type: Object
The object to serialize.

serializer

Type: JavaScriptSerializer
The object that is responsible for the serialization.

Return Value

Type: IDictionary<String, Object>
An object that contains key/value pairs that represent the object’s data.

See Also

RecurrenceConverter Members
RecurrenceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.RecurrenceConverter Properties

RecurrenceConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

See Also

RecurrenceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.RecurrenceConverter.SupportedTypes Property

RecurrenceConverter.SupportedTypes Property
[image]

JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

An IEnumerable<Type> list with all supported types.

See Also

RecurrenceConverter Members
RecurrenceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ReminderConverter Class

ReminderConverter Class
[image]

Provides a JavaScriptConverter to convert Reminder objects to and from other representations.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ReminderConverter : JavaScriptConverter

Visual Basic [image] Copy Code

Public Class ReminderConverter
Inherits JavaScriptConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Scheduling.WebForms.ReminderConverter

See Also

ReminderConverter Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ReminderConverter Members

ReminderConverter Members
Constructors Properties Methods
[image]

Provides a JavaScriptConverter to convert Reminder objects to and from other representations.

The following tables list the members exposed by the ReminderConverter type.

Public Constructors

Name | Description
ReminderConverter | Creates a new instance of the ReminderConverter class.

Public Properties

Name | Description
SupportedTypes | JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

Public Methods

Name | Description
Deserialize | JavaScriptConverter.Deserialize override. Converts the provided dictionary into a Recurrence object.
Serialize | JavaScriptConverter.Serialize override. Builds a dictionary of name/value pairs.

See Also

ReminderConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ReminderConverter Constructor

ReminderConverter Constructor
[image]

Creates a new instance of the ReminderConverter class.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ReminderConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ReminderConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ReminderConverter Methods

ReminderConverter Methods
[image]

Public Methods

Name | Description
Deserialize | JavaScriptConverter.Deserialize override. Converts the provided dictionary into a Recurrence object.
Serialize | JavaScriptConverter.Serialize override. Builds a dictionary of name/value pairs.

See Also

ReminderConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ReminderConverter.Deserialize Method

ReminderConverter.Deserialize Method
[image]

JavaScriptConverter.Deserialize override. Converts the provided dictionary into a Recurrence object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary
Type: IDictionary<String, Object>
An IDictionary<string, object> instance of property data stored as name/value pairs.
type
Type: Type
The System.Type of the resulting object.
serializer
Type: JavaScriptSerializer
A System.Web.Script.Serialization.JavaScriptSerializer instance.

Return Value

Type: Object
The deserialized object.

See Also

ReminderConverter Members
ReminderConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ReminderConverter.Serialize Method

ReminderConverter.Serialize Method
[image]

JavaScriptConverter.Serialize override. Builds a dictionary of name/value pairs.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj
Type: Object
The object to serialize.
serializer
Type: JavaScriptSerializer
The object that is responsible for the serialization.

Return Value

Type: IDictionary<String, Object>
An object that contains key/value pairs that represent the object’s data.

See Also

ReminderConverter Members
ReminderConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ReminderConverter Properties

ReminderConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

See Also

ReminderConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ReminderConverter.SupportedTypes Property

ReminderConverter.SupportedTypes Property
[image]

JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

An IEnumerable<Type> list that contains the types supported by this converter.

See Also

ReminderConverter Members
ReminderConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceConverter Class

ResourceConverter Class
[image]

Provides a JavaScriptConverter to convert Resource objects to and from other representations.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class ResourceConverter : JavaScriptConverter

Visual Basic [image] Copy Code

Public Class ResourceConverter
Inherits JavaScriptConverter

Inheritance Hierarchy

System.Object
System.Web.Script.Serialization.JavaScriptConverter
MindFusion.Scheduling.WebForms.ResourceConverter

See Also

ResourceConverter Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceConverter Members

ResourceConverter Members
Constructors Properties Methods
[image]

Provides a JavaScriptConverter to convert Resource objects to and from other representations.

The following tables list the members exposed by the ResourceConverter type.

Public Constructors

Name | Description
ResourceConverter | Creates a new instance of the ResourceConverter class.

Public Properties

Name | Description
SupportedTypes | JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

Public Methods

Name | Description
Deserialize | JavaScriptConverter.Deserialize override. Converts the provided dictionary into a Resource object.
Serialize | JavaScriptConverter.Serialize override. Builds a dictionary of name/value pairs.

See Also

ResourceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceConverter Constructor

ResourceConverter Constructor
[image]

Creates a new instance of the ResourceConverter class.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ResourceConverter (
Calendar calendar
)

Visual Basic [image] Copy Code

Public New ( _
calendar As Calendar _
)

Parameters

calendar

Type: Calendar
A calendar object.

See Also

ResourceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceConverter Methods

ResourceConverter Methods
[image]

Public Methods

Name | Description
Deserialize | JavaScriptConverter.Deserialize override. Converts the provided dictionary into a Resource object.
Serialize | JavaScriptConverter.Serialize override. Builds a dictionary of name/value pairs.

See Also

ResourceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceConverter.Deserialize Method

ResourceConverter.Deserialize Method
[image]

JavaScriptConverter.Deserialize override. Converts the provided dictionary into a Resource object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object Deserialize (
IDictionary<string, Object> dictionary,
Type type,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Deserialize( _
dictionary As IDictionary(Of String, Object), _
type As Type, _
serializer As JavaScriptSerializer _
) As Object

Parameters

dictionary
Type: IDictionary<String, Object>
An IDictionary<string, object> instance of property data stored as name/value pairs.
type
Type: Type
The System.Type of the resulting object.
serializer
Type: JavaScriptSerializer
An instance of the System.Web.Script.Serialization.JavaScriptSerializer class.

Return Value

Type: Object
The deserialized object.

See Also

ResourceConverter Members
ResourceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceConverter.Serialize Method

ResourceConverter.Serialize Method
[image]

JavaScriptConverter.Serialize override. Builds a dictionary of name/value pairs.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override IDictionary<string, Object> Serialize (
Object obj,
JavaScriptSerializer serializer
)

Visual Basic [image] Copy Code

Public Overrides Function Serialize( _
obj As Object, _
serializer As JavaScriptSerializer _
) As IDictionary(Of String, Object)

Parameters

obj

Type: Object
The object to serialize.

serializer

Type: JavaScriptSerializer
The object that is responsible for the serialization.

Return Value

Type: IDictionary<String, Object>
An IDictionary<string,Object> list that contains key/value pairs that represent the object’s data.

See Also

ResourceConverter Members
ResourceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceConverter Properties

ResourceConverter Properties
[image]

Public Properties

Name | Description
SupportedTypes | JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

See Also

ResourceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceConverter.SupportedTypes Property

ResourceConverter.SupportedTypes Property
[image]

JavaScriptConverter.SupportedTypes override. Gets a collection of the supported types.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override IEnumerable<Type> SupportedTypes { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property SupportedTypes As IEnumerable(Of Type)

Property Value

An IEnumerable<Type> collection with the types supported by this converter.

See Also

ResourceConverter Members
ResourceConverter Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings Class

ResourceViewSettings Class
[image]

Defines properties that allow customizing the appearance of the calendar in Resource view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class ResourceViewSettings : ViewSettings

Visual Basic [image] Copy Code

Public NotInheritable Class ResourceViewSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ViewSettings
MindFusion.Scheduling.WebForms.ResourceViewSettings

See Also

ResourceViewSettings Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings Members

ResourceViewSettings Members
Properties Methods Events
[image]

Defines properties that allow customizing the appearance of the calendar in Resource view.

The following tables list the members exposed by the ResourceViewSettings type.

Public Properties

Name | Description
BottomTimelineSettings | Gets the settings for the bottom timeline.
GridStyle | Gets or sets the style of the grid.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the group header.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header.
MiddleTimelineSettings | Gets the settings for the middle timeline.
Style | Gets or sets the appearance style used to paint the calendar.
Timelines | Gets or sets the number of timelines displayed in the view.
TopTimelineSettings | Gets the settings for the top timeline.
VisibleCells | Gets or sets the number of cells visible at the same time.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

Inherited Public Events

Name | Description
SettingsChanged | Raised when the view settings change. (Inherited from ViewSettings.)

See Also

ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings Methods

ResourceViewSettings Methods
[image]

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

See Also

ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.LoadViewState Method

ResourceViewSettings.LoadViewState Method
[image]

WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state

Type: Object
An Object that represents the control state to be restored.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.SaveViewState Method

ResourceViewSettings.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.TrackViewState Method

ResourceViewSettings.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings Properties

ResourceViewSettings Properties
[image]

Public Properties

Name | Description
BottomTimelineSettings | Gets the settings for the bottom timeline.
GridStyle | Gets or sets the style of the grid.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the group header.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header.
MiddleTimelineSettings | Gets the settings for the middle timeline.
Style | Gets or sets the appearance style used to paint the calendar.
Timelines | Gets or sets the number of timelines displayed in the view.
TopTimelineSettings | Gets the settings for the top timeline.
VisibleCells | Gets or sets the number of cells visible at the same time.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

See Also

ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.BottomTimelineSettings Property

ResourceViewSettings.BottomTimelineSettings Property
[image]

Gets the settings for the bottom timeline.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimelineSettings BottomTimelineSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property BottomTimelineSettings As TimelineSettings

Property Value

Type: TimelineSettings

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.GridStyle Property

ResourceViewSettings.GridStyle Property
[image]

Gets or sets the style of the grid.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Style GridStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property GridStyle As Style

Property Value

Type: Style

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.GroupHeaderSize Property

ResourceViewSettings.GroupHeaderSize Property
[image]

Gets or sets the size of the group header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit GroupHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property GroupHeaderSize As Unit

Property Value

Type: Unit

Remarks

A value of 0 causes the calendar to automatically calculate a header size based on the size of the header font.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.GroupHeaderStyle Property

ResourceViewSettings.GroupHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the group header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle GroupHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property GroupHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.MainHeaderStyle Property

ResourceViewSettings.MainHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the main header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle MainHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MainHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.MiddleTimelineSettings Property

ResourceViewSettings.MiddleTimelineSettings Property
[image]

Gets the settings for the middle timeline.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimelineSettings MiddleTimelineSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MiddleTimelineSettings As TimelineSettings

Property Value

Type: TimelineSettings

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.Style Property

ResourceViewSettings.Style Property
[image]

Gets or sets the appearance style used to paint the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Style Style { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Style As Style

Property Value

Type: Style

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.Timelines Property

ResourceViewSettings.Timelines Property
[image]

Gets or sets the number of timelines displayed in the view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Timelines { get; set; }

Visual Basic [image] Copy Code

Public Property Timelines As Integer

Property Value

Type: Int32

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.TopTimelineSettings Property

ResourceViewSettings.TopTimelineSettings Property
[image]

Gets the settings for the top timeline.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimelineSettings TopTimelineSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TopTimelineSettings As TimelineSettings

Property Value

Type: TimelineSettings

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ResourceViewSettings.VisibleCells Property

ResourceViewSettings.VisibleCells Property
[image]

Gets or sets the number of cells visible at the same time.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int VisibleCells { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleCells As Integer

Property Value

Type: Int32

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection Class

Selection Class
[image]

Represents a set of selected calendar cells and defines a visualization style applied to the selected elements.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class Selection : IStateManager

Visual Basic [image] Copy Code

Public NotInheritable Class Selection
Implements IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.Selection

See Also

Selection Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection Members

Selection Members
Properties Methods Events
[image]

Represents a set of selected calendar cells and defines a visualization style applied to the selected elements.

The following tables list the members exposed by the Selection type.

Public Properties

Name | Description
AllowMultiple | Gets or sets a value indicating whether users are allowed to select multiple elements at a time.
Contact | Gets the Contact related to the current selection.
Enabled | Gets or sets a value indicating whether users are allowed to select any cells in the calendar.
IsEmpty | Gets a value indicating whether this selection is empty.
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.
Location | Gets the Location related to the current selection.
Ranges | Gets a read-only collection of DateTime objects, sorted chronologically. Each pair in the collection represents a selected time range.
Resource | Gets the resource related to the current selection.
Task | Gets the task related to the current selection.

Public Methods

Name | Description
Add | Overloaded. Adds a date or a range of dates to the selection.
Contains | Determines whether the specified date is currently selected.
ContainsDay | Determines whether any part of the specified day is selected.
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
Remove | Overloaded. Removes a date or a range of dates from the selection.
Reset | Clears the selection.
SaveViewState | WebControl.SaveViewState override. Saves any server side view-state changes that have occurred on the Selection object since the page was posted back to the server.
Set | Overloaded. Sets the selection to a date or a range of dates.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Public Events

Name | Description
Changed | Raised when the selection changes.

See Also

Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection Methods

Selection Methods
[image]

Public Methods

Name | Description
Add | Overloaded. Adds a date or a range of dates to the selection.
Contains | Determines whether the specified date is currently selected.
ContainsDay | Determines whether any part of the specified day is selected.
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
Remove | Overloaded. Removes a date or a range of dates from the selection.
Reset | Clears the selection.
SaveViewState | WebControl.SaveViewState override. Saves any server side view-state changes that have occurred on the Selection object since the page was posted back to the server.
Set | Overloaded. Sets the selection to a date or a range of dates.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

See Also

Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Add Method

Selection.Add Method
[image]

Adds a date or a range of dates to the selection.

Overload List

Name | Description
Selection.Add (DateTime) | Adds the specified date to the selection.
Selection.Add (DateTime, DateTime) | Adds the specified date range to the selection.
Selection.Add (DateTime, DateTime, Contact, Resource, Location, Task) | Adds the specified date range to the selection of the specified resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Add Method (DateTime)

Selection.Add Method (DateTime)
See Also
[image]

Adds the specified date to the selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Add (
DateTime date
)

Visual Basic [image] Copy Code

Public Sub Add( _
date As DateTime _
)

Parameters

date

Type: DateTime
The date to be added to the selection.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Add Method (DateTime, DateTime)

Selection.Add Method (DateTime, DateTime)
See Also
[image]

Adds the specified date range to the selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Add (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub Add( _
start As DateTime, _
end As DateTime _
)

Parameters

start

Type: DateTime
The start of the time range to be added to the selection.

end

Type: DateTime
The end of the time range to be added to the selection.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Add Method (DateTime, DateTime, Contact, Resource, Location, Task)

Selection.Add Method (DateTime, DateTime, Contact, Resource, Location, Task)
See Also
[image]

Adds the specified date range to the selection of the specified resource.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Add (
DateTime start,
DateTime end,
Contact contact,
Resource resource,
Location location,
Task task
)

Visual Basic [image] Copy Code

Public Sub Add ( _
start As DateTime, _
end As DateTime, _
contact As Contact, _
resource As Resource, _
location As Location, _
task As Task _
)

Parameters

start

Type: DateTime
The start of the time range to be added to the selection.

end

Type: DateTime
The end of the time range to be added to the selection.

contact
Type: Contact
A reference to a Contact to associate the selection with.
resource
Type: Resource
A reference to a Resource to associate the selection with.
location
Type: Location
A reference to a Location to associate the selection with.
task
Type: Task
A reference to a Task to associate the selection with.

Remarks

Either all of the parameters contact, resource, location and task must be set to null (Nothing in Visual Basic) or only one of them should be a non-null reference.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Contains Method

Selection.Contains Method
[image]

Determines whether the specified date is currently selected.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool Contains (
DateTime date
)

Visual Basic [image] Copy Code

Public Function Contains( _
date As DateTime _
) As Boolean

Parameters

date

Type: DateTime
A date to search for in the selection.

Return Value

Type: Boolean
true if the date's cell is selected; otherwise false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.ContainsDay Method

Selection.ContainsDay Method
[image]

Determines whether any part of the specified day is selected.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool ContainsDay (
DateTime date
)

Visual Basic [image] Copy Code

Public Function ContainsDay( _
date As DateTime _
) As Boolean

Parameters

date
Type: DateTime
A DateTime instance specifying the day to check.

Return Value

Type: Boolean
true if any part of the day is into the selection; otherwise false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.LoadViewState Method

Selection.LoadViewState Method
[image]

WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Sub LoadViewState( _
state As Object _
)

Parameters

state
Type: Object
A System.Object that represents the control state to be restored.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Remove Method

Selection.Remove Method
[image]

Removes a date or a range of dates from the selection.

Overload List

Name | Description
Selection.Remove (DateTime) | Removes the specified date from the selection.
Selection.Remove (DateTime, DateTime) | Removes the specified date range from the selection.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Remove Method (DateTime)

Selection.Remove Method (DateTime)
See Also
[image]

Removes the specified date from the selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Remove (
DateTime date
)

Visual Basic [image] Copy Code

Public Sub Remove( _
date As DateTime _
)

Parameters

date
Type: DateTime
The DateTime value to be removed.

See Also

Remove Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Remove Method (DateTime, DateTime)

Selection.Remove Method (DateTime, DateTime)
See Also
[image]

Removes the specified date range from the selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Remove (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub Remove( _
start As DateTime, _
end As DateTime _
)

Parameters

start

Type: DateTime
The start of the time range to be removed from the selection.

end

Type: DateTime
The end of the time range to be removed from the selection.

See Also

Remove Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Reset Method

Selection.Reset Method
[image]

Clears the selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Reset ()

Visual Basic [image] Copy Code

Public Sub Reset ()

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.SaveViewState Method

Selection.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server side view-state changes that have occurred on the Selection object since the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Object SaveViewState ()

Visual Basic [image] Copy Code

Public Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Set Method

Selection.Set Method
[image]

Sets the selection to a date or a range of dates.

Overload List

Name | Description
Selection.Set (DateTime) | Selects the specified date cell.
Selection.Set (DateTime, DateTime) | Selects a range of date cells.
Selection.Set (DateTime, DateTime, Contact, Resource, Location, Task) | Selects a range of date cells for the specified resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Set Method (DateTime)

Selection.Set Method (DateTime)
See Also
[image]

Selects the specified date cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Set (
DateTime date
)

Visual Basic [image] Copy Code

Public Sub Set( _
date As DateTime _
)

Parameters

date
Type: DateTime
A date whose cell in the calendar to select.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Set Method (DateTime, DateTime)

Selection.Set Method (DateTime, DateTime)
See Also
[image]

Selects a range of date cells.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Set (
DateTime start,
DateTime end
)

Visual Basic [image] Copy Code

Public Sub Set( _
start As DateTime, _
end As DateTime _
)

Parameters

start

Type: DateTime
Specifies the first date in the range.

end

Type: DateTime
Specifies the last date in the range.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Set Method (DateTime, DateTime, Contact, Resource, Location, Task)

Selection.Set Method (DateTime, DateTime, Contact, Resource, Location, Task)
See Also
[image]

Selects a range of date cells for the specified resource.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Set (
DateTime start,
DateTime end,
Contact contact,
Resource resource,
Location location,
Task task
)

Visual Basic [image] Copy Code

Public Sub Set ( _
start As DateTime, _
end As DateTime, _
contact As Contact, _
resource As Resource, _
location As Location, _
task As Task _
)

Parameters

start

Type: DateTime
Specifies the first date in the range.

end

Type: DateTime
Specifies the last date in the range.

contact
Type: Contact
A reference to a Contact to associate the selection with.
resource
Type: Resource
A reference to a Resource to associate the selection with.
location
Type: Location
A reference to a Location to associate the selection with.
task
Type: Task
A reference to a Task to associate the selection with.

Remarks

Either all of the parameters contact, resource, location and task must be set to null (Nothing in Visual Basic) or only one of them should be a non-null reference.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.TrackViewState Method

Selection.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void TrackViewState ()

Visual Basic [image] Copy Code

Public Sub TrackViewState ()

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection Properties

Selection Properties
[image]

Public Properties

Name | Description
AllowMultiple | Gets or sets a value indicating whether users are allowed to select multiple elements at a time.
Contact | Gets the Contact related to the current selection.
Enabled | Gets or sets a value indicating whether users are allowed to select any cells in the calendar.
IsEmpty | Gets a value indicating whether this selection is empty.
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.
Location | Gets the Location related to the current selection.
Ranges | Gets a read-only collection of DateTime objects, sorted chronologically. Each pair in the collection represents a selected time range.
Resource | Gets the resource related to the current selection.
Task | Gets the task related to the current selection.

See Also

Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.AllowMultiple Property

Selection.AllowMultiple Property
[image]

Gets or sets a value indicating whether users are allowed to select multiple elements at a time.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State AllowMultiple { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultiple As State

Property Value

One of the State enumeration values. Default is State.Enabled.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Contact Property

Selection.Contact Property
[image]

Gets the Contact related to the current selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Contact Contact { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Contact As Contact

Property Value

An instance of the Contact class.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Enabled Property

Selection.Enabled Property
[image]

Gets or sets a value indicating whether users are allowed to select any cells in the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State Enabled { get; set; }

Visual Basic [image] Copy Code

Public Property Enabled As State

Property Value

One of the State enumeration values. Default is State.Enabled.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.IsEmpty Property

Selection.IsEmpty Property
[image]

Gets a value indicating whether this selection is empty.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if the selection is empty; otherwise false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.IsTrackingViewState Property

Selection.IsTrackingViewState Property
[image]

IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

true if view state changes are saved; otherwise false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Location Property

Selection.Location Property
[image]

Gets the Location related to the current selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Location Location { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Location As Location

Property Value

An instance of the Location class.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Ranges Property

Selection.Ranges Property
[image]

Gets a read-only collection of DateTime objects, sorted chronologically. Each pair in the collection represents a selected time range.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public IList<DateTime> Ranges { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Ranges As IList(Of DateTime)

Property Value

A strongly-typed collection of DateTime objects.

Remarks

Any attempt to modify this collection will result in a NotSupportedException.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Resource Property

Selection.Resource Property
[image]

Gets the resource related to the current selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Resource Resource { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

An instance of the Resource class.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Task Property

Selection.Task Property
[image]

Gets the task related to the current selection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Task Task { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Task As Task

Property Value

An instance of the Task class.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection Events

Selection Events
[image]

Public Events

Name | Description
Changed | Raised when the selection changes.

See Also

Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.Selection.Changed Event

Selection.Changed Event
[image]

Raised when the selection changes.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler Changed

Visual Basic [image] Copy Code

Public Event Changed As EventHandler

Event Data

An instance of System.EventArgs class that contains data for the event.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.State Enumeration

State Enumeration
[image]

Specifies the state of an object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum State

Visual Basic [image] Copy Code

Public Enum State

Members

Member name | Value | Description
Unspecified | -1 | Indicates undetermined state.
Disabled | 0 | Indicates that the object is disabled.
Enabled | 1 | Indicates that the object is enabled.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ThemeType Enumeration

ThemeType Enumeration
[image]

Specifies an appearance theme applied at the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum ThemeType

Visual Basic [image] Copy Code

Public Enum ThemeType

Members

Member name | Value | Description
Standard | 0 | The standard theme.
Windows2003 | 1 | The Windows 2003 standard theme.
Lila | 2 | The Lila theme.
Silver | 3 | The Silver theme.
Vista | 4 | A theme with a Windows Vista look and feel.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings Class

TimelineSettings Class
[image]

Encapsulates settings for a timeline in a Resource view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class TimelineSettings : ViewSettings

Visual Basic [image] Copy Code

Public Class TimelineSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ViewSettings
MindFusion.Scheduling.WebForms.TimelineSettings

See Also

TimelineSettings Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings Members

TimelineSettings Members
Properties Methods Events
[image]

Encapsulates settings for a timeline in a Resource view.

The following tables list the members exposed by the TimelineSettings type.

Public Properties

Name | Description
Format | Gets or sets the format of the displayed dates in the timeline.
HeaderStyle | Gets or sets the appearance style used to paint the timeline header.
Size | Gets or sets the size of the timeline.
Style | ViewSettings.Style override.
Unit | Gets or sets the resolution of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

Public Methods

Name | Description
LoadViewState | Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server Calendar control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

Inherited Public Events

Name | Description
SettingsChanged | Raised when the view settings change. (Inherited from ViewSettings.)

See Also

TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings Methods

TimelineSettings Methods
[image]

Public Methods

Name | Description
LoadViewState | Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server Calendar control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

See Also

TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings.LoadViewState Method

TimelineSettings.LoadViewState Method
[image]

Control.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
state As Object _
)

Parameters

state

Type: Object
An Object that represents the control state to be restored.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings.SaveViewState Method

TimelineSettings.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings.TrackViewState Method

TimelineSettings.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server Calendar control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings Properties

TimelineSettings Properties
[image]

Public Properties

Name | Description
Format | Gets or sets the format of the displayed dates in the timeline.
HeaderStyle | Gets or sets the appearance style used to paint the timeline header.
Size | Gets or sets the size of the timeline.
Style | ViewSettings.Style override.
Unit | Gets or sets the resolution of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

See Also

TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings.Format Property

TimelineSettings.Format Property
[image]

Gets or sets the format of the displayed dates in the timeline.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string Format { get; set; }

Visual Basic [image] Copy Code

Public Property Format As String

Property Value

Type: String

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings.HeaderStyle Property

TimelineSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the timeline header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle HeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings.Size Property

TimelineSettings.Size Property
[image]

Gets or sets the size of the timeline.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As Integer

Property Value

Type: Int32

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings.Style Property

TimelineSettings.Style Property
[image]

ViewSettings.Style override.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Style Style { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Style As Style

Property Value

Type: Style

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings.Unit Property

TimelineSettings.Unit Property
[image]

Gets or sets the resolution of the timeline.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimeUnit Unit { get; set; }

Visual Basic [image] Copy Code

Public Property Unit As TimeUnit

Property Value

Type: TimeUnit

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimelineSettings.UnitCount Property

TimelineSettings.UnitCount Property
[image]

Gets or sets the number of units between adjacent ticks in the timeline.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int UnitCount { get; set; }

Visual Basic [image] Copy Code

Public Property UnitCount As Integer

Property Value

Type: Int32

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate Class

TimetableDate Class
[image]

A class used for storing DateTime values.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class TimetableDate : IStateManager, IComparable

Visual Basic [image] Copy Code

Public Class TimetableDate
Implements IStateManager, IComparable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.TimetableDate

See Also

TimetableDate Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate Members

TimetableDate Members
Constructors Properties Methods
[image]

A class used for storing DateTime values.

The following tables list the members exposed by the TimetableDate type.

Public Constructors

Name | Description
TimetableDate | Overloaded. Initializes a new instance of the TimetableDate class.

Public Properties

Name | Description
Value | Gets or sets the DateTime value of the item.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the object across multiple requests for the same page.

Public Methods

Name | Description
Equals | IComparable.Equals override. Determines whether the specified Object is equal to the current Object.
GetHashCode | GetHashCode override. Returns the hash code for this TimetableDate.
ToString | Overloaded. Converts this TimetableDate object to its equivalent string representation.

See Also

TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate Constructor

TimetableDate Constructor
[image]

Initializes a new instance of the TimetableDate class.

Overload List

Name | Description
TimetableDate () | Creates a new instance of the TimetableDate class.
TimetableDate (DateTime) | Creates a new instance of the TimetableDate class using the given DateTime as its value.

See Also

TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate Constructor ()

TimetableDate Constructor ()
See Also
[image]

Creates a new instance of the TimetableDate class.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimetableDate ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimetableDate Constructor Overload List
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate Constructor (DateTime)

TimetableDate Constructor (DateTime)
See Also
[image]

Creates a new instance of the TimetableDate class using the given DateTime as its value.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimetableDate (
DateTime dt
)

Visual Basic [image] Copy Code

Public New ( _
dt As DateTime _
)

Parameters

dt
Type: DateTime
The DateTime value to use.

See Also

TimetableDate Constructor Overload List
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate Methods

TimetableDate Methods
[image]

Public Methods

Name | Description
Equals | IComparable.Equals override. Determines whether the specified Object is equal to the current Object.
GetHashCode | GetHashCode override. Returns the hash code for this TimetableDate.
ToString | Overloaded. Converts this TimetableDate object to its equivalent string representation.

See Also

TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate.Equals Method

TimetableDate.Equals Method
[image]

IComparable.Equals override. Determines whether the specified Object is equal to the current Object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

Type: Object
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified Object is equal to the current Object; otherwise, false.

See Also

TimetableDate Members
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate.GetHashCode Method

TimetableDate.GetHashCode Method
[image]

GetHashCode override. Returns the hash code for this TimetableDate.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

Type: Int32
A 32-bit signed integer hash code.

See Also

TimetableDate Members
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate.ToString Method

TimetableDate.ToString Method
[image]

Converts this TimetableDate object to its equivalent string representation.

Overload List

Name | Description
TimetableDate.ToString () | Converts the value of the TimetableDate object to its equivalent string representation.
TimetableDate.ToString (IFormatProvider) | Converts the value of the TimetableDate object to its equivalent string representation using the specified culture-specific format information.
TimetableDate.ToString (String) | Converts the value of the TimetableDate object to its equivalent string representation using the specified format.
TimetableDate.ToString (String, IFormatProvider) | Converts the value of the current TimetableDate object to its equivalent string representation using the specified format and culture-specific format information.

See Also

TimetableDate Members
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate.ToString Method ()

TimetableDate.ToString Method ()
See Also
[image]

Converts the value of the TimetableDate object to its equivalent string representation.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

Type: String
A string representation of the value of the current TimetableDate object.

Remarks

The value of the TimetableDate object is formatted using the general date and time format specifier ('G'). This method uses formatting information derived from the current culture. For more information, see System.Globalization.CurrentCulture.

See Also

ToString Method Overload List
TimetableDate Members
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate.ToString Method (IFormatProvider)

TimetableDate.ToString Method (IFormatProvider)
See Also
[image]

Converts the value of the TimetableDate object to its equivalent string representation using the specified culture-specific format information.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ToString (
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Function ToString( _
provider As IFormatProvider _
) As String

Parameters

provider
Type: IFormatProvider
An IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
A string representation of value of the TimetableDate object as specified by provider.

Remarks

The provider parameter is typically a DateTimeFormatInfo object or a CultureInfo object that contains a DateTimeFormatInfo object. If provider is null, the DateTimeFormatInfo associated with the current culture is used. For more information, see System.Globalization.CultureInfo.CurrentCulture.

See Also

ToString Method Overload List
TimetableDate Members
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate.ToString Method (String)

TimetableDate.ToString Method (String)
See Also
[image]

Converts the value of the TimetableDate object to its equivalent string representation using the specified format.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ToString (
string format
)

Visual Basic [image] Copy Code

Public Function ToString( _
format As String _
) As String

Parameters

format

Type: String
A DateTime format string.

Return Value

Type: String
A string representation of this TimetableDate object.

Remarks

The format parameter should contain either a format specifier character or a custom format pattern. For more information, see the summary page for System.Globalization.DateTimeFormatInfo. If format is null or an empty string, the general format specifier, 'G', is used.

See Also

ToString Method Overload List
TimetableDate Members
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate.ToString Method (String, IFormatProvider)

TimetableDate.ToString Method (String, IFormatProvider)
See Also
[image]

Converts the value of the current TimetableDate object to its equivalent string representation using the specified format and culture-specific format information.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string ToString (
string format,
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Function ToString( _
format As String, _
provider As IFormatProvider _
) As String

Parameters

format
Type: String
A DateTime format string.
provider
Type: IFormatProvider
An IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
A string representation of value of the current TimetableDate object as specified by format and provider.

Remarks

The format parameter can contain either a format specifier character or a custom format pattern. For more information, see the summary page for System.Globalization.DateTimeFormatInfo. If format is null or an empty string (""), the standard format specifier, 'G', is used. The provider parameter is typically a DateTimeFormatInfo object or an instance of CultureInfo, which contains a DateTimeFormatInfo object. If provider is null, the DateTimeFormatInfo associated with the current culture is used. For more information, see System.Globalization.CultureInfo.CurrentCulture.

See Also

ToString Method Overload List
TimetableDate Members
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate Properties

TimetableDate Properties
[image]

Public Properties

Name | Description
Value | Gets or sets the DateTime value of the item.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the object across multiple requests for the same page.

See Also

TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate.Value Property

TimetableDate.Value Property
[image]

Gets or sets the DateTime value of the item.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DateTime Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As DateTime

Property Value

An instance of the System.DateTime structure.

See Also

TimetableDate Members
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDate.ViewState Property

TimetableDate.ViewState Property
[image]

Gets a dictionary of state information that allows you to save and restore the view state of the object across multiple requests for the same page.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected StateBag ViewState { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property ViewState As StateBag

Property Value

An instance of the System.Web.UI.StateBag class that contains the view-state information.

See Also

TimetableDate Members
TimetableDate Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection Class

TimetableDateCollection Class
[image]

Represents a strongly-typed sorted collection of TimetableDate objects.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public class TimetableDateCollection : CollectionBase, IStateManager

Visual Basic [image] Copy Code

Public Class TimetableDateCollection
Inherits CollectionBase
Implements IStateManager

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.WebForms.TimetableDateCollection

See Also

TimetableDateCollection Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection Members

TimetableDateCollection Members
Constructors Properties Methods
[image]

Represents a strongly-typed sorted collection of TimetableDate objects.

The following tables list the members exposed by the TimetableDateCollection type.

Public Constructors

Name | Description
TimetableDateCollection | Overloaded.

Public Properties

Name | Description
Item | This is the indexer of the collection. Gets or sets the TimetableDate object located at the specified position within this collection.

Public Methods

Name | Description
Add | Adds the specified TimetableDate object to this collection.
Clear | Removes all elements from the collection.
Contains | Determines whether this collection contains the specified TimetableDate instance.
CopyTo | Copies the elements of this TimetableDateCollection to the specified collection at the specified index.
IndexOf | Returns the zero-based index of the first occurrence of the specified TimetableDate object in this collection.
Insert | Inserts a TimetableDate object into the collection at the specified index.
Remove | Removes the first occurrence of a TimetableDate object from this collection.
RemoveAt | Removes the element at the specified index from this collection.
SortItems | Sorts the items in the collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.
OnSetComplete | CollectionBase.OnSetComplete override.

See Also

TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection Constructor

TimetableDateCollection Constructor
[image]

Overload List

Name | Description
TimetableDateCollection () | Initializes a new instance of the DateCollection class adding the current date.
TimetableDateCollection (DateTime) | Initializes a new instance of the DateCollection class adding the given date.

See Also

TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection Constructor ()

TimetableDateCollection Constructor ()
See Also
[image]

Initializes a new instance of the DateCollection class adding the current date.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimetableDateCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimetableDateCollection Constructor Overload List
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection Constructor (DateTime)

TimetableDateCollection Constructor (DateTime)
See Also
[image]

Initializes a new instance of the DateCollection class adding the given date.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimetableDateCollection (
DateTime date
)

Visual Basic [image] Copy Code

Public New ( _
date As DateTime _
)

Parameters

date

Type: DateTime
A System.DateTime instance.

See Also

TimetableDateCollection Constructor Overload List
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection Methods

TimetableDateCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified TimetableDate object to this collection.
Clear | Removes all elements from the collection.
Contains | Determines whether this collection contains the specified TimetableDate instance.
CopyTo | Copies the elements of this TimetableDateCollection to the specified collection at the specified index.
IndexOf | Returns the zero-based index of the first occurrence of the specified TimetableDate object in this collection.
Insert | Inserts a TimetableDate object into the collection at the specified index.
Remove | Removes the first occurrence of a TimetableDate object from this collection.
RemoveAt | Removes the element at the specified index from this collection.
SortItems | Sorts the items in the collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.
OnSetComplete | CollectionBase.OnSetComplete override.

See Also

TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.Add Method

TimetableDateCollection.Add Method
[image]

Adds the specified TimetableDate object to this collection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Add (
TimetableDate date
)

Visual Basic [image] Copy Code

Public Sub Add ( _
date As TimetableDate _
)

Parameters

date
Type: TimetableDate
A TimetableDate instance to be added to the collection.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.Clear Method

TimetableDateCollection.Clear Method
[image]

Removes all elements from the collection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public new void Clear ()

Visual Basic [image] Copy Code

Public Shadows Sub Clear ()

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.Contains Method

TimetableDateCollection.Contains Method
[image]

Determines whether this collection contains the specified TimetableDate instance.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool Contains (
TimetableDate date
)

Visual Basic [image] Copy Code

Public Function Contains ( _
date As TimetableDate _
) As Boolean

Parameters

date
Type: TimetableDate
The TimetableDate object to search for in the collection.

Return Value

Type: Boolean
true if the specified object is found; otherwise false.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.CopyTo Method

TimetableDateCollection.CopyTo Method
[image]

Copies the elements of this TimetableDateCollection to the specified collection at the specified index.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void CopyTo (
TimetableDateCollection collection,
int index
)

Visual Basic [image] Copy Code

Public Sub CopyTo ( _
collection As TimetableDateCollection, _
index As Integer _
)

Parameters

collection
Type: TimetableDateCollection
The target collection to which the items are copied.
index

Type: Int32
Specifies the index at which items should be inserted in the target collection.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.IndexOf Method

TimetableDateCollection.IndexOf Method
[image]

Returns the zero-based index of the first occurrence of the specified TimetableDate object in this collection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int IndexOf (
TimetableDate date
)

Visual Basic [image] Copy Code

Public Function IndexOf ( _
date As TimetableDate _
) As Integer

Parameters

date
Type: TimetableDate
The TimetableDate to locate in the collection.

Return Value

Type: Int32
The zero-based index of the first occurrence of the element within the collection if found; otherwise, -1.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.Insert Method

TimetableDateCollection.Insert Method
[image]

Inserts a TimetableDate object into the collection at the specified index.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Insert (
int index,
TimetableDate date
)

Visual Basic [image] Copy Code

Public Sub Insert ( _
index As Integer, _
date As TimetableDate _
)

Parameters

index
Type: Int32
Specifies the position at which the TimetableDate object is inserted.
date
Type: TimetableDate
The TimetableDate instance to insert.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.OnClearComplete Method

TimetableDateCollection.OnClearComplete Method
[image]

CollectionBase.OnClearComplete override.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void OnClearComplete ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnClearComplete ()

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.OnInsertComplete Method

TimetableDateCollection.OnInsertComplete Method
[image]

CollectionBase.OnInsertComplete override.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void OnInsertComplete (
int index,
Object value
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnInsertComplete( _
index As Integer, _
value As Object _
)

Parameters

index

Type: Int32
The zero-based index at which to insert value.

value

Type: Object
The new value of the element at index.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.OnRemoveComplete Method

TimetableDateCollection.OnRemoveComplete Method
[image]

CollectionBase.OnRemoveComplete override.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void OnRemoveComplete (
int index,
Object value
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemoveComplete( _
index As Integer, _
value As Object _
)

Parameters

index

Type: Int32
The zero-based index at which value can be found.

value

Type: Object
The value of the element to remove from index.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.OnSetComplete Method

TimetableDateCollection.OnSetComplete Method
[image]

CollectionBase.OnSetComplete override.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected override void OnSetComplete (
int index,
Object oldValue,
Object newValue
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnSetComplete( _
index As Integer, _
oldValue As Object, _
newValue As Object _
)

Parameters

index
Type: Int32
The zero-based index at which oldValue can be found.
oldValue
Type: Object
The value to replace with newValue.
newValue
Type: Object
The new value of the element at index.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.Remove Method

TimetableDateCollection.Remove Method
[image]

Removes the first occurrence of a TimetableDate object from this collection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void Remove (
TimetableDate date
)

Visual Basic [image] Copy Code

Public Sub Remove ( _
date As TimetableDate _
)

Parameters

date
Type: TimetableDate
A TimetableDate instance which must be removed from the collection.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.RemoveAt Method

TimetableDateCollection.RemoveAt Method
[image]

Removes the element at the specified index from this collection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public new void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Shadows Sub RemoveAt( _
index As Integer _
)

Parameters

index

Type: Int32
The zero-based index of the item to remove.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.SortItems Method

TimetableDateCollection.SortItems Method
[image]

Sorts the items in the collection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public void SortItems ()

Visual Basic [image] Copy Code

Public Sub SortItems ()

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection Properties

TimetableDateCollection Properties
[image]

Public Properties

Name | Description
Item | This is the indexer of the collection. Gets or sets the TimetableDate object located at the specified position within this collection.

See Also

TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableDateCollection.Item Property

TimetableDateCollection.Item Property
[image]

This is the indexer of the collection. Gets or sets the TimetableDate object located at the specified position within this collection.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimetableDate Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item ( _
index As Integer _
) As TimetableDate

Parameters

index
Type: Int32
The 0-based index within the bounds of the collection where the item is located.

Property Value

The TimetableDate instance at the specified index.

See Also

TimetableDateCollection Members
TimetableDateCollection Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings Class

TimetableSettings Class
[image]

Defines properties that allow customizing the visualization of the calendar in Timetable view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class TimetableSettings : ViewSettings

Visual Basic [image] Copy Code

Public NotInheritable Class TimetableSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ViewSettings
MindFusion.Scheduling.WebForms.TimetableSettings

See Also

TimetableSettings Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings Members

TimetableSettings Members
Properties Methods Events
[image]

Defines properties that allow customizing the visualization of the calendar in Timetable view.

The following tables list the members exposed by the TimetableSettings type.

Public Properties

Name | Description
ButtonStyle | Gets the ButtonsStyle object used to specify appearance settings for the navigation buttons.
CellSize | Gets or sets the size of cells that represent the time.
CellStyle | Gets the style of a time segment cell.
CellTime | Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.
ClockAbbreviationColor | Gets or sets the color of the AM and PM clock abbreviations.
ColumnBandSize | Gets or sets the size of the bands displayed on the left/top side of each timetable column.
Dates | Gets a collection of all dates visualized in the timetable.
DayHeaderMinSize | Gets or sets the minimum size of the header displaying all-day items.
EnableWorkOnWeekends | Gets or sets a value indicating whether to color the work-time cells in weekend days.
EndTime | Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.
GeneralFormat | Gets or sets the string to use when formatting times in the timeline.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the group header.
GroupHours | Gets or sets a value indicating whether hours displayed in the timeline are grouped.
HeaderCellStyle | Gets the style of a time segment cell.
HeaderDateFormat | Gets or sets the format of dates displayed in the timetable header.
ItemOffset | Gets or set the distance between the first item and its adjoining cell side.
MainHeaderSize | Gets or sets the size of the main header.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header.
MaxAllDayItems | Gets or sets the maximum number of all-day items visible at a time in the column headers.
MinuteFormat | Gets or sets how to format and display minutes.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
ReverseGrouping | Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.
ScrollStep | Gets or sets the number of days to scroll when the user clicks the navigation buttons.
ShowAM | Gets or sets a value indicating whether the AM and PM suffixes are displayed.
ShowDayHeader | Gets or sets a value indicating whether to show the header displaying all-day items.
ShowExpandButton | Gets or sets a value indicating whether the Timetable view displays expand header button.
ShowMinutesInHourHeaders | Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.
ShowNavigationButtons | Gets or sets a value indicating whether the Timetable view displays navigation buttons.
ShowWorkTime | Gets or sets a value that indicates whether work time is displayed with different style.
StartTime | Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.
Style | Gets or sets the appearance style used to paint the calendar.
TimelineSize | Gets or sets the size of the timeline header.
TimelineStyle | Gets or sets the style of the timeline header.
TimelineTicksColor | Gets or sets the color of ticks in a Timetable timeline.
TwelveHourFormat | Gets or sets a value indicating whether to use a 12-hour format.
WorkTimeCellStyle | Gets or sets the style of cells in the work time interval.
WorkTimeEndHour | Gets or sets the end hour of the work time interval.
WorkTimeStartHour | Gets or sets the start hour of the work time interval.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

Inherited Public Events

Name | Description
SettingsChanged | Raised when the view settings change. (Inherited from ViewSettings.)

See Also

TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings Methods

TimetableSettings Methods
[image]

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

See Also

TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.LoadViewState Method

TimetableSettings.LoadViewState Method
[image]

WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object savedState
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
savedState As Object _
)

Parameters

savedState
Type: Object
A System.Object that represents the control state to be restored.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.SaveViewState Method

TimetableSettings.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.TrackViewState Method

TimetableSettings.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings Properties

TimetableSettings Properties
[image]

Public Properties

Name | Description
ButtonStyle | Gets the ButtonsStyle object used to specify appearance settings for the navigation buttons.
CellSize | Gets or sets the size of cells that represent the time.
CellStyle | Gets the style of a time segment cell.
CellTime | Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.
ClockAbbreviationColor | Gets or sets the color of the AM and PM clock abbreviations.
ColumnBandSize | Gets or sets the size of the bands displayed on the left/top side of each timetable column.
Dates | Gets a collection of all dates visualized in the timetable.
DayHeaderMinSize | Gets or sets the minimum size of the header displaying all-day items.
EnableWorkOnWeekends | Gets or sets a value indicating whether to color the work-time cells in weekend days.
EndTime | Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.
GeneralFormat | Gets or sets the string to use when formatting times in the timeline.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the group header.
GroupHours | Gets or sets a value indicating whether hours displayed in the timeline are grouped.
HeaderCellStyle | Gets the style of a time segment cell.
HeaderDateFormat | Gets or sets the format of dates displayed in the timetable header.
ItemOffset | Gets or set the distance between the first item and its adjoining cell side.
MainHeaderSize | Gets or sets the size of the main header.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header.
MaxAllDayItems | Gets or sets the maximum number of all-day items visible at a time in the column headers.
MinuteFormat | Gets or sets how to format and display minutes.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
ReverseGrouping | Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.
ScrollStep | Gets or sets the number of days to scroll when the user clicks the navigation buttons.
ShowAM | Gets or sets a value indicating whether the AM and PM suffixes are displayed.
ShowDayHeader | Gets or sets a value indicating whether to show the header displaying all-day items.
ShowExpandButton | Gets or sets a value indicating whether the Timetable view displays expand header button.
ShowMinutesInHourHeaders | Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.
ShowNavigationButtons | Gets or sets a value indicating whether the Timetable view displays navigation buttons.
ShowWorkTime | Gets or sets a value that indicates whether work time is displayed with different style.
StartTime | Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.
Style | Gets or sets the appearance style used to paint the calendar.
TimelineSize | Gets or sets the size of the timeline header.
TimelineStyle | Gets or sets the style of the timeline header.
TimelineTicksColor | Gets or sets the color of ticks in a Timetable timeline.
TwelveHourFormat | Gets or sets a value indicating whether to use a 12-hour format.
WorkTimeCellStyle | Gets or sets the style of cells in the work time interval.
WorkTimeEndHour | Gets or sets the end hour of the work time interval.
WorkTimeStartHour | Gets or sets the start hour of the work time interval.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

See Also

TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ButtonStyle Property

TimetableSettings.ButtonStyle Property
[image]

Gets the ButtonsStyle object used to specify appearance settings for the navigation buttons.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public ButtonsStyle ButtonStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ButtonStyle As ButtonsStyle

Property Value

An instance of the ButtonsStyle class.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.CellSize Property

TimetableSettings.CellSize Property
[image]

Gets or sets the size of cells that represent the time.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit CellSize { get; set; }

Visual Basic [image] Copy Code

Public Property CellSize As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure that specifies the size of the time cells. Default value is 25.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.CellStyle Property

TimetableSettings.CellStyle Property
[image]

Gets the style of a time segment cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Style CellStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CellStyle As Style

Property Value

An instance of the Style class.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.CellTime Property

TimetableSettings.CellTime Property
[image]

Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimeSpan CellTime { get; set; }

Visual Basic [image] Copy Code

Public Property CellTime As TimeSpan

Property Value

A System.TimeSpan value that represents the length of a time cell. Default value is 00:30:00 (30 minutes).

Remarks

Valid values for this property range from 1 second to 1 day.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ClockAbbreviationColor Property

TimetableSettings.ClockAbbreviationColor Property
[image]

Gets or sets the color of the AM and PM clock abbreviations.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Color ClockAbbreviationColor { get; set; }

Visual Basic [image] Copy Code

Public Property ClockAbbreviationColor As Color

Property Value

One of the System.Drawing.Color structure that specifies the color of AM and PM clock abbreviations. Default value is Color.Empty.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ColumnBandSize Property

TimetableSettings.ColumnBandSize Property
[image]

Gets or sets the size of the bands displayed on the left/top side of each timetable column.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit ColumnBandSize { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnBandSize As Unit

Property Value

One of the System.Web.UI.WebControls.Unit structure values that specifies the size of the bands. Default value is Unit.Empty.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.Dates Property

TimetableSettings.Dates Property
[image]

Gets a collection of all dates visualized in the timetable.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimetableDateCollection Dates { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Dates As TimetableDateCollection

Property Value

An instance of the TimetableDateCollection class that represents the collection of visible dates in the Timetable view..

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.DayHeaderMinSize Property

TimetableSettings.DayHeaderMinSize Property
[image]

Gets or sets the minimum size of the header displaying all-day items.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit DayHeaderMinSize { get; set; }

Visual Basic [image] Copy Code

Public Property DayHeaderMinSize As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure than specifies the minimum size of the all-day items header. Default value is Unit.Empty.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.EnableWorkOnWeekends Property

TimetableSettings.EnableWorkOnWeekends Property
[image]

Gets or sets a value indicating whether to color the work-time cells in weekend days.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State EnableWorkOnWeekends { get; set; }

Visual Basic [image] Copy Code

Public Property EnableWorkOnWeekends As State

Property Value

One of the State enumeration values. Default value is State.Disabled.

Remarks

If this property is enabled the work-time cells in weekend days are colored.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.EndTime Property

TimetableSettings.EndTime Property
[image]

Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int EndTime { get; set; }

Visual Basic [image] Copy Code

Public Property EndTime As Integer

Property Value

An integer value specifying the end time in minutes. The allowed values range from 0 to 2880.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.GeneralFormat Property

TimetableSettings.GeneralFormat Property
[image]

Gets or sets the string to use when formatting times in the timeline.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string GeneralFormat { get; set; }

Visual Basic [image] Copy Code

Public Property GeneralFormat As String

Property Value

A string that specifies the format. Default value is "h:mm tt".

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.GroupHeaderSize Property

TimetableSettings.GroupHeaderSize Property
[image]

Gets or sets the size of the group header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit GroupHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property GroupHeaderSize As Unit

Property Value

Type: Unit

Remarks

A value of 0 causes the calendar to automatically calculate a header size based on the size of the header font.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.GroupHeaderStyle Property

TimetableSettings.GroupHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the group header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle GroupHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property GroupHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.GroupHours Property

TimetableSettings.GroupHours Property
[image]

Gets or sets a value indicating whether hours displayed in the timeline are grouped.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State GroupHours { get; set; }

Visual Basic [image] Copy Code

Public Property GroupHours As State

Property Value

One of the State enumeration values specifying whether hours in the timeline are grouped. Default value is State.Enabled.

Remarks

Certain conditions prevent hours from grouping, such as when the hours are not divisible by the specified CellTime.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.HeaderCellStyle Property

TimetableSettings.HeaderCellStyle Property
[image]

Gets the style of a time segment cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Style HeaderCellStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HeaderCellStyle As Style

Property Value

Type: Style

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.HeaderDateFormat Property

TimetableSettings.HeaderDateFormat Property
[image]

Gets or sets the format of dates displayed in the timetable header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string HeaderDateFormat { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderDateFormat As String

Property Value

A string value that represents the format used for dates in the timetable header. Default is "MMM dd, yyyy".

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ItemOffset Property

TimetableSettings.ItemOffset Property
[image]

Gets or set the distance between the first item and its adjoining cell side.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit ItemOffset { get; set; }

Visual Basic [image] Copy Code

Public Property ItemOffset As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure that specifies the distance. Default value is "5px".

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.MainHeaderSize Property

TimetableSettings.MainHeaderSize Property
[image]

Gets or sets the size of the main header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit MainHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property MainHeaderSize As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure specifying the size of the main header. Default value is Unit.Empty.

Remarks

A value of 0 causes the calendar to automatically calculate a header size based on the size of the header font.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.MainHeaderStyle Property

TimetableSettings.MainHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the main header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle MainHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MainHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.MaxAllDayItems Property

TimetableSettings.MaxAllDayItems Property
[image]

Gets or sets the maximum number of all-day items visible at a time in the column headers.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int MaxAllDayItems { get; set; }

Visual Basic [image] Copy Code

Public Property MaxAllDayItems As Integer

Property Value

A non-negative integer value specifying the maximum number of all-day items visible at a time in the column headers. Default value is 4.

Remarks

The all-day items header is automatically resized to hold all items up to the number set in this property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.MinuteFormat Property

TimetableSettings.MinuteFormat Property
[image]

Gets or sets how to format and display minutes.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public MinuteFormat MinuteFormat { get; set; }

Visual Basic [image] Copy Code

Public Property MinuteFormat As MinuteFormat

Property Value

One of the MinuteFormat enumeration values. Default value is MinuteFormat.LeadingZero.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ReverseGrouping Property

TimetableSettings.ReverseGrouping Property
[image]

Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ReverseGrouping { get; set; }

Visual Basic [image] Copy Code

Public Property ReverseGrouping As State

Property Value

One of the State enumeration values. Default value is State.Disabled.

Remarks

By default grouping is done first by available dates, then by the resources specified in the current grouping type. Setting this property to Enabled reverses this behavior.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ScrollStep Property

TimetableSettings.ScrollStep Property
[image]

Gets or sets the number of days to scroll when the user clicks the navigation buttons.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int ScrollStep { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollStep As Integer

Property Value

A non-negative integer value specifying the number of days to scroll. Default value is 1.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ShowAM Property

TimetableSettings.ShowAM Property
[image]

Gets or sets a value indicating whether the AM and PM suffixes are displayed.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowAM { get; set; }

Visual Basic [image] Copy Code

Public Property ShowAM As State

Property Value

One of the State enumeration values specifying whether AM and PM suffixes are displayed. Default value is State.Enabled.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ShowDayHeader Property

TimetableSettings.ShowDayHeader Property
[image]

Gets or sets a value indicating whether to show the header displaying all-day items.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowDayHeader { get; set; }

Visual Basic [image] Copy Code

Public Property ShowDayHeader As State

Property Value

One of the State enumeration values specifying whether to show the all-day items header. Default is State.Enabled.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ShowMinutesInHourHeaders Property

TimetableSettings.ShowMinutesInHourHeaders Property
[image]

Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowMinutesInHourHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property ShowMinutesInHourHeaders As State

Property Value

One of the State enumeration values. Default value is State.Enabled.

Remarks

Whole hour cells are displayed when the hours are divisible by the specified CellTime.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ShowNavigationButtons Property

TimetableSettings.ShowNavigationButtons Property
[image]

Gets or sets a value indicating whether the Timetable view displays navigation buttons.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowNavigationButtons { get; set; }

Visual Basic [image] Copy Code

Public Property ShowNavigationButtons As State

Property Value

One of the State enumeration values specifying whether navigation buttons will be displayed in the view. Default value is State.Enabled.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ShowWorkTime Property

TimetableSettings.ShowWorkTime Property
[image]

Gets or sets a value that indicates whether work time is displayed with different style.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowWorkTime { get; set; }

Visual Basic [image] Copy Code

Public Property ShowWorkTime As State

Property Value

One of the State enumeration values specifying whether work time cells are displayed with a different style. Default value is State.Enabled.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.StartTime Property

TimetableSettings.StartTime Property
[image]

Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int StartTime { get; set; }

Visual Basic [image] Copy Code

Public Property StartTime As Integer

Property Value

An integer value specifying the view start time in minutes. The allowed values range from 0 to 1440. Default value is 0.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.Style Property

TimetableSettings.Style Property
[image]

Gets or sets the appearance style used to paint the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Style Style { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Style As Style

Property Value

An instance of the Style class.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.TimelineSize Property

TimetableSettings.TimelineSize Property
[image]

Gets or sets the size of the timeline header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit TimelineSize { get; set; }

Visual Basic [image] Copy Code

Public Property TimelineSize As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure specifying the timeline size. Default value is Unit.Empty.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.TimelineStyle Property

TimetableSettings.TimelineStyle Property
[image]

Gets or sets the style of the timeline header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle TimelineStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TimelineStyle As HeaderStyle

Property Value

An instance of the HeaderStyle class.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.TimelineTicksColor Property

TimetableSettings.TimelineTicksColor Property
[image]

Gets or sets the color of ticks in a Timetable timeline.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Color TimelineTicksColor { get; set; }

Visual Basic [image] Copy Code

Public Property TimelineTicksColor As Color

Property Value

Type: Color

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.TwelveHourFormat Property

TimetableSettings.TwelveHourFormat Property
[image]

Gets or sets a value indicating whether to use a 12-hour format.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State TwelveHourFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TwelveHourFormat As State

Property Value

One of the State enumeration values specifying whether to use a 12-hour format. Default value is State.Enabled.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.WorkTimeCellStyle Property

TimetableSettings.WorkTimeCellStyle Property
[image]

Gets or sets the style of cells in the work time interval.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Style WorkTimeCellStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property WorkTimeCellStyle As Style

Property Value

An instance of the Style class.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.WorkTimeEndHour Property

TimetableSettings.WorkTimeEndHour Property
[image]

Gets or sets the end hour of the work time interval.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimeSpan WorkTimeEndHour { get; set; }

Visual Basic [image] Copy Code

Public Property WorkTimeEndHour As TimeSpan

Property Value

An instance of the System.TimeSpan structure. Default value is "17:30:00";

Remarks

This property and WorkTimeStartHour specify the working time period, whose cells are usually displayed in a different style as set in WorkTimeCellStyle. To use the same style for all cells in the timetable view, set WorkTimeCellStyle to a new empty Style.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.WorkTimeStartHour Property

TimetableSettings.WorkTimeStartHour Property
[image]

Gets or sets the start hour of the work time interval.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public TimeSpan WorkTimeStartHour { get; set; }

Visual Basic [image] Copy Code

Public Property WorkTimeStartHour As TimeSpan

Property Value

An instance of System.TimeSpan structure. Default value is "08:00:00".

Remarks

This property and WorkTimeEndHour specify the working time period, whose cells are usually displayed in a different style as set in WorkTimeCellStyle. To use the same style for all cells in the timetable view, set WorkTimeCellStyle to a new empty Style.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.Orientation Property

TimetableSettings.Orientation Property
[image]

Gets or sets a value indicating whether the cells are displayed horizontally or vertically.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

Type: Orientation

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.TimetableSettings.ShowExpandButton Property

TimetableSettings.ShowExpandButton Property
[image]

Gets or sets a value indicating whether the Timetable view displays expand header button.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State ShowExpandButton { get; set; }

Visual Basic [image] Copy Code

Public Property ShowExpandButton As State

Property Value

Type: State

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings Class

ViewSettings Class
[image]

The base class for the different view settings classes.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract class ViewSettings : IStateManager

Visual Basic [image] Copy Code

Public MustInherit Class ViewSettings
Implements IStateManager

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ViewSettings
MindFusion.Scheduling.WebForms.CellSettings
MindFusion.Scheduling.WebForms.ListViewSettings
MindFusion.Scheduling.WebForms.MonthRangeSettings
MindFusion.Scheduling.WebForms.MonthSettings
MindFusion.Scheduling.WebForms.ResourceViewSettings
MindFusion.Scheduling.WebForms.TimelineSettings
MindFusion.Scheduling.WebForms.TimetableSettings
MindFusion.Scheduling.WebForms.WeekRangeSettings

See Also

ViewSettings Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings Members

ViewSettings Members
Properties Methods Events
[image]

The base class for the different view settings classes.

The following tables list the members exposed by the ViewSettings type.

Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.
Style | Gets a style object that encapsulates the appearance settings for the view.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page.

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Public Events

Name | Description
SettingsChanged | Raised when the view settings change.

See Also

ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings Methods

ViewSettings Methods
[image]

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

See Also

ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings.LoadViewState Method

ViewSettings.LoadViewState Method
[image]

WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void LoadViewState (
Object state
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadViewState( _
state As Object _
)

Parameters

state

Type: Object
An Object that represents the control state to be restored.

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings.SaveViewState Method

ViewSettings.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overridable Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings.TrackViewState Method

ViewSettings.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public virtual void TrackViewState ()

Visual Basic [image] Copy Code

Public Overridable Sub TrackViewState ()

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings Properties

ViewSettings Properties
[image]

Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.
Style | Gets a style object that encapsulates the appearance settings for the view.

Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page.

See Also

ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings.IsTrackingViewState Property

ViewSettings.IsTrackingViewState Property
[image]

IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public bool IsTrackingViewState { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsTrackingViewState As Boolean

Property Value

true if the control is saving changes to its ViewState; otherwise false.

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings.Style Property

ViewSettings.Style Property
[image]

Gets a style object that encapsulates the appearance settings for the view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public abstract Style Style { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Style As Style

Property Value

An instance of the Style class.

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings.ViewState Property

ViewSettings.ViewState Property
[image]

Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

protected StateBag ViewState { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property ViewState As StateBag

Property Value

An instance of the System.Web.UI.StateBag class that contains the server control's view-state information.

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings Events

ViewSettings Events
[image]

Public Events

Name | Description
SettingsChanged | Raised when the view settings change.

See Also

ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.ViewSettings.SettingsChanged Event

ViewSettings.SettingsChanged Event
[image]

Raised when the view settings change.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public event EventHandler SettingsChanged

Visual Basic [image] Copy Code

Public Event SettingsChanged As EventHandler

Event Data

An instance of the System.EventArgs class that contains data for the event.

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeHeaderStyle Enumeration

WeekRangeHeaderStyle Enumeration
[image]

Specifies the style of the time header in WeekRange view. This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its members.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum WeekRangeHeaderStyle

Visual Basic [image] Copy Code

Public Enum WeekRangeHeaderStyle

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
None | 0 | No header is displayed.
Title | 1 | The header displays the start and end dates specified in the WeekRangeSettings object.

See Also

MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings Class

WeekRangeSettings Class
[image]

Specifies appearance settings for the calendar in WeekRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public sealed class WeekRangeSettings : ViewSettings

Visual Basic [image] Copy Code

Public NotInheritable Class WeekRangeSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.WebForms.ViewSettings
MindFusion.Scheduling.WebForms.WeekRangeSettings

See Also

WeekRangeSettings Members
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings Members

WeekRangeSettings Members
Properties Methods Events
[image]

Specifies appearance settings for the calendar in WeekRange view.

The following tables list the members exposed by the WeekRangeSettings type.

Public Properties

Name | Description
DayNamesHeader | Gets or sets a value indicating whether to display the day names header.
DayNamesHeaderHeight | Gets or sets the height of the day names header in the WeekRange view.
DayNamesHeaderStyle | Gets or sets the appearance style used to paint the day names header.
DayOfWeekFormat | Gets or sets the format of week day names.
DaySettings | Gets the CellSettings object used for customizing the appearance of days in the WeekRange view.
DaySpacing | Gets or sets the amount of space between adjacent days.
EvenMonthsFillColor | Gets or sets the color used to paint the background of all even months' areas in the WeekRange view.
HeaderStyle | Gets or sets the style of the main header.
MainHeaderHeight | Gets or sets the height of the main header in the WeekRange view.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header.
MaxItems | Gets or sets the maximum number of items to be displayed in a day cell.
OddMonthsFillColor | Gets or sets the color used to paint the background of all odd months' areas in the WeekRange view.
Style | Gets or sets the appearance style used to paint the calendar.
TitleFormat | Gets or sets the format of the calendar's title.
TitleSeparator | Gets or sets the string used as a separator in the calendar's title.
ViewStyle | Gets or sets the style of the WeekRange view.
VisibleRows | Gets or sets the number of weeks visible at a time.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

Inherited Public Events

Name | Description
SettingsChanged | Raised when the view settings change. (Inherited from ViewSettings.)

See Also

WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings Methods

WeekRangeSettings Methods
[image]

Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Inherited Public Methods

Name | Description
LoadViewState | WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from ViewSettings.)
SaveViewState | WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from ViewSettings.)
TrackViewState | WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. (Inherited from ViewSettings.)

See Also

WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.LoadViewState Method

WeekRangeSettings.LoadViewState Method
[image]

WebControl.LoadViewState override. Restores view-state information from a previous page request that was saved by the SaveViewState method.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void LoadViewState (
Object savedState
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadViewState( _
savedState As Object _
)

Parameters

savedState
Type: Object
A System.Object that represents the control state to be restored.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.SaveViewState Method

WeekRangeSettings.SaveViewState Method
[image]

WebControl.SaveViewState override. Saves any server control view-state changes that have occurred since the time the page was posted back to the server.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Object SaveViewState ()

Visual Basic [image] Copy Code

Public Overrides Function SaveViewState () As Object

Return Value

Type: Object
Returns the server control's current view state. If there is no view state associated with the control, this method returns null (Nothing in VB.NET).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.TrackViewState Method

WeekRangeSettings.TrackViewState Method
[image]

WebControl.TrackViewState override. Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override void TrackViewState ()

Visual Basic [image] Copy Code

Public Overrides Sub TrackViewState ()

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings Properties

WeekRangeSettings Properties
[image]

Public Properties

Name | Description
DayNamesHeader | Gets or sets a value indicating whether to display the day names header.
DayNamesHeaderHeight | Gets or sets the height of the day names header in the WeekRange view.
DayNamesHeaderStyle | Gets or sets the appearance style used to paint the day names header.
DayOfWeekFormat | Gets or sets the format of week day names.
DaySettings | Gets the CellSettings object used for customizing the appearance of days in the WeekRange view.
DaySpacing | Gets or sets the amount of space between adjacent days.
EvenMonthsFillColor | Gets or sets the color used to paint the background of all even months' areas in the WeekRange view.
HeaderStyle | Gets or sets the style of the main header.
MainHeaderHeight | Gets or sets the height of the main header in the WeekRange view.
MainHeaderStyle | Gets or sets the appearance style used to paint the main header.
MaxItems | Gets or sets the maximum number of items to be displayed in a day cell.
OddMonthsFillColor | Gets or sets the color used to paint the background of all odd months' areas in the WeekRange view.
Style | Gets or sets the appearance style used to paint the calendar.
TitleFormat | Gets or sets the format of the calendar's title.
TitleSeparator | Gets or sets the string used as a separator in the calendar's title.
ViewStyle | Gets or sets the style of the WeekRange view.
VisibleRows | Gets or sets the number of weeks visible at a time.

Inherited Public Properties

Name | Description
IsTrackingViewState | IStateManager.IsTrackingViewState override. Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from ViewSettings.)
Style | Gets a style object that encapsulates the appearance settings for the view. (Inherited from ViewSettings.)

Inherited Protected Properties

Name | Description
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of the server control across multiple requests for the same page. (Inherited from ViewSettings.)

See Also

WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.DayNamesHeader Property

WeekRangeSettings.DayNamesHeader Property
[image]

Gets or sets a value indicating whether to display the day names header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public State DayNamesHeader { get; set; }

Visual Basic [image] Copy Code

Public Property DayNamesHeader As State

Property Value

Type: State

Remarks

The day names are obtained from the DateTimeFormat property of the Calendar class, if it isn't a null reference, or from the corresponding DateTimeFormat property of the CultureInfo object assigned to calendar's Culture.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.DayNamesHeaderHeight Property

WeekRangeSettings.DayNamesHeaderHeight Property
[image]

Gets or sets the height of the day names header in the WeekRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit DayNamesHeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property DayNamesHeaderHeight As Unit

Property Value

An instance of the System.Web.UI.WebControls.Unit structure specifying the height of the day headers. Default value is Unit.Empty.

Remarks

A value of 0 causes the height to be calculated automatically based on the size of the header font.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.DayNamesHeaderStyle Property

WeekRangeSettings.DayNamesHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the day names header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle DayNamesHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DayNamesHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.DayOfWeekFormat Property

WeekRangeSettings.DayOfWeekFormat Property
[image]

Gets or sets the format of week day names.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public DayOfWeekFormat DayOfWeekFormat { get; set; }

Visual Basic [image] Copy Code

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

One of the DayOfWeekFormat enumeration values specifying the format of week day names. Default value is DayOfWeekFormat.Abbreviated.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.DaySettings Property

WeekRangeSettings.DaySettings Property
[image]

Gets the CellSettings object used for customizing the appearance of days in the WeekRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CellSettings DaySettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DaySettings As CellSettings

Property Value

An instance of the CellSettings class.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.DaySpacing Property

WeekRangeSettings.DaySpacing Property
[image]

Gets or sets the amount of space between adjacent days.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int DaySpacing { get; set; }

Visual Basic [image] Copy Code

Public Property DaySpacing As Integer

Property Value

Type: Int32

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.EvenMonthsFillColor Property

WeekRangeSettings.EvenMonthsFillColor Property
[image]

Gets or sets the color used to paint the background of all even months' areas in the WeekRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CssBackground EvenMonthsFillColor { get; set; }

Visual Basic [image] Copy Code

Public Property EvenMonthsFillColor As CssBackground

Property Value

An instance of the CssBackground class specifying the color used to paint the background of even months.

Remarks

If this value is set to null (Nothing in Visual Basic), the control uses the color from the associated style to paint the even months' background.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.HeaderStyle Property

WeekRangeSettings.HeaderStyle Property
[image]

Gets or sets the style of the main header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public WeekRangeHeaderStyle HeaderStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeaderStyle As WeekRangeHeaderStyle

Property Value

One of the WeekRangeHeaderStyle enumeration values specifying the style of the header. Default value is WeekRangeHeaderStyle.Title.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.MainHeaderHeight Property

WeekRangeSettings.MainHeaderHeight Property
[image]

Gets or sets the height of the main header in the WeekRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public Unit MainHeaderHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MainHeaderHeight As Unit

Property Value

Type: Unit

Remarks

A value of 0 causes the height to be calculated automatically based on the size of the header font.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.MainHeaderStyle Property

WeekRangeSettings.MainHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the main header.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public HeaderStyle MainHeaderStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property MainHeaderStyle As HeaderStyle

Property Value

Type: HeaderStyle

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.MaxItems Property

WeekRangeSettings.MaxItems Property
[image]

Gets or sets the maximum number of items to be displayed in a day cell.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int MaxItems { get; set; }

Visual Basic [image] Copy Code

Public Property MaxItems As Integer

Property Value

A non-negative integer value specifying the maximum number of items to be displayed in a day cell. Default value is 0.

Remarks

If MaxItems is set to 0, the number of items to be displayed will be calculated on the client side.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.OddMonthsFillColor Property

WeekRangeSettings.OddMonthsFillColor Property
[image]

Gets or sets the color used to paint the background of all odd months' areas in the WeekRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public CssBackground OddMonthsFillColor { get; set; }

Visual Basic [image] Copy Code

Public Property OddMonthsFillColor As CssBackground

Property Value

An instance of the CssBackground class specifying the color used to paint the background of odd months.

Remarks

If this value is set to null (Nothing in Visual Basic), the control uses the color from the associated style to paint the odd months' background.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.Style Property

WeekRangeSettings.Style Property
[image]

Gets or sets the appearance style used to paint the calendar.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public override Style Style { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Style As Style

Property Value

An instance of the Style class.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.TitleFormat Property

WeekRangeSettings.TitleFormat Property
[image]

Gets or sets the format of the calendar's title.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string that represents the format. Default value is "dd MMMM".

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.TitleSeparator Property

WeekRangeSettings.TitleSeparator Property
[image]

Gets or sets the string used as a separator in the calendar's title.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public string TitleSeparator { get; set; }

Visual Basic [image] Copy Code

Public Property TitleSeparator As String

Property Value

A string that represents the separator. Default value is " - ".

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.ViewStyle Property

WeekRangeSettings.ViewStyle Property
[image]

Gets or sets the style of the WeekRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public WeekRangeViewStyle ViewStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ViewStyle As WeekRangeViewStyle

Property Value

One of the WeekRangeViewStyle enumeration values specifying the style of the view. Default value is WeekRangeViewStyle.WeekPerRow.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeSettings.VisibleRows Property

WeekRangeSettings.VisibleRows Property
[image]

Gets or sets the number of weeks visible at a time.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public int VisibleRows { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleRows As Integer

Property Value

A non-negative integer value specifying the number of weeks visible at a time. Default value is 5.

Remarks

Used only when ViewStyle is set to WeekPerRow.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.WebForms Namespace


MindFusion.Scheduling.WebForms.WeekRangeViewStyle Enumeration

WeekRangeViewStyle Enumeration
[image]

Specifies whether there are multiple weeks displayed in WeekRange view.

Namespace: MindFusion.Scheduling.WebForms
Assembly: MindFusion.Scheduling.WebForms

Syntax

C# [image] Copy Code

public enum WeekRangeViewStyle

Visual Basic [image] Copy Code

Public Enum WeekRangeViewStyle

Members

Member name | Value | Description
Unspecified | -1 | Unspecified.
WeekPerRow | 0 | The calendar view displays several weeks at a time.
SingleWeek | 1 | The calendar view displays a single week at a time.

See Also

MindFusion.Scheduling.WebForms Namespace


Upgrading from version 2.x

Upgrading from version 2.x

Upgrading to version 3.0.0

Server

  • Style class has been refactored and split to three new classes - Style, HeaderStyle and ItemStyle. The new Style class has two properties - Borders and Brush and is used for styling non-header elements. The HeaderStyle class is intended for styling header elements and extends the Style class with the text-related properties, namely Font, TextColor, TextMargins and TextAlignment. The ItemStyle class is designed exclusively for styling Calendar items. It extends the HeaderStyle class with header text-related properties(HeaderFont, HeaderTextColor, HeaderTextMargins and HeaderTextAlignment), LineColor and FillColor. See below the list of altered members of the Style class:

Type of member | Removed member name | New member name
Constructor | Style(string representation) | N/A
Method | FromDefinition | N/A
Property | FillColor | N/A
Property | Font | HeaderStyle.Font or ItemStyle.Font
Property | HeaderBorders | HeaderStyle.Borders
Property | HeaderBrush | HeaderStyle.Brush
Property | HeaderFont | HeaderStyle.Font or ItemStyle.HeaderFont
Property | HeaderTextAlignment | HeaderStyle.TextAlignment or ItemStyle.HeaderTextAlignment
Property | HeaderTextColor | HeaderStyle.TextColor or ItemStyle.HeaderTextColor
Property | HeaderTextMargins | HeaderStyle.TextMargins or ItemStyle.HeaderTextMargins
Property | LineColor | ItemStyle.LineColor
Property | TextAlignment | ItemStyle.TextAlignment
Property | TextColor | ItemStyle.TextColor
Property | TextMargins | ItemStyle.TextMargins

  • TimetableCellSettings, TimetableWorkTimeCellStyle and TimetableTimeLineStyle classes have been removed. They have been replaced in the API by Style or HeaderStyle accordingly. The following table lists the changes in the TimetableSettings class:

Member name | Old type | New type
CellStyle | TimetableCellSettings | Style
TimelineStyle | TimetableTimeLineStyle | HeaderStyle
WorkTimeCellStyle | TimetableWorkTimeCellStyle | Style

  • The following Item-related members have been affected by the Style refactoring:

Member name | Old type | New Type
Appointment.Style | Style | ItemStyle
Item.Style | Style | ItemStyle
ItemSettings.Style | Style | ItemStyle

  • Renamed properties in version 3.0.0

Class name | Old member name | New member name
MonthSettings | SubHeaderHeight | DayNamesHeaderHeight
MonthSettings | ShowDayOfWeek | DayNamesHeader
TimetableSettings | SubHeaderSize | GroupHeaderSize
ListViewSettings | HeaderSize | MainHeaderSize
WeekRangeSettings | ShowDayOfWeek | DayNamesHeader
WeekRangeSettings | TimePeriodHeaderHeight | MainHeaderHeight
WeekRangeSettings | DayDistance | DaySpacing

Client

  • signature of calendar.getAllDayCells() method changed as follows (new parameters marked in bold):
    /**
    * Gets the collection of all-day calendar cells in the Timetable view.
    * @param { DateTime } [startTime] The start time of the range.
    * @param {    DateTime} [endTime] The end time of the range.
    * @param {Object} [resource] The resource to search for.
    * @returns {Array} The collection of all-day calendar cells in the Timetable view.
    */
    getAllDayCells: function([startTime, [endTime, [resource]]])
  • signature of calendar.getTimeCell() method changed as follows (new parameters marked in bold):
    /**
    * Gets the date/time calendar cell that corresponds to the specified DateTime.
    * @param {DateTime} dateTime The time to search for.
    * @param {Boolean} [isEndTime] true if the index of the first interval is returned when the time is the boundary between two consecutive intervals;
    false if the index of the second interval is contained. The default is false.
    * @param {Object} [resource] The resource to search for.
    * @returns {Object} The cell that corresponds the specified DateTime and resource.
    */
    getTimeCell: function(dateTime, [isEndTime, [resource]])
  • signature of calendar.getTimeCells() method changed as follows (new parameters marked in bold):
    /**
    * Gets the date/time calendar cells that corresponds to the specified DateTime range.
    * @param {DateTime} startTime The start time of the range.
    * @param {DateTime} [endTime] The end time of the range.
    * @param {Boolean} [isEndTime] true if the index of the first interval is returned when the time is the boundary between two consecutive intervals;
    false if the index of the second interval is contained. The default is false.
    * @param {Object} [resource] The resource to search for.
    * @returns {Array} The collection of cells that correspond to the specified DateTime range and resource.
    */
    getTimeCells: function(startTime, [endTime, [isEndTime, [resource]]])


Technical Support

Technical Support

Detailed information about everything connected with software products offered by MindFusion - online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu/ [image] . The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at mailto:support@mindfusion.eu [image] or by phone at +359 889 199 729.

You can post a question about MindFusion.Scheduling for ASP.NET on the discussion board:

http://mindfusion.eu/Forum/YaBB.pl?board=scheduling_aspnet

or visit our help desk site:

http://www.mindfusion.eu/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding MindFusion.Scheduling for ASP.NET. We do take in account the opinion of every single person who has shown interest in our products.


Acknowledgements

Acknowledgements

Copyright (c) 2011 John Resig, http://jquery.com/

Permission is hereby granted, free of charge, to any person obtaining
a copy of this software and associated documentation files (the
"Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to
the following conditions:

The above copyright notice and this permission notice shall be
included in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.


MindFusion Products

MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming | Links
Diagramming for WPF | Product Information Download
Diagramming for Silverlight | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for .NET Compact | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download
DiagramViewer for iOS/Cocoa Touch | Product Information Download
DiagramViewer for Android | Product Information Download

Charting | Links
Charting for WPF | Product Information Download
Charting for Silverlight | Product Information Download
Charting for WinForms | Product Information Download
Charting for ASP.NET | Product Information Download

Scheduling | Links
Scheduling for WinForms | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for .NET Compact | Product Information Download
Scheduling for WPF | Product Information Download
Scheduling for Silverlight | Product Information Download
Scheduling for Java Swing | Product Information Download

Spreadsheet | Links
Spreadsheet for WinForms | Product Information Download
Spreadsheet for WPF | Product Information Download

Reporting | Links
Reporting for WinForms | Product Information Download
Reporting for WPF | Product Information Download
Reporting for Silverlight | Product Information Download

Mapping | Links
Mapping for WinForms | Product Information Download
Mapping for WPF | Product Information Download
Mapping for Silverlight | Product Information Download

Suites | Links
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Java FX | Product Information Download
Pack for Scheduling | Product Information Download
Pack for Silverlight | Product Information Download