Introduction

MindFusion.Scheduling for Silverlight is a software component that can be used to present calendars and timetables to users and let them edit the schedule information interactively. It is implemented as a Silverlight UserControl and can be easily integrated into any application targeting the Silverlight platform. By providing your software with ready to use capabilities for visualizing and editing schedule data, MindFusion.Scheduling for Silverlight saves you from hundreds of hours of coding and debugging efforts.

MindFusion.Scheduling for Silverlight can display a schedule in several view types, such as:

  • Range of months, displaying several months in a grid, each of the months displaying its days in a smaller grid;
  • Single month view, displaying the days of a month and allowing scrolling to previous or next month;
  • Range of weeks, displaying days in a grid in which the days of a week occupy a single row;
  • List view, displaying a single day on each row or column;
  • Timetable view, displaying the allotment of resources to distinct hours of a day; the columns of this view can be grouped by location, task or contact;
© 2010


General Information

The MindFusion.Scheduling for Silverlight control

  • Redistribution is royalty free
  • Assembly is strong-named
  • Is digitally signed
  • Can be purchased with source code
  • Is written in C#

The Schedule component

  • Allows definition of custom-typed events and resources
  • Supports recurring events
  • Can be persisted into XML documents

Views

  • Timetable view
  • List view
  • Month view
  • WeekRange view
  • MonthRange view
  • Resource view

User interaction

  • In-place item editing
  • Interactive item creation and modification
  • Single and multiple item selection
  • Scrolling
  • Automatic scrolling while dragging items with the mouse
  • Moving to the next / previous day, month or year in various views

Programming

  • Programmatic access to both schedule objects and the calendar methods and properties
  • Numerous properties for customizing the appearance and behavior of every calendar view
  • Rich event set
  • Hundreds classes, methods, properties and events

Appearance

  • Template-based item appearance
  • Fully customizable style-based appearance
  • Customizable fonts, colors, effects and alignments of displayed text
  • Header, item and text effects
  • Rich choice of pen and brush styles
  • Themes


What's New in this Release

The list below describes recent changes and additions to MindFusion.Scheduling for Silverlight:

New in Version 2.2

Undo/Redo support

If the UndoEnabled property is set to true, MindFusion.Scheduling for Silverlight tracks changes done on the schedule and allows undoing and redoing them later by calling the Undo and Redo methods of the Schedule class respectively. Multiple changes could be recorded as a single undoable operation by enclosing them between StartCompositeOperation and CommitCompositeOperation calls. It is also possible to create custom undoable operations by deriving from the Command class and calling ExecuteCommand with the custom command as argument.


Version History

The list below describes recent changes and additions to MindFusion.Scheduling for Silverlight:

New in Version 2.1.1

Visual Studio 2010 Support

New assemblies targeting the 4.0 .NET Framework are now available. Additionally all samples provide versions for Visual Studio 2010.

Miscellaneous

  • The new ShowSelectionToolTips and SelectionToolTipFormat properties can now be used to enable tooltips on the selected time intervals.
  • ResourceViewBottomTimelineClick, ResourceViewMiddleTimelineClick and ResourceViewTopTimelineClick events added to Calendar.
  • OldStartTime, OldEndTime, OldListLane and OldResources properties added to ItemModifyConfirmEventArgs.
  • Several EnsureVisible overloads added to Calendar.

New in Version 2.1

Customizable Cell Templates

The cells in the various views can now be customized through Silverlight control templates. This is achieved through the new CellPresenter class. For an example on how to do this take a look at the two new samples - CustomResourceCells and Holidays.

Miscellaneous

  • The GroupType and CurrentView properties of Calendar are now dependency properties.
  • Improved support for Visual Studio 2010.
  • Several properties which did not work as expected have been fixed.
  • Various other bug fixes.

New in Version 2.0

Resource View

The Resource view is now available in MindFusion.Scheduling for Silverlight. This view displays the distribution of items over a period of time for particular contacts, locations, tasks or resources. The view can be activated by setting the CurrentView property of the Calendar class to ResourceView. For more information about the view, check Resource View. For additional information on how to set up the view, refer to the ResourceViewSettings class. Many new samples illustrating how to use the resource view in different scenarios have been added.

Customizable Item Templates

The appointments in the calendar are reimplemented through Silverlight control templates and can now be completely reskinned with custom templates. This is achieved through the newly introduced ItemPresenter class. For additional information on how to do this, check Customizing the Appearance of Items. Also take a look at the new tutorial Tutorial 5: Custom Item Templates and the new sample - CustomItemTemplates.

Miscellaneous

  • The new methods SetItemTooltip and GetItemTooltip in the Calendar class can be used to associate string tooltips with appointments.
  • The GetDateAt methods can now be used to hit-test for the date at the specified point in the control.


Programming Interface Overview

The MindFusion.Scheduling for Silverlight API is divided in two major parts, implemented in different .NET namespaces. The schedule data is represented by instances of the Schedule class and the helper Appointment, Task, Location, Contact and Resource classes, implemented in the MindFusion.Scheduling namespace. The calendar views are implemented by the Calendar class in the MindFusion.Scheduling.Silverlight namespace.


The Schedule

The Schedule class represents the data displayed by MindFusion.Scheduling for Silverlight calendar views. The schedule contains a collection of schedule items defined by the Item abstract class and implemented by the Appointment class. Appointment objects contain references to instances of the miscellaneous Task, Location, Contact and Resource classes, which are also contained in the respective collection members of the Schedule class.

If your application has to process other types of schedule data items, create a class for each item type and inherit it from Item or Appointment. All methods and properties defined in Item are abstract, so if a class inherits from it, that class must implement all members of the Item class. On the other hand, if a class derives from Appointment, it can just add its own distinct properties and override the SaveTo and LoadFrom methods to implement serialization of the new members of the class. Custom schedule item classes must be registered for serialization via the RegisterItemClass method of the Schedule.


Schedule Items

Events scheduled to occur at an appointed time are represented in MindFusion.Scheduling for Silverlight by the abstract class Item. Item comprises the information that should be defined for all schedule events. For example, the StartTime and EndTime properties specify the time and duration of an event. The Recurrence property lets you create recurrent events that occur repeatedly following some recurrence pattern. There are several descriptive properties that define additional information about an item, such as Priority, HeaderText and DescriptionText. The class also defines methods that support serialization in XML.

It is possible to associate resources with scheduled events via the Resources, Contacts, Location and Task properties of Item. These properties contain objects from the Resource, Contact, Location and Task classes respectively.

The appearance of items when viewed in the Calendar can be set via the ItemSettings property. It lets you define the color, alignment and style of various elements of the item visualization, such as frame lines, fill, header and description texts, icon images, and so on.

The abstract class Item is derived by the concrete class Appointment, which can be readily used in your applications. You could also define your own event class, which derives either from Appointment or Item. In order to integrate your custom class into the calendar API and user interface, you must do the following:

  • Provide parameterless constructor to let users create items of the custom class interactively;
  • Override the SaveTo / LoadFrom methods if you have any additional data fields in your custom class and register the class for serialization using the Schedule.RegisterItemClass method;
  • Override CopyOccurrence to support recurrence of the custom item. Also ensure you call MarkException on the associated recurrence whenever a custom property of the new item changes.


Recurrence

Schedule items can recur in time, following a specific recurrence pattern. For example an event could be set to occur each Monday, on the third day of each month, and so on. Assign a Recurrence object to item's Recurrence property to specify the time period, pattern, and other properties for the repetition of that item in time.

Once a recurrent item is added to the Schedule of a Calendar instance, the calendar creates multiple occurrences of the item in the time period being visualized. Occasionally you will get references to these occurrences passed as arguments to the calendar events or returned by the calendar methods. Occurrences are instances of the same class as of the item that was set recurrent, however their RecurrenceState property is set to Occurrence. If a user moves a recurrent event's occurrence in the calendar, thus changing its start or end time, or changes the occurrence text, an exception is created. Exceptions are item instances whose RecurrenceState is set to Exception.


Resources

MindFusion.Scheduling for Silverlight lets you associate resources with scheduled events via the Resources, Contacts, Location and Task properties of Item objects. These properties contain objects from the Resource, Contact, Location and Task classes respectively. If you need to assign a resource to schedule items, you must also add the resource to the appropriate collection in the Schedule class, namely Resources, Contacts, Locations or Tasks.

The timetable, week range and list views let you display distinct rows or columns for selected resources and to group items by their associated resources. To enable that, add the resources of interest to the appropriate resource collection of the Calendar object (that is, ItemResources, ItemContacts, ItemLocations and ItemTasks respectively) and set the Calendar.GroupType property to the appropriate value.

The class Resource is the base class of Contact, Location and Task. It defines an Id property, which must be unique among all resources in the schedule, and a pair of SaveTo and LoadFrom methods, which implement serialization.

You can define custom resources by deriving from Resource or from any of the Resource-derived classes. Custom resources are added to the schedule by adding them to the Calendar.Schedule.Resources collection. In order to enable serialization of custom resources, you have to provide a parameterless constructor and override the SaveTo / LoadFrom methods in the custom resource class. In addition you must register that class by calling Schedule.RegisterResourceClass before any deserialization code takes place.


Serializing the Schedule

The SaveTo and LoadFrom methods of the Schedule class let you save and load complete schedules to/from XML documents.

The serialization methods of the Schedule work by invoking the SaveTo and LoadFrom methods of the Item and Resource classes or the classes derived from them. If you define your own Item or Resource-derived classes, you must override the SaveTo and LoadFrom methods and register the classes for serialization by calling the RegisterItemClass and RegisterResourceClass methods of the Schedule.


Calendar and Timetable Views

The Calendar class implements several types of views that can be enabled by setting the calendar's CurrentView property. These views provide different outlooks over the schedule data and allow for different user interaction behavior. By changing the views from more general ones to more specialized ones, your application can implement drilling down through the schedule data. At this time MindFusion.Scheduling for Silverlight supports the following views:

  • The Month Range View displays a range of months or years.
  • The Single Month View displays a single month and lets the user scroll to the previous or next month.
  • The Week Range View displays a grid in which the days of a week occupy a single row.
  • The List View displays a list of cells where each cell represents an arbitrary time interval, such as second, minute, hour, and so on.
  • The Timetable View displays the allotment of resources to distinct hours of a day; the columns of this view can be grouped by location, task, contact or resource.


Month Range View

The Month Range view displays an arbitrary long sequence of months arranged in rows and columns. Each month represents a grid of day cells, each of which displays the day number and the schedule events set to occur on its respective date. The months in the view can be scrolled back or forth in time by an arbitrary interval using the navigation buttons in the view header.

In order to enable the Month Range view, set the CurrentView property of the Calendar class to MonthRange. Use the MonthRangeSettings and the MonthSettings properties of the Calendar class to adjust the appearance of the view. The ItemSettings property affects how schedule items will be displayed.


Single Month View

The Single Month view displays a single month and lets the user scroll to the previous or next month or the previous or next year by using the navigation buttons optionally displayed in the view header. The month represents a grid of day cells, which display the day number and the schedule events set to occur on the specific date.

In order to enable the Single Month view, set the CurrentView property of the Calendar class to SingleMonth. Use the MonthSettings property of the Calendar class to set the appearance of the view. The CalendarStyle property of the associated DaySettings object specifies a common appearance style to be used for all cells in the view. The ItemSettings property affects how schedule items will be displayed.


Week Range View

This Week Range view displays a range of weeks. Each week occupies a whole row or column whose cells represent days. The day cells display the day name or number according to the GeneralFormat, FirstDayOfMonthFormat and FirstDayOfYearFormat properties of the associated CellSettings, and the schedule items set to occur on the corresponding date.

In order to enable the Week Range view, set the CurrentView property of the Calendar class to WeekRange. Use the WeekRangeSettings property of the Calendar class to adjust the appearance of the view. The ItemSettings property lets you specify how schedule items should be displayed.


List View

Set the CurrentView property of the Calendar class to List to select the list view. This view displays several rows or columns where each row or column represents a single second, minute, hour, day, week, month or year. The day cells display the represented time in a user-specified format to the GeneralFormat, FirstDayOfMonthFormat and FirstDayOfYearFormat properties of the associated CellSettings, and the schedule items set to occur on the corresponding date.

Use the ListViewSettings property of the of the Calendar class to set the appearance of the list view. The CalendarStyle property of the associated CellSettings specifies a common appearance style to be used for all cells in the view. The ItemSettings property lets you specify how schedule items should be displayed.


Timetable View

Set the CurrentView property of the Calendar class to Timetable to select the timetable view. This view displays the allotment of resources to distinct hours of a day; the columns in this view represent dates, tasks, locations, contacts or resources. The columns can be grouped by location, task, contact or resource. Each row represents an hour or a custom time interval. The cells in the view display information about the schedule items allocated to the task, contact, location or resource for the specific time interval.

Use the TimetableSettings property of the Calendar class to set the appearance of the timetable view. The CalendarStyle property specifies a common appearance style for all cells in the view, while the WorkTimeCellStyle property defines the style of cells in the work time interval. The ItemSettings property lets you specify how schedule items should be displayed.


Resource View

Set the CurrentView property of the Calendar class to ResourceView to select the resource view. This view displays the distribution of items over a period of time for particular contacts, locations, tasks or resources. The view displays a single row for each individual contact, location, task or resource and up to three timelines. In order to view associated items in this view, the GroupType property of the Calendar must be set to GroupByContacts, GroupByLocations, GroupByTasks or GroupByResources.

Use the ResourceViewSettings property of the Calendar class to set the appearance of the resource view. The CalendarStyle property specifies a common appearance style for all cells in the view and the WeekendStyle property specifies the style of weekend cells. The ItemSettings property lets you specify how schedule items should be displayed.

For more information about the resource view settings, see the ResourceViewSettings class.


Grouping

Views that can be grouped: Timetable / Week Range / List / Resource. The other views do not support grouping.

In order to enable grouping the following steps should be done:

  • The resources should be created and added to the appropriate collection in the schedule: Calendar.Schedule.Contacts for contacts, Calendar.Schedule.Locations for locations, Calendar.Schedule.Tasks for tasks and Calendar.Schedule.Resources for general and custom resources.
  • The selected resources by which to group should be added to the appropriate collection in the control: Calendar.ItemContacts for contacts, and so on. The selected resources are a subset of all resources defined in the schedule.
  • The Calendar.GroupType should be set to the appropriate value, for example GroupType.GroupByContacts to group by contacts.

The following code illustrates how to enable grouping by contacts:

C# [image] Copy Code

// Define two contacts to group by
Contact c1 = new Contact();
c1.FirstName = "John";

Contact c2 = new Contact();
c2.FirstName = "Jack";

// Add the contacts to the schedule
calendar.Schedule.Contacts.Add(c1);
calendar.Schedule.Contacts.Add(c2);

// Select these contacts for grouping by adding them to
// the appropriate Calendar collection
calendar.ItemContacts.Add(c1);
calendar.ItemContacts.Add(c2);

// Enable grouping by contacts
calendar.GroupType = GroupType.GroupByContacts;

Visual Basic [image] Copy Code

' Define two contacts to group by
Dim c1 As New Contact()
c1.FirstName = "John"

Dim c2 As New Contact()
c2.FirstName = "Jack"

' Add the contacts to the schedule
calendar.Schedule.Contacts.Add(c1)
calendar.Schedule.Contacts.Add(c2)

' Select these contacts for grouping by adding them to
' the appropriate Calendar collection
calendar.ItemContacts.Add(c1)
calendar.ItemContacts.Add(c2)

' Enable grouping by contacts
calendar.GroupType = GroupType.GroupByContacts

The text displayed in the header of the corresponding resource depends on the type of the resource and is as follows:

  • A string formatted according to Calendar.ContactNameFormat for contacts.
  • The Resource.Name for general and custom resources, and locations.
  • The Task.Subject for tasks.

Grouping and Appearance

  • In timetable view each column (or row in a horizontal view) that represents a day is additionally subdivided to the number of grouped resources. For example if there are 3 resources selected to group by, each day column in the view is subdivided to 3 columns. The sub-columns represent individual resources and contain only the items specific for them. The sub-columns have headers containing the resource text. The header of the day column is displayed above the headers of its underlying resource columns.
  • The week range view displays a separate view for grouped resources. For example if there are two resources, two views are displayed alongside, each of which contains the items associated with its corresponding resource.


Customizing Appearance

The following topics are contained within this topic:

Styles and Themes
Information about the visualization styles and themes available in MindFusion.Scheduling for Silverlight.

Customizing the Appearance of Views
Information on how to modify the appearance of various MindFusion.Scheduling for Silverlight views.

Customizing the Appearance of Items
Information on how to modify the appearance of items in MindFusion.Scheduling for Silverlight.


Styles and Themes

A CalendarStyle is a set of appearance attributes, such as colors, brushes and margins that can be applied to schedule items or calendar view cells as an integral entity. Styles support cascading propagation of attributes up through the visualization hierarchy. Attributes defined in more specific styles override the attributes defined in more general styles. If a style leaves some attribute values undefined, the ones specified in a more general style or in the current theme are used. For example, the style associated with an item (through Calendar.SetItemStyle) cascades to ItemSettings.CalendarStyle, which cascades to the corresponding property in the current theme. If a property in the item's style is defined, it will be used. Otherwise the style system will take the value of this property from ItemSettings.CalendarStyle. If the property is not present there too, the value will be taken from the current theme. A property is considered undefined if its value is set to null (Nothing in Visual Basic).

Themes are complete sets of styles and attributes that can be applied to the calendar and its views. The themes contain values for all properties in the MonthSettings, TimetableSettings, ListViewSettings, and so on, defining the appearance of the various calendar views. MindFusion.Scheduling for Silverlight comes with several predefined themes: Standard, Windows2003, Silver, Lila and Vista. Use the Calendar.Theme property to apply a specific theme.

The following table illustrates how various views would look like when particular appearance theme is applied to them.

 | Standard | Windows2003 | Lila | Silver | Vista
List View |  |  |  |  |
Week Range |  |  |  |  |
Month Range |  |  |  |  |
Timetable |  |  |  |  |


Customizing the Appearance of Views

The appearance of individual calendar views depends on the settings corresponding to them. For example the appearance of the list view is controlled by the Calendar.ListViewSettings property, while the appearance of the timetable view is controlled by the Calendar.TimetableSettings property, and so on. The month range view is an exception to this rule since it depends on both Calendar.MonthSettings and Calendar.MonthRangeSettings properties.

The settings object defines styles for various elements of the view. Most settings contain properties, which let you change the size and number of elements (such as columns, rows, headers, and so on) contained in the view. There are usually properties that control the padding and margin of various elements and properties that define the format of the text displayed in the view.


Customizing the Cell Template

The following topics are discussed in more details:

Cell Presenters
Provides information about the cell presenters and how they are used to visualize view cells in the control.

The Default Cell Template
Lists the complete XAML code of the default cell template.

Creating New Cell Template
Demonstrates how to create a new cell template.

Creating New Cell Presenter
Demonstrates how to create a new cell presenter and what are the benefits from this.


Cell Presenters

The cell presenters are objects of the CellPresenter class (or a class derived from CellPresenter) which are used to define the visual presentation of view cells in the Calendar control. Using a separate object for presentation provides abstraction between the logical views and the displaying control (Calendar). The same presentation pattern is used for the items as described in Customizing the Item Template.

The CellPresenter objects are instantiated by the Calendar control when a view is being constructed or rebuilt. A special pair of events is raised every time a presenter is being created - CellPresenterCreating and CellPresenterCreated. The first event is raised before the presenter is created. It allows the client to create presenters of a custom CellPresenter-derived class. The second event is raised after the presenter is created and initialized. It can be used to supply custom style to the presenter.

The CellPresenter class provides several properties, which can be bound to from within the control template. StyleKeyComplex, StyleKeyWithHeader and StyleKeyToday are probably the most important properties as they define the control template that should be used for the presenter.

The complete XAML code of the default cell template can be found here. For information on how to create custom templates, check Creating New Cell Template. It is also possible to create custom cell presenters. For information about this, check Creating New Cell Presenter.


The Default Cell Template

Below is the complete XAML code of the default style of the cell presenter.

XAML [image] Copy Code

<Style TargetType="local:CellPresenter" x:Key="SimpleCellStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:CellPresenter">

<Border
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
BorderBrush="{Binding CellStyle.BorderBrush}"
BorderThickness="{Binding CellStyle.BorderThickness}"
Background="{Binding Background}"
Margin="{Binding CellStyle.Margin}" />

</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:CellPresenter" x:Key="TodayCellStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:CellPresenter">

<Border
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
BorderThickness="{Binding CellStyle.BorderThickness}"
Margin="{Binding CellStyle.Margin}"
Padding="{Binding CellStyle.ContentMargin}">
<Border
BorderBrush="{Binding CellSettings.TodayBrush}"
BorderThickness="{Binding CellHeaderStyle.BorderThickness}"
Background="{Binding CellSettings.TodayFillBrush}"
Margin="{Binding CellHeaderStyle.Margin}"
Width="{Binding HeaderWidth}"
Height="{Binding HeaderHeight}"
VerticalAlignment="{Binding HeaderVerticalAlignment}"
HorizontalAlignment="{Binding HeaderHorizontalAlignment}" />
</Border>

</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:CellPresenter" x:Key="WithHeaderCellStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:CellPresenter">

<Border
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
BorderBrush="{Binding CellStyle.BorderBrush}"
BorderThickness="{Binding CellStyle.BorderThickness}"
Background="{Binding Background}"
Margin="{Binding CellStyle.Margin}"
Padding="{Binding CellStyle.ContentMargin}">
<Border
BorderBrush="{Binding CellHeaderStyle.BorderBrush}"
BorderThickness="{Binding CellHeaderStyle.BorderThickness}"
Background="{Binding CellHeaderStyle.Background}"
Margin="{Binding CellHeaderStyle.Margin}"
Width="{Binding HeaderWidth}"
Height="{Binding HeaderHeight}"
VerticalAlignment="{Binding HeaderVerticalAlignment}"
HorizontalAlignment="{Binding HeaderHorizontalAlignment}">
<TextBlock
FontFamily="{Binding CellHeaderStyle.FontFamily}"
FontSize="{Binding CellHeaderStyle.FontSize}"
FontStretch="{Binding CellHeaderStyle.FontStretch}"
FontStyle="{Binding CellHeaderStyle.FontStyle}"
FontWeight="{Binding CellHeaderStyle.FontWeight}"
Foreground="{Binding CellHeaderStyle.Foreground}"
TextAlignment="{Binding CellHeaderStyle.TextAlignment}"
VerticalAlignment="{Binding CellHeaderStyle.VerticalAlignment}"
HorizontalAlignment="{Binding CellHeaderStyle.HorizontalAlignment}"
Margin="{Binding CellHeaderStyle.ContentMargin}"
Text="{Binding HeaderText}">
</TextBlock>
</Border>
</Border>

</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The local namespace is defined as follows:

XAML [image] Copy Code

xmlns:local="clr-namespace:MindFusion.Scheduling.Silverlight"

As can be seen in the above XAML, there are several styles supplying different control templates for the cells in different views. For example, the first style supplies the template of cells in the Resource and Timetable views. Those are the cells without headers. The next style supplies the template of cells that can have headers. Those are the cells in the SingleMonth, MonthRange, List and WeekRange views. The last style supplies the template for the cell representing the current day.

The following table illustrates the presentation of a cell in the three different templates:

Condition | Presentation
StyleKey=Simple |
StyleKey=Today |
StyleKey=WithHeader |


Creating New Cell Template

New cell templates are created the same way as custom control templates - by creating a new .NET Style with TargetType set to CellPresenter. The Style should provide a setter for the Template property. The following XAML snippet illustrates how.

XAML [image] Copy Code

<Style TargetType="planner:CellPresenter" x:Key="MyStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="planner:CellPresenter">
...
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The style definition needs to be placed in the application's resources (App.xaml or Application.xaml). The style needs to specify a Key which should be subsequently used to assign the style to the CellPresenter through one of its properties - StyleKeySimple, StyleKeyWithHeader and StyleKeyToday. The Default Cell Template uses this technique to provide different templates for the cells in different views. Below is an example XAML code illustrating this.

XAML [image] Copy Code

<Style TargetType="local:CellPresenter" x:Key="SimpleCellStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:CellPresenter">

<!-- The template for Timetable and Resource view cells goes here -->

</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:CellPresenter" x:Key="TodayCellStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:CellPresenter">

<!-- The template for the cell representing the current day goes here -->

</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:CellPresenter" x:Key="WithHeaderCellStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:CellPresenter">

<!-- The template for SingleMonth, MonthRange, List and WeekRange view cells goes here -->

</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

By default, the CellPresenter is initialized with the above styles as follows:

C# [image] Copy Code

StyleKeySimple = "SimpleCellStyle";
StyleKeyToday = "TodayCellStyle";
StyleKeyWithHeader = "WithHeaderCellStyle";

Visual Basic [image] Copy Code

StyleKeySimple = "SimpleCellStyle"
StyleKeyToday = "TodayCellStyle"
StyleKeyWithHeader = "WithHeaderCellStyle"

When you define one or more new styles for the presenter you need to assign their keys to the corresponding properties. A common way to do this is by handling the CellPresenterCreated event of the Calendar class. The following code illustrates how to assign a custom style (MyStyle) to newly created presenters:

C# [image] Copy Code

calendar.CellPresenterCreated += (sender, e) =>
{
e.CellPresenter.StyleKeySimple = "MyStyle";
e.CellPresenter.StyleKeyToday = "MyStyle";
e.CellPresenter.StyleKeyWithHeader = "MyStyle";
};

For more information on how to create new templates, check the DualView sample.


Creating New Cell Presenter

In certain scenarios creating a new template is not sufficient. For example the case when you want to add an interactive control, such as Button in the cell's presenter and want to attach an event handler to this button so that you can perform specific action when it is pressed. In order to implement the above scenario, you have to derive from CellPresenter and associate a custom template with the new class. For more information on how to create custom templates, check Creating New Cell Template. Somewhere within the newly created template, there will be a button definition similar to the one below.

XAML [image] Copy Code

<Button x:Name="myButton" />

It is important to name the button so that it can be accessed in the template class.

The definition of the custom presenter class will look similar to the following.

C# [image] Copy Code

class MyPresenter : CellPresenter
{
public MyPresenter(Calendar calendar)
: base(calendar)
{
this.DefaultStyleKey = typeof(MyPresenter);
}
}

Visual Basic [image] Copy Code

Class MyPresenter
Inherits CellPresenter

Public Sub New(ByVal calendar As Calendar)
MyBase.New(calendar)

Me.DefaultStyleKey = GetType(MyPresenter)

End Sub

End Class

In order to attach an event handler to the button myButton, you have to override the OnApplyTemplate method, obtain a reference to the button through the GetTemplateChild method and attach an event handler to the button's Click event. Make sure to call the method of the base class in the OnApplyTemplate override. The following code illustrates how.

C# [image] Copy Code

public override void OnApplyTemplate()
{
base.OnApplyTemplate();

Button myButton = GetTemplateChild("myButton") as Button;
if (myButton != null)
myButton.Click += OnMyButtonClick;
}

...

void OnMyButtonClick(object sender, RoutedEventArgs e)
{
// Perform the necessary actions here
}

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate()

MyBase.OnApplyTemplate()

Dim myButton As Button = CType(GetTemplateChild("myButton"), Button)
If Not myButton Is Nothing Then
AddHandler myButton.Click, AddressOf OnMyButtonClick
End If

End Sub

...

Sub OnMyButtonClick(ByVal sender As Object, ByVal e As RoutedEventArgs)

' Perform the necessary actions here

End Sub

Now that the custom presenter and its template are ready, the presenter has to be associated with a cell. This can be done in the CellPresenterCreating event handler of the Calendar class.

C# [image] Copy Code

private void calendar_CellPresenterCreating(object sender, CellPresenterCreatingEventArgs e)
{
e.CellPresenter = new MyPresenter(calendar);
}

Visual Basic [image] Copy Code

Private Sub calendar_CellPresenterCreating(ByVal sender As Object, ByVal e As CellPresenterCreatingEventArgs)

e.CellPresenter = New HolidayPresenter(calendar)

End If

For an extensive example on how to create custom cell presenters, check the new Holidays sample.


Customizing the Appearance of Items

There are several ways to customize the appearance of items in MindFusion.Scheduling for Silverlight.

Customizing the Item Settings
Provides information on how to modify the appearance of items through the ItemSettings object exposed by the Calendar class.

Customizing the Item Styles
Illustrates how to modify the appearance of items in the Calendar using CalendarStyle objects.

Customizing the Item Template
Demonstrates how to replace the default item template and how to create custom item presenters.


Customizing the Item Settings

The most common way to customize the appearance of items in MindFusion.Scheduling for Silverlight is by setting various properties in Calendar.ItemSettings. This would affect the appearance of all items in the control. For example ItemsVisible specifies whether to display the items, Size and HeaderSize define the dimensions of the item and its header and so on. Four properties in the ItemSettings class are particularly interesting - CalendarStyle, SelectedItemStyle, PointedItemStyle and PointedSelectedItemStyle. These properties define various aspects in the visualization of the items depending on their current state - normal, selected, hovered with the mouse and selected and hovered at the same time. For example SelectedItemStyle defines settings for items which are selected but not hovered with the mouse.

For more information on the item styles and how to assign specific styles to individual items, see Customizing the Item Styles.


Customizing the Item Styles

As described in Customizing the Item Settings, the appearance of each item is controlled through four CalendarStyle objects - one for each state of the item (normal, selected, pointed, and pointed and selected). The default four styles for all items can be found in the ItemSettings object returned by the Calendar.ItemSettings property.

To customize the appearance of an individual item, associate a CalendarStyle objects with it by calling one of the following Calendar methods: SetItemStyle, SetSelectedItemStyle, SetPointedItemStyle and SetPointedSelectedItemStyle properties. The particular style that will be used when the item is rendered depends on the state of the item. The style set through SetItemStyle is used when the item is neither selected nor the mouse hovers over it. The style set through SetSelectedItemStyle is used when the item is selected and the mouse is not over it. The style set through SetPointedItemStyle is used when the mouse is over a non-selected item and, finally, the style set through SetPointedSelectedItemStyle is used when the item is selected and the mouse is over it at the same time. The "pointed item" styles are considered extended styles and are only used if ItemSettings.UseExtendedStyles is set to true. The item styles support the cascading paradigm described in Styles and Themes. The most general item styles are defined in the current theme. They cannot be changed by any means except by changing the theme itself. The styles defined in Calendar.ItemSettings are of higher priority and any of their properties that are explicitly specified will be used prior those from the theme. The styles defined for individual items are of highest priority and will always be used first, when present.

The following code defines a sample Calendar control in XAML:

XAML [image] Copy Code

<planner:Calendar x:Name="calendar" Theme="Vista" Date="1, 1, 2010" />

Create two items and add them to the above control using the following code:

C# [image] Copy Code

Appointment a = new Appointment();
a.StartTime = new DateTime(2010, 1, 1);
a.EndTime = new DateTime(2010, 1, 2);
a.HeaderText = "a";
calendar.Schedule.Items.Add(a);

Appointment b = new Appointment();
b.StartTime = new DateTime(2010, 1, 3);
b.EndTime = new DateTime(2010, 1, 4);
b.HeaderText = "b";
calendar.Schedule.Items.Add(b);

Visual Basic [image] Copy Code

Dim a As New Appointment()
a.StartTime = New DateTime(2010, 1, 1)
a.EndTime = New DateTime(2010, 1, 2)
a.HeaderText = "a"
calendar.Schedule.Items.Add(a)

Dim b As New Appointment()
b.StartTime = New DateTime(2010, 1, 3)
b.EndTime = New DateTime(2010, 1, 4)
b.HeaderText = "b"
calendar.Schedule.Items.Add(b)

Specify a custom brush for the text of both items.

C# [image] Copy Code

CalendarStyle style = new CalendarStyle();
style.Foreground = Brushes.Orange;
calendar.ItemSettings.CalendarStyle = style;

Visual Basic [image] Copy Code

Dim style As New CalendarStyle()
style.Foreground = Brushes.Orange
calendar.ItemSettings.CalendarStyle = style

Running the code at this point will display both items with text colored in Orange. It is also noticeable that the rest of the visualization properties are not modified since they were not set explicitly in the custom style and are therefore obtained from the current theme.

Now define a custom background for item a using the following code:

C# [image] Copy Code

CalendarStyle aStyle = new CalendarStyle();
aStyle.Background = Brushes.Blue;
calendar.SetItemStyle(a, aStyle);

Visual Basic [image] Copy Code

Dim aStyle As New CalendarStyle()
aStyle.Background = Brushes.Blue
calendar.SetItemStyle(a, aStyle)

The code above will change the background of a, while the background of b will be left intact.


Customizing the Item Template

The following topics are discussed in more details:

Item Presenters
Provides information about the item presenters and how they are used to visualize items in the control.

The Default Item Template
Lists the complete XAML code of the default item template.

Creating New Item Template
Demonstrates how to create a new item template.

Creating New Item Presenter
Demonstrates how to create a new item presenter and what are the benefits from this.


Item Presenters

The item presenters are objects of the ItemPresenter class (or a class derived from ItemPresenter) which are used to define the visual presentation of items in the Calendar control. Using a separate object for presentation provides abstraction between the data (Item) and the displaying control (Calendar). This abstraction brings several notable benefits.

  • The appearance of the items in a Calendar control can be customized without modifying the Item class. To do this a new style with a setter for the control's Template has to be defined for the ItemPresenter class.
  • The same schedule can be displayed in several Calendar controls simultaneously.
  • Different presenters can be used for the same items in different Calendar controls, or for different items in the same Calendar control.

The ItemPresenter objects are instantiated by the Calendar control when an item needs to be displayed. A special event is raised every time a presenter is created - ItemPresenterCreated. It is possible that several presenters are created for a single item. For example, consider the case when an item wraps across several rows in a SingleMonth or WeekRange views.

The ItemPresenter class provides several properties, which can be bound to from within the control template. StyleKeyComplex, StyleKeySimpleHorizontal and StyleKeySimpleVertical are probably the most important properties as they define the control template that should be used for the presenter.

The complete XAML code of the default item template can be found here. For information on how to create custom templates, check Creating New Item Template. It is also possible to create custom item presenters. For information about this, check Creating New Item Presenter.


The Default Item Template

Below is the complete XAML code of the default styles of the item presenter.

XAML [image] Copy Code

<Style TargetType="local:ItemPresenter" x:Key="ComplexItemStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ItemPresenter">
<local:ResizeBands
Orientation="{TemplateBinding Orientation}"
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
ItemSettings="{TemplateBinding ItemSettings}"
ResizeBandsVisible="{TemplateBinding Selected}">
<local:SideBorders>
<Border Background="{Binding ItemStyle.Background}">
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto" />
<ColumnDefinition />
</Grid.ColumnDefinitions>
<StackPanel Orientation="Vertical">
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/Recurrence.png"
Visibility="{Binding RecurrenceIconVisibility}" Margin="1" />
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/RecurrenceEx.png"
Visibility="{Binding RecurrenceExceptionIconVisibility}" Margin="1" />
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/Reminder.png"
Visibility="{Binding ReminderIconVisibility}" Margin="1" />
</StackPanel>
<StackPanel Grid.Column="1" Orientation="Vertical">
<Border
BorderBrush="{Binding ItemStyle.LineBrush}"
BorderThickness="0,0,0,1"
Height="{Binding ItemSettings.HeaderSize}"
Margin="6,0,6,0">
<TextBlock x:Name="HeaderBlock"
TextWrapping="Wrap"
Text="{Binding Item.HeaderText, RelativeSource={RelativeSource TemplatedParent}}"
DataContext="{TemplateBinding ItemStyle}"
Foreground="{Binding Foreground}"
TextAlignment="{Binding TextAlignment}"
VerticalAlignment="{Binding VerticalAlignment}"
FontFamily="{Binding FontFamily}"
FontSize="{Binding FontSize}"
FontStretch="{Binding FontStretch}"
FontStyle="{Binding FontStyle}"
FontWeight="{Binding FontWeight}" />
</Border>
<TextBlock
DataContext="{TemplateBinding Item}"
TextWrapping="Wrap" Text="{Binding DescriptionText}"
Margin="5,1,1,1" Grid.Column="1" Grid.Row="1" />
</StackPanel>
</Grid>
</Border>
</local:SideBorders>
</local:ResizeBands>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:ItemPresenter" x:Key="SimpleItemHorizontalStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ItemPresenter">
<Grid
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
Background="{Binding ItemStyle.Background}">
<local:SideBorders>
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto" />
<ColumnDefinition Width="Auto" />
<ColumnDefinition />
<ColumnDefinition Width="Auto" />
</Grid.ColumnDefinitions>
<Image Grid.Column="0"
Visibility="{TemplateBinding StartArrowImageVisibility}"
HorizontalAlignment="Center" VerticalAlignment="Center" Stretch="None" Margin="1"
Source="/MindFusion.Scheduling.Silverlight;component/Resources/ArrowLeft.png" />
<StackPanel Orientation="Horizontal" Grid.Column="1">
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/Recurrence.png"
Visibility="{Binding RecurrenceIconVisibility}" Stretch="None" Margin="1" />
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/RecurrenceEx.png"
Visibility="{Binding RecurrenceExceptionIconVisibility}" Stretch="None" Margin="1" />
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/Reminder.png"
Visibility="{Binding ReminderIconVisibility}" Stretch="None" Margin="1" />
</StackPanel>
<TextBlock x:Name="HeaderBlock" Grid.Column="2"
TextWrapping="Wrap"
Text="{Binding Item.HeaderText, RelativeSource={RelativeSource TemplatedParent}}"
DataContext="{TemplateBinding ItemStyle}"
Foreground="{Binding Foreground}"
TextAlignment="{Binding TextAlignment}"
VerticalAlignment="{Binding VerticalAlignment}"
FontFamily="{Binding FontFamily}"
FontSize="{Binding FontSize}"
FontStretch="{Binding FontStretch}"
FontStyle="{Binding FontStyle}"
FontWeight="{Binding FontWeight}" />
<Image Grid.Column="3"
Visibility="{TemplateBinding EndArrowImageVisibility}"
HorizontalAlignment="Center" VerticalAlignment="Center" Stretch="None" Margin="1"
Source="/MindFusion.Scheduling.Silverlight;component/Resources/ArrowRight.png" />
</Grid>
</local:SideBorders>
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:ItemPresenter" x:Key="SimpleItemVerticalStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ItemPresenter">
<Grid
DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
Background="{Binding ItemStyle.Background}">
<local:SideBorders>
<Grid>
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
<RowDefinition Height="Auto" />
<RowDefinition />
<RowDefinition Height="Auto" />
</Grid.RowDefinitions>
<Image Grid.Row="0"
Visibility="{TemplateBinding StartArrowImageVisibility}"
HorizontalAlignment="Center" VerticalAlignment="Center" Stretch="None" Margin="1"
Source="/MindFusion.Scheduling.Silverlight;component/Resources/ArrowUp.png" />
<StackPanel Orientation="Vertical" Grid.Row="1">
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/Recurrence.png"
Visibility="{Binding RecurrenceIconVisibility}" Stretch="None" Margin="1" />
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/RecurrenceEx.png"
Visibility="{Binding RecurrenceExceptionIconVisibility}" Stretch="None" Margin="1" />
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/Reminder.png"
Visibility="{Binding ReminderIconVisibility}" Stretch="None" Margin="1" />
</StackPanel>
<TextBlock Grid.Row="2"
TextWrapping="Wrap"
Text="{Binding Item.HeaderText, RelativeSource={RelativeSource TemplatedParent}}"
DataContext="{TemplateBinding ItemStyle}"
Foreground="{Binding Foreground}"
TextAlignment="{Binding TextAlignment}"
VerticalAlignment="{Binding VerticalAlignment}"
FontFamily="{Binding FontFamily}"
FontSize="{Binding FontSize}"
FontStretch="{Binding FontStretch}"
FontStyle="{Binding FontStyle}"
FontWeight="{Binding FontWeight}" />
<Image Grid.Row="3"
Visibility="{TemplateBinding EndArrowImageVisibility}"
HorizontalAlignment="Center" VerticalAlignment="Center" Stretch="None" Margin="1"
Source="/MindFusion.Scheduling.Silverlight;component/Resources/ArrowDown.png" />
</Grid>
</local:SideBorders>
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:SideBorders">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:SideBorders">
<Grid>
<Rectangle HorizontalAlignment="Left"
Width="{Binding BorderThickness.Left}"
Fill="{Binding ItemStyle.LeftBorderBrush}" />
<Rectangle VerticalAlignment="Top"
Height="{Binding BorderThickness.Top}"
Fill="{Binding ItemStyle.TopBorderBrush}" />
<Rectangle HorizontalAlignment="Right"
Width="{Binding BorderThickness.Right}"
Fill="{Binding ItemStyle.RightBorderBrush}" />
<Rectangle VerticalAlignment="Bottom"
Height="{Binding BorderThickness.Bottom}"
Fill="{Binding ItemStyle.BottomBorderBrush}" />
<Border BorderThickness="{Binding BorderThickness}">
<ContentPresenter Margin="{Binding ItemStyle.ContentMargin}" />
</Border>
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:ResizeBands" x:Key="ResizeBandsVertical">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ResizeBands">
<Grid>
<Grid.Resources>
<local:VisibleConverter x:Key="visibleConverter"/>
</Grid.Resources>
<Grid.RowDefinitions>
<RowDefinition Height="Auto"/>
<RowDefinition />
<RowDefinition Height="Auto"/>
</Grid.RowDefinitions>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto"/>
<ColumnDefinition />
</Grid.ColumnDefinitions>
<Border
Grid.ColumnSpan="2"
BorderThickness="1,1,1,0"
IsHitTestVisible="False"
Background="Transparent"
BorderBrush="Transparent"
Height="{Binding ItemSettings.ResizeBandSize}" />
<Border
Grid.ColumnSpan="2"
BorderThickness="1,1,1,0"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Height="{Binding ItemSettings.ResizeBandSize}"
Visibility="{Binding ResizeBandsVisible, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}}" />
<Border Grid.Row="1"
BorderThickness="1,1,0,1"
Width="{Binding ItemSettings.MoveBandSize}"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}" />
<Border
Grid.Row="2" Grid.ColumnSpan="2"
BorderThickness="1,0,1,1"
IsHitTestVisible="False"
Background="Transparent"
BorderBrush="Transparent"
Height="{Binding ItemSettings.ResizeBandSize}" />
<Border
Grid.Row="2" Grid.ColumnSpan="2"
BorderThickness="1,0,1,1"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Height="{Binding ItemSettings.ResizeBandSize}"
Visibility="{Binding ResizeBandsVisible, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}}" />
<ContentPresenter Grid.Column="1" Grid.Row="1" />
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:ResizeBands" x:Key="ResizeBandsHorizontal">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ResizeBands">
<Grid>
<Grid.Resources>
<local:VisibleConverter x:Key="visibleConverter"/>
</Grid.Resources>
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
<RowDefinition />
</Grid.RowDefinitions>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="Auto" />
<ColumnDefinition />
<ColumnDefinition Width="Auto" />
</Grid.ColumnDefinitions>
<Border
Grid.RowSpan="2"
BorderThickness="1,1,0,1"
IsHitTestVisible="False"
Background="Transparent"
BorderBrush="Transparent"
Width="{Binding ItemSettings.ResizeBandSize}" />
<Border
Grid.RowSpan="2"
BorderThickness="1,1,0,1"
Width="{Binding ItemSettings.ResizeBandSize}"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Visibility="{Binding ResizeBandsVisible, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}}" />
<Border
Grid.Column="1"
BorderThickness="1,1,1,0"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Height="{Binding ItemSettings.MoveBandSize}" />
<Border
Grid.Column="2" Grid.RowSpan="2"
BorderThickness="0,1,1,1"
IsHitTestVisible="False"
Background="Transparent"
BorderBrush="Transparent"
Width="{Binding ItemSettings.ResizeBandSize}" />
<Border
Grid.Column="2" Grid.RowSpan="2"
BorderThickness="0,1,1,1"
Width="{Binding ItemSettings.ResizeBandSize}"
Background="{Binding ItemStyle.FillBrush}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
Visibility="{Binding ResizeBandsVisible, RelativeSource={RelativeSource TemplatedParent}, Converter={StaticResource visibleConverter}}" />
<ContentPresenter Grid.Column="1" Grid.Row="1"/>
</Grid>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The local namespace is defined as follows:

XAML [image] Copy Code

xmlns:local="clr-namespace:MindFusion.Scheduling.Silverlight;assembly=MindFusion.Scheduling.Silverlight"

As can be seen in the above XAML, there are several styles which supply a control template for the items in different contexts. For example, the ComplexItemStyle supplies the template of the so-called complex items. Those are the items in Resource view and non all day items in Timetable view. The next style - SimpleItemHorizontalStyle - supplies the template of the so-called simple items when they are displayed horizontally. Simple items are all day items in Timetable view and the items in SingleMonth, MonthRange, List and WeekRange views. The last style - SimpleItemVerticalStyle - supplies the template for simple items, displayed vertically.

The following table illustrates the presentation of the same item in the three different contexts:

Condition | Presentation
Style=ComplexItemStyle |
Style=SimpleItemHorizontalStyle |
Style=SimpleItemVerticalStyle |

The keys of the individual styles are assigned to the respective ItemPresenter properties - StyleKeyComplex, StyleKeySimpleHorizontal and StyleKeySimpleVertical. It is completely legal to assign the same style for the three cases.

Named Elements

There is one element of particular interest in the template - HeaderBlock. This element is used when initiating item in-place editing operations in order to determine where the in-place text box should be opened. If you create a custom template and want to retain the in-place editing functionality you need to name an element HeaderBlock. Additionally you need to place this element in either grid or border parent.


Creating New Item Template

New item templates are created the same way as custom control templates - by creating a new .NET Style with TargetType set to ItemPresenter. The Style should provide a setter for the Template property. The following XAML snippet illustrates how.

XAML [image] Copy Code

<Style TargetType="planner:ItemPresenter" x:Key="MyStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="planner:ItemPresenter">
...
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The style definition needs to be placed in the application's resources (App.xaml or Application.xaml). The style needs to specify a Key which should be subsequently used to assign the style to the ItemPresenter through one of its properties - StyleKeyComplex, StyleKeySimpleHorizontal and StyleKeySimpleVertical. The Default Item Template uses this technique to provide different templates for the items in different views. Below is an example XAML code illustrating this.

XAML [image] Copy Code

<Style TargetType="local:ItemPresenter" x:Key="ComplexItemStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ItemPresenter">

<!-- The template for Timetable and Resource view items goes here -->

</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:ItemPresenter" x:Key="SimpleItemHorizontalStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ItemPresenter">

<!-- The template for horizontal SingleMonth, MonthRange, List and WeekRange view items goes here -->

</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

<Style TargetType="local:ItemPresenter" x:Key="SimpleItemVerticalStyle">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="local:ItemPresenter">

<!-- The template for vertical SingleMonth, MonthRange, List and WeekRange view items goes here -->

</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

By default, the ItemPresenter is initialized with the above styles as follows:

C# [image] Copy Code

StyleKeyComplex = "ComplexItemStyle";
StyleKeySimpleHorizontal = "SimpleItemHorizontalStyle";
StyleKeySimpleVertical = "SimpleItemVerticalStyle";

Visual Basic [image] Copy Code

StyleKeyComplex = "ComplexItemStyle"
StyleKeySimpleHorizontal = "SimpleItemHorizontalStyle"
StyleKeySimpleVertical = "SimpleItemVerticalStyle"

When you define one or more new styles for the presenter you need to assign their keys to the corresponding properties. A common way to do this is by handling the ItemPresenterCreated event of the Calendar class. The following code illustrates how to assign a custom style (MyStyle) to newly created presenters:

C# [image] Copy Code

calendar.ItemPresenterCreated += (sender, e) =>
{
e.ItemPresenter.StyleKeyComplex = "MyStyle";
e.ItemPresenter.StyleKeySimpleHorizontal = "MyStyle";
e.ItemPresenter.StyleKeySimpleVertical = "MyStyle";
};

For more information on how to create new templates, check Tutorial 5: Custom Item Templates.


Creating New Item Presenter

In certain scenarios creating a new template is not sufficient. For example the case when you want to add an interactive control, such as Button in the Item's presenter and want to attach an event handler to this button so that you can perform specific action when it is pressed. In order to implement the above scenario, you have to derive from ItemPresenter and associate a custom template with the new class. For more information on how to create custom templates, check Creating New Item Template. Somewhere within the newly created template, there will be a button definition similar to the one below.

XAML [image] Copy Code

<Button x:Name="myButton" />

It is important to name the button so that it can be accessed in the template class.

The definition of the custom presenter class will look similar to the following.

C# [image] Copy Code

class MyPresenter : ItemPresenter
{
public MyPresenter(Calendar calendar)
: base(calendar)
{
this.DefaultStyleKey = typeof(MyPresenter);
}
}

Visual Basic [image] Copy Code

Class MyPresenter
Inherits ItemPresenter

Public Sub New(ByVal calendar As Calendar)
MyBase.New(calendar)

Me.DefaultStyleKey = GetType(MyPresenter)

End Sub

End Class

In order to attach an event handler to the button myButton, you have to override the OnApplyTemplate method, obtain a reference to the button through the GetTemplateChild method and attach an event handler to the button's Click event. Make sure to call the method of the base class in the OnApplyTemplate override. The following code illustrates how.

C# [image] Copy Code

public override void OnApplyTemplate()
{
base.OnApplyTemplate();

Button myButton = GetTemplateChild("myButton") as Button;
if (myButton != null)
myButton.Click += OnMyButtonClick;
}

...

void OnMyButtonClick(object sender, RoutedEventArgs e)
{
// Perform the necessary actions here
}

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate()

MyBase.OnApplyTemplate()

Dim myButton As Button = CType(GetTemplateChild("myButton"), Button)
If Not myButton Is Nothing Then
AddHandler myButton.Click, AddressOf OnMyButtonClick
End If

End Sub

...

Sub OnMyButtonClick(ByVal sender As Object, ByVal e As RoutedEventArgs)

' Perform the necessary actions here

End Sub

Now that the custom presenter and its template are ready, you need to associate the presenter with an item. In order to do this, you have to define a new Item class and associate MyPresenter with it using the ItemPresenterAttribute. To see the new presenter in action, create an item of type MyAppointment and add it to the displayed schedule.

C# [image] Copy Code

[ItemPresenter(typeof(MyPresenter))]
public class MyAppointment : Appointment
{
public MyAppointment()
{
}

...
}

Visual Basic [image] Copy Code

<ItemPresenter(GetType(MyAppointmentPresenter))> _
Public Class MyAppointment
Inherits Appointment

Public Sub New(ByVal calendar As calendar)

End Sub

...

End Class

For an extensive example on how to create custom item presenters, check the new CustomItemTemplate sample.


MindFusion.Scheduling for Silverlight Programmer's Guide

Tutorials

© 2010


Tutorial 1: Getting Started

This tutorial will show you how to create a simple timetable application with MindFusion.Scheduling for Silverlight.

1. Create a new Silverlight application project

Select File -> New -> Project from the Visual Studio menu. In the dialog that appears, select Visual C# -> Silverlight from the tree on the left, then Silverlight Application from the list on the right. Type in the name (of your project the tutorial uses Tutorial1) and click 'OK'.

2. Add the Calendar control to the main window

Before using the Calendar control, it must be added it to the toolbox. Display the toolbox by selecting View -> Toolbox from the menu. Then select the appropriate category for the control and right-click on it. From the context menu choose 'Choose Items...'. In the "Customize Toolbox Items" dialog select the Silverlight Components tab and click the 'Browse...' button. Then navigate to the control assembly file - MindFusion.Scheduling.Silverlight.dll. This file is usually found in the 'c:\Program Files\MindFusion\MindFusion.Scheduling for Silverlight' folder or in the folder where you have installed the product. Once the dll is added to the list of components, click 'OK'. A Calendar item should appear in the selected category in the toolbox. Click on this item and drag it to the window's working area. This creates a new MindFusion.Scheduling for Silverlight Calendar control on the window.

3. Setting the control's properties

Modify the XAML code generated for the control as illustrated below:

XAML [image] Copy Code

<planner:Calendar Name="calendar" CurrentView="Timetable" Theme="Silver" />

Where the planner namespace is defined as:

XAML [image] Copy Code

xmlns:planner="clr-namespace:MindFusion.Scheduling.Silverlight;assembly=MindFusion.Scheduling.Silverlight"

The timetable view displays rows of cells corresponding to the time of the day, and the cells in each column correspond to a specific date. In order to modify various view settings through the visual designer, create a new TimetableSettings object and assign it to the TimetableSettings property of the control. Set ShowCurrentTime to true. The code which does this is displayed below:

XAML [image] Copy Code

<planner:Calendar Name="calendar" CurrentView="Timetable" Theme="Silver">
<planner:Calendar.TimetableSettings>
<planner:TimetableSettings ShowCurrentTime="True" />
</planner:Calendar.TimetableSettings>
</planner:Calendar>

An alternative way to modify the settings of the view is through code. The code equivalent the above XAML is illustrated here:

C# [image] Copy Code

calendar.TimetableSettings.ShowCurrentTime = true;

Visual Basic [image] Copy Code
calendar.TimetableSettings.ShowCurrentTime = True

Note, that when the assignment is done in code, there is no need to create and assign a new TimetableSettings object.

4. Adding more days to the Timetable

Initially the timetable displays only one day - usually the day when the control was added to the form. To change the set of displayed days, you must add few lines of code. For that purpose, double-click on the window's title bar in the designer area. This switches to source code view and automatically creates an event handler for the window's constructor. Add the following lines after the call to InitializeComponent.

C# [image] Copy Code

calendar.BeginInit();
calendar.TimetableSettings.Dates.Clear();

for (int i = 0; i < 5; i++)
{
calendar.TimetableSettings.Dates.Add(
DateTime.Today + new TimeSpan(i, 0, 0, 0));
}

calendar.EndInit();

Visual Basic [image] Copy Code

calendar.BeginInit()
calendar.TimetableSettings.Dates.Clear()

Dim i As Integer
For i = 0 To 4

calendar.TimetableSettings.Dates.Add(DateTime.Today.AddDays(i))

Next i

calendar.EndInit()

The code above adds five days to the timetable view, starting from today.

The first and last methods called above are used together to enclose code, which contains series of modifications to the calendar. BeginInit disables the internal update logic of the control, while EndInit resumes the control's normal behavior and updates its internal state to reflect all changes made since the call to BeginInit.

5. Build and run

Compile and run the application. The result should look similar to the image below.


Tutorial 2: Creating Recurrent Items

This tutorial shows how to programmatically create recurring items using MindFusion.Scheduling for Silverlight.

1. Create and initialize a new Silverlight application project

Follow steps 1 through 3 from the previous tutorial.

Set CurrentView to WeekRange, Date to Jan 1, 2010 and EndDate to Mar 1, 2010, respectively.

2. Create an appointment

Create a new appointment in the page's constructor. To create the appointment, add the following lines of code after the call to InitializeComponent.

Note

Be sure to include both MindFusion.Scheduling and MindFusion.Scheduling.Silverlight namespaces via the using (Imports in Visual Basic) keyword in the beginning of the file.

C# [image] Copy Code

Appointment app = new Appointment();
app.HeaderText = "Meet George";
app.DescriptionText = "This is a sample appointment";
app.StartTime = new DateTime(2010, 1, 10, 14, 0, 0);
app.EndTime = new DateTime(2010, 1, 10, 16, 30, 0);

calendar.Schedule.Items.Add(app);

Visual Basic [image] Copy Code

Dim app As New Appointment()
app.HeaderText = "Meet George"
app.DescriptionText = "This is a sample appointment"
app.StartTime = new DateTime(2010, 1, 10, 14, 0, 0)
app.EndTime = new DateTime(2010, 1, 10, 16, 30, 0)

calendar.Schedule.Items.Add(app)

The code above creates a new appointment on 10th of January, 2010, starting at 2:00 PM and ending at 4:30 PM.

3. Create the recurrence

Now that the appointment is added to the schedule, create a Recurrence object that defines how the appointment recurs. The following code creates and initializes a new Recurrence object and associates it with the item. Append these lines to the main page's constructor.

C# [image] Copy Code

Recurrence rec = new Recurrence();
rec.Pattern = RecurrencePattern.Weekly;
rec.DaysOfWeek = DaysOfWeek.Monday | DaysOfWeek.Wednesday;
rec.Weeks = 2;
rec.StartDate = new DateTime(2010, 1, 10);
rec.RecurrenceEnd = RecurrenceEnd.Never;

app.Recurrence = rec;

Visual Basic [image] Copy Code

Dim rec As New Recurrence()
rec.Pattern = RecurrencePattern.Weekly
rec.DaysOfWeek = DaysOfWeek.Monday + DaysOfWeek.Wednesday
rec.Weeks = 2
rec.StartDate = new DateTime(2010, 1, 10)
rec.RecurrenceEnd = RecurrenceEnd.Never

app.Recurrence = rec

This fragment creates a new recurrence object that continues infinitely and repeats the appointment on Monday and Wednesday every two weeks.

4. Build and run

Compile and run the application. The image below depicts what the application output would look like.


Tutorial 4: Creating Custom Appointment Classes

This tutorial shows how to create a custom schedule item class. For simplicity, the sample demonstrates that by inheriting a class from Appointment.

1. Create and initialize a new Silverlight application project

Follow steps 1 through 3 from Tutorial 1: Getting Started.

2. Create new class for the custom item

Select Project -> Add Class... from the menu, type the name of the custom item class in the dialog that appears (for example MyApp) and click 'OK'. Include the MindFusion.Scheduling namespace at the beginning of the file.

C# [image] Copy Code

using MindFusion.Scheduling;

Visual Basic [image] Copy Code

Imports MindFusion.Scheduling

The custom class will expose a new property of type Boolean (called Kept) that will indicate whether the appointment has been kept or cancelled. The implementation of the property is trivial. Simply add a private field of type Boolean and make the property getter setter to return the field and to set the field respectively. The following sample code illustrates this:

C# [image] Copy Code

public class MyApp : Appointment
{
public MyApp()
{
_kept = true;
}

public bool Kept
{
get { return _kept; }
set { _kept = value; }
}

private bool _kept;
}

Visual Basic [image] Copy Code

Class MyApp
Inherits Appointment

Public Sub New()

_kept = True

End Sub

Public Property Kept() As Boolean

Get
Return _kept
End Get

Set(ByVal Value As Boolean)
_kept = Value
End Set

End Property

Private _kept As Boolean

End Class

Note

You must provide constructor that takes no argument with your custom item class. MindFusion.Scheduling for Silverlight creates item class instances using reflection and an exception will be thrown if there isn't such constructor available.

3. Set the custom item as default

By default the Calendar control instantiates items of type Appointment when the user creates items interactively (by typing). To make the calendar create items of the new class, add the following line of code in the window's constructor.

C# [image] Copy Code

calendar.InteractiveItemType = typeof(MyApp);

Visual Basic [image] Copy Code

calendar.InteractiveItemType = GetType(MyApp)

Now all items created by the user at runtime will be instances of MyApp.

4. Test

To test whether the calendar actually creates MyApp instances, add an event handler to the control's ItemClick event. Add the following as a body of the event handler:

C# [image] Copy Code

if (e.Item is MyApp)
{
calendar.ResetDrag();
MessageBox.Show("This is our item.");
}

Visual Basic [image] Copy Code

If TypeOf e.Item Is MyApp Then

calendar.ResetDrag()
MessageBox.Show("This is our item.")

End If

Clicking on an item now should display the message box.

5. Serialization

Serialization of custom items requires additional efforts. Attempts to save a schedule containing items of type MyApp will result in an InvalidOperationException exception. In order to support serialization, we have to register MyApp with the schedule. For this purpose, add the following line of code somewhere in the window's constructor:

C# [image] Copy Code

Schedule.RegisterItemClass(typeof(MyApp), "myapp", 1);

Visual Basic [image] Copy Code

Schedule.RegisterItemClass(GetType(MyApp), "myapp", 1)

Now the exception won't be thrown, but you still need to override the SaveTo and LoadFrom methods of the Appointment class in order to serialize the custom property Kept. The code below illustrates how this is done.

C# [image] Copy Code

public override void SaveTo(XElement element, XmlSerializationContext context)
{
base.SaveTo(element, context);
context.WriteBool(kept, "Kept", element);
}

public override void LoadFrom(XElement element, XmlSerializationContext context)
{
base.LoadFrom(element, context);
kept = context.ReadBool("Kept", element);
}

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo(ByVal element As XElement, ByVal context As XmlSerializationContext)

MyBase.SaveTo(element, context)
context.WriteBool(_kept, "Kept", element)

End Sub

Public Overrides Sub LoadFrom(ByVal element As XElement, ByVal context As XmlSerializationContext)

MyBase.LoadFrom(element, context)
_kept = context.ReadBool("Kept", element)

End Sub

6. Recurrence

Recurrence of items from a custom class is not handled wholly automatically. Let's take a closer look at how recurrence works in MindFusion.Scheduling for Silverlight. When a recurrence pattern is associated with an existing item, the item is said to become the master of the recurrence. Every time the occurrences of a master item must be displayed in a given time range, they are generated by instantiating new objects of the same type as that of the master. This is necessary in order to support infinite recurrences, where the generation of all recurrence instances is not possible. When the occurrences are generated, their properties are copied from the master item. This is done automatically for the built-in item properties, but not for those added by a derived item class. In order to copy the custom properties from the master item to a particular occurrence, you need to override the CopyOccurrence method. The following code sample shows how to do this.

C# [image] Copy Code

protected override void CopyOccurrence(Item master)
{
base.CopyOccurrence(master);
_kept = (master as MyApp).Kept;
}

Visual Basic [image] Copy Code

Protected Overloads Overrides Sub CopyOccurrence(ByVal master As Item)

MyBase.CopyOccurrence(master)
_kept = CType(master, MyApp).Kept

End Sub

In addition, it is recommended to mark an item from a recurrent series as an exception when the value of a custom property changes. Otherwise, the change will be lost the next time the instance is generated.

C# [image] Copy Code

//...
public bool Kept
{
get { return _kept; }
set
{
_kept = value;

if (Recurrence != null)
Recurrence.MarkException(this, false);
}
}
//...

Visual Basic [image] Copy Code

' ...
Public Property Kept() As Boolean

Get
Return _kept
End Get

Set(ByVal Value As Boolean)

_kept = Value

If Not Recurrence Is Nothing Then
Recurrence.MarkException(Me, False)
End If

End Set

End Property
' ...

7. Interactive cloning

The users can clone items by holding down a particular key (the SHIFT key by default). To enable your custom items for interactive cloning, you have to override the Clone method, create a new object from your custom type and duplicate the fields of the prototype item. If you do not override the Clone method, MindFusion.Scheduling for Silverlight will still create copies of the item, but they will be of type Appointment instead of the custom item type. Here is a sample implementation of the Clone method.

C# [image] Copy Code

//...
public override object Clone()
{
MyApp clone = new MyApp();

// The following code replicates the code used in
// the Appointment's Clone method
clone.AllDayEvent = this.AllDayEvent;
clone.DescriptionText = this.DescriptionText;
clone.EndTime = this.EndTime;
clone.HeaderText = this.HeaderText;
clone.Location = this.Location;
clone.Locked = this.Locked;
clone.Priority = this.Priority;
clone.Reminder = this.Reminder;
clone.SelectedStyle = this.SelectedStyle.Clone() as Style;
clone.StartTime = this.StartTime;
clone.Style = this.Style.Clone() as Style;
clone.Tag = this.Tag;
clone.Task = this.Task;
clone.Visible = this.Visible;

foreach (Resource resource in this.Resources)
clone.Resources.Add(resource);

foreach (Contact contact in this.Contacts)
clone.Contacts.Add(contact);

// Now copy the custom fields
clone.Kept = this.Kept;

return clone;
}
//...

Visual Basic [image] Copy Code

'...
Public Overloads Overrides Function Clone() As Object

Dim aClone As New MyApp

' The following code replicates the code used in
' the Appointment's Clone method
aClone.AllDayEvent = Me.AllDayEvent
aClone.DescriptionText = Me.DescriptionText
aClone.EndTime = Me.EndTime
aClone.HeaderText = Me.HeaderText
aClone.Location = Me.Location
aClone.Locked = Me.Locked
aClone.Priority = Me.Priority
aClone.Reminder = Me.Reminder
aClone.StartTime = Me.StartTime
aClone.Tag = Me.Tag
aClone.Task = Me.Task
aClone.Visible = Me.Visible

Dim resource As Resource
For Each resource In Me.Resources
aClone.Resources.Add(resource)
Next resource

Dim contact As Contact
For Each contact In Me.Contacts
aClone.Contacts.Add(contact)
Next contact

' Now copy the custom fields
aClone.Kept = Me.Kept

Return aClone

End Function
'...


Tutorial 5: Custom Item Templates

This tutorial demonstrates how to customize the items presentation through custom item templates.

1. Create and initialize a new Silverlight application project

Follow steps 1 through 3 from Tutorial 1: Getting Started.

Set CurrentView to Timetable, Theme to Vista and Date to Jan 1, 2010.

2. Creating the item template

In order to customize the appearance, you need to define a new style with a control template setter for the item presentation, then you need to handle the ItemPresenterCreated event of the Calendar control and assign the key of the newly created style to one of the three ItemPresenter properties - StyleKeyComplex, StyleKeySimpleHorizontal or StyleKeySimpleVertical. For more information on the ItemPresenter and its role in the item presentation, check Item Presenters.

The easiest way to customize the item templates is to create a copy of the default template and modify it. The full code of the default item template can be found here. The default template contains several styles, which determine the item's appearance in different views and in different orientations. For simplicity this tutorial will only customize the appearance of the items in vertical Timetable view.

Copy the style listed below to the App.xaml (Application.xaml in Visual Basic) file in your project.

XAML [image] Copy Code

<Style x:Key="MyComplex" TargetType="planner:ItemPresenter">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="planner:ItemPresenter">
<Border DataContext="{Binding RelativeSource={RelativeSource TemplatedParent}}"
Background="{Binding ItemStyle.Background}"
BorderBrush="{Binding ItemStyle.BorderBrush}"
BorderThickness="{Binding ItemStyle.BorderThickness}"
CornerRadius="8"
Margin="0,5,0,5">

<Grid>

<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
<RowDefinition Height="Auto" />
<RowDefinition />
</Grid.RowDefinitions>

<Border HorizontalAlignment="Stretch" BorderThickness="0,0,0,1"
BorderBrush="{Binding ItemStyle.LineBrush}"
Height="{Binding ItemSettings.HeaderSize}"
Margin="5,1,5,1">
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition />
<ColumnDefinition Width="Auto" />
</Grid.ColumnDefinitions>
<TextBlock x:Name="HeaderBlock"
TextWrapping="Wrap"
Text="{Binding Item.HeaderText, RelativeSource={RelativeSource TemplatedParent}}"
DataContext="{TemplateBinding ItemStyle}"
Foreground="{Binding Foreground}"
TextAlignment="Left"
HorizontalAlignment="Stretch"
VerticalAlignment="{Binding VerticalAlignment}"
FontFamily="{Binding FontFamily}"
FontSize="{Binding FontSize}"
FontStretch="{Binding FontStretch}"
FontStyle="{Binding FontStyle}"
FontWeight="{Binding FontWeight}" />
<StackPanel Orientation="Horizontal" Grid.Column="1">
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/Recurrence.png"
Visibility="{Binding RecurrenceIconVisibility}" Margin="1" />
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/RecurrenceEx.png"
Visibility="{Binding RecurrenceExceptionIconVisibility}" Margin="1" />
<Image Source="/MindFusion.Scheduling.Silverlight;component/Resources/Reminder.png"
Visibility="{Binding ReminderIconVisibility}" Margin="1" />
</StackPanel>
</Grid>
</Border>
<Border Grid.Row="1" Margin="5,1,5,1" DataContext="{TemplateBinding Item}">
<StackPanel Orientation="Vertical">
<TextBlock Text="{Binding StartTime}" />
<TextBlock Text="{Binding EndTime}" />
</StackPanel>
</Border>
<Border HorizontalAlignment="Stretch" BorderThickness="0,1,0,0"
Grid.Row="2"
BorderBrush="{Binding ItemStyle.LineBrush}"
Margin="5,1,5,1">
<TextBlock x:Name="DescriptionBlock"
DataContext="{TemplateBinding Item}"
TextWrapping="Wrap" Text="{Binding DescriptionText}" />
</Border>
</Grid>
</Border>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The planner namespace is defined in the <Application> tag as follows:

XAML [image] Copy Code

xmlns:planner="clr-namespace:MindFusion.Scheduling.Silverlight;assembly=MindFusion.Scheduling.Silverlight"

The local namespace is set to the namespace of your project (Tutorial5 by default).

Now that the style is defined, it needs to be associated with the newly created timetable items. To do this, handle the ItemPresenterCreated event and assign the style key to the StyleKeyComplex property of the corresponding ItemPresenter. The code below illustrates the handler of the ItemPresenterCreated event:

C# [image] Copy Code

private void calendar_ItemPresenterCreated(object sender, ItemPresenterEventArgs e)
{
e.ItemPresenter.StyleKeyComplex = "MyComplex";
}

Visual Basic [image] Copy Code

Private Sub calendar_ItemPresenterCreated(ByVal sender As Object, ByVal e As ItemPresenterEventArgs)

e.ItemPresenter.StyleKeyComplex = "MyComplex"

End Sub

Assigning the style key to StyleKeyComplex associates this style with non all-day items in the Timetable view. The new template is similar to the default one with the following differences:

  • The resize bands of the items are not displayed;
  • The items now have rounded edges;
  • The recurrence and reminder icons are displayed in the item's header, to the right of the item's HeaderText;
  • The start time and end time of the item are displayed below the item's header. They are automatically updated whenever the item's StartTime or EndTime change;

Without making any further modifications, run the sample, create a new item and see the newly defined template applied to it. The following image illustrates how an item will look like in the Vista theme.

3. Formatting the start and end time

Looking at the new item presentation you can see that the start and end dates displayed below the item's header are formatted using the default DateTime formatting and are not very readable. Let's define our custom IValueConverter class, which will enable us to display the dates in a custom format during databinding. For this purpose, create a new class - FormattingConverter and implement it as illustrated below.

C# [image] Copy Code

public class FormattingConverter : System.Windows.Data.IValueConverter
{
public object Convert(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture)
{
string format = parameter as string;
if (format == null)
return value.ToString();

return string.Format(culture, format, value);
}

public object ConvertBack(object value, Type targetType, object parameter, System.Globalization.CultureInfo culture)
{
throw new NotImplementedException();
}
}

Visual Basic [image] Copy Code

Public Class FormattingConverter
Implements System.Windows.Data.IValueConverter

Public Function Convert(ByVal value As Object, ByVal targetType As Type, ByVal parameter As Object, ByVal culture As System.Globalization.CultureInfo) As Object Implements IValueConverter.Convert

Dim format As String = CStr(parameter)
If format Is Nothing Then
Return value.ToString()
End If

Return String.Format(culture, format, value)

End Function

Public Function ConvertBack(ByVal value As Object, ByVal targetType As Type, ByVal parameter As Object, ByVal culture As System.Globalization.CultureInfo) As Object Implements IValueConverter.ConvertBack

Throw New NotImplementedException()

End Function

End Class

The above class takes a string argument and uses this string in order to format the input value. The next step is to create a static resource object of this class. Insert the following line before the <Style> definition in App.xaml (Application.xaml in Visual Basic):

XAML [image] Copy Code

<local:FormattingConverter x:Key="formattingConverter" />

Now locate the following two lines in the template:

XAML [image] Copy Code

<TextBlock Text="{Binding StartTime}" />
<TextBlock Text="{Binding EndTime}" />

And modify them as following:

XAML [image] Copy Code

<TextBlock Text="{Binding StartTime, Converter={StaticResource formattingConverter}, ConverterParameter='Start time: \{0:H:mm\}'}" />
<TextBlock Text="{Binding EndTime, Converter={StaticResource formattingConverter}, ConverterParameter='End time: \{0:H:mm\}'}" />

The above code instructs the Text bindings to format their source values using the "Start time: {0:H:mm}" and "{End time: {0:H:mm}" formatting strings respectively.

4. Build and run

Compile and run the application. Creating a new item with a Reminder and sample description will yield a result similar to the following:


Reference

© 2010


MindFusion Namespace
Enumerations

Enumerations

Enumeration | Description
Alignment | Specifies the alignment of contents relative to the layout rectangle.


MindFusion.Alignment Enumeration

Alignment Enumeration
See Also
[image]

Specifies the alignment of contents relative to the layout rectangle.

Namespace: MindFusion
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum Alignment
Visual Basic [image] Copy Code

Public Enumeration Alignment

Members

Member name | Description
Far | The contents are aligned far from the origin of the layout rectangle. In a left-to-right layout, the far position is right. In a right-to-left layout, the far position is left.
Near | The contents are aligned near the layout rectangle. In a left-to-right layout, the near position is left. In a right-to-left layout, the near position is right.
None | The contents are unavailable.

See Also

MindFusion Namespace


MindFusion.Scheduling Namespace
Classes Enumerations

Classes

Class | Description
CellPresenterCreatingEventArgs | Contains the arguments passed to handlers of item Calendar.CellPresenterCreating event.
ItemPresenterEventArgs | Contains the arguments passed to handlers of item related events raised by the Schedule class.
Appointment | The Appointment class represents appointments within a schedule.
Contact | Instances of the Contact class contain contact information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.
InstantiateItemEventArgs | Provides data for the InstantiateItem event.
InstantiateResourceEventArgs | Provides data for the InstantiateResource event.
Item | Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.
ItemCollection | Represents a strongly-typed collection of Item objects.
ItemEventArgs | Contains the arguments passed to handlers of item related events raised by the Schedule class.
ItemTimeEventArgs | Contains the arguments passed to handlers of time related events.
Location | Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.
Recurrence | Defines recurrence patterns for items scheduled to repeat over and over again.
RecurrenceException | This class represents exceptions of a recurrence patterns.
Reminder | Represents reminders associated with schedule items.
Resource | Instances of the Resource class contain information about arbitrary resources.
ResourceCollection(T) | Represents a strongly-typed collection of Resource-derived objects.
Schedule | Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.
SerializationContext | This class contains information required to serialize a Schedule element to and from a binary stream or XML document.
Task | Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.
TaskEventArgs | Contains the arguments passed to handlers of task related events raised by the Schedule class.
XmlSerializationContext | Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from XML documents.
SerializeTagEventArgs | Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.
CellPresenterEventArgs | Contains the arguments passed to handlers of item Calendar.CellPresenterCreated event.
AddItemCommand | Implements creation of new schedule items.
ChangeItemCommand | Handles undo / redo of property changes.
Command | Represents an action that changes the schedule and whose effects can be undone.
CompositeCommand | Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.
ItemState | Encapsulates the state of an Item instance.
RemoveItemCommand | Implements deletion of schedule items.
UndoEventArgs | Contains the arguments passed to the ActionUndone and ActionRedone event handlers.

Enumerations

Enumeration | Description
DailyRecurrence | Specifies how daily recurrence patterns are defined.
DayOfWeekType | Specifies the type of week days, used with ByDayType monthly and yearly recurrence patterns.
DaysOfWeek | Specifies the day of the week.
MonthlyRecurrence | Specifies the types of monthly recurrence patterns.
Occurrence | Specifies the occurrence number of a day or a week within a month.
RecurrenceEnd | Specifies when to stop repeating recurring events.
RecurrencePattern | Specifies the interval at which recurring items occur.
RecurrenceState | Specifies the recurrence state of items.
ReminderType | Specifies the type of a reminder.
TaskPriority | Specifies the priority of a task.
TaskStatus | Enumeration providing task status values.
YearlyRecurrence | Specifies the types of yearly recurrence patterns.


MindFusion.Scheduling.AddItemCommand Class

AddItemCommand Class
Remarks See Also
[image]

Implements creation of new schedule items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class AddItemCommand : Command
Visual Basic [image] Copy Code

Public Class AddItemCommand
Inherits Command

Remarks

The control automatically creates instances of this class when items are added either interactively or from code.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Command
MindFusion.Scheduling.AddItemCommand

See Also

AddItemCommand Members
MindFusion.Scheduling Namespace
RemoveItemCommand Class
ChangeItemCommand Class


MindFusion.Scheduling.AddItemCommand Members

AddItemCommand Members
Constructors Methods
[image]

Implements creation of new schedule items.

The following tables list the members exposed by the AddItemCommand type.

Public Constructors

Name | Description
AddItemCommand | Initializes a new instance of the AddItemCommand class.

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.AddItemCommand Constructor

AddItemCommand Constructor
[image]

Initializes a new instance of the AddItemCommand class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public AddItemCommand (
Schedule schedule,
Item item,
int index
)
Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
item As Item, _
index As Integer _
)

Parameters

schedule
The Schedule to which the new item is added.
item
The new Item that should be added to the schedule.
index
The position of the item within the Items collection.

See Also

AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.AddItemCommand Methods

AddItemCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.AddItemCommand.Execute Method

AddItemCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual bool Execute ()
Visual Basic [image] Copy Code

Protected Overridable Function Execute () As Boolean

Return Value

This method always returns true.

See Also

AddItemCommand Members
AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.AddItemCommand.Redo Method

AddItemCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void Redo ()
Visual Basic [image] Copy Code

Protected Overridable Sub Redo ()

See Also

AddItemCommand Members
AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.AddItemCommand.Undo Method

AddItemCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void Undo ()
Visual Basic [image] Copy Code

Protected Overridable Sub Undo ()

See Also

AddItemCommand Members
AddItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Class

Appointment Class
[image]

The Appointment class represents appointments within a schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class Appointment : Item
Visual Basic [image] Copy Code

Public Class Appointment
Inherits Item

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Item
MindFusion.Scheduling.Appointment

See Also

Appointment Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Members

Appointment Members
Constructors Properties Methods
[image]

The Appointment class represents appointments within a schedule.

The following tables list the members exposed by the Appointment type.

Public Constructors

Name | Description
Appointment | Initializes a new instance of the Appointment class.

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the appointment is an all-day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the appointment's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the appointment's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the appointment.
Attendees | Gets the attendees of this appointment.
Contacts | Gets references to all contacts associated with this appointment.
DescriptionText | Gets or sets the details text displayed for this appointment by scheduling controls.
Details | Gets or sets the detailed description of this appointment.
EndTime | Gets or sets the appointment's scheduled old end time.
HeaderText | Gets or sets the header text displayed for this appointment by scheduling controls.
Id | Gets or sets the string identifier of this appointment.
Location | Gets or sets the appointment location.
Locked | Gets or sets a value indicating whether users are forbidden to modify this appointment.
Reminder | Gets or sets the reminder for this appointment.
Resources | Gets references to all resources associated with this appointment.
StartTime | Gets or sets the appointment's scheduled start time.
Subject | Gets or sets the subject of this appointment.
Tag | Gets or sets custom data associated with the appointment.
Task | Gets or sets the task associated with this appointment.
Visible | Gets or sets whether the appointment is visible or not.

Public Methods

Name | Description
Clone | Creates an exact shallow clone of this appointment.
LoadFrom |
SaveTo |

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Constructor

Appointment Constructor
[image]

Initializes a new instance of the Appointment class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Appointment ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Methods

Appointment Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact shallow clone of this appointment.
LoadFrom |
SaveTo |

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Clone Method

Appointment.Clone Method
[image]

Creates an exact shallow clone of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override Object Clone ()
Visual Basic [image] Copy Code

Public Overrides Function Clone () As Object

Return Value

A new Appointment object representing a shallow copy of this one.

Remarks

The Clone method creates an exact copy of an item with the following exceptions. The duplicates of a recurring item created through the Clone method are no longer recurring items. The Id of the newly created item is unique and not the same as the Id of the source item.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.LoadFrom Method (XElement, XmlSerializationContext)

Appointment.LoadFrom Method (XElement, XmlSerializationContext)
See Also
[image]

Loads appointment data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void LoadFrom (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

Loads the appointment's fields from an XML document where they were stored by a previous call to the SaveTo method.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Appointment.SaveTo Method (XElement, XmlSerializationContext)

Appointment.SaveTo Method (XElement, XmlSerializationContext)
See Also
[image]

Saves the appointment data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void SaveTo (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the appointment's fields as elements of an XML document, from which they can be loaded later via the LoadFrom method.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Appointment Properties

Appointment Properties
[image]

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the appointment is an all-day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the appointment's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the appointment's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the appointment.
Attendees | Gets the attendees of this appointment.
Contacts | Gets references to all contacts associated with this appointment.
DescriptionText | Gets or sets the details text displayed for this appointment by scheduling controls.
Details | Gets or sets the detailed description of this appointment.
EndTime | Gets or sets the appointment's scheduled old end time.
HeaderText | Gets or sets the header text displayed for this appointment by scheduling controls.
Id | Gets or sets the string identifier of this appointment.
Location | Gets or sets the appointment location.
Locked | Gets or sets a value indicating whether users are forbidden to modify this appointment.
Reminder | Gets or sets the reminder for this appointment.
Resources | Gets references to all resources associated with this appointment.
StartTime | Gets or sets the appointment's scheduled start time.
Subject | Gets or sets the subject of this appointment.
Tag | Gets or sets custom data associated with the appointment.
Task | Gets or sets the task associated with this appointment.
Visible | Gets or sets whether the appointment is visible or not.

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.AllDayEvent Property

Appointment.AllDayEvent Property
[image]

Gets or sets a value indicating whether the appointment is an all-day event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override bool AllDayEvent { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property AllDayEvent As Boolean

Property Value

true if the item is an all day event; otherwise, false. The default is false.

Remarks

All day events are displayed in a special header area when the Calendar displays a timetable view.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
StartTime Property
EndTime Property


MindFusion.Scheduling.Appointment.AllowChangeEnd Property

Appointment.AllowChangeEnd Property
[image]

Gets or sets a value indicating whether users are allowed to change the appointment's end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override bool AllowChangeEnd { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property AllowChangeEnd As Boolean

Property Value

true if the appointment's end can be modified interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowMove Property


MindFusion.Scheduling.Appointment.AllowChangeStart Property

Appointment.AllowChangeStart Property
[image]

Gets or sets a value indicating whether users are allowed to change the appointment's start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override bool AllowChangeStart { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property AllowChangeStart As Boolean

Property Value

true if the appointment's start can be modified interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeEnd Property
AllowMove Property


MindFusion.Scheduling.Appointment.AllowMove Property

Appointment.AllowMove Property
[image]

Gets or sets a value indicating whether users are allowed to move the appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override bool AllowMove { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property AllowMove As Boolean

Property Value

true if the appointment can be moved interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowChangeEnd Property


MindFusion.Scheduling.Appointment.Attendees Property

Appointment.Attendees Property
[image]

Gets the attendees of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Contact> Attendees { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Attendees As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection(Contact) class specifying the appointment's attendees.

Remarks

This property is equivalent to Contacts.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Contacts Property

Appointment.Contacts Property
[image]

Gets references to all contacts associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override ResourceCollection<Contact> Contacts { get; }
Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Contacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection(Contact) class containing the contacts associated with this appointment.

Remarks

This property is equivalent to Attendees.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.DescriptionText Property

Appointment.DescriptionText Property
[image]

Gets or sets the details text displayed for this appointment by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override string DescriptionText { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property DescriptionText As String

Property Value

A string containing the appointment's description. The default is an empty string.

Remarks

This property implements the DescriptionText property of the Item class and is equivalent to Details.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Details Property

Appointment.Details Property
[image]

Gets or sets the detailed description of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Details { get; set; }
Visual Basic [image] Copy Code

Public Property Details As String

Property Value

This property is equivalent to DescriptionText.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.EndTime Property

Appointment.EndTime Property
[image]

Gets or sets the appointment's scheduled old end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override DateTime EndTime { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property EndTime As DateTime

Property Value

A .NET DateTime object specifying the appointment's end time. The default is DateTime.MaxValue.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
StartTime Property
AllDayEvent Property


MindFusion.Scheduling.Appointment.HeaderText Property

Appointment.HeaderText Property
[image]

Gets or sets the header text displayed for this appointment by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override string HeaderText { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property HeaderText As String

Property Value

A string containing the appointment's header text. The default is an empty string.

Remarks

This property implements the Item's class HeaderText property and is equivalent to Subject.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Id Property

Appointment.Id Property
[image]

Gets or sets the string identifier of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override string Id { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property Id As String

Property Value

A string value that identifies uniquely this appointment.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Location Property

Appointment.Location Property
[image]

Gets or sets the appointment location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override Location Location { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property Location As Location

Property Value

An instance of the Location class specifying the appointment's location. The default is null (Nothing in Visual Basic).

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Locked Property

Appointment.Locked Property
[image]

Gets or sets a value indicating whether users are forbidden to modify this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override bool Locked { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property Locked As Boolean

Property Value

true if users are allowed to move an appointment thus changing its scheduled time; otherwise, false. The default is false.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Reminder Property

Appointment.Reminder Property
[image]

Gets or sets the reminder for this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override Reminder Reminder { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property Reminder As Reminder

Property Value

An instance of the Reminder class.

Remarks

If the reminder type is Exact, the ItemReminderTriggered event is raised at the time set in the reminder's Time property. If the reminder type is Leading, the ItemReminderTriggered event is raised certain amount of time prior to the item's StartTime, as specified in the reminder's TimeInterval property.

Note

Recurring items cannot have leading reminders.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Resources Property

Appointment.Resources Property
[image]

Gets references to all resources associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override ResourceCollection<Resource> Resources { get; }
Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Resources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection(Resource) class containing the resources associated with this item.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.StartTime Property

Appointment.StartTime Property
[image]

Gets or sets the appointment's scheduled start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override DateTime StartTime { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property StartTime As DateTime

Property Value

A .NET DateTime instance specifying the scheduled time for the item.

Remarks

This property affects the initial time cell occupied by the item when it is displayed in a Calendar view.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
EndTime Property
AllDayEvent Property


MindFusion.Scheduling.Appointment.Subject Property

Appointment.Subject Property
[image]

Gets or sets the subject of this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Subject { get; set; }
Visual Basic [image] Copy Code

Public Property Subject As String

Property Value

A string that identifies the subject of the appointment. The default is an empty string.

Remarks

This is equivalent to the HeaderText property.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Tag Property

Appointment.Tag Property
[image]

Gets or sets custom data associated with the appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override Object Tag { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Task Property

Appointment.Task Property
[image]

Gets or sets the task associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override Task Task { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property Task As Task

Property Value

An instance of the Task class. The default is null (Nothing in Visual Basic).

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Visible Property

Appointment.Visible Property
[image]

Gets or sets whether the appointment is visible or not.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override bool Visible { get; set; }
Visual Basic [image] Copy Code

Public Overrides Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false. The default is true.

Remarks

Invisible items are not drawn at all. You could use this property to hide an item temporarily, or to store additional data in a helper item object that always stays invisible.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs Class

CellPresenterCreatingEventArgs Class
[image]

Contains the arguments passed to handlers of item Calendar.CellPresenterCreating event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class CellPresenterCreatingEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class CellPresenterCreatingEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.CellPresenterCreatingEventArgs

See Also

CellPresenterCreatingEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs Members

CellPresenterCreatingEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item Calendar.CellPresenterCreating event.

The following tables list the members exposed by the CellPresenterCreatingEventArgs type.

Public Properties

Name | Description
CellPresenter | Gets the cell presenter related to the event.
EndTime | Gets the end time of the cell whose presenter is being created.
Resource | Gets the resource associated with the cell whose presenter is being created.
StartTime | Gets the start time of the cell whose presenter is being created.

See Also

CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs Properties

CellPresenterCreatingEventArgs Properties
[image]

Public Properties

Name | Description
CellPresenter | Gets the cell presenter related to the event.
EndTime | Gets the end time of the cell whose presenter is being created.
Resource | Gets the resource associated with the cell whose presenter is being created.
StartTime | Gets the start time of the cell whose presenter is being created.

See Also

CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs.CellPresenter Property

CellPresenterCreatingEventArgs.CellPresenter Property
[image]

Gets the cell presenter related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CellPresenter CellPresenter { get; set; }
Visual Basic [image] Copy Code

Public Property CellPresenter As CellPresenter

Property Value

An instance of the CellPresenter class.

See Also

CellPresenterCreatingEventArgs Members
CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs.EndTime Property

CellPresenterCreatingEventArgs.EndTime Property
[image]

Gets the end time of the cell whose presenter is being created.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime EndTime { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property EndTime As DateTime

Property Value

A .NET DateTime object.

Remarks

This property, along with the StartTime and Resource properties, can be used to determine whether to create a custom CellPresenter object for a particular cell.

See Also

CellPresenterCreatingEventArgs Members
CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs.Resource Property

CellPresenterCreatingEventArgs.Resource Property
[image]

Gets the resource associated with the cell whose presenter is being created.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Resource Resource { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

An instance of the Resource class.

Remarks

This property, along with the StartTime and EndTime properties, can be used to determine whether to create a custom CellPresenter object for a particular cell.

See Also

CellPresenterCreatingEventArgs Members
CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterCreatingEventArgs.StartTime Property

CellPresenterCreatingEventArgs.StartTime Property
[image]

Gets the start time of the cell whose presenter is being created.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime StartTime { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property StartTime As DateTime

Property Value

A .NET DateTime object.

Remarks

This property, along with the EndTime and Resource properties, can be used to determine whether to create a custom CellPresenter object for a particular cell.

See Also

CellPresenterCreatingEventArgs Members
CellPresenterCreatingEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterEventArgs Class

CellPresenterEventArgs Class
[image]

Contains the arguments passed to handlers of item Calendar.CellPresenterCreated event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class CellPresenterEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class CellPresenterEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.CellPresenterEventArgs

See Also

CellPresenterEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterEventArgs Members

CellPresenterEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item Calendar.CellPresenterCreated event.

The following tables list the members exposed by the CellPresenterEventArgs type.

Public Properties

Name | Description
CellPresenter | Gets the cell presenter related to the event.

See Also

CellPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterEventArgs Properties

CellPresenterEventArgs Properties
[image]

Public Properties

Name | Description
CellPresenter | Gets the cell presenter related to the event.

See Also

CellPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CellPresenterEventArgs.CellPresenter Property

CellPresenterEventArgs.CellPresenter Property
[image]

Gets the cell presenter related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CellPresenter CellPresenter { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property CellPresenter As CellPresenter

Property Value

An instance of the CellPresenter class.

See Also

CellPresenterEventArgs Members
CellPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand Class

ChangeItemCommand Class
Remarks See Also
[image]

Handles undo / redo of property changes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ChangeItemCommand : Command
Visual Basic [image] Copy Code

Public Class ChangeItemCommand
Inherits Command

Remarks

The ChangeItemCommand constructor records the state of an item, and its Undo and Redo methods restore the item to either its old or new state.

Example

The following example shows the pattern that should be used to save the state of an item for later undo.

C# [image] Copy Code

Item item = calendar.ItemSelection.Items[0];
if (item != null)
{
ChangeItemCommand change = new ChangeItemCommand(calendar.Schedule, item);
item.HeaderText = "new header";
item.StartTime = DateTime.Now;
item.EndTime = DateTime.Now.AddHours(2);
calendar.Schedule.ExecuteCommand(change);
}
Visual Basic [image] Copy Code

Dim item = calendar.ItemSelection.Items(0)
If (item IsNot Nothing) Then

Dim change As New ChangeItemCommand(calendar.Schedule, item)
item.HeaderText = "new header"
item.StartTime = DateTime.Now
item.EndTime = DateTime.Now.AddHours(2)
calendar.Schedule.ExecuteCommand(change)

End If

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Command
MindFusion.Scheduling.ChangeItemCommand

See Also

ChangeItemCommand Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand Members

ChangeItemCommand Members
Constructors Methods
[image]

Handles undo / redo of property changes.

The following tables list the members exposed by the ChangeItemCommand type.

Public Constructors

Name | Description
ChangeItemCommand | Initializes a new instance of the ChangeItemCommand class.

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand Constructor

ChangeItemCommand Constructor
[image]

Initializes a new instance of the ChangeItemCommand class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ChangeItemCommand (
Schedule schedule,
Item item
)
Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
item As Item _
)

Parameters

schedule
The Schedule whose item is changed.
item
The Item that will be modified.

See Also

ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand Methods

ChangeItemCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand.Execute Method

ChangeItemCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual bool Execute ()
Visual Basic [image] Copy Code

Protected Overridable Function Execute () As Boolean

Return Value

true, if the item's state has effectively changed; otherwise, false.

See Also

ChangeItemCommand Members
ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand.Redo Method

ChangeItemCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void Redo ()
Visual Basic [image] Copy Code

Protected Overridable Sub Redo ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ChangeItemCommand.Undo Method

ChangeItemCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void Undo ()
Visual Basic [image] Copy Code

Protected Overridable Sub Undo ()

See Also

ChangeItemCommand Members
ChangeItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command Class

Command Class
[image]

Represents an action that changes the schedule and whose effects can be undone.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract class Command
Visual Basic [image] Copy Code

Public MustInherit Class Command

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Command
MindFusion.Scheduling.AddItemCommand
MindFusion.Scheduling.ChangeItemCommand
MindFusion.Scheduling.CompositeCommand
MindFusion.Scheduling.RemoveItemCommand

See Also

Command Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command Members

Command Members
Constructors Properties Methods
[image]

Represents an action that changes the schedule and whose effects can be undone.

The following tables list the members exposed by the Command type.

Protected Constructors

Name | Description
Command | Initializes a new instance of the Command class.

Public Properties

Name | Description
Schedule | Gets the Schedule modified by this Command object.

Protected Methods

Name | Description
Execute | Carries out an action that changes the schedule in some way.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the schedule to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command Constructor

Command Constructor
[image]

Initializes a new instance of the Command class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected Command (
Schedule schedule
)
Visual Basic [image] Copy Code

Protected New ( _
schedule As Schedule _
)

Parameters

schedule
The Schedule object this command will operate on.

See Also

Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command Methods

Command Methods
[image]

Protected Methods

Name | Description
Execute | Carries out an action that changes the schedule in some way.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the schedule to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command.Execute Method

Command.Execute Method
[image]

Carries out an action that changes the schedule in some way.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected abstract bool Execute ()
Visual Basic [image] Copy Code

Protected MustOverride Function Execute () As Boolean

Return Value

true, if the command actually caused changes in the schedule; otherwise, false.

Remarks

Commands, which return false are never recorded in the command history.

See Also

Command Members
Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command.Redo Method

Command.Redo Method
[image]

Repeats an action that has been undone.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected abstract void Redo ()
Visual Basic [image] Copy Code

Protected MustOverride Sub Redo ()

See Also

Command Members
Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command.Undo Method

Command.Undo Method
[image]

Undoes an action, restoring the schedule to the state it was in before carrying out the action.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected abstract void Undo ()
Visual Basic [image] Copy Code

Protected MustOverride Sub Undo ()

See Also

Command Members
Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command Properties

Command Properties
[image]

Public Properties

Name | Description
Schedule | Gets the Schedule modified by this Command object.

See Also

Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Command.Schedule Property

Command.Schedule Property
[image]

Gets the Schedule modified by this Command object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Schedule Schedule { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Schedule As Schedule

Property Value

An instance of the Schedule class.

See Also

Command Members
Command Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand Class

CompositeCommand Class
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class CompositeCommand : Command
Visual Basic [image] Copy Code

Public Class CompositeCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Command
MindFusion.Scheduling.CompositeCommand

See Also

CompositeCommand Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand Members

CompositeCommand Members
Constructors Properties Methods
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

The following tables list the members exposed by the CompositeCommand type.

Public Constructors

Name | Description
CompositeCommand | Initializes a new instance of the CompositeCommand class.

Public Properties

Name | Description
Commands | Gets a list containing the child Command objects.

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand Constructor

CompositeCommand Constructor
[image]

Initializes a new instance of the CompositeCommand class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CompositeCommand (
Schedule schedule
)
Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule _
)

Parameters

schedule
The Schedule modified by this command.

See Also

CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand Methods

CompositeCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand.Execute Method

CompositeCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual bool Execute ()
Visual Basic [image] Copy Code

Protected Overridable Function Execute () As Boolean

Return Value

true, if at least one of the underlying commands returned true upon execution; otherwise, false.

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand.Redo Method

CompositeCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void Redo ()
Visual Basic [image] Copy Code

Protected Overridable Sub Redo ()

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand.Undo Method

CompositeCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void Undo ()
Visual Basic [image] Copy Code

Protected Overridable Sub Undo ()

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand Properties

CompositeCommand Properties
[image]

Public Properties

Name | Description
Commands | Gets a list containing the child Command objects.

See Also

CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CompositeCommand.Commands Property

CompositeCommand.Commands Property
[image]

Gets a list containing the child Command objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public List<Command> Commands { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Commands As List(Of Command)

Property Value

A generic .NET List of Command objects.

See Also

CompositeCommand Members
CompositeCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Class

Contact Class
[image]

Instances of the Contact class contain contact information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class Contact : Resource
Visual Basic [image] Copy Code

Public Class Contact
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Contact

See Also

Contact Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Members

Contact Members
Constructors Properties Methods
[image]

Instances of the Contact class contain contact information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.

The following tables list the members exposed by the Contact type.

Public Constructors

Name | Description
Contact | Initializes a new instance of the Contact class.

Public Properties

Name | Description
Address | Gets or sets the address of the contact.
Email | Gets or sets the e-mail address of the contact.
FirstName | Gets or sets the first name of the contact.
LastName | Gets or sets the last name of the contact.
MiddleName | Gets or sets the middle name of the contact.
Phone | Gets or sets the phone of the contact.

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Constructor

Contact Constructor
[image]

Initializes a new instance of the Contact class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Contact ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Methods

Contact Methods
[image]

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.LoadFrom Method (XElement, XmlSerializationContext)

Contact.LoadFrom Method (XElement, XmlSerializationContext)
See Also
[image]

Loads contact data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void LoadFrom (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The context parameter wraps an XML document that contains data stored by a previous call to the SaveTo method.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Contact.SaveTo Method (XElement, XmlSerializationContext)

Contact.SaveTo Method (XElement, XmlSerializationContext)
See Also
[image]

Saves the contact data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void SaveTo (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the contact properties as elements of an XML document.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Contact Properties

Contact Properties
[image]

Public Properties

Name | Description
Address | Gets or sets the address of the contact.
Email | Gets or sets the e-mail address of the contact.
FirstName | Gets or sets the first name of the contact.
LastName | Gets or sets the last name of the contact.
MiddleName | Gets or sets the middle name of the contact.
Phone | Gets or sets the phone of the contact.

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.Address Property

Contact.Address Property
[image]

Gets or sets the address of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Address { get; set; }
Visual Basic [image] Copy Code

Public Property Address As String

Property Value

A string containing address information. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.Email Property

Contact.Email Property
[image]

Gets or sets the e-mail address of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Email { get; set; }
Visual Basic [image] Copy Code

Public Property Email As String

Property Value

A string containing an e-mail address. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.FirstName Property

Contact.FirstName Property
[image]

Gets or sets the first name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string FirstName { get; set; }
Visual Basic [image] Copy Code

Public Property FirstName As String

Property Value

A string containing the first name of a person. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
LastName Property
MiddleName Property


MindFusion.Scheduling.Contact.LastName Property

Contact.LastName Property
[image]

Gets or sets the last name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string LastName { get; set; }
Visual Basic [image] Copy Code

Public Property LastName As String

Property Value

A string containing person's last name. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
FirstName Property
MiddleName Property


MindFusion.Scheduling.Contact.MiddleName Property

Contact.MiddleName Property
[image]

Gets or sets the middle name of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string MiddleName { get; set; }
Visual Basic [image] Copy Code

Public Property MiddleName As String

Property Value

A string containing person's last name. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
FirstName Property
LastName Property


MindFusion.Scheduling.Contact.Phone Property

Contact.Phone Property
[image]

Gets or sets the phone of the contact.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Phone { get; set; }
Visual Basic [image] Copy Code

Public Property Phone As String

Property Value

A string containing a phone number. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.DailyRecurrence Enumeration

DailyRecurrence Enumeration
[image]

Specifies how daily recurrence patterns are defined.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum DailyRecurrence
Visual Basic [image] Copy Code

Public Enumeration DailyRecurrence

Members

Member name | Description
ByDayInterval | Repeats the item after every number of days specified in the Recurrence.Days property.
EveryWeekend | Repeats the item each Saturday and Sunday.
EveryWorkday | Repeats the item each workday, Monday through Friday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.DayOfWeekType Enumeration

DayOfWeekType Enumeration
[image]

Specifies the type of week days, used with ByDayType monthly and yearly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum DayOfWeekType
Visual Basic [image] Copy Code

Public Enumeration DayOfWeekType

Members

Member name | Description
AnyDay | Indicates any day.
Friday | Indicates Friday.
Monday | Indicates Monday.
Saturday | Indicates Saturday.
Sunday | Indicates Sunday.
Thursday | Indicates Thursday.
Tuesday | Indicates Tuesday.
Wednesday | Indicates Wednesday.
Weekend | Indicates a weekend day.
Workday | Indicates a workday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.DaysOfWeek Enumeration

DaysOfWeek Enumeration
[image]

Specifies the day of the week.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum DaysOfWeek
Visual Basic [image] Copy Code

Public Enumeration DaysOfWeek

Members

Member name | Description
All | Indicates all days of the week.
Friday | Indicates Friday.
Monday | Indicates Monday.
None | Indicates an undefined day value.
Saturday | Indicates Saturday.
Sunday | Indicates Sunday.
Thursday | Indicates Thursday.
Tuesday | Indicates Tuesday.
Wednesday | Indicates Wednesday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Class

InstantiateItemEventArgs Class
[image]

Provides data for the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class InstantiateItemEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class InstantiateItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateItemEventArgs

See Also

InstantiateItemEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Members

InstantiateItemEventArgs Members
Properties
[image]

Provides data for the InstantiateItem event.

The following tables list the members exposed by the InstantiateItemEventArgs type.

Public Properties

Name | Description
ClassId | Gets the class identifier of the item.
Item | Gets or sets the newly created item.

See Also

InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Properties

InstantiateItemEventArgs Properties
[image]

Public Properties

Name | Description
ClassId | Gets the class identifier of the item.
Item | Gets or sets the newly created item.

See Also

InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs.ClassId Property

InstantiateItemEventArgs.ClassId Property
[image]

Gets the class identifier of the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string ClassId { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ClassId As String

Property Value

A string value representing the class identifier of the item, which should be created.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs.Item Property

InstantiateItemEventArgs.Item Property
[image]

Gets or sets the newly created item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Item Item { get; set; }
Visual Basic [image] Copy Code

Public Property Item As Item

Property Value

An instance of an Item-derived class.

Remarks

Upon handling the InstantiateItem event, you have to create an item of the appropriate type, as specified by ClassId, and assign it to this property.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Class

InstantiateResourceEventArgs Class
[image]

Provides data for the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class InstantiateResourceEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class InstantiateResourceEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateResourceEventArgs

See Also

InstantiateResourceEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Members

InstantiateResourceEventArgs Members
Properties
[image]

Provides data for the InstantiateResource event.

The following tables list the members exposed by the InstantiateResourceEventArgs type.

Public Properties

Name | Description
ClassId | Gets the class identifier of the resource.
Resource | Gets or sets the newly created resource.

See Also

InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Properties

InstantiateResourceEventArgs Properties
[image]

Public Properties

Name | Description
ClassId | Gets the class identifier of the resource.
Resource | Gets or sets the newly created resource.

See Also

InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs.ClassId Property

InstantiateResourceEventArgs.ClassId Property
[image]

Gets the class identifier of the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string ClassId { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ClassId As String

Property Value

A string value representing the class identifier of the resource, which should be created.

See Also

InstantiateResourceEventArgs Members
InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs.Resource Property

InstantiateResourceEventArgs.Resource Property
[image]

Gets or sets the newly created resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Resource Resource { get; set; }
Visual Basic [image] Copy Code

Public Property Resource As Resource

Property Value

An instance of a Resource-derived class.

Remarks

Upon handling the InstantiateResource event, you have to create a resource of the appropriate type, as specified by ClassId, and assign it to this property.

See Also

InstantiateResourceEventArgs Members
InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Class

Item Class
[image]

Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract class Item : INotifyPropertyChanged
Visual Basic [image] Copy Code

Public MustInherit Class Item
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Item
MindFusion.Scheduling.Appointment

See Also

Item Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Members

Item Members
Constructors Properties Methods Events
[image]

Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.

The following tables list the members exposed by the Item type.

Protected Constructors

Name | Description
Item | Initializes a new instance of the Item class.

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the item represents an all day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the item's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the item's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the item.
Contacts | Gets references to all contacts associated with this item.
DescriptionText | Gets or sets the description displayed for this item by scheduling controls.
EndTime | Gets or sets the item's scheduled end time.
HeaderText | Gets or sets the header text displayed for this item by scheduling controls.
Id | Gets or sets the string identifier of this item.
Location | Gets or sets the location associated with this item.
Locked | Gets or sets a value indicating whether users are forbidden to modify this item.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1.
Priority | Gets or sets the priority of this item.
Recurrence | Gets or sets the recurrence pattern of this item.
RecurrenceState | Gets the recurrence state of this item.
Reminder | Gets or sets the reminder for this item.
Resources | Gets references to all resources associated with this item.
StartTime | Gets or sets the item's scheduled start time.
Tag | Gets or sets custom data associated with the item.
Task | Gets or sets the task associated with this item.
Visible | Gets or sets a flag indicating whether the item is visible or not.

Public Methods

Name | Description
Clone | Creates a clone of this item.
GetHashCode | Returns a hash code for this item.
LoadFrom |
SaveTo |

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.
CreateState | Creates an item state corresponding to the concrete type of this item.
NotifyPropertyChanged | Raises the PropertyChanged event for the specified property.
OnChanged | Raises the OnChanged event on this item.
RestoreState | Restores the state of this item.
SaveState | Saves the state of this item.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Constructor

Item Constructor
[image]

Initializes a new instance of the Item class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected Item ()
Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Methods

Item Methods
[image]

Public Methods

Name | Description
Clone | Creates a clone of this item.
GetHashCode | Returns a hash code for this item.
LoadFrom |
SaveTo |

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.
CreateState | Creates an item state corresponding to the concrete type of this item.
NotifyPropertyChanged | Raises the PropertyChanged event for the specified property.
OnChanged | Raises the OnChanged event on this item.
RestoreState | Restores the state of this item.
SaveState | Saves the state of this item.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Clone Method

Item.Clone Method
[image]

Creates a clone of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract Object Clone ()
Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Object

Return Value

This is a pure abstract method and does not return a value.

Remarks

The clone of a recurring item is not an occurrence but an ordinary item. Aside from this, the clone is an exact duplicate of the original item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.CopyOccurrence Method

Item.CopyOccurrence Method
[image]

Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void CopyOccurrence (
Item master
)
Visual Basic [image] Copy Code

Protected Overridable Sub CopyOccurrence ( _
master As Item _
)

Parameters

master
A reference to the master to copy from.

Remarks

This method is usually overridden in classes which derive from Item or Appointment in order to copy the custom fields from the master item to a particular occurrence. If the method is not overridden, the custom fields for all occurrences will have their default values and not the value of the master item.

Example

The following example illustrates how to override CopyOccurrence in a class deriving from Appointment and how to copy the custom fields from the master item.

C# [image] Copy Code

class CustomAppointment : Appointment
{
protected override void CopyOccurrence(Item master)
{
_customField = (master as CustomAppointment)._customField;
base.CopyOccurrence(master);
}

private int _customField;
}
Visual Basic [image] Copy Code

Class CustomAppointment
Inherits Appointment

Protected Overrides Sub CopyOccurrence(ByVal master As Item)

_customField = CType(master, CustomAppointment)._customField
MyBase.CopyOccurrence(master)

End Sub

Private _customField As Integer

End Class

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.CreateState Method

Item.CreateState Method
[image]

Creates an item state corresponding to the concrete type of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual ItemState CreateState ()
Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As ItemState

Return Value

An instance of ItemState or a derived class.

Remarks

This method is used by the undo/redo system to create an ItemState-derived object that corresponds to the item class. Custom item classes must override CreateState in order to implement undo/redo support for any additional members they define. This method should be overridden together with SaveState and RestoreState.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
SaveState Method
RestoreState Method


MindFusion.Scheduling.Item.GetHashCode Method

Item.GetHashCode Method
[image]

Returns a hash code for this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override int GetHashCode ()
Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.LoadFrom Method (XElement, XmlSerializationContext)

Item.LoadFrom Method (XElement, XmlSerializationContext)
See Also
[image]

Loads item data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual void LoadFrom (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overridable Sub LoadFrom ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Item.NotifyPropertyChanged Method

Item.NotifyPropertyChanged Method
[image]

Raises the PropertyChanged event for the specified property.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected void NotifyPropertyChanged (
string prop
)
Visual Basic [image] Copy Code

Protected Sub NotifyPropertyChanged ( _
prop As String _
)

Parameters

prop

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.OnChanged Method

Item.OnChanged Method
[image]

Raises the OnChanged event on this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected void OnChanged ()
Visual Basic [image] Copy Code

Protected Sub OnChanged ()

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.RestoreState Method

Item.RestoreState Method
[image]

Restores the state of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
ItemState state
)
Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState ( _
state As ItemState _
)

Parameters

state
A ItemState that represents previous state of the item.

Remarks

This method is used by the undo/redo system to restore an item to a previous state. Custom item classes must override RestoreState in order to implement undo/redo support for any additional members they define. This method should be overridden together with CreateState and SaveState.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
CreateState Method
SaveState Method


MindFusion.Scheduling.Item.SaveState Method

Item.SaveState Method
[image]

Saves the state of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual ItemState SaveState ()
Visual Basic [image] Copy Code

Protected Overridable Function SaveState () As ItemState

Return Value

An ItemState that represents the current state of the item.

Remarks

This method is used by the undo/redo system to save the state of an item. Custom item classes must override SaveState in order to implement undo/redo support for any additional members they define. This method should be overridden together with CreateState and RestoreState.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
CreateState Method
RestoreState Method


MindFusion.Scheduling.Item.SaveTo Method (XmlElement, XmlSerializationContext)

Item.SaveTo Method (XmlElement, XmlSerializationContext)
See Also
[image]

Saves the item data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overridable Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Item Properties

Item Properties
[image]

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the item represents an all day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the item's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the item's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the item.
Contacts | Gets references to all contacts associated with this item.
DescriptionText | Gets or sets the description displayed for this item by scheduling controls.
EndTime | Gets or sets the item's scheduled end time.
HeaderText | Gets or sets the header text displayed for this item by scheduling controls.
Id | Gets or sets the string identifier of this item.
Location | Gets or sets the location associated with this item.
Locked | Gets or sets a value indicating whether users are forbidden to modify this item.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1.
Priority | Gets or sets the priority of this item.
Recurrence | Gets or sets the recurrence pattern of this item.
RecurrenceState | Gets the recurrence state of this item.
Reminder | Gets or sets the reminder for this item.
Resources | Gets references to all resources associated with this item.
StartTime | Gets or sets the item's scheduled start time.
Tag | Gets or sets custom data associated with the item.
Task | Gets or sets the task associated with this item.
Visible | Gets or sets a flag indicating whether the item is visible or not.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.AllDayEvent Property

Item.AllDayEvent Property
[image]

Gets or sets a value indicating whether the item represents an all day event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract bool AllDayEvent { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property AllDayEvent As Boolean

Property Value

true if the item is an all day event; otherwise, false.

Remarks

All day event items are displayed in a special header area when the Calendar displays a timetable view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
StartTime Property
EndTime Property


MindFusion.Scheduling.Item.AllowChangeEnd Property

Item.AllowChangeEnd Property
[image]

Gets or sets a value indicating whether users are allowed to change the item's end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract bool AllowChangeEnd { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property AllowChangeEnd As Boolean

Property Value

true if the item's end can be modified interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowMove Property


MindFusion.Scheduling.Item.AllowChangeStart Property

Item.AllowChangeStart Property
[image]

Gets or sets a value indicating whether users are allowed to change the item's start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract bool AllowChangeStart { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property AllowChangeStart As Boolean

Property Value

true if the item's start can be modified interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeEnd Property
AllowMove Property


MindFusion.Scheduling.Item.AllowMove Property

Item.AllowMove Property
[image]

Gets or sets a value indicating whether users are allowed to move the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract bool AllowMove { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property AllowMove As Boolean

Property Value

true if the item can be moved interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowChangeEnd Property


MindFusion.Scheduling.Item.Contacts Property

Item.Contacts Property
[image]

Gets references to all contacts associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract ResourceCollection<Contact> Contacts { get; }
Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Contacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection(Contact) generic class containing the Contact objects associated with the item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.DescriptionText Property

Item.DescriptionText Property
[image]

Gets or sets the description displayed for this item by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract string DescriptionText { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property DescriptionText As String

Property Value

A string containing the description of this item.

Remarks

All classes that derive from Item must implement this property. Controls such as Calendar display this text in the details area of an item visual representation.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.EndTime Property

Item.EndTime Property
[image]

Gets or sets the item's scheduled end time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract DateTime EndTime { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property EndTime As DateTime

Property Value

A .NET DateTime instance.

Remarks

This property specifies the last time cell occupied by the item in a Calendar view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
StartTime Property
AllDayEvent Property


MindFusion.Scheduling.Item.HeaderText Property

Item.HeaderText Property
[image]

Gets or sets the header text displayed for this item by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract string HeaderText { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property HeaderText As String

Property Value

A string specifying the item's header text.

Remarks

Calendar views display this value in the header area of the box that represents an item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Id Property

Item.Id Property
[image]

Gets or sets the string identifier of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract string Id { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property Id As String

Property Value

A string whose value uniquely identifies the item.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Location Property

Item.Location Property
[image]

Gets or sets the location associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract Location Location { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property Location As Location

Property Value

An instance of the Location class.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Locked Property

Item.Locked Property
[image]

Gets or sets a value indicating whether users are forbidden to modify this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract bool Locked { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property Locked As Boolean

Property Value

true if users are allowed to move the item thus changing its scheduled time; otherwise, false.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.OccurrenceIndex Property

Item.OccurrenceIndex Property
[image]

Gets the index of a repeating occurrence of a recurring item. If the item is not recurring, this property returns -1.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int OccurrenceIndex { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property OccurrenceIndex As Integer

Property Value

An integer value identifying the index of an occurrence item within the recurrence array. If the item is not recurring, this property returns -1.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Priority Property

Item.Priority Property
[image]

Gets or sets the priority of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int Priority { get; set; }
Visual Basic [image] Copy Code

Public Property Priority As Integer

Property Value

An integer value, specifying the item's priority.

Remarks

Items with higher priority have a better chance to be displayed prior items with lower priority. If two items start and end at the same time, the item with higher Priority will be displayed before the item with lower Priority. In other words, this property gives you control over the order of the items.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Recurrence Property

Item.Recurrence Property
[image]

Gets or sets the recurrence pattern of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Recurrence Recurrence { get; set; }
Visual Basic [image] Copy Code

Public Property Recurrence As Recurrence

Property Value

An instance of the Recurrence class. The default is null (Nothing in Visual Basic).

Remarks

If this property is set, the item becomes a recurring event and the Calendar control displays multiple occurrences of the item. To detach a previously set recurrence from an item, set this property to null (Nothing in Visual Basic).

Example

The following example demonstrates how to create and attach a recurring pattern to an existing item. The example assumes that item identifies an existing Item object.

C# [image] Copy Code

// Create the recurrence so that the item occurs once every two days
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Daily;
recurrence.Days = 2;
recurrence.StartDate = item.StartTime;
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the item by simply setting the Recurrence property
item.Recurrence = recurrence;
Visual Basic [image] Copy Code

' Create the recurrence so that the item occurs once every two days
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Daily
recurrence.Days = 2
recurrence.StartDate = item.StartTime
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the item by simply setting the Recurrence property
item.Recurrence = recurrence

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.RecurrenceState Property

Item.RecurrenceState Property
[image]

Gets the recurrence state of this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public RecurrenceState RecurrenceState { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property RecurrenceState As RecurrenceState

Property Value

A member of the RecurrenceState enumeration.

Remarks

Events raised by the Calendar control could pass as an argument an occurrence or an exception of a recurring item. This property lets you determine the exact state of the item's recurrence state.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Reminder Property

Item.Reminder Property
[image]

Gets or sets the reminder for this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract Reminder Reminder { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property Reminder As Reminder

Property Value

An instance of the Reminder class.

Remarks

If the reminder type is Exact, the ItemReminderTriggered event is raised at the time set in the reminder's Time property. If the reminder type is Leading, the ItemReminderTriggered event is raised certain amount of time prior to the item's StartTime, as specified in the reminder's TimeInterval property.

Note

Recurring items cannot have leading reminders.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Resources Property

Item.Resources Property
[image]

Gets references to all resources associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract ResourceCollection<Resource> Resources { get; }
Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Resources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection(Resource) class containing the resources associated with this item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.StartTime Property

Item.StartTime Property
[image]

Gets or sets the item's scheduled start time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract DateTime StartTime { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property StartTime As DateTime

Property Value

A .NET DateTime instance specifying the scheduled time for the item.

Remarks

This property affects the initial time cell occupied by the item when it is displayed in a Calendar view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
EndTime Property
AllDayEvent Property


MindFusion.Scheduling.Item.Tag Property

Item.Tag Property
[image]

Gets or sets custom data associated with the item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract Object Tag { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Task Property

Item.Task Property
[image]

Gets or sets the task associated with this item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract Task Task { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property Task As Task

Property Value

An instance of the Task class.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Visible Property

Item.Visible Property
[image]

Gets or sets a flag indicating whether the item is visible or not.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract bool Visible { get; set; }
Visual Basic [image] Copy Code

Public MustOverride Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false. The default is true.

Remarks

Invisible items are not drawn at all. You could use this property to hide an item temporarily, or to store additional data in a helper item object that always stays invisible.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Events

Item Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.PropertyChanged Event

Item.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged
Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Class

ItemCollection Class
[image]

Represents a strongly-typed collection of Item objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class ItemCollection : IList<Item>, ICollection<Item>, IEnumerable<Item>, IEnumerable, INotifyCollectionChanged
Visual Basic [image] Copy Code

Public NotInheritable Class ItemCollection
Implements IList(Of Item), ICollection(Of Item), IEnumerable(Of Item), IEnumerable, INotifyCollectionChanged

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.ItemCollection

See Also

ItemCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Members

ItemCollection Members
Constructors Properties Methods Events
[image]

Represents a strongly-typed collection of Item objects.

The following tables list the members exposed by the ItemCollection type.

Public Constructors

Name | Description
ItemCollection | Initializes a new instance of the ItemCollection class.

Public Properties

Name | Description
Count | Gets the number of items contained in the collection.
Item | Overloaded.

Public Methods

Name | Description
Add | Adds the specified item to this collection.
AddRange | Adds the specified items to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether the collection contains specific item.
IndexOf | Returns the zero-based index of the first occurrence of the specified item within this collection.
Insert | Inserts the specified item at the specified position within the collection.
Remove | Removes the first occurrence of the specified item from this collection.
RemoveAt | Removes the item at the specified index of this collection.

Public Events

Name | Description
CollectionChanged | Raised when the collection has been changed. Provides detailed information about what caused the changed.
ItemChanged | Raised when the collection has been changed.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Constructor

ItemCollection Constructor
[image]

Initializes a new instance of the ItemCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Methods

ItemCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified item to this collection.
AddRange | Adds the specified items to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether the collection contains specific item.
IndexOf | Returns the zero-based index of the first occurrence of the specified item within this collection.
Insert | Inserts the specified item at the specified position within the collection.
Remove | Removes the first occurrence of the specified item from this collection.
RemoveAt | Removes the item at the specified index of this collection.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Add Method

ItemCollection.Add Method
[image]

Adds the specified item to this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual void Add (
Item item
)
Visual Basic [image] Copy Code

Public Overridable Sub Add ( _
item As Item _
)

Parameters

item
An Item instance to be added to the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.AddRange Method

ItemCollection.AddRange Method
[image]

Adds the specified items to this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void AddRange (
IList<Item> items
)
Visual Basic [image] Copy Code

Public Sub AddRange ( _
items As IList(Of Item) _
)

Parameters

items
The list of items to add to this collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Clear Method

ItemCollection.Clear Method
[image]

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual void Clear ()
Visual Basic [image] Copy Code

Public Overridable Sub Clear ()

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Contains Method

ItemCollection.Contains Method
[image]

Determines whether the collection contains specific item.

Overload List

Name | Description
ItemCollection.Contains (Item) | Determines whether this collection contains the specified item.
ItemCollection.Contains (String) | Determines whether this collection contains an item identified by the specified string.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Contains Method (Item)

ItemCollection.Contains Method (Item)
See Also
[image]

Determines whether this collection contains the specified item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual bool Contains (
Item item
)
Visual Basic [image] Copy Code

Public Overridable Function Contains ( _
item As Item _
) As Boolean

Parameters

item
The item to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Contains Method (String)

ItemCollection.Contains Method (String)
See Also
[image]

Determines whether this collection contains an item identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool Contains (
string id
)
Visual Basic [image] Copy Code

Public Function Contains ( _
id As String _
) As Boolean

Parameters

id
The identifier of an item to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.IndexOf Method

ItemCollection.IndexOf Method
[image]

Returns the zero-based index of the first occurrence of the specified item within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual int IndexOf (
Item item
)
Visual Basic [image] Copy Code

Public Overridable Function IndexOf ( _
item As Item _
) As Integer

Parameters

item
The item to locate in the collection.

Return Value

The zero-based index of the first occurrence of the item within the collection, if found; otherwise, -1.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Insert Method

ItemCollection.Insert Method
[image]

Inserts the specified item at the specified position within the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual void Insert (
int index,
Item item
)
Visual Basic [image] Copy Code

Public Overridable Sub Insert ( _
index As Integer, _
item As Item _
)

Parameters

index
The zero-based index at which the item must be inserted.
item
An instance of the Item class to be added to the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Remove Method

ItemCollection.Remove Method
[image]

Removes the first occurrence of the specified item from this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Remove (
Item item
)
Visual Basic [image] Copy Code

Public Sub Remove ( _
item As Item _
)

Parameters

item
An instance of the Item class, which must be removed from the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.RemoveAt Method

ItemCollection.RemoveAt Method
[image]

Removes the item at the specified index of this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void RemoveAt (
int index
)
Visual Basic [image] Copy Code

Public Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The zero-based index of the item to remove.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Properties

ItemCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of items contained in the collection.
Item | Overloaded.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Count Property

ItemCollection.Count Property
[image]

Gets the number of items contained in the collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual int Count { get; }
Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Count As Integer

Property Value

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property

ItemCollection.Item Property
[image]

Overload List

Name | Description
ItemCollection.Item (Int32) | Gets or sets the item located at the specified position within this collection.
ItemCollection.Item (String) | Gets the item identified by the specified string.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property (Int32)

ItemCollection.Item Property (Int32)
See Also
[image]

Gets or sets the item located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual Item Item [
int index
] { get; set; }
Visual Basic [image] Copy Code

Public Overridable Property Item ( _
index As Integer _
) As Item

Parameters

index
The zero-based index of the item to get or set.

Property Value

See Also

Item Property Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property (String)

ItemCollection.Item Property (String)
See Also
[image]

Gets the item identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Item Item [
string id
] { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Item ( _
id As String _
) As Item

Parameters

id
The Id of the Item to get.

Property Value

The Item instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Events

ItemCollection Events
[image]

Public Events

Name | Description
CollectionChanged | Raised when the collection has been changed. Provides detailed information about what caused the changed.
ItemChanged | Raised when the collection has been changed.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.CollectionChanged Event

ItemCollection.CollectionChanged Event
[image]

Raised when the collection has been changed. Provides detailed information about what caused the changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event NotifyCollectionChangedEventHandler CollectionChanged
Visual Basic [image] Copy Code

Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Event Data

CollectionChanged event handlers receive an argument of type NotifyCollectionChangedEventArgs.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.ItemChanged Event

ItemCollection.ItemChanged Event
[image]

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler ItemChanged
Visual Basic [image] Copy Code

Public Event ItemChanged As EventHandler

Event Data

ItemChanged event handlers receive an argument of type EventArgs.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Class

ItemEventArgs Class
[image]

Contains the arguments passed to handlers of item related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.ItemTimeEventArgs
MindFusion.Scheduling.Silverlight.ItemConfirmEventArgs
MindFusion.Scheduling.Silverlight.ItemModifiedEventArgs
MindFusion.Scheduling.Silverlight.ItemMouseEventArgs
MindFusion.Scheduling.Silverlight.ItemSelectionEventArgs
MindFusion.Scheduling.Silverlight.RecurringItemConfirmEventArgs

See Also

ItemEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Members

ItemEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item related events raised by the Schedule class.

The following tables list the members exposed by the ItemEventArgs type.

Public Properties

Name | Description
Item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Properties

ItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs.Item Property

ItemEventArgs.Item Property
[image]

Gets the item related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Item Item { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class.

See Also

ItemEventArgs Members
ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemPresenterEventArgs Class

ItemPresenterEventArgs Class
[image]

Contains the arguments passed to handlers of item related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemPresenterEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class ItemPresenterEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemPresenterEventArgs

See Also

ItemPresenterEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemPresenterEventArgs Members

ItemPresenterEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item related events raised by the Schedule class.

The following tables list the members exposed by the ItemPresenterEventArgs type.

Public Properties

Name | Description
ItemPresenter | Gets the item presenter related to the event.

See Also

ItemPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemPresenterEventArgs Properties

ItemPresenterEventArgs Properties
[image]

Public Properties

Name | Description
ItemPresenter | Gets the item presenter related to the event.

See Also

ItemPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemPresenterEventArgs.ItemPresenter Property

ItemPresenterEventArgs.ItemPresenter Property
[image]

Gets the item presenter related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemPresenter ItemPresenter { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ItemPresenter As ItemPresenter

Property Value

An instance of the ItemPresenter class.

See Also

ItemPresenterEventArgs Members
ItemPresenterEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemState Class

ItemState Class
Remarks See Also
[image]

Encapsulates the state of an Item instance.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemState : IEquatable<ItemState>
Visual Basic [image] Copy Code

Public Class ItemState
Implements IEquatable(Of ItemState)

Remarks

Instances of this class are used to store the state of items for later undo or redo operations.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.ItemState

See Also

ItemState Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemState Members

ItemState Members
Constructors Methods
[image]

Encapsulates the state of an Item instance.

The following tables list the members exposed by the ItemState type.

Public Constructors

Name | Description
ItemState | Initializes a new instance of the ItemState class.

Public Methods

Name | Description
Equals | Indicates whether the current state is equal to the specified state.

See Also

ItemState Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemState Constructor

ItemState Constructor
[image]

Initializes a new instance of the ItemState class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemState ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

ItemState Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemState Methods

ItemState Methods
[image]

Public Methods

Name | Description
Equals | Indicates whether the current state is equal to the specified state.

See Also

ItemState Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemState.Equals Method

ItemState.Equals Method
[image]

Indicates whether the current state is equal to the specified state.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override bool Equals (
ItemState other
)
Visual Basic [image] Copy Code

Public Overrides Function Equals ( _
other As ItemState _
) As Boolean

Parameters

other
The state to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

See Also

ItemState Members
ItemState Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Class

ItemTimeEventArgs Class
[image]

Contains the arguments passed to handlers of time related events.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemTimeEventArgs : ItemEventArgs
Visual Basic [image] Copy Code

Public Class ItemTimeEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.ItemTimeEventArgs

See Also

ItemTimeEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Members

ItemTimeEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of time related events.

The following tables list the members exposed by the ItemTimeEventArgs type.

Public Properties

Name | Description
Time | Gets the old value of the time property whose change caused the event to occur.

See Also

ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Properties

ItemTimeEventArgs Properties
[image]

Public Properties

Name | Description
Time | Gets the old value of the time property whose change caused the event to occur.

See Also

ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs.Time Property

ItemTimeEventArgs.Time Property
[image]

Gets the old value of the time property whose change caused the event to occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime Time { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Time As DateTime

Property Value

An instance of the .NET DateTime class.

See Also

ItemTimeEventArgs Members
ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Class

Location Class
[image]

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class Location : Resource
Visual Basic [image] Copy Code

Public Class Location
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Location

See Also

Location Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Members

Location Members
Constructors Properties Methods
[image]

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

The following tables list the members exposed by the Location type.

Public Constructors

Name | Description
Location | Initializes a new instance of the Location class.

Public Properties

Name | Description
Address | Gets or sets the address of the location.
City | Gets or sets the city of this location.
Country | Gets or sets the country of this location.
State | Gets or sets the state of this location.
ZipCode | Gets or sets the zip-code of this location.

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Constructor

Location Constructor
[image]

Initializes a new instance of the Location class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Location ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Methods

Location Methods
[image]

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.LoadFrom Method (XElement, XmlSerializationContext)

Location.LoadFrom Method (XElement, XmlSerializationContext)
See Also
[image]

Loads location data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void LoadFrom (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Location.SaveTo Method (XElement, XmlSerializationContext)

Location.SaveTo Method (XElement, XmlSerializationContext)
See Also
[image]

Saves the location data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void SaveTo (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Location Properties

Location Properties
[image]

Public Properties

Name | Description
Address | Gets or sets the address of the location.
City | Gets or sets the city of this location.
Country | Gets or sets the country of this location.
State | Gets or sets the state of this location.
ZipCode | Gets or sets the zip-code of this location.

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.Address Property

Location.Address Property
[image]

Gets or sets the address of the location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Address { get; set; }
Visual Basic [image] Copy Code

Public Property Address As String

Property Value

A string specifying the address of this location. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
City Property
State Property
Country Property


MindFusion.Scheduling.Location.City Property

Location.City Property
[image]

Gets or sets the city of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string City { get; set; }
Visual Basic [image] Copy Code

Public Property City As String

Property Value

A string specifying the city where this location is located. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
Address Property
State Property
Country Property


MindFusion.Scheduling.Location.Country Property

Location.Country Property
[image]

Gets or sets the country of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Country { get; set; }
Visual Basic [image] Copy Code

Public Property Country As String

Property Value

A string specifying the country where this location is located. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
Address Property
City Property
State Property


MindFusion.Scheduling.Location.State Property

Location.State Property
[image]

Gets or sets the state of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string State { get; set; }
Visual Basic [image] Copy Code

Public Property State As String

Property Value

A string identifying the state where this location is. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
Address Property
City Property
Country Property


MindFusion.Scheduling.Location.ZipCode Property

Location.ZipCode Property
[image]

Gets or sets the zip-code of this location.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string ZipCode { get; set; }
Visual Basic [image] Copy Code

Public Property ZipCode As String

Property Value

A string containing the location's Zip code. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.MonthlyRecurrence Enumeration

MonthlyRecurrence Enumeration
[image]

Specifies the types of monthly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum MonthlyRecurrence
Visual Basic [image] Copy Code

Public Enumeration MonthlyRecurrence

Members

Member name | Description
ByDayNumber | The event occurs on a specific day of the month.
ByDayType | The event occurs on a specific type of day of the specified week of the month.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Occurrence Enumeration

Occurrence Enumeration
[image]

Specifies the occurrence number of a day or a week within a month.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum Occurrence
Visual Basic [image] Copy Code

Public Enumeration Occurrence

Members

Member name | Description
First | Indicates the first occurrence.
Fourth | Indicates the fourth occurrence.
Last | Indicates the last occurrence.
Second | Indicates the second occurrence.
Third | Indicates the third occurrence.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Class

Recurrence Class
[image]

Defines recurrence patterns for items scheduled to repeat over and over again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class Recurrence
Visual Basic [image] Copy Code

Public Class Recurrence

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Recurrence

See Also

Recurrence Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Members

Recurrence Members
Constructors Properties Methods
[image]

Defines recurrence patterns for items scheduled to repeat over and over again.

The following tables list the members exposed by the Recurrence type.

Public Constructors

Name | Description
Recurrence | Initializes a new instance of the Recurrence class.

Public Properties

Name | Description
DailyRecurrence | Gets or sets the type of daily recurrence.
Day | Gets or sets a value indicating on which day of a week the event occurs.
DayOfMonth | Gets or sets on which day of a month the event occurs.
Days | Gets or sets how many days should pass before the event occurs again.
DaysOfWeek | Gets or sets on which days of a week the event occurs.
EndDate | Gets or sets the end date of the recurrence.
Exceptions | Gets the list of all recurrence exceptions.
Interval | Gets or sets the recurrence interval.
Master | Gets the master item of this recurrence. The property returns null (Nothing in Visual Basic) if the recurrence is not associated with an item.
MonthlyRecurrence | Gets or sets the type of monthly recurrence.
MonthOfYear | Gets or sets in which month of the year the event occurs.
Months | Gets or sets how many months should pass before the event occurs again.
NumOccurrences | Gets or sets how many times the recurring event should occur.
Occurrence | Gets or sets on which occurrence of the day type specified in Day the event occurs.
Pattern | Gets or sets the recurrence pattern.
RecurrenceEnd | Gets or sets when the event should stop recurring.
StartDate | Gets or sets when the recurring event should occur for the first time.
Weeks | Gets or sets how many weeks should pass before the event occurs again.
YearlyRecurrence | Gets or sets the type of yearly recurrence.

Public Methods

Name | Description
ApplyPattern | Copies the fields of the specified Recurrence object to this recurrence.
ClearExceptions | Removes all exceptions of this recurrence.
Clone | Creates an exact copy of this Recurrence object.
GenerateItems | Creates occurrence items for this recurrence in the specified date range.
GetEndDate | Returns the end date for this recurrence.
GetOccurrence | Overloaded. Returns the occurrence having the specified index.
LoadFrom |
MarkException | Marks the specified item as an exception of a recurrence pattern.
SamePatternAs | Determines whether two Recurrence objects define the same recurrence pattern.
SaveTo |
ToString | Overloaded. Creates a string from this recurrence.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Constructor

Recurrence Constructor
[image]

Initializes a new instance of the Recurrence class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Recurrence ()
Visual Basic [image] Copy Code

Public Sub New ()

Example

The following example creates a new recurrence object and associates it with an existing appointment. The example assumes that the appointment referenced by app already exists.

C# [image] Copy Code

// Create a recurrence that happens at the third weekend
// every three months, effective July 14th, 2005.
// The recurrence is infinite
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Monthly;
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType;
recurrence.Occurrence = Occurrence.Third;
recurrence.Day = DayOfWeekType.Weekend;
recurrence.Months = 3;
recurrence.StartDate = new DateTime(2005, 7, 14);
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the appointment
app.Recurrence = recurrence;
Visual Basic [image] Copy Code

' Create a recurrence that happens at the third weekend
' every three months, effective July 14th, 2005.
' The recurrence is infinite
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Monthly
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType
recurrence.Occurrence = Occurrence.Third
recurrence.Day = DayOfWeekType.Weekend
recurrence.Months = 3
recurrence.StartDate = New DateTime(2005, 7, 14)
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the appointment
app.Recurrence = recurrence

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Methods

Recurrence Methods
[image]

Public Methods

Name | Description
ApplyPattern | Copies the fields of the specified Recurrence object to this recurrence.
ClearExceptions | Removes all exceptions of this recurrence.
Clone | Creates an exact copy of this Recurrence object.
GenerateItems | Creates occurrence items for this recurrence in the specified date range.
GetEndDate | Returns the end date for this recurrence.
GetOccurrence | Overloaded. Returns the occurrence having the specified index.
LoadFrom |
MarkException | Marks the specified item as an exception of a recurrence pattern.
SamePatternAs | Determines whether two Recurrence objects define the same recurrence pattern.
SaveTo |
ToString | Overloaded. Creates a string from this recurrence.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ApplyPattern Method

Recurrence.ApplyPattern Method
[image]

Copies the fields of the specified Recurrence object to this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void ApplyPattern (
Recurrence recurrence
)
Visual Basic [image] Copy Code

Public Sub ApplyPattern ( _
recurrence As Recurrence _
)

Parameters

recurrence
The Recurrence object whose fields to copy.

Remarks

This method behaves similarly to the Clone method except that it does not create a new object.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ClearExceptions Method

Recurrence.ClearExceptions Method
[image]

Removes all exceptions of this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void ClearExceptions ()
Visual Basic [image] Copy Code

Public Sub ClearExceptions ()

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Clone Method

Recurrence.Clone Method
[image]

Creates an exact copy of this Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual Object Clone ()
Visual Basic [image] Copy Code

Public Overridable Function Clone () As Object

Return Value

A new Recurrence object, cloned from this one.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
ApplyPattern Method


MindFusion.Scheduling.Recurrence.GenerateItems Method

Recurrence.GenerateItems Method
[image]

Creates occurrence items for this recurrence in the specified date range.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection GenerateItems (
DateTime startDate,
DateTime endDate
)
Visual Basic [image] Copy Code

Public Function GenerateItems ( _
startDate As DateTime, _
endDate As DateTime _
) As ItemCollection

Parameters

startDate
The range start date.
endDate
The range end date.

Return Value

A collection of Item instances representing each occurrence of the recurrent event in the specified date range.

Remarks

The Calendar control uses this method to generate item occurrences when a recurrent item must be displayed in the current view.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetEndDate Method

Recurrence.GetEndDate Method
[image]

Returns the end date for this recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime GetEndDate ()
Visual Basic [image] Copy Code

Public Function GetEndDate () As DateTime

Return Value

The end date of the recurrence if the recurrence is set to expire or DateTime.MaxValue otherwise.

Remarks

The end date is calculated from the specified repeat number if RecurrenceEnd is set to NumOccurrences.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method

Recurrence.GetOccurrence Method
[image]

Returns the occurrence having the specified index.

Overload List

Name | Description
Recurrence.GetOccurrence (Int32, Boolean@) | Returns the occurrence having the specified index.
Recurrence.GetOccurrence (Int32, Boolean@, Boolean) | Returns the occurrence having the specified index.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Boolean@)

Recurrence.GetOccurrence Method (Int32, Boolean@)
See Also
[image]

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index,
ref bool isDeleted
)
Visual Basic [image] Copy Code

Public Function GetOccurrence ( _
index As Integer, _
ByRef isDeleted As Boolean _
) As Item

Parameters

index
The index of the occurrence to retrieve.
isDeleted
If the specified occurrence is an exception, this parameter contains upon function completion whether the exception is deleted or not.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, Boolean@, Boolean)

Recurrence.GetOccurrence Method (Int32, Boolean@, Boolean)
See Also
[image]

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Item GetOccurrence (
int index,
ref bool isDeleted,
bool noException
)
Visual Basic [image] Copy Code

Public Function GetOccurrence ( _
index As Integer, _
ByRef isDeleted As Boolean, _
noException As Boolean _
) As Item

Parameters

index
The index of the occurrence to retrieve.
isDeleted
If the specified occurrence is an exception, this parameter contains upon function completion whether the exception is deleted or not.
noException
Specifies whether to return the original item, in case this occurrence is an exception.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.LoadFrom Method (XElement, XmlSerializationContext)

Recurrence.LoadFrom Method (XElement, XmlSerializationContext)
See Also
[image]

Loads the recurrence data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void LoadFrom (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

Loads the state of a recurrence from an XML document, where it was previously saved via SaveTo.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Recurrence.MarkException Method

Recurrence.MarkException Method
[image]

Marks the specified item as an exception of a recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void MarkException (
Item item,
bool deleted
)
Visual Basic [image] Copy Code

Public Sub MarkException ( _
item As Item, _
deleted As Boolean _
)

Parameters

item
The Item instance to be marked as an exception.
deleted
Specifies whether the exception is created by deleting one occurrence from the recurrent pattern or by changing the occurrence time properties.

Remarks

The Calendar control calls this method when a user drags an occurrence item or edits its text, thus creating an exception of the recurrence.

Example

The following example deletes the occurrences of an existing recurrence that are located in the specified date interval. The example assumes that recurrence identifies an existing Recurrence object.

C# [image] Copy Code

ItemCollection items =
recurrence.GenerateItems(new DateTime(2005, 1, 1), new DateTime(2005, 12, 31));

foreach (Item item in items)
recurrence.MarkException(item, true);
Visual Basic [image] Copy Code

Dim items As ItemCollection = _
recurrence.GenerateItems(New DateTime(2005, 1, 1), New DateTime(2005, 12, 31))

Dim item as Item
For Each item in items
recurrence.MarkException(item, True)
Next item

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.SamePatternAs Method

Recurrence.SamePatternAs Method
[image]

Determines whether two Recurrence objects define the same recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool SamePatternAs (
Recurrence recurrence
)
Visual Basic [image] Copy Code

Public Function SamePatternAs ( _
recurrence As Recurrence _
) As Boolean

Parameters

recurrence
A Recurrence object to compare with this recurrence.

Return Value

true if the Recurrence instances represent the same recurrence patterns; otherwise false.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.SaveTo Method (XElement, XmlSerializationContext)

Recurrence.SaveTo Method (XElement, XmlSerializationContext)
See Also
[image]

Saves the recurrence data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SaveTo (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Sub SaveTo ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The recurrence properties are saved as elements of an XML document, and can be later restored using the LoadFrom method.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Recurrence.ToString Method

Recurrence.ToString Method
[image]

Creates a string from this recurrence.

Overload List

Name | Description
Recurrence.ToString () | Creates a string from this recurrence using the date and time formatting information defined in the current culture.
Recurrence.ToString (DateTimeFormatInfo) | Creates a string from this recurrence using the specified date and time formatting.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ToString Method ()

Recurrence.ToString Method ()
See Also
[image]

Creates a string from this recurrence using the date and time formatting information defined in the current culture.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override string ToString ()
Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representation of the recurrence object.

See Also

ToString Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ToString Method (DateTimeFormatInfo)

Recurrence.ToString Method (DateTimeFormatInfo)
See Also
[image]

Creates a string from this recurrence using the specified date and time formatting.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string ToString (
DateTimeFormatInfo info
)
Visual Basic [image] Copy Code

Public Function ToString ( _
info As DateTimeFormatInfo _
) As String

Parameters

info
Defines how date and time values are formatted and displayed.

Return Value

A string representation of the recurrence object.

See Also

ToString Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Properties

Recurrence Properties
[image]

Public Properties

Name | Description
DailyRecurrence | Gets or sets the type of daily recurrence.
Day | Gets or sets a value indicating on which day of a week the event occurs.
DayOfMonth | Gets or sets on which day of a month the event occurs.
Days | Gets or sets how many days should pass before the event occurs again.
DaysOfWeek | Gets or sets on which days of a week the event occurs.
EndDate | Gets or sets the end date of the recurrence.
Exceptions | Gets the list of all recurrence exceptions.
Interval | Gets or sets the recurrence interval.
Master | Gets the master item of this recurrence. The property returns null (Nothing in Visual Basic) if the recurrence is not associated with an item.
MonthlyRecurrence | Gets or sets the type of monthly recurrence.
MonthOfYear | Gets or sets in which month of the year the event occurs.
Months | Gets or sets how many months should pass before the event occurs again.
NumOccurrences | Gets or sets how many times the recurring event should occur.
Occurrence | Gets or sets on which occurrence of the day type specified in Day the event occurs.
Pattern | Gets or sets the recurrence pattern.
RecurrenceEnd | Gets or sets when the event should stop recurring.
StartDate | Gets or sets when the recurring event should occur for the first time.
Weeks | Gets or sets how many weeks should pass before the event occurs again.
YearlyRecurrence | Gets or sets the type of yearly recurrence.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DailyRecurrence Property

Recurrence.DailyRecurrence Property
[image]

Gets or sets the type of daily recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DailyRecurrence DailyRecurrence { get; set; }
Visual Basic [image] Copy Code

Public Property DailyRecurrence As DailyRecurrence

Property Value

A member of the DailyRecurrence enumeration.

Remarks

This value is used when the recurrence Pattern is set to Daily.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Day Property

Recurrence.Day Property
[image]

Gets or sets a value indicating on which day of a week the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DayOfWeekType Day { get; set; }
Visual Basic [image] Copy Code

Public Property Day As DayOfWeekType

Property Value

A member of the DayOfWeekType enumeration.

Remarks

This value is used when the recurrence Pattern is set to Monthly or Yearly and MonthlyRecurrence or YearlyRecurrence are set to ByDayType.

Example

The following example creates a new recurrence object and associates it with an existing appointment. The example assumes that the appointment referenced by app already exists.

C# [image] Copy Code

// Create a recurrence that happens at the third weekend
// every three months, effective July 14th, 2005.
// The recurrence is infinite
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Monthly;
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType;
recurrence.Occurrence = Occurrence.Third;
recurrence.Day = DayOfWeekType.Weekend;
recurrence.Months = 3;
recurrence.StartDate = new DateTime(2005, 7, 14);
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the appointment
app.Recurrence = recurrence;
Visual Basic [image] Copy Code

' Create a recurrence that happens at the third weekend
' every three months, effective July 14th, 2005.
' The recurrence is infinite
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Monthly
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType
recurrence.Occurrence = Occurrence.Third
recurrence.Day = DayOfWeekType.Weekend
recurrence.Months = 3
recurrence.StartDate = New DateTime(2005, 7, 14)
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the appointment
app.Recurrence = recurrence

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DayOfMonth Property

Recurrence.DayOfMonth Property
[image]

Gets or sets on which day of a month the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int DayOfMonth { get; set; }
Visual Basic [image] Copy Code

Public Property DayOfMonth As Integer

Property Value

An integer vale specifying at which month the recurring event occurs. The allowed values range from 1 to 31.

Remarks

This value is used when the recurrence Pattern is set to Monthly or Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Days Property

Recurrence.Days Property
[image]

Gets or sets how many days should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int Days { get; set; }
Visual Basic [image] Copy Code

Public Property Days As Integer

Property Value

An integer value specifying the number of days between event occurrences. The minimal allowed value is 1.

Remarks

This value is used when the recurrence Pattern is set to Daily.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DaysOfWeek Property

Recurrence.DaysOfWeek Property
[image]

Gets or sets on which days of a week the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DaysOfWeek DaysOfWeek { get; set; }
Visual Basic [image] Copy Code

Public Property DaysOfWeek As DaysOfWeek

Property Value

A member of the DaysOfWeek enumeration.

Remarks

This value is used when the recurrence Pattern is set to Weekly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.EndDate Property

Recurrence.EndDate Property
[image]

Gets or sets the end date of the recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime EndDate { get; set; }
Visual Basic [image] Copy Code

Public Property EndDate As DateTime

Property Value

A .NET DateTime object specifying the end date of the recurring event.

Remarks

This property is considered by the recurrence only if the RecurrenceEnd is set to EndDate.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Exceptions Property

Recurrence.Exceptions Property
[image]

Gets the list of all recurrence exceptions.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ICollection Exceptions { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Exceptions As ICollection

Property Value

A .NET ICollection containing the exceptions generated for this recurrence.

Example

The following example traverses all deleted occurrences of a recurrence. The example assumes that recurrence references an existing Recurrence object.

C# [image] Copy Code

foreach (RecurrenceException exception in recurrence.Exceptions)
{
if (exception.IsDeleted)
{
// Do something here
}
}
Visual Basic [image] Copy Code

For Each exception As RecurrenceException in recurrence.Exceptions

If exception.IsDeleted Then

' Do something here

End If

Next

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Interval Property

Recurrence.Interval Property
[image]

Gets or sets the recurrence interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimeSpan Interval { get; set; }
Visual Basic [image] Copy Code

Public Property Interval As TimeSpan

Property Value

A .NET TimeSpan value indicating the time interval between recurring items.

Remarks

This value is used when the recurrence Pattern is set to ByTimeInterval.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Master Property

Recurrence.Master Property
[image]

Gets the master item of this recurrence. The property returns null (Nothing in Visual Basic) if the recurrence is not associated with an item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Item Master { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Master As Item

Property Value

A reference to the schedule item whose recurrence is defined by this object.

Remarks

To associate a recurrence with an item, set a reference to a Recurrence object to the item's Recurrence property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.MonthlyRecurrence Property

Recurrence.MonthlyRecurrence Property
[image]

Gets or sets the type of monthly recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public MonthlyRecurrence MonthlyRecurrence { get; set; }
Visual Basic [image] Copy Code

Public Property MonthlyRecurrence As MonthlyRecurrence

Property Value

A member of the MonthlyRecurrence enumeration.

Remarks

This value is used when the recurrence Pattern is set to Monthly.

Example

The following example creates a new recurrence object and associates it with an existing appointment. The example assumes that the appointment referenced by app already exists.

C# [image] Copy Code

// Create a recurrence that happens at the third weekend
// every three months, effective July 14th, 2005.
// The recurrence is infinite
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Monthly;
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType;
recurrence.Occurrence = Occurrence.Third;
recurrence.Day = DayOfWeekType.Weekend;
recurrence.Months = 3;
recurrence.StartDate = new DateTime(2005, 7, 14);
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the appointment
app.Recurrence = recurrence;
Visual Basic [image] Copy Code

' Create a recurrence that happens at the third weekend
' every three months, effective July 14th, 2005.
' The recurrence is infinite
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Monthly
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType
recurrence.Occurrence = Occurrence.Third
recurrence.Day = DayOfWeekType.Weekend
recurrence.Months = 3
recurrence.StartDate = New DateTime(2005, 7, 14)
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the appointment
app.Recurrence = recurrence

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.MonthOfYear Property

Recurrence.MonthOfYear Property
[image]

Gets or sets in which month of the year the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int MonthOfYear { get; set; }
Visual Basic [image] Copy Code

Public Property MonthOfYear As Integer

Property Value

An integer value specifying at which month the event occurs. The allowed values range from 1 to 12.

Remarks

The value of this property is used when the recurrence Pattern is set to Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Months Property

Recurrence.Months Property
[image]

Gets or sets how many months should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int Months { get; set; }
Visual Basic [image] Copy Code

Public Property Months As Integer

Property Value

An integer value specifying the number of days between event occurrences. The minimal allowed value is 1.

Remarks

The value of this property is used when the recurrence Pattern is set to Monthly.

Example

The following example creates a new recurrence object and associates it with an existing appointment. The example assumes that the appointment referenced by app already exists.

C# [image] Copy Code

// Create a recurrence that happens at the third weekend
// every three months, effective July 14th, 2005.
// The recurrence is infinite
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Monthly;
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType;
recurrence.Occurrence = Occurrence.Third;
recurrence.Day = DayOfWeekType.Weekend;
recurrence.Months = 3;
recurrence.StartDate = new DateTime(2005, 7, 14);
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the appointment
app.Recurrence = recurrence;
Visual Basic [image] Copy Code

' Create a recurrence that happens at the third weekend
' every three months, effective July 14th, 2005.
' The recurrence is infinite
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Monthly
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType
recurrence.Occurrence = Occurrence.Third
recurrence.Day = DayOfWeekType.Weekend
recurrence.Months = 3
recurrence.StartDate = New DateTime(2005, 7, 14)
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the appointment
app.Recurrence = recurrence

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.NumOccurrences Property

Recurrence.NumOccurrences Property
[image]

Gets or sets how many times the recurring event should occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int NumOccurrences { get; set; }
Visual Basic [image] Copy Code

Public Property NumOccurrences As Integer

Property Value

An integer value specifying the number of occurrences. The allowed values range from 1 to 999.

Remarks

The value of this property is used when the RecurrenceEnd is set to NumOccurrences.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Occurrence Property

Recurrence.Occurrence Property
[image]

Gets or sets on which occurrence of the day type specified in Day the event occurs.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Occurrence Occurrence { get; set; }
Visual Basic [image] Copy Code

Public Property Occurrence As Occurrence

Property Value

A member of the Occurrence enumeration.

Remarks

The value of this property is used when the recurrence Pattern is set to Monthly or Yearly and MonthlyRecurrence or YearlyRecurrence are set to ByDayType.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Pattern Property

Recurrence.Pattern Property
[image]

Gets or sets the recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public RecurrencePattern Pattern { get; set; }
Visual Basic [image] Copy Code

Public Property Pattern As RecurrencePattern

Property Value

A member of the RecurrencePattern enumeration.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.RecurrenceEnd Property

Recurrence.RecurrenceEnd Property
[image]

Gets or sets when the event should stop recurring.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public RecurrenceEnd RecurrenceEnd { get; set; }
Visual Basic [image] Copy Code

Public Property RecurrenceEnd As RecurrenceEnd

Property Value

A member of the RecurrenceEnd enumeration.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
EndDate Property
NumOccurrences Property


MindFusion.Scheduling.Recurrence.StartDate Property

Recurrence.StartDate Property
[image]

Gets or sets when the recurring event should occur for the first time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime StartDate { get; set; }
Visual Basic [image] Copy Code

Public Property StartDate As DateTime

Property Value

A .NET DateTime object specifying the recurrence start date.

Remarks

The time properties set in a recurrence object override the time properties of a schedule item to which the recurrence is assigned. The Calendar control displays "occurrence" items corresponding to the recurring master item. The first occurrence is displayed in the date cell specified in this property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Weeks Property

Recurrence.Weeks Property
[image]

Gets or sets how many weeks should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int Weeks { get; set; }
Visual Basic [image] Copy Code

Public Property Weeks As Integer

Property Value

An integer value specifying the number of weeks between event occurrences. The minimal allowed value is 1.

Remarks

This value is used when the recurrence Pattern is set to Weekly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.YearlyRecurrence Property

Recurrence.YearlyRecurrence Property
[image]

Gets or sets the type of yearly recurrence.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public YearlyRecurrence YearlyRecurrence { get; set; }
Visual Basic [image] Copy Code

Public Property YearlyRecurrence As YearlyRecurrence

Property Value

A member of the YearlyRecurrence enumeration.

Remarks

The value of this property is used when the recurrence Pattern is set to Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceEnd Enumeration

RecurrenceEnd Enumeration
[image]

Specifies when to stop repeating recurring events.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum RecurrenceEnd
Visual Basic [image] Copy Code

Public Enumeration RecurrenceEnd

Members

Member name | Description
EndDate | The recurrence ends at a specified date.
Never | Never stop repeating events.
NumOccurrences | Stop repeating events after a specified number of occurrences.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Class

RecurrenceException Class
[image]

This class represents exceptions of a recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class RecurrenceException
Visual Basic [image] Copy Code

Public Class RecurrenceException

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.RecurrenceException

See Also

RecurrenceException Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Members

RecurrenceException Members
Properties
[image]

This class represents exceptions of a recurrence patterns.

The following tables list the members exposed by the RecurrenceException type.

Public Properties

Name | Description
IsDeleted | Gets or sets a value indicating whether this particular occurrence has been deleted.
Item | Gets the item representing the recurrence exception.

See Also

RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Properties

RecurrenceException Properties
[image]

Public Properties

Name | Description
IsDeleted | Gets or sets a value indicating whether this particular occurrence has been deleted.
Item | Gets the item representing the recurrence exception.

See Also

RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException.IsDeleted Property

RecurrenceException.IsDeleted Property
[image]

Gets or sets a value indicating whether this particular occurrence has been deleted.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool IsDeleted { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property IsDeleted As Boolean

Property Value

true if this exception identifies a deleted occurrence; otherwise, false.

See Also

RecurrenceException Members
RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException.Item Property

RecurrenceException.Item Property
[image]

Gets the item representing the recurrence exception.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Item Item { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the item class representing the schedule item for which this exception is defined.

See Also

RecurrenceException Members
RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrencePattern Enumeration

RecurrencePattern Enumeration
[image]

Specifies the interval at which recurring items occur.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum RecurrencePattern
Visual Basic [image] Copy Code

Public Enumeration RecurrencePattern

Members

Member name | Description
ByTimeInterval | Repeats an item over a specified time interval.
Daily | Repeats an item every day.
Monthly | Repeats an item every month.
Weekly | Repeats an item every week.
Yearly | Repeats an item every year.

Remarks

These values can be assigned to the Pattern property of the Recurrence class.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceState Enumeration

RecurrenceState Enumeration
[image]

Specifies the recurrence state of items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum RecurrenceState
Visual Basic [image] Copy Code

Public Enumeration RecurrenceState

Members

Member name | Description
Exception | Specifies an exception of a recurring event.
Master | Specifies a recurring event.
None | Specifies an one-time non-recurring event.
Occurrence | Specifies a single occurrence of a recurring event.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Class

Reminder Class
[image]

Represents reminders associated with schedule items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class Reminder
Visual Basic [image] Copy Code

Public NotInheritable Class Reminder

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reminder

See Also

Reminder Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Members

Reminder Members
Constructors Fields Properties Methods
[image]

Represents reminders associated with schedule items.

The following tables list the members exposed by the Reminder type.

Public Constructors

Name | Description
Reminder | Initializes a new instance of the Reminder class.

Public Fields

Name | Description
MaxInterval | The maximum time interval that can be set as value of TimeInterval for a Reminder object.

Public Properties

Name | Description
Message | Gets or sets the message to display as a reminder.
PlaySound | Gets or sets a value indicating whether to play a sound when the reminder is triggered.
SoundFileName | Gets or sets the name of a sound file to play with this reminder.
Time | Gets or sets the exact time when to trigger the reminder.
TimeInterval | Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.
Type | Gets or sets the type of this reminder.

Public Methods

Name | Description
Clone | Clones this Reminder object.
LoadFrom |
SaveTo |

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Fields

Reminder Fields
[image]

Public Fields

Name | Description
MaxInterval | The maximum time interval that can be set as value of TimeInterval for a Reminder object.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.MaxInterval Field

Reminder.MaxInterval Field
[image]

The maximum time interval that can be set as value of TimeInterval for a Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly TimeSpan MaxInterval
Visual Basic [image] Copy Code

Public Shared ReadOnly MaxInterval As TimeSpan

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Constructor

Reminder Constructor
[image]

Initializes a new instance of the Reminder class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Reminder ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Methods

Reminder Methods
[image]

Public Methods

Name | Description
Clone | Clones this Reminder object.
LoadFrom |
SaveTo |

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Clone Method

Reminder.Clone Method
[image]

Clones this Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual Object Clone ()
Visual Basic [image] Copy Code

Public Overridable Function Clone () As Object

Return Value

An exact copy of this reminder.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.LoadFrom Method (XElement, XmlSerializationContext)

Reminder.LoadFrom Method (XElement, XmlSerializationContext)
See Also
[image]

Loads reminder data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void LoadFrom (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads the reminder fields from an XML document, where they were previously saved via SaveTo.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Reminder.SaveTo Method (XElement, XmlSerializationContext)

Reminder.SaveTo Method (XElement, XmlSerializationContext)
See Also
[image]

Saves the reminder data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SaveTo (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Sub SaveTo ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saved the reminder object fields as elements in a XML document. They can be restored later using the LoadFrom method.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Reminder Properties

Reminder Properties
[image]

Public Properties

Name | Description
Message | Gets or sets the message to display as a reminder.
PlaySound | Gets or sets a value indicating whether to play a sound when the reminder is triggered.
SoundFileName | Gets or sets the name of a sound file to play with this reminder.
Time | Gets or sets the exact time when to trigger the reminder.
TimeInterval | Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.
Type | Gets or sets the type of this reminder.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Message Property

Reminder.Message Property
[image]

Gets or sets the message to display as a reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Message { get; set; }
Visual Basic [image] Copy Code

Public Property Message As String

Property Value

A string containing the message text.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.PlaySound Property

Reminder.PlaySound Property
[image]

Gets or sets a value indicating whether to play a sound when the reminder is triggered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool PlaySound { get; set; }
Visual Basic [image] Copy Code

Public Property PlaySound As Boolean

Property Value

true to play the sound file; otherwise, false.

Remarks

The path to the sound file can be set in the SoundFileName property.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.SoundFileName Property

Reminder.SoundFileName Property
[image]

Gets or sets the name of a sound file to play with this reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string SoundFileName { get; set; }
Visual Basic [image] Copy Code

Public Property SoundFileName As String

Property Value

A string specifying which file to play.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Time Property

Reminder.Time Property
[image]

Gets or sets the exact time when to trigger the reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime Time { get; set; }
Visual Basic [image] Copy Code

Public Property Time As DateTime

Property Value

A .NET DateTime object specifying when the reminder should be triggered.

Remarks

The value of this property is considered only if the Type of the reminder is set to Exact.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.TimeInterval Property

Reminder.TimeInterval Property
[image]

Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimeSpan TimeInterval { get; set; }
Visual Basic [image] Copy Code

Public Property TimeInterval As TimeSpan

Property Value

A .NET TimeSpan instance specifying how much time before event's scheduled time to trigger the reminder.

Remarks

The value of this property is considered only if the Type of the reminder is set to Leading.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Type Property

Reminder.Type Property
[image]

Gets or sets the type of this reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ReminderType Type { get; set; }
Visual Basic [image] Copy Code

Public Property Type As ReminderType

Property Value

A member of the ReminderType enumeration specifying the reminder type.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ReminderType Enumeration

ReminderType Enumeration
[image]

Specifies the type of a reminder.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum ReminderType
Visual Basic [image] Copy Code

Public Enumeration ReminderType

Members

Member name | Description
Exact | Trigger the reminder at the exact time specified in its Date property. Note: Recurring items cannot have exact reminders.
Leading | Trigger the reminder at the specified TimeInterval before the item's scheduled start time. Note: Tasks cannot have leading reminders.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand Class

RemoveItemCommand Class
[image]

Implements deletion of schedule items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class RemoveItemCommand : Command
Visual Basic [image] Copy Code

Public Class RemoveItemCommand
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Command
MindFusion.Scheduling.RemoveItemCommand

See Also

RemoveItemCommand Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand Members

RemoveItemCommand Members
Constructors Methods
[image]

Implements deletion of schedule items.

The following tables list the members exposed by the RemoveItemCommand type.

Public Constructors

Name | Description
RemoveItemCommand | Initializes a new instance of the RemoveItemCommand class.

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand Constructor

RemoveItemCommand Constructor
[image]

Initializes a new instance of the RemoveItemCommand class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public RemoveItemCommand (
Schedule schedule,
Item item,
int index
)
Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
item As Item, _
index As Integer _
)

Parameters

schedule
The Schedule from which the item is removed.
item
The Item that should be removed from the schedule.
index
The index of the item being removed.

See Also

RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand Methods

RemoveItemCommand Methods
[image]

Protected Methods

Name | Description
Execute | Command.Execute override.
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand.Execute Method

RemoveItemCommand.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual bool Execute ()
Visual Basic [image] Copy Code

Protected Overridable Function Execute () As Boolean

Return Value

This method always returns true.

See Also

RemoveItemCommand Members
RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand.Redo Method

RemoveItemCommand.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void Redo ()
Visual Basic [image] Copy Code

Protected Overridable Sub Redo ()

See Also

RemoveItemCommand Members
RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RemoveItemCommand.Undo Method

RemoveItemCommand.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void Undo ()
Visual Basic [image] Copy Code

Protected Overridable Sub Undo ()

See Also

RemoveItemCommand Members
RemoveItemCommand Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Class

Resource Class
[image]

Instances of the Resource class contain information about arbitrary resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class Resource
Visual Basic [image] Copy Code

Public Class Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Contact
MindFusion.Scheduling.Location
MindFusion.Scheduling.Task

See Also

Resource Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Members

Resource Members
Constructors Properties Methods
[image]

Instances of the Resource class contain information about arbitrary resources.

The following tables list the members exposed by the Resource type.

Public Constructors

Name | Description
Resource | Initializes a new instance of the Resource class.

Public Properties

Name | Description
Id | Gets or sets the string identifier of this resource.
Name | Gets or sets the name of the resource.
Tag | Gets or sets custom data associated with the resource.

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Constructor

Resource Constructor
[image]

Initializes a new instance of the Resource class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Resource ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Methods

Resource Methods
[image]

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.LoadFrom Method (XElement, XmlSerializationContext)

Resource.LoadFrom Method (XElement, XmlSerializationContext)
See Also
[image]

Loads resource data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual void LoadFrom (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overridable Sub LoadFrom ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The reader parameter wraps an XML document that contains data stored by a previous call to the SaveTo method.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Resource.SaveTo Method (XElement, XmlSerializationContext)

Resource.SaveTo Method (XElement, XmlSerializationContext)
See Also
[image]

Saves the resource data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual void SaveTo (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overridable Sub SaveTo ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the resource properties as elements of an XML document.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Resource Properties

Resource Properties
[image]

Public Properties

Name | Description
Id | Gets or sets the string identifier of this resource.
Name | Gets or sets the name of the resource.
Tag | Gets or sets custom data associated with the resource.

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Id Property

Resource.Id Property
[image]

Gets or sets the string identifier of this resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Id { get; set; }
Visual Basic [image] Copy Code

Public Property Id As String

Property Value

A string value identifying uniquely this resource instance.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Name Property

Resource.Name Property
[image]

Gets or sets the name of the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Name { get; set; }
Visual Basic [image] Copy Code

Public Property Name As String

Property Value

A string containing the name of the resource. The default is an empty string.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Tag Property

Resource.Tag Property
[image]

Gets or sets custom data associated with the resource.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Object Tag { get; set; }
Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection(T) Class

ResourceCollection(T) Class
[image]

Represents a strongly-typed collection of Resource-derived objects.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class ResourceCollection<T> : ObservableCollection<T> where T : Resource
Visual Basic [image] Copy Code

Public NotInheritable Class ResourceCollection(Of T As Resource)
Inherits ObservableCollection(Of T)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(T)
System.Collections.ObjectModel.ObservableCollection(T)
MindFusion.Scheduling.ResourceCollection(T)

See Also

ResourceCollection(T) Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection(T) Members

ResourceCollection(T) Members
Constructors Properties
[image]

Represents a strongly-typed collection of Resource-derived objects.

The following tables list the members exposed by the ResourceCollection(T) type.

Public Constructors

Name | Description
ResourceCollection | Initializes a new instance of the ResourceCollection class.

Public Properties

Name | Description
Item | Gets the Resource identified by the specified string.

See Also

ResourceCollection(T) Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection(T) Constructor

ResourceCollection(T) Constructor
[image]

Initializes a new instance of the ResourceCollection class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<T> ()
Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

ResourceCollection(T) Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection(T) Properties

ResourceCollection(T) Properties
[image]

Public Properties

Name | Description
Item | Gets the Resource identified by the specified string.

See Also

ResourceCollection(T) Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection(T).Item Property

ResourceCollection(T).Item Property
[image]

Gets the Resource identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public T Item [
string id
] { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Item ( _
id As String _
) As T

Parameters

id
The Id of the Resource to get.

Property Value

The Resource instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

ResourceCollection(T) Members
ResourceCollection(T) Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Class

Schedule Class
[image]

Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class Schedule
Visual Basic [image] Copy Code

Public Class Schedule

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Schedule

See Also

Schedule Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Members

Schedule Members
Constructors Fields Properties Methods Events
[image]

Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.

The following tables list the members exposed by the Schedule type.

Public Constructors

Name | Description
Schedule | Initializes a new instance of the Schedule class.

Public Fields

Name | Description
CurrentVersion | The current version of schedule file format.

Public Properties

Name | Description
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone.
Contacts | Gets all contacts defined in the Schedule.
Items | Gets all scheduled items.
Locations | Gets all locations defined in the Schedule.
Resources | Gets all resources defined in the Schedule.
Tasks | Gets all tasks defined in this Schedule.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

Public Methods

Name | Description
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.
Clear | Clears all items, tasks, locations, contacts and resources contained in this schedule.
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.
ExecuteCommand | Executes the specified command on this schedule.
GetAllItems | Overloaded. Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
GetFreePeriod | Overloaded. Returns the next period with the specified duration after the specified date, which is not occupied by items.
GetItemsToRemindOf | Overloaded. Retrieves a collection of all items that must be reminded of.
GetTasksToRemindOf | Overloaded.
IsClassRegistered | Overloaded.
LoadFrom | Overloaded.
LoadFromXml |
Redo | Executes again an action saved in the command history.
RegisterItemClass | Registers a schedule item class for serialization support.
RegisterResourceClass | Registers a resource class for serialization support.
SaveTo | Overloaded.
SaveToXml |
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
Undo | Undoes an action saved in the command history.
UnregisterClass | Overloaded. Unregisters the item or resource with the specified class identifier or type from the system.

Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnDeserializeTag | Raises the DeserializeTag event.
OnInstantiateItem | Raises the InstantiateItem event.
OnInstantiateResource | Raises the InstantiateResource event.
OnItemEndTimeTriggered | Raises the ItemEndTimeTriggered event.
OnItemReminderTriggered | Raises the ItemReminderTriggered event.
OnSerializeTag | Raises the SerializeTag event.
OnTaskReminderTriggered | Raises the TaskReminderTriggered event.

Public Events

Name | Description
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
Changed | Raised when items are added or removed from the schedule or when the schedule is loaded.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.
InstantiateItem | Raised when deserializing a custom item whose type has not been registered.
InstantiateResource | Raised when deserializing a custom resource whose type has not been registered.
ItemEndTimeTriggered | Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.
ItemReminderTriggered | Raised when the reminder for an item is triggered.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.
TaskReminderTriggered | Raised when the reminder for a task is triggered.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Fields

Schedule Fields
[image]

Public Fields

Name | Description
CurrentVersion | The current version of schedule file format.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.CurrentVersion Field

Schedule.CurrentVersion Field
[image]

The current version of schedule file format.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static int CurrentVersion
Visual Basic [image] Copy Code

Public Shared CurrentVersion As Integer

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Constructor

Schedule Constructor
[image]

Initializes a new instance of the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Schedule ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Methods

Schedule Methods
[image]

Public Methods

Name | Description
CancelCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.
Clear | Clears all items, tasks, locations, contacts and resources contained in this schedule.
CommitCompositeOperation | Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.
ExecuteCommand | Executes the specified command on this schedule.
GetAllItems | Overloaded. Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
GetFreePeriod | Overloaded. Returns the next period with the specified duration after the specified date, which is not occupied by items.
GetItemsToRemindOf | Overloaded. Retrieves a collection of all items that must be reminded of.
GetTasksToRemindOf | Overloaded.
IsClassRegistered | Overloaded.
LoadFrom | Overloaded.
LoadFromXml |
Redo | Executes again an action saved in the command history.
RegisterItemClass | Registers a schedule item class for serialization support.
RegisterResourceClass | Registers a resource class for serialization support.
SaveTo | Overloaded.
SaveToXml |
StartCompositeOperation | Starts recording undo/redo commands into a CompositeCommand.
Undo | Undoes an action saved in the command history.
UnregisterClass | Overloaded. Unregisters the item or resource with the specified class identifier or type from the system.

Protected Methods

Name | Description
OnActionRedone | Raises the ActionRedone event.
OnActionUndone | Raises the ActionUndone event.
OnDeserializeTag | Raises the DeserializeTag event.
OnInstantiateItem | Raises the InstantiateItem event.
OnInstantiateResource | Raises the InstantiateResource event.
OnItemEndTimeTriggered | Raises the ItemEndTimeTriggered event.
OnItemReminderTriggered | Raises the ItemReminderTriggered event.
OnSerializeTag | Raises the SerializeTag event.
OnTaskReminderTriggered | Raises the TaskReminderTriggered event.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.CancelCompositeOperation Method

Schedule.CancelCompositeOperation Method
[image]

Stops recording undo/redo commands into a CompositeCommand and discards the records created so far.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void CancelCompositeOperation ()
Visual Basic [image] Copy Code

Public Sub CancelCompositeOperation ()

Remarks

You must call either CommitCompositeOperation or this method when the schedule modifications are done after a StartCompositeOperation call.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
UndoEnabled Property


MindFusion.Scheduling.Schedule.Clear Method

Schedule.Clear Method
[image]

Clears all items, tasks, locations, contacts and resources contained in this schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Clear ()
Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Contacts Property
Items Property
Locations Property
Resources Property
Tasks Property


MindFusion.Scheduling.Schedule.CommitCompositeOperation Method

Schedule.CommitCompositeOperation Method
[image]

Stops recording undo/redo commands into a CompositeCommand and saves the composite in the history queue.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void CommitCompositeOperation ()
Visual Basic [image] Copy Code

Public Sub CommitCompositeOperation ()

Remarks

You must call either CancelCompositeOperation or this method when the schedule modifications are done after a StartCompositeOperation call.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
UndoEnabled Property


MindFusion.Scheduling.Schedule.ExecuteCommand Method

Schedule.ExecuteCommand Method
[image]

Executes the specified command on this schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void ExecuteCommand (
Command command
)
Visual Basic [image] Copy Code

Public Sub ExecuteCommand ( _
command As Command _
)

Parameters

command
The Command to execute.

Remarks

If undo/redo is enabled, the command is saved in the undo history or added to the active composite command.

AddItemCommand and RemoveItemCommand objects are created automatically by the control when adding or removing items, both programmatically or interactively. Calling this method explicitly could be necessary in order to save item's state for later undo using a ChangeItemCommand, or to run a custom operation represented by a class derived from Command.

Example

The following example shows the pattern that should be used to save the state of an item for later undo.

C# [image] Copy Code

Item item = calendar.ItemSelection.Items[0];
if (item != null)
{
ChangeItemCommand change = new ChangeItemCommand(calendar.Schedule, item);
item.HeaderText = "new header";
item.StartTime = DateTime.Now;
item.EndTime = DateTime.Now.AddHours(2);
calendar.Schedule.ExecuteCommand(change);
}
Visual Basic [image] Copy Code

Dim item = calendar.ItemSelection.Items(0)
If (item IsNot Nothing) Then

Dim change As New ChangeItemCommand(calendar.Schedule, item)
item.HeaderText = "new header"
item.StartTime = DateTime.Now
item.EndTime = DateTime.Now.AddHours(2)
calendar.Schedule.ExecuteCommand(change)

End If

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method

Schedule.GetAllItems Method
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.

Overload List

Name | Description
Schedule.GetAllItems (DateTime, DateTime) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
Schedule.GetAllItems (DateTime, DateTime, Contact) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Contact object.
Schedule.GetAllItems (DateTime, DateTime, Location) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Location object.
Schedule.GetAllItems (DateTime, DateTime, Resource) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Resource object.
Schedule.GetAllItems (DateTime, DateTime, Task) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Task object.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime)

Schedule.GetAllItems Method (DateTime, DateTime)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection GetAllItems (
DateTime startTime,
DateTime endTime
)
Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startTime As DateTime, _
endTime As DateTime _
) As ItemCollection

Parameters

startTime
Time interval start.
endTime
Time interval end.

Return Value

A collection that contains the events scheduled to occur in the specified period.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Contact)

Schedule.GetAllItems Method (DateTime, DateTime, Contact)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Contact object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Contact contact
)
Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
contact As Contact _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
contact
A Contact instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified contact.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Location)

Schedule.GetAllItems Method (DateTime, DateTime, Location)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Location object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Location location
)
Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
location As Location _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
location
A Location instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified location.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Resource)

Schedule.GetAllItems Method (DateTime, DateTime, Resource)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Resource object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Resource resource
)
Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
resource As Resource _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
resource
A Resource instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified resource.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Task)

Schedule.GetAllItems Method (DateTime, DateTime, Task)
See Also
[image]

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Task object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Task task
)
Visual Basic [image] Copy Code

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
task As Task _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
task
A Task instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified task.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method

Schedule.GetFreePeriod Method
[image]

Returns the next period with the specified duration after the specified date, which is not occupied by items.

Overload List

Name | Description
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan) | Returns the next period after the specified date with the specified duration which is not occupied by items.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Contact)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified contacts.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Location)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified locations.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Resource)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified resources.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection(Task)) | Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified tasks.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan)
See Also
[image]

Returns the next period after the specified date with the specified duration which is not occupied by items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration
)
Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Contact))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Contact))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified contacts.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Contact> contacts
)
Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
contacts As ResourceCollection(Of Contact) _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
contacts
The contacts whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Location))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Location))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified locations.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Location> locations
)
Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
locations As ResourceCollection(Of Location) _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
locations
The locations whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Resource))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Resource))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Resource> resources
)
Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
resources As ResourceCollection(Of Resource) _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
resources
The resources whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Task))

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection(Task))
See Also
[image]

Returns the next period after the specified date with the specified duration, which is not occupied by items associated with the specified tasks.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection<Task> tasks
)
Visual Basic [image] Copy Code

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
tasks As ResourceCollection(Of Task) _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
tasks
The tasks whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method

Schedule.GetItemsToRemindOf Method
[image]

Retrieves a collection of all items that must be reminded of.

Overload List

Name | Description
Schedule.GetItemsToRemindOf () | Retrieves a collection with all items that must be reminded of at the current time.
Schedule.GetItemsToRemindOf (DateTime) | Retrieves a collection with all items that must be reminded of at the specified time.
Schedule.GetItemsToRemindOf (DateTime, DateTime) | Retrieves a collection with all items that must be reminded of in the specified interval.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method ()

Schedule.GetItemsToRemindOf Method ()
See Also
[image]

Retrieves a collection with all items that must be reminded of at the current time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection GetItemsToRemindOf ()
Visual Basic [image] Copy Code

Public Function GetItemsToRemindOf () As ItemCollection

Return Value

The collection of all items whose reminders must be displayed at the current time.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method (DateTime)

Schedule.GetItemsToRemindOf Method (DateTime)
See Also
[image]

Retrieves a collection with all items that must be reminded of at the specified time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection GetItemsToRemindOf (
DateTime time
)
Visual Basic [image] Copy Code

Public Function GetItemsToRemindOf ( _
time As DateTime _
) As ItemCollection

Parameters

time
Determine whether any reminders should be displayed at this time.

Return Value

The collection of all items whose reminders must be displayed at the specified time.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method (DateTime, DateTime)

Schedule.GetItemsToRemindOf Method (DateTime, DateTime)
See Also
[image]

Retrieves a collection with all items that must be reminded of in the specified interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection GetItemsToRemindOf (
DateTime start,
DateTime end
)
Visual Basic [image] Copy Code

Public Function GetItemsToRemindOf ( _
start As DateTime, _
end As DateTime _
) As ItemCollection

Parameters

start
The start of the time interval containing the items of interest.
end
The end of the time interval containing the items of interest.

Return Value

The collection of all items whose reminders must be displayed in the specified time interval.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method

Schedule.GetTasksToRemindOf Method
[image]

Overload List

Name | Description
Schedule.GetTasksToRemindOf () | Retrieves a collection of all tasks that must be reminded of at the current time.
Schedule.GetTasksToRemindOf (DateTime) | Retrieves a collection of all tasks that must be reminded of at the specified time.
Schedule.GetTasksToRemindOf (DateTime, DateTime) | Retrieves a collection of all tasks that must be reminded of in the specified interval.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method ()

Schedule.GetTasksToRemindOf Method ()
See Also
[image]

Retrieves a collection of all tasks that must be reminded of at the current time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Task> GetTasksToRemindOf ()
Visual Basic [image] Copy Code

Public Function GetTasksToRemindOf () As ResourceCollection(Of Task)

Return Value

The collection of all tasks whose reminders must be displayed at the current time.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method (DateTime)

Schedule.GetTasksToRemindOf Method (DateTime)
See Also
[image]

Retrieves a collection of all tasks that must be reminded of at the specified time.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Task> GetTasksToRemindOf (
DateTime time
)
Visual Basic [image] Copy Code

Public Function GetTasksToRemindOf ( _
time As DateTime _
) As ResourceCollection(Of Task)

Parameters

time
Determine whether any task reminders should be displayed at this time.

Return Value

The collection of all tasks whose reminders must be displayed at the specified time.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method (DateTime, DateTime)

Schedule.GetTasksToRemindOf Method (DateTime, DateTime)
See Also
[image]

Retrieves a collection of all tasks that must be reminded of in the specified interval.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Task> GetTasksToRemindOf (
DateTime start,
DateTime end
)
Visual Basic [image] Copy Code

Public Function GetTasksToRemindOf ( _
start As DateTime, _
end As DateTime _
) As ResourceCollection(Of Task)

Parameters

start
The start of the time interval containing the tasks of interest.
end
The end of the time interval containing the tasks of interest.

Return Value

The collection of all tasks whose reminders must be displayed in the specified time interval.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method

Schedule.IsClassRegistered Method
[image]

Overload List

Name | Description
Schedule.IsClassRegistered (String) | Checks whether the specified
Schedule.IsClassRegistered (Type) | Checks whether the specified item or resource type is registered for serializaiton.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method (String)

Schedule.IsClassRegistered Method (String)
See Also
[image]

Checks whether the specified

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static bool IsClassRegistered (
string classId
)
Visual Basic [image] Copy Code

Public Shared Function IsClassRegistered ( _
classId As String _
) As Boolean

Parameters

classId
The string identifier of an item or resource class.

Return Value

true if the specified class identifier is already registered; otherwise, false.

See Also

IsClassRegistered Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method (Type)

Schedule.IsClassRegistered Method (Type)
See Also
[image]

Checks whether the specified item or resource type is registered for serializaiton.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static bool IsClassRegistered (
Type classType
)
Visual Basic [image] Copy Code

Public Shared Function IsClassRegistered ( _
classType As Type _
) As Boolean

Parameters

classType
The type of an item or a resource.

Return Value

true if the specified class identifier is already registered; otherwise, false.

See Also

IsClassRegistered Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.LoadFrom Method

Schedule.LoadFrom Method
[image]

Overload List

Name | Description
Schedule.LoadFrom (Stream) | Loads schedule data from a stream.
Schedule.LoadFrom (String) | Loads schedule data from a file.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.LoadFrom Method (Stream)

Schedule.LoadFrom Method (Stream)
See Also
[image]

Loads schedule data from a stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void LoadFrom (
Stream stream
)
Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
stream As Stream _
)

Parameters

stream
The .NET Stream to load the schedule from.

See Also

LoadFrom Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.LoadFrom Method (String)

Schedule.LoadFrom Method (String)
See Also
[image]

Loads schedule data from a file.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void LoadFrom (
string fileName
)
Visual Basic [image] Copy Code

Public Sub LoadFrom ( _
fileName As String _
)

Parameters

fileName
The name of the file from which to load the schedule.

Remarks

This method loads the schedule data from a file where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the file are loaded.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Schedule.LoadFromXml Method (XDocument)

Schedule.LoadFromXml Method (XDocument)
See Also
[image]

Loads schedule data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void LoadFromXml (
XDocument document
)
Visual Basic [image] Copy Code

Public Sub LoadFromXml ( _
document As XDocument _
)

Parameters

document
An XmlDocument instance that allows reading data from the XML document.

Remarks

Loads schedule items from an XML document previously created by SaveToXml. Any data contained in the schedule is discarded before the items stored in the reader are loaded.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveToXml Method


MindFusion.Scheduling.Schedule.OnActionRedone Method

Schedule.OnActionRedone Method
[image]

Raises the ActionRedone event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected void OnActionRedone (
UndoEventArgs e
)
Visual Basic [image] Copy Code

Protected Sub OnActionRedone ( _
e As UndoEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnActionUndone Method

Schedule.OnActionUndone Method
[image]

Raises the ActionUndone event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected void OnActionUndone (
UndoEventArgs e
)
Visual Basic [image] Copy Code

Protected Sub OnActionUndone ( _
e As UndoEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnDeserializeTag Method

Schedule.OnDeserializeTag Method
[image]

Raises the DeserializeTag event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeTag ( _
e As SerializeTagEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnInstantiateItem Method

Schedule.OnInstantiateItem Method
[image]

Raises the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnInstantiateItem (
InstantiateItemEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnInstantiateItem ( _
e As InstantiateItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnInstantiateResource Method

Schedule.OnInstantiateResource Method
[image]

Raises the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnInstantiateResource (
InstantiateResourceEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnInstantiateResource ( _
e As InstantiateResourceEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemEndTimeTriggered Method

Schedule.OnItemEndTimeTriggered Method
[image]

Raises the ItemEndTimeTriggered event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemEndTimeTriggered (
ItemEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemEndTimeTriggered ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemReminderTriggered Method

Schedule.OnItemReminderTriggered Method
[image]

Raises the ItemReminderTriggered event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemReminderTriggered (
ItemEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemReminderTriggered ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnSerializeTag Method

Schedule.OnSerializeTag Method
[image]

Raises the SerializeTag event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeTag ( _
e As SerializeTagEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnTaskReminderTriggered Method

Schedule.OnTaskReminderTriggered Method
[image]

Raises the TaskReminderTriggered event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnTaskReminderTriggered (
TaskEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnTaskReminderTriggered ( _
e As TaskEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Redo Method

Schedule.Redo Method
[image]

Executes again an action saved in the command history.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Redo ()
Visual Basic [image] Copy Code

Public Sub Redo ()

Remarks

The control supports unlimited undo/redo depth. This method moves the "current command" pointer one position back, and calling it again will undo the previous command. The commands can later be redone by calling Redo.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
UndoEnabled Property
CanUndo Property
ActionUndone Event


MindFusion.Scheduling.Schedule.RegisterItemClass Method

Schedule.RegisterItemClass Method
[image]

Registers a schedule item class for serialization support.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion
)
Visual Basic [image] Copy Code

Public Shared Sub RegisterItemClass ( _
itemClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

itemClass
A .NET Type instance identifying the item class.
classId
A class identifier to use when saving and loading items of the specified type.
classVersion
A revision number of the item's class serialization format.

Remarks

When using custom item classes, use this method to enable saving and loading the custom item objects to/from XML or binary files. The class id string is written before each item's data, and when loading items later that string indicates to the schedule what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used: 'std:appointment', 'std:resource', 'std:contact', 'std:location' and 'std:task'.

The version identifier must be increased when the format in which items are saved changes. It is used when loading files to let your application load items data from an older format.

Note

All custom item classes must provide a parameterless constructor. Failing to do so would result in exceptions during the load process, since the schedule will be unable to create custom items.

Example

The following example demonstrates how to use custom item classes with the schedule and how to load and save a schedule containing custom items. The example presumes that schedule already references an existing Schedule object.

Running the example should dump the following line to the output console:

Hello, friend!

C# [image] Copy Code

/// <summary>
/// The declaration of the custom item class.
/// </summary>
class CustomItem : Appointment
{
/// <summary>
/// The parameterless constructor, required by the Schedule.
/// </summary>
public CustomItem()
{
_customField = "This is my field.";
}

public override void LoadFrom(
System.Xml.XmlReader reader,
SerializationContext context)
{
// Don't forget to invoke LoadFrom on the base class
base.LoadFrom(reader, context);

_customField = reader.ReadElementString("customField");
}

public override void SaveTo(
System.Xml.XmlWriter writer,
SerializationContext context)
{
base.SaveTo(writer, context);

writer.WriteElementString("customField", _customField);
}

public string CustomField
{
get { return _customField; }
set { _customField = value; }
}

private string _customField;
}

// ...

// Register our custom item class for use with the schedule
Schedule.RegisterItemClass(typeof(CustomItem), "customItemId", 1);

// Create a new custom item and add it to the schedule
CustomItem customItem = new CustomItem();
customItem.CustomField = "Hello, friend!";
schedule.Items.Add(customItem);

// Save the schedule to a file.
// Make sure the specified path exists on your drive
schedule.SaveTo(@"c:\schedule.save");

// Clear the schedule
schedule.Items.Clear();

// Load the previously saved schedule data
schedule.LoadFrom(@"c:\schedule.save");

// Test the data
foreach (Item item in schedule.Items)
{
if (item is CustomItem)
{
System.Diagnostics.Debug.WriteLine(
(item as CustomItem).CustomField);
}
}
Visual Basic [image] Copy Code

' <summary>
' The declaration of the custom item class.
' </summary>
Class CustomItem
Inherits Appointment

' <summary>
' The parameterless constructor, required by the Schedule.
' </summary>
Public Sub New()

_customField = "This is my field."

End Sub

Public Overloads Overrides Sub LoadFrom( _
ByVal reader As System.Xml.XmlReader, _
ByVal context As SerializationContext)

' Don't forget to invoke LoadFrom on the base class
MyBase.LoadFrom(reader, context)

_customField = reader.ReadElementString("customField")

End Sub

Public Overloads Overrides Sub SaveTo( _
ByVal writer As System.Xml.XmlWriter, _
ByVal context As SerializationContext)

MyBase.SaveTo(writer, context)

writer.WriteElementString("customField", _customField)

End Sub

Public Property CustomField() As String

Get
Return _customField
End Get

Set(ByVal Value As String)
_customField = Value
End Set

End Property

Private _customField As String

End Class

' ...

' Register our custom item class for use with the schedule
schedule.RegisterItemClass(GetType(CustomItem), "customItemId", 1)

' Create a new custom item and add it to the schedule
Dim customItem As New CustomItem
customItem.CustomField = "Hello, friend!"
schedule.Items.Add(customItem)

' Save the schedule to a file.
' Make sure the specified path exists on your drive
schedule.SaveTo("c:\schedule.save")

' Clear the schedule
schedule.Items.Clear()

' Load the previously saved schedule data
schedule.LoadFrom("c:\schedule.save")

' Test the data
Dim item As Item
For Each item In schedule.Items

If TypeOf item Is CustomItem Then

System.Diagnostics.Debug.WriteLine( _
CType(item, CustomItem).CustomField)

End If

Next item

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.RegisterResourceClass Method

Schedule.RegisterResourceClass Method
[image]

Registers a resource class for serialization support.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static void RegisterResourceClass (
Type resourceClass,
string classId,
int classVersion
)
Visual Basic [image] Copy Code

Public Shared Sub RegisterResourceClass ( _
resourceClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

resourceClass
A Type instance identifying the resource class.
classId
A class identifier to use when saving and loading resources of the specified type.
classVersion
A revision number of the resource's class serialization format.

Remarks

When using custom resource classes, use this method to enable saving and loading the custom resource objects to/from XML or binary files. The class id string is written before each resource's data, and when loading resources later that string indicates to the schedule what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used: 'std:appointment', 'std:resource', 'std:contact', 'std:location' and 'std:task'.

The version identifier must be increased when the format in which resources are saved changes. It is used when loading files to let your application load resources data from an older format.

Note

All custom resource classes must provide a parameterless constructor. Failing to do so would result in exceptions during the load process, since the schedule will be unable to create custom resources.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveTo Method

Schedule.SaveTo Method
[image]

Overload List

Name | Description
Schedule.SaveTo (Stream) | Saves the schedule to a stream.
Schedule.SaveTo (String) | Saves the schedule to a file.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveTo Method (Stream)

Schedule.SaveTo Method (Stream)
See Also
[image]

Saves the schedule to a stream.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SaveTo (
Stream stream
)
Visual Basic [image] Copy Code

Public Sub SaveTo ( _
stream As Stream _
)

Parameters

stream
The .NET Stream to save the schedule to.

See Also

SaveTo Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveTo Method (String)

Schedule.SaveTo Method (String)
See Also
[image]

Saves the schedule to a file.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SaveTo (
string fileName
)
Visual Basic [image] Copy Code

Public Sub SaveTo ( _
fileName As String _
)

Parameters

fileName
The path of the file to save to.

Remarks

Saves the schedule data into a XML file. Use LoadFrom to restore the data later.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Schedule.SaveToXml Method (XDocument)

Schedule.SaveToXml Method (XDocument)
See Also
[image]

Saves the schedule to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SaveToXml (
XDocument document
)
Visual Basic [image] Copy Code

Public Sub SaveToXml ( _
document As XDocument _
)

Parameters

document
An XDocument object that allows adding data to the XML document.

Remarks

Saves the schedule data as tags in an XML document. Use LoadFromXml to restore the schedule data later.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFromXml Method


MindFusion.Scheduling.Schedule.StartCompositeOperation Method

Schedule.StartCompositeOperation Method
[image]

Starts recording undo/redo commands into a CompositeCommand.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void StartCompositeOperation ()
Visual Basic [image] Copy Code

Public Sub StartCompositeOperation ()

Remarks

After the schedule modifications are done, call CommitCompositeOperation or CancelCompositeOperation.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
UndoEnabled Property


MindFusion.Scheduling.Schedule.Undo Method

Schedule.Undo Method
[image]

Undoes an action saved in the command history.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Undo ()
Visual Basic [image] Copy Code

Public Sub Undo ()

Remarks

The control supports unlimited undo/redo depth. This method moves the "current command" pointer one position back, and calling it again will undo the previous command. The commands can later be redone by calling Redo.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
UndoEnabled Property
CanUndo Property
ActionUndone Event


MindFusion.Scheduling.Schedule.UnregisterClass Method

Schedule.UnregisterClass Method
[image]

Unregisters the item or resource with the specified class identifier or type from the system.

Overload List

Name | Description
Schedule.UnregisterClass (String) | Unregisters the item or resource with the specified class id from the system.
Schedule.UnregisterClass (Type) | Unregisters the specified item or resource type from the system.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.UnregisterClass Method (String)

Schedule.UnregisterClass Method (String)
See Also
[image]

Unregisters the item or resource with the specified class id from the system.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static void UnregisterClass (
string classId
)
Visual Basic [image] Copy Code

Public Shared Sub UnregisterClass ( _
classId As String _
)

Parameters

classId
The string identifier of an item or resource class.

See Also

UnregisterClass Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
IsClassRegistered Method
RegisterItemClass Method
RegisterResourceClass Method


MindFusion.Scheduling.Schedule.UnregisterClass Method (Type)

Schedule.UnregisterClass Method (Type)
See Also
[image]

Unregisters the specified item or resource type from the system.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static void UnregisterClass (
Type classType
)
Visual Basic [image] Copy Code

Public Shared Sub UnregisterClass ( _
classType As Type _
)

Parameters

classType
The type of an item or a resource.

See Also

UnregisterClass Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
IsClassRegistered Method
RegisterItemClass Method
RegisterResourceClass Method


MindFusion.Scheduling.Schedule Properties

Schedule Properties
[image]

Public Properties

Name | Description
CanRedo | Gets or sets a value indicating whether there is a command in the redo history which can be redone
CanUndo | Gets or sets a value indicating whether there is a command in the undo history which can be undone.
Contacts | Gets all contacts defined in the Schedule.
Items | Gets all scheduled items.
Locations | Gets all locations defined in the Schedule.
Resources | Gets all resources defined in the Schedule.
Tasks | Gets all tasks defined in this Schedule.
UndoEnabled | Gets or sets a value indicating whether saving action records for later undo is enabled.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.CanRedo Property

Schedule.CanRedo Property
[image]

Gets or sets a value indicating whether there is a command in the redo history which can be redone

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool CanRedo { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property CanRedo As Boolean

Property Value

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.CanUndo Property

Schedule.CanUndo Property
[image]

Gets or sets a value indicating whether there is a command in the undo history which can be undone.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool CanUndo { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property CanUndo As Boolean

Property Value

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Contacts Property

Schedule.Contacts Property
[image]

Gets all contacts defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Contact> Contacts { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Contacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection(Contact) class containing all contacts used in the schedule.

Remarks

Add contacts to this collection before assigning them to a schedule item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Items Property

Schedule.Items Property
[image]

Gets all scheduled items.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemCollection Items { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Items As ItemCollection

Property Value

An instance of the ItemCollection class containing all items in the schedule.

Remarks

The Calendar control displays each element of this collection in the time cells corresponding to the item's StartTime and EndTime.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Item Class


MindFusion.Scheduling.Schedule.Locations Property

Schedule.Locations Property
[image]

Gets all locations defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Location> Locations { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Locations As ResourceCollection(Of Location)

Property Value

An instance of the generic ResourceCollection(Location) class containing all locations associated with this schedule.

Remarks

Add locations to this collection before assigning them to schedule items.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Location Class


MindFusion.Scheduling.Schedule.Resources Property

Schedule.Resources Property
[image]

Gets all resources defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Resource> Resources { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Resources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection(Resource) class containing all resources associated with this schedule.

Remarks

Add resources to this collection before assigning them to schedule items.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Resource Class


MindFusion.Scheduling.Schedule.Tasks Property

Schedule.Tasks Property
[image]

Gets all tasks defined in this Schedule.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Task> Tasks { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Tasks As ResourceCollection(Of Task)

Property Value

An instance of the ResourceCollection(Task) class containing references to the tasks assigned to the schedule.

Remarks

If you need to assign a Task object to schedule items, add the task to this collection before assigning it to the item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Task Class


MindFusion.Scheduling.Schedule.UndoEnabled Property

Schedule.UndoEnabled Property
[image]

Gets or sets a value indicating whether saving action records for later undo is enabled.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool UndoEnabled { get; set; }
Visual Basic [image] Copy Code

Public Property UndoEnabled As Boolean

Property Value

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Events

Schedule Events
[image]

Public Events

Name | Description
ActionRedone | Raised when an action is redone.
ActionUndone | Raised when an action is undone.
Changed | Raised when items are added or removed from the schedule or when the schedule is loaded.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.
InstantiateItem | Raised when deserializing a custom item whose type has not been registered.
InstantiateResource | Raised when deserializing a custom resource whose type has not been registered.
ItemEndTimeTriggered | Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.
ItemReminderTriggered | Raised when the reminder for an item is triggered.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.
TaskReminderTriggered | Raised when the reminder for a task is triggered.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ActionRedone Event

Schedule.ActionRedone Event
[image]

Raised when an action is redone.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionRedone
Visual Basic [image] Copy Code

Public Event ActionRedone As EventHandler(Of UndoEventArgs)

Remarks

This event is raised during calls to Redo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ActionUndone Event

Schedule.ActionUndone Event
[image]

Raised when an action is undone.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<UndoEventArgs> ActionUndone
Visual Basic [image] Copy Code

Public Event ActionUndone As EventHandler(Of UndoEventArgs)

Remarks

This event is raised during calls to Undo. It is raised both for top-level commands and for the constituent actions of composite commands.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Changed Event

Schedule.Changed Event
[image]

Raised when items are added or removed from the schedule or when the schedule is loaded.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler Changed
Visual Basic [image] Copy Code

Public Event Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.DeserializeTag Event

Schedule.DeserializeTag Event
[image]

Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> DeserializeTag
Visual Basic [image] Copy Code

Public Event DeserializeTag As EventHandler(Of SerializeTagEventArgs)

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.InstantiateItem Event

Schedule.InstantiateItem Event
[image]

Raised when deserializing a custom item whose type has not been registered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<InstantiateItemEventArgs> InstantiateItem
Visual Basic [image] Copy Code

Public Event InstantiateItem As EventHandler(Of InstantiateItemEventArgs)

Event Data

InstantiateItem event handlers receive an argument of type InstantiateItemEventArgs.

Remarks

This event is being raised during deserialization for all custom items whose types have not been previously registered within the system through a call to RegisterItemClass. The event provides an alternative way for instantiating item of custom types.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.InstantiateResource Event

Schedule.InstantiateResource Event
[image]

Raised when deserializing a custom resource whose type has not been registered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<InstantiateResourceEventArgs> InstantiateResource
Visual Basic [image] Copy Code

Public Event InstantiateResource As EventHandler(Of InstantiateResourceEventArgs)

Event Data

InstantiateResource event handlers receive an argument of type InstantiateResourceEventArgs.

Remarks

This event is being raised during deserialization for all custom resources whose types have not been previously registered within the system through a call to RegisterResourceClass. The event provides an alternative way for instantiating resources of custom types.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemEndTimeTriggered Event

Schedule.ItemEndTimeTriggered Event
[image]

Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemEndTimeTriggered
Visual Basic [image] Copy Code

Public Event ItemEndTimeTriggered As EventHandler(Of ItemEventArgs)

Event Data

ItemEndTimeTriggered event handlers receive an argument of type ItemEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemReminderTriggered Event

Schedule.ItemReminderTriggered Event
[image]

Raised when the reminder for an item is triggered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemReminderTriggered
Visual Basic [image] Copy Code

Public Event ItemReminderTriggered As EventHandler(Of ItemEventArgs)

Event Data

ItemReminderTriggered event handlers receive an argument of type ItemEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SerializeTag Event

Schedule.SerializeTag Event
[image]

Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> SerializeTag
Visual Basic [image] Copy Code

Public Event SerializeTag As EventHandler(Of SerializeTagEventArgs)

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.TaskReminderTriggered Event

Schedule.TaskReminderTriggered Event
[image]

Raised when the reminder for a task is triggered.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<TaskEventArgs> TaskReminderTriggered
Visual Basic [image] Copy Code

Public Event TaskReminderTriggered As EventHandler(Of TaskEventArgs)

Event Data

TaskReminderTriggered event handlers receive an argument of type TaskEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Class

SerializationContext Class
[image]

This class contains information required to serialize a Schedule element to and from a binary stream or XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class SerializationContext
Visual Basic [image] Copy Code

Public Class SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.XmlSerializationContext

See Also

SerializationContext Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Members

SerializationContext Members
Constructors Properties Events
[image]

This class contains information required to serialize a Schedule element to and from a binary stream or XML document.

The following tables list the members exposed by the SerializationContext type.

Public Constructors

Name | Description
SerializationContext | Initializes a new instance of the SerializationContext class.

Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded.
Schedule | Gets a reference to the schedule currently being serialized or deserialized.

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Constructor

SerializationContext Constructor
[image]

Initializes a new instance of the SerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public SerializationContext (
Schedule schedule
)
Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule _
)

Parameters

schedule
An instance of the Schedule class representing the schedule to associate with.

Remarks

Generally, you do not have to instantiate from SerializationContext explicitly unless you want to serialize only particular elements and not the entire schedule.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Properties

SerializationContext Properties
[image]

Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded.
Schedule | Gets a reference to the schedule currently being serialized or deserialized.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.FileVersion Property

SerializationContext.FileVersion Property
[image]

Gets the format revision number of the file being loaded.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int FileVersion { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

An integer value identifying the schedule file format revision number.

Remarks

This revision number specifies the format of the schedule files, but not of distinct item classes. If using custom item classes, specify their format revision number when registering them with the schedule via the RegisterItemClass method.

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.Schedule Property

SerializationContext.Schedule Property
[image]

Gets a reference to the schedule currently being serialized or deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Schedule Schedule { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Schedule As Schedule

Property Value

An instance of the Schedule class.

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Events

SerializationContext Events
[image]

Public Events

Name | Description
Completed | Raised when the serialization or deserialization has completed successfully.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.Completed Event

SerializationContext.Completed Event
[image]

Raised when the serialization or deserialization has completed successfully.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler Completed
Visual Basic [image] Copy Code

Public Event Completed As EventHandler

Event Data

Completed event handlers receive an argument of type EventArgs.

Remarks

You can use this event in your custom items to deserialize references to other Item and/or Resource objects.

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Class

SerializeTagEventArgs Class
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class SerializeTagEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class SerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the Item or Resource whose Tag is being serialized/deserialized.
Representation | Gets or sets the representation of the tag object being serialized / deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the Item or Resource whose Tag is being serialized/deserialized.
Representation | Gets or sets the representation of the tag object being serialized / deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property
[image]

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XmlSerializationContext Context { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlSerializationContext

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool Handled { get; set; }
Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Object Property

SerializeTagEventArgs.Object Property
[image]

Gets the Item or Resource whose Tag is being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Object Object { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Object As Object

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property
[image]

Gets or sets the representation of the tag object being serialized / deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement Representation { get; set; }
Visual Basic [image] Copy Code

Public Property Representation As XElement

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property
[image]

Gets or sets the tag object being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Object Tag { get; set; }
Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Class

Task Class
[image]

Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class Task : Resource
Visual Basic [image] Copy Code

Public Class Task
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Task

See Also

Task Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Members

Task Members
Constructors Properties Methods
[image]

Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.

The following tables list the members exposed by the Task type.

Public Constructors

Name | Description
Task | Initializes a new instance of the Task class.

Public Properties

Name | Description
ActualCost | Gets or sets the actual cost of this task.
ActualDuration | Gets or sets the task actual duration measured in minutes.
ActualEnd | Gets or sets the task's actual completion date.
ActualStart | Gets or sets the task's actual start date.
Details | Gets or sets the detailed description of this task.
DueDate | Gets or sets the task's due date.
EstimatedCost | Gets or sets the estimated cost of this task.
EstimatedDuration | Gets or sets the estimated duration of this task.
ImageIndex | Gets or sets the index of the image associated with this task.
Priority | Gets or sets the task priority.
Progress | Gets or sets the task progress measured in percents.
Reminder | Gets or sets the reminder for this task.
StartDate | Gets or sets the task's start date.
Status | Gets or sets the status of this task.
Subject | Gets or sets the subject of this task.

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Constructor

Task Constructor
[image]

Initializes a new instance of the Task class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Task ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Methods

Task Methods
[image]

Public Methods

Name | Description
LoadFrom |
SaveTo |

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.LoadFrom Method (XElement, XmlSerializationContext)

Task.LoadFrom Method (XElement, XmlSerializationContext)
See Also
[image]

Loads task data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void LoadFrom (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overrides Sub LoadFrom ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads the task properties from an XML document where they were previously saved by SaveTo.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Task.SaveTo Method (XElement, XmlSerializationContext)

Task.SaveTo Method (XElement, XmlSerializationContext)
See Also
[image]

Saves the task data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void SaveTo (
XElement element,
XmlSerializationContext context
)
Visual Basic [image] Copy Code

Public Overrides Sub SaveTo ( _
element As XElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the task properties as elements in an XML document. Later they can be restored via the LoadFrom method.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Task Properties

Task Properties
[image]

Public Properties

Name | Description
ActualCost | Gets or sets the actual cost of this task.
ActualDuration | Gets or sets the task actual duration measured in minutes.
ActualEnd | Gets or sets the task's actual completion date.
ActualStart | Gets or sets the task's actual start date.
Details | Gets or sets the detailed description of this task.
DueDate | Gets or sets the task's due date.
EstimatedCost | Gets or sets the estimated cost of this task.
EstimatedDuration | Gets or sets the estimated duration of this task.
ImageIndex | Gets or sets the index of the image associated with this task.
Priority | Gets or sets the task priority.
Progress | Gets or sets the task progress measured in percents.
Reminder | Gets or sets the reminder for this task.
StartDate | Gets or sets the task's start date.
Status | Gets or sets the status of this task.
Subject | Gets or sets the subject of this task.

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualCost Property

Task.ActualCost Property
[image]

Gets or sets the actual cost of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public float ActualCost { get; set; }
Visual Basic [image] Copy Code

Public Property ActualCost As Single

Property Value

A float value specifying the task's actual cost. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualDuration Property

Task.ActualDuration Property
[image]

Gets or sets the task actual duration measured in minutes.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ActualDuration { get; set; }
Visual Basic [image] Copy Code

Public Property ActualDuration As Integer

Property Value

An integer value specifying the task's duration. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualEnd Property

Task.ActualEnd Property
[image]

Gets or sets the task's actual completion date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime ActualEnd { get; set; }
Visual Basic [image] Copy Code

Public Property ActualEnd As DateTime

Property Value

A .NET DateTime object specifying the task's actual end date. The default is DateTime.MaxValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualStart Property

Task.ActualStart Property
[image]

Gets or sets the task's actual start date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime ActualStart { get; set; }
Visual Basic [image] Copy Code

Public Property ActualStart As DateTime

Property Value

A .NET DateTime object specifying the task's actual start date. The default is DateTime.MinValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Details Property

Task.Details Property
[image]

Gets or sets the detailed description of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Details { get; set; }
Visual Basic [image] Copy Code

Public Property Details As String

Property Value

A string containing the task's details text. The default is an empty string.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.DueDate Property

Task.DueDate Property
[image]

Gets or sets the task's due date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime DueDate { get; set; }
Visual Basic [image] Copy Code

Public Property DueDate As DateTime

Property Value

A .NET DateTime object specifying the task's sue date. The default is DateTime.MaxValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
StartDate Property


MindFusion.Scheduling.Task.EstimatedCost Property

Task.EstimatedCost Property
[image]

Gets or sets the estimated cost of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public float EstimatedCost { get; set; }
Visual Basic [image] Copy Code

Public Property EstimatedCost As Single

Property Value

A float value specifying the task's estimated cost. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.EstimatedDuration Property

Task.EstimatedDuration Property
[image]

Gets or sets the estimated duration of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int EstimatedDuration { get; set; }
Visual Basic [image] Copy Code

Public Property EstimatedDuration As Integer

Property Value

An integer value specifying the task's scheduled duration. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ImageIndex Property

Task.ImageIndex Property
[image]

Gets or sets the index of the image associated with this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ImageIndex { get; set; }
Visual Basic [image] Copy Code

Public Property ImageIndex As Integer

Property Value

An integer value specifying the index of the task image within the calendar's ImageList. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Priority Property

Task.Priority Property
[image]

Gets or sets the task priority.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TaskPriority Priority { get; set; }
Visual Basic [image] Copy Code

Public Property Priority As TaskPriority

Property Value

A member of the TaskPriority enumeration. The default is Normal.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Progress Property

Task.Progress Property
[image]

Gets or sets the task progress measured in percents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public float Progress { get; set; }
Visual Basic [image] Copy Code

Public Property Progress As Single

Property Value

A float value specifying the progress made on this task. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Reminder Property

Task.Reminder Property
[image]

Gets or sets the reminder for this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Reminder Reminder { get; set; }
Visual Basic [image] Copy Code

Public Property Reminder As Reminder

Property Value

A Reminder instance specifying when the task should be reminded of. The default is null (Nothing in Visual Basic).

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.StartDate Property

Task.StartDate Property
[image]

Gets or sets the task's start date.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime StartDate { get; set; }
Visual Basic [image] Copy Code

Public Property StartDate As DateTime

Property Value

A .NET DateTime object specifying the task's scheduled start time. The default is DateTime.MinValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
DueDate Property


MindFusion.Scheduling.Task.Status Property

Task.Status Property
[image]

Gets or sets the status of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TaskStatus Status { get; set; }
Visual Basic [image] Copy Code

Public Property Status As TaskStatus

Property Value

A member of the TaskStatus enumeration. The default is NotStarted.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Subject Property

Task.Subject Property
[image]

Gets or sets the subject of this task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Subject { get; set; }
Visual Basic [image] Copy Code

Public Property Subject As String

Property Value

A string containing the task subject text. The default is an empty string.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Class

TaskEventArgs Class
[image]

Contains the arguments passed to handlers of task related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class TaskEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class TaskEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.TaskEventArgs

See Also

TaskEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Members

TaskEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of task related events raised by the Schedule class.

The following tables list the members exposed by the TaskEventArgs type.

Public Properties

Name | Description
Task | Gets the task related to the event.

See Also

TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Properties

TaskEventArgs Properties
[image]

Public Properties

Name | Description
Task | Gets the task related to the event.

See Also

TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs.Task Property

TaskEventArgs.Task Property
[image]

Gets the task related to the event.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Task Task { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Task As Task

Property Value

An instance of the Task class related to the raised event.

See Also

TaskEventArgs Members
TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskPriority Enumeration

TaskPriority Enumeration
[image]

Specifies the priority of a task.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum TaskPriority
Visual Basic [image] Copy Code

Public Enumeration TaskPriority

Members

Member name | Description
High | Indicates high task priority.
Low | Indicates low task priority.
Normal | Indicates normal task priority.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskStatus Enumeration

TaskStatus Enumeration
[image]

Enumeration providing task status values.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum TaskStatus
Visual Basic [image] Copy Code

Public Enumeration TaskStatus

Members

Member name | Description
Completed | Indicates a completed task.
Deferred | Indicates a deferred task.
InProgress | Indicates a task in progress.
NotStarted | Indicates that the task has not started yet.
WaitingOther | Indicates a task that depends on another task.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.UndoEventArgs Class

UndoEventArgs Class
[image]

Contains the arguments passed to the ActionUndone and ActionRedone event handlers.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class UndoEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class UndoEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.UndoEventArgs

See Also

UndoEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.UndoEventArgs Members

UndoEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the ActionUndone and ActionRedone event handlers.

The following tables list the members exposed by the UndoEventArgs type.

Public Constructors

Name | Description
UndoEventArgs | Initializes a new instance of the UndoEventArgs class.

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.UndoEventArgs Constructor

UndoEventArgs Constructor
[image]

Initializes a new instance of the UndoEventArgs class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public UndoEventArgs (
Command command
)
Visual Basic [image] Copy Code

Public New ( _
command As Command _
)

Parameters

command
The Command related to the event.

See Also

UndoEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.UndoEventArgs Properties

UndoEventArgs Properties
[image]

Public Properties

Name | Description
Command | Gets a reference to the Command instance related to the event being handled.

See Also

UndoEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.UndoEventArgs.Command Property

UndoEventArgs.Command Property
[image]

Gets a reference to the Command instance related to the event being handled.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Command Command { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Command As Command

Property Value

An instance of a Command-derived class.

See Also

UndoEventArgs Members
UndoEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Class

XmlSerializationContext Class
[image]

Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from XML documents.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class XmlSerializationContext : SerializationContext
Visual Basic [image] Copy Code

Public NotInheritable Class XmlSerializationContext
Inherits SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.XmlSerializationContext

See Also

XmlSerializationContext Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Members

XmlSerializationContext Members
Constructors Properties Methods
[image]

Contains methods that can help you serialize/deserialize MindFusion.Scheduling items to/from XML documents.

The following tables list the members exposed by the XmlSerializationContext type.

Public Constructors

Name | Description
XmlSerializationContext | Overloaded. Initializes a new instance of the XmlSerializationContext class.

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node with the specified name to the specified parent node.
ReadBool | Overloaded. Reads a boolean value with the specified name.
ReadByte |
ReadChar |
ReadColor |
ReadDateTime |
ReadDecimal |
ReadDouble |
ReadEnum |
ReadFloat |
ReadInt |
ReadLong |
ReadObject |
ReadPoint |
ReadRect |
ReadRecurrence |
ReadReminder |
ReadSByte |
ReadShort |
ReadSize |
ReadString |
ReadTag |
ReadUInt |
ReadULong |
ReadUShort |
SelectNodes |
SelectSingleNode |
WriteBool |
WriteByte |
WriteChar |
WriteColor |
WriteDateTime |
WriteDecimal |
WriteDouble |
WriteEnum |
WriteFloat |
WriteInt |
WriteLong |
WriteObject |
WritePoint |
WriteRect |
WriteRecurrence |
WriteReminder |
WriteSByte |
WriteShort |
WriteSize |
WriteString |
WriteTag |
WriteUInt |
WriteULong |
WriteUShort |

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor

XmlSerializationContext Constructor
[image]

Initializes a new instance of the XmlSerializationContext class.

Overload List

Name | Description
XmlSerializationContext (Schedule, Int32, XDocument) | Initializes a new instance of the XmlSerializationContext class.
XmlSerializationContext (Schedule, XDocument) | Initializes a new instance of the XmlSerializationContext class.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor (Schedule, Int32, XDocument)

XmlSerializationContext Constructor (Schedule, Int32, XDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Schedule schedule,
int fileVersion,
XDocument document
)
Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
fileVersion As Integer, _
document As XDocument _
)

Parameters

schedule
The Schedule this class will operate on.
fileVersion
The file version of the file being deserialized.
document
The .NET XDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor (Schedule, XDocument)

XmlSerializationContext Constructor (Schedule, XDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Schedule schedule,
XDocument document
)
Visual Basic [image] Copy Code

Public New ( _
schedule As Schedule, _
document As XDocument _
)

Parameters

schedule
The Schedule this class will operate on.
document
The .NET XDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Methods

XmlSerializationContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node with the specified name to the specified parent node.
ReadBool | Overloaded. Reads a boolean value with the specified name.
ReadByte |
ReadChar |
ReadColor |
ReadDateTime |
ReadDecimal |
ReadDouble |
ReadEnum |
ReadFloat |
ReadInt |
ReadLong |
ReadObject |
ReadPoint |
ReadRect |
ReadRecurrence |
ReadReminder |
ReadSByte |
ReadShort |
ReadSize |
ReadString |
ReadTag |
ReadUInt |
ReadULong |
ReadUShort |
SelectNodes |
SelectSingleNode |
WriteBool |
WriteByte |
WriteChar |
WriteColor |
WriteDateTime |
WriteDecimal |
WriteDouble |
WriteEnum |
WriteFloat |
WriteInt |
WriteLong |
WriteObject |
WritePoint |
WriteRect |
WriteRecurrence |
WriteReminder |
WriteSByte |
WriteShort |
WriteSize |
WriteString |
WriteTag |
WriteUInt |
WriteULong |
WriteUShort |

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method

XmlSerializationContext.AddChildElement Method
[image]

Adds a new child node with the specified name to the specified parent node.

Overload List

Name | Description
XmlSerializationContext.AddChildElement (String, XElement) | Adds a new child node with the specified name to the specified parent node.
XmlSerializationContext.AddChildElement (String, XElement, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method (String, XElement)

XmlSerializationContext.AddChildElement Method (String, XElement)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement AddChildElement (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function AddChildElement ( _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

elementName
The desired name of the new node.
parentElement
The parent element of the newly created node.

Return Value

A .NET XElement object representing the newly created element.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method (String, XElement, String)

XmlSerializationContext.AddChildElement Method (String, XElement, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement AddChildElement (
string elementName,
XElement parentElement,
string innerText
)
Visual Basic [image] Copy Code

Public Function AddChildElement ( _
elementName As String, _
parentElement As XElement, _
innerText As String _
) As XElement

Parameters

elementName
The desired name of the new node.
parentElement
The parent element of the newly created node.
innerText
The desired value of the new node.

Return Value

A .NET XElement object representing the newly created element.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method

XmlSerializationContext.ReadBool Method
[image]

Reads a boolean value with the specified name.

Overload List

Name | Description
XmlSerializationContext.ReadBool (String, XElement) | Reads a boolean value with the specified name.
XmlSerializationContext.ReadBool (String, XElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method (String, XElement)

XmlSerializationContext.ReadBool Method (String, XElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadBool ( _
elementName As String, _
parentElement As XElement _
) As Boolean

Parameters

elementName
The name of the element containing the bool value.
parentElement
The parent element of the node with the specified name.

Return Value

A bool value. Returns false if there is no element with the specified name under the specified parent.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method (String, XElement, Boolean)

XmlSerializationContext.ReadBool Method (String, XElement, Boolean)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XElement parentElement,
bool defaultValue
)
Visual Basic [image] Copy Code

Public Function ReadBool ( _
elementName As String, _
parentElement As XElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName
The name of the element containing the bool value.
parentElement
The parent element of the node with the specified name.
defaultValue
The value that should be returned if there is no node with the specified name under the specified parent element.

Return Value

A bool value.

Remarks

If there is no element with the specified name, returns the specified default value.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ReadByte Method (String, XElement)

XmlSerializationContext.ReadByte Method (String, XElement)
See Also
[image]

Reads a byte value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadByte ( _
elementName As String, _
parentElement As XElement _
) As Byte

Parameters

elementName
The name of the element containing the byte value.
parentElement
The parent element of the node with the specified name.

Return Value

A byte value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteByte Method


MindFusion.Scheduling.XmlSerializationContext.ReadChar Method (String, XElement)

XmlSerializationContext.ReadChar Method (String, XElement)
See Also
[image]

Reads a char value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadChar ( _
elementName As String, _
parentElement As XElement _
) As Char

Parameters

elementName
The name of the element containing the char value.
parentElement
The parent element of the node with the specified name.

Return Value

A char value. Returns 'a' if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteChar Method


MindFusion.Scheduling.XmlSerializationContext.ReadColor Method (String, XElement)

XmlSerializationContext.ReadColor Method (String, XElement)
See Also
[image]

Reads a color with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadColor ( _
elementName As String, _
parentElement As XElement _
) As Color

Parameters

elementName
The name of the element containing the .NET Color object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Color object. Returns Black if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteColor Method


MindFusion.Scheduling.XmlSerializationContext.ReadDateTime Method (String, XElement)

XmlSerializationContext.ReadDateTime Method (String, XElement)
See Also
[image]

Reads a DateTime object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime ReadDateTime (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadDateTime ( _
elementName As String, _
parentElement As XElement _
) As DateTime

Parameters

elementName
The name of the element containing the .NET DateTime object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET DateTime object. Returns DateTime.MinValue if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDateTime Method


MindFusion.Scheduling.XmlSerializationContext.ReadDecimal Method (String, XElement)

XmlSerializationContext.ReadDecimal Method (String, XElement)
See Also
[image]

Reads a decimal value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Decimal ReadDecimal (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadDecimal ( _
elementName As String, _
parentElement As XElement _
) As Decimal

Parameters

elementName
The name of the element containing the decimal value.
parentElement
The parent element of the node with the specified name.

Return Value

A decimal value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDecimal Method


MindFusion.Scheduling.XmlSerializationContext.ReadDouble Method (String, XElement)

XmlSerializationContext.ReadDouble Method (String, XElement)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadDouble ( _
elementName As String, _
parentElement As XElement _
) As Double

Parameters

elementName
The name of the element containing the double value.
parentElement
The parent element of the node with the specified name.

Return Value

A double value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDouble Method


MindFusion.Scheduling.XmlSerializationContext.ReadEnum Method (String, XElement)

XmlSerializationContext.ReadEnum Method (String, XElement)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadEnum ( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName
The name of the element containing the enum value.
parentElement
The parent element of the node with the specified name.

Return Value

An enum value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteEnum Method


MindFusion.Scheduling.XmlSerializationContext.ReadFloat Method (String, XElement)

XmlSerializationContext.ReadFloat Method (String, XElement)
See Also
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public float ReadFloat (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadFloat ( _
elementName As String, _
parentElement As XElement _
) As Single

Parameters

elementName
The name of the element containing the float value.
parentElement
The parent element of the node with the specified name.

Return Value

A float value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteFloat Method


MindFusion.Scheduling.XmlSerializationContext.ReadInt Method (String, XElement)

XmlSerializationContext.ReadInt Method (String, XElement)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadInt ( _
elementName As String, _
parentElement As XElement _
) As Integer

Parameters

elementName
The name of the element containing the integer value.
parentElement
The parent element of the node with the specified name.

Return Value

An integer value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteInt Method


MindFusion.Scheduling.XmlSerializationContext.ReadLong Method (String, XElement)

XmlSerializationContext.ReadLong Method (String, XElement)
See Also
[image]

Reads a long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadLong ( _
elementName As String, _
parentElement As XElement _
) As Long

Parameters

elementName
The name of the element containing the long value.
parentElement
The parent element of the node with the specified name.

Return Value

An long value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteLong Method


MindFusion.Scheduling.XmlSerializationContext.ReadObject Method (String, XElement)

XmlSerializationContext.ReadObject Method (String, XElement)
See Also
[image]

Reads an object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Object ReadObject (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadObject ( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName
The name of the element containing the value.
parentElement
The parent element of the node with the specified name.

Return Value

An object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteObject Method


MindFusion.Scheduling.XmlSerializationContext.ReadPoint Method (String, XElement)

XmlSerializationContext.ReadPoint Method (String, XElement)
See Also
[image]

Reads a Point object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Point ReadPoint (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadPoint ( _
elementName As String, _
parentElement As XElement _
) As Point

Parameters

elementName
The name of the element containing the .NET Point object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Point object. Returns an empty Point if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WritePoint Method


MindFusion.Scheduling.XmlSerializationContext.ReadRect Method (String, XElement)

XmlSerializationContext.ReadRect Method (String, XElement)
See Also
[image]

Reads a Rect object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Rect ReadRect (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadRect ( _
elementName As String, _
parentElement As XElement _
) As Rect

Parameters

elementName
The name of the element containing the Rect object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Rect object. Returns an empty Rect if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteRect Method


MindFusion.Scheduling.XmlSerializationContext.ReadRecurrence Method (String, XElement)

XmlSerializationContext.ReadRecurrence Method (String, XElement)
See Also
[image]

Reads a Recurrence object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Recurrence ReadRecurrence (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadRecurrence ( _
elementName As String, _
parentElement As XElement _
) As Recurrence

Parameters

elementName
The name of the element containing the Recurrence object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the Recurrence class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteRecurrence Method


MindFusion.Scheduling.XmlSerializationContext.ReadReminder Method (String, XElement)

XmlSerializationContext.ReadReminder Method (String, XElement)
See Also
[image]

Reads a Reminder object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Reminder ReadReminder (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadReminder ( _
elementName As String, _
parentElement As XElement _
) As Reminder

Parameters

elementName
The name of the element containing the Reminder object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the Reminder class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteReminder Method


MindFusion.Scheduling.XmlSerializationContext.ReadSByte Method (String, XElement)

XmlSerializationContext.ReadSByte Method (String, XElement)
See Also
[image]

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadSByte ( _
elementName As String, _
parentElement As XElement _
) As SByte

Parameters

elementName
The name of the element containing the signed byte value.
parentElement
The parent element of the node with the specified name.

Return Value

A signed byte value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteSByte Method


MindFusion.Scheduling.XmlSerializationContext.ReadShort Method (String, XElement)

XmlSerializationContext.ReadShort Method (String, XElement)
See Also
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadShort ( _
elementName As String, _
parentElement As XElement _
) As Short

Parameters

elementName
The name of the element containing the short value.
parentElement
The parent element of the node with the specified name.

Return Value

A short value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteShort Method


MindFusion.Scheduling.XmlSerializationContext.ReadSize Method (String, XElement)

XmlSerializationContext.ReadSize Method (String, XElement)
See Also
[image]

Reads a Size object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Size ReadSize (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadSize ( _
elementName As String, _
parentElement As XElement _
) As Size

Parameters

elementName
The name of the element containing the .NET Size object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Size object. Returns an empty Size if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteSize Method


MindFusion.Scheduling.XmlSerializationContext.ReadString Method (String, XElement)

XmlSerializationContext.ReadString Method (String, XElement)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadString ( _
elementName As String, _
parentElement As XElement _
) As String

Parameters

elementName
The name of the element containing the string value.
parentElement
The parent element of the node with the specified name.

Return Value

A string value. Returns an empty string if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteString Method


MindFusion.Scheduling.XmlSerializationContext.ReadTag Method (Object, String, XElement)

XmlSerializationContext.ReadTag Method (Object, String, XElement)
See Also
[image]

Reads the specified tag for the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Object ReadTag (
Object item,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadTag ( _
item As Object, _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

item
The Item whose tag is being read.
elementName
The name of the element containing the tag value.
parentElement
The parent element of the node with the specified name.

Return Value

An object value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteTag Method


MindFusion.Scheduling.XmlSerializationContext.ReadUInt Method (String, XElement)

XmlSerializationContext.ReadUInt Method (String, XElement)
See Also
[image]

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadUInt ( _
elementName As String, _
parentElement As XElement _
) As UInteger

Parameters

elementName
The name of the element containing the unsigned integer value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned integer value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteUInt Method


MindFusion.Scheduling.XmlSerializationContext.ReadULong Method (String, XElement)

XmlSerializationContext.ReadULong Method (String, XElement)
See Also
[image]

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadULong ( _
elementName As String, _
parentElement As XElement _
) As ULong

Parameters

elementName
The name of the element containing the unsigned long value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned long value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteULong Method


MindFusion.Scheduling.XmlSerializationContext.ReadUShort Method (String, XElement)

XmlSerializationContext.ReadUShort Method (String, XElement)
See Also
[image]

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function ReadUShort ( _
elementName As String, _
parentElement As XElement _
) As UShort

Parameters

elementName
The name of the element containing the unsigned short value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned short value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteUShort Method


MindFusion.Scheduling.XmlSerializationContext.SelectNodes Method (XNode, String)

XmlSerializationContext.SelectNodes Method (XNode, String)
See Also
[image]

Selects all nodes matching the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static IEnumerable<XNode> SelectNodes (
XNode parent,
string name
)
Visual Basic [image] Copy Code

Public Shared Function SelectNodes ( _
parent As XNode, _
name As String _
) As IEnumerable(Of XNode)

Parameters

parent
The parent element whose children are to be selected.
name
A string specifying the names of the nodes of interest.

Return Value

A .NET IEnumerable containing the nodes matching the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.SelectSingleNode Method (XNode, String)

XmlSerializationContext.SelectSingleNode Method (XNode, String)
See Also
[image]

Selects a node with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static XElement SelectSingleNode (
XNode parent,
string name
)
Visual Basic [image] Copy Code

Public Shared Function SelectSingleNode ( _
parent As XNode, _
name As String _
) As XElement

Parameters

parent
The parent element whose child is to be selected.
name
A string specifying the name of the node of interest.

Return Value

A .NET XElement representing the found node or null (Nothing in Visual Basic) if no node with the specified name has been found.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.WriteBool Method (Boolean, String, XElement)

XmlSerializationContext.WriteBool Method (Boolean, String, XElement)
See Also
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteBool (
bool value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteBool ( _
value As Boolean, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The bool value to write.
elementName

The name of the element under which the value should be written.

parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadBool Method


MindFusion.Scheduling.XmlSerializationContext.WriteByte Method (Byte, String, XElement)

XmlSerializationContext.WriteByte Method (Byte, String, XElement)
See Also
[image]

Write a byte value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteByte (
byte value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteByte ( _
value As Byte, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The byte value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadByte Method


MindFusion.Scheduling.XmlSerializationContext.WriteChar Method (Char, String, XElement)

XmlSerializationContext.WriteChar Method (Char, String, XElement)
See Also
[image]

Write a char value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteChar (
char value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteChar ( _
value As Char, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The char value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadChar Method


MindFusion.Scheduling.XmlSerializationContext.WriteColor Method (Color, String, XElement)

XmlSerializationContext.WriteColor Method (Color, String, XElement)
See Also
[image]

Writes the specified color.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteColor (
Color color,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteColor ( _
color As Color, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

color
The .NET Color object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadColor Method


MindFusion.Scheduling.XmlSerializationContext.WriteDateTime Method (DateTime, String, XElement)

XmlSerializationContext.WriteDateTime Method (DateTime, String, XElement)
See Also
[image]

Writes the specified DateTime object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteDateTime (
DateTime value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteDateTime ( _
value As DateTime, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The .NET DateTime object to write.
elementName
The name of the element under which the object should be written.
parentElement

The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDateTime Method


MindFusion.Scheduling.XmlSerializationContext.WriteDecimal Method (Decimal, String, XElement)

XmlSerializationContext.WriteDecimal Method (Decimal, String, XElement)
See Also
[image]

Write a decimal value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteDecimal (
Decimal value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteDecimal ( _
value As Decimal, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The decimal value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDecimal Method


MindFusion.Scheduling.XmlSerializationContext.WriteDouble Method (Double, String, XElement)

XmlSerializationContext.WriteDouble Method (Double, String, XElement)
See Also
[image]

Writes a double value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteDouble (
double value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteDouble ( _
value As Double, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The double value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDouble Method


MindFusion.Scheduling.XmlSerializationContext.WriteEnum Method (Object, String, XElement)

XmlSerializationContext.WriteEnum Method (Object, String, XElement)
See Also
[image]

Writes the specified enum value.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteEnum (
Object value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteEnum ( _
value As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The enum value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadEnum Method


MindFusion.Scheduling.XmlSerializationContext.WriteFloat Method (Single, String, XElement)

XmlSerializationContext.WriteFloat Method (Single, String, XElement)
See Also
[image]

Writes a float value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteFloat (
float value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteFloat ( _
value As Single, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The float value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadFloat Method


MindFusion.Scheduling.XmlSerializationContext.WriteInt Method (Int32, String, XElement)

XmlSerializationContext.WriteInt Method (Int32, String, XElement)
See Also
[image]

Writes an integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteInt (
int value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteInt ( _
value As Integer, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The integer value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadInt Method


MindFusion.Scheduling.XmlSerializationContext.WriteLong Method (Int64, String, XElement)

XmlSerializationContext.WriteLong Method (Int64, String, XElement)
See Also
[image]

Writes a long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteLong (
long value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteLong ( _
value As Long, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The long value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadLong Method


MindFusion.Scheduling.XmlSerializationContext.WriteObject Method (Object, String, XElement)

XmlSerializationContext.WriteObject Method (Object, String, XElement)
See Also
[image]

Writes the specified object under the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteObject (
Object value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteObject ( _
value As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadObject Method


MindFusion.Scheduling.XmlSerializationContext.WritePoint Method (Point, String, XElement)

XmlSerializationContext.WritePoint Method (Point, String, XElement)
See Also
[image]

Writes a Point with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WritePoint (
Point value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WritePoint ( _
value As Point, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The .NET Point object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadPoint Method


MindFusion.Scheduling.XmlSerializationContext.WriteRect Method (Rect, String, XElement)

XmlSerializationContext.WriteRect Method (Rect, String, XElement)
See Also
[image]

Writes a Rect with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteRect (
Rect value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteRect ( _
value As Rect, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The .NET Rect object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.WriteRecurrence Method (Recurrence, String, XElement)

XmlSerializationContext.WriteRecurrence Method (Recurrence, String, XElement)
See Also
[image]

Writes the specified Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteRecurrence (
Recurrence recurrence,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteRecurrence ( _
recurrence As Recurrence, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

recurrence
The Recurrence instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadRecurrence Method


MindFusion.Scheduling.XmlSerializationContext.WriteReminder Method (Reminder, String, XElement)

XmlSerializationContext.WriteReminder Method (Reminder, String, XElement)
See Also
[image]

Writes the specified Reminder object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteReminder (
Reminder reminder,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteReminder ( _
reminder As Reminder, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

reminder
The Reminder instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.WriteSByte Method (SByte, String, XElement)

XmlSerializationContext.WriteSByte Method (SByte, String, XElement)
See Also
[image]

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteSByte (
sbyte value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteSByte ( _
value As SByte, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The signed byte value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadSByte Method


MindFusion.Scheduling.XmlSerializationContext.WriteShort Method (Int16, String, XElement)

XmlSerializationContext.WriteShort Method (Int16, String, XElement)
See Also
[image]

Writes a short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteShort (
short value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteShort ( _
value As Short, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The short value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadShort Method


MindFusion.Scheduling.XmlSerializationContext.WriteSize Method (Size, String, XElement)

XmlSerializationContext.WriteSize Method (Size, String, XElement)
See Also
[image]

Writes a Size with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteSize (
Size value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteSize ( _
value As Size, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The .NET Size object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadSize Method


MindFusion.Scheduling.XmlSerializationContext.WriteString Method (String, String, XElement)

XmlSerializationContext.WriteString Method (String, String, XElement)
See Also
[image]

Writes a string value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteString (
string value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteString ( _
value As String, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The string value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadString Method


MindFusion.Scheduling.XmlSerializationContext.WriteTag Method (Object, Object, String, XElement)

XmlSerializationContext.WriteTag Method (Object, Object, String, XElement)
See Also
[image]

Writes the specified tag of the specified object.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteTag (
Object item,
Object tagValue,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteTag ( _
item As Object, _
tagValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

item
The Item whose tag is being written.
tagValue
The tag value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadTag Method


MindFusion.Scheduling.XmlSerializationContext.WriteUInt Method (UInt32, String, XElement)

XmlSerializationContext.WriteUInt Method (UInt32, String, XElement)
See Also
[image]

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteUInt (
uint value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteUInt ( _
value As UInteger, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The unsigned integer value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadUInt Method


MindFusion.Scheduling.XmlSerializationContext.WriteULong Method (UInt64, String, XElement)

XmlSerializationContext.WriteULong Method (UInt64, String, XElement)
See Also
[image]

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteULong (
ulong value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteULong ( _
value As ULong, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The unsigned long value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadULong Method


MindFusion.Scheduling.XmlSerializationContext.WriteUShort Method (UInt16, String, XElement)

XmlSerializationContext.WriteUShort Method (UInt16, String, XElement)
See Also
[image]

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteUShort (
ushort value,
string elementName,
XElement parentElement
)
Visual Basic [image] Copy Code

Public Function WriteUShort ( _
value As UShort, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

value
The unsigned short value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadUShort Method


MindFusion.Scheduling.XmlSerializationContext Properties

XmlSerializationContext Properties
[image]

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
XmlDocument | Gets the underlying XML document.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ClassVersion Property

XmlSerializationContext.ClassVersion Property
[image]

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ClassVersion { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer value specifying the class version of the currently deserialized item as specified by the call to RegisterItemClass method at the time the item type was registered.

Remarks

This property is only useful when deserializing items.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.XmlDocument Property

XmlSerializationContext.XmlDocument Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public XDocument XmlDocument { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property XmlDocument As XDocument

Property Value

An instance of the .NET XDocument class.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.YearlyRecurrence Enumeration

YearlyRecurrence Enumeration
[image]

Specifies the types of yearly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum YearlyRecurrence
Visual Basic [image] Copy Code

Public Enumeration YearlyRecurrence

Members

Member name | Description
ByDayType | The event occurs on a specific type of day of the specified week and month of the year.
SpecificDate | The event occurs on a specific date of the year.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Silverlight Namespace
Classes Enumerations

Classes

Class | Description
ItemPresenter | Defines the base class of custom item presenter classes.
Calendar | The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.
CalendarSettings | The base class for the different theme-aware settings classes.
CellSettings | Defines appearance settings for the cells representing time ranges in the calendar.
DateChangedEventArgs | Contains the arguments passed to handlers of the VisibleDateChanged event.
DateCollection | Represents a strongly-typed sorted collection of DateTime objects.
DateEventArgs | Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.
ItemConfirmEventArgs | Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.
ItemEditConfirmEventArgs | Contains the arguments passed to handlers of the ItemInplaceEditEnding event.
ItemModifiedEventArgs | Contains the arguments passed to handlers of the ItemModified event.
ItemModifyConfirmEventArgs | Contains the arguments passed to handlers of the ItemModifying event.
ItemMouseEventArgs | Contains the arguments passed to handlers of the ItemClick event.
ItemSelection | An instance of this class represents a set of selected schedule items.
ItemSelectionEventArgs | Contains the arguments passed to handlers of selection related events.
ItemSettings | Defines properties that allow customizing the visualization of schedule items in the calendar views.
ListViewSettings | Defines properties that allow customizing the visualization of the calendar in a List view.
MonthRangeSettings | Defines settings for the years in the calendar.
MonthSettings | Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.
RecurringItemConfirmEventArgs | Contains the arguments passed to handlers of the RecurringItemDeleting event.
ResourceDateEventArgs | Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.
Selection | Represents a set of selected date cells and defines a visualization style applied to the selected elements.
TimetableSettings | Defines properties that allow customizing the visualization of the calendar in Timetable view.
WeekRangeSettings | Defines properties that allow customizing the visualization of weeks in WeekRange view.
CalendarStyle | Specifies the appearance of calendar elements.
ItemPresenterAttribute | Associates a custom item presenter with a schedule item class.
ResizeBands | Represents the resize and move bands of items in a Timetable and Resource views.
ResourceViewSettings | Defines properties that allow customizing the visualization of the calendar in Resource view.
TimelineSettings | Encapsulates settings for a timeline in a Resource view.
SideBorders | Represents a four-sided border, similar to the Border class, but with the ability to draw each side in a separate color.
VisibleConverter | Converts System.Boolean to System.Windows.Visibility by mapping true to Visibility.Visible and false to Visibility.Collapsed.
CellPresenter | Defines the presentation of cells in calendar views.

Enumerations

Enumeration | Description
CalendarView | Specifies the type of view to display in a calendar control.
DayOfWeekFormat | Specifies the display format of a day of the week.
GroupType | Specifies grouping or filtering criteria for views that support grouping.
ItemAction | Specifies a user action on a schedule item.
ListViewHeaderStyles | Specifies the appearance and behavior of the header in a List view.
MinuteFormat | Specifies how to format and display minutes in the Timetable view.
MonthCellLayout | Specifies the layout of the cells in a SingleMonth and MonthRange views.
MonthHeaderStyles | Specifies the appearance and behavior of month headers in a SingleMonth and MonthRange views.
MonthRangeHeaderStyles | Specifies the appearance and behavior of the header in a MonthRange view.
MonthWeekHeaderStyle | Specifies the placement of the week numbers header in a SingleMonth view.
Orientation | Specifies horizontal or vertical orientation.
Position | Specifies the position of an element relative to its container.
ThemeType | Specifies a calendar theme.
TimeUnit | Specifies a time resolution.
WeekRangeHeaderStyle | Specifies the appearance of the time period header in WeekRange view.
WeekRangeViewStyle | Specifies whether there are multiple weeks displayed in WeekRange view.
ResourceViewStyle | Specifies the style of a Resource view.


MindFusion.Scheduling.Silverlight.Calendar Class

Calendar Class
[image]

The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class Calendar : UserControl, IComponentConnector
Visual Basic [image] Copy Code

Public Class Calendar
Inherits UserControl
Implements IComponentConnector

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.UserControl
MindFusion.Scheduling.Silverlight.Calendar

See Also

Calendar Members
MindFusion.Scheduling.Silverlight Namespace


MindFusion.Scheduling.Silverlight.Calendar Members

Calendar Members
Constructors Fields Properties Methods Events
[image]

The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.

The following tables list the members exposed by the Calendar type.

Public Constructors

Name | Description
Calendar | Overloaded. Initializes a new instance of the Calendar class.

Public Fields

Name | Description
CurrentViewProperty | Identifies the CurrentView dependency property.
GroupTypeProperty | Identifies the GroupType dependency property.
ItemChangeReferenceKeyProperty | Identifies the ItemChangeReferenceKey dependency property.
ItemContactsProperty | Identifies the ItemContacts dependency property.
ItemLocationsProperty | Identifies the ItemLocations dependency property.
ItemResourcesProperty | Identifies the ItemResources dependency property.
ItemSettingsProperty | Identifies the ItemSettings dependency property.
ItemTasksProperty | Identifies the ItemTasks dependency property.
ListViewSettingsProperty | Identifies the ListViewSettings dependency property.
MonthRangeSettingsProperty | Identifies the MonthRangeSettings dependency property.
MonthSettingsProperty | Identifies the MonthSettings dependency property.
SelectionProperty | Identifies the Selection dependency property.
SelectionToolTipFormatProperty | Identifies the SelectionToolTipFormat dependency property.
ShowSelectionToolTipsProperty | Identifies the ShowSelectionToolTips dependency property.
ThemeProperty | Identifies the Theme dependency property.
TimetableSettingsProperty | Identifies the TimetableSettings dependency property.
WeekRangeSettingsProperty | Identifies the WeekRangeSettings dependency property.

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle.
AllowInplaceCreate | Gets or sets a value indicating whether users are allowed to create items interactively.
AllowInplaceEdit | Gets or sets a value indicating whether users are allowed to edit items interactively.
ButtonOffset | Gets or set the offset of the navigation buttons, displayed in the views' headers.
ButtonSize | Gets or sets the size of the navigation buttons, displayed in the views' headers.
ContactNameFormat | Gets or sets how to format and display contact names in the timetable header.
Culture | Gets or sets the CultureInfo object used to format and display time information in the calendar.
CurrentView | Gets or sets the type of the calendar view. This is a dependency property.
Date | Gets or sets the date currently displayed in the calendar.
DateTimeFormat | Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.
DelayInplaceEdit | Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked.
DisableReminders | Gets or sets a value indicating whether to completely disable reminders in the whole schedule.
EnableDragCreate | Gets or sets a value indicating whether items are created merely by dragging in the control.
EndDate | Gets or sets the last date displayed in the calendar.
FirstWeekendDay | Gets or sets the first weekend day in the calendar.
GroupType | Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views. This is a dependency property.
HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed.
HScrollPos | Gets or sets the current horizontal scroll position.
InteractiveItemType | Gets or sets the type of an Item-derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.
ItemChangeReferenceKey | Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view. This is a dependency property.
ItemContacts | Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.
ItemLocations | Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.
ItemResources | Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.
ItemSelection | Gets a list of all selected items.
ItemSettings | Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.
ItemTasks | Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.
ListViewSettings | Gets the ListViewSettings object used to customize the visualization of the List view.
MonthRangeSettings | Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.
MonthSettings | Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.
RemindersCheckInterval | Gets or sets the interval between reminder checks, expressed in seconds.
ResourceViewSettings | Gets or sets the ResourceViewSettings object used to customize the Resource view.
Schedule | Gets or sets the schedule whose information should be displayed inside the calendar control.
Selection | Gets a Selection object representing the current selection in the calendar.
SelectionToolTipFormat | Gets or sets the format of a selection tooltip. This is a dependency property.
ShowSelectionToolTips | Gets or sets a value indicating whether selection ranges in certain views provide tooltips when hovered with the mouse. This is a dependency property.
Theme | Gets or sets the theme applied to the calendar control UI elements. This is a dependency property.
TimetableSettings | Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.
VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed.
VScrollPos | Gets or sets the current vertical scroll position.
WeekRangeSettings | Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

Public Methods

Name | Description
BeginInit | Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.
CollapseResourceRow | Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
EndInit | Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.
EnsureVisible | Overloaded. Ensures that a specific date or item is visible within the control, scrolling the contents of the control if necessary.
ExpandResourceRow | Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
GetDateAt | Overloaded. Returns the date of the calendar cell located at the specified coordinates.
GetItemListLane | Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.
GetItemStyle | Retrieves the CalendarStyle previously associated with the normal state of the specified item.
GetItemTooltip | Retrieves the string tooltip previously associated with the item.
GetPointedItemStyle | Retrieves the CalendarStyle previously associated with the pointed state of the specified item.
GetPointedSelectedItemStyle | Retrieves the CalendarStyle previously associated with the pointed and selected state of the specified item.
GetSelectedItemStyle | Retrieves the CalendarStyle previously associated with the selected state of the specified item.
IsResourceRowExpanded | Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.
ResetDrag | If there is a mouse drag operation in progress, it is canceled.
SetItemListLane | Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.
SetItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is in a normal state.
SetItemTooltip | Associates a new string tooltip with the specified item.
SetPointedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is pointed with the mouse.
SetPointedSelectedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is pointed and selected with the mouse.
SetSelectedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is selected.

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.
OnCellPresenterCreated | Raises the CellPresenterCreated event.
OnCellPresenterCreating | Raises the CellPresenterCreating event.
OnDateClick | Raises the DateClick event.
OnHScroll | Raises the HScroll event.
OnItemClick | Raises the ItemClick event.
OnItemCloned | Raises the ItemCloned event.
OnItemCloning | Raises the ItemCloning event.
OnItemCreated | Raises the ItemCreated event.
OnItemCreating | Raises the ItemCreating event.
OnItemCreationCanceled | Raises the ItemCreationCanceled event.
OnItemDeleted | Raises the ItemDeleted event.
OnItemDeleting | Raises the ItemDeleting event.
OnItemDeselecting | Raises the ItemDeselecting event.
OnItemInplaceEdited | Raises the ItemInplaceEdited event.
OnItemInplaceEditEnding | Raises the ItemInplaceEditEnding event.
OnItemInplaceEditStarting | Raises the ItemInplaceEditStarting event.
OnItemListLaneChanged | Raises the ItemListLaneChanged event.
OnItemModificationCanceled | Raises the ItemModificationCanceled event.
OnItemModified | Raises the ItemModified event.
OnItemModifying | Raises the ItemModifying event.
OnItemPresenterCreated | Raises the ItemPresenterCreated event.
OnItemSelecting | Raises the ItemSelecting event.
OnItemSelectionChanged | Raises the ItemSelectionChanged event.
OnItemSelectionComplete | Raises the ItemSelectionComplete event.
OnListViewHeaderClick | Raises the ListViewHeaderClick event.
OnMonthCellClick | Raises the MonthCellClick event.
OnMonthHeaderClick | Raises the MonthHeaderClick event.
OnMonthRangeHeaderClick | Raises the MonthRangeHeaderClick event.
OnMonthWeekHeaderClick | Raises the MonthWeekHeaderClick event.
OnRecurringItemDeleting | Raises the RecurringItemDeleting event.
OnResourceViewBottomTimelineClick | Raises the ResourceViewBottomTimelineClick event.
OnResourceViewMiddleTimelineClick | Raises the ResourceViewMiddleTimelineClick event.
OnResourceViewTopTimelineClick | Raises the ResourceViewTopTimelineClick event.
OnScroll | Raises the Scroll event.
OnTimetableColumnHeaderClick | Raises the TimetableColumnHeaderClick event.
OnVisibleDateChanged | Raises the VisibleDateChanged event.
OnVScroll | Raises the VScroll event.
OnWeekRangeHeaderClick | Raises the WeekRangeHeaderClick event.

Public Events

Name | Description
CellPresenterCreated | Raised when the CellPresenter control that will visualize specific view cell is created.
CellPresenterCreating | Raised when the CellPresenter control that will visualize specific view cell is being instantiated.
DateClick | Raised when the user clicks a date cell in the calendar.
HScroll | Raised when the control has been scrolled horizontally.
ItemClick | Raised when the user clicks a schedule item.
ItemCloned | Raised when the user has cloned an item interactively.
ItemCloning | Raised when the user is about to clone an item interactively.
ItemCreated | Raised when a schedule item is created by the user.
ItemCreating | Raised when the user is about to create a new schedule item.
ItemCreationCanceled | Raised when an interactive item creation is canceled by the user.
ItemDeleted | Raised when the user deletes a schedule item.
ItemDeleting | Raised when the user is about to delete a schedule item.
ItemDeselecting | Raised when an item is about to be deselected.
ItemInplaceEdited | Raised when item's text is in-place edited.
ItemInplaceEditEnding | Raised when in-place editing of item's text is about to be accepted.
ItemInplaceEditStarting | Raised when in-place editing of item's text is about to begin.
ItemListLaneChanged | Raised when the lane index of an item within a List view has changed.
ItemModificationCanceled | Raised when an item modification is canceled by the user.
ItemModified | Raised when a schedule item is moved or resized by the user.
ItemModifying | Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.
ItemPresenterCreated | Raised when the ItemPresenter Control that will visualise specific item is created.
ItemSelecting | Raised when an item is about to be selected.
ItemSelectionChanged | Raised when an item is selected or deselected.
ItemSelectionComplete | Raised when an item is selected or deselected.
ListViewHeaderClick | Raised when the header of a List view is clicked.
MonthCellClick | Raised when the user clicks on a month cell in a SingleMonth and MonthRange views.
MonthHeaderClick | Raised when the header of a Month view is clicked.
MonthRangeHeaderClick | Raised when the header of an MonthRange view is clicked.
MonthWeekHeaderClick | Raised when a cell in the week header of a Month view is clicked.
RecurringItemDeleting | Raised when the user is about to delete a recurring item.
ResourceViewBottomTimelineClick | Raised when the bottom timeline of a Resource view is clicked.
ResourceViewMiddleTimelineClick | Raised when the middle timeline of a Resource view is clicked.
ResourceViewTopTimelineClick | Raised when the top timeline of a Resource view is clicked.
Scroll | Raised when the value of a scrollbar has changed.
TimetableColumnHeaderClick | Raised when the header of a Timetable column is clicked.
VisibleDateChanged | Raised when the user selects another date using the month or year navigation controls on the calendar header area.
VScroll | Raised when the control has been scrolled vertically.
WeekRangeHeaderClick | Raised when the header of a WeekRange view is clicked.

See Also

Calendar Class


MindFusion.Scheduling.Silverlight.Calendar Fields

Calendar Fields
[image]

Public Fields

Name | Description
CurrentViewProperty | Identifies the CurrentView dependency property.
GroupTypeProperty | Identifies the GroupType dependency property.
ItemChangeReferenceKeyProperty | Identifies the ItemChangeReferenceKey dependency property.
ItemContactsProperty | Identifies the ItemContacts dependency property.
ItemLocationsProperty | Identifies the ItemLocations dependency property.
ItemResourcesProperty | Identifies the ItemResources dependency property.
ItemSettingsProperty | Identifies the ItemSettings dependency property.
ItemTasksProperty | Identifies the ItemTasks dependency property.
ListViewSettingsProperty | Identifies the ListViewSettings dependency property.
MonthRangeSettingsProperty | Identifies the MonthRangeSettings dependency property.
MonthSettingsProperty | Identifies the MonthSettings dependency property.
SelectionProperty | Identifies the Selection dependency property.
SelectionToolTipFormatProperty | Identifies the SelectionToolTipFormat dependency property.
ShowSelectionToolTipsProperty | Identifies the ShowSelectionToolTips dependency property.
ThemeProperty | Identifies the Theme dependency property.
TimetableSettingsProperty | Identifies the TimetableSettings dependency property.
WeekRangeSettingsProperty | Identifies the WeekRangeSettings dependency property.

See Also

Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.CurrentViewProperty Field

Calendar.CurrentViewProperty Field
[image]

Identifies the CurrentView dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CurrentViewProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CurrentViewProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.GroupTypeProperty Field

Calendar.GroupTypeProperty Field
[image]

Identifies the GroupType dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupTypeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly GroupTypeProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemChangeReferenceKeyProperty Field

Calendar.ItemChangeReferenceKeyProperty Field
[image]

Identifies the ItemChangeReferenceKey dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemChangeReferenceKeyProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ItemChangeReferenceKeyProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemContactsProperty Field

Calendar.ItemContactsProperty Field
[image]

Identifies the ItemContacts dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty ItemContactsProperty
Visual Basic [image] Copy Code

Public Shared ItemContactsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemLocationsProperty Field

Calendar.ItemLocationsProperty Field
[image]

Identifies the ItemLocations dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty ItemLocationsProperty
Visual Basic [image] Copy Code

Public Shared ItemLocationsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemResourcesProperty Field

Calendar.ItemResourcesProperty Field
[image]

Identifies the ItemResources dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty ItemResourcesProperty
Visual Basic [image] Copy Code

Public Shared ItemResourcesProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemSettingsProperty Field

Calendar.ItemSettingsProperty Field
[image]

Identifies the ItemSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ItemSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemTasksProperty Field

Calendar.ItemTasksProperty Field
[image]

Identifies the ItemTasks dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty ItemTasksProperty
Visual Basic [image] Copy Code

Public Shared ItemTasksProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ListViewSettingsProperty Field

Calendar.ListViewSettingsProperty Field
[image]

Identifies the ListViewSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ListViewSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ListViewSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.MonthRangeSettingsProperty Field

Calendar.MonthRangeSettingsProperty Field
[image]

Identifies the MonthRangeSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MonthRangeSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MonthRangeSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.MonthSettingsProperty Field

Calendar.MonthSettingsProperty Field
[image]

Identifies the MonthSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MonthSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MonthSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.SelectionProperty Field

Calendar.SelectionProperty Field
[image]

Identifies the Selection dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.SelectionToolTipFormatProperty Field

Calendar.SelectionToolTipFormatProperty Field
[image]

Identifies the SelectionToolTipFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectionToolTipFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectionToolTipFormatProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ShowSelectionToolTipsProperty Field

Calendar.ShowSelectionToolTipsProperty Field
[image]

Identifies the ShowSelectionToolTips dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowSelectionToolTipsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowSelectionToolTipsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ThemeProperty Field

Calendar.ThemeProperty Field
[image]

Identifies the Theme dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ThemeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ThemeProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.TimetableSettingsProperty Field

Calendar.TimetableSettingsProperty Field
[image]

Identifies the TimetableSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimetableSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TimetableSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.WeekRangeSettingsProperty Field

Calendar.WeekRangeSettingsProperty Field
[image]

Identifies the WeekRangeSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekRangeSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly WeekRangeSettingsProperty As DependencyProperty

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar Constructor

Calendar Constructor
[image]

Initializes a new instance of the Calendar class.

Overload List

Name | Description
Calendar () | Initializes a new instance of the Calendar class using the current culture info.
Calendar (CultureInfo) | Initializes a new instance of the Calendar class using the specified culture info.

See Also

Calendar Class


MindFusion.Scheduling.Silverlight.Calendar Constructor ()

Calendar Constructor ()
See Also
[image]

Initializes a new instance of the Calendar class using the current culture info.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Calendar ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

Calendar Constructor Overload List
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar Constructor (CultureInfo)

Calendar Constructor (CultureInfo)
See Also
[image]

Initializes a new instance of the Calendar class using the specified culture info.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Calendar (
CultureInfo culture
)
Visual Basic [image] Copy Code

Public New ( _
culture As CultureInfo _
)

Parameters

culture
A .NET CultureInfo object providing information about formatting and displaying dates and times.

See Also

Calendar Constructor Overload List
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar Methods

Calendar Methods
[image]

Public Methods

Name | Description
BeginInit | Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.
CollapseResourceRow | Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
EndInit | Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.
EnsureVisible | Overloaded. Ensures that a specific date or item is visible within the control, scrolling the contents of the control if necessary.
ExpandResourceRow | Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
GetDateAt | Overloaded. Returns the date of the calendar cell located at the specified coordinates.
GetItemListLane | Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.
GetItemStyle | Retrieves the CalendarStyle previously associated with the normal state of the specified item.
GetItemTooltip | Retrieves the string tooltip previously associated with the item.
GetPointedItemStyle | Retrieves the CalendarStyle previously associated with the pointed state of the specified item.
GetPointedSelectedItemStyle | Retrieves the CalendarStyle previously associated with the pointed and selected state of the specified item.
GetSelectedItemStyle | Retrieves the CalendarStyle previously associated with the selected state of the specified item.
IsResourceRowExpanded | Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.
ResetDrag | If there is a mouse drag operation in progress, it is canceled.
SetItemListLane | Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.
SetItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is in a normal state.
SetItemTooltip | Associates a new string tooltip with the specified item.
SetPointedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is pointed with the mouse.
SetPointedSelectedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is pointed and selected with the mouse.
SetSelectedItemStyle | Associates a new CalendarStyle with the specified item, which will be used when the item is selected.

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.
OnCellPresenterCreated | Raises the CellPresenterCreated event.
OnCellPresenterCreating | Raises the CellPresenterCreating event.
OnDateClick | Raises the DateClick event.
OnHScroll | Raises the HScroll event.
OnItemClick | Raises the ItemClick event.
OnItemCloned | Raises the ItemCloned event.
OnItemCloning | Raises the ItemCloning event.
OnItemCreated | Raises the ItemCreated event.
OnItemCreating | Raises the ItemCreating event.
OnItemCreationCanceled | Raises the ItemCreationCanceled event.
OnItemDeleted | Raises the ItemDeleted event.
OnItemDeleting | Raises the ItemDeleting event.
OnItemDeselecting | Raises the ItemDeselecting event.
OnItemInplaceEdited | Raises the ItemInplaceEdited event.
OnItemInplaceEditEnding | Raises the ItemInplaceEditEnding event.
OnItemInplaceEditStarting | Raises the ItemInplaceEditStarting event.
OnItemListLaneChanged | Raises the ItemListLaneChanged event.
OnItemModificationCanceled | Raises the ItemModificationCanceled event.
OnItemModified | Raises the ItemModified event.
OnItemModifying | Raises the ItemModifying event.
OnItemPresenterCreated | Raises the ItemPresenterCreated event.
OnItemSelecting | Raises the ItemSelecting event.
OnItemSelectionChanged | Raises the ItemSelectionChanged event.
OnItemSelectionComplete | Raises the ItemSelectionComplete event.
OnListViewHeaderClick | Raises the ListViewHeaderClick event.
OnMonthCellClick | Raises the MonthCellClick event.
OnMonthHeaderClick | Raises the MonthHeaderClick event.
OnMonthRangeHeaderClick | Raises the MonthRangeHeaderClick event.
OnMonthWeekHeaderClick | Raises the MonthWeekHeaderClick event.
OnRecurringItemDeleting | Raises the RecurringItemDeleting event.
OnResourceViewBottomTimelineClick | Raises the ResourceViewBottomTimelineClick event.
OnResourceViewMiddleTimelineClick | Raises the ResourceViewMiddleTimelineClick event.
OnResourceViewTopTimelineClick | Raises the ResourceViewTopTimelineClick event.
OnScroll | Raises the Scroll event.
OnTimetableColumnHeaderClick | Raises the TimetableColumnHeaderClick event.
OnVisibleDateChanged | Raises the VisibleDateChanged event.
OnVScroll | Raises the VScroll event.
OnWeekRangeHeaderClick | Raises the WeekRangeHeaderClick event.

See Also

Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.BeginInit Method

Calendar.BeginInit Method
[image]

Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void BeginInit ()
Visual Basic [image] Copy Code

Public Overrides Sub BeginInit ()

Example

The following example demonstrates how to use BeginInit and EndInit to prevent unnecessary updating.

C# [image] Copy Code

using MindFusion.Scheduling.Silverlight;

// ...

calendar.BeginInit();
calendar.Date = DateTime.Today;
calendar.EndDate = DateTime.Today + TimeSpan.FromDays(100);
calendar.CurrentView = CalendarView.WeekRange;
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow;
calendar.WeekRangeSettings.GroupWeekends = true;
calendar.EndInit();
Visual Basic [image] Copy Code

Imports MindFusion.Scheduling.Silverlight

' ...

calendar.BeginInit()
calendar.Date = DateTime.Today
calendar.EndDate = DateTime.Today.Add(TimeSpan.FromDays(100))
calendar.CurrentView = CalendarView.WeekRange
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow
calendar.WeekRangeSettings.GroupWeekends = True
calendar.EndInit()

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.CollapseResourceRow Method

Calendar.CollapseResourceRow Method
[image]

Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void CollapseResourceRow (
Resource reference
)
Visual Basic [image] Copy Code

Public Sub CollapseResourceRow ( _
reference As Resource _
)

Parameters

reference
A reference to a Contact, Location, Task or Resource object whose row is to be collapsed.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
ExpandResourceRow Method
IsResourceRowExpanded Method


MindFusion.Scheduling.Silverlight.Calendar.EndInit Method

Calendar.EndInit Method
[image]

Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void EndInit ()
Visual Basic [image] Copy Code

Public Overrides Sub EndInit ()

Example

The following example demonstrates how to use BeginInit and EndInit to prevent unnecessary updating.

C# [image] Copy Code

using MindFusion.Scheduling.Silverlight;

// ...

calendar.BeginInit();
calendar.Date = DateTime.Today;
calendar.EndDate = DateTime.Today + TimeSpan.FromDays(100);
calendar.CurrentView = CalendarView.WeekRange;
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow;
calendar.WeekRangeSettings.GroupWeekends = true;
calendar.EndInit();
Visual Basic [image] Copy Code

Imports MindFusion.Scheduling.Silverlight

' ...

calendar.BeginInit()
calendar.Date = DateTime.Today
calendar.EndDate = DateTime.Today.Add(TimeSpan.FromDays(100))
calendar.CurrentView = CalendarView.WeekRange
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow
calendar.WeekRangeSettings.GroupWeekends = True
calendar.EndInit()

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.EnsureVisible Method

Calendar.EnsureVisible Method
[image]

Ensures that a specific date or item is visible within the control, scrolling the contents of the control if necessary.

Overload List

Name | Description
Calendar.EnsureVisible (DateTime) | Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary.
Calendar.EnsureVisible (DateTime, Resource) | Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary. The reference parameter allows specifying a Task, Location, Contact or Resource for which to display the date in a view with enabled grouping.
Calendar.EnsureVisible (Item) | Ensures that the item is visible within the control, scrolling the contents of the control if necessary.
Calendar.EnsureVisible (Item, Resource) | Ensures that the item is visible within the control, scrolling the contents of the control if necessary.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.EnsureVisible Method (DateTime)

Calendar.EnsureVisible Method (DateTime)
See Also
[image]

Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void EnsureVisible (
DateTime date
)
Visual Basic [image] Copy Code

Public Sub EnsureVisible ( _
date As DateTime _
)

Parameters

date
A DateTime instance identifying the date to scroll into view.

Remarks

This method does nothing if the specified date is not included in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.EnsureVisible Method (DateTime, Resource)

Calendar.EnsureVisible Method (DateTime, Resource)
See Also
[image]

Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary. The reference parameter allows specifying a Task, Location, Contact or Resource for which to display the date in a view with enabled grouping.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void EnsureVisible (
DateTime date,
Resource reference
)
Visual Basic [image] Copy Code

Public Sub EnsureVisible ( _
date As DateTime, _
reference As Resource _
)

Parameters

date
A DateTime instance identifying the date to scroll into view.
reference
A reference to Task, Location, Contact or Resource whose group to display in the view.

Remarks

This method does nothing if the specified date is not included in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.EnsureVisible Method (Item)

Calendar.EnsureVisible Method (Item)
See Also
[image]

Ensures that the item is visible within the control, scrolling the contents of the control if necessary.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void EnsureVisible (
Item item
)
Visual Basic [image] Copy Code

Public Sub EnsureVisible ( _
item As Item _
)

Parameters

item
The schedule Item to scroll into view.

Remarks

This method does nothing if the item is not scheduled to occur in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.EnsureVisible Method (Item, Resource)

Calendar.EnsureVisible Method (Item, Resource)
See Also
[image]

Ensures that the item is visible within the control, scrolling the contents of the control if necessary.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void EnsureVisible (
Item item,
Resource reference
)
Visual Basic [image] Copy Code

Public Sub EnsureVisible ( _
item As Item, _
reference As Resource _
)

Parameters

item
The schedule Item to scroll into view.
reference
A reference to Task, Location, Contact or Resource whose group to display in the view.

Remarks

This method does nothing if the item is not scheduled to occur in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ExpandResourceRow Method

Calendar.ExpandResourceRow Method
[image]

Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void ExpandResourceRow (
Resource reference
)
Visual Basic [image] Copy Code

Public Sub ExpandResourceRow ( _
reference As Resource _
)

Parameters

reference
A reference to a Contact, Location, Task or Resource object whose row is to be expanded.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
CollapseResourceRow Method
ExpandResourceRow Method


MindFusion.Scheduling.Silverlight.Calendar.GetDateAt Method

Calendar.GetDateAt Method
[image]

Returns the date of the calendar cell located at the specified coordinates.

Overload List

Name | Description
Calendar.GetDateAt (Int32, Int32) | Returns the date of the calendar cell located at the specified coordinates.
Calendar.GetDateAt (Point) | Returns the date of the calendar cell located at the specified position.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.GetDateAt Method (Int32, Int32)

Calendar.GetDateAt Method (Int32, Int32)
See Also
[image]

Returns the date of the calendar cell located at the specified coordinates.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Nullable<DateTime> GetDateAt (
int x,
int y
)
Visual Basic [image] Copy Code

Public Function GetDateAt ( _
x As Integer, _
y As Integer _
) As Nullable(Of DateTime)

Parameters

x
The x-coordinate of the position at which to look for a date cell.
y
The y-coordinate of the position at which to look for a date cell.

Return Value

A DateTime instance indicating which date is displayed at the specified position. If there is no date cell at the specified position, the return value is null (Nothing in Visual Basic).

See Also

GetDateAt Method Overload List
Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.GetDateAt Method (Point)

Calendar.GetDateAt Method (Point)
See Also
[image]

Returns the date of the calendar cell located at the specified position.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Nullable<DateTime> GetDateAt (
Point point
)
Visual Basic [image] Copy Code

Public Function GetDateAt ( _
point As Point _
) As Nullable(Of DateTime)

Parameters

point
The position at which to look for a date cell.

Return Value

A DateTime instance indicating which date is displayed at the specified position. If there is no date cell at the specified point, the return value is null (Nothing in Visual Basic).

See Also

GetDateAt Method Overload List
Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.GetItemListLane Method

Calendar.GetItemListLane Method
[image]

Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int GetItemListLane (
Item item
)
Visual Basic [image] Copy Code

Public Function GetItemListLane ( _
item As Item _
) As Integer

Parameters

item
A reference to the Item whose lane index to retrieve.

Return Value

The zero-based index of the item lane or -1, if the item is not associated with a lane.

See Also

Calendar Members
Calendar Class
SetItemListLane Method


MindFusion.Scheduling.Silverlight.Calendar.GetItemStyle Method

Calendar.GetItemStyle Method
[image]

Retrieves the CalendarStyle previously associated with the normal state of the specified item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle GetItemStyle (
Item item
)
Visual Basic [image] Copy Code

Public Function GetItemStyle ( _
item As Item _
) As CalendarStyle

Parameters

item
A reference to the Item whose style is being requested.

Return Value

An instance of the CalendarStyle class or null (Nothing in Visual Basic) if no style has been associated with the item.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
GetPointedItemStyle Method
GetPointedSelectedItemStyle Method
GetSelectedItemStyle Method


MindFusion.Scheduling.Silverlight.Calendar.GetItemTooltip Method

Calendar.GetItemTooltip Method
[image]

Retrieves the string tooltip previously associated with the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string GetItemTooltip (
Item item
)
Visual Basic [image] Copy Code

Public Function GetItemTooltip ( _
item As Item _
) As String

Parameters

item
An Item whose tooltip to retrieve.

Return Value

The tooltip previously associated with the item through the SetItemTooltip method or null (Nothing in Visual Basic) if the item does not have an associated tooltip.

See Also

Calendar Members
Calendar Class
SetItemTooltip Method


MindFusion.Scheduling.Silverlight.Calendar.GetPointedItemStyle Method

Calendar.GetPointedItemStyle Method
[image]

Retrieves the CalendarStyle previously associated with the pointed state of the specified item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle GetPointedItemStyle (
Item item
)
Visual Basic [image] Copy Code

Public Function GetPointedItemStyle ( _
item As Item _
) As CalendarStyle

Parameters

item
A reference to the Item whose style is being requested.

Return Value

An instance of the CalendarStyle class or null (Nothing in Visual Basic) if no style has been associated with the item.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
GetItemStyle Method
GetPointedSelectedItemStyle Method
GetSelectedItemStyle Method


MindFusion.Scheduling.Silverlight.Calendar.GetPointedSelectedItemStyle Method

Calendar.GetPointedSelectedItemStyle Method
[image]

Retrieves the CalendarStyle previously associated with the pointed and selected state of the specified item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle GetPointedSelectedItemStyle (
Item item
)
Visual Basic [image] Copy Code

Public Function GetPointedSelectedItemStyle ( _
item As Item _
) As CalendarStyle

Parameters

item
A reference to the Item whose style is being requested.

Return Value

An instance of the CalendarStyle class or null (Nothing in Visual Basic) if no style has been associated with the item.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
GetItemStyle Method
GetPointedItemStyle Method
GetSelectedItemStyle Method


MindFusion.Scheduling.Silverlight.Calendar.GetSelectedItemStyle Method

Calendar.GetSelectedItemStyle Method
[image]

Retrieves the CalendarStyle previously associated with the selected state of the specified item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle GetSelectedItemStyle (
Item item
)
Visual Basic [image] Copy Code

Public Function GetSelectedItemStyle ( _
item As Item _
) As CalendarStyle

Parameters

item
A reference to the Item whose style is being requested.

Return Value

An instance of the CalendarStyle class or null (Nothing in Visual Basic) if no style has been associated with the item.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
GetItemStyle Method
GetPointedItemStyle Method
GetPointedSelectedItemStyle Method


MindFusion.Scheduling.Silverlight.Calendar.IsResourceRowExpanded Method

Calendar.IsResourceRowExpanded Method
[image]

Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool IsResourceRowExpanded (
Resource reference
)
Visual Basic [image] Copy Code

Public Function IsResourceRowExpanded ( _
reference As Resource _
) As Boolean

Parameters

reference
A reference to a Contact, Location, Task or Resource object to be checked.

Return Value

Returns true if the associated row is expanded or false if either the row is collapsed, there is no such row or the current view is not a ResourceView.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
CollapseResourceRow Method
ExpandResourceRow Method


MindFusion.Scheduling.Silverlight.Calendar.MeasureOverride Method

Calendar.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)
Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride ( _
constraint As Size _
) As Size

Parameters

constraint
The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

Remarks

MindFusion.Scheduling for Silverlight always uses all available space.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnCellPresenterCreated Method

Calendar.OnCellPresenterCreated Method
[image]

Raises the CellPresenterCreated event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnCellPresenterCreated (
CellPresenterEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnCellPresenterCreated ( _
e As CellPresenterEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnCellPresenterCreating Method

Calendar.OnCellPresenterCreating Method
[image]

Raises the CellPresenterCreating event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnCellPresenterCreating (
CellPresenterCreatingEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnCellPresenterCreating ( _
e As CellPresenterCreatingEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnDateClick Method

Calendar.OnDateClick Method
[image]

Raises the DateClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnDateClick (
ResourceDateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnDateClick ( _
e As ResourceDateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnHScroll Method

Calendar.OnHScroll Method
[image]

Raises the HScroll event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnHScroll (
ScrollEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnHScroll ( _
e As ScrollEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemClick Method

Calendar.OnItemClick Method
[image]

Raises the ItemClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemClick (
ItemMouseEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemClick ( _
e As ItemMouseEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemCloned Method

Calendar.OnItemCloned Method
[image]

Raises the ItemCloned event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemCloned (
ItemEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemCloned ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemCloning Method

Calendar.OnItemCloning Method
[image]

Raises the ItemCloning event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemCloning (
ItemConfirmEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemCloning ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemCreated Method

Calendar.OnItemCreated Method
[image]

Raises the ItemCreated event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemCreated (
ItemEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemCreated ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemCreating Method

Calendar.OnItemCreating Method
[image]

Raises the ItemCreating event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemCreating (
ItemConfirmEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemCreating ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemCreationCanceled Method

Calendar.OnItemCreationCanceled Method
[image]

Raises the ItemCreationCanceled event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemCreationCanceled (
ItemEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemCreationCanceled ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemDeleted Method

Calendar.OnItemDeleted Method
[image]

Raises the ItemDeleted event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemDeleted (
ItemEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemDeleted ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemDeleting Method

Calendar.OnItemDeleting Method
[image]

Raises the ItemDeleting event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemDeleting (
ItemConfirmEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemDeleting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemDeselecting Method

Calendar.OnItemDeselecting Method
[image]

Raises the ItemDeselecting event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemDeselecting (
ItemConfirmEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemDeselecting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemInplaceEdited Method

Calendar.OnItemInplaceEdited Method
[image]

Raises the ItemInplaceEdited event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemInplaceEdited (
ItemEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemInplaceEdited ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemInplaceEditEnding Method

Calendar.OnItemInplaceEditEnding Method
[image]

Raises the ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemInplaceEditEnding (
ItemEditConfirmEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemInplaceEditEnding ( _
e As ItemEditConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemInplaceEditStarting Method

Calendar.OnItemInplaceEditStarting Method
[image]

Raises the ItemInplaceEditStarting event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemInplaceEditStarting (
ItemConfirmEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemInplaceEditStarting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemListLaneChanged Method

Calendar.OnItemListLaneChanged Method
[image]

Raises the ItemListLaneChanged event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemListLaneChanged (
ItemEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemListLaneChanged ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemModificationCanceled Method

Calendar.OnItemModificationCanceled Method
[image]

Raises the ItemModificationCanceled event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemModificationCanceled (
ItemEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemModificationCanceled ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemModified Method

Calendar.OnItemModified Method
[image]

Raises the ItemModified event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemModified (
ItemModifiedEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemModified ( _
e As ItemModifiedEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemModifying Method

Calendar.OnItemModifying Method
[image]

Raises the ItemModifying event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemModifying (
ItemModifyConfirmEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemModifying ( _
e As ItemModifyConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemPresenterCreated Method

Calendar.OnItemPresenterCreated Method
[image]

Raises the ItemPresenterCreated event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemPresenterCreated (
ItemPresenterEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemPresenterCreated ( _
e As ItemPresenterEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemSelecting Method

Calendar.OnItemSelecting Method
[image]

Raises the ItemSelecting event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemSelecting (
ItemConfirmEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemSelecting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemSelectionChanged Method

Calendar.OnItemSelectionChanged Method
[image]

Raises the ItemSelectionChanged event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemSelectionChanged (
ItemSelectionEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemSelectionChanged ( _
e As ItemSelectionEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnItemSelectionComplete Method

Calendar.OnItemSelectionComplete Method
[image]

Raises the ItemSelectionComplete event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnItemSelectionComplete (
EventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnItemSelectionComplete ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnListViewHeaderClick Method

Calendar.OnListViewHeaderClick Method
[image]

Raises the ListViewHeaderClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnListViewHeaderClick (
DateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnListViewHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnMonthCellClick Method

Calendar.OnMonthCellClick Method
[image]

Raises the MonthCellClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnMonthCellClick (
DateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnMonthCellClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnMonthHeaderClick Method

Calendar.OnMonthHeaderClick Method
[image]

Raises the MonthHeaderClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnMonthHeaderClick (
DateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnMonthHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnMonthRangeHeaderClick Method

Calendar.OnMonthRangeHeaderClick Method
[image]

Raises the MonthRangeHeaderClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnMonthRangeHeaderClick (
DateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnMonthRangeHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnMonthWeekHeaderClick Method

Calendar.OnMonthWeekHeaderClick Method
[image]

Raises the MonthWeekHeaderClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnMonthWeekHeaderClick (
DateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnMonthWeekHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnRecurringItemDeleting Method

Calendar.OnRecurringItemDeleting Method
[image]

Raises the RecurringItemDeleting event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnRecurringItemDeleting (
RecurringItemConfirmEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnRecurringItemDeleting ( _
e As RecurringItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnResourceViewBottomTimelineClick Method

Calendar.OnResourceViewBottomTimelineClick Method
[image]

Raises the ResourceViewBottomTimelineClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnResourceViewBottomTimelineClick (
DateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnResourceViewBottomTimelineClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnResourceViewMiddleTimelineClick Method

Calendar.OnResourceViewMiddleTimelineClick Method
[image]

Raises the ResourceViewMiddleTimelineClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnResourceViewMiddleTimelineClick (
DateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnResourceViewMiddleTimelineClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnResourceViewTopTimelineClick Method

Calendar.OnResourceViewTopTimelineClick Method
[image]

Raises the ResourceViewTopTimelineClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnResourceViewTopTimelineClick (
DateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnResourceViewTopTimelineClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnScroll Method

Calendar.OnScroll Method
[image]

Raises the Scroll event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnScroll (
EventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnScroll ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnTimetableColumnHeaderClick Method

Calendar.OnTimetableColumnHeaderClick Method
[image]

Raises the TimetableColumnHeaderClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnTimetableColumnHeaderClick (
DateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnTimetableColumnHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnVisibleDateChanged Method

Calendar.OnVisibleDateChanged Method
[image]

Raises the VisibleDateChanged event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnVisibleDateChanged (
DateChangedEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnVisibleDateChanged ( _
e As DateChangedEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnVScroll Method

Calendar.OnVScroll Method
[image]

Raises the VScroll event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnVScroll (
ScrollEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnVScroll ( _
e As ScrollEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.OnWeekRangeHeaderClick Method

Calendar.OnWeekRangeHeaderClick Method
[image]

Raises the WeekRangeHeaderClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnWeekRangeHeaderClick (
DateEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnWeekRangeHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ResetDrag Method

Calendar.ResetDrag Method
[image]

If there is a mouse drag operation in progress, it is canceled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void ResetDrag ()
Visual Basic [image] Copy Code

Public Sub ResetDrag ()

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.SetItemListLane Method

Calendar.SetItemListLane Method
[image]

Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SetItemListLane (
Item item,
int lane
)
Visual Basic [image] Copy Code

Public Sub SetItemListLane ( _
item As Item, _
lane As Integer _
)

Parameters

item
A reference to the Item whose lane index to set.
lane
The zero-based index of the new item lane.

See Also

Calendar Members
Calendar Class
GetItemListLane Method


MindFusion.Scheduling.Silverlight.Calendar.SetItemStyle Method

Calendar.SetItemStyle Method
[image]

Associates a new CalendarStyle with the specified item, which will be used when the item is in a normal state.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SetItemStyle (
Item item,
CalendarStyle value
)
Visual Basic [image] Copy Code

Public Sub SetItemStyle ( _
item As Item, _
value As CalendarStyle _
)

Parameters

item
A reference to the Item whose style is being set.
value

A reference to the new style of the item or null (Nothing in Visual Basic) to discard any previously associated style.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
SetPointedItemStyle Method
SetPointedSelectedItemStyle Method
SetSelectedItemStyle Method


MindFusion.Scheduling.Silverlight.Calendar.SetItemTooltip Method

Calendar.SetItemTooltip Method
[image]

Associates a new string tooltip with the specified item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SetItemTooltip (
Item item,
string value
)
Visual Basic [image] Copy Code

Public Sub SetItemTooltip ( _
item As Item, _
value As String _
)

Parameters

item
The Item whose tooltip to set.
value
The new tooltip of the item.

See Also

Calendar Members
Calendar Class
GetItemTooltip Method


MindFusion.Scheduling.Silverlight.Calendar.SetPointedItemStyle Method

Calendar.SetPointedItemStyle Method
[image]

Associates a new CalendarStyle with the specified item, which will be used when the item is pointed with the mouse.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SetPointedItemStyle (
Item item,
CalendarStyle value
)
Visual Basic [image] Copy Code

Public Sub SetPointedItemStyle ( _
item As Item, _
value As CalendarStyle _
)

Parameters

item
A reference to the Item whose style is being set.
value
A reference to the new style of the item or null (Nothing in Visual Basic) to discard any previously associated style.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
SetItemStyle Method
SetPointedSelectedItemStyle Method
SetSelectedItemStyle Method


MindFusion.Scheduling.Silverlight.Calendar.SetPointedSelectedItemStyle Method

Calendar.SetPointedSelectedItemStyle Method
[image]

Associates a new CalendarStyle with the specified item, which will be used when the item is pointed and selected with the mouse.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SetPointedSelectedItemStyle (
Item item,
CalendarStyle value
)
Visual Basic [image] Copy Code

Public Sub SetPointedSelectedItemStyle ( _
item As Item, _
value As CalendarStyle _
)

Parameters

item
A reference to the Item whose style is being set.
value
A reference to the new style of the item or null (Nothing in Visual Basic) to discard any previously associated style.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
SetItemStyle Method
SetPointedItemStyle Method
SetSelectedItemStyle Method


MindFusion.Scheduling.Silverlight.Calendar.SetSelectedItemStyle Method

Calendar.SetSelectedItemStyle Method
[image]

Associates a new CalendarStyle with the specified item, which will be used when the item is selected.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void SetSelectedItemStyle (
Item item,
CalendarStyle value
)
Visual Basic [image] Copy Code

Public Sub SetSelectedItemStyle ( _
item As Item, _
value As CalendarStyle _
)

Parameters

item
A reference to the Item whose style is being set.
value
A reference to the new style of the item or null (Nothing in Visual Basic) to discard any previously associated style.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
SetItemStyle Method
SetPointedItemStyle Method
SetPointedSelectedItemStyle Method


MindFusion.Scheduling.Silverlight.Calendar Properties

Calendar Properties
[image]

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle.
AllowInplaceCreate | Gets or sets a value indicating whether users are allowed to create items interactively.
AllowInplaceEdit | Gets or sets a value indicating whether users are allowed to edit items interactively.
ButtonOffset | Gets or set the offset of the navigation buttons, displayed in the views' headers.
ButtonSize | Gets or sets the size of the navigation buttons, displayed in the views' headers.
ContactNameFormat | Gets or sets how to format and display contact names in the timetable header.
Culture | Gets or sets the CultureInfo object used to format and display time information in the calendar.
CurrentView | Gets or sets the type of the calendar view. This is a dependency property.
Date | Gets or sets the date currently displayed in the calendar.
DateTimeFormat | Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.
DelayInplaceEdit | Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked.
DisableReminders | Gets or sets a value indicating whether to completely disable reminders in the whole schedule.
EnableDragCreate | Gets or sets a value indicating whether items are created merely by dragging in the control.
EndDate | Gets or sets the last date displayed in the calendar.
FirstWeekendDay | Gets or sets the first weekend day in the calendar.
GroupType | Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views. This is a dependency property.
HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed.
HScrollPos | Gets or sets the current horizontal scroll position.
InteractiveItemType | Gets or sets the type of an Item-derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.
ItemChangeReferenceKey | Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view. This is a dependency property.
ItemContacts | Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.
ItemLocations | Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.
ItemResources | Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.
ItemSelection | Gets a list of all selected items.
ItemSettings | Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.
ItemTasks | Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.
ListViewSettings | Gets the ListViewSettings object used to customize the visualization of the List view.
MonthRangeSettings | Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.
MonthSettings | Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.
RemindersCheckInterval | Gets or sets the interval between reminder checks, expressed in seconds.
ResourceViewSettings | Gets or sets the ResourceViewSettings object used to customize the Resource view.
Schedule | Gets or sets the schedule whose information should be displayed inside the calendar control.
Selection | Gets a Selection object representing the current selection in the calendar.
SelectionToolTipFormat | Gets or sets the format of a selection tooltip. This is a dependency property.
ShowSelectionToolTips | Gets or sets a value indicating whether selection ranges in certain views provide tooltips when hovered with the mouse. This is a dependency property.
Theme | Gets or sets the theme applied to the calendar control UI elements. This is a dependency property.
TimetableSettings | Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.
VerticalScrollBarVisibility | Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed.
VScrollPos | Gets or sets the current vertical scroll position.
WeekRangeSettings | Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

See Also

Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.AllowAutoScroll Property

Calendar.AllowAutoScroll Property
[image]

Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool AllowAutoScroll { get; set; }
Visual Basic [image] Copy Code

Public Property AllowAutoScroll As Boolean

Property Value

true to enable automatic scrolling; otherwise, false. The default is true.

Remarks

Automatic scrolling starts when a schedule item or a selection of items is dragged near the borders of the calendar contents rectangle. The contents rectangle is the part of a calendar view that contains all time cells and excludes the headers. If the mouse is moved outside the contents rectangle, the scrolling stops.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.AllowInplaceCreate Property

Calendar.AllowInplaceCreate Property
[image]

Gets or sets a value indicating whether users are allowed to create items interactively.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool AllowInplaceCreate { get; set; }
Visual Basic [image] Copy Code

Public Property AllowInplaceCreate As Boolean

Property Value

true to allow users to create schedule items; otherwise, false. The default is true.

Remarks

If this property is disabled, users cannot create items interactively. If it is enabled and InteractiveItemType is not null (Nothing in Visual Basic), a new schedule item of the specified type is created when users start typing in a time cell. This raises the ItemCreating event, which lets your application validate the operation or cancel it.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
InteractiveItemType Property
AllowInplaceEdit Property


MindFusion.Scheduling.Silverlight.Calendar.AllowInplaceEdit Property

Calendar.AllowInplaceEdit Property
[image]

Gets or sets a value indicating whether users are allowed to edit items interactively.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool AllowInplaceEdit { get; set; }
Visual Basic [image] Copy Code

Public Property AllowInplaceEdit As Boolean

Property Value

true to allow users to edit schedule items; otherwise, false. The default is true.

Remarks

If this property is disabled, users cannot edit item's text interactively. Controlling the editing of item text can be done by handling the ItemInplaceEditStarting and ItemInplaceEditEnding events.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
InteractiveItemType Property
AllowInplaceCreate Property


MindFusion.Scheduling.Silverlight.Calendar.ButtonOffset Property

Calendar.ButtonOffset Property
[image]

Gets or set the offset of the navigation buttons, displayed in the views' headers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ButtonOffset { get; set; }
Visual Basic [image] Copy Code

Public Property ButtonOffset As Integer

Property Value

An integer value specifying how many pixels there are between a button and header edges. The default is 4.

Remarks

The buttons get smaller if the value of this property is increased.

See Also

Calendar Members
Calendar Class
ButtonSize Property


MindFusion.Scheduling.Silverlight.Calendar.ButtonSize Property

Calendar.ButtonSize Property
[image]

Gets or sets the size of the navigation buttons, displayed in the views' headers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ButtonSize { get; set; }
Visual Basic [image] Copy Code

Public Property ButtonSize As Integer

Property Value

An integer value specifying the size of the navigation buttons displayed in the List, SingleMonth, MonthRange and Timetable views. The default is 0.

Remarks

The value of this property specifies the absolute size of the navigation buttons. If the value is 0, the size of the buttons is calculated automatically according to the size of the headers that contain them and the value of the ButtonOffset property.

See Also

Calendar Members
Calendar Class
ButtonOffset Property


MindFusion.Scheduling.Silverlight.Calendar.ContactNameFormat Property

Calendar.ContactNameFormat Property
[image]

Gets or sets how to format and display contact names in the timetable header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string ContactNameFormat { get; set; }
Visual Basic [image] Copy Code

Public Property ContactNameFormat As String

Property Value

A string specifying the name format. The default is "F M L".

Remarks

Use the capital letters F, M and L as placeholders for the First, Middle and Last names. Any other character will be displayed unchanged.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.Culture Property

Calendar.Culture Property
[image]

Gets or sets the CultureInfo object used to format and display time information in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CultureInfo Culture { get; set; }
Visual Basic [image] Copy Code

Public Property Culture As CultureInfo

Property Value

An instance of the .NET CultureInfo class.

Remarks

Setting the culture info results in reinitialization of all culture-specific properties, such as day and month names, first day of the week, and so on.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.CurrentView Property

Calendar.CurrentView Property
[image]

Gets or sets the type of the calendar view. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarView CurrentView { get; set; }
Visual Basic [image] Copy Code

Public Property CurrentView As CalendarView

Property Value

A member of the CalendarView enumeration. The default is SingleMonth.

Remarks

The control can display the schedule data in several different types of views. This property allows changing the current view and can be used to implement drill down into the schedule data by switching from more general to more specialized views.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.Date Property

Calendar.Date Property
[image]

Gets or sets the date currently displayed in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime Date { get; set; }
Visual Basic [image] Copy Code

Public Property Date As DateTime

Property Value

A .NET DateTime object. The initial value is DateTime.Today.

Remarks

This value is not used in a timetable view. To specify the dates displayed in timetable view, use TimetableSettings.Dates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
EndDate Property
TimetableSettings.Dates Property


MindFusion.Scheduling.Silverlight.Calendar.DateTimeFormat Property

Calendar.DateTimeFormat Property
[image]

Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTimeFormatInfo DateTimeFormat { get; set; }
Visual Basic [image] Copy Code

Public Property DateTimeFormat As DateTimeFormatInfo

Property Value

An instance of the .NET DateTimeFormatInfo class.

Remarks

If this property is not set, the calendar uses the DateFormatInfo from the associated Culture.

Note

Setting various subproperties of this property is transparent for the Calendar control and in order to update the control, you should enclose the property sets in a BeginInit/EndInit block. See the example section below for illustration.

Example

The following example demonstrates how to properly set various properties of the DateTimeFormat property. The example code assumes that calendar is a variable identifying existing Calendar instance.

C# [image] Copy Code

calendar.BeginInit();
calendar.DateTimeFormat.FirstDayOfWeek = DayOfWeek.Monday;
calendar.EndInit();
Visual Basic [image] Copy Code

calendar.BeginInit()
calendar.DateTimeFormat.FirstDayOfWeek = DayOfWeek.Monday
calendar.EndInit()

See Also

Calendar Members
Calendar Class
Culture Property


MindFusion.Scheduling.Silverlight.Calendar.DelayInplaceEdit Property

Calendar.DelayInplaceEdit Property
[image]

Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool DelayInplaceEdit { get; set; }
Visual Basic [image] Copy Code

Public Property DelayInplaceEdit As Boolean

Property Value

true to delay in-place editing; otherwise, false. The default is true.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.DisableReminders Property

Calendar.DisableReminders Property
[image]

Gets or sets a value indicating whether to completely disable reminders in the whole schedule.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool DisableReminders { get; set; }
Visual Basic [image] Copy Code

Public Property DisableReminders As Boolean

Property Value

true to disable the reminder events; otherwise, false. The default is true.

See Also

Calendar Members
Calendar Class
RemindersCheckInterval Property


MindFusion.Scheduling.Silverlight.Calendar.EnableDragCreate Property

Calendar.EnableDragCreate Property
[image]

Gets or sets a value indicating whether items are created merely by dragging in the control.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool EnableDragCreate { get; set; }
Visual Basic [image] Copy Code

Public Property EnableDragCreate As Boolean

Property Value

true to enable interactive item creation when the users clicks and drags in the control; false to disable it. The default is false.

Remarks

By default, the items in MindFusion.Scheduling for Silverlight are created interactively by selecting a time range in the current view and typing. Setting this property to true overrides this behavior and enables users to create items by clicking and dragging.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.EndDate Property

Calendar.EndDate Property
[image]

Gets or sets the last date displayed in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime EndDate { get; set; }
Visual Basic [image] Copy Code

Public Property EndDate As DateTime

Property Value

A .NET DateTime object. The initial value is set 30 days after Date.

Remarks

This member is only valid in WeekRange view.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.FirstWeekendDay Property

Calendar.FirstWeekendDay Property
[image]

Gets or sets the first weekend day in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DayOfWeek FirstWeekendDay { get; set; }
Visual Basic [image] Copy Code

Public Property FirstWeekendDay As DayOfWeek

Property Value

A member of the .NET DayOfWeek enumeration.

Remarks

Specifies which day to regard as start of the weekend.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.GroupType Property

Calendar.GroupType Property
[image]

Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public GroupType GroupType { get; set; }
Visual Basic [image] Copy Code

Public Property GroupType As GroupType

Property Value

A member of the GroupType enumeration. The default is None.

Remarks

For more information about grouping in MindFusion.Scheduling for Silverlight check Grouping.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.HorizontalScrollBarVisibility Property

Calendar.HorizontalScrollBarVisibility Property
[image]

Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
Visual Basic [image] Copy Code

Public Property HorizontalScrollBarVisibility As ScrollBarVisibility

Property Value

A member of the ScrollBarVisibility enumeration. The default is a Auto.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.HScrollPos Property

Calendar.HScrollPos Property
[image]

Gets or sets the current horizontal scroll position.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public double HScrollPos { get; set; }
Visual Basic [image] Copy Code

Public Property HScrollPos As Double

Property Value

An integer value specifying the current horizontal scroll position.

See Also

Calendar Members
Calendar Class
VScrollPos Property


MindFusion.Scheduling.Silverlight.Calendar.InteractiveItemType Property

Calendar.InteractiveItemType Property
[image]

Gets or sets the type of an Item-derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Type InteractiveItemType { get; set; }
Visual Basic [image] Copy Code

Public Property InteractiveItemType As Type

Property Value

An instance of the .NET Type class specifying what type of items to create when a user starts typing. The default is Appointment.

Remarks

If this property is set to null (Nothing in Visual Basic), users cannot create items interactively.

Note

If you implement custom Item-derived class, make sure it provides parameterless constructor. Otherwise, no items will be created.

See Also

Calendar Members
Calendar Class
AllowInplaceEdit Property


MindFusion.Scheduling.Silverlight.Calendar.ItemChangeReferenceKey Property

Calendar.ItemChangeReferenceKey Property
[image]

Gets or sets the modifier key, which lets users drag items between different contacts, resources, locations or tasks in a grouped view. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ModifierKeys ItemChangeReferenceKey { get; set; }
Visual Basic [image] Copy Code

Public Property ItemChangeReferenceKey As ModifierKeys

Property Value

A member of the ModifiedKeys enumeration. The default is Alt.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemContacts Property

Calendar.ItemContacts Property
[image]

Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Contact> ItemContacts { get; set; }
Visual Basic [image] Copy Code

Public Property ItemContacts As ResourceCollection(Of Contact)

Property Value

An instance of the ResourceCollection(Contact) generic class specifying which contacts are displayed as columns in grouped views.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemLocations Property

Calendar.ItemLocations Property
[image]

Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Location> ItemLocations { get; set; }
Visual Basic [image] Copy Code

Public Property ItemLocations As ResourceCollection(Of Location)

Property Value

An instance of the ResourceCollection(Location) generic class specifying which locations are displayed as columns in grouped views.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemResources Property

Calendar.ItemResources Property
[image]

Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Resource> ItemResources { get; set; }
Visual Basic [image] Copy Code

Public Property ItemResources As ResourceCollection(Of Resource)

Property Value

An instance of the ResourceCollection(Resource) generic class specifying which resources are displayed as columns in grouped views.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemSelection Property

Calendar.ItemSelection Property
[image]

Gets a list of all selected items.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemSelection ItemSelection { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ItemSelection As ItemSelection

Property Value

An instance of the ItemSelection class representing the currently selected items.

Remarks

Use Selection to get the collection of all selected time cells.

See Also

Calendar Members
Calendar Class
Selection Property


MindFusion.Scheduling.Silverlight.Calendar.ItemSettings Property

Calendar.ItemSettings Property
[image]

Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemSettings ItemSettings { get; set; }
Visual Basic [image] Copy Code

Public Property ItemSettings As ItemSettings

Property Value

An instance of the ItemSettings class.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemTasks Property

Calendar.ItemTasks Property
[image]

Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceCollection<Task> ItemTasks { get; set; }
Visual Basic [image] Copy Code

Public Property ItemTasks As ResourceCollection(Of Task)

Property Value

An instance of the ResourceCollection(Resource) generic class specifying which tasks are displayed as columns in grouped views.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ListViewSettings Property

Calendar.ListViewSettings Property
[image]

Gets the ListViewSettings object used to customize the visualization of the List view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ListViewSettings ListViewSettings { get; set; }
Visual Basic [image] Copy Code

Public Property ListViewSettings As ListViewSettings

Property Value

An instance of the ListViewSettings class.

Remarks

Use the ListViewSettings members to customize the appearance of the calendar when CurrentView is set to List.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.MonthRangeSettings Property

Calendar.MonthRangeSettings Property
[image]

Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public MonthRangeSettings MonthRangeSettings { get; set; }
Visual Basic [image] Copy Code

Public Property MonthRangeSettings As MonthRangeSettings

Property Value

An instance of the MonthRangeSettings class.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.MonthSettings Property

Calendar.MonthSettings Property
[image]

Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public MonthSettings MonthSettings { get; set; }
Visual Basic [image] Copy Code

Public Property MonthSettings As MonthSettings

Property Value

An instance of the MonthSettings class.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.RemindersCheckInterval Property

Calendar.RemindersCheckInterval Property
[image]

Gets or sets the interval between reminder checks, expressed in seconds.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int RemindersCheckInterval { get; set; }
Visual Basic [image] Copy Code

Public Property RemindersCheckInterval As Integer

Property Value

An integer value. The default is 30.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ResourceViewSettings Property

Calendar.ResourceViewSettings Property
[image]

Gets or sets the ResourceViewSettings object used to customize the Resource view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceViewSettings ResourceViewSettings { get; set; }
Visual Basic [image] Copy Code

Public Property ResourceViewSettings As ResourceViewSettings

Property Value

An instance of the ResourceViewSettings class.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.Schedule Property

Calendar.Schedule Property
[image]

Gets or sets the schedule whose information should be displayed inside the calendar control.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Schedule Schedule { get; set; }
Visual Basic [image] Copy Code

Public Property Schedule As Schedule

Property Value

A Schedule object providing the schedule data displayed in the calendar view.

Remarks

You can easily substitute the schedule being displayed by the control at any time by simply assigning a new Schedule object to this property. You can also make two or more Calendar controls display the same schedule.

See Also

Calendar Members
Calendar Class
Schedule Class


MindFusion.Scheduling.Silverlight.Calendar.Selection Property

Calendar.Selection Property
[image]

Gets a Selection object representing the current selection in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Selection Selection { get; set; }
Visual Basic [image] Copy Code

Public Property Selection As Selection

Property Value

An instance of the Selection class representing the selection of time cells.

Remarks

Use ItemSelection to get the selection of schedule items.

See Also

Calendar Members
Calendar Class
ItemSelection Property


MindFusion.Scheduling.Silverlight.Calendar.SelectionToolTipFormat Property

Calendar.SelectionToolTipFormat Property
[image]

Gets or sets the format of a selection tooltip. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string SelectionToolTipFormat { get; set; }
Visual Basic [image] Copy Code

Public Property SelectionToolTipFormat As String

Property Value

A standard DateTime formatting string. The default is "HH:mm".

See Also

Calendar Members
Calendar Class
ShowSelectionToolTips Property


MindFusion.Scheduling.Silverlight.Calendar.ShowSelectionToolTips Property

Calendar.ShowSelectionToolTips Property
[image]

Gets or sets a value indicating whether selection ranges in certain views provide tooltips when hovered with the mouse. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowSelectionToolTips { get; set; }
Visual Basic [image] Copy Code

Public Property ShowSelectionToolTips As Boolean

Property Value

true, to display tooltips on selection ranges; otherwise, false.

Remarks

This property has effect only in Timetable and Resource view.

See Also

Calendar Members
Calendar Class
SelectionToolTipFormat Property


MindFusion.Scheduling.Silverlight.Calendar.Theme Property

Calendar.Theme Property
[image]

Gets or sets the theme applied to the calendar control UI elements. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ThemeType Theme { get; set; }
Visual Basic [image] Copy Code

Public Property Theme As ThemeType

Property Value

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.TimetableSettings Property

Calendar.TimetableSettings Property
[image]

Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimetableSettings TimetableSettings { get; set; }
Visual Basic [image] Copy Code

Public Property TimetableSettings As TimetableSettings

Property Value

An instance of the TimetableSettings class.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.VerticalScrollBarVisibility Property

Calendar.VerticalScrollBarVisibility Property
[image]

Gets or sets a value that indicates whether a vertical System.Windows.Controls.Primitives.ScrollBar should be displayed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
Visual Basic [image] Copy Code

Public Property VerticalScrollBarVisibility As ScrollBarVisibility

Property Value

A member of the ScrollBarVisibility enumeration. The default is a Auto.

See Also

Calendar Members
Calendar Class
HorizontalScrollBarVisibility Property


MindFusion.Scheduling.Silverlight.Calendar.VScrollPos Property

Calendar.VScrollPos Property
[image]

Gets or sets the current vertical scroll position.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public double VScrollPos { get; set; }
Visual Basic [image] Copy Code

Public Property VScrollPos As Double

Property Value

An integer value specifying the current vertical scroll position.

See Also

Calendar Members
Calendar Class
HScrollPos Property


MindFusion.Scheduling.Silverlight.Calendar.WeekRangeSettings Property

Calendar.WeekRangeSettings Property
[image]

Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public WeekRangeSettings WeekRangeSettings { get; set; }
Visual Basic [image] Copy Code

Public Property WeekRangeSettings As WeekRangeSettings

Property Value

An instance of the WeekRangeSettings class.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar Events

Calendar Events
[image]

Public Events

Name | Description
CellPresenterCreated | Raised when the CellPresenter control that will visualize specific view cell is created.
CellPresenterCreating | Raised when the CellPresenter control that will visualize specific view cell is being instantiated.
DateClick | Raised when the user clicks a date cell in the calendar.
HScroll | Raised when the control has been scrolled horizontally.
ItemClick | Raised when the user clicks a schedule item.
ItemCloned | Raised when the user has cloned an item interactively.
ItemCloning | Raised when the user is about to clone an item interactively.
ItemCreated | Raised when a schedule item is created by the user.
ItemCreating | Raised when the user is about to create a new schedule item.
ItemCreationCanceled | Raised when an interactive item creation is canceled by the user.
ItemDeleted | Raised when the user deletes a schedule item.
ItemDeleting | Raised when the user is about to delete a schedule item.
ItemDeselecting | Raised when an item is about to be deselected.
ItemInplaceEdited | Raised when item's text is in-place edited.
ItemInplaceEditEnding | Raised when in-place editing of item's text is about to be accepted.
ItemInplaceEditStarting | Raised when in-place editing of item's text is about to begin.
ItemListLaneChanged | Raised when the lane index of an item within a List view has changed.
ItemModificationCanceled | Raised when an item modification is canceled by the user.
ItemModified | Raised when a schedule item is moved or resized by the user.
ItemModifying | Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.
ItemPresenterCreated | Raised when the ItemPresenter Control that will visualise specific item is created.
ItemSelecting | Raised when an item is about to be selected.
ItemSelectionChanged | Raised when an item is selected or deselected.
ItemSelectionComplete | Raised when an item is selected or deselected.
ListViewHeaderClick | Raised when the header of a List view is clicked.
MonthCellClick | Raised when the user clicks on a month cell in a SingleMonth and MonthRange views.
MonthHeaderClick | Raised when the header of a Month view is clicked.
MonthRangeHeaderClick | Raised when the header of an MonthRange view is clicked.
MonthWeekHeaderClick | Raised when a cell in the week header of a Month view is clicked.
RecurringItemDeleting | Raised when the user is about to delete a recurring item.
ResourceViewBottomTimelineClick | Raised when the bottom timeline of a Resource view is clicked.
ResourceViewMiddleTimelineClick | Raised when the middle timeline of a Resource view is clicked.
ResourceViewTopTimelineClick | Raised when the top timeline of a Resource view is clicked.
Scroll | Raised when the value of a scrollbar has changed.
TimetableColumnHeaderClick | Raised when the header of a Timetable column is clicked.
VisibleDateChanged | Raised when the user selects another date using the month or year navigation controls on the calendar header area.
VScroll | Raised when the control has been scrolled vertically.
WeekRangeHeaderClick | Raised when the header of a WeekRange view is clicked.

See Also

Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.CellPresenterCreated Event

Calendar.CellPresenterCreated Event
[image]

Raised when the CellPresenter control that will visualize specific view cell is created.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<CellPresenterEventArgs> CellPresenterCreated
Visual Basic [image] Copy Code

Public Event CellPresenterCreated As EventHandler(Of CellPresenterEventArgs)

Event Data

CellPresenterCreated event handlers receive an argument of type CellPresenterEventArgs.

Remarks

This event can be used to supply custom styles to specific cells.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.CellPresenterCreating Event

Calendar.CellPresenterCreating Event
[image]

Raised when the CellPresenter control that will visualize specific view cell is being instantiated.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<CellPresenterCreatingEventArgs> CellPresenterCreating
Visual Basic [image] Copy Code

Public Event CellPresenterCreating As EventHandler(Of CellPresenterCreatingEventArgs)

Event Data

CellPresenterCreating event handlers receive an argument of type CellPresenterCreatingEventArgs.

Remarks

The event is raised just before the presenter of a cell is created to allow the client to instantiate a presenter of a custom type. If the event is not handled or the client does not assign an object to the CellPresenter property, the control creates a presenter of type CellPresenter.

A common scenario involves the use of the StartTime, EndTime and Resource properties in order to assign custom presenters only to cells matching specific criteria. For example, the client might associate a cell presenter only with holidays or weekend days.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.DateClick Event

Calendar.DateClick Event
[image]

Raised when the user clicks a date cell in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ResourceDateEventArgs> DateClick
Visual Basic [image] Copy Code

Public Event DateClick As EventHandler(Of ResourceDateEventArgs)

Event Data

DateClick event handlers receive an argument of type ResourceDateEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.HScroll Event

Calendar.HScroll Event
[image]

Raised when the control has been scrolled horizontally.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event ScrollEventHandler HScroll
Visual Basic [image] Copy Code

Public Event HScroll As ScrollEventHandler

Event Data

HScroll event handlers receive an argument of type ScrollEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
VScroll Event
Scroll Event


MindFusion.Scheduling.Silverlight.Calendar.ItemClick Event

Calendar.ItemClick Event
[image]

Raised when the user clicks a schedule item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemMouseEventArgs> ItemClick
Visual Basic [image] Copy Code

Public Event ItemClick As EventHandler(Of ItemMouseEventArgs)

Event Data

ItemClick event handlers receive an argument of type ItemMouseEventArgs.

See Also

Calendar Members
Calendar Class
HiddenItemClick Event


MindFusion.Scheduling.Silverlight.Calendar.ItemCloned Event

Calendar.ItemCloned Event
[image]

Raised when the user has cloned an item interactively.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemCloned
Visual Basic [image] Copy Code

Public Event ItemCloned As EventHandler(Of ItemEventArgs)

Event Data

ItemCloned event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
ItemCloning Event


MindFusion.Scheduling.Silverlight.Calendar.ItemCloning Event

Calendar.ItemCloning Event
[image]

Raised when the user is about to clone an item interactively.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemCloning
Visual Basic [image] Copy Code

Public Event ItemCloning As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemCloning event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
ItemCloned Event


MindFusion.Scheduling.Silverlight.Calendar.ItemCreated Event

Calendar.ItemCreated Event
[image]

Raised when a schedule item is created by the user.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemCreated
Visual Basic [image] Copy Code

Public Event ItemCreated As EventHandler(Of ItemEventArgs)

Event Data

ItemCreated event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
ItemCreating Event


MindFusion.Scheduling.Silverlight.Calendar.ItemCreating Event

Calendar.ItemCreating Event
[image]

Raised when the user is about to create a new schedule item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemCreating
Visual Basic [image] Copy Code

Public Event ItemCreating As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemCreating event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
ItemCreated Event


MindFusion.Scheduling.Silverlight.Calendar.ItemCreationCanceled Event

Calendar.ItemCreationCanceled Event
[image]

Raised when an interactive item creation is canceled by the user.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemCreationCanceled
Visual Basic [image] Copy Code

Public Event ItemCreationCanceled As EventHandler(Of ItemEventArgs)

Event Data

ItemCreationCanceled event handlers receive an argument of type ItemEventArgs.

Remarks

This event is raised when the user presses the ESC button while in-place editing the text of an item currently being created.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemDeleted Event

Calendar.ItemDeleted Event
[image]

Raised when the user deletes a schedule item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemDeleted
Visual Basic [image] Copy Code

Public Event ItemDeleted As EventHandler(Of ItemEventArgs)

Event Data

ItemDeleted event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
ItemDeleting Event


MindFusion.Scheduling.Silverlight.Calendar.ItemDeleting Event

Calendar.ItemDeleting Event
[image]

Raised when the user is about to delete a schedule item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemDeleting
Visual Basic [image] Copy Code

Public Event ItemDeleting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemDeleting event handlers receive an argument of type ItemConfirmEventArgs.

Remarks

This event can be used to prevent users from deleting specific non-recurring items by pressing DEL. This event is raised once for each element of the item selection. To control the deletion of recurring items, handle the RecurringItemDeleting event.

See Also

Calendar Members
Calendar Class
ItemDeleted Event


MindFusion.Scheduling.Silverlight.Calendar.ItemDeselecting Event

Calendar.ItemDeselecting Event
[image]

Raised when an item is about to be deselected.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemDeselecting
Visual Basic [image] Copy Code

Public Event ItemDeselecting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemDeselecting event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
ItemSelecting Event


MindFusion.Scheduling.Silverlight.Calendar.ItemInplaceEdited Event

Calendar.ItemInplaceEdited Event
[image]

Raised when item's text is in-place edited.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemInplaceEdited
Visual Basic [image] Copy Code

Public Event ItemInplaceEdited As EventHandler(Of ItemEventArgs)

Event Data

ItemInplaceEdited event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemInplaceEditEnding Event

Calendar.ItemInplaceEditEnding Event
[image]

Raised when in-place editing of item's text is about to be accepted.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemEditConfirmEventArgs> ItemInplaceEditEnding
Visual Basic [image] Copy Code

Public Event ItemInplaceEditEnding As EventHandler(Of ItemEditConfirmEventArgs)

Event Data

ItemInplaceEditEnding event handlers receive an argument of type ItemEditConfirmEventArgs.

Remarks

This event can be used to validate the text entered into a schedule item during the in-place editing mode.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemInplaceEditStarting Event

Calendar.ItemInplaceEditStarting Event
[image]

Raised when in-place editing of item's text is about to begin.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemInplaceEditStarting
Visual Basic [image] Copy Code

Public Event ItemInplaceEditStarting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemInplaceEditStarting event handlers receive an argument of type ItemConfirmEventArgs.

Remarks

This event can be handled to prevent users from editing the text of specific schedule items.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemListLaneChanged Event

Calendar.ItemListLaneChanged Event
[image]

Raised when the lane index of an item within a List view has changed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemListLaneChanged
Visual Basic [image] Copy Code

Public Event ItemListLaneChanged As EventHandler(Of ItemEventArgs)

Event Data

ItemListLaneChanged event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemModificationCanceled Event

Calendar.ItemModificationCanceled Event
[image]

Raised when an item modification is canceled by the user.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemModificationCanceled
Visual Basic [image] Copy Code

Public Event ItemModificationCanceled As EventHandler(Of ItemEventArgs)

Event Data

ItemModificationCanceled event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemModified Event

Calendar.ItemModified Event
[image]

Raised when a schedule item is moved or resized by the user.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemModifiedEventArgs> ItemModified
Visual Basic [image] Copy Code

Public Event ItemModified As EventHandler(Of ItemModifiedEventArgs)

Event Data

ItemModified event handlers receive an argument of type ItemModifiedEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemModifying Event

Calendar.ItemModifying Event
[image]

Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemModifyConfirmEventArgs> ItemModifying
Visual Basic [image] Copy Code

Public Event ItemModifying As EventHandler(Of ItemModifyConfirmEventArgs)

Event Data

ItemModifying event handlers receive an argument of type ItemModifyConfirmEventArgs.

Remarks

This event can be used to prevent users from modifying an item interactively.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemPresenterCreated Event

Calendar.ItemPresenterCreated Event
[image]

Raised when the ItemPresenter Control that will visualise specific item is created.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemPresenterEventArgs> ItemPresenterCreated
Visual Basic [image] Copy Code

Public Event ItemPresenterCreated As EventHandler(Of ItemPresenterEventArgs)

Event Data

ItemModifying event handlers receive an argument of type ItemModifyConfirmEventArgs.

Remarks

This event is particularly useful when it is necessary to specify custom style for an item in different views. In this case the key of the style should be assigned to the corresponding ItemPresenter property - StyleKeyComplex, StyleKeySimpleHorizontal or StyleKeySimpleVertical.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ItemSelecting Event

Calendar.ItemSelecting Event
[image]

Raised when an item is about to be selected.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemConfirmEventArgs> ItemSelecting
Visual Basic [image] Copy Code

Public Event ItemSelecting As EventHandler(Of ItemConfirmEventArgs)

Event Data

ItemSelecting event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
ItemDeselecting Event


MindFusion.Scheduling.Silverlight.Calendar.ItemSelectionChanged Event

Calendar.ItemSelectionChanged Event
[image]

Raised when an item is selected or deselected.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<ItemSelectionEventArgs> ItemSelectionChanged
Visual Basic [image] Copy Code

Public Event ItemSelectionChanged As EventHandler(Of ItemSelectionEventArgs)

Event Data

ItemSelectionChanged event handlers receive an argument of type ItemSelectionEventArgs.

See Also

Calendar Members
Calendar Class
ItemSelectionComplete Event


MindFusion.Scheduling.Silverlight.Calendar.ItemSelectionComplete Event

Calendar.ItemSelectionComplete Event
[image]

Raised when an item is selected or deselected.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler ItemSelectionComplete
Visual Basic [image] Copy Code

Public Event ItemSelectionComplete As EventHandler

Event Data

ItemSelectionComplete event handlers receive an argument of type EventArgs.

Remarks

This event is fired only once unlike ItemSelectionChanged which is fired for each individual item affected by the selection operation.

See Also

Calendar Members
Calendar Class
ItemSelectionChanged Event


MindFusion.Scheduling.Silverlight.Calendar.ListViewHeaderClick Event

Calendar.ListViewHeaderClick Event
[image]

Raised when the header of a List view is clicked.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> ListViewHeaderClick
Visual Basic [image] Copy Code

Public Event ListViewHeaderClick As EventHandler(Of DateEventArgs)

Event Data

ListViewHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.MonthCellClick Event

Calendar.MonthCellClick Event
[image]

Raised when the user clicks on a month cell in a SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> MonthCellClick
Visual Basic [image] Copy Code

Public Event MonthCellClick As EventHandler(Of DateEventArgs)

Event Data

MonthCellClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.MonthHeaderClick Event

Calendar.MonthHeaderClick Event
[image]

Raised when the header of a Month view is clicked.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> MonthHeaderClick
Visual Basic [image] Copy Code

Public Event MonthHeaderClick As EventHandler(Of DateEventArgs)

Event Data

MonthHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MonthWeekHeaderClick Event


MindFusion.Scheduling.Silverlight.Calendar.MonthRangeHeaderClick Event

Calendar.MonthRangeHeaderClick Event
[image]

Raised when the header of an MonthRange view is clicked.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> MonthRangeHeaderClick
Visual Basic [image] Copy Code

Public Event MonthRangeHeaderClick As EventHandler(Of DateEventArgs)

Event Data

MonthRangeHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.MonthWeekHeaderClick Event

Calendar.MonthWeekHeaderClick Event
[image]

Raised when a cell in the week header of a Month view is clicked.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> MonthWeekHeaderClick
Visual Basic [image] Copy Code

Public Event MonthWeekHeaderClick As EventHandler(Of DateEventArgs)

Event Data

MonthWeekHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MonthHeaderClick Event


MindFusion.Scheduling.Silverlight.Calendar.RecurringItemDeleting Event

Calendar.RecurringItemDeleting Event
[image]

Raised when the user is about to delete a recurring item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<RecurringItemConfirmEventArgs> RecurringItemDeleting
Visual Basic [image] Copy Code

Public Event RecurringItemDeleting As EventHandler(Of RecurringItemConfirmEventArgs)

Event Data

RecurringItemDeleting event handlers receive an argument of type RecurringItemConfirmEventArgs.

Remarks

This event can be used to prevent the deletion of recurring items. For non-recurring items, handle the ItemDeleting event.

Example

The following example demonstrates how to use RecurringItemDeleting event to ask the user whether he or she wants to delete all items of a recurring pattern or only the selected item(s). The example assumes that calendar already references a Calendar control. The method ConfirmDelete is supposed to return 0 if the user cancels the deletion of the item, 1 if the user chooses that only the selected item is to be deleted, and 2 if the user wants to delete the entire pattern.

C# [image] Copy Code

// Attach a handler to the event
calendar.RecurringItemDeleting +=
new EventHandler<RecurringItemConfirmEventArgs>(calendar_RecurringItemDeleting);

// ...

private void calendar_RecurringItemDeleting(object sender, RecurringItemConfirmEventArgs e)
{
int result = ConfirmDelete(e.Item);

switch (result)
{

case 0:
// Do nothing
break;

case 1:
e.ConfirmOccurrence = true;
break;

case 2:
e.ConfirmAll = true;
break;

}
}
Visual Basic [image] Copy Code

' Attach a handler to the event
AddHandler calendar.RecurringItemDeleting, AddressOf calendar_RecurringItemDeleting

' ...

Private Sub calendar_RecurringItemDeleting(ByVal sender As Object, ByVal e As RecurringItemConfirmEventArgs)

Dim result As Integer = ConfirmDelete(e.Item)

Select Case result

Case 0
' Do nothing

Case 1
e.ConfirmOccurrence = True

Case 2
e.ConfirmAll = True

End Select

End Sub

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.ResourceViewBottomTimelineClick Event

Calendar.ResourceViewBottomTimelineClick Event
[image]

Raised when the bottom timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> ResourceViewBottomTimelineClick
Visual Basic [image] Copy Code

Public Event ResourceViewBottomTimelineClick As EventHandler(Of DateEventArgs)

Event Data

ResourceViewBottomTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
ResourceViewMiddleTimelineClick Event
ResourceViewTopTimelineClick Event


MindFusion.Scheduling.Silverlight.Calendar.ResourceViewMiddleTimelineClick Event

Calendar.ResourceViewMiddleTimelineClick Event
[image]

Raised when the middle timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> ResourceViewMiddleTimelineClick
Visual Basic [image] Copy Code

Public Event ResourceViewMiddleTimelineClick As EventHandler(Of DateEventArgs)

Event Data

ResourceViewMiddleTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
ResourceViewBottomTimelineClick Event
ResourceViewTopTimelineClick Event


MindFusion.Scheduling.Silverlight.Calendar.ResourceViewTopTimelineClick Event

Calendar.ResourceViewTopTimelineClick Event
[image]

Raised when the top timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> ResourceViewTopTimelineClick
Visual Basic [image] Copy Code

Public Event ResourceViewTopTimelineClick As EventHandler(Of DateEventArgs)

Event Data

ResourceViewTopTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
ResourceViewBottomTimelineClick Event
ResourceViewMiddleTimelineClick Event


MindFusion.Scheduling.Silverlight.Calendar.Scroll Event

Calendar.Scroll Event
[image]

Raised when the value of a scrollbar has changed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler Scroll
Visual Basic [image] Copy Code

Public Event Scroll As EventHandler

Event Data

Scroll event handlers receive an argument of type EventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
HScroll Event
VScroll Event


MindFusion.Scheduling.Silverlight.Calendar.TimetableColumnHeaderClick Event

Calendar.TimetableColumnHeaderClick Event
[image]

Raised when the header of a Timetable column is clicked.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> TimetableColumnHeaderClick
Visual Basic [image] Copy Code

Public Event TimetableColumnHeaderClick As EventHandler(Of DateEventArgs)

Event Data

TimetableColumnHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.VisibleDateChanged Event

Calendar.VisibleDateChanged Event
[image]

Raised when the user selects another date using the month or year navigation controls on the calendar header area.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateChangedEventArgs> VisibleDateChanged
Visual Basic [image] Copy Code

Public Event VisibleDateChanged As EventHandler(Of DateChangedEventArgs)

Event Data

VisibleDateChanged event handlers receive an argument of type DateChangedEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.Calendar.VScroll Event

Calendar.VScroll Event
[image]

Raised when the control has been scrolled vertically.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event ScrollEventHandler VScroll
Visual Basic [image] Copy Code

Public Event VScroll As ScrollEventHandler

Event Data

VScroll event handlers receive an argument of type ScrollEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Silverlight Namespace
HScroll Event
Scroll Event


MindFusion.Scheduling.Silverlight.Calendar.WeekRangeHeaderClick Event

Calendar.WeekRangeHeaderClick Event
[image]

Raised when the header of a WeekRange view is clicked.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<DateEventArgs> WeekRangeHeaderClick
Visual Basic [image] Copy Code

Public Event WeekRangeHeaderClick As EventHandler(Of DateEventArgs)

Event Data

WeekRangeHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class


MindFusion.Scheduling.Silverlight.CalendarSettings Class

CalendarSettings Class
[image]

The base class for the different theme-aware settings classes.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public abstract class CalendarSettings : FrameworkElement
Visual Basic [image] Copy Code

Public MustInherit Class CalendarSettings
Inherits FrameworkElement

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.CalendarStyle
MindFusion.Scheduling.Silverlight.CellSettings
MindFusion.Scheduling.Silverlight.ItemSettings
MindFusion.Scheduling.Silverlight.ListViewSettings
MindFusion.Scheduling.Silverlight.MonthRangeSettings
MindFusion.Scheduling.Silverlight.MonthSettings
MindFusion.Scheduling.Silverlight.ResourceViewSettings
MindFusion.Scheduling.Silverlight.TimelineSettings
MindFusion.Scheduling.Silverlight.TimetableSettings
MindFusion.Scheduling.Silverlight.WeekRangeSettings

See Also

CalendarSettings Members


MindFusion.Scheduling.Silverlight.CalendarSettings Members

CalendarSettings Members
Constructors
[image]

The base class for the different theme-aware settings classes.

The following tables list the members exposed by the CalendarSettings type.

Protected Constructors

Name | Description
CalendarSettings | Initializes a new instance of the CalendarSettings class.

See Also

CalendarSettings Class


MindFusion.Scheduling.Silverlight.CalendarSettings Constructor

CalendarSettings Constructor
[image]

Initializes a new instance of the CalendarSettings class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected CalendarSettings ()
Visual Basic [image] Copy Code

Protected Sub New ()

See Also

CalendarSettings Class


MindFusion.Scheduling.Silverlight.CalendarStyle Class

CalendarStyle Class
[image]

Specifies the appearance of calendar elements.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class CalendarStyle : CalendarSettings
Visual Basic [image] Copy Code

Public Class CalendarStyle
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.CalendarStyle

See Also

CalendarStyle Members


MindFusion.Scheduling.Silverlight.CalendarStyle Members

CalendarStyle Members
Constructors Fields Properties
[image]

Specifies the appearance of calendar elements.

The following tables list the members exposed by the CalendarStyle type.

Public Constructors

Name | Description
CalendarStyle | Initializes a new instance of the CalendarStyle class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
BorderBrushProperty | Identifies the BorderBrush dependency property.
BorderThicknessProperty | Identifies the BorderThickness dependency property.
BottomBorderBrushProperty | Identifies the BottomBorderBrush dependency property.
ContentMarginProperty | Identifies the ContentMargin dependency property.
EffectProperty | Identifies the Effect dependency property.
FillBrushProperty | Identifies the FillBrush dependency property.
FontFamilyProperty | Identifies the FontFamily dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontStretchProperty | Identifies the FontStretch dependency property.
FontStyleProperty | Identifies the FontStyle dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
ForegroundEffectProperty | Identifies the ForegroundEffect dependency property.
ForegroundProperty | Identifies the Foreground dependency property.
HorizontalAlignmentProperty | Identifies the HorizontalAlignment dependency property.
LeftBorderBrushProperty | Identifies the LeftBorderBrush dependency property.
LineBrushProperty | Identifies the LineBrush dependency property.
MarginProperty | Identifies the Margin dependency property.
RightBorderBrushProperty | Identifies the RightBorderBrush dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TopBorderBrushProperty | Identifies the TopBorderBrush dependency property.
VerticalAlignmentProperty | Identifies the VerticalAlignment dependency property.

Public Properties

Name | Description
Background | Gets or sets the brush used to paint the element's background.
BorderBrush | Gets or sets the brush of the element's border.
BorderThickness | Gets or sets the thickness of the element's border.
BottomBorderBrush | Gets or sets the brush of the element's bottom border.
ContentMargin | Gets or sets the margin of the element's contents.
Effect | Gets or sets the effect applied to the element.
FillBrush | Gets or sets a brush used to paint the background of various sub-elements in a color different than the main background.
FontFamily | Gets or sets the font family of the displayed text.
FontSize | Gets or sets the font size of the displayed text.
FontStretch | Gets or sets the font stretch of the displayed text.
FontStyle | Gets or sets the font style of the displayed text.
FontWeight | Gets or sets the font weight of the displayed text.
Foreground | Gets or sets the brush used to paint foreground sub-elements, such as text.
ForegroundEffect | Gets or sets the effect applied on foreground sub-elements, such as text.
HorizontalAlignment | Gets or sets the horizontal alignment of the sub-element containing the displayed text.
LeftBorderBrush | Gets or sets the brush of the element's left border.
LineBrush | Gets or sets a brush used to paint line sub-elements.
Margin | Gets or sets the margin of the element.
RightBorderBrush | Gets or sets the brush of the element's right border.
TextAlignment | Gets or sets the alignment of the displayed text.
TopBorderBrush | Gets or sets the brush of the element's top border.
VerticalAlignment | Gets or sets the vertical alignment of the sub-element containing the displayed text.

See Also

CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle Fields

CalendarStyle Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
BorderBrushProperty | Identifies the BorderBrush dependency property.
BorderThicknessProperty | Identifies the BorderThickness dependency property.
BottomBorderBrushProperty | Identifies the BottomBorderBrush dependency property.
ContentMarginProperty | Identifies the ContentMargin dependency property.
EffectProperty | Identifies the Effect dependency property.
FillBrushProperty | Identifies the FillBrush dependency property.
FontFamilyProperty | Identifies the FontFamily dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontStretchProperty | Identifies the FontStretch dependency property.
FontStyleProperty | Identifies the FontStyle dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
ForegroundEffectProperty | Identifies the ForegroundEffect dependency property.
ForegroundProperty | Identifies the Foreground dependency property.
HorizontalAlignmentProperty | Identifies the HorizontalAlignment dependency property.
LeftBorderBrushProperty | Identifies the LeftBorderBrush dependency property.
LineBrushProperty | Identifies the LineBrush dependency property.
MarginProperty | Identifies the Margin dependency property.
RightBorderBrushProperty | Identifies the RightBorderBrush dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TopBorderBrushProperty | Identifies the TopBorderBrush dependency property.
VerticalAlignmentProperty | Identifies the VerticalAlignment dependency property.

See Also

CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.BackgroundProperty Field

CalendarStyle.BackgroundProperty Field
[image]

Identifies the Background dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty BackgroundProperty
Visual Basic [image] Copy Code

Public Shared BackgroundProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.BorderBrushProperty Field

CalendarStyle.BorderBrushProperty Field
[image]

Identifies the BorderBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty BorderBrushProperty
Visual Basic [image] Copy Code

Public Shared BorderBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.BorderThicknessProperty Field

CalendarStyle.BorderThicknessProperty Field
[image]

Identifies the BorderThickness dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty BorderThicknessProperty
Visual Basic [image] Copy Code

Public Shared BorderThicknessProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.BottomBorderBrushProperty Field

CalendarStyle.BottomBorderBrushProperty Field
[image]

Identifies the BottomBorderBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty BottomBorderBrushProperty
Visual Basic [image] Copy Code

Public Shared BottomBorderBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.ContentMarginProperty Field

CalendarStyle.ContentMarginProperty Field
[image]

Identifies the ContentMargin dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty ContentMarginProperty
Visual Basic [image] Copy Code

Public Shared ContentMarginProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.EffectProperty Field

CalendarStyle.EffectProperty Field
[image]

Identifies the Effect dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty EffectProperty
Visual Basic [image] Copy Code

Public Shared EffectProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FillBrushProperty Field

CalendarStyle.FillBrushProperty Field
[image]

Identifies the FillBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty FillBrushProperty
Visual Basic [image] Copy Code

Public Shared FillBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FontFamilyProperty Field

CalendarStyle.FontFamilyProperty Field
[image]

Identifies the FontFamily dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty FontFamilyProperty
Visual Basic [image] Copy Code

Public Shared FontFamilyProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FontSizeProperty Field

CalendarStyle.FontSizeProperty Field
[image]

Identifies the FontSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty FontSizeProperty
Visual Basic [image] Copy Code

Public Shared FontSizeProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FontStretchProperty Field

CalendarStyle.FontStretchProperty Field
[image]

Identifies the FontStretch dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty FontStretchProperty
Visual Basic [image] Copy Code

Public Shared FontStretchProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FontStyleProperty Field

CalendarStyle.FontStyleProperty Field
[image]

Identifies the FontStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty FontStyleProperty
Visual Basic [image] Copy Code

Public Shared FontStyleProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FontWeightProperty Field

CalendarStyle.FontWeightProperty Field
[image]

Identifies the FontWeight dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty FontWeightProperty
Visual Basic [image] Copy Code

Public Shared FontWeightProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.ForegroundEffectProperty Field

CalendarStyle.ForegroundEffectProperty Field
[image]

Identifies the ForegroundEffect dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty ForegroundEffectProperty
Visual Basic [image] Copy Code

Public Shared ForegroundEffectProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.ForegroundProperty Field

CalendarStyle.ForegroundProperty Field
[image]

Identifies the Foreground dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty ForegroundProperty
Visual Basic [image] Copy Code

Public Shared ForegroundProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.HorizontalAlignmentProperty Field

CalendarStyle.HorizontalAlignmentProperty Field
[image]

Identifies the HorizontalAlignment dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty HorizontalAlignmentProperty
Visual Basic [image] Copy Code

Public Shared HorizontalAlignmentProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.LeftBorderBrushProperty Field

CalendarStyle.LeftBorderBrushProperty Field
[image]

Identifies the LeftBorderBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty LeftBorderBrushProperty
Visual Basic [image] Copy Code

Public Shared LeftBorderBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.LineBrushProperty Field

CalendarStyle.LineBrushProperty Field
[image]

Identifies the LineBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty LineBrushProperty
Visual Basic [image] Copy Code

Public Shared LineBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.MarginProperty Field

CalendarStyle.MarginProperty Field
[image]

Identifies the Margin dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty MarginProperty
Visual Basic [image] Copy Code

Public Shared MarginProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.RightBorderBrushProperty Field

CalendarStyle.RightBorderBrushProperty Field
[image]

Identifies the RightBorderBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty RightBorderBrushProperty
Visual Basic [image] Copy Code

Public Shared RightBorderBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.TextAlignmentProperty Field

CalendarStyle.TextAlignmentProperty Field
[image]

Identifies the TextAlignment dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty TextAlignmentProperty
Visual Basic [image] Copy Code

Public Shared TextAlignmentProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.TopBorderBrushProperty Field

CalendarStyle.TopBorderBrushProperty Field
[image]

Identifies the TopBorderBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty TopBorderBrushProperty
Visual Basic [image] Copy Code

Public Shared TopBorderBrushProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.VerticalAlignmentProperty Field

CalendarStyle.VerticalAlignmentProperty Field
[image]

Identifies the VerticalAlignment dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty VerticalAlignmentProperty
Visual Basic [image] Copy Code

Public Shared VerticalAlignmentProperty As DependencyProperty

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle Constructor

CalendarStyle Constructor
[image]

Initializes a new instance of the CalendarStyle class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle Properties

CalendarStyle Properties
[image]

Public Properties

Name | Description
Background | Gets or sets the brush used to paint the element's background.
BorderBrush | Gets or sets the brush of the element's border.
BorderThickness | Gets or sets the thickness of the element's border.
BottomBorderBrush | Gets or sets the brush of the element's bottom border.
ContentMargin | Gets or sets the margin of the element's contents.
Effect | Gets or sets the effect applied to the element.
FillBrush | Gets or sets a brush used to paint the background of various sub-elements in a color different than the main background.
FontFamily | Gets or sets the font family of the displayed text.
FontSize | Gets or sets the font size of the displayed text.
FontStretch | Gets or sets the font stretch of the displayed text.
FontStyle | Gets or sets the font style of the displayed text.
FontWeight | Gets or sets the font weight of the displayed text.
Foreground | Gets or sets the brush used to paint foreground sub-elements, such as text.
ForegroundEffect | Gets or sets the effect applied on foreground sub-elements, such as text.
HorizontalAlignment | Gets or sets the horizontal alignment of the sub-element containing the displayed text.
LeftBorderBrush | Gets or sets the brush of the element's left border.
LineBrush | Gets or sets a brush used to paint line sub-elements.
Margin | Gets or sets the margin of the element.
RightBorderBrush | Gets or sets the brush of the element's right border.
TextAlignment | Gets or sets the alignment of the displayed text.
TopBorderBrush | Gets or sets the brush of the element's top border.
VerticalAlignment | Gets or sets the vertical alignment of the sub-element containing the displayed text.

See Also

CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.Background Property

CalendarStyle.Background Property
[image]

Gets or sets the brush used to paint the element's background.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush Background { get; set; }
Visual Basic [image] Copy Code

Public Property Background As Brush

Property Value

A .NET Brush instance used to fill the interior of calendar UI elements.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.BorderBrush Property

CalendarStyle.BorderBrush Property
[image]

Gets or sets the brush of the element's border.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush BorderBrush { get; set; }
Visual Basic [image] Copy Code

Public Property BorderBrush As Brush

Property Value

A .NET Brush object specifying the color of the border lines.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.BorderThickness Property

CalendarStyle.BorderThickness Property
[image]

Gets or sets the thickness of the element's border.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Thickness BorderThickness { get; set; }
Visual Basic [image] Copy Code

Public Property BorderThickness As Thickness

Property Value

A .NET Thickness object specifying the border width.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.BottomBorderBrush Property

CalendarStyle.BottomBorderBrush Property
[image]

Gets or sets the brush of the element's bottom border.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush BottomBorderBrush { get; set; }
Visual Basic [image] Copy Code

Public Property BottomBorderBrush As Brush

Property Value

A .NET Brush object specifying the color of the bottom border lines. Assign null (Nothing in Visual Basic) to this property to use the value of BorderBrush.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.ContentMargin Property

CalendarStyle.ContentMargin Property
[image]

Gets or sets the margin of the element's contents.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Thickness ContentMargin { get; set; }
Visual Basic [image] Copy Code

Public Property ContentMargin As Thickness

Property Value

A .NET Thickness object specifying the distance between the element's contents and the element's border.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.Effect Property

CalendarStyle.Effect Property
[image]

Gets or sets the effect applied to the element.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Effect Effect { get; set; }
Visual Basic [image] Copy Code

Public Property Effect As Effect

Property Value

A .NET Effect object.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FillBrush Property

CalendarStyle.FillBrush Property
[image]

Gets or sets a brush used to paint the background of various sub-elements in a color different than the main background.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush FillBrush { get; set; }
Visual Basic [image] Copy Code

Public Property FillBrush As Brush

Property Value

A .NET Brush object specifying the color of the secondary sub-elements.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FontFamily Property

CalendarStyle.FontFamily Property
[image]

Gets or sets the font family of the displayed text.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public FontFamily FontFamily { get; set; }
Visual Basic [image] Copy Code

Public Property FontFamily As FontFamily

Property Value

A .NET FontFamily object.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FontSize Property

CalendarStyle.FontSize Property
[image]

Gets or sets the font size of the displayed text.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public double FontSize { get; set; }
Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A positive double value.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FontStretch Property

CalendarStyle.FontStretch Property
[image]

Gets or sets the font stretch of the displayed text.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public FontStretch FontStretch { get; set; }
Visual Basic [image] Copy Code

Public Property FontStretch As FontStretch

Property Value

A .NET FontStretch object.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FontStyle Property

CalendarStyle.FontStyle Property
[image]

Gets or sets the font style of the displayed text.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public FontStyle FontStyle { get; set; }
Visual Basic [image] Copy Code

Public Property FontStyle As FontStyle

Property Value

A .NET FontStyle object.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.FontWeight Property

CalendarStyle.FontWeight Property
[image]

Gets or sets the font weight of the displayed text.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }
Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

A .NET FontStyle object.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.Foreground Property

CalendarStyle.Foreground Property
[image]

Gets or sets the brush used to paint foreground sub-elements, such as text.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush Foreground { get; set; }
Visual Basic [image] Copy Code

Public Property Foreground As Brush

Property Value

A .NET Brush object.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.ForegroundEffect Property

CalendarStyle.ForegroundEffect Property
[image]

Gets or sets the effect applied on foreground sub-elements, such as text.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Effect ForegroundEffect { get; set; }
Visual Basic [image] Copy Code

Public Property ForegroundEffect As Effect

Property Value

A .NET Effect object.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.HorizontalAlignment Property

CalendarStyle.HorizontalAlignment Property
[image]

Gets or sets the horizontal alignment of the sub-element containing the displayed text.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public HorizontalAlignment HorizontalAlignment { get; set; }
Visual Basic [image] Copy Code

Public Property HorizontalAlignment As HorizontalAlignment

Property Value

A member of the .NET HorizontalAlignment enumeration.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.LeftBorderBrush Property

CalendarStyle.LeftBorderBrush Property
[image]

Gets or sets the brush of the element's left border.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush LeftBorderBrush { get; set; }
Visual Basic [image] Copy Code

Public Property LeftBorderBrush As Brush

Property Value

A .NET Brush object specifying the color of the left border lines. Assign null (Nothing in Visual Basic) to this property to use the value of BorderBrush.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.LineBrush Property

CalendarStyle.LineBrush Property
[image]

Gets or sets a brush used to paint line sub-elements.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush LineBrush { get; set; }
Visual Basic [image] Copy Code

Public Property LineBrush As Brush

Property Value

A .NET Brush object.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.Margin Property

CalendarStyle.Margin Property
[image]

Gets or sets the margin of the element.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Thickness Margin { get; set; }
Visual Basic [image] Copy Code

Public Property Margin As Thickness

Property Value

A .NET Thickness object specifying the distance between the element and its container's borders.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.RightBorderBrush Property

CalendarStyle.RightBorderBrush Property
[image]

Gets or sets the brush of the element's right border.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush RightBorderBrush { get; set; }
Visual Basic [image] Copy Code

Public Property RightBorderBrush As Brush

Property Value

A .NET Brush object specifying the color of the right border lines. Assign null (Nothing in Visual Basic) to this property to use the value of BorderBrush.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.TextAlignment Property

CalendarStyle.TextAlignment Property
[image]

Gets or sets the alignment of the displayed text.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TextAlignment TextAlignment { get; set; }
Visual Basic [image] Copy Code

Public Property TextAlignment As TextAlignment

Property Value

A member of the .NET TextAlignment enumeration.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.TopBorderBrush Property

CalendarStyle.TopBorderBrush Property
[image]

Gets or sets the brush of the element's top border.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush TopBorderBrush { get; set; }
Visual Basic [image] Copy Code

Public Property TopBorderBrush As Brush

Property Value

A .NET Brush object specifying the color of the top border lines. Assign null (Nothing in Visual Basic) to this property to use the value of BorderBrush.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarStyle.VerticalAlignment Property

CalendarStyle.VerticalAlignment Property
[image]

Gets or sets the vertical alignment of the sub-element containing the displayed text.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public VerticalAlignment VerticalAlignment { get; set; }
Visual Basic [image] Copy Code

Public Property VerticalAlignment As VerticalAlignment

Property Value

A member of the .NET VerticalAlignment enumeration.

See Also

CalendarStyle Members
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CalendarView Enumeration

CalendarView Enumeration
[image]

Specifies the type of view to display in a calendar control.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum CalendarView
Visual Basic [image] Copy Code

Public Enumeration CalendarView

Members

Member name | Description
List | The calendar displays several seconds, minutes, hours, days, weeks, months or years in a row or a column (see List View).
MonthRange | The calendar displays several months in a grid. The days of each month are visible too (see Month Range View).
SingleMonth | The calendar displays a single month at a time. The days of the month are displayed in a grid (see Single Month View).
Timetable | The calendar displays a timetable where each row represents a fixed arbitrary time interval and each column represents a day. This view allow further division by various grouping criteria such as by contacts, locations or tasks (see Timetable View).
WeekRange | The calendar displays a grid of days, with the columns representing the week days from Monday to Sunday and the rows representing weeks (see Week Range View).
ResourceView | The calendar displays the distribution of items over a period of time.

Remarks

A value of this enumeration is assigned to the CurrentView property of the Calendar class.

See Also


MindFusion.Scheduling.Silverlight.CellPresenter Class

CellPresenter Class
Remarks See Also
[image]

Defines the presentation of cells in calendar views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class CellPresenter : Control
Visual Basic [image] Copy Code

Public Class CellPresenter
Inherits Control

Remarks

This class defines the presentation of view cells within the Calendar control. For information how to define a custom template for the presenter, check Creating New Cell Template. For information how to derive custom classes from CellPresenter, check the Creating New Cell Presenter.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Scheduling.Silverlight.CellPresenter

See Also

CellPresenter Members


MindFusion.Scheduling.Silverlight.CellPresenter Members

CellPresenter Members
Constructors Fields Properties Methods
[image]

Defines the presentation of cells in calendar views.

The following tables list the members exposed by the CellPresenter type.

Public Constructors

Name | Description
CellPresenter | Initializes a new instance of the CellPresenter class.

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
CalendarProperty | Identifies the Calendar dependency property.
CellHeaderStyleProperty | Identifies the CellHeaderStyle dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderHorizontalAlignmentProperty | Identifies the HeaderHorizontalAlignment dependency property.
HeaderTextProperty | Identifies the HeaderText dependency property.
HeaderTextRotationProperty | Identifies the HeaderTextRotation dependency property.
HeaderVerticalAlignmentProperty | Identifies the HeaderVerticalAlignment dependency property.
HeaderWidthProperty | Identifies the HeaderWidth dependency property.
IsAllDayCellProperty | Identifies the IsAllDayCell property.
IsSelectedProperty | Identifies the IsSelected dependency property.
ResourceProperty | Identifies the Resource dependency property.
StartTimeProperty | Identifies the StartTime dependency property.
StyleKeySimpleProperty | Identifies the StyleKeySimple dependency property.
StyleKeyTodayProperty | Identifies the StyleKeyToday dependency property.
StyleKeyWithHeaderProperty | Identifies the StyleKeyWithHeader dependency property.

Public Properties

Name | Description
Background | Gets the background of the cell in its current state. This is a dependency property.
Calendar | Gets a reference to the Calendar object this presenter is associated with. This is a dependency property.
CellHeaderStyle | Gets the currently effective CalendarStyle for the cell's header (if any). This is a dependency property.
CellSettings | Gets a reference to the CellSettings object defining the current cell settings. This is a dependency property.
CellStyle | Gets the currently effective CalendarStyle. This is a dependency property.
EndTime | Gets the end time of the cell. This is a dependency property.
HeaderHeight | Gets the height of the cell header according to the current state. This is a dependency property.
HeaderHorizontalAlignment | Gets the horizontal alignment of the cell header according to the current state. This is a dependency property.
HeaderText | Gets the text displayed in the cell header. This is a dependency property.
HeaderTextRotation | Gets the rotation of the header text according to the current state. This is a dependency property.
HeaderVerticalAlignment | Gets the vertical alignment of the cell header according to the current state. This is a dependency property.
HeaderWidth | Gets the width of the cell header according to the current state. This is a dependency property.
IsAllDayCell | Gets or sets a value indicating whether this cell is an all-day cell.
IsSelected | Gets a value indicating whether this cell is selected. This is a dependency property.
Resource | Gets the resource (if any) the cell is associated with. This is a dependency property.
StartTime | Gets the start time of the cell. This is a dependency property.
StyleKeySimple | Gets or sets the key of the resource that holds the template to be used when displaying simple (without header) view cells. This is a dependency property.
StyleKeyToday | Gets or sets the key of the resource that holds the template to be used when displaying the view cell representing the current day. This is a dependency property.
StyleKeyWithHeader | Gets or sets the key of the resource that holds the template to be used when displaying view cells with header. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter Fields

CellPresenter Fields
[image]

Public Fields

Name | Description
BackgroundProperty | Identifies the Background dependency property.
CalendarProperty | Identifies the Calendar dependency property.
CellHeaderStyleProperty | Identifies the CellHeaderStyle dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderHorizontalAlignmentProperty | Identifies the HeaderHorizontalAlignment dependency property.
HeaderTextProperty | Identifies the HeaderText dependency property.
HeaderTextRotationProperty | Identifies the HeaderTextRotation dependency property.
HeaderVerticalAlignmentProperty | Identifies the HeaderVerticalAlignment dependency property.
HeaderWidthProperty | Identifies the HeaderWidth dependency property.
IsAllDayCellProperty | Identifies the IsAllDayCell property.
IsSelectedProperty | Identifies the IsSelected dependency property.
ResourceProperty | Identifies the Resource dependency property.
StartTimeProperty | Identifies the StartTime dependency property.
StyleKeySimpleProperty | Identifies the StyleKeySimple dependency property.
StyleKeyTodayProperty | Identifies the StyleKeyToday dependency property.
StyleKeyWithHeaderProperty | Identifies the StyleKeyWithHeader dependency property.

See Also

CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.BackgroundProperty Field

CellPresenter.BackgroundProperty Field
[image]

Identifies the Background dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BackgroundProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly BackgroundProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.CalendarProperty Field

CellPresenter.CalendarProperty Field
[image]

Identifies the Calendar dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.CellHeaderStyleProperty Field

CellPresenter.CellHeaderStyleProperty Field
[image]

Identifies the CellHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellHeaderStyleProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.CellStyleProperty Field

CellPresenter.CellStyleProperty Field
[image]

Identifies the CellStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellStyleProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.EndTimeProperty Field

CellPresenter.EndTimeProperty Field
[image]

Identifies the EndTime dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndTimeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EndTimeProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderHeightProperty Field

CellPresenter.HeaderHeightProperty Field
[image]

Identifies the HeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderHeightProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderHeightProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderHorizontalAlignmentProperty Field

CellPresenter.HeaderHorizontalAlignmentProperty Field
[image]

Identifies the HeaderHorizontalAlignment dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderHorizontalAlignmentProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderHorizontalAlignmentProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderTextProperty Field

CellPresenter.HeaderTextProperty Field
[image]

Identifies the HeaderText dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTextProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTextProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderTextRotationProperty Field

CellPresenter.HeaderTextRotationProperty Field
[image]

Identifies the HeaderTextRotation dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderTextRotationProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderTextRotationProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderVerticalAlignmentProperty Field

CellPresenter.HeaderVerticalAlignmentProperty Field
[image]

Identifies the HeaderVerticalAlignment dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderVerticalAlignmentProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderVerticalAlignmentProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderWidthProperty Field

CellPresenter.HeaderWidthProperty Field
[image]

Identifies the HeaderWidth dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderWidthProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderWidthProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.IsAllDayCellProperty Field

CellPresenter.IsAllDayCellProperty Field
[image]

Identifies the IsAllDayCell property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsAllDayCellProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly IsAllDayCellProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.IsSelectedProperty Field

CellPresenter.IsSelectedProperty Field
[image]

Identifies the IsSelected dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsSelectedProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.ResourceProperty Field

CellPresenter.ResourceProperty Field
[image]

Identifies the Resource dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResourceProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ResourceProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.StartTimeProperty Field

CellPresenter.StartTimeProperty Field
[image]

Identifies the StartTime dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartTimeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly StartTimeProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.StyleKeySimpleProperty Field

CellPresenter.StyleKeySimpleProperty Field
[image]

Identifies the StyleKeySimple dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StyleKeySimpleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly StyleKeySimpleProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.StyleKeyTodayProperty Field

CellPresenter.StyleKeyTodayProperty Field
[image]

Identifies the StyleKeyToday dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StyleKeyTodayProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly StyleKeyTodayProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.StyleKeyWithHeaderProperty Field

CellPresenter.StyleKeyWithHeaderProperty Field
[image]

Identifies the StyleKeyWithHeader dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StyleKeyWithHeaderProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly StyleKeyWithHeaderProperty As DependencyProperty

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter Constructor

CellPresenter Constructor
[image]

Initializes a new instance of the CellPresenter class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CellPresenter (
Calendar calendar
)
Visual Basic [image] Copy Code

Public New ( _
calendar As Calendar _
)

Parameters

calendar
The Calendar instance this CellPresenter is associated with.

See Also

CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter Methods

CellPresenter Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.OnApplyTemplate Method

CellPresenter.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()
Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter Properties

CellPresenter Properties
[image]

Public Properties

Name | Description
Background | Gets the background of the cell in its current state. This is a dependency property.
Calendar | Gets a reference to the Calendar object this presenter is associated with. This is a dependency property.
CellHeaderStyle | Gets the currently effective CalendarStyle for the cell's header (if any). This is a dependency property.
CellSettings | Gets a reference to the CellSettings object defining the current cell settings. This is a dependency property.
CellStyle | Gets the currently effective CalendarStyle. This is a dependency property.
EndTime | Gets the end time of the cell. This is a dependency property.
HeaderHeight | Gets the height of the cell header according to the current state. This is a dependency property.
HeaderHorizontalAlignment | Gets the horizontal alignment of the cell header according to the current state. This is a dependency property.
HeaderText | Gets the text displayed in the cell header. This is a dependency property.
HeaderTextRotation | Gets the rotation of the header text according to the current state. This is a dependency property.
HeaderVerticalAlignment | Gets the vertical alignment of the cell header according to the current state. This is a dependency property.
HeaderWidth | Gets the width of the cell header according to the current state. This is a dependency property.
IsAllDayCell | Gets or sets a value indicating whether this cell is an all-day cell.
IsSelected | Gets a value indicating whether this cell is selected. This is a dependency property.
Resource | Gets the resource (if any) the cell is associated with. This is a dependency property.
StartTime | Gets the start time of the cell. This is a dependency property.
StyleKeySimple | Gets or sets the key of the resource that holds the template to be used when displaying simple (without header) view cells. This is a dependency property.
StyleKeyToday | Gets or sets the key of the resource that holds the template to be used when displaying the view cell representing the current day. This is a dependency property.
StyleKeyWithHeader | Gets or sets the key of the resource that holds the template to be used when displaying view cells with header. This is a dependency property.

See Also

CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.Background Property

CellPresenter.Background Property
[image]

Gets the background of the cell in its current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush Background { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Background As Brush

Property Value

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.Calendar Property

CellPresenter.Calendar Property
[image]

Gets a reference to the Calendar object this presenter is associated with. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Calendar Calendar { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Calendar As Calendar

Property Value

An instance of the Calendar class.

Remarks

This property returns the Calendar instance this CellPresenter belongs to.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.CellHeaderStyle Property

CellPresenter.CellHeaderStyle Property
[image]

Gets the currently effective CalendarStyle for the cell's header (if any). This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CellHeaderStyle { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property CellHeaderStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

Remarks

The appearance of each cell is usually defined by two CalendarStyle objects, depending on the current cell state - normal or selected. This property is automatically updated to reference the cell style appropriate for the current state of the cell. Therefore bindings to this property will be automatically updated when the cell state changes.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.CellSettings Property

CellPresenter.CellSettings Property
[image]

Gets a reference to the CellSettings object defining the current cell settings. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CellSettings CellSettings { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property CellSettings As CellSettings

Property Value

An instance of the CellSettings class. This can be null (Nothing in Visual Basic) in certain views.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.CellStyle Property

CellPresenter.CellStyle Property
[image]

Gets the currently effective CalendarStyle. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CellStyle { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property CellStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

Remarks

The appearance of each cell is usually defined by two CalendarStyle objects, depending on the current cell state - normal or selected. This property is automatically updated to reference the cell style appropriate for the current state of the cell. Therefore bindings to this property will be automatically updated when the cell state changes.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.EndTime Property

CellPresenter.EndTime Property
[image]

Gets the end time of the cell. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime EndTime { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property EndTime As DateTime

Property Value

A .NET DateTime object.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderHeight Property

CellPresenter.HeaderHeight Property
[image]

Gets the height of the cell header according to the current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public double HeaderHeight { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property HeaderHeight As Double

Property Value

A double value specifying the height of the cell header. This is NaN for vertical headers indicating that these headers span the entire cell.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderHorizontalAlignment Property

CellPresenter.HeaderHorizontalAlignment Property
[image]

Gets the horizontal alignment of the cell header according to the current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public HorizontalAlignment HeaderHorizontalAlignment { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property HeaderHorizontalAlignment As HorizontalAlignment

Property Value

A .NET HorizontalAlignment value.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderText Property

CellPresenter.HeaderText Property
[image]

Gets the text displayed in the cell header. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string HeaderText { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property HeaderText As String

Property Value

A string value.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderTextRotation Property

CellPresenter.HeaderTextRotation Property
[image]

Gets the rotation of the header text according to the current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public double HeaderTextRotation { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property HeaderTextRotation As Double

Property Value

A double value specifying the rotation of the header text.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderVerticalAlignment Property

CellPresenter.HeaderVerticalAlignment Property
[image]

Gets the vertical alignment of the cell header according to the current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public VerticalAlignment HeaderVerticalAlignment { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property HeaderVerticalAlignment As VerticalAlignment

Property Value

A .NET VerticalAlignment value.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.HeaderWidth Property

CellPresenter.HeaderWidth Property
[image]

Gets the width of the cell header according to the current state. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public double HeaderWidth { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property HeaderWidth As Double

Property Value

A double value specifying the width of the cell header. This is NaN for horizontal headers indicating that these headers span the entire cell.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.IsAllDayCell Property

CellPresenter.IsAllDayCell Property
[image]

Gets or sets a value indicating whether this cell is an all-day cell.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool IsAllDayCell { get; set; }
Visual Basic [image] Copy Code

Public Property IsAllDayCell As Boolean

Property Value

true if the cell is an all-day cell; otherwise, false.

Remarks

This property is used in timetable views to distinguish between all-day header cells and ordinary cells.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.IsSelected Property

CellPresenter.IsSelected Property
[image]

Gets a value indicating whether this cell is selected. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool IsSelected { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property IsSelected As Boolean

Property Value

A boolean value.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.Resource Property

CellPresenter.Resource Property
[image]

Gets the resource (if any) the cell is associated with. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Resource Resource { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

An instance of the Resource class or null (Nothing in Visual Basic) if the current view is not grouped.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.StartTime Property

CellPresenter.StartTime Property
[image]

Gets the start time of the cell. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime StartTime { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property StartTime As DateTime

Property Value

A .NET DateTime object.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.StyleKeySimple Property

CellPresenter.StyleKeySimple Property
[image]

Gets or sets the key of the resource that holds the template to be used when displaying simple (without header) view cells. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string StyleKeySimple { get; set; }
Visual Basic [image] Copy Code

Public Property StyleKeySimple As String

Property Value

A string value. The default template key is 'SimpleCellStyle'.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.StyleKeyToday Property

CellPresenter.StyleKeyToday Property
[image]

Gets or sets the key of the resource that holds the template to be used when displaying the view cell representing the current day. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string StyleKeyToday { get; set; }
Visual Basic [image] Copy Code

Public Property StyleKeyToday As String

Property Value

A string value. The default template key is 'TodayCellStyle'.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellPresenter.StyleKeyWithHeader Property

CellPresenter.StyleKeyWithHeader Property
[image]

Gets or sets the key of the resource that holds the template to be used when displaying view cells with header. This is a dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string StyleKeyWithHeader { get; set; }
Visual Basic [image] Copy Code

Public Property StyleKeyWithHeader As String

Property Value

A string value. The default template key is 'WithHeaderCellStyle'.

See Also

CellPresenter Members
CellPresenter Class


MindFusion.Scheduling.Silverlight.CellSettings Class

CellSettings Class
[image]

Defines appearance settings for the cells representing time ranges in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class CellSettings : CalendarSettings
Visual Basic [image] Copy Code

Public NotInheritable Class CellSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.CellSettings

See Also

CellSettings Members


MindFusion.Scheduling.Silverlight.CellSettings Members

CellSettings Members
Constructors Fields Properties
[image]

Defines appearance settings for the cells representing time ranges in the calendar.

The following tables list the members exposed by the CellSettings type.

Public Constructors

Name | Description
CellSettings | Initializes a new instance of the CellSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
FirstDayOfMonthFormatProperty | Identifies the FirstDayOfMonthFormat dependency property.
FirstDayOfYearFormatProperty | Identifies the FirstDayOfYearFormat dependency property.
GeneralFormatProperty | Identifies the GeneralFormat dependency property.
HeaderPositionProperty | Identifies the HeaderPosition dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
RotateHeaderProperty | Identifies the RotateHeader dependency property.
ShowTodayProperty | Identifies the ShowToday dependency property.
TodayBrushProperty | Identifies the TodayBrush dependency property.
TodayFillBrushProperty | Identifies the TodayFillBrush dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
FirstDayOfMonthFormat | Gets or sets the string used to format and display the first day of each month in the calendar.
FirstDayOfYearFormat | Gets or sets the string used to format and display the first day of each year in the calendar.
GeneralFormat | Gets or sets the string used to format and display dates and times in the calendar.
HeaderPosition | Gets or sets the position of the cell header.
HeaderSize | Gets or sets the size of the cell header in pixels.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
RotateHeader | Gets or sets a value indicating whether to rotate header text when the header position is set to Left or Right.
ShowToday | Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.
TodayBrush | Gets or sets the color used to paint the line that marks the current cell.
TodayFillBrush | Gets or sets the color used to fill the header of the current cell.

See Also

CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings Fields

CellSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
FirstDayOfMonthFormatProperty | Identifies the FirstDayOfMonthFormat dependency property.
FirstDayOfYearFormatProperty | Identifies the FirstDayOfYearFormat dependency property.
GeneralFormatProperty | Identifies the GeneralFormat dependency property.
HeaderPositionProperty | Identifies the HeaderPosition dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
RotateHeaderProperty | Identifies the RotateHeader dependency property.
ShowTodayProperty | Identifies the ShowToday dependency property.
TodayBrushProperty | Identifies the TodayBrush dependency property.
TodayFillBrushProperty | Identifies the TodayFillBrush dependency property.

See Also

CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.CalendarStyleProperty Field

CellSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.FirstDayOfMonthFormatProperty Field

CellSettings.FirstDayOfMonthFormatProperty Field
[image]

Identifies the FirstDayOfMonthFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FirstDayOfMonthFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly FirstDayOfMonthFormatProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.FirstDayOfYearFormatProperty Field

CellSettings.FirstDayOfYearFormatProperty Field
[image]

Identifies the FirstDayOfYearFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FirstDayOfYearFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly FirstDayOfYearFormatProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.GeneralFormatProperty Field

CellSettings.GeneralFormatProperty Field
[image]

Identifies the GeneralFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GeneralFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly GeneralFormatProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.HeaderPositionProperty Field

CellSettings.HeaderPositionProperty Field
[image]

Identifies the HeaderPosition dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderPositionProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderPositionProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.HeaderSizeProperty Field

CellSettings.HeaderSizeProperty Field
[image]

Identifies the HeaderSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderSizeProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.HeaderStyleProperty Field

CellSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.RotateHeaderProperty Field

CellSettings.RotateHeaderProperty Field
[image]

Identifies the RotateHeader dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateHeaderProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly RotateHeaderProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.ShowTodayProperty Field

CellSettings.ShowTodayProperty Field
[image]

Identifies the ShowToday dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTodayProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTodayProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.TodayBrushProperty Field

CellSettings.TodayBrushProperty Field
[image]

Identifies the TodayBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TodayBrushProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TodayBrushProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.TodayFillBrushProperty Field

CellSettings.TodayFillBrushProperty Field
[image]

Identifies the TodayFillBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TodayFillBrushProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TodayFillBrushProperty As DependencyProperty

See Also

CellSettings Members
CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings Constructor

CellSettings Constructor
[image]

Initializes a new instance of the CellSettings class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CellSettings ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings Properties

CellSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
FirstDayOfMonthFormat | Gets or sets the string used to format and display the first day of each month in the calendar.
FirstDayOfYearFormat | Gets or sets the string used to format and display the first day of each year in the calendar.
GeneralFormat | Gets or sets the string used to format and display dates and times in the calendar.
HeaderPosition | Gets or sets the position of the cell header.
HeaderSize | Gets or sets the size of the cell header in pixels.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
RotateHeader | Gets or sets a value indicating whether to rotate header text when the header position is set to Left or Right.
ShowToday | Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.
TodayBrush | Gets or sets the color used to paint the line that marks the current cell.
TodayFillBrush | Gets or sets the color used to fill the header of the current cell.

See Also

CellSettings Class


MindFusion.Scheduling.Silverlight.CellSettings.CalendarStyle Property

CellSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of calendar UI elements.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CellSettings.FirstDayOfMonthFormat Property

CellSettings.FirstDayOfMonthFormat Property
[image]

Gets or sets the string used to format and display the first day of each month in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string FirstDayOfMonthFormat { get; set; }
Visual Basic [image] Copy Code

Public Property FirstDayOfMonthFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Silverlight Namespace
GeneralFormat Property
FirstDayOfYearFormat Property


MindFusion.Scheduling.Silverlight.CellSettings.FirstDayOfYearFormat Property

CellSettings.FirstDayOfYearFormat Property
[image]

Gets or sets the string used to format and display the first day of each year in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string FirstDayOfYearFormat { get; set; }
Visual Basic [image] Copy Code

Public Property FirstDayOfYearFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Silverlight Namespace
GeneralFormat Property
FirstDayOfMonthFormat Property


MindFusion.Scheduling.Silverlight.CellSettings.GeneralFormat Property

CellSettings.GeneralFormat Property
[image]

Gets or sets the string used to format and display dates and times in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string GeneralFormat { get; set; }
Visual Basic [image] Copy Code

Public Property GeneralFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Silverlight Namespace
FirstDayOfMonthFormat Property
FirstDayOfYearFormat Property


MindFusion.Scheduling.Silverlight.CellSettings.HeaderPosition Property

CellSettings.HeaderPosition Property
[image]

Gets or sets the position of the cell header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Position HeaderPosition { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderPosition As Position

Property Value

A member of the Position enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderSize Property
RotateHeader Property


MindFusion.Scheduling.Silverlight.CellSettings.HeaderSize Property

CellSettings.HeaderSize Property
[image]

Gets or sets the size of the cell header in pixels.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int HeaderSize { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the size in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property specifies the height of the header if HeaderPosition is set to either Top or Bottom, or the width of the header if HeaderPosition is set to Left or Right.

See Also

CellSettings Members
CellSettings Class
HeaderPosition Property


MindFusion.Scheduling.Silverlight.CellSettings.HeaderStyle Property

CellSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.CellSettings.RotateHeader Property

CellSettings.RotateHeader Property
[image]

Gets or sets a value indicating whether to rotate header text when the header position is set to Left or Right.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool RotateHeader { get; set; }
Visual Basic [image] Copy Code

Public Property RotateHeader As Boolean

Property Value

true to rotate header text, otherwise false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

CellSettings Members
CellSettings Class
HeaderPosition Property


MindFusion.Scheduling.Silverlight.CellSettings.ShowToday Property

CellSettings.ShowToday Property
[image]

Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowToday { get; set; }
Visual Basic [image] Copy Code

Public Property ShowToday As Boolean

Property Value

true to indicate visually the current day; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Silverlight Namespace
TodayBrush Property
TodayFillBrush Property


MindFusion.Scheduling.Silverlight.CellSettings.TodayBrush Property

CellSettings.TodayBrush Property
[image]

Gets or sets the color used to paint the line that marks the current cell.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush TodayBrush { get; set; }
Visual Basic [image] Copy Code

Public Property TodayBrush As Brush

Property Value

A .NET Brush object.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Silverlight Namespace
TodayFillBrush Property
ShowToday Property


MindFusion.Scheduling.Silverlight.CellSettings.TodayFillBrush Property

CellSettings.TodayFillBrush Property
[image]

Gets or sets the color used to fill the header of the current cell.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush TodayFillBrush { get; set; }
Visual Basic [image] Copy Code

Public Property TodayFillBrush As Brush

Property Value

A .NET Brush object.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Silverlight Namespace
TodayBrush Property
ShowToday Property


MindFusion.Scheduling.Silverlight.DateChangedEventArgs Class

DateChangedEventArgs Class
[image]

Contains the arguments passed to handlers of the VisibleDateChanged event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class DateChangedEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class DateChangedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Silverlight.DateChangedEventArgs

See Also

DateChangedEventArgs Members


MindFusion.Scheduling.Silverlight.DateChangedEventArgs Members

DateChangedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the VisibleDateChanged event.

The following tables list the members exposed by the DateChangedEventArgs type.

Public Properties

Name | Description
NewDate | Gets the new visible date.
PreviousDate | Gets the previous visible date.

See Also

DateChangedEventArgs Class


MindFusion.Scheduling.Silverlight.DateChangedEventArgs Properties

DateChangedEventArgs Properties
[image]

Public Properties

Name | Description
NewDate | Gets the new visible date.
PreviousDate | Gets the previous visible date.

See Also

DateChangedEventArgs Class


MindFusion.Scheduling.Silverlight.DateChangedEventArgs.NewDate Property

DateChangedEventArgs.NewDate Property
[image]

Gets the new visible date.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime NewDate { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property NewDate As DateTime

Property Value

A .NET DateTime object specifying the new date related to the raised event.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class


MindFusion.Scheduling.Silverlight.DateChangedEventArgs.PreviousDate Property

DateChangedEventArgs.PreviousDate Property
[image]

Gets the previous visible date.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime PreviousDate { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property PreviousDate As DateTime

Property Value

A .NET DateTime object specifying the previous date related to the raised event.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class


MindFusion.Scheduling.Silverlight.DateCollection Class

DateCollection Class
[image]

Represents a strongly-typed sorted collection of DateTime objects.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class DateCollection : ObservableCollection<DateTime>
Visual Basic [image] Copy Code

Public NotInheritable Class DateCollection
Inherits ObservableCollection(Of DateTime)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(DateTime)
System.Collections.ObjectModel.ObservableCollection(DateTime)
MindFusion.Scheduling.Silverlight.DateCollection

See Also

DateCollection Members


MindFusion.Scheduling.Silverlight.DateCollection Members

DateCollection Members
Constructors Methods
[image]

Represents a strongly-typed sorted collection of DateTime objects.

The following tables list the members exposed by the DateCollection type.

Public Constructors

Name | Description
DateCollection | Initializes a new instance of the DateCollection class.

Protected Methods

Name | Description
OnCollectionChanged | ObservableCollection<DateTime>.OnCollectionChanged override.

See Also

DateCollection Class


MindFusion.Scheduling.Silverlight.DateCollection Constructor

DateCollection Constructor
[image]

Initializes a new instance of the DateCollection class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateCollection ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

DateCollection Class


MindFusion.Scheduling.Silverlight.DateCollection Methods

DateCollection Methods
[image]

Protected Methods

Name | Description
OnCollectionChanged | ObservableCollection<DateTime>.OnCollectionChanged override.

See Also

DateCollection Class


MindFusion.Scheduling.Silverlight.DateCollection.OnCollectionChanged Method

DateCollection.OnCollectionChanged Method
[image]

ObservableCollection<DateTime>.OnCollectionChanged override.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnCollectionChanged (
NotifyCollectionChangedEventArgs e
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnCollectionChanged ( _
e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Arguments of the event being raised.

See Also

DateCollection Members
DateCollection Class


MindFusion.Scheduling.Silverlight.DateEventArgs Class

DateEventArgs Class
[image]

Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class DateEventArgs : EventArgs
Visual Basic [image] Copy Code

Public Class DateEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Silverlight.DateEventArgs
MindFusion.Scheduling.Silverlight.ResourceDateEventArgs

See Also

DateEventArgs Members


MindFusion.Scheduling.Silverlight.DateEventArgs Members

DateEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.

The following tables list the members exposed by the DateEventArgs type.

Public Properties

Name | Description
Bounds | Gets the bounds of the cell.
Date | Gets the date and time associated with the event.
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise.

See Also

DateEventArgs Class


MindFusion.Scheduling.Silverlight.DateEventArgs Properties

DateEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounds of the cell.
Date | Gets the date and time associated with the event.
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise.

See Also

DateEventArgs Class


MindFusion.Scheduling.Silverlight.DateEventArgs.Bounds Property

DateEventArgs.Bounds Property
[image]

Gets the bounds of the cell.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Rect Bounds { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

A .NET Rect object specifying the bounds of the cell related to the raised event.

See Also

DateEventArgs Members
DateEventArgs Class


MindFusion.Scheduling.Silverlight.DateEventArgs.Date Property

DateEventArgs.Date Property
[image]

Gets the date and time associated with the event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime Date { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Date As DateTime

Property Value

A .NET DateTime object specifying the date related to the raised event.

See Also

DateEventArgs Members
DateEventArgs Class


MindFusion.Scheduling.Silverlight.DateEventArgs.Index Property

DateEventArgs.Index Property
[image]

Gets the index (if any) of the calendar cell related to the event or -1 otherwise.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int Index { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

An integer value specifying the index of the related cell or -1 if no index is applicable to the selected cell.

See Also

DateEventArgs Members
DateEventArgs Class


MindFusion.Scheduling.Silverlight.DayOfWeekFormat Enumeration

DayOfWeekFormat Enumeration
[image]

Specifies the display format of a day of the week.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum DayOfWeekFormat
Visual Basic [image] Copy Code

Public Enumeration DayOfWeekFormat

Members

Member name | Description
Abbreviated | The first three letters of the day of the week are displayed.
Full | The complete name of the day of the week is displayed.
SingleLetter | Only the first letter of the name of the day is displayed.

See Also


MindFusion.Scheduling.Silverlight.GroupType Enumeration

GroupType Enumeration
[image]

Specifies grouping or filtering criteria for views that support grouping.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum GroupType
Visual Basic [image] Copy Code

Public Enumeration GroupType

Members

Member name | Description
FilterByContacts | Filter by contacts.
FilterByLocations | Filter by locations.
FilterByResources | Filter by resources.
FilterByTasks | Filter by tasks.
GroupByContacts | Group by contacts.
GroupByLocations | Group by locations.
GroupByResources | Group by resources.
GroupByTasks | Group by tasks.
None | No grouping or filtering.

See Also


MindFusion.Scheduling.Silverlight.ItemAction Enumeration

ItemAction Enumeration
[image]

Specifies a user action on a schedule item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum ItemAction
Visual Basic [image] Copy Code

Public Enumeration ItemAction

Members

Member name | Description
Move | Indicates that the item is being moved.
None | Indicates no action.
ResizeEnd | Indicates that the item's end is being modified.
ResizeStart | Indicates that the item's start is being modified.

See Also


MindFusion.Scheduling.Silverlight.ItemConfirmEventArgs Class

ItemConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemConfirmEventArgs : ItemEventArgs
Visual Basic [image] Copy Code

Public Class ItemConfirmEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Silverlight.ItemConfirmEventArgs
MindFusion.Scheduling.Silverlight.ItemEditConfirmEventArgs
MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs

See Also

ItemConfirmEventArgs Members


MindFusion.Scheduling.Silverlight.ItemConfirmEventArgs Members

ItemConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.

The following tables list the members exposed by the ItemConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.

See Also

ItemConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemConfirmEventArgs Properties

ItemConfirmEventArgs Properties
[image]

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.

See Also

ItemConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemConfirmEventArgs.Confirm Property

ItemConfirmEventArgs.Confirm Property
[image]

Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool Confirm { get; set; }
Visual Basic [image] Copy Code

Public Property Confirm As Boolean

Property Value

Set Confirm to false to prevent the action or to true to allow it. The default is true.

See Also

ItemConfirmEventArgs Members
ItemConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemEditConfirmEventArgs Class

ItemEditConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemEditConfirmEventArgs : ItemConfirmEventArgs
Visual Basic [image] Copy Code

Public Class ItemEditConfirmEventArgs
Inherits ItemConfirmEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Silverlight.ItemConfirmEventArgs
MindFusion.Scheduling.Silverlight.ItemEditConfirmEventArgs

See Also

ItemEditConfirmEventArgs Members


MindFusion.Scheduling.Silverlight.ItemEditConfirmEventArgs Members

ItemEditConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ItemInplaceEditEnding event.

The following tables list the members exposed by the ItemEditConfirmEventArgs type.

Public Properties

Name | Description
NewText | Gets the new text that will be applied to the item if the in-place editing operation is allowed.

Inherited Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled. (Inherited from ItemConfirmEventArgs.)

See Also

ItemEditConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemEditConfirmEventArgs Properties

ItemEditConfirmEventArgs Properties
[image]

Public Properties

Name | Description
NewText | Gets the new text that will be applied to the item if the in-place editing operation is allowed.

Inherited Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled. (Inherited from ItemConfirmEventArgs.)

See Also

ItemEditConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemEditConfirmEventArgs.NewText Property

ItemEditConfirmEventArgs.NewText Property
[image]

Gets the new text that will be applied to the item if the in-place editing operation is allowed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string NewText { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

A string containing the new text of the item.

See Also

ItemEditConfirmEventArgs Members
ItemEditConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifiedEventArgs Class

ItemModifiedEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemModified event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemModifiedEventArgs : ItemEventArgs
Visual Basic [image] Copy Code

Public Class ItemModifiedEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Silverlight.ItemModifiedEventArgs

See Also

ItemModifiedEventArgs Members


MindFusion.Scheduling.Silverlight.ItemModifiedEventArgs Members

ItemModifiedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ItemModified event.

The following tables list the members exposed by the ItemModifiedEventArgs type.

Public Properties

Name | Description
OldEndTime | Gets the old end time of the item.
OldResources | Gets the old resources the item was associated with. This might as well contain Contacts, Locations, Tasks or Resources depending on the current grouping type.
OldStartTime | Gets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end has been modified.
ResizeStart | Gets a value indicating whether the item's start has been modified.

See Also

ItemModifiedEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifiedEventArgs Properties

ItemModifiedEventArgs Properties
[image]

Public Properties

Name | Description
OldEndTime | Gets the old end time of the item.
OldResources | Gets the old resources the item was associated with. This might as well contain Contacts, Locations, Tasks or Resources depending on the current grouping type.
OldStartTime | Gets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end has been modified.
ResizeStart | Gets a value indicating whether the item's start has been modified.

See Also

ItemModifiedEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifiedEventArgs.OldEndTime Property

ItemModifiedEventArgs.OldEndTime Property
[image]

Gets the old end time of the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime OldEndTime { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property OldEndTime As DateTime

Property Value

A .NET DateTime value representing the original end time of the modified item.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifiedEventArgs.OldResources Property

ItemModifiedEventArgs.OldResources Property
[image]

Gets the old resources the item was associated with. This might as well contain Contacts, Locations, Tasks or Resources depending on the current grouping type.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public List<Resource> OldResources { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property OldResources As List(Of Resource)

Property Value

A collection of resources originally associated with the item.

Remarks

The returned collection might contain Contact, Location, Task or Resource objects depending on the current grouping type.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifiedEventArgs.OldStartTime Property

ItemModifiedEventArgs.OldStartTime Property
[image]

Gets the old start time of the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime OldStartTime { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property OldStartTime As DateTime

Property Value

A .NET DateTime value representing the original start time of the modified item.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifiedEventArgs.ResizeEnd Property

ItemModifiedEventArgs.ResizeEnd Property
[image]

Gets a value indicating whether the item's end has been modified.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ResizeEnd { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ResizeEnd As Boolean

Property Value

true if the item's end has been modified; false if item was moved or its start has been modified.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifiedEventArgs.ResizeStart Property

ItemModifiedEventArgs.ResizeStart Property
[image]

Gets a value indicating whether the item's start has been modified.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ResizeStart { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ResizeStart As Boolean

Property Value

true if the item's start has been modified; false if item was moved or its end has been modified.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs Class

ItemModifyConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemModifying event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemModifyConfirmEventArgs : ItemConfirmEventArgs
Visual Basic [image] Copy Code

Public Class ItemModifyConfirmEventArgs
Inherits ItemConfirmEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Silverlight.ItemConfirmEventArgs
MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs

See Also

ItemModifyConfirmEventArgs Members


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs Members

ItemModifyConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ItemModifying event.

The following tables list the members exposed by the ItemModifyConfirmEventArgs type.

Public Properties

Name | Description
NewEndTime | Gets or sets the new end time of the item.
NewListLane | Gets or sets the index of the new list lane of the item.
NewStartTime | Gets or sets the new start time of the item.
OldEndTime | Gets or sets the old end time of the item.
OldListLane | Gets or sets the index of the old list lane of the item.
OldResources | Gets a list with the resources the modified item was previously associated with. This might as well be a Contact, Location, Task or Resource depending on the current grouping type.
OldStartTime | Gets or sets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end is being modified.
ResizeStart | Gets a value indicating whether the item's start is being modified.
Resource | Gets the new resource of the item. This might as well be a Contact, Location, Task or Resource depending on the current grouping type.

Inherited Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled. (Inherited from ItemConfirmEventArgs.)

See Also

ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs Properties

ItemModifyConfirmEventArgs Properties
[image]

Public Properties

Name | Description
NewEndTime | Gets or sets the new end time of the item.
NewListLane | Gets or sets the index of the new list lane of the item.
NewStartTime | Gets or sets the new start time of the item.
OldEndTime | Gets or sets the old end time of the item.
OldListLane | Gets or sets the index of the old list lane of the item.
OldResources | Gets a list with the resources the modified item was previously associated with. This might as well be a Contact, Location, Task or Resource depending on the current grouping type.
OldStartTime | Gets or sets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end is being modified.
ResizeStart | Gets a value indicating whether the item's start is being modified.
Resource | Gets the new resource of the item. This might as well be a Contact, Location, Task or Resource depending on the current grouping type.

Inherited Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled. (Inherited from ItemConfirmEventArgs.)

See Also

ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs.NewEndTime Property

ItemModifyConfirmEventArgs.NewEndTime Property
[image]

Gets or sets the new end time of the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime NewEndTime { get; set; }
Visual Basic [image] Copy Code

Public Property NewEndTime As DateTime

Property Value

A .NET DateTime object specifying the item's new end time.

Remarks

You will generally need to inspect the value of this property in order to see whether the new end time of the item would satisfy the criteria of your application, in order to confirm or refuse the user operation accordingly. In certain cases, however, you might want to set a new value to this property, thus forcing the end time of the item, disregarding the user's actions.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs.NewListLane Property

ItemModifyConfirmEventArgs.NewListLane Property
[image]

Gets or sets the index of the new list lane of the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int NewListLane { get; set; }
Visual Basic [image] Copy Code

Public Property NewListLane As Integer

Property Value

An integer object specifying the new list lane of the item, or -1, if this value is not relevant in the current context.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs.NewStartTime Property

ItemModifyConfirmEventArgs.NewStartTime Property
[image]

Gets or sets the new start time of the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime NewStartTime { get; set; }
Visual Basic [image] Copy Code

Public Property NewStartTime As DateTime

Property Value

A .NET DateTime object specifying the item's new start time.

Remarks

You will generally need to inspect the value of this property in order to see whether the new start time of the item would satisfy the criteria of your application, so to confirm or refuse the user operation accordingly. In certain cases, however, you might want to set a new value to this property, thus forcing the start time of the item, disregarding the user's actions.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs.OldEndTime Property

ItemModifyConfirmEventArgs.OldEndTime Property
[image]

Gets or sets the old end time of the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime OldEndTime { get; set; }
Visual Basic [image] Copy Code

Public Property OldEndTime As DateTime

Property Value

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs.OldListLane Property

ItemModifyConfirmEventArgs.OldListLane Property
[image]

Gets or sets the index of the old list lane of the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int OldListLane { get; set; }
Visual Basic [image] Copy Code

Public Property OldListLane As Integer

Property Value

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs.OldResources Property

ItemModifyConfirmEventArgs.OldResources Property
[image]

Gets a list with the resources the modified item was previously associated with. This might as well be a Contact, Location, Task or Resource depending on the current grouping type.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public List<Resource> OldResources { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property OldResources As List(Of Resource)

Property Value

Remarks

This value can be null, if the item doesn't change associated resource.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs.OldStartTime Property

ItemModifyConfirmEventArgs.OldStartTime Property
[image]

Gets or sets the old start time of the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateTime OldStartTime { get; set; }
Visual Basic [image] Copy Code

Public Property OldStartTime As DateTime

Property Value

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs.ResizeEnd Property

ItemModifyConfirmEventArgs.ResizeEnd Property
[image]

Gets a value indicating whether the item's end is being modified.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ResizeEnd { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ResizeEnd As Boolean

Property Value

true if the item's end is being modified; false if item is moved or its start is being modified.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs.ResizeStart Property

ItemModifyConfirmEventArgs.ResizeStart Property
[image]

Gets a value indicating whether the item's start is being modified.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ResizeStart { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ResizeStart As Boolean

Property Value

true if the item's start is being modified; false if item is moved or its end is being modified.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemModifyConfirmEventArgs.Resource Property

ItemModifyConfirmEventArgs.Resource Property
[image]

Gets the new resource of the item. This might as well be a Contact, Location, Task or Resource depending on the current grouping type.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Resource Resource { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

A reference to a Contact, Location, Task or Resource depending on the current grouping type.

Remarks

This value can be null (Nothing in Visual Basic), if the item doesn't change associated resource.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ItemMouseEventArgs Class

ItemMouseEventArgs Class
[image]

Contains the arguments passed to handlers of the ItemClick event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemMouseEventArgs : ItemEventArgs
Visual Basic [image] Copy Code

Public Class ItemMouseEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Silverlight.ItemMouseEventArgs

See Also

ItemMouseEventArgs Members


MindFusion.Scheduling.Silverlight.ItemMouseEventArgs Members

ItemMouseEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the ItemClick event.

The following tables list the members exposed by the ItemMouseEventArgs type.

Public Properties

Name | Description
ResizeEnd | Gets a value indicating whether the item's end is about to be resized.
ResizeStart | Gets a value indicating whether the item's start is about to be resized.
X | Gets the x-position of the mouse relative to the item.
Y | Gets the y-position of the mouse relative to the item.

See Also

ItemMouseEventArgs Class


MindFusion.Scheduling.Silverlight.ItemMouseEventArgs Properties

ItemMouseEventArgs Properties
[image]

Public Properties

Name | Description
ResizeEnd | Gets a value indicating whether the item's end is about to be resized.
ResizeStart | Gets a value indicating whether the item's start is about to be resized.
X | Gets the x-position of the mouse relative to the item.
Y | Gets the y-position of the mouse relative to the item.

See Also

ItemMouseEventArgs Class


MindFusion.Scheduling.Silverlight.ItemMouseEventArgs.ResizeEnd Property

ItemMouseEventArgs.ResizeEnd Property
[image]

Gets a value indicating whether the item's end is about to be resized.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ResizeEnd { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ResizeEnd As Boolean

Property Value

A Boolean value indicating whether the item's end is about to be resized in an ItemClick event.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class


MindFusion.Scheduling.Silverlight.ItemMouseEventArgs.ResizeStart Property

ItemMouseEventArgs.ResizeStart Property
[image]

Gets a value indicating whether the item's start is about to be resized.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ResizeStart { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ResizeStart As Boolean

Property Value

A Boolean value indicating whether the item's start is about to be resized in an ItemClick event.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class


MindFusion.Scheduling.Silverlight.ItemMouseEventArgs.X Property

ItemMouseEventArgs.X Property
[image]

Gets the x-position of the mouse relative to the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int X { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property X As Integer

Property Value

An integer value specifying the mouse position relatively to the item.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
Y Property


MindFusion.Scheduling.Silverlight.ItemMouseEventArgs.Y Property

ItemMouseEventArgs.Y Property
[image]

Gets the y-position of the mouse relative to the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int Y { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Y As Integer

Property Value

An integer value specifying the mouse position relatively to the item.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
X Property


MindFusion.Scheduling.Silverlight.ItemPresenter Class

ItemPresenter Class
Remarks See Also
[image]

Defines the base class of custom item presenter classes.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemPresenter : Control
Visual Basic [image] Copy Code

Public Class ItemPresenter
Inherits Control

Remarks

This class defines the presentation of an Item within the Calendar control. You can think of this class as a mediator between the data (Item) and the presentation layer (Calendar). For information how to define a custom template for the presenter, check Creating New Item Template. For information how to derive custom classes from ItemPresenter, check the Creating New Item Presenter.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Scheduling.Silverlight.ItemPresenter

See Also

ItemPresenter Members


MindFusion.Scheduling.Silverlight.ItemPresenter Members

ItemPresenter Members
Constructors Fields Properties Methods
[image]

Defines the base class of custom item presenter classes.

The following tables list the members exposed by the ItemPresenter type.

Public Constructors

Name | Description
ItemPresenter | Initializes a new instance of the ItemPresenter class.

Public Fields

Name | Description
CalendarProperty | Identifies the Calendar dependency property.
EndArrowImageVisibilityProperty | Identifies the EndArrowImageVisibility dependency property.
ItemProperty | Identifies the Item dependency dependency property.
ItemSettingsProperty | Identifies the ItemSettings dependency property.
ItemStyleProperty | Identifies the ItemStyle dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RecurrenceExceptionIconVisibilityProperty | Identifies the RecurrenceExceptionIconVisibility dependency property.
RecurrenceIconVisibilityProperty | Identifies the RecurrenceIconVisibility dependency property.
ReminderIconVisibilityProperty | Identifies the ReminderIconVisibility dependency property.
SelectedProperty | Identifies the Selected dependency property.
StartArrowImageVisibilityProperty | Identifies the StartArrowImageVisibility dependency property.
StyleKeyProperty | Identifies the StyleKey dependency property.

Public Properties

Name | Description
Calendar | Gets a reference to the Calendar object this presenter is associated with.
EndArrowImageVisibility | Gets a value indicating whether the end continuation arrow should be visible.
Item | Gets the Item associated with this presenter.
ItemSettings | Gets a reference to the Calendar.ItemSettings object.
ItemStyle | Gets the currently effective CalendarStyle.
Orientation | Gets the orientation of the associated item.
RecurrenceExceptionIconVisibility | Gets a value indicating whether the recurrence exception icon should be displayed.
RecurrenceIconVisibility | Gets a value indicating whether the recurrence icon should be displayed.
ReminderIconVisibility | Gets a value indicating whether the reminder icon should be displayed.
Selected | Gets a value indicating whether the underlying item is selected.
StartArrowImageVisibility | Gets a value indicating whether the start continuation arrow should be visible.
StyleKeyComplex | Contains the key of the resource that holds the template to be used when displaying complex (with description) Item instances.
StyleKeySimpleHorizontal | Contains the key of the resource that holds the template to be used when displaying simple (only header text) horizontal Item instances.
StyleKeySimpleVertical | Contains the key of the resource that holds the template to be used when displaying simple (only header text) vertical Item instances.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnOrientationChanged | Called when the value of the Orientation property changes.

See Also

ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter Fields

ItemPresenter Fields
[image]

Public Fields

Name | Description
CalendarProperty | Identifies the Calendar dependency property.
EndArrowImageVisibilityProperty | Identifies the EndArrowImageVisibility dependency property.
ItemProperty | Identifies the Item dependency dependency property.
ItemSettingsProperty | Identifies the ItemSettings dependency property.
ItemStyleProperty | Identifies the ItemStyle dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RecurrenceExceptionIconVisibilityProperty | Identifies the RecurrenceExceptionIconVisibility dependency property.
RecurrenceIconVisibilityProperty | Identifies the RecurrenceIconVisibility dependency property.
ReminderIconVisibilityProperty | Identifies the ReminderIconVisibility dependency property.
SelectedProperty | Identifies the Selected dependency property.
StartArrowImageVisibilityProperty | Identifies the StartArrowImageVisibility dependency property.
StyleKeyProperty | Identifies the StyleKey dependency property.

See Also

ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.CalendarProperty Field

ItemPresenter.CalendarProperty Field
[image]

Identifies the Calendar dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.EndArrowImageVisibilityProperty Field

ItemPresenter.EndArrowImageVisibilityProperty Field
[image]

Identifies the EndArrowImageVisibility dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndArrowImageVisibilityProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EndArrowImageVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.ItemProperty Field

ItemPresenter.ItemProperty Field
[image]

Identifies the Item dependency dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ItemProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.ItemSettingsProperty Field

ItemPresenter.ItemSettingsProperty Field
[image]

Identifies the ItemSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ItemSettingsProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.ItemStyleProperty Field

ItemPresenter.ItemStyleProperty Field
[image]

Identifies the ItemStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ItemStyleProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.OrientationProperty Field

ItemPresenter.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.RecurrenceExceptionIconVisibilityProperty Field

ItemPresenter.RecurrenceExceptionIconVisibilityProperty Field
See Also
[image]

Identifies the RecurrenceExceptionIconVisibility dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RecurrenceExceptionIconVisibilityProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly RecurrenceExceptionIconVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.RecurrenceIconVisibilityProperty Field

ItemPresenter.RecurrenceIconVisibilityProperty Field
[image]

Identifies the RecurrenceIconVisibility dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RecurrenceIconVisibilityProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly RecurrenceIconVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.ReminderIconVisibilityProperty Field

ItemPresenter.ReminderIconVisibilityProperty Field
[image]

Identifies the ReminderIconVisibility dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ReminderIconVisibilityProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ReminderIconVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.SelectedProperty Field

ItemPresenter.SelectedProperty Field
[image]

Identifies the Selected dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.StartArrowImageVisibilityProperty Field

ItemPresenter.StartArrowImageVisibilityProperty Field
[image]

Identifies the StartArrowImageVisibility dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartArrowImageVisibilityProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly StartArrowImageVisibilityProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.StyleKeyProperty Field

ItemPresenter.StyleKeyProperty Field
[image]

Identifies the StyleKey dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StyleKeyProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly StyleKeyProperty As DependencyProperty

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter Constructor

ItemPresenter Constructor
[image]

Initializes a new instance of the ItemPresenter class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemPresenter (
Calendar calendar
)
Visual Basic [image] Copy Code

Public New ( _
calendar As Calendar _
)

Parameters

calendar
The Calendar instance this ItemPresenter is associated with.

Remarks

When creating a custom ItemPresenter, make sure to provide a constructor with single argument of type Calendar. Otherwise your class will fail to load.

Example

The following code illustrates a common way to derive from ItemPresenter:

C# [image] Copy Code

public class MyAppointmentPresenter : ItemPresenter
{
public MyAppointmentPresenter(Calendar calendar)
: base(calendar)
{
this.DefaultStyleKey = typeof(MyAppointmentPresenter);
}

// ...
}
Visual Basic [image] Copy Code

Public Class MyAppointmentPresenter
Inherits ItemPresenter

Public Sub New(ByVal calendar As Calendar)
MyBase.new(calendar)

Me.DefaultStyleKey = GetType(MyAppointmentPresenter)

End Sub

End Class

See Also

ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter Methods

ItemPresenter Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
OnOrientationChanged | Called when the value of the Orientation property changes.

See Also

ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.OnApplyTemplate Method

ItemPresenter.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()
Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

Remarks

You can override this method in an ItemPresenter-derived class for various purposes, as described in the FrameworkElement.OnApplyTemplate [image] MSDN topic. The most common scenario includes obtaining a reference to a named element within the template, in order to attach an event handler for example. Make sure you always invoke the base' implementation of this method.

Check the CustomItemPresenter sample for an example on what you can do in this method.

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.OnOrientationChanged Method

ItemPresenter.OnOrientationChanged Method
[image]

Called when the value of the Orientation property changes.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnOrientationChanged (
Orientation oldOrientation,
Orientation newOrientation
)
Visual Basic [image] Copy Code

Protected Overridable Sub OnOrientationChanged ( _
oldOrientation As Orientation, _
newOrientation As Orientation _
)

Parameters

oldOrientation
The old value of the Orientation property.
newOrientation
The new value of the Orientation property.

Remarks

Override this method if you need to be notified when the value of the Orientation property has changed.

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter Properties

ItemPresenter Properties
[image]

Public Properties

Name | Description
Calendar | Gets a reference to the Calendar object this presenter is associated with.
EndArrowImageVisibility | Gets a value indicating whether the end continuation arrow should be visible.
Item | Gets the Item associated with this presenter.
ItemSettings | Gets a reference to the Calendar.ItemSettings object.
ItemStyle | Gets the currently effective CalendarStyle.
Orientation | Gets the orientation of the associated item.
RecurrenceExceptionIconVisibility | Gets a value indicating whether the recurrence exception icon should be displayed.
RecurrenceIconVisibility | Gets a value indicating whether the recurrence icon should be displayed.
ReminderIconVisibility | Gets a value indicating whether the reminder icon should be displayed.
Selected | Gets a value indicating whether the underlying item is selected.
StartArrowImageVisibility | Gets a value indicating whether the start continuation arrow should be visible.
StyleKeyComplex | Contains the key of the resource that holds the template to be used when displaying complex (with description) Item instances.
StyleKeySimpleHorizontal | Contains the key of the resource that holds the template to be used when displaying simple (only header text) horizontal Item instances.
StyleKeySimpleVertical | Contains the key of the resource that holds the template to be used when displaying simple (only header text) vertical Item instances.

See Also

ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.Calendar Property

ItemPresenter.Calendar Property
[image]

Gets a reference to the Calendar object this presenter is associated with.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Calendar Calendar { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Calendar As Calendar

Property Value

An instance of the Calendar class.

Remarks

This property returns the Calendar instance this ItemPresenter belongs to.

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.EndArrowImageVisibility Property

ItemPresenter.EndArrowImageVisibility Property
[image]

Gets a value indicating whether the end continuation arrow should be visible.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Visibility EndArrowImageVisibility { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property EndArrowImageVisibility As Visibility

Property Value

A member of the .NET Visibility enumeration.

Remarks

This property returns whether the icon of the end arrow should be visible. The end arrow is displayed when a simple item is wrapped across two or more lines.

See Also

ItemPresenter Members
ItemPresenter Class
StartArrowImageVisibility Property


MindFusion.Scheduling.Silverlight.ItemPresenter.Item Property

ItemPresenter.Item Property
[image]

Gets the Item associated with this presenter.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Item Item { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class.

Remarks

This property returns the Item instance this ItemPresenter is associated with. It is possible that more than one presenters is associated with the same item, such as when an item is wrapped across several lines.

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.ItemSettings Property

ItemPresenter.ItemSettings Property
[image]

Gets a reference to the Calendar.ItemSettings object.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemSettings ItemSettings { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ItemSettings As ItemSettings

Property Value

An instance of the ItemSettings class.

Remarks

This is a convenience property enabling item templates to bind to ItemSettings properties directly.

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.ItemStyle Property

ItemPresenter.ItemStyle Property
[image]

Gets the currently effective CalendarStyle.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle ItemStyle { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ItemStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

Remarks

The appearance of each item is defined by four CalendarStyle objects, depending on the current item state - normal, selected, hovered and hovered and selected at the same time. This property is automatically updated to reference the item style appropriate for the current state of the item. Therefore bindings to this property will be automatically updated when the item state changes.

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.Orientation Property

ItemPresenter.Orientation Property
[image]

Gets the orientation of the associated item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Orientation Orientation { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Orientation As Orientation

Property Value

A member of the Orientation enumeration.

Remarks

Items are displayed in either vertical or horizontal orientation depending on the current view and the current view settings. In SingleMonth, MonthRange, WeekRange and Resource views items are always displayed in horizontal orientation. In List view the item's orientation depends on the value of the ItemOrientation property. In Timetable view all day items have horizontal orientation and non-all day items have vertical orientation.

The value of this property is automatically updated to reflect the current orientation of the underlying item.

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.RecurrenceExceptionIconVisibility Property

ItemPresenter.RecurrenceExceptionIconVisibility Property
[image]

Gets a value indicating whether the recurrence exception icon should be displayed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Visibility RecurrenceExceptionIconVisibility { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property RecurrenceExceptionIconVisibility As Visibility

Property Value

A member of the .NET Visibility enumeration.

Remarks

This property returns whether the icon of the recurrence exception should be visible.

Example

The following excerpt from the default item template illustrates how to bind to this property in XAML:

XAML [image] Copy Code

<Image Source="pack://application:,,,/MindFusion.Scheduling.Silverlight;component/Resources/RecurrenceEx.png" Visibility="{Binding RecurrenceExceptionIconVisibility}" />

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Silverlight Namespace
RecurrenceIconVisibility Property
ReminderIconVisibilityÂ Property


MindFusion.Scheduling.Silverlight.ItemPresenter.RecurrenceIconVisibility Property

ItemPresenter.RecurrenceIconVisibility Property
[image]

Gets a value indicating whether the recurrence icon should be displayed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Visibility RecurrenceIconVisibility { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property RecurrenceIconVisibility As Visibility

Property Value

A member of the .NET Visibility enumeration.

Remarks

This property returns whether the icon of the recurrence should be visible.

Example

The following excerpt from the default item template illustrates how to bind to this property in XAML:

XAML [image] Copy Code

<Image Source="pack://application:,,,/MindFusion.Scheduling.Silverlight;component/Resources/Recurrence.png" Visibility="{Binding RecurrenceIconVisibility}" />

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Silverlight Namespace
RecurrenceExceptionIconVisibility Property
ReminderIconVisibility Property


MindFusion.Scheduling.Silverlight.ItemPresenter.ReminderIconVisibility Property

ItemPresenter.ReminderIconVisibility Property
[image]

Gets a value indicating whether the reminder icon should be displayed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Visibility ReminderIconVisibility { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ReminderIconVisibility As Visibility

Property Value

A member of the .NET Visibility enumeration.

Remarks

This property returns whether the icon of the reminder should be visible.

Example

The following excerpt from the default item template illustrates how to bind to this property in XAML:

XAML [image] Copy Code

<Image Source="pack://application:,,,/MindFusion.Scheduling.Silverlight;component/Resources/Reminder.png" Visibility="{Binding ReminderIconVisibility}" />

See Also

ItemPresenter Members
ItemPresenter Class
MindFusion.Scheduling.Silverlight Namespace
RecurrenceExceptionIconVisibility Property
RecurrenceIconVisibility Property


MindFusion.Scheduling.Silverlight.ItemPresenter.Selected Property

ItemPresenter.Selected Property
[image]

Gets a value indicating whether the underlying item is selected.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool Selected { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Selected As Boolean

Property Value

A bool value indicating the selection state of the item.

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.StartArrowImageVisibility Property

ItemPresenter.StartArrowImageVisibility Property
[image]

Gets a value indicating whether the start continuation arrow should be visible.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Visibility StartArrowImageVisibility { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property StartArrowImageVisibility As Visibility

Property Value

A member of the .NET Visibility enumeration.

Remarks

This property returns whether the icon of the start arrow should be visible. The start arrow is displayed when a simple item is wrapped across two or more lines.

See Also

ItemPresenter Members
ItemPresenter Class
EndArrowImageVisibility Property


MindFusion.Scheduling.Silverlight.ItemPresenter.StyleKeyComplex Property

ItemPresenter.StyleKeyComplex Property
[image]

Contains the key of the resource that holds the template to be used when displaying complex (with description) Item instances.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string StyleKeyComplex { get; set; }
Visual Basic [image] Copy Code

Public Property StyleKeyComplex As String

Property Value

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.StyleKeySimpleHorizontal Property

ItemPresenter.StyleKeySimpleHorizontal Property
[image]

Contains the key of the resource that holds the template to be used when displaying simple (only header text) horizontal Item instances.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string StyleKeySimpleHorizontal { get; set; }
Visual Basic [image] Copy Code

Public Property StyleKeySimpleHorizontal As String

Property Value

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenter.StyleKeySimpleVertical Property

ItemPresenter.StyleKeySimpleVertical Property
[image]

Contains the key of the resource that holds the template to be used when displaying simple (only header text) vertical Item instances.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string StyleKeySimpleVertical { get; set; }
Visual Basic [image] Copy Code

Public Property StyleKeySimpleVertical As String

Property Value

See Also

ItemPresenter Members
ItemPresenter Class


MindFusion.Scheduling.Silverlight.ItemPresenterAttribute Class

ItemPresenterAttribute Class
[image]

Associates a custom item presenter with a schedule item class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemPresenterAttribute : Attribute
Visual Basic [image] Copy Code

Public Class ItemPresenterAttribute
Inherits Attribute

Example

The following example illustrates how to associate a custom ItemPresenter class with a custom Appointment class. The example assumes that the custom ItemPresenter class is already defined and is named MyItemPresenter.

C# [image] Copy Code

[ItemPresenter(typeof(MyAppointmentPresenter))]
public class MyAppointment : Appointment
{
// ...
}
Visual Basic [image] Copy Code

<ItemPresenter(GetType(MyAppointmentPresenter))> _
Public Class MyAppointment
Inherits Appointment

' ...

End Class

Inheritance Hierarchy

System.Object
System.Attribute
MindFusion.Scheduling.Silverlight.ItemPresenterAttribute

See Also

ItemPresenterAttribute Members


MindFusion.Scheduling.Silverlight.ItemPresenterAttribute Members

ItemPresenterAttribute Members
Constructors Properties
[image]

Associates a custom item presenter with a schedule item class.

The following tables list the members exposed by the ItemPresenterAttribute type.

Public Constructors

Name | Description
ItemPresenterAttribute | Initializes a new instance of the ItemPresenterAttribute class.

Public Properties

Name | Description
PresenterType | Gets the Type of the custom ItemPresenter.

See Also

ItemPresenterAttribute Class


MindFusion.Scheduling.Silverlight.ItemPresenterAttribute Constructor

ItemPresenterAttribute Constructor
[image]

Initializes a new instance of the ItemPresenterAttribute class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemPresenterAttribute (
Type presenterType
)
Visual Basic [image] Copy Code

Public New ( _
presenterType As Type _
)

Parameters

presenterType
An instance of the .NET Type class specifying the custom presenter class.

See Also

ItemPresenterAttribute Class


MindFusion.Scheduling.Silverlight.ItemPresenterAttribute Properties

ItemPresenterAttribute Properties
[image]

Public Properties

Name | Description
PresenterType | Gets the Type of the custom ItemPresenter.

See Also

ItemPresenterAttribute Class


MindFusion.Scheduling.Silverlight.ItemPresenterAttribute.PresenterType Property

ItemPresenterAttribute.PresenterType Property
[image]

Gets the Type of the custom ItemPresenter.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Type PresenterType { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property PresenterType As Type

Property Value

An instance of the .NET Type class.

Remarks

The custom presenter class must derive from ItemPresenter.

See Also

ItemPresenterAttribute Members
ItemPresenterAttribute Class


MindFusion.Scheduling.Silverlight.ItemSelection Class

ItemSelection Class
[image]

An instance of this class represents a set of selected schedule items.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class ItemSelection
Visual Basic [image] Copy Code

Public NotInheritable Class ItemSelection

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Silverlight.ItemSelection

See Also

ItemSelection Members


MindFusion.Scheduling.Silverlight.ItemSelection Members

ItemSelection Members
Properties Methods
[image]

An instance of this class represents a set of selected schedule items.

The following tables list the members exposed by the ItemSelection type.

Public Properties

Name | Description
Count | Gets the number of selected items.
Items | Gets the selected items.

Public Methods

Name | Description
Add | Adds the specified item to the selection.
Clear | Clears the selection.
Contains | Determines whether the specified item is currently selected.
Remove | Removes the specified item from the selection.

See Also

ItemSelection Class


MindFusion.Scheduling.Silverlight.ItemSelection Methods

ItemSelection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified item to the selection.
Clear | Clears the selection.
Contains | Determines whether the specified item is currently selected.
Remove | Removes the specified item from the selection.

See Also

ItemSelection Class


MindFusion.Scheduling.Silverlight.ItemSelection.Add Method

ItemSelection.Add Method
[image]

Adds the specified item to the selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Add (
Item item
)
Visual Basic [image] Copy Code

Public Sub Add ( _
item As Item _
)

Parameters

item
The Item instance to be added to the selection.

See Also

ItemSelection Members
ItemSelection Class


MindFusion.Scheduling.Silverlight.ItemSelection.Clear Method

ItemSelection.Clear Method
[image]

Clears the selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Clear ()
Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

ItemSelection Members
ItemSelection Class


MindFusion.Scheduling.Silverlight.ItemSelection.Contains Method

ItemSelection.Contains Method
[image]

Determines whether the specified item is currently selected.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool Contains (
Item item
)
Visual Basic [image] Copy Code

Public Function Contains ( _
item As Item _
) As Boolean

Parameters

item
The Item instance to search for in the selection.

Return Value

true if the item is selected or false if it isn't.

See Also

ItemSelection Members
ItemSelection Class


MindFusion.Scheduling.Silverlight.ItemSelection.Remove Method

ItemSelection.Remove Method
[image]

Removes the specified item from the selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Remove (
Item item
)
Visual Basic [image] Copy Code

Public Sub Remove ( _
item As Item _
)

Parameters

item
The Item instance to be removed from the selection.

See Also

ItemSelection Members
ItemSelection Class


MindFusion.Scheduling.Silverlight.ItemSelection Properties

ItemSelection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of selected items.
Items | Gets the selected items.

See Also

ItemSelection Class


MindFusion.Scheduling.Silverlight.ItemSelection.Count Property

ItemSelection.Count Property
[image]

Gets the number of selected items.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int Count { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value specifying the number of selected items.

See Also

ItemSelection Members
ItemSelection Class


MindFusion.Scheduling.Silverlight.ItemSelection.Items Property

ItemSelection.Items Property
[image]

Gets the selected items.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Item[] Items { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Items As Item()

Property Value

An array of selected Item objects.

See Also

ItemSelection Members
ItemSelection Class


MindFusion.Scheduling.Silverlight.ItemSelectionEventArgs Class

ItemSelectionEventArgs Class
[image]

Contains the arguments passed to handlers of selection related events.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemSelectionEventArgs : ItemEventArgs
Visual Basic [image] Copy Code

Public Class ItemSelectionEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Silverlight.ItemSelectionEventArgs

See Also

ItemSelectionEventArgs Members


MindFusion.Scheduling.Silverlight.ItemSelectionEventArgs Members

ItemSelectionEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of selection related events.

The following tables list the members exposed by the ItemSelectionEventArgs type.

Public Properties

Name | Description
IsDeselected | Gets a value indicating whether the item was deselected.
IsSelected | Gets a value indicating whether the item was selected.

See Also

ItemSelectionEventArgs Class


MindFusion.Scheduling.Silverlight.ItemSelectionEventArgs Properties

ItemSelectionEventArgs Properties
[image]

Public Properties

Name | Description
IsDeselected | Gets a value indicating whether the item was deselected.
IsSelected | Gets a value indicating whether the item was selected.

See Also

ItemSelectionEventArgs Class


MindFusion.Scheduling.Silverlight.ItemSelectionEventArgs.IsDeselected Property

ItemSelectionEventArgs.IsDeselected Property
[image]

Gets a value indicating whether the item was deselected.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool IsDeselected { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property IsDeselected As Boolean

Property Value

true if the the item was deselected by the user; false if the item was selected.

Remarks

This property is mutually exclusive with IsSelected, that is, when one of them is false, the other is true, and vice versa.

See Also

ItemSelectionEventArgs Members
ItemSelectionEventArgs Class
IsSelected Property


MindFusion.Scheduling.Silverlight.ItemSelectionEventArgs.IsSelected Property

ItemSelectionEventArgs.IsSelected Property
[image]

Gets a value indicating whether the item was selected.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool IsSelected { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property IsSelected As Boolean

Property Value

true if the the item was selected by the user; false if the item was deselected.

Remarks

This property is mutually exclusive with IsDeselected, that is, when one of them is false, the other is true, and vice versa.

See Also

ItemSelectionEventArgs Members
ItemSelectionEventArgs Class
IsDeselected Property


MindFusion.Scheduling.Silverlight.ItemSettings Class

ItemSettings Class
[image]

Defines properties that allow customizing the visualization of schedule items in the calendar views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ItemSettings : CalendarSettings
Visual Basic [image] Copy Code

Public Class ItemSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.ItemSettings

See Also

ItemSettings Members


MindFusion.Scheduling.Silverlight.ItemSettings Members

ItemSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of schedule items in the calendar views.

The following tables list the members exposed by the ItemSettings type.

Public Constructors

Name | Description
ItemSettings | Initializes a new instance of the ItemSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CapIncompleteSegmentsProperty | Identifies the CapIncompleteSegments dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
ItemsVisibleProperty | Identifies the ItemsVisible dependency property.
MoveBandSizeProperty | Identifies the MoveBandSize dependency property.
PaddingProperty | Identifies the Padding dependency property.
PointedItemStyleProperty | Identifies the PointedItemStyle dependency property.
PointedSelectedItemStyleProperty | Identifies the PointedSelectedItemStyle dependency property.
ResizeBandSizeProperty | Identifies the ResizeBandSize dependency property.
SelectedItemStyleProperty | Identifies the SelectedItemStyle dependency property.
ShowContinuationArrowsProperty | Identifies the ShowContinuationArrows dependency property.
ShowItemEffectProperty | Identifies the ShowItemEffect dependency property.
ShowRecurrenceExceptionIconsProperty | Identifies the ShowRecurrenceExceptionIcons dependency property.
ShowRecurrenceIconsProperty | Identifies the ShowRecurrenceIcons dependency property.
ShowReminderIconsProperty | Identifies the ShowReminderIcons dependency property.
SizeProperty | Identifies the Size dependency property.
UseExtendedStylesProperty | Identifies the UseExtendedStyles dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the CalendarStyle used to paint schedule items that don't have a distinct style assigned to them.
CapIncompleteSegments | Gets or sets a value indicating whether to cap incomplete item segments.
HeaderSize | Gets or sets the size of the item header for non all-day items in the Timetable view.
ItemsVisible | Gets or sets a value indicating whether to display schedule items in the calendar.
MoveBandSize | Gets or sets the size of the move band of items in the Timetable view.
Padding | Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.
PointedItemStyle | Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse.
PointedSelectedItemStyle | Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse and selected at the same time.
ResizeBandSize | Gets or sets the size of the bands used to resize an item in a Timetable view.
SelectedItemStyle | Gets or sets the CalendarStyle used to paint selected schedule items.
ShowContinuationArrows | Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.
ShowItemEffect | Gets or sets a value indicating whether to display the effect of the item.
ShowRecurrenceExceptionIcons | Gets or sets a value indicating whether the icon of recurrence exception items is displayed.
ShowRecurrenceIcons | Gets or sets a value indicating whether the icon of recurring items is displayed.
ShowReminderIcons | Gets or sets a value indicating whether the reminder icon of items is displayed.
Size | Gets or sets the size of schedule items drawn in the calendar.
UseExtendedStyles | Gets or sets a value indicating whether the appropriate styles are used when an item is pointed with the mouse.

See Also

ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings Fields

ItemSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CapIncompleteSegmentsProperty | Identifies the CapIncompleteSegments dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
ItemsVisibleProperty | Identifies the ItemsVisible dependency property.
MoveBandSizeProperty | Identifies the MoveBandSize dependency property.
PaddingProperty | Identifies the Padding dependency property.
PointedItemStyleProperty | Identifies the PointedItemStyle dependency property.
PointedSelectedItemStyleProperty | Identifies the PointedSelectedItemStyle dependency property.
ResizeBandSizeProperty | Identifies the ResizeBandSize dependency property.
SelectedItemStyleProperty | Identifies the SelectedItemStyle dependency property.
ShowContinuationArrowsProperty | Identifies the ShowContinuationArrows dependency property.
ShowItemEffectProperty | Identifies the ShowItemEffect dependency property.
ShowRecurrenceExceptionIconsProperty | Identifies the ShowRecurrenceExceptionIcons dependency property.
ShowRecurrenceIconsProperty | Identifies the ShowRecurrenceIcons dependency property.
ShowReminderIconsProperty | Identifies the ShowReminderIcons dependency property.
SizeProperty | Identifies the Size dependency property.
UseExtendedStylesProperty | Identifies the UseExtendedStyles dependency property.

See Also

ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.CalendarStyleProperty Field

ItemSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.CapIncompleteSegmentsProperty Field

ItemSettings.CapIncompleteSegmentsProperty Field
[image]

Identifies the CapIncompleteSegments dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CapIncompleteSegmentsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CapIncompleteSegmentsProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.HeaderSizeProperty Field

ItemSettings.HeaderSizeProperty Field
[image]

Identifies the HeaderSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderSizeProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.ItemsVisibleProperty Field

ItemSettings.ItemsVisibleProperty Field
[image]

Identifies the ItemsVisible dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemsVisibleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ItemsVisibleProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.MoveBandSizeProperty Field

ItemSettings.MoveBandSizeProperty Field
[image]

Identifies the MoveBandSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MoveBandSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MoveBandSizeProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.PaddingProperty Field

ItemSettings.PaddingProperty Field
[image]

Identifies the Padding dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PaddingProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.PointedItemStyleProperty Field

ItemSettings.PointedItemStyleProperty Field
[image]

Identifies the PointedItemStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointedItemStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly PointedItemStyleProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.PointedSelectedItemStyleProperty Field

ItemSettings.PointedSelectedItemStyleProperty Field
[image]

Identifies the PointedSelectedItemStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointedSelectedItemStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly PointedSelectedItemStyleProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.ResizeBandSizeProperty Field

ItemSettings.ResizeBandSizeProperty Field
[image]

Identifies the ResizeBandSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResizeBandSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ResizeBandSizeProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.SelectedItemStyleProperty Field

ItemSettings.SelectedItemStyleProperty Field
[image]

Identifies the SelectedItemStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedItemStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedItemStyleProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.ShowContinuationArrowsProperty Field

ItemSettings.ShowContinuationArrowsProperty Field
[image]

Identifies the ShowContinuationArrows dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowContinuationArrowsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowContinuationArrowsProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.ShowItemEffectProperty Field

ItemSettings.ShowItemEffectProperty Field
[image]

Identifies the ShowItemEffect dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowItemEffectProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowItemEffectProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.ShowRecurrenceExceptionIconsProperty Field

ItemSettings.ShowRecurrenceExceptionIconsProperty Field
[image]

Identifies the ShowRecurrenceExceptionIcons dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowRecurrenceExceptionIconsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowRecurrenceExceptionIconsProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.ShowRecurrenceIconsProperty Field

ItemSettings.ShowRecurrenceIconsProperty Field
[image]

Identifies the ShowRecurrenceIcons dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowRecurrenceIconsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowRecurrenceIconsProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.ShowReminderIconsProperty Field

ItemSettings.ShowReminderIconsProperty Field
[image]

Identifies the ShowReminderIcons dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowReminderIconsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowReminderIconsProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.SizeProperty Field

ItemSettings.SizeProperty Field
[image]

Identifies the Size dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SizeProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.UseExtendedStylesProperty Field

ItemSettings.UseExtendedStylesProperty Field
[image]

Identifies the UseExtendedStyles dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty UseExtendedStylesProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly UseExtendedStylesProperty As DependencyProperty

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings Constructor

ItemSettings Constructor
[image]

Initializes a new instance of the ItemSettings class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemSettings ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings Properties

ItemSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the CalendarStyle used to paint schedule items that don't have a distinct style assigned to them.
CapIncompleteSegments | Gets or sets a value indicating whether to cap incomplete item segments.
HeaderSize | Gets or sets the size of the item header for non all-day items in the Timetable view.
ItemsVisible | Gets or sets a value indicating whether to display schedule items in the calendar.
MoveBandSize | Gets or sets the size of the move band of items in the Timetable view.
Padding | Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.
PointedItemStyle | Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse.
PointedSelectedItemStyle | Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse and selected at the same time.
ResizeBandSize | Gets or sets the size of the bands used to resize an item in a Timetable view.
SelectedItemStyle | Gets or sets the CalendarStyle used to paint selected schedule items.
ShowContinuationArrows | Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.
ShowItemEffect | Gets or sets a value indicating whether to display the effect of the item.
ShowRecurrenceExceptionIcons | Gets or sets a value indicating whether the icon of recurrence exception items is displayed.
ShowRecurrenceIcons | Gets or sets a value indicating whether the icon of recurring items is displayed.
ShowReminderIcons | Gets or sets a value indicating whether the reminder icon of items is displayed.
Size | Gets or sets the size of schedule items drawn in the calendar.
UseExtendedStyles | Gets or sets a value indicating whether the appropriate styles are used when an item is pointed with the mouse.

See Also

ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.CalendarStyle Property

ItemSettings.CalendarStyle Property
[image]

Gets or sets the CalendarStyle used to paint schedule items that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object defining the appearance of schedule items. This property cannot be null (Nothing in Visual Basic).

Remarks

To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Silverlight Namespace
SelectedItemStyle Property
PointedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.ItemSettings.CapIncompleteSegments Property

ItemSettings.CapIncompleteSegments Property
[image]

Gets or sets a value indicating whether to cap incomplete item segments.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool CapIncompleteSegments { get; set; }
Visual Basic [image] Copy Code

Public Property CapIncompleteSegments As Boolean

Property Value

true to cap incomplete items segments; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property is ignored for non all-day items in the Timetable view.

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.HeaderSize Property

ItemSettings.HeaderSize Property
[image]

Gets or sets the size of the item header for non all-day items in the Timetable view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int HeaderSize { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the item header (in pixels).

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

You can assign 0 to hide the item header completely.

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.ItemsVisible Property

ItemSettings.ItemsVisible Property
[image]

Gets or sets a value indicating whether to display schedule items in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ItemsVisible { get; set; }
Visual Basic [image] Copy Code

Public Property ItemsVisible As Boolean

Property Value

true to display schedule items; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.MoveBandSize Property

ItemSettings.MoveBandSize Property
[image]

Gets or sets the size of the move band of items in the Timetable view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int MoveBandSize { get; set; }
Visual Basic [image] Copy Code

Public Property MoveBandSize As Integer

Property Value

A non-negative integer value specifying the band size in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.Padding Property

ItemSettings.Padding Property
[image]

Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Thickness Padding { get; set; }
Visual Basic [image] Copy Code

Public Property Padding As Thickness

Property Value

A non-negative integer value specifying how many pixels there are left between items and the time cells containing them.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

In a Timetable view this is the distance between consecutive items.

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.PointedItemStyle Property

ItemSettings.PointedItemStyle Property
[image]

Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle PointedItemStyle { get; set; }
Visual Basic [image] Copy Code

Public Property PointedItemStyle As CalendarStyle

Property Value

A CalendarStyle object defining the appearance of schedule items when they are pointed with the mouse. This property cannot be null (Nothing in Visual Basic).

Remarks

This property is ignored when UseExtendedStyles is set to false.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
SelectedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.ItemSettings.PointedSelectedItemStyle Property

ItemSettings.PointedSelectedItemStyle Property
[image]

Gets or sets the CalendarStyle used to paint items when they are pointed with the mouse and selected at the same time.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle PointedSelectedItemStyle { get; set; }
Visual Basic [image] Copy Code

Public Property PointedSelectedItemStyle As CalendarStyle

Property Value

A CalendarStyle object defining the appearance of schedule items when they are pointed with the mouse and selected at the same time. This property cannot be null (Nothing in Visual Basic).

Remarks

This property is ignored when UseExtendedStyles is set to false.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
SelectedItemStyle Property
PointedItemStyle Property
UseExtendedStyles Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.ItemSettings.ResizeBandSize Property

ItemSettings.ResizeBandSize Property
[image]

Gets or sets the size of the bands used to resize an item in a Timetable view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ResizeBandSize { get; set; }
Visual Basic [image] Copy Code

Public Property ResizeBandSize As Integer

Property Value

An integer value specifying the bands' size in pixels. The minimal allowed value is 2.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.SelectedItemStyle Property

ItemSettings.SelectedItemStyle Property
[image]

Gets or sets the CalendarStyle used to paint selected schedule items.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SelectedItemStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SelectedItemStyle As CalendarStyle

Property Value

A CalendarStyle object defining the appearance of selected schedule items. This property cannot be null (Nothing in Visual Basic).

Remarks

To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
PointedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.ItemSettings.ShowContinuationArrows Property

ItemSettings.ShowContinuationArrows Property
[image]

Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowContinuationArrows { get; set; }
Visual Basic [image] Copy Code

Public Property ShowContinuationArrows As Boolean

Property Value

Specify true to display arrow icons when an item continues in next time cell; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.ShowItemEffect Property

ItemSettings.ShowItemEffect Property
[image]

Gets or sets a value indicating whether to display the effect of the item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowItemEffect { get; set; }
Visual Basic [image] Copy Code

Public Property ShowItemEffect As Boolean

Property Value

true to display item effects; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class


MindFusion.Scheduling.Silverlight.ItemSettings.ShowRecurrenceExceptionIcons Property

ItemSettings.ShowRecurrenceExceptionIcons Property
[image]

Gets or sets a value indicating whether the icon of recurrence exception items is displayed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowRecurrenceExceptionIcons { get; set; }
Visual Basic [image] Copy Code

Public Property ShowRecurrenceExceptionIcons As Boolean

Property Value

true to display an icon for the exceptions of recurring items; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Silverlight Namespace
ShowRecurrenceIcons Property
ShowReminderIcons Property


MindFusion.Scheduling.Silverlight.ItemSettings.ShowRecurrenceIcons Property

ItemSettings.ShowRecurrenceIcons Property
[image]

Gets or sets a value indicating whether the icon of recurring items is displayed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowRecurrenceIcons { get; set; }
Visual Basic [image] Copy Code

Public Property ShowRecurrenceIcons As Boolean

Property Value

true to display an icon for recurring items; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Silverlight Namespace
ShowRecurrenceExceptionIcons Property
ShowReminderIcons Property


MindFusion.Scheduling.Silverlight.ItemSettings.ShowReminderIcons Property

ItemSettings.ShowReminderIcons Property
[image]

Gets or sets a value indicating whether the reminder icon of items is displayed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowReminderIcons { get; set; }
Visual Basic [image] Copy Code

Public Property ShowReminderIcons As Boolean

Property Value

true to display an icon for items that have a reminder; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Silverlight Namespace
ShowRecurrenceIcons Property
ShowRecurrenceExceptionIcons Property


MindFusion.Scheduling.Silverlight.ItemSettings.Size Property

ItemSettings.Size Property
[image]

Gets or sets the size of schedule items drawn in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int Size { get; set; }
Visual Basic [image] Copy Code

Public Property Size As Integer

Property Value

A non-negative integer value specifying items width or height in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property specifies the height of horizontal items or the width of vertical items. The items length is defined by their start time and duration. The property is ignored for items drawn in timetable view.

See Also

ItemSettings Members
ItemSettings Class
Padding Property


MindFusion.Scheduling.Silverlight.ItemSettings.UseExtendedStyles Property

ItemSettings.UseExtendedStyles Property
[image]

Gets or sets a value indicating whether the appropriate styles are used when an item is pointed with the mouse.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool UseExtendedStyles { get; set; }
Visual Basic [image] Copy Code

Public Property UseExtendedStyles As Boolean

Property Value

true to enable extended styles; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If this property is set to false, the pointed styles (that is, PointedItemStyle and PointedSelectedItemStyle) are ignored.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Silverlight Namespace
Style Property
SelectedItemStyle Property
PointedItemStyle Property
PointedSelectedItemStyle Property


MindFusion.Scheduling.Silverlight.ListViewHeaderStyles Enumeration

ListViewHeaderStyles Enumeration
[image]

Specifies the appearance and behavior of the header in a List view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum ListViewHeaderStyles
Visual Basic [image] Copy Code

Public Enumeration ListViewHeaderStyles

Members

Member name | Description
None | Do not display a header.
Subheader | Draw a sub-header below the main header. The subheader can be customized through the SubHeaderSize, SubTitleFormat and SubHeaderDivisions properties of the ListViewSettings class.
SubheaderPerCell | Draw the header background for each cell separately, rather than for the whole interval.
Title | Display the cells' dates in the header.

See Also


MindFusion.Scheduling.Silverlight.ListViewSettings Class

ListViewSettings Class
[image]

Defines properties that allow customizing the visualization of the calendar in a List view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class ListViewSettings : CalendarSettings
Visual Basic [image] Copy Code

Public NotInheritable Class ListViewSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.ListViewSettings

See Also

ListViewSettings Members


MindFusion.Scheduling.Silverlight.ListViewSettings Members

ListViewSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of the calendar in a List view.

The following tables list the members exposed by the ListViewSettings type.

Public Constructors

Name | Description
ListViewSettings | Initializes a new instance of the ListViewSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSettingsProperty | Identifies the CellSettings dependency property.
CellUnitsProperty | Identifies the CellUnits dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
EnableVirtualItemSpaceProperty | Identifies the EnableVirtualItemSpace dependency property.
EvenWeeksBrushProperty | Identifies the EvenWeeksBrush dependency property.
FreeDragProperty | Identifies the FreeDrag dependency property.
GroupHeaderSizeProperty | Identifies the GroupHeaderSize dependency property.
GroupHeaderStyleProperty | Identifies the GroupHeaderStyle dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyles dependency property.
ItemOrientationProperty | Identifies the ItemOrientation dependency property.
NumberOfCellsProperty | Identifies the NumberOfCells dependency property.
OddWeeksBrushProperty | Identifies the OddWeeksBrush dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RotateHeaderTextsProperty | Identifies the RotateHeaderTexts dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowGroupHeaderProperty | Identifies the ShowGroupHeader dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
SubHeaderDivisionsProperty | Identifies the SubHeaderDivisions dependency property.
SubHeaderSizeProperty | Identifies the SubHeaderSize dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
SubTitleFormatProperty | Identifies the SubTitleFormat dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TotalLaneCountProperty | Identifies the TotalLaneCount dependency property.
VisibleCellsProperty | Identifies the VisibleCells dependency property.
VisibleColumnsProperty | Identifies the VisibleColumns dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSettings | Gets or sets a CellSettings object used to customize the visualization of cells in the List view.
CellUnits | Gets or sets the resolution of the list view.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EnableVirtualItemSpace | Gets or sets a value indicating whether items in the list view can be scrolled through.
EvenWeeksBrush | Gets or sets the brush used to paint the background of the contents of even weeks.
FreeDrag | Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the group header.
HeaderSize | Gets or sets the header size in pixels.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the List view header.
ItemOrientation | Gets or sets a value indicating whether the items are displayed horizontally or vertically.
NumberOfCells | Gets or sets the total number of cells to be displayed in the List view.
OddWeeksBrush | Gets or sets the brush used to paint the background of the contents of odd weeks.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts in a horizontal list view are rotated.
ScrollStep | Gets or sets the number of units to scroll when the user clicks the navigation buttons.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowGroupHeader | Gets or sets a value indicating whether to display the reference grouping header.
ShowNavigationButtons | Gets or sets a value indicating whether the List view displays navigation buttons.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
SubHeaderDivisions | Gets or sets the number of divisions in the sub-header.
SubHeaderSize | Gets or sets the subheader size in pixels.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
SubTitleFormat | Gets or sets a string used to format the cells subtitles.
TitleFormat | Gets or sets a string used to format the cells titles.
TotalLaneCount | Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to true.
VisibleCells | Gets or sets the number of cells visible at the same time.
VisibleColumns | Gets or sets the number of visible group columns in a list view.

See Also

ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings Fields

ListViewSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSettingsProperty | Identifies the CellSettings dependency property.
CellUnitsProperty | Identifies the CellUnits dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
EnableVirtualItemSpaceProperty | Identifies the EnableVirtualItemSpace dependency property.
EvenWeeksBrushProperty | Identifies the EvenWeeksBrush dependency property.
FreeDragProperty | Identifies the FreeDrag dependency property.
GroupHeaderSizeProperty | Identifies the GroupHeaderSize dependency property.
GroupHeaderStyleProperty | Identifies the GroupHeaderStyle dependency property.
HeaderSizeProperty | Identifies the HeaderSize dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyles dependency property.
ItemOrientationProperty | Identifies the ItemOrientation dependency property.
NumberOfCellsProperty | Identifies the NumberOfCells dependency property.
OddWeeksBrushProperty | Identifies the OddWeeksBrush dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RotateHeaderTextsProperty | Identifies the RotateHeaderTexts dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowGroupHeaderProperty | Identifies the ShowGroupHeader dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
SubHeaderDivisionsProperty | Identifies the SubHeaderDivisions dependency property.
SubHeaderSizeProperty | Identifies the SubHeaderSize dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
SubTitleFormatProperty | Identifies the SubTitleFormat dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TotalLaneCountProperty | Identifies the TotalLaneCount dependency property.
VisibleCellsProperty | Identifies the VisibleCells dependency property.
VisibleColumnsProperty | Identifies the VisibleColumns dependency property.

See Also

ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.CalendarStyleProperty Field

ListViewSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.CellSettingsProperty Field

ListViewSettings.CellSettingsProperty Field
[image]

Identifies the CellSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellSettingsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.CellUnitsProperty Field

ListViewSettings.CellUnitsProperty Field
[image]

Identifies the CellUnits dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellUnitsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellUnitsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.EnableSnappingProperty Field

ListViewSettings.EnableSnappingProperty Field
[image]

Identifies the EnableSnapping dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableSnappingProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EnableSnappingProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.EnableVirtualItemSpaceProperty Field

ListViewSettings.EnableVirtualItemSpaceProperty Field
[image]

Identifies the EnableVirtualItemSpace dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableVirtualItemSpaceProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EnableVirtualItemSpaceProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.EvenWeeksBrushProperty Field

ListViewSettings.EvenWeeksBrushProperty Field
[image]

Identifies the EvenWeeksBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EvenWeeksBrushProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EvenWeeksBrushProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.FreeDragProperty Field

ListViewSettings.FreeDragProperty Field
[image]

Identifies the FreeDrag dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FreeDragProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly FreeDragProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.GroupHeaderSizeProperty Field

ListViewSettings.GroupHeaderSizeProperty Field
[image]

Identifies the GroupHeaderSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupHeaderSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly GroupHeaderSizeProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.GroupHeaderStyleProperty Field

ListViewSettings.GroupHeaderStyleProperty Field
[image]

Identifies the GroupHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly GroupHeaderStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.HeaderSizeProperty Field

ListViewSettings.HeaderSizeProperty Field
[image]

Identifies the HeaderSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderSizeProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.HeaderStyleProperty Field

ListViewSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.HeaderStylesProperty Field

ListViewSettings.HeaderStylesProperty Field
[image]

Identifies the HeaderStyles dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStylesProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStylesProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.ItemOrientationProperty Field

ListViewSettings.ItemOrientationProperty Field
[image]

Identifies the ItemOrientation dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemOrientationProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ItemOrientationProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.NumberOfCellsProperty Field

ListViewSettings.NumberOfCellsProperty Field
[image]

Identifies the NumberOfCells dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NumberOfCellsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly NumberOfCellsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.OddWeeksBrushProperty Field

ListViewSettings.OddWeeksBrushProperty Field
[image]

Identifies the OddWeeksBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OddWeeksBrushProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly OddWeeksBrushProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.OrientationProperty Field

ListViewSettings.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.RotateHeaderTextsProperty Field

ListViewSettings.RotateHeaderTextsProperty Field
[image]

Identifies the RotateHeaderTexts dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateHeaderTextsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly RotateHeaderTextsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.ScrollStepProperty Field

ListViewSettings.ScrollStepProperty Field
[image]

Identifies the ScrollStep dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollStepProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollStepProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.SelectedElementsHeaderStyleProperty Field

ListViewSettings.SelectedElementsHeaderStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsHeaderStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.SelectedElementsStyleProperty Field

ListViewSettings.SelectedElementsStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.ShowGroupHeaderProperty Field

ListViewSettings.ShowGroupHeaderProperty Field
[image]

Identifies the ShowGroupHeader dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowGroupHeaderProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowGroupHeaderProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.ShowNavigationButtonsProperty Field

ListViewSettings.ShowNavigationButtonsProperty Field
[image]

Identifies the ShowNavigationButtons dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowNavigationButtonsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowNavigationButtonsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.SnapUnitCountProperty Field

ListViewSettings.SnapUnitCountProperty Field
[image]

Identifies the SnapUnitCount dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitCountProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitCountProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.SnapUnitProperty Field

ListViewSettings.SnapUnitProperty Field
[image]

Identifies the SnapUnit dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.SubHeaderDivisionsProperty Field

ListViewSettings.SubHeaderDivisionsProperty Field
[image]

Identifies the SubHeaderDivisions dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderDivisionsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderDivisionsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.SubHeaderSizeProperty Field

ListViewSettings.SubHeaderSizeProperty Field
[image]

Identifies the SubHeaderSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderSizeProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.SubHeaderStyleProperty Field

ListViewSettings.SubHeaderStyleProperty Field
[image]

Identifies the SubHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderStyleProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.SubTitleFormatProperty Field

ListViewSettings.SubTitleFormatProperty Field
[image]

Identifies the SubTitleFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubTitleFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SubTitleFormatProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.TitleFormatProperty Field

ListViewSettings.TitleFormatProperty Field
[image]

Identifies the TitleFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFormatProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.TotalLaneCountProperty Field

ListViewSettings.TotalLaneCountProperty Field
[image]

Identifies the TotalLaneCount dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TotalLaneCountProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TotalLaneCountProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.VisibleCellsProperty Field

ListViewSettings.VisibleCellsProperty Field
[image]

Identifies the VisibleCells dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleCellsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleCellsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.VisibleColumnsProperty Field

ListViewSettings.VisibleColumnsProperty Field
[image]

Identifies the VisibleColumns dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleColumnsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleColumnsProperty As DependencyProperty

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings Constructor

ListViewSettings Constructor
[image]

Initializes a new instance of the ListViewSettings class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ListViewSettings ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings Properties

ListViewSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSettings | Gets or sets a CellSettings object used to customize the visualization of cells in the List view.
CellUnits | Gets or sets the resolution of the list view.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EnableVirtualItemSpace | Gets or sets a value indicating whether items in the list view can be scrolled through.
EvenWeeksBrush | Gets or sets the brush used to paint the background of the contents of even weeks.
FreeDrag | Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the group header.
HeaderSize | Gets or sets the header size in pixels.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the List view header.
ItemOrientation | Gets or sets a value indicating whether the items are displayed horizontally or vertically.
NumberOfCells | Gets or sets the total number of cells to be displayed in the List view.
OddWeeksBrush | Gets or sets the brush used to paint the background of the contents of odd weeks.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts in a horizontal list view are rotated.
ScrollStep | Gets or sets the number of units to scroll when the user clicks the navigation buttons.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowGroupHeader | Gets or sets a value indicating whether to display the reference grouping header.
ShowNavigationButtons | Gets or sets a value indicating whether the List view displays navigation buttons.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
SubHeaderDivisions | Gets or sets the number of divisions in the sub-header.
SubHeaderSize | Gets or sets the subheader size in pixels.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
SubTitleFormat | Gets or sets a string used to format the cells subtitles.
TitleFormat | Gets or sets a string used to format the cells titles.
TotalLaneCount | Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to true.
VisibleCells | Gets or sets the number of cells visible at the same time.
VisibleColumns | Gets or sets the number of visible group columns in a list view.

See Also

ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.CalendarStyle Property

ListViewSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the view elements. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
CalendarStyle Class


MindFusion.Scheduling.Silverlight.ListViewSettings.CellSettings Property

ListViewSettings.CellSettings Property
[image]

Gets or sets a CellSettings object used to customize the visualization of cells in the List view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CellSettings CellSettings { get; set; }
Visual Basic [image] Copy Code

Public Property CellSettings As CellSettings

Property Value

An instance of the CellSettings class. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.CellUnits Property

ListViewSettings.CellUnits Property
[image]

Gets or sets the resolution of the list view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimeUnit CellUnits { get; set; }
Visual Basic [image] Copy Code

Public Property CellUnits As TimeUnit

Property Value

A member of the TimeUnit enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.EnableSnapping Property

ListViewSettings.EnableSnapping Property
[image]

Gets or sets a value indicating whether custom snapping is enabled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool EnableSnapping { get; set; }
Visual Basic [image] Copy Code

Public Property EnableSnapping As Boolean

Property Value

true to enable snapping; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

When this property is enabled, the users will move and resize items with the precision specified in the SnapUnit property instead of the precision of the view's resolution. When this property is disabled, the items will snap automatically to the border of their containing cells.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
SnapUnit Property
SnapUnitCount Property


MindFusion.Scheduling.Silverlight.ListViewSettings.EnableVirtualItemSpace Property

ListViewSettings.EnableVirtualItemSpace Property
[image]

Gets or sets a value indicating whether items in the list view can be scrolled through.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool EnableVirtualItemSpace { get; set; }
Visual Basic [image] Copy Code

Public Property EnableVirtualItemSpace As Boolean

Property Value

true to enable virtual item space; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Use this property to override the default behavior of the vertical scrollbar (in a horizontal List view) or the horizontal scrollbar (in a vertical List view). When this property is enabled, the appropriate scrollbar will scroll through the items that are not visible within the view (due to insufficient space) rather than scroll through the cells associated with resources in a grouped List view.

See Also

ListViewSettings Members
ListViewSettings Class
FreeDrag Property


MindFusion.Scheduling.Silverlight.ListViewSettings.EvenWeeksBrush Property

ListViewSettings.EvenWeeksBrush Property
[image]

Gets or sets the brush used to paint the background of the contents of even weeks.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush EvenWeeksBrush { get; set; }
Visual Basic [image] Copy Code

Public Property EvenWeeksBrush As Brush

Property Value

An instance of a Brush-derived class.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If this property is set to null (Nothing in Visual Basic), the brush from the associated style is used.

See Also

ListViewSettings Members
ListViewSettings Class
OddWeeksBrush Property


MindFusion.Scheduling.Silverlight.ListViewSettings.FreeDrag Property

ListViewSettings.FreeDrag Property
[image]

Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool FreeDrag { get; set; }
Visual Basic [image] Copy Code

Public Property FreeDrag As Boolean

Property Value

true to enable free dragging; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Set this property to true to disable the default item layout algorithm, where colliding items are arranged relative to each other according to their start and end times and their Priority. Turning this property on will allow users to move items anywhere within the view.

The position of an item acquired through free dragging is related to the view. This means that if the schedule, containing the item is displayed in another Calendar control, the item's position within the List view might not be the same as its position in the initial view. Additionally, view-related data is not serialized by calling the serialization methods of the Schedule class.

Finally, the position of an item within the view can be obtained and set programmatically through the use of the GetItemListLane and SetItemListLane methods of the Calendar class.

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.GroupHeaderSize Property

ListViewSettings.GroupHeaderSize Property
[image]

Gets or sets the size of the group header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int GroupHeaderSize { get; set; }
Visual Basic [image] Copy Code

Public Property GroupHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ListViewSettings Members
ListViewSettings Class
ShowGroupHeader Property


MindFusion.Scheduling.Silverlight.ListViewSettings.GroupHeaderStyle Property

ListViewSettings.GroupHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the group header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle GroupHeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property GroupHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the column headers. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.ListViewSettings.HeaderSize Property

ListViewSettings.HeaderSize Property
[image]

Gets or sets the header size in pixels.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int HeaderSize { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the header size. A value of 0 hides the header.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property specifies the header width if Orientation is Horizontal or the height if Orientation is Vertical.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyle Property
TitleFormat Property


MindFusion.Scheduling.Silverlight.ListViewSettings.HeaderStyle Property

ListViewSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
SubHeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.ListViewSettings.HeaderStyles Property

ListViewSettings.HeaderStyles Property
[image]

Gets or sets the style of the List view header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ListViewHeaderStyles HeaderStyles { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderStyles As ListViewHeaderStyles

Property Value

A member of the ListViewHeaderStyles enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderSize Property
TitleFormat Property


MindFusion.Scheduling.Silverlight.ListViewSettings.ItemOrientation Property

ListViewSettings.ItemOrientation Property
[image]

Gets or sets a value indicating whether the items are displayed horizontally or vertically.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Orientation ItemOrientation { get; set; }
Visual Basic [image] Copy Code

Public Property ItemOrientation As Orientation

Property Value

A member of the Orientation enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Items are usually oriented according to the view's Orientation. That is, items are horizontal in a horizontal List view and vice versa. The orientation of the items can be explicitly specified by using this property.

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.NumberOfCells Property

ListViewSettings.NumberOfCells Property
[image]

Gets or sets the total number of cells to be displayed in the List view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int NumberOfCells { get; set; }
Visual Basic [image] Copy Code

Public Property NumberOfCells As Integer

Property Value

An integer value specifying how many days to display.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This value cannot be less than 1 or less than the number of visible days set in the VisibleCells property.

See Also

ListViewSettings Members
ListViewSettings Class
VisibleCells Property


MindFusion.Scheduling.Silverlight.ListViewSettings.OddWeeksBrush Property

ListViewSettings.OddWeeksBrush Property
[image]

Gets or sets the brush used to paint the background of the contents of odd weeks.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush OddWeeksBrush { get; set; }
Visual Basic [image] Copy Code

Public Property OddWeeksBrush As Brush

Property Value

An instance of a Brush-derived class.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If this property is set to null (Nothing in Visual Basic), the brush from the associated style is used.

See Also

ListViewSettings Members
ListViewSettings Class
EvenWeeksBrush Property


MindFusion.Scheduling.Silverlight.ListViewSettings.Orientation Property

ListViewSettings.Orientation Property
[image]

Gets or sets a value indicating whether the cells are displayed horizontally or vertically.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }
Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If this property is set to Horizontal, the view header is displayed at the top and the day cells are arranged in a horizontal row underneath it. If set to Vertical, the header is displayed on the left side and the days are arranged in a vertical row on the right.

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.RotateHeaderTexts Property

ListViewSettings.RotateHeaderTexts Property
[image]

Gets or sets a value indicating whether the header texts in a horizontal list view are rotated.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool RotateHeaderTexts { get; set; }
Visual Basic [image] Copy Code

Public Property RotateHeaderTexts As Boolean

Property Value

true to display the header text rotated; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.ScrollStep Property

ListViewSettings.ScrollStep Property
[image]

Gets or sets the number of units to scroll when the user clicks the navigation buttons.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ScrollStep { get; set; }
Visual Basic [image] Copy Code

Public Property ScrollStep As Integer

Property Value

An integer value specifying the number of units to scroll.

Remarks

This property specifies the amount of units (as specified by the CellUnits property) to scroll back and forth when using the navigation buttons in the List view.

See Also

ListViewSettings Members
ListViewSettings Class
ShowNavigationButtons Property


MindFusion.Scheduling.Silverlight.ListViewSettings.SelectedElementsHeaderStyle Property

ListViewSettings.SelectedElementsHeaderStyle Property
[image]

Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsHeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SelectedElementsHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected header elements. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
SelectedElementsStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.ListViewSettings.SelectedElementsStyle Property

ListViewSettings.SelectedElementsStyle Property
[image]

Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SelectedElementsStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected elements. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
SelectedElementsHeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.ListViewSettings.ShowGroupHeader Property

ListViewSettings.ShowGroupHeader Property
[image]

Gets or sets a value indicating whether to display the reference grouping header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowGroupHeader { get; set; }
Visual Basic [image] Copy Code

Public Property ShowGroupHeader As Boolean

Property Value

true to show the group header; otherwise, false.

See Also

ListViewSettings Members
ListViewSettings Class
GroupHeaderSize Property


MindFusion.Scheduling.Silverlight.ListViewSettings.ShowNavigationButtons Property

ListViewSettings.ShowNavigationButtons Property
[image]

Gets or sets a value indicating whether the List view displays navigation buttons.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowNavigationButtons { get; set; }
Visual Basic [image] Copy Code

Public Property ShowNavigationButtons As Boolean

Property Value

true to display the navigation buttons; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The size of the buttons can be controlled through the ButtonSize property of the Calendar class. The amount of units to scroll can be specified through the ScrollStep property.

See Also

ListViewSettings Members
ListViewSettings Class
ScrollStep Property


MindFusion.Scheduling.Silverlight.ListViewSettings.SnapUnit Property

ListViewSettings.SnapUnit Property
[image]

Gets or sets the snap unit.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimeUnit SnapUnit { get; set; }
Visual Basic [image] Copy Code

Public Property SnapUnit As TimeUnit

Property Value

A member of the TimeUnit enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Use this property in a conjunction with the EnableSnapping property to specify the precision with which users can move and resize items interactively. If EnableSnapping is set to false the value of this property is ignored and items snap to cell borders.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
EnableSnapping Property
SnapUnitCount Property


MindFusion.Scheduling.Silverlight.ListViewSettings.SnapUnitCount Property

ListViewSettings.SnapUnitCount Property
[image]

Gets or sets the snap unit count.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int SnapUnitCount { get; set; }
Visual Basic [image] Copy Code

Public Property SnapUnitCount As Integer

Property Value

A positive integer value specifying the number of units from the associated SnapUnit to snap to.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
SnapUnit Property
EnableSnapping Property


MindFusion.Scheduling.Silverlight.ListViewSettings.SubHeaderDivisions Property

ListViewSettings.SubHeaderDivisions Property
[image]

Gets or sets the number of divisions in the sub-header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int SubHeaderDivisions { get; set; }
Visual Basic [image] Copy Code

Public Property SubHeaderDivisions As Integer

Property Value

An integer value specifying the number of cells in the subheader.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The value of this property is used only when the subheader of the List view is displayed (as specified by the HeaderStyle property). The value specifies the number of cells in the subheader. The date in each cell is calculated automatically and is displayed according to the SubTitleFormat property.

Example

The following example demonstrates how to setup a List view to display a week in each cell and the days of the week in the subheader. The example assumes that the variable calendar references an existing Calendar instance.

C# [image] Copy Code

calendar.CurrentView = CalendarView.List;
calendar.ListViewSettings.CellUnits = TimeUnit.Week;
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None;
calendar.ListViewSettings.TitleFormat = "dd, MMM";
calendar.ListViewSettings.Orientation = Orientation.Horizontal;
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader |
ListViewHeaderStyles.SubheaderPerCell | ListViewHeaderStyles.Title;
calendar.ListViewSettings.SubHeaderDivisions = 7;
calendar.ListViewSettings.SubTitleFormat = "w1";
Visual Basic [image] Copy Code

calendar.CurrentView = CalendarView.List
calendar.ListViewSettings.CellUnits = TimeUnit.Week
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None
calendar.ListViewSettings.TitleFormat = "dd, MMM"
calendar.ListViewSettings.Orientation = Orientation.Horizontal
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader Or _
ListViewHeaderStyles.SubheaderPerCell Or ListViewHeaderStyles.Title
calendar.ListViewSettings.SubHeaderDivisions = 7
calendar.ListViewSettings.SubTitleFormat = "w1"

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyles Property
SubHeaderSize Property
SubTitleFormat Property


MindFusion.Scheduling.Silverlight.ListViewSettings.SubHeaderSize Property

ListViewSettings.SubHeaderSize Property
[image]

Gets or sets the subheader size in pixels.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int SubHeaderSize { get; set; }
Visual Basic [image] Copy Code

Public Property SubHeaderSize As Integer

Property Value

A non-negative integer value specifying the subheader size.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property specifies the subheader width if Orientation is Horizontal or the height if Orientation is Vertical.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyles Property
SubHeaderDivisions Property
SubTitleFormat Property


MindFusion.Scheduling.Silverlight.ListViewSettings.SubHeaderStyle Property

ListViewSettings.SubHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view subheaders.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SubHeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SubHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of subheader elements. This property cannot be null (Nothing in Visual Basic).

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.ListViewSettings.SubTitleFormat Property

ListViewSettings.SubTitleFormat Property
[image]

Gets or sets a string used to format the cells subtitles.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string SubTitleFormat { get; set; }
Visual Basic [image] Copy Code

Public Property SubTitleFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic. Additionally, the "w1" format specifier can be used to display only the first letter of the day of the week (that is, 'M' for Monday, 'T' for Tuesday, and so on). This specifier cannot be combined with other specifiers, it can be used only by its own.

Example

The following example demonstrates how to setup a List view to display a week in each cell and the days of the week in the subheader. The example assumes that the variable calendar references an existing Calendar instance.

C# [image] Copy Code

calendar.CurrentView = CalendarView.List;
calendar.ListViewSettings.CellUnits = TimeUnit.Week;
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None;
calendar.ListViewSettings.TitleFormat = "dd, MMM";
calendar.ListViewSettings.Orientation = Orientation.Horizontal;
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader |
ListViewHeaderStyles.SubheaderPerCell | ListViewHeaderStyles.Title;
calendar.ListViewSettings.SubHeaderDivisions = 7;
calendar.ListViewSettings.SubTitleFormat = "w1";
Visual Basic [image] Copy Code

calendar.CurrentView = CalendarView.List
calendar.ListViewSettings.CellUnits = TimeUnit.Week
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None
calendar.ListViewSettings.TitleFormat = "dd, MMM"
calendar.ListViewSettings.Orientation = Orientation.Horizontal
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader Or _
ListViewHeaderStyles.SubheaderPerCell Or ListViewHeaderStyles.Title
calendar.ListViewSettings.SubHeaderDivisions = 7
calendar.ListViewSettings.SubTitleFormat = "w1"

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.TitleFormat Property

ListViewSettings.TitleFormat Property
[image]

Gets or sets a string used to format the cells titles.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }
Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.ListViewSettings.TotalLaneCount Property

ListViewSettings.TotalLaneCount Property
[image]

Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to true.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int TotalLaneCount { get; set; }
Visual Basic [image] Copy Code

Public Property TotalLaneCount As Integer

Property Value

A non-negative integer value specifying the number of lanes in the view.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

When this property is set to 0, the item scrollbar is automatically adjusted so that it covers all existing items. Otherwise the item scrollbar is adjusted so that it covers the specified number of lanes.

See Also

ListViewSettings Members
ListViewSettings Class
EnableVirtualItemSpace Property


MindFusion.Scheduling.Silverlight.ListViewSettings.VisibleCells Property

ListViewSettings.VisibleCells Property
[image]

Gets or sets the number of cells visible at the same time.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int VisibleCells { get; set; }
Visual Basic [image] Copy Code

Public Property VisibleCells As Integer

Property Value

A positive integer value specifying how many days to display simultaneously in the List view.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The value assigned to this property cannot be less than 1 or less than the total number of days available in the view, as specified in the NumberOfCells property.

See Also

ListViewSettings Members
ListViewSettings Class
NumberOfCells Property


MindFusion.Scheduling.Silverlight.ListViewSettings.VisibleColumns Property

ListViewSettings.VisibleColumns Property
[image]

Gets or sets the number of visible group columns in a list view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int VisibleColumns { get; set; }
Visual Basic [image] Copy Code

Public Property VisibleColumns As Integer

Property Value

A positive integer value specifying the number of columns visible at the same time.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property is actually used only in a grouped List view. Otherwise, the number of columns in the view is always 1.

See Also

ListViewSettings Members
ListViewSettings Class


MindFusion.Scheduling.Silverlight.MinuteFormat Enumeration

MinuteFormat Enumeration
[image]

Specifies how to format and display minutes in the Timetable view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum MinuteFormat
Visual Basic [image] Copy Code

Public Enumeration MinuteFormat

Members

Member name | Description
Colons | Display a colon and a leading zero.
LeadingZero | Display a leading zero for single digit minutes.
NoLeadingZero | No leading zero for single digit minutes.

See Also


MindFusion.Scheduling.Silverlight.MonthCellLayout Enumeration

MonthCellLayout Enumeration
[image]

Specifies the layout of the cells in a SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum MonthCellLayout
Visual Basic [image] Copy Code

Public Enumeration MonthCellLayout

Members

Member name | Description
Grid | Indicates that the cells are laid out in a grid, where each row in the grid contains the days of a single week.
Linear | Indicates that the cells are laid out in a single line.

See Also


MindFusion.Scheduling.Silverlight.MonthHeaderStyles Enumeration

MonthHeaderStyles Enumeration
[image]

Specifies the appearance and behavior of month headers in a SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum MonthHeaderStyles
Visual Basic [image] Copy Code

Public Enumeration MonthHeaderStyles

Members

Member name | Description
MonthButtons | Display buttons for scrolling to previous or next month.
None | Do not display the header.
SubheaderPerDay | The sub headers are drawn separately for each day, rather than for the whole interval.
Title | Display the date of the month in the header.
YearButtons | Display buttons for scrolling to previous or next year.

See Also


MindFusion.Scheduling.Silverlight.MonthRangeHeaderStyles Enumeration

MonthRangeHeaderStyles Enumeration
[image]

Specifies the appearance and behavior of the header in a MonthRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum MonthRangeHeaderStyles
Visual Basic [image] Copy Code

Public Enumeration MonthRangeHeaderStyles

Members

Member name | Description
Buttons | The header displays buttons that can be used to scroll to previous and following moths.
None | The header is not displayed.
Title | The header displays the start and end dates.

See Also


MindFusion.Scheduling.Silverlight.MonthRangeSettings Class

MonthRangeSettings Class
[image]

Defines settings for the years in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class MonthRangeSettings : CalendarSettings
Visual Basic [image] Copy Code

Public NotInheritable Class MonthRangeSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.MonthRangeSettings

See Also

MonthRangeSettings Members


MindFusion.Scheduling.Silverlight.MonthRangeSettings Members

MonthRangeSettings Members
Constructors Fields Properties
[image]

Defines settings for the years in the calendar.

The following tables list the members exposed by the MonthRangeSettings type.

Public Constructors

Name | Description
MonthRangeSettings | Initializes a new instance of the MonthRangeSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
EffectProperty | Identifies the Effect dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyles dependency property.
MonthSpacingProperty | Identifies the MonthSpacing dependency property.
MonthsPerRowProperty | Identifies the MonthsPerRow dependency property.
NumberOfMonthsProperty | Identifies the NumberOfMonths dependency property.
ScrollIntervalProperty | Identifies the ScrollInterval property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TitleSeparatorProperty | Identifies the TitleSeparator dependency property.
VisibleRowsProperty | Identifies the VisibleRows dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
Effect | Gets or sets the effect applied to view headers.
HeaderHeight | Gets or sets the height of the header in a MonthRange view.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the MonthRange view header.
MonthSpacing | Gets or sets the amount of space between adjacent months.
MonthsPerRow | Gets or sets the number of months to be displayed in a row.
NumberOfMonths | Gets or sets the number of months to display in the MonthRange view.
ScrollInterval | Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.
TitleFormat | Gets or sets the string used to format the month titles.
TitleSeparator | Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.
VisibleRows | Gets or sets the number of rows to display at the same time.

See Also

MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings Fields

MonthRangeSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
EffectProperty | Identifies the Effect dependency property.
HeaderHeightProperty | Identifies the HeaderHeight dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyles dependency property.
MonthSpacingProperty | Identifies the MonthSpacing dependency property.
MonthsPerRowProperty | Identifies the MonthsPerRow dependency property.
NumberOfMonthsProperty | Identifies the NumberOfMonths dependency property.
ScrollIntervalProperty | Identifies the ScrollInterval property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TitleSeparatorProperty | Identifies the TitleSeparator dependency property.
VisibleRowsProperty | Identifies the VisibleRows dependency property.

See Also

MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.CalendarStyleProperty Field

MonthRangeSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.EffectProperty Field

MonthRangeSettings.EffectProperty Field
[image]

Identifies the Effect dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EffectProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EffectProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.HeaderHeightProperty Field

MonthRangeSettings.HeaderHeightProperty Field
[image]

Identifies the HeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderHeightProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderHeightProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.HeaderStyleProperty Field

MonthRangeSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.HeaderStylesProperty Field

MonthRangeSettings.HeaderStylesProperty Field
[image]

Identifies the HeaderStyles dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStylesProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStylesProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.MonthSpacingProperty Field

MonthRangeSettings.MonthSpacingProperty Field
[image]

Identifies the MonthSpacing dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MonthSpacingProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MonthSpacingProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.MonthsPerRowProperty Field

MonthRangeSettings.MonthsPerRowProperty Field
[image]

Identifies the MonthsPerRow dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MonthsPerRowProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MonthsPerRowProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.NumberOfMonthsProperty Field

MonthRangeSettings.NumberOfMonthsProperty Field
[image]

Identifies the NumberOfMonths dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NumberOfMonthsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly NumberOfMonthsProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.ScrollIntervalProperty Field

MonthRangeSettings.ScrollIntervalProperty Field
[image]

Identifies the ScrollInterval property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollIntervalProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollIntervalProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.TitleFormatProperty Field

MonthRangeSettings.TitleFormatProperty Field
[image]

Identifies the TitleFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFormatProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.TitleSeparatorProperty Field

MonthRangeSettings.TitleSeparatorProperty Field
[image]

Identifies the TitleSeparator dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleSeparatorProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TitleSeparatorProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.VisibleRowsProperty Field

MonthRangeSettings.VisibleRowsProperty Field
[image]

Identifies the VisibleRows dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleRowsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleRowsProperty As DependencyProperty

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings Constructor

MonthRangeSettings Constructor
[image]

Initializes a new instance of the MonthRangeSettings class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public MonthRangeSettings ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings Properties

MonthRangeSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
Effect | Gets or sets the effect applied to view headers.
HeaderHeight | Gets or sets the height of the header in a MonthRange view.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the MonthRange view header.
MonthSpacing | Gets or sets the amount of space between adjacent months.
MonthsPerRow | Gets or sets the number of months to be displayed in a row.
NumberOfMonths | Gets or sets the number of months to display in the MonthRange view.
ScrollInterval | Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.
TitleFormat | Gets or sets the string used to format the month titles.
TitleSeparator | Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.
VisibleRows | Gets or sets the number of rows to display at the same time.

See Also

MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.CalendarStyle Property

MonthRangeSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the view elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.Effect Property

MonthRangeSettings.Effect Property
[image]

Gets or sets the effect applied to view headers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Effect Effect { get; set; }
Visual Basic [image] Copy Code

Public Property Effect As Effect

Property Value

A .NET Effect object.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.HeaderHeight Property

MonthRangeSettings.HeaderHeight Property
[image]

Gets or sets the height of the header in a MonthRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int HeaderHeight { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyle Property
TitleFormat Property
TitleSeparator Property


MindFusion.Scheduling.Silverlight.MonthRangeSettings.HeaderStyle Property

MonthRangeSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.HeaderStyles Property

MonthRangeSettings.HeaderStyles Property
[image]

Gets or sets the style of the MonthRange view header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public MonthRangeHeaderStyles HeaderStyles { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderStyles As MonthRangeHeaderStyles

Property Value

A member of the MonthRangeHeaderStyles enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderHeight Property
TitleFormat Property
TitleSeparator Property


MindFusion.Scheduling.Silverlight.MonthRangeSettings.MonthSpacing Property

MonthRangeSettings.MonthSpacing Property
[image]

Gets or sets the amount of space between adjacent months.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Thickness MonthSpacing { get; set; }
Visual Basic [image] Copy Code

Public Property MonthSpacing As Thickness

Property Value

A non-negative integer value specifying how many pixels there are between adjacent month cells.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
Margin Property


MindFusion.Scheduling.Silverlight.MonthRangeSettings.MonthsPerRow Property

MonthRangeSettings.MonthsPerRow Property
[image]

Gets or sets the number of months to be displayed in a row.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int MonthsPerRow { get; set; }
Visual Basic [image] Copy Code

Public Property MonthsPerRow As Integer

Property Value

An integer value specifying how many months are displayed in a row in the month range view. The allowed values range from 1 to 12.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If this value multiplied by VisibleRows is larger than NumberOfMonths, the calendar control displays scrollbars letting users scroll the view up and down.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
VisibleRows Property
NumberOfMonths Property


MindFusion.Scheduling.Silverlight.MonthRangeSettings.NumberOfMonths Property

MonthRangeSettings.NumberOfMonths Property
[image]

Gets or sets the number of months to display in the MonthRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int NumberOfMonths { get; set; }
Visual Basic [image] Copy Code

Public Property NumberOfMonths As Integer

Property Value

A positive integer value specifying how many months to display in the view.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If the number of months is set larger than number of rows multiplied by MonthsPerRow, the calendar displays scrollbar, letting users scroll the view up and down.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
VisibleRows Property
MonthsPerRow Property


MindFusion.Scheduling.Silverlight.MonthRangeSettings.ScrollInterval Property

MonthRangeSettings.ScrollInterval Property
[image]

Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ScrollInterval { get; set; }
Visual Basic [image] Copy Code

Public Property ScrollInterval As Integer

Property Value

A positive integer value specifying with how many months to scroll the view.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class


MindFusion.Scheduling.Silverlight.MonthRangeSettings.TitleFormat Property

MonthRangeSettings.TitleFormat Property
[image]

Gets or sets the string used to format the month titles.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }
Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
TitleSeparator Property


MindFusion.Scheduling.Silverlight.MonthRangeSettings.TitleSeparator Property

MonthRangeSettings.TitleSeparator Property
[image]

Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string TitleSeparator { get; set; }
Visual Basic [image] Copy Code

Public Property TitleSeparator As String

Property Value

A string containing the separator text.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format of the text displayed in the view's header is in the format "<FirstDate><TitleSeparator><LastDate>", where <FirstDate> and <LastDate> indicate the first and the last visible dates in the calendar, formatted according to the TitleFormat property. The <TitleSeparator> represents the value of this property. If TitleSeparator is set to an empty string, then the header's text is only "<FirstDate>". See the example below for more information.

Example

The following example shows how to display only the current year in the header of a MonthRange view. The sample assumes that calendar references an existing Calendar object.

C# [image] Copy Code

calendar.MonthRangeSettings.TitleFormat = "yyyy";
calendar.MonthRangeSettings.TitleSeparator = "";
Visual Basic [image] Copy Code

calendar.MonthRangeSettings.TitleFormat = "yyyy"
calendar.MonthRangeSettings.TitleSeparator = ""

See Also

MonthRangeSettings Members
MonthRangeSettings Class
TitleFormat Property


MindFusion.Scheduling.Silverlight.MonthRangeSettings.VisibleRows Property

MonthRangeSettings.VisibleRows Property
[image]

Gets or sets the number of rows to display at the same time.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int VisibleRows { get; set; }
Visual Basic [image] Copy Code

Public Property VisibleRows As Integer

Property Value

A positive integer value specifying how many rows of month cells to display.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
MonthsPerRow Property
NumberOfMonths Property


MindFusion.Scheduling.Silverlight.MonthSettings Class

MonthSettings Class
[image]

Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class MonthSettings : CalendarSettings
Visual Basic [image] Copy Code

Public NotInheritable Class MonthSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.MonthSettings

See Also

MonthSettings Members


MindFusion.Scheduling.Silverlight.MonthSettings Members

MonthSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.

The following tables list the members exposed by the MonthSettings type.

Public Constructors

Name | Description
MonthSettings | Initializes a new instance of the MonthSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellLayoutProperty | Identifies the CellLayout dependency property.
DayOfWeekFormatProperty | Identifies the DayOfWeekFormat dependency property.
EffectProperty | Identifies the Effect dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyle dependency property.
LeadingWeekCountProperty | Identifies the LeadingWeekCount dependency property.
MainHeaderHeightProperty | Identifies the MainHeaderHeight dependency property.
PaddingDaysHeaderStyleProperty | Identifies the PaddingDaysHeaderStyle dependency property.
PaddingDaysStyleProperty | Identifies the PaddingDaysStyle dependency property.
RotateWeekHeaderTextsProperty | Identifies the RotateWeekHeaderTexts dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowDayOfWeekProperty | Identifies the ShowDayOfWeek dependency property.
ShowPaddingDaysProperty | Identifies the ShowPaddingDays dependency property.
SubHeaderHeightProperty | Identifies the SubHeaderHeight dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TrailingWeekCountProperty | Identifies the TrailingWeekCount dependency property.
WeekHeaderFormatProperty | Identifies the WeekHeaderFormat dependency property.
WeekHeaderStyleProperty | Identifies the WeekHeaderStyle dependency property.
WeekNumbersHeaderWidthProperty | Identifies the WeekNumbersHeaderWidth dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellLayout | Gets or sets the layout of the cells in SingleMonth and MonthRange views.
DayOfWeekFormat | Gets or sets the format of the day names displayed in the week header.
DaySettings | Gets or sets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.
Effect | Gets or sets the effect applied to view headers.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the month's header.
LeadingWeekCount | Gets or sets the number of full weeks to display from the previous month.
MainHeaderHeight | Gets or sets the height of the main header in a month view.
PaddingDaysHeaderStyle | Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
PaddingDaysStyle | Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
RotateWeekHeaderTexts | Gets or sets a value indicating whether the week header texts should be rotated.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the month's header.
ShowPaddingDays | Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.
SubHeaderHeight | Gets or sets the height of the secondary header in a SingleMonth view.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TitleFormat | Gets or sets the string used to format the month's title.
TrailingWeekCount | Gets or sets the number of full weeks to display from the next month.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderStyle | Gets or sets the style of the week numbers header.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

See Also

MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings Fields

MonthSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellLayoutProperty | Identifies the CellLayout dependency property.
DayOfWeekFormatProperty | Identifies the DayOfWeekFormat dependency property.
EffectProperty | Identifies the Effect dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
HeaderStylesProperty | Identifies the HeaderStyle dependency property.
LeadingWeekCountProperty | Identifies the LeadingWeekCount dependency property.
MainHeaderHeightProperty | Identifies the MainHeaderHeight dependency property.
PaddingDaysHeaderStyleProperty | Identifies the PaddingDaysHeaderStyle dependency property.
PaddingDaysStyleProperty | Identifies the PaddingDaysStyle dependency property.
RotateWeekHeaderTextsProperty | Identifies the RotateWeekHeaderTexts dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowDayOfWeekProperty | Identifies the ShowDayOfWeek dependency property.
ShowPaddingDaysProperty | Identifies the ShowPaddingDays dependency property.
SubHeaderHeightProperty | Identifies the SubHeaderHeight dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TrailingWeekCountProperty | Identifies the TrailingWeekCount dependency property.
WeekHeaderFormatProperty | Identifies the WeekHeaderFormat dependency property.
WeekHeaderStyleProperty | Identifies the WeekHeaderStyle dependency property.
WeekNumbersHeaderWidthProperty | Identifies the WeekNumbersHeaderWidth dependency property.

See Also

MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.CalendarStyleProperty Field

MonthSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.CellLayoutProperty Field

MonthSettings.CellLayoutProperty Field
[image]

Identifies the CellLayout dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellLayoutProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellLayoutProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.DayOfWeekFormatProperty Field

MonthSettings.DayOfWeekFormatProperty Field
[image]

Identifies the DayOfWeekFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DayOfWeekFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly DayOfWeekFormatProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.EffectProperty Field

MonthSettings.EffectProperty Field
[image]

Identifies the Effect dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EffectProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EffectProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.HeaderStyleProperty Field

MonthSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.HeaderStylesProperty Field

MonthSettings.HeaderStylesProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStylesProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStylesProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.LeadingWeekCountProperty Field

MonthSettings.LeadingWeekCountProperty Field
[image]

Identifies the LeadingWeekCount dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LeadingWeekCountProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly LeadingWeekCountProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.MainHeaderHeightProperty Field

MonthSettings.MainHeaderHeightProperty Field
[image]

Identifies the MainHeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MainHeaderHeightProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MainHeaderHeightProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.PaddingDaysHeaderStyleProperty Field

MonthSettings.PaddingDaysHeaderStyleProperty Field
[image]

Identifies the PaddingDaysHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PaddingDaysHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingDaysHeaderStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.PaddingDaysStyleProperty Field

MonthSettings.PaddingDaysStyleProperty Field
[image]

Identifies the PaddingDaysStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PaddingDaysStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingDaysStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.RotateWeekHeaderTextsProperty Field

MonthSettings.RotateWeekHeaderTextsProperty Field
[image]

Identifies the RotateWeekHeaderTexts dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateWeekHeaderTextsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly RotateWeekHeaderTextsProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.SelectedElementsHeaderStyleProperty Field

MonthSettings.SelectedElementsHeaderStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsHeaderStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.SelectedElementsStyleProperty Field

MonthSettings.SelectedElementsStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.ShowDayOfWeekProperty Field

MonthSettings.ShowDayOfWeekProperty Field
[image]

Identifies the ShowDayOfWeek dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowDayOfWeekProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowDayOfWeekProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.ShowPaddingDaysProperty Field

MonthSettings.ShowPaddingDaysProperty Field
[image]

Identifies the ShowPaddingDays dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowPaddingDaysProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowPaddingDaysProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.SubHeaderHeightProperty Field

MonthSettings.SubHeaderHeightProperty Field
[image]

Identifies the SubHeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderHeightProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderHeightProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.SubHeaderStyleProperty Field

MonthSettings.SubHeaderStyleProperty Field
[image]

Identifies the SubHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.TitleFormatProperty Field

MonthSettings.TitleFormatProperty Field
[image]

Identifies the TitleFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFormatProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.TrailingWeekCountProperty Field

MonthSettings.TrailingWeekCountProperty Field
[image]

Identifies the TrailingWeekCount dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TrailingWeekCountProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TrailingWeekCountProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.WeekHeaderFormatProperty Field

MonthSettings.WeekHeaderFormatProperty Field
[image]

Identifies the WeekHeaderFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekHeaderFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly WeekHeaderFormatProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.WeekHeaderStyleProperty Field

MonthSettings.WeekHeaderStyleProperty Field
[image]

Identifies the WeekHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly WeekHeaderStyleProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.WeekNumbersHeaderWidthProperty Field

MonthSettings.WeekNumbersHeaderWidthProperty Field
[image]

Identifies the WeekNumbersHeaderWidth dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekNumbersHeaderWidthProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly WeekNumbersHeaderWidthProperty As DependencyProperty

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings Constructor

MonthSettings Constructor
[image]

Initializes a new instance of the MonthSettings class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public MonthSettings ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings Properties

MonthSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellLayout | Gets or sets the layout of the cells in SingleMonth and MonthRange views.
DayOfWeekFormat | Gets or sets the format of the day names displayed in the week header.
DaySettings | Gets or sets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.
Effect | Gets or sets the effect applied to view headers.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
HeaderStyles | Gets or sets the style of the month's header.
LeadingWeekCount | Gets or sets the number of full weeks to display from the previous month.
MainHeaderHeight | Gets or sets the height of the main header in a month view.
PaddingDaysHeaderStyle | Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
PaddingDaysStyle | Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
RotateWeekHeaderTexts | Gets or sets a value indicating whether the week header texts should be rotated.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the month's header.
ShowPaddingDays | Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.
SubHeaderHeight | Gets or sets the height of the secondary header in a SingleMonth view.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TitleFormat | Gets or sets the string used to format the month's title.
TrailingWeekCount | Gets or sets the number of full weeks to display from the next month.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderStyle | Gets or sets the style of the week numbers header.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

See Also

MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.CalendarStyle Property

MonthSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the view elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.MonthSettings.CellLayout Property

MonthSettings.CellLayout Property
[image]

Gets or sets the layout of the cells in SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public MonthCellLayout CellLayout { get; set; }
Visual Basic [image] Copy Code

Public Property CellLayout As MonthCellLayout

Property Value

A member of the MonthCellLayout enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.DayOfWeekFormat Property

MonthSettings.DayOfWeekFormat Property
[image]

Gets or sets the format of the day names displayed in the week header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DayOfWeekFormat DayOfWeekFormat { get; set; }
Visual Basic [image] Copy Code

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

A member of the DayOfWeekFormat enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.DaySettings Property

MonthSettings.DaySettings Property
[image]

Gets or sets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CellSettings DaySettings { get; set; }
Visual Basic [image] Copy Code

Public Property DaySettings As CellSettings

Property Value

An instance of the CellSettings class. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.Effect Property

MonthSettings.Effect Property
[image]

Gets or sets the effect applied to view headers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Effect Effect { get; set; }
Visual Basic [image] Copy Code

Public Property Effect As Effect

Property Value

A .NET Effect object.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.HeaderStyle Property

MonthSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.MonthSettings.HeaderStyles Property

MonthSettings.HeaderStyles Property
[image]

Gets or sets the style of the month's header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public MonthHeaderStyles HeaderStyles { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderStyles As MonthHeaderStyles

Property Value

A member of the MonthHeaderStyles enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.LeadingWeekCount Property

MonthSettings.LeadingWeekCount Property
[image]

Gets or sets the number of full weeks to display from the previous month.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int LeadingWeekCount { get; set; }
Visual Basic [image] Copy Code

Public Property LeadingWeekCount As Integer

Property Value

A non-negative integer value specifying the number of weeks to display before the first week of the selected month.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
TrailingWeekCount Property


MindFusion.Scheduling.Silverlight.MonthSettings.MainHeaderHeight Property

MonthSettings.MainHeaderHeight Property
[image]

Gets or sets the height of the main header in a month view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int MainHeaderHeight { get; set; }
Visual Basic [image] Copy Code

Public Property MainHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the main header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.PaddingDaysHeaderStyle Property

MonthSettings.PaddingDaysHeaderStyle Property
[image]

Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle PaddingDaysHeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property PaddingDaysHeaderStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Silverlight Namespace
PaddingDaysStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.MonthSettings.PaddingDaysStyle Property

MonthSettings.PaddingDaysStyle Property
[image]

Gets or sets the CalendarStyle object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle PaddingDaysStyle { get; set; }
Visual Basic [image] Copy Code

Public Property PaddingDaysStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Silverlight Namespace
PaddingDaysHeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.MonthSettings.RotateWeekHeaderTexts Property

MonthSettings.RotateWeekHeaderTexts Property
[image]

Gets or sets a value indicating whether the week header texts should be rotated.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool RotateWeekHeaderTexts { get; set; }
Visual Basic [image] Copy Code

Public Property RotateWeekHeaderTexts As Boolean

Property Value

true to rotate the texts in the week header; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.SelectedElementsHeaderStyle Property

MonthSettings.SelectedElementsHeaderStyle Property
[image]

Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsHeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SelectedElementsHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected header elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Silverlight Namespace
SelectedElementsStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.MonthSettings.SelectedElementsStyle Property

MonthSettings.SelectedElementsStyle Property
[image]

Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SelectedElementsStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Silverlight Namespace
SelectedElementsHeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.MonthSettings.ShowDayOfWeek Property

MonthSettings.ShowDayOfWeek Property
[image]

Gets or sets a value indicating whether the day names are displayed in the month's header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowDayOfWeek { get; set; }
Visual Basic [image] Copy Code

Public Property ShowDayOfWeek As Boolean

Property Value

true to display day names; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The day names are obtained from the DateTimeFormat property of the Calendar class, if it is not a null reference (Nothing in Visual Basic), or from the corresponding DateTimeFormat property of the .NET CultureInfo object assigned to calendar's Culture.

See Also

MonthSettings Members
MonthSettings Class
SubHeaderHeight Property


MindFusion.Scheduling.Silverlight.MonthSettings.ShowPaddingDays Property

MonthSettings.ShowPaddingDays Property
[image]

Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowPaddingDays { get; set; }
Visual Basic [image] Copy Code

Public Property ShowPaddingDays As Boolean

Property Value

true to display days from the previous and next months to fill up this month's grid; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Padding days are also displayed in the month range view for the first and the last months contained in the view.

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.SubHeaderHeight Property

MonthSettings.SubHeaderHeight Property
[image]

Gets or sets the height of the secondary header in a SingleMonth view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int SubHeaderHeight { get; set; }
Visual Basic [image] Copy Code

Public Property SubHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
ShowDayOfWeek Property


MindFusion.Scheduling.Silverlight.MonthSettings.SubHeaderStyle Property

MonthSettings.SubHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view subheaders.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SubHeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SubHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the subheader elements. This property cannot be null (Nothing in Visual Basic).

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.MonthSettings.TitleFormat Property

MonthSettings.TitleFormat Property
[image]

Gets or sets the string used to format the month's title.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }
Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.TrailingWeekCount Property

MonthSettings.TrailingWeekCount Property
[image]

Gets or sets the number of full weeks to display from the next month.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int TrailingWeekCount { get; set; }
Visual Basic [image] Copy Code

Public Property TrailingWeekCount As Integer

Property Value

A non-negative integer value specifying the number of weeks to display after the selected month.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
LeadingWeekCount Property


MindFusion.Scheduling.Silverlight.MonthSettings.WeekHeaderFormat Property

MonthSettings.WeekHeaderFormat Property
[image]

Gets or sets the format of the text displayed for each week in the week header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string WeekHeaderFormat { get; set; }
Visual Basic [image] Copy Code

Public Property WeekHeaderFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The string controls how to format the text displayed by week headers in a SingleMonth and MonthRange views. The value of this property can contain the following formatting specifiers among ordinary text in any number and order:

Specified | Description
%s[{format}] | The date of the first day in the corresponding week, formatted according to the standard date formatting string, specified by {format}. The brackets '{' and '}' should not be included.
%e[{format}] | The date of the last day in the corresponding week, formatted according to the standard date formatting string, specified by {format}. The brackets '{' and '}' should not be included.
%w | The number of the corresponding week relative to the current year.

Example

For example, the formatting string "(%w) %s[d ]-%e[d ], %s[MMM]" for the week 13.08-19.08 will yield the following result: "(33) 13-19, Aug". Pay attention to the space following 'd' in the format specification '[d ]'. If the space is missing, the format will be interpreted by the .NET framework as standard short date formatting.

See Also

MonthSettings Members
MonthSettings Class


MindFusion.Scheduling.Silverlight.MonthSettings.WeekHeaderStyle Property

MonthSettings.WeekHeaderStyle Property
[image]

Gets or sets the style of the week numbers header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public MonthWeekHeaderStyle WeekHeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property WeekHeaderStyle As MonthWeekHeaderStyle

Property Value

A member of the MonthWeekHeaderStyle enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
WeekNumbersHeaderWidth Property


MindFusion.Scheduling.Silverlight.MonthSettings.WeekNumbersHeaderWidth Property

MonthSettings.WeekNumbersHeaderWidth Property
[image]

Gets or sets the width of the header, which displays week numbers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int WeekNumbersHeaderWidth { get; set; }
Visual Basic [image] Copy Code

Public Property WeekNumbersHeaderWidth As Integer

Property Value

A non-negative integer value specifying the header width in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

MonthSettings Members
MonthSettings Class
WeekHeaderStyle Property


MindFusion.Scheduling.Silverlight.MonthWeekHeaderStyle Enumeration

MonthWeekHeaderStyle Enumeration
[image]

Specifies the placement of the week numbers header in a SingleMonth view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum MonthWeekHeaderStyle
Visual Basic [image] Copy Code

Public Enumeration MonthWeekHeaderStyle

Members

Member name | Description
Left | Display the header on the left side of the calendar.
None | Do not display a week numbers header.
Right | Display the header on the right side of the calendar.

See Also


MindFusion.Scheduling.Silverlight.Orientation Enumeration

Orientation Enumeration
[image]

Specifies horizontal or vertical orientation.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum Orientation
Visual Basic [image] Copy Code

Public Enumeration Orientation

Members

Member name | Description
Horizontal | Indicates a horizontal orientation.
Vertical | Indicates a vertical orientation.

See Also


MindFusion.Scheduling.Silverlight.Position Enumeration

Position Enumeration
[image]

Specifies the position of an element relative to its container.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum Position
Visual Basic [image] Copy Code

Public Enumeration Position

Members

Member name | Description
Bottom | The element is docked at the bottom side.
Left | The element is docked at the left side.
None | The element is not displayed.
Right | The element is docked at the right side.
Top | The element is docked at the top side.

See Also


MindFusion.Scheduling.Silverlight.RecurringItemConfirmEventArgs Class

RecurringItemConfirmEventArgs Class
[image]

Contains the arguments passed to handlers of the RecurringItemDeleting event.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class RecurringItemConfirmEventArgs : ItemEventArgs
Visual Basic [image] Copy Code

Public Class RecurringItemConfirmEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.Silverlight.RecurringItemConfirmEventArgs

See Also

RecurringItemConfirmEventArgs Members


MindFusion.Scheduling.Silverlight.RecurringItemConfirmEventArgs Members

RecurringItemConfirmEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the RecurringItemDeleting event.

The following tables list the members exposed by the RecurringItemConfirmEventArgs type.

Public Properties

Name | Description
ConfirmAll | Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.
ConfirmOccurrence | Gets or sets a value indicating whether the operation is allowed for the particular occurrence.

See Also

RecurringItemConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.RecurringItemConfirmEventArgs Properties

RecurringItemConfirmEventArgs Properties
[image]

Public Properties

Name | Description
ConfirmAll | Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.
ConfirmOccurrence | Gets or sets a value indicating whether the operation is allowed for the particular occurrence.

See Also

RecurringItemConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.RecurringItemConfirmEventArgs.ConfirmAll Property

RecurringItemConfirmEventArgs.ConfirmAll Property
[image]

Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ConfirmAll { get; set; }
Visual Basic [image] Copy Code

Public Property ConfirmAll As Boolean

Property Value

true to allow the operation for all occurrences of the recurring item.

See Also

RecurringItemConfirmEventArgs Members
RecurringItemConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.RecurringItemConfirmEventArgs.ConfirmOccurrence Property

RecurringItemConfirmEventArgs.ConfirmOccurrence Property
[image]

Gets or sets a value indicating whether the operation is allowed for the particular occurrence.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ConfirmOccurrence { get; set; }
Visual Basic [image] Copy Code

Public Property ConfirmOccurrence As Boolean

Property Value

true to allow the operation for the specified item's occurrence; otherwise, false.

See Also

RecurringItemConfirmEventArgs Members
RecurringItemConfirmEventArgs Class


MindFusion.Scheduling.Silverlight.ResizeBands Class

ResizeBands Class
Remarks See Also
[image]

Represents the resize and move bands of items in a Timetable and Resource views.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ResizeBands : ContentControl
Visual Basic [image] Copy Code

Public Class ResizeBands
Inherits ContentControl

Remarks

This is a utility class used in the presentation of items.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Scheduling.Silverlight.ResizeBands

See Also

ResizeBands Members


MindFusion.Scheduling.Silverlight.ResizeBands Members

ResizeBands Members
Constructors Fields Properties
[image]

Represents the resize and move bands of items in a Timetable and Resource views.

The following tables list the members exposed by the ResizeBands type.

Public Constructors

Name | Description
ResizeBands | Initializes a new instance of the ResizeBands class.

Public Fields

Name | Description
ItemSettingsProperty | Identifies the ItemSettings dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ResizeBandsVisibleProperty | Identifies the ResizeBandsVisible dependency property.

Public Properties

Name | Description
ItemSettings | Gets or sets a reference to the Calendar.ItemSettings object.
Orientation | Gets the orientation of the item the bands belong to.
ResizeBandsVisible | Gets a value indicating whether the bands should be displayed.

See Also

ResizeBands Class


MindFusion.Scheduling.Silverlight.ResizeBands Fields

ResizeBands Fields
[image]

Public Fields

Name | Description
ItemSettingsProperty | Identifies the ItemSettings dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ResizeBandsVisibleProperty | Identifies the ResizeBandsVisible dependency property.

See Also

ResizeBands Class


MindFusion.Scheduling.Silverlight.ResizeBands.ItemSettingsProperty Field

ResizeBands.ItemSettingsProperty Field
[image]

Identifies the ItemSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ItemSettingsProperty As DependencyProperty

See Also

ResizeBands Members
ResizeBands Class


MindFusion.Scheduling.Silverlight.ResizeBands.OrientationProperty Field

ResizeBands.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

ResizeBands Members
ResizeBands Class


MindFusion.Scheduling.Silverlight.ResizeBands.ResizeBandsVisibleProperty Field

ResizeBands.ResizeBandsVisibleProperty Field
[image]

Identifies the ResizeBandsVisible dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ResizeBandsVisibleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ResizeBandsVisibleProperty As DependencyProperty

See Also

ResizeBands Members
ResizeBands Class


MindFusion.Scheduling.Silverlight.ResizeBands Constructor

ResizeBands Constructor
[image]

Initializes a new instance of the ResizeBands class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResizeBands ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

ResizeBands Class


MindFusion.Scheduling.Silverlight.ResizeBands Properties

ResizeBands Properties
[image]

Public Properties

Name | Description
ItemSettings | Gets or sets a reference to the Calendar.ItemSettings object.
Orientation | Gets the orientation of the item the bands belong to.
ResizeBandsVisible | Gets a value indicating whether the bands should be displayed.

See Also

ResizeBands Class


MindFusion.Scheduling.Silverlight.ResizeBands.ItemSettings Property

ResizeBands.ItemSettings Property
[image]

Gets or sets a reference to the Calendar.ItemSettings object.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemSettings ItemSettings { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ItemSettings As ItemSettings

Property Value

An instance of the ItemSettings class.

Remarks

This is a convenience property enabling item templates to bind to the ItemSettings directly.

See Also

ResizeBands Members
ResizeBands Class


MindFusion.Scheduling.Silverlight.ResizeBands.Orientation Property

ResizeBands.Orientation Property
[image]

Gets the orientation of the item the bands belong to.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Orientation Orientation { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Orientation As Orientation

Property Value

A member of the Orientation enumeration.

See Also

ResizeBands Members
ResizeBands Class


MindFusion.Scheduling.Silverlight.ResizeBands.ResizeBandsVisible Property

ResizeBands.ResizeBandsVisible Property
[image]

Gets a value indicating whether the bands should be displayed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ResizeBandsVisible { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property ResizeBandsVisible As Boolean

Property Value

See Also

ResizeBands Members
ResizeBands Class


MindFusion.Scheduling.Silverlight.ResourceDateEventArgs Class

ResourceDateEventArgs Class
[image]

Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class ResourceDateEventArgs : DateEventArgs
Visual Basic [image] Copy Code

Public Class ResourceDateEventArgs
Inherits DateEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Silverlight.DateEventArgs
MindFusion.Scheduling.Silverlight.ResourceDateEventArgs

See Also

ResourceDateEventArgs Members


MindFusion.Scheduling.Silverlight.ResourceDateEventArgs Members

ResourceDateEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.

The following tables list the members exposed by the ResourceDateEventArgs type.

Public Properties

Name | Description
Resource | Gets the resource associated with the clicked cell.

Inherited Public Properties

Name | Description
Bounds | Gets the bounds of the cell. (Inherited from DateEventArgs.)
Date | Gets the date and time associated with the event. (Inherited from DateEventArgs.)
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise. (Inherited from DateEventArgs.)

See Also

ResourceDateEventArgs Class


MindFusion.Scheduling.Silverlight.ResourceDateEventArgs Properties

ResourceDateEventArgs Properties
[image]

Public Properties

Name | Description
Resource | Gets the resource associated with the clicked cell.

Inherited Public Properties

Name | Description
Bounds | Gets the bounds of the cell. (Inherited from DateEventArgs.)
Date | Gets the date and time associated with the event. (Inherited from DateEventArgs.)
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise. (Inherited from DateEventArgs.)

See Also

ResourceDateEventArgs Class


MindFusion.Scheduling.Silverlight.ResourceDateEventArgs.Resource Property

ResourceDateEventArgs.Resource Property
[image]

Gets the resource associated with the clicked cell.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Resource Resource { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

This is either null (Nothing in Visual Basic) or reference to a Resource, Contact, Location or Task object.

See Also

ResourceDateEventArgs Members
ResourceDateEventArgs Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings Class

ResourceViewSettings Class
Remarks See Also
[image]

Defines properties that allow customizing the visualization of the calendar in Resource view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class ResourceViewSettings : CalendarSettings
Visual Basic [image] Copy Code

Public NotInheritable Class ResourceViewSettings
Inherits CalendarSettings

Remarks

An instance of this class can be accessed through the ResourceViewSettings property of the Calendar class.

The settings for the timelines displayed in the Resource view are exposed through the BottomTimelineSettings, MiddleTimelineSettings and TopTimelineSettings properties. The BottomTimelineSettings are important because the resolution of the bottom timeline also determines the resolution of the view. For example, if the cells of the bottom timeline display one week intervals, the cells of the view display one week intervals as well.

The resource view supports two modes - general and lanes, according to the value of the ViewStyle property. In general mode, the size of the rows, corresponding to the individual resources displayed in the view, is fixed (as specified by RowSize). The colliding items are resized to fit within the available space. In lanes mode, the size of the resource rows is dynamic. When two or more items collide, each item is distributed in its own lane. The more items colliding, the more lanes are added to the resource row. The size of each individual lane is specified through the LaneSize property.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.ResourceViewSettings

See Also

ResourceViewSettings Members


MindFusion.Scheduling.Silverlight.ResourceViewSettings Members

ResourceViewSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of the calendar in Resource view.

The following tables list the members exposed by the ResourceViewSettings type.

Public Constructors

Name | Description
ResourceViewSettings | Initializes a new instance of the ResourceViewSettings class.

Public Fields

Name | Description
BottomTimelineSettingsProperty | Identifies the BottomTimelineSettings dependency property.
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSizeProperty | Identifies the CellSize dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
ExpandableRowsProperty | Identifies the ExpandableRows dependency property.
ExpandActiveItemOnProperty | Identifies the ExpandActiveItemOn dependency property.
GroupRowHeaderProperty | Identifies the GroupRowHeader dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
LaneSizeProperty | Identifies the LaneSize dependency property.
MiddleTimelineSettingsProperty | Identifies the MiddleTimelineSettings dependency property.
MinItemSizeProperty | Identifies the MinItemSize dependency property.
RowHeaderSizeProperty | Identifies the RowHeaderSize dependency property.
RowSizeProperty | Identifies the RowSize dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsStyle dependency property.
ShowPaddingProperty | Identifies the ShowPadding dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
TimelinesProperty | Identifies the Timelines dependency property.
TopTimelineSettingsProperty | Identifies the TopTimelineSettings dependency property.
ViewStyleProperty | Identifies the ViewStyle dependency property.
WeekendStyleProperty | Identifies the WeekendStyle dependency property.

Public Properties

Name | Description
BottomTimelineSettings | Gets the settings for the bottom timeline.
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of the unit cells.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
ExpandableRows | Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GroupRowHeader | Gets or sets a value indicating whether the rows display the header as a group header.
HeaderStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct header style assigned to them.
LaneSize | Gets or sets the size of a single lane.
MiddleTimelineSettings | Gets the settings for the middle timeline.
MinItemSize | Gets or sets the smallest size allowed for resource items.
RowHeaderSize | Gets or sets the size of the row header.
RowSize | Gets or sets the size of individual resource rows in when the view style is set to General.
SelectedElementsStyle | Gets or sets the style of the weekend cells.
ShowPadding | Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
Timelines | Gets or sets the number of timelines displayed in the view.
TopTimelineSettings | Gets the settings for the top timeline.
ViewStyle | Gets or sets the style of the view.
WeekendStyle | Gets or sets the style of the weekend cells.

See Also

ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings Fields

ResourceViewSettings Fields
[image]

Public Fields

Name | Description
BottomTimelineSettingsProperty | Identifies the BottomTimelineSettings dependency property.
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSizeProperty | Identifies the CellSize dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
ExpandableRowsProperty | Identifies the ExpandableRows dependency property.
ExpandActiveItemOnProperty | Identifies the ExpandActiveItemOn dependency property.
GroupRowHeaderProperty | Identifies the GroupRowHeader dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
LaneSizeProperty | Identifies the LaneSize dependency property.
MiddleTimelineSettingsProperty | Identifies the MiddleTimelineSettings dependency property.
MinItemSizeProperty | Identifies the MinItemSize dependency property.
RowHeaderSizeProperty | Identifies the RowHeaderSize dependency property.
RowSizeProperty | Identifies the RowSize dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsStyle dependency property.
ShowPaddingProperty | Identifies the ShowPadding dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
TimelinesProperty | Identifies the Timelines dependency property.
TopTimelineSettingsProperty | Identifies the TopTimelineSettings dependency property.
ViewStyleProperty | Identifies the ViewStyle dependency property.
WeekendStyleProperty | Identifies the WeekendStyle dependency property.

See Also

ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.BottomTimelineSettingsProperty Field

ResourceViewSettings.BottomTimelineSettingsProperty Field
[image]

Identifies the BottomTimelineSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BottomTimelineSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly BottomTimelineSettingsProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.CalendarStyleProperty Field

ResourceViewSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.CellSizeProperty Field

ResourceViewSettings.CellSizeProperty Field
[image]

Identifies the CellSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellSizeProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.CellStyleProperty Field

ResourceViewSettings.CellStyleProperty Field
[image]

Identifies the CellStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.EnableSnappingProperty Field

ResourceViewSettings.EnableSnappingProperty Field
[image]

Identifies the EnableSnapping dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableSnappingProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EnableSnappingProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.ExpandableRowsProperty Field

ResourceViewSettings.ExpandableRowsProperty Field
[image]

Identifies the ExpandableRows dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpandableRowsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandableRowsProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.ExpandActiveItemOnProperty Field

ResourceViewSettings.ExpandActiveItemOnProperty Field
[image]

Identifies the ExpandActiveItemOn dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpandActiveItemOnProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandActiveItemOnProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.GroupRowHeaderProperty Field

ResourceViewSettings.GroupRowHeaderProperty Field
[image]

Identifies the GroupRowHeader dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupRowHeaderProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly GroupRowHeaderProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.HeaderStyleProperty Field

ResourceViewSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.LaneSizeProperty Field

ResourceViewSettings.LaneSizeProperty Field
[image]

Identifies the LaneSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LaneSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly LaneSizeProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.MiddleTimelineSettingsProperty Field

ResourceViewSettings.MiddleTimelineSettingsProperty Field
[image]

Identifies the MiddleTimelineSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MiddleTimelineSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MiddleTimelineSettingsProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.MinItemSizeProperty Field

ResourceViewSettings.MinItemSizeProperty Field
[image]

Identifies the MinItemSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinItemSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MinItemSizeProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.RowHeaderSizeProperty Field

ResourceViewSettings.RowHeaderSizeProperty Field
[image]

Identifies the RowHeaderSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RowHeaderSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly RowHeaderSizeProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.RowSizeProperty Field

ResourceViewSettings.RowSizeProperty Field
[image]

Identifies the RowSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RowSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly RowSizeProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.SelectedElementsStyleProperty Field

ResourceViewSettings.SelectedElementsStyleProperty Field
[image]

Identifies the SelectedElementsStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.ShowPaddingProperty Field

ResourceViewSettings.ShowPaddingProperty Field
[image]

Identifies the ShowPadding dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowPaddingProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowPaddingProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.SnapUnitCountProperty Field

ResourceViewSettings.SnapUnitCountProperty Field
[image]

Identifies the SnapUnitCount dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitCountProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitCountProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.SnapUnitProperty Field

ResourceViewSettings.SnapUnitProperty Field
[image]

Identifies the SnapUnit dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.TimelinesProperty Field

ResourceViewSettings.TimelinesProperty Field
[image]

Identifies the Timelines dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelinesProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TimelinesProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.TopTimelineSettingsProperty Field

ResourceViewSettings.TopTimelineSettingsProperty Field
[image]

Identifies the TopTimelineSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopTimelineSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TopTimelineSettingsProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.ViewStyleProperty Field

ResourceViewSettings.ViewStyleProperty Field
[image]

Identifies the ViewStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ViewStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ViewStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.WeekendStyleProperty Field

ResourceViewSettings.WeekendStyleProperty Field
[image]

Identifies the WeekendStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WeekendStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly WeekendStyleProperty As DependencyProperty

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings Constructor

ResourceViewSettings Constructor
[image]

Initializes a new instance of the ResourceViewSettings class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceViewSettings ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings Properties

ResourceViewSettings Properties
[image]

Public Properties

Name | Description
BottomTimelineSettings | Gets the settings for the bottom timeline.
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of the unit cells.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
ExpandableRows | Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GroupRowHeader | Gets or sets a value indicating whether the rows display the header as a group header.
HeaderStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct header style assigned to them.
LaneSize | Gets or sets the size of a single lane.
MiddleTimelineSettings | Gets the settings for the middle timeline.
MinItemSize | Gets or sets the smallest size allowed for resource items.
RowHeaderSize | Gets or sets the size of the row header.
RowSize | Gets or sets the size of individual resource rows in when the view style is set to General.
SelectedElementsStyle | Gets or sets the style of the weekend cells.
ShowPadding | Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
Timelines | Gets or sets the number of timelines displayed in the view.
TopTimelineSettings | Gets the settings for the top timeline.
ViewStyle | Gets or sets the style of the view.
WeekendStyle | Gets or sets the style of the weekend cells.

See Also

ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.BottomTimelineSettings Property

ResourceViewSettings.BottomTimelineSettings Property
[image]

Gets the settings for the bottom timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimelineSettings BottomTimelineSettings { get; set; }
Visual Basic [image] Copy Code

Public Property BottomTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
MiddleTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.Silverlight.ResourceViewSettings.CalendarStyle Property

ResourceViewSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.CellSize Property

ResourceViewSettings.CellSize Property
[image]

Gets or sets the size of time cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int CellSize { get; set; }
Visual Basic [image] Copy Code

Public Property CellSize As Integer

Property Value

An integer value specifying the size of the cells, in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.CellStyle Property

ResourceViewSettings.CellStyle Property
[image]

Gets or sets the style of the unit cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CellStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CellStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
WeekendStyle Property


MindFusion.Scheduling.Silverlight.ResourceViewSettings.EnableSnapping Property

ResourceViewSettings.EnableSnapping Property
[image]

Gets or sets a value indicating whether custom snapping is enabled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool EnableSnapping { get; set; }
Visual Basic [image] Copy Code

Public Property EnableSnapping As Boolean

Property Value

true, to enable custom snapping; otherwise false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If custom snapping is disabled, interactions with the items will automatically align the items to the cells of the view. If custom snapping is enabled, the items are aligned to a virtual grid defined by the SnapUnit and SnapUnitCount properties.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
SnapUnit Property
SnapUnitCount Property


MindFusion.Scheduling.Silverlight.ResourceViewSettings.ExpandableRows Property

ResourceViewSettings.ExpandableRows Property
[image]

Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ExpandableRows { get; set; }
Visual Basic [image] Copy Code

Public Property ExpandableRows As Boolean

Property Value

true, to display expand/collapse icons in the headers of resource rows; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property is only used if the view style is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.ExpandActiveItemOn Property

ResourceViewSettings.ExpandActiveItemOn Property
[image]

Gets or sets whether the active item should ignore collisions.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemAction ExpandActiveItemOn { get; set; }
Visual Basic [image] Copy Code

Public Property ExpandActiveItemOn As ItemAction

Property Value

A member of the ItemAction enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This only works if the ViewStyle is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.GroupRowHeader Property

ResourceViewSettings.GroupRowHeader Property
[image]

Gets or sets a value indicating whether the rows display the header as a group header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool GroupRowHeader { get; set; }
Visual Basic [image] Copy Code

Public Property GroupRowHeader As Boolean

Property Value

true, to display row headers to the left of the rows; false, to display row headers above the rows.

Remarks

This property is only used if the view style is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.HeaderStyle Property

ResourceViewSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct header style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
CalendarStyle Property


MindFusion.Scheduling.Silverlight.ResourceViewSettings.LaneSize Property

ResourceViewSettings.LaneSize Property
[image]

Gets or sets the size of a single lane.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int LaneSize { get; set; }
Visual Basic [image] Copy Code

Public Property LaneSize As Integer

Property Value

An integer value specifying the size of the lanes, in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property is only used when the ViewStyle is set to Lanes. Otherwise the size of the resource rows can be adjusted through the RowSize property.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
RowSize Property


MindFusion.Scheduling.Silverlight.ResourceViewSettings.MiddleTimelineSettings Property

ResourceViewSettings.MiddleTimelineSettings Property
[image]

Gets the settings for the middle timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimelineSettings MiddleTimelineSettings { get; set; }
Visual Basic [image] Copy Code

Public Property MiddleTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
BottomTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.Silverlight.ResourceViewSettings.MinItemSize Property

ResourceViewSettings.MinItemSize Property
[image]

Gets or sets the smallest size allowed for resource items.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int MinItemSize { get; set; }
Visual Basic [image] Copy Code

Public Property MinItemSize As Integer

Property Value

An integer value specifying the minimum item size, in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If there is not enough space in a row to display all related items, the items that do not fit remain invisible. This property is only used if the view style is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.RowHeaderSize Property

ResourceViewSettings.RowHeaderSize Property
[image]

Gets or sets the size of the row header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int RowHeaderSize { get; set; }
Visual Basic [image] Copy Code

Public Property RowHeaderSize As Integer

Property Value

An integer value specifying the size of the row headers, in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The size of a header is used only when GroupRowHeader is enabled. Otherwise, the size of the header equals LaneSize.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.RowSize Property

ResourceViewSettings.RowSize Property
[image]

Gets or sets the size of individual resource rows in when the view style is set to General.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int RowSize { get; set; }
Visual Basic [image] Copy Code

Public Property RowSize As Integer

Property Value

An integer value specifying the size of the resource rows, in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property is ignored if the view style is set to Lanes. In this case the size of the rows is dynamically determined by the number of their lanes multiplied by the LaneSize.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.SelectedElementsStyle Property

ResourceViewSettings.SelectedElementsStyle Property
[image]

Gets or sets the style of the weekend cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SelectedElementsStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.ShowPadding Property

ResourceViewSettings.ShowPadding Property
[image]

Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowPadding { get; set; }
Visual Basic [image] Copy Code

Public Property ShowPadding As Boolean

Property Value

true, to visually expand the items so that they are aligned to nearest cells; otherwise, false.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.SnapUnit Property

ResourceViewSettings.SnapUnit Property
[image]

Gets or sets the snap unit.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimeUnit SnapUnit { get; set; }
Visual Basic [image] Copy Code

Public Property SnapUnit As TimeUnit

Property Value

A member of the TimeUnit enumeration.

Remarks

This property works in conjunction with SnapUnitCount when EnableSnapping is set to true. These properties specify a virtual grid to which the items are aligned when modified interactively. If custom snapping is disabled, the items are aligned to the cells of the view.

To completely disable snapping, specify custom snapping with very small resolution - for example, one second.

Example

The following example disables snapping:

C# [image] Copy Code

calendar.ResourceViewSettings.EnableSnapping = true;
calendar.ResourceViewSettings.SnapUnit = TimeUnit.Second;
calendar.ResourceViewSettings.SnapUnitCount = 1;
Visual Basic [image] Copy Code

calendar.ResourceViewSettings.EnableSnapping = True
calendar.ResourceViewSettings.SnapUnit = TimeUnit.Second
calendar.ResourceViewSettings.SnapUnitCount = 1

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
SnapUnitCount Property
EnableSnapping Property


MindFusion.Scheduling.Silverlight.ResourceViewSettings.SnapUnitCount Property

ResourceViewSettings.SnapUnitCount Property
[image]

Gets or sets the snap unit count.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int SnapUnitCount { get; set; }
Visual Basic [image] Copy Code

Public Property SnapUnitCount As Integer

Property Value

An integer value specifying the number of units.

Remarks

This property works in conjunction with SnapUnit when EnableSnapping is set to true. These properties specify a virtual grid to which the items are aligned when modified interactively. If custom snapping is disabled, the items are aligned to the cells of the view.

To completely disable snapping, specify custom snapping with very small resolution - for example, one second.

Example

The following example disables snapping:

C# [image] Copy Code

calendar.ResourceViewSettings.EnableSnapping = true;
calendar.ResourceViewSettings.SnapUnit = TimeUnit.Second;
calendar.ResourceViewSettings.SnapUnitCount = 1;
Visual Basic [image] Copy Code

calendar.ResourceViewSettings.EnableSnapping = True
calendar.ResourceViewSettings.SnapUnit = TimeUnit.Second
calendar.ResourceViewSettings.SnapUnitCount = 1

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
SnapUnit Property
EnableSnapping Property


MindFusion.Scheduling.Silverlight.ResourceViewSettings.Timelines Property

ResourceViewSettings.Timelines Property
[image]

Gets or sets the number of timelines displayed in the view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int Timelines { get; set; }
Visual Basic [image] Copy Code

Public Property Timelines As Integer

Property Value

An integer value specifying the number of timelines.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The timelines are displayed from bottom to top. A value of 1 displays only the bottom timeline, a value of 2 displays the bottom and middle timelines and a value of 3 displays all three timelines.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
BottomTimelineSettings Property
MiddleTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.Silverlight.ResourceViewSettings.TopTimelineSettings Property

ResourceViewSettings.TopTimelineSettings Property
[image]

Gets the settings for the top timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimelineSettings TopTimelineSettings { get; set; }
Visual Basic [image] Copy Code

Public Property TopTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Silverlight Namespace
BottomTimelineSettings Property
MiddleTimelineSettings Property


MindFusion.Scheduling.Silverlight.ResourceViewSettings.ViewStyle Property

ResourceViewSettings.ViewStyle Property
[image]

Gets or sets the style of the view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ResourceViewStyle ViewStyle { get; set; }
Visual Basic [image] Copy Code

Public Property ViewStyle As ResourceViewStyle

Property Value

A member of the ResourceViewStyle enumeration.

Remarks

The resource view supports two modes - general and lanes, according to the value of the ViewStyle property. In general mode, the size of the rows, corresponding to the individual resources displayed in the view, is fixed (as specified by RowSize). The colliding items are resized to fit within the available space. In lanes mode, the size of the resource rows is dynamic. When two or more items collide, each item is distributed in its own lane. The more items colliding, the more lanes are added to the resource row. The size of each individual lane is specified through the LaneSize property.

See Also

ResourceViewSettings Members
ResourceViewSettings Class


MindFusion.Scheduling.Silverlight.ResourceViewSettings.WeekendStyle Property

ResourceViewSettings.WeekendStyle Property
[image]

Gets or sets the style of the weekend cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle WeekendStyle { get; set; }
Visual Basic [image] Copy Code

Public Property WeekendStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
CellStyle Property


MindFusion.Scheduling.Silverlight.ResourceViewStyle Enumeration

ResourceViewStyle Enumeration
[image]

Specifies the style of a Resource view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum ResourceViewStyle
Visual Basic [image] Copy Code

Public Enumeration ResourceViewStyle

Members

Member name | Description
General | Each row in a Resource view has a fixed width. The items within the row are positioned much like in a Timetable view.
Lanes | Each row in a Resource view displays one or more lanes where items are positioned. More lanes are added automatically to respect the requirement that all overlapping items are on separate lanes.

Remarks

A value of this enumeration is assigned to the ViewStyle property of the ResourceViewSettings class.

See Also


MindFusion.Scheduling.Silverlight.Selection Class

Selection Class
[image]

Represents a set of selected date cells and defines a visualization style applied to the selected elements.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class Selection : DependencyObject
Visual Basic [image] Copy Code

Public NotInheritable Class Selection
Inherits DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
MindFusion.Scheduling.Silverlight.Selection

See Also

Selection Members


MindFusion.Scheduling.Silverlight.Selection Members

Selection Members
Constructors Fields Properties Methods Events
[image]

Represents a set of selected date cells and defines a visualization style applied to the selected elements.

The following tables list the members exposed by the Selection type.

Public Constructors

Name | Description
Selection | Initializes a new instance of the Selection class.

Public Fields

Name | Description
AllowMultipleProperty | Identifies the AllowMultiple dependency property.
ContinuousProperty | Identifies the Continuous dependency property.

Public Properties

Name | Description
AllowMultiple | Gets or sets a value indicating whether users are allowed to select multiple elements at a time.
Contact | Gets the contact related to the current selection.
Continuous | Gets or sets a value indicating whether users can select only one range of dates in the calendar.
IsEmpty | Gets a value indicating whether this selection is empty.
Location | Gets the location related to the current selection.
Ranges | Gets a read-only collection of DateTime objects, sorted chronologically. Each pair in the collection represents a selected time range.
Resource | Gets the resource related to the current selection.
Task | Gets the task related to the current selection.

Public Methods

Name | Description
Add | Overloaded. Adds the specified date or range of dates to the selection.
Contains | Determines whether the specified date is currently selected.
Intersects | Determines whether the specified range is partially contained within one of the date ranges.
Remove | Overloaded. Removes the specified date or range of dates from the selection.
Reset | Clears the selection.
Set | Overloaded. Sets the current selection to the specified date or range of dates.

Protected Methods

Name | Description
CreateInstanceCore | Freezable.CreateInstanceCore override.

Public Events

Name | Description
Changed | Fired when the selection has changed;

See Also

Selection Class


MindFusion.Scheduling.Silverlight.Selection Fields

Selection Fields
[image]

Public Fields

Name | Description
AllowMultipleProperty | Identifies the AllowMultiple dependency property.
ContinuousProperty | Identifies the Continuous dependency property.

See Also

Selection Class


MindFusion.Scheduling.Silverlight.Selection.AllowMultipleProperty Field

Selection.AllowMultipleProperty Field
[image]

Identifies the AllowMultiple dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty AllowMultipleProperty
Visual Basic [image] Copy Code

Public Shared AllowMultipleProperty As DependencyProperty

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.ContinuousProperty Field

Selection.ContinuousProperty Field
[image]

Identifies the Continuous dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static DependencyProperty ContinuousProperty
Visual Basic [image] Copy Code

Public Shared ContinuousProperty As DependencyProperty

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection Constructor

Selection Constructor
[image]

Initializes a new instance of the Selection class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Selection ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

Selection Class


MindFusion.Scheduling.Silverlight.Selection Methods

Selection Methods
[image]

Public Methods

Name | Description
Add | Overloaded. Adds the specified date or range of dates to the selection.
Contains | Determines whether the specified date is currently selected.
Intersects | Determines whether the specified range is partially contained within one of the date ranges.
Remove | Overloaded. Removes the specified date or range of dates from the selection.
Reset | Clears the selection.
Set | Overloaded. Sets the current selection to the specified date or range of dates.

Protected Methods

Name | Description
CreateInstanceCore | Freezable.CreateInstanceCore override.

See Also

Selection Class


MindFusion.Scheduling.Silverlight.Selection.Add Method

Selection.Add Method
[image]

Adds the specified date or range of dates to the selection.

Overload List

Name | Description
Selection.Add (DateTime) | Adds the specified date to the selection.
Selection.Add (DateTime, DateTime) | Adds the specified date range to the selection.
Selection.Add (DateTime, DateTime, Contact, Resource, Location, Task) | Adds the specified date range to the selection of the specified resource.

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Add Method (DateTime)

Selection.Add Method (DateTime)
See Also
[image]

Adds the specified date to the selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Add (
DateTime date
)
Visual Basic [image] Copy Code

Public Sub Add ( _
date As DateTime _
)

Parameters

date
The date to be added to the selection.

See Also

Add Method Overload List
Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Add Method (DateTime, DateTime)

Selection.Add Method (DateTime, DateTime)
See Also
[image]

Adds the specified date range to the selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Add (
DateTime start,
DateTime end
)
Visual Basic [image] Copy Code

Public Sub Add ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
The start of the time range to be added to the selection.
end
The end of the time range to be added to the selection.

See Also

Add Method Overload List
Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Add Method (DateTime, DateTime, Contact, Resource, Location, Task)

Selection.Add Method (DateTime, DateTime, Contact, Resource, Location, Task)
See Also
[image]

Adds the specified date range to the selection of the specified resource.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Add (
DateTime start,
DateTime end,
Contact contact,
Resource resource,
Location location,
Task task
)
Visual Basic [image] Copy Code

Public Sub Add ( _
start As DateTime, _
end As DateTime, _
contact As Contact, _
resource As Resource, _
location As Location, _
task As Task _
)

Parameters

start
The start of the time range to be added to the selection.
end
The end of the time range to be added to the selection.
contact
A reference to a Contact to associate the selection with.
resource
A reference to a Resource to associate the selection with.
location
A reference to a Location to associate the selection with.
task
A reference to a Task to associate the selection with.

Remarks

Either all of the parameters contact, resource, location and task must be set to null (Nothing in Visual Basic) or only one of them should be a non-null reference.

See Also

Add Method Overload List
Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Contains Method

Selection.Contains Method
[image]

Determines whether the specified date is currently selected.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool Contains (
DateTime date
)
Visual Basic [image] Copy Code

Public Function Contains ( _
date As DateTime _
) As Boolean

Parameters

date
A date to search for in the selection.

Return Value

true if the date's cell is selected; otherwise false.

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.CreateInstanceCore Method

Selection.CreateInstanceCore Method
[image]

Freezable.CreateInstanceCore override.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

protected virtual Freezable CreateInstanceCore ()
Visual Basic [image] Copy Code

Protected Overridable Function CreateInstanceCore () As Freezable

Return Value

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Intersects Method

Selection.Intersects Method
[image]

Determines whether the specified range is partially contained within one of the date ranges.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool Intersects (
DateTime start,
DateTime end
)
Visual Basic [image] Copy Code

Public Function Intersects ( _
start As DateTime, _
end As DateTime _
) As Boolean

Parameters

start
The start date of the interval to check.
end
The end date of the interval to check.

Return Value

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Remove Method

Selection.Remove Method
[image]

Removes the specified date or range of dates from the selection.

Overload List

Name | Description
Selection.Remove (DateTime) | Removes the specified date from the selection.
Selection.Remove (DateTime, DateTime) | Removes the specified date range from the selection.

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Remove Method (DateTime)

Selection.Remove Method (DateTime)
See Also
[image]

Removes the specified date from the selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Remove (
DateTime date
)
Visual Basic [image] Copy Code

Public Sub Remove ( _
date As DateTime _
)

Parameters

date
The date to be removed from the selection.

See Also

Remove Method Overload List
Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Remove Method (DateTime, DateTime)

Selection.Remove Method (DateTime, DateTime)
See Also
[image]

Removes the specified date range from the selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Remove (
DateTime start,
DateTime end
)
Visual Basic [image] Copy Code

Public Sub Remove ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
The start of the time range to be removed from the selection.
end
The end of the time range to be removed from the selection.

See Also

Remove Method Overload List
Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Reset Method

Selection.Reset Method
[image]

Clears the selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Reset ()
Visual Basic [image] Copy Code

Public Sub Reset ()

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Set Method

Selection.Set Method
[image]

Sets the current selection to the specified date or range of dates.

Overload List

Name | Description
Selection.Set (DateTime) | Selects the specified date cell.
Selection.Set (DateTime, DateTime) | Selects a range of date cells.
Selection.Set (DateTime, DateTime, Contact, Resource, Location, Task) | Selects a range of date cells for a specified resource.

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Set Method (DateTime)

Selection.Set Method (DateTime)
See Also
[image]

Selects the specified date cell.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Set (
DateTime date
)
Visual Basic [image] Copy Code

Public Sub Set ( _
date As DateTime _
)

Parameters

date
A date whose calendar cell to select.

See Also

Set Method Overload List
Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Set Method (DateTime, DateTime)

Selection.Set Method (DateTime, DateTime)
See Also
[image]

Selects a range of date cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Set (
DateTime start,
DateTime end
)
Visual Basic [image] Copy Code

Public Sub Set ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
Specifies the first date in the range.
end
Specifies the last date in the range.

See Also

Set Method Overload List
Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Set Method (DateTime, DateTime, Contact, Resource, Location, Task)

Selection.Set Method (DateTime, DateTime, Contact, Resource, Location, Task)
See Also
[image]

Selects a range of date cells for a specified resource.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public void Set (
DateTime start,
DateTime end,
Contact contact,
Resource resource,
Location location,
Task task
)
Visual Basic [image] Copy Code

Public Sub Set ( _
start As DateTime, _
end As DateTime, _
contact As Contact, _
resource As Resource, _
location As Location, _
task As Task _
)

Parameters

start
Specifies the first date in the range.
end
Specifies the last date in the range.
contact
A reference to a Contact to associate the selection with.
resource
A reference to a Resource to associate the selection with.
location
A reference to a Location to associate the selection with.
task
A reference to a Task to associate the selection with.

Remarks

Either all of the parameters contact, resource, location and task must be set to null (Nothing in Visual Basic) or only one of them should be a non-null reference.

See Also

Set Method Overload List
Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection Properties

Selection Properties
[image]

Public Properties

Name | Description
AllowMultiple | Gets or sets a value indicating whether users are allowed to select multiple elements at a time.
Contact | Gets the contact related to the current selection.
Continuous | Gets or sets a value indicating whether users can select only one range of dates in the calendar.
IsEmpty | Gets a value indicating whether this selection is empty.
Location | Gets the location related to the current selection.
Ranges | Gets a read-only collection of DateTime objects, sorted chronologically. Each pair in the collection represents a selected time range.
Resource | Gets the resource related to the current selection.
Task | Gets the task related to the current selection.

See Also

Selection Class


MindFusion.Scheduling.Silverlight.Selection.AllowMultiple Property

Selection.AllowMultiple Property
[image]

Gets or sets a value indicating whether users are allowed to select multiple elements at a time.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool AllowMultiple { get; set; }
Visual Basic [image] Copy Code

Public Property AllowMultiple As Boolean

Property Value

true to allow multiple selection; otherwise, false.

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Contact Property

Selection.Contact Property
[image]

Gets the contact related to the current selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Contact Contact { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Contact As Contact

Property Value

The contact related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a contact.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Silverlight Namespace
Location Property
Resource Property
Task Property


MindFusion.Scheduling.Silverlight.Selection.Continuous Property

Selection.Continuous Property
[image]

Gets or sets a value indicating whether users can select only one range of dates in the calendar.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool Continuous { get; set; }
Visual Basic [image] Copy Code

Public Property Continuous As Boolean

Property Value

true to prevent users from selecting more than one, continuous range of dates in the control; otherwise, false.

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.IsEmpty Property

Selection.IsEmpty Property
[image]

Gets a value indicating whether this selection is empty.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if there are selected calendar cells; otherwise, false.

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Location Property

Selection.Location Property
[image]

Gets the location related to the current selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Location Location { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Location As Location

Property Value

The location related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a location.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Silverlight Namespace
Contact Property
Resource Property
Task Property


MindFusion.Scheduling.Silverlight.Selection.Ranges Property

Selection.Ranges Property
[image]

Gets a read-only collection of DateTime objects, sorted chronologically. Each pair in the collection represents a selected time range.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public IList<DateTime> Ranges { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Ranges As IList(Of DateTime)

Property Value

An instance of an IList class containing even number of DateTime objects.

Remarks

Any attempt to modify the returned list will result in a NotSupportedException exception. If you want to add or remove time intervals from the selection, use the Add, Set and Remove methods respectively.

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.Selection.Resource Property

Selection.Resource Property
[image]

Gets the resource related to the current selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Resource Resource { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Resource As Resource

Property Value

The resource related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Silverlight Namespace
Contact Property
Location Property
Task Property


MindFusion.Scheduling.Silverlight.Selection.Task Property

Selection.Task Property
[image]

Gets the task related to the current selection.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Task Task { get; }
Visual Basic [image] Copy Code

Public ReadOnly Property Task As Task

Property Value

The task related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a task.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Silverlight Namespace
Contact Property
Location Property
Resource Property


MindFusion.Scheduling.Silverlight.Selection Events

Selection Events
[image]

Public Events

Name | Description
Changed | Fired when the selection has changed;

See Also

Selection Class


MindFusion.Scheduling.Silverlight.Selection.Changed Event

Selection.Changed Event
[image]

Fired when the selection has changed;

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler Changed
Visual Basic [image] Copy Code

Public Event Changed As EventHandler

See Also

Selection Members
Selection Class


MindFusion.Scheduling.Silverlight.SideBorders Class

SideBorders Class
Remarks See Also
[image]

Represents a four-sided border, similar to the Border class, but with the ability to draw each side in a separate color.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class SideBorders : ContentControl
Visual Basic [image] Copy Code

Public Class SideBorders
Inherits ContentControl

Remarks

This is a utility class used in the presentation of items.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
MindFusion.Scheduling.Silverlight.SideBorders

See Also

SideBorders Members


MindFusion.Scheduling.Silverlight.SideBorders Members

SideBorders Members
Constructors
[image]

Represents a four-sided border, similar to the Border class, but with the ability to draw each side in a separate color.

The following tables list the members exposed by the SideBorders type.

Public Constructors

Name | Description
SideBorders | Initializes a new instance of the SideBorders class.

See Also

SideBorders Class


MindFusion.Scheduling.Silverlight.SideBorders Constructor

SideBorders Constructor
[image]

Initializes a new instance of the SideBorders class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public SideBorders ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

SideBorders Class


MindFusion.Scheduling.Silverlight.ThemeType Enumeration

ThemeType Enumeration
[image]

Specifies a calendar theme.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum ThemeType
Visual Basic [image] Copy Code

Public Enumeration ThemeType

Members

Member name | Description
Lila | The Lila theme.
Silver | The Silver theme.
Standard | The standard theme.
Vista | The Vista theme.
Windows2003 | The Windows 2003 standard theme.

See Also


MindFusion.Scheduling.Silverlight.TimelineSettings Class

TimelineSettings Class
Remarks See Also
[image]

Encapsulates settings for a timeline in a Resource view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class TimelineSettings : CalendarSettings
Visual Basic [image] Copy Code

Public NotInheritable Class TimelineSettings
Inherits CalendarSettings

Remarks

This class provides various properties which can be used for customizing the timelines in a Resource view. The settings for the individual timelines can be accessed through the BottomTimelineSettings, MiddleTimelineSettings and TopTimelineSettings of the ResourceViewSettings class respectively.

The Unit and UnitCount properties specify the resolution of the timeline. For example, specifying Day for Unit and 2 for UnitCount will divide the timeline into cells representing 2 days intervals each. The resolution of the bottom timeline also determines the resolution of the view. The dates displayed in the timeline cells are formatted according to the Format property.

To modify the appearance of the timeline, use the CalendarStyle property.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.TimelineSettings

See Also

TimelineSettings Members


MindFusion.Scheduling.Silverlight.TimelineSettings Members

TimelineSettings Members
Constructors Fields Properties
[image]

Encapsulates settings for a timeline in a Resource view.

The following tables list the members exposed by the TimelineSettings type.

Public Constructors

Name | Description
TimelineSettings | Initializes a new instance of the TimelineSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
FormatProperty | Identifies the Format dependency property.
NowBrushProperty | Identifies the NowBrush dependency property.
NowFillBrushProperty | Identifies the NowFillBrush dependency property.
ShowCurrentTimeProperty | Identifies the ShowCurrentTime dependency property.
SizeProperty | Identifies the Size dependency property.
UnitCountProperty | Identifies the UnitCount dependency property.
UnitProperty | Identifies the Unit dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the style of the timeline.
Format | Gets or sets the format of the displayed dates in the timeline.
NowBrush | Gets or sets the brush used to mark the current time in the timeline.
NowFillBrush | Gets or sets the fill brush used to mark the current time in the timeline.
ShowCurrentTime | Gets or sets a value indicating whether to indicate the current time in the timeline.
Size | Gets or sets the size of the timeline.
Unit | Gets or sets the time unit of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

See Also

TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings Fields

TimelineSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
FormatProperty | Identifies the Format dependency property.
NowBrushProperty | Identifies the NowBrush dependency property.
NowFillBrushProperty | Identifies the NowFillBrush dependency property.
ShowCurrentTimeProperty | Identifies the ShowCurrentTime dependency property.
SizeProperty | Identifies the Size dependency property.
UnitCountProperty | Identifies the UnitCount dependency property.
UnitProperty | Identifies the Unit dependency property.

See Also

TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.CalendarStyleProperty Field

TimelineSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.FormatProperty Field

TimelineSettings.FormatProperty Field
[image]

Identifies the Format dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly FormatProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.NowBrushProperty Field

TimelineSettings.NowBrushProperty Field
[image]

Identifies the NowBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NowBrushProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly NowBrushProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.NowFillBrushProperty Field

TimelineSettings.NowFillBrushProperty Field
[image]

Identifies the NowFillBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NowFillBrushProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly NowFillBrushProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.ShowCurrentTimeProperty Field

TimelineSettings.ShowCurrentTimeProperty Field
[image]

Identifies the ShowCurrentTime dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCurrentTimeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCurrentTimeProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.SizeProperty Field

TimelineSettings.SizeProperty Field
[image]

Identifies the Size dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SizeProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.UnitCountProperty Field

TimelineSettings.UnitCountProperty Field
[image]

Identifies the UnitCount dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty UnitCountProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly UnitCountProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.UnitProperty Field

TimelineSettings.UnitProperty Field
[image]

Identifies the Unit dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty UnitProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly UnitProperty As DependencyProperty

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings Constructor

TimelineSettings Constructor
[image]

Initializes a new instance of the TimelineSettings class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimelineSettings ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings Properties

TimelineSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the style of the timeline.
Format | Gets or sets the format of the displayed dates in the timeline.
NowBrush | Gets or sets the brush used to mark the current time in the timeline.
NowFillBrush | Gets or sets the fill brush used to mark the current time in the timeline.
ShowCurrentTime | Gets or sets a value indicating whether to indicate the current time in the timeline.
Size | Gets or sets the size of the timeline.
Unit | Gets or sets the time unit of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

See Also

TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.CalendarStyle Property

TimelineSettings.CalendarStyle Property
[image]

Gets or sets the style of the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

An instance of the CalendarStyle class.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Example

The following example changes the background brush of the bottom timeline. The example assumes that calendar is a variable referencing existing Calendar instance.

C# [image] Copy Code

calendar.ResourceViewSettings.BottomTimelineSettings.CalendarStyle.Background = Brushes.LightSteelBlue;
Visual Basic [image] Copy Code

calendar.ResourceViewSettings.BottomTimelineSettings.CalendarStyle.Background = Brushes.LightSteelBlue

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.Format Property

TimelineSettings.Format Property
[image]

Gets or sets the format of the displayed dates in the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string Format { get; set; }
Visual Basic [image] Copy Code

Public Property Format As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

Example

The following example sets the resolution of the bottom timeline to one hour and the display format to "HH:mm". The example assumes that calendar is a valid reference to a Calendar instance.

C# [image] Copy Code

calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour;
calendar.ResourceViewSettings.BottomTimelineSettings.UnitCount = 1;
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "HH:mm";
Visual Basic [image] Copy Code

calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour
calendar.ResourceViewSettings.BottomTimelineSettings.UnitCount = 1
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "HH:mm"

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.NowBrush Property

TimelineSettings.NowBrush Property
[image]

Gets or sets the brush used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush NowBrush { get; set; }
Visual Basic [image] Copy Code

Public Property NowBrush As Brush

Property Value

A .NET Brush instance used to draw the current time indicator.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Silverlight Namespace
NowFillBrush Property
ShowCurrentTime Property


MindFusion.Scheduling.Silverlight.TimelineSettings.NowFillBrush Property

TimelineSettings.NowFillBrush Property
[image]

Gets or sets the fill brush used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush NowFillBrush { get; set; }
Visual Basic [image] Copy Code

Public Property NowFillBrush As Brush

Property Value

A .NET Brush instance specifying the background of the current time indicator.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Silverlight Namespace
NowBrush Property
ShowCurrentTime Property


MindFusion.Scheduling.Silverlight.TimelineSettings.ShowCurrentTime Property

TimelineSettings.ShowCurrentTime Property
[image]

Gets or sets a value indicating whether to indicate the current time in the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowCurrentTime { get; set; }
Visual Basic [image] Copy Code

Public Property ShowCurrentTime As Boolean

Property Value

true to display the current time; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The current time is rendered using the brushes specified by the NowBrush and NowFillBrush properties.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Silverlight Namespace
NowBrush Property
NowFillBrush Property


MindFusion.Scheduling.Silverlight.TimelineSettings.Size Property

TimelineSettings.Size Property
[image]

Gets or sets the size of the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int Size { get; set; }
Visual Basic [image] Copy Code

Public Property Size As Integer

Property Value

An integer value specifying the size of the timeline in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimelineSettings Members
TimelineSettings Class


MindFusion.Scheduling.Silverlight.TimelineSettings.Unit Property

TimelineSettings.Unit Property
[image]

Gets or sets the time unit of the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimeUnit Unit { get; set; }
Visual Basic [image] Copy Code

Public Property Unit As TimeUnit

Property Value

A member of the TimeUnit enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property in conjunction with the UnitCount property specifies the resolution of the timeline.

Example

The following example sets the resolution of the bottom timeline to one hour and the display format to "HH:mm". The example assumes that calendar is a valid reference to a Calendar instance.

C# [image] Copy Code

calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour;
calendar.ResourceViewSettings.BottomTimelineSettings.UnitCount = 1;
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "HH:mm";
Visual Basic [image] Copy Code

calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour
calendar.ResourceViewSettings.BottomTimelineSettings.UnitCount = 1
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "HH:mm"

See Also

TimelineSettings Members
TimelineSettings Class
UnitCount Property


MindFusion.Scheduling.Silverlight.TimelineSettings.UnitCount Property

TimelineSettings.UnitCount Property
[image]

Gets or sets the number of units between adjacent ticks in the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int UnitCount { get; set; }
Visual Basic [image] Copy Code

Public Property UnitCount As Integer

Property Value

An integer value specifying the number of units.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property in conjunction with the Unit property specifies the resolution of the timeline.

Example

The following example sets the resolution of the bottom timeline to one hour and the display format to "HH:mm". The example assumes that calendar is a valid reference to a Calendar instance.

C# [image] Copy Code

calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour;
calendar.ResourceViewSettings.BottomTimelineSettings.UnitCount = 1;
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "HH:mm";
Visual Basic [image] Copy Code

calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour
calendar.ResourceViewSettings.BottomTimelineSettings.UnitCount = 1
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "HH:mm"

See Also

TimelineSettings Members
TimelineSettings Class
Unit Property


MindFusion.Scheduling.Silverlight.TimetableSettings Class

TimetableSettings Class
[image]

Defines properties that allow customizing the visualization of the calendar in Timetable view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public sealed class TimetableSettings : CalendarSettings
Visual Basic [image] Copy Code

Public NotInheritable Class TimetableSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.TimetableSettings

See Also

TimetableSettings Members


MindFusion.Scheduling.Silverlight.TimetableSettings Members

TimetableSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of the calendar in Timetable view.

The following tables list the members exposed by the TimetableSettings type.

Public Constructors

Name | Description
TimetableSettings | Initializes a new instance of the TimetableSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSizeProperty | Identifies the CellSize dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
CellTimeProperty | Identifies the CellTime dependency property.
ColumnBandSizeProperty | Identifies the ColumnBandSize dependency property.
DatesProperty | Identifies the Dates dependency property.
DayHeaderMinSizeProperty | Identifies the DayHeaderMinSize dependency property.
EnableCollisionsProperty | Identifies the EnableCollisions dependency property.
EnableDayItemsProperty | Identifies the EnableDayItems dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
ExpandActiveItemOnProperty | Identifies the ExpandActiveItemOn dependency property.
GeneralFormatProperty | Identifies the GeneralFormat dependency property.
GroupHoursProperty | Identifies the GroupHours dependency property.
HeaderDateFormatProperty | Identifies the HeaderDateFormat dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
ItemOffsetProperty | Identifies the ItemOffset dependency property.
MainHeaderSizeProperty | Identifies the MainHeaderSize dependency property.
MaxAllDayItemsProperty | Identifies the MaxAllDayItems dependency property.
MinColumnSizeProperty | Identifies the MinColumnSize dependency property.
MinItemSizeProperty | Identifies the MinItemSize dependency property.
MinuteFormatProperty | Identifies the MinuteFormat dependency property.
NowBrushProperty | Identifies the NowBrush dependency property.
NowFillBrushProperty | Identifies the NowFillBrush dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RotateHeaderTextsProperty | Identifies the RotateHeaderTexts dependency property.
RotateTimelineTextsProperty | Identifies the RotateTimelineTexts dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SecondTimelineOffsetProperty | Identifies the SecondTimelineOffset dependency property.
SecondTimelinePositionProperty | Identifies the SecondTimelinePosition dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsStyle dependency property.
SelectWholeDayOnHeaderClickProperty | Identifies the SelectWholeDayOnHeaderClick dependency property.
ShowAMProperty | Identifies the ShowAM dependency property.
ShowCurrentTimeProperty | Identifies the ShowCurrentTime dependency property.
ShowDayHeaderProperty | Identifies the ShowDayHeader dependency property.
ShowItemSpansProperty | Identifies the ShowItemSpans dependency property.
ShowMinutesInHourHeadersProperty | Identifies the ShowMinutesInHourHeaders dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
ShowPaddingProperty | Identifies the ShowPadding dependency property.
ShowWorkTimeProperty | Identifies the ShowWorkTime dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
StartTimeProperty | Identifies the StartTime dependency property.
SubHeaderSizeProperty | Identifies the SubHeaderSize dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TimelineSizeProperty | Identifies the TimelineSize dependency property.
TimelineStyleProperty | Identifies the TimelineStyle dependency property.
TwelveHourFormatProperty | Identifies the TwelveHourFormat dependency property.
WorkTimeCellStyleProperty | Identifies the WorkTimeCellStyle dependency property.
WorkTimeEndHourProperty | Identifies the WorkTimeEndHour dependency property.
WorkTimeStartHourProperty | Identifies the WorkTimeStartHour dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of a time segment cells.
CellTime | Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.
ColumnBandSize | Gets or sets the size of the bands displayed on the left/top side of each timetable column.
Dates | Gets a collection of all dates visualized in the timetable.
DayHeaderMinSize | Gets or sets the minimum size of the header displaying all-day items.
EnableCollisions | Gets or sets a value indicating whether the item collision processing is enabled.
EnableDayItems | Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EndTime | Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GeneralFormat | Gets or sets the string to use when formatting times in the timeline.
GroupHours | Gets or sets a value indicating whether hours displayed in the timeline are grouped.
HeaderDateFormat | Gets or sets how to format and display dates in the timetable header.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
ItemOffset | Gets or set the distance between the first item and its adjoining cell side.
MainHeaderSize | Gets or sets the size of the main header.
MaxAllDayItems | Gets or sets the maximum number of all-day items visible in the columns headers at a time.
MinColumnSize | Gets or sets the smallest size allowed for timetable columns.
MinItemSize | Gets or sets the smallest size allowed for schedule items.
MinuteFormat | Gets or sets how to format and display minutes.
NowBrush | Gets or sets the brush used to mark the current time in the timeline.
NowFillBrush | Gets or sets the fill brush used to mark the current time in the timeline.
Orientation | Gets or sets the view orientation.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts are rotated in a view with Horizontal orientation.
RotateTimelineTexts | Gets or sets a value indicating whether the timeline texts are rotated in a view with Horizontal orientation.
ScrollStep | Gets or sets the number of days to scroll when the user clicks the navigation buttons.
SecondTimelineOffset | Gets or sets the offset in hours of the second timeline.
SecondTimelinePosition | Gets or sets a value indicating whether a second timeline is displayed in addition to the primary one.
SelectedElementsStyle | Gets or sets the appearance of selected cells.
SelectWholeDayOnHeaderClick | Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.
ShowAM | Gets or sets a value indicating whether the AM and PM suffixes are displayed.
ShowCurrentTime | Gets or sets a value indicating whether to display the current time in the timeline.
ShowDayHeader | Gets or sets a value indicating whether to show the header displaying all-day items.
ShowItemSpans | Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.
ShowMinutesInHourHeaders | Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.
ShowNavigationButtons | Gets or sets a value indicating whether the Timetable view displays navigation buttons.
ShowPadding | Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.
ShowWorkTime | Gets or sets a value indicating whether the work time should be displayed with different style.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
StartTime | Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.
SubHeaderSize | Gets or sets the size of the secondary header.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TimelineSize | Gets or sets the size of the timeline header.
TimelineStyle | Gets or sets the style of the timeline header.
TwelveHourFormat | Gets or sets a value indicating whether to use a 12-hour format.
WorkTimeCellStyle | Gets or sets the style of cells in the work time interval.
WorkTimeEndHour | Gets or sets the end hour of the work time interval.
WorkTimeStartHour | Gets or sets the start hour of the work time interval.

See Also

TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings Fields

TimetableSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSizeProperty | Identifies the CellSize dependency property.
CellStyleProperty | Identifies the CellStyle dependency property.
CellTimeProperty | Identifies the CellTime dependency property.
ColumnBandSizeProperty | Identifies the ColumnBandSize dependency property.
DatesProperty | Identifies the Dates dependency property.
DayHeaderMinSizeProperty | Identifies the DayHeaderMinSize dependency property.
EnableCollisionsProperty | Identifies the EnableCollisions dependency property.
EnableDayItemsProperty | Identifies the EnableDayItems dependency property.
EnableSnappingProperty | Identifies the EnableSnapping dependency property.
EndTimeProperty | Identifies the EndTime dependency property.
ExpandActiveItemOnProperty | Identifies the ExpandActiveItemOn dependency property.
GeneralFormatProperty | Identifies the GeneralFormat dependency property.
GroupHoursProperty | Identifies the GroupHours dependency property.
HeaderDateFormatProperty | Identifies the HeaderDateFormat dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
ItemOffsetProperty | Identifies the ItemOffset dependency property.
MainHeaderSizeProperty | Identifies the MainHeaderSize dependency property.
MaxAllDayItemsProperty | Identifies the MaxAllDayItems dependency property.
MinColumnSizeProperty | Identifies the MinColumnSize dependency property.
MinItemSizeProperty | Identifies the MinItemSize dependency property.
MinuteFormatProperty | Identifies the MinuteFormat dependency property.
NowBrushProperty | Identifies the NowBrush dependency property.
NowFillBrushProperty | Identifies the NowFillBrush dependency property.
OrientationProperty | Identifies the Orientation dependency property.
RotateHeaderTextsProperty | Identifies the RotateHeaderTexts dependency property.
RotateTimelineTextsProperty | Identifies the RotateTimelineTexts dependency property.
ScrollStepProperty | Identifies the ScrollStep dependency property.
SecondTimelineOffsetProperty | Identifies the SecondTimelineOffset dependency property.
SecondTimelinePositionProperty | Identifies the SecondTimelinePosition dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsStyle dependency property.
SelectWholeDayOnHeaderClickProperty | Identifies the SelectWholeDayOnHeaderClick dependency property.
ShowAMProperty | Identifies the ShowAM dependency property.
ShowCurrentTimeProperty | Identifies the ShowCurrentTime dependency property.
ShowDayHeaderProperty | Identifies the ShowDayHeader dependency property.
ShowItemSpansProperty | Identifies the ShowItemSpans dependency property.
ShowMinutesInHourHeadersProperty | Identifies the ShowMinutesInHourHeaders dependency property.
ShowNavigationButtonsProperty | Identifies the ShowNavigationButtons dependency property.
ShowPaddingProperty | Identifies the ShowPadding dependency property.
ShowWorkTimeProperty | Identifies the ShowWorkTime dependency property.
SnapUnitCountProperty | Identifies the SnapUnitCount dependency property.
SnapUnitProperty | Identifies the SnapUnit dependency property.
StartTimeProperty | Identifies the StartTime dependency property.
SubHeaderSizeProperty | Identifies the SubHeaderSize dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TimelineSizeProperty | Identifies the TimelineSize dependency property.
TimelineStyleProperty | Identifies the TimelineStyle dependency property.
TwelveHourFormatProperty | Identifies the TwelveHourFormat dependency property.
WorkTimeCellStyleProperty | Identifies the WorkTimeCellStyle dependency property.
WorkTimeEndHourProperty | Identifies the WorkTimeEndHour dependency property.
WorkTimeStartHourProperty | Identifies the WorkTimeStartHour dependency property.

See Also

TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.CalendarStyleProperty Field

TimetableSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.CellSizeProperty Field

TimetableSettings.CellSizeProperty Field
[image]

Identifies the CellSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.CellStyleProperty Field

TimetableSettings.CellStyleProperty Field
[image]

Identifies the CellStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.CellTimeProperty Field

TimetableSettings.CellTimeProperty Field
[image]

Identifies the CellTime dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellTimeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellTimeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ColumnBandSizeProperty Field

TimetableSettings.ColumnBandSizeProperty Field
[image]

Identifies the ColumnBandSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ColumnBandSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ColumnBandSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.DatesProperty Field

TimetableSettings.DatesProperty Field
[image]

Identifies the Dates dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DatesProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly DatesProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.DayHeaderMinSizeProperty Field

TimetableSettings.DayHeaderMinSizeProperty Field
[image]

Identifies the DayHeaderMinSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DayHeaderMinSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly DayHeaderMinSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.EnableCollisionsProperty Field

TimetableSettings.EnableCollisionsProperty Field
[image]

Identifies the EnableCollisions dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableCollisionsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EnableCollisionsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.EnableDayItemsProperty Field

TimetableSettings.EnableDayItemsProperty Field
[image]

Identifies the EnableDayItems dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableDayItemsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EnableDayItemsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.EnableSnappingProperty Field

TimetableSettings.EnableSnappingProperty Field
[image]

Identifies the EnableSnapping dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableSnappingProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EnableSnappingProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.EndTimeProperty Field

TimetableSettings.EndTimeProperty Field
[image]

Identifies the EndTime dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndTimeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EndTimeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ExpandActiveItemOnProperty Field

TimetableSettings.ExpandActiveItemOnProperty Field
[image]

Identifies the ExpandActiveItemOn dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ExpandActiveItemOnProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ExpandActiveItemOnProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.GeneralFormatProperty Field

TimetableSettings.GeneralFormatProperty Field
[image]

Identifies the GeneralFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GeneralFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly GeneralFormatProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.GroupHoursProperty Field

TimetableSettings.GroupHoursProperty Field
[image]

Identifies the GroupHours dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupHoursProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly GroupHoursProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.HeaderDateFormatProperty Field

TimetableSettings.HeaderDateFormatProperty Field
[image]

Identifies the HeaderDateFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderDateFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderDateFormatProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.HeaderStyleProperty Field

TimetableSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ItemOffsetProperty Field

TimetableSettings.ItemOffsetProperty Field
[image]

Identifies the ItemOffset dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ItemOffsetProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ItemOffsetProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.MainHeaderSizeProperty Field

TimetableSettings.MainHeaderSizeProperty Field
[image]

Identifies the MainHeaderSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MainHeaderSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MainHeaderSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.MaxAllDayItemsProperty Field

TimetableSettings.MaxAllDayItemsProperty Field
[image]

Identifies the MaxAllDayItems dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxAllDayItemsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MaxAllDayItemsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.MinColumnSizeProperty Field

TimetableSettings.MinColumnSizeProperty Field
[image]

Identifies the MinColumnSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinColumnSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MinColumnSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.MinItemSizeProperty Field

TimetableSettings.MinItemSizeProperty Field
[image]

Identifies the MinItemSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinItemSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MinItemSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.MinuteFormatProperty Field

TimetableSettings.MinuteFormatProperty Field
[image]

Identifies the MinuteFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinuteFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly MinuteFormatProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.NowBrushProperty Field

TimetableSettings.NowBrushProperty Field
[image]

Identifies the NowBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NowBrushProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly NowBrushProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.NowFillBrushProperty Field

TimetableSettings.NowFillBrushProperty Field
[image]

Identifies the NowFillBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty NowFillBrushProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly NowFillBrushProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.OrientationProperty Field

TimetableSettings.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.RotateHeaderTextsProperty Field

TimetableSettings.RotateHeaderTextsProperty Field
[image]

Identifies the RotateHeaderTexts dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateHeaderTextsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly RotateHeaderTextsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.RotateTimelineTextsProperty Field

TimetableSettings.RotateTimelineTextsProperty Field
[image]

Identifies the RotateTimelineTexts dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RotateTimelineTextsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly RotateTimelineTextsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ScrollStepProperty Field

TimetableSettings.ScrollStepProperty Field
[image]

Identifies the ScrollStep dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScrollStepProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ScrollStepProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SecondTimelineOffsetProperty Field

TimetableSettings.SecondTimelineOffsetProperty Field
[image]

Identifies the SecondTimelineOffset dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SecondTimelineOffsetProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SecondTimelineOffsetProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SecondTimelinePositionProperty Field

TimetableSettings.SecondTimelinePositionProperty Field
[image]

Identifies the SecondTimelinePosition dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SecondTimelinePositionProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SecondTimelinePositionProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SelectedElementsStyleProperty Field

TimetableSettings.SelectedElementsStyleProperty Field
[image]

Identifies the SelectedElementsStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SelectWholeDayOnHeaderClickProperty Field

TimetableSettings.SelectWholeDayOnHeaderClickProperty Field
[image]

Identifies the SelectWholeDayOnHeaderClick dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectWholeDayOnHeaderClickProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectWholeDayOnHeaderClickProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowAMProperty Field

TimetableSettings.ShowAMProperty Field
[image]

Identifies the ShowAM dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowAMProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowAMProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowCurrentTimeProperty Field

TimetableSettings.ShowCurrentTimeProperty Field
[image]

Identifies the ShowCurrentTime dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowCurrentTimeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowCurrentTimeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowDayHeaderProperty Field

TimetableSettings.ShowDayHeaderProperty Field
[image]

Identifies the ShowDayHeader dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowDayHeaderProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowDayHeaderProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowItemSpansProperty Field

TimetableSettings.ShowItemSpansProperty Field
[image]

Identifies the ShowItemSpans dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowItemSpansProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowItemSpansProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowMinutesInHourHeadersProperty Field

TimetableSettings.ShowMinutesInHourHeadersProperty Field
[image]

Identifies the ShowMinutesInHourHeaders dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowMinutesInHourHeadersProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowMinutesInHourHeadersProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowNavigationButtonsProperty Field

TimetableSettings.ShowNavigationButtonsProperty Field
[image]

Identifies the ShowNavigationButtons dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowNavigationButtonsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowNavigationButtonsProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowPaddingProperty Field

TimetableSettings.ShowPaddingProperty Field
[image]

Identifies the ShowPadding dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowPaddingProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowPaddingProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowWorkTimeProperty Field

TimetableSettings.ShowWorkTimeProperty Field
[image]

Identifies the ShowWorkTime dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowWorkTimeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowWorkTimeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SnapUnitCountProperty Field

TimetableSettings.SnapUnitCountProperty Field
[image]

Identifies the SnapUnitCount dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitCountProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitCountProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SnapUnitProperty Field

TimetableSettings.SnapUnitProperty Field
[image]

Identifies the SnapUnit dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SnapUnitProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SnapUnitProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.StartTimeProperty Field

TimetableSettings.StartTimeProperty Field
[image]

Identifies the StartTime dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartTimeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly StartTimeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SubHeaderSizeProperty Field

TimetableSettings.SubHeaderSizeProperty Field
[image]

Identifies the SubHeaderSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SubHeaderStyleProperty Field

TimetableSettings.SubHeaderStyleProperty Field
[image]

Identifies the SubHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.TimelineSizeProperty Field

TimetableSettings.TimelineSizeProperty Field
[image]

Identifies the TimelineSize dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelineSizeProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TimelineSizeProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.TimelineStyleProperty Field

TimetableSettings.TimelineStyleProperty Field
[image]

Identifies the TimelineStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimelineStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TimelineStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.TwelveHourFormatProperty Field

TimetableSettings.TwelveHourFormatProperty Field
[image]

Identifies the TwelveHourFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TwelveHourFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TwelveHourFormatProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.WorkTimeCellStyleProperty Field

TimetableSettings.WorkTimeCellStyleProperty Field
[image]

Identifies the WorkTimeCellStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WorkTimeCellStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly WorkTimeCellStyleProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.WorkTimeEndHourProperty Field

TimetableSettings.WorkTimeEndHourProperty Field
[image]

Identifies the WorkTimeEndHour dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WorkTimeEndHourProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly WorkTimeEndHourProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.WorkTimeStartHourProperty Field

TimetableSettings.WorkTimeStartHourProperty Field
[image]

Identifies the WorkTimeStartHour dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty WorkTimeStartHourProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly WorkTimeStartHourProperty As DependencyProperty

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings Constructor

TimetableSettings Constructor
[image]

Initializes a new instance of the TimetableSettings class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimetableSettings ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings Properties

TimetableSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of a time segment cells.
CellTime | Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.
ColumnBandSize | Gets or sets the size of the bands displayed on the left/top side of each timetable column.
Dates | Gets a collection of all dates visualized in the timetable.
DayHeaderMinSize | Gets or sets the minimum size of the header displaying all-day items.
EnableCollisions | Gets or sets a value indicating whether the item collision processing is enabled.
EnableDayItems | Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EndTime | Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GeneralFormat | Gets or sets the string to use when formatting times in the timeline.
GroupHours | Gets or sets a value indicating whether hours displayed in the timeline are grouped.
HeaderDateFormat | Gets or sets how to format and display dates in the timetable header.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
ItemOffset | Gets or set the distance between the first item and its adjoining cell side.
MainHeaderSize | Gets or sets the size of the main header.
MaxAllDayItems | Gets or sets the maximum number of all-day items visible in the columns headers at a time.
MinColumnSize | Gets or sets the smallest size allowed for timetable columns.
MinItemSize | Gets or sets the smallest size allowed for schedule items.
MinuteFormat | Gets or sets how to format and display minutes.
NowBrush | Gets or sets the brush used to mark the current time in the timeline.
NowFillBrush | Gets or sets the fill brush used to mark the current time in the timeline.
Orientation | Gets or sets the view orientation.
RotateHeaderTexts | Gets or sets a value indicating whether the header texts are rotated in a view with Horizontal orientation.
RotateTimelineTexts | Gets or sets a value indicating whether the timeline texts are rotated in a view with Horizontal orientation.
ScrollStep | Gets or sets the number of days to scroll when the user clicks the navigation buttons.
SecondTimelineOffset | Gets or sets the offset in hours of the second timeline.
SecondTimelinePosition | Gets or sets a value indicating whether a second timeline is displayed in addition to the primary one.
SelectedElementsStyle | Gets or sets the appearance of selected cells.
SelectWholeDayOnHeaderClick | Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.
ShowAM | Gets or sets a value indicating whether the AM and PM suffixes are displayed.
ShowCurrentTime | Gets or sets a value indicating whether to display the current time in the timeline.
ShowDayHeader | Gets or sets a value indicating whether to show the header displaying all-day items.
ShowItemSpans | Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.
ShowMinutesInHourHeaders | Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.
ShowNavigationButtons | Gets or sets a value indicating whether the Timetable view displays navigation buttons.
ShowPadding | Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.
ShowWorkTime | Gets or sets a value indicating whether the work time should be displayed with different style.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
StartTime | Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.
SubHeaderSize | Gets or sets the size of the secondary header.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TimelineSize | Gets or sets the size of the timeline header.
TimelineStyle | Gets or sets the style of the timeline header.
TwelveHourFormat | Gets or sets a value indicating whether to use a 12-hour format.
WorkTimeCellStyle | Gets or sets the style of cells in the work time interval.
WorkTimeEndHour | Gets or sets the end hour of the work time interval.
WorkTimeStartHour | Gets or sets the start hour of the work time interval.

See Also

TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.CalendarStyle Property

TimetableSettings.CalendarStyle Property
[image]

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of calendar UI elements. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.CellSize Property

TimetableSettings.CellSize Property
[image]

Gets or sets the size of time cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int CellSize { get; set; }
Visual Basic [image] Copy Code

Public Property CellSize As Integer

Property Value

An integer value specifying the cell size. The minimal allowed value is 10.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
CellStyle Property


MindFusion.Scheduling.Silverlight.TimetableSettings.CellStyle Property

TimetableSettings.CellStyle Property
[image]

Gets or sets the style of a time segment cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CellStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CellStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of timetable cells. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
WorkTimeCellStyle Property
CellSize Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.TimetableSettings.CellTime Property

TimetableSettings.CellTime Property
[image]

Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimeSpan CellTime { get; set; }
Visual Basic [image] Copy Code

Public Property CellTime As TimeSpan

Property Value

A .NET TimeSpan object that specifies the time length of a single cell. The allowed values range from 1 second to 1 hour inclusive.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Example

The following sample demonstrates several ways for setting the time span of timetable cells. The sample assumes that calendar already references an existing Calendar object.

C# [image] Copy Code

// Set the cell time to 10 minutes
calendar.TimetableSettings.CellTime = TimeSpan.FromMinutes(10);

// Set the cell time to 1 second
calendar.TimetableSettings.CellTime = TimeSpan.FromSeconds(1);

// Set the cell time to 1 minute and 20 seconds
calendar.TimetableSettings.CellTime = new TimeSpan(0, 1, 20);
Visual Basic [image] Copy Code

' Set the cell time to 10 minutes
calendar.TimetableSettings.CellTime = TimeSpan.FromMinutes(10)

' Set the cell time to 1 second
calendar.TimetableSettings.CellTime = TimeSpan.FromSeconds(1)

' Set the cell time to 1 minute and 20 seconds
calendar.TimetableSettings.CellTime = New TimeSpan(0, 1, 20)

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ColumnBandSize Property

TimetableSettings.ColumnBandSize Property
[image]

Gets or sets the size of the bands displayed on the left/top side of each timetable column.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ColumnBandSize { get; set; }
Visual Basic [image] Copy Code

Public Property ColumnBandSize As Integer

Property Value

A non-negative integer specifying band width in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

For best results, assign to this property the value of ItemSettings.MoveBandSize.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.Dates Property

TimetableSettings.Dates Property
[image]

Gets a collection of all dates visualized in the timetable.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DateCollection Dates { get; set; }
Visual Basic [image] Copy Code

Public Property Dates As DateCollection

Property Value

An instance of the DateCollection class specifying which dates to display as columns in the timetable view. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.DayHeaderMinSize Property

TimetableSettings.DayHeaderMinSize Property
[image]

Gets or sets the minimum size of the header displaying all-day items.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int DayHeaderMinSize { get; set; }
Visual Basic [image] Copy Code

Public Property DayHeaderMinSize As Integer

Property Value

An integer value specifying the minimal header size in pixels. The minimal allowed value is 5.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.EnableCollisions Property

TimetableSettings.EnableCollisions Property
[image]

Gets or sets a value indicating whether the item collision processing is enabled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool EnableCollisions { get; set; }
Visual Basic [image] Copy Code

Public Property EnableCollisions As Boolean

Property Value

A Boolean value.

Remarks

Turn this flag off if you don't need collision detection to improve performance.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.EnableDayItems Property

TimetableSettings.EnableDayItems Property
[image]

Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool EnableDayItems { get; set; }
Visual Basic [image] Copy Code

Public Property EnableDayItems As Boolean

Property Value

A Boolean value.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

By default, items longer than 1 day or items marked as AllDayEvent are displayed in the day header of the view. If the day header is not displayed (that is, ShowDayHeader is set to false) then these items are never displayed. Settings this property to false causes all items regardless of their length to be displayed in the main view.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.EnableSnapping Property

TimetableSettings.EnableSnapping Property
[image]

Gets or sets a value indicating whether custom snapping is enabled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool EnableSnapping { get; set; }
Visual Basic [image] Copy Code

Public Property EnableSnapping As Boolean

Property Value

A Boolean value.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
SnapUnit Property
SnapUnitCount Property


MindFusion.Scheduling.Silverlight.TimetableSettings.EndTime Property

TimetableSettings.EndTime Property
[image]

Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int EndTime { get; set; }
Visual Basic [image] Copy Code

Public Property EndTime As Integer

Property Value

An integer value specifying the end time in minutes. The allowed values range from 0 to 2880.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Specifying value for this property which is smaller than the value of StartTime is permissible. This indicates that the end value represents time from the next day. For example if StartTime is set to 600 (10:00 AM) and EndTime is set to 480 (8:00 AM), then each column in the view represents the time from 10:00 AM until 8:00 AM on the following day. Specifying 1920 (480 + 1440) for the EndTime yields the same result.

Note

It is possible to specify more than 24 hours to be displayed in a single timetable column. Doing so though might lead to ambiguities because certain periods of time will appear in more than one place (for example, a period will appear once at the end of a column and again in the beginning of the next one).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
StartTime Property
CellTime Property


MindFusion.Scheduling.Silverlight.TimetableSettings.ExpandActiveItemOn Property

TimetableSettings.ExpandActiveItemOn Property
[image]

Gets or sets whether the active item should ignore collisions.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public ItemAction ExpandActiveItemOn { get; set; }
Visual Basic [image] Copy Code

Public Property ExpandActiveItemOn As ItemAction

Property Value

A member of the ItemAction enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.GeneralFormat Property

TimetableSettings.GeneralFormat Property
[image]

Gets or sets the string to use when formatting times in the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string GeneralFormat { get; set; }
Visual Basic [image] Copy Code

Public Property GeneralFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.GroupHours Property

TimetableSettings.GroupHours Property
[image]

Gets or sets a value indicating whether hours displayed in the timeline are grouped.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool GroupHours { get; set; }
Visual Basic [image] Copy Code

Public Property GroupHours As Boolean

Property Value

true to enable grouping; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Certain conditions prevent hours from grouping, such as when the hours are not divisible by the specified CellTime.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.HeaderDateFormat Property

TimetableSettings.HeaderDateFormat Property
[image]

Gets or sets how to format and display dates in the timetable header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string HeaderDateFormat { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderDateFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.HeaderStyle Property

TimetableSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ItemOffset Property

TimetableSettings.ItemOffset Property
[image]

Gets or set the distance between the first item and its adjoining cell side.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ItemOffset { get; set; }
Visual Basic [image] Copy Code

Public Property ItemOffset As Integer

Property Value

A non-negative integer value specifying the item offset in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.MainHeaderSize Property

TimetableSettings.MainHeaderSize Property
[image]

Gets or sets the size of the main header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int MainHeaderSize { get; set; }
Visual Basic [image] Copy Code

Public Property MainHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.MaxAllDayItems Property

TimetableSettings.MaxAllDayItems Property
[image]

Gets or sets the maximum number of all-day items visible in the columns headers at a time.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int MaxAllDayItems { get; set; }
Visual Basic [image] Copy Code

Public Property MaxAllDayItems As Integer

Property Value

An integer value specifying how many all-day items to display at most in the column headers. The allowed values range from 1 to 20.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The all-day items header is automatically resized to hold all items up to the number set in this property. If there are more all-day items, the rest of them are not shown.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.MinColumnSize Property

TimetableSettings.MinColumnSize Property
[image]

Gets or sets the smallest size allowed for timetable columns.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int MinColumnSize { get; set; }
Visual Basic [image] Copy Code

Public Property MinColumnSize As Integer

Property Value

An integer value specifying the minimal column size. The minimal allowed value is 10.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.MinItemSize Property

TimetableSettings.MinItemSize Property
[image]

Gets or sets the smallest size allowed for schedule items.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int MinItemSize { get; set; }
Visual Basic [image] Copy Code

Public Property MinItemSize As Integer

Property Value

An integer value specifying the minimal size in pixels. The minimal allowed value is 5.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

If there is not enough space in a column to display all related items, the items that do not fit remain invisible.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.MinuteFormat Property

TimetableSettings.MinuteFormat Property
[image]

Gets or sets how to format and display minutes.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public MinuteFormat MinuteFormat { get; set; }
Visual Basic [image] Copy Code

Public Property MinuteFormat As MinuteFormat

Property Value

A MinuteFormat object specifying the minutes format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.NowBrush Property

TimetableSettings.NowBrush Property
[image]

Gets or sets the brush used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush NowBrush { get; set; }
Visual Basic [image] Copy Code

Public Property NowBrush As Brush

Property Value

A .NET Brush object specifying the color used to indicate the current time.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
NowFillBrush Property
ShowCurrentTime Property


MindFusion.Scheduling.Silverlight.TimetableSettings.NowFillBrush Property

TimetableSettings.NowFillBrush Property
[image]

Gets or sets the fill brush used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush NowFillBrush { get; set; }
Visual Basic [image] Copy Code

Public Property NowFillBrush As Brush

Property Value

A .NET Brush object specifying the color used to indicate the current time.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
NowBrush Property
ShowCurrentTime Property


MindFusion.Scheduling.Silverlight.TimetableSettings.Orientation Property

TimetableSettings.Orientation Property
[image]

Gets or sets the view orientation.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }
Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

A vertical timetable view displays cells for the same daytime in a row, and cells for the same date in a column. A horizontal timetable view displays cells for the same time of the day in a column, and cells for the same date in a row.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.RotateHeaderTexts Property

TimetableSettings.RotateHeaderTexts Property
[image]

Gets or sets a value indicating whether the header texts are rotated in a view with Horizontal orientation.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool RotateHeaderTexts { get; set; }
Visual Basic [image] Copy Code

Public Property RotateHeaderTexts As Boolean

Property Value

true to display the header text rotated; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
RotateTimelineTexts Property


MindFusion.Scheduling.Silverlight.TimetableSettings.RotateTimelineTexts Property

TimetableSettings.RotateTimelineTexts Property
[image]

Gets or sets a value indicating whether the timeline texts are rotated in a view with Horizontal orientation.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool RotateTimelineTexts { get; set; }
Visual Basic [image] Copy Code

Public Property RotateTimelineTexts As Boolean

Property Value

true to display the timeline text rotated; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
RotateHeaderTexts Property


MindFusion.Scheduling.Silverlight.TimetableSettings.ScrollStep Property

TimetableSettings.ScrollStep Property
[image]

Gets or sets the number of days to scroll when the user clicks the navigation buttons.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ScrollStep { get; set; }
Visual Basic [image] Copy Code

Public Property ScrollStep As Integer

Property Value

A positive integer value specifying the number of days to scroll.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SecondTimelineOffset Property

TimetableSettings.SecondTimelineOffset Property
[image]

Gets or sets the offset in hours of the second timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int SecondTimelineOffset { get; set; }
Visual Basic [image] Copy Code

Public Property SecondTimelineOffset As Integer

Property Value

An integer value specifying the offset in hours. The allowed values range from 0 to 23.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
SecondTimelinePosition Property


MindFusion.Scheduling.Silverlight.TimetableSettings.SecondTimelinePosition Property

TimetableSettings.SecondTimelinePosition Property
[image]

Gets or sets a value indicating whether a second timeline is displayed in addition to the primary one.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Alignment SecondTimelinePosition { get; set; }
Visual Basic [image] Copy Code

Public Property SecondTimelinePosition As Alignment

Property Value

Specify Near to show the second timeline next to the main one, Far to place it at the opposite side of the view, or None to hide it.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
SecondTimelineOffset Property


MindFusion.Scheduling.Silverlight.TimetableSettings.SelectedElementsStyle Property

TimetableSettings.SelectedElementsStyle Property
[image]

Gets or sets the appearance of selected cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SelectedElementsStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected elements. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
CalendarStyle Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SelectWholeDayOnHeaderClick Property

TimetableSettings.SelectWholeDayOnHeaderClick Property
[image]

Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool SelectWholeDayOnHeaderClick { get; set; }
Visual Basic [image] Copy Code

Public Property SelectWholeDayOnHeaderClick As Boolean

Property Value

A Boolean value.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowAM Property

TimetableSettings.ShowAM Property
[image]

Gets or sets a value indicating whether the AM and PM suffixes are displayed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowAM { get; set; }
Visual Basic [image] Copy Code

Public Property ShowAM As Boolean

Property Value

true to show AM/PM suffixes; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowCurrentTime Property

TimetableSettings.ShowCurrentTime Property
[image]

Gets or sets a value indicating whether to display the current time in the timeline.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowCurrentTime { get; set; }
Visual Basic [image] Copy Code

Public Property ShowCurrentTime As Boolean

Property Value

true to indicate the current time; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
NowBrush Property
NowFillBrush Property


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowDayHeader Property

TimetableSettings.ShowDayHeader Property
[image]

Gets or sets a value indicating whether to show the header displaying all-day items.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowDayHeader { get; set; }
Visual Basic [image] Copy Code

Public Property ShowDayHeader As Boolean

Property Value

true to show the days header; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MaxAllDayItems Property


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowItemSpans Property

TimetableSettings.ShowItemSpans Property
[image]

Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowItemSpans { get; set; }
Visual Basic [image] Copy Code

Public Property ShowItemSpans As Boolean

Property Value

true to display item spans; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowMinutesInHourHeaders Property

TimetableSettings.ShowMinutesInHourHeaders Property
[image]

Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowMinutesInHourHeaders { get; set; }
Visual Basic [image] Copy Code

Public Property ShowMinutesInHourHeaders As Boolean

Property Value

true to show minutes; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Whole hour cells are displayed when the hours are divisible by the specified CellTime.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowNavigationButtons Property

TimetableSettings.ShowNavigationButtons Property
[image]

Gets or sets a value indicating whether the Timetable view displays navigation buttons.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowNavigationButtons { get; set; }
Visual Basic [image] Copy Code

Public Property ShowNavigationButtons As Boolean

Property Value

true to show navigation buttons; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowPadding Property

TimetableSettings.ShowPadding Property
[image]

Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowPadding { get; set; }
Visual Basic [image] Copy Code

Public Property ShowPadding As Boolean

Property Value

A Boolean value.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.ShowWorkTime Property

TimetableSettings.ShowWorkTime Property
[image]

Gets or sets a value indicating whether the work time should be displayed with different style.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowWorkTime { get; set; }
Visual Basic [image] Copy Code

Public Property ShowWorkTime As Boolean

Property Value

A Boolean value.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
WorkTimeCellStyle Property


MindFusion.Scheduling.Silverlight.TimetableSettings.SnapUnit Property

TimetableSettings.SnapUnit Property
[image]

Gets or sets the snap unit.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public TimeUnit SnapUnit { get; set; }
Visual Basic [image] Copy Code

Public Property SnapUnit As TimeUnit

Property Value

A member of the TimeUnit enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Use this property in a conjunction with the EnableSnapping property to specify the precision with which users can move and resize items interactively. If EnableSnapping is set to false the value of this property is ignored and items snap to cell borders.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
EnableSnapping Property
SnapUnitCount Property


MindFusion.Scheduling.Silverlight.TimetableSettings.SnapUnitCount Property

TimetableSettings.SnapUnitCount Property
[image]

Gets or sets the snap unit count.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int SnapUnitCount { get; set; }
Visual Basic [image] Copy Code

Public Property SnapUnitCount As Integer

Property Value

A positive integer value specifying the number of units from the associated SnapUnit to snap to.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
SnapUnit Property
EnableSnapping Property


MindFusion.Scheduling.Silverlight.TimetableSettings.StartTime Property

TimetableSettings.StartTime Property
[image]

Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int StartTime { get; set; }
Visual Basic [image] Copy Code

Public Property StartTime As Integer

Property Value

An integer value specifying the view start time in minutes. The allowed values range from 0 to 1440.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
EndTime Property
CellTime Property


MindFusion.Scheduling.Silverlight.TimetableSettings.SubHeaderSize Property

TimetableSettings.SubHeaderSize Property
[image]

Gets or sets the size of the secondary header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int SubHeaderSize { get; set; }
Visual Basic [image] Copy Code

Public Property SubHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the secondary header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.SubHeaderStyle Property

TimetableSettings.SubHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view subheaders.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SubHeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SubHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of subheader elements. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.TimetableSettings.TimelineSize Property

TimetableSettings.TimelineSize Property
[image]

Gets or sets the size of the timeline header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int TimelineSize { get; set; }
Visual Basic [image] Copy Code

Public Property TimelineSize As Integer

Property Value

A non-negative integer value specifying the size of the timeline header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.TimelineStyle Property

TimetableSettings.TimelineStyle Property
[image]

Gets or sets the style of the timeline header.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle TimelineStyle { get; set; }
Visual Basic [image] Copy Code

Public Property TimelineStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the appearance of the timeline header. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
CalendarStyle Class


MindFusion.Scheduling.Silverlight.TimetableSettings.TwelveHourFormat Property

TimetableSettings.TwelveHourFormat Property
[image]

Gets or sets a value indicating whether to use a 12-hour format.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool TwelveHourFormat { get; set; }
Visual Basic [image] Copy Code

Public Property TwelveHourFormat As Boolean

Property Value

true to use 12-hour format, or false to use 24-hour format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

TimetableSettings Members
TimetableSettings Class


MindFusion.Scheduling.Silverlight.TimetableSettings.WorkTimeCellStyle Property

TimetableSettings.WorkTimeCellStyle Property
[image]

Gets or sets the style of cells in the work time interval.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle WorkTimeCellStyle { get; set; }
Visual Basic [image] Copy Code

Public Property WorkTimeCellStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of the work time cells. This property cannot be null (Nothing in Visual Basic).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Silverlight Namespace
CellStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.TimetableSettings.WorkTimeEndHour Property

TimetableSettings.WorkTimeEndHour Property
[image]

Gets or sets the end hour of the work time interval.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int WorkTimeEndHour { get; set; }
Visual Basic [image] Copy Code

Public Property WorkTimeEndHour As Integer

Property Value

An integer value specifying the start of the work time in hours. The allowed values range from 0 to 23. The value cannot be less than WorkTimeStartHour.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property and WorkTimeStartHour specify the working time period, whose cells are usually displayed in a different style as set in WorkTimeCellStyle. To use the same style for all cells in the timetable view, set WorkTimeCellStyle to a new empty CalendarStyle.

See Also

TimetableSettings Members
TimetableSettings Class
WorkTimeStartHour Property


MindFusion.Scheduling.Silverlight.TimetableSettings.WorkTimeStartHour Property

TimetableSettings.WorkTimeStartHour Property
[image]

Gets or sets the start hour of the work time interval.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int WorkTimeStartHour { get; set; }
Visual Basic [image] Copy Code

Public Property WorkTimeStartHour As Integer

Property Value

An integer value specifying the start of the work time in hours. The allowed values range from 0 to 23. The value cannot be greater than WorkTimeEndHour.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This property and WorkTimeEndHour specify the working time period, whose cells are usually displayed in a different style as set in WorkTimeCellStyle. To use the same style for all cells in the timetable view, set WorkTimeCellStyle to a new empty CalendarStyle.

See Also

TimetableSettings Members
TimetableSettings Class
WorkTimeEndHour Property


MindFusion.Scheduling.Silverlight.TimeUnit Enumeration

TimeUnit Enumeration
[image]

Specifies a time resolution.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum TimeUnit
Visual Basic [image] Copy Code

Public Enumeration TimeUnit

Members

Member name | Description
Day | Specifies days.
Hour | Specifies hours.
Minute | Specifies minutes.
Month | Specifies months.
Second | Specifies seconds.
Week | Specifies weeks.
Year | Specifies years.

See Also


MindFusion.Scheduling.Silverlight.VisibleConverter Class

VisibleConverter Class
Remarks See Also
[image]

Converts System.Boolean to System.Windows.Visibility by mapping true to Visibility.Visible and false to Visibility.Collapsed.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class VisibleConverter : IValueConverter
Visual Basic [image] Copy Code

Public Class VisibleConverter
Implements IValueConverter

Remarks

This converter can be used when binding elements' Visibility to a boolean property.

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Silverlight.VisibleConverter

See Also

VisibleConverter Members


MindFusion.Scheduling.Silverlight.VisibleConverter Members

VisibleConverter Members
Constructors Methods
[image]

Converts System.Boolean to System.Windows.Visibility by mapping true to Visibility.Visible and false to Visibility.Collapsed.

The following tables list the members exposed by the VisibleConverter type.

Public Constructors

Name | Description
VisibleConverter | Initializes a new instance of the VisibleConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

VisibleConverter Class


MindFusion.Scheduling.Silverlight.VisibleConverter Constructor

VisibleConverter Constructor
[image]

Initializes a new instance of the VisibleConverter class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public VisibleConverter ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisibleConverter Class


MindFusion.Scheduling.Silverlight.VisibleConverter Methods

VisibleConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

VisibleConverter Class


MindFusion.Scheduling.Silverlight.VisibleConverter.Convert Method

VisibleConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)
Visual Basic [image] Copy Code

Public Overridable Function Convert ( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value
The value produced by the binding source.
targetType
The type of the binding target property.
parameter
The converter parameter to use.
culture
The culture to use in the converter.

Return Value

A converted value.

Remarks

Converts true to Visibility.Visible and false to Visibility.Collapsed.

See Also

VisibleConverter Members
VisibleConverter Class


MindFusion.Scheduling.Silverlight.VisibleConverter.ConvertBack Method

VisibleConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public virtual Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)
Visual Basic [image] Copy Code

Public Overridable Function ConvertBack ( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value
The value that is produced by the binding target.
targetType
The type to convert to.
parameter
The converter parameter to use.
culture
The culture to use in the converter.

Return Value

A converted value.

Remarks

This method is not implemented and will throw an exception if used.

See Also

VisibleConverter Members
VisibleConverter Class


MindFusion.Scheduling.Silverlight.WeekRangeHeaderStyle Enumeration

WeekRangeHeaderStyle Enumeration
[image]

Specifies the appearance of the time period header in WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum WeekRangeHeaderStyle
Visual Basic [image] Copy Code

Public Enumeration WeekRangeHeaderStyle

Members

Member name | Description
None | There isn't a header displayed.
Reference | The header displays the name of the associated contact, location or task. This flag is valid only if grouping is enabled.
Title | The header displays the start and end dates specified in the WeekRangeSettings object.

See Also


MindFusion.Scheduling.Silverlight.WeekRangeSettings Class

WeekRangeSettings Class
[image]

Defines properties that allow customizing the visualization of weeks in WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public class WeekRangeSettings : CalendarSettings
Visual Basic [image] Copy Code

Public Class WeekRangeSettings
Inherits CalendarSettings

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Scheduling.Silverlight.CalendarSettings
MindFusion.Scheduling.Silverlight.WeekRangeSettings

See Also

WeekRangeSettings Members


MindFusion.Scheduling.Silverlight.WeekRangeSettings Members

WeekRangeSettings Members
Constructors Fields Properties
[image]

Defines properties that allow customizing the visualization of weeks in WeekRange view.

The following tables list the members exposed by the WeekRangeSettings type.

Public Constructors

Name | Description
WeekRangeSettings | Initializes a new instance of the WeekRangeSettings class.

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSettingsProperty | Identifies the CellSettings dependency property.
DayNamesHeaderHeightProperty | Identifies the DayNamesHeaderHeight dependency property.
DayOfWeekFormatProperty | Identifies the DayOfWeekFormat dependency property.
EvenMonthsBrushProperty | Identifies the EvenMonthsBrush dependency property.
GroupWeekendsProperty | Identifies the GroupWeekends dependency property.
GroupWeekendsTitleSeparatorProperty | Identifies the GroupWeekendsTitleSeparator dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
OddMonthsBrushProperty | Identifies the OddMonthsBrush dependency property.
ReferenceHeaderHeightProperty | Identifies the ReferenceHeaderHeight dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowDayOfWeekProperty | Identifies the ShowDayOfWeek dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TimePeriodHeaderHeightProperty | Identifies the TimePeriodHeaderHeight dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TitleSeparatorProperty | Identifies the TitleSeparator dependency property.
ViewStyleProperty | Identifies the ViewStyle dependency property.
VisibleColumnsProperty | Identifies the VisibleColumns dependency property.
VisibleRowsProperty | Identifies the VisibleRows dependency property.

Public Properties

Name | Description
CalendarStyle | Gets or sets the CalendarStyle used to paint calendar elements that don't have a distinct style assigned to them.
CellSettings | Gets or sets the CellSettings object used to customize the visualization of days in a WeekRange view.
DayNamesHeaderHeight | Gets or sets the height of the day-names header in the WeekRange view.
DayOfWeekFormat | Gets or sets the display format of the names of the days of the week.
EvenMonthsBrush | Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.
GroupWeekends | Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.
GroupWeekendsTitleSeparator | Gets or sets the separator string displayed between the weekend day names when GroupWeekends is enabled.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
OddMonthsBrush | Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.
ReferenceHeaderHeight | Gets or sets the height of the reference header in the WeekRange view.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TimePeriodHeaderHeight | Gets or sets the height of the time-period header in the WeekRange view.
TitleFormat | Gets or sets the format of the calendar's title.
TitleSeparator | Gets or sets the string used as a separator in the calendar's title.
ViewStyle | Gets or sets the style of the WeekRange view.
VisibleColumns | Gets or sets the number of columns visible when the GroupType is enabled.
VisibleRows | Gets or sets the number of weeks visible at a time.

See Also

WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings Fields

WeekRangeSettings Fields
[image]

Public Fields

Name | Description
CalendarStyleProperty | Identifies the CalendarStyle dependency property.
CellSettingsProperty | Identifies the CellSettings dependency property.
DayNamesHeaderHeightProperty | Identifies the DayNamesHeaderHeight dependency property.
DayOfWeekFormatProperty | Identifies the DayOfWeekFormat dependency property.
EvenMonthsBrushProperty | Identifies the EvenMonthsBrush dependency property.
GroupWeekendsProperty | Identifies the GroupWeekends dependency property.
GroupWeekendsTitleSeparatorProperty | Identifies the GroupWeekendsTitleSeparator dependency property.
HeaderStyleProperty | Identifies the HeaderStyle dependency property.
OddMonthsBrushProperty | Identifies the OddMonthsBrush dependency property.
ReferenceHeaderHeightProperty | Identifies the ReferenceHeaderHeight dependency property.
SelectedElementsHeaderStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
SelectedElementsStyleProperty | Identifies the SelectedElementsHeaderStyle dependency property.
ShowDayOfWeekProperty | Identifies the ShowDayOfWeek dependency property.
SubHeaderStyleProperty | Identifies the SubHeaderStyle dependency property.
TimePeriodHeaderHeightProperty | Identifies the TimePeriodHeaderHeight dependency property.
TitleFormatProperty | Identifies the TitleFormat dependency property.
TitleSeparatorProperty | Identifies the TitleSeparator dependency property.
ViewStyleProperty | Identifies the ViewStyle dependency property.
VisibleColumnsProperty | Identifies the VisibleColumns dependency property.
VisibleRowsProperty | Identifies the VisibleRows dependency property.

See Also

WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.CalendarStyleProperty Field

WeekRangeSettings.CalendarStyleProperty Field
[image]

Identifies the CalendarStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CalendarStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CalendarStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.CellSettingsProperty Field

WeekRangeSettings.CellSettingsProperty Field
[image]

Identifies the CellSettings dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CellSettingsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly CellSettingsProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.DayNamesHeaderHeightProperty Field

WeekRangeSettings.DayNamesHeaderHeightProperty Field
[image]

Identifies the DayNamesHeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DayNamesHeaderHeightProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly DayNamesHeaderHeightProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.DayOfWeekFormatProperty Field

WeekRangeSettings.DayOfWeekFormatProperty Field
[image]

Identifies the DayOfWeekFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DayOfWeekFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly DayOfWeekFormatProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.EvenMonthsBrushProperty Field

WeekRangeSettings.EvenMonthsBrushProperty Field
[image]

Identifies the EvenMonthsBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EvenMonthsBrushProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly EvenMonthsBrushProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.GroupWeekendsProperty Field

WeekRangeSettings.GroupWeekendsProperty Field
[image]

Identifies the GroupWeekends dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupWeekendsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly GroupWeekendsProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.GroupWeekendsTitleSeparatorProperty Field

WeekRangeSettings.GroupWeekendsTitleSeparatorProperty Field
[image]

Identifies the GroupWeekendsTitleSeparator dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GroupWeekendsTitleSeparatorProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly GroupWeekendsTitleSeparatorProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.HeaderStyleProperty Field

WeekRangeSettings.HeaderStyleProperty Field
[image]

Identifies the HeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty HeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly HeaderStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.OddMonthsBrushProperty Field

WeekRangeSettings.OddMonthsBrushProperty Field
[image]

Identifies the OddMonthsBrush dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OddMonthsBrushProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly OddMonthsBrushProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.ReferenceHeaderHeightProperty Field

WeekRangeSettings.ReferenceHeaderHeightProperty Field
[image]

Identifies the ReferenceHeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ReferenceHeaderHeightProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ReferenceHeaderHeightProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.SelectedElementsHeaderStyleProperty Field

WeekRangeSettings.SelectedElementsHeaderStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsHeaderStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.SelectedElementsStyleProperty Field

WeekRangeSettings.SelectedElementsStyleProperty Field
[image]

Identifies the SelectedElementsHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SelectedElementsStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SelectedElementsStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.ShowDayOfWeekProperty Field

WeekRangeSettings.ShowDayOfWeekProperty Field
[image]

Identifies the ShowDayOfWeek dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowDayOfWeekProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ShowDayOfWeekProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.SubHeaderStyleProperty Field

WeekRangeSettings.SubHeaderStyleProperty Field
[image]

Identifies the SubHeaderStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SubHeaderStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly SubHeaderStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.TimePeriodHeaderHeightProperty Field

WeekRangeSettings.TimePeriodHeaderHeightProperty Field
[image]

Identifies the TimePeriodHeaderHeight dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TimePeriodHeaderHeightProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TimePeriodHeaderHeightProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.TitleFormatProperty Field

WeekRangeSettings.TitleFormatProperty Field
[image]

Identifies the TitleFormat dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFormatProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFormatProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.TitleSeparatorProperty Field

WeekRangeSettings.TitleSeparatorProperty Field
[image]

Identifies the TitleSeparator dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleSeparatorProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly TitleSeparatorProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.ViewStyleProperty Field

WeekRangeSettings.ViewStyleProperty Field
[image]

Identifies the ViewStyle dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ViewStyleProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly ViewStyleProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.VisibleColumnsProperty Field

WeekRangeSettings.VisibleColumnsProperty Field
[image]

Identifies the VisibleColumns dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleColumnsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleColumnsProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.VisibleRowsProperty Field

WeekRangeSettings.VisibleRowsProperty Field
[image]

Identifies the VisibleRows dependency property.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty VisibleRowsProperty
Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleRowsProperty As DependencyProperty

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings Constructor

WeekRangeSettings Constructor
[image]

Initializes a new instance of the WeekRangeSettings class.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public WeekRangeSettings ()
Visual Basic [image] Copy Code

Public Sub New ()

See Also

WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings Properties

WeekRangeSettings Properties
[image]

Public Properties

Name | Description
CalendarStyle | Gets or sets the CalendarStyle used to paint calendar elements that don't have a distinct style assigned to them.
CellSettings | Gets or sets the CellSettings object used to customize the visualization of days in a WeekRange view.
DayNamesHeaderHeight | Gets or sets the height of the day-names header in the WeekRange view.
DayOfWeekFormat | Gets or sets the display format of the names of the days of the week.
EvenMonthsBrush | Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.
GroupWeekends | Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.
GroupWeekendsTitleSeparator | Gets or sets the separator string displayed between the weekend day names when GroupWeekends is enabled.
HeaderStyle | Gets or sets the appearance style used to paint the view headers.
OddMonthsBrush | Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.
ReferenceHeaderHeight | Gets or sets the height of the reference header in the WeekRange view.
SelectedElementsHeaderStyle | Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.
SelectedElementsStyle | Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.
SubHeaderStyle | Gets or sets the appearance style used to paint the view subheaders.
TimePeriodHeaderHeight | Gets or sets the height of the time-period header in the WeekRange view.
TitleFormat | Gets or sets the format of the calendar's title.
TitleSeparator | Gets or sets the string used as a separator in the calendar's title.
ViewStyle | Gets or sets the style of the WeekRange view.
VisibleColumns | Gets or sets the number of columns visible when the GroupType is enabled.
VisibleRows | Gets or sets the number of weeks visible at a time.

See Also

WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.CalendarStyle Property

WeekRangeSettings.CalendarStyle Property
[image]

Gets or sets the CalendarStyle used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle CalendarStyle { get; set; }
Visual Basic [image] Copy Code

Public Property CalendarStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of calendar UI elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.CellSettings Property

WeekRangeSettings.CellSettings Property
[image]

Gets or sets the CellSettings object used to customize the visualization of days in a WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CellSettings CellSettings { get; set; }
Visual Basic [image] Copy Code

Public Property CellSettings As CellSettings

Property Value

An instance of the CellSettings class. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.DayNamesHeaderHeight Property

WeekRangeSettings.DayNamesHeaderHeight Property
[image]

Gets or sets the height of the day-names header in the WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int DayNamesHeaderHeight { get; set; }
Visual Basic [image] Copy Code

Public Property DayNamesHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the day-names header in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.DayOfWeekFormat Property

WeekRangeSettings.DayOfWeekFormat Property
[image]

Gets or sets the display format of the names of the days of the week.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public DayOfWeekFormat DayOfWeekFormat { get; set; }
Visual Basic [image] Copy Code

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

A member of the DayOfWeekFormat enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.EvenMonthsBrush Property

WeekRangeSettings.EvenMonthsBrush Property
[image]

Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush EvenMonthsBrush { get; set; }
Visual Basic [image] Copy Code

Public Property EvenMonthsBrush As Brush

Property Value

An instance of a Brush-derived class used to fill the even month cells.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
OddMonthsBrush Property


MindFusion.Scheduling.Silverlight.WeekRangeSettings.GroupWeekends Property

WeekRangeSettings.GroupWeekends Property
[image]

Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool GroupWeekends { get; set; }
Visual Basic [image] Copy Code

Public Property GroupWeekends As Boolean

Property Value

true to display weekend days together; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.GroupWeekendsTitleSeparator Property

WeekRangeSettings.GroupWeekendsTitleSeparator Property
[image]

Gets or sets the separator string displayed between the weekend day names when GroupWeekends is enabled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string GroupWeekendsTitleSeparator { get; set; }
Visual Basic [image] Copy Code

Public Property GroupWeekendsTitleSeparator As String

Property Value

A string specifying the separator text.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.HeaderStyle Property

WeekRangeSettings.HeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view headers.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle HeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property HeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of header elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
CalendarStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.OddMonthsBrush Property

WeekRangeSettings.OddMonthsBrush Property
[image]

Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public Brush OddMonthsBrush { get; set; }
Visual Basic [image] Copy Code

Public Property OddMonthsBrush As Brush

Property Value

An instance of a Brush-derived class used to fill the odd month cells.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
EvenMonthsBrush Property


MindFusion.Scheduling.Silverlight.WeekRangeSettings.ReferenceHeaderHeight Property

WeekRangeSettings.ReferenceHeaderHeight Property
[image]

Gets or sets the height of the reference header in the WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int ReferenceHeaderHeight { get; set; }
Visual Basic [image] Copy Code

Public Property ReferenceHeaderHeight As Integer

Property Value

A non-negative integer value specifying the header height.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

This header is where the contact, task, location or resource names are displayed, depending on the calendar GroupType.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.SelectedElementsHeaderStyle Property

WeekRangeSettings.SelectedElementsHeaderStyle Property
[image]

Gets or sets the header appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsHeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SelectedElementsHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected header elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
SelectedElementsStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.SelectedElementsStyle Property

WeekRangeSettings.SelectedElementsStyle Property
[image]

Gets or sets the appearance of selected calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SelectedElementsStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SelectedElementsStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of selected elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
SelectedElementsHeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.ShowDayOfWeek Property

WeekRangeSettings.ShowDayOfWeek Property
[image]

Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public bool ShowDayOfWeek { get; set; }
Visual Basic [image] Copy Code

Public Property ShowDayOfWeek As Boolean

Property Value

true to display the day names; otherwise, false.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The day names are obtained from the DateTimeFormat property of the Calendar class, if it isn't a null reference (Nothing in Visual Basic), or from the corresponding DateTimeFormat property of the CultureInfo object assigned to calendar's Culture.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.SubHeaderStyle Property

WeekRangeSettings.SubHeaderStyle Property
[image]

Gets or sets the appearance style used to paint the view subheaders.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public CalendarStyle SubHeaderStyle { get; set; }
Visual Basic [image] Copy Code

Public Property SubHeaderStyle As CalendarStyle

Property Value

A CalendarStyle object specifying the style of subheader elements. This property cannot be null (Nothing in Visual Basic).

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Silverlight Namespace
HeaderStyle Property
CalendarStyle Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.TimePeriodHeaderHeight Property

WeekRangeSettings.TimePeriodHeaderHeight Property
[image]

Gets or sets the height of the time-period header in the WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int TimePeriodHeaderHeight { get; set; }
Visual Basic [image] Copy Code

Public Property TimePeriodHeaderHeight As Integer

Property Value

A non-negative integer value specifying the header height in pixels.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.TitleFormat Property

WeekRangeSettings.TitleFormat Property
[image]

Gets or sets the format of the calendar's title.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string TitleFormat { get; set; }
Visual Basic [image] Copy Code

Public Property TitleFormat As String

Property Value

A string specifying the display format.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.TitleSeparator Property

WeekRangeSettings.TitleSeparator Property
[image]

Gets or sets the string used as a separator in the calendar's title.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public string TitleSeparator { get; set; }
Visual Basic [image] Copy Code

Public Property TitleSeparator As String

Property Value

A string specifying the separator text.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.ViewStyle Property

WeekRangeSettings.ViewStyle Property
[image]

Gets or sets the style of the WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public WeekRangeViewStyle ViewStyle { get; set; }
Visual Basic [image] Copy Code

Public Property ViewStyle As WeekRangeViewStyle

Property Value

A member of the WeekRangeViewStyle enumeration.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.VisibleColumns Property

WeekRangeSettings.VisibleColumns Property
[image]

Gets or sets the number of columns visible when the GroupType is enabled.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int VisibleColumns { get; set; }
Visual Basic [image] Copy Code

Public Property VisibleColumns As Integer

Property Value

A positive integer value specifying how many columns are visible simultaneously.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

In the week range view schedule data can be displayed in several columns grouped by contact, location, task or resource, as set in Calendar.GroupType. This property determines how many parallel columns are visible at a time.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeSettings.VisibleRows Property

WeekRangeSettings.VisibleRows Property
[image]

Gets or sets the number of weeks visible at a time.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public int VisibleRows { get; set; }
Visual Basic [image] Copy Code

Public Property VisibleRows As Integer

Property Value

The allowed values range from 1 to 10.

Unsetting the Property Value

Unset the local value of this property to use the corresponding value from the current theme. To unset the property value, call ClearValue on the settings containing the property and pass a reference to the DependencyProperty representing the property.

Remarks

Used only when ViewStyle is set to WeekPerRow.

See Also

WeekRangeSettings Members
WeekRangeSettings Class


MindFusion.Scheduling.Silverlight.WeekRangeViewStyle Enumeration

WeekRangeViewStyle Enumeration
[image]

Specifies whether there are multiple weeks displayed in WeekRange view.

Namespace: MindFusion.Scheduling.Silverlight
Assembly: MindFusion.Scheduling.Silverlight

Syntax

C# [image] Copy Code

public enum WeekRangeViewStyle
Visual Basic [image] Copy Code

Public Enumeration WeekRangeViewStyle

Members

Member name | Description
SingleWeek | The calendar view displays a single week at a time.
WeekPerRow | The calendar view displays several weeks at a time.

See Also


Technical Support

Detailed information about everything connected with software products offered by MindFusion - online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu [image] . The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at support@mindfusion.eu [image] or by phone at +359 877 65 22 51.

If you need a higher support level, you can use the premium support [image] .

In addition, you can post a question on the MindFusion.Scheduling for Silverlight discussion board here:

http://mindfusion.eu/Forum/YaBB.pl?board=scheduling_silverlight

or visit our Help Desk site:

http://www.mindfusion.eu/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding MindFusion.Scheduling for Silverlight. We take in account the opinion of every single person who has shown interest in our products.


MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

MindFusion.Reporting for WinForms

A .NET reporting component.

Product Information
Download

WpfDiagram

A flow-diagramming component for WPF.

Product Information
Download

MindFusion.Diagramming for WinForms

A flow-diagramming component for .NET.

Product Information
Download

FlowChartX

An ActiveX flow-diagramming component.

Product Information
Download

NetDiagram

An ASP.NET flow-diagramming component.

Product Information
Download

JDiagram

A flow-diagramming component for Java.

Product Information
Download

PocketChart

A flow-diagramming component for the .NET Compact Framework.

Product Information
Download

MindFusion.Scheduling for WinForms

Time-management and task-planning component for .NET.

Product Information
Download

PocketPlanner

Time-management and task-planning component for the .NET Compact Framework.

Product Information
Download

MindFusion.Charting

A charting component for .NET WinForms and WebForms.

Product Information
Download

InSight Diagrammer

Ready-to-use software for drawing of diagrams and charts.

Product Information
Download

XML Viewer

Freeware product for viewing and editing *.xml files.

Product Information
Download


MindFusion.Scheduling.Appointment.LoadFrom Method

Appointment.LoadFrom Method
[image]

Overload List

Name | Description
Appointment.LoadFrom (XElement, XmlSerializationContext) | Loads appointment data from an XML document.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.SaveTo Method

Appointment.SaveTo Method
[image]

Overload List

Name | Description
Appointment.SaveTo (XElement, XmlSerializationContext) | Saves the appointment data to an XML document.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.LoadFrom Method

Contact.LoadFrom Method
[image]

Overload List

Name | Description
Contact.LoadFrom (XElement, XmlSerializationContext) | Loads contact data from an XML document.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.SaveTo Method

Contact.SaveTo Method
[image]

Overload List

Name | Description
Contact.SaveTo (XElement, XmlSerializationContext) | Saves the contact data to an XML document.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.SaveTo Method

Item.SaveTo Method
[image]

Overload List

Name | Description
Item.SaveTo (XmlElement, XmlSerializationContext) | Saves the item data to an XML document.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.LoadFrom Method

Location.LoadFrom Method
[image]

Overload List

Name | Description
Location.LoadFrom (XElement, XmlSerializationContext) | Loads location data from an XML document.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.SaveTo Method

Location.SaveTo Method
[image]

Overload List

Name | Description
Location.SaveTo (XElement, XmlSerializationContext) | Saves the location data to an XML document.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.LoadFrom Method

Recurrence.LoadFrom Method
[image]

Overload List

Name | Description
Recurrence.LoadFrom (XElement, XmlSerializationContext) | Loads the recurrence data from an XML document.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.SaveTo Method

Recurrence.SaveTo Method
[image]

Overload List

Name | Description
Recurrence.SaveTo (XElement, XmlSerializationContext) | Saves the recurrence data to an XML document.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.LoadFrom Method

Reminder.LoadFrom Method
[image]

Overload List

Name | Description
Reminder.LoadFrom (XElement, XmlSerializationContext) | Loads reminder data from an XML document.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.SaveTo Method

Reminder.SaveTo Method
[image]

Overload List

Name | Description
Reminder.SaveTo (XElement, XmlSerializationContext) | Saves the reminder data to an XML document.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.LoadFrom Method

Resource.LoadFrom Method
[image]

Overload List

Name | Description
Resource.LoadFrom (XElement, XmlSerializationContext) | Loads resource data from an XML document.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.SaveTo Method

Resource.SaveTo Method
[image]

Overload List

Name | Description
Resource.SaveTo (XElement, XmlSerializationContext) | Saves the resource data to an XML document.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.LoadFrom Method

Task.LoadFrom Method
[image]

Overload List

Name | Description
Task.LoadFrom (XElement, XmlSerializationContext) | Loads task data from an XML document.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.SaveTo Method

Task.SaveTo Method
[image]

Overload List

Name | Description
Task.SaveTo (XElement, XmlSerializationContext) | Saves the task data to an XML document.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace