Introduction

PocketPlanner is a software component that can be used to present calendars and timetables to users and let them edit the schedule information interactively. It is implemented as a .NET Compact Framework Windows Forms control and can be easily integrated into any application targeting the Microsoft .NET platform. By providing your software with ready to use capabilities for visualizing and editing schedule data, PocketPlanner saves you from hundreds of hours of coding and debugging efforts.

PocketPlanner can display a schedule in several view types, such as:

  • Range of months, displaying several months in a grid, each of the months displaying its days in a smaller grid;
  • Single month view, displaying the days of a month and allowing scrolling to previous or next month;
  • Range of weeks, displaying days in a grid in which the days of a week occupy a single row;
  • Range of days, displaying a single day on each row or column;
  • Timetable view, displaying the allotment of resources to distinct hours of a day; the columns of this view can be grouped by location, task or contact;
  • Resource view, displaying the distribution of resources over a period of time;

PocketPlanner provides intuitive user-interaction model for creating or editing appointments and events in a schedule. In addition, its programming interface places at your disposal many useful functions, ranging from XML serialization to displaying reminders and checking what occurrences of recurrent events happen in a specified time interval.

The control has been tested with the most popular .NET development environments and programming languages, and can be used to create applications in C#, VB.NET and Delphi.NET.

All obsolete members and types are marked with the [image] icon.

Note

Important! All members marked as obsolete are going to be removed in the next major release.

© 2008 MindFusion


General Information

The PocketPlanner control

  • Redistribution is royalty free
  • Assembly is strong-named
  • Is digitally signed
  • Can be purchased with source code
  • Is written in C#

The Schedule component

  • Allows definition of custom-typed events
  • Supports recurring events
  • Can be persisted into XML documents

Views

  • Timetable view
  • Resource view
  • List view
  • Month view
  • WeekRange view
  • MonthRange view

User interaction

  • In-place item editing
  • Interactive item creation and modification
  • Single and multiple item selection
  • Scrolling
  • Automatic scrolling while dragging items with the mouse
  • Column resize in Timetable view
  • Expand and collapse rows in Resource view
  • Moving to the next / previous day, month or year in various views

Programming

  • Programmatic access to both schedule objects and the calendar methods and properties
  • Numerous properties for customizing the appearance and behavior of every calendar view
  • Rich event set
  • More than 2000! classes, methods, properties and events

Output

  • To display via Windows Forms

Appearance

  • Fully customizable style-based appearance
  • Customizable fonts, colors, shadows and alignments of displayed text
  • Images can be associated with calendar elements
  • Item shadows
  • Custom painting of various elements
  • User-assigned mouse cursors
  • Rich choice of pen and brush styles
  • Themes


What's New in this Release

The list below describes recent changes and additions to PocketPlanner:

New in Version 4.5

Improved styles

The Style class now exposes several new properties that can be used to enable text shadows. The properties are HeaderTextShadowColor, HeaderTextShadowOffset, HeaderTextShadowStyle, TextShadowColor, TextShadowOffset and TextShadowStyle. These new properties automatically apply to all elements that are currently using Style class for their appearance.

Updated icons

Several built-in icons have been replaced to improve appearance.

Note

All methods and properties marked as obsolete ( [image]) will be removed in the next major release.


Version History

The list below describes changes in all versions of PocketPlanner:

New in Version 4.4

Visual Studio 2008 support

The PocketPlanner package now includes .NET 3.5 assemblies and sample VS2008 projects.

Improved serialization

The serialization of the PocketPlanner Schedule has been internally redesigned to allow easier custom item and tag serialization and more robust compatibility with previous file format versions. All schedule file formats post version 3 should be supported by the new serialization.

The following list summarizes the additions and improvements to the serialization system:

  • Improved custom item serialization: The custom item classes should now override the SaveTo and LoadFrom methods of the Item or Appointment classes that accept XmlSerializationContext arguments. These new context classes provide a vast range of new methods that can help you serialize and deserialize various data types with ease.
  • Tag values can now be serialized through the new SerializeTag and DeserializeTag events.

Enhanced List view

The List view has been substantially improved. The following list describes the new features implemented in the view:

  • Custom item snapping: It is now possible to define different snapping unit for items than the one specified by CellUnit property. In order to enable custom snapping, use the two new properties - EnableSnapping and SnapUnit.
  • The new ItemOrientation property enables you to explicitly specify the item orientation.
  • Free dragging: Users can now be allowed to drag items anywhere in the view. Once dragged, the items retain their new position. In order to enable this functionality, use the new FreeDrag property.
  • The items that do not fit in the view due to insufficient space can now be scrolled through by enabling the new EnableVirtualItemSpace property.
  • Navigation buttons similar to those in the Timetable and SingleMonth views can now be enabled for the List view as well by using the new ShowNavigationButtons property.
  • A subheader can now be displayed under the main view header by specifying the new Subheader value for the HeaderStyle property. The new header can display an arbitrary number of subdivisions of the main header's time interval, as specified by the new SubheaderDivisions property.

Miscellaneous

  • The new ItemModificationStyle property of the Calendar class can now be used to specify the way items are rendered and laid out while they are being modified interactively.
  • The new CellLayout property of the MonthSettings class can be used to specify the layout of cells in SingleMonth and MonthRange views.
  • The new ItemScroll property lets you specify the current scrolling position in a List view whose EnableVirtualItemSpace property is enabled.
  • The new HScrollerSmallChange and VScrollerSmallChange properties lets you define the SmallChange value for the horizontal and vertical scrollbars respectively.
  • The Schedule class now provides the new GetFreePeriod methods that enable you to find an unoccupied time interval with a desired duration.

New in Version 4.3

List View

The new List view replaces the old DayRange view. The List view displays an arbitrary long sequences of seconds, minutes, hours, weeks, months and years, in addition to the day sequences supported by the DayRange view. The List view also supports grouping.

The names of certain properties, methods, events and classes have been changed in order to better represent the generalized nature of the List view. If you are using the DayRange view, you will have to rename the members and classes related to it. See below for more details.

Miscellaneous

  • The Position enumeration now contains new value (None), which when specified indicates that the headers will not be displayed.
  • The new CellUnits property of the ListViewSettings class specifies the time resolution of the cells in the list view. The property value can be any of the TimeUnit members.
  • The TimelineSettings class now exposes three new properties: NowColor, NowFillColor and ShowCurrentTime. These properties indicate whether and how to display the current time in a timeline of a Resource view. The new properties act in a way similar to the corresponding properties with the same names in the TimetableSettings class.
  • The WeekRangeHeaderStyle enumeration now contains the Reference value, which indicates whether the view header should display the name of the corresponding resource when grouping is enabled.
  • The property CurrentTime has been added to the Calendar class. This property may be used to 'override' the current system time.

API changes

  • The following table lists all members, classes and enumerations whose names have been changed:

Old name | New name
Calendar.OnDayRangeHeaderClick | Calendar.OnListViewHeaderClick
Calendar.DayRangeSettings | Calendar.ListViewSettings
Calendar.DayRangeSettings | Calendar.ListViewHeaderClick
CalendarView.DayRange | CalendarView.List
CustomDrawElements.DayHeader | CustomDrawElements.CellHeader
CustomDrawElements.DayContents | CustomDrawElements.CellContents
CustomDrawElements.DayRangeHeader | CustomDrawElements.ListViewHeader
CustomDrawElements.DayRangeHeaderCell | CustomDrawElements.ListViewHeaderCell
DaySettings | CellSettings
DayRangeHeaderStyles | ListViewHeaderStyles
DayRangeHeaderStyles.SubheaderPerDay | ListViewHeaderStyles.SubheaderPerCell
DayRangeSettings | ListViewSettings
DayRangeSettings.DaySettings | ListViewSettings.CellSettings
DayRangeSettings.DaySpacing | ListViewSettings.CellSpacing
DayRangeSettings.NumberOfDays | ListViewSettings.NumberOfCells
DayRangeSettings.VisibleDays | ListViewSettings.VisibleCells

  • The following classes in the MindFusion.Scheduling.Outlook namespace have been renamed as well to improve readability:

Old name | New name
Importer | OutlookImporter
Exporter | OutlookExporter

New in Version 4.2.1

Miscellaneous

  • A new EnableOptimization property has been added to the Calendar class, which enables optimization when rendering schedule items.
  • An info header can now optionally be displayed in Timetable views. You can enable this info header through the new ShowInfoHeader property. The size and background brush can be specified through InfoHeaderSize and InfoHeaderBrush.
  • The new CellOffset property of the ResourceViewSettings class can be used to specify the offset of the first cell in a Resource view from the view's origin.

Bug fixes

  • A memory leak when using recurring items has been fixed.

New in Version 4.2

Miscellaneous

  • The Style class now exposes 8 new properties specifying the left, top, right and bottom margins of normal and header texts accordingly.
  • The new GetVisibleItems method allows you to get a collection of all visible items.
  • The transparent color of images used within the control can now be specified through the new ColorKey property.

New in Version 4.1

Improved recurrence

The recurrence in PocketPlanner has been extended with a new recurrence type - ByTimeInterval. The new recurrence type allows recurrences over arbitrary period of time, as specified by the new Interval property. Furthermore, the recurrence can now be applied to items of arbitrary length. In previous versions the recurrence could support items up to 1 day in length.

Miscellaneous

  • Cells can now be deselected by holding down the CTRL key and clicking on them. In previous versions holding the CTRL key always selected the cells.
  • Items can now be interactively created by clicking and dragging in the control. To enable this feature, set Calendar.EnableDragCreate to true.
  • Interactive item cloning can now be canceled by right clicking while dragging the cloned items.
  • New click event has been added - MonthWeekHeaderClick in the Calendar class. The event is fired when the user clicks on the week header in a SingleMonth and MonthRange views.
  • New events added to the Calendar control - ItemSelecting and ItemDeselecting, which are fired when the item is about to be selected or deselected respectively.
  • The TimetableSettings class now exposes a new property - EnableDayItems, which can be used to prevent all day items and items longer than one day to appear in the day header.
  • More precise control over the item interaction can now be achieved through the use of the new AllowMove, AllowChangeStart and AllowChangeEnd properties.
  • The reminder checks in the schedule can now be turned off, be settings DisableReminders to true.
  • The text displayed in week headers in the SingleMonth and MonthRange views is now formatted according to the new WeekHeaderFormat property.
  • Various minor improvements and bug fixes.

Removed members

  • StartHour, StartMinute, EndHour and EndMinute properties have been removed. Now the recurrence uses the start and end time of the associated master item instead. This was done to enable recurring items with arbitrary length and over more than one day.
  • The constructors of several EventArgs-derived classes have been removed, since these classes were not intended to be instantiated externally.

Obsolete members

  • The following properties are considered obsolete: Item.ImageIndex and Appointment.ImageIndex. Instead use the ImageIndex property from the corresponding Style.

API changes

  • Calendar.ItemSelectionChanged - the event type has been changed to ItemSelectionEventHandler.
  • Calendar.DateClick - the event type has been changed to ResourceDateEventHandler.

New in Version 4

Miscellaneous

  • Users can now interactively clone items by holding specific modifier key when dragging the item as specified in the new ItemCloneKey property.
  • More sophisticated user interaction control can be achieved through the use of the new properties AllowInplaceCreate and EnableKeyboard.
  • The Selection object has been improved to support setting the selection to a specific resource in a grouped view. New properties has also been added which allow getting the resource related to the current selection.
  • The Style class now allows settings the width and color of individual borderlines. For example it is possible to specify different width and color to the left, top, right and bottom borders of an element.
  • The Timetable view now supports reverse grouping, that is, grouping first by resource and then by date. To reverse grouping, use the new ReverseGrouping property.
  • The Timetable view can now operate on levels other than the cell level. For example users can select only parts of cells and move/resize items disregarding snapping to cells. Check the new properties TimetableSettings.EnableSnapping and TimetableSettings.SnapInterval.
  • The Timetable and Resource views now provide a new property - TimetableSettings.ExpandActiveItemOn and ResourceViewSettings.ExpandActiveItemOn respectively, which allows turning off collision detection for items when certain operation are performed on them. For example, you can turn off collision detection for an item when it is moved.

Obsolete members

  • The following properties are considered obsolete: Style.BorderColorLight, Style.BorderColorDark, Style.BorderWidth, Style.HeaderBorderColorLight, Style.HeaderBorderColorDark, Style.HeaderBorderWidth. Instead use the new set of border properties.

API changes

  • The enumeration ShadowStyle has been moved from the MindFusion.Scheduling.Compact namespace to the MindFusion.Scheduling namespace.

New in Version 3.2

Miscellaneous

  • The DayRange view now supports grouping.
  • Improved item ordering. Items in the same day in a DayRange, WeekRange, SingleMonth and MonthRange views are ordered according to their start time now. They were pseudo-randomly ordered in previous versions. The Priority of items can still be used to break default ordering.
  • Improved interaction with items in the Resource view. The items now have resizing bands when selected similarly to the items in the timetable view.
  • The new property TimetableSettings.SelectWholeDayOnHeaderClick now controls whether the whole day is selected when the user clicks on the column header in a Timetable view.
  • Selection now supports non-contiguous time ranges. The two selection properties StartDate and EndDate are considered obsolete and should no longer be used. The new property Ranges should be used instead. Time ranges can be added and removed from the selection programmatically by calling the new Add and Remove methods respectively.
  • The new property SnapUnitCount now makes items in resource view snap at arbitrary intervals.
  • Other minor changes.

Obsolete members

  • As stated above the properties StartDate and EndDate of the Selection class are now considered obsolete and their use should be avoided.

API changes

  • The Save and Load methods in PocketPlanner in Schedule, Item, Contact, and so on, classes were renamed to SaveTo and LoadFrom accordingly to match the corresponding methods in Planner.NET.

New in Version 3.1

Miscellaneous

  • The resource view now supports filtering. Particularly certain days of the week can be hidden through the use of the new HiddenDays property. Furthermore the visible part of the day can be limited by the VisibleStartTime and VisibleEndTime properties. The filtering only works in an Hour and partially in a Day view.
  • The bounding rectangle of an item can now be obtained at any time by calling GetItemBounds.
  • The new event ItemModificationCanceled is now triggered when an interactive item modification is canceled.
  • Other minor changes.

API changes

  • The methods EnsureVisible, ExpandResourceRow, CollapseResourceRow and IsResourceRowExpanded now take as a parameter a reference to a Resource instead of Object. This ensues from the new design introduced in version 3 where contacts, locations and tasks all derive from Resource.
  • Several other properties have had their type changed from Object to Resource.
  • The ItemModified event is now declared as ItemModifiedEventHandler (was ItemEventHandler in the previous versions). The ItemModifiedEventArgs object supplied to the handlers of this event contains additional information about the initial state of the modified item.

New in Version 3

Resource view

A new view type, called Resource view, has been implemented. It displays the distribution of resources over an arbitrary period of time. Each resource is displayed in its own row in the view, and the horizontal position of items represents their time span. See Resource view for more information.

Resources

The Resource class implements a new general type of resources that can be assigned to schedule items along with contacts, locations and tasks.

Styles and themes

Styles have been redesigned to support cascading propagation of style attributes. For example, when a distinct DateStyle is defined for a range of dates, only the settings that are explicitly set in the custom style are used. Attributes defined in more specific styles override the attributes defined in more general styles. If a style leaves some attribute values undefined, the ones specified in a more general style or the current theme are used.

The themes have been redesigned too, so that applying a theme to the calendar in design time is a reversible operation. In previous versions applying a theme caused a lot of modifications of various settings of the control, which were hard to control or undo.

Timetable view

Now the timetable view can display cells with accuracy down to the second. The deprecated property MinutesPerCell has been replaced by CellTime, which allows specifying arbitrary periods of time for timetable cells with seconds precision. See below for more API changes.

Miscellaneous

  • Three new methods added to the Calendar class allow manipulation of resource rows in a resource view: CollapseResourceRow, ExpandResourceRow and IsResourceRowExpanded.
  • The minimal length of items created interactively can now be controlled via the MinItemLength property.
  • The Timetable view can be zoomed in or out. To enable zooming, set the UseZoom property of the calendar's TimetableSettings. The ZoomFactor property of the latter is used to specify the zoom level.
  • Resources property has been added to the Item class. It can be used to associate Resource objects with an item.

API changes

  • In order to support cascading styles and themes, the type of all boolean properties has been changed to State in the following classes: DayRangeSettings, DaySettings, ItemSettings, MonthSettings, Selection, TimetableSettings and WeekRangeSettings.
  • In order to support cascading styles and themes, a new field 'Unspecified' has been added to the following enumerations: ControlAppearance, DayRangeHeaderStyles, MonthHeaderStyles, MonthRangeHeaderStyles, MonthWeekHeaderStyle, Orientation, Position, SelectionStyle, ShadowStyle, MinuteFormat, WeekRangeHeaderStyle and WeekRangeViewStyle. This field is used to indicate that the properties of these types are not set.
  • ImageAlignment - the field Invalid has been changed to Unspecified.
  • Calendar.DisplayDate renamed to Calendar.Date.
  • DaySettings has been removed from the Calendar class. Now most settings classes contain a separate DaySettings instance, thus changes in the day settings of one view does not affect the others. The settings classes that now incorporate DaySettings object are MonthSettings, MonthRangeSettings and WeekRangeSettings.
  • StartDate and EndDate have been removed from the WeekRangeSettings class. The Calendar.Date and Calendar.EndDate properties are used for the same purpose.
  • Calendar.DetachThemeOnChange has been removed.
  • CustomDrawArgs.StartMinute and CustomDrawArgs.EndMinute have been changed to CustomDrawArgs.StartTime and CustomDrawArgs.EndTime respectively.
  • TimetableSettings.MinutesPerCell is replaced by TimetableSettings.CellTime. The assignment 'settings.MinutesPerCell = 15;' translates to 'settings.CellTime = TimeSpan.FromMinutes(15);'


Programming Interface Overview

The PocketPlanner API is divided in two major parts, implemented in different .NET namespaces. The schedule data is represented by instances of the Schedule class and the helper Appointment, Task, Location, Contact and Resource classes, implemented in the MindFusion.Scheduling namespace. The calendar views are implemented by the Calendar class in the MindFusion.Scheduling.Compact namespace.


The Schedule

The Schedule class represents the data displayed by PocketPlanner calendar views. The schedule contains a collection of schedule items defined by the Item abstract class and implemented by the Appointment class. Appointment objects contain references to instances of the miscellaneous Task, Location, Contact and Resource classes, which are also contained in the respective collection members of the Schedule class.

If your application has to process other types of schedule data items, create a class for each item type and inherit it from Item or Appointment. All methods and properties defined in Item are abstract, so if a class inherits from it, that class must implement all members of the Item class. On the other hand, if a class derives from Appointment, it can just add its own distinct properties and override the SaveTo and LoadFrom methods to implement serialization of the new members of the class. Custom schedule item classes must be registered for serialization via the RegisterItemClass method of the Schedule.


Schedule Items

Events scheduled to occur at an appointed time are represented in PocketPlanner by the abstract class Item. Item comprises the information that should be defined for all schedule events. For example, the StartTime and EndTime properties specify the time and duration of an event. The Recurrence property lets you create recurrent events that occur repeatedly following some recurrence pattern. There are several descriptive properties that define additional information about an item, such as Priority, HeaderText and DescriptionText. The class also defines methods that support serialization in XML.

It is possible to associate resources with scheduled events via the Resources, Contacts, Location and Task properties of Item. These properties contain objects from the Resource, Contact, Location and Task classes respectively.

The appearance of items when viewed in the Calendar can be set via the Style property. It lets you define the color, alignment and style of various elements of the item visualization, such as frame lines, fill, header and description texts, icon images, and so on.

The abstract class Item is derived by the concrete class Appointment, which can be readily used in your applications. You could also define your own event class, which derives either from Appointment or Item. In order to integrate your custom class into the calendar API and user interface, you must do the following:

  • Provide parameterless constructor to let users create items of the custom class interactively;
  • Override the SaveTo / LoadFrom methods if you have any additional data fields in your custom class and register the class for serialization using the Schedule.RegisterItemClass method;
  • Override CopyOccurrence to support recurrence of the custom item. Also ensure you call MarkException on the associated recurrence whenever a custom property of the new item changes.


Recurrence

Schedule items can recur in time, following a specific recurrence pattern. For example an event could be set to occur each Monday, on the third day of each month, and so on. Assign a Recurrence object to item's Recurrence property to specify the time period, pattern, and other properties for the repetition of that item in time.

Once a recurrent item is added to the Schedule of a Calendar instance, the calendar creates multiple occurrences of the item in the time period being visualized. Occasionally you will get references to these occurrences passed as arguments to the calendar events or returned by the calendar methods. Occurrences are instances of the same class as of the item that was set recurrent, however their RecurrenceState property is set to Occurrence. If a user moves a recurrent event's occurrence in the calendar, thus changing its start or end time, or changes the occurrence text, an exception is created. Exceptions are item instances whose RecurrenceState is set to Exception.

Note

Recurrence is not automatically supported in user classes derived from Item or Appointment.


Resources

PocketPlanner lets you associate resources with scheduled events via the Resources, Contacts, Location and Task properties of Item objects. These properties contain objects from the Resource, Contact, Location and Task classes respectively. If you need to assign a resource to schedule items, you must also add the resource to the appropriate collection in the Schedule class, namely Resources, Contacts, Locations or Tasks.

The timetable, week range and resource views let you display distinct rows or columns for selected resources and to group items by their associated resources. To enable that, add the resources of interest to the appropriate resource collection of the Calendar object (that is, Resources, Contacts, Locations and Tasks respectively) and set the Calendar.GroupType property to the appropriate value.

The class Resource is the base class of Contact, Location and Task. It defines an Id property, which must be unique among all resources in the schedule, and a pair of SaveTo and LoadFrom methods, which implement serialization.

You can define custom resources by deriving from Resource or from any of the Resource-derived classes. Custom resources are added to the schedule by adding them to the Calendar.Schedule.Resources collection. In order to enable serialization of custom resources, you have to provide a parameterless constructor and override the SaveTo / LoadFrom methods in the custom resource class. In addition you must register that class by calling Schedule.RegisterResourceClass before any deserialization code takes place.


Serializing the Schedule

The SaveTo and LoadFrom methods of the Schedule class let you save and load complete schedules to/from files or XML documents. The SaveToString and LoadFromString methods let you encode or decode a schedule into/from an ASCII string, which could be used to store the whole schedule in a database table field or as a part of a larger file.

The serialization methods of the Schedule work by invoking the SaveTo and LoadFrom methods of the Item and Resource classes or the classes derived from them. If you define your own Item or Resource-derived classes, you must override the SaveTo and LoadFrom methods and register the classes for serialization by calling the RegisterItemClass and RegisterResourceClass methods of the Schedule.


Calendar and Timetable Views

The Calendar class implements several types of views that can be enabled by setting the calendar's CurrentView property. These views provide different outlooks over the schedule data and allow for different user interaction behavior. By changing the views from more general ones to more specialized ones, your application can implement drilling down through the schedule data. At this time PocketPlanner supports the following views:

  • The Month Range View displays a range of months or years.
  • The Single Month View displays a single month and lets the user scroll to the previous or next month.
  • The Week Range View displays a grid in which the days of a week occupy a single row.
  • The List View displays a list of cells where each cell represents an arbitrary time interval, such as second, minute, hour, and so on.
  • The Timetable View displays the allotment of resources to distinct hours of a day; the columns of this view can be grouped by location, task, contact or resource.
  • The Resource View displays the distribution of resources over a period of time.


Month Range View

The Month Range view displays an arbitrary long sequence of months arranged in rows and columns. Each month represents a grid of day cells, each of which displays the day number and the schedule events set to occur on its respective date. The months in the view can be scrolled back or forth in time by an arbitrary interval using the navigation buttons in the view header.

In order to enable the Month Range view, set the CurrentView property of the Calendar class to MonthRange. Use the MonthRangeSettings and the MonthSettings properties of the Calendar class to adjust the appearance of the view. Use the DayStyles, DayOfWeekStyles and MonthStyles collections of the Calendar class to specify individual styles for particular cells or ranges of cells. The ItemSettings property affects how schedule items will be displayed.


Single Month View

This Single Month view displays a single month and lets the user scroll to the previous or next month or the previous or next year by using the navigation buttons optionally displayed in the view header. The month represents a grid of day cells, which display the day number and the schedule events set to occur on the specific date.

In order to enable the Single Month view, set the CurrentView property of the Calendar class to SingleMonth. Use the MonthSettings property of the Calendar class to set the appearance of the view. The Style property of the associated DaySettings object specifies a common appearance style to be used for all cells in the view. Use the DayStyles, DayOfWeekStyles and MonthStyles collections of the Calendar class to specify individual styles for particular cells or range of cells. The ItemSettings property affects how schedule items will be displayed.


Week Range View

This Week Range view displays a range of weeks. Each week occupies a whole row or column whose cells represent days. The day cells display the day name or number according to the GeneralFormat, FirstDayOfMonthFormat and FirstDayOfYearFormat properties of the associated DaySettings, and the schedule items set to occur on the corresponding date.

In order to enable the Week Range view, set the CurrentView property of the Calendar class to WeekRange. Use the WeekRangeSettings property of the Calendar class to adjust the appearance of the view. Use the DayStyles and DayOfWeekStyles collections of the Calendar class to specify individual styles for specific cells. The ItemSettings property lets you specify how schedule items should be displayed.


List View

Set the CurrentView property of the Calendar class to List to select the list view. This view displays several rows or columns where each row or column represents a single second, minute, hour, day, week, month or year. The day cells display the represented time in a user-specified format to the GeneralFormat, FirstDayOfMonthFormat and FirstDayOfYearFormat properties of the associated CellSettings, and the schedule items set to occur on the corresponding date.

Use the ListViewSettings property of the of the Calendar class to set the appearance of the list view. The Style property of the associated CellSettings specifies a common appearance style to be used for all cells in the view. Use DayStyles and DayOfWeekStyles to specify a higher priority style for specific cells. The ItemSettings property lets you specify how schedule items should be displayed.


Timetable View

Set the CurrentView property of the Calendar class to Timetable to select the timetable view. This view displays the allotment of resources to distinct hours of a day; the columns in this view represent dates, tasks, locations, contacts or resources. The columns can be grouped by location, task, contact or resource. Each row represents an hour or a custom time interval. The cells in the view display information about the schedule items allocated to the task, contact, location or resource for the specific time interval.

Use the TimetableSettings property of the Calendar class to set the appearance of the timetable view. The Style property specifies a common appearance style for all cells in the view, while the WorkTimeCellStyle property defines the style of cells in the work time interval. The ItemSettings property lets you specify how schedule items should be displayed.


Resource View

Set the CurrentView property of the Calendar class to Resource to select the resource view. This view displays the distribution of items over a period of time for a particular contacts, locations, tasks or resources. The view displays a single row for each individual contact, location, task or resource and up to three timelines. In order to view associated items in this view, the GroupType property of the Calendar must be set to GroupByContacts, GroupByLocations, GroupByTasks or GroupByResources.

Use the ResourceViewSettings property of the Calendar class to set the appearance of the resource view. The Style property specifies a common appearance style for all cells in the view. The ItemSettings property lets you specify how schedule items should be displayed.


Grouping

Views that can be grouped: Timetable / Week Range / List.
Views that should to be grouped: Resource.
The other views do not support grouping.

In order to enable grouping the following steps should be done:

  • The resources should be created and added to the appropriate collection in the schedule: Calendar.Schedule.Contacts for contacts, Calendar.Schedule.Locations for locations, Calendar.Schedule.Tasks for tasks and Calendar.Schedule.Resources for general and custom resources.
  • The selected resources by which to group should be added to the appropriate collection in the control: Calendar.Contacts for contacts, and so on. The selected resources are a subset of all resources defined in the schedule.
  • The Calendar.GroupType should be set to the appropriate value, for example GroupType.GroupByContacts to group by contacts.

The following code illustrates how to enable grouping by contacts:

C#

// Define two contacts to group by
Contact c1 = new Contact();
c1.FirstName = "John";

Contact c2 = new Contact();
c2.FirstName = "Jack";

// Add the contacts to the schedule
calendar.Schedule.Contacts.Add(c1);
calendar.Schedule.Contacts.Add(c2);

// Select these contacts for grouping by adding them to
// the appropriate Calendar collection
calendar.Contacts.Add(c1);
calendar.Contacts.Add(c2);

// Enable grouping by contacts
calendar.GroupType = GroupType.GroupByContacts;

Visual Basic

' Define two contacts to group by
Dim c1 As New Contact()
c1.FirstName = "John"

Dim c2 As New Contact()
c2.FirstName = "Jack"

' Add the contacts to the schedule
calendar.Schedule.Contacts.Add(c1)
calendar.Schedule.Contacts.Add(c2)

' Select these contacts for grouping by adding them to
' the appropriate Calendar collection
calendar.Contacts.Add(c1)
calendar.Contacts.Add(c2)

' Enable grouping by contacts
calendar.GroupType = GroupType.GroupByContacts

The text displayed in the header of the corresponding resource depends on the type of the resource and is as follows:

  • A string formatted according to Calendar.ContactNameFormat for contacts.
  • The Resource.Name for general and custom resources, and locations.
  • The Task.Subject for tasks.

Grouping and Appearance

  • In resource view a single row is dedicated to each individual resource. The row has a header, displaying the text for that resource and contains all items, associated with that resource for the specified time interval. The row can be additionally subdivided to lanes depending on the ResourceViewSettings.ViewStyle.
  • In timetable view each column (or row in a horizontal view) that represents a day is additionally subdivided to the number of grouped resources. For example if there are 3 resources selected to group by, each day column in the view is subdivided to 3 columns. The sub-columns represent individual resources and contain only the items specific for them. The sub-columns have headers containing the resource text. The header of the day column is displayed above the headers of its underlying resource columns.
  • The week range view displays a separate view for grouped resources. For example if there are two resources, two views are displayed alongside, each of which contains the items associated with its corresponding resource.


Customizing Appearance

The following topics are contained within this topic:

Styles and Themes
Information about the visualization styles and themes available in PocketPlanner.

Customizing the Appearance of Views
Information on how to modify the appearance of various PocketPlanner views.

Customizing the Appearance of Items
Information on how to modify the appearance of items in PocketPlanner.


Styles and Themes

A Style is a set of appearance attributes, such as colors, brushes and images that can be applied to schedule items or calendar view cells as an integral entity. Styles support cascading propagation of attributes up through the visualization hierarchy. Attributes defined in more specific styles override the attributes defined in more general styles. If a style leaves some attribute values undefined, the ones specified in a more general style or in the current theme are used. For example, the Item.Style property cascades to ItemSettings.Style, which cascades to the corresponding property in the current theme. If a property in Item.Style is defined, it will be used. Otherwise the style system will take the value of this property from ItemSettings.Style. If the property is not present there too, the value will be taken from the current theme.

The following values are used as an "not defined" marker for the style attributes, that is, when a style use them for some property, the value of the same property defined higher in the style hierarchy will be used instead:

  • Enumerations: <EnumName>.Unspecified
  • Numbers: -1 (or -2 for Style.ImageIndex where -1 indicates that there is no image associated with the style)
  • Strings: null (Nothing in Visual Basic)
  • Other reference types: null (Nothing in Visual Basic)

Themes are complete sets of styles and attributes that can be applied to the calendar and its views. The themes contain values for all properties in the MonthSettings, TimetableSettings, ListViewSettings, and so on, defining the appearance of the various calendar views. PocketPlanner comes with several predefined themes: Standard, LightBlue and LightBrown. Use the Calendar.ApplyTheme method to apply a specific theme.


PocketPlanner Themes

The following table illustrates how various views would look like when particular appearance Theme is applied to them.

 | Standard | LightBlue | LightBrown
List View |  |  |
Week Range |  |  |
Month Range |  |  |
Timetable |  |  |
Resource View |  |  |


Customizing the Appearance of Views

The appearance of individual calendar views depends on the settings corresponding to them. For example the appearance of the list view is controlled by the Calendar.ListViewSettings property, while the appearance of the timetable view is controlled by the Calendar.TimetableSettings property, and so on. The month range view is an exception to this rule since it depends on both Calendar.MonthSettings and Calendar.MonthRangeSettings properties.

The settings object defines styles for various elements of the view. Most settings contain properties, which let you change the size and number of elements (such as columns, rows, headers, and so on) contained in the view. There are usually properties that control the padding and margin of various elements and properties that define the format of the text displayed in the view.

Most view elements can be custom-drawn by setting the appropriate flag in the CustomDraw property of the Calendar and handling the Draw event. Draw event handler receives argument, which specifies which element is being drawn, its coordinates and style. Use the methods of the .NET Graphics object argument to render your custom visualization.


Customizing the Appearance of Items

There are several ways to customize the appearance of items in PocketPlanner.

You can customize the general appearance of items in a schedule, by setting various properties in Calendar.ItemSettings. This would affect the appearance of all items in the current schedule. To customize the appearance of individual item, adjust its Style and SelectedStyle properties. The particular style that will be used when the item is rendered depends on the state of the item. Style is used when the item is neither selected nor the mouse hovers over it. SelectedStyle is used when the item is selected and the mouse is not over it. The item styles support the cascading paradigm described in Styles and Themes. The most general item styles are defined in the current theme. They cannot be changed by any means except by changing the theme itself. The styles defined in Calendar.ItemSettings are of higher priority and any of their properties that are explicitly specified will be used prior those from the theme. The styles defined in individual items are of highest priority and will always be used first, when present.

The following illustration shows how item appearance is affected by the item settings and style.

The image shows how to customize item appearance in a single month, month range, day range and week range views. The grayed out properties either does not have effect or does not have noticeable effect on the items in these views.

The next image illustrates how settings affect the appearance of items in a timetable view.

You can use custom drawing to perform additional drawing on an item by setting the Calendar.CustomDraw property to CalendarItem, ScheduleItem or ResourceViewItem and handling the Draw event.


Optimizing Performance

The following tips might help you improve the performance of your application:

Timetable Collisions

If you don't need collision detection in a Timetable view you can disable it by settings TimetableSettings.EnableCollisions to Disabled.

Default Item Rendering

If you perform full custom drawing of items, or for some other reason you don't need default item rendering, you can disable it through ItemSettings.EnableDefaultRendering.


PocketPlanner Programmer's Guide

Reference

© 2008 MindFusion


MindFusion Namespace
Enumerations

Enumerations

Enumeration | Description
Alignment | Specifies the alignment of contents relative to the layout rectangle.


MindFusion.Alignment Enumeration

Alignment Enumeration
See Also

Specifies the alignment of contents relative to the layout rectangle.

Namespace: MindFusion
Assembly: PocketPlanner

Syntax

C#

public enum Alignment
Visual Basic

Public Enumeration Alignment

Members

Member name | Description
Far | The contents are aligned far from the origin of the layout rectangle. In a left-to-right layout, the far position is right. In a right-to-left layout, the far position is left.
Near | The contents are aligned near the layout rectangle. In a left-to-right layout, the near position is left. In a right-to-left layout, the near position is right.
None | The contents are unavailable.
Unspecified | Unspecified.

See Also

MindFusion Namespace


MindFusion.Drawing Namespace
Classes Enumerations

Classes

Class | Description
Brush | Brush objects are used to fill the interiors of geometric shapes.
GraphicObject | The base class for graphical objects such as pens and brushes.
GraphicsEx | Extends the .NET Compact Framework Graphics class.
Pen | Pen instances are used to draw the outline of geometric shapes.
SolidBrush | SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.

Enumerations

Enumeration | Description
ImageAlignment | Specifies the alignment of an image.
TextAlignment | Specifies the alignment of text on the drawing surface.


MindFusion.Drawing.Brush Class

Brush Class
Remarks See Also

Brush objects are used to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public abstract class Brush : GraphicObject
Visual Basic

Public MustInherit Class Brush
Inherits GraphicObject

Remarks

The Brush-derived classes act as proxies for the .NET standard GDI+ System.Drawing.Brush-derived classes. There are two reasons to use proxy classes instead the original GDI classes:

  • First, the GDI resources are limited and would be exhausted by keeping a GDI brushes all the time; by using proxies GDI brushes can be created only at the time of drawing, and immediately disposed after that.
  • Second, the GDI Brush classes do not support serialization; the proxy-classes implement the required interfaces instead.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.SolidBrush

See Also

Brush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Members

Brush Members
Constructors Methods

Brush objects are used to fill the interiors of geometric shapes.

The following tables list the members exposed by the Brush type.

Protected Constructors

Name | Description
Brush | Initializes a new instance of the Brush class.

Public Methods

Name | Description
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Constructor

Brush Constructor

Initializes a new instance of the Brush class.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

protected Brush ()
Visual Basic

Protected Sub New ()

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Methods

Brush Methods

Public Methods

Name | Description
CreateGdiBrush | Overloaded. Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method

Brush.CreateGdiBrush Method

Returns an instance of a System.Drawing.Brush-derived class corresponding to the current brush.

Overload List

Name | Description
Brush.CreateGdiBrush (RectangleF) | Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object.
Brush.CreateGdiBrush (RectangleF, Single, Single) | Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object. The specified offset is used for texture or pattern brushes whose contents must scroll with the rest of the drawn image.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method (RectangleF)

Brush.CreateGdiBrush Method (RectangleF)
See Also

Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public abstract Brush CreateGdiBrush (
RectangleF rc
)
Visual Basic

Public MustOverride Function CreateGdiBrush ( _
rc As RectangleF _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.CreateGdiBrush Method (RectangleF, Single, Single)

Brush.CreateGdiBrush Method (RectangleF, Single, Single)
See Also

Returns an instance of a System.Drawing.Brush-derived class that can be used to paint in a GDI+ Graphics object. The specified offset is used for texture or pattern brushes whose contents must scroll with the rest of the drawn image.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public virtual Brush CreateGdiBrush (
RectangleF rc,
float dx,
float dy
)
Visual Basic

Public Overridable Function CreateGdiBrush ( _
rc As RectangleF, _
dx As Single, _
dy As Single _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.
dx
Specifies a horizontal offset to apply to this brush.
dy
Specifies a vertical offset to apply to this brush.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

CreateGdiBrush Method Overload List
Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Class

GraphicObject Class

The base class for graphical objects such as pens and brushes.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public abstract class GraphicObject : ICloneable
Visual Basic

Public MustInherit Class GraphicObject
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.Pen

See Also

GraphicObject Members
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Members

GraphicObject Members
Constructors Methods

The base class for graphical objects such as pens and brushes.

The following tables list the members exposed by the GraphicObject type.

Protected Constructors

Name | Description
GraphicObject | Initializes a new instance of the GraphicObject class.

Public Methods

Name | Description
Clone | Creates an exact copy of the graphic object.
Equals | Determines whether two GraphicObject instances are equal.
GetHashCode | Returns a hash code for this object.

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Constructor

GraphicObject Constructor

Initializes a new instance of the GraphicObject class.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

protected GraphicObject ()
Visual Basic

Protected Sub New ()

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject Methods

GraphicObject Methods

Public Methods

Name | Description
Clone | Creates an exact copy of the graphic object.
Equals | Determines whether two GraphicObject instances are equal.
GetHashCode | Returns a hash code for this object.

See Also

GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Clone Method

GraphicObject.Clone Method

Creates an exact copy of the graphic object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public abstract Object Clone ()
Visual Basic

Public MustOverride Function Clone () As Object

Return Value

An instance of the GraphicObject class.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.Equals Method

GraphicObject.Equals Method

Determines whether two GraphicObject instances are equal.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public override bool Equals (
Object obj
)
Visual Basic

Public Overrides Function Equals ( _
obj As Object _
) As Boolean

Parameters

obj
The object to compare to this one.

Return Value

true is the objects are equal; otherwise, false.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicObject.GetHashCode Method

GraphicObject.GetHashCode Method

Returns a hash code for this object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for this object.

See Also

GraphicObject Members
GraphicObject Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx Class

GraphicsEx Class
Remarks See Also

Extends the .NET Compact Framework Graphics class.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public class GraphicsEx : IDisposable
Visual Basic

Public Class GraphicsEx
Implements IDisposable

Remarks

An instance of this class wraps a Graphics instance and implements the ability to apply translation transformations to the drawing coordinate system.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicsEx

See Also

GraphicsEx Members
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx Members

GraphicsEx Members
Constructors Properties Methods

Extends the .NET Compact Framework Graphics class.

The following tables list the members exposed by the GraphicsEx type.

Public Constructors

Name | Description
GraphicsEx | Initializes a new instance of the GraphicsEx class.

Public Properties

Name | Description
Scroll | Gets the current translation vector of this GraphicsEx object.

Public Methods

Name | Description
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Disposes the underlying Graphics object.
DrawImage | Overloaded. The DrawImage methods are used to draw an image at a specified position. Some of the overloads let you specify a color key and a size to which the image is stretched.
DrawLine | Overloaded. Draws a line connecting two points.
DrawPolygon | Draws a polygon defined by an array of .NET Point structures.
DrawRectangle | Overloaded. Draws a rectangle at the specified position with the specified size.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
FillPolygon | Fills the interior of a polygon defined by an array of points specified by .NET Point structures.
FillRectangle | Fills the interior of a rectangle specified by a .NET Rectangle structure.
GetFontHeight | Returns the line spacing of a specified .NET Font object.
MeasureString | Measures the extent of the string in the specified font.
ResetTransform | Sets the transformation applied to this GraphicsEx object to the identity transformation.
TranslateTransform | Appends the specified translation to the current translation transformation of this GraphicsEx object.

See Also

GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx Constructor

GraphicsEx Constructor

Initializes a new instance of the GraphicsEx class.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public GraphicsEx (
Graphics graphics
)
Visual Basic

Public Sub GraphicsEx ( _
graphics As Graphics _
)

Parameters

graphics
The underlying .NET Graphics object.

See Also

GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx Methods

GraphicsEx Methods

Public Methods

Name | Description
Clear | Clears the entire drawing surface and fills it with the specified background color.
Dispose | Disposes the underlying Graphics object.
DrawImage | Overloaded. The DrawImage methods are used to draw an image at a specified position. Some of the overloads let you specify a color key and a size to which the image is stretched.
DrawLine | Overloaded. Draws a line connecting two points.
DrawPolygon | Draws a polygon defined by an array of .NET Point structures.
DrawRectangle | Overloaded. Draws a rectangle at the specified position with the specified size.
DrawString | Overloaded. Draws the specified text string at the specified location with the specified Brush and Font objects.
FillPolygon | Fills the interior of a polygon defined by an array of points specified by .NET Point structures.
FillRectangle | Fills the interior of a rectangle specified by a .NET Rectangle structure.
GetFontHeight | Returns the line spacing of a specified .NET Font object.
MeasureString | Measures the extent of the string in the specified font.
ResetTransform | Sets the transformation applied to this GraphicsEx object to the identity transformation.
TranslateTransform | Appends the specified translation to the current translation transformation of this GraphicsEx object.

See Also

GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.Clear Method

GraphicsEx.Clear Method

Clears the entire drawing surface and fills it with the specified background color.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void Clear (
Color color
)
Visual Basic

Public Sub Clear ( _
color As Color _
)

Parameters

color
A .NET Color structure that represents the background color of the drawing surface.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.Dispose Method

GraphicsEx.Dispose Method

Disposes the underlying Graphics object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public virtual void Dispose ()
Visual Basic

Public Overridable Sub Dispose ()

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawImage Method

GraphicsEx.DrawImage Method

The DrawImage methods are used to draw an image at a specified position. Some of the overloads let you specify a color key and a size to which the image is stretched.

Overload List

Name | Description
GraphicsEx.DrawImage (Image, Int32, Int32) | Draws an image using its original size at the location specified by a coordinate pair.
GraphicsEx.DrawImage (Image, Int32, Int32, Color) | Draws an image at the specified location using the specified color key, keeping the original size of the image intact.
GraphicsEx.DrawImage (Image, Point) | Draws an image using its original size at the specified location.
GraphicsEx.DrawImage (Image, Point, Color) | Draws an image using its original size at the specified location, using the specified color key.
GraphicsEx.DrawImage (Image, Rectangle, Rectangle) | Draws a portion of an image at the specified location and with the specified size.
GraphicsEx.DrawImage (Image, Rectangle, Rectangle, Color) | Draws a portion of an image at the specified location with the specified size, using the specified color key.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawImage Method (Image, Int32, Int32)

GraphicsEx.DrawImage Method (Image, Int32, Int32)
See Also

Draws an image using its original size at the location specified by a coordinate pair.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawImage (
Image image,
int dx,
int dy
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
dx As Integer, _
dy As Integer _
)

Parameters

image
The image object to draw.
dx
The x-coordinate of the upper-left corner of the drawn image.
dy
The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawImage Method (Image, Int32, Int32, Color)

GraphicsEx.DrawImage Method (Image, Int32, Int32, Color)
See Also

Draws an image at the specified location using the specified color key, keeping the original size of the image intact.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawImage (
Image image,
int dx,
int dy,
Color colorKey
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
dx As Integer, _
dy As Integer, _
colorKey As Color _
)

Parameters

image
The image object to draw.
dx
The x-coordinate of the upper-left corner of the drawn image.
dy
The y-coordinate of the upper-left corner of the drawn image.
colorKey
The color that specifies which pixels of the original image are not transferred to the destination graphics, that is, are not drawn.

See Also

DrawImage Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawImage Method (Image, Point)

GraphicsEx.DrawImage Method (Image, Point)
See Also

Draws an image using its original size at the specified location.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawImage (
Image image,
Point dest
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
dest As Point _
)

Parameters

image
The .NET Image object to draw.
dest
A .NET Point structure that represents the location of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawImage Method (Image, Point, Color)

GraphicsEx.DrawImage Method (Image, Point, Color)
See Also

Draws an image using its original size at the specified location, using the specified color key.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawImage (
Image image,
Point dest,
Color colorKey
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
dest As Point, _
colorKey As Color _
)

Parameters

image
The .NET Image object to draw.
dest
A .NET Point structure that represents the location of the upper-left corner of the drawn image.
colorKey
The color that specifies which pixels of the original image are not transferred to the destination graphics, that is, are not drawn.

See Also

DrawImage Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawImage Method (Image, Rectangle, Rectangle)

GraphicsEx.DrawImage Method (Image, Rectangle, Rectangle)
See Also

Draws a portion of an image at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawImage (
Image image,
Rectangle dest,
Rectangle src
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
dest As Rectangle, _
src As Rectangle _
)

Parameters

image
The .NET Image object to draw.
dest
A .NET Rectangle structure that specifies the location and size of the drawn image.
src
A .NET Rectangle structure that specifies the portion of the image that is to be drawn.

See Also

DrawImage Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawImage Method (Image, Rectangle, Rectangle, Color)

GraphicsEx.DrawImage Method (Image, Rectangle, Rectangle, Color)
See Also

Draws a portion of an image at the specified location with the specified size, using the specified color key.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawImage (
Image image,
Rectangle dest,
Rectangle src,
Color colorKey
)
Visual Basic

Public Sub DrawImage ( _
image As Image, _
dest As Rectangle, _
src As Rectangle, _
colorKey As Color _
)

Parameters

image
The .NET Image object to draw.
dest
A .NET Rectangle structure that specifies the location and size of the drawn image.
src
A .NET Rectangle structure that specifies the portion of the image that is to be drawn.
colorKey
The color that specifies which pixels of the original image are not transferred to the destination graphics, that is, are not drawn.

See Also

DrawImage Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawLine Method

GraphicsEx.DrawLine Method

Draws a line connecting two points.

Overload List

Name | Description
GraphicsEx.DrawLine (Pen, Int32, Int32, Int32, Int32) | Draws a line connecting the two points specified by coordinate pairs.
GraphicsEx.DrawLine (Pen, Point, Point) | Draws a line connecting two points.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawLine Method (Pen, Int32, Int32, Int32, Int32)

GraphicsEx.DrawLine Method (Pen, Int32, Int32, Int32, Int32)
See Also

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawLine (
Pen pen,
int x1,
int y1,
int x2,
int y2
)
Visual Basic

Public Sub DrawLine ( _
pen As Pen, _
x1 As Integer, _
y1 As Integer, _
x2 As Integer, _
y2 As Integer _
)

Parameters

pen
A .NET System.Drawing.Pen object that determines the color of the line.
x1
The x-coordinate of the first point.
y1
The y-coordinate of the first point.
x2
The x-coordinate of the second point.
y2
The y-coordinate of the second point.

See Also

DrawLine Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawLine Method (Pen, Point, Point)

GraphicsEx.DrawLine Method (Pen, Point, Point)
See Also

Draws a line connecting two points.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawLine (
Pen pen,
Point pt1,
Point pt2
)
Visual Basic

Public Sub DrawLine ( _
pen As Pen, _
pt1 As Point, _
pt2 As Point _
)

Parameters

pen
A Pen object that determines the color, width, and style of the line.
pt1
A Point structure that represents the first point to connect.
pt2
A Point structure that represents the second point to connect.

See Also

DrawLine Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawPolygon Method

GraphicsEx.DrawPolygon Method

Draws a polygon defined by an array of .NET Point structures.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawPolygon (
Pen pen,
Point[] points
)
Visual Basic

Public Sub DrawPolygon ( _
pen As Pen, _
points As Point() _
)

Parameters

pen
A .NET System.Drawing.Pen object that determines the color of the polygon.
points
An array of .NET Point structures that represent the vertices of the polygon.

Remarks

Every pair of two consecutive points in the array specifies a side of the polygon. In addition, if the last point and the first point of the array do not coincide, they specify the last side of the polygon.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawRectangle Method

GraphicsEx.DrawRectangle Method

Draws a rectangle at the specified position with the specified size.

Overload List

Name | Description
GraphicsEx.DrawRectangle (Pen, Int32, Int32, Int32, Int32) | Draws a rectangle specified by a coordinate pair, a width, and a height.
GraphicsEx.DrawRectangle (Pen, Rectangle) | Draws a rectangle specified by a .NET Rectangle structure.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)

GraphicsEx.DrawRectangle Method (Pen, Int32, Int32, Int32, Int32)
See Also

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawRectangle (
Pen pen,
int x,
int y,
int width,
int height
)
Visual Basic

Public Sub DrawRectangle ( _
pen As Pen, _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

pen
A .NET System.Drawing.Pen object that determines the color of the rectangle.
x
The x-coordinate of the upper-left corner of the rectangle to draw.
y
The y-coordinate of the upper-left corner of the rectangle to draw.
width
The width of the rectangle to draw.
height
The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawRectangle Method (Pen, Rectangle)

GraphicsEx.DrawRectangle Method (Pen, Rectangle)
See Also

Draws a rectangle specified by a .NET Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawRectangle (
Pen pen,
Rectangle rc
)
Visual Basic

Public Sub DrawRectangle ( _
pen As Pen, _
rc As Rectangle _
)

Parameters

pen
A .NET System.Drawing.Pen object that determines the color of the rectangle.
rc
A .NET Rectangle structure that represents the rectangle to draw.

See Also

DrawRectangle Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawString Method

GraphicsEx.DrawString Method

Draws the specified text string at the specified location with the specified Brush and Font objects.

Overload List

Name | Description
GraphicsEx.DrawString (String, Font, Brush, Point) | Draws the specified text string at the specified location with the specified Brush and Font objects.
GraphicsEx.DrawString (String, Font, Brush, Rectangle) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects.
GraphicsEx.DrawString (String, Font, TextAlignment, Brush, Rectangle) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects, and alignment.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawString Method (String, Font, Brush, Point)

GraphicsEx.DrawString Method (String, Font, Brush, Point)
See Also

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawString (
string s,
Font f,
Brush brush,
Point pt
)
Visual Basic

Public Sub DrawString ( _
s As String, _
f As Font, _
brush As Brush, _
pt As Point _
)

Parameters

s
The string to draw.
f

A .NET Font object that defines the text format of the string.

brush
A .NET System.Drawing.Brush object that determines the color and texture of the drawn text.
pt
A .NET Point structure that specifies the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawString Method (String, Font, Brush, Rectangle)

GraphicsEx.DrawString Method (String, Font, Brush, Rectangle)
See Also

Draws the specified text string in the specified rectangle with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawString (
string s,
Font f,
Brush brush,
Rectangle rc
)
Visual Basic

Public Sub DrawString ( _
s As String, _
f As Font, _
brush As Brush, _
rc As Rectangle _
)

Parameters

s
A string to draw.
f
A .NET Font object that defines the text format of the string.
brush
A .NET System.Drawing.Brush object that determines the color and texture of the drawn text.
rc
A .NET Rectangle structure that specifies the location of the drawn text.

See Also

DrawString Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.DrawString Method (String, Font, TextAlignment, Brush, Rectangle)

GraphicsEx.DrawString Method (String, Font, TextAlignment, Brush, Rectangle)
See Also

Draws the specified text string in the specified rectangle with the specified Brush and Font objects, and alignment.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void DrawString (
string s,
Font f,
TextAlignment alignment,
Brush brush,
Rectangle rect
)
Visual Basic

Public Sub DrawString ( _
s As String, _
f As Font, _
alignment As TextAlignment, _
brush As Brush, _
rect As Rectangle _
)

Parameters

s
A string to draw.
f
A .NET Font object that defines the text format of the string.
alignment
The alignment of the drawn string relative to the specified rectangle.
brush
A .NET System.Drawing.Brush object that determines the color and texture of the drawn text.
rect
A .NET Rectangle structure that specifies the location of the drawn text.

See Also

DrawString Method Overload List
GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.FillPolygon Method

GraphicsEx.FillPolygon Method

Fills the interior of a polygon defined by an array of points specified by .NET Point structures.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void FillPolygon (
Brush brush,
Point[] points
)
Visual Basic

Public Sub FillPolygon ( _
brush As Brush, _
points As Point() _
)

Parameters

brush

A .NET System.Drawing.Brush object that determines the characteristics of the fill.

points
An array of .NET Point structures that represent the vertices of the polygon to fill.

Remarks

Every two consecutive points in the array specify a side of the polygon. In addition, if the last point and the first point do not coincide, they specify the closing side of the polygon.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.FillRectangle Method

GraphicsEx.FillRectangle Method

Fills the interior of a rectangle specified by a .NET Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void FillRectangle (
Brush brush,
Rectangle rc
)
Visual Basic

Public Sub FillRectangle ( _
brush As Brush, _
rc As Rectangle _
)

Parameters

brush
A .NET System.Drawing.Brush object that determines the characteristics of the fill.
rc
A .NET Rectangle structure that represents the rectangle to fill.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.GetFontHeight Method

GraphicsEx.GetFontHeight Method

Returns the line spacing of a specified .NET Font object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public int GetFontHeight (
Font font
)
Visual Basic

Public Function GetFontHeight ( _
font As Font _
) As Integer

Parameters

font
The font to measure.

Return Value

The line spacing, in pixels, of the specified font.

Remarks

The line spacing is the vertical distance between the base lines of two consecutive lines of text. Thus, the line spacing includes the blank space between lines along with the height of the character itself.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.MeasureString Method

GraphicsEx.MeasureString Method

Measures the extent of the string in the specified font.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public Size MeasureString (
string text,
Font font
)
Visual Basic

Public Function MeasureString ( _
text As String, _
font As Font _
) As Size

Parameters

text
The string to measure.
font
A .NET Font object that defines the style and the size of the font applied to the string.

Return Value

A .NET Size structure that represents the size, in pixels, of the string specified by the text parameter as drawn with the font parameter.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.ResetTransform Method

GraphicsEx.ResetTransform Method

Sets the transformation applied to this GraphicsEx object to the identity transformation.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void ResetTransform ()
Visual Basic

Public Sub ResetTransform ()

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.TranslateTransform Method

GraphicsEx.TranslateTransform Method

Appends the specified translation to the current translation transformation of this GraphicsEx object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public void TranslateTransform (
int dx,
int dy
)
Visual Basic

Public Sub TranslateTransform ( _
dx As Integer, _
dy As Integer _
)

Parameters

dx
A value to add to the x component of the translation vector.
dy
A value to add to the y component of the translation vector.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx Properties

GraphicsEx Properties

Public Properties

Name | Description
Scroll | Gets the current translation vector of this GraphicsEx object.

See Also

GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsEx.Scroll Property

GraphicsEx.Scroll Property

Gets the current translation vector of this GraphicsEx object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public Point Scroll { get; }
Visual Basic

Public ReadOnly Property Scroll As Point

Property Value

A .NET Point object containing the coordinates of the current translation vector.

See Also

GraphicsEx Members
GraphicsEx Class
MindFusion.Drawing Namespace


MindFusion.Drawing.ImageAlignment Enumeration

ImageAlignment Enumeration

Specifies the alignment of an image.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public enum ImageAlignment
Visual Basic

Public Enumeration ImageAlignment

Members

Member name | Description
Bottom | The image is aligned to the bottom side of the layout rectangle.
Center | The image is centered within the layout rectangle.
Fit | The image is stretched to fit in the layout rectangle, but its original ratio is preserved.
Left | The image is aligned to the left side of the layout rectangle.
None | Same as Center.
Right | The image is aligned to the right side of the layout rectangle.
Stretch | The image is stretched. Equal to Left | Top | Right | Bottom.
Tile | The image is tiled across the layout rectangle.
Top | The image is aligned to the top side of the layout rectangle.
Unspecified | Invalid image alignment.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Class

Pen Class
Remarks See Also

Pen instances are used to draw the outline of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public class Pen : GraphicObject
Visual Basic

Public Class Pen
Inherits GraphicObject

Remarks

The Pen class acts as a proxy for the .NET standard GDI+ System.Drawing.Pen class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Pen

See Also

Pen Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Members

Pen Members
Constructors Properties Methods

Pen instances are used to draw the outline of geometric shapes.

The following tables list the members exposed by the Pen type.

Public Constructors

Name | Description
Pen | Initialize a new instance of the Pen class.

Public Properties

Name | Description
Color | Gets or sets the color of this pen.

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.
CreateGdiPen | Overloaded. Returns an instance of the System.Drawing.Pen class corresponding to the current pen.
ToString | Returns the string representation of this Pen object.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Color)

Pen Constructor (Color)
See Also

Initializes a new instance of the Pen class with the specified color.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public Pen (
Color color
)
Visual Basic

Public Sub Pen ( _
color As Color _
)

Parameters

color
A Color structure that specifies the color of the new pen.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Methods

Pen Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.
CreateGdiPen | Overloaded. Returns an instance of the System.Drawing.Pen class corresponding to the current pen.
ToString | Returns the string representation of this Pen object.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Clone Method

Pen.Clone Method

Creates an exact copy of this pen.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the Pen class.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method

Pen.CreateGdiPen Method

Returns an instance of the System.Drawing.Pen class corresponding to the current pen.

Overload List

Name | Description
Pen.CreateGdiPen () | Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.
Pen.CreateGdiPen (RectangleF) | Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method ()

Pen.CreateGdiPen Method ()
See Also

Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public Pen CreateGdiPen ()
Visual Basic

Public Function CreateGdiPen () As Pen

Return Value

A System.Drawing.Pen instance corresponding to this pen.

See Also

CreateGdiPen Method Overload List
Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.CreateGdiPen Method (RectangleF)

Pen.CreateGdiPen Method (RectangleF)
See Also

Returns an instance of the System.Drawing.Pen class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public Pen CreateGdiPen (
RectangleF rc
)
Visual Basic

Public Function CreateGdiPen ( _
rc As RectangleF _
) As Pen

Parameters

rc
The rectangle in which painting will be performed.

Return Value

A System.Drawing.Pen instance corresponding to this pen.

See Also

CreateGdiPen Method Overload List
Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.ToString Method

Pen.ToString Method

Returns the string representation of this Pen object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string representing this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Properties

Pen Properties

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Color Property

Pen.Color Property

Gets or sets the color of this pen.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public Color Color { get; set; }
Visual Basic

Public Property Color As Color

Property Value

An instance of the .NET Color structure that represents the color of this pen.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Class

SolidBrush Class
Remarks See Also

SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public class SolidBrush : Brush
Visual Basic

Public Class SolidBrush
Inherits Brush

Remarks

The SolidBrush class acts as a proxy for the .NET standard GDI+ System.Drawing.SolidBrush class.

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicObject
MindFusion.Drawing.Brush
MindFusion.Drawing.SolidBrush

See Also

SolidBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Members

SolidBrush Members
Constructors Properties Methods

SolidBrush objects represent brushes of a single color that are used to fill the interiors of geometric shapes.

The following tables list the members exposed by the SolidBrush type.

Public Constructors

Name | Description
SolidBrush | Initializes a new instance of the SolidBrush class.

Public Properties

Name | Description
Color | Gets or sets the color of this brush.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.
ToString | Returns "Solid".

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor (Color)

SolidBrush Constructor (Color)
See Also

Initializes a new instance of the SolidBrush class with the specified color.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public SolidBrush (
Color color
)
Visual Basic

Public Sub SolidBrush ( _
color As Color _
)

Parameters

color
A Color object that specifies the color of the new brush.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Methods

SolidBrush Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
CreateGdiBrush | Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.
ToString | Returns "Solid".

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Clone Method

SolidBrush.Clone Method

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

An instance of the SolidBrush class.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.CreateGdiBrush Method

SolidBrush.CreateGdiBrush Method

Returns an instance of the System.Drawing.SolidBrush class that can be used to paint in a GDI+ Graphics object.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public override Brush CreateGdiBrush (
RectangleF rc
)
Visual Basic

Public Overrides Function CreateGdiBrush ( _
rc As RectangleF _
) As Brush

Parameters

rc
The rectangle in which painting will be performed.

Return Value

An instance of the System.Drawing.Brush class corresponding to this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.ToString Method

SolidBrush.ToString Method

Returns "Solid".

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string representing this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Properties

SolidBrush Properties

Public Properties

Name | Description
Color | Gets or sets the color of this brush.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Color Property

SolidBrush.Color Property

Gets or sets the color of this brush.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public Color Color { get; set; }
Visual Basic

Public Property Color As Color

Property Value

Instance of the .NET Color structure that represents the color of this brush.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextAlignment Enumeration

TextAlignment Enumeration

Specifies the alignment of text on the drawing surface.

Namespace: MindFusion.Drawing
Assembly: PocketPlanner

Syntax

C#

public enum TextAlignment
Visual Basic

Public Enumeration TextAlignment

Members

Member name | Description
AlignmentFlag | For internal use only.
BottomCenter | Text is vertically aligned at the bottom, and horizontally aligned at the center.
BottomLeft | Text is vertically aligned at the bottom, and horizontally aligned on the left.
BottomRight | Text is vertically aligned at the bottom, and horizontally aligned on the right.
MiddleCenter | Text is vertically aligned in the middle, and horizontally aligned at the center.
MiddleLeft | Text is vertically aligned in the middle, and horizontally aligned on the left.
MiddleRight | Text is vertically aligned in the middle, and horizontally aligned on the right.
NoWrap | The only flag that can be combines with any of the alignment flags. Specifies that the drawn text should not wrap when the text does not fit in a single line.
TopCenter | Text is vertically aligned at the top, and horizontally aligned at the center.
TopLeft | Text is vertically aligned at the top, and horizontally aligned on the left.
TopRight | Text is vertically aligned at the top, and horizontally aligned on the right.
Unspecified | No alignment is specified.

See Also

MindFusion.Drawing Namespace


MindFusion.Scheduling Namespace
Classes Delegates Enumerations

Classes

Class | Description
Appointment | Represents appointments within a schedule.
Contact | Instances of the Contact class contain information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.
ContactCollection | Represents a strongly-typed collection of Contact objects.
CustomBrushes | Defines a pair of brushes to be used to paint cells in cells in Timetable, WeekRange and Resource views.
InstantiateItemEventArgs | Provides data for the InstantiateItem event.
InstantiateResourceEventArgs | Provides data for the InstantiateResource event.
Item | Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.
ItemCollection | Represents a strongly typed collection of Item objects.
ItemEventArgs | Contains the arguments passed to handlers of item related events raised by the Schedule class.
ItemTimeEventArgs | Contains the arguments passed to handlers of time related events.
Location | Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.
LocationCollection | Represents a strongly typed collection of Location objects.
Recurrence | Defines recurrence patterns for items scheduled to repeat over and over again.
RecurrenceException | This class represents exceptions of a recurrence patterns.
Reminder | Represents reminders associated with schedule items.
Resource | Instances of the Resource class contain information about arbitrary resources.
ResourceCollection | Represents a strongly-typed collection of Resource objects.
Schedule | Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.
SerializationContext | This class contains information required to serialize a Schedule element to and from a binary stream or XML document.
SerializeTagEventArgs | Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.
Style | Specifies the appearance of calendar elements.
Task | Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.
TaskCollection | Represents a strongly-typed collection of Task objects.
TaskEventArgs | Contains the arguments passed to handlers of task related events raised by the Schedule class.
XmlSerializationContext | Contains methods that can help you serialize/deserialize PocketPlanner items to/from XML documents.

Delegates

Delegate | Description
InstantiateItemEventHandler | Represents methods that handle the InstantiateItem event.
InstantiateResourceEventHandler | Represents methods that handle the InstantiateResource event.
ItemEventHandler | Represents methods that will handle general item related events raised by the Schedule class.
ItemTimeEventHandler | Represents methods that will handle the time related events raised by the Schedule class.
SerializeTagEventHandler | Represents methods that will handle the SerializeTag and DeserializeTag events of the Schedule class.
TaskEventHandler | Represents methods that will handle the task related events raised by the Schedule class.

Enumerations

Enumeration | Description
DailyRecurrence | Specifies how daily recurrence patterns are defined.
DayOfWeekType | Specifies the type of week days, used with ByDayType monthly and yearly recurrence patterns.
DaysOfWeek | Specifies the day of the week.
MonthlyRecurrence | Specifies the types of monthly recurrence patterns.
Occurrence | Specifies the occurrence number of a day or a week within a month.
RecurrenceEnd | Specifies when to stop repeating recurring events.
RecurrencePattern | Specifies the interval at which recurring items occur.
RecurrenceState | Specifies the recurrence state of items.
ReminderType | Specifies the type of a reminder.
ShadowStyle | Specifies what type of shadow effect to apply to a calendar UI element.
TaskPriority | Specifies the priority of a task.
TaskStatus | Enumeration providing task status values.
YearlyRecurrence | Specifies the types of yearly recurrence patterns.


MindFusion.Scheduling.Appointment Class

Appointment Class

Represents appointments within a schedule.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class Appointment : Item
Visual Basic

Public Class Appointment
Inherits Item

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Item
MindFusion.Scheduling.Appointment

See Also

Appointment Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Members

Appointment Members
Constructors Properties Methods

Represents appointments within a schedule.

The following tables list the members exposed by the Appointment type.

Public Constructors

Name | Description
Appointment | Initializes a new instance of the Appointment class.

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the appointment is an all-day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the appointment's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the appointment's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the appointment.
Attendees | Gets the attendees of this appointment.
Contacts | Gets references to all contacts associated with this appointment.
DescriptionText | Gets or sets the details text displayed for this appointment by scheduling controls.
Details | Gets or sets the detailed description of this appointment.
EndTime | Gets or sets the appointment's scheduled end time.
HeaderText | Gets or sets the header text displayed for this appointment by scheduling controls.
Id | Gets or sets the string identifier of this appointment.
ImageIndex | Gets or sets the index of the image associated with this appointment. Since version 4.1, this property is considered obsolete. Instead, use the ImageIndex property of the associated Style.
Location | Gets or sets the appointment location.
Locked | Gets or sets a value indicating whether users are forbidden to modify this appointment.
Reminder | Gets or sets the reminder for this appointment.
Resources | Gets references to all resources associated with this appointment.
SelectedStyle | Gets or sets the style used when this appointment is selected.
StartTime | Gets or sets the appointment's scheduled start time.
Style | Gets or sets the style associated with this appointment.
Subject | Gets or sets the subject of this appointment.
Tag | Gets or sets custom data associated with the appointment.
Task | Gets or sets the task associated with this appointment.
Visible | Gets or sets whether the appointment is visible or not.

Public Methods

Name | Description
Clone | Creates an exact shallow clone of this appointment.
LoadFrom | Overloaded. Loads appointment data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the appointment data to a binary stream or an XML document.

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Constructor

Appointment Constructor

Initializes a new instance of the Appointment class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Appointment ()
Visual Basic

Public Sub New ()

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment Methods

Appointment Methods

Public Methods

Name | Description
Clone | Creates an exact shallow clone of this appointment.
LoadFrom | Overloaded. Loads appointment data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the appointment data to a binary stream or an XML document.

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Clone Method

Appointment.Clone Method

Creates an exact shallow clone of this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override Object Clone ()
Visual Basic

Public Overrides Function Clone () As Object

Return Value

A new Appointment object representing a shallow copy of this one.

Remarks

The Clone method creates an exact copy of an item with the following exceptions. The duplicates of a recurring item created through the Clone method are no longer recurring items. The Id of the newly created item is unique and not the same as the Id of the source item.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.LoadFrom Method

Appointment.LoadFrom Method

Loads appointment data from a binary stream or an XML document.

Overload List

Name | Description
Appointment.LoadFrom (XmlElement, XmlSerializationContext) | Loads appointment data from an XML document.
Appointment.LoadFrom (XmlReader, SerializationContext) | Loads appointment data from an XML document. Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.LoadFrom Method (XmlElement, XmlSerializationContext)

Appointment.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads appointment data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

Loads the appointment's fields from an XML document where they were stored by a previous call to the SaveTo method.

See Also

LoadFrom Method Overload List
Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Appointment.LoadFrom Method (XmlReader, SerializationContext)

Appointment.LoadFrom Method (XmlReader, SerializationContext)
See Also

Loads appointment data from an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void LoadFrom (
XmlReader reader,
SerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
reader As XmlReader, _
context As SerializationContext _
)

Parameters

reader
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also allows getting locations, contacts and tasks by their string identifiers.

Remarks

Loads the appointment's fields from an XML document where they were stored by a previous call to the SaveTo method.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Appointment.SaveTo Method

Appointment.SaveTo Method

Saves the appointment data to a binary stream or an XML document.

Overload List

Name | Description
Appointment.SaveTo (XmlElement, XmlSerializationContext) | Saves the appointment data to an XML document.
Appointment.SaveTo (XmlWriter, SerializationContext) | Saves the appointment data to an XML document. Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.SaveTo Method (XmlElement, XmlSerializationContext)

Appointment.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the appointment data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the appointment's fields as elements of an XML document, from which they can be loaded later via the LoadFrom method.

See Also

SaveTo Method Overload List
Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Appointment.SaveTo Method (XmlWriter, SerializationContext)

Appointment.SaveTo Method (XmlWriter, SerializationContext)
See Also

Saves the appointment data to an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void SaveTo (
XmlWriter writer,
SerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
writer As XmlWriter, _
context As SerializationContext _
)

Parameters

writer
Allows adding data to the XML document.
context
The context object contains the current revision number of the schedule file format.

Remarks

This method saves the appointment's fields as elements of an XML document, from which they can be loaded later via the LoadFrom method.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Appointment Properties

Appointment Properties

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the appointment is an all-day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the appointment's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the appointment's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the appointment.
Attendees | Gets the attendees of this appointment.
Contacts | Gets references to all contacts associated with this appointment.
DescriptionText | Gets or sets the details text displayed for this appointment by scheduling controls.
Details | Gets or sets the detailed description of this appointment.
EndTime | Gets or sets the appointment's scheduled end time.
HeaderText | Gets or sets the header text displayed for this appointment by scheduling controls.
Id | Gets or sets the string identifier of this appointment.
ImageIndex | Gets or sets the index of the image associated with this appointment. Since version 4.1, this property is considered obsolete. Instead, use the ImageIndex property of the associated Style.
Location | Gets or sets the appointment location.
Locked | Gets or sets a value indicating whether users are forbidden to modify this appointment.
Reminder | Gets or sets the reminder for this appointment.
Resources | Gets references to all resources associated with this appointment.
SelectedStyle | Gets or sets the style used when this appointment is selected.
StartTime | Gets or sets the appointment's scheduled start time.
Style | Gets or sets the style associated with this appointment.
Subject | Gets or sets the subject of this appointment.
Tag | Gets or sets custom data associated with the appointment.
Task | Gets or sets the task associated with this appointment.
Visible | Gets or sets whether the appointment is visible or not.

See Also

Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.AllDayEvent Property

Appointment.AllDayEvent Property

Gets or sets a value indicating whether the appointment is an all-day event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override bool AllDayEvent { get; set; }
Visual Basic

Public Overrides Property AllDayEvent As Boolean

Property Value

true if the item is an all day event; otherwise, false. The default is false.

Remarks

All day events are displayed in a special header area when the Calendar displays a timetable view.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
StartTime Property
EndTime Property


MindFusion.Scheduling.Appointment.AllowChangeEnd Property

Appointment.AllowChangeEnd Property

Gets or sets a value indicating whether users are allowed to change the appointment's end time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override bool AllowChangeEnd { get; set; }
Visual Basic

Public Overrides Property AllowChangeEnd As Boolean

Property Value

true if the appointment's end can be modified interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowMove Property


MindFusion.Scheduling.Appointment.AllowChangeStart Property

Appointment.AllowChangeStart Property

Gets or sets a value indicating whether users are allowed to change the appointment's start time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override bool AllowChangeStart { get; set; }
Visual Basic

Public Overrides Property AllowChangeStart As Boolean

Property Value

true if the appointment's start can be modified interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeEnd Property
AllowMove Property


MindFusion.Scheduling.Appointment.AllowMove Property

Appointment.AllowMove Property

Gets or sets a value indicating whether users are allowed to move the appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override bool AllowMove { get; set; }
Visual Basic

Public Overrides Property AllowMove As Boolean

Property Value

true if the appointment can be moved interactively; otherwise, false. The default is true.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowChangeEnd Property


MindFusion.Scheduling.Appointment.Attendees Property

Appointment.Attendees Property

Gets the attendees of this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ContactCollection Attendees { get; }
Visual Basic

Public ReadOnly Property Attendees As ContactCollection

Property Value

An instance of the ContactCollection class specifying the appointment's attendees.

Remarks

This property is equivalent to Contacts.

Example

The following example creates a new contact and associates it with an existing appointment. The example assumes that app references an existing appointment. The last call is equivalent to app.Contacts.Add(c), since Attendees and Contacts both return a reference to the same collection.

C#

// Create the contact
Contact c = new Contact();
c.FirstName = "John";
c.LastName = "Silver";

// Associate the contact with the appointment
app.Attendees.Add(c);
Visual Basic

' Create the contact
Dim c As New Contact()
c.FirstName = "John"
c.LastName = "Silver"

' Associate the contact with the appointment
app.Attendees.Add(c)

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Contacts Property

Appointment.Contacts Property

Gets references to all contacts associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override ContactCollection Contacts { get; }
Visual Basic

Public Overrides ReadOnly Property Contacts As ContactCollection

Property Value

An instance of the ContactCollection class containing the contacts associated with this appointment.

Remarks

This property is equivalent to Attendees.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.DescriptionText Property

Appointment.DescriptionText Property

Gets or sets the details text displayed for this appointment by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override string DescriptionText { get; set; }
Visual Basic

Public Overrides Property DescriptionText As String

Property Value

A string containing the appointment's description. The default is an empty string.

Remarks

This property implements the DescriptionText property of the Item class and is equivalent to Details.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Details Property

Appointment.Details Property

Gets or sets the detailed description of this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Details { get; set; }
Visual Basic

Public Property Details As String

Property Value

A string containing the appointment's description. The default is an empty string.

Remarks

This property is equivalent to DescriptionText.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.EndTime Property

Appointment.EndTime Property

Gets or sets the appointment's scheduled end time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override DateTime EndTime { get; set; }
Visual Basic

Public Overrides Property EndTime As DateTime

Property Value

A .NET DateTime object specifying the appointment's end time. The default is DateTime.MaxValue.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
StartTime Property
AllDayEvent Property


MindFusion.Scheduling.Appointment.HeaderText Property

Appointment.HeaderText Property

Gets or sets the header text displayed for this appointment by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override string HeaderText { get; set; }
Visual Basic

Public Overrides Property HeaderText As String

Property Value

A string containing the appointment's header text. The default is an empty string.

Remarks

This property implements the Item's class HeaderText property and is equivalent to Subject.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Id Property

Appointment.Id Property

Gets or sets the string identifier of this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override string Id { get; set; }
Visual Basic

Public Overrides Property Id As String

Property Value

A string value that identifies uniquely this appointment.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.ImageIndex Property

Appointment.ImageIndex Property

Gets or sets the index of the image associated with this appointment.

Since version 4.1, this property is considered obsolete. Instead, use the ImageIndex property of the associated Style.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override int ImageIndex { get; set; }
Visual Basic

Public Overrides Property ImageIndex As Integer

Property Value

An integer index of the appointment's image within the Calendar.ImageList. The default is 0.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Location Property

Appointment.Location Property

Gets or sets the appointment location.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override Location Location { get; set; }
Visual Basic

Public Overrides Property Location As Location

Property Value

An instance of the Location class specifying the appointment's location. The default is null (Nothing in Visual Basic).

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Locked Property

Appointment.Locked Property

Gets or sets a value indicating whether users are forbidden to modify this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override bool Locked { get; set; }
Visual Basic

Public Overrides Property Locked As Boolean

Property Value

true if users are allowed to move an appointment thus changing its scheduled time; otherwise, false. The default is false.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Reminder Property

Appointment.Reminder Property

Gets or sets the reminder for this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override Reminder Reminder { get; set; }
Visual Basic

Public Overrides Property Reminder As Reminder

Property Value

An instance of the Reminder class.

Remarks

If the reminder type is Exact, the ItemReminderTriggered event is raised at the time set in the reminder's Time property. If the reminder type is Leading, the ItemReminderTriggered event is raised certain amount of time prior to the item's StartTime, as specified in the reminder's TimeInterval property.

Note:

Recurring items cannot have leading reminders.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Resources Property

Appointment.Resources Property

Gets references to all resources associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override ResourceCollection Resources { get; }
Visual Basic

Public Overrides ReadOnly Property Resources As ResourceCollection

Property Value

An instance of the ResourceCollection class containing the resources associated with this item.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.SelectedStyle Property

Appointment.SelectedStyle Property

Gets or sets the style used when this appointment is selected.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override Style SelectedStyle { get; set; }
Visual Basic

Public Overrides Property SelectedStyle As Style

Property Value

An instance of the Style class that defines the appearance of the item.

Remarks

This style is applied on the appointment when it is selected.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
Style Property
PointedStyle Property
PointedSelectedStyle Property


MindFusion.Scheduling.Appointment.StartTime Property

Appointment.StartTime Property

Gets or sets the appointment's scheduled start time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override DateTime StartTime { get; set; }
Visual Basic

Public Overrides Property StartTime As DateTime

Property Value

A .NET DateTime instance specifying the scheduled time for the item.

Remarks

This property affects the initial time cell occupied by the item when it is displayed in a Calendar view.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
EndTime Property
AllDayEvent Property


MindFusion.Scheduling.Appointment.Style Property

Appointment.Style Property

Gets or sets the style associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

An instance of the Style class that defines the appearance of the item.

Remarks

This style is applied to the item when it is neither pointed with the mouse nor selected.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace
SelectedStyle Property
PointedStyle Property
PointedSelectedStyle Property


MindFusion.Scheduling.Appointment.Subject Property

Appointment.Subject Property

Gets or sets the subject of this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Subject { get; set; }
Visual Basic

Public Property Subject As String

Property Value

A string that identifies the subject of the appointment. The default is an empty string.

Remarks

This is equivalent to the HeaderText property.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Tag Property

Appointment.Tag Property

Gets or sets custom data associated with the appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override Object Tag { get; set; }
Visual Basic

Public Overrides Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data. The tag can be a value from a primitive data type or a complex object from the .NET class library or a class defined by you. If the tag is an instance of a value type, it will be serialized together with the object containing it when saving / loading the schedule. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Task Property

Appointment.Task Property

Gets or sets the task associated with this appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override Task Task { get; set; }
Visual Basic

Public Overrides Property Task As Task

Property Value

An instance of the Task class. The default is null (Nothing in Visual Basic).

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Appointment.Visible Property

Appointment.Visible Property

Gets or sets whether the appointment is visible or not.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override bool Visible { get; set; }
Visual Basic

Public Overrides Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false. The default is true.

Remarks

Invisible items are not drawn at all. You could use this property to hide an item temporarily, or to store additional data in a helper item object that always stays invisible.

See Also

Appointment Members
Appointment Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Class

Contact Class

Instances of the Contact class contain information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class Contact : Resource
Visual Basic

Public Class Contact
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Contact

See Also

Contact Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Members

Contact Members
Constructors Properties Methods

Instances of the Contact class contain information about individual persons. Contact objects are used by schedule classes that have human resources associated with them.

The following tables list the members exposed by the Contact type.

Public Constructors

Name | Description
Contact | Initializes a new instance of the Contact class.

Public Properties

Name | Description
Address | Gets or sets the address of the contact.
Email | Gets or sets the e-mail address of the contact.
FirstName | Gets or sets the first name of the contact.
LastName | Gets or sets the last name of the contact.
MiddleName | Gets or sets the middle name of the contact.
Phone | Gets or sets the phone of the contact.

Public Methods

Name | Description
LoadFrom | Overloaded. Loads contact data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the contact data to a binary stream or an XML document.

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Constructor

Contact Constructor

Initializes a new instance of the Contact class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Contact ()
Visual Basic

Public Sub New ()

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact Methods

Contact Methods

Public Methods

Name | Description
LoadFrom | Overloaded. Loads contact data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the contact data to a binary stream or an XML document.

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.LoadFrom Method

Contact.LoadFrom Method

Loads contact data from a binary stream or an XML document.

Overload List

Name | Description
Contact.LoadFrom (XmlElement, XmlSerializationContext) | Loads contact data from an XML document.
Contact.LoadFrom (XmlReader, SerializationContext) | Loads contact data from an XML document. Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.LoadFrom Method (XmlElement, XmlSerializationContext)

Contact.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads contact data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The context parameter wraps an XML document that contains data stored by a previous call to the SaveTo method.

See Also

LoadFrom Method Overload List
Contact Members
Contact Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Contact.LoadFrom Method (XmlReader, SerializationContext)

Contact.LoadFrom Method (XmlReader, SerializationContext)
See Also

Loads contact data from an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void LoadFrom (
XmlReader reader,
SerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
reader As XmlReader, _
context As SerializationContext _
)

Parameters

reader
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also allows getting locations, contacts and tasks by their string identifiers.

Remarks

The reader parameter wraps an XML document that contains data stored by a previous call to the SaveTo method. Both methods are used internally by the serialization methods of the Schedule class.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Contact.SaveTo Method

Contact.SaveTo Method

Saves the contact data to a binary stream or an XML document.

Overload List

Name | Description
Contact.SaveTo (XmlElement, XmlSerializationContext) | Saves the contact data to an XML document.
Contact.SaveTo (XmlWriter, SerializationContext) | Saves the contact data to an XML document. Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.SaveTo Method (XmlElement, XmlSerializationContext)

Contact.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the contact data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the contact properties as elements of an XML document.

See Also

SaveTo Method Overload List
Contact Members
Contact Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Contact.SaveTo Method (XmlWriter, SerializationContext)

Contact.SaveTo Method (XmlWriter, SerializationContext)
See Also

Saves the contact data to an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void SaveTo (
XmlWriter writer,
SerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
writer As XmlWriter, _
context As SerializationContext _
)

Parameters

writer
Allows adding data to the XML document.
context
The context object contains the current revision number of the schedule file format.

Remarks

This method saves the contact properties as elements of an XML document.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Contact Properties

Contact Properties

Public Properties

Name | Description
Address | Gets or sets the address of the contact.
Email | Gets or sets the e-mail address of the contact.
FirstName | Gets or sets the first name of the contact.
LastName | Gets or sets the last name of the contact.
MiddleName | Gets or sets the middle name of the contact.
Phone | Gets or sets the phone of the contact.

See Also

Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.Address Property

Contact.Address Property

Gets or sets the address of the contact.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Address { get; set; }
Visual Basic

Public Property Address As String

Property Value

A string containing address information. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.Email Property

Contact.Email Property

Gets or sets the e-mail address of the contact.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Email { get; set; }
Visual Basic

Public Property Email As String

Property Value

A string containing an e-mail address. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Contact.FirstName Property

Contact.FirstName Property

Gets or sets the first name of the contact.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string FirstName { get; set; }
Visual Basic

Public Property FirstName As String

Property Value

A string containing the first name of a person. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
LastName Property
MiddleName Property


MindFusion.Scheduling.Contact.LastName Property

Contact.LastName Property

Gets or sets the last name of the contact.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string LastName { get; set; }
Visual Basic

Public Property LastName As String

Property Value

A string containing person's last name. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
FirstName Property
LastName Property


MindFusion.Scheduling.Contact.MiddleName Property

Contact.MiddleName Property

Gets or sets the middle name of the contact.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string MiddleName { get; set; }
Visual Basic

Public Property MiddleName As String

Property Value

A string containing person's last name. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace
FirstName Property
LastName Property


MindFusion.Scheduling.Contact.Phone Property

Contact.Phone Property

Gets or sets the phone of the contact.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Phone { get; set; }
Visual Basic

Public Property Phone As String

Property Value

A string containing a phone number. The default is an empty string.

See Also

Contact Members
Contact Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Class

ContactCollection Class

Represents a strongly-typed collection of Contact objects.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public sealed class ContactCollection : CollectionBase
Visual Basic

Public NotInheritable Class ContactCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.ContactCollection

See Also

ContactCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Members

ContactCollection Members
Constructors Properties Methods Events

Represents a strongly-typed collection of Contact objects.

The following tables list the members exposed by the ContactCollection type.

Public Constructors

Name | Description
ContactCollection | Initializes a new instance of the ContactCollection class.

Public Properties

Name | Description
Item | Gets a Contact object from the collection given its zero-based index or identifier.

Public Methods

Name | Description
Add | Adds the specified contact to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified contact.
Insert | Inserts the specified Contact object at the specified position within the collection.
Remove | Removes the first occurrence of the specified Contact object from this collection.

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Constructor

ContactCollection Constructor

Initializes a new instance of the ContactCollection class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ContactCollection ()
Visual Basic

Public Sub New ()

See Also

ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Methods

ContactCollection Methods

Public Methods

Name | Description
Add | Adds the specified contact to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified contact.
Insert | Inserts the specified Contact object at the specified position within the collection.
Remove | Removes the first occurrence of the specified Contact object from this collection.

See Also

ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Add Method

ContactCollection.Add Method

Adds the specified contact to this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Add (
Contact contact
)
Visual Basic

Public Sub Add ( _
contact As Contact _
)

Parameters

contact
An instance of the Contact class to be added to the collection.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace
Insert Method


MindFusion.Scheduling.ContactCollection.Clear Method

ContactCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Contains Method

ContactCollection.Contains Method

Determines whether this collection contains the specified contact.

Overload List

Name | Description
ContactCollection.Contains (Contact) | Determines whether this collection contains the specified contact.
ContactCollection.Contains (String) | Determines whether this collection contains a contact identified by the specified string.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Contains Method (Contact)

ContactCollection.Contains Method (Contact)
See Also

Determines whether this collection contains the specified contact.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
Contact contact
)
Visual Basic

Public Function Contains ( _
contact As Contact _
) As Boolean

Parameters

contact
The Contact object to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Contains Method (String)

ContactCollection.Contains Method (String)
See Also

Determines whether this collection contains a contact identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
string contactId
)
Visual Basic

Public Function Contains ( _
contactId As String _
) As Boolean

Parameters

contactId
The identifier of a contact to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Insert Method

ContactCollection.Insert Method

Inserts the specified Contact object at the specified position within the collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Insert (
int index,
Contact contact
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
contact As Contact _
)

Parameters

index
The zero-based index at which the contact must be inserted.
contact
An instance of the Contact class to be added to the collection.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace
Add Method


MindFusion.Scheduling.ContactCollection.Remove Method

ContactCollection.Remove Method

Removes the first occurrence of the specified Contact object from this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Remove (
Contact contact
)
Visual Basic

Public Sub Remove ( _
contact As Contact _
)

Parameters

contact
A Contact instance which must be removed from the collection.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Properties

ContactCollection Properties

Public Properties

Name | Description
Item | Gets a Contact object from the collection given its zero-based index or identifier.

See Also

ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Item Property

ContactCollection.Item Property

Gets a Contact object from the collection given its zero-based index or identifier.

Overload List

Name | Description
ContactCollection.Item (Int32) | Gets or sets the Contact object located at the specified position within this collection.
ContactCollection.Item (String) | Gets the Contact object identified by the specified string.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Item Property (Int32)

ContactCollection.Item Property (Int32)
See Also

Gets or sets the Contact object located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Contact Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Contact

Parameters

index
The zero-based index of the Contact to set or retrieve.

Property Value

The Contact instance at the specified index.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their integer indices.

See Also

Item Property Overload List
ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Item Property (String)

ContactCollection.Item Property (String)
See Also

Gets the Contact object identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Contact Item [
string id
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
id As String _
) As Contact

Parameters

id
The Id of the Contact to get.

Property Value

The Contact instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection Events

ContactCollection Events

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ContactCollection.Changed Event

ContactCollection.Changed Event

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public EventHandler Changed
Visual Basic

Public Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

ContactCollection Members
ContactCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CustomBrushes Class

CustomBrushes Class

Defines a pair of brushes to be used to paint cells in cells in Timetable, WeekRange and Resource views.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class CustomBrushes
Visual Basic

Public Class CustomBrushes

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.CustomBrushes

See Also

CustomBrushes Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CustomBrushes Members

CustomBrushes Members
Constructors Properties

Defines a pair of brushes to be used to paint cells in cells in Timetable, WeekRange and Resource views.

The following tables list the members exposed by the CustomBrushes type.

Public Constructors

Name | Description
CustomBrushes | Initializes a new instance of the CustomBrushes class.

Public Properties

Name | Description
PrimaryBrush | Gets or sets the brush used to paint primary calendar elements.
SecondaryBrush | Gets or sets the brush used to paint secondary calendar elements.

See Also

CustomBrushes Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CustomBrushes Constructor

CustomBrushes Constructor

Initializes a new instance of the CustomBrushes class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public CustomBrushes ()
Visual Basic

Public Sub New ()

See Also

CustomBrushes Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CustomBrushes Properties

CustomBrushes Properties

Public Properties

Name | Description
PrimaryBrush | Gets or sets the brush used to paint primary calendar elements.
SecondaryBrush | Gets or sets the brush used to paint secondary calendar elements.

See Also

CustomBrushes Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.CustomBrushes.PrimaryBrush Property

CustomBrushes.PrimaryBrush Property

Gets or sets the brush used to paint primary calendar elements.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Brush PrimaryBrush { get; set; }
Visual Basic

Public Property PrimaryBrush As Brush

Property Value

A Brush instance used to fill the interior of calendar UI elements. The default is null (Nothing in Visual Basic).

Remarks

What is painted with this brush depends on the current view and the context in which the CustomBrushes instance is used. For example in timetable view contact's primary custom brush is used to paint the non-work time cells for the contact.

See Also

CustomBrushes Members
CustomBrushes Class
MindFusion.Scheduling Namespace
SecondaryBrush Property


MindFusion.Scheduling.CustomBrushes.SecondaryBrush Property

CustomBrushes.SecondaryBrush Property

Gets or sets the brush used to paint secondary calendar elements.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Brush SecondaryBrush { get; set; }
Visual Basic

Public Property SecondaryBrush As Brush

Property Value

A Brush instance used to fill the interior of calendar UI elements. The default is null (Nothing in Visual Basic).

Remarks

What is painted with this brush depends on the current view and the context in which the CustomBrushes instance is used. For example in timetable view contact's secondary custom brush is used to paint the work time cells for the contact.

See Also

CustomBrushes Members
CustomBrushes Class
MindFusion.Scheduling Namespace
PrimaryBrush Property


MindFusion.Scheduling.DailyRecurrence Enumeration

DailyRecurrence Enumeration

Specifies how daily recurrence patterns are defined.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum DailyRecurrence
Visual Basic

Public Enumeration DailyRecurrence

Members

Member name | Description
ByDayInterval | Repeats the item after every number of days specified in the Recurrence.Days property.
EveryWeekend | Repeats the item each Saturday and Sunday.
EveryWorkday | Repeats the item each workday, Monday through Friday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.DayOfWeekType Enumeration

DayOfWeekType Enumeration

Specifies the type of week days, used with ByDayType monthly and yearly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum DayOfWeekType
Visual Basic

Public Enumeration DayOfWeekType

Members

Member name | Description
AnyDay | Indicates any day.
Friday | Indicates Friday.
Monday | Indicates Monday.
Saturday | Indicates Saturday.
Sunday | Indicates Sunday.
Thursday | Indicates Thursday.
Tuesday | Indicates Tuesday.
Wednesday | Indicates Wednesday.
Weekend | Indicates a weekend day.
Workday | Indicates a workday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.DaysOfWeek Enumeration

DaysOfWeek Enumeration

Specifies the day of the week.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum DaysOfWeek
Visual Basic

Public Enumeration DaysOfWeek

Members

Member name | Description
All | Indicates all days of the week.
Friday | Indicates Friday.
Monday | Indicates Monday.
None | Indicates an undefined day value.
Saturday | Indicates Saturday.
Sunday | Indicates Sunday.
Thursday | Indicates Thursday.
Tuesday | Indicates Tuesday.
Wednesday | Indicates Wednesday.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Class

InstantiateItemEventArgs Class

Provides data for the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class InstantiateItemEventArgs : EventArgs
Visual Basic

Public Class InstantiateItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateItemEventArgs

See Also

InstantiateItemEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Members

InstantiateItemEventArgs Members
Properties

Provides data for the InstantiateItem event.

The following tables list the members exposed by the InstantiateItemEventArgs type.

Public Properties

Name | Description
ClassId | Gets the class identifier of the item.
Item | Gets or sets the newly created item.

See Also

InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs Properties

InstantiateItemEventArgs Properties

Public Properties

Name | Description
ClassId | Gets the class identifier of the item.
Item | Gets or sets the newly created item.

See Also

InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs.ClassId Property

InstantiateItemEventArgs.ClassId Property

Gets the class identifier of the item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string ClassId { get; }
Visual Basic

Public ReadOnly Property ClassId As String

Property Value

A string value representing the class identifier of the item, which should be created.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventArgs.Item Property

InstantiateItemEventArgs.Item Property

Gets or sets the newly created item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Item Item { get; set; }
Visual Basic

Public Property Item As Item

Property Value

An instance of an Item-derived class.

Remarks

Upon handling the InstantiateItem event, you have to create an item of the appropriate type, as specified by ClassId, and assign it to this property.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateItemEventHandler Delegate

InstantiateItemEventHandler Delegate

Represents methods that handle the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public delegate void InstantiateItemEventHandler (
Object sender,
InstantiateItemEventArgs e
)
Visual Basic

Public Delegate Sub InstantiateItemEventHandler ( _
sender As Object, _
e As InstantiateItemEventArgs _
)

Parameters

sender
The source of the event.
e
An InstantiateItemEventArgs that contains the event data.

See Also

MindFusion.Scheduling Namespace
InstantiateResourceEventHandler Delegate


MindFusion.Scheduling.InstantiateResourceEventArgs Class

InstantiateResourceEventArgs Class

Provides data for the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class InstantiateResourceEventArgs : EventArgs
Visual Basic

Public Class InstantiateResourceEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.InstantiateResourceEventArgs

See Also

InstantiateResourceEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Members

InstantiateResourceEventArgs Members
Properties

Provides data for the InstantiateResource event.

The following tables list the members exposed by the InstantiateResourceEventArgs type.

Public Properties

Name | Description
ClassId | Gets the class identifier of the resource.
Resource | Gets or sets the newly created resource.

See Also

InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs Properties

InstantiateResourceEventArgs Properties

Public Properties

Name | Description
ClassId | Gets the class identifier of the resource.
Resource | Gets or sets the newly created resource.

See Also

InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs.ClassId Property

InstantiateResourceEventArgs.ClassId Property

Gets the class identifier of the resource.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string ClassId { get; }
Visual Basic

Public ReadOnly Property ClassId As String

Property Value

A string value representing the class identifier of the resource, which should be created.

See Also

InstantiateResourceEventArgs Members
InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventArgs.Resource Property

InstantiateResourceEventArgs.Resource Property

Gets or sets the newly created resource.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Resource Resource { get; set; }
Visual Basic

Public Property Resource As Resource

Property Value

An instance of a Resource-derived class.

Remarks

Upon handling the InstantiateResource event, you have to create a resource of the appropriate type, as specified by ClassId, and assign it to this property.

See Also

InstantiateResourceEventArgs Members
InstantiateResourceEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.InstantiateResourceEventHandler Delegate

InstantiateResourceEventHandler Delegate

Represents methods that handle the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public delegate void InstantiateResourceEventHandler (
Object sender,
InstantiateResourceEventArgs e
)
Visual Basic

Public Delegate Sub InstantiateResourceEventHandler ( _
sender As Object, _
e As InstantiateResourceEventArgs _
)

Parameters

sender
The source of the event.
e
An InstantiateResourceEventArgs that contains the event data.

See Also

MindFusion.Scheduling Namespace
InstantiateItemEventHandler Delegate


MindFusion.Scheduling.Item Class

Item Class

Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract class Item : ICloneable
Visual Basic

Public MustInherit Class Item
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Item
MindFusion.Scheduling.Appointment

See Also

Item Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Members

Item Members
Constructors Properties Methods

Represents events scheduled to occur at some point in time. It is derived by concrete classes such as Appointment.

The following tables list the members exposed by the Item type.

Protected Constructors

Name | Description
Item | Initializes a new instance of the Item class.

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the item represents an all day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the item's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the item's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the item.
Contacts | Gets references to all contacts associated with this item.
DescriptionText | Gets or sets the description displayed for this item by scheduling controls.
EndTime | Gets or sets the item's scheduled end time.
HeaderText | Gets or sets the header text displayed for this item by scheduling controls.
Id | Gets or sets the string identifier of this item.
ImageIndex | Gets or sets the index of the image associated with this item. Since version 4.1, this property is considered obsolete. Instead, use the ImageIndex property of the associated Style.
Location | Gets or sets the location associated with this item.
Locked | Gets or sets a value indicating whether users are forbidden to modify this item.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item.
Priority | Gets or sets the priority of this item.
Recurrence | Gets or sets the recurrence pattern of this item.
RecurrenceState | Gets the recurrence state of this item.
Reminder | Gets or sets the reminder for this item.
Resources | Gets references to all resources associated with this item.
SelectedStyle | Gets or sets the selected style associated with the item.
StartTime | Gets or sets the item's scheduled start time.
Style | Gets or sets a style associated with the item.
Tag | Gets or sets custom data associated with the item.
Task | Gets or sets the task associated with this item.
Visible | Gets or sets a flag indicating whether the item is visible or not.

Public Methods

Name | Description
Clone | Creates a clone of this item.
GetHashCode | Returns a hash code for this item.
LoadFrom | Overloaded. Loads item data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the item data to a binary stream or an XML document.

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.
OnVisualsChanged | Forces the item to be repainted.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Constructor

Item Constructor

Initializes a new instance of the Item class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected Item ()
Visual Basic

Protected Sub New ()

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item Methods

Item Methods

Public Methods

Name | Description
Clone | Creates a clone of this item.
GetHashCode | Returns a hash code for this item.
LoadFrom | Overloaded. Loads item data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the item data to a binary stream or an XML document.

Protected Methods

Name | Description
CopyOccurrence | Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.
OnVisualsChanged | Forces the item to be repainted.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Clone Method

Item.Clone Method

Creates a clone of this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract Object Clone ()
Visual Basic

Public MustOverride Function Clone () As Object

Return Value

This method is a pure abstract method and does not return a value.

Remarks

The clone of a recurring item is not an occurrence but an ordinary item. Aside from this, the clone is an exact duplicate of the original item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.CopyOccurrence Method

Item.CopyOccurrence Method

Called by the recurrence whenever a new occurrence is being generated in order to populate the fields of the instance from the master item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void CopyOccurrence (
Item master
)
Visual Basic

Protected Overridable Sub CopyOccurrence ( _
master As Item _
)

Parameters

master
A reference to the master to copy from.

Remarks

This method is usually overridden in classes which derive from Item or Appointment in order to copy the custom fields from the master item to a particular occurrence. If the method is not overridden, the custom fields for all occurrences will have their default values and not the value of the master item.

Example

The following example illustrates how to override CopyOccurrence in a class deriving from Appointment and how to copy the custom fields from the master item.

C#

class CustomAppointment : Appointment
{
protected override void CopyOccurrence(Item master)
{
_customField = (master as CustomAppointment)._customField;
base.CopyOccurrence(master);
}

private int _customField;
}
Visual Basic

Class CustomAppointment
Inherits Appointment

Protected Overrides Sub CopyOccurrence(ByVal master As Item)

_customField = CType(master, CustomAppointment)._customField
MyBase.CopyOccurrence(master)

End Sub

Private _customField As Integer

End Class

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.GetHashCode Method

Item.GetHashCode Method

Returns a hash code for this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.LoadFrom Method

Item.LoadFrom Method

Loads item data from a binary stream or an XML document.

Overload List

Name | Description
Item.LoadFrom (XmlElement, XmlSerializationContext) | Loads item data from an XML document.
Item.LoadFrom (XmlReader, SerializationContext) | Loads item data from an XML document. Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.LoadFrom Method (XmlElement, XmlSerializationContext)

Item.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads item data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public virtual void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overridable Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

LoadFrom Method Overload List
Item Members
Item Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Item.LoadFrom Method (XmlReader, SerializationContext)

Item.LoadFrom Method (XmlReader, SerializationContext)
See Also

Loads item data from an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public virtual void LoadFrom (
XmlReader reader,
SerializationContext context
)
Visual Basic

Public Overridable Sub LoadFrom ( _
reader As XmlReader, _
context As SerializationContext _
)

Parameters

reader
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also allows getting locations, contacts and tasks by their string identifiers.

Remarks

This method loads item data from an XML document saved there by a previous call to SaveTo the method.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Item.OnVisualsChanged Method

Item.OnVisualsChanged Method

Forces the item to be repainted.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected void OnVisualsChanged ()
Visual Basic

Protected Sub OnVisualsChanged ()

Remarks

Call this method from within your derived classes when the appearance of the item has been changed.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.SaveTo Method

Item.SaveTo Method

Saves the item data to a binary stream or an XML document.

Overload List

Name | Description
Item.SaveTo (XmlElement, XmlSerializationContext) | Saves the item data to an XML document.
Item.SaveTo (XmlWriter, SerializationContext) | Saves the item data to an XML document. Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.SaveTo Method (XmlElement, XmlSerializationContext)

Item.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the item data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public virtual void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overridable Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

SaveTo Method Overload List
Item Members
Item Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Item.SaveTo Method (XmlWriter, SerializationContext)

Item.SaveTo Method (XmlWriter, SerializationContext)
See Also

Saves the item data to an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public virtual void SaveTo (
XmlWriter writer,
SerializationContext context
)
Visual Basic

Public Overridable Sub SaveTo ( _
writer As XmlWriter, _
context As SerializationContext _
)

Parameters

writer
Allows adding data to the XML document.
context
The context object contains the current revision number of the schedule file format.

Remarks

The writer parameter wraps an XML document to which the item is being serialized. If you override this method in your own item class, you must also override LoadFrom, so that each element written by SaveTo method is read by LoadFrom.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Item Properties

Item Properties

Public Properties

Name | Description
AllDayEvent | Gets or sets a value indicating whether the item represents an all day event.
AllowChangeEnd | Gets or sets a value indicating whether users are allowed to change the item's end time.
AllowChangeStart | Gets or sets a value indicating whether users are allowed to change the item's start time.
AllowMove | Gets or sets a value indicating whether users are allowed to move the item.
Contacts | Gets references to all contacts associated with this item.
DescriptionText | Gets or sets the description displayed for this item by scheduling controls.
EndTime | Gets or sets the item's scheduled end time.
HeaderText | Gets or sets the header text displayed for this item by scheduling controls.
Id | Gets or sets the string identifier of this item.
ImageIndex | Gets or sets the index of the image associated with this item. Since version 4.1, this property is considered obsolete. Instead, use the ImageIndex property of the associated Style.
Location | Gets or sets the location associated with this item.
Locked | Gets or sets a value indicating whether users are forbidden to modify this item.
OccurrenceIndex | Gets the index of a repeating occurrence of a recurring item.
Priority | Gets or sets the priority of this item.
Recurrence | Gets or sets the recurrence pattern of this item.
RecurrenceState | Gets the recurrence state of this item.
Reminder | Gets or sets the reminder for this item.
Resources | Gets references to all resources associated with this item.
SelectedStyle | Gets or sets the selected style associated with the item.
StartTime | Gets or sets the item's scheduled start time.
Style | Gets or sets a style associated with the item.
Tag | Gets or sets custom data associated with the item.
Task | Gets or sets the task associated with this item.
Visible | Gets or sets a flag indicating whether the item is visible or not.

See Also

Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.AllDayEvent Property

Item.AllDayEvent Property

Gets or sets a value indicating whether the item represents an all day event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract bool AllDayEvent { get; set; }
Visual Basic

Public MustOverride Property AllDayEvent As Boolean

Property Value

true if the item is an all day event; otherwise, false.

Remarks

All day event items are displayed in a special header area when the Calendar displays a timetable view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
StartTime Property
EndTime Property


MindFusion.Scheduling.Item.AllowChangeEnd Property

Item.AllowChangeEnd Property

Gets or sets a value indicating whether users are allowed to change the item's end time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract bool AllowChangeEnd { get; set; }
Visual Basic

Public MustOverride Property AllowChangeEnd As Boolean

Property Value

true if the item's end can be modified interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowMove Property


MindFusion.Scheduling.Item.AllowChangeStart Property

Item.AllowChangeStart Property

Gets or sets a value indicating whether users are allowed to change the item's start time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract bool AllowChangeStart { get; set; }
Visual Basic

Public MustOverride Property AllowChangeStart As Boolean

Property Value

true if the item's start can be modified interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeEnd Property
AllowMove Property


MindFusion.Scheduling.Item.AllowMove Property

Item.AllowMove Property

Gets or sets a value indicating whether users are allowed to move the item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract bool AllowMove { get; set; }
Visual Basic

Public MustOverride Property AllowMove As Boolean

Property Value

true if the item can be moved interactively; otherwise, false. The default is true.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
AllowChangeStart Property
AllowChangeEnd Property


MindFusion.Scheduling.Item.Contacts Property

Item.Contacts Property

Gets references to all contacts associated with this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract ContactCollection Contacts { get; }
Visual Basic

Public MustOverride ReadOnly Property Contacts As ContactCollection

Property Value

An instance of the ContactCollection class containing the Contact objects associated with the item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.DescriptionText Property

Item.DescriptionText Property

Gets or sets the description displayed for this item by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract string DescriptionText { get; set; }
Visual Basic

Public MustOverride Property DescriptionText As String

Property Value

A string containing the description of this item.

Remarks

All classes that derive from Item must implement this property. Controls such as Calendar display this text in the details area of an item visual representation.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.EndTime Property

Item.EndTime Property

Gets or sets the item's scheduled end time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract DateTime EndTime { get; set; }
Visual Basic

Public MustOverride Property EndTime As DateTime

Property Value

A .NET DateTime instance.

Remarks

This property specifies the last time cell occupied by the item in a Calendar view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
StartTime Property
AllDayEvent Property


MindFusion.Scheduling.Item.HeaderText Property

Item.HeaderText Property

Gets or sets the header text displayed for this item by scheduling controls.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract string HeaderText { get; set; }
Visual Basic

Public MustOverride Property HeaderText As String

Property Value

A string specifying the item's header text.

Remarks

Calendar views display this value in the header area of the box that represents an item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Id Property

Item.Id Property

Gets or sets the string identifier of this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract string Id { get; set; }
Visual Basic

Public MustOverride Property Id As String

Property Value

A string whose value uniquely identifies the item.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.ImageIndex Property

Item.ImageIndex Property

Gets or sets the index of the image associated with this item.

Since version 4.1, this property is considered obsolete. Instead, use the ImageIndex property of the associated Style.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract int ImageIndex { get; set; }
Visual Basic

Public MustOverride Property ImageIndex As Integer

Property Value

An integer value specifying the index of an image within the Calendar.ImageList.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Location Property

Item.Location Property

Gets or sets the location associated with this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract Location Location { get; set; }
Visual Basic

Public MustOverride Property Location As Location

Property Value

An instance of the Location class.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Locked Property

Item.Locked Property

Gets or sets a value indicating whether users are forbidden to modify this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract bool Locked { get; set; }
Visual Basic

Public MustOverride Property Locked As Boolean

Property Value

true if users are allowed to move the item thus changing its scheduled time; otherwise, false.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.OccurrenceIndex Property

Item.OccurrenceIndex Property

Gets the index of a repeating occurrence of a recurring item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int OccurrenceIndex { get; set; }
Visual Basic

Public Property OccurrenceIndex As Integer

Property Value

An integer value identifying the index of an occurrence item within the recurrence array. If the item is not recurring, this property returns -1.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
Recurrence Property
RecurrenceState Property


MindFusion.Scheduling.Item.Priority Property

Item.Priority Property

Gets or sets the priority of this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int Priority { get; set; }
Visual Basic

Public Property Priority As Integer

Property Value

An integer value, specifying the item's priority.

Remarks

Items with higher priority have a better chance to be displayed prior items with lower priority. If two items start and end at the same time, the item with higher Priority will be displayed before the item with lower Priority. In other words, this property gives you control over the order of the items.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Recurrence Property

Item.Recurrence Property

Gets or sets the recurrence pattern of this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Recurrence Recurrence { get; set; }
Visual Basic

Public Property Recurrence As Recurrence

Property Value

An instance of the Recurrence class. The default is null (Nothing in Visual Basic).

Remarks

If this property is set, the item becomes a recurring event and the Calendar control displays multiple occurrences of the item. To detach a previously set recurrence from an item, set this property to null.

Example

The following example demonstrates how to create and attach a recurring pattern to an existing item. The example assumes that item identifies an existing Item object.

C#

// Create the recurrence so that the item occurs once every two days
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Daily;
recurrence.Days = 2;
recurrence.StartDate = item.StartTime;
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the item by simply setting the Recurrence property
item.Recurrence = recurrence;
Visual Basic

' Create the recurrence so that the item occurs once every two days
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Daily
recurrence.Days = 2
recurrence.StartDate = item.StartTime
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the item by simply setting the Recurrence property
item.Recurrence = recurrence

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
RecurrenceState Property
OccurrenceIndex Property


MindFusion.Scheduling.Item.RecurrenceState Property

Item.RecurrenceState Property

Gets the recurrence state of this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public RecurrenceState RecurrenceState { get; set; }
Visual Basic

Public Property RecurrenceState As RecurrenceState

Property Value

A member of the RecurrenceState enumeration.

Remarks

Events raised by the Calendar control could pass as an argument an occurrence or an exception of a recurring item. This property lets you determine the exact state of the item's recurrence state.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
Recurrence Property
OccurrenceIndex Property


MindFusion.Scheduling.Item.Reminder Property

Item.Reminder Property

Gets or sets the reminder for this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract Reminder Reminder { get; set; }
Visual Basic

Public MustOverride Property Reminder As Reminder

Property Value

An instance of the Reminder class.

Remarks

If the reminder type is Exact, the ItemReminderTriggered event is raised at the time set in the reminder's Time property. If the reminder type is Leading, the ItemReminderTriggered event is raised certain amount of time prior to the item's StartTime, as specified in the reminder's TimeInterval property.

Note:

Recurring items cannot have leading reminders.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Resources Property

Item.Resources Property

Gets references to all resources associated with this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract ResourceCollection Resources { get; }
Visual Basic

Public MustOverride ReadOnly Property Resources As ResourceCollection

Property Value

An instance of the ResourceCollection class containing the resources associated with this item.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.SelectedStyle Property

Item.SelectedStyle Property

Gets or sets the selected style associated with the item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract Style SelectedStyle { get; set; }
Visual Basic

Public MustOverride Property SelectedStyle As Style

Property Value

A Style object that defines the appearance of the item.

Remarks

This style is applied to the item when it is selected.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
Style Property
PointedStyle Property
PointedSelectedStyle Property


MindFusion.Scheduling.Item.StartTime Property

Item.StartTime Property

Gets or sets the item's scheduled start time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract DateTime StartTime { get; set; }
Visual Basic

Public MustOverride Property StartTime As DateTime

Property Value

A .NET DateTime instance specifying the scheduled time for the item.

Remarks

This property affects the initial time cell occupied by the item when it is displayed in a Calendar view.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
EndTime Property
AllDayEvent Property


MindFusion.Scheduling.Item.Style Property

Item.Style Property

Gets or sets a style associated with the item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract Style Style { get; set; }
Visual Basic

Public MustOverride Property Style As Style

Property Value

A Style object that defines the appearance of the item.

Remarks

This style is applied to the item when it is neither pointed with the mouse nor selected.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace
SelectedStyle Property
PointedStyle Property
PointedSelectedStyle Property


MindFusion.Scheduling.Item.Tag Property

Item.Tag Property

Gets or sets custom data associated with the item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract Object Tag { get; set; }
Visual Basic

Public MustOverride Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data. The tag can be a value from a primitive data type or a complex object from the .NET class library or a class defined by you. If the tag is an instance of a value type, it will be serialized together with the object containing it when saving / loading the schedule. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Task Property

Item.Task Property

Gets or sets the task associated with this item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract Task Task { get; set; }
Visual Basic

Public MustOverride Property Task As Task

Property Value

An instance of the Task class.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Item.Visible Property

Item.Visible Property

Gets or sets a flag indicating whether the item is visible or not.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public abstract bool Visible { get; set; }
Visual Basic

Public MustOverride Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false. The default is true.

Remarks

Invisible items are not drawn at all. You could use this property to hide an item temporarily, or to store additional data in a helper item object that always stays invisible.

See Also

Item Members
Item Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Class

ItemCollection Class

Represents a strongly typed collection of Item objects.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public sealed class ItemCollection : CollectionBase
Visual Basic

Public NotInheritable Class ItemCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.ItemCollection

See Also

ItemCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Members

ItemCollection Members
Constructors Properties Methods Events

Represents a strongly typed collection of Item objects.

The following tables list the members exposed by the ItemCollection type.

Public Constructors

Name | Description
ItemCollection | Initializes a new instance of the ItemCollection class.

Public Properties

Name | Description
Item | Gets an Item object from the collection given its zero-based index or identifier.

Public Methods

Name | Description
Add | Adds the specified item to this collection.
AddRange | Adds the specified items to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified item.
IndexOf | Returns the zero-based index of the first occurrence of the specified item within this collection.
Insert | Inserts the specified item at the specified position within the collection.
Remove | Removes the first occurrence of the specified item from this collection.
RemoveAt | Removes the item at the specified index of this collection.

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Constructor

ItemCollection Constructor

Initializes a new instance of the ItemCollection class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection ()
Visual Basic

Public Sub New ()

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Methods

ItemCollection Methods

Public Methods

Name | Description
Add | Adds the specified item to this collection.
AddRange | Adds the specified items to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified item.
IndexOf | Returns the zero-based index of the first occurrence of the specified item within this collection.
Insert | Inserts the specified item at the specified position within the collection.
Remove | Removes the first occurrence of the specified item from this collection.
RemoveAt | Removes the item at the specified index of this collection.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Add Method

ItemCollection.Add Method

Adds the specified item to this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Add (
Item item
)
Visual Basic

Public Sub Add ( _
item As Item _
)

Parameters

item
An Item instance to be added to the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
AddRange Method
Insert Method


MindFusion.Scheduling.ItemCollection.AddRange Method

ItemCollection.AddRange Method

Adds the specified items to this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void AddRange (
ItemCollection items
)
Visual Basic

Public Sub AddRange ( _
items As ItemCollection _
)

Parameters

items
A collection of items to add to this collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
Add Method
Insert Method


MindFusion.Scheduling.ItemCollection.Clear Method

ItemCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Contains Method

ItemCollection.Contains Method

Determines whether this collection contains the specified item.

Overload List

Name | Description
ItemCollection.Contains (Item) | Determines whether this collection contains the specified item.
ItemCollection.Contains (String) | Determines whether this collection contains an item identified by the specified string.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Contains Method (Item)

ItemCollection.Contains Method (Item)
See Also

Determines whether this collection contains the specified item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
Item item
)
Visual Basic

Public Function Contains ( _
item As Item _
) As Boolean

Parameters

item
The item to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
IndexOf Method


MindFusion.Scheduling.ItemCollection.Contains Method (String)

ItemCollection.Contains Method (String)
See Also

Determines whether this collection contains an item identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
string id
)
Visual Basic

Public Function Contains ( _
id As String _
) As Boolean

Parameters

id
The identifier of an item to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
IndexOf Method


MindFusion.Scheduling.ItemCollection.IndexOf Method

ItemCollection.IndexOf Method

Returns the zero-based index of the first occurrence of the specified item within this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int IndexOf (
Item item
)
Visual Basic

Public Function IndexOf ( _
item As Item _
) As Integer

Parameters

item
The item to locate in the collection.

Return Value

The zero-based index of the first occurrence of the item within the collection, if found; otherwise, -1.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Insert Method

ItemCollection.Insert Method

Inserts the specified item at the specified position within the collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Insert (
int index,
Item item
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
item As Item _
)

Parameters

index
The zero-based index at which the item must be inserted.
item
An instance of the Item class to be added to the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
Add Method
AddRange Method


MindFusion.Scheduling.ItemCollection.Remove Method

ItemCollection.Remove Method

Removes the first occurrence of the specified item from this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Remove (
Item item
)
Visual Basic

Public Sub Remove ( _
item As Item _
)

Parameters

item
An instance of the Item class, which must be removed from the collection.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
RemoveAt Method


MindFusion.Scheduling.ItemCollection.RemoveAt Method

ItemCollection.RemoveAt Method

Removes the item at the specified index of this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The zero-based index of the item to remove.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace
Remove Method


MindFusion.Scheduling.ItemCollection Properties

ItemCollection Properties

Public Properties

Name | Description
Item | Gets an Item object from the collection given its zero-based index or identifier.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property

ItemCollection.Item Property

Gets an Item object from the collection given its zero-based index or identifier.

Overload List

Name | Description
ItemCollection.Item (Int32) | Gets or sets the item located at the specified position within this collection.
ItemCollection.Item (String) | Gets the item identified by the specified string.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property (Int32)

ItemCollection.Item Property (Int32)
See Also

Gets or sets the item located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Item Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Item

Parameters

index
The zero-based index of the Item to set or retrieve.

Property Value

The Item instance at the specified index.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their integer indices.

See Also

Item Property Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Item Property (String)

ItemCollection.Item Property (String)
See Also

Gets the item identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Item Item [
string id
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
id As String _
) As Item

Parameters

id
The Id of the Item to get.

Property Value

The Item instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection Events

ItemCollection Events

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemCollection.Changed Event

ItemCollection.Changed Event

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public EventHandler Changed
Visual Basic

Public Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

ItemCollection Members
ItemCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Class

ItemEventArgs Class

Contains the arguments passed to handlers of item related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class ItemEventArgs : EventArgs
Visual Basic

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.ItemTimeEventArgs

See Also

ItemEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Members

ItemEventArgs Members
Properties

Contains the arguments passed to handlers of item related events raised by the Schedule class.

The following tables list the members exposed by the ItemEventArgs type.

Public Properties

Name | Description
Item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs Properties

ItemEventArgs Properties

Public Properties

Name | Description
Item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventArgs.Item Property

ItemEventArgs.Item Property

Gets the item related to the event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class.

See Also

ItemEventArgs Members
ItemEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemEventHandler Delegate

ItemEventHandler Delegate

Represents methods that will handle general item related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public delegate void ItemEventHandler (
Object sender,
ItemEventArgs e
)
Visual Basic

Public Delegate Sub ItemEventHandler ( _
sender As Object, _
e As ItemEventArgs _
)

Parameters

sender
The source of the event.
e
An ItemEventArgs that contains the event data.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Class

ItemTimeEventArgs Class

Contains the arguments passed to handlers of time related events.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class ItemTimeEventArgs : ItemEventArgs
Visual Basic

Public Class ItemTimeEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.ItemEventArgs
MindFusion.Scheduling.ItemTimeEventArgs

See Also

ItemTimeEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Members

ItemTimeEventArgs Members
Properties

Contains the arguments passed to handlers of time related events.

The following tables list the members exposed by the ItemTimeEventArgs type.

Public Properties

Name | Description
Time | Gets the old value of the time property whose change caused the event to occur.

See Also

ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs Properties

ItemTimeEventArgs Properties

Public Properties

Name | Description
Time | Gets the old value of the time property whose change caused the event to occur.

See Also

ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventArgs.Time Property

ItemTimeEventArgs.Time Property

Gets the old value of the time property whose change caused the event to occur.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime Time { get; }
Visual Basic

Public ReadOnly Property Time As DateTime

Property Value

An instance of the .NET DateTime class.

See Also

ItemTimeEventArgs Members
ItemTimeEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ItemTimeEventHandler Delegate

ItemTimeEventHandler Delegate

Represents methods that will handle the time related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public delegate void ItemTimeEventHandler (
Object sender,
ItemTimeEventArgs e
)
Visual Basic

Public Delegate Sub ItemTimeEventHandler ( _
sender As Object, _
e As ItemTimeEventArgs _
)

Parameters

sender
The source of the event.
e
A ItemTimeEventArgs that contains the event data.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Class

Location Class

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class Location : Resource
Visual Basic

Public Class Location
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Location

See Also

Location Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Members

Location Members
Constructors Properties Methods

Instances of this class contain address information that identifies distinct locations. Location objects are used by schedule classes that have locations and addresses allocated to them.

The following tables list the members exposed by the Location type.

Public Constructors

Name | Description
Location | Initializes a new instance of the Location class.

Public Properties

Name | Description
Address | Gets or sets the address of the location.
City | Gets or sets the city of this location.
Country | Gets or sets the country of this location.
State | Gets or sets the state of this location.
ZipCode | Gets or sets the zip-code of this location.

Public Methods

Name | Description
LoadFrom | Overloaded. Loads location data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the location data to a binary stream or an XML document.

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Constructor

Location Constructor

Initializes a new instance of the Location class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Location ()
Visual Basic

Public Sub New ()

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location Methods

Location Methods

Public Methods

Name | Description
LoadFrom | Overloaded. Loads location data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the location data to a binary stream or an XML document.

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.LoadFrom Method

Location.LoadFrom Method

Loads location data from a binary stream or an XML document.

Overload List

Name | Description
Location.LoadFrom (XmlElement, XmlSerializationContext) | Loads location data from an XML document.
Location.LoadFrom (XmlReader, SerializationContext) | Loads location data from an XML document. Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.LoadFrom Method (XmlElement, XmlSerializationContext)

Location.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads location data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

LoadFrom Method Overload List
Location Members
Location Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Location.LoadFrom Method (XmlReader, SerializationContext)

Location.LoadFrom Method (XmlReader, SerializationContext)
See Also

Loads location data from an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void LoadFrom (
XmlReader reader,
SerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
reader As XmlReader, _
context As SerializationContext _
)

Parameters

reader
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also allows getting locations, contacts and tasks by their string identifiers.

Remarks

Loads the location fields from an XML document where they were saved previously using SaveTo.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Location.SaveTo Method

Location.SaveTo Method

Saves the location data to a binary stream or an XML document.

Overload List

Name | Description
Location.SaveTo (XmlElement, XmlSerializationContext) | Saves the location data to an XML document.
Location.SaveTo (XmlWriter, SerializationContext) | Saves the location data to an XML document. Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.SaveTo Method (XmlElement, XmlSerializationContext)

Location.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the location data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

See Also

SaveTo Method Overload List
Location Members
Location Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Location.SaveTo Method (XmlWriter, SerializationContext)

Location.SaveTo Method (XmlWriter, SerializationContext)
See Also

Saves the location data to an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void SaveTo (
XmlWriter writer,
SerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
writer As XmlWriter, _
context As SerializationContext _
)

Parameters

writer
Allows adding data to the XML document.
context
The context object contains the current revision number of the schedule file format.

Remarks

This method saves the location properties as elements of an XML document.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Location Properties

Location Properties

Public Properties

Name | Description
Address | Gets or sets the address of the location.
City | Gets or sets the city of this location.
Country | Gets or sets the country of this location.
State | Gets or sets the state of this location.
ZipCode | Gets or sets the zip-code of this location.

See Also

Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.Address Property

Location.Address Property

Gets or sets the address of the location.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Address { get; set; }
Visual Basic

Public Property Address As String

Property Value

A string specifying the address of this location. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
City Property
State Property
Country Property


MindFusion.Scheduling.Location.City Property

Location.City Property

Gets or sets the city of this location.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string City { get; set; }
Visual Basic

Public Property City As String

Property Value

A string specifying the city where this location is located. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
Address Property
State Property
Country Property


MindFusion.Scheduling.Location.Country Property

Location.Country Property

Gets or sets the country of this location.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Country { get; set; }
Visual Basic

Public Property Country As String

Property Value

A string specifying the country where this location is located. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Location.State Property

Location.State Property

Gets or sets the state of this location.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string State { get; set; }
Visual Basic

Public Property State As String

Property Value

A string identifying the state where this location is. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace
Address Property
City Property
Country Property


MindFusion.Scheduling.Location.ZipCode Property

Location.ZipCode Property

Gets or sets the zip-code of this location.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string ZipCode { get; set; }
Visual Basic

Public Property ZipCode As String

Property Value

A string containing the location's Zip code. The default is an empty string.

See Also

Location Members
Location Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Class

LocationCollection Class

Represents a strongly typed collection of Location objects.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public sealed class LocationCollection : CollectionBase
Visual Basic

Public NotInheritable Class LocationCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.LocationCollection

See Also

LocationCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Members

LocationCollection Members
Constructors Properties Methods Events

Represents a strongly typed collection of Location objects.

The following tables list the members exposed by the LocationCollection type.

Public Constructors

Name | Description
LocationCollection | Initializes a new instance of the LocationCollection class.

Public Properties

Name | Description
Item | Gets a Location object from the collection given its zero-based index or identifier.

Public Methods

Name | Description
Add | Adds the specified location to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified location.
Insert | Inserts the specified location object at the specified position within the collection.
Remove | Removes the first occurrence of the specified location object from this collection.

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Constructor

LocationCollection Constructor

Initializes a new instance of the LocationCollection class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public LocationCollection ()
Visual Basic

Public Sub New ()

See Also

LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Methods

LocationCollection Methods

Public Methods

Name | Description
Add | Adds the specified location to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified location.
Insert | Inserts the specified location object at the specified position within the collection.
Remove | Removes the first occurrence of the specified location object from this collection.

See Also

LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Add Method

LocationCollection.Add Method

Adds the specified location to this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Add (
Location location
)
Visual Basic

Public Sub Add ( _
location As Location _
)

Parameters

location
An instance of the Location class to be added to the collection.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace
Insert Method


MindFusion.Scheduling.LocationCollection.Clear Method

LocationCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Contains Method

LocationCollection.Contains Method

Determines whether this collection contains the specified location.

Overload List

Name | Description
LocationCollection.Contains (Location) | Determines whether this collection contains the specified location.
LocationCollection.Contains (String) | Determines whether this collection contains a location identified by the specified string.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Contains Method (Location)

LocationCollection.Contains Method (Location)
See Also

Determines whether this collection contains the specified location.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
Location location
)
Visual Basic

Public Function Contains ( _
location As Location _
) As Boolean

Parameters

location
The Location object to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Contains Method (String)

LocationCollection.Contains Method (String)
See Also

Determines whether this collection contains a location identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
string locationId
)
Visual Basic

Public Function Contains ( _
locationId As String _
) As Boolean

Parameters

locationId
The identifier of a location to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Insert Method

LocationCollection.Insert Method

Inserts the specified location object at the specified position within the collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Insert (
int index,
Location location
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
location As Location _
)

Parameters

index
The zero-based index at which the location must be inserted.
location
An instance of the Location class to be added to the collection.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace
Add Method


MindFusion.Scheduling.LocationCollection.Remove Method

LocationCollection.Remove Method

Removes the first occurrence of the specified location object from this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Remove (
Location location
)
Visual Basic

Public Sub Remove ( _
location As Location _
)

Parameters

location
A Location instance which must be removed from the collection.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Properties

LocationCollection Properties

Public Properties

Name | Description
Item | Gets a Location object from the collection given its zero-based index or identifier.

See Also

LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Item Property

LocationCollection.Item Property

Gets a Location object from the collection given its zero-based index or identifier.

Overload List

Name | Description
LocationCollection.Item (Int32) | Gets or sets the location object located at the specified position within this collection.
LocationCollection.Item (String) | Gets the location object identified by the specified string.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Item Property (Int32)

LocationCollection.Item Property (Int32)
See Also

Gets or sets the location object located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Location Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Location

Parameters

index
The zero-based index of the Location to set or retrieve.

Property Value

The Location object at the specified index.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their integer indices.

See Also

Item Property Overload List
LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Item Property (String)

LocationCollection.Item Property (String)
See Also

Gets the location object identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Location Item [
string id
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
id As String _
) As Location

Parameters

id
The Id of the Location to get.

Property Value

The Location instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection Events

LocationCollection Events

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.LocationCollection.Changed Event

LocationCollection.Changed Event

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public EventHandler Changed
Visual Basic

Public Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

LocationCollection Members
LocationCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.MonthlyRecurrence Enumeration

MonthlyRecurrence Enumeration

Specifies the types of monthly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum MonthlyRecurrence
Visual Basic

Public Enumeration MonthlyRecurrence

Members

Member name | Description
ByDayNumber | The event occurs on a specific day of the month.
ByDayType | The event occurs on a specific type of day of the specified week of the month.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Occurrence Enumeration

Occurrence Enumeration

Specifies the occurrence number of a day or a week within a month.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum Occurrence
Visual Basic

Public Enumeration Occurrence

Members

Member name | Description
First | Indicates the first occurrence.
Fourth | Indicates the fourth occurrence.
Last | Indicates the last occurrence.
Second | Indicates the second occurrence.
Third | Indicates the third occurrence.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Class

Recurrence Class

Defines recurrence patterns for items scheduled to repeat over and over again.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class Recurrence : ICloneable
Visual Basic

Public Class Recurrence
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Recurrence

See Also

Recurrence Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Members

Recurrence Members
Constructors Properties Methods

Defines recurrence patterns for items scheduled to repeat over and over again.

The following tables list the members exposed by the Recurrence type.

Public Constructors

Name | Description
Recurrence | Initializes a new instance of the Recurrence class.

Public Properties

Name | Description
DailyRecurrence | Gets or sets the type of daily recurrence.
Day | Gets or sets a value indicating on which day of a week the event occurs.
DayOfMonth | Gets or sets on which day of a month the event occurs.
Days | Gets or sets how many days should pass before the event occurs again.
DaysOfWeek | Gets or sets on which days of a week the event occurs.
EndDate | Gets or sets the end date of the recurrence.
Exceptions | Gets the list of all recurrence exceptions.
Interval | Gets or sets the recurrence interval.
Master | Gets the master item of this recurrence. The property returns null if the recurrence is not associated with an item.
MonthlyRecurrence | Gets or sets the type of monthly recurrence.
MonthOfYear | Gets or sets in which month of the year the event occurs.
Months | Gets or sets how many months should pass before the event occurs again.
NumOccurrences | Gets or sets how many times the recurring event should occur.
Occurrence | Gets or sets on which occurrence of the day type specified in Day the event occurs.
Pattern | Gets or sets the recurrence pattern.
RecurrenceEnd | Gets or sets when the event should stop recurring.
StartDate | Gets or sets when the recurring event should occur for the first time.
Weeks | Gets or sets how many weeks should pass before the event occurs again.
YearlyRecurrence | Gets or sets the type of yearly recurrence.

Public Methods

Name | Description
ApplyPattern | Copies the fields of the specified Recurrence object to this recurrence.
ClearExceptions | Removes all exceptions of this recurrence.
Clone | Creates an exact copy of this Recurrence object.
GenerateItems | Creates occurrence items for this recurrence in the specified date range.
GetEndDate | Returns the end date for this recurrence.
GetOccurrence | Overloaded. Returns the occurrence having the specified index.
LoadFrom | Overloaded. Loads recurrence data from a binary stream or an XML document.
MarkException | Marks the specified item as an exception of a recurrence pattern.
SamePatternAs | Determines whether two Recurrence objects define the same recurrence pattern.
SaveTo | Overloaded. Saves the recurrence data to a binary stream or an XML document.
ToString | Overloaded. Creates a string from this recurrence.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Constructor

Recurrence Constructor

Initializes a new instance of the Recurrence class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Recurrence ()
Visual Basic

Public Sub New ()

Example

The following example creates a new recurrence object and associates it with an existing appointment. The example assumes that the appointment referenced by app already exists.

C#

// Create a recurrence that happens at the third weekend
// every three months, effective July 14th, 2005.
// The recurrence is infinite
Recurrence recurrence = new Recurrence();
recurrence.Pattern = RecurrencePattern.Monthly;
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType;
recurrence.Occurrence = Occurrence.Third;
recurrence.Day = DayOfWeekType.Weekend;
recurrence.Months = 3;
recurrence.StartDate = new DateTime(2005, 7, 14);
recurrence.RecurrenceEnd = RecurrenceEnd.Never;

// Associate the recurrence with the appointment
app.Recurrence = recurrence;
Visual Basic

' Create a recurrence that happens at the third weekend
' every three months, effective July 14th, 2005.
' The recurrence is infinite
Dim recurrence As New Recurrence()
recurrence.Pattern = RecurrencePattern.Monthly
recurrence.MonthlyRecurrence = MonthlyRecurrence.ByDayType
recurrence.Occurrence = Occurrence.Third
recurrence.Day = DayOfWeekType.Weekend
recurrence.Months = 3
recurrence.StartDate = New DateTime(2005, 7, 14)
recurrence.RecurrenceEnd = RecurrenceEnd.Never

' Associate the recurrence with the appointment
app.Recurrence = recurrence

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Methods

Recurrence Methods

Public Methods

Name | Description
ApplyPattern | Copies the fields of the specified Recurrence object to this recurrence.
ClearExceptions | Removes all exceptions of this recurrence.
Clone | Creates an exact copy of this Recurrence object.
GenerateItems | Creates occurrence items for this recurrence in the specified date range.
GetEndDate | Returns the end date for this recurrence.
GetOccurrence | Overloaded. Returns the occurrence having the specified index.
LoadFrom | Overloaded. Loads recurrence data from a binary stream or an XML document.
MarkException | Marks the specified item as an exception of a recurrence pattern.
SamePatternAs | Determines whether two Recurrence objects define the same recurrence pattern.
SaveTo | Overloaded. Saves the recurrence data to a binary stream or an XML document.
ToString | Overloaded. Creates a string from this recurrence.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ApplyPattern Method

Recurrence.ApplyPattern Method

Copies the fields of the specified Recurrence object to this recurrence.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void ApplyPattern (
Recurrence recurrence
)
Visual Basic

Public Sub ApplyPattern ( _
recurrence As Recurrence _
)

Parameters

recurrence
The Recurrence object whose fields to copy.

Remarks

This method behaves similarly to the Clone method except that it does not create a new object.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ClearExceptions Method

Recurrence.ClearExceptions Method

Removes all exceptions of this recurrence.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void ClearExceptions ()
Visual Basic

Public Sub ClearExceptions ()

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Clone Method

Recurrence.Clone Method

Creates an exact copy of this Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

A new Recurrence object, cloned from this one.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
ApplyPattern Method


MindFusion.Scheduling.Recurrence.GenerateItems Method

Recurrence.GenerateItems Method

Creates occurrence items for this recurrence in the specified date range.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection GenerateItems (
DateTime startDate,
DateTime endDate
)
Visual Basic

Public Function GenerateItems ( _
startDate As DateTime, _
endDate As DateTime _
) As ItemCollection

Parameters

startDate
The range start date.
endDate
The range end date.

Return Value

A collection of Item instances representing each occurrence of the recurrent event in the specified date range.

Remarks

The Calendar control uses this method to generate item occurrences when a recurrent item must be displayed in the current view.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetEndDate Method

Recurrence.GetEndDate Method

Returns the end date for this recurrence.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime GetEndDate ()
Visual Basic

Public Function GetEndDate () As DateTime

Return Value

The end date of the recurrence if the recurrence is set to expire or DateTime.MaxValue otherwise.

Remarks

The end date is calculated from the specified repeat number if RecurrenceEnd is set to NumOccurrences.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method

Recurrence.GetOccurrence Method

Returns the occurrence having the specified index.

Overload List

Name | Description
Recurrence.GetOccurrence (Int32, ref Boolean) | Returns the occurrence having the specified index.
Recurrence.GetOccurrence (Int32, ref Boolean, Boolean) | Returns the occurrence having the specified index.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, ref Boolean)

Recurrence.GetOccurrence Method (Int32, ref Boolean)
See Also

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Item GetOccurrence (
int index,
ref bool isDeleted
)
Visual Basic

Public Function GetOccurrence ( _
index As Integer, _
ByRef isDeleted As Boolean _
) As Item

Parameters

index

The index of the occurrence to retrieve.

isDeleted
If the specified occurrence is an exception, this parameter contains upon function completion whether the exception is deleted or not.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.GetOccurrence Method (Int32, ref Boolean, Boolean)

Recurrence.GetOccurrence Method (Int32, ref Boolean, Boolean)
See Also

Returns the occurrence having the specified index.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Item GetOccurrence (
int index,
ref bool isDeleted,
bool noException
)
Visual Basic

Public Function GetOccurrence ( _
index As Integer, _
ByRef isDeleted As Boolean, _
noException As Boolean _
) As Item

Parameters

index
The index of the occurrence to retrieve.
isDeleted
If the specified occurrence is an exception, this parameter contains upon function completion whether the exception is deleted or not.
noException
Specifies whether to return the original item, in case this occurrence is an exception.

Return Value

A reference to the occurrence with the specified index or null (Nothing in Visual Basic), if there is no such occurrence.

Remarks

This function might take considerable amount of time if you specify a large index in an infinite recurrence.

See Also

GetOccurrence Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.LoadFrom Method

Recurrence.LoadFrom Method

Loads recurrence data from a binary stream or an XML document.

Overload List

Name | Description
Recurrence.LoadFrom (XmlElement, XmlSerializationContext) | Loads the recurrence data from an XML document.
Recurrence.LoadFrom (XmlReader, SerializationContext) | Loads the recurrence data from an XML document. Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.LoadFrom Method (XmlElement, XmlSerializationContext)

Recurrence.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads the recurrence data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

Loads the state of a recurrence from an XML document, where it was previously saved via SaveTo.

See Also

LoadFrom Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Recurrence.LoadFrom Method (XmlReader, SerializationContext)

Recurrence.LoadFrom Method (XmlReader, SerializationContext)
See Also

Loads the recurrence data from an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void LoadFrom (
XmlReader reader,
SerializationContext context
)
Visual Basic

Public Sub LoadFrom ( _
reader As XmlReader, _
context As SerializationContext _
)

Parameters

reader
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also allows getting locations, contacts and tasks by their string identifiers.

Remarks

Loads the state of a recurrence from an XML document, where it was previously saved via SaveTo.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Recurrence.MarkException Method

Recurrence.MarkException Method

Marks the specified item as an exception of a recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void MarkException (
Item item,
bool deleted
)
Visual Basic

Public Sub MarkException ( _
item As Item, _
deleted As Boolean _
)

Parameters

item
The Item instance to be marked as an exception.
deleted
Specifies whether the exception is created by deleting one occurrence from the recurrent pattern or by changing the occurrence time properties.

Remarks

The Calendar control calls this method when a user drags an occurrence item or edits its text, thus creating an exception of the recurrence.

Example

The following example deletes the occurrences of an existing recurrence that are located in the specified date interval. The example assumes that recurrence identifies an existing Recurrence object.

C#

ItemCollection items =
recurrence.GenerateItems(new DateTime(2005, 1, 1), new DateTime(2005, 12, 31));

foreach (Item item in items)
recurrence.MarkException(item, true);
Visual Basic

Dim items As ItemCollection = _
recurrence.GenerateItems(New DateTime(2005, 1, 1), New DateTime(2005, 12, 31))

Dim item as Item
For Each item in items
recurrence.MarkException(item, True)
Next item

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
Exceptions Property


MindFusion.Scheduling.Recurrence.SamePatternAs Method

Recurrence.SamePatternAs Method

Determines whether two Recurrence objects define the same recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool SamePatternAs (
Recurrence recurrence
)
Visual Basic

Public Function SamePatternAs ( _
recurrence As Recurrence _
) As Boolean

Parameters

recurrence
A Recurrence object to compare with this recurrence.

Return Value

true if the Recurrence instances represent the same recurrence patterns; otherwise, false.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.SaveTo Method

Recurrence.SaveTo Method

Saves the recurrence data to a binary stream or an XML document.

Overload List

Name | Description
Recurrence.SaveTo (XmlElement, XmlSerializationContext) | Saves the recurrence data to an XML document.
Recurrence.SaveTo (XmlWriter, SerializationContext) | Saves the recurrence data to an XML document. Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.SaveTo Method (XmlElement, XmlSerializationContext)

Recurrence.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the recurrence data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

The recurrence properties are saved as elements of an XML document, and can be later restored using the LoadFrom method.

See Also

SaveTo Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Recurrence.SaveTo Method (XmlWriter, SerializationContext)

Recurrence.SaveTo Method (XmlWriter, SerializationContext)
See Also

Saves the recurrence data to an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void SaveTo (
XmlWriter writer,
SerializationContext context
)
Visual Basic

Public Sub SaveTo ( _
writer As XmlWriter, _
context As SerializationContext _
)

Parameters

writer
Allows adding data to the XML document.
context
The context object contains the current revision number of the schedule file format.

Remarks

The recurrence properties are saved as elements of an XML document, and can be later restored using the LoadFrom method.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Recurrence.ToString Method

Recurrence.ToString Method

Creates a string from this recurrence.

Overload List

Name | Description
Recurrence.ToString () | Creates a string from this recurrence using the date and time formatting information defined int the current culture.
Recurrence.ToString (DateTimeFormatInfo) | Creates a string from this recurrence using the specified date and time formatting.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ToString Method ()

Recurrence.ToString Method ()
See Also

Creates a string from this recurrence using the date and time formatting information defined int the current culture.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override string ToString ()
Visual Basic

Public Overrides Function ToString () As String

Return Value

A string representation of the recurrence object.

See Also

ToString Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.ToString Method (DateTimeFormatInfo)

Recurrence.ToString Method (DateTimeFormatInfo)
See Also

Creates a string from this recurrence using the specified date and time formatting.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string ToString (
DateTimeFormatInfo info
)
Visual Basic

Public Function ToString ( _
info As DateTimeFormatInfo _
) As String

Parameters

info
Defines how date and time values are formatted and displayed.

Return Value

A string representation of the recurrence object.

See Also

ToString Method Overload List
Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence Properties

Recurrence Properties

Public Properties

Name | Description
DailyRecurrence | Gets or sets the type of daily recurrence.
Day | Gets or sets a value indicating on which day of a week the event occurs.
DayOfMonth | Gets or sets on which day of a month the event occurs.
Days | Gets or sets how many days should pass before the event occurs again.
DaysOfWeek | Gets or sets on which days of a week the event occurs.
EndDate | Gets or sets the end date of the recurrence.
Exceptions | Gets the list of all recurrence exceptions.
Interval | Gets or sets the recurrence interval.
Master | Gets the master item of this recurrence. The property returns null if the recurrence is not associated with an item.
MonthlyRecurrence | Gets or sets the type of monthly recurrence.
MonthOfYear | Gets or sets in which month of the year the event occurs.
Months | Gets or sets how many months should pass before the event occurs again.
NumOccurrences | Gets or sets how many times the recurring event should occur.
Occurrence | Gets or sets on which occurrence of the day type specified in Day the event occurs.
Pattern | Gets or sets the recurrence pattern.
RecurrenceEnd | Gets or sets when the event should stop recurring.
StartDate | Gets or sets when the recurring event should occur for the first time.
Weeks | Gets or sets how many weeks should pass before the event occurs again.
YearlyRecurrence | Gets or sets the type of yearly recurrence.

See Also

Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DailyRecurrence Property

Recurrence.DailyRecurrence Property

Gets or sets the type of daily recurrence.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DailyRecurrence DailyRecurrence { get; set; }
Visual Basic

Public Property DailyRecurrence As DailyRecurrence

Property Value

A member of the DailyRecurrence enumeration.

Remarks

This value is used when the recurrence Pattern is set to Daily.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Day Property

Recurrence.Day Property

Gets or sets a value indicating on which day of a week the event occurs.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DayOfWeekType Day { get; set; }
Visual Basic

Public Property Day As DayOfWeekType

Property Value

A member of the DayOfWeekType enumeration.

Remarks

This value is used when the recurrence Pattern is set to Monthly or Yearly and MonthlyRecurrence or YearlyRecurrence are set to ByDayType.

Example

Check the Recurrence constructor for an example on how to use this property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DayOfMonth Property

Recurrence.DayOfMonth Property

Gets or sets on which day of a month the event occurs.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int DayOfMonth { get; set; }
Visual Basic

Public Property DayOfMonth As Integer

Property Value

An integer vale specifying at which month the recurring event occurs. The allowed values range from 1 to 31.

Remarks

This value is used when the recurrence Pattern is set to Monthly or Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Days Property

Recurrence.Days Property

Gets or sets how many days should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int Days { get; set; }
Visual Basic

Public Property Days As Integer

Property Value

An integer value specifying the number of days between event occurrences. The minimal allowed value is 1.

Remarks

This value is used when the recurrence Pattern is set to Daily.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.DaysOfWeek Property

Recurrence.DaysOfWeek Property

Gets or sets on which days of a week the event occurs.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DaysOfWeek DaysOfWeek { get; set; }
Visual Basic

Public Property DaysOfWeek As DaysOfWeek

Property Value

A member of the DaysOfWeek enumeration.

Remarks

This value is used when the recurrence Pattern is set to Weekly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.EndDate Property

Recurrence.EndDate Property

Gets or sets the end date of the recurrence.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime EndDate { get; set; }
Visual Basic

Public Property EndDate As DateTime

Property Value

A DateTime object specifying the end date of the recurring event.

Remarks

This property is considered by the recurrence only if the RecurrenceEnd is set to EndDate.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Exceptions Property

Recurrence.Exceptions Property

Gets the list of all recurrence exceptions.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ICollection Exceptions { get; }
Visual Basic

Public ReadOnly Property Exceptions As ICollection

Property Value

A collection containing all exceptions defined for this recurrence.

Example

The following example traverses all deleted occurrences of a recurrence. The example assumes that recurrence references an existing Recurrence object.

C#

foreach (RecurrenceException exception in recurrence.Exceptions)
{
if (exception.IsDeleted)
{
// Do something here
}
}
Visual Basic

For Each exception As RecurrenceException in recurrence.Exceptions

If exception.IsDeleted Then

' Do something here

End If

Next

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Interval Property

Recurrence.Interval Property

Gets or sets the recurrence interval.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TimeSpan Interval { get; set; }
Visual Basic

Public Property Interval As TimeSpan

Property Value

A TimeSpan value indicating the time interval between recurring items.

Remarks

This value is used when the recurrence Pattern is set to ByTimeInterval.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Master Property

Recurrence.Master Property

Gets the master item of this recurrence. The property returns null if the recurrence is not associated with an item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Item Master { get; }
Visual Basic

Public ReadOnly Property Master As Item

Property Value

A reference to the schedule item whose recurrence is defined by this object.

Remarks

To associate a recurrence with an item, set a reference to a Recurrence object to the item's Recurrence property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.MonthlyRecurrence Property

Recurrence.MonthlyRecurrence Property

Gets or sets the type of monthly recurrence.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public MonthlyRecurrence MonthlyRecurrence { get; set; }
Visual Basic

Public Property MonthlyRecurrence As MonthlyRecurrence

Property Value

A member of the MonthlyRecurrence enumeration.

Remarks

This value is used when the recurrence Pattern is set to Monthly.

Example

Check the Recurrence constructor for an example on how to use this property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.MonthOfYear Property

Recurrence.MonthOfYear Property

Gets or sets in which month of the year the event occurs.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int MonthOfYear { get; set; }
Visual Basic

Public Property MonthOfYear As Integer

Property Value

An integer value specifying at which month the event occurs. The allowed values range from 1 to 12.

Remarks

The value of this property is used when the recurrence Pattern is set to Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Months Property

Recurrence.Months Property

Gets or sets how many months should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int Months { get; set; }
Visual Basic

Public Property Months As Integer

Property Value

An integer value specifying the number of days between event occurrences. The minimal allowed value is 1.

Remarks

The value of this property is used when the recurrence Pattern is set to Monthly.

Example

Check the Recurrence constructor for an example on how to use this property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.NumOccurrences Property

Recurrence.NumOccurrences Property

Gets or sets how many times the recurring event should occur.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int NumOccurrences { get; set; }
Visual Basic

Public Property NumOccurrences As Integer

Property Value

An integer value specifying the number of occurrences. The allowed values range from 1 to 999.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Occurrence Property

Recurrence.Occurrence Property

Gets or sets on which occurrence of the day type specified in Day the event occurs.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Occurrence Occurrence { get; set; }
Visual Basic

Public Property Occurrence As Occurrence

Property Value

A member of the Occurrence enumeration.

Remarks

The value of this property is used when the recurrence Pattern is set to Monthly or Yearly and MonthlyRecurrence or YearlyRecurrence are set to ByDayType.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.Pattern Property

Recurrence.Pattern Property

Gets or sets the recurrence pattern.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public RecurrencePattern Pattern { get; set; }
Visual Basic

Public Property Pattern As RecurrencePattern

Property Value

A member of the RecurrencePattern enumeration.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.RecurrenceEnd Property

Recurrence.RecurrenceEnd Property

Gets or sets when the event should stop recurring.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public RecurrenceEnd RecurrenceEnd { get; set; }
Visual Basic

Public Property RecurrenceEnd As RecurrenceEnd

Property Value

A member of the RecurrenceEnd enumeration.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
NumOccurrences
EndDate


MindFusion.Scheduling.Recurrence.StartDate Property

Recurrence.StartDate Property

Gets or sets when the recurring event should occur for the first time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime StartDate { get; set; }
Visual Basic

Public Property StartDate As DateTime

Property Value

A DateTime object specifying the recurrence start date.

Remarks

The time properties set in a recurrence object override the time properties of a schedule item to which the recurrence is assigned. The Calendar control displays "occurrence" items corresponding to the recurring master item. The first occurrence is displayed in the date cell specified in this property.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace
EndDate


MindFusion.Scheduling.Recurrence.Weeks Property

Recurrence.Weeks Property

Gets or sets how many weeks should pass before the event occurs again.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int Weeks { get; set; }
Visual Basic

Public Property Weeks As Integer

Property Value

An integer value specifying the number of weeks between event occurrences. The minimal allowed value is 1.

Remarks

This value is used when the recurrence Pattern is set to Weekly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Recurrence.YearlyRecurrence Property

Recurrence.YearlyRecurrence Property

Gets or sets the type of yearly recurrence.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public YearlyRecurrence YearlyRecurrence { get; set; }
Visual Basic

Public Property YearlyRecurrence As YearlyRecurrence

Property Value

A member of the YearlyRecurrence enumeration.

Remarks

The value of this property is used when the recurrence Pattern is set to Yearly.

See Also

Recurrence Members
Recurrence Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceEnd Enumeration

RecurrenceEnd Enumeration

Specifies when to stop repeating recurring events.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum RecurrenceEnd
Visual Basic

Public Enumeration RecurrenceEnd

Members

Member name | Description
EndDate | The recurrence ends at a specified date.
Never | Never stop repeating events.
NumOccurrences | Stop repeating events after a specified number of occurrences.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Class

RecurrenceException Class

This class represents exceptions of a recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class RecurrenceException
Visual Basic

Public Class RecurrenceException

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.RecurrenceException

See Also

RecurrenceException Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Members

RecurrenceException Members
Properties

This class represents exceptions of a recurrence patterns.

The following tables list the members exposed by the RecurrenceException type.

Public Properties

Name | Description
IsDeleted | Gets or sets a value indicating whether this particular occurrence has been deleted.
Item | Gets the item representing the recurrence exception.

See Also

RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException Properties

RecurrenceException Properties

Public Properties

Name | Description
IsDeleted | Gets or sets a value indicating whether this particular occurrence has been deleted.
Item | Gets the item representing the recurrence exception.

See Also

RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException.IsDeleted Property

RecurrenceException.IsDeleted Property

Gets or sets a value indicating whether this particular occurrence has been deleted.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool IsDeleted { get; set; }
Visual Basic

Public Property IsDeleted As Boolean

Property Value

true if this exception identifies a deleted occurrence; otherwise, false.

See Also

RecurrenceException Members
RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceException.Item Property

RecurrenceException.Item Property

Gets the item representing the recurrence exception.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Item Item { get; set; }
Visual Basic

Public Property Item As Item

Property Value

An instance of the item class representing the schedule item for which this exception is defined.

See Also

RecurrenceException Members
RecurrenceException Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrencePattern Enumeration

RecurrencePattern Enumeration

Specifies the interval at which recurring items occur.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum RecurrencePattern
Visual Basic

Public Enumeration RecurrencePattern

Members

Member name | Description
ByTimeInterval | Repeats an item over a specified time interval.
Daily | Repeats an item every day.
Monthly | Repeats an item every month.
Weekly | Repeats an item every week.
Yearly | Repeats an item every year.

Remarks

These values can be assigned to the Pattern property of the Recurrence class.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.RecurrenceState Enumeration

RecurrenceState Enumeration

Specifies the recurrence state of items.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum RecurrenceState
Visual Basic

Public Enumeration RecurrenceState

Members

Member name | Description
Exception | Specifies an exception of a recurring event.
Master | Specifies a recurring event.
None | Specifies an one-time non-recurring event.
Occurrence | Specifies a single occurrence of a recurring event.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Class

Reminder Class

Represents reminders associated with schedule items.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public sealed class Reminder : ICloneable
Visual Basic

Public NotInheritable Class Reminder
Implements ICloneable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Reminder

See Also

Reminder Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Members

Reminder Members
Constructors Fields Properties Methods

Represents reminders associated with schedule items.

The following tables list the members exposed by the Reminder type.

Public Constructors

Name | Description
Reminder | Initializes a new instance of the Reminder class.

Public Fields

Name | Description
MaxInterval | The maximum time interval that can be set as value of TimeInterval for a Reminder object.

Public Properties

Name | Description
Message | Gets or sets the message to display as a reminder.
PlaySound | Gets or sets a value indicating whether to play a sound when the reminder is triggered.
SoundFileName | Gets or sets the name of a sound file to play with this reminder.
Time | Gets or sets the exact time when to trigger the reminder.
TimeInterval | Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.
Type | Gets or sets the type of this reminder.

Public Methods

Name | Description
Clone | Clones this Reminder object.
LoadFrom | Overloaded. Loads reminder data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the reminder data to a binary stream or an XML document.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Fields

Reminder Fields

Public Fields

Name | Description
MaxInterval | The maximum time interval that can be set as value of TimeInterval for a Reminder object.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.MaxInterval Field

Reminder.MaxInterval Field

The maximum time interval that can be set as value of TimeInterval for a Reminder object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public static readonly TimeSpan MaxInterval
Visual Basic

Public Shared ReadOnly MaxInterval As TimeSpan

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Constructor

Reminder Constructor

Initializes a new instance of the Reminder class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Reminder ()
Visual Basic

Public Sub New ()

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder Methods

Reminder Methods

Public Methods

Name | Description
Clone | Clones this Reminder object.
LoadFrom | Overloaded. Loads reminder data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the reminder data to a binary stream or an XML document.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Clone Method

Reminder.Clone Method

Clones this Reminder object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

An exact copy of this reminder.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.LoadFrom Method

Reminder.LoadFrom Method

Loads reminder data from a binary stream or an XML document.

Overload List

Name | Description
Reminder.LoadFrom (XmlElement, XmlSerializationContext) | Loads reminder data from an XML document.
Reminder.LoadFrom (XmlReader, SerializationContext) | Loads reminder data from an XML document. Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.LoadFrom Method (XmlElement, XmlSerializationContext)

Reminder.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads reminder data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads the reminder fields from an XML document, where they were previously saved via SaveTo.

See Also

LoadFrom Method Overload List
Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Reminder.LoadFrom Method (XmlReader, SerializationContext)

Reminder.LoadFrom Method (XmlReader, SerializationContext)
See Also

Loads reminder data from an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void LoadFrom (
XmlReader reader,
SerializationContext context
)
Visual Basic

Public Sub LoadFrom ( _
reader As XmlReader, _
context As SerializationContext _
)

Parameters

reader
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also allows getting locations, contacts and tasks by their string identifiers.

Remarks

This method loads the reminder fields from an XML document, where they were previously saved via SaveTo.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Reminder.SaveTo Method

Reminder.SaveTo Method

Saves the reminder data to a binary stream or an XML document.

Overload List

Name | Description
Reminder.SaveTo (XmlElement, XmlSerializationContext) | Saves the reminder data to an XML document.
Reminder.SaveTo (XmlWriter, SerializationContext) | Saves the reminder data to an XML document. Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.SaveTo Method (XmlElement, XmlSerializationContext)

Reminder.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the reminder data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saved the reminder object fields as elements in a XML document. They can be restored later using the LoadFrom method.

See Also

SaveTo Method Overload List
Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Reminder.SaveTo Method (XmlWriter, SerializationContext)

Reminder.SaveTo Method (XmlWriter, SerializationContext)
See Also

Saves the reminder data to an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void SaveTo (
XmlWriter writer,
SerializationContext context
)
Visual Basic

Public Sub SaveTo ( _
writer As XmlWriter, _
context As SerializationContext _
)

Parameters

writer
Allows adding data to the XML document.
context
The context object contains the current revision number of the schedule file format.

Remarks

This method saved the reminder object fields as elements in a XML document. They can be restored later using the LoadFrom method.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Reminder Properties

Reminder Properties

Public Properties

Name | Description
Message | Gets or sets the message to display as a reminder.
PlaySound | Gets or sets a value indicating whether to play a sound when the reminder is triggered.
SoundFileName | Gets or sets the name of a sound file to play with this reminder.
Time | Gets or sets the exact time when to trigger the reminder.
TimeInterval | Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.
Type | Gets or sets the type of this reminder.

See Also

Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Message Property

Reminder.Message Property

Gets or sets the message to display as a reminder.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Message { get; set; }
Visual Basic

Public Property Message As String

Property Value

A string containing the message text.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.PlaySound Property

Reminder.PlaySound Property

Gets or sets a value indicating whether to play a sound when the reminder is triggered.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool PlaySound { get; set; }
Visual Basic

Public Property PlaySound As Boolean

Property Value

true to play the sound file; otherwise, false.

Remarks

The path to the sound file can be set in the SoundFileName property.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.SoundFileName Property

Reminder.SoundFileName Property

Gets or sets the name of a sound file to play with this reminder.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string SoundFileName { get; set; }
Visual Basic

Public Property SoundFileName As String

Property Value

A string specifying which file to play.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Time Property

Reminder.Time Property

Gets or sets the exact time when to trigger the reminder.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime Time { get; set; }
Visual Basic

Public Property Time As DateTime

Property Value

A .NET DateTime object specifying when the reminder should be triggered.

Remarks

The value of this property is considered only if the Type of the reminder is set to Exact.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.TimeInterval Property

Reminder.TimeInterval Property

Gets or sets how much time before the item's scheduled start time to raise the event that triggers the reminder.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TimeSpan TimeInterval { get; set; }
Visual Basic

Public Property TimeInterval As TimeSpan

Property Value

A .NET TimeSpan instance specifying how much time before event's scheduled time to trigger the reminder.

Remarks

The value of this property is considered only if the Type of the reminder is set to Leading.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Reminder.Type Property

Reminder.Type Property

Gets or sets the type of this reminder.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ReminderType Type { get; set; }
Visual Basic

Public Property Type As ReminderType

Property Value

A member of the ReminderType enumeration specifying the reminder type.

See Also

Reminder Members
Reminder Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ReminderType Enumeration

ReminderType Enumeration

Specifies the type of a reminder.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum ReminderType
Visual Basic

Public Enumeration ReminderType

Members

Member name | Description
Exact | Trigger the reminder at the exact time specified in its Time property. Note: Recurring items cannot have exact reminders.
Leading | Trigger the reminder at the specified TimeInterval before the item's scheduled start time. Note: Tasks cannot have leading reminders.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Class

Resource Class

Instances of the Resource class contain information about arbitrary resources.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class Resource
Visual Basic

Public Class Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Contact
MindFusion.Scheduling.Location
MindFusion.Scheduling.Task

See Also

Resource Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Members

Resource Members
Constructors Properties Methods

Instances of the Resource class contain information about arbitrary resources.

The following tables list the members exposed by the Resource type.

Public Constructors

Name | Description
Resource | Initializes a new instance of the Resource class.

Public Properties

Name | Description
CustomBrushes | Gets a CustomBrushes object associated with the resource.
Id | Gets or sets the string identifier of this resource.
Name | Gets or sets the name of the resource.
Tag | Gets or sets custom data associated with the resource.

Public Methods

Name | Description
LoadFrom | Loads resource data from a binary stream or an XML document.
SaveTo | Saves the resource data to a binary stream or an XML document.

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Constructor

Resource Constructor

Initializes a new instance of the Resource class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Resource ()
Visual Basic

Public Sub New ()

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource Methods

Resource Methods

Public Methods

Name | Description
LoadFrom | Loads resource data from a binary stream or an XML document.
SaveTo | Saves the resource data to a binary stream or an XML document.

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.LoadFrom Method (XmlReader, SerializationContext)

Resource.LoadFrom Method (XmlReader, SerializationContext)
See Also

Loads resource data from an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public virtual void LoadFrom (
XmlReader reader,
SerializationContext context
)
Visual Basic

Public Overridable Sub LoadFrom ( _
reader As XmlReader, _
context As SerializationContext _
)

Parameters

reader
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also allows getting locations, contacts and tasks by their string identifiers.

Remarks

The reader parameter wraps an XML document that contains data stored by a previous call to the SaveTo method.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Resource.SaveTo Method (XmlWriter, SerializationContext)

Resource.SaveTo Method (XmlWriter, SerializationContext)
See Also

Saves the resource data to an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public virtual void SaveTo (
XmlWriter writer,
SerializationContext context
)
Visual Basic

Public Overridable Sub SaveTo ( _
writer As XmlWriter, _
context As SerializationContext _
)

Parameters

writer
Allows adding data to the XML document.
context
The context object contains the current revision number of the schedule file format.

Remarks

This method saves the resource properties as elements of an XML document.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Resource Properties

Resource Properties

Public Properties

Name | Description
CustomBrushes | Gets a CustomBrushes object associated with the resource.
Id | Gets or sets the string identifier of this resource.
Name | Gets or sets the name of the resource.
Tag | Gets or sets custom data associated with the resource.

See Also

Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.CustomBrushes Property

Resource.CustomBrushes Property

Gets a CustomBrushes object associated with the resource.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public CustomBrushes CustomBrushes { get; set; }
Visual Basic

Public Property CustomBrushes As CustomBrushes

Property Value

An instance of the CustomBrushes class that defines brushes used to paint the background of calendar elements associated with this resource.

Remarks

This property defines a primary and a secondary brush used to paint the background of resource-related UI elements. The scheduled events for a resource can be displayed in their own columns in timetable, week range and resource views. In timetable view the primary brush is used to paint the non-work time cells, and the secondary brush is used to paint the work time cells. In week range view the two brushes are used to alternately paint odd and even weeks.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Id Property

Resource.Id Property

Gets or sets the string identifier of this resource.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Id { get; set; }
Visual Basic

Public Property Id As String

Property Value

A string value identifying uniquely this resource instance.

Remarks

If you need to change its value, make sure the identifier is always unique.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Name Property

Resource.Name Property

Gets or sets the name of the resource.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Name { get; set; }
Visual Basic

Public Property Name As String

Property Value

A string containing the name of the resource. The default is an empty string.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Resource.Tag Property

Resource.Tag Property

Gets or sets custom data associated with the resource.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Object Tag { get; set; }
Visual Basic

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object.

Remarks

Use this property to store your custom data. The tag can be a value from a primitive data type or a complex object from the .NET class library or a class defined by you. If the tag is an instance of a value type, it will be serialized together with the object containing it when saving / loading the schedule. Reference types are serialized if marked with the [Serializable] attribute or if they implement the ISerializable interface.

See Also

Resource Members
Resource Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Class

ResourceCollection Class

Represents a strongly-typed collection of Resource objects.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public sealed class ResourceCollection : CollectionBase
Visual Basic

Public NotInheritable Class ResourceCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.ResourceCollection

See Also

ResourceCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Members

ResourceCollection Members
Constructors Properties Methods Events

Represents a strongly-typed collection of Resource objects.

The following tables list the members exposed by the ResourceCollection type.

Public Constructors

Name | Description
ResourceCollection | Initializes a new instance of the ResourceCollection class.

Public Properties

Name | Description
Item | Gets a Resource object from the collection given its zero-based index or identifier.

Public Methods

Name | Description
Add | Adds the specified resource to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains particular resource.
Insert | Inserts the specified Resource object at the specified position within the collection.
Remove | Removes the first occurrence of the specified Resource object from this collection.

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Constructor

ResourceCollection Constructor

Initializes a new instance of the ResourceCollection class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ResourceCollection ()
Visual Basic

Public Sub New ()

See Also

ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Methods

ResourceCollection Methods

Public Methods

Name | Description
Add | Adds the specified resource to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains particular resource.
Insert | Inserts the specified Resource object at the specified position within the collection.
Remove | Removes the first occurrence of the specified Resource object from this collection.

See Also

ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Add Method

ResourceCollection.Add Method

Adds the specified resource to this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Add (
Resource resource
)
Visual Basic

Public Sub Add ( _
resource As Resource _
)

Parameters

resource
An instance of the Resource class to be added to the collection.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace
Insert Method


MindFusion.Scheduling.ResourceCollection.Clear Method

ResourceCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Contains Method

ResourceCollection.Contains Method

Determines whether this collection contains particular resource.

Overload List

Name | Description
ResourceCollection.Contains (Resource) | Determines whether this collection contains the specified resource.
ResourceCollection.Contains (String) | Determines whether this collection contains a resource identified by the specified string.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Contains Method (Resource)

ResourceCollection.Contains Method (Resource)
See Also

Determines whether this collection contains the specified resource.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
Resource resource
)
Visual Basic

Public Function Contains ( _
resource As Resource _
) As Boolean

Parameters

resource
The Resource object to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Contains Method (String)

ResourceCollection.Contains Method (String)
See Also

Determines whether this collection contains a resource identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
string resourceId
)
Visual Basic

Public Function Contains ( _
resourceId As String _
) As Boolean

Parameters

resourceId
The identifier of a resource to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Insert Method

ResourceCollection.Insert Method

Inserts the specified Resource object at the specified position within the collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Insert (
int index,
Resource resource
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
resource As Resource _
)

Parameters

index
The zero-based index at which the contact must be inserted.
resource
An instance of the Resource class to be added to the collection.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace
Add Method


MindFusion.Scheduling.ResourceCollection.Remove Method

ResourceCollection.Remove Method

Removes the first occurrence of the specified Resource object from this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Remove (
Resource resource
)
Visual Basic

Public Sub Remove ( _
resource As Resource _
)

Parameters

resource
A Resource instance which must be removed from the collection.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Properties

ResourceCollection Properties

Public Properties

Name | Description
Item | Gets a Resource object from the collection given its zero-based index or identifier.

See Also

ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Item Property

ResourceCollection.Item Property

Gets a Resource object from the collection given its zero-based index or identifier.

Overload List

Name | Description
ResourceCollection.Item (Int32) | Gets or sets the Resource object located at the specified position within this collection.
ResourceCollection.Item (String) | Gets the Resource object identified by the specified string.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Item Property (Int32)

ResourceCollection.Item Property (Int32)
See Also

Gets or sets the Resource object located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Resource Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Resource

Parameters

index
The zero-based index of the Resource to set or retrieve.

Property Value

The Resource instance at the specified index.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their integer indices.

See Also

Item Property Overload List
ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Item Property (String)

ResourceCollection.Item Property (String)
See Also

Gets the Resource object identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Resource Item [
string id
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
id As String _
) As Resource

Parameters

id

The Id of the Resource to get.

Property Value

The Resource instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection Events

ResourceCollection Events

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.ResourceCollection.Changed Event

ResourceCollection.Changed Event

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public EventHandler Changed
Visual Basic

Public Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

ResourceCollection Members
ResourceCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Class

Schedule Class

Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class Schedule : IDisposable
Visual Basic

Public Class Schedule
Implements IDisposable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Schedule

See Also

Schedule Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Members

Schedule Members
Constructors Fields Properties Methods Events

Represents a timetable of scheduled events. In the model-view architecture, Schedule instances are the documents whose data is displayed by Calendar instances - the views.

The following tables list the members exposed by the Schedule type.

Public Constructors

Name | Description
Schedule | Initializes a new instance of the Schedule class.

Public Fields

Name | Description
CurrentVersion | The current version of the schedule file format.

Public Properties

Name | Description
Contacts | Gets all contacts defined in the Schedule.
DisableReminders | Gets or sets a value indicating whether to completely disable reminders in the whole schedule.
Items | Gets all scheduled items.
Locations | Gets all locations defined in the Schedule.
RemindersCheckInterval | Gets or sets the interval between reminder checks, expressed in seconds.
Resources | Gets all resources defined in the Schedule.
Tasks | Gets all tasks defined in this Schedule.

Public Methods

Name | Description
Clear | Clears all items, tasks, locations, contacts and resources contained in this schedule.
Dispose | Disposes any resources used by this Schedule object.
GetAllItems | Overloaded. Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
GetFreePeriod | Overloaded. Returns the next period with the specified duration after the specified date, which is not occupied by items.
GetItemsToRemindOf | Overloaded. Retrieves a collection of all items that must be reminded of.
GetTasksToRemindOf | Overloaded. Retrieves a collection of all tasks that must be reminded of.
IsClassRegistered | Overloaded. Checks whether a specified class identifier or type is registered for serialization.
LoadFrom | Overloaded. Loads schedule data from a file, a binary stream or an XML document.
LoadFromString |
LoadFromXml | Loads schedule data from an XML document.
RegisterItemClass | Registers a schedule item class for serialization support.
RegisterResourceClass | Registers a resource class for serialization support.
SaveTo | Overloaded. Saves the schedule to a file, a binary stream or an XML document.
SaveToString |
SaveToXml | Saves the schedule to an XML document.
UnregisterClass | Overloaded. Unregisters the item or resource with the specified class identifier or type from the system.

Protected Methods

Name | Description
OnDeserializeTag | Raises the DeserializeTag event.
OnExceptionCreated | Raises the ExceptionCreated event.
OnInstantiateItem | Raises the InstantiateItem event.
OnInstantiateResource | Raises the InstantiateResource event.
OnItemEndTimeChanged | Raises the ItemEndTimeChanged event.
OnItemEndTimeTriggered | Raises the ItemEndTimeTriggered event.
OnItemReminderTriggered | Raises the ItemReminderTriggered event.
OnItemStartTimeChanged | Raises the ItemStartTimeChanged event.
OnItemVisualsChanged | Raises the ItemVisualsChanged event.
OnRecurrenceReset | Raises the RecurrenceReset event.
OnSerializeTag | Raises the SerializeTag event.
OnTaskReminderTriggered | Raises the TaskReminderTriggered event.

Public Events

Name | Description
Changed | Raised when items are added or removed from the schedule or when the schedule is loaded.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.
ExceptionCreated | Raised when a recurrence exception item is created.
InstantiateItem | Raised when deserializing a custom item whose type has not been registered.
InstantiateResource | Raised when deserializing a custom resource whose type has not been registered.
ItemEndTimeChanged | Raised when the EndTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous EndTime value of the item.
ItemEndTimeTriggered | Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.
ItemReminderTriggered | Raised when the reminder for an item is triggered.
ItemStartTimeChanged | Raised when the StartTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous StartTime value of the item.
ItemVisualsChanged | Raised when the appearance of an item in the schedule has changed.
RecurrenceReset | Raised when the recurrence pattern associated with an item has been reset, causing all associated exception items to be lost.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.
TaskReminderTriggered | Raised when the reminder for a task is triggered.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Fields

Schedule Fields

Public Fields

Name | Description
CurrentVersion | The current version of the schedule file format.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.CurrentVersion Field

Schedule.CurrentVersion Field

The current version of the schedule file format.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public static int CurrentVersion
Visual Basic

Public Shared CurrentVersion As Integer

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Constructor

Schedule Constructor

Initializes a new instance of the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Schedule ()
Visual Basic

Public Sub New ()

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule Methods

Schedule Methods

Public Methods

Name | Description
Clear | Clears all items, tasks, locations, contacts and resources contained in this schedule.
Dispose | Disposes any resources used by this Schedule object.
GetAllItems | Overloaded. Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
GetFreePeriod | Overloaded. Returns the next period with the specified duration after the specified date, which is not occupied by items.
GetItemsToRemindOf | Overloaded. Retrieves a collection of all items that must be reminded of.
GetTasksToRemindOf | Overloaded. Retrieves a collection of all tasks that must be reminded of.
IsClassRegistered | Overloaded. Checks whether a specified class identifier or type is registered for serialization.
LoadFrom | Overloaded. Loads schedule data from a file, a binary stream or an XML document.
LoadFromString |
LoadFromXml | Loads schedule data from an XML document.
RegisterItemClass | Registers a schedule item class for serialization support.
RegisterResourceClass | Registers a resource class for serialization support.
SaveTo | Overloaded. Saves the schedule to a file, a binary stream or an XML document.
SaveToString |
SaveToXml | Saves the schedule to an XML document.
UnregisterClass | Overloaded. Unregisters the item or resource with the specified class identifier or type from the system.

Protected Methods

Name | Description
OnDeserializeTag | Raises the DeserializeTag event.
OnExceptionCreated | Raises the ExceptionCreated event.
OnInstantiateItem | Raises the InstantiateItem event.
OnInstantiateResource | Raises the InstantiateResource event.
OnItemEndTimeChanged | Raises the ItemEndTimeChanged event.
OnItemEndTimeTriggered | Raises the ItemEndTimeTriggered event.
OnItemReminderTriggered | Raises the ItemReminderTriggered event.
OnItemStartTimeChanged | Raises the ItemStartTimeChanged event.
OnItemVisualsChanged | Raises the ItemVisualsChanged event.
OnRecurrenceReset | Raises the RecurrenceReset event.
OnSerializeTag | Raises the SerializeTag event.
OnTaskReminderTriggered | Raises the TaskReminderTriggered event.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Clear Method

Schedule.Clear Method

Clears all items, tasks, locations, contacts and resources contained in this schedule.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Clear ()
Visual Basic

Public Sub Clear ()

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Contacts Property
Items Property
Locations Property
Resources Property
Tasks Property


MindFusion.Scheduling.Schedule.Dispose Method

Schedule.Dispose Method

Disposes any resources used by this Schedule object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public virtual void Dispose ()
Visual Basic

Public Overridable Sub Dispose ()

Remarks

It is important to call Dispose on the object when you are done using it, in order to stop the schedule's timer used to trigger reminder events.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method

Schedule.GetAllItems Method

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.

Overload List

Name | Description
Schedule.GetAllItems (DateTime, DateTime) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.
Schedule.GetAllItems (DateTime, DateTime, Contact) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Contact object.
Schedule.GetAllItems (DateTime, DateTime, Location) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Location object.
Schedule.GetAllItems (DateTime, DateTime, Resource) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Resource object.
Schedule.GetAllItems (DateTime, DateTime, Task) | Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Task object.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime)

Schedule.GetAllItems Method (DateTime, DateTime)
See Also

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection GetAllItems (
DateTime startTime,
DateTime endTime
)
Visual Basic

Public Function GetAllItems ( _
startTime As DateTime, _
endTime As DateTime _
) As ItemCollection

Parameters

startTime
Time interval start.
endTime
Time interval end.

Return Value

A collection that contains the events scheduled to occur in the specified period.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Contact)

Schedule.GetAllItems Method (DateTime, DateTime, Contact)
See Also

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Contact object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Contact contact
)
Visual Basic

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
contact As Contact _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
contact
A Contact instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified contact.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Location)

Schedule.GetAllItems Method (DateTime, DateTime, Location)
See Also

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Location object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Location location
)
Visual Basic

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
location As Location _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
location
A Location instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified location.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Resource)

Schedule.GetAllItems Method (DateTime, DateTime, Resource)
See Also

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Resource object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Resource resource
)
Visual Basic

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
resource As Resource _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
resource
A Resource instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified resource.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetAllItems Method (DateTime, DateTime, Task)

Schedule.GetAllItems Method (DateTime, DateTime, Task)
See Also

Retrieves a collection of all events, including recurrent item instances, scheduled to occur in the specified time interval for a specific Task object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection GetAllItems (
DateTime startDate,
DateTime endDate,
Task task
)
Visual Basic

Public Function GetAllItems ( _
startDate As DateTime, _
endDate As DateTime, _
task As Task _
) As ItemCollection

Parameters

startDate
Specifies the start of the time period.
endDate
Specifies the end of the time period.
task
A Task instance that must be related to the items.

Return Value

A collection that contains the events scheduled to occur in the specified period for the specified task.

Remarks

If a recurring event occurs in the specified interval, each occurrence is represented by an Item instance whose RecurrenceState is set to Occurrence.

See Also

GetAllItems Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method

Schedule.GetFreePeriod Method

Returns the next period with the specified duration after the specified date, which is not occupied by items.

Overload List

Name | Description
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan) | Returns the next period with the specified duration after the specified date, which is not occupied by items.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ContactCollection) | Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified contacts.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, LocationCollection) | Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified locations.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, ResourceCollection) | Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified resources.
Schedule.GetFreePeriod (DateTime, DateTime, TimeSpan, TaskCollection) | Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified tasks.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan)
See Also

Returns the next period with the specified duration after the specified date, which is not occupied by items.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration
)
Visual Basic

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ContactCollection)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ContactCollection)
See Also

Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified contacts.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ContactCollection contacts
)
Visual Basic

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
contacts As ContactCollection _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
contacts
The contacts whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, LocationCollection)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, LocationCollection)
See Also

Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified locations.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
LocationCollection locations
)
Visual Basic

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
locations As LocationCollection _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
locations
The locations whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, ResourceCollection)
See Also

Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified resources.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
ResourceCollection resources
)
Visual Basic

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
resources As ResourceCollection _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
resources
The resources whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, TaskCollection)

Schedule.GetFreePeriod Method (DateTime, DateTime, TimeSpan, TaskCollection)
See Also

Returns the next period with the specified duration after the specified date, which is not occupied by items associated with the specified tasks.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime GetFreePeriod (
DateTime from,
DateTime to,
TimeSpan duration,
TaskCollection tasks
)
Visual Basic

Public Function GetFreePeriod ( _
from As DateTime, _
to As DateTime, _
duration As TimeSpan, _
tasks As TaskCollection _
) As DateTime

Parameters

from
The start date of the interval in which to search for a free period.
to
The end date of the interval in which to search for a free period.
duration
The required minimum duration of the period.
tasks
The tasks whose items should be considered when looking for the free period.

Return Value

A .NET DateTime object representing the start time of the period found or DateTime.MinValue if none.

Remarks

If there are recurring items associated with a resource in the specified collection, the function execution might take very long if a period with the specified duration doesn't exist.

See Also

GetFreePeriod Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method

Schedule.GetItemsToRemindOf Method

Retrieves a collection of all items that must be reminded of.

Overload List

Name | Description
Schedule.GetItemsToRemindOf () | Retrieves a collection with all items that must be reminded of at the current time.
Schedule.GetItemsToRemindOf (DateTime) | Retrieves a collection with all items that must be reminded of at the specified time.
Schedule.GetItemsToRemindOf (DateTime, DateTime) | Retrieves a collection with all items that must be reminded of in the specified interval.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method ()

Schedule.GetItemsToRemindOf Method ()
See Also

Retrieves a collection with all items that must be reminded of at the current time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection GetItemsToRemindOf ()
Visual Basic

Public Function GetItemsToRemindOf () As ItemCollection

Return Value

The collection of all items whose reminders must be displayed at the current time.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method (DateTime)

Schedule.GetItemsToRemindOf Method (DateTime)
See Also

Retrieves a collection with all items that must be reminded of at the specified time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection GetItemsToRemindOf (
DateTime time
)
Visual Basic

Public Function GetItemsToRemindOf ( _
time As DateTime _
) As ItemCollection

Parameters

time
Determine whether any reminders should be displayed at this time.

Return Value

The collection of all items whose reminders must be displayed at the specified time.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetItemsToRemindOf Method (DateTime, DateTime)

Schedule.GetItemsToRemindOf Method (DateTime, DateTime)
See Also

Retrieves a collection with all items that must be reminded of in the specified interval.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection GetItemsToRemindOf (
DateTime start,
DateTime end
)
Visual Basic

Public Function GetItemsToRemindOf ( _
start As DateTime, _
end As DateTime _
) As ItemCollection

Parameters

start
The start of the time interval containing the items of interest.
end
The end of the time interval containing the items of interest.

Return Value

The collection of all items whose reminders must be displayed in the specified time interval.

See Also

GetItemsToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetTasksToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method

Schedule.GetTasksToRemindOf Method

Retrieves a collection of all tasks that must be reminded of.

Overload List

Name | Description
Schedule.GetTasksToRemindOf () | Retrieves a collection of all tasks that must be reminded of at the current time.
Schedule.GetTasksToRemindOf (DateTime) | Retrieves a collection of all tasks that must be reminded of at the specified time.
Schedule.GetTasksToRemindOf (DateTime, DateTime) | Retrieves a collection of all tasks that must be reminded of in the specified interval.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method ()

Schedule.GetTasksToRemindOf Method ()
See Also

Retrieves a collection of all tasks that must be reminded of at the current time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TaskCollection GetTasksToRemindOf ()
Visual Basic

Public Function GetTasksToRemindOf () As TaskCollection

Return Value

The collection of all tasks whose reminders must be displayed at the current time.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method (DateTime)

Schedule.GetTasksToRemindOf Method (DateTime)
See Also

Retrieves a collection of all tasks that must be reminded of at the specified time.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TaskCollection GetTasksToRemindOf (
DateTime time
)
Visual Basic

Public Function GetTasksToRemindOf ( _
time As DateTime _
) As TaskCollection

Parameters

time
Determine whether any task reminders should be displayed at this time.

Return Value

The collection of all tasks whose reminders must be displayed at the specified time.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.GetTasksToRemindOf Method (DateTime, DateTime)

Schedule.GetTasksToRemindOf Method (DateTime, DateTime)
See Also

Retrieves a collection of all tasks that must be reminded of in the specified interval.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TaskCollection GetTasksToRemindOf (
DateTime start,
DateTime end
)
Visual Basic

Public Function GetTasksToRemindOf ( _
start As DateTime, _
end As DateTime _
) As TaskCollection

Parameters

start
The start of the time interval containing the tasks of interest.
end
The end of the time interval containing the tasks of interest.

Return Value

The collection of all tasks whose reminders must be displayed in the specified time interval.

See Also

GetTasksToRemindOf Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
GetItemsToRemindOf Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method

Schedule.IsClassRegistered Method

Checks whether a specified class identifier or type is registered for serialization.

Overload List

Name | Description
Schedule.IsClassRegistered (String) | Checks whether the specified item or resource class identifier is registered for serializaiton.
Schedule.IsClassRegistered (Type) | Checks whether the specified item or resource type is registered for serializaiton.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method (String)

Schedule.IsClassRegistered Method (String)
See Also

Checks whether the specified item or resource class identifier is registered for serializaiton.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public static bool IsClassRegistered (
string classId
)
Visual Basic

Public Shared Function IsClassRegistered ( _
classId As String _
) As Boolean

Parameters

classId
The string identifier of an item or resource class.

Return Value

true if the specified class identifier is already registered; otherwise, false.

See Also

IsClassRegistered Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.IsClassRegistered Method (Type)

Schedule.IsClassRegistered Method (Type)
See Also

Checks whether the specified item or resource type is registered for serializaiton.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public static bool IsClassRegistered (
Type classType
)
Visual Basic

Public Shared Function IsClassRegistered ( _
classType As Type _
) As Boolean

Parameters

classType
The type of an item or a resource.

Return Value

true if the specified class identifier is already registered; otherwise, false.

See Also

IsClassRegistered Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterItemClass Method
RegisterResourceClass Method
UnregisterClass Method


MindFusion.Scheduling.Schedule.LoadFrom Method

Schedule.LoadFrom Method

Loads schedule data from a file, a binary stream or an XML document.

Overload List

Name | Description
Schedule.LoadFrom (String) | Loads schedule data from a file.
Schedule.LoadFrom (XmlReader) | Loads schedule data from an XML document. Since version 4.4, this method is considered obsolete. Instead, use the LoadFromXml method.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.LoadFrom Method (String)

Schedule.LoadFrom Method (String)
See Also

Loads schedule data from a file.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void LoadFrom (
string fileName
)
Visual Basic

Public Sub LoadFrom ( _
fileName As String _
)

Parameters

fileName
The name of the file from which to load the schedule.

Remarks

This method loads the schedule data from a file where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the file are loaded.

See Also

LoadFrom Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Schedule.LoadFrom Method (XmlReader)

Schedule.LoadFrom Method (XmlReader)
See Also

Loads schedule data from an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the LoadFromXml method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void LoadFrom (
XmlReader reader
)
Visual Basic

Public Sub LoadFrom ( _
reader As XmlReader _
)

Parameters

reader
An XmlReader instance that allows reading data from the XML document.

Remarks

Loads schedule items from an XML document previously created by SaveTo. Any data contained in the schedule is discarded before the items stored in the reader are loaded.

See Also

LoadFrom Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Schedule.LoadFromString Method (String)

Schedule.LoadFromString Method (String)
See Also

Decodes schedule data from a string previously created by SaveToString.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void LoadFromString (
string content
)
Visual Basic

Public Sub LoadFromString ( _
content As String _
)

Parameters

content
A string that contains schedule data.

Remarks

This method loads from a string data previously saved by SaveToString.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveToString Method


MindFusion.Scheduling.Schedule.LoadFromXml Method

Schedule.LoadFromXml Method

Loads schedule data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void LoadFromXml (
XmlDocument document
)
Visual Basic

Public Sub LoadFromXml ( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument instance that allows reading data from the XML document.

Remarks

Loads schedule data from an XML document previously created by SaveToXml. Any data contained in the schedule is discarded before the items stored in the reader are loaded.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
SaveToXml Method


MindFusion.Scheduling.Schedule.OnDeserializeTag Method

Schedule.OnDeserializeTag Method

Raises the DeserializeTag event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)
Visual Basic

Protected Overridable Sub OnDeserializeTag ( _
e As SerializeTagEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnExceptionCreated Method

Schedule.OnExceptionCreated Method

Raises the ExceptionCreated event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnExceptionCreated (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnExceptionCreated ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnInstantiateItem Method

Schedule.OnInstantiateItem Method

Raises the InstantiateItem event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnInstantiateItem (
InstantiateItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnInstantiateItem ( _
e As InstantiateItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnInstantiateResource Method

Schedule.OnInstantiateResource Method

Raises the InstantiateResource event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnInstantiateResource (
InstantiateResourceEventArgs e
)
Visual Basic

Protected Overridable Sub OnInstantiateResource ( _
e As InstantiateResourceEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemEndTimeChanged Method

Schedule.OnItemEndTimeChanged Method

Raises the ItemEndTimeChanged event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemEndTimeChanged (
ItemTimeEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemEndTimeChanged ( _
e As ItemTimeEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemEndTimeTriggered Method

Schedule.OnItemEndTimeTriggered Method

Raises the ItemEndTimeTriggered event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemEndTimeTriggered (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemEndTimeTriggered ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemReminderTriggered Method

Schedule.OnItemReminderTriggered Method

Raises the ItemReminderTriggered event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemReminderTriggered (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemReminderTriggered ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemStartTimeChanged Method

Schedule.OnItemStartTimeChanged Method

Raises the ItemStartTimeChanged event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemStartTimeChanged (
ItemTimeEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemStartTimeChanged ( _
e As ItemTimeEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnItemVisualsChanged Method

Schedule.OnItemVisualsChanged Method

Raises the ItemVisualsChanged event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemVisualsChanged (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemVisualsChanged ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnRecurrenceReset Method

Schedule.OnRecurrenceReset Method

Raises the RecurrenceReset event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnRecurrenceReset (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnRecurrenceReset ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnSerializeTag Method

Schedule.OnSerializeTag Method

Raises the SerializeTag event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)
Visual Basic

Protected Overridable Sub OnSerializeTag ( _
e As SerializeTagEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.OnTaskReminderTriggered Method

Schedule.OnTaskReminderTriggered Method

Raises the TaskReminderTriggered event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnTaskReminderTriggered (
TaskEventArgs e
)
Visual Basic

Protected Overridable Sub OnTaskReminderTriggered ( _
e As TaskEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.RegisterItemClass Method

Schedule.RegisterItemClass Method

Registers a schedule item class for serialization support.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion
)
Visual Basic

Public Shared Sub RegisterItemClass ( _
itemClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

itemClass
A .NET Type instance identifying the item class.
classId
A class identifier to use when saving and loading items of the specified type.
classVersion
A revision number of the item's class serialization format.

Remarks

When using custom item classes, use this method to enable saving and loading the custom item objects to/from XML or binary files. The class id string is written before each item's data, and when loading items later that string indicates to the schedule what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used: 'std:appointment', 'std:resource', 'std:contact', 'std:location' and 'std:task'.

The version identifier must be increased when the format in which items are saved changes. It is used when loading files to let your application load items data from an older format.

Note

All custom item classes must provide a parameterless constructor. Failing to do so would result in exceptions during the load process, since the schedule will be unable to create custom items.

Example

The following example demonstrates how to use custom item classes with the schedule and how to load and save a schedule containing custom items. The example presumes that schedule already references an existing Schedule object.

Running the example should dump the following line to the output console:

Hello, friend!

C#

/// <summary>
/// The declaration of the custom item class.
/// </summary>
class CustomItem : Appointment
{
/// <summary>
/// The parameterless constructor, required by the Schedule.
/// </summary>
public CustomItem()
{
_customField = "This is my field.";
}

public override void LoadFrom(
System.IO.BinaryReader reader,
SerializationContext context)
{
// Don't forget to invoke LoadFrom on the base class
base.LoadFrom(reader, context);

_customField = reader.ReadString();
}

public override void LoadFrom(
System.Xml.XmlReader reader,
SerializationContext context)
{
// Don't forget to invoke LoadFrom on the base class
base.LoadFrom(reader, context);

_customField = reader.ReadElementString("customField");
}

public override void SaveTo(
System.IO.BinaryWriter writer,
SerializationContext context)
{
// Don't forget to invoke SaveTo on the base class
base.SaveTo(writer, context);

writer.Write(_customField);
}

public override void SaveTo(
System.Xml.XmlWriter writer,
SerializationContext context)
{
base.SaveTo(writer, context);

writer.WriteElementString("customField", _customField);
}

public string CustomField
{
get { return _customField; }
set { _customField = value; }
}

private string _customField;
}

// ...

// Register our custom item class for use with the schedule
Schedule.RegisterItemClass(typeof(CustomItem), "customItemId", 1);

// Create a new custom item and add it to the schedule
CustomItem customItem = new CustomItem();
customItem.CustomField = "Hello, friend!";
schedule.Items.Add(customItem);

// Save the schedule to a file.
// Make sure the specified path exists on your drive
schedule.SaveTo(@"c:\schedule.save", ContentType.Xml);

// Clear the schedule
schedule.Items.Clear();

// Load the previously saved schedule data
schedule.LoadFrom(@"c:\schedule.save", ContentType.Xml);

// Test the data
foreach (Item item in schedule.Items)
{
if (item is CustomItem)
{
System.Diagnostics.Debug.WriteLine(
(item as CustomItem).CustomField);
}
}
Visual Basic

' <summary>
' The declaration of the custom item class.
' </summary>
Class CustomItem
Inherits Appointment

' <summary>
' The parameterless constructor, required by the Schedule.
' </summary>
Public Sub New()

_customField = "This is my field."

End Sub

Public Overloads Overrides Sub LoadFrom( _
ByVal reader As System.IO.BinaryReader, _
ByVal context As SerializationContext)

' Don't forget to invoke LoadFrom on the base class
MyBase.LoadFrom(reader, context)

_customField = reader.ReadString()

End Sub

Public Overloads Overrides Sub LoadFrom( _
ByVal reader As System.Xml.XmlReader, _
ByVal context As SerializationContext)

' Don't forget to invoke LoadFrom on the base class
MyBase.LoadFrom(reader, context)

_customField = reader.ReadElementString("customField")

End Sub

Public Overloads Overrides Sub SaveTo( _
ByVal writer As System.IO.BinaryWriter, _
ByVal context As SerializationContext)

' Don't forget to invoke SaveTo on the base class
MyBase.SaveTo(writer, context)

writer.Write(_customField)

End Sub

Public Overloads Overrides Sub SaveTo( _
ByVal writer As System.Xml.XmlWriter, _
ByVal context As SerializationContext)

MyBase.SaveTo(writer, context)

writer.WriteElementString("customField", _customField)

End Sub

Public Property CustomField() As String

Get
Return _customField
End Get

Set(ByVal Value As String)
_customField = Value
End Set

End Property

Private _customField As String

End Class

' ...

' Register our custom item class for use with the schedule
schedule.RegisterItemClass(GetType(CustomItem), "customItemId", 1)

' Create a new custom item and add it to the schedule
Dim customItem As New CustomItem
customItem.CustomField = "Hello, friend!"
schedule.Items.Add(customItem)

' Save the schedule to a file.
' Make sure the specified path exists on your drive
schedule.SaveTo("c:\schedule.save", ContentType.Xml)

' Clear the schedule
schedule.Items.Clear()

' Load the previously saved schedule data
schedule.LoadFrom("c:\schedule.save", ContentType.Xml)

' Test the data
Dim item As Item
For Each item In schedule.Items

If TypeOf item Is CustomItem Then

System.Diagnostics.Debug.WriteLine( _
CType(item, CustomItem).CustomField)

End If

Next item

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RegisterResourceClass Method


MindFusion.Scheduling.Schedule.RegisterResourceClass Method

Schedule.RegisterResourceClass Method

Registers a resource class for serialization support.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public static void RegisterResourceClass (
Type resourceClass,
string classId,
int classVersion
)
Visual Basic

Public Shared Sub RegisterResourceClass ( _
resourceClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

resourceClass
A .NET Type instance identifying the resource class.
classId
A class identifier to use when saving and loading resources of the specified type.
classVersion
A revision number of the resource's class serialization format.

Remarks

When using custom resource classes, use this method to enable saving and loading the custom resource objects to/from XML or binary files. The class id string is written before each resource's data, and when loading resources later that string indicates to the schedule what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used: 'std:appointment', 'std:resource', 'std:contact', 'std:location' and 'std:task'.

The version identifier must be increased when the format in which resources are saved changes. It is used when loading files to let your application load resources data from an older format.

Note

All custom resource classes must provide a parameterless constructor. Failing to do so would result in exceptions during the load process, since the schedule will be unable to create custom resources.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveTo Method

Schedule.SaveTo Method

Saves the schedule to a file, a binary stream or an XML document.

Overload List

Name | Description
Schedule.SaveTo (String) | Saves the schedule to a file.
Schedule.SaveTo (XmlWriter, Boolean) | Saves the schedule to an XML document. Since version 4.4, this method is considered obsolete. Instead, use the SaveToXml method.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SaveTo Method (String)

Schedule.SaveTo Method (String)
See Also

Saves the schedule to a file.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void SaveTo (
string fileName
)
Visual Basic

Public Sub SaveTo ( _
fileName As String _
)

Parameters

fileName

The path of the file to save to.

Remarks

Saves the schedule data into a binary or XML file. Use LoadFrom to restore the data later.

See Also

SaveTo Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Schedule.SaveTo Method (XmlWriter, Boolean)

Schedule.SaveTo Method (XmlWriter, Boolean)
See Also

Saves the schedule to an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the SaveToXml method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void SaveTo (
XmlWriter writer,
bool document
)
Visual Basic

Public Sub SaveTo ( _
writer As XmlWriter, _
document As Boolean _
)

Parameters

writer
A .NET XmlWriter object that allows adding data to the XML document.
document
Specifies whether the schedule data should be written as a top-level element in the XML document.

Remarks

Saves the schedule data as tags in an XML document. Use LoadFrom to restore the schedule data later.

See Also

SaveTo Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Schedule.SaveToString Method ()

Schedule.SaveToString Method ()
See Also

Encodes the schedule into a string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string SaveToString ()
Visual Basic

Public Function SaveToString () As String

Return Value

A string containing all schedule data.

Remarks

Saves the schedule data into a base64-encoded string. Use LoadFromString to restore the data later.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFromString Method


MindFusion.Scheduling.Schedule.SaveToXml Method

Schedule.SaveToXml Method

Saves the schedule to an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void SaveToXml (
XmlDocument document
)
Visual Basic

Public Sub SaveToXml ( _
document As XmlDocument _
)

Parameters

document
A .NET XmlDocument object that allows adding data to the XML document.

Remarks

Saves the schedule data as tags in an XML document. Use LoadFromXml to restore the schedule data later.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
LoadFromXml Method


MindFusion.Scheduling.Schedule.UnregisterClass Method

Schedule.UnregisterClass Method

Unregisters the item or resource with the specified class identifier or type from the system.

Overload List

Name | Description
Schedule.UnregisterClass (String) | Unregisters the item or resource with the specified class id from the system.
Schedule.UnregisterClass (Type) | Unregisters the specified item or resource type from the system.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
IsClassRegistered Method
RegisterItemClass Method
RegisterResourceClass Method


MindFusion.Scheduling.Schedule.UnregisterClass Method (String)

Schedule.UnregisterClass Method (String)
See Also

Unregisters the item or resource with the specified class id from the system.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public static void UnregisterClass (
string classId
)
Visual Basic

Public Shared Sub UnregisterClass ( _
classId As String _
)

Parameters

classId
The string identifier of an item or resource class.

See Also

UnregisterClass Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
IsClassRegistered Method
RegisterItemClass Method
RegisterResourceClass Method


MindFusion.Scheduling.Schedule.UnregisterClass Method (Type)

Schedule.UnregisterClass Method (Type)
See Also

Unregisters the specified item or resource type from the system.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public static void UnregisterClass (
Type classType
)
Visual Basic

Public Shared Sub UnregisterClass ( _
classType As Type _
)

Parameters

classType
The type of an item or a resource.

See Also

UnregisterClass Method Overload List
Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
IsClassRegistered Method
RegisterItemClass Method
RegisterResourceClass Method


MindFusion.Scheduling.Schedule Properties

Schedule Properties

Public Properties

Name | Description
Contacts | Gets all contacts defined in the Schedule.
DisableReminders | Gets or sets a value indicating whether to completely disable reminders in the whole schedule.
Items | Gets all scheduled items.
Locations | Gets all locations defined in the Schedule.
RemindersCheckInterval | Gets or sets the interval between reminder checks, expressed in seconds.
Resources | Gets all resources defined in the Schedule.
Tasks | Gets all tasks defined in this Schedule.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Contacts Property

Schedule.Contacts Property

Gets all contacts defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ContactCollection Contacts { get; }
Visual Basic

Public ReadOnly Property Contacts As ContactCollection

Property Value

An instance of the ContactCollection class containing all contacts used in the schedule.

Remarks

Add contacts to this collection before assigning them to a schedule item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Contact Class


MindFusion.Scheduling.Schedule.DisableReminders Property

Schedule.DisableReminders Property

Gets or sets a value indicating whether to completely disable reminders in the whole schedule.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool DisableReminders { get; set; }
Visual Basic

Public Property DisableReminders As Boolean

Property Value

true to disable reminders; false to enable them. The default is false.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Items Property

Schedule.Items Property

Gets all scheduled items.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemCollection Items { get; }
Visual Basic

Public ReadOnly Property Items As ItemCollection

Property Value

An instance of the ItemCollection class containing all items in the schedule.

Remarks

The Calendar control displays each element of this collection in the time cells corresponding to the item's StartTime and EndTime.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Item Class


MindFusion.Scheduling.Schedule.Locations Property

Schedule.Locations Property

Gets all locations defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public LocationCollection Locations { get; }
Visual Basic

Public ReadOnly Property Locations As LocationCollection

Property Value

An instance of the LocationCollection class containing all locations associated with this schedule.

Remarks

Add locations to this collection before assigning them to schedule items.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Location Class


MindFusion.Scheduling.Schedule.RemindersCheckInterval Property

Schedule.RemindersCheckInterval Property

Gets or sets the interval between reminder checks, expressed in seconds.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int RemindersCheckInterval { get; set; }
Visual Basic

Public Property RemindersCheckInterval As Integer

Property Value

A positive integer value specifying the time between subsequent reminder checks.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Resources Property

Schedule.Resources Property

Gets all resources defined in the Schedule.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ResourceCollection Resources { get; }
Visual Basic

Public ReadOnly Property Resources As ResourceCollection

Property Value

An instance of the ResourceCollection class containing all resources associated with this schedule.

Remarks

Add resources to this collection before assigning them to schedule items.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Resource Class


MindFusion.Scheduling.Schedule.Tasks Property

Schedule.Tasks Property

Gets all tasks defined in this Schedule.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TaskCollection Tasks { get; }
Visual Basic

Public ReadOnly Property Tasks As TaskCollection

Property Value

An instance of the TaskCollection class containing references to the tasks assigned to the schedule.

Remarks

If you need to assign a Task object to schedule items, add the task to this collection before assigning it to the item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
Task Class


MindFusion.Scheduling.Schedule Events

Schedule Events

Public Events

Name | Description
Changed | Raised when items are added or removed from the schedule or when the schedule is loaded.
DeserializeTag | Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.
ExceptionCreated | Raised when a recurrence exception item is created.
InstantiateItem | Raised when deserializing a custom item whose type has not been registered.
InstantiateResource | Raised when deserializing a custom resource whose type has not been registered.
ItemEndTimeChanged | Raised when the EndTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous EndTime value of the item.
ItemEndTimeTriggered | Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.
ItemReminderTriggered | Raised when the reminder for an item is triggered.
ItemStartTimeChanged | Raised when the StartTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous StartTime value of the item.
ItemVisualsChanged | Raised when the appearance of an item in the schedule has changed.
RecurrenceReset | Raised when the recurrence pattern associated with an item has been reset, causing all associated exception items to be lost.
SerializeTag | Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.
TaskReminderTriggered | Raised when the reminder for a task is triggered.

See Also

Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.Changed Event

Schedule.Changed Event

Raised when items are added or removed from the schedule or when the schedule is loaded.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public EventHandler Changed
Visual Basic

Public Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.DeserializeTag Event

Schedule.DeserializeTag Event

Raised during XML deserialization to enable users to perform custom deserialization of the tag values of items and resources.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public SerializeTagEventHandler DeserializeTag
Visual Basic

Public DeserializeTag As SerializeTagEventHandler

Remarks

This event is being raised during the deserialization of item and resource tag values from a XML document. If the event is not handled the system will try to deserialize the tags as an arbitrary objects.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ExceptionCreated Event

Schedule.ExceptionCreated Event

Raised when a recurrence exception item is created.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemEventHandler ExceptionCreated
Visual Basic

Public ExceptionCreated As ItemEventHandler

Event Data

ExceptionCreated event handlers receive an argument of type ItemEventArgs.

Remarks

An exception is created if a user drags an occurrence of a recurring event thus changing its time, or changes its text.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace
RecurrenceException Class


MindFusion.Scheduling.Schedule.InstantiateItem Event

Schedule.InstantiateItem Event

Raised when deserializing a custom item whose type has not been registered.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public InstantiateItemEventHandler InstantiateItem
Visual Basic

Public InstantiateItem As InstantiateItemEventHandler

Remarks

This event is being raised during deserialization for all custom items whose types have not been previously registered within the system through a call to RegisterItemClass. The event provides an alternative way for instantiating item of custom types.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.InstantiateResource Event

Schedule.InstantiateResource Event

Raised when deserializing a custom resource whose type has not been registered.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public InstantiateResourceEventHandler InstantiateResource
Visual Basic

Public InstantiateResource As InstantiateResourceEventHandler

Remarks

This event is being raised during deserialization for all custom resources whose types have not been previously registered within the system through a call to RegisterResourceClass. The event provides an alternative way for instantiating resources of custom types.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemEndTimeChanged Event

Schedule.ItemEndTimeChanged Event

Raised when the EndTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous EndTime value of the item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemTimeEventHandler ItemEndTimeChanged
Visual Basic

Public ItemEndTimeChanged As ItemTimeEventHandler

Event Data

ItemEndTimeChanged event handlers receive an argument of type ItemTimeEventArgs.

Remarks

The ItemTimeEventArgs.Time property provides the previous EndTime value of the item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemEndTimeTriggered Event

Schedule.ItemEndTimeTriggered Event

Raised when the reminder for an item is triggered, but taking into consideration the item's end time for the purpose.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemEventHandler ItemEndTimeTriggered
Visual Basic

Public ItemEndTimeTriggered As ItemEventHandler

Event Data

ItemEndTimeTriggered event handlers receive an argument of type ItemEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemReminderTriggered Event

Schedule.ItemReminderTriggered Event

Raised when the reminder for an item is triggered.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemEventHandler ItemReminderTriggered
Visual Basic

Public ItemReminderTriggered As ItemEventHandler

Event Data

ItemReminderTriggered event handlers receive an argument of type ItemEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemStartTimeChanged Event

Schedule.ItemStartTimeChanged Event

Raised when the StartTime property of an item in this Schedule has changed. The ItemTimeEventArgs.Time property provides the previous StartTime value of the item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemTimeEventHandler ItemStartTimeChanged
Visual Basic

Public ItemStartTimeChanged As ItemTimeEventHandler

Event Data

ItemStartTimeChanged event handlers receive an argument of type ItemTimeEventArgs.

Remarks

The ItemTimeEventArgs.Time property provides the previous StartTime value of the item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.ItemVisualsChanged Event

Schedule.ItemVisualsChanged Event

Raised when the appearance of an item in the schedule has changed.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemEventHandler ItemVisualsChanged
Visual Basic

Public ItemVisualsChanged As ItemEventHandler

Event Data

ItemVisualsChanged event handlers receive an argument of type ItemEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.RecurrenceReset Event

Schedule.RecurrenceReset Event

Raised when the recurrence pattern associated with an item has been reset, causing all associated exception items to be lost.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ItemEventHandler RecurrenceReset
Visual Basic

Public RecurrenceReset As ItemEventHandler

Event Data

ItemVisualsChanged event handlers receive an argument of type ItemEventArgs.

Remarks

The recurrence is reset when the value of any of the properties that define it is changed. The recurrence is also reset when it is associated to or dissociated from an item.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.SerializeTag Event

Schedule.SerializeTag Event

Raised during XML serialization to enable users to perform custom serialization of the tag values of items and resources.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public SerializeTagEventHandler SerializeTag
Visual Basic

Public SerializeTag As SerializeTagEventHandler

Remarks

This event is being raised during the serialization of item and resource tag values in a XML document. If the event is not handled the system will try to serialize the tags as an arbitrary objects.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Schedule.TaskReminderTriggered Event

Schedule.TaskReminderTriggered Event

Raised when the reminder for a task is triggered.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TaskEventHandler TaskReminderTriggered
Visual Basic

Public TaskReminderTriggered As TaskEventHandler

Event Data

TaskReminderTriggered event handlers receive an argument of type TaskEventArgs.

See Also

Schedule Members
Schedule Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Class

SerializationContext Class

This class contains information required to serialize a Schedule element to and from a binary stream or XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public sealed class SerializationContext
Visual Basic

Public NotInheritable Class SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.XmlSerializationContext

See Also

SerializationContext Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Members

SerializationContext Members
Constructors Properties

This class contains information required to serialize a Schedule element to and from a binary stream or XML document.

The following tables list the members exposed by the SerializationContext type.

Public Constructors

Name | Description
SerializationContext | Initializes a new instance of the SerializationContext class.

Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded.
Schedule | Gets a reference to the schedule currently being serialized or deserialized.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Constructor

SerializationContext Constructor

Initializes a new instance of the SerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public SerializationContext (
Schedule schedule
)
Visual Basic

Public Sub SerializationContext ( _
schedule As Schedule _
)

Parameters

schedule

An instance of the Schedule class representing the schedule to associate with.

Remarks

Generally, you do not have to instantiate from SerializationContext explicitly unless you want to serialize only particular elements and not the entire schedule.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext Properties

SerializationContext Properties

Public Properties

Name | Description
FileVersion | Gets the format revision number of the file being loaded.
Schedule | Gets a reference to the schedule currently being serialized or deserialized.

See Also

SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.FileVersion Property

SerializationContext.FileVersion Property

Gets the format revision number of the file being loaded.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int FileVersion { get; }
Visual Basic

Public ReadOnly Property FileVersion As Integer

Property Value

An integer value identifying the schedule file format revision number.

Remarks

This revision number specifies the format of the schedule binary and XML files, but not of distinct item classes. If using custom item classes, specify their format revision number when registering them with the schedule via the RegisterItemClass method.

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializationContext.Schedule Property

SerializationContext.Schedule Property

Gets a reference to the schedule currently being serialized or deserialized.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Schedule Schedule { get; }
Visual Basic

Public ReadOnly Property Schedule As Schedule

Property Value

An instance of the Schedule class.

See Also

SerializationContext Members
SerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Class

SerializeTagEventArgs Class

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class SerializeTagEventArgs : EventArgs
Visual Basic

Public Class SerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the Item or Resource whose Tag is being serialized/deserialized.
Representation | Gets or sets the XmlElement representing the root element in the XML tree of the tag object being serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the Item or Resource whose Tag is being serialized/deserialized.
Representation | Gets or sets the XmlElement representing the root element in the XML tree of the tag object being serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlSerializationContext Context { get; }
Visual Basic

Public ReadOnly Property Context As XmlSerializationContext

Property Value

An instance of the XmlSerializationContext class.

Remarks

It is recommended to operate with the underlying XML document by calling the methods of this object. See the example section below for a demonstration on how to use this object.

Example

The following example demonstrates how to use the Context object in order to write and read complex tag values in the XML document.

C#

class MyTag
{
public MyTag(int intValue, string stringValue)
{
IntValue = intValue;
StringValue = stringValue;
}

public int IntValue;
public string StringValue;
}

// ...

private void OnSerializeTag(object sender, SerializeTagEventArgs e)
{
if (e.Tag is MyTag)
{
e.Handled = true;
e.Context.WriteBool(true, "mytag", e.Representation);

MyTag tag = e.Tag as MyTag;
e.Context.WriteInt(tag.IntValue, "intValue", e.Representation);
e.Context.WriteString(tag.StringValue, "stringValue", e.Representation);
}
}

private void OnDeserializeTag(object sender, SerializeTagEventArgs e)
{
if (e.Context.ReadBool("mytag", e.Representation, false))
{
e.Handled = true;

int intValue = e.Context.ReadInt("intValue", e.Representation);
string stringValue = e.Context.ReadString("stringValue", e.Representation);

e.Tag = new MyTag(intValue, stringValue);
}
}
Visual Basic

Class MyTag

Public Sub New(ByVal intValue As Integer, ByVal stringValue As String)

IntValue = intValue;
StringValue = stringValue;

End Sub

Public IntValue As Integer
Public StringValue As String

End Class

Private Sub OnSerializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)

If TypeOf e.Tag Is MyTag Then

e.Handled = True
e.Context.WriteBool(True, "mytag", e.Representation)

Dim tag As MyTag = CType(e.Tag, MyTag)
e.Context.WriteInt(tag.IntValue, "intValue", e.Representation)
e.Context.WriteString(tag.StringValue, "stringValue", e.Representation)

End If

End Sub

Private Sub OnDeserializeTag(ByVal sender As Object, ByVal e As SerializeTagEventArgs)

If e.Context.ReadBool("mytag", e.Representation, False) Then

e.Handled = True

Dim intValue As Integer = e.Context.ReadInt("intValue", e.Representation)
Dim stringValue As String = e.Context.ReadString("stringValue", e.Representation)

e.Tag = New MyTag(intValue, stringValue)

End If

End Sub

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Handled { get; set; }
Visual Basic

Public Property Handled As Boolean

Property Value

true to indicate that the system should not attempt to serialize or deserialize the tag; otherwise, false.

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Object Property

SerializeTagEventArgs.Object Property

Gets the Item or Resource whose Tag is being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Object Object { get; }
Visual Basic

Public ReadOnly Property Object As Object

Property Value

A reference to an Item or Resource class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property

Gets or sets the XmlElement representing the root element in the XML tree of the tag object being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement Representation { get; set; }
Visual Basic

Public Property Representation As XmlElement

Property Value

An instance of the .NET XmlElement class representing the node in the XML document, containing the tag representation.

Remarks

When serializing tags use this XML element as a root of the tag representation by adding child elements to it. When deserializing the tag use this XML element as a root of the tag representation by reading child elements from it.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property

Gets or sets the tag object being serialized/deserialized.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Object Tag { get; set; }
Visual Basic

Public Property Tag As Object

Property Value

An object representing the tag value being serialized or deserialized.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.SerializeTagEventHandler Delegate

SerializeTagEventHandler Delegate

Represents methods that will handle the SerializeTag and DeserializeTag events of the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public delegate void SerializeTagEventHandler (
Object sender,
SerializeTagEventArgs e
)
Visual Basic

Public Delegate Sub SerializeTagEventHandler ( _
sender As Object, _
e As SerializeTagEventArgs _
)

Parameters

sender
The source of the event.
e
A SerializeTagEventArgs that contains the event data.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.ShadowStyle Enumeration

ShadowStyle Enumeration

Specifies what type of shadow effect to apply to a calendar UI element.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum ShadowStyle
Visual Basic

Public Enumeration ShadowStyle

Members

Member name | Description
Fading | Display a fading shadow.
None | Do not display a shadow.
Solid | Display a solid shadow.
Unspecified | The shadow style is not specified.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Class

Style Class

Specifies the appearance of calendar elements.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class Style : ICloneable, ISerializable
Visual Basic

Public Class Style
Implements ICloneable, ISerializable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Style

See Also

Style Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Members

Style Members
Constructors Properties Methods Events

Specifies the appearance of calendar elements.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Overloaded.

Public Properties

Name Description

BorderBottomColor

Gets or sets the color used to paint the bottom border of a calendar element.

BorderBottomWidth

Gets or sets the width in pixels of the bottom border of an element.

BorderColorDark

Gets or sets the color used to paint the dark sides of the outermost 3D border of a calendar element.

Since version 4.0, this property is considered obsolete. Instead, use the BorderRightColor and BorderBottomColor properties.

BorderColorLight

Gets or sets the color used to paint the light sides of the outermost 3D border of a calendar element.

Since version 4.0, this property is considered obsolete. Instead, use the BorderLeftColor and BorderTopColor properties.

BorderLeftColor

Gets or sets the color used to paint the left border of a calendar element.

BorderLeftWidth

Gets or sets the width in pixels of the left border of an element.

BorderRightColor

Gets or sets the color used to paint the right border of a calendar element.

BorderRightWidth

Gets or sets the width in pixels of the right border of an element.

BorderTopColor

Gets or sets the color used to paint the top border of a calendar element.

BorderTopWidth

Gets or sets the width in pixels of the top border of an element.

BorderWidth

Gets or sets the width in pixels of the outermost border of an element.

Since version 4.0, this property is considered obsolete. Instead, use the BorderLeftWidth, BorderTopWidth, BorderRightWidth and BorderBottomWidth properties.

Brush

Gets or sets the brush used to fill the interior of elements.

FillColor

Gets or sets the color used to fill calendar elements.

Font

Gets or sets the font used to display an element's text.

HeaderBorderBottomColor

Gets or sets the color used to paint the bottom border of an element's header.

HeaderBorderBottomWidth

Gets or sets the width in pixels of the bottom border of an element's header.

HeaderBorderColorDark

Gets or sets the color used to paint the dark sides of the outermost 3D border of an element's header.

Since version 4.0, this property is considered obsolete. Instead, use the HeaderBorderRightColor and HeaderBorderBottomColor properties.

HeaderBorderColorLight

Gets or sets the color used to paint the light sides of the outermost 3D border of an element's header.

Since version 4.0, this property is considered obsolete. Instead, use the HeaderBorderLeftColor and HeaderBorderTopColor properties.

HeaderBorderLeftColor

Gets or sets the color used to paint the left border of an element's header.

HeaderBorderLeftWidth

Gets or sets the width in pixels of the left border of an element's header.

HeaderBorderRightColor

Gets or sets the color used to paint the right border of an element's header.

HeaderBorderRightWidth

Gets or sets the width in pixels of the right border of an element's header.

HeaderBorderTopColor

Gets or sets the color used to paint the top border of an element's header.

HeaderBorderTopWidth

Gets or sets the width in pixels of the top border of an element's header.

HeaderBorderWidth

Gets or sets the width in pixels of the outermost border of an element's header.

Since version 4.0, this property is considered obsolete. Instead, use the HeaderBorderLeftWidth, HeaderBorderTopWidth, HeaderBorderRightWidth and HeaderBorderBottomWidth properties.

HeaderBrush

Gets or sets the brush used to fill the interior of an element's header.

HeaderFont

Gets or sets the font used to paint the text of an element's header.

HeaderTextAlignment

Gets or sets the alignment of the headers' text.

HeaderTextBottomMargin

Gets or sets the bottom header text margin.

HeaderTextColor

Gets or sets the color used to paint the text of an element's header.

HeaderTextLeftMargin

Gets or sets the left header text margin.

HeaderTextRightMargin

Gets or sets the right header text margin.

HeaderTextShadowColor

Gets or sets the color of the shadow cast by the header text.

HeaderTextShadowOffset

Gets or sets the distance of the shadow from the header text that casts it.

HeaderTextShadowStyle

Gets or sets the type of the shadow cast by the header text.

HeaderTextTopMargin

Gets or sets the top header text margin.

Image

Gets or sets an image associated with this style.

ImageAlignment

Gets or sets the image alignment to be used when rendering the image assigned to this style.

ImageIndex

Gets or sets the index of the image from the calendar image list assigned to this style.

LineColor

Gets or sets the color used to paint various lines that are not part of element borders.

TextAlignment

Gets or sets the alignment of the text contents of a calendar element.

TextBottomMargin

Gets or sets the bottom text margin.

TextColor

Gets or sets the color used to paint an element's text.

TextLeftMargin

Gets or sets the left text margin.

TextRightMargin

Gets or sets the right text margin.

TextShadowColor

Gets or sets the color of the shadow cast by the text.

TextShadowOffset

Gets or sets the distance of the shadow from the text that casts it.

TextShadowStyle

Gets or sets the type of the shadow cast by the text.

TextTopMargin

Gets or sets the top text margin.

Public Methods

Name | Description
Clone | Creates an exact copy of this Style object.
Equals | Determines whether this style is equivalent to the specified style.
FromDefinition | Creates a new style from the specified definition.
GetHashCode | Returns the hash code for this Style instance.
Restore | Restores a Style object from a style string representation.
Store | Creates a string representation of the Style.

Protected Methods

Name | Description
OnChanged | Fires the Changed event.

Public Events

Name | Description
Changed | Raised when the style changes.

See Also

Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Constructor

Style Constructor

Overload List

Name | Description
Style () | Initializes a new empty instance of the Style class.
Style (String) | Initializes a new Style instance out of the specified string representation.

See Also

Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Constructor ()

Style Constructor ()
See Also

Initializes a new empty instance of the Style class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Style ()
Visual Basic

Public Sub New ()

See Also

Style Constructor Overload List
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Constructor (String)

Style Constructor (String)
See Also

Initializes a new Style instance out of the specified string representation.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Style (
string representation
)
Visual Basic

Public Sub Style ( _
representation As String _
)

Parameters

representation

Remarks

This constructor is for internal use only.

See Also

Style Constructor Overload List
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Methods

Style Methods

Public Methods

Name | Description
Clone | Creates an exact copy of this Style object.
Equals | Determines whether this style is equivalent to the specified style.
FromDefinition | Creates a new style from the specified definition.
GetHashCode | Returns the hash code for this Style instance.
Restore | Restores a Style object from a style string representation.
Store | Creates a string representation of the Style.

Protected Methods

Name | Description
OnChanged | Fires the Changed event.

See Also

Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Clone Method

Style.Clone Method

Creates an exact copy of this Style object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public virtual Object Clone ()
Visual Basic

Public Overridable Function Clone () As Object

Return Value

The Style copy created by this method.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Equals Method

Style.Equals Method

Determines whether this style is equivalent to the specified style.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override bool Equals (
Object obj
)
Visual Basic

Public Overrides Function Equals ( _
obj As Object _
) As Boolean

Parameters

obj
A Style object to compare with this one.

Return Value

true if the two styles are the same; otherwise, false.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.FromDefinition Method

Style.FromDefinition Method

Creates a new style from the specified definition.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public static Style FromDefinition (
string representation
)
Visual Basic

Public Shared Function FromDefinition ( _
representation As String _
) As Style

Parameters

representation

The string representation of the style.

Return Value

A new Style object corresponding to the specified representation.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.GetHashCode Method

Style.GetHashCode Method

Returns the hash code for this Style instance.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override int GetHashCode ()
Visual Basic

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for this object.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.OnChanged Method

Style.OnChanged Method

Fires the Changed event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

protected void OnChanged (
EventArgs e
)
Visual Basic

Protected Sub OnChanged ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Restore Method

Style.Restore Method

Restores a Style object from a style string representation.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Restore (
string representation
)
Visual Basic

Public Sub Restore ( _
representation As String _
)

Parameters

representation
The string representation of the style.

Remarks

Restore the Style members from the string created by Store.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Store Method

Style.Store Method

Creates a string representation of the Style.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Store ()
Visual Basic

Public Function Store () As String

Return Value

A string containing the Style representation.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style Properties

Style Properties

Public Properties

Name Description

BorderBottomColor

Gets or sets the color used to paint the bottom border of a calendar element.

BorderBottomWidth

Gets or sets the width in pixels of the bottom border of an element.

BorderColorDark

Gets or sets the color used to paint the dark sides of the outermost 3D border of a calendar element.

Since version 4.0, this property is considered obsolete. Instead, use the BorderRightColor and BorderBottomColor properties.

BorderColorLight

Gets or sets the color used to paint the light sides of the outermost 3D border of a calendar element.

Since version 4.0, this property is considered obsolete. Instead, use the BorderLeftColor and BorderTopColor properties.

BorderLeftColor

Gets or sets the color used to paint the left border of a calendar element.

BorderLeftWidth

Gets or sets the width in pixels of the left border of an element.

BorderRightColor

Gets or sets the color used to paint the right border of a calendar element.

BorderRightWidth

Gets or sets the width in pixels of the right border of an element.

BorderTopColor

Gets or sets the color used to paint the top border of a calendar element.

BorderTopWidth

Gets or sets the width in pixels of the top border of an element.

BorderWidth

Gets or sets the width in pixels of the outermost border of an element.

Since version 4.0, this property is considered obsolete. Instead, use the BorderLeftWidth, BorderTopWidth, BorderRightWidth and BorderBottomWidth properties.

Brush

Gets or sets the brush used to fill the interior of elements.

FillColor

Gets or sets the color used to fill calendar elements.

Font

Gets or sets the font used to display an element's text.

HeaderBorderBottomColor

Gets or sets the color used to paint the bottom border of an element's header.

HeaderBorderBottomWidth

Gets or sets the width in pixels of the bottom border of an element's header.

HeaderBorderColorDark

Gets or sets the color used to paint the dark sides of the outermost 3D border of an element's header.

Since version 4.0, this property is considered obsolete. Instead, use the HeaderBorderRightColor and HeaderBorderBottomColor properties.

HeaderBorderColorLight

Gets or sets the color used to paint the light sides of the outermost 3D border of an element's header.

Since version 4.0, this property is considered obsolete. Instead, use the HeaderBorderLeftColor and HeaderBorderTopColor properties.

HeaderBorderLeftColor

Gets or sets the color used to paint the left border of an element's header.

HeaderBorderLeftWidth

Gets or sets the width in pixels of the left border of an element's header.

HeaderBorderRightColor

Gets or sets the color used to paint the right border of an element's header.

HeaderBorderRightWidth

Gets or sets the width in pixels of the right border of an element's header.

HeaderBorderTopColor

Gets or sets the color used to paint the top border of an element's header.

HeaderBorderTopWidth

Gets or sets the width in pixels of the top border of an element's header.

HeaderBorderWidth

Gets or sets the width in pixels of the outermost border of an element's header.

Since version 4.0, this property is considered obsolete. Instead, use the HeaderBorderLeftWidth, HeaderBorderTopWidth, HeaderBorderRightWidth and HeaderBorderBottomWidth properties.

HeaderBrush

Gets or sets the brush used to fill the interior of an element's header.

HeaderFont

Gets or sets the font used to paint the text of an element's header.

HeaderTextAlignment

Gets or sets the alignment of the headers' text.

HeaderTextBottomMargin

Gets or sets the bottom header text margin.

HeaderTextColor

Gets or sets the color used to paint the text of an element's header.

HeaderTextLeftMargin

Gets or sets the left header text margin.

HeaderTextRightMargin

Gets or sets the right header text margin.

HeaderTextShadowColor

Gets or sets the color of the shadow cast by the header text.

HeaderTextShadowOffset

Gets or sets the distance of the shadow from the header text that casts it.

HeaderTextShadowStyle

Gets or sets the type of the shadow cast by the header text.

HeaderTextTopMargin

Gets or sets the top header text margin.

Image

Gets or sets an image associated with this style.

ImageAlignment

Gets or sets the image alignment to be used when rendering the image assigned to this style.

ImageIndex

Gets or sets the index of the image from the calendar image list assigned to this style.

LineColor

Gets or sets the color used to paint various lines that are not part of element borders.

TextAlignment

Gets or sets the alignment of the text contents of a calendar element.

TextBottomMargin

Gets or sets the bottom text margin.

TextColor

Gets or sets the color used to paint an element's text.

TextLeftMargin

Gets or sets the left text margin.

TextRightMargin

Gets or sets the right text margin.

TextShadowColor

Gets or sets the color of the shadow cast by the text.

TextShadowOffset

Gets or sets the distance of the shadow from the text that casts it.

TextShadowStyle

Gets or sets the type of the shadow cast by the text.

TextTopMargin

Gets or sets the top text margin.

See Also

Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.BorderBottomColor Property

Style.BorderBottomColor Property

Gets or sets the color used to paint the bottom border of a calendar element.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color BorderBottomColor { get; set; }
Visual Basic

Public Property BorderBottomColor As Color

Property Value

A .NET Color object specifying the color of the bottom border lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no bottom border or set the BorderBottomWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderBottomWidth Property


MindFusion.Scheduling.Style.BorderBottomWidth Property

Style.BorderBottomWidth Property

Gets or sets the width in pixels of the bottom border of an element.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int BorderBottomWidth { get; set; }
Visual Basic

Public Property BorderBottomWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the bottom border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderBottomColor Property


MindFusion.Scheduling.Style.BorderColorDark Property

Style.BorderColorDark Property

Gets or sets the color used to paint the dark sides of the outermost 3D border of a calendar element.

Since version 4.0, this property is considered obsolete. Instead, use the BorderRightColor and BorderBottomColor properties.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color BorderColorDark { get; set; }
Visual Basic

Public Property BorderColorDark As Color

Property Value

A .NET Color object specifying the color of the right and bottom border lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderColorLight Property
BorderWidth Property


MindFusion.Scheduling.Style.BorderColorLight Property

Style.BorderColorLight Property

Gets or sets the color used to paint the light sides of the outermost 3D border of a calendar element.

Since version 4.0, this property is considered obsolete. Instead, use the BorderLeftColor and BorderTopColor properties.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color BorderColorLight { get; set; }
Visual Basic

Public Property BorderColorLight As Color

Property Value

A .NET Color object specifying the color of the top and left border lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the BorderWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderColorDark Property
BorderWidth Property


MindFusion.Scheduling.Style.BorderLeftColor Property

Style.BorderLeftColor Property

Gets or sets the color used to paint the left border of a calendar element.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color BorderLeftColor { get; set; }
Visual Basic

Public Property BorderLeftColor As Color

Property Value

A .NET Color object specifying the color left border lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no left border or set the BorderLeftWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderLeftWidth Property


MindFusion.Scheduling.Style.BorderLeftWidth Property

Style.BorderLeftWidth Property

Gets or sets the width in pixels of the left border of an element.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int BorderLeftWidth { get; set; }
Visual Basic

Public Property BorderLeftWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the left border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderLeftColor Property


MindFusion.Scheduling.Style.BorderRightColor Property

Style.BorderRightColor Property

Gets or sets the color used to paint the right border of a calendar element.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color BorderRightColor { get; set; }
Visual Basic

Public Property BorderRightColor As Color

Property Value

A .NET Color object specifying the color of the right border lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no right border or set the BorderRightWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderRightWidth Property


MindFusion.Scheduling.Style.BorderRightWidth Property

Style.BorderRightWidth Property

Gets or sets the width in pixels of the right border of an element.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int BorderRightWidth { get; set; }
Visual Basic

Public Property BorderRightWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the right border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderRightColor Property


MindFusion.Scheduling.Style.BorderTopColor Property

Style.BorderTopColor Property

Gets or sets the color used to paint the top border of a calendar element.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color BorderTopColor { get; set; }
Visual Basic

Public Property BorderTopColor As Color

Property Value

A .NET Color object specifying the color of the top border lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no top border or set the BorderTopWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderTopWidth Property


MindFusion.Scheduling.Style.BorderTopWidth Property

Style.BorderTopWidth Property

Gets or sets the width in pixels of the top border of an element.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int BorderTopWidth { get; set; }
Visual Basic

Public Property BorderTopWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the top border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderTopColor Property


MindFusion.Scheduling.Style.BorderWidth Property

Style.BorderWidth Property

Gets or sets the width in pixels of the outermost border of an element.

Since version 4.0, this property is considered obsolete. Instead, use the BorderLeftWidth, BorderTopWidth, BorderRightWidth and BorderBottomWidth properties.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int BorderWidth { get; set; }
Visual Basic

Public Property BorderWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the borders, set this property to 0. Alternatively, you can set both BorderColorLight and BorderColorDark to Color.Transparent.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
BorderColorLight Property
BorderColorDark Property


MindFusion.Scheduling.Style.Brush Property

Style.Brush Property

Gets or sets the brush used to fill the interior of elements.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Brush Brush { get; set; }
Visual Basic

Public Property Brush As Brush

Property Value

A Brush instance used to fill the interior of calendar UI elements. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.FillColor Property

Style.FillColor Property

Gets or sets the color used to fill calendar elements.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color FillColor { get; set; }
Visual Basic

Public Property FillColor As Color

Property Value

A .NET Color object used to fill calendar elements. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
LineColor Property


MindFusion.Scheduling.Style.Font Property

Style.Font Property

Gets or sets the font used to display an element's text.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Font Font { get; set; }
Visual Basic

Public Property Font As Font

Property Value

A .NET Font object specifying the font of calendar elements' text. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextAlignment Property
TextColor Property


MindFusion.Scheduling.Style.HeaderBorderBottomColor Property

Style.HeaderBorderBottomColor Property

Gets or sets the color used to paint the bottom border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color HeaderBorderBottomColor { get; set; }
Visual Basic

Public Property HeaderBorderBottomColor As Color

Property Value

A .NET Color object specifying the color of the bottom side of the header's rectangle. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the HeaderBorderBottomWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderBottomWidth Property


MindFusion.Scheduling.Style.HeaderBorderBottomWidth Property

Style.HeaderBorderBottomWidth Property

Gets or sets the width in pixels of the bottom border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int HeaderBorderBottomWidth { get; set; }
Visual Basic

Public Property HeaderBorderBottomWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the bottom border of the header, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderBottomColor Property


MindFusion.Scheduling.Style.HeaderBorderColorDark Property

Style.HeaderBorderColorDark Property

Gets or sets the color used to paint the dark sides of the outermost 3D border of an element's header.

Since version 4.0, this property is considered obsolete. Instead, use the HeaderBorderRightColor and HeaderBorderBottomColor properties.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color HeaderBorderColorDark { get; set; }
Visual Basic

Public Property HeaderBorderColorDark As Color

Property Value

A .NET Color object specifying the color of the right and bottom sides of header's rectangle. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the HeaderBorderWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderColorLight Property
HeaderBorderWidth Property


MindFusion.Scheduling.Style.HeaderBorderColorLight Property

Style.HeaderBorderColorLight Property

Gets or sets the color used to paint the light sides of the outermost 3D border of an element's header.

Since version 4.0, this property is considered obsolete. Instead, use the HeaderBorderLeftColor and HeaderBorderTopColor properties.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color HeaderBorderColorLight { get; set; }
Visual Basic

Public Property HeaderBorderColorLight As Color

Property Value

A .NET Color object specifying the color of the top and left sides of header's rectangle. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the HeaderBorderWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderColorDark Property
HeaderBorderWidth Property


MindFusion.Scheduling.Style.HeaderBorderLeftColor Property

Style.HeaderBorderLeftColor Property

Gets or sets the color used to paint the left border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color HeaderBorderLeftColor { get; set; }
Visual Basic

Public Property HeaderBorderLeftColor As Color

Property Value

A .NET Color object specifying the color of the left side of the header's rectangle. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the HeaderBorderLeftWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderLeftWidth Property


MindFusion.Scheduling.Style.HeaderBorderLeftWidth Property

Style.HeaderBorderLeftWidth Property

Gets or sets the width in pixels of the left border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int HeaderBorderLeftWidth { get; set; }
Visual Basic

Public Property HeaderBorderLeftWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the left border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderLeftColor Property


MindFusion.Scheduling.Style.HeaderBorderRightColor Property

Style.HeaderBorderRightColor Property

Gets or sets the color used to paint the right border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color HeaderBorderRightColor { get; set; }
Visual Basic

Public Property HeaderBorderRightColor As Color

Property Value

A .NET Color object specifying the color of the right side of the header's rectangle. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the HeaderBorderRightWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderRightWidth Property


MindFusion.Scheduling.Style.HeaderBorderRightWidth Property

Style.HeaderBorderRightWidth Property

Gets or sets the width in pixels of the right border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int HeaderBorderRightWidth { get; set; }
Visual Basic

Public Property HeaderBorderRightWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the right border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderRightColor Property


MindFusion.Scheduling.Style.HeaderBorderTopColor Property

Style.HeaderBorderTopColor Property

Gets or sets the color used to paint the top border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color HeaderBorderTopColor { get; set; }
Visual Basic

Public Property HeaderBorderTopColor As Color

Property Value

A .NET Color object specifying the color of the top side of the header's rectangle. Assign Color.Empty to this property to use the corresponding value from the current theme.

Remarks

Specify Color.Transparent for no border or set the HeaderBorderTopWidth to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderTopWidth Property


MindFusion.Scheduling.Style.HeaderBorderTopWidth Property

Style.HeaderBorderTopWidth Property

Gets or sets the width in pixels of the top border of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int HeaderBorderTopWidth { get; set; }
Visual Basic

Public Property HeaderBorderTopWidth As Integer

Property Value

A non-negative integer specifying the border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing the top border, set this property to 0.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderTopColor Property


MindFusion.Scheduling.Style.HeaderBorderWidth Property

Style.HeaderBorderWidth Property

Gets or sets the width in pixels of the outermost border of an element's header.

Since version 4.0, this property is considered obsolete. Instead, use the HeaderBorderLeftWidth, HeaderBorderTopWidth, HeaderBorderRightWidth and HeaderBorderBottomWidth properties.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int HeaderBorderWidth { get; set; }
Visual Basic

Public Property HeaderBorderWidth As Integer

Property Value

A non-negative integer specifying headers' border width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To disable drawing header borders, set this property to 0. Alternatively, you can set both HeaderBorderColorLight and HeaderBorderColorDark to Color.Transparent.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderBorderColorLight Property
HeaderBorderColorDark Property


MindFusion.Scheduling.Style.HeaderBrush Property

Style.HeaderBrush Property

Gets or sets the brush used to fill the interior of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Brush HeaderBrush { get; set; }
Visual Basic

Public Property HeaderBrush As Brush

Property Value

A Brush object used to fill header interior. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.HeaderFont Property

Style.HeaderFont Property

Gets or sets the font used to paint the text of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Font HeaderFont { get; set; }
Visual Basic

Public Property HeaderFont As Font

Property Value

A .NET Font object specifying the font of text displayed in headers. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextAlignment Property
HeaderTextColor Property


MindFusion.Scheduling.Style.HeaderTextAlignment Property

Style.HeaderTextAlignment Property

Gets or sets the alignment of the headers' text.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TextAlignment HeaderTextAlignment { get; set; }
Visual Basic

Public Property HeaderTextAlignment As TextAlignment

Property Value

A member of the TextAlignment enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderFont Property
HeaderTextColor Property


MindFusion.Scheduling.Style.HeaderTextBottomMargin Property

Style.HeaderTextBottomMargin Property

Gets or sets the bottom header text margin.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int HeaderTextBottomMargin { get; set; }
Visual Basic

Public Property HeaderTextBottomMargin As Integer

Property Value

A non-negative integer specifying the bottom margin of header texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextLeftMargin Property
HeaderTextRightMargin Property
HeaderTextTopMargin Property


MindFusion.Scheduling.Style.HeaderTextColor Property

Style.HeaderTextColor Property

Gets or sets the color used to paint the text of an element's header.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color HeaderTextColor { get; set; }
Visual Basic

Public Property HeaderTextColor As Color

Property Value

A .NET Color object specifying the color of text displayed in headers. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderFont Property
HeaderTextAlignment Property


MindFusion.Scheduling.Style.HeaderTextLeftMargin Property

Style.HeaderTextLeftMargin Property

Gets or sets the left header text margin.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int HeaderTextLeftMargin { get; set; }
Visual Basic

Public Property HeaderTextLeftMargin As Integer

Property Value

A non-negative integer specifying the left margin of header texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextBottomMargin Property
HeaderTextRightMargin Property
HeaderTextTopMargin Property


MindFusion.Scheduling.Style.HeaderTextRightMargin Property

Style.HeaderTextRightMargin Property

Gets or sets the right header text margin.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int HeaderTextRightMargin { get; set; }
Visual Basic

Public Property HeaderTextRightMargin As Integer

Property Value

A non-negative integer specifying the right margin of header texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextBottomMargin Property
HeaderTextLeftMargin Property
HeaderTextTopMargin Property


MindFusion.Scheduling.Style.HeaderTextShadowColor Property

Style.HeaderTextShadowColor Property

Gets or sets the color of the shadow cast by the header text.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color HeaderTextShadowColor { get; set; }
Visual Basic

Public Property HeaderTextShadowColor As Color

Property Value

A .NET Color object specifying the color of the header text shadows drawn with this style. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextShadowOffset Property
HeaderTextShadowStyle Property
TextShadowColor Property


MindFusion.Scheduling.Style.HeaderTextShadowOffset Property

Style.HeaderTextShadowOffset Property

Gets or sets the distance of the shadow from the header text that casts it.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int HeaderTextShadowOffset { get; set; }
Visual Basic

Public Property HeaderTextShadowOffset As Integer

Property Value

An integer value specifying the distance between the drawn shadow and the header text that casts it, expressed in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextShadowColor Property
HeaderTextShadowStyle Property
TextShadowOffset Property


MindFusion.Scheduling.Style.HeaderTextShadowStyle Property

Style.HeaderTextShadowStyle Property

Gets or sets the type of the shadow cast by the header text.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ShadowStyle HeaderTextShadowStyle { get; set; }
Visual Basic

Public Property HeaderTextShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextShadowColor Property
HeaderTextShadowOffset Property
TextShadowStyle Property


MindFusion.Scheduling.Style.HeaderTextTopMargin Property

Style.HeaderTextTopMargin Property

Gets or sets the top header text margin.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int HeaderTextTopMargin { get; set; }
Visual Basic

Public Property HeaderTextTopMargin As Integer

Property Value

A non-negative integer specifying the top margin of header texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
HeaderTextBottomMargin Property
HeaderTextLeftMargin Property
HeaderTextRightMargin Property


MindFusion.Scheduling.Style.Image Property

Style.Image Property

Gets or sets an image associated with this style.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Image Image { get; set; }
Visual Basic

Public Property Image As Image

Property Value

A .NET Image object. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

This image takes precedence over the image associated with an item through an image list / image index pair.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
ImageAlignment Property
ImageIndex Property
ImageTransparency Property


MindFusion.Scheduling.Style.ImageAlignment Property

Style.ImageAlignment Property

Gets or sets the image alignment to be used when rendering the image assigned to this style.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ImageAlignment ImageAlignment { get; set; }
Visual Basic

Public Property ImageAlignment As ImageAlignment

Property Value

A member of the ImageAlignment enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
Image Property
ImageIndex Property
ImageTransparency Property


MindFusion.Scheduling.Style.ImageIndex Property

Style.ImageIndex Property

Gets or sets the index of the image from the calendar image list assigned to this style.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int ImageIndex { get; set; }
Visual Basic

Public Property ImageIndex As Integer

Property Value

An integer value specifying the image index. Assign -2 to this property to use the corresponding value from the current theme.

Remarks

If there is an Image assigned to this style, it takes precedence over the image identified by this index.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
Image Property
ImageAlignment Property
ImageTransparency Property


MindFusion.Scheduling.Style.LineColor Property

Style.LineColor Property

Gets or sets the color used to paint various lines that are not part of element borders.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color LineColor { get; set; }
Visual Basic

Public Property LineColor As Color

Property Value

A .NET Color object specifying the color of lines. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
FillColor Property


MindFusion.Scheduling.Style.TextAlignment Property

Style.TextAlignment Property

Gets or sets the alignment of the text contents of a calendar element.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TextAlignment TextAlignment { get; set; }
Visual Basic

Public Property TextAlignment As TextAlignment

Property Value

A member of the TextAlignment enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
Font Property
TextColor Property


MindFusion.Scheduling.Style.TextBottomMargin Property

Style.TextBottomMargin Property

Gets or sets the bottom text margin.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int TextBottomMargin { get; set; }
Visual Basic

Public Property TextBottomMargin As Integer

Property Value

A non-negative integer specifying the bottom margin of texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextLeftMargin Property
TextRightMargin Property
TextTopMargin Property


MindFusion.Scheduling.Style.TextColor Property

Style.TextColor Property

Gets or sets the color used to paint an element's text.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color TextColor { get; set; }
Visual Basic

Public Property TextColor As Color

Property Value

A .NET Color object specifying the text color. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
Font Property
TextAlignment Property


MindFusion.Scheduling.Style.TextLeftMargin Property

Style.TextLeftMargin Property

Gets or sets the left text margin.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int TextLeftMargin { get; set; }
Visual Basic

Public Property TextLeftMargin As Integer

Property Value

A non-negative integer specifying the left margin of texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextBottomMargin Property
TextRightMargin Property
TextTopMargin Property


MindFusion.Scheduling.Style.TextRightMargin Property

Style.TextRightMargin Property

Gets or sets the right text margin.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int TextRightMargin { get; set; }
Visual Basic

Public Property TextRightMargin As Integer

Property Value

A non-negative integer specifying the right margin of texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextBottomMargin Property
TextLeftMargin Property
TextTopMargin Property


MindFusion.Scheduling.Style.TextShadowColor Property

Style.TextShadowColor Property

Gets or sets the color of the shadow cast by the text.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color TextShadowColor { get; set; }
Visual Basic

Public Property TextShadowColor As Color

Property Value

A .NET Color object specifying the color of the text shadows drawn with this style. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextShadowOffset Property
TextShadowStyle Property
HeaderTextShadowColor Property


MindFusion.Scheduling.Style.TextShadowOffset Property

Style.TextShadowOffset Property

Gets or sets the distance of the shadow from the text that casts it.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int TextShadowOffset { get; set; }
Visual Basic

Public Property TextShadowOffset As Integer

Property Value

An integer value specifying the distance between the drawn shadow and the text that casts it, expressed in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextShadowColor Property
TextShadowStyle Property
HeaderTextShadowOffset Property


MindFusion.Scheduling.Style.TextShadowStyle Property

Style.TextShadowStyle Property

Gets or sets the type of the shadow cast by the text.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ShadowStyle TextShadowStyle { get; set; }
Visual Basic

Public Property TextShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextShadowColor Property
TextShadowOffset Property
HeaderTextShadowStyle Property


MindFusion.Scheduling.Style.TextTopMargin Property

Style.TextTopMargin Property

Gets or sets the top text margin.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int TextTopMargin { get; set; }
Visual Basic

Public Property TextTopMargin As Integer

Property Value

A non-negative integer specifying the top margin of texts drawn with this style. Assign -1 to this property to use the corresponding value from the current theme.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace
TextBottomMargin Property
TextLeftMargin Property
TextRightMargin Property


MindFusion.Scheduling.Style Events

Style Events

Public Events

Name | Description
Changed | Raised when the style changes.

See Also

Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Style.Changed Event

Style.Changed Event

Raised when the style changes.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public EventHandler Changed
Visual Basic

Public Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

Style Members
Style Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Class

Task Class

Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class Task : Resource
Visual Basic

Public Class Task
Inherits Resource

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Resource
MindFusion.Scheduling.Task

See Also

Task Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Members

Task Members
Constructors Properties Methods

Instances of this class contain task information. Task objects are used by schedule items that are allocated to some task.

The following tables list the members exposed by the Task type.

Public Constructors

Name | Description
Task | Initializes a new instance of the Task class.

Public Properties

Name | Description
ActualCost | Gets or sets the actual cost of this task.
ActualDuration | Gets or sets the task actual duration measured in minutes.
ActualEnd | Gets or sets the task's actual completion date.
ActualStart | Gets or sets the task's actual start date.
Details | Gets or sets the detailed description of this task.
DueDate | Gets or sets the task's due date.
EstimatedCost | Gets or sets the estimated cost of this task.
EstimatedDuration | Gets or sets the estimated duration of this task.
ImageIndex | Gets or sets the index of the image associated with this task.
Priority | Gets or sets the task priority.
Progress | Gets or sets the task progress measured in percents.
Reminder | Gets or sets the reminder for this task.
StartDate | Gets or sets the task's start date.
Status | Gets or sets the status of this task.
Subject | Gets or sets the subject of this task.

Public Methods

Name | Description
LoadFrom | Overloaded. Loads task data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the task data to a binary stream or an XML document.

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Constructor

Task Constructor

Initializes a new instance of the Task class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Task ()
Visual Basic

Public Sub New ()

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task Methods

Task Methods

Public Methods

Name | Description
LoadFrom | Overloaded. Loads task data from a binary stream or an XML document.
SaveTo | Overloaded. Saves the task data to a binary stream or an XML document.

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.LoadFrom Method

Task.LoadFrom Method

Loads task data from a binary stream or an XML document.

Overload List

Name | Description
Task.LoadFrom (XmlElement, XmlSerializationContext) | Loads task data from an XML document.
Task.LoadFrom (XmlReader, SerializationContext) | Loads task data from an XML document. Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.LoadFrom Method (XmlElement, XmlSerializationContext)

Task.LoadFrom Method (XmlElement, XmlSerializationContext)
See Also

Loads task data from an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void LoadFrom (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method loads the task properties from an XML document where they were previously saved by SaveTo.

See Also

LoadFrom Method Overload List
Task Members
Task Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Task.LoadFrom Method (XmlReader, SerializationContext)

Task.LoadFrom Method (XmlReader, SerializationContext)
See Also

Loads task data from an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the LoadFrom method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void LoadFrom (
XmlReader reader,
SerializationContext context
)
Visual Basic

Public Overrides Sub LoadFrom ( _
reader As XmlReader, _
context As SerializationContext _
)

Parameters

reader
Allows reading data from the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also allows getting locations, contacts and tasks by their string identifiers.

Remarks

This method loads the task properties from an XML document where they were previously saved by SaveTo.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
SaveTo Method


MindFusion.Scheduling.Task.SaveTo Method

Task.SaveTo Method

Saves the task data to a binary stream or an XML document.

Overload List

Name | Description
Task.SaveTo (XmlElement, XmlSerializationContext) | Saves the task data to an XML document.
Task.SaveTo (XmlWriter, SerializationContext) | Saves the task data to an XML document. Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.SaveTo Method (XmlElement, XmlSerializationContext)

Task.SaveTo Method (XmlElement, XmlSerializationContext)
See Also

Saves the task data to an XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void SaveTo (
XmlElement element,
XmlSerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
element As XmlElement, _
context As XmlSerializationContext _
)

Parameters

element
Allows adding data to the XML document.
context
The context object contains the file format revision number of the schedule being loaded. It also provides methods that facilitate reading and writing various data types from and to the XML document.

Remarks

This method saves the task properties as elements in an XML document. Later they can be restored via the LoadFrom method.

See Also

SaveTo Method Overload List
Task Members
Task Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Task.SaveTo Method (XmlWriter, SerializationContext)

Task.SaveTo Method (XmlWriter, SerializationContext)
See Also

Saves the task data to an XML document.

Since version 4.4, this method is considered obsolete. Instead, use the SaveTo method.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public override void SaveTo (
XmlWriter writer,
SerializationContext context
)
Visual Basic

Public Overrides Sub SaveTo ( _
writer As XmlWriter, _
context As SerializationContext _
)

Parameters

writer
Allows adding data to the XML document.
context
The context object contains the current revision number of the schedule file format.

Remarks

This method saves the task properties as elements in an XML document. Later they can be restored via the LoadFrom method.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
LoadFrom Method


MindFusion.Scheduling.Task Properties

Task Properties

Public Properties

Name | Description
ActualCost | Gets or sets the actual cost of this task.
ActualDuration | Gets or sets the task actual duration measured in minutes.
ActualEnd | Gets or sets the task's actual completion date.
ActualStart | Gets or sets the task's actual start date.
Details | Gets or sets the detailed description of this task.
DueDate | Gets or sets the task's due date.
EstimatedCost | Gets or sets the estimated cost of this task.
EstimatedDuration | Gets or sets the estimated duration of this task.
ImageIndex | Gets or sets the index of the image associated with this task.
Priority | Gets or sets the task priority.
Progress | Gets or sets the task progress measured in percents.
Reminder | Gets or sets the reminder for this task.
StartDate | Gets or sets the task's start date.
Status | Gets or sets the status of this task.
Subject | Gets or sets the subject of this task.

See Also

Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualCost Property

Task.ActualCost Property

Gets or sets the actual cost of this task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public float ActualCost { get; set; }
Visual Basic

Public Property ActualCost As Single

Property Value

A float value specifying the task's actual cost. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualDuration Property

Task.ActualDuration Property

Gets or sets the task actual duration measured in minutes.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int ActualDuration { get; set; }
Visual Basic

Public Property ActualDuration As Integer

Property Value

An integer value specifying the task's duration. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ActualEnd Property

Task.ActualEnd Property

Gets or sets the task's actual completion date.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime ActualEnd { get; set; }
Visual Basic

Public Property ActualEnd As DateTime

Property Value

A .NET DateTime object specifying the task's actual end date. The default is DateTime.MaxValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
ActualStart Property


MindFusion.Scheduling.Task.ActualStart Property

Task.ActualStart Property

Gets or sets the task's actual start date.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime ActualStart { get; set; }
Visual Basic

Public Property ActualStart As DateTime

Property Value

A .NET DateTime object specifying the task's actual start date. The default is DateTime.MinValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
ActualEnd Property


MindFusion.Scheduling.Task.Details Property

Task.Details Property

Gets or sets the detailed description of this task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Details { get; set; }
Visual Basic

Public Property Details As String

Property Value

A string containing the task's details text. The default is an empty string.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.DueDate Property

Task.DueDate Property

Gets or sets the task's due date.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime DueDate { get; set; }
Visual Basic

Public Property DueDate As DateTime

Property Value

A .NET DateTime object specifying the task's sue date. The default is DateTime.MaxValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
StartDate Property


MindFusion.Scheduling.Task.EstimatedCost Property

Task.EstimatedCost Property

Gets or sets the estimated cost of this task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public float EstimatedCost { get; set; }
Visual Basic

Public Property EstimatedCost As Single

Property Value

A float value specifying the task's estimated cost. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.EstimatedDuration Property

Task.EstimatedDuration Property

Gets or sets the estimated duration of this task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int EstimatedDuration { get; set; }
Visual Basic

Public Property EstimatedDuration As Integer

Property Value

An integer value specifying the task's scheduled duration. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.ImageIndex Property

Task.ImageIndex Property

Gets or sets the index of the image associated with this task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int ImageIndex { get; set; }
Visual Basic

Public Property ImageIndex As Integer

Property Value

An integer value specifying the index of the task image within the calendar's ImageList. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Priority Property

Task.Priority Property

Gets or sets the task priority.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TaskPriority Priority { get; set; }
Visual Basic

Public Property Priority As TaskPriority

Property Value

A member of the TaskPriority enumeration. The default is Normal.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Progress Property

Task.Progress Property

Gets or sets the task progress measured in percents.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public float Progress { get; set; }
Visual Basic

Public Property Progress As Single

Property Value

A float value specifying the progress made on this task. The default is 0.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Reminder Property

Task.Reminder Property

Gets or sets the reminder for this task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Reminder Reminder { get; set; }
Visual Basic

Public Property Reminder As Reminder

Property Value

A Reminder instance specifying when the task should be reminded of. The default is null (Nothing in Visual Basic).

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.StartDate Property

Task.StartDate Property

Gets or sets the task's start date.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime StartDate { get; set; }
Visual Basic

Public Property StartDate As DateTime

Property Value

A .NET DateTime object specifying the task's scheduled start time. The default is DateTime.MinValue.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace
DueDate Property


MindFusion.Scheduling.Task.Status Property

Task.Status Property

Gets or sets the status of this task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TaskStatus Status { get; set; }
Visual Basic

Public Property Status As TaskStatus

Property Value

A member of the TaskStatus enumeration. The default is NotStarted.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.Task.Subject Property

Task.Subject Property

Gets or sets the subject of this task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string Subject { get; set; }
Visual Basic

Public Property Subject As String

Property Value

A string containing the task subject text. The default is an empty string.

See Also

Task Members
Task Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Class

TaskCollection Class

Represents a strongly-typed collection of Task objects.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public sealed class TaskCollection : CollectionBase
Visual Basic

Public NotInheritable Class TaskCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.TaskCollection

See Also

TaskCollection Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Members

TaskCollection Members
Constructors Properties Methods Events

Represents a strongly-typed collection of Task objects.

The following tables list the members exposed by the TaskCollection type.

Public Constructors

Name | Description
TaskCollection | Initializes a new instance of the TaskCollection class.

Public Properties

Name | Description
Item | Gets a Task object from the collection given its zero-based index or identifier.

Public Methods

Name | Description
Add | Adds the specified task to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified task.
Insert | Inserts a location object into the collection at the specified index.
Remove | Removes the first occurrence of the specified Task object from this collection.

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Constructor

TaskCollection Constructor

Initializes a new instance of the TaskCollection class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public TaskCollection ()
Visual Basic

Public Sub New ()

See Also

TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Methods

TaskCollection Methods

Public Methods

Name | Description
Add | Adds the specified task to this collection.
Clear | Removes all elements from the collection.
Contains | Overloaded. Determines whether this collection contains the specified task.
Insert | Inserts a location object into the collection at the specified index.
Remove | Removes the first occurrence of the specified Task object from this collection.

See Also

TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Add Method

TaskCollection.Add Method

Adds the specified task to this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Add (
Task task
)
Visual Basic

Public Sub Add ( _
task As Task _
)

Parameters

task
An instance of the Task class to be added to the collection.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace
Insert Method


MindFusion.Scheduling.TaskCollection.Clear Method

TaskCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Contains Method

TaskCollection.Contains Method

Determines whether this collection contains the specified task.

Overload List

Name | Description
TaskCollection.Contains (String) | Determines whether this collection contains a task identified by the specified string.
TaskCollection.Contains (Task) | Determines whether this collection contains the specified task.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Contains Method (String)

TaskCollection.Contains Method (String)
See Also

Determines whether this collection contains a task identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
string taskId
)
Visual Basic

Public Function Contains ( _
taskId As String _
) As Boolean

Parameters

taskId
The identifier of a task to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Contains Method (Task)

TaskCollection.Contains Method (Task)
See Also

Determines whether this collection contains the specified task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
Task task
)
Visual Basic

Public Function Contains ( _
task As Task _
) As Boolean

Parameters

task
The Task object to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

Contains Method Overload List
TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Insert Method

TaskCollection.Insert Method

Inserts a location object into the collection at the specified index.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Insert (
int index,
Task task
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
task As Task _
)

Parameters

index
The zero-based index at which the task must be inserted.
task
An instance of the Task class to be added to the collection.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace
Add Method


MindFusion.Scheduling.TaskCollection.Remove Method

TaskCollection.Remove Method

Removes the first occurrence of the specified Task object from this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public void Remove (
Task task
)
Visual Basic

Public Sub Remove ( _
task As Task _
)

Parameters

task
A Task instance which must be removed from the collection.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Properties

TaskCollection Properties

Public Properties

Name | Description
Item | Gets a Task object from the collection given its zero-based index or identifier.

See Also

TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Item Property

TaskCollection.Item Property

Gets a Task object from the collection given its zero-based index or identifier.

Overload List

Name | Description
TaskCollection.Item (Int32) | Gets or sets the task object located at the specified position within this collection.
TaskCollection.Item (String) | Gets the task object identified by the specified string.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Item Property (Int32)

TaskCollection.Item Property (Int32)
See Also

Gets or sets the task object located at the specified position within this collection.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Task Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As Task

Parameters

index
The zero-based index of the Task to set or retrieve.

Property Value

A reference to the task at the specified position.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their integer indices.

See Also

Item Property Overload List
TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Item Property (String)

TaskCollection.Item Property (String)
See Also

Gets the task object identified by the specified string.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Task Item [
string id
] { get; }
Visual Basic

Public ReadOnly Property Item ( _
id As String _
) As Task

Parameters

id
The Id of the Task to get.

Property Value

The Task instance identified by the specified string.

Remarks

This indexer property enables using the C# [] operator or the VB.NET () operator to access the elements of the collection by their string identifiers.

See Also

Item Property Overload List
TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection Events

TaskCollection Events

Public Events

Name | Description
Changed | Raised when the collection has been changed.

See Also

TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskCollection.Changed Event

TaskCollection.Changed Event

Raised when the collection has been changed.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public EventHandler Changed
Visual Basic

Public Changed As EventHandler

Event Data

Changed event handlers receive an argument of type EventArgs.

See Also

TaskCollection Members
TaskCollection Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Class

TaskEventArgs Class

Contains the arguments passed to handlers of task related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public class TaskEventArgs : EventArgs
Visual Basic

Public Class TaskEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.TaskEventArgs

See Also

TaskEventArgs Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Members

TaskEventArgs Members
Properties

Contains the arguments passed to handlers of task related events raised by the Schedule class.

The following tables list the members exposed by the TaskEventArgs type.

Public Properties

Name | Description
Task | Gets the task related to the event.

See Also

TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs Properties

TaskEventArgs Properties

Public Properties

Name | Description
Task | Gets the task related to the event.

See Also

TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventArgs.Task Property

TaskEventArgs.Task Property

Gets the task related to the event.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Task Task { get; }
Visual Basic

Public ReadOnly Property Task As Task

Property Value

An instance of the Task class related to the raised event.

See Also

TaskEventArgs Members
TaskEventArgs Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskEventHandler Delegate

TaskEventHandler Delegate

Represents methods that will handle the task related events raised by the Schedule class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public delegate void TaskEventHandler (
Object sender,
TaskEventArgs e
)
Visual Basic

Public Delegate Sub TaskEventHandler ( _
sender As Object, _
e As TaskEventArgs _
)

Parameters

sender
The source of the event.
e
A TaskEventArgs that contains the event data.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskPriority Enumeration

TaskPriority Enumeration

Specifies the priority of a task.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum TaskPriority
Visual Basic

Public Enumeration TaskPriority

Members

Member name | Description
High | Indicates high task priority.
Low | Indicates low task priority.
Normal | Indicates normal task priority.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.TaskStatus Enumeration

TaskStatus Enumeration

Enumeration providing task status values.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum TaskStatus
Visual Basic

Public Enumeration TaskStatus

Members

Member name | Description
Completed | Indicates a completed task.
Deferred | Indicates a deferred task.
InProgress | Indicates a task in progress.
NotStarted | Indicates that the task has not started yet.
WaitingOther | Indicates a task that depends on another task.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Class

XmlSerializationContext Class

Contains methods that can help you serialize/deserialize PocketPlanner items to/from XML documents.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public sealed class XmlSerializationContext : SerializationContext
Visual Basic

Public NotInheritable Class XmlSerializationContext
Inherits SerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.SerializationContext
MindFusion.Scheduling.XmlSerializationContext

See Also

XmlSerializationContext Members
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Members

XmlSerializationContext Members
Constructors Properties Methods

Contains methods that can help you serialize/deserialize PocketPlanner items to/from XML documents.

The following tables list the members exposed by the XmlSerializationContext type.

Public Constructors

Name | Description
XmlSerializationContext | Overloaded. Initializes a new instance of the XmlSerializationContext class.

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node with the specified name to the specified parent node.
ReadBool | Overloaded. Reads a boolean value with the specified name.
ReadBrush | Reads a MindFusion.Drawing.Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadCustomBrushes | Reads a CustomBrushes object with the specified name.
ReadDateTime | Reads a DateTime object with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEnum | Reads an enum value with the specified name.
ReadFloat | Reads a float value with the specified name.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Reads a Font object with the specified name.
ReadHashtable | Reads a hashtable object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Reads an integer value with the specified name.
ReadLong | Reads a long value with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a MindFusion.Drawing.Pen object with the specified name.
ReadRecurrence | Reads a Recurrence object with the specified name.
ReadReminder | Reads a Reminder object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Reads a short value with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Reads a string value with the specified name.
ReadStyle | Reads a Style object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteCustomBrushes | Writes the specified CustomBrushes object.
WriteDateTime | Writes the specified DateTime object.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteLong | Writes a long value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WriteRecurrence | Writes the specified Recurrence object.
WriteReminder | Writes the specified Reminder object.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStyle | Writes the specified Style object.
WriteTag | Writes the specified tag of the specified object.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor

XmlSerializationContext Constructor

Initializes a new instance of the XmlSerializationContext class.

Overload List

Name | Description
XmlSerializationContext (Schedule, Int32, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.
XmlSerializationContext (Schedule, XmlDocument) | Initializes a new instance of the XmlSerializationContext class.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor (Schedule, Int32, XmlDocument)

XmlSerializationContext Constructor (Schedule, Int32, XmlDocument)
See Also

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlSerializationContext (
Schedule schedule,
int fileVersion,
XmlDocument document
)
Visual Basic

Public Sub XmlSerializationContext ( _
schedule As Schedule, _
fileVersion As Integer, _
document As XmlDocument _
)

Parameters

schedule
The Schedule this class will operate on.
fileVersion
The file version of the file being deserialized.
document
The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Constructor (Schedule, XmlDocument)

XmlSerializationContext Constructor (Schedule, XmlDocument)
See Also

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlSerializationContext (
Schedule schedule,
XmlDocument document
)
Visual Basic

Public Sub XmlSerializationContext ( _
schedule As Schedule, _
document As XmlDocument _
)

Parameters

schedule
The Schedule this class will operate on.
document
The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext Methods

XmlSerializationContext Methods

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node with the specified name to the specified parent node.
ReadBool | Overloaded. Reads a boolean value with the specified name.
ReadBrush | Reads a MindFusion.Drawing.Brush object with the specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadCustomBrushes | Reads a CustomBrushes object with the specified name.
ReadDateTime | Reads a DateTime object with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Reads a double value with the specified name.
ReadEnum | Reads an enum value with the specified name.
ReadFloat | Reads a float value with the specified name.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Reads a Font object with the specified name.
ReadHashtable | Reads a hashtable object with the specified name.
ReadImage | Reads an Image object with the specified name.
ReadInt | Reads an integer value with the specified name.
ReadLong | Reads a long value with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Reads a MindFusion.Drawing.Pen object with the specified name.
ReadRecurrence | Reads a Recurrence object with the specified name.
ReadReminder | Reads a Reminder object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Reads a short value with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Reads a string value with the specified name.
ReadStyle | Reads a Style object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteCustomBrushes | Writes the specified CustomBrushes object.
WriteDateTime | Writes the specified DateTime object.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteLong | Writes a long value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WriteRecurrence | Writes the specified Recurrence object.
WriteReminder | Writes the specified Reminder object.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStyle | Writes the specified Style object.
WriteTag | Writes the specified tag of the specified object.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method

XmlSerializationContext.AddChildElement Method

Adds a new child node with the specified name to the specified parent node.

Overload List

Name | Description
XmlSerializationContext.AddChildElement (String, XmlElement) | Adds a new child node with the specified name to the specified parent node.
XmlSerializationContext.AddChildElement (String, XmlElement, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method (String, XmlElement)

XmlSerializationContext.AddChildElement Method (String, XmlElement)
See Also

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function AddChildElement ( _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

elementName
The desired name of the new node.
parentElement
The parent element of the newly created node.

Return Value

A .NET XmlElement object represneting the newly created element.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.AddChildElement Method (String, XmlElement, String)

XmlSerializationContext.AddChildElement Method (String, XmlElement, String)
See Also

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement AddChildElement (
string elementName,
XmlElement parentElement,
string innerText
)
Visual Basic

Public Function AddChildElement ( _
elementName As String, _
parentElement As XmlElement, _
innerText As String _
) As XmlElement

Parameters

elementName
The desired name of the new node.
parentElement
The parent element of the newly created node.
innerText
The desired value of the new node.

Return Value

A .NET XmlElement object represneting the newly created element.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method

XmlSerializationContext.ReadBool Method

Reads a boolean value with the specified name.

Overload List

Name | Description
XmlSerializationContext.ReadBool (String, XmlElement) | Reads a boolean value with the specified name.
XmlSerializationContext.ReadBool (String, XmlElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method (String, XmlElement)

XmlSerializationContext.ReadBool Method (String, XmlElement)
See Also

Reads a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool ReadBool (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadBool ( _
elementName As String, _
parentElement As XmlElement _
) As Boolean

Parameters

elementName
The name of the element containing the bool value.
parentElement
The parent element of the node with the specified name.

Return Value

A bool value. Returns false if there is no element with the specified name under the specified parent.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteBool Method


MindFusion.Scheduling.XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)

XmlSerializationContext.ReadBool Method (String, XmlElement, Boolean)
See Also

Reads a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public bool ReadBool (
string elementName,
XmlElement parentElement,
bool defaultValue
)
Visual Basic

Public Function ReadBool ( _
elementName As String, _
parentElement As XmlElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName
The name of the element containing the bool value.
parentElement
The parent element of the node with the specified name.
defaultValue
The value that should be returned if there is no node with the specified name under the specified parent element.

Return Value

A bool value.

Remarks

If there is no element with the specified name, returns the specified default value.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteBool Method


MindFusion.Scheduling.XmlSerializationContext.ReadBrush Method

XmlSerializationContext.ReadBrush Method

Reads a MindFusion.Drawing.Brush object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Brush ReadBrush (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadBrush ( _
elementName As String, _
parentElement As XmlElement _
) As Brush

Parameters

elementName
The name of the element containing the Brush object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the MindFusion.Drawing.Brush class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteBrush Method


MindFusion.Scheduling.XmlSerializationContext.ReadByte Method

XmlSerializationContext.ReadByte Method

Reads a byte value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public byte ReadByte (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadByte ( _
elementName As String, _
parentElement As XmlElement _
) As Byte

Parameters

elementName
The name of the element containing the byte value.
parentElement
The parent element of the node with the specified name.

Return Value

A byte value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteByte Method


MindFusion.Scheduling.XmlSerializationContext.ReadChar Method

XmlSerializationContext.ReadChar Method

Reads a char value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public char ReadChar (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadChar ( _
elementName As String, _
parentElement As XmlElement _
) As Char

Parameters

elementName
The name of the element containing the char value.
parentElement
The parent element of the node with the specified name.

Return Value

A char value. Returns 'a' if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteChar Method


MindFusion.Scheduling.XmlSerializationContext.ReadColor Method

XmlSerializationContext.ReadColor Method

Reads a color with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color ReadColor (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadColor ( _
elementName As String, _
parentElement As XmlElement _
) As Color

Parameters

elementName
The name of the element containing the .NET Color object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Color object. Returns Black if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteColor Method


MindFusion.Scheduling.XmlSerializationContext.ReadColorArray Method

XmlSerializationContext.ReadColorArray Method

Reads a color array with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Color[] ReadColorArray (
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadColorArray ( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Color()

Parameters

elementName
The name of the element containing the array.
subElementName
The name of the elements containing the individual array values.
parentElement
The parent element of the node with the specified name.

Return Value

An array of .NET Color objects. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteColorArray Method


MindFusion.Scheduling.XmlSerializationContext.ReadCustomBrushes Method

XmlSerializationContext.ReadCustomBrushes Method

Reads a CustomBrushes object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public CustomBrushes ReadCustomBrushes (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadCustomBrushes ( _
elementName As String, _
parentElement As XmlElement _
) As CustomBrushes

Parameters

elementName
The name of the element containing the CustomBrushes object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the CustomBrushes class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteCustomBrushes Method


MindFusion.Scheduling.XmlSerializationContext.ReadDateTime Method

XmlSerializationContext.ReadDateTime Method

Reads a DateTime object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public DateTime ReadDateTime (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadDateTime ( _
elementName As String, _
parentElement As XmlElement _
) As DateTime

Parameters

elementName
The name of the element containing the .NET DateTime object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET DateTime object. Returns DateTime.MinValue if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDateTime Method


MindFusion.Scheduling.XmlSerializationContext.ReadDecimal Method

XmlSerializationContext.ReadDecimal Method

Reads a decimal value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Decimal ReadDecimal (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadDecimal ( _
elementName As String, _
parentElement As XmlElement _
) As Decimal

Parameters

elementName
The name of the element containing the decimal value.
parentElement
The parent element of the node with the specified name.

Return Value

A decimal value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDecimal Method


MindFusion.Scheduling.XmlSerializationContext.ReadDouble Method

XmlSerializationContext.ReadDouble Method

Reads a double value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public double ReadDouble (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadDouble ( _
elementName As String, _
parentElement As XmlElement _
) As Double

Parameters

elementName
The name of the element containing the double value.
parentElement
The parent element of the node with the specified name.

Return Value

A double value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteDouble Method


MindFusion.Scheduling.XmlSerializationContext.ReadEnum Method

XmlSerializationContext.ReadEnum Method

Reads an enum value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Object ReadEnum (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadEnum ( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName
The name of the element containing the enum value.
parentElement
The parent element of the node with the specified name.

Return Value

An enum value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteEnum Method


MindFusion.Scheduling.XmlSerializationContext.ReadFloat Method

XmlSerializationContext.ReadFloat Method

Reads a float value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public float ReadFloat (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadFloat ( _
elementName As String, _
parentElement As XmlElement _
) As Single

Parameters

elementName
The name of the element containing the float value.
parentElement
The parent element of the node with the specified name.

Return Value

A float value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteFloat Method


MindFusion.Scheduling.XmlSerializationContext.ReadFloatArray Method

XmlSerializationContext.ReadFloatArray Method

Reads a float array with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public float[] ReadFloatArray (
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadFloatArray ( _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As Single()

Parameters

elementName
The name of the element containing the array.
subElementName
The name of the elements containing the individual array values.
parentElement
The parent element of the node with the specified name.

Return Value

An array of float values. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteFloatArray Method


MindFusion.Scheduling.XmlSerializationContext.ReadFont Method

XmlSerializationContext.ReadFont Method

Reads a Font object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Font ReadFont (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadFont ( _
elementName As String, _
parentElement As XmlElement _
) As Font

Parameters

elementName
The name of the element containing the .NET Font object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Font object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteFont Method


MindFusion.Scheduling.XmlSerializationContext.ReadHashtable Method

XmlSerializationContext.ReadHashtable Method

Reads a hashtable object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Hashtable ReadHashtable (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadHashtable ( _
elementName As String, _
parentElement As XmlElement _
) As Hashtable

Parameters

elementName
The name of the element containing the .NET Hashtable object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Hashtable object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteHashtable Method


MindFusion.Scheduling.XmlSerializationContext.ReadImage Method

XmlSerializationContext.ReadImage Method

Reads an Image object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Image ReadImage (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadImage ( _
elementName As String, _
parentElement As XmlElement _
) As Image

Parameters

elementName
The name of the element containing the .NET Image object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Image object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteImage Method


MindFusion.Scheduling.XmlSerializationContext.ReadInt Method

XmlSerializationContext.ReadInt Method

Reads an integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int ReadInt (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadInt ( _
elementName As String, _
parentElement As XmlElement _
) As Integer

Parameters

elementName
The name of the element containing the integer value.
parentElement
The parent element of the node with the specified name.

Return Value

An integer value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteInt Method


MindFusion.Scheduling.XmlSerializationContext.ReadLong Method

XmlSerializationContext.ReadLong Method

Reads a long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public long ReadLong (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadLong ( _
elementName As String, _
parentElement As XmlElement _
) As Long

Parameters

elementName
The name of the element containing the long value.
parentElement
The parent element of the node with the specified name.

Return Value

An long value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteLong Method


MindFusion.Scheduling.XmlSerializationContext.ReadObject Method

XmlSerializationContext.ReadObject Method

Reads an object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Object ReadObject (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadObject ( _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

elementName
The name of the element containing the object.
parentElement
The parent element of the node with the specified name.

Return Value

An object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent or if the object cannot be deserialized.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteObject Method


MindFusion.Scheduling.XmlSerializationContext.ReadPen Method

XmlSerializationContext.ReadPen Method

Reads a MindFusion.Drawing.Pen object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Pen ReadPen (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadPen ( _
elementName As String, _
parentElement As XmlElement _
) As Pen

Parameters

elementName
The name of the element containing the Pen object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the MindFusion.Drawing.Pen class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WritePen Method


MindFusion.Scheduling.XmlSerializationContext.ReadRecurrence Method

XmlSerializationContext.ReadRecurrence Method

Reads a Recurrence object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Recurrence ReadRecurrence (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadRecurrence ( _
elementName As String, _
parentElement As XmlElement _
) As Recurrence

Parameters

elementName
The name of the element containing the Recurrence object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the Recurrence class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteRecurrence Method


MindFusion.Scheduling.XmlSerializationContext.ReadReminder Method

XmlSerializationContext.ReadReminder Method

Reads a Reminder object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Reminder ReadReminder (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadReminder ( _
elementName As String, _
parentElement As XmlElement _
) As Reminder

Parameters

elementName
The name of the element containing the Reminder object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the Reminder class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteReminder Method


MindFusion.Scheduling.XmlSerializationContext.ReadSByte Method

XmlSerializationContext.ReadSByte Method

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public sbyte ReadSByte (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadSByte ( _
elementName As String, _
parentElement As XmlElement _
) As SByte

Parameters

elementName
The name of the element containing the signed byte value.
parentElement
The parent element of the node with the specified name.

Return Value

A signed byte value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteSByte Method


MindFusion.Scheduling.XmlSerializationContext.ReadShort Method

XmlSerializationContext.ReadShort Method

Reads a short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public short ReadShort (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadShort ( _
elementName As String, _
parentElement As XmlElement _
) As Short

Parameters

elementName
The name of the element containing the short value.
parentElement
The parent element of the node with the specified name.

Return Value

A short value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteShort Method


MindFusion.Scheduling.XmlSerializationContext.ReadStream Method

XmlSerializationContext.ReadStream Method

Reads a stream with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Stream ReadStream (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadStream ( _
elementName As String, _
parentElement As XmlElement _
) As Stream

Parameters

elementName
The name of the element containing the .NET Stream object.
parentElement
The parent element of the node with the specified name.

Return Value

A .NET Stream object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteStream Method


MindFusion.Scheduling.XmlSerializationContext.ReadString Method

XmlSerializationContext.ReadString Method

Reads a string value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public string ReadString (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadString ( _
elementName As String, _
parentElement As XmlElement _
) As String

Parameters

elementName
The name of the element containing the string value.
parentElement
The parent element of the node with the specified name.

Return Value

A string value. Returns an empty string if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteString Method


MindFusion.Scheduling.XmlSerializationContext.ReadStyle Method

XmlSerializationContext.ReadStyle Method

Reads a Style object with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Style ReadStyle (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadStyle ( _
elementName As String, _
parentElement As XmlElement _
) As Style

Parameters

elementName
The name of the element containing the Style object.
parentElement
The parent element of the node with the specified name.

Return Value

An instance of the Style class. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteStyle Method


MindFusion.Scheduling.XmlSerializationContext.ReadTag Method

XmlSerializationContext.ReadTag Method

Reads the specified tag for the specified object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public Object ReadTag (
Object item,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadTag ( _
item As Object, _
elementName As String, _
parentElement As XmlElement _
) As Object

Parameters

item
The Item whose tag is being deserialized.
elementName
The name of the element containing the tag object.
parentElement
The parent element of the node with the specified name.

Return Value

An object. Returns null (Nothing in Visual Basic) if there is no element with the specified name under the specified parent or if the tag cannot be deserialized.

Remarks

This method raises the DeserializeTag event of the underlying schedule, giving clients a chance to perform custom deserialization. If the event is not handled, the system attempts to deserialize the tag as an arbitrary object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteTag Method
Schedule.DeserializeTag Event


MindFusion.Scheduling.XmlSerializationContext.ReadUInt Method

XmlSerializationContext.ReadUInt Method

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public uint ReadUInt (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadUInt ( _
elementName As String, _
parentElement As XmlElement _
) As UInteger

Parameters

elementName
The name of the element containing the unsigned integer value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned integer value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteUInt Method


MindFusion.Scheduling.XmlSerializationContext.ReadULong Method

XmlSerializationContext.ReadULong Method

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ulong ReadULong (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadULong ( _
elementName As String, _
parentElement As XmlElement _
) As ULong

Parameters

elementName
The name of the element containing the unsigned long value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned long value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
WriteULong Method


MindFusion.Scheduling.XmlSerializationContext.ReadUShort Method

XmlSerializationContext.ReadUShort Method

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public ushort ReadUShort (
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function ReadUShort ( _
elementName As String, _
parentElement As XmlElement _
) As UShort

Parameters

elementName
The name of the element containing the unsigned short value.
parentElement
The parent element of the node with the specified name.

Return Value

An unsigned short value. Returns 0 if there is no element with the specified name under the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.WriteBool Method

XmlSerializationContext.WriteBool Method

Writes a boolean value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteBool (
bool boolValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteBool ( _
boolValue As Boolean, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

boolValue
The bool value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadBool Method


MindFusion.Scheduling.XmlSerializationContext.WriteBrush Method

XmlSerializationContext.WriteBrush Method

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteBrush (
Brush brush,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteBrush ( _
brush As Brush, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

brush
The Brush instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadBrush Method


MindFusion.Scheduling.XmlSerializationContext.WriteByte Method

XmlSerializationContext.WriteByte Method

Write a byte value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteByte (
byte byteValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteByte ( _
byteValue As Byte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

byteValue
The byte value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadByte Method


MindFusion.Scheduling.XmlSerializationContext.WriteChar Method

XmlSerializationContext.WriteChar Method

Write a char value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteChar (
char charValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteChar ( _
charValue As Char, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

charValue
The char value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadChar Method


MindFusion.Scheduling.XmlSerializationContext.WriteColor Method

XmlSerializationContext.WriteColor Method

Writes the specified color.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteColor (
Color color,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteColor ( _
color As Color, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

color
The .NET Color object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadColor Method


MindFusion.Scheduling.XmlSerializationContext.WriteColorArray Method

XmlSerializationContext.WriteColorArray Method

Writes the specified array.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteColorArray ( _
array As Color(), _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array
The array to write.
elementName
The name of the element under which the array should be written.
subElementName
The name of the XML elements under which the individual array values will be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadColorArray Method


MindFusion.Scheduling.XmlSerializationContext.WriteCustomBrushes Method

XmlSerializationContext.WriteCustomBrushes Method

Writes the specified CustomBrushes object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteCustomBrushes (
CustomBrushes customBrushes,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteCustomBrushes ( _
customBrushes As CustomBrushes, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

customBrushes
The CustomBrushes instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadCustomBrushes Method


MindFusion.Scheduling.XmlSerializationContext.WriteDateTime Method

XmlSerializationContext.WriteDateTime Method

Writes the specified DateTime object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteDateTime (
DateTime dateTime,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteDateTime ( _
dateTime As DateTime, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

dateTime
The .NET DateTime object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDateTime Method


MindFusion.Scheduling.XmlSerializationContext.WriteDecimal Method

XmlSerializationContext.WriteDecimal Method

Write a decimal value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteDecimal (
Decimal decimalValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteDecimal ( _
decimalValue As Decimal, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

decimalValue
The decimal value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDecimal Method


MindFusion.Scheduling.XmlSerializationContext.WriteDouble Method

XmlSerializationContext.WriteDouble Method

Writes a double value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteDouble (
double doubleValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteDouble ( _
doubleValue As Double, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

doubleValue
The double value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadDouble Method


MindFusion.Scheduling.XmlSerializationContext.WriteEnum Method

XmlSerializationContext.WriteEnum Method

Writes the specified enum value.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteEnum (
Object enumValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteEnum ( _
enumValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

enumValue
The enum value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadEnum Method


MindFusion.Scheduling.XmlSerializationContext.WriteFloat Method

XmlSerializationContext.WriteFloat Method

Writes a float value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteFloat (
float floatValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteFloat ( _
floatValue As Single, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

floatValue
The float value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadFloat Method


MindFusion.Scheduling.XmlSerializationContext.WriteFloatArray Method

XmlSerializationContext.WriteFloatArray Method

Writes the specified array.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteFloatArray (
float[] array,
string elementName,
string subElementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteFloatArray ( _
array As Single(), _
elementName As String, _
subElementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

array
The array to write.
elementName
The name of the element under which the array should be written.
subElementName
The name of the XML elements under which the individual array values will be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadFloatArray Method


MindFusion.Scheduling.XmlSerializationContext.WriteFont Method

XmlSerializationContext.WriteFont Method

Writes the specified font.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteFont (
Font font,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteFont ( _
font As Font, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

font
The .NET Font object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadFont Method


MindFusion.Scheduling.XmlSerializationContext.WriteHashtable Method

XmlSerializationContext.WriteHashtable Method

Writes the specified hashtable.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteHashtable (
Hashtable hashtable,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteHashtable ( _
hashtable As Hashtable, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

hashtable
The .NET Hashtable object to write.
elementName
The name of the element under which the hashtable should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadHashtable Method


MindFusion.Scheduling.XmlSerializationContext.WriteImage Method

XmlSerializationContext.WriteImage Method

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteImage (
Image image,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteImage ( _
image As Image, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

image
The .NET Image object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadImage Method


MindFusion.Scheduling.XmlSerializationContext.WriteInt Method

XmlSerializationContext.WriteInt Method

Writes an integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteInt (
int intValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteInt ( _
intValue As Integer, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

intValue
The integer value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadInt Method


MindFusion.Scheduling.XmlSerializationContext.WriteLong Method

XmlSerializationContext.WriteLong Method

Writes a long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteLong (
long longValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteLong ( _
longValue As Long, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

longValue
The long value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadLong Method


MindFusion.Scheduling.XmlSerializationContext.WriteObject Method

XmlSerializationContext.WriteObject Method

Writes the specified object under the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteObject (
Object objectValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteObject ( _
objectValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

objectValue
The object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadObject Method


MindFusion.Scheduling.XmlSerializationContext.WritePen Method

XmlSerializationContext.WritePen Method

Writes the specified pen.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WritePen (
Pen pen,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WritePen ( _
pen As Pen, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

pen
The Pen instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadPen Method


MindFusion.Scheduling.XmlSerializationContext.WriteRecurrence Method

XmlSerializationContext.WriteRecurrence Method

Writes the specified Recurrence object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteRecurrence (
Recurrence recurrence,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteRecurrence ( _
recurrence As Recurrence, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

recurrence
The Recurrence instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadRecurrence Method


MindFusion.Scheduling.XmlSerializationContext.WriteReminder Method

XmlSerializationContext.WriteReminder Method

Writes the specified Reminder object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteReminder (
Reminder reminder,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteReminder ( _
reminder As Reminder, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

reminder
The Reminder instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadReminder Method


MindFusion.Scheduling.XmlSerializationContext.WriteSByte Method

XmlSerializationContext.WriteSByte Method

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteSByte (
sbyte byteValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteSByte ( _
byteValue As SByte, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

byteValue
The signed byte value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadSByte Method


MindFusion.Scheduling.XmlSerializationContext.WriteShort Method

XmlSerializationContext.WriteShort Method

Writes a short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteShort (
short shortValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteShort ( _
shortValue As Short, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

shortValue
The short value to write.
elementName

The name of the element under which the value should be written.

parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadShort Method


MindFusion.Scheduling.XmlSerializationContext.WriteStream Method

XmlSerializationContext.WriteStream Method

Writes the specified stream.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteStream (
Stream stream,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteStream ( _
stream As Stream, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stream
The .NET Stream object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadStream Method


MindFusion.Scheduling.XmlSerializationContext.WriteString Method

XmlSerializationContext.WriteString Method

Writes a string value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteString (
string stringValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteString ( _
stringValue As String, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

stringValue
The string value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadString Method


MindFusion.Scheduling.XmlSerializationContext.WriteStyle Method

XmlSerializationContext.WriteStyle Method

Writes the specified Style object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteStyle (
Style style,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteStyle ( _
style As Style, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

style
The Style instance to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadStyle Method


MindFusion.Scheduling.XmlSerializationContext.WriteTag Method

XmlSerializationContext.WriteTag Method

Writes the specified tag of the specified object.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteTag (
Object item,
Object tagValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteTag ( _
item As Object, _
tagValue As Object, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

item
The Item whose tag is being serialized.
tagValue
The tag object to write.
elementName
The name of the element under which the object should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

Remarks

This method raises the SerializeTag event of the underlying schedule, giving clients a chance to perform custom serialization. If the event is not handled, the system attempts to serialize the tag as an arbitrary object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadTag Method
Schedule.SerializeTag Event


MindFusion.Scheduling.XmlSerializationContext.WriteUInt Method

XmlSerializationContext.WriteUInt Method

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteUInt (
uint uintValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteUInt ( _
uintValue As UInteger, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

uintValue
The unsigned integer value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadUInt Method


MindFusion.Scheduling.XmlSerializationContext.WriteULong Method

XmlSerializationContext.WriteULong Method

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteULong (
ulong ulongValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteULong ( _
ulongValue As ULong, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

ulongValue
The unsigned long value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadULong Method


MindFusion.Scheduling.XmlSerializationContext.WriteUShort Method

XmlSerializationContext.WriteUShort Method

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlElement WriteUShort (
ushort ushortValue,
string elementName,
XmlElement parentElement
)
Visual Basic

Public Function WriteUShort ( _
ushortValue As UShort, _
elementName As String, _
parentElement As XmlElement _
) As XmlElement

Parameters

ushortValue
The unsigned short value to write.
elementName
The name of the element under which the value should be written.
parentElement
The parent element of the newly created node.

Return Value

An instance of the .NET XmlElement class representing the newly created XML element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace
ReadUShort Method


MindFusion.Scheduling.XmlSerializationContext Properties

XmlSerializationContext Properties

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
XmlDocument | Gets the underlying XML document.

See Also

XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.ClassVersion Property

XmlSerializationContext.ClassVersion Property

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public int ClassVersion { get; }
Visual Basic

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer value specifying the class version of the currently deserialized item as specified by the call to RegisterItemClass method at the time the item type was registered.

Remarks

This property is only useful when deserializing items.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.XmlSerializationContext.XmlDocument Property

XmlSerializationContext.XmlDocument Property

Gets the underlying XML document.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public XmlDocument XmlDocument { get; }
Visual Basic

Public ReadOnly Property XmlDocument As XmlDocument

Property Value

An instance of the .NET XmlDocument class.

See Also

XmlSerializationContext Members
XmlSerializationContext Class
MindFusion.Scheduling Namespace


MindFusion.Scheduling.YearlyRecurrence Enumeration

YearlyRecurrence Enumeration

Specifies the types of yearly recurrence patterns.

Namespace: MindFusion.Scheduling
Assembly: PocketPlanner

Syntax

C#

public enum YearlyRecurrence
Visual Basic

Public Enumeration YearlyRecurrence

Members

Member name | Description
ByDayType | The event occurs on a specific type of day of the specified week and month of the year.
SpecificDate | The event occurs on a specific date of the year.

See Also

MindFusion.Scheduling Namespace


MindFusion.Scheduling.Compact Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
Calendar | The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.
CellSettings | Defines appearance settings for the cells representing time ranges in the calendar in the calendar.
CustomDrawArgs | Contains the arguments passed to handlers of the Draw event.
DateChangedEventArgs | Contains the arguments passed to handlers of the VisibleDateChanged event.
DateCollection | Represents a strongly-typed sorted collection of DateTime objects.
DateEventArgs | Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.
DateStyle | Defines formatting for a range of dates. Can be used either to format either days or months.
DateStyleCollection | Represents a strongly-typed collection of DateStyle objects.
DayOfWeekStyle | An instance of this class defines how a day of the week should be displayed and formatted.
DayOfWeekStyleCollection | Represents a strongly-typed collection of DayOfWeekStyle objects.
ItemConfirmEventArgs | Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.
ItemEditConfirmEventArgs | Contains the arguments passed to handlers of the ItemInplaceEditEnding event.
ItemEventArgs | Contains the arguments passed to handlers of item related events, such as ItemCreated and ItemDeleted.
ItemModifiedEventArgs | Contains the arguments passed to handlers of the ItemModified event.
ItemModifyConfirmEventArgs | Contains the arguments passed to handlers of the ItemModifying event.
ItemMouseEventArgs | Contains the arguments passed to handlers of the ItemClick event.
ItemSelection | Represents a set of selected schedule items.
ItemSelectionEventArgs | Contains the arguments passed to handlers of selection related events.
ItemSettings | Defines properties that allow customizing the visualization of schedule items in the calendar views.
ListViewSettings | Defines properties that allow customizing the visualization of the calendar in a List view.
MonthRangeSettings | Defines settings for the years in the calendar.
MonthSettings | Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.
RecurringItemConfirmEventArgs | Contains the arguments passed to handlers of the RecurringItemDeleting event.
ResourceDateEventArgs | Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.
ResourceViewSettings | Defines properties that allow customizing the visualization of the calendar in Resource view.
Selection | Represents a set of selected date cells and defines a visualization style applied to the selected elements.
SelectionState | Represents the saved state of a Selection object.
Theme | Encapsulates visualization settings that can be applied to a Calendar control by calling the ApplyTheme method. A theme includes settings for all calendar views - List, Month, Timetable, and so on.
TimelineSettings | Encapsulates settings for a timeline in a Resource view.
TimetableSettings | Defines properties that allow customizing the visualization of the calendar in Timetable view.
ViewSettings | The base class for the different view settings classes.
WeekRangeSettings | Defines properties that allow customizing the visualization of weeks in WeekRange view.

Interfaces

Interface | Description
ISupportInitialize | Specifies that this object supports a simple, transacted notification for batch initialization.

Delegates

Delegate | Description
CustomDraw | Represents methods that will handle the Draw event.
DateChangedEventHandler | Represents methods that will handle the VisibleDateChanged event.
DateEventHandler | Represents methods that will handle mouse events related to date and time cells in the calendar.
ItemConfirmEventHandler | Represents methods that will handle item validation events such as ItemCreating and ItemDeleting.
ItemEditConfirmEventHandler | Represents methods that will handle the ItemInplaceEditEnding event.
ItemEventHandler | Represents methods that will handle general item related events.
ItemModifiedEventHandler | Represents methods that will handle the ItemModified event.
ItemModifyConfirmEventHandler | Represents methods that will handle the ItemModifying event.
ItemMouseEventHandler | Represents methods that will handle the ItemClick event.
ItemSelectionEventHandler | Represents methods that will handle item selection related events.
RecurringItemConfirmEventHandler | Represents methods that will handle the RecurringItemDeleting event.
ResourceDateEventHandler | Represents methods that will handle mouse events related to date/time and resource related cells in the calendar.

Enumerations

Enumeration | Description
CalendarElement | Specifies a calendar subelement.
CalendarView | Specifies the type of view to display in a calendar control.
CustomDrawElements | Specifies which elements of the calendar are custom-drawn.
DayOfWeekFormat | Specifies the display format of a day of the week.
GroupType | Specifies grouping or filtering criteria for views that support grouping.
ItemAction | Specifies a user action on a schedule item.
LineStyle | Specifies the style of lines.
ListViewHeaderStyles | Specifies the appearance and behavior of the header in a List view.
MinuteFormat | Specifies how to format and display minutes in the Timetable view.
MonthCellLayout | Specifies the layout of the cells in a SingleMonth and MonthRange views.
MonthHeaderStyles | Specifies the appearance and behavior of month headers in a SingleMonth and MonthRange views.
MonthRangeHeaderStyles | Specifies the appearance and behavior of the header in a MonthRange view.
MonthWeekHeaderStyle | Specifies the placement of the week numbers header in a SingleMonth view.
Orientation | Specifies horizontal or vertical orientation.
Position | Specifies the position of an element relative to its container.
ResourceLengthMethod | Specifies how to calculate the length of the resources in a Resource view.
ResourceResizeMethod | Specifies the item resizing method in a Resource view.
ResourceViewStyle | Specifies the style of a Resource view.
SelectionStyle | Specifies what type of frame to draw around selected elements.
State | Specifies the state of a subject.
ThemeType | Specifies a calendar theme.
TimeUnit | Specifies a time resolution.
WeekRangeHeaderStyle | Specifies the appearance of the time period header in WeekRange view.
WeekRangeViewStyle | Specifies whether there are multiple weeks displayed in WeekRange view.


MindFusion.Scheduling.WinForms.Calendar Class

Calendar Class

The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class Calendar : Control, ISupportInitialize
Visual Basic

Public Class Calendar
Inherits Control
Implements ISupportInitialize

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Scheduling.Compact.Calendar

See Also

Calendar Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar Members

Calendar Members
Constructors Properties Methods Events

The Calendar control serves as a view in document-view architecture, where the document is implemented by the Schedule class. The Calendar provides several schedule related views, such as SingleMonth, List, Timetable, that present the scheduled events in different styles and layouts.

The following tables list the members exposed by the Calendar type.

Public Constructors

Name | Description
Calendar | Overloaded. Initializes a new instance of the Calendar class.

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle.
AllowInplaceCreate | Gets or sets a value indicating whether users are allowed to create items interactively.
AllowInplaceEdit | Gets or sets a value indicating whether users are allowed to edit items interactively.
ButtonOffset | Gets or set the offset of the buttons, displayed in the MonthRange and SingleMonth views' headers.
ButtonSize | Gets or sets the size of the navigation buttons, displayed in the views' headers.
ColorKey | Gets or sets the color key to use when drawing images.
ContactNameFormat | Gets or sets how to format and display contact names in the timetable header.
Contacts | Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.
Culture | Gets or sets the CultureInfo object used to format and display time information in the calendar.
CurrentTime | Gets or sets the current time. When this property is set to DateTime.MinValue, the actual system time is returned.
CurrentView | Gets or sets the type of the calendar view.
CustomDraw | Gets or sets which UI elements of the calendar should be custom drawn.
DataSource | Gets or sets the data source associated with the control.
Date | Gets or sets the date currently displayed in the calendar.
DateTimeFormat | Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.
DayOfWeekStyles | Gets a collection of DayOfWeekStyle objects that allow customizing the appearance of specific days of the week in the calendar.
DayStyles | Gets a collection of DateStyle objects that allow customizing the appearance of specific days in the calendar.
DelayInplaceEdit | Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked.
DragItemsOnDisabledAreas | Gets or sets a value indicating whether to update the position of items dragged over areas which do not allow items.
EnableDragCreate | Gets or sets a value indicating whether items are created merely by dragging in the control.
EnableKeyboard | Gets or sets a value indicating whether the selection can be manipulated through the keyboard.
EnableOptimization | Gets or sets a value indicating whether the control should try to optimize item rendering.
EndDate | Gets or sets the last date displayed in the calendar.
EnsureVisibleSelection | Gets or sets a value indicating whether the selected cells should be automatically brought into view.
FirstWeekendDay | Gets or sets the first weekend day in the calendar.
GroupType | Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views.
HScrollerSmallChange | Gets or sets the small step for the horizontal scroll bar.
HScrollerVisible | Gets or sets a value indicating whether the horizontal scroller should always be visible, always hidden or visible only when it is needed.
HScrollPos | Gets or sets the current horizontal scroll position.
ImageList | Gets or sets the image list associated with the calendar.
InteractiveItemType | Gets or sets the type of an Item derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.
ItemModificationStyle | Gets or sets a value indicating the way items are processed when modified interactively.
ItemScroll | Gets or sets the current scroll position in a List view whose EnableVirtualItemSpace property is set to Enabled.
ItemSelection | Gets a list of all selected items.
ItemSettings | Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.
ListViewSettings | Gets the ListViewSettings object used to customize the visualization of the List view.
Locations | Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.
MinItemLength | Gets or sets the minimal length of interactively created items, expressed in minutes.
MonthRangeSettings | Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.
MonthSettings | Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.
MonthStyles | Gets a collection of DateStyle objects that allow customizing the appearance of specific months in the calendar.
Resources | Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.
ResourceViewSettings | Gets the ResourceViewSettings object used to customize the visualization of a Resource view.
Schedule | Gets or sets the schedule whose information should be displayed inside the calendar control.
ScrollPosition | Gets or sets the current scroll position.
Selection | Gets a Selection object representing the current selection in the calendar.
StartEditAfterModify | Gets or sets a value indicating whether in-place editing of items should automatically start after they are modified interactively.
Tasks | Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.
Theme | Gets or sets the theme applied to the calendar control UI elements.
TimetableSettings | Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.
ToolTip | Gets the underlying ToolTip component.
VScrollerSmallChange | Gets or sets the small step for the vertical scroll bar.
VScrollerVisible | Gets or sets a value indicating whether the vertical scroller should always be visible, always hidden or visible only when it is needed.
VScrollPos | Gets or sets the current vertical scroll position.
WeekRangeSettings | Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

Public Methods

Name | Description
ApplyTheme | Overloaded. Applies a Theme to the calendar.
BeginInit | Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.
CollapseResourceRow | Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
EndInit | Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.
EnsureVisible | Overloaded. Ensures that the specified date or item is visible within the control, scrolling the contents of the control if necessary.
ExpandResourceRow | Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
GetContactAt | Overloaded. Gets the Contact object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetDateAt | Overloaded. Returns the date of the calendar cell located at the specified coordinates.
GetElementBounds | Gets the bounding rectangle of a particular calendar element.
GetExactDateAt | Overloaded. Returns the date located at a specified position.
GetFirstDate | Gets the first date of the time range displayed in the calendar.
GetFirstVisibleDate | Determines which is the first visible date in the current view.
GetItemAt | Overloaded. Gets the scheduled Item object displayed at the specified coordinates.
GetItemBounds | Retrieves the bounding rectangle of the specified item.
GetItemListLane | Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.
GetLastDate | Gets the last date of the time range displayed in the calendar.
GetLastVisibleDate | Determines which is the last visible date in the current view.
GetListLaneAt | Retrieves the index of the List view lane at the specified point, expressed in client coordinates.
GetLocationAt | Overloaded. Gets the Location object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetResourceAt | Overloaded. Gets the Resource object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetTaskAt | Overloaded. Gets the Task object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetVisibleItems | Retrieves a collection with all currently visible items.
IsResourceRowExpanded | Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.
LoadFrom |
LoadFromDataSource | Loads the schedule from the underlying data source.
LoadViewSettings | Loads the view settings from the specified stream or XML document.
ResetDrag | If there is a mouse drag operation in progress, it is canceled.
ResetItemViewState | Resets the view-related item data contained in the underlying schedule. For example, items moved around in a list view with enabled FreeDrag property have their relative positions within the view reset.
ResumeDrag | Resumes the previously paused mouse drag operation.
SaveTo |
SaveViewSettings | Saves the view settings to the specified stream or XML document.
SetItemListLane | Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.
StartInplaceEdit | Starts in-place editing mode for the specified item to let users edit the item's text.
SuspendDrag | Temporarily pauses the current mouse drag operation.
UpdateLayout | Updates the position of the calendar's child controls such as buttons and scrollbars.

Protected Methods

Name | Description
Dispose | Cleans up any resources being used.
OnContinuePrinting | Raises the ContinuePrinting event.
OnDateClick | Raises the DateClick event.
OnDraw | Raises the Draw event.
OnHiddenItemClick | Raises the HiddenItemClick event.
OnHScroll |
OnItemClick | Raises the ItemClick event.
OnItemCloned | Raises the ItemCloned event.
OnItemCloning | Raises the ItemCloning event.
OnItemCreated | Raises the ItemCreated event.
OnItemCreating | Raises the ItemCreating event.
OnItemDeleted | Raises the ItemDeleted event.
OnItemDeleting | Raises the ItemDeleting event.
OnItemDeselecting | Raises the ItemDeselecting event.
OnItemInplaceEdited | Raises the ItemInplaceEdited event.
OnItemInplaceEditEnding | Raises the ItemInplaceEditEnding event.
OnItemInplaceEditStarting | Raises the ItemInplaceEditStarting event.
OnItemListLaneChanged | Raises the ItemListLaneChanged event.
OnItemModificationCanceled | Raises the ItemModificationCanceled event.
OnItemModified | Raises the ItemModified event.
OnItemModifying | Raises the ItemModifying event.
OnItemSelecting | Raises the ItemSelecting event.
OnItemSelectionChanged | Raises the ItemSelectionChanged event.
OnItemTooltipDisplaying | Raises the ItemTooltipDisplaying event.
OnKeyPress | Control.OnKeyPress override.
OnListViewHeaderClick | Raises the ListViewHeaderClick event.
OnLostFocus | Control.OnLostFocus override.
OnMonthHeaderClick | Raises the MonthHeaderClick event.
OnMonthRangeHeaderClick | Raises the MonthRangeHeaderClick event.
OnMonthWeekHeaderClick | Raises the MonthWeekHeaderClick event.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPaintBackground override.
OnRecurringItemDeleting | Raises the RecurringItemDeleting event.
OnResize | Control.OnResize override.
OnResourceViewBottomTimelineClick | Raises the ResourceViewBottomTimelineClick event.
OnResourceViewMiddleTimelineClick | Raises the ResourceViewMiddleTimelineClick event.
OnResourceViewRowHeaderClick | Raises the ResourceViewRowHeaderClick event.
OnResourceViewTopTimelineClick | Raises the ResourceViewTopTimelineClick event.
OnScroll | Raises the Scroll event.
OnTimetableColumnHeaderClick | Raises the TimetableColumnHeaderClick event.
OnVisibleDateChanged | Raises the VisibleDateChanged event.
OnVScroll |
OnWeekRangeHeaderClick | Raises the WeekRangeHeaderClick event.

Public Events

Name | Description
ContinuePrinting | Occurs at the end of a printing operation to enable users to continue printing the calendar with different view settings.
DateClick | Raised when the user clicks a date cell in the calendar.
Draw | Raised to allow custom drawing of calendar UI elements.
HiddenItemClick | Raised when a hidden items cue icon is clicked.
HScroll | Raised when the control has been scrolled horizontally.
ItemClick | Raised when the user clicks a schedule item.
ItemCreated | Raised when a schedule item is created by the user.
ItemCreating | Raised when the user is about to create a new schedule item.
ItemDeleted | Raised when the user deletes a schedule item.
ItemDeleting | Raised when the user is about to delete a schedule item.
ItemDeselecting | Raised when an item is about to be deselected.
ItemInplaceEdited | Raised when item's text is in-place edited.
ItemInplaceEditEnding | Raised when in-place editing of item's text is about to be accepted.
ItemInplaceEditStarting | Raised when in-place editing of item's text is about to begin.
ItemListLaneChanged | Raised when the lane index of an item within a List view has changed.
ItemModificationCanceled | Raised when an item modification is canceled by the user.
ItemModified | Raised when a schedule item is moved or resized by the user.
ItemModifying | Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.
ItemSelecting | Raised when an item is about to be selected.
ItemSelectionChanged | Raised when an item is selected or deselected.
ListViewHeaderClick | Raised when the header of a List view is clicked.
MonthHeaderClick | Raised when the header of a Month view is clicked.
MonthRangeHeaderClick | Raised when the header of an MonthRange view is clicked.
MonthWeekHeaderClick | Raised when a cell in the week header of a Month view is clicked.
RecurringItemDeleting | Raised when the user is about to delete a recurring item.
ResourceViewBottomTimelineClick | Raised when the bottom timeline of a Resource view is clicked.
ResourceViewMiddleTimelineClick | Raised when the middle timeline of a Resource view is clicked.
ResourceViewRowHeaderClick | Raised when the header of a Resource view row is clicked.
ResourceViewTopTimelineClick | Raised when the top timeline of a Resource view is clicked.
Scroll | Raised when the value of a scrollbar has changed.
TimetableColumnHeaderClick | Raised when the header of a Timetable column is clicked.
VisibleDateChanged | Raised when the user selects another date using the month or year navigation controls on the calendar header area.
VScroll | Raised when the control has been scrolled vertically.
WeekRangeHeaderClick | Raised when the header of a WeekRange view is clicked.

See Also

Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar Constructor

Calendar Constructor

Initializes a new instance of the Calendar class.

Overload List

Name | Description
Calendar () | Initializes a new instance of the Calendar class using the current culture info.
Calendar (CultureInfo) | Initializes a new instance of the Calendar class using the specified culture info.

See Also

Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar Constructor ()

Calendar Constructor ()
See Also

Initializes a new instance of the Calendar class using the current culture info.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Calendar ()
Visual Basic

Public Sub New ()

See Also

Calendar Constructor Overload List
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar Constructor (CultureInfo)

Calendar Constructor (CultureInfo)
See Also

Initializes a new instance of the Calendar class using the specified culture info.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Calendar (
CultureInfo culture
)
Visual Basic

Public Sub Calendar ( _
culture As CultureInfo _
)

Parameters

culture
A .NET CultureInfo object providing information about formatting and displaying dates and times.

See Also

Calendar Constructor Overload List
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar Methods

Calendar Methods

Public Methods

Name | Description
ApplyTheme | Overloaded. Applies a Theme to the calendar.
BeginInit | Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.
CollapseResourceRow | Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
EndInit | Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.
EnsureVisible | Overloaded. Ensures that the specified date or item is visible within the control, scrolling the contents of the control if necessary.
ExpandResourceRow | Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.
GetContactAt | Overloaded. Gets the Contact object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetDateAt | Overloaded. Returns the date of the calendar cell located at the specified coordinates.
GetElementBounds | Gets the bounding rectangle of a particular calendar element.
GetExactDateAt | Overloaded. Returns the date located at a specified position.
GetFirstDate | Gets the first date of the time range displayed in the calendar.
GetFirstVisibleDate | Determines which is the first visible date in the current view.
GetItemAt | Overloaded. Gets the scheduled Item object displayed at the specified coordinates.
GetItemBounds | Retrieves the bounding rectangle of the specified item.
GetItemListLane | Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.
GetLastDate | Gets the last date of the time range displayed in the calendar.
GetLastVisibleDate | Determines which is the last visible date in the current view.
GetListLaneAt | Retrieves the index of the List view lane at the specified point, expressed in client coordinates.
GetLocationAt | Overloaded. Gets the Location object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetResourceAt | Overloaded. Gets the Resource object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetTaskAt | Overloaded. Gets the Task object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.
GetVisibleItems | Retrieves a collection with all currently visible items.
IsResourceRowExpanded | Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.
LoadFrom |
LoadFromDataSource | Loads the schedule from the underlying data source.
LoadViewSettings | Loads the view settings from the specified stream or XML document.
ResetDrag | If there is a mouse drag operation in progress, it is canceled.
ResetItemViewState | Resets the view-related item data contained in the underlying schedule. For example, items moved around in a list view with enabled FreeDrag property have their relative positions within the view reset.
ResumeDrag | Resumes the previously paused mouse drag operation.
SaveTo |
SaveViewSettings | Saves the view settings to the specified stream or XML document.
SetItemListLane | Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.
StartInplaceEdit | Starts in-place editing mode for the specified item to let users edit the item's text.
SuspendDrag | Temporarily pauses the current mouse drag operation.
UpdateLayout | Updates the position of the calendar's child controls such as buttons and scrollbars.

Protected Methods

Name | Description
Dispose | Cleans up any resources being used.
OnContinuePrinting | Raises the ContinuePrinting event.
OnDateClick | Raises the DateClick event.
OnDraw | Raises the Draw event.
OnHiddenItemClick | Raises the HiddenItemClick event.
OnHScroll |
OnItemClick | Raises the ItemClick event.
OnItemCloned | Raises the ItemCloned event.
OnItemCloning | Raises the ItemCloning event.
OnItemCreated | Raises the ItemCreated event.
OnItemCreating | Raises the ItemCreating event.
OnItemDeleted | Raises the ItemDeleted event.
OnItemDeleting | Raises the ItemDeleting event.
OnItemDeselecting | Raises the ItemDeselecting event.
OnItemInplaceEdited | Raises the ItemInplaceEdited event.
OnItemInplaceEditEnding | Raises the ItemInplaceEditEnding event.
OnItemInplaceEditStarting | Raises the ItemInplaceEditStarting event.
OnItemListLaneChanged | Raises the ItemListLaneChanged event.
OnItemModificationCanceled | Raises the ItemModificationCanceled event.
OnItemModified | Raises the ItemModified event.
OnItemModifying | Raises the ItemModifying event.
OnItemSelecting | Raises the ItemSelecting event.
OnItemSelectionChanged | Raises the ItemSelectionChanged event.
OnItemTooltipDisplaying | Raises the ItemTooltipDisplaying event.
OnKeyPress | Control.OnKeyPress override.
OnListViewHeaderClick | Raises the ListViewHeaderClick event.
OnLostFocus | Control.OnLostFocus override.
OnMonthHeaderClick | Raises the MonthHeaderClick event.
OnMonthRangeHeaderClick | Raises the MonthRangeHeaderClick event.
OnMonthWeekHeaderClick | Raises the MonthWeekHeaderClick event.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnPaint | Control.OnPaint override.
OnPaintBackground | Control.OnPaintBackground override.
OnRecurringItemDeleting | Raises the RecurringItemDeleting event.
OnResize | Control.OnResize override.
OnResourceViewBottomTimelineClick | Raises the ResourceViewBottomTimelineClick event.
OnResourceViewMiddleTimelineClick | Raises the ResourceViewMiddleTimelineClick event.
OnResourceViewRowHeaderClick | Raises the ResourceViewRowHeaderClick event.
OnResourceViewTopTimelineClick | Raises the ResourceViewTopTimelineClick event.
OnScroll | Raises the Scroll event.
OnTimetableColumnHeaderClick | Raises the TimetableColumnHeaderClick event.
OnVisibleDateChanged | Raises the VisibleDateChanged event.
OnVScroll |
OnWeekRangeHeaderClick | Raises the WeekRangeHeaderClick event.

See Also

Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ApplyTheme Method

Calendar.ApplyTheme Method

Applies a Theme to the calendar.

Overload List

Name | Description
Calendar.ApplyTheme (Theme) | Applies the specified theme to the calendar.
Calendar.ApplyTheme (Theme, Boolean) | Applies the specified theme to the calendar, optionally resetting all current settings.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ApplyTheme Method (Theme)

Calendar.ApplyTheme Method (Theme)
See Also

Applies the specified theme to the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void ApplyTheme (
Theme theme
)
Visual Basic

Public Sub ApplyTheme ( _
theme As Theme _
)

Parameters

theme
A Theme object containing appearance settings.

See Also

ApplyTheme Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
Theme Property


MindFusion.Scheduling.WinForms.Calendar.ApplyTheme Method (Theme, Boolean)

Calendar.ApplyTheme Method (Theme, Boolean)
See Also

Applies the specified theme to the calendar, optionally resetting all current settings.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void ApplyTheme (
Theme theme,
bool reset
)
Visual Basic

Public Sub ApplyTheme ( _
theme As Theme, _
reset As Boolean _
)

Parameters

theme
A Theme object containing appearance settings.
reset
Specifies whether to reset the settings.

Example

The following example attaches the Windows2003 theme to a calendar. The example assumes that calendar already references an existing Calendar object.

C#

calendar.ApplyTheme(MindFusion.Scheduling.Compact.Theme.Windows2003, false);
Visual Basic

calendar.ApplyTheme(MindFusion.Scheduling.Compact.Theme.Windows2003, False)

See Also

ApplyTheme Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
Theme Property


MindFusion.Scheduling.WinForms.Calendar.BeginInit Method

Calendar.BeginInit Method

Implements the ISupportInitialize.BeginInit method. Call this method before making several consecutive changes to the control to suppress internal updates, but don't forget to invoke EndInit at the end.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public virtual void BeginInit ()
Visual Basic

Public Overridable Sub BeginInit ()

Example

The following example demonstrates how to use BeginInit and EndInit to prevent unnecessary updating.

C#

using MindFusion.Scheduling.Compact;

// ...

calendar.BeginInit();
calendar.Date = DateTime.Today;
calendar.EndDate = DateTime.Today + TimeSpan.FromDays(100);
calendar.CurrentView = CalendarView.WeekRange;
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow;
calendar.WeekRangeSettings.GroupWeekends = State.Enabled;
calendar.EndInit();
Visual Basic

Imports MindFusion.Scheduling.Compact

' ...

calendar.BeginInit()
calendar.Date = DateTime.Today
calendar.EndDate = DateTime.Today.Add(TimeSpan.FromDays(100))
calendar.CurrentView = CalendarView.WeekRange
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow
calendar.WeekRangeSettings.GroupWeekends = State.Enabled
calendar.EndInit()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
EndInit Method


MindFusion.Scheduling.WinForms.Calendar.CollapseResourceRow Method

Calendar.CollapseResourceRow Method

Collapses the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void CollapseResourceRow (
Resource reference
)
Visual Basic

Public Sub CollapseResourceRow ( _
reference As Resource _
)

Parameters

reference
A reference to a Contact, Location, Task or Resource object whose row is to be collapsed.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ExpandResourceRow Method
IsResourceRowExpanded Method


MindFusion.Scheduling.WinForms.Calendar.Dispose Method

Calendar.Dispose Method

Cleans up any resources being used.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void Dispose (
bool disposing
)
Visual Basic

Protected Overridable Sub Dispose ( _
disposing As Boolean _
)

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.EndInit Method

Calendar.EndInit Method

Implements the ISupportInitialize.EndInit method. Call this method to signal that object initialization started with BeginInit is complete.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public virtual void EndInit ()
Visual Basic

Public Overridable Sub EndInit ()

Example

The following example demonstrates how to use BeginInit and EndInit to prevent unnecessary updating.

C#

using MindFusion.Scheduling.Compact;

// ...

calendar.BeginInit();
calendar.Date = DateTime.Today;
calendar.EndDate = DateTime.Today + TimeSpan.FromDays(100);
calendar.CurrentView = CalendarView.WeekRange;
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow;
calendar.WeekRangeSettings.GroupWeekends = State.Enabled;
calendar.EndInit();
Visual Basic

Imports MindFusion.Scheduling.Compact

' ...

calendar.BeginInit()
calendar.Date = DateTime.Today
calendar.EndDate = DateTime.Today.Add(TimeSpan.FromDays(100))
calendar.CurrentView = CalendarView.WeekRange
calendar.WeekRangeSettings.ViewStyle = WeekRangeViewStyle.WeekPerRow
calendar.WeekRangeSettings.GroupWeekends = State.Enabled
calendar.EndInit()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
BeginInit Method


MindFusion.Scheduling.WinForms.Calendar.EnsureVisible Method

Calendar.EnsureVisible Method

Ensures that the specified date or item is visible within the control, scrolling the contents of the control if necessary.

Overload List

Name | Description
Calendar.EnsureVisible (DateTime) | Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary.
Calendar.EnsureVisible (DateTime, Resource) | Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary. The reference parameter allows specifying a Task, Location, Contact or Resource for which to display the date in a view with enabled grouping.
Calendar.EnsureVisible (Item) | Ensures that the item is visible within the control, scrolling the contents of the control if necessary.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.EnsureVisible Method (DateTime)

Calendar.EnsureVisible Method (DateTime)
See Also

Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void EnsureVisible (
DateTime date
)
Visual Basic

Public Sub EnsureVisible ( _
date As DateTime _
)

Parameters

date
A DateTime instance identifying the date to scroll into view.

Remarks

This method does nothing if the specified date is not included in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.EnsureVisible Method (DateTime, Resource)

Calendar.EnsureVisible Method (DateTime, Resource)
See Also

Ensures that the specified date is visible within the control, scrolling the contents of the control if necessary. The reference parameter allows specifying a Task, Location, Contact or Resource for which to display the date in a view with enabled grouping.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void EnsureVisible (
DateTime date,
Resource reference
)
Visual Basic

Public Sub EnsureVisible ( _
date As DateTime, _
reference As Resource _
)

Parameters

date
A .NET DateTime instance identifying the date to scroll into view.
reference
A reference to Task, Location, Contact or Resource whose group to display in the view.

Remarks

This method does nothing if the specified date is not included in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.EnsureVisible Method (Item)

Calendar.EnsureVisible Method (Item)
See Also

Ensures that the item is visible within the control, scrolling the contents of the control if necessary.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void EnsureVisible (
Item item
)
Visual Basic

Public Sub EnsureVisible ( _
item As Item _
)

Parameters

item
The schedule Item to scroll into view.

Remarks

This method does nothing if the item is not scheduled to occur in the time-period displayed in the current view.

See Also

EnsureVisible Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ExpandResourceRow Method

Calendar.ExpandResourceRow Method

Expands the row associated with the specified Contact, Location, Task or Resource in a Resource view. If there is no such row or the current view is not ResourceView, nothing happens.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void ExpandResourceRow (
Resource reference
)
Visual Basic

Public Sub ExpandResourceRow ( _
reference As Resource _
)

Parameters

reference
A reference to a Contact, Location, Task or Resource object whose row is to be expanded.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
CollapseResourceRow Method
IsResourceRowExpanded Method


MindFusion.Scheduling.WinForms.Calendar.GetContactAt Method

Calendar.GetContactAt Method

Gets the Contact object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.

Overload List

Name | Description
Calendar.GetContactAt (Int32, Int32) | Gets the Contact object whose schedule is displayed at the specified coordinates.
Calendar.GetContactAt (Point) | Gets the Contact object whose schedule is displayed at the specified coordinates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetContactAt Method (Int32, Int32)

Calendar.GetContactAt Method (Int32, Int32)
See Also

Gets the Contact object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Contact GetContactAt (
int x,
int y
)
Visual Basic

Public Function GetContactAt ( _
x As Integer, _
y As Integer _
) As Contact

Parameters

x
The x-coordinate of the position at which to look for contact's scheduled items.
y
The y-coordinate of the position at which to look for contact's scheduled items.

Return Value

An instance of the Contact class representing the contact related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetContactAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetContactAt Method (Point)

Calendar.GetContactAt Method (Point)
See Also

Gets the Contact object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Contact GetContactAt (
Point point
)
Visual Basic

Public Function GetContactAt ( _
point As Point _
) As Contact

Parameters

point
The position at which to look for contact's scheduled items.

Return Value

An instance of the Contact class representing the contact related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetContactAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetDateAt Method

Calendar.GetDateAt Method

Returns the date of the calendar cell located at the specified coordinates.

Overload List

Name | Description
Calendar.GetDateAt (Int32, Int32) | Returns the date of the calendar cell located at the specified coordinates.
Calendar.GetDateAt (Point) | Returns the date of the calendar cell located at the specified position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetDateAt Method (Int32, Int32)

Calendar.GetDateAt Method (Int32, Int32)
See Also

Returns the date of the calendar cell located at the specified coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime GetDateAt (
int x,
int y
)
Visual Basic

Public Function GetDateAt ( _
x As Integer, _
y As Integer _
) As DateTime

Parameters

x
The x-coordinate of the position at which to look for a date cell.
y
The y-coordinate of the position at which to look for a date cell.

Return Value

A .NET DateTime instance indicating which date is displayed at the specified position. If there is no date cell at the specified position, the return value is DateTime.MinValue.

See Also

GetDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method


MindFusion.Scheduling.WinForms.Calendar.GetDateAt Method (Point)

Calendar.GetDateAt Method (Point)
See Also

Returns the date of the calendar cell located at the specified position.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime GetDateAt (
Point point
)
Visual Basic

Public Function GetDateAt ( _
point As Point _
) As DateTime

Parameters

point
The position at which to look for a date cell.

Return Value

A .NET DateTime instance indicating which date is displayed at the specified position. If there is no date cell at the specified point, the return value is DateTime.MinValue.

See Also

GetDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method


MindFusion.Scheduling.WinForms.Calendar.GetElementBounds Method

Calendar.GetElementBounds Method

Gets the bounding rectangle of a particular calendar element.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Rectangle GetElementBounds (
CalendarElement element,
int index
)
Visual Basic

Public Function GetElementBounds ( _
element As CalendarElement, _
index As Integer _
) As Rectangle

Parameters

element
The type of the element whose bounds to retrieve.
index
The index of the element, if there is more than one element of the specified type.

Return Value

The bounding rectangle of the specified element or Rectangle.Empty if the element is either not present in the current view or not visible in the current viewport.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetExactDateAt Method

Calendar.GetExactDateAt Method

Returns the date located at a specified position.

Overload List

Name | Description
Calendar.GetExactDateAt (Int32, Int32) | Returns the date located at the specified coordinates.
Calendar.GetExactDateAt (Point) | Returns the date located at the specified position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetExactDateAt Method (Int32, Int32)

Calendar.GetExactDateAt Method (Int32, Int32)
See Also

Returns the date located at the specified coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime GetExactDateAt (
int x,
int y
)
Visual Basic

Public Function GetExactDateAt ( _
x As Integer, _
y As Integer _
) As DateTime

Parameters

x
The x-coordinate of the position at which to look for a date.
y
The y-coordinate of the position at which to look for a date.

Return Value

A DateTime instance indicating which date is displayed at the specified position. If there is no date at the specified position, the return value is DateTime.MinValue.

Remarks

The returned value represents the exact date located at the specified position in contrast with GetDateAt, which returns the start date of the cell, located at the specified position.

This method works only in a Timetable view.

See Also

GetExactDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetExactDateAt Method (Point)

Calendar.GetExactDateAt Method (Point)
See Also

Returns the date located at the specified position.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime GetExactDateAt (
Point point
)
Visual Basic

Public Function GetExactDateAt ( _
point As Point _
) As DateTime

Parameters

point
The position at which to look for a date.

Return Value

A .NET DateTime instance indicating which date is displayed at the specified position. If there is no date cell at the specified point, the return value is DateTime.MinValue.

Remarks

The returned value represents the exact date located at the specified position in contrast with GetDateAt, which returns the start date of the cell, located at the specified position.

This method works only in a Timetable view.

See Also

GetExactDateAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetFirstDate Method

Calendar.GetFirstDate Method

Gets the first date of the time range displayed in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime GetFirstDate ()
Visual Basic

Public Function GetFirstDate () As DateTime

Return Value

A .NET DateTime instance indicating the first date.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetLastDate Method
GetFirstVisibleDate Method


MindFusion.Scheduling.WinForms.Calendar.GetFirstVisibleDate Method

Calendar.GetFirstVisibleDate Method

Determines which is the first visible date in the current view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime GetFirstVisibleDate ()
Visual Basic

Public Function GetFirstVisibleDate () As DateTime

Return Value

A .NET DateTime object indicating the first visible date.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetLastVisibleDate Method
GetFirstDate Method


MindFusion.Scheduling.WinForms.Calendar.GetItemAt Method

Calendar.GetItemAt Method

Gets the scheduled Item object displayed at the specified coordinates.

Overload List

Name | Description
Calendar.GetItemAt (Int32, Int32) | Gets the scheduled Item object displayed at the specified coordinates.
Calendar.GetItemAt (Point) | Gets the scheduled Item object displayed at the specified coordinates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetItemAt Method (Int32, Int32)

Calendar.GetItemAt Method (Int32, Int32)
See Also

Gets the scheduled Item object displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Item GetItemAt (
int x,
int y
)
Visual Basic

Public Function GetItemAt ( _
x As Integer, _
y As Integer _
) As Item

Parameters

x
The x-coordinate of the position at which to look for a scheduled item.
y
The y-coordinate of the position at which to look for a scheduled item.

Return Value

The scheduled Item displayed at the specified position.

See Also

GetItemAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetItemAt Method (Point)

Calendar.GetItemAt Method (Point)
See Also

Gets the scheduled Item object displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Item GetItemAt (
Point point
)
Visual Basic

Public Function GetItemAt ( _
point As Point _
) As Item

Parameters

point
The position at which to look for a scheduled item.

Return Value

The scheduled Item displayed at the specified position.

See Also

GetItemAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetResourceAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetItemBounds Method

Calendar.GetItemBounds Method

Retrieves the bounding rectangle of the specified item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Rectangle GetItemBounds (
Item item
)
Visual Basic

Public Function GetItemBounds ( _
item As Item _
) As Rectangle

Parameters

item
A reference to the item whose bounds to retrieve.

Return Value

The visible part of the bounding rectangle of the specified item, expressed in coordinates relative to the control. The return value is Rectangle.Empty if the item is not visible.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetItemListLane Method

Calendar.GetItemListLane Method

Gets the index of the lane of the specified item within a List view whose FreeDrag property is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int GetItemListLane (
Item item
)
Visual Basic

Public Function GetItemListLane ( _
item As Item _
) As Integer

Parameters

item
A reference to the Item whose lane index to retrieve.

Return Value

The zero-based index of the item lane or -1, if the item is not associated with a lane.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
SetItemListLane Method


MindFusion.Scheduling.WinForms.Calendar.GetLastDate Method

Calendar.GetLastDate Method

Gets the last date of the time range displayed in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime GetLastDate ()
Visual Basic

Public Function GetLastDate () As DateTime

Return Value

A .NET DateTime instance indicating the last date.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetFirstDate Method
GetLastVisibleDate Method


MindFusion.Scheduling.WinForms.Calendar.GetLastVisibleDate Method

Calendar.GetLastVisibleDate Method

Determines which is the last visible date in the current view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime GetLastVisibleDate ()
Visual Basic

Public Function GetLastVisibleDate () As DateTime

Return Value

A .NET DateTime object indicating the last visible date.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetLastDate Method
GetFirstVisibleDate Method


MindFusion.Scheduling.WinForms.Calendar.GetListLaneAt Method

Calendar.GetListLaneAt Method

Retrieves the index of the List view lane at the specified point, expressed in client coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int GetListLaneAt (
Point point
)
Visual Basic

Public Function GetListLaneAt ( _
point As Point _
) As Integer

Parameters

point
The point to test, expressed in client coordinates.

Return Value

The zero-based index of the lane at the specified position or -1, if the the point does not lie over a lane.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetLocationAt Method

Calendar.GetLocationAt Method

Gets the Location object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.

Overload List

Name | Description
Calendar.GetLocationAt (Int32, Int32) | Gets the Location object whose schedule is displayed at the specified coordinates.
Calendar.GetLocationAt (Point) | Gets the Location object whose schedule is displayed at the specified position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetLocationAt Method (Int32, Int32)

Calendar.GetLocationAt Method (Int32, Int32)
See Also

Gets the Location object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Location GetLocationAt (
int x,
int y
)
Visual Basic

Public Function GetLocationAt ( _
x As Integer, _
y As Integer _
) As Location

Parameters

x
The x-coordinate of the position at which to look for location's scheduled items.
y
The y-coordinate of the position at which to look for location's scheduled items.

Return Value

An instance of the Location class representing the location related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetLocationAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetContactAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetLocationAt Method (Point)

Calendar.GetLocationAt Method (Point)
See Also

Gets the Location object whose schedule is displayed at the specified position.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Location GetLocationAt (
Point point
)
Visual Basic

Public Function GetLocationAt ( _
point As Point _
) As Location

Parameters

point
The position at which to look for location's scheduled items.

Return Value

An instance of the Location class representing the location related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetLocationAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetContactAt Method
GetTaskAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetResourceAt Method

Calendar.GetResourceAt Method

Gets the Resource object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.

Overload List

Name | Description
Calendar.GetResourceAt (Int32, Int32) | Gets the Resource object whose schedule is displayed at the specified coordinates.
Calendar.GetResourceAt (Point) | Gets the Resource object whose schedule is displayed at the specified coordinates.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetResourceAt Method (Int32, Int32)

Calendar.GetResourceAt Method (Int32, Int32)
See Also

Gets the Resource object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Resource GetResourceAt (
int x,
int y
)
Visual Basic

Public Function GetResourceAt ( _
x As Integer, _
y As Integer _
) As Resource

Parameters

x
The x-coordinate of the position at which to look for resource's scheduled items.
y
The y-coordinate of the position at which to look for resource's scheduled items.

Return Value

An instance of the Resource class representing the resource related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetResourceAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetResourceAt Method (Point)

Calendar.GetResourceAt Method (Point)
See Also

Gets the Resource object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Resource GetResourceAt (
Point point
)
Visual Basic

Public Function GetResourceAt ( _
point As Point _
) As Resource

Parameters

point
The position at which to look for resource's scheduled items.

Return Value

An instance of the Resource class representing the resource related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetResourceAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetContactAt Method
GetLocationAt Method
GetTaskAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetTaskAt Method

Calendar.GetTaskAt Method

Gets the Task object whose schedule is displayed at the specified coordinates. This method can be only be used in views that support grouping.

Overload List

Name | Description
Calendar.GetTaskAt (Int32, Int32) | Gets the Task object whose schedule is displayed at the specified coordinates.
Calendar.GetTaskAt (Point) | Gets the Task object whose schedule is displayed at the specified position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GetTaskAt Method (Int32, Int32)

Calendar.GetTaskAt Method (Int32, Int32)
See Also

Gets the Task object whose schedule is displayed at the specified coordinates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Task GetTaskAt (
int x,
int y
)
Visual Basic

Public Function GetTaskAt ( _
x As Integer, _
y As Integer _
) As Task

Parameters

x
The x-coordinate of the position at which to look for task's scheduled items.
y
The y-coordinate of the position at which to look for task's scheduled items.

Return Value

An instance of the Task class representing the task related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetTaskAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetContactAt Method
GetLocationAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetTaskAt Method (Point)

Calendar.GetTaskAt Method (Point)
See Also

Gets the Task object whose schedule is displayed at the specified position.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Task GetTaskAt (
Point point
)
Visual Basic

Public Function GetTaskAt ( _
point As Point _
) As Task

Parameters

point
The position at which to look for task's scheduled items.

Return Value

An instance of the Task class representing the task related to the scheduled items displayed at the specified position.

Remarks

This method can be only be used in views that support grouping.

See Also

GetTaskAt Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetContactAt Method
GetLocationAt Method
GetResourceAt Method
GetItemAt Method
GetDateAt Method


MindFusion.Scheduling.WinForms.Calendar.GetVisibleItems Method

Calendar.GetVisibleItems Method

Retrieves a collection with all currently visible items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemCollection GetVisibleItems ()
Visual Basic

Public Function GetVisibleItems () As ItemCollection

Return Value

An instance of the ItemCollection class containing all items currently visible within the control. The collection is empty if there are no visible items.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.IsResourceRowExpanded Method

Calendar.IsResourceRowExpanded Method

Checks whether the row associated with the specified Contact, Location, Task or Resource in a Resource view is expanded.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool IsResourceRowExpanded (
Resource reference
)
Visual Basic

Public Function IsResourceRowExpanded ( _
reference As Resource _
) As Boolean

Parameters

reference
A reference to a Contact, Location, Task or Resource object to be checked.

Return Value

Returns true if the associated row is expanded or false if either the row is collapsed, there is no such row or the current view is not a ResourceView.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
CollapseResourceRow Method
ExpandResourceRow Method


MindFusion.Scheduling.WinForms.Calendar.LoadFrom Method (String)

Calendar.LoadFrom Method (String)
See Also

Loads schedule data from the specified file.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void LoadFrom (
string fileName
)
Visual Basic

Public Sub LoadFrom ( _
fileName As String _
)

Parameters

fileName
The name of the file from which to load the schedule.

Remarks

This method loads the schedule data from a file where it was previously saved by a call to SaveTo. Any data contained in the schedule is discarded before the items stored in the file are loaded. This method also attempts to load a previously saved view state.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.LoadFromDataSource Method

Calendar.LoadFromDataSource Method

Loads the schedule from the underlying data source.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void LoadFromDataSource ()
Visual Basic

Public Sub LoadFromDataSource ()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
SaveToDataSource Method


MindFusion.Scheduling.WinForms.Calendar.LoadViewSettings Method (XmlDocument, String)

Calendar.LoadViewSettings Method (XmlDocument, String)
See Also

Loads the view settings under the specified name from the specified XML document.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void LoadViewSettings (
XmlDocument document,
string name
)
Visual Basic

Public Sub LoadViewSettings ( _
document As XmlDocument, _
name As String _
)

Parameters

document
A .NET System.Xml.XmlDocument to load the settings from.
name
The name of the XML element where the settings should be looked for. If the name is null (Nothing in Visual Basic), the name of the control is used as a key.

Remarks

This method restores view settings (such as the item position within a List view whose FreeDrag property is enabled) where they were previously saved by a call to SaveViewSettings.

See Also

LoadViewSettings Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
SaveViewSettings Method


MindFusion.Scheduling.WinForms.Calendar.OnContinuePrinting Method

Calendar.OnContinuePrinting Method

Raises the ContinuePrinting event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnContinuePrinting (
ContinuePrintingEventArgs e
)
Visual Basic

Protected Overridable Sub OnContinuePrinting ( _
e As ContinuePrintingEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnDateClick Method

Calendar.OnDateClick Method

Raises the DateClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnDateClick (
ResourceDateEventArgs e
)
Visual Basic

Protected Overridable Sub OnDateClick ( _
e As ResourceDateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnDraw Method

Calendar.OnDraw Method

Raises the Draw event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnDraw (
CustomDrawArgs e
)
Visual Basic

Protected Overridable Sub OnDraw ( _
e As CustomDrawArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnHiddenItemClick Method

Calendar.OnHiddenItemClick Method

Raises the HiddenItemClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnHiddenItemClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnHiddenItemClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnHScroll Method (EventArgs)

Calendar.OnHScroll Method (EventArgs)
See Also

Raises the HScroll event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnHScroll (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnHScroll ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemClick Method

Calendar.OnItemClick Method

Raises the ItemClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemClick (
ItemMouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemClick ( _
e As ItemMouseEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemCloned Method

Calendar.OnItemCloned Method

Raises the ItemCloned event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemCloned (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemCloned ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemCloning Method

Calendar.OnItemCloning Method

Raises the ItemCloning event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemCloning (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemCloning ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemCreated Method

Calendar.OnItemCreated Method

Raises the ItemCreated event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemCreated (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemCreated ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemCreating Method

Calendar.OnItemCreating Method

Raises the ItemCreating event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemCreating (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemCreating ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemDeleted Method

Calendar.OnItemDeleted Method

Raises the ItemDeleted event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemDeleted (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemDeleted ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemDeleting Method

Calendar.OnItemDeleting Method

Raises the ItemDeleting event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemDeleting (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemDeleting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemDeselecting Method

Calendar.OnItemDeselecting Method

Raises the ItemDeselecting event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemDeselecting (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemDeselecting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemInplaceEdited Method

Calendar.OnItemInplaceEdited Method

Raises the ItemInplaceEdited event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemInplaceEdited (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemInplaceEdited ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemInplaceEditEnding Method

Calendar.OnItemInplaceEditEnding Method

Raises the ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemInplaceEditEnding (
ItemEditConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemInplaceEditEnding ( _
e As ItemEditConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemInplaceEditStarting Method

Calendar.OnItemInplaceEditStarting Method

Raises the ItemInplaceEditStarting event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemInplaceEditStarting (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemInplaceEditStarting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemListLaneChanged Method

Calendar.OnItemListLaneChanged Method

Raises the ItemListLaneChanged event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemListLaneChanged (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemListLaneChanged ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemModificationCanceled Method

Calendar.OnItemModificationCanceled Method

Raises the ItemModificationCanceled event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemModificationCanceled (
ItemEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemModificationCanceled ( _
e As ItemEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemModified Method

Calendar.OnItemModified Method

Raises the ItemModified event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemModified (
ItemModifiedEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemModified ( _
e As ItemModifiedEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemModifying Method

Calendar.OnItemModifying Method

Raises the ItemModifying event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemModifying (
ItemModifyConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemModifying ( _
e As ItemModifyConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemSelecting Method

Calendar.OnItemSelecting Method

Raises the ItemSelecting event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemSelecting (
ItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemSelecting ( _
e As ItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemSelectionChanged Method

Calendar.OnItemSelectionChanged Method

Raises the ItemSelectionChanged event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemSelectionChanged (
ItemSelectionEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemSelectionChanged ( _
e As ItemSelectionEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnItemTooltipDisplaying Method

Calendar.OnItemTooltipDisplaying Method

Raises the ItemTooltipDisplaying event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnItemTooltipDisplaying (
ItemTooltipEventArgs e
)
Visual Basic

Protected Overridable Sub OnItemTooltipDisplaying ( _
e As ItemTooltipEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnKeyPress Method

Calendar.OnKeyPress Method

Control.OnKeyPress override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnKeyPress (
KeyPressEventArgs e
)
Visual Basic

Protected Overridable Sub OnKeyPress ( _
e As KeyPressEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnListViewHeaderClick Method

Calendar.OnListViewHeaderClick Method

Raises the ListViewHeaderClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnListViewHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnListViewHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnLostFocus Method

Calendar.OnLostFocus Method

Control.OnLostFocus override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnLostFocus (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnLostFocus ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMonthHeaderClick Method

Calendar.OnMonthHeaderClick Method

Raises the MonthHeaderClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnMonthHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnMonthHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMonthRangeHeaderClick Method

Calendar.OnMonthRangeHeaderClick Method

Raises the MonthRangeHeaderClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnMonthRangeHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnMonthRangeHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMonthWeekHeaderClick Method

Calendar.OnMonthWeekHeaderClick Method

Raises the MonthWeekHeaderClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnMonthWeekHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnMonthWeekHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMouseDown Method

Calendar.OnMouseDown Method

Control.OnMouseDown override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnMouseDown (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseDown ( _
e As MouseEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMouseMove Method

Calendar.OnMouseMove Method

Control.OnMouseMove override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnMouseMove (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseMove ( _
e As MouseEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnMouseUp Method

Calendar.OnMouseUp Method

Control.OnMouseUp override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnMouseUp (
MouseEventArgs e
)
Visual Basic

Protected Overridable Sub OnMouseUp ( _
e As MouseEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnPaint Method

Calendar.OnPaint Method

Control.OnPaint override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnPaint (
PaintEventArgs pe
)
Visual Basic

Protected Overridable Sub OnPaint ( _
pe As PaintEventArgs _
)

Parameters

pe
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnPaintBackground Method

Calendar.OnPaintBackground Method

Control.OnPaintBackground override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnPaintBackground (
PaintEventArgs pevent
)
Visual Basic

Protected Overridable Sub OnPaintBackground ( _
pevent As PaintEventArgs _
)

Parameters

pevent
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnRecurringItemDeleting Method

Calendar.OnRecurringItemDeleting Method

Raises the RecurringItemDeleting event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnRecurringItemDeleting (
RecurringItemConfirmEventArgs e
)
Visual Basic

Protected Overridable Sub OnRecurringItemDeleting ( _
e As RecurringItemConfirmEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnResize Method

Calendar.OnResize Method

Control.OnResize override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnResize (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnResize ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnResourceViewBottomTimelineClick Method

Calendar.OnResourceViewBottomTimelineClick Method

Raises the ResourceViewBottomTimelineClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnResourceViewBottomTimelineClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnResourceViewBottomTimelineClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnResourceViewMiddleTimelineClick Method

Calendar.OnResourceViewMiddleTimelineClick Method

Raises the ResourceViewMiddleTimelineClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnResourceViewMiddleTimelineClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnResourceViewMiddleTimelineClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnResourceViewRowHeaderClick Method

Calendar.OnResourceViewRowHeaderClick Method

Raises the ResourceViewRowHeaderClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnResourceViewRowHeaderClick (
ResourceDateEventArgs e
)
Visual Basic

Protected Overridable Sub OnResourceViewRowHeaderClick ( _
e As ResourceDateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnResourceViewTopTimelineClick Method

Calendar.OnResourceViewTopTimelineClick Method

Raises the ResourceViewTopTimelineClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnResourceViewTopTimelineClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnResourceViewTopTimelineClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnScroll Method

Calendar.OnScroll Method

Raises the Scroll event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnScroll (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnScroll ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnTimetableColumnHeaderClick Method

Calendar.OnTimetableColumnHeaderClick Method

Raises the TimetableColumnHeaderClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnTimetableColumnHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnTimetableColumnHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnVisibleDateChanged Method

Calendar.OnVisibleDateChanged Method

Raises the VisibleDateChanged event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnVisibleDateChanged (
DateChangedEventArgs e
)
Visual Basic

Protected Overridable Sub OnVisibleDateChanged ( _
e As DateChangedEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnVScroll Method (EventArgs)

Calendar.OnVScroll Method (EventArgs)
See Also

Raises the VScroll event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnVScroll (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnVScroll ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.OnWeekRangeHeaderClick Method

Calendar.OnWeekRangeHeaderClick Method

Raises the WeekRangeHeaderClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnWeekRangeHeaderClick (
DateEventArgs e
)
Visual Basic

Protected Overridable Sub OnWeekRangeHeaderClick ( _
e As DateEventArgs _
)

Parameters

e
An object, containing the event data.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ResetDrag Method

Calendar.ResetDrag Method

If there is a mouse drag operation in progress, it is canceled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void ResetDrag ()
Visual Basic

Public Sub ResetDrag ()

Remarks

Call this method if a message box or a dialog must be displayed in response to various *Click events, but you do not want the control to continue tracking the mouse afterwards.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ResetItemViewState Method

Calendar.ResetItemViewState Method

Resets the view-related item data contained in the underlying schedule. For example, items moved around in a list view with enabled FreeDrag property have their relative positions within the view reset.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void ResetItemViewState ()
Visual Basic

Public Sub ResetItemViewState ()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ResumeDrag Method

Calendar.ResumeDrag Method

Resumes the previously paused mouse drag operation.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void ResumeDrag ()
Visual Basic

Public Sub ResumeDrag ()

Remarks

Use this method in conjunction with the SuspendDrag method to temporarily disable control response to user interactions. The most common scenario where you would use these two methods is when you want to display a modal dialog during user interaction without terminating it.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
SuspendDrag Method


MindFusion.Scheduling.WinForms.Calendar.SaveTo Method (String)

Calendar.SaveTo Method (String)
See Also

Saves the underlying schedule to the specified file.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void SaveTo (
string fileName
)
Visual Basic

Public Sub SaveTo ( _
fileName As String _
)

Parameters

fileName
The path of the file to save to.

Remarks

Saves the schedule data into a XML file. Use LoadFrom to restore the data later. This method also attempts to save the current view state.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.SaveViewSettings Method (XmlDocument, String)

Calendar.SaveViewSettings Method (XmlDocument, String)
See Also

Saves the view settings to the specified XML document under the specified name.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void SaveViewSettings (
XmlDocument document,
string name
)
Visual Basic

Public Sub SaveViewSettings ( _
document As XmlDocument, _
name As String _
)

Parameters

document
A .NET System.Xml.XmlDocument to save the settings to.
name
The name of the XML element where the settings should be saved. If the name is null (Nothing in Visual Basic), the name of the control is used as a key.

Remarks

This method stores the current view settings (such as the item position within a List view whose FreeDrag property is enabled) to the specified document where they can be subsequently restored from by a call to LoadViewSettings.

See Also

SaveViewSettings Method Overload List
Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
LoadViewSettings Method


MindFusion.Scheduling.WinForms.Calendar.SetItemListLane Method

Calendar.SetItemListLane Method

Sets the lane index for the specified item within a List view whose FreeDrag property is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void SetItemListLane (
Item item,
int lane
)
Visual Basic

Public Sub SetItemListLane ( _
item As Item, _
lane As Integer _
)

Parameters

item
A reference to the Item whose lane index to set.
lane
The zero-based index of the new item lane.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
GetItemListLane Method


MindFusion.Scheduling.WinForms.Calendar.StartInplaceEdit Method

Calendar.StartInplaceEdit Method

Starts in-place editing mode for the specified item to let users edit the item's text.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void StartInplaceEdit (
Item item
)
Visual Basic

Public Sub StartInplaceEdit ( _
item As Item _
)

Parameters

item
Specifies which Item should be edited in place.

Remarks

The ItemInplaceEditStarting event is raised to validate the operation, even if entering in-place edit mode programmatically.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.SuspendDrag Method

Calendar.SuspendDrag Method

Temporarily pauses the current mouse drag operation.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void SuspendDrag ()
Visual Basic

Public Sub SuspendDrag ()

Remarks

Use this method in conjunction with the ResumeDrag method to temporarily disable control response to user interactions. The most common scenario where you would use these two methods is when you want to display a modal dialog during user interaction without terminating it.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ResumeDrag Method


MindFusion.Scheduling.WinForms.Calendar.UpdateLayout Method

Calendar.UpdateLayout Method

Updates the position of the calendar's child controls such as buttons and scrollbars.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void UpdateLayout ()
Visual Basic

Public Sub UpdateLayout ()

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar Properties

Calendar Properties

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle.
AllowInplaceCreate | Gets or sets a value indicating whether users are allowed to create items interactively.
AllowInplaceEdit | Gets or sets a value indicating whether users are allowed to edit items interactively.
ButtonOffset | Gets or set the offset of the buttons, displayed in the MonthRange and SingleMonth views' headers.
ButtonSize | Gets or sets the size of the navigation buttons, displayed in the views' headers.
ColorKey | Gets or sets the color key to use when drawing images.
ContactNameFormat | Gets or sets how to format and display contact names in the timetable header.
Contacts | Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.
Culture | Gets or sets the CultureInfo object used to format and display time information in the calendar.
CurrentTime | Gets or sets the current time. When this property is set to DateTime.MinValue, the actual system time is returned.
CurrentView | Gets or sets the type of the calendar view.
CustomDraw | Gets or sets which UI elements of the calendar should be custom drawn.
DataSource | Gets or sets the data source associated with the control.
Date | Gets or sets the date currently displayed in the calendar.
DateTimeFormat | Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.
DayOfWeekStyles | Gets a collection of DayOfWeekStyle objects that allow customizing the appearance of specific days of the week in the calendar.
DayStyles | Gets a collection of DateStyle objects that allow customizing the appearance of specific days in the calendar.
DelayInplaceEdit | Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked.
DragItemsOnDisabledAreas | Gets or sets a value indicating whether to update the position of items dragged over areas which do not allow items.
EnableDragCreate | Gets or sets a value indicating whether items are created merely by dragging in the control.
EnableKeyboard | Gets or sets a value indicating whether the selection can be manipulated through the keyboard.
EnableOptimization | Gets or sets a value indicating whether the control should try to optimize item rendering.
EndDate | Gets or sets the last date displayed in the calendar.
EnsureVisibleSelection | Gets or sets a value indicating whether the selected cells should be automatically brought into view.
FirstWeekendDay | Gets or sets the first weekend day in the calendar.
GroupType | Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views.
HScrollerSmallChange | Gets or sets the small step for the horizontal scroll bar.
HScrollerVisible | Gets or sets a value indicating whether the horizontal scroller should always be visible, always hidden or visible only when it is needed.
HScrollPos | Gets or sets the current horizontal scroll position.
ImageList | Gets or sets the image list associated with the calendar.
InteractiveItemType | Gets or sets the type of an Item derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.
ItemModificationStyle | Gets or sets a value indicating the way items are processed when modified interactively.
ItemScroll | Gets or sets the current scroll position in a List view whose EnableVirtualItemSpace property is set to Enabled.
ItemSelection | Gets a list of all selected items.
ItemSettings | Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.
ListViewSettings | Gets the ListViewSettings object used to customize the visualization of the List view.
Locations | Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.
MinItemLength | Gets or sets the minimal length of interactively created items, expressed in minutes.
MonthRangeSettings | Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.
MonthSettings | Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.
MonthStyles | Gets a collection of DateStyle objects that allow customizing the appearance of specific months in the calendar.
Resources | Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.
ResourceViewSettings | Gets the ResourceViewSettings object used to customize the visualization of a Resource view.
Schedule | Gets or sets the schedule whose information should be displayed inside the calendar control.
ScrollPosition | Gets or sets the current scroll position.
Selection | Gets a Selection object representing the current selection in the calendar.
StartEditAfterModify | Gets or sets a value indicating whether in-place editing of items should automatically start after they are modified interactively.
Tasks | Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.
Theme | Gets or sets the theme applied to the calendar control UI elements.
TimetableSettings | Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.
ToolTip | Gets the underlying ToolTip component.
VScrollerSmallChange | Gets or sets the small step for the vertical scroll bar.
VScrollerVisible | Gets or sets a value indicating whether the vertical scroller should always be visible, always hidden or visible only when it is needed.
VScrollPos | Gets or sets the current vertical scroll position.
WeekRangeSettings | Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

See Also

Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.AllowAutoScroll Property

Calendar.AllowAutoScroll Property

Gets or sets a value indicating whether the control scrolls automatically its contents when users drag items near the edge of the client rectangle.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool AllowAutoScroll { get; set; }
Visual Basic

Public Property AllowAutoScroll As Boolean

Property Value

true to enable automatic scrolling; otherwise, false. The default is true.

Remarks

Automatic scrolling starts when a schedule item or a selection of items is dragged near the borders of the calendar contents rectangle. The contents rectangle is the part of a calendar view that contains all time cells and excludes the headers. If the mouse is moved outside the contents rectangle, the scrolling stops.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.AllowInplaceCreate Property

Calendar.AllowInplaceCreate Property

Gets or sets a value indicating whether users are allowed to create items interactively.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool AllowInplaceCreate { get; set; }
Visual Basic

Public Property AllowInplaceCreate As Boolean

Property Value

true to allow users to create schedule items; otherwise, false. The default is true.

Remarks

If this property is disabled, users cannot create items interactively. If it is enabled and InteractiveItemType is not null (Nothing in Visual Basic), a new schedule item of the specified type is created when users start typing in a time cell. This raises the ItemCreating event, which lets your application validate the operation or cancel it.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
InteractiveItemType Property
AllowInplaceEdit Property


MindFusion.Scheduling.WinForms.Calendar.AllowInplaceEdit Property

Calendar.AllowInplaceEdit Property

Gets or sets a value indicating whether users are allowed to edit items interactively.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool AllowInplaceEdit { get; set; }
Visual Basic

Public Property AllowInplaceEdit As Boolean

Property Value

true to allow users to edit schedule items; otherwise, false. The default is true.

Remarks

If this property is disabled, users cannot edit item's text interactively. Controlling the editing of item text can be done by handling the ItemInplaceEditStarting and ItemInplaceEditEnding events.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
InteractiveItemType Property
AllowInplaceCreate Property


MindFusion.Scheduling.WinForms.Calendar.ButtonOffset Property

Calendar.ButtonOffset Property

Gets or set the offset of the buttons, displayed in the MonthRange and SingleMonth views' headers.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ButtonOffset { get; set; }
Visual Basic

Public Property ButtonOffset As Integer

Property Value

An integer value specifying how many pixels there are between a button and header edges. The default is 4.

Remarks

The buttons get smaller if the value of this property is increased.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ButtonSize Property


MindFusion.Scheduling.WinForms.Calendar.ButtonSize Property

Calendar.ButtonSize Property

Gets or sets the size of the navigation buttons, displayed in the views' headers.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ButtonSize { get; set; }
Visual Basic

Public Property ButtonSize As Integer

Property Value

An integer value specifying the size of the navigation buttons displayed in the List, SingleMonth, MonthRange and Timetable views. The default is 0.

Remarks

The value of this property specifies the absolute size of the navigation buttons. If the value is 0, the size of the buttons is calculated automatically according to the size of the headers that contain them and the value of the ButtonOffset property.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ButtonOffset Property


MindFusion.Scheduling.WinForms.Calendar.ColorKey Property

Calendar.ColorKey Property

Gets or sets the color key to use when drawing images.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Color ColorKey { get; set; }
Visual Basic

Public Property ColorKey As Color

Property Value

Remarks

Use Color.Empty to specify no color key.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ContactNameFormat Property

Calendar.ContactNameFormat Property

Gets or sets how to format and display contact names in the timetable header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string ContactNameFormat { get; set; }
Visual Basic

Public Property ContactNameFormat As String

Property Value

A string specifying the name format. The default is "F M L".

Remarks

Use the capital letters F, M and L as placeholders for the First, Middle and Last names. Any other character will be displayed unchanged.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.Contacts Property

Calendar.Contacts Property

Gets the contacts whose schedule to display when GroupType is set to GroupByContacts.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ContactCollection Contacts { get; }
Visual Basic

Public ReadOnly Property Contacts As ContactCollection

Property Value

An instance of the ContactCollection class specifying which contacts are displayed as columns in timetable, week range and resource views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.Culture Property

Calendar.Culture Property

Gets or sets the CultureInfo object used to format and display time information in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public CultureInfo Culture { get; set; }
Visual Basic

Public Property Culture As CultureInfo

Property Value

An instance of the .NET CultureInfo class.

Remarks

Setting the culture info results in reinitialization of all culture-specific properties, such as day and month names, first day of the week, and so on.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
DateTimeFormat Property


MindFusion.Scheduling.WinForms.Calendar.CurrentTime Property

Calendar.CurrentTime Property

Gets or sets the current time. When this property is set to DateTime.MinValue, the actual system time is returned.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime CurrentTime { get; set; }
Visual Basic

Public Property CurrentTime As DateTime

Property Value

A .NET DateTime object representing the time to use as current.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.CurrentView Property

Calendar.CurrentView Property

Gets or sets the type of the calendar view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public CalendarView CurrentView { get; set; }
Visual Basic

Public Property CurrentView As CalendarView

Property Value

A member of the CalendarView enumeration. The default is SingleMonth.

Remarks

The control can display the schedule data in several different types of views. This property allows changing the current view and can be used to implement drill down into the schedule data by switching from more general to more specialized views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.CustomDraw Property

Calendar.CustomDraw Property

Gets or sets which UI elements of the calendar should be custom drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public CustomDrawElements CustomDraw { get; set; }
Visual Basic

Public Property CustomDraw As CustomDrawElements

Property Value

A combination of CustomDrawElements enumeration members. The default is None.

Remarks

Use the bitwise or operation to combine members of CustomDrawElements specifying which elements of the view must be custom drawn. Handle the Draw event to perform custom drawing.

Example

The following example demonstrates how to use the CustomDraw property in conjunction with the Draw event. The example assumes that calendar references a valid Calendar instance.

The example draws a red ellipse around specific dates in a SingleMonth view.

C#

calendar.CurrentView = CalendarView.SingleMonth;
calendar.CustomDraw = CustomDrawElements.CellHeader;
calendar.Draw += new CustomDraw(calendar_Draw);

// ...

private bool IsHoliday(DateTime date)
{
if (date.Day == 31 && date.Month == 12)
return true;
if (date.Day == 24 && date.Month == 5)
return true;

return false;
}

// ...

private void calendar_Draw(object sender, CustomDrawArgs e)
{
if (e.Element == CustomDrawElements.CellHeader)
{
if (IsHoliday(e.Date))
e.Graphics.DrawEllipse(Pens.Red, e.Bounds);
}
}
Visual Basic

calendar.CurrentView = CalendarView.SingleMonth
calendar.CustomDraw = CustomDrawElements.CellHeader
AddHandler calendar.Draw, AddressOf calendar_Draw

' ...

Private Function IsHoliday(ByVal ddate As DateTime) As Boolean

If ddate.Day = 31 And ddate.Month = 12 Then
Return True
End If

If ddate.Day = 24 And ddate.Month = 5 Then
Return True
End If

Return False

End Function

' ...

Private Sub calendar_Draw(ByVal sender As Object, ByVal e As CustomDrawArgs)

If e.Element = CustomDrawElements.CellHeader Then

If IsHoliday(e.Date) Then
e.Graphics.DrawEllipse(Pens.Red, e.Bounds)
End If

End If

End Sub

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
Draw Event


MindFusion.Scheduling.WinForms.Calendar.DataSource Property

Calendar.DataSource Property

Gets or sets the data source associated with the control.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Object DataSource { get; set; }
Visual Basic

Public Property DataSource As Object

Property Value

An Object representing the data source.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.Date Property

Calendar.Date Property

Gets or sets the date currently displayed in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime Date { get; set; }
Visual Basic

Public Property Date As DateTime

Property Value

A .NET DateTime object. The initial value is DateTime.Today.

Remarks

This value is not used in a timetable view. To specify the dates displayed in timetable view, use TimetableSettings.Dates.

The single month view displays the month containing the specified date. The first month in a month range view is the one containing the specified date. The first day in a day range view is the specified date.

The week range and resource views display all dates in the range defined from this property and the EndDate property.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
EndDate Property
TimetableSettings.Dates Property


MindFusion.Scheduling.WinForms.Calendar.DateTimeFormat Property

Calendar.DateTimeFormat Property

Gets or sets the DateTimeFormatInfo object that specifies how to format and display all dates within the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTimeFormatInfo DateTimeFormat { get; set; }
Visual Basic

Public Property DateTimeFormat As DateTimeFormatInfo

Property Value

An instance of the .NET DateTimeFormatInfo class.

Remarks

If this property is not set, the calendar uses the DateFormatInfo from the associated Culture.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
Culture Property


MindFusion.Scheduling.WinForms.Calendar.DayOfWeekStyles Property

Calendar.DayOfWeekStyles Property

Gets a collection of DayOfWeekStyle objects that allow customizing the appearance of specific days of the week in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DayOfWeekStyleCollection DayOfWeekStyles { get; }
Visual Basic

Public ReadOnly Property DayOfWeekStyles As DayOfWeekStyleCollection

Property Value

An instance of the DayOfWeekStyleCollection class.

Remarks

Add DayOfWeekStyle objects to this collection to specify a distinct style for a day of the week. If several styles are defined for the same day, the one having the highest Priority is used.

Example

The following example demonstrates how to make all weekend days to be colored differently. The example assumes that calendar references an existing Calendar object.

C#

calendar.CurrentView = CalendarView.SingleMonth;

DayOfWeekStyle s;

s = new DayOfWeekStyle();
s.DayOfWeek = DayOfWeek.Saturday;
s.Style = new Style();
s.Style.HeaderBrush = new MindFusion.Drawing.SolidBrush(Color.PaleGreen);
calendar.DayOfWeekStyles.Add(s);

s = new DayOfWeekStyle();
s.DayOfWeek = DayOfWeek.Sunday;
s.Style = new Style();
s.Style.HeaderBrush = new MindFusion.Drawing.SolidBrush(Color.PaleGreen);
calendar.DayOfWeekStyles.Add(s);
Visual Basic

calendar.CurrentView = CalendarView.SingleMonth

Dim s As DayOfWeekStyle s

s = New DayOfWeekStyle()
s.DayOfWeek = DayOfWeek.Saturday
s.Style = New Style()
s.Style.HeaderBrush = New MindFusion.Drawing.SolidBrush(Color.PaleGreen)
calendar.DayOfWeekStyles.Add(s)

s = New DayOfWeekStyle()
s.DayOfWeek = DayOfWeek.Sunday
s.Style = New Style()
s.Style.HeaderBrush = New MindFusion.Drawing.SolidBrush(Color.PaleGreen)
calendar.DayOfWeekStyles.Add(s)

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
DayStyles Property
MonthStyles Property


MindFusion.Scheduling.WinForms.Calendar.DayStyles Property

Calendar.DayStyles Property

Gets a collection of DateStyle objects that allow customizing the appearance of specific days in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateStyleCollection DayStyles { get; }
Visual Basic

Public ReadOnly Property DayStyles As DateStyleCollection

Property Value

An instance of the DateStyleCollection class.

Remarks

Use this collection to assign a distinct style to a day or a range of days, overriding the default style of the current view. If there are several styles defined for the same day, the one with highest Priority is used.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
DayOfWeekStyles Property
MonthStyles Property


MindFusion.Scheduling.WinForms.Calendar.DelayInplaceEdit Property

Calendar.DelayInplaceEdit Property

Gets or sets a value indicating whether the in-place editing of an item is delayed for a second when the item is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool DelayInplaceEdit { get; set; }
Visual Basic

Public Property DelayInplaceEdit As Boolean

Property Value

true to delay in-place editing; otherwise, false. The default is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.DragItemsOnDisabledAreas Property

Calendar.DragItemsOnDisabledAreas Property

Gets or sets a value indicating whether to update the position of items dragged over areas which do not allow items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool DragItemsOnDisabledAreas { get; set; }
Visual Basic

Public Property DragItemsOnDisabledAreas As Boolean

Property Value

true to indicate that the modified items will follow the cursor over areas which do not allow items; otherwise, false.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.EnableDragCreate Property

Calendar.EnableDragCreate Property

Gets or sets a value indicating whether items are created merely by dragging in the control.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool EnableDragCreate { get; set; }
Visual Basic

Public Property EnableDragCreate As Boolean

Property Value

true to enable interactive item creation when the users clicks and drags in the control; false to disable it. The default is false.

Remarks

By default, the items in PocketPlanner are created interactively by selecting a time range in the current view and typing. Setting this property to true overrides this behavior and enables users to create items by clicking and dragging.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.EnableKeyboard Property

Calendar.EnableKeyboard Property

Gets or sets a value indicating whether the selection can be manipulated through the keyboard.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool EnableKeyboard { get; set; }
Visual Basic

Public Property EnableKeyboard As Boolean

Property Value

A Boolean value specifying whether the selection can be modified through the keyboard. The default is true.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.EnableOptimization Property

Calendar.EnableOptimization Property

Gets or sets a value indicating whether the control should try to optimize item rendering.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool EnableOptimization { get; set; }
Visual Basic

Public Property EnableOptimization As Boolean

Property Value

A Boolean value specifying whether item rendering optimization is enabled. The default is false.

Remarks

Turning this flag on will increase repainting speed at the cost of memory.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.EndDate Property

Calendar.EndDate Property

Gets or sets the last date displayed in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime EndDate { get; set; }
Visual Basic

Public Property EndDate As DateTime

Property Value

A .NET DateTime object. The initial value is set 30 days after Date.

Remarks

This member is only valid in WeekRange and Resource views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
Date Property


MindFusion.Scheduling.WinForms.Calendar.EnsureVisibleSelection Property

Calendar.EnsureVisibleSelection Property

Gets or sets a value indicating whether the selected cells should be automatically brought into view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool EnsureVisibleSelection { get; set; }
Visual Basic

Public Property EnsureVisibleSelection As Boolean

Property Value

A Boolean value specifying whether the control should automatically scroll when the user selects cells outside of the current viewport (by using the keyboard for example).

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.FirstWeekendDay Property

Calendar.FirstWeekendDay Property

Gets or sets the first weekend day in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DayOfWeek FirstWeekendDay { get; set; }
Visual Basic

Public Property FirstWeekendDay As DayOfWeek

Property Value

A member of the .NET DayOfWeek enumeration.

Remarks

Specifies which day to regard as start of the weekend.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.GroupType Property

Calendar.GroupType Property

Gets or sets the grouping criteria for the Timetable, WeekRange, List and Resource views.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public GroupType GroupType { get; set; }
Visual Basic

Public Property GroupType As GroupType

Property Value

A member of the GroupType enumeration. The default is None.

Remarks

See the Timetable View topic for more information regarding grouping.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.HScrollerSmallChange Property

Calendar.HScrollerSmallChange Property

Gets or sets the small step for the horizontal scroll bar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int HScrollerSmallChange { get; set; }
Visual Basic

Public Property HScrollerSmallChange As Integer

Property Value

An integer value representing the small step of the horizontal scroll bar.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
VScrollerSmallChange Property


MindFusion.Scheduling.WinForms.Calendar.HScrollerVisible Property

Calendar.HScrollerVisible Property

Gets or sets a value indicating whether the horizontal scroller should always be visible, always hidden or visible only when it is needed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State HScrollerVisible { get; set; }
Visual Basic

Public Property HScrollerVisible As State

Property Value

A member of the State enumeration specifying the visibility state of the horizontal scroller.

Remarks

Specify Disabled for this property to always hide the scroller, Enabled to always show it and Unspecified to let the Calendar control decide when to show the scroller.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
VScrollerVisible Property


MindFusion.Scheduling.WinForms.Calendar.HScrollPos Property

Calendar.HScrollPos Property

Gets or sets the current horizontal scroll position.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int HScrollPos { get; set; }
Visual Basic

Public Property HScrollPos As Integer

Property Value

An integer value specifying the current horizontal scroll position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
VScrollPos Property
ScrollPosition Property


MindFusion.Scheduling.WinForms.Calendar.ImageList Property

Calendar.ImageList Property

Gets or sets the image list associated with the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ImageList ImageList { get; set; }
Visual Basic

Public Property ImageList As ImageList

Property Value

An instance of the .NET ImageList class. The default is null (Nothing in Visual Basic).

Remarks

The value of each Style.ImageIndex is an index within this list.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.InteractiveItemType Property

Calendar.InteractiveItemType Property

Gets or sets the type of an Item derived class whose instance should be created when a user starts typing while the calendar control has the keyboard focus.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Type InteractiveItemType { get; set; }
Visual Basic

Public Property InteractiveItemType As Type

Property Value

An instance of the .NET Type class specifying what type of items to create when a user starts typing. The default is Appointment.

Remarks

If this property is set to null (Nothing in Visual Basic), users cannot create items interactively.

Note

If you implement custom Item derived class, make sure it provides parameterless constructor. Otherwise, no items will be created.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
AllowInplaceEdit Property


MindFusion.Scheduling.WinForms.Calendar.ItemModificationStyle Property

Calendar.ItemModificationStyle Property

Gets or sets a value indicating the way items are processed when modified interactively.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemModificationStyle ItemModificationStyle { get; set; }
Visual Basic

Public Property ItemModificationStyle As ItemModificationStyle

Property Value

A member of the ItemModificationStyle enumeration. The default is InPlace.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemScroll Property

Calendar.ItemScroll Property

Gets or sets the current scroll position in a List view whose EnableVirtualItemSpace property is set to Enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ItemScroll { get; set; }
Visual Basic

Public Property ItemScroll As Integer

Property Value

An integer value specifying the current scroll bar position.

Remarks

The value of this property equals the HScrollPos value in a vertical list view or the VScrollPos value in a horizontal list view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemSelection Property

Calendar.ItemSelection Property

Gets a list of all selected items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemSelection ItemSelection { get; }
Visual Basic

Public ReadOnly Property ItemSelection As ItemSelection

Property Value

An instance of the ItemSelection class representing the currently selected items.

Remarks

Use Selection to get the collection of all selected time cells.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
Selection Property


MindFusion.Scheduling.WinForms.Calendar.ItemSettings Property

Calendar.ItemSettings Property

Gets the ItemSettings object used to customize the visualization of schedule items in all calendar views.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemSettings ItemSettings { get; }
Visual Basic

Public ReadOnly Property ItemSettings As ItemSettings

Property Value

An instance of the ItemSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ListViewSettings Property

Calendar.ListViewSettings Property

Gets the ListViewSettings object used to customize the visualization of the List view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ListViewSettings ListViewSettings { get; }
Visual Basic

Public ReadOnly Property ListViewSettings As ListViewSettings

Property Value

An instance of the ListViewSettings class.

Remarks

Use the ListViewSettings members to customize the appearance of the calendar when CurrentView is set to List.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.Locations Property

Calendar.Locations Property

Gets the locations whose schedule to display in the timetable when GroupType is set to GroupByLocations.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public LocationCollection Locations { get; }
Visual Basic

Public ReadOnly Property Locations As LocationCollection

Property Value

An instance of the LocationCollection class specifying which locations are displayed as columns in a grouped view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.MinItemLength Property

Calendar.MinItemLength Property

Gets or sets the minimal length of interactively created items, expressed in minutes.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MinItemLength { get; set; }
Visual Basic

Public Property MinItemLength As Integer

Property Value

A non-negative integer value.

Remarks

Specify 0 for no item length restrictions.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthRangeSettings Property

Calendar.MonthRangeSettings Property

Gets the MonthRangeSettings object used to customize the visualization of a month range in the MonthRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public MonthRangeSettings MonthRangeSettings { get; }
Visual Basic

Public ReadOnly Property MonthRangeSettings As MonthRangeSettings

Property Value

An instance of the MonthRangeSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthSettings Property

Calendar.MonthSettings Property

Gets the MonthSettings object used to customize the visualization of months in the MonthRange and SingleMonth views.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public MonthSettings MonthSettings { get; }
Visual Basic

Public ReadOnly Property MonthSettings As MonthSettings

Property Value

An instance of the MonthSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthStyles Property

Calendar.MonthStyles Property

Gets a collection of DateStyle objects that allow customizing the appearance of specific months in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateStyleCollection MonthStyles { get; }
Visual Basic

Public ReadOnly Property MonthStyles As DateStyleCollection

Property Value

An instance of the DateStyleCollection class.

Remarks

Use this collection to assign a distinct style to a month or a range of months, overriding the default style of the current view. If there are several styles defined for the same month, the one with highest Priority is used.

Example

The following example creates a custom style for the current month. The example assumes that calendar references existing Calendar control.

C#

// Create the custom date style
DateStyle dateStyle = new DateStyle();

// Change the brush used to fill the header contents
dateStyle.Style.HeaderBrush =
new MindFusion.Drawing.LinearGradientBrush(
Color.LightSteelBlue, Color.SteelBlue, 90);

// Set the time range of the style to span the whole month
DateTime today = DateTime.Today;
dateStyle.From = new DateTime(today.Year, today.Month, 1);
dateStyle.To = new DateTime(today.Year, today.Month,
DateTime.DaysInMonth(today.Year, today.Month));

// Add the style
calendar.MonthStyles.Add(dateStyle);
Visual Basic

' Create the custom date style
Dim dateStyle As New DateStyle()

' Change the brush used to fill the header contents
dateStyle.Style.HeaderBrush = _
New MindFusion.Drawing.LinearGradientBrush( _
Color.LightSteelBlue, Color.SteelBlue, 90)

' Set the time range of the style to span the whole month
Dim today As DateTime = DateTime.Today
dateStyle.From = New DateTime(today.Year, today.Month, 1)
dateStyle.To = New DateTime(today.Year, today.Month, _
DateTime.DaysInMonth(today.Year, today.Month))

' Add the style
calendar.MonthStyles.Add(dateStyle)

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
DayStyles Property
DayOfWeekStyles Property


MindFusion.Scheduling.WinForms.Calendar.Resources Property

Calendar.Resources Property

Gets the resources whose schedule to display in the control when GroupType is set to GroupByResources.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ResourceCollection Resources { get; }
Visual Basic

Public ReadOnly Property Resources As ResourceCollection

Property Value

An instance of the ResourceCollection class specifying which resources are displayed as columns in timetable, week range and resource views.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ResourceViewSettings Property

Calendar.ResourceViewSettings Property

Gets the ResourceViewSettings object used to customize the visualization of a Resource view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ResourceViewSettings ResourceViewSettings { get; }
Visual Basic

Public ReadOnly Property ResourceViewSettings As ResourceViewSettings

Property Value

An instance of the ResourceViewSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.Schedule Property

Calendar.Schedule Property

Gets or sets the schedule whose information should be displayed inside the calendar control.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Schedule Schedule { get; set; }
Visual Basic

Public Property Schedule As Schedule

Property Value

An Schedule object providing the schedule data displayed in the calendar view.

Remarks

You can easily substitute the schedule being displayed by the control at any time by simply assigning a new Schedule object to this property. You can also make two or more PocketPlanner controls display the same schedule.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
Schedule Class


MindFusion.Scheduling.WinForms.Calendar.ScrollPosition Property

Calendar.ScrollPosition Property

Gets or sets the current scroll position.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Point ScrollPosition { get; set; }
Visual Basic

Public Property ScrollPosition As Point

Property Value

A .NET Point object specifying the scroll position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
HScrollPos Property
VScrollPos Property


MindFusion.Scheduling.WinForms.Calendar.Selection Property

Calendar.Selection Property

Gets a Selection object representing the current selection in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Selection Selection { get; }
Visual Basic

Public ReadOnly Property Selection As Selection

Property Value

An instance of the Selection class representing the selection of time cells.

Remarks

Use ItemSelection to get the selection of schedule items.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemSelection Property


MindFusion.Scheduling.WinForms.Calendar.StartEditAfterModify Property

Calendar.StartEditAfterModify Property

Gets or sets a value indicating whether in-place editing of items should automatically start after they are modified interactively.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool StartEditAfterModify { get; set; }
Visual Basic

Public Property StartEditAfterModify As Boolean

Property Value

true to enable automatic in-place editing after item modification; false to disable it. The default is false.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.Tasks Property

Calendar.Tasks Property

Gets the tasks whose schedule to display in the control when GroupType is set to GroupByTasks.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TaskCollection Tasks { get; }
Visual Basic

Public ReadOnly Property Tasks As TaskCollection

Property Value

An instance of the TaskCollection class specifying which tasks are displayed as columns in a grouped view.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.Theme Property

Calendar.Theme Property

Gets or sets the theme applied to the calendar control UI elements.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ThemeType Theme { get; set; }
Visual Basic

Public Property Theme As ThemeType

Property Value

A member of the ThemeType enumeration.

Remarks

You cannot specify the value Custom for this property. In order to apply a custom theme, either assign the theme to the CustomTheme property of the Calendar control or pass it as an argument to the ApplyTheme method.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ApplyTheme Method


MindFusion.Scheduling.WinForms.Calendar.TimetableSettings Property

Calendar.TimetableSettings Property

Gets the TimetableSettings object used to customize the visualization of days and hours in Timetable view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimetableSettings TimetableSettings { get; }
Visual Basic

Public ReadOnly Property TimetableSettings As TimetableSettings

Property Value

An instance of the TimetableSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ToolTip Property

Calendar.ToolTip Property

Gets the underlying ToolTip component.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ToolTip ToolTip { get; }
Visual Basic

Public ReadOnly Property ToolTip As ToolTip

Property Value

An instance of the .NET ToolTip class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.VScrollerSmallChange Property

Calendar.VScrollerSmallChange Property

Gets or sets the small step for the vertical scroll bar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int VScrollerSmallChange { get; set; }
Visual Basic

Public Property VScrollerSmallChange As Integer

Property Value

An integer value representing the small step of the vertical scroll bar.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
HScrollerSmallChange Property


MindFusion.Scheduling.WinForms.Calendar.VScrollerVisible Property

Calendar.VScrollerVisible Property

Gets or sets a value indicating whether the vertical scroller should always be visible, always hidden or visible only when it is needed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State VScrollerVisible { get; set; }
Visual Basic

Public Property VScrollerVisible As State

Property Value

A member of the State enumeration specifying the visibility state of the horizontal scroller.

Remarks

Specify Disabled for this property to always hide the scroller, Enabled to always show it and Unspecified to let the Calendar control decide when to show the scroller.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
HScrollerVisible Property


MindFusion.Scheduling.WinForms.Calendar.VScrollPos Property

Calendar.VScrollPos Property

Gets or sets the current vertical scroll position.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int VScrollPos { get; set; }
Visual Basic

Public Property VScrollPos As Integer

Property Value

An integer value specifying the current vertical scroll position.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
HScrollPos Property
ScrollPosition Property


MindFusion.Scheduling.WinForms.Calendar.WeekRangeSettings Property

Calendar.WeekRangeSettings Property

Gets the WeekRangeSettings object used to customize the visualization of weeks in a WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public WeekRangeSettings WeekRangeSettings { get; }
Visual Basic

Public ReadOnly Property WeekRangeSettings As WeekRangeSettings

Property Value

An instance of the WeekRangeSettings class.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar Events

Calendar Events

Public Events

Name | Description
ContinuePrinting | Occurs at the end of a printing operation to enable users to continue printing the calendar with different view settings.
DateClick | Raised when the user clicks a date cell in the calendar.
Draw | Raised to allow custom drawing of calendar UI elements.
HiddenItemClick | Raised when a hidden items cue icon is clicked.
HScroll | Raised when the control has been scrolled horizontally.
ItemClick | Raised when the user clicks a schedule item.
ItemCreated | Raised when a schedule item is created by the user.
ItemCreating | Raised when the user is about to create a new schedule item.
ItemDeleted | Raised when the user deletes a schedule item.
ItemDeleting | Raised when the user is about to delete a schedule item.
ItemDeselecting | Raised when an item is about to be deselected.
ItemInplaceEdited | Raised when item's text is in-place edited.
ItemInplaceEditEnding | Raised when in-place editing of item's text is about to be accepted.
ItemInplaceEditStarting | Raised when in-place editing of item's text is about to begin.
ItemListLaneChanged | Raised when the lane index of an item within a List view has changed.
ItemModificationCanceled | Raised when an item modification is canceled by the user.
ItemModified | Raised when a schedule item is moved or resized by the user.
ItemModifying | Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.
ItemSelecting | Raised when an item is about to be selected.
ItemSelectionChanged | Raised when an item is selected or deselected.
ListViewHeaderClick | Raised when the header of a List view is clicked.
MonthHeaderClick | Raised when the header of a Month view is clicked.
MonthRangeHeaderClick | Raised when the header of an MonthRange view is clicked.
MonthWeekHeaderClick | Raised when a cell in the week header of a Month view is clicked.
RecurringItemDeleting | Raised when the user is about to delete a recurring item.
ResourceViewBottomTimelineClick | Raised when the bottom timeline of a Resource view is clicked.
ResourceViewMiddleTimelineClick | Raised when the middle timeline of a Resource view is clicked.
ResourceViewRowHeaderClick | Raised when the header of a Resource view row is clicked.
ResourceViewTopTimelineClick | Raised when the top timeline of a Resource view is clicked.
Scroll | Raised when the value of a scrollbar has changed.
TimetableColumnHeaderClick | Raised when the header of a Timetable column is clicked.
VisibleDateChanged | Raised when the user selects another date using the month or year navigation controls on the calendar header area.
VScroll | Raised when the control has been scrolled vertically.
WeekRangeHeaderClick | Raised when the header of a WeekRange view is clicked.

See Also

Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ContinuePrinting Event

Calendar.ContinuePrinting Event

Occurs at the end of a printing operation to enable users to continue printing the calendar with different view settings.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ContinuePrintingEventHandler ContinuePrinting
Visual Basic

Public ContinuePrinting As ContinuePrintingEventHandler

Event Data

ContinuePrinting event handlers receive an argument of type ContinuePrintingEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.DateClick Event

Calendar.DateClick Event

Raised when the user clicks a date cell in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ResourceDateEventHandler DateClick
Visual Basic

Public DateClick As ResourceDateEventHandler

Event Data

DateClick event handlers receive an argument of type ResourceDateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.Draw Event

Calendar.Draw Event

Raised to allow custom drawing of calendar UI elements.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public CustomDraw Draw
Visual Basic

Public Draw As CustomDraw

Event Data

Draw event handlers receive an argument of type CustomDrawArgs.

Remarks

This event is raised if the CustomDraw property is set to a value different than None.

Example

The following example demonstrates how to use the CustomDraw property in conjunction with the Draw event. The example assumes that calendar references a valid Calendar instance.

The example draws a red ellipse around specific dates in a SingleMonth view.

C#

calendar.CurrentView = CalendarView.SingleMonth;
calendar.CustomDraw = CustomDrawElements.CellHeader;
calendar.Draw += new CustomDraw(calendar_Draw);

// ...

private bool IsHoliday(DateTime date)
{
if (date.Day == 31 && date.Month == 12)
return true;
if (date.Day == 24 && date.Month == 5)
return true;

return false;
}

// ...

private void calendar_Draw(object sender, CustomDrawArgs e)
{
if (e.Element == CustomDrawElements.CellHeader)
{
if (IsHoliday(e.Date))
e.Graphics.DrawEllipse(Pens.Red, e.Bounds);
}
}
Visual Basic

calendar.CurrentView = CalendarView.SingleMonth
calendar.CustomDraw = CustomDrawElements.CellHeader
AddHandler calendar.Draw, AddressOf calendar_Draw

' ...

Private Function IsHoliday(ByVal ddate As DateTime) As Boolean

If ddate.Day = 31 And ddate.Month = 12 Then
Return True
End If

If ddate.Day = 24 And ddate.Month = 5 Then
Return True
End If

Return False

End Function

' ...

Private Sub calendar_Draw(ByVal sender As Object, ByVal e As CustomDrawArgs)

If e.Element = CustomDrawElements.CellHeader Then

If IsHoliday(e.Date) Then
e.Graphics.DrawEllipse(Pens.Red, e.Bounds)
End If

End If

End Sub

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.HiddenItemClick Event

Calendar.HiddenItemClick Event

Raised when a hidden items cue icon is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateEventHandler HiddenItemClick
Visual Basic

Public HiddenItemClick As DateEventHandler

Event Data

HiddenItemClick event handlers receive an argument of type DateEventArgs.

Remarks

The hidden items cue is displayed when there are schedule items included in the time range of the current calendar view, but not currently visible because of insufficient space.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemClick Event


MindFusion.Scheduling.WinForms.Calendar.HScroll Event

Calendar.HScroll Event

Raised when the control has been scrolled horizontally.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ScrollEventHandler HScroll
Visual Basic

Public HScroll As ScrollEventHandler

Event Data

HScroll event handlers receive an argument of type ScrollEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
VScroll Event
Scroll Event


MindFusion.Scheduling.WinForms.Calendar.ItemClick Event

Calendar.ItemClick Event

Raised when the user clicks a schedule item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemMouseEventHandler ItemClick
Visual Basic

Public ItemClick As ItemMouseEventHandler

Event Data

ItemClick event handlers receive an argument of type ItemMouseEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
HiddenItemClick Event


MindFusion.Scheduling.WinForms.Calendar.ItemCreated Event

Calendar.ItemCreated Event

Raised when a schedule item is created by the user.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemEventHandler ItemCreated
Visual Basic

Public ItemCreated As ItemEventHandler

Event Data

ItemCreated event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemCreating Event


MindFusion.Scheduling.WinForms.Calendar.ItemCreating Event

Calendar.ItemCreating Event

Raised when the user is about to create a new schedule item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemConfirmEventHandler ItemCreating
Visual Basic

Public ItemCreating As ItemConfirmEventHandler

Event Data

ItemCreating event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemCreated Event


MindFusion.Scheduling.WinForms.Calendar.ItemDeleted Event

Calendar.ItemDeleted Event

Raised when the user deletes a schedule item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemEventHandler ItemDeleted
Visual Basic

Public ItemDeleted As ItemEventHandler

Event Data

ItemDeleted event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemDeleting Event


MindFusion.Scheduling.WinForms.Calendar.ItemDeleting Event

Calendar.ItemDeleting Event

Raised when the user is about to delete a schedule item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemConfirmEventHandler ItemDeleting
Visual Basic

Public ItemDeleting As ItemConfirmEventHandler

Event Data

ItemDeleting event handlers receive an argument of type ItemConfirmEventArgs.

Remarks

This event can be used to prevent users from deleting specific non-recurring items by pressing DEL. This event is raised once for each element of the item selection. To control the deletion of recurring items, handle the RecurringItemDeleting event.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemDeleted Event


MindFusion.Scheduling.WinForms.Calendar.ItemDeselecting Event

Calendar.ItemDeselecting Event

Raised when an item is about to be deselected.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemConfirmEventHandler ItemDeselecting
Visual Basic

Public ItemDeselecting As ItemConfirmEventHandler

Event Data

ItemDeselecting event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemSelecting Event


MindFusion.Scheduling.WinForms.Calendar.ItemInplaceEdited Event

Calendar.ItemInplaceEdited Event

Raised when item's text is in-place edited.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemEventHandler ItemInplaceEdited
Visual Basic

Public ItemInplaceEdited As ItemEventHandler

Event Data

ItemInplaceEdited event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemInplaceEditStarting Event
ItemInplaceEditEnding Event


MindFusion.Scheduling.WinForms.Calendar.ItemInplaceEditEnding Event

Calendar.ItemInplaceEditEnding Event

Raised when in-place editing of item's text is about to be accepted.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemEditConfirmEventHandler ItemInplaceEditEnding
Visual Basic

Public ItemInplaceEditEnding As ItemEditConfirmEventHandler

Event Data

ItemInplaceEditEnding event handlers receive an argument of type ItemEditConfirmEventArgs.

Remarks

This event can be used to validate the text entered into a schedule item during the in-place editing mode.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemInplaceEditStarting Event
ItemInplaceEdited Event


MindFusion.Scheduling.WinForms.Calendar.ItemInplaceEditStarting Event

Calendar.ItemInplaceEditStarting Event

Raised when in-place editing of item's text is about to begin.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemConfirmEventHandler ItemInplaceEditStarting
Visual Basic

Public ItemInplaceEditStarting As ItemConfirmEventHandler

Event Data

ItemInplaceEditStarting event handlers receive an argument of type ItemConfirmEventArgs.

Remarks

This event can be handled to prevent users from editing the text of specific schedule items.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemInplaceEditEnding Event
ItemInplaceEdited Event


MindFusion.Scheduling.WinForms.Calendar.ItemListLaneChanged Event

Calendar.ItemListLaneChanged Event

Raised when the lane index of an item within a List view has changed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemEventHandler ItemListLaneChanged
Visual Basic

Public ItemListLaneChanged As ItemEventHandler

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ItemModificationCanceled Event

Calendar.ItemModificationCanceled Event

Raised when an item modification is canceled by the user.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemEventHandler ItemModificationCanceled
Visual Basic

Public ItemModificationCanceled As ItemEventHandler

Event Data

ItemModificationCanceled event handlers receive an argument of type ItemEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemModified Event
ItemModifying Event


MindFusion.Scheduling.WinForms.Calendar.ItemModified Event

Calendar.ItemModified Event

Raised when a schedule item is moved or resized by the user.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemModifiedEventHandler ItemModified
Visual Basic

Public ItemModified As ItemModifiedEventHandler

Event Data

ItemModified event handlers receive an argument of type ItemModifiedEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemModifying Event
ItemModificationCanceled Event


MindFusion.Scheduling.WinForms.Calendar.ItemModifying Event

Calendar.ItemModifying Event

Raised when the user moves or resizes a schedule item, which would change the item's scheduled start or end date and time.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemModifyConfirmEventHandler ItemModifying
Visual Basic

Public ItemModifying As ItemModifyConfirmEventHandler

Event Data

ItemModifying event handlers receive an argument of type ItemModifyConfirmEventArgs.

Remarks

This event can be used to prevent users from modifying an item interactively.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemModified Event
ItemModificationCanceled Event


MindFusion.Scheduling.WinForms.Calendar.ItemSelecting Event

Calendar.ItemSelecting Event

Raised when an item is about to be selected.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemConfirmEventHandler ItemSelecting
Visual Basic

Public ItemSelecting As ItemConfirmEventHandler

Event Data

ItemSelecting event handlers receive an argument of type ItemConfirmEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemDeselecting Event


MindFusion.Scheduling.WinForms.Calendar.ItemSelectionChanged Event

Calendar.ItemSelectionChanged Event

Raised when an item is selected or deselected.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemSelectionEventHandler ItemSelectionChanged
Visual Basic

Public ItemSelectionChanged As ItemSelectionEventHandler

Event Data

ItemSelectionChanged event handlers receive an argument of type ItemSelectionEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ItemSelectionComplete Event


MindFusion.Scheduling.WinForms.Calendar.ListViewHeaderClick Event

Calendar.ListViewHeaderClick Event

Raised when the header of a List view is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateEventHandler ListViewHeaderClick
Visual Basic

Public ListViewHeaderClick As DateEventHandler

Event Data

ListViewHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthHeaderClick Event

Calendar.MonthHeaderClick Event

Raised when the header of a Month view is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateEventHandler MonthHeaderClick
Visual Basic

Public MonthHeaderClick As DateEventHandler

Event Data

MonthHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
MonthWeekHeaderClick Event


MindFusion.Scheduling.WinForms.Calendar.MonthRangeHeaderClick Event

Calendar.MonthRangeHeaderClick Event

Raised when the header of an MonthRange view is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateEventHandler MonthRangeHeaderClick
Visual Basic

Public MonthRangeHeaderClick As DateEventHandler

Event Data

MonthRangeHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.MonthWeekHeaderClick Event

Calendar.MonthWeekHeaderClick Event

Raised when a cell in the week header of a Month view is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateEventHandler MonthWeekHeaderClick
Visual Basic

Public MonthWeekHeaderClick As DateEventHandler

Event Data

MonthWeekHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
MonthHeaderClick Event


MindFusion.Scheduling.WinForms.Calendar.RecurringItemDeleting Event

Calendar.RecurringItemDeleting Event

Raised when the user is about to delete a recurring item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public RecurringItemConfirmEventHandler RecurringItemDeleting
Visual Basic

Public RecurringItemDeleting As RecurringItemConfirmEventHandler

Event Data

RecurringItemDeleting event handlers receive an argument of type RecurringItemConfirmEventArgs.

Remarks

This event can be used to prevent the deletion of recurring items. For non-recurring items, handle the ItemDeleting event.

Example

The following example demonstrates how to use RecurringItemDeleting event to ask the user whether he or she wants to delete all items of a recurring pattern or only the selected item(s). The example assumes that calendar already references a Calendar control. The method ConfirmDelete is supposed to return 0 if the user cancels the deletion of the item, 1 if the user chooses that only the selected item is to be deleted, and 2 if the user wants to delete the entire pattern.

C#

// Attach a handler to the event
calendar.RecurringItemDeleting +=
new RecurringItemConfirmEventHandler(calendar_RecurringItemDeleting);

// ...

private void calendar_RecurringItemDeleting(object sender, RecurringItemConfirmEventArgs e)
{
int result = ConfirmDelete(e.Item);

switch (result)
{

case 0:
// Do nothing
break;

case 1:
e.ConfirmOccurrence = true;
break;

case 2:
e.ConfirmAll = true;
break;

}
}
Visual Basic

' Attach a handler to the event
AddHandler calendar.RecurringItemDeleting, AddressOf calendar_RecurringItemDeleting

' ...

Private Sub calendar_RecurringItemDeleting(ByVal sender As Object, ByVal e As RecurringItemConfirmEventArgs)

Dim result As Integer = ConfirmDelete(e.Item)

Select Case result

Case 0
' Do nothing

Case 1
e.ConfirmOccurrence = True

Case 2
e.ConfirmAll = True

End Select

End Sub

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ResourceViewBottomTimelineClick Event

Calendar.ResourceViewBottomTimelineClick Event

Raised when the bottom timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateEventHandler ResourceViewBottomTimelineClick
Visual Basic

Public ResourceViewBottomTimelineClick As DateEventHandler

Event Data

ResourceViewBottomTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ResourceViewMiddleTimelineClick Event
ResourceViewTopTimelineClick Event


MindFusion.Scheduling.WinForms.Calendar.ResourceViewMiddleTimelineClick Event

Calendar.ResourceViewMiddleTimelineClick Event

Raised when the middle timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateEventHandler ResourceViewMiddleTimelineClick
Visual Basic

Public ResourceViewMiddleTimelineClick As DateEventHandler

Event Data

ResourceViewMiddleTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ResourceViewBottomTimelineClick Event
ResourceViewTopTimelineClick Event


MindFusion.Scheduling.WinForms.Calendar.ResourceViewRowHeaderClick Event

Calendar.ResourceViewRowHeaderClick Event

Raised when the header of a Resource view row is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ResourceDateEventHandler ResourceViewRowHeaderClick
Visual Basic

Public ResourceViewRowHeaderClick As ResourceDateEventHandler

Event Data

ResourceViewRowHeaderClick event handlers receive an argument of type ResourceDateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.ResourceViewTopTimelineClick Event

Calendar.ResourceViewTopTimelineClick Event

Raised when the top timeline of a Resource view is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateEventHandler ResourceViewTopTimelineClick
Visual Basic

Public ResourceViewTopTimelineClick As DateEventHandler

Event Data

ResourceViewTopTimelineClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
ResourceViewBottomTimelineClick Event
ResourceViewMiddleTimelineClick Event


MindFusion.Scheduling.WinForms.Calendar.Scroll Event

Calendar.Scroll Event

Raised when the value of a scrollbar has changed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public EventHandler Scroll
Visual Basic

Public Scroll As EventHandler

Event Data

Scroll event handlers receive an argument of type EventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
HScroll Event
VScroll Event


MindFusion.Scheduling.WinForms.Calendar.TimetableColumnHeaderClick Event

Calendar.TimetableColumnHeaderClick Event

Raised when the header of a Timetable column is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateEventHandler TimetableColumnHeaderClick
Visual Basic

Public TimetableColumnHeaderClick As DateEventHandler

Event Data

TimetableColumnHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.VisibleDateChanged Event

Calendar.VisibleDateChanged Event

Raised when the user selects another date using the month or year navigation controls on the calendar header area.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateChangedEventHandler VisibleDateChanged
Visual Basic

Public VisibleDateChanged As DateChangedEventHandler

Event Data

VisibleDateChanged event handlers receive an argument of type DateChangedEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.VScroll Event

Calendar.VScroll Event

Raised when the control has been scrolled vertically.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ScrollEventHandler VScroll
Visual Basic

Public VScroll As ScrollEventHandler

Event Data

VScroll event handlers receive an argument of type ScrollEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace
HScroll Event
Scroll Event


MindFusion.Scheduling.WinForms.Calendar.WeekRangeHeaderClick Event

Calendar.WeekRangeHeaderClick Event

Raised when the header of a WeekRange view is clicked.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateEventHandler WeekRangeHeaderClick
Visual Basic

Public WeekRangeHeaderClick As DateEventHandler

Event Data

WeekRangeHeaderClick event handlers receive an argument of type DateEventArgs.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CalendarElement Enumeration

CalendarElement Enumeration

Specifies a calendar subelement.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum CalendarElement
Visual Basic

Public Enumeration CalendarElement

Members

Member name | Description
Cell | A cell in a SingleMonth, MonthRange, WeekRange or List view.
MonthWeek | The week header in a SingleMonth and MonthRange view.
ResourceViewBottomTimeline | The bottom timeline in a Resource view.
ResourceViewCell | A cell in a Resource view.
ResourceViewHeader | The row header in a Resource view.
ResourceViewMiddleTimeline | The middle timeline in a Resource view.
ResourceViewTopTimeline | The topmost timeline in a Resource view.
TimetableCell | A cell in a Timetable view.
TimetableColumnHeader | The header of a Timetable view column. This might be the header displaying the column date, if no grouping is enabled, or the header displaying the referenced contact or location if grouping is enabled.
TimetableDayHeader | The all-day header in a Timetable view.
TimetableGroupHeader | The group header in a Timetable view. Only available when grouping is enabled.
TimetableInfoHeader | The info header in a Timetable view.
TimetableTimeline | The timeline in a Timetable view.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CalendarView Enumeration

CalendarView Enumeration

Specifies the type of view to display in a calendar control.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum CalendarView
Visual Basic

Public Enumeration CalendarView

Members

Member name | Description
List | The calendar displays several seconds, minutes, hours, days, weeks, months or years in a row or a column (see List View).
MonthRange | The calendar displays several months in a grid. The days of each month are visible too (see Month Range View).
ResourceView | The calendar displays the distribution of items over a period of time (see Resource View).
SingleMonth | The calendar displays a single month at a time. The days of the month are displayed in a grid (see Single Month View).
Timetable | The calendar displays a timetable where each row represents a fixed arbitrary time interval and each column represents a day. This view allow further division by various grouping criteria such as by contacts, locations or tasks (see Timetable View).
WeekRange | The calendar displays a grid of days, with the columns representing the week days from Monday to Sunday and the rows representing weeks (see Week Range View).

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CellSettings Class

CellSettings Class

Defines appearance settings for the cells representing time ranges in the calendar in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class CellSettings : ViewSettings
Visual Basic

Public NotInheritable Class CellSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.ViewSettings
MindFusion.Scheduling.Compact.CellSettings

See Also

CellSettings Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CellSettings Members

CellSettings Members
Properties

Defines appearance settings for the cells representing time ranges in the calendar in the calendar.

The following tables list the members exposed by the CellSettings type.

Public Properties

Name | Description
FirstDayOfMonthFormat | Gets or sets the string used to format and display the first day of each month in the calendar.
FirstDayOfYearFormat | Gets or sets the string used to format and display the first day of each year in the calendar.
GeneralFormat | Gets or sets the string used to format and display dates and times in the calendar.
HeaderPosition | Gets or sets the position of the cell header.
HeaderSize | Gets or sets the size of the cell header in pixels.
Margin | Gets or sets the distance between the outermost border of the cell and the cell contents.
ShowToday | Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TodayColor | Gets or sets the color used to paint the line that marks the current cell.

See Also

CellSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CellSettings Properties

CellSettings Properties

Public Properties

Name | Description
FirstDayOfMonthFormat | Gets or sets the string used to format and display the first day of each month in the calendar.
FirstDayOfYearFormat | Gets or sets the string used to format and display the first day of each year in the calendar.
GeneralFormat | Gets or sets the string used to format and display dates and times in the calendar.
HeaderPosition | Gets or sets the position of the cell header.
HeaderSize | Gets or sets the size of the cell header in pixels.
Margin | Gets or sets the distance between the outermost border of the cell and the cell contents.
ShowToday | Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TodayColor | Gets or sets the color used to paint the line that marks the current cell.

See Also

CellSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CellSettings.FirstDayOfMonthFormat Property

CellSettings.FirstDayOfMonthFormat Property

Gets or sets the string used to format and display the first day of each month in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string FirstDayOfMonthFormat { get; set; }
Visual Basic

Public Property FirstDayOfMonthFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Compact Namespace
GeneralFormat Property
FirstDayOfYearFormat Property


MindFusion.Scheduling.WinForms.CellSettings.FirstDayOfYearFormat Property

CellSettings.FirstDayOfYearFormat Property

Gets or sets the string used to format and display the first day of each year in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string FirstDayOfYearFormat { get; set; }
Visual Basic

Public Property FirstDayOfYearFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Compact Namespace
GeneralFormat Property
FirstDayOfMonthFormat Property


MindFusion.Scheduling.WinForms.CellSettings.GeneralFormat Property

CellSettings.GeneralFormat Property

Gets or sets the string used to format and display dates and times in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string GeneralFormat { get; set; }
Visual Basic

Public Property GeneralFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Compact Namespace
FirstDayOfMonthFormat Property
FirstDayOfYearFormat Property


MindFusion.Scheduling.WinForms.CellSettings.HeaderPosition Property

CellSettings.HeaderPosition Property

Gets or sets the position of the cell header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Position HeaderPosition { get; set; }
Visual Basic

Public Property HeaderPosition As Position

Property Value

A member of the Position enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Compact Namespace
HeaderSize Property
RotateHeader Property


MindFusion.Scheduling.WinForms.CellSettings.HeaderSize Property

CellSettings.HeaderSize Property

Gets or sets the size of the cell header in pixels.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int HeaderSize { get; set; }
Visual Basic

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the size in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property specifies the height of the header if HeaderPosition is set to either Top or Bottom, or the width of the header if HeaderPosition is set to Left or Right. Specifying 0 for this property expands the header to fill the entire cell.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Compact Namespace
HeaderPosition Property


MindFusion.Scheduling.WinForms.CellSettings.Margin Property

CellSettings.Margin Property

Gets or sets the distance between the outermost border of the cell and the cell contents.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Margin { get; set; }
Visual Basic

Public Property Margin As Integer

Property Value

A non-negative integer value specifying the margin size in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CellSettings.ShowToday Property

CellSettings.ShowToday Property

Gets or sets a value indicating whether the calendar should mark the current cell by underlining the header area.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowToday { get; set; }
Visual Basic

Public Property ShowToday As State

Property Value

Specify Enabled to indicate visually the current day; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Compact Namespace
TodayColor Property
TodayFillColor Property


MindFusion.Scheduling.WinForms.CellSettings.Style Property

CellSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CellSettings.TodayColor Property

CellSettings.TodayColor Property

Gets or sets the color used to paint the line that marks the current cell.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Color TodayColor { get; set; }
Visual Basic

Public Property TodayColor As Color

Property Value

A .NET Color object. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

CellSettings Members
CellSettings Class
MindFusion.Scheduling.Compact Namespace
TodayFillColor Property
ShowToday Property


MindFusion.Scheduling.WinForms.CustomDraw Delegate

CustomDraw Delegate

Represents methods that will handle the Draw event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void CustomDraw (
Object sender,
CustomDrawArgs e
)
Visual Basic

Public Delegate Sub CustomDraw ( _
sender As Object, _
e As CustomDrawArgs _
)

Parameters

sender
The source of the event.
e
A CustomDrawArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs Class

CustomDrawArgs Class

Contains the arguments passed to handlers of the Draw event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class CustomDrawArgs : EventArgs
Visual Basic

Public NotInheritable Class CustomDrawArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.CustomDrawArgs

See Also

CustomDrawArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs Members

CustomDrawArgs Members
Properties

Contains the arguments passed to handlers of the Draw event.

The following tables list the members exposed by the CustomDrawArgs type.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the element being drawn.
Date | Gets the date and time associated with the element being drawn.
Element | Gets the type of the calendar element being drawn.
EndTime | Gets the end time associated with the element being drawn.
Graphics | Gets the GraphicsEx instance whose methods can be used to perform custom drawing.
Index | Gets the index associated with the element being drawn.
Item | Gets the item being custom drawn.
Resource | Gets the resource related to the element being drawn.
StartTime | Gets the start time associated with the element being drawn.
Style | Gets the style associated with the element being drawn.
Text | Gets the text associated with the element being drawn.

See Also

CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs Properties

CustomDrawArgs Properties

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the element being drawn.
Date | Gets the date and time associated with the element being drawn.
Element | Gets the type of the calendar element being drawn.
EndTime | Gets the end time associated with the element being drawn.
Graphics | Gets the GraphicsEx instance whose methods can be used to perform custom drawing.
Index | Gets the index associated with the element being drawn.
Item | Gets the item being custom drawn.
Resource | Gets the resource related to the element being drawn.
StartTime | Gets the start time associated with the element being drawn.
Style | Gets the style associated with the element being drawn.
Text | Gets the text associated with the element being drawn.

See Also

CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.Bounds Property

CustomDrawArgs.Bounds Property

Gets the bounding rectangle of the element being drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Rectangle Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As Rectangle

Property Value

A .NET Rectangle object specifying the element's bounds.

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.Date Property

CustomDrawArgs.Date Property

Gets the date and time associated with the element being drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime Date { get; }
Visual Basic

Public ReadOnly Property Date As DateTime

Property Value

A DateTime object specifying the date related to the element being drawn.

Remarks

If there is not any time associated with the element, the return value is DateTime.MinValue.

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.Element Property

CustomDrawArgs.Element Property

Gets the type of the calendar element being drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public CustomDrawElements Element { get; }
Visual Basic

Public ReadOnly Property Element As CustomDrawElements

Property Value

A member of the CustomDrawElements enumeration specifying what element to draw.

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.EndTime Property

CustomDrawArgs.EndTime Property

Gets the end time associated with the element being drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeSpan EndTime { get; }
Visual Basic

Public ReadOnly Property EndTime As TimeSpan

Property Value

A .NET TimeSpan object specifying the end time related to the element being drawn.

Remarks

This property is used only with certain events in the Timetable view. For events that do not use it, it is set to TimeSpan.Zero.

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.Graphics Property ()

CustomDrawArgs.Graphics Property ()
See Also

Gets the GraphicsEx instance whose methods can be used to perform custom drawing.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public GraphicsEx Graphics { get; }
Visual Basic

Public ReadOnly Property Graphics As GraphicsEx

Property Value

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.Index Property

CustomDrawArgs.Index Property

Gets the index associated with the element being drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Index { get; }
Visual Basic

Public ReadOnly Property Index As Integer

Property Value

An integer value specifying the element's index.

Remarks

This property specifies the index of a view column, cell or a scheduled item being custom drawn. If there is not an index associated with the element, the return value is 0.

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.Item Property

CustomDrawArgs.Item Property

Gets the item being custom drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

A reference to a schedule Item. If no item is associated with the drawn element, returns null (Nothing in Visual Basic).

Remarks

This property refers to an item when CustomDraw is set to CalendarItem or ScheduleItem.

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.Resource Property

CustomDrawArgs.Resource Property

Gets the resource related to the element being drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

A reference to a Contact, Location, Task or Resource related to the custom drawn element.

Remarks

This could be null (Nothing in Visual Basic) when no resource is related to the element.

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.StartTime Property

CustomDrawArgs.StartTime Property

Gets the start time associated with the element being drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeSpan StartTime { get; }
Visual Basic

Public ReadOnly Property StartTime As TimeSpan

Property Value

A .NET TimeSpan object specifying the start time related to the custom drawn element.

Remarks

This property is used only with certain events in Timetable view. For events that do not use it, it is set to TimeSpan.Zero.

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.Style Property

CustomDrawArgs.Style Property

Gets the style associated with the element being drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style Style { get; }
Visual Basic

Public ReadOnly Property Style As Style

Property Value

The Style object associated with the element being drawn.

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawArgs.Text Property

CustomDrawArgs.Text Property

Gets the text associated with the element being drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string Text { get; }
Visual Basic

Public ReadOnly Property Text As String

Property Value

A string specifying the text associated with a custom drawn element.

See Also

CustomDrawArgs Members
CustomDrawArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.CustomDrawElements Enumeration

CustomDrawElements Enumeration

Specifies which elements of the calendar are custom-drawn.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum CustomDrawElements
Visual Basic

Public Enumeration CustomDrawElements

Members

Member name | Description
All | All elements.
CalendarItem | An all day item in a Timetable view, or an item in any other view.
CellContents | The contents of a single cell.
CellHeader | The header of a single cell.
ListViewHeader | The header of a List view.
ListViewHeaderCell | A cell in the header of a List view.
MonthContents | The contents of a month cell.
MonthMainHeader | A month main header in MonthRange or SingleMonth view.
MonthRangeHeader | The header in a MonthRange view.
MonthSubHeader | The day of week header in MonthRange or SingleMonth view.
MonthSubHeaderCell | A cell in the day of week header in MonthRange or SingleMonth view.
MonthWeekNumbersHeader | The week numbers header in MonthRange or SingleMonth view.
MonthWeekNumbersHeaderCell | A cell in the week numbers header in MonthRange or SingleMonth view.
None | Do not use custom drawing.
ResourceViewCell | A cell in a Resource view. If the view style is Lanes this enumeration value indicates a cell in each individual lane.
ResourceViewCellComplete | A cell in a Resource view. If the view style is Lanes this enumeration value indicates a cell that encompasses all lanes for the associated Resource.
ResourceViewItem | An item in a Resource view.
ResourceViewRowHeader | The header of a Resource view row.
ResourceViewTimeline | A timeline of a Resource view.
ResourceViewTimelineCell | A cell of a timeline in a Resource view.
ScheduleItem | A non all-day item in a Timetable view. For all-day items, the CalendarItem value is specified.
TimetableCell | A cell in a Timetable view.
TimetableColumnHeader | A column header in a Timetable view.
TimetableGroupHeader | The group header in a Timetable view.
TimetableGroupHeaderCell | A cell of the group header in a Timetable view.
TimetableInfoHeader | The timetable info header. Occurs for each column in the view.
TimetableTimeline | The timeline in a Timetable view. Occurs before the timeline divisions are painted.
TimetableTimelineCell | A portion of the timeline in a Timetable view.
TimetableTimelineHourCell | An hour cell of the timeline in a Timetable view.
TimetableWholeDayHeader | A whole day portion of the header in a Timetable view. Occurs for each column in the view.
WeekRangeHeader | The header in a WeekRange view.
WeekRangeReferenceHeader | The reference header in a WeekRange view.
WeekRangeSubHeader | The day of week header in a WeekRange view.
WeekRangeSubHeaderCell | A cell in the day of week header in a WeekRange view.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateChangedEventArgs Class

DateChangedEventArgs Class

Contains the arguments passed to handlers of the VisibleDateChanged event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class DateChangedEventArgs : EventArgs
Visual Basic

Public Class DateChangedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.DateChangedEventArgs

See Also

DateChangedEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateChangedEventArgs Members

DateChangedEventArgs Members
Properties

Contains the arguments passed to handlers of the VisibleDateChanged event.

The following tables list the members exposed by the DateChangedEventArgs type.

Public Properties

Name | Description
NewDate | Gets the new visible date.
PreviousDate | Gets the previous visible date.

See Also

DateChangedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateChangedEventArgs Properties

DateChangedEventArgs Properties

Public Properties

Name | Description
NewDate | Gets the new visible date.
PreviousDate | Gets the previous visible date.

See Also

DateChangedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateChangedEventArgs.NewDate Property

DateChangedEventArgs.NewDate Property

Gets the new visible date.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime NewDate { get; }
Visual Basic

Public ReadOnly Property NewDate As DateTime

Property Value

A .NET DateTime object specifying the new date related to the raised event.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateChangedEventArgs.PreviousDate Property

DateChangedEventArgs.PreviousDate Property

Gets the previous visible date.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime PreviousDate { get; }
Visual Basic

Public ReadOnly Property PreviousDate As DateTime

Property Value

A .NET DateTime object specifying the previous date related to the raised event.

See Also

DateChangedEventArgs Members
DateChangedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateChangedEventHandler Delegate

DateChangedEventHandler Delegate

Represents methods that will handle the VisibleDateChanged event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void DateChangedEventHandler (
Object sender,
DateChangedEventArgs e
)
Visual Basic

Public Delegate Sub DateChangedEventHandler ( _
sender As Object, _
e As DateChangedEventArgs _
)

Parameters

sender
The source of the event.
e
A DateChangedEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection Class

DateCollection Class

Represents a strongly-typed sorted collection of DateTime objects.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class DateCollection : CollectionBase
Visual Basic

Public NotInheritable Class DateCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.Compact.DateCollection

See Also

DateCollection Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection Members

DateCollection Members
Constructors Properties Methods

Represents a strongly-typed sorted collection of DateTime objects.

The following tables list the members exposed by the DateCollection type.

Public Constructors

Name | Description
DateCollection | Initializes a new instance of the DateCollection class.

Public Properties

Name | Description
Item | Gets or sets the DateTime located at the specified position within this collection.

Public Methods

Name | Description
Add | Adds the specified DateTime object to this collection.
Clear | Removes all elements from the collection.
Contains | Determines whether this collection contains the specified DateTime instance.
CopyTo | Copies the elements of the DateCollection to another collection, starting from the specified index.
IndexOf | Returns the zero-based index of the first occurrence of the specified DateTime object in this collection.
Insert | Inserts a DateTime object into the collection at the specified index.
Remove | Removes the first occurrence of a DateTime object from this collection.
RemoveAt | Removes the DateTime object at the specified index of this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.
OnSetComplete | CollectionBase.OnSetComplete override.

See Also

DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection Constructor

DateCollection Constructor

Initializes a new instance of the DateCollection class.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateCollection ()
Visual Basic

Public Sub New ()

See Also

DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection Methods

DateCollection Methods

Public Methods

Name | Description
Add | Adds the specified DateTime object to this collection.
Clear | Removes all elements from the collection.
Contains | Determines whether this collection contains the specified DateTime instance.
CopyTo | Copies the elements of the DateCollection to another collection, starting from the specified index.
IndexOf | Returns the zero-based index of the first occurrence of the specified DateTime object in this collection.
Insert | Inserts a DateTime object into the collection at the specified index.
Remove | Removes the first occurrence of a DateTime object from this collection.
RemoveAt | Removes the DateTime object at the specified index of this collection.

Protected Methods

Name | Description
OnClearComplete | CollectionBase.OnClearComplete override.
OnInsertComplete | CollectionBase.OnInsertComplete override.
OnRemoveComplete | CollectionBase.OnRemoveComplete override.
OnSetComplete | CollectionBase.OnSetComplete override.

See Also

DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.Add Method

DateCollection.Add Method

Adds the specified DateTime object to this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Add (
DateTime date
)
Visual Basic

Public Sub Add ( _
date As DateTime _
)

Parameters

date
A DateTime instance to be added to the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.Clear Method

DateCollection.Clear Method

Removes all elements from the collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public new void Clear ()
Visual Basic

Public Shadows Sub Clear ()

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.Contains Method

DateCollection.Contains Method

Determines whether this collection contains the specified DateTime instance.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
DateTime date
)
Visual Basic

Public Function Contains ( _
date As DateTime _
) As Boolean

Parameters

date
The DateTime object to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.CopyTo Method

DateCollection.CopyTo Method

Copies the elements of the DateCollection to another collection, starting from the specified index.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void CopyTo (
DateCollection collection,
int index
)
Visual Basic

Public Sub CopyTo ( _
collection As DateCollection, _
index As Integer _
)

Parameters

collection
The target collection to which items should be copied.
index
Specifies the index at which items should be inserted in the target collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.IndexOf Method

DateCollection.IndexOf Method

Returns the zero-based index of the first occurrence of the specified DateTime object in this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int IndexOf (
DateTime date
)
Visual Basic

Public Function IndexOf ( _
date As DateTime _
) As Integer

Parameters

date
The DateTime to locate in the collection.

Return Value

The zero-based index of the first occurrence of the element within the collection if found; otherwise, -1.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.Insert Method

DateCollection.Insert Method

Inserts a DateTime object into the collection at the specified index.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Insert (
int index,
DateTime date
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
date As DateTime _
)

Parameters

index
Specifies the position at which the DateTime must be inserted.
date
A DateTime instance to be added to the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.OnClearComplete Method

DateCollection.OnClearComplete Method

CollectionBase.OnClearComplete override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnClearComplete ()
Visual Basic

Protected Overridable Sub OnClearComplete ()

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.OnInsertComplete Method

DateCollection.OnInsertComplete Method

CollectionBase.OnInsertComplete override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnInsertComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnInsertComplete ( _
index As Integer, _
value As Object _
)

Parameters

index
The zero-based index where the item was inserted.
value
The inserted item.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.OnRemoveComplete Method

DateCollection.OnRemoveComplete Method

CollectionBase.OnRemoveComplete override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnRemoveComplete (
int index,
Object value
)
Visual Basic

Protected Overridable Sub OnRemoveComplete ( _
index As Integer, _
value As Object _
)

Parameters

index

The zero-based index at which value can be found.

value
The value of the element to remove from index.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.OnSetComplete Method

DateCollection.OnSetComplete Method

CollectionBase.OnSetComplete override.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnSetComplete (
int index,
Object oldValue,
Object newValue
)
Visual Basic

Protected Overridable Sub OnSetComplete ( _
index As Integer, _
oldValue As Object, _
newValue As Object _
)

Parameters

index
The zero-based index at which oldValue can be found.
oldValue

The value to replace with newValue.

newValue
The new value of the element at index.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.Remove Method

DateCollection.Remove Method

Removes the first occurrence of a DateTime object from this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Remove (
DateTime date
)
Visual Basic

Public Sub Remove ( _
date As DateTime _
)

Parameters

date
A DateTime instance which must be removed from the collection.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.RemoveAt Method

DateCollection.RemoveAt Method

Removes the DateTime object at the specified index of this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public new void RemoveAt (
int index
)
Visual Basic

Public Shadows Sub RemoveAt ( _
index As Integer _
)

Parameters

index
The zero-based index of the DateTime object to remove.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection Properties

DateCollection Properties

Public Properties

Name | Description
Item | Gets or sets the DateTime located at the specified position within this collection.

See Also

DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateCollection.Item Property

DateCollection.Item Property

Gets or sets the DateTime located at the specified position within this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As DateTime

Parameters

index
The zero-based index of the DateTime object to set or retrieve.

Property Value

A DateTime instance located at the specified index within this collection.

Remarks

This indexer property allows using the C# [] or VB.NET () operators to access elements of this collection by their integer index.

See Also

DateCollection Members
DateCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateEventArgs Class

DateEventArgs Class

Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class DateEventArgs : EventArgs
Visual Basic

Public Class DateEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.DateEventArgs
MindFusion.Scheduling.Compact.ResourceDateEventArgs

See Also

DateEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateEventArgs Members

DateEventArgs Members
Properties

Contains the arguments passed to handlers of mouse events related to date and time cells in the calendar.

The following tables list the members exposed by the DateEventArgs type.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the clicked date cell.
Button | Gets the pressed mouse button.
Date | Gets the date and time associated with the event.
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise.

See Also

DateEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateEventArgs Properties

DateEventArgs Properties

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the clicked date cell.
Button | Gets the pressed mouse button.
Date | Gets the date and time associated with the event.
Index | Gets the index (if any) of the calendar cell related to the event or -1 otherwise.

See Also

DateEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateEventArgs.Bounds Property

DateEventArgs.Bounds Property

Gets the bounding rectangle of the clicked date cell.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Rectangle Bounds { get; }
Visual Basic

Public ReadOnly Property Bounds As Rectangle

Property Value

A .NET Rectangle object specifying the bounds of the cell related to the raised event.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateEventArgs.Button Property

DateEventArgs.Button Property

Gets the pressed mouse button.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public MouseButtons Button { get; }
Visual Basic

Public ReadOnly Property Button As MouseButtons

Property Value

A member of the .NET MouseButtons enumeration specifying what mouse button was pressed.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateEventArgs.Date Property

DateEventArgs.Date Property

Gets the date and time associated with the event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime Date { get; }
Visual Basic

Public ReadOnly Property Date As DateTime

Property Value

A .NET DateTime object specifying the date related to the raised event.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateEventArgs.Index Property

DateEventArgs.Index Property

Gets the index (if any) of the calendar cell related to the event or -1 otherwise.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Index { get; }
Visual Basic

Public ReadOnly Property Index As Integer

Property Value

An integer value specifying the index of the related cell or -1 if no index is applicable to the selected cell.

See Also

DateEventArgs Members
DateEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateEventHandler Delegate

DateEventHandler Delegate

Represents methods that will handle mouse events related to date and time cells in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void DateEventHandler (
Object sender,
DateEventArgs e
)
Visual Basic

Public Delegate Sub DateEventHandler ( _
sender As Object, _
e As DateEventArgs _
)

Parameters

sender

The source of the event.

e
A DateEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyle Class

DateStyle Class

Defines formatting for a range of dates. Can be used either to format either days or months.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class DateStyle
Visual Basic

Public Class DateStyle

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.DateStyle

See Also

DateStyle Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyle Members

DateStyle Members
Constructors Properties

Defines formatting for a range of dates. Can be used either to format either days or months.

The following tables list the members exposed by the DateStyle type.

Public Constructors

Name | Description
DateStyle | Initializes a new instance of the DateStyle class. Both the start and end dates are set to the current date.

Public Properties

Name | Description
AllowItems | Gets or sets a value indicating whether the date cells in this range allow items to be placed or created in them interactively.
AllowSelect | Gets or sets a value indicating whether the date cells in this range can be selected.
From | Gets or sets the start date of the formatted range.
Priority | Gets or sets the format priority. If one date has several styles applied to it, only the highest in priority is taken into account.
Style | Gets or sets the visualization style of the date cells included in the formatted range.
To | Gets or sets the end date of the formatted range.

See Also

DateStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyle Constructor

DateStyle Constructor

Initializes a new instance of the DateStyle class. Both the start and end dates are set to the current date.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateStyle ()
Visual Basic

Public Sub New ()

See Also

DateStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyle Properties

DateStyle Properties

Public Properties

Name | Description
AllowItems | Gets or sets a value indicating whether the date cells in this range allow items to be placed or created in them interactively.
AllowSelect | Gets or sets a value indicating whether the date cells in this range can be selected.
From | Gets or sets the start date of the formatted range.
Priority | Gets or sets the format priority. If one date has several styles applied to it, only the highest in priority is taken into account.
Style | Gets or sets the visualization style of the date cells included in the formatted range.
To | Gets or sets the end date of the formatted range.

See Also

DateStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyle.AllowItems Property

DateStyle.AllowItems Property

Gets or sets a value indicating whether the date cells in this range allow items to be placed or created in them interactively.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool AllowItems { get; set; }
Visual Basic

Public Property AllowItems As Boolean

Property Value

true to let users place schedule items in the specified cells; otherwise, false. The default is false.

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyle.AllowSelect Property

DateStyle.AllowSelect Property

Gets or sets a value indicating whether the date cells in this range can be selected.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool AllowSelect { get; set; }
Visual Basic

Public Property AllowSelect As Boolean

Property Value

true to let users select the date cells; otherwise, false. The default is true.

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyle.From Property

DateStyle.From Property

Gets or sets the start date of the formatted range.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime From { get; set; }
Visual Basic

Public Property From As DateTime

Property Value

A .NET DateTime object specifying the start of the time interval whose cells' style is defined in this object.

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyle.Priority Property

DateStyle.Priority Property

Gets or sets the format priority. If one date has several styles applied to it, only the highest in priority is taken into account.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Priority { get; set; }
Visual Basic

Public Property Priority As Integer

Property Value

An integer value specifying the priority of this style.

Remarks

When a time cell is included in the time intervals of several DateStyle or DayOfWeekStyle objects, the style that has the highest priority is used.

Example

Note

If you want the overlapping styles for a single date to cascade, you have to specify different priorities for them.

The following example illustrates how to create overlapping DateStyle objects for a specific date in a SingleMonth view. The example creates two date styles - one for the time range 03/15 - 03/20 and another for the time range 03/18 - 03/24. The two styles have different priorities to allow cascading. If both styles have had the same priorities, only the second style would have been used for the dates in the overlapped range (03/18 - 03/20).

C#

DateStyle style1 = new DateStyle();
style1.From = new DateTime(2006, 3, 15);
style1.To = new DateTime(2006, 3, 20);
style1.Style = new Style();
style1.Style.BorderLeftWidth = 2;
style1.Style.BorderTopWidth = 2;
style1.Style.BorderRightWidth = 2;
style1.Style.BorderBottomWidth = 2;
style1.Priority = 1;
calendar.DayStyles.Add(style1);

DateStyle style2 = new DateStyle();
style2.From = new DateTime(2006, 3, 18);
style2.To = new DateTime(2006, 3, 24);
style2.Style = new Style();
style2.Style.Brush = new MindFusion.Drawing.SolidBrush(Color.PaleGoldenrod);
style2.Priority = 2;
calendar.DayStyles.Add(style2);
Visual Basic

Dim style1 As New DateStyle()
style1.From = New DateTime(2006, 3, 15)
style1.To = New DateTime(2006, 3, 20)
style1.Style = New Style()
style1.Style.BorderLeftWidth = 2
style1.Style.BorderTopWidth = 2
style1.Style.BorderRightWidth = 2
style1.Style.BorderBottomWidth = 2
style1.Priority = 1
calendar.DayStyles.Add(style1)

Dim style2 As New DateStyle()
style2.From = New DateTime(2006, 3, 18)
style2.To = New DateTime(2006, 3, 24)
style2.Style = New Style()
style2.Style.Brush = New MindFusion.Drawing.SolidBrush(Color.PaleGoldenrod)
style2.Priority = 2
calendar.DayStyles.Add(style2)

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyle.Style Property

DateStyle.Style Property

Gets or sets the visualization style of the date cells included in the formatted range.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

A Style object that defines the appearance of time cells included in the specified interval.

Remarks

Only the properties in this Style object that have been explicitly set would be used. See the example section below for more detail.

Example

The following example creates a custom style for the dates in the range 03/20 - 03/24. The style changes only the border color and the border width of the cells in the specified range. The values of all other properties are retrieved from the default settings, because they are never explicitly set in this custom style.

C#

DateStyle style = new DateStyle();
style.From = new DateTime(2006, 3, 20);
style.To = new DateTime(2006, 3, 24);
style.Style = new Style();
style.Style.BorderLeftColor = Color.LightBlue;
style.Style.BorderLeftWidth = 1;
style.Style.BorderTopColor = Color.LightBlue;
style.Style.BorderTopWidth = 1;
style.Style.BorderRightColor = Color.SteelBlue;
style.Style.BorderRightWidth = 1;
style.Style.BorderBottomColor = Color.SteelBlue;
style.Style.BorderBottomWidth = 1;
calendar.DayStyles.Add(style);
Visual Basic

Dim style As New DateStyle()
style.From = New DateTime(2006, 3, 20)
style.To = New DateTime(2006, 3, 24)
style.Style = New Style()
style.Style.BorderLeftColor = Color.LightBlue
style.Style.BorderLeftWidth = 1
style.Style.BorderTopColor = Color.LightBlue
style.Style.BorderTopWidth = 1
style.Style.BorderRightColor = Color.SteelBlue
style.Style.BorderRightWidth = 1
style.Style.BorderBottomColor = Color.SteelBlue
style.Style.BorderBottomWidth = 1
calendar.DayStyles.Add(style)

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyle.To Property

DateStyle.To Property

Gets or sets the end date of the formatted range.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime To { get; set; }
Visual Basic

Public Property To As DateTime

Property Value

A .NET DateTime object specifying the end of the time interval whose cells' style is defined in this object.

See Also

DateStyle Members
DateStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection Class

DateStyleCollection Class

Represents a strongly-typed collection of DateStyle objects.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class DateStyleCollection : CollectionBase
Visual Basic

Public Class DateStyleCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.Compact.DateStyleCollection

See Also

DateStyleCollection Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection Members

DateStyleCollection Members
Constructors Properties Methods

Represents a strongly-typed collection of DateStyle objects.

The following tables list the members exposed by the DateStyleCollection type.

Public Constructors

Name | Description
DateStyleCollection | Initializes a new instance of the DateStyleCollection class.

Public Properties

Name | Description
Item | Gets or sets the DateStyle located at the specified position within this collection.

Public Methods

Name | Description
Add | Adds the specified DateStyle object to this collection.
Contains | Determines whether this collection contains the specified DateStyle instance.
CopyTo | Copies the elements of the DateStyleCollection to another collection, starting from a particular index.
IndexOf | Returns the zero-based index of the first occurrence of a DateStyle object in this collection.
Insert | Inserts the specified DateStyle object at the specified position within the collection.
Remove | Removes the first occurrence of the specified DateStyle object from this collection.

See Also

DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection Constructor

DateStyleCollection Constructor

Initializes a new instance of the DateStyleCollection class.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateStyleCollection ()
Visual Basic

Public Sub New ()

See Also

DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection Methods

DateStyleCollection Methods

Public Methods

Name | Description
Add | Adds the specified DateStyle object to this collection.
Contains | Determines whether this collection contains the specified DateStyle instance.
CopyTo | Copies the elements of the DateStyleCollection to another collection, starting from a particular index.
IndexOf | Returns the zero-based index of the first occurrence of a DateStyle object in this collection.
Insert | Inserts the specified DateStyle object at the specified position within the collection.
Remove | Removes the first occurrence of the specified DateStyle object from this collection.

See Also

DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.Add Method

DateStyleCollection.Add Method

Adds the specified DateStyle object to this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Add (
DateStyle style
)
Visual Basic

Public Sub Add ( _
style As DateStyle _
)

Parameters

style
A DateStyle instance to be added to the collection.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.Contains Method

DateStyleCollection.Contains Method

Determines whether this collection contains the specified DateStyle instance.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
DateStyle style
)
Visual Basic

Public Function Contains ( _
style As DateStyle _
) As Boolean

Parameters

style
The DateStyle value to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.CopyTo Method

DateStyleCollection.CopyTo Method

Copies the elements of the DateStyleCollection to another collection, starting from a particular index.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void CopyTo (
DateStyleCollection collection,
int index
)
Visual Basic

Public Sub CopyTo ( _
collection As DateStyleCollection, _
index As Integer _
)

Parameters

collection
The target collection to which items should be copied.
index
Specifies the index at which items should be inserted in the target collection.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.IndexOf Method

DateStyleCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a DateStyle object in this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int IndexOf (
DateStyle style
)
Visual Basic

Public Function IndexOf ( _
style As DateStyle _
) As Integer

Parameters

style
The DateStyle to locate in the collection.

Return Value

The zero-based index of the first occurrence of the element within the collection if found; otherwise, -1.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.Insert Method

DateStyleCollection.Insert Method

Inserts the specified DateStyle object at the specified position within the collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Insert (
int index,
DateStyle style
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
style As DateStyle _
)

Parameters

index
Specifies the position at which the DateStyle must be inserted.
style
A DateStyle instance to be added to the collection.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.Remove Method

DateStyleCollection.Remove Method

Removes the first occurrence of the specified DateStyle object from this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Remove (
DateStyle style
)
Visual Basic

Public Sub Remove ( _
style As DateStyle _
)

Parameters

style
A DateStyle instance which must be removed from the collection.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection Properties

DateStyleCollection Properties

Public Properties

Name | Description
Item | Gets or sets the DateStyle located at the specified position within this collection.

See Also

DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DateStyleCollection.Item Property

DateStyleCollection.Item Property

Gets or sets the DateStyle located at the specified position within this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateStyle Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As DateStyle

Parameters

index
The zero-based index of the DateStyle object to set or retrieve.

Property Value

An instance of the DateStyle class located at the specified index within this collection.

Remarks

This indexer property allows using the C# [] or VB.NET () operators to access elements of this collection by their integer index.

See Also

DateStyleCollection Members
DateStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekFormat Enumeration

DayOfWeekFormat Enumeration

Specifies the display format of a day of the week.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum DayOfWeekFormat
Visual Basic

Public Enumeration DayOfWeekFormat

Members

Member name | Description
Abbreviated | The first three letters of the day of the week are displayed.
Full | The complete name of the day of the week is displayed.
SingleLetter | Only the first letter of the name of the day is displayed.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle Class

DayOfWeekStyle Class

An instance of this class defines how a day of the week should be displayed and formatted.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class DayOfWeekStyle
Visual Basic

Public Class DayOfWeekStyle

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.DayOfWeekStyle

See Also

DayOfWeekStyle Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle Members

DayOfWeekStyle Members
Constructors Properties

An instance of this class defines how a day of the week should be displayed and formatted.

The following tables list the members exposed by the DayOfWeekStyle type.

Public Constructors

Name | Description
DayOfWeekStyle | Initializes a new instance of the DayOfWeekStyle class.

Public Properties

Name | Description
AllowItems | Gets or sets a value indicating whether the calendar cell for the specified day allows items to be placed or created in it interactively.
AllowSelect | Gets or sets a value indicating whether the specified day of the week can be selected.
DayOfWeek | Gets or sets the day of the week to which this DayOfWeekStyle object is assigned.
Priority | Gets or sets the style priority. If one date has several styles applied to it, only the highest in priority is taken into account.
Style | Gets or sets the visualization style of the specified day.

See Also

DayOfWeekStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle Constructor

DayOfWeekStyle Constructor

Initializes a new instance of the DayOfWeekStyle class.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DayOfWeekStyle ()
Visual Basic

Public Sub New ()

See Also

DayOfWeekStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle Properties

DayOfWeekStyle Properties

Public Properties

Name | Description
AllowItems | Gets or sets a value indicating whether the calendar cell for the specified day allows items to be placed or created in it interactively.
AllowSelect | Gets or sets a value indicating whether the specified day of the week can be selected.
DayOfWeek | Gets or sets the day of the week to which this DayOfWeekStyle object is assigned.
Priority | Gets or sets the style priority. If one date has several styles applied to it, only the highest in priority is taken into account.
Style | Gets or sets the visualization style of the specified day.

See Also

DayOfWeekStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle.AllowItems Property

DayOfWeekStyle.AllowItems Property

Gets or sets a value indicating whether the calendar cell for the specified day allows items to be placed or created in it interactively.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool AllowItems { get; set; }
Visual Basic

Public Property AllowItems As Boolean

Property Value

true to let users place schedule items in the specified cells; otherwise, false. The default is false.

See Also

DayOfWeekStyle Members
DayOfWeekStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle.AllowSelect Property

DayOfWeekStyle.AllowSelect Property

Gets or sets a value indicating whether the specified day of the week can be selected.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool AllowSelect { get; set; }
Visual Basic

Public Property AllowSelect As Boolean

Property Value

true to let users select the date cells; otherwise, false. The default is true.

See Also

DayOfWeekStyle Members
DayOfWeekStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle.DayOfWeek Property

DayOfWeekStyle.DayOfWeek Property

Gets or sets the day of the week to which this DayOfWeekStyle object is assigned.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DayOfWeek DayOfWeek { get; set; }
Visual Basic

Public Property DayOfWeek As DayOfWeek

Property Value

A member of the .NET DayOfWeek enumeration. The default is Sunday.

See Also

DayOfWeekStyle Members
DayOfWeekStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle.Priority Property

DayOfWeekStyle.Priority Property

Gets or sets the style priority. If one date has several styles applied to it, only the highest in priority is taken into account.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Priority { get; set; }
Visual Basic

Public Property Priority As Integer

Property Value

An integer value specifying the priority of this style.

Remarks

When a time cell is included in the time intervals of several DateStyle or DayOfWeekStyle objects, the style that has the highest priority is used.

See Also

DayOfWeekStyle Members
DayOfWeekStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyle.Style Property

DayOfWeekStyle.Style Property

Gets or sets the visualization style of the specified day.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

A Style object that defines the appearance of time cells included in the specified interval.

See Also

DayOfWeekStyle Members
DayOfWeekStyle Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection Class

DayOfWeekStyleCollection Class

Represents a strongly-typed collection of DayOfWeekStyle objects.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class DayOfWeekStyleCollection : CollectionBase
Visual Basic

Public Class DayOfWeekStyleCollection
Inherits CollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
MindFusion.Scheduling.Compact.DayOfWeekStyleCollection

See Also

DayOfWeekStyleCollection Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection Members

DayOfWeekStyleCollection Members
Constructors Properties Methods

Represents a strongly-typed collection of DayOfWeekStyle objects.

The following tables list the members exposed by the DayOfWeekStyleCollection type.

Public Constructors

Name | Description
DayOfWeekStyleCollection | Initializes a new instance of the DayOfWeekStyleCollection class.

Public Properties

Name | Description
Item | Gets or sets the DayOfWeekStyle located at the specified index within this collection.

Public Methods

Name | Description
Add | Adds the specified DayOfWeekStyle object to this collection.
Contains | Determines whether this collection contains the specified DayOfWeekStyle instance.
CopyTo | Copies the elements of the DayOfWeekStyleCollection to another collection, starting from a particular index.
IndexOf | Returns the zero-based index of the first occurrence of a DayOfWeekStyle object in this collection.
Insert | Inserts the specified DayOfWeekStyle object at the specified position within the collection.
Remove | Removes the first occurrence of the specified DayOfWeekStyle object from this collection.

See Also

DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection Constructor

DayOfWeekStyleCollection Constructor

Initializes a new instance of the DayOfWeekStyleCollection class.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DayOfWeekStyleCollection ()
Visual Basic

Public Sub New ()

See Also

DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection Methods

DayOfWeekStyleCollection Methods

Public Methods

Name | Description
Add | Adds the specified DayOfWeekStyle object to this collection.
Contains | Determines whether this collection contains the specified DayOfWeekStyle instance.
CopyTo | Copies the elements of the DayOfWeekStyleCollection to another collection, starting from a particular index.
IndexOf | Returns the zero-based index of the first occurrence of a DayOfWeekStyle object in this collection.
Insert | Inserts the specified DayOfWeekStyle object at the specified position within the collection.
Remove | Removes the first occurrence of the specified DayOfWeekStyle object from this collection.

See Also

DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.Add Method

DayOfWeekStyleCollection.Add Method

Adds the specified DayOfWeekStyle object to this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Add (
DayOfWeekStyle style
)
Visual Basic

Public Sub Add ( _
style As DayOfWeekStyle _
)

Parameters

style
A DayOfWeekStyle instance to be added to the collection.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.Contains Method

DayOfWeekStyleCollection.Contains Method

Determines whether this collection contains the specified DayOfWeekStyle instance.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
DayOfWeekStyle style
)
Visual Basic

Public Function Contains ( _
style As DayOfWeekStyle _
) As Boolean

Parameters

style
The DayOfWeekStyle value to search for in the collection.

Return Value

true if the object is found or false if it isn't.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.CopyTo Method

DayOfWeekStyleCollection.CopyTo Method

Copies the elements of the DayOfWeekStyleCollection to another collection, starting from a particular index.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void CopyTo (
DayOfWeekStyleCollection collection,
int index
)
Visual Basic

Public Sub CopyTo ( _
collection As DayOfWeekStyleCollection, _
index As Integer _
)

Parameters

collection
The target collection to which items should be copied.
index
Specifies the index at which items should be inserted in the target collection.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.IndexOf Method

DayOfWeekStyleCollection.IndexOf Method

Returns the zero-based index of the first occurrence of a DayOfWeekStyle object in this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int IndexOf (
DayOfWeekStyle style
)
Visual Basic

Public Function IndexOf ( _
style As DayOfWeekStyle _
) As Integer

Parameters

style
The DayOfWeekStyle to locate in the collection.

Return Value

The zero-based index of the first occurrence of the element within the collection if found; otherwise, -1.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.Insert Method

DayOfWeekStyleCollection.Insert Method

Inserts the specified DayOfWeekStyle object at the specified position within the collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Insert (
int index,
DayOfWeekStyle style
)
Visual Basic

Public Sub Insert ( _
index As Integer, _
style As DayOfWeekStyle _
)

Parameters

index
Specifies the position at which the DayOfWeekStyle must be inserted.
style
A DayOfWeekStyle instance to be added to the collection.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.Remove Method

DayOfWeekStyleCollection.Remove Method

Removes the first occurrence of the specified DayOfWeekStyle object from this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Remove (
DayOfWeekStyle style
)
Visual Basic

Public Sub Remove ( _
style As DayOfWeekStyle _
)

Parameters

style
A DayOfWeekStyle instance which must be removed from the collection.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection Properties

DayOfWeekStyleCollection Properties

Public Properties

Name | Description
Item | Gets or sets the DayOfWeekStyle located at the specified index within this collection.

See Also

DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.DayOfWeekStyleCollection.Item Property

DayOfWeekStyleCollection.Item Property

Gets or sets the DayOfWeekStyle located at the specified index within this collection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DayOfWeekStyle Item [
int index
] { get; set; }
Visual Basic

Public Property Item ( _
index As Integer _
) As DayOfWeekStyle

Parameters

index
The zero-based index of the DayOfWeekStyle object to set or retrieve.

Property Value

A DayOfWeekStyle instance located at the specified index within this collection.

Remarks

This indexer property allows using the C# [] or VB.NET () operators to access elements of this collection by their integer index.

See Also

DayOfWeekStyleCollection Members
DayOfWeekStyleCollection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.GroupType Enumeration

GroupType Enumeration

Specifies grouping or filtering criteria for views that support grouping.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum GroupType
Visual Basic

Public Enumeration GroupType

Members

Member name | Description
FilterByContacts | Filter by contacts.
FilterByLocations | Filter by locations.
FilterByResources | Filter by resources.
FilterByTasks | Filter by tasks.
GroupByContacts | Group by contacts.
GroupByLocations | Group by locations.
GroupByResources | Group by resources.
GroupByTasks | Group by tasks.
None | No grouping or filtering.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ISupportInitialize Interface

ISupportInitialize Interface

Specifies that this object supports a simple, transacted notification for batch initialization.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public interface ISupportInitialize
Visual Basic

Public Interface ISupportInitialize

See Also

ISupportInitialize Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ISupportInitialize Members

ISupportInitialize Members
Methods

Specifies that this object supports a simple, transacted notification for batch initialization.

The following tables list the members exposed by the ISupportInitialize type.

Public Methods

Name | Description
BeginInit | Signals the object that initialization is starting.
EndInit | Signals the object that initialization is complete.

See Also

ISupportInitialize Interface
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ISupportInitialize Methods

ISupportInitialize Methods

Public Methods

Name | Description
BeginInit | Signals the object that initialization is starting.
EndInit | Signals the object that initialization is complete.

See Also

ISupportInitialize Interface
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ISupportInitialize.BeginInit Method

ISupportInitialize.BeginInit Method

Signals the object that initialization is starting.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public abstract void BeginInit ()
Visual Basic

Public MustOverride Sub BeginInit ()

See Also

ISupportInitialize Members
ISupportInitialize Interface
MindFusion.Scheduling.Compact Namespace
EndInit Method


MindFusion.Scheduling.WinForms.ISupportInitialize.EndInit Method

ISupportInitialize.EndInit Method

Signals the object that initialization is complete.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public abstract void EndInit ()
Visual Basic

Public MustOverride Sub EndInit ()

See Also

ISupportInitialize Members
ISupportInitialize Interface
MindFusion.Scheduling.Compact Namespace
BeginInit Method


MindFusion.Scheduling.WinForms.ItemAction Enumeration

ItemAction Enumeration

Specifies a user action on a schedule item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum ItemAction
Visual Basic

Public Enumeration ItemAction

Members

Member name | Description
Move | Indicates that the item is being moved.
None | Indicates no action.
ResizeEnd | Indicates that the item's end is being modified.
ResizeStart | Indicates that the item's start is being modified.
Unspecified | An unspecified action.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemConfirmEventArgs Class

ItemConfirmEventArgs Class

Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class ItemConfirmEventArgs : ItemEventArgs
Visual Basic

Public Class ItemConfirmEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.ItemEventArgs
MindFusion.Scheduling.Compact.ItemConfirmEventArgs
MindFusion.Scheduling.Compact.ItemEditConfirmEventArgs
MindFusion.Scheduling.Compact.ItemModifyConfirmEventArgs

See Also

ItemConfirmEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemConfirmEventArgs Members

ItemConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of item validation events, such as ItemCreating and ItemDeleting.

The following tables list the members exposed by the ItemConfirmEventArgs type.

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.

See Also

ItemConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemConfirmEventArgs Properties

ItemConfirmEventArgs Properties

Public Properties

Name | Description
Confirm | Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.

See Also

ItemConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemConfirmEventArgs.Confirm Property

ItemConfirmEventArgs.Confirm Property

Gets or sets a value indicating whether the action related to this event should be confirmed or canceled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool Confirm { get; set; }
Visual Basic

Public Property Confirm As Boolean

Property Value

Set Confirm to false to prevent the action or to true to allow it. The default is true.

See Also

ItemConfirmEventArgs Members
ItemConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemConfirmEventHandler Delegate

ItemConfirmEventHandler Delegate

Represents methods that will handle item validation events such as ItemCreating and ItemDeleting.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void ItemConfirmEventHandler (
Object sender,
ItemConfirmEventArgs e
)
Visual Basic

Public Delegate Sub ItemConfirmEventHandler ( _
sender As Object, _
e As ItemConfirmEventArgs _
)

Parameters

sender
The source of the event.
e
An ItemConfirmEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemEditConfirmEventArgs Class

ItemEditConfirmEventArgs Class

Contains the arguments passed to handlers of the ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class ItemEditConfirmEventArgs : ItemConfirmEventArgs
Visual Basic

Public Class ItemEditConfirmEventArgs
Inherits ItemConfirmEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.ItemEventArgs
MindFusion.Scheduling.Compact.ItemConfirmEventArgs
MindFusion.Scheduling.Compact.ItemEditConfirmEventArgs

See Also

ItemEditConfirmEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemEditConfirmEventArgs Members

ItemEditConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of the ItemInplaceEditEnding event.

The following tables list the members exposed by the ItemEditConfirmEventArgs type.

Public Properties

Name | Description
NewText | Gets the new text that will be applied to the item if the in-place editing operation is allowed.

See Also

ItemEditConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemEditConfirmEventArgs Properties

ItemEditConfirmEventArgs Properties

Public Properties

Name | Description
NewText | Gets the new text that will be applied to the item if the in-place editing operation is allowed.

See Also

ItemEditConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemEditConfirmEventArgs.NewText Property

ItemEditConfirmEventArgs.NewText Property

Gets the new text that will be applied to the item if the in-place editing operation is allowed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string NewText { get; }
Visual Basic

Public ReadOnly Property NewText As String

Property Value

A string containing the new text of the item.

See Also

ItemEditConfirmEventArgs Members
ItemEditConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemEditConfirmEventHandler Delegate

ItemEditConfirmEventHandler Delegate

Represents methods that will handle the ItemInplaceEditEnding event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void ItemEditConfirmEventHandler (
Object sender,
ItemEditConfirmEventArgs e
)
Visual Basic

Public Delegate Sub ItemEditConfirmEventHandler ( _
sender As Object, _
e As ItemEditConfirmEventArgs _
)

Parameters

sender
The source of the event.
e
An ItemEditConfirmEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemEventArgs Class

ItemEventArgs Class

Contains the arguments passed to handlers of item related events, such as ItemCreated and ItemDeleted.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class ItemEventArgs : EventArgs
Visual Basic

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.ItemEventArgs
MindFusion.Scheduling.Compact.ItemConfirmEventArgs
MindFusion.Scheduling.Compact.ItemModifiedEventArgs
MindFusion.Scheduling.Compact.ItemMouseEventArgs
MindFusion.Scheduling.Compact.ItemSelectionEventArgs
MindFusion.Scheduling.Compact.RecurringItemConfirmEventArgs

See Also

ItemEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemEventArgs Members

ItemEventArgs Members
Properties

Contains the arguments passed to handlers of item related events, such as ItemCreated and ItemDeleted.

The following tables list the members exposed by the ItemEventArgs type.

Public Properties

Name | Description
Item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemEventArgs Properties

ItemEventArgs Properties

Public Properties

Name | Description
Item | Gets the item related to the event.

See Also

ItemEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemEventArgs.Item Property

ItemEventArgs.Item Property

Gets the item related to the event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Item Item { get; }
Visual Basic

Public ReadOnly Property Item As Item

Property Value

An instance of the Item class for which the event is raised.

See Also

ItemEventArgs Members
ItemEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemEventHandler Delegate

ItemEventHandler Delegate

Represents methods that will handle general item related events.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void ItemEventHandler (
Object sender,
ItemEventArgs e
)
Visual Basic

Public Delegate Sub ItemEventHandler ( _
sender As Object, _
e As ItemEventArgs _
)

Parameters

sender

The source of the event.

e
An ItemEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs Class

ItemModifiedEventArgs Class

Contains the arguments passed to handlers of the ItemModified event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class ItemModifiedEventArgs : ItemEventArgs
Visual Basic

Public Class ItemModifiedEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.ItemEventArgs
MindFusion.Scheduling.Compact.ItemModifiedEventArgs

See Also

ItemModifiedEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs Members

ItemModifiedEventArgs Members
Properties

Contains the arguments passed to handlers of the ItemModified event.

The following tables list the members exposed by the ItemModifiedEventArgs type.

Public Properties

Name | Description
OldEndTime | Gets the old end time of the item.
OldResources | Gets the old resources the item was associated with.
OldStartTime | Gets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end has been modified.
ResizeStart | Gets a value indicating whether the item's start has been modified.

See Also

ItemModifiedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs Properties

ItemModifiedEventArgs Properties

Public Properties

Name | Description
OldEndTime | Gets the old end time of the item.
OldResources | Gets the old resources the item was associated with.
OldStartTime | Gets the old start time of the item.
ResizeEnd | Gets a value indicating whether the item's end has been modified.
ResizeStart | Gets a value indicating whether the item's start has been modified.

See Also

ItemModifiedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs.OldEndTime Property

ItemModifiedEventArgs.OldEndTime Property

Gets the old end time of the item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime OldEndTime { get; }
Visual Basic

Public ReadOnly Property OldEndTime As DateTime

Property Value

A .NET DateTime value representing the original end time of the modified item.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs.OldResources Property

ItemModifiedEventArgs.OldResources Property

Gets the old resources the item was associated with.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ResourceCollection OldResources { get; }
Visual Basic

Public ReadOnly Property OldResources As ResourceCollection

Property Value

A collection of resources originally associated with the item.

Remarks

The returned collection might contain Contact, Location, Task or Resource objects depending on the current grouping type.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs.OldStartTime Property

ItemModifiedEventArgs.OldStartTime Property

Gets the old start time of the item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime OldStartTime { get; }
Visual Basic

Public ReadOnly Property OldStartTime As DateTime

Property Value

A .NET DateTime value representing the original start time of the modified item.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs.ResizeEnd Property

ItemModifiedEventArgs.ResizeEnd Property

Gets a value indicating whether the item's end has been modified.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool ResizeEnd { get; }
Visual Basic

Public ReadOnly Property ResizeEnd As Boolean

Property Value

true if the item's end has been modified; false if item was moved or its start has been modified.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventArgs.ResizeStart Property

ItemModifiedEventArgs.ResizeStart Property

Gets a value indicating whether the item's start has been modified.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool ResizeStart { get; }
Visual Basic

Public ReadOnly Property ResizeStart As Boolean

Property Value

true if the item's start has been modified; false if item was moved or its end has been modified.

See Also

ItemModifiedEventArgs Members
ItemModifiedEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifiedEventHandler Delegate

ItemModifiedEventHandler Delegate

Represents methods that will handle the ItemModified event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void ItemModifiedEventHandler (
Object sender,
ItemModifiedEventArgs e
)
Visual Basic

Public Delegate Sub ItemModifiedEventHandler ( _
sender As Object, _
e As ItemModifiedEventArgs _
)

Parameters

sender
The source of the event.
e
An ItemModifiedEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs Class

ItemModifyConfirmEventArgs Class

Contains the arguments passed to handlers of the ItemModifying event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class ItemModifyConfirmEventArgs : ItemConfirmEventArgs
Visual Basic

Public Class ItemModifyConfirmEventArgs
Inherits ItemConfirmEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.ItemEventArgs
MindFusion.Scheduling.Compact.ItemConfirmEventArgs
MindFusion.Scheduling.Compact.ItemModifyConfirmEventArgs

See Also

ItemModifyConfirmEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs Members

ItemModifyConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of the ItemModifying event.

The following tables list the members exposed by the ItemModifyConfirmEventArgs type.

Public Properties

Name | Description
NewEndTime | Gets or sets the new end time of the item.
NewStartTime | Gets or sets the new start time of the item.
ResizeEnd | Gets a value indicating whether the item's end is being modified.
ResizeStart | Gets a value indicating whether the item's start is being modified.
Resource | Gets the new resource of the item.

See Also

ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs Properties

ItemModifyConfirmEventArgs Properties

Public Properties

Name | Description
NewEndTime | Gets or sets the new end time of the item.
NewStartTime | Gets or sets the new start time of the item.
ResizeEnd | Gets a value indicating whether the item's end is being modified.
ResizeStart | Gets a value indicating whether the item's start is being modified.
Resource | Gets the new resource of the item.

See Also

ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.NewEndTime Property

ItemModifyConfirmEventArgs.NewEndTime Property

Gets or sets the new end time of the item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime NewEndTime { get; set; }
Visual Basic

Public Property NewEndTime As DateTime

Property Value

A .NET DateTime object specifying the item's new end time.

Remarks

You will generally need to inspect the value of this property in order to see whether the new end time of the item would satisfy the criteria of your application, in order to confirm or refuse the user operation accordingly. In certain cases, however, you might want to set a new value to this property, thus forcing the end time of the item, disregarding the user's actions.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.NewStartTime Property

ItemModifyConfirmEventArgs.NewStartTime Property

Gets or sets the new start time of the item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime NewStartTime { get; set; }
Visual Basic

Public Property NewStartTime As DateTime

Property Value

A .NET DateTime object specifying the item's new start time.

Remarks

You will generally need to inspect the value of this property in order to see whether the new start time of the item would satisfy the criteria of your application, so to confirm or refuse the user operation accordingly. In certain cases, however, you might want to set a new value to this property, thus forcing the start time of the item, disregarding the user's actions.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.ResizeEnd Property

ItemModifyConfirmEventArgs.ResizeEnd Property

Gets a value indicating whether the item's end is being modified.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool ResizeEnd { get; }
Visual Basic

Public ReadOnly Property ResizeEnd As Boolean

Property Value

true if the item's end is being modified; false if item is moved or its start is being modified.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.ResizeStart Property

ItemModifyConfirmEventArgs.ResizeStart Property

Gets a value indicating whether the item's start is being modified.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool ResizeStart { get; }
Visual Basic

Public ReadOnly Property ResizeStart As Boolean

Property Value

true if the item's start is being modified; false if item is moved or its end is being modified.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventArgs.Resource Property

ItemModifyConfirmEventArgs.Resource Property

Gets the new resource of the item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

A reference to a Contact, Location, Task or Resource depending on the current grouping type.

Remarks

This value can be null (Nothing in Visual Basic), if the item doesn't change associated resource.

See Also

ItemModifyConfirmEventArgs Members
ItemModifyConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemModifyConfirmEventHandler Delegate

ItemModifyConfirmEventHandler Delegate

Represents methods that will handle the ItemModifying event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void ItemModifyConfirmEventHandler (
Object sender,
ItemModifyConfirmEventArgs e
)
Visual Basic

Public Delegate Sub ItemModifyConfirmEventHandler ( _
sender As Object, _
e As ItemModifyConfirmEventArgs _
)

Parameters

sender
The source of the event.
e
An ItemModifyConfirmEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs Class

ItemMouseEventArgs Class

Contains the arguments passed to handlers of the ItemClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class ItemMouseEventArgs : ItemEventArgs
Visual Basic

Public Class ItemMouseEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.ItemEventArgs
MindFusion.Scheduling.Compact.ItemMouseEventArgs

See Also

ItemMouseEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs Members

ItemMouseEventArgs Members
Properties

Contains the arguments passed to handlers of the ItemClick event.

The following tables list the members exposed by the ItemMouseEventArgs type.

Public Properties

Name | Description
Button | Gets the pressed mouse button.
ResizeEnd | Gets a value indicating whether the item's end is about to be resized.
ResizeStart | Gets a value indicating whether the item's start is about to be resized.
X | Gets the x-position of the mouse relative to the item.
Y | Gets the y-position of the mouse relative to the item.

See Also

ItemMouseEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs Properties

ItemMouseEventArgs Properties

Public Properties

Name | Description
Button | Gets the pressed mouse button.
ResizeEnd | Gets a value indicating whether the item's end is about to be resized.
ResizeStart | Gets a value indicating whether the item's start is about to be resized.
X | Gets the x-position of the mouse relative to the item.
Y | Gets the y-position of the mouse relative to the item.

See Also

ItemMouseEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.Button Property

ItemMouseEventArgs.Button Property

Gets the pressed mouse button.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public MouseButtons Button { get; }
Visual Basic

Public ReadOnly Property Button As MouseButtons

Property Value

A member of the .NET MouseButtons enumeration.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.ResizeEnd Property

ItemMouseEventArgs.ResizeEnd Property

Gets a value indicating whether the item's end is about to be resized.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool ResizeEnd { get; }
Visual Basic

Public ReadOnly Property ResizeEnd As Boolean

Property Value

A Boolean value indicating whether the item's end is about to be resized in an ItemClick event.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.ResizeStart Property

ItemMouseEventArgs.ResizeStart Property

Gets a value indicating whether the item's start is about to be resized.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool ResizeStart { get; }
Visual Basic

Public ReadOnly Property ResizeStart As Boolean

Property Value

A Boolean value indicating whether the item's start is about to be resized in an ItemClick event.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.X Property

ItemMouseEventArgs.X Property

Gets the x-position of the mouse relative to the item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int X { get; }
Visual Basic

Public ReadOnly Property X As Integer

Property Value

An integer value specifying the mouse position relatively to the item.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Compact Namespace
Y Property


MindFusion.Scheduling.WinForms.ItemMouseEventArgs.Y Property

ItemMouseEventArgs.Y Property

Gets the y-position of the mouse relative to the item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Y { get; }
Visual Basic

Public ReadOnly Property Y As Integer

Property Value

An integer value specifying the mouse position relatively to the item.

See Also

ItemMouseEventArgs Members
ItemMouseEventArgs Class
MindFusion.Scheduling.Compact Namespace
X Property


MindFusion.Scheduling.WinForms.ItemMouseEventHandler Delegate

ItemMouseEventHandler Delegate

Represents methods that will handle the ItemClick event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void ItemMouseEventHandler (
Object sender,
ItemMouseEventArgs e
)
Visual Basic

Public Delegate Sub ItemMouseEventHandler ( _
sender As Object, _
e As ItemMouseEventArgs _
)

Parameters

sender
The source of the event.
e
An ItemMouseEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelection Class

ItemSelection Class

Represents a set of selected schedule items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class ItemSelection
Visual Basic

Public NotInheritable Class ItemSelection

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.ItemSelection

See Also

ItemSelection Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelection Members

ItemSelection Members
Properties Methods

Represents a set of selected schedule items.

The following tables list the members exposed by the ItemSelection type.

Public Properties

Name | Description
Count | Gets the number of selected items.
Items | Gets the selected items.

Public Methods

Name | Description
Add | Adds the specified item to the selection.
Clear | Clears the selection.
Contains | Determines whether the specified item is currently selected.
Remove | Removes the specified item from the selection.

See Also

ItemSelection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelection Methods

ItemSelection Methods

Public Methods

Name | Description
Add | Adds the specified item to the selection.
Clear | Clears the selection.
Contains | Determines whether the specified item is currently selected.
Remove | Removes the specified item from the selection.

See Also

ItemSelection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Add Method

ItemSelection.Add Method

Adds the specified item to the selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Add (
Item item
)
Visual Basic

Public Sub Add ( _
item As Item _
)

Parameters

item
The Item instance to be added to the selection.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Clear Method

ItemSelection.Clear Method

Clears the selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Clear ()
Visual Basic

Public Sub Clear ()

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Contains Method

ItemSelection.Contains Method

Determines whether the specified item is currently selected.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
Item item
)
Visual Basic

Public Function Contains ( _
item As Item _
) As Boolean

Parameters

item
The Item instance to search for in the selection.

Return Value

true if the item is selected or false if it isn't.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Remove Method

ItemSelection.Remove Method

Removes the specified item from the selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Remove (
Item item
)
Visual Basic

Public Sub Remove ( _
item As Item _
)

Parameters

item
The Item instance to be removed from the selection.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelection Properties

ItemSelection Properties

Public Properties

Name | Description
Count | Gets the number of selected items.
Items | Gets the selected items.

See Also

ItemSelection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Count Property

ItemSelection.Count Property

Gets the number of selected items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Count { get; }
Visual Basic

Public ReadOnly Property Count As Integer

Property Value

An integer value specifying the number of selected items.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelection.Items Property

ItemSelection.Items Property

Gets the selected items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Item[] Items { get; }
Visual Basic

Public ReadOnly Property Items As Item()

Property Value

An array of selected Item objects.

See Also

ItemSelection Members
ItemSelection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelectionEventArgs Class

ItemSelectionEventArgs Class

Contains the arguments passed to handlers of selection related events.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class ItemSelectionEventArgs : ItemEventArgs
Visual Basic

Public Class ItemSelectionEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.ItemEventArgs
MindFusion.Scheduling.Compact.ItemSelectionEventArgs

See Also

ItemSelectionEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelectionEventArgs Members

ItemSelectionEventArgs Members
Properties

Contains the arguments passed to handlers of selection related events.

The following tables list the members exposed by the ItemSelectionEventArgs type.

Public Properties

Name | Description
IsDeselected | Gets a value indicating whether the item was deselected.
IsSelected | Gets a value indicating whether the item was selected.

See Also

ItemSelectionEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelectionEventArgs Properties

ItemSelectionEventArgs Properties

Public Properties

Name | Description
IsDeselected | Gets a value indicating whether the item was deselected.
IsSelected | Gets a value indicating whether the item was selected.

See Also

ItemSelectionEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSelectionEventArgs.IsDeselected Property

ItemSelectionEventArgs.IsDeselected Property

Gets a value indicating whether the item was deselected.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool IsDeselected { get; }
Visual Basic

Public ReadOnly Property IsDeselected As Boolean

Property Value

true if the the item was deselected by the user; false if the item was selected.

Remarks

This property is mutually exclusive with IsSelected, that is, when one of them is false, the other is true, and vice versa.

See Also

ItemSelectionEventArgs Members
ItemSelectionEventArgs Class
MindFusion.Scheduling.Compact Namespace
IsSelected Property


MindFusion.Scheduling.WinForms.ItemSelectionEventArgs.IsSelected Property

ItemSelectionEventArgs.IsSelected Property

Gets a value indicating whether the item was selected.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool IsSelected { get; }
Visual Basic

Public ReadOnly Property IsSelected As Boolean

Property Value

true if the the item was selected by the user; false if the item was deselected.

Remarks

This property is mutually exclusive with IsDeselected, that is, when one of them is false, the other is true, and vice versa.

See Also

ItemSelectionEventArgs Members
ItemSelectionEventArgs Class
MindFusion.Scheduling.Compact Namespace
IsDeselected Property


MindFusion.Scheduling.WinForms.ItemSelectionEventHandler Delegate

ItemSelectionEventHandler Delegate

Represents methods that will handle item selection related events.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void ItemSelectionEventHandler (
Object sender,
ItemSelectionEventArgs e
)
Visual Basic

Public Delegate Sub ItemSelectionEventHandler ( _
sender As Object, _
e As ItemSelectionEventArgs _
)

Parameters

sender
The source of the event.
e
An ItemSelectionEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings Class

ItemSettings Class

Defines properties that allow customizing the visualization of schedule items in the calendar views.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class ItemSettings
Visual Basic

Public Class ItemSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.ItemSettings

See Also

ItemSettings Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings Members

ItemSettings Members
Properties Methods Events

Defines properties that allow customizing the visualization of schedule items in the calendar views.

The following tables list the members exposed by the ItemSettings type.

Public Properties

Name | Description
CapIncompleteSegments | Gets or sets a value indicating whether to cap incomplete item segments.
EnableDefaultRendering | Gets or sets a value indicating whether the default item rendering is enabled.
HeaderSize | Gets or sets the size of the item header for non all-day items in the Timetable view.
ItemsVisible | Gets or sets a value indicating whether to display schedule items in the calendar.
MoveBandSize | Gets or sets the size of the move band of items in the Timetable view.
Padding | Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.
ResizeBandSize | Gets or sets the size of the bands used to resize an item in a Timetable view.
SelectedItemStyle | Gets or sets the Style used to paint selected schedule items.
ShadowColor | Gets or sets the color of the shadow cast by the items.
ShadowOffset | Gets or set the offset of the shadows from the items that cast them.
ShadowStyle | Gets or sets the style of the shadow cast by the items.
ShowContinuationArrows | Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' icon in a calendar cell which isn't big enough to contain all of its items.
ShowRecurrenceExceptionIcons | Gets or sets a value indicating whether the icon of recurrence exception items is displayed.
ShowRecurrenceIcons | Gets or sets a value indicating whether the icon of recurring items is displayed.
ShowReminderIcons | Gets or sets a value indicating whether the reminder icon of items is displayed.
Size | Gets or sets the size of schedule items drawn in the calendar.
Spacing | Gets or sets the amount of space between adjacent items.
Style | Gets or sets the Style used to paint schedule items that don't have a distinct style assigned to them.

Protected Methods

Name | Description
OnSettingsChanged | Fires the SettingsChanged event.

Public Events

Name | Description
SettingsChanged | Raised when an ItemSettings object has changed.

See Also

ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings Methods

ItemSettings Methods

Protected Methods

Name | Description
OnSettingsChanged | Fires the SettingsChanged event.

See Also

ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.OnSettingsChanged Method

ItemSettings.OnSettingsChanged Method

Fires the SettingsChanged event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

protected virtual void OnSettingsChanged (
EventArgs e
)
Visual Basic

Protected Overridable Sub OnSettingsChanged ( _
e As EventArgs _
)

Parameters

e
An object, containing the event data.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings Properties

ItemSettings Properties

Public Properties

Name | Description
CapIncompleteSegments | Gets or sets a value indicating whether to cap incomplete item segments.
EnableDefaultRendering | Gets or sets a value indicating whether the default item rendering is enabled.
HeaderSize | Gets or sets the size of the item header for non all-day items in the Timetable view.
ItemsVisible | Gets or sets a value indicating whether to display schedule items in the calendar.
MoveBandSize | Gets or sets the size of the move band of items in the Timetable view.
Padding | Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.
ResizeBandSize | Gets or sets the size of the bands used to resize an item in a Timetable view.
SelectedItemStyle | Gets or sets the Style used to paint selected schedule items.
ShadowColor | Gets or sets the color of the shadow cast by the items.
ShadowOffset | Gets or set the offset of the shadows from the items that cast them.
ShadowStyle | Gets or sets the style of the shadow cast by the items.
ShowContinuationArrows | Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' icon in a calendar cell which isn't big enough to contain all of its items.
ShowRecurrenceExceptionIcons | Gets or sets a value indicating whether the icon of recurrence exception items is displayed.
ShowRecurrenceIcons | Gets or sets a value indicating whether the icon of recurring items is displayed.
ShowReminderIcons | Gets or sets a value indicating whether the reminder icon of items is displayed.
Size | Gets or sets the size of schedule items drawn in the calendar.
Spacing | Gets or sets the amount of space between adjacent items.
Style | Gets or sets the Style used to paint schedule items that don't have a distinct style assigned to them.

See Also

ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.CapIncompleteSegments Property

ItemSettings.CapIncompleteSegments Property

Gets or sets a value indicating whether to cap incomplete item segments.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State CapIncompleteSegments { get; set; }
Visual Basic

Public Property CapIncompleteSegments As State

Property Value

Specify Enabled to cap incomplete items segments; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

This property is ignored for non all-day items in the Timetable view.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.EnableDefaultRendering Property

ItemSettings.EnableDefaultRendering Property

Gets or sets a value indicating whether the default item rendering is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State EnableDefaultRendering { get; set; }
Visual Basic

Public Property EnableDefaultRendering As State

Property Value

A member of the State enumeration specifying whether the control should paint schedule items.

Remarks

You can disable this property when you perform complete custom drawing of your items and don't want the Calendar control to perform default painting. This way you can substantially optimize the performance of your application.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.HeaderSize Property

ItemSettings.HeaderSize Property

Gets or sets the size of the item header for non all-day items in the Timetable view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int HeaderSize { get; set; }
Visual Basic

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the item header (in pixels). Assign -1 to this property to use the corresponding value from the current theme.

Remarks

You can assign 0 to hide the item header completely.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.ItemsVisible Property

ItemSettings.ItemsVisible Property

Gets or sets a value indicating whether to display schedule items in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ItemsVisible { get; set; }
Visual Basic

Public Property ItemsVisible As State

Property Value

Specify Enabled to display schedule items; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.MoveBandSize Property

ItemSettings.MoveBandSize Property

Gets or sets the size of the move band of items in the Timetable view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MoveBandSize { get; set; }
Visual Basic

Public Property MoveBandSize As Integer

Property Value

A non-negative integer value specifying the band size in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.Padding Property

ItemSettings.Padding Property

Gets or sets the amount of space between each item and the frame lines of the calendar cell that contains the item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Padding { get; set; }
Visual Basic

Public Property Padding As Integer

Property Value

A non-negative integer value specifying how many pixels there are left between items and the time cells containing them. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

In a Timetable view this is the distance between consecutive items.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.ResizeBandSize Property

ItemSettings.ResizeBandSize Property

Gets or sets the size of the bands used to resize an item in a Timetable view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ResizeBandSize { get; set; }
Visual Basic

Public Property ResizeBandSize As Integer

Property Value

An integer value specifying the bands' size in pixels. The minimal allowed value is 2. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.SelectedItemStyle Property

ItemSettings.SelectedItemStyle Property

Gets or sets the Style used to paint selected schedule items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style SelectedItemStyle { get; set; }
Visual Basic

Public Property SelectedItemStyle As Style

Property Value

A Style object defining the appearance of schedule items. This property cannot be null.

Remarks

To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace
Style Property
PointedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property


MindFusion.Scheduling.WinForms.ItemSettings.ShadowColor Property

ItemSettings.ShadowColor Property

Gets or sets the color of the shadow cast by the items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Color ShadowColor { get; set; }
Visual Basic

Public Property ShadowColor As Color

Property Value

A .NET Color object specifying the color of item shadows. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace
ShadowOffset Property
ShadowStyle Property


MindFusion.Scheduling.WinForms.ItemSettings.ShadowOffset Property

ItemSettings.ShadowOffset Property

Gets or set the offset of the shadows from the items that cast them.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ShadowOffset { get; set; }
Visual Basic

Public Property ShadowOffset As Integer

Property Value

An integer value specifying with how many pixels an item's shadow is offset from the item. The allowed values range from 1 to 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace
ShadowColor Property
ShadowStyle Property


MindFusion.Scheduling.WinForms.ItemSettings.ShadowStyle Property

ItemSettings.ShadowStyle Property

Gets or sets the style of the shadow cast by the items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ShadowStyle ShadowStyle { get; set; }
Visual Basic

Public Property ShadowStyle As ShadowStyle

Property Value

A member of the ShadowStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace
ShadowColor Property
ShadowOffset Property


MindFusion.Scheduling.WinForms.ItemSettings.ShowContinuationArrows Property

ItemSettings.ShowContinuationArrows Property

Gets or sets a value indicating whether to display small arrows at the beginning or at the end of each incomplete segment to indicate that the schedule item continues in an adjacent calendar cell.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowContinuationArrows { get; set; }
Visual Basic

Public Property ShowContinuationArrows As State

Property Value

Specify Enabled to display arrow icons when an item continues in next time cell; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.ShowMoreItemsCue Property

ItemSettings.ShowMoreItemsCue Property

Gets or sets a value indicating whether to display a 'more items' icon in a calendar cell which isn't big enough to contain all of its items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowMoreItemsCue { get; set; }
Visual Basic

Public Property ShowMoreItemsCue As State

Property Value

Specify Enabled to display the 'more items' cue icon when there are items not visible in the current viewport. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.ShowRecurrenceExceptionIcons Property

ItemSettings.ShowRecurrenceExceptionIcons Property

Gets or sets a value indicating whether the icon of recurrence exception items is displayed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowRecurrenceExceptionIcons { get; set; }
Visual Basic

Public Property ShowRecurrenceExceptionIcons As State

Property Value

Specify Enabled to display an icon for the exceptions of recurring items; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace
ShowRecurrenceIcons Property
ShowReminderIcons Property


MindFusion.Scheduling.WinForms.ItemSettings.ShowRecurrenceIcons Property

ItemSettings.ShowRecurrenceIcons Property

Gets or sets a value indicating whether the icon of recurring items is displayed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowRecurrenceIcons { get; set; }
Visual Basic

Public Property ShowRecurrenceIcons As State

Property Value

Specify Enabled to display an icon for recurring items; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace
ShowRecurrenceExceptionIcons Property
ShowReminderIcons Property


MindFusion.Scheduling.WinForms.ItemSettings.ShowReminderIcons Property

ItemSettings.ShowReminderIcons Property

Gets or sets a value indicating whether the reminder icon of items is displayed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowReminderIcons { get; set; }
Visual Basic

Public Property ShowReminderIcons As State

Property Value

Specify Enabled to display an icon for items that have a reminder; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace
ShowRecurrenceIcons Property
ShowRecurrenceExceptionIcons Property


MindFusion.Scheduling.WinForms.ItemSettings.Size Property

ItemSettings.Size Property

Gets or sets the size of schedule items drawn in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Size { get; set; }
Visual Basic

Public Property Size As Integer

Property Value

A non-negative integer value specifying items width or height in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property specifies the height of horizontal items or the width of vertical items. The items length is defined by their start time and duration. The property is ignored for items drawn in timetable view.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace
Padding Property
Spacing Property


MindFusion.Scheduling.WinForms.ItemSettings.Spacing Property

ItemSettings.Spacing Property

Gets or sets the amount of space between adjacent items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Spacing { get; set; }
Visual Basic

Public Property Spacing As Integer

Property Value

A non-negative integer value specifying how many pixels there are between adjacent items. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace
Padding Property


MindFusion.Scheduling.WinForms.ItemSettings.Style Property

ItemSettings.Style Property

Gets or sets the Style used to paint schedule items that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

A Style object defining the appearance of schedule items. This property cannot be null.

Remarks

To read more about how this property affects items appearance, refer to the Customizing the Appearance of Items topic.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace
SelectedItemStyle Property
PointedItemStyle Property
PointedSelectedItemStyle Property
UseExtendedStyles Property


MindFusion.Scheduling.WinForms.ItemSettings Events

ItemSettings Events

Public Events

Name | Description
SettingsChanged | Raised when an ItemSettings object has changed.

See Also

ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ItemSettings.SettingsChanged Event

ItemSettings.SettingsChanged Event

Raised when an ItemSettings object has changed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public EventHandler SettingsChanged
Visual Basic

Public SettingsChanged As EventHandler

Event Data

SettingsChanged event handlers receive an argument of type EventArgs.

See Also

ItemSettings Members
ItemSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.LineStyle Enumeration

LineStyle Enumeration

Specifies the style of lines.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum LineStyle
Visual Basic

Public Enumeration LineStyle

Members

Member name | Description
Dotted | Specifies dotted style.
Invisible | Specifies invisible style.
Solid | Specifies solid style.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewHeaderStyles Enumeration

ListViewHeaderStyles Enumeration

Specifies the appearance and behavior of the header in a List view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum ListViewHeaderStyles
Visual Basic

Public Enumeration ListViewHeaderStyles

Members

Member name | Description
None | Do not display a header.
Subheader | Draw a sub-header below the main header. The subheader can be customized through the SubHeaderSize, SubTitleFormat and SubHeaderDivisions properties of the ListViewSettings class.
SubheaderPerCell | Draw the header background for each cell separately, rather than for the whole interval.
Title | Display the cells' dates in the header.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings Class

ListViewSettings Class

Defines properties that allow customizing the visualization of the calendar in a List view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class ListViewSettings : ViewSettings
Visual Basic

Public NotInheritable Class ListViewSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.ViewSettings
MindFusion.Scheduling.Compact.ListViewSettings

See Also

ListViewSettings Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings Members

ListViewSettings Members
Properties

Defines properties that allow customizing the visualization of the calendar in a List view.

The following tables list the members exposed by the ListViewSettings type.

Public Properties

Name | Description
CellSettings | Gets a CellSettings object used to customize the visualization of cells in the List view.
CellSpacing | Gets or sets the amount space between adjacent cells.
CellUnits | Gets or sets the resolution of the list view.
ContentsMargin | Gets or sets the amount of space between the contents border and the actual contents of the view.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EnableVirtualItemSpace | Gets or sets a value indicating whether items in the list view can be scrolled through.
EvenWeeksBrush | Gets or sets the brush used to paint the background of the contents of even weeks.
FreeDrag | Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the headers of individual columns.
HeaderSize | Gets or sets the header size in pixels.
HeaderStyle | Gets or sets the style of the List view header.
ItemOrientation | Gets or sets a value indicating whether the items are displayed horizontally, vertically or according to the orientation of the view.
NumberOfCells | Gets or sets the total number of cells to be displayed in the List view.
OddWeeksBrush | Gets or sets the brush used to paint the background of the contents of odd weeks.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
ScrollStep | Gets or sets the number of units to scroll when the user clicks the navigation buttons.
ShowGroupHeader | Gets or sets a value indicating whether to display the reference grouping header.
ShowNavigationButtons | Gets or sets a value indicating whether the List view displays navigation buttons.
SnapUnit | Gets or sets the snap unit.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderDivisions | Gets or sets the number of divisions in the sub-header.
SubHeaderSize | Gets or sets the subheader size in pixels.
SubTitleFormat | Gets or sets a string used to format the cells subtitles.
TitleFormat | Gets or sets a string used to format the cells titles.
TotalLaneCount | Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to Enabled.
VisibleCells | Gets or sets the number of cells visible at the same time.
VisibleColumns | Gets or sets the number of visible group columns in a list view.

See Also

ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings Properties

ListViewSettings Properties

Public Properties

Name | Description
CellSettings | Gets a CellSettings object used to customize the visualization of cells in the List view.
CellSpacing | Gets or sets the amount space between adjacent cells.
CellUnits | Gets or sets the resolution of the list view.
ContentsMargin | Gets or sets the amount of space between the contents border and the actual contents of the view.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EnableVirtualItemSpace | Gets or sets a value indicating whether items in the list view can be scrolled through.
EvenWeeksBrush | Gets or sets the brush used to paint the background of the contents of even weeks.
FreeDrag | Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.
GroupHeaderSize | Gets or sets the size of the group header.
GroupHeaderStyle | Gets or sets the appearance style used to paint the headers of individual columns.
HeaderSize | Gets or sets the header size in pixels.
HeaderStyle | Gets or sets the style of the List view header.
ItemOrientation | Gets or sets a value indicating whether the items are displayed horizontally, vertically or according to the orientation of the view.
NumberOfCells | Gets or sets the total number of cells to be displayed in the List view.
OddWeeksBrush | Gets or sets the brush used to paint the background of the contents of odd weeks.
Orientation | Gets or sets a value indicating whether the cells are displayed horizontally or vertically.
ScrollStep | Gets or sets the number of units to scroll when the user clicks the navigation buttons.
ShowGroupHeader | Gets or sets a value indicating whether to display the reference grouping header.
ShowNavigationButtons | Gets or sets a value indicating whether the List view displays navigation buttons.
SnapUnit | Gets or sets the snap unit.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderDivisions | Gets or sets the number of divisions in the sub-header.
SubHeaderSize | Gets or sets the subheader size in pixels.
SubTitleFormat | Gets or sets a string used to format the cells subtitles.
TitleFormat | Gets or sets a string used to format the cells titles.
TotalLaneCount | Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to Enabled.
VisibleCells | Gets or sets the number of cells visible at the same time.
VisibleColumns | Gets or sets the number of visible group columns in a list view.

See Also

ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.CellSettings Property

ListViewSettings.CellSettings Property

Gets a CellSettings object used to customize the visualization of cells in the List view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public CellSettings CellSettings { get; }
Visual Basic

Public ReadOnly Property CellSettings As CellSettings

Property Value

An instance of the CellSettings class.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.CellSpacing Property

ListViewSettings.CellSpacing Property

Gets or sets the amount space between adjacent cells.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int CellSpacing { get; set; }
Visual Basic

Public Property CellSpacing As Integer

Property Value

A non-negative integer value specifying how much space to leave (expressed in pixels). Assign -1 to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.CellUnits Property

ListViewSettings.CellUnits Property

Gets or sets the resolution of the list view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeUnit CellUnits { get; set; }
Visual Basic

Public Property CellUnits As TimeUnit

Property Value

A member of the TimeUnit enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.ContentsMargin Property

ListViewSettings.ContentsMargin Property

Gets or sets the amount of space between the contents border and the actual contents of the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ContentsMargin { get; set; }
Visual Basic

Public Property ContentsMargin As Integer

Property Value

A non-negative integer value defining the border space in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.EnableSnapping Property

ListViewSettings.EnableSnapping Property

Gets or sets a value indicating whether custom snapping is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State EnableSnapping { get; set; }
Visual Basic

Public Property EnableSnapping As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

When this property is enabled, the users will move and resize items with the precision specified in the SnapUnit property instead of the precision of the view's resolution. When this property is disabled, the items will snap automatically to the border of their containing cells.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
SnapUnit Property


MindFusion.Scheduling.WinForms.ListViewSettings.EnableVirtualItemSpace Property

ListViewSettings.EnableVirtualItemSpace Property

Gets or sets a value indicating whether items in the list view can be scrolled through.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State EnableVirtualItemSpace { get; set; }
Visual Basic

Public Property EnableVirtualItemSpace As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Use this property to override the default behavior of the vertical scrollbar (in a horizontal List view) or the horizontal scrollbar (in a vertical List view). When this property is enabled, the appropriate scrollbar will scroll through the items that are not visible within the view (due to insufficient space) rather than scroll through the cells associated with resources in a grouped List view.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
FreeDrag Property


MindFusion.Scheduling.WinForms.ListViewSettings.EvenWeeksBrush Property

ListViewSettings.EvenWeeksBrush Property

Gets or sets the brush used to paint the background of the contents of even weeks.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Brush EvenWeeksBrush { get; set; }
Visual Basic

Public Property EvenWeeksBrush As Brush

Property Value

An instance of a Brush-derived class. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
OddWeeksBrush Property


MindFusion.Scheduling.WinForms.ListViewSettings.FreeDrag Property

ListViewSettings.FreeDrag Property

Gets or sets a value indicating whether users can drag items anywhere in the view, not only in the first unoccupied row.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State FreeDrag { get; set; }
Visual Basic

Public Property FreeDrag As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Set this property to Enabled to disable the default item layout algorithm, where colliding items are arranged relative to each other according to their start and end times and their Priority. Turning this property on will allow users to move items anywhere within the view.

The position of an item acquired through free dragging is related to the view. This means that if the schedule, containing the item is displayed in another Calendar control, the item's position within the List view might not be the same as its position in the initial view. Additionally, view-related data is not serialized by calling the serialization methods of the Schedule class. In order to serialize and deserialize this data, you have to invoke the SaveTo and LoadFrom methods of the Calendar class instead.

Finally, the position of an item within the view can be obtained and set programmatically through the use of the GetItemListLane and SetItemListLane methods of the Calendar class.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.GroupHeaderSize Property

ListViewSettings.GroupHeaderSize Property

Gets or sets the size of the group header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int GroupHeaderSize { get; set; }
Visual Basic

Public Property GroupHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the calendar to automatically calculate a header size based on the size of the header font.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
ShowGroupHeader Property


MindFusion.Scheduling.WinForms.ListViewSettings.GroupHeaderStyle Property

ListViewSettings.GroupHeaderStyle Property

Gets or sets the appearance style used to paint the headers of individual columns.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style GroupHeaderStyle { get; set; }
Visual Basic

Public Property GroupHeaderStyle As Style

Property Value

A Style object specifying the style of the column headers. This property cannot be null.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.HeaderSize Property

ListViewSettings.HeaderSize Property

Gets or sets the header size in pixels.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int HeaderSize { get; set; }
Visual Basic

Public Property HeaderSize As Integer

Property Value

A non-negative integer value specifying the header size. A value of 0 hides the header. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property specifies the header width if Orientation is Horizontal or the height if Orientation is Vertical.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
HeaderStyle Property
TitleFormat Property


MindFusion.Scheduling.WinForms.ListViewSettings.HeaderStyle Property

ListViewSettings.HeaderStyle Property

Gets or sets the style of the List view header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ListViewHeaderStyles HeaderStyle { get; set; }
Visual Basic

Public Property HeaderStyle As ListViewHeaderStyles

Property Value

A member of the ListViewHeaderStyles enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
HeaderSize Property
TitleFormat Property


MindFusion.Scheduling.WinForms.ListViewSettings.ItemOrientation Property

ListViewSettings.ItemOrientation Property

Gets or sets a value indicating whether the items are displayed horizontally, vertically or according to the orientation of the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Orientation ItemOrientation { get; set; }
Visual Basic

Public Property ItemOrientation As Orientation

Property Value

A member of the Orientation enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Items are usually oriented according to the view's Orientation. That is, items are horizontal in a horizontal List view and vice versa. The orientation of the items can be explicitly specified by using this property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.NumberOfCells Property

ListViewSettings.NumberOfCells Property

Gets or sets the total number of cells to be displayed in the List view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int NumberOfCells { get; set; }
Visual Basic

Public Property NumberOfCells As Integer

Property Value

An integer value specifying how many days to display. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This value cannot be less than 1 or less than the number of visible days set in the VisibleCells property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
VisibleCells Property


MindFusion.Scheduling.WinForms.ListViewSettings.OddWeeksBrush Property

ListViewSettings.OddWeeksBrush Property

Gets or sets the brush used to paint the background of the contents of odd weeks.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Brush OddWeeksBrush { get; set; }
Visual Basic

Public Property OddWeeksBrush As Brush

Property Value

An instance of a Brush-derived class. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
EvenWeeksBrush Property


MindFusion.Scheduling.WinForms.ListViewSettings.Orientation Property

ListViewSettings.Orientation Property

Gets or sets a value indicating whether the cells are displayed horizontally or vertically.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Orientation Orientation { get; set; }
Visual Basic

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

If this property is set to Horizontal, the view header is displayed at the top and the day cells are arranged in a horizontal row underneath it. If set to Vertical, the header is displayed on the left side and the days are arranged in a vertical row on the right.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.ScrollStep Property

ListViewSettings.ScrollStep Property

Gets or sets the number of units to scroll when the user clicks the navigation buttons.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ScrollStep { get; set; }
Visual Basic

Public Property ScrollStep As Integer

Property Value

An integer value specifying the number of units to scroll. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property specifies the amount of units (as specified by the CellUnits property) to scroll back and forth when using the navigation buttons in the List view.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
ShowNavigationButtons Property


MindFusion.Scheduling.WinForms.ListViewSettings.ShowGroupHeader Property

ListViewSettings.ShowGroupHeader Property

Gets or sets a value indicating whether to display the reference grouping header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowGroupHeader { get; set; }
Visual Basic

Public Property ShowGroupHeader As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
GroupHeaderSize Property


MindFusion.Scheduling.WinForms.ListViewSettings.ShowNavigationButtons Property

ListViewSettings.ShowNavigationButtons Property

Gets or sets a value indicating whether the List view displays navigation buttons.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowNavigationButtons { get; set; }
Visual Basic

Public Property ShowNavigationButtons As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

The size of the buttons can be controlled through the ButtonSize property of the Calendar class. The amount of units to scroll can be specified through the ScrollStep property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
ScrollStep Property


MindFusion.Scheduling.WinForms.ListViewSettings.SnapUnit Property

ListViewSettings.SnapUnit Property

Gets or sets the snap unit.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeUnit SnapUnit { get; set; }
Visual Basic

Public Property SnapUnit As TimeUnit

Property Value

A member of the TimeUnit enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Use this property in a conjunction with the EnableSnapping property to specify the precision with which users can move and resize items interactively. If EnableSnapping is set to Disabled the value of this property is ignored and items snap to cell borders.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
EnableSnapping Property


MindFusion.Scheduling.WinForms.ListViewSettings.Style Property

ListViewSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
Style Class


MindFusion.Scheduling.WinForms.ListViewSettings.SubHeaderDivisions Property

ListViewSettings.SubHeaderDivisions Property

Gets or sets the number of divisions in the sub-header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int SubHeaderDivisions { get; set; }
Visual Basic

Public Property SubHeaderDivisions As Integer

Property Value

An integer value specifying the number of cells in the subheader. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

The value of this property is used only when the subheader of the List view is displayed (as specified by the HeaderStyle property). The value specifies the number of cells in the subheader. The date in each cell is calculated automatically and is displayed according to the SubTitleFormat property.

Example

The following example demonstrates how to setup a List view to display a week in each cell and the days of the week in the subheader. The example assumes that the variable calendar references an existing Calendar instance.

C#

calendar.CurrentView = CalendarView.List;
calendar.ListViewSettings.CellUnits = TimeUnit.Week;
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None;
calendar.ListViewSettings.TitleFormat = "dd, MMM";
calendar.ListViewSettings.Orientation = MindFusion.Scheduling.Compact.Orientation.Horizontal;
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader |
ListViewHeaderStyles.SubheaderPerCell | ListViewHeaderStyles.Title;
calendar.ListViewSettings.SubHeaderDivisions = 7;
calendar.ListViewSettings.SubTitleFormat = "w1";
Visual Basic

calendar.CurrentView = CalendarView.List
calendar.ListViewSettings.CellUnits = TimeUnit.Week
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None
calendar.ListViewSettings.TitleFormat = "dd, MMM"
calendar.ListViewSettings.Orientation = MindFusion.Scheduling.Compact.Orientation.Horizontal
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader Or _
ListViewHeaderStyles.SubheaderPerCell Or ListViewHeaderStyles.Title
calendar.ListViewSettings.SubHeaderDivisions = 7
calendar.ListViewSettings.SubTitleFormat = "w1"

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
HeaderStyle Property
SubHeaderSize Property
SubTitleFormat Property


MindFusion.Scheduling.WinForms.ListViewSettings.SubHeaderSize Property

ListViewSettings.SubHeaderSize Property

Gets or sets the subheader size in pixels.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int SubHeaderSize { get; set; }
Visual Basic

Public Property SubHeaderSize As Integer

Property Value

A non-negative integer value specifying the subheader size. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property specifies the subheader width if Orientation is Horizontal or the height if Orientation is Vertical.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
HeaderStyle Property
SubHeaderDivisions Property
SubTitleFormat Property


MindFusion.Scheduling.WinForms.ListViewSettings.SubTitleFormat Property

ListViewSettings.SubTitleFormat Property

Gets or sets a string used to format the cells subtitles.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string SubTitleFormat { get; set; }
Visual Basic

Public Property SubTitleFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic. Additionally, the "w1" format specifier can be used to display only the first letter of the day of the week (that is, 'M' for Monday, 'T' for Tuesday, and so on). This specifier cannot be combined with other specifiers, it can be used only by its own.

Example

The following example demonstrates how to setup a List view to display a week in each cell and the days of the week in the subheader. The example assumes that the variable calendar references an existing Calendar instance.

C#

calendar.CurrentView = CalendarView.List;
calendar.ListViewSettings.CellUnits = TimeUnit.Week;
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None;
calendar.ListViewSettings.TitleFormat = "dd, MMM";
calendar.ListViewSettings.Orientation = MindFusion.Scheduling.Compact.Orientation.Horizontal;
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader |
ListViewHeaderStyles.SubheaderPerCell | ListViewHeaderStyles.Title;
calendar.ListViewSettings.SubHeaderDivisions = 7;
calendar.ListViewSettings.SubTitleFormat = "w1";
Visual Basic

calendar.CurrentView = CalendarView.List
calendar.ListViewSettings.CellUnits = TimeUnit.Week
calendar.ListViewSettings.CellSettings.HeaderPosition = Position.None
calendar.ListViewSettings.TitleFormat = "dd, MMM"
calendar.ListViewSettings.Orientation = MindFusion.Scheduling.Compact.Orientation.Horizontal
calendar.ListViewSettings.HeaderStyle = ListViewHeaderStyles.Subheader Or _
ListViewHeaderStyles.SubheaderPerCell Or ListViewHeaderStyles.Title
calendar.ListViewSettings.SubHeaderDivisions = 7
calendar.ListViewSettings.SubTitleFormat = "w1"

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.TitleFormat Property

ListViewSettings.TitleFormat Property

Gets or sets a string used to format the cells titles.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string TitleFormat { get; set; }
Visual Basic

Public Property TitleFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ListViewSettings.TotalLaneCount Property

ListViewSettings.TotalLaneCount Property

Gets or sets the number of lanes in a List view whose EnableVirtualItemSpace is set to Enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int TotalLaneCount { get; set; }
Visual Basic

Public Property TotalLaneCount As Integer

Property Value

A non-negative integer value specifying the number of lanes in the view. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

When this property is set to 0, the item scrollbar is automatically adjusted so that it covers all existing items. Otherwise the item scrollbar is adjusted so that it covers the specified number of lanes.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
EnableVirtualItemSpace Property


MindFusion.Scheduling.WinForms.ListViewSettings.VisibleCells Property

ListViewSettings.VisibleCells Property

Gets or sets the number of cells visible at the same time.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int VisibleCells { get; set; }
Visual Basic

Public Property VisibleCells As Integer

Property Value

A positive integer value specifying how many days to display simultaneously in the day range view. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

The value assigned to this property cannot be less than 1 or less than the total number of days available in the view, as specified in the NumberOfCells property.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace
NumberOfCells Property


MindFusion.Scheduling.WinForms.ListViewSettings.VisibleColumns Property

ListViewSettings.VisibleColumns Property

Gets or sets the number of visible group columns in a list view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int VisibleColumns { get; set; }
Visual Basic

Public Property VisibleColumns As Integer

Property Value

A positive integer value specifying the number of columns visible at the same time. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property is actually used only in a grouped day range view. Otherwise, the number of columns in the view is always 1.

See Also

ListViewSettings Members
ListViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MinuteFormat Enumeration

MinuteFormat Enumeration

Specifies how to format and display minutes in the Timetable view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum MinuteFormat
Visual Basic

Public Enumeration MinuteFormat

Members

Member name | Description
Colons | Display a colon and a leading zero.
LeadingZero | Display a leading zero for single digit minutes.
NoLeadingZero | No leading zero for single digit minutes.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthCellLayout Enumeration

MonthCellLayout Enumeration

Specifies the layout of the cells in a SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum MonthCellLayout
Visual Basic

Public Enumeration MonthCellLayout

Members

Member name | Description
Grid | Indicates that the cells are laid out in a grid, where each row in the grid contains the days of a single week.
Linear | Indicates that the cells are laid out in a single row.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthHeaderStyles Enumeration

MonthHeaderStyles Enumeration

Specifies the appearance and behavior of month headers in a SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum MonthHeaderStyles
Visual Basic

Public Enumeration MonthHeaderStyles

Members

Member name | Description
MonthButtons | Display buttons for scrolling to previous or next month.
None | Do not display the header.
SubheaderPerDay | The sub headers are drawn separately for each day, rather than for the whole interval.
Title | Display the date of the month in the header.
Unspecified | Unspecified.
YearButtons | Display buttons for scrolling to previous or next year.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthRangeHeaderStyles Enumeration

MonthRangeHeaderStyles Enumeration

Specifies the appearance and behavior of the header in a MonthRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum MonthRangeHeaderStyles
Visual Basic

Public Enumeration MonthRangeHeaderStyles

Members

Member name | Description
Buttons | The header displays buttons that can be used to scroll to previous and following moths.
None | The header is not displayed.
Title | The header displays the start and end dates.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings Class

MonthRangeSettings Class

Defines settings for the years in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class MonthRangeSettings : ViewSettings
Visual Basic

Public NotInheritable Class MonthRangeSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.ViewSettings
MindFusion.Scheduling.Compact.MonthRangeSettings

See Also

MonthRangeSettings Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings Members

MonthRangeSettings Members
Properties

Defines settings for the years in the calendar.

The following tables list the members exposed by the MonthRangeSettings type.

Public Properties

Name | Description
ContentsMargin | Gets or sets the amount of space between the contents border and the actual contents of the view.
HeaderHeight | Gets or sets the height of the header in a MonthRange view.
HeaderSpacing | Gets or sets the amount of space between the headers.
HeaderStyle | Gets or sets the style of the MonthRange view header.
Margin | Gets or sets the amount of space between the outermost border of the view and its contents.
MonthSpacing | Gets or sets the amount of space between adjacent months.
MonthsPerRow | Gets or sets the number of months to be displayed in a row.
NumberOfMonths | Gets or sets the number of months to display in the MonthRange view.
ScrollInterval | Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TitleFormat | Gets or sets the string used to format the month titles.
TitleSeparator | Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.
VisibleRows | Gets or sets the number of rows to display at the same time.

See Also

MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings Properties

MonthRangeSettings Properties

Public Properties

Name | Description
ContentsMargin | Gets or sets the amount of space between the contents border and the actual contents of the view.
HeaderHeight | Gets or sets the height of the header in a MonthRange view.
HeaderSpacing | Gets or sets the amount of space between the headers.
HeaderStyle | Gets or sets the style of the MonthRange view header.
Margin | Gets or sets the amount of space between the outermost border of the view and its contents.
MonthSpacing | Gets or sets the amount of space between adjacent months.
MonthsPerRow | Gets or sets the number of months to be displayed in a row.
NumberOfMonths | Gets or sets the number of months to display in the MonthRange view.
ScrollInterval | Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TitleFormat | Gets or sets the string used to format the month titles.
TitleSeparator | Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.
VisibleRows | Gets or sets the number of rows to display at the same time.

See Also

MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings.ContentsMargin Property

MonthRangeSettings.ContentsMargin Property

Gets or sets the amount of space between the contents border and the actual contents of the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ContentsMargin { get; set; }
Visual Basic

Public Property ContentsMargin As Integer

Property Value

A non-negative integer value specifying how many pixels to leave between the contents border and the time cells. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
HeaderSpacing Property
Margin Property
MonthSpacing Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.HeaderHeight Property

MonthRangeSettings.HeaderHeight Property

Gets or sets the height of the header in a MonthRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int HeaderHeight { get; set; }
Visual Basic

Public Property HeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the calendar control to automatically calculate the header height based on the size of the header font.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
HeaderStyle Property
TitleFormat Property
TitleSeparator Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.HeaderSpacing Property

MonthRangeSettings.HeaderSpacing Property

Gets or sets the amount of space between the headers.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int HeaderSpacing { get; set; }
Visual Basic

Public Property HeaderSpacing As Integer

Property Value

An integer value specifying how many pixels there are between adjacent headers. The minimal allowed value is -1. Assign -2 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
ContentsMargin Property
Margin Property
MonthSpacing Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.HeaderStyle Property

MonthRangeSettings.HeaderStyle Property

Gets or sets the style of the MonthRange view header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public MonthRangeHeaderStyles HeaderStyle { get; set; }
Visual Basic

Public Property HeaderStyle As MonthRangeHeaderStyles

Property Value

A member of the MonthRangeHeaderStyles enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
HeaderHeight Property
TitleFormat Property
TitleSeparator Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.Margin Property

MonthRangeSettings.Margin Property

Gets or sets the amount of space between the outermost border of the view and its contents.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Margin { get; set; }
Visual Basic

Public Property Margin As Integer

Property Value

A non-negative integer value specifying how many pixels there are between the view contents and the outermost view border. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
ContentsMargin Property
HeaderSpacing Property
MonthSpacing Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.MonthSpacing Property

MonthRangeSettings.MonthSpacing Property

Gets or sets the amount of space between adjacent months.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MonthSpacing { get; set; }
Visual Basic

Public Property MonthSpacing As Integer

Property Value

A non-negative integer value specifying how many pixels there are between adjacent month cells. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
ContentsMargin Property
HeaderSpacing Property
Margin Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.MonthsPerRow Property

MonthRangeSettings.MonthsPerRow Property

Gets or sets the number of months to be displayed in a row.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MonthsPerRow { get; set; }
Visual Basic

Public Property MonthsPerRow As Integer

Property Value

An integer value specifying how many months are displayed in a row in the month range view. The allowed values range from 1 to 12. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

If this value multiplied by VisibleRows is larger than NumberOfMonths, the calendar control displays scrollbars letting users scroll the view up and down.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
VisibleRows Property
NumberOfMonths Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.NumberOfMonths Property

MonthRangeSettings.NumberOfMonths Property

Gets or sets the number of months to display in the MonthRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int NumberOfMonths { get; set; }
Visual Basic

Public Property NumberOfMonths As Integer

Property Value

A positive integer value specifying how many months to display in the view. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

If the number of months is set larger than number of rows multiplied by MonthsPerRow, the calendar displays scrollbar, letting users scroll the view up and down.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
VisibleRows Property
MonthsPerRow Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.ScrollInterval Property

MonthRangeSettings.ScrollInterval Property

Gets or sets the number of months to scroll the view back or forth in time when a scroll button is pressed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ScrollInterval { get; set; }
Visual Basic

Public Property ScrollInterval As Integer

Property Value

A positive integer value specifying with how many months to scroll the view. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings.Style Property

MonthRangeSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthRangeSettings.TitleFormat Property

MonthRangeSettings.TitleFormat Property

Gets or sets the string used to format the month titles.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string TitleFormat { get; set; }
Visual Basic

Public Property TitleFormat As String

Property Value

A string specifying the display format. Assign null to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
TitleSeparator Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.TitleSeparator Property

MonthRangeSettings.TitleSeparator Property

Gets or sets the string used as a title separator in a MonthRange view that displays more than 1 month at a time.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string TitleSeparator { get; set; }
Visual Basic

Public Property TitleSeparator As String

Property Value

A string containing the separator text. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format of the text displayed in the view's header is in the format "<FirstDate><TitleSeparator><LastDate>", where <FirstDate> and <LastDate> indicate the first and the last visible dates in the calendar, formatted according to the TitleFormat property. The <TitleSeparator> represents the value of this property. If TitleSeparator is set to an empty string, then the header's text is only "<FirstDate>". See the example below for more information.

Example

The following example shows how to display only the current year in the header of a MonthRange view. The sample assumes that calendar references an existing Calendar object.

C#

calendar.MonthRangeSettings.TitleFormat = "yyyy";
calendar.MonthRangeSettings.TitleSeparator = "";
Visual Basic

calendar.MonthRangeSettings.TitleFormat = "yyyy"
calendar.MonthRangeSettings.TitleSeparator = ""

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
TitleFormat Property


MindFusion.Scheduling.WinForms.MonthRangeSettings.VisibleRows Property

MonthRangeSettings.VisibleRows Property

Gets or sets the number of rows to display at the same time.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int VisibleRows { get; set; }
Visual Basic

Public Property VisibleRows As Integer

Property Value

A positive integer value specifying how many rows of month cells to display. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthRangeSettings Members
MonthRangeSettings Class
MindFusion.Scheduling.Compact Namespace
MonthsPerRow Property
NumberOfMonths Property


MindFusion.Scheduling.WinForms.MonthSettings Class

MonthSettings Class

Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class MonthSettings : ViewSettings
Visual Basic

Public NotInheritable Class MonthSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.ViewSettings
MindFusion.Scheduling.Compact.MonthSettings

See Also

MonthSettings Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings Members

MonthSettings Members
Properties

Defines properties that allow customizing the visualization of months in the SingleMonth and MonthRange views.

The following tables list the members exposed by the MonthSettings type.

Public Properties

Name | Description
CellLayout | Gets or sets the layout of the cells in SingleMonth and MonthRange views.
ContentsMargin | Gets or sets the amount of space between the month's day cells and the month's bounding rectangle.
DayOfWeekFormat | Gets or sets the format of the day names displayed in the week header.
DaySettings | Gets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.
DaySpacing | Gets or sets the amount of space between adjacent days.
HeaderSpacing | Gets or sets the amount of space between headers.
HeaderStyle | Gets or sets the style of the month's header.
LeadingWeekCount | Gets or sets the number of full weeks to display from the previous month.
MainHeaderHeight | Gets or sets the height of the main header in a SingleMonth view.
Margin | Gets or sets the amount of space between the outermost frame of the month and the month's contents.
PaddingDaysStyle | Gets or sets the Style object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the month's header.
ShowPaddingDays | Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderHeight | Gets or sets the height of the secondary header in a SingleMonth view.
TitleFormat | Gets or sets the string used to format the month's title.
TrailingWeekCount | Gets or sets the number of full weeks to display from the next month.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderStyle | Gets or sets the style of the week numbers header.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

See Also

MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings Properties

MonthSettings Properties

Public Properties

Name | Description
CellLayout | Gets or sets the layout of the cells in SingleMonth and MonthRange views.
ContentsMargin | Gets or sets the amount of space between the month's day cells and the month's bounding rectangle.
DayOfWeekFormat | Gets or sets the format of the day names displayed in the week header.
DaySettings | Gets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.
DaySpacing | Gets or sets the amount of space between adjacent days.
HeaderSpacing | Gets or sets the amount of space between headers.
HeaderStyle | Gets or sets the style of the month's header.
LeadingWeekCount | Gets or sets the number of full weeks to display from the previous month.
MainHeaderHeight | Gets or sets the height of the main header in a SingleMonth view.
Margin | Gets or sets the amount of space between the outermost frame of the month and the month's contents.
PaddingDaysStyle | Gets or sets the Style object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the month's header.
ShowPaddingDays | Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderHeight | Gets or sets the height of the secondary header in a SingleMonth view.
TitleFormat | Gets or sets the string used to format the month's title.
TrailingWeekCount | Gets or sets the number of full weeks to display from the next month.
WeekHeaderFormat | Gets or sets the format of the text displayed for each week in the week header.
WeekHeaderStyle | Gets or sets the style of the week numbers header.
WeekNumbersHeaderWidth | Gets or sets the width of the header, which displays week numbers.

See Also

MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings.CellLayout Property

MonthSettings.CellLayout Property

Gets or sets the layout of the cells in SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public MonthCellLayout CellLayout { get; set; }
Visual Basic

Public Property CellLayout As MonthCellLayout

Property Value

A member of the MonthCellLayout enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings.ContentsMargin Property

MonthSettings.ContentsMargin Property

Gets or sets the amount of space between the month's day cells and the month's bounding rectangle.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ContentsMargin { get; set; }
Visual Basic

Public Property ContentsMargin As Integer

Property Value

A non-negative integer value specifying how many pixels to leave between the cells and the month's bounds. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
DaySpacing Property
HeaderSpacing Property
Margin Property


MindFusion.Scheduling.WinForms.MonthSettings.DayOfWeekFormat Property

MonthSettings.DayOfWeekFormat Property

Gets or sets the format of the day names displayed in the week header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DayOfWeekFormat DayOfWeekFormat { get; set; }
Visual Basic

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

A member of the DayOfWeekFormat enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings.DaySettings Property

MonthSettings.DaySettings Property

Gets the CellSettings object used to customize the visualization of days in SingleMonth and MonthRange views.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public CellSettings DaySettings { get; }
Visual Basic

Public ReadOnly Property DaySettings As CellSettings

Property Value

An instance of the CellSettings class.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings.DaySpacing Property

MonthSettings.DaySpacing Property

Gets or sets the amount of space between adjacent days.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int DaySpacing { get; set; }
Visual Basic

Public Property DaySpacing As Integer

Property Value

A non-negative integer value specifying how many pixels to leave between adjacent day cells. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
ContentsMargin Property
HeaderSpacing Property
Margin Property


MindFusion.Scheduling.WinForms.MonthSettings.HeaderSpacing Property

MonthSettings.HeaderSpacing Property

Gets or sets the amount of space between headers.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int HeaderSpacing { get; set; }
Visual Basic

Public Property HeaderSpacing As Integer

Property Value

An integer value specifying how many pixels to leave between headers. The minimal allowed value is -1. Assign -2 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
ContentsMargin Property
DaySpacing Property
Margin Property


MindFusion.Scheduling.WinForms.MonthSettings.HeaderStyle Property

MonthSettings.HeaderStyle Property

Gets or sets the style of the month's header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public MonthHeaderStyles HeaderStyle { get; set; }
Visual Basic

Public Property HeaderStyle As MonthHeaderStyles

Property Value

A member of the MonthHeaderStyles enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings.LeadingWeekCount Property

MonthSettings.LeadingWeekCount Property

Gets or sets the number of full weeks to display from the previous month.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int LeadingWeekCount { get; set; }
Visual Basic

Public Property LeadingWeekCount As Integer

Property Value

A non-negative integer value specifying the number of weeks to display before the first week of the selected month. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
TrailingWeekCount Property


MindFusion.Scheduling.WinForms.MonthSettings.MainHeaderHeight Property

MonthSettings.MainHeaderHeight Property

Gets or sets the height of the main header in a SingleMonth view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MainHeaderHeight { get; set; }
Visual Basic

Public Property MainHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the main header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the Calendar control to automatically calculate the header size based on the header font size.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings.Margin Property

MonthSettings.Margin Property

Gets or sets the amount of space between the outermost frame of the month and the month's contents.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Margin { get; set; }
Visual Basic

Public Property Margin As Integer

Property Value

A non-negative integer value specifying the margins size in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
ContentsMargin Property
DaySpacing Property
HeaderSpacing Property


MindFusion.Scheduling.WinForms.MonthSettings.PaddingDaysStyle Property

MonthSettings.PaddingDaysStyle Property

Gets or sets the Style object used to specify appearance settings for the days from previous and next months, shown when the ShowPaddingDays property is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style PaddingDaysStyle { get; set; }
Visual Basic

Public Property PaddingDaysStyle As Style

Property Value

An instance of the Style class. This property cannot be null.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
ShowPaddingDays Property


MindFusion.Scheduling.WinForms.MonthSettings.ShowDayOfWeek Property

MonthSettings.ShowDayOfWeek Property

Gets or sets a value indicating whether the day names are displayed in the month's header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowDayOfWeek { get; set; }
Visual Basic

Public Property ShowDayOfWeek As State

Property Value

Specify Enabled to display day names; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

The day names are obtained from the DateTimeFormat property of the Calendar class, if it is not a null reference (Nothing in Visual Basic), or from the corresponding DateTimeFormat property of the .NET CultureInfo object assigned to calendar's Culture.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
SubHeaderHeight Property


MindFusion.Scheduling.WinForms.MonthSettings.ShowPaddingDays Property

MonthSettings.ShowPaddingDays Property

Gets or sets a value indicating whether to display days from the previous and next months at the beginning and the end of the current one, in order to fill the whole grid of day cells.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowPaddingDays { get; set; }
Visual Basic

Public Property ShowPaddingDays As State

Property Value

Specify Enabled to display days from the previous and next months to fill up this month's grid; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Padding days are also displayed in the month range view for the first and the last months contained in the view.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings.Style Property

MonthSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings.SubHeaderHeight Property

MonthSettings.SubHeaderHeight Property

Gets or sets the height of the secondary header in a SingleMonth view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int SubHeaderHeight { get; set; }
Visual Basic

Public Property SubHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the Calendar control to automatically calculate the header size based on the header font size.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
ShowDayOfWeek Property


MindFusion.Scheduling.WinForms.MonthSettings.TitleFormat Property

MonthSettings.TitleFormat Property

Gets or sets the string used to format the month's title.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string TitleFormat { get; set; }
Visual Basic

Public Property TitleFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings.TrailingWeekCount Property

MonthSettings.TrailingWeekCount Property

Gets or sets the number of full weeks to display from the next month.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int TrailingWeekCount { get; set; }
Visual Basic

Public Property TrailingWeekCount As Integer

Property Value

A non-negative integer value specifying the number of weeks to display after the selected month. Assign -1 to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
LeadingWeekCount Property


MindFusion.Scheduling.WinForms.MonthSettings.WeekHeaderFormat Property

MonthSettings.WeekHeaderFormat Property

Gets or sets the format of the text displayed for each week in the week header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string WeekHeaderFormat { get; set; }
Visual Basic

Public Property WeekHeaderFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The string controls how to format the text displayed by week headers in a SingleMonth and MonthRange views. The value of this property can contain the following formatting specifiers among ordinary text in any number and order:

Specified | Description
%s[{format}] | The date of the first day in the corresponding week, formatted according to the standard date formatting string, specified by {format}. The brackets '{' and '}' should not be included.
%e[{format}] | The date of the last day in the corresponding week, formatted according to the standard date formatting string, specified by {format}. The brackets '{' and '}' should not be included.
%w | The number of the corresponding week relative to the current year.

Example

For example, the formatting string "(%w) %s[d ]-%e[d ], %s[MMM]" for the week 13.08-19.08 will yield the following result: "(33) 13-19, Aug". Pay attention to the space following 'd' in the format specification '[d ]'. If the space is missing, the format will be interpreted by the .NET framework as standard short date formatting.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.MonthSettings.WeekHeaderStyle Property

MonthSettings.WeekHeaderStyle Property

Gets or sets the style of the week numbers header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public MonthWeekHeaderStyle WeekHeaderStyle { get; set; }
Visual Basic

Public Property WeekHeaderStyle As MonthWeekHeaderStyle

Property Value

A member of the MonthWeekHeaderStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
WeekNumbersHeaderWidth Property


MindFusion.Scheduling.WinForms.MonthSettings.WeekNumbersHeaderWidth Property

MonthSettings.WeekNumbersHeaderWidth Property

Gets or sets the width of the header, which displays week numbers.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int WeekNumbersHeaderWidth { get; set; }
Visual Basic

Public Property WeekNumbersHeaderWidth As Integer

Property Value

A non-negative integer value specifying the header width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the Calendar control to automatically calculate the header size based on the header font size.

See Also

MonthSettings Members
MonthSettings Class
MindFusion.Scheduling.Compact Namespace
WeekHeaderStyle Property


MindFusion.Scheduling.WinForms.MonthWeekHeaderStyle Enumeration

MonthWeekHeaderStyle Enumeration

Specifies the placement of the week numbers header in a SingleMonth view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum MonthWeekHeaderStyle
Visual Basic

Public Enumeration MonthWeekHeaderStyle

Members

Member name | Description
Left | Display the header on the left side of the calendar.
None | Do not display a week numbers header.
Right | Display the header on the right side of the calendar.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Orientation Enumeration

Orientation Enumeration

Specifies horizontal or vertical orientation.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum Orientation
Visual Basic

Public Enumeration Orientation

Members

Member name | Description
Horizontal | Indicates a horizontal orientation.
Unspecified | Unspecified.
Vertical | Indicates a vertical orientation.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Position Enumeration

Position Enumeration

Specifies the position of an element relative to its container.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum Position
Visual Basic

Public Enumeration Position

Members

Member name | Description
Bottom | The element is docked at the bottom side.
Left | The element is docked at the left side.
None | The element is not displayed.
Right | The element is docked at the right side.
Top | The element is docked at the top side.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs Class

RecurringItemConfirmEventArgs Class

Contains the arguments passed to handlers of the RecurringItemDeleting event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class RecurringItemConfirmEventArgs : ItemEventArgs
Visual Basic

Public Class RecurringItemConfirmEventArgs
Inherits ItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.ItemEventArgs
MindFusion.Scheduling.Compact.RecurringItemConfirmEventArgs

See Also

RecurringItemConfirmEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs Members

RecurringItemConfirmEventArgs Members
Properties

Contains the arguments passed to handlers of the RecurringItemDeleting event.

The following tables list the members exposed by the RecurringItemConfirmEventArgs type.

Public Properties

Name | Description
ConfirmAll | Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.
ConfirmOccurrence | Gets or sets a value indicating whether the operation is allowed for the particular occurrence.

See Also

RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs Properties

RecurringItemConfirmEventArgs Properties

Public Properties

Name | Description
ConfirmAll | Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.
ConfirmOccurrence | Gets or sets a value indicating whether the operation is allowed for the particular occurrence.

See Also

RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs.ConfirmAll Property

RecurringItemConfirmEventArgs.ConfirmAll Property

Gets or sets a value indicating whether the operation is allowed for all occurrences of a repeating item.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool ConfirmAll { get; set; }
Visual Basic

Public Property ConfirmAll As Boolean

Property Value

true to allow the operation for all occurrences of the recurring item.

See Also

RecurringItemConfirmEventArgs Members
RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventArgs.ConfirmOccurrence Property

RecurringItemConfirmEventArgs.ConfirmOccurrence Property

Gets or sets a value indicating whether the operation is allowed for the particular occurrence.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool ConfirmOccurrence { get; set; }
Visual Basic

Public Property ConfirmOccurrence As Boolean

Property Value

true to allow the operation for the specified item's occurrence; otherwise, false.

See Also

RecurringItemConfirmEventArgs Members
RecurringItemConfirmEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.RecurringItemConfirmEventHandler Delegate

RecurringItemConfirmEventHandler Delegate

Represents methods that will handle the RecurringItemDeleting event.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void RecurringItemConfirmEventHandler (
Object sender,
RecurringItemConfirmEventArgs e
)
Visual Basic

Public Delegate Sub RecurringItemConfirmEventHandler ( _
sender As Object, _
e As RecurringItemConfirmEventArgs _
)

Parameters

sender
The source of the event.
e
A RecurringItemConfirmEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceDateEventArgs Class

ResourceDateEventArgs Class

Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class ResourceDateEventArgs : DateEventArgs
Visual Basic

Public Class ResourceDateEventArgs
Inherits DateEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Scheduling.Compact.DateEventArgs
MindFusion.Scheduling.Compact.ResourceDateEventArgs

See Also

ResourceDateEventArgs Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceDateEventArgs Members

ResourceDateEventArgs Members
Properties

Contains the arguments passed to handlers of mouse events related to date/time and resource related cells in the calendar.

The following tables list the members exposed by the ResourceDateEventArgs type.

Public Properties

Name | Description
Resource | Gets the resource associated with the clicked cell.

See Also

ResourceDateEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceDateEventArgs Properties

ResourceDateEventArgs Properties

Public Properties

Name | Description
Resource | Gets the resource associated with the clicked cell.

See Also

ResourceDateEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceDateEventArgs.Resource Property

ResourceDateEventArgs.Resource Property

Gets the resource associated with the clicked cell.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

A reference to a Resource, Contact, Location or Task object or null (Nothing in Visual Basic).

See Also

ResourceDateEventArgs Members
ResourceDateEventArgs Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceDateEventHandler Delegate

ResourceDateEventHandler Delegate

Represents methods that will handle mouse events related to date/time and resource related cells in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public delegate void ResourceDateEventHandler (
Object sender,
ResourceDateEventArgs e
)
Visual Basic

Public Delegate Sub ResourceDateEventHandler ( _
sender As Object, _
e As ResourceDateEventArgs _
)

Parameters

sender
The source of the event.
e
A ResourceDateEventArgs that contains the event data.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceLengthMethod Enumeration

ResourceLengthMethod Enumeration

Specifies how to calculate the length of the resources in a Resource view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum ResourceLengthMethod
Visual Basic

Public Enumeration ResourceLengthMethod

Members

Member name | Description
Exact | The length of the resources depends on the time span they occupy.
MinimumAuto | The length of the resources is at least big enough to fit their contents.
MinimumFixed | The length of the resources is not less than a specified predefined value.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceResizeMethod Enumeration

ResourceResizeMethod Enumeration

Specifies the item resizing method in a Resource view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum ResourceResizeMethod
Visual Basic

Public Enumeration ResourceResizeMethod

Members

Member name | Description
DurationBounds | The items are resized by pointing near the ends of the bounding rectangle of the bands showing their duration.
ItemBounds | The items are resized by pointing near the ends of their bounding rectangle.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings Class

ResourceViewSettings Class

Defines properties that allow customizing the visualization of the calendar in Resource view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class ResourceViewSettings : ViewSettings
Visual Basic

Public Class ResourceViewSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.ViewSettings
MindFusion.Scheduling.Compact.ResourceViewSettings

See Also

ResourceViewSettings Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings Members

ResourceViewSettings Members
Properties

Defines properties that allow customizing the visualization of the calendar in Resource view.

The following tables list the members exposed by the ResourceViewSettings type.

Public Properties

Name | Description
BottomTimelineSettings | Gets the settings for the bottom timeline.
CellOffset | Gets or sets the time offset of the first cell from the origin of the resource view.
ExpandableRows | Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GridStyle | Gets or sets the style of the grid lines.
GroupRowHeader | Gets or sets a value indicating whether the rows display the header as a group header.
HeaderSpacing | Gets or sets the amount of space between headers.
HiddenDays | Gets or sets the days of the week that should not be displayed in a resource view.
InnerGridStyle | Gets or sets the style of the internal grid lines.
LaneSize | Gets or sets the size of a single lane.
MiddleTimelineSettings | Gets the settings for the middle timeline.
MinItemSize | Gets or sets the smallest size allowed for resource items.
MinResourceLength | Gets or sets the minimum length for resources when the ResourceLengthMethod property is set to MinimumFixed.
MinRowSize | Gets or sets the smallest size allowed for resource rows.
ResourceLengthMethod | Gets or sets the method used to calculate the length of the resources.
ResourceResizeMethod | Gets or sets the method to be used when resizing resources in the view.
RowHeaderSize | Gets or sets the size of the row header.
ScrollStep | Gets or sets the time modification interval when the user scrolls the view.
ShowPaddingDates | Gets or sets a value indicating whether to display padding dates.
ShowResourceDuration | Gets or sets a value indicating whether to display the duration of individual resources.
ShowSubTicks | Gets or sets a value indicating whether the view displays sub ticks in the bottom timeline.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubTickSize | Gets or sets the size of the sub ticks displayed in the bottom timeline.
Timelines | Gets or sets the number of timelines displayed in the view.
TimelineScale | Gets or sets the scale factor of the timeline.
TopTimelineSettings | Gets the settings for the top timeline.
ViewStyle | Gets or sets the style of the view.
VisibleEndTime | Gets or sets the last visible time of displayed days.
VisibleRows | Gets or sets the number of rows visible in the view.
VisibleStartTime | Gets or sets the first visible time of displayed days.
WeekendStyle | Gets or sets the style of the weekend cells.

See Also

ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings Properties

ResourceViewSettings Properties

Public Properties

Name | Description
BottomTimelineSettings | Gets the settings for the bottom timeline.
CellOffset | Gets or sets the time offset of the first cell from the origin of the resource view.
ExpandableRows | Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GridStyle | Gets or sets the style of the grid lines.
GroupRowHeader | Gets or sets a value indicating whether the rows display the header as a group header.
HeaderSpacing | Gets or sets the amount of space between headers.
HiddenDays | Gets or sets the days of the week that should not be displayed in a resource view.
InnerGridStyle | Gets or sets the style of the internal grid lines.
LaneSize | Gets or sets the size of a single lane.
MiddleTimelineSettings | Gets the settings for the middle timeline.
MinItemSize | Gets or sets the smallest size allowed for resource items.
MinResourceLength | Gets or sets the minimum length for resources when the ResourceLengthMethod property is set to MinimumFixed.
MinRowSize | Gets or sets the smallest size allowed for resource rows.
ResourceLengthMethod | Gets or sets the method used to calculate the length of the resources.
ResourceResizeMethod | Gets or sets the method to be used when resizing resources in the view.
RowHeaderSize | Gets or sets the size of the row header.
ScrollStep | Gets or sets the time modification interval when the user scrolls the view.
ShowPaddingDates | Gets or sets a value indicating whether to display padding dates.
ShowResourceDuration | Gets or sets a value indicating whether to display the duration of individual resources.
ShowSubTicks | Gets or sets a value indicating whether the view displays sub ticks in the bottom timeline.
SnapUnit | Gets or sets the snap unit.
SnapUnitCount | Gets or sets the snap unit count.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubTickSize | Gets or sets the size of the sub ticks displayed in the bottom timeline.
Timelines | Gets or sets the number of timelines displayed in the view.
TimelineScale | Gets or sets the scale factor of the timeline.
TopTimelineSettings | Gets the settings for the top timeline.
ViewStyle | Gets or sets the style of the view.
VisibleEndTime | Gets or sets the last visible time of displayed days.
VisibleRows | Gets or sets the number of rows visible in the view.
VisibleStartTime | Gets or sets the first visible time of displayed days.
WeekendStyle | Gets or sets the style of the weekend cells.

See Also

ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.BottomTimelineSettings Property

ResourceViewSettings.BottomTimelineSettings Property

Gets the settings for the bottom timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimelineSettings BottomTimelineSettings { get; }
Visual Basic

Public ReadOnly Property BottomTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class that defines the preferences for the bottom timeline.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
MiddleTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.CellOffset Property

ResourceViewSettings.CellOffset Property

Gets or sets the time offset of the first cell from the origin of the resource view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public float CellOffset { get; set; }
Visual Basic

Public Property CellOffset As Single

Property Value

A floating point value, specifying the offset in the units set in the Unit property of the BottomTimelineSettings.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ExpandableRows Property

ResourceViewSettings.ExpandableRows Property

Gets or sets a value indicating whether the rows in the resource view can be expanded/collapsed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ExpandableRows { get; set; }
Visual Basic

Public Property ExpandableRows As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ExpandActiveItemOn Property

ResourceViewSettings.ExpandActiveItemOn Property

Gets or sets whether the active item should ignore collisions.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemAction ExpandActiveItemOn { get; set; }
Visual Basic

Public Property ExpandActiveItemOn As ItemAction

Property Value

A member of the ItemAction enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.GridStyle Property

ResourceViewSettings.GridStyle Property

Gets or sets the style of the grid lines.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public LineStyle GridStyle { get; set; }
Visual Basic

Public Property GridStyle As LineStyle

Property Value

A member of the LineStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
InnerGridStyle Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.GroupRowHeader Property

ResourceViewSettings.GroupRowHeader Property

Gets or sets a value indicating whether the rows display the header as a group header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State GroupRowHeader { get; set; }
Visual Basic

Public Property GroupRowHeader As State

Property Value

A member of the State enumeration. Set it to Enabled to activate this feature or to Disabled to turn it off. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.HeaderSpacing Property

ResourceViewSettings.HeaderSpacing Property

Gets or sets the amount of space between headers.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int HeaderSpacing { get; set; }
Visual Basic

Public Property HeaderSpacing As Integer

Property Value

An integer value specifying how many pixels there are between adjacent headers. The minimal allowed value is -1. Assign -2 to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.HiddenDays Property

ResourceViewSettings.HiddenDays Property

Gets or sets the days of the week that should not be displayed in a resource view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DaysOfWeek HiddenDays { get; set; }
Visual Basic

Public Property HiddenDays As DaysOfWeek

Property Value

A member of the DaysOfWeek enumeration indicating the visible days in a ResourceView.

Remarks

This property determines which days should be filtered (that is, not displayed) in a resource view. This setting only works if the Unit of the bottom timeline is set to Day or Hour.

Example

The following example demonstrates how to use filtering in a resource view. The example assumes that calendar references an existing Calendar object.

C#

// Enable resource view
calendar.ResourceViewSettings.Timelines = 2;
calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour;
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "h:mm";
calendar.ResourceViewSettings.MiddleTimelineSettings.Unit = TimeUnit.Day;
calendar.ResourceViewSettings.MiddleTimelineSettings.Format = "d ddd";

// Show only work days from 9 to 18
calendar.ResourceViewSettings.HiddenDays = DaysOfWeek.Saturday | DaysOfWeek.Sunday;
calendar.ResourceViewSettings.VisibleStartTime = TimeSpan.FromHours(9);
calendar.ResourceViewSettings.VisibleEndTime = TimeSpan.FromHours(18);

// Set appropriate scroll step
calendar.ResourceViewSettings.ScrollStep = TimeSpan.FromHours(1);
Visual Basic

' Enable resource view
calendar.ResourceViewSettings.Timelines = 2
calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "h:mm"
calendar.ResourceViewSettings.MiddleTimelineSettings.Unit = TimeUnit.Day
calendar.ResourceViewSettings.MiddleTimelineSettings.Format = "d ddd"

' Show only work days from 9 to 18
calendar.ResourceViewSettings.HiddenDays = DaysOfWeek.Saturday Or DaysOfWeek.Sunday
calendar.ResourceViewSettings.VisibleStartTime = TimeSpan.FromHours(9)
calendar.ResourceViewSettings.VisibleEndTime = TimeSpan.FromHours(18)

' Set appropriate scroll step
calendar.ResourceViewSettings.ScrollStep = TimeSpan.FromHours(1)

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
VisibleStartTime Property
VisibleEndTime Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.InnerGridStyle Property

ResourceViewSettings.InnerGridStyle Property

Gets or sets the style of the internal grid lines.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public LineStyle InnerGridStyle { get; set; }
Visual Basic

Public Property InnerGridStyle As LineStyle

Property Value

A member of the LineStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
GridStyle Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.LaneSize Property

ResourceViewSettings.LaneSize Property

Gets or sets the size of a single lane.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int LaneSize { get; set; }
Visual Basic

Public Property LaneSize As Integer

Property Value

An integer value specifying the size in pixels of a resource lane. The minimal allowed value is 10. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to Lanes.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.MiddleTimelineSettings Property

ResourceViewSettings.MiddleTimelineSettings Property

Gets the settings for the middle timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimelineSettings MiddleTimelineSettings { get; }
Visual Basic

Public ReadOnly Property MiddleTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class that defines the preferences for the middle timeline.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
BottomTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.MinItemSize Property

ResourceViewSettings.MinItemSize Property

Gets or sets the smallest size allowed for resource items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MinItemSize { get; set; }
Visual Basic

Public Property MinItemSize As Integer

Property Value

An integer value, specifying the minimal item size in pixels. The minimal allowed value is 5. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

If there is not enough space in a row to display all related items, the items that do not fit remain invisible. This property is only used if the ViewStyle is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.MinResourceLength Property

ResourceViewSettings.MinResourceLength Property

Gets or sets the minimum length for resources when the ResourceLengthMethod property is set to MinimumFixed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MinResourceLength { get; set; }
Visual Basic

Public Property MinResourceLength As Integer

Property Value

An integer value, specifying the minimal resource length in pixels. The minimal allowed value is 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.MinRowSize Property

ResourceViewSettings.MinRowSize Property

Gets or sets the smallest size allowed for resource rows.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MinRowSize { get; set; }
Visual Basic

Public Property MinRowSize As Integer

Property Value

An integer value, specifying the minimal row size in pixels. The minimal allowed value is 10. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ResourceLengthMethod Property

ResourceViewSettings.ResourceLengthMethod Property

Gets or sets the method used to calculate the length of the resources.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ResourceLengthMethod ResourceLengthMethod { get; set; }
Visual Basic

Public Property ResourceLengthMethod As ResourceLengthMethod

Property Value

A value of the ResourceLengthMethod enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ResourceResizeMethod Property

ResourceViewSettings.ResourceResizeMethod Property

Gets or sets the method to be used when resizing resources in the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ResourceResizeMethod ResourceResizeMethod { get; set; }
Visual Basic

Public Property ResourceResizeMethod As ResourceResizeMethod

Property Value

A member of the ResourceResizeMethod enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.RowHeaderSize Property

ResourceViewSettings.RowHeaderSize Property

Gets or sets the size of the row header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int RowHeaderSize { get; set; }
Visual Basic

Public Property RowHeaderSize As Integer

Property Value

An integer value specifying the size in pixels of the row headers. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

The size of a header is used only when GroupRowHeader is enabled. Otherwise, the size of the header equals LaneSize.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ScrollStep Property

ResourceViewSettings.ScrollStep Property

Gets or sets the time modification interval when the user scrolls the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeSpan ScrollStep { get; set; }
Visual Basic

Public Property ScrollStep As TimeSpan

Property Value

A .NET TimeSpan object that defines the scroll interval. The minimal allowed value is 1 second. Assign -1 ticks to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ShowPaddingDates Property

ResourceViewSettings.ShowPaddingDates Property

Gets or sets a value indicating whether to display padding dates.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowPaddingDates { get; set; }
Visual Basic

Public Property ShowPaddingDates As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

It is sometimes possible that the control draws dates outside of the range specified by the Date and EndDate properties. This usually happens when the viewport is larger than the entire time range. Set this property to Disabled if you don't want the control to draw external dates.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ShowResourceDuration Property

ResourceViewSettings.ShowResourceDuration Property

Gets or sets a value indicating whether to display the duration of individual resources.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowResourceDuration { get; set; }
Visual Basic

Public Property ShowResourceDuration As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.ShowSubTicks Property

ResourceViewSettings.ShowSubTicks Property

Gets or sets a value indicating whether the view displays sub ticks in the bottom timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowSubTicks { get; set; }
Visual Basic

Public Property ShowSubTicks As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
SubTicksSize Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.SnapUnit Property

ResourceViewSettings.SnapUnit Property

Gets or sets the snap unit.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeUnit SnapUnit { get; set; }
Visual Basic

Public Property SnapUnit As TimeUnit

Property Value

A member of the TimeUnit enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Specifies the time unit of the nearest value to align to when an item is being modified interactively. For example specifying Day causes the manipulated item to always be aligned to the nearest day. To practically disable snapping, specify Second for this property.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
SnapUnitCount Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.SnapUnitCount Property

ResourceViewSettings.SnapUnitCount Property

Gets or sets the snap unit count.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int SnapUnitCount { get; set; }
Visual Basic

Public Property SnapUnitCount As Integer

Property Value

A positive integer value specifying the number of units from the associated SnapUnit to snap to. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

When SnapUnitCount is 1 the snapping is absolute. When SnapUnitCount is greater than 1, then the snapping is relative to the element being dragged. For example, if the item is moved or its start is being resized, the snapping is relative to the item's start. If the item's end is being resized, the snapping is relative to the item's end. For example if the item starts at 02/16, the unit count is 3 and the unit is Day, an attempt to resize the item's start on the left would cause snapping at 02/13 (which is the item's start time minus 3 days).

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
SnapUnit Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.Style Property

ResourceViewSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.SubTickSize Property

ResourceViewSettings.SubTickSize Property

Gets or sets the size of the sub ticks displayed in the bottom timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int SubTickSize { get; set; }
Visual Basic

Public Property SubTickSize As Integer

Property Value

A non-negative integer value. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
ShowSubTicks Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.Timelines Property

ResourceViewSettings.Timelines Property

Gets or sets the number of timelines displayed in the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Timelines { get; set; }
Visual Basic

Public Property Timelines As Integer

Property Value

An integer value specifying the number of timelines visible in the view. The allowed values range from 1 to 3. Assign -1 to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
BottomTimelineSettings Property
MiddleTimelineSettings Property
TopTimelineSettings Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.TimelineScale Property

ResourceViewSettings.TimelineScale Property

Gets or sets the scale factor of the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int TimelineScale { get; set; }
Visual Basic

Public Property TimelineScale As Integer

Property Value

An integer value specifying the scale of the timeline expressed in percents. The allowed values range from 10 to 1000. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

Usually the size of the cells in the ResourceView is calculated to be large enough so that the texts in the timeline can fit without clipping. By using values other than 100 for this property, you can scale up or down the precalculated size of the cells.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.TopTimelineSettings Property

ResourceViewSettings.TopTimelineSettings Property

Gets the settings for the top timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimelineSettings TopTimelineSettings { get; }
Visual Basic

Public ReadOnly Property TopTimelineSettings As TimelineSettings

Property Value

An instance of the TimelineSettings class that defines the preferences for the top timeline.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
BottomTimelineSettings Property
MiddleTimelineSettings Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.ViewStyle Property

ResourceViewSettings.ViewStyle Property

Gets or sets the style of the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ResourceViewStyle ViewStyle { get; set; }
Visual Basic

Public Property ViewStyle As ResourceViewStyle

Property Value

A member of the ResourceViewStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.VisibleEndTime Property

ResourceViewSettings.VisibleEndTime Property

Gets or sets the last visible time of displayed days.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeSpan VisibleEndTime { get; set; }
Visual Basic

Public Property VisibleEndTime As TimeSpan

Property Value

A .NET TimeSpan value indicating the last visible hour of the day in a ResourceView.

Remarks

This property along with the VisibleStartTime property determine the range of hours displayed in a resource view for each day. The rest of the day is filtered (that is, the hours outside this range are not displayed). Despite being a TimeSpan, only the Hour component is taken into consideration when filtering. Furthermore, this setting only works if the Unit property of the bottom timeline is set to Hour and the UnitCount is set to 1 or if Unit is set to Minute.

Example

The following example demonstrates how to use filtering in a resource view. The example assumes that calendar references an existing Calendar object.

C#

// Enable resource view
calendar.ResourceViewSettings.Timelines = 2;
calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour;
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "h:mm";
calendar.ResourceViewSettings.MiddleTimelineSettings.Unit = TimeUnit.Day;
calendar.ResourceViewSettings.MiddleTimelineSettings.Format = "d ddd";

// Show only work days from 9 to 18
calendar.ResourceViewSettings.HiddenDays = DaysOfWeek.Saturday | DaysOfWeek.Sunday;
calendar.ResourceViewSettings.VisibleStartTime = TimeSpan.FromHours(9);
calendar.ResourceViewSettings.VisibleEndTime = TimeSpan.FromHours(18);

// Set appropriate scroll step
calendar.ResourceViewSettings.ScrollStep = TimeSpan.FromHours(1);
Visual Basic

' Enable resource view
calendar.ResourceViewSettings.Timelines = 2
calendar.ResourceViewSettings.BottomTimelineSettings.Unit = TimeUnit.Hour
calendar.ResourceViewSettings.BottomTimelineSettings.Format = "h:mm"
calendar.ResourceViewSettings.MiddleTimelineSettings.Unit = TimeUnit.Day
calendar.ResourceViewSettings.MiddleTimelineSettings.Format = "d ddd"

' Show only work days from 9 to 18
calendar.ResourceViewSettings.HiddenDays = DaysOfWeek.Saturday Or DaysOfWeek.Sunday
calendar.ResourceViewSettings.VisibleStartTime = TimeSpan.FromHours(9)
calendar.ResourceViewSettings.VisibleEndTime = TimeSpan.FromHours(18)

' Set appropriate scroll step
calendar.ResourceViewSettings.ScrollStep = TimeSpan.FromHours(1)

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
VisibleStartTime Property
HiddenDays Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.VisibleRows Property

ResourceViewSettings.VisibleRows Property

Gets or sets the number of rows visible in the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int VisibleRows { get; set; }
Visual Basic

Public Property VisibleRows As Integer

Property Value

An integer value specifying the number of rows visible at a time. The minimal allowed value is 1. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property is only used if the ViewStyle is set to General.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewSettings.VisibleStartTime Property

ResourceViewSettings.VisibleStartTime Property

Gets or sets the first visible time of displayed days.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeSpan VisibleStartTime { get; set; }
Visual Basic

Public Property VisibleStartTime As TimeSpan

Property Value

A .NET TimeSpan value indicating the first visible hour of the day in a ResourceView.

Remarks

This property along with the VisibleEndTime property determine the range of hours displayed in a resource view for each day. The rest of the day is filtered (that is, the hours outside this range are not displayed). Despite being a TimeSpan, only the Hour component is taken into consideration when filtering. Furthermore, this setting only works if the Unit property of the bottom timeline is set to Hour and the UnitCount is set to 1 or if the Unit is set to Minute.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace
VisibleEndTime Property
HiddenDays Property


MindFusion.Scheduling.WinForms.ResourceViewSettings.WeekendStyle Property

ResourceViewSettings.WeekendStyle Property

Gets or sets the style of the weekend cells.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style WeekendStyle { get; set; }
Visual Basic

Public Property WeekendStyle As Style

Property Value

A Style object specifying the appearance of weekend cells. This property cannot be null.

See Also

ResourceViewSettings Members
ResourceViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ResourceViewStyle Enumeration

ResourceViewStyle Enumeration

Specifies the style of a Resource view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum ResourceViewStyle
Visual Basic

Public Enumeration ResourceViewStyle

Members

Member name | Description
General | Each row in a Resource view has a fixed width. The items within the row are positioned much like in a Timetable view.
Lanes | Each row in a Resource view displays one or more lanes where items are positioned. More lanes are added automatically to respect the requirement that all overlapping items are on separate lanes.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection Class

Selection Class

Represents a set of selected date cells and defines a visualization style applied to the selected elements.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class Selection : IDisposable
Visual Basic

Public NotInheritable Class Selection
Implements IDisposable

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.Selection

See Also

Selection Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection Members

Selection Members
Properties Methods Events

Represents a set of selected date cells and defines a visualization style applied to the selected elements.

The following tables list the members exposed by the Selection type.

Public Properties

Name | Description
AllowMultiple | Gets or sets a value indicating whether users are allowed to select multiple elements at a time.
Contact | Gets the contact related to the current selection.
Continuous | Gets or sets a value indicating whether users can select only one range of dates in the calendar.
DayRanges | Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents an interval of selected days.
Enabled | Gets or sets a value indicating whether users are allowed to select any cells in the calendar.
EndDate | Gets the end date of the first range in the selection. Since version 3.2, this property is considered obsolete. Instead, use the Ranges property.
IsEmpty | Gets a value indicating whether this selection is empty.
Location | Gets the location related to the current selection.
Ranges | Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents a selected time range.
Resource | Gets the resource related to the current selection.
SelectedElementsStyle | Gets or sets the visualization style to apply to selected elements.
StartDate | Gets the start date of the first range in the selection. Since version 3.2, this property is considered obsolete. Instead, use the Ranges property.
Style | Gets or sets the style of the selection frame drawn around selected calendar cells.
Task | Gets the task related to the current selection.

Public Methods

Name | Description
Add | Overloaded. Adds the specified date or range of dates to the selection.
Contains | Determines whether the specified date is currently selected.
ContainsDay | Determines whether any part of the specified day is selected.
Dispose | Disposes any resources used by this Selection object.
Remove | Overloaded. Removes the specified date or range of dates from the selection.
Reset | Clears the selection.
Restore | Restores a previously saved state.
Save | Saves the current selection state.
Set | Overloaded. Sets the current selection to the specified date or range of dates.

Public Events

Name | Description
Changed | Raised when the selection changes.
SelectedElementsStyleChanged | Raised when the appearance style of the selection changes.

See Also

Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection Methods

Selection Methods

Public Methods

Name | Description
Add | Overloaded. Adds the specified date or range of dates to the selection.
Contains | Determines whether the specified date is currently selected.
ContainsDay | Determines whether any part of the specified day is selected.
Dispose | Disposes any resources used by this Selection object.
Remove | Overloaded. Removes the specified date or range of dates from the selection.
Reset | Clears the selection.
Restore | Restores a previously saved state.
Save | Saves the current selection state.
Set | Overloaded. Sets the current selection to the specified date or range of dates.

See Also

Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Add Method

Selection.Add Method

Adds the specified date or range of dates to the selection.

Overload List

Name | Description
Selection.Add (DateTime) | Adds the specified date to the selection.
Selection.Add (DateTime, DateTime) | Adds the specified date range to the selection.
Selection.Add (DateTime, DateTime, Contact, Resource, Location, Task) | Adds the specified date range to the selection of the specified resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Add Method (DateTime)

Selection.Add Method (DateTime)
See Also

Adds the specified date to the selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Add (
DateTime date
)
Visual Basic

Public Sub Add ( _
date As DateTime _
)

Parameters

date
The date to be added to the selection.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Add Method (DateTime, DateTime)

Selection.Add Method (DateTime, DateTime)
See Also

Adds the specified date range to the selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Add (
DateTime start,
DateTime end
)
Visual Basic

Public Sub Add ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
The start of the time range to be added to the selection.
end
The end of the time range to be added to the selection.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Add Method (DateTime, DateTime, Contact, Resource, Location, Task)

Selection.Add Method (DateTime, DateTime, Contact, Resource, Location, Task)
See Also

Adds the specified date range to the selection of the specified resource.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Add (
DateTime start,
DateTime end,
Contact contact,
Resource resource,
Location location,
Task task
)
Visual Basic

Public Sub Add ( _
start As DateTime, _
end As DateTime, _
contact As Contact, _
resource As Resource, _
location As Location, _
task As Task _
)

Parameters

start
The start of the time range to be added to the selection.
end
The end of the time range to be added to the selection.
contact
A reference to a Contact to associate the selection with.
resource
A reference to a Resource to associate the selection with.
location
A reference to a Location to associate the selection with.
task
A reference to a Task to associate the selection with.

Remarks

Either all of the parameters contact, resource, location and task must be set to null or only one of them should be a non-null reference.

See Also

Add Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Contains Method

Selection.Contains Method

Determines whether the specified date is currently selected.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool Contains (
DateTime date
)
Visual Basic

Public Function Contains ( _
date As DateTime _
) As Boolean

Parameters

date
A date to search for in the selection.

Return Value

true if the date's cell is selected; otherwise false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.ContainsDay Method

Selection.ContainsDay Method

Determines whether any part of the specified day is selected.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool ContainsDay (
DateTime date
)
Visual Basic

Public Function ContainsDay ( _
date As DateTime _
) As Boolean

Parameters

date
A DateTime instance specifying the day to check.

Return Value

true if any part of the day is into the selection; otherwise false.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Dispose Method

Selection.Dispose Method

Disposes any resources used by this Selection object.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public virtual void Dispose ()
Visual Basic

Public Overridable Sub Dispose ()

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Remove Method

Selection.Remove Method

Removes the specified date or range of dates from the selection.

Overload List

Name | Description
Selection.Remove (DateTime) | Removes the specified date from the selection.
Selection.Remove (DateTime, DateTime) | Removes the specified date range from the selection.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Remove Method (DateTime)

Selection.Remove Method (DateTime)
See Also

Removes the specified date from the selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Remove (
DateTime date
)
Visual Basic

Public Sub Remove ( _
date As DateTime _
)

Parameters

date
The date to be removed from the selection.

See Also

Remove Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Remove Method (DateTime, DateTime)

Selection.Remove Method (DateTime, DateTime)
See Also

Removes the specified date range from the selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Remove (
DateTime start,
DateTime end
)
Visual Basic

Public Sub Remove ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
The start of the time range to be removed from the selection.
end
The end of the time range to be removed from the selection.

See Also

Remove Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Reset Method

Selection.Reset Method

Clears the selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Reset ()
Visual Basic

Public Sub Reset ()

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Restore Method

Selection.Restore Method

Restores a previously saved state.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Restore (
SelectionState state
)
Visual Basic

Public Sub Restore ( _
state As SelectionState _
)

Parameters

state
A previously saved selection state.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Save Method

Selection.Save Method

Saves the current selection state.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public SelectionState Save ()
Visual Basic

Public Function Save () As SelectionState

Return Value

A SelectionState object representing the current selection state.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Set Method

Selection.Set Method

Sets the current selection to the specified date or range of dates.

Overload List

Name | Description
Selection.Set (DateTime) | Selects the specified date cell.
Selection.Set (DateTime, DateTime) | Selects a range of date cells.
Selection.Set (DateTime, DateTime, Contact, Resource, Location, Task) | Selects a range of date cells for a specified resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Set Method (DateTime)

Selection.Set Method (DateTime)
See Also

Selects the specified date cell.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Set (
DateTime date
)
Visual Basic

Public Sub Set ( _
date As DateTime _
)

Parameters

date
A date whose calendar cell to select.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Set Method (DateTime, DateTime)

Selection.Set Method (DateTime, DateTime)
See Also

Selects a range of date cells.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Set (
DateTime start,
DateTime end
)
Visual Basic

Public Sub Set ( _
start As DateTime, _
end As DateTime _
)

Parameters

start
Specifies the first date in the range.
end
Specifies the last date in the range.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Set Method (DateTime, DateTime, Contact, Resource, Location, Task)

Selection.Set Method (DateTime, DateTime, Contact, Resource, Location, Task)
See Also

Selects a range of date cells for a specified resource.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public void Set (
DateTime start,
DateTime end,
Contact contact,
Resource resource,
Location location,
Task task
)
Visual Basic

Public Sub Set ( _
start As DateTime, _
end As DateTime, _
contact As Contact, _
resource As Resource, _
location As Location, _
task As Task _
)

Parameters

start
Specifies the first date in the range.
end
Specifies the last date in the range.
contact
A reference to a Contact to associate the selection with.
resource
A reference to a Resource to associate the selection with.
location
A reference to a Location to associate the selection with.
task
A reference to a Task to associate the selection with.

Remarks

Either all of the parameters contact, resource, location and task must be set to null or only one of them should be a non-null reference.

See Also

Set Method Overload List
Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection Properties

Selection Properties

Public Properties

Name | Description
AllowMultiple | Gets or sets a value indicating whether users are allowed to select multiple elements at a time.
Contact | Gets the contact related to the current selection.
Continuous | Gets or sets a value indicating whether users can select only one range of dates in the calendar.
DayRanges | Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents an interval of selected days.
Enabled | Gets or sets a value indicating whether users are allowed to select any cells in the calendar.
EndDate | Gets the end date of the first range in the selection. Since version 3.2, this property is considered obsolete. Instead, use the Ranges property.
IsEmpty | Gets a value indicating whether this selection is empty.
Location | Gets the location related to the current selection.
Ranges | Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents a selected time range.
Resource | Gets the resource related to the current selection.
SelectedElementsStyle | Gets or sets the visualization style to apply to selected elements.
StartDate | Gets the start date of the first range in the selection. Since version 3.2, this property is considered obsolete. Instead, use the Ranges property.
Style | Gets or sets the style of the selection frame drawn around selected calendar cells.
Task | Gets the task related to the current selection.

See Also

Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.AllowMultiple Property

Selection.AllowMultiple Property

Gets or sets a value indicating whether users are allowed to select multiple elements at a time.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State AllowMultiple { get; set; }
Visual Basic

Public Property AllowMultiple As State

Property Value

Specify Enabled to allow multiple selection; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Contact Property

Selection.Contact Property

Gets the contact related to the current selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Contact Contact { get; }
Visual Basic

Public ReadOnly Property Contact As Contact

Property Value

The contact related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a contact.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace
Location Property
Task Property
Resource Property


MindFusion.Scheduling.WinForms.Selection.Continuous Property

Selection.Continuous Property

Gets or sets a value indicating whether users can select only one range of dates in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State Continuous { get; set; }
Visual Basic

Public Property Continuous As State

Property Value

Specify Enabled to prevent users from selecting more than one, continuous range of dates in the control; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.DayRanges Property

Selection.DayRanges Property

Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents an interval of selected days.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ArrayList DayRanges { get; }
Visual Basic

Public ReadOnly Property DayRanges As ArrayList

Property Value

An instance of an ArrayList class containing even number of DateTime objects.

Remarks

Any attempt to modify the returned list will result in a NotSupportedException exception. If you want to add or remove date intervals from the selection, use the Add, Set and Remove methods respectively.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace
Ranges Property


MindFusion.Scheduling.WinForms.Selection.Enabled Property

Selection.Enabled Property

Gets or sets a value indicating whether users are allowed to select any cells in the calendar.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State Enabled { get; set; }
Visual Basic

Public Property Enabled As State

Property Value

Specify Enabled if users are allowed to select calendar cells; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.EndDate Property

Selection.EndDate Property

Gets the end date of the first range in the selection.

Since version 3.2, this property is considered obsolete. Instead, use the Ranges property.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime EndDate { get; }
Visual Basic

Public ReadOnly Property EndDate As DateTime

Property Value

A .NET DateTime object specifying the end of the first range in the selection.

Remarks

If the selection is empty, the current date and time are returned. To check whether the selection is empty (that is, no dates are selected) use the IsEmpty method.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace
StartDate Property
IsEmpty Property


MindFusion.Scheduling.WinForms.Selection.IsEmpty Property

Selection.IsEmpty Property

Gets a value indicating whether this selection is empty.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public bool IsEmpty { get; }
Visual Basic

Public ReadOnly Property IsEmpty As Boolean

Property Value

true if there are selected calendar cells; otherwise, false.

Remarks

Attempts to access either StartDate or EndDate of an empty selection return the current date and time.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace
StartDate Property
EndDate Property


MindFusion.Scheduling.WinForms.Selection.Location Property

Selection.Location Property

Gets the location related to the current selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Location Location { get; }
Visual Basic

Public ReadOnly Property Location As Location

Property Value

The location related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a location.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace
Contact Property
Task Property
Resource Property


MindFusion.Scheduling.WinForms.Selection.Ranges Property

Selection.Ranges Property

Gets a read-only list of .NET DateTime objects, sorted chronologically. Each pair in the list represents a selected time range.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ArrayList Ranges { get; }
Visual Basic

Public ReadOnly Property Ranges As ArrayList

Property Value

An instance of an ArrayList class containing even number of DateTime objects.

Remarks

Any attempt to modify the returned list will result in a NotSupportedException exception. If you want to add or remove time intervals from the selection, use the Add, Set and Remove methods respectively.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace
DayRanges Property


MindFusion.Scheduling.WinForms.Selection.Resource Property

Selection.Resource Property

Gets the resource related to the current selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Resource Resource { get; }
Visual Basic

Public ReadOnly Property Resource As Resource

Property Value

The resource related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a resource.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace
Contact Property
Location Property
Task Property


MindFusion.Scheduling.WinForms.Selection.SelectedElementsStyle Property

Selection.SelectedElementsStyle Property

Gets or sets the visualization style to apply to selected elements.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style SelectedElementsStyle { get; set; }
Visual Basic

Public Property SelectedElementsStyle As Style

Property Value

A Style object specifying the style applied to selected calendar cells. This property cannot be null.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace
Style Class


MindFusion.Scheduling.WinForms.Selection.StartDate Property

Selection.StartDate Property

Gets the start date of the first range in the selection.

Since version 3.2, this property is considered obsolete. Instead, use the Ranges property.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateTime StartDate { get; }
Visual Basic

Public ReadOnly Property StartDate As DateTime

Property Value

A .NET DateTime object specifying the start of the first range in the selection.

Remarks

If the selection is empty, the current date and time are returned. To check whether the selection is empty (that is, no dates are selected) use the IsEmpty method.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace
EndDate Property
IsEmpty Property


MindFusion.Scheduling.WinForms.Selection.Style Property

Selection.Style Property

Gets or sets the style of the selection frame drawn around selected calendar cells.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public SelectionStyle Style { get; set; }
Visual Basic

Public Property Style As SelectionStyle

Property Value

A member of the SelectionStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Task Property

Selection.Task Property

Gets the task related to the current selection.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Task Task { get; }
Visual Basic

Public ReadOnly Property Task As Task

Property Value

The task related to the current selection or null (Nothing in Visual Basic) if there are no selected cells or the current selection is not associated with a task.

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace
Contact Property
Location Property
Resource Property


MindFusion.Scheduling.WinForms.Selection Events

Selection Events

Public Events

Name | Description
Changed | Raised when the selection changes.
SelectedElementsStyleChanged | Raised when the appearance style of the selection changes.

See Also

Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.Changed Event

Selection.Changed Event

Raised when the selection changes.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public EventHandler Changed
Visual Basic

Public Changed As EventHandler

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Selection.SelectedElementsStyleChanged Event

Selection.SelectedElementsStyleChanged Event

Raised when the appearance style of the selection changes.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public EventHandler SelectedElementsStyleChanged
Visual Basic

Public SelectedElementsStyleChanged As EventHandler

See Also

Selection Members
Selection Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.SelectionState Class

SelectionState Class

Represents the saved state of a Selection object.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class SelectionState
Visual Basic

Public NotInheritable Class SelectionState

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.SelectionState

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.SelectionStyle Enumeration

SelectionStyle Enumeration

Specifies what type of frame to draw around selected elements.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum SelectionStyle
Visual Basic

Public Enumeration SelectionStyle

Members

Member name | Description
FocusFrame | Draw a focus frame around the selected elements.
None | Do not draw a frame.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.State Enumeration

State Enumeration

Specifies the state of a subject.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum State
Visual Basic

Public Enumeration State

Members

Member name | Description
Disabled | Indicates that the subject is disabled.
Enabled | Indicates that the subject is enabled.
Unspecified | Indicates undetermined state.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Theme Class

Theme Class
Remarks See Also

Encapsulates visualization settings that can be applied to a Calendar control by calling the ApplyTheme method. A theme includes settings for all calendar views - List, Month, Timetable, and so on.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public abstract class Theme : Component
Visual Basic

Public MustInherit Class Theme
Inherits Component

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
MindFusion.Scheduling.Compact.Theme

See Also

Theme Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Theme Members

Theme Members
Properties

Encapsulates visualization settings that can be applied to a Calendar control by calling the ApplyTheme method. A theme includes settings for all calendar views - List, Month, Timetable, and so on.

The following tables list the members exposed by the Theme type.

Public Properties

Name | Description
LightBlue | Gets the LightBlue predefined theme.
LightBrown | Gets the LightBrown predefined theme.
Standard | Gets the standard PocketPlanner theme.
Vista | Gets the Vista predefined theme.

See Also

Theme Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Theme Properties

Theme Properties

Theme Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Theme.LightBlue Property

Theme.LightBlue Property

Gets the LightBlue predefined theme.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public static Theme LightBlue { get; }
Visual Basic

Public Shared ReadOnly Property LightBlue As Theme

Property Value

An instance of the Theme class representing the LightBlue theme.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.Compact Namespace
PocketPlanner Themes
Standard Property
LightBrown Property


MindFusion.Scheduling.WinForms.Theme.LightBrown Property

Theme.LightBrown Property

Gets the LightBrown predefined theme.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public static Theme LightBrown { get; }
Visual Basic

Public Shared ReadOnly Property LightBrown As Theme

Property Value

An instance of the Theme class representing the LightBrown theme.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.Compact Namespace
PocketPlanner Themes
Standard Property
LightBlue Property


MindFusion.Scheduling.WinForms.Theme.Standard Property

Theme.Standard Property

Gets the standard PocketPlanner theme.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public static Theme Standard { get; }
Visual Basic

Public Shared ReadOnly Property Standard As Theme

Property Value

An instance of the Theme class representing the Standard theme.

Remarks

The standard theme is based on the current color settings of Windows.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.Compact Namespace
PocketPlanner Themes
LightBlue Property
LightBrown Property


MindFusion.Scheduling.WinForms.Theme.Vista Property

Theme.Vista Property

Gets the Vista predefined theme.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public static Theme Vista { get; }
Visual Basic

Public Shared ReadOnly Property Vista As Theme

Property Value

An instance of the Theme class representing the Vista theme.

See Also

Theme Members
Theme Class
MindFusion.Scheduling.Compact Namespace
Planner.NET Themes
Standard Property
Windows2003 Property
Silver Property
Lila Property


MindFusion.Scheduling.WinForms.ThemeType Enumeration

ThemeType Enumeration

Specifies a calendar theme.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum ThemeType
Visual Basic

Public Enumeration ThemeType

Members

Member name | Description
Custom | Indicates a user-defined theme.
LightBlue | The LightBlue theme.
LightBrown | The LightBrown theme.
Lila | The Lila theme.
Silver | The Silver theme.
Standard | The standard PocketPlanner theme.
Windows2003 | The Windows2003 standard theme.
Vista | A theme with a Windows Vista look and feel.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimelineSettings Class

TimelineSettings Class

Encapsulates settings for a timeline in a Resource view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class TimelineSettings
Visual Basic

Public NotInheritable Class TimelineSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.TimelineSettings

See Also

TimelineSettings Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimelineSettings Members

TimelineSettings Members
Properties

Encapsulates settings for a timeline in a Resource view.

The following tables list the members exposed by the TimelineSettings type.

Public Properties

Name | Description
Format | Gets or sets the format of the displayed dates in the timeline.
NowColor | Gets or sets the color used to mark the current time in the timeline.
ShowCurrentTime | Gets or sets a value indicating whether to indicate the current time in the timeline.
ShowTicks | Gets or sets a value indicating whether the timeline displays tick lines.
Size | Gets or sets the size of the timeline.
SpanCellCount | Gets or sets a value indicating the number of cells to span when SpanTexts is enabled.
SpanTexts | Gets or sets a value indicating whether some cell texts will span more than one cell when the space in their corresponding cells is insufficient due to scaling the view.
Style | Gets or sets the style of the timeline.
TickSize | Gets or sets the size of the ticks displayed in the timeline.
Unit | Gets or sets the time unit of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

See Also

TimelineSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimelineSettings Properties

TimelineSettings Properties

Public Properties

Name | Description
Format | Gets or sets the format of the displayed dates in the timeline.
NowColor | Gets or sets the color used to mark the current time in the timeline.
ShowCurrentTime | Gets or sets a value indicating whether to indicate the current time in the timeline.
ShowTicks | Gets or sets a value indicating whether the timeline displays tick lines.
Size | Gets or sets the size of the timeline.
SpanCellCount | Gets or sets a value indicating the number of cells to span when SpanTexts is enabled.
SpanTexts | Gets or sets a value indicating whether some cell texts will span more than one cell when the space in their corresponding cells is insufficient due to scaling the view.
Style | Gets or sets the style of the timeline.
TickSize | Gets or sets the size of the ticks displayed in the timeline.
Unit | Gets or sets the time unit of the timeline.
UnitCount | Gets or sets the number of units between adjacent ticks in the timeline.

See Also

TimelineSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.Format Property

TimelineSettings.Format Property

Gets or sets the format of the displayed dates in the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string Format { get; set; }
Visual Basic

Public Property Format As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.NowColor Property

TimelineSettings.NowColor Property

Gets or sets the color used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Color NowColor { get; set; }
Visual Basic

Public Property NowColor As Color

Property Value

A .NET Color object specifying the color used to indicate the current time. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace
NowFillColor Property
ShowCurrentTime Property


MindFusion.Scheduling.WinForms.TimelineSettings.ShowCurrentTime Property

TimelineSettings.ShowCurrentTime Property

Gets or sets a value indicating whether to indicate the current time in the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowCurrentTime { get; set; }
Visual Basic

Public Property ShowCurrentTime As State

Property Value

Specify Enabled to indicate the current time; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace
NowColor Property
NowFillColor Property


MindFusion.Scheduling.WinForms.TimelineSettings.ShowTicks Property

TimelineSettings.ShowTicks Property

Gets or sets a value indicating whether the timeline displays tick lines.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowTicks { get; set; }
Visual Basic

Public Property ShowTicks As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.Size Property

TimelineSettings.Size Property

Gets or sets the size of the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Size { get; set; }
Visual Basic

Public Property Size As Integer

Property Value

A non-negative integer value. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the size to be calculated automatically based on the size of the header font.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.SpanCellCount Property

TimelineSettings.SpanCellCount Property

Gets or sets a value indicating the number of cells to span when SpanTexts is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int SpanCellCount { get; set; }
Visual Basic

Public Property SpanCellCount As Integer

Property Value

A non-negative integer value specifying the number of cells to span. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

If this value is 0, it is automatically calculated based on the current scale factor, which is specified by TimelineScale.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.SpanTexts Property

TimelineSettings.SpanTexts Property

Gets or sets a value indicating whether some cell texts will span more than one cell when the space in their corresponding cells is insufficient due to scaling the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State SpanTexts { get; set; }
Visual Basic

Public Property SpanTexts As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

The number of spanned cells is specified by the SpanCellCount property. If the value of this property is 0, then the number of cells is automatically calculated based on the current scale factor, which is specified by the TimelineScale property.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace
SpanCellCount Property


MindFusion.Scheduling.WinForms.TimelineSettings.Style Property

TimelineSettings.Style Property

Gets or sets the style of the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style Style { get; set; }
Visual Basic

Public Property Style As Style

Property Value

A Style object specifying the style of the timeline. This property cannot be null.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.TickSize Property

TimelineSettings.TickSize Property

Gets or sets the size of the ticks displayed in the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int TickSize { get; set; }
Visual Basic

Public Property TickSize As Integer

Property Value

A non-negative integer value. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimelineSettings.Unit Property

TimelineSettings.Unit Property

Gets or sets the time unit of the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeUnit Unit { get; set; }
Visual Basic

Public Property Unit As TimeUnit

Property Value

A member of the TimeUnit enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace
UnitCount Property


MindFusion.Scheduling.WinForms.TimelineSettings.UnitCount Property

TimelineSettings.UnitCount Property

Gets or sets the number of units between adjacent ticks in the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int UnitCount { get; set; }
Visual Basic

Public Property UnitCount As Integer

Property Value

A non-negative integer value. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimelineSettings Members
TimelineSettings Class
MindFusion.Scheduling.Compact Namespace
Unit Property


MindFusion.Scheduling.WinForms.TimetableSettings Class

TimetableSettings Class

Defines properties that allow customizing the visualization of the calendar in Timetable view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public sealed class TimetableSettings : ViewSettings
Visual Basic

Public NotInheritable Class TimetableSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.ViewSettings
MindFusion.Scheduling.Compact.TimetableSettings

See Also

TimetableSettings Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings Members

TimetableSettings Members
Properties

Defines properties that allow customizing the visualization of the calendar in Timetable view.

The following tables list the members exposed by the TimetableSettings type.

Public Properties

Name | Description
AllowResizeColumns | Gets or sets a value indicating whether the users can resize timetable columns.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of a time segment cell.
CellTime | Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.
ColumnBandSize | Gets or sets the size of the bands displayed on the left/top side of each timetable column.
Dates | Gets a collection of all dates visualized in the timetable.
DayHeaderBrush | Gets or sets the brush used to paint the subheader where the all-day items are displayed.
DayHeaderMinSize | Gets or sets the minimum size of the header displaying all-day items.
EnableAutoDayChange | Gets or sets a value indicating whether the Timetable view will automatically scroll one day forth and back when the user moves the mouse at the top or at the bottom of the view.
EnableCollisions | Gets or sets a value indicating whether the item collision processing is enabled.
EnableDayItems | Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EndTime | Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GeneralFormat | Gets or sets the string to use when formatting times in the timeline.
GroupHours | Gets or sets a value indicating whether hours displayed in the timeline are grouped.
HeaderDateFormat | Gets or sets how to format and display dates in the timetable header.
InfoHeaderBrush | Gets or sets the brush used to paint the info header.
InfoHeaderSize | Gets or sets the size of the info header.
ItemOffset | Gets or set the distance between the first item and its adjoining cell side.
MainHeaderSize | Gets or sets the size of the main header.
MaxAllDayItems | Gets or sets the maximum number of all-day items visible in the columns headers at a time.
MinColumnSize | Gets or sets the smallest size allowed for timetable columns.
MinItemSize | Gets or sets the smallest size allowed for schedule items.
MinuteFormat | Gets or sets how to format and display minutes.
NowColor | Gets or sets the color used to mark the current time in the timeline.
Orientation | Gets or sets the view orientation.
ReverseGrouping | Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.
ScrollStep | Gets or sets the number of days to scroll when the user clicks the navigation buttons.
SelectWholeDayOnHeaderClick | Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.
ShowAM | Gets or sets a value indicating whether the AM and PM suffixes are displayed.
ShowCurrentTime | Gets or sets a value indicating whether to display the current time in the timeline.
ShowDayHeader | Gets or sets a value indicating whether to show the header displaying all-day items.
ShowInfoHeader | Gets or sets a value indicating whether to show the info header.
ShowItemSpans | Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.
ShowMinutesInHourHeaders | Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' icon in the timeline header when some items in a timetable column are not currently visible.
ShowNavigationButtons | Gets or sets a value indicating whether the Timetable view displays navigation buttons.
ShowPadding | Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.
ShowWorkTime | Gets or sets a value indicating whether the work time should be displayed with different style.
SnapInterval | Gets or sets the custom snap interval.
StartTime | Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderSize | Gets or sets the size of the secondary header.
TimelineSize | Gets or sets the size of the timeline header.
TimelineStyle | Gets or sets the style of the timeline header.
TwelveHourFormat | Gets or sets a value indicating whether to use a 12-hour format.
UseZoom | Gets or sets a value indicating whether to use the associated zoom factor or the fixed cell height when displaying cells.
VisibleColumns | Gets or sets the number of columns visible in the view.
WorkTimeCellStyle | Gets or sets the style of cells in the work time interval.
WorkTimeEndHour | Gets or sets the end hour of the work time interval.
WorkTimeStartHour | Gets or sets the start hour of the work time interval.
ZoomFactor | Gets or sets the zoom factor when zoom is enabled.

See Also

TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings Properties

TimetableSettings Properties

Public Properties

Name | Description
AllowResizeColumns | Gets or sets a value indicating whether the users can resize timetable columns.
CellSize | Gets or sets the size of time cells.
CellStyle | Gets or sets the style of a time segment cell.
CellTime | Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.
ColumnBandSize | Gets or sets the size of the bands displayed on the left/top side of each timetable column.
Dates | Gets a collection of all dates visualized in the timetable.
DayHeaderBrush | Gets or sets the brush used to paint the subheader where the all-day items are displayed.
DayHeaderMinSize | Gets or sets the minimum size of the header displaying all-day items.
EnableAutoDayChange | Gets or sets a value indicating whether the Timetable view will automatically scroll one day forth and back when the user moves the mouse at the top or at the bottom of the view.
EnableCollisions | Gets or sets a value indicating whether the item collision processing is enabled.
EnableDayItems | Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.
EnableSnapping | Gets or sets a value indicating whether custom snapping is enabled.
EndTime | Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.
ExpandActiveItemOn | Gets or sets whether the active item should ignore collisions.
GeneralFormat | Gets or sets the string to use when formatting times in the timeline.
GroupHours | Gets or sets a value indicating whether hours displayed in the timeline are grouped.
HeaderDateFormat | Gets or sets how to format and display dates in the timetable header.
InfoHeaderBrush | Gets or sets the brush used to paint the info header.
InfoHeaderSize | Gets or sets the size of the info header.
ItemOffset | Gets or set the distance between the first item and its adjoining cell side.
MainHeaderSize | Gets or sets the size of the main header.
MaxAllDayItems | Gets or sets the maximum number of all-day items visible in the columns headers at a time.
MinColumnSize | Gets or sets the smallest size allowed for timetable columns.
MinItemSize | Gets or sets the smallest size allowed for schedule items.
MinuteFormat | Gets or sets how to format and display minutes.
NowColor | Gets or sets the color used to mark the current time in the timeline.
Orientation | Gets or sets the view orientation.
ReverseGrouping | Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.
ScrollStep | Gets or sets the number of days to scroll when the user clicks the navigation buttons.
SelectWholeDayOnHeaderClick | Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.
ShowAM | Gets or sets a value indicating whether the AM and PM suffixes are displayed.
ShowCurrentTime | Gets or sets a value indicating whether to display the current time in the timeline.
ShowDayHeader | Gets or sets a value indicating whether to show the header displaying all-day items.
ShowInfoHeader | Gets or sets a value indicating whether to show the info header.
ShowItemSpans | Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.
ShowMinutesInHourHeaders | Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.
ShowMoreItemsCue | Gets or sets a value indicating whether to display a 'more items' icon in the timeline header when some items in a timetable column are not currently visible.
ShowNavigationButtons | Gets or sets a value indicating whether the Timetable view displays navigation buttons.
ShowPadding | Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.
ShowWorkTime | Gets or sets a value indicating whether the work time should be displayed with different style.
SnapInterval | Gets or sets the custom snap interval.
StartTime | Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
SubHeaderSize | Gets or sets the size of the secondary header.
TimelineSize | Gets or sets the size of the timeline header.
TimelineStyle | Gets or sets the style of the timeline header.
TwelveHourFormat | Gets or sets a value indicating whether to use a 12-hour format.
UseZoom | Gets or sets a value indicating whether to use the associated zoom factor or the fixed cell height when displaying cells.
VisibleColumns | Gets or sets the number of columns visible in the view.
WorkTimeCellStyle | Gets or sets the style of cells in the work time interval.
WorkTimeEndHour | Gets or sets the end hour of the work time interval.
WorkTimeStartHour | Gets or sets the start hour of the work time interval.
ZoomFactor | Gets or sets the zoom factor when zoom is enabled.

See Also

TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.AllowResizeColumns Property

TimetableSettings.AllowResizeColumns Property

Gets or sets a value indicating whether the users can resize timetable columns.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State AllowResizeColumns { get; set; }
Visual Basic

Public Property AllowResizeColumns As State

Property Value

Specify Enabled to let users resize the view columns; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.CellSize Property

TimetableSettings.CellSize Property

Gets or sets the size of time cells.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int CellSize { get; set; }
Visual Basic

Public Property CellSize As Integer

Property Value

An integer value specifying the cell size. The minimal allowed value is 10. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
CellStyle Property


MindFusion.Scheduling.WinForms.TimetableSettings.CellStyle Property

TimetableSettings.CellStyle Property

Gets or sets the style of a time segment cell.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style CellStyle { get; set; }
Visual Basic

Public Property CellStyle As Style

Property Value

A Style object specifying the style of timetable cells. This property cannot be null.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
CellSize Property


MindFusion.Scheduling.WinForms.TimetableSettings.CellTime Property

TimetableSettings.CellTime Property

Gets or sets the time length of a single cell in a timetable view, accurate to the nearest second.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeSpan CellTime { get; set; }
Visual Basic

Public Property CellTime As TimeSpan

Property Value

A TimeSpan object that specifies the time length of a single cell. The allowed values range from 1 second to 1 hour inclusive. Assign -1 ticks to this property to use the corresponding value from the current theme.

Example

The following sample demonstrates several ways for setting the time span of timetable cells. The sample assumes that calendar already references an existing Calendar object.

C#

// Set the cell time to 10 minutes
calendar.TimetableSettings.CellTime = TimeSpan.FromMinutes(10);

// Set the cell time to 1 second
calendar.TimetableSettings.CellTime = TimeSpan.FromSeconds(1);

// Set the cell time to 1 minute and 20 seconds
calendar.TimetableSettings.CellTime = new TimeSpan(0, 1, 20);
Visual Basic

' Set the cell time to 10 minutes
calendar.TimetableSettings.CellTime = TimeSpan.FromMinutes(10)

' Set the cell time to 1 second
calendar.TimetableSettings.CellTime = TimeSpan.FromSeconds(1)

' Set the cell time to 1 minute and 20 seconds
calendar.TimetableSettings.CellTime = New TimeSpan(0, 1, 20)

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ColumnBandSize Property

TimetableSettings.ColumnBandSize Property

Gets or sets the size of the bands displayed on the left/top side of each timetable column.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ColumnBandSize { get; set; }
Visual Basic

Public Property ColumnBandSize As Integer

Property Value

A non-negative integer specifying band width in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

For best results, assign to this property the value of ItemSettings.MoveBandSize.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.Dates Property

TimetableSettings.Dates Property

Gets a collection of all dates visualized in the timetable.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DateCollection Dates { get; }
Visual Basic

Public ReadOnly Property Dates As DateCollection

Property Value

An instance of the DateCollection class specifying which dates to display as columns in the timetable view.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.DayHeaderBrush Property

TimetableSettings.DayHeaderBrush Property

Gets or sets the brush used to paint the subheader where the all-day items are displayed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Brush DayHeaderBrush { get; set; }
Visual Basic

Public Property DayHeaderBrush As Brush

Property Value

An instance of a Brush-derived class used to fill the day header. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.DayHeaderMinSize Property

TimetableSettings.DayHeaderMinSize Property

Gets or sets the minimum size of the header displaying all-day items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int DayHeaderMinSize { get; set; }
Visual Basic

Public Property DayHeaderMinSize As Integer

Property Value

An integer value specifying the minimal header size in pixels. The minimal allowed value is 5. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.EnableAutoDayChange Property

TimetableSettings.EnableAutoDayChange Property

Gets or sets a value indicating whether the Timetable view will automatically scroll one day forth and back when the user moves the mouse at the top or at the bottom of the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State EnableAutoDayChange { get; set; }
Visual Basic

Public Property EnableAutoDayChange As State

Property Value

A member of the State enumeration.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.EnableCollisions Property

TimetableSettings.EnableCollisions Property

Gets or sets a value indicating whether the item collision processing is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State EnableCollisions { get; set; }
Visual Basic

Public Property EnableCollisions As State

Property Value

A member of the State enumeration.

Remarks

Turn this flag off if you don't need collision detection to improve performance.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.EnableDayItems Property

TimetableSettings.EnableDayItems Property

Gets or sets a value indicating whether items longer than 24 hours are displayed in the day header or not.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State EnableDayItems { get; set; }
Visual Basic

Public Property EnableDayItems As State

Property Value

A value of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

By default, items longer than 1 day or items marked as AllDayEvent are displayed in the day header of the view. If the day header is not displayed (that is, ShowDayHeader is set to State.Disabled) then these items are never displayed. Settings this property to State.Disabled causes all items regardless of their length to be displayed in the main view.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.EnableSnapping Property

TimetableSettings.EnableSnapping Property

Gets or sets a value indicating whether custom snapping is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State EnableSnapping { get; set; }
Visual Basic

Public Property EnableSnapping As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
SnapInterval Property


MindFusion.Scheduling.WinForms.TimetableSettings.EndTime Property

TimetableSettings.EndTime Property

Gets or sets the end time of the timetable, expressed in minutes since the beginning of the day.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int EndTime { get; set; }
Visual Basic

Public Property EndTime As Integer

Property Value

An integer value specifying the end time in minutes. The allowed values range from 0 to 2880. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

Specifying value for this property which is smaller than the value of StartTime is permissible. This indicates that the end value represents time from the next day. For example if StartTime is set to 600 (10:00 AM) and EndTime is set to 480 (8:00 AM), then each column in the view represents the time from 10:00 AM until 8:00 AM on the following day. Specifying 1920 (480 + 1440) for the EndTime yields the same result.

Note

It is possible to specify more than 24 hours to be displayed in a single timetable column. Doing so though might lead to ambiguities because certain periods of time will appear in more than one place (for example, a period will appear once at the end of a column and again in the beginning of the next one).

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
StartTime Property
CellTime Property


MindFusion.Scheduling.WinForms.TimetableSettings.ExpandActiveItemOn Property

TimetableSettings.ExpandActiveItemOn Property

Gets or sets whether the active item should ignore collisions.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public ItemAction ExpandActiveItemOn { get; set; }
Visual Basic

Public Property ExpandActiveItemOn As ItemAction

Property Value

A member of the ItemAction enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.GeneralFormat Property

TimetableSettings.GeneralFormat Property

Gets or sets the string to use when formatting times in the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string GeneralFormat { get; set; }
Visual Basic

Public Property GeneralFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.GroupHours Property

TimetableSettings.GroupHours Property

Gets or sets a value indicating whether hours displayed in the timeline are grouped.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State GroupHours { get; set; }
Visual Basic

Public Property GroupHours As State

Property Value

Specify Enabled to enable grouping; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Certain conditions prevent hours from grouping, such as when the hours are not divisible by the specified CellTime.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.HeaderDateFormat Property

TimetableSettings.HeaderDateFormat Property

Gets or sets how to format and display dates in the timetable header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string HeaderDateFormat { get; set; }
Visual Basic

Public Property HeaderDateFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.InfoHeaderBrush Property

TimetableSettings.InfoHeaderBrush Property

Gets or sets the brush used to paint the info header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Brush InfoHeaderBrush { get; set; }
Visual Basic

Public Property InfoHeaderBrush As Brush

Property Value

A Brush object specifying the interior fill of the header. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.InfoHeaderSize Property

TimetableSettings.InfoHeaderSize Property

Gets or sets the size of the info header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int InfoHeaderSize { get; set; }
Visual Basic

Public Property InfoHeaderSize As Integer

Property Value

A positive integer value specifying the size of the info header. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ItemOffset Property

TimetableSettings.ItemOffset Property

Gets or set the distance between the first item and its adjoining cell side.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ItemOffset { get; set; }
Visual Basic

Public Property ItemOffset As Integer

Property Value

A non-negative integer value specifying the item offset in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.MainHeaderSize Property

TimetableSettings.MainHeaderSize Property

Gets or sets the size of the main header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MainHeaderSize { get; set; }
Visual Basic

Public Property MainHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the calendar to automatically calculate a header size based on the size of the header font.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.MaxAllDayItems Property

TimetableSettings.MaxAllDayItems Property

Gets or sets the maximum number of all-day items visible in the columns headers at a time.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MaxAllDayItems { get; set; }
Visual Basic

Public Property MaxAllDayItems As Integer

Property Value

An integer value specifying how many all-day items to display at most in the column headers. The allowed values range from 1 to 20. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

The all-day items header is automatically resized to hold all items up to the number set in this property. If there are more all-day items, the rest of them are not shown. In that case, the 'hidden items' icon is displayed if ShowMoreItemsCue is enabled.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
ShowDayHeader Property


MindFusion.Scheduling.WinForms.TimetableSettings.MinColumnSize Property

TimetableSettings.MinColumnSize Property

Gets or sets the smallest size allowed for timetable columns.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MinColumnSize { get; set; }
Visual Basic

Public Property MinColumnSize As Integer

Property Value

An integer value specifying the minimal column size. The minimal allowed value is 10. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.MinItemSize Property

TimetableSettings.MinItemSize Property

Gets or sets the smallest size allowed for schedule items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int MinItemSize { get; set; }
Visual Basic

Public Property MinItemSize As Integer

Property Value

An integer value specifying the minimal size in pixels. The minimal allowed value is 5. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

If there is not enough space in a column to display all related items, the items that do not fit remain invisible.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.MinuteFormat Property

TimetableSettings.MinuteFormat Property

Gets or sets how to format and display minutes.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public MinuteFormat MinuteFormat { get; set; }
Visual Basic

Public Property MinuteFormat As MinuteFormat

Property Value

A MinuteFormat object specifying the minutes format. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.NowColor Property

TimetableSettings.NowColor Property

Gets or sets the color used to mark the current time in the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Color NowColor { get; set; }
Visual Basic

Public Property NowColor As Color

Property Value

A .NET Color object specifying the color used to indicate the current time. Assign Color.Empty to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
NowFillColor Property
ShowCurrentTime Property


MindFusion.Scheduling.WinForms.TimetableSettings.Orientation Property

TimetableSettings.Orientation Property

Gets or sets the view orientation.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Orientation Orientation { get; set; }
Visual Basic

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

A vertical timetable view displays cells for the same daytime in a row, and cells for the same date in a column. A horizontal timetable view displays cells for the same time of the day in a column, and cells for the same date in a row.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ReverseGrouping Property

TimetableSettings.ReverseGrouping Property

Gets or sets a value indicating whether grouping (if enabled) will be performed first by the resource, and then by the date.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ReverseGrouping { get; set; }
Visual Basic

Public Property ReverseGrouping As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

By default grouping is done first by available dates, then by the resources specified in the current grouping type. Setting this property to Enabled reverses this behavior.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ScrollStep Property

TimetableSettings.ScrollStep Property

Gets or sets the number of days to scroll when the user clicks the navigation buttons.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ScrollStep { get; set; }
Visual Basic

Public Property ScrollStep As Integer

Property Value

A positive integer value specifying the number of days to scroll. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.SelectWholeDayOnHeaderClick Property

TimetableSettings.SelectWholeDayOnHeaderClick Property

Gets or sets a value indicating whether the whole day is selected when the user clicks in the column's header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State SelectWholeDayOnHeaderClick { get; set; }
Visual Basic

Public Property SelectWholeDayOnHeaderClick As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowAM Property

TimetableSettings.ShowAM Property

Gets or sets a value indicating whether the AM and PM suffixes are displayed.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowAM { get; set; }
Visual Basic

Public Property ShowAM As State

Property Value

Specify Enabled to show AM/PM suffixes; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowCurrentTime Property

TimetableSettings.ShowCurrentTime Property

Gets or sets a value indicating whether to display the current time in the timeline.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowCurrentTime { get; set; }
Visual Basic

Public Property ShowCurrentTime As State

Property Value

Specify Enabled to indicate the current time; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
NowColor Property
NowFillColor Property


MindFusion.Scheduling.WinForms.TimetableSettings.ShowDayHeader Property

TimetableSettings.ShowDayHeader Property

Gets or sets a value indicating whether to show the header displaying all-day items.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowDayHeader { get; set; }
Visual Basic

Public Property ShowDayHeader As State

Property Value

Specify Enabled to show the days header; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
MaxAllDayItems Property


MindFusion.Scheduling.WinForms.TimetableSettings.ShowInfoHeader Property

TimetableSettings.ShowInfoHeader Property

Gets or sets a value indicating whether to show the info header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowInfoHeader { get; set; }
Visual Basic

Public Property ShowInfoHeader As State

Property Value

A value of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowItemSpans Property

TimetableSettings.ShowItemSpans Property

Gets or sets a value indicating whether the item time spans are also drawn in the left band of the corresponding column.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowItemSpans { get; set; }
Visual Basic

Public Property ShowItemSpans As State

Property Value

Specify Enabled to display item spans; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowMinutesInHourHeaders Property

TimetableSettings.ShowMinutesInHourHeaders Property

Gets or sets a value indicating whether to display the minutes of each hour in the timeline header when it displays whole hour cells.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowMinutesInHourHeaders { get; set; }
Visual Basic

Public Property ShowMinutesInHourHeaders As State

Property Value

Specify Enabled to show minutes; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

Whole hour cells are displayed when the hours are divisible by the specified CellTime.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowMoreItemsCue Property

TimetableSettings.ShowMoreItemsCue Property

Gets or sets a value indicating whether to display a 'more items' icon in the timeline header when some items in a timetable column are not currently visible.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowMoreItemsCue { get; set; }
Visual Basic

Public Property ShowMoreItemsCue As State

Property Value

Specify Enabled to show the 'more items' cue when there are items not visible in the current viewport; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowNavigationButtons Property

TimetableSettings.ShowNavigationButtons Property

Gets or sets a value indicating whether the Timetable view displays navigation buttons.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowNavigationButtons { get; set; }
Visual Basic

Public Property ShowNavigationButtons As State

Property Value

Specify Enabled to show navigation buttons; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowPadding Property

TimetableSettings.ShowPadding Property

Gets or sets a value indicating whether padding should be disabled. Padding of items appear when the items are not aligned to cells.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowPadding { get; set; }
Visual Basic

Public Property ShowPadding As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.ShowWorkTime Property

TimetableSettings.ShowWorkTime Property

Gets or sets a value indicating whether the work time should be displayed with different style.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowWorkTime { get; set; }
Visual Basic

Public Property ShowWorkTime As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
WorkTimeCellStyle Property


MindFusion.Scheduling.WinForms.TimetableSettings.SnapInterval Property

TimetableSettings.SnapInterval Property

Gets or sets the custom snap interval.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public TimeSpan SnapInterval { get; set; }
Visual Basic

Public Property SnapInterval As TimeSpan

Property Value

A .NET TimeSpan object that specifies the snap interval, relative to the beginning of the timetable column. The allowed values range from 1 second to 1 hour inclusive. Assign -1 ticks to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
EnableSnapping Property


MindFusion.Scheduling.WinForms.TimetableSettings.StartTime Property

TimetableSettings.StartTime Property

Gets or sets the start time of the timetable, expressed in minutes since the beginning of the day.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int StartTime { get; set; }
Visual Basic

Public Property StartTime As Integer

Property Value

An integer value specifying the view start time in minutes. The allowed values range from 0 to 1440. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
EndTime Property
CellTime Property


MindFusion.Scheduling.WinForms.TimetableSettings.Style Property

TimetableSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.SubHeaderSize Property

TimetableSettings.SubHeaderSize Property

Gets or sets the size of the secondary header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int SubHeaderSize { get; set; }
Visual Basic

Public Property SubHeaderSize As Integer

Property Value

A non-negative integer value specifying the size of the secondary header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the calendar to automatically calculate a header size based on the size of the header font.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.TimelineSize Property

TimetableSettings.TimelineSize Property

Gets or sets the size of the timeline header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int TimelineSize { get; set; }
Visual Basic

Public Property TimelineSize As Integer

Property Value

A non-negative integer value specifying the size of the timeline header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.TimelineStyle Property

TimetableSettings.TimelineStyle Property

Gets or sets the style of the timeline header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style TimelineStyle { get; set; }
Visual Basic

Public Property TimelineStyle As Style

Property Value

A Style object specifying the appearance of the timeline header. This property cannot be null.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.TwelveHourFormat Property

TimetableSettings.TwelveHourFormat Property

Gets or sets a value indicating whether to use a 12-hour format.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State TwelveHourFormat { get; set; }
Visual Basic

Public Property TwelveHourFormat As State

Property Value

Specify Enabled to use 12-hour format, or Disabled to use 24-hour format. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.UseZoom Property

TimetableSettings.UseZoom Property

Gets or sets a value indicating whether to use the associated zoom factor or the fixed cell height when displaying cells.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State UseZoom { get; set; }
Visual Basic

Public Property UseZoom As State

Property Value

A member of the State enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
ZoomFactor Property


MindFusion.Scheduling.WinForms.TimetableSettings.VisibleColumns Property

TimetableSettings.VisibleColumns Property

Gets or sets the number of columns visible in the view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int VisibleColumns { get; set; }
Visual Basic

Public Property VisibleColumns As Integer

Property Value

A positive integer value specifying the number of columns visible at the same time. Assign -1 to this property to use the corresponding value from the current theme.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.TimetableSettings.WorkTimeCellStyle Property

TimetableSettings.WorkTimeCellStyle Property

Gets or sets the style of cells in the work time interval.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Style WorkTimeCellStyle { get; set; }
Visual Basic

Public Property WorkTimeCellStyle As Style

Property Value

A Style object specifying the style of the work time cells. This property cannot be null.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
ShowWorkTime Property


MindFusion.Scheduling.WinForms.TimetableSettings.WorkTimeEndHour Property

TimetableSettings.WorkTimeEndHour Property

Gets or sets the end hour of the work time interval.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int WorkTimeEndHour { get; set; }
Visual Basic

Public Property WorkTimeEndHour As Integer

Property Value

An integer value specifying the start of the work time in hours. The allowed values range from 0 to 23. The value cannot be less than WorkTimeStartHour. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property and WorkTimeStartHour specify the working time period, whose cells are usually displayed in a different style as set in WorkTimeCellStyle. To use the same style for all cells in the timetable view, set WorkTimeCellStyle to a new empty Style.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
WorkTimeStartHour Property


MindFusion.Scheduling.WinForms.TimetableSettings.WorkTimeStartHour Property

TimetableSettings.WorkTimeStartHour Property

Gets or sets the start hour of the work time interval.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int WorkTimeStartHour { get; set; }
Visual Basic

Public Property WorkTimeStartHour As Integer

Property Value

An integer value specifying the start of the work time in hours. The allowed values range from 0 to 23. The value cannot be greater than WorkTimeEndHour. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This property and WorkTimeEndHour specify the working time period, whose cells are usually displayed in a different style as set in WorkTimeCellStyle. To use the same style for all cells in the timetable view, set WorkTimeCellStyle to a new empty Style.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
WorkTimeEndHour Property


MindFusion.Scheduling.WinForms.TimetableSettings.ZoomFactor Property

TimetableSettings.ZoomFactor Property

Gets or sets the zoom factor when zoom is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ZoomFactor { get; set; }
Visual Basic

Public Property ZoomFactor As Integer

Property Value

An integer value specifying the zoom factor when UseZoom is enabled. The allowed values range from 100 to 1000. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

To make the whole timeline visible at a time, set this to 100.

See Also

TimetableSettings Members
TimetableSettings Class
MindFusion.Scheduling.Compact Namespace
UseZoom Property


MindFusion.Scheduling.WinForms.TimeUnit Enumeration

TimeUnit Enumeration

Specifies a time resolution.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum TimeUnit
Visual Basic

Public Enumeration TimeUnit

Members

Member name | Description
Day | Specifies days.
Hour | Specifies hours.
Minute | Specifies minutes.
Month | Specifies months.
Second | Specifies seconds.
Unspecified | Unspecified.
Week | Specifies weeks.
Year | Specifies years.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ViewSettings Class

ViewSettings Class

The base class for the different view settings classes.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public abstract class ViewSettings
Visual Basic

Public MustInherit Class ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.ViewSettings
MindFusion.Scheduling.Compact.CellSettings
MindFusion.Scheduling.Compact.ListViewSettings
MindFusion.Scheduling.Compact.MonthRangeSettings
MindFusion.Scheduling.Compact.MonthSettings
MindFusion.Scheduling.Compact.ResourceViewSettings
MindFusion.Scheduling.Compact.TimetableSettings
MindFusion.Scheduling.Compact.WeekRangeSettings

See Also

ViewSettings Members
MindFusion.Scheduling.Compact Namespace
CellSettings Class
ListViewSettings Class
MonthRangeSettings Class
MonthSettings Class
TimetableSettings Class
ResourceViewSettings Class
WeekRangeSettings Class


MindFusion.Scheduling.WinForms.ViewSettings Members

ViewSettings Members
Properties Events

The base class for the different view settings classes.

The following tables list the members exposed by the ViewSettings type.

Public Properties

Name | Description
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Public Events

Name | Description
SettingsChanged | Raised when the view settings change.

See Also

ViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ViewSettings Properties

ViewSettings Properties

Public Properties

Name | Description
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

See Also

ViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ViewSettings.Style Property

ViewSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public abstract Style Style { get; set; }
Visual Basic

Public MustOverride Property Style As Style

Property Value

An instance of the Style class specifying the style of calendar UI elements. This property cannot be null.

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.Compact Namespace
Style Class


MindFusion.Scheduling.WinForms.ViewSettings Events

ViewSettings Events

Public Events

Name | Description
SettingsChanged | Raised when the view settings change.

See Also

ViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.ViewSettings.SettingsChanged Event

ViewSettings.SettingsChanged Event

Raised when the view settings change.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public EventHandler SettingsChanged
Visual Basic

Public SettingsChanged As EventHandler

Event Data

SettingsChanged event handlers receive an argument of type EventArgs.

See Also

ViewSettings Members
ViewSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeHeaderStyle Enumeration

WeekRangeHeaderStyle Enumeration

Specifies the appearance of the time period header in WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum WeekRangeHeaderStyle
Visual Basic

Public Enumeration WeekRangeHeaderStyle

Members

Member name | Description
None | There isn't a header displayed.
Reference | The header displays the name of the associated contact, resource, location or task. This flag is valid only if grouping is enabled.
Title | The header displays the start and end dates specified in the WeekRangeSettings object.
Unspecified | Unspecified.

See Also

MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings Class

WeekRangeSettings Class

Defines properties that allow customizing the visualization of weeks in WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public class WeekRangeSettings : ViewSettings
Visual Basic

Public Class WeekRangeSettings
Inherits ViewSettings

Inheritance Hierarchy

System.Object
MindFusion.Scheduling.Compact.ViewSettings
MindFusion.Scheduling.Compact.WeekRangeSettings

See Also

WeekRangeSettings Members
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings Members

WeekRangeSettings Members
Properties

Defines properties that allow customizing the visualization of weeks in WeekRange view.

The following tables list the members exposed by the WeekRangeSettings type.

Public Properties

Name | Description
DayDistance | Gets or sets the distance between adjacent days.
DayNamesHeaderHeight | Gets or sets the height of the day-names header in the WeekRange view.
DayOfWeekFormat | Gets or sets the display format of the names of the days of the week.
DaySettings | Gets the CellSettings object used to customize the visualization of days in a WeekRange view.
EvenMonthsBrush | Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.
GroupWeekends | Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.
GroupWeekendsTitleSeparator | Gets or sets the separator string displayed between Saturday and Sunday strings when GroupWeekends is enabled.
HeaderStyle | Gets or sets the style of the time-period header, displayed above the day-names header.
Margin | Gets or sets the distance between the outermost border and the rest of the calendar contents.
NumberOfDays | Gets the total number of days displayed in the WeekRange view.
OddMonthsBrush | Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.
ReferenceHeaderHeight | Gets or sets the height of the reference header in the WeekRange view.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TimePeriodHeaderHeight | Gets or sets the height of the time-period header in the WeekRange view.
TitleFormat | Gets or sets the format of the calendar's title.
TitleSeparator | Gets or sets the string used as a separator in the calendar's title.
ViewStyle | Gets or sets the style of the WeekRange view.
VisibleColumns | Gets or sets the number of columns visible when the GroupType is enabled.
VisibleRows | Gets or sets the number of weeks visible at a time.

See Also

WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings Properties

WeekRangeSettings Properties

Public Properties

Name | Description
DayDistance | Gets or sets the distance between adjacent days.
DayNamesHeaderHeight | Gets or sets the height of the day-names header in the WeekRange view.
DayOfWeekFormat | Gets or sets the display format of the names of the days of the week.
DaySettings | Gets the CellSettings object used to customize the visualization of days in a WeekRange view.
EvenMonthsBrush | Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.
GroupWeekends | Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.
GroupWeekendsTitleSeparator | Gets or sets the separator string displayed between Saturday and Sunday strings when GroupWeekends is enabled.
HeaderStyle | Gets or sets the style of the time-period header, displayed above the day-names header.
Margin | Gets or sets the distance between the outermost border and the rest of the calendar contents.
NumberOfDays | Gets the total number of days displayed in the WeekRange view.
OddMonthsBrush | Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.
ReferenceHeaderHeight | Gets or sets the height of the reference header in the WeekRange view.
ShowDayOfWeek | Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.
Style | Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.
TimePeriodHeaderHeight | Gets or sets the height of the time-period header in the WeekRange view.
TitleFormat | Gets or sets the format of the calendar's title.
TitleSeparator | Gets or sets the string used as a separator in the calendar's title.
ViewStyle | Gets or sets the style of the WeekRange view.
VisibleColumns | Gets or sets the number of columns visible when the GroupType is enabled.
VisibleRows | Gets or sets the number of weeks visible at a time.

See Also

WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.DayDistance Property

WeekRangeSettings.DayDistance Property

Gets or sets the distance between adjacent days.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int DayDistance { get; set; }
Visual Basic

Public Property DayDistance As Integer

Property Value

A non-negative integer value specifying the distance between adjacent day cells in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace
Margin Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.DayNamesHeaderHeight Property

WeekRangeSettings.DayNamesHeaderHeight Property

Gets or sets the height of the day-names header in the WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int DayNamesHeaderHeight { get; set; }
Visual Basic

Public Property DayNamesHeaderHeight As Integer

Property Value

A non-negative integer value specifying the height of the day-names header in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the height to be calculated automatically based on the size of the header font.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.DayOfWeekFormat Property

WeekRangeSettings.DayOfWeekFormat Property

Gets or sets the display format of the names of the days of the week.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public DayOfWeekFormat DayOfWeekFormat { get; set; }
Visual Basic

Public Property DayOfWeekFormat As DayOfWeekFormat

Property Value

A member of the DayOfWeekFormat enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.DaySettings Property

WeekRangeSettings.DaySettings Property

Gets the CellSettings object used to customize the visualization of days in a WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public CellSettings DaySettings { get; }
Visual Basic

Public ReadOnly Property DaySettings As CellSettings

Property Value

An instance of the CellSettings class.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.EvenMonthsBrush Property

WeekRangeSettings.EvenMonthsBrush Property

Gets or sets the brush used to paint the background of all even months' areas in the WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Brush EvenMonthsBrush { get; set; }
Visual Basic

Public Property EvenMonthsBrush As Brush

Property Value

An instance of a Brush-derived class used to fill the even month cells. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace
OddMonthsBrush Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.GroupWeekends Property

WeekRangeSettings.GroupWeekends Property

Gets or sets a value indicating whether weekend days are grouped in a single calendar cell. Weekends are always grouped in a SingleWeek view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State GroupWeekends { get; set; }
Visual Basic

Public Property GroupWeekends As State

Property Value

Specify Enabled to display weekend days together; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.GroupWeekendsTitleSeparator Property

WeekRangeSettings.GroupWeekendsTitleSeparator Property

Gets or sets the separator string displayed between Saturday and Sunday strings when GroupWeekends is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string GroupWeekendsTitleSeparator { get; set; }
Visual Basic

Public Property GroupWeekendsTitleSeparator As String

Property Value

A string specifying the separator text. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.HeaderStyle Property

WeekRangeSettings.HeaderStyle Property

Gets or sets the style of the time-period header, displayed above the day-names header.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public WeekRangeHeaderStyle HeaderStyle { get; set; }
Visual Basic

Public Property HeaderStyle As WeekRangeHeaderStyle

Property Value

A member of the WeekRangeHeaderStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.Margin Property

WeekRangeSettings.Margin Property

Gets or sets the distance between the outermost border and the rest of the calendar contents.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int Margin { get; set; }
Visual Basic

Public Property Margin As Integer

Property Value

A non-negative integer value specifying the margin size in pixels. Assign -1 to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace
DayDistance Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.NumberOfDays Property

WeekRangeSettings.NumberOfDays Property

Gets the total number of days displayed in the WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int NumberOfDays { get; }
Visual Basic

Public ReadOnly Property NumberOfDays As Integer

Property Value

An integer value specifying how many days are contained in the week range view.

Remarks

Use the Date and EndDate properties of the Calendar control to set the time period displayed in the week range view.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace
VisibleRows Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.OddMonthsBrush Property

WeekRangeSettings.OddMonthsBrush Property

Gets or sets the brush used to paint the background of all odd months' areas in the WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public Brush OddMonthsBrush { get; set; }
Visual Basic

Public Property OddMonthsBrush As Brush

Property Value

An instance of a Brush-derived class used to fill the odd month cells. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace
EvenMonthsBrush Property


MindFusion.Scheduling.WinForms.WeekRangeSettings.ReferenceHeaderHeight Property

WeekRangeSettings.ReferenceHeaderHeight Property

Gets or sets the height of the reference header in the WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int ReferenceHeaderHeight { get; set; }
Visual Basic

Public Property ReferenceHeaderHeight As Integer

Property Value

A non-negative integer value specifying the header height. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

This header is where the contact, task, location or resource names are displayed, depending on the calendar GroupType. A value of 0 causes the height to be calculated automatically based on the size of the header font.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.ShowDayOfWeek Property

WeekRangeSettings.ShowDayOfWeek Property

Gets or sets a value indicating whether the day names are displayed in the header area of the WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public State ShowDayOfWeek { get; set; }
Visual Basic

Public Property ShowDayOfWeek As State

Property Value

Specify Enabled to display the day names; otherwise, Disabled. Assign Unspecified to this property to use the corresponding value from the current theme.

Remarks

The day names are obtained from the DateTimeFormat property of the Calendar class, if it isn't a null reference (Nothing in Visual Basic), or from the corresponding DateTimeFormat property of the .NET CultureInfo object assigned to calendar's Culture.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.Style Property

WeekRangeSettings.Style Property

Gets or sets the appearance style used to paint calendar elements that don't have a distinct style assigned to them.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public override Style Style { get; set; }
Visual Basic

Public Overrides Property Style As Style

Property Value

A Style object specifying the style of calendar UI elements. This property cannot be null.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.TimePeriodHeaderHeight Property

WeekRangeSettings.TimePeriodHeaderHeight Property

Gets or sets the height of the time-period header in the WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int TimePeriodHeaderHeight { get; set; }
Visual Basic

Public Property TimePeriodHeaderHeight As Integer

Property Value

A non-negative integer value specifying the header height in pixels. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

A value of 0 causes the height to be calculated automatically based on the size of the header font.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.TitleFormat Property

WeekRangeSettings.TitleFormat Property

Gets or sets the format of the calendar's title.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string TitleFormat { get; set; }
Visual Basic

Public Property TitleFormat As String

Property Value

A string specifying the display format. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

Remarks

The format specifiers that can be used in the format string are listed in the MSDN's DateTimeFormatInfo [image] class topic.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.TitleSeparator Property

WeekRangeSettings.TitleSeparator Property

Gets or sets the string used as a separator in the calendar's title.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public string TitleSeparator { get; set; }
Visual Basic

Public Property TitleSeparator As String

Property Value

A string specifying the separator text. Assign null (Nothing in Visual Basic) to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.ViewStyle Property

WeekRangeSettings.ViewStyle Property

Gets or sets the style of the WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public WeekRangeViewStyle ViewStyle { get; set; }
Visual Basic

Public Property ViewStyle As WeekRangeViewStyle

Property Value

A member of the WeekRangeViewStyle enumeration. Assign Unspecified to this property to use the corresponding value from the current theme.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.VisibleColumns Property

WeekRangeSettings.VisibleColumns Property

Gets or sets the number of columns visible when the GroupType is enabled.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int VisibleColumns { get; set; }
Visual Basic

Public Property VisibleColumns As Integer

Property Value

A positive integer value specifying how many columns are visible simultaneously. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

In the week range view schedule data can be displayed in several columns grouped by contact, location, task or resource, as set in Calendar.GroupType. This property determines how many parallel columns are visible at a time.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.WeekRangeSettings.VisibleRows Property

WeekRangeSettings.VisibleRows Property

Gets or sets the number of weeks visible at a time.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public int VisibleRows { get; set; }
Visual Basic

Public Property VisibleRows As Integer

Property Value

The allowed values range from 1 to 10. Assign -1 to this property to use the corresponding value from the current theme.

Remarks

Used only when ViewStyle is set to WeekPerRow.

See Also

WeekRangeSettings Members
WeekRangeSettings Class
MindFusion.Scheduling.Compact Namespace
NumberOfDays Property


MindFusion.Scheduling.WinForms.WeekRangeViewStyle Enumeration

WeekRangeViewStyle Enumeration

Specifies whether there are multiple weeks displayed in WeekRange view.

Namespace: MindFusion.Scheduling.Compact
Assembly: PocketPlanner

Syntax

C#

public enum WeekRangeViewStyle
Visual Basic

Public Enumeration WeekRangeViewStyle

Members

Member name | Description
SingleWeek | The calendar view displays a single week at a time.
Unspecified | Unspecified.
WeekPerRow | The calendar view displays several weeks at a time.

See Also

MindFusion.Scheduling.Compact Namespace


Technical Support

Detailed information about everything connected with software products offered by MindFusion - online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu [image] . The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at support@mindfusion.eu [image] or by phone at +359 877 65 22 51.

In addition, you can post a question on the Planner.NET discussion board here:

http://mindfusion.eu/Forum/YaBB.pl#calnet_cat

the PocketPlanner discussion board here:

http://mindfusion.eu/Forum/YaBB.pl#pplanner_cat

or visit our help desk site:

http://www.mindfusion.eu/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding PocketPlanner. We do take in account the opinion of every single person who has shown interest in our products.


MindFusion.Scheduling.WinForms.Calendar.LoadViewSettings Method

Calendar.LoadViewSettings Method

Loads the view settings from the specified stream or XML document.

Overload List

Name | Description
Calendar.LoadViewSettings (XmlDocument, String) | Loads the view settings under the specified name from the specified XML document.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace


MindFusion.Scheduling.WinForms.Calendar.SaveViewSettings Method

Calendar.SaveViewSettings Method

Saves the view settings to the specified stream or XML document.

Overload List

Name | Description
Calendar.SaveViewSettings (XmlDocument, String) | Saves the view settings to the specified XML document under the specified name.

See Also

Calendar Members
Calendar Class
MindFusion.Scheduling.Compact Namespace