Introduction

DroidChart Programmer's Guide
Introduction

MindFusion.Charting for Android is a Java class library suitable for creating:

  • line / area / stacked area / scatter charts
  • bar / groups of bars / stacked / overlay / column charts
  • combination (line and bar) charts
  • pie / doughnut charts

The component is designed to be easy to use, with powerful and intuitive API, various samples and tutorials. It provides your mobile application with features that take months to develop. By using this library you save yourself hours of coding and debugging.

For today's mobile applications good looks and reliable performance are indispensible. MindFusion.Charting for Android offers various appearance settings, which you can use to customize the chart according to your needs. The component has been thoroughly tested to ensure that it meets the high quality standards MindFusion sets for its tools.

© 2014 MindFusion


General Information

General Information

The DroidChart library

  • Is written in Java
  • Can be purchased with source code
  • Redistribution is royalty free

Line / Area charts

  • Stacked charts
  • Unlimited number of series
  • Scatter charts
  • Labels at data points
  • Dashed lines

Pie / Doughnut charts

  • Unlimited number of series
  • Customizable inner and outer labels
  • Customizable doughnut thickness

Bar charts

  • Different bar styles
  • Stacked charts
  • Customizable bar width
  • Customizable series width

Combination charts

  • unlimited number of bar and line series

Axes

  • custom labels
  • title label
  • Tick marks
  • Positive and negative values for all axes

Grid

  • several grid types
  • Customizable grid strokes and fills

Data

  • Unlimited number of data series
  • Positive and negative values


Getting Started

Getting Started

Create Android project

This tutorial assumes you have installed the Android SDK and Eclipse, and have unarchived the MindFusion.Charting for Android distribution archive.

Let's create an Android application project and add the charting library to it:

1. Select the File -> New -> Project command in Eclipse.
2. Select the Android Application Project wizard.
3. Enter ChartApp in the Application Name field.
4. Keep the default settings on Configure Project screen.
5. Keep the default settings on Configure Launcher Icon screen.
6. Check Create Activity and select Blank Activity on the Create Activity screen.
7. Enter ChartActivity as Activity name on the last screen or leave it to the default name and click Finish.
8. Expand ChartApp -> libs in Package Explorer.
9. Drag droidchart.jar from your file manager to the libs folder in Eclipse. Now you can use classes from the com.mindfusion.charting namespace in this project.
10. Expand ChartApp -> res -> values in Package Explorer and copy attrs.xml from any of the sample projects. This alows you to use custom chart attributes in your XML declaration of the chart.
11. Open activity_main.xml and switch to XML view.
Add a Chart element to the layout:

Java [image] Copy Code

<LinearLayout xmlns:android="http://schemas.android.com/apk/res/android"
xmlns:tools="http://schemas.android.com/tools"
xmlns:chart="http://schemas.android.com/apk/res-auto"
...
>

Initialize the chart - in this case it is an AxesChart:

Java [image] Copy Code

<com.mindfusion.charting.AxesChart
android:id="@+id/chart"
android:layout_width="fill_parent"
android:layout_height="wrap_content"
chart:gridType="horizontal"
chart:titleOffset="20dp"
chart:titleHeight="20dp"
chart:labelHeight="12dp"
tools:context=".MainActivity" />

Here we set the grid type, title offset, the title height and the height of the labels. Next, in the MainActivity.java file we access the AxesChart:

Java [image] Copy Code

//initialize a variable to access the chart
private AxesChart chart;

protected void onCreate(Bundle savedInstanceState) {
.
.
.
//get the chart
chart = (AxesChart)findViewById(R.id.chart);

Customizing the Chart

1. First, let's specify the settings for the axes. Here is an overview of how we have customized to Y-axis - we create an axis that ranges from 0 to 500, shows the intervals as labels and shows "in thousands":

Java [image] Copy Code

chart.yAxisSettings.setMin(0f);
chart.yAxisSettings.setMax(500f);
chart.yAxisSettings.setInterval(50f);
chart.yAxisSettings.setLabelType(AxisLabelType.Scale);
chart.yAxisSettings.setTitle("Sales");
chart.yAxisSettings.setTitleOffset(10f);

2. Let's place custom labels at the X-axis that show various years:

Java [image] Copy Code

ArrayList<String> labels = new ArrayList<String>();

labels.add("2009");
labels.add("2010");
labels.add("2011");
labels.add("2012");
labels.add("2013");

chart.xAxisSettings.setLabels(labels);
chart.xAxisSettings.setLabelType(AxisLabelType.Custom);
chart.xAxisSettings.setTitle("Year");

3. Add a BarSeries with 5 data points:

Java [image] Copy Code

BarSeries series1 = new BarSeries();

ArrayList<Float> xData = new ArrayList<Float>();

for(int i = 0; i < 5; i++)
xData.add((float)i);

series1.setXData(xData);

ArrayList<Float> yData1 = new ArrayList<Float>();
yData1.add(234f);
yData1.add(315f);
yData1.add(265f);
yData1.add(302f);
yData1.add(276f);
series1.setYData(yData1);

//add the series
chart.addSeries(series1);

4. Set the colors for the bars. Each bar will be painted in different color.

Java [image] Copy Code

ArrayList<Integer> fillColors1 = new ArrayList<Integer>();
fillColors1.add(Color.rgb(140, 123, 169));
fillColors1.add(Color.rgb(213, 192, 202));
fillColors1.add(Color.rgb(242, 231, 196));
fillColors1.add(Color.rgb(242, 234, 121));
fillColors1.add(Color.rgb(189, 204, 128));
series1.setFillColors(fillColors1);

ArrayList<Integer> strokeColors1 = new ArrayList<Integer>();
strokeColors1.add(Color.rgb(97, 85, 117));
strokeColors1.add(Color.rgb(133, 120, 126));
strokeColors1.add(Color.rgb(196, 187, 159));
strokeColors1.add(Color.rgb(194, 187, 97));
strokeColors1.add(Color.rgb(142, 153, 96));
series1.setStrokeColors(strokeColors1);

5. Customize the grid - make it gray and dash:

Java [image] Copy Code

ArrayList<Integer>gridStrokeColors = new ArrayList<Integer>();
gridStrokeColors.add(Color.rgb(192, 192, 192));

chart.setGridStrokeColors(gridStrokeColors);

DashPathEffect effect = new DashPathEffect(new float[] {10,5}, 0);
chart.setGridStrokeEffect(effect);

6. Run the application - here is the chart:


Programming Interface Overview

Programming Interface Overview


Chart Series

Chart Series

Charts with Axes

Charts with axes can have unlimited number of BarSeries and LineSeries. If you use both types of series you'll get a combination chart. You add a ChartSeries by initializing it and adding it to the Series list of the chart:

Java [image] Copy Code

BarSeries series1 = new BarSeries();
....
series1.setBarType(BarType.VerticalOverlay);
chart.addSeries(series1);

Use BarSeries.setBarType, LineSeries.setLineType and LineSeries.setScatterType to specify the type of the series. You can create line series with scatters, area series with scatters or scatter only series.

Pie Charts

Pie charts use the PieSeries. There is no limit to the number of pie series you can add. Use PieChart.setDoughnutFraction to specify the fraction of a doughnut chart - the smallest the fraction, the thinner the doughnut shall be.


Data

Data

The data for each chart is set as a property of each series. Series for an AxesChart expose setXData() and setYData() methods. Set the data as an array of foat values using the respective method.

Java [image] Copy Code

//create an array for the data
ArrayList<Float> yData1 = new ArrayList<Float>();
yData1.add(234f);
yData1.add(315f);
yData1.add(265f);
yData1.add(302f);
yData1.add(276f);
axesSeries1.setYData(yData1);

In pie charts, PieSeries has the setData() method. You use it the same way as in the code snippet above.


Grid

Grid

Charts with axes can have crossed, horizontal or vertical grid. Use setGridType to specify what type of grid you want. You set the grid pens with setGridStrokeColors. If you specify more than one color, the control cycles through them. You can fill the grid stripes with setGridFillColors.

Java [image] Copy Code

ArrayList<Integer> gridStrokes = new ArrayList<Integer>();
gridStrokes.add(Color.rgb(207, 207, 207));
chart.setGridStrokeColors(gridStrokes);

ArrayList<Integer> gridFills = new ArrayList<Integer>();
gridFills.add(Color.rgb(237, 237, 237));
gridFills.add(Color.WHITE);
chart.setGridFillColors(gridFills);

You can also set the grid type in XML:

XML [image] Copy Code

<com.mindfusion.charting.AxesChart
android:id="@+id/chart"
android:layout_width="fill_parent"
android:layout_height="wrap_content"
chart:gridType="horizontal"
...
tools:context=".MainActivity" />


Labels

Labels

Each chart can have a variety of labels according to its type.

The axes

You can draw custom labels or the numeric scale. The type of the labels depends on AxisSettings.LabelType. If the type is AxisLabelType.Custom you use setLabels() to specify the labels.

Java [image] Copy Code

ArrayList<String> labels = new ArrayList<String>();
labels.add("2009");
labels.add("2010");
labels.add("2011");
labels.add("2012");
labels.add("2013");

chart.xAxisSettings.setLabels(labels);

Each axis can have a title - use AxisSettings.setTitle() to specify it.

Line charts

Line charts can show custom labes at data points or scatters. Set them with LineSeries.setLabels().

Bar charts

Bar charts can have labels inside and at the top of each bar. Set them with BarSeries.setInnerLabels() and BarSeries.setTopLabels().

Pie charts

Each pie series can have labels inside and outside pie pieces. When you have multiple series it might be better to set outer labels only for the last series, outer labels for the other series might not visualize correctly if you don't set enough space among them. Use PieSeries.setInnerLabels() and PieSeries.setOuterLabels() to specify the labels. Space among pie series depends on the DoughnutFraction property.


Reference

Reference


com.mindfusion.charting Namespace

com.mindfusion.charting Namespace
Classes

Classes

Class | Description
AxesChart | Base class for charts which use the Cartesian coordinate system.
AxesSeries | Base class for all ChartSeries that use the Cartesian coordinate system.
AxisLabelType | Specifies what type of labels can be drawn at the axes in an AxesChart.
AxisSettings | Provides settings that define the appearance of an axes in an AxesChart.
Bar | Represents a bar in a bar chart.
BarSeries | A class that represents a single series in an AxesChart.
BarType | Specifies different ways the bars in a BarChart could be arranged.
Chart | Base class for all chart types.
ChartElement | Base class for all chart elements - pie pieces, bars, lines.
ChartSeries | Base class for all series in the Chart.
GridType | Defines the different types of grid a Chart can have.
LabelType | Identifies possible label types a Chart can have.
LineSeries | Represents a line series in an AxesChart.
LineType | Identifies possible types of a LineSeries.
PieChart | Represents a pie chart.
PiePiece | Represents a piece in a PieChart.
PieSeries | Represents a series in a PieChart.
PieType | Identifies possible types a PieSeries can have.
ScatterType | Identifies possible types scatters in a LineSeries can have.


com.mindfusion.charting.AxesChart Class

AxesChart Class
See Also
[image]

Base class for charts which use the Cartesian coordinate system.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class AxesChart extends Chart

Inheritance Hierarchy

java.lang.Object
android.view.View
com.mindfusion.charting.Chart
com.mindfusion.charting.AxesChart

See Also

AxesChart Members
com.mindfusion.charting Namespace


com.mindfusion.charting.AxesChart Members

AxesChart Members
Constructors Fields Methods
[image]

Base class for charts which use the Cartesian coordinate system.

The following tables list the members exposed by the AxesChart type.

Public Constructors

Name | Description
AxesChart | Overloaded.

Public Fields

Name | Description
xAxisSettings | Defines the AxisSettings for the X-axis
yAxisSettings | Defines the AxisSettings for the Y-axis

Public Methods

Name | Description
getGridFillColors | Gets the colors for the grid stripes.
getGridStrokeColors | Gets the colors of the grid strokes.
getGridStrokeEffect | Gets the PathEffect applied on GridStrokeColors.
getGridType | Returns a value that specifies the type of the grid that is drawn.
getOutline | Gets a value that specifies if outlining is drawn for the plot area.
getXAxisSettings | Gets the AxisSettings for the X-axis.
getYAxisSettings | Gets the AxisSettings for the Y-axis.
setGridFillColors | Sets the colors for the grid stripes.
setGridStrokeColors | Sets the colors for the grid strokes.
setGridStrokeEffect | Sets a PathEffect applied on GridStrokeColors.
setGridType | Set a value that specifies the type of grid that is drawn.
setOutline | Sets a value that specifies whether outlining is drawn around the plot area of the chart.
setXAxisSettings | Sets the AxisSettings for the X-axis.
setYAxisSettings | Sets the AxisSettings for the Y-axis.

Inherited Public Methods

Name | Description
addSeries | Adds a ChartSeries to the Chart. (Inherited from Chart.)
getBackgroundColor | Gets the color of the chart background. (Inherited from Chart.)
getBottomChartPadding | Gets the padding at the bottom side of the chart. (Inherited from Chart.)
getChartPadding | Gets the padding at all four sides of the chart. (Inherited from Chart.)
getLabelHeight | Gets the height of the font used for the labels at the Chart. (Inherited from Chart.)
getLeftChartPadding | Gets the padding at the left side of the chart. (Inherited from Chart.)
getRightChartPadding | Gets the padding at the right side of the chart. (Inherited from Chart.)
getTitle | Gets the title of the chart. (Inherited from Chart.)
getTitleColor | Gets the color of the Chart title. (Inherited from Chart.)
getTitleHeight | Gets the height of the font used for the Chart title. (Inherited from Chart.)
getTitleOffset | Gets the offset of the chart title. (Inherited from Chart.)
getTopChartPadding | Gets the padding at the top side of the chart. (Inherited from Chart.)
setBackgroundColor | Sets the color of the chart background. (Inherited from Chart.)
setBottomChartPadding | Sets the padding at the bottom side of the chart. (Inherited from Chart.)
setChartPadding | Sets the padding at all four chart sides. (Inherited from Chart.)
setLabelHeight | Sets the height of the font used for the labels at the Chart. (Inherited from Chart.)
setLeftChartPadding | Sets the padding at the left side of the chart. (Inherited from Chart.)
setRightChartPadding | Sets the padding at the right side of the chart. (Inherited from Chart.)
setTitle | Sets the title of the chart. (Inherited from Chart.)
setTitleColor | Sets the color of the chart title. (Inherited from Chart.)
setTitleHeight | Sets the height of the font used for the Chart title. (Inherited from Chart.)
setTitleOffset | Sets the offset of the chart title to the plot area. (Inherited from Chart.)
setTopChartPadding | Sets the padding at the top of the chart. (Inherited from Chart.)

See Also

AxesChart Class


com.mindfusion.charting.AxesChart Fields

AxesChart Fields
[image]

Public Fields

Name | Description
xAxisSettings | Defines the AxisSettings for the X-axis
yAxisSettings | Defines the AxisSettings for the Y-axis

See Also

AxesChart Class


com.mindfusion.charting.AxesChart.xAxisSettings Field

AxesChart.xAxisSettings Field
[image]

Defines the AxisSettings for the X-axis

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public AxisSettings xAxisSettings

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.yAxisSettings Field

AxesChart.yAxisSettings Field
[image]

Defines the AxisSettings for the Y-axis

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public AxisSettings yAxisSettings

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart Constructor

AxesChart Constructor
[image]

Overload List

Name | Description
AxesChart (Context) | Creates a new AxesChart that uses the specified Context.
AxesChart (Context, AttributeSet) | Creates a new AxesChart that uses the specified Context and attributes.

See Also

AxesChart Class


com.mindfusion.charting.AxesChart Constructor (Context)

AxesChart Constructor (Context)
See Also
[image]

Creates a new AxesChart that uses the specified Context.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public AxesChart (
Context context
)

Parameters

context

The context used by the chart.

See Also

AxesChart Constructor Overload List
AxesChart Class


com.mindfusion.charting.AxesChart Constructor (Context, AttributeSet)

AxesChart Constructor (Context, AttributeSet)
See Also
[image]

Creates a new AxesChart that uses the specified Context and attributes.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public AxesChart (
Context context,
AttributeSet attrs
)

Parameters

context

The context used by the chart.

attrs

The attributes used by the chart.

See Also

AxesChart Constructor Overload List
AxesChart Class


com.mindfusion.charting.AxesChart Methods

AxesChart Methods
[image]

Public Methods

Name | Description
getGridFillColors | Gets the colors for the grid stripes.
getGridStrokeColors | Gets the colors of the grid strokes.
getGridStrokeEffect | Gets the PathEffect applied on GridStrokeColors.
getGridType | Returns a value that specifies the type of the grid that is drawn.
getOutline | Gets a value that specifies if outlining is drawn for the plot area.
getXAxisSettings | Gets the AxisSettings for the X-axis.
getYAxisSettings | Gets the AxisSettings for the Y-axis.
setGridFillColors | Sets the colors for the grid stripes.
setGridStrokeColors | Sets the colors for the grid strokes.
setGridStrokeEffect | Sets a PathEffect applied on GridStrokeColors.
setGridType | Set a value that specifies the type of grid that is drawn.
setOutline | Sets a value that specifies whether outlining is drawn around the plot area of the chart.
setXAxisSettings | Sets the AxisSettings for the X-axis.
setYAxisSettings | Sets the AxisSettings for the Y-axis.

Inherited Public Methods

Name | Description
addSeries | Adds a ChartSeries to the Chart. (Inherited from Chart.)
getBackgroundColor | Gets the color of the chart background. (Inherited from Chart.)
getBottomChartPadding | Gets the padding at the bottom side of the chart. (Inherited from Chart.)
getChartPadding | Gets the padding at all four sides of the chart. (Inherited from Chart.)
getLabelHeight | Gets the height of the font used for the labels at the Chart. (Inherited from Chart.)
getLeftChartPadding | Gets the padding at the left side of the chart. (Inherited from Chart.)
getRightChartPadding | Gets the padding at the right side of the chart. (Inherited from Chart.)
getTitle | Gets the title of the chart. (Inherited from Chart.)
getTitleColor | Gets the color of the Chart title. (Inherited from Chart.)
getTitleHeight | Gets the height of the font used for the Chart title. (Inherited from Chart.)
getTitleOffset | Gets the offset of the chart title. (Inherited from Chart.)
getTopChartPadding | Gets the padding at the top side of the chart. (Inherited from Chart.)
setBackgroundColor | Sets the color of the chart background. (Inherited from Chart.)
setBottomChartPadding | Sets the padding at the bottom side of the chart. (Inherited from Chart.)
setChartPadding | Sets the padding at all four chart sides. (Inherited from Chart.)
setLabelHeight | Sets the height of the font used for the labels at the Chart. (Inherited from Chart.)
setLeftChartPadding | Sets the padding at the left side of the chart. (Inherited from Chart.)
setRightChartPadding | Sets the padding at the right side of the chart. (Inherited from Chart.)
setTitle | Sets the title of the chart. (Inherited from Chart.)
setTitleColor | Sets the color of the chart title. (Inherited from Chart.)
setTitleHeight | Sets the height of the font used for the Chart title. (Inherited from Chart.)
setTitleOffset | Sets the offset of the chart title to the plot area. (Inherited from Chart.)
setTopChartPadding | Sets the padding at the top of the chart. (Inherited from Chart.)

See Also

AxesChart Class


com.mindfusion.charting.AxesChart.getGridFillColors Method

AxesChart.getGridFillColors Method
[image]

Gets the colors for the grid stripes.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<Integer> getGridFillColors ()

Return Value

ArrayList with the grid colors.

Remarks

Use setGridType to specify the type of the grid.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.getGridStrokeColors Method

AxesChart.getGridStrokeColors Method
[image]

Gets the colors of the grid strokes.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<Integer> getGridStrokeColors ()

Return Value

ArrayList with the colors.

Remarks

Use setGridType to specify the type of the grid.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.getGridStrokeEffect Method

AxesChart.getGridStrokeEffect Method
[image]

Gets the PathEffect applied on GridStrokeColors.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public PathEffect getGridStrokeEffect ()

Return Value

The PathEffect applied on GridStrokeColors.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.getGridType Method

AxesChart.getGridType Method
[image]

Returns a value that specifies the type of the grid that is drawn.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public GridType getGridType ()

Return Value

One of the GridType enumeration values.

Remarks

Use GridStrokeColors and GridFillColors to customize the appearance of the grid.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.getOutline Method

AxesChart.getOutline Method
[image]

Gets a value that specifies if outlining is drawn for the plot area.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public boolean getOutline ()

Return Value

true if outlining is drawn; otherwise false.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.getXAxisSettings Method

AxesChart.getXAxisSettings Method
[image]

Gets the AxisSettings for the X-axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public AxisSettings getXAxisSettings ()

Return Value

AxisSettings object that defines the appearance of the X-axis.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.getYAxisSettings Method

AxesChart.getYAxisSettings Method
[image]

Gets the AxisSettings for the Y-axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public AxisSettings getYAxisSettings ()

Return Value

AxisSettings object that defines the appearance of the Y-axis.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.setGridFillColors Method

AxesChart.setGridFillColors Method
[image]

Sets the colors for the grid stripes.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setGridFillColors (
ArrayList<Integer> gridFillColors
)

Parameters

gridFillColors

ArrayList with the colors.

Remarks

Use setGridType to specify the type of the grid.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.setGridStrokeColors Method

AxesChart.setGridStrokeColors Method
[image]

Sets the colors for the grid strokes.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setGridStrokeColors (
ArrayList<Integer> gridStrokeColors
)

Parameters

gridStrokeColors

ArrayList with the colors.

Remarks

Use setGridType to specify the type of the grid.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.setGridStrokeEffect Method

AxesChart.setGridStrokeEffect Method
[image]

Sets a PathEffect applied on GridStrokeColors.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setGridStrokeEffect (
PathEffect effect
)

Parameters

effect

The PathEffect applied on GridStrokeColors.

Remarks

Use setGridType to specify the type of the grid.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.setGridType Method

AxesChart.setGridType Method
[image]

Set a value that specifies the type of grid that is drawn.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setGridType (
GridType gridType
)

Parameters

gridType

One of the GridType enumeration values.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.setOutline Method

AxesChart.setOutline Method
[image]

Sets a value that specifies whether outlining is drawn around the plot area of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setOutline (
boolean outline
)

Parameters

outline

true if outline is drawn; otherwise false.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.setXAxisSettings Method

AxesChart.setXAxisSettings Method
[image]

Sets the AxisSettings for the X-axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setXAxisSettings (
AxisSettings axisSettings
)

Parameters

axisSettings

AxisSettings object that defines the appearance of the X-axis.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesChart.setYAxisSettings Method

AxesChart.setYAxisSettings Method
[image]

Sets the AxisSettings for the Y-axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setYAxisSettings (
AxisSettings axisSettings
)

Parameters

axisSettings

AxisSettings object that defines the appearance of the Y-axis.

See Also

AxesChart Members
AxesChart Class


com.mindfusion.charting.AxesSeries Class

AxesSeries Class
[image]

Base class for all ChartSeries that use the Cartesian coordinate system.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class AxesSeries extends ChartSeries

Inheritance Hierarchy

java.lang.Object
com.mindfusion.charting.ChartSeries
com.mindfusion.charting.AxesSeries
com.mindfusion.charting.BarSeries
com.mindfusion.charting.LineSeries

See Also

AxesSeries Members


com.mindfusion.charting.AxesSeries Members

AxesSeries Members
Constructors Methods
[image]

Base class for all ChartSeries that use the Cartesian coordinate system.

The following tables list the members exposed by the AxesSeries type.

Public Constructors

Name | Description
AxesSeries | Creates a new instance of the AxesSeries class.

Public Methods

Name | Description
getXData | Gets the X-data for this AxesSeries.
getYData | Gets the Y-data for this AxesSeries.
setXData | Sets X-data for this AxesSeries.
setYData | Sets the Y-data for this AxesSeries.

Inherited Public Methods

Name | Description
getFillColors | Gets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getIndex | Gets the index of the current ChartSeries in the series collections. (Inherited from ChartSeries.)
getStrokeColors | Gets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getStrokeEffect | Gets the PathEffect used with the strokes for this ChartSeries. (Inherited from ChartSeries.)
getStrokeWidth | Gets the width of the stroke colors for this ChartSeries. (Inherited from ChartSeries.)
setFillColors | Sets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeColors | Sets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeEffect | Applies the specified PathEffect on the strokes for this ChartSeries. (Inherited from ChartSeries.)
setStrokeWidth | Sets the width of the strokes used when drawing this ChartSeries. (Inherited from ChartSeries.)

See Also

AxesSeries Class


com.mindfusion.charting.AxesSeries Constructor

AxesSeries Constructor
[image]

Creates a new instance of the AxesSeries class.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public AxesSeries ()

See Also

AxesSeries Class


com.mindfusion.charting.AxesSeries Methods

AxesSeries Methods
[image]

Public Methods

Name | Description
getXData | Gets the X-data for this AxesSeries.
getYData | Gets the Y-data for this AxesSeries.
setXData | Sets X-data for this AxesSeries.
setYData | Sets the Y-data for this AxesSeries.

Inherited Public Methods

Name | Description
getFillColors | Gets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getIndex | Gets the index of the current ChartSeries in the series collections. (Inherited from ChartSeries.)
getStrokeColors | Gets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getStrokeEffect | Gets the PathEffect used with the strokes for this ChartSeries. (Inherited from ChartSeries.)
getStrokeWidth | Gets the width of the stroke colors for this ChartSeries. (Inherited from ChartSeries.)
setFillColors | Sets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeColors | Sets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeEffect | Applies the specified PathEffect on the strokes for this ChartSeries. (Inherited from ChartSeries.)
setStrokeWidth | Sets the width of the strokes used when drawing this ChartSeries. (Inherited from ChartSeries.)

See Also

AxesSeries Class


com.mindfusion.charting.AxesSeries.getXData Method

AxesSeries.getXData Method
[image]

Gets the X-data for this AxesSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<Float> getXData ()

Return Value

ArrayList with float numbers.

See Also

AxesSeries Members
AxesSeries Class


com.mindfusion.charting.AxesSeries.getYData Method

AxesSeries.getYData Method
[image]

Gets the Y-data for this AxesSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<Float> getYData ()

Return Value

ArrayList with float numbers.

See Also

AxesSeries Members
AxesSeries Class


com.mindfusion.charting.AxesSeries.setXData Method

AxesSeries.setXData Method
[image]

Sets X-data for this AxesSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setXData (
ArrayList<Float> xData
)

Parameters

xData

ArrayList with float numbers.

See Also

AxesSeries Members
AxesSeries Class


com.mindfusion.charting.AxesSeries.setYData Method

AxesSeries.setYData Method
[image]

Sets the Y-data for this AxesSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setYData (
ArrayList<Float> yData
)

Parameters

yData

ArrayList with float numbers.

See Also

AxesSeries Members
AxesSeries Class


com.mindfusion.charting.AxisLabelType Class

AxisLabelType Class
Remarks See Also
[image]

Specifies what type of labels can be drawn at the axes in an AxesChart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public enum AxisLabelType

Remarks

Member | Description
Custom | Labels are strings set by the user.
None | No labels are drawn.
Scale | Labels show the axis scale.

Inheritance Hierarchy

java.lang.Enum(E)

See Also

AxisLabelType Members


com.mindfusion.charting.AxisLabelType Members

AxisLabelType Members
[image]

Specifies what type of labels can be drawn at the axes in an AxesChart.

The following tables list the members exposed by the AxisLabelType type.

See Also

AxisLabelType Class


com.mindfusion.charting.AxisSettings Class

AxisSettings Class
[image]

Provides settings that define the appearance of an axes in an AxesChart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class AxisSettings

Inheritance Hierarchy

java.lang.Object
com.mindfusion.charting.AxisSettings

See Also

AxisSettings Members


com.mindfusion.charting.AxisSettings Members

AxisSettings Members
Constructors Methods
[image]

Provides settings that define the appearance of an axes in an AxesChart.

The following tables list the members exposed by the AxisSettings type.

Public Constructors

Name | Description
AxisSettings | Creates a new instance of the AxisSettings class.

Public Methods

Name | Description
getInterval | Gets the interval at this axis.
getLabelOffset | Gets the offset of the labels from the axis.
getLabels | Gets the custom labels drawn at this axis instead of the axis intervals.
getLabelType | Gets the type of the labels drawn at this axis.
getMax | Gets the biggest number at this axis.
getMin | Gets the smallest number at this axis.
getNumberFormat | Gets the format of numeric labels.
getOrigin | Gets the origin of this axis. This is the number where this axis is crossed with the other axis.
getTitle | Gets the text of the title label for this axis.
getTitleColor | Gets the color for the axis title.
getTitleOffset | Gets the offset of the title label from the axis or the axis labels, if drawn.
setInterval | Sets the interval of this axis.
setLabelOffset | Sets the offset of the labels from the axis.
setLabels | Sets custom labels for this axis. Custom labels are drawn instead of the axis intervals.
setLabelType | Sets the type of the labels drawn at the axis.
setMax | Sets the biggest number at the axis.
setMin | Sets the smallest number at the axis.
setNumberFormat | Sets the format of numeric labels.
setOrigin | Sets the origin of the axis. The origin is where the axis is crossed by the other axis.
setTitle | Sets the text of the title label for this axis.
setTitleColor | Sets the color for the axis title.
setTitleOffset | Sets the offset of the title label from the axis or from the axis labels, if any are drawn.

See Also

AxisSettings Class


com.mindfusion.charting.AxisSettings Constructor

AxisSettings Constructor
[image]

Creates a new instance of the AxisSettings class.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public AxisSettings ()

See Also

AxisSettings Class


com.mindfusion.charting.AxisSettings Methods

AxisSettings Methods
[image]

Public Methods

Name | Description
getInterval | Gets the interval at this axis.
getLabelOffset | Gets the offset of the labels from the axis.
getLabels | Gets the custom labels drawn at this axis instead of the axis intervals.
getLabelType | Gets the type of the labels drawn at this axis.
getMax | Gets the biggest number at this axis.
getMin | Gets the smallest number at this axis.
getNumberFormat | Gets the format of numeric labels.
getOrigin | Gets the origin of this axis. This is the number where this axis is crossed with the other axis.
getTitle | Gets the text of the title label for this axis.
getTitleColor | Gets the color for the axis title.
getTitleOffset | Gets the offset of the title label from the axis or the axis labels, if drawn.
setInterval | Sets the interval of this axis.
setLabelOffset | Sets the offset of the labels from the axis.
setLabels | Sets custom labels for this axis. Custom labels are drawn instead of the axis intervals.
setLabelType | Sets the type of the labels drawn at the axis.
setMax | Sets the biggest number at the axis.
setMin | Sets the smallest number at the axis.
setNumberFormat | Sets the format of numeric labels.
setOrigin | Sets the origin of the axis. The origin is where the axis is crossed by the other axis.
setTitle | Sets the text of the title label for this axis.
setTitleColor | Sets the color for the axis title.
setTitleOffset | Sets the offset of the title label from the axis or from the axis labels, if any are drawn.

See Also

AxisSettings Class


com.mindfusion.charting.AxisSettings.getInterval Method

AxisSettings.getInterval Method
[image]

Gets the interval at this axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getInterval ()

Return Value

The value between two adjacent numbers at the axis.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.getLabelOffset Method

AxisSettings.getLabelOffset Method
[image]

Gets the offset of the labels from the axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getLabelOffset ()

Return Value

The offset of the axis labels from the axis, in pixels.

Remarks

Use setLabelType to specify what labels are drawn at the axis.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.getLabels Method

AxisSettings.getLabels Method
[image]

Gets the custom labels drawn at this axis instead of the axis intervals.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<String> getLabels ()

Return Value

An ArrayList with the labels.

Remarks

The label type must be set to AxisLabelType.Custom.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.getLabelType Method

AxisSettings.getLabelType Method
[image]

Gets the type of the labels drawn at this axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public AxisLabelType getLabelType ()

Return Value

One of the AxisLabelType enumeration values.

Remarks

Use setLabels to specify custom labels.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.getMax Method

AxisSettings.getMax Method
[image]

Gets the biggest number at this axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getMax ()

Return Value

The biggest number at this axis.

Remarks

Use getMin to get the smallest number at the axis.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.getMin Method

AxisSettings.getMin Method
[image]

Gets the smallest number at this axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getMin ()

Return Value

The smallest number at this axis.

Remarks

Use getMax to get the biggest number at the axis.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.getNumberFormat Method

AxisSettings.getNumberFormat Method
[image]

Gets the format of numeric labels.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public NumberFormat getNumberFormat ()

Return Value

The format of numeric labels.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.getOrigin Method

AxisSettings.getOrigin Method
[image]

Gets the origin of this axis. This is the number where this axis is crossed with the other axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getOrigin ()

Return Value

The origin of the axis. Default value is 0 (zero).

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.getTitle Method

AxisSettings.getTitle Method
[image]

Gets the text of the title label for this axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public String getTitle ()

Return Value

A string that represents the title label. Default value is an empty string ("").

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.getTitleColor Method

AxisSettings.getTitleColor Method
[image]

Gets the color for the axis title.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public int getTitleColor ()

Return Value

The color for the axis title.

Remarks

Use setTitle to specify the title.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.getTitleOffset Method

AxisSettings.getTitleOffset Method
[image]

Gets the offset of the title label from the axis or the axis labels, if drawn.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getTitleOffset ()

Return Value

The offset of the title label from the axis or the axis labels, in pixels.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setInterval Method

AxisSettings.setInterval Method
[image]

Sets the interval of this axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setInterval (
float interval
)

Parameters

interval

A float value that specifies the interval.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setLabelOffset Method

AxisSettings.setLabelOffset Method
[image]

Sets the offset of the labels from the axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setLabelOffset (
float labelOffset
)

Parameters

labelOffset

The offset of the axis labels from the axis, in pixels.

Remarks

Use setLabelType to specify the type of labels drawn at the axis.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setLabels Method

AxisSettings.setLabels Method
[image]

Sets custom labels for this axis. Custom labels are drawn instead of the axis intervals.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setLabels (
ArrayList<String> labels
)

Parameters

labels

ArrayList with string values.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setLabelType Method

AxisSettings.setLabelType Method
[image]

Sets the type of the labels drawn at the axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setLabelType (
AxisLabelType labelType
)

Parameters

labelType

One of the AxisLabelType enumeration values.

Remarks

Use setLabels to specify custom labels.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setMax Method

AxisSettings.setMax Method
[image]

Sets the biggest number at the axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setMax (
float max
)

Parameters

max

The biggest number at the axis.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setMin Method

AxisSettings.setMin Method
[image]

Sets the smallest number at the axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setMin (
float min
)

Parameters

min

The smallest number at the axis.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setNumberFormat Method

AxisSettings.setNumberFormat Method
[image]

Sets the format of numeric labels.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setNumberFormat (
NumberFormat numberFormat
)

Parameters

numberFormat

Sets the format of numeric labels.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setOrigin Method

AxisSettings.setOrigin Method
[image]

Sets the origin of the axis. The origin is where the axis is crossed by the other axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setOrigin (
float origin
)

Parameters

origin

The number at which this axis is crossed by the other axis.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setTitle Method

AxisSettings.setTitle Method
[image]

Sets the text of the title label for this axis.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setTitle (
String title
)

Parameters

title

The string that represents the title label.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setTitleColor Method

AxisSettings.setTitleColor Method
[image]

Sets the color for the axis title.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setTitleColor (
int tColor
)

Parameters

tColor

The color for the axis title.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.AxisSettings.setTitleOffset Method

AxisSettings.setTitleOffset Method
[image]

Sets the offset of the title label from the axis or from the axis labels, if any are drawn.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setTitleOffset (
float titleOffset
)

Parameters

titleOffset

The offset of the title label from the axis or the axis labels, in pixels.

See Also

AxisSettings Members
AxisSettings Class


com.mindfusion.charting.Bar Class

Bar Class
[image]

Represents a bar in a bar chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class Bar extends ChartElement

Inheritance Hierarchy

java.lang.Object
com.mindfusion.charting.ChartElement
com.mindfusion.charting.Bar

See Also

Bar Members


com.mindfusion.charting.Bar Members

Bar Members
Constructors Methods
[image]

Represents a bar in a bar chart.

The following tables list the members exposed by the Bar type.

Public Constructors

Name | Description
Bar | Initializes a new instance of the Bar class.

Public Methods

Name | Description
getInnerLabel | Gets the label drawn inside this Bar.
getTopLabel | Gets the labels drawn at the top of this Bar.
getValue | Gets the value of this Bar.

Inherited Public Methods

Name | Description
getDataIndex | Gets the index of this ChartElement in the data array for this ChartSeries. (Inherited from ChartElement.)
getFillColor | Gets the color used for filling this ChartElement. (Inherited from ChartElement.)
getSeriesIndex | Gets the index of the ChartSeries this element belongs to. (Inherited from ChartElement.)
getStrokeColor | Gets the color used for stroking this ChartElement. (Inherited from ChartElement.)

See Also

Bar Class


com.mindfusion.charting.Bar Constructor

Bar Constructor
[image]

Initializes a new instance of the Bar class.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public Bar ()

See Also

Bar Class


com.mindfusion.charting.Bar Methods

Bar Methods
[image]

Public Methods

Name | Description
getInnerLabel | Gets the label drawn inside this Bar.
getTopLabel | Gets the labels drawn at the top of this Bar.
getValue | Gets the value of this Bar.

Inherited Public Methods

Name | Description
getDataIndex | Gets the index of this ChartElement in the data array for this ChartSeries. (Inherited from ChartElement.)
getFillColor | Gets the color used for filling this ChartElement. (Inherited from ChartElement.)
getSeriesIndex | Gets the index of the ChartSeries this element belongs to. (Inherited from ChartElement.)
getStrokeColor | Gets the color used for stroking this ChartElement. (Inherited from ChartElement.)

See Also

Bar Class


com.mindfusion.charting.Bar.getInnerLabel Method

Bar.getInnerLabel Method
[image]

Gets the label drawn inside this Bar.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public String getInnerLabel ()

Return Value

A string that represents the label drawn inside this Bar.

Remarks

Use BarSeries.setInnerLabels to specify the labels.

See Also

Bar Members
Bar Class


com.mindfusion.charting.Bar.getTopLabel Method

Bar.getTopLabel Method
[image]

Gets the labels drawn at the top of this Bar.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public String getTopLabel ()

Return Value

A string that represents the label drawn at the top of the Bar.

Remarks

Use BarSeries.setTopLabels to specify the labels.

See Also

Bar Members
Bar Class


com.mindfusion.charting.Bar.getValue Method

Bar.getValue Method
[image]

Gets the value of this Bar.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getValue ()

Return Value

A float number represented by this Bar.

See Also

Bar Members
Bar Class


com.mindfusion.charting.BarSeries Class

BarSeries Class
[image]

A class that represents a single series in an AxesChart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class BarSeries extends AxesSeries

Inheritance Hierarchy

java.lang.Object
com.mindfusion.charting.ChartSeries
com.mindfusion.charting.AxesSeries
com.mindfusion.charting.BarSeries

See Also

BarSeries Members


com.mindfusion.charting.BarSeries Members

BarSeries Members
Constructors Methods
[image]

A class that represents a single series in an AxesChart.

The following tables list the members exposed by the BarSeries type.

Public Constructors

Name | Description
BarSeries | Initializes a new instance of the BarSeries class.

Public Methods

Name | Description
getBarType | Gets the type of the bars in this BarSeries.
getBarWidth | Gets the width of the bar as a percent of the space allocated to it.
getInnerLabels | Gets the inner labels for the bars in this BarSeries.
getSeriesWidth | Gets the width of the BarSeries as a percent of the space allocated to it.
getTopLabelOffset | Gets the offset of the top labels to the edge of the Bar.
getTopLabels | Gets the top labels for the bars in this BarSeries.
setBarType | Sets the type of the bars in this BarSeries.
setBarWidth | Sets the width of the bar as a percent of the space allocated to it.
setInnerLabels | Sets the inner labels for the bars in this BarSeries.
setSeriesWidth | Sets the width of the BarSeries as a percent of the space allocated to it.
setTopLabelOffset | Sets the offset of the top labels to the edge of the Bar.
setTopLabels | Sets the top labels for the bars in this BarSeries.

Inherited Public Methods

Name | Description
getFillColors | Gets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getIndex | Gets the index of the current ChartSeries in the series collections. (Inherited from ChartSeries.)
getStrokeColors | Gets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getStrokeEffect | Gets the PathEffect used with the strokes for this ChartSeries. (Inherited from ChartSeries.)
getStrokeWidth | Gets the width of the stroke colors for this ChartSeries. (Inherited from ChartSeries.)
getXData | Gets the X-data for this AxesSeries. (Inherited from AxesSeries.)
getYData | Gets the Y-data for this AxesSeries. (Inherited from AxesSeries.)
setFillColors | Sets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeColors | Sets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeEffect | Applies the specified PathEffect on the strokes for this ChartSeries. (Inherited from ChartSeries.)
setStrokeWidth | Sets the width of the strokes used when drawing this ChartSeries. (Inherited from ChartSeries.)
setXData | Sets X-data for this AxesSeries. (Inherited from AxesSeries.)
setYData | Sets the Y-data for this AxesSeries. (Inherited from AxesSeries.)

See Also

BarSeries Class


com.mindfusion.charting.BarSeries Constructor

BarSeries Constructor
[image]

Initializes a new instance of the BarSeries class.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public BarSeries ()

See Also

BarSeries Class


com.mindfusion.charting.BarSeries Methods

BarSeries Methods
[image]

Public Methods

Name | Description
getBarType | Gets the type of the bars in this BarSeries.
getBarWidth | Gets the width of the bar as a percent of the space allocated to it.
getInnerLabels | Gets the inner labels for the bars in this BarSeries.
getSeriesWidth | Gets the width of the BarSeries as a percent of the space allocated to it.
getTopLabelOffset | Gets the offset of the top labels to the edge of the Bar.
getTopLabels | Gets the top labels for the bars in this BarSeries.
setBarType | Sets the type of the bars in this BarSeries.
setBarWidth | Sets the width of the bar as a percent of the space allocated to it.
setInnerLabels | Sets the inner labels for the bars in this BarSeries.
setSeriesWidth | Sets the width of the BarSeries as a percent of the space allocated to it.
setTopLabelOffset | Sets the offset of the top labels to the edge of the Bar.
setTopLabels | Sets the top labels for the bars in this BarSeries.

Inherited Public Methods

Name | Description
getFillColors | Gets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getIndex | Gets the index of the current ChartSeries in the series collections. (Inherited from ChartSeries.)
getStrokeColors | Gets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getStrokeEffect | Gets the PathEffect used with the strokes for this ChartSeries. (Inherited from ChartSeries.)
getStrokeWidth | Gets the width of the stroke colors for this ChartSeries. (Inherited from ChartSeries.)
getXData | Gets the X-data for this AxesSeries. (Inherited from AxesSeries.)
getYData | Gets the Y-data for this AxesSeries. (Inherited from AxesSeries.)
setFillColors | Sets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeColors | Sets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeEffect | Applies the specified PathEffect on the strokes for this ChartSeries. (Inherited from ChartSeries.)
setStrokeWidth | Sets the width of the strokes used when drawing this ChartSeries. (Inherited from ChartSeries.)
setXData | Sets X-data for this AxesSeries. (Inherited from AxesSeries.)
setYData | Sets the Y-data for this AxesSeries. (Inherited from AxesSeries.)

See Also

BarSeries Class


com.mindfusion.charting.BarSeries.getBarType Method

BarSeries.getBarType Method
[image]

Gets the type of the bars in this BarSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public BarType getBarType ()

Return Value

One of the BarType enumeration values.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.getBarWidth Method

BarSeries.getBarWidth Method
[image]

Gets the width of the bar as a percent of the space allocated to it.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getBarWidth ()

Return Value

The width of the bar as a percent of the space allocated to it. Acceptable values range from 0 to 100.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.getInnerLabels Method

BarSeries.getInnerLabels Method
[image]

Gets the inner labels for the bars in this BarSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<String> getInnerLabels ()

Return Value

ArrayList with strings that represent the inner labels for the bars.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.getSeriesWidth Method

BarSeries.getSeriesWidth Method
[image]

Gets the width of the BarSeries as a percent of the space allocated to it.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getSeriesWidth ()

Return Value

The width of the BarSeries as a percent of the space allocated to it. Acceptable values range from 0 to 100.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.getTopLabelOffset Method

BarSeries.getTopLabelOffset Method
[image]

Gets the offset of the top labels to the edge of the Bar.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getTopLabelOffset ()

Return Value

The offset of the top labels to the edge of the Bar, in pixels.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.getTopLabels Method

BarSeries.getTopLabels Method
[image]

Gets the top labels for the bars in this BarSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<String> getTopLabels ()

Return Value

ArrayList with strings that represent the top labels for the bars.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.setBarType Method

BarSeries.setBarType Method
[image]

Sets the type of the bars in this BarSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setBarType (
BarType barType
)

Parameters

barType

One of the BarType enumeration values.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.setBarWidth Method

BarSeries.setBarWidth Method
[image]

Sets the width of the bar as a percent of the space allocated to it.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setBarWidth (
float barWidth
)

Parameters

barWidth

The width of the bar as a percent of the space allocated to it. Acceptable values range from 0 to 100.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.setInnerLabels Method

BarSeries.setInnerLabels Method
[image]

Sets the inner labels for the bars in this BarSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setInnerLabels (
ArrayList<String> innerLabels
)

Parameters

innerLabels

ArrayList with strings that represent the inner labels for the bars.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.setSeriesWidth Method

BarSeries.setSeriesWidth Method
[image]

Sets the width of the BarSeries as a percent of the space allocated to it.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setSeriesWidth (
float seriesWidth
)

Parameters

seriesWidth

The width of the BarSeries as a percent of the space allocated to it. Acceptable values range from 0 to 100.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.setTopLabelOffset Method

BarSeries.setTopLabelOffset Method
[image]

Sets the offset of the top labels to the edge of the Bar.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setTopLabelOffset (
float topLabelOffset
)

Parameters

topLabelOffset

The offset of the top labels to the edge of the Bar, in pixels.

Remarks

Use setTopLabels to specify the labels drawn at the top of the bars.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarSeries.setTopLabels Method

BarSeries.setTopLabels Method
[image]

Sets the top labels for the bars in this BarSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setTopLabels (
ArrayList<String> topLabels
)

Parameters

topLabels

ArrayList with strings that represent the top labels for the bars.

See Also

BarSeries Members
BarSeries Class


com.mindfusion.charting.BarType Class

BarType Class
Remarks See Also
[image]

Specifies different ways the bars in a BarChart could be arranged.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public enum BarType

Remarks

Member | Description
Vertical | Each bar at the same position in another series is drawn next to its predecessor.
VerticalOverlay | Each bar at the same position in another series is drawn inside its predecessor and is thinner.
VerticalStacked | Each bar at the same position in another series is drawn at the top of its predecessor.

Inheritance Hierarchy

java.lang.Enum(E)

See Also

BarType Members


com.mindfusion.charting.BarType Members

BarType Members
[image]

Specifies different ways the bars in a BarChart could be arranged.

The following tables list the members exposed by the BarType type.

See Also

BarType Class


com.mindfusion.charting.Chart Class

Chart Class
[image]

Base class for all chart types.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public abstract class Chart extends View implements SettingsListener

Inheritance Hierarchy

java.lang.Object
android.view.View
com.mindfusion.charting.Chart
com.mindfusion.charting.AxesChart
com.mindfusion.charting.PieChart

See Also

Chart Members


com.mindfusion.charting.Chart Members

Chart Members
Constructors Methods
[image]

Base class for all chart types.

The following tables list the members exposed by the Chart type.

Public Constructors

Name | Description
Chart | Overloaded.

Public Methods

Name | Description
addSeries | Adds a ChartSeries to the Chart.
getBackgroundColor | Gets the color of the chart background.
getBottomChartPadding | Gets the padding at the bottom side of the chart.
getChartPadding | Gets the padding at all four sides of the chart.
getLabelHeight | Gets the height of the font used for the labels at the Chart.
getLeftChartPadding | Gets the padding at the left side of the chart.
getRightChartPadding | Gets the padding at the right side of the chart.
getTitle | Gets the title of the chart.
getTitleColor | Gets the color of the Chart title.
getTitleHeight | Gets the height of the font used for the Chart title.
getTitleOffset | Gets the offset of the chart title.
getTopChartPadding | Gets the padding at the top side of the chart.
setBackgroundColor | Sets the color of the chart background.
setBottomChartPadding | Sets the padding at the bottom side of the chart.
setChartPadding | Sets the padding at all four chart sides.
setLabelHeight | Sets the height of the font used for the labels at the Chart.
setLeftChartPadding | Sets the padding at the left side of the chart.
setRightChartPadding | Sets the padding at the right side of the chart.
setTitle | Sets the title of the chart.
setTitleColor | Sets the color of the chart title.
setTitleHeight | Sets the height of the font used for the Chart title.
setTitleOffset | Sets the offset of the chart title to the plot area.
setTopChartPadding | Sets the padding at the top of the chart.

See Also

Chart Class


com.mindfusion.charting.Chart Constructor

Chart Constructor
[image]

Overload List

Name | Description
Chart (Context) | Initializes a new instance of the Chart class with the specified Context.
Chart (Context, AttributeSet) | Initializes a new instance of the Chart class with the specified Context and AttributeSet.

See Also

Chart Class


com.mindfusion.charting.Chart Constructor (Context)

Chart Constructor (Context)
See Also
[image]

Initializes a new instance of the Chart class with the specified Context.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public Chart (
Context context
)

Parameters

context

The Context used by the chart to draw its elements.

See Also

Chart Constructor Overload List
Chart Class


com.mindfusion.charting.Chart Constructor (Context, AttributeSet)

Chart Constructor (Context, AttributeSet)
See Also
[image]

Initializes a new instance of the Chart class with the specified Context and AttributeSet.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public Chart (
Context context,
AttributeSet attrs
)

Parameters

context

The Context used by the chart to draw its elements.

attrs

An AttributeSet that holds data for various appearance properties of the chart.

See Also

Chart Constructor Overload List
Chart Class


com.mindfusion.charting.Chart Methods

Chart Methods
[image]

Public Methods

Name | Description
addSeries | Adds a ChartSeries to the Chart.
getBackgroundColor | Gets the color of the chart background.
getBottomChartPadding | Gets the padding at the bottom side of the chart.
getChartPadding | Gets the padding at all four sides of the chart.
getLabelHeight | Gets the height of the font used for the labels at the Chart.
getLeftChartPadding | Gets the padding at the left side of the chart.
getRightChartPadding | Gets the padding at the right side of the chart.
getTitle | Gets the title of the chart.
getTitleColor | Gets the color of the Chart title.
getTitleHeight | Gets the height of the font used for the Chart title.
getTitleOffset | Gets the offset of the chart title.
getTopChartPadding | Gets the padding at the top side of the chart.
setBackgroundColor | Sets the color of the chart background.
setBottomChartPadding | Sets the padding at the bottom side of the chart.
setChartPadding | Sets the padding at all four chart sides.
setLabelHeight | Sets the height of the font used for the labels at the Chart.
setLeftChartPadding | Sets the padding at the left side of the chart.
setRightChartPadding | Sets the padding at the right side of the chart.
setTitle | Sets the title of the chart.
setTitleColor | Sets the color of the chart title.
setTitleHeight | Sets the height of the font used for the Chart title.
setTitleOffset | Sets the offset of the chart title to the plot area.
setTopChartPadding | Sets the padding at the top of the chart.

See Also

Chart Class


com.mindfusion.charting.Chart.addSeries Method

Chart.addSeries Method
[image]

Adds a ChartSeries to the Chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void addSeries (
ChartSeries chartSeries
)

Parameters

chartSeries

A ChartSeries object.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getBackgroundColor Method

Chart.getBackgroundColor Method
[image]

Gets the color of the chart background.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public int getBackgroundColor ()

Return Value

An instance of the Color class.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getBottomChartPadding Method

Chart.getBottomChartPadding Method
[image]

Gets the padding at the bottom side of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getBottomChartPadding ()

Return Value

A float value that represents the padding.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getChartPadding Method

Chart.getChartPadding Method
[image]

Gets the padding at all four sides of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getChartPadding ()

Return Value

A float value that represents the left padding.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getLabelHeight Method

Chart.getLabelHeight Method
[image]

Gets the height of the font used for the labels at the Chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getLabelHeight ()

Return Value

A float that represents the height of the font used for the labels at the Chart.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getLeftChartPadding Method

Chart.getLeftChartPadding Method
[image]

Gets the padding at the left side of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getLeftChartPadding ()

Return Value

A float value that represents the padding.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getRightChartPadding Method

Chart.getRightChartPadding Method
[image]

Gets the padding at the right side of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getRightChartPadding ()

Return Value

A float value that represents the padding.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getTitle Method

Chart.getTitle Method
[image]

Gets the title of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public String getTitle ()

Return Value

A string value that represents the title.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getTitleColor Method

Chart.getTitleColor Method
[image]

Gets the color of the Chart title.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public int getTitleColor ()

Return Value

An instance of the Color class.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getTitleHeight Method

Chart.getTitleHeight Method
[image]

Gets the height of the font used for the Chart title.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getTitleHeight ()

Return Value

A float that represents the height of the Chart.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getTitleOffset Method

Chart.getTitleOffset Method
[image]

Gets the offset of the chart title.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getTitleOffset ()

Return Value

A float value that represents the offset of the title to the plot area.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.getTopChartPadding Method

Chart.getTopChartPadding Method
[image]

Gets the padding at the top side of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getTopChartPadding ()

Return Value

A float value that represents the padding.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setBackgroundColor Method

Chart.setBackgroundColor Method
[image]

Sets the color of the chart background.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setBackgroundColor (
int backgroundColor
)

Parameters

backgroundColor

An instance of the Color class.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setBottomChartPadding Method

Chart.setBottomChartPadding Method
[image]

Sets the padding at the bottom side of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setBottomChartPadding (
float bottomPadding
)

Parameters

bottomPadding

A float value that represents the bottom padding.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setChartPadding Method

Chart.setChartPadding Method
[image]

Sets the padding at all four chart sides.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setChartPadding (
float padding
)

Parameters

padding

A float value that represents the padding.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setLabelHeight Method

Chart.setLabelHeight Method
[image]

Sets the height of the font used for the labels at the Chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setLabelHeight (
float labelHeight
)

Parameters

labelHeight

A float that represents the height of the font used for the labels at the Chart.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setLeftChartPadding Method

Chart.setLeftChartPadding Method
[image]

Sets the padding at the left side of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setLeftChartPadding (
float leftPadding
)

Parameters

leftPadding

A float value that represents the left padding.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setRightChartPadding Method

Chart.setRightChartPadding Method
[image]

Sets the padding at the right side of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setRightChartPadding (
float rightPadding
)

Parameters

rightPadding

A float value that represents the right padding.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setTitle Method

Chart.setTitle Method
[image]

Sets the title of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setTitle (
String title
)

Parameters

title

A string that represents the title.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setTitleColor Method

Chart.setTitleColor Method
[image]

Sets the color of the chart title.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setTitleColor (
int titleColor
)

Parameters

titleColor

An instance of the Color class.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setTitleHeight Method

Chart.setTitleHeight Method
[image]

Sets the height of the font used for the Chart title.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setTitleHeight (
float titleHeight
)

Parameters

titleHeight

A float that represents the height of the chart title.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setTitleOffset Method

Chart.setTitleOffset Method
[image]

Sets the offset of the chart title to the plot area.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setTitleOffset (
float offset
)

Parameters

offset

A float value that represents the offset.

See Also

Chart Members
Chart Class


com.mindfusion.charting.Chart.setTopChartPadding Method

Chart.setTopChartPadding Method
[image]

Sets the padding at the top of the chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setTopChartPadding (
float topPadding
)

Parameters

topPadding

A float value that represents the top padding.

See Also

Chart Members
Chart Class


com.mindfusion.charting.ChartElement Class

ChartElement Class
[image]

Base class for all chart elements - pie pieces, bars, lines.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class ChartElement

Inheritance Hierarchy

java.lang.Object
com.mindfusion.charting.ChartElement
com.mindfusion.charting.Bar
com.mindfusion.charting.PiePiece

See Also

ChartElement Members


com.mindfusion.charting.ChartElement Members

ChartElement Members
Constructors Methods
[image]

Base class for all chart elements - pie pieces, bars, lines.

The following tables list the members exposed by the ChartElement type.

Public Constructors

Name | Description
ChartElement | Initializes a new instance of the ChartElement class.

Public Methods

Name | Description
getDataIndex | Gets the index of this ChartElement in the data array for this ChartSeries.
getFillColor | Gets the color used for filling this ChartElement.
getSeriesIndex | Gets the index of the ChartSeries this element belongs to.
getStrokeColor | Gets the color used for stroking this ChartElement.

See Also

ChartElement Class


com.mindfusion.charting.ChartElement Constructor

ChartElement Constructor
[image]

Initializes a new instance of the ChartElement class.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ChartElement ()

See Also

ChartElement Class


com.mindfusion.charting.ChartElement Methods

ChartElement Methods
[image]

Public Methods

Name | Description
getDataIndex | Gets the index of this ChartElement in the data array for this ChartSeries.
getFillColor | Gets the color used for filling this ChartElement.
getSeriesIndex | Gets the index of the ChartSeries this element belongs to.
getStrokeColor | Gets the color used for stroking this ChartElement.

See Also

ChartElement Class


com.mindfusion.charting.ChartElement.getDataIndex Method

ChartElement.getDataIndex Method
[image]

Gets the index of this ChartElement in the data array for this ChartSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public int getDataIndex ()

Return Value

The index.

Remarks

Use setXData and setYData to specify data for axes charts; setData to specify data in pie and doughnut charts.

See Also

ChartElement Members
ChartElement Class


com.mindfusion.charting.ChartElement.getFillColor Method

ChartElement.getFillColor Method
[image]

Gets the color used for filling this ChartElement.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public int getFillColor ()

Return Value

An instance of the Color class.

Remarks

Use setFillColors to specify the colors in a ChartSeries.

See Also

ChartElement Members
ChartElement Class


com.mindfusion.charting.ChartElement.getSeriesIndex Method

ChartElement.getSeriesIndex Method
[image]

Gets the index of the ChartSeries this element belongs to.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public int getSeriesIndex ()

Return Value

An integer that specifies the index..

Remarks

Use addSeries to add a series to your chart.

See Also

ChartElement Members
ChartElement Class


com.mindfusion.charting.ChartElement.getStrokeColor Method

ChartElement.getStrokeColor Method
[image]

Gets the color used for stroking this ChartElement.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public int getStrokeColor ()

Return Value

An instance of the Color class.

Remarks

Use setStrokeColors to specify the strokes for the ChartSeries.

See Also

ChartElement Members
ChartElement Class


com.mindfusion.charting.ChartSeries Class

ChartSeries Class
[image]

Base class for all series in the Chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class ChartSeries

Inheritance Hierarchy

java.lang.Object
com.mindfusion.charting.ChartSeries
com.mindfusion.charting.AxesSeries
com.mindfusion.charting.PieSeries

See Also

ChartSeries Members


com.mindfusion.charting.ChartSeries Members

ChartSeries Members
Constructors Methods
[image]

Base class for all series in the Chart.

The following tables list the members exposed by the ChartSeries type.

Public Constructors

Name | Description
ChartSeries | Initializes a new instance of the ChartSeries class.

Public Methods

Name | Description
getFillColors | Gets the colors used when filling the ChartElements of this ChartSeries.
getIndex | Gets the index of the current ChartSeries in the series collections.
getStrokeColors | Gets the colors used when stroking the ChartElements of this ChartSeries.
getStrokeEffect | Gets the PathEffect used with the strokes for this ChartSeries.
getStrokeWidth | Gets the width of the stroke colors for this ChartSeries.
setFillColors | Sets the colors used when filling the ChartElements of this ChartSeries.
setStrokeColors | Sets the colors used when stroking the ChartElements of this ChartSeries.
setStrokeEffect | Applies the specified PathEffect on the strokes for this ChartSeries.
setStrokeWidth | Sets the width of the strokes used when drawing this ChartSeries.

See Also

ChartSeries Class


com.mindfusion.charting.ChartSeries Constructor

ChartSeries Constructor
[image]

Initializes a new instance of the ChartSeries class.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ChartSeries ()

See Also

ChartSeries Class


com.mindfusion.charting.ChartSeries Methods

ChartSeries Methods
[image]

Public Methods

Name | Description
getFillColors | Gets the colors used when filling the ChartElements of this ChartSeries.
getIndex | Gets the index of the current ChartSeries in the series collections.
getStrokeColors | Gets the colors used when stroking the ChartElements of this ChartSeries.
getStrokeEffect | Gets the PathEffect used with the strokes for this ChartSeries.
getStrokeWidth | Gets the width of the stroke colors for this ChartSeries.
setFillColors | Sets the colors used when filling the ChartElements of this ChartSeries.
setStrokeColors | Sets the colors used when stroking the ChartElements of this ChartSeries.
setStrokeEffect | Applies the specified PathEffect on the strokes for this ChartSeries.
setStrokeWidth | Sets the width of the strokes used when drawing this ChartSeries.

See Also

ChartSeries Class


com.mindfusion.charting.ChartSeries.getFillColors Method

ChartSeries.getFillColors Method
[image]

Gets the colors used when filling the ChartElements of this ChartSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<Integer> getFillColors ()

Return Value

An ArrayList with the colors.

See Also

ChartSeries Members
ChartSeries Class


com.mindfusion.charting.ChartSeries.getIndex Method

ChartSeries.getIndex Method
[image]

Gets the index of the current ChartSeries in the series collections.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public int getIndex ()

Return Value

The index.

See Also

ChartSeries Members
ChartSeries Class


com.mindfusion.charting.ChartSeries.getStrokeColors Method

ChartSeries.getStrokeColors Method
[image]

Gets the colors used when stroking the ChartElements of this ChartSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<Integer> getStrokeColors ()

Return Value

An ArrayList with the colors.

See Also

ChartSeries Members
ChartSeries Class


com.mindfusion.charting.ChartSeries.getStrokeEffect Method

ChartSeries.getStrokeEffect Method
[image]

Gets the PathEffect used with the strokes for this ChartSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public PathEffect getStrokeEffect ()

Return Value

The PathEffect applied at the strokes of this ChartSeries.

Remarks

Use setStrokeColors to specify the colors for the Chart.

See Also

ChartSeries Members
ChartSeries Class


com.mindfusion.charting.ChartSeries.getStrokeWidth Method

ChartSeries.getStrokeWidth Method
[image]

Gets the width of the stroke colors for this ChartSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getStrokeWidth ()

Return Value

A float that represents the width of the stroke colors.

Remarks

Use setStrokeColors to specify the strokes for the ChartSeries.

See Also

ChartSeries Members
ChartSeries Class


com.mindfusion.charting.ChartSeries.setFillColors Method

ChartSeries.setFillColors Method
[image]

Sets the colors used when filling the ChartElements of this ChartSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setFillColors (
ArrayList<Integer> colors
)

Parameters

colors

An ArrayList with the colors.

See Also

ChartSeries Members
ChartSeries Class


com.mindfusion.charting.ChartSeries.setStrokeColors Method

ChartSeries.setStrokeColors Method
[image]

Sets the colors used when stroking the ChartElements of this ChartSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setStrokeColors (
ArrayList<Integer> colors
)

Parameters

colors

An ArrayList with the colors.

See Also

ChartSeries Members
ChartSeries Class


com.mindfusion.charting.ChartSeries.setStrokeEffect Method

ChartSeries.setStrokeEffect Method
[image]

Applies the specified PathEffect on the strokes for this ChartSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setStrokeEffect (
PathEffect effect
)

Parameters

effect

The PathEffect to use.

Remarks

Use setStrokeColors to specify the strokes for the Chart.

See Also

ChartSeries Members
ChartSeries Class


com.mindfusion.charting.ChartSeries.setStrokeWidth Method

ChartSeries.setStrokeWidth Method
[image]

Sets the width of the strokes used when drawing this ChartSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setStrokeWidth (
float strokeWidth
)

Parameters

strokeWidth

A float that represents the width of the setStrokeColors.

Remarks

Use setStrokeColors to specify the strokes for the ChartSeries.

See Also

ChartSeries Members
ChartSeries Class


com.mindfusion.charting.GridType Class

GridType Class
Remarks See Also
[image]

Defines the different types of grid a Chart can have.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public enum GridType

Remarks

Member | Description
Crossed | Specifies a crossed grid.
Horizontal | Specifies a horizontal grid.
None | No grid is drawn.
Vertical | Specifies a vertical grid.

Inheritance Hierarchy

java.lang.Enum(E)

See Also

GridType Members


com.mindfusion.charting.GridType Members

GridType Members
[image]

Defines the different types of grid a Chart can have.

The following tables list the members exposed by the GridType type.

See Also

GridType Class


com.mindfusion.charting.LabelType Class

LabelType Class
Remarks See Also
[image]

Identifies possible label types a Chart can have.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public enum LabelType

Remarks

Member | Description
Custom | Labels are strings set by the user.
Data | Labels show the data at the point they refer to.
Empty | No labels are drawn.

Inheritance Hierarchy

java.lang.Enum(E)

See Also

LabelType Members


com.mindfusion.charting.LabelType Members

LabelType Members
[image]

Identifies possible label types a Chart can have.

The following tables list the members exposed by the LabelType type.

See Also

LabelType Class


com.mindfusion.charting.LineSeries Class

LineSeries Class
[image]

Represents a line series in an AxesChart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class LineSeries extends AxesSeries

Inheritance Hierarchy

java.lang.Object
com.mindfusion.charting.ChartSeries
com.mindfusion.charting.AxesSeries
com.mindfusion.charting.LineSeries

See Also

LineSeries Members


com.mindfusion.charting.LineSeries Members

LineSeries Members
Constructors Methods
[image]

Represents a line series in an AxesChart.

The following tables list the members exposed by the LineSeries type.

Public Constructors

Name | Description
LineSeries | Initializes a new instance of the LineSeries class.

Public Methods

Name | Description
getLabelOffset | Gets the offset of labels drawn at data points.
getLabels | Gets the labels drawn at data points at this LineSeries.
getLineType | Gets the type of this LineSeries.
getScatterFillColors | Gets the colors with which scatters are filled.
getScatterSize | Gets the size of the scatter.
getScatterStrokeColors | Gets the colors with which scatters are stroked.
getScatterStrokeEffect | Gets the PathEffect applied at strokes used for drawing scatters.
getScatterStrokeWidth | Gets the width of strokes used for drawing scatters.
getscatterType | Gets the type of the scatters at this LineSeries.
setLabelOffset | Sets the offset of labels drawn at data points.
setLabels | Sets the labels drawn at data points at this LineSeries.
setLineType | Sets the type of this LineSeries.
setScatterFillColors | Sets the colors with which scatters are filled.
setScatterSize | Sets the size of the scatters.
setScatterStrokeColors | Sets the colors with which scatters are stroked.
setScatterStrokeEffect | Sets the PathEffect applied at strokes used for drawing scatters.
setScatterStrokeWidth | Sets the width of strokes used for drawing scatters.
setScatterType | Sets the type of the scatters at this LineSeries.

Inherited Public Methods

Name | Description
getFillColors | Gets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getIndex | Gets the index of the current ChartSeries in the series collections. (Inherited from ChartSeries.)
getStrokeColors | Gets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getStrokeEffect | Gets the PathEffect used with the strokes for this ChartSeries. (Inherited from ChartSeries.)
getStrokeWidth | Gets the width of the stroke colors for this ChartSeries. (Inherited from ChartSeries.)
getXData | Gets the X-data for this AxesSeries. (Inherited from AxesSeries.)
getYData | Gets the Y-data for this AxesSeries. (Inherited from AxesSeries.)
setFillColors | Sets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeColors | Sets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeEffect | Applies the specified PathEffect on the strokes for this ChartSeries. (Inherited from ChartSeries.)
setStrokeWidth | Sets the width of the strokes used when drawing this ChartSeries. (Inherited from ChartSeries.)
setXData | Sets X-data for this AxesSeries. (Inherited from AxesSeries.)
setYData | Sets the Y-data for this AxesSeries. (Inherited from AxesSeries.)

See Also

LineSeries Class


com.mindfusion.charting.LineSeries Constructor

LineSeries Constructor
[image]

Initializes a new instance of the LineSeries class.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public LineSeries ()

See Also

LineSeries Class


com.mindfusion.charting.LineSeries Methods

LineSeries Methods
[image]

Public Methods

Name | Description
getLabelOffset | Gets the offset of labels drawn at data points.
getLabels | Gets the labels drawn at data points at this LineSeries.
getLineType | Gets the type of this LineSeries.
getScatterFillColors | Gets the colors with which scatters are filled.
getScatterSize | Gets the size of the scatter.
getScatterStrokeColors | Gets the colors with which scatters are stroked.
getScatterStrokeEffect | Gets the PathEffect applied at strokes used for drawing scatters.
getScatterStrokeWidth | Gets the width of strokes used for drawing scatters.
getscatterType | Gets the type of the scatters at this LineSeries.
setLabelOffset | Sets the offset of labels drawn at data points.
setLabels | Sets the labels drawn at data points at this LineSeries.
setLineType | Sets the type of this LineSeries.
setScatterFillColors | Sets the colors with which scatters are filled.
setScatterSize | Sets the size of the scatters.
setScatterStrokeColors | Sets the colors with which scatters are stroked.
setScatterStrokeEffect | Sets the PathEffect applied at strokes used for drawing scatters.
setScatterStrokeWidth | Sets the width of strokes used for drawing scatters.
setScatterType | Sets the type of the scatters at this LineSeries.

Inherited Public Methods

Name | Description
getFillColors | Gets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getIndex | Gets the index of the current ChartSeries in the series collections. (Inherited from ChartSeries.)
getStrokeColors | Gets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getStrokeEffect | Gets the PathEffect used with the strokes for this ChartSeries. (Inherited from ChartSeries.)
getStrokeWidth | Gets the width of the stroke colors for this ChartSeries. (Inherited from ChartSeries.)
getXData | Gets the X-data for this AxesSeries. (Inherited from AxesSeries.)
getYData | Gets the Y-data for this AxesSeries. (Inherited from AxesSeries.)
setFillColors | Sets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeColors | Sets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeEffect | Applies the specified PathEffect on the strokes for this ChartSeries. (Inherited from ChartSeries.)
setStrokeWidth | Sets the width of the strokes used when drawing this ChartSeries. (Inherited from ChartSeries.)
setXData | Sets X-data for this AxesSeries. (Inherited from AxesSeries.)
setYData | Sets the Y-data for this AxesSeries. (Inherited from AxesSeries.)

See Also

LineSeries Class


com.mindfusion.charting.LineSeries.getLabelOffset Method

LineSeries.getLabelOffset Method
[image]

Gets the offset of labels drawn at data points.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getLabelOffset ()

Return Value

The offset.

Remarks

Use setLabels to specify the labels.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.getLabels Method

LineSeries.getLabels Method
[image]

Gets the labels drawn at data points at this LineSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<String> getLabels ()

Return Value

ArrayList with the labels.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.getLineType Method

LineSeries.getLineType Method
[image]

Gets the type of this LineSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public LineType getLineType ()

Return Value

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.getScatterFillColors Method

LineSeries.getScatterFillColors Method
[image]

Gets the colors with which scatters are filled.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<Integer> getScatterFillColors ()

Return Value

An ArrayList with Color objects.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.getScatterSize Method

LineSeries.getScatterSize Method
[image]

Gets the size of the scatter.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getScatterSize ()

Return Value

A float that represents the size of the scatter.

Remarks

Use setScatterType to specify the type of scatters drawn at this LineSeries.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.getScatterStrokeColors Method

LineSeries.getScatterStrokeColors Method
[image]

Gets the colors with which scatters are stroked.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<Integer> getScatterStrokeColors ()

Return Value

An ArrayList with Color objects.

Remarks

Use setScatterType to specify the type of scatters drawn at this LineSeries.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.getScatterStrokeEffect Method

LineSeries.getScatterStrokeEffect Method
[image]

Gets the PathEffect applied at strokes used for drawing scatters.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public PathEffect getScatterStrokeEffect ()

Return Value

A PathEffect object.

Remarks

Use setScatterStrokeColors to spesify the strokes for the scatters.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.getScatterStrokeWidth Method

LineSeries.getScatterStrokeWidth Method
[image]

Gets the width of strokes used for drawing scatters.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getScatterStrokeWidth ()

Return Value

The width.

Remarks

Use setScatterStrokeColors to specify the strokes for the scatters.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.getscatterType Method

LineSeries.getscatterType Method
[image]

Gets the type of the scatters at this LineSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ScatterType getscatterType ()

Return Value

One of the ScatterType enumeration values.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.setLabelOffset Method

LineSeries.setLabelOffset Method
[image]

Sets the offset of labels drawn at data points.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setLabelOffset (
float labelOffset
)

Parameters

labelOffset

The offset.

Remarks

Use setLabels to specify the labels for this LineSeries.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.setLabels Method

LineSeries.setLabels Method
[image]

Sets the labels drawn at data points at this LineSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setLabels (
ArrayList<String> labels
)

Parameters

labels

ArrayList with the labels.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.setLineType Method

LineSeries.setLineType Method
[image]

Sets the type of this LineSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setLineType (
LineType lineType
)

Parameters

lineType

One of the LineType enumeration values.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.setScatterFillColors Method

LineSeries.setScatterFillColors Method
[image]

Sets the colors with which scatters are filled.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setScatterFillColors (
ArrayList<Integer> scatterFillColors
)

Parameters

scatterFillColors

An ArrayList with Color objects.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.setScatterSize Method

LineSeries.setScatterSize Method
[image]

Sets the size of the scatters.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setScatterSize (
float scatterSize
)

Parameters

scatterSize

A float value that represents the diameter of the scatter.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.setScatterStrokeColors Method

LineSeries.setScatterStrokeColors Method
[image]

Sets the colors with which scatters are stroked.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setScatterStrokeColors (
ArrayList<Integer> scatterStrokeColors
)

Parameters

scatterStrokeColors

An ArrayList with Color objects.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.setScatterStrokeEffect Method

LineSeries.setScatterStrokeEffect Method
[image]

Sets the PathEffect applied at strokes used for drawing scatters.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setScatterStrokeEffect (
PathEffect effect
)

Parameters

effect

A PathEffect object.

Remarks

Use setScatterStrokeColors to specify the colors for the scatters.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.setScatterStrokeWidth Method

LineSeries.setScatterStrokeWidth Method
[image]

Sets the width of strokes used for drawing scatters.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setScatterStrokeWidth (
float scatterStrokeWidth
)

Parameters

scatterStrokeWidth

The width.

Remarks

Use setScatterStrokeColors to specify the colors for the scatters.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineSeries.setScatterType Method

LineSeries.setScatterType Method
[image]

Sets the type of the scatters at this LineSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setScatterType (
ScatterType scatterType
)

Parameters

scatterType

One of the ScatterType enumeration values.

See Also

LineSeries Members
LineSeries Class


com.mindfusion.charting.LineType Class

LineType Class
Remarks See Also
[image]

Identifies possible types of a LineSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public enum LineType

Remarks

Member | Description
Area | The LineSeries is drawn as an area.
Line | The LineSeries is drawn as a line.
None | The LineSeries is not drawn.
StackedArea | The LineSeries is drawn at top of the previous LineSeries.

Inheritance Hierarchy

java.lang.Enum(E)

See Also

LineType Members


com.mindfusion.charting.LineType Members

LineType Members
[image]

Identifies possible types of a LineSeries.

The following tables list the members exposed by the LineType type.

See Also

LineType Class


com.mindfusion.charting.PieChart Class

PieChart Class
[image]

Represents a pie chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class PieChart extends Chart

Inheritance Hierarchy

java.lang.Object
android.view.View
com.mindfusion.charting.Chart
com.mindfusion.charting.PieChart

See Also

PieChart Members


com.mindfusion.charting.PieChart Members

PieChart Members
Constructors Methods
[image]

Represents a pie chart.

The following tables list the members exposed by the PieChart type.

Public Constructors

Name | Description
PieChart | Overloaded.

Public Methods

Name | Description
getDistBtwSeries | Gets the distance between PieSeries.
getDoughnutFraction | Sets the fraction of the doughnut as a percent of the radius.
setDistBtwSeries | Sets the distance between adjacent PieSeries in a pie chart.
setDoughnutFraction | Sets the thickness of the doughnut as a fraction of the radius.

Inherited Public Methods

Name | Description
addSeries | Adds a ChartSeries to the Chart. (Inherited from Chart.)
getBackgroundColor | Gets the color of the chart background. (Inherited from Chart.)
getBottomChartPadding | Gets the padding at the bottom side of the chart. (Inherited from Chart.)
getChartPadding | Gets the padding at all four sides of the chart. (Inherited from Chart.)
getLabelHeight | Gets the height of the font used for the labels at the Chart. (Inherited from Chart.)
getLeftChartPadding | Gets the padding at the left side of the chart. (Inherited from Chart.)
getRightChartPadding | Gets the padding at the right side of the chart. (Inherited from Chart.)
getTitle | Gets the title of the chart. (Inherited from Chart.)
getTitleColor | Gets the color of the Chart title. (Inherited from Chart.)
getTitleHeight | Gets the height of the font used for the Chart title. (Inherited from Chart.)
getTitleOffset | Gets the offset of the chart title. (Inherited from Chart.)
getTopChartPadding | Gets the padding at the top side of the chart. (Inherited from Chart.)
setBackgroundColor | Sets the color of the chart background. (Inherited from Chart.)
setBottomChartPadding | Sets the padding at the bottom side of the chart. (Inherited from Chart.)
setChartPadding | Sets the padding at all four chart sides. (Inherited from Chart.)
setLabelHeight | Sets the height of the font used for the labels at the Chart. (Inherited from Chart.)
setLeftChartPadding | Sets the padding at the left side of the chart. (Inherited from Chart.)
setRightChartPadding | Sets the padding at the right side of the chart. (Inherited from Chart.)
setTitle | Sets the title of the chart. (Inherited from Chart.)
setTitleColor | Sets the color of the chart title. (Inherited from Chart.)
setTitleHeight | Sets the height of the font used for the Chart title. (Inherited from Chart.)
setTitleOffset | Sets the offset of the chart title to the plot area. (Inherited from Chart.)
setTopChartPadding | Sets the padding at the top of the chart. (Inherited from Chart.)

See Also

PieChart Class


com.mindfusion.charting.PieChart Constructor

PieChart Constructor
[image]

Overload List

Name | Description
PieChart (Context) | Initializes a new instance of the PieChart class with the specified context.
PieChart (Context, AttributeSet) | Initializes a new instance of the PieChart class with the specified context and set of attributes.

See Also

PieChart Class


com.mindfusion.charting.PieChart Constructor (Context)

PieChart Constructor (Context)
See Also
[image]

Initializes a new instance of the PieChart class with the specified context.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public PieChart (
Context context
)

Parameters

context

The Context used by this PieChart.

See Also

PieChart Constructor Overload List
PieChart Class


com.mindfusion.charting.PieChart Constructor (Context, AttributeSet)

PieChart Constructor (Context, AttributeSet)
See Also
[image]

Initializes a new instance of the PieChart class with the specified context and set of attributes.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public PieChart (
Context context,
AttributeSet attrs
)

Parameters

context

The Context used by this PieChart.

attrs

A set of attributes applied at this PieChart.

See Also

PieChart Constructor Overload List
PieChart Class


com.mindfusion.charting.PieChart Methods

PieChart Methods
[image]

Public Methods

Name | Description
getDistBtwSeries | Gets the distance between PieSeries.
getDoughnutFraction | Sets the fraction of the doughnut as a percent of the radius.
setDistBtwSeries | Sets the distance between adjacent PieSeries in a pie chart.
setDoughnutFraction | Sets the thickness of the doughnut as a fraction of the radius.

Inherited Public Methods

Name | Description
addSeries | Adds a ChartSeries to the Chart. (Inherited from Chart.)
getBackgroundColor | Gets the color of the chart background. (Inherited from Chart.)
getBottomChartPadding | Gets the padding at the bottom side of the chart. (Inherited from Chart.)
getChartPadding | Gets the padding at all four sides of the chart. (Inherited from Chart.)
getLabelHeight | Gets the height of the font used for the labels at the Chart. (Inherited from Chart.)
getLeftChartPadding | Gets the padding at the left side of the chart. (Inherited from Chart.)
getRightChartPadding | Gets the padding at the right side of the chart. (Inherited from Chart.)
getTitle | Gets the title of the chart. (Inherited from Chart.)
getTitleColor | Gets the color of the Chart title. (Inherited from Chart.)
getTitleHeight | Gets the height of the font used for the Chart title. (Inherited from Chart.)
getTitleOffset | Gets the offset of the chart title. (Inherited from Chart.)
getTopChartPadding | Gets the padding at the top side of the chart. (Inherited from Chart.)
setBackgroundColor | Sets the color of the chart background. (Inherited from Chart.)
setBottomChartPadding | Sets the padding at the bottom side of the chart. (Inherited from Chart.)
setChartPadding | Sets the padding at all four chart sides. (Inherited from Chart.)
setLabelHeight | Sets the height of the font used for the labels at the Chart. (Inherited from Chart.)
setLeftChartPadding | Sets the padding at the left side of the chart. (Inherited from Chart.)
setRightChartPadding | Sets the padding at the right side of the chart. (Inherited from Chart.)
setTitle | Sets the title of the chart. (Inherited from Chart.)
setTitleColor | Sets the color of the chart title. (Inherited from Chart.)
setTitleHeight | Sets the height of the font used for the Chart title. (Inherited from Chart.)
setTitleOffset | Sets the offset of the chart title to the plot area. (Inherited from Chart.)
setTopChartPadding | Sets the padding at the top of the chart. (Inherited from Chart.)

See Also

PieChart Class


com.mindfusion.charting.PieChart.getDistBtwSeries Method

PieChart.getDistBtwSeries Method
[image]

Gets the distance between PieSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getDistBtwSeries ()

Return Value

A float value that specifies the distance between the series.

See Also

PieChart Members
PieChart Class


com.mindfusion.charting.PieChart.getDoughnutFraction Method

PieChart.getDoughnutFraction Method
[image]

Sets the fraction of the doughnut as a percent of the radius.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getDoughnutFraction ()

Return Value

A float value. Values range from 0 to 1.

Remarks

The bigger the vaue, the thinner the ring of the doughnut. Value of 0 means a pie is drawn.

See Also

PieChart Members
PieChart Class


com.mindfusion.charting.PieChart.setDistBtwSeries Method

PieChart.setDistBtwSeries Method
[image]

Sets the distance between adjacent PieSeries in a pie chart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setDistBtwSeries (
float distBtwSeries
)

Parameters

distBtwSeries

A float value that indicates the distance between adjacent PieSeries, in pixels.

See Also

PieChart Members
PieChart Class


com.mindfusion.charting.PieChart.setDoughnutFraction Method

PieChart.setDoughnutFraction Method
[image]

Sets the thickness of the doughnut as a fraction of the radius.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setDoughnutFraction (
float dFraction
)

Parameters

dFraction

A float value that indicates the thickness of the doughnut as a percent of the radius.

Remarks

The bigger the vaue, the thinner the ring of the doughnut. Value of 0 means a pie is drawn.

See Also

PieChart Members
PieChart Class


com.mindfusion.charting.PiePiece Class

PiePiece Class
[image]

Represents a piece in a PieChart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class PiePiece extends ChartElement

Inheritance Hierarchy

java.lang.Object
com.mindfusion.charting.ChartElement
com.mindfusion.charting.PiePiece

See Also

PiePiece Members


com.mindfusion.charting.PiePiece Members

PiePiece Members
Constructors Methods
[image]

Represents a piece in a PieChart.

The following tables list the members exposed by the PiePiece type.

Public Constructors

Name | Description
PiePiece | Initializes a new instance of the PiePiece class.

Public Methods

Name | Description
getData | Gets the data this piece represents.
getInnerLabel | Gets the inner label of this PiePiece.
getOuterLabel | Gets the outer label of this PiePiece.

Inherited Public Methods

Name | Description
getDataIndex | Gets the index of this ChartElement in the data array for this ChartSeries. (Inherited from ChartElement.)
getFillColor | Gets the color used for filling this ChartElement. (Inherited from ChartElement.)
getSeriesIndex | Gets the index of the ChartSeries this element belongs to. (Inherited from ChartElement.)
getStrokeColor | Gets the color used for stroking this ChartElement. (Inherited from ChartElement.)

See Also

PiePiece Class


com.mindfusion.charting.PiePiece Constructor

PiePiece Constructor
[image]

Initializes a new instance of the PiePiece class.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public PiePiece ()

See Also

PiePiece Class


com.mindfusion.charting.PiePiece Methods

PiePiece Methods
[image]

Public Methods

Name | Description
getData | Gets the data this piece represents.
getInnerLabel | Gets the inner label of this PiePiece.
getOuterLabel | Gets the outer label of this PiePiece.

Inherited Public Methods

Name | Description
getDataIndex | Gets the index of this ChartElement in the data array for this ChartSeries. (Inherited from ChartElement.)
getFillColor | Gets the color used for filling this ChartElement. (Inherited from ChartElement.)
getSeriesIndex | Gets the index of the ChartSeries this element belongs to. (Inherited from ChartElement.)
getStrokeColor | Gets the color used for stroking this ChartElement. (Inherited from ChartElement.)

See Also

PiePiece Class


com.mindfusion.charting.PiePiece.getData Method

PiePiece.getData Method
[image]

Gets the data this piece represents.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getData ()

Return Value

The data.

Remarks

Use PieSeries.setData to specify the data for the pie.

See Also

PiePiece Members
PiePiece Class


com.mindfusion.charting.PiePiece.getInnerLabel Method

PiePiece.getInnerLabel Method
[image]

Gets the inner label of this PiePiece.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public String getInnerLabel ()

Return Value

The inner label.

Remarks

Use PieSeries.setInnerLabels to specify the labels drawn inside pie pieces.

See Also

PiePiece Members
PiePiece Class


com.mindfusion.charting.PiePiece.getOuterLabel Method

PiePiece.getOuterLabel Method
[image]

Gets the outer label of this PiePiece.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public String getOuterLabel ()

Return Value

The outer label.

Remarks

Use PieSeries.setOuterLabels to specify the labels drawn outside pie pieces.

See Also

PiePiece Members
PiePiece Class


com.mindfusion.charting.PieSeries Class

PieSeries Class
[image]

Represents a series in a PieChart.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public class PieSeries extends ChartSeries

Inheritance Hierarchy

java.lang.Object
com.mindfusion.charting.ChartSeries
com.mindfusion.charting.PieSeries

See Also

PieSeries Members


com.mindfusion.charting.PieSeries Members

PieSeries Members
Constructors Methods
[image]

Represents a series in a PieChart.

The following tables list the members exposed by the PieSeries type.

Public Constructors

Name | Description
PieSeries | Initializes a new PieSeries.

Public Methods

Name | Description
getData | Gets the data for this pie/doughnut series.
getInnerLabels | Gets the labels inside pie/doughnut pieces.
getOuterLabelOffset | Gets the offset of the outer label to the label pointer.
getOuterLabels | Gets the labels outside pie/doughnut pieces.
getPointerLength | Gets the length of the pointer to the OuterLabels.
setData | Sets the data for this pie/doughnut series.
setInnerLabels | sets the labels inside pie/doughnut pieces.
setOuterLabelOffset | Sets the offset of the outer label to the label pointer.
setOuterLabels | Sets the labels outside pie/doughnut pieces.
setPointerLength | Sets the length of the pointer to the OuterLabels.

Inherited Public Methods

Name | Description
getFillColors | Gets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getIndex | Gets the index of the current ChartSeries in the series collections. (Inherited from ChartSeries.)
getStrokeColors | Gets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getStrokeEffect | Gets the PathEffect used with the strokes for this ChartSeries. (Inherited from ChartSeries.)
getStrokeWidth | Gets the width of the stroke colors for this ChartSeries. (Inherited from ChartSeries.)
setFillColors | Sets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeColors | Sets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeEffect | Applies the specified PathEffect on the strokes for this ChartSeries. (Inherited from ChartSeries.)
setStrokeWidth | Sets the width of the strokes used when drawing this ChartSeries. (Inherited from ChartSeries.)

See Also

PieSeries Class


com.mindfusion.charting.PieSeries Constructor

PieSeries Constructor
[image]

Initializes a new PieSeries.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public PieSeries ()

See Also

PieSeries Class


com.mindfusion.charting.PieSeries Methods

PieSeries Methods
[image]

Public Methods

Name | Description
getData | Gets the data for this pie/doughnut series.
getInnerLabels | Gets the labels inside pie/doughnut pieces.
getOuterLabelOffset | Gets the offset of the outer label to the label pointer.
getOuterLabels | Gets the labels outside pie/doughnut pieces.
getPointerLength | Gets the length of the pointer to the OuterLabels.
setData | Sets the data for this pie/doughnut series.
setInnerLabels | sets the labels inside pie/doughnut pieces.
setOuterLabelOffset | Sets the offset of the outer label to the label pointer.
setOuterLabels | Sets the labels outside pie/doughnut pieces.
setPointerLength | Sets the length of the pointer to the OuterLabels.

Inherited Public Methods

Name | Description
getFillColors | Gets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getIndex | Gets the index of the current ChartSeries in the series collections. (Inherited from ChartSeries.)
getStrokeColors | Gets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
getStrokeEffect | Gets the PathEffect used with the strokes for this ChartSeries. (Inherited from ChartSeries.)
getStrokeWidth | Gets the width of the stroke colors for this ChartSeries. (Inherited from ChartSeries.)
setFillColors | Sets the colors used when filling the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeColors | Sets the colors used when stroking the ChartElements of this ChartSeries. (Inherited from ChartSeries.)
setStrokeEffect | Applies the specified PathEffect on the strokes for this ChartSeries. (Inherited from ChartSeries.)
setStrokeWidth | Sets the width of the strokes used when drawing this ChartSeries. (Inherited from ChartSeries.)

See Also

PieSeries Class


com.mindfusion.charting.PieSeries.getData Method

PieSeries.getData Method
[image]

Gets the data for this pie/doughnut series.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<Float> getData ()

Return Value

An ArrayList with the data.

See Also

PieSeries Members
PieSeries Class


com.mindfusion.charting.PieSeries.getInnerLabels Method

PieSeries.getInnerLabels Method
[image]

Gets the labels inside pie/doughnut pieces.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<String> getInnerLabels ()

Return Value

An ArrayList with the labels.

See Also

PieSeries Members
PieSeries Class


com.mindfusion.charting.PieSeries.getOuterLabelOffset Method

PieSeries.getOuterLabelOffset Method
[image]

Gets the offset of the outer label to the label pointer.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getOuterLabelOffset ()

Return Value

The offset.

Remarks

Use setOuterLabels to specify the labels outside pie pieces.

See Also

PieSeries Members
PieSeries Class


com.mindfusion.charting.PieSeries.getOuterLabels Method

PieSeries.getOuterLabels Method
[image]

Gets the labels outside pie/doughnut pieces.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public ArrayList<String> getOuterLabels ()

Return Value

An ArrayList with the labels.

See Also

PieSeries Members
PieSeries Class


com.mindfusion.charting.PieSeries.getPointerLength Method

PieSeries.getPointerLength Method
[image]

Gets the length of the pointer to the OuterLabels.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public float getPointerLength ()

Return Value

The length of the pointer.

Remarks

Use setOuterLabels to specify the labels outside pie pieces.

See Also

PieSeries Members
PieSeries Class


com.mindfusion.charting.PieSeries.setData Method

PieSeries.setData Method
[image]

Sets the data for this pie/doughnut series.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setData (
ArrayList<Float> data
)

Parameters

data

An ArrayList with the data.

See Also

PieSeries Members
PieSeries Class


com.mindfusion.charting.PieSeries.setInnerLabels Method

PieSeries.setInnerLabels Method
[image]

sets the labels inside pie/doughnut pieces.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setInnerLabels (
ArrayList<String> innerLabels
)

Parameters

innerLabels

An ArrayList with the labels.

See Also

PieSeries Members
PieSeries Class


com.mindfusion.charting.PieSeries.setOuterLabelOffset Method

PieSeries.setOuterLabelOffset Method
[image]

Sets the offset of the outer label to the label pointer.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setOuterLabelOffset (
float outerLabelOffset
)

Parameters

outerLabelOffset

The offset.

Remarks

Use setOuterLabels to specify the labels outside pie pieces.

See Also

PieSeries Members
PieSeries Class


com.mindfusion.charting.PieSeries.setOuterLabels Method

PieSeries.setOuterLabels Method
[image]

Sets the labels outside pie/doughnut pieces.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setOuterLabels (
ArrayList<String> outerLabels
)

Parameters

outerLabels

An ArrayList with the labels.

See Also

PieSeries Members
PieSeries Class


com.mindfusion.charting.PieSeries.setPointerLength Method

PieSeries.setPointerLength Method
[image]

Sets the length of the pointer to the OuterLabels.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public void setPointerLength (
float pointerLength
)

Parameters

pointerLength

The length of the pointer.

Remarks

Use setOuterLabels to specify the labels outside pie pieces.

See Also

PieSeries Members
PieSeries Class


com.mindfusion.charting.PieType Class

PieType Class
Remarks See Also
[image]

Identifies possible types a PieSeries can have.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public enum PieType

Remarks

Member | Description
Doughnut | The PieSeries is drawn as a doughnut.
Pie | The PieSeries is drawn as a pie.

Inheritance Hierarchy

java.lang.Enum(E)

See Also

PieType Members


com.mindfusion.charting.PieType Members

PieType Members
[image]

Identifies possible types a PieSeries can have.

The following tables list the members exposed by the PieType type.

See Also

PieType Class


com.mindfusion.charting.ScatterType Class

ScatterType Class
Remarks See Also
[image]

Identifies possible types scatters in a LineSeries can have.

Namespace: com.mindfusion.charting
Package: com.mindfusion.charting

Syntax

Java [image] Copy Code

public enum ScatterType

Remarks

Member | Description
Circle | The scatters are drawn as circles.
Diamond | The scatters are drawn as diamonds.
None | No scatters are drawn.
Square | The scatters are drawn as squares.
Triangle | The scatters are drawn as triangles.

Inheritance Hierarchy

java.lang.Enum(E)

See Also

ScatterType Members


com.mindfusion.charting.ScatterType Members

ScatterType Members
[image]

Identifies possible types scatters in a LineSeries can have.

The following tables list the members exposed by the ScatterType type.

See Also

ScatterType Class


MindFusion Products

MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming | Links
Diagramming for WPF | Product Information Download
Diagramming for Silverlight | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for .NET Compact | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download
DiagramViewer for iOS/Cocoa Touch | Product Information Download
DiagramViewer for Android | Product Information Download

Charting | Links
Charting for WPF | Product Information Download
Charting for Silverlight | Product Information Download
Charting for WinForms | Product Information Download
Charting for ASP.NET | Product Information Download

Scheduling | Links
Scheduling for WinForms | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for .NET Compact | Product Information Download
Scheduling for WPF | Product Information Download
Scheduling for Silverlight | Product Information Download
Scheduling for Java Swing | Product Information Download

Reporting | Links
Reporting for WinForms | Product Information Download
Reporting for WPF | Product Information Download
Reporting for Silverlight | Product Information Download

Mapping | Links
Mapping for WinForms | Product Information Download
Mapping for WPF | Product Information Download
Mapping for Silverlight | Product Information Download

Suites | Links
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Java FX | Product Information Download
Pack for Scheduling | Product Information Download
Pack for Silverlight | Product Information Download


Technical Support

Technical Support

Detailed information about everything connected with software products offered by MindFusion - online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu [image] . The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at support@mindfusion.eu [image] or by phone at +359 889 199 729.

You can post a question on the MindFusion.Charting for Android discussion board here:

http://mindfusion.eu/Forum/YaBB.pl?catselect=mchart_cat

or visit our help desk site:

http://www.mindfusion.eu/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding MindFusion.Charting for Android. We take in account the opinion of every single person who has shown interest in our products.