Introduction

MindFusion.Charting for Silverlight Programmer's Guide
Introduction

MindFusion.Charting for Silverlight is a smart programming tool suitable for creating all types of

  • line / area / stacked area / scatter charts
  • bar / groups of bars / stacked / overlay / column charts
  • pie / doughnut charts
  • radar / polar charts
  • oval and linear gauges

The component is designed to be easy to use, with powerful and intuitive API, various samples and tutorials.

In today’s fast changing, overloaded with information and competition business environment, software engineers face greater and greater challenges. They need more time to learn, to concentrate, to grasp the big picture. By integrating MindFusion's powerful and reliable charting component, you save both time and money, leaving the coding of the charting functionality to MindFusion.

MindFusion.Charting for Silverlight has been tested with the most popular .NET development environments and programming languages C# and VB.NET.

© 2013 MindFusion


What's New in this Release

What's New in this Release

The list below describes recent changes and additions to MindFusion.Charting for Silverlight:

New in Version 1.2

Styles and Themes

Styles define the appearance of a given chart element - the axis, the series, the legend. Each ChartTheme is a collection of styles. With MindFusion.Charting for Silverlight you can now:

  • create themes based on the appearance of an existing chart
  • create themes with the ThemeEditor tool
  • save themes to XML files
  • load themes from XML files
  • use a number of predefined themes.

The "Working with Themes" tutorial gives detailed information on how to create, save, load and edit themes with MindFusion.Charting for Silverlight.

Better Design Time Support

MindFusion.Charting for Silverlight lets you now edit all collection properties, including the Series collection, the brushes and strokes in design time through the property grid.

Axis Intervals

The new AxisSettings.IntervalCount property lets you specify the exact number of intervals at the axis. In such case the control does not use the Interval property and calculates the value of each interval based on AxisSettings.Min, AxisSettings.Max and AxisSettings.IntervalCount.

API Changes

  • ChartSeries.Fills, ChartSeries.Strokes, LineSeries.ScatterFills, LineSeries.ScatterStrokes and other properties that were lists with Brush-es are now of type BrushCollection. The change was required by the new design time support features. The properties that are lists with labels or data values are now of type StringCollection and DoubleCollection respectively.
  • a bug with the Series property in the ChartLegend was fixed.

Important Note:

Due to the extended design time support that we added in this version all predefined data series and brush collections have been removed from the charts. This might lead to exceptions if you reference them. To correct this just create a new instance of the type you are trying to access in the collection.

Wrong:

C# [image] Copy Code

//this will result in an exception, there isn't a predefined series any more.
BarSeries series0 = barChart.Series[0] as BarSeries;

VB.NET [image] Copy Code

'this will result in an exception, there isn't a predefined series any more.
Dim series0 As BarSeries = TryCast(barChart.Series(0), BarSeries)

Correct:

C# [image] Copy Code

BarSeries series0 = new BarSeries();
barChart.Series.Add(series0);

VB.NET [image] Copy Code

Dim series0 As New BarSeries()
barChart.Series.Add(series0)


Version History

Version History

The list below describes recent changes and additions to MindFusion.Charting for Silverlight:

New in Version 1.1

Radar and Polar charts

A brand new type of charts has been added - the radar chart control. It supports:
  • unlimited number of data series
  • 4 types of labels at the inner axis and outer axes
  • label borders
  • customizable sweep angle and sweep direction
  • spiderweb
  • labels for each data series
  • scatters
  • custom labels

Hit testing

MindFusion.Charting for Silverlight supports hit testing. Use the HitTest method, which returns a list of ChartElement objects that contain the specified point. Each chart element has properties that help you identify the data that it represents:
  • PiePiece.PieceIndex and PiePiece.PieceValue get the index of the data this piece represents in the Data for the PieSeries as well its value.
  • Bar.BarIndex and Bar.SeriesIndex get the index of the bar in the series and the index of the series in the Series collection. The Value property gets the value for the bar.
  • Line.SeriesIndex gives you the index of the Line in the Series collection. Points gives you the data for this Line as provided by the user.

Visual Effects

Each chart supports the System.Windows.Media.Effects.DropShadowEffect and System.Windows.Media.Effects.Blur effect. Use the Effect property to specicy the chosen effect.


General Information

General Information

The MindFusion.Charting for Silverlight control

  • Redistribution is royalty free
  • Assembly is strong-named
  • Is digitally signed
  • Can be purchased with source code
  • Is written in C#

Line / Area charts

  • Stacked charts
  • Unlimited number of series
  • Scatter charts
  • Labels at data points
  • Dashed lines
  • Surface charts

Pie / Doughnut charts

  • Detached pieces
  • Customizable inner and outer labels
  • Customizable doughnut thickness

Bar / Column charts

  • 4 different styles
  • Stacked charts
  • Customizable bar width

Radar / Polar charts

  • unlimited number of series
  • labels at the inner axis, outer axis and at data points
  • 4 label types
  • custom labels
  • adjustable start angle and sweep direction
  • scatters at data points
  • spiderweb
  • customizable number of inner and outer axes

Axes

  • 5 label types
  • Rotation of labels
  • Rotation of the title label
  • Custom brushes for the labels and the title
  • Second X-axis
  • Second Y-axis
  • DateTime labels
  • Tick marks
  • Positive and negative values for all axes

Legend

  • Bound to the items in a series or to a collection of series
  • Customizable labels and brushes
  • Border
  • Customizable position and alignment
  • Unlimited number of legends

Grid

  • 5 grid types
  • Customizable grid strokes and fills
  • Customizable width and height of the grid stripes
  • Outline

Data

  • Data binding
  • DateTime values
  • Data arrays
  • Unlimited number of data series in line and bar charts
  • Positive and negative values

Appearance

  • Chart effects
  • Rich choice of pens and brushes
  • Customizable fonts
  • Label background and border

User Interaction

  • Zoom
  • Mouse drag
  • Hit testing

Gauge types

  • Oval gauges
  • Horizontal and vertical gauges

Gauge elements

  • Scales
  • Pointers
  • Ranges
  • Ticks and Labels
  • Indicators
  • Any FrameworkElement object

Miscellaneous

  • Template-based appearance
  • Limitless possibilities for element composition and skinning
  • Several element alignment modes
  • Scalable gauges using relative sizes
  • Predefined templates for quadratic gauges


Programming Interface Overview

Programming Interface Overview


Charts

Charts


Chart Types

Chart Types

MindFusion.Charting for Silverlight supports the following chart type controls that appear as icons in the VisualStudio toolbox:

  • line
  • bar
  • pie
  • radar

Customizing the type of the chart

You can change the type of the chart with LineSeries.LineType, BarSeries.BarType, RadarSeries.RadarStyle and PieSeries.PieType properties. All of them take value from the respective enumerations LineType enum, BarType enum, RadarStyle enum and PieType enum. Radar charts can be radar or polar - use the RadarChart.RadarType property to specify the type. Some chart types require more than one series - BarType.VerticalOverlay, BarType.HorizontalOverlay, BarType.VerticalStack, BarType.HorizontalStack, LineType.Area2DStack. Use the Series property to add the series.

Scatter charts

You can add scatters at data points to any line series. You should only set the LineSeries.ScatterType property of the LineSeries class to be anything different than ScatterType.None, which is its default value. You can draw only scatter charts by setting the LineType of the LineSeries to LineType.None. Scatters can be drawn at data points in radar charts - if you set ShowScatters to true.

Here is a sample that sets the scatter properties in a LineSeries in a line chart. This will be a scatter chart - only scatters will be drawn, no line or area:

C# [image] Copy Code

LineSeries series = lineChart1.Series[0] as LineSeries;
series.LineType = LineType.None;
series.ScatterType = ScatterType.Diamond;
series.ScatterSize = 13.0;
series.ScatterStrokes.Add(new SolidColorBrush(Colors.DarkGray));
series.ScatterStrokeThickness = 1.0;
series.ScatterFills.Add(new SolidColorBrush(Colors.LightGray));

VB.NET [image] Copy Code

Dim series As LineSeries = CType(lineChart1.Series(0),LineSeries)
series.LineType = LineType.None
series.ScatterType = ScatterType.Diamond
series.ScatterSize = 13
series.ScatterStrokes.Add(New SolidColorBrush(Colors.DarkGray))
series.ScatterStrokeThickness = 1
series.ScatterFills.Add(New SolidColorBrush(Colors.LightGray))

Pie / Doughnut charts

They support currently a single PieSeries.


Chart Series

Chart Series

Each graphic on the chart represents a ChartSeries object. It holds data, which is used for calculating the coordinates of the graphics as well various style and appearance properties. All ChartSeries for a chart are kept in the Series property.

The following code creates a new series in a line chart, sets its data and adds it to the Series of the chart:

C# [image] Copy Code

LineSeries lSeries = new LineSeries();
lSeries.Title = "August 2012";
lSeries.XData = new double[] { 12, 23, 35, -1 };
for (int i = 0; i < 4; i++)
lSeries.YData.Add(i);
lineChart1.Series.Add(lSeries);

VB.NET [image] Copy Code

Dim lSeries As LineSeries = New LineSeries
lSeries.Title = "August 2012"
lSeries.XData = New Double() {12, 23, 35, -1}
Dim i As Integer = 0
Do While (i < 4)
lSeries.YData.Add(i)
i = (i + 1)
Loop
lineChart1.Series.Add(lSeries)

Each ChartSeries has a Title property, which shows as a label in the ChartLegend should you use one.

The ChartSeries defines the Fills and Strokes used for painting the chart graphics that corresponds to this series. It also holds properties for labels drawn at the series - LabelFontFamily, LabelFontSize etc.

Line, Radar and Bar charts can have unlimited number of LineSeries and BarSeries. Pie and doughnut charts have just one, which is an instance of PieSeries. The order in which the series are added may influence the appearance of the chart.

Note

When a chart control is dropped at the form, it is created with a default series in it. You should either remove it or modify it according to your needs.


Data

Data

Data Properties

Data for the chart is set with the data properties of the ChartSeries objects. For line and bar charts they are AxesSeries.XData and AxesSeries.YData. For pie charts it is PieSeries.Data. Radar series support Data property for the data and Angles property for the angles if you draw a polar chart.

Data Binding

If you want to set the data with data binding the properties are marked with 'Path' at the end - PieSeries.DataPath, AxesSeries.XDataPath, AxesSeries.YDataPath, RadarSeries.DataPath.

The follwoing example uses an observable collection as a data source for the Y-values of a bar chart. The X-values are numbers:

C# [image] Copy Code

barChart1.DataSource = sales;
BarSeries series = barChart1.Series[0] as BarSeries;
series.YDataPath = "Profit";
series.XData.Clear();
for (int i = 0; i < sales.Count; i++)
series.XData.Add(i);

VB.NET [image] Copy Code

barChart1.DataSource = sales
Dim series As BarSeries = CType(barChart1.Series(0),BarSeries)
series.YDataPath = "Profit"
series.XData.Clear
Dim i As Integer = 0
Do While (i < sales.Count)
series.XData.Add(i)
i = (i + 1)
Loop

Second X-axis and Second Y-axis

The ChartSeries might be bound to the second X-axis or the second Y-axis or both. In this the AxesSeries.X2Data and AxesSeries.Y2Data properties set the data as numbers. If you prefer data binding the properties are AxesSeries.X2DataPath and AxesSeries.Y2DataPath.

Data Format

Data in each series is expected to be one dimensional IList which holds double-s or other that could be converted to double-s with the standard .NET converters and parsers.

DateTime Values

If you want to use DateTime values in your chart you must set the AxisSettings.ValueFormat property to ValueFormat.DateTime. Check the DateTime Values section of this reference for further details on how to use DateTime values.


DateTime Values

DateTime Values

  1. If you want to use DateTime values as X, Y, X2 or Y2 data for your chart you do that the same was as you'd add numeric values. MindFusion.Charting for Silverlight supports DateTime values given in any of these formats:
  • as double values that are representation of a DateTime value in an OLE Automation format.

C# [image] Copy Code

DateTime myDateTime = new DateTime(2011, 12, 1);
lineSeries[0].XData.Add(myDateTime.ToOADate());

VB.NET [image] Copy Code

Dim myDateTime As New DateTime(2011, 12, 1)
lineSeries(0).XData.Add(myDateTime.ToOADate())

  • as DateTime objects

C# [image] Copy Code

DateTime myDateTime = new DateTime(2011, 12, 1);
lineSeries[0].XData.Add(myDateTime);

VB.NET [image] Copy Code

Dim myDateTime As New DateTime(2011, 12, 1)
lineSeries(0).XData.Add(myDateTime)

  • as long integer values that are representation of a DateTime value in ticks.

C# [image] Copy Code

DateTime myDateTime = new DateTime(2011, 12, 1);
lineSeries[0].XData.Add(myDateTime.Ticks);

VB.NET [image] Copy Code

Dim myDateTime As New DateTime(2011, 12, 1)
lineSeries(0).XData.Add(myDateTime.Ticks)

  2. You must set the ValueFormat property of the AxisSettings object for the axis at which DateTime data will be shown to ValueFormat.DateTime:

C# [image] Copy Code

lineChart1.XAxisSettings.ValueFormat = ValueFormat.DateTime;

VB.NET [image] Copy Code

lineChart1.XAxisSettings.ValueFormat = ValueFormat.DateTime

  3. The start and end values of the respective axis must be set to the desired DateTime value. The properties for that - AxisSettings.MinValue and AxisSettings.MaxValue accept only double values. When the AxisSettings.ValueFormat is ValueFormat.DateTime the control expects OLE Automation representation of the values for the properties:

C# [image] Copy Code

DateTime start = new DateTime(2011, 3, 1);
DateTime end = new DateTime(2011, 10, 31);
lineChart1.XAxisSettings.MinValue = start.ToOADate();
lineChart1.XAxisSettings.MaxValue = end.ToOADate();

VB.NET [image] Copy Code

Dim start As New DateTime(2011, 3, 1)
Dim [end] As New DateTime(2011, 10, 31)
lineChart1.XAxisSettings.MinValue = start.ToOADate()
lineChart1.XAxisSettings.MaxValue = [end].ToOADate()

  4. Set the interval. The size of the interval among the scale divisions of the axis depends on the number of divisions we want to see. In the following code the intervals are 10:

C# [image] Copy Code

lineChart1.XAxisSettings.Interval = (end.ToOADate() - start.ToOADate())/10;

VB.NET [image] Copy Code

lineChart1.XAxisSettings.Interval = ([end].ToOADate() - start.ToOADate()) / 10

  5. Format the labels. You must use the AxisSettings.LabelFormat property to specify how the chart will display the DateTime values. All standard .NET format specifiers for DateTime values are supported:

C# [image] Copy Code

lineChart1.XAxisSettings.LabelFormat = "MM-dd-yy";

VB.NET [image] Copy Code

lineChart1.XAxisSettings.LabelFormat = "MM-dd-yy"

  6. Rotate the labels. If the labels are too long you can use the AxisSettings.LabelRotationAngle property to rotate them so they don't overlap:

C# [image] Copy Code

lineChart1.XAxisSettings.LabelRotationAngle = 35;

VB.NET [image] Copy Code

lineChart1.XAxisSettings.LabelRotationAngle = 35

Using DateTime values in a chart is shown in detail in the DateTimeValues sample that is installed with the control.


Labels

Labels

Labels can be displayed for any chart type - line charts display them at data points, bar charts - inside or at the top of bars, pie charts - inside or beside each pie slice.

Title

Each chart can have a title which is set with Chart.Title. If you don't want a title you can hide it with the Chart.TitleVisibility property. Use Chart.TitleFontStyle, Chart.TitleFontFamily, Chart.TitleFontSize and Chart.TitleFontWeight to customize the appearance of the title label.

Line Charts

Line charts show labels at data points with the LineSeries.Labels property. If you want to use data binding, the property is LineSeries.LabelPath.

Bar charts

Bar charts can show labels inside bars depending on the value of the BarSeries.InnerLabelType property. If it is set to LabelType.CustomText, custom labels are specified with BarSeries.InnerLabel. The type of labels at the top of the bars depends on BarSeries.TopLabelType. Custom labels are set with BarSeries.TopLabel. If you want to use data binding for setting the labels the properties are BarSeries.InnerLabelPath and BarSeries.TopLabelPath.

Pie charts

Pie charts can show labels both inside and outside the pieces. The type depends on PieSeries.InnerLabelType and PieSeries.OuterLabelType. If custom labels are drawn, the properties are PieSeries.InnerLabel or PieSeries.OuterLabel as well PieSeries.InnerLabelPath and PieSeries.OuterLabelPath if you use data binding.

Radar charts

Radar charts can show labels at their inner axis, at the outer axis and at data points for each series. Use the InnerLabelType property to specify the labels for the inner axis and OuterLabelType to set the labels for the outer axis. If you need custom labels, use InnerLabels and OuterLabels to specify them. Each RadarSeries has its LabelType property which sets the labels drawn at data points for this series. Custom labels are set with RadarSeries.Labels.

Font Settings

The Font settings for labels drawn at each chart are set with ChartSeries.LabelFontFamily, ChartSeries.LabelFontSize, ChartSeries.LabelFontWeight and ChartSeries.LabelFontStyle.

Number Format

You can set the formt of your numbers with the standard numeric format strings supported by the Silverlight class library. The property for this is AxisSettings.LabelFormat:

C# [image] Copy Code

//format the labels as currency
barChart1.XAxisSettings.LabelFormat = "C";

VB.NET [image] Copy Code

'format the labels as currency
barChart1.XAxisSettings.LabelFormat = "C"


Axes

Axes

I. Charts that use the Cartesian coordinate system - bar, line, area etc.

The XAxisSettings, YAxisSettings, Y2AxisSettings and X2AxisSettings are used for setting the properties of the axes. The labels at each axis depend on the AxisSettings.LabelType property. If the AxisSettings.LabelType is LabelType.CustomText there are two options for placing custom labels:

  • at scale divisions - the AxisSettings.CustomLabelPosition property should be set to CustomLabelPosition.AutoScalePoints
  • at the position of data points - the AxisSettings.CustomLabelPosition property should be set to CustomLabelPosition.ChartDataPoints

The Title property sets the title of the axis. The title is drawn behind the labels. The space between the title and the labels is set with AxisSettings.TitleOffset.

Custom labels for the X, Y, Y2 or X2 axis are specified with the AxesChart.XLabels, AxesChart.YLabels, AxesChart.Y2Labels or AxesChart.X2Labels properties. Of course, you can use data binding - specify the name of the data bound property with AxesChart.XLabelPath, AxesChart.YLabelPath, AxesChart.Y2LabelPath and AxesChart.X2LabelPath.

The sample code demonstrates how to set t title, the label type and the position of the custom labels as well the labels using a data bound property:

C# [image] Copy Code

barChart1.DataSource = sales;
barChart1.XLabelPath = "Products";
barChart1.XAxisSettings.LabelType = LabelType.CustomText;
//place the custom labels at the position of the data
barChart1.XAxisSettings.CustomLabelPosition = CustomLabelPosition.ChartDataPoints;
barChart1.XAxisSettings.Title = "Products";
barChart1.XAxisSettings.TitleOffset = 10;

VB.NET [image] Copy Code

barChart1.DataSource = sales
barChart1.XLabelPath = "Products"
barChart1.XAxisSettings.LabelType = LabelType.CustomText
'place the custom labels at the position of the data
barChart1.XAxisSettings.CustomLabelPosition = CustomLabelPosition.ChartDataPoints
barChart1.XAxisSettings.Title = "Products"
barChart1.XAxisSettings.TitleOffset = 10

II. Polar and Radar charts

Radar and polar charts have two types of axes: inner and outer. The following illustration identifies them:

The inner axis can start from any position - use StartAngle to set where it will be drawn. It can have any type of labels supported by the LabelType enumeration - use InnerLabelType to specify it. The axis is drawn with InnerAxisStroke. You can use InnerStrokeThickness and InnerStrokeDashArray to customize its appearance.

The outer axis is drawn with OuterAxisStroke. It can be customized with OuterStrokeDashArray and OuterStrokeThickness. The labels for it are set with OuterLabelType. Use OuterLabelType to set the type of the labels that will be drawn at the axis.


Legend

Legend

There are no limits as to the count of legend you can add to the chart. They must be added to the Chart.Legends property. MindFusion.Gauges for Silverlight supports two types of legends.

Chart Legend

ChartLegend takes its labels from the ChartSeries.Title property of the ChartSeriesCollection it refers to. Use ChartLegend.Series to set the ChartSeriesCollection. The brushes for the rectangles that are drawn before each label are taken automatically from ChartSeries.Fills. If a given ChartSeries has more than brushes in its Fills property, the first brush is taken.

Here is a sample code that creates a ChartLegend that is bound to the Series collection of the chart.

C# [image] Copy Code

ChartLegend legend = new ChartLegend();
legend.Series = barChart1.Series;
legend.BorderBrush = Brushes.LightGray;
legend.Background = Brushes.White;
barChart1.Legends.Add(legend);

VB.NET [image] Copy Code

Dim legend As New ChartLegend()
legend.Series = barChart1.Series
legend.BorderBrush = Brushes.LightGray
legend.Background = Brushes.White
barChart1.Legends.Add(legend)

Series Legend

SeriesLegend is designed to give details about data in a single ChartSeries. Its labels and brushes are custom-set with the SeriesLegend.LabelsSource and SeriesLegend.BrushesSource properties.

Here is a sample code that creates a SeriesLegend with two brushes and two labels:

C# [image] Copy Code

SeriesLegend legend1 = new SeriesLegend();
legend1.BrushesSource = new List<Brush>() {
new SolidColorBrush(Color.FromArgb(100, 0, 255, 0)),
Brushes.Yellow };
legend1.BorderBrush = Brushes.Silver;
legend1.Background = new SolidColorBrush(Color.FromRgb(240, 240, 240));
legend1.LabelsSource = new List<string>() { "Arina LLC", "Falderia Corp." };
lineChart1.Legends.Add(legend1);

VB.NET [image] Copy Code

Dim legend1 As New SeriesLegend()
legend1.BrushesSource = New List(Of Brush)() From { _
New SolidColorBrush(Color.FromArgb(100, 0, 255, 0)), _
Brushes.Yellow _
}
legend1.BorderBrush = Brushes.Silver
legend1.Background = New SolidColorBrush(Color.FromRgb(240, 240, 240))
legend1.LabelsSource = New List(Of String)() From { _
"Arina LLC", _
"Falderia Corp." _
}
lineChart1.Legends.Add(legend1)

Customizing the Legend's Appearance

The following properties are used to customize how the legend looks:

  • Orientation for specifying whether labels are drawn in a row or column
  • CornerRadius for rounding the edges of the legend's rectangle.
  • Background and BorderBrush

Position of the Legend

You can place the legend anywhere around the plot area where the chart is drawn. The docking of the legend is set with the Dock attached property of the LayoutPanel, which contains both the chart and the legend. The alignment of the legend depends on its position: if its docked to the bottom or the top of the plot area, the alignment is set with the HorizontalAlignment. If the legend is placed at the left or right side of the plot area, its alignment is set with VerticalAlignment.

Here is sample code that palces a legend to the right of the plot area and algns it in the middle:

C# [image] Copy Code

LayoutPanel.SetDock(legend, Dock.Right);
legend.VerticalAlignment = VerticalAlignment.Top;

VB.NET [image] Copy Code

LayoutPanel.SetDock(legend, Dock.Right)
legend.VerticalAlignment = VerticalAlignment.Top

A diagram of the legend classes.


Zoom

Zoom

  1. You can zoom any chart with axes (line, area, bar column etc). by setting the Behavior property of the chart to Behavior.ZoomChart:

C# [image] Copy Code

lineChart1.Behavior = Behavior.ZoomChart;

VB.NET [image] Copy Code

lineChart1.Behavior = Behavior.ZoomChart

  2. If you want to go one step back in zooming out the chart, you must call ZoomOut():

C# [image] Copy Code

lineChart1.ZoomOut()

VB.NET [image] Copy Code

lineChart1.ZoomOut()

  3. You can reset the chart to its original state, before zooming has begun, by calling ResetZoom():

C# [image] Copy Code

lineChart1.ResetZoom();

VB.NET [image] Copy Code

lineChart1.ResetZoom()

  4. To stop the chart from responding with zooming to user actions, set its Behavior property to Behavior.DoNothing:

C# [image] Copy Code

lineChart1.Behavior = Behavior.DoNothing;

VB.NET [image] Copy Code

lineChart1.Behavior = Behavior.DoNothing


Drag

Drag

MindFusion.Charting for Silverlight allows users to change data of a bar in a bar chart or the coordinates of a point in a line chart. This is done by setting the AxesChart.Behavior property to Behavior.AllowXDrag or Behavior.AllowYDrag. The Behavior enumeration allows bitwise combining of its members.

  1. If you want to allow dragging the data point in any direction you should use:

C# [image] Copy Code

lineChart1.Behavior = Behavior.AllowXDrag | Behavior.AllowYDrag;

VB.NET [image] Copy Code

lineChart1.Behavior = Behavior.AllowXDrag Or Behavior.AllowYDrag

In bar charts you should only allow dragging in the direction of the bar - for horizontal bars this is Behavior.AllowXDrag, for vertical it is Behavior.AllowYDrag.

  2. If you want to stop the drag behavior you should set the property to Behavior.DoNothing:

C# [image] Copy Code

lineChart1.Behavior = Behavior.DoNothing;

VB.NET [image] Copy Code

lineChart1.Behavior = Behavior.DoNothing

  3. When the chart is dragged a thin red line appears to indicate the contour of the resulting graphic. If the graphic is dragged beyond values currently visible at the axes, the axes is rescaled automatically.


Hit testing

Hit testing

Hit testing is done with the HitTest method. You must give a point for which to test and the method will return a list of the ChartElement objects that contain this point. The ChartElement can be either Bar, Line, Scatter or PiePiece. Each ChartElement has Index and SeriesIndex properties, which allow you to recognize the series that this chart element belongs to.

The location of the data that the ChartElement represents in the data list for the series can be get with the Bar.BarIndex, Scatter.ScatterIndex, PiePiece.PieceIndex and Line.Points properties.

The following code tests which bar the user has clicked. It uses the MouseLeftButtonUp event:

C# [image] Copy Code

private void barChart1_MouseLeftButtonUp(object sender, MouseButtonEventArgs e)
{
Point p = e.GetPosition(barChart1);
List<ChartElement> list = barChart1.HitTest(p);

foreach (ChartElement element in list)
{
if (element is Bar)
{
Bar bar = element as Bar;
int seriesIndex = bar.SeriesIndex;
int dataIndex = bar.BarIndex;
MessageBox.Show(seriesIndex.ToString() + " " + dataIndex.ToString());
}
}
}

VB.NET [image] Copy Code

Private Sub barChart1_MouseLeftButtonUp(sender As Object, e As MouseButtonEventArgs)
Dim p As Point = e.GetPosition(barChart1)
Dim list As List(Of ChartElement) = barChart1.HitTest(p)

For Each element As ChartElement In list
If TypeOf element Is Bar Then
Dim bar As Bar = TryCast(element, Bar)
Dim seriesIndex As Integer = bar.SeriesIndex
Dim dataIndex As Integer = bar.BarIndex
MessageBox.Show(seriesIndex.ToString() & " " & dataIndex.ToString())
End If
Next
End Sub


Gauges

Gauges


Gauges

Gauges

MindFusion.Charting for Silverlight provides two type of gauge controls - oval and linear. The two types of gauges are represented by the OvalGauge and LinearGauge classes respectively. The purpose of the gauge controls is to visualize various quantities in two layouts - circular and linear.

Structure

The most important component of each gauge control are the scales contained within it. The scales are collections of gauge elements such as ticks, labels, pointers, and so on. The scales provide interactivity and animation. The gauges are merely shells, which provide visual decoration to the shells nested within them. The following example demonstrates how to define a simple OvalGauge control with a single oval scale in it in XAML:

XAML [image] Copy Code

<gauges:OvalGauge>
<gauges:OvalScale />
</gauges:OvalGauge>

The example (and all following examples hereafter) assumes that the gauges namespace is defined as following:

XAML [image] Copy Code

xmlns:gauges="clr-namespace:MindFusion.Gauges.Silverlight;assembly=MindFusion.Gauges.Silverlight"

Running the example will yield a result similar to the image below:

Removing the scale from the above gauge and running the application again will result in an empty gauge control.

Scales

As previously mentioned the scales can contain ticks, labels, pointers, ranges and other elements. There are two types of scale corresponding to the two types of gauges - OvalScale and LinearScale, which share a common base class - BaseScale. The oval scale distributes its elements in a circle and the linear scale distributes its elements along a horizontal or vertical axis.

Although it is possible to add oval scales to a linear gauge control and linear scales to an oval gauge control, this is not a common scenario. The scales are responsible for arranging their contents. They also provide user interaction and pointer animation.

The following example adds a pointer to the gauge defined in the previous section:

XAML [image] Copy Code

<gauges:OvalGauge>
<gauges:OvalScale>
<gauges:OvalScale.Pointers>
<gauges:Pointer />
</gauges:OvalScale.Pointers>
</gauges:OvalScale>
</gauges:OvalGauge>

Running the application now will produce the following result:

To learn more about gauge scales, refer to the Scales topic.

Composition

Gauge controls can contain more than just one scale. A common scenario is an oval gauge containing several concentric scales displaying different measures. The following example illustrates an oval gauge control with two concentric scales:

XAML [image] Copy Code

<gauges:OvalGauge>

<gauges:OvalScale />

<gauges:OvalScale Margin="50" Fill="Transparent" Stroke="Transparent" FunctionType="Logarithmic">
<gauges:OvalScale.MajorTickSettings>
<gauges:MajorTickSettings LabelFormat="0" TickShape="Rectangle" Fill="Gray" />
</gauges:OvalScale.MajorTickSettings>
<gauges:OvalScale.MiddleTickSettings>
<gauges:MiddleTickSettings ShowTicks="False" ShowLabels="False" />
</gauges:OvalScale.MiddleTickSettings>
<gauges:OvalScale.MinorTickSettings>
<gauges:MinorTickSettings ShowTicks="False" />
</gauges:OvalScale.MinorTickSettings>
</gauges:OvalScale>

</gauges:OvalGauge>

The second scale in the example has a fixed margin so that it does not overlap the first scale. The following image demonstrates the gauge:

Gauge controls are not limited to the type of scales that can be added to them. Linear scales can be added to oval gauges and oval scales can be added to linear gauges, although this is not common. What is more, any Silverlight FrameworkElement can be added to a gauge. This can be especially useful for arranging scales within the gauge by employing the appropriate panels. In the example above, increasing the size of the gauge will cause the scales to overlap because the inner scale has a fixed margin. This can be resolved by using a Grid panel as a parent of the inner scale as illustrated by the example below:

XAML [image] Copy Code

<gauges:OvalGauge>

<gauges:OvalScale />

<Grid>
<Grid.RowDefinitions>
<RowDefinition />
<RowDefinition Height="3*" />
<RowDefinition />
</Grid.RowDefinitions>
<Grid.ColumnDefinitions>
<ColumnDefinition />
<ColumnDefinition Width="3*" />
<ColumnDefinition />
</Grid.ColumnDefinitions>

<gauges:OvalScale Fill="Transparent" Stroke="Transparent" FunctionType="Logarithmic" Grid.Column="1" Grid.Row="1">
<!-- Scale settings -->
</gauges:OvalScale>

</Grid>

</gauges:OvalGauge>

Resizing the gauge now will be consistent.

Custom Gauges

The customization of the gauge controls can be achieved by using custom control templates. A simple control template is provided in the following example.

XAML [image] Copy Code

<Style TargetType="gauges:OvalGauge">
<Setter Property="Template">
<Setter.Value>
<ControlTemplate TargetType="gauges:OvalGauge">
<gauges:CenterPanel>
<Ellipse Stroke="DarkSlateBlue" StrokeThickness="4" Stretch="Uniform">
<Ellipse.Fill>
<RadialGradientBrush Center="0.3,0.3">
<GradientStop Offset="0" Color="White" />
<GradientStop Offset="1" Color="LightSteelBlue" />
</RadialGradientBrush>
</Ellipse.Fill>
</Ellipse>
<Ellipse Stretch="Uniform">
<Ellipse.Fill>
<RadialGradientBrush>
<GradientStop Offset="0.75" Color="#00000000" />
<GradientStop Offset="1" Color="#60000000" />
</RadialGradientBrush>
</Ellipse.Fill>
</Ellipse>
<ItemsPresenter />
</gauges:CenterPanel>
</ControlTemplate>
</Setter.Value>
</Setter>
</Style>

The above template simply adds to concentric ellipses as a background of the gauge. Applying the template on an oval gauge with a scale and a pointer within it will produce the following result:

Built-in Gauge Templates

There are several built-in templates for quadratic gauges in different orientations. Each built-in template is encapsulated in a separate resource dictionary. In order to use the custom templates, its corresponding resource dictionary needs to be merged in the application. The following table lists the predefined gauge templates and the names of their respective resource dictionaries.

Template | Dictionary Name
Quadratic North-West | /MindFusion.Gauges.Silveright;component/Themes/OvalGaugeNW.xaml
Quadratic North-East | /MindFusion.Gauges.Silverlight;component/Themes/OvalGaugeNE.xaml
Quadratic South-East | /MindFusion.Gauges.Silverlight;component/Themes/OvalGaugeSW.xaml
Quadratic South-West | /MindFusion.Gauges.Silverlight;component/Themes/OvalGaugeNE.xaml

Each dictionary contains two styles - one for the gauge control and one for the scales contained in it. The keys of the styles are displayed in the table below:

Template | Gauge Style Key | Scale Style Key
Quadratic North-West | OvalGaugeStyleNW | OvalScaleStyleNW
Quadratic North-East | OvalGaugeStyleNE | OvalScaleStyleNE
Quadratic South-East | OvalGaugeStyleSW | OvalScaleStyleSW
Quadratic South-West | OvalGaugeStyleSE | OvalScaleStyleSE

To use the built-in templates, the resource dictionary should be merged within the application. The following example merges the dictionary containing the North-West quadratic gauge templates.

XAML [image] Copy Code

<Window.Resources>
<ResourceDictionary>
<ResourceDictionary.MergedDictionaries>
<ResourceDictionary Source="/MindFusion.Gauges.Silverlight;component/Themes/OvalGaugeNW.xaml" />
</ResourceDictionary.MergedDictionaries>
</ResourceDictionary>
</Window.Resources>

After that the styles in the dictionary can be referenced as static resources:

XAML [image] Copy Code

<gauges:OvalGauge Style="{StaticResource OvalGaugeStyleNW}">

<gauges:OvalScale Style="{StaticResource OvalScaleStyleNW}">
<gauges:OvalScale.Pointers>
<gauges:Pointer Value="10" />
</gauges:OvalScale.Pointers>
</gauges:OvalScale>

</gauges:OvalGauge>

Running the application will produce the following result:


Scales

Scales

As discussed in the Gauges topic, the scales are the most important component of a gauge. The scales display ticks and labels, they arrange and animate pointers and also maintain ranges and other auxiliary elements. There are two types of scales - oval and linear. The oval scale distributes its elements in a circle, the linear scale distributes its element on a vertical or horizontal axis depending on its orientation. The oval and linear scales are represented by the OvalScale and LinearScale classes respectively. These classes share a common base class - BaseScale and apart from the difference in their layout logic they are very similar.

Default Template

The following XAML shows the default template for the scale classes.

XML [image] Copy Code

<ControlTemplate>
<Grid Background="Transparent">
<Path Name="ScalePath" Fill="{TemplateBinding Fill}" Stroke="{TemplateBinding Stroke}" StrokeThickness="{TemplateBinding StrokeThickness}" />
<Grid Name="RangeContainer" />
<Grid Name="TickContainer" />
<Grid Name="LabelContainer" />
<ItemsPresenter />
<Grid Name="PointerContainer">
<Grid.Effect>
<DropShadowEffect Opacity="0.3" ShadowDepth="2" />
</Grid.Effect>
</Grid>
</Grid>
</ControlTemplate>

As can be observed in the template the scales have several named parts. The following table lists them.

Part | Type | Description
ScalePath | Path | A Silverlight Path object which renders the scale geometry.
RangeContainer | Grid | A Silverlight Grid panel which acts as a container of the Range objects added to the scale.
TickContainer | Grid | A Silverlight Grid panel which acts as a container of the scale ticks.
LabelContainer | Grid | A Silverlight Grid panel which acts as a container of the scale labels.
PointerContainer | Grid | A Silverlight Grid panel which acts as a container of the Pointer objects added to the scale.

The appearance order of the scale elements can be modified by replacing the scale template with another template in which the element containers are rearranged accordingly.

Customization

Geometry

The scales display a geometry according to its type. The elements displayed in the scale are aligned and arranged relative to the scale geometry. The geometry is either circular, for oval scale, or trapezial, for linear scales. The following figures show the geometries of oval and horizontal and vertical linear scales.

Oval | Horizontal Linear | Vertical Linear

The scale geometry can be customized through various properties. The fill and stroke of the geometry are defined by the Fill, Stroke and StrokeThickness properties. The start and end width are specified through the StartWidth and EndWidth properties. These properties are of type Length and can express relative values. See the Metrics section at the end of this topic for additional information regarding this. The start and end angles of the oval geometry can be specified through the StartAngle and EndAngle properties of the OvalScale class respectively. Both properties are expressed in degrees.

Data

The MinValue and MaxValue properties can be used to define the range of values displayed on the scale. The distribution of the values along the scale geometry is determined by the FunctionType property and can be Linear, Logarithmic or Custom. The base of the logarithmic distribution is specified through the LogarithmBase property. The custom value distribution function is supplied through the CustomFunction and ReversedCustomFunction properties.

Scale Elements

Various elements can be added to a scale, including ticks, labels and pointers.

Ticks and Labels

The ticks and labels represent cornerstones along the scale, usually round values. The ticks and labels are created and added to the scales implicitly according to the specified settings. There are three categories of ticks and labels - major, middle and minor. Each category has corresponding settings, exposed respectively by the MajorTickSettings, MiddleTickSettings and MinorTickSettings properties of the BaseScale class. These settings provide properties for specifying the number of ticks along the scale, their alignment and appearance, the format of their associated label, and more. For additional information about ticks and labels refer to the Ticks and Labels topic.

Pointers

The pointers represent needles or similar types of indicators within the scale. They are used to visualize a current measurement within the scale. For example, in a car speedometer the pointers are used to indicate the current speed. Pointers can be added to the scale through the Pointers property. Pointers expose numerous properties that can be used to customize their appearance. For additional information check the Pointers topic.

Ranges

The ranges emphasize portions of the scale which represent particular interest. An example of a range is the red zone of a car cyclometer. Ranges are added to the scale through the Ranges property. For extensive information on how to use and setup ranges, refer to the Ranges topic.

Miscellaneous

In addition to the elements discussed so far, scales can host any Silverlight FrameworkElement. The following code demonstrates how to add a Silverlight Path to a scale.

XML [image] Copy Code

<gauges:OvalScale>
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="4*" />
<ColumnDefinition Width="1*" />
<ColumnDefinition Width="4*" />
</Grid.ColumnDefinitions>
<Grid.RowDefinitions>
<RowDefinition Height="2.5*" />
<RowDefinition Height="1*" />
<RowDefinition Height="5.5*" />
</Grid.RowDefinitions>
<Path Data="M125,5 L155,90 L245,90 L175,145 L200,230 L125,180 L50,230 L75,145 L5,90 L95,90 z" Grid.Row="1" Grid.Column="1" Stroke="Black" Fill="Lime" Stretch="Uniform" />
</Grid>
</gauges:OvalScale>

The above XAML will render a scale similar to this image:

Interaction

Users can interactively adjust the value of the pointers in the scale by clicking anywhere within the scale bounds. Interactivity only applies to pointers with IsInteractive property set to true. When the value of a pointer is changed interactively, the ValueChanged of the pointer is raised.

Animation

Scales enable animations and interactivity of the pointers contained within them. The animation is enabled through the EnableAnimation property but only applies to pointers with IsAnimated set to true. Oval scales, which represent continuous intervals (for example clocks), can enable animation across scale boundaries by setting AnimateThroughSmallerArc property to true.

Metrics

The sizes of various scale elements can be specified either relatively to the size of the scale or as absolute values. This applies to all properties of type Length. Expressing a relative value in XAML can be achieved by appending the percent sign (%) at the end of the value. The following example defines a pointer with relative width and height in XAML:

XAML [image] Copy Code

<gauges:Pointer PointerWidth="100%" PointerHeight="50%" />

Relative sizes are calculated differently depending on the type of scale. In oval scales relative sizes are calculated based on the radius of the scale. Therefore the above pointer will extend from the center to the outer edge of the scale. In linear scales sizes are based on the width or height of the scale depending on the scale orientation.


Ticks and Labels

Ticks and Labels

There are three categories of ticks and labels in a scale - major, middle and minor. Each category is governed by a separate settings object in the BaseScale class - MajorTickSettings, MiddleTickSettings and MinorTickSettings.

The number of ticks from a specific category can be specified in either of two ways:

  • By setting the Count property to the desired number of ticks.
  • By setting the Step property to the desired quantity between adjacent ticks.

If both of the above properties are specified Step will take precedence. The ticks and/or labels in a particular category can be hidden through the ShowTicks and ShowLabels properties of the respective settings objects.

Here is a table with some examples illustrating various combinations of the above properties, applied on an oval scale with MinValue set to 0 and MaxValue set to 100:

Settings | Scale
MajorTickSettings Count = 5 MiddleTickSettings Count = 3 ShowLabels = false MinorTickSettings ShowTicks = false |
MajorTickSettings Step = 15 MiddleTickSettings Count = 4 ShowLabels = false MinorTickSettings Count = 2 |
MajorTickSettings Count = 10 MiddleTickSettings Count = 1 ShowLabels = False MinorTickSettings Step = 2 |

Alignment

The alignment of ticks and labels relative to the scale geometry is specified through the TickAlignment and LabelAlignment properties. The following scheme illustrates the possible alignment modes in an oval scale:

The pale blue lane at the background represents an oval scale, the orange line represents the center of the scale and the green objects are the elements being aligned to the scale using different alignment modes. The center of each element is illustrated in light green color. The alignment modes used for each of the elements in the scheme is specified below:

  1. InnerInside
  2. InnerCenter
  3. InnerOutside
  4. CenterInside
  5. TrueCenter
  6. CenterOutside
  7. OuterInside
  8. OuterCenter
  9. OuterOutside

The position of the aligned elements can be further adjusted through their offset, specified respectively by the TickOffset and LabelOffset properties.

Label Rotation

The following schemes illustrates all possible label rotation modes in an oval scale.

Auto | BaselineAwayFromCenter | BaselineToCenter | None | Sideways

Appearance

The fill and stroke of the ticks are specified through the Fill, Stroke and StrokeThickness properties. The TickShape specifies the shape of the ticks. There are several predefined shapes available. The size of the ticks is controlled by the TickWidth and TickHeight properties and can be specified as either relative or absolute value.

The foreground color of the labels can be specified through the LabelForeground property. The size of the label font is set through the FontSize property. FontSize is of type Length and can express relative sizes. The other font attributes of the labels are specified from the FontFamily, FontSize and FontWeight properties of the containing scale.

Custom Intervals

It is possible to customize the appearance of the ticks in a specific interval by using CustomInterval objects. To initialize the custom interval, set its MinValue and MaxValue properties to reflect the range of ticks this interval will apply to, then use its Fill, Stroke and StrokeThickness properties to specify explicit fill and stroke for the ticks in this interval. Finally add the custom interval to the CustomIntervals collection of the respective TickSettings.

Below is an example of a custom interval defined in XAML. The custom interval specifies red background for all major ticks of an oval scale in the range [10..50].

XAML [image] Copy Code

<gauges:OvalScale>
<gauges:OvalScale.MajorTickSettings>
<gauges:MajorTickSettings>
<gauges:MajorTickSettings.CustomIntervals>
<gauges:CustomInterval MinValue="10" MaxValue="50" Fill="Red" />
</gauges:MajorTickSettings.CustomIntervals>
</gauges:MajorTickSettings>
</gauges:OvalScale.MajorTickSettings>
</gauges:OvalScale>

Custom Labels

The text of the labels can be customized beyond simple formatting of the value associated with them. This can be achieved by handling the QueryLabelValue event of the BaseScale class. The handlers of this event will receive an instance of the QueryLabelValueEventArgs class. The new label value can be assigned to the NewValue property of this instance.


Pointers

Pointers

The pointers represent needles or similar type of indicators within the scale. They are used to visualize a current measurement within the scale. The most important member of the pointer object is its Value. The pointer is automatically adjusted by its containing scale so that it points to the scale location, corresponding to its value.

The size of the pointer is defined by the PointerWidth and PointerHeight properties. These properties can express the size as relative or absolute value. The location of the pointer can be adjusted through the PointerOffset property and its alignment in a linear scale can be specified through the Alignment property.

The pointer can be made interactive by setting the IsInteractive property to true. Clicking with the mouse within a scale causes all its interactive pointers to be adjusted to the value corresponding to the clicked point. A pointer can be made discrete by setting IsDiscrete to true. The value of a discrete pointer is always integer.

Usage

The sample code below illustrates how to define and add pointers to a linear scale in XAML:

XAML [image] Copy Code

<gauges:LinearGauge Orientation="Horizontal">
<gauges:LinearScale Orientation="Horizontal">
<gauges:LinearScale.Pointers>
<gauges:Pointer IsInteractive="True" />
</gauges:LinearScale.Pointers>
</gauges:LinearScale>
</gauges:LinearGauge>

Custom Appearance

The appearance of the pointer can be customized by using a custom ControlTemplate. The following example demonstrates an oval gauge with a compass needle type of pointer:

XAML [image] Copy Code

<gauges:OvalGauge>

<gauges:OvalScale Fill="Transparent" Stroke="Transparent" StartAngle="0" EndAngle="360" AnimateThroughSmallerArc="True">
<gauges:OvalScale.Pointers>

<gauges:Pointer PointerWidth="180%" PointerHeight="20%" PointerOffset="80%" IsInteractive="True" IsAnimated="True" Value="75">
<gauges:Pointer.Template>
<ControlTemplate TargetType="gauges:Pointer">
<Grid>
<Grid.RowDefinitions>
<RowDefinition Height="3*" />
<RowDefinition Height="4*" />
<RowDefinition Height="3*" />
</Grid.RowDefinitions>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="48*" />
<ColumnDefinition Width="2*" />
<ColumnDefinition Width="2*" />
<ColumnDefinition Width="48*" />
</Grid.ColumnDefinitions>

<Polygon Grid.Column="2" Grid.ColumnSpan="2" Grid.RowSpan="3" Points="0,0 1,0.5 0,1" Stretch="Fill">
<Polygon.Fill>
<LinearGradientBrush StartPoint="0.5,0" EndPoint="0.5,1">
<GradientStop Offset="0" Color="#990000" />
<GradientStop Offset="0.3" Color="#FF0000" />
<GradientStop Offset="1" Color="#660000" />
</LinearGradientBrush>
</Polygon.Fill>
</Polygon>
<Polygon Grid.ColumnSpan="2" Grid.RowSpan="3" Points="1,0 0,0.5 1,1" Stretch="Fill">
<Polygon.Fill>
<LinearGradientBrush StartPoint="0.5,0" EndPoint="0.5,1">
<GradientStop Offset="0" Color="#999999" />
<GradientStop Offset="0.3" Color="#CCCCCC" />
<GradientStop Offset="1" Color="#666666" />
</LinearGradientBrush>
</Polygon.Fill>
</Polygon>
<Polygon Grid.ColumnSpan="4" Grid.RowSpan="3" Points="0,0.5 0.5,0 1,0.5 0.5,1" Stretch="Fill" Stroke="#202020" />
<Ellipse Grid.Column="1" Grid.ColumnSpan="2" Grid.Row="1" Fill="DimGray" Stroke="Black" StrokeThickness="1" />

</Grid>
</ControlTemplate>
</gauges:Pointer.Template>
</gauges:Pointer>
</gauges:OvalScale.Pointers>

<gauges:OvalScale.MajorTickSettings>
<gauges:MajorTickSettings ShowTicks="False" ShowLabels="False" />
</gauges:OvalScale.MajorTickSettings>
<gauges:OvalScale.MiddleTickSettings>
<gauges:MiddleTickSettings ShowTicks="False" ShowLabels="False" />
</gauges:OvalScale.MiddleTickSettings>
<gauges:OvalScale.MinorTickSettings>
<gauges:MinorTickSettings ShowTicks="False" ShowLabels="False" />
</gauges:OvalScale.MinorTickSettings>

</gauges:OvalScale>

</gauges:OvalGauge>

The above gauge will look similar to the following image:


Ranges

Ranges

The range is a visual representation of an interval within a gauge. Ranges are commonly used to mark or emphasize specific zones on the scale. Often the end of the scale is a danger zone and a range can be used to indicate this. The following image illustrates an oval gauge with three ranges (red, yellow and green) specifying different zones on the scale.

The range interval is specified through the MinValue and MaxValue properties. The Alignment and Offset properties control the positioning and the StartWidth and EndWidth properties specify the size of the range. The range can be auto-sized to the scale by setting AutoSize to true. To learn more about the different alignment modes check the Ticks and Labels topic.

Appearance

The Fill, Stroke and StrokeThickness properties can be used to specify the appearance of the range.

Usage

The sample code below illustrates how to define and add ranges to a linear scale in XAML:

XAML [image] Copy Code

<gauges:LinearGauge Orientation="Horizontal">

<gauges:LinearScale Orientation="Horizontal">
<gauges:LinearScale.Ranges>
<gauges:Range MinValue="70" MaxValue="80" StartWidth="0" EndWidth="5%" Fill="Yellow" Stroke="DimGray" StrokeThickness="1" Alignment="OuterOutside" Offset="-2" />
<gauges:Range MinValue="80" MaxValue="90" StartWidth="5%" EndWidth="10%" Fill="orange" Stroke="DimGray" StrokeThickness="1" Alignment="OuterOutside" Offset="-2" />
<gauges:Range MinValue="90" MaxValue="100" StartWidth="10%" EndWidth="15%" Fill="Red" Stroke="DimGray" StrokeThickness="1" Alignment="OuterOutside" Offset="-2" />
</gauges:LinearScale.Ranges>
</gauges:LinearScale>

</gauges:LinearGauge>

The linear gauge defined above will look like this:


Indicators

Indicators

The indicator is a gauge element, which changes its appearance based on its Value property and its defined states. The states of the indicator are specified as CustomInterval objects and are located in the States collection. When the value of the indicator falls within one of its defined states, this state becomes active and its Fill, Stroke and StrokeThickness properties are applied to the indicator automatically. In addition, the attached property ActiveColor is applied as a glow color of the indicator. If the value of the indicator does not fall in any of the defined states, then the DefaultState becomes active.

A common scenario is to bind the Value property of the indicator to the Value of a Pointer object, thus when the value of the pointer is modified, the state of the indicator changes to reflect this.

Usage

The sample code below illustrates how to define and add indicators to a scale in XAML:

XAML [image] Copy Code

<gauges:OvalGauge>
<gauges:OvalScale>
<gauges:OvalScale.Pointers>
<gauges:Pointer Name="pointer" IsInteractive="True" />
</gauges:OvalScale.Pointers>
<Grid>
<Grid.ColumnDefinitions>
<ColumnDefinition Width="4*" />
<ColumnDefinition />
<ColumnDefinition Width="4*" />
</Grid.ColumnDefinitions>
<Grid.RowDefinitions>
<RowDefinition Height="6*" />
<RowDefinition />
<RowDefinition Height="2*" />
</Grid.RowDefinitions>
<gauges:Indicator Grid.Row="1" Grid.Column="1" Value="{Binding Value, ElementName=pointer}">
<gauges:CustomInterval MinValue="80" MaxValue="100" Fill="Red" />
</gauges:Indicator>
</Grid>
</gauges:OvalScale>
</gauges:OvalGauge>

The oval gauge defined above will look like this:


Tutorials

Tutorials


Working with Themes

Working with Themes

With MindFusion.Charting for Silverlight you can:

  • Create custom themes based on the appearance of an existing chart;
  • Save a custom theme as an XML file;
  • Load a custom theme from its XML file;
  • Use a number of predefined themes.

I. Create a custom theme based on the appearance of an existing chart.

1. Style your chart as you want. In our sample we will use a BarChart. We set a background, font settings for the title, brushes for the grid and customize the outline of the chart:

C# [image] Copy Code

BarChart modelChart = new BarChart()
{
Background = new SolidColorBrush(Colors.LightGray),
BorderThickness = new Thickness(5),
CornerRadius = new CornerRadius(5),
TitleFontSize = 18,
TitleFontWeight = FontWeights.Bold,
TitleFontFamily = new FontFamily("Tahoma"),
GridFills = new BrushCollection() { new SolidColorBrush(Colors.LightGray),
new SolidColorBrush(Colors.Gray) },
GridStrokes = new BrushCollection() { new SolidColorBrush(Colors.Gray)},
PlotAreaStroke = new SolidColorBrush(Colors.Gray)
};

VB.NET [image] Copy Code

Dim modelChart As New BarChart() With { _
Key .Background = New SolidColorBrush(Colors.LightGray), _
Key .BorderThickness = New Thickness(5), _
Key .CornerRadius = New CornerRadius(5), _
Key .TitleFontSize = 18, _
Key .TitleFontWeight = FontWeights.Bold, _
Key .TitleFontFamily = New FontFamily("Tahoma"), _
Key .GridFills = New BrushCollection() From { _
New SolidColorBrush(Colors.LightGray), _
New SolidColorBrush(Colors.Gray) _
}, _
Key .GridStrokes = New BrushCollection() From { _
New SolidColorBrush(Colors.Gray) _
}, _
Key .PlotAreaStroke = New SolidColorBrush(Colors.Gray) _
}

2. Next, we set the colors for the bars in a BarSeries. We add the series to the chart:

C# [image] Copy Code

BarSeries series = new BarSeries()
{
XData = new DoubleCollection() { 1, 2, 3, 4 },
YData = new DoubleCollection() { 23, 13, 34, 51 },
Fills = new BrushCollection(){new SolidColorBrush(Colors.Green)},
Strokes = new BrushCollection() { new SolidColorBrush(Colors.Purple) }
};

modelChart.Series.Add(series);

VB.NET [image] Copy Code

Dim series As New BarSeries() With { _
Key .XData = New DoubleCollection() From { 1, 2, 3, 4 }, _
Key .YData = New DoubleCollection() From { 23, 13, 34, 51 }, _
Key .Fills = New BrushCollection() From { _
New SolidColorBrush(Colors.Green) _
}, _
Key .Strokes = New BrushCollection() From { _
New SolidColorBrush(Colors.Purple) _
} _
}

modelChart.Series.Add(series)

3. We finally create a new ChartTheme based on the model and we apply this theme to the chart we already have - barChart1.

C# [image] Copy Code

//create the theme
ChartTheme theme = new ChartTheme(modelChart);

//apply the theme
theme.Apply(barChart1);

VB.NET Copy Code

'create the theme
Dim theme As New ChartTheme(modelChart)

'apply the theme
theme.Apply(barChart1)

II. Save a custom theme as a XML file.

In the installation folder of the component you will find the ThemeEditor tool. Use it to create, edit, load and save ChartTheme-s on your computer. There is a shortcut to the ThemeEditor from the MindFusion.Charting for Silverlight items group in your start menu.

III. Load a theme from a XML file.

Important!

Add the XML file to your Silverlight project and set it its BuildAction to "Resource".

Use the following code to load and apply the ChartTheme. Here we load the theme Green.xml and apply it to out chart called barChart1:

C# [image] Copy Code

StreamResourceInfo stream = Application.GetResourceStream(
new Uri("SilverlightApplication1;component/Resources/Green.xml", UriKind.Relative));

ChartTheme theme = new ChartTheme();
theme.LoadFromXml(stream.Stream);
theme.Apply(barChart1);

VB.NET Copy Code

Dim stream As StreamResourceInfo = Application.GetResourceStream(New Uri("SilverlightApplication1;component/Resources/Green.xml", UriKind.Relative))

Dim theme As New ChartTheme()
theme.LoadFromXml(stream.Stream)
theme.Apply(barChart1)

IV. Predefined themes.

MindFusion.Charting for Silverlight offers a set of predefined themes, which are found in the setup directory. You can load them the way you would load any XML ChartTheme - see point III.

The predefined Green theme applied on a bar chart.


Reference

Reference


MindFusion.Charting.Silverlight Namespace

MindFusion.Charting.Silverlight Namespace
Classes Delegates Enumerations

Classes

Class | Description
Annotation | Represents an anotation at a chart element.
AnnotationsCollection | Represents an observable collection of Annotation objects.
AxesChart | Base class for charts which support the Cartesian coordinate system.
AxesSeries | Base class for series of charts that support the Cartesian coordinate system.
AxisSettings | Gets or sets the settings of a chart axis.
Bar | Represents a bar in charts that show bars.
BarChart | Represents a bar chart.
BarSeries | Represents a series in a bar chart.
BrushCollection | Represents an observable collection of System.Windows.Media.Brush objects.
CanvasInitializedEventArgs | Provides data for events that are raised when canvas is initialized.
CanvasSizeInitializedEventArgs | Provides data for events that are raised when canvas size is initialized.
Chart | Base class for all charts.
ChartElement | Base class for all graphical elements on the chart.
ChartLegend | Describes a legend where each item gives info about a ChartSeries.
ChartSeries | Base class for series in the chart.
ChartSeriesCollection | Represents an observable collection of ChartSeries objects.
ChartSeriesToBrushConverter | Returns the Brush that corresponds to the given ChartSeries.
ChartSeriesToStrokeConverter | Returns the Stroke that corresponds to the given ChartSeries.
ChartTheme | Represents an appearance theme for the chart.
ChartValueConverter | Provides capabilities to convert various types to and from strings in a cutlure-independent way.
DoubleCollectionConverter | Provides a unified way of converting values of the DoubleCollection type to other types.
LayoutPanel | Represents the panel of the whole chart.
Legend | A base class for classes that represent chart legends.
LegendItem | Represents an item in a SeriesLegend.
LegendsCollection | Represents an observable collection of Legend objects.
Line | Represents a line in line charts.
LineChart | Represents a line chart.
LineSeries | Represents a series in a line chart.
PieChart | Represents a pie chart.
PiePiece | Represents a slice in a pie chart.
PieSeries | Represents a series in a pie chart.
PlotArea | Represents the plot area where the chart is drawn.
RadarChart | Represents a radar chart.
RadarSeries | Represents a series in a radar chart.
RotatedLabel | Represents a text label, which can be rotated.
Scatter | Represents scatter objects drawn at data points in line charts.
SeriesLegend | Represents a legend with custom labels and colors.
StringCollection | Represents an observable collection of string objects.
StringCollectionConverter | Converts StringCollection objects to and from strings.
XmlSerializationContext | Contains methods that can help you serialize and deserialize MindFusion.Charting for Silverlight items to and from XML documents.

Delegates

Delegate | Description
CanvasInitializedEventHandler | Delegate for the CanvasInitialized event.
PlotArea.CanvasInitializedHandler | A delegate for the PlotAreaCanvasInitialized event.
PlotArea.CanvasSizeInitializedHandler | A delegate for the CanvasSizeInitialized event.

Enumerations

Enumeration | Description
AnnotationType | Represents types of Annotation-s that are drawn.
BarType | Specifies the types of bar charts supported by the control.
Behavior | Defines values that specify how the component responds to actions performed by the user.
CustomLabelPosition | Specifies where custom labels are drawn at the chart axis.
Dock | Specifies the docking of elements in a layout panel
GridType | Specifies the possible grid options for chart elements that support grid.
InnerLabelPosition | Defines values that specify the position of the inner labels in a radar chart.
LabelType | Specifies the different types of chart labels that can be drawn at the chart axes.
LineType | Specifies the type of the line chart.
PieType | Specifies the type of the pie chart.
RadarStyle | Defines values that specify how the radar graphic is drawn.
RadarType | Defines values that specify the type of the radar chart.
ScatterType | Specifies the types of scatter shapes supported by the control.
ValueFormat | Defines type of data related to a chart axis.


MindFusion.Charting.Silverlight.Annotation Class

Annotation Class
Remarks See Also
[image]

Represents an anotation at a chart element.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class Annotation : DependencyObject

Visual Basic [image] Copy Code

Public Class Annotation
Inherits DependencyObject

Remarks

Used by bar charts to mark important data at given positions at the bar. Supports several appearance styles and can have a text label.

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
MindFusion.Charting.Silverlight.Annotation

See Also

Annotation Members
MindFusion.Charting.Silverlight Namespace


MindFusion.Charting.Silverlight.Annotation Members

Annotation Members
Constructors Fields Properties Methods Events
[image]

Represents an anotation at a chart element.

The following tables list the members exposed by the Annotation type.

Public Constructors

Name | Description
Annotation | Initializes a new instance of the Annotation class.

Public Fields

Name | Description
AnnotationTypeProperty | Identifies the AnnotationType dependency property.
FillProperty | Identifies the Fill dependency property.
IndexProperty | Identifies the Index dependency property.
LabelProperty | Identifies the Label dependency property.
SizeProperty | Identifies the Size dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
ValueProperty | Identifies the Value dependency property.

Public Properties

Name | Description
AnnotationType | Gets or sets the type of the annotation label.
Fill | Gets or sets the fill of the annotation.
Index | Gets or sets the index of the chart element where this Annotation is drawn.
Label | Gets or sets the annotation label.
Size | Gets or sets the size of the annotation.
Stroke | Gets or sets the stroke of the annotation.
StrokeThickness | Gets or sets the thickness of the Stroke for the annotation.
Value | Gets or sets the value that indicates where to draw this Annotation.

Public Methods

Name | Description
OnAnnotationChanged | Raises the AnnotationChanged event.

Public Events

Name | Description
AnnotationChanged | Occurs when the Annotation has changed.

See Also

Annotation Class


MindFusion.Charting.Silverlight.Annotation Fields

Annotation Fields
[image]

Public Fields

Name | Description
AnnotationTypeProperty | Identifies the AnnotationType dependency property.
FillProperty | Identifies the Fill dependency property.
IndexProperty | Identifies the Index dependency property.
LabelProperty | Identifies the Label dependency property.
SizeProperty | Identifies the Size dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
ValueProperty | Identifies the Value dependency property.

See Also

Annotation Class


MindFusion.Charting.Silverlight.Annotation.AnnotationTypeProperty Field

Annotation.AnnotationTypeProperty Field
See Also
[image]

Identifies the AnnotationType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AnnotationTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AnnotationTypeProperty As DependencyProperty

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.FillProperty Field

Annotation.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.IndexProperty Field

Annotation.IndexProperty Field
[image]

Identifies the Index dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IndexProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IndexProperty As DependencyProperty

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.LabelProperty Field

Annotation.LabelProperty Field
[image]

Identifies the Label dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelProperty As DependencyProperty

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.SizeProperty Field

Annotation.SizeProperty Field
[image]

Identifies the Size dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SizeProperty As DependencyProperty

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.StrokeProperty Field

Annotation.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.StrokeThicknessProperty Field

Annotation.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.ValueProperty Field

Annotation.ValueProperty Field
[image]

Identifies the Value dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation Constructor

Annotation Constructor
[image]

Initializes a new instance of the Annotation class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Annotation ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Annotation Class


MindFusion.Charting.Silverlight.Annotation Methods

Annotation Methods
[image]

Public Methods

Name | Description
OnAnnotationChanged | Raises the AnnotationChanged event.

See Also

Annotation Class


MindFusion.Charting.Silverlight.Annotation.OnAnnotationChanged Method

Annotation.OnAnnotationChanged Method
[image]

Raises the AnnotationChanged event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void OnAnnotationChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnAnnotationChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The Annotation object that raised the event.

e

System.Windows.DependencyPropertyChangedEventArgs that contains data for the event.

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation Properties

Annotation Properties
[image]

Public Properties

Name | Description
AnnotationType | Gets or sets the type of the annotation label.
Fill | Gets or sets the fill of the annotation.
Index | Gets or sets the index of the chart element where this Annotation is drawn.
Label | Gets or sets the annotation label.
Size | Gets or sets the size of the annotation.
Stroke | Gets or sets the stroke of the annotation.
StrokeThickness | Gets or sets the thickness of the Stroke for the annotation.
Value | Gets or sets the value that indicates where to draw this Annotation.

See Also

Annotation Class


MindFusion.Charting.Silverlight.Annotation.AnnotationType Property

Annotation.AnnotationType Property
[image]

Gets or sets the type of the annotation label.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public AnnotationType AnnotationType { get; set; }

Visual Basic [image] Copy Code

Public Property AnnotationType As AnnotationType

Property Value

One of the AnnotationType enumeration values. Default value is AnnotationType.Empty.

Example

The following example adds an annotation as a point at value 10 to the first bar in a BarSeries series.

C# [image] Copy Code
Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Break";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = new SolidColorBrush(Colors.Green);
annotation1.Stroke = new SolidColorBrush(Colors.Green);
series.Annotations.Add(annotation1);
Visual Basic [image] Copy Code
Dim annotation1 As Annotation = New Annotation
annotation1.Index = 0
annotation1.Label = "Break"
annotation1.Value = 10
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = New SolidColorBrush(Colors.Green)
annotation1.Stroke = New SolidColorBrush(Colors.Green)
series.Annotations.Add(annotation1)

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.Fill Property

Annotation.Fill Property
[image]

Gets or sets the fill of the annotation.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

An instance of the Windows.Media.Brush class. Default value is a red SolidBrush.

Example

The following example adds an annotation as a point at value 10 to the first bar in a BarSeries series.

C# [image] Copy Code
Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Break";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = new SolidColorBrush(Colors.Green);
annotation1.Stroke = new SolidColorBrush(Colors.Green);
series.Annotations.Add(annotation1);
Visual Basic [image] Copy Code
Dim annotation1 As Annotation = New Annotation
annotation1.Index = 0
annotation1.Label = "Break"
annotation1.Value = 10
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = New SolidColorBrush(Colors.Green)
annotation1.Stroke = New SolidColorBrush(Colors.Green)
series.Annotations.Add(annotation1)

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.Index Property

Annotation.Index Property
[image]

Gets or sets the index of the chart element where this Annotation is drawn.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An int value. Default value is -1.

Example

The following example adds an annotation as a point at value 10 to the first bar in a BarSeries series.

C# [image] Copy Code
Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Break";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = new SolidColorBrush(Colors.Green);
annotation1.Stroke = new SolidColorBrush(Colors.Green);
series.Annotations.Add(annotation1);
Visual Basic [image] Copy Code
Dim annotation1 As Annotation = New Annotation
annotation1.Index = 0
annotation1.Label = "Break"
annotation1.Value = 10
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = New SolidColorBrush(Colors.Green)
annotation1.Stroke = New SolidColorBrush(Colors.Green)
series.Annotations.Add(annotation1)

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.Label Property

Annotation.Label Property
[image]

Gets or sets the annotation label.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

A string property. Default value is an empty string ("").

Example

The following example adds an annotation as a point at value 10 to the first bar in a BarSeries series.

C# [image] Copy Code
Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Break";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = new SolidColorBrush(Colors.Green);
annotation1.Stroke = new SolidColorBrush(Colors.Green);
series.Annotations.Add(annotation1);
Visual Basic [image] Copy Code
Dim annotation1 As Annotation = New Annotation
annotation1.Index = 0
annotation1.Label = "Break"
annotation1.Value = 10
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = New SolidColorBrush(Colors.Green)
annotation1.Stroke = New SolidColorBrush(Colors.Green)
series.Annotations.Add(annotation1)

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.Size Property

Annotation.Size Property
[image]

Gets or sets the size of the annotation.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As Double

Property Value

A double value. Default is 5.0

Remarks

The Size property specifies the diameter of the circle drawn for this Annotation when AnnotationType is AnnotationType.Point.

Example

The following example adds an annotation as a point at value 10 to the first bar in a BarSeries series.

C# [image] Copy Code
Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Break";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = new SolidColorBrush(Colors.Green);
annotation1.Stroke = new SolidColorBrush(Colors.Green);
series.Annotations.Add(annotation1);
Visual Basic [image] Copy Code
Dim annotation1 As Annotation = New Annotation
annotation1.Index = 0
annotation1.Label = "Break"
annotation1.Value = 10
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = New SolidColorBrush(Colors.Green)
annotation1.Stroke = New SolidColorBrush(Colors.Green)
series.Annotations.Add(annotation1)

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.Stroke Property

Annotation.Stroke Property
[image]

Gets or sets the stroke of the annotation.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

An object of type System.Windows.Media.Brush. Default value is a red SolidColorBrush.

Remarks

The property is used for drawing annotations with AnnotationType set to AnnotationType.Stick or the outline of the circle when the AnnotationType is AnnotationType.Point.

Example

The following example adds an annotation as a point at value 10 to the first bar in a BarSeries series.

C# [image] Copy Code
Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Break";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = new SolidColorBrush(Colors.Green);
annotation1.Stroke = new SolidColorBrush(Colors.Gre en);
series.Annotations.Add(annotation1);
Visual Basic [image] Copy Code
Dim annotation1 As Annotation = New Annotation
annotation1.Index = 0
annotation1.Label = "Break"
annotation1.Value = 10
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = New SolidColorBrush(Colors.Green)
annotation1.Stroke = New SolidColorBrush(Colors.Green)
series.Annotations.Add(annotation1)

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.StrokeThickness Property

Annotation.StrokeThickness Property
[image]

Gets or sets the thickness of the Stroke for the annotation.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value. Default value is 1.0

Example

The following example adds an annotation as a point at value 10 to the first bar in a BarSeries series.

C# [image] Copy Code
Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Break";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = new SolidColorBrush(Colors.Green);
annotation1.Stroke = new SolidColorBrush(Colors.Gre en);
series.Annotations.Add(annotation1);
Visual Basic [image] Copy Code
Dim annotation1 As Annotation = New Annotation
annotation1.Index = 0
annotation1.Label = "Break"
annotation1.Value = 10
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = New SolidColorBrush(Colors.Green)
annotation1.Stroke = New SolidColorBrush(Colors.Green)
series.Annotations.Add(annotation1)

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation.Value Property

Annotation.Value Property
[image]

Gets or sets the value that indicates where to draw this Annotation.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value. Default is 0.0

Remarks

The Value property specifies the location of the Annotation in terms of bar value. If the property is set to 10 and the bar represents a value of 20, the annotation will be drawn at its center.

Example

The following example adds an annotation as a point at value 10 to the first bar in a BarSeries series.

C# [image] Copy Code
Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Break";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = new SolidColorBrush(Colors.Green);
annotation1.Stroke = new SolidColorBrush(Colors.Gre en);
series.Annotations.Add(annotation1);
Visual Basic [image] Copy Code
Dim annotation1 As Annotation = New Annotation
annotation1.Index = 0
annotation1.Label = "Break"
annotation1.Value = 10
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = New SolidColorBrush(Colors.Green)
annotation1.Stroke = New SolidColorBrush(Colors.Green)
series.Annotations.Add(annotation1)

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.Annotation Events

Annotation Events
[image]

Public Events

Name | Description
AnnotationChanged | Occurs when the Annotation has changed.

See Also

Annotation Class


MindFusion.Charting.Silverlight.Annotation.AnnotationChanged Event

Annotation.AnnotationChanged Event
[image]

Occurs when the Annotation has changed.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler AnnotationChanged

Visual Basic [image] Copy Code

Public Event AnnotationChanged As EventHandler

See Also

Annotation Members
Annotation Class


MindFusion.Charting.Silverlight.AnnotationsCollection Class

AnnotationsCollection Class
Remarks See Also
[image]

Represents an observable collection of Annotation objects.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class AnnotationsCollection : ObservableCollection<Annotation>

Visual Basic [image] Copy Code

Public Class AnnotationsCollection
Inherits ObservableCollection(Of Annotation)

Remarks

Add the Annotation-s for each BarSeries to this collection.

Example

The following example creates an Annotation at position 10 that is a green point with label "Break" and adds it to the Annotations collection of the series.

C# [image] Copy Code

Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Break";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = new SolidColorBrush(Colors.Green);
annotation1.Stroke = new SolidColorBrush(Colors.Green);
series.Annotations.Add(annotation1);

Visual Basic [image] Copy Code

Dim annotation1 As Annotation = New Annotation
annotation1.Index = 0
annotation1.Label = "Break"
annotation1.Value = 10
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = New SolidColorBrush(Colors.Green)
annotation1.Stroke = New SolidColorBrush(Colors.Green)
series.Annotations.Add(annotation1)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Annotation)
System.Collections.ObjectModel.ObservableCollection(Annotation)
MindFusion.Charting.Silverlight.AnnotationsCollection

See Also

AnnotationsCollection Members


MindFusion.Charting.Silverlight.AnnotationsCollection Members

AnnotationsCollection Members
Constructors
[image]

Represents an observable collection of Annotation objects.

The following tables list the members exposed by the AnnotationsCollection type.

Public Constructors

Name | Description
AnnotationsCollection | Initializes a new instance of the AnnotationsCollection.

See Also

AnnotationsCollection Class


MindFusion.Charting.Silverlight.AnnotationsCollection Constructor

AnnotationsCollection Constructor
[image]

Initializes a new instance of the AnnotationsCollection.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public AnnotationsCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnnotationsCollection Class


MindFusion.Charting.Silverlight.AnnotationType Enumeration

AnnotationType Enumeration
[image]

Represents types of Annotation-s that are drawn.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum AnnotationType

Visual Basic [image] Copy Code

Public Enum AnnotationType

Members

Member name | Description
Empty | No annotation mark is drawn.
Point | The annotation mark is drawn as a circle.
Stick | The annotation mark is drawn as a stick.

See Also


MindFusion.Charting.Silverlight.AxesChart Class

AxesChart Class
[image]

Base class for charts which support the Cartesian coordinate system.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public abstract class AxesChart : Chart

Visual Basic [image] Copy Code

Public MustInherit Class AxesChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Silverlight.Chart
MindFusion.Charting.Silverlight.AxesChart
MindFusion.Charting.Silverlight.BarChart
MindFusion.Charting.Silverlight.LineChart

See Also

AxesChart Members


MindFusion.Charting.Silverlight.AxesChart Members

AxesChart Members
Constructors Fields Properties Methods Events
[image]

Base class for charts which support the Cartesian coordinate system.

The following tables list the members exposed by the AxesChart type.

Public Constructors

Name | Description
AxesChart | Initializes a new instance of the AxesChart class.

Public Fields

Name | Description
GridFillsProperty | Identifies the GridFills dependency property.
GridStrokesProperty | Identifies the GridStrokes dependency property.
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property.
GridTypeProperty | Identifies the GridType dependency property.
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property.
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property.
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property.
X2LabelPathProperty | Identifies the X2LabelPath dependency property.
X2LabelsProperty | Identifies the X2Labels dependency property.
XLabelPathProperty | Identifies the XLabelPath dependency property.
XLabelsProperty | Identifies the XLabels dependency property.
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property.
Y2LabelsProperty | Identifies the Y2Labels dependency property.
YLabelPathProperty | Identifies the YLabelPath dependency property.
YLabelsProperty | Identifies the YLabels dependency property.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)

Public Properties

Name | Description
Behavior | Gets or sets the behavor of the chart control.
GridFills | Gets or sets the brushes for the grid stripes.
GridStrokes | Gets or sets the brushes for the grid lines.
GridStrokeThickness | Gets or sets the thickness of grid lines.
GridType | Gets or sets the grid type.
PlotAreaFill | Gets or sets the background of the plot area.
PlotAreaStroke | Gets or sets the outline of the plot area.
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area.
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center.
X2AxisSettings | Gets or sets the settings for the X2-axis
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels.
X2Labels | Gets or sets custom labels for the X2-axis.
XAxisSettings | Gets the settings for the X axis.
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels.
XLabels | Gets or sets custom labels for the X-axis.
Y2AxisSettings | Gets or sets the settings for the Y2-axis
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels.
Y2Labels | Gets or sets custom labels for the Y2-axis.
YAxisSettings | Gets or sets the settings for the Y-axis
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels.
YLabels | Gets or sets custom labels for the Y-axis.

Inherited Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)

Public Methods

Name | Description
ResetZoom | Resets the zoom of the chart.
Zoom | Zooms a portion of the graphics.
ZoomOut | Zooms out the chart one step back.

Protected Methods

Name | Description
OnMouseEnter | Raised when the mouse eneters the control.
OnMouseLeave | Raised when the mouse leaves the chart area.
OnMouseLeftButtonDown | Raised when the left mouse button is pressed while the pointer is over this control.
OnMouseLeftButtonUp | Raised when the left mouse button is released while the mouse pointer is over the chart.
OnMouseMove | Raised when the mouse pointer moves while the mouse pointer is over the chart control.

Inherited Public Methods

Name | Description
HitTest | Gets a collection of ChartElement-s that contain the point specified as parameter. (Inherited from Chart.)
LoadTheme | Loads a ChartTheme from the specified file. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Invoked whenever application code or internal processes call. (Inherited from Chart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
SaveTheme | Saves the appearance of the current chart as a ChartTheme. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)

Inherited Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

AxesChart Class


MindFusion.Charting.Silverlight.AxesChart Fields

AxesChart Fields
[image]

Public Fields

Name | Description
GridFillsProperty | Identifies the GridFills dependency property.
GridStrokesProperty | Identifies the GridStrokes dependency property.
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property.
GridTypeProperty | Identifies the GridType dependency property.
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property.
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property.
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property.
X2LabelPathProperty | Identifies the X2LabelPath dependency property.
X2LabelsProperty | Identifies the X2Labels dependency property.
XLabelPathProperty | Identifies the XLabelPath dependency property.
XLabelsProperty | Identifies the XLabels dependency property.
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property.
Y2LabelsProperty | Identifies the Y2Labels dependency property.
YLabelPathProperty | Identifies the YLabelPath dependency property.
YLabelsProperty | Identifies the YLabels dependency property.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)

See Also

AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.GridFillsProperty Field

AxesChart.GridFillsProperty Field
[image]

Identifies the GridFills dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridFillsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridFillsProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.GridStrokesProperty Field

AxesChart.GridStrokesProperty Field
[image]

Identifies the GridStrokes dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridStrokesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridStrokesProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.GridStrokeThicknessProperty Field

AxesChart.GridStrokeThicknessProperty Field
[image]

Identifies the GridStrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridStrokeThicknessProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.GridTypeProperty Field

AxesChart.GridTypeProperty Field
[image]

Identifies the GridType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GridTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GridTypeProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.PlotAreaFillProperty Field

AxesChart.PlotAreaFillProperty Field
[image]

Identifies the PlotAreaFill dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaFillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaFillProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.PlotAreaStrokeProperty Field

AxesChart.PlotAreaStrokeProperty Field
[image]

Identifies the PlotAreaStroke dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaStrokeProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.PlotAreaStrokeThicknessProperty Field

AxesChart.PlotAreaStrokeThicknessProperty Field
[image]

Identifies the PlotAreaStrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaStrokeThicknessProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.X2LabelPathProperty Field

AxesChart.X2LabelPathProperty Field
[image]

Identifies the X2LabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty X2LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly X2LabelPathProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.X2LabelsProperty Field

AxesChart.X2LabelsProperty Field
[image]

Identifies the X2Labels dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty X2LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly X2LabelsProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.XLabelPathProperty Field

AxesChart.XLabelPathProperty Field
[image]

Identifies the XLabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XLabelPathProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.XLabelsProperty Field

AxesChart.XLabelsProperty Field
[image]

Identifies the XLabels dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XLabelsProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.Y2LabelPathProperty Field

AxesChart.Y2LabelPathProperty Field
[image]

Identifies the Y2LabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Y2LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Y2LabelPathProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.Y2LabelsProperty Field

AxesChart.Y2LabelsProperty Field
[image]

Identifies the Y2Labels dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Y2LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Y2LabelsProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.YLabelPathProperty Field

AxesChart.YLabelPathProperty Field
[image]

Identifies the YLabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YLabelPathProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.YLabelsProperty Field

AxesChart.YLabelsProperty Field
[image]

Identifies the YLabels dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YLabelsProperty As DependencyProperty

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart Constructor

AxesChart Constructor
[image]

Initializes a new instance of the AxesChart class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public AxesChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AxesChart Class


MindFusion.Charting.Silverlight.AxesChart Methods

AxesChart Methods
[image]

Public Methods

Name | Description
ResetZoom | Resets the zoom of the chart.
Zoom | Zooms a portion of the graphics.
ZoomOut | Zooms out the chart one step back.

Protected Methods

Name | Description
OnMouseEnter | Raised when the mouse eneters the control.
OnMouseLeave | Raised when the mouse leaves the chart area.
OnMouseLeftButtonDown | Raised when the left mouse button is pressed while the pointer is over this control.
OnMouseLeftButtonUp | Raised when the left mouse button is released while the mouse pointer is over the chart.
OnMouseMove | Raised when the mouse pointer moves while the mouse pointer is over the chart control.

Inherited Public Methods

Name | Description
HitTest | Gets a collection of ChartElement-s that contain the point specified as parameter. (Inherited from Chart.)
LoadTheme | Loads a ChartTheme from the specified file. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Invoked whenever application code or internal processes call. (Inherited from Chart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
SaveTheme | Saves the appearance of the current chart as a ChartTheme. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)

See Also

AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.OnMouseEnter Method

AxesChart.OnMouseEnter Method
[image]

Raised when the mouse eneters the control.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

protected override void OnMouseEnter (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseEnter( _
e As MouseEventArgs _
)

Parameters

e

An instance of the MouseEventArgs class that provides data for the event.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.OnMouseLeave Method

AxesChart.OnMouseLeave Method
[image]

Raised when the mouse leaves the chart area.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

protected override void OnMouseLeave (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeave( _
e As MouseEventArgs _
)

Parameters

e

An instance of the MouseEventArgs class that provides data for the event.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.OnMouseLeftButtonDown Method

AxesChart.OnMouseLeftButtonDown Method
[image]

Raised when the left mouse button is pressed while the pointer is over this control.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

An instance of the MouseButtonEventArgs class that provides data for the event.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.OnMouseLeftButtonUp Method

AxesChart.OnMouseLeftButtonUp Method
[image]

Raised when the left mouse button is released while the mouse pointer is over the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e

An instance of the MouseButtonEventArgs class that provides data for the event.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.OnMouseMove Method

AxesChart.OnMouseMove Method
[image]

Raised when the mouse pointer moves while the mouse pointer is over the chart control.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

An instance of the MouseEventArgs class that provides data for the event.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.ResetZoom Method

AxesChart.ResetZoom Method
[image]

Resets the zoom of the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void ResetZoom ()

Visual Basic [image] Copy Code

Public Sub ResetZoom ()

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.Zoom Method

AxesChart.Zoom Method
[image]

Zooms a portion of the graphics.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void Zoom (
Point selectionStart,
Point selectionEnd
)

Visual Basic [image] Copy Code

Public Sub Zoom( _
selectionStart As Point, _
selectionEnd As Point _
)

Parameters

selectionStart

The start of the section to zoom.

selectionEnd

The end of the section to zoom.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.ZoomOut Method

AxesChart.ZoomOut Method
[image]

Zooms out the chart one step back.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void ZoomOut ()

Visual Basic [image] Copy Code

Public Sub ZoomOut ()

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart Properties

AxesChart Properties
[image]

Public Properties

Name | Description
Behavior | Gets or sets the behavor of the chart control.
GridFills | Gets or sets the brushes for the grid stripes.
GridStrokes | Gets or sets the brushes for the grid lines.
GridStrokeThickness | Gets or sets the thickness of grid lines.
GridType | Gets or sets the grid type.
PlotAreaFill | Gets or sets the background of the plot area.
PlotAreaStroke | Gets or sets the outline of the plot area.
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area.
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center.
X2AxisSettings | Gets or sets the settings for the X2-axis
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels.
X2Labels | Gets or sets custom labels for the X2-axis.
XAxisSettings | Gets the settings for the X axis.
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels.
XLabels | Gets or sets custom labels for the X-axis.
Y2AxisSettings | Gets or sets the settings for the Y2-axis
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels.
Y2Labels | Gets or sets custom labels for the Y2-axis.
YAxisSettings | Gets or sets the settings for the Y-axis
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels.
YLabels | Gets or sets custom labels for the Y-axis.

Inherited Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)

See Also

AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.Behavior Property

AxesChart.Behavior Property
[image]

Gets or sets the behavor of the chart control.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Behavior Behavior { get; set; }

Visual Basic [image] Copy Code

Public Property Behavior As Behavior

Property Value

One of the Behavior enumeration values. Default value is Behavior.DoNothing.

Remarks

The Behavior enumeration allows bitwise combining.

For horizontal bars the behavior should be Behavior.AllowXDrag while for vertical bars it is Behavior.AllowYDrag.

Example

The following code allows data points in a line chart to be dragged with the mouse in all directions.

C# [image] Copy Code
lineChart1.Behavior = Behavior.AllowXDrag | Behavior.AllowYDrag;
Visual Basic [image] Copy Code
lineChart1.Behavior = (Behavior.AllowXDrag Or Behavior.AllowYDrag)

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.GridFills Property

AxesChart.GridFills Property
[image]

Gets or sets the brushes for the grid stripes.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection GridFills { get; set; }

Visual Basic [image] Copy Code

Public Property GridFills As BrushCollection

Property Value

An instance of the BrushCollection class. Default is an empty list.

Remarks

The GridFills property is used to fill the grid stripes when the GridType is set to a value different than GridType.None.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.GridStrokes Property

AxesChart.GridStrokes Property
[image]

Gets or sets the brushes for the grid lines.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection GridStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property GridStrokes As BrushCollection

Property Value

An instance of the BrushCollection class. Default value is an empty list.

Remarks

The property is used to draw the grid lines when the GridType is not GridType.None. If it is an empty list the grid is drawn without grid lines, just stripes.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.GridStrokeThickness Property

AxesChart.GridStrokeThickness Property
[image]

Gets or sets the thickness of grid lines.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double GridStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property GridStrokeThickness As Double

Property Value

A double value. Default value is 1.0

Remarks

The GridStrokeThickness sets or gets the thickness of the grid lines that are drawn with the GridStrokes.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.GridType Property

AxesChart.GridType Property
[image]

Gets or sets the grid type.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public GridType GridType { get; set; }

Visual Basic [image] Copy Code

Public Property GridType As GridType

Property Value

One of the GridType enumeration values. Default value is GridType.None.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.PlotAreaFill Property

AxesChart.PlotAreaFill Property
[image]

Gets or sets the background of the plot area.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush PlotAreaFill { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaFill As Brush

Property Value

An object of type System.Windows.Media.Brush. Defult value is null.

Remarks

The PlotAreaFill property specifies the brush used to fill the rectangle between the axes of the chart. If a grid is drawn, the plot area will be filled with the grid and setting the PlotAreaFill property will have no effect.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.PlotAreaStroke Property

AxesChart.PlotAreaStroke Property
[image]

Gets or sets the outline of the plot area.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush PlotAreaStroke { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaStroke As Brush

Property Value

An instance of System.Windows.Media.Brush class. Default value is a gray brush.

Remarks

The PlotAreaStroke property draws a border around the rectangle between the axes of the chart. Set the property to null if you don't want the border.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.PlotAreaStrokeThickness Property

AxesChart.PlotAreaStrokeThickness Property
[image]

Gets or sets the thickness of the outline of the plot area.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double PlotAreaStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaStrokeThickness As Double

Property Value

A double value. Default is 1.0

Remarks

The outline of the plot area is drawn with the PlotAreaStroke.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.PointAreaRadius Property

AxesChart.PointAreaRadius Property
[image]

Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double PointAreaRadius { get; set; }

Visual Basic [image] Copy Code

Public Property PointAreaRadius As Double

Property Value

A double value. Default is 10.

Remarks

The property is used in hit testing a given point. If the mouse is within PointAreaRadius distance of the point it is considered to be placed at the point.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.X2AxisSettings Property

AxesChart.X2AxisSettings Property
[image]

Gets or sets the settings for the X2-axis

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public AxisSettings X2AxisSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property X2AxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class.

Remarks

The X2-axis is drawn when the X2AxisSettings.MinValue and X2AxisSettings.MaxValue properties are set or an AxesSeries.X2Data is not an empty list.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.X2LabelPath Property

AxesChart.X2LabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving X2-labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string X2LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property X2LabelPath As String

Property Value

A string value. Default is an empty string ("").

Remarks

The X2LabelPath property provides custom labels for the X2-axis. They are drawn when X2AxisSettings.LabelType is set to LabelType.CustomText.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.X2Labels Property

AxesChart.X2Labels Property
[image]

Gets or sets custom labels for the X2-axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection X2Labels { get; set; }

Visual Basic [image] Copy Code

Public Property X2Labels As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty collection.

Remarks

The X2Labels property provides custom labels for the X2-axis. They are drawn when X2AxisSettings.LabelType is set to LabelType.CustomText.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.XAxisSettings Property

AxesChart.XAxisSettings Property
[image]

Gets the settings for the X axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public AxisSettings XAxisSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XAxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.XLabelPath Property

AxesChart.XLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving X-labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string XLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property XLabelPath As String

Property Value

A string value. Default value is an empty string ("").

Remarks

The XLabelPath property provides custom labels for the X-axis. They are drawn when XAxisSettings.LabelType is set to LabelType.CustomText.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.XLabels Property

AxesChart.XLabels Property
[image]

Gets or sets custom labels for the X-axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection XLabels { get; set; }

Visual Basic [image] Copy Code

Public Property XLabels As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty collection.

Remarks

The XLabels property provides custom labels for the X-axis. They are drawn when XAxisSettings.LabelType is set to LabelType.CustomText.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.Y2AxisSettings Property

AxesChart.Y2AxisSettings Property
[image]

Gets or sets the settings for the Y2-axis

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public AxisSettings Y2AxisSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Y2AxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class.

Remarks

The Y2-axis is drawn when the Y2AxisSettings.MinValue and Y2AxisSettings.MaxValue properties are set or an AxesSeries.Y2Data is not an empty list.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.Y2LabelPath Property

AxesChart.Y2LabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving Y2-labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string Y2LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property Y2LabelPath As String

Property Value

A string value Default value is an empty string ("").

Remarks

The Y2LabelPath property provides custom labels for the Y2-axis. They are drawn when Y2AxisSettings.LabelType is set to LabelType.CustomText.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.Y2Labels Property

AxesChart.Y2Labels Property
[image]

Gets or sets custom labels for the Y2-axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection Y2Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Y2Labels As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty collection.

Remarks

The Y2Labels property provides custom labels for the Y2-axis. They are drawn when Y2AxisSettings.LabelType is set to LabelType.CustomText.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.YAxisSettings Property

AxesChart.YAxisSettings Property
[image]

Gets or sets the settings for the Y-axis

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public AxisSettings YAxisSettings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property YAxisSettings As AxisSettings

Property Value

An instance of the AxisSettings class.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.YLabelPath Property

AxesChart.YLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving Y-labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string YLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property YLabelPath As String

Property Value

A string value. Default value is an empty string ("").

Remarks

The YLabelPath property provides custom labels for the Y-axis. They are drawn when YAxisSettings.LabelType is set to LabelType.CustomText.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesChart.YLabels Property

AxesChart.YLabels Property
[image]

Gets or sets custom labels for the Y-axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection YLabels { get; set; }

Visual Basic [image] Copy Code

Public Property YLabels As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty collection.

Remarks

The YLabels property provides custom labels for the Y-axis. They are drawn when YAxisSettings.LabelType is set to LabelType.CustomText.

See Also

AxesChart Members
AxesChart Class


MindFusion.Charting.Silverlight.AxesSeries Class

AxesSeries Class
[image]

Base class for series of charts that support the Cartesian coordinate system.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class AxesSeries : ChartSeries

Visual Basic [image] Copy Code

Public Class AxesSeries
Inherits ChartSeries

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Silverlight.ChartSeries
MindFusion.Charting.Silverlight.AxesSeries
MindFusion.Charting.Silverlight.BarSeries
MindFusion.Charting.Silverlight.LineSeries

See Also

AxesSeries Members


MindFusion.Charting.Silverlight.AxesSeries Members

AxesSeries Members
Constructors Fields Properties Methods Events
[image]

Base class for series of charts that support the Cartesian coordinate system.

The following tables list the members exposed by the AxesSeries type.

Public Constructors

Name | Description
AxesSeries | Initializes a new instance of the AxesSeries class.

Public Fields

Name | Description
X2DataPathProperty | Identifies the X2DataPath dependency property.
X2DataProperty | Identifies the X2Data dependency property.
XDataPathProperty | Identifies the XDataPath dependency property.
XDataProperty | Identifies the XData dependency property.
Y2DataPathProperty | Identifies the Y2DataPath dependency property.
Y2DataProperty | Identifies the Y2Data dependency property.
YDataPathProperty | Identifies the YDataPath dependency property.
YDataProperty | Identifies the YData dependency property.

Inherited Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property. (Inherited from ChartSeries.)
FillsProperty | Identifies the Fills dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesProperty | Identifies the Strokes dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)

Public Properties

Name | Description
X2Data | Gets or sets the data used for calculating the X2-coordinates of data points.
X2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the X2-data for this series.
XData | Gets or sets the data used for calculating the X-coordinates of data points.
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series.
Y2Data | Gets or sets the data used for calculating the Y2-coordinates of data points.
Y2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y2-data for this series.
YData | Gets or sets the data used for calculating the Y-coordinates of data points.
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series.

Inherited Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries. (Inherited from ChartSeries.)
Fills | Gets or sets the brushes for the series. (Inherited from ChartSeries.)
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the series labels. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. (Inherited from ChartSeries.)
StrokesSource | Gets or sets the source of strokes used in this ChartSeries. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. (Inherited from ChartSeries.)

Inherited Public Methods

Name | Description
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from ChartSeries.)
OnDataChanged | Raises the DataChanged event. (Inherited from ChartSeries.)

Inherited Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries Fields

AxesSeries Fields
[image]

Public Fields

Name | Description
X2DataPathProperty | Identifies the X2DataPath dependency property.
X2DataProperty | Identifies the X2Data dependency property.
XDataPathProperty | Identifies the XDataPath dependency property.
XDataProperty | Identifies the XData dependency property.
Y2DataPathProperty | Identifies the Y2DataPath dependency property.
Y2DataProperty | Identifies the Y2Data dependency property.
YDataPathProperty | Identifies the YDataPath dependency property.
YDataProperty | Identifies the YData dependency property.

Inherited Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property. (Inherited from ChartSeries.)
FillsProperty | Identifies the Fills dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesProperty | Identifies the Strokes dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)

See Also

AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.X2DataPathProperty Field

AxesSeries.X2DataPathProperty Field
[image]

Identifies the X2DataPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty X2DataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly X2DataPathProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.X2DataProperty Field

AxesSeries.X2DataProperty Field
[image]

Identifies the X2Data dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty X2DataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly X2DataProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.XDataPathProperty Field

AxesSeries.XDataPathProperty Field
[image]

Identifies the XDataPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XDataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XDataPathProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.XDataProperty Field

AxesSeries.XDataProperty Field
[image]

Identifies the XData dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty XDataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly XDataProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.Y2DataPathProperty Field

AxesSeries.Y2DataPathProperty Field
[image]

Identifies the Y2DataPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Y2DataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Y2DataPathProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.Y2DataProperty Field

AxesSeries.Y2DataProperty Field
[image]

Identifies the Y2Data dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty Y2DataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly Y2DataProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.YDataPathProperty Field

AxesSeries.YDataPathProperty Field
[image]

Identifies the YDataPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YDataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YDataPathProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.YDataProperty Field

AxesSeries.YDataProperty Field
[image]

Identifies the YData dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty YDataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly YDataProperty As DependencyProperty

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries Constructor

AxesSeries Constructor
[image]

Initializes a new instance of the AxesSeries class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public AxesSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries Properties

AxesSeries Properties
[image]

Public Properties

Name | Description
X2Data | Gets or sets the data used for calculating the X2-coordinates of data points.
X2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the X2-data for this series.
XData | Gets or sets the data used for calculating the X-coordinates of data points.
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series.
Y2Data | Gets or sets the data used for calculating the Y2-coordinates of data points.
Y2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y2-data for this series.
YData | Gets or sets the data used for calculating the Y-coordinates of data points.
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series.

Inherited Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries. (Inherited from ChartSeries.)
Fills | Gets or sets the brushes for the series. (Inherited from ChartSeries.)
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the series labels. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. (Inherited from ChartSeries.)
StrokesSource | Gets or sets the source of strokes used in this ChartSeries. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. (Inherited from ChartSeries.)

See Also

AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.X2Data Property

AxesSeries.X2Data Property
[image]

Gets or sets the data used for calculating the X2-coordinates of data points.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection X2Data { get; set; }

Visual Basic [image] Copy Code

Public Property X2Data As DoubleCollection

Property Value

An instance of the System.Windows.Media.DoubleCollection class. Default value is an empty list.

Remarks

When the X2Data property is set the X2-axis is drawn automatically. You can customize it with the AxesChart.X2AxisSettings property.

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.X2DataPath Property

AxesSeries.X2DataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the X2-data for this series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string X2DataPath { get; set; }

Visual Basic [image] Copy Code

Public Property X2DataPath As String

Property Value

A string value. Default value is an empty string ("").

Remarks

When the X2DataPath property is set the X2-axis is drawn automatically. You can customize it with the AxesChart.X2AxisSettings property.

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.XData Property

AxesSeries.XData Property
[image]

Gets or sets the data used for calculating the X-coordinates of data points.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection XData { get; set; }

Visual Basic [image] Copy Code

Public Property XData As DoubleCollection

Property Value

An instance of the System.Windows.Media.DoubleCollection class. Default value is an empty list.

Remarks

The X-axis is customized with the AxesChart.XAxisSettings property.

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.XDataPath Property

AxesSeries.XDataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string XDataPath { get; set; }

Visual Basic [image] Copy Code

Public Property XDataPath As String

Property Value

A string value. Default value is an empty string ("").

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.Y2Data Property

AxesSeries.Y2Data Property
[image]

Gets or sets the data used for calculating the Y2-coordinates of data points.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection Y2Data { get; set; }

Visual Basic [image] Copy Code

Public Property Y2Data As DoubleCollection

Property Value

An instance of the System.Windows.Media.DoubleCollection class. Default value is an empty list.

Remarks

When the Y2Data property is set the Y2-axis is drawn automatically. You can customize it with the AxesChart.Y2AxisSettings property.

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.Y2DataPath Property

AxesSeries.Y2DataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the Y2-data for this series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string Y2DataPath { get; set; }

Visual Basic [image] Copy Code

Public Property Y2DataPath As String

Property Value

A string value. Default value is an empty string ("").

Remarks

When the Y2DataPath property is set the Y2-axis is drawn automatically. You can customize it with the AxesChart.Y2AxisSettings property.

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.YData Property

AxesSeries.YData Property
[image]

Gets or sets the data used for calculating the Y-coordinates of data points.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection YData { get; set; }

Visual Basic [image] Copy Code

Public Property YData As DoubleCollection

Property Value

An instance of the System.Windows.Media.DoubleCollection class. Default value is an empty list.

Remarks

The Y-axis is customized with the AxesChart.YAxisSettings property.

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxesSeries.YDataPath Property

AxesSeries.YDataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string YDataPath { get; set; }

Visual Basic [image] Copy Code

Public Property YDataPath As String

Property Value

A string value. Default value is an empty string ("").

Remarks

You can customize the Y-axis with the AxesChart.YAxisSettings property.

See Also

AxesSeries Members
AxesSeries Class


MindFusion.Charting.Silverlight.AxisSettings Class

AxisSettings Class
[image]

Gets or sets the settings of a chart axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class AxisSettings : FrameworkElement

Visual Basic [image] Copy Code

Public Class AxisSettings
Inherits FrameworkElement

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Silverlight.AxisSettings

See Also

AxisSettings Members


MindFusion.Charting.Silverlight.AxisSettings Members

AxisSettings Members
Constructors Fields Properties Methods Events
[image]

Gets or sets the settings of a chart axis.

The following tables list the members exposed by the AxisSettings type.

Public Constructors

Name | Description
AxisSettings | Creates a new AxisSettings object.

Public Fields

Name | Description
CustomLabelPositionProperty | Identifies the CustomLabelPosition dependency property.
IntervalCountProperty | Identifies the IntervalCount dependency property.
IntervalProperty | Identifies the Interval dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelRotationAngleProperty | Identifies the LabelRotationAngle dependency property.
LabelStrokeProperty | Identifies the LabelStroke dependency property.
LabelTypeProperty | Identifies the LabelType dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TickProperty | Identifies the Tick dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleOffsetProperty | Identifies the TitleOffset dependency property.
TitleProperty | Identifies the Title dependency property.
TitleRotationAngleProperty | Identifies the TitleRotationAngle dependency property.
TitleStrokeProperty | Identifies the TitleStroke dependency property.
ValueFormatProperty | Identifies the ValueFormat dependency property.

Public Properties

Name | Description
CustomLabelPosition | Gets or sets the position of custom labels.
Interval | Gets or sets the interval between two adjacent values at the axis.
IntervalCount | Gets or sets the count of intervals at the axis.
LabelFontFamily | Gets or sets the font family for the labels at the axis.
LabelFontSize | Gets or sets the font size for the labels at the axis.
LabelFontStyle | Gets or sets the font style for the chart labels.
LabelFontWeight | Gets or sets the font weight for the labels at the axis.
LabelFormat | Gets or sets the format of the labels.
LabelOffset | Gets or sets the offset of the label from the axis.
LabelRotationAngle | Gets or sets the rotation angle of labels at a horizontal axis.
LabelStroke | Gets or sets the brush for drawing the labels at the axis.
LabelType | Gets or sets the type of labels drawn at the axis.
MaxValue | Gets or sets the maximum value at the axis.
MinValue | Gets or sets the minimum value at the axis.
Stroke | Gets or sets the brush for drawing the axis.
StrokeThickness | Gets or sets the thickness of the stroke for this axis.
Tick | Gets or sets the length of tick marks.
Title | Gets or sets the title of the axis.
TitleFontFamily | Gets or sets the font family for the title.
TitleFontSize | Gets or sets the font size for the title.
TitleFontStyle | Gets or sets the font style for the title.
TitleFontWeight | Gets or sets the font weight for the title.
TitleOffset | Gets or sets the offset of the title label from the axis.
TitleRotationAngle | Gets or sets the rotation angle of the title label at a horizontal axis.
TitleStroke | Gets or sets the brush for drawing the title of the axis.
ValueFormat | Gets or sets the format of data related to this axis.

Public Methods

Name | Description
IsValidAngle | Checks if the given value is valid value for an angle.
OnInnerValueChanged | Raises the InnerValueChanged event.

Public Events

Name | Description
InnerValueChanged | Occurs when a property of the AxisSettings object has changed.

See Also

AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings Fields

AxisSettings Fields
[image]

Public Fields

Name | Description
CustomLabelPositionProperty | Identifies the CustomLabelPosition dependency property.
IntervalCountProperty | Identifies the IntervalCount dependency property.
IntervalProperty | Identifies the Interval dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelRotationAngleProperty | Identifies the LabelRotationAngle dependency property.
LabelStrokeProperty | Identifies the LabelStroke dependency property.
LabelTypeProperty | Identifies the LabelType dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TickProperty | Identifies the Tick dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleOffsetProperty | Identifies the TitleOffset dependency property.
TitleProperty | Identifies the Title dependency property.
TitleRotationAngleProperty | Identifies the TitleRotationAngle dependency property.
TitleStrokeProperty | Identifies the TitleStroke dependency property.
ValueFormatProperty | Identifies the ValueFormat dependency property.

See Also

AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.CustomLabelPositionProperty Field

AxisSettings.CustomLabelPositionProperty Field
[image]

Identifies the CustomLabelPosition dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CustomLabelPositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CustomLabelPositionProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.IntervalProperty Field

AxisSettings.IntervalProperty Field
[image]

Identifies the Interval dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IntervalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IntervalProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelFontFamilyProperty Field

AxisSettings.LabelFontFamilyProperty Field
[image]

Identifies the LabelFontFamily dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontFamilyProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelFontSizeProperty Field

AxisSettings.LabelFontSizeProperty Field
[image]

Identifies the LabelFontSize dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontSizeProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelFontStyleProperty Field

AxisSettings.LabelFontStyleProperty Field
[image]

Identifies the LabelFontStyle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontStyleProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelFontWeightProperty Field

AxisSettings.LabelFontWeightProperty Field
[image]

Identifies the LabelFontWeight dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontWeightProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelFormatProperty Field

AxisSettings.LabelFormatProperty Field
[image]

Identifies the LabelFormat dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFormatProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelOffsetProperty Field

AxisSettings.LabelOffsetProperty Field
[image]

Identifies the LabelOffset dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelOffsetProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelRotationAngleProperty Field

AxisSettings.LabelRotationAngleProperty Field
[image]

Identifies the LabelRotationAngle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelRotationAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelRotationAngleProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelStrokeProperty Field

AxisSettings.LabelStrokeProperty Field
[image]

Identifies the LabelStroke dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelStrokeProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelTypeProperty Field

AxisSettings.LabelTypeProperty Field
[image]

Identifies the LabelType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelTypeProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.MaxValueProperty Field

AxisSettings.MaxValueProperty Field
[image]

Identifies the MaxValue dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxValueProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.MinValueProperty Field

AxisSettings.MinValueProperty Field
[image]

Identifies the MinValue dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinValueProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.StrokeProperty Field

AxisSettings.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.StrokeThicknessProperty Field

AxisSettings.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TickProperty Field

AxisSettings.TickProperty Field
[image]

Identifies the Tick dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleFontFamilyProperty Field

AxisSettings.TitleFontFamilyProperty Field
[image]

Identifies the TitleFontFamily dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontFamilyProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleFontSizeProperty Field

AxisSettings.TitleFontSizeProperty Field
[image]

Identifies the TitleFontSize dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontSizeProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleFontStyleProperty Field

AxisSettings.TitleFontStyleProperty Field
[image]

Identifies the TitleFontStyle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontStyleProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleFontWeightProperty Field

AxisSettings.TitleFontWeightProperty Field
[image]

Identifies the TitleFontWeight dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontWeightProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleOffsetProperty Field

AxisSettings.TitleOffsetProperty Field
[image]

Identifies the TitleOffset dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleOffsetProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleProperty Field

AxisSettings.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleRotationAngleProperty Field

AxisSettings.TitleRotationAngleProperty Field
[image]

Identifies the TitleRotationAngle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleRotationAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleRotationAngleProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleStrokeProperty Field

AxisSettings.TitleStrokeProperty Field
[image]

Identifies the TitleStroke dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleStrokeProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.ValueFormatProperty Field

AxisSettings.ValueFormatProperty Field
[image]

Identifies the ValueFormat dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueFormatProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.IntervalCountProperty Field

AxisSettings.IntervalCountProperty Field
[image]

Identifies the IntervalCount dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IntervalCountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IntervalCountProperty As DependencyProperty

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings Constructor

AxisSettings Constructor
[image]

Creates a new AxisSettings object.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public AxisSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings Methods

AxisSettings Methods
[image]

Public Methods

Name | Description
IsValidAngle | Checks if the given value is valid value for an angle.
OnInnerValueChanged | Raises the InnerValueChanged event.

See Also

AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.IsValidAngle Method

AxisSettings.IsValidAngle Method
[image]

Checks if the given value is valid value for an angle.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static bool IsValidAngle (
Object value
)

Visual Basic [image] Copy Code

Public Shared Function IsValidAngle( _
value As Object _
) As Boolean

Parameters

value

The value to check.

Return Value

true if the value is valie value for an angle; otherwise false.

Remarks

This method is used by the control and is not intended to be called directly from your code.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.OnInnerValueChanged Method

AxisSettings.OnInnerValueChanged Method
[image]

Raises the InnerValueChanged event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void OnInnerValueChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnInnerValueChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The dependency object that has raised the event.

e

A System.Windows.DependencyPropertyChangedEventArgs that contains the event data.

Remarks

The event is raised whenever a property of the AxisSettings class changes its value. This event is used internally by the control and is not meant to be called by your code.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings Properties

AxisSettings Properties
[image]

Public Properties

Name | Description
CustomLabelPosition | Gets or sets the position of custom labels.
Interval | Gets or sets the interval between two adjacent values at the axis.
IntervalCount | Gets or sets the count of intervals at the axis.
LabelFontFamily | Gets or sets the font family for the labels at the axis.
LabelFontSize | Gets or sets the font size for the labels at the axis.
LabelFontStyle | Gets or sets the font style for the chart labels.
LabelFontWeight | Gets or sets the font weight for the labels at the axis.
LabelFormat | Gets or sets the format of the labels.
LabelOffset | Gets or sets the offset of the label from the axis.
LabelRotationAngle | Gets or sets the rotation angle of labels at a horizontal axis.
LabelStroke | Gets or sets the brush for drawing the labels at the axis.
LabelType | Gets or sets the type of labels drawn at the axis.
MaxValue | Gets or sets the maximum value at the axis.
MinValue | Gets or sets the minimum value at the axis.
Stroke | Gets or sets the brush for drawing the axis.
StrokeThickness | Gets or sets the thickness of the stroke for this axis.
Tick | Gets or sets the length of tick marks.
Title | Gets or sets the title of the axis.
TitleFontFamily | Gets or sets the font family for the title.
TitleFontSize | Gets or sets the font size for the title.
TitleFontStyle | Gets or sets the font style for the title.
TitleFontWeight | Gets or sets the font weight for the title.
TitleOffset | Gets or sets the offset of the title label from the axis.
TitleRotationAngle | Gets or sets the rotation angle of the title label at a horizontal axis.
TitleStroke | Gets or sets the brush for drawing the title of the axis.
ValueFormat | Gets or sets the format of data related to this axis.

See Also

AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.CustomLabelPosition Property

AxisSettings.CustomLabelPosition Property
[image]

Gets or sets the position of custom labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public CustomLabelPosition CustomLabelPosition { get; set; }

Visual Basic [image] Copy Code

Public Property CustomLabelPosition As CustomLabelPosition

Property Value

One of the CustomLabelPosition enumeration values. Default value is CustomLabelPosition.ChartDataPoints.

Remarks

Custom labels are drawn when the LabelType property is set to LabelType.CustomText. They are set with AxesChart.XLabels, AxesChart.YLabels, AxesChart.X2Labels or AxesChart.Y2Labels. If you want to use databinding the properties are AxesChart.XLabelPath, AxesChart.YLabelPath, AxesChart.X2LabelPath, AxesChart.Y2LabelPath.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.Interval Property

AxisSettings.Interval Property
[image]

Gets or sets the interval between two adjacent values at the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Interval { get; set; }

Visual Basic [image] Copy Code

Public Property Interval As Double

Property Value

A double value. Default value is double.NaN, which means the interval is calculated automatically.

Remarks

The chart calculates the interval automatically so that exactly 10 intervals fit between the MinValue and MaxValue at the axis.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelFontFamily Property

AxisSettings.LabelFontFamily Property
[image]

Gets or sets the font family for the labels at the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontFamily LabelFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontFamily As FontFamily

Property Value

An instance of the System.Windows.Media.FontFamily class. Default value is Times New Roman.

Remarks

Labels at the axis are drawn when the LabelType is not LabelType.Empty.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelFontSize Property

AxisSettings.LabelFontSize Property
[image]

Gets or sets the font size for the labels at the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double LabelFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontSize As Double

Property Value

A double value. Default is 12.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelFontStyle Property

AxisSettings.LabelFontStyle Property
[image]

Gets or sets the font style for the chart labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontStyle LabelFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontStyle As FontStyle

Property Value

An instance of the System.Windows.FontStyle structure. Default value is FontStyles.Normal.

Remarks

Labels at the axis are drawn when the LabelType is not LabelType.Empty.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelFontWeight Property

AxisSettings.LabelFontWeight Property
[image]

Gets or sets the font weight for the labels at the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontWeight LabelFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontWeight As FontWeight

Property Value

An instance of the System.Windows.FontWeight class. Default value is FontWeights.Normal.

Remarks

Labels at the axis are drawn when the LabelType is not LabelType.Empty.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelFormat Property

AxisSettings.LabelFormat Property
[image]

Gets or sets the format of the labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string LabelFormat { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFormat As String

Property Value

One of the standard numeric format strings. Default value is "F2".

Remarks

The LabelFormat property is used when the labels are numbers.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelOffset Property

AxisSettings.LabelOffset Property
[image]

Gets or sets the offset of the label from the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double LabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LabelOffset As Double

Property Value

A double value. Default is 5.0.

Remarks

Labels at the axis are drawn when the LabelType is not LabelType.Empty.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelRotationAngle Property

AxisSettings.LabelRotationAngle Property
[image]

Gets or sets the rotation angle of labels at a horizontal axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double LabelRotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property LabelRotationAngle As Double

Property Value

A double value. Default is 0.0

Remarks

Only labels at the X-axis and X2-axis are rotated.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelStroke Property

AxisSettings.LabelStroke Property
[image]

Gets or sets the brush for drawing the labels at the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush LabelStroke { get; set; }

Visual Basic [image] Copy Code

Public Property LabelStroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is a black SolidColorBrush.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.LabelType Property

AxisSettings.LabelType Property
[image]

Gets or sets the type of labels drawn at the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LabelType LabelType { get; set; }

Visual Basic [image] Copy Code

Public Property LabelType As LabelType

Property Value

One of the LabelType enumeration values. Default value is LabelType.Empty.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.MaxValue Property

AxisSettings.MaxValue Property
[image]

Gets or sets the maximum value at the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

A double value. Default value is double.NaN, which means the control calculates the MaxValue automatically.

Remarks

The MaxValue is calculated automatically in such manner that all data that refers to the respective axis could fit in.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.MinValue Property

AxisSettings.MinValue Property
[image]

Gets or sets the minimum value at the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

A double value. Default value is double.NaN, which means the control calculates the MinValue automatically.

Remarks

The MinValue is calculated automatically in such manner that all data that refers to the respective axis could fit in.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.Stroke Property

AxisSettings.Stroke Property
[image]

Gets or sets the brush for drawing the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is a black SolidColorBrush.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.StrokeThickness Property

AxisSettings.StrokeThickness Property
[image]

Gets or sets the thickness of the stroke for this axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value. Default is 1.0

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.Tick Property

AxisSettings.Tick Property
[image]

Gets or sets the length of tick marks.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Tick { get; set; }

Visual Basic [image] Copy Code

Public Property Tick As Double

Property Value

A double value. Default is 0.0

Remarks

Ticks are drawn at the location of the axis labels when Tick is bigger than 0.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.Title Property

AxisSettings.Title Property
[image]

Gets or sets the title of the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value. Default is an empty string ("").

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleFontFamily Property

AxisSettings.TitleFontFamily Property
[image]

Gets or sets the font family for the title.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontFamily TitleFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontFamily As FontFamily

Property Value

An instance of the System.Windows.Media.FontFamily class. Default value is Times New Roman.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleFontSize Property

AxisSettings.TitleFontSize Property
[image]

Gets or sets the font size for the title.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Double

Property Value

A double value. Default is 14.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleFontStyle Property

AxisSettings.TitleFontStyle Property
[image]

Gets or sets the font style for the title.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontStyle TitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontStyle As FontStyle

Property Value

An instance of the System.Windows.FontStyle structure. Default value is FontStyles.Normal.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleFontWeight Property

AxisSettings.TitleFontWeight Property
[image]

Gets or sets the font weight for the title.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontWeight TitleFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontWeight As FontWeight

Property Value

An instance of the System.Windows.FontWeight class. Default value is FontWeights.Normal.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleOffset Property

AxisSettings.TitleOffset Property
[image]

Gets or sets the offset of the title label from the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double TitleOffset { get; set; }

Visual Basic [image] Copy Code

Public Property TitleOffset As Double

Property Value

A double value. Default is 5.0.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleRotationAngle Property

AxisSettings.TitleRotationAngle Property
[image]

Gets or sets the rotation angle of the title label at a horizontal axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double TitleRotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleRotationAngle As Double

Property Value

A double value. Default is 0.0

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.TitleStroke Property

AxisSettings.TitleStroke Property
[image]

Gets or sets the brush for drawing the title of the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush TitleStroke { get; set; }

Visual Basic [image] Copy Code

Public Property TitleStroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is a black SolidColorBrush.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.ValueFormat Property

AxisSettings.ValueFormat Property
[image]

Gets or sets the format of data related to this axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ValueFormat ValueFormat { get; set; }

Visual Basic [image] Copy Code

Public Property ValueFormat As ValueFormat

Property Value

One of the ValueFormat enumeration values. Default value is ValueFormat.Number.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.IntervalCount Property

AxisSettings.IntervalCount Property
[image]

Gets or sets the count of intervals at the axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int IntervalCount { get; set; }

Visual Basic [image] Copy Code

Public Property IntervalCount As Integer

Property Value

an int value. Default value is -1.

Remarks

When the IntervalCount property is set, the Interval property is not considered and the axis has between MinValue and MaxValue as many intervals as set by IntervalCount.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings Events

AxisSettings Events
[image]

Public Events

Name | Description
InnerValueChanged | Occurs when a property of the AxisSettings object has changed.

See Also

AxisSettings Class


MindFusion.Charting.Silverlight.AxisSettings.InnerValueChanged Event

AxisSettings.InnerValueChanged Event
[image]

Occurs when a property of the AxisSettings object has changed.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler InnerValueChanged

Visual Basic [image] Copy Code

Public Event InnerValueChanged As EventHandler

Remarks

This event is used internally by the control and is not meant to be called by your code.

See Also

AxisSettings Members
AxisSettings Class


MindFusion.Charting.Silverlight.Bar Class

Bar Class
[image]

Represents a bar in charts that show bars.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class Bar : ChartElement

Visual Basic [image] Copy Code

Public Class Bar
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Silverlight.ChartElement
MindFusion.Charting.Silverlight.Bar

See Also

Bar Members


MindFusion.Charting.Silverlight.Bar Members

Bar Members
Properties Methods
[image]

Represents a bar in charts that show bars.

The following tables list the members exposed by the Bar type.

Public Properties

Name | Description
BarIndex | Gets the index of the bar in the BarSeries.
Height | Gets the height of the bar.
Progress | Gets the progress of the bar.
SeriesIndex | Gets the index of the series in the Series collection this bar belongs to.
Value | Gets the value of the bar.
Width | Gets the width of the bar.

Inherited Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Shape | Gets or sers the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this bar.

Inherited Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element. (Inherited from ChartElement.)

See Also

Bar Class


MindFusion.Charting.Silverlight.Bar Methods

Bar Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this bar.

Inherited Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element. (Inherited from ChartElement.)

See Also

Bar Class


MindFusion.Charting.Silverlight.Bar.CreateShape Method

Bar.CreateShape Method
[image]

Creates a Shape that represents this bar.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

A System.Windows.Shape object.

Remarks

This method is used internally by the control and is not

See Also

Bar Members
Bar Class


MindFusion.Charting.Silverlight.Bar Properties

Bar Properties
[image]

Public Properties

Name | Description
BarIndex | Gets the index of the bar in the BarSeries.
Height | Gets the height of the bar.
Progress | Gets the progress of the bar.
SeriesIndex | Gets the index of the series in the Series collection this bar belongs to.
Value | Gets the value of the bar.
Width | Gets the width of the bar.

Inherited Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Shape | Gets or sers the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

See Also

Bar Class


MindFusion.Charting.Silverlight.Bar.BarIndex Property

Bar.BarIndex Property
[image]

Gets the index of the bar in the BarSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int BarIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property BarIndex As Integer

Property Value

An int value. Default value is -1.

See Also

Bar Members
Bar Class


MindFusion.Charting.Silverlight.Bar.Height Property

Bar.Height Property
[image]

Gets the height of the bar.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Height { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Height As Double

Property Value

A double value. Default is 0.0

See Also

Bar Members
Bar Class


MindFusion.Charting.Silverlight.Bar.Progress Property

Bar.Progress Property
[image]

Gets the progress of the bar.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Progress { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Progress As Double

Property Value

A double value. Default is 0.0

See Also

Bar Members
Bar Class


MindFusion.Charting.Silverlight.Bar.SeriesIndex Property

Bar.SeriesIndex Property
[image]

Gets the index of the series in the Series collection this bar belongs to.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int SeriesIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SeriesIndex As Integer

Property Value

An int value. Default value is -1.

See Also

Bar Members
Bar Class


MindFusion.Charting.Silverlight.Bar.Value Property

Bar.Value Property
[image]

Gets the value of the bar.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Value { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Value As Double

Property Value

A double value. Default value is 0.

See Also

Bar Members
Bar Class


MindFusion.Charting.Silverlight.Bar.Width Property

Bar.Width Property
[image]

Gets the width of the bar.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Width { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Width As Double

Property Value

A double value. Default is 0.0

See Also

Bar Members
Bar Class


MindFusion.Charting.Silverlight.BarChart Class

BarChart Class
[image]

Represents a bar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class BarChart : AxesChart

Visual Basic [image] Copy Code

Public Class BarChart
Inherits AxesChart

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Silverlight.Chart
MindFusion.Charting.Silverlight.AxesChart
MindFusion.Charting.Silverlight.BarChart

See Also

BarChart Members


MindFusion.Charting.Silverlight.BarChart Members

BarChart Members
Constructors Fields Properties Methods Events
[image]

Represents a bar chart.

The following tables list the members exposed by the BarChart type.

Public Constructors

Name | Description
BarChart | Creates a new bar chart.

Public Fields

Name | Description
SeriesWidthProperty | Identifies the SeriesWidth dependency property.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property. (Inherited from AxesChart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property. (Inherited from AxesChart.)
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property. (Inherited from AxesChart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)
X2LabelPathProperty | Identifies the X2LabelPath dependency property. (Inherited from AxesChart.)
X2LabelsProperty | Identifies the X2Labels dependency property. (Inherited from AxesChart.)
XLabelPathProperty | Identifies the XLabelPath dependency property. (Inherited from AxesChart.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart.)
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property. (Inherited from AxesChart.)
Y2LabelsProperty | Identifies the Y2Labels dependency property. (Inherited from AxesChart.)
YLabelPathProperty | Identifies the YLabelPath dependency property. (Inherited from AxesChart.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart.)

Public Properties

Name | Description
SeriesWidth | Gets or sets the width of the bar series.

Inherited Public Properties

Name | Description
Behavior | Gets or sets the behavor of the chart control. (Inherited from AxesChart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
GridFills | Gets or sets the brushes for the grid stripes. (Inherited from AxesChart.)
GridStrokes | Gets or sets the brushes for the grid lines. (Inherited from AxesChart.)
GridStrokeThickness | Gets or sets the thickness of grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the grid type. (Inherited from AxesChart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
PlotAreaFill | Gets or sets the background of the plot area. (Inherited from AxesChart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
PlotAreaStroke | Gets or sets the outline of the plot area. (Inherited from AxesChart.)
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area. (Inherited from AxesChart.)
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center. (Inherited from AxesChart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)
X2AxisSettings | Gets or sets the settings for the X2-axis (Inherited from AxesChart.)
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels. (Inherited from AxesChart.)
X2Labels | Gets or sets custom labels for the X2-axis. (Inherited from AxesChart.)
XAxisSettings | Gets the settings for the X axis. (Inherited from AxesChart.)
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels. (Inherited from AxesChart.)
XLabels | Gets or sets custom labels for the X-axis. (Inherited from AxesChart.)
Y2AxisSettings | Gets or sets the settings for the Y2-axis (Inherited from AxesChart.)
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels. (Inherited from AxesChart.)
Y2Labels | Gets or sets custom labels for the Y2-axis. (Inherited from AxesChart.)
YAxisSettings | Gets or sets the settings for the Y-axis (Inherited from AxesChart.)
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels. (Inherited from AxesChart.)
YLabels | Gets or sets custom labels for the Y-axis. (Inherited from AxesChart.)

Inherited Public Methods

Name | Description
HitTest | Gets a collection of ChartElement-s that contain the point specified as parameter. (Inherited from Chart.)
LoadTheme | Loads a ChartTheme from the specified file. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Invoked whenever application code or internal processes call. (Inherited from Chart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
ResetZoom | Resets the zoom of the chart. (Inherited from AxesChart.)
SaveTheme | Saves the appearance of the current chart as a ChartTheme. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)
Zoom | Zooms a portion of the graphics. (Inherited from AxesChart.)
ZoomOut | Zooms out the chart one step back. (Inherited from AxesChart.)

Inherited Protected Methods

Name | Description
OnMouseEnter | Raised when the mouse eneters the control. (Inherited from AxesChart.)
OnMouseLeave | Raised when the mouse leaves the chart area. (Inherited from AxesChart.)
OnMouseLeftButtonDown | Raised when the left mouse button is pressed while the pointer is over this control. (Inherited from AxesChart.)
OnMouseLeftButtonUp | Raised when the left mouse button is released while the mouse pointer is over the chart. (Inherited from AxesChart.)
OnMouseMove | Raised when the mouse pointer moves while the mouse pointer is over the chart control. (Inherited from AxesChart.)

Inherited Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

BarChart Class


MindFusion.Charting.Silverlight.BarChart Fields

BarChart Fields
[image]

Public Fields

Name | Description
SeriesWidthProperty | Identifies the SeriesWidth dependency property.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property. (Inherited from AxesChart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property. (Inherited from AxesChart.)
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property. (Inherited from AxesChart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)
X2LabelPathProperty | Identifies the X2LabelPath dependency property. (Inherited from AxesChart.)
X2LabelsProperty | Identifies the X2Labels dependency property. (Inherited from AxesChart.)
XLabelPathProperty | Identifies the XLabelPath dependency property. (Inherited from AxesChart.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart.)
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property. (Inherited from AxesChart.)
Y2LabelsProperty | Identifies the Y2Labels dependency property. (Inherited from AxesChart.)
YLabelPathProperty | Identifies the YLabelPath dependency property. (Inherited from AxesChart.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart.)

See Also

BarChart Class


MindFusion.Charting.Silverlight.BarChart.SeriesWidthProperty Field

BarChart.SeriesWidthProperty Field
[image]

Identifies the SeriesWidth dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SeriesWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SeriesWidthProperty As DependencyProperty

See Also

BarChart Members
BarChart Class


MindFusion.Charting.Silverlight.BarChart Constructor

BarChart Constructor
[image]

Creates a new bar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BarChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarChart Class


MindFusion.Charting.Silverlight.BarChart Properties

BarChart Properties
[image]

Public Properties

Name | Description
SeriesWidth | Gets or sets the width of the bar series.

Inherited Public Properties

Name | Description
Behavior | Gets or sets the behavor of the chart control. (Inherited from AxesChart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
GridFills | Gets or sets the brushes for the grid stripes. (Inherited from AxesChart.)
GridStrokes | Gets or sets the brushes for the grid lines. (Inherited from AxesChart.)
GridStrokeThickness | Gets or sets the thickness of grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the grid type. (Inherited from AxesChart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
PlotAreaFill | Gets or sets the background of the plot area. (Inherited from AxesChart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
PlotAreaStroke | Gets or sets the outline of the plot area. (Inherited from AxesChart.)
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area. (Inherited from AxesChart.)
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center. (Inherited from AxesChart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)
X2AxisSettings | Gets or sets the settings for the X2-axis (Inherited from AxesChart.)
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels. (Inherited from AxesChart.)
X2Labels | Gets or sets custom labels for the X2-axis. (Inherited from AxesChart.)
XAxisSettings | Gets the settings for the X axis. (Inherited from AxesChart.)
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels. (Inherited from AxesChart.)
XLabels | Gets or sets custom labels for the X-axis. (Inherited from AxesChart.)
Y2AxisSettings | Gets or sets the settings for the Y2-axis (Inherited from AxesChart.)
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels. (Inherited from AxesChart.)
Y2Labels | Gets or sets custom labels for the Y2-axis. (Inherited from AxesChart.)
YAxisSettings | Gets or sets the settings for the Y-axis (Inherited from AxesChart.)
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels. (Inherited from AxesChart.)
YLabels | Gets or sets custom labels for the Y-axis. (Inherited from AxesChart.)

See Also

BarChart Class


MindFusion.Charting.Silverlight.BarChart.SeriesWidth Property

BarChart.SeriesWidth Property
[image]

Gets or sets the width of the bar series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double SeriesWidth { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesWidth As Double

Property Value

A double value. Default is 0.8

Remarks

Valid values range from 0 to 1 and indicate the percentage of available space for this series at the axis, which is to be taken by the bars. The rest is left as an empty space. Value of 0.8 means that the bars will take 80% of the space alocated for this series at the axis and the rest will be empty space - 10% before and 10% after the series.

See Also

BarChart Members
BarChart Class


MindFusion.Charting.Silverlight.BarSeries Class

BarSeries Class
[image]

Represents a series in a bar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class BarSeries : AxesSeries

Visual Basic [image] Copy Code

Public Class BarSeries
Inherits AxesSeries

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Silverlight.ChartSeries
MindFusion.Charting.Silverlight.AxesSeries
MindFusion.Charting.Silverlight.BarSeries

See Also

BarSeries Members


MindFusion.Charting.Silverlight.BarSeries Members

BarSeries Members
Constructors Fields Properties Methods Events
[image]

Represents a series in a bar chart.

The following tables list the members exposed by the BarSeries type.

Public Constructors

Name | Description
BarSeries | Creates a new instance of the BarSeries class.

Public Fields

Name | Description
AnnotationsProperty | Identifies the Annotations dependency property.
BarTypeProperty | Identifies the BarType dependency property.
BarWidthProperty | Identifies the BarWidth dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelProperty | Identifies the InnerLabel dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
ProgressPathProperty | Identifies the ProgressPath dependency property.
ProgressProperty | Identifies the Progress dependency property.
TopLabelOffsetProperty | Identifies the TopLabelOffset dependency property.
TopLabelPathProperty | Identifies the TopLabelPath dependency property.
TopLabelProperty | Identifies the TopLabel dependency property.
TopLabelTypeProperty | Identifies the TopLabelType dependency property.

Inherited Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property. (Inherited from ChartSeries.)
FillsProperty | Identifies the Fills dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesProperty | Identifies the Strokes dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
X2DataPathProperty | Identifies the X2DataPath dependency property. (Inherited from AxesSeries.)
X2DataProperty | Identifies the X2Data dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
Y2DataPathProperty | Identifies the Y2DataPath dependency property. (Inherited from AxesSeries.)
Y2DataProperty | Identifies the Y2Data dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

Public Properties

Name | Description
Annotations | Gets the list with Annotation-s for the chart.
BarType | Gets or sets the type of the bar chart.
BarWidth | Gets or sets the width of the bar.
InnerLabel | Gets or sets custom inner labels.
InnerLabelPath | Gets or sets the path used for retrieving inner label values from the DataSource.
InnerLabelType | Gets or sets the type of the inner labels.
Progress | Gets or sets the progress of bars in the chart.
ProgressPath | Gets or sets the path used for retrieving progress values from the DataSource.
TopLabel | Gets or sets custom top labels.
TopLabelOffset | Gets or sets the offset for top labels.
TopLabelPath | Gets or sets the path used for retrieving top label values from the DataSource.
TopLabelType | Gets or sets the type of the top labels.

Inherited Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries. (Inherited from ChartSeries.)
Fills | Gets or sets the brushes for the series. (Inherited from ChartSeries.)
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the series labels. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. (Inherited from ChartSeries.)
StrokesSource | Gets or sets the source of strokes used in this ChartSeries. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. (Inherited from ChartSeries.)
X2Data | Gets or sets the data used for calculating the X2-coordinates of data points. (Inherited from AxesSeries.)
X2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the X2-data for this series. (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. (Inherited from AxesSeries.)
Y2Data | Gets or sets the data used for calculating the Y2-coordinates of data points. (Inherited from AxesSeries.)
Y2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y2-data for this series. (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. (Inherited from AxesSeries.)

Inherited Public Methods

Name | Description
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from ChartSeries.)
OnDataChanged | Raises the DataChanged event. (Inherited from ChartSeries.)

Inherited Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

BarSeries Class


MindFusion.Charting.Silverlight.BarSeries Fields

BarSeries Fields
[image]

Public Fields

Name | Description
AnnotationsProperty | Identifies the Annotations dependency property.
BarTypeProperty | Identifies the BarType dependency property.
BarWidthProperty | Identifies the BarWidth dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelProperty | Identifies the InnerLabel dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
ProgressPathProperty | Identifies the ProgressPath dependency property.
ProgressProperty | Identifies the Progress dependency property.
TopLabelOffsetProperty | Identifies the TopLabelOffset dependency property.
TopLabelPathProperty | Identifies the TopLabelPath dependency property.
TopLabelProperty | Identifies the TopLabel dependency property.
TopLabelTypeProperty | Identifies the TopLabelType dependency property.

Inherited Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property. (Inherited from ChartSeries.)
FillsProperty | Identifies the Fills dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesProperty | Identifies the Strokes dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
X2DataPathProperty | Identifies the X2DataPath dependency property. (Inherited from AxesSeries.)
X2DataProperty | Identifies the X2Data dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
Y2DataPathProperty | Identifies the Y2DataPath dependency property. (Inherited from AxesSeries.)
Y2DataProperty | Identifies the Y2Data dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

See Also

BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.AnnotationsProperty Field

BarSeries.AnnotationsProperty Field
[image]

Identifies the Annotations dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AnnotationsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AnnotationsProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.BarTypeProperty Field

BarSeries.BarTypeProperty Field
[image]

Identifies the BarType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BarTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BarTypeProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.BarWidthProperty Field

BarSeries.BarWidthProperty Field
[image]

Identifies the BarWidth dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BarWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BarWidthProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.InnerLabelPathProperty Field

BarSeries.InnerLabelPathProperty Field
[image]

Identifies the InnerLabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelPathProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.InnerLabelProperty Field

BarSeries.InnerLabelProperty Field
[image]

Identifies the InnerLabel dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.InnerLabelTypeProperty Field

BarSeries.InnerLabelTypeProperty Field
[image]

Identifies the InnerLabelType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelTypeProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.ProgressPathProperty Field

BarSeries.ProgressPathProperty Field
[image]

Identifies the ProgressPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ProgressPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ProgressPathProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.ProgressProperty Field

BarSeries.ProgressProperty Field
[image]

Identifies the Progress dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ProgressProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ProgressProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.TopLabelOffsetProperty Field

BarSeries.TopLabelOffsetProperty Field
[image]

Identifies the TopLabelOffset dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelOffsetProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.TopLabelPathProperty Field

BarSeries.TopLabelPathProperty Field
[image]

Identifies the TopLabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelPathProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.TopLabelProperty Field

BarSeries.TopLabelProperty Field
[image]

Identifies the TopLabel dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.TopLabelTypeProperty Field

BarSeries.TopLabelTypeProperty Field
[image]

Identifies the TopLabelType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopLabelTypeProperty As DependencyProperty

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries Constructor

BarSeries Constructor
[image]

Creates a new instance of the BarSeries class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BarSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BarSeries Class


MindFusion.Charting.Silverlight.BarSeries Properties

BarSeries Properties
[image]

Public Properties

Name | Description
Annotations | Gets the list with Annotation-s for the chart.
BarType | Gets or sets the type of the bar chart.
BarWidth | Gets or sets the width of the bar.
InnerLabel | Gets or sets custom inner labels.
InnerLabelPath | Gets or sets the path used for retrieving inner label values from the DataSource.
InnerLabelType | Gets or sets the type of the inner labels.
Progress | Gets or sets the progress of bars in the chart.
ProgressPath | Gets or sets the path used for retrieving progress values from the DataSource.
TopLabel | Gets or sets custom top labels.
TopLabelOffset | Gets or sets the offset for top labels.
TopLabelPath | Gets or sets the path used for retrieving top label values from the DataSource.
TopLabelType | Gets or sets the type of the top labels.

Inherited Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries. (Inherited from ChartSeries.)
Fills | Gets or sets the brushes for the series. (Inherited from ChartSeries.)
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the series labels. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. (Inherited from ChartSeries.)
StrokesSource | Gets or sets the source of strokes used in this ChartSeries. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. (Inherited from ChartSeries.)
X2Data | Gets or sets the data used for calculating the X2-coordinates of data points. (Inherited from AxesSeries.)
X2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the X2-data for this series. (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. (Inherited from AxesSeries.)
Y2Data | Gets or sets the data used for calculating the Y2-coordinates of data points. (Inherited from AxesSeries.)
Y2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y2-data for this series. (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. (Inherited from AxesSeries.)

See Also

BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.Annotations Property

BarSeries.Annotations Property
[image]

Gets the list with Annotation-s for the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public AnnotationsCollection Annotations { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Annotations As AnnotationsCollection

Property Value

An empty AnnotationsCollection.

Remarks

Create and add Annotation-s to this collection to mark important data or events at a chart.

Example

The following example adds an annotation as a point at value 10 to the first bar in a BarSeries series.

C# [image] Copy Code
Annotation annotation1 = new Annotation();
annotation1.Index = 0;
annotation1.Label = "Break";
annotation1.Value = 10.0;
annotation1.AnnotationType = AnnotationType.Point;
annotation1.Fill = new SolidColorBrush(Colors.Green);
annotation1.Stroke = new SolidColorBrush(Colors.Green);
series.Annotations.Add(annotation1);
Visual Basic [image] Copy Code
Dim annotation1 As Annotation = New Annotation
annotation1.Index = 0
annotation1.Label = "Break"
annotation1.Value = 10
annotation1.AnnotationType = AnnotationType.Point
annotation1.Fill = New SolidColorBrush(Colors.Green)
annotation1.Stroke = New SolidColorBrush(Colors.Green)
series.Annotations.Add(annotation1)

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.BarType Property

BarSeries.BarType Property
[image]

Gets or sets the type of the bar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BarType BarType { get; set; }

Visual Basic [image] Copy Code

Public Property BarType As BarType

Property Value

One of the BarType enumeration values. Default value is BarType.Vertical.

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.BarWidth Property

BarSeries.BarWidth Property
[image]

Gets or sets the width of the bar.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double BarWidth { get; set; }

Visual Basic [image] Copy Code

Public Property BarWidth As Double

Property Value

A double value. Default is 0.8

Remarks

Valid values range from 0 to 1 and indicate the percentage of available space for this bar at the axis. The rest is left as an empty space. Value of 0.8 means that the bar will take 80% of the space alocated for it at the axis and the rest will be empty space - 10% before and 10% after the series.

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.InnerLabel Property

BarSeries.InnerLabel Property
[image]

Gets or sets custom inner labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection InnerLabel { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabel As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty list.

Remarks

The InnerLabels property is used when the InnerLabelType is LabelType.CustomText.

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.InnerLabelPath Property

BarSeries.InnerLabelPath Property
[image]

Gets or sets the path used for retrieving inner label values from the DataSource.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string InnerLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelPath As String

Property Value

A string. Default value is an empty string ("").

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.InnerLabelType Property

BarSeries.InnerLabelType Property
[image]

Gets or sets the type of the inner labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LabelType InnerLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelType As LabelType

Property Value

One of the LabelType enumeration values. Default value is LabelType.Empty.

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.Progress Property

BarSeries.Progress Property
[image]

Gets or sets the progress of bars in the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public IList Progress { get; set; }

Visual Basic [image] Copy Code

Public Property Progress As IList

Property Value

A single dimensional list with double values. Default value is an empty list.

Remarks

The values in the list correspond to the bars in the series. The first value corresponds to the first bar etc. Each value indicates the progress of the bar in terms of bar data e.g. if the data for the bar is 60 and you want to indicate that progress is at 1/3 of it, you should add 20 at the poistion corrsponding to the bar in the Progress array.

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.ProgressPath Property

BarSeries.ProgressPath Property
[image]

Gets or sets the path used for retrieving progress values from the DataSource.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string ProgressPath { get; set; }

Visual Basic [image] Copy Code

Public Property ProgressPath As String

Property Value

A string value. Default value is an empty string ("").

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.TopLabel Property

BarSeries.TopLabel Property
[image]

Gets or sets custom top labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection TopLabel { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabel As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty list.

Remarks

The TopLabel property is used when the TopLabelType is LabelType.CustomText.

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.TopLabelOffset Property

BarSeries.TopLabelOffset Property
[image]

Gets or sets the offset for top labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double TopLabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelOffset As Double

Property Value

A double value. Default is 5.0.

Remarks

Top labels are drawn when the TopLabelType is not set to LabelType.Empty.

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.TopLabelPath Property

BarSeries.TopLabelPath Property
[image]

Gets or sets the path used for retrieving top label values from the DataSource.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string TopLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelPath As String

Property Value

A string value. Default value is an empty string ("").

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarSeries.TopLabelType Property

BarSeries.TopLabelType Property
[image]

Gets or sets the type of the top labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LabelType TopLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property TopLabelType As LabelType

Property Value

One of the LabelType enumeration values. Default value is LabelType.Empty.

See Also

BarSeries Members
BarSeries Class


MindFusion.Charting.Silverlight.BarType Enumeration

BarType Enumeration
[image]

Specifies the types of bar charts supported by the control.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum BarType

Visual Basic [image] Copy Code

Public Enum BarType

Members

Member name | Description
Horizontal | Bars are drawn horizontal.
HorizontalOverlay | Bars are drawn horizontal and bars from each series are drawn inside the respective bar from the previous series.
HorizontalStack | Bars are drawn in a horizontal stack.
Vertical | Bars are drawn vertical.
VerticalOverlay | Bars are drawn vertical and bars from each series are drawn inside the respective bar from the previous series.
VerticalStack | Bars are drawn in a vertical stack.

See Also


MindFusion.Charting.Silverlight.Behavior Enumeration

Behavior Enumeration
[image]

Defines values that specify how the component responds to actions performed by the user.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum Behavior

Visual Basic [image] Copy Code

Public Enum Behavior

Members

Member name | Description
AllowXDrag | Allows dragging of chart points along the X axes.
AllowYDrag | Allows dragging of chart points along the Y axes.
DoNothing | The control does not respont to actions performed by the user.
ZoomChart | The control responds to actions performed by the user by zooming the chart.

Remarks

The enumeration allows bitwise combining.

Example

The following code allows data points in a line chart to be dragged with the mouse in all directions.

C# [image] Copy Code

lineChart1.Behavior = Behavior.AllowXDrag | Behavior.AllowYDrag;

Visual Basic [image] Copy Code

lineChart1.Behavior = (Behavior.AllowXDrag Or Behavior.AllowYDrag)

See Also


MindFusion.Charting.Silverlight.BrushCollection Class

BrushCollection Class
[image]

Represents an observable collection of System.Windows.Media.Brush objects.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class BrushCollection : ObservableCollection<Brush>

Visual Basic [image] Copy Code

Public Class BrushCollection
Inherits ObservableCollection(Of Brush)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Brush)
System.Collections.ObjectModel.ObservableCollection(Brush)
MindFusion.Charting.Silverlight.BrushCollection

See Also

BrushCollection Members


MindFusion.Charting.Silverlight.BrushCollection Members

BrushCollection Members
Constructors
[image]

Represents an observable collection of System.Windows.Media.Brush objects.

The following tables list the members exposed by the BrushCollection type.

Public Constructors

Name | Description
BrushCollection | Initializes a new instance of the BrushCollection class.

See Also

BrushCollection Class


MindFusion.Charting.Silverlight.BrushCollection Constructor

BrushCollection Constructor
[image]

Initializes a new instance of the BrushCollection class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

BrushCollection Class


MindFusion.Charting.Silverlight.CanvasInitializedEventArgs Class

CanvasInitializedEventArgs Class
Remarks See Also
[image]

Provides data for events that are raised when canvas is initialized.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class CanvasInitializedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CanvasInitializedEventArgs
Inherits EventArgs

Remarks

This class is used internally by the control.

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Charting.Silverlight.CanvasInitializedEventArgs

See Also

CanvasInitializedEventArgs Members


MindFusion.Charting.Silverlight.CanvasInitializedEventArgs Members

CanvasInitializedEventArgs Members
Constructors Properties
[image]

Provides data for events that are raised when canvas is initialized.

The following tables list the members exposed by the CanvasInitializedEventArgs type.

Public Constructors

Name | Description
CanvasInitializedEventArgs | Initializes a new instance of the CanvasInitializedEventArgs class.

Public Properties

Name | Description
ChartCanvas | Gets the canvas.

See Also

CanvasInitializedEventArgs Class


MindFusion.Charting.Silverlight.CanvasInitializedEventArgs Constructor

CanvasInitializedEventArgs Constructor
[image]

Initializes a new instance of the CanvasInitializedEventArgs class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public CanvasInitializedEventArgs (
Canvas canvas
)

Visual Basic [image] Copy Code

Public New ( _
canvas As Canvas _
)

Parameters

canvas

The canvas.

See Also

CanvasInitializedEventArgs Class


MindFusion.Charting.Silverlight.CanvasInitializedEventArgs Properties

CanvasInitializedEventArgs Properties
[image]

Public Properties

Name | Description
ChartCanvas | Gets the canvas.

See Also

CanvasInitializedEventArgs Class


MindFusion.Charting.Silverlight.CanvasInitializedEventArgs.ChartCanvas Property

CanvasInitializedEventArgs.ChartCanvas Property
[image]

Gets the canvas.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Canvas ChartCanvas { get; set; }

Visual Basic [image] Copy Code

Public Property ChartCanvas As Canvas

Property Value

A System.Windows.Controls.Canvas object.

See Also

CanvasInitializedEventArgs Members
CanvasInitializedEventArgs Class


MindFusion.Charting.Silverlight.CanvasInitializedEventHandler Delegate

CanvasInitializedEventHandler Delegate
[image]

Delegate for the CanvasInitialized event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public delegate void CanvasInitializedEventHandler (
Object sender,
CanvasInitializedEventArgs e
)

Visual Basic [image] Copy Code

Public Delegate Sub CanvasInitializedEventHandler( _
sender As Object, _
e As CanvasInitializedEventArgs _
)

Parameters

sender

The object that fired the event.

e

CanvasInitializedEventArgs object that gives information about the event.

See Also


MindFusion.Charting.Silverlight.CanvasSizeInitializedEventArgs Class

CanvasSizeInitializedEventArgs Class
[image]

Provides data for events that are raised when canvas size is initialized.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class CanvasSizeInitializedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CanvasSizeInitializedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Charting.Silverlight.CanvasSizeInitializedEventArgs

See Also

CanvasSizeInitializedEventArgs Members


MindFusion.Charting.Silverlight.CanvasSizeInitializedEventArgs Members

CanvasSizeInitializedEventArgs Members
Constructors Properties
[image]

Provides data for events that are raised when canvas size is initialized.

The following tables list the members exposed by the CanvasSizeInitializedEventArgs type.

Public Constructors

Name | Description
CanvasSizeInitializedEventArgs | Initializes a new instance of the CanvasSizeInitializedEventArgs class.

Public Properties

Name | Description
CanvasSize | Gets the size of the canvas.

See Also

CanvasSizeInitializedEventArgs Class


MindFusion.Charting.Silverlight.CanvasSizeInitializedEventArgs Constructor

CanvasSizeInitializedEventArgs Constructor
[image]

Initializes a new instance of the CanvasSizeInitializedEventArgs class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public CanvasSizeInitializedEventArgs (
Size size
)

Visual Basic [image] Copy Code

Public New ( _
size As Size _
)

Parameters

size

The size of the canvas.

See Also

CanvasSizeInitializedEventArgs Class


MindFusion.Charting.Silverlight.CanvasSizeInitializedEventArgs Properties

CanvasSizeInitializedEventArgs Properties
[image]

Public Properties

Name | Description
CanvasSize | Gets the size of the canvas.

See Also

CanvasSizeInitializedEventArgs Class


MindFusion.Charting.Silverlight.CanvasSizeInitializedEventArgs.CanvasSize Property

CanvasSizeInitializedEventArgs.CanvasSize Property
[image]

Gets the size of the canvas.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Size CanvasSize { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CanvasSize As Size

Property Value

A System.Windows.Size structure.

See Also

CanvasSizeInitializedEventArgs Members
CanvasSizeInitializedEventArgs Class


MindFusion.Charting.Silverlight.Chart Class

Chart Class
[image]

Base class for all charts.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public abstract class Chart : Control

Visual Basic [image] Copy Code

Public MustInherit Class Chart
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Silverlight.Chart
MindFusion.Charting.Silverlight.AxesChart
MindFusion.Charting.Silverlight.PieChart
MindFusion.Charting.Silverlight.RadarChart

See Also

Chart Members


MindFusion.Charting.Silverlight.Chart Members

Chart Members
Constructors Fields Properties Methods Events
[image]

Base class for all charts.

The following tables list the members exposed by the Chart type.

Public Constructors

Name | Description
Chart | Initializes a new instance of the Chart class.

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DataSourceProperty | Identifies the DataSource dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleMarginProperty | Identifies the TitleMargin dependency property.
TitleProperty | Identifies the Title dependency property.
TitleVisibilityProperty | Identifies the TitleVisibility dependency property.

Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle.
DataSource | Gets or sets the data source. This is a dependency property.
LabelFontFamily | Gets or sets the font family for the chart labels.
LabelFontSize | Gets or sets the font size for the chart labels.
LabelFontStyle | Gets or sets the font style for the chart labels.
LabelFontWeight | Gets or sets the font weight for the chart labels.
Legends | Gets or sets a list with the chart legends.
PlotAreaMargin | Gets or sets the margin around the plot area.
Series | Gets the list with the series in the chart.
Title | Gets or sets the title of the chart.
TitleFontFamily | Gets or sets the font family for the title.
TitleFontSize | Gets or sets the font size for the title.
TitleFontStyle | Gets or sets the font style for the title.
TitleFontWeight | Gets or sets the font weight for the title.
TitleMargin | Gets or sets the margin around the title.
TitleVisibility | Gets or sets the visibility of the chart's title.

Public Methods

Name | Description
HitTest | Gets a collection of ChartElement-s that contain the point specified as parameter.
LoadTheme | Loads a ChartTheme from the specified file.
OnAppearanceChanged | Raises the AppearanceChanged event.
OnApplyTemplate | Invoked whenever application code or internal processes call.
OnDataChanged | Fired when data on the chart has changed.
SaveTheme | Saves the appearance of the current chart as a ChartTheme.
UpdateChart | Recalculates and redraws the chart.

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes.
DataChanged | Occurs when the data for the chart has changed.

See Also

Chart Class


MindFusion.Charting.Silverlight.Chart Fields

Chart Fields
[image]

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
DataSourceProperty | Identifies the DataSource dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property.
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property.
TitleFontSizeProperty | Identifies the TitleFontSize dependency property.
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property.
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property.
TitleMarginProperty | Identifies the TitleMargin dependency property.
TitleProperty | Identifies the Title dependency property.
TitleVisibilityProperty | Identifies the TitleVisibility dependency property.

See Also

Chart Class


MindFusion.Charting.Silverlight.Chart.CornerRadiusProperty Field

Chart.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.DataSourceProperty Field

Chart.DataSourceProperty Field
[image]

Identifies the DataSource dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataSourceProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.LabelFontFamilyProperty Field

Chart.LabelFontFamilyProperty Field
[image]

Identifies the LabelFontFamily dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontFamilyProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.LabelFontSizeProperty Field

Chart.LabelFontSizeProperty Field
[image]

Identifies the LabelFontSize dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontSizeProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.LabelFontStyleProperty Field

Chart.LabelFontStyleProperty Field
[image]

Identifies the LabelFontStyle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontStyleProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.LabelFontWeightProperty Field

Chart.LabelFontWeightProperty Field
[image]

Identifies the LabelFontWeight dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontWeightProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.PlotAreaMarginProperty Field

Chart.PlotAreaMarginProperty Field
[image]

Identifies the PlotAreaMargin dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaMarginProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleFontFamilyProperty Field

Chart.TitleFontFamilyProperty Field
[image]

Identifies the TitleFontFamily dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontFamilyProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleFontSizeProperty Field

Chart.TitleFontSizeProperty Field
[image]

Identifies the TitleFontSize dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontSizeProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleFontStyleProperty Field

Chart.TitleFontStyleProperty Field
[image]

Identifies the TitleFontStyle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontStyleProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleFontWeightProperty Field

Chart.TitleFontWeightProperty Field
[image]

Identifies the TitleFontWeight dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleFontWeightProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleMarginProperty Field

Chart.TitleMarginProperty Field
[image]

Identifies the TitleMargin dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleMarginProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleMarginProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleProperty Field

Chart.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleVisibilityProperty Field

Chart.TitleVisibilityProperty Field
[image]

Identifies the TitleVisibility dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleVisibilityProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleVisibilityProperty As DependencyProperty

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart Constructor

Chart Constructor
[image]

Initializes a new instance of the Chart class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Chart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Chart Class


MindFusion.Charting.Silverlight.Chart Methods

Chart Methods
[image]

Public Methods

Name | Description
HitTest | Gets a collection of ChartElement-s that contain the point specified as parameter.
LoadTheme | Loads a ChartTheme from the specified file.
OnAppearanceChanged | Raises the AppearanceChanged event.
OnApplyTemplate | Invoked whenever application code or internal processes call.
OnDataChanged | Fired when data on the chart has changed.
SaveTheme | Saves the appearance of the current chart as a ChartTheme.
UpdateChart | Recalculates and redraws the chart.

See Also

Chart Class


MindFusion.Charting.Silverlight.Chart.HitTest Method

Chart.HitTest Method
[image]

Gets a collection of ChartElement-s that contain the point specified as parameter.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public new List<ChartElement> HitTest (
Point p
)

Visual Basic [image] Copy Code

Public Shadows Function HitTest( _
p As Point _
) As List(Of ChartElement)

Parameters

p

A System.Windows.Point to test.

Return Value

A collection of ChartElement objects.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.LoadTheme Method

Chart.LoadTheme Method
[image]

Loads a ChartTheme from the specified file.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void LoadTheme (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadTheme( _
fileName As String _
)

Parameters

fileName

The name of the XML file that describes the theme.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.OnAppearanceChanged Method

Chart.OnAppearanceChanged Method
[image]

Raises the AppearanceChanged event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void OnAppearanceChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnAppearanceChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The object that raised the event.

e

An instance of the System.Windows.DependencyPropertyChangedEventArgs class that provides data for the event.

Remarks

This method is used internally by the control and is not intended to be called by your code.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.OnApplyTemplate Method

Chart.OnApplyTemplate Method
[image]

Invoked whenever application code or internal processes call.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

Remarks

This method is used internally by the control and is not intended to be called by your code.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.OnDataChanged Method

Chart.OnDataChanged Method
[image]

Fired when data on the chart has changed.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void OnDataChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnDataChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The chart instance that fired the event.

e

A System.Windows.DependencyPropertyChangedEventArgs object that specifies the event data.

Remarks

This method is used internally by the control and is not intended to be called by your code.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.SaveTheme Method

Chart.SaveTheme Method
[image]

Saves the appearance of the current chart as a ChartTheme.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void SaveTheme (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveTheme( _
fileName As String _
)

Parameters

fileName

The name of the XML file where the ChartTheme will be saved.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.UpdateChart Method

Chart.UpdateChart Method
[image]

Recalculates and redraws the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void UpdateChart ()

Visual Basic [image] Copy Code

Public Sub UpdateChart ()

Remarks

Called internally after a change in charts settings or data.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart Properties

Chart Properties
[image]

Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle.
DataSource | Gets or sets the data source. This is a dependency property.
LabelFontFamily | Gets or sets the font family for the chart labels.
LabelFontSize | Gets or sets the font size for the chart labels.
LabelFontStyle | Gets or sets the font style for the chart labels.
LabelFontWeight | Gets or sets the font weight for the chart labels.
Legends | Gets or sets a list with the chart legends.
PlotAreaMargin | Gets or sets the margin around the plot area.
Series | Gets the list with the series in the chart.
Title | Gets or sets the title of the chart.
TitleFontFamily | Gets or sets the font family for the title.
TitleFontSize | Gets or sets the font size for the title.
TitleFontStyle | Gets or sets the font style for the title.
TitleFontWeight | Gets or sets the font weight for the title.
TitleMargin | Gets or sets the margin around the title.
TitleVisibility | Gets or sets the visibility of the chart's title.

See Also

Chart Class


MindFusion.Charting.Silverlight.Chart.CornerRadius Property

Chart.CornerRadius Property
[image]

Gets or sets the corner radius of the chart control's bounding rectangle.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

An instance of the System.Windows.CornerRadius structure. Default value is CornerRadius(3).

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.DataSource Property

Chart.DataSource Property
[image]

Gets or sets the data source. This is a dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public IEnumerable DataSource { get; set; }

Visual Basic [image] Copy Code

Public Property DataSource As IEnumerable

Property Value

An IEnumerable collection that holds the data. Default value is an empty collection.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.LabelFontFamily Property

Chart.LabelFontFamily Property
[image]

Gets or sets the font family for the chart labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontFamily LabelFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontFamily As FontFamily

Property Value

An instance of the System.Windows.Media.FontFamily class. Default value is Times New Roman.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.LabelFontSize Property

Chart.LabelFontSize Property
[image]

Gets or sets the font size for the chart labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double LabelFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontSize As Double

Property Value

A double value. Default is 12.0

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.LabelFontStyle Property

Chart.LabelFontStyle Property
[image]

Gets or sets the font style for the chart labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontStyle LabelFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontStyle As FontStyle

Property Value

An instance of the System.Windows.FontStyle structure. Default value is FontStyles.Normal.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.LabelFontWeight Property

Chart.LabelFontWeight Property
[image]

Gets or sets the font weight for the chart labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontWeight LabelFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontWeight As FontWeight

Property Value

An instance of the System.Windows.FontWeight class. Default value is FontWeights.Normal.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.Legends Property

Chart.Legends Property
[image]

Gets or sets a list with the chart legends.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LegendsCollection Legends { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Legends As LegendsCollection

Property Value

A strongly typed LegendsCollection. Default value is an empty LegendsCollection.

Example

The following code creates and adds a SeriesLegend to a bar chart. The legend labels are taken from the XLabels of the bar chart, the lgend brushes are taken from the bar brushes.

C# [image] Copy Code
SeriesLegend legend = new SeriesLegend();
legend.BorderBrush = new SolidColorBrush(Color.FromArgb(255, 206, 206, 255));
legend.Background = new SolidColorBrush(Colors.White);
legend.BorderThickness = new Thickness(1);
legend.CornerRadius = new CornerRadius(3);
legend.LabelsSource = barChart1.XLabels;
legend.BrushesSource = series1.Fills;
LayoutPanel.SetDock(legend, Dock.Right);
legend.VerticalAlignment = VerticalAlignment.Bottom;
legend.Margin = new Thickness(10);
legend.Padding = new Thickness(3);
legend.FontSize = 16;
barChart1.Legends.Add(legend);
Visual Basic [image] Copy Code
Dim legend As SeriesLegend = New SeriesLegend
legend.BorderBrush = New SolidColorBrush(Color.FromArgb(255, 206, 206, 255))
legend.Background = New SolidColorBrush(Colors.White)
legend.BorderThickness = New Thickness(1)
legend.CornerRadius = New CornerRadius(3)
legend.LabelsSource = barChart1.XLabels
legend.BrushesSource = series1.Fills
LayoutPanel.SetDock(legend, Dock.Right)
legend.VerticalAlignment = VerticalAlignment.Bottom
legend.Margin = New Thickness(10)
legend.Padding = New Thickness(3)
legend.FontSize = 16
barChart1.Legends.Add(legend)

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.PlotAreaMargin Property

Chart.PlotAreaMargin Property
[image]

Gets or sets the margin around the plot area.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Thickness PlotAreaMargin { get; set; }

Visual Basic [image] Copy Code

Public Property PlotAreaMargin As Thickness

Property Value

An instance of the System.Windows

Remarks

The plot area is the canvas where the chart graphics is drawn. Around the plot area are located the title and the legend(s).

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.Series Property

Chart.Series Property
[image]

Gets the list with the series in the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ChartSeriesCollection Series { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Series As ChartSeriesCollection

Property Value

A strongly types ChartSeriesCollection. Default value is a ChartSeriesCollection with one series.

Remarks

When you place the control at the form there is always a single chart series to aid visualisation. Delete or modify it.

Example

The following example modifies the data in the default series of a bar chart.

C# [image] Copy Code
BarSeries series1 = barChart1.Series[0] as BarSeries;
series1.YDataPath = "Profit";
Visual Basic [image] Copy Code
Dim series1 As BarSeries = CType(barChart1.Series(0),BarSeries)
series1.YDataPath = "Profit"

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.Title Property

Chart.Title Property
[image]

Gets or sets the title of the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value. By default newly created charts show "Product Sales" as their title.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleFontFamily Property

Chart.TitleFontFamily Property
[image]

Gets or sets the font family for the title.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontFamily TitleFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontFamily As FontFamily

Property Value

An instance of the System.Windows.Media.FontFamily class. Default value is Times New Roman.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleFontSize Property

Chart.TitleFontSize Property
[image]

Gets or sets the font size for the title.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double TitleFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontSize As Double

Property Value

A double value. Default is 14.0

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleFontStyle Property

Chart.TitleFontStyle Property
[image]

Gets or sets the font style for the title.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontStyle TitleFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontStyle As FontStyle

Property Value

An instance of the System.Windows.FontStyle structure. Default value is FontStyles.Normal.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleFontWeight Property

Chart.TitleFontWeight Property
[image]

Gets or sets the font weight for the title.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontWeight TitleFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFontWeight As FontWeight

Property Value

An instance of the System.Windows.FontWeight class. Default value is FontWeights.Normal.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleMargin Property

Chart.TitleMargin Property
[image]

Gets or sets the margin around the title.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Thickness TitleMargin { get; set; }

Visual Basic [image] Copy Code

Public Property TitleMargin As Thickness

Property Value

An instance of the System.Windows.Thickness structure. Default value is Thickness(0, 10, 0, 0).

Remarks

By default the title is 10 device-independent units above the plot area.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.TitleVisibility Property

Chart.TitleVisibility Property
[image]

Gets or sets the visibility of the chart's title.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Visibility TitleVisibility { get; set; }

Visual Basic [image] Copy Code

Public Property TitleVisibility As Visibility

Property Value

One of the System.Windows.Visibility enumeration values. Default value is Visibility.Visible.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart Events

Chart Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes.
DataChanged | Occurs when the data for the chart has changed.

See Also

Chart Class


MindFusion.Charting.Silverlight.Chart.AppearanceChanged Event

Chart.AppearanceChanged Event
[image]

Occurs when the value of a property that influences the appearance of the chart changes.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler AppearanceChanged

Visual Basic [image] Copy Code

Public Event AppearanceChanged As PropertyChangedEventHandler

Remarks

This event is used internally by the control and is not intended to be called by your code.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.Chart.DataChanged Event

Chart.DataChanged Event
[image]

Occurs when the data for the chart has changed.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

Remarks

This event is used internally by the control and is not intended to be called by your code.

See Also

Chart Members
Chart Class


MindFusion.Charting.Silverlight.ChartElement Class

ChartElement Class
[image]

Base class for all graphical elements on the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public abstract class ChartElement : IShapeCreator

Visual Basic [image] Copy Code

Public MustInherit Class ChartElement
Implements IShapeCreator

Inheritance Hierarchy

System.Object
MindFusion.Charting.Silverlight.ChartElement
MindFusion.Charting.Silverlight.Bar
MindFusion.Charting.Silverlight.Line
MindFusion.Charting.Silverlight.PiePiece
MindFusion.Charting.Silverlight.Scatter

See Also

ChartElement Members


MindFusion.Charting.Silverlight.ChartElement Members

ChartElement Members
Constructors Properties Methods
[image]

Base class for all graphical elements on the chart.

The following tables list the members exposed by the ChartElement type.

Public Constructors

Name | Description
ChartElement | Initializes a new instance of the ChartElement class.

Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement.
Fill | Gets the fill of the element.
Shape | Gets or sers the shape that represents this ChartElement.
Stroke | Gets or the stroke of the element.
StrokeDashArray | Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape.
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.
StrokeDashOffset | Gets a Double that specifies the distance within the dash pattern where a dash begins.
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line.
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape.
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element.
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line.
StrokeThickness | Gets the stroke thickness of the element.

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element.

See Also

ChartElement Class


MindFusion.Charting.Silverlight.ChartElement Constructor

ChartElement Constructor
[image]

Initializes a new instance of the ChartElement class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ChartElement ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartElement Class


MindFusion.Charting.Silverlight.ChartElement Methods

ChartElement Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element.

See Also

ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.CreateShape Method

ChartElement.CreateShape Method
[image]

Creates a Shape that represents the chart element.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public abstract Shape CreateShape ()

Visual Basic [image] Copy Code

Public MustOverride Function CreateShape () As Shape

Return Value

An instance of the System.Windows.Shape class.

Remarks

This method is used internally by the control and is not intended to be called by your code.

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement Properties

ChartElement Properties
[image]

Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement.
Fill | Gets the fill of the element.
Shape | Gets or sers the shape that represents this ChartElement.
Stroke | Gets or the stroke of the element.
StrokeDashArray | Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape.
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.
StrokeDashOffset | Gets a Double that specifies the distance within the dash pattern where a dash begins.
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line.
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape.
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element.
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line.
StrokeThickness | Gets the stroke thickness of the element.

See Also

ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.Effect Property

ChartElement.Effect Property
[image]

Gets or sets the effect of this ChartElement.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Effect Effect { get; set; }

Visual Basic [image] Copy Code

Public Property Effect As Effect

Property Value

An instance of the System.Windows.Media.Effects.Effect class.

Remarks

Use the ChartSeries.Effect property to set the effect for the whole series.

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.Fill Property

ChartElement.Fill Property
[image]

Gets the fill of the element.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush Fill { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Fill As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is a blue SolidColorBrush.

Remarks

The Fill property is used for painting the interior of the bar, pie piece, area etc.

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.Shape Property

ChartElement.Shape Property
[image]

Gets or sers the shape that represents this ChartElement.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Shape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As Shape

Property Value

An instance of the System.Windows.Media.Shapes.Shape class.

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.Stroke Property

ChartElement.Stroke Property
[image]

Gets or the stroke of the element.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush Stroke { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Stroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is a black SolidColorBrush.

Remarks

The Stroke brush is used for drawing the outline of a bar, pie piece, scatter shape etc.

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.StrokeDashArray Property

ChartElement.StrokeDashArray Property
[image]

Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection StrokeDashArray { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeDashArray As DoubleCollection

Property Value

An instance of the System.Windows.Media.DoubleCollection class.

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.StrokeDashCap Property

ChartElement.StrokeDashCap Property
[image]

Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PenLineCap StrokeDashCap { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeDashCap As PenLineCap

Property Value

An instance of the System.Windows.Media.PenLineCap enumeration values. Default value is PenLineCap.Flat.

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.StrokeDashOffset Property

ChartElement.StrokeDashOffset Property
[image]

Gets a Double that specifies the distance within the dash pattern where a dash begins.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StrokeDashOffset { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeDashOffset As Double

Property Value

A double value. Default is 0.0

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.StrokeEndLineCap Property

ChartElement.StrokeEndLineCap Property
[image]

Gets a PenLineCap enumeration value that describes the Shape at the end of a line.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PenLineCap StrokeEndLineCap { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeEndLineCap As PenLineCap

Property Value

An instance of the System.Windows.Media.PenLineCap enumeration values. Default value is PenLineCap.Flat.

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.StrokeLineJoin Property

ChartElement.StrokeLineJoin Property
[image]

Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PenLineJoin StrokeLineJoin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeLineJoin As PenLineJoin

Property Value

An instance of the System.Windows.Media.PenLineJoin enumeration values. Default value is PenLineJoin.Miter.

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.StrokeMiterLimit Property

ChartElement.StrokeMiterLimit Property
[image]

Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StrokeMiterLimit { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeMiterLimit As Double

Property Value

A double value. Default is 1.0

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.StrokeStartLineCap Property

ChartElement.StrokeStartLineCap Property
[image]

Gets a PenLineCap enumeration value that describes the Shape at the start of a line.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PenLineCap StrokeStartLineCap { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeStartLineCap As PenLineCap

Property Value

An instance of the System.Windows.Media.PenLineCap enumeration values. Default value is PenLineCap.Flat.

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartElement.StrokeThickness Property

ChartElement.StrokeThickness Property
[image]

Gets the stroke thickness of the element.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StrokeThickness { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StrokeThickness As Double

Property Value

A double value. Default is 1.0

See Also

ChartElement Members
ChartElement Class


MindFusion.Charting.Silverlight.ChartLegend Class

ChartLegend Class
[image]

Describes a legend where each item gives info about a ChartSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class ChartLegend : Legend

Visual Basic [image] Copy Code

Public Class ChartLegend
Inherits Legend

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Charting.Silverlight.Legend
MindFusion.Charting.Silverlight.ChartLegend

See Also

ChartLegend Members


MindFusion.Charting.Silverlight.ChartLegend Members

ChartLegend Members
Constructors Fields Properties Methods Events
[image]

Describes a legend where each item gives info about a ChartSeries.

The following tables list the members exposed by the ChartLegend type.

Public Constructors

Name | Description
ChartLegend | Initializes a new instance of the ChartLegend class.

Public Fields

Name | Description
SeriesProperty | Identifies the Series dependency property.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Legend.)
OrientationProperty | Identifies the Orientation dependency property. (Inherited from Legend.)
ShapeSizeProperty | Identifies the ShapeSize dependency property. (Inherited from Legend.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from Legend.)

Public Properties

Name | Description
Series | Gets or sets the ChartSeriesCollection for the legend.

Inherited Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the Legend. (Inherited from Legend.)
Orientation | Gets or sets the orientation of the Legend. (Inherited from Legend.)
ShapeSize | Gets or sets the size of the shapes in the Legend. (Inherited from Legend.)
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the Legend. (Inherited from Legend.)

Inherited Public Methods

Name | Description
OnDataChanged | Raises the DataChanged event. (Inherited from Legend.)
RegisterForNotification | Listens for changes in the specified dependency property. (Inherited from Legend.)

Inherited Public Events

Name | Description
DataChanged | Occurs when series appearance was changed. (Inherited from Legend.)

See Also

ChartLegend Class


MindFusion.Charting.Silverlight.ChartLegend Fields

ChartLegend Fields
[image]

Public Fields

Name | Description
SeriesProperty | Identifies the Series dependency property.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Legend.)
OrientationProperty | Identifies the Orientation dependency property. (Inherited from Legend.)
ShapeSizeProperty | Identifies the ShapeSize dependency property. (Inherited from Legend.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from Legend.)

See Also

ChartLegend Class


MindFusion.Charting.Silverlight.ChartLegend.SeriesProperty Field

ChartLegend.SeriesProperty Field
[image]

Identifies the Series dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SeriesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SeriesProperty As DependencyProperty

See Also

ChartLegend Members
ChartLegend Class


MindFusion.Charting.Silverlight.ChartLegend Constructor

ChartLegend Constructor
[image]

Initializes a new instance of the ChartLegend class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ChartLegend ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartLegend Class


MindFusion.Charting.Silverlight.ChartLegend Properties

ChartLegend Properties
[image]

Public Properties

Name | Description
Series | Gets or sets the ChartSeriesCollection for the legend.

Inherited Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the Legend. (Inherited from Legend.)
Orientation | Gets or sets the orientation of the Legend. (Inherited from Legend.)
ShapeSize | Gets or sets the size of the shapes in the Legend. (Inherited from Legend.)
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the Legend. (Inherited from Legend.)

See Also

ChartLegend Class


MindFusion.Charting.Silverlight.ChartLegend.Series Property

ChartLegend.Series Property
[image]

Gets or sets the ChartSeriesCollection for the legend.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ChartSeriesCollection Series { get; set; }

Visual Basic [image] Copy Code

Public Property Series As ChartSeriesCollection

Property Value

An empty ChartSeriesCollection.

Remarks

Each label for the legend is taken from ChartSeries.Title property.

Example

The following example adds a ChartLegend to a line chart - the labels and brushes for the legend are taken from the series of the chart.

C# [image] Copy Code
ChartLegend legend = new ChartLegend();
legend.Series = lineChart1.Series;
LayoutPanel.SetDock(legend, Dock.Left);
lineChart1.Legends.Add(legend);
Visual Basic [image] Copy Code
Dim legend As ChartLegend = New ChartLegend
legend.Series = lineChart1.Series
LayoutPanel.SetDock(legend, Dock.Left)
lineChart1.Legends.Add(legend)

See Also

ChartLegend Members
ChartLegend Class


MindFusion.Charting.Silverlight.ChartSeries Class

ChartSeries Class
[image]

Base class for series in the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public abstract class ChartSeries : FrameworkElement

Visual Basic [image] Copy Code

Public MustInherit Class ChartSeries
Inherits FrameworkElement

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Silverlight.ChartSeries
MindFusion.Charting.Silverlight.AxesSeries
MindFusion.Charting.Silverlight.PieSeries
MindFusion.Charting.Silverlight.RadarSeries

See Also

ChartSeries Members


MindFusion.Charting.Silverlight.ChartSeries Members

ChartSeries Members
Constructors Fields Properties Methods Events
[image]

Base class for series in the chart.

The following tables list the members exposed by the ChartSeries type.

Public Constructors

Name | Description
ChartSeries | Initializes a new instance of the ChartSeries class.

Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property.
FillsProperty | Identifies the Fills dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property.
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property.
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
LabelForegroundProperty | Identifies the LabelForeground dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property.
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property.
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property.
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property.
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property.
StrokesProperty | Identifies the Strokes dependency property.
StrokesSourceProperty | Identifies the StrokesSource dependency property.
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TitleProperty | Identifies the Title dependency property.

Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries.
Fills | Gets or sets the brushes for the series.
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries.
Index | Gets or sets the index of this ChartSeries.
LabelBackground | Gets or sets the background of the label.
LabelBorderBrush | Gets or sets the brush for the label border.
LabelBorderThickness | Gets or sets the thickness of the label border.
LabelFontFamily | Gets or sets the font family for the chart labels.
LabelFontSize | Gets or sets the font size for the chart labels.
LabelFontStyle | Gets or sets the font style for the chart labels.
LabelFontWeight | Gets or sets the font weight for the series labels.
LabelForeground | Gets or sets the foreground of the label.
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes.
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn.
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins.
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line.
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape.
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element.
Strokes | Gets the strokes of the series.
StrokesSource | Gets or sets the source of strokes used in this ChartSeries.
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line.
StrokeThickness | Gets or sets the thickness of the stroke for the series.
Title | Gets or sets the title of the series.

Public Methods

Name | Description
OnAppearanceChanged | Raises the AppearanceChanged event.
OnDataChanged | Raises the DataChanged event.

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed.
DataChanged | Occurs when series data was changed.

See Also

ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries Fields

ChartSeries Fields
[image]

Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property.
FillsProperty | Identifies the Fills dependency property.
FillsSourceProperty | Identifies the FillsSource dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property.
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property.
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property.
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property.
LabelFontSizeProperty | Identifies the LabelFontSize dependency property.
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property.
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property.
LabelForegroundProperty | Identifies the LabelForeground dependency property.
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property.
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property.
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property.
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property.
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property.
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property.
StrokesProperty | Identifies the Strokes dependency property.
StrokesSourceProperty | Identifies the StrokesSource dependency property.
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TitleProperty | Identifies the Title dependency property.

See Also

ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.EffectProperty Field

ChartSeries.EffectProperty Field
[image]

Identifies the Effect dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EffectProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EffectProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.FillsProperty Field

ChartSeries.FillsProperty Field
[image]

Identifies the Fills dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillsProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.FillsSourceProperty Field

ChartSeries.FillsSourceProperty Field
[image]

Identifies the FillsSource dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillsSourceProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelBackgroundProperty Field

ChartSeries.LabelBackgroundProperty Field
[image]

Identifies the LabelBackground dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBackgroundProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelBorderBrushProperty Field

ChartSeries.LabelBorderBrushProperty Field
[image]

Identifies the LabelBorderBrush dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBorderBrushProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelBorderThicknessProperty Field

ChartSeries.LabelBorderThicknessProperty Field
[image]

Identifies the LabelBorderThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBorderThicknessProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelFontFamilyProperty Field

ChartSeries.LabelFontFamilyProperty Field
[image]

Identifies the LabelFontFamily dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontFamilyProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontFamilyProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelFontSizeProperty Field

ChartSeries.LabelFontSizeProperty Field
[image]

Identifies the LabelFontSize dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontSizeProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelFontStyleProperty Field

ChartSeries.LabelFontStyleProperty Field
[image]

Identifies the LabelFontStyle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontStyleProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelFontWeightProperty Field

ChartSeries.LabelFontWeightProperty Field
[image]

Identifies the LabelFontWeight dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFontWeightProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelForegroundProperty Field

ChartSeries.LabelForegroundProperty Field
[image]

Identifies the LabelForeground dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelForegroundProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeDashArrayProperty Field

ChartSeries.StrokeDashArrayProperty Field
[image]

Identifies the StrokeDashArray dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashArrayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashArrayProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeDashCapProperty Field

ChartSeries.StrokeDashCapProperty Field
[image]

Identifies the StrokeDashCap dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashCapProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeDashOffsetProperty Field

ChartSeries.StrokeDashOffsetProperty Field
[image]

Identifies the StrokeDashOffset dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeDashOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeDashOffsetProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeEndLineCapProperty Field

ChartSeries.StrokeEndLineCapProperty Field
[image]

Identifies the StrokeEndLineCap dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeEndLineCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeEndLineCapProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeLineJoinProperty Field

ChartSeries.StrokeLineJoinProperty Field
[image]

Identifies the StrokeLineJoin dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeLineJoinProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeLineJoinProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeMiterLimitProperty Field

ChartSeries.StrokeMiterLimitProperty Field
[image]

Identifies the StrokeMiterLimit dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeMiterLimitProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeMiterLimitProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokesProperty Field

ChartSeries.StrokesProperty Field
[image]

Identifies the Strokes dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokesProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokesSourceProperty Field

ChartSeries.StrokesSourceProperty Field
[image]

Identifies the StrokesSource dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokesSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokesSourceProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeStartLineCapProperty Field

ChartSeries.StrokeStartLineCapProperty Field
[image]

Identifies the StrokeStartLineCap dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeStartLineCapProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeStartLineCapProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeThicknessProperty Field

ChartSeries.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.TitleProperty Field

ChartSeries.TitleProperty Field
[image]

Identifies the Title dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TitleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TitleProperty As DependencyProperty

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries Constructor

ChartSeries Constructor
[image]

Initializes a new instance of the ChartSeries class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ChartSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries Methods

ChartSeries Methods
[image]

Public Methods

Name | Description
OnAppearanceChanged | Raises the AppearanceChanged event.
OnDataChanged | Raises the DataChanged event.

See Also

ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.OnAppearanceChanged Method

ChartSeries.OnAppearanceChanged Method
[image]

Raises the AppearanceChanged event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void OnAppearanceChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnAppearanceChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The object that raised the event.

e

An instance of the System.Windows.DependencyPropertyChangedEventArgs class that contains data for the event.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.OnDataChanged Method

ChartSeries.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void OnDataChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnDataChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The ChartSeries that raised the event.

e

An instance of the System.Windows.DependencyPropertyChangedEventArgs class that contains data for the event.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries Properties

ChartSeries Properties
[image]

Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries.
Fills | Gets or sets the brushes for the series.
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries.
Index | Gets or sets the index of this ChartSeries.
LabelBackground | Gets or sets the background of the label.
LabelBorderBrush | Gets or sets the brush for the label border.
LabelBorderThickness | Gets or sets the thickness of the label border.
LabelFontFamily | Gets or sets the font family for the chart labels.
LabelFontSize | Gets or sets the font size for the chart labels.
LabelFontStyle | Gets or sets the font style for the chart labels.
LabelFontWeight | Gets or sets the font weight for the series labels.
LabelForeground | Gets or sets the foreground of the label.
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes.
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn.
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins.
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line.
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape.
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element.
Strokes | Gets the strokes of the series.
StrokesSource | Gets or sets the source of strokes used in this ChartSeries.
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line.
StrokeThickness | Gets or sets the thickness of the stroke for the series.
Title | Gets or sets the title of the series.

See Also

ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.Effect Property

ChartSeries.Effect Property
[image]

Gets or sets the visual effect for this ChartSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Effect Effect { get; set; }

Visual Basic [image] Copy Code

Public Property Effect As Effect

Property Value

An instance of the System.Windows.Media.Effects.Effect class. By default no effect is set.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.Fills Property

ChartSeries.Fills Property
[image]

Gets or sets the brushes for the series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection Fills { get; set; }

Visual Basic [image] Copy Code

Public Property Fills As BrushCollection

Property Value

An instance of the BrushCollection class. Default value is an empty list.

Remarks

The Fills property is used for filling the interior of bars, areas, pie pieces etc.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.FillsSource Property

ChartSeries.FillsSource Property
[image]

Gets or sets the source for the Brush-es used in this ChartSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public List<Brush> FillsSource { get; set; }

Visual Basic [image] Copy Code

Public Property FillsSource As List(Of Brush)

Property Value

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.Index Property

ChartSeries.Index Property
[image]

Gets or sets the index of this ChartSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An int value. Default is -1.

Remarks

The index property identifies the ChartSeries in the Series collection.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelBackground Property

ChartSeries.LabelBackground Property
[image]

Gets or sets the background of the label.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush LabelBackground { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBackground As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

Remarks

Use LabelBackground to fill a rectangle under each label at chart data points.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelBorderBrush Property

ChartSeries.LabelBorderBrush Property
[image]

Gets or sets the brush for the label border.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush LabelBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBorderBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

Remarks

The LabelBorderBrush paints the border of the rectangle that is drawn under labels when LabelBackground is not null.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelBorderThickness Property

ChartSeries.LabelBorderThickness Property
[image]

Gets or sets the thickness of the label border.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Thickness LabelBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBorderThickness As Thickness

Property Value

An instance of the System.Windows.Thickness enumeration. Default value is Thickness(1).

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelFontFamily Property

ChartSeries.LabelFontFamily Property
[image]

Gets or sets the font family for the chart labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontFamily LabelFontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontFamily As FontFamily

Property Value

An instance of the System.Windows.Media.FontFamily class. Default value is Times New Roman.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelFontSize Property

ChartSeries.LabelFontSize Property
[image]

Gets or sets the font size for the chart labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double LabelFontSize { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontSize As Double

Property Value

A double value. Default is 12.0.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelFontStyle Property

ChartSeries.LabelFontStyle Property
[image]

Gets or sets the font style for the chart labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontStyle LabelFontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontStyle As FontStyle

Property Value

An instance of the System.Windows.FontStyle structure. Default value is FontStyles.Normal.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelFontWeight Property

ChartSeries.LabelFontWeight Property
[image]

Gets or sets the font weight for the series labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontWeight LabelFontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFontWeight As FontWeight

Property Value

An instance of the System.Windows.FontWeight class. Default value is FontWeights.Normal.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.LabelForeground Property

ChartSeries.LabelForeground Property
[image]

Gets or sets the foreground of the label.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush LabelForeground { get; set; }

Visual Basic [image] Copy Code

Public Property LabelForeground As Brush

Property Value

A System.Windows.Media.Brush object used for painting the foreground of the labels at this ChartSeries.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeDashArray Property

ChartSeries.StrokeDashArray Property
[image]

Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection StrokeDashArray { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashArray As DoubleCollection

Property Value

An instance of the System.Windows.Media.DoubleCollection class. Default value is an empty DoubleCollection.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeDashCap Property

ChartSeries.StrokeDashCap Property
[image]

Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PenLineCap StrokeDashCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashCap As PenLineCap

Property Value

An instance of the System.Windows.Media.PenLineCap enumeration values. Default value is PenLineCap.Flat.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeDashOffset Property

ChartSeries.StrokeDashOffset Property
[image]

Gets or sets a double that specifies the distance within the dash pattern where a dash begins.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StrokeDashOffset { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashOffset As Double

Property Value

A double value. Default is 0.0.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeEndLineCap Property

ChartSeries.StrokeEndLineCap Property
[image]

Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PenLineCap StrokeEndLineCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeEndLineCap As PenLineCap

Property Value

An instance of the System.Windows.Media.PenLineCap enumeration values. Default value is PenLineCap.Flat.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeLineJoin Property

ChartSeries.StrokeLineJoin Property
[image]

Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PenLineJoin StrokeLineJoin { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeLineJoin As PenLineJoin

Property Value

An instance of the System.Windows.Media.PenLineJoin enumeration values. Default value is PenLineJoin.Miter.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeMiterLimit Property

ChartSeries.StrokeMiterLimit Property
[image]

Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StrokeMiterLimit { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeMiterLimit As Double

Property Value

A double value. Default is 1.0

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.Strokes Property

ChartSeries.Strokes Property
[image]

Gets the strokes of the series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection Strokes { get; set; }

Visual Basic [image] Copy Code

Public Property Strokes As BrushCollection

Property Value

An instance of the BrushCollection class. Default value is an empty list.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokesSource Property

ChartSeries.StrokesSource Property
[image]

Gets or sets the source of strokes used in this ChartSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public List<Brush> StrokesSource { get; set; }

Visual Basic [image] Copy Code

Public Property StrokesSource As List(Of Brush)

Property Value

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeStartLineCap Property

ChartSeries.StrokeStartLineCap Property
[image]

Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PenLineCap StrokeStartLineCap { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeStartLineCap As PenLineCap

Property Value

An instance of the System.Windows.Media.PenLineCap enumeration values. Default value is PenLineCap.Flat.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.StrokeThickness Property

ChartSeries.StrokeThickness Property
[image]

Gets or sets the thickness of the stroke for the series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value. Default is 1.0

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.Title Property

ChartSeries.Title Property
[image]

Gets or sets the title of the series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value. Default value is an empty string ("").

Remarks

The property is used by the ChartLegend - each item in the legend is read from the Title property of the respective ChartSeries in the ChartLegend.Series collection.

Example

The following example adds a ChartLegend to a line chart - the labels and brushes for the legend are taken from the series of the chart.

C# [image] Copy Code
ChartLegend legend = new ChartLegend();
legend.Series = lineChart1.Series;
LayoutPanel.SetDock(legend, Dock.Left);
lineChart1.Legends.Add(legend);
Visual Basic [image] Copy Code
Dim legend As ChartLegend = New ChartLegend
legend.Series = lineChart1.Series
LayoutPanel.SetDock(legend, Dock.Left)
lineChart1.Legends.Add(legend)

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries Events

ChartSeries Events
[image]

Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed.
DataChanged | Occurs when series data was changed.

See Also

ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.AppearanceChanged Event

ChartSeries.AppearanceChanged Event
[image]

Occurs when series appearance was changed.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler AppearanceChanged

Visual Basic [image] Copy Code

Public Event AppearanceChanged As PropertyChangedEventHandler

Remarks

This event is used internally by the control and is not intended to be called by your code.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeries.DataChanged Event

ChartSeries.DataChanged Event
[image]

Occurs when series data was changed.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

Remarks

This event is used internally by the control and is not intended to be called by your code.

See Also

ChartSeries Members
ChartSeries Class


MindFusion.Charting.Silverlight.ChartSeriesCollection Class

ChartSeriesCollection Class
[image]

Represents an observable collection of ChartSeries objects.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class ChartSeriesCollection : ObservableCollection<ChartSeries>

Visual Basic [image] Copy Code

Public Class ChartSeriesCollection
Inherits ObservableCollection(Of ChartSeries)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(ChartSeries)
System.Collections.ObjectModel.ObservableCollection(ChartSeries)
MindFusion.Charting.Silverlight.ChartSeriesCollection

See Also

ChartSeriesCollection Members


MindFusion.Charting.Silverlight.ChartSeriesCollection Members

ChartSeriesCollection Members
Constructors
[image]

Represents an observable collection of ChartSeries objects.

The following tables list the members exposed by the ChartSeriesCollection type.

Public Constructors

Name | Description
ChartSeriesCollection | Initializes a new instance of the ChartSeriesCollection class.

See Also

ChartSeriesCollection Class


MindFusion.Charting.Silverlight.ChartSeriesCollection Constructor

ChartSeriesCollection Constructor
[image]

Initializes a new instance of the ChartSeriesCollection class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ChartSeriesCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartSeriesCollection Class


MindFusion.Charting.Silverlight.ChartSeriesToBrushConverter Class

ChartSeriesToBrushConverter Class
[image]

Returns the Brush that corresponds to the given ChartSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class ChartSeriesToBrushConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ChartSeriesToBrushConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Silverlight.ChartSeriesToBrushConverter

See Also

ChartSeriesToBrushConverter Members


MindFusion.Charting.Silverlight.ChartSeriesToBrushConverter Members

ChartSeriesToBrushConverter Members
Constructors Methods
[image]

Returns the Brush that corresponds to the given ChartSeries.

The following tables list the members exposed by the ChartSeriesToBrushConverter type.

Public Constructors

Name | Description
ChartSeriesToBrushConverter |

Public Methods

Name | Description
Convert | Converts a ChartSeries to a System.Windows.Media.Brush object.
ConvertBack | Converts a value.

See Also

ChartSeriesToBrushConverter Class


MindFusion.Charting.Silverlight.ChartSeriesToBrushConverter Constructor

ChartSeriesToBrushConverter Constructor
[image]

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ChartSeriesToBrushConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartSeriesToBrushConverter Class


MindFusion.Charting.Silverlight.ChartSeriesToBrushConverter Methods

ChartSeriesToBrushConverter Methods
[image]

Public Methods

Name | Description
Convert | Converts a ChartSeries to a System.Windows.Media.Brush object.
ConvertBack | Converts a value.

See Also

ChartSeriesToBrushConverter Class


MindFusion.Charting.Silverlight.ChartSeriesToBrushConverter.Convert Method

ChartSeriesToBrushConverter.Convert Method
[image]

Converts a ChartSeries to a System.Windows.Media.Brush object.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The type of the target property in the binding.

parameter

A parameter to use in the conversion.

culture

The culture to use in the conversion.

Return Value

A System.Windows.Media.Brush object.

See Also

ChartSeriesToBrushConverter Members
ChartSeriesToBrushConverter Class


MindFusion.Charting.Silverlight.ChartSeriesToBrushConverter.ConvertBack Method

ChartSeriesToBrushConverter.ConvertBack Method
[image]

Converts a value.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type to convert to.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

The converted value.

See Also

ChartSeriesToBrushConverter Members
ChartSeriesToBrushConverter Class


MindFusion.Charting.Silverlight.ChartSeriesToStrokeConverter Class

ChartSeriesToStrokeConverter Class
[image]

Returns the Stroke that corresponds to the given ChartSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class ChartSeriesToStrokeConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ChartSeriesToStrokeConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Silverlight.ChartSeriesToStrokeConverter

See Also

ChartSeriesToStrokeConverter Members


MindFusion.Charting.Silverlight.ChartSeriesToStrokeConverter Members

ChartSeriesToStrokeConverter Members
Constructors Methods
[image]

Returns the Stroke that corresponds to the given ChartSeries.

The following tables list the members exposed by the ChartSeriesToStrokeConverter type.

Public Constructors

Name | Description
ChartSeriesToStrokeConverter | Initializes a new instance of the ChartSeriesToStrokeConverter class.

Public Methods

Name | Description
Convert | Converts a ChartSeries to a Brush.
ConvertBack | Converts a value.

See Also

ChartSeriesToStrokeConverter Class


MindFusion.Charting.Silverlight.ChartSeriesToStrokeConverter Constructor

ChartSeriesToStrokeConverter Constructor
[image]

Initializes a new instance of the ChartSeriesToStrokeConverter class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ChartSeriesToStrokeConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartSeriesToStrokeConverter Class


MindFusion.Charting.Silverlight.ChartSeriesToStrokeConverter Methods

ChartSeriesToStrokeConverter Methods
[image]

Public Methods

Name | Description
Convert | Converts a ChartSeries to a Brush.
ConvertBack | Converts a value.

See Also

ChartSeriesToStrokeConverter Class


MindFusion.Charting.Silverlight.ChartSeriesToStrokeConverter.Convert Method

ChartSeriesToStrokeConverter.Convert Method
[image]

Converts a ChartSeries to a Brush.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value to convert.

targetType

The type of the target property in the binding.

parameter

A parameter to use in the conversion.

culture

The culture to use in the conversion.

Return Value

A System.Windows.Media.Brush object.

See Also

ChartSeriesToStrokeConverter Members
ChartSeriesToStrokeConverter Class


MindFusion.Charting.Silverlight.ChartSeriesToStrokeConverter.ConvertBack Method

ChartSeriesToStrokeConverter.ConvertBack Method
[image]

Converts a value.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type to convert to.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

The converted value.

See Also

ChartSeriesToStrokeConverter Members
ChartSeriesToStrokeConverter Class


MindFusion.Charting.Silverlight.ChartTheme Class

ChartTheme Class
[image]

Represents an appearance theme for the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class ChartTheme

Visual Basic [image] Copy Code

Public Class ChartTheme

Inheritance Hierarchy

System.Object
MindFusion.Charting.Silverlight.ChartTheme

See Also

ChartTheme Members


MindFusion.Charting.Silverlight.ChartTheme Members

ChartTheme Members
Constructors Properties Methods
[image]

Represents an appearance theme for the chart.

The following tables list the members exposed by the ChartTheme type.

Public Constructors

Name | Description
ChartTheme | Overloaded.

Public Properties

Name | Description
AxisStyles | Gets or sets the styles for the axis series.
SeriesStyles | Gets or sets the style for the ChartSeries.
ThemeStyle | Gets or sets the style of the ChartTheme.

Public Methods

Name | Description
Apply | Applies this ChartTheme at the specified chart.
BasedOn | Copies the appearance settings of the specified chart to the current theme.
LoadFromXml | Overloaded.
SaveToXml | Overloaded.

See Also

ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme Constructor

ChartTheme Constructor
[image]

Overload List

Name | Description
ChartTheme () | Initializes a new instance of the ChartTheme class.
ChartTheme (Chart) | Initializes a new ChartTheme based on the apprearance of the specified chart.

See Also

ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme Constructor ()

ChartTheme Constructor ()
See Also
[image]

Initializes a new instance of the ChartTheme class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ChartTheme ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ChartTheme Constructor Overload List
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme Constructor (Chart)

ChartTheme Constructor (Chart)
See Also
[image]

Initializes a new ChartTheme based on the apprearance of the specified chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ChartTheme (
Chart chart
)

Visual Basic [image] Copy Code

Public New ( _
chart As Chart _
)

Parameters

chart

The chart, which provides appearance settings for this ChartTheme.

See Also

ChartTheme Constructor Overload List
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme Methods

ChartTheme Methods
[image]

Public Methods

Name | Description
Apply | Applies this ChartTheme at the specified chart.
BasedOn | Copies the appearance settings of the specified chart to the current theme.
LoadFromXml | Overloaded.
SaveToXml | Overloaded.

See Also

ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.Apply Method

ChartTheme.Apply Method
[image]

Applies this ChartTheme at the specified chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void Apply (
Chart chart
)

Visual Basic [image] Copy Code

Public Sub Apply( _
chart As Chart _
)

Parameters

chart

The chart at which the theme is applied.

See Also

ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.BasedOn Method

ChartTheme.BasedOn Method
[image]

Copies the appearance settings of the specified chart to the current theme.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void BasedOn (
Chart chart
)

Visual Basic [image] Copy Code

Public Sub BasedOn( _
chart As Chart _
)

Parameters

chart

The chart that provides the appearance settings.

See Also

ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.LoadFromXml Method

ChartTheme.LoadFromXml Method
[image]

Overload List

Name | Description
ChartTheme.LoadFromXml (String) | Loads the current ChartTheme from the specified XML file.
ChartTheme.LoadFromXml (XNode) | Loads the settings for the current ChartTheme from the specified XML node.
ChartTheme.LoadFromXml (XElement) | Loads the settings for the current ChartTheme from the specified XML node.
ChartTheme.LoadFromXml (Stream) | Loads the settings for this ChartTheme from the specified stream.

See Also

ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.LoadFromXml Method (String)

ChartTheme.LoadFromXml Method (String)
See Also
[image]

Loads the current ChartTheme from the specified XML file.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The name of the XML file.

See Also

LoadFromXml Method Overload List
ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.LoadFromXml Method (XNode)

ChartTheme.LoadFromXml Method (XNode)
See Also
[image]

Loads the settings for the current ChartTheme from the specified XML node.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public virtual void LoadFromXml (
XNode node
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromXml( _
node As XNode _
)

Parameters

node

The node to load the settings from.

See Also

LoadFromXml Method Overload List
ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.LoadFromXml Method (XElement)

ChartTheme.LoadFromXml Method (XElement)
See Also
[image]

Loads the settings for the current ChartTheme from the specified XML node.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public virtual void LoadFromXml (
XElement node
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromXml( _
node As XElement _
)

Parameters

node

The node to load the settings from.

See Also

LoadFromXml Method Overload List
ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.LoadFromXml Method (Stream)

ChartTheme.LoadFromXml Method (Stream)
See Also
[image]

Loads the settings for this ChartTheme from the specified stream.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void LoadFromXml (
Stream fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As Stream _
)

Parameters

fileName

An instance of the System.IO.Stream class.

See Also

LoadFromXml Method Overload List
ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.SaveToXml Method

ChartTheme.SaveToXml Method
[image]

Overload List

Name | Description
ChartTheme.SaveToXml (String) | Saves the current theme to the specified XML file.
ChartTheme.SaveToXml (XNode) | Saves the current theme under the specified XNode.

See Also

ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.SaveToXml Method (String)

ChartTheme.SaveToXml Method (String)
See Also
[image]

Saves the current theme to the specified XML file.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void SaveToXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
fileName As String _
)

Parameters

fileName

The name of the file.

See Also

SaveToXml Method Overload List
ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.SaveToXml Method (XNode)

ChartTheme.SaveToXml Method (XNode)
See Also
[image]

Saves the current theme under the specified XNode.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void SaveToXml (
XNode node
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
node As XNode _
)

Parameters

node

The Xml node under which the ChartTheme will be saved.

See Also

SaveToXml Method Overload List
ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme Properties

ChartTheme Properties
[image]

Public Properties

Name | Description
AxisStyles | Gets or sets the styles for the axis series.
SeriesStyles | Gets or sets the style for the ChartSeries.
ThemeStyle | Gets or sets the style of the ChartTheme.

See Also

ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.AxisStyles Property

ChartTheme.AxisStyles Property
[image]

Gets or sets the styles for the axis series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public List<Style> AxisStyles { get; set; }

Visual Basic [image] Copy Code

Public Property AxisStyles As List(Of Style)

Property Value

A list of System.Windows.Style objects. Each style in the list sets the appearance of one of the chart axes.

See Also

ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.SeriesStyles Property

ChartTheme.SeriesStyles Property
[image]

Gets or sets the style for the ChartSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public List<Style> SeriesStyles { get; set; }

Visual Basic [image] Copy Code

Public Property SeriesStyles As List(Of Style)

Property Value

A list of System.Windows.Style objects. Each style in the list sets the appearance of one ChartSeries.

See Also

ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartTheme.ThemeStyle Property

ChartTheme.ThemeStyle Property
[image]

Gets or sets the style of the ChartTheme.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Style ThemeStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ThemeStyle As Style

Property Value

An instance of the System.Windows.Style class.

See Also

ChartTheme Members
ChartTheme Class


MindFusion.Charting.Silverlight.ChartValueConverter Class

ChartValueConverter Class
[image]

Provides capabilities to convert various types to and from strings in a cutlure-independent way.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public sealed class ChartValueConverter

Visual Basic [image] Copy Code

Public NotInheritable Class ChartValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Charting.Silverlight.ChartValueConverter

See Also

ChartValueConverter Members


MindFusion.Charting.Silverlight.ChartValueConverter Members

ChartValueConverter Members
Fields Methods
[image]

Provides capabilities to convert various types to and from strings in a cutlure-independent way.

The following tables list the members exposed by the ChartValueConverter type.

Public Fields

Name | Description
NAMESPACE | The XML namespace for shape library files.

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Overloaded.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
FromXmlElement | Deserializes a Point object from the specified XmlElement.
SaveTo | Writes the specified System.Windows.Point to the specified XmlWriter.
ToBoolean | Converts the specified string value to bool.
ToBrush | Converts the specified string value to a System.Windows.Media.Brush.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specifed string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to a 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to a float.
ToStream | Converts the specified string value to a System.IO.Stream.
ToStreamV4 | Converts the specified string value to System.IO.Stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter Fields

ChartValueConverter Fields
[image]

Public Fields

Name | Description
NAMESPACE | The XML namespace for shape library files.

See Also

ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.NAMESPACE Field

ChartValueConverter.NAMESPACE Field
[image]

The XML namespace for shape library files.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string NAMESPACE

Visual Basic [image] Copy Code

Public Shared NAMESPACE As String

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter Methods

ChartValueConverter Methods
[image]

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Overloaded.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
FromXmlElement | Deserializes a Point object from the specified XmlElement.
SaveTo | Writes the specified System.Windows.Point to the specified XmlWriter.
ToBoolean | Converts the specified string value to bool.
ToBrush | Converts the specified string value to a System.Windows.Media.Brush.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specifed string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to a 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to a float.
ToStream | Converts the specified string value to a System.IO.Stream.
ToStreamV4 | Converts the specified string value to System.IO.Stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromBoolean Method

ChartValueConverter.FromBoolean Method
[image]

Converts the specified bool value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromBoolean (
bool val
)

Visual Basic [image] Copy Code

Public Shared Function FromBoolean( _
val As Boolean _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromByte Method

ChartValueConverter.FromByte Method
[image]

Converts the specified byte value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromByte (
byte val
)

Visual Basic [image] Copy Code

Public Shared Function FromByte( _
val As Byte _
) As String

Parameters

val

The byte value to convert.

Return Value

A string that represents the specified byte value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromChar Method

ChartValueConverter.FromChar Method
[image]

Converts the specified char value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromChar (
char val
)

Visual Basic [image] Copy Code

Public Shared Function FromChar( _
val As Char _
) As String

Parameters

val

The char value to convert.

Return Value

A string that represents the specified char value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromColor Method

ChartValueConverter.FromColor Method
[image]

Converts the specified color value to string in the format #AARRGGBB.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromColor (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor( _
val As Color _
) As String

Parameters

val

The color to convert.

Return Value

A string that represents the specified char value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromDecimal Method

ChartValueConverter.FromDecimal Method
[image]

Converts the specified decimal to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromDecimal (
decimal val
)

Visual Basic [image] Copy Code

Public Shared Function FromDecimal( _
val As Decimal _
) As String

Parameters

val

The decimal value to convert.

Return Value

A string that represents the specified decimal value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromDouble Method

ChartValueConverter.FromDouble Method
[image]

Converts the specified double value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromDouble (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromDouble( _
val As Double _
) As String

Parameters

val

The double value to convert.

Return Value

A string that represents the specified double value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromEnum Method

ChartValueConverter.FromEnum Method
[image]

Converts the specified enum value to a string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromEnum (
Object val
)

Visual Basic [image] Copy Code

Public Shared Function FromEnum( _
val As Object _
) As String

Parameters

val

The enum value to convert.

Return Value

A string that represents the specified enum value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromInt16 Method

ChartValueConverter.FromInt16 Method
[image]

Converts the specified 16-bit integer value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromInt16 (
short val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt16( _
val As Short _
) As String

Parameters

val

The Int16 value to convert.

Return Value

A string that represents the specified Int16 value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromInt32 Method

ChartValueConverter.FromInt32 Method
[image]

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromInt32 (
int val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt32( _
val As Integer _
) As String

Parameters

val

The Int32 value to convert.

Return Value

A string that represents the specified Int32 value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromInt64 Method

ChartValueConverter.FromInt64 Method
[image]

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromInt64 (
long val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt64( _
val As Long _
) As String

Parameters

val

The Int64 value to convert.

Return Value

A string that represents the specified Int64 value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromSByte Method

ChartValueConverter.FromSByte Method
[image]

Converts the specified 8-bit signed integer to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromSByte (
sbyte val
)

Visual Basic [image] Copy Code

Public Shared Function FromSByte( _
val As SByte _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified 8-bit signed integer value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromSingle Method

ChartValueConverter.FromSingle Method
[image]

Overload List

Name | Description
ChartValueConverter.FromSingle (Double) | Converts the specified double value to string.
ChartValueConverter.FromSingle (Single) | Converts the specified float value to string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromSingle Method (Double)

ChartValueConverter.FromSingle Method (Double)
See Also
[image]

Converts the specified double value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromSingle (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Double _
) As String

Parameters

val

The double value to convert.

Return Value

A string representing the specified double value.

See Also

FromSingle Method Overload List
ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromSingle Method (Single)

ChartValueConverter.FromSingle Method (Single)
See Also
[image]

Converts the specified float value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromSingle (
float val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Single _
) As String

Parameters

val

The float value to convert.

Return Value

A string that represents the specified float value.

See Also

FromSingle Method Overload List
ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromStream Method

ChartValueConverter.FromStream Method
[image]

Converts the specified stream to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromStream (
Stream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStream( _
val As Stream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified stream value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromStreamV4 Method

ChartValueConverter.FromStreamV4 Method
[image]

Converts the specified memory stream to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromStreamV4 (
MemoryStream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStreamV4( _
val As MemoryStream _
) As String

Parameters

val

The memory stream object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromUInt16 Method

ChartValueConverter.FromUInt16 Method
[image]

Converts the specified unsigned 16-bit integer value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromUInt16 (
ushort val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt16( _
val As UShort _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified unsigned 16-bit int value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromUInt32 Method

ChartValueConverter.FromUInt32 Method
[image]

Converts the specified unsigned 32-bit integer value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromUInt32 (
uint val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt32( _
val As UInteger _
) As String

Parameters

val

The value to convert.

Return Value

A string that represents the specified unsigned 32-bit integer value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromUInt64 Method

ChartValueConverter.FromUInt64 Method
[image]

Converts the specified unsigned 64-bit integer value to string.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static string FromUInt64 (
ulong val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt64( _
val As ULong _
) As String

Parameters

val

The unsigned Int64-bit value to convert.

Return Value

A string that represents the specified unsigned 64-bit value.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.FromXmlElement Method

ChartValueConverter.FromXmlElement Method
[image]

Deserializes a Point object from the specified XmlElement.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static Point FromXmlElement (
XElement point
)

Visual Basic [image] Copy Code

Public Shared Function FromXmlElement( _
point As XElement _
) As Point

Parameters

point

The XmlElement representing the serialized point.

Return Value

A System.Windows.Point object deserialized from the specified XmlElement.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.SaveTo Method

ChartValueConverter.SaveTo Method
[image]

Writes the specified System.Windows.Point to the specified XmlWriter.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void SaveTo (
XmlWriter w,
Point p
)

Visual Basic [image] Copy Code

Public Shared Sub SaveTo( _
w As XmlWriter, _
p As Point _
)

Parameters

w

The .NET XmlWriter to write to.

p

The Point object to be serialized.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToBoolean Method

ChartValueConverter.ToBoolean Method
[image]

Converts the specified string value to bool.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static bool ToBoolean (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBoolean( _
s As String _
) As Boolean

Parameters

s

The string value to convert from.

Return Value

A boolean value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToBrush Method

ChartValueConverter.ToBrush Method
[image]

Converts the specified string value to a System.Windows.Media.Brush.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static Brush ToBrush (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBrush( _
s As String _
) As Brush

Parameters

s

The string value to convert from.

Return Value

A System.Windows.Media.Brush value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToByte Method

ChartValueConverter.ToByte Method
[image]

Converts the specified string value to byte value.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static byte ToByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToByte( _
s As String _
) As Byte

Parameters

s

The string value to convert from.

Return Value

A byte value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToChar Method

ChartValueConverter.ToChar Method
[image]

Converts the specified string value to char.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static char ToChar (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToChar( _
s As String _
) As Char

Parameters

s

The string value to convert from.

Return Value

A char value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToColor Method

ChartValueConverter.ToColor Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static Color ToColor (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToColor( _
s As String _
) As Color

Parameters

s

The string value to convert from.

Return Value

A Color value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToDecimal Method

ChartValueConverter.ToDecimal Method
[image]

Converts the specified string value to decimal.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static decimal ToDecimal (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDecimal( _
s As String _
) As Decimal

Parameters

s

The string value to convert from.

Return Value

A decimal value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToDouble Method

ChartValueConverter.ToDouble Method
[image]

Converts the specifed string value to double.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static double ToDouble (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDouble( _
s As String _
) As Double

Parameters

s

The string value to convert from.

Return Value

A double value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToEnum Method

ChartValueConverter.ToEnum Method
[image]

Converts the specified string value to its corresponding enumeration member of the specified type.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static Object ToEnum (
Type type,
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToEnum( _
type As Type, _
s As String _
) As Object

Parameters

type

The type of the enumeration to convert to.

s

The string value to convert from.

Return Value

A member of the specified enumeration that is deserialized from the specified string, possibly a null reference (Nothing in Visual Basic) if the deserialization failed.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToInt16 Method

ChartValueConverter.ToInt16 Method
[image]

Converts the specified string value to 16-bit integer.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static short ToInt16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt16( _
s As String _
) As Short

Parameters

s

The string value to convert from.

Return Value

A 16-bit integer value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToInt32 Method

ChartValueConverter.ToInt32 Method
[image]

Overload List

Name | Description
ChartValueConverter.ToInt32 (String) | Converts the specified string value to a 32-bit integer.
ChartValueConverter.ToInt32 (String, Int32) | Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToInt32 Method (String)

ChartValueConverter.ToInt32 Method (String)
See Also
[image]

Converts the specified string value to a 32-bit integer.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String _
) As Integer

Parameters

s

The string value to convert from.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToInt32 Method (String, Int32)

ChartValueConverter.ToInt32 Method (String, Int32)
See Also
[image]

Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s,
int defaultValue
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String, _
defaultValue As Integer _
) As Integer

Parameters

s

The string value to convert from.

defaultValue

The default value to return if s cannot be deserialized.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToInt64 Method

ChartValueConverter.ToInt64 Method
[image]

Converts the specified string value to a 64-bit integer.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static long ToInt64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt64( _
s As String _
) As Long

Parameters

s

The string value to convert from.

Return Value

A 64-bit integer value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToSByte Method

ChartValueConverter.ToSByte Method
[image]

Converts the specified string value to 8-bit signed integer.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static sbyte ToSByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSByte( _
s As String _
) As SByte

Parameters

s

The string value to convert from.

Return Value

An 8-bit signed integer value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToSingle Method

ChartValueConverter.ToSingle Method
[image]

Converts the specified string value to a float.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static float ToSingle (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSingle( _
s As String _
) As Single

Parameters

s

The string value to convert from.

Return Value

A float value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToStream Method

ChartValueConverter.ToStream Method
[image]

Converts the specified string value to a System.IO.Stream.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static Stream ToStream (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStream( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET System.IO.Stream object that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToStreamV4 Method

ChartValueConverter.ToStreamV4 Method
[image]

Converts the specified string value to System.IO.Stream.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static Stream ToStreamV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStreamV4( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A .NET System.IO.Stream object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToUint16 Method

ChartValueConverter.ToUint16 Method
[image]

Converts the specified string value to unsigned 16-bit integer.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static ushort ToUint16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint16( _
s As String _
) As UShort

Parameters

s

The string value to convert from.

Return Value

An unsigned 16-bit integer value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToUint32 Method

ChartValueConverter.ToUint32 Method
[image]

Converts the specified string value to unsigned 32-bit integer.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static uint ToUint32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint32( _
s As String _
) As UInteger

Parameters

s

The string value to convert from.

Return Value

An unsigned 32-bit integer value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.ChartValueConverter.ToUint64 Method

ChartValueConverter.ToUint64 Method
[image]

Converts the specified string value to unsigned 64-bit integer.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static ulong ToUint64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint64( _
s As String _
) As ULong

Parameters

s

The string value to convert from.

Return Value

An unsigned 64-bit integer value that is deserialized from the specified string.

See Also

ChartValueConverter Members
ChartValueConverter Class


MindFusion.Charting.Silverlight.CustomLabelPosition Enumeration

CustomLabelPosition Enumeration
[image]

Specifies where custom labels are drawn at the chart axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum CustomLabelPosition

Visual Basic [image] Copy Code

Public Enum CustomLabelPosition

Members

Member name | Description
AutoScalePoints | The labels are the drawn at auto scale points.
ChartDataPoints | The labels are draw at data points.

Remarks

Custom labels are drawn when the AxisSettings.LabelType property is set to LabelType.CustomText. They are set with AxesChart.XLabels, AxesChart.YLabels, AxesChart.X2Labels or AxesChart.Y2Labels. If you want to use databinding the properties are AxesChart.XLabelPath, AxesChart.YLabelPath, AxesChart.X2LabelPath, AxesChart.Y2LabelPath.

See Also


MindFusion.Charting.Silverlight.Dock Enumeration

Dock Enumeration
[image]

Specifies the docking of elements in a layout panel

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum Dock

Visual Basic [image] Copy Code

Public Enum Dock

Members

Member name | Description
Bottom | the element is docked to the bottom of the panel.
Left | the element is docked to the left of the panel.
Right | the element is docked to the right of the panel.
Top | the element is docked to the top of the panel.

Example

The following example adds a ChartLegend to a line chart and docks it to the left.

C# [image] Copy Code
ChartLegend legend = new ChartLegend();
legend.Series = lineChart1.Series;
LayoutPanel.SetDock(legend, Dock.Left);
lineChart1.Legends.Add(legend);
Visual Basic [image] Copy Code
Dim legend As ChartLegend = New ChartLegend
legend.Series = lineChart1.Series
LayoutPanel.SetDock(legend, Dock.Left)
lineChart1.Legends.Add(legend)

See Also


MindFusion.Charting.Silverlight.DoubleCollectionConverter Class

DoubleCollectionConverter Class
[image]

Provides a unified way of converting values of the DoubleCollection type to other types.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class DoubleCollectionConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class DoubleCollectionConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Charting.Silverlight.DoubleCollectionConverter

See Also

DoubleCollectionConverter Members


MindFusion.Charting.Silverlight.DoubleCollectionConverter Members

DoubleCollectionConverter Members
Constructors Methods
[image]

Provides a unified way of converting values of the DoubleCollection type to other types.

The following tables list the members exposed by the DoubleCollectionConverter type.

Public Constructors

Name | Description
DoubleCollectionConverter | Initializes a new instance of the DoubleCollection class.

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

DoubleCollectionConverter Class


MindFusion.Charting.Silverlight.DoubleCollectionConverter Constructor

DoubleCollectionConverter Constructor
[image]

Initializes a new instance of the DoubleCollection class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollectionConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DoubleCollectionConverter Class


MindFusion.Charting.Silverlight.DoubleCollectionConverter Methods

DoubleCollectionConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

DoubleCollectionConverter Class


MindFusion.Charting.Silverlight.DoubleCollectionConverter.CanConvertFrom Method

DoubleCollectionConverter.CanConvertFrom Method
[image]

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context

An System.ComponentModel.ITypeDescriptorContext that provides a format context.

sourceType

A System.Type that represents the type we want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

DoubleCollectionConverter Members
DoubleCollectionConverter Class


MindFusion.Charting.Silverlight.DoubleCollectionConverter.CanConvertTo Method

DoubleCollectionConverter.CanConvertTo Method
[image]

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context

A System.ComponentModel.ITypeDescriptorContext that provides a format context.

destinationType

A System.Type that represents the type we want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

DoubleCollectionConverter Members
DoubleCollectionConverter Class


MindFusion.Charting.Silverlight.DoubleCollectionConverter.ConvertFrom Method

DoubleCollectionConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context

A System.ComponentModel.ITypeDescriptorContext that provides a format context.

culture

The System.Globalization.CultureInfo to use as the current culture.

value

The System.Object to convert.

Return Value

A System.Object that represents the converted value.

See Also

DoubleCollectionConverter Members
DoubleCollectionConverter Class


MindFusion.Charting.Silverlight.DoubleCollectionConverter.ConvertTo Method

DoubleCollectionConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context

A System.ComponentModel.ITypeDescriptorContext that provides a format context.

culture

A System.Globalization.CultureInfo. If null is passed, the current culture is assumed.

value

The System.Object to convert.

destinationType

The System.Type to convert the value parameter to.

Return Value

See Also

DoubleCollectionConverter Members
DoubleCollectionConverter Class


MindFusion.Charting.Silverlight.GridType Enumeration

GridType Enumeration
[image]

Specifies the possible grid options for chart elements that support grid.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum GridType

Visual Basic [image] Copy Code

Public Enum GridType

Members

Member name | Description
Crossed | The grid is built of vertical and horizontal lines, which follow the intervals of the two axes.
Horizontal | The grid is built of horizontal lines only.
None | No grid is drawn.
Vertical | The grid is built of vertical lines only.

See Also


MindFusion.Charting.Silverlight.InnerLabelPosition Enumeration

InnerLabelPosition Enumeration
[image]

Defines values that specify the position of the inner labels in a radar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum InnerLabelPosition

Visual Basic [image] Copy Code

Public Enum InnerLabelPosition

Members

Member name | Description
Center | The label is aligned to the center.
Left | The label is aligned to the left.
Right | The label is aligned to the right.

See Also


MindFusion.Charting.Silverlight.LabelType Enumeration

LabelType Enumeration
[image]

Specifies the different types of chart labels that can be drawn at the chart axes.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum LabelType

Visual Basic [image] Copy Code

Public Enum LabelType

Members

Member name | Description
AutoScale | The labels are the numbers from the numerical auto scale.
ChartData | The labels are the numbers from the chart data.
CustomText | The labels are set by the user.
Empty | No labels are drawn.
Percents | The labels show the percentage value of each element.

See Also


MindFusion.Charting.Silverlight.LayoutPanel Class

LayoutPanel Class
[image]

Represents the panel of the whole chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class LayoutPanel : Panel

Visual Basic [image] Copy Code

Public Class LayoutPanel
Inherits Panel

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
MindFusion.Charting.Silverlight.LayoutPanel

See Also

LayoutPanel Members


MindFusion.Charting.Silverlight.LayoutPanel Members

LayoutPanel Members
Constructors Fields Attached Properties Properties Methods
[image]

Represents the panel of the whole chart.

The following tables list the members exposed by the LayoutPanel type.

Public Constructors

Name | Description
LayoutPanel | Initializes a new instance of the LayoutPanel class.

Public Fields

Name | Description
DockProperty | Identifies the Dock attached property.
PlotAreaProperty | Identifies the PlotArea dependency property.

Public Attached Properties

Name | Description
DockProperty | Specifies the docking of elements within the PlotArea.

Public Properties

Name | Description
PlotArea | Gtes or sets the plot area where the chart is drawn.

Public Methods

Name | Description
GetDock | Gets the dock of an element contained in the LayoutPanel.
SetDock | Sets the dock of an element added to the layout panel.

Protected Methods

Name | Description
ArrangeOverride | Places the elements within the place allocated for them and according to their dock and alignment.
MeasureOverride | Allocates to each element the space avvailable for it according to its dock preferences.

See Also

LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel Fields

LayoutPanel Fields
[image]

Public Fields

Name | Description
DockProperty | Identifies the Dock attached property.
PlotAreaProperty | Identifies the PlotArea dependency property.

See Also

LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel.DockProperty Field

LayoutPanel.DockProperty Field
[image]

Identifies the Dock attached property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DockProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DockProperty As DependencyProperty

See Also

LayoutPanel Members
LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel.PlotAreaProperty Field

LayoutPanel.PlotAreaProperty Field
[image]

Identifies the PlotArea dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PlotAreaProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PlotAreaProperty As DependencyProperty

See Also

LayoutPanel Members
LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel Constructor

LayoutPanel Constructor
[image]

Initializes a new instance of the LayoutPanel class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LayoutPanel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel Methods

LayoutPanel Methods
[image]

Public Methods

Name | Description
GetDock | Gets the dock of an element contained in the LayoutPanel.
SetDock | Sets the dock of an element added to the layout panel.

Protected Methods

Name | Description
ArrangeOverride | Places the elements within the place allocated for them and according to their dock and alignment.
MeasureOverride | Allocates to each element the space avvailable for it according to its dock preferences.

See Also

LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel.ArrangeOverride Method

LayoutPanel.ArrangeOverride Method
[image]

Places the elements within the place allocated for them and according to their dock and alignment.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size finalSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
finalSize As Size _
) As Size

Parameters

finalSize

The size allocated for the LayoutPanel.

Return Value

The size used by the LayoutPanel.

See Also

LayoutPanel Members
LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel.GetDock Method

LayoutPanel.GetDock Method
[image]

Gets the dock of an element contained in the LayoutPanel.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static Dock GetDock (
UIElement element
)

Visual Basic [image] Copy Code

Public Shared Function GetDock( _
element As UIElement _
) As Dock

Parameters

element

The element.

Return Value

The dock of the element.

See Also

LayoutPanel Members
LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel.MeasureOverride Method

LayoutPanel.MeasureOverride Method
[image]

Allocates to each element the space avvailable for it according to its dock preferences.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The size available for the LayoutPanel.

Return Value

The size requested by the LayoutPanel.

See Also

LayoutPanel Members
LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel.SetDock Method

LayoutPanel.SetDock Method
[image]

Sets the dock of an element added to the layout panel.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void SetDock (
UIElement element,
Dock dock
)

Visual Basic [image] Copy Code

Public Shared Sub SetDock( _
element As UIElement, _
dock As Dock _
)

Parameters

element

The element to be added.

dock

The dock.

See Also

LayoutPanel Members
LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel Attached Properties

LayoutPanel Attached Properties
[image]

Public Attached Properties

Name | Description
DockProperty | Specifies the docking of elements within the PlotArea.

See Also

LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel.Dock Attached Property

LayoutPanel.Dock Attached Property
[image]

Specifies the docking of elements within the PlotArea.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code
See LayoutPanel.GetDock, LayoutPanel.SetDock
Visual Basic [image] Copy Code
See LayoutPanel.GetDock, LayoutPanel.SetDock

Property Value

One of the Dock enumeration members.

Example

The following example adds a ChartLegend to a line chart and docks it to the left.

C# [image] Copy Code
ChartLegend legend = new ChartLegend();
legend.Series = lineChart1.Series;
LayoutPanel.SetDock(legend, Dock.Left);
lineChart1.Legends.Add(legend);
Visual Basic [image] Copy Code
Dim legend As ChartLegend = New ChartLegend
legend.Series = lineChart1.Series
LayoutPanel.SetDock(legend, Dock.Left)
lineChart1.Legends.Add(legend)

See Also

LayoutPanel Members
LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel Properties

LayoutPanel Properties
[image]

Public Properties

Name | Description
PlotArea | Gtes or sets the plot area where the chart is drawn.

See Also

LayoutPanel Class


MindFusion.Charting.Silverlight.LayoutPanel.PlotArea Property

LayoutPanel.PlotArea Property
[image]

Gtes or sets the plot area where the chart is drawn.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FrameworkElement PlotArea { get; set; }

Visual Basic [image] Copy Code

Public Property PlotArea As FrameworkElement

Property Value

A System.Windows.Controls.Canvas object that is the plot area for the chart.

See Also

LayoutPanel Members
LayoutPanel Class


MindFusion.Charting.Silverlight.Legend Class

Legend Class
[image]

A base class for classes that represent chart legends.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public abstract class Legend : ItemsControl

Visual Basic [image] Copy Code

Public MustInherit Class Legend
Inherits ItemsControl

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Charting.Silverlight.Legend
MindFusion.Charting.Silverlight.ChartLegend
MindFusion.Charting.Silverlight.SeriesLegend

See Also

Legend Members


MindFusion.Charting.Silverlight.Legend Members

Legend Members
Constructors Fields Properties Methods Events
[image]

A base class for classes that represent chart legends.

The following tables list the members exposed by the Legend type.

Public Constructors

Name | Description
Legend | Initializes a new Legend.

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ShapeSizeProperty | Identifies the ShapeSize dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the Legend.
Orientation | Gets or sets the orientation of the Legend.
ShapeSize | Gets or sets the size of the shapes in the Legend.
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the Legend.

Public Methods

Name | Description
OnDataChanged | Raises the DataChanged event.
RegisterForNotification | Listens for changes in the specified dependency property.

Public Events

Name | Description
DataChanged | Occurs when series appearance was changed.

See Also

Legend Class


MindFusion.Charting.Silverlight.Legend Fields

Legend Fields
[image]

Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ShapeSizeProperty | Identifies the ShapeSize dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

See Also

Legend Class


MindFusion.Charting.Silverlight.Legend.CornerRadiusProperty Field

Legend.CornerRadiusProperty Field
[image]

Identifies the CornerRadius dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CornerRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.Legend.OrientationProperty Field

Legend.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.Legend.ShapeSizeProperty Field

Legend.ShapeSizeProperty Field
[image]

Identifies the ShapeSize dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShapeSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShapeSizeProperty As DependencyProperty

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.Legend.StrokeThicknessProperty Field

Legend.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.Legend Constructor

Legend Constructor
[image]

Initializes a new Legend.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Legend ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Legend Class


MindFusion.Charting.Silverlight.Legend Methods

Legend Methods
[image]

Public Methods

Name | Description
OnDataChanged | Raises the DataChanged event.
RegisterForNotification | Listens for changes in the specified dependency property.

See Also

Legend Class


MindFusion.Charting.Silverlight.Legend.OnDataChanged Method

Legend.OnDataChanged Method
[image]

Raises the DataChanged event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void OnDataChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnDataChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The object that raised the event.

e

A System.DependencyPropertyChangedEventArgs object that contains data for the event.

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.Legend.RegisterForNotification Method

Legend.RegisterForNotification Method
[image]

Listens for changes in the specified dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public void RegisterForNotification (
string propertyName,
FrameworkElement element,
PropertyChangedCallback callback
)

Visual Basic [image] Copy Code

Public Sub RegisterForNotification( _
propertyName As String, _
element As FrameworkElement, _
callback As PropertyChangedCallback _
)

Parameters

propertyName

The name of the property.

element

The owner of the dependency property.

callback

The callback that handles the change.

Remarks

This method is used internally by the control and is not intended to be called by your code.

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.Legend Properties

Legend Properties
[image]

Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the Legend.
Orientation | Gets or sets the orientation of the Legend.
ShapeSize | Gets or sets the size of the shapes in the Legend.
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the Legend.

See Also

Legend Class


MindFusion.Charting.Silverlight.Legend.CornerRadius Property

Legend.CornerRadius Property
[image]

Gets or sets the corner radius of the Legend.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public CornerRadius CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As CornerRadius

Property Value

An instance of the System.Windows.CornerRadius structure. Default value is CornerRadius().

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.Legend.Orientation Property

Legend.Orientation Property
[image]

Gets or sets the orientation of the Legend.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

One of the System.Windows.Controls.Orientation enumeration values. Default value is Orientation.Vertical.

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.Legend.ShapeSize Property

Legend.ShapeSize Property
[image]

Gets or sets the size of the shapes in the Legend.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double ShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeSize As Double

Property Value

A double value. Default is 20.

Remarks

The ShapeSize property specifies the size of the rectangles that are drawn before each legend label.

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.Legend.StrokeThickness Property

Legend.StrokeThickness Property
[image]

Gets or sets the stroke thickness of lines drawn in the Legend.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value. Default is 1.0

Remarks

The StrokeThickness property is used by the outlining of the legend and the rectangles that stand before each legend label.

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.Legend Events

Legend Events
[image]

Public Events

Name | Description
DataChanged | Occurs when series appearance was changed.

See Also

Legend Class


MindFusion.Charting.Silverlight.Legend.DataChanged Event

Legend.DataChanged Event
[image]

Occurs when series appearance was changed.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler DataChanged

Visual Basic [image] Copy Code

Public Event DataChanged As EventHandler

Remarks

This event is used internally by the control and is not intended to be called by your code.

See Also

Legend Members
Legend Class


MindFusion.Charting.Silverlight.LegendItem Class

LegendItem Class
[image]

Represents an item in a SeriesLegend.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class LegendItem : DependencyObject

Visual Basic [image] Copy Code

Public Class LegendItem
Inherits DependencyObject

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
MindFusion.Charting.Silverlight.LegendItem

See Also

LegendItem Members


MindFusion.Charting.Silverlight.LegendItem Members

LegendItem Members
Constructors Fields Properties
[image]

Represents an item in a SeriesLegend.

The following tables list the members exposed by the LegendItem type.

Public Constructors

Name | Description
LegendItem | Initializes a new instance of the LegendItem class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
LabelProperty | Identifies the Label dependency property.

Public Properties

Name | Description
Brush | The Brush used for painting the shape of this LegendItem.
FontSize | The font size for this label.
Label | Gets or sets the label for this LegendItem.

See Also

LegendItem Class


MindFusion.Charting.Silverlight.LegendItem Fields

LegendItem Fields
[image]

Public Fields

Name | Description
BrushProperty | Identifies the Brush dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
LabelProperty | Identifies the Label dependency property.

See Also

LegendItem Class


MindFusion.Charting.Silverlight.LegendItem.BrushProperty Field

LegendItem.BrushProperty Field
[image]

Identifies the Brush dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BrushProperty As DependencyProperty

See Also

LegendItem Members
LegendItem Class


MindFusion.Charting.Silverlight.LegendItem.FontSizeProperty Field

LegendItem.FontSizeProperty Field
[image]

Identifies the FontSize dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontSizeProperty As DependencyProperty

See Also

LegendItem Members
LegendItem Class


MindFusion.Charting.Silverlight.LegendItem.LabelProperty Field

LegendItem.LabelProperty Field
[image]

Identifies the Label dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelProperty As DependencyProperty

See Also

LegendItem Members
LegendItem Class


MindFusion.Charting.Silverlight.LegendItem Constructor

LegendItem Constructor
[image]

Initializes a new instance of the LegendItem class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LegendItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LegendItem Class


MindFusion.Charting.Silverlight.LegendItem Properties

LegendItem Properties
[image]

Public Properties

Name | Description
Brush | The Brush used for painting the shape of this LegendItem.
FontSize | The font size for this label.
Label | Gets or sets the label for this LegendItem.

See Also

LegendItem Class


MindFusion.Charting.Silverlight.LegendItem.Brush Property

LegendItem.Brush Property
[image]

The Brush used for painting the shape of this LegendItem.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is a blue SolidColorBrush.

Remarks

The Brush property fills the rectangle that is drawn before the legend label.

See Also

LegendItem Members
LegendItem Class


MindFusion.Charting.Silverlight.LegendItem.FontSize Property

LegendItem.FontSize Property
[image]

The font size for this label.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value. Default is 10.0

See Also

LegendItem Members
LegendItem Class


MindFusion.Charting.Silverlight.LegendItem.Label Property

LegendItem.Label Property
[image]

Gets or sets the label for this LegendItem.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Object Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As Object

Property Value

An instance of System.Object . Default value is an empty string ("").

See Also

LegendItem Members
LegendItem Class


MindFusion.Charting.Silverlight.LegendsCollection Class

LegendsCollection Class
[image]

Represents an observable collection of Legend objects.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class LegendsCollection : ObservableCollection<Legend>

Visual Basic [image] Copy Code

Public Class LegendsCollection
Inherits ObservableCollection(Of Legend)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Legend)
System.Collections.ObjectModel.ObservableCollection(Legend)
MindFusion.Charting.Silverlight.LegendsCollection

See Also

LegendsCollection Members


MindFusion.Charting.Silverlight.LegendsCollection Members

LegendsCollection Members
Constructors
[image]

Represents an observable collection of Legend objects.

The following tables list the members exposed by the LegendsCollection type.

Public Constructors

Name | Description
LegendsCollection | Initializes a new instance of the LegendsCollection class.

See Also

LegendsCollection Class


MindFusion.Charting.Silverlight.LegendsCollection Constructor

LegendsCollection Constructor
[image]

Initializes a new instance of the LegendsCollection class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LegendsCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LegendsCollection Class


MindFusion.Charting.Silverlight.Line Class

Line Class
[image]

Represents a line in line charts.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class Line : ChartElement

Visual Basic [image] Copy Code

Public Class Line
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Silverlight.ChartElement
MindFusion.Charting.Silverlight.Line

See Also

Line Members


MindFusion.Charting.Silverlight.Line Members

Line Members
Properties Methods
[image]

Represents a line in line charts.

The following tables list the members exposed by the Line type.

Public Properties

Name | Description
LineType | Gets the type of this Line.
Points | Gets the points for this Line.
SeriesIndex | Gets the index of the ChartSeries this Line represents in the Series collection.

Inherited Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Shape | Gets or sers the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the line element.

Inherited Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element. (Inherited from ChartElement.)

See Also

Line Class


MindFusion.Charting.Silverlight.Line Methods

Line Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the line element.

Inherited Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element. (Inherited from ChartElement.)

See Also

Line Class


MindFusion.Charting.Silverlight.Line.CreateShape Method

Line.CreateShape Method
[image]

Creates a Shape that represents the line element.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

A System.Windows.Shapes.Shape object.

Remarks

This method is used internally by the control and is not intended to be called by your code.

See Also

Line Members
Line Class


MindFusion.Charting.Silverlight.Line Properties

Line Properties
[image]

Public Properties

Name | Description
LineType | Gets the type of this Line.
Points | Gets the points for this Line.
SeriesIndex | Gets the index of the ChartSeries this Line represents in the Series collection.

Inherited Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Shape | Gets or sers the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

See Also

Line Class


MindFusion.Charting.Silverlight.Line.LineType Property

Line.LineType Property
[image]

Gets the type of this Line.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LineType LineType { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LineType As LineType

Property Value

One of the LineType enumeration values. Default value is LineType.None.

See Also

Line Members
Line Class


MindFusion.Charting.Silverlight.Line.Points Property

Line.Points Property
[image]

Gets the points for this Line.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PointCollection Points { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Points As PointCollection

Property Value

An instance of the System.Windows.Media.PointCollection class. Default value is an empty PointCollection.

See Also

Line Members
Line Class


MindFusion.Charting.Silverlight.Line.SeriesIndex Property

Line.SeriesIndex Property
[image]

Gets the index of the ChartSeries this Line represents in the Series collection.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int SeriesIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SeriesIndex As Integer

Property Value

An int value. Default is -1.

See Also

Line Members
Line Class


MindFusion.Charting.Silverlight.LineChart Class

LineChart Class
[image]

Represents a line chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class LineChart : AxesChart

Visual Basic [image] Copy Code

Public Class LineChart
Inherits AxesChart

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Silverlight.Chart
MindFusion.Charting.Silverlight.AxesChart
MindFusion.Charting.Silverlight.LineChart

See Also

LineChart Members


MindFusion.Charting.Silverlight.LineChart Members

LineChart Members
Constructors Fields Properties Methods Events
[image]

Represents a line chart.

The following tables list the members exposed by the LineChart type.

Public Constructors

Name | Description
LineChart | Initializes a new instance of the LineChart class.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
GridFillsProperty | Identifies the GridFills dependency property. (Inherited from AxesChart.)
GridStrokesProperty | Identifies the GridStrokes dependency property. (Inherited from AxesChart.)
GridStrokeThicknessProperty | Identifies the GridStrokeThickness dependency property. (Inherited from AxesChart.)
GridTypeProperty | Identifies the GridType dependency property. (Inherited from AxesChart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaFillProperty | Identifies the PlotAreaFill dependency property. (Inherited from AxesChart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
PlotAreaStrokeProperty | Identifies the PlotAreaStroke dependency property. (Inherited from AxesChart.)
PlotAreaStrokeThicknessProperty | Identifies the PlotAreaStrokeThickness dependency property. (Inherited from AxesChart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)
X2LabelPathProperty | Identifies the X2LabelPath dependency property. (Inherited from AxesChart.)
X2LabelsProperty | Identifies the X2Labels dependency property. (Inherited from AxesChart.)
XLabelPathProperty | Identifies the XLabelPath dependency property. (Inherited from AxesChart.)
XLabelsProperty | Identifies the XLabels dependency property. (Inherited from AxesChart.)
Y2LabelPathProperty | Identifies the Y2LabelPath dependency property. (Inherited from AxesChart.)
Y2LabelsProperty | Identifies the Y2Labels dependency property. (Inherited from AxesChart.)
YLabelPathProperty | Identifies the YLabelPath dependency property. (Inherited from AxesChart.)
YLabelsProperty | Identifies the YLabels dependency property. (Inherited from AxesChart.)

Inherited Public Properties

Name | Description
Behavior | Gets or sets the behavor of the chart control. (Inherited from AxesChart.)
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
GridFills | Gets or sets the brushes for the grid stripes. (Inherited from AxesChart.)
GridStrokes | Gets or sets the brushes for the grid lines. (Inherited from AxesChart.)
GridStrokeThickness | Gets or sets the thickness of grid lines. (Inherited from AxesChart.)
GridType | Gets or sets the grid type. (Inherited from AxesChart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
PlotAreaFill | Gets or sets the background of the plot area. (Inherited from AxesChart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
PlotAreaStroke | Gets or sets the outline of the plot area. (Inherited from AxesChart.)
PlotAreaStrokeThickness | Gets or sets the thickness of the outline of the plot area. (Inherited from AxesChart.)
PointAreaRadius | Gets or sets the radius of the area that, if clicked, will be considered for a click at the chart point, which is its center. (Inherited from AxesChart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)
X2AxisSettings | Gets or sets the settings for the X2-axis (Inherited from AxesChart.)
X2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving X2-labels. (Inherited from AxesChart.)
X2Labels | Gets or sets custom labels for the X2-axis. (Inherited from AxesChart.)
XAxisSettings | Gets the settings for the X axis. (Inherited from AxesChart.)
XLabelPath | Gets or sets the path to the property of the DataSource used for retrieving X-labels. (Inherited from AxesChart.)
XLabels | Gets or sets custom labels for the X-axis. (Inherited from AxesChart.)
Y2AxisSettings | Gets or sets the settings for the Y2-axis (Inherited from AxesChart.)
Y2LabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y2-labels. (Inherited from AxesChart.)
Y2Labels | Gets or sets custom labels for the Y2-axis. (Inherited from AxesChart.)
YAxisSettings | Gets or sets the settings for the Y-axis (Inherited from AxesChart.)
YLabelPath | Gets or sets the path to the property of the DataSource used for retrieving Y-labels. (Inherited from AxesChart.)
YLabels | Gets or sets custom labels for the Y-axis. (Inherited from AxesChart.)

Inherited Public Methods

Name | Description
HitTest | Gets a collection of ChartElement-s that contain the point specified as parameter. (Inherited from Chart.)
LoadTheme | Loads a ChartTheme from the specified file. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Invoked whenever application code or internal processes call. (Inherited from Chart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
ResetZoom | Resets the zoom of the chart. (Inherited from AxesChart.)
SaveTheme | Saves the appearance of the current chart as a ChartTheme. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)
Zoom | Zooms a portion of the graphics. (Inherited from AxesChart.)
ZoomOut | Zooms out the chart one step back. (Inherited from AxesChart.)

Inherited Protected Methods

Name | Description
OnMouseEnter | Raised when the mouse eneters the control. (Inherited from AxesChart.)
OnMouseLeave | Raised when the mouse leaves the chart area. (Inherited from AxesChart.)
OnMouseLeftButtonDown | Raised when the left mouse button is pressed while the pointer is over this control. (Inherited from AxesChart.)
OnMouseLeftButtonUp | Raised when the left mouse button is released while the mouse pointer is over the chart. (Inherited from AxesChart.)
OnMouseMove | Raised when the mouse pointer moves while the mouse pointer is over the chart control. (Inherited from AxesChart.)

Inherited Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

LineChart Class


MindFusion.Charting.Silverlight.LineChart Constructor

LineChart Constructor
[image]

Initializes a new instance of the LineChart class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LineChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LineChart Class


MindFusion.Charting.Silverlight.LineSeries Class

LineSeries Class
[image]

Represents a series in a line chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class LineSeries : AxesSeries

Visual Basic [image] Copy Code

Public Class LineSeries
Inherits AxesSeries

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Silverlight.ChartSeries
MindFusion.Charting.Silverlight.AxesSeries
MindFusion.Charting.Silverlight.LineSeries

See Also

LineSeries Members


MindFusion.Charting.Silverlight.LineSeries Members

LineSeries Members
Constructors Fields Properties Methods Events
[image]

Represents a series in a line chart.

The following tables list the members exposed by the LineSeries type.

Public Constructors

Name | Description
LineSeries | Initializes a new instance of the LineSeries class.

Public Fields

Name | Description
LabelPathProperty | Identifies the LabelPath dependency property.
LabelsProperty | Identifies the Labels dependency property.
LineTypeProperty | Identifies the LineType dependency property.
ScatterFillsProperty | Identifies the ScatterFills dependency property.
ScatterFillsSourceProperty | Identifies the ScatterFillsSource dependency property.
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterStrokesProperty | Identifies the ScatterStrokes dependency property.
ScatterStrokesSourceProperty | Identifies the ScatterStrokesSource dependency property.
ScatterStrokeThicknessProperty | Identifies the ScatterStrokeThickness dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.

Inherited Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property. (Inherited from ChartSeries.)
FillsProperty | Identifies the Fills dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesProperty | Identifies the Strokes dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
X2DataPathProperty | Identifies the X2DataPath dependency property. (Inherited from AxesSeries.)
X2DataProperty | Identifies the X2Data dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
Y2DataPathProperty | Identifies the Y2DataPath dependency property. (Inherited from AxesSeries.)
Y2DataProperty | Identifies the Y2Data dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

Public Properties

Name | Description
LabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom labels.
Labels | Gets or sets the labels drawn at data points.
LineType | Gets or sets the type of the line series.
ScatterFills | Gets the fills for the scatters.
ScatterFillsSource | Gets or sets the fills used for scatters in this ChartSeries.
ScatterSize | Gets or sets the size of the scatter for the series.
ScatterStrokes | Gets the strokes for the scatters.
ScatterStrokesSource | Gets or sets the strokes used for scatters in this LineSeries.
ScatterStrokeThickness | Gets or sets the thickness of the scatter strokes.
ScatterType | Gets or sets the type of the scatter for the series.

Inherited Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries. (Inherited from ChartSeries.)
Fills | Gets or sets the brushes for the series. (Inherited from ChartSeries.)
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the series labels. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. (Inherited from ChartSeries.)
StrokesSource | Gets or sets the source of strokes used in this ChartSeries. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. (Inherited from ChartSeries.)
X2Data | Gets or sets the data used for calculating the X2-coordinates of data points. (Inherited from AxesSeries.)
X2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the X2-data for this series. (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. (Inherited from AxesSeries.)
Y2Data | Gets or sets the data used for calculating the Y2-coordinates of data points. (Inherited from AxesSeries.)
Y2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y2-data for this series. (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. (Inherited from AxesSeries.)

Inherited Public Methods

Name | Description
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from ChartSeries.)
OnDataChanged | Raises the DataChanged event. (Inherited from ChartSeries.)

Inherited Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

LineSeries Class


MindFusion.Charting.Silverlight.LineSeries Fields

LineSeries Fields
[image]

Public Fields

Name | Description
LabelPathProperty | Identifies the LabelPath dependency property.
LabelsProperty | Identifies the Labels dependency property.
LineTypeProperty | Identifies the LineType dependency property.
ScatterFillsProperty | Identifies the ScatterFills dependency property.
ScatterFillsSourceProperty | Identifies the ScatterFillsSource dependency property.
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterStrokesProperty | Identifies the ScatterStrokes dependency property.
ScatterStrokesSourceProperty | Identifies the ScatterStrokesSource dependency property.
ScatterStrokeThicknessProperty | Identifies the ScatterStrokeThickness dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.

Inherited Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property. (Inherited from ChartSeries.)
FillsProperty | Identifies the Fills dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesProperty | Identifies the Strokes dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)
X2DataPathProperty | Identifies the X2DataPath dependency property. (Inherited from AxesSeries.)
X2DataProperty | Identifies the X2Data dependency property. (Inherited from AxesSeries.)
XDataPathProperty | Identifies the XDataPath dependency property. (Inherited from AxesSeries.)
XDataProperty | Identifies the XData dependency property. (Inherited from AxesSeries.)
Y2DataPathProperty | Identifies the Y2DataPath dependency property. (Inherited from AxesSeries.)
Y2DataProperty | Identifies the Y2Data dependency property. (Inherited from AxesSeries.)
YDataPathProperty | Identifies the YDataPath dependency property. (Inherited from AxesSeries.)
YDataProperty | Identifies the YData dependency property. (Inherited from AxesSeries.)

See Also

LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.LabelPathProperty Field

LineSeries.LabelPathProperty Field
[image]

Identifies the LabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelPathProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.LabelsProperty Field

LineSeries.LabelsProperty Field
[image]

Identifies the Labels dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelsProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.LineTypeProperty Field

LineSeries.LineTypeProperty Field
[image]

Identifies the LineType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LineTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LineTypeProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterFillsProperty Field

LineSeries.ScatterFillsProperty Field
[image]

Identifies the ScatterFills dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterFillsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterFillsProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterFillsSourceProperty Field

LineSeries.ScatterFillsSourceProperty Field
[image]

Identifies the ScatterFillsSource dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterFillsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterFillsSourceProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterSizeProperty Field

LineSeries.ScatterSizeProperty Field
[image]

Identifies the ScatterSize dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterSizeProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterStrokesProperty Field

LineSeries.ScatterStrokesProperty Field
[image]

Identifies the ScatterStrokes dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterStrokesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterStrokesProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterStrokesSourceProperty Field

LineSeries.ScatterStrokesSourceProperty Field
[image]

Identifies the ScatterStrokesSource dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterStrokesSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterStrokesSourceProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterStrokeThicknessProperty Field

LineSeries.ScatterStrokeThicknessProperty Field
[image]

Identifies the ScatterStrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterStrokeThicknessProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterTypeProperty Field

LineSeries.ScatterTypeProperty Field
[image]

Identifies the ScatterType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterTypeProperty As DependencyProperty

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries Constructor

LineSeries Constructor
[image]

Initializes a new instance of the LineSeries class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LineSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LineSeries Class


MindFusion.Charting.Silverlight.LineSeries Properties

LineSeries Properties
[image]

Public Properties

Name | Description
LabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom labels.
Labels | Gets or sets the labels drawn at data points.
LineType | Gets or sets the type of the line series.
ScatterFills | Gets the fills for the scatters.
ScatterFillsSource | Gets or sets the fills used for scatters in this ChartSeries.
ScatterSize | Gets or sets the size of the scatter for the series.
ScatterStrokes | Gets the strokes for the scatters.
ScatterStrokesSource | Gets or sets the strokes used for scatters in this LineSeries.
ScatterStrokeThickness | Gets or sets the thickness of the scatter strokes.
ScatterType | Gets or sets the type of the scatter for the series.

Inherited Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries. (Inherited from ChartSeries.)
Fills | Gets or sets the brushes for the series. (Inherited from ChartSeries.)
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the series labels. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. (Inherited from ChartSeries.)
StrokesSource | Gets or sets the source of strokes used in this ChartSeries. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. (Inherited from ChartSeries.)
X2Data | Gets or sets the data used for calculating the X2-coordinates of data points. (Inherited from AxesSeries.)
X2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the X2-data for this series. (Inherited from AxesSeries.)
XData | Gets or sets the data used for calculating the X-coordinates of data points. (Inherited from AxesSeries.)
XDataPath | Gets or sets the path to the property of the DataSource used for retrieving the X-data for this series. (Inherited from AxesSeries.)
Y2Data | Gets or sets the data used for calculating the Y2-coordinates of data points. (Inherited from AxesSeries.)
Y2DataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y2-data for this series. (Inherited from AxesSeries.)
YData | Gets or sets the data used for calculating the Y-coordinates of data points. (Inherited from AxesSeries.)
YDataPath | Gets or sets the path to the property of the DataSource used for retrieving the Y-data for this series. (Inherited from AxesSeries.)

See Also

LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.LabelPath Property

LineSeries.LabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving custom labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPath As String

Property Value

A string value. Default value is an empty string ("").

Remarks

The LabelPath property provides the labels that are drawn at data points in the chart.

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.Labels Property

LineSeries.Labels Property
[image]

Gets or sets the labels drawn at data points.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty list.

Remarks

The Labels property provides the labels that are drawn at data points in the chart.

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.LineType Property

LineSeries.LineType Property
[image]

Gets or sets the type of the line series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LineType LineType { get; set; }

Visual Basic [image] Copy Code

Public Property LineType As LineType

Property Value

One of the LineType enumeration values. Default value is LineType.Line.

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterFills Property

LineSeries.ScatterFills Property
[image]

Gets the fills for the scatters.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection ScatterFills { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterFills As BrushCollection

Property Value

An instance of the BrushCollection class. Default value is an empty list.

Remarks

Scatters are drawn when the LineSeries.ScatterType property is not set to ScatterType.None

Example

The following example adds gray scatters with the form of a diamond to the first series in a line chart:

C# [image] Copy Code
LineSeries series = lineChart1.Series[0] as LineSeries;
series.ScatterType = ScatterType.Diamond;
series.ScatterSize = 13.0;
series.ScatterStrokes.Add(new SolidColorBrush(Colors.DarkGray));
series.ScatterStrokeThickness = 1.0;
series.ScatterFills.Add(new SolidColorBrush(Colors.LightGray));
Visual Basic [image] Copy Code
Dim series As LineSeries = CType(lineChart1.Series(0),LineSeries)
series.ScatterType = ScatterType.Diamond
series.ScatterSize = 13
series.ScatterStrokes.Add(New SolidColorBrush(Colors.DarkGray))
series.ScatterStrokeThickness = 1
series.ScatterFills.Add(New SolidColorBrush(Colors.LightGray))

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterFillsSource Property

LineSeries.ScatterFillsSource Property
[image]

Gets or sets the fills used for scatters in this ChartSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public List<Brush> ScatterFillsSource { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterFillsSource As List(Of Brush)

Property Value

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterSize Property

LineSeries.ScatterSize Property
[image]

Gets or sets the size of the scatter for the series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double ScatterSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterSize As Double

Property Value

A double value. Default is 10.0

Remarks

Scatters are drawn when the LineSeries.ScatterType property is not set to ScatterType.None

Example

The following example adds gray scatters with the form of a diamond to the first series in a line chart:

C# [image] Copy Code
LineSeries series = lineChart1.Series[0] as LineSeries;
series.ScatterType = ScatterType.Diamond;
series.ScatterSize = 13.0;
series.ScatterStrokes.Add(new SolidColorBrush(Colors.DarkGray));
series.ScatterStrokeThickness = 1.0;
series.ScatterFills.Add(new SolidColorBrush(Colors.LightGray));
Visual Basic [image] Copy Code
Dim series As LineSeries = CType(lineChart1.Series(0),LineSeries)
series.ScatterType = ScatterType.Diamond
series.ScatterSize = 13
series.ScatterStrokes.Add(New SolidColorBrush(Colors.DarkGray))
series.ScatterStrokeThickness = 1
series.ScatterFills.Add(New SolidColorBrush(Colors.LightGray))

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterStrokes Property

LineSeries.ScatterStrokes Property
[image]

Gets the strokes for the scatters.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection ScatterStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterStrokes As BrushCollection

Property Value

An instance of the BrushCollection class. Default value is an empty list.

Remarks

Scatters are drawn when the LineSeries.ScatterType property is not set to ScatterType.None.

Example

The following example adds gray scatters with the form of a diamond to the first series in a line chart:

C# [image] Copy Code
LineSeries series = lineChart1.Series[0] as LineSeries;
series.ScatterType = ScatterType.Diamond;
series.ScatterSize = 13.0;
series.ScatterStrokes.Add(new SolidColorBrush(Colors.DarkGray));
series.ScatterStrokeThickness = 1.0;
series.ScatterFills.Add(new SolidColorBrush(Colors.LightGray));
Visual Basic [image] Copy Code
Dim series As LineSeries = CType(lineChart1.Series(0),LineSeries)
series.ScatterType = ScatterType.Diamond
series.ScatterSize = 13
series.ScatterStrokes.Add(New SolidColorBrush(Colors.DarkGray))
series.ScatterStrokeThickness = 1
series.ScatterFills.Add(New SolidColorBrush(Colors.LightGray))

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterStrokesSource Property

LineSeries.ScatterStrokesSource Property
[image]

Gets or sets the strokes used for scatters in this LineSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public List<Brush> ScatterStrokesSource { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterStrokesSource As List(Of Brush)

Property Value

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterStrokeThickness Property

LineSeries.ScatterStrokeThickness Property
[image]

Gets or sets the thickness of the scatter strokes.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double ScatterStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterStrokeThickness As Double

Property Value

A double value. Default is 1.0

Remarks

Scatters are drawn when the LineSeries.ScatterType property is not set to ScatterType.None

Example

The following example adds gray scatters with the form of a diamond to the first series in a line chart:

C# [image] Copy Code
LineSeries series = lineChart1.Series[0] as LineSeries;
series.ScatterType = ScatterType.Diamond;
series.ScatterSize = 13.0;
series.ScatterStrokes.Add(new SolidColorBrush(Colors.DarkGray));
series.ScatterStrokeThickness = 1.0;
series.ScatterFills.Add(new SolidColorBrush(Colors.LightGray));
Visual Basic [image] Copy Code
Dim series As LineSeries = CType(lineChart1.Series(0),LineSeries)
series.ScatterType = ScatterType.Diamond
series.ScatterSize = 13
series.ScatterStrokes.Add(New SolidColorBrush(Colors.DarkGray))
series.ScatterStrokeThickness = 1
series.ScatterFills.Add(New SolidColorBrush(Colors.LightGray))

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineSeries.ScatterType Property

LineSeries.ScatterType Property
[image]

Gets or sets the type of the scatter for the series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ScatterType ScatterType { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterType As ScatterType

Property Value

One of the ScatterType enumeration values. Default value is ScatterType.None.

Remarks

Scatters are drawn when the LineSeries.ScatterType property is not set to ScatterType.None

Example

The following example adds gray scatters with the form of a diamond to the first series in a line chart:

C# [image] Copy Code
LineSeries series = lineChart1.Series[0] as LineSeries;
series.ScatterType = ScatterType.Diamond;
series.ScatterSize = 13.0;
series.ScatterStrokes.Add(new SolidColorBrush(Colors.DarkGray));
series.ScatterStrokeThickness = 1.0;
series.ScatterFills.Add(new SolidColorBrush(Colors.LightGray));
Visual Basic [image] Copy Code
Dim series As LineSeries = CType(lineChart1.Series(0),LineSeries)
series.ScatterType = ScatterType.Diamond
series.ScatterSize = 13
series.ScatterStrokes.Add(New SolidColorBrush(Colors.DarkGray))
series.ScatterStrokeThickness = 1
series.ScatterFills.Add(New SolidColorBrush(Colors.LightGray))

See Also

LineSeries Members
LineSeries Class


MindFusion.Charting.Silverlight.LineType Enumeration

LineType Enumeration
[image]

Specifies the type of the line chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum LineType

Visual Basic [image] Copy Code

Public Enum LineType

Members

Member name | Description
Area2D | the chart is drawn as an area.
Area2DStack | the chart is drawn as a stacked area.
Line | the chart is drawn as a line.
None | No graphic is drawn.

Remarks

The LineType.None mode is useful when you want to draw a chart that shows only scatters. In this case you should use the LineSeries.ScatterType property and the other properties that refer to scatters.

See Also


MindFusion.Charting.Silverlight.PieChart Class

PieChart Class
[image]

Represents a pie chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class PieChart : Chart

Visual Basic [image] Copy Code

Public Class PieChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Silverlight.Chart
MindFusion.Charting.Silverlight.PieChart

See Also

PieChart Members


MindFusion.Charting.Silverlight.PieChart Members

PieChart Members
Constructors Fields Properties Methods Events
[image]

Represents a pie chart.

The following tables list the members exposed by the PieChart type.

Public Constructors

Name | Description
PieChart | Initializes a new instance of the PieChart class.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)

Inherited Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)

Inherited Public Methods

Name | Description
HitTest | Gets a collection of ChartElement-s that contain the point specified as parameter. (Inherited from Chart.)
LoadTheme | Loads a ChartTheme from the specified file. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Invoked whenever application code or internal processes call. (Inherited from Chart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
SaveTheme | Saves the appearance of the current chart as a ChartTheme. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)

Inherited Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

PieChart Class


MindFusion.Charting.Silverlight.PieChart Constructor

PieChart Constructor
[image]

Initializes a new instance of the PieChart class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PieChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PieChart Class


MindFusion.Charting.Silverlight.PiePiece Class

PiePiece Class
[image]

Represents a slice in a pie chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class PiePiece : ChartElement

Visual Basic [image] Copy Code

Public Class PiePiece
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Silverlight.ChartElement
MindFusion.Charting.Silverlight.PiePiece

See Also

PiePiece Members


MindFusion.Charting.Silverlight.PiePiece Members

PiePiece Members
Properties Methods
[image]

Represents a slice in a pie chart.

The following tables list the members exposed by the PiePiece type.

Public Properties

Name | Description
Detached | Gets the distance at which this piece is detached.
Percent | Gets the percent from the pie this piece represents.
PieceIndex | Gets the index of this pie piece in the PieSeries.
PieceValue | Gets the data from the PieSeries this piece represents.
RadiusX | Gets the X-radius of the pie this piece is taken of.
RadiusY | Gets the Y-radius of the pie this piece is taken of.
SeriesIndex | Gets the index of the PieSeries this PiePiece belongs to, in the Series collection.
StartAngle | Gets the start angle of the piece.
SweepAngle | Gets the sweep angle of the piece.

Inherited Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Shape | Gets or sers the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the pie piece.

Inherited Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element. (Inherited from ChartElement.)

See Also

PiePiece Class


MindFusion.Charting.Silverlight.PiePiece Methods

PiePiece Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents the pie piece.

Inherited Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element. (Inherited from ChartElement.)

See Also

PiePiece Class


MindFusion.Charting.Silverlight.PiePiece.CreateShape Method

PiePiece.CreateShape Method
[image]

Creates a Shape that represents the pie piece.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

An instance of the System.Windows.Shapes.Shape object.

Remarks

This method is used internally by the control and is not intended to be called by your code.

See Also

PiePiece Members
PiePiece Class


MindFusion.Charting.Silverlight.PiePiece Properties

PiePiece Properties
[image]

Public Properties

Name | Description
Detached | Gets the distance at which this piece is detached.
Percent | Gets the percent from the pie this piece represents.
PieceIndex | Gets the index of this pie piece in the PieSeries.
PieceValue | Gets the data from the PieSeries this piece represents.
RadiusX | Gets the X-radius of the pie this piece is taken of.
RadiusY | Gets the Y-radius of the pie this piece is taken of.
SeriesIndex | Gets the index of the PieSeries this PiePiece belongs to, in the Series collection.
StartAngle | Gets the start angle of the piece.
SweepAngle | Gets the sweep angle of the piece.

Inherited Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Shape | Gets or sers the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

See Also

PiePiece Class


MindFusion.Charting.Silverlight.PiePiece.Detached Property

PiePiece.Detached Property
[image]

Gets the distance at which this piece is detached.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Detached { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Detached As Double

Property Value

A double value. Default value is 0.0

Remarks

Use PieSeries.DetachedPiecesList to set the detachment for each piece in the series.

See Also

PiePiece Members
PiePiece Class


MindFusion.Charting.Silverlight.PiePiece.Percent Property

PiePiece.Percent Property
[image]

Gets the percent from the pie this piece represents.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Percent { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Percent As Double

Property Value

A double value. Default is 0.0

Remarks

The percent value for each PiePiece is calculated automatically based on the data for the PieSeries.

See Also

PiePiece Members
PiePiece Class


MindFusion.Charting.Silverlight.PiePiece.PieceIndex Property

PiePiece.PieceIndex Property
[image]

Gets the index of this pie piece in the PieSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int PieceIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PieceIndex As Integer

Property Value

An int value. Default value is -1.

See Also

PiePiece Members
PiePiece Class


MindFusion.Charting.Silverlight.PiePiece.PieceValue Property

PiePiece.PieceValue Property
[image]

Gets the data from the PieSeries this piece represents.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double PieceValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PieceValue As Double

Property Value

A double value. Default is 0.0

Remarks

Use PieSeries.Data or PieSeries.DataPath to specify data for the series.

See Also

PiePiece Members
PiePiece Class


MindFusion.Charting.Silverlight.PiePiece.RadiusX Property

PiePiece.RadiusX Property
[image]

Gets the X-radius of the pie this piece is taken of.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double RadiusX { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RadiusX As Double

Property Value

A double value. Default is 0.0

Remarks

The radius of the pie is calculated automatically based on the size of the control.

See Also

PiePiece Members
PiePiece Class


MindFusion.Charting.Silverlight.PiePiece.RadiusY Property

PiePiece.RadiusY Property
[image]

Gets the Y-radius of the pie this piece is taken of.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double RadiusY { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RadiusY As Double

Property Value

A double value. Default is 0.0

Remarks

The radius of the pie is calculated automatically based on the size of the control.

See Also

PiePiece Members
PiePiece Class


MindFusion.Charting.Silverlight.PiePiece.SeriesIndex Property

PiePiece.SeriesIndex Property
[image]

Gets the index of the PieSeries this PiePiece belongs to, in the Series collection.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int SeriesIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SeriesIndex As Integer

Property Value

An int value. Default value is -1.

See Also

PiePiece Members
PiePiece Class


MindFusion.Charting.Silverlight.PiePiece.StartAngle Property

PiePiece.StartAngle Property
[image]

Gets the start angle of the piece.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StartAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartAngle As Double

Property Value

A double value that specifies the angle in degrees. Default is 0.0

Remarks

The angle is measured counter - clockwise from left.

See Also

PiePiece Members
PiePiece Class


MindFusion.Charting.Silverlight.PiePiece.SweepAngle Property

PiePiece.SweepAngle Property
[image]

Gets the sweep angle of the piece.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double SweepAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SweepAngle As Double

Property Value

A double value that specifies the size of the angle in degrees. Default is 0.0

See Also

PiePiece Members
PiePiece Class


MindFusion.Charting.Silverlight.PieSeries Class

PieSeries Class
[image]

Represents a series in a pie chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class PieSeries : ChartSeries

Visual Basic [image] Copy Code

Public Class PieSeries
Inherits ChartSeries

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Silverlight.ChartSeries
MindFusion.Charting.Silverlight.PieSeries

See Also

PieSeries Members


MindFusion.Charting.Silverlight.PieSeries Members

PieSeries Members
Constructors Fields Properties Methods Events
[image]

Represents a series in a pie chart.

The following tables list the members exposed by the PieSeries type.

Public Constructors

Name | Description
PieSeries | Initializes a new instance of the PieSeries class.

Public Fields

Name | Description
DataPathProperty | Identifies the DataPath dependency property.
DataProperty | Identifies the Data dependency property.
DetachedPiecesListProperty | Identifies the DetachedPiecesList dependency property.
DoughnutThicknessProperty | Identifies the DoughnutThickness dependency property.
InnerLabelLocationProperty | Identifies the InnerLabelLocation dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelProperty | Identifies the InnerLabel dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
OuterLabelOffsetProperty | Identifies the OuterLabelOffset dependency property.
OuterLabelPathProperty | Identifies the OuterLabelPath dependency property.
OuterLabelProperty | Identifies the OuterLabel dependency property.
OuterLabelTypeProperty | Identifies the OuterLabelType dependency property.
PieTypeProperty | Identifies the PieType dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.

Inherited Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property. (Inherited from ChartSeries.)
FillsProperty | Identifies the Fills dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesProperty | Identifies the Strokes dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)

Public Properties

Name | Description
Data | Gets or sets the data for the chart.
DataPath | Gets or sets the path to the property of the DataSource used for retrieving the data for this series.
DetachedPiecesList | Gets or sets the position of detached pieces.
DoughnutThickness | Gets or sets the thickness of the doughnut.
InnerLabel | An instance of the StringCollection class. Default value is an empty list.
InnerLabelLocation | Gets or sets the location of the inner label.
InnerLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom inner labels.
InnerLabelType | Gets or sets the type of labels drawn inside pie pieces.
OuterLabel | Gets or sets custom outer labels.
OuterLabelOffset | Gets or sets the offset of the outer label from the edge of the pie.
OuterLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom outer labels.
OuterLabelType | Gets or sets the type of labels drawn outside pie pieces.
PieType | Gets or sets the type of the pie chart.
StartAngle | Gets or sets the start angle of the chart.

Inherited Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries. (Inherited from ChartSeries.)
Fills | Gets or sets the brushes for the series. (Inherited from ChartSeries.)
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the series labels. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. (Inherited from ChartSeries.)
StrokesSource | Gets or sets the source of strokes used in this ChartSeries. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. (Inherited from ChartSeries.)

Inherited Public Methods

Name | Description
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from ChartSeries.)
OnDataChanged | Raises the DataChanged event. (Inherited from ChartSeries.)

Inherited Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

PieSeries Class


MindFusion.Charting.Silverlight.PieSeries Fields

PieSeries Fields
[image]

Public Fields

Name | Description
DataPathProperty | Identifies the DataPath dependency property.
DataProperty | Identifies the Data dependency property.
DetachedPiecesListProperty | Identifies the DetachedPiecesList dependency property.
DoughnutThicknessProperty | Identifies the DoughnutThickness dependency property.
InnerLabelLocationProperty | Identifies the InnerLabelLocation dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelProperty | Identifies the InnerLabel dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
OuterLabelOffsetProperty | Identifies the OuterLabelOffset dependency property.
OuterLabelPathProperty | Identifies the OuterLabelPath dependency property.
OuterLabelProperty | Identifies the OuterLabel dependency property.
OuterLabelTypeProperty | Identifies the OuterLabelType dependency property.
PieTypeProperty | Identifies the PieType dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.

Inherited Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property. (Inherited from ChartSeries.)
FillsProperty | Identifies the Fills dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesProperty | Identifies the Strokes dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)

See Also

PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.DataPathProperty Field

PieSeries.DataPathProperty Field
[image]

Identifies the DataPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataPathProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.DataProperty Field

PieSeries.DataProperty Field
[image]

Identifies the Data dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.DetachedPiecesListProperty Field

PieSeries.DetachedPiecesListProperty Field
[image]

Identifies the DetachedPiecesList dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DetachedPiecesListProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DetachedPiecesListProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.DoughnutThicknessProperty Field

PieSeries.DoughnutThicknessProperty Field
[image]

Identifies the DoughnutThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DoughnutThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DoughnutThicknessProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.InnerLabelLocationProperty Field

PieSeries.InnerLabelLocationProperty Field
[image]

Identifies the InnerLabelLocation dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelLocationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelLocationProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.InnerLabelPathProperty Field

PieSeries.InnerLabelPathProperty Field
[image]

Identifies the InnerLabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelPathProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.InnerLabelProperty Field

PieSeries.InnerLabelProperty Field
[image]

Identifies the InnerLabel dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.InnerLabelTypeProperty Field

PieSeries.InnerLabelTypeProperty Field
[image]

Identifies the InnerLabelType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelTypeProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.OuterLabelOffsetProperty Field

PieSeries.OuterLabelOffsetProperty Field
[image]

Identifies the OuterLabelOffset dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelOffsetProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.OuterLabelPathProperty Field

PieSeries.OuterLabelPathProperty Field
[image]

Identifies the OuterLabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelPathProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.OuterLabelProperty Field

PieSeries.OuterLabelProperty Field
[image]

Identifies the OuterLabel dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.OuterLabelTypeProperty Field

PieSeries.OuterLabelTypeProperty Field
[image]

Identifies the OuterLabelType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelTypeProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.PieTypeProperty Field

PieSeries.PieTypeProperty Field
[image]

Identifies the PieType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PieTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PieTypeProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.StartAngleProperty Field

PieSeries.StartAngleProperty Field
[image]

Identifies the StartAngle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartAngleProperty As DependencyProperty

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries Constructor

PieSeries Constructor
[image]

Initializes a new instance of the PieSeries class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PieSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PieSeries Class


MindFusion.Charting.Silverlight.PieSeries Properties

PieSeries Properties
[image]

Public Properties

Name | Description
Data | Gets or sets the data for the chart.
DataPath | Gets or sets the path to the property of the DataSource used for retrieving the data for this series.
DetachedPiecesList | Gets or sets the position of detached pieces.
DoughnutThickness | Gets or sets the thickness of the doughnut.
InnerLabel | An instance of the StringCollection class. Default value is an empty list.
InnerLabelLocation | Gets or sets the location of the inner label.
InnerLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom inner labels.
InnerLabelType | Gets or sets the type of labels drawn inside pie pieces.
OuterLabel | Gets or sets custom outer labels.
OuterLabelOffset | Gets or sets the offset of the outer label from the edge of the pie.
OuterLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom outer labels.
OuterLabelType | Gets or sets the type of labels drawn outside pie pieces.
PieType | Gets or sets the type of the pie chart.
StartAngle | Gets or sets the start angle of the chart.

Inherited Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries. (Inherited from ChartSeries.)
Fills | Gets or sets the brushes for the series. (Inherited from ChartSeries.)
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the series labels. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. (Inherited from ChartSeries.)
StrokesSource | Gets or sets the source of strokes used in this ChartSeries. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. (Inherited from ChartSeries.)

See Also

PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.Data Property

PieSeries.Data Property
[image]

Gets or sets the data for the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As DoubleCollection

Property Value

An instance of the System.Windows.Media.DoubleCollection class. Default value is an empty list.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.DataPath Property

PieSeries.DataPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving the data for this series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string DataPath { get; set; }

Visual Basic [image] Copy Code

Public Property DataPath As String

Property Value

A string. Default value is an empty string ("").

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.DetachedPiecesList Property

PieSeries.DetachedPiecesList Property
[image]

Gets or sets the position of detached pieces.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection DetachedPiecesList { get; set; }

Visual Basic [image] Copy Code

Public Property DetachedPiecesList As DoubleCollection

Property Value

An instance of the System.Windows.Media.DoubleCollection class. Default value is an empty list.

Remarks

Each member in the list specifies the detachment, in device independent units, of its corresponding piece. If you decide to have detached pieces, put a number in the DetachedPiecesList for every data value that you have in PieSeries.Data. Use 0 for pieces that should not be detached.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.DoughnutThickness Property

PieSeries.DoughnutThickness Property
[image]

Gets or sets the thickness of the doughnut.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double DoughnutThickness { get; set; }

Visual Basic [image] Copy Code

Public Property DoughnutThickness As Double

Property Value

A double value that should range between 0 and 1. Default value is 0.5

Remarks

The DoughnutThickness property specifies the thickness of the doughnut as a percent of the radius. The smaller the value, the thinner the doughnut.

Set PieSeries.PieType to PieType.Doughnut2D to draw a doughnut.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.InnerLabel Property

PieSeries.InnerLabel Property
[image]

An instance of the StringCollection class. Default value is an empty list.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection InnerLabel { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabel As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty list.

Remarks

InnerLabel property is considered when PieSeries.InnerLabelType is set to LabelType.CustomText.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.InnerLabelLocation Property

PieSeries.InnerLabelLocation Property
[image]

Gets or sets the location of the inner label.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double InnerLabelLocation { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelLocation As Double

Property Value

A double value. Values should range from 0 to 1. The smaller the value, the closer to the center the label is drawn. Default value is 0.5

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.InnerLabelPath Property

PieSeries.InnerLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving custom inner labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string InnerLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelPath As String

Property Value

A string value. Default value is an empty string ("").

Remarks

The InnerLabelPath property is considered when PieSeries.InnerLabelType is set to LabelType.CustomText.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.InnerLabelType Property

PieSeries.InnerLabelType Property
[image]

Gets or sets the type of labels drawn inside pie pieces.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LabelType InnerLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelType As LabelType

Property Value

One of the LabelType enumeration values. Default value is LabelType.Empty.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.OuterLabel Property

PieSeries.OuterLabel Property
[image]

Gets or sets custom outer labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection OuterLabel { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabel As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty list.

Remarks

An instance of the StringCollection class. Default value is an empty list.The OuterLabel property is considered when PieSeries.OuterLabelType is set to LabelType.CustomText.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.OuterLabelOffset Property

PieSeries.OuterLabelOffset Property
[image]

Gets or sets the offset of the outer label from the edge of the pie.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double OuterLabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelOffset As Double

Property Value

A double value. Default is 5.0

Remarks

The OuterLabelOffset property is considered when PieSeries.OuterLabelType is set to LabelType.CustomText.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.OuterLabelPath Property

PieSeries.OuterLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving custom outer labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string OuterLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelPath As String

Property Value

A string value. Default value is an empty string ("").

Remarks

The OuterLabelPath property is considered when PieSeries.OuterLabelType is set to LabelType.CustomText.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.OuterLabelType Property

PieSeries.OuterLabelType Property
[image]

Gets or sets the type of labels drawn outside pie pieces.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LabelType OuterLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelType As LabelType

Property Value

One of the LabelType enumeration values. Default value is LabelType.Empty.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.PieType Property

PieSeries.PieType Property
[image]

Gets or sets the type of the pie chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PieType PieType { get; set; }

Visual Basic [image] Copy Code

Public Property PieType As PieType

Property Value

One of the PieType enumeration values. Default value is PieType.Doughnut2D.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieSeries.StartAngle Property

PieSeries.StartAngle Property
[image]

Gets or sets the start angle of the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StartAngle { get; set; }

Visual Basic [image] Copy Code

Public Property StartAngle As Double

Property Value

A double value. Default is 0.0

Remarks

The start angle is measured in degrees, counter-clockwise starting from the right side of the pie.

See Also

PieSeries Members
PieSeries Class


MindFusion.Charting.Silverlight.PieType Enumeration

PieType Enumeration
[image]

Specifies the type of the pie chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum PieType

Visual Basic [image] Copy Code

Public Enum PieType

Members

Member name | Description
Doughnut2D | the chart is drawn as a doughnut.
Pie2D | the chart is drawn as a 2D pie.

See Also


MindFusion.Charting.Silverlight.PlotArea Class

PlotArea Class
[image]

Represents the plot area where the chart is drawn.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class PlotArea : Control

Visual Basic [image] Copy Code

Public Class PlotArea
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Silverlight.PlotArea

See Also

PlotArea Members


MindFusion.Charting.Silverlight.PlotArea Members

PlotArea Members
Constructors Methods Events
[image]

Represents the plot area where the chart is drawn.

The following tables list the members exposed by the PlotArea type.

Public Constructors

Name | Description
PlotArea | Initializes a new instance of the PlotArea class.

Public Methods

Name | Description
OnApplyTemplate | Invoked whenever application code or internal processes call.

Public Events

Name | Description
CanvasSizeInitialized | Occurs when the Size of the chart's PlotArea Canvas is initialized.
PlotAreaCanvasInitialized | Occurs when the Canvas of the chart's PlotArea is initialized.

See Also

PlotArea Class


MindFusion.Charting.Silverlight.PlotArea Constructor

PlotArea Constructor
[image]

Initializes a new instance of the PlotArea class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PlotArea ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PlotArea Class


MindFusion.Charting.Silverlight.PlotArea Methods

PlotArea Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | Invoked whenever application code or internal processes call.

See Also

PlotArea Class


MindFusion.Charting.Silverlight.PlotArea.OnApplyTemplate Method

PlotArea.OnApplyTemplate Method
[image]

Invoked whenever application code or internal processes call.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

PlotArea Members
PlotArea Class


MindFusion.Charting.Silverlight.PlotArea Events

PlotArea Events
[image]

Public Events

Name | Description
CanvasSizeInitialized | Occurs when the Size of the chart's PlotArea Canvas is initialized.
PlotAreaCanvasInitialized | Occurs when the Canvas of the chart's PlotArea is initialized.

See Also

PlotArea Class


MindFusion.Charting.Silverlight.PlotArea.CanvasSizeInitialized Event

PlotArea.CanvasSizeInitialized Event
[image]

Occurs when the Size of the chart's PlotArea Canvas is initialized.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public event PlotArea.CanvasSizeInitializedHandler CanvasSizeInitialized

Visual Basic [image] Copy Code

Public Event CanvasSizeInitialized As PlotArea.CanvasSizeInitializedHandler

Remarks

This event is used internally by the control and is not intended to be called by your code.

See Also

PlotArea Members
PlotArea Class


MindFusion.Charting.Silverlight.PlotArea.PlotAreaCanvasInitialized Event

PlotArea.PlotAreaCanvasInitialized Event
[image]

Occurs when the Canvas of the chart's PlotArea is initialized.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public event PlotArea.CanvasInitializedHandler PlotAreaCanvasInitialized

Visual Basic [image] Copy Code

Public Event PlotAreaCanvasInitialized As PlotArea.CanvasInitializedHandler

Remarks

This event is used internally by the control and is not intended to be called by your code.

See Also

PlotArea Members
PlotArea Class


MindFusion.Charting.Silverlight.PlotArea.CanvasInitializedHandler Delegate

PlotArea.CanvasInitializedHandler Delegate
[image]

A delegate for the PlotAreaCanvasInitialized event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public delegate void PlotArea.CanvasInitializedHandler (
Object sender,
CanvasInitializedEventArgs e
)

Visual Basic [image] Copy Code

Public Delegate Sub PlotArea.CanvasInitializedHandler( _
sender As Object, _
e As CanvasInitializedEventArgs _
)

Parameters

sender

The object that invoked the event.

e

The arguments for the event.

See Also


MindFusion.Charting.Silverlight.PlotArea.CanvasSizeInitializedHandler Delegate

PlotArea.CanvasSizeInitializedHandler Delegate
[image]

A delegate for the CanvasSizeInitialized event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public delegate void PlotArea.CanvasSizeInitializedHandler (
Object sender,
CanvasSizeInitializedEventArgs e
)

Visual Basic [image] Copy Code

Public Delegate Sub PlotArea.CanvasSizeInitializedHandler( _
sender As Object, _
e As CanvasSizeInitializedEventArgs _
)

Parameters

sender

The object that invoked the event.

e

The arguments for the event.

See Also


MindFusion.Charting.Silverlight.RadarChart Class

RadarChart Class
[image]

Represents a radar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class RadarChart : Chart

Visual Basic [image] Copy Code

Public Class RadarChart
Inherits Chart

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Silverlight.Chart
MindFusion.Charting.Silverlight.RadarChart

See Also

RadarChart Members


MindFusion.Charting.Silverlight.RadarChart Members

RadarChart Members
Constructors Fields Properties Methods Events
[image]

Represents a radar chart.

The following tables list the members exposed by the RadarChart type.

Public Constructors

Name | Description
RadarChart | Initializes a new instance of the RadarChart class.

Public Fields

Name | Description
AngleDirectionProperty | Identifies the AngleDirection dependency property.
AngleStepProperty | Identifies the AngleStep dependency property.
InnerAxisStrokeProperty | Identifies the InnerAxisStroke dependency property.
InnerLabelAngleProperty | Identifies the InnerLabelAngle dependency property.
InnerLabelBackgroundProperty | Identifies the InnerLabelBackground dependency property.
InnerLabelBorderBrushProperty | Identifies the InnerLabelBorderBrush dependency property.
InnerLabelBorderThicknessProperty | Identifies the InnerLabelBorderThickness dependency property.
InnerLabelForegroundProperty | Identifies the InnerLabelForeground dependency property.
InnerLabelOffsetProperty | Identifies the InnerLabelOffset dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelPositionProperty | Identifies the InnerLabelPosition dependency property.
InnerLabelsProperty | Identifies the InnerLabels dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
InnerStrokeDashArrayProperty | Identifies the InnerStrokeDashArray dependency property.
InnerStrokeThicknessProperty | Identifies the InnerStrokeThickness dependency property.
IntervalProperty | Identifies the Interval dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
OuterAxisStrokeProperty | Identifies the OuterAxisStroke dependency property.
OuterLabelBackgroundProperty | Identifies the OuterLabelBackground dependency property.
OuterLabelBorderBrushProperty | Identifies the OuterLabelBorderBrush dependency property.
OuterLabelBorderThicknessProperty | Identifies the OuterLabelBorderThickness dependency property.
OuterLabelForegroundProperty | Identifies the OuterLabelForeground dependency property.
OuterLabelOffsetProperty | Identifies the OuterLabelOffset dependency property.
OuterLabelPathProperty | Identifies the OuterLabelPath dependency property.
OuterLabelsProperty | Identifies the OuterLabels dependency property.
OuterLabelTypeProperty | Identifies the OuterLabelType dependency property.
OuterStrokeDashArrayProperty | Identifies the OuterStrokeDashArray dependency property.
OuterStrokeThicknessProperty | Identifies the OuterStrokeThickness dependency property.
RadarTypeProperty | Identifies the RadarType dependency property.
SectionBrushesProperty | Identifies the SectionBrushes dependency property.
SectionStrokesProperty | Identifies the SectionStrokes dependency property.
ShowScattersProperty | Identifies the ShowScatters dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)

Public Properties

Name | Description
AngleDirection | Gets or sets the sweep direction of the angles in a polar chart.
AngleStep | Gets or sets the step of incrementation for the angles that build the sections of the chart.
InnerAxisStroke | Gets or sets the stroke for the inner axis.
InnerLabelAngle | Gets or sets the angle of the inner labels.
InnerLabelBackground | Gets or sets the background for the inner labels.
InnerLabelBorderBrush | Gets or set the brush for the border drawn around inner labels.
InnerLabelBorderThickness | Gets or sets the thickness of the border drawn around inner labels.
InnerLabelForeground | Gets or sets the brush for the foreground of the inner labels.
InnerLabelOffset | Gets or sets the offset of the labels drawn at the inner axis.
InnerLabelPath | Gets or sets the path to the property in the DataSource used for retrieving custom labels for the inner axis.
InnerLabelPosition | Gets or sets the position of the inner labels.
InnerLabels | Gets or sets custom labels for the innner axis.
InnerLabelType | Gets or sets the type of labels drawn at the inner axis.
InnerStrokeDashArray | Gets or sets the dash array of the stroke for the inner axis.
InnerStrokeThickness | Gets or sets the thickness of the stroke for the inner axis.
Interval | Gets or sets the interval at the inner axis.
MaxValue | Gets or sets the maximum value of the radar.
MinValue | Gets or sets the minimum value of the radar.
OuterAxisStroke | Gets or sets the stroke for the outer axis.
OuterLabelBackground | Gets or sets the brush that fills the background of the outer labels.
OuterLabelBorderBrush | Gets or sets the brush for the border of the outer labels.
OuterLabelBorderThickness | Gets or sets the thickness of the border of the outer labels.
OuterLabelForeground | Gets or sets the brush for the foreground of the outer labels.
OuterLabelOffset | Gets or sets the offset of the outer label from the edge of the radar.
OuterLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom labels for the outer axis.
OuterLabels | Gets or sets custom outer labels.
OuterLabelType | Gets or sets the type of labels drawn at the outer axis.
OuterStrokeDashArray | Gets or sets the dash array of the stroke for the outer axis.
OuterStrokeThickness | Gets or sets the thickness of the stroke for the outer axis.
RadarType | Gets or sets the type of the radar chart.
SectionBrushes | Gets or sets the brushes that paint the radar sections.
SectionStrokes | Gets or sets the brushes used for outlining the radar sections.
ShowScatters | Gets or sets whether scatters are drawn.
StartAngle | Gets or sets the start angle in a polar chart.

Inherited Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)

Public Methods

Name | Description
OnApplyTemplate | Invoked whenever application code or internal processes call .

Inherited Public Methods

Name | Description
HitTest | Gets a collection of ChartElement-s that contain the point specified as parameter. (Inherited from Chart.)
LoadTheme | Loads a ChartTheme from the specified file. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Invoked whenever application code or internal processes call. (Inherited from Chart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
SaveTheme | Saves the appearance of the current chart as a ChartTheme. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)

Inherited Public Events

Name | Description
AppearanceChanged | Occurs when the value of a property that influences the appearance of the chart changes. (Inherited from Chart.)
DataChanged | Occurs when the data for the chart has changed. (Inherited from Chart.)

See Also

RadarChart Class


MindFusion.Charting.Silverlight.RadarChart Fields

RadarChart Fields
[image]

Public Fields

Name | Description
AngleDirectionProperty | Identifies the AngleDirection dependency property.
AngleStepProperty | Identifies the AngleStep dependency property.
InnerAxisStrokeProperty | Identifies the InnerAxisStroke dependency property.
InnerLabelAngleProperty | Identifies the InnerLabelAngle dependency property.
InnerLabelBackgroundProperty | Identifies the InnerLabelBackground dependency property.
InnerLabelBorderBrushProperty | Identifies the InnerLabelBorderBrush dependency property.
InnerLabelBorderThicknessProperty | Identifies the InnerLabelBorderThickness dependency property.
InnerLabelForegroundProperty | Identifies the InnerLabelForeground dependency property.
InnerLabelOffsetProperty | Identifies the InnerLabelOffset dependency property.
InnerLabelPathProperty | Identifies the InnerLabelPath dependency property.
InnerLabelPositionProperty | Identifies the InnerLabelPosition dependency property.
InnerLabelsProperty | Identifies the InnerLabels dependency property.
InnerLabelTypeProperty | Identifies the InnerLabelType dependency property.
InnerStrokeDashArrayProperty | Identifies the InnerStrokeDashArray dependency property.
InnerStrokeThicknessProperty | Identifies the InnerStrokeThickness dependency property.
IntervalProperty | Identifies the Interval dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
OuterAxisStrokeProperty | Identifies the OuterAxisStroke dependency property.
OuterLabelBackgroundProperty | Identifies the OuterLabelBackground dependency property.
OuterLabelBorderBrushProperty | Identifies the OuterLabelBorderBrush dependency property.
OuterLabelBorderThicknessProperty | Identifies the OuterLabelBorderThickness dependency property.
OuterLabelForegroundProperty | Identifies the OuterLabelForeground dependency property.
OuterLabelOffsetProperty | Identifies the OuterLabelOffset dependency property.
OuterLabelPathProperty | Identifies the OuterLabelPath dependency property.
OuterLabelsProperty | Identifies the OuterLabels dependency property.
OuterLabelTypeProperty | Identifies the OuterLabelType dependency property.
OuterStrokeDashArrayProperty | Identifies the OuterStrokeDashArray dependency property.
OuterStrokeThicknessProperty | Identifies the OuterStrokeThickness dependency property.
RadarTypeProperty | Identifies the RadarType dependency property.
SectionBrushesProperty | Identifies the SectionBrushes dependency property.
SectionStrokesProperty | Identifies the SectionStrokes dependency property.
ShowScattersProperty | Identifies the ShowScatters dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Chart.)
DataSourceProperty | Identifies the DataSource dependency property. (Inherited from Chart.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from Chart.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from Chart.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from Chart.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from Chart.)
PlotAreaMarginProperty | Identifies the PlotAreaMargin dependency property. (Inherited from Chart.)
TitleFontFamilyProperty | Identifies the TitleFontFamily dependency property. (Inherited from Chart.)
TitleFontSizeProperty | Identifies the TitleFontSize dependency property. (Inherited from Chart.)
TitleFontStyleProperty | Identifies the TitleFontStyle dependency property. (Inherited from Chart.)
TitleFontWeightProperty | Identifies the TitleFontWeight dependency property. (Inherited from Chart.)
TitleMarginProperty | Identifies the TitleMargin dependency property. (Inherited from Chart.)
TitleProperty | Identifies the Title dependency property. (Inherited from Chart.)
TitleVisibilityProperty | Identifies the TitleVisibility dependency property. (Inherited from Chart.)

See Also

RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.AngleDirectionProperty Field

RadarChart.AngleDirectionProperty Field
[image]

Identifies the AngleDirection dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AngleDirectionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AngleDirectionProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.AngleStepProperty Field

RadarChart.AngleStepProperty Field
[image]

Identifies the AngleStep dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AngleStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AngleStepProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerAxisStrokeProperty Field

RadarChart.InnerAxisStrokeProperty Field
[image]

Identifies the InnerAxisStroke dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerAxisStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerAxisStrokeProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelAngleProperty Field

RadarChart.InnerLabelAngleProperty Field
[image]

Identifies the InnerLabelAngle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelAngleProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelBackgroundProperty Field

RadarChart.InnerLabelBackgroundProperty Field
[image]

Identifies the InnerLabelBackground dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelBackgroundProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelBorderBrushProperty Field

RadarChart.InnerLabelBorderBrushProperty Field
[image]

Identifies the InnerLabelBorderBrush dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelBorderBrushProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelBorderThicknessProperty Field

RadarChart.InnerLabelBorderThicknessProperty Field
[image]

Identifies the InnerLabelBorderThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelBorderThicknessProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelForegroundProperty Field

RadarChart.InnerLabelForegroundProperty Field
[image]

Identifies the InnerLabelForeground dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelForegroundProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelOffsetProperty Field

RadarChart.InnerLabelOffsetProperty Field
[image]

Identifies the InnerLabelOffset dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelOffsetProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelPathProperty Field

RadarChart.InnerLabelPathProperty Field
[image]

Identifies the InnerLabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelPathProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelPositionProperty Field

RadarChart.InnerLabelPositionProperty Field
[image]

Identifies the InnerLabelPosition dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelPositionProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelPositionProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelsProperty Field

RadarChart.InnerLabelsProperty Field
[image]

Identifies the InnerLabels dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelsProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelTypeProperty Field

RadarChart.InnerLabelTypeProperty Field
[image]

Identifies the InnerLabelType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerLabelTypeProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerStrokeDashArrayProperty Field

RadarChart.InnerStrokeDashArrayProperty Field
[image]

Identifies the InnerStrokeDashArray dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerStrokeDashArrayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerStrokeDashArrayProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerStrokeThicknessProperty Field

RadarChart.InnerStrokeThicknessProperty Field
[image]

Identifies the InnerStrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty InnerStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly InnerStrokeThicknessProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.IntervalProperty Field

RadarChart.IntervalProperty Field
[image]

Identifies the Interval dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IntervalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IntervalProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.MaxValueProperty Field

RadarChart.MaxValueProperty Field
[image]

Identifies the MaxValue dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxValueProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.MinValueProperty Field

RadarChart.MinValueProperty Field
[image]

Identifies the MinValue dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinValueProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterAxisStrokeProperty Field

RadarChart.OuterAxisStrokeProperty Field
[image]

Identifies the OuterAxisStroke dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterAxisStrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterAxisStrokeProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelBackgroundProperty Field

RadarChart.OuterLabelBackgroundProperty Field
[image]

Identifies the OuterLabelBackground dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelBackgroundProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelBorderBrushProperty Field

RadarChart.OuterLabelBorderBrushProperty Field
[image]

Identifies the OuterLabelBorderBrush dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelBorderBrushProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelBorderThicknessProperty Field

RadarChart.OuterLabelBorderThicknessProperty Field
[image]

Identifies the OuterLabelBorderThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelBorderThicknessProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelForegroundProperty Field

RadarChart.OuterLabelForegroundProperty Field
[image]

Identifies the OuterLabelForeground dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelForegroundProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelOffsetProperty Field

RadarChart.OuterLabelOffsetProperty Field
[image]

Identifies the OuterLabelOffset dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelOffsetProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelPathProperty Field

RadarChart.OuterLabelPathProperty Field
[image]

Identifies the OuterLabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelPathProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelsProperty Field

RadarChart.OuterLabelsProperty Field
[image]

Identifies the OuterLabels dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelsProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelTypeProperty Field

RadarChart.OuterLabelTypeProperty Field
[image]

Identifies the OuterLabelType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterLabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterLabelTypeProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterStrokeDashArrayProperty Field

RadarChart.OuterStrokeDashArrayProperty Field
[image]

Identifies the OuterStrokeDashArray dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterStrokeDashArrayProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterStrokeDashArrayProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterStrokeThicknessProperty Field

RadarChart.OuterStrokeThicknessProperty Field
[image]

Identifies the OuterStrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OuterStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OuterStrokeThicknessProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.RadarTypeProperty Field

RadarChart.RadarTypeProperty Field
[image]

Identifies the RadarType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RadarTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RadarTypeProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.SectionBrushesProperty Field

RadarChart.SectionBrushesProperty Field
[image]

Identifies the SectionBrushes dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionBrushesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionBrushesProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.SectionStrokesProperty Field

RadarChart.SectionStrokesProperty Field
[image]

Identifies the SectionStrokes dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty SectionStrokesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly SectionStrokesProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.ShowScattersProperty Field

RadarChart.ShowScattersProperty Field
[image]

Identifies the ShowScatters dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowScattersProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowScattersProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.StartAngleProperty Field

RadarChart.StartAngleProperty Field
[image]

Identifies the StartAngle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartAngleProperty As DependencyProperty

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart Constructor

RadarChart Constructor
[image]

Initializes a new instance of the RadarChart class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public RadarChart ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RadarChart Class


MindFusion.Charting.Silverlight.RadarChart Methods

RadarChart Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | Invoked whenever application code or internal processes call .

Inherited Public Methods

Name | Description
HitTest | Gets a collection of ChartElement-s that contain the point specified as parameter. (Inherited from Chart.)
LoadTheme | Loads a ChartTheme from the specified file. (Inherited from Chart.)
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from Chart.)
OnApplyTemplate | Invoked whenever application code or internal processes call. (Inherited from Chart.)
OnDataChanged | Fired when data on the chart has changed. (Inherited from Chart.)
SaveTheme | Saves the appearance of the current chart as a ChartTheme. (Inherited from Chart.)
UpdateChart | Recalculates and redraws the chart. (Inherited from Chart.)

See Also

RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OnApplyTemplate Method

RadarChart.OnApplyTemplate Method
[image]

Invoked whenever application code or internal processes call .

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart Properties

RadarChart Properties
[image]

Public Properties

Name | Description
AngleDirection | Gets or sets the sweep direction of the angles in a polar chart.
AngleStep | Gets or sets the step of incrementation for the angles that build the sections of the chart.
InnerAxisStroke | Gets or sets the stroke for the inner axis.
InnerLabelAngle | Gets or sets the angle of the inner labels.
InnerLabelBackground | Gets or sets the background for the inner labels.
InnerLabelBorderBrush | Gets or set the brush for the border drawn around inner labels.
InnerLabelBorderThickness | Gets or sets the thickness of the border drawn around inner labels.
InnerLabelForeground | Gets or sets the brush for the foreground of the inner labels.
InnerLabelOffset | Gets or sets the offset of the labels drawn at the inner axis.
InnerLabelPath | Gets or sets the path to the property in the DataSource used for retrieving custom labels for the inner axis.
InnerLabelPosition | Gets or sets the position of the inner labels.
InnerLabels | Gets or sets custom labels for the innner axis.
InnerLabelType | Gets or sets the type of labels drawn at the inner axis.
InnerStrokeDashArray | Gets or sets the dash array of the stroke for the inner axis.
InnerStrokeThickness | Gets or sets the thickness of the stroke for the inner axis.
Interval | Gets or sets the interval at the inner axis.
MaxValue | Gets or sets the maximum value of the radar.
MinValue | Gets or sets the minimum value of the radar.
OuterAxisStroke | Gets or sets the stroke for the outer axis.
OuterLabelBackground | Gets or sets the brush that fills the background of the outer labels.
OuterLabelBorderBrush | Gets or sets the brush for the border of the outer labels.
OuterLabelBorderThickness | Gets or sets the thickness of the border of the outer labels.
OuterLabelForeground | Gets or sets the brush for the foreground of the outer labels.
OuterLabelOffset | Gets or sets the offset of the outer label from the edge of the radar.
OuterLabelPath | Gets or sets the path to the property of the DataSource used for retrieving custom labels for the outer axis.
OuterLabels | Gets or sets custom outer labels.
OuterLabelType | Gets or sets the type of labels drawn at the outer axis.
OuterStrokeDashArray | Gets or sets the dash array of the stroke for the outer axis.
OuterStrokeThickness | Gets or sets the thickness of the stroke for the outer axis.
RadarType | Gets or sets the type of the radar chart.
SectionBrushes | Gets or sets the brushes that paint the radar sections.
SectionStrokes | Gets or sets the brushes used for outlining the radar sections.
ShowScatters | Gets or sets whether scatters are drawn.
StartAngle | Gets or sets the start angle in a polar chart.

Inherited Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the chart control's bounding rectangle. (Inherited from Chart.)
DataSource | Gets or sets the data source. This is a dependency property. (Inherited from Chart.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from Chart.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from Chart.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from Chart.)
LabelFontWeight | Gets or sets the font weight for the chart labels. (Inherited from Chart.)
Legends | Gets or sets a list with the chart legends. (Inherited from Chart.)
PlotAreaMargin | Gets or sets the margin around the plot area. (Inherited from Chart.)
Series | Gets the list with the series in the chart. (Inherited from Chart.)
Title | Gets or sets the title of the chart. (Inherited from Chart.)
TitleFontFamily | Gets or sets the font family for the title. (Inherited from Chart.)
TitleFontSize | Gets or sets the font size for the title. (Inherited from Chart.)
TitleFontStyle | Gets or sets the font style for the title. (Inherited from Chart.)
TitleFontWeight | Gets or sets the font weight for the title. (Inherited from Chart.)
TitleMargin | Gets or sets the margin around the title. (Inherited from Chart.)
TitleVisibility | Gets or sets the visibility of the chart's title. (Inherited from Chart.)

See Also

RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.AngleDirection Property

RadarChart.AngleDirection Property
[image]

Gets or sets the sweep direction of the angles in a polar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public SweepDirection AngleDirection { get; set; }

Visual Basic [image] Copy Code

Public Property AngleDirection As SweepDirection

Property Value

An instance of the System.Windows.Media.SweepDirection enum. Default value is System.Windows.Media.SweepDirection.Clockwise.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.AngleStep Property

RadarChart.AngleStep Property
[image]

Gets or sets the step of incrementation for the angles that build the sections of the chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double AngleStep { get; set; }

Visual Basic [image] Copy Code

Public Property AngleStep As Double

Property Value

A double value. Default value is double.NaN.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerAxisStroke Property

RadarChart.InnerAxisStroke Property
[image]

Gets or sets the stroke for the inner axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush InnerAxisStroke { get; set; }

Visual Basic [image] Copy Code

Public Property InnerAxisStroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelAngle Property

RadarChart.InnerLabelAngle Property
[image]

Gets or sets the angle of the inner labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double InnerLabelAngle { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelAngle As Double

Property Value

A double value. Default value is 0.0

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelBackground Property

RadarChart.InnerLabelBackground Property
[image]

Gets or sets the background for the inner labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush InnerLabelBackground { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelBackground As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelBorderBrush Property

RadarChart.InnerLabelBorderBrush Property
[image]

Gets or set the brush for the border drawn around inner labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush InnerLabelBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelBorderBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelBorderThickness Property

RadarChart.InnerLabelBorderThickness Property
[image]

Gets or sets the thickness of the border drawn around inner labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Thickness InnerLabelBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelBorderThickness As Thickness

Property Value

An instance of the System.Windows.Thickness structure. Default value is Thickness (0).

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelForeground Property

RadarChart.InnerLabelForeground Property
[image]

Gets or sets the brush for the foreground of the inner labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush InnerLabelForeground { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelForeground As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelOffset Property

RadarChart.InnerLabelOffset Property
[image]

Gets or sets the offset of the labels drawn at the inner axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double InnerLabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelOffset As Double

Property Value

A double value. Default value is 0.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelPath Property

RadarChart.InnerLabelPath Property
[image]

Gets or sets the path to the property in the DataSource used for retrieving custom labels for the inner axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string InnerLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelPath As String

Property Value

A string value. Default value is an empty string ("").

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelPosition Property

RadarChart.InnerLabelPosition Property
[image]

Gets or sets the position of the inner labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public InnerLabelPosition InnerLabelPosition { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelPosition As InnerLabelPosition

Property Value

One of the InnerLabelPosition enumeration values. Default value is InnerLabelPosition.Right.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabels Property

RadarChart.InnerLabels Property
[image]

Gets or sets custom labels for the innner axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public IList InnerLabels { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabels As IList

Property Value

A list that holds the labels. Default value is an empty list.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerLabelType Property

RadarChart.InnerLabelType Property
[image]

Gets or sets the type of labels drawn at the inner axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LabelType InnerLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property InnerLabelType As LabelType

Property Value

One of the LabelType enumeration values. Default value is LabelType.AutoScale.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerStrokeDashArray Property

RadarChart.InnerStrokeDashArray Property
[image]

Gets or sets the dash array of the stroke for the inner axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection InnerStrokeDashArray { get; set; }

Visual Basic [image] Copy Code

Public Property InnerStrokeDashArray As DoubleCollection

Property Value

A DoubleCollection that specifies the dash pattern. Default value is an empty DoubleCollection.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.InnerStrokeThickness Property

RadarChart.InnerStrokeThickness Property
[image]

Gets or sets the thickness of the stroke for the inner axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double InnerStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property InnerStrokeThickness As Double

Property Value

A double value. Default value is 1.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.Interval Property

RadarChart.Interval Property
[image]

Gets or sets the interval at the inner axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Interval { get; set; }

Visual Basic [image] Copy Code

Public Property Interval As Double

Property Value

A double value. Default value is double.NaN.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.MaxValue Property

RadarChart.MaxValue Property
[image]

Gets or sets the maximum value of the radar.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

A double value. Default value is double.NaN.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.MinValue Property

RadarChart.MinValue Property
[image]

Gets or sets the minimum value of the radar.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

A double value. Default value is double.NaN.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterAxisStroke Property

RadarChart.OuterAxisStroke Property
[image]

Gets or sets the stroke for the outer axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush OuterAxisStroke { get; set; }

Visual Basic [image] Copy Code

Public Property OuterAxisStroke As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelBackground Property

RadarChart.OuterLabelBackground Property
[image]

Gets or sets the brush that fills the background of the outer labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush OuterLabelBackground { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelBackground As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelBorderBrush Property

RadarChart.OuterLabelBorderBrush Property
[image]

Gets or sets the brush for the border of the outer labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush OuterLabelBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelBorderBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelBorderThickness Property

RadarChart.OuterLabelBorderThickness Property
[image]

Gets or sets the thickness of the border of the outer labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Thickness OuterLabelBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelBorderThickness As Thickness

Property Value

An instance of the System.Windows.Thickness structure. Default value is Thickness(0).

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelForeground Property

RadarChart.OuterLabelForeground Property
[image]

Gets or sets the brush for the foreground of the outer labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush OuterLabelForeground { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelForeground As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelOffset Property

RadarChart.OuterLabelOffset Property
[image]

Gets or sets the offset of the outer label from the edge of the radar.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double OuterLabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelOffset As Double

Property Value

A double value. Default value is 5.0

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelPath Property

RadarChart.OuterLabelPath Property
[image]

Gets or sets the path to the property of the DataSource used for retrieving custom labels for the outer axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string OuterLabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelPath As String

Property Value

A string value. Default value is an empty string ("").

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabels Property

RadarChart.OuterLabels Property
[image]

Gets or sets custom outer labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection OuterLabels { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabels As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty list.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterLabelType Property

RadarChart.OuterLabelType Property
[image]

Gets or sets the type of labels drawn at the outer axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LabelType OuterLabelType { get; set; }

Visual Basic [image] Copy Code

Public Property OuterLabelType As LabelType

Property Value

One of the LabelType enumeration values. Default value is LabelType.AutoScale.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterStrokeDashArray Property

RadarChart.OuterStrokeDashArray Property
[image]

Gets or sets the dash array of the stroke for the outer axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection OuterStrokeDashArray { get; set; }

Visual Basic [image] Copy Code

Public Property OuterStrokeDashArray As DoubleCollection

Property Value

A DoubleCollection that specifies the dash pattern. Default value is an empty DoubleCollection.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.OuterStrokeThickness Property

RadarChart.OuterStrokeThickness Property
[image]

Gets or sets the thickness of the stroke for the outer axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double OuterStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property OuterStrokeThickness As Double

Property Value

A double value. Default value is 1.0

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.RadarType Property

RadarChart.RadarType Property
[image]

Gets or sets the type of the radar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public RadarType RadarType { get; set; }

Visual Basic [image] Copy Code

Public Property RadarType As RadarType

Property Value

One of the RadarType enumeration values. Default value is RadarType.Polar.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.SectionBrushes Property

RadarChart.SectionBrushes Property
[image]

Gets or sets the brushes that paint the radar sections.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection SectionBrushes { get; set; }

Visual Basic [image] Copy Code

Public Property SectionBrushes As BrushCollection

Property Value

An instance of the BrushCollection class. Default value is an empty list.

Remarks

The radar sections are the circles/polygons that build the background of the chart.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.SectionStrokes Property

RadarChart.SectionStrokes Property
[image]

Gets or sets the brushes used for outlining the radar sections.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection SectionStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property SectionStrokes As BrushCollection

Property Value

An instance of the BrushCollection class. Default value is an empty list.

Remarks

The radar sections are the circles/polygons that build the background of the chart.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.ShowScatters Property

RadarChart.ShowScatters Property
[image]

Gets or sets whether scatters are drawn.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public bool ShowScatters { get; set; }

Visual Basic [image] Copy Code

Public Property ShowScatters As Boolean

Property Value

true if scatters are drawn at data points; otherwise false. Default is true.

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarChart.StartAngle Property

RadarChart.StartAngle Property
[image]

Gets or sets the start angle in a polar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double StartAngle { get; set; }

Visual Basic [image] Copy Code

Public Property StartAngle As Double

Property Value

A double value. Default value is 0.0

See Also

RadarChart Members
RadarChart Class


MindFusion.Charting.Silverlight.RadarSeries Class

RadarSeries Class
[image]

Represents a series in a radar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class RadarSeries : ChartSeries

Visual Basic [image] Copy Code

Public Class RadarSeries
Inherits ChartSeries

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
MindFusion.Charting.Silverlight.ChartSeries
MindFusion.Charting.Silverlight.RadarSeries

See Also

RadarSeries Members


MindFusion.Charting.Silverlight.RadarSeries Members

RadarSeries Members
Constructors Fields Properties Methods Events
[image]

Represents a series in a radar chart.

The following tables list the members exposed by the RadarSeries type.

Public Constructors

Name | Description
RadarSeries | Initializes a new instance of the RadarSeries class.

Public Fields

Name | Description
AnglesProperty | Identifies the Angles dependency property.
DataPathProperty | Identifies the DataPath dependency property.
DataProperty | Identifies the Data dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property.
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property.
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property.
LabelForegroundProperty | Identifies the LabelForeground dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelPathProperty | Identifies the LabelPath dependency property.
LabelsProperty | Identifies the Labels dependency property.
LabelTypeProperty | Identifies the LabelType dependency property.
RadarScatterFillsSourceProperty | Identifies the RadarScatterFillsSource dependency property.
RadarScatterStrokesSourceProperty | Identifies the RadarScatterStrokesSource dependency property.
RadarScatterStrokeThicknessProperty | Identifies the RadarScatterStrokeThickness dependency property.
RadarStyleProperty | Identifies the RadarStyle dependency property.
ScatterFillsProperty | Identifies the ScatterFills dependency property.
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterStrokesProperty | Identifies the ScatterStrokes dependency property.
ScatterStrokeThicknessProperty | Identifies the ScatterStrokeThickness dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.

Inherited Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property. (Inherited from ChartSeries.)
FillsProperty | Identifies the Fills dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesProperty | Identifies the Strokes dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)

Public Properties

Name | Description
Angles | Gets or sets the angles for the radar series.
Data | Gets or sets the data for the RadarSeries.
DataPath | Gets or sets the path to the property in the DataSource used for retrieving data for the RadarSeries.
LabelBackground | Gets or sets the background of the label.
LabelBorderBrush | Gets or sets the brush for the label border.
LabelBorderThickness | Gets or sets the thickness of the label border.
LabelForeground | Gets or sets the foreground of the label.
LabelOffset | Gets or sets the offset of the labels.
LabelPath | Gets or sets the path to the property in the DataSource used for retrieving custom labels for this RadarSeries.
Labels | Gets or sets custom labels.
LabelType | Gets or sets the type of labels.
RadarScatterFills | Gets the fills of the scatters.
RadarScatterFillsSource | Gets or sets the source for the fills of radar scatters.
RadarScatterStrokes | Gets the strokes for the scatters.
RadarScatterStrokesSource | Gets or sets the strokes for the radar scatters.
RadarScatterStrokeThickness | Gets or sets the thickness of the scatter stroke.
RadarStyle | Gets or sets the style of this RadarSeries.
ScatterFills | Gets or sets the fills for the scatters.
ScatterSize | Gets or sets the size of the scatter.
ScatterStrokes | Gets or sets the strokes for the scatters.
ScatterStrokeThickness | Gets or sets the thickness of the scatter stroke.
ScatterType | Gets or sets the type of the scatter.

Inherited Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries. (Inherited from ChartSeries.)
Fills | Gets or sets the brushes for the series. (Inherited from ChartSeries.)
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the series labels. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. (Inherited from ChartSeries.)
StrokesSource | Gets or sets the source of strokes used in this ChartSeries. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. (Inherited from ChartSeries.)

Inherited Public Methods

Name | Description
OnAppearanceChanged | Raises the AppearanceChanged event. (Inherited from ChartSeries.)
OnDataChanged | Raises the DataChanged event. (Inherited from ChartSeries.)

Inherited Public Events

Name | Description
AppearanceChanged | Occurs when series appearance was changed. (Inherited from ChartSeries.)
DataChanged | Occurs when series data was changed. (Inherited from ChartSeries.)

See Also

RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries Fields

RadarSeries Fields
[image]

Public Fields

Name | Description
AnglesProperty | Identifies the Angles dependency property.
DataPathProperty | Identifies the DataPath dependency property.
DataProperty | Identifies the Data dependency property.
LabelBackgroundProperty | Identifies the LabelBackground dependency property.
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property.
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property.
LabelForegroundProperty | Identifies the LabelForeground dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelPathProperty | Identifies the LabelPath dependency property.
LabelsProperty | Identifies the Labels dependency property.
LabelTypeProperty | Identifies the LabelType dependency property.
RadarScatterFillsSourceProperty | Identifies the RadarScatterFillsSource dependency property.
RadarScatterStrokesSourceProperty | Identifies the RadarScatterStrokesSource dependency property.
RadarScatterStrokeThicknessProperty | Identifies the RadarScatterStrokeThickness dependency property.
RadarStyleProperty | Identifies the RadarStyle dependency property.
ScatterFillsProperty | Identifies the ScatterFills dependency property.
ScatterSizeProperty | Identifies the ScatterSize dependency property.
ScatterStrokesProperty | Identifies the ScatterStrokes dependency property.
ScatterStrokeThicknessProperty | Identifies the ScatterStrokeThickness dependency property.
ScatterTypeProperty | Identifies the ScatterType dependency property.

Inherited Public Fields

Name | Description
EffectProperty | Identifies the Effect dependency property. (Inherited from ChartSeries.)
FillsProperty | Identifies the Fills dependency property. (Inherited from ChartSeries.)
FillsSourceProperty | Identifies the FillsSource dependency property. (Inherited from ChartSeries.)
LabelBackgroundProperty | Identifies the LabelBackground dependency property. (Inherited from ChartSeries.)
LabelBorderBrushProperty | Identifies the LabelBorderBrush dependency property. (Inherited from ChartSeries.)
LabelBorderThicknessProperty | Identifies the LabelBorderThickness dependency property. (Inherited from ChartSeries.)
LabelFontFamilyProperty | Identifies the LabelFontFamily dependency property. (Inherited from ChartSeries.)
LabelFontSizeProperty | Identifies the LabelFontSize dependency property. (Inherited from ChartSeries.)
LabelFontStyleProperty | Identifies the LabelFontStyle dependency property. (Inherited from ChartSeries.)
LabelFontWeightProperty | Identifies the LabelFontWeight dependency property. (Inherited from ChartSeries.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from ChartSeries.)
StrokeDashArrayProperty | Identifies the StrokeDashArray dependency property. (Inherited from ChartSeries.)
StrokeDashCapProperty | Identifies the StrokeDashCap dependency property. (Inherited from ChartSeries.)
StrokeDashOffsetProperty | Identifies the StrokeDashOffset dependency property. (Inherited from ChartSeries.)
StrokeEndLineCapProperty | Identifies the StrokeEndLineCap dependency property. (Inherited from ChartSeries.)
StrokeLineJoinProperty | Identifies the StrokeLineJoin dependency property. (Inherited from ChartSeries.)
StrokeMiterLimitProperty | Identifies the StrokeMiterLimit dependency property. (Inherited from ChartSeries.)
StrokesProperty | Identifies the Strokes dependency property. (Inherited from ChartSeries.)
StrokesSourceProperty | Identifies the StrokesSource dependency property. (Inherited from ChartSeries.)
StrokeStartLineCapProperty | Identifies the StrokeStartLineCap dependency property. (Inherited from ChartSeries.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from ChartSeries.)
TitleProperty | Identifies the Title dependency property. (Inherited from ChartSeries.)

See Also

RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.AnglesProperty Field

RadarSeries.AnglesProperty Field
[image]

Identifies the Angles dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AnglesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AnglesProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.DataPathProperty Field

RadarSeries.DataPathProperty Field
[image]

Identifies the DataPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataPathProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.DataProperty Field

RadarSeries.DataProperty Field
[image]

Identifies the Data dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DataProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DataProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelBackgroundProperty Field

RadarSeries.LabelBackgroundProperty Field
[image]

Identifies the LabelBackground dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBackgroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBackgroundProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelBorderBrushProperty Field

RadarSeries.LabelBorderBrushProperty Field
[image]

Identifies the LabelBorderBrush dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBorderBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBorderBrushProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelBorderThicknessProperty Field

RadarSeries.LabelBorderThicknessProperty Field
[image]

Identifies the LabelBorderThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelBorderThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelBorderThicknessProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelForegroundProperty Field

RadarSeries.LabelForegroundProperty Field
[image]

Identifies the LabelForeground dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelForegroundProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelOffsetProperty Field

RadarSeries.LabelOffsetProperty Field
[image]

Identifies the LabelOffset dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelOffsetProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelPathProperty Field

RadarSeries.LabelPathProperty Field
[image]

Identifies the LabelPath dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelPathProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelPathProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelsProperty Field

RadarSeries.LabelsProperty Field
[image]

Identifies the Labels dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelsProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelTypeProperty Field

RadarSeries.LabelTypeProperty Field
[image]

Identifies the LabelType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelTypeProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.RadarScatterFillsSourceProperty Field

RadarSeries.RadarScatterFillsSourceProperty Field
[image]

Identifies the RadarScatterFillsSource dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RadarScatterFillsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RadarScatterFillsSourceProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.RadarScatterStrokesSourceProperty Field

RadarSeries.RadarScatterStrokesSourceProperty Field
[image]

Identifies the RadarScatterStrokesSource dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RadarScatterStrokesSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RadarScatterStrokesSourceProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.RadarScatterStrokeThicknessProperty Field

RadarSeries.RadarScatterStrokeThicknessProperty Field
[image]

Identifies the RadarScatterStrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RadarScatterStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RadarScatterStrokeThicknessProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.RadarStyleProperty Field

RadarSeries.RadarStyleProperty Field
[image]

Identifies the RadarStyle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RadarStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RadarStyleProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.ScatterFillsProperty Field

RadarSeries.ScatterFillsProperty Field
[image]

Identifies the ScatterFills dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterFillsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterFillsProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.ScatterSizeProperty Field

RadarSeries.ScatterSizeProperty Field
[image]

Identifies the ScatterSize dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterSizeProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.ScatterStrokesProperty Field

RadarSeries.ScatterStrokesProperty Field
[image]

Identifies the ScatterStrokes dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterStrokesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterStrokesProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.ScatterStrokeThicknessProperty Field

RadarSeries.ScatterStrokeThicknessProperty Field
[image]

Identifies the ScatterStrokeThickness dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterStrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterStrokeThicknessProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.ScatterTypeProperty Field

RadarSeries.ScatterTypeProperty Field
[image]

Identifies the ScatterType dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScatterTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScatterTypeProperty As DependencyProperty

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries Constructor

RadarSeries Constructor
[image]

Initializes a new instance of the RadarSeries class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public RadarSeries ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries Properties

RadarSeries Properties
[image]

Public Properties

Name | Description
Angles | Gets or sets the angles for the radar series.
Data | Gets or sets the data for the RadarSeries.
DataPath | Gets or sets the path to the property in the DataSource used for retrieving data for the RadarSeries.
LabelBackground | Gets or sets the background of the label.
LabelBorderBrush | Gets or sets the brush for the label border.
LabelBorderThickness | Gets or sets the thickness of the label border.
LabelForeground | Gets or sets the foreground of the label.
LabelOffset | Gets or sets the offset of the labels.
LabelPath | Gets or sets the path to the property in the DataSource used for retrieving custom labels for this RadarSeries.
Labels | Gets or sets custom labels.
LabelType | Gets or sets the type of labels.
RadarScatterFills | Gets the fills of the scatters.
RadarScatterFillsSource | Gets or sets the source for the fills of radar scatters.
RadarScatterStrokes | Gets the strokes for the scatters.
RadarScatterStrokesSource | Gets or sets the strokes for the radar scatters.
RadarScatterStrokeThickness | Gets or sets the thickness of the scatter stroke.
RadarStyle | Gets or sets the style of this RadarSeries.
ScatterFills | Gets or sets the fills for the scatters.
ScatterSize | Gets or sets the size of the scatter.
ScatterStrokes | Gets or sets the strokes for the scatters.
ScatterStrokeThickness | Gets or sets the thickness of the scatter stroke.
ScatterType | Gets or sets the type of the scatter.

Inherited Public Properties

Name | Description
Effect | Gets or sets the visual effect for this ChartSeries. (Inherited from ChartSeries.)
Fills | Gets or sets the brushes for the series. (Inherited from ChartSeries.)
FillsSource | Gets or sets the source for the Brush-es used in this ChartSeries. (Inherited from ChartSeries.)
Index | Gets or sets the index of this ChartSeries. (Inherited from ChartSeries.)
LabelBackground | Gets or sets the background of the label. (Inherited from ChartSeries.)
LabelBorderBrush | Gets or sets the brush for the label border. (Inherited from ChartSeries.)
LabelBorderThickness | Gets or sets the thickness of the label border. (Inherited from ChartSeries.)
LabelFontFamily | Gets or sets the font family for the chart labels. (Inherited from ChartSeries.)
LabelFontSize | Gets or sets the font size for the chart labels. (Inherited from ChartSeries.)
LabelFontStyle | Gets or sets the font style for the chart labels. (Inherited from ChartSeries.)
LabelFontWeight | Gets or sets the font weight for the series labels. (Inherited from ChartSeries.)
LabelForeground | Gets or sets the foreground of the label. (Inherited from ChartSeries.)
StrokeDashArray | Gets or sets a collection of double values that indicate the pattern of dashes and gaps that is used to outline ChartSeries shapes. (Inherited from ChartSeries.)
StrokeDashCap | Gets or sets a PenLineCap enumeration value that specifies how the ends of a dash in a ChartSeries shape are drawn. (Inherited from ChartSeries.)
StrokeDashOffset | Gets or sets a double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartSeries.)
StrokeEndLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartSeries.)
StrokeLineJoin | Gets or sets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a ChartSeries Shape. (Inherited from ChartSeries.)
StrokeMiterLimit | Gets or sets a limit on the ratio of the miter length to half the StrokeThickness of a ChartSeries Shape element. (Inherited from ChartSeries.)
Strokes | Gets the strokes of the series. (Inherited from ChartSeries.)
StrokesSource | Gets or sets the source of strokes used in this ChartSeries. (Inherited from ChartSeries.)
StrokeStartLineCap | Gets or sets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartSeries.)
StrokeThickness | Gets or sets the thickness of the stroke for the series. (Inherited from ChartSeries.)
Title | Gets or sets the title of the series. (Inherited from ChartSeries.)

See Also

RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.Angles Property

RadarSeries.Angles Property
[image]

Gets or sets the angles for the radar series.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection Angles { get; set; }

Visual Basic [image] Copy Code

Public Property Angles As DoubleCollection

Property Value

An instance of the System.Windows.Media.DoubleCollection class. Default value is an empty list.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.Data Property

RadarSeries.Data Property
[image]

Gets or sets the data for the RadarSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As DoubleCollection

Property Value

An object of type System.Windows.Media.DoubleCollection. Default value is an empty collection.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.DataPath Property

RadarSeries.DataPath Property
[image]

Gets or sets the path to the property in the DataSource used for retrieving data for the RadarSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string DataPath { get; set; }

Visual Basic [image] Copy Code

Public Property DataPath As String

Property Value

A string value. Default is an empty string ("").

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelBackground Property

RadarSeries.LabelBackground Property
[image]

Gets or sets the background of the label.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush LabelBackground { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBackground As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelBorderBrush Property

RadarSeries.LabelBorderBrush Property
[image]

Gets or sets the brush for the label border.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush LabelBorderBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBorderBrush As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelBorderThickness Property

RadarSeries.LabelBorderThickness Property
[image]

Gets or sets the thickness of the label border.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Thickness LabelBorderThickness { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBorderThickness As Thickness

Property Value

An instance of the System.Windows.Thickness structure. Default value is Thickness(1).

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelForeground Property

RadarSeries.LabelForeground Property
[image]

Gets or sets the foreground of the label.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush LabelForeground { get; set; }

Visual Basic [image] Copy Code

Public Property LabelForeground As Brush

Property Value

An instance of the System.Windows.Media.Brush class. Default value is null.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelOffset Property

RadarSeries.LabelOffset Property
[image]

Gets or sets the offset of the labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double LabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LabelOffset As Double

Property Value

A double value. Default value is 20.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelPath Property

RadarSeries.LabelPath Property
[image]

Gets or sets the path to the property in the DataSource used for retrieving custom labels for this RadarSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string LabelPath { get; set; }

Visual Basic [image] Copy Code

Public Property LabelPath As String

Property Value

A string value. Default value is an empty string ("").

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.Labels Property

RadarSeries.Labels Property
[image]

Gets or sets custom labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection Labels { get; set; }

Visual Basic [image] Copy Code

Public Property Labels As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty list.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.LabelType Property

RadarSeries.LabelType Property
[image]

Gets or sets the type of labels.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public LabelType LabelType { get; set; }

Visual Basic [image] Copy Code

Public Property LabelType As LabelType

Property Value

One of the LabelType enumeration values. Default value is LabelType.AutoScale.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.RadarScatterFills Property

RadarSeries.RadarScatterFills Property
[image]

Gets the fills of the scatters.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection RadarScatterFills { get; set; }

Visual Basic [image] Copy Code

Public Property RadarScatterFills As BrushCollection

Property Value

An instance of the BrushCollection class. Default value is an empty list.

Example

The following example creates a radar chart with diamond scatters. The scatters are orange with a red outlining.

C# [image] Copy Code

RadarSeries serie1 = new RadarSeries();

serie1.ScatterType = ScatterType.Diamond;
serie1.ScatterSize = 20;
serie1.RadarScatterFills.Add(new SolidColorBrush(Colors.Orange));
serie1.RadarScatterStrokes.Add(new SolidColorBrush(Colors.Red));

Visual Basic [image] Copy Code

Dim serie1 As New RadarSeries()

serie1.ScatterType = ScatterType.Diamond
serie1.ScatterSize = 20
serie1.RadarScatterFills.Add(New SolidColorBrush(Colors.Orange))
serie1.RadarScatterStrokes.Add(New SolidColorBrush(Colors.Red))

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.RadarScatterFillsSource Property

RadarSeries.RadarScatterFillsSource Property
[image]

Gets or sets the source for the fills of radar scatters.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public List<Brush> RadarScatterFillsSource { get; set; }

Visual Basic [image] Copy Code

Public Property RadarScatterFillsSource As List(Of Brush)

Property Value

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.RadarScatterStrokes Property

RadarSeries.RadarScatterStrokes Property
[image]

Gets the strokes for the scatters.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection RadarScatterStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property RadarScatterStrokes As BrushCollection

Property Value

An instance of the BrushCollection class. Default value is an empty list.

Example

Here is an example that renders diamond scatters at data points in a radar chart. The scatters are orange with a red outline.

C# [image] Copy Code

RadarSeries serie1 = new RadarSeries();

serie1.ScatterType = ScatterType.Diamond;
serie1.ScatterSize = 20;
serie1.RadarScatterFills.Add(new SolidColorBrush(Colors.Orange));
serie1.RadarScatterStrokes.Add(new SolidColorBrush(Colors.Red));

Visual Basic [image] Copy Code

Dim serie1 As New RadarSeries()

serie1.ScatterType = ScatterType.Diamond
serie1.ScatterSize = 20
serie1.RadarScatterFills.Add(New SolidColorBrush(Colors.Orange))
serie1.RadarScatterStrokes.Add(New SolidColorBrush(Colors.Red))

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.RadarScatterStrokesSource Property

RadarSeries.RadarScatterStrokesSource Property
[image]

Gets or sets the strokes for the radar scatters.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public List<Brush> RadarScatterStrokesSource { get; set; }

Visual Basic [image] Copy Code

Public Property RadarScatterStrokesSource As List(Of Brush)

Property Value

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.RadarScatterStrokeThickness Property

RadarSeries.RadarScatterStrokeThickness Property
[image]

Gets or sets the thickness of the scatter stroke.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double RadarScatterStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property RadarScatterStrokeThickness As Double

Property Value

A double value. Default value is 1.

Remarks

Scatters are drawn when RadarSeries.ScatterType is not ScatterType.Empty.

Example

The following example creates diamond scatters at a radar chart. The scatters are orange with a red outlining.

C# [image] Copy Code

RadarSeries serie1 = new RadarSeries();

serie1.ScatterType = ScatterType.Diamond;
serie1.ScatterSize = 20;
serie1.RadarScatterFills.Add(new SolidColorBrush(Colors.Orange));
serie1.RadarScatterStrokes.Add(new SolidColorBrush(Colors.Red));

Visual Basic [image] Copy Code

Dim serie1 As New RadarSeries()

serie1.ScatterType = ScatterType.Diamond
serie1.ScatterSize = 20
serie1.RadarScatterFills.Add(New SolidColorBrush(Colors.Orange))
serie1.RadarScatterStrokes.Add(New SolidColorBrush(Colors.Red))

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.RadarStyle Property

RadarSeries.RadarStyle Property
[image]

Gets or sets the style of this RadarSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public RadarStyle RadarStyle { get; set; }

Visual Basic [image] Copy Code

Public Property RadarStyle As RadarStyle

Property Value

One of the RadarStyle enumeration values. Default value is RadarStyle.Line.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.ScatterFills Property

RadarSeries.ScatterFills Property
[image]

Gets or sets the fills for the scatters.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public List<Brush> ScatterFills { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterFills As List(Of Brush)

Property Value

A list with System.Windows.Media.Brush objects. Default value is an empty list.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.ScatterSize Property

RadarSeries.ScatterSize Property
[image]

Gets or sets the size of the scatter.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double ScatterSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterSize As Double

Property Value

A double value. Default value is 10.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.ScatterStrokes Property

RadarSeries.ScatterStrokes Property
[image]

Gets or sets the strokes for the scatters.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public List<Brush> ScatterStrokes { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterStrokes As List(Of Brush)

Property Value

A list with System.Windows.Media.Brush objects. Default value is an empty list.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.ScatterStrokeThickness Property

RadarSeries.ScatterStrokeThickness Property
[image]

Gets or sets the thickness of the scatter stroke.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double ScatterStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterStrokeThickness As Double

Property Value

A double value. Default value is 1.0

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarSeries.ScatterType Property

RadarSeries.ScatterType Property
[image]

Gets or sets the type of the scatter.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ScatterType ScatterType { get; set; }

Visual Basic [image] Copy Code

Public Property ScatterType As ScatterType

Property Value

One of the ScatterType enumeration values. Default value is ScatterType.Circle.

See Also

RadarSeries Members
RadarSeries Class


MindFusion.Charting.Silverlight.RadarStyle Enumeration

RadarStyle Enumeration
[image]

Defines values that specify how the radar graphic is drawn.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum RadarStyle

Visual Basic [image] Copy Code

Public Enum RadarStyle

Members

Member name | Description
Arc | The radar graphic is built of arcs.
Bezier | The radar graphic is built of bezier curves.
Line | The radar graphic is built of lines.

See Also


MindFusion.Charting.Silverlight.RadarType Enumeration

RadarType Enumeration
[image]

Defines values that specify the type of the radar chart.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum RadarType

Visual Basic [image] Copy Code

Public Enum RadarType

Members

Member name | Description
Polar | The chart is polar.
Radar | The chart is radar.

See Also


MindFusion.Charting.Silverlight.RotatedLabel Class

RotatedLabel Class
[image]

Represents a text label, which can be rotated.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class RotatedLabel : Control

Visual Basic [image] Copy Code

Public Class RotatedLabel
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Charting.Silverlight.RotatedLabel

See Also

RotatedLabel Members


MindFusion.Charting.Silverlight.RotatedLabel Members

RotatedLabel Members
Constructors Fields Properties Methods
[image]

Represents a text label, which can be rotated.

The following tables list the members exposed by the RotatedLabel type.

Public Constructors

Name | Description
RotatedLabel | Initializes a new instance of the RotatedLabel class.

Public Fields

Name | Description
AngleProperty | Identifies the Angle dependency property.
TextProperty | Identifies the Text dependency property.

Public Properties

Name | Description
Angle | Gets or sets the angle of rotation for this RotatedLabel.
Text | Gets or sets the text of this RotatedLabel.

Public Methods

Name | Description
OnApplyTemplate | Invoked whenever application code or internal processes call.

Protected Methods

Name | Description
MeasureOverride | Provides behavior for the Measure pass of the layout for this RotatedLabel.

See Also

RotatedLabel Class


MindFusion.Charting.Silverlight.RotatedLabel Fields

RotatedLabel Fields
[image]

Public Fields

Name | Description
AngleProperty | Identifies the Angle dependency property.
TextProperty | Identifies the Text dependency property.

See Also

RotatedLabel Class


MindFusion.Charting.Silverlight.RotatedLabel.AngleProperty Field

RotatedLabel.AngleProperty Field
[image]

Identifies the Angle dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AngleProperty As DependencyProperty

See Also

RotatedLabel Members
RotatedLabel Class


MindFusion.Charting.Silverlight.RotatedLabel.TextProperty Field

RotatedLabel.TextProperty Field
[image]

Identifies the Text dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TextProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextProperty As DependencyProperty

See Also

RotatedLabel Members
RotatedLabel Class


MindFusion.Charting.Silverlight.RotatedLabel Constructor

RotatedLabel Constructor
[image]

Initializes a new instance of the RotatedLabel class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public RotatedLabel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RotatedLabel Class


MindFusion.Charting.Silverlight.RotatedLabel Methods

RotatedLabel Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | Invoked whenever application code or internal processes call.

Protected Methods

Name | Description
MeasureOverride | Provides behavior for the Measure pass of the layout for this RotatedLabel.

See Also

RotatedLabel Class


MindFusion.Charting.Silverlight.RotatedLabel.MeasureOverride Method

RotatedLabel.MeasureOverride Method
[image]

Provides behavior for the Measure pass of the layout for this RotatedLabel.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

The available size that the RotatedLabel could use.

Return Value

An insrtance of the System.Windows.Size structure that defines the space this RotatedLabel calculates it needs.

See Also

RotatedLabel Members
RotatedLabel Class


MindFusion.Charting.Silverlight.RotatedLabel.OnApplyTemplate Method

RotatedLabel.OnApplyTemplate Method
[image]

Invoked whenever application code or internal processes call.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

RotatedLabel Members
RotatedLabel Class


MindFusion.Charting.Silverlight.RotatedLabel Properties

RotatedLabel Properties
[image]

Public Properties

Name | Description
Angle | Gets or sets the angle of rotation for this RotatedLabel.
Text | Gets or sets the text of this RotatedLabel.

See Also

RotatedLabel Class


MindFusion.Charting.Silverlight.RotatedLabel.Angle Property

RotatedLabel.Angle Property
[image]

Gets or sets the angle of rotation for this RotatedLabel.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double Angle { get; set; }

Visual Basic [image] Copy Code

Public Property Angle As Double

Property Value

A double value. Default is 0.0

See Also

RotatedLabel Members
RotatedLabel Class


MindFusion.Charting.Silverlight.RotatedLabel.Text Property

RotatedLabel.Text Property
[image]

Gets or sets the text of this RotatedLabel.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string value. Default value is an empty string ("").

See Also

RotatedLabel Members
RotatedLabel Class


MindFusion.Charting.Silverlight.Scatter Class

Scatter Class
[image]

Represents scatter objects drawn at data points in line charts.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class Scatter : ChartElement

Visual Basic [image] Copy Code

Public Class Scatter
Inherits ChartElement

Inheritance Hierarchy

System.Object
MindFusion.Charting.Silverlight.ChartElement
MindFusion.Charting.Silverlight.Scatter

See Also

Scatter Members


MindFusion.Charting.Silverlight.Scatter Members

Scatter Members
Constructors Properties Methods
[image]

Represents scatter objects drawn at data points in line charts.

The following tables list the members exposed by the Scatter type.

Public Constructors

Name | Description
Scatter | Creates a new instance of the Scatter class.

Public Properties

Name | Description
Center | Gets the center of this Scatter.
ScatterIndex | Gets the index of this Scatter in the ChartSeries.
ScatterSize | Gets the size of this Scatter.
ScatterType | Gets the type of this Scatter.
SeriesIndex | Gets the index of the ChartSeries this Scatter belongs to in the Series collection.

Inherited Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Shape | Gets or sers the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this scatter element.

Inherited Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element. (Inherited from ChartElement.)

See Also

Scatter Class


MindFusion.Charting.Silverlight.Scatter Constructor

Scatter Constructor
[image]

Creates a new instance of the Scatter class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Scatter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Scatter Class


MindFusion.Charting.Silverlight.Scatter Methods

Scatter Methods
[image]

Public Methods

Name | Description
CreateShape | Creates a Shape that represents this scatter element.

Inherited Public Methods

Name | Description
CreateShape | Creates a Shape that represents the chart element. (Inherited from ChartElement.)

See Also

Scatter Class


MindFusion.Charting.Silverlight.Scatter.CreateShape Method

Scatter.CreateShape Method
[image]

Creates a Shape that represents this scatter element.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override Shape CreateShape ()

Visual Basic [image] Copy Code

Public Overrides Function CreateShape () As Shape

Return Value

An instance of the System.Windows.Shapes.Shape class.

Remarks

This event is used internally by the control and is not intended to be called by your code.

See Also

Scatter Members
Scatter Class


MindFusion.Charting.Silverlight.Scatter Properties

Scatter Properties
[image]

Public Properties

Name | Description
Center | Gets the center of this Scatter.
ScatterIndex | Gets the index of this Scatter in the ChartSeries.
ScatterSize | Gets the size of this Scatter.
ScatterType | Gets the type of this Scatter.
SeriesIndex | Gets the index of the ChartSeries this Scatter belongs to in the Series collection.

Inherited Public Properties

Name | Description
Effect | Gets or sets the effect of this ChartElement. (Inherited from ChartElement.)
Fill | Gets the fill of the element. (Inherited from ChartElement.)
Shape | Gets or sers the shape that represents this ChartElement. (Inherited from ChartElement.)
Stroke | Gets or the stroke of the element. (Inherited from ChartElement.)
StrokeDashArray | Gets the collection of double values that indicate the pattern of dashes and gaps that is used to outline the ChartElement shape. (Inherited from ChartElement.)
StrokeDashCap | Gets a PenLineCap enumeration value that specifies how the ends of a dash are drawn. (Inherited from ChartElement.)
StrokeDashOffset | Gets a Double that specifies the distance within the dash pattern where a dash begins. (Inherited from ChartElement.)
StrokeEndLineCap | Gets a PenLineCap enumeration value that describes the Shape at the end of a line. (Inherited from ChartElement.)
StrokeLineJoin | Gets a PenLineJoin enumeration value that specifies the type of join that is used at the vertices of a Shape. (Inherited from ChartElement.)
StrokeMiterLimit | Gets a limit on the ratio of the miter length to half the StrokeThickness of a Shape element. (Inherited from ChartElement.)
StrokeStartLineCap | Gets a PenLineCap enumeration value that describes the Shape at the start of a line. (Inherited from ChartElement.)
StrokeThickness | Gets the stroke thickness of the element. (Inherited from ChartElement.)

See Also

Scatter Class


MindFusion.Charting.Silverlight.Scatter.Center Property

Scatter.Center Property
[image]

Gets the center of this Scatter.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Point Center { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Center As Point

Property Value

An instance of the System.Windows.Point structure. Default value is Point(0,0).

Remarks

The value of the Center property depends on the location of the point which is set with AxesSeries.XData and AxesSeries.YData.

See Also

Scatter Members
Scatter Class


MindFusion.Charting.Silverlight.Scatter.ScatterIndex Property

Scatter.ScatterIndex Property
[image]

Gets the index of this Scatter in the ChartSeries.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int ScatterIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScatterIndex As Integer

Property Value

An int value. Default value is -1.

See Also

Scatter Members
Scatter Class


MindFusion.Charting.Silverlight.Scatter.ScatterSize Property

Scatter.ScatterSize Property
[image]

Gets the size of this Scatter.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double ScatterSize { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScatterSize As Double

Property Value

A double value. Default is 0.0

Remarks

The size of the scatter is set with LineSeries.ScatterSize.

See Also

Scatter Members
Scatter Class


MindFusion.Charting.Silverlight.Scatter.ScatterType Property

Scatter.ScatterType Property
[image]

Gets the type of this Scatter.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ScatterType ScatterType { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScatterType As ScatterType

Property Value

One of the ScatterType enumeration values. Default value is ScatterType.None.

Remarks

The size of the scatter is set with LineSeries.ScatterSize.

See Also

Scatter Members
Scatter Class


MindFusion.Charting.Silverlight.Scatter.SeriesIndex Property

Scatter.SeriesIndex Property
[image]

Gets the index of the ChartSeries this Scatter belongs to in the Series collection.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int SeriesIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SeriesIndex As Integer

Property Value

An int value. Default value is -1.

See Also

Scatter Members
Scatter Class


MindFusion.Charting.Silverlight.ScatterType Enumeration

ScatterType Enumeration
[image]

Specifies the types of scatter shapes supported by the control.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum ScatterType

Visual Basic [image] Copy Code

Public Enum ScatterType

Members

Member name | Description
Circle | The scatter is drawn in the shape of a circle.
Cross | The scatter is drawn in the shape of a cross.
Diamond | The scatter is drawn in the shape of a diamond.
HorStick | The scatter is drawn in the shape of a horizontal stick.
InvertedTriangle | The scatter is drawn in the shape of an inverted triangle.
None | No scatter is drawn.
Plus | The scatter is drawn in the shape of a plus.
Square | The scatter is drawn in the shape of a square.
Star | The scatter is drawn in the shape of a star.
Triangle | The scatter is drawn in the shape of a triangle.
VertStick | The scatter is drawn in the shape of a vertical stick.

See Also


MindFusion.Charting.Silverlight.SeriesLegend Class

SeriesLegend Class
[image]

Represents a legend with custom labels and colors.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class SeriesLegend : Legend

Visual Basic [image] Copy Code

Public Class SeriesLegend
Inherits Legend

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ItemsControl
MindFusion.Charting.Silverlight.Legend
MindFusion.Charting.Silverlight.SeriesLegend

See Also

SeriesLegend Members


MindFusion.Charting.Silverlight.SeriesLegend Members

SeriesLegend Members
Constructors Fields Properties Methods Events
[image]

Represents a legend with custom labels and colors.

The following tables list the members exposed by the SeriesLegend type.

Public Constructors

Name | Description
SeriesLegend | Initializes a new instance of the SeriesLegend class.

Public Fields

Name | Description
BrushesSourceProperty | Identifies the BrushesSource dependency property.
LabelsSourceProperty | Identifies the LabelsSource dependency property.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Legend.)
OrientationProperty | Identifies the Orientation dependency property. (Inherited from Legend.)
ShapeSizeProperty | Identifies the ShapeSize dependency property. (Inherited from Legend.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from Legend.)

Public Properties

Name | Description
BrushesSource | Gets or sets the source of the brushes that are used by this SeriesLegend.
LabelsSource | Gets or sets the source of the labels that are used by this SeriesLegend.

Inherited Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the Legend. (Inherited from Legend.)
Orientation | Gets or sets the orientation of the Legend. (Inherited from Legend.)
ShapeSize | Gets or sets the size of the shapes in the Legend. (Inherited from Legend.)
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the Legend. (Inherited from Legend.)

Public Methods

Name | Description
OnBrushesSourceChanged | Raises the BrushesSourceChanged event.
OnLabelsSourceChanged | Raises the LabelsSourceChanged event.

Inherited Public Methods

Name | Description
OnDataChanged | Raises the DataChanged event. (Inherited from Legend.)
RegisterForNotification | Listens for changes in the specified dependency property. (Inherited from Legend.)

Inherited Public Events

Name | Description
DataChanged | Occurs when series appearance was changed. (Inherited from Legend.)

See Also

SeriesLegend Class


MindFusion.Charting.Silverlight.SeriesLegend Fields

SeriesLegend Fields
[image]

Public Fields

Name | Description
BrushesSourceProperty | Identifies the BrushesSource dependency property.
LabelsSourceProperty | Identifies the LabelsSource dependency property.

Inherited Public Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property. (Inherited from Legend.)
OrientationProperty | Identifies the Orientation dependency property. (Inherited from Legend.)
ShapeSizeProperty | Identifies the ShapeSize dependency property. (Inherited from Legend.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from Legend.)

See Also

SeriesLegend Class


MindFusion.Charting.Silverlight.SeriesLegend.BrushesSourceProperty Field

SeriesLegend.BrushesSourceProperty Field
[image]

Identifies the BrushesSource dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty BrushesSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BrushesSourceProperty As DependencyProperty

See Also

SeriesLegend Members
SeriesLegend Class


MindFusion.Charting.Silverlight.SeriesLegend.LabelsSourceProperty Field

SeriesLegend.LabelsSourceProperty Field
[image]

Identifies the LabelsSource dependency property.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelsSourceProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelsSourceProperty As DependencyProperty

See Also

SeriesLegend Members
SeriesLegend Class


MindFusion.Charting.Silverlight.SeriesLegend Constructor

SeriesLegend Constructor
[image]

Initializes a new instance of the SeriesLegend class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public SeriesLegend ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SeriesLegend Class


MindFusion.Charting.Silverlight.SeriesLegend Methods

SeriesLegend Methods
[image]

Public Methods

Name | Description
OnBrushesSourceChanged | Raises the BrushesSourceChanged event.
OnLabelsSourceChanged | Raises the LabelsSourceChanged event.

Inherited Public Methods

Name | Description
OnDataChanged | Raises the DataChanged event. (Inherited from Legend.)
RegisterForNotification | Listens for changes in the specified dependency property. (Inherited from Legend.)

See Also

SeriesLegend Class


MindFusion.Charting.Silverlight.SeriesLegend.OnBrushesSourceChanged Method

SeriesLegend.OnBrushesSourceChanged Method
[image]

Raises the BrushesSourceChanged event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void OnBrushesSourceChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnBrushesSourceChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The sender of the event.

e

An instance of the System.DependencyPropertyChangedEventArgs class that provides data for the event.

See Also

SeriesLegend Members
SeriesLegend Class


MindFusion.Charting.Silverlight.SeriesLegend.OnLabelsSourceChanged Method

SeriesLegend.OnLabelsSourceChanged Method
[image]

Raises the LabelsSourceChanged event.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static void OnLabelsSourceChanged (
DependencyObject d,
DependencyPropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Public Shared Sub OnLabelsSourceChanged( _
d As DependencyObject, _
e As DependencyPropertyChangedEventArgs _
)

Parameters

d

The object that reised the event.

e

An instance of the System.DependencyPropertyChangedEventArgs class that provides data for the event.

See Also

SeriesLegend Members
SeriesLegend Class


MindFusion.Charting.Silverlight.SeriesLegend Properties

SeriesLegend Properties
[image]

Public Properties

Name | Description
BrushesSource | Gets or sets the source of the brushes that are used by this SeriesLegend.
LabelsSource | Gets or sets the source of the labels that are used by this SeriesLegend.

Inherited Public Properties

Name | Description
CornerRadius | Gets or sets the corner radius of the Legend. (Inherited from Legend.)
Orientation | Gets or sets the orientation of the Legend. (Inherited from Legend.)
ShapeSize | Gets or sets the size of the shapes in the Legend. (Inherited from Legend.)
StrokeThickness | Gets or sets the stroke thickness of lines drawn in the Legend. (Inherited from Legend.)

See Also

SeriesLegend Class


MindFusion.Charting.Silverlight.SeriesLegend.BrushesSource Property

SeriesLegend.BrushesSource Property
[image]

Gets or sets the source of the brushes that are used by this SeriesLegend.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection BrushesSource { get; set; }

Visual Basic [image] Copy Code

Public Property BrushesSource As BrushCollection

Property Value

An instance of the BrushCollection class. Default value is an empty list.

Remarks

You should set a corresponding label in the LabelsSource array for each Brush that you add to BrushesSource.

See Also

SeriesLegend Members
SeriesLegend Class


MindFusion.Charting.Silverlight.SeriesLegend.LabelsSource Property

SeriesLegend.LabelsSource Property
[image]

Gets or sets the source of the labels that are used by this SeriesLegend.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection LabelsSource { get; set; }

Visual Basic [image] Copy Code

Public Property LabelsSource As StringCollection

Property Value

An instance of the StringCollection class. Default value is an empty list.

Remarks

You should set a corresponding label in the BrushesSource array for each Brush that you add to LabelsSource.

See Also

SeriesLegend Members
SeriesLegend Class


MindFusion.Charting.Silverlight.StringCollection Class

StringCollection Class
[image]

Represents an observable collection of string objects.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class StringCollection : ObservableCollection<string>

Visual Basic [image] Copy Code

Public Class StringCollection
Inherits ObservableCollection(Of String)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(String)
System.Collections.ObjectModel.ObservableCollection(String)
MindFusion.Charting.Silverlight.StringCollection

See Also

StringCollection Members


MindFusion.Charting.Silverlight.StringCollection Members

StringCollection Members
Constructors
[image]

Represents an observable collection of string objects.

The following tables list the members exposed by the StringCollection type.

Public Constructors

Name | Description
StringCollection | Initializes a new instance of the StringCollection class.

See Also

StringCollection Class


MindFusion.Charting.Silverlight.StringCollection Constructor

StringCollection Constructor
[image]

Initializes a new instance of the StringCollection class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

StringCollection Class


MindFusion.Charting.Silverlight.StringCollectionConverter Class

StringCollectionConverter Class
Remarks See Also
[image]

Converts StringCollection objects to and from strings.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class StringCollectionConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class StringCollectionConverter
Inherits TypeConverter

Remarks

This class is for internal use only.

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Charting.Silverlight.StringCollectionConverter

See Also

StringCollectionConverter Members


MindFusion.Charting.Silverlight.StringCollectionConverter Members

StringCollectionConverter Members
Constructors Methods
[image]

Converts StringCollection objects to and from strings.

The following tables list the members exposed by the StringCollectionConverter type.

Public Constructors

Name | Description
StringCollectionConverter | Initializes a new instance of the StringCollectionConverter class.

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

StringCollectionConverter Class


MindFusion.Charting.Silverlight.StringCollectionConverter Constructor

StringCollectionConverter Constructor
[image]

Initializes a new instance of the StringCollectionConverter class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public StringCollectionConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

StringCollectionConverter Class


MindFusion.Charting.Silverlight.StringCollectionConverter Methods

StringCollectionConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | TypeConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

StringCollectionConverter Class


MindFusion.Charting.Silverlight.StringCollectionConverter.CanConvertFrom Method

StringCollectionConverter.CanConvertFrom Method
[image]

TypeConverter.CanConvertFrom override.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context

An System.ComponentModel.ITypeDescriptorContext that provides a format context.

sourceType

A System.Type that represents the type we want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

StringCollectionConverter Members
StringCollectionConverter Class


MindFusion.Charting.Silverlight.StringCollectionConverter.CanConvertTo Method

StringCollectionConverter.CanConvertTo Method
[image]

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context

A System.ComponentModel.ITypeDescriptorContext that provides a format context.

destinationType

A System.Type that represents the type we want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

StringCollectionConverter Members
StringCollectionConverter Class


MindFusion.Charting.Silverlight.StringCollectionConverter.ConvertFrom Method

StringCollectionConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context

A System.ComponentModel.ITypeDescriptorContext that provides a format context.

culture

The System.Globalization.CultureInfo to use as the current culture.

value

The System.Object to convert.

Return Value

A System.Object that represents the converted value.

See Also

StringCollectionConverter Members
StringCollectionConverter Class


MindFusion.Charting.Silverlight.StringCollectionConverter.ConvertTo Method

StringCollectionConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context

A System.ComponentModel.ITypeDescriptorContext that provides a format context.

culture

A System.Globalization.CultureInfo. If null is passed, the current culture is assumed.

value

The System.Object to convert.

destinationType

The System.Type to convert the value parameter to.

Return Value

See Also

StringCollectionConverter Members
StringCollectionConverter Class


MindFusion.Charting.Silverlight.ValueFormat Enumeration

ValueFormat Enumeration
[image]

Defines type of data related to a chart axis.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public enum ValueFormat

Visual Basic [image] Copy Code

Public Enum ValueFormat

Members

Member name | Description
DateTime | The data is DateTime values.
Number | The data is numbers.

See Also


MindFusion.Charting.Silverlight.XmlSerializationContext Class

XmlSerializationContext Class
[image]

Contains methods that can help you serialize and deserialize MindFusion.Charting for Silverlight items to and from XML documents.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public class XmlSerializationContext

Visual Basic [image] Copy Code

Public Class XmlSerializationContext

Inheritance Hierarchy

System.Object
MindFusion.Charting.Silverlight.XmlSerializationContext

See Also

XmlSerializationContext Members


MindFusion.Charting.Silverlight.XmlSerializationContext Members

XmlSerializationContext Members
Constructors Fields Properties Methods
[image]

Contains methods that can help you serialize and deserialize MindFusion.Charting for Silverlight items to and from XML documents.

The following tables list the members exposed by the XmlSerializationContext type.

Public Constructors

Name | Description
XmlSerializationContext | Overloaded.

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

Public Properties

Name | Description
BaseURI | Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.
FileVersion | Gets the format revision number for the file being currently serialized.
XDocument | Gets the underlying XML document.
XElement | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded.
ReadBool | Overloaded.
ReadBrush | Reads a Brush object with the specified name.
ReadBrushList | Reads a list of brushes from the specified element with the specified parent.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Overloaded.
ReadDoubleArray | Reads a color array with the specified name.
ReadDoubleCollection | Reads a System.Windows.Media.DoubleCollection from the specified element with the specified parent.
ReadEffect | Reads the System.Windows.Media.Effects.Effect that was applied to the specified element with the specified parent.
ReadEnum | Overloaded. Reads enumeration.
ReadFloat | Overloaded. Reads a float value.
ReadFontFamily | Reads a FontFamily object with the specified name.
ReadFontStyle | Reads a System.Windows.FontStyle object with the specified name.
ReadFontWeight | Reads a System.Windows.FontWeight object with the specified name.
ReadGradientStopCollection | Reads a System.Windows.Media.GradientStopCollection from the specified element with the specified parent.
ReadInt | Overloaded. Reads an int value.
ReadLong | Reads a long value with the specified name.
ReadPoint | Overloaded.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadRectangle | Reads a Rect object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Reads a short value with the specified name.
ReadSize | Reads a System.Windows.Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadThickness | Reads a System.Windows.Thickness object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
SelectNode | Returns the child node with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteBrushList | Overloaded.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array of Color values.
WriteDecimal | Write the decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteDoubleArray | Writes the specified array.
WriteDoubleCollection | Writes the specified DoubleCollection under the specified name with the specified parent.
WriteEffect | Writes the specified System.Windows.Media.Effect under the specified name with the specified parent.
WriteEnum | Writes the specified enum value.
WriteFontFamily | Overloaded.
WriteFontStyle | Writes a FontStyle object with the specified name.
WriteFontWeight | Writes a FontWeight object with the specified name.
WriteGradientStop | Writes the specified GradientStop under the specified name with the specified parent.
WriteGradientStopCollection | Writes the specified GradientStopCollection under the specified name with the specified parent.
WriteInt | Writes an integer value with the specified name.
WriteLong | Writes a long value with the specified name.
WritePoint | Overloaded.
WritePointCollection | Writes the specified point collection.
WriteRectangle | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSize | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteThickness | Overloaded.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext Fields

XmlSerializationContext Fields
[image]

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

See Also

XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.LatestFormat Field

XmlSerializationContext.LatestFormat Field
[image]

Specifies the latest file format revision number.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public static int LatestFormat

Visual Basic [image] Copy Code

Public Shared LatestFormat As Integer

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext Constructor

XmlSerializationContext Constructor
[image]

Overload List

Name | Description
XmlSerializationContext (Chart, Int32, XDocument) | Initializes a new instance of the XmlSerializationContext class.
XmlSerializationContext (Chart, XDocument) | Initializes a new instance of the XmlSerializationContext class.
XmlSerializationContext (Chart, Int32, XElement) | Initializes a new instance of the XmlSerializationContext class.
XmlSerializationContext (Chart, XElement) | Initializes a new instance of the XmlSerializationContext class.

See Also

XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext Constructor (Chart, Int32, XDocument)

XmlSerializationContext Constructor (Chart, Int32, XDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Chart chart,
int fileVersion,
XDocument document
)

Visual Basic [image] Copy Code

Public New ( _
chart As Chart, _
fileVersion As Integer, _
document As XDocument _
)

Parameters

chart

The Chart this class will operate on.

fileVersion

The file version of the file being deserialized.

document

The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext Constructor (Chart, XDocument)

XmlSerializationContext Constructor (Chart, XDocument)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Chart chart,
XDocument document
)

Visual Basic [image] Copy Code

Public New ( _
chart As Chart, _
document As XDocument _
)

Parameters

chart

The Chart this class will operate on.

document

The System.Xml.XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext Constructor (Chart, Int32, XElement)

XmlSerializationContext Constructor (Chart, Int32, XElement)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Chart chart,
int fileVersion,
XElement document
)

Visual Basic [image] Copy Code

Public New ( _
chart As Chart, _
fileVersion As Integer, _
document As XElement _
)

Parameters

chart

The Chart this class will operate on.

fileVersion

The file version of the file being deserialized.

document

The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext Constructor (Chart, XElement)

XmlSerializationContext Constructor (Chart, XElement)
See Also
[image]

Initializes a new instance of the XmlSerializationContext class.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XmlSerializationContext (
Chart chart,
XElement document
)

Visual Basic [image] Copy Code

Public New ( _
chart As Chart, _
document As XElement _
)

Parameters

chart

The Schedule this class will operate on.

document

The .NET XmlDocument to serialize/deserialize to/from.

See Also

XmlSerializationContext Constructor Overload List
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext Methods

XmlSerializationContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded.
ReadBool | Overloaded.
ReadBrush | Reads a Brush object with the specified name.
ReadBrushList | Reads a list of brushes from the specified element with the specified parent.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Reads a color with the specified name.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Overloaded.
ReadDoubleArray | Reads a color array with the specified name.
ReadDoubleCollection | Reads a System.Windows.Media.DoubleCollection from the specified element with the specified parent.
ReadEffect | Reads the System.Windows.Media.Effects.Effect that was applied to the specified element with the specified parent.
ReadEnum | Overloaded. Reads enumeration.
ReadFloat | Overloaded. Reads a float value.
ReadFontFamily | Reads a FontFamily object with the specified name.
ReadFontStyle | Reads a System.Windows.FontStyle object with the specified name.
ReadFontWeight | Reads a System.Windows.FontWeight object with the specified name.
ReadGradientStopCollection | Reads a System.Windows.Media.GradientStopCollection from the specified element with the specified parent.
ReadInt | Overloaded. Reads an int value.
ReadLong | Reads a long value with the specified name.
ReadPoint | Overloaded.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadRectangle | Reads a Rect object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShort | Reads a short value with the specified name.
ReadSize | Reads a System.Windows.Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded.
ReadThickness | Reads a System.Windows.Thickness object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
SelectNode | Returns the child node with the specified name.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteBrushList | Overloaded.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array of Color values.
WriteDecimal | Write the decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteDoubleArray | Writes the specified array.
WriteDoubleCollection | Writes the specified DoubleCollection under the specified name with the specified parent.
WriteEffect | Writes the specified System.Windows.Media.Effect under the specified name with the specified parent.
WriteEnum | Writes the specified enum value.
WriteFontFamily | Overloaded.
WriteFontStyle | Writes a FontStyle object with the specified name.
WriteFontWeight | Writes a FontWeight object with the specified name.
WriteGradientStop | Writes the specified GradientStop under the specified name with the specified parent.
WriteGradientStopCollection | Writes the specified GradientStopCollection under the specified name with the specified parent.
WriteInt | Writes an integer value with the specified name.
WriteLong | Writes a long value with the specified name.
WritePoint | Overloaded.
WritePointCollection | Writes the specified point collection.
WriteRectangle | Writes a RectangleF with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSize | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteThickness | Overloaded.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.AddChildElement Method

XmlSerializationContext.AddChildElement Method
[image]

Overload List

Name | Description
XmlSerializationContext.AddChildElement (String, XElement) | Adds a new child node with the specified name to the specified parent node.
XmlSerializationContext.AddChildElement (String, XElement, String) | Adds a new child node with the specified name to the specified parent node.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.AddChildElement Method (String, XElement)

XmlSerializationContext.AddChildElement Method (String, XElement)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement AddChildElement (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

elementName

The name of the element to add.

parentElement

The parent of the element to add.

Return Value

The newly added System.Xml.Linq.XElement object.

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.AddChildElement Method (String, XElement, String)

XmlSerializationContext.AddChildElement Method (String, XElement, String)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement AddChildElement (
string elementName,
XElement parentElement,
string Value
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XElement, _
Value As String _
) As XElement

Parameters

elementName

The name of the element to add.

parentElement

The parent of the element to add.

Value

The value of the element to add.

Return Value

See Also

AddChildElement Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadBool Method

XmlSerializationContext.ReadBool Method
[image]

Overload List

Name | Description
XmlSerializationContext.ReadBool (String, XElement) | Reads a boolean value with the specified name.
XmlSerializationContext.ReadBool (String, XElement, Boolean) | ReReads a boolean value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadBool Method (String, XElement)

XmlSerializationContext.ReadBool Method (String, XElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XElement _
) As Boolean

Parameters

elementName

The name of the element containing the bool value.

parentElement

The parent element of the node with the specified name.

Return Value

The deserialized bool value.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadBool Method (String, XElement, Boolean)

XmlSerializationContext.ReadBool Method (String, XElement, Boolean)
See Also
[image]

ReReads a boolean value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName

The name of the element containing the bool value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value to return if the specified element is not found.

Return Value

The deserialized a bool value or returns defaultValue if the conversion fails.

See Also

ReadBool Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadBrush Method

XmlSerializationContext.ReadBrush Method
[image]

Reads a Brush object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As String, _
parentElement As XElement _
) As Brush

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

Reads a System.Windows.Media.Brush object from the specified element with the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadBrushList Method

XmlSerializationContext.ReadBrushList Method
[image]

Reads a list of brushes from the specified element with the specified parent.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public BrushCollection ReadBrushList (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrushList( _
elementName As String, _
parentElement As XElement _
) As BrushCollection

Parameters

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The BrushCollection objects that was deserialized.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadByte Method

XmlSerializationContext.ReadByte Method
[image]

Reads a byte value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As String, _
parentElement As XElement _
) As Byte

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The byte value that was deserialized.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadChar Method

XmlSerializationContext.ReadChar Method
[image]

Reads a char value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As String, _
parentElement As XElement _
) As Char

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The char value that was deserialized.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadColor Method

XmlSerializationContext.ReadColor Method
[image]

Reads a color with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XElement _
) As Color

Parameters

elementName
The name of the element to read.
parentElement

The parent of the element to read.

Return Value

The deserialized Color value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadColorArray Method

XmlSerializationContext.ReadColorArray Method
[image]

Reads a color array with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As Color()

Parameters

elementName

The name of the element to read.

subElementName

The name of the sub-elements that represent the Color objects to read.

parentElement

The parent of the element to read.

Return Value

The deserialized array with Color values.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadDecimal Method

XmlSerializationContext.ReadDecimal Method
[image]

Reads a decimal value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As String, _
parentElement As XElement _
) As Decimal

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The deserialized decimal value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadDouble Method

XmlSerializationContext.ReadDouble Method
[image]

Overload List

Name | Description
XmlSerializationContext.ReadDouble (String, XElement) | Reads a double value with the specified name.
XmlSerializationContext.ReadDouble (String, XElement, Double) | Reads a double value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadDouble Method (String, XElement)

XmlSerializationContext.ReadDouble Method (String, XElement)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XElement _
) As Double

Parameters

elementName

The name of the element containing the double value.

parentElement

The parent element of the node with the specified name.

Return Value

The deserialized double value.

See Also

ReadDouble Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadDouble Method (String, XElement, Double)

XmlSerializationContext.ReadDouble Method (String, XElement, Double)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XElement parentElement,
double defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XElement, _
defaultValue As Double _
) As Double

Parameters

elementName

The name of the element containing the double value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value to be returned if the element is not found

Return Value

The deserialized double value or defaultValue if the deserialization fails.

See Also

ReadDouble Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadDoubleArray Method

XmlSerializationContext.ReadDoubleArray Method
[image]

Reads a color array with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double[] ReadDoubleArray (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDoubleArray( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As Double()

Parameters

elementName

The name of the element to read.

subElementName

The name of the sub-element to read.

parentElement

The parent of the element.

Return Value

The deserialized array with double values.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadDoubleCollection Method

XmlSerializationContext.ReadDoubleCollection Method
[image]

Reads a System.Windows.Media.DoubleCollection from the specified element with the specified parent.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public DoubleCollection ReadDoubleCollection (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDoubleCollection( _
elementName As String, _
parentElement As XElement _
) As DoubleCollection

Parameters

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The System.Windows.Media.DoubleCollection that was deserialized.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadEffect Method

XmlSerializationContext.ReadEffect Method
[image]

Reads the System.Windows.Media.Effects.Effect that was applied to the specified element with the specified parent.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Effect ReadEffect (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
elementName As String, _
parentElement As XElement _
) As Effect

Parameters

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The System.Windows.Media.Effects.Effect that was deserialized.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadEnum Method

XmlSerializationContext.ReadEnum Method
[image]

Reads enumeration.

Overload List

Name | Description
XmlSerializationContext.ReadEnum (String, XElement) | Reads an enum value with the specified name.
XmlSerializationContext.ReadEnum (String, XElement, Object) | Reads an enum value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadEnum Method (String, XElement)

XmlSerializationContext.ReadEnum Method (String, XElement)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

ReadEnum Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadEnum Method (String, XElement, Object)

XmlSerializationContext.ReadEnum Method (String, XElement, Object)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XElement parentElement,
Object defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XElement, _
defaultValue As Object _
) As Object

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadEnum Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadFloat Method

XmlSerializationContext.ReadFloat Method
[image]

Reads a float value.

Overload List

Name | Description
XmlSerializationContext.ReadFloat (String, XElement) | Reads a double value with the specified name.
XmlSerializationContext.ReadFloat (String, XElement, Double) | Reads a double value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadFloat Method (String, XElement)

XmlSerializationContext.ReadFloat Method (String, XElement)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double ReadFloat (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XElement _
) As Double

Parameters

elementName

parentElement

Return Value

See Also

ReadFloat Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadFloat Method (String, XElement, Double)

XmlSerializationContext.ReadFloat Method (String, XElement, Double)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public double ReadFloat (
string elementName,
XElement parentElement,
double defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XElement, _
defaultValue As Double _
) As Double

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadFloat Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadFontFamily Method

XmlSerializationContext.ReadFontFamily Method
[image]

Reads a FontFamily object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public FontFamily ReadFontFamily (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontFamily( _
elementName As String, _
parentElement As XElement _
) As FontFamily

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadFontStyle Method

XmlSerializationContext.ReadFontStyle Method
[image]

Reads a System.Windows.FontStyle object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Object ReadFontStyle (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontStyle( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The deserialized System.Windows.FontStyle value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadFontWeight Method

XmlSerializationContext.ReadFontWeight Method
[image]

Reads a System.Windows.FontWeight object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Object ReadFontWeight (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFontWeight( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The deserialized System.Object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadGradientStopCollection Method

XmlSerializationContext.ReadGradientStopCollection Method
[image]

Reads a System.Windows.Media.GradientStopCollection from the specified element with the specified parent.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public GradientStopCollection ReadGradientStopCollection (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadGradientStopCollection( _
elementName As String, _
parentElement As XElement _
) As GradientStopCollection

Parameters

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The System.Windows.Media.GradientStopCollection that was deserialized.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadInt Method

XmlSerializationContext.ReadInt Method
[image]

Reads an int value.

Overload List

Name | Description
XmlSerializationContext.ReadInt (String, XElement) | Reads an integer value with the specified name.
XmlSerializationContext.ReadInt (String, XElement, Int32) | Reads an integer value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadInt Method (String, XElement)

XmlSerializationContext.ReadInt Method (String, XElement)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XElement _
) As Integer

Parameters

elementName

parentElement

Return Value

See Also

ReadInt Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadInt Method (String, XElement, Int32)

XmlSerializationContext.ReadInt Method (String, XElement, Int32)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XElement parentElement,
int defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XElement, _
defaultValue As Integer _
) As Integer

Parameters

elementName

The name of the element containing the integer value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value returned if the specified element is not found.

Return Value

See Also

ReadInt Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadLong Method

XmlSerializationContext.ReadLong Method
[image]

Reads a long value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As String, _
parentElement As XElement _
) As Long

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The deserialized long value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadPoint Method

XmlSerializationContext.ReadPoint Method
[image]

Overload List

Name | Description
XmlSerializationContext.ReadPoint (String, XElement) | Reads a Point object with the specified name.
XmlSerializationContext.ReadPoint (XElement) | Reads a PointF object from the specified element.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadPoint Method (String, XElement)

XmlSerializationContext.ReadPoint Method (String, XElement)
See Also
[image]

Reads a Point object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Point ReadPoint (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPoint( _
elementName As String, _
parentElement As XElement _
) As Point

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The deserialized System.Windows.Point value.

See Also

ReadPoint Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadPoint Method (XElement)

XmlSerializationContext.ReadPoint Method (XElement)
See Also
[image]

Reads a PointF object from the specified element.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Point ReadPoint (
XElement element
)

Visual Basic [image] Copy Code

Public Function ReadPoint( _
element As XElement _
) As Point

Parameters

element

The name of the element to read.

Return Value

The deserialized System.Windows.Point value.

See Also

ReadPoint Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadPointCollection Method

XmlSerializationContext.ReadPointCollection Method
[image]

Reads a PointCollection object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public PointCollection ReadPointCollection (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointCollection( _
elementName As String, _
parentElement As XElement _
) As PointCollection

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The deserialized System.Windows.Media.PointCollection value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadRectangle Method

XmlSerializationContext.ReadRectangle Method
[image]

Reads a Rect object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Rect ReadRectangle (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRectangle( _
elementName As String, _
parentElement As XElement _
) As Rect

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The deserialized System.Windows.Rect value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadSByte Method

XmlSerializationContext.ReadSByte Method
[image]

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As String, _
parentElement As XElement _
) As SByte

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The deserialized sbyte value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadShort Method

XmlSerializationContext.ReadShort Method
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XElement _
) As Short

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The deserialized short value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadSize Method

XmlSerializationContext.ReadSize Method
[image]

Reads a System.Windows.Size object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Size ReadSize (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSize( _
elementName As String, _
parentElement As XElement _
) As Size

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

The deserialized System.Windows.Size value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadStream Method

XmlSerializationContext.ReadStream Method
[image]

Reads a stream with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Stream ReadStream (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
elementName As String, _
parentElement As XElement _
) As Stream

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadString Method

XmlSerializationContext.ReadString Method
[image]

Overload List

Name | Description
XmlSerializationContext.ReadString (String, XElement) | Reads a string value with the specified name.
XmlSerializationContext.ReadString (String, XElement, String) | Reads a string value with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadString Method (String, XElement)

XmlSerializationContext.ReadString Method (String, XElement)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XElement _
) As String

Parameters

elementName

The name of the element containing the string value.

parentElement

The parent element of the node with the specified name.

Return Value

A string value that is deserialized from the specified string.

See Also

ReadString Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadString Method (String, XElement, String)

XmlSerializationContext.ReadString Method (String, XElement, String)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XElement parentElement,
string defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XElement, _
defaultValue As String _
) As String

Parameters

elementName

The name of the element containing the string value.

parentElement

The parent element of the node with the specified name.

defaultValue

The value to return if the specified element is not found.

Return Value

A string value that is deserialized from the specified string.

See Also

ReadString Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadThickness Method

XmlSerializationContext.ReadThickness Method
[image]

Reads a System.Windows.Thickness object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public Thickness ReadThickness (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadThickness( _
elementName As String, _
parentElement As XElement _
) As Thickness

Parameters

elementName

The name of the element to read.

parentElement

The parent of the element to read.

Return Value

A boolean value that is deserialized from the specified string.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadUInt Method

XmlSerializationContext.ReadUInt Method
[image]

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As String, _
parentElement As XElement _
) As UInteger

Parameters

elementName

The name of the element containing the unsigned integer value.

parentElement

The parent element of the node with the specified name.

Return Value

An unisgned integer that is deserialized from the specified string.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadULong Method

XmlSerializationContext.ReadULong Method
[image]

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As String, _
parentElement As XElement _
) As ULong

Parameters

elementName

The name of the element containing the unsigned long value.

parentElement

The parent element of the node with the specified name.

Return Value

An unsigned long that is deserialized from the specified string.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.ReadUShort Method

XmlSerializationContext.ReadUShort Method
[image]

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As String, _
parentElement As XElement _
) As UShort

Parameters

elementName

The name of the element containing the unsigned short value.

parentElement

The name of the element containing the unsigned short value.

Return Value

An unsigned short that is deserialized from the specified string.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.SelectNode Method

XmlSerializationContext.SelectNode Method
[image]

Returns the child node with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement SelectNode (
XElement parentElement,
string name
)

Visual Basic [image] Copy Code

Public Function SelectNode( _
parentElement As XElement, _
name As String _
) As XElement

Parameters

parentElement

The parent XML element.

name

A string specifying the name of the child node.

Return Value

An XmlElement corresponding to the child node.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteBool Method

XmlSerializationContext.WriteBool Method
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteBool (
bool boolValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
boolValue As Boolean, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

boolValue

The bool value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteBrush Method

XmlSerializationContext.WriteBrush Method
[image]

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteBrush (
Brush brush,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrush( _
brush As Brush, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

brush

The Brush to serialize.

elementName

The name of the XML element.

parentElement

The parent of the XML element.

Return Value

The newly created System.Windows.Media.Brush object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteByte Method

XmlSerializationContext.WriteByte Method
[image]

Write a byte value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteByte (
byte byteValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
byteValue As Byte, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

byteValue

The byte value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteChar Method

XmlSerializationContext.WriteChar Method
[image]

Write a char value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteChar (
char charValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
charValue As Char, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

charValue

The char value to write.

elementName

The name of the element that presents the value to be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteColor Method

XmlSerializationContext.WriteColor Method
[image]

Writes the specified color.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteColor (
Color color,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

color

The color to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteColorArray Method

XmlSerializationContext.WriteColorArray Method
[image]

Writes the specified array of Color values.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColorArray( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

array

The array to write.

elementName

The name of the new element.

subElementName

The names of the subelements where the Color values will be written.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteDecimal Method

XmlSerializationContext.WriteDecimal Method
[image]

Write the decimal value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteDecimal (
decimal decimalValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
decimalValue As Decimal, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

decimalValue

The decimal value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteDouble Method

XmlSerializationContext.WriteDouble Method
[image]

Writes a double value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteDouble (
double doubleValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
doubleValue As Double, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

doubleValue

The double value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteDoubleArray Method

XmlSerializationContext.WriteDoubleArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteDoubleArray (
double[] array,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDoubleArray( _
array() As Double, _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

array

The array to write.

elementName

The name of the new element.

subElementName

The name of the sub-elements where the double values will be stored.

parentElement

The parent of the new node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteDoubleCollection Method

XmlSerializationContext.WriteDoubleCollection Method
[image]

Writes the specified DoubleCollection under the specified name with the specified parent.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteDoubleCollection (
DoubleCollection array,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDoubleCollection( _
array As DoubleCollection, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

array

The DoubleCollection to write.

elementName

The name of the element.

parentElement

The name of the parent.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteEffect Method

XmlSerializationContext.WriteEffect Method
[image]

Writes the specified System.Windows.Media.Effect under the specified name with the specified parent.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteEffect (
Effect effect,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEffect( _
effect As Effect, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

effect

The effect to write.

elementName

The name of the new XML element.

parentElement

The parent of the new XML element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteEnum Method

XmlSerializationContext.WriteEnum Method
[image]

Writes the specified enum value.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteEnum (
Object enumValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
enumValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

enumValue

The enum value to write.

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteFontStyle Method

XmlSerializationContext.WriteFontStyle Method
[image]

Writes a FontStyle object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteFontStyle (
Object fontValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontStyle( _
fontValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

fontValue

The object to write.

elementName

The name of the element to write.

parentElement

The parent of the element to write.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteFontWeight Method

XmlSerializationContext.WriteFontWeight Method
[image]

Writes a FontWeight object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteFontWeight (
Object fontValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontWeight( _
fontValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

fontValue

The FontWeight object to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteGradientStop Method

XmlSerializationContext.WriteGradientStop Method
[image]

Writes the specified GradientStop under the specified name with the specified parent.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteGradientStop (
GradientStop stop,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteGradientStop( _
stop As GradientStop, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stop

The GradientStop to write.

elementName

The name of the element.

parentElement

The name of the parent.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteGradientStopCollection Method

XmlSerializationContext.WriteGradientStopCollection Method
[image]

Writes the specified GradientStopCollection under the specified name with the specified parent.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteGradientStopCollection (
GradientStopCollection stops,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteGradientStopCollection( _
stops As GradientStopCollection, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stops

The GradientStopCollection to write.

elementName

The name of the element.

parentElement

The parent of the XML element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteInt Method

XmlSerializationContext.WriteInt Method
[image]

Writes an integer value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteInt (
int intValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
intValue As Integer, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

intValue

The integer value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteLong Method

XmlSerializationContext.WriteLong Method
[image]

Writes a long value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteLong (
long longValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
longValue As Long, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

longValue

The long value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WritePoint Method

XmlSerializationContext.WritePoint Method
[image]

Overload List

Name | Description
XmlSerializationContext.WritePoint (Double, Double, String, XElement) | Writes the specified PointF under the specified name. The x and y components of the point are written as attributes.
XmlSerializationContext.WritePoint (Point, String, XElement) | Writes a Point with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WritePoint Method (Double, Double, String, XElement)

XmlSerializationContext.WritePoint Method (Double, Double, String, XElement)
See Also
[image]

Writes the specified PointF under the specified name. The x and y components of the point are written as attributes.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WritePoint (
double x,
double y,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePoint( _
x As Double, _
y As Double, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

x

The X-value of the point to write.

y

The Y-value of the point to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

WritePoint Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WritePoint Method (Point, String, XElement)

XmlSerializationContext.WritePoint Method (Point, String, XElement)
See Also
[image]

Writes a Point with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WritePoint (
Point point,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePoint( _
point As Point, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

point

The .NET Point object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

WritePoint Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WritePointCollection Method

XmlSerializationContext.WritePointCollection Method
[image]

Writes the specified point collection.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WritePointCollection (
PointCollection points,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointCollection( _
points As PointCollection, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

points

The collection of points to write.

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteRectangle Method

XmlSerializationContext.WriteRectangle Method
[image]

Writes a RectangleF with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteRectangle (
Rect rectangle,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRectangle( _
rectangle As Rect, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

rectangle

The .NET Rect object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteSByte Method

XmlSerializationContext.WriteSByte Method
[image]

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteSByte (
sbyte byteValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
byteValue As SByte, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

byteValue

The signed byte value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteShort Method

XmlSerializationContext.WriteShort Method
[image]

Writes a short value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteShort (
short shortValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
shortValue As Short, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

shortValue

The short value to write.

elementName

The name of the element under which the value should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteSize Method

XmlSerializationContext.WriteSize Method
[image]

Writes a Size with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteSize (
Size size,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSize( _
size As Size, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

size

The .NET Size object to write.

elementName

The name of the element under which the object should be written.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteStream Method

XmlSerializationContext.WriteStream Method
[image]

Writes the specified stream.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteStream (
Stream stream,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStream( _
stream As Stream, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stream

The .NET System.IO.Stream object to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteString Method

XmlSerializationContext.WriteString Method
[image]

Writes a string value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteString (
string stringValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
stringValue As String, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stringValue

The string to write.

elementName

The name of the element to write.

parentElement

The parent of the element to write.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteUInt Method

XmlSerializationContext.WriteUInt Method
[image]

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteUInt (
uint uintValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
uintValue As UInteger, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

uintValue

The unsigned integer value to write.

elementName

The name of the new element.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteULong Method

XmlSerializationContext.WriteULong Method
[image]

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteULong (
ulong ulongValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
ulongValue As ULong, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

ulongValue

The unsigned long value to write.

elementName

The name of the new element.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteUShort Method

XmlSerializationContext.WriteUShort Method
[image]

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteUShort (
ushort ushortValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
ushortValue As UShort, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

ushortValue

The unsigned short value to write.

elementName

The name of the new element.

parentElement

The parent element of the newly created node.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteBrushList Method

XmlSerializationContext.WriteBrushList Method
[image]

Overload List

Name | Description
XmlSerializationContext.WriteBrushList (IList, String, XElement) | Writes the specified collection of brushes under the specified name with the specified parent.
XmlSerializationContext.WriteBrushList (BrushCollection, String, XElement) | Writes the specified collection of brushes under the specified name with the specified parent.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteBrushList Method (IList, String, XElement)

XmlSerializationContext.WriteBrushList Method (IList, String, XElement)
See Also
[image]

Writes the specified collection of brushes under the specified name with the specified parent.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteBrushList (
IList brushes,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrushList( _
brushes As IList, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

brushes

The brush collection to write.

elementName

The name of the element.

parentElement

The name of the parent.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

WriteBrushList Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteBrushList Method (BrushCollection, String, XElement)

XmlSerializationContext.WriteBrushList Method (BrushCollection, String, XElement)
See Also
[image]

Writes the specified collection of brushes under the specified name with the specified parent.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteBrushList (
BrushCollection brushes,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrushList( _
brushes As BrushCollection, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

brushes

The brush collection to write.

elementName

The name of the element.

parentElement

The name of the parent.

Return Value

The newly created element.

See Also

WriteBrushList Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteFontFamily Method

XmlSerializationContext.WriteFontFamily Method
[image]

Overload List

Name | Description
XmlSerializationContext.WriteFontFamily (FontFamily, String, XElement) | Writes a FontFamily object with the specified name.
XmlSerializationContext.WriteFontFamily (Object, String, XElement) | Writes a FontFamily object with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteFontFamily Method (FontFamily, String, XElement)

XmlSerializationContext.WriteFontFamily Method (FontFamily, String, XElement)
See Also
[image]

Writes a FontFamily object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteFontFamily (
FontFamily fontFamily,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontFamily( _
fontFamily As FontFamily, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

fontFamily

The FontFamily object to write.

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

WriteFontFamily Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteFontFamily Method (Object, String, XElement)

XmlSerializationContext.WriteFontFamily Method (Object, String, XElement)
See Also
[image]

Writes a FontFamily object with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteFontFamily (
Object fontFamily,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFontFamily( _
fontFamily As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

fontFamily

The FontFamily object to serialize.

elementName

The name of the element.

parentElement

The parent of the element.

Return Value

The newly created XElement.

See Also

WriteFontFamily Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteThickness Method

XmlSerializationContext.WriteThickness Method
[image]

Overload List

Name | Description
XmlSerializationContext.WriteThickness (Thickness, String, XElement) | Writes a Thickness with the specified name.
XmlSerializationContext.WriteThickness (Object, String, XElement) | Writes a Thickness with the specified name.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteThickness Method (Thickness, String, XElement)

XmlSerializationContext.WriteThickness Method (Thickness, String, XElement)
See Also
[image]

Writes a Thickness with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteThickness (
Thickness thickness,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteThickness( _
thickness As Thickness, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

thickness

The System.Windows.Thickness structure to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created System.Xml.Linq.XElement object.

See Also

WriteThickness Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.WriteThickness Method (Object, String, XElement)

XmlSerializationContext.WriteThickness Method (Object, String, XElement)
See Also
[image]

Writes a Thickness with the specified name.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement WriteThickness (
Object thickness,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteThickness( _
thickness As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

thickness

The System.Windows.Thickness structure to write.

elementName

The name of the new element.

parentElement

The parent of the new element.

Return Value

The newly created XElement.

See Also

WriteThickness Method Overload List
XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext Properties

XmlSerializationContext Properties
[image]

Public Properties

Name | Description
BaseURI | Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.
FileVersion | Gets the format revision number for the file being currently serialized.
XDocument | Gets the underlying XML document.
XElement | Gets the underlying XML document.

See Also

XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.BaseURI Property

XmlSerializationContext.BaseURI Property
[image]

Gets or sets the base URI of the XML document being loaded or saved. When not specified, the BaseURI of the underlying XmlDocument is used.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public string BaseURI { get; set; }

Visual Basic [image] Copy Code

Public Property BaseURI As String

Property Value

A string value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.FileVersion Property

XmlSerializationContext.FileVersion Property
[image]

Gets the format revision number for the file being currently serialized.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

An int value.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.XDocument Property

XmlSerializationContext.XDocument Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XDocument XDocument { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XDocument As XDocument

Property Value

An instance of the System.Xml.Linq.XDocument class.

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Charting.Silverlight.XmlSerializationContext.XElement Property

XmlSerializationContext.XElement Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Charting.Silverlight
Assembly: MindFusion.Charting.Silverlight

Syntax

C# [image] Copy Code

public XElement XElement { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XElement As XElement

Property Value

See Also

XmlSerializationContext Members
XmlSerializationContext Class


MindFusion.Gauges.Silverlight Namespace

MindFusion.Gauges.Silverlight Namespace
Classes Structures Delegates Enumerations

Classes

Class | Description
BaseScale | Represents a scale within a gauge control. The scale contains collections of pointers, labels, ticks and ranges along with any arbitrary controls.
Container | A special grid-derived container which provides ActualContainerWidth and ActualContainerHeight properties which can be bound to from within XAML.
CustomInterval | Represents an interval with associated custom values for fill, stroke and stroke thickness.
CustomIntervalCollection | Represents an observable collection of CustomInterval objects.
GaugeMouseEventArgs | Contains the arguments passed to mouse-related event handlers.
Indicator | Represents a gauge element, which changes its appearance based on its current state.
Led | A LED-like control with a glow effect. This control is suitable for gauge indicators.
LengthConverter | Represents a TypeConverter for Length objects.
LinearGauge | Represents a linear gauge control.
LinearScale | Represents a linear scale.
MajorTickSettings | Provides settings for the major ticks and labels in a gauge scale.
MiddleTickSettings | Provides settings for the middle ticks and labels in a gauge scale.
MinorTickSettings | Provides settings for the minor ticks and labels in a gauge scale.
OvalGauge | Represents a circular gauge control.
OvalScale | Represents a radial scale.
PercentConverter | Converts an amount of the specified converter parameter equal to the percentage specified by the source value.
Pointer | Represents a needle (or arrow) within a gauge scale.
QueryLabelValueEventArgs | Provides data for the QueryLabelValue event.
Range | Represents a range within a gauge scale.
ThicknessConverter | Converts Thickness values to double values.
TickSettings | Provides settings for the ticks and labels in a gauge scale.
ValueChangedEventArgs(T) | Contains the arguments passed to value change notification handlers.
VisibilityConverter | Converts boolean values to Visibility and vice versa.

Structures

Structure | Description
Length | Specifies distance expressed either absolutely, through pixels, or relatively, through a percentage of the container's size.

Delegates

Delegate | Description
FunctionDelegate | Represents a user-defined method, which performs custom distribution of values along the gauge scale.
ValueChangedEventHandler(T) | Represents the method that will handle value change notification events.

Enumerations

Enumeration | Description
Alignment | Indicates an alignment of an object relative to the scale. In the descriptions below 'outbound' refers to an element's outer outline, 'inbound' refers to an element's inner outline and 'center' refers to en element's center, that is, the middle of the inbound and outbound.
DisplayType | Specifies a display condition.
FunctionType | Indicates the type of function that will be used to distribute values along the gauge scale.
LabelRotation | Indicates the rotation of a label within a scale.
LengthType | Indicates the type of the units of a Length object.
TickShape | Indicates the shape of a scale tick.
TickType | Indicates the type of a scale tick.


MindFusion.Gauges.Silverlight.Alignment Enumeration

Alignment Enumeration
[image]

Indicates an alignment of an object relative to the scale. In the descriptions below 'outbound' refers to an element's outer outline, 'inbound' refers to an element's inner outline and 'center' refers to en element's center, that is, the middle of the inbound and outbound.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public enum Alignment

Visual Basic [image] Copy Code

Public Enum Alignment

Members

Member name | Description
CenterInside | Specifies that the outbound of an object is aligned with the center of the scale.
CenterOutside | Specifies that the inbound of an object is aligned with the center of the scale.
InnerCenter | Specifies that the center of an object is aligned with the inbound of the scale.
InnerInside | Specifies that the outbound of an object is aligned with the inbound of the scale.
InnerOutside | Specifies that the inbound of an object is aligned with the inbound of the scale.
OuterCenter | Specifies that the center of an object is aligned with the outbound of the scale.
OuterInside | Specifies that the outbound of an object is aligned with the outbound of the scale.
OuterOutside | Specifies that the inbound of an object is aligned with the outbound of the scale.
TrueCenter | Specifies that the center of an object is aligned with the center of the scale.

Remarks

The following scheme illustrates all possible alignment modes:

The pale blue lane at the background represents an oval scale, the orange line represents the center of the scale and the green objects are the elements being aligned to the scale using different alignment modes. The center of each element is illustrated in light green color. The alignment modes used for each of the elements in the scheme is specified below:

  1. InnerInside
  2. InnerCenter
  3. InnerOutside
  4. CenterInside
  5. TrueCenter
  6. CenterOutside
  7. OuterInside
  8. OuterCenter
  9. OuterOutside

The position of the aligned elements can be further adjusted through their offset. The offset of the different element types is specified through a different property. For example for Range objects, it is specified through the Offset property and for ticks and labels it is specified respectively by the TickOffset and LabelOffset properties of the corresponding TickSettings class.

See Also

MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale Class

BaseScale Class
[image]

Represents a scale within a gauge control. The scale contains collections of pointers, labels, ticks and ranges along with any arbitrary controls.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public abstract class BaseScale : ItemsControl

Visual Basic [image] Copy Code

Public MustInherit Class BaseScale
Inherits ItemsControl

Inheritance Hierarchy

MindFusion.Gauges.Silverlight.LinearScale
MindFusion.Gauges.Silverlight.OvalScale

See Also

BaseScale Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale Members

BaseScale Members
Constructors Fields Properties Methods Events
[image]

Represents a scale within a gauge control. The scale contains collections of pointers, labels, ticks and ranges along with any arbitrary controls.

The following tables list the members exposed by the BaseScale type.

Protected Constructors

Name | Description
BaseScale | Initializes a new instance of the BaseScale class.

Public Fields

Name | Description
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property.
EnableAnimationProperty | Identifies the EnableAnimation dependency property.
EndWidthProperty | Identifies the EndWidth dependency property.
FillProperty | Identifies the Fill dependency property.
FunctionArgumentProperty | Identifies the FunctionArgument dependency property.
FunctionTypeProperty | Identifies the FunctionType dependency property.
LogarithmBaseProperty | Identifies the LogarithmBase dependency property.
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property.
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property.
MinValueProperty | Identifies the MinValue dependency property.
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property.
PointerAnimationSpeedRatioProperty | Identifies the PointerAnimationSpeedRatio dependency property.
PointersProperty | Identifies the Pointers dependency property.
RangesProperty | Identifies the Ranges dependency property.
StartWidthProperty | Identifies the StartWidth dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

Public Properties

Name | Description
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom.
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property.
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property.
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property.
Fill | Gets or sets the brush used to fill the scale. This is a dependency property.
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property.
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property.
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property.
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property.
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property.
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property.
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property.
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property.
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property.
PointerAnimationSpeedRatio | Gets or sets the speed ratio of the animation of animated pointers. This is a dependency property.
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property.
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property.
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction.
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property.
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property.

Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override.
EndInit | ItemsControl.EndInit override.
GetValueFromPoint | Returns the value corresponding to the specified point.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
MeasureOverride | Control.MeasureOverride override.
OnMouseLeftButtonDown | UIElement.OnMouseDown override.
OnMouseLeftButtonUp | UIElement.OnMouseUp override.
OnMouseMove | UIElement.OnMouseMove override.
OnPointerClicked | Raises the PointerClicked event.
OnQueryLabelValue | Raises the QueryLabelValue event.
OnRangeClicked | Raises the RangeClicked event.
OnRender | UIElement.OnRender override.
OnScaleClicked | Raises the ScaleClicked event.
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event.

Public Events

Name | Description
PointerClicked | Occurs when a pointer within the scale is clicked with the mouse.
QueryLabelValue | Occurs when the labels in the scale are being generated in order to associate custom values with them.
RangeClicked | Occurs when a range within the scale is clicked with the mouse.
ScaleClicked | Occurs when the scale is clicked with the mouse.
ScaleGeometryClicked | Occurs when the scale geometry is clicked with the mouse.

See Also

BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale Fields

BaseScale Fields
[image]

Public Fields

Name | Description
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property.
EnableAnimationProperty | Identifies the EnableAnimation dependency property.
EndWidthProperty | Identifies the EndWidth dependency property.
FillProperty | Identifies the Fill dependency property.
FunctionArgumentProperty | Identifies the FunctionArgument dependency property.
FunctionTypeProperty | Identifies the FunctionType dependency property.
LogarithmBaseProperty | Identifies the LogarithmBase dependency property.
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property.
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property.
MinValueProperty | Identifies the MinValue dependency property.
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property.
PointerAnimationSpeedRatioProperty | Identifies the PointerAnimationSpeedRatio dependency property.
PointersProperty | Identifies the Pointers dependency property.
RangesProperty | Identifies the Ranges dependency property.
StartWidthProperty | Identifies the StartWidth dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

See Also

BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.DefaultPointerStyleProperty Field

BaseScale.DefaultPointerStyleProperty Field
[image]

Identifies the DefaultPointerStyle dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DefaultPointerStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DefaultPointerStyleProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.EnableAnimationProperty Field

BaseScale.EnableAnimationProperty Field
[image]

Identifies the EnableAnimation dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EnableAnimationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EnableAnimationProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.EndWidthProperty Field

BaseScale.EndWidthProperty Field
[image]

Identifies the EndWidth dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndWidthProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.FillProperty Field

BaseScale.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.FunctionArgumentProperty Field

BaseScale.FunctionArgumentProperty Field
[image]

Identifies the FunctionArgument dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FunctionArgumentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FunctionArgumentProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.FunctionTypeProperty Field

BaseScale.FunctionTypeProperty Field
[image]

Identifies the FunctionType dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FunctionTypeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FunctionTypeProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.LogarithmBaseProperty Field

BaseScale.LogarithmBaseProperty Field
[image]

Identifies the LogarithmBase dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LogarithmBaseProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LogarithmBaseProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.MajorTickSettingsProperty Field

BaseScale.MajorTickSettingsProperty Field
[image]

Identifies the MajorTickSettings dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MajorTickSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MajorTickSettingsProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.MaxValueProperty Field

BaseScale.MaxValueProperty Field
[image]

Identifies the MaxValue dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxValueProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.MiddleTickSettingsProperty Field

BaseScale.MiddleTickSettingsProperty Field
[image]

Identifies the MiddleTickSettings dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MiddleTickSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MiddleTickSettingsProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.MinorTickSettingsProperty Field

BaseScale.MinorTickSettingsProperty Field
[image]

Identifies the MinorTickSettings dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinorTickSettingsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinorTickSettingsProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.MinValueProperty Field

BaseScale.MinValueProperty Field
[image]

Identifies the MinValue dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinValueProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.PointerAnimationDurationProperty Field

BaseScale.PointerAnimationDurationProperty Field
[image]

Identifies the PointerAnimationDuration dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerAnimationDurationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerAnimationDurationProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.PointerAnimationSpeedRatioProperty Field

BaseScale.PointerAnimationSpeedRatioProperty Field
[image]

Identifies the PointerAnimationSpeedRatio dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerAnimationSpeedRatioProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerAnimationSpeedRatioProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.PointersProperty Field

BaseScale.PointersProperty Field
[image]

Identifies the Pointers dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointersProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointersProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.RangesProperty Field

BaseScale.RangesProperty Field
[image]

Identifies the Ranges dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty RangesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly RangesProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.StartWidthProperty Field

BaseScale.StartWidthProperty Field
[image]

Identifies the StartWidth dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartWidthProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.StrokeProperty Field

BaseScale.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.StrokeThicknessProperty Field

BaseScale.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale Constructor

BaseScale Constructor
[image]

Initializes a new instance of the BaseScale class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected BaseScale ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale Methods

BaseScale Methods
[image]

Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override.
EndInit | ItemsControl.EndInit override.
GetValueFromPoint | Returns the value corresponding to the specified point.
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
MeasureOverride | Control.MeasureOverride override.
OnMouseLeftButtonDown | UIElement.OnMouseDown override.
OnMouseLeftButtonUp | UIElement.OnMouseUp override.
OnMouseMove | UIElement.OnMouseMove override.
OnPointerClicked | Raises the PointerClicked event.
OnQueryLabelValue | Raises the QueryLabelValue event.
OnRangeClicked | Raises the RangeClicked event.
OnRender | UIElement.OnRender override.
OnScaleClicked | Raises the ScaleClicked event.
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event.

See Also

BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.ArrangeOverride Method

BaseScale.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual Size ArrangeOverride (
Size arrangeBounds
)

Visual Basic [image] Copy Code

Protected Overridable Function ArrangeOverride( _
arrangeBounds As Size _
) As Size

Parameters

arrangeBounds

The computed size that is used to arrange the content.

Return Value

The size of the control.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.BeginInit Method

BaseScale.BeginInit Method
[image]

ItemsControl.BeginInit override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override void BeginInit ()

Visual Basic [image] Copy Code

Public Overrides Sub BeginInit ()

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.EndInit Method

BaseScale.EndInit Method
[image]

ItemsControl.EndInit override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override void EndInit ()

Visual Basic [image] Copy Code

Public Overrides Sub EndInit ()

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.GetValueFromPoint Method

BaseScale.GetValueFromPoint Method
[image]

Returns the value corresponding to the specified point.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public abstract double GetValueFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public MustOverride Function GetValueFromPoint( _
point As Point _
) As Double

Parameters

point

The point to test.

Return Value

The value from the scale, corresponding to the point, possibly MinValue or MaxValue if the specified point cannot be associated with a value.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.MeasureOverride Method

BaseScale.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.OnApplyTemplate Method

BaseScale.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.OnMouseLeftButtonDown Method

BaseScale.OnMouseLeftButtonDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.OnMouseLeftButtonUp Method

BaseScale.OnMouseLeftButtonUp Method
[image]

UIElement.OnMouseUp override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e

The System.Windows.Input.MouseButtonEventArgs that contains the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.OnMouseMove Method

BaseScale.OnMouseMove Method
[image]

UIElement.OnMouseMove override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

The System.Windows.Input.MouseEventArgs that contains the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.OnPointerClicked Method

BaseScale.OnPointerClicked Method
[image]

Raises the PointerClicked event.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnPointerClicked (
GaugeMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPointerClicked ( _
e As GaugeMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.OnQueryLabelValue Method

BaseScale.OnQueryLabelValue Method
[image]

Raises the QueryLabelValue event.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnQueryLabelValue (
QueryLabelValueEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnQueryLabelValue ( _
e As QueryLabelValueEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.OnRangeClicked Method

BaseScale.OnRangeClicked Method
[image]

Raises the RangeClicked event.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnRangeClicked (
GaugeMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRangeClicked ( _
e As GaugeMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.OnRender Method

BaseScale.OnRender Method
[image]

UIElement.OnRender override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnRender (
DrawingContext drawingContext
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRender( _
drawingContext As DrawingContext _
)

Parameters

drawingContext

The drawing instructions for a specific element. This context is provided to the layout system.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.OnScaleClicked Method

BaseScale.OnScaleClicked Method
[image]

Raises the ScaleClicked event.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnScaleClicked (
GaugeMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnScaleClicked ( _
e As GaugeMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.OnScaleGeometryClicked Method

BaseScale.OnScaleGeometryClicked Method
[image]

Raises the ScaleGeometryClicked event.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnScaleGeometryClicked (
GaugeMouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnScaleGeometryClicked ( _
e As GaugeMouseEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale Properties

BaseScale Properties
[image]

Public Properties

Name | Description
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom.
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property.
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property.
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property.
Fill | Gets or sets the brush used to fill the scale. This is a dependency property.
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property.
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property.
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property.
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property.
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property.
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property.
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property.
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property.
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property.
PointerAnimationSpeedRatio | Gets or sets the speed ratio of the animation of animated pointers. This is a dependency property.
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property.
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property.
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction.
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property.
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property.
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property.

See Also

BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.CustomFunction Property

BaseScale.CustomFunction Property
[image]

Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public FunctionDelegate CustomFunction { get; set; }

Visual Basic [image] Copy Code

Public Property CustomFunction As FunctionDelegate

Property Value

A FunctionDelegate, which will be invoked when a value needs to be displayed on the scale.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
ReversedCustomFunction Property
FunctionType Property


MindFusion.Gauges.Silverlight.BaseScale.DefaultPointerStyle Property

BaseScale.DefaultPointerStyle Property
[image]

Gets or sets the default style for pointers in this scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Style DefaultPointerStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultPointerStyle As Style

Property Value

A Silverlight Style instance.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.EnableAnimation Property

BaseScale.EnableAnimation Property
[image]

Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public bool EnableAnimation { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAnimation As Boolean

Property Value

true, to enable animations; otherwise, false.

Remarks

This property is useful to temporarily disable animations - during initialization phases for example. Animations are always disabled in design-time.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.EndWidth Property

BaseScale.EndWidth Property
[image]

Gets or sets the width of the scale bar at its end. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length EndWidth { get; set; }

Visual Basic [image] Copy Code

Public Property EndWidth As Length

Property Value

An instance of the Length structure.

Remarks

This property, in conjunction with StartWidth, define the thickness of the scale.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
StartWidth Property


MindFusion.Gauges.Silverlight.BaseScale.Fill Property

BaseScale.Fill Property
[image]

Gets or sets the brush used to fill the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

A .NET Brush object.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
Stroke Property
StrokeThickness Property


MindFusion.Gauges.Silverlight.BaseScale.FunctionArgument Property

BaseScale.FunctionArgument Property
[image]

Gets or sets the argument passed to custom functions. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double FunctionArgument { get; set; }

Visual Basic [image] Copy Code

Public Property FunctionArgument As Double

Property Value

A double value.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.FunctionType Property

BaseScale.FunctionType Property
[image]

The type of the function used to calculate the distribution of values along the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public FunctionType FunctionType { get; set; }

Visual Basic [image] Copy Code

Public Property FunctionType As FunctionType

Property Value

A member of the FunctionType enumeration.

Remarks

When the value of this property is set to Custom, the distribution of values along the scale is defined by the CustomFunction property.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
FunctionArgument Property
CustomFunction Property


MindFusion.Gauges.Silverlight.BaseScale.LogarithmBase Property

BaseScale.LogarithmBase Property
[image]

Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double LogarithmBase { get; set; }

Visual Basic [image] Copy Code

Public Property LogarithmBase As Double

Property Value

A double value specifying the base of logarithmic scales.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
FunctionType Property


MindFusion.Gauges.Silverlight.BaseScale.MajorTickSettings Property

BaseScale.MajorTickSettings Property
[image]

Gets or sets the settings for the major ticks and their associated labels. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public MajorTickSettings MajorTickSettings { get; set; }

Visual Basic [image] Copy Code

Public Property MajorTickSettings As MajorTickSettings

Property Value

An instance of the MajorTickSettings class.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
MiddleTickSettings Property
MinorTickSettings Property


MindFusion.Gauges.Silverlight.BaseScale.MaxValue Property

BaseScale.MaxValue Property
[image]

Gets or sets the maximal value displayed by the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

A double value.

Remarks

If MaxValue is less than MinValue, the direction of the scale is automatically reversed.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
MinValue Property


MindFusion.Gauges.Silverlight.BaseScale.MiddleTickSettings Property

BaseScale.MiddleTickSettings Property
[image]

Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public MiddleTickSettings MiddleTickSettings { get; set; }

Visual Basic [image] Copy Code

Public Property MiddleTickSettings As MiddleTickSettings

Property Value

An instance of the MiddleTickSettings class.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
MajorTickSettings Property
MinorTickSettings Property


MindFusion.Gauges.Silverlight.BaseScale.MinorTickSettings Property

BaseScale.MinorTickSettings Property
[image]

Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public MinorTickSettings MinorTickSettings { get; set; }

Visual Basic [image] Copy Code

Public Property MinorTickSettings As MinorTickSettings

Property Value

An instance of the MinorTickSettings class.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
MajorTickSettings Property
MinorTickSettings Property


MindFusion.Gauges.Silverlight.BaseScale.MinValue Property

BaseScale.MinValue Property
[image]

Gets or sets the minimal value displayed by the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

A double value.

Remarks

If MaxValue is less than MinValue, the direction of the scale is automatically reversed.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.PointerAnimationDuration Property

BaseScale.PointerAnimationDuration Property
[image]

Gets or sets the duration of the animation of animated pointers. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public TimeSpan PointerAnimationDuration { get; set; }

Visual Basic [image] Copy Code

Public Property PointerAnimationDuration As TimeSpan

Property Value

A .NET TimeSpan object.

Remarks

The value of this property is assigned to the Duration property of the Timeline objects used to animate pointers.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
PointerAnimationDecelerationRatio Property
EnableAnimation Property


MindFusion.Gauges.Silverlight.BaseScale.PointerAnimationSpeedRatio Property

BaseScale.PointerAnimationSpeedRatio Property
[image]

Gets or sets the speed ratio of the animation of animated pointers. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double PointerAnimationSpeedRatio { get; set; }

Visual Basic [image] Copy Code

Public Property PointerAnimationSpeedRatio As Double

Property Value

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.Pointers Property

BaseScale.Pointers Property
[image]

Gets or sets a collection with the pointers displayed in the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public ObservableCollection<Pointer> Pointers { get; set; }

Visual Basic [image] Copy Code

Public Property Pointers As ObservableCollection(Of Pointer)

Property Value

An observable collection of Pointer objects.

Example

The following XAML code defines an OvalScale with a single pointer in it. The gauges XAML namespace is defined as http://mindfusion.eu/gauges/.

XAML [image] Copy Code

<gauges:OvalScale>
<gauges:OvalScale.Pointers>
<gauges:Pointer />
</gauges:OvalScale.Pointers>
</gauges:OvalScale>

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.Ranges Property

BaseScale.Ranges Property
[image]

Gets or sets a collection with the ranges displayed in the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public ObservableCollection<Range> Ranges { get; set; }

Visual Basic [image] Copy Code

Public Property Ranges As ObservableCollection(Of Range)

Property Value

An observable collection of Range objects.

Remarks

The following XAML code defines an OvalScale with a single range in it. The gauges XAML namespace is defined as http://mindfusion.eu/gauges/.

XAML [image] Copy Code

<gauges:OvalScale>
<gauges:OvalScale.Ranges>
<gauges:Range MinValue="20" MaxValue="50" Fill="Red" />
</gauges:OvalScale.Ranges>
</gauges:OvalScale>

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.ReversedCustomFunction Property

BaseScale.ReversedCustomFunction Property
[image]

Gets or sets the reversed version of the function specified through CustomFunction.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public FunctionDelegate ReversedCustomFunction { get; set; }

Visual Basic [image] Copy Code

Public Property ReversedCustomFunction As FunctionDelegate

Property Value

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.StartWidth Property

BaseScale.StartWidth Property
[image]

Gets or sets the width of the scale bar at its beginning. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length StartWidth { get; set; }

Visual Basic [image] Copy Code

Public Property StartWidth As Length

Property Value

An instance of the Length structure.

Remarks

This property, in conjunction with StartWidth, define the thickness of the scale.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
EndWidth Property


MindFusion.Gauges.Silverlight.BaseScale.Stroke Property

BaseScale.Stroke Property
[image]

Gets or sets the brush used to stroke the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A .NET Brush object.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
StrokeThickness Property
Fill Property


MindFusion.Gauges.Silverlight.BaseScale.StrokeThickness Property

BaseScale.StrokeThickness Property
[image]

Gets or sets the thickness of the scale stroke. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace
Stroke Property
Fill Property


MindFusion.Gauges.Silverlight.BaseScale Events

BaseScale Events
[image]

Public Events

Name | Description
PointerClicked | Occurs when a pointer within the scale is clicked with the mouse.
QueryLabelValue | Occurs when the labels in the scale are being generated in order to associate custom values with them.
RangeClicked | Occurs when a range within the scale is clicked with the mouse.
ScaleClicked | Occurs when the scale is clicked with the mouse.
ScaleGeometryClicked | Occurs when the scale geometry is clicked with the mouse.

See Also

BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.PointerClicked Event

BaseScale.PointerClicked Event
[image]

Occurs when a pointer within the scale is clicked with the mouse.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<GaugeMouseEventArgs> PointerClicked

Visual Basic [image] Copy Code

Public Event PointerClicked As EventHandler(Of GaugeMouseEventArgs)

Event Data

PointerClicked event handlers receive an argument of type GaugeMouseEventArgs.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.QueryLabelValue Event

BaseScale.QueryLabelValue Event
[image]

Occurs when the labels in the scale are being generated in order to associate custom values with them.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<QueryLabelValueEventArgs> QueryLabelValue

Visual Basic [image] Copy Code

Public Event QueryLabelValue As EventHandler(Of QueryLabelValueEventArgs)

Event Data

QueryLabelValue event handlers receive an argument of type QueryLabelValueEventArgs.

Remarks

This event is raised in order to allow clients to customize the texts of tick labels beyond simple formatting.

Example

The following example illustrates a QueryLabelValue event handler which customizes the labels of a scale to display "Empty" as min value and "Full" as max value:

C# [image] Copy Code

private void OnQueryLabelValue(object sender, QueryLabelValueEventArgs e)
{
var baseScale = sender as BaseScale;
if (e.Settings.TickType == TickType.Major)
{
if (e.CalculatedLabelValue == baseScale.MinValue)
e.NewValue = "Empty";
if (e.CalculatedLabelValue == baseScale.MaxValue)
e.NewValue = "Full";
}
}

Visual Basic [image] Copy Code

Private Sub OnQueryLabelValue(ByVal sender As System.Object, ByVal e As QueryLabelValueEventArgs)

Dim baseScale = CType(sender, BaseScale)
If (e.Settings.TickType = TickType.Major) Then

If (e.CalculatedLabelValue = baseScale.MinValue) Then
e.NewValue = "Empty"
End If
If (e.CalculatedLabelValue = baseScale.MaxValue) Then
e.NewValue = "Full"
End If

End If

End Sub

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.RangeClicked Event

BaseScale.RangeClicked Event
[image]

Occurs when a range within the scale is clicked with the mouse.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<GaugeMouseEventArgs> RangeClicked

Visual Basic [image] Copy Code

Public Event RangeClicked As EventHandler(Of GaugeMouseEventArgs)

Event Data

RangeClicked event handlers receive an argument of type GaugeMouseEventArgs.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.ScaleClicked Event

BaseScale.ScaleClicked Event
[image]

Occurs when the scale is clicked with the mouse.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<GaugeMouseEventArgs> ScaleClicked

Visual Basic [image] Copy Code

Public Event ScaleClicked As EventHandler(Of GaugeMouseEventArgs)

Event Data

ScaleClicked event handlers receive an argument of type GaugeMouseEventArgs.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.BaseScale.ScaleGeometryClicked Event

BaseScale.ScaleGeometryClicked Event
[image]

Occurs when the scale geometry is clicked with the mouse.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public event EventHandler<GaugeMouseEventArgs> ScaleGeometryClicked

Visual Basic [image] Copy Code

Public Event ScaleGeometryClicked As EventHandler(Of GaugeMouseEventArgs)

Event Data

ScaleGeometryClicked event handlers receive an argument of type GaugeMouseEventArgs.

Remarks

This event will be raised only when the path geometry representing the scale is clicked. Therefore, if the scale is very thin or transparent, this event will not be raised. In this case the more general ScaleClicked event should be used.

See Also

BaseScale Members
BaseScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Container Class

Container Class
[image]

A special grid-derived container which provides ActualContainerWidth and ActualContainerHeight properties which can be bound to from within XAML.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class Container : Grid

Visual Basic [image] Copy Code

Public Class Container
Inherits Grid

Inheritance Hierarchy

System.Object
System.Windows.DependencyObject
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Panel
System.Windows.Controls.Grid
MindFusion.Gauges.Silverlight.Container

See Also

Container Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Container Members

Container Members
Constructors Fields Properties
[image]

A special grid-derived container which provides ActualContainerWidth and ActualContainerHeight properties which can be bound to from within XAML.

The following tables list the members exposed by the Container type.

Public Constructors

Name | Description
Container | Initializes a new instance of the Container class.

Public Fields

Name | Description
ActualContainerHeightProperty | Identifies the ActualContainerHeight dependency property.
ActualContainerWidthProperty | Identifies the ActualContainerWidth dependency property.

Public Properties

Name | Description
ActualContainerHeight | Gets the actual height of the container. This is a dependency property.
ActualContainerWidth | Gets the actual width of the container. This is a dependency property.

See Also

Container Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Container Fields

Container Fields
[image]

Public Fields

Name | Description
ActualContainerHeightProperty | Identifies the ActualContainerHeight dependency property.
ActualContainerWidthProperty | Identifies the ActualContainerWidth dependency property.

See Also

Container Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Container.ActualContainerHeightProperty Field

Container.ActualContainerHeightProperty Field
[image]

Identifies the ActualContainerHeight dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActualContainerHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActualContainerHeightProperty As DependencyProperty

See Also

Container Members
Container Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Container.ActualContainerWidthProperty Field

Container.ActualContainerWidthProperty Field
[image]

Identifies the ActualContainerWidth dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActualContainerWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActualContainerWidthProperty As DependencyProperty

See Also

Container Members
Container Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Container Constructor

Container Constructor
[image]

Initializes a new instance of the Container class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Container ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Container Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Container Properties

Container Properties
[image]

Public Properties

Name | Description
ActualContainerHeight | Gets the actual height of the container. This is a dependency property.
ActualContainerWidth | Gets the actual width of the container. This is a dependency property.

See Also

Container Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Container.ActualContainerHeight Property

Container.ActualContainerHeight Property
[image]

Gets the actual height of the container. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double ActualContainerHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ActualContainerHeight As Double

Property Value

Remarks

This property can be bound to from within XAML because binding directly to FrameworkElement.ActualHeight seems to fail.

See Also

Container Members
Container Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Container.ActualContainerWidth Property

Container.ActualContainerWidth Property
[image]

Gets the actual width of the container. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double ActualContainerWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ActualContainerWidth As Double

Property Value

Remarks

This property can be bound to from within XAML because binding directly to FrameworkElement.ActualWidth seems to fail.

See Also

Container Members
Container Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval Class

CustomInterval Class
Remarks See Also
[image]

Represents an interval with associated custom values for fill, stroke and stroke thickness.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class CustomInterval : DependencyObject, INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class CustomInterval
Inherits DependencyObject
Implements INotifyPropertyChanged

Remarks

The custom interval is defined by its MinValue and MaxValue properties. The property values provided by the custom interval to the elements within it are Fill, Stroke and StrokeThickness. Certain custom interval containers associate additional properties with the custom intervals through the use of attached properties. For example the Indicator class provides an ActiveColor property which is used for the glow effect of the indicator.

Example

The following XAML code defines a custom interval, which sets the background of all elements in the range [10..20] it to Red.

XAML [image] Copy Code

<g:CustomInterval MinValue="15" MaxValue="20" Fill="Red" />

Inheritance Hierarchy

See Also

CustomInterval Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval Members

CustomInterval Members
Constructors Fields Properties Methods Events
[image]

Represents an interval with associated custom values for fill, stroke and stroke thickness.

The following tables list the members exposed by the CustomInterval type.

Public Constructors

Name | Description
CustomInterval | Initializes a new instance of the CustomInterval class.

Public Fields

Name | Description
FillProperty | Identifies the Fill dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

Public Properties

Name | Description
Fill | Gets or sets the brush to apply as a background of the elements within the custom interval. This is a dependency property.
MaxValue | Gets or sets the end of this custom interval. This is a dependency property.
MinValue | Gets or sets the start of this custom interval. This is a dependency property.
Stroke | Gets or sets the brush to apply as an outline of the elements within the custom interval. This is a dependency property.
StrokeThickness | Gets or sets the outline thickness of the elements within the custom interval. This is a dependency property.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
PropertyChanged | Occurs when a property of the interval changes.

See Also

CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval Fields

CustomInterval Fields
[image]

Public Fields

Name | Description
FillProperty | Identifies the Fill dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

See Also

CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval.FillProperty Field

CustomInterval.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval.MaxValueProperty Field

CustomInterval.MaxValueProperty Field
[image]

Identifies the MaxValue dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxValueProperty As DependencyProperty

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval.MinValueProperty Field

CustomInterval.MinValueProperty Field
[image]

Identifies the MinValue dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinValueProperty As DependencyProperty

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval.StrokeProperty Field

CustomInterval.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval.StrokeThicknessProperty Field

CustomInterval.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval Constructor

CustomInterval Constructor
[image]

Initializes a new instance of the CustomInterval class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public CustomInterval ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval Methods

CustomInterval Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval.OnPropertyChanged Method

CustomInterval.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
PropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As PropertyChangedEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval Properties

CustomInterval Properties
[image]

Public Properties

Name | Description
Fill | Gets or sets the brush to apply as a background of the elements within the custom interval. This is a dependency property.
MaxValue | Gets or sets the end of this custom interval. This is a dependency property.
MinValue | Gets or sets the start of this custom interval. This is a dependency property.
Stroke | Gets or sets the brush to apply as an outline of the elements within the custom interval. This is a dependency property.
StrokeThickness | Gets or sets the outline thickness of the elements within the custom interval. This is a dependency property.

See Also

CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval.Fill Property

CustomInterval.Fill Property
[image]

Gets or sets the brush to apply as a background of the elements within the custom interval. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

A .NET Brush object.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace
Stroke Property
StrokeThickness Property


MindFusion.Gauges.Silverlight.CustomInterval.MaxValue Property

CustomInterval.MaxValue Property
[image]

Gets or sets the end of this custom interval. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

A double value.

Remarks

If this property is not set, positive infinity will be considered as the end of the interval.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace
MinValue Property


MindFusion.Gauges.Silverlight.CustomInterval.MinValue Property

CustomInterval.MinValue Property
[image]

Gets or sets the start of this custom interval. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

A double value.

Remarks

If this property is not set, negative infinity will be considered as the start of the interval.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace
MaxValue Property


MindFusion.Gauges.Silverlight.CustomInterval.Stroke Property

CustomInterval.Stroke Property
[image]

Gets or sets the brush to apply as an outline of the elements within the custom interval. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A .NET Brush object.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace
StrokeThickness Property
Fill Property


MindFusion.Gauges.Silverlight.CustomInterval.StrokeThickness Property

CustomInterval.StrokeThickness Property
[image]

Gets or sets the outline thickness of the elements within the custom interval. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value.

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace
Stroke Property
Fill Property


MindFusion.Gauges.Silverlight.CustomInterval Events

CustomInterval Events
[image]

Public Events

Name | Description
PropertyChanged | Occurs when a property of the interval changes.

See Also

CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomInterval.PropertyChanged Event

CustomInterval.PropertyChanged Event
[image]

Occurs when a property of the interval changes.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

CustomInterval Members
CustomInterval Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomIntervalCollection Class

CustomIntervalCollection Class
[image]

Represents an observable collection of CustomInterval objects.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class CustomIntervalCollection : ObservableCollection<CustomInterval>

Visual Basic [image] Copy Code

Public Class CustomIntervalCollection
Inherits ObservableCollection(Of CustomInterval)

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(CustomInterval)
System.Collections.ObjectModel.ObservableCollection(CustomInterval)
MindFusion.Gauges.Silverlight.CustomIntervalCollection

See Also

CustomIntervalCollection Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomIntervalCollection Members

CustomIntervalCollection Members
Constructors
[image]

Represents an observable collection of CustomInterval objects.

The following tables list the members exposed by the CustomIntervalCollection type.

Public Constructors

Name | Description
CustomIntervalCollection |

See Also

CustomIntervalCollection Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.CustomIntervalCollection Constructor

CustomIntervalCollection Constructor
[image]

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public CustomIntervalCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CustomIntervalCollection Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.DisplayType Enumeration

DisplayType Enumeration
[image]

Specifies a display condition.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public enum DisplayType

Visual Basic [image] Copy Code

Public Enum DisplayType

Members

Member name | Description
Always | Indicates that the the element should always be displayed.
Auto | Indicates that the visibility of an element should be determined automatically.
Never | Indicates that the the element should always be hidden.

Remarks

Members of this enumeration are used as values of the ShowMaxValueTick property.

See Also

MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.FunctionDelegate Delegate

FunctionDelegate Delegate
[image]

Represents a user-defined method, which performs custom distribution of values along the gauge scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public delegate double FunctionDelegate (
double value,
double argument
)

Visual Basic [image] Copy Code

Public Delegate Function FunctionDelegate( _
value As Double, _
argument As Double _
) As Double

Parameters

value

The source parameter value.

argument
An optional argument passed to the function. This is the value of the FunctionArgument property of the BaseScale class.

Return Value

The function result, which will be displayed on the scale.

See Also

MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.FunctionType Enumeration

FunctionType Enumeration
[image]

Indicates the type of function that will be used to distribute values along the gauge scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public enum FunctionType

Visual Basic [image] Copy Code

Public Enum FunctionType

Members

Member name | Description
Custom | Specifies a user defined function, which will be supplied by the CustomFunction property.
Linear | Specifies that the values will be distributed linearly.
Logarithmic | Specifies a logarithmic function with base specified by the LogarithmBase property.

See Also

MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.GaugeMouseEventArgs Class

GaugeMouseEventArgs Class
[image]

Contains the arguments passed to mouse-related event handlers.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class GaugeMouseEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class GaugeMouseEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Gauges.Silverlight.GaugeMouseEventArgs

See Also

GaugeMouseEventArgs Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.GaugeMouseEventArgs Members

GaugeMouseEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to mouse-related event handlers.

The following tables list the members exposed by the GaugeMouseEventArgs type.

Public Constructors

Name | Description
GaugeMouseEventArgs |

Public Properties

Name | Description
Element | Gets a reference to the clicked gauge element, if any.
Position | Gets the position of the mouse relative to the clicked element.
Value | Get the gauge value corresponding to the clicked point.

See Also

GaugeMouseEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.GaugeMouseEventArgs Constructor (Control, Point, Double)

GaugeMouseEventArgs Constructor (Control, Point, Double)
See Also
[image]

Initializes a new instance of the GaugeMouseEventArgs class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public GaugeMouseEventArgs (
Control element,
Point position,
double value
)

Visual Basic [image] Copy Code

Public New ( _
element As Control, _
position As Point, _
value As Double _
)

Parameters

element

The clicked gauge element, if any.

position

The position of the mouse relative to the clicked element.

value

The gauge value corresponding to the clicked point.

See Also

GaugeMouseEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.GaugeMouseEventArgs Properties

GaugeMouseEventArgs Properties
[image]

Public Properties

Name | Description
Element | Gets a reference to the clicked gauge element, if any.
Position | Gets the position of the mouse relative to the clicked element.
Value | Get the gauge value corresponding to the clicked point.

See Also

GaugeMouseEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.GaugeMouseEventArgs.Element Property

GaugeMouseEventArgs.Element Property
[image]

Gets a reference to the clicked gauge element, if any.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Control Element { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Element As Control

Property Value

A reference to the clicked element, or null (Nothing in Visual Basic) if the property value is not relevant.

See Also

GaugeMouseEventArgs Members
GaugeMouseEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.GaugeMouseEventArgs.Position Property

GaugeMouseEventArgs.Position Property
[image]

Gets the position of the mouse relative to the clicked element.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

A .NET Point object.

See Also

GaugeMouseEventArgs Members
GaugeMouseEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.GaugeMouseEventArgs.Value Property

GaugeMouseEventArgs.Value Property
[image]

Get the gauge value corresponding to the clicked point.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double Value { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Value As Double

Property Value

A double value.

See Also

GaugeMouseEventArgs Members
GaugeMouseEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator Class

Indicator Class
Remarks See Also
[image]

Represents a gauge element, which changes its appearance based on its current state.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class Indicator : Control

Visual Basic [image] Copy Code

Public Class Indicator
Inherits Control

Remarks

The indicator is a gauge element, which changes its appearance based on its Value property and its defined states. The states of the indicator are specified as CustomInterval objects and are located in the States collection. When the value of the indicator falls within one of its defined states, this state becomes active and its Fill, Stroke and StrokeThickness properties are applied to the indicator automatically. In addition, the attached property ActiveColor is applied as a glow color of the indicator. If the value of the indicator does not fall in any of the defined states, then the DefaultState becomes active.

A common scenario is to bind the Value property of the indicator to the Value of a Pointer object, thus when the value of the pointer is modified, the state of the indicator changes to reflect this.

Example

Indicators can be embedded within a scale. The following XAML code illustrates a LinearGauge with an indicator embedded in it. The indicator defines a single state, which paints the indicator in a green color.

XAML [image] Copy Code

<gauges:LinearScale Orientation="Vertical">
<gauges:Indicator VerticalAlignment="Center" HorizontalAlignment="Left" Margin="10,0,0,0" Width="20" Height="20">
<gauges:Indicator.States>
<gauges:CustomInterval MinValue="0" MaxValue="25" Fill="Green" gauges:Indicator.ActiveColor="Green" />
</gauges:Indicator.States>
</gauges:Indicator>
</gauges:LinearScale>

Inheritance Hierarchy

See Also

Indicator Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator Members

Indicator Members
Constructors Fields Attached Properties Properties Methods
[image]

Represents a gauge element, which changes its appearance based on its current state.

The following tables list the members exposed by the Indicator type.

Public Constructors

Name | Description
Indicator | Initializes a new instance of the Indicator class.

Public Fields

Name | Description
ActiveColorProperty | Identifies the ActiveColor attached property.
CurrentStateProperty | Identifies the CurrentState dependency property.
DefaultStateProperty | Identifies the DefaultState dependency property.
StatesProperty | Identifies the States dependency property.
ValueProperty | Identifies the Value dependency property.

Public Attached Properties

Name | Description
ActiveColorProperty | Gets or sets the glow color of an indicator state.

Public Properties

Name | Description
CurrentState | Gets the state the indicator is currently in. This is a dependency property.
DefaultState | Gets or sets the state to use when the indicator is not in any of the defined states. This is a dependency property.
States | Gets or sets a collection of CustomInterval objects, which define various states for the indicator. This is a dependency property.
Value | Gets or sets the value associated with this indicator. This is a dependency property.

Public Methods

Name | Description
GetActiveColor | Gets the value of the Indicator.ActiveColor attached property for a given dependency object.
SetActiveColor | Sets the value of the Indicator.ActiveColor attached property for a given dependency object.

See Also

Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator Fields

Indicator Fields
[image]

Public Fields

Name | Description
ActiveColorProperty | Identifies the ActiveColor attached property.
CurrentStateProperty | Identifies the CurrentState dependency property.
DefaultStateProperty | Identifies the DefaultState dependency property.
StatesProperty | Identifies the States dependency property.
ValueProperty | Identifies the Value dependency property.

See Also

Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator.ActiveColorProperty Field

Indicator.ActiveColorProperty Field
[image]

Identifies the ActiveColor attached property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActiveColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActiveColorProperty As DependencyProperty

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator.CurrentStateProperty Field

Indicator.CurrentStateProperty Field
[image]

Identifies the CurrentState dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CurrentStateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CurrentStateProperty As DependencyProperty

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator.DefaultStateProperty Field

Indicator.DefaultStateProperty Field
[image]

Identifies the DefaultState dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty DefaultStateProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly DefaultStateProperty As DependencyProperty

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator.StatesProperty Field

Indicator.StatesProperty Field
[image]

Identifies the States dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StatesProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StatesProperty As DependencyProperty

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator.ValueProperty Field

Indicator.ValueProperty Field
[image]

Identifies the Value dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator Constructor

Indicator Constructor
[image]

Initializes a new instance of the Indicator class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Indicator ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator Methods

Indicator Methods
[image]

Public Methods

Name | Description
GetActiveColor | Gets the value of the Indicator.ActiveColor attached property for a given dependency object.
SetActiveColor | Sets the value of the Indicator.ActiveColor attached property for a given dependency object.

See Also

Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator.GetActiveColor Method

Indicator.GetActiveColor Method
[image]

Gets the value of the Indicator.ActiveColor attached property for a given dependency object.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static Color GetActiveColor (
CustomInterval element
)

Visual Basic [image] Copy Code

Public Shared Function GetActiveColor ( _
element As CustomInterval _
) As Color

Parameters

element

The element from which the property value is read.

Return Value

The Indicator.ActiveColor value of the specified element.

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace
SetActiveColor Method


MindFusion.Gauges.Silverlight.Indicator.SetActiveColor Method

Indicator.SetActiveColor Method
[image]

Sets the value of the Indicator.ActiveColor attached property for a given dependency object.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static void SetActiveColor (
CustomInterval element,
Color value
)

Visual Basic [image] Copy Code

Public Shared Sub SetActiveColor ( _
element As CustomInterval, _
value As Color _
)

Parameters

element

The element to which the property value is written.

value
The new value for the Indicator.ActiveColor property of the specified element.

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace
GetActiveColor Method


MindFusion.Gauges.Silverlight.Indicator Attached Properties

Indicator Attached Properties
[image]

Public Attached Properties

Name | Description
ActiveColorProperty | Gets or sets the glow color of an indicator state.

See Also

Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator.ActiveColor Attached Property

Indicator.ActiveColor Attached Property
[image]

Gets or sets the glow color of an indicator state.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code
See Indicator.GetActiveColor, Indicator.SetActiveColor
Visual Basic [image] Copy Code
See Indicator.GetActiveColor, Indicator.SetActiveColor

Property Value

A .NET Color object.

Dependency Property Information

Identifier Field | ActiveColorProperty
Metadata Flags | None

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator Properties

Indicator Properties
[image]

Public Properties

Name | Description
CurrentState | Gets the state the indicator is currently in. This is a dependency property.
DefaultState | Gets or sets the state to use when the indicator is not in any of the defined states. This is a dependency property.
States | Gets or sets a collection of CustomInterval objects, which define various states for the indicator. This is a dependency property.
Value | Gets or sets the value associated with this indicator. This is a dependency property.

See Also

Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator.CurrentState Property

Indicator.CurrentState Property
[image]

Gets the state the indicator is currently in. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public CustomInterval CurrentState { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentState As CustomInterval

Property Value

An instance of the CustomInterval class.

Remarks

The value of this property is updated automatically to reflect the current state of the indicator. The intention is to bind to this property from within the indicator's control template. Therefore, when the current state changed, the appearance of the indicator will change accordingly.

Example

For example, the following XAML code illustrates the default template of the Indicator class and how it binds to the properties of the CurrentState:

XAML [image] Copy Code

<ControlTemplate TargetType="{x:Type local:Indicator}">
<local:Led
BorderBrush="{Binding Path=CurrentState.Stroke, RelativeSource={RelativeSource TemplatedParent}}"
Background="{Binding Path=CurrentState.Fill, RelativeSource={RelativeSource TemplatedParent}}"
GlowColor="{Binding Path=CurrentState.(local:Indicator.ActiveColor), RelativeSource={RelativeSource TemplatedParent}}" />
</ControlTemplate>

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace
DefaultState Property


MindFusion.Gauges.Silverlight.Indicator.DefaultState Property

Indicator.DefaultState Property
[image]

Gets or sets the state to use when the indicator is not in any of the defined states. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public CustomInterval DefaultState { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultState As CustomInterval

Property Value

An instance of the CustomInterval class.

Remarks

This is the state, which will be used by the indicator when it is not in any of its defined states. For example, if the States collection is empty, the indicator will always be in this default state.

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator.States Property

Indicator.States Property
[image]

Gets or sets a collection of CustomInterval objects, which define various states for the indicator. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public CustomIntervalCollection States { get; set; }

Visual Basic [image] Copy Code

Public Property States As CustomIntervalCollection

Property Value

An instance of the CustomIntervalCollection class.

Remarks

To define new states for the indicator, create new CustomInterval objects, set their range through their MinValue and MaxValue properties, and add them to this collection.

Example

The following example illustrates how to create several states for an indicator through XAML:

XAML [image] Copy Code

<gauges:Indicator>
<gauges:Indicator.States>
<gauges:CustomInterval MinValue="0" MaxValue="10" Fill="DarkGreen" gauges:Indicator.ActiveColor="DarkGreen" />
<gauges:CustomInterval MinValue="10" MaxValue="20" Fill="Green" gauges:Indicator.ActiveColor="Green" />
<gauges:CustomInterval MinValue="20" MaxValue="30" Fill="Lime" gauges:Indicator.ActiveColor="Lime" />
<gauges:CustomInterval MinValue="30" MaxValue="40" Fill="Yellow" gauges:Indicator.ActiveColor="Yellow" />
<gauges:CustomInterval MinValue="40" MaxValue="50" Fill="Orange" gauges:Indicator.ActiveColor="Orange" />
<gauges:CustomInterval MinValue="50" MaxValue="60" Fill="Red" gauges:Indicator.ActiveColor="Red" />
</gauges:Indicator.States>
</gauges:Indicator>

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Indicator.Value Property

Indicator.Value Property
[image]

Gets or sets the value associated with this indicator. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value.

Remarks

The value of the indicator determines its current state. A common scenario is to bind the Value property of the indicator to the Value of a Pointer object, thus when the value of the pointer is modified, the state of the indicator changes to reflect this.

See Also

Indicator Members
Indicator Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LabelRotation Enumeration

LabelRotation Enumeration
[image]

Indicates the rotation of a label within a scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public enum LabelRotation

Visual Basic [image] Copy Code

Public Enum LabelRotation

Members

Member name | Description
Auto | Specifies that the labels are automatically rotated so that their baseline always points downwards.
BaselineAwayFromCenter | Specifies that the labels are rotated so that their baseline points away from the center of the scale.
BaselineToCenter | Specifies that the labels are rotated so that their baseline points towards the center of the scale.
None | Specifies no rotation.
Sideways | Specifies that the labels are aligned sideways to the scale.

Remarks

The following schemes illustrates all possible label rotation modes in an oval scale.

Auto | BaselineAwayFromCenter | BaselineToCenter | None | Sideways

See Also

MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Led Class

Led Class
Remarks See Also
[image]

A LED-like control with a glow effect. This control is suitable for gauge indicators.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class Led : Control

Visual Basic [image] Copy Code

Public Class Led
Inherits Control

Remarks

The Led control represents a LED-like light source. The color of the light is controlled through the Background (which specifies the fill) and GlowColor (which specifies the ambience light) properties and the color of the border is specified through the BorderBrush property.

The default control template of the Indicator class uses a Led control.

Inheritance Hierarchy

See Also

Led Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Led Members

Led Members
Constructors Fields Properties Methods
[image]

A LED-like control with a glow effect. This control is suitable for gauge indicators.

The following tables list the members exposed by the Led type.

Public Constructors

Name | Description
Led | Initializes a new instance of the Led class.

Public Fields

Name | Description
GlowColorProperty | Identifies the GlowColor dependency property.

Public Properties

Name | Description
GlowColor | Gets or sets the glow color of the control. This is a dependency property.

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

Led Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Led Fields

Led Fields
[image]

Public Fields

Name | Description
GlowColorProperty | Identifies the GlowColor dependency property.

See Also

Led Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Led.GlowColorProperty Field

Led.GlowColorProperty Field
[image]

Identifies the GlowColor dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty GlowColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly GlowColorProperty As DependencyProperty

See Also

Led Members
Led Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Led Constructor

Led Constructor
[image]

Initializes a new instance of the Led class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Led ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Led Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Led Methods

Led Methods
[image]

Public Methods

Name | Description
OnApplyTemplate | FrameworkElement.OnApplyTemplate override.

See Also

Led Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Led.OnApplyTemplate Method

Led.OnApplyTemplate Method
[image]

FrameworkElement.OnApplyTemplate override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

Led Members
Led Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Led Properties

Led Properties
[image]

Public Properties

Name | Description
GlowColor | Gets or sets the glow color of the control. This is a dependency property.

See Also

Led Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Led.GlowColor Property

Led.GlowColor Property
[image]

Gets or sets the glow color of the control. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Color GlowColor { get; set; }

Visual Basic [image] Copy Code

Public Property GlowColor As Color

Property Value

A .NET Color value.

Remarks

This color is used as an outer glow of the control.

See Also

Led Members
Led Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length Structure

Length Structure
Remarks See Also
[image]

Specifies distance expressed either absolutely, through pixels, or relatively, through a percentage of the container's size.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public struct Length

Visual Basic [image] Copy Code

Public Structure Length

Remarks

Through the use of relative lengths it is possible to create scalable gauges.

To define relative lengths in XAML, use the percentage sign after the value. For example, the following code snipped defines a Pointer with width and height set to 30% and 10% respectively.

XAML [image] Copy Code

<gauges:Pointer PointerWidth="30%" PointerHeight="10%" />

See Also

Length Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length Members

Length Members
Constructors Properties Methods
[image]

Specifies distance expressed either absolutely, through pixels, or relatively, through a percentage of the container's size.

The following tables list the members exposed by the Length type.

Public Constructors

Name | Description
Length | Overloaded. Initializes a new instance of the Length structure with the specified absolute value.

Public Properties

Name | Description
Type | Gets or sets a value indicating how to interpret Value.
Value | Gets or sets the value representing this length.

Public Methods

Name | Description
Equals | ValueType.Equals override. Compares an object to an instance of Length for equality.
GetHashCode | Gets the hash code for this instance of Length object.
ToString | Returns a string representation of this Length object.

See Also

Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length Constructor

Length Constructor
[image]

Initializes a new instance of the Length structure with the specified absolute value.

Overload List

Name | Description
Length (Double) | Initializes a new instance of the Length structure with the specified absolute value.
Length (Double, LengthType) | Initializes a new instance of the Length structure with the specified value and type.

See Also

Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length Constructor (Double)

Length Constructor (Double)
See Also
[image]

Initializes a new instance of the Length structure with the specified absolute value.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length (
double absoluteValue
)

Visual Basic [image] Copy Code

Public New ( _
absoluteValue As Double _
)

Parameters

absoluteValue

A double specifying absolute length.

See Also

Length Constructor Overload List
Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length Constructor (Double, LengthType)

Length Constructor (Double, LengthType)
See Also
[image]

Initializes a new instance of the Length structure with the specified value and type.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length (
double value,
LengthType type
)

Visual Basic [image] Copy Code

Public New ( _
value As Double, _
type As LengthType _
)

Parameters

value

A double specifying the initial length value.

type
A member of the LengthType enumeration specifying the length type.

See Also

Length Constructor Overload List
Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length Methods

Length Methods
[image]

Public Methods

Name | Description
Equals | ValueType.Equals override. Compares an object to an instance of Length for equality.
GetHashCode | Gets the hash code for this instance of Length object.
ToString | Returns a string representation of this Length object.

See Also

Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length.Equals Method

Length.Equals Method
[image]

ValueType.Equals override. Compares an object to an instance of Length for equality.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare.

Return Value

true if the lengths are equal; otherwise, false.

See Also

Length Members
Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length.GetHashCode Method

Length.GetHashCode Method
[image]

Gets the hash code for this instance of Length object.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The hash code for this instance of Length.

See Also

Length Members
Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length.ToString Method

Length.ToString Method
[image]

Returns a string representation of this Length object.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string representation of this Length.

See Also

Length Members
Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length Properties

Length Properties
[image]

Public Properties

Name | Description
Type | Gets or sets a value indicating how to interpret Value.
Value | Gets or sets the value representing this length.

See Also

Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length.Type Property

Length.Type Property
[image]

Gets or sets a value indicating how to interpret Value.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public LengthType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As LengthType

Property Value

A member of the LengthType enumeration specifying how to interpret the length value.

See Also

Length Members
Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Length.Value Property

Length.Value Property
[image]

Gets or sets the value representing this length.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value.

See Also

Length Members
Length Structure
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LengthConverter Class

LengthConverter Class
[image]

Represents a TypeConverter for Length objects.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class LengthConverter : TypeConverter

Visual Basic [image] Copy Code

Public Class LengthConverter
Inherits TypeConverter

Inheritance Hierarchy

System.Object
System.ComponentModel.TypeConverter
MindFusion.Gauges.Silverlight.LengthConverter

See Also

LengthConverter Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LengthConverter Members

LengthConverter Members
Constructors Methods
[image]

Represents a TypeConverter for Length objects.

The following tables list the members exposed by the LengthConverter type.

Public Constructors

Name | Description
LengthConverter | Initializes a new instance of the LengthConverter class.

Public Methods

Name | Description
CanConvertFrom | LengthConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

LengthConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LengthConverter Constructor

LengthConverter Constructor
[image]

Initializes a new instance of the LengthConverter class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public LengthConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LengthConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LengthConverter Methods

LengthConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | LengthConverter.CanConvertFrom override.
CanConvertTo | TypeConverter.CanConvertTo override.
ConvertFrom | TypeConverter.ConvertFrom override.
ConvertTo | TypeConverter.ConvertTo override.

See Also

LengthConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LengthConverter.CanConvertFrom Method

LengthConverter.CanConvertFrom Method
[image]

LengthConverter.CanConvertFrom override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override bool CanConvertFrom (
ITypeDescriptorContext context,
Type sourceType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertFrom( _
context As ITypeDescriptorContext, _
sourceType As Type _
) As Boolean

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
sourceType
A System.Type that represents the type you want to convert from.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

LengthConverter Members
LengthConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LengthConverter.CanConvertTo Method

LengthConverter.CanConvertTo Method
[image]

TypeConverter.CanConvertTo override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override bool CanConvertTo (
ITypeDescriptorContext context,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function CanConvertTo( _
context As ITypeDescriptorContext, _
destinationType As Type _
) As Boolean

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
destinationType
A System.Type that represents the type you want to convert to.

Return Value

true if this converter can perform the conversion; otherwise, false.

See Also

LengthConverter Members
LengthConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LengthConverter.ConvertFrom Method

LengthConverter.ConvertFrom Method
[image]

TypeConverter.ConvertFrom override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override Object ConvertFrom (
ITypeDescriptorContext context,
CultureInfo culture,
Object value
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertFrom( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object _
) As Object

Parameters

context
An System.ComponentModel.ITypeDescriptorContext that provides a format context.
culture
The System.Globalization.CultureInfo to use as the current culture.
value
The System.Object to convert.

Return Value

An System.Object that represents the converted value.

See Also

LengthConverter Members
LengthConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LengthConverter.ConvertTo Method

LengthConverter.ConvertTo Method
[image]

TypeConverter.ConvertTo override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override Object ConvertTo (
ITypeDescriptorContext context,
CultureInfo culture,
Object value,
Type destinationType
)

Visual Basic [image] Copy Code

Public Overrides Function ConvertTo( _
context As ITypeDescriptorContext, _
culture As CultureInfo, _
value As Object, _
destinationType As Type _
) As Object

Parameters

context
The System.Object to convert.
culture
The System.Type to convert the value parameter to.
value
An System.Object that represents the converted value.
destinationType
The System.Type to convert the value parameter to.

Return Value

An System.Object that represents the converted value.

See Also

LengthConverter Members
LengthConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LengthType Enumeration

LengthType Enumeration
[image]

Indicates the type of the units of a Length object.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public enum LengthType

Visual Basic [image] Copy Code

Public Enum LengthType

Members

Member name | Description
Absolute | Specifies absolute length, expressed in pixels.
Relative | Specifies relative length, expressed as a percentage of the container's size.

See Also

MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearGauge Class

LinearGauge Class
Remarks See Also
[image]

Represents a linear gauge control.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class LinearGauge : ItemsControl

Visual Basic [image] Copy Code

Public Class LinearGauge
Inherits ItemsControl

Remarks

The LinearGauge class acts as a container for LinearScale objects. The use of the gauge is not mandatory. However, the gauge provides a nice background skinning and glass effect. The following code illustrates how to define an LinearGauge object with a single scale in XAML:

XAML [image] Copy Code

<gauges:LinearGauge Orientation="Horizontal">
<gauges:LinearScale Orientation="Horizontal" />
</gauges:LinearGauge>

The above code will produce a gauge similar to the following image.

Inheritance Hierarchy

See Also

LinearGauge Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearGauge Members

LinearGauge Members
Constructors Fields Properties
[image]

Represents a linear gauge control.

The following tables list the members exposed by the LinearGauge type.

Public Constructors

Name | Description
LinearGauge | Initializes a new instance of the LinearGauge class.

Public Fields

Name | Description
OrientationProperty | Identifies the Orientation dependency property.

Public Properties

Name | Description
Orientation | Gets or sets the orientation of the gauge. This is a dependency property.

See Also

LinearGauge Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearGauge Fields

LinearGauge Fields
[image]

Public Fields

Name | Description
OrientationProperty | Identifies the Orientation dependency property.

See Also

LinearGauge Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearGauge.OrientationProperty Field

LinearGauge.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

LinearGauge Members
LinearGauge Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearGauge Constructor

LinearGauge Constructor
[image]

Initializes a new instance of the LinearGauge class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public LinearGauge ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LinearGauge Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearGauge Properties

LinearGauge Properties
[image]

Public Properties

Name | Description
Orientation | Gets or sets the orientation of the gauge. This is a dependency property.

See Also

LinearGauge Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearGauge.Orientation Property

LinearGauge.Orientation Property
[image]

Gets or sets the orientation of the gauge. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the .NET Orientation enumeration.

See Also

LinearGauge Members
LinearGauge Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale Class

LinearScale Class
Remarks See Also
[image]

Represents a linear scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class LinearScale : BaseScale

Visual Basic [image] Copy Code

Public Class LinearScale
Inherits BaseScale

Remarks

This scale distributes its elements along a vertical or horizontal line. The size and positioning of the scale within its container is specified through the Left, Top and ScaleLength properties. All of these are usually specified as relative lengths.

Inheritance Hierarchy

See Also

LinearScale Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale Members

LinearScale Members
Constructors Fields Properties Methods Events
[image]

Represents a linear scale.

The following tables list the members exposed by the LinearScale type.

Public Constructors

Name | Description
LinearScale | Initializes a new instance of the LinearScale class.

Public Fields

Name | Description
LeftProperty | Identifies the Left dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ScaleAlignmentProperty | Identifies the ScaleAlignment dependency property.
ScaleLengthProperty | Identifies the ScaleLength dependency property.
TopProperty | Identifies the Top dependency property.

Inherited Public Fields

Name | Description
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property. (Inherited from BaseScale.)
EnableAnimationProperty | Identifies the EnableAnimation dependency property. (Inherited from BaseScale.)
EndWidthProperty | Identifies the EndWidth dependency property. (Inherited from BaseScale.)
FillProperty | Identifies the Fill dependency property. (Inherited from BaseScale.)
FunctionArgumentProperty | Identifies the FunctionArgument dependency property. (Inherited from BaseScale.)
FunctionTypeProperty | Identifies the FunctionType dependency property. (Inherited from BaseScale.)
LogarithmBaseProperty | Identifies the LogarithmBase dependency property. (Inherited from BaseScale.)
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property. (Inherited from BaseScale.)
MaxValueProperty | Identifies the MaxValue dependency property. (Inherited from BaseScale.)
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property. (Inherited from BaseScale.)
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property. (Inherited from BaseScale.)
MinValueProperty | Identifies the MinValue dependency property. (Inherited from BaseScale.)
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property. (Inherited from BaseScale.)
PointerAnimationSpeedRatioProperty | Identifies the PointerAnimationSpeedRatio dependency property. (Inherited from BaseScale.)
PointersProperty | Identifies the Pointers dependency property. (Inherited from BaseScale.)
RangesProperty | Identifies the Ranges dependency property. (Inherited from BaseScale.)
StartWidthProperty | Identifies the StartWidth dependency property. (Inherited from BaseScale.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from BaseScale.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from BaseScale.)

Public Properties

Name | Description
Left | Gets or sets the distance between the left of this scale and the left of its container. This is a dependency property.
Orientation | Gets or sets the orientation of the scale. This is a dependency property.
ScaleAlignment | Gets or sets the alignment of the scale. This is a dependency property.
ScaleLength | Gets or sets the length of the scale. This is a dependency property.
Top | Gets or sets the distance between the top of the scale and the top of its container. This is a dependency property.

Inherited Public Properties

Name | Description
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom. (Inherited from BaseScale.)
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property. (Inherited from BaseScale.)
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property. (Inherited from BaseScale.)
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property. (Inherited from BaseScale.)
Fill | Gets or sets the brush used to fill the scale. This is a dependency property. (Inherited from BaseScale.)
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property. (Inherited from BaseScale.)
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property. (Inherited from BaseScale.)
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property. (Inherited from BaseScale.)
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationSpeedRatio | Gets or sets the speed ratio of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction. (Inherited from BaseScale.)
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property. (Inherited from BaseScale.)
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property. (Inherited from BaseScale.)
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property. (Inherited from BaseScale.)

Public Methods

Name | Description
GetValueFromPoint | BaseScale.GetValueFromPoint override.

Protected Methods

Name | Description
MeasureOverride | BaseScale.MeasureOverride override.

Inherited Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override. (Inherited from BaseScale.)
EndInit | ItemsControl.EndInit override. (Inherited from BaseScale.)
GetValueFromPoint | Returns the value corresponding to the specified point. (Inherited from BaseScale.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from BaseScale.)

Inherited Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from BaseScale.)
MeasureOverride | Control.MeasureOverride override. (Inherited from BaseScale.)
OnMouseLeftButtonDown | UIElement.OnMouseDown override. (Inherited from BaseScale.)
OnMouseLeftButtonUp | UIElement.OnMouseUp override. (Inherited from BaseScale.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseScale.)
OnPointerClicked | Raises the PointerClicked event. (Inherited from BaseScale.)
OnQueryLabelValue | Raises the QueryLabelValue event. (Inherited from BaseScale.)
OnRangeClicked | Raises the RangeClicked event. (Inherited from BaseScale.)
OnRender | UIElement.OnRender override. (Inherited from BaseScale.)
OnScaleClicked | Raises the ScaleClicked event. (Inherited from BaseScale.)
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event. (Inherited from BaseScale.)

Inherited Public Events

Name | Description
PointerClicked | Occurs when a pointer within the scale is clicked with the mouse. (Inherited from BaseScale.)
QueryLabelValue | Occurs when the labels in the scale are being generated in order to associate custom values with them. (Inherited from BaseScale.)
RangeClicked | Occurs when a range within the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleClicked | Occurs when the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleGeometryClicked | Occurs when the scale geometry is clicked with the mouse. (Inherited from BaseScale.)

See Also

LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale Fields

LinearScale Fields
[image]

Public Fields

Name | Description
LeftProperty | Identifies the Left dependency property.
OrientationProperty | Identifies the Orientation dependency property.
ScaleAlignmentProperty | Identifies the ScaleAlignment dependency property.
ScaleLengthProperty | Identifies the ScaleLength dependency property.
TopProperty | Identifies the Top dependency property.

Inherited Public Fields

Name | Description
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property. (Inherited from BaseScale.)
EnableAnimationProperty | Identifies the EnableAnimation dependency property. (Inherited from BaseScale.)
EndWidthProperty | Identifies the EndWidth dependency property. (Inherited from BaseScale.)
FillProperty | Identifies the Fill dependency property. (Inherited from BaseScale.)
FunctionArgumentProperty | Identifies the FunctionArgument dependency property. (Inherited from BaseScale.)
FunctionTypeProperty | Identifies the FunctionType dependency property. (Inherited from BaseScale.)
LogarithmBaseProperty | Identifies the LogarithmBase dependency property. (Inherited from BaseScale.)
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property. (Inherited from BaseScale.)
MaxValueProperty | Identifies the MaxValue dependency property. (Inherited from BaseScale.)
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property. (Inherited from BaseScale.)
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property. (Inherited from BaseScale.)
MinValueProperty | Identifies the MinValue dependency property. (Inherited from BaseScale.)
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property. (Inherited from BaseScale.)
PointerAnimationSpeedRatioProperty | Identifies the PointerAnimationSpeedRatio dependency property. (Inherited from BaseScale.)
PointersProperty | Identifies the Pointers dependency property. (Inherited from BaseScale.)
RangesProperty | Identifies the Ranges dependency property. (Inherited from BaseScale.)
StartWidthProperty | Identifies the StartWidth dependency property. (Inherited from BaseScale.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from BaseScale.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from BaseScale.)

See Also

LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale.LeftProperty Field

LinearScale.LeftProperty Field
[image]

Identifies the Left dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LeftProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LeftProperty As DependencyProperty

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale.OrientationProperty Field

LinearScale.OrientationProperty Field
[image]

Identifies the Orientation dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OrientationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale.ScaleAlignmentProperty Field

LinearScale.ScaleAlignmentProperty Field
[image]

Identifies the ScaleAlignment dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScaleAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScaleAlignmentProperty As DependencyProperty

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale.ScaleLengthProperty Field

LinearScale.ScaleLengthProperty Field
[image]

Identifies the ScaleLength dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScaleLengthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScaleLengthProperty As DependencyProperty

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale.TopProperty Field

LinearScale.TopProperty Field
[image]

Identifies the Top dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TopProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TopProperty As DependencyProperty

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale Constructor

LinearScale Constructor
[image]

Initializes a new instance of the LinearScale class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public LinearScale ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale Methods

LinearScale Methods
[image]

Public Methods

Name | Description
GetValueFromPoint | BaseScale.GetValueFromPoint override.

Protected Methods

Name | Description
MeasureOverride | BaseScale.MeasureOverride override.

Inherited Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override. (Inherited from BaseScale.)
EndInit | ItemsControl.EndInit override. (Inherited from BaseScale.)
GetValueFromPoint | Returns the value corresponding to the specified point. (Inherited from BaseScale.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from BaseScale.)

Inherited Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from BaseScale.)
MeasureOverride | Control.MeasureOverride override. (Inherited from BaseScale.)
OnMouseLeftButtonDown | UIElement.OnMouseDown override. (Inherited from BaseScale.)
OnMouseLeftButtonUp | UIElement.OnMouseUp override. (Inherited from BaseScale.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseScale.)
OnPointerClicked | Raises the PointerClicked event. (Inherited from BaseScale.)
OnQueryLabelValue | Raises the QueryLabelValue event. (Inherited from BaseScale.)
OnRangeClicked | Raises the RangeClicked event. (Inherited from BaseScale.)
OnRender | UIElement.OnRender override. (Inherited from BaseScale.)
OnScaleClicked | Raises the ScaleClicked event. (Inherited from BaseScale.)
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event. (Inherited from BaseScale.)

See Also

LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale.GetValueFromPoint Method

LinearScale.GetValueFromPoint Method
[image]

BaseScale.GetValueFromPoint override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override double GetValueFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function GetValueFromPoint( _
point As Point _
) As Double

Parameters

point

The point to test.

Return Value

The value from the scale, corresponding to the point, possibly MinValue or MaxValue if the specified point cannot be associated with a value.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale.MeasureOverride Method

LinearScale.MeasureOverride Method
[image]

BaseScale.MeasureOverride override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint
The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale Properties

LinearScale Properties
[image]

Public Properties

Name | Description
Left | Gets or sets the distance between the left of this scale and the left of its container. This is a dependency property.
Orientation | Gets or sets the orientation of the scale. This is a dependency property.
ScaleAlignment | Gets or sets the alignment of the scale. This is a dependency property.
ScaleLength | Gets or sets the length of the scale. This is a dependency property.
Top | Gets or sets the distance between the top of the scale and the top of its container. This is a dependency property.

Inherited Public Properties

Name | Description
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom. (Inherited from BaseScale.)
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property. (Inherited from BaseScale.)
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property. (Inherited from BaseScale.)
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property. (Inherited from BaseScale.)
Fill | Gets or sets the brush used to fill the scale. This is a dependency property. (Inherited from BaseScale.)
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property. (Inherited from BaseScale.)
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property. (Inherited from BaseScale.)
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property. (Inherited from BaseScale.)
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationSpeedRatio | Gets or sets the speed ratio of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction. (Inherited from BaseScale.)
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property. (Inherited from BaseScale.)
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property. (Inherited from BaseScale.)
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property. (Inherited from BaseScale.)

See Also

LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale.Left Property

LinearScale.Left Property
[image]

Gets or sets the distance between the left of this scale and the left of its container. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length Left { get; set; }

Visual Basic [image] Copy Code

Public Property Left As Length

Property Value

An instance of the Length structure.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace
Top Property
ScaleLength Property


MindFusion.Gauges.Silverlight.LinearScale.Orientation Property

LinearScale.Orientation Property
[image]

Gets or sets the orientation of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the .NET Orientation enumeration.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale.ScaleAlignment Property

LinearScale.ScaleAlignment Property
[image]

Gets or sets the alignment of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Alignment ScaleAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleAlignment As Alignment

Property Value

A member of the Alignment enumeration.

Remarks

All Inner* values align a vertical scale to the left side and a horizontal scale to the top side of the control. All Outer* values align a vertical scale to the right side and a horizontal scale to the bottom side of the control. All Center* values center the scale along its length.

This property is relevant only when the StartWidth of the scale is different than the EndWidth.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.LinearScale.ScaleLength Property

LinearScale.ScaleLength Property
[image]

Gets or sets the length of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length ScaleLength { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleLength As Length

Property Value

An instance of the Length structure.

Remarks

Relative scale length is measured based on the width of the control in horizontal scales and on the height of the control in vertical scales.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace
Left Property
Top Property


MindFusion.Gauges.Silverlight.LinearScale.Top Property

LinearScale.Top Property
[image]

Gets or sets the distance between the top of the scale and the top of its container. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length Top { get; set; }

Visual Basic [image] Copy Code

Public Property Top As Length

Property Value

An instance of the Length class.

See Also

LinearScale Members
LinearScale Class
MindFusion.Gauges.Silverlight Namespace
Left Property
ScaleLength Property


MindFusion.Gauges.Silverlight.MajorTickSettings Class

MajorTickSettings Class
[image]

Provides settings for the major ticks and labels in a gauge scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class MajorTickSettings : TickSettings

Visual Basic [image] Copy Code

Public Class MajorTickSettings
Inherits TickSettings

Inheritance Hierarchy

See Also

MajorTickSettings Members
MindFusion.Gauges.Silverlight Namespace
MiddleTickSettings Class
MinorTickSettings Class


MindFusion.Gauges.Silverlight.MajorTickSettings Members

MajorTickSettings Members
Constructors Fields Properties Methods Events
[image]

Provides settings for the major ticks and labels in a gauge scale.

The following tables list the members exposed by the MajorTickSettings type.

Public Constructors

Name | Description
MajorTickSettings | Initializes a new instance of the MajorTickSettings class.

Inherited Public Fields

Name | Description
CountProperty | Identifies the Count dependency property. (Inherited from TickSettings.)
CustomIntervalsProperty | Identifies the CustomIntervals dependency property. (Inherited from TickSettings.)
FillProperty | Identifies the Fill dependency property. (Inherited from TickSettings.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TickSettings.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TickSettings.)
LabelAlignmentProperty | Identifies the LabelAlignment dependency property. (Inherited from TickSettings.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from TickSettings.)
LabelFormatProperty | Identifies the LabelFormat dependency property. (Inherited from TickSettings.)
LabelOffsetProperty | Identifies the LabelOffset dependency property. (Inherited from TickSettings.)
LabelRotationProperty | Identifies the LabelRotation dependency property. (Inherited from TickSettings.)
ShowLabelsProperty | Identifies the ShowLabels dependency property. (Inherited from TickSettings.)
ShowMaxValueTickProperty | Identifies the ShowMaxValueTick dependency property. (Inherited from TickSettings.)
ShowTicksProperty | Identifies the ShowTicks dependency property. (Inherited from TickSettings.)
StepProperty | Identifies the Step dependency property. (Inherited from TickSettings.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from TickSettings.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from TickSettings.)
TickAlignmentProperty | Identifies the TickAlignment dependency property. (Inherited from TickSettings.)
TickHeightProperty | Identifies the TickHeight dependency property. (Inherited from TickSettings.)
TickOffsetProperty | Identifies the TickOffset dependency property. (Inherited from TickSettings.)
TickShapeProperty | Identifies the TickShape dependency property. (Inherited from TickSettings.)
TickStyleProperty | Identifies the TickStyle dependency property. (Inherited from TickSettings.)
TickWidthProperty | Identifies the TickWidth dependency property. (Inherited from TickSettings.)

Public Properties

Name | Description
TickType | TickSettings.TickType override.

Inherited Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickStyle | Gets or sets the Style to use for custom tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | Gets the type of ticks this object applies to. (Inherited from TickSettings.)
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

Inherited Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from TickSettings.)

Inherited Public Events

Name | Description
PropertyChanged | Raised when a property value changes. (Inherited from TickSettings.)

See Also

MajorTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MajorTickSettings Constructor

MajorTickSettings Constructor
[image]

Initializes a new instance of the MajorTickSettings class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public MajorTickSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MajorTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MajorTickSettings Properties

MajorTickSettings Properties
[image]

Public Properties

Name | Description
TickType | TickSettings.TickType override.

Inherited Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickStyle | Gets or sets the Style to use for custom tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | Gets the type of ticks this object applies to. (Inherited from TickSettings.)
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

See Also

MajorTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MajorTickSettings.TickType Property

MajorTickSettings.TickType Property
[image]

TickSettings.TickType override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override TickType TickType { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TickType As TickType

Property Value

Always returns Major.

See Also

MajorTickSettings Members
MajorTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MiddleTickSettings Class

MiddleTickSettings Class
[image]

Provides settings for the middle ticks and labels in a gauge scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class MiddleTickSettings : TickSettings

Visual Basic [image] Copy Code

Public Class MiddleTickSettings
Inherits TickSettings

Inheritance Hierarchy

See Also

MiddleTickSettings Members
MindFusion.Gauges.Silverlight Namespace
MajorTickSettings Class
MinorTickSettings Class


MindFusion.Gauges.Silverlight.MiddleTickSettings Members

MiddleTickSettings Members
Constructors Fields Properties Methods Events
[image]

Provides settings for the middle ticks and labels in a gauge scale.

The following tables list the members exposed by the MiddleTickSettings type.

Public Constructors

Name | Description
MiddleTickSettings | Initializes a new instance of the MiddleTickSettings class.

Inherited Public Fields

Name | Description
CountProperty | Identifies the Count dependency property. (Inherited from TickSettings.)
CustomIntervalsProperty | Identifies the CustomIntervals dependency property. (Inherited from TickSettings.)
FillProperty | Identifies the Fill dependency property. (Inherited from TickSettings.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TickSettings.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TickSettings.)
LabelAlignmentProperty | Identifies the LabelAlignment dependency property. (Inherited from TickSettings.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from TickSettings.)
LabelFormatProperty | Identifies the LabelFormat dependency property. (Inherited from TickSettings.)
LabelOffsetProperty | Identifies the LabelOffset dependency property. (Inherited from TickSettings.)
LabelRotationProperty | Identifies the LabelRotation dependency property. (Inherited from TickSettings.)
ShowLabelsProperty | Identifies the ShowLabels dependency property. (Inherited from TickSettings.)
ShowMaxValueTickProperty | Identifies the ShowMaxValueTick dependency property. (Inherited from TickSettings.)
ShowTicksProperty | Identifies the ShowTicks dependency property. (Inherited from TickSettings.)
StepProperty | Identifies the Step dependency property. (Inherited from TickSettings.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from TickSettings.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from TickSettings.)
TickAlignmentProperty | Identifies the TickAlignment dependency property. (Inherited from TickSettings.)
TickHeightProperty | Identifies the TickHeight dependency property. (Inherited from TickSettings.)
TickOffsetProperty | Identifies the TickOffset dependency property. (Inherited from TickSettings.)
TickShapeProperty | Identifies the TickShape dependency property. (Inherited from TickSettings.)
TickStyleProperty | Identifies the TickStyle dependency property. (Inherited from TickSettings.)
TickWidthProperty | Identifies the TickWidth dependency property. (Inherited from TickSettings.)

Public Properties

Name | Description
TickType | TickSettings.TickType override.

Inherited Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickStyle | Gets or sets the Style to use for custom tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | Gets the type of ticks this object applies to. (Inherited from TickSettings.)
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

Inherited Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from TickSettings.)

Inherited Public Events

Name | Description
PropertyChanged | Raised when a property value changes. (Inherited from TickSettings.)

See Also

MiddleTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MiddleTickSettings Constructor

MiddleTickSettings Constructor
[image]

Initializes a new instance of the MiddleTickSettings class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public MiddleTickSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MiddleTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MiddleTickSettings Properties

MiddleTickSettings Properties
[image]

Public Properties

Name | Description
TickType | TickSettings.TickType override.

Inherited Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickStyle | Gets or sets the Style to use for custom tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | Gets the type of ticks this object applies to. (Inherited from TickSettings.)
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

See Also

MiddleTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MiddleTickSettings.TickType Property

MiddleTickSettings.TickType Property
[image]

TickSettings.TickType override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override TickType TickType { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TickType As TickType

Property Value

Always returns Middle.

See Also

MiddleTickSettings Members
MiddleTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MinorTickSettings Class

MinorTickSettings Class
[image]

Provides settings for the minor ticks and labels in a gauge scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class MinorTickSettings : TickSettings

Visual Basic [image] Copy Code

Public Class MinorTickSettings
Inherits TickSettings

Inheritance Hierarchy

See Also

MinorTickSettings Members
MindFusion.Gauges.Silverlight Namespace
MajorTickSettings Class
MiddleTickSettings Class


MindFusion.Gauges.Silverlight.MinorTickSettings Members

MinorTickSettings Members
Constructors Fields Properties Methods Events
[image]

Provides settings for the minor ticks and labels in a gauge scale.

The following tables list the members exposed by the MinorTickSettings type.

Public Constructors

Name | Description
MinorTickSettings | Initializes a new instance of the MinorTickSettings class.

Inherited Public Fields

Name | Description
CountProperty | Identifies the Count dependency property. (Inherited from TickSettings.)
CustomIntervalsProperty | Identifies the CustomIntervals dependency property. (Inherited from TickSettings.)
FillProperty | Identifies the Fill dependency property. (Inherited from TickSettings.)
FontSizeProperty | Identifies the FontSize dependency property. (Inherited from TickSettings.)
FontWeightProperty | Identifies the FontWeight dependency property. (Inherited from TickSettings.)
LabelAlignmentProperty | Identifies the LabelAlignment dependency property. (Inherited from TickSettings.)
LabelForegroundProperty | Identifies the LabelForeground dependency property. (Inherited from TickSettings.)
LabelFormatProperty | Identifies the LabelFormat dependency property. (Inherited from TickSettings.)
LabelOffsetProperty | Identifies the LabelOffset dependency property. (Inherited from TickSettings.)
LabelRotationProperty | Identifies the LabelRotation dependency property. (Inherited from TickSettings.)
ShowLabelsProperty | Identifies the ShowLabels dependency property. (Inherited from TickSettings.)
ShowMaxValueTickProperty | Identifies the ShowMaxValueTick dependency property. (Inherited from TickSettings.)
ShowTicksProperty | Identifies the ShowTicks dependency property. (Inherited from TickSettings.)
StepProperty | Identifies the Step dependency property. (Inherited from TickSettings.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from TickSettings.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from TickSettings.)
TickAlignmentProperty | Identifies the TickAlignment dependency property. (Inherited from TickSettings.)
TickHeightProperty | Identifies the TickHeight dependency property. (Inherited from TickSettings.)
TickOffsetProperty | Identifies the TickOffset dependency property. (Inherited from TickSettings.)
TickShapeProperty | Identifies the TickShape dependency property. (Inherited from TickSettings.)
TickStyleProperty | Identifies the TickStyle dependency property. (Inherited from TickSettings.)
TickWidthProperty | Identifies the TickWidth dependency property. (Inherited from TickSettings.)

Public Properties

Name | Description
TickType | TickSettings.TickType override.

Inherited Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickStyle | Gets or sets the Style to use for custom tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | Gets the type of ticks this object applies to. (Inherited from TickSettings.)
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

Inherited Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from TickSettings.)

Inherited Public Events

Name | Description
PropertyChanged | Raised when a property value changes. (Inherited from TickSettings.)

See Also

MinorTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MinorTickSettings Constructor

MinorTickSettings Constructor
[image]

Initializes a new instance of the MinorTickSettings class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public MinorTickSettings ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MinorTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MinorTickSettings Properties

MinorTickSettings Properties
[image]

Public Properties

Name | Description
TickType | TickSettings.TickType override.

Inherited Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property. (Inherited from TickSettings.)
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property. (Inherited from TickSettings.)
Fill | Gets or sets the fill brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
FontSize | Gets or sets the font size of the labels. This is a dependency property. (Inherited from TickSettings.)
FontWeight | Gets or sets the font weight of the labels. This is a dependency property. (Inherited from TickSettings.)
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property. (Inherited from TickSettings.)
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property. (Inherited from TickSettings.)
LabelFormat | Gets or sets the format for label texts. (Inherited from TickSettings.)
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property. (Inherited from TickSettings.)
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property. (Inherited from TickSettings.)
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property. (Inherited from TickSettings.)
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property. (Inherited from TickSettings.)
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property. (Inherited from TickSettings.)
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property. (Inherited from TickSettings.)
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property. (Inherited from TickSettings.)
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property. (Inherited from TickSettings.)
TickHeight | Gets or sets the height of a tick. This is a dependency property. (Inherited from TickSettings.)
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property. (Inherited from TickSettings.)
TickShape | Gets or sets the shape of the ticks. This is a dependency property. (Inherited from TickSettings.)
TickStyle | Gets or sets the Style to use for custom tick representation. This is a dependency property. (Inherited from TickSettings.)
TickType | Gets the type of ticks this object applies to. (Inherited from TickSettings.)
TickWidth | Gets or sets the width of a tick. This is a dependency property. (Inherited from TickSettings.)

See Also

MinorTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.MinorTickSettings.TickType Property

MinorTickSettings.TickType Property
[image]

TickSettings.TickType override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override TickType TickType { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TickType As TickType

Property Value

Always returns Minor.

See Also

MinorTickSettings Members
MinorTickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalGauge Class

OvalGauge Class
Remarks See Also
[image]

Represents a circular gauge control.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class OvalGauge : ItemsControl

Visual Basic [image] Copy Code

Public Class OvalGauge
Inherits ItemsControl

Remarks

The OvalGauge class acts as a container for OvalScale objects. The use of the gauge is not mandatory. However, the gauge provides a nice background skinning and glass effect. The following code illustrates how to define an OvalGauge object with a single scale in XAML:

XAML [image] Copy Code

<gauges:OvalGauge>
<gauges:OvalScale />
</gauges:OvalGauge>

The above code will produce a gauge similar to the following image.

Inheritance Hierarchy

See Also

OvalGauge Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalGauge Members

OvalGauge Members
Constructors
[image]

Represents a circular gauge control.

The following tables list the members exposed by the OvalGauge type.

Public Constructors

Name | Description
OvalGauge | Initializes a new instance of the OvalGauge class.

See Also

OvalGauge Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalGauge Constructor

OvalGauge Constructor
[image]

Initializes a new instance of the OvalGauge class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public OvalGauge ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OvalGauge Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale Class

OvalScale Class
Remarks See Also
[image]

Represents a radial scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class OvalScale : BaseScale

Visual Basic [image] Copy Code

Public Class OvalScale
Inherits BaseScale

Remarks

This scale distributes its elements along an circular arc. The start and angles of the arc is defined by the StartAngle and EndAngle properties respectively.

Inheritance Hierarchy

See Also

OvalScale Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale Members

OvalScale Members
Constructors Fields Properties Methods Events
[image]

Represents a radial scale.

The following tables list the members exposed by the OvalScale type.

Public Constructors

Name | Description
OvalScale | Initializes a new instance of the OvalScale class.

Public Fields

Name | Description
AnimateThroughSmallerArcProperty | Identifies the AnimateThroughSmallerArc dependency property.
EndAngleProperty | Identifies the EndAngle dependency property.
OffsetProperty | Identifies the Offset dependency property.
ScaleRelativeCenterProperty | Identifies the ScaleRelativeCenter dependency property.
ScaleRelativeRadiusProperty | Identifies the ScaleRelativeRadius dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.

Inherited Public Fields

Name | Description
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property. (Inherited from BaseScale.)
EnableAnimationProperty | Identifies the EnableAnimation dependency property. (Inherited from BaseScale.)
EndWidthProperty | Identifies the EndWidth dependency property. (Inherited from BaseScale.)
FillProperty | Identifies the Fill dependency property. (Inherited from BaseScale.)
FunctionArgumentProperty | Identifies the FunctionArgument dependency property. (Inherited from BaseScale.)
FunctionTypeProperty | Identifies the FunctionType dependency property. (Inherited from BaseScale.)
LogarithmBaseProperty | Identifies the LogarithmBase dependency property. (Inherited from BaseScale.)
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property. (Inherited from BaseScale.)
MaxValueProperty | Identifies the MaxValue dependency property. (Inherited from BaseScale.)
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property. (Inherited from BaseScale.)
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property. (Inherited from BaseScale.)
MinValueProperty | Identifies the MinValue dependency property. (Inherited from BaseScale.)
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property. (Inherited from BaseScale.)
PointerAnimationSpeedRatioProperty | Identifies the PointerAnimationSpeedRatio dependency property. (Inherited from BaseScale.)
PointersProperty | Identifies the Pointers dependency property. (Inherited from BaseScale.)
RangesProperty | Identifies the Ranges dependency property. (Inherited from BaseScale.)
StartWidthProperty | Identifies the StartWidth dependency property. (Inherited from BaseScale.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from BaseScale.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from BaseScale.)

Public Properties

Name | Description
AnimateThroughSmallerArc | Gets or sets a value indicating whether animations are performed through the smaller of the two arcs even though the animated element may cross outside of the scale. This is a dependency property.
EndAngle | Gets or sets the end angle of the scale. This is a dependency property.
Offset | Gets or sets the distance between the outline of the scale and the outline of the gauge control which contains it. This is a dependency property.
ScaleRelativeCenter | Gets or sets the center of the scale relative to the scale bounds. A value of (0.5, 0.5) indicates the center of the bounds, a value of (0, 0) indicates the top-left corner. This is a dependency property.
ScaleRelativeRadius | Gets or sets the radius of the scale relative to the scale bounds. A value of 0.5 indicates that the radius is half the size of the scale. This is a dependency property.
StartAngle | Gets or sets the start angle of the scale. This is a dependency property.

Inherited Public Properties

Name | Description
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom. (Inherited from BaseScale.)
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property. (Inherited from BaseScale.)
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property. (Inherited from BaseScale.)
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property. (Inherited from BaseScale.)
Fill | Gets or sets the brush used to fill the scale. This is a dependency property. (Inherited from BaseScale.)
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property. (Inherited from BaseScale.)
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property. (Inherited from BaseScale.)
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property. (Inherited from BaseScale.)
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationSpeedRatio | Gets or sets the speed ratio of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction. (Inherited from BaseScale.)
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property. (Inherited from BaseScale.)
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property. (Inherited from BaseScale.)
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property. (Inherited from BaseScale.)

Public Methods

Name | Description
GetValueFromPoint | BaseScale.GetValueFromPoint override.

Protected Methods

Name | Description
MeasureOverride | BaseScale.MeasureOverride override.

Inherited Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override. (Inherited from BaseScale.)
EndInit | ItemsControl.EndInit override. (Inherited from BaseScale.)
GetValueFromPoint | Returns the value corresponding to the specified point. (Inherited from BaseScale.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from BaseScale.)

Inherited Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from BaseScale.)
MeasureOverride | Control.MeasureOverride override. (Inherited from BaseScale.)
OnMouseLeftButtonDown | UIElement.OnMouseDown override. (Inherited from BaseScale.)
OnMouseLeftButtonUp | UIElement.OnMouseUp override. (Inherited from BaseScale.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseScale.)
OnPointerClicked | Raises the PointerClicked event. (Inherited from BaseScale.)
OnQueryLabelValue | Raises the QueryLabelValue event. (Inherited from BaseScale.)
OnRangeClicked | Raises the RangeClicked event. (Inherited from BaseScale.)
OnRender | UIElement.OnRender override. (Inherited from BaseScale.)
OnScaleClicked | Raises the ScaleClicked event. (Inherited from BaseScale.)
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event. (Inherited from BaseScale.)

Inherited Public Events

Name | Description
PointerClicked | Occurs when a pointer within the scale is clicked with the mouse. (Inherited from BaseScale.)
QueryLabelValue | Occurs when the labels in the scale are being generated in order to associate custom values with them. (Inherited from BaseScale.)
RangeClicked | Occurs when a range within the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleClicked | Occurs when the scale is clicked with the mouse. (Inherited from BaseScale.)
ScaleGeometryClicked | Occurs when the scale geometry is clicked with the mouse. (Inherited from BaseScale.)

See Also

OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale Fields

OvalScale Fields
[image]

Public Fields

Name | Description
AnimateThroughSmallerArcProperty | Identifies the AnimateThroughSmallerArc dependency property.
EndAngleProperty | Identifies the EndAngle dependency property.
OffsetProperty | Identifies the Offset dependency property.
ScaleRelativeCenterProperty | Identifies the ScaleRelativeCenter dependency property.
ScaleRelativeRadiusProperty | Identifies the ScaleRelativeRadius dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.

Inherited Public Fields

Name | Description
DefaultPointerStyleProperty | Identifies the DefaultPointerStyle dependency property. (Inherited from BaseScale.)
EnableAnimationProperty | Identifies the EnableAnimation dependency property. (Inherited from BaseScale.)
EndWidthProperty | Identifies the EndWidth dependency property. (Inherited from BaseScale.)
FillProperty | Identifies the Fill dependency property. (Inherited from BaseScale.)
FunctionArgumentProperty | Identifies the FunctionArgument dependency property. (Inherited from BaseScale.)
FunctionTypeProperty | Identifies the FunctionType dependency property. (Inherited from BaseScale.)
LogarithmBaseProperty | Identifies the LogarithmBase dependency property. (Inherited from BaseScale.)
MajorTickSettingsProperty | Identifies the MajorTickSettings dependency property. (Inherited from BaseScale.)
MaxValueProperty | Identifies the MaxValue dependency property. (Inherited from BaseScale.)
MiddleTickSettingsProperty | Identifies the MiddleTickSettings dependency property. (Inherited from BaseScale.)
MinorTickSettingsProperty | Identifies the MinorTickSettings dependency property. (Inherited from BaseScale.)
MinValueProperty | Identifies the MinValue dependency property. (Inherited from BaseScale.)
PointerAnimationDurationProperty | Identifies the PointerAnimationDuration dependency property. (Inherited from BaseScale.)
PointerAnimationSpeedRatioProperty | Identifies the PointerAnimationSpeedRatio dependency property. (Inherited from BaseScale.)
PointersProperty | Identifies the Pointers dependency property. (Inherited from BaseScale.)
RangesProperty | Identifies the Ranges dependency property. (Inherited from BaseScale.)
StartWidthProperty | Identifies the StartWidth dependency property. (Inherited from BaseScale.)
StrokeProperty | Identifies the Stroke dependency property. (Inherited from BaseScale.)
StrokeThicknessProperty | Identifies the StrokeThickness dependency property. (Inherited from BaseScale.)

See Also

OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.AnimateThroughSmallerArcProperty Field

OvalScale.AnimateThroughSmallerArcProperty Field
[image]

Identifies the AnimateThroughSmallerArc dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AnimateThroughSmallerArcProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AnimateThroughSmallerArcProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.EndAngleProperty Field

OvalScale.EndAngleProperty Field
[image]

Identifies the EndAngle dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndAngleProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.OffsetProperty Field

OvalScale.OffsetProperty Field
[image]

Identifies the Offset dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OffsetProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.ScaleRelativeCenterProperty Field

OvalScale.ScaleRelativeCenterProperty Field
[image]

Identifies the ScaleRelativeCenter dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScaleRelativeCenterProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScaleRelativeCenterProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.ScaleRelativeRadiusProperty Field

OvalScale.ScaleRelativeRadiusProperty Field
[image]

Identifies the ScaleRelativeRadius dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ScaleRelativeRadiusProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ScaleRelativeRadiusProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.StartAngleProperty Field

OvalScale.StartAngleProperty Field
[image]

Identifies the StartAngle dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartAngleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartAngleProperty As DependencyProperty

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale Constructor

OvalScale Constructor
[image]

Initializes a new instance of the OvalScale class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public OvalScale ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale Methods

OvalScale Methods
[image]

Public Methods

Name | Description
GetValueFromPoint | BaseScale.GetValueFromPoint override.

Protected Methods

Name | Description
MeasureOverride | BaseScale.MeasureOverride override.

Inherited Public Methods

Name | Description
BeginInit | ItemsControl.BeginInit override. (Inherited from BaseScale.)
EndInit | ItemsControl.EndInit override. (Inherited from BaseScale.)
GetValueFromPoint | Returns the value corresponding to the specified point. (Inherited from BaseScale.)
OnApplyTemplate | FrameworkElement.OnApplyTemplate override. (Inherited from BaseScale.)

Inherited Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override. (Inherited from BaseScale.)
MeasureOverride | Control.MeasureOverride override. (Inherited from BaseScale.)
OnMouseLeftButtonDown | UIElement.OnMouseDown override. (Inherited from BaseScale.)
OnMouseLeftButtonUp | UIElement.OnMouseUp override. (Inherited from BaseScale.)
OnMouseMove | UIElement.OnMouseMove override. (Inherited from BaseScale.)
OnPointerClicked | Raises the PointerClicked event. (Inherited from BaseScale.)
OnQueryLabelValue | Raises the QueryLabelValue event. (Inherited from BaseScale.)
OnRangeClicked | Raises the RangeClicked event. (Inherited from BaseScale.)
OnRender | UIElement.OnRender override. (Inherited from BaseScale.)
OnScaleClicked | Raises the ScaleClicked event. (Inherited from BaseScale.)
OnScaleGeometryClicked | Raises the ScaleGeometryClicked event. (Inherited from BaseScale.)

See Also

OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.GetValueFromPoint Method

OvalScale.GetValueFromPoint Method
[image]

BaseScale.GetValueFromPoint override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public override double GetValueFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function GetValueFromPoint( _
point As Point _
) As Double

Parameters

point

The point to test.

Return Value

The value from the scale, corresponding to the point, possibly MinValue or MaxValue if the specified point cannot be associated with a value.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.MeasureOverride Method

OvalScale.MeasureOverride Method
[image]

BaseScale.MeasureOverride override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale Properties

OvalScale Properties
[image]

Public Properties

Name | Description
AnimateThroughSmallerArc | Gets or sets a value indicating whether animations are performed through the smaller of the two arcs even though the animated element may cross outside of the scale. This is a dependency property.
EndAngle | Gets or sets the end angle of the scale. This is a dependency property.
Offset | Gets or sets the distance between the outline of the scale and the outline of the gauge control which contains it. This is a dependency property.
ScaleRelativeCenter | Gets or sets the center of the scale relative to the scale bounds. A value of (0.5, 0.5) indicates the center of the bounds, a value of (0, 0) indicates the top-left corner. This is a dependency property.
ScaleRelativeRadius | Gets or sets the radius of the scale relative to the scale bounds. A value of 0.5 indicates that the radius is half the size of the scale. This is a dependency property.
StartAngle | Gets or sets the start angle of the scale. This is a dependency property.

Inherited Public Properties

Name | Description
CustomFunction | Gets or sets the function to be used for distribution of values along the scale when FunctionType is set to Custom. (Inherited from BaseScale.)
DefaultPointerStyle | Gets or sets the default style for pointers in this scale. This is a dependency property. (Inherited from BaseScale.)
EnableAnimation | Gets or sets a value indicating whether animations in the scale are enabled. This is a dependency property. (Inherited from BaseScale.)
EndWidth | Gets or sets the width of the scale bar at its end. This is a dependency property. (Inherited from BaseScale.)
Fill | Gets or sets the brush used to fill the scale. This is a dependency property. (Inherited from BaseScale.)
FunctionArgument | Gets or sets the argument passed to custom functions. This is a dependency property. (Inherited from BaseScale.)
FunctionType | The type of the function used to calculate the distribution of values along the scale. This is a dependency property. (Inherited from BaseScale.)
LogarithmBase | Gets or sets the logarithm base when FunctionType is set to Logarithmic. This is a dependency property. (Inherited from BaseScale.)
MajorTickSettings | Gets or sets the settings for the major ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MaxValue | Gets or sets the maximal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
MiddleTickSettings | Gets or sets the settings for the middle ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinorTickSettings | Gets or sets the settings for the minor ticks and their associated labels. This is a dependency property. (Inherited from BaseScale.)
MinValue | Gets or sets the minimal value displayed by the scale. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationDuration | Gets or sets the duration of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
PointerAnimationSpeedRatio | Gets or sets the speed ratio of the animation of animated pointers. This is a dependency property. (Inherited from BaseScale.)
Pointers | Gets or sets a collection with the pointers displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
Ranges | Gets or sets a collection with the ranges displayed in the scale. This is a dependency property. (Inherited from BaseScale.)
ReversedCustomFunction | Gets or sets the reversed version of the function specified through CustomFunction. (Inherited from BaseScale.)
StartWidth | Gets or sets the width of the scale bar at its beginning. This is a dependency property. (Inherited from BaseScale.)
Stroke | Gets or sets the brush used to stroke the scale. This is a dependency property. (Inherited from BaseScale.)
StrokeThickness | Gets or sets the thickness of the scale stroke. This is a dependency property. (Inherited from BaseScale.)

See Also

OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.AnimateThroughSmallerArc Property

OvalScale.AnimateThroughSmallerArc Property
[image]

Gets or sets a value indicating whether animations are performed through the smaller of the two arcs even though the animated element may cross outside of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public bool AnimateThroughSmallerArc { get; set; }

Visual Basic [image] Copy Code

Public Property AnimateThroughSmallerArc As Boolean

Property Value

A boolean value.

Remarks

This property is useful when implementing continuous scales with animated pointers, for example clocks. When the pointer is moving across the end of the scale, it will animate properly through the smaller arc. The following image illustrates the behavior of the pointer when animating across the end of the scale.

The value of the minute pointer changes so that the pointer moves across the end of the scale. The blue arrow indicate the animation direction when the AnimateThroughSmallerArc property is set to true, the red arrow indicates the animation direction when the property is set to false.

Note

Setting this property to false immediately discards all current pointer animations and sets the position of the pointers corresponding to their current value.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.EndAngle Property

OvalScale.EndAngle Property
[image]

Gets or sets the end angle of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double EndAngle { get; set; }

Visual Basic [image] Copy Code

Public Property EndAngle As Double

Property Value

A double value, expressing the angle in degrees.

Remarks

This property along with the StartAngle property define the arc orientation and sweep of the scale. The measurement is performed using a standard coordinate system with a center in the middle of the scale and angle values increasing in a clockwise direction. The following picture illustrates this:

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace
StartAngle Property


MindFusion.Gauges.Silverlight.OvalScale.Offset Property

OvalScale.Offset Property
[image]

Gets or sets the distance between the outline of the scale and the outline of the gauge control which contains it. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length Offset { get; set; }

Visual Basic [image] Copy Code

Public Property Offset As Length

Property Value

An instance of the Length structure.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.OvalScale.ScaleRelativeCenter Property

OvalScale.ScaleRelativeCenter Property
[image]

Gets or sets the center of the scale relative to the scale bounds. A value of (0.5, 0.5) indicates the center of the bounds, a value of (0, 0) indicates the top-left corner. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Point ScaleRelativeCenter { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleRelativeCenter As Point

Property Value

A .NET Point object.

Remarks

ScaleRelativeCenter and ScaleRelativeRadius properties can be used to implement gauges such as quadratic and other non-centralized gauges.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace
ScaleRelativeRadius Property


MindFusion.Gauges.Silverlight.OvalScale.ScaleRelativeRadius Property

OvalScale.ScaleRelativeRadius Property
[image]

Gets or sets the radius of the scale relative to the scale bounds. A value of 0.5 indicates that the radius is half the size of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double ScaleRelativeRadius { get; set; }

Visual Basic [image] Copy Code

Public Property ScaleRelativeRadius As Double

Property Value

A double value.

Remarks

ScaleRelativeCenter and ScaleRelativeRadius properties can be used to implement gauges such as quadratic and other non-centralized gauges.

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace
ScaleRelativeCenter Property


MindFusion.Gauges.Silverlight.OvalScale.StartAngle Property

OvalScale.StartAngle Property
[image]

Gets or sets the start angle of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double StartAngle { get; set; }

Visual Basic [image] Copy Code

Public Property StartAngle As Double

Property Value

A double value, expressing the angle in degrees.

Remarks

This property along with the EndAngle property define the arc orientation and sweep of the scale. The measurement is performed using a standard coordinate system with a center in the middle of the scale and angle values increasing in a clockwise direction. The following picture illustrates this:

See Also

OvalScale Members
OvalScale Class
MindFusion.Gauges.Silverlight Namespace
EndAngle Property


MindFusion.Gauges.Silverlight.PercentConverter Class

PercentConverter Class
Remarks See Also
[image]

Converts an amount of the specified converter parameter equal to the percentage specified by the source value.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class PercentConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class PercentConverter
Implements IValueConverter

Remarks

The PercentConverter can be very useful for specifying scalable values for standard properties. For example, you can define an ellipse with a StrokeThickness relative to the size of the ellipse.

Example

The following sample code defines an Ellipse with StrokeThickness equal to 2% of its actual width:

XAML [image] Copy Code

<gauges:PercentConverter x:Key="PercentConverter" />

<Ellipse StrokeThickness="{Binding ActualWidth, RelativeSource={RelativeSource Self}, Converter={StaticResource PercentConverter}, ConverterParameter=2}" />

Inheritance Hierarchy

System.Object
MindFusion.Gauges.Silverlight.PercentConverter

See Also

PercentConverter Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.PercentConverter Members

PercentConverter Members
Constructors Methods
[image]

Converts an amount of the specified converter parameter equal to the percentage specified by the source value.

The following tables list the members exposed by the PercentConverter type.

Public Constructors

Name | Description
PercentConverter | Initializes a new instance of the PercentConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

PercentConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.PercentConverter Constructor

PercentConverter Constructor
[image]

Initializes a new instance of the PercentConverter class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public PercentConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PercentConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.PercentConverter Methods

PercentConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

PercentConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.PercentConverter.Convert Method

PercentConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public virtual Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

PercentConverter Members
PercentConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.PercentConverter.ConvertBack Method

PercentConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public virtual Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

PercentConverter Members
PercentConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer Class

Pointer Class
Remarks See Also
[image]

Represents a needle (or arrow) within a gauge scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class Pointer : Control

Visual Basic [image] Copy Code

Public Class Pointer
Inherits Control

Remarks

The most important member of the pointer object is its Value. The pointer is automatically adjusted by its containing scale so that it points to the scale location, corresponding to its value.

The size of the pointer is defined by the PointerWidth and PointerHeight properties. The size is usually specified as a relative value so that the pointer scales with its containing gauge. The location of the pointer can be adjusted through the PointerOffset property and its alignment in a linear scale can be specified through the Alignment property.

The pointer can be made interactive by setting the IsInteractive property to true. Clicking with the mouse within a scale causes all its interactive pointers to be adjusted to the value corresponding to the clicked point.

A pointer can be made discrete by setting IsDiscrete to true. The value of a discrete pointer is always integer.

Note

To add a pointer to a scale simply add it to the Pointers collection of the scale.

To customize the appearance of a pointer associate a new ControlTemplate with it. Several pointers with custom templates are illustrated below.

Inheritance Hierarchy

See Also

Pointer Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer Members

Pointer Members
Constructors Fields Properties Methods Events
[image]

Represents a needle (or arrow) within a gauge scale.

The following tables list the members exposed by the Pointer type.

Public Constructors

Name | Description
Pointer | Initializes a new instance of the Pointer class.

Public Fields

Name | Description
ActualPointerHeightProperty | Identifies the ActualPointerHeight property.
ActualPointerWidthProperty | Identifies the ActualPointerWidth dependency property.
AlignmentProperty | Identifies the Alignment dependency property.
IsAnimatedProperty | Identifies the IsAnimated dependency property.
IsDiscreteProperty | Identifies the IsDiscrete dependency property.
IsInteractiveProperty | Identifies the IsInteractive dependency property.
PointerHeightProperty | Identifies the PointerHeight dependency property.
PointerOffsetProperty | Identifies the PointerOffset dependency property.
PointerWidthProperty | Identifies the PointerWidth dependency property.
ValueProperty | Identifies the Value dependency property.

Public Properties

Name | Description
ActualPointerHeight | Gets the actual height of the pointer. This is a dependency property.
ActualPointerWidth | Gets the actual width of the pointer. This is a dependency property.
Alignment | Gets or sets the alignment of the pointer relative to the scale. This is a dependency property.
IsAnimated | Gets or sets a value indicating whether the pointer should animate when its position changes. This is a dependency property.
IsDiscrete | Gets or sets a value indicating whether the pointer value can be changed only discretely. In other words, the pointer Value can be only integer. This is a dependency property.
IsInteractive | Gets or sets a value indicating whether the pointer position should be affected by user interactions. This is a dependency property.
PointerHeight | Gets or sets the height of the pointer. This is a dependency property.
PointerOffset | Gets or sets the offset of the pointer along the direction it points to. This is a dependency property.
PointerWidth | Gets or sets the width of the pointer. This is a dependency property.
Value | Gets or sets the value this pointer points to. This is a dependency property.

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
MeasureOverride | Control.MeasureOverride override.
OnMouseLeftButtonDown | UIElement.OnMouseDown override.
OnValueChanged | Raises the ValueChanged event.

Public Events

Name | Description
ValueChanged | Occurs when the Value of this pointer changes, either programmatically or interactively.

See Also

Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer Fields

Pointer Fields
[image]

Public Fields

Name | Description
ActualPointerHeightProperty | Identifies the ActualPointerHeight property.
ActualPointerWidthProperty | Identifies the ActualPointerWidth dependency property.
AlignmentProperty | Identifies the Alignment dependency property.
IsAnimatedProperty | Identifies the IsAnimated dependency property.
IsDiscreteProperty | Identifies the IsDiscrete dependency property.
IsInteractiveProperty | Identifies the IsInteractive dependency property.
PointerHeightProperty | Identifies the PointerHeight dependency property.
PointerOffsetProperty | Identifies the PointerOffset dependency property.
PointerWidthProperty | Identifies the PointerWidth dependency property.
ValueProperty | Identifies the Value dependency property.

See Also

Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.ActualPointerHeightProperty Field

Pointer.ActualPointerHeightProperty Field
[image]

Identifies the ActualPointerHeight property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActualPointerHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActualPointerHeightProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.ActualPointerWidthProperty Field

Pointer.ActualPointerWidthProperty Field
[image]

Identifies the ActualPointerWidth dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ActualPointerWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActualPointerWidthProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.AlignmentProperty Field

Pointer.AlignmentProperty Field
[image]

Identifies the Alignment dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlignmentProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.IsAnimatedProperty Field

Pointer.IsAnimatedProperty Field
[image]

Identifies the IsAnimated dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsAnimatedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsAnimatedProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.IsDiscreteProperty Field

Pointer.IsDiscreteProperty Field
[image]

Identifies the IsDiscrete dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsDiscreteProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsDiscreteProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.IsInteractiveProperty Field

Pointer.IsInteractiveProperty Field
[image]

Identifies the IsInteractive dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty IsInteractiveProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsInteractiveProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.PointerHeightProperty Field

Pointer.PointerHeightProperty Field
[image]

Identifies the PointerHeight dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerHeightProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.PointerOffsetProperty Field

Pointer.PointerOffsetProperty Field
[image]

Identifies the PointerOffset dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerOffsetProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.PointerWidthProperty Field

Pointer.PointerWidthProperty Field
[image]

Identifies the PointerWidth dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty PointerWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PointerWidthProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.ValueProperty Field

Pointer.ValueProperty Field
[image]

Identifies the Value dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer Constructor

Pointer Constructor
[image]

Initializes a new instance of the Pointer class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Pointer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer Methods

Pointer Methods
[image]

Protected Methods

Name | Description
ArrangeOverride | Control.ArrangeOverride override.
MeasureOverride | Control.MeasureOverride override.
OnMouseLeftButtonDown | UIElement.OnMouseDown override.
OnValueChanged | Raises the ValueChanged event.

See Also

Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.ArrangeOverride Method

Pointer.ArrangeOverride Method
[image]

Control.ArrangeOverride override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual Size ArrangeOverride (
Size arrangeBounds
)

Visual Basic [image] Copy Code

Protected Overridable Function ArrangeOverride( _
arrangeBounds As Size _
) As Size

Parameters

arrangeBounds

The computed size that is used to arrange the content.

Return Value

The size of the control.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.MeasureOverride Method

Pointer.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.OnMouseLeftButtonDown Method

Pointer.OnMouseLeftButtonDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

The System.Windows.Input.MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.OnValueChanged Method

Pointer.OnValueChanged Method
[image]

Raises the ValueChanged event.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnValueChanged (
ValueChangedEventArgs<Double> e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValueChanged ( _
e As ValueChangedEventArgs(Of Double) _
)

Parameters

e

An object, containing the event data.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer Properties

Pointer Properties
[image]

Public Properties

Name | Description
ActualPointerHeight | Gets the actual height of the pointer. This is a dependency property.
ActualPointerWidth | Gets the actual width of the pointer. This is a dependency property.
Alignment | Gets or sets the alignment of the pointer relative to the scale. This is a dependency property.
IsAnimated | Gets or sets a value indicating whether the pointer should animate when its position changes. This is a dependency property.
IsDiscrete | Gets or sets a value indicating whether the pointer value can be changed only discretely. In other words, the pointer Value can be only integer. This is a dependency property.
IsInteractive | Gets or sets a value indicating whether the pointer position should be affected by user interactions. This is a dependency property.
PointerHeight | Gets or sets the height of the pointer. This is a dependency property.
PointerOffset | Gets or sets the offset of the pointer along the direction it points to. This is a dependency property.
PointerWidth | Gets or sets the width of the pointer. This is a dependency property.
Value | Gets or sets the value this pointer points to. This is a dependency property.

See Also

Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.ActualPointerHeight Property

Pointer.ActualPointerHeight Property
[image]

Gets the actual height of the pointer. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double ActualPointerHeight { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ActualPointerHeight As Double

Property Value

Remarks

This property can be bound to from within the pointer template because binding directly to FrameworkElement.ActualHeight seems to fail.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.ActualPointerWidth Property

Pointer.ActualPointerWidth Property
[image]

Gets the actual width of the pointer. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double ActualPointerWidth { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ActualPointerWidth As Double

Property Value

Remarks

This property can be bound to from within the pointer template because binding directly to FrameworkElement.ActualWidth seems to fail.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.Alignment Property

Pointer.Alignment Property
[image]

Gets or sets the alignment of the pointer relative to the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Alignment Alignment { get; set; }

Visual Basic [image] Copy Code

Public Property Alignment As Alignment

Property Value

A member of the Alignment enumeration.

Remarks

This property is ignored in oval gauges where the pointer is always pinned to the center of the gauge.

For more information on the effect of this property, check the Alignment enumeration.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace
PointerOffset Property


MindFusion.Gauges.Silverlight.Pointer.IsAnimated Property

Pointer.IsAnimated Property
[image]

Gets or sets a value indicating whether the pointer should animate when its position changes. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public bool IsAnimated { get; set; }

Visual Basic [image] Copy Code

Public Property IsAnimated As Boolean

Property Value

true to animate the pointer when its value changes; otherwise, false.

Remarks

This property has effect only when the EnableAnimation property of the scale containing the pointer is set to true. Additionally the pointers never animate in design-time.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.IsDiscrete Property

Pointer.IsDiscrete Property
[image]

Gets or sets a value indicating whether the pointer value can be changed only discretely. In other words, the pointer Value can be only integer. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public bool IsDiscrete { get; set; }

Visual Basic [image] Copy Code

Public Property IsDiscrete As Boolean

Property Value

true to make the pointer discrete; otherwise, false.

Remarks

This property can be useful when implementing analog-style pointers, which can move only discretely.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.IsInteractive Property

Pointer.IsInteractive Property
[image]

Gets or sets a value indicating whether the pointer position should be affected by user interactions. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public bool IsInteractive { get; set; }

Visual Basic [image] Copy Code

Public Property IsInteractive As Boolean

Property Value

true, to automatically adjust the pointer value when the user clicks with the mouse in the containing scale; otherwise, false.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.PointerHeight Property

Pointer.PointerHeight Property
[image]

Gets or sets the height of the pointer. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length PointerHeight { get; set; }

Visual Basic [image] Copy Code

Public Property PointerHeight As Length

Property Value

An instance of the Length structure.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace
PointerWidth Property
PointerOffset Property


MindFusion.Gauges.Silverlight.Pointer.PointerOffset Property

Pointer.PointerOffset Property
[image]

Gets or sets the offset of the pointer along the direction it points to. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length PointerOffset { get; set; }

Visual Basic [image] Copy Code

Public Property PointerOffset As Length

Property Value

An instance of the Length structure.

Remarks

In an oval scale positive offsets move elements towards the center of the scale and negative offsets move elements outwards. In a vertical linear scale positive offsets move elements to the left and negative offsets move elements to the right. In a horizontal linear scale positive offsets move elements to the top and negative offsets move elements to the bottom.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace
PointerHeight Property
PointerWidth Property


MindFusion.Gauges.Silverlight.Pointer.PointerWidth Property

Pointer.PointerWidth Property
[image]

Gets or sets the width of the pointer. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length PointerWidth { get; set; }

Visual Basic [image] Copy Code

Public Property PointerWidth As Length

Property Value

An instance of the Length structure.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace
PointerHeight Property
PointerOffset Property


MindFusion.Gauges.Silverlight.Pointer.Value Property

Pointer.Value Property
[image]

Gets or sets the value this pointer points to. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer Events

Pointer Events
[image]

Public Events

Name | Description
ValueChanged | Occurs when the Value of this pointer changes, either programmatically or interactively.

See Also

Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Pointer.ValueChanged Event

Pointer.ValueChanged Event
[image]

Occurs when the Value of this pointer changes, either programmatically or interactively.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public event ValueChangedEventHandler<Double> ValueChanged

Visual Basic [image] Copy Code

Public Event ValueChanged As ValueChangedEventHandler(Of Double)

Event Data

ValueChanged event handlers receive an argument of type ValueChangedEventArgs<Double>.

See Also

Pointer Members
Pointer Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.QueryLabelValueEventArgs Class

QueryLabelValueEventArgs Class
[image]

Provides data for the QueryLabelValue event.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class QueryLabelValueEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class QueryLabelValueEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Gauges.Silverlight.QueryLabelValueEventArgs

See Also

QueryLabelValueEventArgs Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.QueryLabelValueEventArgs Members

QueryLabelValueEventArgs Members
Constructors Properties
[image]

Provides data for the QueryLabelValue event.

The following tables list the members exposed by the QueryLabelValueEventArgs type.

Public Constructors

Name | Description
QueryLabelValueEventArgs | Initializes a new instance of the QueryLabelValueEventArgs class.

Public Properties

Name | Description
CalculatedLabelValue | Gets the value, which has been calculated for the label and which will be used if no custom value is provided.
NewValue | Gets or sets the new value to associate with the label.
Settings | Gets the TickSettings object which specifies the settings of the label.

See Also

QueryLabelValueEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.QueryLabelValueEventArgs Constructor

QueryLabelValueEventArgs Constructor
[image]

Initializes a new instance of the QueryLabelValueEventArgs class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public QueryLabelValueEventArgs ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

QueryLabelValueEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.QueryLabelValueEventArgs Properties

QueryLabelValueEventArgs Properties
[image]

Public Properties

Name | Description
CalculatedLabelValue | Gets the value, which has been calculated for the label and which will be used if no custom value is provided.
NewValue | Gets or sets the new value to associate with the label.
Settings | Gets the TickSettings object which specifies the settings of the label.

See Also

QueryLabelValueEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.QueryLabelValueEventArgs.CalculatedLabelValue Property

QueryLabelValueEventArgs.CalculatedLabelValue Property
[image]

Gets the value, which has been calculated for the label and which will be used if no custom value is provided.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double CalculatedLabelValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property CalculatedLabelValue As Double

Property Value

See Also

QueryLabelValueEventArgs Members
QueryLabelValueEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.QueryLabelValueEventArgs.NewValue Property

QueryLabelValueEventArgs.NewValue Property
[image]

Gets or sets the new value to associate with the label.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Object NewValue { get; set; }

Visual Basic [image] Copy Code

Public Property NewValue As Object

Property Value

See Also

QueryLabelValueEventArgs Members
QueryLabelValueEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.QueryLabelValueEventArgs.Settings Property

QueryLabelValueEventArgs.Settings Property
[image]

Gets the TickSettings object which specifies the settings of the label.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public TickSettings Settings { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Settings As TickSettings

Property Value

See Also

QueryLabelValueEventArgs Members
QueryLabelValueEventArgs Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range Class

Range Class
Remarks See Also
[image]

Represents a range within a gauge scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class Range : Control

Visual Basic [image] Copy Code

Public Class Range
Inherits Control

Remarks

The range is a visual representation of an interval within a gauge. Ranges are commonly used to mark specific zones on the scale or to emphasize scale intervals. Often the end of the scale is a danger zone and a range can be used to indicate this. The following image illustrates an oval gauge with three ranges (red, yellow and green) specifying different zones on the scale.

The range interval is specified through the MinValue and MaxValue properties. The Alignment and Offset properties control the positioning and the StartWidth and EndWidth properties specify the size of the range. The range can be auto-sized to the scale by setting AutoSize to true.

The Fill, Stroke and StrokeThickness properties can be used to specify the appearance of the range.

Inheritance Hierarchy

See Also

Range Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range Members

Range Members
Constructors Fields Properties Methods
[image]

Represents a range within a gauge scale.

The following tables list the members exposed by the Range type.

Public Constructors

Name | Description
Range | Initializes a new instance of the Range class.

Public Fields

Name | Description
AlignmentProperty | Identifies the Alignment dependency property.
AutoSizeProperty | Identifies the AutoSize dependency property.
EndWidthProperty | Identifies the EndWidth dependency property.
FillProperty | Identifies the Fill dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
OffsetProperty | Identifies the Offset dependency property.
StartWidthProperty | Identifies the StartWidth dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

Public Properties

Name | Description
Alignment | Gets or sets the alignment of this range relative to the scale it is associated with. This is a dependency property.
AutoSize | Gets or sets a value indicating whether the start and end width of the range will be automatically adjusted to match the width of the scale. This is a dependency property.
EndWidth | Gets or sets the width of this range at its end. This is a dependency property.
Fill | Gets or sets the fill brush of this range. This is a dependency property.
MaxValue | Gets or sets the end value of this range. This is a dependency property.
MinValue | Gets or sets the start value of this range. This is a dependency property.
Offset | Gets or sets the offset of the range from the position calculated according to its alignment. This is a dependency property.
StartWidth | Gets or sets the width of this range at its start. This is a dependency property.
Stroke | Gets or sets the stroke of this range. This is a dependency property.
StrokeThickness | Gets or sets the stroke thickness of this range. This is a dependency property.

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.
OnMouseLeftButtonDown | UIElement.OnMouseDown override.

See Also

Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range Fields

Range Fields
[image]

Public Fields

Name | Description
AlignmentProperty | Identifies the Alignment dependency property.
AutoSizeProperty | Identifies the AutoSize dependency property.
EndWidthProperty | Identifies the EndWidth dependency property.
FillProperty | Identifies the Fill dependency property.
MaxValueProperty | Identifies the MaxValue dependency property.
MinValueProperty | Identifies the MinValue dependency property.
OffsetProperty | Identifies the Offset dependency property.
StartWidthProperty | Identifies the StartWidth dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

See Also

Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.AlignmentProperty Field

Range.AlignmentProperty Field
[image]

Identifies the Alignment dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AlignmentProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.AutoSizeProperty Field

Range.AutoSizeProperty Field
[image]

Identifies the AutoSize dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty AutoSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly AutoSizeProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.EndWidthProperty Field

Range.EndWidthProperty Field
[image]

Identifies the EndWidth dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty EndWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly EndWidthProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.FillProperty Field

Range.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.MaxValueProperty Field

Range.MaxValueProperty Field
[image]

Identifies the MaxValue dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MaxValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaxValueProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.MinValueProperty Field

Range.MinValueProperty Field
[image]

Identifies the MinValue dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty MinValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinValueProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.OffsetProperty Field

Range.OffsetProperty Field
[image]

Identifies the Offset dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty OffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly OffsetProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.StartWidthProperty Field

Range.StartWidthProperty Field
[image]

Identifies the StartWidth dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StartWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StartWidthProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.StrokeProperty Field

Range.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.StrokeThicknessProperty Field

Range.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range Constructor

Range Constructor
[image]

Initializes a new instance of the Range class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Range ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range Methods

Range Methods
[image]

Protected Methods

Name | Description
MeasureOverride | Control.MeasureOverride override.
OnMouseLeftButtonDown | UIElement.OnMouseDown override.

See Also

Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.MeasureOverride Method

Range.MeasureOverride Method
[image]

Control.MeasureOverride override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual Size MeasureOverride (
Size constraint
)

Visual Basic [image] Copy Code

Protected Overridable Function MeasureOverride( _
constraint As Size _
) As Size

Parameters

constraint

The maximum size that the method can return.

Return Value

The size of the control, up to the maximum specified by constraint.

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.OnMouseLeftButtonDown Method

Range.OnMouseLeftButtonDown Method
[image]

UIElement.OnMouseDown override.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

The System.Windows.Input.MouseButtonEventArgs that contains the event data. This event data reports details about the mouse button that was pressed and the handled state.

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range Properties

Range Properties
[image]

Public Properties

Name | Description
Alignment | Gets or sets the alignment of this range relative to the scale it is associated with. This is a dependency property.
AutoSize | Gets or sets a value indicating whether the start and end width of the range will be automatically adjusted to match the width of the scale. This is a dependency property.
EndWidth | Gets or sets the width of this range at its end. This is a dependency property.
Fill | Gets or sets the fill brush of this range. This is a dependency property.
MaxValue | Gets or sets the end value of this range. This is a dependency property.
MinValue | Gets or sets the start value of this range. This is a dependency property.
Offset | Gets or sets the offset of the range from the position calculated according to its alignment. This is a dependency property.
StartWidth | Gets or sets the width of this range at its start. This is a dependency property.
Stroke | Gets or sets the stroke of this range. This is a dependency property.
StrokeThickness | Gets or sets the stroke thickness of this range. This is a dependency property.

See Also

Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.Alignment Property

Range.Alignment Property
[image]

Gets or sets the alignment of this range relative to the scale it is associated with. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Alignment Alignment { get; set; }

Visual Basic [image] Copy Code

Public Property Alignment As Alignment

Property Value

A member of the Alignment enumeration.

Remarks

For more information on the effect of this property, check the Alignment enumeration.

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace
Offset Property


MindFusion.Gauges.Silverlight.Range.AutoSize Property

Range.AutoSize Property
[image]

Gets or sets a value indicating whether the start and end width of the range will be automatically adjusted to match the width of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public bool AutoSize { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSize As Boolean

Property Value

A boolean value.

Remarks

If this property is set to true the values of StartWidth and EndWidth properties are ignored.

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace
StartWidth Property
EndWidth Property


MindFusion.Gauges.Silverlight.Range.EndWidth Property

Range.EndWidth Property
[image]

Gets or sets the width of this range at its end. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length EndWidth { get; set; }

Visual Basic [image] Copy Code

Public Property EndWidth As Length

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.Fill Property

Range.Fill Property
[image]

Gets or sets the fill brush of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.MaxValue Property

Range.MaxValue Property
[image]

Gets or sets the end value of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double MaxValue { get; set; }

Visual Basic [image] Copy Code

Public Property MaxValue As Double

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.MinValue Property

Range.MinValue Property
[image]

Gets or sets the start value of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double MinValue { get; set; }

Visual Basic [image] Copy Code

Public Property MinValue As Double

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.Offset Property

Range.Offset Property
[image]

Gets or sets the offset of the range from the position calculated according to its alignment. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length Offset { get; set; }

Visual Basic [image] Copy Code

Public Property Offset As Length

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.StartWidth Property

Range.StartWidth Property
[image]

Gets or sets the width of this range at its start. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length StartWidth { get; set; }

Visual Basic [image] Copy Code

Public Property StartWidth As Length

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.Stroke Property

Range.Stroke Property
[image]

Gets or sets the stroke of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.Range.StrokeThickness Property

Range.StrokeThickness Property
[image]

Gets or sets the stroke thickness of this range. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

See Also

Range Members
Range Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ThicknessConverter Class

ThicknessConverter Class
[image]

Converts Thickness values to double values.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class ThicknessConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class ThicknessConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Gauges.Silverlight.ThicknessConverter

See Also

ThicknessConverter Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ThicknessConverter Members

ThicknessConverter Members
Constructors Methods
[image]

Converts Thickness values to double values.

The following tables list the members exposed by the ThicknessConverter type.

Public Constructors

Name | Description
ThicknessConverter | Initializes a new instance of the ThicknessConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

ThicknessConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ThicknessConverter Constructor

ThicknessConverter Constructor
[image]

Initializes a new instance of the ThicknessConverter class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public ThicknessConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ThicknessConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ThicknessConverter Methods

ThicknessConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

ThicknessConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ThicknessConverter.Convert Method

ThicknessConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public virtual Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

ThicknessConverter Members
ThicknessConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ThicknessConverter.ConvertBack Method

ThicknessConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public virtual Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

ThicknessConverter Members
ThicknessConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings Class

TickSettings Class
[image]

Provides settings for the ticks and labels in a gauge scale.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public abstract class TickSettings : FrameworkElement, INotifyPropertyChanged

Visual Basic [image] Copy Code

Public MustInherit Class TickSettings
Inherits FrameworkElement
Implements INotifyPropertyChanged

Inheritance Hierarchy

MindFusion.Gauges.Silverlight.MajorTickSettings
MindFusion.Gauges.Silverlight.MiddleTickSettings
MindFusion.Gauges.Silverlight.MinorTickSettings

See Also

TickSettings Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings Members

TickSettings Members
Constructors Fields Properties Methods Events
[image]

Provides settings for the ticks and labels in a gauge scale.

The following tables list the members exposed by the TickSettings type.

Protected Constructors

Name | Description
TickSettings | Initializes a new instance of the TickSettings class.

Public Fields

Name | Description
CountProperty | Identifies the Count dependency property.
CustomIntervalsProperty | Identifies the CustomIntervals dependency property.
FillProperty | Identifies the Fill dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
LabelAlignmentProperty | Identifies the LabelAlignment dependency property.
LabelForegroundProperty | Identifies the LabelForeground dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelRotationProperty | Identifies the LabelRotation dependency property.
ShowLabelsProperty | Identifies the ShowLabels dependency property.
ShowMaxValueTickProperty | Identifies the ShowMaxValueTick dependency property.
ShowTicksProperty | Identifies the ShowTicks dependency property.
StepProperty | Identifies the Step dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TickAlignmentProperty | Identifies the TickAlignment dependency property.
TickHeightProperty | Identifies the TickHeight dependency property.
TickOffsetProperty | Identifies the TickOffset dependency property.
TickShapeProperty | Identifies the TickShape dependency property.
TickStyleProperty | Identifies the TickStyle dependency property.
TickWidthProperty | Identifies the TickWidth dependency property.

Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property.
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property.
Fill | Gets or sets the fill brush of the ticks. This is a dependency property.
FontSize | Gets or sets the font size of the labels. This is a dependency property.
FontWeight | Gets or sets the font weight of the labels. This is a dependency property.
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property.
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property.
LabelFormat | Gets or sets the format for label texts.
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property.
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property.
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property.
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property.
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property.
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property.
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property.
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property.
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property.
TickHeight | Gets or sets the height of a tick. This is a dependency property.
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property.
TickShape | Gets or sets the shape of the ticks. This is a dependency property.
TickStyle | Gets or sets the Style to use for custom tick representation. This is a dependency property.
TickType | Gets the type of ticks this object applies to.
TickWidth | Gets or sets the width of a tick. This is a dependency property.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
PropertyChanged | Raised when a property value changes.

See Also

TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings Fields

TickSettings Fields
[image]

Public Fields

Name | Description
CountProperty | Identifies the Count dependency property.
CustomIntervalsProperty | Identifies the CustomIntervals dependency property.
FillProperty | Identifies the Fill dependency property.
FontSizeProperty | Identifies the FontSize dependency property.
FontWeightProperty | Identifies the FontWeight dependency property.
LabelAlignmentProperty | Identifies the LabelAlignment dependency property.
LabelForegroundProperty | Identifies the LabelForeground dependency property.
LabelFormatProperty | Identifies the LabelFormat dependency property.
LabelOffsetProperty | Identifies the LabelOffset dependency property.
LabelRotationProperty | Identifies the LabelRotation dependency property.
ShowLabelsProperty | Identifies the ShowLabels dependency property.
ShowMaxValueTickProperty | Identifies the ShowMaxValueTick dependency property.
ShowTicksProperty | Identifies the ShowTicks dependency property.
StepProperty | Identifies the Step dependency property.
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
TickAlignmentProperty | Identifies the TickAlignment dependency property.
TickHeightProperty | Identifies the TickHeight dependency property.
TickOffsetProperty | Identifies the TickOffset dependency property.
TickShapeProperty | Identifies the TickShape dependency property.
TickStyleProperty | Identifies the TickStyle dependency property.
TickWidthProperty | Identifies the TickWidth dependency property.

See Also

TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.CountProperty Field

TickSettings.CountProperty Field
[image]

Identifies the Count dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CountProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CountProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.CustomIntervalsProperty Field

TickSettings.CustomIntervalsProperty Field
[image]

Identifies the CustomIntervals dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty CustomIntervalsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly CustomIntervalsProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.FillProperty Field

TickSettings.FillProperty Field
[image]

Identifies the Fill dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FillProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FillProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.FontSizeProperty Field

TickSettings.FontSizeProperty Field
[image]

Identifies the FontSize dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontSizeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontSizeProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.FontWeightProperty Field

TickSettings.FontWeightProperty Field
[image]

Identifies the FontWeight dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty FontWeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly FontWeightProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.LabelAlignmentProperty Field

TickSettings.LabelAlignmentProperty Field
[image]

Identifies the LabelAlignment dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelAlignmentProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.LabelForegroundProperty Field

TickSettings.LabelForegroundProperty Field
[image]

Identifies the LabelForeground dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelForegroundProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelForegroundProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.LabelFormatProperty Field

TickSettings.LabelFormatProperty Field
[image]

Identifies the LabelFormat dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelFormatProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelFormatProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.LabelOffsetProperty Field

TickSettings.LabelOffsetProperty Field
[image]

Identifies the LabelOffset dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelOffsetProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.LabelRotationProperty Field

TickSettings.LabelRotationProperty Field
[image]

Identifies the LabelRotation dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty LabelRotationProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LabelRotationProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.ShowLabelsProperty Field

TickSettings.ShowLabelsProperty Field
[image]

Identifies the ShowLabels dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowLabelsProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowLabelsProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.ShowMaxValueTickProperty Field

TickSettings.ShowMaxValueTickProperty Field
[image]

Identifies the ShowMaxValueTick dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowMaxValueTickProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowMaxValueTickProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.ShowTicksProperty Field

TickSettings.ShowTicksProperty Field
[image]

Identifies the ShowTicks dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ShowTicksProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShowTicksProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.StepProperty Field

TickSettings.StepProperty Field
[image]

Identifies the Step dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StepProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.StrokeProperty Field

TickSettings.StrokeProperty Field
[image]

Identifies the Stroke dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.StrokeThicknessProperty Field

TickSettings.StrokeThicknessProperty Field
[image]

Identifies the StrokeThickness dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty StrokeThicknessProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.TickAlignmentProperty Field

TickSettings.TickAlignmentProperty Field
[image]

Identifies the TickAlignment dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickAlignmentProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickAlignmentProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.TickHeightProperty Field

TickSettings.TickHeightProperty Field
[image]

Identifies the TickHeight dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickHeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickHeightProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.TickOffsetProperty Field

TickSettings.TickOffsetProperty Field
[image]

Identifies the TickOffset dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickOffsetProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickOffsetProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.TickShapeProperty Field

TickSettings.TickShapeProperty Field
[image]

Identifies the TickShape dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickShapeProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickShapeProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.TickStyleProperty Field

TickSettings.TickStyleProperty Field
[image]

Identifies the TickStyle dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickStyleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickStyleProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.TickWidthProperty Field

TickSettings.TickWidthProperty Field
[image]

Identifies the TickWidth dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public static readonly DependencyProperty TickWidthProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TickWidthProperty As DependencyProperty

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings Constructor

TickSettings Constructor
[image]

Initializes a new instance of the TickSettings class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected TickSettings ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings Methods

TickSettings Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.OnPropertyChanged Method

TickSettings.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
PropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As PropertyChangedEventArgs _
)

Parameters

e

An object, containing the event data.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings Properties

TickSettings Properties
[image]

Public Properties

Name | Description
Count | Gets or sets the number of ticks and labels. This is a dependency property.
CustomIntervals | Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property.
Fill | Gets or sets the fill brush of the ticks. This is a dependency property.
FontSize | Gets or sets the font size of the labels. This is a dependency property.
FontWeight | Gets or sets the font weight of the labels. This is a dependency property.
LabelAlignment | Gets or sets the alignment of the labels relative to the scale. This is a dependency property.
LabelForeground | Gets or sets the brush used to paint label texts. This is a dependency property.
LabelFormat | Gets or sets the format for label texts.
LabelOffset | Gets or sets the offset of the labels relative to their calculated position. This is a dependency property.
LabelRotation | Gets or sets the rotation mode of the labels. This is a dependency property.
ShowLabels | Gets or sets a value indicating whether the labels are visible. This is a dependency property.
ShowMaxValueTick | Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property.
ShowTicks | Gets or sets a value indicating whether the ticks are visible. This is a dependency property.
Step | Gets or sets the value between adjacent ticks and labels. This is a dependency property.
Stroke | Gets or sets the stroke brush of the ticks. This is a dependency property.
StrokeThickness | Gets or sets the thickness of tick strokes. This is a dependency property.
TickAlignment | Gets or sets the alignment of the ticks relative to the scale. This is a dependency property.
TickHeight | Gets or sets the height of a tick. This is a dependency property.
TickOffset | Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property.
TickShape | Gets or sets the shape of the ticks. This is a dependency property.
TickStyle | Gets or sets the Style to use for custom tick representation. This is a dependency property.
TickType | Gets the type of ticks this object applies to.
TickWidth | Gets or sets the width of a tick. This is a dependency property.

See Also

TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.Count Property

TickSettings.Count Property
[image]

Gets or sets the number of ticks and labels. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public int Count { get; set; }

Visual Basic [image] Copy Code

Public Property Count As Integer

Property Value

A positive integer value.

Remarks

This property is mutually exclusive with the Step property. If both are specified the Step property will take precedence.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
Step Property


MindFusion.Gauges.Silverlight.TickSettings.CustomIntervals Property

TickSettings.CustomIntervals Property
[image]

Gets or sets a collection with CustomInterval objects, which can be used to customize the appearance of the ticks in a particular interval. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public CustomIntervalCollection CustomIntervals { get; set; }

Visual Basic [image] Copy Code

Public Property CustomIntervals As CustomIntervalCollection

Property Value

An instance of the CustomIntervalCollection class.

Remarks

The custom intervals can be used to give specific appearance to the ticks within a particular range.

Example

The following example defines a linear scale. The major ticks of the scale in the range [60..100] are filled with a Red brush.

XAML [image] Copy Code

<gauges:LinearScale>
<gauges:LinearScale.MajorTickSettings>
<gauges:TickSettings>
<gauges:TickSettings.CustomIntervals>
<gauges:CustomInterval MinValue="60" Fill="Red" />
</gauges:TickSettings.CustomIntervals>
</gauges:TickSettings>
</gauges:LinearScale.MajorTickSettings>
</gauges:LinearScale>

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.Fill Property

TickSettings.Fill Property
[image]

Gets or sets the fill brush of the ticks. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

A .NET Brush object.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
Stroke Property
StrokeThickness Property


MindFusion.Gauges.Silverlight.TickSettings.FontSize Property

TickSettings.FontSize Property
[image]

Gets or sets the font size of the labels. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Length

Property Value

An instance of the Length structure.

Remarks

The font size of type Length so that it can be specified as a relative value.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
FontWeight Property


MindFusion.Gauges.Silverlight.TickSettings.FontWeight Property

TickSettings.FontWeight Property
[image]

Gets or sets the font weight of the labels. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public FontWeight FontWeight { get; set; }

Visual Basic [image] Copy Code

Public Property FontWeight As FontWeight

Property Value

A .NET FontWeight object.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
FontSize Property


MindFusion.Gauges.Silverlight.TickSettings.LabelAlignment Property

TickSettings.LabelAlignment Property
[image]

Gets or sets the alignment of the labels relative to the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Alignment LabelAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property LabelAlignment As Alignment

Property Value

A member of the Alignment enumeration.

Remarks

For more information on the effect of this property, check the Alignment enumeration.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
LabelOffset Property
LabelRotation Property


MindFusion.Gauges.Silverlight.TickSettings.LabelForeground Property

TickSettings.LabelForeground Property
[image]

Gets or sets the brush used to paint label texts. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Brush LabelForeground { get; set; }

Visual Basic [image] Copy Code

Public Property LabelForeground As Brush

Property Value

A .NET Brush object.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.LabelFormat Property

TickSettings.LabelFormat Property
[image]

Gets or sets the format for label texts.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public string LabelFormat { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFormat As String

Property Value

A standard numeric format string.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.LabelOffset Property

TickSettings.LabelOffset Property
[image]

Gets or sets the offset of the labels relative to their calculated position. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length LabelOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LabelOffset As Length

Property Value

An instance of the Length structure.

Remarks

In an oval scale positive offsets move elements towards the center of the scale and negative offsets move elements outwards. In a vertical linear scale positive offsets move elements to the left and negative offsets move elements to the right. In a horizontal linear scale positive offsets move elements to the top and negative offsets move elements to the bottom.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
LabelOffset Property
LabelRotation Property


MindFusion.Gauges.Silverlight.TickSettings.LabelRotation Property

TickSettings.LabelRotation Property
[image]

Gets or sets the rotation mode of the labels. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public LabelRotation LabelRotation { get; set; }

Visual Basic [image] Copy Code

Public Property LabelRotation As LabelRotation

Property Value

An instance of the LabelRotation enumeration.

Remarks

For more information on the effect of this property, check the LabelRotation enumeration.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
LabelAlignment Property
LabelOffset Property


MindFusion.Gauges.Silverlight.TickSettings.ShowLabels Property

TickSettings.ShowLabels Property
[image]

Gets or sets a value indicating whether the labels are visible. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public bool ShowLabels { get; set; }

Visual Basic [image] Copy Code

Public Property ShowLabels As Boolean

Property Value

true to show the labels; otherwise, false.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
ShowTicks Property


MindFusion.Gauges.Silverlight.TickSettings.ShowMaxValueTick Property

TickSettings.ShowMaxValueTick Property
[image]

Gets or sets a value indicating whether to display a tick for the MaxValue of the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public DisplayType ShowMaxValueTick { get; set; }

Visual Basic [image] Copy Code

Public Property ShowMaxValueTick As DisplayType

Property Value

true, to always show a tick for the max value of the scale; otherwise, false.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.ShowTicks Property

TickSettings.ShowTicks Property
[image]

Gets or sets a value indicating whether the ticks are visible. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public bool ShowTicks { get; set; }

Visual Basic [image] Copy Code

Public Property ShowTicks As Boolean

Property Value

true to show the ticks; otherwise, false.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
ShowLabels Property


MindFusion.Gauges.Silverlight.TickSettings.Step Property

TickSettings.Step Property
[image]

Gets or sets the value between adjacent ticks and labels. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double Step { get; set; }

Visual Basic [image] Copy Code

Public Property Step As Double

Property Value

A positive double value.

Remarks

This property is mutually exclusive with the Count property. If both are specified the Step property will take precedence.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
Count Property


MindFusion.Gauges.Silverlight.TickSettings.Stroke Property

TickSettings.Stroke Property
[image]

Gets or sets the stroke brush of the ticks. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

A .NET Brush object.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
StrokeThickness Property
Fill Property


MindFusion.Gauges.Silverlight.TickSettings.StrokeThickness Property

TickSettings.StrokeThickness Property
[image]

Gets or sets the thickness of tick strokes. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
Stroke Property
Fill Property


MindFusion.Gauges.Silverlight.TickSettings.TickAlignment Property

TickSettings.TickAlignment Property
[image]

Gets or sets the alignment of the ticks relative to the scale. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Alignment TickAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TickAlignment As Alignment

Property Value

A member of the Alignment enumeration.

Remarks

For more information on the effect of this property, check the Alignment enumeration.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
TickOffset Property


MindFusion.Gauges.Silverlight.TickSettings.TickHeight Property

TickSettings.TickHeight Property
[image]

Gets or sets the height of a tick. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length TickHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TickHeight As Length

Property Value

An instance of the Length structure.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
TickWidth Property


MindFusion.Gauges.Silverlight.TickSettings.TickOffset Property

TickSettings.TickOffset Property
[image]

Gets or sets the offset of he ticks relative to their calculated position. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length TickOffset { get; set; }

Visual Basic [image] Copy Code

Public Property TickOffset As Length

Property Value

An instance of the Length structure.

Remarks

In an oval scale positive offsets move elements towards the center of the scale and negative offsets move elements outwards. In a vertical linear scale positive offsets move elements to the left and negative offsets move elements to the right. In a horizontal linear scale positive offsets move elements to the top and negative offsets move elements to the bottom.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
TickAlignment Property


MindFusion.Gauges.Silverlight.TickSettings.TickShape Property

TickSettings.TickShape Property
[image]

Gets or sets the shape of the ticks. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public TickShape TickShape { get; set; }

Visual Basic [image] Copy Code

Public Property TickShape As TickShape

Property Value

A member of the TickShape enumeration.

Remarks

In order to use a custom shape for the ticks, set this property to Custom and assign the DataTemplate that will give the appearance of the ticks to the TickTemplate property.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.TickStyle Property

TickSettings.TickStyle Property
[image]

Gets or sets the Style to use for custom tick representation. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Style TickStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TickStyle As Style

Property Value

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.TickType Property

TickSettings.TickType Property
[image]

Gets the type of ticks this object applies to.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public TickType TickType { get; set; }

Visual Basic [image] Copy Code

Public Property TickType As TickType

Property Value

A member of the TickType enumeration.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.TickWidth Property

TickSettings.TickWidth Property
[image]

Gets or sets the width of a tick. This is a dependency property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public Length TickWidth { get; set; }

Visual Basic [image] Copy Code

Public Property TickWidth As Length

Property Value

An instance of the Length structure.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace
TickHeight Property


MindFusion.Gauges.Silverlight.TickSettings Events

TickSettings Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when a property value changes.

See Also

TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickSettings.PropertyChanged Event

TickSettings.PropertyChanged Event
[image]

Raised when a property value changes.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

TickSettings Members
TickSettings Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickShape Enumeration

TickShape Enumeration
[image]

Indicates the shape of a scale tick.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public enum TickShape

Visual Basic [image] Copy Code

Public Enum TickShape

Members

Member name | Description
Arrow1 | Specifies an arrow shape.
Arrow2 | Specifies an arrow shape.
Arrow3 | Specifies an arrow shape.
Custom | Specifies a custom shape.
Ellipse | Specifies an elliptical shape.
Line | Specifies a line as a shape.
None | Specifies an empty shape, that is, the tick is not displayed.
Rectangle | Specifies a rectangular shape.
Rhombus | Specifies a rhombus as a shape.
RoundRect | Specifies a rounded rectangle as a shape.
Triangle | Specifies a triangular shape.

Remarks

The values of this enumeration are assigned to the TickShape property of the TickSettings class.

See Also

MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.TickType Enumeration

TickType Enumeration
[image]

Indicates the type of a scale tick.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public enum TickType

Visual Basic [image] Copy Code

Public Enum TickType

Members

Member name | Description
Major | Specifies a major tick.
Middle | Specifies a middle tick.
Minor | Specifies a minor tick.
None | Specifies ticks of an unknown type.

See Also

MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ValueChangedEventArgs(T) Class

ValueChangedEventArgs(T) Class
[image]

Contains the arguments passed to value change notification handlers.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class ValueChangedEventArgs<T> : EventArgs

Visual Basic [image] Copy Code

Public Class ValueChangedEventArgs(Of T)
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Gauges.Silverlight.ValueChangedEventArgs(T)

See Also

ValueChangedEventArgs(T) Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ValueChangedEventArgs(T) Members

ValueChangedEventArgs(T) Members
Constructors Properties
[image]

Contains the arguments passed to value change notification handlers.

The following tables list the members exposed by the ValueChangedEventArgs(T) type.

Public Constructors

Name | Description
ValueChangedEventArgs | Overloaded. Initializes a new instance of the ValueChangedEventArgs class.

Public Properties

Name | Description
NewValue | Gets the new value of the changed property.
OldValue | Gets the previous value of the changed property.

See Also

ValueChangedEventArgs(T) Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ValueChangedEventArgs(T) Constructor

ValueChangedEventArgs(T) Constructor
[image]

Initializes a new instance of the ValueChangedEventArgs class.

Overload List

Name | Description
ValueChangedEventArgs(T) () | Initializes a new instance of the ValueChangedEventArgs class.
ValueChangedEventArgs(T) (T, T) | Initializes a new instance of the ValueChangedEventArgs class.

See Also

ValueChangedEventArgs(T) Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ValueChangedEventArgs(T) Constructor ()

ValueChangedEventArgs(T) Constructor ()
See Also
[image]

Initializes a new instance of the ValueChangedEventArgs class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public ValueChangedEventArgs<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

ValueChangedEventArgs(T) Constructor Overload List
ValueChangedEventArgs(T) Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ValueChangedEventArgs(T) Constructor (T, T)

ValueChangedEventArgs(T) Constructor (T, T)
See Also
[image]

Initializes a new instance of the ValueChangedEventArgs class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public ValueChangedEventArgs<T> (
T oldValue,
T newValue
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
oldValue As T, _
newValue As T _
)

Parameters

oldValue

The previous value of the changed property.

newValue

The new value of the changed property.

See Also

ValueChangedEventArgs(T) Constructor Overload List
ValueChangedEventArgs(T) Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ValueChangedEventArgs(T) Properties

ValueChangedEventArgs(T) Properties
[image]

Public Properties

Name | Description
NewValue | Gets the new value of the changed property.
OldValue | Gets the previous value of the changed property.

See Also

ValueChangedEventArgs(T) Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ValueChangedEventArgs(T).NewValue Property

ValueChangedEventArgs(T).NewValue Property
[image]

Gets the new value of the changed property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public T NewValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewValue As T

Property Value

See Also

ValueChangedEventArgs(T) Members
ValueChangedEventArgs(T) Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ValueChangedEventArgs(T).OldValue Property

ValueChangedEventArgs(T).OldValue Property
[image]

Gets the previous value of the changed property.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public T OldValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldValue As T

Property Value

See Also

ValueChangedEventArgs(T) Members
ValueChangedEventArgs(T) Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.ValueChangedEventHandler(T) Delegate

ValueChangedEventHandler(T) Delegate
[image]

Represents the method that will handle value change notification events.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public delegate void ValueChangedEventHandler<T> (
Object sender,
ValueChangedEventArgs<T> e
)

Visual Basic [image] Copy Code

Public Delegate Sub ValueChangedEventHandler(Of T) ( _
sender As Object, _
e As ValueChangedEventArgs(Of T) _
)

Parameters

sender

The source of the event.

e
A ValueChangedEventArgs<T> that contains the event data.

See Also

MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.VisibilityConverter Class

VisibilityConverter Class
Remarks See Also
[image]

Converts boolean values to Visibility and vice versa.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public class VisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class VisibilityConverter
Implements IValueConverter

Remarks

This converter can be useful when you need to bind properties of type Visibility to boolean values.

Inheritance Hierarchy

System.Object
MindFusion.Gauges.Silverlight.VisibilityConverter

See Also

VisibilityConverter Members
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.VisibilityConverter Members

VisibilityConverter Members
Constructors Methods
[image]

Converts boolean values to Visibility and vice versa.

The following tables list the members exposed by the VisibilityConverter type.

Public Constructors

Name | Description
VisibilityConverter | Initializes a new instance of the VisibilityConverter class.

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

VisibilityConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.VisibilityConverter Constructor

VisibilityConverter Constructor
[image]

Initializes a new instance of the VisibilityConverter class.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public VisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisibilityConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.VisibilityConverter Methods

VisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | IValueConverter.Convert implementation.
ConvertBack | IValueConverter.ConvertBack implementation.

See Also

VisibilityConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.VisibilityConverter.Convert Method

VisibilityConverter.Convert Method
[image]

IValueConverter.Convert implementation.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public virtual Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

VisibilityConverter Members
VisibilityConverter Class
MindFusion.Gauges.Silverlight Namespace


MindFusion.Gauges.Silverlight.VisibilityConverter.ConvertBack Method

VisibilityConverter.ConvertBack Method
[image]

IValueConverter.ConvertBack implementation.

Namespace: MindFusion.Gauges.Silverlight
Assembly: MindFusion.Gauges.Silverlight

Syntax

C# [image] Copy Code

public virtual Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Overridable Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

The value produced by the binding source.

targetType

The type of the binding target property.

parameter

The converter parameter to use.

culture

The culture to use in the converter.

Return Value

A converted value. If the method returns null, the valid null value is used.

See Also

VisibilityConverter Members
VisibilityConverter Class
MindFusion.Gauges.Silverlight Namespace


Technical Support

Technical Support


MindFusion Products

MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming | Links
Diagramming for WPF | Product Information Download
Diagramming for Silverlight | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for .NET Compact | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download

Charting | Links
Charting for WPF | Product Information Download
Charting for Silverlight | Product Information Download
Charting for WinForms | Product Information Download
Charting for ASP.NET | Product Information Download

Scheduling | Links
Scheduling for WinForms | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for .NET Compact | Product Information Download
Scheduling for WPF | Product Information Download
Scheduling for Silverlight | Product Information Download
Scheduling for Java Swing | Product Information Download

Reporting | Links
Reporting for WinForms | Product Information Download
Reporting for WPF | Product Information Download
Reporting for Silverlight | Product Information Download

Mapping | Links
Mapping for WinForms | Product Information Download
Mapping for WPF | Product Information Download
Mapping for Silverlight | Product Information Download

Suites | Links
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Java FX | Product Information Download
Pack for Scheduling | Product Information Download
Pack for Silverlight | Product Information Download