Introduction

MindFusion.Mapping Programmer's Guide
Introduction

MindFusion.Mapping comprises a Windows Forms control and a class library that provides your application with great features for loading, customizing and displaying any type of regional, national or world map. Easy to integrate and program, this control gives you the power to build the perfect map according to your needs with minimal time and efforts from your side. You can:

  • add labels to map elements
  • access database data associated with map elements
  • choose the color scheme
  • set decorative elements like images, icons etc.

Map data can be loaded from the popular ESRI Shapefile format and you have at your disposal an impressive variety of *.shp files, which give you valuable data for any country in the world as well for selected cities, rivers, roads and other geographic objects. Data for the attributes of map elements can be loaded from a DBF file associated with each map. It's also possible to load OpenStreetMap XML files to display city and road maps. The control supports multiple layers so you can show several maps in a single view.

MindFusion.Mapping is installed with various samples in C# and VB.NET that demonstrate all important features of the control and significantly shorten the time needed to learn how to use it. The help file also includes step-by-step guides and tutorials. The API is documented in details and both offline and online documentation is provided. The control and the map files included in the package are royalty free.

© 2015 MindFusion


What's New in this Release

What's New in this Release

The list below describes recent changes and additions to MindFusion.Mapping for Windows Forms:

New in version 2

Street maps

You can render street maps in OpenStreetMap format by adding a StreetMapLayer instance to the MapView. In order to load a street map, create a new StreetMapLayer object and call its Map's LoadFromXml method to load the corresponding *.osm file. The pens and brushes used for drawing the map are stored within the StreetMapPens and StreetMapBrushes collections in the static StreetMapFeatures class. You can define additional pens and brushes for drawing and painting certain map features by using the StreetMapLayer's AddPen and AddBrush methods.

Zoom control

The ZoomControl class lets user change interactively the current zoom level and scroll position of a MapView. To set it up, add a ZoomControl to the form, place it anywhere over a MapView, and set the control's Target property to that view. Set the ZoomStep and ScrollStep properties to specify the amount added to view's zoom level or scroll position by ZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, BorderColor, CornerRadius and TickPosition.

Multiple selection

Now it's possible to select multiple decorations or map shapes by drawing a selection rectangle. To enable that, set the Behavior property to Select. Selected elements are stored in the Selection collection of respective layer objects.

API changes

  • The type of MapElement's Label property has been changed from string to Label class. The FontName and FontSize properties have been moved from MapElement to Label.
  • Type of Layers property changed from List to ObservableCollection.


Licensing

Licensing

There are no separate trial builds of MindFusion assemblies. When you purchase a component you can find the license key for this component listed on the Keys & Donwloads page at the customer's portal [image] . Assign this license key to the LicenseKey property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one MindFusion component, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) method from application start-up code to specify the key once instead of setting it per each control.


Tutorials

Tutorials


Getting Started

Getting Started

This topic provides you with a detailed and easy step-by-step instructions on how to create your first map from a *.shp and a *.dbf file.

1. Add the MindFusion.Mapping.WinForms component to the VisualStudio toolbox.

1.1 Create a new WinForms project in Microsoft VisualStudio.

1.2 Open the main form in Design view, richt click the Toolbox and select 'Choose Items...' Navigate to the folder, which contains the MindFusion.Mapping.WinForms assembly for your chosen .NET version. It is usually of type "C:\Program Files\MindFusion\MindFusion.Mapping for WinForms\VS2010 (.NET 4.0)". Select the assembly and click "OK" - the MapView component should appear in the Toolbox.

2. Set the map.

2.1 In the code behind file for your form use the BaseMap property of the MapView object you created in step 1.2.

VB.NET [image] Copy Code

mapView.BaseMap = Map.FromFile("C:\Maps\countries_level_1\Bulgaria.shp", True, "NAME_1")

Here we set the first parameter designates the location of the *.shp file from where we load the map. The second parameter tells the control that a corresponding database file is also present and should be loaded. The third parameter gives precise instructions on the name of the column in the *.dbf file, whose fields should be used as map element labels.

3. Set the colors and draw the map.

3.1 Call the AssignColors method that will paint your map in such a way that no two adjacant polygons will have the same color:

C# [image] Copy Code

mapView.BaseMap.AssignColors();
mapView.Invalidate();

VB.NET [image] Copy Code

mapView.BaseMap.AssignColors()
mapView.Invalidate()

4. Compile and run the project. By now you must have a map displayed in the MapView control.


Implementing Drag and Drop

Implementing Drag and Drop

This topic provides you with a detailed step-by-step guide on how to implement drag and drop functionality in your map.

1. Create a map. For detailed instructions how to do it, please read the "Getting Started" topic.

2. Prepare the list with the images to drag and drop.

2.1 Click on the ListView control in the Toobox panel in Visual Studio while in Design view. Place the control at the desired location in your form and size it according to your needs.

2.2. Create a folder named "Images" in your project. Add the images for the drag and drop there with the "Add existing item" command.

2.3 Initialize a strongly typed List<image> that will hold all the images. Write the following line in the code-behind class of the form that holds the MapView control and the ListView with the images:

C# [image] Copy Code

List<Image> images = new List<Image>();

VB.NET [image] Copy Code

Dim images As New List(Of Image)()

2.4 Load the images from your directory and add them as ListViewItem-s in your ListView control:

C# [image] Copy Code

// load images
var imgFolder = new DirectoryInfo("Images");

//create a list that will hold the images
var imgList = lvImages.LargeImageList = new ImageList();

//set the image size
imgList.ImageSize = new Size(32, 32);

//loop through all loaded image files
foreach (var imgFile in imgFolder.GetFiles())
{
//add each image to the ImageList
var image = Image.FromFile(imgFile.FullName);
images.Add(image);

//create a ListViewItem from each image
var item = new ListViewItem(
Path.GetFileNameWithoutExtension(imgFile.Name),
imgList.Images.Count);

//add the Image to the image list
imgList.Images.Add(image);

//add the ListBoxItem to the ListBox
lvImages.Items.Add(item);
}

//set a proper view for the ListView control
lvImages.View = View.Tile;

//create a DecorationLayer over the MapView control
//that will draw the images
decorationLayer = new DecorationLayer(map.BoundingBox);
mapView.Layers.Add(decorationLayer);
mapView.Focus();

VB.NET [image] Copy Code

' load images
Dim imgFolder = New DirectoryInfo("Images")

'create a list that will hold the images
Dim imgList = InlineAssignHelper(lvImages.LargeImageList, New ImageList())

'set the image size
imgList.ImageSize = New Size(32, 32)

'loop through all loaded image files
For Each imgFile As var In imgFolder.GetFiles()
'add each image to the ImageList
Dim image__1 = Image.FromFile(imgFile.FullName)
images.Add(image__1)

'create a ListViewItem from each image
Dim item = New ListViewItem(Path.GetFileNameWithoutExtension(imgFile.Name), imgList.Images.Count)

'add the Image to the image list
imgList.Images.Add(image__1)

'add the ListBoxItem to the ListBox
lvImages.Items.Add(item)
Next

'set a proper view for the ListView control
lvImages.View = View.Tile

'create a DecorationLayer over the MapView control
'that will draw the images
decorationLayer = New DecorationLayer(map.BoundingBox)
mapView.Layers.Add(decorationLayer)
mapView.Focus()

3. Add event handler for the ItemDrag event of the ListView control.

C# [image] Copy Code

this.lvImages.ItemDrag += new System.Windows.Forms.ItemDragEventHandler(this.lvImages_ItemDrag);

VB.NET [image] Copy Code

Me.lvImages.ItemDrag += New System.Windows.Forms.ItemDragEventHandler(Me.lvImages_ItemDrag)

3.1 Provide the event with data about the index of the image being dragged.

C# [image] Copy Code

private void lvImages_ItemDrag(object sender, ItemDragEventArgs e)
{
DoDragDrop(lvImages.SelectedIndices[0], DragDropEffects.Copy);
}

VB.NET [image] Copy Code

Private Sub lvImages_ItemDrag(sender As Object, e As ItemDragEventArgs)
DoDragDrop(lvImages.SelectedIndices(0), DragDropEffects.Copy)
End Sub

4. Handle the DragOver event of the MapView.

C# [image] Copy Code

this.mapView.DragOver += new System.Windows.Forms.DragEventHandler(this.mapView_DragOver);

VB.NET [image] Copy Code

Me.mapView.DragOver += New System.Windows.Forms.DragEventHandler(Me.mapView_DragOver)

4.1 Get the location where the image is about to be dropped and if that's a valid location - copy there the file:

C# [image] Copy Code

private void mapView_DragOver(object sender, DragEventArgs e)
{
//get the client coordinates of the specified screen point
var clientPoint = mapView.PointToClient(new Point(e.X, e.Y));

//get the map coordinates of the specified client point
var geoLocation = mapView.ClientToMap(clientPoint);

//get the region where the item will be dropped
var province = mapView.BaseMap.HitTest(geoLocation);

//copy the dragged image into the specified province
e.Effect = province != null ? DragDropEffects.Copy : DragDropEffects.None;
}

VB.NET [image] Copy Code

Private Sub mapView_DragOver(sender As Object, e As DragEventArgs)
'get the client coordinates of the specified screen point
Dim clientPoint = mapView.PointToClient(New Point(e.X, e.Y))

'get the map coordinates of the specified client point
Dim geoLocation = mapView.ClientToMap(clientPoint)

'get the region where the item will be dropped
Dim province = mapView.BaseMap.HitTest(geoLocation)

'copy the dragged image into the specified province
e.Effect = If(province IsNot Nothing, DragDropEffects.Copy, DragDropEffects.None)
End Sub

5. Handle the DragDrop event of the MapView.

C# [image] Copy Code

this.mapView.DragDrop += new System.Windows.Forms.DragEventHandler(this.mapView_DragDrop);

VB.NET [image] Copy Code

Me.mapView.DragDrop += New System.Windows.Forms.DragEventHandler(Me.mapView_DragDrop)

5.1 Create a DecorationImage together with a label and place it at the location where it has been dropped.

C# [image] Copy Code

private void mapView_DragDrop(object sender, DragEventArgs e)
{
//get the client coordinate of the specified screen coordinate
var clientPoint = mapView.PointToClient(new Point(e.X, e.Y));

//get the map coordinate of the specified client coordinate
var geoLocation = mapView.ClientToMap(clientPoint);

//check if the drop location is a valid region
var region = mapView.BaseMap.HitTest(geoLocation);

//if this is valid region the image must be copied
e.Effect = region != null ? DragDropEffects.Copy : DragDropEffects.None;

if (region != null)
{
//get the index of the image
int index = (int)e.Data.GetData(typeof(Int32));

//create a DecorationImage to add to the DecorationLayer
var decoration = new DecorationImage(
images[index], geoLocation.Y, geoLocation.X);

//set the label
decoration.Label = lvImages.Items[index].Text +
" in " + region.DatabaseRow["NAME_1"];

//add the image
decorationLayer.Decorations.Add(decoration);

//repaint the map
mapView.Invalidate();
}
}

VB.NET [image] Copy Code

Private Sub mapView_DragDrop(sender As Object, e As DragEventArgs)
'get the client coordinate of the specified screen coordinate
Dim clientPoint = mapView.PointToClient(New Point(e.X, e.Y))

'get the map coordinate of the specified client coordinate
Dim geoLocation = mapView.ClientToMap(clientPoint)

'check if the drop location is a valid region
Dim region = mapView.BaseMap.HitTest(geoLocation)

'if this is valid region the image must be copied
e.Effect = If(region IsNot Nothing, DragDropEffects.Copy, DragDropEffects.None)

If region IsNot Nothing Then
'get the index of the image
Dim index As Integer = CInt(e.Data.GetData(GetType(Int32)))

'create a DecorationImage to add to the DecorationLayer
Dim decoration = New DecorationImage(images(index), geoLocation.Y, geoLocation.X)

'set the label
decoration.Label = lvImages.Items(index).Text + " in " + region.DatabaseRow("NAME_1")

'add the image
decorationLayer.Decorations.Add(decoration)

'repaint the map
mapView.Invalidate()
End If
End Sub

6. By now you must have working drag and drop functionality in your map from the kind shown below:


Adding Tooltips

Adding Tooltips

This topic gives you detailed step-by-step instructions on how to add tooltips in your map. The tooltips are displayed when the mouse is over a region in the map.

1. Create a WinForms project and add the MapView control as described in the "Getting Started" section.

2. Add event handler for the MapElementHover event of your MapView instance.

C# [image] Copy Code

this.mapView.MapElementHover += new System.EventHandler<MindFusion.Mapping.WinForms.MapEventArgs>(this.mapView_MapElementHover);

VB.NET [image] Copy Code

AddHandler mapView.MapElementHover, AddressOf Me.mapView_MapElementHover

3. Add a System.Windows.Forms.ToolTip instance somewhere in the code behind file.

C# [image] Copy Code

ToolTip toolTip = new ToolTip();

VB.NET [image] Copy Code

Dim toolTip As ToolTip = New ToolTip

4. Handle the MapElementHover event - get the region under the mouse, construct and display the tooltip.

C# [image] Copy Code

private void mapView_MapElementHover(object sender, MapEventArgs e)
{
//get the region under the mouse
var region = e.MapElement as Shape;

if (region != null)
{
//remove any previous tooltip
if (toolTip != null)
toolTip.Dispose();

//Gets the DBF database row associated with the region
var name = region.DatabaseRow["NAME_1"];

//get the client coordinates of the mouse position
var point = mapView.PointToClient(MousePosition);

//initialize the tooltip
toolTip = new ToolTip();
toolTip.Show(name, mapView, point.X, point.Y + 20, 1000);
}
}

VB.NET [image] Copy Code

Private Sub mapView_MapElementHover(ByVal sender As Object, ByVal e As MapEventArgs)
'get the region under the mouse
Dim region As var = CType(e.MapElement,Shape)
If (Not (region) Is Nothing) Then
'remove any previous tooltip
If (Not (toolTip) Is Nothing) Then
toolTip.Dispose
End If
'Gets the DBF database row associated with the region
Dim name As var = region.DatabaseRow("NAME_1")
'get the client coordinates of the mouse position
Dim point As var = mapView.PointToClient(MousePosition)
'initialize the tooltip
toolTip = New ToolTip
toolTip.Show(name, mapView, point.X, (point.Y + 20), 1000)
End If
End Sub

5. Compile and run your project. By now you must have working tooltips.


Programming Interface Overview

Programming Interface Overview


Loading Map Files

Loading Map Files

Maps in the MidnFusion.Mapping library are represented by the Map class. Its LoadFromFile method can load map data from files in the ESRI Shapefile format. Shapefiles come with an associated DBF database, that can provide various attribute values for the map elements. To load the DBF database along with the main map file, set the loadDatabase parameter of LoadFromFile to true. The loaded database can be accessed via the Database property, and each record associated with a map element is exposed via the DatabaseRow property of the Shape class.

To display a map once it is loaded, assign it to the BaseMap property of the MapView control, or add a new MapLayer to the view and assign the map to its Map property.


Map Layers

Map Layers

The MapView control can display several map and decoration layers. In order to add a new layer, create a MapLayer or DecorationLayer instance and add it to the Layers collection of the view. Assigning a map to the BaseMap property is a shortcut to creating a MapLayer, setting it as the first layer in the view and setting its Map property to the specified value.

Visibility of individual layers can be set through their Visible property. In addition, you can turn on or off interactive selection and highlighting in a layer by setting the EnableHighlight and EnableSelection properties. Even if interactive support is disabled, map elements can still be selected or highlighted programmatically by calling the Select or Highlight methods of the Layer class.

The following excerpt from the Layers sample project shows how to add several map layers displaying different maps:

C# [image] Copy Code

// load base map
var layer0 = new MapLayer();
layer0.Visible = true;
layer0.Map = new Map();
layer0.Map.LoadFromFile(FindMap("ne_50m_admin_0_countries.shp"));

mapView.Layers.Add(layer0);

// load urban areas map
var layer1 = new MapLayer();
layer1.Visible = false;
layer1.LineColor = Color.Yellow;
layer1.FillColors[0] = Color.Yellow;
layer1.Map = new Map();
layer1.Map.LoadFromFile(FindMap("ne_50m_urban_areas.shp"));

mapView.Layers.Add(layer1);

// load rivers map
var layer2 = new MapLayer();
layer2.Visible = false;
layer2.LineColor = Color.Blue;
layer2.Map = new Map();
layer2.Map.LoadFromFile(FindMap("50m_rivers_lake_centerlines.shp"));

mapView.Layers.Add(layer2);


Street Maps

Street Maps

You can render street maps in OpenStreetMap format by adding a StreetMapLayer instance to the MapView. In order to load an OSM map, create a new StreetMapLayer object and call its Map's LoadFromXml method to load the corresponding *.osm file. This is demonstrated in following excerpt from the StreetMaps sample project:

C# [image] Copy Code
var streetLayer = new StreetMapLayer();
streetLayer.Map = new Map();
streetLayer.Map.LoadFromXml(fileName);
mapView.Layers.Add(streetLayer);

The pens and brushes used for drawing the map are stored within the StreetMapPens and StreetMapBrushes collections in the static StreetMapFeatures class. You can define additional pens and brushes for drawing and painting certain map features by using the StreetMapLayer's AddPen and AddBrush methods. If their MapFeature parameter specifies a key but not a value, the pen or brush parameters will be applied to all features with associated key. For a list of standard key and value identifiers of map features, see http://wiki.openstreetmap.org/wiki/Map_Features [image] .


Customizing The Map

Customizing The Map

Maps can be customized by assigning labels to the map elements, by specifying new colors, or by adding decoration images.

To set an element's label, assign to the Label property of MapElement. The label is diplayed using the font set through the FontName and FontSize properties. Note that labels can be automatically loaded from a Shapefile database by passing a column name as third argument of the LoadFromFile method.

Colors of map elements can be set via the Color property of the Shape class. This property specifies an index within the layer's palette. The palette colors can be customized via the FillColors property of the Layer class. By default, all shapes are painted using the same color. The AssignColors method lets you automatically assign colors in such a way that no adjacent shapes share the same color.


Decorations

Decorations

Decorations can be displayed by adding a DecorationLayer to the MapView. At this time there are two kinds of built-in decorations supported, DecorationImage and DecorationBubble.

DecorationImage can display a bitmap image at the specified latitude and longitude. This is useful if you need to show an icon (e.g denoting a landmark or a kind of business object) located there. The image is set via the Image property. You can specify an additional image through the HighlightImage property, which is drawn over the main image when the decoration is highlighted or selected. The PivotX and PivotY properties lets you specify the exact pixel within the image that should be placed at the decoration's map location. Decoration images can also have an associated Label drawn below them.

DecorationBubble is used to drawn a circle at the specified latitude and longitude. The circle radius length can be set proportionally to some statistical value associated with the location, for example population or income. The circle can be customized by setting its Label, FontName, FontSize, FillColor and BorderColor properties.

The following excerpt from the Markers sample project shows how to add a decoration layer and decoration images to the map view:

C# [image] Copy Code

// add a second layer to display decoration objects
var decorationLayer = new DecorationLayer(mapView.BaseMap.BoundingBox);
mapView.Layers.Add(decorationLayer);

// create decoration images
foreach (var landmark in landmarks)
{
var img = new DecorationImage(
Image.FromFile(@"Images\" + landmark.Image),
landmark.ImageX, landmark.ImageY,
landmark.Latitude, landmark.Longitude);
img.Label = landmark.Label;
decorationLayer.Decorations.Add(img);
}


Scrolling and Zooming

Scrolling and Zooming

The map view can be panned interactively by dragging it with the mouse. The user can also zoom into or out of the map via the mouse wheel. To implement a different scroll or zoom interaction logic, you can use the properties and methods exposed by MapView from various input event handlers. In order to change the scroll position, call the ScrollTo method. In order to change the zoom level, set the ZoomFactor property or call the SetZoomFactor method.

The following excerpt from the Markers sample project shows how to center the view on a specific decoration object:

C# [image] Copy Code

mapView.ZoomFactor = 6;

// office is a reference to a DecorationBubble instance
mapView.ScrollTo(office.Latitude, office.Longitude);

// focus is necessary in order to receive mouse wheel events
mapView.Focus();

Zoom control

Zoom level and scroll position of MapView can also be changed using the dedicated ZoomControl widget. To set it up, add a ZoomControl to the form, place it anywhere over a MapView, and set the control's Target property to that view. Set the ZoomStep and ScrollStep properties to specify the amount added to view's zoom level or scroll position by ZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, BorderColor, CornerRadius and TickPosition.


Drag and Drop

Drag and Drop

Drag and drop from or to the map can be implemented using the standard Windows Forms drag and drop API. You will only need to convert between map and screen coordinates where appropriate, and probably use hit-testing methods to find what map element is under the mouse pointer. Use the MapToClient and ClientToMap methods to convert location latitude/longitude coordinates to or from pixel coordinates. Use the HitTest method of the Map class to find out what map element lies at the mouse position.

The following excerpt from the Palette sample project demonstrates how to add DecorationImage objects for images dragged from a ListView to the MapView:

C# [image] Copy Code

private void mapView_DragOver(object sender, DragEventArgs e)
{
var clientPoint = mapView.PointToClient(new Point(e.X, e.Y));
var geoLocation = mapView.ClientToMap(clientPoint);
var state = mapView.BaseMap.HitTest(geoLocation);

e.Effect = state != null ? DragDropEffects.Copy : DragDropEffects.None;
}

private void mapView_DragDrop(object sender, DragEventArgs e)
{
var clientPoint = mapView.PointToClient(new Point(e.X, e.Y));
var geoLocation = mapView.ClientToMap(clientPoint);
var state = mapView.BaseMap.HitTest(geoLocation);

e.Effect = state != null ? DragDropEffects.Copy : DragDropEffects.None;

if (state != null)
{
int index = (int)e.Data.GetData(typeof(Int32));
var decoration = new DecorationImage(
images[index], geoLocation.Y, geoLocation.X);
decoration.Label = lvImages.Items[index].Text +
" in " + state.DatabaseRow["NAME_1"];
decorationLayer.Decorations.Add(decoration);
mapView.Invalidate();
}
}


Reference

Reference


MindFusion.Common.WinForms Namespace

MindFusion.Common.WinForms Namespace
Classes Interfaces Enumerations

Classes

Class | Description
ScrollArrowEventArgs | Contains arguments for the ScrollArrowClicked event.
ZoomControl | ZoomControl lets users zoom and pan a target component interactively.

Interfaces

Interface | Description
IZoomTarget | Specifies the capabilities required by ZoomControl from its target controls.

Enumerations

Enumeration | Description
ScrollDirection | Identifies the direction of a scroll arrow.
TickPosition | Specifies the position of trackbar ticks.


MindFusion.Common.WinForms.IZoomTarget Interface

IZoomTarget Interface
See Also
[image]

Specifies the capabilities required by ZoomControl from its target controls.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public interface IZoomTarget

Visual Basic [image] Copy Code

Public Interface IZoomTarget

Inheritors

MindFusion.Mapping.WinForms.MapView

See Also

IZoomTarget Members
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget Members

IZoomTarget Members
Properties Methods Events
[image]

Specifies the capabilities required by ZoomControl from its target controls.

The following tables list the members exposed by the IZoomTarget type.

Public Properties

Name | Description
IsDrawing | Gets or sets a value indicating whether the zoom target is currently being painted by the zoom control.

Public Methods

Name | Description
GetScrollX | Gets the horizontal scroll position.
GetScrollY | Gets the vertical scroll position.
GetZoomLevel | Gets the current zoom level.
SetScrollX | Sets the horizontal scroll position.
SetScrollY | Sets the vertical scroll position.
SetZoomLevel | Sets a new zoom level.

Public Events

Name | Description
ViewChanged | Raised to notify that the target view has changed.
ZoomLevelChanged | Raised to notify that the target's zoom level has changed.

See Also

IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget Methods

IZoomTarget Methods
[image]

Public Methods

Name | Description
GetScrollX | Gets the horizontal scroll position.
GetScrollY | Gets the vertical scroll position.
GetZoomLevel | Gets the current zoom level.
SetScrollX | Sets the horizontal scroll position.
SetScrollY | Sets the vertical scroll position.
SetZoomLevel | Sets a new zoom level.

See Also

IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget.GetScrollX Method

IZoomTarget.GetScrollX Method
[image]

Gets the horizontal scroll position.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

float GetScrollX ()

Visual Basic [image] Copy Code

Function GetScrollX () As Single

Return Value

A float value specifying the horizontal scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget.GetScrollY Method

IZoomTarget.GetScrollY Method
[image]

Gets the vertical scroll position.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

float GetScrollY ()

Visual Basic [image] Copy Code

Function GetScrollY () As Single

Return Value

A float value specifying the vertical scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget.GetZoomLevel Method

IZoomTarget.GetZoomLevel Method
[image]

Gets the current zoom level.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

float GetZoomLevel ()

Visual Basic [image] Copy Code

Function GetZoomLevel () As Single

Return Value

A float value specifying the zoom level.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget.SetScrollX Method

IZoomTarget.SetScrollX Method
[image]

Sets the horizontal scroll position.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

void SetScrollX (
float scrollX
)

Visual Basic [image] Copy Code

Sub SetScrollX( _
scrollX As Single _
)

Parameters

scrollX

A float value specifying the horizontal scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget.SetScrollY Method

IZoomTarget.SetScrollY Method
[image]

Sets the vertical scroll position.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

void SetScrollY (
float scrollY
)

Visual Basic [image] Copy Code

Sub SetScrollY( _
scrollY As Single _
)

Parameters

scrollY

A float value specifying the vertical scroll position.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget.SetZoomLevel Method

IZoomTarget.SetZoomLevel Method
[image]

Sets a new zoom level.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

void SetZoomLevel (
float zoom
)

Visual Basic [image] Copy Code

Sub SetZoomLevel( _
zoom As Single _
)

Parameters

zoom

A float value specifying the zoom level.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget Properties

IZoomTarget Properties
[image]

Public Properties

Name | Description
IsDrawing | Gets or sets a value indicating whether the zoom target is currently being painted by the zoom control.

See Also

IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget.IsDrawing Property

IZoomTarget.IsDrawing Property
[image]

Gets or sets a value indicating whether the zoom target is currently being painted by the zoom control.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

bool IsDrawing { get; set; }

Visual Basic [image] Copy Code

Property IsDrawing As Boolean

Property Value

true if ZoomControl is drawing, or false otherwise.

Remarks

This is set when ZoomControl's background is transparent and it needs to draw the target control behind it.

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget Events

IZoomTarget Events
[image]

Public Events

Name | Description
ViewChanged | Raised to notify that the target view has changed.
ZoomLevelChanged | Raised to notify that the target's zoom level has changed.

See Also

IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget.ViewChanged Event

IZoomTarget.ViewChanged Event
[image]

Raised to notify that the target view has changed.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

event EventHandler ViewChanged

Visual Basic [image] Copy Code

Event ViewChanged As EventHandler

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.IZoomTarget.ZoomLevelChanged Event

IZoomTarget.ZoomLevelChanged Event
[image]

Raised to notify that the target's zoom level has changed.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

event EventHandler ZoomLevelChanged

Visual Basic [image] Copy Code

Event ZoomLevelChanged As EventHandler

See Also

IZoomTarget Members
IZoomTarget Interface
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ScrollArrowEventArgs Class

ScrollArrowEventArgs Class
[image]

Contains arguments for the ScrollArrowClicked event.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public class ScrollArrowEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ScrollArrowEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Common.WinForms.ScrollArrowEventArgs

See Also

ScrollArrowEventArgs Members
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ScrollArrowEventArgs Members

ScrollArrowEventArgs Members
Constructors Properties
[image]

Contains arguments for the ScrollArrowClicked event.

The following tables list the members exposed by the ScrollArrowEventArgs type.

Public Constructors

Name | Description
ScrollArrowEventArgs | Initializes a new instance of the ScrollArrowEventArgs class.

Public Properties

Name | Description
Direction | Specifies which arrow button has been clicked.

See Also

ScrollArrowEventArgs Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ScrollArrowEventArgs Constructor

ScrollArrowEventArgs Constructor
[image]

Initializes a new instance of the ScrollArrowEventArgs class.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public ScrollArrowEventArgs (
ScrollDirection p
)

Visual Basic [image] Copy Code

Public New ( _
p As ScrollDirection _
)

Parameters

p

A member of the ScrollDirection enumeration.

See Also

ScrollArrowEventArgs Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ScrollArrowEventArgs Properties

ScrollArrowEventArgs Properties
[image]

Public Properties

Name | Description
Direction | Specifies which arrow button has been clicked.

See Also

ScrollArrowEventArgs Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ScrollArrowEventArgs.Direction Property

ScrollArrowEventArgs.Direction Property
[image]

Specifies which arrow button has been clicked.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public ScrollDirection Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As ScrollDirection

Property Value

A member of the ScrollDirection enumeration.

See Also

ScrollArrowEventArgs Members
ScrollArrowEventArgs Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ScrollDirection Enumeration

ScrollDirection Enumeration
[image]

Identifies the direction of a scroll arrow.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public enum ScrollDirection

Visual Basic [image] Copy Code

Public Enum ScrollDirection

Members

Member name | Description
Bottom | Scroll to the bottom.
Left | Scroll to the left.
Right | Scroll to the right.
Top | Scroll to the top.

See Also

MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.TickPosition Enumeration

TickPosition Enumeration
[image]

Specifies the position of trackbar ticks.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public enum TickPosition

Visual Basic [image] Copy Code

Public Enum TickPosition

Members

Member name | Description
Both | Ticks are rendered on both sides of the trackbar.
Left | Ticks are rendered on the left side of the trackbar.
None | There are no ticks rendered.
Right | Ticks are rendered on the right side of the trackbar.

See Also

MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl Class

ZoomControl Class
Remarks See Also
[image]

ZoomControl lets users zoom and pan a target component interactively.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public class ZoomControl : UserControl

Visual Basic [image] Copy Code

Public Class ZoomControl
Inherits UserControl

Remarks

The ZoomControl class lets user change interactively the current zoom level and scroll position of a DiagramView or MapView. To set it up, add a ZoomControl to the form, place it anywhere over the target view, and set the control's Target property to that view. Set the ZoomStep and ScrollStep properties to specify the amount added to view's zoom level or scroll position by ZoomControl's buttons. You can customize the control's appearance by setting properties such as Fill, BorderColor, CornerRadius and TickPosition.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.UserControl
MindFusion.Common.WinForms.ZoomControl

See Also

ZoomControl Members
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl Members

ZoomControl Members
Constructors Properties Methods Events
[image]

ZoomControl lets users zoom and pan a target component interactively.

The following tables list the members exposed by the ZoomControl type.

Public Constructors

Name | Description
ZoomControl | Initializes a new instance of the ZoomControl class.

Public Properties

Name | Description
ActiveColor | Gets or sets the color used to render depressed buttons.
BorderColor | Gets or sets the color of ZoomControl elements' borders.
CornerRadius | Gets or sets the corner radius of rounded child elements.
Fill | Gets or sets the brush used to fill the ZoomControl elements.
InnerColor | Gets or sets the color of plus, minus and arrow icons.
LabelFill | Gets or sets the brush of the the label that shows the current zoom level.
MaxZoomFactor | The maximum zoom level allowed to set through this control.
MinZoomFactor | The minimum zoom level allowed to set through this control.
ScrollStep | Gets or sets the scroll offset added when users click the pan arrows.
ShadowColor | Gets or sets the shadow color.
ShowLabel | Gets or sets a value indicating whether the label that shows the current zoom level should be visible.
SnapToZoomStep | Gets or sets whether the trackbar should snap to ZoomStep values when dragged.
Target | Gets or sets the target view controlled by this ZoomControl.
TickPosition | Gets or sets the current tick position of the trackbar.
ZoomFactor | Gets or sets the current zoom level.
ZoomStep | Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

Public Methods

Name | Description
SetZoomFactor | Sets the current zoom level.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnPaint | Control.OnPaint override.

Public Events

Name | Description
ScrollArrowClicked | Raised when a scroll arrow has been clicked.
ZoomFactorChanged | Raised when the zoom level changes.

See Also

ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl Constructor

ZoomControl Constructor
[image]

Initializes a new instance of the ZoomControl class.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public ZoomControl ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl Methods

ZoomControl Methods
[image]

Public Methods

Name | Description
SetZoomFactor | Sets the current zoom level.

Protected Methods

Name | Description
Dispose | Clean up any resources being used.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnPaint | Control.OnPaint override.

See Also

ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.Dispose Method

ZoomControl.Dispose Method
[image]

Clean up any resources being used.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

protected override void Dispose (
bool disposing
)

Visual Basic [image] Copy Code

Protected Overrides Sub Dispose( _
disposing As Boolean _
)

Parameters

disposing

true if managed resources should be disposed; otherwise, false.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.OnMouseDown Method

ZoomControl.OnMouseDown Method
[image]

Control.OnMouseDown override.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
e As MouseEventArgs _
)

Parameters

e

A MouseEventArgs instance providing more information about the event.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.OnMouseMove Method

ZoomControl.OnMouseMove Method
[image]

Control.OnMouseMove override.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

A MouseEventArgs instance providing more information about the event.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.OnMouseUp Method

ZoomControl.OnMouseUp Method
[image]

Control.OnMouseUp override.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
e As MouseEventArgs _
)

Parameters

e

A MouseEventArgs instance providing more information about the event.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.OnPaint Method

ZoomControl.OnPaint Method
[image]

Control.OnPaint override.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

protected override void OnPaint (
PaintEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPaint( _
e As PaintEventArgs _
)

Parameters

e

A PaintEventArgs instance providing more information about the event.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.SetZoomFactor Method

ZoomControl.SetZoomFactor Method
[image]

Sets the current zoom level.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public void SetZoomFactor (
float value,
bool applyConstraints
)

Visual Basic [image] Copy Code

Public Sub SetZoomFactor( _
value As Single, _
applyConstraints As Boolean _
)

Parameters

value

A float value specifying the new zoom level.

applyConstraints

true to apply min/max constraints and align to ZoomStep, or false otherwise.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl Properties

ZoomControl Properties
[image]

Public Properties

Name | Description
ActiveColor | Gets or sets the color used to render depressed buttons.
BorderColor | Gets or sets the color of ZoomControl elements' borders.
CornerRadius | Gets or sets the corner radius of rounded child elements.
Fill | Gets or sets the brush used to fill the ZoomControl elements.
InnerColor | Gets or sets the color of plus, minus and arrow icons.
LabelFill | Gets or sets the brush of the the label that shows the current zoom level.
MaxZoomFactor | The maximum zoom level allowed to set through this control.
MinZoomFactor | The minimum zoom level allowed to set through this control.
ScrollStep | Gets or sets the scroll offset added when users click the pan arrows.
ShadowColor | Gets or sets the shadow color.
ShowLabel | Gets or sets a value indicating whether the label that shows the current zoom level should be visible.
SnapToZoomStep | Gets or sets whether the trackbar should snap to ZoomStep values when dragged.
Target | Gets or sets the target view controlled by this ZoomControl.
TickPosition | Gets or sets the current tick position of the trackbar.
ZoomFactor | Gets or sets the current zoom level.
ZoomStep | Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

See Also

ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.ActiveColor Property

ZoomControl.ActiveColor Property
[image]

Gets or sets the color used to render depressed buttons.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public Color ActiveColor { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveColor As Color

Property Value

A System.Drawing.Color instance. The default value is SkyBlue.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.BorderColor Property

ZoomControl.BorderColor Property
[image]

Gets or sets the color of ZoomControl elements' borders.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public Color BorderColor { get; set; }

Visual Basic [image] Copy Code

Public Property BorderColor As Color

Property Value

A System.Drawing.Color instance. The default value is RGB(77, 83, 94).

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.CornerRadius Property

ZoomControl.CornerRadius Property
[image]

Gets or sets the corner radius of rounded child elements.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public int CornerRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CornerRadius As Integer

Property Value

An integer value specifying the radius of corner arcs. The default value is 2.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.Fill Property

ZoomControl.Fill Property
[image]

Gets or sets the brush used to fill the ZoomControl elements.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public Brush Fill { get; set; }

Visual Basic [image] Copy Code

Public Property Fill As Brush

Property Value

A System.Drawing.Brush instance. The default value is Brushes.White.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.InnerColor Property

ZoomControl.InnerColor Property
[image]

Gets or sets the color of plus, minus and arrow icons.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public Color InnerColor { get; set; }

Visual Basic [image] Copy Code

Public Property InnerColor As Color

Property Value

A System.Drawing.Color instance. The default value is RGB(91, 91, 91).

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.LabelFill Property

ZoomControl.LabelFill Property
[image]

Gets or sets the brush of the the label that shows the current zoom level.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public Brush LabelFill { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFill As Brush

Property Value

A System.Drawing.Brush instance.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.MaxZoomFactor Property

ZoomControl.MaxZoomFactor Property
[image]

The maximum zoom level allowed to set through this control.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public float MaxZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property MaxZoomFactor As Single

Property Value

A float value specifying the maximum zoom level. The default value is 200.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.MinZoomFactor Property

ZoomControl.MinZoomFactor Property
[image]

The minimum zoom level allowed to set through this control.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public float MinZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property MinZoomFactor As Single

Property Value

A float value specifying the minimum zoom level. The default value is 0.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.ScrollStep Property

ZoomControl.ScrollStep Property
[image]

Gets or sets the scroll offset added when users click the pan arrows.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public float ScrollStep { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollStep As Single

Property Value

A float value specifying the scroll offset. The default value is 10.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.ShadowColor Property

ZoomControl.ShadowColor Property
[image]

Gets or sets the shadow color.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public Color ShadowColor { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowColor As Color

Property Value

A System.Drawing.Color instance. The default value is ARGB(150, 0, 0, 0).

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.ShowLabel Property

ZoomControl.ShowLabel Property
[image]

Gets or sets a value indicating whether the label that shows the current zoom level should be visible.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public bool ShowLabel { get; set; }

Visual Basic [image] Copy Code

Public Property ShowLabel As Boolean

Property Value

true to show the zoom level label, or false otherwise. The default value is true.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.SnapToZoomStep Property

ZoomControl.SnapToZoomStep Property
[image]

Gets or sets whether the trackbar should snap to ZoomStep values when dragged.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public bool SnapToZoomStep { get; set; }

Visual Basic [image] Copy Code

Public Property SnapToZoomStep As Boolean

Property Value

true to snap to multiples of ZoomStep, or false otherwise. The default value is true.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.Target Property

ZoomControl.Target Property
[image]

Gets or sets the target view controlled by this ZoomControl.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public IZoomTarget Target { get; set; }

Visual Basic [image] Copy Code

Public Property Target As IZoomTarget

Property Value

Instance of a class implementing the IZoomTarget interface. MindFusion controls that implement it at this time are DiagramView and MapView.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.TickPosition Property

ZoomControl.TickPosition Property
[image]

Gets or sets the current tick position of the trackbar.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public TickPosition TickPosition { get; set; }

Visual Basic [image] Copy Code

Public Property TickPosition As TickPosition

Property Value

A member of the TickPosition enumeration. The default value is Left.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.ZoomFactor Property

ZoomControl.ZoomFactor Property
[image]

Gets or sets the current zoom level.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public float ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Single

Property Value

A float value specifying the current zoom level.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.ZoomStep Property

ZoomControl.ZoomStep Property
[image]

Gets or sets the amount by which to change zoom level when + and - buttons are clicked.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public float ZoomStep { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomStep As Single

Property Value

A float value specifying the zoom level change. The default value is 10.

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl Events

ZoomControl Events
[image]

Public Events

Name | Description
ScrollArrowClicked | Raised when a scroll arrow has been clicked.
ZoomFactorChanged | Raised when the zoom level changes.

See Also

ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.ScrollArrowClicked Event

ZoomControl.ScrollArrowClicked Event
[image]

Raised when a scroll arrow has been clicked.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public event EventHandler<ScrollArrowEventArgs> ScrollArrowClicked

Visual Basic [image] Copy Code

Public Event ScrollArrowClicked As EventHandler(Of ScrollArrowEventArgs)

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Common.WinForms.ZoomControl.ZoomFactorChanged Event

ZoomControl.ZoomFactorChanged Event
[image]

Raised when the zoom level changes.

Namespace: MindFusion.Common.WinForms
Assembly: MindFusion.Common.WinForms

Syntax

C# [image] Copy Code

public event EventHandler ZoomFactorChanged

Visual Basic [image] Copy Code

Public Event ZoomFactorChanged As EventHandler

See Also

ZoomControl Members
ZoomControl Class
MindFusion.Common.WinForms Namespace


MindFusion.Mapping Namespace

MindFusion.Mapping Namespace
Classes Interfaces Structures Enumerations

Classes

Class | Description
Column | Represents a database column.
Database | Represents the DBF database associated with an ESRI map file.
Decoration | Represents a decoration element drawn in a separate layer over the map.
DecorationLayerBase(TColor, TPalette) | Represents a layer containing decorative elements.
Label | Represents a text label associated with map element.
Layer(TColor, TPalette) | Represents a map layer.
Map | Represents a geographic map.
MapElement | Represents visual elements of a map that can be drawn and hit-tested.
MapLayerBase(TColor, TPalette) | Represents a map layer containing geometric shapes.
NullShape | Represents a null shape with no geometric data; often used as a place holder until data becomes available.
Point | Represents a point on the map with X (longitude) and Y (latitude) coordinates.
Rect | A class representing a rectangular are on the map.
Row | Represents a DBF database row.
RuntimePolicy | Contains environment settings to use in implementation for current platform.
Shape | Represents geometrical shapes displayed on a map.
StreetMapFeatures | A helper class used for OSM files import and rendering.
StreetShape | Represents a shape in OSM file format.
Vector | Represents a two-dimensional vector.

Interfaces

Interface | Description
ICanvas | Represents a drawing canvas.
ICanvasWithPalette(TColor) | Represents a drawing canvas with an associated palette of colors.
IPalette(TColor) | Represents a palette of colors.
ITransform | Represents a geometrical transform used to convert world coordinates to screen coordinates.

Structures

Structure | Description
MapFeature | Contains OpenStreetMap key and value tags describing a map feature.

Enumerations

Enumeration | Description
ColumnType | Specifies a DBF column type.
ShapeType | Specifies the type of shapes contained in an ESRI map file.
StreetShapeType | Specifies the type of shapes contained in an OSM map file.
TextAlignment | Specifies text alignment.


MindFusion.Mapping.Column Class

Column Class
Remarks See Also
[image]

Represents a database column.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Column

Visual Basic [image] Copy Code

Public Class Column

Remarks

Objects of this class represent the columns in a DBF database associated with a map file. The Name property indicates the column name, and the Type property indicates the DBF data type.

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Column

See Also

Column Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Column Members

Column Members
Properties Methods
[image]

Represents a database column.

The following tables list the members exposed by the Column type.

Public Properties

Name | Description
Decimals | Gets the number of decimals stored for numeric values in this column.
Length | Gets the length of fields in this column.
Name | Gets the column name.
Type | Gets the DBF column type.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Column Class


MindFusion.Mapping.Column Methods

Column Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Column Class


MindFusion.Mapping.Column.ToString Method

Column.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

Returns the column name.

See Also

Column Members
Column Class


MindFusion.Mapping.Column Properties

Column Properties
[image]

Public Properties

Name | Description
Decimals | Gets the number of decimals stored for numeric values in this column.
Length | Gets the length of fields in this column.
Name | Gets the column name.
Type | Gets the DBF column type.

See Also

Column Class


MindFusion.Mapping.Column.Decimals Property

Column.Decimals Property
[image]

Gets the number of decimals stored for numeric values in this column.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public byte Decimals { get; set; }

Visual Basic [image] Copy Code

Public Property Decimals As Byte

Property Value

A byte value specifying the number of decimal places in numeric fields.

See Also

Column Members
Column Class
Type Property


MindFusion.Mapping.Column.Length Property

Column.Length Property
[image]

Gets the length of fields in this column.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Integer

Property Value

An integer value that specifies the length in bytes of data fields in this column.

See Also

Column Members
Column Class


MindFusion.Mapping.Column.Name Property

Column.Name Property
[image]

Gets the column name.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

A string value specifying the column name.

See Also

Column Members
Column Class
Type Property


MindFusion.Mapping.Column.Type Property

Column.Type Property
[image]

Gets the DBF column type.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public ColumnType Type { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Type As ColumnType

Property Value

A member of the ColumnType enumeration.

See Also

Column Members
Column Class
Name Property


MindFusion.Mapping.ColumnType Enumeration

ColumnType Enumeration
[image]

Specifies a DBF column type.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public enum ColumnType

Visual Basic [image] Copy Code

Public Enum ColumnType

Members

Member name | Description
Binary | Indicates that the column stores binary data.
Boolean | Indicates that the column stores Boolean data.
Character | Indicates that the column stores character data.
Date | Indicates that the column stores date values.
FloatingPoint | Indicates that the column stores floating point values.
Integer | Indicates that the column stores integer values.
Memo | Indicates that the column stores memo data.
Number | Indicates that the column stores numeric data.

See Also


MindFusion.Mapping.Database Class

Database Class
Remarks See Also
[image]

Represents the DBF database associated with an ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Database : IListSource

Visual Basic [image] Copy Code

Public Class Database
Implements IListSource

Remarks

The DBF database associated with a map is loaded optionally, as specified via parameters of the LoadFromFile method of the Map class. If the database is loaded, it is represented by instance of this class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Database

See Also

Database Members


MindFusion.Mapping.Database Members

Database Members
Constructors Properties Methods
[image]

Represents the DBF database associated with an ESRI map file.

The following tables list the members exposed by the Database type.

Public Constructors

Name | Description
Database | Overloaded.

Public Properties

Name | Description
ColumnCount | Returns the number of column in the database.
Columns | Gets a list of columns in the database.
ContainsListCollection | Implements IListSource.ContainsListCollection.
Item | Overloaded.
RowLength | Returns the length in bytes of a database row.
Rows | Gets a list of rows in the database.

Public Methods

Name | Description
GetList | Implements IListSource.GetList.
LoadFrom | Overloaded.
SaveTo | Overloaded.

See Also

Database Class


MindFusion.Mapping.Database Constructor

Database Constructor
[image]

Overload List

Name | Description
Database (BinaryReader) | Creates a new instance of the Database class.
Database (Database) | Creates a new instance of the Database class.
Database (String) | Creates a new instance of the Database class.

See Also

Database Class


MindFusion.Mapping.Database Constructor (BinaryReader)

Database Constructor (BinaryReader)
See Also
[image]

Creates a new instance of the Database class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public New ( _
reader As BinaryReader _
)

Parameters

reader

Specifies a stream from which to load the database data.

See Also

Database Constructor Overload List
Database Class


MindFusion.Mapping.Database Constructor (Database)

Database Constructor (Database)
See Also
[image]

Creates a new instance of the Database class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database (
Database schema
)

Visual Basic [image] Copy Code

Public New ( _
schema As Database _
)

Parameters

schema

A prototype database whose schema should be copied to this database.

See Also

Database Constructor Overload List
Database Class


MindFusion.Mapping.Database Constructor (String)

Database Constructor (String)
See Also
[image]

Creates a new instance of the Database class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database (
string fileName
)

Visual Basic [image] Copy Code

Public New ( _
fileName As String _
)

Parameters

fileName

Specifies the file name of the DBF database file.

See Also

Database Constructor Overload List
Database Class


MindFusion.Mapping.Database Methods

Database Methods
[image]

Public Methods

Name | Description
GetList | Implements IListSource.GetList.
LoadFrom | Overloaded.
SaveTo | Overloaded.

See Also

Database Class


MindFusion.Mapping.Database.GetList Method

Database.GetList Method
[image]

Implements IListSource.GetList.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public IList GetList ()

Visual Basic [image] Copy Code

Public Function GetList () As IList

Return Value

An IList containing the database rows.

Remarks

This method allows using a Database instance as the data source of grid or list controls.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.LoadFrom Method

Database.LoadFrom Method
[image]

Overload List

Name | Description
Database.LoadFrom (BinaryReader) | Loads database data from the specified stream.
Database.LoadFrom (String) | Loads database data from the specified file.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.LoadFrom Method (BinaryReader)

Database.LoadFrom Method (BinaryReader)
See Also
[image]

Loads database data from the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFrom (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
reader As BinaryReader _
)

Parameters

reader

A BinaryReader used to read database data.

See Also

LoadFrom Method Overload List
Database Members
Database Class


MindFusion.Mapping.Database.LoadFrom Method (String)

Database.LoadFrom Method (String)
See Also
[image]

Loads database data from the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFrom (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
fileName As String _
)

Parameters

fileName

A string value specifying the file name.

See Also

LoadFrom Method Overload List
Database Members
Database Class


MindFusion.Mapping.Database.SaveTo Method

Database.SaveTo Method
[image]

Overload List

Name | Description
Database.SaveTo (BinaryWriter) | Saves this database to the specified stream.
Database.SaveTo (String) | Saves this database to the specified file.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.SaveTo Method (BinaryWriter)

Database.SaveTo Method (BinaryWriter)
See Also
[image]

Saves this database to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the database data.

See Also

SaveTo Method Overload List
Database Members
Database Class


MindFusion.Mapping.Database.SaveTo Method (String)

Database.SaveTo Method (String)
See Also
[image]

Saves this database to the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveTo (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
fileName As String _
)

Parameters

fileName

A string value specifying the file name.

See Also

SaveTo Method Overload List
Database Members
Database Class


MindFusion.Mapping.Database Properties

Database Properties
[image]

Public Properties

Name | Description
ColumnCount | Returns the number of column in the database.
Columns | Gets a list of columns in the database.
ContainsListCollection | Implements IListSource.ContainsListCollection.
Item | Overloaded.
RowLength | Returns the length in bytes of a database row.
Rows | Gets a list of rows in the database.

See Also

Database Class


MindFusion.Mapping.Database.ColumnCount Property

Database.ColumnCount Property
[image]

Returns the number of column in the database.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int ColumnCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ColumnCount As Integer

Property Value

An integer value specifying the number of columns in the DBF file.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.Columns Property

Database.Columns Property
[image]

Gets a list of columns in the database.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Column> Columns { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Columns As List(Of Column)

Property Value

A List of Column objects.

See Also

Database Members
Database Class
Rows Property


MindFusion.Mapping.Database.ContainsListCollection Property

Database.ContainsListCollection Property
[image]

Implements IListSource.ContainsListCollection.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool ContainsListCollection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ContainsListCollection As Boolean

Property Value

This property always returns false.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.Item Property

Database.Item Property
[image]

Overload List

Name | Description
Database.Item (Int32) | Gets the column with the specified index.
Database.Item (String) | Gets the column with the specified name.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.Item Property (Int32)

Database.Item Property (Int32)
See Also
[image]

Gets the column with the specified index.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Column Item [
int nIndex
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
nIndex As Integer _
) As Column

Parameters

nIndex

An integer value specifying the column index.

Property Value

A Column instance representing the database column.

See Also

Item Property Overload List
Database Members
Database Class


MindFusion.Mapping.Database.Item Property (String)

Database.Item Property (String)
See Also
[image]

Gets the column with the specified name.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Column Item [
string name
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
name As String _
) As Column

Parameters

name

A string value specifying the column name.

Property Value

A Column instance representing the database column.

See Also

Item Property Overload List
Database Members
Database Class


MindFusion.Mapping.Database.RowLength Property

Database.RowLength Property
[image]

Returns the length in bytes of a database row.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int RowLength { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowLength As Integer

Property Value

An integer value specifying the length in bytes of a DBF data record.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.Rows Property

Database.Rows Property
[image]

Gets a list of rows in the database.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Row> Rows { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Rows As List(Of Row)

Property Value

A List of Row objects.

See Also

Database Members
Database Class


MindFusion.Mapping.Decoration Class

Decoration Class
[image]

Represents a decoration element drawn in a separate layer over the map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class Decoration : MapElement

Visual Basic [image] Copy Code

Public MustInherit Class Decoration
Inherits MapElement

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.WinForms.DecorationBubble
MindFusion.Mapping.WinForms.DecorationImage

See Also

Decoration Members


MindFusion.Mapping.Decoration Members

Decoration Members
Constructors Properties Methods
[image]

Represents a decoration element drawn in a separate layer over the map.

The following tables list the members exposed by the Decoration type.

Public Constructors

Name | Description
Decoration | Initializes a new instance of the Decoration class.

Public Properties

Name | Description
Latitude | Gets or sets the latitude associated with this decoration.
Longitude | Gets or sets the longitude associated with this decoration.

Inherited Public Properties

Name | Description
Label | Gets or sets the label of this map element. (Inherited from MapElement.)

Public Methods

Name | Description
GetLocation | Gets the decoration's location.

Inherited Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

Decoration Class


MindFusion.Mapping.Decoration Constructor

Decoration Constructor
[image]

Initializes a new instance of the Decoration class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Decoration (
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
latitude As Double, _
longitude As Double _
)

Parameters

latitude

Specifies the latitude associated with this element.

longitude

Specifies the longitude associated with this element.

See Also

Decoration Class


MindFusion.Mapping.Decoration Methods

Decoration Methods
[image]

Public Methods

Name | Description
GetLocation | Gets the decoration's location.

Inherited Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

Decoration Class


MindFusion.Mapping.Decoration.GetLocation Method

Decoration.GetLocation Method
[image]

Gets the decoration's location.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point GetLocation ()

Visual Basic [image] Copy Code

Public Function GetLocation () As Point

Return Value

A Point containing the decoration's location.

See Also

Decoration Members
Decoration Class


MindFusion.Mapping.Decoration Properties

Decoration Properties
[image]

Public Properties

Name | Description
Latitude | Gets or sets the latitude associated with this decoration.
Longitude | Gets or sets the longitude associated with this decoration.

Inherited Public Properties

Name | Description
Label | Gets or sets the label of this map element. (Inherited from MapElement.)

See Also

Decoration Class


MindFusion.Mapping.Decoration.Latitude Property

Decoration.Latitude Property
[image]

Gets or sets the latitude associated with this decoration.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Latitude { get; set; }

Visual Basic [image] Copy Code

Public Property Latitude As Double

Property Value

A double value specifying the latitude of the decoration's location.

Remarks

You can call the Latitude method of the Map class to get the double value for latitude specified in [degrees,minutes,seconds,N/S] format.

See Also

Decoration Members
Decoration Class


MindFusion.Mapping.Decoration.Longitude Property

Decoration.Longitude Property
[image]

Gets or sets the longitude associated with this decoration.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Longitude { get; set; }

Visual Basic [image] Copy Code

Public Property Longitude As Double

Property Value

A double value specifying the longitude of the decoration's location.

Remarks

You can call the Longitude method of the Map class to get the double value for longitudes specified in [degrees,minutes,seconds,W/E] format.

See Also

Decoration Members
Decoration Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Class

DecorationLayerBase(TColor, TPalette) Class
[image]

Represents a layer containing decorative elements.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class DecorationLayerBase<TColor, TPalette> : Layer<TColor, TPalette> where TPalette : IPalette<TColor>

Visual Basic [image] Copy Code

Public Class DecorationLayerBase(Of TColor, TPalette As IPalette(Of TColor))
Inherits Layer(Of TColor, TPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(TColor, TPalette)
MindFusion.Mapping.DecorationLayerBase(TColor, TPalette)
MindFusion.Mapping.WinForms.DecorationLayer

See Also

DecorationLayerBase(TColor, TPalette) Members


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Members

DecorationLayerBase(TColor, TPalette) Members
Constructors Properties Methods Events
[image]

Represents a layer containing decorative elements.

The following tables list the members exposed by the DecorationLayerBase(TColor, TPalette) type.

Public Constructors

Name | Description
DecorationLayerBase | Initializes a new instance of the DecorationLayerBase class. (Inherited from DecorationLayerBase.)

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override. (Inherited from DecorationLayerBase.)
Decorations | Gets the list of decorations displayed in this layer. (Inherited from DecorationLayerBase.)
Selection | Gets the list of selected decorations. (Inherited from DecorationLayerBase.)

Inherited Public Properties

Name | Description
BoundingBox | Returns the bounding box of elements in this layer. (Inherited from Layer.)
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

Public Methods

Name | Description
Draw | Layer.Draw override. (Inherited from DecorationLayerBase.)
DrawHighlights | Layer.DrawHighlights override. (Inherited from DecorationLayerBase.)
DrawLabels | Layer.DrawLabels override. (Inherited from DecorationLayerBase.)
Highlight | Layer.Highlight override. (Inherited from DecorationLayerBase.)
HitTest | Layer.HitTest override. (Inherited from DecorationLayerBase.)
Select | Overloaded. (Inherited from DecorationLayerBase.)
Toggle | Layer.Toggle override. (Inherited from DecorationLayerBase.)

Inherited Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level. (Inherited from Layer.)
Draw | Overloaded. (Inherited from Layer.)
DrawHighlights | Draws the layer's highlighted elements on the specified canvas. (Inherited from Layer.)
DrawLabels | Draws the labels of elements of this layer on the specified canvas. (Inherited from Layer.)
Highlight | Highlights the specified map element. (Inherited from Layer.)
HitTest | Returns the map element located at the specified point. (Inherited from Layer.)
Select | Overloaded. (Inherited from Layer.)
Toggle | Toggles the selection state the specified map element. (Inherited from Layer.)

Inherited Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from Layer.)
OnEndLoad | Raises the EndLoad event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

Inherited Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
BeginLoad | Raised when the component starts loading map data from a file or memory stream. (Inherited from Layer.)
EndLoad | Raised when the component ends loading map data from a file or memory stream. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Constructor

DecorationLayerBase(TColor, TPalette) Constructor
[image]

Initializes a new instance of the DecorationLayerBase class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public DecorationLayerBase<TColor, TPalette> (
Rect boundingBox
)

Visual Basic [image] Copy Code

Public New (Of TColor, TPalette) ( _
boundingBox As Rect _
)

Parameters

boundingBox

A Rect specifying the map area displayed on this layer.

See Also

DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Methods

DecorationLayerBase(TColor, TPalette) Methods
[image]

Public Methods

Name | Description
Draw | Layer.Draw override. (Inherited from DecorationLayerBase.)
DrawHighlights | Layer.DrawHighlights override. (Inherited from DecorationLayerBase.)
DrawLabels | Layer.DrawLabels override. (Inherited from DecorationLayerBase.)
Highlight | Layer.Highlight override. (Inherited from DecorationLayerBase.)
HitTest | Layer.HitTest override. (Inherited from DecorationLayerBase.)
Select | Overloaded. (Inherited from DecorationLayerBase.)
Toggle | Layer.Toggle override. (Inherited from DecorationLayerBase.)

Inherited Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level. (Inherited from Layer.)
Draw | Overloaded. (Inherited from Layer.)
DrawHighlights | Draws the layer's highlighted elements on the specified canvas. (Inherited from Layer.)
DrawLabels | Draws the labels of elements of this layer on the specified canvas. (Inherited from Layer.)
Highlight | Highlights the specified map element. (Inherited from Layer.)
HitTest | Returns the map element located at the specified point. (Inherited from Layer.)
Select | Overloaded. (Inherited from Layer.)
Toggle | Toggles the selection state the specified map element. (Inherited from Layer.)

Inherited Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from Layer.)
OnEndLoad | Raises the EndLoad event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

See Also

DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Draw Method

DecorationLayerBase(TColor, TPalette).Draw Method
[image]

Layer.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void Draw (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).DrawHighlights Method

DecorationLayerBase(TColor, TPalette).DrawHighlights Method
[image]

Layer.DrawHighlights override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawHighlights (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHighlights( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

bounds

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).DrawLabels Method

DecorationLayerBase(TColor, TPalette).DrawLabels Method
[image]

Layer.DrawLabels override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawLabels (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLabels( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Highlight Method

DecorationLayerBase(TColor, TPalette).Highlight Method
[image]

Layer.Highlight override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Highlight (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Highlight( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be highlighted.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).HitTest Method

DecorationLayerBase(TColor, TPalette).HitTest Method
[image]

Layer.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override MapElement HitTest (
Point mousePosition,
ITransform transform
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
mousePosition As Point, _
transform As ITransform _
) As MapElement

Parameters

mousePosition

A Point instance specifying location.

transform

The transform currently used to draw the map.

Return Value

The MapElement that contains the specified point.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Select Method

DecorationLayerBase(TColor, TPalette).Select Method
[image]

Overload List

Name | Description
DecorationLayerBase(TColor, TPalette).Select (MapElement) | Layer.Select override.
DecorationLayerBase(TColor, TPalette).Select (Rect) | Layer.Select override.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Select Method (MapElement)

DecorationLayerBase(TColor, TPalette).Select Method (MapElement)
See Also
[image]

Layer.Select override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Select (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Select Method (Rect)

DecorationLayerBase(TColor, TPalette).Select Method (Rect)
See Also
[image]

Layer.Select override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Select (
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
bounds As Rect _
) As Boolean

Parameters

bounds

A Rect specifying the selection boundaries.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Toggle Method

DecorationLayerBase(TColor, TPalette).Toggle Method
[image]

Layer.Toggle override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Toggle (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Toggle( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement whose selection state should be toggled.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Properties

DecorationLayerBase(TColor, TPalette) Properties
[image]

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override. (Inherited from DecorationLayerBase.)
Decorations | Gets the list of decorations displayed in this layer. (Inherited from DecorationLayerBase.)
Selection | Gets the list of selected decorations. (Inherited from DecorationLayerBase.)

Inherited Public Properties

Name | Description
BoundingBox | Returns the bounding box of elements in this layer. (Inherited from Layer.)
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

See Also

DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).BoundingBox Property

DecorationLayerBase(TColor, TPalette).BoundingBox Property
[image]

Layer.BoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property BoundingBox As Rect

Property Value

A Rect instance specifying the layer's bounding rectangle.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Decorations Property

DecorationLayerBase(TColor, TPalette).Decorations Property
[image]

Gets the list of decorations displayed in this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public ObservableCollection<Decoration> Decorations { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Decorations As ObservableCollection(Of Decoration)

Property Value

A List of Decoration objects.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Selection Property

DecorationLayerBase(TColor, TPalette).Selection Property
[image]

Gets the list of selected decorations.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Decoration> Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As List(Of Decoration)

Property Value

A List of Decoration objects.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.ICanvas Interface

ICanvas Interface
[image]

Represents a drawing canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface ICanvas

Visual Basic [image] Copy Code

Public Interface ICanvas

Inheritors

MindFusion.Mapping.ICanvasWithPalette(TColor)
MindFusion.Mapping.WinForms.GdiCanvas

See Also

ICanvas Members


MindFusion.Mapping.ICanvas Members

ICanvas Members
Methods
[image]

Represents a drawing canvas.

The following tables list the members exposed by the ICanvas type.

Public Methods

Name | Description
ArrangeLabel | Arranges shape's labels so that they do not overlap specified obstacles.
ClipExclude | Overloaded.
DrawLabel | Draws a Label.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
GetRotatedBounds | Gets the bounding box of a rotated rectangle.
ResetClip | Resets the current clip region.
SetBrush | Sets the current brush to the one associated with specified map feature.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetPen | Sets the current pen to the one associated with specified map feature.
SetTextAlignment | Sets the current text alignment.
UpdateLabel | Updates bounding box of shape's label from shape coordinates.

See Also

ICanvas Interface


MindFusion.Mapping.ICanvas Methods

ICanvas Methods
[image]

Public Methods

Name | Description
ArrangeLabel | Arranges shape's labels so that they do not overlap specified obstacles.
ClipExclude | Overloaded.
DrawLabel | Draws a Label.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
GetRotatedBounds | Gets the bounding box of a rotated rectangle.
ResetClip | Resets the current clip region.
SetBrush | Sets the current brush to the one associated with specified map feature.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetPen | Sets the current pen to the one associated with specified map feature.
SetTextAlignment | Sets the current text alignment.
UpdateLabel | Updates bounding box of shape's label from shape coordinates.

See Also

ICanvas Interface


MindFusion.Mapping.ICanvas.ArrangeLabel Method

ICanvas.ArrangeLabel Method
[image]

Arranges shape's labels so that they do not overlap specified obstacles.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

bool ArrangeLabel (
Shape shape,
List<Rect> obstacles
)

Visual Basic [image] Copy Code

Function ArrangeLabel( _
shape As Shape, _
obstacles As List(Of Rect) _
) As Boolean

Parameters

shape

A Shape whose labels to arrange.

obstacles

A list of obstacles.

Return Value

true if non-overlapping position has been found, or false otherwise.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.ClipExclude Method

ICanvas.ClipExclude Method
[image]

Overload List

Name | Description
ICanvas.ClipExclude (IList(Point)) | Excludes the specified area from the current clip region.
ICanvas.ClipExclude (List(IList(Point))) | Excludes the specified areas from the current clip region.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.ClipExclude Method (IList(Point))

ICanvas.ClipExclude Method (IList(Point))
See Also
[image]

Excludes the specified area from the current clip region.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void ClipExclude (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub ClipExclude( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.ClipExclude Method (List(IList(Point)))

ICanvas.ClipExclude Method (List(IList(Point)))
See Also
[image]

Excludes the specified areas from the current clip region.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void ClipExclude (
List<IList<Point>> points
)

Visual Basic [image] Copy Code

Sub ClipExclude( _
points As List(Of IList(Of Point)) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.DrawLabel Method

ICanvas.DrawLabel Method
[image]

Draws a Label.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void DrawLabel (
Label label
)

Visual Basic [image] Copy Code

Sub DrawLabel( _
label As Label _
)

Parameters

label

The Label instance to draw.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.DrawPoint Method

ICanvas.DrawPoint Method
[image]

Draws a point marker at the specified location.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void DrawPoint (
Point point
)

Visual Basic [image] Copy Code

Sub DrawPoint( _
point As Point _
)

Parameters

point

The Point to draw.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.DrawPolyline Method

ICanvas.DrawPolyline Method
[image]

Draws a polyline.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void DrawPolyline (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub DrawPolyline( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polyline segments.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.DrawString Method

ICanvas.DrawString Method
[image]

Draws a string with the specified attributes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void DrawString (
string s,
Point point,
Rect bounds,
string fontName,
double fontSize
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
point As Point, _
bounds As Rect, _
fontName As String, _
fontSize As Double _
)

Parameters

s

The string that should be drawn.

point

A Point specifying the string location.

bounds

A Rect specifying the string bounding box.

fontName

The name of the font used to render the string.

fontSize

The size of the font used to render the string.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.FillPolygon Method

ICanvas.FillPolygon Method
[image]

Fills a polygon.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void FillPolygon (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polygon borders.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.GetPixelSize Method

ICanvas.GetPixelSize Method
[image]

Gets the size of a pixel at the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

double GetPixelSize ()

Visual Basic [image] Copy Code

Function GetPixelSize () As Double

Return Value

A double value specifying the pixel size.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.GetRotatedBounds Method

ICanvas.GetRotatedBounds Method
[image]

Gets the bounding box of a rotated rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

Rect GetRotatedBounds (
Rect rect,
float angle
)

Visual Basic [image] Copy Code

Function GetRotatedBounds( _
rect As Rect, _
angle As Single _
) As Rect

Parameters

rect

A Rect to rotate.

angle

Rotation angle.

Return Value

A Rect that bounds the specified rotated rectangle.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.ResetClip Method

ICanvas.ResetClip Method
[image]

Resets the current clip region.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void ResetClip ()

Visual Basic [image] Copy Code

Sub ResetClip ()

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.SetBrush Method

ICanvas.SetBrush Method
[image]

Sets the current brush to the one associated with specified map feature.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetBrush (
MapFeature brushKey
)

Visual Basic [image] Copy Code

Sub SetBrush( _
brushKey As MapFeature _
)

Parameters

brushKey

A MapFeature used as key in StreetMapBrushes table.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.SetFillColor Method

ICanvas.SetFillColor Method
[image]

Sets the current fill color to the specified color from the palette.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetFillColor (
int color
)

Visual Basic [image] Copy Code

Sub SetFillColor( _
color As Integer _
)

Parameters

color

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.SetHighlightColor Method

ICanvas.SetHighlightColor Method
[image]

Sets the current fill and line colors to the highlight color associated with this canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetHighlightColor ()

Visual Basic [image] Copy Code

Sub SetHighlightColor ()

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.SetLineColor Method

ICanvas.SetLineColor Method
[image]

Sets the current line color to the line color associated with this canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetLineColor ()

Visual Basic [image] Copy Code

Sub SetLineColor ()

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.SetPen Method

ICanvas.SetPen Method
[image]

Sets the current pen to the one associated with specified map feature.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetPen (
MapFeature penKey,
bool isBorderPen
)

Visual Basic [image] Copy Code

Sub SetPen( _
penKey As MapFeature, _
isBorderPen As Boolean _
)

Parameters

penKey

A MapFeature used as key in StreetMapPens table.

isBorderPen

true if the pen will be used to outline a closed shape, or false otherwise.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.SetTextAlignment Method

ICanvas.SetTextAlignment Method
[image]

Sets the current text alignment.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void SetTextAlignment (
TextAlignment horzAlignment,
TextAlignment vertAlignment
)

Visual Basic [image] Copy Code

Public MustOverride Sub SetTextAlignment( _
horzAlignment As TextAlignment, _
vertAlignment As TextAlignment _
)

Parameters

horzAlignment

A TextAlignment member specifying the horizontal alignment.

vertAlignment

A TextAlignment member specifying the vertical alignment.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.UpdateLabel Method

ICanvas.UpdateLabel Method
[image]

Updates bounding box of shape's label from shape coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

Rect UpdateLabel (
Shape shape
)

Visual Basic [image] Copy Code

Function UpdateLabel( _
shape As Shape _
) As Rect

Parameters

shape

A Shape instance.

Return Value

The label's bounding box.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvasWithPalette(TColor) Interface

ICanvasWithPalette(TColor) Interface
[image]

Represents a drawing canvas with an associated palette of colors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface ICanvasWithPalette<TColor> : ICanvas

Visual Basic [image] Copy Code

Public Interface ICanvasWithPalette(Of TColor)
Implements ICanvas

Inheritors

MindFusion.Mapping.WinForms.GdiCanvas

See Also

ICanvasWithPalette(TColor) Members


MindFusion.Mapping.ICanvasWithPalette(TColor) Members

ICanvasWithPalette(TColor) Members
Properties
[image]

Represents a drawing canvas with an associated palette of colors.

The following tables list the members exposed by the ICanvasWithPalette(TColor) type.

Public Properties

Name | Description
Palette | Gets or sets the color palette associated with this drawing canvas.

See Also

ICanvasWithPalette(TColor) Interface


MindFusion.Mapping.ICanvasWithPalette(TColor) Properties

ICanvasWithPalette(TColor) Properties
[image]

Public Properties

Name | Description
Palette | Gets or sets the color palette associated with this drawing canvas.

See Also

ICanvasWithPalette(TColor) Interface


MindFusion.Mapping.ICanvasWithPalette(TColor).Palette Property

ICanvasWithPalette(TColor).Palette Property
[image]

Gets or sets the color palette associated with this drawing canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract IPalette<TColor> Palette { get; set; }

Visual Basic [image] Copy Code

Public MustOverride Property Palette As IPalette(Of TColor)

Property Value

See Also

ICanvasWithPalette(TColor) Members
ICanvasWithPalette(TColor) Interface


MindFusion.Mapping.IPalette(TColor) Interface

IPalette(TColor) Interface
[image]

Represents a palette of colors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface IPalette<TColor>

Visual Basic [image] Copy Code

Public Interface IPalette(Of TColor)

Inheritors

MindFusion.Mapping.WinForms.GdiPalette

See Also

IPalette(TColor) Members


MindFusion.Mapping.IPalette(TColor) Members

IPalette(TColor) Members
Properties
[image]

Represents a palette of colors.

The following tables list the members exposed by the IPalette(TColor) type.

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

IPalette(TColor) Interface


MindFusion.Mapping.IPalette(TColor) Properties

IPalette(TColor) Properties
[image]

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

IPalette(TColor) Interface


MindFusion.Mapping.IPalette(TColor).FillColors Property

IPalette(TColor).FillColors Property
[image]

Gets or sets an array of fill colors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

TColor[] FillColors { get; set; }

Visual Basic [image] Copy Code

Property FillColors As TColor()

Property Value

See Also

IPalette(TColor) Members
IPalette(TColor) Interface


MindFusion.Mapping.IPalette(TColor).HighlightColor Property

IPalette(TColor).HighlightColor Property
[image]

Gets or sets the highlight color.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

TColor HighlightColor { get; set; }

Visual Basic [image] Copy Code

Property HighlightColor As TColor

Property Value

See Also

IPalette(TColor) Members
IPalette(TColor) Interface


MindFusion.Mapping.IPalette(TColor).LineColor Property

IPalette(TColor).LineColor Property
[image]

Gets or sets the line color.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

TColor LineColor { get; set; }

Visual Basic [image] Copy Code

Property LineColor As TColor

Property Value

See Also

IPalette(TColor) Members
IPalette(TColor) Interface


MindFusion.Mapping.ITransform Interface

ITransform Interface
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface ITransform

Visual Basic [image] Copy Code

Public Interface ITransform

Inheritors

MindFusion.Mapping.WinForms.GdiTransform

See Also

ITransform Members


MindFusion.Mapping.ITransform Members

ITransform Members
Methods
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

The following tables list the members exposed by the ITransform type.

Public Methods

Name | Description
DeviceToWorld | Convert a point from screen to world coordinates.
WorldToDevice | Overloaded.

See Also

ITransform Interface


MindFusion.Mapping.ITransform Methods

ITransform Methods
[image]

Public Methods

Name | Description
DeviceToWorld | Convert a point from screen to world coordinates.
WorldToDevice | Overloaded.

See Also

ITransform Interface


MindFusion.Mapping.ITransform.DeviceToWorld Method

ITransform.DeviceToWorld Method
[image]

Convert a point from screen to world coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

Point DeviceToWorld (
Point point
)

Visual Basic [image] Copy Code

Function DeviceToWorld( _
point As Point _
) As Point

Parameters

point

A Point specifying screen coordinates.

Return Value

A Point containing the corresponding world coordinates.

See Also

ITransform Members
ITransform Interface


MindFusion.Mapping.ITransform.WorldToDevice Method

ITransform.WorldToDevice Method
[image]

Overload List

Name | Description
ITransform.WorldToDevice (Point) | Convert a point from world to screen coordinates.
ITransform.WorldToDevice (Point[]) | Convert an array of points from world to screen coordinates.
ITransform.WorldToDevice (Rect) | Convert a Rect instance from world to screen coordinates.

See Also

ITransform Members
ITransform Interface


MindFusion.Mapping.ITransform.WorldToDevice Method (Point)

ITransform.WorldToDevice Method (Point)
See Also
[image]

Convert a point from world to screen coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

Point WorldToDevice (
Point point
)

Visual Basic [image] Copy Code

Function WorldToDevice( _
point As Point _
) As Point

Parameters

point

A Point specifying world coordinates.

Return Value

A Point containing the corresponding screen coordinates.

See Also

WorldToDevice Method Overload List
ITransform Members
ITransform Interface


MindFusion.Mapping.ITransform.WorldToDevice Method (Point[])

ITransform.WorldToDevice Method (Point[])
See Also
[image]

Convert an array of points from world to screen coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

Point[] WorldToDevice (
Point[] points
)

Visual Basic [image] Copy Code

Function WorldToDevice( _
points() As Point _
) As Point()

Parameters

points

An array of Point objects specifying world coordinates.

Return Value

An array of Point objects containing the corresponding screen coordinates.

See Also

WorldToDevice Method Overload List
ITransform Members
ITransform Interface


MindFusion.Mapping.ITransform.WorldToDevice Method (Rect)

ITransform.WorldToDevice Method (Rect)
See Also
[image]

Convert a Rect instance from world to screen coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

Rect WorldToDevice (
Rect rect
)

Visual Basic [image] Copy Code

Function WorldToDevice( _
rect As Rect _
) As Rect

Parameters

rect

A Rect instance specifying world coordinates.

Return Value

A Rect instance containing the corresponding screen coordinates.

See Also

WorldToDevice Method Overload List
ITransform Members
ITransform Interface


MindFusion.Mapping.Label Class

Label Class
[image]

Represents a text label associated with map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Label

Visual Basic [image] Copy Code

Public Class Label

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Label

See Also

Label Members


MindFusion.Mapping.Label Members

Label Members
Constructors Properties Methods
[image]

Represents a text label associated with map element.

The following tables list the members exposed by the Label type.

Public Constructors

Name | Description
Label | Initializes a new instance of the Label class.

Public Properties

Name | Description
BoundingBox | Gets the bounds of the label.
FontName | Gets or sets the name of the font used to render the label.
FontSize | Gets or sets the size of the font used to render the label.
Rotate | Gets or sets whether the label should rotate to follow shape's direction.
RotationAngle | Gets the rotation angle of the label.
Text | Gets or sets the text of the label.
Visible | Gets or sets whether the label should be visible.
WordWrap | Gets or sets whether the label's text should wrap.

Public Methods

Name | Description
Invalidate | Invalidates the label's position, requesting a new layout.

See Also

Label Class


MindFusion.Mapping.Label Constructor

Label Constructor
[image]

Initializes a new instance of the Label class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Label (
string text
)

Visual Basic [image] Copy Code

Public New ( _
text As String _
)

Parameters

text

See Also

Label Class


MindFusion.Mapping.Label Methods

Label Methods
[image]

Public Methods

Name | Description
Invalidate | Invalidates the label's position, requesting a new layout.

See Also

Label Class


MindFusion.Mapping.Label.Invalidate Method

Label.Invalidate Method
[image]

Invalidates the label's position, requesting a new layout.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void Invalidate ()

Visual Basic [image] Copy Code

Public Sub Invalidate ()

See Also

Label Members
Label Class


MindFusion.Mapping.Label Properties

Label Properties
[image]

Public Properties

Name | Description
BoundingBox | Gets the bounds of the label.
FontName | Gets or sets the name of the font used to render the label.
FontSize | Gets or sets the size of the font used to render the label.
Rotate | Gets or sets whether the label should rotate to follow shape's direction.
RotationAngle | Gets the rotation angle of the label.
Text | Gets or sets the text of the label.
Visible | Gets or sets whether the label should be visible.
WordWrap | Gets or sets whether the label's text should wrap.

See Also

Label Class


MindFusion.Mapping.Label.BoundingBox Property

Label.BoundingBox Property
[image]

Gets the bounds of the label.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect BoundingBox { get; set; }

Visual Basic [image] Copy Code

Public Property BoundingBox As Rect

Property Value

See Also

Label Members
Label Class


MindFusion.Mapping.Label.FontName Property

Label.FontName Property
[image]

Gets or sets the name of the font used to render the label.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

A string specifying font name.

See Also

Label Members
Label Class


MindFusion.Mapping.Label.FontSize Property

Label.FontSize Property
[image]

Gets or sets the size of the font used to render the label.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value specifying font size.

See Also

Label Members
Label Class


MindFusion.Mapping.Label.Rotate Property

Label.Rotate Property
[image]

Gets or sets whether the label should rotate to follow shape's direction.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool Rotate { get; set; }

Visual Basic [image] Copy Code

Public Property Rotate As Boolean

Property Value

true to rotate the label, or false otherwise.

See Also

Label Members
Label Class


MindFusion.Mapping.Label.RotationAngle Property

Label.RotationAngle Property
[image]

Gets the rotation angle of the label.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double RotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAngle As Double

Property Value

A double value specifying label's rotation angle.

See Also

Label Members
Label Class


MindFusion.Mapping.Label.Text Property

Label.Text Property
[image]

Gets or sets the text of the label.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string containing the label's text.

See Also

Label Members
Label Class


MindFusion.Mapping.Label.Visible Property

Label.Visible Property
[image]

Gets or sets whether the label should be visible.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true to draw this label, or false otherwise.

See Also

Label Members
Label Class


MindFusion.Mapping.Label.WordWrap Property

Label.WordWrap Property
[image]

Gets or sets whether the label's text should wrap.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool WordWrap { get; set; }

Visual Basic [image] Copy Code

Public Property WordWrap As Boolean

Property Value

See Also

Label Members
Label Class


MindFusion.Mapping.Layer(TColor, TPalette) Class

Layer(TColor, TPalette) Class
[image]

Represents a map layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class Layer<TColor, TPalette> where TPalette : IPalette<TColor>

Visual Basic [image] Copy Code

Public MustInherit Class Layer(Of TColor, TPalette As IPalette(Of TColor))

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(TColor, TPalette)
MindFusion.Mapping.DecorationLayerBase(TColor, TPalette)
MindFusion.Mapping.MapLayerBase(TColor, TPalette)

See Also

Layer(TColor, TPalette) Members


MindFusion.Mapping.Layer(TColor, TPalette) Members

Layer(TColor, TPalette) Members
Constructors Properties Methods Events
[image]

Represents a map layer.

The following tables list the members exposed by the Layer(TColor, TPalette) type.

Public Constructors

Name | Description
Layer | Initializes a new instance of the Layer class. (Inherited from Layer.)

Public Properties

Name | Description
BoundingBox | Returns the bounding box of elements in this layer. (Inherited from Layer.)
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level. (Inherited from Layer.)
Draw | Overloaded. (Inherited from Layer.)
DrawHighlights | Draws the layer's highlighted elements on the specified canvas. (Inherited from Layer.)
DrawLabels | Draws the labels of elements of this layer on the specified canvas. (Inherited from Layer.)
Highlight | Highlights the specified map element. (Inherited from Layer.)
HitTest | Returns the map element located at the specified point. (Inherited from Layer.)
Select | Overloaded. (Inherited from Layer.)
Toggle | Toggles the selection state the specified map element. (Inherited from Layer.)

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from Layer.)
OnEndLoad | Raises the EndLoad event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
BeginLoad | Raised when the component starts loading map data from a file or memory stream. (Inherited from Layer.)
EndLoad | Raised when the component ends loading map data from a file or memory stream. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette) Constructor

Layer(TColor, TPalette) Constructor
[image]

Initializes a new instance of the Layer class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Layer<TColor, TPalette> ()

Visual Basic [image] Copy Code

Public Sub New(Of TColor, TPalette) ()

See Also

Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette) Methods

Layer(TColor, TPalette) Methods
[image]

Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level. (Inherited from Layer.)
Draw | Overloaded. (Inherited from Layer.)
DrawHighlights | Draws the layer's highlighted elements on the specified canvas. (Inherited from Layer.)
DrawLabels | Draws the labels of elements of this layer on the specified canvas. (Inherited from Layer.)
Highlight | Highlights the specified map element. (Inherited from Layer.)
HitTest | Returns the map element located at the specified point. (Inherited from Layer.)
Select | Overloaded. (Inherited from Layer.)
Toggle | Toggles the selection state the specified map element. (Inherited from Layer.)

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from Layer.)
OnEndLoad | Raises the EndLoad event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

See Also

Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).ClearCache Method

Layer(TColor, TPalette).ClearCache Method
[image]

Clears any cached values associated with the layer for the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public virtual void ClearCache ()

Visual Basic [image] Copy Code

Public Overridable Sub ClearCache ()

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Draw Method

Layer(TColor, TPalette).Draw Method
[image]

Overload List

Name | Description
Layer(TColor, TPalette).Draw (ICanvasWithPalette(TColor), Rect) | Draws the elements of this layer on the specified canvas.
Layer(TColor, TPalette).Draw (MapElement, ICanvas) | Draws the specified map element on the specified canvas.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Draw Method (ICanvasWithPalette(TColor), Rect)

Layer(TColor, TPalette).Draw Method (ICanvasWithPalette(TColor), Rect)
See Also
[image]

Draws the elements of this layer on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void Draw (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Sub Draw( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

Draw Method Overload List
Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Draw Method (MapElement, ICanvas)

Layer(TColor, TPalette).Draw Method (MapElement, ICanvas)
See Also
[image]

Draws the specified map element on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void Draw (
MapElement element,
ICanvas canvas
)

Visual Basic [image] Copy Code

Public Sub Draw( _
element As MapElement, _
canvas As ICanvas _
)

Parameters

element

A MapElement instance that should be rendered on the canvas.

canvas

An ICanvasWithPalette specifying the drawing canvas.

See Also

Draw Method Overload List
Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).DrawHighlights Method

Layer(TColor, TPalette).DrawHighlights Method
[image]

Draws the layer's highlighted elements on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void DrawHighlights (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawHighlights( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).DrawLabels Method

Layer(TColor, TPalette).DrawLabels Method
[image]

Draws the labels of elements of this layer on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void DrawLabels (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawLabels( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Highlight Method

Layer(TColor, TPalette).Highlight Method
[image]

Highlights the specified map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Highlight (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public MustOverride Function Highlight( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be highlighted.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).HitTest Method

Layer(TColor, TPalette).HitTest Method
[image]

Returns the map element located at the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract MapElement HitTest (
Point mousePosition,
ITransform transform
)

Visual Basic [image] Copy Code

Public MustOverride Function HitTest( _
mousePosition As Point, _
transform As ITransform _
) As MapElement

Parameters

mousePosition

A Point instance specifying location.

transform

The transform currently used to draw the map.

Return Value

The MapElement that contains the specified point.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).OnAsyncDatabaseLoadComplete Method

Layer(TColor, TPalette).OnAsyncDatabaseLoadComplete Method
[image]

Raises the AsyncDatabaseLoadComplete event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnAsyncDatabaseLoadComplete ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnAsyncDatabaseLoadComplete ()

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).OnAsyncLoadComplete Method

Layer(TColor, TPalette).OnAsyncLoadComplete Method
[image]

Raises the AsyncLoadComplete event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnAsyncLoadComplete ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnAsyncLoadComplete ()

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).OnPropertyChanged Method

Layer(TColor, TPalette).OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
propertyName As String _
)

Parameters

propertyName

A string specifying the name of the property whose value has changed.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Select Method

Layer(TColor, TPalette).Select Method
[image]

Overload List

Name | Description
Layer(TColor, TPalette).Select (MapElement) | Selects the specified map element.
Layer(TColor, TPalette).Select (Rect) | Selects map elements that intersect with the specified rectangle.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Select Method (MapElement)

Layer(TColor, TPalette).Select Method (MapElement)
See Also
[image]

Selects the specified map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Select (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public MustOverride Function Select( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Select Method (Rect)

Layer(TColor, TPalette).Select Method (Rect)
See Also
[image]

Selects map elements that intersect with the specified rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Select (
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Function Select( _
bounds As Rect _
) As Boolean

Parameters

bounds

A Rect specifying the selection boundaries.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Toggle Method

Layer(TColor, TPalette).Toggle Method
[image]

Toggles the selection state the specified map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Toggle (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public MustOverride Function Toggle( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement whose selection state should be toggled.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).OnBeginLoad Method

Layer(TColor, TPalette).OnBeginLoad Method
[image]

Raises the BeginLoad event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnBeginLoad (
Object sender,
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBeginLoad( _
sender As Object, _
e As EventArgs _
)

Parameters

sender

The source of the event.

e

An object providing the event data.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).OnEndLoad Method

Layer(TColor, TPalette).OnEndLoad Method
[image]

Raises the EndLoad event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnEndLoad (
Object sender,
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEndLoad( _
sender As Object, _
e As EventArgs _
)

Parameters

sender

The source of the event.

e

An object providing the event data.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette) Properties

Layer(TColor, TPalette) Properties
[image]

Public Properties

Name | Description
BoundingBox | Returns the bounding box of elements in this layer. (Inherited from Layer.)
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

See Also

Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).BoundingBox Property

Layer(TColor, TPalette).BoundingBox Property
[image]

Returns the bounding box of elements in this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property BoundingBox As Rect

Property Value

A Rect instance specifying the layer's bounding box.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).EnableHighlight Property

Layer(TColor, TPalette).EnableHighlight Property
[image]

Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool EnableHighlight { get; set; }

Visual Basic [image] Copy Code

Public Property EnableHighlight As Boolean

Property Value

true to highlight elements, otherwise false. The default value is true.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).EnableSelection Property

Layer(TColor, TPalette).EnableSelection Property
[image]

Gets or sets whether map elements should be selected when the user clicks them.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool EnableSelection { get; set; }

Visual Basic [image] Copy Code

Public Property EnableSelection As Boolean

Property Value

true to select elements, otherwise false. The default value is true.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).FillColors Property

Layer(TColor, TPalette).FillColors Property
[image]

Gets or sets the colors used to fill map elements on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TColor[] FillColors { get; set; }

Visual Basic [image] Copy Code

Public Property FillColors As TColor()

Property Value

An array of color objects used as a palette.

Remarks

The Color property of the Shape class is an index within this array.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).HighlightColor Property

Layer(TColor, TPalette).HighlightColor Property
[image]

Gets or sets the color used to highlight elements on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TColor HighlightColor { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightColor As TColor

Property Value

A color used to draw highlighted elements.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).LineColor Property

Layer(TColor, TPalette).LineColor Property
[image]

Gets or sets the line color used to draw elements on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TColor LineColor { get; set; }

Visual Basic [image] Copy Code

Public Property LineColor As TColor

Property Value

A color used to draw border lines.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Palette Property

Layer(TColor, TPalette).Palette Property
[image]

Gets or sets the color palette associated with this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TPalette Palette { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Palette As TPalette

Property Value

A TPalette instance.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Visible Property

Layer(TColor, TPalette).Visible Property
[image]

Gets or sets whether this layer should be visible in the map view.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true to show this layer, otherwise false.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette) Events

Layer(TColor, TPalette) Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
BeginLoad | Raised when the component starts loading map data from a file or memory stream. (Inherited from Layer.)
EndLoad | Raised when the component ends loading map data from a file or memory stream. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).AsyncDatabaseLoadComplete Event

Layer(TColor, TPalette).AsyncDatabaseLoadComplete Event
[image]

Raised when an asynchronous database-read operation is completed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event EventHandler AsyncDatabaseLoadComplete

Visual Basic [image] Copy Code

Public Event AsyncDatabaseLoadComplete As EventHandler

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).AsyncLoadComplete Event

Layer(TColor, TPalette).AsyncLoadComplete Event
[image]

Raised when an asynchronous shapefile-read operation is completed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event EventHandler AsyncLoadComplete

Visual Basic [image] Copy Code

Public Event AsyncLoadComplete As EventHandler

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).PropertyChanged Event

Layer(TColor, TPalette).PropertyChanged Event
[image]

Raised when the value of a property of the Layer class is changed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).BeginLoad Event

Layer(TColor, TPalette).BeginLoad Event
[image]

Raised when the component starts loading map data from a file or memory stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event EventHandler BeginLoad

Visual Basic [image] Copy Code

Public Event BeginLoad As EventHandler

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).EndLoad Event

Layer(TColor, TPalette).EndLoad Event
[image]

Raised when the component ends loading map data from a file or memory stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event EventHandler EndLoad

Visual Basic [image] Copy Code

Public Event EndLoad As EventHandler

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Map Class

Map Class
[image]

Represents a geographic map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Map

Visual Basic [image] Copy Code

Public Class Map

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Map

See Also

Map Members


MindFusion.Mapping.Map Members

Map Members
Constructors Properties Methods Events
[image]

Represents a geographic map.

The following tables list the members exposed by the Map type.

Public Constructors

Name | Description
Map | Initializes a new instance of the Map class.

Public Properties

Name | Description
BoundingBox | Returns the bounding box of all map shapes.
Database | Gets or sets the DBF database associated with the map file.
Shapes | Returns the list of map shapes.
ShapeType | Returns the shape type associated with this map.

Public Methods

Name | Description
AssignColors | Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.
ClearCache | Clears any cached values associated with the map for the current zoom level.
FromFile | Overloaded.
FromXml | Creates and loads a map from the specified file.
HitTest | Overloaded.
Latitude | Overloaded.
LoadFromFile | Overloaded.
LoadFromStream | Overloaded.
LoadFromXml | Loads the map data from the specified OSM map file.
Longitude | Overloaded.
SaveToFile | Saves the map to the specified file.

Protected Methods

Name | Description
OnBeginLoad | Raises the BeginLoad event.
OnEndLoad | Raises the EndLoad event.
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
BeginLoad | Raised when the component starts loading map data from a file or memory stream.
EndLoad | Raised when the component ends loading map data from a file or memory stream.
PropertyChanged | Raised when the value of a property of the Map class is changed.

See Also

Map Class


MindFusion.Mapping.Map Constructor

Map Constructor
[image]

Initializes a new instance of the Map class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Map ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Map Class


MindFusion.Mapping.Map Methods

Map Methods
[image]

Public Methods

Name | Description
AssignColors | Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.
ClearCache | Clears any cached values associated with the map for the current zoom level.
FromFile | Overloaded.
FromXml | Creates and loads a map from the specified file.
HitTest | Overloaded.
Latitude | Overloaded.
LoadFromFile | Overloaded.
LoadFromStream | Overloaded.
LoadFromXml | Loads the map data from the specified OSM map file.
Longitude | Overloaded.
SaveToFile | Saves the map to the specified file.

Protected Methods

Name | Description
OnBeginLoad | Raises the BeginLoad event.
OnEndLoad | Raises the EndLoad event.
OnPropertyChanged | Raises the PropertyChanged event.

See Also

Map Class


MindFusion.Mapping.Map.AssignColors Method

Map.AssignColors Method
[image]

Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void AssignColors ()

Visual Basic [image] Copy Code

Public Sub AssignColors ()

See Also

Map Members
Map Class


MindFusion.Mapping.Map.ClearCache Method

Map.ClearCache Method
[image]

Clears any cached values associated with the map for the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void ClearCache ()

Visual Basic [image] Copy Code

Public Sub ClearCache ()

See Also

Map Members
Map Class


MindFusion.Mapping.Map.FromFile Method

Map.FromFile Method
[image]

Overload List

Name | Description
Map.FromFile (String) | Creates and loads a map from the specified file.
Map.FromFile (String, Boolean, String) | Creates and loads a map from the specified file.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.FromFile Method (String)

Map.FromFile Method (String)
See Also
[image]

Creates and loads a map from the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Map FromFile (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function FromFile( _
fileName As String _
) As Map

Parameters

fileName

Specifies the file name of an ESRI map file.

Return Value

The Map loaded from the specified file.

See Also

FromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.FromFile Method (String, Boolean, String)

Map.FromFile Method (String, Boolean, String)
See Also
[image]

Creates and loads a map from the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Map FromFile (
string fileName,
bool loadDatabase,
string labelField
)

Visual Basic [image] Copy Code

Public Shared Function FromFile( _
fileName As String, _
loadDatabase As Boolean, _
labelField As String _
) As Map

Parameters

fileName

Specifies the file name of an ESRI map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

labelField

A string specifying the name of the database column whose fields should be used as map element labels.

Return Value

The Map loaded from the specified file.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

FromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.FromXml Method

Map.FromXml Method
[image]

Creates and loads a map from the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Map FromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function FromXml( _
fileName As String _
) As Map

Parameters

fileName

Specifies the file name of an OSM map file.

Return Value

The Map loaded from the specified file.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.HitTest Method

Map.HitTest Method
[image]

Overload List

Name | Description
Map.HitTest (Point) | Returns the Shape that contains the specified point.
Map.HitTest (Point, ITransform) | Returns the Shape that contains the specified point.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.HitTest Method (Point)

Map.HitTest Method (Point)
See Also
[image]

Returns the Shape that contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Shape HitTest (
Point point
)

Visual Basic [image] Copy Code

Public Function HitTest( _
point As Point _
) As Shape

Parameters

point

A Point instance specifying location on the map.

Return Value

The Shape that contains the specified point.

See Also

HitTest Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.HitTest Method (Point, ITransform)

Map.HitTest Method (Point, ITransform)
See Also
[image]

Returns the Shape that contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Shape HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Public Function HitTest( _
point As Point, _
transform As ITransform _
) As Shape

Parameters

point

A Point instance specifying location on the map.

transform

An ITransform specifying the transform used to render this map.

Return Value

The Shape that contains the specified point.

See Also

HitTest Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.Latitude Method

Map.Latitude Method
[image]

Overload List

Name | Description
Map.Latitude (Double, Double, Char) | Converts latitude specified in arc degree, minutes, 'N'/'S' to its representation as a double value.
Map.Latitude (Double, Double, Double, Char) | Converts latitude specified in arc degrees, minutes, seconds, 'N'/'S' to its representation as a double value.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.Latitude Method (Double, Double, Char)

Map.Latitude Method (Double, Double, Char)
See Also
[image]

Converts latitude specified in arc degree, minutes, 'N'/'S' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Latitude (
double degrees,
double minutes,
char ns
)

Visual Basic [image] Copy Code

Public Shared Function Latitude( _
degrees As Double, _
minutes As Double, _
ns As Char _
) As Double

Parameters

degrees

Specifies the latitude arc degrees.

minutes

Specifies the latitude arc minutes.

ns

A char value specifying 'N' for north or 'S' for south.

Return Value

A double value representing the specified latitude.

See Also

Latitude Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.Latitude Method (Double, Double, Double, Char)

Map.Latitude Method (Double, Double, Double, Char)
See Also
[image]

Converts latitude specified in arc degrees, minutes, seconds, 'N'/'S' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Latitude (
double degrees,
double minutes,
double seconds,
char ns
)

Visual Basic [image] Copy Code

Public Shared Function Latitude( _
degrees As Double, _
minutes As Double, _
seconds As Double, _
ns As Char _
) As Double

Parameters

degrees

Specifies the latitude arc degrees.

minutes

Specifies the latitude arc minutes.

seconds

Specifies the latitude arc seconds.

ns

A char value specifying 'N' for north or 'S' for south.

Return Value

A double value representing the specified latitude.

See Also

Latitude Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromFile Method

Map.LoadFromFile Method
[image]

Overload List

Name | Description
Map.LoadFromFile (String) | Loads the map data from the specified ESRI map file.
Map.LoadFromFile (String, Boolean) | Loads the map data from the specified ESRI map file.
Map.LoadFromFile (String, Boolean, Int32) | Loads the map data from the specified ESRI map file.
Map.LoadFromFile (String, Boolean, String) | Loads the map data from the specified ESRI map file.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.LoadFromFile Method (String)

Map.LoadFromFile Method (String)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String _
)

Parameters

fileName

The file name of the map file.

See Also

LoadFromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromFile Method (String, Boolean)

Map.LoadFromFile Method (String, Boolean)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName,
bool loadDatabase
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String, _
loadDatabase As Boolean _
)

Parameters

fileName

The file name of the map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromFile Method (String, Boolean, Int32)

Map.LoadFromFile Method (String, Boolean, Int32)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName,
bool loadDatabase,
int labelField
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String, _
loadDatabase As Boolean, _
labelField As Integer _
)

Parameters

fileName

The file name of the map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

labelField

An integer specifying the index of the database column whose fields should be used as map element labels.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromFile Method (String, Boolean, String)

Map.LoadFromFile Method (String, Boolean, String)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName,
bool loadDatabase,
string labelField
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String, _
loadDatabase As Boolean, _
labelField As String _
)

Parameters

fileName

The file name of the map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

labelField

A string specifying the name of the database column whose fields should be used as map element labels.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromStream Method

Map.LoadFromStream Method
[image]

Overload List

Name | Description
Map.LoadFromStream (Stream) | Loads the map data from the specified stream.
Map.LoadFromStream (Stream, Stream, String) | Loads the map data from the specified stream.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.LoadFromStream Method (Stream)

Map.LoadFromStream Method (Stream)
See Also
[image]

Loads the map data from the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromStream (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromStream( _
stream As Stream _
)

Parameters

stream

A System.IO.Stream instance representing shapefile data.

See Also

LoadFromStream Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromStream Method (Stream, Stream, String)

Map.LoadFromStream Method (Stream, Stream, String)
See Also
[image]

Loads the map data from the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromStream (
Stream mapStream,
Stream dbfStream,
string labelField
)

Visual Basic [image] Copy Code

Public Sub LoadFromStream( _
mapStream As Stream, _
dbfStream As Stream, _
labelField As String _
)

Parameters

mapStream

A System.IO.Stream instance representing shapefile data.

dbfStream

A System.IO.Stream instance representing the map database.

labelField

Specifies the name of the database column containing labels of map elements.

See Also

LoadFromStream Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromXml Method

Map.LoadFromXml Method
[image]

Loads the map data from the specified OSM map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromXml (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
fileName As String _
)

Parameters

fileName

The file name of the map file.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.Longitude Method

Map.Longitude Method
[image]

Overload List

Name | Description
Map.Longitude (Double, Double, Char) | Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.
Map.Longitude (Double, Double, Double, Char) | Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.Longitude Method (Double, Double, Char)

Map.Longitude Method (Double, Double, Char)
See Also
[image]

Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Longitude (
double degrees,
double minutes,
char ew
)

Visual Basic [image] Copy Code

Public Shared Function Longitude( _
degrees As Double, _
minutes As Double, _
ew As Char _
) As Double

Parameters

degrees

Specifies the longitude arc degrees.

minutes

Specifies the longitude arc minutes.

ew

A char value specifying 'E' for east or 'W' for west.

Return Value

A double value representing the specified longitude.

See Also

Longitude Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.Longitude Method (Double, Double, Double, Char)

Map.Longitude Method (Double, Double, Double, Char)
See Also
[image]

Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Longitude (
double degrees,
double minutes,
double seconds,
char ew
)

Visual Basic [image] Copy Code

Public Shared Function Longitude( _
degrees As Double, _
minutes As Double, _
seconds As Double, _
ew As Char _
) As Double

Parameters

degrees

Specifies the longitude arc degrees.

minutes

Specifies the longitude arc minutes.

seconds

Specifies the longitude arc seconds.

ew

A char value specifying 'E' for east or 'W' for west.

Return Value

A double value representing the specified longitude.

See Also

Longitude Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.OnPropertyChanged Method

Map.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
propertyName As String _
)

Parameters

propertyName

A string specifying the name of the property whose value has changed.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.SaveToFile Method

Map.SaveToFile Method
[image]

Saves the map to the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveToFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToFile( _
fileName As String _
)

Parameters

fileName

A string specifying the file name.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.OnBeginLoad Method

Map.OnBeginLoad Method
[image]

Raises the BeginLoad event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnBeginLoad (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBeginLoad( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.OnEndLoad Method

Map.OnEndLoad Method
[image]

Raises the EndLoad event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnEndLoad (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEndLoad( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

Map Members
Map Class


MindFusion.Mapping.Map Properties

Map Properties
[image]

Public Properties

Name | Description
BoundingBox | Returns the bounding box of all map shapes.
Database | Gets or sets the DBF database associated with the map file.
Shapes | Returns the list of map shapes.
ShapeType | Returns the shape type associated with this map.

See Also

Map Class


MindFusion.Mapping.Map.BoundingBox Property

Map.BoundingBox Property
[image]

Returns the bounding box of all map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect BoundingBox { get; set; }

Visual Basic [image] Copy Code

Public Property BoundingBox As Rect

Property Value

A Rect instance specifying the map's bounding box.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.Database Property

Map.Database Property
[image]

Gets or sets the DBF database associated with the map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database Database { get; set; }

Visual Basic [image] Copy Code

Public Property Database As Database

Property Value

A Database instance.

Remarks

This property is set by LoadFromFile if the loadDatabase parameter is set to true.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.Shapes Property

Map.Shapes Property
[image]

Returns the list of map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Shape> Shapes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shapes As List(Of Shape)

Property Value

A List of Shape objects.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.ShapeType Property

Map.ShapeType Property
[image]

Returns the shape type associated with this map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public ShapeType ShapeType { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeType As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

Map Members
Map Class


MindFusion.Mapping.Map Events

Map Events
[image]

Public Events

Name | Description
BeginLoad | Raised when the component starts loading map data from a file or memory stream.
EndLoad | Raised when the component ends loading map data from a file or memory stream.
PropertyChanged | Raised when the value of a property of the Map class is changed.

See Also

Map Class


MindFusion.Mapping.Map.PropertyChanged Event

Map.PropertyChanged Event
[image]

Raised when the value of a property of the Map class is changed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

Map Members
Map Class


MindFusion.Mapping.Map.BeginLoad Event

Map.BeginLoad Event
[image]

Raised when the component starts loading map data from a file or memory stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event EventHandler BeginLoad

Visual Basic [image] Copy Code

Public Event BeginLoad As EventHandler

See Also

Map Members
Map Class


MindFusion.Mapping.Map.EndLoad Event

Map.EndLoad Event
[image]

Raised when the component ends loading map data from a file or memory stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event EventHandler EndLoad

Visual Basic [image] Copy Code

Public Event EndLoad As EventHandler

See Also

Map Members
Map Class


MindFusion.Mapping.MapElement Class

MapElement Class
[image]

Represents visual elements of a map that can be drawn and hit-tested.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class MapElement

Visual Basic [image] Copy Code

Public MustInherit Class MapElement

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.Shape

See Also

MapElement Members


MindFusion.Mapping.MapElement Members

MapElement Members
Constructors Properties Methods
[image]

Represents visual elements of a map that can be drawn and hit-tested.

The following tables list the members exposed by the MapElement type.

Public Constructors

Name | Description
MapElement | Initializes a new instance of the MapElement class.

Public Properties

Name | Description
Label | Gets or sets the label of this map element.

Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface.
DrawLabel | Draws the label of this map element.
Highlight | Draws a highlight of this map element.
HitTest | Tests whether this map element contains the specified point.

See Also

MapElement Class


MindFusion.Mapping.MapElement Constructor

MapElement Constructor
[image]

Initializes a new instance of the MapElement class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public MapElement ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapElement Class


MindFusion.Mapping.MapElement Methods

MapElement Methods
[image]

Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface.
DrawLabel | Draws the label of this map element.
Highlight | Draws a highlight of this map element.
HitTest | Tests whether this map element contains the specified point.

See Also

MapElement Class


MindFusion.Mapping.MapElement.Draw Method

MapElement.Draw Method
[image]

Draws this map element on the specified drawing surface.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected abstract void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected MustOverride Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapElement.DrawLabel Method

MapElement.DrawLabel Method
[image]

Draws the label of this map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapElement.Highlight Method

MapElement.Highlight Method
[image]

Draws a highlight of this map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapElement.HitTest Method

MapElement.HitTest Method
[image]

Tests whether this map element contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected abstract bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected MustOverride Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapElement Properties

MapElement Properties
[image]

Public Properties

Name | Description
Label | Gets or sets the label of this map element.

See Also

MapElement Class


MindFusion.Mapping.MapElement.Label Property

MapElement.Label Property
[image]

Gets or sets the label of this map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Label Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As Label

Property Value

A string specifying the label text.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapFeature Structure

MapFeature Structure
Remarks See Also
[image]

Contains OpenStreetMap key and value tags describing a map feature.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public struct MapFeature

Visual Basic [image] Copy Code

Public Structure MapFeature

Remarks

For a list of standard key and value identifiers of map features, see http://wiki.openstreetmap.org/wiki/Map_Features [image] .

See Also

MapFeature Members


MindFusion.Mapping.MapFeature Members

MapFeature Members
Constructors Properties Methods
[image]

Contains OpenStreetMap key and value tags describing a map feature.

The following tables list the members exposed by the MapFeature type.

Public Constructors

Name | Description
MapFeature | Initializes a new instance of the MapFeature struct.

Public Properties

Name | Description
Key | Gets the map feature key.
Value | Gets the map feature value.

Public Methods

Name | Description
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

MapFeature Structure


MindFusion.Mapping.MapFeature Constructor

MapFeature Constructor
[image]

Initializes a new instance of the MapFeature struct.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public MapFeature (
string key,
string value
)

Visual Basic [image] Copy Code

Public New ( _
key As String, _
value As String _
)

Parameters

key

The feature's key.

value

The feature's value.

See Also

MapFeature Structure


MindFusion.Mapping.MapFeature Methods

MapFeature Methods
[image]

Public Methods

Name | Description
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

MapFeature Structure


MindFusion.Mapping.MapFeature.Equals Method

MapFeature.Equals Method
[image]

Object.Equals override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with this instance.

Return Value

true if the objects are equal, or false otherwise.

See Also

MapFeature Members
MapFeature Structure


MindFusion.Mapping.MapFeature.GetHashCode Method

MapFeature.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

An integer value containing the hash-code.

See Also

MapFeature Members
MapFeature Structure


MindFusion.Mapping.MapFeature Properties

MapFeature Properties
[image]

Public Properties

Name | Description
Key | Gets the map feature key.
Value | Gets the map feature value.

See Also

MapFeature Structure


MindFusion.Mapping.MapFeature.Key Property

MapFeature.Key Property
[image]

Gets the map feature key.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Key { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Key As String

Property Value

See Also

MapFeature Members
MapFeature Structure


MindFusion.Mapping.MapFeature.Value Property

MapFeature.Value Property
[image]

Gets the map feature value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Value { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Value As String

Property Value

See Also

MapFeature Members
MapFeature Structure


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Class

MapLayerBase(TColor, TPalette) Class
[image]

Represents a map layer containing geometric shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class MapLayerBase<TColor, TPalette> : Layer<TColor, TPalette> where TPalette : IPalette<TColor>

Visual Basic [image] Copy Code

Public Class MapLayerBase(Of TColor, TPalette As IPalette(Of TColor))
Inherits Layer(Of TColor, TPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(TColor, TPalette)
MindFusion.Mapping.MapLayerBase(TColor, TPalette)
MindFusion.Mapping.WinForms.MapLayer
MindFusion.Mapping.WinForms.StreetMapLayer

See Also

MapLayerBase(TColor, TPalette) Members


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Members

MapLayerBase(TColor, TPalette) Members
Constructors Properties Methods Events
[image]

Represents a map layer containing geometric shapes.

The following tables list the members exposed by the MapLayerBase(TColor, TPalette) type.

Public Constructors

Name | Description
MapLayerBase | Initializes a new instance of the MapLayerBase class. (Inherited from MapLayerBase.)

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override. (Inherited from MapLayerBase.)
Map | Gets or sets the Map whose elements should be rendered on this layer. (Inherited from MapLayerBase.)
Selection | Gets the list of selected map shapes. (Inherited from MapLayerBase.)

Inherited Public Properties

Name | Description
BoundingBox | Returns the bounding box of elements in this layer. (Inherited from Layer.)
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

Public Methods

Name | Description
ClearCache | Layer.ClearCache override. (Inherited from MapLayerBase.)
Draw | Layer.Draw override. (Inherited from MapLayerBase.)
DrawHighlights | Overrides Layer.DrawHighlights. (Inherited from MapLayerBase.)
DrawLabels | Layer.DrawLabels override. (Inherited from MapLayerBase.)
DrawStreetMap | Layer.DrawStreetMap override. (Inherited from MapLayerBase.)
Highlight | Layer.Highlight override. (Inherited from MapLayerBase.)
HitTest | Layer.HitTest override. (Inherited from MapLayerBase.)
Select | Overloaded. (Inherited from MapLayerBase.)
Toggle | Layer.Toggle override. (Inherited from MapLayerBase.)

Protected Methods

Name | Description
OnBeginLoad | Raises the BeginLoad event. (Inherited from MapLayerBase.)

Inherited Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level. (Inherited from Layer.)
Draw | Overloaded. (Inherited from Layer.)
DrawHighlights | Draws the layer's highlighted elements on the specified canvas. (Inherited from Layer.)
DrawLabels | Draws the labels of elements of this layer on the specified canvas. (Inherited from Layer.)
Highlight | Highlights the specified map element. (Inherited from Layer.)
HitTest | Returns the map element located at the specified point. (Inherited from Layer.)
Select | Overloaded. (Inherited from Layer.)
Toggle | Toggles the selection state the specified map element. (Inherited from Layer.)

Inherited Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from Layer.)
OnEndLoad | Raises the EndLoad event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

Inherited Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
BeginLoad | Raised when the component starts loading map data from a file or memory stream. (Inherited from Layer.)
EndLoad | Raised when the component ends loading map data from a file or memory stream. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Constructor

MapLayerBase(TColor, TPalette) Constructor
[image]

Initializes a new instance of the MapLayerBase class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public MapLayerBase<TColor, TPalette> ()

Visual Basic [image] Copy Code

Public Sub New(Of TColor, TPalette) ()

See Also

MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Methods

MapLayerBase(TColor, TPalette) Methods
[image]

Public Methods

Name | Description
ClearCache | Layer.ClearCache override. (Inherited from MapLayerBase.)
Draw | Layer.Draw override. (Inherited from MapLayerBase.)
DrawHighlights | Overrides Layer.DrawHighlights. (Inherited from MapLayerBase.)
DrawLabels | Layer.DrawLabels override. (Inherited from MapLayerBase.)
DrawStreetMap | Layer.DrawStreetMap override. (Inherited from MapLayerBase.)
Highlight | Layer.Highlight override. (Inherited from MapLayerBase.)
HitTest | Layer.HitTest override. (Inherited from MapLayerBase.)
Select | Overloaded. (Inherited from MapLayerBase.)
Toggle | Layer.Toggle override. (Inherited from MapLayerBase.)

Protected Methods

Name | Description
OnBeginLoad | Raises the BeginLoad event. (Inherited from MapLayerBase.)

Inherited Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level. (Inherited from Layer.)
Draw | Overloaded. (Inherited from Layer.)
DrawHighlights | Draws the layer's highlighted elements on the specified canvas. (Inherited from Layer.)
DrawLabels | Draws the labels of elements of this layer on the specified canvas. (Inherited from Layer.)
Highlight | Highlights the specified map element. (Inherited from Layer.)
HitTest | Returns the map element located at the specified point. (Inherited from Layer.)
Select | Overloaded. (Inherited from Layer.)
Toggle | Toggles the selection state the specified map element. (Inherited from Layer.)

Inherited Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from Layer.)
OnEndLoad | Raises the EndLoad event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

See Also

MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).ClearCache Method

MapLayerBase(TColor, TPalette).ClearCache Method
[image]

Layer.ClearCache override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void ClearCache ()

Visual Basic [image] Copy Code

Public Overrides Sub ClearCache ()

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Draw Method

MapLayerBase(TColor, TPalette).Draw Method
[image]

Layer.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void Draw (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).DrawHighlights Method

MapLayerBase(TColor, TPalette).DrawHighlights Method
[image]

Overrides Layer.DrawHighlights.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawHighlights (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHighlights( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).DrawLabels Method

MapLayerBase(TColor, TPalette).DrawLabels Method
[image]

Layer.DrawLabels override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawLabels (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLabels( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).DrawStreetMap Method

MapLayerBase(TColor, TPalette).DrawStreetMap Method
[image]

Layer.DrawStreetMap override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void DrawStreetMap (
ICanvas canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Sub DrawStreetMap( _
canvas As ICanvas, _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Highlight Method

MapLayerBase(TColor, TPalette).Highlight Method
[image]

Layer.Highlight override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Highlight (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Highlight( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be highlighted.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).HitTest Method

MapLayerBase(TColor, TPalette).HitTest Method
[image]

Layer.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override MapElement HitTest (
Point mousePosition,
ITransform transform
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
mousePosition As Point, _
transform As ITransform _
) As MapElement

Parameters

mousePosition

A Point instance specifying location.

transform

The transform currently used to draw the map.

Return Value

The MapElement that contains the specified point.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Select Method

MapLayerBase(TColor, TPalette).Select Method
[image]

Overload List

Name | Description
MapLayerBase(TColor, TPalette).Select (MapElement) | Layer.Select override.
MapLayerBase(TColor, TPalette).Select (Rect) | Layer.Select override.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Select Method (MapElement)

MapLayerBase(TColor, TPalette).Select Method (MapElement)
See Also
[image]

Layer.Select override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Select (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Select Method (Rect)

MapLayerBase(TColor, TPalette).Select Method (Rect)
See Also
[image]

Layer.Select override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Select (
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
bounds As Rect _
) As Boolean

Parameters

bounds

A Rect instance specifying the area in which elements should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Select Method Overload List
MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Toggle Method

MapLayerBase(TColor, TPalette).Toggle Method
[image]

Layer.Toggle override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Toggle (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Toggle( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement whose selection state should be toggled.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).OnBeginLoad Method

MapLayerBase(TColor, TPalette).OnBeginLoad Method
[image]

Raises the BeginLoad event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override void OnBeginLoad (
Object sender,
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnBeginLoad( _
sender As Object, _
e As EventArgs _
)

Parameters

sender

The source of the event.

e

An object providing the event data.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Properties

MapLayerBase(TColor, TPalette) Properties
[image]

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override. (Inherited from MapLayerBase.)
Map | Gets or sets the Map whose elements should be rendered on this layer. (Inherited from MapLayerBase.)
Selection | Gets the list of selected map shapes. (Inherited from MapLayerBase.)

Inherited Public Properties

Name | Description
BoundingBox | Returns the bounding box of elements in this layer. (Inherited from Layer.)
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

See Also

MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).BoundingBox Property

MapLayerBase(TColor, TPalette).BoundingBox Property
[image]

Layer.BoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property BoundingBox As Rect

Property Value

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Map Property

MapLayerBase(TColor, TPalette).Map Property
[image]

Gets or sets the Map whose elements should be rendered on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Map Map { get; set; }

Visual Basic [image] Copy Code

Public Property Map As Map

Property Value

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Selection Property

MapLayerBase(TColor, TPalette).Selection Property
[image]

Gets the list of selected map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Shape> Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As List(Of Shape)

Property Value

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.NullShape Class

NullShape Class
[image]

Represents a null shape with no geometric data; often used as a place holder until data becomes available.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class NullShape : Shape

Visual Basic [image] Copy Code

Public Class NullShape
Inherits Shape

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Shape
MindFusion.Mapping.NullShape

See Also

NullShape Members


MindFusion.Mapping.NullShape Members

NullShape Members
Constructors Fields Properties Methods
[image]

Represents a null shape with no geometric data; often used as a place holder until data becomes available.

The following tables list the members exposed by the NullShape type.

Public Constructors

Name | Description
NullShape | Initializes a new instance of the NullShape class.

Inherited Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file. (Inherited from Shape.)

Public Properties

Name | Description
Type | Shape.Type override.

Inherited Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette. (Inherited from Shape.)
DatabaseRow | Gets the DBF database row associated with this Shape. (Inherited from Shape.)
HitTestDistance | Gets or set the current hit test threshold distance. (Inherited from Shape.)
IsStreetShape | Gets or sets whether this object represents an OpenStreetMap shape. (Inherited from Shape.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
PenKey | Gets or sets a key used to associate a pen with this shape's map feature. (Inherited from Shape.)
Size | Gets the shape's area. (Inherited from Shape.)
Type | Gets the ESRI shape type of this Shape. (Inherited from Shape.)
ZIndex | Gets or sets the shape's Z order index. (Inherited from Shape.)

Public Methods

Name | Description
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
SaveTo | Shape.SaveTo override.

Protected Methods

Name | Description
Draw | MapElement.Draw override.
HitTest | MapElement.HitTest override.

Inherited Public Methods

Name | Description
GetBoundingBox | Gets the bounding box of this shape. (Inherited from Shape.)
GetCenter | Gets the center point of this shape. (Inherited from Shape.)
GetPoints | Returns the vertex points of this shape. (Inherited from Shape.)
SaveTo | Saves this shape to the specified stream. (Inherited from Shape.)

Inherited Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level. (Inherited from Shape.)
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

NullShape Class


MindFusion.Mapping.NullShape Constructor

NullShape Constructor
[image]

Initializes a new instance of the NullShape class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public NullShape (
int id
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer _
)

Parameters

id

The record number of this shape in the ESRI map file.

See Also

NullShape Class


MindFusion.Mapping.NullShape Methods

NullShape Methods
[image]

Public Methods

Name | Description
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
SaveTo | Shape.SaveTo override.

Protected Methods

Name | Description
Draw | MapElement.Draw override.
HitTest | MapElement.HitTest override.

Inherited Public Methods

Name | Description
GetBoundingBox | Gets the bounding box of this shape. (Inherited from Shape.)
GetCenter | Gets the center point of this shape. (Inherited from Shape.)
GetPoints | Returns the vertex points of this shape. (Inherited from Shape.)
SaveTo | Saves this shape to the specified stream. (Inherited from Shape.)

Inherited Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level. (Inherited from Shape.)
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

NullShape Class


MindFusion.Mapping.NullShape.Draw Method

NullShape.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.NullShape.GetBoundingBox Method

NullShape.GetBoundingBox Method
[image]

Shape.GetBoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect GetBoundingBox ()

Visual Basic [image] Copy Code

Public Overrides Function GetBoundingBox () As Rect

Return Value

A Rect representing the shape's bounding box.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.NullShape.GetCenter Method

NullShape.GetCenter Method
[image]

Shape.GetCenter override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Point GetCenter ()

Visual Basic [image] Copy Code

Public Overrides Function GetCenter () As Point

Return Value

A Point representing the shape's center.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.NullShape.HitTest Method

NullShape.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overridable Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.NullShape.SaveTo Method

NullShape.SaveTo Method
[image]

Shape.SaveTo override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the shape's data to a stream.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.NullShape Properties

NullShape Properties
[image]

Public Properties

Name | Description
Type | Shape.Type override.

Inherited Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette. (Inherited from Shape.)
DatabaseRow | Gets the DBF database row associated with this Shape. (Inherited from Shape.)
HitTestDistance | Gets or set the current hit test threshold distance. (Inherited from Shape.)
IsStreetShape | Gets or sets whether this object represents an OpenStreetMap shape. (Inherited from Shape.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
PenKey | Gets or sets a key used to associate a pen with this shape's map feature. (Inherited from Shape.)
Size | Gets the shape's area. (Inherited from Shape.)
Type | Gets the ESRI shape type of this Shape. (Inherited from Shape.)
ZIndex | Gets or sets the shape's Z order index. (Inherited from Shape.)

See Also

NullShape Class


MindFusion.Mapping.NullShape.Type Property

NullShape.Type Property
[image]

Shape.Type override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override ShapeType Type { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Type As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.Point Class

Point Class
[image]

Represents a point on the map with X (longitude) and Y (latitude) coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Point : Shape

Visual Basic [image] Copy Code

Public Class Point
Inherits Shape

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Shape
MindFusion.Mapping.Point

See Also

Point Members


MindFusion.Mapping.Point Members

Point Members
Constructors Fields Properties Methods
[image]

Represents a point on the map with X (longitude) and Y (latitude) coordinates.

The following tables list the members exposed by the Point type.

Public Constructors

Name | Description
Point | Overloaded.

Public Fields

Name | Description
X | The X coordinate of this Point.
Y | The Y coordinate of this Point.

Inherited Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file. (Inherited from Shape.)

Public Properties

Name | Description
Type | Shape.Type override.

Inherited Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette. (Inherited from Shape.)
DatabaseRow | Gets the DBF database row associated with this Shape. (Inherited from Shape.)
HitTestDistance | Gets or set the current hit test threshold distance. (Inherited from Shape.)
IsStreetShape | Gets or sets whether this object represents an OpenStreetMap shape. (Inherited from Shape.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
PenKey | Gets or sets a key used to associate a pen with this shape's map feature. (Inherited from Shape.)
Size | Gets the shape's area. (Inherited from Shape.)
Type | Gets the ESRI shape type of this Shape. (Inherited from Shape.)
ZIndex | Gets or sets the shape's Z order index. (Inherited from Shape.)

Public Methods

Name | Description
Angle | Returns the angle between the X axis and the line passinh through specified point and this point.
Clone | Clones this point.
Distance | Returns the distance from this point to the specified point.
Equals | Overloaded.
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
GetHashCode | Object.GetHashCode override.
GetPoints | Shape.GetPoints override.
SaveTo | Saves the point to the specified stream.
ToString | Object.ToString override.

Protected Methods

Name | Description
ClearCache | Clears cached label positions.
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

Inherited Public Methods

Name | Description
GetBoundingBox | Gets the bounding box of this shape. (Inherited from Shape.)
GetCenter | Gets the center point of this shape. (Inherited from Shape.)
GetPoints | Returns the vertex points of this shape. (Inherited from Shape.)
SaveTo | Saves this shape to the specified stream. (Inherited from Shape.)

Inherited Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level. (Inherited from Shape.)
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

Point Class


MindFusion.Mapping.Point Fields

Point Fields
[image]

Public Fields

Name | Description
X | The X coordinate of this Point.
Y | The Y coordinate of this Point.

Inherited Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file. (Inherited from Shape.)

See Also

Point Class


MindFusion.Mapping.Point.X Field

Point.X Field
[image]

The X coordinate of this Point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double X

Visual Basic [image] Copy Code

Public X As Double

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Y Field

Point.Y Field
[image]

The Y coordinate of this Point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Y

Visual Basic [image] Copy Code

Public Y As Double

See Also

Point Members
Point Class


MindFusion.Mapping.Point Constructor

Point Constructor
[image]

Overload List

Name | Description
Point (Double, Double) | Initializes a new instance of the Point class.
Point (Int32, BinaryReader) | Initializes a new instance of the Point class.
Point (Int32, StreetShape) | Initializes a new instance of the Point class.

See Also

Point Class


MindFusion.Mapping.Point Constructor (Double, Double)

Point Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the Point class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying longitude.

y

A double value specifying latitude.

See Also

Point Constructor Overload List
Point Class


MindFusion.Mapping.Point Constructor (Int32, BinaryReader)

Point Constructor (Int32, BinaryReader)
See Also
[image]

Initializes a new instance of the Point class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point (
int id,
BinaryReader reader
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer, _
reader As BinaryReader _
)

Parameters

id

The record number of this point in the ESRI map file.

reader

A BinaryReader used to read the point data.

See Also

Point Constructor Overload List
Point Class


MindFusion.Mapping.Point Constructor (Int32, StreetShape)

Point Constructor (Int32, StreetShape)
See Also
[image]

Initializes a new instance of the Point class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point (
int id,
StreetShape shape
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer, _
shape As StreetShape _
)

Parameters

id

The point's identifier in OpenStreetMap file.

shape

A StreetShape containing the shape's attributes.

See Also

Point Constructor Overload List
Point Class


MindFusion.Mapping.Point Methods

Point Methods
[image]

Public Methods

Name | Description
Angle | Returns the angle between the X axis and the line passinh through specified point and this point.
Clone | Clones this point.
Distance | Returns the distance from this point to the specified point.
Equals | Overloaded.
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
GetHashCode | Object.GetHashCode override.
GetPoints | Shape.GetPoints override.
SaveTo | Saves the point to the specified stream.
ToString | Object.ToString override.

Protected Methods

Name | Description
ClearCache | Clears cached label positions.
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

Inherited Public Methods

Name | Description
GetBoundingBox | Gets the bounding box of this shape. (Inherited from Shape.)
GetCenter | Gets the center point of this shape. (Inherited from Shape.)
GetPoints | Returns the vertex points of this shape. (Inherited from Shape.)
SaveTo | Saves this shape to the specified stream. (Inherited from Shape.)

Inherited Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level. (Inherited from Shape.)
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

Point Class


MindFusion.Mapping.Point.Angle Method

Point.Angle Method
[image]

Returns the angle between the X axis and the line passinh through specified point and this point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Angle (
Point point
)

Visual Basic [image] Copy Code

Public Function Angle( _
point As Point _
) As Double

Parameters

point

Specifies the second point of line segment.

Return Value

The angle between specified line and X axis.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.ClearCache Method

Point.ClearCache Method
[image]

Clears cached label positions.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override void ClearCache ()

Visual Basic [image] Copy Code

Protected Overrides Sub ClearCache ()

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Clone Method

Point.Clone Method
[image]

Clones this point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Point

Return Value

A Point instance with the same coordinates as this point.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Distance Method

Point.Distance Method
[image]

Returns the distance from this point to the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Distance (
Point point
)

Visual Basic [image] Copy Code

Public Function Distance( _
point As Point _
) As Double

Parameters

point

A Point instance.

Return Value

A double value representing the distance between the two points.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Draw Method

Point.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.DrawLabel Method

Point.DrawLabel Method
[image]

MapElement.DrawLabel override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Equals Method

Point.Equals Method
[image]

Overload List

Name | Description
Point.Equals (Object) | Object.Equals override.
Point.Equals (Point) | Determines whether the specified Point is equal to this Point.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Equals Method (Object)

Point.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with this object.

Return Value

true if the specified Object is equal to the current Object, otherwise false.

See Also

Equals Method Overload List
Point Members
Point Class


MindFusion.Mapping.Point.Equals Method (Point)

Point.Equals Method (Point)
See Also
[image]

Determines whether the specified Point is equal to this Point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public new bool Equals (
Point other
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
other As Point _
) As Boolean

Parameters

other

The Point to compare with this point.

Return Value

true if the specified Point is equal to the current Point, otherwise false.

See Also

Equals Method Overload List
Point Members
Point Class


MindFusion.Mapping.Point.GetBoundingBox Method

Point.GetBoundingBox Method
[image]

Shape.GetBoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect GetBoundingBox ()

Visual Basic [image] Copy Code

Public Overrides Function GetBoundingBox () As Rect

Return Value

A Rect representing the shape's bounding box.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.GetCenter Method

Point.GetCenter Method
[image]

Shape.GetCenter override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Point GetCenter ()

Visual Basic [image] Copy Code

Public Overrides Function GetCenter () As Point

Return Value

A Point representing the shape's center.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.GetHashCode Method

Point.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the this point.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.GetPoints Method

Point.GetPoints Method
[image]

Shape.GetPoints override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override List<Point> GetPoints ()

Visual Basic [image] Copy Code

Public Overrides Function GetPoints () As List(Of Point)

Return Value

A list containing this point.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Highlight Method

Point.Highlight Method
[image]

MapElement.Highlight override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.HitTest Method

Point.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overridable Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.SaveTo Method

Point.SaveTo Method
[image]

Saves the point to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the point data.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.ToString Method

Point.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The string representation of this point.

See Also

Point Members
Point Class


MindFusion.Mapping.Point Properties

Point Properties
[image]

Public Properties

Name | Description
Type | Shape.Type override.

Inherited Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette. (Inherited from Shape.)
DatabaseRow | Gets the DBF database row associated with this Shape. (Inherited from Shape.)
HitTestDistance | Gets or set the current hit test threshold distance. (Inherited from Shape.)
IsStreetShape | Gets or sets whether this object represents an OpenStreetMap shape. (Inherited from Shape.)
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
PenKey | Gets or sets a key used to associate a pen with this shape's map feature. (Inherited from Shape.)
Size | Gets the shape's area. (Inherited from Shape.)
Type | Gets the ESRI shape type of this Shape. (Inherited from Shape.)
ZIndex | Gets or sets the shape's Z order index. (Inherited from Shape.)

See Also

Point Class


MindFusion.Mapping.Point.Type Property

Point.Type Property
[image]

Shape.Type override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override ShapeType Type { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Type As ShapeType

Property Value

See Also

Point Members
Point Class


MindFusion.Mapping.Rect Class

Rect Class
[image]

A class representing a rectangular are on the map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Rect

Visual Basic [image] Copy Code

Public Class Rect

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Rect

See Also

Rect Members


MindFusion.Mapping.Rect Members

Rect Members
Constructors Properties Methods
[image]

A class representing a rectangular are on the map.

The following tables list the members exposed by the Rect type.

Public Constructors

Name | Description
Rect | Overloaded.

Public Properties

Name | Description
Height | Gets the rectangle height.
Width | Gets the rectangle width.
XMax | Gets or set the maximum X value.
XMin | Gets or set the minimum X value.
YMax | Gets or set the maximum Y value.
YMin | Gets or set the minimum Y value.

Public Methods

Name | Description
Clone | Returns a copy of this rectangle.
ContainsPoint | Overloaded.
Divide | Divides this rectangle into four equal parts.
GetCenter | Returns the rectangle center.
GetLocation | Returns the min X/Y corner of this rectangle.
Intersect | Returns the intersection of this rectangle with the specified rectangle.
Intersects | Tests whether this rectangle intersects with the specified rectangle.
Offset | Moves this rectangle by specified offset.
SaveTo | Saves the rectangle to the specified stream.
SetCenter | Moves this rectangle so that its center coincides with specified point.
Union | Returns the union of two rectangles.

See Also

Rect Class


MindFusion.Mapping.Rect Constructor

Rect Constructor
[image]

Overload List

Name | Description
Rect (BinaryReader) | Initializes a new instance of the Rect class.
Rect (Double, Double, Double, Double) | Initializes a new instance of the Rect class.
Rect (Point, Point) | Initializes a new instance of the Rect class.

See Also

Rect Class


MindFusion.Mapping.Rect Constructor (BinaryReader)

Rect Constructor (BinaryReader)
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public New ( _
reader As BinaryReader _
)

Parameters

reader

A BinaryReader used to read the rectangle coordinates.

See Also

Rect Constructor Overload List
Rect Class


MindFusion.Mapping.Rect Constructor (Double, Double, Double, Double)

Rect Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect (
double xMin,
double yMin,
double xMax,
double yMax
)

Visual Basic [image] Copy Code

Public New ( _
xMin As Double, _
yMin As Double, _
xMax As Double, _
yMax As Double _
)

Parameters

xMin

The minimum X value.

yMin

The minimum Y value.

xMax

The maximum X value.

yMax

The maximum Y value.

See Also

Rect Constructor Overload List
Rect Class


MindFusion.Mapping.Rect Constructor (Point, Point)

Rect Constructor (Point, Point)
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect (
Point point1,
Point point2
)

Visual Basic [image] Copy Code

Public New ( _
point1 As Point, _
point2 As Point _
)

Parameters

point1

A Point specifying one of the rectangle corners.

point2

A Point specifying the opposite rectangle corner.

See Also

Rect Constructor Overload List
Rect Class


MindFusion.Mapping.Rect Methods

Rect Methods
[image]

Public Methods

Name | Description
Clone | Returns a copy of this rectangle.
ContainsPoint | Overloaded.
Divide | Divides this rectangle into four equal parts.
GetCenter | Returns the rectangle center.
GetLocation | Returns the min X/Y corner of this rectangle.
Intersect | Returns the intersection of this rectangle with the specified rectangle.
Intersects | Tests whether this rectangle intersects with the specified rectangle.
Offset | Moves this rectangle by specified offset.
SaveTo | Saves the rectangle to the specified stream.
SetCenter | Moves this rectangle so that its center coincides with specified point.
Union | Returns the union of two rectangles.

See Also

Rect Class


MindFusion.Mapping.Rect.Clone Method

Rect.Clone Method
[image]

Returns a copy of this rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Rect

Return Value

A Rect instance with same coordinates as this rectangle.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.ContainsPoint Method

Rect.ContainsPoint Method
[image]

Overload List

Name | Description
Rect.ContainsPoint (Point) | Tests whether this rectangle contains the specified point.
Rect.ContainsPoint (Point, Double) | Tests whether this rectangle contains the specified point within a threshold.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.ContainsPoint Method (Point)

Rect.ContainsPoint Method (Point)
See Also
[image]

Tests whether this rectangle contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

A Point instance.

Return Value

true if this rectangle contains the point, otherwise false.

See Also

ContainsPoint Method Overload List
Rect Members
Rect Class


MindFusion.Mapping.Rect.ContainsPoint Method (Point, Double)

Rect.ContainsPoint Method (Point, Double)
See Also
[image]

Tests whether this rectangle contains the specified point within a threshold.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

A Point instance.

threshold

A threshold value.

Return Value

true if this rectangle contains the point, otherwise false.

See Also

ContainsPoint Method Overload List
Rect Members
Rect Class


MindFusion.Mapping.Rect.Divide Method

Rect.Divide Method
[image]

Divides this rectangle into four equal parts.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect[] Divide ()

Visual Basic [image] Copy Code

Public Function Divide () As Rect()

Return Value

An array of rectangles.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.GetCenter Method

Rect.GetCenter Method
[image]

Returns the rectangle center.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point GetCenter ()

Visual Basic [image] Copy Code

Public Function GetCenter () As Point

Return Value

A Point representing the center of this rectangle.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.GetLocation Method

Rect.GetLocation Method
[image]

Returns the min X/Y corner of this rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point GetLocation ()

Visual Basic [image] Copy Code

Public Function GetLocation () As Point

Return Value

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.Intersect Method

Rect.Intersect Method
[image]

Returns the intersection of this rectangle with the specified rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect Intersect (
Rect rect
)

Visual Basic [image] Copy Code

Public Function Intersect( _
rect As Rect _
) As Rect

Parameters

rect

A Rect instance.

Return Value

A Rect representing the intersection of the two rectangles.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.Intersects Method

Rect.Intersects Method
[image]

Tests whether this rectangle intersects with the specified rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool Intersects (
Rect rect
)

Visual Basic [image] Copy Code

Public Function Intersects( _
rect As Rect _
) As Boolean

Parameters

rect

A Rect instance.

Return Value

true if the rectangles intersect, otherwise false.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.Offset Method

Rect.Offset Method
[image]

Moves this rectangle by specified offset.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void Offset (
double x,
double y
)

Visual Basic [image] Copy Code

Public Sub Offset( _
x As Double, _
y As Double _
)

Parameters

x

Specifies horizontal offset.

y

Specifies vertical offset.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.SaveTo Method

Rect.SaveTo Method
[image]

Saves the rectangle to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the rectangle coordinates.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.SetCenter Method

Rect.SetCenter Method
[image]

Moves this rectangle so that its center coincides with specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SetCenter (
Point point
)

Visual Basic [image] Copy Code

Public Sub SetCenter( _
point As Point _
)

Parameters

point

The point where rectangle's center should be located.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.Union Method

Rect.Union Method
[image]

Returns the union of two rectangles.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Rect Union (
Rect rect1,
Rect rect2
)

Visual Basic [image] Copy Code

Public Shared Function Union( _
rect1 As Rect, _
rect2 As Rect _
) As Rect

Parameters

rect1

Specifies the first rectangle.

rect2

Specifies the second rectangle.

Return Value

A Rect instance representing the union of specified rectangles.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect Properties

Rect Properties
[image]

Public Properties

Name | Description
Height | Gets the rectangle height.
Width | Gets the rectangle width.
XMax | Gets or set the maximum X value.
XMin | Gets or set the minimum X value.
YMax | Gets or set the maximum Y value.
YMin | Gets or set the minimum Y value.

See Also

Rect Class


MindFusion.Mapping.Rect.Height Property

Rect.Height Property
[image]

Gets the rectangle height.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Height { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Height As Double

Property Value

A double value specifying the rectangle's height.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.Width Property

Rect.Width Property
[image]

Gets the rectangle width.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Width { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Width As Double

Property Value

A double value specifying the rectangle's width.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.XMax Property

Rect.XMax Property
[image]

Gets or set the maximum X value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double XMax { get; set; }

Visual Basic [image] Copy Code

Public Property XMax As Double

Property Value

A double value specifying the maximum X coordinate of the rectangle.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.XMin Property

Rect.XMin Property
[image]

Gets or set the minimum X value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double XMin { get; set; }

Visual Basic [image] Copy Code

Public Property XMin As Double

Property Value

A double value specifying the minimum X coordinate of the rectangle.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.YMax Property

Rect.YMax Property
[image]

Gets or set the maximum Y value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double YMax { get; set; }

Visual Basic [image] Copy Code

Public Property YMax As Double

Property Value

A double value specifying the maximum Y coordinate of the rectangle.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.YMin Property

Rect.YMin Property
[image]

Gets or set the minimum Y value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double YMin { get; set; }

Visual Basic [image] Copy Code

Public Property YMin As Double

Property Value

A double value specifying the minimum Y coordinate of the rectangle.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Row Class

Row Class
[image]

Represents a DBF database row.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Row : ICustomTypeDescriptor

Visual Basic [image] Copy Code

Public Class Row
Implements ICustomTypeDescriptor

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Row

See Also

Row Members


MindFusion.Mapping.Row Members

Row Members
Properties
[image]

Represents a DBF database row.

The following tables list the members exposed by the Row type.

Public Properties

Name | Description
Index | Gets or sets the row index.
Item | Overloaded.

See Also

Row Class


MindFusion.Mapping.Row Properties

Row Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the row index.
Item | Overloaded.

See Also

Row Class


MindFusion.Mapping.Row.Index Property

Row.Index Property
[image]

Gets or sets the row index.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value specifying the row's ordinal index within the database.

See Also

Row Members
Row Class


MindFusion.Mapping.Row.Item Property

Row.Item Property
[image]

Overload List

Name | Description
Row.Item (Column) | Returns the data stored in the specified field.
Row.Item (Int32) | Returns the data stored in the specified field.
Row.Item (String) | Returns the data stored in the specified field.

See Also

Row Members
Row Class


MindFusion.Mapping.Row.Item Property (Column)

Row.Item Property (Column)
See Also
[image]

Returns the data stored in the specified field.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Item [
Column column
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
column As Column _
) As String

Parameters

column

Specifies the database column.

Property Value

The string value of the specified field.

See Also

Item Property Overload List
Row Members
Row Class


MindFusion.Mapping.Row.Item Property (Int32)

Row.Item Property (Int32)
See Also
[image]

Returns the data stored in the specified field.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Item [
int columnIndex
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
columnIndex As Integer _
) As String

Parameters

columnIndex

Specifies the index of the database column.

Property Value

The string value of the specified field.

See Also

Item Property Overload List
Row Members
Row Class


MindFusion.Mapping.Row.Item Property (String)

Row.Item Property (String)
See Also
[image]

Returns the data stored in the specified field.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Item [
string columnName
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
columnName As String _
) As String

Parameters

columnName

Specifies the name of the database column.

Property Value

The string value of the specified field.

See Also

Item Property Overload List
Row Members
Row Class


MindFusion.Mapping.RuntimePolicy Class

RuntimePolicy Class
[image]

Contains environment settings to use in implementation for current platform.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class RuntimePolicy

Visual Basic [image] Copy Code

Public Class RuntimePolicy

Inheritance Hierarchy

System.Object
MindFusion.Mapping.RuntimePolicy

See Also

RuntimePolicy Members


MindFusion.Mapping.RuntimePolicy Members

RuntimePolicy Members
Constructors Fields
[image]

Contains environment settings to use in implementation for current platform.

The following tables list the members exposed by the RuntimePolicy type.

Public Constructors

Name | Description
RuntimePolicy |

Public Fields

Name | Description
CharEncoding | Specifies default encoding of text fields in database.
DefaultFontSize | The default font size.
DrawHighlights | Specifies whether highlights should be drawn by the base layer class.
RunningThreads | Identifies if there are worker threads still running.
UseCaching | Specifies whether to cache shape coordinates.

See Also

RuntimePolicy Class


MindFusion.Mapping.RuntimePolicy Fields

RuntimePolicy Fields
[image]

Public Fields

Name | Description
CharEncoding | Specifies default encoding of text fields in database.
DefaultFontSize | The default font size.
DrawHighlights | Specifies whether highlights should be drawn by the base layer class.
RunningThreads | Identifies if there are worker threads still running.
UseCaching | Specifies whether to cache shape coordinates.

See Also

RuntimePolicy Class


MindFusion.Mapping.RuntimePolicy.CharEncoding Field

RuntimePolicy.CharEncoding Field
[image]

Specifies default encoding of text fields in database.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Encoding CharEncoding

Visual Basic [image] Copy Code

Public Shared CharEncoding As Encoding

See Also

RuntimePolicy Members
RuntimePolicy Class


MindFusion.Mapping.RuntimePolicy.DefaultFontSize Field

RuntimePolicy.DefaultFontSize Field
[image]

The default font size.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double DefaultFontSize

Visual Basic [image] Copy Code

Public Shared DefaultFontSize As Double

See Also

RuntimePolicy Members
RuntimePolicy Class


MindFusion.Mapping.RuntimePolicy.DrawHighlights Field

RuntimePolicy.DrawHighlights Field
[image]

Specifies whether highlights should be drawn by the base layer class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static bool DrawHighlights

Visual Basic [image] Copy Code

Public Shared DrawHighlights As Boolean

See Also

RuntimePolicy Members
RuntimePolicy Class


MindFusion.Mapping.RuntimePolicy.UseCaching Field

RuntimePolicy.UseCaching Field
[image]

Specifies whether to cache shape coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static bool UseCaching

Visual Basic [image] Copy Code

Public Shared UseCaching As Boolean

See Also

RuntimePolicy Members
RuntimePolicy Class


MindFusion.Mapping.RuntimePolicy.RunningThreads Field

RuntimePolicy.RunningThreads Field
[image]

Identifies if there are worker threads still running.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static bool RunningThreads

Visual Basic [image] Copy Code

Public Shared RunningThreads As Boolean

See Also

RuntimePolicy Members
RuntimePolicy Class


MindFusion.Mapping.RuntimePolicy Constructor

RuntimePolicy Constructor
[image]

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public RuntimePolicy ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RuntimePolicy Class


MindFusion.Mapping.Shape Class

Shape Class
[image]

Represents geometrical shapes displayed on a map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class Shape : MapElement

Visual Basic [image] Copy Code

Public MustInherit Class Shape
Inherits MapElement

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Shape
MindFusion.Mapping.NullShape
MindFusion.Mapping.Point

See Also

Shape Members


MindFusion.Mapping.Shape Members

Shape Members
Constructors Fields Properties Methods
[image]

Represents geometrical shapes displayed on a map.

The following tables list the members exposed by the Shape type.

Protected Constructors

Name | Description
Shape | Initializes a new instance of the Shape class.

Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file.

Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette.
DatabaseRow | Gets the DBF database row associated with this Shape.
HitTestDistance | Gets or set the current hit test threshold distance.
IsStreetShape | Gets or sets whether this object represents an OpenStreetMap shape.
PenKey | Gets or sets a key used to associate a pen with this shape's map feature.
Size | Gets the shape's area.
Type | Gets the ESRI shape type of this Shape.
ZIndex | Gets or sets the shape's Z order index.

Inherited Public Properties

Name | Description
Label | Gets or sets the label of this map element. (Inherited from MapElement.)

Public Methods

Name | Description
GetBoundingBox | Gets the bounding box of this shape.
GetCenter | Gets the center point of this shape.
GetPoints | Returns the vertex points of this shape.
SaveTo | Saves this shape to the specified stream.

Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level.

Inherited Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

Shape Class


MindFusion.Mapping.Shape Fields

Shape Fields
[image]

Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file.

See Also

Shape Class


MindFusion.Mapping.Shape.Id Field

Shape.Id Field
[image]

The record number of this shape in the ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Id

Visual Basic [image] Copy Code

Public Id As Integer

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape Constructor

Shape Constructor
[image]

Initializes a new instance of the Shape class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected Shape (
int id
)

Visual Basic [image] Copy Code

Protected New ( _
id As Integer _
)

Parameters

id

The record number of this shape in the ESRI map file.

See Also

Shape Class


MindFusion.Mapping.Shape Methods

Shape Methods
[image]

Public Methods

Name | Description
GetBoundingBox | Gets the bounding box of this shape.
GetCenter | Gets the center point of this shape.
GetPoints | Returns the vertex points of this shape.
SaveTo | Saves this shape to the specified stream.

Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level.

Inherited Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

Shape Class


MindFusion.Mapping.Shape.ClearCache Method

Shape.ClearCache Method
[image]

Clears any cached values associated with the shape for the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void ClearCache ()

Visual Basic [image] Copy Code

Protected Overridable Sub ClearCache ()

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.GetBoundingBox Method

Shape.GetBoundingBox Method
[image]

Gets the bounding box of this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract Rect GetBoundingBox ()

Visual Basic [image] Copy Code

Public MustOverride Function GetBoundingBox () As Rect

Return Value

A Rect representing the shape's bounding box.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.GetCenter Method

Shape.GetCenter Method
[image]

Gets the center point of this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract Point GetCenter ()

Visual Basic [image] Copy Code

Public MustOverride Function GetCenter () As Point

Return Value

A Point representing the shape's center.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.GetPoints Method

Shape.GetPoints Method
[image]

Returns the vertex points of this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public virtual List<Point> GetPoints ()

Visual Basic [image] Copy Code

Public Overridable Function GetPoints () As List(Of Point)

Return Value

A List containing the shape's vertices.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.SaveTo Method

Shape.SaveTo Method
[image]

Saves this shape to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public MustOverride Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the shape's data to a stream.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape Properties

Shape Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette.
DatabaseRow | Gets the DBF database row associated with this Shape.
HitTestDistance | Gets or set the current hit test threshold distance.
IsStreetShape | Gets or sets whether this object represents an OpenStreetMap shape.
PenKey | Gets or sets a key used to associate a pen with this shape's map feature.
Size | Gets the shape's area.
Type | Gets the ESRI shape type of this Shape.
ZIndex | Gets or sets the shape's Z order index.

Inherited Public Properties

Name | Description
Label | Gets or sets the label of this map element. (Inherited from MapElement.)

See Also

Shape Class


MindFusion.Mapping.Shape.Color Property

Shape.Color Property
[image]

Gets or sets the index of the shape's color within the current color palette.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Integer

Property Value

An integer value specifying an index within the FillColors array of a MapLayer.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.DatabaseRow Property

Shape.DatabaseRow Property
[image]

Gets the DBF database row associated with this Shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Row DatabaseRow { get; set; }

Visual Basic [image] Copy Code

Public Property DatabaseRow As Row

Property Value

A Row instance.

Remarks

This property is set if the loadDatabase argument of the LoadFromFile method is set to true.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.HitTestDistance Property

Shape.HitTestDistance Property
[image]

Gets or set the current hit test threshold distance.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double HitTestDistance { get; set; }

Visual Basic [image] Copy Code

Public Shared Property HitTestDistance As Double

Property Value

A double value specifying threshold distance for hit-testing non-polygonal shapes.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.IsStreetShape Property

Shape.IsStreetShape Property
[image]

Gets or sets whether this object represents an OpenStreetMap shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool IsStreetShape { get; set; }

Visual Basic [image] Copy Code

Public Property IsStreetShape As Boolean

Property Value

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.PenKey Property

Shape.PenKey Property
[image]

Gets or sets a key used to associate a pen with this shape's map feature.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public MapFeature PenKey { get; set; }

Visual Basic [image] Copy Code

Public Property PenKey As MapFeature

Property Value

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.Size Property

Shape.Size Property
[image]

Gets the shape's area.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public virtual float Size { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Size As Single

Property Value

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.Type Property

Shape.Type Property
[image]

Gets the ESRI shape type of this Shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract ShapeType Type { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Type As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.ZIndex Property

Shape.ZIndex Property
[image]

Gets or sets the shape's Z order index.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int ZIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ZIndex As Integer

Property Value

See Also

Shape Members
Shape Class


MindFusion.Mapping.ShapeType Enumeration

ShapeType Enumeration
[image]

Specifies the type of shapes contained in an ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public enum ShapeType

Visual Basic [image] Copy Code

Public Enum ShapeType

Members

Member name | Description
MultiPatch | Indicates a MultiPatch shape, which consists of a number of surface patches.
MultiPoint | Indicates a MultiPoint shape, which contains a set of points.
MultiPointM | Indicates a MultiPointM shape, which is a MultiPoint with additional measure attributes.
MultiPointZ | Indicates a MultiPointZ shape, which is a MultiPoint with additional Z and measure attributes.
NullShape | Indicates a null shape with no geometric data; often used as a place holder until data becomes available.
Point | Indicates a Point shape, which contains X (longitude) and Y (latitude) coordinates.
PointM | Indicates a PointM shape, which is a Point with an additional measure attribute.
PointZ | Indicates a PointZ shape, which is a Point with additional Z and measure attributes.
Polygon | Indicates a Polygon shape, which contains several ordered sets of points rendered as filled polygons.
PolygonM | Indicates a PolygonM shape, which is a Polygon with additional measure attributes.
PolygonZ | Indicates a PolygonZ shape, which is a Polygon with additional Z and measure attributes.
PolyLine | Indicates a Polyline shape, which contains several ordered sets of points rendered as connected line segments.
PolyLineM | Indicates a PolyLineM shape, which is a PolyLine with additional measure attributes.
PolyLineZ | Indicates a PolyLineZ shape, which is a PolyLine with additional Z and measure attributes.

See Also


MindFusion.Mapping.StreetMapFeatures Class

StreetMapFeatures Class
[image]

A helper class used for OSM files import and rendering.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public sealed class StreetMapFeatures

Visual Basic [image] Copy Code

Public NotInheritable Class StreetMapFeatures

Inheritance Hierarchy

System.Object
MindFusion.Mapping.StreetMapFeatures

See Also

StreetMapFeatures Members


MindFusion.Mapping.StreetMapFeatures Members

StreetMapFeatures Members
Fields Properties Methods
[image]

A helper class used for OSM files import and rendering.

The following tables list the members exposed by the StreetMapFeatures type.

Public Fields

Name | Description
Features | The list of physical map features, included in OSM format.

Public Properties

Name | Description
StreetMapBrushes | A list of brush keys used for drawing map shapes.
StreetMapPens | A list of pen keys used for drawing map shapes.

Public Methods

Name | Description
KeyIsNull | Checks whether the provided key has a value.

See Also

StreetMapFeatures Class


MindFusion.Mapping.StreetMapFeatures Fields

StreetMapFeatures Fields
[image]

Public Fields

Name | Description
Features | The list of physical map features, included in OSM format.

See Also

StreetMapFeatures Class


MindFusion.Mapping.StreetMapFeatures.Features Field

StreetMapFeatures.Features Field
[image]

The list of physical map features, included in OSM format.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static string[] Features

Visual Basic [image] Copy Code

Public Shared Features() As String

See Also

StreetMapFeatures Members
StreetMapFeatures Class


MindFusion.Mapping.StreetMapFeatures Methods

StreetMapFeatures Methods
[image]

Public Methods

Name | Description
KeyIsNull | Checks whether the provided key has a value.

See Also

StreetMapFeatures Class


MindFusion.Mapping.StreetMapFeatures.KeyIsNull Method

StreetMapFeatures.KeyIsNull Method
[image]

Checks whether the provided key has a value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static bool KeyIsNull (
MapFeature key
)

Visual Basic [image] Copy Code

Public Shared Function KeyIsNull( _
key As MapFeature _
) As Boolean

Parameters

key

Return Value

See Also

StreetMapFeatures Members
StreetMapFeatures Class


MindFusion.Mapping.StreetMapFeatures Properties

StreetMapFeatures Properties
[image]

Public Properties

Name | Description
StreetMapBrushes | A list of brush keys used for drawing map shapes.
StreetMapPens | A list of pen keys used for drawing map shapes.

See Also

StreetMapFeatures Class


MindFusion.Mapping.StreetMapFeatures.StreetMapBrushes Property

StreetMapFeatures.StreetMapBrushes Property
[image]

A list of brush keys used for drawing map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Dictionary<MapFeature, Object> StreetMapBrushes { get; set; }

Visual Basic [image] Copy Code

Public Shared Property StreetMapBrushes As Dictionary(Of MapFeature, Object)

Property Value

See Also

StreetMapFeatures Members
StreetMapFeatures Class


MindFusion.Mapping.StreetMapFeatures.StreetMapPens Property

StreetMapFeatures.StreetMapPens Property
[image]

A list of pen keys used for drawing map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Dictionary<MapFeature, Object> StreetMapPens { get; set; }

Visual Basic [image] Copy Code

Public Shared Property StreetMapPens As Dictionary(Of MapFeature, Object)

Property Value

See Also

StreetMapFeatures Members
StreetMapFeatures Class


MindFusion.Mapping.StreetShape Class

StreetShape Class
[image]

Represents a shape in OSM file format.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class StreetShape

Visual Basic [image] Copy Code

Public Class StreetShape

Inheritance Hierarchy

System.Object
MindFusion.Mapping.StreetShape

See Also

StreetShape Members


MindFusion.Mapping.StreetShape Members

StreetShape Members
Constructors Properties
[image]

Represents a shape in OSM file format.

The following tables list the members exposed by the StreetShape type.

Public Constructors

Name | Description
StreetShape | Initializes a new instance of the StreetShape class.

Public Properties

Name | Description
BrushKey | Gets the brush key, associated with this shape.
Id | Gets the Id of this shape.
Label | Gets the text, associated with this shape.
LabelRotate | Indicates whether the shape's text should be rotated.
PenKey | Gets the pen key, associated with this shape.
Points | Gets the collection of points, representing this shape.
Type | Gets the type of the shape.

See Also

StreetShape Class


MindFusion.Mapping.StreetShape Constructor

StreetShape Constructor
[image]

Initializes a new instance of the StreetShape class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public StreetShape (
XmlReader reader,
Dictionary<Int64, Point> nodes
)

Visual Basic [image] Copy Code

Public New ( _
reader As XmlReader, _
nodes As Dictionary(Of Int64, Point) _
)

Parameters

reader

nodes

See Also

StreetShape Class


MindFusion.Mapping.StreetShape Properties

StreetShape Properties
[image]

Public Properties

Name | Description
BrushKey | Gets the brush key, associated with this shape.
Id | Gets the Id of this shape.
Label | Gets the text, associated with this shape.
LabelRotate | Indicates whether the shape's text should be rotated.
PenKey | Gets the pen key, associated with this shape.
Points | Gets the collection of points, representing this shape.
Type | Gets the type of the shape.

See Also

StreetShape Class


MindFusion.Mapping.StreetShape.BrushKey Property

StreetShape.BrushKey Property
[image]

Gets the brush key, associated with this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public MapFeature BrushKey { get; set; }

Visual Basic [image] Copy Code

Public Property BrushKey As MapFeature

Property Value

See Also

StreetShape Members
StreetShape Class


MindFusion.Mapping.StreetShape.Id Property

StreetShape.Id Property
[image]

Gets the Id of this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public long Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As Long

Property Value

See Also

StreetShape Members
StreetShape Class


MindFusion.Mapping.StreetShape.Label Property

StreetShape.Label Property
[image]

Gets the text, associated with this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

See Also

StreetShape Members
StreetShape Class


MindFusion.Mapping.StreetShape.LabelRotate Property

StreetShape.LabelRotate Property
[image]

Indicates whether the shape's text should be rotated.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool LabelRotate { get; set; }

Visual Basic [image] Copy Code

Public Property LabelRotate As Boolean

Property Value

See Also

StreetShape Members
StreetShape Class


MindFusion.Mapping.StreetShape.PenKey Property

StreetShape.PenKey Property
[image]

Gets the pen key, associated with this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public MapFeature PenKey { get; set; }

Visual Basic [image] Copy Code

Public Property PenKey As MapFeature

Property Value

See Also

StreetShape Members
StreetShape Class


MindFusion.Mapping.StreetShape.Points Property

StreetShape.Points Property
[image]

Gets the collection of points, representing this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point[] Points { get; set; }

Visual Basic [image] Copy Code

Public Property Points As Point()

Property Value

See Also

StreetShape Members
StreetShape Class


MindFusion.Mapping.StreetShape.Type Property

StreetShape.Type Property
[image]

Gets the type of the shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public StreetShapeType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As StreetShapeType

Property Value

See Also

StreetShape Members
StreetShape Class


MindFusion.Mapping.StreetShapeType Enumeration

StreetShapeType Enumeration
[image]

Specifies the type of shapes contained in an OSM map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public enum StreetShapeType

Visual Basic [image] Copy Code

Public Enum StreetShapeType

Members

Member name | Description
ClosedWay | Indicates a closed way.
Node | Indicates a node.
Way | Indicates a way.

See Also


MindFusion.Mapping.TextAlignment Enumeration

TextAlignment Enumeration
[image]

Specifies text alignment.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public enum TextAlignment

Visual Basic [image] Copy Code

Public Enum TextAlignment

Members

Member name | Description
Center | Indicates center alignment.
Far | Indicates right or bottom alignment.
Near | Indicates top or left alignment.

See Also


MindFusion.Mapping.Vector Class

Vector Class
[image]

Represents a two-dimensional vector.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Vector

Visual Basic [image] Copy Code

Public Class Vector

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Vector

See Also

Vector Members


MindFusion.Mapping.Vector Members

Vector Members
Constructors Properties Methods
[image]

Represents a two-dimensional vector.

The following tables list the members exposed by the Vector type.

Public Constructors

Name | Description
Vector | Overloaded.

Public Properties

Name | Description
Length | Returns the vector length.
LengthSquared | Returns the squared length.
X | X coordinate of the vector.
Y | Y coordinate of the vector.

Public Methods

Name | Description
Add | Overloaded.
AngleBetween | Returns the angle between two vectors.
Divide | Divides a vector by a scalar value.
Equals | Overloaded.
GetHashCode | Object.GetHashCode override.
Left | Returns the left vector.
Multiply | Overloaded.
Negate | Reverses this vector's direction.
Right | Returns the right vector.
Subtract | Subtracts two vectors.
ToString | Overloaded.

See Also

Vector Class


MindFusion.Mapping.Vector Constructor

Vector Constructor
[image]

Overload List

Name | Description
Vector (Double, Double) | Initializes a new instance of the Vector structure with specified coordinates.
Vector (Point, Point) | Initializes a new instance of the Vector structure from the specified points.

See Also

Vector Class


MindFusion.Mapping.Vector Constructor (Double, Double)

Vector Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the Vector structure with specified coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Vector (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

X coordinate of the vector.

y

Y coordinate of the vector.

See Also

Vector Constructor Overload List
Vector Class


MindFusion.Mapping.Vector Constructor (Point, Point)

Vector Constructor (Point, Point)
See Also
[image]

Initializes a new instance of the Vector structure from the specified points.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Vector (
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public New ( _
p1 As Point, _
p2 As Point _
)

Parameters

p1

Origin point of the vector.

p2

End point of the vector.

See Also

Vector Constructor Overload List
Vector Class


MindFusion.Mapping.Vector Methods

Vector Methods
[image]

Public Methods

Name | Description
Add | Overloaded.
AngleBetween | Returns the angle between two vectors.
Divide | Divides a vector by a scalar value.
Equals | Overloaded.
GetHashCode | Object.GetHashCode override.
Left | Returns the left vector.
Multiply | Overloaded.
Negate | Reverses this vector's direction.
Right | Returns the right vector.
Subtract | Subtracts two vectors.
ToString | Overloaded.

See Also

Vector Class


MindFusion.Mapping.Vector.Add Method

Vector.Add Method
[image]

Overload List

Name | Description
Vector.Add (Vector, Point) | Adds vector to a point.
Vector.Add (Vector, Vector) | Adds two vectors.

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.Add Method (Vector, Point)

Vector.Add Method (Vector, Point)
See Also
[image]

Adds vector to a point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Point Add (
Vector vector,
Point point
)

Visual Basic [image] Copy Code

Public Shared Function Add( _
vector As Vector, _
point As Point _
) As Point

Parameters

vector

A Vector instance.

point

A Point instance.

Return Value

A point offset from the specified point by adding specified vector.

See Also

Add Method Overload List
Vector Members
Vector Class


MindFusion.Mapping.Vector.Add Method (Vector, Vector)

Vector.Add Method (Vector, Vector)
See Also
[image]

Adds two vectors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Vector Add (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Add( _
vector1 As Vector, _
vector2 As Vector _
) As Vector

Parameters

vector1

vector2

Return Value

See Also

Add Method Overload List
Vector Members
Vector Class


MindFusion.Mapping.Vector.AngleBetween Method

Vector.AngleBetween Method
[image]

Returns the angle between two vectors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double AngleBetween (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function AngleBetween( _
vector1 As Vector, _
vector2 As Vector _
) As Double

Parameters

vector1

A Vector instance.

vector2

A Vector instance.

Return Value

The angle between specified vectors.

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.Divide Method

Vector.Divide Method
[image]

Divides a vector by a scalar value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Vector Divide (
Vector vector,
double scalar
)

Visual Basic [image] Copy Code

Public Shared Function Divide( _
vector As Vector, _
scalar As Double _
) As Vector

Parameters

vector

A Vector instance.

scalar

A double value.

Return Value

A Vector with same direction and divided length.

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.Equals Method

Vector.Equals Method
[image]

Overload List

Name | Description
Vector.Equals (Object) | Object.Equals override.
Vector.Equals (Vector) | Compare this vector with the specified vector for equality.
Vector.Equals (Vector, Vector) | Compares two vectors for equality.

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.Equals Method (Object)

Vector.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Equals (
Object o
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
o As Object _
) As Boolean

Parameters

o

The object to compare this vector with.

Return Value

true if the objects are equal, or otherwise false.

See Also

Equals Method Overload List
Vector Members
Vector Class


MindFusion.Mapping.Vector.Equals Method (Vector)

Vector.Equals Method (Vector)
See Also
[image]

Compare this vector with the specified vector for equality.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public new bool Equals (
Vector value
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
value As Vector _
) As Boolean

Parameters

value

The vector to compare with.

Return Value

true if the vectors are equal, or otherwise false.

See Also

Equals Method Overload List
Vector Members
Vector Class


MindFusion.Mapping.Vector.Equals Method (Vector, Vector)

Vector.Equals Method (Vector, Vector)
See Also
[image]

Compares two vectors for equality.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public new static bool Equals (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shadows Shared Function Equals( _
vector1 As Vector, _
vector2 As Vector _
) As Boolean

Parameters

vector1

The first vector to compare.

vector2

The second vector to compare.

Return Value

true if the vectors are equal, or otherwise false.

See Also

Equals Method Overload List
Vector Members
Vector Class


MindFusion.Mapping.Vector.GetHashCode Method

Vector.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The vector's hash code.

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.Left Method

Vector.Left Method
[image]

Returns the left vector.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Vector Left (
Vector v
)

Visual Basic [image] Copy Code

Public Shared Function Left( _
v As Vector _
) As Vector

Parameters

v

Return Value

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.Multiply Method

Vector.Multiply Method
[image]

Overload List

Name | Description
Vector.Multiply (Double, Vector) | Multiplies a vector by a scalar value.
Vector.Multiply (Vector, Double) | Multiplies a vector by a scalar value.
Vector.Multiply (Vector, Vector) | Multiplies two vectors.

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.Multiply Method (Double, Vector)

Vector.Multiply Method (Double, Vector)
See Also
[image]

Multiplies a vector by a scalar value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Vector Multiply (
double scalar,
Vector vector
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
scalar As Double, _
vector As Vector _
) As Vector

Parameters

scalar

A double value.

vector

A Vector instance.

Return Value

A Vector with same direction and multiplied length.

See Also

Multiply Method Overload List
Vector Members
Vector Class


MindFusion.Mapping.Vector.Multiply Method (Vector, Double)

Vector.Multiply Method (Vector, Double)
See Also
[image]

Multiplies a vector by a scalar value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Vector Multiply (
Vector vector,
double scalar
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
vector As Vector, _
scalar As Double _
) As Vector

Parameters

vector

A Vector instance.

scalar

A double value.

Return Value

A Vector with same direction and multiplied length.

See Also

Multiply Method Overload List
Vector Members
Vector Class


MindFusion.Mapping.Vector.Multiply Method (Vector, Vector)

Vector.Multiply Method (Vector, Vector)
See Also
[image]

Multiplies two vectors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Multiply (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
vector1 As Vector, _
vector2 As Vector _
) As Double

Parameters

vector1

A Vector instance.

vector2

A Vector instance.

Return Value

The dot product of specified vectors.

See Also

Multiply Method Overload List
Vector Members
Vector Class


MindFusion.Mapping.Vector.Negate Method

Vector.Negate Method
[image]

Reverses this vector's direction.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void Negate ()

Visual Basic [image] Copy Code

Public Sub Negate ()

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.Right Method

Vector.Right Method
[image]

Returns the right vector.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Vector Right (
Vector v
)

Visual Basic [image] Copy Code

Public Shared Function Right( _
v As Vector _
) As Vector

Parameters

v

Return Value

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.Subtract Method

Vector.Subtract Method
[image]

Subtracts two vectors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Vector Subtract (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Subtract( _
vector1 As Vector, _
vector2 As Vector _
) As Vector

Parameters

vector1

A Vector instance.

vector2

A Vector instance.

Return Value

The difference between specified vectors.

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.ToString Method

Vector.ToString Method
[image]

Overload List

Name | Description
Vector.ToString () | Object.ToString override.
Vector.ToString (IFormatProvider) | Returns the vector's string representation in specified culture.

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.ToString Method ()

Vector.ToString Method ()
See Also
[image]

Object.ToString override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The vector's string representation.

See Also

ToString Method Overload List
Vector Members
Vector Class


MindFusion.Mapping.Vector.ToString Method (IFormatProvider)

Vector.ToString Method (IFormatProvider)
See Also
[image]

Returns the vector's string representation in specified culture.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string ToString (
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Function ToString( _
provider As IFormatProvider _
) As String

Parameters

provider

An IFormatProvider (e.g. CultureInfo) specifying number format.

Return Value

The vector's string representation.

See Also

ToString Method Overload List
Vector Members
Vector Class


MindFusion.Mapping.Vector Properties

Vector Properties
[image]

Public Properties

Name | Description
Length | Returns the vector length.
LengthSquared | Returns the squared length.
X | X coordinate of the vector.
Y | Y coordinate of the vector.

See Also

Vector Class


MindFusion.Mapping.Vector.Length Property

Vector.Length Property
[image]

Returns the vector length.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Double

Property Value

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.LengthSquared Property

Vector.LengthSquared Property
[image]

Returns the squared length.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double LengthSquared { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LengthSquared As Double

Property Value

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.X Property

Vector.X Property
[image]

X coordinate of the vector.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

See Also

Vector Members
Vector Class


MindFusion.Mapping.Vector.Y Property

Vector.Y Property
[image]

Y coordinate of the vector.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

See Also

Vector Members
Vector Class


MindFusion.Mapping.WinForms Namespace

MindFusion.Mapping.WinForms Namespace
Classes Enumerations

Classes

Class | Description
DecorationBubble | Represents a bubble object that can be drawn as a decoration over the map.
DecorationImage | Represents an image that can be drawn as a decoration over the map.
DecorationLayer | Represents a layer containing decorative elements.
GdiCanvas | Implements the ICanvas interface using System.Drawing API.
GdiPalette | Represents a palette of colors.
GdiTransform | Represents a geometrical transform used to convert world coordinates to screen coordinates.
MapEventArgs | Provides data for map events.
MapLayer | Represents a map layer containing geometric shapes.
MapView | A Windows Forms control used to draw maps.
StreetMapLayer | Represents a map layer containing OpenStreetMap maps.

Enumerations

Enumeration | Description
Behavior | Defines values that specify how the component responds to actions performed by the user.


MindFusion.Mapping.WinForms.Behavior Enumeration

Behavior Enumeration
[image]

Defines values that specify how the component responds to actions performed by the user.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public enum Behavior

Visual Basic [image] Copy Code

Public Enum Behavior

Members

Member name | Description
Pan | Dragging with the mouse pans the view.
Select | Draw a selection rectangle.

See Also

MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble Class

DecorationBubble Class
[image]

Represents a bubble object that can be drawn as a decoration over the map.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public class DecorationBubble : Decoration

Visual Basic [image] Copy Code

Public Class DecorationBubble
Inherits Decoration

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.WinForms.DecorationBubble

See Also

DecorationBubble Members
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble Members

DecorationBubble Members
Constructors Properties Methods
[image]

Represents a bubble object that can be drawn as a decoration over the map.

The following tables list the members exposed by the DecorationBubble type.

Public Constructors

Name | Description
DecorationBubble | Initializes a new instance of the DecorationBubble class.

Public Properties

Name | Description
BorderColor | Gets or sets the bubble's border color.
FillColor | Gets or sets the bubble's fill color.
Radius | Gets or sets the bubble radius in pixels.

Inherited Public Properties

Name | Description
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Latitude | Gets or sets the latitude associated with this decoration. (Inherited from Decoration.)
Longitude | Gets or sets the longitude associated with this decoration. (Inherited from Decoration.)

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

Inherited Public Methods

Name | Description
GetLocation | Gets the decoration's location. (Inherited from Decoration.)

Inherited Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble Constructor

DecorationBubble Constructor
[image]

Initializes a new instance of the DecorationBubble class.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public DecorationBubble (
int radius,
Color fillColor,
Color borderColor,
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
radius As Integer, _
fillColor As Color, _
borderColor As Color, _
latitude As Double, _
longitude As Double _
)

Parameters

radius

An integer specifying the bubble radius.

fillColor

A Color instance specifying the bubble fill color.

borderColor

A Color instance specifying the bubble border color.

latitude

A double value specifying the latitude at which the bubble should be drawn.

longitude

A double value specifying the longitude at which the bubble should be drawn.

See Also

DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble Methods

DecorationBubble Methods
[image]

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

Inherited Public Methods

Name | Description
GetLocation | Gets the decoration's location. (Inherited from Decoration.)

Inherited Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble.Draw Method

DecorationBubble.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble.DrawLabel Method

DecorationBubble.DrawLabel Method
[image]

MapElement.DrawLabel override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble.Highlight Method

DecorationBubble.Highlight Method
[image]

MapElement.Highlight override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble.HitTest Method

DecorationBubble.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overridable Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble Properties

DecorationBubble Properties
[image]

Public Properties

Name | Description
BorderColor | Gets or sets the bubble's border color.
FillColor | Gets or sets the bubble's fill color.
Radius | Gets or sets the bubble radius in pixels.

Inherited Public Properties

Name | Description
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Latitude | Gets or sets the latitude associated with this decoration. (Inherited from Decoration.)
Longitude | Gets or sets the longitude associated with this decoration. (Inherited from Decoration.)

See Also

DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble.BorderColor Property

DecorationBubble.BorderColor Property
[image]

Gets or sets the bubble's border color.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Color BorderColor { get; set; }

Visual Basic [image] Copy Code

Public Property BorderColor As Color

Property Value

A System.Drawing.Color instance.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble.FillColor Property

DecorationBubble.FillColor Property
[image]

Gets or sets the bubble's fill color.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Color FillColor { get; set; }

Visual Basic [image] Copy Code

Public Property FillColor As Color

Property Value

A System.Drawing.Color instance.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationBubble.Radius Property

DecorationBubble.Radius Property
[image]

Gets or sets the bubble radius in pixels.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public int Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Integer

Property Value

An integer value specifying the bubble radius in pixels.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage Class

DecorationImage Class
[image]

Represents an image that can be drawn as a decoration over the map.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public class DecorationImage : Decoration

Visual Basic [image] Copy Code

Public Class DecorationImage
Inherits Decoration

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.WinForms.DecorationImage

See Also

DecorationImage Members
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage Members

DecorationImage Members
Constructors Properties Methods
[image]

Represents an image that can be drawn as a decoration over the map.

The following tables list the members exposed by the DecorationImage type.

Public Constructors

Name | Description
DecorationImage | Overloaded.

Public Properties

Name | Description
HighlightImage | Gets or sets a System.Drawing.Image that should be displayed when the decoration is highlighted.
Image | Gets or sets the System.Drawing.Image that should be displayed as a decoration.
PivotX | Gets or sets horizontal offset within the image that should be aligned to the decoration longitude.
PivotY | Gets or sets vertical offset within the image that should be aligned to the decoration latitude.

Inherited Public Properties

Name | Description
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Latitude | Gets or sets the latitude associated with this decoration. (Inherited from Decoration.)
Longitude | Gets or sets the longitude associated with this decoration. (Inherited from Decoration.)

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

Inherited Public Methods

Name | Description
GetLocation | Gets the decoration's location. (Inherited from Decoration.)

Inherited Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage Constructor

DecorationImage Constructor
[image]

Overload List

Name | Description
DecorationImage (Image, Double, Double) | Initializes a new instance of the DecorationImage class.
DecorationImage (Image, Int32, Int32, Double, Double) | Initializes a new instance of the DecorationImage class.

See Also

DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage Constructor (Image, Double, Double)

DecorationImage Constructor (Image, Double, Double)
See Also
[image]

Initializes a new instance of the DecorationImage class.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public DecorationImage (
Image image,
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
image As Image, _
latitude As Double, _
longitude As Double _
)

Parameters

image

A System.Drawing.Image instance.

latitude

A double value specifying the latitude at which the image should be drawn.

longitude

A double value specifying the longitude at which the image should be drawn.

See Also

DecorationImage Constructor Overload List
DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage Constructor (Image, Int32, Int32, Double, Double)

DecorationImage Constructor (Image, Int32, Int32, Double, Double)
See Also
[image]

Initializes a new instance of the DecorationImage class.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public DecorationImage (
Image image,
int pivotX,
int pivotY,
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
image As Image, _
pivotX As Integer, _
pivotY As Integer, _
latitude As Double, _
longitude As Double _
)

Parameters

image

A System.Drawing.Image instance.

pivotX

Position within the image that should be aligned to the specified longitude.

pivotY

Position within the image that should be aligned to the specified latitude.

latitude

A double value specifying the latitude at which the image should be drawn.

longitude

A double value specifying the longitude at which the image should be drawn.

See Also

DecorationImage Constructor Overload List
DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage Methods

DecorationImage Methods
[image]

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

Inherited Public Methods

Name | Description
GetLocation | Gets the decoration's location. (Inherited from Decoration.)

Inherited Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface. (Inherited from MapElement.)
DrawLabel | Draws the label of this map element. (Inherited from MapElement.)
Highlight | Draws a highlight of this map element. (Inherited from MapElement.)
HitTest | Tests whether this map element contains the specified point. (Inherited from MapElement.)

See Also

DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage.Draw Method

DecorationImage.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage.DrawLabel Method

DecorationImage.DrawLabel Method
[image]

MapElement.DrawLabel override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage.Highlight Method

DecorationImage.Highlight Method
[image]

MapElement.Highlight override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage.HitTest Method

DecorationImage.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overridable Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage Properties

DecorationImage Properties
[image]

Public Properties

Name | Description
HighlightImage | Gets or sets a System.Drawing.Image that should be displayed when the decoration is highlighted.
Image | Gets or sets the System.Drawing.Image that should be displayed as a decoration.
PivotX | Gets or sets horizontal offset within the image that should be aligned to the decoration longitude.
PivotY | Gets or sets vertical offset within the image that should be aligned to the decoration latitude.

Inherited Public Properties

Name | Description
Label | Gets or sets the label of this map element. (Inherited from MapElement.)
Latitude | Gets or sets the latitude associated with this decoration. (Inherited from Decoration.)
Longitude | Gets or sets the longitude associated with this decoration. (Inherited from Decoration.)

See Also

DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage.HighlightImage Property

DecorationImage.HighlightImage Property
[image]

Gets or sets a System.Drawing.Image that should be displayed when the decoration is highlighted.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Image HighlightImage { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightImage As Image

Property Value

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage.Image Property

DecorationImage.Image Property
[image]

Gets or sets the System.Drawing.Image that should be displayed as a decoration.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Image Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As Image

Property Value

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage.PivotX Property

DecorationImage.PivotX Property
[image]

Gets or sets horizontal offset within the image that should be aligned to the decoration longitude.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public int PivotX { get; set; }

Visual Basic [image] Copy Code

Public Property PivotX As Integer

Property Value

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationImage.PivotY Property

DecorationImage.PivotY Property
[image]

Gets or sets vertical offset within the image that should be aligned to the decoration latitude.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public int PivotY { get; set; }

Visual Basic [image] Copy Code

Public Property PivotY As Integer

Property Value

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationLayer Class

DecorationLayer Class
[image]

Represents a layer containing decorative elements.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public class DecorationLayer : DecorationLayerBase<Color, GdiPalette>

Visual Basic [image] Copy Code

Public Class DecorationLayer
Inherits DecorationLayerBase(Of Color, GdiPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(Color, GdiPalette)
MindFusion.Mapping.DecorationLayerBase(Color, GdiPalette)
MindFusion.Mapping.WinForms.DecorationLayer

See Also

DecorationLayer Members
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationLayer Members

DecorationLayer Members
Constructors Properties Methods Events
[image]

Represents a layer containing decorative elements.

The following tables list the members exposed by the DecorationLayer type.

Public Constructors

Name | Description
DecorationLayer | Initializes a new instance of the DecorationLayer class.

Inherited Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override. (Inherited from DecorationLayerBase.)
Decorations | Gets the list of decorations displayed in this layer. (Inherited from DecorationLayerBase.)
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Selection | Gets the list of selected decorations. (Inherited from DecorationLayerBase.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

Inherited Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level. (Inherited from Layer.)
Draw | Layer.Draw override. (Inherited from DecorationLayerBase.)
DrawHighlights | Layer.DrawHighlights override. (Inherited from DecorationLayerBase.)
DrawLabels | Layer.DrawLabels override. (Inherited from DecorationLayerBase.)
Highlight | Layer.Highlight override. (Inherited from DecorationLayerBase.)
HitTest | Layer.HitTest override. (Inherited from DecorationLayerBase.)
Select | Overloaded. (Inherited from DecorationLayerBase.)
Toggle | Layer.Toggle override. (Inherited from DecorationLayerBase.)

Inherited Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from Layer.)
OnEndLoad | Raises the EndLoad event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

Inherited Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
BeginLoad | Raised when the component starts loading map data from a file or memory stream. (Inherited from Layer.)
EndLoad | Raised when the component ends loading map data from a file or memory stream. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

DecorationLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.DecorationLayer Constructor

DecorationLayer Constructor
[image]

Initializes a new instance of the DecorationLayer class.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public DecorationLayer (
Rect boundingBox
)

Visual Basic [image] Copy Code

Public New ( _
boundingBox As Rect _
)

Parameters

boundingBox

A Rect specifying the map area displayed on this layer.

See Also

DecorationLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas Class

GdiCanvas Class
[image]

Implements the ICanvas interface using System.Drawing API.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public class GdiCanvas : ICanvasWithPalette<Color>, ICanvas

Visual Basic [image] Copy Code

Public Class GdiCanvas
Implements ICanvasWithPalette(Of Color), ICanvas

Inheritance Hierarchy

System.Object
MindFusion.Mapping.WinForms.GdiCanvas

See Also

GdiCanvas Members
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas Members

GdiCanvas Members
Constructors Properties Methods
[image]

Implements the ICanvas interface using System.Drawing API.

The following tables list the members exposed by the GdiCanvas type.

Public Constructors

Name | Description
GdiCanvas | Initializes a new instance of the GdiCanvas class.

Public Properties

Name | Description
Graphics | Gets or sets the System.Drawing.Graphics instance backing this canvas.
Palette | Gets or sets the current color palette.
Transform | Gets or sets a matrix that transforms geo-coordinates to pixels.
ZoomFactor | Gets or sets the current zoom factor.

Public Methods

Name | Description
ArrangeLabel | Arranges shape's labels so that they do not overlap specified obstacles.
ClipExclude | Overloaded.
DrawLabel | Draws a Label.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
GetRotatedBounds | Gets the bounding box of a rotated rectangle.
ResetClip | Resets the current clip region.
SetBrush | Sets the current brush to the one associated with specified map feature.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetPen | Sets the current pen to the one associated with specified map feature.
SetTextAlignment | Sets the current text alignment.
UpdateLabel | Updates bounding box of shape's label from shape coordinates.

See Also

GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas Constructor

GdiCanvas Constructor
[image]

Initializes a new instance of the GdiCanvas class.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public GdiCanvas (
Graphics graphics,
Point zoomOffset
)

Visual Basic [image] Copy Code

Public New ( _
graphics As Graphics, _
zoomOffset As Point _
)

Parameters

graphics

zoomOffset

See Also

GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas Methods

GdiCanvas Methods
[image]

Public Methods

Name | Description
ArrangeLabel | Arranges shape's labels so that they do not overlap specified obstacles.
ClipExclude | Overloaded.
DrawLabel | Draws a Label.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
GetRotatedBounds | Gets the bounding box of a rotated rectangle.
ResetClip | Resets the current clip region.
SetBrush | Sets the current brush to the one associated with specified map feature.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetPen | Sets the current pen to the one associated with specified map feature.
SetTextAlignment | Sets the current text alignment.
UpdateLabel | Updates bounding box of shape's label from shape coordinates.

See Also

GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.ArrangeLabel Method

GdiCanvas.ArrangeLabel Method
[image]

Arranges shape's labels so that they do not overlap specified obstacles.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public bool ArrangeLabel (
Shape shape,
List<Rect> obstacles
)

Visual Basic [image] Copy Code

Public Function ArrangeLabel( _
shape As Shape, _
obstacles As List(Of Rect) _
) As Boolean

Parameters

shape

A Shape whose labels to arrange.

obstacles

A list of obstacles.

Return Value

true if non-overlapping position has been found, or false otherwise.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.ClipExclude Method

GdiCanvas.ClipExclude Method
[image]

Overload List

Name | Description
GdiCanvas.ClipExclude (IList(Point)) | Excludes the specified area from the current clip region.
GdiCanvas.ClipExclude (List(IList(Point))) | Excludes the specified areas from the current clip region.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.ClipExclude Method (IList(Point))

GdiCanvas.ClipExclude Method (IList(Point))
See Also
[image]

Excludes the specified area from the current clip region.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void ClipExclude (
IList<Point> points
)

Visual Basic [image] Copy Code

Public Sub ClipExclude( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.ClipExclude Method (List(IList(Point)))

GdiCanvas.ClipExclude Method (List(IList(Point)))
See Also
[image]

Excludes the specified areas from the current clip region.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void ClipExclude (
List<IList<Point>> points
)

Visual Basic [image] Copy Code

Public Sub ClipExclude( _
points As List(Of IList(Of Point)) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.DrawLabel Method

GdiCanvas.DrawLabel Method
[image]

Draws a Label.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void DrawLabel (
Label label
)

Visual Basic [image] Copy Code

Public Sub DrawLabel( _
label As Label _
)

Parameters

label

The Label instance to draw.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.DrawPoint Method

GdiCanvas.DrawPoint Method
[image]

Draws a point marker at the specified location.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void DrawPoint (
Point point
)

Visual Basic [image] Copy Code

Public Sub DrawPoint( _
point As Point _
)

Parameters

point

The Point to draw.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.DrawPolyline Method

GdiCanvas.DrawPolyline Method
[image]

Draws a polyline.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void DrawPolyline (
IList<Point> points
)

Visual Basic [image] Copy Code

Public Sub DrawPolyline( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polyline segments.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.DrawString Method

GdiCanvas.DrawString Method
[image]

Draws a string with the specified attributes.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void DrawString (
string s,
Point point,
Rect bounds,
string fontName,
double fontSize
)

Visual Basic [image] Copy Code

Public Sub DrawString( _
s As String, _
point As Point, _
bounds As Rect, _
fontName As String, _
fontSize As Double _
)

Parameters

s

The string that should be drawn.

point

A Point specifying the string location.

bounds

A Rect specifying the string bounding box.

fontName

The name of the font used to render the string.

fontSize

The size of the font used to render the string.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.FillPolygon Method

GdiCanvas.FillPolygon Method
[image]

Fills a polygon.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void FillPolygon (
IList<Point> points
)

Visual Basic [image] Copy Code

Public Sub FillPolygon( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polygon borders.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.GetPixelSize Method

GdiCanvas.GetPixelSize Method
[image]

Gets the size of a pixel at the current zoom level.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public double GetPixelSize ()

Visual Basic [image] Copy Code

Public Function GetPixelSize () As Double

Return Value

A double value specifying the pixel size.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.GetRotatedBounds Method

GdiCanvas.GetRotatedBounds Method
[image]

Gets the bounding box of a rotated rectangle.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Rect GetRotatedBounds (
Rect rect,
float angle
)

Visual Basic [image] Copy Code

Public Function GetRotatedBounds( _
rect As Rect, _
angle As Single _
) As Rect

Parameters

rect

A Rect to rotate.

angle

Rotation angle.

Return Value

A Rect that bounds the specified rotated rectangle.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.ResetClip Method

GdiCanvas.ResetClip Method
[image]

Resets the current clip region.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void ResetClip ()

Visual Basic [image] Copy Code

Public Sub ResetClip ()

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.SetBrush Method

GdiCanvas.SetBrush Method
[image]

Sets the current brush to the one associated with specified map feature.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void SetBrush (
MapFeature brushKey
)

Visual Basic [image] Copy Code

Public Sub SetBrush( _
brushKey As MapFeature _
)

Parameters

brushKey

A MapFeature used as key in StreetMapBrushes table.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.SetFillColor Method

GdiCanvas.SetFillColor Method
[image]

Sets the current fill color to the specified color from the palette.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void SetFillColor (
int color
)

Visual Basic [image] Copy Code

Public Sub SetFillColor( _
color As Integer _
)

Parameters

color

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.SetHighlightColor Method

GdiCanvas.SetHighlightColor Method
[image]

Sets the current fill and line colors to the highlight color associated with this canvas.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void SetHighlightColor ()

Visual Basic [image] Copy Code

Public Sub SetHighlightColor ()

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.SetLineColor Method

GdiCanvas.SetLineColor Method
[image]

Sets the current line color to the line color associated with this canvas.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void SetLineColor ()

Visual Basic [image] Copy Code

Public Sub SetLineColor ()

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.SetPen Method

GdiCanvas.SetPen Method
[image]

Sets the current pen to the one associated with specified map feature.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void SetPen (
MapFeature penKey,
bool isBorderPen
)

Visual Basic [image] Copy Code

Public Sub SetPen( _
penKey As MapFeature, _
isBorderPen As Boolean _
)

Parameters

penKey

A MapFeature used as key in StreetMapPens table.

isBorderPen

true if the pen will be used to outline a closed shape, or false otherwise.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.SetTextAlignment Method

GdiCanvas.SetTextAlignment Method
[image]

Sets the current text alignment.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void SetTextAlignment (
TextAlignment horzAlignment,
TextAlignment vertAlignment
)

Visual Basic [image] Copy Code

Public Sub SetTextAlignment( _
horzAlignment As TextAlignment, _
vertAlignment As TextAlignment _
)

Parameters

horzAlignment

A TextAlignment member specifying the horizontal alignment.

vertAlignment

A TextAlignment member specifying the vertical alignment.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.UpdateLabel Method

GdiCanvas.UpdateLabel Method
[image]

Updates bounding box of shape's label from shape coordinates.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Rect UpdateLabel (
Shape shape
)

Visual Basic [image] Copy Code

Public Function UpdateLabel( _
shape As Shape _
) As Rect

Parameters

shape

A Shape instance.

Return Value

The label's bounding box.

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas Properties

GdiCanvas Properties
[image]

Public Properties

Name | Description
Graphics | Gets or sets the System.Drawing.Graphics instance backing this canvas.
Palette | Gets or sets the current color palette.
Transform | Gets or sets a matrix that transforms geo-coordinates to pixels.
ZoomFactor | Gets or sets the current zoom factor.

See Also

GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.Graphics Property

GdiCanvas.Graphics Property
[image]

Gets or sets the System.Drawing.Graphics instance backing this canvas.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Graphics Graphics { get; set; }

Visual Basic [image] Copy Code

Public Property Graphics As Graphics

Property Value

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.Palette Property

GdiCanvas.Palette Property
[image]

Gets or sets the current color palette.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public IPalette<Color> Palette { get; set; }

Visual Basic [image] Copy Code

Public Property Palette As IPalette(Of Color)

Property Value

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.Transform Property

GdiCanvas.Transform Property
[image]

Gets or sets a matrix that transforms geo-coordinates to pixels.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Matrix Transform { get; set; }

Visual Basic [image] Copy Code

Public Property Transform As Matrix

Property Value

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiCanvas.ZoomFactor Property

GdiCanvas.ZoomFactor Property
[image]

Gets or sets the current zoom factor.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

See Also

GdiCanvas Members
GdiCanvas Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiPalette Class

GdiPalette Class
[image]

Represents a palette of colors.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public class GdiPalette : IPalette<Color>

Visual Basic [image] Copy Code

Public Class GdiPalette
Implements IPalette(Of Color)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.WinForms.GdiPalette

See Also

GdiPalette Members
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiPalette Members

GdiPalette Members
Constructors Properties
[image]

Represents a palette of colors.

The following tables list the members exposed by the GdiPalette type.

Public Constructors

Name | Description
GdiPalette |

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

GdiPalette Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiPalette Constructor

GdiPalette Constructor
[image]

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public GdiPalette ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GdiPalette Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiPalette Properties

GdiPalette Properties
[image]

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

GdiPalette Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiPalette.FillColors Property

GdiPalette.FillColors Property
[image]

Gets or sets an array of fill colors.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public virtual Color[] FillColors { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property FillColors As Color()

Property Value

An array of System.Drawing.Color objects.

See Also

GdiPalette Members
GdiPalette Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiPalette.HighlightColor Property

GdiPalette.HighlightColor Property
[image]

Gets or sets the highlight color.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public virtual Color HighlightColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property HighlightColor As Color

Property Value

A System.Drawing.Color instance.

See Also

GdiPalette Members
GdiPalette Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiPalette.LineColor Property

GdiPalette.LineColor Property
[image]

Gets or sets the line color.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public virtual Color LineColor { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LineColor As Color

Property Value

A System.Drawing.Color instance.

See Also

GdiPalette Members
GdiPalette Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiTransform Class

GdiTransform Class
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public class GdiTransform : ITransform

Visual Basic [image] Copy Code

Public Class GdiTransform
Implements ITransform

Inheritance Hierarchy

System.Object
MindFusion.Mapping.WinForms.GdiTransform

See Also

GdiTransform Members
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiTransform Members

GdiTransform Members
Constructors Methods
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

The following tables list the members exposed by the GdiTransform type.

Public Constructors

Name | Description
GdiTransform | Initializes a new instance of the GdiTransform class.

Public Methods

Name | Description
DeviceToWorld | Convert a point from screen to world coordinates.
WorldToDevice | Overloaded.

See Also

GdiTransform Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiTransform Constructor

GdiTransform Constructor
[image]

Initializes a new instance of the GdiTransform class.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public GdiTransform (
Matrix matrix
)

Visual Basic [image] Copy Code

Public New ( _
matrix As Matrix _
)

Parameters

matrix

A Matrix instance specifying an affine transformation.

See Also

GdiTransform Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiTransform Methods

GdiTransform Methods
[image]

Public Methods

Name | Description
DeviceToWorld | Convert a point from screen to world coordinates.
WorldToDevice | Overloaded.

See Also

GdiTransform Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiTransform.DeviceToWorld Method

GdiTransform.DeviceToWorld Method
[image]

Convert a point from screen to world coordinates.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public virtual Point DeviceToWorld (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function DeviceToWorld( _
point As Point _
) As Point

Parameters

point

A Point specifying screen coordinates.

Return Value

A Point containing the corresponding world coordinates.

See Also

GdiTransform Members
GdiTransform Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiTransform.WorldToDevice Method

GdiTransform.WorldToDevice Method
[image]

Overload List

Name | Description
GdiTransform.WorldToDevice (Point) | Convert a point from world to screen coordinates.
GdiTransform.WorldToDevice (Point[]) | Convert an array of Point objects from world to screen coordinates.
GdiTransform.WorldToDevice (Rect) | Convert a Rect instance from world to screen coordinates.

See Also

GdiTransform Members
GdiTransform Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiTransform.WorldToDevice Method (Point)

GdiTransform.WorldToDevice Method (Point)
See Also
[image]

Convert a point from world to screen coordinates.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public virtual Point WorldToDevice (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function WorldToDevice( _
point As Point _
) As Point

Parameters

point

A Point specifying world coordinates.

Return Value

A Point containing the corresponding screen coordinates.

See Also

WorldToDevice Method Overload List
GdiTransform Members
GdiTransform Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiTransform.WorldToDevice Method (Point[])

GdiTransform.WorldToDevice Method (Point[])
See Also
[image]

Convert an array of Point objects from world to screen coordinates.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Point[] WorldToDevice (
Point[] points
)

Visual Basic [image] Copy Code

Public Function WorldToDevice( _
points() As Point _
) As Point()

Parameters

points

An array of Point objects specifying world coordinates.

Return Value

An array of Point objects containing the corresponding screen coordinates.

See Also

WorldToDevice Method Overload List
GdiTransform Members
GdiTransform Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.GdiTransform.WorldToDevice Method (Rect)

GdiTransform.WorldToDevice Method (Rect)
See Also
[image]

Convert a Rect instance from world to screen coordinates.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Rect WorldToDevice (
Rect rect
)

Visual Basic [image] Copy Code

Public Function WorldToDevice( _
rect As Rect _
) As Rect

Parameters

rect

An Rect instance specifying world coordinates.

Return Value

An Rect instance containing the corresponding screen coordinates.

See Also

WorldToDevice Method Overload List
GdiTransform Members
GdiTransform Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapEventArgs Class

MapEventArgs Class
[image]

Provides data for map events.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public class MapEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class MapEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Mapping.WinForms.MapEventArgs

See Also

MapEventArgs Members
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapEventArgs Members

MapEventArgs Members
Constructors Properties
[image]

Provides data for map events.

The following tables list the members exposed by the MapEventArgs type.

Public Constructors

Name | Description
MapEventArgs | Initializes a new instance of the MapEventArgs class.

Public Properties

Name | Description
Button | Gets or sets a MouseButtons member specifying the mouse button related to the event.
MapElement | Gets ot sets the MapElement for which the event is raised.

See Also

MapEventArgs Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapEventArgs Constructor

MapEventArgs Constructor
[image]

Initializes a new instance of the MapEventArgs class.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public MapEventArgs (
MapElement mapElement,
MouseButtons button
)

Visual Basic [image] Copy Code

Public New ( _
mapElement As MapElement, _
button As MouseButtons _
)

Parameters

mapElement

A MapElement for which the event is raised.

button

A MouseButtons member specifying the related mouse button.

See Also

MapEventArgs Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapEventArgs Properties

MapEventArgs Properties
[image]

Public Properties

Name | Description
Button | Gets or sets a MouseButtons member specifying the mouse button related to the event.
MapElement | Gets ot sets the MapElement for which the event is raised.

See Also

MapEventArgs Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapEventArgs.Button Property

MapEventArgs.Button Property
[image]

Gets or sets a MouseButtons member specifying the mouse button related to the event.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public MouseButtons Button { get; set; }

Visual Basic [image] Copy Code

Public Property Button As MouseButtons

Property Value

A member of the MouseButtons enumeration.

See Also

MapEventArgs Members
MapEventArgs Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapEventArgs.MapElement Property

MapEventArgs.MapElement Property
[image]

Gets ot sets the MapElement for which the event is raised.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public MapElement MapElement { get; set; }

Visual Basic [image] Copy Code

Public Property MapElement As MapElement

Property Value

A MapElement instance.

See Also

MapEventArgs Members
MapEventArgs Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapLayer Class

MapLayer Class
[image]

Represents a map layer containing geometric shapes.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public class MapLayer : MapLayerBase<Color, GdiPalette>

Visual Basic [image] Copy Code

Public Class MapLayer
Inherits MapLayerBase(Of Color, GdiPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(Color, GdiPalette)
MindFusion.Mapping.MapLayerBase(Color, GdiPalette)
MindFusion.Mapping.WinForms.MapLayer

See Also

MapLayer Members
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapLayer Members

MapLayer Members
Constructors Properties Methods Events
[image]

Represents a map layer containing geometric shapes.

The following tables list the members exposed by the MapLayer type.

Public Constructors

Name | Description
MapLayer |

Inherited Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override. (Inherited from MapLayerBase.)
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Map | Gets or sets the Map whose elements should be rendered on this layer. (Inherited from MapLayerBase.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Selection | Gets the list of selected map shapes. (Inherited from MapLayerBase.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

Inherited Public Methods

Name | Description
ClearCache | Layer.ClearCache override. (Inherited from MapLayerBase.)
Draw | Layer.Draw override. (Inherited from MapLayerBase.)
DrawHighlights | Overrides Layer.DrawHighlights. (Inherited from MapLayerBase.)
DrawLabels | Layer.DrawLabels override. (Inherited from MapLayerBase.)
DrawStreetMap | Layer.DrawStreetMap override. (Inherited from MapLayerBase.)
Highlight | Layer.Highlight override. (Inherited from MapLayerBase.)
HitTest | Layer.HitTest override. (Inherited from MapLayerBase.)
Select | Overloaded. (Inherited from MapLayerBase.)
Toggle | Layer.Toggle override. (Inherited from MapLayerBase.)

Inherited Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from MapLayerBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

Inherited Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
BeginLoad | Raised when the component starts loading map data from a file or memory stream. (Inherited from Layer.)
EndLoad | Raised when the component ends loading map data from a file or memory stream. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

MapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapLayer Constructor

MapLayer Constructor
[image]

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public MapLayer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView Class

MapView Class
[image]

A Windows Forms control used to draw maps.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public class MapView : Control, IZoomTarget

Visual Basic [image] Copy Code

Public Class MapView
Inherits Control
Implements IZoomTarget

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
MindFusion.Mapping.WinForms.MapView

See Also

MapView Members
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView Members

MapView Members
Constructors Properties Methods Events
[image]

A Windows Forms control used to draw maps.

The following tables list the members exposed by the MapView type.

Public Constructors

Name | Description
MapView | Initializes a new instance of the MapView class.

Public Properties

Name | Description
BackColor | Gets or sets the background color for the control.
BaseMap | Gets or sets the Map displayed in the first layer of this view.
Behavior | Specifies how the view interprets mouse input.
LabelsOnTop | Gets or sets whether labels of map elements should be drawn after rendering all layers
Layers | Gets the list of layers displayed in this view.
LicenseKey | Gets or sets the license key of the control.
MaxImageSize | Specifies the size of the image tiles of the map. Image maps can be split into multuple images to avoid problems with large images.
ZoomFactor | Gets or sets the current zoom level.

Public Methods

Name | Description
ClearCache | Clears cached bitmaps generated to represent current street-map.
ClientToMap | Converts a point from the control's client coordinates to map coordinates.
CreateImage | Overloaded.
MapToClient | Converts a point from the map coordinates to control's client coordinates.
RaiseMapElementClick | Raises the MapElementClick event.
RaiseMapElementHover | Raises the MapElementHover event.
ScrollTo | Overloaded.
SetZoomFactor | Sets the map zoom level.
Transform | Overloaded.

Protected Methods

Name | Description
OnBeginLoad | Raises the BeginLoad event.
OnEndLoad | Raises the EndLoad event.
OnMapElementClick | Raises the MapElementClick event.
OnMapElementHover | Raises the MapElementHover event.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnMouseWheel | Control.OnMouseWheel override.
OnPaint | Control.OnPaint override.
OnResize | Control.OnResize override.

Public Events

Name | Description
MapElementClick | Raised when the user clicks a map element.
MapElementHover | Raised when the mouse rests over a map element.

See Also

MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView Constructor

MapView Constructor
[image]

Initializes a new instance of the MapView class.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public MapView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView Methods

MapView Methods
[image]

Public Methods

Name | Description
ClearCache | Clears cached bitmaps generated to represent current street-map.
ClientToMap | Converts a point from the control's client coordinates to map coordinates.
CreateImage | Overloaded.
MapToClient | Converts a point from the map coordinates to control's client coordinates.
RaiseMapElementClick | Raises the MapElementClick event.
RaiseMapElementHover | Raises the MapElementHover event.
ScrollTo | Overloaded.
SetZoomFactor | Sets the map zoom level.
Transform | Overloaded.

Protected Methods

Name | Description
OnBeginLoad | Raises the BeginLoad event.
OnEndLoad | Raises the EndLoad event.
OnMapElementClick | Raises the MapElementClick event.
OnMapElementHover | Raises the MapElementHover event.
OnMouseDown | Control.OnMouseDown override.
OnMouseMove | Control.OnMouseMove override.
OnMouseUp | Control.OnMouseUp override.
OnMouseWheel | Control.OnMouseWheel override.
OnPaint | Control.OnPaint override.
OnResize | Control.OnResize override.

See Also

MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.ClearCache Method

MapView.ClearCache Method
[image]

Clears cached bitmaps generated to represent current street-map.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void ClearCache ()

Visual Basic [image] Copy Code

Public Sub ClearCache ()

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.ClientToMap Method

MapView.ClientToMap Method
[image]

Converts a point from the control's client coordinates to map coordinates.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Point ClientToMap (
Point point
)

Visual Basic [image] Copy Code

Public Function ClientToMap( _
point As Point _
) As Point

Parameters

point

A System.Drawing.Point instance.

Return Value

A MindFusion.Mapping.Point instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.CreateImage Method

MapView.CreateImage Method
[image]

Overload List

Name | Description
MapView.CreateImage () | Exports the currently displayed map to a bitmap image.
MapView.CreateImage (Size) | Exports the currently displayed map to a bitmap image.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.CreateImage Method ()

MapView.CreateImage Method ()
See Also
[image]

Exports the currently displayed map to a bitmap image.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Bitmap CreateImage ()

Visual Basic [image] Copy Code

Public Function CreateImage () As Bitmap

Return Value

A Bitmap instance.

See Also

CreateImage Method Overload List
MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.CreateImage Method (Size)

MapView.CreateImage Method (Size)
See Also
[image]

Exports the currently displayed map to a bitmap image.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Bitmap CreateImage (
Size size
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
size As Size _
) As Bitmap

Parameters

size

A Size instance specifying the bitmap height.

Return Value

A Bitmap instance.

See Also

CreateImage Method Overload List
MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.MapToClient Method

MapView.MapToClient Method
[image]

Converts a point from the map coordinates to control's client coordinates.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Point MapToClient (
Point point
)

Visual Basic [image] Copy Code

Public Function MapToClient( _
point As Point _
) As Point

Parameters

point

A MindFusion.Mapping.Point instance.

Return Value

A System.Drawing.Point instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.OnMapElementClick Method

MapView.OnMapElementClick Method
[image]

Raises the MapElementClick event.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual void OnMapElementClick (
MapEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMapElementClick( _
e As MapEventArgs _
)

Parameters

e

A MapEventArgs instance that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.OnMapElementHover Method

MapView.OnMapElementHover Method
[image]

Raises the MapElementHover event.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual void OnMapElementHover (
MapEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMapElementHover( _
e As MapEventArgs _
)

Parameters

e

A MapEventArgs instance that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.OnMouseDown Method

MapView.OnMouseDown Method
[image]

Control.OnMouseDown override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected override void OnMouseDown (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseDown( _
e As MouseEventArgs _
)

Parameters

e

A MouseEventArgs that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.OnMouseMove Method

MapView.OnMouseMove Method
[image]

Control.OnMouseMove override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

A MouseEventArgs that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.OnMouseUp Method

MapView.OnMouseUp Method
[image]

Control.OnMouseUp override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected override void OnMouseUp (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseUp( _
e As MouseEventArgs _
)

Parameters

e

A MouseEventArgs that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.OnMouseWheel Method

MapView.OnMouseWheel Method
[image]

Control.OnMouseWheel override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected override void OnMouseWheel (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseWheel( _
e As MouseEventArgs _
)

Parameters

e

A MouseEventArgs that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.OnPaint Method

MapView.OnPaint Method
[image]

Control.OnPaint override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected override void OnPaint (
PaintEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPaint( _
e As PaintEventArgs _
)

Parameters

e

A PaintEventArgs that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.OnResize Method

MapView.OnResize Method
[image]

Control.OnResize override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected override void OnResize (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnResize( _
e As EventArgs _
)

Parameters

e

An EventArgs that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.RaiseMapElementClick Method

MapView.RaiseMapElementClick Method
[image]

Raises the MapElementClick event.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void RaiseMapElementClick (
MapElement mapElement,
MouseButtons button
)

Visual Basic [image] Copy Code

Public Sub RaiseMapElementClick( _
mapElement As MapElement, _
button As MouseButtons _
)

Parameters

mapElement

The clicked map element.

button

The mouse button.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.RaiseMapElementHover Method

MapView.RaiseMapElementHover Method
[image]

Raises the MapElementHover event.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void RaiseMapElementHover (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Sub RaiseMapElementHover( _
mapElement As MapElement _
)

Parameters

mapElement

The hovered map element.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.ScrollTo Method

MapView.ScrollTo Method
[image]

Overload List

Name | Description
MapView.ScrollTo (Double, Double) | Scrolls to the specified map location and center it inside the control.
MapView.ScrollTo (Point) | Scrolls to the specified map location and center it inside the control.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.ScrollTo Method (Double, Double)

MapView.ScrollTo Method (Double, Double)
See Also
[image]

Scrolls to the specified map location and center it inside the control.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void ScrollTo (
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
latitude As Double, _
longitude As Double _
)

Parameters

latitude

A double value specifying the location latitude.

longitude

A double value specifying the location longitude.

See Also

ScrollTo Method Overload List
MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace
SetZoomFactor Method


MindFusion.Mapping.WinForms.MapView.ScrollTo Method (Point)

MapView.ScrollTo Method (Point)
See Also
[image]

Scrolls to the specified map location and center it inside the control.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void ScrollTo (
Point point
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
point As Point _
)

Parameters

point

A Point instance specifying a map location.

See Also

ScrollTo Method Overload List
MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace
SetZoomFactor Method


MindFusion.Mapping.WinForms.MapView.SetZoomFactor Method

MapView.SetZoomFactor Method
[image]

Sets the map zoom level.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void SetZoomFactor (
double zoomFactor,
Point pivotPoint
)

Visual Basic [image] Copy Code

Public Sub SetZoomFactor( _
zoomFactor As Double, _
pivotPoint As Point _
)

Parameters

zoomFactor

A double value specifying the new zoom level; 1 is for 100% zoom.

pivotPoint

A System.Drawing.Point whose screen location should not change after zoom.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace
ScrollTo Method
ZoomFactor Property


MindFusion.Mapping.WinForms.MapView.Transform Method

MapView.Transform Method
[image]

Overload List

Name | Description
MapView.Transform () | Gets a matrix representing the transformation from world to screen coordinates.
MapView.Transform (Layer(Color, GdiPalette)) | Gets a matrix representing the transformation from layer to screen coordinates.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.Transform Method ()

MapView.Transform Method ()
See Also
[image]

Gets a matrix representing the transformation from world to screen coordinates.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Matrix Transform ()

Visual Basic [image] Copy Code

Public Function Transform () As Matrix

Return Value

A Matrix instance.

See Also

Transform Method Overload List
MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.Transform Method (Layer(Color, GdiPalette))

MapView.Transform Method (Layer(Color, GdiPalette))
See Also
[image]

Gets a matrix representing the transformation from layer to screen coordinates.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Matrix Transform (
Layer<Color, GdiPalette> layer
)

Visual Basic [image] Copy Code

Public Function Transform( _
layer As Layer(Of Color, GdiPalette) _
) As Matrix

Parameters

layer

A layer whose bounding box should be mapped to the control's rectangle.

Return Value

A Matrix instance.

See Also

Transform Method Overload List
MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.OnBeginLoad Method

MapView.OnBeginLoad Method
[image]

Raises the BeginLoad event.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual void OnBeginLoad (
Object sender,
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBeginLoad( _
sender As Object, _
e As EventArgs _
)

Parameters

sender

The source of the event.

e

An object providing the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.OnEndLoad Method

MapView.OnEndLoad Method
[image]

Raises the EndLoad event.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

protected virtual void OnEndLoad (
Object sender,
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEndLoad( _
sender As Object, _
e As EventArgs _
)

Parameters

sender

The source of the event.

e

An object providing the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView Properties

MapView Properties
[image]

Public Properties

Name | Description
BackColor | Gets or sets the background color for the control.
BaseMap | Gets or sets the Map displayed in the first layer of this view.
Behavior | Specifies how the view interprets mouse input.
LabelsOnTop | Gets or sets whether labels of map elements should be drawn after rendering all layers
Layers | Gets the list of layers displayed in this view.
LicenseKey | Gets or sets the license key of the control.
MaxImageSize | Specifies the size of the image tiles of the map. Image maps can be split into multuple images to avoid problems with large images.
ZoomFactor | Gets or sets the current zoom level.

See Also

MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.BackColor Property

MapView.BackColor Property
[image]

Gets or sets the background color for the control.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public override Color BackColor { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property BackColor As Color

Property Value

A System.Drawing.Color instance. The default value is White.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.BaseMap Property

MapView.BaseMap Property
[image]

Gets or sets the Map displayed in the first layer of this view.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Map BaseMap { get; set; }

Visual Basic [image] Copy Code

Public Property BaseMap As Map

Property Value

An instance of the Map class.

Remarks

Assigning a map to this property is a shortcut to creating a MapLayer, setting it as the first layer in the view and setting its Map to the specified value.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.Behavior Property

MapView.Behavior Property
[image]

Specifies how the view interprets mouse input.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Behavior Behavior { get; set; }

Visual Basic [image] Copy Code

Public Property Behavior As Behavior

Property Value

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.LabelsOnTop Property

MapView.LabelsOnTop Property
[image]

Gets or sets whether labels of map elements should be drawn after rendering all layers

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public bool LabelsOnTop { get; set; }

Visual Basic [image] Copy Code

Public Property LabelsOnTop As Boolean

Property Value

true to draw map element labels after all layers have been rendered, otherwise false. The default value is true.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.Layers Property

MapView.Layers Property
[image]

Gets the list of layers displayed in this view.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public ObservableCollection<Layer<Color, GdiPalette>> Layers { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Layers As ObservableCollection(Of Layer(Of Color, GdiPalette))

Property Value

A List of Layer objects.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.LicenseKey Property

MapView.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.MaxImageSize Property

MapView.MaxImageSize Property
[image]

Specifies the size of the image tiles of the map. Image maps can be split into multuple images to avoid problems with large images.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public Size MaxImageSize { get; set; }

Visual Basic [image] Copy Code

Public Property MaxImageSize As Size

Property Value

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.ZoomFactor Property

MapView.ZoomFactor Property
[image]

Gets or sets the current zoom level.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

A double value specifying the zoom level. The default value is 1.

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace
ScrollTo Method
SetZoomFactor Method


MindFusion.Mapping.WinForms.MapView Events

MapView Events
[image]

Public Events

Name | Description
MapElementClick | Raised when the user clicks a map element.
MapElementHover | Raised when the mouse rests over a map element.

See Also

MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.MapElementClick Event

MapView.MapElementClick Event
[image]

Raised when the user clicks a map element.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public event EventHandler<MapEventArgs> MapElementClick

Visual Basic [image] Copy Code

Public Event MapElementClick As EventHandler(Of MapEventArgs)

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.MapView.MapElementHover Event

MapView.MapElementHover Event
[image]

Raised when the mouse rests over a map element.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public event EventHandler<MapEventArgs> MapElementHover

Visual Basic [image] Copy Code

Public Event MapElementHover As EventHandler(Of MapEventArgs)

See Also

MapView Members
MapView Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer Class

StreetMapLayer Class
[image]

Represents a map layer containing OpenStreetMap maps.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public class StreetMapLayer : MapLayerBase<Color, GdiPalette>

Visual Basic [image] Copy Code

Public Class StreetMapLayer
Inherits MapLayerBase(Of Color, GdiPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(Color, GdiPalette)
MindFusion.Mapping.MapLayerBase(Color, GdiPalette)
MindFusion.Mapping.WinForms.StreetMapLayer

See Also

StreetMapLayer Members
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer Members

StreetMapLayer Members
Constructors Properties Methods Events
[image]

Represents a map layer containing OpenStreetMap maps.

The following tables list the members exposed by the StreetMapLayer type.

Public Constructors

Name | Description
StreetMapLayer | Initializes a new instance of the StreetMapLayer class.

Inherited Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override. (Inherited from MapLayerBase.)
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them. (Inherited from Layer.)
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them. (Inherited from Layer.)
FillColors | Gets or sets the colors used to fill map elements on this layer. (Inherited from Layer.)
HighlightColor | Gets or sets the color used to highlight elements on this layer. (Inherited from Layer.)
LineColor | Gets or sets the line color used to draw elements on this layer. (Inherited from Layer.)
Map | Gets or sets the Map whose elements should be rendered on this layer. (Inherited from MapLayerBase.)
Palette | Gets or sets the color palette associated with this layer. (Inherited from Layer.)
Selection | Gets the list of selected map shapes. (Inherited from MapLayerBase.)
Visible | Gets or sets whether this layer should be visible in the map view. (Inherited from Layer.)

Public Methods

Name | Description
AddBrush | Adds a brush to the list of brushes used for shapes rendering.
AddPen | Adds a pen to the list of pens used for shapes rendering.
ClearCache | Layer.ClearCache override.
Draw | Layer.Draw override.
DrawLabels | Layer.DrawLabels override.
Select | Layer.Select override.

Inherited Public Methods

Name | Description
ClearCache | Layer.ClearCache override. (Inherited from MapLayerBase.)
Draw | Layer.Draw override. (Inherited from MapLayerBase.)
DrawHighlights | Overrides Layer.DrawHighlights. (Inherited from MapLayerBase.)
DrawLabels | Layer.DrawLabels override. (Inherited from MapLayerBase.)
DrawStreetMap | Layer.DrawStreetMap override. (Inherited from MapLayerBase.)
Highlight | Layer.Highlight override. (Inherited from MapLayerBase.)
HitTest | Layer.HitTest override. (Inherited from MapLayerBase.)
Select | Overloaded. (Inherited from MapLayerBase.)
Toggle | Layer.Toggle override. (Inherited from MapLayerBase.)

Inherited Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from MapLayerBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

Inherited Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed. (Inherited from Layer.)
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed. (Inherited from Layer.)
BeginLoad | Raised when the component starts loading map data from a file or memory stream. (Inherited from Layer.)
EndLoad | Raised when the component ends loading map data from a file or memory stream. (Inherited from Layer.)
PropertyChanged | Raised when the value of a property of the Layer class is changed. (Inherited from Layer.)

See Also

StreetMapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer Constructor

StreetMapLayer Constructor
[image]

Initializes a new instance of the StreetMapLayer class.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public StreetMapLayer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

StreetMapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer Methods

StreetMapLayer Methods
[image]

Public Methods

Name | Description
AddBrush | Adds a brush to the list of brushes used for shapes rendering.
AddPen | Adds a pen to the list of pens used for shapes rendering.
ClearCache | Layer.ClearCache override.
Draw | Layer.Draw override.
DrawLabels | Layer.DrawLabels override.
Select | Layer.Select override.

Inherited Public Methods

Name | Description
ClearCache | Layer.ClearCache override. (Inherited from MapLayerBase.)
Draw | Layer.Draw override. (Inherited from MapLayerBase.)
DrawHighlights | Overrides Layer.DrawHighlights. (Inherited from MapLayerBase.)
DrawLabels | Layer.DrawLabels override. (Inherited from MapLayerBase.)
DrawStreetMap | Layer.DrawStreetMap override. (Inherited from MapLayerBase.)
Highlight | Layer.Highlight override. (Inherited from MapLayerBase.)
HitTest | Layer.HitTest override. (Inherited from MapLayerBase.)
Select | Overloaded. (Inherited from MapLayerBase.)
Toggle | Layer.Toggle override. (Inherited from MapLayerBase.)

Inherited Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event. (Inherited from Layer.)
OnAsyncLoadComplete | Raises the AsyncLoadComplete event. (Inherited from Layer.)
OnBeginLoad | Raises the BeginLoad event. (Inherited from MapLayerBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from Layer.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Layer.)

See Also

StreetMapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer.AddBrush Method

StreetMapLayer.AddBrush Method
[image]

Adds a brush to the list of brushes used for shapes rendering.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void AddBrush (
string tagKey,
string tagValue,
SolidBrush brush
)

Visual Basic [image] Copy Code

Public Sub AddBrush( _
tagKey As String, _
tagValue As String, _
brush As SolidBrush _
)

Parameters

tagKey

The key of the tag, specifying the map feature.

tagValue

The value of the tag, specifying the map feature.

brush

The SolidBrush object to add.

Remarks

For a list of standard key and value identifiers of map features, see http://wiki.openstreetmap.org/wiki/Map_Features [image] .

See Also

StreetMapLayer Members
StreetMapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer.AddPen Method

StreetMapLayer.AddPen Method
[image]

Adds a pen to the list of pens used for shapes rendering.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public void AddPen (
string tagKey,
string tagValue,
Pen pen
)

Visual Basic [image] Copy Code

Public Sub AddPen( _
tagKey As String, _
tagValue As String, _
pen As Pen _
)

Parameters

tagKey

The key of the tag, specifying the map feature.

tagValue

The value of the tag, specifying the map feature.

pen

The Pen object to add.

Remarks

For a list of standard key and value identifiers of map features, see http://wiki.openstreetmap.org/wiki/Map_Features [image] .

See Also

StreetMapLayer Members
StreetMapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer.ClearCache Method

StreetMapLayer.ClearCache Method
[image]

Layer.ClearCache override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public override void ClearCache ()

Visual Basic [image] Copy Code

Public Overrides Sub ClearCache ()

See Also

StreetMapLayer Members
StreetMapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer.Draw Method

StreetMapLayer.Draw Method
[image]

Layer.Draw override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public override void Draw (
ICanvasWithPalette<Color> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
canvas As ICanvasWithPalette(Of Color), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

StreetMapLayer Members
StreetMapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer.DrawLabels Method

StreetMapLayer.DrawLabels Method
[image]

Layer.DrawLabels override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public override void DrawLabels (
ICanvasWithPalette<Color> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLabels( _
canvas As ICanvasWithPalette(Of Color), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

StreetMapLayer Members
StreetMapLayer Class
MindFusion.Mapping.WinForms Namespace


MindFusion.Mapping.WinForms.StreetMapLayer.Select Method

StreetMapLayer.Select Method
[image]

Layer.Select override.

Namespace: MindFusion.Mapping.WinForms
Assembly: MindFusion.Mapping.WinForms

Syntax

C# [image] Copy Code

public override bool Select (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

StreetMapLayer Members
StreetMapLayer Class
MindFusion.Mapping.WinForms Namespace


Online Resources

Online Resources

The following websites host free map files in ESRI Shapefile format:

Natural Earth
http://www.naturalearthdata.com

U.S. Census Bureau
http://www.census.gov/geo/www/cob/bdy_files.html

Map Library
http://www.maplibrary.org/

MapCruzin
http://www.mapcruzin.com/download-free-arcgis-shapefiles.htm

OpenStreetMap Shapefiles
http://wiki.openstreetmap.org/wiki/Shapefiles

UN Second Administrative Level Boundaries
http://www.unsalb.org/

Centers for Disease Control and Prevention
http://wwwn.cdc.gov/epiinfo/script/shapefiles.aspx

Free Spatial Data as DIVA-GIS
http://www.diva-gis.org/Data


MindFusion Products

MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming | Links
Diagramming for WPF | Product Information Download
Diagramming for Silverlight | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for .NET Compact | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download
DiagramViewer for iOS/Cocoa Touch | Product Information Download
DiagramViewer for Android | Product Information Download

Charting | Links
Charting for WPF | Product Information Download
Charting for Silverlight | Product Information Download
Charting for WinForms | Product Information Download
Charting for ASP.NET | Product Information Download

Scheduling | Links
Scheduling for WinForms | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for .NET Compact | Product Information Download
Scheduling for WPF | Product Information Download
Scheduling for Silverlight | Product Information Download
Scheduling for Java Swing | Product Information Download

Spreadsheet | Links
Spreadsheet for WinForms | Product Information Download
Spreadsheet for WPF | Product Information Download

Reporting | Links
Reporting for WinForms | Product Information Download
Reporting for WPF | Product Information Download
Reporting for Silverlight | Product Information Download

Mapping | Links
Mapping for WinForms | Product Information Download
Mapping for WPF | Product Information Download
Mapping for Silverlight | Product Information Download

Suites | Links
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Java FX | Product Information Download
Pack for Scheduling | Product Information Download
Pack for Silverlight | Product Information Download


Acknowledgements

Acknowledgements

The map files installed under the 50m* and 110m* folders contain public domain maps from http://www.naturalearthdata.com [image] . They correspond to the medium and small scale vector sets from that site. An additional high-resolution large scale data set can be downloaded from http://www.naturalearthdata.com/downloads/10m-cultural-vectors/ [image] . The maps are free to use in any kind of project as outlined at http://www.naturalearthdata.com/about/terms-of-use/ [image] .

The country map files installed with this library were created by MindFusion from public domain data, mostly from http://www.naturalearthdata.com [image] .

Landmark icons used in sample project are from the Tourism icon set from http://iconka.com/free/ [image] .