Introduction

MindFusion.Mapping for WPF comprises a WPF control and a class library that provides your application with great features for loading, customizing and displaying any type of regional, national or world map. Easy to integrate and program, this control gives you the power to build the perfect map according to your needs with minimal time and efforts from your side. You can:

  • add labels to map elements
  • access database data associated with map elements
  • choose the color scheme
  • set decorative elements like images, icons etc.

Map data can be loaded from the popular ESRI Shapefile format and you have at your disposal an impressive variety of *.shp files, which give you valuable data for any country in the world as well for selected cities, rivers, roads and other geographic objects. Data for the attributes of map elements can be loaded from a DBF file associated with each map. The control supports multiple layers so you can show several maps in a single view.

MindFusion.Mapping for WPF is installed with various samples in C# and VB.NET that demonstrate all important features of the control and significantly shorten the time needed to learn how to use it. The help file also includes step-by-step guides and tutorials. The API is documented in details and both offline and online documentation is provided. The control and the map files included in the package are royalty free.

© 2012 MindFusion


Programming Interface Overview

© 2012 MindFusion


Loading Map Files

Maps in the MindFusion.Mapping for WPF are represented by the Map class. Its LoadFromStream method can load map data from files in the ESRI Shapefile format. Shapefiles come with an associated DBF database, that can provide various attribute values for the map elements. To load the DBF database along with the main map file, set the dbfStream parameter of LoadFromFile. The loaded database can be accessed via the Database property, and each record associated with a map element is exposed via the DatabaseRow property of the Shape class.

To display a map once it is loaded, assign it to the BaseMap property of the MapView control, or add a new MapLayer to the view and assign the map to its Map property. The following code demonstrates how to load a map with associated database from the application's XAP file and assign it to BaseMap:

C# [image] Copy Code

private void OnLoaded(object sender, RoutedEventArgs e)
{
var mapUri = new Uri("MyApp;component/my_map.shp", UriKind.Relative);
var dbfUri = new Uri("MyApp;component/my_map.dbf", UriKind.Relative);

var mapStreamInfo = Application.GetResourceStream(mapUri);
var dbfStreamInfo = Application.GetResourceStream(dbfUri);

if (mapStreamInfo != null && dbfStreamInfo != null)
{
var map = new Map();
map.LoadFromStream(mapStreamInfo.Stream, dbfStreamInfo.Stream, "NAME");
map.AssignColors();

mapView.BaseMap = map;
}
}

Visual Basic [image] Copy Code

Private Sub OnLoaded(sender As Object, e As RoutedEventArgs)

Dim mapUri = New Uri("MyApp;component/my_map.shp", UriKind.Relative)
Dim dbfUri = New Uri("MyApp;component/my_map.dbf", UriKind.Relative)

Dim mapStreamInfo = Application.GetResourceStream(mapUri)
Dim dbfStreamInfo = Application.GetResourceStream(dbfUri)

If mapStreamInfo IsNot Nothing AndAlso dbfStreamInfo IsNot Nothing Then
Dim map = New Map()
map.LoadFromStream(mapStreamInfo.Stream, dbfStreamInfo.Stream, "NAME")
map.AssignColors()

mapView.BaseMap = map
End If

End Sub

Maps can be loaded as well from XAML code by setting the MapLocation property of a map layer. The following example loads a map file:

Xaml [image] Copy Code

<ScrollViewer HorizontalScrollBarVisibility="Auto">
<map:MapView x:Name="mapView">
<map:MapLayer MapLocation="my_map.shp" DatabaseLocation="my_map.dbf" LabelField="NAME" />
</map:MapView>
</ScrollViewer>


Map Layers

The MapView control can display several map and decoration layers. In order to add a new layer, create a MapLayer or DecorationLayer instance and add it to the Layers collection of the view. Assigning a map to the BaseMap property is a shortcut to creating a MapLayer, setting it as the first layer in the view and setting its Map property to the specified value.

Visibility of individual layers can be set through their Visible property. In addition, you can turn on or off interactive selection and highlighting in a layer by setting the EnableHighlight and EnableSelection properties. Even if interactive support is disabled, map elements can still be selected or highlighted programmatically by calling the Select or Highlight methods of the Layer class.

The following excerpt from the Layers sample project shows how to add several map layers displaying different maps:

C# [image] Copy Code

// load base map
var layer0 = new MapLayer();
layer0.Visible = true;
layer0.Map = new Map();
layer0.Map.LoadFromFile(FindMap("ne_50m_admin_0_countries.shp"));

mapView.Layers.Add(layer0);

// load urban areas map
var layer1 = new MapLayer();
layer1.Visible = false;
layer1.LineColor = Color.Yellow;
layer1.FillColors[0] = Color.Yellow;
layer1.Map = new Map();
layer1.Map.LoadFromFile(FindMap("ne_50m_urban_areas.shp"));

mapView.Layers.Add(layer1);

// load rivers map
var layer2 = new MapLayer();
layer2.Visible = false;
layer2.LineColor = Color.Blue;
layer2.Map = new Map();
layer2.Map.LoadFromFile(FindMap("50m_rivers_lake_centerlines.shp"));

mapView.Layers.Add(layer2);

Visual Basic [image] Copy Code

' load base map
Dim layer0 As New MapLayer()
layer0.Visible = True
layer0.Map = New Map()
layer0.Map.LoadFromFile(FindMap("ne_50m_admin_0_countries.shp"))

mapView.Layers.Add(layer0)

' load urban areas map
Dim layer1 As New MapLayer()
layer1.Visible = False
layer1.LineColor = Color.Yellow
layer1.FillColors(0) = Color.Yellow
layer1.Map = New Map()
layer1.Map.LoadFromFile(FindMap("ne_50m_urban_areas.shp"))

mapView.Layers.Add(layer1)

' load rivers map
Dim layer2 As New MapLayer()
layer2.Visible = False
layer2.LineColor = Color.Blue
layer2.Map = New Map()
layer2.Map.LoadFromFile(FindMap("50m_rivers_lake_centerlines.shp"))

mapView.Layers.Add(layer2)


Customizing the Map

Maps can be customized by assigning labels to the map elements, by specifying new colors, or by adding decoration images.

To set an element's label, assign to the Label property of MapElement. The label is diplayed using the font set through the FontName and FontSize properties. Note that labels can be automatically loaded from the Shapefile database by passing a column name as third argument of the LoadFromStream method.

Colors of map elements can be set via the Color property of the Shape class. This property specifies an index within the layer's palette. The palette colors can be customized via the FillColors property of the Layer class. By default, all shapes are painted using the same color. The AssignColors method lets you automatically assign colors in such a way that no adjacent shapes share the same color.


Decorations

Decorations can be displayed by adding a DecorationLayer to the MapView. At this time there are two kinds of built-in decorations supported, DecorationImage and DecorationBubble.

DecorationImage can display a bitmap image at the specified latitude and longitude. This is useful if you need to show an icon (e.g denoting a landmark or a kind of business object) located there. The image is set via the Image property. You can specify an additional image through the HighlightImage property, which is drawn over the main image when the decoration is highlighted or selected. The PivotX and PivotY properties lets you specify the exact pixel within the image that should be placed at the decoration's map location. Decoration images can also have an associated Label drawn below them.

DecorationBubble is used to drawn a circle at the specified latitude and longitude. The circle radius length can be set proportionally to some statistical value associated with the location, for example population or income. The circle can be customized by setting its Label, FontName, FontSize, FillColor and BorderColor properties.

The following excerpt from the Markers sample project shows how to add a decoration layer and decoration images to the map view:

C# [image] Copy Code

// add a second layer to display decoration objects
var decorationLayer = new DecorationLayer(mapView.BaseMap.BoundingBox);
mapView.Layers.Add(decorationLayer);

// create decoration images
foreach (var landmark in landmarks)
{
var img = new DecorationImage(
Image.FromFile(@"Images\" + landmark.Image),
landmark.ImageX, landmark.ImageY,
landmark.Latitude, landmark.Longitude);
img.Label = landmark.Label;
decorationLayer.Decorations.Add(img);
}

Visual Basic [image] Copy Code

' add a second layer to display decoration objects
Dim decorationLayer = New DecorationLayer(mapView.BaseMap.BoundingBox)
mapView.Layers.Add(decorationLayer)

' create decoration images
For Each landmark As var In landmarks
Dim img = New DecorationImage(Image.FromFile("Images\" & Convert.ToString(landmark.Image)), landmark.ImageX, landmark.ImageY, landmark.Latitude, landmark.Longitude)
img.Label = landmark.Label
decorationLayer.Decorations.Add(img)
Next


Scrolling and Zooming

In order to enable scrolling and zooming, the MapView control must be placed inside a ScrollViewer.

The view can be panned interactively by dragging it with the mouse. The user can also zoom into or out of the map via the mouse wheel. To implement a different scroll or zoom interaction logic, you can use the properties and methods exposed by MapView from various input event handlers. In order to change the scroll position, call the ScrollTo method. In order to change the zoom level, set the ZoomFactor property or call the SetZoomFactor method.

The following excerpt from the Markers sample project shows how to center the view on a specific decoration object:

C# [image] Copy Code

mapView.ZoomFactor = 6;

// office is a reference to a DecorationBubble instance
mapView.ScrollTo(office.Latitude, office.Longitude);

// focus is necessary in order to receive mouse wheel events
mapView.Focus();

Visual Basic [image] Copy Code

mapView.ZoomFactor = 6

' office is a reference to a DecorationBubble instance
mapView.ScrollTo(office.Latitude, office.Longitude)

' focus is necessary in order to receive mouse wheel events
mapView.Focus()


MindFusion.Mapping Programmer's Guide

Reference

© 2012 MindFusion


MindFusion.Mapping Namespace
Classes Interfaces Enumerations

Classes

Class | Description
Column | Represents a database column.
Database | Represents the DBF database associated with an ESRI map file.
Decoration | Represents a decoration element drawn in a separate layer over the map.
DecorationLayerBase(TColor, TPalette) | Represents a layer containing decorative elements.
Layer(TColor, TPalette) | Represents a map layer.
Map | Represents a geographic map.
MapElement | Represents visual elements of a map that can be drawn and hit-tested.
MapLayerBase(TColor, TPalette) | Represents a map layer containing geometric shapes.
NullShape | Represents a null shape with no geometric data; often used as a place holder until data becomes available.
Point | Represents a point on the map with X (longitude) and Y (latitude) coordinates.
Rect | A class representing a rectangular are on the map.
Row | Represents a DBF database row.
Shape | Represents geometrical shapes displayed on a map.

Interfaces

Interface | Description
ICanvas | Represents a drawing canvas.
ICanvasWithPalette(TColor) | Represents a drawing canvas with an associated palette of colors.
IPalette(TColor) | Represents a palette of colors.
ITransform | Represents a geometrical transform used to convert world coordinates to screen coordinates.

Enumerations

Enumeration | Description
ColumnType | Specifies a DBF column type.
ShapeType | Specifies the type of shapes contained in an ESRI map file.
TextAlignment | Specifies text alignment.


MindFusion.Mapping.Column Class

Column Class
Remarks See Also
[image]

Represents a database column.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Column

Visual Basic [image] Copy Code

Public Class Column

Remarks

Objects of this class represent the columns in a DBF database associated with a map file. The Name property indicates the column name, and the Type property indicates the DBF data type.

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Column

See Also

Column Members
MindFusion.Mapping Namespace


MindFusion.Mapping.Column Members

Column Members
Properties Methods
[image]

Represents a database column.

The following tables list the members exposed by the Column type.

Public Properties

Name | Description
Decimals | Gets the number of decimals stored for numeric values in this column.
Length | Gets the length of fields in this column.
Name | Gets the column name.
Type | Gets the DBF column type.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Column Class


MindFusion.Mapping.Column Methods

Column Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

Column Class


MindFusion.Mapping.Column.ToString Method

Column.ToString Method
See Also
[image]

Object.ToString override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

Returns the column name.

See Also

Column Members
Column Class


MindFusion.Mapping.Column Properties

Column Properties
[image]

Public Properties

Name | Description
Decimals | Gets the number of decimals stored for numeric values in this column.
Length | Gets the length of fields in this column.
Name | Gets the column name.
Type | Gets the DBF column type.

See Also

Column Class


MindFusion.Mapping.Column.Decimals Property

Column.Decimals Property
[image]

Gets the number of decimals stored for numeric values in this column.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public byte Decimals { get; set; }

Visual Basic [image] Copy Code

Public Property Decimals As Byte

Property Value

A byte value specifying the number of decimal places in numeric fields.

See Also

Column Members
Column Class
Type Property


MindFusion.Mapping.Column.Length Property

Column.Length Property
[image]

Gets the length of fields in this column.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Integer

Property Value

An integer value that specifies the length in bytes of data fields in this column.

See Also

Column Members
Column Class


MindFusion.Mapping.Column.Name Property

Column.Name Property
[image]

Gets the column name.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

A string value specifying the column name.

See Also

Column Members
Column Class
Type Property


MindFusion.Mapping.Column.Type Property

Column.Type Property
[image]

Gets the DBF column type.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public ColumnType Type { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Type As ColumnType

Property Value

A member of the ColumnType enumeration.

See Also

Column Members
Column Class
Name Property


MindFusion.Mapping.ColumnType Enumeration

ColumnType Enumeration
[image]

Specifies a DBF column type.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public enum ColumnType

Visual Basic [image] Copy Code

Public Enumeration ColumnType

Members

Member name | Description
Binary | Indicates that the column stores binary data.
Boolean | Indicates that the column stores Boolean data.
Character | Indicates that the column stores character data.
Date | Indicates that the column stores date values.
FloatingPoint | Indicates that the column stores floating point values.
Integer | Indicates that the column stores integer values.
Memo | Indicates that the column stores memo data.
Number | Indicates that the column stores numeric data.

See Also


MindFusion.Mapping.Database Class

Database Class
Remarks See Also
[image]

Represents the DBF database associated with an ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Database : IListSource

Visual Basic [image] Copy Code

Public Class Database
Implements IListSource

Remarks

The DBF database associated with a map is loaded optionally, as specified via parameters of the LoadFromStream method of the Map class. If the database is loaded, it is represented by instance of this class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Database

See Also

Database Members


MindFusion.Mapping.Database Members

Database Members
Constructors Properties Methods
[image]

Represents the DBF database associated with an ESRI map file.

The following tables list the members exposed by the Database type.

Public Constructors

Name | Description
Database | Overloaded. Initializes a new instance of the Database class.

Public Properties

Name | Description
ColumnCount | Returns the number of column in the database.
Columns | Gets a list of columns in the database.
ContainsListCollection | Implements IListSource.ContainsListCollection.
Item | Overloaded. Gets the column with a specified name or index.
RowLength | Returns the length in bytes of a database row.
Rows | Gets a list of rows in the database.

Public Methods

Name | Description
GetList | Implements IListSource.GetList.
LoadFrom | Overloaded. Loads database data from a stream or a file.
SaveTo | Overloaded. Saves this database to a stream or a file.

See Also

Database Class


MindFusion.Mapping.Database Constructor

Database Constructor
[image]

Initializes a new instance of the Database class.

Overload List

Name | Description
Database (Database) | Creates a new instance of the Database class.
Database (String) | Creates a new instance of the Database class.
Database (BinaryReader) | Creates a new instance of the Database class.

See Also

Database Class


MindFusion.Mapping.Database Constructor (Database)

Database Constructor (Database)
See Also
[image]

Creates a new instance of the Database class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database (
Database schema
)

Visual Basic [image] Copy Code

Public New ( _
schema As Database _
)

Parameters

schema

A prototype database whose schema should be copied to this database.

See Also

Database Constructor Overload List
Database Class


MindFusion.Mapping.Database Constructor (String)

Database Constructor (String)
See Also
[image]

Creates a new instance of the Database class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database (
string fileName
)

Visual Basic [image] Copy Code

Public New ( _
fileName As String _
)

Parameters

fileName

Specifies the file name of the DBF database file.

See Also

Database Constructor Overload List
Database Class


MindFusion.Mapping.Database Constructor (BinaryReader)

Database Constructor (BinaryReader)
See Also
[image]

Creates a new instance of the Database class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public New ( _
reader As BinaryReader _
)

Parameters

reader

Specifies a stream from which to load the database data.

See Also

Database Constructor Overload List
Database Class


MindFusion.Mapping.Database Methods

Database Methods
[image]

Public Methods

Name | Description
GetList | Implements IListSource.GetList.
LoadFrom | Overloaded. Loads database data from a stream or a file.
SaveTo | Overloaded. Saves this database to a stream or a file.

See Also

Database Class


MindFusion.Mapping.Database.GetList Method

Database.GetList Method
[image]

Implements IListSource.GetList.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public IList GetList ()

Visual Basic [image] Copy Code

Public Function GetList () As IList

Return Value

An IList containing the database rows.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.LoadFrom Method

Database.LoadFrom Method
[image]

Loads database data from a stream or a file.

Overload List

Name | Description
Database.LoadFrom (BinaryReader) | Loads database data from the specified stream.
Database.LoadFrom (String) | Loads database data from the specified file.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.LoadFrom Method (BinaryReader)

Database.LoadFrom Method (BinaryReader)
See Also
[image]

Loads database data from the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFrom (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
reader As BinaryReader _
)

Parameters

reader

A BinaryReader used to read database data.

See Also

LoadFrom Method Overload List
Database Members
Database Class


MindFusion.Mapping.Database.LoadFrom Method (String)

Database.LoadFrom Method (String)
See Also
[image]

Loads database data from the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFrom (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFrom( _
fileName As String _
)

Parameters

fileName

A string value specifying the file name.

See Also

LoadFrom Method Overload List
Database Members
Database Class


MindFusion.Mapping.Database.SaveTo Method

Database.SaveTo Method
[image]

Saves this database to a stream or a file.

Overload List

Name | Description
Database.SaveTo (String) | Saves this database to the specified file.
Database.SaveTo (BinaryWriter) | Saves this database to the specified stream.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.SaveTo Method (String)

Database.SaveTo Method (String)
See Also
[image]

Saves this database to the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveTo (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
fileName As String _
)

Parameters

fileName

A string value specifying the file name.

See Also

SaveTo Method Overload List
Database Members
Database Class


MindFusion.Mapping.Database.SaveTo Method (BinaryWriter)

Database.SaveTo Method (BinaryWriter)
See Also
[image]

Saves this database to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the database data.

See Also

SaveTo Method Overload List
Database Members
Database Class


MindFusion.Mapping.Database Properties

Database Properties
[image]

Public Properties

Name | Description
ColumnCount | Returns the number of column in the database.
Columns | Gets a list of columns in the database.
ContainsListCollection | Implements IListSource.ContainsListCollection.
Item | Overloaded. Gets the column with a specified name or index.
RowLength | Returns the length in bytes of a database row.
Rows | Gets a list of rows in the database.

See Also

Database Class


MindFusion.Mapping.Database.ColumnCount Property

Database.ColumnCount Property
[image]

Returns the number of column in the database.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int ColumnCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ColumnCount As Integer

Property Value

An integer value specifying the number of columns in the DBF file.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.Columns Property

Database.Columns Property
[image]

Gets a list of columns in the database.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Column> Columns { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Columns As List(Of Column)

Property Value

A List of Column objects.

See Also

Database Members
Database Class
Rows Property


MindFusion.Mapping.Database.ContainsListCollection Property

Database.ContainsListCollection Property
[image]

Implements IListSource.ContainsListCollection.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool ContainsListCollection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ContainsListCollection As Boolean

Property Value

This property always returns false.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.Item Property

Database.Item Property
[image]

Gets the column with a specified name or index.

Overload List

Name | Description
Database.Item (String) | Gets the column with the specified name.
Database.Item (Int32) | Gets the column with the specified index.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.Item Property (String)

Database.Item Property (String)
See Also
[image]

Gets the column with the specified name.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Column Item [
string name
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
name As String _
) As Column

Parameters

name

A string value specifying the column name.

Property Value

A Column instance representing the database column.

See Also

Item Property Overload List
Database Members
Database Class


MindFusion.Mapping.Database.Item Property (Int32)

Database.Item Property (Int32)
See Also
[image]

Gets the column with the specified index.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Column Item [
int nIndex
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
nIndex As Integer _
) As Column

Parameters

nIndex

An integer value specifying the column index.

Property Value

A Column instance representing the database column.

See Also

Item Property Overload List
Database Members
Database Class


MindFusion.Mapping.Database.RowLength Property

Database.RowLength Property
[image]

Returns the length in bytes of a database row.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int RowLength { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowLength As Integer

Property Value

An integer value specifying the length in bytes of a DBF data record.

See Also

Database Members
Database Class


MindFusion.Mapping.Database.Rows Property

Database.Rows Property
[image]

Gets a list of rows in the database.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Row> Rows { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Rows As List(Of Row)

Property Value

A List of Row objects.

See Also

Database Members
Database Class
Columns Property


MindFusion.Mapping.Decoration Class

Decoration Class
[image]

Represents a decoration element drawn in a separate layer over the map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class Decoration : MapElement

Visual Basic [image] Copy Code

Public MustInherit Class Decoration
Inherits MapElement

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.Wpf.DecorationBubble
MindFusion.Mapping.Wpf.DecorationImage

See Also

Decoration Members


MindFusion.Mapping.Decoration Members

Decoration Members
Constructors Properties
[image]

Represents a decoration element drawn in a separate layer over the map.

The following tables list the members exposed by the Decoration type.

Public Constructors

Name | Description
Decoration | Initializes a new instance of the Decoration class.

Public Properties

Name | Description
Latitude | Gets or sets the latitude associated with this decoration.
Longitude | Gets or sets the longitude associated with this decoration.

See Also

Decoration Class


MindFusion.Mapping.Decoration Constructor

Decoration Constructor
[image]

Initializes a new instance of the Decoration class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Decoration (
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
latitude As Double, _
longitude As Double _
)

Parameters

latitude

Specifies the latitude associated with this element.

longitude

Specifies the longitude associated with this element.

See Also

Decoration Class


MindFusion.Mapping.Decoration Properties

Decoration Properties
[image]

Public Properties

Name | Description
Latitude | Gets or sets the latitude associated with this decoration.
Longitude | Gets or sets the longitude associated with this decoration.

See Also

Decoration Class


MindFusion.Mapping.Decoration.Latitude Property

Decoration.Latitude Property
[image]

Gets or sets the latitude associated with this decoration.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Latitude { get; set; }

Visual Basic [image] Copy Code

Public Property Latitude As Double

Property Value

A double value specifying the latitude of the decoration's location.

Remarks

You can call the Latitude method of the Map class to get the double value for latitude specified in [degrees,minutes,seconds,N/S] format.

See Also

Decoration Members
Decoration Class


MindFusion.Mapping.Decoration.Longitude Property

Decoration.Longitude Property
[image]

Gets or sets the longitude associated with this decoration.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Longitude { get; set; }

Visual Basic [image] Copy Code

Public Property Longitude As Double

Property Value

A double value specifying the longitude of the decoration's location.

Remarks

You can call the Longitude method of the Map class to get the double value for longitudes specified in [degrees,minutes,seconds,W/E] format.

See Also

Decoration Members
Decoration Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Class

DecorationLayerBase(TColor, TPalette) Class
[image]

Represents a layer containing decorative elements.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class DecorationLayerBase<TColor, TPalette> : Layer<TColor, TPalette> where TPalette : IPalette<TColor>

Visual Basic [image] Copy Code

Public Class DecorationLayerBase(Of TColor, TPalette As IPalette(Of TColor))
Inherits Layer(Of TColor, TPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(TColor, TPalette)
MindFusion.Mapping.DecorationLayerBase(TColor, TPalette)
MindFusion.Mapping.Wpf.DecorationLayer

See Also

DecorationLayerBase(TColor, TPalette) Members


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Members

DecorationLayerBase(TColor, TPalette) Members
Constructors Properties Methods
[image]

Represents a layer containing decorative elements.

The following tables list the members exposed by the DecorationLayerBase(TColor, TPalette) type.

Public Constructors

Name | Description
DecorationLayerBase | Initializes a new instance of the DecorationLayerBase class.

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override.
Decorations | Gets the list of decorations displayed in this layer.
Selection | Gets the list of selected decorations.

Public Methods

Name | Description
Draw | Layer.Draw override.
DrawHighlights | Layer.DrawHighlights override.
DrawLabels | Layer.DrawLabels override.
Highlight | Layer.Highlight override.
HitTest | Layer.HitTest override.
Select | Layer.Select override.
Toggle | Layer.Toggle override.

See Also

DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Constructor

DecorationLayerBase(TColor, TPalette) Constructor
[image]

Initializes a new instance of the DecorationLayerBase class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public DecorationLayerBase<TColor, TPalette> (
Rect boundingBox
)

Visual Basic [image] Copy Code

Public New (Of TColor, TPalette) ( _
boundingBox As Rect _
)

Parameters

boundingBox

A Rect specifying the map area displayed on this layer.

See Also

DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Methods

DecorationLayerBase(TColor, TPalette) Methods
[image]

Public Methods

Name | Description
Draw | Layer.Draw override.
DrawHighlights | Layer.DrawHighlights override.
DrawLabels | Layer.DrawLabels override.
Highlight | Layer.Highlight override.
HitTest | Layer.HitTest override.
Select | Layer.Select override.
Toggle | Layer.Toggle override.

See Also

DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Draw Method

DecorationLayerBase(TColor, TPalette).Draw Method
[image]

Layer.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void Draw (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).DrawHighlights Method

DecorationLayerBase(TColor, TPalette).DrawHighlights Method
[image]

Layer.DrawHighlights override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawHighlights (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHighlights( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).DrawLabels Method

DecorationLayerBase(TColor, TPalette).DrawLabels Method
[image]

Layer.DrawLabels override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawLabels (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLabels( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Highlight Method

DecorationLayerBase(TColor, TPalette).Highlight Method
[image]

Layer.Highlight override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Highlight (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Highlight( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be highlighted.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).HitTest Method

DecorationLayerBase(TColor, TPalette).HitTest Method
[image]

Layer.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override MapElement HitTest (
Point mousePosition,
ITransform transform
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
mousePosition As Point, _
transform As ITransform _
) As MapElement

Parameters

mousePosition

A Point instance specifying location.

transform

The transform currently used to draw the map.

Return Value

The MapElement that contains the specified point.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Select Method

DecorationLayerBase(TColor, TPalette).Select Method
[image]

Layer.Select override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Select (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Toggle Method

DecorationLayerBase(TColor, TPalette).Toggle Method
[image]

Layer.Toggle override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Toggle (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Toggle( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement whose selection state should be toggled.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette) Properties

DecorationLayerBase(TColor, TPalette) Properties
[image]

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override.
Decorations | Gets the list of decorations displayed in this layer.
Selection | Gets the list of selected decorations.

See Also

DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).BoundingBox Property

DecorationLayerBase(TColor, TPalette).BoundingBox Property
[image]

Layer.BoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property BoundingBox As Rect

Property Value

A Rect instance specifying the layer's bounding rectangle.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Decorations Property

DecorationLayerBase(TColor, TPalette).Decorations Property
[image]

Gets the list of decorations displayed in this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public ObservableCollection<Decoration> Decorations { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Decorations As ObservableCollection(Of Decoration)

Property Value

A list of Decoration objects.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.DecorationLayerBase(TColor, TPalette).Selection Property

DecorationLayerBase(TColor, TPalette).Selection Property
[image]

Gets the list of selected decorations.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Decoration> Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As List(Of Decoration)

Property Value

A List of Decoration objects.

See Also

DecorationLayerBase(TColor, TPalette) Members
DecorationLayerBase(TColor, TPalette) Class


MindFusion.Mapping.ICanvas Interface

ICanvas Interface
[image]

Represents a drawing canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface ICanvas

Visual Basic [image] Copy Code

Public Interface ICanvas

See Also

ICanvas Members


MindFusion.Mapping.ICanvas Members

ICanvas Members
Methods
[image]

Represents a drawing canvas.

The following tables list the members exposed by the ICanvas type.

Public Methods

Name | Description
ClipExclude | Overloaded. Excludes an area from the current clip region.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
ResetClip | Resets the current clip region.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetTextAlignment | Sets the current text alignment.

See Also

ICanvas Interface


MindFusion.Mapping.ICanvas Methods

ICanvas Methods
[image]

Public Methods

Name | Description
ClipExclude | Overloaded. Excludes an area from the current clip region.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
ResetClip | Resets the current clip region.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetTextAlignment | Sets the current text alignment.

See Also

ICanvas Interface


MindFusion.Mapping.ICanvas.ClipExclude Method

ICanvas.ClipExclude Method
[image]

Excludes an area from the current clip region.

Overload List

Name | Description
ICanvas.ClipExclude (IList(Point)) | Excludes the specified area from the current clip region.
ICanvas.ClipExclude (List(IList(Point))) | Excludes the specified areas from the current clip region.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.ClipExclude Method (IList(Point))

ICanvas.ClipExclude Method (IList(Point))
See Also
[image]

Excludes the specified area from the current clip region.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void ClipExclude (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub ClipExclude( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.ClipExclude Method (List(IList(Point)))

ICanvas.ClipExclude Method (List(IList(Point)))
See Also
[image]

Excludes the specified areas from the current clip region.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void ClipExclude (
List<IList<Point>> points
)

Visual Basic [image] Copy Code

Sub ClipExclude( _
points As List(Of IList(Of Point)) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.DrawPoint Method

ICanvas.DrawPoint Method
[image]

Draws a point marker at the specified location.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void DrawPoint (
Point point
)

Visual Basic [image] Copy Code

Sub DrawPoint( _
point As Point _
)

Parameters

point

The Point to draw.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.DrawPolyline Method

ICanvas.DrawPolyline Method
[image]

Draws a polyline.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void DrawPolyline (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub DrawPolyline( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polyline segments.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.DrawString Method

ICanvas.DrawString Method
[image]

Draws a string with the specified attributes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void DrawString (
string s,
Point point,
Rect bounds,
string fontName,
double fontSize
)

Visual Basic [image] Copy Code

Sub DrawString( _
s As String, _
point As Point, _
bounds As Rect, _
fontName As String, _
fontSize As Double _
)

Parameters

s

The string that should be drawn.

point

A Point specifying the string location.

bounds

A Rect specifying the string bounding box.

fontName

The name of the font used to render the string.

fontSize

The size of the font used to render the string.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.FillPolygon Method

ICanvas.FillPolygon Method
[image]

Fills a polygon.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void FillPolygon (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polygon borders.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.GetPixelSize Method

ICanvas.GetPixelSize Method
[image]

Gets the size of a pixel at the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

double GetPixelSize ()

Visual Basic [image] Copy Code

Function GetPixelSize () As Double

Return Value

A double value specifying the pixel size.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.ResetClip Method

ICanvas.ResetClip Method
[image]

Resets the current clip region.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void ResetClip ()

Visual Basic [image] Copy Code

Sub ResetClip ()

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.SetFillColor Method

ICanvas.SetFillColor Method
[image]

Sets the current fill color to the specified color from the palette.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetFillColor (
int color
)

Visual Basic [image] Copy Code

Sub SetFillColor( _
color As Integer _
)

Parameters

color

The index of the color in the associated palette.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.SetHighlightColor Method

ICanvas.SetHighlightColor Method
[image]

Sets the current fill and line colors to the highlight color associated with this canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetHighlightColor ()

Visual Basic [image] Copy Code

Sub SetHighlightColor ()

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.SetLineColor Method

ICanvas.SetLineColor Method
[image]

Sets the current line color to the line color associated with this canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetLineColor ()

Visual Basic [image] Copy Code

Sub SetLineColor ()

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvas.SetTextAlignment Method

ICanvas.SetTextAlignment Method
[image]

Sets the current text alignment.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

void SetTextAlignment (
TextAlignment horzAlignment,
TextAlignment vertAlignment
)

Visual Basic [image] Copy Code

Sub SetTextAlignment( _
horzAlignment As TextAlignment, _
vertAlignment As TextAlignment _
)

Parameters

horzAlignment

A TextAlignment member specifying the horizontal alignment.

vertAlignment

A TextAlignment member specifying the vertical alignment.

See Also

ICanvas Members
ICanvas Interface


MindFusion.Mapping.ICanvasWithPalette(TColor) Interface

ICanvasWithPalette(TColor) Interface
[image]

Represents a drawing canvas with an associated palette of colors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface ICanvasWithPalette<TColor> : ICanvas

Visual Basic [image] Copy Code

Public Interface ICanvasWithPalette(Of TColor)
Implements ICanvas

See Also

ICanvasWithPalette(TColor) Members


MindFusion.Mapping.ICanvasWithPalette(TColor) Members

ICanvasWithPalette(TColor) Members
Properties
[image]

Represents a drawing canvas with an associated palette of colors.

The following tables list the members exposed by the ICanvasWithPalette(TColor) type.

Public Properties

Name | Description
Palette | Gets or sets the color palette associated with this drawing canvas.

See Also

ICanvasWithPalette(TColor) Interface


MindFusion.Mapping.ICanvasWithPalette(TColor) Properties

ICanvasWithPalette(TColor) Properties
[image]

Public Properties

Name | Description
Palette | Gets or sets the color palette associated with this drawing canvas.

See Also

ICanvasWithPalette(TColor) Interface


MindFusion.Mapping.ICanvasWithPalette(TColor).Palette Property

ICanvasWithPalette(TColor).Palette Property
[image]

Gets or sets the color palette associated with this drawing canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

IPalette<TColor> Palette { get; set; }

Visual Basic [image] Copy Code

Property Palette As IPalette(Of TColor)

Property Value

An object implementing the IPalette interface.

See Also

ICanvasWithPalette(TColor) Members
ICanvasWithPalette(TColor) Interface


MindFusion.Mapping.IPalette(TColor) Interface

IPalette(TColor) Interface
[image]

Represents a palette of colors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface IPalette<TColor>

Visual Basic [image] Copy Code

Public Interface IPalette(Of TColor)

See Also

IPalette(TColor) Members


MindFusion.Mapping.IPalette(TColor) Members

IPalette(TColor) Members
Properties
[image]

Represents a palette of colors.

The following tables list the members exposed by the IPalette(TColor) type.

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

IPalette(TColor) Interface


MindFusion.Mapping.IPalette(TColor) Properties

IPalette(TColor) Properties
[image]

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

IPalette(TColor) Interface


MindFusion.Mapping.IPalette(TColor).FillColors Property

IPalette(TColor).FillColors Property
[image]

Gets or sets an array of fill colors.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

TColor[] FillColors { get; set; }

Visual Basic [image] Copy Code

Property FillColors As TColor()

Property Value

See Also

IPalette(TColor) Members
IPalette(TColor) Interface


MindFusion.Mapping.IPalette(TColor).HighlightColor Property

IPalette(TColor).HighlightColor Property
[image]

Gets or sets the highlight color.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

TColor HighlightColor { get; set; }

Visual Basic [image] Copy Code

Property HighlightColor As TColor

Property Value

See Also

IPalette(TColor) Members
IPalette(TColor) Interface


MindFusion.Mapping.IPalette(TColor).LineColor Property

IPalette(TColor).LineColor Property
[image]

Gets or sets the line color.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

TColor LineColor { get; set; }

Visual Basic [image] Copy Code

Property LineColor As TColor

Property Value

See Also

IPalette(TColor) Members
IPalette(TColor) Interface


MindFusion.Mapping.ITransform Interface

ITransform Interface
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public interface ITransform

Visual Basic [image] Copy Code

Public Interface ITransform

See Also

ITransform Members


MindFusion.Mapping.ITransform Members

ITransform Members
Methods
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

The following tables list the members exposed by the ITransform type.

Public Methods

Name | Description
DeviceToWorld | Convert a point from screen to world coordinates.
WorldToDevice | Convert a point from world to screen coordinates.

See Also

ITransform Interface


MindFusion.Mapping.ITransform Methods

ITransform Methods
[image]

Public Methods

Name | Description
DeviceToWorld | Convert a point from screen to world coordinates.
WorldToDevice | Convert a point from world to screen coordinates.

See Also

ITransform Interface


MindFusion.Mapping.ITransform.DeviceToWorld Method

ITransform.DeviceToWorld Method
[image]

Convert a point from screen to world coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

Point DeviceToWorld (
Point point
)

Visual Basic [image] Copy Code

Function DeviceToWorld( _
point As Point _
) As Point

Parameters

point

A Point specifying screen coordinates.

Return Value

A Point containing the corresponding world coordinates.

See Also

ITransform Members
ITransform Interface


MindFusion.Mapping.ITransform.WorldToDevice Method

ITransform.WorldToDevice Method
[image]

Convert a point from world to screen coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

Point WorldToDevice (
Point point
)

Visual Basic [image] Copy Code

Function WorldToDevice( _
point As Point _
) As Point

Parameters

point

A Point specifying world coordinates.

Return Value

A Point containing the corresponding screen coordinates.

See Also

ITransform Members
ITransform Interface


MindFusion.Mapping.Layer(TColor, TPalette) Class

Layer(TColor, TPalette) Class
[image]

Represents a map layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class Layer<TColor, TPalette> : INotifyPropertyChanged where TPalette : IPalette<TColor>

Visual Basic [image] Copy Code

Public MustInherit Class Layer(Of TColor, TPalette As IPalette(Of TColor))
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(TColor, TPalette)
MindFusion.Mapping.DecorationLayerBase(TColor, TPalette)
MindFusion.Mapping.MapLayerBase(TColor, TPalette)

See Also

Layer(TColor, TPalette) Members


MindFusion.Mapping.Layer(TColor, TPalette) Members

Layer(TColor, TPalette) Members
Constructors Properties Methods Events
[image]

Represents a map layer.

The following tables list the members exposed by the Layer(TColor, TPalette) type.

Public Constructors

Name | Description
Layer | Initializes a new instance of the Layer class.

Public Properties

Name | Description
BoundingBox | Returns the bounding box of elements in this layer.
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them.
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them.
FillColors | Gets or sets the colors used to fill map elements on this layer.
HighlightColor | Gets or sets the color used to highlight elements on this layer.
LineColor | Gets or sets the line color used to draw elements on this layer.
Palette | Gets or sets the color palette associated with this layer.
Visible | Gets or sets whether this layer should be visible in the map view.

Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level.
Draw | Overloaded. Draws the elements of this layer on a canvas.
DrawHighlights | Draws the layer's highlighted elements on the specified canvas.
DrawLabels | Draws the labels of elements of this layer on the specified canvas.
Highlight | Highlights the specified map element.
HitTest | Returns the map element located at the specified point.
Select | Selects the specified map element.
Toggle | Toggles the selection state the specified map element.

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event.
OnAsyncLoadComplete | Raises the AsyncLoadComplete event.
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed.
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed.
PropertyChanged | Raised when the value of a property of the Layer class is changed.

See Also

Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette) Constructor

Layer(TColor, TPalette) Constructor
[image]

Initializes a new instance of the Layer class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Layer<TColor, TPalette> ()

Visual Basic [image] Copy Code

Public Sub New(Of TColor, TPalette) ()

See Also

Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette) Methods

Layer(TColor, TPalette) Methods
[image]

Public Methods

Name | Description
ClearCache | Clears any cached values associated with the layer for the current zoom level.
Draw | Overloaded. Draws the elements of this layer on a canvas.
DrawHighlights | Draws the layer's highlighted elements on the specified canvas.
DrawLabels | Draws the labels of elements of this layer on the specified canvas.
Highlight | Highlights the specified map element.
HitTest | Returns the map element located at the specified point.
Select | Selects the specified map element.
Toggle | Toggles the selection state the specified map element.

Protected Methods

Name | Description
OnAsyncDatabaseLoadComplete | Raises the AsyncDatabaseLoadComplete event.
OnAsyncLoadComplete | Raises the AsyncLoadComplete event.
OnPropertyChanged | Raises the PropertyChanged event.

See Also

Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).ClearCache Method

Layer(TColor, TPalette).ClearCache Method
[image]

Clears any cached values associated with the layer for the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public virtual void ClearCache ()

Visual Basic [image] Copy Code

Public Overridable Sub ClearCache ()

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Draw Method

Layer(TColor, TPalette).Draw Method
[image]

Draws the elements of this layer on a canvas.

Overload List

Name | Description
Layer(TColor, TPalette).Draw (ICanvasWithPalette(TColor), Rect) | Draws the elements of this layer on the specified canvas.
Layer(TColor, TPalette).Draw (MapElement, ICanvas) | Draws the specified map element on the specified canvas.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Draw Method (ICanvasWithPalette(TColor), Rect)

Layer(TColor, TPalette).Draw Method (ICanvasWithPalette(TColor), Rect)
See Also
[image]

Draws the elements of this layer on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void Draw (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Sub Draw( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

Draw Method Overload List
Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Draw Method (MapElement, ICanvas)

Layer(TColor, TPalette).Draw Method (MapElement, ICanvas)
See Also
[image]

Draws the specified map element on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void Draw (
MapElement element,
ICanvas canvas
)

Visual Basic [image] Copy Code

Public Sub Draw( _
element As MapElement, _
canvas As ICanvas _
)

Parameters

element

A MapElement instance that should be rendered on the canvas.

canvas

An ICanvasWithPalette specifying the drawing canvas.

See Also

Draw Method Overload List
Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).DrawHighlights Method

Layer(TColor, TPalette).DrawHighlights Method
[image]

Draws the layer's highlighted elements on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void DrawHighlights (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawHighlights( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).DrawLabels Method

Layer(TColor, TPalette).DrawLabels Method
[image]

Draws the labels of elements of this layer on the specified canvas.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void DrawLabels (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawLabels( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Highlight Method

Layer(TColor, TPalette).Highlight Method
[image]

Highlights the specified map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Highlight (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public MustOverride Function Highlight( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be highlighted.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).HitTest Method

Layer(TColor, TPalette).HitTest Method
[image]

Returns the map element located at the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract MapElement HitTest (
Point mousePosition,
ITransform transform
)

Visual Basic [image] Copy Code

Public MustOverride Function HitTest( _
mousePosition As Point, _
transform As ITransform _
) As MapElement

Parameters

mousePosition

A Point instance specifying location.

transform

The transform currently used to draw the map.

Return Value

The MapElement that contains the specified point.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).OnAsyncDatabaseLoadComplete Method

Layer(TColor, TPalette).OnAsyncDatabaseLoadComplete Method
[image]

Raises the AsyncDatabaseLoadComplete event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnAsyncDatabaseLoadComplete ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnAsyncDatabaseLoadComplete ()

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).OnAsyncLoadComplete Method

Layer(TColor, TPalette).OnAsyncLoadComplete Method
[image]

Raises the AsyncLoadComplete event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnAsyncLoadComplete ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnAsyncLoadComplete ()

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).OnPropertyChanged Method

Layer(TColor, TPalette).OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
propertyName As String _
)

Parameters

propertyName

A string specifying the name of the property whose value has changed.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Select Method

Layer(TColor, TPalette).Select Method
[image]

Selects the specified map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Select (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public MustOverride Function Select( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Toggle Method

Layer(TColor, TPalette).Toggle Method
[image]

Toggles the selection state the specified map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract bool Toggle (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public MustOverride Function Toggle( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement whose selection state should be toggled.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette) Properties

Layer(TColor, TPalette) Properties
[image]

Public Properties

Name | Description
BoundingBox | Returns the bounding box of elements in this layer.
EnableHighlight | Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them.
EnableSelection | Gets or sets whether map elements should be selected when the user clicks them.
FillColors | Gets or sets the colors used to fill map elements on this layer.
HighlightColor | Gets or sets the color used to highlight elements on this layer.
LineColor | Gets or sets the line color used to draw elements on this layer.
Palette | Gets or sets the color palette associated with this layer.
Visible | Gets or sets whether this layer should be visible in the map view.

See Also

Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).BoundingBox Property

Layer(TColor, TPalette).BoundingBox Property
[image]

Returns the bounding box of elements in this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property BoundingBox As Rect

Property Value

A Rect instance specifying the layer's bounding box.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).EnableHighlight Property

Layer(TColor, TPalette).EnableHighlight Property
[image]

Gets or sets whether map elements should be automatically highlighted when the mouse hovers over them.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool EnableHighlight { get; set; }

Visual Basic [image] Copy Code

Public Property EnableHighlight As Boolean

Property Value

true to highlight elements, otherwise false. The default value is true.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).EnableSelection Property

Layer(TColor, TPalette).EnableSelection Property
[image]

Gets or sets whether map elements should be selected when the user clicks them.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool EnableSelection { get; set; }

Visual Basic [image] Copy Code

Public Property EnableSelection As Boolean

Property Value

true to select elements, otherwise false. The default value is true.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).FillColors Property

Layer(TColor, TPalette).FillColors Property
[image]

Gets or sets the colors used to fill map elements on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TColor[] FillColors { get; set; }

Visual Basic [image] Copy Code

Public Property FillColors As TColor()

Property Value

An array of color objects used as a palette.

Remarks

The Color property of the Shape class is an index within this array.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).HighlightColor Property

Layer(TColor, TPalette).HighlightColor Property
[image]

Gets or sets the color used to highlight elements on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TColor HighlightColor { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightColor As TColor

Property Value

A color used to draw highlighted elements.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).LineColor Property

Layer(TColor, TPalette).LineColor Property
[image]

Gets or sets the line color used to draw elements on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TColor LineColor { get; set; }

Visual Basic [image] Copy Code

Public Property LineColor As TColor

Property Value

A color used to draw border lines.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Palette Property

Layer(TColor, TPalette).Palette Property
[image]

Gets or sets the color palette associated with this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public TPalette Palette { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Palette As TPalette

Property Value

A TPalette instance.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).Visible Property

Layer(TColor, TPalette).Visible Property
[image]

Gets or sets whether this layer should be visible in the map view.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true to show this layer, otherwise false.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette) Events

Layer(TColor, TPalette) Events
[image]

Public Events

Name | Description
AsyncDatabaseLoadComplete | Raised when an asynchronous database-read operation is completed.
AsyncLoadComplete | Raised when an asynchronous shapefile-read operation is completed.
PropertyChanged | Raised when the value of a property of the Layer class is changed.

See Also

Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).AsyncDatabaseLoadComplete Event

Layer(TColor, TPalette).AsyncDatabaseLoadComplete Event
[image]

Raised when an asynchronous database-read operation is completed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event EventHandler AsyncDatabaseLoadComplete

Visual Basic [image] Copy Code

Public Event AsyncDatabaseLoadComplete As EventHandler

Event Data

AsyncDatabaseLoadComplete event handlers receive an argument of type EventArgs.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).AsyncLoadComplete Event

Layer(TColor, TPalette).AsyncLoadComplete Event
[image]

Raised when an asynchronous shapefile-read operation is completed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event EventHandler AsyncLoadComplete

Visual Basic [image] Copy Code

Public Event AsyncLoadComplete As EventHandler

Event Data

AsyncLoadComplete event handlers receive an argument of type EventArgs.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Layer(TColor, TPalette).PropertyChanged Event

Layer(TColor, TPalette).PropertyChanged Event
[image]

Raised when the value of a property of the Layer class is changed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Layer(TColor, TPalette) Members
Layer(TColor, TPalette) Class


MindFusion.Mapping.Map Class

Map Class
[image]

Represents a geographic map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Map

Visual Basic [image] Copy Code

Public Class Map

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Map

See Also

Map Members


MindFusion.Mapping.Map Members

Map Members
Constructors Properties Methods Events
[image]

Represents a geographic map.

The following tables list the members exposed by the Map type.

Public Constructors

Name | Description
Map | Initializes a new instance of the Map class.

Public Properties

Name | Description
BoundingBox | Returns the bounding box of all map shapes.
Database | Gets or sets the DBF database associated with the map file.
Shapes | Returns the list of map shapes.
ShapeType | Returns the shape type associated with this map.

Public Methods

Name | Description
AssignColors | Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.
ClearCache | Clears any cached values associated with the map for the current zoom level.
FromFile | Overloaded. Creates and loads a map from a file.
HitTest | Overloaded. Returns the Shape that contains a specified point.
Latitude | Overloaded. Converts latitude to its representation as a double value.
LoadFromFile | Overloaded. Loads the map data from an ESRI file.
LoadFromStream | Overloaded. Loads the map data from a stream.
Longitude | Overloaded. Converts longitude to its representation as a double value.
SaveToFile | Saves the map to the specified file.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
PropertyChanged | Raised when the value of a property of the Map class is changed.

See Also

Map Class


MindFusion.Mapping.Map Constructor

Map Constructor
[image]

Initializes a new instance of the Map class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Map ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Map Class


MindFusion.Mapping.Map Methods

Map Methods
[image]

Public Methods

Name | Description
AssignColors | Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.
ClearCache | Clears any cached values associated with the map for the current zoom level.
FromFile | Overloaded. Creates and loads a map from a file.
HitTest | Overloaded. Returns the Shape that contains a specified point.
Latitude | Overloaded. Converts latitude to its representation as a double value.
LoadFromFile | Overloaded. Loads the map data from an ESRI file.
LoadFromStream | Overloaded. Loads the map data from a stream.
Longitude | Overloaded. Converts longitude to its representation as a double value.
SaveToFile | Saves the map to the specified file.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

Map Class


MindFusion.Mapping.Map.AssignColors Method

Map.AssignColors Method
[image]

Assigns colors to polygon shapes in the map in such a way that no two adjacent polygons are painted in the same color.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void AssignColors ()

Visual Basic [image] Copy Code

Public Sub AssignColors ()

See Also

Map Members
Map Class


MindFusion.Mapping.Map.ClearCache Method

Map.ClearCache Method
[image]

Clears any cached values associated with the map for the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void ClearCache ()

Visual Basic [image] Copy Code

Public Sub ClearCache ()

See Also

Map Members
Map Class


MindFusion.Mapping.Map.FromFile Method

Map.FromFile Method
[image]

Creates and loads a map from a file.

Overload List

Name | Description
Map.FromFile (String) | Creates and loads a map from the specified file.
Map.FromFile (String, Boolean, String) | Creates and loads a map from the specified file.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.FromFile Method (String)

Map.FromFile Method (String)
See Also
[image]

Creates and loads a map from the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Map FromFile (
string fileName
)

Visual Basic [image] Copy Code

Public Shared Function FromFile( _
fileName As String _
) As Map

Parameters

fileName

Specifies the file name of an ESRI map file.

Return Value

The Map loaded from the specified file.

See Also

FromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.FromFile Method (String, Boolean, String)

Map.FromFile Method (String, Boolean, String)
See Also
[image]

Creates and loads a map from the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Map FromFile (
string fileName,
bool loadDatabase,
string labelField
)

Visual Basic [image] Copy Code

Public Shared Function FromFile( _
fileName As String, _
loadDatabase As Boolean, _
labelField As String _
) As Map

Parameters

fileName

Specifies the file name of an ESRI map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

labelField

A string specifying the name of the database column whose fields should be used as map element labels.

Return Value

The Map loaded from the specified file.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

FromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.HitTest Method

Map.HitTest Method
[image]

Returns the Shape that contains a specified point.

Overload List

Name | Description
Map.HitTest (Point, ITransform) | Returns the Shape that contains the specified point.
Map.HitTest (Point) | Returns the Shape that contains the specified point.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.HitTest Method (Point, ITransform)

Map.HitTest Method (Point, ITransform)
See Also
[image]

Returns the Shape that contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Shape HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Public Function HitTest( _
point As Point, _
transform As ITransform _
) As Shape

Parameters

point

A Point instance specifying location on the map.

transform

An ITransform specifying the transform used to render this map.

Return Value

The Shape that contains the specified point.

See Also

HitTest Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.HitTest Method (Point)

Map.HitTest Method (Point)
See Also
[image]

Returns the Shape that contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Shape HitTest (
Point point
)

Visual Basic [image] Copy Code

Public Function HitTest( _
point As Point _
) As Shape

Parameters

point

A Point instance specifying location on the map.

Return Value

The Shape that contains the specified point.

See Also

HitTest Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.Latitude Method

Map.Latitude Method
[image]

Converts latitude to its representation as a double value.

Overload List

Name | Description
Map.Latitude (Double, Double, Double, Char) | Converts latitude specified in arc degrees, minutes, seconds, 'N'/'S' to its representation as a double value.
Map.Latitude (Double, Double, Char) | Converts latitude specified in arc degree, minutes, 'N'/'S' to its representation as a double value.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.Latitude Method (Double, Double, Double, Char)

Map.Latitude Method (Double, Double, Double, Char)
See Also
[image]

Converts latitude specified in arc degrees, minutes, seconds, 'N'/'S' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Latitude (
double degrees,
double minutes,
double seconds,
char ns
)

Visual Basic [image] Copy Code

Public Shared Function Latitude( _
degrees As Double, _
minutes As Double, _
seconds As Double, _
ns As Char _
) As Double

Parameters

degrees

Specifies the latitude arc degrees.

minutes

Specifies the latitude arc minutes.

seconds

Specifies the latitude arc seconds.

ns

A char value specifying 'N' for north or 'S' for south.

Return Value

A double value representing the specified latitude.

See Also

Latitude Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.Latitude Method (Double, Double, Char)

Map.Latitude Method (Double, Double, Char)
See Also
[image]

Converts latitude specified in arc degree, minutes, 'N'/'S' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Latitude (
double degrees,
double minutes,
char ns
)

Visual Basic [image] Copy Code

Public Shared Function Latitude( _
degrees As Double, _
minutes As Double, _
ns As Char _
) As Double

Parameters

degrees

Specifies the latitude arc degrees.

minutes

Specifies the latitude arc minutes.

ns

A char value specifying 'N' for north or 'S' for south.

Return Value

A double value representing the specified latitude.

See Also

Latitude Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromFile Method

Map.LoadFromFile Method
[image]

Loads the map data from an ESRI file.

Overload List

Name | Description
Map.LoadFromFile (String, Boolean) | Loads the map data from the specified ESRI map file.
Map.LoadFromFile (String, Boolean, Int32) | Loads the map data from the specified ESRI map file.
Map.LoadFromFile (String) | Loads the map data from the specified ESRI map file.
Map.LoadFromFile (String, Boolean, String) | Loads the map data from the specified ESRI map file.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.LoadFromFile Method (String, Boolean)

Map.LoadFromFile Method (String, Boolean)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName,
bool loadDatabase
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String, _
loadDatabase As Boolean _
)

Parameters

fileName

The file name of the map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromFile Method (String, Boolean, Int32)

Map.LoadFromFile Method (String, Boolean, Int32)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName,
bool loadDatabase,
int labelField
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String, _
loadDatabase As Boolean, _
labelField As Integer _
)

Parameters

fileName

The file name of the map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

labelField

An integer specifying the index of the database column whose fields should be used as map element labels.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromFile Method (String)

Map.LoadFromFile Method (String)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String _
)

Parameters

fileName

The file name of the map file.

See Also

LoadFromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromFile Method (String, Boolean, String)

Map.LoadFromFile Method (String, Boolean, String)
See Also
[image]

Loads the map data from the specified ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromFile (
string fileName,
bool loadDatabase,
string labelField
)

Visual Basic [image] Copy Code

Public Sub LoadFromFile( _
fileName As String, _
loadDatabase As Boolean, _
labelField As String _
)

Parameters

fileName

The file name of the map file.

loadDatabase

true to load the database associated with the specified map file, otherwise false.

labelField

A string specifying the name of the database column whose fields should be used as map element labels.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromFile Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromStream Method

Map.LoadFromStream Method
[image]

Loads the map data from a stream.

Overload List

Name | Description
Map.LoadFromStream (Stream, Stream, String) | Loads the map data from the specified stream.
Map.LoadFromStream (Stream) | Loads the map data from the specified stream.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.LoadFromStream Method (Stream, Stream, String)

Map.LoadFromStream Method (Stream, Stream, String)
See Also
[image]

Loads the map data from the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromStream (
Stream mapStream,
Stream dbfStream,
string labelField
)

Visual Basic [image] Copy Code

Public Sub LoadFromStream( _
mapStream As Stream, _
dbfStream As Stream, _
labelField As String _
)

Parameters

mapStream

A System.IO.Stream instance representing shapefile data.

dbfStream

A System.IO.Stream instance representing the map database.

labelField

Specifies the name of the database column containing labels of map elements.

Remarks

If the database is loaded, it is represented by an instance of the Database class exposed via the Database property. Additionally, each Shape in the map has its DatabaseRow property set to an object representing the corresponding data record.

See Also

LoadFromStream Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.LoadFromStream Method (Stream)

Map.LoadFromStream Method (Stream)
See Also
[image]

Loads the map data from the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void LoadFromStream (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromStream( _
stream As Stream _
)

Parameters

stream

A System.IO.Stream instance representing shapefile data.

See Also

LoadFromStream Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.Longitude Method

Map.Longitude Method
[image]

Converts longitude to its representation as a double value.

Overload List

Name | Description
Map.Longitude (Double, Double, Char) | Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.
Map.Longitude (Double, Double, Double, Char) | Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.Longitude Method (Double, Double, Char)

Map.Longitude Method (Double, Double, Char)
See Also
[image]

Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Longitude (
double degrees,
double minutes,
char ew
)

Visual Basic [image] Copy Code

Public Shared Function Longitude( _
degrees As Double, _
minutes As Double, _
ew As Char _
) As Double

Parameters

degrees

Specifies the longitude arc degrees.

minutes

Specifies the longitude arc minutes.

ew

A char value specifying 'E' for east or 'W' for west.

Return Value

A double value representing the specified longitude.

See Also

Longitude Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.Longitude Method (Double, Double, Double, Char)

Map.Longitude Method (Double, Double, Double, Char)
See Also
[image]

Converts longitude specified in arc degrees, minutes, 'E'/'W' to its representation as a double value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double Longitude (
double degrees,
double minutes,
double seconds,
char ew
)

Visual Basic [image] Copy Code

Public Shared Function Longitude( _
degrees As Double, _
minutes As Double, _
seconds As Double, _
ew As Char _
) As Double

Parameters

degrees

Specifies the longitude arc degrees.

minutes

Specifies the longitude arc minutes.

seconds

Specifies the longitude arc seconds.

ew

A char value specifying 'E' for east or 'W' for west.

Return Value

A double value representing the specified longitude.

See Also

Longitude Method Overload List
Map Members
Map Class


MindFusion.Mapping.Map.OnPropertyChanged Method

Map.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
propertyName As String _
)

Parameters

propertyName

A string specifying the name of the property whose value has changed.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.SaveToFile Method

Map.SaveToFile Method
[image]

Saves the map to the specified file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveToFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub SaveToFile( _
fileName As String _
)

Parameters

fileName

A string specifying the file name.

See Also

Map Members
Map Class


MindFusion.Mapping.Map Properties

Map Properties
[image]

Public Properties

Name | Description
BoundingBox | Returns the bounding box of all map shapes.
Database | Gets or sets the DBF database associated with the map file.
Shapes | Returns the list of map shapes.
ShapeType | Returns the shape type associated with this map.

See Also

Map Class


MindFusion.Mapping.Map.BoundingBox Property

Map.BoundingBox Property
[image]

Returns the bounding box of all map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect BoundingBox { get; set; }

Visual Basic [image] Copy Code

Public Property BoundingBox As Rect

Property Value

A Rect object.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.Database Property

Map.Database Property
[image]

Gets or sets the DBF database associated with the map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Database Database { get; set; }

Visual Basic [image] Copy Code

Public Property Database As Database

Property Value

A Database object.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.Shapes Property

Map.Shapes Property
[image]

Returns the list of map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Shape> Shapes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shapes As List(Of Shape)

Property Value

A list of Shape objects.

See Also

Map Members
Map Class


MindFusion.Mapping.Map.ShapeType Property

Map.ShapeType Property
[image]

Returns the shape type associated with this map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public ShapeType ShapeType { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeType As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

Map Members
Map Class


MindFusion.Mapping.Map Events

Map Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when the value of a property of the Map class is changed.

See Also

Map Class


MindFusion.Mapping.Map.PropertyChanged Event

Map.PropertyChanged Event
[image]

Raised when the value of a property of the Map class is changed.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Map Members
Map Class


MindFusion.Mapping.MapElement Class

MapElement Class
[image]

Represents visual elements of a map that can be drawn and hit-tested.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class MapElement

Visual Basic [image] Copy Code

Public MustInherit Class MapElement

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.Shape

See Also

MapElement Members


MindFusion.Mapping.MapElement Members

MapElement Members
Constructors Properties Methods
[image]

Represents visual elements of a map that can be drawn and hit-tested.

The following tables list the members exposed by the MapElement type.

Public Constructors

Name | Description
MapElement | Initializes a new instance of the MapElement class.

Public Properties

Name | Description
FontName | Gets or sets the name of the font used to render the label of this element.
FontSize | Gets or sets the size of the font used to render the label of this element.
Label | Gets or sets the label of this map element.

Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface.
DrawLabel | Draws the label of this map element.
Highlight | Draws a highlight of this map element.
HitTest | Tests whether this map element contains the specified point.

See Also

MapElement Class


MindFusion.Mapping.MapElement Constructor

MapElement Constructor
[image]

Initializes a new instance of the MapElement class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public MapElement ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapElement Class


MindFusion.Mapping.MapElement Methods

MapElement Methods
[image]

Protected Methods

Name | Description
Draw | Draws this map element on the specified drawing surface.
DrawLabel | Draws the label of this map element.
Highlight | Draws a highlight of this map element.
HitTest | Tests whether this map element contains the specified point.

See Also

MapElement Class


MindFusion.Mapping.MapElement.Draw Method

MapElement.Draw Method
[image]

Draws this map element on the specified drawing surface.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected abstract void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected MustOverride Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapElement.DrawLabel Method

MapElement.DrawLabel Method
[image]

Draws the label of this map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapElement.Highlight Method

MapElement.Highlight Method
[image]

Draws a highlight of this map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overridable Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapElement.HitTest Method

MapElement.HitTest Method
[image]

Tests whether this map element contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected abstract bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected MustOverride Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapElement Properties

MapElement Properties
[image]

Public Properties

Name | Description
FontName | Gets or sets the name of the font used to render the label of this element.
FontSize | Gets or sets the size of the font used to render the label of this element.
Label | Gets or sets the label of this map element.

See Also

MapElement Class


MindFusion.Mapping.MapElement.FontName Property

MapElement.FontName Property
[image]

Gets or sets the name of the font used to render the label of this element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string FontName { get; set; }

Visual Basic [image] Copy Code

Public Property FontName As String

Property Value

A string specifying the name of the label's font. The default value is "Arial".

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapElement.FontSize Property

MapElement.FontSize Property
[image]

Gets or sets the size of the font used to render the label of this element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Double

Property Value

A double value specifying the size of the label's font. The default value is 12.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapElement.Label Property

MapElement.Label Property
[image]

Gets or sets the label of this map element.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

A string specifying the label text.

See Also

MapElement Members
MapElement Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Class

MapLayerBase(TColor, TPalette) Class
[image]

Represents a map layer containing geometric shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class MapLayerBase<TColor, TPalette> : Layer<TColor, TPalette> where TPalette : IPalette<TColor>

Visual Basic [image] Copy Code

Public Class MapLayerBase(Of TColor, TPalette As IPalette(Of TColor))
Inherits Layer(Of TColor, TPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(TColor, TPalette)
MindFusion.Mapping.MapLayerBase(TColor, TPalette)
MindFusion.Mapping.Wpf.MapLayer

See Also

MapLayerBase(TColor, TPalette) Members


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Members

MapLayerBase(TColor, TPalette) Members
Constructors Properties Methods
[image]

Represents a map layer containing geometric shapes.

The following tables list the members exposed by the MapLayerBase(TColor, TPalette) type.

Public Constructors

Name | Description
MapLayerBase | Initializes a new instance of the MapLayerBase class.

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override.
Map | Gets or sets the Map whose elements should be rendered on this layer.
Selection | Gets the list of selected map shapes.

Public Methods

Name | Description
ClearCache | Layer.ClearCache override.
Draw | Layer.Draw override.
DrawHighlights | Overrides Layer.DrawHighlights.
DrawLabels | Layer.DrawLabels override.
Highlight | Layer.Highlight override.
HitTest | Layer.HitTest override.
Select | Layer.Select override.
Toggle | Layer.Toggle override.

See Also

MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Constructor

MapLayerBase(TColor, TPalette) Constructor
[image]

Initializes a new instance of the MapLayerBase class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public MapLayerBase<TColor, TPalette> ()

Visual Basic [image] Copy Code

Public Sub New(Of TColor, TPalette) ()

See Also

MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Methods

MapLayerBase(TColor, TPalette) Methods
[image]

Public Methods

Name | Description
ClearCache | Layer.ClearCache override.
Draw | Layer.Draw override.
DrawHighlights | Overrides Layer.DrawHighlights.
DrawLabels | Layer.DrawLabels override.
Highlight | Layer.Highlight override.
HitTest | Layer.HitTest override.
Select | Layer.Select override.
Toggle | Layer.Toggle override.

See Also

MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).ClearCache Method

MapLayerBase(TColor, TPalette).ClearCache Method
[image]

Layer.ClearCache override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void ClearCache ()

Visual Basic [image] Copy Code

Public Overrides Sub ClearCache ()

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Draw Method

MapLayerBase(TColor, TPalette).Draw Method
[image]

Layer.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void Draw (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).DrawHighlights Method

MapLayerBase(TColor, TPalette).DrawHighlights Method
[image]

Overrides Layer.DrawHighlights.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawHighlights (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHighlights( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).DrawLabels Method

MapLayerBase(TColor, TPalette).DrawLabels Method
[image]

Layer.DrawLabels override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void DrawLabels (
ICanvasWithPalette<TColor> canvas,
Rect bounds
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLabels( _
canvas As ICanvasWithPalette(Of TColor), _
bounds As Rect _
)

Parameters

canvas

An ICanvasWithPalette specifying the drawing canvas.

bounds

A Rect specifying the map region to draw.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Highlight Method

MapLayerBase(TColor, TPalette).Highlight Method
[image]

Layer.Highlight override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Highlight (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Highlight( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be highlighted.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).HitTest Method

MapLayerBase(TColor, TPalette).HitTest Method
[image]

Layer.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override MapElement HitTest (
Point mousePosition,
ITransform transform
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
mousePosition As Point, _
transform As ITransform _
) As MapElement

Parameters

mousePosition

A Point instance specifying location.

transform

The transform currently used to draw the map.

Return Value

The MapElement that contains the specified point.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Select Method

MapLayerBase(TColor, TPalette).Select Method
[image]

Layer.Select override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Select (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Select( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement that should be selected.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Toggle Method

MapLayerBase(TColor, TPalette).Toggle Method
[image]

Layer.Toggle override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Toggle (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Overrides Function Toggle( _
mapElement As MapElement _
) As Boolean

Parameters

mapElement

The MapElement whose selection state should be toggled.

Return Value

true if the map view should be redrawn, otherwise false.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette) Properties

MapLayerBase(TColor, TPalette) Properties
[image]

Public Properties

Name | Description
BoundingBox | Layer.BoundingBox override.
Map | Gets or sets the Map whose elements should be rendered on this layer.
Selection | Gets the list of selected map shapes.

See Also

MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).BoundingBox Property

MapLayerBase(TColor, TPalette).BoundingBox Property
[image]

Layer.BoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property BoundingBox As Rect

Property Value

A Rect instance specifying the bounding box.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Map Property

MapLayerBase(TColor, TPalette).Map Property
[image]

Gets or sets the Map whose elements should be rendered on this layer.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Map Map { get; set; }

Visual Basic [image] Copy Code

Public Property Map As Map

Property Value

A Map object.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.MapLayerBase(TColor, TPalette).Selection Property

MapLayerBase(TColor, TPalette).Selection Property
[image]

Gets the list of selected map shapes.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public List<Shape> Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As List(Of Shape)

Property Value

A list of Shape objects.

See Also

MapLayerBase(TColor, TPalette) Members
MapLayerBase(TColor, TPalette) Class


MindFusion.Mapping.NullShape Class

NullShape Class
[image]

Represents a null shape with no geometric data; often used as a place holder until data becomes available.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class NullShape : Shape

Visual Basic [image] Copy Code

Public Class NullShape
Inherits Shape

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Shape
MindFusion.Mapping.NullShape

See Also

NullShape Members


MindFusion.Mapping.NullShape Members

NullShape Members
Constructors Properties Methods
[image]

Represents a null shape with no geometric data; often used as a place holder until data becomes available.

The following tables list the members exposed by the NullShape type.

Public Constructors

Name | Description
NullShape | Initializes a new instance of the NullShape class.

Public Properties

Name | Description
Type | Shape.Type override.

Public Methods

Name | Description
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
SaveTo | Shape.SaveTo override.

Protected Methods

Name | Description
Draw | MapElement.Draw override.
HitTest | MapElement.HitTest override.

See Also

NullShape Class


MindFusion.Mapping.NullShape Constructor

NullShape Constructor
[image]

Initializes a new instance of the NullShape class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public NullShape (
int id
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer _
)

Parameters

id

The record number of this shape in the ESRI map file.

See Also

NullShape Class


MindFusion.Mapping.NullShape Methods

NullShape Methods
[image]

Public Methods

Name | Description
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
SaveTo | Shape.SaveTo override.

Protected Methods

Name | Description
Draw | MapElement.Draw override.
HitTest | MapElement.HitTest override.

See Also

NullShape Class


MindFusion.Mapping.NullShape.Draw Method

NullShape.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.NullShape.GetBoundingBox Method

NullShape.GetBoundingBox Method
[image]

Shape.GetBoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect GetBoundingBox ()

Visual Basic [image] Copy Code

Public Overrides Function GetBoundingBox () As Rect

Return Value

A Rect representing the shape's bounding box.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.NullShape.GetCenter Method

NullShape.GetCenter Method
[image]

Shape.GetCenter override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Point GetCenter ()

Visual Basic [image] Copy Code

Public Overrides Function GetCenter () As Point

Return Value

A Point representing the shape's center.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.NullShape.HitTest Method

NullShape.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.NullShape.SaveTo Method

NullShape.SaveTo Method
[image]

Shape.SaveTo override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the shape's data to a stream.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.NullShape Properties

NullShape Properties
[image]

Public Properties

Name | Description
Type | Shape.Type override.

See Also

NullShape Class


MindFusion.Mapping.NullShape.Type Property

NullShape.Type Property
[image]

Shape.Type override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override ShapeType Type { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Type As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

NullShape Members
NullShape Class


MindFusion.Mapping.Point Class

Point Class
[image]

Represents a point on the map with X (longitude) and Y (latitude) coordinates.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Point : Shape

Visual Basic [image] Copy Code

Public Class Point
Inherits Shape

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Shape
MindFusion.Mapping.Point

See Also

Point Members


MindFusion.Mapping.Point Members

Point Members
Constructors Fields Properties Methods
[image]

Represents a point on the map with X (longitude) and Y (latitude) coordinates.

The following tables list the members exposed by the Point type.

Public Constructors

Name | Description
Point | Overloaded. Initializes a new instance of the Point class.

Public Fields

Name | Description
X | The X coordinate of this Point.
Y | The Y coordinate of this Point.

Public Properties

Name | Description
Type | Shape.Type override.

Public Methods

Name | Description
Clone | Clones this point.
Distance | Returns the distance from this point to the specified point.
Equals | Overloaded. Determines whether this point is equal to another point.
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
GetHashCode | Object.GetHashCode override.
SaveTo | Saves the point to the specified stream.
ToString | Object.ToString override.

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

Point Class


MindFusion.Mapping.Point Constructor

Point Constructor
[image]

Initializes a new instance of the Point class.

Overload List

Name | Description
Point (Int32, BinaryReader) | Initializes a new instance of the Point class.
Point (Double, Double) | Initializes a new instance of the Point class.

See Also

Point Class


MindFusion.Mapping.Point Constructor (Int32, BinaryReader)

Point Constructor (Int32, BinaryReader)
See Also
[image]

Initializes a new instance of the Point class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point (
int id,
BinaryReader reader
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer, _
reader As BinaryReader _
)

Parameters

id

The record number of this point in the ESRI map file.

reader

A BinaryReader used to read the point data.

See Also

Point Constructor Overload List
Point Class


MindFusion.Mapping.Point Constructor (Double, Double)

Point Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the Point class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying longitude.

y

A double value specifying latitude.

See Also

Point Constructor Overload List
Point Class


MindFusion.Mapping.Point Methods

Point Methods
[image]

Public Methods

Name | Description
Clone | Clones this point.
Distance | Returns the distance from this point to the specified point.
Equals | Overloaded. Determines whether this point is equal to another point.
GetBoundingBox | Shape.GetBoundingBox override.
GetCenter | Shape.GetCenter override.
GetHashCode | Object.GetHashCode override.
SaveTo | Saves the point to the specified stream.
ToString | Object.ToString override.

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

Point Class


MindFusion.Mapping.Point.Clone Method

Point.Clone Method
[image]

Clones this point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Point

Return Value

A Point instance with the same coordinates as this point.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Distance Method

Point.Distance Method
[image]

Returns the distance from this point to the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Distance (
Point point
)

Visual Basic [image] Copy Code

Public Function Distance( _
point As Point _
) As Double

Parameters

point

A Point instance.

Return Value

A double value representing the distance between the two points.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Draw Method

Point.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.DrawLabel Method

Point.DrawLabel Method
[image]

MapElement.DrawLabel override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Equals Method

Point.Equals Method
[image]

Determines whether this point is equal to another point.

Overload List

Name | Description
Point.Equals (Point) | Determines whether the specified Point is equal to this Point.
Point.Equals (Object) | Object.Equals override.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Equals Method (Point)

Point.Equals Method (Point)
See Also
[image]

Determines whether the specified Point is equal to this Point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public new bool Equals (
Point other
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
other As Point _
) As Boolean

Parameters

other

The Point to compare with this point.

Return Value

true if the specified Point is equal to the current Point, otherwise false.

See Also

Equals Method Overload List
Point Members
Point Class


MindFusion.Mapping.Point.Equals Method (Object)

Point.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with this object.

Return Value

true if the specified Object is equal to the current Object, otherwise false.

See Also

Equals Method Overload List
Point Members
Point Class


MindFusion.Mapping.Point.GetBoundingBox Method

Point.GetBoundingBox Method
[image]

Shape.GetBoundingBox override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Rect GetBoundingBox ()

Visual Basic [image] Copy Code

Public Overrides Function GetBoundingBox () As Rect

Return Value

A Rect representing the shape's bounding box.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.GetCenter Method

Point.GetCenter Method
[image]

Shape.GetCenter override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override Point GetCenter ()

Visual Basic [image] Copy Code

Public Overrides Function GetCenter () As Point

Return Value

A Point representing the shape's center.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.GetHashCode Method

Point.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the this point.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Highlight Method

Point.Highlight Method
[image]

MapElement.Highlight override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.HitTest Method

Point.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected override bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.SaveTo Method

Point.SaveTo Method
[image]

Saves the point to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Overrides Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the point data.

See Also

Point Members
Point Class


MindFusion.Mapping.Point.ToString Method

Point.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The string representation of this point.

See Also

Point Members
Point Class


MindFusion.Mapping.Point Properties

Point Properties
[image]

Public Properties

Name | Description
Type | Shape.Type override.

See Also

Point Class


MindFusion.Mapping.Point.Type Property

Point.Type Property
[image]

Shape.Type override.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public override ShapeType Type { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Type As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

Point Members
Point Class


MindFusion.Mapping.Point Fields

Point Fields
[image]

Public Fields

Name | Description
X | The X coordinate of this Point.
Y | The Y coordinate of this Point.

See Also

Point Class


MindFusion.Mapping.Point.X Field

Point.X Field
[image]

The X coordinate of this Point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double X

Visual Basic [image] Copy Code

Public X As Double

See Also

Point Members
Point Class


MindFusion.Mapping.Point.Y Field

Point.Y Field
[image]

The Y coordinate of this Point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Y

Visual Basic [image] Copy Code

Public Y As Double

See Also

Point Members
Point Class


MindFusion.Mapping.Rect Class

Rect Class
[image]

A class representing a rectangular are on the map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Rect

Visual Basic [image] Copy Code

Public Class Rect

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Rect

See Also

Rect Members


MindFusion.Mapping.Rect Members

Rect Members
Constructors Properties Methods
[image]

A class representing a rectangular are on the map.

The following tables list the members exposed by the Rect type.

Public Constructors

Name | Description
Rect | Overloaded. Initializes a new instance of the Rect class.

Public Properties

Name | Description
Height | Gets the rectangle height.
Width | Gets the rectangle width.
XMax | Gets or set the maximum X value.
XMin | Gets or set the minimum X value.
YMax | Gets or set the maximum Y value.
YMin | Gets or set the minimum Y value.

Public Methods

Name | Description
ContainsPoint | Overloaded. Tests whether this rectangle contains a point.
Divide | Divides this rectangle into four equal parts.
GetCenter | Returns the rectangle center.
GetLocation | Returns the min X/Y corner of this rectangle.
Intersect | Returns the intersection of this rectangle with the specified rectangle.
Intersects | Tests whether this rectangle intersects with the specified rectangle.
SaveTo | Saves the rectangle to the specified stream.
Union | Returns the union of two rectangles.

See Also

Rect Class


MindFusion.Mapping.Rect Constructor

Rect Constructor
[image]

Initializes a new instance of the Rect class.

Overload List

Name | Description
Rect (Double, Double, Double, Double) | Initializes a new instance of the Rect class.
Rect (Point, Point) | Initializes a new instance of the Rect class.
Rect (BinaryReader) | Initializes a new instance of the Rect class.

See Also

Rect Class


MindFusion.Mapping.Rect Constructor (Double, Double, Double, Double)

Rect Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect (
double xMin,
double yMin,
double xMax,
double yMax
)

Visual Basic [image] Copy Code

Public New ( _
xMin As Double, _
yMin As Double, _
xMax As Double, _
yMax As Double _
)

Parameters

xMin

The minimum X value.

yMin

The minimum Y value.

xMax

The maximum X value.

yMax

The maximum Y value.

See Also

Rect Constructor Overload List
Rect Class


MindFusion.Mapping.Rect Constructor (Point, Point)

Rect Constructor (Point, Point)
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect (
Point point1,
Point point2
)

Visual Basic [image] Copy Code

Public New ( _
point1 As Point, _
point2 As Point _
)

Parameters

point1

A Point specifying one of the rectangle corners.

point2

A Point specifying the opposite rectangle corner.

See Also

Rect Constructor Overload List
Rect Class


MindFusion.Mapping.Rect Constructor (BinaryReader)

Rect Constructor (BinaryReader)
See Also
[image]

Initializes a new instance of the Rect class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect (
BinaryReader reader
)

Visual Basic [image] Copy Code

Public New ( _
reader As BinaryReader _
)

Parameters

reader

A BinaryReader used to read the rectangle coordinates.

See Also

Rect Constructor Overload List
Rect Class


MindFusion.Mapping.Rect Methods

Rect Methods
[image]

Public Methods

Name | Description
ContainsPoint | Overloaded. Tests whether this rectangle contains a point.
Divide | Divides this rectangle into four equal parts.
GetCenter | Returns the rectangle center.
GetLocation | Returns the min X/Y corner of this rectangle.
Intersect | Returns the intersection of this rectangle with the specified rectangle.
Intersects | Tests whether this rectangle intersects with the specified rectangle.
SaveTo | Saves the rectangle to the specified stream.
Union | Returns the union of two rectangles.

See Also

Rect Class


MindFusion.Mapping.Rect.ContainsPoint Method

Rect.ContainsPoint Method
[image]

Tests whether this rectangle contains a point.

Overload List

Name | Description
Rect.ContainsPoint (Point, Double) | Tests whether this rectangle contains the specified point within a threshold.
Rect.ContainsPoint (Point) | Tests whether this rectangle contains the specified point.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.ContainsPoint Method (Point, Double)

Rect.ContainsPoint Method (Point, Double)
See Also
[image]

Tests whether this rectangle contains the specified point within a threshold.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

A Point instance.

threshold

A threshold value.

Return Value

true if this rectangle contains the point, otherwise false.

See Also

ContainsPoint Method Overload List
Rect Members
Rect Class


MindFusion.Mapping.Rect.ContainsPoint Method (Point)

Rect.ContainsPoint Method (Point)
See Also
[image]

Tests whether this rectangle contains the specified point.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

A Point instance.

Return Value

true if this rectangle contains the point, otherwise false.

See Also

ContainsPoint Method Overload List
Rect Members
Rect Class


MindFusion.Mapping.Rect.Divide Method

Rect.Divide Method
[image]

Divides this rectangle into four equal parts.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect[] Divide ()

Visual Basic [image] Copy Code

Public Function Divide () As Rect()

Return Value

An array of rectangles.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.GetCenter Method

Rect.GetCenter Method
[image]

Returns the rectangle center.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point GetCenter ()

Visual Basic [image] Copy Code

Public Function GetCenter () As Point

Return Value

A Point representing the center of this rectangle.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.GetLocation Method

Rect.GetLocation Method
[image]

Returns the min X/Y corner of this rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Point GetLocation ()

Visual Basic [image] Copy Code

Public Function GetLocation () As Point

Return Value

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.Intersect Method

Rect.Intersect Method
[image]

Returns the intersection of this rectangle with the specified rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Rect Intersect (
Rect rect
)

Visual Basic [image] Copy Code

Public Function Intersect( _
rect As Rect _
) As Rect

Parameters

rect

A Rect instance.

Return Value

A Rect representing the intersection of the two rectangles.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.Intersects Method

Rect.Intersects Method
[image]

Tests whether this rectangle intersects with the specified rectangle.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public bool Intersects (
Rect rect
)

Visual Basic [image] Copy Code

Public Function Intersects( _
rect As Rect _
) As Boolean

Parameters

rect

A Rect instance.

Return Value

true if the rectangles intersect, otherwise false.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.SaveTo Method

Rect.SaveTo Method
[image]

Saves the rectangle to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the rectangle coordinates.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.Union Method

Rect.Union Method
[image]

Returns the union of two rectangles.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static Rect Union (
Rect rect1,
Rect rect2
)

Visual Basic [image] Copy Code

Public Shared Function Union( _
rect1 As Rect, _
rect2 As Rect _
) As Rect

Parameters

rect1

Specifies the first rectangle.

rect2

Specifies the second rectangle.

Return Value

A Rect instance representing the union of specified rectangles.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect Properties

Rect Properties
[image]

Public Properties

Name | Description
Height | Gets the rectangle height.
Width | Gets the rectangle width.
XMax | Gets or set the maximum X value.
XMin | Gets or set the minimum X value.
YMax | Gets or set the maximum Y value.
YMin | Gets or set the minimum Y value.

See Also

Rect Class


MindFusion.Mapping.Rect.Height Property

Rect.Height Property
[image]

Gets the rectangle height.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Height { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Height As Double

Property Value

A double value.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.Width Property

Rect.Width Property
[image]

Gets the rectangle width.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double Width { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Width As Double

Property Value

A double value.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.XMax Property

Rect.XMax Property
[image]

Gets or set the maximum X value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double XMax { get; set; }

Visual Basic [image] Copy Code

Public Property XMax As Double

Property Value

A double value.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.XMin Property

Rect.XMin Property
[image]

Gets or set the minimum X value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double XMin { get; set; }

Visual Basic [image] Copy Code

Public Property XMin As Double

Property Value

A double value.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.YMax Property

Rect.YMax Property
[image]

Gets or set the maximum Y value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double YMax { get; set; }

Visual Basic [image] Copy Code

Public Property YMax As Double

Property Value

A double value.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Rect.YMin Property

Rect.YMin Property
[image]

Gets or set the minimum Y value.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public double YMin { get; set; }

Visual Basic [image] Copy Code

Public Property YMin As Double

Property Value

A double value.

See Also

Rect Members
Rect Class


MindFusion.Mapping.Row Class

Row Class
[image]

Represents a DBF database row.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public class Row : ICustomTypeDescriptor

Visual Basic [image] Copy Code

Public Class Row
Implements ICustomTypeDescriptor

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Row

See Also

Row Members


MindFusion.Mapping.Row Members

Row Members
Properties
[image]

Represents a DBF database row.

The following tables list the members exposed by the Row type.

Public Properties

Name | Description
Index | Gets or sets the row index.
Item | Overloaded. Gets the data stored in a specified field.

See Also

Row Class


MindFusion.Mapping.Row Properties

Row Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the row index.
Item | Overloaded. Gets the data stored in a specified field.

See Also

Row Class


MindFusion.Mapping.Row.Index Property

Row.Index Property
[image]

Gets or sets the row index.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value specifying the row's ordinal index within the database.

See Also

Row Members
Row Class


MindFusion.Mapping.Row.Item Property

Row.Item Property
[image]

Gets the data stored in a specified field.

Overload List

Name | Description
Row.Item (Int32) | Returns the data stored in the specified field.
Row.Item (Column) | Returns the data stored in the specified field.
Row.Item (String) | Returns the data stored in the specified field.

See Also

Row Members
Row Class


MindFusion.Mapping.Row.Item Property (Int32)

Row.Item Property (Int32)
See Also
[image]

Returns the data stored in the specified field.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Item [
int columnIndex
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
columnIndex As Integer _
) As String

Parameters

columnIndex

Specifies the index of the database column.

Property Value

The string value of the specified field.

See Also

Item Property Overload List
Row Members
Row Class


MindFusion.Mapping.Row.Item Property (Column)

Row.Item Property (Column)
See Also
[image]

Returns the data stored in the specified field.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Item [
Column column
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
column As Column _
) As String

Parameters

column

Specifies the database column.

Property Value

The string value of the specified field.

See Also

Item Property Overload List
Row Members
Row Class


MindFusion.Mapping.Row.Item Property (String)

Row.Item Property (String)
See Also
[image]

Returns the data stored in the specified field.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public string Item [
string columnName
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
columnName As String _
) As String

Parameters

columnName

Specifies the name of the database column.

Property Value

The string value of the specified field.

See Also

Item Property Overload List
Row Members
Row Class


MindFusion.Mapping.Shape Class

Shape Class
[image]

Represents geometrical shapes displayed on a map.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract class Shape : MapElement

Visual Basic [image] Copy Code

Public MustInherit Class Shape
Inherits MapElement

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Shape
MindFusion.Mapping.NullShape
MindFusion.Mapping.Point

See Also

Shape Members


MindFusion.Mapping.Shape Members

Shape Members
Constructors Fields Properties Methods
[image]

Represents geometrical shapes displayed on a map.

The following tables list the members exposed by the Shape type.

Protected Constructors

Name | Description
Shape | Initializes a new instance of the Shape class.

Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file.

Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette.
DatabaseRow | Gets the DBF database row associated with this Shape.
HitTestDistance | Gets or set the current hit test threshold distance.
Type | Gets the ESRI shape type of this Shape.

Public Methods

Name | Description
GetBoundingBox | Gets the bounding box of this shape.
GetCenter | Gets the center point of this shape.
SaveTo | Saves this shape to the specified stream.

Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level.

See Also

Shape Class


MindFusion.Mapping.Shape Constructor

Shape Constructor
[image]

Initializes a new instance of the Shape class.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected Shape (
int id
)

Visual Basic [image] Copy Code

Protected New ( _
id As Integer _
)

Parameters

id

The record number of this shape in the ESRI map file.

See Also

Shape Class


MindFusion.Mapping.Shape Methods

Shape Methods
[image]

Public Methods

Name | Description
GetBoundingBox | Gets the bounding box of this shape.
GetCenter | Gets the center point of this shape.
SaveTo | Saves this shape to the specified stream.

Protected Methods

Name | Description
ClearCache | Clears any cached values associated with the shape for the current zoom level.

See Also

Shape Class


MindFusion.Mapping.Shape.ClearCache Method

Shape.ClearCache Method
[image]

Clears any cached values associated with the shape for the current zoom level.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

protected virtual void ClearCache ()

Visual Basic [image] Copy Code

Protected Overridable Sub ClearCache ()

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.GetBoundingBox Method

Shape.GetBoundingBox Method
[image]

Gets the bounding box of this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract Rect GetBoundingBox ()

Visual Basic [image] Copy Code

Public MustOverride Function GetBoundingBox () As Rect

Return Value

A Rect representing the shape's bounding box.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.GetCenter Method

Shape.GetCenter Method
[image]

Gets the center point of this shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract Point GetCenter ()

Visual Basic [image] Copy Code

Public MustOverride Function GetCenter () As Point

Return Value

A Point representing the shape's center.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.SaveTo Method

Shape.SaveTo Method
[image]

Saves this shape to the specified stream.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract void SaveTo (
BinaryWriter writer
)

Visual Basic [image] Copy Code

Public MustOverride Sub SaveTo( _
writer As BinaryWriter _
)

Parameters

writer

A BinaryWriter used to write the shape's data to a stream.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape Properties

Shape Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the index of the shape's color within the current color palette.
DatabaseRow | Gets the DBF database row associated with this Shape.
HitTestDistance | Gets or set the current hit test threshold distance.
Type | Gets the ESRI shape type of this Shape.

See Also

Shape Class


MindFusion.Mapping.Shape.Color Property

Shape.Color Property
[image]

Gets or sets the index of the shape's color within the current color palette.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Integer

Property Value

An integer value specifying an index within the FillColors array of a MapLayer.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.DatabaseRow Property

Shape.DatabaseRow Property
[image]

Gets the DBF database row associated with this Shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public Row DatabaseRow { get; set; }

Visual Basic [image] Copy Code

Public Property DatabaseRow As Row

Property Value

A Row instance.

Remarks

This property is set if the loadDatabase argument of the LoadFromFile method is set to true.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.HitTestDistance Property

Shape.HitTestDistance Property
[image]

Gets or set the current hit test threshold distance.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public static double HitTestDistance { get; set; }

Visual Basic [image] Copy Code

Public Shared Property HitTestDistance As Double

Property Value

A double value specifying threshold distance for hit-testing non-polygonal shapes.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape.Type Property

Shape.Type Property
[image]

Gets the ESRI shape type of this Shape.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public abstract ShapeType Type { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Type As ShapeType

Property Value

A member of the ShapeType enumeration.

See Also

Shape Members
Shape Class


MindFusion.Mapping.Shape Fields

Shape Fields
[image]

Public Fields

Name | Description
Id | The record number of this shape in the ESRI map file.

See Also

Shape Class


MindFusion.Mapping.Shape.Id Field

Shape.Id Field
[image]

The record number of this shape in the ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public int Id

Visual Basic [image] Copy Code

Public Id As Integer

See Also

Shape Members
Shape Class


MindFusion.Mapping.ShapeType Enumeration

ShapeType Enumeration
[image]

Specifies the type of shapes contained in an ESRI map file.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public enum ShapeType

Visual Basic [image] Copy Code

Public Enumeration ShapeType

Members

Member name | Description
MultiPatch | Indicates a MultiPatch shape, which consists of a number of surface patches.
MultiPoint | Indicates a MultiPoint shape, which contains a set of points.
MultiPointM | Indicates a MultiPointM shape, which is a MultiPoint with additional measure attributes.
MultiPointZ | Indicates a MultiPointZ shape, which is a MultiPoint with additional Z and measure attributes.
NullShape | Indicates a null shape with no geometric data; often used as a place holder until data becomes available.
Point | Indicates a Point shape, which contains X (longitude) and Y (latitude) coordinates.
PointM | Indicates a PointM shape, which is a Point with an additional measure attribute.
PointZ | Indicates a PointZ shape, which is a Point with additional Z and measure attributes.
Polygon | Indicates a Polygon shape, which contains several ordered sets of points rendered as filled polygons.
PolygonM | Indicates a PolygonM shape, which is a Polygon with additional measure attributes.
PolygonZ | Indicates a PolygonZ shape, which is a Polygon with additional Z and measure attributes.
PolyLine | Indicates a Polyline shape, which contains several ordered sets of points rendered as connected line segments.
PolyLineM | Indicates a PolyLineM shape, which is a PolyLine with additional measure attributes.
PolyLineZ | Indicates a PolyLineZ shape, which is a PolyLine with additional Z and measure attributes.

See Also


MindFusion.Mapping.TextAlignment Enumeration

TextAlignment Enumeration
[image]

Specifies text alignment.

Namespace: MindFusion.Mapping
Assembly: MindFusion.Mapping

Syntax

C# [image] Copy Code

public enum TextAlignment

Visual Basic [image] Copy Code

Public Enumeration TextAlignment

Members

Member name | Description
Center | Indicates center alignment.
Far | Indicates right or bottom alignment.
Near | Indicates top or left alignment.

See Also


MindFusion.Mapping.Wpf Namespace
Classes

Classes

Class | Description
DecorationBubble | Represents a bubble object that can be drawn as a decoration over the map.
DecorationImage | Represents an image that can be drawn as a decoration over the map.
DecorationLayer | Represents a layer containing decorative elements.
LayerEventArgs | Provides data for layer-related events.
LayerList | Represents a list of Layer objects.
LayerPresenter | A control used to render a single map layer.
MapEventArgs | Provides data for map events.
MapLayer | Represents a map layer containing geometric shapes.
MapView | A WPF control used to draw maps.
Viewbox | Defines a decorator that can stretch and scale a single child to fill the available space.
VisibilityConverter | Converts boolean property values to Visibility values.
XamlPalette | Represents a palette of colors.
XamlTransform | Represents a geometrical transform used to convert world coordinates to screen coordinates.


MindFusion.Mapping.Wpf.DecorationBubble Class

DecorationBubble Class
[image]

Represents a bubble object that can be drawn as a decoration over the map.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class DecorationBubble : Decoration

Visual Basic [image] Copy Code

Public Class DecorationBubble
Inherits Decoration

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.Wpf.DecorationBubble

See Also

DecorationBubble Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble Members

DecorationBubble Members
Constructors Properties Methods
[image]

Represents a bubble object that can be drawn as a decoration over the map.

The following tables list the members exposed by the DecorationBubble type.

Public Constructors

Name | Description
DecorationBubble | Initializes a new instance of the DecorationBubble class.

Public Properties

Name | Description
BorderColor | Gets or sets the bubble's border color.
FillColor | Gets or sets the bubble's fill color.
Radius | Gets or sets the bubble radius in pixels.

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble Constructor

DecorationBubble Constructor
[image]

Initializes a new instance of the DecorationBubble class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationBubble (
int radius,
Color fillColor,
Color borderColor,
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
radius As Integer, _
fillColor As Color, _
borderColor As Color, _
latitude As Double, _
longitude As Double _
)

Parameters

radius

An integer specifying the bubble radius.

fillColor

A Color instance specifying the bubble fill color.

borderColor

A Color instance specifying the bubble border color.

latitude

A double value specifying the latitude at which the bubble should be drawn.

longitude

A double value specifying the longitude at which the bubble should be drawn.

See Also

DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble Methods

DecorationBubble Methods
[image]

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.Draw Method

DecorationBubble.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.DrawLabel Method

DecorationBubble.DrawLabel Method
[image]

MapElement.DrawLabel override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.Highlight Method

DecorationBubble.Highlight Method
[image]

MapElement.Highlight override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.HitTest Method

DecorationBubble.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble Properties

DecorationBubble Properties
[image]

Public Properties

Name | Description
BorderColor | Gets or sets the bubble's border color.
FillColor | Gets or sets the bubble's fill color.
Radius | Gets or sets the bubble radius in pixels.

See Also

DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.BorderColor Property

DecorationBubble.BorderColor Property
[image]

Gets or sets the bubble's border color.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Color BorderColor { get; set; }

Visual Basic [image] Copy Code

Public Property BorderColor As Color

Property Value

A System.Windows.Media.Color instance.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.FillColor Property

DecorationBubble.FillColor Property
[image]

Gets or sets the bubble's fill color.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Color FillColor { get; set; }

Visual Basic [image] Copy Code

Public Property FillColor As Color

Property Value

A System.Windows.Media.Color instance.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationBubble.Radius Property

DecorationBubble.Radius Property
[image]

Gets or sets the bubble radius in pixels.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public int Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Integer

Property Value

An integer value specifying the bubble radius in pixels.

See Also

DecorationBubble Members
DecorationBubble Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Class

DecorationImage Class
[image]

Represents an image that can be drawn as a decoration over the map.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class DecorationImage : Decoration

Visual Basic [image] Copy Code

Public Class DecorationImage
Inherits Decoration

Inheritance Hierarchy

System.Object
MindFusion.Mapping.MapElement
MindFusion.Mapping.Decoration
MindFusion.Mapping.Wpf.DecorationImage

See Also

DecorationImage Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Members

DecorationImage Members
Constructors Properties Methods
[image]

Represents an image that can be drawn as a decoration over the map.

The following tables list the members exposed by the DecorationImage type.

Public Constructors

Name | Description
DecorationImage | Overloaded. Initializes a new instance of the DecorationImage class.

Public Properties

Name | Description
HighlightImage | Gets or sets a System.Drawing.Image that should be displayed when the decoration is highlighted.
Image | Gets or sets the BitmapImage that should be displayed as a decoration.
PivotX | Gets or sets horizontal offset within the image that should be aligned to the decoration longitude.
PivotY | Gets or sets vertical offset within the image that should be aligned to the decoration latitude.

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Constructor

DecorationImage Constructor
[image]

Initializes a new instance of the DecorationImage class.

Overload List

Name | Description
DecorationImage () | Initializes a new instance of the DecorationImage class.
DecorationImage (BitmapImage, Double, Double) | Initializes a new instance of the DecorationImage class.
DecorationImage (BitmapImage, Int32, Int32, Double, Double) | Initializes a new instance of the DecorationImage class.

See Also

DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Constructor ()

DecorationImage Constructor ()
See Also
[image]

Initializes a new instance of the DecorationImage class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationImage ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DecorationImage Constructor Overload List
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Constructor (BitmapImage, Double, Double)

DecorationImage Constructor (BitmapImage, Double, Double)
See Also
[image]

Initializes a new instance of the DecorationImage class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationImage (
BitmapImage image,
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
image As BitmapImage, _
latitude As Double, _
longitude As Double _
)

Parameters

image

A BitmapImage instance.

latitude

A double value specifying the latitude at which the image should be drawn.

longitude

A double value specifying the longitude at which the image should be drawn.

See Also

DecorationImage Constructor Overload List
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Constructor (BitmapImage, Int32, Int32, Double, Double)

DecorationImage Constructor (BitmapImage, Int32, Int32, Double, Double)
See Also
[image]

Initializes a new instance of the DecorationImage class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationImage (
BitmapImage image,
int pivotX,
int pivotY,
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public New ( _
image As BitmapImage, _
pivotX As Integer, _
pivotY As Integer, _
latitude As Double, _
longitude As Double _
)

Parameters

image

A BitmapImage instance.

pivotX

Position within the image that should be aligned to the specified longitude.

pivotY

Position within the image that should be aligned to the specified latitude.

latitude

A double value specifying the latitude at which the image should be drawn.

longitude

A double value specifying the longitude at which the image should be drawn.

See Also

DecorationImage Constructor Overload List
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Methods

DecorationImage Methods
[image]

Protected Methods

Name | Description
Draw | MapElement.Draw override.
DrawLabel | MapElement.DrawLabel override.
Highlight | MapElement.Highlight override.
HitTest | MapElement.HitTest override.

See Also

DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.Draw Method

DecorationImage.Draw Method
[image]

MapElement.Draw override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void Draw (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Draw( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.DrawLabel Method

DecorationImage.DrawLabel Method
[image]

MapElement.DrawLabel override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void DrawLabel (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub DrawLabel( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.Highlight Method

DecorationImage.Highlight Method
[image]

MapElement.Highlight override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void Highlight (
ICanvas canvas
)

Visual Basic [image] Copy Code

Protected Overrides Sub Highlight( _
canvas As ICanvas _
)

Parameters

canvas

An ICanvas representing the drawing surface.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.HitTest Method

DecorationImage.HitTest Method
[image]

MapElement.HitTest override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override bool HitTest (
Point point,
ITransform transform
)

Visual Basic [image] Copy Code

Protected Overrides Function HitTest( _
point As Point, _
transform As ITransform _
) As Boolean

Parameters

point

A Point representing a location on the map.

transform

An ITransform representing the transform currently used to render the map.

Return Value

true if this element contains the specified point, otherwise false.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage Properties

DecorationImage Properties
[image]

Public Properties

Name | Description
HighlightImage | Gets or sets a System.Drawing.Image that should be displayed when the decoration is highlighted.
Image | Gets or sets the BitmapImage that should be displayed as a decoration.
PivotX | Gets or sets horizontal offset within the image that should be aligned to the decoration longitude.
PivotY | Gets or sets vertical offset within the image that should be aligned to the decoration latitude.

See Also

DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.HighlightImage Property

DecorationImage.HighlightImage Property
[image]

Gets or sets a System.Drawing.Image that should be displayed when the decoration is highlighted.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public BitmapImage HighlightImage { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightImage As BitmapImage

Property Value

A System.Windows.Media.Imaging.BitmapImage instance.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.Image Property

DecorationImage.Image Property
[image]

Gets or sets the BitmapImage that should be displayed as a decoration.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public BitmapImage Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As BitmapImage

Property Value

A System.Windows.Media.Imaging.BitmapImage instance.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.PivotX Property

DecorationImage.PivotX Property
[image]

Gets or sets horizontal offset within the image that should be aligned to the decoration longitude.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public int PivotX { get; set; }

Visual Basic [image] Copy Code

Public Property PivotX As Integer

Property Value

An integer value specifying horizontal offset.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationImage.PivotY Property

DecorationImage.PivotY Property
[image]

Gets or sets vertical offset within the image that should be aligned to the decoration latitude.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public int PivotY { get; set; }

Visual Basic [image] Copy Code

Public Property PivotY As Integer

Property Value

An integer value specifying vertical offset.

See Also

DecorationImage Members
DecorationImage Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Class

DecorationLayer Class
[image]

Represents a layer containing decorative elements.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class DecorationLayer : DecorationLayerBase<Color, XamlPalette>

Visual Basic [image] Copy Code

Public Class DecorationLayer
Inherits DecorationLayerBase(Of Color, XamlPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(Color, XamlPalette)
MindFusion.Mapping.DecorationLayerBase(Color, XamlPalette)
MindFusion.Mapping.Wpf.DecorationLayer

See Also

DecorationLayer Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Members

DecorationLayer Members
Constructors
[image]

Represents a layer containing decorative elements.

The following tables list the members exposed by the DecorationLayer type.

Public Constructors

Name | Description
DecorationLayer | Overloaded. Initializes a new instance of the DecorationLayer class.

See Also

DecorationLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Constructor

DecorationLayer Constructor
[image]

Initializes a new instance of the DecorationLayer class.

Overload List

Name | Description
DecorationLayer () | Initializes a new instance of the DecorationLayer class.
DecorationLayer (Rect) | Initializes a new instance of the DecorationLayer class.

See Also

DecorationLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Constructor ()

DecorationLayer Constructor ()
See Also
[image]

Initializes a new instance of the DecorationLayer class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationLayer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DecorationLayer Constructor Overload List
DecorationLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.DecorationLayer Constructor (Rect)

DecorationLayer Constructor (Rect)
See Also
[image]

Initializes a new instance of the DecorationLayer class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public DecorationLayer (
Rect boundingBox
)

Visual Basic [image] Copy Code

Public New ( _
boundingBox As Rect _
)

Parameters

boundingBox

A Rect specifying the map area displayed on this layer.

See Also

DecorationLayer Constructor Overload List
DecorationLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerEventArgs Class

LayerEventArgs Class
[image]

Provides data for layer-related events.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class LayerEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class LayerEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Mapping.Wpf.LayerEventArgs

See Also

LayerEventArgs Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerEventArgs Members

LayerEventArgs Members
Constructors Properties
[image]

Provides data for layer-related events.

The following tables list the members exposed by the LayerEventArgs type.

Public Constructors

Name | Description
LayerEventArgs | Initializes a new instance of the LayerEventArgs class.

Public Properties

Name | Description
Layer | Gets or sets the layer for which the event is raised.

See Also

LayerEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerEventArgs Constructor

LayerEventArgs Constructor
[image]

Initializes a new instance of the LayerEventArgs class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public LayerEventArgs (
Layer<Color, XamlPalette> layer
)

Visual Basic [image] Copy Code

Public New ( _
layer As Layer(Of Color, XamlPalette) _
)

Parameters

layer

An instance of the Layer class.

See Also

LayerEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerEventArgs Properties

LayerEventArgs Properties
[image]

Public Properties

Name | Description
Layer | Gets or sets the layer for which the event is raised.

See Also

LayerEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerEventArgs.Layer Property

LayerEventArgs.Layer Property
[image]

Gets or sets the layer for which the event is raised.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Layer<Color, XamlPalette> Layer { get; set; }

Visual Basic [image] Copy Code

Public Property Layer As Layer(Of Color, XamlPalette)

Property Value

An instance of the Layer class.

See Also

LayerEventArgs Members
LayerEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerList Class

LayerList Class
[image]

Represents a list of Layer objects.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class LayerList : ObservableCollection<Layer<Color, XamlPalette>>

Visual Basic [image] Copy Code

Public Class LayerList
Inherits ObservableCollection(Of Layer(Of Color, XamlPalette))

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(Layer(Color, XamlPalette))
System.Collections.ObjectModel.ObservableCollection(Layer(Color, XamlPalette))
MindFusion.Mapping.Wpf.LayerList

See Also

LayerList Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerList Members

LayerList Members
Constructors
[image]

Represents a list of Layer objects.

The following tables list the members exposed by the LayerList type.

Public Constructors

Name | Description
LayerList | Initializes a new instance of the LayerList class.

See Also

LayerList Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerList Constructor

LayerList Constructor
[image]

Initializes a new instance of the LayerList class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public LayerList ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayerList Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Class

LayerPresenter Class
[image]

A control used to render a single map layer.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class LayerPresenter : Control, ICanvasWithPalette<Color>, ICanvas

Visual Basic [image] Copy Code

Public Class LayerPresenter
Inherits Control
Implements ICanvasWithPalette(Of Color), ICanvas

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Mapping.Wpf.LayerPresenter

See Also

LayerPresenter Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Members

LayerPresenter Members
Constructors Fields Properties Methods
[image]

A control used to render a single map layer.

The following tables list the members exposed by the LayerPresenter type.

Public Constructors

Name | Description
LayerPresenter | Initializes a new instance of the LayerPresenter class.

Public Fields

Name | Description
LayerProperty | Identifies the Layer dependency property.

Public Properties

Name | Description
Layer | Gets or sets the layer rendered inside this control.
Palette | Gets or sets the color palette used to draw map shapes in this layer.

Public Methods

Name | Description
ClipExclude | Overloaded. Excludes an area from the current clip region.
DrawImageUnscaled | Draws an image with the specified attributes.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
OnApplyTemplate | Control.OnApplyTemplate override.
ResetClip | Resets the current clip region.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetTextAlignment | Sets the current text alignment.

See Also

LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Constructor

LayerPresenter Constructor
[image]

Initializes a new instance of the LayerPresenter class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public LayerPresenter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Methods

LayerPresenter Methods
[image]

Public Methods

Name | Description
ClipExclude | Overloaded. Excludes an area from the current clip region.
DrawImageUnscaled | Draws an image with the specified attributes.
DrawPoint | Draws a point marker at the specified location.
DrawPolyline | Draws a polyline.
DrawString | Draws a string with the specified attributes.
FillPolygon | Fills a polygon.
GetPixelSize | Gets the size of a pixel at the current zoom level.
OnApplyTemplate | Control.OnApplyTemplate override.
ResetClip | Resets the current clip region.
SetFillColor | Sets the current fill color to the specified color from the palette.
SetHighlightColor | Sets the current fill and line colors to the highlight color associated with this canvas.
SetLineColor | Sets the current line color to the line color associated with this canvas.
SetTextAlignment | Sets the current text alignment.

See Also

LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.ClipExclude Method

LayerPresenter.ClipExclude Method
[image]

Excludes an area from the current clip region.

Overload List

Name | Description
LayerPresenter.ClipExclude (IList(Point)) | Excludes the specified area from the current clip region.
LayerPresenter.ClipExclude (List(IList(Point))) | Excludes the specified areas from the current clip region.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.ClipExclude Method (IList(Point))

LayerPresenter.ClipExclude Method (IList(Point))
See Also
[image]

Excludes the specified area from the current clip region.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void ClipExclude (
IList<Point> points
)

Visual Basic [image] Copy Code

Public Sub ClipExclude( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.ClipExclude Method (List(IList(Point)))

LayerPresenter.ClipExclude Method (List(IList(Point)))
See Also
[image]

Excludes the specified areas from the current clip region.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void ClipExclude (
List<IList<Point>> points
)

Visual Basic [image] Copy Code

Public Sub ClipExclude( _
points As List(Of IList(Of Point)) _
)

Parameters

points

A list of points specifying the area to exclude.

See Also

ClipExclude Method Overload List
LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.DrawImageUnscaled Method

LayerPresenter.DrawImageUnscaled Method
[image]

Draws an image with the specified attributes.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void DrawImageUnscaled (
BitmapImage image,
Point point,
int pivotX,
int pivotY
)

Visual Basic [image] Copy Code

Public Sub DrawImageUnscaled( _
image As BitmapImage, _
point As Point, _
pivotX As Integer, _
pivotY As Integer _
)

Parameters

image

The image that should be drawn.

point

A Point specifying the image location.

pivotX

Horizontal position within the image that should be aligned to the specified point.

pivotY

Vertical position within the image that should be aligned to the specified point.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.DrawPoint Method

LayerPresenter.DrawPoint Method
[image]

Draws a point marker at the specified location.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void DrawPoint (
Point point
)

Visual Basic [image] Copy Code

Public Sub DrawPoint( _
point As Point _
)

Parameters

point

The Point to draw.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.DrawPolyline Method

LayerPresenter.DrawPolyline Method
[image]

Draws a polyline.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void DrawPolyline (
IList<Point> points
)

Visual Basic [image] Copy Code

Public Sub DrawPolyline( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polyline segments.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.DrawString Method

LayerPresenter.DrawString Method
[image]

Draws a string with the specified attributes.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void DrawString (
string s,
Point point,
Rect bounds,
string fontName,
double fontSize
)

Visual Basic [image] Copy Code

Public Sub DrawString( _
s As String, _
point As Point, _
bounds As Rect, _
fontName As String, _
fontSize As Double _
)

Parameters

s

The string that should be drawn.

point

A Point specifying the string location.

bounds

A Rect specifying the string bounding box.

fontName

The name of the font used to render the string.

fontSize

The size of the font used to render the string.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.FillPolygon Method

LayerPresenter.FillPolygon Method
[image]

Fills a polygon.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void FillPolygon (
IList<Point> points
)

Visual Basic [image] Copy Code

Public Sub FillPolygon( _
points As IList(Of Point) _
)

Parameters

points

A list of points specifying the polygon borders.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.GetPixelSize Method

LayerPresenter.GetPixelSize Method
[image]

Gets the size of a pixel at the current zoom level.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double GetPixelSize ()

Visual Basic [image] Copy Code

Public Function GetPixelSize () As Double

Return Value

A double value specifying the pixel size.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.OnApplyTemplate Method

LayerPresenter.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.ResetClip Method

LayerPresenter.ResetClip Method
[image]

Resets the current clip region.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void ResetClip ()

Visual Basic [image] Copy Code

Public Sub ResetClip ()

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.SetFillColor Method

LayerPresenter.SetFillColor Method
[image]

Sets the current fill color to the specified color from the palette.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetFillColor (
int color
)

Visual Basic [image] Copy Code

Public Sub SetFillColor( _
color As Integer _
)

Parameters

color

The index of the color in the associated palette.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.SetHighlightColor Method

LayerPresenter.SetHighlightColor Method
[image]

Sets the current fill and line colors to the highlight color associated with this canvas.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetHighlightColor ()

Visual Basic [image] Copy Code

Public Sub SetHighlightColor ()

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.SetLineColor Method

LayerPresenter.SetLineColor Method
[image]

Sets the current line color to the line color associated with this canvas.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetLineColor ()

Visual Basic [image] Copy Code

Public Sub SetLineColor ()

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.SetTextAlignment Method

LayerPresenter.SetTextAlignment Method
[image]

Sets the current text alignment.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetTextAlignment (
TextAlignment horzAlignment,
TextAlignment vertAlignment
)

Visual Basic [image] Copy Code

Public Sub SetTextAlignment( _
horzAlignment As TextAlignment, _
vertAlignment As TextAlignment _
)

Parameters

horzAlignment

A TextAlignment member specifying the horizontal alignment.

vertAlignment

A TextAlignment member specifying the vertical alignment.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Properties

LayerPresenter Properties
[image]

Public Properties

Name | Description
Layer | Gets or sets the layer rendered inside this control.
Palette | Gets or sets the color palette used to draw map shapes in this layer.

See Also

LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.Layer Property

LayerPresenter.Layer Property
[image]

Gets or sets the layer rendered inside this control.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Layer<Color, XamlPalette> Layer { get; set; }

Visual Basic [image] Copy Code

Public Property Layer As Layer(Of Color, XamlPalette)

Property Value

An instance of the Layer class.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.Palette Property

LayerPresenter.Palette Property
[image]

Gets or sets the color palette used to draw map shapes in this layer.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public IPalette<Color> Palette { get; set; }

Visual Basic [image] Copy Code

Public Property Palette As IPalette(Of Color)

Property Value

An instance of the XamlPalette class.

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter Fields

LayerPresenter Fields
[image]

Public Fields

Name | Description
LayerProperty | Identifies the Layer dependency property.

See Also

LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.LayerPresenter.LayerProperty Field

LayerPresenter.LayerProperty Field
[image]

Identifies the Layer dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LayerProperty

Visual Basic [image] Copy Code

Public Shared LayerProperty As DependencyProperty

See Also

LayerPresenter Members
LayerPresenter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs Class

MapEventArgs Class
[image]

Provides data for map events.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class MapEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class MapEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Mapping.Wpf.MapEventArgs

See Also

MapEventArgs Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs Members

MapEventArgs Members
Constructors Properties
[image]

Provides data for map events.

The following tables list the members exposed by the MapEventArgs type.

Public Constructors

Name | Description
MapEventArgs | Initializes a new instance of the MapEventArgs class.

Public Properties

Name | Description
Button | Gets or sets a MouseButtons member specifying the mouse button related to the event.
MapElement | Gets or sets the MapElement for which the event is raised.

See Also

MapEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs Constructor

MapEventArgs Constructor
[image]

Initializes a new instance of the MapEventArgs class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public MapEventArgs (
MapElement mapElement,
MouseButton button
)

Visual Basic [image] Copy Code

Public New ( _
mapElement As MapElement, _
button As MouseButton _
)

Parameters

mapElement

A MapElement for which the event is raised.

button

A MouseButtons member specifying the related mouse button.

See Also

MapEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs Properties

MapEventArgs Properties
[image]

Public Properties

Name | Description
Button | Gets or sets a MouseButtons member specifying the mouse button related to the event.
MapElement | Gets or sets the MapElement for which the event is raised.

See Also

MapEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs.Button Property

MapEventArgs.Button Property
[image]

Gets or sets a MouseButtons member specifying the mouse button related to the event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public MouseButton Button { get; set; }

Visual Basic [image] Copy Code

Public Property Button As MouseButton

Property Value

A member of the MouseButton enumeration.

See Also

MapEventArgs Members
MapEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapEventArgs.MapElement Property

MapEventArgs.MapElement Property
[image]

Gets or sets the MapElement for which the event is raised.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public MapElement MapElement { get; set; }

Visual Basic [image] Copy Code

Public Property MapElement As MapElement

Property Value

A MapElement instance.

See Also

MapEventArgs Members
MapEventArgs Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer Class

MapLayer Class
[image]

Represents a map layer containing geometric shapes.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class MapLayer : MapLayerBase<Color, XamlPalette>

Visual Basic [image] Copy Code

Public Class MapLayer
Inherits MapLayerBase(Of Color, XamlPalette)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Layer(Color, XamlPalette)
MindFusion.Mapping.MapLayerBase(Color, XamlPalette)
MindFusion.Mapping.Wpf.MapLayer

See Also

MapLayer Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer Members

MapLayer Members
Constructors Properties
[image]

Represents a map layer containing geometric shapes.

The following tables list the members exposed by the MapLayer type.

Public Constructors

Name | Description
MapLayer | Initializes a new instance of the MapLayer class.

Public Properties

Name | Description
AutoAssignColors | Gets or sets whether colors should be assigned automatically to map elements.
BoundingBox | Layer.BoundingBox override.
DatabaseLocation | Gets or sets the URL of the DBF database file.
LabelField | Gets or sets the name of the label column in the DBF database.
LabelsLoaded | Gets or sets whether the map element labels have been loaded.
MapLocation | Gets or sets the URL of the shapefile map file.

See Also

MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer Constructor

MapLayer Constructor
[image]

Initializes a new instance of the MapLayer class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public MapLayer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer Properties

MapLayer Properties
[image]

Public Properties

Name | Description
AutoAssignColors | Gets or sets whether colors should be assigned automatically to map elements.
BoundingBox | Layer.BoundingBox override.
DatabaseLocation | Gets or sets the URL of the DBF database file.
LabelField | Gets or sets the name of the label column in the DBF database.
LabelsLoaded | Gets or sets whether the map element labels have been loaded.
MapLocation | Gets or sets the URL of the shapefile map file.

See Also

MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.AutoAssignColors Property

MapLayer.AutoAssignColors Property
[image]

Gets or sets whether colors should be assigned automatically to map elements.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public bool AutoAssignColors { get; set; }

Visual Basic [image] Copy Code

Public Property AutoAssignColors As Boolean

Property Value

true to assign colors to map elements automatically, otherwise false. The default value is false.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.BoundingBox Property

MapLayer.BoundingBox Property
[image]

Layer.BoundingBox override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public override Rect BoundingBox { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property BoundingBox As Rect

Property Value

A Rect instance.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.DatabaseLocation Property

MapLayer.DatabaseLocation Property
[image]

Gets or sets the URL of the DBF database file.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public string DatabaseLocation { get; set; }

Visual Basic [image] Copy Code

Public Property DatabaseLocation As String

Property Value

A string specifying the DBF file location.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.LabelField Property

MapLayer.LabelField Property
[image]

Gets or sets the name of the label column in the DBF database.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public string LabelField { get; set; }

Visual Basic [image] Copy Code

Public Property LabelField As String

Property Value

A string specifying the name of a DBF column containing map region labels.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.LabelsLoaded Property

MapLayer.LabelsLoaded Property
[image]

Gets or sets whether the map element labels have been loaded.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public bool LabelsLoaded { get; set; }

Visual Basic [image] Copy Code

Public Property LabelsLoaded As Boolean

Property Value

true if labels have been loaded, otherwise false.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapLayer.MapLocation Property

MapLayer.MapLocation Property
[image]

Gets or sets the URL of the shapefile map file.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public string MapLocation { get; set; }

Visual Basic [image] Copy Code

Public Property MapLocation As String

Property Value

A string specifying the shapefile location.

See Also

MapLayer Members
MapLayer Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Class

MapView Class
[image]

A WPF control used to draw maps.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class MapView : Control

Visual Basic [image] Copy Code

Public Class MapView
Inherits Control

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
MindFusion.Mapping.Wpf.MapView

See Also

MapView Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Members

MapView Members
Constructors Fields Properties Methods Events
[image]

A WPF control used to draw maps.

The following tables list the members exposed by the MapView type.

Public Constructors

Name | Description
MapView | Initializes a new instance of the MapView class.

Public Fields

Name | Description
BaseBoundsProperty | Identifies the BaseBounds dependency property.
LayersProperty | Identifies the Layers dependency property.
MapHeightProperty | Identifies the MapHeight dependency property.
MapWidthProperty | Identifies the MapWidth dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

Public Properties

Name | Description
BaseBounds | Gets or sets the bounding rectangle of the base map.
BaseMap | Gets or sets the Map displayed in the first layer of this view.
Layers | Gets the list of layers displayed in this view.
MapHeight | Returns the height of the base map. Used for binding in the control's Xaml template.
MapWidth | Returns the width of the base map. Used for binding in the control's Xaml template.
ZoomFactor | Gets or sets the current zoom level.

Public Methods

Name | Description
ClientToMap | Converts a point from the control's client coordinates to map coordinates.
MapToClient | Converts a point from the map coordinates to control's client coordinates.
OnApplyTemplate | Control.OnApplyTemplate override.
RaiseMapElementClick | Raises the MapElementClick event.
RaiseMapElementHover | Raises the MapElementHover event.
ScrollTo | Overloaded. Scrolls to a specified map location.
SetZoomFactor | Sets the map zoom level.
Transform | Gets the world-to-screen coordinate system transformation.

Protected Methods

Name | Description
MeasureOverride | FrameworkElement.MeasureOverride override.
OnMapElementClick | Raises the MapElementClick event.
OnMapElementHover | Raises the MapElementHover event.
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override.
OnMouseMove | Control.OnMouseMove override.
OnMouseWheel | Control.OnMouseWheel override.

Public Events

Name | Description
LayerDatabaseLoaded | Raised when the control completes loading layer's database asynchronously.
LayerLoaded | Raised when the control completes loading layer's data asynchronously.
MapElementClick | Raised when the user clicks a map element.
MapElementHover | Raised when the mouse rests over a map element.

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Constructor

MapView Constructor
[image]

Initializes a new instance of the MapView class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public MapView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Methods

MapView Methods
[image]

Public Methods

Name | Description
ClientToMap | Converts a point from the control's client coordinates to map coordinates.
MapToClient | Converts a point from the map coordinates to control's client coordinates.
OnApplyTemplate | Control.OnApplyTemplate override.
RaiseMapElementClick | Raises the MapElementClick event.
RaiseMapElementHover | Raises the MapElementHover event.
ScrollTo | Overloaded. Scrolls to a specified map location.
SetZoomFactor | Sets the map zoom level.
Transform | Gets the world-to-screen coordinate system transformation.

Protected Methods

Name | Description
MeasureOverride | FrameworkElement.MeasureOverride override.
OnMapElementClick | Raises the MapElementClick event.
OnMapElementHover | Raises the MapElementHover event.
OnMouseLeftButtonDown | Control.OnMouseLeftButtonDown override.
OnMouseLeftButtonUp | Control.OnMouseLeftButtonUp override.
OnMouseMove | Control.OnMouseMove override.
OnMouseWheel | Control.OnMouseWheel override.

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ClientToMap Method

MapView.ClientToMap Method
[image]

Converts a point from the control's client coordinates to map coordinates.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Point ClientToMap (
Point point
)

Visual Basic [image] Copy Code

Public Function ClientToMap( _
point As Point _
) As Point

Parameters

point

A System.Windows.Point instance.

Return Value

A MindFusion.Mapping.Point instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapToClient Method

MapView.MapToClient Method
[image]

Converts a point from the map coordinates to control's client coordinates.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Point MapToClient (
Point point
)

Visual Basic [image] Copy Code

Public Function MapToClient( _
point As Point _
) As Point

Parameters

point

A MindFusion.Mapping.Point instance.

Return Value

A System.Windows.Point instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MeasureOverride Method

MapView.MeasureOverride Method
[image]

FrameworkElement.MeasureOverride override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

The available size that this object can give to child objects.

Return Value

The size that this object determines it needs during layout.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnApplyTemplate Method

MapView.OnApplyTemplate Method
[image]

Control.OnApplyTemplate override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public override void OnApplyTemplate ()

Visual Basic [image] Copy Code

Public Overrides Sub OnApplyTemplate ()

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMapElementClick Method

MapView.OnMapElementClick Method
[image]

Raises the MapElementClick event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMapElementClick (
MapEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMapElementClick( _
e As MapEventArgs _
)

Parameters

e

A MapEventArgs instance that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMapElementHover Method

MapView.OnMapElementHover Method
[image]

Raises the MapElementHover event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected virtual void OnMapElementHover (
MapEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMapElementHover( _
e As MapEventArgs _
)

Parameters

e

A MapEventArgs instance that contains the event data.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMouseLeftButtonDown Method

MapView.OnMouseLeftButtonDown Method
[image]

Control.OnMouseLeftButtonDown override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonDown (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonDown( _
e As MouseButtonEventArgs _
)

Parameters

e

The data for the event.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMouseLeftButtonUp Method

MapView.OnMouseLeftButtonUp Method
[image]

Control.OnMouseLeftButtonUp override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseLeftButtonUp (
MouseButtonEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseLeftButtonUp( _
e As MouseButtonEventArgs _
)

Parameters

e

The data for the event.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMouseMove Method

MapView.OnMouseMove Method
[image]

Control.OnMouseMove override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseMove (
MouseEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseMove( _
e As MouseEventArgs _
)

Parameters

e

The data for the event.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.OnMouseWheel Method

MapView.OnMouseWheel Method
[image]

Control.OnMouseWheel override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override void OnMouseWheel (
MouseWheelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnMouseWheel( _
e As MouseWheelEventArgs _
)

Parameters

e

The data for the event.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.RaiseMapElementClick Method

MapView.RaiseMapElementClick Method
[image]

Raises the MapElementClick event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void RaiseMapElementClick (
MapElement mapElement,
MouseButton button
)

Visual Basic [image] Copy Code

Public Sub RaiseMapElementClick( _
mapElement As MapElement, _
button As MouseButton _
)

Parameters

mapElement

The clicked map element.

button

The mouse button.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.RaiseMapElementHover Method

MapView.RaiseMapElementHover Method
[image]

Raises the MapElementHover event.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void RaiseMapElementHover (
MapElement mapElement
)

Visual Basic [image] Copy Code

Public Sub RaiseMapElementHover( _
mapElement As MapElement _
)

Parameters

mapElement

The hovered map element.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ScrollTo Method

MapView.ScrollTo Method
[image]

Scrolls to a specified map location.

Overload List

Name | Description
MapView.ScrollTo (Double, Double) | Scrolls to the specified map location and center it inside the control.
MapView.ScrollTo (Point) | Scrolls to the specified map location and center it inside the control.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ScrollTo Method (Double, Double)

MapView.ScrollTo Method (Double, Double)
See Also
[image]

Scrolls to the specified map location and center it inside the control.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void ScrollTo (
double latitude,
double longitude
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
latitude As Double, _
longitude As Double _
)

Parameters

latitude

A double value specifying the location latitude.

longitude

A double value specifying the location longitude.

See Also

ScrollTo Method Overload List
MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace
SetZoomFactor Method


MindFusion.Mapping.Wpf.MapView.ScrollTo Method (Point)

MapView.ScrollTo Method (Point)
See Also
[image]

Scrolls to the specified map location and center it inside the control.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void ScrollTo (
Point point
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
point As Point _
)

Parameters

point

A Point instance specifying a map location.

See Also

ScrollTo Method Overload List
MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace
SetZoomFactor Method


MindFusion.Mapping.Wpf.MapView.SetZoomFactor Method

MapView.SetZoomFactor Method
[image]

Sets the map zoom level.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public void SetZoomFactor (
double zoomFactor,
Point pivotPoint
)

Visual Basic [image] Copy Code

Public Sub SetZoomFactor( _
zoomFactor As Double, _
pivotPoint As Point _
)

Parameters

zoomFactor

A double value specifying the new zoom level; 1 is for 100% zoom.

pivotPoint

A Point whose screen location should not change after zoom.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace
ScrollTo Method
ZoomFactor Property


MindFusion.Mapping.Wpf.MapView.Transform Method

MapView.Transform Method
[image]

Gets the world-to-screen coordinate system transformation.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public GeneralTransform Transform ()

Visual Basic [image] Copy Code

Public Function Transform () As GeneralTransform

Return Value

A GeneralTransform instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Properties

MapView Properties
[image]

Public Properties

Name | Description
BaseBounds | Gets or sets the bounding rectangle of the base map.
BaseMap | Gets or sets the Map displayed in the first layer of this view.
Layers | Gets the list of layers displayed in this view.
MapHeight | Returns the height of the base map. Used for binding in the control's Xaml template.
MapWidth | Returns the width of the base map. Used for binding in the control's Xaml template.
ZoomFactor | Gets or sets the current zoom level.

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.BaseBounds Property

MapView.BaseBounds Property
[image]

Gets or sets the bounding rectangle of the base map.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Rect BaseBounds { get; set; }

Visual Basic [image] Copy Code

Public Property BaseBounds As Rect

Property Value

A Rect instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.BaseMap Property

MapView.BaseMap Property
[image]

Gets or sets the Map displayed in the first layer of this view.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Map BaseMap { get; set; }

Visual Basic [image] Copy Code

Public Property BaseMap As Map

Property Value

An instance of the Map class.

Remarks

Assigning a map to this property is a shortcut to creating a MapLayer, setting it as the first layer in the view and setting its Map to the specified value.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.Layers Property

MapView.Layers Property
[image]

Gets the list of layers displayed in this view.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public LayerList Layers { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Layers As LayerList

Property Value

A LayerList instance.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapHeight Property

MapView.MapHeight Property
[image]

Returns the height of the base map. Used for binding in the control's Xaml template.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double MapHeight { get; set; }

Visual Basic [image] Copy Code

Public Property MapHeight As Double

Property Value

A double value specifying the height of the base map.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapWidth Property

MapView.MapWidth Property
[image]

Returns the width of the base map. Used for binding in the control's Xaml template.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double MapWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MapWidth As Double

Property Value

A double value specifying the width of the base map.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ZoomFactor Property

MapView.ZoomFactor Property
[image]

Gets or sets the current zoom level.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

A double value specifying the zoom level. The default value is 1.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace
ScrollTo Method
SetZoomFactor Method


MindFusion.Mapping.Wpf.MapView Events

MapView Events
[image]

Public Events

Name | Description
LayerDatabaseLoaded | Raised when the control completes loading layer's database asynchronously.
LayerLoaded | Raised when the control completes loading layer's data asynchronously.
MapElementClick | Raised when the user clicks a map element.
MapElementHover | Raised when the mouse rests over a map element.

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.LayerDatabaseLoaded Event

MapView.LayerDatabaseLoaded Event
[image]

Raised when the control completes loading layer's database asynchronously.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LayerEventArgs> LayerDatabaseLoaded

Visual Basic [image] Copy Code

Public Event LayerDatabaseLoaded As EventHandler(Of LayerEventArgs)

Event Data

LayerDatabaseLoaded event handlers receive an argument of type LayerEventArgs.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.LayerLoaded Event

MapView.LayerLoaded Event
[image]

Raised when the control completes loading layer's data asynchronously.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<LayerEventArgs> LayerLoaded

Visual Basic [image] Copy Code

Public Event LayerLoaded As EventHandler(Of LayerEventArgs)

Event Data

LayerLoaded event handlers receive an argument of type LayerEventArgs.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapElementClick Event

MapView.MapElementClick Event
[image]

Raised when the user clicks a map element.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<MapEventArgs> MapElementClick

Visual Basic [image] Copy Code

Public Event MapElementClick As EventHandler(Of MapEventArgs)

Event Data

MapElementClick event handlers receive an argument of type MapEventArgs.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapElementHover Event

MapView.MapElementHover Event
[image]

Raised when the mouse rests over a map element.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public event EventHandler<MapEventArgs> MapElementHover

Visual Basic [image] Copy Code

Public Event MapElementHover As EventHandler(Of MapEventArgs)

Event Data

MapElementHover event handlers receive an argument of type MapEventArgs.

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView Fields

MapView Fields
[image]

Public Fields

Name | Description
BaseBoundsProperty | Identifies the BaseBounds dependency property.
LayersProperty | Identifies the Layers dependency property.
MapHeightProperty | Identifies the MapHeight dependency property.
MapWidthProperty | Identifies the MapWidth dependency property.
ZoomFactorProperty | Identifies the ZoomFactor dependency property.

See Also

MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.BaseBoundsProperty Field

MapView.BaseBoundsProperty Field
[image]

Identifies the BaseBounds dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty BaseBoundsProperty

Visual Basic [image] Copy Code

Public Shared BaseBoundsProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.LayersProperty Field

MapView.LayersProperty Field
[image]

Identifies the Layers dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty LayersProperty

Visual Basic [image] Copy Code

Public Shared LayersProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapHeightProperty Field

MapView.MapHeightProperty Field
[image]

Identifies the MapHeight dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty MapHeightProperty

Visual Basic [image] Copy Code

Public Shared MapHeightProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.MapWidthProperty Field

MapView.MapWidthProperty Field
[image]

Identifies the MapWidth dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static DependencyProperty MapWidthProperty

Visual Basic [image] Copy Code

Public Shared MapWidthProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.MapView.ZoomFactorProperty Field

MapView.ZoomFactorProperty Field
[image]

Identifies the ZoomFactor dependency property.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public static readonly DependencyProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZoomFactorProperty As DependencyProperty

See Also

MapView Members
MapView Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox Class

Viewbox Class
[image]

Defines a decorator that can stretch and scale a single child to fill the available space.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class Viewbox : Decorator

Visual Basic [image] Copy Code

Public Class Viewbox
Inherits Decorator

Inheritance Hierarchy

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Decorator
MindFusion.Mapping.Wpf.Viewbox

See Also

Viewbox Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox Members

Viewbox Members
Constructors Methods
[image]

Defines a decorator that can stretch and scale a single child to fill the available space.

The following tables list the members exposed by the Viewbox type.

Public Constructors

Name | Description
Viewbox | Initializes a new instance of the Viewbox class.

Protected Methods

Name | Description
ArrangeOverride | Decorator.ArrangeOverride override.
MeasureOverride | Decorator.MeasureOverride override.

See Also

Viewbox Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox Constructor

Viewbox Constructor
[image]

Initializes a new instance of the Viewbox class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Viewbox ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Viewbox Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox Methods

Viewbox Methods
[image]

Protected Methods

Name | Description
ArrangeOverride | Decorator.ArrangeOverride override.
MeasureOverride | Decorator.MeasureOverride override.

See Also

Viewbox Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox.ArrangeOverride Method

Viewbox.ArrangeOverride Method
[image]

Decorator.ArrangeOverride override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override Size ArrangeOverride (
Size arrangeSize
)

Visual Basic [image] Copy Code

Protected Overrides Function ArrangeOverride( _
arrangeSize As Size _
) As Size

Parameters

arrangeSize

The Size this element uses to arrange its child content.

Return Value

The Size that represents the arranged size of this element and its child.

See Also

Viewbox Members
Viewbox Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.Viewbox.MeasureOverride Method

Viewbox.MeasureOverride Method
[image]

Decorator.MeasureOverride override.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
Size availableSize
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
availableSize As Size _
) As Size

Parameters

availableSize

An upper limit Size that should not be exceeded.

Return Value

The target Size of the element.

See Also

Viewbox Members
Viewbox Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter Class

VisibilityConverter Class
[image]

Converts boolean property values to Visibility values.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class VisibilityConverter : IValueConverter

Visual Basic [image] Copy Code

Public Class VisibilityConverter
Implements IValueConverter

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Wpf.VisibilityConverter

See Also

VisibilityConverter Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter Members

VisibilityConverter Members
Constructors Methods
[image]

Converts boolean property values to Visibility values.

The following tables list the members exposed by the VisibilityConverter type.

Public Constructors

Name | Description
VisibilityConverter | Initializes a new instance of the VisibilityConverter class.

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Not implemented.

See Also

VisibilityConverter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter Constructor

VisibilityConverter Constructor
[image]

Initializes a new instance of the VisibilityConverter class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public VisibilityConverter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

VisibilityConverter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter Methods

VisibilityConverter Methods
[image]

Public Methods

Name | Description
Convert | Implements IValueConverter.Convert.
ConvertBack | Not implemented.

See Also

VisibilityConverter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter.Convert Method

VisibilityConverter.Convert Method
[image]

Implements IValueConverter.Convert.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Object Convert (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

VisibilityConverter Members
VisibilityConverter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.VisibilityConverter.ConvertBack Method

VisibilityConverter.ConvertBack Method
[image]

Not implemented.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Object ConvertBack (
Object value,
Type targetType,
Object parameter,
CultureInfo culture
)

Visual Basic [image] Copy Code

Public Function ConvertBack( _
value As Object, _
targetType As Type, _
parameter As Object, _
culture As CultureInfo _
) As Object

Parameters

value

targetType

parameter

culture

Return Value

See Also

VisibilityConverter Members
VisibilityConverter Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette Class

XamlPalette Class
[image]

Represents a palette of colors.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class XamlPalette : IPalette<Color>

Visual Basic [image] Copy Code

Public Class XamlPalette
Implements IPalette(Of Color)

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Wpf.XamlPalette

See Also

XamlPalette Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette Members

XamlPalette Members
Constructors Properties
[image]

Represents a palette of colors.

The following tables list the members exposed by the XamlPalette type.

Public Constructors

Name | Description
XamlPalette | Initializes a new instance of the XamlPalette class.

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette Constructor

XamlPalette Constructor
[image]

Initializes a new instance of the XamlPalette class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public XamlPalette ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette Properties

XamlPalette Properties
[image]

Public Properties

Name | Description
FillColors | Gets or sets an array of fill colors.
HighlightColor | Gets or sets the highlight color.
LineColor | Gets or sets the line color.

See Also

XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette.FillColors Property

XamlPalette.FillColors Property
[image]

Gets or sets an array of fill colors.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Color[] FillColors { get; set; }

Visual Basic [image] Copy Code

Public Property FillColors As Color()

Property Value

An array of System.Windows.Media.Color objects.

See Also

XamlPalette Members
XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette.HighlightColor Property

XamlPalette.HighlightColor Property
[image]

Gets or sets the highlight color.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Color HighlightColor { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightColor As Color

Property Value

A System.Windows.Media.Color instance.

See Also

XamlPalette Members
XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlPalette.LineColor Property

XamlPalette.LineColor Property
[image]

Gets or sets the line color.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Color LineColor { get; set; }

Visual Basic [image] Copy Code

Public Property LineColor As Color

Property Value

A System.Windows.Media.Color instance.

See Also

XamlPalette Members
XamlPalette Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform Class

XamlTransform Class
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public class XamlTransform : ITransform

Visual Basic [image] Copy Code

Public Class XamlTransform
Implements ITransform

Inheritance Hierarchy

System.Object
MindFusion.Mapping.Wpf.XamlTransform

See Also

XamlTransform Members
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform Members

XamlTransform Members
Constructors Methods
[image]

Represents a geometrical transform used to convert world coordinates to screen coordinates.

The following tables list the members exposed by the XamlTransform type.

Public Constructors

Name | Description
XamlTransform | Initializes a new instance of the XamlTransform class.

Public Methods

Name | Description
DeviceToWorld | Converts a point from screen to world coordinates.
WorldToDevice | Converts a point from world to screen coordinates.

See Also

XamlTransform Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform Constructor

XamlTransform Constructor
[image]

Initializes a new instance of the XamlTransform class.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public XamlTransform (
GeneralTransform transform
)

Visual Basic [image] Copy Code

Public New ( _
transform As GeneralTransform _
)

Parameters

transform

A GeneralTransform instance specifying an affine transformation.

See Also

XamlTransform Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform Methods

XamlTransform Methods
[image]

Public Methods

Name | Description
DeviceToWorld | Converts a point from screen to world coordinates.
WorldToDevice | Converts a point from world to screen coordinates.

See Also

XamlTransform Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform.DeviceToWorld Method

XamlTransform.DeviceToWorld Method
[image]

Converts a point from screen to world coordinates.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Point DeviceToWorld (
Point point
)

Visual Basic [image] Copy Code

Public Function DeviceToWorld( _
point As Point _
) As Point

Parameters

point

A System.Windows.Point specifying screen coordinates.

Return Value

A Point containing the corresponding world coordinates.

See Also

XamlTransform Members
XamlTransform Class
MindFusion.Mapping.Wpf Namespace


MindFusion.Mapping.Wpf.XamlTransform.WorldToDevice Method

XamlTransform.WorldToDevice Method
[image]

Converts a point from world to screen coordinates.

Namespace: MindFusion.Mapping.Wpf
Assembly: MindFusion.Mapping.Wpf

Syntax

C# [image] Copy Code

public Point WorldToDevice (
Point point
)

Visual Basic [image] Copy Code

Public Function WorldToDevice( _
point As Point _
) As Point

Parameters

point

A Point specifying world coordinates.

Return Value

A System.Windows.Point containing the corresponding screen coordinates.

See Also

XamlTransform Members
XamlTransform Class
MindFusion.Mapping.Wpf Namespace


Online Resources

The following websites host free map files in ESRI Shapefile format:

Natural Earth
http://www.naturalearthdata.com

U.S. Census Bureau
http://www.census.gov/geo/www/cob/bdy_files.html

Map Library
http://www.maplibrary.org/

MapCruzin
http://www.mapcruzin.com/download-free-arcgis-shapefiles.htm

OpenStreetMap Shapefiles
http://wiki.openstreetmap.org/wiki/Shapefiles

UN Second Administrative Level Boundaries
http://www.unsalb.org/

Centers for Disease Control and Prevention
http://wwwn.cdc.gov/epiinfo/script/shapefiles.aspx

Free Spatial Data as DIVA-GIS
http://www.diva-gis.org/Data


MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming |
Diagramming for WPF | Product Information Download
Diagramming for Silverlight | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for .NET Compact | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download

Charting |
Charting for WPF | Product Information Download
Charting for WinForms | Product Information Download
Charting for ASP.NET | Product Information Download

Scheduling |
Scheduling for WinForms | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for .NET Compact | Product Information Download
Scheduling for WPF | Product Information Download
Scheduling for Silverlight | Product Information Download
Scheduling for Java Swing | Product Information Download

Reporting |
Reporting for WinForms | Product Information Download
Reporting for WPF | Product Information Download
Reporting for Silverlight | Product Information Download

Mapping |
Mapping for WinForms | Product Information Download
Mapping for WPF | Product Information Download
Mapping for Silverlight | Product Information Download

Suites |
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Java FX | Product Information Download
Pack for Scheduling | Product Information Download
Pack for Silverlight | Product Information Download


Acknowledgements

The map files installed under the 50m* and 110m* folders contain public domain maps from http://www.naturalearthdata.com [image] . They correspond to the medium and small scale vector sets from that site. An additional high-resolution large scale data set can be downloaded from http://www.naturalearthdata.com/downloads/10m-cultural-vectors/ [image] . The maps are free to use in any kind of project as outlined at http://www.naturalearthdata.com/about/terms-of-use/ [image] .

The country map files installed with this library were created by MindFusion from public domain data, mostly from http://www.naturalearthdata.com [image] .

Landmark icons used in sample project are from the Tourism icon set from http://iconka.com/free/ [image] .