Introduction

MindFusion.Diagramming for .NET MAUI is a general-purpose software component that can be used to display various types of diagrams and charts, in many different formats. It is implemented as a .NET MAUI control and can be easily integrated into applications targeting Windows, Android, iOS and Macos. By providing your software with ready to use capabilities for visualizing and editing relational data, MindFusion.Diagramming for .NET MAUI saves you from hundreds of hours of coding and debugging efforts.

MindFusion.Diagramming for .NET MAUI can give graphical representation to:

  • Workflow processes
  • Class relationships
  • Graphs and networks
  • Entity-relationship / database diagrams
  • IVR systems
  • Industrial automation processes
  • Genealogy trees
  • Algorithms and flowcharts
  • Organizational charts
  • XML documents
  • Classification hierarchies
  • And much more

MindFusion.Diagramming for .NET MAUI provides intuitive user-interaction model for creating or editing diagrams. In addition, its programmatic interface places at your disposal many useful functions, such as XML serialization, path-finding and automatic layout algorithms.

Diagramming for .NET MAUI Guide © 2023 MindFusion


General Information

The MindFusion.Diagramming for .NET MAUI Component

  • Redistribution is royalty free
  • Can be purchased with source code
  • Is written in C#
  • Implements the Document/View architecture

User Interaction

  • Several user interaction modes
  • Scrolling and zooming
  • Panning
  • Automatic scrolling while dragging items with the mouse
  • Alignment to grid
  • Multiple selection
  • Docking points can be defined for nodes

Programming

  • Programmatic access to the diagram elements
  • Numerous properties for customizing appearance and behavior
  • Numerous utility methods
  • Path finding and cycle detection
  • Rich event set

Diagram Elements

  • More than 100 predefined node shapes
  • Ability to define custom shapes
  • Rotation of nodes at arbitrary angles
  • Container nodes
  • Tables with unlimited number of rows and columns
  • Table cells can span several columns and rows
  • Display hierarchical data in TreeView nodes
  • Assign diagram items to layers
  • Sections of table rows can be expanded or collapsed
  • Links can comprise multiple segments
  • Link segments can be straight lines or curves
  • Display multiple labels per link
  • Support for custom node and link types

Automatic Layout

  • Spring-Embedder graph layout
  • Directional tree layout
  • Horizontal/vertical binary tree layout
  • Radial tree layout
  • Fractal tree layout
  • Layered graph layout
  • Grid layout
  • Simulated Annealing graph layout
  • One-way graph layout
  • Orthogonal graph layout
  • Circular graph layout
  • Orthogonal link router
  • Source code flowchart layout
  • Decision flowchart layout
  • Process diagrams layout
  • Tree map layout
  • Swimlane diagrams layout
  • Topological graph layout
  • Triangular graph layout
  • Hierarchical graph layout
  • Cascading graph layout
  • Multi-level graph layout
  • Automatic link routing

Appearance

  • Styles and themes
  • Nodes can display images and text
  • Various text alignment styles
  • Customizable fonts and colors
  • Custom painting of nodes
  • Shadows
  • Z-order
  • Rich choice of pen and brush styles
  • Transparent nodes
  • Invisible nodes
  • Node effects
  • A background lane grid

Behavior

  • Lock diagram elements
  • Read-only mode supported
  • Tables can be scrolled
  • Collapse and expand hierarchy branches
  • In-place text editing
  • Dynamic positioning of links relative to connected nodes

Link Diagram Items

  • Nodes to nodes
  • Table rows to table rows
  • Nodes to table rows
  • Unconnected links

Hierarchical Grouping

  • Attaching nodes to other nodes
  • Attaching nodes to link control points
  • Attaching nodes to link segments


Getting Started

Diagramming for .NET MAUI Guide © 2023 MindFusion


Add Nuget Package

In order to integrate Diagramming for MAUI into your Visual Studio project, select the Manage Nuget Packages from Project menu:

Open the Browse tab, and enter MindFusion.Diagramming.Maui in the search field. Select the MindFusion.Diagramming.Maui package and click Install.

Once the package is installed, you should be able to add controls from the library to your UI (DiagramView, NodeListView, etc).


Integrate Diagramming API into a project

After following the previous topic, you should be able to use MindFusion.Diagramming classes in your project.

Initialize the library

Call the UseMindFusionDiagramming extension from CreateMauiApp to configure the library:

C# [image] Copy Code

namespace DiagramMauiApp;

using MindFusion.Diagramming;

public static class MauiProgram
{
public static MauiApp CreateMauiApp()
{
var builder = MauiApp.CreateBuilder();
builder
.UseMauiApp<App>()
.UseMindFusionDiagramming()
.......);

return builder.Build();
}
}

Add a DiagramView to Xaml UI

  1. Add an xmlns attribute to the root Xaml object and set its value to http://mindfusion.eu/diagramming/maui, which lets you create objects from the Diagramming namespace in Xaml.
  2. Add a DiagramView element, and set its Name attribute to a variable name that lets you access the instance from code-behind.

Xaml [image] Copy Code

<?xml version="1.0" encoding="utf-8" ?>
<ContentPage
xmlns="http://schemas.microsoft.com/dotnet/2021/maui"
xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml"
xmlns:diag="http://mindfusion.eu/diagramming/maui"
x:Class="DiagramMauiApp.MainPage">

<Grid>

<diag:DiagramView x:Name="diagView" />

</Grid>

</ContentPage>

Create diagram items

You can create nodes and links programmatically either by calling Factory methods, or by instantiating objects of respective class and adding them to Items collection:

C# [image] Copy Code

public MainPage()
{
InitializeComponent();

var df = diagView.Diagram.Factory;

var node1 = df.CreateShapeNode(10, 10, 30, 30);
node1.Text = "Hello";

var node2 = df.CreateShapeNode(60, 25, 30, 30);
node2.Text = ".NET MAUI";

df.CreateDiagramLink(node1, node2);
}

DiagramView interaction

Set the value of the Behavior property, which defines how the control interprets touch or mouse input. The default value LinkShapes specifies that users can draw shape nodes and connect them with links. Other Link* and Draw* modes allow drawing different types of nodes (TableNode, ContainerNode, etc). Modes such as Modify, PanAndModify, MoveNodes, SelectOnly allow users to interact with existing items, but not draw new ones on the canvas.

Browse the other sections of this help file to learn more about the functionality provided by the MindFusion.Diagramming classes, methods and properties. Follow the tutorials to learn how to populate the diagram model programmatically.


User Interaction

Most likely an application will use the Diagram control to enable users to interactively create diagrams, flowcharts and other kinds of presentation documents. A user composes or edits a diagram by drawing its elements on the diagram canvas area. Using touch ot mouse, users draw shapes and links, possibly connecting them in complex hierarchies, graphs, trees or other structures they might need.

Creating New Items

New items can be created by drawing them using touch device ot mouse. During drag interaction, the view is updated to show what the new item would look like at the pointer location. If the operation cannot be completed at the current position, mouse cursor changes to a crossed out circle. When the user releases touch or button, the item is created and added to the diagram. The control does not let users create very tiny nodes which would be hard to select and modify. By default links can be drawn only between nodes, unless the AllowUnconnectedLinks property is enabled. Users can cancel item creation by pressing the right mouse button while drawing.

A node can also be created via drag-and-drop from the NodeListView control. Its instance can be added to the Xaml page using <NodeListView> tag. Specify a collection of prototype nodes that should be shown in the list view by calling AddNodes or AddNode methods.

Modifying Items

A user modifies an item by dragging its adjustment handles, or using pinch gesture to scale and rotate nodes. In order to use adjustment handles, an item should first be selected by tapping it. Adjustment handles appear around the item to indicate that now it can be moved or resized. Number and functionality of those handles depend on the item type and the value of the corresponding HandlesStyle property.

Multi-touch Support

  • If MultiTouchZoom property is enabled (default), the view can be zoomed or panned using two-touch pinch / flick gestures.
  • If MultiTouchModify property is enabled (default), diagram nodes can be moved, scaled and rotated using two-touch pinch / flick gestures.
  • If MultiTouchZoom property is disabled, each touch draws diagram items corresponding to current behavior.
  • If MultiTouchModify property is disabled, each touch started from a node draws a diagram link.

Latter modes can be used for collaborative whiteboarding / classroom scenarios.

Node Handles

Usually nodes have nine adjustment handles. The one at the center can be used to move the node. When dragged, each corner handle resizes the node by moving the two edges adjacent to the corresponding corner. The edge handles placed at the center of each side can be used to resize a node either horizontally or vertically. Shape nodes can be rotated using an additional round handle drawn above them. Each handle can be enabled or disabled by setting or clearing the respective bit in EnabledHandles.

Modifying a Link

Variety and behavior of link adjustment handles depend on the link's Shape and SegmentCount. Control-points stay at both ends of each segment that constitutes a link. The library offers three link styles. Following sections discuss how to modify links of each style.

  • The first style called Polyline defines links that consist of a series of straight segments drawn between control-points. There are no restrictions as to the number of segments. Dragging a control-point modifies each segment adjacent to the point. If the AllowSplitLinks property is enabled, users are allowed to insert new control points or to remove existing ones. Inserting a control point is done by pressing the left mouse button over a segment and dragging. The new point appears at the mouse location and splits the pointed segment in two.
  • If link's style is set to Bezier, each segment has 4 manipulation handles that define a curve. Each curve goes through the end-points, which are shaped as circles. Bend of the curve is defined by the middle two points shaped as rectangles. If a user drags an end-point modification handle, the adjacent control points will be moved with same translation vector as that of the end-point. If a bend control point is dragged, the symmetric control point of the neighboring curve is also moved to ensure the two stay on the same line with the end-point and on the same distance from it.
  • Cascading links consist of straight horizontal and vertical segments, each one orthogonal to its neighbors. If a control-point is dragged, the segments adjacent to it are moved and resized preserving their orthogonal orientation to each other. If the AllowSplitLinks property is enabled, users are allowed to insert new control points to Cascading links or remove existing ones. The orientation of the link segments can be changed if CascadeOrientation is set to Auto.

Selecting Items

Individual item can be selected by tapping it. Multiple items can be selected by drawing a selection lasso when Behavior is set to SelectOnly or Modify. Selection state can also be toggled from raidal menu displayed using a long-press gesture.


Programming Interface Overview

The next few chapters give you an overview of all features, grouped by functionality. Hyperlinks refer to the detailed description of methods and properties of each class.


Diagram Structure

The following topics are contained within this topic:

Standard Item Types
Information about the standard MindFusion.Diagramming for .NET MAUI item types, such as ShapeNode, TableNode and DiagramLink.

Custom Item Types
Information on how to implement and use custom item types.

Creating and Deleting Items
Information on how to create and delete items both interactively and programmatically.

Accessing Items
Information about how to access the diagram items, how to get the selected items and how to find particular items in the diagram according to a specific criteria.

Attaching and Grouping Items
Information about how to group items in order to create hierarchies of dependent objects in MindFusion.Diagramming for .NET MAUI.

Layers
Information about how to organize items in layers.

Collapsing and Expanding Tree Branches
Information on how to enable expanding diagram nodes.


Standard Item Types

Diagram elements in MindFusion.Diagramming for .NET MAUI are represented by ShapeNode, TableNode, ContainerNode, TreeViewNode, and DiagramLink instances. Combined and linked together, they can form complex data structures such as process or entity-relationship diagrams, class hierarchies, networks and graphs. Each of their rich features can be customized through numerous methods and properties. MindFusion.Diagramming for .NET MAUI also offers intuitive user interface for drawing and editing diagram items interactively.

Shape Nodes

Shape nodes can represent geometric shapes, flowchart elements, icons in network diagrams, and so on. They can display both graphics and text in different fonts, sizes and colors. There are over 100 predefined node shapes (you can preview them here) and apart from them, MindFusion.Diagramming for .NET MAUI offers an easy way to define custom shapes. Shape nodes can be rotated, either interactively using the round selection handle drawn above them, or programmatically using the RotationAngle property. ShapeNode appearance can be customized further using several types of custom painting. The first type gives you full control over the painting. With the second one your painting code is performed additionally to the basic painting. The third one performs standard drawing of nodes and custom drawing of their shadows.

Table Nodes

Tables can be used to represent table schemas in database diagrams or classes in class-hierarchies. A table contains cells arranged in a grid, and every cell can display text and/or image. Cells can span several rows and columns as set in the RowSpan and ColumnSpan properties. Cells, columns and rows can be customized in various ways – there are properties available for setting their extents, style, image and text alignment. Tables' dimensions can be programmatically changed; inserting, appending or deleting rows and columns can be done in a very comprehensive, intuitive way whenever you might need it. Tables can also display background images and graphics.

Free-form Nodes

A FreeFormNode collects all points from users' mouse or touch input and displays them as node's outline. To let users draw free-form nodes interactively, set Behavior to DrawFreeForms. Use the Points property of FreeFormNode to get or set outline points programmatically. If the Closed property is set, the node is drawn as a closed shape and its interior filled, or otherwise the node is drawn as a poly-line. If the distance between first and last points drawn by user is shorter than AutoCloseDistance, the node gets closed automatically.

Container Nodes

A ContainerNode can contain other diagram nodes. When a container is moved, the contained nodes move too. Containers can be folded to hide the contained nodes, and unfolded back to show them again. Nodes inside a container can be linked to nodes both inside and outside of it. When a container is folded, the links connected to contained nodes point to the container outlines. Containers can be nested one within another to unlimited depth.

TreeView Nodes

The TreeViewNode class represents nodes that can display hierarchical data. The root items displayed in the node can be accessed through the RootItems property. New items can be added to and removed from the returned collection. The root items can have child items on their own and so on. For more information, refer to the TreeViewItem class.

Links

Links are used to represent various types of connections and relations in diagrams. MindFusion.Diagramming for .NET MAUI offers three basic link types:

  • polyline links composed of straight-line segments;
  • curved links composed of Bézier-spline segments;
  • links composed of horizontal and vertical segments, alternating their orientation so that every segment is orthogonal to its neighbor.

A link can be connected to a node at each of the link's ends. It is also possible to have unconnected links – having one or both of their ends not connected to nodes. Some customizable link's properties are: arrowheads, style, color, text, pen width and style, modification behavior and number of segments.


Custom Item Types

You can create your own item types by deriving from the DiagramNode and DiagramLink classes or their successors such as TableNode, ContainerNode, and so on. This lets you add custom data fields to the diagram items, and implement custom visualization and interaction functionality.

Serialization

If you add custom fields to your item class, you will probably want their values saved when saving diagram files, and restored when loading files. To enable this, override the SaveToXml and LoadFromXml methods of the DiagramItem class, which let you serialize the properties in a XDocument object.

Rendering

If you need to provide custom rendering for your items, override the Draw and DrawShadow methods. They receive as an argument an object that implements the IGraphics interface, which provides methods for drawing vector graphics, text and images.

User interaction

To let the user draw items from a custom class, set the Behavior property of the diagram view to Custom, and set the CustomBehavior property to a BaseTouchBehavior-derived instance, which implements the details of the interaction.


Creating and Deleting Items

Creating Items Programmatically

In order to add a new node or link to a diagram, create an instance of the item class via the new operator and add it to the diagram's Nodes or Links collection. This works the same way for adding both items from your custom class or ones from the MindFusion.Diagramming for .NET MAUI predefined types.

There are several shortcut methods provided for creating instances of the predefined node and link types. The methods are members of the diagram's Factory object:

  • The CreateShapeNode methods create a ShapeNode at a specified position.
  • The CreateTableNode methods create a TableNode at a specified position. Tables have a method that connects them with other tables called AddRelation.
  • The CreateContainerNode methods create a ContainerNode at a specified position.
  • The CreateTreeViewNode methods create a TreeViewNode at a specified position.
  • There are several overloads of the CreateDiagramLink method that allow connecting two nodes of the same type or of different types.

Drawing New Items

Users can draw diagram elements with the mouse. The Behavior property specifies what type of elements should be created when a user starts drawing. When a user starts dragging, an item is created and an initialization event is raised to let you customize the item appearance before showing it on the screen. The initialization events include ones such as InitializeNode, InitializeLink, and so on. While items are being drawn, the control raises validation events such as NodeCreating to let you validate the operation and prevent creating items at a specific location. When the user releases the touch, the item is added to the collection that contains items from the same type (for example Nodes) and an event is raised, for example NodeCreated.

Deleting Items

Call the Remove method of the Nodes or Links collection to delete an item from the diagram. The ClearAll method clears diagram contents by deleting all items. A shortcut for removing a link between two tables is provided by the BreakRelation method.


Accessing Items

One of the most common tasks when using the component is iterating over all items in the diagram document or navigating through the connections between items – from a node to the incoming or outgoing links, or from a link to its origin and destination nodes. To enumerate items of a diagram use the Items, Links or Nodes collections. The nodes that a link connects are referenced by the link's Destination and Origin properties. To access the links that are connected to a node, use its IncomingLinks and OutgoingLinks collections. The first collection contains references to all links pointing to the node, the second – to the links that start from it. Links can connect to rows of a table; to find such links use table's Rows collection and the IncomingLinks and OutgoingLinks collections. A shortcut for accessing the other end of a relation in entity-relationship diagrams is provided by the RelatedOneToMany and RelatedManyToOne properties of the Row class.

Selected Items

If only one item is selected, it is considered the active item and can be accessed with the ActiveItem property. The type of this property is DiagramItem; you can get the actual type of the selected item through reflection. Multiple items can be selected when dragging by selecting the appropriate behavior. Multiple selection is represented by the Selection property of the Diagram class. The Selection object provides collections to access the selected Links and Nodes.

Finding Items

You can search for diagram items by their Tag or Id using the FindLink, FindNode, FindLinkById and FindNodeById methods. Tag and id objects are compared by calling the Equals method of the System.Object class. Thus if they are of value type, they are compared by value (that is bitwise equality). If they are of reference type their Equals method is used. If there are more items with the same tag, the first one will be returned. If no item with the specified tag or id exists, a null reference will be returned.


Attaching and Grouping Items

MindFusion.Diagramming for .NET MAUI allows attaching a node to another diagram element, establishing a subordinate-master relationship between the two items. To attach an node to another node, use the AttachToNode method. To attach a node to a link, call one of the AttachToLink overloads. When a master element is moved or resized, any subordinated node follows it, so that the initial distance between the two items stays constant. This happens both when a user moves the master item around, and when the item position is changed using a method or a property.

Possible Uses

  • Attach a Transparent shape node to another item and set its Text, so that the shape node acts as an additional label assigned to the main item.
  • Attach a shape node to another item and set the node's Image, so it acts as an additional icon displayed inside or near the main item.
  • Attach a shape node or a table to another item and handle the NodeClicked or similar events to perform some action on the main item. This makes the subordinated node act as a button or another type of UI element attached to the main item.
  • In all previous cases, the Locked property can be set for attached nodes, which are used only as decorations embellishing the main item. That prevents users from selecting, modifying or drawing links to the subordinates.
  • Attach child elements in a tree branch to the branch root, so that when a user moves a tree node, the node's children moves simultaneously with it. Modifying an item in such hierarchical group makes the modification pervade through all dependant subordinated items.

Hierarchical Grouping

Every member of a group can be the master item of another group, that is, an item can be subordinate in one group and meanwhile be another group's master. MindFusion.Diagramming for .NET MAUI doesn't impose any limits to the depth and width of group hierarchies built that way. However, it is not possible to put an item as a subordinate in more than one groups because the hierarchy relations would become ambiguous.

Unions

It is possible to create such groups, that if any item in the hierarchy is modified, all other items are updated too. This can be done by putting the items in circular chain of dependencies – that is, item1 is attached to item2, item2 to item3, … itemN to item1. If any of these items is modified, the change will propagate through the chain until it reaches its originator.

Attaching Items to an Existing Group

Links cannot be attached to groups but can be master items of groups. If a group's master item is a link, nodes can be attached to the control points or segments of the link. See the AttachToLink methods for details. If the master item is a node, other nodes can be attached to any of its corners, or to an area specified as percent of master-node's bounding rectangle. Check AttachToNode for details.

Accessing Group Masters

The item a node is attached to can be accessed through the Master property.

Detaching Items

An item can be detached from its master by calling the Detach method.


Layers

Items can be assigned to layers, and layers can be hidden, locked or moved up/down in the Z order as a group. Layer objects provide Visible, Locked, and ZIndex properties, which will affect all items in the respective layer. Layers also expose a Title property. Newly drawn items are added to the layer specified via Diagram.ActiveLayer.

Set the LayerIndex property of items to associate them with layers in the Diagram.Layers collection. If LayerIndex has the default value of -1, the item is not associated with any layer and its visibility depends only on the item's own Visible property.


Collapsing and Expanding Tree Branches

If a diagram represents a tree structure, the tree branch starting from a node can be collapsed or expanded again in order to hide or display hierarchy details. Use the nodes' Collapse and Expand methods to do this programmatically. To determine whether a subtree is expanded or collapsed, check its root's Expanded property.

Displaying Expand/Collapse Button

If the Expandable property of a node is set to true, there is a [±] button displayed beside the node to allow users to collapse or expand the tree branch starting there. The button location can be customized through the diagram's ExpandButtonPosition property. By default, pressing that button calls automatically the Collapse and Expand methods and raises the TreeExpanded or TreeCollapsed events.

Defining Tree Direction

A node can be connected to other nodes through outgoing and incoming links. Setting the ExpandOnIncoming property specifies which items connected to a node will be regarded as its descendants. If ExpandOnIncoming is false (default value) then each node will be regarded as a parent of its outgoing links and the items attached to them. If ExpandOnIncoming is set to true, the node's incoming links define its children. So that property specifies the direction of parent-children relationship between diagram items and respectively the overall direction in which collapsing / expanding is done.

Expanding a Branch Recursively

Use the RecursiveExpand property to specify whether the whole tree branch starting from a node will be shown when expanding, or only the first level of descendants.

Custom Expand/Collapse Functionality

The ExpandButtonAction property lets you override the standard functionality of the [±] button. Set this property to RaiseEvents and handle the ExpandButtonClicked event if you need to implement your own expand/collapse logic.


User Interaction

The following topics are contained within this topic:

Controlling User Interaction
Information on how to control user interactions with the control through diagram behavior, node constraints and event handling.

Handling Events
Information about some more notable events in MindFusion.Diagramming for .NET MAUI.

Scrolling and Zooming
Controlling scrolling and zooming in diagram views.

In-place Editing the Contents of Items
Information about in-place editing of ShapeNodes, TableNode.Cells and DiagramLinks.


Controlling User Interaction

There are several ways to control user actions on the diagram as a whole, or on individual items in the diagram.

Specify How User's Actions are Interpreted

The Behavior property provides several predefined sets of rules specifying how user input with the mouse or touch is interpreted. If Behavior is set to LinkShapes, dragging started from an unoccupied point of the document is processed as a ShapeNode creation request and dragging over a node creates a link. Note that such behavior leads to some extra work when creating overlaying nodes – users need to draw the second node on an empty area and move it over the first one afterwards. If you want to avoid that, use the DrawShapes behavior. If LinkTables is set, dragging the mouse over an empty area creates a table and dragging over a table creates a link. Behavior options also include DrawLinks, DrawTables and Modify.

Setting Diagram Bounds

Document size can be get or set with the Bounds property. By default, users are able to move items outside the diagram bounds. To prevent this, enable the RestrictItemsToBounds property. It provides three options to restrict item positions. They might not be restricted at all. The most restrictive option is to keep items entirely inside the document area. Another option allows items to be partially outside the document area but having at least a small visible part inside.

Item Constraints

Constraints upon how users are allowed to modify a node are set through the Constraints and EnabledHandles properties. The former can be used to constrain the move direction, node size and aspect ratio. The latter enables or disables specific manipulation handles of a node. That allows making the node non-moveable, non-resizable, or resizable only horizontally/vertically.

Items can be locked by the Locked properties. Locked items are excluded from selection and users cannot select, move or modify them.

Control How Links Connect to Nodes

The AllowIncomingLinks property of the DiagramNode class specifies whether incoming links can be drawn to a node. The AllowOutgoingLinks property enables drawing of outgoing links to a node.

Anchor points define where link's ends are placed when a user attaches a link to a node. A pattern of anchor points can be assigned to a node by setting the node's AnchorPattern. The SnapToAnchor property specifies whether link ends are aligned to anchor points when creating or modifying links.

Once a link is created, a user can still move its end points to different positions, unless LinkEndsMovable is set to false. This can also be controlled on a per-link basis by the AllowMoveEnd and AllowMoveStart properties. You can dynamically validate moving of links' end points using the LinkModifying event.

The AllowSelfLoops property enables or disables drawing of reflexive links. They are allowed by default, but can be disabled if you consider them meaningless for the application. AllowLinksRepeat controls if two nodes can be connected more than once in the same direction.

In-place Text Editing

The text of nodes and tables can be edited in-place through the context menu. To enable the feature set the AllowInplaceEdit property to true. For tables, both captions and cells can be edited in this way. Handle the CellTextEditing event to enable/disable in-place editing per cell. Depending on the type of item being edited, one of these events can be fired when editing completes: NodeTextEdited, CellTextEdited. In-place editing mode is exited when users click outside the text entry control.

Validation Events

When users try to create, delete or select an item, one of the following events is raised. To ban the action, set corresponding event bool argument to false:

Event | Description
NodeCreating | Raised while a user draws a new node.
LinkCreating | Raised while a user draws a new link.
NodeSelecting | Raised when the user is trying to select a node.
LinkSelecting | Raised when the user is trying to select a link.
NodeDeleting | Raised when the user is trying to delete a node.
LinkDeleting | Raised when the user is trying to delete a link.
NodeModifying | Raised while a user modifies an existing node.
LinkModifying | Raised while a user modifies an existing link.

For more events that can be fired by user's actions, please, consult the Events section of the documentation.

Multi-touch Support

  • If MultiTouchZoom property is enabled (default), the view can be zoomed or panned using two-touch pinch / flick gestures.
  • If MultiTouchModify property is enabled (default), diagram nodes can be moved, scaled and rotated using two-touch pinch / flick gestures.
  • If MultiTouchZoom property is disabled, each touch draws diagram items corresponding to current behavior.
  • If MultiTouchModify property is disabled, each touch started from a node draws a diagram link.

Latter modes can be used for collaborative whiteboarding / classroom scenarios.

Miscellaneous

  • Setting the SelectAfterCreate property to true automatically selects each newly created item, so users can immediately modify it.
  • AllowMultipleResize specifies whether the user can resize multiple selected items simultaneously.


Handling Events

Most events are raised only in response to users actions. If you need to execute the same code after user actions and API calls, move the common code to a method and invoke the method both in the respective event handler and after the API method or property setter call. A notable exception is the *Deleted set of events, which are also raised when items are deleted programmatically, because in some circumstances deleting an item could delete other items related to it.

When a user starts drawing a new item, the control raises an initialization event to let you set the appearance properties of the item. That is, for a node, the control raises InitializeNode.

While the user is dragging, a validation event is raised to let you cancel the item creation (for example, NodeCreating). If the action is not cancelled, a creation event is raised to let your application know about the new item (for example, NodeCreated). There are events raised when users modify items, for example, NodeModifying and NodeModified. Call the CancelDrag method to cancel the item modification or creation from the *Modifying or *Creating events raised for nodes or links.

When a user deletes an item through the context menu, there is a validation event raised to let you confirm that an item should be deleted (for example, NodeDeleting), and if not cancelled, there is an item-deleted event raised (for example, NodeDeleted).

There are many other events related to various activities a user could carry out on the diagram. The full set of events can be found here: DiagramBase Events.


Scrolling and Zooming

By default MindFusion.Diagramming for .NET MAUI scrollbars are invisible. When the user interacts with the diagram, the scrollbars are temporarily displayed to indicate the current position inside the document.

Diagram Size

The diagram size is set through the Bounds property. Its value is a Rect instance that specifies the origin of the diagram coordinate system and the diagram size. The scrollbar ranges also depend on the current ZoomFactor.

Automatic Scrolling

The AllowAutoScroll property controls automatic scrolling. If it is enabled and the user drags an adjustment handle near the visible edges of the diagram while manipulating an item, the control will scroll the viewport towards in that direction. The ScrollZoneSize property defines the size of the area near the view borders that triggers automatic scrolling.

Programmatic Scrolling

In order to scroll the document content programmatically, you can set the ScrollX and ScrollY properties. These properties can also be used to access the current scroll position in case you need it.

Scrolling Tables

Table rows can be scrolled too. If the Scrollable property is set to true, an up/down scroll button is displayed in the table's caption area. By means of this button users can scroll the rows of the table. Scrolling can also be done programmatically using the CurrentScrollRow property.

Zooming

Zooming is controlled via the ZoomFactor property. The zoom factor is expressed as a percentage, 100% meaning no zoom. Higher than 100% makes the diagram items look closer and bigger on the screen – zooming in. Less than 100% makes items look further and smaller on screen – zooming out.

Interactive Scrolling and Zooming

The user can click on the compass arrow at the bottom-right corner of the diagram to activate pan mode. While in pan mode dragging inside the diagram scrolls the diagram and pinching inside the diagram either zooms in or out the view. The compass icon can be shown or hidden through the ShowScrollToggle property. The control can be set in pan mode permanently by setting the Behavior property of the DiagramView class to Pan.


In-place Editing the Contents of Items

To activate the standard in-place editing of the text of MindFusion.Diagramming for .NET MAUI objects, set the AllowInplaceEdit property to true. AllowInplaceEdit allows in-place editing the content of a diagram element through the context menu. To display the context menu, tap and hold over an item without moving. In-place editing mode can be accepted and exited by clicking anywhere outside the text-field.

In-place editing can be applied to the following properties: ShapeNode.Text, DiagramLink.Text, TableNode.Cell.Text, TableNode.Caption and ContainerNode.Caption. For tables, both captions and cells can be edited in this way.

If you want to enable/disable in-place editing of a specific table's cell, handle the CellTextEditing event. To enable/disable in-place editing of nodes, handle the NodeTextEditing event. For a DiagramLink object, the LinkTextEditing event is raised while in-place editing. These validation events let you prevent users from editing the text in the particular object if it is necessary.

When in-place editing of a node is completed, the NodeTextEdited event is raised. For a table's cell, handle the CellTextEdited event. LinkTextEdited event is raised when in-place editing of a DiagramLink object completes.

To enter in-place editing mode programmatically and let users edit an item's text inline, call the BeginEdit method of Diagram. The EndEdit method exits in-place editing mode.


Placement and Layout

The following topics are contained within this topic:

Items Placement - Position, Size and Z-order
Information on how to modify the position, size and z-order of diagram items, both interactively and programmatically.

Alignment Grid
Information about the alignment grid.

Lanes Grid
Introduces the lanes grid - a grid that can be used in Swimlane diagrams or Gantt charts.

Laying Out Diagrams Automatically
Provides information about the automatic layouts available in MindFusion.Diagramming for .NET MAUI. These include the TreeLayout, SpringLayout and GridLayout.

Link Routing
Information about the automatic link routing.

Anchor Points and Patterns
Information on how to use anchor patterns and how to create custom anchor patterns.


Items Placement - Position, Size and Z-order

Measure Unit

The MeasureUnit property specifies the unit of measure for all location and size-related values assigned to MindFusion.Diagramming for .NET MAUI properties or passed as arguments to its methods.

Location and Size of Nodes

Use the Bounds property to get or change the location and size of a node. To move a node without changing its size, call the Move method. To change only the size of a node, invoke the Resize method. ResizeToFitImage and ResizeToFitImage methods set nodes' sizes to fit that of their pictures.

Links Control Points

Links have two or more control points, depending on their Shape and SegmentCount. You can get access to the control points via link's ControlPoints collection. You must call UpdateFromPoints after moving control points of a link; that's needed in order to repaint the link and update its internal state variables. The Bounds property is read-only. It returns the smallest rectangle that bounds all link points.

Link Dynamics

The Dynamic property of a link can be enabled to make the link automatically recalculate its end point positions if the nodes connected to the link are moved or resized; the end points are moved in such a way that the link points to the centers of the connected nodes. A related property is AutoSnapToNode, which can be enabled to make the link end points align to the border of their origin or destination nodes while a user move the link ends.

RetainForm is useful for links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

Links have an AutoRoute property that enables or disables automatic routing of a link. Routed links avoid nodes by finding the shortest path between their origin and destination that does not cross any other nodes. The link routing algorithm can be tuned via the properties exposed by RoutingOptions.

Interactive Moving or Resizing

End-users of your application can move or resize the diagram elements. They do this by selecting an item and dragging any of its adjustment handles, a point inside its interior, any of its sides or a selection frame. The HandlesStyle property of nodes controls how interaction can be performed. Additionally it defines the representation of selected items on screen. EnabledHandles lets you disable specific manipulations users are allowed to perform on a node, for example resizing the item horizontally or moving it. If an item is modified interactively, the NodeModified or LinkModified event is raised, depending on the item's type.

Controlling the Z-order

The Z-order defines how items are ordered along the Z-axis, so that one item appears in front of or behind another one. Members of the DiagramItem class give you full control over the Z-order. To move an item one level up or down, invoke the ZLevelUp or ZLevelDown methods. To move an item to the bottom of the Z-order call its ZBottom method. To move the item in front of all others, call its ZTop method. You can use the ZIndex property to get or set the position of an item within the Z-order.


Alignment Grid

MindFusion.Diagramming for .NET MAUI provides an alignment grid to help users place the diagram items more precisely. To activate the grid, set the AlignToGrid property to true. If the grid is active while an item is being created or modified, the item's control-points are aligned to the nearest grid points. The distance between adjacent grid points is set by the GridSizeX and GridSizeY properties. The GridOffsetX and GridOffsetY properties allow specifying the horizontal and vertical offset of the first point in the alignment grid.

Items created or modified by a user are automatically aligned to the grid. However, if items are placed in the diagram programmatically, their coordinates are set to the specified positions without aligning. In such cases use AlignPointToGrid if items must be placed exactly at grid points.

The grid can be either visible or invisible, depending on whether the ShowGrid value is true or false. If visible, the grid is painted as a matrix of points or as series of crossing lines, as specified by the GridStyle property. GridColor defines the color with which the alignment points or lines are painted.


Lanes Grid

The classes from the MindFusion.Diagramming.Lanes namespace let you develop process maps and lane diagrams, useful in business process planning and reporting. Processes consist of consecutive operations accomplished by people involved, technical installations, means of contact, and flow of information. The MindFusion.Diagramming for .NET MAUI lane grid features allow indicating and arranging related diagram items in complicated processes and systems, that is, Swim lane diagrams (known as Rummler-Brache diagram), Gantt Charts (planning and scheduling of projects). A lane in the grid can visually contain nodes, links, shapes or images, that represent tasks fulfilled in specified periods of time by people, companies or departments.

The MindFusion.Diagramming.Lanes namespace provides the Grid, Header, HeaderCollection, and Style classes, the ICell interface and the ResizeType enumeration. These types expose additional properties and methods that let you define your own grids as required by your application logic. Grids can include varying number of lanes, divided into child rows and columns whose intersections form cells. The cells color and style can be customized too.

Use the EnableLanes property of the Diagram class to display lanes in your application. The LaneGrid lets you setup the rows and columns in the grid by defining horizontal and vertical lanes, where each lane can be titled by its own header and/or subheadings. The grid can be resized by setting the ColumnCount and RowCount properties or by adding headers to the ColumnHeaders and RowHeaders collections. A column or row can be divided into child elements by adding to the SubHeaders collection of a Header, which lets you form a complex hierarchy of unlimited depth. The intersection of rows and columns can be either a simple cell for bottommost elements in the hierarchy, or a group of cells for parent rows and columns. Cells or cell groups can be accessed via the grid class Item property, that lets you index cells either by their integer positions, or by their Header objects.

The position of the grid and grid headers within the diagram is defined via TopMargin and LeftMargin, which specify the grid offset relative to Bounds. HookHeaders enables lane headers to be anchored to the left or right side of the control's visible area. The sizes of headers at different levels in the lane hierarchy can be set in a single operation by the RowHeadersWidths and ColumnHeadersHeights properties.

The appearance of the lanes grid can be customized further via the AlignCells property, which specifies whether cells are aligned to each other, the HeadersOnTop property, which specifies whether headers should appear on top of the Z-order, and the TopLeftAreaStyle specifying the appearance of the grid's top-left corner.

The Grid class provides many miscellaneous methods that can be used to find grid elements, for determining their bounds and for hit-testing: FindColumn, FindRow, GetCellBounds, GetCellColumn, GetCellFromPoint, GetCellRow, GetColumn, GetRow, GetRowIndex, GetColumnHeaderBounds, GetColumnIndex, GetHeaderBounds, GetRowHeaderBounds, GetHeaderFromPoint.

The headers in the lanes grid can be customized by using the following properties of the Header class:

Property Name | Description
Height | Gets or sets the height of the header and the related row in the grid.
ResizeType | Gets or sets the resize type of the header.
RotateTitle | Gets or sets a value indicating whether rotating of the header caption at 90 degree is enabled.
Style | Gets or sets the style of the header.
SubHeaders | Gets a collection with the subheaders of the header.
Title | Gets or sets the header caption.
TitleColor | Gets or sets the color of the header caption.
TitleFont | Gets or sets the font of the header caption.
TitleFormat | Gets or sets the alignment format of the header.
Width | Gets or sets the width of the header and the related column in the grid.


Laying Out Diagrams Automatically

Applications that process hierarchical or more complex entity-relationship data might need to present that data to end-users in an aesthetical and visually appealing manner. Such applications would store their data as graph of connected nodes possibly having additional information attached to them. However, position and size coordinates of nodes might be unnecessary and/or unavailable. MindFusion.Diagramming for .NET MAUI provides a way to automatically arrange the nodes of a diagram, applying attractive layouts on the overall structure of the diagram. To utilize that functionality, an application can create a diagram by assigning generic coordinates to its nodes, instantiating a layout object and invoking the layout's Arrange method. The Arrange methods can be prevented from changing positions of individual items by setting the IgnoreLayout property of those items to true.

The classes that implement automatic layout algorithms are located in the MindFusion.Diagramming.Layout namespace. The following sections list the available algorithms categorized by their general implementation strategy: force-directed algorithms, graph topology based algorithms and semantics based algorithms.


Force-directed layout algorithms

Force-directed algorithms simulate forces acting between objects in the graph and iteratively run a physical simulation that pulls the objects closer or pushes them apart. At each iteration the energy associated with the simulated system decreases, and the node positions calculated by this process usually lead to evenly distributed nodes and uniform link lengths.

Spring-Embedder Graph Layout

Spring-Embedder is force-directed layout algorithm. It simulates a physical system in which nodes repulse each other, and the links between them act as confining springs. Graphs processed by Spring-Embedder have their nodes distributed uniformly across the diagram area. The algorithm can be applied on a graph by creating a SpringLayout object and calling its Arrange method. Members of SpringLayout allow you to set the desired distance between graph nodes and the number of iteration steps to use while calculating node positions. You can also specify to minimize link crossings. If you select that option, the algorithm would produce better result with more iteration steps. However, it needs more time to complete if more steps are specified. In VB.NET and C#, Spring-Embedder layout might be applied like this:

C# [image] Copy Code

SpringLayout sl = new SpringLayout();
sl.IterationCount = 500;
sl.NodeDistance = 30;
sl.Arrange(diagram);

Visual Basic [image] Copy Code

Dim sl As New SpringLayout()
sl.IterationCount = 500
sl.NodeDistance = 30
sl.Arrange(diagram)

Grid Graph Layout

The GridLayout algorithm arranges diagram nodes in a grid, keeping connected nodes close together. The algorithm strives to achieve a small number of link crossings. It is based on an iterative process whose initial steps shuffle the grid nodes randomly. That can lead to very different results each time the algorithm is run.

To apply the layout to a diagram, create a GridLayout instance, set its members and invoke the Arrange method. Grid layout might be applied like this:

C# [image] Copy Code

GridLayout gl = new GridLayout();
gl.GridSize = 75;
gl.Arrange(diagram);

Visual Basic [image] Copy Code

Dim gl As New GridLayout()
gl.GridSize = 75
gl.Arrange(diagram)

Simulated Annealing Graph Layout

The AnnealLayout class implements the Simulated Annealing graph layout algorithm. Simulated Annealing is a general-purpose optimization method used to solve large-scale combinatorial problems by simulating the process of heating and cooling of metal to achieve freedom from defects. Finding a nice arrangement of a graph is a combinatorial problem that can be reduced to assigning costs to graph configurations and finding the minimum cost configuration. AnnealLayout assigns costs to graph configurations by evaluating different aesthetic criteria such as distance between nodes, length of links and the number of link crossings. Thus the best configuration found will have good aesthetic properties.

Circular Graph Layout

CircularLayout distributes nodes evenly on the circumference of a circle at positions that result in as few link crossing as possible. Set its Radius property to specify the size of the layout circle. Use SiftingRounds to set the number of fine-tuning crossing-reduction iterations.


Topology based layout algorithms

The following algorithms are based on the topological features of the graph being arranged, such as the size and adjacency of faces (a face is a region bounded by links) and the overall direction of links. The algorithms differ in the shape they apply to graph faces and the manner in which faces are embedded in the plane.

One-way Graph Layout

The OneWayLayout class ensures that links enter into nodes from the same general direction and exit them from the opposite side. If the graph contains cycles, some links bend around the nodes to keep the enter/exit direction consistent. The algorithm aims to minimize the number of such links.

Orthogonal Graph Layout

The OrthogonalLayout class implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings. This algorithm was designed for planar graphs where the nodes have at most four incident links, and produces best results with such graphs as input. It can arrange any arbitrary graph as well, by adding some dummy nodes and links to planarize the graph and reduce its vertex degree, and removing them after the layout. However this might lead to using larger area than necessary, due to the space occupied by dummy elements.

Orthogonal Router

OrthogonalRouter is a secondary layout algorithm that can be used to arrange links after an initial node arrangement has already been applied. The orthogonal layout is useful when there are much more links than nodes in a graph. The algorithm strives to achieve the following criteria, while preserving as much of the initial node configuration as possible.

  • links must not overlap;
  • only vertical and horizontal routing lines are used;
  • graph routing is performed with respect to the specified main layout direction;
  • links crossings are minimized;
  • bends are minimized;

Topological Layout

If the underlying graph if acyclic, TopologicalLayout arranges the nodes linearly in such a way that each node comes before all destination nodes of its outgoing links. The links are drawn as arcs above the chain of nodes, with their height proportional to the distance between the nodes. If the graph is not acyclic, the layout algorithm finds an ordering with a minimal number of back links, and draws the back links below the chain of nodes.

Cascade Graph Layout

CascadeLayout places nodes on a virtual grid and arranges links orthogonally, such that if the source graph is planar all links are guaranteed to have no more than two bends and will not intersect. By default the layout method arranges nodes in rows and link segments in columns; this can be changed by setting the Orientation property.

Triangular Graph Layout

TriangularLayout places nodes on a virtual grid, such that if the source graph is planar, all links are guaranteed to have a single segment and not intersect. If the graph is not planar, its intersecting links can be optionally segmented and bended in order to improve readability. The layout method places the nodes from the external face on a triangle and recursively adds the rest of the nodes as vertices of internal triangles. As a result, it is very effective for near maximal-planar (a.k.a. triangular) graphs.


Semantics based layout algorithms

The following algorithms arrange the diagram in a way that shows the semantics of individual items or the overall graph structure, such as hierarchical relations between objects, loops and decisions in flowcharts, assignments of nodes to layers or swimlanes.

Tree Layout

If application's data is structured hierarchically, it is appropriate to apply tree layout on it. To do this, create a TreeLayout object and call its Arrange method. Members of TreeLayout control many aspects of the layout process. The type of layout can be directional or radial. You can choose how much space to leave between tree levels and between nodes on the same level. For directional layouts the style of links in the arranged tree can be set to straight, orthogonal or curved. Global tree direction and alignment can be customized too. In VB.NET and C#, tree layout might be applied like this:

C# [image] Copy Code

TreeLayout tl = new TreeLayout();
tl.Type = TreeLayoutType.Cascading;
tl.Direction = TreeLayoutDirections.LeftToRight;
tl.LinkStyle = TreeLayoutLinkType.Cascading2;
tl.LevelDistance = 10;
tl.Arrange(diagram);

Visual Basic [image] Copy Code

Dim tl As New TreeLayout()
tl.Type = TreeLayoutType.Cascading
tl.Direction = TreeLayoutDirections.LeftToRight
tl.LinkStyle = TreeLayoutLinkType.Cascading2
tl.LevelDistance = 10
tl.Arrange(diagram)

Fractal Tree Layout

FractalLayout is a tree layout algorithm that places child nodes symmetrically around their parent node. Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached. If nodes in the tree have uniform number of children, the end result has fractal-like appearance (subsets of the graph look like scaled-down copies of the whole graph).

You can choose which node should be displayed at the center of the topmost circle by setting the Root property. If it is not specified, the algorithm automatically selects a root that leads to more balanced distribution of nodes.

Layered Graph Layout

The LayeredLayout algorithm arranges diagram nodes in layers according to several criteria, most important of which are: connected nodes must be placed close together; links must flow in one direction if possible; links must cross as few layers as possible; links must not cross other links. To apply the layout to a diagram, create a LayeredLayout instance, set its members and invoke the Arrange method. In C# and VB.NET, layered layout can be applied like this:

C# [image] Copy Code

LayeredLayout ll = new LayeredLayout();
ll.Orientation = MindFusion.Diagramming.Layout.Orientation.Horizontal;
ll.SplitLayers = true;
ll.LayerDistance = 35;
ll.Arrange(diagram);

Visual Basic [image] Copy Code

Dim ll = New LayeredLayout()
ll.Orientation = MindFusion.Diagramming.Layout.Orientation.Horizontal
ll.SplitLayers = True
ll.LayerDistance = 35
ll.Arrange(Diagram)

Tree map layout

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment (see ContainerNode class), and will ignore any links in the diagram. The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

Decision flowchart layout

DecisionLayout arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding. The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

Flowchart Graph Layout

FlowchartLayout recognizes program code -like patterns in the graph, such as loops, sequences and if/switch branchings, and arranges them recursively. FlowchartLayout could be used to arrange other types of graphs as well, though with some restrictions. For example it treats all back links as loops in the code, and expects that they are nested - loop links starting closer to the stop node should end closer to the start node. Another similar restriction is that there shouldn't be any cross-links that connect different branches of a decision sub-graph.

Swimlane Layout

SwimlaneLayout can be used to arrange process diagrams in which nodes representing activities are placed in swimlanes representing resources. The index of the resource allocated to an activity should be assigned to the corresponding node's LayoutTraits[SwimlaneLayoutTraits.Lane].

By default, the algorithm works with the diagram's LaneGrid, but its SwimlaneGrid property can be set to any class that implements ISwimlaneGrid. This allows applying the layout to a custom-drawn grid rendered through the DrawBackground event, or one composed of locked background nodes.

Hierarchical Graph Layout

HierarchicalLayout places nodes on user-defined levels, such that if the source graph is level-planar, all links are guaranteed to have a single segment and not intersect. The layout method requires that for each node LayoutTraits contains a HierarchicalLayoutTraits.Level entry specifying the level, and no two connected nodes must be on the same level.


Link Routing

Routed links avoid nodes marked as Obstacles by finding the shortest path between their origin and destination that does not cross any other nodes.

Setting Up a Link Router

The control finds paths for links affected by modifications of nearby nodes by calling methods of an object that implements the ILinkRouter interface. This object can be get or set through the LinkRouter property of the Diagram class. MindFusion.Diagramming for .NET MAUI provides two classes that implement ILinkRouter – GridRouter and QuickRouter. By default LinkRouter is set to a QuickRouter instance.

Automatic or Explicit Routing

The RouteAllLinks method can be invoked to explicitly rearrange links in a way they do not cross nodes. In addition, links have an AutoRoute property that enables or disables automatic routing of a link; that property is initialized from the diagram's RouteLinks member. The TriggerRerouting member of the RoutingOptions class specifies when links should be rerouted automatically.

Tuning the Routing Algorithm

When a GridRouter is used, the RoutingOptions class allows customizing various aspects of the routing algorithm. That algorithm evaluates possible paths aiming to find one that has a minimal cost. The values of LengthCost, TurnCost, CrossingCost, and NodeVicinityCost are added to the total cost of a route and have a great influence over the shape of the chosen path. The StartOrientation and EndOrientation properties specify the orientation of the first and last segments of routed links.


Anchor Points and Patterns

Anchor Points

For each node you can define one or more points to which links should dock when connecting to that node. Such points are represented by instances of the AnchorPoint class. The position of an anchor point relative to node's bounding rectangle is specified via the X and Y properties. By default, their values are expressed as percent of the node's width and height to accommodate for moving and resizing. The final location of an anchor point is determined by this simple calculation:

C# [image] Copy Code

return new Point(
nodeRect.X + nodeRect.Width * X / 100,
nodeRect.Y + nodeRect.Height * Y / 100);

Visual Basic [image] Copy Code

Return New Point( _
nodeRect.X + nodeRect.Width * X / 100, _
nodeRect.Y + nodeRect.Height * Y / 100)

A point's position can also be defined as a fixed offset from the node's top-left corner, letting you define anchor positions that do not depend on the node's width or height. This is controlled independently for X and Y coordinates, by means of the XUnit and YUnit properties.

You can control whether an anchor point accepts incoming or outgoing links or both. That is done via the AllowIncoming and AllowOutgoing properties. When a link is drawn, its ends are aligned to the nearest anchors allowing docking of the respective end type. Another way to control whether links can be connected to an anchor point is to handle the ValidateAnchorPoint event.

Anchor Patterns

An AnchorPattern instance defines a set of anchor points to be used together. When creating an anchor pattern, pass to its constructor an array of AnchorPoint objects. The AnchorPattern class exposes several predefined patterns as static properties. An existing pattern can be assigned as a single entity to the AnchorPattern property of nodes. The following example creates a pattern of four anchor points:

C# [image] Copy Code

apat1 = new AnchorPattern(new AnchorPoint[] {
new AnchorPoint(50, 0, true, true),
new AnchorPoint(100, 50, true, true),
new AnchorPoint(50, 100, true, true),
new AnchorPoint(0, 50, true, true)});

Visual Basic [image] Copy Code

apat1 = new AnchorPattern(new AnchorPoint() { _
new AnchorPoint(50, 0, true, true), _
new AnchorPoint(100, 50, true, true), _
new AnchorPoint(50, 100, true, true), _
new AnchorPoint(0, 50, true, true) })

The points are located at the middles of bounding rectangle sides of nodes to which the pattern is assigned. All four points accept both incoming and outgoing links.

Anchor Patterns and Tables

A distinct anchor pattern can be assigned to every row of a table. When a link is connected to a row, the respective end of the link is aligned to the nearest AnchorPoint assigned to that row. If a row does not have associated anchor points of the appropriate type (incoming/outgoing), the link will be connected to the nearest row that has such anchors defined. If none of the rows of a table has an associated anchor pattern, links are connected to the middle of the left or right side of the pointed row.

Anchor Points and User Interaction

By default, a link is attached to an anchor point only when the link is created. Afterwards, the user can move the link end to any part of the node. To ensure that links always stay attached to an anchor point even after subsequent modifications done by the user, set the SnapToAnchor property to CreateOrModify. You can prevent the user from attaching specific links to specific anchor points by handling the ValidateAnchorPoint event.

Setting Anchor Point Programmatically

You can connect a link to a specific anchor point by setting the link's OriginAnchor and DestinationAnchor properties to the index of the point in the respective node's AnchorPattern. The ReassignAnchorPoints method of DiagramLink automatically chooses anchor points of the origin and destination nodes that are close to each other, so that the link takes a shorter path between the nodes. The ReassignAnchorPoints method of DiagramNode sets the anchor point of each link connected to the node so that links are evenly distributed among the available anchor points.


Serializing and Exporting

XML Serialization

It is possible to save a diagram as an XML document. To do that, call the SaveToXml method of the Diagram class. To deserialize a diagram back from its XML representation, call the LoadFromXml method.

Custom item classes can implement XML serialization for their additional properties by overriding the SaveToXml and LoadFromXml methods. In addition, such classes must specify a string to use as their identifier in the XML document by calling RegisterItemClass.

The control raises SerializeTag and DeserializeTag to enable serialization of complex Id and Tag objects without overriding the item classes. The PropertyName event argument specifies which property is being serialized.

JSON Serialization

To serialize a diagram as a JSON string, call its SaveToJson method. To deserialize a diagram back from its JSON representation, call the LoadFromJson method. The SaveToJsonFile and LoadFromJsonFile methods serialize the JSON strings to / from files.

Custom item classes can implement JSON serialization for their additional properties by overriding the SaveToJson and LoadFromJson methods. Such classes must be registered for serialization by calling the RegisterItemClass method and providing a string identifier for the clientClass parameter.

The control raises JsonSerializeTag and JsonDeserializeTag to enable serialization of complex Id and Tag objects without overriding the item classes. The PropertyName event argument specifies which property is being serialized.

JSON serialization is handled internally by the classes from MindFusion.Json namespace. The JsonValue class represents a property value. Property names and values are stored in instances of the JsonObject dictionary class. The JsonContext class handles the serialization of the Diagram properties. The Serialize method is a wrapper over the Serializer class' Serialize method. It takes a JsonObject and serializes it to a string. The Parse method is a wrapper over the Parser class' ReadJsonObject method. It takes a JSON-formatted string and returns a JsonObject with the parsed data.

Exporting Images

You can create a static image representing the current diagram using the CreateImage method. The method returns an instance of the ImageSource class. Alternatively, call ExportImage to export the diagram to a bitmap file.


Appearance

The following topics are contained within this topic:

Styles and Themes
Provides information on how to use styles and themes and how to create styles for custom items.

Brush and Pen Classes
Introduces the MindFusion implementation of pens and brushes.

Node Effects
Information on how to apply the built-in node effects.

Customizing the Appearance of Items
Information about how to modify various aspects of the appearance of individual diagram items.

User Defined Node Shapes and Custom Drawing
Information on how to define arbitrary node shapes as well as how to use custom-drawing.

Modifying Appearance
General options affecting the appearance of a MindFusion.Diagramming for .NET MAUI diagram.


Styles and Themes

The style and theme system provides a consistent way to customize the appearance of a Diagram and its items. By using styles and themes, it is easier to achieve coherent look and feel across the entire diagram. In addition, changing the look and feel can be achieved by simply replacing the current theme.

Styles

The style is a set of properties. Styles can be applied to diagrams and individual diagram items and this can potentially affect the values of some properties of the target object. More specifically, if the value of a style-affected property in the target object is null, then the value is obtained from the associated style. The style does not necessarily need to provide values for all of its properties. If a styled property is null and it is not defined in the associated style, the style system searches for a value in the current theme. A complete value precedence list can be found later in this topic.

The styles are represented by the Style class and its various subclasses. Styles can be applied to diagram objects through the Style property of the Diagram class and to diagram items through the Style property of the DiagramItem class. Styles can also participate in themes, in which case they affect all objects of specific type.

Themes

The theme is a set of styles, each associated with specific diagram or item type. When the theme is applied to a diagram, the styles registered in the theme affect all objects of their associated type.

Themes are represented by the Theme class and can be assigned to Diagram objects through the Theme property. Styles are associated with types within the theme through the RegisterStyle method. The following code creates a new theme, with a single style for ShapeNode items and applies this theme to an existing diagram.

C# [image] Copy Code

var theme = new Theme();
var style = new ShapeNodeStyle();
style.FontFamily = "Courier New";
theme.RegisterStyle(typeof(ShapeNode), style);
diagram.Theme = theme;

VB.NET [image] Copy Code

Dim theme As New Theme()
Dim style As New ShapeNodeStyle()
style.FontFamily = "Courier New"
theme.RegisterStyle(GetType(ShapeNode), style)
diagram.Theme = theme

Alternatively, themes can be loaded from XML files by calling the LoadFromXml method. Such XML files can be produced by the Theme Editor tool, or by calling the SaveToXml method of an existing theme.

Value Precedence

The style and theme system is hierarchical. This means that, when a value of a styled property is requested, the system starts searching for this value along a chain of defined styles. The system returns the first valid value encountered. If no valid value is encountered along the chain, the system returns a globally defined default value for the property. The following list explains the search order in more details:

  1. If the local value of the object is not null, the local value is returned.
  2. If the object has a style and the property in this style has value, this value is returned.
  3. If the object is an item, which is part of a diagram, the local style of the diagram is searched.
  4. If the object is an item, which is part of a diagram and the diagram has associated theme, the theme is searched for styles registered for the item's type or its base types. If a style with a defined property value is found, this value is returned.
  5. Similar search as the previous one is performed for a theme-registered style for the Diagram class.
  6. If the above steps do not produce value; the system returns a globally define default for the property.

For example, if the effective value of the text brush property of a ShapeNode is requested (through the EffectiveTextBrush property), the style system performs the following search, according to the above rules:

  1. If ShapeNode.TextBrush is not null, ShapeNode.TextBrush is returned.
  2. If ShapeNode.Style is set and the DiagramItemStyle.TextBrush property in this style has value, this value is returned.
  3. If the node is part of a diagram, the Diagram.Style is set, and the DiagramStyle.TextBrush property of this style has value, this value is returned.
  4. If the node is part of a diagram and the Diagram.Theme is set, the theme is searched for a style registered for the ShapeNode type. If there is such style and its DiagramItemStyle.TextBrush property has value, this value is returned.
  5. Similar search as the previous one is performed for a theme-registered style for the Diagram type.
  6. Finally, the system returns a globally-defined default value for the TextBrush property (which is a solid Black brush).

Custom Styles

The following section describes how to enable styling for properties of custom item classes. To enable styling, create a custom style class by deriving from the closest existing type. For example, for a custom ShapeNode (say, MyNode), the custom style needs to inherit from ShapeNodeStyle:

C# [image] Copy Code

public class MyNodeStyle : ShapeNodeStyle
{
}

Visual Basic [image] Copy Code

Public Class MyNodeStyle
Inherits ShapeNodeStyle

End Class

For each property in MyNode that needs to be styled, define a property with the same name and type in the MyNodeStyle class by following the pattern below. For example, if MyNode contains a property MyBrush of type Brush, the following code defines its corresponding style property:

C# [image] Copy Code

public class MyNodeStyle : ShapeNodeStyle
{
public MyNodeStyle()
{
myBrushProperty = RegisterProperty("MyBrush");
}

public Brush MyBrush
{
get { return (Brush)GetValue(myBrushProperty); }
set { SetValue(myBrushProperty, value); }
}

private object myBrushProperty;
}

Visual Basic [image] Copy Code

Public Class MyNodeStyle
Inherits ShapeNodeStyle

Public Sub New()
myBrushProperty = RegisterProperty("MyBrush")
End Sub

Public Property MyBrush() As Brush
Get
Return DirectCast(GetValue(myBrushProperty), Brush)
End Get
Set
SetValue(myBrushProperty, value)
End Set
End Property

Private myBrushProperty As Object

End Class

Now, in the custom MyNode class, define a new property, EffectiveMyBrush, which will return the actual value of MyBrush:

C# [image] Copy Code

public Brush EffectiveMyBrush
{
get
{
// Checking for local value
if (MyBrush != null)
return MyBrush;
// Querying the property value through the style system
return (Brush)GetValue("MyBrush");
}
}

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveMyBrush() As Brush

Get

' Checking for local value
If MyBrush IsNot Nothing Then
Return MyBrush
End If
' Querying the property value through the style system
Return DirectCast(GetValue("MyBrush"), Brush)

End Get

End Property

Remember to register the style class for serialization, along with the custom node class:

C# [image] Copy Code

Diagram.RegisterClass(typeof(MyNode), "MyNode", 1);
Diagram.RegisterClass(typeof(MyNodeStyle), "MyNodeStyle", 1);

Visual Basic [image] Copy Code

Diagram.RegisterClass(GetType(MyNode), "MyNode", 1)
Diagram.RegisterClass(GetType(MyNodeStyle), "MyNodeStyle", 1)

Now you can style and theme your custom nodes. Here is a theme, which affects the MyBrush property of all MyNode items in a diagram:

C# [image] Copy Code

Theme theme = new Theme();
MyNodeStyle myNodeStyle = new MyNodeStyle();
myNodeStyle.MyBrush = new SolidBrush(Colors.PaleGoldenrod);
theme.RegisterStyle(typeof(MyNode), myNodeStyle);
diagram.Theme = theme;

Visual Basic [image] Copy Code

Dim theme As New Theme()
Dim myNodeStyle As New MyNodeStyle()
myNodeStyle.MyBrush = New SolidBrush(Colors.PaleGoldenrod)
theme.RegisterStyle(GetType(MyNode), myNodeStyle)
diagram.Theme = theme

It is important to remember that there are no global default values for custom properties. Therefore you should be prepare to handle null values from GetValue or ensure that at least one of the five steps in the precedence list above produces a value.


Brush and Pen Classes

MindFusion.Diagramming for .NET MAUI defines a set of classes which are used to define colors and patterns used to stroke and fill geometric shapes. These classes are located in the MindFusion.Drawing namespace. There Brush-derived classes are used to define colored fills for objects. The simplest brush, SolidBrush, fills the interior of an object with a solid color. There are also hatch and gradient brushes represented by the HatchBrush, LinearGradientBrush, and PathGradientBrush classes respectively. The Pen class defines the attributes of strokes, for example, color and thickness.

Instances of those classes can be assigned to various diagram properties, including to the Pen and Brush properties of the diagram items.


Node Effects

To apply an effect to the nodes in a diagram, create an instance of one of the effect classes and add this instance to the Diagram.NodeEffects collection. To apply the effect to individual nodes, add the instance to the node's Effects collection. To discard the diagram effects for a particular node, add a null reference at position 0 in the node's Effects collection. Effects can also be applied through styles by adding them to the DiagramStyle.NodeEffects and DiagramNodeStyle.Effects collections respectively.

It is possible to combine different effects by adding instances of their appropriate types to the effect collections. If is also admissible to apply more than one effect of the same type.

The currently supplied effect types are Aero and Glass. They are examined in more details in the sections below.

Aero Effect

The Aero effect is represented by the AeroEffect class. The effect is designed to roughly resemble the Aero theme of Windows. More specifically, the effect adds semi transparency to the nodes, a smooth shade at the outside and a thin inset stroke. The semi transparency is specified through the Opacity property. Opacity varies from 0 to 1 inclusive, where 0 indicates full transparency and 1 indicates the original node color. The semi transparency is applied only on the node brush. The colors of the shade and the inner stroke are specified through the ShadeColor and InnerOutlineColor properties respectively. The following image illustrates how these properties affect the output:

The following example applies the Aero effect on the nodes of an existing diagram:

C# [image] Copy Code

AeroEffect effect = new AeroEffect();
effect.Opacity = 0.5;
effect.InnerOutlineColor = Color.FromRgba(255, 255, 255, 100);
diagram.NodeEffects.Add(effect);

Visual Basic [image] Copy Code

Dim effect As New AeroEffect()
effect.Opacity = 0.5
effect.InnerOutlineColor = Color.FromRgba(255, 255, 255, 100)
diagram.NodeEffects.Add(effect)

Tips

  • The Aero effect works very well in scenarios with overlapping nodes or in cases where the background is more complex than solid color, due to the effect of semi transparency.
  • Aero combines well with the Glass effect. There are some examples at the end of this topic.
  • The ShadeColor is usually black or another dark color. However, some nice glow effects can be achieved by setting bright ShadeColor on a diagram with dark background.
  • The Aero effect can impact performance if there are many nodes visible in the diagram.

Glass Effect

The Glass effect is represented by the GlassEffect class. The Glass effect adds visuals on top of the nodes in order to give the impression of a reflective surface. There are several variations of this effect, which can be selected through the Type property. The color of the reflection and the ambient color can be specified through the ReflectionColor and GlowColor properties respectively. When UsePenAsGlow is set to true the color of the node's pen is used as the ambient color. The following image illustrates the differences between the distinct effect types:

The following example applies a Glass effect with the default settings to the nodes of a diagram:

C# [image] Copy Code

diagram.NodeEffects.Add(new GlassEffect());

Visual Basic [image] Copy Code

diagram.NodeEffects.Add(New GlassEffect())

Tips

  • The GlowColor is usually white. However, for Type4 glass effects it is often more suitable to use black glow.
  • The Glass effect combines well with the Aero effect. There are some examples at the end of this topic.
  • Several glass effects of different types can be applied simultaneously for emphasized effect.

Examples

The values of the effect properties are usually selected in accordance with the color scheme of the target diagram and the desired end result. In addition different types of effects can be applied simultaneously to achieve more interesting results. The examples below demonstrate possible effect combinations in various color contexts.

Aero & Glass (Dark on Light)

In this example the Aero and Glass effects are combined. The Aero effect is useful in scenarios when dark nodes are placed on light background or vice versa, in order to emphasize the contrast.

Here is the code that applies the above effects:

C# [image] Copy Code

diagram.NodeEffects.Add(new GlassEffect());
diagram.NodeEffects.Add(new AeroEffect());

Visual Basic [image] Copy Code

diagram.NodeEffects.Add(New GlassEffect())
diagram.NodeEffects.Add(New AeroEffect())

Aero & Glass (Light on Dark)

This example is similar to the first one, only this time the nodes are painted in light colors and the background is dark.

Here is the code that applies the above effect:

C# [image] Copy Code

GlassEffect glassEffect = new GlassEffect();
glassEffect.Type = GlassEffectType.Type3;
diagram.NodeEffects.Add(glassEffect);
diagram.NodeEffects.Add(new AeroEffect());

Visual Basic [image] Copy Code

Dim glassEffect As New GlassEffect()
glassEffect.Type = GlassEffectType.Type3
diagram.NodeEffects.Add(glassEffect)
diagram.NodeEffects.Add(New AeroEffect())

Glass & Smooth Shadow

This example illustrates how to emphasize the glass effect by combining it with a Smooth Shadow effect. The nodes have semitransparent fills so that the shadow can be seen through them in order to improve the glass impression.

Here is the code that applies the above effects:

C# [image] Copy Code

// Make sure that the shadows in the diagram are enabled and nodes are assigned semitransparent brushes
diagram.NodeEffects.Add(new GlassEffect());
diagram.NodeEffects.Add(new SmoothShadowEffect());

Visual Basic [image] Copy Code

' Make sure that the shadows in the diagram are enabled and nodes are assigned semitransparent brushes
diagram.NodeEffects.Add(New GlassEffect())
diagram.NodeEffects.Add(New SmoothShadowEffect())

Glow Effect

This example uses bright colors on black background to create a glow effect. The example utilizes an Aero effect with ShadeColor set to the color of the nodes' pens.

Here is the code that applies the above effects:

C# [image] Copy Code

GlassEffect glassEffect = new GlassEffect();
glassEffect.Type = GlassEffectType.Type2;
glassEffect.UsePenAsGlow = true;
diagram.NodeEffects.Add(glassEffect);
AeroEffect aeroEffect = new AeroEffect();
aeroEffect.Opacity = 0;
aeroEffect.InnerOutlineColor = Color.Black;
aeroEffect.ShadeColor = Color.FromRgb(128, 255, 255);
diagram.NodeEffects.Add(aeroEffect);

Visual Basic [image] Copy Code

Dim glassEffect As New GlassEffect()
glassEffect.Type = GlassEffectType.Type2
glassEffect.UsePenAsGlow = True
diagram.NodeEffects.Add(glassEffect)
Dim aeroEffect As New AeroEffect()
aeroEffect.Opacity = 0
aeroEffect.InnerOutlineColor = Color.Black
aeroEffect.ShadeColor = Color.FromRgb(128, 255, 255)
diagram.NodeEffects.Add(aeroEffect)


Customizing the Appearance of Items

For every diagram item, different visual styles and properties can be set as described in the following paragraphs.

Stroke Width and Style

When customizing items through styles and themes, the appearance of their border lines can be set via the Stroke and StrokeThickness properties of DiagramItemStyle. The borders or segment lines of individual nodes or links can be customized through the Pen property. Links provide an additional property for customizing the borders of their arrowheads, called HeadPen.

Color of Diagram Elements

The color of link segments can be set using the Pen property. The borders of arrowheads are drawn using HeadPen. Brush specifies how closed arrowhead shapes are filled. It is also possible to define distinct fill style for each type of arrowheads by means of the HeadBrush, BaseBrush, and IntermediateBrush properties. TextBrush is used for rendering link's text.

Nodes have three properties for colors: the color of node borders is specified through the Pen property; the interior of a node is filled using Brush; TextBrush specifies the color for rendering text. Tables have a special property for their caption color – CaptionBrush.

Text

Diagram items can have attached text, displayed inside / over them.

Text of shape nodes is set using their Text property and the text format and alignment style is specified using TextFormat. To make a node big enough to display its text without clipping, call ResizeToFitText.

Links have their text drawn horizontally above their middle segment or rotated as specified via TextStyle; the string to display can be set using the Text property.

Tables have caption text specified via Caption; table cells expose Text property and their text can be formatted via TextFormat.

All diagram items expose Font property, specifying the name, style and size of the font of item's text. The color of item's text is set in its TextBrush property.

Images

Shape nodes and tables can display images inside them. Use ShapeNode.Image and TableNode.Image properties to load images into the respective items. A node can be made the same size as the image it contains by calling ResizeToFitImage.

Images can be positioned in different ways: they can be tiled, stretched or aligned to the containing nodes' centers or sides. Use ShapeNode.ImageAlign and TableNode.ImageAlign to specify how images are placed within the corresponding nodes. An image shown inside a node is clipped in accordance with the shape of that node.

Table cells can have Image and ImageAlign assigned too. For example that might be used to display an icon for the key field of a database table.

Shadows

The shadow of each diagram item can be painted with a distinct brush, as specified via the item's ShadowBrush property. Shadow offsets from their items can be set individually via the ShadowOffsetX and ShadowOffsetY properties. Set those to zero to hide item's shadow.

DiagramLink-specific Properties

The shape and orientation of link segments is specified by the Shape property; the number of segments is specified by the SegmentCount property. The form and size of the arrowhead shape is set using the HeadShape and HeadShapeSize properties. Shapes displayed at the origin of links are defined by BaseShape and BaseShapeSize. Shapes can be displayed at middles of segments, helping to follow the path of long links. They are defined by the IntermediateShape and IntermediateShapeSize properties. The lines of arrowhead shapes are painted using the HeadPen pen. Custom painting code may be invoked for a link, as set in CustomDraw.

Rounded Links

Links comprising straight segments, that is, ones whose Shape is set to Polyline or Cascading, can use arcs to join their adjacent segments. To enable that feature, set RoundedLinks to true. Use RoundedLinksRadius to set the radius of the joining arcs.

Link Crossings

Intersection points where links cross their paths can be rendered as arcs or breaks, as specified via LinkCrossings. It depends on the Z-order, which links jump over the others, or which links appear cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, links at lower Z position are cut by links at higher Z. Radius of arcs and breaks can be set through the CrossingRadius property.

ShapeNode-specific Properties

The shape of a node is defined using its Shape property. Shape templates can be applied to a shape node with an orientation of 0/90/180/270 degrees as specified via the ShapeOrientation property. Your own drawing code may be invoked for a node, depending on the value of CustomDraw. Shape nodes can be marked as Transparent, having only their text or images rendered.

TableNode-specific Properties

The outline of a table can be either a rectangle or rounded rectangle, as specified via the Shape property. The borders of table cells can be rendered in different ways, depending on the value of CellFrameStyle. The table caption area is painted using the CaptionBackBrush brush. Custom painting can be performed on a table and its cells as set in the CustomDraw and CellCustomDraw properties.


User Defined Node Shapes and Custom Drawing

The appearance of MindFusion.Diagramming for .NET MAUI items can be customized in several additional ways, as described below.

Shape Templates

The Shape class provides the means for defining complex geometric shapes, made of straight lines, arcs and Bézier curves. Such shapes can be assigned to the Shape property of ShapeNode objects, or to the HeadShape property of DiagramLink objects. A shape template must always contain an outline to be used for hit testing, clipping and finding intersections with other items. Optionally, shapes can contain decoration elements and text region definitions. Decorations are visual elements that do not take part in hit testing and clipping. Text regions are the parts of shapes in which node's text is laid out and rendered. MindFusion.Diagramming for .NET MAUI provides more than 100 predefined shape templates, which can be accessed through the Shapes collection or FromId method of the Shape class. Each predefined shape has a string identifier assigned to it. Use the FromId method to find a shape with the specified id. A shape template can be assigned to the Shape member of shape nodes.

Custom Painting

Another way to customize item's appearance is implemented by raising an event each time an item is painted, giving you the option to attach your own drawing code to the MindFusion.Diagramming for .NET MAUI's rendering engine. Use the corresponding CustomDraw property of items to enable that feature in your application.

MindFusion.Diagramming for .NET MAUI provides several options for custom drawing. If you choose Additional drawing style, your drawing code will be executed after the standard item drawing code is executed and Image is rendered, but before the text is rendered. Furthermore, the IGraphics object you receive to draw on has a clipping region applied that corresponds to a node's shape. If using Full drawing mode, none of the standard MindFusion.Diagramming for .NET MAUI drawing code is executed – just yours. The ShadowOnly mode performs standard painting of items, but leaves the drawing of shadows to your code.

Place your own drawing code in a handler of the DrawNode, DrawCell, and DrawLink events. These events are fired for each custom-drawn item that needs repainting.

Combining Custom Shapes with Custom Drawing

Finally, you could combine user-defined shapes with the Additional custom-painting style. Thus, you can get custom shapes enabled for a node and your custom painting code executing with the node shape used as clipping region. You might clear the clipping region, but be careful – if you draw outside node's bounding rectangle the view may not update correctly.


Modifying Appearance

You can customize most of the diagram visualization effects.

Background

The Diagram background area can be filled using a solid brush, gradient, texture or color patterns, by setting the BackBrush property. Background theme can also be an image set by the BackgroundImage property. Background image can be centered, aligned to a corner of the control or document, tiled or stretched to cover the drawing area – depending on the BackgroundImageAlign property value. It is possible to paint the area outside Bounds using a distinct brush by setting the ExteriorBrush property.

Shadows

By default all diagram items have shadows drawn under them. If ShadowsStyle is set to OneLevel, the item shadows are drawn at the lowest Z-level under all items, which makes them look as on single Z-level. If it is set to ZOrder each shadow is drawn immediately under its corresponding item, possibly covering parts of other items, which gives more 3D-like look to the diagram. If the style is set to OneLevel no shadows are drawn. The shadows offset from items is specified by the ShadowOffsetX and ShadowOffsetY properties or the SetShadowOffset method. Shadows are painted using the brush specified via ShadowBrush.

Selection

The style of selection handles drawn around the active item can be set with the ActiveItemHandlesStyle property. Items in multiple selection have their handles drawn using the style specified through the SelectedItemHandlesStyle property. Disabled manipulation handles are painted using DisabledHandlesStyle when ShowDisabledHandles is enabled (see EnabledHandles). The Style property of the Selection class controls the way multiple selection is displayed.

Grid Settings

An alignment grid is drawn if the ShowGrid is set to true. The GridColor and GridStyle properties specifies respectively the color and style of grid.


Miscellaneous

Associate Custom Data with Items

Every diagram item can be associated with a user-defined value from any data type. Use the Tag property of the DiagramItem class to associate your data with an item.

Informative Properties and Methods

  • The Intersects method of the DiagramNode class determines whether nodes intersect.
  • The Length property of the DiagramLink class returns the total length of a link.


Tutorials

Diagramming for .NET MAUI Guide © 2023 MindFusion


Tutorial 1: Loading graph data

This tutorial shows how to load graph data from XML and create diagram objects corresponding to the graph nodes and edges. It assumes you have already integrated the diagram library into your project, as shown in Getting Started guide.

1. Right-click the project in Solution Explorer and choose Add -> New Item from the context menu. Create a new XML file called SampleGraph.xml and add to it content in the following form:

XML [image] Copy Code

<?xml version="1.0" encoding="utf-8" ?>
<Graph>
<Nodes>
<Node id="0" name="start" />
<Node id="1" name="activity 1" />
<Node id="2" name="task 1" />
<Node id="3" name="task 2" />
<Node id="4" name="activity 2" />
<Node id="5" name="task 3" />
<Node id="6" name="task 4" />
<Node id="7" name="activity 3" />
<Node id="8" name="task 5" />
<Node id="9" name="task 6" />
<Node id="10" name="end" />
</Nodes>
<Links>
<Link origin="0" target="1" />
<Link origin="1" target="2" />
<Link origin="1" target="3" />
<Link origin="2" target="4" />
<Link origin="3" target="4" />
<Link origin="4" target="5" />
<Link origin="4" target="6" />
<Link origin="5" target="10" />
<Link origin="6" target="10" />
<Link origin="0" target="7" />
<Link origin="7" target="8" />
<Link origin="8" target="9" />
<Link origin="1" target="9" />
<Link origin="9" target="10" />
</Links>
</Graph>

2. Set the file's "Build Action" property to "Embedded resource".

3. Add the following variables to page's constructor. "nodeMap" maps diagram nodes to their identifiers, and "bounds" contains the default node size.

C# [image] Copy Code

var nodeMap = new Dictionary<string, DiagramNode>();
var bounds = new Rect(0, 0, 18, 6);

4. Load the XML document and its root element using the Linq for XML API:

C# [image] Copy Code

var assembly = typeof(App).GetTypeInfo().Assembly;
Stream stream = assembly.GetManifestResourceStream("Tutorial1.SampleGraph.xml");

string text;
using (var reader = new StreamReader(stream))
{
text = reader.ReadToEnd();
}
XDocument document = XDocument.Parse(text);

5. Load the graph node elements and create their corresponding ShapeNode objects by calling the CreateShapeNode method of the Factory class. CreateShapeNode is just a shortcut to creating a ShapeNode instance using the "new" operator and adding it to the Nodes collection of the diagram. Additionally, this code maps the new node to the "id" attribute of the XML element, and sets the node's Text to the value of the "name" attribute.

C# [image] Copy Code

// load node data
var nodes = document.Descendants("Node");
foreach (var node in nodes)
{
var diagramNode = diagram.Factory.CreateShapeNode(bounds);
nodeMap[node.Attribute("id").Value] = diagramNode;
diagramNode.Text = node.Attribute("name").Value;
}

6. Load the graph links and create corresponding DiagramLink objects. The Origin and Destination of the links are accessed by their ids through the "nodeMap" dictionary.

C# [image] Copy Code

// load link data
var links = document.Descendants("Link");
foreach (var link in links)
{
diagram.Factory.CreateDiagramLink(
nodeMap[link.Attribute("origin").Value],
nodeMap[link.Attribute("target").Value]);
}

7. Arrange the diagram using the LayeredLayout class.

C# [image] Copy Code

// arrange the graph
var layout = new LayeredLayout();
layout.LayerDistance = 12;
layout.Arrange(diagram);

8. Build and run the project. If everything is fine, you should see this representation of the graph:

Complete sample project is available in Samples/Tutorial1 folder from distribution.


Tutorial 2: Loading hierarchical data

This tutorial shows how to load hierarchical data recursively from XML and create diagram items corresponding to the hierarchy. It assumes you have already integrated the diagram library into your project, as shown in Getting Started guide.

1. Right-click the project in Solution Explorer and choose Add -> New Item from the context menu. Create a new XML file called SampleTree.xml and add to it content in the following form:

XML [image] Copy Code

<?xml version="1.0" encoding="utf-8" ?>
<Project>
<Activity Name="Activity 1">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
</Activity>
<Activity Name="sub-activity 2">
<Activity Name="sub-activity 2-1" />
<Activity Name="sub-activity 2-2" />
<Activity Name="sub-activity 2-3" />
</Activity>
<Activity Name="sub-activity 3">
<Activity Name="sub-activity 3-1" />
<Activity Name="sub-activity 3-2" />
</Activity>
</Activity>
<Activity Name="Activity 2">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
<Activity Name="sub-activity 1-3" />
</Activity>
<Activity Name="sub-activity 2">
<Activity Name="sub-activity 2-1" />
<Activity Name="sub-activity 2-2" />
</Activity>
</Activity>
<Activity Name="Activity 3">
<Activity Name="sub-activity 1">
<Activity Name="sub-activity 1-1" />
<Activity Name="sub-activity 1-2" />
<Activity Name="sub-activity 1-3" />
<Activity Name="sub-activity 1-4" />
</Activity>
<Activity Name="sub-activity 2" />
<Activity Name="sub-activity 3">
<Activity Name="sub-activity 3-1" />
<Activity Name="sub-activity 3-2" />
</Activity>
</Activity>
</Project>

2. Set the file's "Build Action" property to "Embedded resource".

3. Add the following member to the page class to hold the default node size.

C# [image] Copy Code

Rect bounds = new Rect(0, 0, 24, 6);

4. Create the tree root node, and call the CreateChildren method, which builds the tree recursively.

C# [image] Copy Code

var root = diagram.Factory.CreateShapeNode(nodeBounds);
root.Text = "Project";

// Load the graph xml
var assembly = typeof(App).GetTypeInfo().Assembly;
Stream stream = assembly.GetManifestResourceStream("Tutorial2.SampleTree.xml");

string text;
using (var reader = new StreamReader(stream))
{
text = reader.ReadToEnd();
}

XDocument document = XDocument.Parse(text);
CreateChildren(root, document.Root);

5. Define CreateChildren as follows. It takes as parameters the parent DiagramNode and parent XML element, iterates the child XML elements to build the next level of the hierarchy, and creates corresponding diagram items by calling CreateShapeNode and CreateDiagramLink.

C# [image] Copy Code

void CreateChildren(DiagramNode parentDiagNode, XElement parentXmlElement)
{
var activities = parentXmlNode.Elements();
foreach (var activity in activities)
{
if (activity.Name == "Activity")
{
var node = diagram.Factory.CreateShapeNode(bounds);
node.Text = activity.Attribute(XName.Get("Name")).Value;
diagram.Factory.CreateDiagramLink(parentDiagNode, node);
CreateChildren(node, activity);
}
}
}

6. Use TreeLayout to arrange the diagram. Add the following code to the end of the Loaded handler.

C# [image] Copy Code

var layout = new TreeLayout();
layout.Type = TreeLayoutType.Cascading;
layout.Direction = TreeLayoutDirections.LeftToRight;
layout.LinkStyle = TreeLayoutLinkType.Cascading2;
layout.NodeDistance = 3;
layout.LevelDistance = -8;
layout.Arrange(diagram);

7. Build and run the project. If everything is fine, you should see this representation of the hierarchy:

Complete sample project is available in Samples/Tutorial2 folder from distribution.


Reference

Diagramming for .NET MAUI Guide © 2023 MindFusion


MindFusion Namespace
Classes Interfaces Structures Enumerations

Classes

Class | Description
DoubleUtils | For internal use.
Extensions |
GeneralFormat | Encapsulates a string that can be used to format arbitrary objects.
Geometry | Provides various conversions.
Line | Represents a line in the plane defined by two points.
PlatformProvider | A IPlatformProvider implementation.
Polygon | Represents immutable closed plane figure with three or more straight sides.
Resources |
Utilities | Contains common helper methods.
XmlElementNameAttribute | Specifies a string to be used as a XmlElement name of a type during XML serialization.

Interfaces

Interface | Description
IDisplayService |
IPlatformProvider | Represents a platform-independent object that can provide type information.
ISupportInitialize | Provides support for simple, transacted notification for batch initialization.
ViewWithCursor |

Structures

Structure | Description
PointI | Represents a point with integer coordinates.
RectangleI | Represents a rectangle with integer coordinates.
Vector | Represents a two-dimensional vector.

Enumerations

Enumeration | Description
PlatformType | Specifies the type of a platform.


MindFusion.DoubleUtils Class

DoubleUtils Class
See Also
[image]

For internal use.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class DoubleUtils

Visual Basic [image] Copy Code

Public NotInheritable Class DoubleUtils

Inheritance Hierarchy

System.Object
MindFusion.DoubleUtils

See Also

DoubleUtils Members
MindFusion Namespace


MindFusion.DoubleUtils Members

DoubleUtils Members
Fields Methods
[image]

For internal use.

The following tables list the members exposed by the DoubleUtils type.

Public Fields

Name | Description
Epsilon | For internal use.

Public Methods

Name | Description
AreClose | For internal use.
Equals | For internal use.
IsZero | For internal use.

See Also

DoubleUtils Class
MindFusion Namespace


MindFusion.DoubleUtils Fields

DoubleUtils Fields
[image]

Public Fields

Name | Description
Epsilon | For internal use.

See Also

DoubleUtils Class
MindFusion Namespace


MindFusion.DoubleUtils.Epsilon Field

DoubleUtils.Epsilon Field
[image]

For internal use.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly double Epsilon

Visual Basic [image] Copy Code

Public Shared ReadOnly Epsilon As Double

See Also

DoubleUtils Members
DoubleUtils Class
MindFusion Namespace


MindFusion.DoubleUtils Methods

DoubleUtils Methods
[image]

Public Methods

Name | Description
AreClose | For internal use.
Equals | For internal use.
IsZero | For internal use.

See Also

DoubleUtils Class
MindFusion Namespace


MindFusion.DoubleUtils.AreClose Method

DoubleUtils.AreClose Method
[image]

For internal use.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool AreClose (
double a,
double b
)

Visual Basic [image] Copy Code

Public Shared Function AreClose( _
a As Double, _
b As Double _
) As Boolean

Parameters

a

b

Return Value

See Also

DoubleUtils Members
DoubleUtils Class
MindFusion Namespace


MindFusion.DoubleUtils.Equals Method

DoubleUtils.Equals Method
[image]

For internal use.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool Equals (
double a,
double b
)

Visual Basic [image] Copy Code

Public Shared Function Equals( _
a As Double, _
b As Double _
) As Boolean

Parameters

a

b

Return Value

See Also

DoubleUtils Members
DoubleUtils Class
MindFusion Namespace


MindFusion.DoubleUtils.IsZero Method

DoubleUtils.IsZero Method
[image]

For internal use.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool IsZero (
double a
)

Visual Basic [image] Copy Code

Public Shared Function IsZero( _
a As Double _
) As Boolean

Parameters

a

Return Value

See Also

DoubleUtils Members
DoubleUtils Class
MindFusion Namespace


MindFusion.Extensions Class

Extensions Class
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class Extensions

Visual Basic [image] Copy Code

Public NotInheritable Class Extensions

Inheritance Hierarchy

System.Object
MindFusion.Extensions

See Also

Extensions Members
MindFusion Namespace


MindFusion.Extensions Members

Extensions Members
Methods
[image]

The following tables list the members exposed by the Extensions type.

Public Methods

Name | Description
GetAttribute |
HasAttribute |
IsEmpty |
IsTransparent |
Normalize |
OnPlatform |
SetAttribute |
SymmetricPoint |
ToArgb |
ToDayOfWeek |
ToInt |
WithOpacity |

See Also

Extensions Class
MindFusion Namespace


MindFusion.Extensions Methods

Extensions Methods
[image]

Public Methods

Name | Description
GetAttribute |
HasAttribute |
IsEmpty |
IsTransparent |
Normalize |
OnPlatform |
SetAttribute |
SymmetricPoint |
ToArgb |
ToDayOfWeek |
ToInt |
WithOpacity |

See Also

Extensions Class
MindFusion Namespace


MindFusion.Extensions.GetAttribute Method

Extensions.GetAttribute Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string GetAttribute (
XElement element,
string name
)

Visual Basic [image] Copy Code

Public Shared Function GetAttribute( _
element As XElement, _
name As String _
) As String

Parameters

element

name

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.HasAttribute Method

Extensions.HasAttribute Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool HasAttribute (
XElement element,
string name
)

Visual Basic [image] Copy Code

Public Shared Function HasAttribute( _
element As XElement, _
name As String _
) As Boolean

Parameters

element

name

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.IsEmpty Method

Extensions.IsEmpty Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool IsEmpty (
Color color
)

Visual Basic [image] Copy Code

Public Shared Function IsEmpty( _
color As Color _
) As Boolean

Parameters

color

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.IsTransparent Method

Extensions.IsTransparent Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool IsTransparent (
Color color
)

Visual Basic [image] Copy Code

Public Shared Function IsTransparent( _
color As Color _
) As Boolean

Parameters

color

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.Normalize Method

Extensions.Normalize Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Rect Normalize (
Rect rect
)

Visual Basic [image] Copy Code

Public Shared Function Normalize( _
rect As Rect _
) As Rect

Parameters

rect

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.OnPlatform(T) Method

Extensions.OnPlatform(T) Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static T OnPlatform<T> (
T iOS,
T android,
T winPhone
)

Visual Basic [image] Copy Code

Public Shared Function OnPlatform(Of T) ( _
iOS As T, _
android As T, _
winPhone As T _
) As T

Parameters

iOS

android

winPhone

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.SetAttribute Method

Extensions.SetAttribute Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static void SetAttribute (
XElement element,
string name,
string value
)

Visual Basic [image] Copy Code

Public Shared Sub SetAttribute( _
element As XElement, _
name As String, _
value As String _
)

Parameters

element

name

value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.SymmetricPoint Method

Extensions.SymmetricPoint Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point SymmetricPoint (
Point point,
Point pivot
)

Visual Basic [image] Copy Code

Public Shared Function SymmetricPoint( _
point As Point, _
pivot As Point _
) As Point

Parameters

point

pivot

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.ToArgb Method

Extensions.ToArgb Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static int ToArgb (
Color color
)

Visual Basic [image] Copy Code

Public Shared Function ToArgb( _
color As Color _
) As Integer

Parameters

color

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.ToDayOfWeek Method

Extensions.ToDayOfWeek Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static DayOfWeek ToDayOfWeek (
int value
)

Visual Basic [image] Copy Code

Public Shared Function ToDayOfWeek( _
value As Integer _
) As DayOfWeek

Parameters

value

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.ToInt Method

Extensions.ToInt Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static int ToInt (
DayOfWeek value
)

Visual Basic [image] Copy Code

Public Shared Function ToInt( _
value As DayOfWeek _
) As Integer

Parameters

value

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.Extensions.WithOpacity Method

Extensions.WithOpacity Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Color WithOpacity (
Color color,
int alpha
)

Visual Basic [image] Copy Code

Public Shared Function WithOpacity( _
color As Color, _
alpha As Integer _
) As Color

Parameters

color

alpha

Return Value

See Also

Extensions Members
Extensions Class
MindFusion Namespace


MindFusion.GeneralFormat Class

GeneralFormat Class
Remarks See Also
[image]

Encapsulates a string that can be used to format arbitrary objects.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class GeneralFormat

Visual Basic [image] Copy Code

Public Class GeneralFormat

Remarks

The format has the following specification: Text {PropertyName:FormattingSpecifiers} Text

Inheritance Hierarchy

System.Object
MindFusion.GeneralFormat

See Also

GeneralFormat Members
MindFusion Namespace


MindFusion.GeneralFormat Members

GeneralFormat Members
Constructors Methods
[image]

Encapsulates a string that can be used to format arbitrary objects.

The following tables list the members exposed by the GeneralFormat type.

Public Constructors

Name | Description
GeneralFormat | Initializes a new instance of the GeneralFormat class.

Public Methods

Name | Description
Process | Overloaded.

See Also

GeneralFormat Class
MindFusion Namespace


MindFusion.GeneralFormat Constructor

GeneralFormat Constructor
[image]

Initializes a new instance of the GeneralFormat class.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public GeneralFormat (
string format
)

Visual Basic [image] Copy Code

Public New ( _
format As String _
)

Parameters

format

See Also

GeneralFormat Class
MindFusion Namespace


MindFusion.GeneralFormat Methods

GeneralFormat Methods
[image]

Public Methods

Name | Description
Process | Overloaded.

See Also

GeneralFormat Class
MindFusion Namespace


MindFusion.GeneralFormat.Process Method

GeneralFormat.Process Method
[image]

Overload List

Name | Description
GeneralFormat.Process (Object) | Converts the specified object to a string according to the underlying formatting string.
GeneralFormat.Process (Object, IFormatProvider) | Converts the specified object to a string according to the underlying formatting string.

See Also

GeneralFormat Members
GeneralFormat Class
MindFusion Namespace


MindFusion.GeneralFormat.Process Method (Object)

GeneralFormat.Process Method (Object)
See Also
[image]

Converts the specified object to a string according to the underlying formatting string.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public string Process (
Object value
)

Visual Basic [image] Copy Code

Public Function Process( _
value As Object _
) As String

Parameters

value

Return Value

See Also

Process Method Overload List
GeneralFormat Members
GeneralFormat Class
MindFusion Namespace


MindFusion.GeneralFormat.Process Method (Object, IFormatProvider)

GeneralFormat.Process Method (Object, IFormatProvider)
See Also
[image]

Converts the specified object to a string according to the underlying formatting string.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public string Process (
Object value,
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Function Process( _
value As Object, _
provider As IFormatProvider _
) As String

Parameters

value

provider

Return Value

See Also

Process Method Overload List
GeneralFormat Members
GeneralFormat Class
MindFusion Namespace


MindFusion.Geometry Class

Geometry Class
[image]

Provides various conversions.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class Geometry

Visual Basic [image] Copy Code

Public NotInheritable Class Geometry

Inheritance Hierarchy

System.Object
MindFusion.Geometry

See Also

Geometry Members
MindFusion Namespace


MindFusion.Geometry Members

Geometry Members
Methods
[image]

Provides various conversions.

The following tables list the members exposed by the Geometry type.

Public Methods

Name | Description
AngleFromPoints | Returns the angle between (p1, p2) and (p1, p3).
CartesianToPolar | Overloaded.
CartesianToPolarRad | Converts the specified point from cartesian to polar coordinates.
Degrees | Converts the specified angle from radians to degrees.
Distance | Calculates the distance between the specified points.
PolarToCartesian | Overloaded.
PolarToCartesianRad | Converts the specified point from polar to cartesian coordinates.
Radians | Converts the specified angle from degrees to radians.
RotatePoint | Rotates the specified point around the specified pivot at the specified angle.
RotatePointRad | Rotates the specified point around the specified pivot at the specified angle.

See Also

Geometry Class
MindFusion Namespace


MindFusion.Geometry Methods

Geometry Methods
[image]

Public Methods

Name | Description
AngleFromPoints | Returns the angle between (p1, p2) and (p1, p3).
CartesianToPolar | Overloaded.
CartesianToPolarRad | Converts the specified point from cartesian to polar coordinates.
Degrees | Converts the specified angle from radians to degrees.
Distance | Calculates the distance between the specified points.
PolarToCartesian | Overloaded.
PolarToCartesianRad | Converts the specified point from polar to cartesian coordinates.
Radians | Converts the specified angle from degrees to radians.
RotatePoint | Rotates the specified point around the specified pivot at the specified angle.
RotatePointRad | Rotates the specified point around the specified pivot at the specified angle.

See Also

Geometry Class
MindFusion Namespace


MindFusion.Geometry.AngleFromPoints Method

Geometry.AngleFromPoints Method
[image]

Returns the angle between (p1, p2) and (p1, p3).

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double AngleFromPoints (
Point p1,
Point p2,
Point p3
)

Visual Basic [image] Copy Code

Public Shared Function AngleFromPoints( _
p1 As Point, _
p2 As Point, _
p3 As Point _
) As Double

Parameters

p1

p2

p3

Return Value

See Also

Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.CartesianToPolar Method

Geometry.CartesianToPolar Method
[image]

Overload List

Name | Description
Geometry.CartesianToPolar (Point, Point) | Converts the specified point from cartesian to polar coordinates.
Geometry.CartesianToPolar (Point, Point, Double@, Double@) | Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.

See Also

Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.CartesianToPolar Method (Point, Point)

Geometry.CartesianToPolar Method (Point, Point)
See Also
[image]

Converts the specified point from cartesian to polar coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point CartesianToPolar (
Point center,
Point point
)

Visual Basic [image] Copy Code

Public Shared Function CartesianToPolar( _
center As Point, _
point As Point _
) As Point

Parameters

center

point

Return Value

See Also

CartesianToPolar Method Overload List
Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.CartesianToPolar Method (Point, Point, Double@, Double@)

Geometry.CartesianToPolar Method (Point, Point, Double@, Double@)
See Also
[image]

Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static void CartesianToPolar (
Point coordCenter,
Point point,
ref double a,
ref double r
)

Visual Basic [image] Copy Code

Public Shared Sub CartesianToPolar( _
coordCenter As Point, _
point As Point, _
ByRef a As Double, _
ByRef r As Double _
)

Parameters

coordCenter

point

a

r

See Also

CartesianToPolar Method Overload List
Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.CartesianToPolarRad Method

Geometry.CartesianToPolarRad Method
[image]

Converts the specified point from cartesian to polar coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point CartesianToPolarRad (
Point center,
Point point
)

Visual Basic [image] Copy Code

Public Shared Function CartesianToPolarRad( _
center As Point, _
point As Point _
) As Point

Parameters

center

point

Return Value

See Also

Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.Degrees Method

Geometry.Degrees Method
[image]

Converts the specified angle from radians to degrees.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double Degrees (
double radians
)

Visual Basic [image] Copy Code

Public Shared Function Degrees( _
radians As Double _
) As Double

Parameters

radians

Return Value

See Also

Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.Distance Method

Geometry.Distance Method
[image]

Calculates the distance between the specified points.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double Distance (
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function Distance( _
p1 As Point, _
p2 As Point _
) As Double

Parameters

p1

p2

Return Value

See Also

Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.PolarToCartesian Method

Geometry.PolarToCartesian Method
[image]

Overload List

Name | Description
Geometry.PolarToCartesian (Point, Double, Double, Point@) | Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.
Geometry.PolarToCartesian (Point, Point) | Converts the specified point from polar to cartesian coordinates.

See Also

Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.PolarToCartesian Method (Point, Double, Double, Point@)

Geometry.PolarToCartesian Method (Point, Double, Double, Point@)
See Also
[image]

Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static void PolarToCartesian (
Point coordCenter,
double a,
double r,
ref Point point
)

Visual Basic [image] Copy Code

Public Shared Sub PolarToCartesian( _
coordCenter As Point, _
a As Double, _
r As Double, _
ByRef point As Point _
)

Parameters

coordCenter

a

r

point

See Also

PolarToCartesian Method Overload List
Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.PolarToCartesian Method (Point, Point)

Geometry.PolarToCartesian Method (Point, Point)
See Also
[image]

Converts the specified point from polar to cartesian coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point PolarToCartesian (
Point center,
Point polar
)

Visual Basic [image] Copy Code

Public Shared Function PolarToCartesian( _
center As Point, _
polar As Point _
) As Point

Parameters

center

polar

Return Value

See Also

PolarToCartesian Method Overload List
Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.PolarToCartesianRad Method

Geometry.PolarToCartesianRad Method
[image]

Converts the specified point from polar to cartesian coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point PolarToCartesianRad (
Point center,
Point polar
)

Visual Basic [image] Copy Code

Public Shared Function PolarToCartesianRad( _
center As Point, _
polar As Point _
) As Point

Parameters

center

polar

Return Value

See Also

Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.Radians Method

Geometry.Radians Method
[image]

Converts the specified angle from degrees to radians.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double Radians (
double degrees
)

Visual Basic [image] Copy Code

Public Shared Function Radians( _
degrees As Double _
) As Double

Parameters

degrees

Return Value

See Also

Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.RotatePoint Method

Geometry.RotatePoint Method
[image]

Rotates the specified point around the specified pivot at the specified angle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point RotatePoint (
Point point,
Point pivot,
double angle
)

Visual Basic [image] Copy Code

Public Shared Function RotatePoint( _
point As Point, _
pivot As Point, _
angle As Double _
) As Point

Parameters

point

pivot

angle

Return Value

See Also

Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.Geometry.RotatePointRad Method

Geometry.RotatePointRad Method
[image]

Rotates the specified point around the specified pivot at the specified angle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point RotatePointRad (
Point point,
Point pivot,
double angle
)

Visual Basic [image] Copy Code

Public Shared Function RotatePointRad( _
point As Point, _
pivot As Point, _
angle As Double _
) As Point

Parameters

point

pivot

angle

Return Value

See Also

Geometry Members
Geometry Class
MindFusion Namespace


MindFusion.IDisplayService Interface

IDisplayService Interface
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public interface IDisplayService

Visual Basic [image] Copy Code

Public Interface IDisplayService

See Also

IDisplayService Members
MindFusion Namespace


MindFusion.IDisplayService Members

IDisplayService Members
Properties
[image]

The following tables list the members exposed by the IDisplayService type.

Public Properties

Name | Description
DpiX |
DpiY |

See Also

IDisplayService Interface
MindFusion Namespace


MindFusion.IDisplayService Properties

IDisplayService Properties
[image]

Public Properties

Name | Description
DpiX |
DpiY |

See Also

IDisplayService Interface
MindFusion Namespace


MindFusion.IDisplayService.DpiX Property

IDisplayService.DpiX Property
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

double DpiX { get; }

Visual Basic [image] Copy Code

ReadOnly Property DpiX As Double

Property Value

See Also

IDisplayService Members
IDisplayService Interface
MindFusion Namespace


MindFusion.IDisplayService.DpiY Property

IDisplayService.DpiY Property
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

double DpiY { get; }

Visual Basic [image] Copy Code

ReadOnly Property DpiY As Double

Property Value

See Also

IDisplayService Members
IDisplayService Interface
MindFusion Namespace


MindFusion.IPlatformProvider Interface

IPlatformProvider Interface
[image]

Represents a platform-independent object that can provide type information.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public interface IPlatformProvider

Visual Basic [image] Copy Code

Public Interface IPlatformProvider

Inheritors

MindFusion.Diagramming.IDiagramPlatformProvider

See Also

IPlatformProvider Members
MindFusion Namespace


MindFusion.IPlatformProvider Members

IPlatformProvider Members
Properties Methods
[image]

Represents a platform-independent object that can provide type information.

The following tables list the members exposed by the IPlatformProvider type.

Public Properties

Name | Description
PlatformType | Gets the type of the current platform.

Public Methods

Name | Description
AddKeyboardNotifications | Adds keyboard notification for the specified element.
CreateMenuItem | Creates a new context menu item with the specified attributes.
GetConstructor | Gets the constructor of the specified type and with the specified parameters.
GetDisplayService |
GetImageSize | Overloaded.
GetProperty | Gets the property of the specified type with the specified name.
GetRenderedText | Returns a representation of the specified text, which is ready to be rendered.

See Also

IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider Methods

IPlatformProvider Methods
[image]

Public Methods

Name | Description
AddKeyboardNotifications | Adds keyboard notification for the specified element.
CreateMenuItem | Creates a new context menu item with the specified attributes.
GetConstructor | Gets the constructor of the specified type and with the specified parameters.
GetDisplayService |
GetImageSize | Overloaded.
GetProperty | Gets the property of the specified type with the specified name.
GetRenderedText | Returns a representation of the specified text, which is ready to be rendered.

See Also

IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider.AddKeyboardNotifications Method

IPlatformProvider.AddKeyboardNotifications Method
[image]

Adds keyboard notification for the specified element.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddKeyboardNotifications (
Element e
)

Visual Basic [image] Copy Code

Sub AddKeyboardNotifications( _
e As Element _
)

Parameters

e

The element to add notifications for.

See Also

IPlatformProvider Members
IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider.CreateMenuItem Method

IPlatformProvider.CreateMenuItem Method
[image]

Creates a new context menu item with the specified attributes.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IMenuItem CreateMenuItem (
ImageSource source,
Size buttonSize,
Pen strokeColor,
Brush fillBrush,
Size imageSize
)

Visual Basic [image] Copy Code

Function CreateMenuItem( _
source As ImageSource, _
buttonSize As Size, _
strokeColor As Pen, _
fillBrush As Brush, _
imageSize As Size _
) As IMenuItem

Parameters

source

The image of the new button.

buttonSize

The size of the new button.

strokeColor

The stroke color of the new button.

fillBrush

The brush used to fill the button background.

imageSize

The size of the button image.

Return Value

The newly created menu item.

See Also

IPlatformProvider Members
IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider.GetConstructor Method

IPlatformProvider.GetConstructor Method
[image]

Gets the constructor of the specified type and with the specified parameters.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

ConstructorInfo GetConstructor (
Type type,
Type[] parameters
)

Visual Basic [image] Copy Code

Function GetConstructor( _
type As Type, _
parameters() As Type _
) As ConstructorInfo

Parameters

type

The type whose constructor to get.

parameters

The parameters of the constructor.

Return Value

A ConstructorInfo object identifying the constructor.

See Also

IPlatformProvider Members
IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider.GetDisplayService Method

IPlatformProvider.GetDisplayService Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IDisplayService GetDisplayService ()

Visual Basic [image] Copy Code

Function GetDisplayService () As IDisplayService

Return Value

See Also

IPlatformProvider Members
IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider.GetImageSize Method

IPlatformProvider.GetImageSize Method
[image]

Overload List

Name | Description
IPlatformProvider.GetImageSize (ImageSource) | Gets the size of the specified image.
IPlatformProvider.GetImageSize (String, Boolean) | Gets the size of the specified image.

See Also

IPlatformProvider Members
IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider.GetImageSize Method (ImageSource)

IPlatformProvider.GetImageSize Method (ImageSource)
See Also
[image]

Gets the size of the specified image.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Size GetImageSize (
ImageSource source
)

Visual Basic [image] Copy Code

Function GetImageSize( _
source As ImageSource _
) As Size

Parameters

source

The source of image to inspect.

Return Value

The size of the image.

See Also

GetImageSize Method Overload List
IPlatformProvider Members
IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider.GetImageSize Method (String, Boolean)

IPlatformProvider.GetImageSize Method (String, Boolean)
See Also
[image]

Gets the size of the specified image.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Size GetImageSize (
string fileName,
bool isEmbedded
)

Visual Basic [image] Copy Code

Function GetImageSize( _
fileName As String, _
isEmbedded As Boolean _
) As Size

Parameters

fileName

The image to inspect.

isEmbedded

A flag indicating whether the specified file name identifies an embedded resource.

Return Value

The size of the image.

See Also

GetImageSize Method Overload List
IPlatformProvider Members
IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider.GetProperty Method

IPlatformProvider.GetProperty Method
[image]

Gets the property of the specified type with the specified name.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

PropertyInfo GetProperty (
Type type,
string name
)

Visual Basic [image] Copy Code

Function GetProperty( _
type As Type, _
name As String _
) As PropertyInfo

Parameters

type

The type whose property to get.

name

The name of the property.

Return Value

A PropertyInfo object identifying the property.

See Also

IPlatformProvider Members
IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider.GetRenderedText Method

IPlatformProvider.GetRenderedText Method
[image]

Returns a representation of the specified text, which is ready to be rendered.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

string GetRenderedText (
string text,
Font font,
Brush brush,
Rect rect,
StringFormat format
)

Visual Basic [image] Copy Code

Function GetRenderedText( _
text As String, _
font As Font, _
brush As Brush, _
rect As Rect, _
format As StringFormat _
) As String

Parameters

text

The text to be processed.

font

The font the text will be rendered with.

brush

The brush that will be used to render the text.

rect

The target rectangle where the text will be rendered.

format

The alignment and format of the rendered text.

Return Value

The render-ready representation of the text.

See Also

IPlatformProvider Members
IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider Properties

IPlatformProvider Properties
[image]

Public Properties

Name | Description
PlatformType | Gets the type of the current platform.

See Also

IPlatformProvider Interface
MindFusion Namespace


MindFusion.IPlatformProvider.PlatformType Property

IPlatformProvider.PlatformType Property
[image]

Gets the type of the current platform.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

PlatformType PlatformType { get; }

Visual Basic [image] Copy Code

ReadOnly Property PlatformType As PlatformType

Property Value

A member of the PlatformType enumeration.

See Also

IPlatformProvider Members
IPlatformProvider Interface
MindFusion Namespace


MindFusion.ISupportInitialize Interface

ISupportInitialize Interface
[image]

Provides support for simple, transacted notification for batch initialization.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public interface ISupportInitialize

Visual Basic [image] Copy Code

Public Interface ISupportInitialize

See Also

ISupportInitialize Members
MindFusion Namespace


MindFusion.ISupportInitialize Members

ISupportInitialize Members
Methods
[image]

Provides support for simple, transacted notification for batch initialization.

The following tables list the members exposed by the ISupportInitialize type.

Public Methods

Name | Description
BeginInit | Signals the object that initialization is starting.
EndInit | Signals the object that initialization is complete.

See Also

ISupportInitialize Interface
MindFusion Namespace


MindFusion.ISupportInitialize Methods

ISupportInitialize Methods
[image]

Public Methods

Name | Description
BeginInit | Signals the object that initialization is starting.
EndInit | Signals the object that initialization is complete.

See Also

ISupportInitialize Interface
MindFusion Namespace


MindFusion.ISupportInitialize.BeginInit Method

ISupportInitialize.BeginInit Method
[image]

Signals the object that initialization is starting.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void BeginInit ()

Visual Basic [image] Copy Code

Sub BeginInit ()

See Also

ISupportInitialize Members
ISupportInitialize Interface
MindFusion Namespace


MindFusion.ISupportInitialize.EndInit Method

ISupportInitialize.EndInit Method
[image]

Signals the object that initialization is complete.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void EndInit ()

Visual Basic [image] Copy Code

Sub EndInit ()

See Also

ISupportInitialize Members
ISupportInitialize Interface
MindFusion Namespace


MindFusion.Line Class

Line Class
[image]

Represents a line in the plane defined by two points.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class Line

Visual Basic [image] Copy Code

Public Class Line

Inheritance Hierarchy

System.Object
MindFusion.Line

See Also

Line Members
MindFusion Namespace


MindFusion.Line Members

Line Members
Constructors Properties Methods
[image]

Represents a line in the plane defined by two points.

The following tables list the members exposed by the Line type.

Public Constructors

Name | Description
Line | Overloaded.

Public Properties

Name | Description
A | Gets or sets the first point defining the line.
B | Gets or sets the second point defining the line.
Bounds | Gets the smallest rectangle bounding the segment which defines the line.

Public Methods

Name | Description
ContainsInSegment | Checks whether the given point lies on the line segment.
IntersectLine | Overloaded.
IntersectSegment | Overloaded.

See Also

Line Class
MindFusion Namespace


MindFusion.Line Constructor

Line Constructor
[image]

Overload List

Name | Description
Line (Line) | Initializes a new instance of the Line class.
Line (Point, Point) | Initializes a new instance of the Line class.

See Also

Line Class
MindFusion Namespace


MindFusion.Line Constructor (Line)

Line Constructor (Line)
See Also
[image]

Initializes a new instance of the Line class.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Line (
Line line
)

Visual Basic [image] Copy Code

Public New ( _
line As Line _
)

Parameters

line

See Also

Line Constructor Overload List
Line Class
MindFusion Namespace


MindFusion.Line Constructor (Point, Point)

Line Constructor (Point, Point)
See Also
[image]

Initializes a new instance of the Line class.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Line (
Point a,
Point b
)

Visual Basic [image] Copy Code

Public New ( _
a As Point, _
b As Point _
)

Parameters

a

b

See Also

Line Constructor Overload List
Line Class
MindFusion Namespace


MindFusion.Line Methods

Line Methods
[image]

Public Methods

Name | Description
ContainsInSegment | Checks whether the given point lies on the line segment.
IntersectLine | Overloaded.
IntersectSegment | Overloaded.

See Also

Line Class
MindFusion Namespace


MindFusion.Line.ContainsInSegment Method

Line.ContainsInSegment Method
[image]

Checks whether the given point lies on the line segment.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public bool ContainsInSegment (
Point point
)

Visual Basic [image] Copy Code

Public Function ContainsInSegment( _
point As Point _
) As Boolean

Parameters

point

Return Value

See Also

Line Members
Line Class
MindFusion Namespace


MindFusion.Line.IntersectLine Method

Line.IntersectLine Method
[image]

Overload List

Name | Description
Line.IntersectLine (Line) | Calculates the intersection point with the specified line. If there is no intersection the return value is an infinite point.
Line.IntersectLine (Point, Point) | Calculates the intersection point with the line defined by the given points. If there is no intersection the return value is an infinite point.

See Also

Line Members
Line Class
MindFusion Namespace


MindFusion.Line.IntersectLine Method (Line)

Line.IntersectLine Method (Line)
See Also
[image]

Calculates the intersection point with the specified line. If there is no intersection the return value is an infinite point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Point IntersectLine (
Line line
)

Visual Basic [image] Copy Code

Public Function IntersectLine( _
line As Line _
) As Point

Parameters

line

Return Value

See Also

IntersectLine Method Overload List
Line Members
Line Class
MindFusion Namespace


MindFusion.Line.IntersectLine Method (Point, Point)

Line.IntersectLine Method (Point, Point)
See Also
[image]

Calculates the intersection point with the line defined by the given points. If there is no intersection the return value is an infinite point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Point IntersectLine (
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Function IntersectLine( _
a As Point, _
b As Point _
) As Point

Parameters

a

b

Return Value

See Also

IntersectLine Method Overload List
Line Members
Line Class
MindFusion Namespace


MindFusion.Line.IntersectSegment Method

Line.IntersectSegment Method
[image]

Overload List

Name | Description
Line.IntersectSegment (Line) | Calculates the intersection point with the given line segment. If there is no intersection the return value is an infinite point.
Line.IntersectSegment (Point, Point) | Calculates the intersection point with the line segment defined by the given points. If there is no intersection the return value is an infinite point.

See Also

Line Members
Line Class
MindFusion Namespace


MindFusion.Line.IntersectSegment Method (Line)

Line.IntersectSegment Method (Line)
See Also
[image]

Calculates the intersection point with the given line segment. If there is no intersection the return value is an infinite point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Point IntersectSegment (
Line line
)

Visual Basic [image] Copy Code

Public Function IntersectSegment( _
line As Line _
) As Point

Parameters

line

Return Value

See Also

IntersectSegment Method Overload List
Line Members
Line Class
MindFusion Namespace


MindFusion.Line.IntersectSegment Method (Point, Point)

Line.IntersectSegment Method (Point, Point)
See Also
[image]

Calculates the intersection point with the line segment defined by the given points. If there is no intersection the return value is an infinite point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Point IntersectSegment (
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Function IntersectSegment( _
a As Point, _
b As Point _
) As Point

Parameters

a

b

Return Value

See Also

IntersectSegment Method Overload List
Line Members
Line Class
MindFusion Namespace


MindFusion.Line Properties

Line Properties
[image]

Public Properties

Name | Description
A | Gets or sets the first point defining the line.
B | Gets or sets the second point defining the line.
Bounds | Gets the smallest rectangle bounding the segment which defines the line.

See Also

Line Class
MindFusion Namespace


MindFusion.Line.A Property

Line.A Property
[image]

Gets or sets the first point defining the line.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Point A { get; set; }

Visual Basic [image] Copy Code

Public Property A As Point

Property Value

See Also

Line Members
Line Class
MindFusion Namespace


MindFusion.Line.B Property

Line.B Property
[image]

Gets or sets the second point defining the line.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Point B { get; set; }

Visual Basic [image] Copy Code

Public Property B As Point

Property Value

See Also

Line Members
Line Class
MindFusion Namespace


MindFusion.Line.Bounds Property

Line.Bounds Property
[image]

Gets the smallest rectangle bounding the segment which defines the line.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

See Also

Line Members
Line Class
MindFusion Namespace


MindFusion.PlatformProvider Class

PlatformProvider Class
[image]

A IPlatformProvider implementation.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class PlatformProvider

Visual Basic [image] Copy Code

Public NotInheritable Class PlatformProvider

Inheritance Hierarchy

System.Object
MindFusion.PlatformProvider

See Also

PlatformProvider Members
MindFusion Namespace


MindFusion.PlatformProvider Members

PlatformProvider Members
Properties Methods
[image]

A IPlatformProvider implementation.

The following tables list the members exposed by the PlatformProvider type.

Public Properties

Name | Description
PlatformType | Implements IPlatformProvider.PlatformType

Public Methods

Name | Description
AddKeyboardNotifications | Implements IPlatformProvider.AddKeyboardNotifications
GetConstructor | Implements IPlatformProvider.GetConstructor.
GetDisplayService |
GetImageSize | Overloaded.
GetProperty | Implements IPlatformProvider.GetProperty.
GetRenderedText | Implements IPlatformProvider.GetRenderedText

See Also

PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider Methods

PlatformProvider Methods
[image]

Public Methods

Name | Description
AddKeyboardNotifications | Implements IPlatformProvider.AddKeyboardNotifications
GetConstructor | Implements IPlatformProvider.GetConstructor.
GetDisplayService |
GetImageSize | Overloaded.
GetProperty | Implements IPlatformProvider.GetProperty.
GetRenderedText | Implements IPlatformProvider.GetRenderedText

See Also

PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider.AddKeyboardNotifications Method

PlatformProvider.AddKeyboardNotifications Method
[image]

Implements IPlatformProvider.AddKeyboardNotifications

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static void AddKeyboardNotifications (
Element e
)

Visual Basic [image] Copy Code

Public Shared Sub AddKeyboardNotifications( _
e As Element _
)

Parameters

e

See Also

PlatformProvider Members
PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider.GetConstructor Method

PlatformProvider.GetConstructor Method
[image]

Implements IPlatformProvider.GetConstructor.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static ConstructorInfo GetConstructor (
Type type,
Type[] parameters
)

Visual Basic [image] Copy Code

Public Shared Function GetConstructor( _
type As Type, _
parameters() As Type _
) As ConstructorInfo

Parameters

type

parameters

Return Value

See Also

PlatformProvider Members
PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider.GetDisplayService Method

PlatformProvider.GetDisplayService Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static IDisplayService GetDisplayService ()

Visual Basic [image] Copy Code

Public Shared Function GetDisplayService () As IDisplayService

Return Value

See Also

PlatformProvider Members
PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider.GetImageSize Method

PlatformProvider.GetImageSize Method
[image]

Overload List

Name | Description
PlatformProvider.GetImageSize (ImageSource) | Implements IPlatformProvider.GetImageSize
PlatformProvider.GetImageSize (String, Boolean) | Implements IPlatformProvider.GetImageSize

See Also

PlatformProvider Members
PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider.GetImageSize Method (ImageSource)

PlatformProvider.GetImageSize Method (ImageSource)
See Also
[image]

Implements IPlatformProvider.GetImageSize

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Size GetImageSize (
ImageSource source
)

Visual Basic [image] Copy Code

Public Shared Function GetImageSize( _
source As ImageSource _
) As Size

Parameters

source

Return Value

See Also

GetImageSize Method Overload List
PlatformProvider Members
PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider.GetImageSize Method (String, Boolean)

PlatformProvider.GetImageSize Method (String, Boolean)
See Also
[image]

Implements IPlatformProvider.GetImageSize

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Size GetImageSize (
string fileName,
bool isEmbedded
)

Visual Basic [image] Copy Code

Public Shared Function GetImageSize( _
fileName As String, _
isEmbedded As Boolean _
) As Size

Parameters

fileName

isEmbedded

Return Value

See Also

GetImageSize Method Overload List
PlatformProvider Members
PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider.GetProperty Method

PlatformProvider.GetProperty Method
[image]

Implements IPlatformProvider.GetProperty.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static PropertyInfo GetProperty (
Type type,
string name
)

Visual Basic [image] Copy Code

Public Shared Function GetProperty( _
type As Type, _
name As String _
) As PropertyInfo

Parameters

type

name

Return Value

See Also

PlatformProvider Members
PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider.GetRenderedText Method

PlatformProvider.GetRenderedText Method
[image]

Implements IPlatformProvider.GetRenderedText

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string GetRenderedText (
string text,
Font font,
Brush brush,
Rect rect,
StringFormat format
)

Visual Basic [image] Copy Code

Public Shared Function GetRenderedText( _
text As String, _
font As Font, _
brush As Brush, _
rect As Rect, _
format As StringFormat _
) As String

Parameters

text

font

brush

rect

format

Return Value

See Also

PlatformProvider Members
PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider Properties

PlatformProvider Properties
[image]

Public Properties

Name | Description
PlatformType | Implements IPlatformProvider.PlatformType

See Also

PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformProvider.PlatformType Property

PlatformProvider.PlatformType Property
[image]

Implements IPlatformProvider.PlatformType

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static PlatformType PlatformType { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PlatformType As PlatformType

Property Value

See Also

PlatformProvider Members
PlatformProvider Class
MindFusion Namespace


MindFusion.PlatformType Enumeration

PlatformType Enumeration
[image]

Specifies the type of a platform.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum PlatformType

Visual Basic [image] Copy Code

Public Enum PlatformType

Members

Member name | Description
Android | Indicates the Android platform.
IOS | Indicates the iOS platform.
UWP | Indicates the Universal Windows platform.
WindowsMobile | Indicates the Windows Mobile platform.

See Also

MindFusion Namespace


MindFusion.PointI Structure

PointI Structure
[image]

Represents a point with integer coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public struct PointI

Visual Basic [image] Copy Code

Public Structure PointI

See Also

PointI Members
MindFusion Namespace


MindFusion.PointI Members

PointI Members
Constructors Fields Properties Methods
[image]

Represents a point with integer coordinates.

The following tables list the members exposed by the PointI type.

Public Constructors

Name | Description
PointI | Initializes a new instance of the PointI class.

Public Fields

Name | Description
Zero | A zero point.

Public Properties

Name | Description
IsEmpty | Gets a value indicating whether this instance is empty.
X | Gets or sets the x-coordinate of the point.
Y | Gets or sets the y-coordinate of the point.

Public Methods

Name | Description
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.
ManhDistance | Returns the Manhattan distance between this point and the specified point.
ToString | Object.ToString override.

See Also

PointI Structure
MindFusion Namespace


MindFusion.PointI Fields

PointI Fields
[image]

Public Fields

Name | Description
Zero | A zero point.

See Also

PointI Structure
MindFusion Namespace


MindFusion.PointI.Zero Field

PointI.Zero Field
[image]

A zero point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly PointI Zero

Visual Basic [image] Copy Code

Public Shared ReadOnly Zero As PointI

See Also

PointI Members
PointI Structure
MindFusion Namespace


MindFusion.PointI Constructor

PointI Constructor
[image]

Initializes a new instance of the PointI class.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PointI (
int x,
int y
)

Visual Basic [image] Copy Code

Public New ( _
x As Integer, _
y As Integer _
)

Parameters

x

y

See Also

PointI Structure
MindFusion Namespace


MindFusion.PointI Methods

PointI Methods
[image]

Public Methods

Name | Description
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.
ManhDistance | Returns the Manhattan distance between this point and the specified point.
ToString | Object.ToString override.

See Also

PointI Structure
MindFusion Namespace


MindFusion.PointI.Equals Method

PointI.Equals Method
[image]

Object.Equals override.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

Return Value

See Also

PointI Members
PointI Structure
MindFusion Namespace


MindFusion.PointI.GetHashCode Method

PointI.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

PointI Members
PointI Structure
MindFusion Namespace


MindFusion.PointI.ManhDistance Method

PointI.ManhDistance Method
[image]

Returns the Manhattan distance between this point and the specified point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int ManhDistance (
PointI p
)

Visual Basic [image] Copy Code

Public Function ManhDistance( _
p As PointI _
) As Integer

Parameters

p

Return Value

See Also

PointI Members
PointI Structure
MindFusion Namespace


MindFusion.PointI.ToString Method

PointI.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

PointI Members
PointI Structure
MindFusion Namespace


MindFusion.PointI Properties

PointI Properties
[image]

Public Properties

Name | Description
IsEmpty | Gets a value indicating whether this instance is empty.
X | Gets or sets the x-coordinate of the point.
Y | Gets or sets the y-coordinate of the point.

See Also

PointI Structure
MindFusion Namespace


MindFusion.PointI.IsEmpty Property

PointI.IsEmpty Property
[image]

Gets a value indicating whether this instance is empty.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

See Also

PointI Members
PointI Structure
MindFusion Namespace


MindFusion.PointI.X Property

PointI.X Property
[image]

Gets or sets the x-coordinate of the point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Integer

Property Value

See Also

PointI Members
PointI Structure
MindFusion Namespace


MindFusion.PointI.Y Property

PointI.Y Property
[image]

Gets or sets the y-coordinate of the point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Integer

Property Value

See Also

PointI Members
PointI Structure
MindFusion Namespace


MindFusion.Polygon Class

Polygon Class
[image]

Represents immutable closed plane figure with three or more straight sides.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class Polygon

Visual Basic [image] Copy Code

Public Class Polygon

Inheritance Hierarchy

System.Object
MindFusion.Polygon

See Also

Polygon Members
MindFusion Namespace


MindFusion.Polygon Members

Polygon Members
Constructors Properties Methods
[image]

Represents immutable closed plane figure with three or more straight sides.

The following tables list the members exposed by the Polygon type.

Public Constructors

Name | Description
Polygon | Overloaded.

Public Properties

Name | Description
Bounds | Gets the smallest rectangle bounding the polygon.
Points | Gets a collection of the polygon points.

Public Methods

Name | Description
Contains | Checks whether the specified point lies whithin the polygon.
FindConvexVertex | Finds a convex vertex of the polygon.
GetInternalPoint | Finds a point inside the polygon.
IntersectLine | Overloaded.
IntersectSegment | Overloaded.

See Also

Polygon Class
MindFusion Namespace


MindFusion.Polygon Constructor

Polygon Constructor
[image]

Overload List

Name | Description
Polygon (List(Point)) | Initializes a new instance of the Polygon class from the specified collection of points.
Polygon (Rect) | Initializes a new instance of the Polygon class from the specified rectangle.

See Also

Polygon Class
MindFusion Namespace


MindFusion.Polygon Constructor (List(Point))

Polygon Constructor (List(Point))
See Also
[image]

Initializes a new instance of the Polygon class from the specified collection of points.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Polygon (
List<Point> points
)

Visual Basic [image] Copy Code

Public New ( _
points As List(Of Point) _
)

Parameters

points

See Also

Polygon Constructor Overload List
Polygon Class
MindFusion Namespace


MindFusion.Polygon Constructor (Rect)

Polygon Constructor (Rect)
See Also
[image]

Initializes a new instance of the Polygon class from the specified rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Polygon (
Rect rect
)

Visual Basic [image] Copy Code

Public New ( _
rect As Rect _
)

Parameters

rect

See Also

Polygon Constructor Overload List
Polygon Class
MindFusion Namespace


MindFusion.Polygon Methods

Polygon Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified point lies whithin the polygon.
FindConvexVertex | Finds a convex vertex of the polygon.
GetInternalPoint | Finds a point inside the polygon.
IntersectLine | Overloaded.
IntersectSegment | Overloaded.

See Also

Polygon Class
MindFusion Namespace


MindFusion.Polygon.Contains Method

Polygon.Contains Method
[image]

Checks whether the specified point lies whithin the polygon.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public bool Contains (
Point point
)

Visual Basic [image] Copy Code

Public Function Contains( _
point As Point _
) As Boolean

Parameters

point

Return Value

See Also

Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.Polygon.FindConvexVertex Method

Polygon.FindConvexVertex Method
[image]

Finds a convex vertex of the polygon.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int FindConvexVertex ()

Visual Basic [image] Copy Code

Public Function FindConvexVertex () As Integer

Return Value

See Also

Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.Polygon.GetInternalPoint Method

Polygon.GetInternalPoint Method
[image]

Finds a point inside the polygon.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Point GetInternalPoint ()

Visual Basic [image] Copy Code

Public Function GetInternalPoint () As Point

Return Value

See Also

Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.Polygon.IntersectLine Method

Polygon.IntersectLine Method
[image]

Overload List

Name | Description
Polygon.IntersectLine (Line) | Calculates the intersections between the polygon and the given line. The result is a list containing all points of intersection.
Polygon.IntersectLine (Point, Point) | Calculates the intersections between the polygon and the line defined by the given points. The result is a list containing all points of intersection.

See Also

Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.Polygon.IntersectLine Method (Line)

Polygon.IntersectLine Method (Line)
See Also
[image]

Calculates the intersections between the polygon and the given line. The result is a list containing all points of intersection.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public List<Point> IntersectLine (
Line line
)

Visual Basic [image] Copy Code

Public Function IntersectLine( _
line As Line _
) As List(Of Point)

Parameters

line

Return Value

See Also

IntersectLine Method Overload List
Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.Polygon.IntersectLine Method (Point, Point)

Polygon.IntersectLine Method (Point, Point)
See Also
[image]

Calculates the intersections between the polygon and the line defined by the given points. The result is a list containing all points of intersection.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public List<Point> IntersectLine (
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Function IntersectLine( _
a As Point, _
b As Point _
) As List(Of Point)

Parameters

a

b

Return Value

See Also

IntersectLine Method Overload List
Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.Polygon.IntersectSegment Method

Polygon.IntersectSegment Method
[image]

Overload List

Name | Description
Polygon.IntersectSegment (Line) | Calculates the intersections between the polygon and the given line segment. The result is a list containing all points of intersection.
Polygon.IntersectSegment (Point, Point) | Calculates the intersections between the polygon and the line segment defined by the given points. The result is a list containing all points of intersection.

See Also

Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.Polygon.IntersectSegment Method (Line)

Polygon.IntersectSegment Method (Line)
See Also
[image]

Calculates the intersections between the polygon and the given line segment. The result is a list containing all points of intersection.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public List<Point> IntersectSegment (
Line line
)

Visual Basic [image] Copy Code

Public Function IntersectSegment( _
line As Line _
) As List(Of Point)

Parameters

line

Return Value

See Also

IntersectSegment Method Overload List
Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.Polygon.IntersectSegment Method (Point, Point)

Polygon.IntersectSegment Method (Point, Point)
See Also
[image]

Calculates the intersections between the polygon and the line segment defined by the given points. The result is a list containing all points of intersection.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public List<Point> IntersectSegment (
Point a,
Point b
)

Visual Basic [image] Copy Code

Public Function IntersectSegment( _
a As Point, _
b As Point _
) As List(Of Point)

Parameters

a

b

Return Value

See Also

IntersectSegment Method Overload List
Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.Polygon Properties

Polygon Properties
[image]

Public Properties

Name | Description
Bounds | Gets the smallest rectangle bounding the polygon.
Points | Gets a collection of the polygon points.

See Also

Polygon Class
MindFusion Namespace


MindFusion.Polygon.Bounds Property

Polygon.Bounds Property
[image]

Gets the smallest rectangle bounding the polygon.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

See Also

Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.Polygon.Points Property

Polygon.Points Property
[image]

Gets a collection of the polygon points.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Point[] Points { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Points As Point()

Property Value

See Also

Polygon Members
Polygon Class
MindFusion Namespace


MindFusion.RectangleI Structure

RectangleI Structure
[image]

Represents a rectangle with integer coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public struct RectangleI

Visual Basic [image] Copy Code

Public Structure RectangleI

See Also

RectangleI Members
MindFusion Namespace


MindFusion.RectangleI Members

RectangleI Members
Constructors Fields Properties Methods
[image]

Represents a rectangle with integer coordinates.

The following tables list the members exposed by the RectangleI type.

Public Constructors

Name | Description
RectangleI | Initializes a new instance of the RectangleI struct.

Public Fields

Name | Description
Zero | An empty rectangle.

Public Properties

Name | Description
Bottom | Gets the y-coordinate of the bottom edge of the rectangle.
Height | Gets or sets the height of the rectangle.
IsEmpty | Gets a value indicating whether this instance is empty.
Left | Gets the x-coordinate of the left edge of the rectangle.
Right | Gets the x-coordinate of the right edge of the rectangle.
Top | Gets the y-coordinate of the top edge of the rectangle.
Width | Gets or sets the width of the rectangle.
X | Gets or sets the x-coordinate of the upper left corner of the rectangle.
Y | Gets or sets the y-coordinate of the upper left corner of the rectangle.

Public Methods

Name | Description
Equals | Object.Equals override.
FromLTRB | Constructs a new RectangleI instance from the specified values.
GetHashCode | Object.GetHashCode override.
Offset | Offset the rectangle by the specified values.
ToString | Object.ToString override.

See Also

RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI Fields

RectangleI Fields
[image]

Public Fields

Name | Description
Zero | An empty rectangle.

See Also

RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.Zero Field

RectangleI.Zero Field
[image]

An empty rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly RectangleI Zero

Visual Basic [image] Copy Code

Public Shared ReadOnly Zero As RectangleI

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI Constructor

RectangleI Constructor
[image]

Initializes a new instance of the RectangleI struct.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public RectangleI (
int x,
int y,
int width,
int height
)

Visual Basic [image] Copy Code

Public New ( _
x As Integer, _
y As Integer, _
width As Integer, _
height As Integer _
)

Parameters

x

y

width

height

See Also

RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI Methods

RectangleI Methods
[image]

Public Methods

Name | Description
Equals | Object.Equals override.
FromLTRB | Constructs a new RectangleI instance from the specified values.
GetHashCode | Object.GetHashCode override.
Offset | Offset the rectangle by the specified values.
ToString | Object.ToString override.

See Also

RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.Equals Method

RectangleI.Equals Method
[image]

Object.Equals override.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

Return Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.FromLTRB Method

RectangleI.FromLTRB Method
[image]

Constructs a new RectangleI instance from the specified values.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static RectangleI FromLTRB (
int left,
int top,
int right,
int bottom
)

Visual Basic [image] Copy Code

Public Shared Function FromLTRB( _
left As Integer, _
top As Integer, _
right As Integer, _
bottom As Integer _
) As RectangleI

Parameters

left

top

right

bottom

Return Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.GetHashCode Method

RectangleI.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.Offset Method

RectangleI.Offset Method
[image]

Offset the rectangle by the specified values.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Offset (
int x,
int y
)

Visual Basic [image] Copy Code

Public Sub Offset( _
x As Integer, _
y As Integer _
)

Parameters

x

The amount to offset along the x-axis.

y

The amount to offset along the y-axis.

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.ToString Method

RectangleI.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI Properties

RectangleI Properties
[image]

Public Properties

Name | Description
Bottom | Gets the y-coordinate of the bottom edge of the rectangle.
Height | Gets or sets the height of the rectangle.
IsEmpty | Gets a value indicating whether this instance is empty.
Left | Gets the x-coordinate of the left edge of the rectangle.
Right | Gets the x-coordinate of the right edge of the rectangle.
Top | Gets the y-coordinate of the top edge of the rectangle.
Width | Gets or sets the width of the rectangle.
X | Gets or sets the x-coordinate of the upper left corner of the rectangle.
Y | Gets or sets the y-coordinate of the upper left corner of the rectangle.

See Also

RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.Bottom Property

RectangleI.Bottom Property
[image]

Gets the y-coordinate of the bottom edge of the rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Bottom { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bottom As Integer

Property Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.Height Property

RectangleI.Height Property
[image]

Gets or sets the height of the rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Integer

Property Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.IsEmpty Property

RectangleI.IsEmpty Property
[image]

Gets a value indicating whether this instance is empty.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public bool IsEmpty { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsEmpty As Boolean

Property Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.Left Property

RectangleI.Left Property
[image]

Gets the x-coordinate of the left edge of the rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Left { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Left As Integer

Property Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.Right Property

RectangleI.Right Property
[image]

Gets the x-coordinate of the right edge of the rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Right { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Right As Integer

Property Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.Top Property

RectangleI.Top Property
[image]

Gets the y-coordinate of the top edge of the rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Top { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Top As Integer

Property Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.Width Property

RectangleI.Width Property
[image]

Gets or sets the width of the rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Integer

Property Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.X Property

RectangleI.X Property
[image]

Gets or sets the x-coordinate of the upper left corner of the rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Integer

Property Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.RectangleI.Y Property

RectangleI.Y Property
[image]

Gets or sets the y-coordinate of the upper left corner of the rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public int Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Integer

Property Value

See Also

RectangleI Members
RectangleI Structure
MindFusion Namespace


MindFusion.Resources Class

Resources Class
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class Resources

Visual Basic [image] Copy Code

Public NotInheritable Class Resources

Inheritance Hierarchy

System.Object
MindFusion.Resources

See Also

Resources Members
MindFusion Namespace


MindFusion.Resources Members

Resources Members
Fields
[image]

The following tables list the members exposed by the Resources type.

Public Fields

Name | Description
ExAboveHighBound |
ExArrayLength |
ExBadType |
ExBelowLowBound |
ExNullArgument |
ExOutOfRange |

See Also

Resources Class
MindFusion Namespace


MindFusion.Resources Fields

Resources Fields
[image]

Public Fields

Name | Description
ExAboveHighBound |
ExArrayLength |
ExBadType |
ExBelowLowBound |
ExNullArgument |
ExOutOfRange |

See Also

Resources Class
MindFusion Namespace


MindFusion.Resources.ExAboveHighBound Field

Resources.ExAboveHighBound Field
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly string ExAboveHighBound

Visual Basic [image] Copy Code

Public Shared ReadOnly ExAboveHighBound As String

See Also

Resources Members
Resources Class
MindFusion Namespace


MindFusion.Resources.ExArrayLength Field

Resources.ExArrayLength Field
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly string ExArrayLength

Visual Basic [image] Copy Code

Public Shared ReadOnly ExArrayLength As String

See Also

Resources Members
Resources Class
MindFusion Namespace


MindFusion.Resources.ExBadType Field

Resources.ExBadType Field
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly string ExBadType

Visual Basic [image] Copy Code

Public Shared ReadOnly ExBadType As String

See Also

Resources Members
Resources Class
MindFusion Namespace


MindFusion.Resources.ExBelowLowBound Field

Resources.ExBelowLowBound Field
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly string ExBelowLowBound

Visual Basic [image] Copy Code

Public Shared ReadOnly ExBelowLowBound As String

See Also

Resources Members
Resources Class
MindFusion Namespace


MindFusion.Resources.ExNullArgument Field

Resources.ExNullArgument Field
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly string ExNullArgument

Visual Basic [image] Copy Code

Public Shared ReadOnly ExNullArgument As String

See Also

Resources Members
Resources Class
MindFusion Namespace


MindFusion.Resources.ExOutOfRange Field

Resources.ExOutOfRange Field
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly string ExOutOfRange

Visual Basic [image] Copy Code

Public Shared ReadOnly ExOutOfRange As String

See Also

Resources Members
Resources Class
MindFusion Namespace


MindFusion.Utilities Class

Utilities Class
[image]

Contains common helper methods.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class Utilities

Visual Basic [image] Copy Code

Public NotInheritable Class Utilities

Inheritance Hierarchy

System.Object
MindFusion.Utilities

See Also

Utilities Members
MindFusion Namespace


MindFusion.Utilities Members

Utilities Members
Fields Methods
[image]

Contains common helper methods.

The following tables list the members exposed by the Utilities type.

Public Fields

Name | Description
MauiPointScale |

Public Methods

Name | Description
AddPoints | Adds two points. Point.Offset() may be used instead.
ApproxBezier | Approximates the specified bezier curve with a polyline. The specified quality parameter varies in the interval [1, …) and is proportional to the number of points in the resulting polyline.
CalcBezierCoef | Calculates the bezier coefficients in the equation of the specified bezier curve.
CartesianToPolar | Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.
Ccw | Determines, given three points, if when travelling from the first to the second to the third, we travel in a counterclockwise direction.
Closer | Returns the point from the specified pair, which lies closer to the specified pivot.
Degrees | Converts the values expressed in radians to degrees.
DeviceToDoc | Overloaded.
Distance | Overloaded.
DistancePoint | Calculates the point of the the specified line segment which determines the distance from the specified point to the line segment
DistanceSq | Overloaded.
DistToBezier | Calculates the shortest distance from the specified point to the specified bezier curve.
DistToLineSegment | Calculates distance from the specified point to the specified line segment
DistToPolyline | Overloaded.
DistToRect | Calculates distance from the specified point to the specified rectangle.
DocToDevice | Overloaded.
GetBezierPt | Gets the point from the specified bezier curve, corresponding to the specified parameter t [0, 1].
GetEllipseIntr | Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.
GetNearestPt | Calculates the orthogonal projection of the specified point on the line defined be the specified point pair.
GetRectIntr | Calculates the intersection point between the specified rectangle and the line segment defined by the specified points.
Intersect | Determines whether the specified line segments intersect.
LineIntersect | Overloaded.
LineIntersectNaN | Finds the intersection point of the lines defined by the specified point pairs.
PointInEllipse | Checks whether the specified point is contained in the ellipse defined by the specified rectangle.
PointInPolygon | Determines if the specified point is within the specified polygon.
PointInPolyRect | Determines if the specified point is within the smallest rectangle that encloses the specified polygon.
PointInSegment | Checks whether the line segment defined by the specified points contain the specified point.
PolarToCartesian | Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.
Radians | Converts the values expressed in degrees to radians.
SegmentIntersect | Checks whether the segments defined by the specified point pairs intersect and returns the intersection point.

See Also

Utilities Class
MindFusion Namespace


MindFusion.Utilities Fields

Utilities Fields
[image]

Public Fields

Name | Description
MauiPointScale |

See Also

Utilities Class
MindFusion Namespace


MindFusion.Utilities.MauiPointScale Field

Utilities.MauiPointScale Field
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double MauiPointScale

Visual Basic [image] Copy Code

Public Shared MauiPointScale As Double

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities Methods

Utilities Methods
[image]

Public Methods

Name | Description
AddPoints | Adds two points. Point.Offset() may be used instead.
ApproxBezier | Approximates the specified bezier curve with a polyline. The specified quality parameter varies in the interval [1, …) and is proportional to the number of points in the resulting polyline.
CalcBezierCoef | Calculates the bezier coefficients in the equation of the specified bezier curve.
CartesianToPolar | Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.
Ccw | Determines, given three points, if when travelling from the first to the second to the third, we travel in a counterclockwise direction.
Closer | Returns the point from the specified pair, which lies closer to the specified pivot.
Degrees | Converts the values expressed in radians to degrees.
DeviceToDoc | Overloaded.
Distance | Overloaded.
DistancePoint | Calculates the point of the the specified line segment which determines the distance from the specified point to the line segment
DistanceSq | Overloaded.
DistToBezier | Calculates the shortest distance from the specified point to the specified bezier curve.
DistToLineSegment | Calculates distance from the specified point to the specified line segment
DistToPolyline | Overloaded.
DistToRect | Calculates distance from the specified point to the specified rectangle.
DocToDevice | Overloaded.
GetBezierPt | Gets the point from the specified bezier curve, corresponding to the specified parameter t [0, 1].
GetEllipseIntr | Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.
GetNearestPt | Calculates the orthogonal projection of the specified point on the line defined be the specified point pair.
GetRectIntr | Calculates the intersection point between the specified rectangle and the line segment defined by the specified points.
Intersect | Determines whether the specified line segments intersect.
LineIntersect | Overloaded.
LineIntersectNaN | Finds the intersection point of the lines defined by the specified point pairs.
PointInEllipse | Checks whether the specified point is contained in the ellipse defined by the specified rectangle.
PointInPolygon | Determines if the specified point is within the specified polygon.
PointInPolyRect | Determines if the specified point is within the smallest rectangle that encloses the specified polygon.
PointInSegment | Checks whether the line segment defined by the specified points contain the specified point.
PolarToCartesian | Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.
Radians | Converts the values expressed in degrees to radians.
SegmentIntersect | Checks whether the segments defined by the specified point pairs intersect and returns the intersection point.

See Also

Utilities Class
MindFusion Namespace


MindFusion.Utilities.AddPoints Method

Utilities.AddPoints Method
[image]

Adds two points. Point.Offset() may be used instead.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point AddPoints (
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function AddPoints( _
p1 As Point, _
p2 As Point _
) As Point

Parameters

p1

p2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.ApproxBezier Method

Utilities.ApproxBezier Method
[image]

Approximates the specified bezier curve with a polyline. The specified quality parameter varies in the interval [1, …) and is proportional to the number of points in the resulting polyline.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point[] ApproxBezier (
Point[] points,
int startIdx,
int quality
)

Visual Basic [image] Copy Code

Public Shared Function ApproxBezier( _
points() As Point, _
startIdx As Integer, _
quality As Integer _
) As Point()

Parameters

points

startIdx

quality

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.CalcBezierCoef Method

Utilities.CalcBezierCoef Method
[image]

Calculates the bezier coefficients in the equation of the specified bezier curve.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static void CalcBezierCoef (
ref double a0,
ref double a1,
ref double a2,
ref double a3,
ref double b0,
ref double b1,
ref double b2,
ref double b3,
ref double u,
ref double s,
ref double z,
ref double x4,
ref double y4
)

Visual Basic [image] Copy Code

Public Shared Sub CalcBezierCoef( _
ByRef a0 As Double, _
ByRef a1 As Double, _
ByRef a2 As Double, _
ByRef a3 As Double, _
ByRef b0 As Double, _
ByRef b1 As Double, _
ByRef b2 As Double, _
ByRef b3 As Double, _
ByRef u As Double, _
ByRef s As Double, _
ByRef z As Double, _
ByRef x4 As Double, _
ByRef y4 As Double _
)

Parameters

a0

a1

a2

a3

b0

b1

b2

b3

u

s

z

x4

y4

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.CartesianToPolar Method

Utilities.CartesianToPolar Method
[image]

Converts Cartesian coordinates to the corresponding polar coordinates, using the specified point as a center of the coordinate system.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static void CartesianToPolar (
Point coordCenter,
Point point,
ref double a,
ref double r
)

Visual Basic [image] Copy Code

Public Shared Sub CartesianToPolar( _
coordCenter As Point, _
point As Point, _
ByRef a As Double, _
ByRef r As Double _
)

Parameters

coordCenter

point

a

r

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Ccw Method

Utilities.Ccw Method
[image]

Determines, given three points, if when travelling from the first to the second to the third, we travel in a counterclockwise direction.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static int Ccw (
Point p0,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function Ccw( _
p0 As Point, _
p1 As Point, _
p2 As Point _
) As Integer

Parameters

p0

p1

p2

Return Value

Remarks

1 if the movement is in a counterclockwise direction, -1 if not.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Closer Method

Utilities.Closer Method
[image]

Returns the point from the specified pair, which lies closer to the specified pivot.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point Closer (
Point pivot,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function Closer( _
pivot As Point, _
p1 As Point, _
p2 As Point _
) As Point

Parameters

pivot

p1

p2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Degrees Method

Utilities.Degrees Method
[image]

Converts the values expressed in radians to degrees.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double Degrees (
double radians
)

Visual Basic [image] Copy Code

Public Shared Function Degrees( _
radians As Double _
) As Double

Parameters

radians

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DeviceToDoc Method

Utilities.DeviceToDoc Method
[image]

Overload List

Name | Description
Utilities.DeviceToDoc (IGraphics, Point) | Converts the specified point from device to document coordinates.
Utilities.DeviceToDoc (IGraphics, Rect) | Converts the specified rectangle from device to document coordinates.
Utilities.DeviceToDoc (IMatrix, Rect) | Converts the specified rectangle from device to document coordinates.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DeviceToDoc Method (IGraphics, Point)

Utilities.DeviceToDoc Method (IGraphics, Point)
See Also
[image]

Converts the specified point from device to document coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point DeviceToDoc (
IGraphics graphics,
Point point
)

Visual Basic [image] Copy Code

Public Shared Function DeviceToDoc( _
graphics As IGraphics, _
point As Point _
) As Point

Parameters

graphics

point

Return Value

See Also

DeviceToDoc Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DeviceToDoc Method (IGraphics, Rect)

Utilities.DeviceToDoc Method (IGraphics, Rect)
See Also
[image]

Converts the specified rectangle from device to document coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Rect DeviceToDoc (
IGraphics graphics,
Rect rect
)

Visual Basic [image] Copy Code

Public Shared Function DeviceToDoc( _
graphics As IGraphics, _
rect As Rect _
) As Rect

Parameters

graphics

rect

Return Value

See Also

DeviceToDoc Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DeviceToDoc Method (IMatrix, Rect)

Utilities.DeviceToDoc Method (IMatrix, Rect)
See Also
[image]

Converts the specified rectangle from device to document coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Rect DeviceToDoc (
IMatrix matrix,
Rect rect
)

Visual Basic [image] Copy Code

Public Shared Function DeviceToDoc( _
matrix As IMatrix, _
rect As Rect _
) As Rect

Parameters

matrix

rect

Return Value

See Also

DeviceToDoc Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Distance Method

Utilities.Distance Method
[image]

Overload List

Name | Description
Utilities.Distance (Double, Double) | Calculates the length of the hypotenuse of a right rectangle whose catheti have the specified length.
Utilities.Distance (Point, Point) | Calculates the distance between the specified points.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Distance Method (Double, Double)

Utilities.Distance Method (Double, Double)
See Also
[image]

Calculates the length of the hypotenuse of a right rectangle whose catheti have the specified length.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double Distance (
double x,
double y
)

Visual Basic [image] Copy Code

Public Shared Function Distance( _
x As Double, _
y As Double _
) As Double

Parameters

x

y

Return Value

See Also

Distance Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Distance Method (Point, Point)

Utilities.Distance Method (Point, Point)
See Also
[image]

Calculates the distance between the specified points.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double Distance (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Shared Function Distance( _
pt1 As Point, _
pt2 As Point _
) As Double

Parameters

pt1

pt2

Return Value

See Also

Distance Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistancePoint Method

Utilities.DistancePoint Method
[image]

Calculates the point of the the specified line segment which determines the distance from the specified point to the line segment

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point DistancePoint (
Point pt,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function DistancePoint( _
pt As Point, _
p1 As Point, _
p2 As Point _
) As Point

Parameters

pt

p1

p2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistanceSq Method

Utilities.DistanceSq Method
[image]

Overload List

Name | Description
Utilities.DistanceSq (Point, Double, Double) | Calculates the square of the distance between the specified points.
Utilities.DistanceSq (Point, Point) | Calculates the square of the distance between the specified points.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistanceSq Method (Point, Double, Double)

Utilities.DistanceSq Method (Point, Double, Double)
See Also
[image]

Calculates the square of the distance between the specified points.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double DistanceSq (
Point point,
double x,
double y
)

Visual Basic [image] Copy Code

Public Shared Function DistanceSq( _
point As Point, _
x As Double, _
y As Double _
) As Double

Parameters

point

x

y

Return Value

See Also

DistanceSq Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistanceSq Method (Point, Point)

Utilities.DistanceSq Method (Point, Point)
See Also
[image]

Calculates the square of the distance between the specified points.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double DistanceSq (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Shared Function DistanceSq( _
pt1 As Point, _
pt2 As Point _
) As Double

Parameters

pt1

pt2

Return Value

See Also

DistanceSq Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToBezier Method

Utilities.DistToBezier Method
[image]

Calculates the shortest distance from the specified point to the specified bezier curve.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double DistToBezier (
Point pt,
IList bez_pts,
int nPoints
)

Visual Basic [image] Copy Code

Public Shared Function DistToBezier( _
pt As Point, _
bez_pts As IList, _
nPoints As Integer _
) As Double

Parameters

pt

bez_pts

nPoints

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToLineSegment Method

Utilities.DistToLineSegment Method
[image]

Calculates distance from the specified point to the specified line segment

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double DistToLineSegment (
Point pt,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public Shared Function DistToLineSegment( _
pt As Point, _
p1 As Point, _
p2 As Point _
) As Double

Parameters

pt

p1

p2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToPolyline Method

Utilities.DistToPolyline Method
[image]

Overload List

Name | Description
Utilities.DistToPolyline (Point, IList, Int32) | Calculates the shortest distance from the specified point to the specified polyline.
Utilities.DistToPolyline (Point, IList, Int32, Int32@) | Calculates the shortest distance from the specified point to the specified polyline, also returning the index of the segment the point is closest to.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToPolyline Method (Point, IList, Int32)

Utilities.DistToPolyline Method (Point, IList, Int32)
See Also
[image]

Calculates the shortest distance from the specified point to the specified polyline.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double DistToPolyline (
Point pt,
IList line_pts,
int nPoints
)

Visual Basic [image] Copy Code

Public Shared Function DistToPolyline( _
pt As Point, _
line_pts As IList, _
nPoints As Integer _
) As Double

Parameters

pt

line_pts

nPoints

Return Value

See Also

DistToPolyline Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToPolyline Method (Point, IList, Int32, Int32@)

Utilities.DistToPolyline Method (Point, IList, Int32, Int32@)
See Also
[image]

Calculates the shortest distance from the specified point to the specified polyline, also returning the index of the segment the point is closest to.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double DistToPolyline (
Point pt,
IList line_pts,
int nPoints,
ref int segmNum
)

Visual Basic [image] Copy Code

Public Shared Function DistToPolyline( _
pt As Point, _
line_pts As IList, _
nPoints As Integer, _
ByRef segmNum As Integer _
) As Double

Parameters

pt

line_pts

nPoints

segmNum

Return Value

See Also

DistToPolyline Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DistToRect Method

Utilities.DistToRect Method
[image]

Calculates distance from the specified point to the specified rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double DistToRect (
Point pt,
Rect r
)

Visual Basic [image] Copy Code

Public Shared Function DistToRect( _
pt As Point, _
r As Rect _
) As Double

Parameters

pt

r

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DocToDevice Method

Utilities.DocToDevice Method
[image]

Overload List

Name | Description
Utilities.DocToDevice (IGraphics, Point) | Converts the specified point from document to device coordinates.
Utilities.DocToDevice (IGraphics, Rect) | Converts the specified rectangle from document to device coordinates.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DocToDevice Method (IGraphics, Point)

Utilities.DocToDevice Method (IGraphics, Point)
See Also
[image]

Converts the specified point from document to device coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point DocToDevice (
IGraphics graphics,
Point point
)

Visual Basic [image] Copy Code

Public Shared Function DocToDevice( _
graphics As IGraphics, _
point As Point _
) As Point

Parameters

graphics

point

Return Value

See Also

DocToDevice Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.DocToDevice Method (IGraphics, Rect)

Utilities.DocToDevice Method (IGraphics, Rect)
See Also
[image]

Converts the specified rectangle from document to device coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Rect DocToDevice (
IGraphics graphics,
Rect rect
)

Visual Basic [image] Copy Code

Public Shared Function DocToDevice( _
graphics As IGraphics, _
rect As Rect _
) As Rect

Parameters

graphics

rect

Return Value

See Also

DocToDevice Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.GetBezierPt Method

Utilities.GetBezierPt Method
[image]

Gets the point from the specified bezier curve, corresponding to the specified parameter t [0, 1].

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point GetBezierPt (
IList<Point> points,
int segment,
double t
)

Visual Basic [image] Copy Code

Public Shared Function GetBezierPt( _
points As IList(Of Point), _
segment As Integer, _
t As Double _
) As Point

Parameters

points

segment

t

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.GetEllipseIntr Method

Utilities.GetEllipseIntr Method
[image]

Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static void GetEllipseIntr (
Rect rcBox,
Point pt1,
Point pt2,
ref Point pt
)

Visual Basic [image] Copy Code

Public Shared Sub GetEllipseIntr( _
rcBox As Rect, _
pt1 As Point, _
pt2 As Point, _
ByRef pt As Point _
)

Parameters

rcBox

pt1

pt2

pt

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.GetNearestPt Method

Utilities.GetNearestPt Method
[image]

Calculates the orthogonal projection of the specified point on the line defined be the specified point pair.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point GetNearestPt (
Point pt,
Point segPt1,
Point segPt2
)

Visual Basic [image] Copy Code

Public Shared Function GetNearestPt( _
pt As Point, _
segPt1 As Point, _
segPt2 As Point _
) As Point

Parameters

pt

segPt1

segPt2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.GetRectIntr Method

Utilities.GetRectIntr Method
[image]

Calculates the intersection point between the specified rectangle and the line segment defined by the specified points.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static void GetRectIntr (
Rect rcBox,
Point pt1,
Point pt2,
ref Point pt
)

Visual Basic [image] Copy Code

Public Shared Sub GetRectIntr( _
rcBox As Rect, _
pt1 As Point, _
pt2 As Point, _
ByRef pt As Point _
)

Parameters

rcBox

pt1

pt2

pt

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Intersect Method

Utilities.Intersect Method
[image]

Determines whether the specified line segments intersect.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool Intersect (
Point p1,
Point p2,
Point p3,
Point p4
)

Visual Basic [image] Copy Code

Public Shared Function Intersect( _
p1 As Point, _
p2 As Point, _
p3 As Point, _
p4 As Point _
) As Boolean

Parameters

p1

p2

p3

p4

Return Value

true if the segments intersect, false if not.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.LineIntersect Method

Utilities.LineIntersect Method
[image]

Overload List

Name | Description
Utilities.LineIntersect (Point, Point, Point, Point) | Finds the intersection point of the lines defined by the specified point pairs.
Utilities.LineIntersect (Point, Point, Point, Point, Point@) | Finds the intersection point of the lines defined by the specified point pairs.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.LineIntersect Method (Point, Point, Point, Point)

Utilities.LineIntersect Method (Point, Point, Point, Point)
See Also
[image]

Finds the intersection point of the lines defined by the specified point pairs.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point LineIntersect (
Point m1,
Point m2,
Point n1,
Point n2
)

Visual Basic [image] Copy Code

Public Shared Function LineIntersect( _
m1 As Point, _
m2 As Point, _
n1 As Point, _
n2 As Point _
) As Point

Parameters

m1

m2

n1

n2

Return Value

The intersection point of the specified lines or Point(float.MinValue, float.MinValue) if the lines do not intersect.

See Also

LineIntersect Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.LineIntersect Method (Point, Point, Point, Point, Point@)

Utilities.LineIntersect Method (Point, Point, Point, Point, Point@)
See Also
[image]

Finds the intersection point of the lines defined by the specified point pairs.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool LineIntersect (
Point m1,
Point m2,
Point n1,
Point n2,
out Point result
)

Visual Basic [image] Copy Code

Public Shared Function LineIntersect( _
m1 As Point, _
m2 As Point, _
n1 As Point, _
n2 As Point, _
<System.Runtime.InteropServices.Out()> ByRef result As Point _
) As Boolean

Parameters

m1

m2

n1

n2

result

Return Value

See Also

LineIntersect Method Overload List
Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.LineIntersectNaN Method

Utilities.LineIntersectNaN Method
[image]

Finds the intersection point of the lines defined by the specified point pairs.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point LineIntersectNaN (
Point m1,
Point m2,
Point n1,
Point n2
)

Visual Basic [image] Copy Code

Public Shared Function LineIntersectNaN( _
m1 As Point, _
m2 As Point, _
n1 As Point, _
n2 As Point _
) As Point

Parameters

m1

m2

n1

n2

Return Value

The intersection point of the specified lines or Point(double.NaN, double.NaN) if the lines do not intersect.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PointInEllipse Method

Utilities.PointInEllipse Method
[image]

Checks whether the specified point is contained in the ellipse defined by the specified rectangle.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool PointInEllipse (
Point pt,
Rect rc
)

Visual Basic [image] Copy Code

Public Shared Function PointInEllipse( _
pt As Point, _
rc As Rect _
) As Boolean

Parameters

pt

rc

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PointInPolygon Method

Utilities.PointInPolygon Method
[image]

Determines if the specified point is within the specified polygon.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool PointInPolygon (
IList<Point> poly,
Point ptTest
)

Visual Basic [image] Copy Code

Public Shared Function PointInPolygon( _
poly As IList(Of Point), _
ptTest As Point _
) As Boolean

Parameters

poly

ptTest

Return Value

true if the point is inside the polygon, false if not.

Remarks

It uses the classical polygon hit-testing algorithm: a horizontal ray starting at the point is extended infinitely rightwards and the number of polygon edges that intersect the ray are counted. If the number is odd, the point is inside the polygon.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PointInPolyRect Method

Utilities.PointInPolyRect Method
[image]

Determines if the specified point is within the smallest rectangle that encloses the specified polygon.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool PointInPolyRect (
IList<Point> poly,
Point ptTest,
ref Rect rBound
)

Visual Basic [image] Copy Code

Public Shared Function PointInPolyRect( _
poly As IList(Of Point), _
ptTest As Point, _
ByRef rBound As Rect _
) As Boolean

Parameters

poly

ptTest

rBound

Return Value

true or false depending on whether the point is in the rect or not.

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PointInSegment Method

Utilities.PointInSegment Method
[image]

Checks whether the line segment defined by the specified points contain the specified point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool PointInSegment (
Point pt,
Point sgm1,
Point sgm2
)

Visual Basic [image] Copy Code

Public Shared Function PointInSegment( _
pt As Point, _
sgm1 As Point, _
sgm2 As Point _
) As Boolean

Parameters

pt

sgm1

sgm2

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.PolarToCartesian Method

Utilities.PolarToCartesian Method
[image]

Converts polar coordinates to the corresponding Cartesian coordinates, using the specified point as a center of the coordinate system.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static void PolarToCartesian (
Point coordCenter,
double a,
double r,
ref Point point
)

Visual Basic [image] Copy Code

Public Shared Sub PolarToCartesian( _
coordCenter As Point, _
a As Double, _
r As Double, _
ByRef point As Point _
)

Parameters

coordCenter

a

r

point

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.Radians Method

Utilities.Radians Method
[image]

Converts the values expressed in degrees to radians.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double Radians (
double degrees
)

Visual Basic [image] Copy Code

Public Shared Function Radians( _
degrees As Double _
) As Double

Parameters

degrees

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Utilities.SegmentIntersect Method

Utilities.SegmentIntersect Method
[image]

Checks whether the segments defined by the specified point pairs intersect and returns the intersection point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool SegmentIntersect (
Point s1,
Point s2,
Point l1,
Point l2,
ref Point pt
)

Visual Basic [image] Copy Code

Public Shared Function SegmentIntersect( _
s1 As Point, _
s2 As Point, _
l1 As Point, _
l2 As Point, _
ByRef pt As Point _
) As Boolean

Parameters

s1

s2

l1

l2

pt

Return Value

See Also

Utilities Members
Utilities Class
MindFusion Namespace


MindFusion.Vector Structure

Vector Structure
[image]

Represents a two-dimensional vector.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public struct Vector

Visual Basic [image] Copy Code

Public Structure Vector

See Also

Vector Members
MindFusion Namespace


MindFusion.Vector Members

Vector Members
Constructors Properties Methods
[image]

Represents a two-dimensional vector.

The following tables list the members exposed by the Vector type.

Public Constructors

Name | Description
Vector | Overloaded.

Public Properties

Name | Description
Length | Returns the vector length.
LengthSquared | Returns the squared length.
X | X coordinate of the vector.
Y | Y coordinate of the vector.

Public Methods

Name | Description
Add | Overloaded.
AngleBetween | Returns the angle between two vectors.
Divide | Divides a vector by a scalar value.
Equals | Overloaded.
GetHashCode | Object.GetHashCode override.
Left | Returns the left vector.
Multiply | Overloaded.
Negate | Reverses this vector's direction.
Normalize | Normalizes this vector.
Right | Returns the right vector.
Subtract | Subtracts two vectors.
ToString | Overloaded.

See Also

Vector Structure
MindFusion Namespace


MindFusion.Vector Constructor

Vector Constructor
[image]

Overload List

Name | Description
Vector (Double, Double) | Initializes a new instance of the Vector structure with specified coordinates.
Vector (Point, Point) | Initializes a new instance of the Vector structure from the specified points.

See Also

Vector Structure
MindFusion Namespace


MindFusion.Vector Constructor (Double, Double)

Vector Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the Vector structure with specified coordinates.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Vector (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

X coordinate of the vector.

y

Y coordinate of the vector.

See Also

Vector Constructor Overload List
Vector Structure
MindFusion Namespace


MindFusion.Vector Constructor (Point, Point)

Vector Constructor (Point, Point)
See Also
[image]

Initializes a new instance of the Vector structure from the specified points.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Vector (
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Public New ( _
p1 As Point, _
p2 As Point _
)

Parameters

p1

Origin point of the vector.

p2

End point of the vector.

See Also

Vector Constructor Overload List
Vector Structure
MindFusion Namespace


MindFusion.Vector Methods

Vector Methods
[image]

Public Methods

Name | Description
Add | Overloaded.
AngleBetween | Returns the angle between two vectors.
Divide | Divides a vector by a scalar value.
Equals | Overloaded.
GetHashCode | Object.GetHashCode override.
Left | Returns the left vector.
Multiply | Overloaded.
Negate | Reverses this vector's direction.
Normalize | Normalizes this vector.
Right | Returns the right vector.
Subtract | Subtracts two vectors.
ToString | Overloaded.

See Also

Vector Structure
MindFusion Namespace


MindFusion.Vector.Add Method

Vector.Add Method
[image]

Overload List

Name | Description
Vector.Add (Vector, Point) | Adds vector to a point.
Vector.Add (Vector, Vector) | Adds two vectors.

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Add Method (Vector, Point)

Vector.Add Method (Vector, Point)
See Also
[image]

Adds vector to a point.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Point Add (
Vector vector,
Point point
)

Visual Basic [image] Copy Code

Public Shared Function Add( _
vector As Vector, _
point As Point _
) As Point

Parameters

vector

A Vector instance.

point

A Point instance.

Return Value

A point offset from the specified point by adding specified vector.

See Also

Add Method Overload List
Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Add Method (Vector, Vector)

Vector.Add Method (Vector, Vector)
See Also
[image]

Adds two vectors.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Vector Add (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Add( _
vector1 As Vector, _
vector2 As Vector _
) As Vector

Parameters

vector1

vector2

Return Value

See Also

Add Method Overload List
Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.AngleBetween Method

Vector.AngleBetween Method
[image]

Returns the angle between two vectors.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double AngleBetween (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function AngleBetween( _
vector1 As Vector, _
vector2 As Vector _
) As Double

Parameters

vector1

A Vector instance.

vector2

A Vector instance.

Return Value

The angle between specified vectors.

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Divide Method

Vector.Divide Method
[image]

Divides a vector by a scalar value.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Vector Divide (
Vector vector,
double scalar
)

Visual Basic [image] Copy Code

Public Shared Function Divide( _
vector As Vector, _
scalar As Double _
) As Vector

Parameters

vector

A Vector instance.

scalar

A double value.

Return Value

A Vector with same direction and divided length.

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Equals Method

Vector.Equals Method
[image]

Overload List

Name | Description
Vector.Equals (Object) | Object.Equals override.
Vector.Equals (Vector) | Compare this vector with the specified vector for equality.
Vector.Equals (Vector, Vector) | Compares two vectors for equality.

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Equals Method (Object)

Vector.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare this vector with.

Return Value

true if the objects are equal, or otherwise false.

See Also

Equals Method Overload List
Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Equals Method (Vector)

Vector.Equals Method (Vector)
See Also
[image]

Compare this vector with the specified vector for equality.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public new bool Equals (
Vector value
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
value As Vector _
) As Boolean

Parameters

value

The vector to compare with.

Return Value

true if the vectors are equal, or otherwise false.

See Also

Equals Method Overload List
Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Equals Method (Vector, Vector)

Vector.Equals Method (Vector, Vector)
See Also
[image]

Compares two vectors for equality.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public new static bool Equals (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shadows Shared Function Equals( _
vector1 As Vector, _
vector2 As Vector _
) As Boolean

Parameters

vector1

The first vector to compare.

vector2

The second vector to compare.

Return Value

true if the vectors are equal, or otherwise false.

See Also

Equals Method Overload List
Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.GetHashCode Method

Vector.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

The vector's hash code.

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Left Method

Vector.Left Method
[image]

Returns the left vector.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Vector Left (
Vector v
)

Visual Basic [image] Copy Code

Public Shared Function Left( _
v As Vector _
) As Vector

Parameters

v

Return Value

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Multiply Method

Vector.Multiply Method
[image]

Overload List

Name | Description
Vector.Multiply (Double, Vector) | Multiplies a vector by a scalar value.
Vector.Multiply (Vector, Double) | Multiplies a vector by a scalar value.
Vector.Multiply (Vector, Vector) | Multiplies two vectors.

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Multiply Method (Double, Vector)

Vector.Multiply Method (Double, Vector)
See Also
[image]

Multiplies a vector by a scalar value.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Vector Multiply (
double scalar,
Vector vector
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
scalar As Double, _
vector As Vector _
) As Vector

Parameters

scalar

A double value.

vector

A Vector instance.

Return Value

A Vector with same direction and multiplied length.

See Also

Multiply Method Overload List
Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Multiply Method (Vector, Double)

Vector.Multiply Method (Vector, Double)
See Also
[image]

Multiplies a vector by a scalar value.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Vector Multiply (
Vector vector,
double scalar
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
vector As Vector, _
scalar As Double _
) As Vector

Parameters

vector

A Vector instance.

scalar

A double value.

Return Value

A Vector with same direction and multiplied length.

See Also

Multiply Method Overload List
Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Multiply Method (Vector, Vector)

Vector.Multiply Method (Vector, Vector)
See Also
[image]

Multiplies two vectors.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double Multiply (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Multiply( _
vector1 As Vector, _
vector2 As Vector _
) As Double

Parameters

vector1

A Vector instance.

vector2

A Vector instance.

Return Value

The dot product of specified vectors.

See Also

Multiply Method Overload List
Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Negate Method

Vector.Negate Method
[image]

Reverses this vector's direction.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Negate ()

Visual Basic [image] Copy Code

Public Sub Negate ()

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Normalize Method

Vector.Normalize Method
[image]

Normalizes this vector.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Normalize ()

Visual Basic [image] Copy Code

Public Sub Normalize ()

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Right Method

Vector.Right Method
[image]

Returns the right vector.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Vector Right (
Vector v
)

Visual Basic [image] Copy Code

Public Shared Function Right( _
v As Vector _
) As Vector

Parameters

v

Return Value

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Subtract Method

Vector.Subtract Method
[image]

Subtracts two vectors.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Vector Subtract (
Vector vector1,
Vector vector2
)

Visual Basic [image] Copy Code

Public Shared Function Subtract( _
vector1 As Vector, _
vector2 As Vector _
) As Vector

Parameters

vector1

A Vector instance.

vector2

A Vector instance.

Return Value

The difference between specified vectors.

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.ToString Method

Vector.ToString Method
[image]

Overload List

Name | Description
Vector.ToString () | Object.ToString override.
Vector.ToString (IFormatProvider) | Returns the vector's string representation in specified culture.

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.ToString Method ()

Vector.ToString Method ()
See Also
[image]

Object.ToString override.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The vector's string representation.

See Also

ToString Method Overload List
Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.ToString Method (IFormatProvider)

Vector.ToString Method (IFormatProvider)
See Also
[image]

Returns the vector's string representation in specified culture.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public string ToString (
IFormatProvider provider
)

Visual Basic [image] Copy Code

Public Function ToString( _
provider As IFormatProvider _
) As String

Parameters

provider

An IFormatProvider (e.g. CultureInfo) specifying number format.

Return Value

The vector's string representation.

See Also

ToString Method Overload List
Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector Properties

Vector Properties
[image]

Public Properties

Name | Description
Length | Returns the vector length.
LengthSquared | Returns the squared length.
X | X coordinate of the vector.
Y | Y coordinate of the vector.

See Also

Vector Structure
MindFusion Namespace


MindFusion.Vector.Length Property

Vector.Length Property
[image]

Returns the vector length.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public double Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Double

Property Value

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.LengthSquared Property

Vector.LengthSquared Property
[image]

Returns the squared length.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public double LengthSquared { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LengthSquared As Double

Property Value

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.X Property

Vector.X Property
[image]

X coordinate of the vector.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.Vector.Y Property

Vector.Y Property
[image]

Y coordinate of the vector.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

See Also

Vector Members
Vector Structure
MindFusion Namespace


MindFusion.ViewWithCursor Interface

ViewWithCursor Interface
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public interface ViewWithCursor

Visual Basic [image] Copy Code

Public Interface ViewWithCursor

See Also

ViewWithCursor Members
MindFusion Namespace


MindFusion.ViewWithCursor Members

ViewWithCursor Members
Methods
[image]

The following tables list the members exposed by the ViewWithCursor type.

Public Methods

Name | Description
SetMouseCursor |

See Also

ViewWithCursor Interface
MindFusion Namespace


MindFusion.ViewWithCursor Methods

ViewWithCursor Methods
[image]

Public Methods

Name | Description
SetMouseCursor |

See Also

ViewWithCursor Interface
MindFusion Namespace


MindFusion.ViewWithCursor.SetMouseCursor Method

ViewWithCursor.SetMouseCursor Method
[image]

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetMouseCursor (
CursorHint cursor
)

Visual Basic [image] Copy Code

Sub SetMouseCursor( _
cursor As CursorHint _
)

Parameters

cursor

See Also

ViewWithCursor Members
ViewWithCursor Interface
MindFusion Namespace


MindFusion.XmlElementNameAttribute Class

XmlElementNameAttribute Class
[image]

Specifies a string to be used as a XmlElement name of a type during XML serialization.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class XmlElementNameAttribute : Attribute

Visual Basic [image] Copy Code

Public NotInheritable Class XmlElementNameAttribute
Inherits Attribute

Inheritance Hierarchy

System.Object
System.Attribute
MindFusion.XmlElementNameAttribute

See Also

XmlElementNameAttribute Members
MindFusion Namespace


MindFusion.XmlElementNameAttribute Members

XmlElementNameAttribute Members
Constructors Properties
[image]

Specifies a string to be used as a XmlElement name of a type during XML serialization.

The following tables list the members exposed by the XmlElementNameAttribute type.

Public Constructors

Name | Description
XmlElementNameAttribute | Initializes a new instance of the XmlElementNameAttribute class.

Public Properties

Name | Description
Name | Gets the associated XML name.

See Also

XmlElementNameAttribute Class
MindFusion Namespace


MindFusion.XmlElementNameAttribute Constructor

XmlElementNameAttribute Constructor
[image]

Initializes a new instance of the XmlElementNameAttribute class.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public XmlElementNameAttribute (
string name
)

Visual Basic [image] Copy Code

Public New ( _
name As String _
)

Parameters

name

See Also

XmlElementNameAttribute Class
MindFusion Namespace


MindFusion.XmlElementNameAttribute Properties

XmlElementNameAttribute Properties
[image]

Public Properties

Name | Description
Name | Gets the associated XML name.

See Also

XmlElementNameAttribute Class
MindFusion Namespace


MindFusion.XmlElementNameAttribute.Name Property

XmlElementNameAttribute.Name Property
[image]

Gets the associated XML name.

Namespace: MindFusion
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

See Also

XmlElementNameAttribute Members
XmlElementNameAttribute Class
MindFusion Namespace


MindFusion.Diagramming Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AdjustmentHandle | Represents an adjustment handle used to move or modify diagram items.
AeroEffect | Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.
AnchorPattern | Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.
AnchorPoint | Represents a location in a node, to which links are allowed to connect.
AnchorPointCollection | Represents a strongly-typed collection of anchor points.
AnchorPointEventArgs | Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.
ArcTemplate | Represents an arc in a shape definition.
ArrowHeads | Contains predefined arrowhead shapes.
BezierTemplate | Represents a Bezier curve in a shape definition.
CellEventArgs | Contains the arguments passed to event handlers, such as CellClicked.
CellValidationEventArgs | Contains the arguments passed to event handlers, such as CellTextEditing.
ClipboardEventArgs | Contains the arguments passed to the RequestClipboard event handlers.
CollectionBase(T) | An implementation of the IList<T> interface.
CompatibilityExtensions |
ConnectionPoint | This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.
Constants | Contains various global constants, also provides measure unit independent constants.
ContainerChildEventArgs | Contains arguments passed to events related to container children.
ContainerNode | Implements nodes that can contain other nodes.
ContainerNodeProperties | Stores the values of ContainerNode properties during undo / redo operations.
ContainerNodeStyle | Represents a reusable set of properties that define the appearance of container nodes.
Converter | Provides capabilities to convert various types to and from strings in a cutlure-independent way.
Diagram | Represents a flow diagram.
DiagramBase | The base class of the Diagram class.
DiagramEventArgs | Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.
DiagramItem | Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.
DiagramItemCollection | Represents a strongly-typed collection of DiagramItem objects.
DiagramItemProperties | The base type for classes that store diagram item properties during undo / redo operations.
DiagramItemState | Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.
DiagramItemStyle | Represents a reusable set of properties that define the appearance of diagram items.
DiagramLink | Represents a link between two diagram nodes.
DiagramLinkCollection | Represents a strongly-typed collection of DiagramLink objects.
DiagramLinkProperties | Stores the values of DiagramLink properties during undo / redo operations.
DiagramLinkState | Contains a snapshot of the internal state of a DiagramLink.
DiagramLinkStyle | Represents a reusable set of properties that define the appearance of diagram links.
DiagramNode | Represents a diagram node.
DiagramNodeCollection | Represents a strongly-typed collection of diagram nodes.
DiagramNodeEventArgs | Contains the arguments passed to the NodeSelected and NodeRemoved event handlers.
DiagramNodeProperties | The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.
DiagramNodeState | Contains a snapshot of the internal state of a DiagramNode.
DiagramNodeStyle | Represents a reusable set of properties that define the appearance of diagram nodes.
DiagramPlatformProvider |
DiagramPresenter |
DiagramStyle | Represents a reusable set of properties that define the appearance of diagrams.
DiagramView | Displays the content of a Diagram object and provides the ability to autoscroll and display scrollbars.
DragEventArgs | Holds event data for the NodeListView drag events.
DraggedNode | Class used to hold the DiagramNode instance during drag and drop from NodeListView. It is used for easier detection of the dragged content as DragEventArgs.Data.GetData() does not check super classes.
DrawAnchorPointEventArgs | Contains the arguments passed to the DrawAnchorPoint event handlers.
DrawCellEventArgs | Contains the arguments passed to the DrawCell event handlers.
DrawItemEventArgs | Contains the arguments passed to the DrawAdjustmentHandles event handlers.
DrawLinkEventArgs | Contains the arguments passed to the DrawLink event handlers.
DrawNodeEventArgs | Contains the arguments passed to the DrawNode event handlers.
DummyNode | Represents virtual nodes used for disconnected links.
EditCellTextEventArgs | Contains the arguments passed to the CellTextEdited event handlers.
EditLinkTextEventArgs | Contains the arguments passed to the LinkTextEdited event handlers.
EditNodeTextEventArgs | Contains the arguments passed to the NodeTextEdited event handlers.
ElementTemplate | Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.
Factory | Provides shortcut methods for creating and adding instances of the standard MindFusion.Diagramming for .NET MAUI item types. Call the class methods through the Factory property of the Diagram class.
FreeFormHandle | Represents an adjustment handle used to modify the outline of a FreeFormNode.
FreeFormNode | A FreeFormNode collects all points from users' mouse or touch input and displays them as node's outline.
FreeFormNodeStyle | Represents a reusable set of properties that define the appearance of free-form nodes.
GlassEffect | Represents a glass-like visual effect.
GridRouter | Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.
HandlesVisualStyle | Defines the Pen and Brush objects used to draw items' adjustment handles.
HitTestEventArgs | Contains the arguments passed to the HitTestAdjustmentHandles event handlers.
InPlaceEditEventArgs | Contains the arguments passed to the EnterInplaceEditMode and LeaveInplaceEditMode event handlers.
InstantiateItemEventArgs | Contains the arguments passed to the InstantiateItem event handlers.
InternalUtils | Contains common helper methods.
ItemCollectionBase(T) | A base collection class for the diagram item collections.
ItemEventArgs | Contains the arguments passed to item instantiation event handlers.
ItemLabel | The base class for node and link labels.
JsonOptions | Defines properties used to customize the JSON serialization process.
JsonPersistContext | Contains methods that can help you serialize and deserialize MindFusion.Diagramming items to and from JSON.
JsonSerializeTagEventArgs | Contains the arguments passed to the JsonSerializeTag and JsonDeserializeTag event handlers.
Layer | Represents a layer in a Diagram object.
LayerEventArgs | Contains the arguments passed to the LayerVisibilityChanged event handler.
LineTemplate | Represents a line segment in a shape definition.
LinkAdjustmentHandle | Represents an adjustment handle used to modify the position of a link's control point.
LinkEventArgs | Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.
LinkLabel | Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.
LinkLabelEventArgs | Contains the arguments passed to handlers of link label related events, such as LabelClicked.
LinkShapeEventArgs | Contains the arguments passed to the SetSelfLoopShape event handler.
LinkValidationEventArgs | Contains the arguments passed to handlers of link validation events.
MeasureUnit | Represents a unit of measure.
MenuItemEventArgs | Provides the arguments passed to the Clicked event handlers.
NodeAdjustmentHandle | Represents an adjustment handle used to move, resize or rotate a node.
NodeConstraints | Defines specific constraints that can be applied to the size and location of nodes.
NodeEffect | Represents the base class of all visual effects that can be applied to the nodes in a Diagram.
NodeEventArgs | Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.
NodeLabel | Represents a label displayed by a DiagramNode. New labels can be added to a node by calling the DiagramNode.AddLabel method.
NodeListView | Represents a list view containing DiagramNode objects.
NodeValidationEventArgs | Contains the arguments passed to handlers of node validation events.
NotATreeException | An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.
NotifyCollectionChangedEventArgs(T) | Provides data for the ObservableCollection<T>.CollectionChanged event.
ObservableCollection(T) | Represents a dynamic data collection that provides notifications when items get added, removed, or when the whole list is refreshed.
Path | Represents a sequence of connected DiagramNode and DiagramLink elements.
PathCollection | Represents a strongly-typed collection of Path objects.
PathFinder | Provides methods that help you find paths and cycles in a graph.
PointCollection | Represents a strongly-typed collection of points.
QuickRouter | Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.
RadialMenu | Represents a context menu that can be used to in-place edit and delete diagram items.
RadialMenuEventArgs | Contains the arguments passed to the ContextMenuShowing event handlers.
ReadOnlyCollection(T) | Represents a read-only wrapper of a collection.
ReadOnlyDiagramItemCollection | Represents a read-only collection of items.
ReadOnlyDiagramLinkCollection | Represents a read-only collection of links.
ReadOnlyDiagramNodeCollection | Represents a read-only collection of nodes.
RenderOptions | Provides properties that allow customization of various aspects of printing and print-preview.
RepaintEventArgs | Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.
RoundRectangleTemplate | Represents an ElementTemplate that draws round rectangle.
RoutingOptions | Allows customization of various aspects of the link routing algorithm.
RowEventArgs | Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.
ScrollBarView | Represents a scrollbar in a DiagramView.
ScrollToggleView | Represents a small toggle control that can be used to turn pan mode on and off in a diagram.
Selection | Represents a set of items selected in the diagram document.
SelectionCopy | Used internally in the implementation of copy/paste functions.
SelectionEventArgs | Contains the arguments passed to the SelectionModified event handler.
SelectionValidationEventArgs | Contains the arguments passed to the SelectionModifying event handler.
SerializeTagEventArgs | Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.
Shape | An instance of this class represents a shape defined through a series of arc, line and Bézier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.
ShapeCollection | Represents a read-only collection of shapes.
ShapeDecoration | Defines decoration elements that are displayed as filled shapes.
ShapeLibrary | The ShapeLibrary class represents a collection of shape definitions stored together.
ShapeNode | ShapeNode instances are diagram nodes that represent geometric shapes.
ShapeNodeProperties | Stores the values of ShapeNode properties during undo / redo operations.
ShapeNodeState | Contains a snapshot of the internal state of a ShapeNode.
ShapeNodeStyle | Represents a reusable set of properties that define the appearance of shape nodes.
Shapes | Provides alternative method of access to the MindFusion.Diagramming for .NET MAUI predefined shapes, that allows code completion, which is not available when using Shape.FromId.
Style | Represents an unordered dynamic collection of properties that can be identified by name.
StylePropertyChangedEventArgs | Contains the arguments passed to handlers of the PropertyChanged event.
SyncScrollView |
TableNode | Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.
TableNode.Cell | Represents a cell in a TableNode instance.
TableNode.CellCollection | Represents a strongly-typed collection of TableNode.Cell objects.
TableNode.Column | Represents a column of a TableNode.
TableNode.ColumnCollection | Represents a strongly-typed collection of TableNode.Column objects.
TableNode.Row | Represents a row in TableNode node.
TableNode.RowCollection | Represents a strongly-typed collection of TableNode.Row objects.
TableNodeProperties | Stores the values of TableNode properties during undo / redo operations.
TableNodeStyle | Represents a reusable set of properties that define the appearance of table nodes.
TextEditor | For internal use.
Theme | Represents a set of Style objects for different diagram item types.
TimerEventArgs | Contains the arguments passed to timer-related event handlers.
TreeEnumerator | Enables an easy standard method to iterate over the elements of a tree-like structure of objects.
TreeItemEventArgs | Contains the arguments passed to handlers of TreeViewItem-related events.
TreeItemValidationEventArgs | Contains the arguments passed to event handlers, such as TreeItemTextEditing.
TreeViewConnectionPoint | Represents a connection between a link and a TreeViewNode.
TreeViewItem | Represents a constituent item of the hierarchy displayed inside a TreeViewNode.
TreeViewNode | Represents nodes that can draw hierarchical data.
TreeViewNodeStyle | Represents a reusable set of properties that define the appearance of tree view nodes.
XmlPersistContext | Contains methods that can help you serialize and deserialize MindFusion.Diagramming for .NET MAUI items to and from XML documents.

Interfaces

Interface | Description
IDiagramPlatformProvider |
IDiagramView | Controls that display Diagram objects must implement this interface to provide screen resolution information to drawing methods.
IItemFactory | Defines an interface for constructing various objects.
ILinkRouter | Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.
IMeasureUnitConverter | Provides means to convert between cross-type measure units.
IMenuItem | Represents an item in a radial menu.
InplaceEditable | Represents an inplace-editable object.
IProperty | Represents a property that can have an undefined value.
IResolution | Provides information about device resolution.
ScrollTarget |

Delegates

Delegate | Description
ContextMenuAction | Represents methods that are called when the user activates actions from the context menu.
CreatePathDelegate | Specifies the signature of callback functions used to generate dynamic node shapes.
VisitNode | Defines the prototype for methods called by VisitNodes.

Enumerations

Enumeration | Description
Action | Specifies the possible actions a user can carry out on diagram items.
AdjustmentHandles | Identifies the distinct selection handles of a node.
Anchoring | Defines values that specify how automatic layout algorithms align links to anchor points.
AttachTo | Specifies the type of attachment in a group.
AttachToLink | Specifies the possible ways to attach a node to a link.
AttachToNode | Defines values specifying the possible ways to attach a node to another node.
AutoResize | Defines in which directions automatic resizing can enlarge the diagram scrollable area.
Axis | Specifies a coordinate axis.
Behavior | Defines values that specify how the component responds to actions performed by the user.
CellFrameStyle | Specifies the style of the cells' frame lines.
ColumnStyle | Specifies how table columns' width is set.
ContainmentKeys | For internal use.
CustomDraw | Specifies what kind of custom painting to perform on diagram elements.
DirectionConstraint | Defines values that specify in what direction to constrain node movement.
ExpandButtonAction | Specifies what action is triggered by the +/- buttons that are displayed near expandable nodes.
ExpandButtonPosition | Defines values that specify possible locations for expand/collapse buttons.
FitSize | Specifies how the ResizeToFitText method should resize a node.
GlassEffectType | Specifies the type of a GlassEffect node effect.
Granularity | Specifies the granularity of the obstacles map generated by QuickRouter.
GridStyle | Defines values that specify the visual style of the alignment grid.
GroupAnchorStyles | Specifies the master node edges to which a subordinate node can be anchored.
GroupRotation | Defines values that indicate how rotation of a group's master node affects the nodes attached to that group.
HandlesStyle | Enumerates possible visual styles for frames that are drawn around selected nodes.
HitTestPriority | Defines values that specify the order of item hit-testing.
HyperLinkStyle | Specifies how various export components should treat the HyperLink property of items.
LinkCrossings | Defines values that indicate how to render link intersection points.
LinkShape | Specifies available styles for the segments of links.
LinkTextStyle | Specifies the position and alignment of links' labels.
MarkStyle | Specifies the visual style of anchor point marks.
MeasureUnitType | Specifies the type of a unit of measure.
NodeHandleType | Identifies the types of selection handles of a node.
NotifyCollectionChangedAction | Describes the action that caused a CollectionChanged event.
Orientation | Defines values that specify the orientation of the first segment of cascading links.
Relationship | Specifies the type of relationship between two tables.
RelativeToLink | Specifies how the link labels are positioned.
RelativeToNode | Specifies how the node labels are positioned.
RenderTarget | Specifies where the diagram is being rendered.
RerouteLinks | Provides values indicating in what circumstances links must be rerouted automatically.
RestrictToBounds | Specifies the restriction of the position of an object as to the document extents.
SaveToStringFormat | Specifies in what format to save the diagram when generating a string using the SaveToString method.
SelectionStyle | Defines values that specify how multiple selected items are indicated visually.
ShadowsStyle | Enumerates possible shadows-drawing styles.
ShowAnchors | Specifies when anchors points should be displayed.
SimpleShape | Defines the possible values for Shape property of tables.
SnapToAnchor | Specifies when link ends are snapped to nearest anchor points.
TableConnectionStyle | Specifies the possible values for the ConnectionStyle property of tables.
TreeViewConnectionStyle | Specifies the possible values for the ConnectionStyle property of TreeViewNode objects.
UnitType | Defines values that indicate whether point positions are specified in percentage, or in absolute units relative to the node's top-left corner.
VisualizationPosition | Specifies the alignment of the radial menu items relative to the menu center.


MindFusion.Diagramming.Action Enumeration

Action Enumeration
[image]

Specifies the possible actions a user can carry out on diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Action

Visual Basic [image] Copy Code

Public Enum Action

Members

Member name | Description
Create | Draw a new item.
Modify | Modify an existing item.
None | Do not perform any action.
Split | Split a link's segment.

See Also

MindFusion.Diagramming Namespace


MindFusion.Diagramming.AdjustmentHandle Class

AdjustmentHandle Class
[image]

Represents an adjustment handle used to move or modify diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class AdjustmentHandle

Visual Basic [image] Copy Code

Public MustInherit Class AdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AdjustmentHandle
MindFusion.Diagramming.LinkAdjustmentHandle
MindFusion.Diagramming.NodeAdjustmentHandle

See Also

AdjustmentHandle Members


MindFusion.Diagramming.AdjustmentHandle Members

AdjustmentHandle Members
Constructors
[image]

Represents an adjustment handle used to move or modify diagram items.

The following tables list the members exposed by the AdjustmentHandle type.

Protected Constructors

Name | Description
AdjustmentHandle | Initializes a new instance of the AdjustmentHandle class.

See Also

AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandle Constructor

AdjustmentHandle Constructor
[image]

Initializes a new instance of the AdjustmentHandle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected AdjustmentHandle ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

AdjustmentHandle Class


MindFusion.Diagramming.AdjustmentHandles Enumeration

AdjustmentHandles Enumeration
[image]

Identifies the distinct selection handles of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AdjustmentHandles

Visual Basic [image] Copy Code

Public Enum AdjustmentHandles

Members

Member name | Description
All | All selection handles areenabled and canbe used to modify the node.
BottomHandles | The bottom-left, bottom-center and bottom-right handles are enabled.
LeftHandles | The top-left, middle-left and bottom-left handles are enabled.
Move | The center selection handle is enabled and can be used to move the node.
None | Specifies that none of the selection handles can be used to modify the node.
ResizeBottomCenter | The bottom-center handle is enabled and can be used to resize the node vertically.
ResizeBottomLeft | The bottom-left handle is enabled and can be used to resize the node.
ResizeBottomRight | The bottom-right handle is enabled and can be used to resize the node.
ResizeMiddleLeft | The middle-left handle is enabled and can be used to resize the node horizontally.
ResizeMiddleRight | The middle-right handle is enabled and can be used to resize the node horizontally.
ResizeTopCenter | The top-center handle is enabled and can be used to resize the node vertically.
ResizeTopLeft | The top-left handle is enabled and can be used to resize the node.
ResizeTopRight | The top-right handle is enabled and can be used to resize the node.
RightHandles | The top-right, bottom-right and middle-right handles are enabled.
Rotate | The rotation handle is enabled and can be used to rotate the node.
TopHandles | The top-left, top-center and top-right handles are enabled.

See Also


MindFusion.Diagramming.AeroEffect Class

AeroEffect Class
Remarks See Also
[image]

Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class AeroEffect : NodeEffect

Visual Basic [image] Copy Code

Public NotInheritable Class AeroEffect
Inherits NodeEffect

Remarks

This effect can be applied to the nodes in a Diagram by adding an instance of this class to the NodeEffects collection.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeEffect
MindFusion.Diagramming.AeroEffect

See Also

AeroEffect Members


MindFusion.Diagramming.AeroEffect Members

AeroEffect Members
Constructors Properties Methods Events
[image]

Represents an effect that adds semitransparency to the node and emphasizes its outline by adding a shade and an inner stroke.

The following tables list the members exposed by the AeroEffect type.

Public Constructors

Name | Description
AeroEffect | Initializes a new instance of the AeroEffect class.

Public Properties

Name | Description
InnerOutlineColor | Gets or sets the color of the inner outline.
Opacity | Gets or sets the opacity to apply to the node's background.
ShadeColor | Gets or sets the color of the shade.

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect Constructor

AeroEffect Constructor
[image]

Initializes a new instance of the AeroEffect class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AeroEffect ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect Methods

AeroEffect Methods
[image]

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect.Clone Method

AeroEffect.Clone Method
[image]

NodeEffect.Clone override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override NodeEffect Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As NodeEffect

Return Value

An instance of the NodeEffect class.

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect Properties

AeroEffect Properties
[image]

Public Properties

Name | Description
InnerOutlineColor | Gets or sets the color of the inner outline.
Opacity | Gets or sets the opacity to apply to the node's background.
ShadeColor | Gets or sets the color of the shade.

See Also

AeroEffect Class


MindFusion.Diagramming.AeroEffect.InnerOutlineColor Property

AeroEffect.InnerOutlineColor Property
[image]

Gets or sets the color of the inner outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color InnerOutlineColor { get; set; }

Visual Basic [image] Copy Code

Public Property InnerOutlineColor As Color

Property Value

A Color object. The default is White.

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect.Opacity Property

AeroEffect.Opacity Property
[image]

Gets or sets the opacity to apply to the node's background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Opacity { get; set; }

Visual Basic [image] Copy Code

Public Property Opacity As Double

Property Value

A double value.

Remarks

Opacity varies in the range [0..1] where 0 indicates full transparency and 1 indicates the original transparency. Opacity has no effect on image backgrounds.

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.AeroEffect.ShadeColor Property

AeroEffect.ShadeColor Property
[image]

Gets or sets the color of the shade.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ShadeColor { get; set; }

Visual Basic [image] Copy Code

Public Property ShadeColor As Color

Property Value

A Color object. The default is Black.

See Also

AeroEffect Members
AeroEffect Class


MindFusion.Diagramming.Anchoring Enumeration

Anchoring Enumeration
[image]

Defines values that specify how automatic layout algorithms align links to anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Anchoring

Visual Basic [image] Copy Code

Public Enum Anchoring

Members

Member name | Description
Ignore | Anchor points are ignored.
Keep | Links are aligned to their original anchor points.
Reassign | Links are aligned to new anchor points, depending on the positions of graph nodes after a layout is applied.

Remarks

Assign values of this enumeration to the Anchoring property of layout algorithms. Most algorithms produce best results if they can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

See Also


MindFusion.Diagramming.AnchorPattern Class

AnchorPattern Class
Remarks See Also
[image]

Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnchorPattern

Visual Basic [image] Copy Code

Public Class AnchorPattern

Remarks

A pattern can be assigned as an integral entity to the AnchorPattern property of nodes. By default, when assigning a pattern to a node, a new copy of the pattern is created. Thus you can modify nodes' anchor patterns independently at runtime. However, if your anchor patterns won't change while the application executes, you can register them as shared to save storage space for the diagram. To do so, use AnchorPattern constructors that take a string id parameter. The AnchorPattern class exposes several predefined patterns as static properties; all of them are considered shared.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AnchorPattern

See Also

AnchorPattern Members


MindFusion.Diagramming.AnchorPattern Members

AnchorPattern Members
Constructors Properties Methods
[image]

Represents a set of anchor points, which specify the exact locations where links are allowed to connect to nodes.

The following tables list the members exposed by the AnchorPattern type.

Public Constructors

Name | Description
AnchorPattern | Overloaded. Initializes a new instance of the AnchorPattern class.

Public Properties

Name | Description
Decision1In3Out | Gets the predefined anchor pattern Decision1In3Out.
Decision2In2Out | Gets the predefined anchor pattern Decision2In2Out.
Id | Gets the AnchorPattern unique identifier.
LeftInRightOut | Gets the predefined anchor pattern LeftInRightOut.
Points | Gets a collection of the anchor points in this pattern.
TopInBottomOut | Gets the predefined anchor pattern TopInBottomOut.

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPattern object.
FromId | Returns a reference to the anchor pattern with the specified string identifier.
Register | Registers the specified anchor pattern as shared.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor

AnchorPattern Constructor
[image]

Initializes a new instance of the AnchorPattern class.

Overload List

Name | Description
AnchorPattern () | Initializes a new empty instance of the AnchorPattern class.
AnchorPattern (AnchorPoint[]) | Initializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPoint[], String) | Initializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPointCollection) | Initializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (AnchorPointCollection, String) | Initializes a new instance of the AnchorPattern class with the specified anchor points.
AnchorPattern (String) | Initializes a new empty instance of the AnchorPattern class.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor ()

AnchorPattern Constructor ()
See Also
[image]

Initializes a new empty instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPoint[])

AnchorPattern Constructor (AnchorPoint[])
See Also
[image]

Initializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPoint[] points
)

Visual Basic [image] Copy Code

Public New ( _
points() As AnchorPoint _
)

Parameters

points

Contains the initial set of AnchorPoint instances for the new pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPoint[], String)

AnchorPattern Constructor (AnchorPoint[], String)
See Also
[image]

Initializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPoint[] points,
string id
)

Visual Basic [image] Copy Code

Public New ( _
points() As AnchorPoint, _
id As String _
)

Parameters

points

An array of AnchorPoint objects.

id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPointCollection)

AnchorPattern Constructor (AnchorPointCollection)
See Also
[image]

Initializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPointCollection points
)

Visual Basic [image] Copy Code

Public New ( _
points As AnchorPointCollection _
)

Parameters

points

A collection of AnchorPoint objects.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (AnchorPointCollection, String)

AnchorPattern Constructor (AnchorPointCollection, String)
See Also
[image]

Initializes a new instance of the AnchorPattern class with the specified anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
AnchorPointCollection points,
string id
)

Visual Basic [image] Copy Code

Public New ( _
points As AnchorPointCollection, _
id As String _
)

Parameters

points

A collection of AnchorPoint objects.

id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Constructor (String)

AnchorPattern Constructor (String)
See Also
[image]

Initializes a new empty instance of the AnchorPattern class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern (
string id
)

Visual Basic [image] Copy Code

Public New ( _
id As String _
)

Parameters

id

An unique identifier for this anchor pattern.

See Also

AnchorPattern Constructor Overload List
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Methods

AnchorPattern Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPattern object.
FromId | Returns a reference to the anchor pattern with the specified string identifier.
Register | Registers the specified anchor pattern as shared.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Clone Method

AnchorPattern.Clone Method
[image]

Creates an exact clone of this AnchorPattern object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the AnchorPattern class.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.FromId Method

AnchorPattern.FromId Method
[image]

Returns a reference to the anchor pattern with the specified string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern FromId (
string id
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As String _
) As AnchorPattern

Parameters

id

A string identifying an AnchorPattern instance.

Return Value

The AnchorPattern object whose Id is equal to the id parameter, or null if no such object exists.

Remarks

The id argument should match an identifier passed to the constructor of an existing AnchorPattern object.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Register Method

AnchorPattern.Register Method
[image]

Registers the specified anchor pattern as shared.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void Register (
AnchorPattern pattern
)

Visual Basic [image] Copy Code

Public Shared Sub Register( _
pattern As AnchorPattern _
)

Parameters

pattern

The AnchorPattern to register.

Remarks

This method is obsolete. Please use the Id property to create shared anchor patterns.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern Properties

AnchorPattern Properties
[image]

Public Properties

Name | Description
Decision1In3Out | Gets the predefined anchor pattern Decision1In3Out.
Decision2In2Out | Gets the predefined anchor pattern Decision2In2Out.
Id | Gets the AnchorPattern unique identifier.
LeftInRightOut | Gets the predefined anchor pattern LeftInRightOut.
Points | Gets a collection of the anchor points in this pattern.
TopInBottomOut | Gets the predefined anchor pattern TopInBottomOut.

See Also

AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Decision1In3Out Property

AnchorPattern.Decision1In3Out Property
[image]

Gets the predefined anchor pattern Decision1In3Out.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern Decision1In3Out { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision1In3Out As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

Incoming links connect to the top vertex; outgoing links can start from the other vertices.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Decision2In2Out Property

AnchorPattern.Decision2In2Out Property
[image]

Gets the predefined anchor pattern Decision2In2Out.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern Decision2In2Out { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision2In2Out As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

Incoming links can connect with the top and left vertices; outgoing links can start from the right and bottom vertices.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Id Property

AnchorPattern.Id Property
[image]

Gets the AnchorPattern unique identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As String

Property Value

The string id that was passed as an argument to the AnchorPattern constructor. The default is an empty string.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.LeftInRightOut Property

AnchorPattern.LeftInRightOut Property
[image]

Gets the predefined anchor pattern LeftInRightOut.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern LeftInRightOut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property LeftInRightOut As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

The middle point of a node's bounding rectangle left side is anchor for incoming links; that on the right side – for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.Points Property

AnchorPattern.Points Property
[image]

Gets a collection of the anchor points in this pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointCollection Points { get; set; }

Visual Basic [image] Copy Code

Public Property Points As AnchorPointCollection

Property Value

A collection of AnchorPoint object.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPattern.TopInBottomOut Property

AnchorPattern.TopInBottomOut Property
[image]

Gets the predefined anchor pattern TopInBottomOut.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static AnchorPattern TopInBottomOut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property TopInBottomOut As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

The middle point of a node's bounding rectangle top side is anchor for incoming links; that on the bottom – for outgoing.

See Also

AnchorPattern Members
AnchorPattern Class


MindFusion.Diagramming.AnchorPoint Class

AnchorPoint Class
Remarks See Also
[image]

Represents a location in a node, to which links are allowed to connect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class AnchorPoint

Visual Basic [image] Copy Code

Public NotInheritable Class AnchorPoint

Remarks

An anchor point can accept incoming or outgoing links, or both, as specified by the AllowIncoming and AllowOutgoing properties. The position of the anchor point inside a node's bounding rectangle is set through the X and Y properties, expressed as percent of the rectangle width and height.

How anchor points are marked on the display can be set using MarkStyle and Color properties. Custom painting can be done by setting MarkStyle to Custom and handling the DrawAnchorPoint event.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AnchorPoint

See Also

AnchorPoint Members


MindFusion.Diagramming.AnchorPoint Members

AnchorPoint Members
Constructors Properties Methods
[image]

Represents a location in a node, to which links are allowed to connect.

The following tables list the members exposed by the AnchorPoint type.

Public Constructors

Name | Description
AnchorPoint | Overloaded. Initializes a new instance of the AnchorPoint class.

Public Properties

Name | Description
AllowIncoming | Gets or sets a value indicating whether incoming links can be connected to this anchor.
AllowOutgoing | Gets or sets a value indicating whether the anchor point accepts outgoing connections.
Color | Gets or sets the color of the anchor point mark.
Column | Gets or sets the column index of a cell with which the anchor point is associated.
MarkStyle | Gets or sets the appearance of the anchor point mark.
Tag | Gets or sets a user-defined data associated with the anchor point.
X | Gets or sets the horizontal position of the anchor point expressed as percent of a node's width or as a fixed length.
XUnit | Gets or sets whether the point's X position is specified as percentage of node's size or fixed offset from the node's left side.
Y | Gets or sets the vertical position of the anchor point expressed as percent of a node's height or as a fixed length.
YUnit | Gets or sets whether the point's Y position is specified as percentage of node's size or fixed offset from the node's top side.

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPoint object.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor

AnchorPoint Constructor
[image]

Initializes a new instance of the AnchorPoint class.

Overload List

Name | Description
AnchorPoint (Double, Double) | Initializes a new instance of the AnchorPoint class with the specified coordinates.
AnchorPoint (Double, Double, Boolean, Boolean) | Initializes a new instance of the AnchorPoint class with the specified coordinates and restrictions.
AnchorPoint (Double, Double, Boolean, Boolean, Color, Int32) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and brush.
AnchorPoint (Double, Double, Boolean, Boolean, Color, Int32, Object) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, brush and tag.
AnchorPoint (Double, Double, Boolean, Boolean, MarkStyle) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and style.
AnchorPoint (Double, Double, Boolean, Boolean, MarkStyle, Color) | Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, style and brush.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double)

AnchorPoint Constructor (Double, Double)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double, Boolean, Boolean)

AnchorPoint Constructor (Double, Double, Boolean, Boolean)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates and restrictions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double, Boolean, Boolean, Color, Int32)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, Color, Int32)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
Color color,
int col
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
color As Color, _
col As Integer _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

color

The color with which the anchor mark is painted.

col

Specifies a table's column, with which an anchor point is associated.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double, Boolean, Boolean, Color, Int32, Object)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, Color, Int32, Object)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, brush and tag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
Color color,
int col,
Object tag
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
color As Color, _
col As Integer, _
tag As Object _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

color

The color with which the anchor mark is painted.

col

The table's column, with which an anchor point is associated.

tag

User-defined data associated with the anchor point.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions and style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
MarkStyle markStyle
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
markStyle As MarkStyle _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

markStyle

Defines how the anchor point is marked visually.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle, Color)

AnchorPoint Constructor (Double, Double, Boolean, Boolean, MarkStyle, Color)
See Also
[image]

Initializes a new instance of the AnchorPoint class with the specified coordinates, restrictions, style and brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint (
double x,
double y,
bool allowIncoming,
bool allowOutgoing,
MarkStyle markStyle,
Color color
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
allowIncoming As Boolean, _
allowOutgoing As Boolean, _
markStyle As MarkStyle, _
color As Color _
)

Parameters

x

The horizontal position of the anchor expressed as percent of the width of a node.

y

The vertical position of the anchor expressed as percent of the height of a node.

allowIncoming

Specifies whether incoming links can connect to this anchor.

allowOutgoing

Specifies whether outgoing links can connect to this anchor.

markStyle

Defines how the anchor point is marked visually.

color

The color with which the anchor mark is painted.

See Also

AnchorPoint Constructor Overload List
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Methods

AnchorPoint Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this AnchorPoint object.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.Clone Method

AnchorPoint.Clone Method
[image]

Creates an exact clone of this AnchorPoint object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the AnchorPoint class.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint Properties

AnchorPoint Properties
[image]

Public Properties

Name | Description
AllowIncoming | Gets or sets a value indicating whether incoming links can be connected to this anchor.
AllowOutgoing | Gets or sets a value indicating whether the anchor point accepts outgoing connections.
Color | Gets or sets the color of the anchor point mark.
Column | Gets or sets the column index of a cell with which the anchor point is associated.
MarkStyle | Gets or sets the appearance of the anchor point mark.
Tag | Gets or sets a user-defined data associated with the anchor point.
X | Gets or sets the horizontal position of the anchor point expressed as percent of a node's width or as a fixed length.
XUnit | Gets or sets whether the point's X position is specified as percentage of node's size or fixed offset from the node's left side.
Y | Gets or sets the vertical position of the anchor point expressed as percent of a node's height or as a fixed length.
YUnit | Gets or sets whether the point's Y position is specified as percentage of node's size or fixed offset from the node's top side.

See Also

AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.AllowIncoming Property

AnchorPoint.AllowIncoming Property
[image]

Gets or sets a value indicating whether incoming links can be connected to this anchor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowIncoming { get; set; }

Visual Basic [image] Copy Code

Public Property AllowIncoming As Boolean

Property Value

true to allow incoming links connect to the anchor; false to forbid that. The default is true.

Remarks

If no incoming anchors are defined for a node, links end points can be placed anywhere inside that node, unless AllowUnanchoredLinks is disabled.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.AllowOutgoing Property

AnchorPoint.AllowOutgoing Property
[image]

Gets or sets a value indicating whether the anchor point accepts outgoing connections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowOutgoing { get; set; }

Visual Basic [image] Copy Code

Public Property AllowOutgoing As Boolean

Property Value

true to allow outgoing links connect to the anchor; false to forbid that. The default is true.

Remarks

If no outgoing anchors are defined for a node, links start points can be placed anywhere inside that node, unless AllowUnanchoredLinks is disabled.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.Color Property

AnchorPoint.Color Property
[image]

Gets or sets the color of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

An instance of the Color structure. The default is Black.

Remarks

The anchor mark shape specified via MarkStyle is painted with this color.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.Column Property

AnchorPoint.Column Property
[image]

Gets or sets the column index of a cell with which the anchor point is associated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; set; }

Visual Basic [image] Copy Code

Public Property Column As Integer

Property Value

An integer value specifying the zero-based index of a table's column. The default is -1.

Remarks

If Column is set to -1, the point relative coordinates specify percents of row's extents. Otherwise the point coordinates specify percents of cell's extents.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.MarkStyle Property

AnchorPoint.MarkStyle Property
[image]

Gets or sets the appearance of the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MarkStyle MarkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property MarkStyle As MarkStyle

Property Value

A member of the MarkStyle enumeration. The default is MarkStyle.X.

Remarks

Specifies how anchor points are marked visually on the display.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.Tag Property

AnchorPoint.Tag Property
[image]

Gets or sets a user-defined data associated with the anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default is null.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.X Property

AnchorPoint.X Property
[image]

Gets or sets the horizontal position of the anchor point expressed as percent of a node's width or as a fixed length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

A double value specifying the location of the anchor point.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.XUnit Property

AnchorPoint.XUnit Property
[image]

Gets or sets whether the point's X position is specified as percentage of node's size or fixed offset from the node's left side.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public UnitType XUnit { get; set; }

Visual Basic [image] Copy Code

Public Property XUnit As UnitType

Property Value

A member of the UnitType enumeration. The default value is Percentage.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.Y Property

AnchorPoint.Y Property
[image]

Gets or sets the vertical position of the anchor point expressed as percent of a node's height or as a fixed length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

A double value specifying the location of the anchor point.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPoint.YUnit Property

AnchorPoint.YUnit Property
[image]

Gets or sets whether the point's Y position is specified as percentage of node's size or fixed offset from the node's top side.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public UnitType YUnit { get; set; }

Visual Basic [image] Copy Code

Public Property YUnit As UnitType

Property Value

A member of the UnitType enumeration. The default value is Percentage.

See Also

AnchorPoint Members
AnchorPoint Class


MindFusion.Diagramming.AnchorPointCollection Class

AnchorPointCollection Class
[image]

Represents a strongly-typed collection of anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnchorPointCollection : CollectionBase<AnchorPoint>

Visual Basic [image] Copy Code

Public Class AnchorPointCollection
Inherits CollectionBase(Of AnchorPoint)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(AnchorPoint)
MindFusion.Diagramming.AnchorPointCollection

See Also

AnchorPointCollection Members


MindFusion.Diagramming.AnchorPointCollection Members

AnchorPointCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly-typed collection of anchor points.

The following tables list the members exposed by the AnchorPointCollection type.

Public Constructors

Name | Description
AnchorPointCollection | Overloaded. Initializes a new instance of the AnchorPointCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Add | Adds the specified anchor point to the collection.
Clear | Removes all anchor points from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the anchor point at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified anchor point in the collection at the specified position.
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
Remove | Removes the specified anchor point from the collection.
RemoveAt | Removes the anchor point at the specified index of the collection.
Sort | Overloaded. Sorts the elements in this collection. (Inherited from CollectionBase.)

See Also

AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Constructor

AnchorPointCollection Constructor
[image]

Initializes a new instance of the AnchorPointCollection class.

Overload List

Name | Description
AnchorPointCollection () | Initializes a new instance of the AnchorPointCollection class.
AnchorPointCollection (AnchorPoint[]) | Initializes a new instance of the AnchorPointCollection class.

See Also

AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Constructor ()

AnchorPointCollection Constructor ()
See Also
[image]

Initializes a new instance of the AnchorPointCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnchorPointCollection Constructor Overload List
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Constructor (AnchorPoint[])

AnchorPointCollection Constructor (AnchorPoint[])
See Also
[image]

Initializes a new instance of the AnchorPointCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointCollection (
AnchorPoint[] array
)

Visual Basic [image] Copy Code

Public New ( _
array() As AnchorPoint _
)

Parameters

array

An array of AnchorPoint objects.

See Also

AnchorPointCollection Constructor Overload List
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection Methods

AnchorPointCollection Methods
[image]

Public Methods

Name | Description
Add | Adds an object to the end of the collection. (Inherited from CollectionBase.)
Add | Adds the specified anchor point to the collection.
Clear | Removes all anchor points from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the anchor point at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified anchor point in the collection at the specified position.
Insert | Inserts an element into the collection at the specified index. (Inherited from CollectionBase.)
Remove | Removes the first occurrence of a specific object from the collection. (Inherited from CollectionBase.)
Remove | Removes the specified anchor point from the collection.
RemoveAt | Removes the anchor point at the specified index of the collection.
Sort | Overloaded. Sorts the elements in this collection. (Inherited from CollectionBase.)

See Also

AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.Add Method

AnchorPointCollection.Add Method
[image]

Adds the specified anchor point to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Add (
AnchorPoint item
)

Visual Basic [image] Copy Code

Public Overrides Sub Add( _
item As AnchorPoint _
)

Parameters

item

The point to add.

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.Clear Method

AnchorPointCollection.Clear Method
[image]

Removes all anchor points from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Clear ()

Visual Basic [image] Copy Code

Public Overrides Sub Clear ()

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.GetAt Method

AnchorPointCollection.GetAt Method
[image]

Gets the anchor point at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPoint GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As AnchorPoint

Parameters

index

The zero-based index of the point to get.

Return Value

The AnchorPoint at the specified index.

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.Insert Method

AnchorPointCollection.Insert Method
[image]

Inserts the specified anchor point in the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Insert (
int index,
AnchorPoint item
)

Visual Basic [image] Copy Code

Public Overrides Sub Insert( _
index As Integer, _
item As AnchorPoint _
)

Parameters

index

The zero-based position at which to insert the new point.

item

The point to insert.

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.Remove Method

AnchorPointCollection.Remove Method
[image]

Removes the specified anchor point from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Remove (
AnchorPoint item
)

Visual Basic [image] Copy Code

Public Overrides Function Remove( _
item As AnchorPoint _
) As Boolean

Parameters

item

The point to remove.

Return Value

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointCollection.RemoveAt Method

AnchorPointCollection.RemoveAt Method
[image]

Removes the anchor point at the specified index of the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overrides Sub RemoveAt( _
index As Integer _
)

Parameters

index

The zero-based index of the point to remove.

See Also

AnchorPointCollection Members
AnchorPointCollection Class


MindFusion.Diagramming.AnchorPointEventArgs Class

AnchorPointEventArgs Class
[image]

Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnchorPointEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class AnchorPointEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.AnchorPointEventArgs

See Also

AnchorPointEventArgs Members


MindFusion.Diagramming.AnchorPointEventArgs Members

AnchorPointEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the anchor point-related events, such as OriginAnchorChanged and DestinationAnchorChanged.

The following tables list the members exposed by the AnchorPointEventArgs type.

Public Constructors

Name | Description
AnchorPointEventArgs | Initializes a new instance of the AnchorPointEventArgs class.

Public Properties

Name | Description
Link | Gets the link whose anchor point index has been changed.
NewAnchorIndex | Gets the index of the new anchor point.
OldAnchorIndex | Gets the index of the old anchor point.

See Also

AnchorPointEventArgs Class


MindFusion.Diagramming.AnchorPointEventArgs Constructor

AnchorPointEventArgs Constructor
[image]

Initializes a new instance of the AnchorPointEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPointEventArgs (
DiagramLink link,
int oldAnchorIndex,
int newAnchorIndex
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
oldAnchorIndex As Integer, _
newAnchorIndex As Integer _
)

Parameters

link

The link whose end has been attached to a different anchor point.

oldAnchorIndex

The index of the old anchor point.

newAnchorIndex

The index of the new anchor point.

See Also

AnchorPointEventArgs Class


MindFusion.Diagramming.AnchorPointEventArgs Properties

AnchorPointEventArgs Properties
[image]

Public Properties

Name | Description
Link | Gets the link whose anchor point index has been changed.
NewAnchorIndex | Gets the index of the new anchor point.
OldAnchorIndex | Gets the index of the old anchor point.

See Also

AnchorPointEventArgs Class


MindFusion.Diagramming.AnchorPointEventArgs.Link Property

AnchorPointEventArgs.Link Property
[image]

Gets the link whose anchor point index has been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class


MindFusion.Diagramming.AnchorPointEventArgs.NewAnchorIndex Property

AnchorPointEventArgs.NewAnchorIndex Property
[image]

Gets the index of the new anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int NewAnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewAnchorIndex As Integer

Property Value

An integer value that represents the index of the anchor point within its containing AnchorPattern class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class


MindFusion.Diagramming.AnchorPointEventArgs.OldAnchorIndex Property

AnchorPointEventArgs.OldAnchorIndex Property
[image]

Gets the index of the old anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int OldAnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldAnchorIndex As Integer

Property Value

An integer value that represents the index of the anchor point within its containing AnchorPattern class.

See Also

AnchorPointEventArgs Members
AnchorPointEventArgs Class


MindFusion.Diagramming.ArcTemplate Class

ArcTemplate Class
[image]

Represents an arc in a shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ArcTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class ArcTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.ArcTemplate

See Also

ArcTemplate Members


MindFusion.Diagramming.ArcTemplate Members

ArcTemplate Members
Constructors Properties Methods
[image]

Represents an arc in a shape definition.

The following tables list the members exposed by the ArcTemplate type.

Public Constructors

Name | Description
ArcTemplate | Overloaded. Initializes a new instance of the ArcTemplate class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
StartAngle | Gets the start angle of this arc element.
SweepAngle | Gets the sweep angle of this arc element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this ArcTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Constructor

ArcTemplate Constructor
[image]

Initializes a new instance of the ArcTemplate class.

Overload List

Name | Description
ArcTemplate (Double, Double, Double, Double, Double, Double) | Initializes a new instance of the ArcTemplate class with the specified coordinates.
ArcTemplate (Double, Double, Double, Double, Double, Double, Color, DashStyle, Double) | Initializes a new instance of the ArcTemplate class with the specified coordinates and visualization settings.

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Constructor (Double, Double, Double, Double, Double, Double)

ArcTemplate Constructor (Double, Double, Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the ArcTemplate class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ArcTemplate (
double x,
double y,
double w,
double h,
double a,
double s
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
a As Double, _
s As Double _
)

Parameters

x

The x-coordinate of the upper left corner of the ellipse's bounding rectangle.

y

The y-coordinate of the upper left corner of the ellipse's bounding rectangle.

w

The width of the ellipse's bounding rectangle.

h

The height of the ellipse's bounding rectangle.

a

The clockwise angle, in degrees, between the horizontal axis of the ellipse and the starting point of the arc.

s

The clockwise angle, in degrees, between the starting point and the ending point of the arc.

Remarks

An arc template is defined by an ellipse and starting and sweeping angles.

See Also

ArcTemplate Constructor Overload List
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Constructor (Double, Double, Double, Double, Double, Double, Color, DashStyle, Double)

ArcTemplate Constructor (Double, Double, Double, Double, Double, Double, Color, DashStyle, Double)
See Also
[image]

Initializes a new instance of the ArcTemplate class with the specified coordinates and visualization settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ArcTemplate (
double x,
double y,
double w,
double h,
double a,
double s,
Color color,
DashStyle dashStyle,
double width
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
a As Double, _
s As Double, _
color As Color, _
dashStyle As DashStyle, _
width As Double _
)

Parameters

x

The x-coordinate of the upper left corner of the ellipse's bounding rectangle.

y

The y-coordinate of the upper left corner of the ellipse's bounding rectangle.

w

The width of the ellipse's bounding rectangle.

h

The height of the ellipse's bounding rectangle.

a

The clockwise angle, in degrees, between the horizontal axis of the ellipse and the starting point of the arc.

s

The clockwise angle, in degrees, between the starting point and the ending point of the arc.

color

The color of this segment.

dashStyle

The dash style of this segment.

width

The width of this segment.

Remarks

An arc template is defined by an ellipse and starting and sweeping angles.

See Also

ArcTemplate Constructor Overload List
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Methods

ArcTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this ArcTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.Clone Method

ArcTemplate.Clone Method
[image]

Creates an exact copy of this ArcTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override ElementTemplate Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As ElementTemplate

Return Value

An instance of the ArcTemplate class.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.SameAs Method

ArcTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is an ArcTemplate closely approximating this template; otherwise, false.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate Properties

ArcTemplate Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
StartAngle | Gets the start angle of this arc element.
SweepAngle | Gets the sweep angle of this arc element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.Bounds Property

ArcTemplate.Bounds Property
[image]

Gets the bounding rectangle of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

An instance of the Rectangle structure.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.StartAngle Property

ArcTemplate.StartAngle Property
[image]

Gets the start angle of this arc element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StartAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartAngle As Double

Property Value

A double value specifying the start angle of the arc, in degrees.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArcTemplate.SweepAngle Property

ArcTemplate.SweepAngle Property
[image]

Gets the sweep angle of this arc element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double SweepAngle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SweepAngle As Double

Property Value

A double value specifying the sweep angle of the arc, in degrees.

See Also

ArcTemplate Members
ArcTemplate Class


MindFusion.Diagramming.ArrowHeads Class

ArrowHeads Class
Remarks See Also
[image]

Contains predefined arrowhead shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class ArrowHeads

Visual Basic [image] Copy Code

Public NotInheritable Class ArrowHeads

Remarks

Shape objects exposed as properties of this class can be assigned to the HeadShape, BaseShape and IntermediateShape properties of links.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ArrowHeads

See Also

ArrowHeads Members


MindFusion.Diagramming.ArrowHeads Members

ArrowHeads Members
Fields
[image]

Contains predefined arrowhead shapes.

The following tables list the members exposed by the ArrowHeads type.

Public Fields

Name | Description
Arrow | Display an arrow-like shape.
BackSlash | Display a back slash.
BowArrow | Display a bow arrow.
Circle | Display a circle.
DefaultFlow | "Default flow" in BPMN diagrams.
DoubleArrow | Display a double arrow.
None | Do not display an arrowhead shape.
Pentagon | Display a pentagon.
PointerArrow | Display a pointer arrow.
Quill | Display a quill.
Reversed | Reversed arrowhead.
RevTriangle | Display a reversed triangle.
RevWithCirc | Reversed arrowhead with a circle.
RevWithLine | Reversed arrowhead with intersecting line.
Rhombus | Display a rhombus.
Slash | Display a slash.
Tetragon | Display a tetragon.
Triangle | Display a triangle.

See Also

ArrowHeads Class


MindFusion.Diagramming.ArrowHeads Fields

ArrowHeads Fields
[image]

Public Fields

Name | Description
Arrow | Display an arrow-like shape.
BackSlash | Display a back slash.
BowArrow | Display a bow arrow.
Circle | Display a circle.
DefaultFlow | "Default flow" in BPMN diagrams.
DoubleArrow | Display a double arrow.
None | Do not display an arrowhead shape.
Pentagon | Display a pentagon.
PointerArrow | Display a pointer arrow.
Quill | Display a quill.
Reversed | Reversed arrowhead.
RevTriangle | Display a reversed triangle.
RevWithCirc | Reversed arrowhead with a circle.
RevWithLine | Reversed arrowhead with intersecting line.
Rhombus | Display a rhombus.
Slash | Display a slash.
Tetragon | Display a tetragon.
Triangle | Display a triangle.

See Also

ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Arrow Field

ArrowHeads.Arrow Field
[image]

Display an arrow-like shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow

Visual Basic [image] Copy Code

Public Shared Arrow As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.BackSlash Field

ArrowHeads.BackSlash Field
[image]

Display a back slash.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BackSlash

Visual Basic [image] Copy Code

Public Shared BackSlash As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.BowArrow Field

ArrowHeads.BowArrow Field
[image]

Display a bow arrow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BowArrow

Visual Basic [image] Copy Code

Public Shared BowArrow As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Circle Field

ArrowHeads.Circle Field
[image]

Display a circle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Circle

Visual Basic [image] Copy Code

Public Shared Circle As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.DefaultFlow Field

ArrowHeads.DefaultFlow Field
[image]

"Default flow" in BPMN diagrams.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DefaultFlow

Visual Basic [image] Copy Code

Public Shared DefaultFlow As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.DoubleArrow Field

ArrowHeads.DoubleArrow Field
[image]

Display a double arrow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DoubleArrow

Visual Basic [image] Copy Code

Public Shared DoubleArrow As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.None Field

ArrowHeads.None Field
[image]

Do not display an arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape None

Visual Basic [image] Copy Code

Public Shared None As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Pentagon Field

ArrowHeads.Pentagon Field
[image]

Display a pentagon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Pentagon

Visual Basic [image] Copy Code

Public Shared Pentagon As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.PointerArrow Field

ArrowHeads.PointerArrow Field
[image]

Display a pointer arrow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PointerArrow

Visual Basic [image] Copy Code

Public Shared PointerArrow As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Quill Field

ArrowHeads.Quill Field
[image]

Display a quill.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Quill

Visual Basic [image] Copy Code

Public Shared Quill As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Reversed Field

ArrowHeads.Reversed Field
[image]

Reversed arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Reversed

Visual Basic [image] Copy Code

Public Shared Reversed As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.RevTriangle Field

ArrowHeads.RevTriangle Field
[image]

Display a reversed triangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RevTriangle

Visual Basic [image] Copy Code

Public Shared RevTriangle As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.RevWithCirc Field

ArrowHeads.RevWithCirc Field
[image]

Reversed arrowhead with a circle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RevWithCirc

Visual Basic [image] Copy Code

Public Shared RevWithCirc As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.RevWithLine Field

ArrowHeads.RevWithLine Field
[image]

Reversed arrowhead with intersecting line.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RevWithLine

Visual Basic [image] Copy Code

Public Shared RevWithLine As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Rhombus Field

ArrowHeads.Rhombus Field
[image]

Display a rhombus.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Rhombus

Visual Basic [image] Copy Code

Public Shared Rhombus As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Slash Field

ArrowHeads.Slash Field
[image]

Display a slash.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Slash

Visual Basic [image] Copy Code

Public Shared Slash As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Tetragon Field

ArrowHeads.Tetragon Field
[image]

Display a tetragon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Tetragon

Visual Basic [image] Copy Code

Public Shared Tetragon As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.ArrowHeads.Triangle Field

ArrowHeads.Triangle Field
[image]

Display a triangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Triangle

Visual Basic [image] Copy Code

Public Shared Triangle As Shape

See Also

ArrowHeads Members
ArrowHeads Class


MindFusion.Diagramming.AttachTo Enumeration

AttachTo Enumeration
[image]

Specifies the type of attachment in a group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AttachTo

Visual Basic [image] Copy Code

Public Enum AttachTo

Members

Member name | Description
AnchorToEdges | Indicates attachment that is anchored to one or more sides of a node.
ControlledByMaster | The virtual UpdateGroup method of master items is called to update subordinates.
DistanceAlongLink | Preserves the absolute distance from a node to link's start or end point.
FixedCorner | Indicates attachment to a fixed corner of a node.
LinkPoint | Indicates attachment to an link's control point.
LinkSegment | Indicates attachment to an link's segment.
LongestHSegment | Indicates attachment to the longest horizontal segment of a link.
Proportional | Indicates proportional attachment to a node.
ProportionalToLength | Preserves the relative distance from a node to link's start point.
SideMiddle | Indicates attachment to the middle of a side of a node's bounding rectangle.

See Also


MindFusion.Diagramming.AttachToLink Enumeration

AttachToLink Enumeration
[image]

Specifies the possible ways to attach a node to a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AttachToLink

Visual Basic [image] Copy Code

Public Enum AttachToLink

Members

Member name | Description
Center | The node is attached to the center of the link's bounding rectangle.
FixedDistance | Preserves the absolute distance from a node to link's start or end point.
LongestHSegment | The node stays attached to the longest horizontal segment of the link.
Point | The node is attached to a fixed control point of the link.
RelativeDistance | Preserves the relative distance from a node to link's start point.
Segment | The node is attached to a fixed segment of the link.

Remarks

Members of this enumeration are used as values for the argument of the AttachToLink methods of the DiagramNode class.

See Also


MindFusion.Diagramming.AttachToNode Enumeration

AttachToNode Enumeration
[image]

Defines values specifying the possible ways to attach a node to another node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AttachToNode

Visual Basic [image] Copy Code

Public Enum AttachToNode

Members

Member name | Description
BottomCenter | The node follows the bottom-center point of the master node.
BottomLeft | The node follows the bottom-left corner of the master node.
BottomRight | The node follows the bottom-right corner of the master node.
Center | The node follows the center of the master node.
MiddleLeft | The node follows the middle-left point of the master node.
MiddleRight | The node follows the middle-right point of the master node.
TopCenter | The node follows the top-center point of the master node.
TopLeft | The node follows the top-left corner of the master node.
TopRight | The node follows the top-right corner of the master node.

Remarks

Members of this enumeration are used as values for the argument of the AttachToNode method of the DiagramNode class.

See Also


MindFusion.Diagramming.AutoResize Enumeration

AutoResize Enumeration
[image]

Defines in which directions automatic resizing can enlarge the diagram scrollable area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AutoResize

Visual Basic [image] Copy Code

Public Enum AutoResize

Members

Member name | Description
AllDirections | Enlarge the diagram area in any direction if an item is moved outside the boundaries.
None | Do not enlarge the diagram area automatically.
RightAndDown | Enlarge the diagram area to the right and down if an item is moved outside the boundaries in these directions.

Remarks

Values from this enumeration can be assigned to the AutoResize property.

See Also


MindFusion.Diagramming.Axis Enumeration

Axis Enumeration
[image]

Specifies a coordinate axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Axis

Visual Basic [image] Copy Code

Public Enum Axis

Members

Member name | Description
X | Indicates the X coordinate axis.
Y | Indicates the Y coordinate axis.

See Also


MindFusion.Diagramming.Behavior Enumeration

Behavior Enumeration
[image]

Defines values that specify how the component responds to actions performed by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Behavior

Visual Basic [image] Copy Code

Public Enum Behavior

Members

Member name | Description
Custom | Specifies that user input should be handled by the BaseTouchBehavior-derived object assigned to CustomBehavior.
DoNothing | The control ignores users actions, but raises the appropriate events. This mode allows applications to implement their own drawing behavior, disabling the MindFusion.Diagramming for .NET MAUI default response to users actions.
DrawContainers | Touching and dragging creates ContainerNode instances.
DrawFreeForms | Drawing over empty document area creates FreeFormNode instances.
DrawFreeShapes | Points from user input are shown using a FreeFormNode instance. Once the user finishes drawing, the FreeFormNode is replaced by a ShapeNode with a matching shape from Diagram.FreeFormTargets list.
DrawLinks | Drawing started over a node creates a DiagramLink. Otherwise a lasso rectangle is displayed allowing the selection of items.
DrawShapes | Touching and dragging creates ShapeNode instances.
DrawTables | Touching and dragging creates TableNode instances.
DrawTreeViews | Touching and dragging creates TreeViewNode instances.
LinkContainers | Drawing over empty document area creates a ContainerNode instance. Drawing started over a node creates a DiagramLink.
LinkFreeForms | Drawing over empty document area creates a FreeFormNode instance. Drawing started over a node creates a DiagramLink.
LinkFreeShapes | Points from user input are shown using a FreeFormNode instance. Once the user finishes drawing, the FreeFormNode is replaced by a ShapeNode with a matching shape from Diagram.FreeFormTargets list. Drawing started over a node creates a DiagramLink.
LinkShapes | A mode that is suitable for creating flowcharts and process diagrams. Drawing over empty document area creates a ShapeNode instance. Drawing started over a node creates a DiagramLink.
LinkTables | A mode that is suitable for creating entity-relationship diagrams. Drawing over empty document area creates a TableNode instance. Drawing started over a node creates a DiagramLink.
LinkTreeViews | Drawing over empty document area creates a TreeViewNode instance. Drawing started over a node creates a DiagramLink.
Modify | Objects can be selected and modified. New objects cannot be created.
MoveLabels | Dragging with the mouse moves the label under mouse pointer.
MoveNodes | Dragging with the mouse moves the node under mouse pointer.
Pan | Touching and dragging pans the view.
PanAndModify | Items can be selected and modified. New items cannot be created, and dragging without grabbing an adjustment handle pans the view.
SelectOnly | Allow only selection of existing items. Modifying them or drawing new ones is disabled.

Remarks

Set the Behavior property to specify how MindFusion.Diagramming for .NET MAUI interprets user's actions.

See Also


MindFusion.Diagramming.BezierTemplate Class

BezierTemplate Class
[image]

Represents a Bezier curve in a shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class BezierTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class BezierTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.BezierTemplate

See Also

BezierTemplate Members


MindFusion.Diagramming.BezierTemplate Members

BezierTemplate Members
Constructors Properties Methods
[image]

Represents a Bezier curve in a shape definition.

The following tables list the members exposed by the BezierTemplate type.

Public Constructors

Name | Description
BezierTemplate | Overloaded. Initializes a new instance of the BezierTemplate class.

Public Properties

Name | Description
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a double array containing the coordinates of the points defining the bezier curve represented by this element.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this BezierTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Constructor

BezierTemplate Constructor
[image]

Initializes a new instance of the BezierTemplate class.

Overload List

Name | Description
BezierTemplate (Double, Double, Double, Double, Double, Double, Double, Double) | Initializes a new instance of the BezierTemplate class with the specified coordinates.
BezierTemplate (Double, Double, Double, Double, Double, Double, Double, Double, Color, DashStyle, Double) | Initializes a new instance of the BezierTemplate class with the specified coordinates and visualization settings.

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double)

BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the BezierTemplate class with the specified coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BezierTemplate (
double x1,
double y1,
double x2,
double y2,
double x3,
double y3,
double x4,
double y4
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double, _
x3 As Double, _
y3 As Double, _
x4 As Double, _
y4 As Double _
)

Parameters

x1

The x-coordinate of the first control point of the curve.

y1

The y-coordinate of the first control point of the curve.

x2

The x-coordinate of the second control point of the curve.

y2

The y-coordinate of the second control point of the curve.

x3

The x-coordinate of the third control point of the curve.

y3

The y-coordinate of the third control point of the curve.

x4

The x-coordinate of the fourth control point of the curve.

y4

The y-coordinate of the fourth control point of the curve.

Remarks

A Bezier spline is defined by four control points. The spline goes through the first and last points, and the other two define the tension of the spline.

See Also

BezierTemplate Constructor Overload List
BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Color, DashStyle, Double)

BezierTemplate Constructor (Double, Double, Double, Double, Double, Double, Double, Double, Color, DashStyle, Double)
See Also
[image]

Initializes a new instance of the BezierTemplate class with the specified coordinates and visualization settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BezierTemplate (
double x1,
double y1,
double x2,
double y2,
double x3,
double y3,
double x4,
double y4,
Color color,
DashStyle dashStyle,
double width
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double, _
x3 As Double, _
y3 As Double, _
x4 As Double, _
y4 As Double, _
color As Color, _
dashStyle As DashStyle, _
width As Double _
)

Parameters

x1

The x-coordinate of the first control point of the curve.

y1

The y-coordinate of the first control point of the curve.

x2

The x-coordinate of the second control point of the curve.

y2

The y-coordinate of the second control point of the curve.

x3

The x-coordinate of the third control point of the curve.

y3

The y-coordinate of the third control point of the curve.

x4

The x-coordinate of the fourth control point of the curve.

y4

The y-coordinate of the fourth control point of the curve.

color

The color of this segment.

dashStyle

The dash style of this segment.

width

The width of this segment.

Remarks

A Bezier spline is defined by four control points. The spline goes through the first and last points, and the other two define the tension of the spline.

See Also

BezierTemplate Constructor Overload List
BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Methods

BezierTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this BezierTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate.Clone Method

BezierTemplate.Clone Method
[image]

Creates an exact copy of this BezierTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override ElementTemplate Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As ElementTemplate

Return Value

An instance of the BezierTemplate class.

See Also

BezierTemplate Members
BezierTemplate Class


MindFusion.Diagramming.BezierTemplate.SameAs Method

BezierTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is a BezierTemplate closely approximating this template; otherwise, false.

See Also

BezierTemplate Members
BezierTemplate Class


MindFusion.Diagramming.BezierTemplate Properties

BezierTemplate Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a double array containing the coordinates of the points defining the bezier curve represented by this element.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

BezierTemplate Class


MindFusion.Diagramming.BezierTemplate.Coordinates Property

BezierTemplate.Coordinates Property
[image]

Gets a double array containing the coordinates of the points defining the bezier curve represented by this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double[] Coordinates { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Coordinates As Double()

Property Value

An array of double values containing the coordinates of the points composing this element.

See Also

BezierTemplate Members
BezierTemplate Class


MindFusion.Diagramming.CellEventArgs Class

CellEventArgs Class
[image]

Contains the arguments passed to event handlers, such as CellClicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CellEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.CellEventArgs
MindFusion.Diagramming.CellValidationEventArgs

See Also

CellEventArgs Members


MindFusion.Diagramming.CellEventArgs Members

CellEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as CellClicked.

The following tables list the members exposed by the CellEventArgs type.

Public Constructors

Name | Description
CellEventArgs | Initializes a new instance of the CellEventArgs class.

Public Properties

Name | Description
Cell | Get the cell for which the event is raised.
Column | Gets the index of the table's column that contains Cell.
Position | Gets the location related to the event.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs Constructor

CellEventArgs Constructor
[image]

Initializes a new instance of the CellEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CellEventArgs (
TableNode.Cell cell,
Point position,
int column,
int row
)

Visual Basic [image] Copy Code

Public New ( _
cell As TableNode.Cell, _
position As Point, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

position

The location related to the event.

column

The zero-based index of the column related to the event.

row

The zero-based index of the row related to the event.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs Properties

CellEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Get the cell for which the event is raised.
Column | Gets the index of the table's column that contains Cell.
Position | Gets the location related to the event.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Cell Property

CellEventArgs.Cell Property
[image]

Get the cell for which the event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class specifying the cell related to the event.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Column Property

CellEventArgs.Column Property
[image]

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the table column related to the event.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Position Property

CellEventArgs.Position Property
[image]

Gets the location related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

A Point value specifying the current position.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Row Property

CellEventArgs.Row Property
[image]

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the table row related to the event.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellEventArgs.Table Property

CellEventArgs.Table Property
[image]

Get the table that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class specifying the table related to the event.

See Also

CellEventArgs Members
CellEventArgs Class


MindFusion.Diagramming.CellFrameStyle Enumeration

CellFrameStyle Enumeration
[image]

Specifies the style of the cells' frame lines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum CellFrameStyle

Visual Basic [image] Copy Code

Public Enum CellFrameStyle

Members

Member name | Description
None | Table cells have no border.
Simple | The border of table cells is simple line.
System3D | The border has 3D look.

See Also


MindFusion.Diagramming.CellValidationEventArgs Class

CellValidationEventArgs Class
[image]

Contains the arguments passed to event handlers, such as CellTextEditing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CellValidationEventArgs : CellEventArgs

Visual Basic [image] Copy Code

Public Class CellValidationEventArgs
Inherits CellEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.CellEventArgs
MindFusion.Diagramming.CellValidationEventArgs

See Also

CellValidationEventArgs Members


MindFusion.Diagramming.CellValidationEventArgs Members

CellValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as CellTextEditing.

The following tables list the members exposed by the CellValidationEventArgs type.

Public Constructors

Name | Description
CellValidationEventArgs | Initializes a new instance of the CellValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Cell | Get the cell for which the event is raised. (Inherited from CellEventArgs.)
Column | Gets the index of the table's column that contains Cell. (Inherited from CellEventArgs.)
Position | Gets the location related to the event. (Inherited from CellEventArgs.)
Row | Gets the index of the table's row that contains Cell. (Inherited from CellEventArgs.)
Table | Get the table that contains Cell. (Inherited from CellEventArgs.)

See Also

CellValidationEventArgs Class


MindFusion.Diagramming.CellValidationEventArgs Constructor

CellValidationEventArgs Constructor
[image]

Initializes a new instance of the CellValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CellValidationEventArgs (
TableNode.Cell cell,
Point position,
int column,
int row
)

Visual Basic [image] Copy Code

Public New ( _
cell As TableNode.Cell, _
position As Point, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

position

The location related to the event.

column

The zero-based index of the column related to the event.

row

The zero-based index of the row related to the event.

See Also

CellValidationEventArgs Class


MindFusion.Diagramming.CellValidationEventArgs Properties

CellValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Cell | Get the cell for which the event is raised. (Inherited from CellEventArgs.)
Column | Gets the index of the table's column that contains Cell. (Inherited from CellEventArgs.)
Position | Gets the location related to the event. (Inherited from CellEventArgs.)
Row | Gets the index of the table's row that contains Cell. (Inherited from CellEventArgs.)
Table | Get the table that contains Cell. (Inherited from CellEventArgs.)

See Also

CellValidationEventArgs Class


MindFusion.Diagramming.CellValidationEventArgs.Cancel Property

CellValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to prevent the user from completing the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

See Also

CellValidationEventArgs Members
CellValidationEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs Class

ClipboardEventArgs Class
[image]

Contains the arguments passed to the RequestClipboard event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ClipboardEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ClipboardEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ClipboardEventArgs

See Also

ClipboardEventArgs Members


MindFusion.Diagramming.ClipboardEventArgs Members

ClipboardEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the RequestClipboard event handlers.

The following tables list the members exposed by the ClipboardEventArgs type.

Public Constructors

Name | Description
ClipboardEventArgs | Overloaded. Initializes a new instance of the ClipboardEventArgs class.

Public Properties

Name | Description
Data | Gets or sets the clipboard data.
DataType | Gets or sets the type of the data to get or set from the clipboard. This should be null for clipboard set operations.
IsGetOperation | Gets a value indicating whether getting or setting the clipboard.
IsHandled | Gets or sets a value indicating whether the event is handled.
Source | Gets the object, which initiated the event.

See Also

ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs Constructor

ClipboardEventArgs Constructor
[image]

Initializes a new instance of the ClipboardEventArgs class.

Overload List

Name | Description
ClipboardEventArgs (Object) | Initializes a new instance of the ClipboardEventArgs class.
ClipboardEventArgs (Object, Object) | Initializes a new instance of the ClipboardEventArgs class.

See Also

ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs Constructor (Object)

ClipboardEventArgs Constructor (Object)
See Also
[image]

Initializes a new instance of the ClipboardEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ClipboardEventArgs (
Object source
)

Visual Basic [image] Copy Code

Public New ( _
source As Object _
)

Parameters

source

The object requesting the Clipboard contents.

See Also

ClipboardEventArgs Constructor Overload List
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs Constructor (Object, Object)

ClipboardEventArgs Constructor (Object, Object)
See Also
[image]

Initializes a new instance of the ClipboardEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ClipboardEventArgs (
Object source,
Object value
)

Visual Basic [image] Copy Code

Public New ( _
source As Object, _
value As Object _
)

Parameters

source

The object requesting to set the Clipboard contents.

value
The new contents for the Clipboard.

See Also

ClipboardEventArgs Constructor Overload List
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs Properties

ClipboardEventArgs Properties
[image]

Public Properties

Name | Description
Data | Gets or sets the clipboard data.
DataType | Gets or sets the type of the data to get or set from the clipboard. This should be null for clipboard set operations.
IsGetOperation | Gets a value indicating whether getting or setting the clipboard.
IsHandled | Gets or sets a value indicating whether the event is handled.
Source | Gets the object, which initiated the event.

See Also

ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs.Data Property

ClipboardEventArgs.Data Property
[image]

Gets or sets the clipboard data.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Data { get; set; }

Visual Basic [image] Copy Code

Public Property Data As Object

Property Value

An object representing the Clipboard contents.

See Also

ClipboardEventArgs Members
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs.DataType Property

ClipboardEventArgs.DataType Property
[image]

Gets or sets the type of the data to get or set from the clipboard. This should be null for clipboard set operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Type DataType { get; set; }

Visual Basic [image] Copy Code

Public Property DataType As Type

Property Value

A Type instance.

See Also

ClipboardEventArgs Members
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs.IsGetOperation Property

ClipboardEventArgs.IsGetOperation Property
[image]

Gets a value indicating whether getting or setting the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsGetOperation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsGetOperation As Boolean

Property Value

true if the request is to get the Clipboard contents; false if the request is to set Clipboard contents.

See Also

ClipboardEventArgs Members
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs.IsHandled Property

ClipboardEventArgs.IsHandled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsHandled { get; set; }

Visual Basic [image] Copy Code

Public Property IsHandled As Boolean

Property Value

A boolean value.

See Also

ClipboardEventArgs Members
ClipboardEventArgs Class


MindFusion.Diagramming.ClipboardEventArgs.Source Property

ClipboardEventArgs.Source Property
[image]

Gets the object, which initiated the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Source { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Source As Object

Property Value

The object requesting the Clipboard.

See Also

ClipboardEventArgs Members
ClipboardEventArgs Class


MindFusion.Diagramming.CollectionBase(T) Class

CollectionBase(T) Class
[image]

An implementation of the IList<T> interface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class CollectionBase<T> : IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable

Visual Basic [image] Copy Code

Public MustInherit Class CollectionBase(Of T)
Implements IList(Of T), ICollection(Of T), IEnumerable(Of T), IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(T)
MindFusion.Diagramming.AnchorPointCollection
MindFusion.Diagramming.ItemCollectionBase(T)

See Also

CollectionBase(T) Members


MindFusion.Diagramming.CollectionBase(T) Members

CollectionBase(T) Members
Constructors Fields Properties Methods
[image]

An implementation of the IList<T> interface.

The following tables list the members exposed by the CollectionBase(T) type.

Protected Constructors

Name | Description
CollectionBase | Initializes a new instance of the CollectionBase<T> class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance.

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the element at the specified index.

Public Methods

Name | Description
Add | Adds an object to the end of the collection.
Clear | Removes all elements from the collection.
Contains | Determines whether an element is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts an element into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.
Sort | Overloaded. Sorts the elements in this collection.

See Also

CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T) Fields

CollectionBase(T) Fields
[image]

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance.

See Also

CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).InnerList Field

CollectionBase(T).InnerList Field
[image]

Gets a List<T> containing the list of elements in the collection instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected List<T> InnerList

Visual Basic [image] Copy Code

Protected InnerList As List(Of T)

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T) Constructor

CollectionBase(T) Constructor
[image]

Initializes a new instance of the CollectionBase<T> class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected CollectionBase<T> ()

Visual Basic [image] Copy Code

Protected Sub New(Of T) ()

See Also

CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T) Methods

CollectionBase(T) Methods
[image]

Public Methods

Name | Description
Add | Adds an object to the end of the collection.
Clear | Removes all elements from the collection.
Contains | Determines whether an element is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.
Insert | Inserts an element into the collection at the specified index.
Remove | Removes the first occurrence of a specific object from the collection.
RemoveAt | Removes the element at the specified index of the collection.
Sort | Overloaded. Sorts the elements in this collection.

See Also

CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Add Method

CollectionBase(T).Add Method
[image]

Adds an object to the end of the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Add (
T item
)

Visual Basic [image] Copy Code

Public MustOverride Sub Add( _
item As T _
)

Parameters

item

The object to be added to the end of the collection.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Clear Method

CollectionBase(T).Clear Method
[image]

Removes all elements from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Clear ()

Visual Basic [image] Copy Code

Public MustOverride Sub Clear ()

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Contains Method

CollectionBase(T).Contains Method
[image]

Determines whether an element is in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
T item
)

Visual Basic [image] Copy Code

Public Function Contains( _
item As T _
) As Boolean

Parameters

item

The object to locate in the collection.

Return Value

true if item is found in the collection; otherwise, false.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).CopyTo Method

CollectionBase(T).CopyTo Method
[image]

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CopyTo (
T[] array,
int arrayIndex
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array() As T, _
arrayIndex As Integer _
)

Parameters

array

The one-dimensional array that is the destination of the elements copied from collection.

arrayIndex

The zero-based index in array at which copying begins.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).GetEnumerator Method

CollectionBase(T).GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerator<T> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of T)

Return Value

An IEnumerator<T> for the collection.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).IndexOf Method

CollectionBase(T).IndexOf Method
[image]

Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
T item
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
item As T _
) As Integer

Parameters

item

The object to locate in the collection.

Return Value

The zero-based index of the first occurrence of item within the entire collection, if found; otherwise, -1.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Insert Method

CollectionBase(T).Insert Method
[image]

Inserts an element into the collection at the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Insert (
int index,
T item
)

Visual Basic [image] Copy Code

Public MustOverride Sub Insert( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index at which item should be inserted.

item

The object to insert.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Remove Method

CollectionBase(T).Remove Method
[image]

Removes the first occurrence of a specific object from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool Remove (
T item
)

Visual Basic [image] Copy Code

Public MustOverride Function Remove( _
item As T _
) As Boolean

Parameters

item

The object to remove from the collection.

Return Value

true if item is successfully removed; otherwise, false.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).RemoveAt Method

CollectionBase(T).RemoveAt Method
[image]

Removes the element at the specified index of the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public MustOverride Sub RemoveAt( _
index As Integer _
)

Parameters

index

The zero-based index of the element to remove.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Sort Method

CollectionBase(T).Sort Method
[image]

Sorts the elements in this collection.

Overload List

Name | Description
CollectionBase(T).Sort (Comparison(T)) | Sorts the elements in this collection using the specified comparison.
CollectionBase(T).Sort (IComparer(T)) | Sorts the elements in this collection using the specified comparer.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Sort Method (Comparison(T))

CollectionBase(T).Sort Method (Comparison(T))
See Also
[image]

Sorts the elements in this collection using the specified comparison.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Sort (
Comparison<T> comparison
)

Visual Basic [image] Copy Code

Public Sub Sort( _
comparison As Comparison(Of T) _
)

Parameters

comparison

The System.Comparison to use when comparing elements.

See Also

Sort Method Overload List
CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Sort Method (IComparer(T))

CollectionBase(T).Sort Method (IComparer(T))
See Also
[image]

Sorts the elements in this collection using the specified comparer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Sort (
IComparer<T> comparer
)

Visual Basic [image] Copy Code

Public Sub Sort( _
comparer As IComparer(Of T) _
)

Parameters

comparer

The IComparer implementation to use when comparing elements.

See Also

Sort Method Overload List
CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T) Properties

CollectionBase(T) Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the element at the specified index.

See Also

CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Count Property

CollectionBase(T).Count Property
[image]

Gets the number of elements actually contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).IsReadOnly Property

CollectionBase(T).IsReadOnly Property
[image]

Gets a value indicating whether the collection is read-only.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsReadOnly { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsReadOnly As Boolean

Property Value

true if the collection is read-only; otherwise, false.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.CollectionBase(T).Item Property

CollectionBase(T).Item Property
[image]

Gets or sets the element at the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public T Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As T

Parameters

index

The zero-based index of the element to get or set.

Property Value

The element at the specified index.

See Also

CollectionBase(T) Members
CollectionBase(T) Class


MindFusion.Diagramming.ColumnStyle Enumeration

ColumnStyle Enumeration
[image]

Specifies how table columns' width is set.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ColumnStyle

Visual Basic [image] Copy Code

Public Enum ColumnStyle

Members

Member name | Description
AutoWidth | The columns' width changes when the table is resized.
FixedWidth | The columns has fixed, unchangeable width.

Remarks

Use the enumeration values to set the behavior of table columns, when the user resizes the table.

See Also


MindFusion.Diagramming.CompatibilityExtensions Class

CompatibilityExtensions Class
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class CompatibilityExtensions

Visual Basic [image] Copy Code

Public NotInheritable Class CompatibilityExtensions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CompatibilityExtensions

See Also

CompatibilityExtensions Members


MindFusion.Diagramming.CompatibilityExtensions Members

CompatibilityExtensions Members
Methods
[image]

The following tables list the members exposed by the CompatibilityExtensions type.

Public Methods

Name | Description
UseMindFusionDiagramming |

See Also

CompatibilityExtensions Class


MindFusion.Diagramming.CompatibilityExtensions Methods

CompatibilityExtensions Methods
[image]

Public Methods

Name | Description
UseMindFusionDiagramming |

See Also

CompatibilityExtensions Class


MindFusion.Diagramming.CompatibilityExtensions.UseMindFusionDiagramming Method

CompatibilityExtensions.UseMindFusionDiagramming Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static MauiAppBuilder UseMindFusionDiagramming (
MauiAppBuilder builder
)

Visual Basic [image] Copy Code

Public Shared Function UseMindFusionDiagramming( _
builder As MauiAppBuilder _
) As MauiAppBuilder

Parameters

builder

Return Value

See Also

CompatibilityExtensions Members
CompatibilityExtensions Class


MindFusion.Diagramming.ConnectionPoint Class

ConnectionPoint Class
Remarks See Also
[image]

This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ConnectionPoint

Visual Basic [image] Copy Code

Public Class ConnectionPoint

Remarks

If custom nodes should store additional information about their connections, inherit the ConnectionPoint class, add the necessary members and return an instance of this class from the CreateConnectionPoint override. For example, TreeViewNode uses TreeViewConnectionPoint objects to store reference to the item associated with the connection.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ConnectionPoint
MindFusion.Diagramming.TreeViewConnectionPoint
MindFusion.Diagramming.Interaction.VirtualConnectionPoint

See Also

ConnectionPoint Members


MindFusion.Diagramming.ConnectionPoint Members

ConnectionPoint Members
Constructors Properties Methods
[image]

This class represents a connection between an edge and a node in a graph. It decouples the DiagramLink class from the DiagramNode class, allowing edges to connect different types of nodes without knowing anything of their implementation details. Each DiagramLink object contains two ConnectionPoint instances describing the connections at both ends of the link.

The following tables list the members exposed by the ConnectionPoint type.

Public Constructors

Name | Description
ConnectionPoint | Overloaded. Initializes a new instance of the ConnectionPoint class.

Public Properties

Name | Description
Anchor | Gets or sets the anchor point associated with the connection point.
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.
Link | Gets the link associated with this connection point.
Node | Gets the node associated with this connection point.

Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node.
AlignToNode | Aligns the specified point to the nearest anchor point of the connected node.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.
GetAnchorPos | Overloaded. Returns a point from the node's associated anchor pattern.
GetEndPoint | Calculates the coordinates of the this connection point expressed in document coordinates.
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point.
LinkChanges | Checks whether the relationship represented by the associated link would change if the link is attached to the specified node at the specified point.
NearestAnchorPoint | Returns the anchor point closest to the specified point from the node's associated anchor pattern.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
PositionFromNode | Overloaded. Returns the position of the connection point.
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node.

Protected Methods

Name | Description
GetNearestBorderPoint | Returns the nearest point lying on the node border.
UpdateFromPoint | Updates the connection state according to the specified point, without changing the related node.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Constructor

ConnectionPoint Constructor
[image]

Initializes a new instance of the ConnectionPoint class.

Overload List

Name | Description
ConnectionPoint () | Initializes a new instance of the ConnectionPoint class.
ConnectionPoint (DiagramNode, DiagramLink, Boolean) | Initializes a new instance of the ConnectionPoint class between the specified node and link.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Constructor ()

ConnectionPoint Constructor ()
See Also
[image]

Initializes a new instance of the ConnectionPoint class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected ConnectionPoint ()

Visual Basic [image] Copy Code

Protected Sub New ()

Remarks

This constructor is used only during deserialization.

See Also

ConnectionPoint Constructor Overload List
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Constructor (DiagramNode, DiagramLink, Boolean)

ConnectionPoint Constructor (DiagramNode, DiagramLink, Boolean)
See Also
[image]

Initializes a new instance of the ConnectionPoint class between the specified node and link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ConnectionPoint (
DiagramNode node,
DiagramLink link,
bool incoming
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
link As DiagramLink, _
incoming As Boolean _
)

Parameters

node

The node whose connection to a link is managed by this ConnectionPoint.

link

The link whose connection to a node is managed by this ConnectionPoint.

incoming

Specifies which end of the link is represented by this ConnectionPoint.

See Also

ConnectionPoint Constructor Overload List
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Methods

ConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | Adds the link associated with this connection point to the associated node.
AlignToNode | Aligns the specified point to the nearest anchor point of the connected node.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.
GetAnchorPos | Overloaded. Returns a point from the node's associated anchor pattern.
GetEndPoint | Calculates the coordinates of the this connection point expressed in document coordinates.
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node.
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point.
LinkChanges | Checks whether the relationship represented by the associated link would change if the link is attached to the specified node at the specified point.
NearestAnchorPoint | Returns the anchor point closest to the specified point from the node's associated anchor pattern.
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.
PositionFromNode | Overloaded. Returns the position of the connection point.
RemoveLinkFromNode | Removes the link associated with this connection point from the associated node.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node.

Protected Methods

Name | Description
GetNearestBorderPoint | Returns the nearest point lying on the node border.
UpdateFromPoint | Updates the connection state according to the specified point, without changing the related node.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.AddLinkToNode Method

ConnectionPoint.AddLinkToNode Method
[image]

Adds the link associated with this connection point to the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overridable Sub AddLinkToNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.AlignToNode Method

ConnectionPoint.AlignToNode Method
[image]

Aligns the specified point to the nearest anchor point of the connected node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void AlignToNode (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Sub AlignToNode( _
point As Point _
)

Parameters

point

The point to align.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.CalculateIntersections Method

ConnectionPoint.CalculateIntersections Method
[image]

Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool CalculateIntersections ()

Visual Basic [image] Copy Code

Public Overridable Function CalculateIntersections () As Boolean

Return Value

true to align the link end; otherwise false.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.CanMoveLink Method

ConnectionPoint.CanMoveLink Method
[image]

Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool CanMoveLink (
Point pt
)

Visual Basic [image] Copy Code

Public Overridable Function CanMoveLink( _
pt As Point _
) As Boolean

Parameters

pt

The Point to check for validity.

Return Value

true if the specified point represents a valid location for the connection point; otherwise, false.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetAnchorPos Method

ConnectionPoint.GetAnchorPos Method
[image]

Returns a point from the node's associated anchor pattern.

Overload List

Name | Description
ConnectionPoint.GetAnchorPos (Int32) | Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.
ConnectionPoint.GetAnchorPos (Int32, Point@) | Retrieves the point from the node's associated anchor pattern (if any) with the specified index.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetAnchorPos Method (Int32)

ConnectionPoint.GetAnchorPos Method (Int32)
See Also
[image]

Returns the point from the node's associated anchor pattern (if any) with the specified index or the link's initial point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Point GetAnchorPos (
int anchorIdx
)

Visual Basic [image] Copy Code

Public Overridable Function GetAnchorPos( _
anchorIdx As Integer _
) As Point

Parameters

anchorIdx

Return Value

See Also

GetAnchorPos Method Overload List
ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetAnchorPos Method (Int32, Point@)

ConnectionPoint.GetAnchorPos Method (Int32, Point@)
See Also
[image]

Retrieves the point from the node's associated anchor pattern (if any) with the specified index.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool GetAnchorPos (
int anchorIdx,
ref Point point
)

Visual Basic [image] Copy Code

Public Overridable Function GetAnchorPos( _
anchorIdx As Integer, _
ByRef point As Point _
) As Boolean

Parameters

anchorIdx

point

Return Value

See Also

GetAnchorPos Method Overload List
ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetEndPoint Method

ConnectionPoint.GetEndPoint Method
[image]

Calculates the coordinates of the this connection point expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Point GetEndPoint ()

Visual Basic [image] Copy Code

Public Overridable Function GetEndPoint () As Point

Return Value

A Point object.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetInitialPoint Method

ConnectionPoint.GetInitialPoint Method
[image]

Returns a point (usually the center of the bounding rectangle) contained within the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Point GetInitialPoint ()

Visual Basic [image] Copy Code

Public Overridable Function GetInitialPoint () As Point

Return Value

A Point object.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetIntersection Method

ConnectionPoint.GetIntersection Method
[image]

Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Point GetIntersection (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Overridable Function GetIntersection( _
pt1 As Point, _
pt2 As Point _
) As Point

Parameters

pt1

pt2

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetNearestBorderPoint Method

ConnectionPoint.GetNearestBorderPoint Method
[image]

Returns the nearest point lying on the node border.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual Point GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overridable Function GetNearestBorderPoint( _
point As Point _
) As Point

Parameters

point

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.GetNodeRect Method

ConnectionPoint.GetNodeRect Method
[image]

Returns the bounding rectangle of the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Rect GetNodeRect (
bool rotated
)

Visual Basic [image] Copy Code

Public Overridable Function GetNodeRect( _
rotated As Boolean _
) As Rect

Parameters

rotated

Return Value

A Rectangle object.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.LinkChanges Method

ConnectionPoint.LinkChanges Method
[image]

Checks whether the relationship represented by the associated link would change if the link is attached to the specified node at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool LinkChanges (
DiagramItem item,
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function LinkChanges( _
item As DiagramItem, _
point As Point _
) As Boolean

Parameters

item

point

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.NearestAnchorPoint Method

ConnectionPoint.NearestAnchorPoint Method
[image]

Returns the anchor point closest to the specified point from the node's associated anchor pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Tuple<Point, Int32, Int32> NearestAnchorPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function NearestAnchorPoint( _
point As Point _
) As Tuple(Of Point, Int32, Int32)

Parameters

point

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.NodesIntersect Method

ConnectionPoint.NodesIntersect Method
[image]

Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool NodesIntersect (
ConnectionPoint connectionPoint
)

Visual Basic [image] Copy Code

Public Function NodesIntersect( _
connectionPoint As ConnectionPoint _
) As Boolean

Parameters

connectionPoint

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.PositionFromNode Method

ConnectionPoint.PositionFromNode Method
[image]

Returns the position of the connection point.

Overload List

Name | Description
ConnectionPoint.PositionFromNode () | Returns the position of the connection point.
ConnectionPoint.PositionFromNode (Int32) | Returns the position of the connection point.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.PositionFromNode Method ()

ConnectionPoint.PositionFromNode Method ()
See Also
[image]

Returns the position of the connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point PositionFromNode ()

Visual Basic [image] Copy Code

Public Function PositionFromNode () As Point

Return Value

A Point object.

See Also

PositionFromNode Method Overload List
ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.PositionFromNode Method (Int32)

ConnectionPoint.PositionFromNode Method (Int32)
See Also
[image]

Returns the position of the connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point PositionFromNode (
int anchorIndex
)

Visual Basic [image] Copy Code

Public Function PositionFromNode( _
anchorIndex As Integer _
) As Point

Parameters

anchorIndex

Return Value

A Point object.

See Also

PositionFromNode Method Overload List
ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.RemoveLinkFromNode Method

ConnectionPoint.RemoveLinkFromNode Method
[image]

Removes the link associated with this connection point from the associated node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overridable Sub RemoveLinkFromNode ()

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.SameNode Method

ConnectionPoint.SameNode Method
[image]

Checks whether the current connection point and the specified connection point are associated with the same node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool SameNode (
ConnectionPoint otherConnectionPoint
)

Visual Basic [image] Copy Code

Public Overridable Function SameNode( _
otherConnectionPoint As ConnectionPoint _
) As Boolean

Parameters

otherConnectionPoint

Return Value

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.UpdateFromPoint Method

ConnectionPoint.UpdateFromPoint Method
[image]

Updates the connection state according to the specified point, without changing the related node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void UpdateFromPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overridable Sub UpdateFromPoint( _
point As Point _
)

Parameters

point

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint Properties

ConnectionPoint Properties
[image]

Public Properties

Name | Description
Anchor | Gets or sets the anchor point associated with the connection point.
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.
Link | Gets the link associated with this connection point.
Node | Gets the node associated with this connection point.

See Also

ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Anchor Property

ConnectionPoint.Anchor Property
[image]

Gets or sets the anchor point associated with the connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Anchor { get; set; }

Visual Basic [image] Copy Code

Public Property Anchor As Integer

Property Value

An integer value.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Incoming Property

ConnectionPoint.Incoming Property
[image]

Gets a flag indicating whether this connection point is at the origin or the destination of the associated link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool Incoming { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Incoming As Boolean

Property Value

A boolean value.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Link Property

ConnectionPoint.Link Property
[image]

Gets the link associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramLink Link { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Link As DiagramLink

Property Value

A instance of the DiagramLink class.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Node Property

ConnectionPoint.Node Property
[image]

Gets the node associated with this connection point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramNode Node { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property Node As DiagramNode

Property Value

A instance of the DiagramNode class.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.ConnectionPoint.Row Property

ConnectionPoint.Row Property
[image]

Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual int Row { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Row As Integer

Property Value

An integer value.

See Also

ConnectionPoint Members
ConnectionPoint Class


MindFusion.Diagramming.Constants Class

Constants Class
[image]

Contains various global constants, also provides measure unit independent constants.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Constants

Visual Basic [image] Copy Code

Public NotInheritable Class Constants

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Constants

See Also

Constants Members


MindFusion.Diagramming.Constants Members

Constants Members
Fields Methods
[image]

Contains various global constants, also provides measure unit independent constants.

The following tables list the members exposed by the Constants type.

Public Fields

Name | Description
NoAnchorPattern | A constant indicating no anchor pattern during binary serialization.

Public Methods

Name | Description
GetAutoScroll | Gets the number of units to scroll the control during autoscrolling operation.
GetContainerFolderPadding | Gets the padding around the folding button of a container node.
GetExpandIconSize | Gets the size of the expand/collapse manipulator icon.
GetFitTextStep | Gets a value used when fitting the size of a node to its contained text.
GetHalfInch | Gets the size of a half inch.
GetInflation | Gets a relax value used when testing object intersections.
GetLineHitTest | Gets a value specifying relative distance from an arrow used during hit-testing operations, in millimeters.
GetMarkSize | Gets the size of an anchor point mark, in millimeters
GetMillimeter | Gets the size of one millimeter.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetMinItemSize | Gets the minimum size for a diagram node that can be achieved interactively.
GetPixel | Overloaded. Gets the size of one pixel.
GetReflHth | Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetRotationHandleOffset | Gets the rotation handle offset, in millimeters.
GetRoundRectArc | Gets the radius of the arc of the rounded rectangle node shape.
GetRouteGridSize | Gets the default size of the link routing grid.
GetScrollButtonSize | Gets the size of scrollbar arrow buttons.
GetScrollerWidth | Gets the width of the scroller manipulator icon.
GetTableHeaderOffset | Gets the width of a header row icon.
GetTouchRadius | Gets the radius of the finger touch, in millimeters.

See Also

Constants Class


MindFusion.Diagramming.Constants Fields

Constants Fields
[image]

Public Fields

Name | Description
NoAnchorPattern | A constant indicating no anchor pattern during binary serialization.

See Also

Constants Class


MindFusion.Diagramming.Constants.NoAnchorPattern Field

Constants.NoAnchorPattern Field
[image]

A constant indicating no anchor pattern during binary serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int NoAnchorPattern

Visual Basic [image] Copy Code

Public Shared NoAnchorPattern As Integer

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants Methods

Constants Methods
[image]

Public Methods

Name | Description
GetAutoScroll | Gets the number of units to scroll the control during autoscrolling operation.
GetContainerFolderPadding | Gets the padding around the folding button of a container node.
GetExpandIconSize | Gets the size of the expand/collapse manipulator icon.
GetFitTextStep | Gets a value used when fitting the size of a node to its contained text.
GetHalfInch | Gets the size of a half inch.
GetInflation | Gets a relax value used when testing object intersections.
GetLineHitTest | Gets a value specifying relative distance from an arrow used during hit-testing operations, in millimeters.
GetMarkSize | Gets the size of an anchor point mark, in millimeters
GetMillimeter | Gets the size of one millimeter.
GetMinArrowheadSize | Gets the minimum allowed size of an arrowhead.
GetMinItemSize | Gets the minimum size for a diagram node that can be achieved interactively.
GetPixel | Overloaded. Gets the size of one pixel.
GetReflHth | Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.
GetReflWth2 | Gets the initial distance between adjacent control points of a reflexive link along the X-axis.
GetRotationHandleOffset | Gets the rotation handle offset, in millimeters.
GetRoundRectArc | Gets the radius of the arc of the rounded rectangle node shape.
GetRouteGridSize | Gets the default size of the link routing grid.
GetScrollButtonSize | Gets the size of scrollbar arrow buttons.
GetScrollerWidth | Gets the width of the scroller manipulator icon.
GetTableHeaderOffset | Gets the width of a header row icon.
GetTouchRadius | Gets the radius of the finger touch, in millimeters.

See Also

Constants Class


MindFusion.Diagramming.Constants.GetAutoScroll Method

Constants.GetAutoScroll Method
[image]

Gets the number of units to scroll the control during autoscrolling operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetAutoScroll (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetAutoScroll( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

The number of units to add to or remove from the scroll position.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetContainerFolderPadding Method

Constants.GetContainerFolderPadding Method
[image]

Gets the padding around the folding button of a container node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetContainerFolderPadding (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetContainerFolderPadding( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

The padding space to leave around fold buttons, expressed in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetExpandIconSize Method

Constants.GetExpandIconSize Method
[image]

Gets the size of the expand/collapse manipulator icon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetExpandIconSize (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetExpandIconSize( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

The +/- icon size, expressed in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetFitTextStep Method

Constants.GetFitTextStep Method
[image]

Gets a value used when fitting the size of a node to its contained text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetFitTextStep (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetFitTextStep( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

The step size, expressed in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetHalfInch Method

Constants.GetHalfInch Method
[image]

Gets the size of a half inch.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetHalfInch (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetHalfInch( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

Half of an inch in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetInflation Method

Constants.GetInflation Method
[image]

Gets a relax value used when testing object intersections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetInflation (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetInflation( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetLineHitTest Method

Constants.GetLineHitTest Method
[image]

Gets a value specifying relative distance from an arrow used during hit-testing operations, in millimeters.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetLineHitTest ()

Visual Basic [image] Copy Code

Public Shared Function GetLineHitTest () As Double

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetMarkSize Method

Constants.GetMarkSize Method
[image]

Gets the size of an anchor point mark, in millimeters

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetMarkSize ()

Visual Basic [image] Copy Code

Public Shared Function GetMarkSize () As Double

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetMillimeter Method

Constants.GetMillimeter Method
[image]

Gets the size of one millimeter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetMillimeter (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetMillimeter( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

The size of a millimeter measured in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetMinArrowheadSize Method

Constants.GetMinArrowheadSize Method
[image]

Gets the minimum allowed size of an arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetMinArrowheadSize (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetMinArrowheadSize( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetMinItemSize Method

Constants.GetMinItemSize Method
[image]

Gets the minimum size for a diagram node that can be achieved interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetMinItemSize (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetMinItemSize( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetPixel Method

Constants.GetPixel Method
[image]

Gets the size of one pixel.

Overload List

Name | Description
Constants.GetPixel (Diagram) | Gets the size of one pixel expressed in the specified diagram's units of measure.
Constants.GetPixel (MeasureUnit) | Gets the size of one pixel.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetPixel Method (Diagram)

Constants.GetPixel Method (Diagram)
See Also
[image]

Gets the size of one pixel expressed in the specified diagram's units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetPixel (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Shared Function GetPixel( _
diagram As Diagram _
) As Double

Parameters

diagram

An instance of the Diagram class.

Return Value

See Also

GetPixel Method Overload List
Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetPixel Method (MeasureUnit)

Constants.GetPixel Method (MeasureUnit)
See Also
[image]

Gets the size of one pixel.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetPixel (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetPixel( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

See Also

GetPixel Method Overload List
Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetReflHth Method

Constants.GetReflHth Method
[image]

Gets the initial distance between adjacent control points of a reflexive arrow along the Y-axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetReflHth (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetReflHth( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetReflWth2 Method

Constants.GetReflWth2 Method
[image]

Gets the initial distance between adjacent control points of a reflexive link along the X-axis.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetReflWth2 (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetReflWth2( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetRotationHandleOffset Method

Constants.GetRotationHandleOffset Method
[image]

Gets the rotation handle offset, in millimeters.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetRotationHandleOffset ()

Visual Basic [image] Copy Code

Public Shared Function GetRotationHandleOffset () As Double

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetRoundRectArc Method

Constants.GetRoundRectArc Method
[image]

Gets the radius of the arc of the rounded rectangle node shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetRoundRectArc (
MeasureUnit unit,
double factor
)

Visual Basic [image] Copy Code

Public Shared Function GetRoundRectArc( _
unit As MeasureUnit, _
factor As Double _
) As Double

Parameters

unit

A MeasureUnit instance.

factor

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetRouteGridSize Method

Constants.GetRouteGridSize Method
[image]

Gets the default size of the link routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetRouteGridSize (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetRouteGridSize( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetScrollButtonSize Method

Constants.GetScrollButtonSize Method
[image]

Gets the size of scrollbar arrow buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Size GetScrollButtonSize (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetScrollButtonSize( _
unit As MeasureUnit _
) As Size

Parameters

unit

A MeasureUnit instance.

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetScrollerWidth Method

Constants.GetScrollerWidth Method
[image]

Gets the width of the scroller manipulator icon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetScrollerWidth (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetScrollerWidth( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetTableHeaderOffset Method

Constants.GetTableHeaderOffset Method
[image]

Gets the width of a header row icon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetTableHeaderOffset (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shared Function GetTableHeaderOffset( _
unit As MeasureUnit _
) As Double

Parameters

unit

A MeasureUnit instance.

Return Value

The offset of header rows, expressed in the specified unit.

See Also

Constants Members
Constants Class


MindFusion.Diagramming.Constants.GetTouchRadius Method

Constants.GetTouchRadius Method
[image]

Gets the radius of the finger touch, in millimeters.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double GetTouchRadius ()

Visual Basic [image] Copy Code

Public Shared Function GetTouchRadius () As Double

Return Value

See Also

Constants Members
Constants Class


MindFusion.Diagramming.ContainerChildEventArgs Class

ContainerChildEventArgs Class
[image]

Contains arguments passed to events related to container children.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerChildEventArgs : NodeEventArgs

Visual Basic [image] Copy Code

Public Class ContainerChildEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.ContainerChildEventArgs

See Also

ContainerChildEventArgs Members


MindFusion.Diagramming.ContainerChildEventArgs Members

ContainerChildEventArgs Members
Constructors Properties Methods
[image]

Contains arguments passed to events related to container children.

The following tables list the members exposed by the ContainerChildEventArgs type.

Public Constructors

Name | Description
ContainerChildEventArgs | Initializes a new instance of the ContainerChildEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Container | Gets the container related to the event.
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)
Position | Gets the location related to the event. (Inherited from NodeEventArgs.)

Public Methods

Name | Description
ToString | NodeEventArgs.ToString override.

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs Constructor

ContainerChildEventArgs Constructor
[image]

Initializes a new instance of the ContainerChildEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerChildEventArgs (
ContainerNode container,
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
container As ContainerNode, _
node As DiagramNode _
)

Parameters

container

A ContainerNode object related to the event.

node

A DiagramNode added to or removed from the container.

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs Methods

ContainerChildEventArgs Methods
[image]

Public Methods

Name | Description
ToString | NodeEventArgs.ToString override.

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs.ToString Method

ContainerChildEventArgs.ToString Method
[image]

NodeEventArgs.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

ContainerChildEventArgs Members
ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs Properties

ContainerChildEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Container | Gets the container related to the event.
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)
Position | Gets the location related to the event. (Inherited from NodeEventArgs.)

See Also

ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerChildEventArgs.Container Property

ContainerChildEventArgs.Container Property
[image]

Gets the container related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode Container { get; set; }

Visual Basic [image] Copy Code

Public Property Container As ContainerNode

Property Value

An instance of the ContainerNode class.

See Also

ContainerChildEventArgs Members
ContainerChildEventArgs Class


MindFusion.Diagramming.ContainerNode Class

ContainerNode Class
Remarks See Also
[image]

Implements nodes that can contain other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class ContainerNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

Users can drag nodes into a container interactively. When a dragged node is over a container, the container frame is painted using the HighlightPen property to indicate that the node would be added to the container.

Use the Add method to add a node to container programmatically. Use the Remove method to remove a node from the container. The GetContainer static method returns the container that contains a node.

AutoShrink specifies whether the size of a container should shrink when a node is removed from it. The container node will not shrink to a size smaller than MinimumSize, even if it does not contain any items.

A container node can be folded and unfolded, either interactively or programmatically, as specified through the Foldable and Folded properties. When a container is folded, it occupies a minimal area and its child nodes are hidden. You can get the original size of a folded container using the UnfoldedSize property.

The Caption property specifies the caption text of a container node, and CaptionBrush specifies its color. Use the CaptionFormat property to define the alignment and position of the caption text. The height of the caption area of a container can be set using the CaptionHeight property.

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ContainerNode

See Also

ContainerNode Members


MindFusion.Diagramming.ContainerNode Members

ContainerNode Members
Constructors Fields Properties Methods
[image]

Implements nodes that can contain other nodes.

The following tables list the members exposed by the ContainerNode type.

Public Constructors

Name | Description
ContainerNode | Overloaded. Initializes a new instance of the ContainerNode class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowAddChildren | Gets or sets a value indicating whether child nodes can be added interactively to this container.
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AllowRemoveChildren | Gets or sets a value indicating whether child nodes can be removed interactively from this container.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
AutoGrow | Gets or sets a value indicating whether the container should grow in size when nodes are added to it.
AutoShrink | Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the container caption text.
CaptionBrush | Gets or sets the brush used to paint the container caption.
CaptionFormat | Gets or sets the caption alignment and format.
CaptionHeight | Gets or sets the height of the container's caption area.
ClipChildren | Gets or sets a value indicating whether child items should be clipped by container boundaries.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveCaptionBrush | Gets the effective caption brush of the container.
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Foldable | Gets or sets a value indicating whether the user is allowed to fold this container.
Folded | Gets or sets a value indicating whether this container is folded.
FoldedSize | Gets or sets the size of the container when folded.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightPen | Gets or sets the Pen used to draw the container frame lines when an item is dragged over the container.
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Margin | Gets or sets how much space should be left between contained nodes and the container borders.
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
MinimumSize | Gets or sets the minimum size of the container.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the container's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UnfoldedSize | Returns the original size of a folded container.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Add | Adds a node to this container.
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
ContainsRecursively | Determines whether this container contains the specified node, either directly or recursively through other containers.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramNode.Draw override. Draws the container on the specified IGraphics surface.
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override. Draws the container on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetContainer | Retrieves the container node (if any) the specified node belongs to.
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | DiagramItem.HitTest override.
HitTestHandle | DiagramNode.HitTestHandle override.
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
OnLoad | DiagramItem.OnLoad override.
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Remove | Removes a node from this container.
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
UpdateBounds | Overloaded. Updates the container bounds to fit its contents.
VisitNodes | Visits the diagram nodes in reverse Z order.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified.
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnPropertyChanged | DiagramNode.OnPropertyChanged override.
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor

ContainerNode Constructor
[image]

Initializes a new instance of the ContainerNode class.

Overload List

Name | Description
ContainerNode () | Initializes a new instance of the ContainerNode class.
ContainerNode (ContainerNode) | Initializes a new instance of the ContainerNode class using the specified node as a prototype.
ContainerNode (Diagram) | Initializes a new instance of the ContainerNode class with the default values of the specified diagram.

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor ()

ContainerNode Constructor ()
See Also
[image]

Initializes a new instance of the ContainerNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ContainerNode Constructor Overload List
ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor (ContainerNode)

ContainerNode Constructor (ContainerNode)
See Also
[image]

Initializes a new instance of the ContainerNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode (
ContainerNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As ContainerNode _
)

Parameters

prototype

An instance of the ContainerNode class.

See Also

ContainerNode Constructor Overload List
ContainerNode Class


MindFusion.Diagramming.ContainerNode Constructor (Diagram)

ContainerNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the ContainerNode class with the default values of the specified diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

An instance of the Diagram class.

See Also

ContainerNode Constructor Overload List
ContainerNode Class


MindFusion.Diagramming.ContainerNode Methods

ContainerNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
Add | Adds a node to this container.
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
ContainsRecursively | Determines whether this container contains the specified node, either directly or recursively through other containers.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramNode.Draw override. Draws the container on the specified IGraphics surface.
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | DiagramNode.DrawLocal override. Draws the container on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetContainer | Retrieves the container node (if any) the specified node belongs to.
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | DiagramItem.HitTest override.
HitTestHandle | DiagramNode.HitTestHandle override.
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
OnLoad | DiagramItem.OnLoad override.
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
Remove | Removes a node from this container.
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
UpdateBounds | Overloaded. Updates the container bounds to fit its contents.
VisitNodes | Visits the diagram nodes in reverse Z order.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified.
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnPropertyChanged | DiagramNode.OnPropertyChanged override.
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode.Add Method

ContainerNode.Add Method
[image]

Adds a node to this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Add (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub Add( _
node As DiagramNode _
)

Parameters

node

The DiagramNode that should be added to the container.

Remarks

If the container bounds do not include the specified node bounds, the container will grow automatically to accommodate the new node.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.ContainsRecursively Method

ContainerNode.ContainsRecursively Method
[image]

Determines whether this container contains the specified node, either directly or recursively through other containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ContainsRecursively (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function ContainsRecursively( _
node As DiagramNode _
) As Boolean

Parameters

node

The DiagramNode to check.

Return Value

true if this container contains the node; otherwise, false.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.CreateProperties Method

ContainerNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

An instance of the DiagramItemProperties class.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Draw Method

ContainerNode.Draw Method
[image]

DiagramNode.Draw override. Draws the container on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the node on.

options

Provides options for the drawing operation.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.DrawLocal Method

ContainerNode.DrawLocal Method
[image]

DiagramNode.DrawLocal override. Draws the container on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.GetContainer Method

ContainerNode.GetContainer Method
[image]

Retrieves the container node (if any) the specified node belongs to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ContainerNode GetContainer (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Shared Function GetContainer( _
node As DiagramNode _
) As ContainerNode

Parameters

node

The DiagramNode whose container you need to find.

Return Value

A ContainerNode that contains the specified node, or null if the node is not contained.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.HitTest Method

ContainerNode.HitTest Method
[image]

DiagramItem.HitTest override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override DiagramItem HitTest (
Point point,
double threshold,
bool onlyNodes,
bool onlyInteractive,
bool includeHandles
)

Visual Basic [image] Copy Code

Public Overrides Function HitTest( _
point As Point, _
threshold As Double, _
onlyNodes As Boolean, _
onlyInteractive As Boolean, _
includeHandles As Boolean _
) As DiagramItem

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

onlyNodes

true to exclude child links from the search.

onlyInteractive

true to exclude locked items from the search.

includeHandles

true to hit-test modification handles; otherwise, false.

Return Value

The item that contains the specified point.

Remarks

This method performs recursive search if items contain child items.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.HitTestHandle Method

ContainerNode.HitTestHandle Method
[image]

DiagramNode.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point,
double radius
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point, _
radius As Double _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

radius

The touch radius.

Return Value

An AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.LoadFromJson Method

ContainerNode.LoadFromJson Method
[image]

Loads the item content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the item's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.LoadFromXml Method

ContainerNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnChildModified Method

ContainerNode.OnChildModified Method
[image]

Called when a group child node has been modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnChildModified (
DiagramNode node,
AdjustmentHandles handle
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnChildModified( _
node As DiagramNode, _
handle As AdjustmentHandles _
)

Parameters

node

The DiagramNode that has been moved or resized.

handle

The adjustment handle used to modify the node.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnDragOut Method

ContainerNode.OnDragOut Method
[image]

Invoked when a diagram item is being dragged out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnDragOut (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Sub OnDragOut( _
item As DiagramItem _
)

Parameters

item

The DiagramItem being dragged.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnDragOver Method

ContainerNode.OnDragOver Method
[image]

Invoked when a diagram item is being dragged over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool OnDragOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Function OnDragOver( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem being dragged.

Return Value

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnDropOver Method

ContainerNode.OnDropOver Method
[image]

Invoked when a diagram item is dropped over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool OnDropOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overrides Function OnDropOver( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem being dragged.

Return Value

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnLoad Method

ContainerNode.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnLoad ()

Visual Basic [image] Copy Code

Public Overrides Sub OnLoad ()

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.OnPropertyChanged Method

ContainerNode.OnPropertyChanged Method
[image]

DiagramNode.OnPropertyChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnPropertyChanged (
string propertyName = null
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPropertyChanged( _
Optional propertyName As String = Nothing _
)

Parameters

propertyName
Optional.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Remove Method

ContainerNode.Remove Method
[image]

Removes a node from this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Remove (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub Remove( _
node As DiagramNode _
)

Parameters

node

The DiagramNode that should be removed from the container.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.RestoreProperties Method

ContainerNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.SaveProperties Method

ContainerNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.SaveToJson Method

ContainerNode.SaveToJson Method
[image]

Saves the item content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the item's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.SaveToXml Method

ContainerNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToXml( _
element As XElement, _
context As XmlPersistContext _
) As Task

Parameters

element

An XElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.ScaleElements Method

ContainerNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.UpdateBounds Method

ContainerNode.UpdateBounds Method
[image]

Updates the container bounds to fit its contents.

Overload List

Name | Description
ContainerNode.UpdateBounds () | Updates the container bounds to fit its contents.
ContainerNode.UpdateBounds (Boolean) | Updates the container bounds to fit its contents.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.UpdateBounds Method ()

ContainerNode.UpdateBounds Method ()
See Also
[image]

Updates the container bounds to fit its contents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateBounds ()

Visual Basic [image] Copy Code

Public Sub UpdateBounds ()

See Also

UpdateBounds Method Overload List
ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.UpdateBounds Method (Boolean)

ContainerNode.UpdateBounds Method (Boolean)
See Also
[image]

Updates the container bounds to fit its contents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateBounds (
bool includeLinks
)

Visual Basic [image] Copy Code

Public Sub UpdateBounds( _
includeLinks As Boolean _
)

Parameters

includeLinks

Specifies whether the bounding rectangle should contain the control points of links whose ends are both child nodes of this container.

See Also

UpdateBounds Method Overload List
ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.VisitNodes Method

ContainerNode.VisitNodes Method
[image]

Visits the diagram nodes in reverse Z order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool VisitNodes (
Point point,
VisitNode visitNode,
DiagramItem relatedItem
)

Visual Basic [image] Copy Code

Public Function VisitNodes( _
point As Point, _
visitNode As VisitNode, _
relatedItem As DiagramItem _
) As Boolean

Parameters

point

Location of the nodes that should be visited.

visitNode

An operation to be performed on the nodes.

relatedItem

Parameter to pass to the visitNode operation.

Return Value

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode Properties

ContainerNode Properties
[image]

Public Properties

Name | Description
AllowAddChildren | Gets or sets a value indicating whether child nodes can be added interactively to this container.
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AllowRemoveChildren | Gets or sets a value indicating whether child nodes can be removed interactively from this container.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
AutoGrow | Gets or sets a value indicating whether the container should grow in size when nodes are added to it.
AutoShrink | Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the container caption text.
CaptionBrush | Gets or sets the brush used to paint the container caption.
CaptionFormat | Gets or sets the caption alignment and format.
CaptionHeight | Gets or sets the height of the container's caption area.
ClipChildren | Gets or sets a value indicating whether child items should be clipped by container boundaries.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveCaptionBrush | Gets the effective caption brush of the container.
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Foldable | Gets or sets a value indicating whether the user is allowed to fold this container.
Folded | Gets or sets a value indicating whether this container is folded.
FoldedSize | Gets or sets the size of the container when folded.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightPen | Gets or sets the Pen used to draw the container frame lines when an item is dragged over the container.
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Margin | Gets or sets how much space should be left between contained nodes and the container borders.
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
MinimumSize | Gets or sets the minimum size of the container.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the container's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
UnfoldedSize | Returns the original size of a folded container.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

ContainerNode Class


MindFusion.Diagramming.ContainerNode.AllowAddChildren Property

ContainerNode.AllowAddChildren Property
[image]

Gets or sets a value indicating whether child nodes can be added interactively to this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowAddChildren { get; set; }

Visual Basic [image] Copy Code

Public Property AllowAddChildren As Boolean

Property Value

true to allow adding child nodes, otherwise false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.AllowRemoveChildren Property

ContainerNode.AllowRemoveChildren Property
[image]

Gets or sets a value indicating whether child nodes can be removed interactively from this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowRemoveChildren { get; set; }

Visual Basic [image] Copy Code

Public Property AllowRemoveChildren As Boolean

Property Value

true to allow removing child nodes, otherwise false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.AutoGrow Property

ContainerNode.AutoGrow Property
[image]

Gets or sets a value indicating whether the container should grow in size when nodes are added to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoGrow { get; set; }

Visual Basic [image] Copy Code

Public Property AutoGrow As Boolean

Property Value

true to grow container's size automatically, or false otherwise. The default value is true.

Remarks

When AutoGrow is enabled, the container size will grow to include newly added nodes when they wouldn't fit in its current size. The new Bounds of the container is set to the union of bounding rectangles of all child nodes inflated by Margin.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.AutoShrink Property

ContainerNode.AutoShrink Property
[image]

Gets or sets a value indicating whether the container should shrink in size when nodes are removed from it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoShrink { get; set; }

Visual Basic [image] Copy Code

Public Property AutoShrink As Boolean

Property Value

true if the container should shrink automatically; otherwise, false. The default is false.

Remarks

The container won't shrink to a size smaller than MinimumSize.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Caption Property

ContainerNode.Caption Property
[image]

Gets or sets the container caption text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

A string containing the container's caption text.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.CaptionBrush Property

ContainerNode.CaptionBrush Property
[image]

Gets or sets the brush used to paint the container caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CaptionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.CaptionFormat Property

ContainerNode.CaptionFormat Property
[image]

Gets or sets the caption alignment and format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat CaptionFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionFormat As StringFormat

Property Value

An instance of the StringFormat class.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.CaptionHeight Property

ContainerNode.CaptionHeight Property
[image]

Gets or sets the height of the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Double

Property Value

A string value specifying the container's caption text. Initialized with the value of ContainerCaptionHeight.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.ClipChildren Property

ContainerNode.ClipChildren Property
[image]

Gets or sets a value indicating whether child items should be clipped by container boundaries.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ClipChildren { get; set; }

Visual Basic [image] Copy Code

Public Property ClipChildren As Boolean

Property Value

true to clip child items; otherwise, false. The default value is true.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.EffectiveCaptionBrush Property

ContainerNode.EffectiveCaptionBrush Property
[image]

Gets the effective caption brush of the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveCaptionBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveCaptionBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Foldable Property

ContainerNode.Foldable Property
[image]

Gets or sets a value indicating whether the user is allowed to fold this container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Foldable { get; set; }

Visual Basic [image] Copy Code

Public Property Foldable As Boolean

Property Value

true if the container can be folded; otherwise, false. Initialized with the value of ContainersFoldable.

Remarks

A foldable container can be folded and unfolded by clicking the up/down arrow displayed in the caption area.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Folded Property

ContainerNode.Folded Property
[image]

Gets or sets a value indicating whether this container is folded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Folded { get; set; }

Visual Basic [image] Copy Code

Public Property Folded As Boolean

Property Value

true if the container is folded; otherwise, false. The default is false.

Remarks

When folded, the container children are not visible, and only its caption bar is displayed.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.FoldedSize Property

ContainerNode.FoldedSize Property
[image]

Gets or sets the size of the container when folded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size FoldedSize { get; set; }

Visual Basic [image] Copy Code

Public Property FoldedSize As Size

Property Value

A Size instance specifying the folded size of a container. The default is an empty size.

Remarks

If this property is not set, the width of the folded container is set to its MinimumSize.Width, and the height to CaptionHeight.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.HighlightPen Property

ContainerNode.HighlightPen Property
[image]

Gets or sets the Pen used to draw the container frame lines when an item is dragged over the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen HighlightPen { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightPen As Pen

Property Value

An instance of the Pen class. Initialized with the value of ContainerHighlightPen.

Remarks

The highlight rectangle is not drawn when AllowAddChildren is disabled.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Margin Property

ContainerNode.Margin Property
[image]

Gets or sets how much space should be left between contained nodes and the container borders.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Margin { get; set; }

Visual Basic [image] Copy Code

Public Property Margin As Double

Property Value

A double value specifying the margin size. Initialized with the value of ContainerMargin.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.MinimumSize Property

ContainerNode.MinimumSize Property
[image]

Gets or sets the minimum size of the container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size MinimumSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinimumSize As Size

Property Value

A Size object specifying the minimum size. Initialized with the value of ContainerMinimumSize.

Remarks

The container won't shrink smaller than that size, even if it does not contain any items.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.Shape Property

ContainerNode.Shape Property
[image]

Gets or sets the shape of the container's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As SimpleShape

Property Value

A member of the SimpleShape enumeration.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNode.UnfoldedSize Property

ContainerNode.UnfoldedSize Property
[image]

Returns the original size of a folded container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size UnfoldedSize { get; set; }

Visual Basic [image] Copy Code

Public Property UnfoldedSize As Size

Property Value

A Size instance containing the original size of the container.

See Also

ContainerNode Members
ContainerNode Class


MindFusion.Diagramming.ContainerNodeProperties Class

ContainerNodeProperties Class
Remarks See Also
[image]

Stores the values of ContainerNode properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class ContainerNodeProperties
Inherits DiagramNodeProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from ContainerNode, do so by deriving from ContainerNodeProperties and overriding the ContainerNode.SaveProperties, ContainerNode.RestoreProperties, and ContainerNode.CreateProperties methods.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.ContainerNodeProperties

See Also

ContainerNodeProperties Members


MindFusion.Diagramming.ContainerNodeProperties Members

ContainerNodeProperties Members
Constructors Fields Methods
[image]

Stores the values of ContainerNode properties during undo / redo operations.

The following tables list the members exposed by the ContainerNodeProperties type.

Public Constructors

Name | Description
ContainerNodeProperties | Initializes a new instance of the ContainerNodeProperties class.

Public Fields

Name | Description
Caption | For internal use.
CaptionHeight | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use. (Inherited from DiagramNodeProperties.)
Margin | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Shape | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used. (Inherited from DiagramItemProperties.)

See Also

ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties Fields

ContainerNodeProperties Fields
[image]

Public Fields

Name | Description
Caption | For internal use.
CaptionHeight | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use. (Inherited from DiagramNodeProperties.)
Margin | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Shape | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

See Also

ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties.Caption Field

ContainerNodeProperties.Caption Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption

Visual Basic [image] Copy Code

Public Caption As String

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties.CaptionHeight Field

ContainerNodeProperties.CaptionHeight Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CaptionHeight

Visual Basic [image] Copy Code

Public CaptionHeight As Double

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties.Margin Field

ContainerNodeProperties.Margin Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Margin

Visual Basic [image] Copy Code

Public Margin As Double

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties.Shape Field

ContainerNodeProperties.Shape Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleShape Shape

Visual Basic [image] Copy Code

Public Shape As SimpleShape

See Also

ContainerNodeProperties Members
ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeProperties Constructor

ContainerNodeProperties Constructor
[image]

Initializes a new instance of the ContainerNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ContainerNodeProperties Class


MindFusion.Diagramming.ContainerNodeStyle Class

ContainerNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of container nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ContainerNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class ContainerNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.ContainerNodeStyle

See Also

ContainerNodeStyle Members


MindFusion.Diagramming.ContainerNodeStyle Members

ContainerNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of container nodes.

The following tables list the members exposed by the ContainerNodeStyle type.

Public Constructors

Name | Description
ContainerNodeStyle | Initializes a new instance of the ContainerNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JsonObject. (Inherited from DiagramNodeStyle.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject. (Inherited from DiagramNodeStyle.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

ContainerNodeStyle Class


MindFusion.Diagramming.ContainerNodeStyle Constructor

ContainerNodeStyle Constructor
[image]

Initializes a new instance of the ContainerNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ContainerNodeStyle Class


MindFusion.Diagramming.ContainmentKeys Enumeration

ContainmentKeys Enumeration
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ContainmentKeys

Visual Basic [image] Copy Code

Public Enum ContainmentKeys

Members

Member name | Description
InContainer | Set for Group.Attachment objects for nodes in a container.

See Also


MindFusion.Diagramming.ContextMenuAction Delegate

ContextMenuAction Delegate
[image]

Represents methods that are called when the user activates actions from the context menu.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void ContextMenuAction (
DiagramItem item,
Point point
)

Visual Basic [image] Copy Code

Public Delegate Sub ContextMenuAction( _
item As DiagramItem, _
point As Point _
)

Parameters

item

The diagram item for which the menu is displayed.

point

The touch point.

See Also


MindFusion.Diagramming.Converter Class

Converter Class
[image]

Provides capabilities to convert various types to and from strings in a cutlure-independent way.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Converter

Visual Basic [image] Copy Code

Public NotInheritable Class Converter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Converter

See Also

Converter Members


MindFusion.Diagramming.Converter Members

Converter Members
Methods
[image]

Provides capabilities to convert various types to and from strings in a cutlure-independent way.

The following tables list the members exposed by the Converter type.

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromImageAsync | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
ToBoolean | Converts the specified string value to bool.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specified string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class


MindFusion.Diagramming.Converter Methods

Converter Methods
[image]

Public Methods

Name | Description
FromBoolean | Converts the specified bool value to string.
FromByte | Converts the specified byte value to string.
FromChar | Converts the specified char value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDecimal | Converts the specified decimal to string.
FromDouble | Converts the specified double value to string.
FromEnum | Converts the specified enum value to a string.
FromImage | Converts the specified image to string.
FromImageAsync | Converts the specified image to string.
FromInt16 | Converts the specified 16-bit integer value to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromSByte | Converts the specified 8-bit signed integer to string.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
FromUInt16 | Converts the specified unsigned 16-bit integer value to string.
FromUInt32 | Converts the specified unsigned 32-bit integer value to string.
FromUInt64 | Converts the specified unsigned 64-bit integer value to string.
ToBoolean | Converts the specified string value to bool.
ToByte | Converts the specified string value to byte value.
ToChar | Converts the specified string value to char.
ToColor | Converts the specified string value to Color.
ToDecimal | Converts the specified string value to decimal.
ToDouble | Converts the specified string value to double.
ToEnum | Converts the specified string value to its corresponding enumeration member of the specified type.
ToImage | Converts the specified string value to image.
ToInt16 | Converts the specified string value to 16-bit integer.
ToInt32 | Overloaded.
ToInt64 | Converts the specified string value to 64-bit integer.
ToSByte | Converts the specified string value to 8-bit signed integer.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.
ToUint16 | Converts the specified string value to unsigned 16-bit integer.
ToUint32 | Converts the specified string value to unsigned 32-bit integer.
ToUint64 | Converts the specified string value to unsigned 64-bit integer.

See Also

Converter Class


MindFusion.Diagramming.Converter.FromBoolean Method

Converter.FromBoolean Method
[image]

Converts the specified bool value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromBoolean (
bool val
)

Visual Basic [image] Copy Code

Public Shared Function FromBoolean( _
val As Boolean _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromByte Method

Converter.FromByte Method
[image]

Converts the specified byte value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromByte (
byte val
)

Visual Basic [image] Copy Code

Public Shared Function FromByte( _
val As Byte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromChar Method

Converter.FromChar Method
[image]

Converts the specified char value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromChar (
char val
)

Visual Basic [image] Copy Code

Public Shared Function FromChar( _
val As Char _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromColor Method

Converter.FromColor Method
[image]

Converts the specified color value to string in the format #AARRGGBB.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromColor (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromDecimal Method

Converter.FromDecimal Method
[image]

Converts the specified decimal to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromDecimal (
decimal val
)

Visual Basic [image] Copy Code

Public Shared Function FromDecimal( _
val As Decimal _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromDouble Method

Converter.FromDouble Method
[image]

Converts the specified double value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromDouble (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromDouble( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromEnum Method

Converter.FromEnum Method
[image]

Converts the specified enum value to a string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromEnum (
Object val
)

Visual Basic [image] Copy Code

Public Shared Function FromEnum( _
val As Object _
) As String

Parameters

val

The value to convert.

Return Value

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromImage Method

Converter.FromImage Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromImage (
ImageSource val,
out string type
)

Visual Basic [image] Copy Code

Public Shared Function FromImage( _
val As ImageSource, _
<System.Runtime.InteropServices.Out()> ByRef type As String _
) As String

Parameters

val

The image object to convert.

type

The type of the specified image representation.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromImageAsync Method

Converter.FromImageAsync Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Task<string> FromImageAsync (
ImageSource val
)

Visual Basic [image] Copy Code

Public Shared Function FromImageAsync( _
val As ImageSource _
) As Task(Of String)

Parameters

val

The image object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromInt16 Method

Converter.FromInt16 Method
[image]

Converts the specified 16-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromInt16 (
short val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt16( _
val As Short _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromInt32 Method

Converter.FromInt32 Method
[image]

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromInt32 (
int val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt32( _
val As Integer _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromInt64 Method

Converter.FromInt64 Method
[image]

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromInt64 (
long val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt64( _
val As Long _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromSByte Method

Converter.FromSByte Method
[image]

Converts the specified 8-bit signed integer to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromSByte (
sbyte val
)

Visual Basic [image] Copy Code

Public Shared Function FromSByte( _
val As SByte _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromSingle Method

Converter.FromSingle Method
[image]

Converts the specified float value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromSingle (
float val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Single _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromStream Method

Converter.FromStream Method
[image]

Converts the specified stream to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromStream (
Stream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStream( _
val As Stream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromStreamV4 Method

Converter.FromStreamV4 Method
[image]

Converts the specified memory stream to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromStreamV4 (
MemoryStream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStreamV4( _
val As MemoryStream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromUInt16 Method

Converter.FromUInt16 Method
[image]

Converts the specified unsigned 16-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromUInt16 (
ushort val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt16( _
val As UShort _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromUInt32 Method

Converter.FromUInt32 Method
[image]

Converts the specified unsigned 32-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromUInt32 (
uint val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt32( _
val As UInteger _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.FromUInt64 Method

Converter.FromUInt64 Method
[image]

Converts the specified unsigned 64-bit integer value to string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string FromUInt64 (
ulong val
)

Visual Basic [image] Copy Code

Public Shared Function FromUInt64( _
val As ULong _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToBoolean Method

Converter.ToBoolean Method
[image]

Converts the specified string value to bool.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool ToBoolean (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBoolean( _
s As String _
) As Boolean

Parameters

s

The string value to convert from.

Return Value

A boolean value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToByte Method

Converter.ToByte Method
[image]

Converts the specified string value to byte value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static byte ToByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToByte( _
s As String _
) As Byte

Parameters

s

The string value to convert from.

Return Value

A byte value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToChar Method

Converter.ToChar Method
[image]

Converts the specified string value to char.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static char ToChar (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToChar( _
s As String _
) As Char

Parameters

s

The string value to convert from.

Return Value

A char value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToColor Method

Converter.ToColor Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Color ToColor (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToColor( _
s As String _
) As Color

Parameters

s

The string value to convert from.

Return Value

A Color value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToDecimal Method

Converter.ToDecimal Method
[image]

Converts the specified string value to decimal.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static decimal ToDecimal (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDecimal( _
s As String _
) As Decimal

Parameters

s

The string value to convert from.

Return Value

A decimal value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToDouble Method

Converter.ToDouble Method
[image]

Converts the specified string value to double.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double ToDouble (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDouble( _
s As String _
) As Double

Parameters

s

The string value to convert from.

Return Value

A double value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToEnum Method

Converter.ToEnum Method
[image]

Converts the specified string value to its corresponding enumeration member of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Object ToEnum (
Type type,
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToEnum( _
type As Type, _
s As String _
) As Object

Parameters

type

The type of the enumeration to convert to.

s

The string value to convert from.

Return Value

A member of the specified enumeration that is deserialized from the specified string, possibly a null reference if the deserialization failed.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToImage Method

Converter.ToImage Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ImageSource ToImage (
string s,
string type
)

Visual Basic [image] Copy Code

Public Shared Function ToImage( _
s As String, _
type As String _
) As ImageSource

Parameters

s

type

Return Value

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt16 Method

Converter.ToInt16 Method
[image]

Converts the specified string value to 16-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static short ToInt16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt16( _
s As String _
) As Short

Parameters

s

The string value to convert from.

Return Value

A 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt32 Method

Converter.ToInt32 Method
[image]

Overload List

Name | Description
Converter.ToInt32 (String) | Converts the specified string value to 32-bit integer.
Converter.ToInt32 (String, Int32) | Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt32 Method (String)

Converter.ToInt32 Method (String)
See Also
[image]

Converts the specified string value to 32-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String _
) As Integer

Parameters

s

The string value to convert from.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt32 Method (String, Int32)

Converter.ToInt32 Method (String, Int32)
See Also
[image]

Converts the specified string value to 32-bit integer without throwing exceptions. In case the specified string cannot be converted, the specified default value is returned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s,
int defaultValue
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String, _
defaultValue As Integer _
) As Integer

Parameters

s

The string value to convert from.

defaultValue

The default value to return if s cannot be deserialized.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

ToInt32 Method Overload List
Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToInt64 Method

Converter.ToInt64 Method
[image]

Converts the specified string value to 64-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static long ToInt64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt64( _
s As String _
) As Long

Parameters

s

The string value to convert from.

Return Value

A 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToSByte Method

Converter.ToSByte Method
[image]

Converts the specified string value to 8-bit signed integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static sbyte ToSByte (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSByte( _
s As String _
) As SByte

Parameters

s

The string value to convert from.

Return Value

An 8-bit signed integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToSingle Method

Converter.ToSingle Method
[image]

Converts the specified string value to float.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static float ToSingle (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSingle( _
s As String _
) As Single

Parameters

s

The string value to convert from.

Return Value

A float value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToStream Method

Converter.ToStream Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Stream ToStream (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStream( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A Stream object that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToStreamV4 Method

Converter.ToStreamV4 Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Stream ToStreamV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStreamV4( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A Stream object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToUint16 Method

Converter.ToUint16 Method
[image]

Converts the specified string value to unsigned 16-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ushort ToUint16 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint16( _
s As String _
) As UShort

Parameters

s

The string value to convert from.

Return Value

An unsigned 16-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToUint32 Method

Converter.ToUint32 Method
[image]

Converts the specified string value to unsigned 32-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static uint ToUint32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint32( _
s As String _
) As UInteger

Parameters

s

The string value to convert from.

Return Value

An unsigned 32-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.Converter.ToUint64 Method

Converter.ToUint64 Method
[image]

Converts the specified string value to unsigned 64-bit integer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ulong ToUint64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToUint64( _
s As String _
) As ULong

Parameters

s

The string value to convert from.

Return Value

Remarks

An unsigned 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class


MindFusion.Diagramming.CreatePathDelegate Delegate

CreatePathDelegate Delegate
[image]

Specifies the signature of callback functions used to generate dynamic node shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate IGraphicsPath CreatePathDelegate (
Rectangle nodeBounds
)

Visual Basic [image] Copy Code

Public Delegate Function CreatePathDelegate( _
nodeBounds As Rectangle _
) As IGraphicsPath

Parameters

nodeBounds

A Rectangle object.

Return Value

A IGraphicsPath specifying the shape outline or decorations.

See Also


MindFusion.Diagramming.CreatePathDelegate Delegate

CreatePathDelegate Delegate
[image]

Specifies the signature of callback functions used to generate dynamic node shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate IGraphicsPath CreatePathDelegate (
Rect nodeBounds
)

Visual Basic [image] Copy Code

Public Delegate Function CreatePathDelegate( _
nodeBounds As Rect _
) As IGraphicsPath

Parameters

nodeBounds

A Rectangle object.

Return Value

An IGraphicsPath specifying the shape outline or decorations.

See Also


MindFusion.Diagramming.CustomDraw Enumeration

CustomDraw Enumeration
[image]

Specifies what kind of custom painting to perform on diagram elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum CustomDraw

Visual Basic [image] Copy Code

Public Enum CustomDraw

Members

Member name | Description
Additional | The custom painting code executes after item's interior and frame are painted by MindFusion.Diagramming for .NET MAUI, but before text is rendered. In this mode, the Graphics instance passed to the custom drawing event handler has a clipping region applied to it.
Additional2 | The custom painting code executes after all parts of an item are painted by MindFusion.Diagramming for .NET MAUI. In this mode, the Graphics instance passed to the custom drawing event handler doesn't have a clipping region applied to it.
Full | The component does not do any standard drawing, the entire painting of an item is done by the application.
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming for .NET MAUI.
ShadowOnly | Only the shadow of an item is painted by custom code, the item itself is drawn by the component.

Remarks

These values can be assigned to the CustomDraw property of shapes, tables and links.

See Also


MindFusion.Diagramming.Diagram Class

Diagram Class
Remarks See Also
[image]

Represents a flow diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Diagram : DiagramBase, IItemFactory

Visual Basic [image] Copy Code

Public Class Diagram
Inherits DiagramBase
Implements IItemFactory

Remarks

An instance of the Diagram class represents a diagram document. A Diagram instance does not provide its own user interface. To display a diagram on a form, add a DiagramView instance to the form and set the view's Diagram property. A diagram can be displayed in more than one view.

A diagram can contain connected nodes and links. Nodes are instances of DiagramNode-derived classes. Nodes are stored in the Nodes collection. Links in MindFusion.Diagramming for .NET MAUI are instances of the DiagramLink class and are stored in the Links collection.

Managing Items

Items can be created by using the new operator and added to the diagram by means of the Add method of the Nodes or Links collection. Items are deleted by using the Remove method of the respective collection. There are shortcut methods provided by the diagram's Factory object that can be used to create an item and add it to the diagram with just one method call. Use the CreateTableNode, CreateShapeNode and CreateDiagramLink factory methods to create new items of the respective type.

Searching for a particular kind of items is done with the FindLink and FindNode methods, which look for an item that has a particular Tag, or FindLinkById and FindNodeById to find items by their Id. To get the item placed at a certain location, use the GetItemAt method.

Serialization

Use the SaveToXml and LoadFromXml methods to serialize a diagram into/from XML documents.

Controlling Users' Actions

Most aspects of user interaction are controlled by the DiagramView class.

Users actions can be validated by handling various events, fired while items are being created, modified or deleted.

The following properties control what kind of links users can create: AllowLinksRepeat, AllowSelfLoops, AllowUnanchoredLinks, AllowUnconnectedLinks.

The order in which items are hit-tested when clicking on them depends on the value of HitTestPriority. The LinkHitDistance property specifies the furthest distance from a link that a click would be still considered a hit.

Alignment

Items are aligned to a grid when AlignToGrid is enabled. To display the grid, set ShowGrid to true. The grid size and appearance can be customized via the GridSizeX, GridSizeY, GridColor and GridStyle properties.

If AutoAlignNodes is enabled, nodes are aligned to other nodes so that a pair of their vertical or horizontal sides become collinear. To specify the maximal distance at which nodes are aligned, set the AutoAlignDistance property. The pair of aligned nodes is indicated visually by drawing an alignment guide using the pen assigned to AlignmentGuidePen.

Links can also automatically snap to nodes when AutoSnapLinks is set. The maximal distance at which links will connect to a nearby node is set via AutoSnapDistance.

Appearance

The Diagram background area can be painted using a solid, gradient, texture or color brush, by setting the BackBrush property, and/or using an image specified by BackgroundImage and BackgroundImageAlign.

To further customize the diagram appearance, handle the DrawBackground event to render custom background graphics, or the DrawForeground event to render custom foreground graphics.

Lanes

The lane grid lets you emphasize the relationship between a group of diagram items by displaying them in a distinct lane or cell within the grid. Use the EnableLanes property to display a background grid of lanes, optionally divided into cells. The grid can be set up using the LaneGrid property.

Text Formatting

Use TextFormat and TextColor to specify alignment and color of the text for all diagram items. EnableStyledText allows using HTML-like tags to format item's text. PolygonalTextLayout allows laying text out inside non-rectangular node shapes.

Tweaks

  • SelectionOnTop specifies whether selected items should be painted on top of other items.
  • MergeThreshold specifies how closely one to another adjacent link points should be placed in order to merge link segments.

Default Item Properties

Many properties of the Diagram class provide initial values for the properties of new items.

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
Microsoft.Maui.Controls.Layout
Microsoft.Maui.Controls.AbsoluteLayout
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.Diagram

See Also

Diagram Members


MindFusion.Diagramming.Diagram Members

Diagram Members
Constructors Fields Properties Methods Events
[image]

Represents a flow diagram.

The following tables list the members exposed by the Diagram type.

Public Constructors

Name | Description
Diagram | Initializes a new instance of the Diagram class.

Public Fields

Name | Description
Dummy | A shared DummyNode instance.

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element.
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item.
ActiveLayer | Gets or sets the zero-based index of the active layer.
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects, expressed in millimeters.
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides.
AlignToGrid | Gets or sets a value indicating whether the items in the diagram are aligned to grid.
AllowLinksRepeat | Gets or sets a value indicating whether more than one arrow can link the same origin and destination diagram nodes.
AllowMultipleResize | Gets or sets whether multiple selected nodes can be resized simultaneously.
AllowSelfLoops | Gets or sets value indicating whether reflexive links are allowed.
AllowSplitLinks | Gets or sets a value indicating whether arrow segments can be added and removed interactively.
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders of other nodes.
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders of other nodes during user interaction.
AutoCloseDistance | Gets or sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically.
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it.
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes.
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links.
BackBrush | Gets or sets the brush used for painting the diagram background.
BackgroundImage | Gets or sets the diagram background image.
BackgroundImageAlign | Gets or set a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area.
BoundsPen | The pen with which the document bounds should be drawn.
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables.
CellFrameStyle | Gets or sets the default cell border style of new tables.
ContainerCaption | Specifies the default container caption text.
ContainerCaptionHeight | Specifies the default container caption height.
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers.
ContainerMargin | Gets or sets the default value for the Margin property of containers.
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers.
ContainerNodeStyle | Gets the theme-level style for container nodes.
ContainersFoldable | Gets or sets the default value for the Foldable property of containers.
CrossingRadius | Gets or sets the radius length of decorations displayed at arrow intersection points.
DefaultShape | Gets or sets the default shape of shape nodes.
DiagramLinkStyle | Gets the theme-level style for diagram links.
DiagramStyle | Gets the theme-level style for the diagram.
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save.
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles.
DynamicLinks | Gets or sets the default value for the Dynamic property of new links.
EffectiveBackBrush | Gets the currently effective background brush of the diagram.
EnableLanes | Gets or sets whether lanes are enabled.
ExpandButtonAction | Specifies what should happen when a user clicks the +/- button that is displayed near expandable nodes.
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes.
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded.
ExteriorBrush | Gets or sets the brush used for painting the area outside document bounds.
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram.
FoldedContainerSize | Gets or sets the size of folded containers.
Font | Gets or sets the default font.
FreeFormAttractDistance | Gets or sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too.
FreeFormTargets | An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes.
GridColor | Gets or sets the color of the grid points.
GridOffsetX | Gets or sets the horizontal offset of the first column of grid points.
GridOffsetY | Gets or sets the vertical offset of the first row of grid points.
GridSizeX | Gets or sets the horizontal distance between adjacent grid points.
GridSizeY | Gets or sets the vertical distance between adjacent grid points.
GridStyle | Gets or sets the visual style of the alignment grid.
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested.
Items | Gets a read-only collection of all objects in this diagram.
JsonOptions | A JsonOptions object providing properties for customizing the JSON serialization process.
LaneGrid | Gets the lane grid.
Layers | Gets a list of the layers in the current diagram.
LicenseKey | Gets or sets the license key of the control.
LinkBaseShape | Gets or sets the shape displayed at the base of new links.
LinkBaseShapeSize | Gets or sets the default size of the base of new links.
LinkBrush | Gets or sets the default value for the Brush property of links.
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links.
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths.
LinkCustomDraw | Gets or sets the default type of custom painting done on links.
LinkEndsMovable | Gets or sets a value indicating whether link ends can be moved by users after the link is created.
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links.
LinkHeadShape | Gets or sets the shape displayed as head of new links.
LinkHeadShapeSize | Gets or sets the default size of arrowheads.
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit, expressed in millimeters.
LinkIntermediateShape | Gets or sets default shape to be displayed in the middle of each segment of links.
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of arrow segments.
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links.
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.
Links | Gets a collection of all links in this diagram.
LinkSegments | Gets or sets the default number of arrow segments.
LinkShape | Gets or sets the default style of arrow objects.
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.
LinkText | Gets or sets the default text of links.
LinkTextStyle | Gets or sets default placement and orientation for links' text.
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram.
MergeThreshold | Gets or sets the maximum distance between adjacent control points of an arrow at which the respective segments can be merged.
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set.
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram.
Nodes | Gets a collection of all nodes in this diagram.
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded.
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file.
RecursiveExpand | Gets or sets value indicating how a tree is expanded.
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.
RoundedLinks | Specifies whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments.
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.
RouteLinks | Gets or sets a value specifying whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm.
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows.
SelectAfterCreate | Gets or sets value indicating whether newly created objects are automatically selected.
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items.
Selection | Gets the Selection instance that represents the selection of items in this diagram.
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items.
ShadowBrush | Gets or sets the default brush used for painting the items' shadows.
ShadowOffsetX | Gets or sets the horizontal offset of objects' shadows.
ShadowOffsetY | Gets or sets the vertical offset of objects' shadows.
ShadowsStyle | Gets or sets the style for rendering shadows.
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes.
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes.
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes.
ShapeNodeStyle | Gets the theme-level style for shape nodes.
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes.
ShapePen | Gets or sets the default value for the Pen property of shape nodes.
ShapeText | Gets or sets the default text of shape nodes.
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed.
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled.
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible.
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of pointed objects while another object is being modified.
SnapToAnchor | Gets or sets when arrow end points should be aligned to the nearest anchor points.
Style | Gets or sets the style associated with the diagram.
TableBrush | Gets or sets the default value for the Brush property of tables.
TableCaption | Gets or sets the default text for tables' captions.
TableCaptionHeight | Gets or sets the default height of table captions.
TableColumnCount | Gets or sets the default number of table columns.
TableColumnWidth | Gets or sets the default width of tables' columns.
TableConnectionStyle | Gets or sets a value indicating whether drawing an arrow between tables should link rows of those tables, or the tables as whole entities.
TableCustomDraw | Gets or sets the default type of custom painting done on tables.
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables.
TableNodeStyle | Gets the theme-level style for table nodes.
TablePen | Gets or sets the default value for the Pen property of tables.
TableRowCount | Gets or sets the default number of table rows.
TableRowHeight | Gets or sets the default height of tables' rows.
TableShape | Gets or sets the default style of new tables.
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables.
Tag | Gets or sets custom data associated with this diagram.
TextColor | Gets or sets the default color of text displayed inside diagram items.
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.
Theme | Gets or sets the theme associated with the diagram.
TouchRadius | Gets or sets the distance tolerance during hit-testing, expressed in millimeters, or null, to use the default tolerance.
TreeViewNodeStyle | Gets the theme-level style for tree view nodes.
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the specified point.
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled.
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.
ClearAll | Removes all items and groups from the diagram.
CreateImage | Overloaded. Creates a bitmap containing an image of the diagram.
CreateMeasureGraphics | Creates an IGraphics object that can be used to obtain various string size measurements.
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram.
Draw | Renders the diagram on the specified IGraphics object.
DrawAlignmentGuides | Draws the current alignment guides.
DrawLayer | Renders all diagram items to the specified graphics.
ExportImage | Overloaded. Exports a bitmap file containing an image of the diagram.
FindLink | Finds the link that has the specified tag value.
FindLinkById | Finds the link that has the specified id value.
FindNode | Finds the node that has the specified tag value.
FindNodeById | Finds the node that has the specified id value.
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects.
GetGraphics | For internal use.
GetItemAt | Returns the top-most diagram item lying at the specified location.
GetLinkAt | Overloaded. Returns the top-most link that lies at a specified position.
GetLinksAt | Returns the links that contain the specified point.
GetMeasureGraphics | For internal use.
GetNearestNode | Returns the nearest node whose bounding rectangle is intersected by the circle, defined by origin point and radius.
GetNodeAt | Overloaded. Returns the topmost node that lies at a specified position.
GetNodesAt | Returns the nodes that contain the specified point.
HitTestLabels | Returns the item label located at specified position.
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.
Invalidate | Overloaded. Invalidates the diagram.
InvalidateZOrder | Forces a new sort of the Z order list before next redraw.
IsClassRegistered | Checks if a class is registered for serialization support.
IsClientClassRegistered | Checks if a class is registered for JSON serialization support.
IsItemInteractive | Checks if the specified item can be modified interactively.
IsItemLocked | Checks if the specified item is locked.
IsItemVisible | Checks if the specified item is currently visible.
LoadFromJson | Loads the diagram from a JSON-formatted string.
LoadFromJsonFile | Loads the diagram from a JSON file.
LoadFromJsonObject | Loads the diagram from a JSON object.
LoadFromString | Loads a diagram from the specified string.
LoadFromXml | Overloaded. Loads the diagram.
Navigate | Selects the nearest item in the specified direction.
PrepareImages |
RaiseCellTextEdited | Raises the CellTextEdited event.
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode.
RaiseClicked | Raises the Clicked event.
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item.
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item.
RaiseLinkTextEdited | Overloaded.
RaiseLinkTextEditing | Overloaded.
RaiseNodeTextEdited | Overloaded.
RaiseNodeTextEditing | Overloaded.
RaisePasted | Raises the appropriate Pasted event.
RaiseSelecting | Raises the appropriate Selecting event.
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode.
RaiseViewRemoved | Raises the ViewRemoved event.
RegisterClass | Overloaded.
RegisterDefaultStyle | Registers a default style for the objects of the specified type.
RegisterItemClass | Overloaded.
ResizeToFitItem | Resize the document extents so that the specified item is contained within.
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items.
RouteAllLinks | Performs routing on all links ignoring their AutoRoute flag.
SaveToJson |
SaveToJsonFile | Saves the diagram into a JSON file.
SaveToJsonObject | Saves the diagram to a JSON object.
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string.
SaveToXml | Overloaded. Saves the diagram to an XML document.
SetShadowOffset | Sets the default offset at which objects' shadows are drawn.

Protected Methods

Name | Description
AddItem | Invoked by the AddItemCmd and RemoveItemCmd classes to effectively add the specified item to the diagram.
CreateItem | Creates an instance of the specified class.
GetValue | Gets the effective value of the style property with the specified name.
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnJsonDeserializeTag | Raises the JsonDeserializeTag event. (Inherited from DiagramBase.)
OnJsonSerializeTag | Raises the JsonSerializeTag event. (Inherited from DiagramBase.)
OnLabelClicked | Raises the LabelClicked event. (Inherited from DiagramBase.)
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreateCancelled | Raises the LinkCreateCancelled event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifyCancelled | Raises the LinkModifyCancelled event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreateCancelled | Raises the NodeCreateCancelled event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifyCancelled | Raises the NodeModifyCancelled event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnQueryAlignTarget | Raises the QueryAlignTarget event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnRequestClipboard | Raises the RequestClipboard event. (Inherited from DiagramBase.)
OnRequestTimer | Raises the RequestTimer event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnViewRemoved | Raises the ViewRemoved event. (Inherited from DiagramBase.)

Public Events

Name | Description
ActiveLayerChanged | Raised when the diagram's active layer has changed. (Inherited from DiagramBase.)
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
BoundsChanged | Raised when the Bounds property value has changed. (Inherited from DiagramBase.)
CellClicked | Raised when the user clicks a table's cell. (Inherited from DiagramBase.)
CellTextEdited | Raised when the user edits the text of a table's cell. (Inherited from DiagramBase.)
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table's cell. (Inherited from DiagramBase.)
Clicked | Raised when the user clicks the diagram at a point where no items are located. (Inherited from DiagramBase.)
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user. (Inherited from DiagramBase.)
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area. (Inherited from DiagramBase.)
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area. (Inherited from DiagramBase.)
DefaultShapeChanged | Raised when the DefaultShape property value has changed. (Inherited from DiagramBase.)
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format. (Inherited from DiagramBase.)
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed. (Inherited from DiagramBase.)
DirtyChanged | Raised when the Dirty property value has changed. (Inherited from DiagramBase.)
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn. (Inherited from DiagramBase.)
DrawAnchorPoint | Raised when an anchor point must be custom drawn. (Inherited from DiagramBase.)
DrawBackground | Raised to let you custom draw the diagram background. (Inherited from DiagramBase.)
DrawCell | Raised when a table's cell must be custom drawn. (Inherited from DiagramBase.)
DrawForeground | Raised to let you custom draw the diagram foreground. (Inherited from DiagramBase.)
DrawLink | Raised when a diagram link must be custom drawn. (Inherited from DiagramBase.)
DrawNode | Raised when a diagram node must be custom drawn. (Inherited from DiagramBase.)
EndLoad | Raised when the component ends loading diagram data from a file or memory stream. (Inherited from DiagramBase.)
ExpandButtonClicked | Raised if ExpandButtonAction is set to RaiseEvents and the [+/-] button of an Expandable node is clicked. (Inherited from DiagramBase.)
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed. (Inherited from DiagramBase.)
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created. (Inherited from DiagramBase.)
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created. (Inherited from DiagramBase.)
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively. (Inherited from DiagramBase.)
JsonDeserializeTag | Raised when the Tag of a diagram item must be deserialized from Json. (Inherited from DiagramBase.)
JsonSerializeTag | Raised when the Tag of a diagram item must be serialized to Json. (Inherited from DiagramBase.)
LabelClicked | Raised when the user clicks a link label. (Inherited from DiagramBase.)
LayerVisibilityChanged | Raised when the visibility of a Layer changes. (Inherited from DiagramBase.)
LinkActivated | Raised when a link becomes the ActiveItem. (Inherited from DiagramBase.)
LinkClicked | Raised when the user clicks a link. (Inherited from DiagramBase.)
LinkCreateCancelled | Raised when the user cancels link creation. (Inherited from DiagramBase.)
LinkCreated | Raised when the user draws a new link. (Inherited from DiagramBase.)
LinkCreating | A validation event raised while the user is drawing a new link. (Inherited from DiagramBase.)
LinkDeactivated | Raised when a link is no longer the ActiveItem. (Inherited from DiagramBase.)
LinkDeleted | Raised when a link is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkDeselected | Raised when a link is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkModified | Raised when the user moves any control point of a link. (Inherited from DiagramBase.)
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link. (Inherited from DiagramBase.)
LinkModifying | A validation event raised while the user is modifying a link. (Inherited from DiagramBase.)
LinkPasted | Raised when a link has been pasted from the clipboard. (Inherited from DiagramBase.)
LinkRouted | Raised when a link is routed by the auto-routing algorithm. (Inherited from DiagramBase.)
LinkSelected | Raised when a link is selected, either programmatically or by the user. (Inherited from DiagramBase.)
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation. (Inherited from DiagramBase.)
LinkSplit | Raised when the user splits a link interactively. (Inherited from DiagramBase.)
LinkStartModifying | A validation event raised when the user starts modifying a link. (Inherited from DiagramBase.)
LinkTextEdited | Raised when the user edits the text of a link. (Inherited from DiagramBase.)
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link. (Inherited from DiagramBase.)
MeasureUnitChanged | Raised when the MeasureUnit property value has changed. (Inherited from DiagramBase.)
NodeActivated | Raised when a node becomes the ActiveItem. (Inherited from DiagramBase.)
NodeClicked | Raised when the user clicks a node. (Inherited from DiagramBase.)
NodeCreateCancelled | Raised when the user cancels node creation. (Inherited from DiagramBase.)
NodeCreated | Raised when the user draws a new node. (Inherited from DiagramBase.)
NodeCreating | A validation event raised while the user is drawing a new node. (Inherited from DiagramBase.)
NodeDeactivated | Raised when a node is no longer the ActiveItem. (Inherited from DiagramBase.)
NodeDeleted | Raised when a node is deleted, either programmatically or by the user. (Inherited from DiagramBase.)
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeDeselected | Raised when a node is deselected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeModified | Raised when the user moves or resizes a node. (Inherited from DiagramBase.)
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node. (Inherited from DiagramBase.)
NodeModifying | A validation event raised while the user is moving or resizing a node. (Inherited from DiagramBase.)
NodePasted | Raised when a node has been pasted from the clipboard. (Inherited from DiagramBase.)
NodeSelected | Raised when a node is selected, either programmatically or by the user. (Inherited from DiagramBase.)
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation. (Inherited from DiagramBase.)
NodeStartModifying | A validation event raised when the user starts modifying a node. (Inherited from DiagramBase.)
NodeTextEdited | Raised when the user edits the text of a node. (Inherited from DiagramBase.)
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node. (Inherited from DiagramBase.)
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed. (Inherited from DiagramBase.)
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled. (Inherited from DiagramBase.)
Repaint | Raised when the diagram views should be repainted. (Inherited from DiagramBase.)
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap. (Inherited from DiagramBase.)
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard. (Inherited from DiagramBase.)
RequestTimer | Raised when an object within the diagram needs to start or stop a timer. (Inherited from DiagramBase.)
SelectionChanged | Raised when an item is added to or removed from the selection. (Inherited from DiagramBase.)
SelectionModified | Raised when the user moves multiple selected items. (Inherited from DiagramBase.)
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification. (Inherited from DiagramBase.)
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document. (Inherited from DiagramBase.)
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape. (Inherited from DiagramBase.)
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row. (Inherited from DiagramBase.)
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row. (Inherited from DiagramBase.)
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node. (Inherited from DiagramBase.)
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node. (Inherited from DiagramBase.)
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a treeviewnode's item. (Inherited from DiagramBase.)
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point. (Inherited from DiagramBase.)
ViewRemoved | Raised when a DiagramView is detached from this diagram. (Inherited from DiagramBase.)

See Also

Diagram Class


MindFusion.Diagramming.Diagram Fields

Diagram Fields
[image]

Public Fields

Name | Description
Dummy | A shared DummyNode instance.

See Also

Diagram Class


MindFusion.Diagramming.Diagram.Dummy Field

Diagram.Dummy Field
[image]

A shared DummyNode instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DummyNode Dummy

Visual Basic [image] Copy Code

Public Dummy As DummyNode

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram Constructor

Diagram Constructor
[image]

Initializes a new instance of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Diagram Class


MindFusion.Diagramming.Diagram Methods

Diagram Methods
[image]

Public Methods

Name | Description
AlignPointToGrid | Returns a point of the alignment grid nearest to the specified point.
ArrangeLinkLabels | Rearranges link labels whose AutoArrange property is enabled.
ChangeUnit | Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.
ClearAll | Removes all items and groups from the diagram.
CreateImage | Overloaded. Creates a bitmap containing an image of the diagram.
CreateMeasureGraphics | Creates an IGraphics object that can be used to obtain various string size measurements.
CreateThemeFromDefaults | Creates a Theme object representing the default properties of the diagram.
Draw | Renders the diagram on the specified IGraphics object.
DrawAlignmentGuides | Draws the current alignment guides.
DrawLayer | Renders all diagram items to the specified graphics.
ExportImage | Overloaded. Exports a bitmap file containing an image of the diagram.
FindLink | Finds the link that has the specified tag value.
FindLinkById | Finds the link that has the specified id value.
FindNode | Finds the node that has the specified tag value.
FindNodeById | Finds the node that has the specified id value.
GetContentBounds | Returns the smallest rectangle that bounds all diagram objects.
GetGraphics | For internal use.
GetItemAt | Returns the top-most diagram item lying at the specified location.
GetLinkAt | Overloaded. Returns the top-most link that lies at a specified position.
GetLinksAt | Returns the links that contain the specified point.
GetMeasureGraphics | For internal use.
GetNearestNode | Returns the nearest node whose bounding rectangle is intersected by the circle, defined by origin point and radius.
GetNodeAt | Overloaded. Returns the topmost node that lies at a specified position.
GetNodesAt | Returns the nodes that contain the specified point.
HitTestLabels | Returns the item label located at specified position.
HitTestManipulators | Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.
Invalidate | Overloaded. Invalidates the diagram.
InvalidateZOrder | Forces a new sort of the Z order list before next redraw.
IsClassRegistered | Checks if a class is registered for serialization support.
IsClientClassRegistered | Checks if a class is registered for JSON serialization support.
IsItemInteractive | Checks if the specified item can be modified interactively.
IsItemLocked | Checks if the specified item is locked.
IsItemVisible | Checks if the specified item is currently visible.
LoadFromJson | Loads the diagram from a JSON-formatted string.
LoadFromJsonFile | Loads the diagram from a JSON file.
LoadFromJsonObject | Loads the diagram from a JSON object.
LoadFromString | Loads a diagram from the specified string.
LoadFromXml | Overloaded. Loads the diagram.
Navigate | Selects the nearest item in the specified direction.
PrepareImages |
RaiseCellTextEdited | Raises the CellTextEdited event.
RaiseCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode.
RaiseClicked | Raises the Clicked event.
RaiseCreated | Raises the appropriate *Created event according to the type of the specified item.
RaiseDeleting | Raises the appropriate *Deleting event according to the type of the specified item.
RaiseLinkTextEdited | Overloaded.
RaiseLinkTextEditing | Overloaded.
RaiseNodeTextEdited | Overloaded.
RaiseNodeTextEditing | Overloaded.
RaisePasted | Raises the appropriate Pasted event.
RaiseSelecting | Raises the appropriate Selecting event.
RaiseTreeItemTextEditing | Raises the TreeItemTextEditing event to validate entering inplace edit mode.
RaiseViewRemoved | Raises the ViewRemoved event.
RegisterClass | Overloaded.
RegisterDefaultStyle | Registers a default style for the objects of the specified type.
RegisterItemClass | Overloaded.
ResizeToFitItem | Resize the document extents so that the specified item is contained within.
ResizeToFitItems | Overloaded. Resizes the document scrollable area so it fits all diagram items.
RouteAllLinks | Performs routing on all links ignoring their AutoRoute flag.
SaveToJson |
SaveToJsonFile | Saves the diagram into a JSON file.
SaveToJsonObject | Saves the diagram to a JSON object.
SaveToString | Overloaded. Encodes the diagram contents into an ASCII string.
SaveToXml | Overloaded. Saves the diagram to an XML document.
SetShadowOffset | Sets the default offset at which objects' shadows are drawn.

Protected Methods

Name | Description
AddItem | Invoked by the AddItemCmd and RemoveItemCmd classes to effectively add the specified item to the diagram.
CreateItem | Creates an instance of the specified class.
GetValue | Gets the effective value of the style property with the specified name.
OnBeginLoad | Raises the BeginLoad event. (Inherited from DiagramBase.)
OnBoundsChanged | Raises the BoundsChanged event. (Inherited from DiagramBase.)
OnCellClicked | Raises the CellClicked event. (Inherited from DiagramBase.)
OnCellTextEdited | Raises the CellTextEdited event. (Inherited from DiagramBase.)
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnClicked | Raises the Clicked event. (Inherited from DiagramBase.)
OnContainerChildAdded | Raises the ContainerChildAdded event. (Inherited from DiagramBase.)
OnContainerChildRemoved | Raises the ContainerChildRemoved event. (Inherited from DiagramBase.)
OnContainerFolded | Raises the ContainerFolded event. (Inherited from DiagramBase.)
OnContainerUnfolded | Raises the ContainerUnfolded event. (Inherited from DiagramBase.)
OnDefaultShapeChanged | Raises the DefaultShapeChanged event. (Inherited from DiagramBase.)
OnDeserializeTag | Raises the DeserializeTag event. (Inherited from DiagramBase.)
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event. (Inherited from DiagramBase.)
OnDirtyChanged | Raises the DirtyChanged event. (Inherited from DiagramBase.)
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event. (Inherited from DiagramBase.)
OnDrawAnchorPoint | Raises the DrawAnchorPoint event. (Inherited from DiagramBase.)
OnDrawBackground | Raises the DrawBackground event. (Inherited from DiagramBase.)
OnDrawCell | Raises the DrawCell event. (Inherited from DiagramBase.)
OnDrawForeground | Raises the DrawForeground event. (Inherited from DiagramBase.)
OnDrawLink | Raises the DrawLink event. (Inherited from DiagramBase.)
OnDrawNode | Raises the DrawNode event. (Inherited from DiagramBase.)
OnEndLoad | Raises the EndLoad event. (Inherited from DiagramBase.)
OnExpandButtonClicked | Raises the ExpandButtonClicked event. (Inherited from DiagramBase.)
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event. (Inherited from DiagramBase.)
OnInitializeLink | Raises the InitializeLink event. (Inherited from DiagramBase.)
OnInitializeNode | Raises the InitializeNode event. (Inherited from DiagramBase.)
OnItemAdded | Raises the ItemAdded event. (Inherited from DiagramBase.)
OnItemRemoved | Raises the ItemRemoved event. (Inherited from DiagramBase.)
OnJsonDeserializeTag | Raises the JsonDeserializeTag event. (Inherited from DiagramBase.)
OnJsonSerializeTag | Raises the JsonSerializeTag event. (Inherited from DiagramBase.)
OnLabelClicked | Raises the LabelClicked event. (Inherited from DiagramBase.)
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event. (Inherited from DiagramBase.)
OnLinkActivated | Raises the LinkActivated event. (Inherited from DiagramBase.)
OnLinkClicked | Raises the LinkClicked event. (Inherited from DiagramBase.)
OnLinkCreateCancelled | Raises the LinkCreateCancelled event. (Inherited from DiagramBase.)
OnLinkCreated | Raises the LinkCreated event. (Inherited from DiagramBase.)
OnLinkCreating | Raises the LinkCreating event. (Inherited from DiagramBase.)
OnLinkDeactivated | Raises the LinkDeactivated event. (Inherited from DiagramBase.)
OnLinkDeleted | Raises the LinkDeleted event. (Inherited from DiagramBase.)
OnLinkDeleting | Raises the LinkDeleting event. (Inherited from DiagramBase.)
OnLinkDeselected | Raises the LinkDeselected event. (Inherited from DiagramBase.)
OnLinkModified | Raises the LinkModified event. (Inherited from DiagramBase.)
OnLinkModifyCancelled | Raises the LinkModifyCancelled event. (Inherited from DiagramBase.)
OnLinkModifying | Raises the LinkModifying event. (Inherited from DiagramBase.)
OnLinkPasted | Raises the LinkPasted event. (Inherited from DiagramBase.)
OnLinkRouted | Raises the LinkRouted event. (Inherited from DiagramBase.)
OnLinkSelected | Raises the LinkSelected event. (Inherited from DiagramBase.)
OnLinkSelecting | Raises the LinkSelecting event. (Inherited from DiagramBase.)
OnLinkSplit | Raises the LinkSplit event. (Inherited from DiagramBase.)
OnLinkStartModifying | Raises the LinkStartModifying event. (Inherited from DiagramBase.)
OnLinkTextEdited | Raises the LinkTextEdited event. (Inherited from DiagramBase.)
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnMeasureUnitChanged | Raises the MeasureUnitChanged event. (Inherited from DiagramBase.)
OnNodeActivated | Raises the NodeActivated event. (Inherited from DiagramBase.)
OnNodeClicked | Raises the NodeClicked event. (Inherited from DiagramBase.)
OnNodeCreateCancelled | Raises the NodeCreateCancelled event. (Inherited from DiagramBase.)
OnNodeCreated | Raises the NodeCreated event. (Inherited from DiagramBase.)
OnNodeCreating | Raises the NodeCreating event. (Inherited from DiagramBase.)
OnNodeDeactivated | Raises the NodeDeactivated event. (Inherited from DiagramBase.)
OnNodeDeleted | Raises the NodeDeleted event. (Inherited from DiagramBase.)
OnNodeDeleting | Raises the NodeDeleting event. (Inherited from DiagramBase.)
OnNodeDeselected | Raises the NodeDeselected event. (Inherited from DiagramBase.)
OnNodeModified | Raises the NodeModified event. (Inherited from DiagramBase.)
OnNodeModifyCancelled | Raises the NodeModifyCancelled event. (Inherited from DiagramBase.)
OnNodeModifying | Raises the NodeModifying event. (Inherited from DiagramBase.)
OnNodePasted | Raises the NodePasted event. (Inherited from DiagramBase.)
OnNodeSelected | Raises the NodeSelected event. (Inherited from DiagramBase.)
OnNodeSelecting | Raises the NodeSelecting event. (Inherited from DiagramBase.)
OnNodeStartModifying | Raises the NodeStartModifying event. (Inherited from DiagramBase.)
OnNodeTextEdited | Raises the NodeTextEdited event. (Inherited from DiagramBase.)
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode. (Inherited from DiagramBase.)
OnOriginAnchorChanged | Raises the OriginAnchorChanged event. (Inherited from DiagramBase.)
OnQueryAlignTarget | Raises the QueryAlignTarget event. (Inherited from DiagramBase.)
OnRepaint | Raises the Repaint event. (Inherited from DiagramBase.)
OnRequestClipboard | Raises the RequestClipboard event. (Inherited from DiagramBase.)
OnRequestTimer | Raises the RequestTimer event. (Inherited from DiagramBase.)
OnSelectionChanged | Raises the SelectionChanged event. (Inherited from DiagramBase.)
OnSelectionModified | Raises the SelectionModified event. (Inherited from DiagramBase.)
OnSelectionModifying | Raises the SelectionModifying event. (Inherited from DiagramBase.)
OnSerializeTag | Raises the SerializeTag event. (Inherited from DiagramBase.)
OnSetSelfLoopShape | Raises the SetSelfLoopShape event. (Inherited from DiagramBase.)
OnTableSectionCollapsed | Raises the TableSectionCollapsed event. (Inherited from DiagramBase.)
OnTableSectionExpanded | Raises the TableSectionExpanded event. (Inherited from DiagramBase.)
OnTreeCollapsed | Raises the TreeCollapsed event. (Inherited from DiagramBase.)
OnTreeExpanded | Raises the TreeExpanded event. (Inherited from DiagramBase.)
OnTreeItemTextEditing | Raises the TreeItemTextEditing event. (Inherited from DiagramBase.)
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event. (Inherited from DiagramBase.)
OnViewRemoved | Raises the ViewRemoved event. (Inherited from DiagramBase.)

See Also

Diagram Class


MindFusion.Diagramming.Diagram.AddItem Method

Diagram.AddItem Method
[image]

Invoked by the AddItemCmd and RemoveItemCmd classes to effectively add the specified item to the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void AddItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Sub AddItem( _
item As DiagramItem _
)

Parameters

item

The DiagramItem being added to the diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AlignPointToGrid Method

Diagram.AlignPointToGrid Method
[image]

Returns a point of the alignment grid nearest to the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point AlignPointToGrid (
Point point
)

Visual Basic [image] Copy Code

Public Function AlignPointToGrid( _
point As Point _
) As Point

Parameters

point

A point specified in diagram coordinates.

Return Value

A point from the alignment grid.

Remarks

Items created or moved by a user are automatically aligned to the grid. However, if items are placed in the diagram programmatically, their coordinates are set to the specified positions without aligning. In such cases use AlignPointToGrid if items must be placed exactly at grid points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ArrangeLinkLabels Method

Diagram.ArrangeLinkLabels Method
[image]

Rearranges link labels whose AutoArrange property is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ArrangeLinkLabels ()

Visual Basic [image] Copy Code

Public Sub ArrangeLinkLabels ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ChangeUnit Method

Diagram.ChangeUnit Method
[image]

Sets new MeasureUnit value and scales the coordinates of diagram items so that their absolute size remains unchanged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ChangeUnit (
MeasureUnit newUnit
)

Visual Basic [image] Copy Code

Public Sub ChangeUnit( _
newUnit As MeasureUnit _
)

Parameters

newUnit

A MeasureUnit instance specifying the new unit.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ClearAll Method

Diagram.ClearAll Method
[image]

Removes all items and groups from the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ClearAll ()

Visual Basic [image] Copy Code

Public Sub ClearAll ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateImage Method

Diagram.CreateImage Method
[image]

Creates a bitmap containing an image of the diagram.

Overload List

Name | Description
Diagram.CreateImage () | Creates a bitmap image representing this diagram.
Diagram.CreateImage (IGraphicsPath) | Creates a bitmap image representing this diagram, clipped by specified path.
Diagram.CreateImage (IGraphicsPath, Single, Boolean) | Creates a bitmap image representing this diagram, clipped by specified path and scaled by specified factor.
Diagram.CreateImage (Point[]) | Creates a bitmap image representing this diagram, clipped by specified polygon.
Diagram.CreateImage (Point[], Single, Boolean) | Creates a bitmap image representing this diagram, clipped by specified polygon and scaled by specified factor.
Diagram.CreateImage (Rect) | Creates a bitmap image containing specified diagram region.
Diagram.CreateImage (Rect, Single, Boolean) | Creates a bitmap image containing specified diagram region, scaled by specified factor.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateImage Method ()

Diagram.CreateImage Method ()
See Also
[image]

Creates a bitmap image representing this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<ImageSource> CreateImage ()

Visual Basic [image] Copy Code

Public Function CreateImage () As Task(Of ImageSource)

Return Value

An ImageSource instance.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
ExportImage Method


MindFusion.Diagramming.Diagram.CreateImage Method (IGraphicsPath)

Diagram.CreateImage Method (IGraphicsPath)
See Also
[image]

Creates a bitmap image representing this diagram, clipped by specified path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<ImageSource> CreateImage (
IGraphicsPath path
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
path As IGraphicsPath _
) As Task(Of ImageSource)

Parameters

path
An IGraphicsPath instance returned by GraphicsFactory.CreatePath.

Return Value

An ImageSource instance.

Remarks

Pixels outside the specified path are set transparent.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
ExportImage Method


MindFusion.Diagramming.Diagram.CreateImage Method (IGraphicsPath, Single, Boolean)

Diagram.CreateImage Method (IGraphicsPath, Single, Boolean)
See Also
[image]

Creates a bitmap image representing this diagram, clipped by specified path and scaled by specified factor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<ImageSource> CreateImage (
IGraphicsPath clip,
float scale,
bool prepareImages = false
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
clip As IGraphicsPath, _
scale As Single, _
Optional prepareImages As Boolean = False _
) As Task(Of ImageSource)

Parameters

clip

An IGraphicsPath instance returned by GraphicsFactory.CreatePath.

scale

Specifies the scale factor as percentage of the original size.

prepareImages
Optional.

Specifies whether images are pre-rendered within a graphic context prior to an export. This is useful, when the exported diagram is not being drawn on an actual graphic context. The default value is false.

Return Value

An ImageSource instance.

Remarks

Pixels outside the specified path are set transparent.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
ExportImage Method


MindFusion.Diagramming.Diagram.CreateImage Method (Point[])

Diagram.CreateImage Method (Point[])
See Also
[image]

Creates a bitmap image representing this diagram, clipped by specified polygon.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<ImageSource> CreateImage (
Point[] clipPoly
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
clipPoly() As Point _
) As Task(Of ImageSource)

Parameters

clipPoly

An array of Point values.

Return Value

An ImageSource instance.

Remarks

Pixels outside the specified polygon are set transparent.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
ExportImage Method


MindFusion.Diagramming.Diagram.CreateImage Method (Point[], Single, Boolean)

Diagram.CreateImage Method (Point[], Single, Boolean)
See Also
[image]

Creates a bitmap image representing this diagram, clipped by specified polygon and scaled by specified factor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<ImageSource> CreateImage (
Point[] clipPoly,
float scale,
bool prepareImages = false
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
clipPoly() As Point, _
scale As Single, _
Optional prepareImages As Boolean = False _
) As Task(Of ImageSource)

Parameters

clipPoly

An array of Point values.

scale

Specifies the scale factor as percentage of the original size.

prepareImages
Optional.

Specifies whether images are pre-rendered within a graphic context prior to an export. This is useful, when the exported diagram is not being drawn on an actual graphic context. The default value is false.

Return Value

An ImageSource instance.

Remarks

Pixels outside the specified path are set transparent.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
ExportImage Method


MindFusion.Diagramming.Diagram.CreateImage Method (Rect)

Diagram.CreateImage Method (Rect)
See Also
[image]

Creates a bitmap image containing specified diagram region.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<ImageSource> CreateImage (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
bounds As Rect _
) As Task(Of ImageSource)

Parameters

bounds

A Rect specifying what region of the diagram to export, in logical coordinates.

Return Value

An ImageSource instance.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
ExportImage Method


MindFusion.Diagramming.Diagram.CreateImage Method (Rect, Single, Boolean)

Diagram.CreateImage Method (Rect, Single, Boolean)
See Also
[image]

Creates a bitmap image containing specified diagram region, scaled by specified factor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<ImageSource> CreateImage (
Rect viewport,
float scale,
bool prepareImages = false
)

Visual Basic [image] Copy Code

Public Function CreateImage( _
viewport As Rect, _
scale As Single, _
Optional prepareImages As Boolean = False _
) As Task(Of ImageSource)

Parameters

viewport

A Rect specifying what region of the diagram to export, in logical coordinates.

scale

Specifies the scale factor as percentage of the original size.

prepareImages
Optional.

Specifies whether images are pre-rendered within a graphic context prior to an export. This is useful, when the exported diagram is not being drawn on an actual graphic context. The default value is false.

Return Value

An ImageSource instance.

See Also

CreateImage Method Overload List
Diagram Members
Diagram Class
ExportImage Method


MindFusion.Diagramming.Diagram.CreateItem Method

Diagram.CreateItem Method
[image]

Creates an instance of the specified class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual Object CreateItem (
string itemClass
)

Visual Basic [image] Copy Code

Protected Overridable Function CreateItem( _
itemClass As String _
) As Object

Parameters

itemClass

A string identifying class registered via the RegisterClass method.

Return Value

An instance of the class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateMeasureGraphics Method

Diagram.CreateMeasureGraphics Method
[image]

Creates an IGraphics object that can be used to obtain various string size measurements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics CreateMeasureGraphics ()

Visual Basic [image] Copy Code

Public Function CreateMeasureGraphics () As IGraphics

Return Value

An IGraphics object.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CreateThemeFromDefaults Method

Diagram.CreateThemeFromDefaults Method
[image]

Creates a Theme object representing the default properties of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme CreateThemeFromDefaults ()

Visual Basic [image] Copy Code

Public Function CreateThemeFromDefaults () As Theme

Return Value

An instance of the Theme class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Draw Method

Diagram.Draw Method
[image]

Renders the diagram on the specified IGraphics object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void Draw (
IGraphics graphics,
RenderOptions options,
Rect clipRect
)

Visual Basic [image] Copy Code

Public Overridable Sub Draw( _
graphics As IGraphics, _
options As RenderOptions, _
clipRect As Rect _
)

Parameters

graphics

The IGraphics surface to draw the diagram on.

options

A RenderOptions object specifying options for the drawing operation.

clipRect

A Rect specifying the current clipping rectangle.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DrawAlignmentGuides Method

Diagram.DrawAlignmentGuides Method
[image]

Draws the current alignment guides.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DrawAlignmentGuides (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Sub DrawAlignmentGuides( _
graphics As IGraphics _
)

Parameters

graphics

An IGraphics drawing surface.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DrawLayer Method

Diagram.DrawLayer Method
[image]

Renders all diagram items to the specified graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DrawLayer (
IGraphics graphics,
Rect backgroundRect,
int layerIndex,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Sub DrawLayer( _
graphics As IGraphics, _
backgroundRect As Rect, _
layerIndex As Integer, _
options As RenderOptions _
)

Parameters

graphics

backgroundRect

layerIndex

options

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExportImage Method

Diagram.ExportImage Method
[image]

Exports a bitmap file containing an image of the diagram.

Overload List

Name | Description
Diagram.ExportImage (String, IGraphicsPath, Single, Boolean) | Exports a bitmap file containing an image of the diagram, clipped by specified path and scaled by specified factor.
Diagram.ExportImage (String, Point[], Single, Boolean) | Exports a bitmap file containing an image of the diagram, clipped by specified polygon and scaled by specified factor.
Diagram.ExportImage (String, Rect, Single, Boolean) | Exports a bitmap file containing specified diagram region, scaled by specified factor.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExportImage Method (String, IGraphicsPath, Single, Boolean)

Diagram.ExportImage Method (String, IGraphicsPath, Single, Boolean)
See Also
[image]

Exports a bitmap file containing an image of the diagram, clipped by specified path and scaled by specified factor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task ExportImage (
string filePath,
IGraphicsPath clip,
float scale,
bool prepareImages = false
)

Visual Basic [image] Copy Code

Public Function ExportImage( _
filePath As String, _
clip As IGraphicsPath, _
scale As Single, _
Optional prepareImages As Boolean = False _
) As Task

Parameters

filePath

The file name or path.

clip

An IGraphicsPath instance returned by GraphicsFactory.CreatePath.

scale

Specifies the scale factor as percentage of the original size.

prepareImages
Optional.

Specifies whether images are pre-rendered within a graphic context prior to an export. This is useful, when the exported diagram is not being drawn on an actual graphic context. The default value is false.

Return Value

An ImageSource instance.

Remarks

Pixels outside the specified path are set transparent.

See Also

ExportImage Method Overload List
Diagram Members
Diagram Class
CreateImage Method


MindFusion.Diagramming.Diagram.ExportImage Method (String, Point[], Single, Boolean)

Diagram.ExportImage Method (String, Point[], Single, Boolean)
See Also
[image]

Exports a bitmap file containing an image of the diagram, clipped by specified polygon and scaled by specified factor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task ExportImage (
string filePath,
Point[] clipPoly,
float scale,
bool prepareImages = false
)

Visual Basic [image] Copy Code

Public Function ExportImage( _
filePath As String, _
clipPoly() As Point, _
scale As Single, _
Optional prepareImages As Boolean = False _
) As Task

Parameters

filePath

The file name or path.

clipPoly

An array of Point values.

scale

Specifies the scale factor as percentage of the original size.

prepareImages
Optional.

Specifies whether images are pre-rendered within a graphic context prior to an export. This is useful, when the exported diagram is not being drawn on an actual graphic context. The default value is false.

Return Value

An ImageSource instance.

Remarks

Pixels outside the specified path are set transparent.

See Also

ExportImage Method Overload List
Diagram Members
Diagram Class
CreateImage Method


MindFusion.Diagramming.Diagram.ExportImage Method (String, Rect, Single, Boolean)

Diagram.ExportImage Method (String, Rect, Single, Boolean)
See Also
[image]

Exports a bitmap file containing specified diagram region, scaled by specified factor.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task ExportImage (
string filePath,
Rect viewport,
float scale,
bool prepareImages = false
)

Visual Basic [image] Copy Code

Public Function ExportImage( _
filePath As String, _
viewport As Rect, _
scale As Single, _
Optional prepareImages As Boolean = False _
) As Task

Parameters

filePath

The file name or path.

viewport

A Rect specifying what region of the diagram to export, in logical coordinates.

scale

Specifies the scale factor as percentage of the original size.

prepareImages
Optional.

Specifies whether images are pre-rendered within a graphic context prior to an export. This is useful, when the exported diagram is not being drawn on an actual graphic context. The default value is false.

Return Value

An ImageSource instance.

See Also

ExportImage Method Overload List
Diagram Members
Diagram Class
CreateImage Method


MindFusion.Diagramming.Diagram.FindLink Method

Diagram.FindLink Method
[image]

Finds the link that has the specified tag value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink FindLink (
Object tagValue
)

Visual Basic [image] Copy Code

Public Function FindLink( _
tagValue As Object _
) As DiagramLink

Parameters

tagValue

The looked for tag value.

Return Value

An arrow whose Tag equals to the specified value.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.FindLinkById Method

Diagram.FindLinkById Method
[image]

Finds the link that has the specified id value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink FindLinkById (
Object id
)

Visual Basic [image] Copy Code

Public Function FindLinkById( _
id As Object _
) As DiagramLink

Parameters

id

The looked for tag value.

Return Value

An arrow whose Id equals to the specified value.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.FindNode Method

Diagram.FindNode Method
[image]

Finds the node that has the specified tag value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode FindNode (
Object tagValue
)

Visual Basic [image] Copy Code

Public Function FindNode( _
tagValue As Object _
) As DiagramNode

Parameters

tagValue

The looked for tag value.

Return Value

A node whose Tag equals to the specified value.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.FindNodeById Method

Diagram.FindNodeById Method
[image]

Finds the node that has the specified id value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode FindNodeById (
Object id
)

Visual Basic [image] Copy Code

Public Function FindNodeById( _
id As Object _
) As DiagramNode

Parameters

id

The looked for tag value.

Return Value

A node whose Id equals to the specified value.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetContentBounds Method

Diagram.GetContentBounds Method
[image]

Returns the smallest rectangle that bounds all diagram objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetContentBounds (
bool forPrint,
bool onlyVisible
)

Visual Basic [image] Copy Code

Public Function GetContentBounds( _
forPrint As Boolean, _
onlyVisible As Boolean _
) As Rect

Parameters

forPrint

Specifies whether only printable items should be considered.

onlyVisible

Specifies whether only visible items should be considered.

Return Value

The smallest rectangle that bounds all diagram items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetGraphics Method

Diagram.GetGraphics Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics GetGraphics ()

Visual Basic [image] Copy Code

Public Function GetGraphics () As IGraphics

Return Value

An IGraphics object.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetItemAt Method

Diagram.GetItemAt Method
[image]

Returns the top-most diagram item lying at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem GetItemAt (
Point pt,
bool exclLocked
)

Visual Basic [image] Copy Code

Public Function GetItemAt( _
pt As Point, _
exclLocked As Boolean _
) As DiagramItem

Parameters

pt

Specifies a location in the diagram where to look for items.

exclLocked

Specifies whether locked items should be excluded from the search.

Return Value

A DiagramItem instance found at the specified point.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetLinkAt Method

Diagram.GetLinkAt Method
[image]

Returns the top-most link that lies at a specified position.

Overload List

Name | Description
Diagram.GetLinkAt (Point, Double) | Returns the top-most link that lies at the specified position.
Diagram.GetLinkAt (Point, Double, Boolean) | Returns the top-most link that lies at the specified position; optionally exclude locked links from the search.
Diagram.GetLinkAt (Point, Double, Boolean, Int32@) | Returns the top-most link that lies at the specified position; optionally exclude locked links from the search.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetLinkAt Method (Point, Double)

Diagram.GetLinkAt Method (Point, Double)
See Also
[image]

Returns the top-most link that lies at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
Point pt,
double maxDist
)

Visual Basic [image] Copy Code

Public Function GetLinkAt( _
pt As Point, _
maxDist As Double _
) As DiagramLink

Parameters

pt

A Point specifying a diagram point in logical coordinates.

maxDist

The maximum distance allowed between tested links and the specified point.

Return Value

A DiagramLink object found near the specified point.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetLinkAt Method (Point, Double, Boolean)

Diagram.GetLinkAt Method (Point, Double, Boolean)
See Also
[image]

Returns the top-most link that lies at the specified position; optionally exclude locked links from the search.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
Point pt,
double maxDist,
bool exclLocked
)

Visual Basic [image] Copy Code

Public Function GetLinkAt( _
pt As Point, _
maxDist As Double, _
exclLocked As Boolean _
) As DiagramLink

Parameters

pt

A Point specifying a diagram point in logical coordinates.

maxDist

The maximum distance allowed between tested links and the specified point.

exclLocked

Specifies whether locked links should be excluded from the search.

Return Value

A DiagramLink object found near the specified point.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetLinkAt Method (Point, Double, Boolean, Int32@)

Diagram.GetLinkAt Method (Point, Double, Boolean, Int32@)
See Also
[image]

Returns the top-most link that lies at the specified position; optionally exclude locked links from the search.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink GetLinkAt (
Point pt,
double maxDist,
bool exclLocked,
ref int segmNum
)

Visual Basic [image] Copy Code

Public Function GetLinkAt( _
pt As Point, _
maxDist As Double, _
exclLocked As Boolean, _
ByRef segmNum As Integer _
) As DiagramLink

Parameters

pt

A Point specifying a diagram point in logical coordinates.

maxDist

The maximum distance allowed between tested links and the specified point.

exclLocked

Specifies whether locked links should be excluded from the search.

segmNum

Returns the index of the link segment that lies at the specified point.

Return Value

A DiagramLink object found near the specified point.

See Also

GetLinkAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetLinksAt Method

Diagram.GetLinksAt Method
[image]

Returns the links that contain the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetLinksAt (
Point point
)

Visual Basic [image] Copy Code

Public Function GetLinksAt( _
point As Point _
) As DiagramLinkCollection

Parameters

point

A Point structure specifying the location at which to look for links.

Return Value

A DiagramLinkCollection instance containing the links lying at the specified location.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetMeasureGraphics Method

Diagram.GetMeasureGraphics Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics GetMeasureGraphics ()

Visual Basic [image] Copy Code

Public Function GetMeasureGraphics () As IGraphics

Return Value

An IGraphics object.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNearestNode Method

Diagram.GetNearestNode Method
[image]

Returns the nearest node whose bounding rectangle is intersected by the circle, defined by origin point and radius.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNearestNode (
Point point,
double maxDistance,
DiagramNode ignored
)

Visual Basic [image] Copy Code

Public Function GetNearestNode( _
point As Point, _
maxDistance As Double, _
ignored As DiagramNode _
) As DiagramNode

Parameters

point

The point to test.

maxDistance

The maximum distance from the point at which to look for nodes.

ignored

A node that should be ignored.

Return Value

The DiagramNode nearest to the specified point.

Remarks

The last argument is useful when calling this method from NodeCreated and NodeModified handlers and the affected node should not be included in the search.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodeAt Method

Diagram.GetNodeAt Method
[image]

Returns the topmost node that lies at a specified position.

Overload List

Name | Description
Diagram.GetNodeAt (Point) | Returns the topmost node that lies at the specified position.
Diagram.GetNodeAt (Point, Boolean) | Returns the topmost node that lies at the specified position.
Diagram.GetNodeAt (Point, Boolean, Boolean, Double) | Returns the top-most node lying at the specified location.
Diagram.GetNodeAt (Point, Double) | Returns the top-most node that lies at the specified position.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodeAt Method (Point)

Diagram.GetNodeAt Method (Point)
See Also
[image]

Returns the topmost node that lies at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
point As Point _
) As DiagramNode

Parameters

point

A Point specifying a diagram point in logical coordinates.

Return Value

A DiagramNode instance if a node lies at the specified location, otherwise null.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodeAt Method (Point, Boolean)

Diagram.GetNodeAt Method (Point, Boolean)
See Also
[image]

Returns the topmost node that lies at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point,
bool excludeLocked
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
point As Point, _
excludeLocked As Boolean _
) As DiagramNode

Parameters

point

A Point specifying a diagram point in logical coordinates.

excludeLocked

Specifies whether locked nodes should be excluded from the search.

Return Value

A DiagramNode instance if a node lies at the specified location, otherwise null.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodeAt Method (Point, Boolean, Boolean, Double)

Diagram.GetNodeAt Method (Point, Boolean, Boolean, Double)
See Also
[image]

Returns the top-most node lying at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point,
bool excludeLocked,
bool excludeSelected,
double threshold
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
point As Point, _
excludeLocked As Boolean, _
excludeSelected As Boolean, _
threshold As Double _
) As DiagramNode

Parameters

point

Specifies a location in the diagram where to look for nodes.

excludeLocked

Specifies whether locked nodes should be excluded from the search.

excludeSelected

Specifies whether selected nodes should be excluded from the search.

threshold

Allowed distance from the node.

Return Value

A DiagramNode object found at the specified point.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodeAt Method (Point, Double)

Diagram.GetNodeAt Method (Point, Double)
See Also
[image]

Returns the top-most node that lies at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
point As Point, _
threshold As Double _
) As DiagramNode

Parameters

point

A Point specifying a diagram point in logical coordinates.

threshold

Allowed distance from the node.

Return Value

A DiagramNode instance if a node lies at the specified location, otherwise null.

See Also

GetNodeAt Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetNodesAt Method

Diagram.GetNodesAt Method
[image]

Returns the nodes that contain the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection GetNodesAt (
Point point
)

Visual Basic [image] Copy Code

Public Function GetNodesAt( _
point As Point _
) As DiagramNodeCollection

Parameters

point

A Point instance identifying a diagram location.

Return Value

An instance of the DiagramNodeCollection class containing all found nodes; null if no node has been found.

Remarks

This method gives you the possibility to specify search options when looking for the nodes occupying some location in the diagram document.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GetValue Method

Diagram.GetValue Method
[image]

Gets the effective value of the style property with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Object GetValue (
string name
)

Visual Basic [image] Copy Code

Protected Function GetValue( _
name As String _
) As Object

Parameters

name

The name of the property to get.

Return Value

An object representing the effective property value.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HitTestLabels Method

Diagram.HitTestLabels Method
[image]

Returns the item label located at specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ItemLabel HitTestLabels (
Point point
)

Visual Basic [image] Copy Code

Public Function HitTestLabels( _
point As Point _
) As ItemLabel

Parameters

point

A PointF specifying where to look for labels.

Return Value

An ItemLabel instance, or null if there was no label found.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HitTestManipulators Method

Diagram.HitTestManipulators Method
[image]

Tests whether the specified point is within the manipulator of a diagram object and triggers the manipulator.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Manipulator HitTestManipulators (
Point pt
)

Visual Basic [image] Copy Code

Public Function HitTestManipulators( _
pt As Point _
) As Manipulator

Parameters

pt

A Point instance specifying the point to test.

Return Value

An instance of the Manipulator class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Invalidate Method

Diagram.Invalidate Method
[image]

Invalidates the diagram.

Overload List

Name | Description
Diagram.Invalidate () | Causes the entire visible diagram area to be repainted.
Diagram.Invalidate (Boolean) | Causes the entire visible diagram area to be repainted.
Diagram.Invalidate (Object, Rect) | Invalidates the specified document region.
Diagram.Invalidate (Rect) | Invalidates the specified document region.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Invalidate Method ()

Diagram.Invalidate Method ()
See Also
[image]

Causes the entire visible diagram area to be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Invalidate ()

Visual Basic [image] Copy Code

Public Sub Invalidate ()

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Invalidate Method (Boolean)

Diagram.Invalidate Method (Boolean)
See Also
[image]

Causes the entire visible diagram area to be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Invalidate (
bool redrawCacheImage
)

Visual Basic [image] Copy Code

Public Sub Invalidate( _
redrawCacheImage As Boolean _
)

Parameters

redrawCacheImage

A boolean value specifying whether the diagram cache image used during modification should be re-created.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Invalidate Method (Object, Rect)

Diagram.Invalidate Method (Object, Rect)
See Also
[image]

Invalidates the specified document region.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Invalidate (
Object sender,
Rect invalidRect
)

Visual Basic [image] Copy Code

Public Sub Invalidate( _
sender As Object, _
invalidRect As Rect _
)

Parameters

sender

The object that causes the diagram invalidation.

invalidRect

A Rectangle instance specifying the region that should be repainted. If not specified, the whole diagram will be repainted.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Invalidate Method (Rect)

Diagram.Invalidate Method (Rect)
See Also
[image]

Invalidates the specified document region.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Invalidate (
Rect invalidRect
)

Visual Basic [image] Copy Code

Public Sub Invalidate( _
invalidRect As Rect _
)

Parameters

invalidRect

A Rectangle instance specifying the region that should be repainted. If not specified, the whole diagram will be repainted.

See Also

Invalidate Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.InvalidateZOrder Method

Diagram.InvalidateZOrder Method
[image]

Forces a new sort of the Z order list before next redraw.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InvalidateZOrder ()

Visual Basic [image] Copy Code

Public Sub InvalidateZOrder ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsClassRegistered Method

Diagram.IsClassRegistered Method
[image]

Checks if a class is registered for serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool IsClassRegistered (
Type classType
)

Visual Basic [image] Copy Code

Public Shared Function IsClassRegistered( _
classType As Type _
) As Boolean

Parameters

classType

A Type instance identifying the class.

Return Value

true if the class is registered; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsClientClassRegistered Method

Diagram.IsClientClassRegistered Method
[image]

Checks if a class is registered for JSON serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool IsClientClassRegistered (
Type classType
)

Visual Basic [image] Copy Code

Public Shared Function IsClientClassRegistered( _
classType As Type _
) As Boolean

Parameters

classType

A Type instance identifying the class.

Return Value

true if the class is registered; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsItemInteractive Method

Diagram.IsItemInteractive Method
[image]

Checks if the specified item can be modified interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsItemInteractive (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemInteractive( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true, if the item is currently visible and unlocked and it is not associated with a hidden or locked layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsItemLocked Method

Diagram.IsItemLocked Method
[image]

Checks if the specified item is locked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsItemLocked (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemLocked( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true, if the item's Locked property is set to true or if the item is associated with a locked layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.IsItemVisible Method

Diagram.IsItemVisible Method
[image]

Checks if the specified item is currently visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsItemVisible (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IsItemVisible( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to check.

Return Value

true if the item's Visible property is set to true and the item is not associated with a hidden layer; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromJson Method

Diagram.LoadFromJson Method
[image]

Loads the diagram from a JSON-formatted string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void LoadFromJson (
string json
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromJson( _
json As String _
)

Parameters

json

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromJsonFile Method

Diagram.LoadFromJsonFile Method
[image]

Loads the diagram from a JSON file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromJsonFile (
string fileName
)

Visual Basic [image] Copy Code

Public Sub LoadFromJsonFile( _
fileName As String _
)

Parameters

fileName

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromJsonObject Method

Diagram.LoadFromJsonObject Method
[image]

Loads the diagram from a JSON object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void LoadFromJsonObject (
JsonObject diagramObj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromJsonObject( _
diagramObj As JsonObject, _
context As JsonPersistContext _
)

Parameters

diagramObj

context

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromString Method

Diagram.LoadFromString Method
[image]

Loads a diagram from the specified string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromString (
string str
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
str As String _
)

Parameters

str

A string containing the serialized diagram contents.

Remarks

Loads a diagram document from a string. The string must have been created by the SaveToString method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromXml Method

Diagram.LoadFromXml Method
[image]

Loads the diagram.

Overload List

Name | Description
Diagram.LoadFromXml (Stream) | Loads the diagram from a stream.
Diagram.LoadFromXml (Stream, Boolean) | Loads the diagram from a stream.
Diagram.LoadFromXml (XDocument) | Loads the diagram from an XML document.
Diagram.LoadFromXml (XDocument, Boolean) | Loads the diagram from an XML document.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromXml Method (Stream)

Diagram.LoadFromXml Method (Stream)
See Also
[image]

Loads the diagram from a stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
stream As Stream _
)

Parameters

stream

The stream to load from.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromXml Method (Stream, Boolean)

Diagram.LoadFromXml Method (Stream, Boolean)
See Also
[image]

Loads the diagram from a stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
Stream stream,
bool loadDiagramProperties
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
stream As Stream, _
loadDiagramProperties As Boolean _
)

Parameters

stream

The stream to load from.

loadDiagramProperties

true to load values of the diagram properties; false to load only the diagram items.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromXml Method (XDocument)

Diagram.LoadFromXml Method (XDocument)
See Also
[image]

Loads the diagram from an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void LoadFromXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromXml( _
document As XDocument _
)

Parameters

document

The XDocument to load from.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LoadFromXml Method (XDocument, Boolean)

Diagram.LoadFromXml Method (XDocument, Boolean)
See Also
[image]

Loads the diagram from an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void LoadFromXml (
XDocument document,
bool loadDiagramProperties
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromXml( _
document As XDocument, _
loadDiagramProperties As Boolean _
)

Parameters

document

The XDocument to load from.

loadDiagramProperties

true to load values of the diagram properties; false to load only the diagram items.

See Also

LoadFromXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Navigate Method

Diagram.Navigate Method
[image]

Selects the nearest item in the specified direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Navigate (
Point directionVector
)

Visual Basic [image] Copy Code

Public Sub Navigate( _
directionVector As Point _
)

Parameters

directionVector

A Point object specifying the direction vector.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.PrepareImages Method

Diagram.PrepareImages Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task PrepareImages ()

Visual Basic [image] Copy Code

Public Function PrepareImages () As Task

Return Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseCellTextEdited Method

Diagram.RaiseCellTextEdited Method
[image]

Raises the CellTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseCellTextEdited (
TableNode.Cell cell,
string oldText,
string newText,
int column,
int row
)

Visual Basic [image] Copy Code

Public Sub RaiseCellTextEdited( _
cell As TableNode.Cell, _
oldText As String, _
newText As String, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

oldText

The old text of the cell.

newText

The new text of the cell.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseCellTextEditing Method

Diagram.RaiseCellTextEditing Method
[image]

Raises the CellTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseCellTextEditing (
TableNode table,
int column,
int row
)

Visual Basic [image] Copy Code

Public Function RaiseCellTextEditing( _
table As TableNode, _
column As Integer, _
row As Integer _
) As Boolean

Parameters

table

The TableNode related to the event.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

Return Value

true if the in-place editing operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseClicked Method

Diagram.RaiseClicked Method
[image]

Raises the Clicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseClicked (
Point position
)

Visual Basic [image] Copy Code

Public Sub RaiseClicked( _
position As Point _
)

Parameters

position

The touch position, in document coordinates.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseCreated Method

Diagram.RaiseCreated Method
[image]

Raises the appropriate *Created event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseCreated (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub RaiseCreated( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseDeleting Method

Diagram.RaiseDeleting Method
[image]

Raises the appropriate *Deleting event according to the type of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseDeleting (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function RaiseDeleting( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem related to the event.

Return Value

true if the operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseLinkTextEdited Method

Diagram.RaiseLinkTextEdited Method
[image]

Overload List

Name | Description
Diagram.RaiseLinkTextEdited (DiagramLink, String, String) | Raises the LinkTextEdited event.
Diagram.RaiseLinkTextEdited (DiagramLink, String, String, LinkLabel) | Raises the LinkTextEdited event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseLinkTextEdited Method (DiagramLink, String, String)

Diagram.RaiseLinkTextEdited Method (DiagramLink, String, String)
See Also
[image]

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseLinkTextEdited (
DiagramLink link,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub RaiseLinkTextEdited( _
link As DiagramLink, _
oldText As String, _
newText As String _
)

Parameters

link

The DiagramLink related to the event.

oldText

The old text of the link.

newText

The new text of the link.

See Also

RaiseLinkTextEdited Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseLinkTextEdited Method (DiagramLink, String, String, LinkLabel)

Diagram.RaiseLinkTextEdited Method (DiagramLink, String, String, LinkLabel)
See Also
[image]

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseLinkTextEdited (
DiagramLink link,
string oldText,
string newText,
LinkLabel label
)

Visual Basic [image] Copy Code

Public Sub RaiseLinkTextEdited( _
link As DiagramLink, _
oldText As String, _
newText As String, _
label As LinkLabel _
)

Parameters

link

oldText

newText

label

See Also

RaiseLinkTextEdited Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseLinkTextEditing Method

Diagram.RaiseLinkTextEditing Method
[image]

Overload List

Name | Description
Diagram.RaiseLinkTextEditing (DiagramLink) | Raises the LinkTextEditing event to validate entering inplace edit mode.
Diagram.RaiseLinkTextEditing (DiagramLink, LinkLabel) | Raises the LinkTextEditing event to validate entering inplace edit mode.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseLinkTextEditing Method (DiagramLink)

Diagram.RaiseLinkTextEditing Method (DiagramLink)
See Also
[image]

Raises the LinkTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseLinkTextEditing (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function RaiseLinkTextEditing( _
link As DiagramLink _
) As Boolean

Parameters

link

The DiagramLink related to the event.

Return Value

See Also

RaiseLinkTextEditing Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseLinkTextEditing Method (DiagramLink, LinkLabel)

Diagram.RaiseLinkTextEditing Method (DiagramLink, LinkLabel)
See Also
[image]

Raises the LinkTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseLinkTextEditing (
DiagramLink link,
LinkLabel label
)

Visual Basic [image] Copy Code

Public Function RaiseLinkTextEditing( _
link As DiagramLink, _
label As LinkLabel _
) As Boolean

Parameters

link

label

Return Value

See Also

RaiseLinkTextEditing Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseNodeTextEdited Method

Diagram.RaiseNodeTextEdited Method
[image]

Overload List

Name | Description
Diagram.RaiseNodeTextEdited (DiagramNode, String, String) | Raises the NodeTextEdited event.
Diagram.RaiseNodeTextEdited (DiagramNode, String, String, NodeLabel) | Raises the NodeTextEdited event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseNodeTextEdited Method (DiagramNode, String, String)

Diagram.RaiseNodeTextEdited Method (DiagramNode, String, String)
See Also
[image]

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseNodeTextEdited (
DiagramNode node,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public Sub RaiseNodeTextEdited( _
node As DiagramNode, _
oldText As String, _
newText As String _
)

Parameters

node

The DiagramNode related to the event.

oldText

The old text of the node.

newText

The new text of the node.

See Also

RaiseNodeTextEdited Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseNodeTextEdited Method (DiagramNode, String, String, NodeLabel)

Diagram.RaiseNodeTextEdited Method (DiagramNode, String, String, NodeLabel)
See Also
[image]

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseNodeTextEdited (
DiagramNode node,
string oldText,
string newText,
NodeLabel label
)

Visual Basic [image] Copy Code

Public Sub RaiseNodeTextEdited( _
node As DiagramNode, _
oldText As String, _
newText As String, _
label As NodeLabel _
)

Parameters

node

oldText

newText

label

See Also

RaiseNodeTextEdited Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseNodeTextEditing Method

Diagram.RaiseNodeTextEditing Method
[image]

Overload List

Name | Description
Diagram.RaiseNodeTextEditing (DiagramNode) | Raises the NodeTextEditing event to validate entering inplace edit mode.
Diagram.RaiseNodeTextEditing (DiagramNode, NodeLabel) | Raises the NodeTextEditing event to validate entering inplace edit mode.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseNodeTextEditing Method (DiagramNode)

Diagram.RaiseNodeTextEditing Method (DiagramNode)
See Also
[image]

Raises the NodeTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseNodeTextEditing (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function RaiseNodeTextEditing( _
node As DiagramNode _
) As Boolean

Parameters

node

The DiagramNode related to the event.

Return Value

See Also

RaiseNodeTextEditing Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseNodeTextEditing Method (DiagramNode, NodeLabel)

Diagram.RaiseNodeTextEditing Method (DiagramNode, NodeLabel)
See Also
[image]

Raises the NodeTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseNodeTextEditing (
DiagramNode node,
NodeLabel label = null
)

Visual Basic [image] Copy Code

Public Function RaiseNodeTextEditing( _
node As DiagramNode, _
Optional label As NodeLabel = Nothing _
) As Boolean

Parameters

node

label
Optional.

Return Value

See Also

RaiseNodeTextEditing Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaisePasted Method

Diagram.RaisePasted Method
[image]

Raises the appropriate Pasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaisePasted (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub RaisePasted( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseSelecting Method

Diagram.RaiseSelecting Method
[image]

Raises the appropriate Selecting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseSelecting (
DiagramItem item,
Point position
)

Visual Basic [image] Copy Code

Public Function RaiseSelecting( _
item As DiagramItem, _
position As Point _
) As Boolean

Parameters

item

The DiagramItem related to the event.

position

The touch position, in document coordinates.

Return Value

true if the operation has been confirmed; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseTreeItemTextEditing Method

Diagram.RaiseTreeItemTextEditing Method
[image]

Raises the TreeItemTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RaiseTreeItemTextEditing (
TreeViewItem item
)

Visual Basic [image] Copy Code

Public Function RaiseTreeItemTextEditing( _
item As TreeViewItem _
) As Boolean

Parameters

item

The TreeViewItem instance related to the event.

Return Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RaiseViewRemoved Method

Diagram.RaiseViewRemoved Method
[image]

Raises the ViewRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseViewRemoved ()

Visual Basic [image] Copy Code

Public Sub RaiseViewRemoved ()

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterClass Method

Diagram.RegisterClass Method
[image]

Overload List

Name | Description
Diagram.RegisterClass (Type, String, Int32) | Registers a diagram item or lane header class for serialization support.
Diagram.RegisterClass (Type, String, Int32, String) | Registers a diagram item or lane header class for serialization support.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterClass Method (Type, String, Int32)

Diagram.RegisterClass Method (Type, String, Int32)
See Also
[image]

Registers a diagram item or lane header class for serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterClass (
Type classType,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterClass( _
classType As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

classType

A Type instance identifying the class.

classId

A class identifier to use when saving and loading objects of the specified type.

classVersion

A revision number of the serialization format.

See Also

RegisterClass Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterClass Method (Type, String, Int32, String)

Diagram.RegisterClass Method (Type, String, Int32, String)
See Also
[image]

Registers a diagram item or lane header class for serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterClass (
Type classType,
string classId,
int classVersion,
string clientClass
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterClass( _
classType As Type, _
classId As String, _
classVersion As Integer, _
clientClass As String _
)

Parameters

classType

A Type instance identifying the class.

classId

A class identifier to use when saving and loading objects of the specified type.

classVersion

A revision number of the serialization format.

clientClass

A class identifier to use when serializing item of the specified type to JSON.

See Also

RegisterClass Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterDefaultStyle Method

Diagram.RegisterDefaultStyle Method
[image]

Registers a default style for the objects of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterDefaultStyle (
Type type,
Style style
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterDefaultStyle( _
type As Type, _
style As Style _
)

Parameters

type

style

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterItemClass Method

Diagram.RegisterItemClass Method
[image]

Overload List

Name | Description
Diagram.RegisterItemClass (Type, String, Int32) | Registers a diagram item class for serialization support.
Diagram.RegisterItemClass (Type, String, Int32, String) | Registers a diagram item class for serialization support.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterItemClass Method (Type, String, Int32)

Diagram.RegisterItemClass Method (Type, String, Int32)
See Also
[image]

Registers a diagram item class for serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterItemClass( _
itemClass As Type, _
classId As String, _
classVersion As Integer _
)

Parameters

itemClass

A Type instance identifying the item class.

classId

A class identifier to use when saving and loading items of the specified type.

classVersion

A revision number of the item's class serialization format.

Remarks

When using custom item types, use this method to enable saving and loading the custom item instances to/from XML or binary files. The class id string is written before each item's data, and when loading items later that string indicates what class instance to create and let it load the subsequent data. The following class identifiers are reserved and should not be used by your application: "std:DiagramLink", "std:ShapeNode", "std:TableNode", "std:ContainerNode" and "std:ControlNode".

The version identifier must be increased when the format in which items are saved changes. It can be used when loading files to let your application load items data from an older format.

Note
All custom item classes must provide a parameterless constructor, or one that takes a Diagram argument. Failing to do so would result in exceptions during the load process, since the diagram will be unable to create items from the custom type.

See Also

RegisterItemClass Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RegisterItemClass Method (Type, String, Int32, String)

Diagram.RegisterItemClass Method (Type, String, Int32, String)
See Also
[image]

Registers a diagram item class for serialization support.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterItemClass (
Type itemClass,
string classId,
int classVersion,
string clientClass
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterItemClass( _
itemClass As Type, _
classId As String, _
classVersion As Integer, _
clientClass As String _
)

Parameters

itemClass

A Type instance identifying the item class.

classId

A class identifier to use when saving and loading items of the specified type.

classVersion

A revision number of the item's class serialization format.

clientClass

A class identifier to use when serializing item of the specified type to JSON.

See Also

RegisterItemClass Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ResizeToFitItem Method

Diagram.ResizeToFitItem Method
[image]

Resize the document extents so that the specified item is contained within.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItem( _
item As DiagramItem _
)

Parameters

item

The diagram item contained in the document area.

Remarks

Resizes the document area to fit the specified diagram item.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ResizeToFitItems Method

Diagram.ResizeToFitItems Method
[image]

Resizes the document scrollable area so it fits all diagram items.

Overload List

Name | Description
Diagram.ResizeToFitItems (Double) | Resizes the document scrollable area so it fits all diagram items.
Diagram.ResizeToFitItems (Double, Boolean) | Resizes the document scrollable area so it fits all diagram items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ResizeToFitItems Method (Double)

Diagram.ResizeToFitItems Method (Double)
See Also
[image]

Resizes the document scrollable area so it fits all diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitItems (
double borderGap
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItems( _
borderGap As Double _
)

Parameters

borderGap

A gap that should be left as a border around the diagram.

Remarks

Resizes the document area to be just as big as needed, for example, the smallest rectangle containing all diagram items. For aesthetic reasons, additional space can be left around the outmost items as a margin. Invoking the method on an empty document produces no result.

See Also

ResizeToFitItems Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ResizeToFitItems Method (Double, Boolean)

Diagram.ResizeToFitItems Method (Double, Boolean)
See Also
[image]

Resizes the document scrollable area so it fits all diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitItems (
double borderGap,
bool onlyVisible
)

Visual Basic [image] Copy Code

Public Sub ResizeToFitItems( _
borderGap As Double, _
onlyVisible As Boolean _
)

Parameters

borderGap

A gap that should be left as a border around the diagram.

onlyVisible

Specifies whether only the bounds of the Visible items should be included in the new document area.

Remarks

Resizes the document area to be just as big as needed, for example the smallest rectangle containing all diagram items. For aesthetic reasons, additional space can be left around the outmost items as a margin. Invoking the method on an empty document produces no result.

See Also

ResizeToFitItems Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RouteAllLinks Method

Diagram.RouteAllLinks Method
[image]

Performs routing on all links ignoring their AutoRoute flag.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RouteAllLinks ()

Visual Basic [image] Copy Code

Public Sub RouteAllLinks ()

Remarks

Each link is routed so that it goes the shortest possible way between the nodes it links without crossing any other nodes. To do so, this method might modify the number of link segments. The value of AutoRoute is not considered when RouteAllLinks executes.

RoutingOptions allows tuning the routing algorithm. The most important options are the cost values exposed as LengthCost, TurnCost and CrossingCost properties. They greatly influence the shape of the generated route.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToJson Method

Diagram.SaveToJson Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Task<string> SaveToJson ()

Visual Basic [image] Copy Code

Public Overridable Function SaveToJson () As Task(Of String)

Return Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToJsonFile Method

Diagram.SaveToJsonFile Method
[image]

Saves the diagram into a JSON file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task SaveToJsonFile (
string fileName
)

Visual Basic [image] Copy Code

Public Function SaveToJsonFile( _
fileName As String _
) As Task

Parameters

fileName

Return Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToJsonObject Method

Diagram.SaveToJsonObject Method
[image]

Saves the diagram to a JSON object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Task SaveToJsonObject (
JsonObject diagramObj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Public Overridable Function SaveToJsonObject( _
diagramObj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

diagramObj

context

Return Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToString Method

Diagram.SaveToString Method
[image]

Encodes the diagram contents into an ASCII string.

Overload List

Name | Description
Diagram.SaveToString () | Saves the diagram as an ASCII string.
Diagram.SaveToString (SaveToStringFormat) | Saves the diagram as an ASCII string.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToString Method ()

Diagram.SaveToString Method ()
See Also
[image]

Saves the diagram as an ASCII string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<string> SaveToString ()

Visual Basic [image] Copy Code

Public Function SaveToString () As Task(Of String)

Return Value

A string containing the encoded diagram data.

See Also

SaveToString Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToString Method (SaveToStringFormat)

Diagram.SaveToString Method (SaveToStringFormat)
See Also
[image]

Saves the diagram as an ASCII string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<string> SaveToString (
SaveToStringFormat format
)

Visual Basic [image] Copy Code

Public Function SaveToString( _
format As SaveToStringFormat _
) As Task(Of String)

Parameters

format

A member of the SaveToStringFormat enumeration.

Return Value

A string containing the encoded diagram data.

See Also

SaveToString Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToXml Method

Diagram.SaveToXml Method
[image]

Saves the diagram to an XML document.

Overload List

Name | Description
Diagram.SaveToXml (Stream) | Saves the diagram into an stream in a XML format.
Diagram.SaveToXml (XDocument) | Saves the diagram into an XML document.
Diagram.SaveToXml (XDocument, Boolean) | Saves the diagram into an XML document.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToXml Method (Stream)

Diagram.SaveToXml Method (Stream)
See Also
[image]

Saves the diagram into an stream in a XML format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task SaveToXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Function SaveToXml( _
stream As Stream _
) As Task

Parameters

stream

The stream to save to.

Return Value

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToXml Method (XDocument)

Diagram.SaveToXml Method (XDocument)
See Also
[image]

Saves the diagram into an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Task SaveToXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Overridable Function SaveToXml( _
document As XDocument _
) As Task

Parameters

document

A XDocument object where the diagram should be saved.

Return Value

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SaveToXml Method (XDocument, Boolean)

Diagram.SaveToXml Method (XDocument, Boolean)
See Also
[image]

Saves the diagram into an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Task SaveToXml (
XDocument document,
bool includeUnalteredProperties
)

Visual Basic [image] Copy Code

Public Overridable Function SaveToXml( _
document As XDocument, _
includeUnalteredProperties As Boolean _
) As Task

Parameters

document

A XDocument object where the diagram should be saved.

includeUnalteredProperties

true if properties that have their default value should be saved; otherwise, false.

Return Value

See Also

SaveToXml Method Overload List
Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SetShadowOffset Method

Diagram.SetShadowOffset Method
[image]

Sets the default offset at which objects' shadows are drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetShadowOffset (
double x,
double y
)

Visual Basic [image] Copy Code

Public Sub SetShadowOffset( _
x As Double, _
y As Double _
)

Parameters

x

The horizontal offset of the item shadow.

y

The vertical offset of the item shadow.

Remarks

Use the method to draw shadows that are closer or further to the item they belong to. The values are applied respectively to the ShadowOffsetX and ShadowOffsetY properties.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram Properties

Diagram Properties
[image]

Public Properties

Name | Description
ActiveItem | Gets or sets the active diagram element.
ActiveItemHandlesStyle | Gets the visual style of adjustment handles of the active item.
ActiveLayer | Gets or sets the zero-based index of the active layer.
AdjustmentHandlesSize | Gets or sets the size of the handles, which appear around selected objects, expressed in millimeters.
AlignmentGuidePen | Gets or sets the pen used to draw alignment guides.
AlignToGrid | Gets or sets a value indicating whether the items in the diagram are aligned to grid.
AllowLinksRepeat | Gets or sets a value indicating whether more than one arrow can link the same origin and destination diagram nodes.
AllowMultipleResize | Gets or sets whether multiple selected nodes can be resized simultaneously.
AllowSelfLoops | Gets or sets value indicating whether reflexive links are allowed.
AllowSplitLinks | Gets or sets a value indicating whether arrow segments can be added and removed interactively.
AllowUnanchoredLinks | Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.
AllowUnconnectedLinks | Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.
AutoAlignDistance | Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders of other nodes.
AutoAlignNodes | Gets or sets whether nodes should automatically align to the borders of other nodes during user interaction.
AutoCloseDistance | Gets or sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically.
AutoHighlightRows | Gets or sets whether a table row should be highlighted when the user clicks on it.
AutoResize | Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.
AutoSnapDistance | Specifies the maximum distance at which links auto-snap to nodes.
AutoSnapLinks | Gets or sets the default value for the AutoSnapToNode property of new links.
BackBrush | Gets or sets the brush used for painting the diagram background.
BackgroundImage | Gets or sets the diagram background image.
BackgroundImageAlign | Gets or set a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.
Bounds | Gets or sets a value representing the size of the diagram's scrollable area.
BoundsPen | The pen with which the document bounds should be drawn.
CellCustomDraw | Gets or sets the default type of custom painting done on the cells of tables.
CellFrameStyle | Gets or sets the default cell border style of new tables.
ContainerCaption | Specifies the default container caption text.
ContainerCaptionHeight | Specifies the default container caption height.
ContainerHighlightPen | Gets or sets the default value for the HighlightPen property of containers.
ContainerMargin | Gets or sets the default value for the Margin property of containers.
ContainerMinimumSize | Gets or sets the default value for the MinimumSize property of containers.
ContainerNodeStyle | Gets the theme-level style for container nodes.
ContainersFoldable | Gets or sets the default value for the Foldable property of containers.
CrossingRadius | Gets or sets the radius length of decorations displayed at arrow intersection points.
DefaultShape | Gets or sets the default shape of shape nodes.
DiagramLinkStyle | Gets the theme-level style for diagram links.
DiagramStyle | Gets the theme-level style for the diagram.
Dirty | Gets or sets a value indicating whether the diagram has changed since the last save.
DisabledHandlesStyle | Gets the visual style of disabled adjustment handles.
DynamicLinks | Gets or sets the default value for the Dynamic property of new links.
EffectiveBackBrush | Gets the currently effective background brush of the diagram.
EnableLanes | Gets or sets whether lanes are enabled.
ExpandButtonAction | Specifies what should happen when a user clicks the +/- button that is displayed near expandable nodes.
ExpandButtonPosition | Gets or sets where expand/collapse buttons are located relatively to their nodes.
ExpandOnIncoming | Gets or sets a value, indicating in which direction object hierarchies are expanded.
ExteriorBrush | Gets or sets the brush used for painting the area outside document bounds.
Factory | Gets a Factory instance that lets you add programmatically new items to the diagram.
FoldedContainerSize | Gets or sets the size of folded containers.
Font | Gets or sets the default font.
FreeFormAttractDistance | Gets or sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too.
FreeFormTargets | An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes.
GridColor | Gets or sets the color of the grid points.
GridOffsetX | Gets or sets the horizontal offset of the first column of grid points.
GridOffsetY | Gets or sets the vertical offset of the first row of grid points.
GridSizeX | Gets or sets the horizontal distance between adjacent grid points.
GridSizeY | Gets or sets the vertical distance between adjacent grid points.
GridStyle | Gets or sets the visual style of the alignment grid.
HitTestPriority | Gets or sets a value indicating the order in which items are hit-tested.
Items | Gets a read-only collection of all objects in this diagram.
JsonOptions | A JsonOptions object providing properties for customizing the JSON serialization process.
LaneGrid | Gets the lane grid.
Layers | Gets a list of the layers in the current diagram.
LicenseKey | Gets or sets the license key of the control.
LinkBaseShape | Gets or sets the shape displayed at the base of new links.
LinkBaseShapeSize | Gets or sets the default size of the base of new links.
LinkBrush | Gets or sets the default value for the Brush property of links.
LinkCascadeOrientation | Gets or sets the initial orientation of the first segment of new cascading links.
LinkCrossings | Gets or sets how to render the intersection points where links cross their paths.
LinkCustomDraw | Gets or sets the default type of custom painting done on links.
LinkEndsMovable | Gets or sets a value indicating whether link ends can be moved by users after the link is created.
LinkHandlesStyle | Gets or sets the default value for the HandlesStyle property of new links.
LinkHeadShape | Gets or sets the shape displayed as head of new links.
LinkHeadShapeSize | Gets or sets the default size of arrowheads.
LinkHitDistance | Gets or sets a value specifying how far from a link a click is still considered a hit, expressed in millimeters.
LinkIntermediateShape | Gets or sets default shape to be displayed in the middle of each segment of links.
LinkIntermediateShapeSize | Gets or sets the default size of the shapes at middles of arrow segments.
LinkPen | Gets or sets the default value for the Pen and HeadPen properties of links.
LinkRouter | Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.
Links | Gets a collection of all links in this diagram.
LinkSegments | Gets or sets the default number of arrow segments.
LinkShape | Gets or sets the default style of arrow objects.
LinksRetainForm | Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.
LinkText | Gets or sets the default text of links.
LinkTextStyle | Gets or sets default placement and orientation for links' text.
MeasureUnit | Gets or sets the unit of measure used for logical coordinates in this diagram.
MergeThreshold | Gets or sets the maximum distance between adjacent control points of an arrow at which the respective segments can be merged.
MinimumNodeSize | Gets or sets the minimum node size that the user is allowed to set.
NodeEffects | Gets a collection with all effects applied to the nodes of this diagram.
Nodes | Gets a collection of all nodes in this diagram.
NodesExpandable | Gets or sets a value indicating whether newly created nodes can be expanded.
NowLoading | Gets a value indicating whether the diagram data is now being loaded from a file.
RecursiveExpand | Gets or sets value indicating how a tree is expanded.
RestrictItemsToBounds | Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.
RoundedLinks | Specifies whether the joins between segments of Polyline and Cascading links should be rounded.
RoundedLinksRadius | Gets or sets the radius of arc joins of rounded links' segments.
RoundRectFactor | Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.
RouteLinks | Gets or sets a value specifying whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.
RoutingOptions | Gets an object, which allows customizing various parameters of the link routing algorithm.
RowHighlightBrush | Gets or sets the Brush used to fill highlighted table rows.
SelectAfterCreate | Gets or sets value indicating whether newly created objects are automatically selected.
SelectedItemHandlesStyle | Gets the visual style of adjustment handles of selected items.
Selection | Gets the Selection instance that represents the selection of items in this diagram.
SelectionOnTop | Gets or sets a value indicating whether selected items should be painted on top of other items.
ShadowBrush | Gets or sets the default brush used for painting the items' shadows.
ShadowOffsetX | Gets or sets the horizontal offset of objects' shadows.
ShadowOffsetY | Gets or sets the vertical offset of objects' shadows.
ShadowsStyle | Gets or sets the style for rendering shadows.
ShapeBrush | Gets or sets the default value for the Brush property of shape nodes.
ShapeCustomDraw | Gets or sets the default type of custom painting done for shape nodes.
ShapeHandlesStyle | Gets or sets the default value for the HandlesStyle property of new shape nodes.
ShapeNodeStyle | Gets the theme-level style for shape nodes.
ShapeOrientation | Gets or sets the default value for the ShapeOrientation property of shape nodes.
ShapePen | Gets or sets the default value for the Pen property of shape nodes.
ShapeText | Gets or sets the default text of shape nodes.
ShowAnchors | Gets or sets a value indicating whether and when node anchor points should be displayed.
ShowDisabledHandles | Gets or sets a value indicating whether manipulation handles are painted when they are disabled.
ShowGrid | Gets or sets a value indicating whether the alignment grid is visible.
ShowHandlesOnDrag | Gets or sets a value indicating whether to display selection handles of pointed objects while another object is being modified.
SnapToAnchor | Gets or sets when arrow end points should be aligned to the nearest anchor points.
Style | Gets or sets the style associated with the diagram.
TableBrush | Gets or sets the default value for the Brush property of tables.
TableCaption | Gets or sets the default text for tables' captions.
TableCaptionHeight | Gets or sets the default height of table captions.
TableColumnCount | Gets or sets the default number of table columns.
TableColumnWidth | Gets or sets the default width of tables' columns.
TableConnectionStyle | Gets or sets a value indicating whether drawing an arrow between tables should link rows of those tables, or the tables as whole entities.
TableCustomDraw | Gets or sets the default type of custom painting done on tables.
TableHandlesStyle | Gets or sets the default value for the HandlesStyle property of new tables.
TableNodeStyle | Gets the theme-level style for table nodes.
TablePen | Gets or sets the default value for the Pen property of tables.
TableRowCount | Gets or sets the default number of table rows.
TableRowHeight | Gets or sets the default height of tables' rows.
TableShape | Gets or sets the default style of new tables.
TablesScrollable | Gets or sets the default value for the Scrollable property of new tables.
Tag | Gets or sets custom data associated with this diagram.
TextColor | Gets or sets the default color of text displayed inside diagram items.
TextFormat | Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.
Theme | Gets or sets the theme associated with the diagram.
TouchRadius | Gets or sets the distance tolerance during hit-testing, expressed in millimeters, or null, to use the default tolerance.
TreeViewNodeStyle | Gets the theme-level style for tree view nodes.
ValidityChecks | Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.

See Also

Diagram Class


MindFusion.Diagramming.Diagram.ActiveItem Property

Diagram.ActiveItem Property
[image]

Gets or sets the active diagram element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem ActiveItem { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveItem As DiagramItem

Property Value

A reference to the DiagramItem instance that is currently active.

Remarks

Use this property to get the active item – the one selected by the user or the last put in a multiple Selection. It is shown with white selection handles by default.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ActiveItemHandlesStyle Property

Diagram.ActiveItemHandlesStyle Property
[image]

Gets the visual style of adjustment handles of the active item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle ActiveItemHandlesStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ActiveItemHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ActiveLayer Property

Diagram.ActiveLayer Property
[image]

Gets or sets the zero-based index of the active layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ActiveLayer { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveLayer As Integer

Property Value

An integer value that specifies the index of the active layer.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AdjustmentHandlesSize Property

Diagram.AdjustmentHandlesSize Property
[image]

Gets or sets the size of the handles, which appear around selected objects, expressed in millimeters.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double AdjustmentHandlesSize { get; set; }

Visual Basic [image] Copy Code

Public Property AdjustmentHandlesSize As Double

Property Value

A double value specifying the height of the selection handles. The default is 2.

Remarks

Use the property to set the size of the manipulation handles, which appear around selected items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AlignmentGuidePen Property

Diagram.AlignmentGuidePen Property
[image]

Gets or sets the pen used to draw alignment guides.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen AlignmentGuidePen { get; set; }

Visual Basic [image] Copy Code

Public Property AlignmentGuidePen As Pen

Property Value

An instance of the Pen class.

Remarks

This pen is used to draw alignment guides shown when AutoAlignNodes is enabled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AlignToGrid Property

Diagram.AlignToGrid Property
[image]

Gets or sets a value indicating whether the items in the diagram are aligned to grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AlignToGrid { get; set; }

Visual Basic [image] Copy Code

Public Property AlignToGrid As Boolean

Property Value

true if the grid is activated; otherwise, false. The default is true.

Remarks

When the property is set to true, the sides of every newly created diagram item are aligned to the nearest grid points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowLinksRepeat Property

Diagram.AllowLinksRepeat Property
[image]

Gets or sets a value indicating whether more than one arrow can link the same origin and destination diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowLinksRepeat { get; set; }

Visual Basic [image] Copy Code

Public Property AllowLinksRepeat As Boolean

Property Value

true if repeated links are allowed; otherwise, false. The default is true.

Remarks

Specifies whether more than one link can connect the same origin and destination diagram nodes. If set to false, two diagram nodes can be connected with at most one link in a single direction.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowMultipleResize Property

Diagram.AllowMultipleResize Property
[image]

Gets or sets whether multiple selected nodes can be resized simultaneously.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMultipleResize { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultipleResize As Boolean

Property Value

true to let the user resize multiple selected nodes; otherwise, false. The default value is false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowSelfLoops Property

Diagram.AllowSelfLoops Property
[image]

Gets or sets value indicating whether reflexive links are allowed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowSelfLoops { get; set; }

Visual Basic [image] Copy Code

Public Property AllowSelfLoops As Boolean

Property Value

true if self loops are allowed; otherwise, false. The default is true.

Remarks

Use the property to specify whether the user is allowed to draw self loops – links that connect a node to itself.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowSplitLinks Property

Diagram.AllowSplitLinks Property
[image]

Gets or sets a value indicating whether arrow segments can be added and removed interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowSplitLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowSplitLinks As Boolean

Property Value

true if interactive adding/removing of link segments allowed; false if not.

Remarks

Allows users insert new link segments interactively by clicking and dragging a point of a link's segment. For polyline-style link this creates one additional segment by splitting the existing one into two parts. For cascading links there are two segments inserted, keeping intact the alternating pattern of horizontal and vertical segments, each orthogonal to its neighbors. Bézier-style links cannot be split in the current MindFusion.Diagramming for .NET MAUI version.

Segments can be merged by moving their joining point until the angle between reaches certain threshold value. In case of cascading-style links, segments can be merged by placing adjacent control points close one to the other, as set in MergeThreshold.

This property also affects how users can change the orientation of cascading links. For more details see CascadeOrientation.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowUnanchoredLinks Property

Diagram.AllowUnanchoredLinks Property
[image]

Gets or sets a value indicating whether links can be connected to nodes to which there aren't anchor points assigned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowUnanchoredLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowUnanchoredLinks As Boolean

Property Value

true to let links connect to nodes without anchor points; otherwise, false. The default is true.

Remarks

AllowUnanchoredLinks applies to nodes whose AnchorPattern is not set or does not contain incoming or outgoing anchor points available. If the property is enabled, users can connect links to any point of such nodes. If disabled, users cannot connect links to such nodes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AllowUnconnectedLinks Property

Diagram.AllowUnconnectedLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw links that are not connected to any node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowUnconnectedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowUnconnectedLinks As Boolean

Property Value

true to allow drawing unconnected links; otherwise, false. The default is false.

Remarks

If the property is set to true, users will be able to draw links from or to any point of the document. Depending on which end of a link is unconnected, its Origin or Destination nodes might be of type DummyNode.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoAlignDistance Property

Diagram.AutoAlignDistance Property
[image]

Gets or sets the maximal horizontal or vertical distance at which a node aligns to the borders of other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double AutoAlignDistance { get; set; }

Visual Basic [image] Copy Code

Public Property AutoAlignDistance As Double

Property Value

A double value specifying the maximal alignment distance. The default value is 3.

Remarks

To enable node alignment, set AutoAlignNodes to true. When either the horizontal or vertical borders of the dragged node are within the specified distance from the respective borders of a nearby node, the dragged node snaps to a position where the borders are aligned.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoAlignNodes Property

Diagram.AutoAlignNodes Property
[image]

Gets or sets whether nodes should automatically align to the borders of other nodes during user interaction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoAlignNodes { get; set; }

Visual Basic [image] Copy Code

Public Property AutoAlignNodes As Boolean

Property Value

true to align nodes, otherwise false. The default value is false.

Remarks

When either the horizontal or vertical borders of the dragged node are within AutoAlignDistance from the respective borders of a nearby node, the dragged node snaps to a position where the borders are aligned. In addition, an alignment guide that indicates which borders are aligned is drawn using the pen specified through AlignmentGuidePen.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoCloseDistance Property

Diagram.AutoCloseDistance Property
[image]

Gets or sets the maximum distance between first and last points of a FreeFormNode for which the node's outline is closed automatically.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Double> AutoCloseDistance { get; set; }

Visual Basic [image] Copy Code

Public Property AutoCloseDistance As Nullable(Of Double)

Property Value

An optional double value specifying upper limit of distance between end points where the form should close automatically. The default null value specifies that the form should always close.

See Also

Diagram Members
Diagram Class
FreeFormAttractDistance Property


MindFusion.Diagramming.Diagram.AutoHighlightRows Property

Diagram.AutoHighlightRows Property
[image]

Gets or sets whether a table row should be highlighted when the user clicks on it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoHighlightRows { get; set; }

Visual Basic [image] Copy Code

Public Property AutoHighlightRows As Boolean

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoResize Property

Diagram.AutoResize Property
[image]

Gets or sets a value indicating whether the document area should be resized automatically so it fits the diagram contents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AutoResize AutoResize { get; set; }

Visual Basic [image] Copy Code

Public Property AutoResize As AutoResize

Property Value

A member of the AutoResize enumeration. The default is AutoResize.RightAndDown.

Remarks

If automatic resizing is enabled, the size of the document scrollable area is updated each time an item is created, deleted or moved, either by end-users or by calling of methods. The following AutoResize values specify in what directions the diagram area is allowed to grow:

Member name | Description
None | Do not enlarge the diagram area automatically.
RightAndDown | Enlarge the diagram area to the right and down if an item is moved outside the boundaries in these directions.
AllDirections | Enlarge the diagram area in any direction if an item is moved outside the boundaries.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoSnapDistance Property

Diagram.AutoSnapDistance Property
[image]

Specifies the maximum distance at which links auto-snap to nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double AutoSnapDistance { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapDistance As Double

Property Value

A double value specifying the maximum auto-snap distance. The default value is 16.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.AutoSnapLinks Property

Diagram.AutoSnapLinks Property
[image]

Gets or sets the default value for the AutoSnapToNode property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoSnapLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapLinks As Boolean

Property Value

true to snap links to nearest node, otherwise, false; the default value is false.

Remarks

Only nodes at a distance smaller than AutoSnapDistance are considered. A link does not snap to its current origin or destination nodes if that would create a self-loop.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.BackBrush Property

Diagram.BackBrush Property
[image]

Gets or sets the brush used for painting the diagram background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush BackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BackBrush As Brush

Property Value

An instance of a Brush-derived class. The default is a solid brush initialized with Color(170, 170, 200).

Remarks

This property enables more spectacular background painting with effects such as gradients, textures and color patterns.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.BackgroundImage Property

Diagram.BackgroundImage Property
[image]

Gets or sets the diagram background image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource BackgroundImage { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundImage As ImageSource

Property Value

An instance of the ImageSource class.

Remarks

This image is painted as a background of the diagram, behind the alignment grid and all items. Its position is controlled by the BackgroundImageAlign property.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.BackgroundImageAlign Property

Diagram.BackgroundImageAlign Property
[image]

Gets or set a value indicating how the background image is positioned, relatively either to the control's window or to the scrollable document area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageAlignment BackgroundImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundImageAlign As ImageAlignment

Property Value

A member of the ImageAlignment enumeration. The default is ImageAlignment.TopLeft.

Remarks

The background image can be aligned to a corner, stretched, centered, or tiled to cover the control's area.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Bounds Property

Diagram.Bounds Property
[image]

Gets or sets a value representing the size of the diagram's scrollable area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new Rect Bounds { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Bounds As Rect

Property Value

An instance of the Rectangle structure. The default size of the document is the standard A4 size, that is 210x297.

Remarks

Use this property to specify how large a document should be, that is, how far it can be scrolled. After creating a diagram programmatically, you might wish to call ResizeToFitItems to make the scrollable area just big enough to contain all diagram elements.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.BoundsPen Property

Diagram.BoundsPen Property
[image]

The pen with which the document bounds should be drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen BoundsPen { get; set; }

Visual Basic [image] Copy Code

Public Property BoundsPen As Pen

Property Value

A Pen instance. The default value is null.

Remarks

This pen is used to draw borders around the diagram bounding rectangle, which could be useful when the DiagramView is larger than the diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CellCustomDraw Property

Diagram.CellCustomDraw Property
[image]

Gets or sets the default type of custom painting done on the cells of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw CellCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CellCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is CustomDraw.None.

Remarks

The CellCustomDraw member of new tables is initialized from this property.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CellFrameStyle Property

Diagram.CellFrameStyle Property
[image]

Gets or sets the default cell border style of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CellFrameStyle CellFrameStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CellFrameStyle As CellFrameStyle

Property Value

A member of the CellFrameStyle enumeration. The default is CellFrameStyle.System3D.

Remarks

Use this property to specify the default border style of cells in new tables. See CellFrameStyle enumeration for more details.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerCaption Property

Diagram.ContainerCaption Property
[image]

Specifies the default container caption text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ContainerCaption { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerCaption As String

Property Value

A string specifying the initial caption text of containers. The default is "Container".

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerCaptionHeight Property

Diagram.ContainerCaptionHeight Property
[image]

Specifies the default container caption height.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ContainerCaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerCaptionHeight As Double

Property Value

A double value specifying the initial height of containers' caption bars. The default is 5.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerHighlightPen Property

Diagram.ContainerHighlightPen Property
[image]

Gets or sets the default value for the HighlightPen property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ContainerHighlightPen { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerHighlightPen As Pen

Property Value

A Pen instance specifying the initial highlight pen of containers. The default is a pen with Colors.LightSkyBlue color and width 0.5.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerMargin Property

Diagram.ContainerMargin Property
[image]

Gets or sets the default value for the Margin property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ContainerMargin { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerMargin As Double

Property Value

A double value specifying the initial margin size of containers. The default is 10.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerMinimumSize Property

Diagram.ContainerMinimumSize Property
[image]

Gets or sets the default value for the MinimumSize property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size ContainerMinimumSize { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerMinimumSize As Size

Property Value

A Size value specifying the initial minimum size of containers. The default is 50x40.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainerNodeStyle Property

Diagram.ContainerNodeStyle Property
[image]

Gets the theme-level style for container nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNodeStyle ContainerNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ContainerNodeStyle As ContainerNodeStyle

Property Value

An instance of the ContainerNodeStyle class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ContainersFoldable Property

Diagram.ContainersFoldable Property
[image]

Gets or sets the default value for the Foldable property of containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ContainersFoldable { get; set; }

Visual Basic [image] Copy Code

Public Property ContainersFoldable As Boolean

Property Value

A boolean value specifying whether containers are initially foldable. The default is true.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.CrossingRadius Property

Diagram.CrossingRadius Property
[image]

Gets or sets the radius length of decorations displayed at arrow intersection points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CrossingRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingRadius As Double

Property Value

A double value specifying the radius of the arcs drawn at link intersection points.

Remarks

If LinkCrossings is set to Cut, link segments are cut at intersection points and this property defines the length of the break left between adjacent cut points. If LinkCrossings is set to Arcs, this property defines the radius of the arcs drawn over intersection points.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DefaultShape Property

Diagram.DefaultShape Property
[image]

Gets or sets the default shape of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape DefaultShape { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultShape As Shape

Property Value

An instance of the Shape class. The default is the RoundRect shape.

Remarks

The Shape property of newly created shape nodes is initialized with the value of this property. It defines a series of lines, arcs and curves composed in a complex shape. There are many predefined shapes exposed as static members of the Shape class. You can also define your own shapes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DiagramLinkStyle Property

Diagram.DiagramLinkStyle Property
[image]

Gets the theme-level style for diagram links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkStyle DiagramLinkStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DiagramLinkStyle As DiagramLinkStyle

Property Value

An instance of the DiagramLinkStyle class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DiagramStyle Property

Diagram.DiagramStyle Property
[image]

Gets the theme-level style for the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramStyle DiagramStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DiagramStyle As DiagramStyle

Property Value

An instance of the DiagramStyle class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Dirty Property

Diagram.Dirty Property
[image]

Gets or sets a value indicating whether the diagram has changed since the last save.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Dirty { get; set; }

Visual Basic [image] Copy Code

Public Property Dirty As Boolean

Property Value

A boolean value that indicates whether the diagram has changed.

Remarks

MindFusion.Diagramming for .NET MAUI tracks all changes that are done on the diagram contents, either programmatically or by users. If there are changes that are still not saved, the property has value of true. The Dirty flag is cleared automatically when a document is loaded from file or stream. When a document is saved, the Dirty flag can be cleared as specified by an argument of the Save* methods.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DisabledHandlesStyle Property

Diagram.DisabledHandlesStyle Property
[image]

Gets the visual style of disabled adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle DisabledHandlesStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DisabledHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides Pen and Brush attributes that let you customize the appearance of disabled adjustment handles.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.DynamicLinks Property

Diagram.DynamicLinks Property
[image]

Gets or sets the default value for the Dynamic property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DynamicLinks { get; set; }

Visual Basic [image] Copy Code

Public Property DynamicLinks As Boolean

Property Value

true if dynamic links are enabled; otherwise, false. The default is false.

Remarks

Use the property to specify whether links automatically reposition their end segments, so they keep pointing to the centers of connected nodes. If enabled, moving a connected node recalculates the position of link's end point, placing it at appropriate location of the node outline. If the node has anchor points assigned to it, the end point is attached to one of them.

If the value is false, links do not look for the center of the origin and destination node, but keep their relative position as set when they were created – from the left corner of the first node to the top of the other node for instance.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.EffectiveBackBrush Property

Diagram.EffectiveBackBrush Property
[image]

Gets the currently effective background brush of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveBackBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveBackBrush As Brush

Property Value

An instance of the Brush class.

Remarks

This property returns BackBrush if it is not null, or the brush from the associated style or theme otherwise.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.EnableLanes Property

Diagram.EnableLanes Property
[image]

Gets or sets whether lanes are enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableLanes { get; set; }

Visual Basic [image] Copy Code

Public Property EnableLanes As Boolean

Property Value

true if lanes are enabled; otherwise, false. The default is false.

Remarks

You can customize the lane grid through the LaneGrid property.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExpandButtonAction Property

Diagram.ExpandButtonAction Property
[image]

Specifies what should happen when a user clicks the +/- button that is displayed near expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ExpandButtonAction ExpandButtonAction { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandButtonAction As ExpandButtonAction

Property Value

A member of the ExpandButtonAction enumeration. The default is ExpandTreeBranch.

Remarks

The default behavior of a [±] button displayed nearby an Expandable node is to hide or show the children of that node. In that case, the children of a node are all nodes that can be reached from it by following recursively the OutgoingLinks or IncomingLinks, as defined by the ExpandOnIncoming property.

To implement custom expand/collapse functionality, set ExpandButtonAction to RaiseEvents and handle the ExpandButtonClicked event. That lets you use other criteria for what nodes should be shown or hidden, for example, containment or hierarchical grouping.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExpandButtonPosition Property

Diagram.ExpandButtonPosition Property
[image]

Gets or sets where expand/collapse buttons are located relatively to their nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ExpandButtonPosition ExpandButtonPosition { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandButtonPosition As ExpandButtonPosition

Property Value

A member of the ExpandButtonPosition enumeration. The default is OuterRight.

Remarks

If diagram links tend to flow vertically, it would be useful to have the expand/collapse buttons stay at the left- or right-hand side of nodes. If diagram links tend to flow horizontally, choose position for expand buttons such that they stay above or below nodes. That will prevent button icons from being overlapped by links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExpandOnIncoming Property

Diagram.ExpandOnIncoming Property
[image]

Gets or sets a value, indicating in which direction object hierarchies are expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ExpandOnIncoming { get; set; }

Visual Basic [image] Copy Code

Public Property ExpandOnIncoming As Boolean

Property Value

true if trees are expanded in the direction of the links, which come into nodes; otherwise, false. The default is false.

Remarks

Use this property when presenting tree structures with enabled collapse/expand. If the property is set to false, a clicked expand button of a node expands in the direction of the node's outgoing links. That is, the nodes pointed by links going out of a node are considered children of that node.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ExteriorBrush Property

Diagram.ExteriorBrush Property
[image]

Gets or sets the brush used for painting the area outside document bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ExteriorBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ExteriorBrush As Brush

Property Value

An instance of a Brush-derived class. Default value is null.

Remarks

If ExteriorBrush is set to null, the BackBrush is used to paint the areas both inside and outside Bounds. In order to scroll the exterior filling and the background image consistently, ExteriorBrush can be used only with document-relative BackgroundImageAlign.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Factory Property

Diagram.Factory Property
[image]

Gets a Factory instance that lets you add programmatically new items to the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Factory Factory { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Factory As Factory

Property Value

An instance of the Factory class.

Remarks

You can add a new node or link to the diagram by creating an instance of the item class by using the new operator and adding it to the Nodes or Links collection. This works the same way for adding both items from your custom class or ones from the MindFusion.Diagramming for .NET MAUI predefined types. The Factory class methods are just shortcuts that let you do that with a single method call, and they work only for the predefined item classes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.FoldedContainerSize Property

Diagram.FoldedContainerSize Property
[image]

Gets or sets the size of folded containers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size FoldedContainerSize { get; set; }

Visual Basic [image] Copy Code

Public Property FoldedContainerSize As Size

Property Value

A Size instance specifying the size of folded containers. The default value is an empty size.

Remarks

If this property is not set, the width of folded containers is set to their MinimumSize and the height to their CaptionHeight.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Font Property

Diagram.Font Property
[image]

Gets or sets the default font.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Font Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Font

Property Value

An instance of the Font class.

Remarks

The Font of new nodes and links is initialized with the value of this property.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.FreeFormAttractDistance Property

Diagram.FreeFormAttractDistance Property
[image]

Gets or sets the radius around dragged free-form adjustment handle in which other points of FreeFormNode are modified too.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double FreeFormAttractDistance { get; set; }

Visual Basic [image] Copy Code

Public Property FreeFormAttractDistance As Double

Property Value

A double value specifying attraction radius.

See Also

Diagram Members
Diagram Class
AutoCloseDistance Property


MindFusion.Diagramming.Diagram.FreeFormTargets Property

Diagram.FreeFormTargets Property
[image]

An array of Shape objects used to replace FreeFormNode instances with ShapeNode ones when Behavior is set to LinkFreeShapes or DrawFreeShapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape[] FreeFormTargets { get; set; }

Visual Basic [image] Copy Code

Public Property FreeFormTargets As Shape()

Property Value

An array of Shape objects.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridColor Property

Diagram.GridColor Property
[image]

Gets or sets the color of the grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color GridColor { get; set; }

Visual Basic [image] Copy Code

Public Property GridColor As Color

Property Value

An instance of the Color structure. The default is Color(140, 140, 150).

Remarks

Use the property to specify the color of grid points and lines.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridOffsetX Property

Diagram.GridOffsetX Property
[image]

Gets or sets the horizontal offset of the first column of grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridOffsetX { get; set; }

Visual Basic [image] Copy Code

Public Property GridOffsetX As Double

Property Value

A double value that specifies the horizontal grid offset. The default is Double.NaN.

Remarks

The property specifies the offset of the first point of the alignment grid. The default value NaN makes the grid start at offset GridSizeX / 2.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridOffsetY Property

Diagram.GridOffsetY Property
[image]

Gets or sets the vertical offset of the first row of grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property GridOffsetY As Double

Property Value

A double value that specifies the vertical grid offset. The default is Double.NaN.

Remarks

The property specifies the offset of the first point of the alignment grid. The default value NaN makes the grid start at offset GridSizeY / 2.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridSizeX Property

Diagram.GridSizeX Property
[image]

Gets or sets the horizontal distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSizeX { get; set; }

Visual Basic [image] Copy Code

Public Property GridSizeX As Double

Property Value

A double number specifying the horizontal distance between grid points. The default is 4.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridSizeY Property

Diagram.GridSizeY Property
[image]

Gets or sets the vertical distance between adjacent grid points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSizeY { get; set; }

Visual Basic [image] Copy Code

Public Property GridSizeY As Double

Property Value

A double number specifying the vertical distance between grid points. The default is 4.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.GridStyle Property

Diagram.GridStyle Property
[image]

Gets or sets the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GridStyle GridStyle { get; set; }

Visual Basic [image] Copy Code

Public Property GridStyle As GridStyle

Property Value

A member of the GridStyle enumeration. The default is Points.

Remarks

Specifies how the alignment grid is drawn. If the property value is set to Points, the grid is painted as a matrix of points. If set to Lines, the grid is represented as a series of crossing horizontal and vertical lines. Grid points or lines are painted with the color set in GridColor; the distance between them is specified by the GridSizeX and GridSizeY properties.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.HitTestPriority Property

Diagram.HitTestPriority Property
[image]

Gets or sets a value indicating the order in which items are hit-tested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HitTestPriority HitTestPriority { get; set; }

Visual Basic [image] Copy Code

Public Property HitTestPriority As HitTestPriority

Property Value

A member of the HitTestPriority enumeration. The default value is NodesBeforeLinks.

Remarks

For easier selection, links have a hit-detection area several pixels wider than their visible segment lines. However, if several links with higher z-index cross a node, it would be difficult to select it. The HitTestPriority property allows altering hit-test results in such situations. If set to NodesBeforeLinks, nodes are hit-tested before all links. ZOrder makes all items tested in decreasing z-order, independently of their type.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Items Property

Diagram.Items Property
[image]

Gets a read-only collection of all objects in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This collection gives you access to all items contained in this document. You can also use it to add new items to the diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.JsonOptions Property

Diagram.JsonOptions Property
[image]

A JsonOptions object providing properties for customizing the JSON serialization process.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonOptions JsonOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property JsonOptions As JsonOptions

Property Value

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LaneGrid Property

Diagram.LaneGrid Property
[image]

Gets the lane grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Grid LaneGrid { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LaneGrid As Grid

Property Value

An instance of the Grid class.

Remarks

The Grid object gives you full control over the lane grid. For example, it lets you set the number of rows and columns in the grid, add headers, customize the appearance, subscribe to events and so on.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Layers Property

Diagram.Layers Property
[image]

Gets a list of the layers in the current diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<Layer> Layers { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Layers As IList(Of Layer)

Property Value

A list with all diagram layers.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LicenseKey Property

Diagram.LicenseKey Property
[image]

Gets or sets the license key of the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string LicenseKey { get; set; }

Visual Basic [image] Copy Code

Public Property LicenseKey As String

Property Value

A string value.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkBaseShape Property

Diagram.LinkBaseShape Property
[image]

Gets or sets the shape displayed at the base of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape LinkBaseShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBaseShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is None.

Remarks

This property specifies the default shape displayed as arrowhead at the links' origin points. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkBaseShapeSize Property

Diagram.LinkBaseShapeSize Property
[image]

Gets or sets the default size of the base of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkBaseShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBaseShapeSize As Double

Property Value

A double value that specifies the size. The default is 5.

Remarks

The property specifies the size of the graphical shapes that are displayed at the start of new diagram links, for example, at the beginning of the links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkBrush Property

Diagram.LinkBrush Property
[image]

Gets or sets the default value for the Brush property of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush LinkBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

The property provides a default value for the brush, with which an arrowhead's interior is filled. The Brush property of new links is initialized with a clone of LinkBrush, but after link creation the properties are independent – changing one of them does not change the other.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkCascadeOrientation Property

Diagram.LinkCascadeOrientation Property
[image]

Gets or sets the initial orientation of the first segment of new cascading links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation LinkCascadeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property LinkCascadeOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

Use this property to specify the default orientation of the first segment of DiagramLink objects whose Shape is set to LinkShape.Cascading. The default value, Auto, lets the component decide whether to draw the first segment horizontally or vertically. See Orientation for more details.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkCrossings Property

Diagram.LinkCrossings Property
[image]

Gets or sets how to render the intersection points where links cross their paths.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkCrossings LinkCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property LinkCrossings As LinkCrossings

Property Value

A member of the LinkCrossings enumeration. The default is Straight.

Remarks

Intersection points where links cross each other's paths can be rendered as arcs or breaks, depending on the value of this property. The z-order defines which links jump over the others or which links are cut by the others. If LinkCrossings is set to Arcs, links with higher ZIndex jump over those with lower ZIndex. If set to Cut, segments of links at lower z-position are cut by links at higher z-position. Radius of arcs and breaks can be set by the CrossingRadius property.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkCustomDraw Property

Diagram.LinkCustomDraw Property
[image]

Gets or sets the default type of custom painting done on links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw LinkCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property LinkCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

This property specifies whether and how custom painting of links is performed. Its value is assigned to the CustomDraw property of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkEndsMovable Property

Diagram.LinkEndsMovable Property
[image]

Gets or sets a value indicating whether link ends can be moved by users after the link is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool LinkEndsMovable { get; set; }

Visual Basic [image] Copy Code

Public Property LinkEndsMovable As Boolean

Property Value

true if moving link ends is allowed; false, if not.

Remarks

When the property is set to true, users cannot move the ends of a link after the link is created. This prevents them from connecting the links to other origin and destination nodes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkHandlesStyle Property

Diagram.LinkHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle LinkHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. The default is SquareHandles.

Remarks

Default value for the HandlesStyle property of new links, created either programmatically or by a user. That property specifies how links' selection status is indicated visually.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkHeadShape Property

Diagram.LinkHeadShape Property
[image]

Gets or sets the shape displayed as head of new links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape LinkHeadShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHeadShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is Arrow.

Remarks

This property specifies the default shape displayed as arrowhead at the links' end points. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkHeadShapeSize Property

Diagram.LinkHeadShapeSize Property
[image]

Gets or sets the default size of arrowheads.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkHeadShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHeadShapeSize As Double

Property Value

A double value that measures the size. The default is 5.

Remarks

The property specifies how big the shapes of new arrowheads are.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkHitDistance Property

Diagram.LinkHitDistance Property
[image]

Gets or sets a value specifying how far from a link a click is still considered a hit, expressed in millimeters.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkHitDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LinkHitDistance As Double

Property Value

A double value specifying the distance in MeasureUnit units. The default value is 0.

Remarks

If this property is set to 0, the control considers it a hit when a link is no further than five millimeters from the mouse position. This LinkHitDistance value is also used when hit-testing programmatically, e.g. by calling the GetItemAt method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkIntermediateShape Property

Diagram.LinkIntermediateShape Property
[image]

Gets or sets default shape to be displayed in the middle of each segment of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape LinkIntermediateShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkIntermediateShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. The default is None.

Remarks

The property specifies default shape to be displayed at the middle of each segment of new links. It facilitates users by following the path of a link across the diagram, especially for longer links in large documents. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkIntermediateShapeSize Property

Diagram.LinkIntermediateShapeSize Property
[image]

Gets or sets the default size of the shapes at middles of arrow segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkIntermediateShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property LinkIntermediateShapeSize As Double

Property Value

A double value that measures the size. The default is 5.

Remarks

Specifies default value for the IntermediateShapeSize property of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkPen Property

Diagram.LinkPen Property
[image]

Gets or sets the default value for the Pen and HeadPen properties of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen LinkPen { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPen As Pen

Property Value

An instance of the Pen class.

Remarks

The property provides a default value for the pens, with which link's segments and arrowhead lines are painted. The Pen and HeadPen properties of new links are initialized with clones of LinkPen, but after link creation the properties are independent – changing one of them does not change the others.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkRouter Property

Diagram.LinkRouter Property
[image]

Gets or sets the component used to find paths for auto-routed links when diagram nodes are added or their positions change.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ILinkRouter LinkRouter { get; set; }

Visual Basic [image] Copy Code

Public Property LinkRouter As ILinkRouter

Property Value

An instance of a class implementing the ILinkRouter interface. The currently available implementations include GridRouter and QuickRouter.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Links Property

Diagram.Links Property
[image]

Gets a collection of all links in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

Links provides type-safe access to all links in the current diagram. Any diagram element can be accessed also via the Items collection.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkSegments Property

Diagram.LinkSegments Property
[image]

Gets or sets the default number of arrow segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int LinkSegments { get; set; }

Visual Basic [image] Copy Code

Public Property LinkSegments As Integer

Property Value

An integer value specifying how many segments links consists of. The default is 1.

Remarks

Use the property to create more indented links, when necessary.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkShape Property

Diagram.LinkShape Property
[image]

Gets or sets the default style of arrow objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkShape LinkShape { get; set; }

Visual Basic [image] Copy Code

Public Property LinkShape As LinkShape

Property Value

A member of the LinkShape enumeration. The default value is Polyline.

Remarks

Use the property to specify how new links are composed and what they look like. The segments of a link could be curves or straight lines, and they might be restricted to be horizontal / vertical only.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinksRetainForm Property

Diagram.LinksRetainForm Property
[image]

Gets or sets whether links should maintain their forms if the nodes linked with those links are moved around.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool LinksRetainForm { get; set; }

Visual Basic [image] Copy Code

Public Property LinksRetainForm As Boolean

Property Value

true to retain links' forms; otherwise, false. The default is false.

Remarks

LinksRetainForm value is used to initialize the RetainForm property of new links. It has effect on links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkText Property

Diagram.LinkText Property
[image]

Gets or sets the default text of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string LinkText { get; set; }

Visual Basic [image] Copy Code

Public Property LinkText As String

Property Value

A string specifying the initial text of links. The default is an empty string.

Remarks

The value of this property is assigned to the Text property of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.LinkTextStyle Property

Diagram.LinkTextStyle Property
[image]

Gets or sets default placement and orientation for links' text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkTextStyle LinkTextStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LinkTextStyle As LinkTextStyle

Property Value

A member of the LinkTextStyle enumeration. The default value is Center.

Remarks

The value of this property is used to initialize the TextStyle property of new links.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.MeasureUnit Property

Diagram.MeasureUnit Property
[image]

Gets or sets the unit of measure used for logical coordinates in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As MeasureUnit

Property Value

An instance of the MeasureUnit class. The default value is Millimeter.

Remarks

Many properties in the MindFusion.Diagramming for .NET MAUI API are used to specify the dimensions of diagram items or the size of various visual elements, for example, selection handles, arrowhead shapes, frame widths, and so on. MeasureUnit specifies the measure of length in which these size values are defined.

Changing the measure unit does not automatically rescale the size-related property values. Your application must set appropriate values to: Bounds, GridSizeX, GridSizeY, GridOffsetX, GridOffsetY, AdjustmentHandlesSize, LinkBaseShapeSize, LinkHeadShapeSize, LinkIntermediateShapeSize, TableCaptionHeight, TableColumnWidth, TableRowHeight, CrossingRadius, ShadowOffsetX, ShadowOffsetY and to the size-related members of RoutingOptions.

Changing the measure unit resets RoutingOptions to default values for the new unit, because performance might suffer greatly if the routing algorithm uses too big or too small GridSize.

The arguments passed to some methods depend on the measure unit too, for example, CreateShapeNode, CreateTableNode, GetNodeAt, GetLinkAt.

The following MeasureUnit members provide ready-to-use measure units:

Member name | Description
Centimeter | Specifies centimeters as the unit of measure.
Document | Specifies the document unit (1/300 inch) as the unit of measure.
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies a device pixel as the unit of measure. Note that print and on-screen output will differ greatly in size when using pixels because printer pixels are much smaller than screen ones.
Point | Specifies a printer's point (1/72 inch) as the unit of measure.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.MergeThreshold Property

Diagram.MergeThreshold Property
[image]

Gets or sets the maximum distance between adjacent control points of an arrow at which the respective segments can be merged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MergeThreshold { get; set; }

Visual Basic [image] Copy Code

Public Property MergeThreshold As Double

Property Value

A double value specifying the maximum distance in the current MeasureUnit. The default is 0.

Remarks

An user may add or remove links' segments interactively when the AllowSplitLinks property is enabled. They can drag a link's control point over the next one in order to merge two adjacent segments. Usually the two points must be placed exactly at the same coordinates in order to merge the respective segments of the link. Assign a larger value to this property if you wish to make it easier for users to merge segments by just moving link's control point close one to another.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.MinimumNodeSize Property

Diagram.MinimumNodeSize Property
[image]

Gets or sets the minimum node size that the user is allowed to set.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size MinimumNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinimumNodeSize As Size

Property Value

A Size instance specifying the minimum size allowed for nodes.

Remarks

If the user releases the mouse button while creating or modifying a node and the node size is smaller than this value, the operation is cancelled.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.NodeEffects Property

Diagram.NodeEffects Property
[image]

Gets a collection with all effects applied to the nodes of this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<NodeEffect> NodeEffects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeEffects As IList(Of NodeEffect)

Property Value

A list with all currently active node effects.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Nodes Property

Diagram.Nodes Property
[image]

Gets a collection of all nodes in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class.

Remarks

Nodes provides type-safe access to all nodes in the current diagram. Any diagram element can be accessed also by using the Items collection.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.NodesExpandable Property

Diagram.NodesExpandable Property
[image]

Gets or sets a value indicating whether newly created nodes can be expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool NodesExpandable { get; set; }

Visual Basic [image] Copy Code

Public Property NodesExpandable As Boolean

Property Value

true if new nodes can be expanded; otherwise, false. The default is false.

Remarks

If using MindFusion.Diagramming for .NET MAUI to present tree/hierarchical diagrams, you might set NodesExpandable to true. If enabled, the property makes each newly created node appear with a [±] sign next to it, which expands or collapses the node's descendants.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.NowLoading Property

Diagram.NowLoading Property
[image]

Gets a value indicating whether the diagram data is now being loaded from a file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool NowLoading { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NowLoading As Boolean

Property Value

true if the diagram is currently in a loading state; otherwise, false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RecursiveExpand Property

Diagram.RecursiveExpand Property
[image]

Gets or sets value indicating how a tree is expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RecursiveExpand { get; set; }

Visual Basic [image] Copy Code

Public Property RecursiveExpand As Boolean

Property Value

true if a tree is recursively expanded; otherwise, false. The default is false.

Remarks

Use the property when representing tree structures, which hide some of their elements. When the property is set to true, clicking on a certain node in the tree, expands not only its descendants, but all descendants of the descendants, and so on, till the whole tree is expanded.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RestrictItemsToBounds Property

Diagram.RestrictItemsToBounds Property
[image]

Gets or sets a value indicating whether users are allowed to place items outside the scrollable area of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RestrictToBounds RestrictItemsToBounds { get; set; }

Visual Basic [image] Copy Code

Public Property RestrictItemsToBounds As RestrictToBounds

Property Value

A member of the RestrictToBounds enumeration. The default is Intersection.

Remarks

Use this property to specify whether diagram elements can be drawn or moved outside the document area. It is possible to specify that items have to be entirely inside, partly outside or there is no restriction.

If there is no restriction and AutoResize is disabled, users could place an item to a position where they cannot reach it by scrolling. That might be interpreted as an item deletion operation by handling the NodeModified event and deleting the item if it is outside the document boundaries.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RoundedLinks Property

Diagram.RoundedLinks Property
[image]

Specifies whether the joins between segments of Polyline and Cascading links should be rounded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RoundedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinks As Boolean

Property Value

true to use rounded segment joins; otherwise, false. The default is false.

Remarks

The value of this property is considered when drawing links whose Shape is set to Polyline or Cascading. If the property is enabled, the joins between the segments of all such links are drawn as arcs, whose radius equals the value of RoundedLinksRadius.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RoundedLinksRadius Property

Diagram.RoundedLinksRadius Property
[image]

Gets or sets the radius of arc joins of rounded links' segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RoundedLinksRadius { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinksRadius As Double

Property Value

A double value specifying the radius length. The default is 2.

Remarks

The value of this property is used when RoundedLinks is enabled. It specifies the radius of the arcs drawn as joins between link segments.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RoundRectFactor Property

Diagram.RoundRectFactor Property
[image]

Gets or sets the relative size of arcs displayed at the corners of rounded rectangles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RoundRectFactor { get; set; }

Visual Basic [image] Copy Code

Public Property RoundRectFactor As Double

Property Value

A double multiplier applied to the radius of the arcs used as corners of rounded rectangles. The default is 1.

Remarks

The default length of the radius of rounded-corner arcs is 7. This property lets you increase or decrease that value by multiplying it by the specified factor.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RouteLinks Property

Diagram.RouteLinks Property
[image]

Gets or sets a value specifying whether links should avoid nodes by going the shortest path from their origin to their destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RouteLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RouteLinks As Boolean

Property Value

true to route links; otherwise, false. The default is false.

Remarks

The value of RouteLinks is used to initialize the AutoRoute property of new links. If a node is moved or resized, all links that intersect with its new position and have AutoRoute enabled are rerouted. Keep in mind that number of link segments will probably change when routing is enabled.

RoutingOptions allows tuning the routing algorithm. The most important options are the cost values exposed as LengthCost, TurnCost and CrossingCost properties. They greatly influence the shape of the generated route.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RoutingOptions Property

Diagram.RoutingOptions Property
[image]

Gets an object, which allows customizing various parameters of the link routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoutingOptions RoutingOptions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RoutingOptions As RoutingOptions

Property Value

An instance of the RoutingOptions class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.RowHighlightBrush Property

Diagram.RowHighlightBrush Property
[image]

Gets or sets the Brush used to fill highlighted table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush RowHighlightBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RowHighlightBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SelectAfterCreate Property

Diagram.SelectAfterCreate Property
[image]

Gets or sets value indicating whether newly created objects are automatically selected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SelectAfterCreate { get; set; }

Visual Basic [image] Copy Code

Public Property SelectAfterCreate As Boolean

Property Value

true if items are selected after being created; otherwise, false. The default is true.

Remarks

Use the property to specify if the items that are drawn are selecting, which allows immediate modification actions to be performed over them.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SelectedItemHandlesStyle Property

Diagram.SelectedItemHandlesStyle Property
[image]

Gets the visual style of adjustment handles of selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle SelectedItemHandlesStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectedItemHandlesStyle As HandlesVisualStyle

Property Value

An instance of the HandlesVisualStyle class.

Remarks

This style object provides Pen and Brush attributes that let you customize the appearance of adjustment handles drawn around selected items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Selection Property

Diagram.Selection Property
[image]

Gets the Selection instance that represents the selection of items in this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Selection Selection { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Selection As Selection

Property Value

An instance of the Selection class representing the current selection.

Remarks

Use this property to get the items currently selected by a user. Items can be enumerated by the Items member of the Selection class. An item from the selection is considered the active one and can be accessed by using ActiveItem. To prevent users from selecting multiple items, set AllowMultipleSelection to false.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SelectionOnTop Property

Diagram.SelectionOnTop Property
[image]

Gets or sets a value indicating whether selected items should be painted on top of other items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SelectionOnTop { get; set; }

Visual Basic [image] Copy Code

Public Property SelectionOnTop As Boolean

Property Value

true if selected items should be painted on top; otherwise, false. The default is true.

Remarks

If SelectionOnTop is enabled, selected items are painted over non-selected ones, ignoring the z-order position specified in ZIndex. If disabled, the items are painted as set in the z-order.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShadowBrush Property

Diagram.ShadowBrush Property
[image]

Gets or sets the default brush used for painting the items' shadows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShadowBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

Use the property to specify an initial value for the ShadowBrush property of new diagram elements.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShadowOffsetX Property

Diagram.ShadowOffsetX Property
[image]

Gets or sets the horizontal offset of objects' shadows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ShadowOffsetX { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowOffsetX As Double

Property Value

A double value that specifies the X shadow offset.

Remarks

Use the property to specify how distant the shadow of the item should be drawing as to the x-coordinate axis. You can set both X and Y offset values with the SetShadowOffset method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShadowOffsetY Property

Diagram.ShadowOffsetY Property
[image]

Gets or sets the vertical offset of objects' shadows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ShadowOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowOffsetY As Double

Property Value

A double value that specifies the Y shadow offset.

Remarks

Use the property to specify how distant the shadow of the item should be drawing as to the y-coordinate axis. You can set both X and Y offset values with the SetShadowOffset method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShadowsStyle Property

Diagram.ShadowsStyle Property
[image]

Gets or sets the style for rendering shadows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShadowsStyle ShadowsStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowsStyle As ShadowsStyle

Property Value

A member of the ShadowsStyle enumeration.

Remarks

This property specifies how the shadows of diagram items are drawn. If its value is None no shadows are painted. OneLevel makes all shadows paint on the lowest z-level, not covering any items. Thus the diagram items will seem to appear on the same z-level. ZOrder makes the shadow paint immediately under their items, possibly covering other items. This style gives more 3D-like outlook to the diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeBrush Property

Diagram.ShapeBrush Property
[image]

Gets or sets the default value for the Brush property of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShapeBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

The property provides a default value for the brush, with which a node' interior is filled. The Brush property of new shape nodes is initialized with a clone of ShapeBrush, but after the node creation the properties are independent – changing one of them does not change the other.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeCustomDraw Property

Diagram.ShapeCustomDraw Property
[image]

Gets or sets the default type of custom painting done for shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw ShapeCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

This property specifies whether and how custom painting of shape nodes is performed. Its value is assigned to the CustomDraw property of new shape nodes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeHandlesStyle Property

Diagram.ShapeHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle ShapeHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeHandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration.

Remarks

This property provides default value for the HandlesStyle property of new shape nodes, created either programmatically or by the user. That property specifies how selected nodes are indicated visually, and how they can be moved, resized or connected to other objects.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeNodeStyle Property

Diagram.ShapeNodeStyle Property
[image]

Gets the theme-level style for shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNodeStyle ShapeNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ShapeNodeStyle As ShapeNodeStyle

Property Value

An instance of the ShapeNodeStyle class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeOrientation Property

Diagram.ShapeOrientation Property
[image]

Gets or sets the default value for the ShapeOrientation property of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ShapeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeOrientation As Double

Property Value

A double value specifying an angle in degrees. Allowed values are 0, 90, 180 and 270.

Remarks

Use this property in conjunction with DefaultShape to define what shape will be assigned to new nodes that end-users draw.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapePen Property

Diagram.ShapePen Property
[image]

Gets or sets the default value for the Pen property of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ShapePen { get; set; }

Visual Basic [image] Copy Code

Public Property ShapePen As Pen

Property Value

An instance of the Pen class.

Remarks

The property provides a default value for the pen, with which a shape node's frame is painted. The Pen property of new shape nodes is initialized with a clone of ShapePen, but after the node creation the properties are independent – changing one of them does not change the other.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShapeText Property

Diagram.ShapeText Property
[image]

Gets or sets the default text of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ShapeText { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeText As String

Property Value

A string specifying the initial text of shape nodes. The default is an empty string.

Remarks

The value of this property is assigned to the Text property of new nodes.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShowAnchors Property

Diagram.ShowAnchors Property
[image]

Gets or sets a value indicating whether and when node anchor points should be displayed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShowAnchors ShowAnchors { get; set; }

Visual Basic [image] Copy Code

Public Property ShowAnchors As ShowAnchors

Property Value

A member of the ShowAnchors enumeration. The default value is Auto.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShowDisabledHandles Property

Diagram.ShowDisabledHandles Property
[image]

Gets or sets a value indicating whether manipulation handles are painted when they are disabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowDisabledHandles { get; set; }

Visual Basic [image] Copy Code

Public Property ShowDisabledHandles As Boolean

Property Value

true to display disabled manipulation handles; otherwise, false. The default is true.

Remarks

Individual handles can be disabled or enabled by clearing or setting their correspondent bits in node's EnabledHandles. If disabled handles are displayed, they are painted using the HandleBrush specified through DisabledHandlesStyle.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShowGrid Property

Diagram.ShowGrid Property
[image]

Gets or sets a value indicating whether the alignment grid is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowGrid { get; set; }

Visual Basic [image] Copy Code

Public Property ShowGrid As Boolean

Property Value

true if the grid is visible; otherwise, false. The default is false.

Remarks

If it is visible, the grid is painted as either a matrix of points or crossing horizontal and vertical lines. That depends on the value of GridStyle.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ShowHandlesOnDrag Property

Diagram.ShowHandlesOnDrag Property
[image]

Gets or sets a value indicating whether to display selection handles of pointed objects while another object is being modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowHandlesOnDrag { get; set; }

Visual Basic [image] Copy Code

Public Property ShowHandlesOnDrag As Boolean

Property Value

true to display the selection handles of an item while it is being modified; false to hide them.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.SnapToAnchor Property

Diagram.SnapToAnchor Property
[image]

Gets or sets when arrow end points should be aligned to the nearest anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SnapToAnchor SnapToAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property SnapToAnchor As SnapToAnchor

Property Value

A member of the SnapToAnchor enumeration. The default is OnCreate.

Remarks

The default value OnCreate, specifies that links are snapped to anchor points when they are created, but allows the user to move the link ends to different locations of a node. The OnCreateOrModify value makes link ends points connect to node anchors both if links are created or modified.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Style Property

Diagram.Style Property
[image]

Gets or sets the style associated with the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new DiagramStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Style As DiagramStyle

Property Value

An instance of the DiagramStyle class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableBrush Property

Diagram.TableBrush Property
[image]

Gets or sets the default value for the Brush property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TableBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TableBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

The property provides a default value for the brush, with which a table' interior is filled. The Brush property of new tables is initialized with a clone of TableBrush, but after table creation the properties are independent – changing one of them does not change the other.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableCaption Property

Diagram.TableCaption Property
[image]

Gets or sets the default text for tables' captions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string TableCaption { get; set; }

Visual Basic [image] Copy Code

Public Property TableCaption As String

Property Value

A string specifying the initial text of table captions. The default is "Table".

Remarks

The Caption property of new tables is initialized with the value of TableCaption.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableCaptionHeight Property

Diagram.TableCaptionHeight Property
[image]

Gets or sets the default height of table captions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TableCaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TableCaptionHeight As Double

Property Value

A double value, which indicates the height of table caption. Default value is 5.

Remarks

The value of this property is used to initialize the CaptionHeight property of new tables.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableColumnCount Property

Diagram.TableColumnCount Property
[image]

Gets or sets the default number of table columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int TableColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property TableColumnCount As Integer

Property Value

An integer value, which specifies the number of columns in new tables. The default is 2.

Remarks

This value is used to initialize the ColumnCount property of new tables.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableColumnWidth Property

Diagram.TableColumnWidth Property
[image]

Gets or sets the default width of tables' columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TableColumnWidth { get; set; }

Visual Basic [image] Copy Code

Public Property TableColumnWidth As Double

Property Value

A double value, which specifies the width of table columns measured. The default is 18.

Remarks

This property is used to initialize the ColumnWidth property of new tables.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableConnectionStyle Property

Diagram.TableConnectionStyle Property
[image]

Gets or sets a value indicating whether drawing an arrow between tables should link rows of those tables, or the tables as whole entities.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableConnectionStyle TableConnectionStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TableConnectionStyle As TableConnectionStyle

Property Value

A member of the TableConnectionStyle enumeration. The default is Rows.

Remarks

The value of TableConnectionStyle is used to initialize the ConnectionStyle property of new tables. There are three possible ways to relate tables to other nodes. This property specifies how users are allowed to create such relations:

  • Rows – relation ends are the rows of a table. A link connected to the table is connected to a particular row. This mode is convenient for database diagrams.
  • Table – relations target tables as whole entities, and not any particular row. This mode is convenient for class diagrams.
  • Both – a mixed mode where links can target either a row of a table or the table itself.

Programmatically, links can be connected to a table in any way, regardless of the table's ConnectionStyle. The value of ConnectionStyle is considered only when end-users draw links to or from a table. To link to a table as an entity and not to a specific row, pass -1 as row argument of the CreateDiagramLink method.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableCustomDraw Property

Diagram.TableCustomDraw Property
[image]

Gets or sets the default type of custom painting done on tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw TableCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property TableCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. The default is None.

Remarks

The CustomDraw member of tables is initialized from this property.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableHandlesStyle Property

Diagram.TableHandlesStyle Property
[image]

Gets or sets the default value for the HandlesStyle property of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle TableHandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TableHandlesStyle As HandlesStyle

Property Value

One of the HandlesStyle enumeration values.

Remarks

Default value for the HandlesStyle property of new tables, created either programmatically or by the user. That property specifies how selected tables are indicated visually, and how they can be moved, resized or connected to other objects.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableNodeStyle Property

Diagram.TableNodeStyle Property
[image]

Gets the theme-level style for table nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNodeStyle TableNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNodeStyle As TableNodeStyle

Property Value

An instance of the TableNodeStyle class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TablePen Property

Diagram.TablePen Property
[image]

Gets or sets the default value for the Pen property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen TablePen { get; set; }

Visual Basic [image] Copy Code

Public Property TablePen As Pen

Property Value

An instance of the Pen class.

Remarks

The property provides a default value for the pen, with which a table's frame is painted. The Pen property of new tables is initialized with a clone of TablePen, but after table creation the properties are independent – changing one of them does not change the other.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableRowCount Property

Diagram.TableRowCount Property
[image]

Gets or sets the default number of table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int TableRowCount { get; set; }

Visual Basic [image] Copy Code

Public Property TableRowCount As Integer

Property Value

An integer value specifying the number of rows.

Remarks

Use the property to set the initial number of rows for newly created tables. Further customization of table nodes can be done through TableNode class properties and methods.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableRowHeight Property

Diagram.TableRowHeight Property
[image]

Gets or sets the default height of tables' rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TableRowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property TableRowHeight As Double

Property Value

A double value specifying the height of table rows. The default is 5.

Remarks

TableRowHeight is used to initialize the RowHeight property of new tables.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TableShape Property

Diagram.TableShape Property
[image]

Gets or sets the default style of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleShape TableShape { get; set; }

Visual Basic [image] Copy Code

Public Property TableShape As SimpleShape

Property Value

A member of the SimpleShape enumeration. The default value is Rectangle.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TablesScrollable Property

Diagram.TablesScrollable Property
[image]

Gets or sets the default value for the Scrollable property of new tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool TablesScrollable { get; set; }

Visual Basic [image] Copy Code

Public Property TablesScrollable As Boolean

Property Value

true if the scrolling is possible; otherwise, false. The default is false.

Remarks

The Scrollable property of each new table is initialized with the value of TablesScrollable. Small up/down scroll buttons appear in the caption of scrollable tables. With the help of the buttons users can scroll table rows.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Tag Property

Diagram.Tag Property
[image]

Gets or sets custom data associated with this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TextColor Property

Diagram.TextColor Property
[image]

Gets or sets the default color of text displayed inside diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color TextColor { get; set; }

Visual Basic [image] Copy Code

Public Property TextColor As Color

Property Value

An instance of the Color structure. The default is Colors.Black.

Remarks

Use the property to specify the default color of the text of diagram items.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TextFormat Property

Diagram.TextFormat Property
[image]

Gets or sets the default alignment and formatting style for text displayed inside nodes and table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the StringFormat class. The default value for both HorizontalAlignment and VerticalAlignment properties is Center.

Remarks

When a new node is created, its TextFormat is initialized with the value of this property. The same applies for the TextFormat of the cells of a new table.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.Theme Property

Diagram.Theme Property
[image]

Gets or sets the theme associated with the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme Theme { get; set; }

Visual Basic [image] Copy Code

Public Property Theme As Theme

Property Value

An instance of the Theme class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TouchRadius Property

Diagram.TouchRadius Property
[image]

Gets or sets the distance tolerance during hit-testing, expressed in millimeters, or null, to use the default tolerance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Double> TouchRadius { get; set; }

Visual Basic [image] Copy Code

Public Property TouchRadius As Nullable(Of Double)

Property Value

A double value.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.TreeViewNodeStyle Property

Diagram.TreeViewNodeStyle Property
[image]

Gets the theme-level style for tree view nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNodeStyle TreeViewNodeStyle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TreeViewNodeStyle As TreeViewNodeStyle

Property Value

An instance of the TreeViewNodeStyle class.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.Diagram.ValidityChecks Property

Diagram.ValidityChecks Property
[image]

Gets or sets a value indicating whether validity checks are performed each time an item is added to the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ValidityChecks { get; set; }

Visual Basic [image] Copy Code

Public Property ValidityChecks As Boolean

Property Value

true to perform validity checks; otherwise, false. The default is true.

Remarks

If enabled, validity checks are performed each time an item is added to the diagram. That involves enumerating the Items collection and can slow up the process considerably for large diagrams. You can disable this property in order to skip the validity checks, however be sure that you don't add an item twice to the diagram and that links are created only between items in the same diagram.

See Also

Diagram Members
Diagram Class


MindFusion.Diagramming.DiagramBase Class

DiagramBase Class
[image]

The base class of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DiagramBase : AbsoluteLayout

Visual Basic [image] Copy Code

Public MustInherit Class DiagramBase
Inherits AbsoluteLayout

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
Microsoft.Maui.Controls.Layout
Microsoft.Maui.Controls.AbsoluteLayout
MindFusion.Diagramming.DiagramBase
MindFusion.Diagramming.Diagram

See Also

DiagramBase Members


MindFusion.Diagramming.DiagramBase Members

DiagramBase Members
Constructors Methods Events
[image]

The base class of the Diagram class.

The following tables list the members exposed by the DiagramBase type.

Protected Constructors

Name | Description
DiagramBase | Initializes a new instance of the DiagramBase class.

Protected Methods

Name | Description
OnBeginLoad | Raises the BeginLoad event.
OnBoundsChanged | Raises the BoundsChanged event.
OnCellClicked | Raises the CellClicked event.
OnCellTextEdited | Raises the CellTextEdited event.
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode.
OnClicked | Raises the Clicked event.
OnContainerChildAdded | Raises the ContainerChildAdded event.
OnContainerChildRemoved | Raises the ContainerChildRemoved event.
OnContainerFolded | Raises the ContainerFolded event.
OnContainerUnfolded | Raises the ContainerUnfolded event.
OnDefaultShapeChanged | Raises the DefaultShapeChanged event.
OnDeserializeTag | Raises the DeserializeTag event.
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event.
OnDirtyChanged | Raises the DirtyChanged event.
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event.
OnDrawAnchorPoint | Raises the DrawAnchorPoint event.
OnDrawBackground | Raises the DrawBackground event.
OnDrawCell | Raises the DrawCell event.
OnDrawForeground | Raises the DrawForeground event.
OnDrawLink | Raises the DrawLink event.
OnDrawNode | Raises the DrawNode event.
OnEndLoad | Raises the EndLoad event.
OnExpandButtonClicked | Raises the ExpandButtonClicked event.
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event.
OnInitializeLink | Raises the InitializeLink event.
OnInitializeNode | Raises the InitializeNode event.
OnItemAdded | Raises the ItemAdded event.
OnItemRemoved | Raises the ItemRemoved event.
OnJsonDeserializeTag | Raises the JsonDeserializeTag event.
OnJsonSerializeTag | Raises the JsonSerializeTag event.
OnLabelClicked | Raises the LabelClicked event.
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event.
OnLinkActivated | Raises the LinkActivated event.
OnLinkClicked | Raises the LinkClicked event.
OnLinkCreateCancelled | Raises the LinkCreateCancelled event.
OnLinkCreated | Raises the LinkCreated event.
OnLinkCreating | Raises the LinkCreating event.
OnLinkDeactivated | Raises the LinkDeactivated event.
OnLinkDeleted | Raises the LinkDeleted event.
OnLinkDeleting | Raises the LinkDeleting event.
OnLinkDeselected | Raises the LinkDeselected event.
OnLinkModified | Raises the LinkModified event.
OnLinkModifyCancelled | Raises the LinkModifyCancelled event.
OnLinkModifying | Raises the LinkModifying event.
OnLinkPasted | Raises the LinkPasted event.
OnLinkRouted | Raises the LinkRouted event.
OnLinkSelected | Raises the LinkSelected event.
OnLinkSelecting | Raises the LinkSelecting event.
OnLinkSplit | Raises the LinkSplit event.
OnLinkStartModifying | Raises the LinkStartModifying event.
OnLinkTextEdited | Raises the LinkTextEdited event.
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode.
OnMeasureUnitChanged | Raises the MeasureUnitChanged event.
OnNodeActivated | Raises the NodeActivated event.
OnNodeClicked | Raises the NodeClicked event.
OnNodeCreateCancelled | Raises the NodeCreateCancelled event.
OnNodeCreated | Raises the NodeCreated event.
OnNodeCreating | Raises the NodeCreating event.
OnNodeDeactivated | Raises the NodeDeactivated event.
OnNodeDeleted | Raises the NodeDeleted event.
OnNodeDeleting | Raises the NodeDeleting event.
OnNodeDeselected | Raises the NodeDeselected event.
OnNodeModified | Raises the NodeModified event.
OnNodeModifyCancelled | Raises the NodeModifyCancelled event.
OnNodeModifying | Raises the NodeModifying event.
OnNodePasted | Raises the NodePasted event.
OnNodeSelected | Raises the NodeSelected event.
OnNodeSelecting | Raises the NodeSelecting event.
OnNodeStartModifying | Raises the NodeStartModifying event.
OnNodeTextEdited | Raises the NodeTextEdited event.
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode.
OnOriginAnchorChanged | Raises the OriginAnchorChanged event.
OnQueryAlignTarget | Raises the QueryAlignTarget event.
OnRepaint | Raises the Repaint event.
OnRequestClipboard | Raises the RequestClipboard event.
OnRequestTimer | Raises the RequestTimer event.
OnSelectionChanged | Raises the SelectionChanged event.
OnSelectionModified | Raises the SelectionModified event.
OnSelectionModifying | Raises the SelectionModifying event.
OnSerializeTag | Raises the SerializeTag event.
OnSetSelfLoopShape | Raises the SetSelfLoopShape event.
OnTableSectionCollapsed | Raises the TableSectionCollapsed event.
OnTableSectionExpanded | Raises the TableSectionExpanded event.
OnTreeCollapsed | Raises the TreeCollapsed event.
OnTreeExpanded | Raises the TreeExpanded event.
OnTreeItemTextEditing | Raises the TreeItemTextEditing event.
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event.
OnViewRemoved | Raises the ViewRemoved event.

Public Events

Name | Description
ActiveLayerChanged | Raised when the diagram's active layer has changed.
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream.
BoundsChanged | Raised when the Bounds property value has changed.
CellClicked | Raised when the user clicks a table's cell.
CellTextEdited | Raised when the user edits the text of a table's cell.
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table's cell.
Clicked | Raised when the user clicks the diagram at a point where no items are located.
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user.
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user.
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
DefaultShapeChanged | Raised when the DefaultShape property value has changed.
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format.
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed.
DirtyChanged | Raised when the Dirty property value has changed.
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn.
DrawAnchorPoint | Raised when an anchor point must be custom drawn.
DrawBackground | Raised to let you custom draw the diagram background.
DrawCell | Raised when a table's cell must be custom drawn.
DrawForeground | Raised to let you custom draw the diagram foreground.
DrawLink | Raised when a diagram link must be custom drawn.
DrawNode | Raised when a diagram node must be custom drawn.
EndLoad | Raised when the component ends loading diagram data from a file or memory stream.
ExpandButtonClicked | Raised if ExpandButtonAction is set to RaiseEvents and the [+/-] button of an Expandable node is clicked.
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed.
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively.
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively.
JsonDeserializeTag | Raised when the Tag of a diagram item must be deserialized from Json.
JsonSerializeTag | Raised when the Tag of a diagram item must be serialized to Json.
LabelClicked | Raised when the user clicks a link label.
LayerVisibilityChanged | Raised when the visibility of a Layer changes.
LinkActivated | Raised when a link becomes the ActiveItem.
LinkClicked | Raised when the user clicks a link.
LinkCreateCancelled | Raised when the user cancels link creation.
LinkCreated | Raised when the user draws a new link.
LinkCreating | A validation event raised while the user is drawing a new link.
LinkDeactivated | Raised when a link is no longer the ActiveItem.
LinkDeleted | Raised when a link is deleted, either programmatically or by the user.
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation.
LinkDeselected | Raised when a link is deselected, either programmatically or by the user.
LinkModified | Raised when the user moves any control point of a link.
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link.
LinkModifying | A validation event raised while the user is modifying a link.
LinkPasted | Raised when a link has been pasted from the clipboard.
LinkRouted | Raised when a link is routed by the auto-routing algorithm.
LinkSelected | Raised when a link is selected, either programmatically or by the user.
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation.
LinkSplit | Raised when the user splits a link interactively.
LinkStartModifying | A validation event raised when the user starts modifying a link.
LinkTextEdited | Raised when the user edits the text of a link.
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link.
MeasureUnitChanged | Raised when the MeasureUnit property value has changed.
NodeActivated | Raised when a node becomes the ActiveItem.
NodeClicked | Raised when the user clicks a node.
NodeCreateCancelled | Raised when the user cancels node creation.
NodeCreated | Raised when the user draws a new node.
NodeCreating | A validation event raised while the user is drawing a new node.
NodeDeactivated | Raised when a node is no longer the ActiveItem.
NodeDeleted | Raised when a node is deleted, either programmatically or by the user.
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation.
NodeDeselected | Raised when a node is deselected, either programmatically or by the user.
NodeModified | Raised when the user moves or resizes a node.
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node.
NodeModifying | A validation event raised while the user is moving or resizing a node.
NodePasted | Raised when a node has been pasted from the clipboard.
NodeSelected | Raised when a node is selected, either programmatically or by the user.
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation.
NodeStartModifying | A validation event raised when the user starts modifying a node.
NodeTextEdited | Raised when the user edits the text of a node.
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node.
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed.
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled.
Repaint | Raised when the diagram views should be repainted.
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap.
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard.
RequestTimer | Raised when an object within the diagram needs to start or stop a timer.
SelectionChanged | Raised when an item is added to or removed from the selection.
SelectionModified | Raised when the user moves multiple selected items.
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification.
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document.
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape.
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row.
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row.
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a treeviewnode's item.
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point.
ViewRemoved | Raised when a DiagramView is detached from this diagram.

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase Constructor

DiagramBase Constructor
[image]

Initializes a new instance of the DiagramBase class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramBase ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase Methods

DiagramBase Methods
[image]

Protected Methods

Name | Description
OnBeginLoad | Raises the BeginLoad event.
OnBoundsChanged | Raises the BoundsChanged event.
OnCellClicked | Raises the CellClicked event.
OnCellTextEdited | Raises the CellTextEdited event.
OnCellTextEditing | Raises the CellTextEditing event to validate entering inplace edit mode.
OnClicked | Raises the Clicked event.
OnContainerChildAdded | Raises the ContainerChildAdded event.
OnContainerChildRemoved | Raises the ContainerChildRemoved event.
OnContainerFolded | Raises the ContainerFolded event.
OnContainerUnfolded | Raises the ContainerUnfolded event.
OnDefaultShapeChanged | Raises the DefaultShapeChanged event.
OnDeserializeTag | Raises the DeserializeTag event.
OnDestinationAnchorChanged | Raises the DestinationAnchorChanged event.
OnDirtyChanged | Raises the DirtyChanged event.
OnDrawAdjustmentHandles | Raises the DrawAdjustmentHandles event.
OnDrawAnchorPoint | Raises the DrawAnchorPoint event.
OnDrawBackground | Raises the DrawBackground event.
OnDrawCell | Raises the DrawCell event.
OnDrawForeground | Raises the DrawForeground event.
OnDrawLink | Raises the DrawLink event.
OnDrawNode | Raises the DrawNode event.
OnEndLoad | Raises the EndLoad event.
OnExpandButtonClicked | Raises the ExpandButtonClicked event.
OnHitTestAdjustmentHandles | Raises the HitTestAdjustmentHandles event.
OnInitializeLink | Raises the InitializeLink event.
OnInitializeNode | Raises the InitializeNode event.
OnItemAdded | Raises the ItemAdded event.
OnItemRemoved | Raises the ItemRemoved event.
OnJsonDeserializeTag | Raises the JsonDeserializeTag event.
OnJsonSerializeTag | Raises the JsonSerializeTag event.
OnLabelClicked | Raises the LabelClicked event.
OnLayerVisibilityChanged | Raises the LayerVisibilityChanged event.
OnLinkActivated | Raises the LinkActivated event.
OnLinkClicked | Raises the LinkClicked event.
OnLinkCreateCancelled | Raises the LinkCreateCancelled event.
OnLinkCreated | Raises the LinkCreated event.
OnLinkCreating | Raises the LinkCreating event.
OnLinkDeactivated | Raises the LinkDeactivated event.
OnLinkDeleted | Raises the LinkDeleted event.
OnLinkDeleting | Raises the LinkDeleting event.
OnLinkDeselected | Raises the LinkDeselected event.
OnLinkModified | Raises the LinkModified event.
OnLinkModifyCancelled | Raises the LinkModifyCancelled event.
OnLinkModifying | Raises the LinkModifying event.
OnLinkPasted | Raises the LinkPasted event.
OnLinkRouted | Raises the LinkRouted event.
OnLinkSelected | Raises the LinkSelected event.
OnLinkSelecting | Raises the LinkSelecting event.
OnLinkSplit | Raises the LinkSplit event.
OnLinkStartModifying | Raises the LinkStartModifying event.
OnLinkTextEdited | Raises the LinkTextEdited event.
OnLinkTextEditing | Raises the LinkTextEditing event to validate entering inplace edit mode.
OnMeasureUnitChanged | Raises the MeasureUnitChanged event.
OnNodeActivated | Raises the NodeActivated event.
OnNodeClicked | Raises the NodeClicked event.
OnNodeCreateCancelled | Raises the NodeCreateCancelled event.
OnNodeCreated | Raises the NodeCreated event.
OnNodeCreating | Raises the NodeCreating event.
OnNodeDeactivated | Raises the NodeDeactivated event.
OnNodeDeleted | Raises the NodeDeleted event.
OnNodeDeleting | Raises the NodeDeleting event.
OnNodeDeselected | Raises the NodeDeselected event.
OnNodeModified | Raises the NodeModified event.
OnNodeModifyCancelled | Raises the NodeModifyCancelled event.
OnNodeModifying | Raises the NodeModifying event.
OnNodePasted | Raises the NodePasted event.
OnNodeSelected | Raises the NodeSelected event.
OnNodeSelecting | Raises the NodeSelecting event.
OnNodeStartModifying | Raises the NodeStartModifying event.
OnNodeTextEdited | Raises the NodeTextEdited event.
OnNodeTextEditing | Raises the NodeTextEditing event to validate entering inplace edit mode.
OnOriginAnchorChanged | Raises the OriginAnchorChanged event.
OnQueryAlignTarget | Raises the QueryAlignTarget event.
OnRepaint | Raises the Repaint event.
OnRequestClipboard | Raises the RequestClipboard event.
OnRequestTimer | Raises the RequestTimer event.
OnSelectionChanged | Raises the SelectionChanged event.
OnSelectionModified | Raises the SelectionModified event.
OnSelectionModifying | Raises the SelectionModifying event.
OnSerializeTag | Raises the SerializeTag event.
OnSetSelfLoopShape | Raises the SetSelfLoopShape event.
OnTableSectionCollapsed | Raises the TableSectionCollapsed event.
OnTableSectionExpanded | Raises the TableSectionExpanded event.
OnTreeCollapsed | Raises the TreeCollapsed event.
OnTreeExpanded | Raises the TreeExpanded event.
OnTreeItemTextEditing | Raises the TreeItemTextEditing event.
OnValidateAnchorPoint | Raises the ValidateAnchorPoint event.
OnViewRemoved | Raises the ViewRemoved event.

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnBeginLoad Method

DiagramBase.OnBeginLoad Method
[image]

Raises the BeginLoad event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnBeginLoad (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBeginLoad( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnBoundsChanged Method

DiagramBase.OnBoundsChanged Method
[image]

Raises the BoundsChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnBoundsChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnBoundsChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnCellClicked Method

DiagramBase.OnCellClicked Method
[image]

Raises the CellClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCellClicked (
CellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellClicked( _
e As CellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnCellTextEdited Method

DiagramBase.OnCellTextEdited Method
[image]

Raises the CellTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCellTextEdited (
EditCellTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellTextEdited( _
e As EditCellTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnCellTextEditing Method

DiagramBase.OnCellTextEditing Method
[image]

Raises the CellTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCellTextEditing (
CellValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCellTextEditing( _
e As CellValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnClicked Method

DiagramBase.OnClicked Method
[image]

Raises the Clicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnClicked (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnClicked( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerChildAdded Method

DiagramBase.OnContainerChildAdded Method
[image]

Raises the ContainerChildAdded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerChildAdded (
ContainerChildEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerChildAdded( _
e As ContainerChildEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerChildRemoved Method

DiagramBase.OnContainerChildRemoved Method
[image]

Raises the ContainerChildRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerChildRemoved (
ContainerChildEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerChildRemoved( _
e As ContainerChildEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerFolded Method

DiagramBase.OnContainerFolded Method
[image]

Raises the ContainerFolded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerFolded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerFolded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnContainerUnfolded Method

DiagramBase.OnContainerUnfolded Method
[image]

Raises the ContainerUnfolded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnContainerUnfolded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnContainerUnfolded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDefaultShapeChanged Method

DiagramBase.OnDefaultShapeChanged Method
[image]

Raises the DefaultShapeChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDefaultShapeChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDefaultShapeChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDeserializeTag Method

DiagramBase.OnDeserializeTag Method
[image]

Raises the DeserializeTag event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDeserializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDeserializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDestinationAnchorChanged Method

DiagramBase.OnDestinationAnchorChanged Method
[image]

Raises the DestinationAnchorChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDestinationAnchorChanged (
AnchorPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDestinationAnchorChanged( _
e As AnchorPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDirtyChanged Method

DiagramBase.OnDirtyChanged Method
[image]

Raises the DirtyChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDirtyChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDirtyChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawAdjustmentHandles Method

DiagramBase.OnDrawAdjustmentHandles Method
[image]

Raises the DrawAdjustmentHandles event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawAdjustmentHandles (
DrawItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawAdjustmentHandles( _
e As DrawItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawAnchorPoint Method

DiagramBase.OnDrawAnchorPoint Method
[image]

Raises the DrawAnchorPoint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawAnchorPoint (
DrawAnchorPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawAnchorPoint( _
e As DrawAnchorPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawBackground Method

DiagramBase.OnDrawBackground Method
[image]

Raises the DrawBackground event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawBackground (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawBackground( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawCell Method

DiagramBase.OnDrawCell Method
[image]

Raises the DrawCell event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawCell (
DrawCellEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawCell( _
e As DrawCellEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawForeground Method

DiagramBase.OnDrawForeground Method
[image]

Raises the DrawForeground event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawForeground (
DiagramEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawForeground( _
e As DiagramEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawLink Method

DiagramBase.OnDrawLink Method
[image]

Raises the DrawLink event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawLink (
DrawLinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawLink( _
e As DrawLinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnDrawNode Method

DiagramBase.OnDrawNode Method
[image]

Raises the DrawNode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnDrawNode (
DrawNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnDrawNode( _
e As DrawNodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnEndLoad Method

DiagramBase.OnEndLoad Method
[image]

Raises the EndLoad event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnEndLoad (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEndLoad( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnExpandButtonClicked Method

DiagramBase.OnExpandButtonClicked Method
[image]

Raises the ExpandButtonClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnExpandButtonClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnExpandButtonClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnHitTestAdjustmentHandles Method

DiagramBase.OnHitTestAdjustmentHandles Method
[image]

Raises the HitTestAdjustmentHandles event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnHitTestAdjustmentHandles (
HitTestEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnHitTestAdjustmentHandles( _
e As HitTestEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnInitializeLink Method

DiagramBase.OnInitializeLink Method
[image]

Raises the InitializeLink event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnInitializeLink (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInitializeLink( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnInitializeNode Method

DiagramBase.OnInitializeNode Method
[image]

Raises the InitializeNode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnInitializeNode (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnInitializeNode( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnItemAdded Method

DiagramBase.OnItemAdded Method
[image]

Raises the ItemAdded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnItemAdded (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemAdded( _
e As ItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnItemRemoved Method

DiagramBase.OnItemRemoved Method
[image]

Raises the ItemRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnItemRemoved (
ItemEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnItemRemoved( _
e As ItemEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnJsonDeserializeTag Method

DiagramBase.OnJsonDeserializeTag Method
[image]

Raises the JsonDeserializeTag event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnJsonDeserializeTag (
JsonSerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnJsonDeserializeTag( _
e As JsonSerializeTagEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnJsonSerializeTag Method

DiagramBase.OnJsonSerializeTag Method
[image]

Raises the JsonSerializeTag event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnJsonSerializeTag (
JsonSerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnJsonSerializeTag( _
e As JsonSerializeTagEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLabelClicked Method

DiagramBase.OnLabelClicked Method
[image]

Raises the LabelClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLabelClicked (
LinkLabelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLabelClicked( _
e As LinkLabelEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLayerVisibilityChanged Method

DiagramBase.OnLayerVisibilityChanged Method
[image]

Raises the LayerVisibilityChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLayerVisibilityChanged (
LayerEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLayerVisibilityChanged( _
e As LayerEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkActivated Method

DiagramBase.OnLinkActivated Method
[image]

Raises the LinkActivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkActivated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkActivated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkClicked Method

DiagramBase.OnLinkClicked Method
[image]

Raises the LinkClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkClicked (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkClicked( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkCreateCancelled Method

DiagramBase.OnLinkCreateCancelled Method
[image]

Raises the LinkCreateCancelled event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkCreateCancelled (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkCreateCancelled( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkCreated Method

DiagramBase.OnLinkCreated Method
[image]

Raises the LinkCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkCreated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkCreated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkCreating Method

DiagramBase.OnLinkCreating Method
[image]

Raises the LinkCreating event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkCreating (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkCreating( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeactivated Method

DiagramBase.OnLinkDeactivated Method
[image]

Raises the LinkDeactivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeactivated (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeactivated( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeleted Method

DiagramBase.OnLinkDeleted Method
[image]

Raises the LinkDeleted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeleted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeleted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeleting Method

DiagramBase.OnLinkDeleting Method
[image]

Raises the LinkDeleting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeleting (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeleting( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkDeselected Method

DiagramBase.OnLinkDeselected Method
[image]

Raises the LinkDeselected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkDeselected (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkDeselected( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkModified Method

DiagramBase.OnLinkModified Method
[image]

Raises the LinkModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkModified (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkModified( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkModifyCancelled Method

DiagramBase.OnLinkModifyCancelled Method
[image]

Raises the LinkModifyCancelled event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkModifyCancelled (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkModifyCancelled( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkModifying Method

DiagramBase.OnLinkModifying Method
[image]

Raises the LinkModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkModifying (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkModifying( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkPasted Method

DiagramBase.OnLinkPasted Method
[image]

Raises the LinkPasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkPasted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkPasted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkRouted Method

DiagramBase.OnLinkRouted Method
[image]

Raises the LinkRouted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkRouted (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkRouted( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkSelected Method

DiagramBase.OnLinkSelected Method
[image]

Raises the LinkSelected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkSelected (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkSelected( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkSelecting Method

DiagramBase.OnLinkSelecting Method
[image]

Raises the LinkSelecting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkSelecting (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkSelecting( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkSplit Method

DiagramBase.OnLinkSplit Method
[image]

Raises the LinkSplit event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkSplit (
LinkEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkSplit( _
e As LinkEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkStartModifying Method

DiagramBase.OnLinkStartModifying Method
[image]

Raises the LinkStartModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkStartModifying (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkStartModifying( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkTextEdited Method

DiagramBase.OnLinkTextEdited Method
[image]

Raises the LinkTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkTextEdited (
EditLinkTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkTextEdited( _
e As EditLinkTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnLinkTextEditing Method

DiagramBase.OnLinkTextEditing Method
[image]

Raises the LinkTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLinkTextEditing (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLinkTextEditing( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnMeasureUnitChanged Method

DiagramBase.OnMeasureUnitChanged Method
[image]

Raises the MeasureUnitChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnMeasureUnitChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnMeasureUnitChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeActivated Method

DiagramBase.OnNodeActivated Method
[image]

Raises the NodeActivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeActivated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeActivated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeClicked Method

DiagramBase.OnNodeClicked Method
[image]

Raises the NodeClicked event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeClicked (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeClicked( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeCreateCancelled Method

DiagramBase.OnNodeCreateCancelled Method
[image]

Raises the NodeCreateCancelled event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeCreateCancelled (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeCreateCancelled( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeCreated Method

DiagramBase.OnNodeCreated Method
[image]

Raises the NodeCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeCreated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeCreated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeCreating Method

DiagramBase.OnNodeCreating Method
[image]

Raises the NodeCreating event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeCreating (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeCreating( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeactivated Method

DiagramBase.OnNodeDeactivated Method
[image]

Raises the NodeDeactivated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeactivated (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeactivated( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeleted Method

DiagramBase.OnNodeDeleted Method
[image]

Raises the NodeDeleted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeleted (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeleted( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeleting Method

DiagramBase.OnNodeDeleting Method
[image]

Raises the NodeDeleting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeleting (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeleting( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeDeselected Method

DiagramBase.OnNodeDeselected Method
[image]

Raises the NodeDeselected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDeselected (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDeselected( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeModified Method

DiagramBase.OnNodeModified Method
[image]

Raises the NodeModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeModified (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeModified( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeModifyCancelled Method

DiagramBase.OnNodeModifyCancelled Method
[image]

Raises the NodeModifyCancelled event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeModifyCancelled (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeModifyCancelled( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeModifying Method

DiagramBase.OnNodeModifying Method
[image]

Raises the NodeModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeModifying (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeModifying( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodePasted Method

DiagramBase.OnNodePasted Method
[image]

Raises the NodePasted event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodePasted (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodePasted( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeSelected Method

DiagramBase.OnNodeSelected Method
[image]

Raises the NodeSelected event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeSelected (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeSelected( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeSelecting Method

DiagramBase.OnNodeSelecting Method
[image]

Raises the NodeSelecting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeSelecting (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeSelecting( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeStartModifying Method

DiagramBase.OnNodeStartModifying Method
[image]

Raises the NodeStartModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeStartModifying (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeStartModifying( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeTextEdited Method

DiagramBase.OnNodeTextEdited Method
[image]

Raises the NodeTextEdited event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeTextEdited (
EditNodeTextEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeTextEdited( _
e As EditNodeTextEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnNodeTextEditing Method

DiagramBase.OnNodeTextEditing Method
[image]

Raises the NodeTextEditing event to validate entering inplace edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeTextEditing (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeTextEditing( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnOriginAnchorChanged Method

DiagramBase.OnOriginAnchorChanged Method
[image]

Raises the OriginAnchorChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnOriginAnchorChanged (
AnchorPointEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnOriginAnchorChanged( _
e As AnchorPointEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnQueryAlignTarget Method

DiagramBase.OnQueryAlignTarget Method
[image]

Raises the QueryAlignTarget event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnQueryAlignTarget (
NodeValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnQueryAlignTarget( _
e As NodeValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnRepaint Method

DiagramBase.OnRepaint Method
[image]

Raises the Repaint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRepaint (
RepaintEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRepaint( _
e As RepaintEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnRequestClipboard Method

DiagramBase.OnRequestClipboard Method
[image]

Raises the RequestClipboard event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRequestClipboard (
ClipboardEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRequestClipboard( _
e As ClipboardEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnRequestTimer Method

DiagramBase.OnRequestTimer Method
[image]

Raises the RequestTimer event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRequestTimer (
TimerEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRequestTimer( _
e As TimerEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSelectionChanged Method

DiagramBase.OnSelectionChanged Method
[image]

Raises the SelectionChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSelectionChanged (
EventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionChanged( _
e As EventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSelectionModified Method

DiagramBase.OnSelectionModified Method
[image]

Raises the SelectionModified event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSelectionModified (
SelectionEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionModified( _
e As SelectionEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSelectionModifying Method

DiagramBase.OnSelectionModifying Method
[image]

Raises the SelectionModifying event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSelectionModifying (
SelectionValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSelectionModifying( _
e As SelectionValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSerializeTag Method

DiagramBase.OnSerializeTag Method
[image]

Raises the SerializeTag event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSerializeTag (
SerializeTagEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSerializeTag( _
e As SerializeTagEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnSetSelfLoopShape Method

DiagramBase.OnSetSelfLoopShape Method
[image]

Raises the SetSelfLoopShape event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnSetSelfLoopShape (
LinkShapeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnSetSelfLoopShape( _
e As LinkShapeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTableSectionCollapsed Method

DiagramBase.OnTableSectionCollapsed Method
[image]

Raises the TableSectionCollapsed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTableSectionCollapsed (
RowEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableSectionCollapsed( _
e As RowEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTableSectionExpanded Method

DiagramBase.OnTableSectionExpanded Method
[image]

Raises the TableSectionExpanded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTableSectionExpanded (
RowEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTableSectionExpanded( _
e As RowEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTreeCollapsed Method

DiagramBase.OnTreeCollapsed Method
[image]

Raises the TreeCollapsed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTreeCollapsed (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeCollapsed( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTreeExpanded Method

DiagramBase.OnTreeExpanded Method
[image]

Raises the TreeExpanded event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTreeExpanded (
NodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeExpanded( _
e As NodeEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnTreeItemTextEditing Method

DiagramBase.OnTreeItemTextEditing Method
[image]

Raises the TreeItemTextEditing event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTreeItemTextEditing (
TreeItemValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTreeItemTextEditing( _
e As TreeItemValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnValidateAnchorPoint Method

DiagramBase.OnValidateAnchorPoint Method
[image]

Raises the ValidateAnchorPoint event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnValidateAnchorPoint (
LinkValidationEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnValidateAnchorPoint( _
e As LinkValidationEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OnViewRemoved Method

DiagramBase.OnViewRemoved Method
[image]

Raises the ViewRemoved event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnViewRemoved (
CancelEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnViewRemoved( _
e As CancelEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase Events

DiagramBase Events
[image]

Public Events

Name | Description
ActiveLayerChanged | Raised when the diagram's active layer has changed.
BeginLoad | Raised when the component starts loading diagram data from a file or memory stream.
BoundsChanged | Raised when the Bounds property value has changed.
CellClicked | Raised when the user clicks a table's cell.
CellTextEdited | Raised when the user edits the text of a table's cell.
CellTextEditing | A validation event that lets you approve or reject changes made to the text of a table's cell.
Clicked | Raised when the user clicks the diagram at a point where no items are located.
ContainerChildAdded | Raised when a node is added to a ContainerNode, either programmatically or by the user.
ContainerChildRemoved | Raised when a node is removed from a ContainerNode, either programmatically or by the user.
ContainerFolded | Raised when the user folds a container by clicking the arrow-up button in the container's caption area.
ContainerUnfolded | Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.
DefaultShapeChanged | Raised when the DefaultShape property value has changed.
DeserializeTag | Raised when the Tag of a diagram item must be deserialized from XML format.
DestinationAnchorChanged | Raised when the DestinationAnchor property value of a link has changed.
DirtyChanged | Raised when the Dirty property value has changed.
DrawAdjustmentHandles | Raised when item's adjustment handles must be custom drawn.
DrawAnchorPoint | Raised when an anchor point must be custom drawn.
DrawBackground | Raised to let you custom draw the diagram background.
DrawCell | Raised when a table's cell must be custom drawn.
DrawForeground | Raised to let you custom draw the diagram foreground.
DrawLink | Raised when a diagram link must be custom drawn.
DrawNode | Raised when a diagram node must be custom drawn.
EndLoad | Raised when the component ends loading diagram data from a file or memory stream.
ExpandButtonClicked | Raised if ExpandButtonAction is set to RaiseEvents and the [+/-] button of an Expandable node is clicked.
HitTestAdjustmentHandles | Raised when custom hit testing of item's adjustment handles must be performed.
InitializeLink | Raised when the user starts drawing a new link, just after the DiagramLink instance is created.
InitializeNode | Raised when the user starts drawing a new node, just after the DiagramNode instance is created.
ItemAdded | Raised when an item is added to the diagram, either programmatically or interactively.
ItemRemoved | Raised when an item is removed from the diagram, either programmatically or interactively.
JsonDeserializeTag | Raised when the Tag of a diagram item must be deserialized from Json.
JsonSerializeTag | Raised when the Tag of a diagram item must be serialized to Json.
LabelClicked | Raised when the user clicks a link label.
LayerVisibilityChanged | Raised when the visibility of a Layer changes.
LinkActivated | Raised when a link becomes the ActiveItem.
LinkClicked | Raised when the user clicks a link.
LinkCreateCancelled | Raised when the user cancels link creation.
LinkCreated | Raised when the user draws a new link.
LinkCreating | A validation event raised while the user is drawing a new link.
LinkDeactivated | Raised when a link is no longer the ActiveItem.
LinkDeleted | Raised when a link is deleted, either programmatically or by the user.
LinkDeleting | Raised when the user tries to delete a link, this event lets you cancel the operation.
LinkDeselected | Raised when a link is deselected, either programmatically or by the user.
LinkModified | Raised when the user moves any control point of a link.
LinkModifyCancelled | Raised when the user cancels move or resize operation being done on a link.
LinkModifying | A validation event raised while the user is modifying a link.
LinkPasted | Raised when a link has been pasted from the clipboard.
LinkRouted | Raised when a link is routed by the auto-routing algorithm.
LinkSelected | Raised when a link is selected, either programmatically or by the user.
LinkSelecting | Raised when the user tries to select a link, this event lets you cancel the operation.
LinkSplit | Raised when the user splits a link interactively.
LinkStartModifying | A validation event raised when the user starts modifying a link.
LinkTextEdited | Raised when the user edits the text of a link.
LinkTextEditing | A validation event that lets you approve or reject changes made to the text of a link.
MeasureUnitChanged | Raised when the MeasureUnit property value has changed.
NodeActivated | Raised when a node becomes the ActiveItem.
NodeClicked | Raised when the user clicks a node.
NodeCreateCancelled | Raised when the user cancels node creation.
NodeCreated | Raised when the user draws a new node.
NodeCreating | A validation event raised while the user is drawing a new node.
NodeDeactivated | Raised when a node is no longer the ActiveItem.
NodeDeleted | Raised when a node is deleted, either programmatically or by the user.
NodeDeleting | Raised when the user tries to delete a node, this event lets you cancel the operation.
NodeDeselected | Raised when a node is deselected, either programmatically or by the user.
NodeModified | Raised when the user moves or resizes a node.
NodeModifyCancelled | Raised when the user cancels move or resize operation being done on a node.
NodeModifying | A validation event raised while the user is moving or resizing a node.
NodePasted | Raised when a node has been pasted from the clipboard.
NodeSelected | Raised when a node is selected, either programmatically or by the user.
NodeSelecting | Raised when the user tries to select a node, this event lets you cancel the operation.
NodeStartModifying | A validation event raised when the user starts modifying a node.
NodeTextEdited | Raised when the user edits the text of a node.
NodeTextEditing | A validation event that lets you approve or reject changes made to the text of a node.
OriginAnchorChanged | Raised when the OriginAnchor property value of a link has changed.
QueryAlignTarget | Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled.
Repaint | Raised when the diagram views should be repainted.
RequestCacheReset | Raised when an object within the diagram requests a reset of the cached bitmap.
RequestClipboard | Raised when an object within the diagram requests an operation with the clipboard.
RequestTimer | Raised when an object within the diagram needs to start or stop a timer.
SelectionChanged | Raised when an item is added to or removed from the selection.
SelectionModified | Raised when the user moves multiple selected items.
SelectionModifying | Raised while the user is moving multiple selected items, this event lets you cancel the modification.
SerializeTag | Raised when the Tag of a diagram item must be serialized into an XML document.
SetSelfLoopShape | Raised when a link becomes a self-loop, giving you a chance to override the default look shape.
TableSectionCollapsed | Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row.
TableSectionExpanded | Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row.
TreeCollapsed | Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.
TreeExpanded | Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.
TreeItemTextEditing | A validation event that lets you approve or reject changes made to the text of a treeviewnode's item.
ValidateAnchorPoint | A validation event that lets you approve or reject connecting a link to an anchor point.
ViewRemoved | Raised when a DiagramView is detached from this diagram.

See Also

DiagramBase Class


MindFusion.Diagramming.DiagramBase.ActiveLayerChanged Event

DiagramBase.ActiveLayerChanged Event
[image]

Raised when the diagram's active layer has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler ActiveLayerChanged

Visual Basic [image] Copy Code

Public Event ActiveLayerChanged As EventHandler

Event Data

ActiveLayerChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.BeginLoad Event

DiagramBase.BeginLoad Event
[image]

Raised when the component starts loading diagram data from a file or memory stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler BeginLoad

Visual Basic [image] Copy Code

Public Event BeginLoad As EventHandler

Event Data

BeginLoad event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.BoundsChanged Event

DiagramBase.BoundsChanged Event
[image]

Raised when the Bounds property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler BoundsChanged

Visual Basic [image] Copy Code

Public Event BoundsChanged As EventHandler

Event Data

BoundsChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.CellClicked Event

DiagramBase.CellClicked Event
[image]

Raised when the user clicks a table's cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellEventArgs> CellClicked

Visual Basic [image] Copy Code

Public Event CellClicked As EventHandler(Of CellEventArgs)

Event Data

CellClicked event handlers receive an argument of type CellEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.CellTextEdited Event

DiagramBase.CellTextEdited Event
[image]

Raised when the user edits the text of a table's cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<EditCellTextEventArgs> CellTextEdited

Visual Basic [image] Copy Code

Public Event CellTextEdited As EventHandler(Of EditCellTextEventArgs)

Event Data

CellTextEdited event handlers receive an argument of type EditCellTextEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.CellTextEditing Event

DiagramBase.CellTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a table's cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellValidationEventArgs> CellTextEditing

Visual Basic [image] Copy Code

Public Event CellTextEditing As EventHandler(Of CellValidationEventArgs)

Event Data

CellTextEditing event handlers receive an argument of type CellValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.Clicked Event

DiagramBase.Clicked Event
[image]

Raised when the user clicks the diagram at a point where no items are located.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> Clicked

Visual Basic [image] Copy Code

Public Event Clicked As EventHandler(Of DiagramEventArgs)

Event Data

Clicked event handlers receive an argument of type DiagramEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ContainerChildAdded Event

DiagramBase.ContainerChildAdded Event
[image]

Raised when a node is added to a ContainerNode, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ContainerChildEventArgs> ContainerChildAdded

Visual Basic [image] Copy Code

Public Event ContainerChildAdded As EventHandler(Of ContainerChildEventArgs)

Event Data

ContainerChildAdded event handlers receive an argument of type ContainerChildEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ContainerChildRemoved Event

DiagramBase.ContainerChildRemoved Event
[image]

Raised when a node is removed from a ContainerNode, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ContainerChildEventArgs> ContainerChildRemoved

Visual Basic [image] Copy Code

Public Event ContainerChildRemoved As EventHandler(Of ContainerChildEventArgs)

Event Data

ContainerChildRemoved event handlers receive an argument of type ContainerChildEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ContainerFolded Event

DiagramBase.ContainerFolded Event
[image]

Raised when the user folds a container by clicking the arrow-up button in the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ContainerFolded

Visual Basic [image] Copy Code

Public Event ContainerFolded As EventHandler(Of NodeEventArgs)

Event Data

ContainerFolded event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ContainerUnfolded Event

DiagramBase.ContainerUnfolded Event
[image]

Raised when the user unfolds a container by clicking the arrow-down button in the container's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ContainerUnfolded

Visual Basic [image] Copy Code

Public Event ContainerUnfolded As EventHandler(Of NodeEventArgs)

Event Data

ContainerUnfolded event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DefaultShapeChanged Event

DiagramBase.DefaultShapeChanged Event
[image]

Raised when the DefaultShape property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler DefaultShapeChanged

Visual Basic [image] Copy Code

Public Event DefaultShapeChanged As EventHandler

Event Data

DefaultShapeChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DeserializeTag Event

DiagramBase.DeserializeTag Event
[image]

Raised when the Tag of a diagram item must be deserialized from XML format.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> DeserializeTag

Visual Basic [image] Copy Code

Public Event DeserializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

DeserializeTag event handlers receive an argument of type SerializeTagEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DestinationAnchorChanged Event

DiagramBase.DestinationAnchorChanged Event
[image]

Raised when the DestinationAnchor property value of a link has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<AnchorPointEventArgs> DestinationAnchorChanged

Visual Basic [image] Copy Code

Public Event DestinationAnchorChanged As EventHandler(Of AnchorPointEventArgs)

Event Data

DestinationAnchorChanged event handlers receive an argument of type AnchorPointEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DirtyChanged Event

DiagramBase.DirtyChanged Event
[image]

Raised when the Dirty property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler DirtyChanged

Visual Basic [image] Copy Code

Public Event DirtyChanged As EventHandler

Event Data

DirtyChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DrawAdjustmentHandles Event

DiagramBase.DrawAdjustmentHandles Event
[image]

Raised when item's adjustment handles must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawItemEventArgs> DrawAdjustmentHandles

Visual Basic [image] Copy Code

Public Event DrawAdjustmentHandles As EventHandler(Of DrawItemEventArgs)

Event Data

DrawAdjustmentHandles event handlers receive an argument of type DrawItemEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DrawAnchorPoint Event

DiagramBase.DrawAnchorPoint Event
[image]

Raised when an anchor point must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawAnchorPointEventArgs> DrawAnchorPoint

Visual Basic [image] Copy Code

Public Event DrawAnchorPoint As EventHandler(Of DrawAnchorPointEventArgs)

Event Data

DrawAnchorPoint event handlers receive an argument of type DrawAnchorPointEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DrawBackground Event

DiagramBase.DrawBackground Event
[image]

Raised to let you custom draw the diagram background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> DrawBackground

Visual Basic [image] Copy Code

Public Event DrawBackground As EventHandler(Of DiagramEventArgs)

Event Data

DrawBackground event handlers receive an argument of type DiagramEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DrawCell Event

DiagramBase.DrawCell Event
[image]

Raised when a table's cell must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawCellEventArgs> DrawCell

Visual Basic [image] Copy Code

Public Event DrawCell As EventHandler(Of DrawCellEventArgs)

Event Data

DrawCell event handlers receive an argument of type DrawCellEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DrawForeground Event

DiagramBase.DrawForeground Event
[image]

Raised to let you custom draw the diagram foreground.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramEventArgs> DrawForeground

Visual Basic [image] Copy Code

Public Event DrawForeground As EventHandler(Of DiagramEventArgs)

Event Data

DrawForeground event handlers receive an argument of type DiagramEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DrawLink Event

DiagramBase.DrawLink Event
[image]

Raised when a diagram link must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawLinkEventArgs> DrawLink

Visual Basic [image] Copy Code

Public Event DrawLink As EventHandler(Of DrawLinkEventArgs)

Event Data

DrawLink event handlers receive an argument of type DrawLinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.DrawNode Event

DiagramBase.DrawNode Event
[image]

Raised when a diagram node must be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DrawNodeEventArgs> DrawNode

Visual Basic [image] Copy Code

Public Event DrawNode As EventHandler(Of DrawNodeEventArgs)

Event Data

DrawNode event handlers receive an argument of type DrawNodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.EndLoad Event

DiagramBase.EndLoad Event
[image]

Raised when the component ends loading diagram data from a file or memory stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler EndLoad

Visual Basic [image] Copy Code

Public Event EndLoad As EventHandler

Event Data

EndLoad event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ExpandButtonClicked Event

DiagramBase.ExpandButtonClicked Event
[image]

Raised if ExpandButtonAction is set to RaiseEvents and the [+/-] button of an Expandable node is clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> ExpandButtonClicked

Visual Basic [image] Copy Code

Public Event ExpandButtonClicked As EventHandler(Of NodeEventArgs)

Event Data

ExpandButtonClicked event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.HitTestAdjustmentHandles Event

DiagramBase.HitTestAdjustmentHandles Event
[image]

Raised when custom hit testing of item's adjustment handles must be performed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<HitTestEventArgs> HitTestAdjustmentHandles

Visual Basic [image] Copy Code

Public Event HitTestAdjustmentHandles As EventHandler(Of HitTestEventArgs)

Event Data

HitTestAdjustmentHandles event handlers receive an argument of type HitTestEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.InitializeLink Event

DiagramBase.InitializeLink Event
[image]

Raised when the user starts drawing a new link, just after the DiagramLink instance is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> InitializeLink

Visual Basic [image] Copy Code

Public Event InitializeLink As EventHandler(Of LinkEventArgs)

Event Data

InitializeLink event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.InitializeNode Event

DiagramBase.InitializeNode Event
[image]

Raised when the user starts drawing a new node, just after the DiagramNode instance is created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> InitializeNode

Visual Basic [image] Copy Code

Public Event InitializeNode As EventHandler(Of NodeEventArgs)

Event Data

InitializeNode event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ItemAdded Event

DiagramBase.ItemAdded Event
[image]

Raised when an item is added to the diagram, either programmatically or interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemAdded

Visual Basic [image] Copy Code

Public Event ItemAdded As EventHandler(Of ItemEventArgs)

Event Data

ItemAdded event handlers receive an argument of type ItemEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ItemRemoved Event

DiagramBase.ItemRemoved Event
[image]

Raised when an item is removed from the diagram, either programmatically or interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ItemEventArgs> ItemRemoved

Visual Basic [image] Copy Code

Public Event ItemRemoved As EventHandler(Of ItemEventArgs)

Event Data

ItemRemoved event handlers receive an argument of type ItemEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.JsonDeserializeTag Event

DiagramBase.JsonDeserializeTag Event
[image]

Raised when the Tag of a diagram item must be deserialized from Json.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<JsonSerializeTagEventArgs> JsonDeserializeTag

Visual Basic [image] Copy Code

Public Event JsonDeserializeTag As EventHandler(Of JsonSerializeTagEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.JsonSerializeTag Event

DiagramBase.JsonSerializeTag Event
[image]

Raised when the Tag of a diagram item must be serialized to Json.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<JsonSerializeTagEventArgs> JsonSerializeTag

Visual Basic [image] Copy Code

Public Event JsonSerializeTag As EventHandler(Of JsonSerializeTagEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LabelClicked Event

DiagramBase.LabelClicked Event
[image]

Raised when the user clicks a link label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkLabelEventArgs> LabelClicked

Visual Basic [image] Copy Code

Public Event LabelClicked As EventHandler(Of LinkLabelEventArgs)

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LayerVisibilityChanged Event

DiagramBase.LayerVisibilityChanged Event
[image]

Raised when the visibility of a Layer changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LayerEventArgs> LayerVisibilityChanged

Visual Basic [image] Copy Code

Public Event LayerVisibilityChanged As EventHandler(Of LayerEventArgs)

Event Data

LayerVisibilityChanged event handlers receive an argument of type LayerEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkActivated Event

DiagramBase.LinkActivated Event
[image]

Raised when a link becomes the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkActivated

Visual Basic [image] Copy Code

Public Event LinkActivated As EventHandler(Of LinkEventArgs)

Event Data

LinkActivated event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkClicked Event

DiagramBase.LinkClicked Event
[image]

Raised when the user clicks a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkClicked

Visual Basic [image] Copy Code

Public Event LinkClicked As EventHandler(Of LinkEventArgs)

Event Data

LinkClicked event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkCreateCancelled Event

DiagramBase.LinkCreateCancelled Event
[image]

Raised when the user cancels link creation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkCreateCancelled

Visual Basic [image] Copy Code

Public Event LinkCreateCancelled As EventHandler(Of LinkEventArgs)

Event Data

LinkCreateCancelled event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkCreated Event

DiagramBase.LinkCreated Event
[image]

Raised when the user draws a new link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkCreated

Visual Basic [image] Copy Code

Public Event LinkCreated As EventHandler(Of LinkEventArgs)

Event Data

LinkCreated event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkCreating Event

DiagramBase.LinkCreating Event
[image]

A validation event raised while the user is drawing a new link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkCreating

Visual Basic [image] Copy Code

Public Event LinkCreating As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkCreating event handlers receive an argument of type LinkValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkDeactivated Event

DiagramBase.LinkDeactivated Event
[image]

Raised when a link is no longer the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeactivated

Visual Basic [image] Copy Code

Public Event LinkDeactivated As EventHandler(Of LinkEventArgs)

Event Data

LinkDeactivated event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkDeleted Event

DiagramBase.LinkDeleted Event
[image]

Raised when a link is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeleted

Visual Basic [image] Copy Code

Public Event LinkDeleted As EventHandler(Of LinkEventArgs)

Event Data

LinkDeleted event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkDeleting Event

DiagramBase.LinkDeleting Event
[image]

Raised when the user tries to delete a link, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkDeleting

Visual Basic [image] Copy Code

Public Event LinkDeleting As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkDeleting event handlers receive an argument of type LinkValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkDeselected Event

DiagramBase.LinkDeselected Event
[image]

Raised when a link is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkDeselected

Visual Basic [image] Copy Code

Public Event LinkDeselected As EventHandler(Of LinkEventArgs)

Event Data

LinkDeselected event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkModified Event

DiagramBase.LinkModified Event
[image]

Raised when the user moves any control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkModified

Visual Basic [image] Copy Code

Public Event LinkModified As EventHandler(Of LinkEventArgs)

Event Data

LinkModified event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkModifyCancelled Event

DiagramBase.LinkModifyCancelled Event
[image]

Raised when the user cancels move or resize operation being done on a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkModifyCancelled

Visual Basic [image] Copy Code

Public Event LinkModifyCancelled As EventHandler(Of LinkEventArgs)

Event Data

LinkModifyCancelled event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkModifying Event

DiagramBase.LinkModifying Event
[image]

A validation event raised while the user is modifying a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkModifying

Visual Basic [image] Copy Code

Public Event LinkModifying As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkModifying event handlers receive an argument of type LinkValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkPasted Event

DiagramBase.LinkPasted Event
[image]

Raised when a link has been pasted from the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkPasted

Visual Basic [image] Copy Code

Public Event LinkPasted As EventHandler(Of LinkEventArgs)

Event Data

LinkPasted event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkRouted Event

DiagramBase.LinkRouted Event
[image]

Raised when a link is routed by the auto-routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkRouted

Visual Basic [image] Copy Code

Public Event LinkRouted As EventHandler(Of LinkEventArgs)

Event Data

LinkRouted event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkSelected Event

DiagramBase.LinkSelected Event
[image]

Raised when a link is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkSelected

Visual Basic [image] Copy Code

Public Event LinkSelected As EventHandler(Of LinkEventArgs)

Event Data

LinkSelected event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkSelecting Event

DiagramBase.LinkSelecting Event
[image]

Raised when the user tries to select a link, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkSelecting

Visual Basic [image] Copy Code

Public Event LinkSelecting As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkSelecting event handlers receive an argument of type LinkValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkSplit Event

DiagramBase.LinkSplit Event
[image]

Raised when the user splits a link interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkEventArgs> LinkSplit

Visual Basic [image] Copy Code

Public Event LinkSplit As EventHandler(Of LinkEventArgs)

Event Data

LinkSplit event handlers receive an argument of type LinkEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkStartModifying Event

DiagramBase.LinkStartModifying Event
[image]

A validation event raised when the user starts modifying a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkStartModifying

Visual Basic [image] Copy Code

Public Event LinkStartModifying As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkStartModifying event handlers receive an argument of type LinkValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkTextEdited Event

DiagramBase.LinkTextEdited Event
[image]

Raised when the user edits the text of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<EditLinkTextEventArgs> LinkTextEdited

Visual Basic [image] Copy Code

Public Event LinkTextEdited As EventHandler(Of EditLinkTextEventArgs)

Event Data

LinkTextEdited event handlers receive an argument of type EditLinkTextEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.LinkTextEditing Event

DiagramBase.LinkTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> LinkTextEditing

Visual Basic [image] Copy Code

Public Event LinkTextEditing As EventHandler(Of LinkValidationEventArgs)

Event Data

LinkTextEditing event handlers receive an argument of type LinkValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.MeasureUnitChanged Event

DiagramBase.MeasureUnitChanged Event
[image]

Raised when the MeasureUnit property value has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler MeasureUnitChanged

Visual Basic [image] Copy Code

Public Event MeasureUnitChanged As EventHandler

Event Data

MeasureUnitChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeActivated Event

DiagramBase.NodeActivated Event
[image]

Raised when a node becomes the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeActivated

Visual Basic [image] Copy Code

Public Event NodeActivated As EventHandler(Of NodeEventArgs)

Event Data

NodeActivated event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeClicked Event

DiagramBase.NodeClicked Event
[image]

Raised when the user clicks a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeClicked

Visual Basic [image] Copy Code

Public Event NodeClicked As EventHandler(Of NodeEventArgs)

Event Data

NodeClicked event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeCreateCancelled Event

DiagramBase.NodeCreateCancelled Event
[image]

Raised when the user cancels node creation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeCreateCancelled

Visual Basic [image] Copy Code

Public Event NodeCreateCancelled As EventHandler(Of NodeEventArgs)

Event Data

NodeCreateCancelled event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeCreated Event

DiagramBase.NodeCreated Event
[image]

Raised when the user draws a new node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeCreated

Visual Basic [image] Copy Code

Public Event NodeCreated As EventHandler(Of NodeEventArgs)

Event Data

NodeCreated event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeCreating Event

DiagramBase.NodeCreating Event
[image]

A validation event raised while the user is drawing a new node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeCreating

Visual Basic [image] Copy Code

Public Event NodeCreating As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeCreating event handlers receive an argument of type NodeValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeDeactivated Event

DiagramBase.NodeDeactivated Event
[image]

Raised when a node is no longer the ActiveItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeactivated

Visual Basic [image] Copy Code

Public Event NodeDeactivated As EventHandler(Of NodeEventArgs)

Event Data

NodeDeactivated event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeDeleted Event

DiagramBase.NodeDeleted Event
[image]

Raised when a node is deleted, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeleted

Visual Basic [image] Copy Code

Public Event NodeDeleted As EventHandler(Of NodeEventArgs)

Event Data

NodeDeleted event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeDeleting Event

DiagramBase.NodeDeleting Event
[image]

Raised when the user tries to delete a node, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeDeleting

Visual Basic [image] Copy Code

Public Event NodeDeleting As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeDeleting event handlers receive an argument of type NodeValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeDeselected Event

DiagramBase.NodeDeselected Event
[image]

Raised when a node is deselected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeDeselected

Visual Basic [image] Copy Code

Public Event NodeDeselected As EventHandler(Of NodeEventArgs)

Event Data

NodeDeselected event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeModified Event

DiagramBase.NodeModified Event
[image]

Raised when the user moves or resizes a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeModified

Visual Basic [image] Copy Code

Public Event NodeModified As EventHandler(Of NodeEventArgs)

Event Data

NodeModified event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeModifyCancelled Event

DiagramBase.NodeModifyCancelled Event
[image]

Raised when the user cancels move or resize operation being done on a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeModifyCancelled

Visual Basic [image] Copy Code

Public Event NodeModifyCancelled As EventHandler(Of NodeEventArgs)

Event Data

NodeModifyCancelled event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeModifying Event

DiagramBase.NodeModifying Event
[image]

A validation event raised while the user is moving or resizing a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeModifying

Visual Basic [image] Copy Code

Public Event NodeModifying As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeModifying event handlers receive an argument of type NodeValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodePasted Event

DiagramBase.NodePasted Event
[image]

Raised when a node has been pasted from the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodePasted

Visual Basic [image] Copy Code

Public Event NodePasted As EventHandler(Of NodeEventArgs)

Event Data

NodePasted event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeSelected Event

DiagramBase.NodeSelected Event
[image]

Raised when a node is selected, either programmatically or by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> NodeSelected

Visual Basic [image] Copy Code

Public Event NodeSelected As EventHandler(Of NodeEventArgs)

Event Data

NodeSelected event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeSelecting Event

DiagramBase.NodeSelecting Event
[image]

Raised when the user tries to select a node, this event lets you cancel the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeSelecting

Visual Basic [image] Copy Code

Public Event NodeSelecting As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeSelecting event handlers receive an argument of type NodeValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeStartModifying Event

DiagramBase.NodeStartModifying Event
[image]

A validation event raised when the user starts modifying a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeStartModifying

Visual Basic [image] Copy Code

Public Event NodeStartModifying As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeStartModifying event handlers receive an argument of type NodeValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeTextEdited Event

DiagramBase.NodeTextEdited Event
[image]

Raised when the user edits the text of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<EditNodeTextEventArgs> NodeTextEdited

Visual Basic [image] Copy Code

Public Event NodeTextEdited As EventHandler(Of EditNodeTextEventArgs)

Event Data

NodeTextEdited event handlers receive an argument of type EditNodeTextEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.NodeTextEditing Event

DiagramBase.NodeTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> NodeTextEditing

Visual Basic [image] Copy Code

Public Event NodeTextEditing As EventHandler(Of NodeValidationEventArgs)

Event Data

NodeTextEditing event handlers receive an argument of type NodeValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.OriginAnchorChanged Event

DiagramBase.OriginAnchorChanged Event
[image]

Raised when the OriginAnchor property value of a link has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<AnchorPointEventArgs> OriginAnchorChanged

Visual Basic [image] Copy Code

Public Event OriginAnchorChanged As EventHandler(Of AnchorPointEventArgs)

Event Data

OriginAnchorChanged event handlers receive an argument of type AnchorPointEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.QueryAlignTarget Event

DiagramBase.QueryAlignTarget Event
[image]

Raised to validate a node as target for alignment guides when AutoAlignNodes is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeValidationEventArgs> QueryAlignTarget

Visual Basic [image] Copy Code

Public Event QueryAlignTarget As EventHandler(Of NodeValidationEventArgs)

Event Data

QueryAlignTarget event handlers receive an argument of type NodeValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.Repaint Event

DiagramBase.Repaint Event
[image]

Raised when the diagram views should be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<RepaintEventArgs> Repaint

Visual Basic [image] Copy Code

Public Event Repaint As EventHandler(Of RepaintEventArgs)

Event Data

Repaint event handlers receive an argument of type RepaintEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.RequestCacheReset Event

DiagramBase.RequestCacheReset Event
[image]

Raised when an object within the diagram requests a reset of the cached bitmap.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler RequestCacheReset

Visual Basic [image] Copy Code

Public Event RequestCacheReset As EventHandler

Event Data

RequestCacheReset event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.RequestClipboard Event

DiagramBase.RequestClipboard Event
[image]

Raised when an object within the diagram requests an operation with the clipboard.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<ClipboardEventArgs> RequestClipboard

Visual Basic [image] Copy Code

Public Event RequestClipboard As EventHandler(Of ClipboardEventArgs)

Event Data

RequestClipboard event handlers receive an argument of type ClipboardEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.RequestTimer Event

DiagramBase.RequestTimer Event
[image]

Raised when an object within the diagram needs to start or stop a timer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<TimerEventArgs> RequestTimer

Visual Basic [image] Copy Code

Public Event RequestTimer As EventHandler(Of TimerEventArgs)

Event Data

RequestTimer event handlers receive an argument of type TimerEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SelectionChanged Event

DiagramBase.SelectionChanged Event
[image]

Raised when an item is added to or removed from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler SelectionChanged

Visual Basic [image] Copy Code

Public Event SelectionChanged As EventHandler

Event Data

SelectionChanged event handlers receive an argument of type EventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SelectionModified Event

DiagramBase.SelectionModified Event
[image]

Raised when the user moves multiple selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SelectionEventArgs> SelectionModified

Visual Basic [image] Copy Code

Public Event SelectionModified As EventHandler(Of SelectionEventArgs)

Event Data

SelectionModified event handlers receive an argument of type SelectionEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SelectionModifying Event

DiagramBase.SelectionModifying Event
[image]

Raised while the user is moving multiple selected items, this event lets you cancel the modification.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SelectionValidationEventArgs> SelectionModifying

Visual Basic [image] Copy Code

Public Event SelectionModifying As EventHandler(Of SelectionValidationEventArgs)

Event Data

SelectionModifying event handlers receive an argument of type SelectionValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SerializeTag Event

DiagramBase.SerializeTag Event
[image]

Raised when the Tag of a diagram item must be serialized into an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<SerializeTagEventArgs> SerializeTag

Visual Basic [image] Copy Code

Public Event SerializeTag As EventHandler(Of SerializeTagEventArgs)

Event Data

SerializeTag event handlers receive an argument of type SerializeTagEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.SetSelfLoopShape Event

DiagramBase.SetSelfLoopShape Event
[image]

Raised when a link becomes a self-loop, giving you a chance to override the default look shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkShapeEventArgs> SetSelfLoopShape

Visual Basic [image] Copy Code

Public Event SetSelfLoopShape As EventHandler(Of LinkShapeEventArgs)

Event Data

SetSelfLoopShape event handlers receive an argument of type LinkShapeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TableSectionCollapsed Event

DiagramBase.TableSectionCollapsed Event
[image]

Raised when the user collapses the rows of a table's section by clicking the [-] button in the section's header row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<RowEventArgs> TableSectionCollapsed

Visual Basic [image] Copy Code

Public Event TableSectionCollapsed As EventHandler(Of RowEventArgs)

Event Data

TableSectionCollapsed event handlers receive an argument of type RowEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TableSectionExpanded Event

DiagramBase.TableSectionExpanded Event
[image]

Raised when the user expands the rows of a table's section by clicking the [+] button in the section's header row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<RowEventArgs> TableSectionExpanded

Visual Basic [image] Copy Code

Public Event TableSectionExpanded As EventHandler(Of RowEventArgs)

Event Data

TableSectionExpanded event handlers receive an argument of type RowEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TreeCollapsed Event

DiagramBase.TreeCollapsed Event
[image]

Raised when a user collapses a tree branch by clicking the [-] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> TreeCollapsed

Visual Basic [image] Copy Code

Public Event TreeCollapsed As EventHandler(Of NodeEventArgs)

Event Data

TreeCollapsed event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TreeExpanded Event

DiagramBase.TreeExpanded Event
[image]

Raised when a user expands a tree branch by clicking the [+] button of an Expandable node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NodeEventArgs> TreeExpanded

Visual Basic [image] Copy Code

Public Event TreeExpanded As EventHandler(Of NodeEventArgs)

Event Data

TreeExpanded event handlers receive an argument of type NodeEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.TreeItemTextEditing Event

DiagramBase.TreeItemTextEditing Event
[image]

A validation event that lets you approve or reject changes made to the text of a treeviewnode's item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<TreeItemValidationEventArgs> TreeItemTextEditing

Visual Basic [image] Copy Code

Public Event TreeItemTextEditing As EventHandler(Of TreeItemValidationEventArgs)

Event Data

TreeItemTextEditing event handlers receive an argument of type TreeItemValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ValidateAnchorPoint Event

DiagramBase.ValidateAnchorPoint Event
[image]

A validation event that lets you approve or reject connecting a link to an anchor point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<LinkValidationEventArgs> ValidateAnchorPoint

Visual Basic [image] Copy Code

Public Event ValidateAnchorPoint As EventHandler(Of LinkValidationEventArgs)

Event Data

ValidateAnchorPoint event handlers receive an argument of type LinkValidationEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramBase.ViewRemoved Event

DiagramBase.ViewRemoved Event
[image]

Raised when a DiagramView is detached from this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CancelEventArgs> ViewRemoved

Visual Basic [image] Copy Code

Public Event ViewRemoved As EventHandler(Of CancelEventArgs)

Event Data

ViewRemoved event handlers receive an argument of type CancelEventArgs.

See Also

DiagramBase Members
DiagramBase Class


MindFusion.Diagramming.DiagramEventArgs Class

DiagramEventArgs Class
[image]

Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DiagramEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DiagramEventArgs

See Also

DiagramEventArgs Members


MindFusion.Diagramming.DiagramEventArgs Members

DiagramEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as Clicked and DoubleClicked.

The following tables list the members exposed by the DiagramEventArgs type.

Public Constructors

Name | Description
DiagramEventArgs | Overloaded. Initializes a new instance of the DiagramEventArgs class.

Public Properties

Name | Description
ClipRect | Gets the current clipping rectangle.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.
Position | Gets location related to the event.
VisibleRect | Gets what part of the diagram is currently visible.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Constructor

DiagramEventArgs Constructor
[image]

Initializes a new instance of the DiagramEventArgs class.

Overload List

Name | Description
DiagramEventArgs (IGraphics, Rect, Rect) | Initializes a new instance of the DiagramEventArgs class.
DiagramEventArgs (Point) | Initializes a new instance of the DiagramEventArgs class.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Constructor (IGraphics, Rect, Rect)

DiagramEventArgs Constructor (IGraphics, Rect, Rect)
See Also
[image]

Initializes a new instance of the DiagramEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramEventArgs (
IGraphics graphics,
Rect visibleRect,
Rect clipRect
)

Visual Basic [image] Copy Code

Public New ( _
graphics As IGraphics, _
visibleRect As Rect, _
clipRect As Rect _
)

Parameters

graphics

visibleRect

clipRect

See Also

DiagramEventArgs Constructor Overload List
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Constructor (Point)

DiagramEventArgs Constructor (Point)
See Also
[image]

Initializes a new instance of the DiagramEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramEventArgs (
Point position
)

Visual Basic [image] Copy Code

Public New ( _
position As Point _
)

Parameters

position

The location related to the event, expressed in document coordinates.

See Also

DiagramEventArgs Constructor Overload List
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs Properties

DiagramEventArgs Properties
[image]

Public Properties

Name | Description
ClipRect | Gets the current clipping rectangle.
Graphics | Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.
Position | Gets location related to the event.
VisibleRect | Gets what part of the diagram is currently visible.

See Also

DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.ClipRect Property

DiagramEventArgs.ClipRect Property
[image]

Gets the current clipping rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect ClipRect { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClipRect As Rect

Property Value

A Rectangle instance.

Remarks

This property is used as an argument to DrawBackground event handlers.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.Graphics Property

DiagramEventArgs.Graphics Property
[image]

Gets an object implementing the IGraphics interface whose methods should be used to draw the custom graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

Remarks

This property is used as an argument to DrawBackground event handlers.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.Position Property

DiagramEventArgs.Position Property
[image]

Gets location related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

A Point value.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramEventArgs.VisibleRect Property

DiagramEventArgs.VisibleRect Property
[image]

Gets what part of the diagram is currently visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect VisibleRect { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property VisibleRect As Rect

Property Value

A Rectangle instance.

Remarks

This property is used as an argument to DrawBackground event handlers.

See Also

DiagramEventArgs Members
DiagramEventArgs Class


MindFusion.Diagramming.DiagramItem Class

DiagramItem Class
Remarks See Also
[image]

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DiagramItem : BindableObject

Visual Basic [image] Copy Code

Public MustInherit Class DiagramItem
Inherits BindableObject

Remarks

All items in the diagram document – links and nodes – share common base class called DiagramItem. Its main function is to provide interface for the most common methods and properties of every diagram element.

MindFusion.Diagramming for .NET MAUI invokes the Draw method when an item must be drawn on screen. You can call Draw if you need to draw an item on your own graphics surface. Override the method when implementing custom item types to provide your own rendering functionality. The standard item types draw their interior and borders using the objects assigned to the Brush and Pen properties. The font of the item's text is set by the Font property.

The order in which items are painted from bottom to top is called the z-order. Moving items up or down the z-order can be done by means of the ZBottom, ZTop, ZLevelUp and ZLevelDown methods. Accessing and setting the index of an item in the z-order can be done using the ZIndex property.

Every item can cast a shadow, whose offset from the item is specified by the ShadowOffsetX and ShadowOffsetY properties. The shadow is painted using the color set in ShadowBrush.

An application can associate custom data with an item by means of the Tag property. The tags are only meant to hold data related to the entities represented by the chart items. They are not used or modified by MindFusion.Diagramming for .NET MAUI in any way. The tags are saved and loaded together with the diagram elements when serializing the document to a disk file or a stream.

Items can be locked for interactive modification through the Locked property. Locked items can still be modified programmatically. Items can also be marked as locked for automatic layout methods through the IgnoreLayout property.

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramLink
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.Selection

See Also

DiagramItem Members


MindFusion.Diagramming.DiagramItem Members

DiagramItem Members
Constructors Fields Properties Methods
[image]

Represents an item in the diagram document. All classes representing diagram elements derive from DiagramItem.

The following tables list the members exposed by the DiagramItem type.

Protected Constructors

Name | Description
DiagramItem | Overloaded. Initializes a new instance of the DiagramItem class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property.
HyperLinkProperty | Identifies the HyperLink property.
IdProperty | Identifies the Id property.
IgnoreLayoutProperty | Identifies the IgnoreLayout property.
LayerIndexProperty | Identifies the LayerIndex property.
LockedProperty | Identifies the Locked property.
PenProperty | Identifies the Pen property.
ShadowBrushProperty | Identifies the ShadowBrush property.
ShadowOffsetXProperty | Identifies the ShadowOffsetX property.
ShadowOffsetYProperty | Identifies the ShadowOffsetY property.
TagProperty | Identifies the Tag property.
TextBrushProperty | Identifies the TextBrush property.
TextPaddingProperty | Identifies the TextPadding property.
VisibleProperty | Identifies the Visible property.
WeightProperty | Idenitifies the Weight property.
ZIndexProperty | Identifies the ZIndex property.

Public Properties

Name | Description
AttachedNodes | Gets a reference to the list of items that are attached to this one.
Brush | Gets or sets the brush used to fill the interior of this item.
EffectiveBrush | Gets the effective brush of the item.
EffectiveFont | Gets the currently effective font of the item.
EffectivePen | Gets the effective pen of the item.
EffectiveShadowBrush | Gets the effective shadow brush of the item.
EffectiveTextBrush | Gets the effective text brush of the item.
Font | Gets or sets the font used to render the item's text.
HyperLink | Gets or sets the hyper link.
Id | Gets or sets user-defined identifier associated with this item.
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.
LayoutTraits | Contains properties specific to each layout algorithm.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item.
Parent | Gets the diagram that contains this item.
Pen | Gets or sets the pen used to paint the frame of the item.
RuntimeIndex | For internal use.
Selected | Gets or sets a value indicating whether a diagram item is selected.
ShadowBrush | Gets or sets the brush used to paint the item's shadow.
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item.
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item.
Style | Gets or sets the style associated with the item.
Tag | Gets or sets user-defined data associated with this item.
TextBrush | Gets or sets the brush used to paint texts inside the item.
TextPadding | Gets or sets the spacing between the item boundaries and its text.
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container.
Visible | Gets or sets a value indicating whether this item is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms.
ZIndex | Gets or sets the z-order position of this item.

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit.

Public Methods

Name | Description
Clone | Creates a copy of this item.
ContainsPoint | Overloaded. Determines whether this item contains the specified point.
Draw | Draws the item on the specified IGraphics surface.
DrawHandles | Renders the adjustment handles of this item.
DrawShadow | Draws the shadow of this item on the specified IGraphics surface.
GetBounds | Gets the bounding rectangle of this item.
GetOutlinePoly | Gets a polygon approximating the outline of this object.
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
HitTest | Returns the diagram item that contains the specified point.
HitTestHandle | Determines whether a selection handle of this item is located at the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item.
OnLoad | Called after successful deserialization.
RestoreItemProperties | For internal use.
SaveItemProperties | For internal use.
ZBottom | Moves the item to the bottom of the z-order.
ZLevelDown | Moves the item one level down in the z-order.
ZLevelUp | Moves the item one level up in the z-order.
ZTop | Moves the item to the top of the z-order.

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object.
CreateProperties | Creates an item property set corresponding to the type of this diagram item.
CreateState | Creates an item state corresponding to the type of this diagram item.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
GetValue | Gets the effective value of the style property with the specified name.
HandleTap | Invoked when the user releases his finger over this item.
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified.
OnFontChanged | Invoked when the Font property has changed.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.
OnStyleChanged | Invoked when the associated style or theme have changed.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes.
RaiseClicked | Raises an event which notifies that an item has been clicked.
RemoveManipulator | Removes the specified manipulator from the object.
Repaint | Overloaded. Repaints the specified region of the diagram.
RestoreProperties | Restores the properties of this diagram item.
RestoreState | Restores the state of this diagram item.
SaveProperties | Saves the properties of this diagram item.
SaveState | Saves the state of this diagram item.
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
SetDiagramDirty | Marks the diagram as changed.
SetExpanded | Sets whether the item is in expanded or collapsed state.
ShouldRender | Determines whether the item should be rendered in the current context.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem Fields

DiagramItem Fields
[image]

Public Fields

Name | Description
BrushProperty | Identifies the Brush property.
HyperLinkProperty | Identifies the HyperLink property.
IdProperty | Identifies the Id property.
IgnoreLayoutProperty | Identifies the IgnoreLayout property.
LayerIndexProperty | Identifies the LayerIndex property.
LockedProperty | Identifies the Locked property.
PenProperty | Identifies the Pen property.
ShadowBrushProperty | Identifies the ShadowBrush property.
ShadowOffsetXProperty | Identifies the ShadowOffsetX property.
ShadowOffsetYProperty | Identifies the ShadowOffsetY property.
TagProperty | Identifies the Tag property.
TextBrushProperty | Identifies the TextBrush property.
TextPaddingProperty | Identifies the TextPadding property.
VisibleProperty | Identifies the Visible property.
WeightProperty | Idenitifies the Weight property.
ZIndexProperty | Identifies the ZIndex property.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem.BrushProperty Field

DiagramItem.BrushProperty Field
[image]

Identifies the Brush property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty BrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly BrushProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.HyperLinkProperty Field

DiagramItem.HyperLinkProperty Field
[image]

Identifies the HyperLink property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty HyperLinkProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly HyperLinkProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.IdProperty Field

DiagramItem.IdProperty Field
[image]

Identifies the Id property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty IdProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IdProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.IgnoreLayoutProperty Field

DiagramItem.IgnoreLayoutProperty Field
[image]

Identifies the IgnoreLayout property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty IgnoreLayoutProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IgnoreLayoutProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LayerIndexProperty Field

DiagramItem.LayerIndexProperty Field
[image]

Identifies the LayerIndex property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty LayerIndexProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LayerIndexProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LockedProperty Field

DiagramItem.LockedProperty Field
[image]

Identifies the Locked property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty LockedProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LockedProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.PenProperty Field

DiagramItem.PenProperty Field
[image]

Identifies the Pen property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty PenProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PenProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ShadowBrushProperty Field

DiagramItem.ShadowBrushProperty Field
[image]

Identifies the ShadowBrush property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty ShadowBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShadowBrushProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ShadowOffsetXProperty Field

DiagramItem.ShadowOffsetXProperty Field
[image]

Identifies the ShadowOffsetX property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty ShadowOffsetXProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShadowOffsetXProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ShadowOffsetYProperty Field

DiagramItem.ShadowOffsetYProperty Field
[image]

Identifies the ShadowOffsetY property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty ShadowOffsetYProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ShadowOffsetYProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.TagProperty Field

DiagramItem.TagProperty Field
[image]

Identifies the Tag property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty TagProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TagProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.TextBrushProperty Field

DiagramItem.TextBrushProperty Field
[image]

Identifies the TextBrush property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty TextBrushProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextBrushProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.TextPaddingProperty Field

DiagramItem.TextPaddingProperty Field
[image]

Identifies the TextPadding property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty TextPaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly TextPaddingProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.VisibleProperty Field

DiagramItem.VisibleProperty Field
[image]

Identifies the Visible property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty VisibleProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly VisibleProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.WeightProperty Field

DiagramItem.WeightProperty Field
[image]

Idenitifies the Weight property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty WeightProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly WeightProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZIndexProperty Field

DiagramItem.ZIndexProperty Field
[image]

Identifies the ZIndex property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty ZIndexProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ZIndexProperty As BindableProperty

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor

DiagramItem Constructor
[image]

Initializes a new instance of the DiagramItem class.

Overload List

Name | Description
DiagramItem () | Initializes a new instance of the DiagramItem class.
DiagramItem (Diagram) | Initializes a new instance of the DiagramItem class with default values supplied form the specified Diagram.
DiagramItem (DiagramItem) | Initializes a new instance of the DiagramItem class using the specified diagram item as a prototype.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor ()

DiagramItem Constructor ()
See Also
[image]

Initializes a new instance of the DiagramItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramItem ()

Visual Basic [image] Copy Code

Protected Sub New ()

Remarks

This constructor sets the DiagramItem properties to their default values.

See Also

DiagramItem Constructor Overload List
DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor (Diagram)

DiagramItem Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramItem class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramItem (
Diagram parent
)

Visual Basic [image] Copy Code

Protected New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the item properties.

Remarks

This constructor initializes the DiagramItem properties with the values specified in the respective default-value properties of the Diagram object.

See Also

DiagramItem Constructor Overload List
DiagramItem Class


MindFusion.Diagramming.DiagramItem Constructor (DiagramItem)

DiagramItem Constructor (DiagramItem)
See Also
[image]

Initializes a new instance of the DiagramItem class using the specified diagram item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramItem (
DiagramItem prototype
)

Visual Basic [image] Copy Code

Protected New ( _
prototype As DiagramItem _
)

Parameters

prototype

The item to use as a prototype. The properties of the new item are initialized from the property values of this item.

Remarks

This constructor copies the DiagramItem property values from the specified prototype item.

See Also

DiagramItem Constructor Overload List
DiagramItem Class


MindFusion.Diagramming.DiagramItem Methods

DiagramItem Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this item.
ContainsPoint | Overloaded. Determines whether this item contains the specified point.
Draw | Draws the item on the specified IGraphics surface.
DrawHandles | Renders the adjustment handles of this item.
DrawShadow | Draws the shadow of this item on the specified IGraphics surface.
GetBounds | Gets the bounding rectangle of this item.
GetOutlinePoly | Gets a polygon approximating the outline of this object.
GetRepaintRect | Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated.
HitTest | Returns the diagram item that contains the specified point.
HitTestHandle | Determines whether a selection handle of this item is located at the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item.
OnLoad | Called after successful deserialization.
RestoreItemProperties | For internal use.
SaveItemProperties | For internal use.
ZBottom | Moves the item to the bottom of the z-order.
ZLevelDown | Moves the item one level down in the z-order.
ZLevelUp | Moves the item one level up in the z-order.
ZTop | Moves the item to the top of the z-order.

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object.
CreateProperties | Creates an item property set corresponding to the type of this diagram item.
CreateState | Creates an item state corresponding to the type of this diagram item.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics.
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.
GetValue | Gets the effective value of the style property with the specified name.
HandleTap | Invoked when the user releases his finger over this item.
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified.
OnFontChanged | Invoked when the Font property has changed.
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.
OnStyleChanged | Invoked when the associated style or theme have changed.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes.
RaiseClicked | Raises an event which notifies that an item has been clicked.
RemoveManipulator | Removes the specified manipulator from the object.
Repaint | Overloaded. Repaints the specified region of the diagram.
RestoreProperties | Restores the properties of this diagram item.
RestoreState | Restores the state of this diagram item.
SaveProperties | Saves the properties of this diagram item.
SaveState | Saves the state of this diagram item.
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
SetDiagramDirty | Marks the diagram as changed.
SetExpanded | Sets whether the item is in expanded or collapsed state.
ShouldRender | Determines whether the item should be rendered in the current context.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem.AddManipulator Method

DiagramItem.AddManipulator Method
[image]

Adds the specified manipulator to this object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void AddManipulator (
Manipulator mnp
)

Visual Basic [image] Copy Code

Protected Sub AddManipulator( _
mnp As Manipulator _
)

Parameters

mnp

An instance of Manipulator-derived class.

Remarks

Use this method to add custom manipulators to diagram elements. Manipulators are interactive widgets associated with an item that let users change aspects of the item different from its position and size. Some built-in manipulators are the +/- icons displayed for Expandable nodes and the scrollbar of a TreeViewNode.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Clone Method

DiagramItem.Clone Method
[image]

Creates a copy of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual DiagramItem Clone (
bool clipboard
)

Visual Basic [image] Copy Code

Public Overridable Function Clone( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard

true if the copy will be stored in the Windows clipboard; otherwise, false.

Return Value

The copy of this item.

Remarks

The default implementation of this item invokes the item's class copy constructor through reflection. If your custom type does not provide a copy constructor, you must implement this method to provide for clipboard operations support.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ContainsPoint Method

DiagramItem.ContainsPoint Method
[image]

Determines whether this item contains the specified point.

Overload List

Name | Description
DiagramItem.ContainsPoint (Point) | Determines whether this item contains the specified point.
DiagramItem.ContainsPoint (Point, Double) | Determines whether this item contains the specified point.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ContainsPoint Method (Point)

DiagramItem.ContainsPoint Method (Point)
See Also
[image]

Determines whether this item contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public MustOverride Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

Return Value

true it this item contains the specified point; otherwise, false.

Remarks

This method is used during hit-testing.

See Also

ContainsPoint Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ContainsPoint Method (Point, Double)

DiagramItem.ContainsPoint Method (Point, Double)
See Also
[image]

Determines whether this item contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public MustOverride Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

Return Value

true it this item contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.CreateProperties Method

DiagramItem.CreateProperties Method
[image]

Creates an item property set corresponding to the type of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.CreateState Method

DiagramItem.CreateState Method
[image]

Creates an item state corresponding to the type of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overridable Function CreateState () As DiagramItemState

Return Value

An instance of the DiagramItemState class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Draw Method

DiagramItem.Draw Method
[image]

Draws the item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public MustOverride Sub Draw( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the item on.

options

Provides options for the drawing operation.

Remarks

MindFusion.Diagramming for .NET MAUI calls this method to draw a representation of the diagram item onto the specified graphics surface. Implement this method in custom node or link types if you need to provide your own drawing functionality.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.DrawHandles Method

DiagramItem.DrawHandles Method
[image]

Renders the adjustment handles of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style,
RenderOptions options
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawHandles( _
graphics As IGraphics, _
style As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface on which the handles should be drawn.

style

A HandlesVisualStyle instance containing brush and pen objects that should be used when drawing handles.

options

Provides options for the drawing operation.

Remarks

This method is invoked when the item's adjustment handles must be rendered.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.DrawManipulators Method

DiagramItem.DrawManipulators Method
[image]

Draws the associated manipulators on a specified graphics.

Overload List

Name | Description
DiagramItem.DrawManipulators (IGraphics, Boolean) | Draws the associated manipulators in the specified graphics.
DiagramItem.DrawManipulators (IGraphics, Boolean, Boolean) | Draws the associated manipulators in the specified graphics.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.DrawManipulators Method (IGraphics, Boolean)

DiagramItem.DrawManipulators Method (IGraphics, Boolean)
See Also
[image]

Draws the associated manipulators in the specified graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void DrawManipulators (
IGraphics graphics,
bool clip
)

Visual Basic [image] Copy Code

Protected Sub DrawManipulators( _
graphics As IGraphics, _
clip As Boolean _
)

Parameters

graphics

The IGraphics surface to draw the manipulators on.

clip

true to render only inside the item's bounds; otherwise, false.

Remarks

This method is invoked to render the item's manipulators, for example, collapse/expand buttons, scrollbars, and so on.

See Also

DrawManipulators Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.DrawManipulators Method (IGraphics, Boolean, Boolean)

DiagramItem.DrawManipulators Method (IGraphics, Boolean, Boolean)
See Also
[image]

Draws the associated manipulators in the specified graphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void DrawManipulators (
IGraphics graphics,
bool clip,
bool inLocal
)

Visual Basic [image] Copy Code

Protected Sub DrawManipulators( _
graphics As IGraphics, _
clip As Boolean, _
inLocal As Boolean _
)

Parameters

graphics

The IGraphics surface to draw the manipulators on.

clip

true to render only inside the item's bounds; otherwise, false.

inLocal

true if current graphics are in local coordinates; otherwise, false.

Remarks

This method is invoked to render the item's manipulators, for example, collapse/expand buttons, scrollbars, and so on.

See Also

DrawManipulators Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.DrawShadow Method

DiagramItem.DrawShadow Method
[image]

Draws the shadow of this item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public MustOverride Sub DrawShadow( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.FreeResources Method

DiagramItem.FreeResources Method
[image]

Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void FreeResources ()

Visual Basic [image] Copy Code

Protected Overridable Sub FreeResources ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetBounds Method

DiagramItem.GetBounds Method
[image]

Gets the bounding rectangle of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Rect GetBounds ()

Visual Basic [image] Copy Code

Public Overridable Function GetBounds () As Rect

Return Value

The rectangle that bounds this item.

Remarks

The Bounds property getter returns the result of this method.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetOutlinePoly Method

DiagramItem.GetOutlinePoly Method
[image]

Gets a polygon approximating the outline of this object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual PointCollection GetOutlinePoly (
bool rendering
)

Visual Basic [image] Copy Code

Public Overridable Function GetOutlinePoly( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Specifies whether the outline will be used for rendering (true) or hit-testing (false).

Return Value

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetRepaintRect Method

DiagramItem.GetRepaintRect Method
[image]

Gets the repaint region for this item, taking into account factors such as pen, selection handles and shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overridable Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected

true is related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this item is modified.

Remarks

This method is invoked when an item is modified by the user, or when an appearance property of the item changes. The returned region is invalidated and redrawn at the next paint operation.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetRotatedBounds Method

DiagramItem.GetRotatedBounds Method
[image]

Gets the bounding rectangle of this item when it is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Rect GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overridable Function GetRotatedBounds () As Rect

Return Value

A rectangle that bounds the rotated shape of the item.

Remarks

This method is invoked during hit-testing to do a quick test whether a point is within the item's bounds, before calling the possibly more time-consuming ContainsPoint method.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.GetValue Method

DiagramItem.GetValue Method
[image]

Gets the effective value of the style property with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Object GetValue (
string name
)

Visual Basic [image] Copy Code

Protected Function GetValue( _
name As String _
) As Object

Parameters

name

The name of the property to get.

Return Value

An object representing the effective property value.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.HandleTap Method

DiagramItem.HandleTap Method
[image]

Invoked when the user releases his finger over this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void HandleTap (
Point position,
double radius
)

Visual Basic [image] Copy Code

Protected Overridable Sub HandleTap( _
position As Point, _
radius As Double _
)

Parameters

position

The release location.

radius

The touch radius.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.HitTest Method

DiagramItem.HitTest Method
[image]

Returns the diagram item that contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual DiagramItem HitTest (
Point point,
double threshold,
bool onlyNodes,
bool onlyInteractive,
bool includeHandles
)

Visual Basic [image] Copy Code

Public Overridable Function HitTest( _
point As Point, _
threshold As Double, _
onlyNodes As Boolean, _
onlyInteractive As Boolean, _
includeHandles As Boolean _
) As DiagramItem

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

onlyNodes

true to exclude child links from the search.

onlyInteractive

true to exclude locked items from the search.

includeHandles

true to hit-test modification handles; otherwise, false.

Return Value

The item that contains the specified point.

Remarks

This method performs recursive search if items contain child items.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.HitTestHandle Method

DiagramItem.HitTestHandle Method
[image]

Determines whether a selection handle of this item is located at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract AdjustmentHandle HitTestHandle (
Point point,
double radius
)

Visual Basic [image] Copy Code

Public MustOverride Function HitTestHandle( _
point As Point, _
radius As Double _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

radius

A hit-testing threshold.

Return Value

Returns an AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LoadFromJson Method

DiagramItem.LoadFromJson Method
[image]

Loads the item content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the item's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being deserialized from a diagram file saved in JSON format.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LoadFromXml Method

DiagramItem.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being deserialized from a diagram file saved in XML format.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.NotInteractive Method

DiagramItem.NotInteractive Method
[image]

Gets whether the user is prevented from manipulating this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool NotInteractive ()

Visual Basic [image] Copy Code

Public Overridable Function NotInteractive () As Boolean

Return Value

true to prevent user interaction with this item; otherwise, false.

Remarks

The default implementation prevents manipulation of invisible or locked items.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnAdd Method

DiagramItem.OnAdd Method
[image]

Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnAdd ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnAdd ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnChildModified Method

DiagramItem.OnChildModified Method
[image]

Called when a group child node has been modified.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnChildModified (
DiagramNode node,
AdjustmentHandles handle
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnChildModified( _
node As DiagramNode, _
handle As AdjustmentHandles _
)

Parameters

node

The node that has been modified.

handle

The adjustment handle used to modify the node.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnFontChanged Method

DiagramItem.OnFontChanged Method
[image]

Invoked when the Font property has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnFontChanged (
Nullable<Font> oldValue,
Nullable<Font> newValue
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnFontChanged( _
oldValue As Nullable(Of Font), _
newValue As Nullable(Of Font) _
)

Parameters

oldValue

newValue

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnLoad Method

DiagramItem.OnLoad Method
[image]

Called after successful deserialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnLoad ()

Visual Basic [image] Copy Code

Public Overridable Sub OnLoad ()

Remarks

Override this method if you need to update the state of items after successfully loading a diagram.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnMeasureUnitChanged Method

DiagramItem.OnMeasureUnitChanged Method
[image]

Called when the diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnMeasureUnitChanged ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnRemove Method

DiagramItem.OnRemove Method
[image]

Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRemove ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnRemove ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnStyleChanged Method

DiagramItem.OnStyleChanged Method
[image]

Invoked when the associated style or theme have changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnStyleChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnStyleChanged ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.OnZoomChanged Method

DiagramItem.OnZoomChanged Method
[image]

Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnZoomChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnZoomChanged ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RaiseClicked Method

DiagramItem.RaiseClicked Method
[image]

Raises an event which notifies that an item has been clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RaiseClicked (
Point position,
double radius
)

Visual Basic [image] Copy Code

Protected Overridable Sub RaiseClicked( _
position As Point, _
radius As Double _
)

Parameters

position

The position of the pointer.

radius

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RemoveManipulator Method

DiagramItem.RemoveManipulator Method
[image]

Removes the specified manipulator from the object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RemoveManipulator (
Manipulator manipulator
)

Visual Basic [image] Copy Code

Protected Sub RemoveManipulator( _
manipulator As Manipulator _
)

Parameters

manipulator

An instance of Manipulator-derived class.

Remarks

Invoke this method to remove manipulators previously added using AddManipulator.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Repaint Method

DiagramItem.Repaint Method
[image]

Repaints the specified region of the diagram.

Overload List

Name | Description
DiagramItem.Repaint () | Repaints the region of the diagram where this item is located.
DiagramItem.Repaint (Boolean) | Repaints the specified region of the diagram.
DiagramItem.Repaint (Rect) | Repaints the specified region of the diagram.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Repaint Method ()

DiagramItem.Repaint Method ()
See Also
[image]

Repaints the region of the diagram where this item is located.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void Repaint ()

Visual Basic [image] Copy Code

Protected Sub Repaint ()

Remarks

Call this method to repaint the diagram after changing appearance attributes of this item.

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Repaint Method (Boolean)

DiagramItem.Repaint Method (Boolean)
See Also
[image]

Repaints the specified region of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void Repaint (
bool includeConnected
)

Visual Basic [image] Copy Code

Protected Sub Repaint( _
includeConnected As Boolean _
)

Parameters

includeConnected

true if related items should be considered too; otherwise, false.

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Repaint Method (Rect)

DiagramItem.Repaint Method (Rect)
See Also
[image]

Repaints the specified region of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void Repaint (
Rect invalidRect
)

Visual Basic [image] Copy Code

Protected Sub Repaint( _
invalidRect As Rect _
)

Parameters

invalidRect

The region to repaint.

Remarks

Call this method to repaint a part of the item after changing its appearance attributes.

See Also

Repaint Method Overload List
DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RestoreItemProperties Method

DiagramItem.RestoreItemProperties Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RestoreItemProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Public Sub RestoreItemProperties( _
props As DiagramItemProperties _
)

Parameters

props

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RestoreProperties Method

DiagramItem.RestoreProperties Method
[image]

Restores the properties of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

Remarks

This method is invoked by the undo/redo subsystem when undoing or redoing a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RestoreState Method

DiagramItem.RestoreState Method
[image]

Restores the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overridable Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

A DiagramItemState object.

Remarks

This method is called when an item should be restored to the state it had before user interaction.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveItemProperties Method

DiagramItem.SaveItemProperties Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveItemProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Public Sub SaveItemProperties( _
props As DiagramItemProperties _
)

Parameters

props

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveProperties Method

DiagramItem.SaveProperties Method
[image]

Saves the properties of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object where the item's properties should be saved.

Remarks

This method is invoked by the undo/redo subsystem when saving a ChangeItemCmd instance.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveState Method

DiagramItem.SaveState Method
[image]

Saves the state of this diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

A DiagramItemState object.

Remarks

This method is called to save undo information when the users starts modifying an item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveToJson Method

DiagramItem.SaveToJson Method
[image]

Saves the item content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the item's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

Remarks

This method is invoked when an item is being serialized into a JSON-format diagram file.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SaveToXml Method

DiagramItem.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual Task SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Function SaveToXml( _
element As XElement, _
context As XmlPersistContext _
) As Task

Parameters

element

An XElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

Remarks

This method is invoked when an item is being serialized into an XML-format diagram file.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SetDiagramDirty Method

DiagramItem.SetDiagramDirty Method
[image]

Marks the diagram as changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetDiagramDirty ()

Visual Basic [image] Copy Code

Protected Sub SetDiagramDirty ()

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.SetExpanded Method

DiagramItem.SetExpanded Method
[image]

Sets whether the item is in expanded or collapsed state.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetExpanded (
bool e
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetExpanded( _
e As Boolean _
)

Parameters

e

Specifies the new state of the item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ShouldRender Method

DiagramItem.ShouldRender Method
[image]

Determines whether the item should be rendered in the current context.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool ShouldRender ()

Visual Basic [image] Copy Code

Protected Function ShouldRender () As Boolean

Return Value

true to draw the item; otherwise, false,

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZBottom Method

DiagramItem.ZBottom Method
[image]

Moves the item to the bottom of the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZBottom (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZBottom( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

Remarks

Call the method to move the item to the bottom of the z-order.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZLevelDown Method

DiagramItem.ZLevelDown Method
[image]

Moves the item one level down in the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZLevelDown (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZLevelDown( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

Remarks

Call the method to change the item's position in z-order with one level down.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZLevelUp Method

DiagramItem.ZLevelUp Method
[image]

Moves the item one level up in the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZLevelUp (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZLevelUp( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

Remarks

Call the method to change the item's position in z-order with one level up.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZTop Method

DiagramItem.ZTop Method
[image]

Moves the item to the top of the z-order.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZTop (
bool keepInLayer
)

Visual Basic [image] Copy Code

Public Sub ZTop( _
keepInLayer As Boolean _
)

Parameters

keepInLayer

Remarks

Call the method to move the item to the top of the z-order.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem Properties

DiagramItem Properties
[image]

Public Properties

Name | Description
AttachedNodes | Gets a reference to the list of items that are attached to this one.
Brush | Gets or sets the brush used to fill the interior of this item.
EffectiveBrush | Gets the effective brush of the item.
EffectiveFont | Gets the currently effective font of the item.
EffectivePen | Gets the effective pen of the item.
EffectiveShadowBrush | Gets the effective shadow brush of the item.
EffectiveTextBrush | Gets the effective text brush of the item.
Font | Gets or sets the font used to render the item's text.
HyperLink | Gets or sets the hyper link.
Id | Gets or sets user-defined identifier associated with this item.
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.
LayoutTraits | Contains properties specific to each layout algorithm.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item.
Parent | Gets the diagram that contains this item.
Pen | Gets or sets the pen used to paint the frame of the item.
RuntimeIndex | For internal use.
Selected | Gets or sets a value indicating whether a diagram item is selected.
ShadowBrush | Gets or sets the brush used to paint the item's shadow.
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item.
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item.
Style | Gets or sets the style associated with the item.
Tag | Gets or sets user-defined data associated with this item.
TextBrush | Gets or sets the brush used to paint texts inside the item.
TextPadding | Gets or sets the spacing between the item boundaries and its text.
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container.
Visible | Gets or sets a value indicating whether this item is visible.
Weight | Gets or sets a weight value used in layout and path-finding algorithms.
ZIndex | Gets or sets the z-order position of this item.

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit.

See Also

DiagramItem Class


MindFusion.Diagramming.DiagramItem.AttachedNodes Property

DiagramItem.AttachedNodes Property
[image]

Gets a reference to the list of items that are attached to this one.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<DiagramNode> AttachedNodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AttachedNodes As List(Of DiagramNode)

Property Value

A list of nodes attached to this item via the AttachToNode or AttachToLink method.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Brush Property

DiagramItem.Brush Property
[image]

Gets or sets the brush used to fill the interior of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of a Brush-derived class. The default value is null.

Remarks

This property refers to a brush with which an item is painted. You can assign to it an instance of one of the following classes: HatchBrush, LinearGradientBrush, PathGradientBrush, or SolidBrush, located in the MindFusion.Drawing namespace. When applied to links, the property defines how arrowheads interior is painted.

When set to null, the brush object used to paint this item is derived from the item's Style, or from the diagram's Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.EffectiveBrush Property

DiagramItem.EffectiveBrush Property
[image]

Gets the effective brush of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

Returns a Brush instance used to paint this item. This value comes from the Brush property if it is set, or is derived from either the item's Style or the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.EffectiveFont Property

DiagramItem.EffectiveFont Property
[image]

Gets the currently effective font of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Font EffectiveFont { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveFont As Font

Property Value

A Font object.

Remarks

This property returns Font if it is not null, or a font with the FontFamily, FontSize, and FontStyle properties of the item's style.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.EffectivePen Property

DiagramItem.EffectivePen Property
[image]

Gets the effective pen of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen EffectivePen { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectivePen As Pen

Property Value

An instance of the Pen class.

Remarks

Returns a Pen instance used to draw this item's border or segment lines. This value comes from the Pen property if it is set, or is derived from either the item's Style or the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.EffectiveShadowBrush Property

DiagramItem.EffectiveShadowBrush Property
[image]

Gets the effective shadow brush of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveShadowBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveShadowBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

Returns a Brush instance used to paint the item's shadow. This value comes from the ShadowBrush property if it is set, or is derived from either the item's Style or the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.EffectiveTextBrush Property

DiagramItem.EffectiveTextBrush Property
[image]

Gets the effective text brush of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveTextBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveTextBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

Returns a Brush instance used to paint the item's text. This value comes from the TextBrush property if it is set, or is derived from either the item's Style or the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Font Property

DiagramItem.Font Property
[image]

Gets or sets the font used to render the item's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Font> Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Nullable(Of Font)

Property Value

An instance of the Font class. The default value is null.

Remarks

Items derived from DiagramItem use this font to draw their text. Tables for example render their captions and text in cells using this font. Initially the font is set to the value of Font.

When set to null, the font object used to render the item's text is derived from the item's Style, or from the diagram's current Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.HyperLink Property

DiagramItem.HyperLink Property
[image]

Gets or sets the hyper link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string HyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLink As String

Property Value

A string value containing the hyperlink URL.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Id Property

DiagramItem.Id Property
[image]

Gets or sets user-defined identifier associated with this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As Object

Property Value

An instance of any class derived from System.Object.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.IgnoreLayout Property

DiagramItem.IgnoreLayout Property
[image]

Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreLayout { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLayout As Boolean

Property Value

true if the item must stay at its place nevertheless an automatic layout is performed; otherwise, false. The default is false.

Remarks

Enable IgnoreLayout to specify that the Arrange method of layout classes should ignore an item. If enabled, the position of an item won't be changed. This property applies to visible nodes. Invisible nodes are always ignored by automatic layout methods.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LayerIndex Property

DiagramItem.LayerIndex Property
[image]

Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int LayerIndex { get; set; }

Visual Basic [image] Copy Code

Public Property LayerIndex As Integer

Property Value

An integer value that specifies the index of the layer.

Remarks

This property specifies the index of a Layer instance within the Layers collection of the Diagram.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.LayoutTraits Property

DiagramItem.LayoutTraits Property
[image]

Contains properties specific to each layout algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IDictionary<Object, Object> LayoutTraits { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LayoutTraits As IDictionary(Of Object, Object)

Property Value

A hashtable of key-value pairs that define layout-specific properties for this item.

Remarks

This property is used by some Layout classes:

  • SpringLayout looks for values associated with SpringLayoutTraits members.
  • TreeLayout looks for values associated with TreeLayoutTraits members.
  • SwimlaneLayout looks for values associated with SwimlaneLayoutTraits members.
  • LayeredLayout looks for values associated with LayeredLayoutTraits members.
  • HierarchicalLayout looks for values associated with HierarchicalLayoutTraits members.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Locked Property

DiagramItem.Locked Property
[image]

Gets or sets a value indicating whether users are allowed to edit the diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Property Locked As Boolean

Property Value

true to prevent users from editing a diagram element; otherwise, false. The default is false.

Remarks

A locked item cannot be selected, moved or resized interactively. Additionally, its text cannot be edited in-place.

Locked nodes still can be moved or resized programmatically through the Bounds property and the Move / Resize methods. Positions of locked links' control points can be changed programmatically too – through their ControlPoints collections.

Locked items positions can be changed also by the automatic layout algorithms. To prevent automatic layout methods from changing positions of individual items, set the IgnoreLayout property of DiagramItem to false.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.MeasureUnit Property

DiagramItem.MeasureUnit Property
[image]

Returns the diagram measure unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected MeasureUnit MeasureUnit { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property MeasureUnit As MeasureUnit

Property Value

An instance of the MeasureUnit class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Parent Property

DiagramItem.Parent Property
[image]

Gets the diagram that contains this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Parent { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Parent As Diagram

Property Value

A reference to a Diagram instance.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Pen Property

DiagramItem.Pen Property
[image]

Gets or sets the pen used to paint the frame of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen Pen { get; set; }

Visual Basic [image] Copy Code

Public Property Pen As Pen

Property Value

An instance of the Pen class. The default value is null.

Remarks

The property refers to a pen, with which the item frame is painted. When applied to links, the property specifies how their segments are painted.

When set to null, the pen object used to draw the item borders is derived from the item's Style, or from the diagram's current Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.RuntimeIndex Property

DiagramItem.RuntimeIndex Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RuntimeIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RuntimeIndex As Integer

Property Value

A sequential integer id for this item.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Selected Property

DiagramItem.Selected Property
[image]

Gets or sets a value indicating whether a diagram item is selected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Selected { get; set; }

Visual Basic [image] Copy Code

Public Property Selected As Boolean

Property Value

true if the item is selected; otherwise, false.

Remarks

Use the property to check which items are selected by the user, or to programmatically select items if needed. Selected items adjustment handles are painted using the pen and brush specified through the SelectedItemHandlesStyle property.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ShadowBrush Property

DiagramItem.ShadowBrush Property
[image]

Gets or sets the brush used to paint the item's shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShadowBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowBrush As Brush

Property Value

An instance of a Brush-derived class. The default value is null.

Remarks

The shadow of an item has the same shape as the item, but is painted with a different brush and with some offset from the item position. This property specifies the brush used to paint the item's shadow.

When set to null, the brush object used to paint the shadow is derived from the item's Style, or from the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ShadowOffsetX Property

DiagramItem.ShadowOffsetX Property
[image]

Gets or sets the horizontal offset of the shadow of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ShadowOffsetX { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowOffsetX As Double

Property Value

A double value specifying the horizontal offset of this item's shadow. Initialized with the value of ShadowOffsetX.

Remarks

The shadow of an item has the same shape as the item itself, but with a different color and with some offset from the item position. This property specifies the horizontal offset of the shadow.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ShadowOffsetY Property

DiagramItem.ShadowOffsetY Property
[image]

Gets or sets the vertical offset of the shadow of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ShadowOffsetY { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowOffsetY As Double

Property Value

A double value specifying the vertical offset of this item's shadow. Initialized with the value of ShadowOffsetY.

Remarks

The shadow of an item has the same shape as the item itself, but with a different color and with some offset from the item position. This property specifies the vertical offset of the shadow.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Style Property

DiagramItem.Style Property
[image]

Gets or sets the style associated with the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Property Style As DiagramItemStyle

Property Value

An instance of a DiagramItemStyle-derived class.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Tag Property

DiagramItem.Tag Property
[image]

Gets or sets user-defined data associated with this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.TextBrush Property

DiagramItem.TextBrush Property
[image]

Gets or sets the brush used to paint texts inside the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a Brush-derived class. The default value is null.

Remarks

When set to null, the brush object used to draw text is derived from either the item's Style or the current diagram Theme.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.TextPadding Property

DiagramItem.TextPadding Property
[image]

Gets or sets the spacing between the item boundaries and its text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness TextPadding { get; set; }

Visual Basic [image] Copy Code

Public Property TextPadding As Thickness

Property Value

A Thickness instance specifying the size of the padding space left around the text.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.TopLevel Property

DiagramItem.TopLevel Property
[image]

True if this is a top-level item in the diagram, or false if it is inside a container.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool TopLevel { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property TopLevel As Boolean

Property Value

true if this is a top-level item in the diagram; false otherwise.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Visible Property

DiagramItem.Visible Property
[image]

Gets or sets a value indicating whether this item is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true if the item is visible; otherwise, false.

Remarks

Invisible items are not drawn at all. You might use the property to hide or show items temporarily, or to construct complex group hierarchies in which intermediate helper items are invisible.

Invisible nodes are ignored by automatic layout methods. The position of such nodes won't change when the Arrange method of a layout class is called. Visible items can be ignored too by enabling their IgnoreLayout property.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.Weight Property

DiagramItem.Weight Property
[image]

Gets or sets a weight value used in layout and path-finding algorithms.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Weight { get; set; }

Visual Basic [image] Copy Code

Public Property Weight As Double

Property Value

A double value specifying the weight of this item. The default value is 1.

Remarks

Currently Weight is used in the implementations of:

  • The SpringLayout class: the weight of a link connecting two nodes is multiplied by the desired NodeDistance to determine the final distance between the nodes.
  • The PathFinder class: an override of the FindShortestPath method uses the Weight values of nodes and/or links to find the path with smallest total weight.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItem.ZIndex Property

DiagramItem.ZIndex Property
[image]

Gets or sets the z-order position of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ZIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ZIndex As Integer

Property Value

An integer value specifying the position of the diagram item within the z-order. The default value is -1.

Remarks

Use this property to arrange items in z-order. Items with lower ZIndex appear behind items with higher ZIndex.

If the ZIndex property of newly added items is equal to -1, the control will automatically assign consecutively increasing values to it. If you set ZIndex to a value greater then -1 before adding an item, the control will preserve it.

See Also

DiagramItem Members
DiagramItem Class


MindFusion.Diagramming.DiagramItemCollection Class

DiagramItemCollection Class
[image]

Represents a strongly-typed collection of DiagramItem objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramItemCollection : ItemCollectionBase<DiagramItem>

Visual Basic [image] Copy Code

Public Class DiagramItemCollection
Inherits ItemCollectionBase(Of DiagramItem)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(DiagramItem)
MindFusion.Diagramming.ItemCollectionBase(DiagramItem)
MindFusion.Diagramming.DiagramItemCollection

See Also

DiagramItemCollection Members


MindFusion.Diagramming.DiagramItemCollection Members

DiagramItemCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly-typed collection of DiagramItem objects.

The following tables list the members exposed by the DiagramItemCollection type.

Public Constructors

Name | Description
DiagramItemCollection | Initializes a new instance of the DiagramItemCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from ItemCollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from ItemCollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. Sorts the elements in this collection. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemCollection Constructor

DiagramItemCollection Constructor
[image]

Initializes a new instance of the DiagramItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemCollection Methods

DiagramItemCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. Sorts the elements in this collection. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemCollection.Clone Method

DiagramItemCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As DiagramItemCollection

Return Value

An instance of the DiagramItemCollection class.

See Also

DiagramItemCollection Members
DiagramItemCollection Class


MindFusion.Diagramming.DiagramItemProperties Class

DiagramItemProperties Class
[image]

The base type for classes that store diagram item properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramItemProperties

Visual Basic [image] Copy Code

Public Class DiagramItemProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramLinkProperties
MindFusion.Diagramming.DiagramNodeProperties

See Also

DiagramItemProperties Members


MindFusion.Diagramming.DiagramItemProperties Members

DiagramItemProperties Members
Constructors Fields Methods
[image]

The base type for classes that store diagram item properties during undo / redo operations.

The following tables list the members exposed by the DiagramItemProperties type.

Public Constructors

Name | Description
DiagramItemProperties | Initializes a new instance of the DiagramItemProperties class.

Public Fields

Name | Description
ItemClass | For internal use.
Selected | For internal use.
TextPadding | For internal use.
ZIndex | For internal use.

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used.

See Also

DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties Fields

DiagramItemProperties Fields
[image]

Public Fields

Name | Description
ItemClass | For internal use.
Selected | For internal use.
TextPadding | For internal use.
ZIndex | For internal use.

See Also

DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties.ItemClass Field

DiagramItemProperties.ItemClass Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ItemClass

Visual Basic [image] Copy Code

Public ItemClass As String

See Also

DiagramItemProperties Members
DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties.Selected Field

DiagramItemProperties.Selected Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Selected

Visual Basic [image] Copy Code

Public Selected As Boolean

See Also

DiagramItemProperties Members
DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties.TextPadding Field

DiagramItemProperties.TextPadding Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness TextPadding

Visual Basic [image] Copy Code

Public TextPadding As Thickness

See Also

DiagramItemProperties Members
DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties.ZIndex Field

DiagramItemProperties.ZIndex Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ZIndex

Visual Basic [image] Copy Code

Public ZIndex As Integer

See Also

DiagramItemProperties Members
DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties Constructor

DiagramItemProperties Constructor
[image]

Initializes a new instance of the DiagramItemProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties Methods

DiagramItemProperties Methods
[image]

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used.

See Also

DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemProperties.FreeResources Method

DiagramItemProperties.FreeResources Method
[image]

Frees stored resources which will no longer be used.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void FreeResources ()

Visual Basic [image] Copy Code

Public Overridable Sub FreeResources ()

See Also

DiagramItemProperties Members
DiagramItemProperties Class


MindFusion.Diagramming.DiagramItemState Class

DiagramItemState Class
[image]

Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramItemState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramLinkState
MindFusion.Diagramming.DiagramNodeState

See Also

DiagramItemState Members


MindFusion.Diagramming.DiagramItemState Members

DiagramItemState Members
Constructors
[image]

Contains a snapshot of the internal state of a diagram item. Instances of this class are used to store the state of items for later undo or redo operations.

The following tables list the members exposed by the DiagramItemState type.

Public Constructors

Name | Description
DiagramItemState | Initializes a new instance of the DiagramItemState class.

See Also

DiagramItemState Class


MindFusion.Diagramming.DiagramItemState Constructor

DiagramItemState Constructor
[image]

Initializes a new instance of the DiagramItemState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramItemState Class


MindFusion.Diagramming.DiagramItemStyle Class

DiagramItemStyle Class
[image]

Represents a reusable set of properties that define the appearance of diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramItemStyle : Style

Visual Basic [image] Copy Code

Public Class DiagramItemStyle
Inherits Style

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramLinkStyle
MindFusion.Diagramming.DiagramNodeStyle

See Also

DiagramItemStyle Members


MindFusion.Diagramming.DiagramItemStyle Members

DiagramItemStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of diagram items.

The following tables list the members exposed by the DiagramItemStyle type.

Protected Constructors

Name | Description
DiagramItemStyle | Initializes a new instance of the DiagramItemStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item.
FontFamily | Gets or sets the font family of the item text.
FontSize | Gets or sets the font size of the item text.
FontStyle | Gets or sets the font style of the item text.
ShadowBrush | Gets or sets the brush used to paint the shadow of the item.
Stroke | Gets or sets the brush used to paint the outline of the item.
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items.
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure.
TextBrush | Gets or sets the brush used to paint texts inside the item.

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JsonObject.
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject.
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle Constructor

DiagramItemStyle Constructor
[image]

Initializes a new instance of the DiagramItemStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramItemStyle ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle Methods

DiagramItemStyle Methods
[image]

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JsonObject.
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject.
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

See Also

DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.LoadFromJson Method

DiagramItemStyle.LoadFromJson Method
[image]

Loads the style content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the style's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.SaveToJson Method

DiagramItemStyle.SaveToJson Method
[image]

Saves the style content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject the style's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle Properties

DiagramItemStyle Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item.
FontFamily | Gets or sets the font family of the item text.
FontSize | Gets or sets the font size of the item text.
FontStyle | Gets or sets the font style of the item text.
ShadowBrush | Gets or sets the brush used to paint the shadow of the item.
Stroke | Gets or sets the brush used to paint the outline of the item.
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items.
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure.
TextBrush | Gets or sets the brush used to paint texts inside the item.

See Also

DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.Brush Property

DiagramItemStyle.Brush Property
[image]

Gets or sets the brush used to fill the interior of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.FontFamily Property

DiagramItemStyle.FontFamily Property
[image]

Gets or sets the font family of the item text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As String

Property Value

A string value.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.FontSize Property

DiagramItemStyle.FontSize Property
[image]

Gets or sets the font size of the item text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Single

Property Value

A double value.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.FontStyle Property

DiagramItemStyle.FontStyle Property
[image]

Gets or sets the font style of the item text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FontAttributes FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontAttributes

Property Value

One or more of the members of the FontAttributes enumeration.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.ShadowBrush Property

DiagramItemStyle.ShadowBrush Property
[image]

Gets or sets the brush used to paint the shadow of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShadowBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.Stroke Property

DiagramItemStyle.Stroke Property
[image]

Gets or sets the brush used to paint the outline of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.StrokeDashStyle Property

DiagramItemStyle.StrokeDashStyle Property
[image]

Gets or sets the pattern of dashes and gaps used to outline items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle StrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashStyle As DashStyle

Property Value

A member of the DashStyle enumeration.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.StrokeThickness Property

DiagramItemStyle.StrokeThickness Property
[image]

Gets or sets the thickness of the item's outline, expressed in the current units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramItemStyle.TextBrush Property

DiagramItemStyle.TextBrush Property
[image]

Gets or sets the brush used to paint texts inside the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramItemStyle Members
DiagramItemStyle Class


MindFusion.Diagramming.DiagramLink Class

DiagramLink Class
Remarks See Also
[image]

Represents a link between two diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLink : DiagramItem, InplaceEditable, Routable

Visual Basic [image] Copy Code

Public Class DiagramLink
Inherits DiagramItem
Implements InplaceEditable, Routable

Remarks

Links between nodes in MindFusion.Diagramming for .NET MAUI diagrams are represented by instances of the DiagramLink class. Links connect at most two nodes, which can be accessed with the Origin and Destination properties. If connected to node anchor points, the point indices can be accessed using the OriginAnchor and DestinationAnchor properties. To control whether users are allowed to move link end points, set AllowMoveStart and AllowMoveEnd.

Links are built of smaller parts called segments, which can be straight lines, cascading orthogonal lines or Bézier curves. The type of segments is set through the Shape property. The number of link's segments is specified by the SegmentCount property. Access to control point locations is provided by the ControlPoints collection.

Usually only the starting and ending segments of a link are updated if the nodes it connects are moved around. Number, orientation and/or position of link segments can change dynamically in various ways depending on the values of AutoRoute, Dynamic and RetainForm. For links of style Cascading, the CascadeOrientation property specifies the orientation of their first segments.

If AutoSnapToNode is enabled, a link automatically aligns its end points to the border of the origin or destination nodes when a user moves the first or last control points. This has a higher priority than aligning to the grid, but a lower priority than aligning to an anchor point.

Links can display distinct arrowhead shapes at their ends. These shapes can be set with the HeadShape and BaseShape properties. The size of the base and arrowhead images is specified through the HeadShapeSize and BaseShapeSize properties. Arrowhead shapes can be displayed in the middle of each segment to facilitate users by distinguishing different links. The type and size of these shapes is set with the IntermediateShape and IntermediateShapeSize properties. The lines of arowhead shapes are painted using the HeadPen pen.

The color of link segments can be specified by the Pen property and the fill color of its base and head shapes with the BaseBrush and HeadBrush properties. The appearance of link's selection handles can be changed using HandlesStyle.

Links can have some text associated with them, displayed as specified via the Text, TextBrush and TextStyle properties. The AddLabel method allows displaying multiple labels per link. Labels can automatically avoid overlapping nodes or other labels when their AutoArrange property is set.

Bounds and Length are informative properties returning respectively link's location and total length.

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramLink

See Also

DiagramLink Members


MindFusion.Diagramming.DiagramLink Members

DiagramLink Members
Constructors Fields Properties Methods
[image]

Represents a link between two diagram nodes.

The following tables list the members exposed by the DiagramLink type.

Public Constructors

Name | Description
DiagramLink | Overloaded. Initializes a new instance of the DiagramLink class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowMoveEnd | Gets or sets a value indicating whether the user is allowed to move the end point of a link.
AllowMoveStart | Gets or sets a value indicating whether the user is allowed to move the first control point of a link.
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
AutoRoute | Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
AutoSnapToNode | Gets or sets a value indicating whether link end points should automatically align to the border of the nearest node while the user moves them.
BaseBrush | Gets or sets the brush to use when filling arrow base shapes.
BaseShape | Gets or sets what shape to display at the beginning of a link.
BaseShapeSize | Gets or sets the size of the BaseShape shape.
Bounds | Gets the size of the rectangle that bounds this link.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
CascadeOrientation | Gets or sets the orientation of the first segment of a cascading link.
ControlPoints |
CrossingRadius | Gets or sets the radius length of decorations displayed at intersection points of this link.
CustomDraw | Gets or sets the type of custom drawing performed on this link.
Destination | Gets or sets the destination node of this link.
DestinationAnchor | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationConnection | Gets or sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
DestinationIndex | Gets or sets the index of link's destination anchor point or table row.
DrawCrossings | Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.
Dynamic | Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectiveHeadPen | Gets the effective head pen of the link.
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
EndPoint | Gets or sets the last control point of a link.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets the appearance of the link's selection handles.
HeadBrush | Gets or sets the brush to use when filling arrow heads.
HeadPen | Gets or sets the pen to use when painting arrowheads lines.
HeadShape | Gets or sets the shape of this link's arrowhead.
HeadShapeSize | Gets or sets the size of the arrowhead shape.
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IntermediateBrush | Gets or sets the brush to use when filling intermediate arrow shapes.
IntermediateShape | Gets or sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Gets or sets the size of the IntermediateShape shape.
IsConnected | Gets a value indicating whether the link is connected to nodes at both its ends.
Labels | Returns the list of all labels displayed by this link.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Length | Gets the length of the link.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Origin | Gets or sets the origin node of the link.
OriginAnchor | Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginConnection | Gets or sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
OriginIndex | Gets or sets the index of link's origin anchor point or table row.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RetainForm | Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
SegmentCount | Gets or sets the number of segments of this link.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the type of link segments and how they are positioned one relatively to another.
StartPoint | Gets or sets the first control point of a link.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed over a link.
TextAlignment | Gets or sets the link's text placement and orientation.
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TextStyle | Gets or sets the link's text placement and orientation.
TopLevel | DiagramItem.TopLevel override.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AddLabel | Overloaded. Adds a label to this link.
AlignPoints | Arranges the middle points of polyline and bezier links so that they are evenly spaces between the link's end points.
Clone | Creates a copy of this link.
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override.
Draw | Draws the link on the specified IGraphics surface.
DrawArrowhead | Draws an arrowhead shape.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | Draws the shadow of this link on the specified IGraphics surface.
GetBounds | DiagramItem.GetBounds override.
GetLongestHSegment | Returns the index of the longest horizontal segment of this link.
GetOutlinePoly | DiagramItem.GetOutlinePoly override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Overloaded. Checks whether this link intersects with the specified link.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnLoad | DiagramItem.OnLoad override.
ReassignAnchorPoints | Attaches the link end points to the anchor points defined for the link's origin and destination nodes.
RemoveLabel | Removes the specified label from this link.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
Route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetOrgAndDest | Sets the origin and destination connection points of this link.
UpdateFromPoints | Overloaded. Updates the link's internal state after the link's control points have been changed.
UpdateIntersections | Aligns the link ends to the contour of the nodes it connects.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the link content from a JsonObject.
LoadFromXml | Loads the link content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | DiagramItem.OnFontChanged override.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnPropertyChanged | DiagramItem.OnPropertyChanged override.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnStyleChanged | DiagramItem.OnStyleChanged override.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a link has been clicked.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveToJson | Saves the link content into a JsonObject.
SaveToXml | Saves the link content into an XML element.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor

DiagramLink Constructor
[image]

Initializes a new instance of the DiagramLink class.

Overload List

Name | Description
DiagramLink (Diagram) | Initializes a new instance of the DiagramLink class with default values supplied form the specified Diagram.
DiagramLink (Diagram, DiagramNode, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified node with default values supplied form the specified Diagram.
DiagramLink (Diagram, DiagramNode, Point) | Initializes a new instance of the DiagramLink class between the specified node and the specified point with default values supplied form the specified Diagram.
DiagramLink (Diagram, Point, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified point and the specified node with default values supplied form the specified Diagram.
DiagramLink (Diagram, Point, Point) | Initializes a new instance of the DiagramLink class between the specified points with default values supplied form the specified Diagram.
DiagramLink (DiagramLink, DiagramNode, DiagramNode) | Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram)

DiagramLink Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramLink class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram, DiagramNode, DiagramNode)

DiagramLink Constructor (Diagram, DiagramNode, DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified node with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
DiagramNode origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram, _
origin As DiagramNode, _
destination As DiagramNode _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

origin

The origin node of the new link.

destination

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram, DiagramNode, Point)

DiagramLink Constructor (Diagram, DiagramNode, Point)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified node and the specified point with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
DiagramNode origin,
Point destination
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram, _
origin As DiagramNode, _
destination As Point _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

origin

The origin node of the new link.

destination

The destination point of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram, Point, DiagramNode)

DiagramLink Constructor (Diagram, Point, DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified point and the specified node with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
Point src,
DiagramNode dest
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram, _
src As Point, _
dest As DiagramNode _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

src

The origin point of the new link.

dest

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (Diagram, Point, Point)

DiagramLink Constructor (Diagram, Point, Point)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified points with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
Diagram parent,
Point src,
Point dest
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram, _
src As Point, _
dest As Point _
)

Parameters

parent

The Diagram from which to obtain default values for the link properties.

src

The origin point of the new link.

dest

The destination point of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Constructor (DiagramLink, DiagramNode, DiagramNode)

DiagramLink Constructor (DiagramLink, DiagramNode, DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramLink class between the specified nodes using the specified diagram link as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink (
DiagramLink prototype,
DiagramNode src,
DiagramNode dest
)

Visual Basic [image] Copy Code

Public New ( _
prototype As DiagramLink, _
src As DiagramNode, _
dest As DiagramNode _
)

Parameters

prototype

The link to use as a prototype. The properties of the new link are initialized from the property values of this link.

src

The origin node of the new link.

dest

The destination node of the new link.

See Also

DiagramLink Constructor Overload List
DiagramLink Class


MindFusion.Diagramming.DiagramLink Methods

DiagramLink Methods
[image]

Public Methods

Name | Description
AddLabel | Overloaded. Adds a label to this link.
AlignPoints | Arranges the middle points of polyline and bezier links so that they are evenly spaces between the link's end points.
Clone | Creates a copy of this link.
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override.
Draw | Draws the link on the specified IGraphics surface.
DrawArrowhead | Draws an arrowhead shape.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | Draws the shadow of this link on the specified IGraphics surface.
GetBounds | DiagramItem.GetBounds override.
GetLongestHSegment | Returns the index of the longest horizontal segment of this link.
GetOutlinePoly | DiagramItem.GetOutlinePoly override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | DiagramItem.GetRotatedBounds override.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Overloaded. Checks whether this link intersects with the specified link.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnLoad | DiagramItem.OnLoad override.
ReassignAnchorPoints | Attaches the link end points to the anchor points defined for the link's origin and destination nodes.
RemoveLabel | Removes the specified label from this link.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
Route | Routes this link, regardless of whether the link's AutoRoute flag is enabled.
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetOrgAndDest | Sets the origin and destination connection points of this link.
UpdateFromPoints | Overloaded. Updates the link's internal state after the link's control points have been changed.
UpdateIntersections | Aligns the link ends to the contour of the nodes it connects.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the link content from a JsonObject.
LoadFromXml | Loads the link content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | DiagramItem.OnFontChanged override.
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnPropertyChanged | DiagramItem.OnPropertyChanged override.
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnStyleChanged | DiagramItem.OnStyleChanged override.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a link has been clicked.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveToJson | Saves the link content into a JsonObject.
SaveToXml | Saves the link content into an XML element.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddLabel Method

DiagramLink.AddLabel Method
[image]

Adds a label to this link.

Overload List

Name | Description
DiagramLink.AddLabel (LinkLabel) | Adds the specified label to this link.
DiagramLink.AddLabel (String) | Adds a new label to this link.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddLabel Method (LinkLabel)

DiagramLink.AddLabel Method (LinkLabel)
See Also
[image]

Adds the specified label to this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddLabel (
LinkLabel label
)

Visual Basic [image] Copy Code

Public Sub AddLabel( _
label As LinkLabel _
)

Parameters

label

A LinkLabel instance.

See Also

AddLabel Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AddLabel Method (String)

DiagramLink.AddLabel Method (String)
See Also
[image]

Adds a new label to this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel AddLabel (
string text
)

Visual Basic [image] Copy Code

Public Function AddLabel( _
text As String _
) As LinkLabel

Parameters

text

The label's text.

Return Value

A LinkLabel instance.

See Also

AddLabel Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AlignPoints Method

DiagramLink.AlignPoints Method
[image]

Arranges the middle points of polyline and bezier links so that they are evenly spaces between the link's end points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AlignPoints ()

Visual Basic [image] Copy Code

Public Sub AlignPoints ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Clone Method

DiagramLink.Clone Method
[image]

Creates a copy of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override DiagramItem Clone (
bool clipboard
)

Visual Basic [image] Copy Code

Public Overrides Function Clone( _
clipboard As Boolean _
) As DiagramItem

Parameters

clipboard

true if the copy will be stored in the Windows clipboard; otherwise, false.

Return Value

An instance of the DiagramItem class.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ContainsPoint Method

DiagramLink.ContainsPoint Method
[image]

DiagramItem.ContainsPoint override.

Overload List

Name | Description
DiagramLink.ContainsPoint (Point) | DiagramItem.ContainsPoint override.
DiagramLink.ContainsPoint (Point, Double) | DiagramItem.ContainsPoint override.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ContainsPoint Method (Point)

DiagramLink.ContainsPoint Method (Point)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

The point to check.

Return Value

true it this link contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ContainsPoint Method (Point, Double)

DiagramLink.ContainsPoint Method (Point, Double)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

Return Value

true it this item contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CreateProperties Method

DiagramLink.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CreateState Method

DiagramLink.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateState () As DiagramItemState

Return Value

A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Draw Method

DiagramLink.Draw Method
[image]

Draws the link on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the link should be rendered.

options

Provides options for the drawing operation.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DrawArrowhead Method

DiagramLink.DrawArrowhead Method
[image]

Draws an arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void DrawArrowhead (
IGraphics graphics,
Pen pen,
Brush brush,
Shape shape,
Point pivot,
Point position,
Point segmentStart,
double size,
bool shadow
)

Visual Basic [image] Copy Code

Public Shared Sub DrawArrowhead( _
graphics As IGraphics, _
pen As Pen, _
brush As Brush, _
shape As Shape, _
pivot As Point, _
position As Point, _
segmentStart As Point, _
size As Double, _
shadow As Boolean _
)

Parameters

graphics

The graphics surface to draw the shape on.

pen

A Pen instance used to draw the shape outline.

brush

A Brush instance used to fill the shape.

shape

A Shape instance that defines the arrowhead geometry.

pivot

A Point specified in percents that corresponds to the arrowhead tip position within the Shape geometry.

position

A point on the drawing surface where the arrowhead tip should be located.

segmentStart

A point specifying the arrowhead direction.

size

A double value that specifies the arrowhead size.

shadow

A bool value that specifies if drawing shadow, which causes the passed brush and pen to be used instead of those provided by the shape.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DrawHandles Method

DiagramLink.DrawHandles Method
[image]

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As IGraphics, _
style As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface on which the handles should be drawn.

style

A HandlesVisualStyle instance containing brush and pen objects that should be used when drawing handles.

options

Provides options for the drawing operation.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DrawShadow Method

DiagramLink.DrawShadow Method
[image]

Draws the shadow of this link on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadow( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetBounds Method

DiagramLink.GetBounds Method
[image]

DiagramItem.GetBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetBounds () As Rect

Return Value

A Rectangle object.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetLongestHSegment Method

DiagramLink.GetLongestHSegment Method
[image]

Returns the index of the longest horizontal segment of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetLongestHSegment ()

Visual Basic [image] Copy Code

Public Function GetLongestHSegment () As Integer

Return Value

An integer value.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetOutlinePoly Method

DiagramLink.GetOutlinePoly Method
[image]

DiagramItem.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointCollection GetOutlinePoly (
bool rendering
)

Visual Basic [image] Copy Code

Public Overrides Function GetOutlinePoly( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetRepaintRect Method

DiagramLink.GetRepaintRect Method
[image]

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected

true if related items should be considered too; otherwise, false.

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.GetRotatedBounds Method

DiagramLink.GetRotatedBounds Method
[image]

DiagramItem.GetRotatedBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetRotatedBounds () As Rect

Return Value

A Rectangle object.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HitTestHandle Method

DiagramLink.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point,
double radius
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point, _
radius As Double _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

radius

The touch radius.

Return Value

A LinkAdjustmentHandle instance if there is a control point at the specified location, otherwise null.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Intersects Method

DiagramLink.Intersects Method
[image]

Checks whether this link intersects with the specified link.

Overload List

Name | Description
DiagramLink.Intersects (DiagramLink) | Checks whether this link intersects with the specified link.
DiagramLink.Intersects (DiagramNode) | Checks whether the link contour intersects with the outline of the specified node.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Intersects Method (DiagramLink)

DiagramLink.Intersects Method (DiagramLink)
See Also
[image]

Checks whether this link intersects with the specified link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Intersects (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function Intersects( _
link As DiagramLink _
) As Boolean

Parameters

link

A DiagramLink object for which to determine whether the link intersects it.

Return Value

true if the two links intersect; otherwise, false.

See Also

Intersects Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Intersects Method (DiagramNode)

DiagramLink.Intersects Method (DiagramNode)
See Also
[image]

Checks whether the link contour intersects with the outline of the specified node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Intersects (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function Intersects( _
node As DiagramNode _
) As Boolean

Parameters

node

A DiagramNode object for which to determine whether the link intersects it.

Return Value

true if the link intersects the node; otherwise, false.

See Also

Intersects Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.LabelFromPoint Method

DiagramLink.LabelFromPoint Method
[image]

Returns the label whose layout rectangle contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel LabelFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public Function LabelFromPoint( _
point As Point _
) As LinkLabel

Parameters

point

A Point instance.

Return Value

The LinkLabel that contains the specified point.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.LoadFromJson Method

DiagramLink.LoadFromJson Method
[image]

Loads the link content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the link's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.LoadFromXml Method

DiagramLink.LoadFromXml Method
[image]

Loads the link content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OnFontChanged Method

DiagramLink.OnFontChanged Method
[image]

DiagramItem.OnFontChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnFontChanged (
Nullable<Font> oldValue,
Nullable<Font> newValue
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnFontChanged( _
oldValue As Nullable(Of Font), _
newValue As Nullable(Of Font) _
)

Parameters

oldValue

newValue

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OnLoad Method

DiagramLink.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnLoad ()

Visual Basic [image] Copy Code

Public Overrides Sub OnLoad ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OnMeasureUnitChanged Method

DiagramLink.OnMeasureUnitChanged Method
[image]

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OnPropertyChanged Method

DiagramLink.OnPropertyChanged Method
[image]

DiagramItem.OnPropertyChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnPropertyChanged (
string propertyName = null
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnPropertyChanged( _
Optional propertyName As String = Nothing _
)

Parameters

propertyName
Optional.

The name of the property that changed.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OnStyleChanged Method

DiagramLink.OnStyleChanged Method
[image]

DiagramItem.OnStyleChanged override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnStyleChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnStyleChanged ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.RaiseClicked Method

DiagramLink.RaiseClicked Method
[image]

Raises an event which notifies that a link has been clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RaiseClicked (
Point position,
double radius
)

Visual Basic [image] Copy Code

Protected Overrides Sub RaiseClicked( _
position As Point, _
radius As Double _
)

Parameters

position

The position of the pointer.

radius

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ReassignAnchorPoints Method

DiagramLink.ReassignAnchorPoints Method
[image]

Attaches the link end points to the anchor points defined for the link's origin and destination nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReassignAnchorPoints ()

Visual Basic [image] Copy Code

Public Sub ReassignAnchorPoints ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.RemoveLabel Method

DiagramLink.RemoveLabel Method
[image]

Removes the specified label from this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveLabel (
LinkLabel label
)

Visual Basic [image] Copy Code

Public Sub RemoveLabel( _
label As LinkLabel _
)

Parameters

label

A LinkLabel instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.RestoreProperties Method

DiagramLink.RestoreProperties Method
[image]

DiagramItem.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.RestoreState Method

DiagramLink.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Route Method

DiagramLink.Route Method
[image]

Routes this link, regardless of whether the link's AutoRoute flag is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Route ()

Visual Basic [image] Copy Code

Public Function Route () As Boolean

Return Value

true is a route has been successfully found; otherwise, false.

Remarks

Routing may fail if there is a large background node whose Obstacle property is enabled, or if the value of RoutingOptions.GridSize is too big for the average distance between adjacent nodes in the diagram.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveProperties Method

DiagramLink.SaveProperties Method
[image]

DiagramItem.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveState Method

DiagramLink.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

A DiagramLinkState instance.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveToJson Method

DiagramLink.SaveToJson Method
[image]

Saves the link content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the link's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SaveToXml Method

DiagramLink.SaveToXml Method
[image]

Saves the link content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToXml( _
element As XElement, _
context As XmlPersistContext _
) As Task

Parameters

element

An XElement the link's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SetOrgAndDest Method

DiagramLink.SetOrgAndDest Method
[image]

Sets the origin and destination connection points of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetOrgAndDest (
ConnectionPoint orgConnectionPoint,
ConnectionPoint trgConnectionPoint
)

Visual Basic [image] Copy Code

Public Sub SetOrgAndDest( _
orgConnectionPoint As ConnectionPoint, _
trgConnectionPoint As ConnectionPoint _
)

Parameters

orgConnectionPoint

trgConnectionPoint

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method

DiagramLink.UpdateFromPoints Method
[image]

Updates the link's internal state after the link's control points have been changed.

Overload List

Name | Description
DiagramLink.UpdateFromPoints () | Updates the link's internal state after the link's control points have been changed.
DiagramLink.UpdateFromPoints (Boolean) | Updates the link's internal state after the link's control points have been changed.
DiagramLink.UpdateFromPoints (Boolean, Boolean) | Updates the link's internal state after the link's control points have been changed.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method ()

DiagramLink.UpdateFromPoints Method ()
See Also
[image]

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateFromPoints ()

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints ()

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method (Boolean)

DiagramLink.UpdateFromPoints Method (Boolean)
See Also
[image]

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateFromPoints (
bool updateGroups
)

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints( _
updateGroups As Boolean _
)

Parameters

updateGroups

true to update the positions of nodes attached to the link; otherwise, false.

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateFromPoints Method (Boolean, Boolean)

DiagramLink.UpdateFromPoints Method (Boolean, Boolean)
See Also
[image]

Updates the link's internal state after the link's control points have been changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateFromPoints (
bool updateGroups,
bool updateSegmentCount
)

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints( _
updateGroups As Boolean, _
updateSegmentCount As Boolean _
)

Parameters

updateGroups

true to update the positions of nodes attached to the link; otherwise, false.

updateSegmentCount

true to update the SegmentCount property based on the number of points in the collection.

See Also

UpdateFromPoints Method Overload List
DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.UpdateIntersections Method

DiagramLink.UpdateIntersections Method
[image]

Aligns the link ends to the contour of the nodes it connects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateIntersections ()

Visual Basic [image] Copy Code

Public Sub UpdateIntersections ()

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink Properties

DiagramLink Properties
[image]

Public Properties

Name | Description
AllowMoveEnd | Gets or sets a value indicating whether the user is allowed to move the end point of a link.
AllowMoveStart | Gets or sets a value indicating whether the user is allowed to move the first control point of a link.
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
AutoRoute | Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.
AutoSnapToNode | Gets or sets a value indicating whether link end points should automatically align to the border of the nearest node while the user moves them.
BaseBrush | Gets or sets the brush to use when filling arrow base shapes.
BaseShape | Gets or sets what shape to display at the beginning of a link.
BaseShapeSize | Gets or sets the size of the BaseShape shape.
Bounds | Gets the size of the rectangle that bounds this link.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
CascadeOrientation | Gets or sets the orientation of the first segment of a cascading link.
ControlPoints |
CrossingRadius | Gets or sets the radius length of decorations displayed at intersection points of this link.
CustomDraw | Gets or sets the type of custom drawing performed on this link.
Destination | Gets or sets the destination node of this link.
DestinationAnchor | Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.
DestinationConnection | Gets or sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
DestinationIndex | Gets or sets the index of link's destination anchor point or table row.
DrawCrossings | Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.
Dynamic | Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectiveHeadPen | Gets the effective head pen of the link.
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
EndPoint | Gets or sets the last control point of a link.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets the appearance of the link's selection handles.
HeadBrush | Gets or sets the brush to use when filling arrow heads.
HeadPen | Gets or sets the pen to use when painting arrowheads lines.
HeadShape | Gets or sets the shape of this link's arrowhead.
HeadShapeSize | Gets or sets the size of the arrowhead shape.
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IntermediateBrush | Gets or sets the brush to use when filling intermediate arrow shapes.
IntermediateShape | Gets or sets the shape displayed at the middle of each segment of the link.
IntermediateShapeSize | Gets or sets the size of the IntermediateShape shape.
IsConnected | Gets a value indicating whether the link is connected to nodes at both its ends.
Labels | Returns the list of all labels displayed by this link.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Length | Gets the length of the link.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Origin | Gets or sets the origin node of the link.
OriginAnchor | Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.
OriginConnection | Gets or sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.
OriginIndex | Gets or sets the index of link's origin anchor point or table row.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RetainForm | Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
SegmentCount | Gets or sets the number of segments of this link.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the type of link segments and how they are positioned one relatively to another.
StartPoint | Gets or sets the first control point of a link.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed over a link.
TextAlignment | Gets or sets the link's text placement and orientation.
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TextStyle | Gets or sets the link's text placement and orientation.
TopLevel | DiagramItem.TopLevel override.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

DiagramLink Class


MindFusion.Diagramming.DiagramLink.AllowMoveEnd Property

DiagramLink.AllowMoveEnd Property
[image]

Gets or sets a value indicating whether the user is allowed to move the end point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMoveEnd { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMoveEnd As Boolean

Property Value

true to enable users to move the end point of the link; otherwise, false. Initialized with the value of LinkEndsMovable.

Remarks

Set the property to false to prevent the link destination to be changed interactively. Alternatively, you might handle the LinkModifying event to implement selective validation of attaching a link to different diagram nodes.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AllowMoveStart Property

DiagramLink.AllowMoveStart Property
[image]

Gets or sets a value indicating whether the user is allowed to move the first control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMoveStart { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMoveStart As Boolean

Property Value

true to enable users to move the start point of the link; otherwise false. Initialized with the value of LinkEndsMovable.

Remarks

Set the property to false to prevent the link origin to be changed interactively. Alternatively, you might handle the LinkModifying event to implement selective validation of attaching a link to different diagram nodes.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AutoRoute Property

DiagramLink.AutoRoute Property
[image]

Gets or sets a value indicating whether a link should avoid nodes by going the shortest path from its origin to its destination without crossing any other nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoRoute { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRoute As Boolean

Property Value

true to route this link; otherwise, false. Initialized with the value of RouteLinks.

Remarks

If AutoRoute is enabled, a link automatically finds the shortest possible path between its origin and destination that doesn't intersect Obstacle nodes. The number and orientation of the link's segments are updated when the nodes it links are moved around. The positions of end points of a routed link are not changed, unless the link is also set to Dynamic.

It is best to use AutoRoute with links of the Cascading style. Note that automatic routing overrides the RetainForm behavior.

Performance note

Links whose AutoRoute property is enabled are re-routed if they intersect with newly created nodes. Thus when constructing a large diagram programmatically, each link might be re-routed many times, once for each newly added node whose location arguments collide with link's bounding rectangle. That might slow down diagram creation a lot. To avoid it, first create all nodes, and afterwards the link; that requires a single calculation for each link's route.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.AutoSnapToNode Property

DiagramLink.AutoSnapToNode Property
[image]

Gets or sets a value indicating whether link end points should automatically align to the border of the nearest node while the user moves them.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoSnapToNode { get; set; }

Visual Basic [image] Copy Code

Public Property AutoSnapToNode As Boolean

Property Value

true to snap links to nearest node; otherwise, false. Initialized with the value of AutoSnapLinks.

Remarks

Only nodes at a distance smaller than AutoSnapDistance are considered. A link does not snap to its current origin or destination nodes if that would create a self-loop. If there is an AnchorPattern assigned to a node, the link snaps to an anchor point instead of a border point.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.BaseBrush Property

DiagramLink.BaseBrush Property
[image]

Gets or sets the brush to use when filling arrow base shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush BaseBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BaseBrush As Brush

Property Value

An instance of a Brush-derived class. The default value is null.

Remarks

This property refers to a brush used to fill arrow base shapes.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.BaseShape Property

DiagramLink.BaseShape Property
[image]

Gets or sets what shape to display at the beginning of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape BaseShape { get; set; }

Visual Basic [image] Copy Code

Public Property BaseShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkBaseShape.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.BaseShapeSize Property

DiagramLink.BaseShapeSize Property
[image]

Gets or sets the size of the BaseShape shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BaseShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property BaseShapeSize As Double

Property Value

A double value that specifies the shape size. Initialized with the value of LinkBaseShapeSize.

Remarks

The property specifies how big is the shape that is displayed at the origin of a link.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Bounds Property

DiagramLink.Bounds Property
[image]

Gets the size of the rectangle that bounds this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

A Rectangle that represents the bounding rectangle.

Remarks

Use the property to get the smallest rectangle that bounds all link points.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CascadeOrientation Property

DiagramLink.CascadeOrientation Property
[image]

Gets or sets the orientation of the first segment of a cascading link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation CascadeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property CascadeOrientation As Orientation

Property Value

A member of the Orientation enumeration.

Remarks

Use this property to specify the orientation of the first segment of a link whose Shape is set to Cascading. See Orientation for more details. The orientation of the first segment defines the orientation of all other segments in the cascade, because each next segment changes its orientation alternately to the previous one.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.ControlPoints Property

DiagramLink.ControlPoints Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection ControlPoints { get; set; }

Visual Basic [image] Copy Code

Public Property ControlPoints As PointCollection

Property Value

A collection of control points that specify the link's shape.

Remarks

You can specify new positions of a link's points through that property. The number of points in the collection depends on the Shape and SegmentCount of the link. Links made of Bézier-splines has four control points for each segment. Links of the other styles have two control points per segment. Adjacent segments share a common control point. Check the Count property of the collection to get the number of points. After setting new positions of control points you must call the UpdateFromPoints method.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CrossingRadius Property

DiagramLink.CrossingRadius Property
[image]

Gets or sets the radius length of decorations displayed at intersection points of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CrossingRadius { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingRadius As Double

Property Value

A double value specifying the radius of arcs or cuts displayed at the intersection points of this link. The default is 0.

Remarks

If this property is set to 0, the control uses the value of the CrossingRadius property.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.CustomDraw Property

DiagramLink.CustomDraw Property
[image]

Gets or sets the type of custom drawing performed on this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw CustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of LinkCustomDraw.

Remarks

This property allows invoking custom painting code for a link. That code must execute in response to the DrawLink event. There are several modes of custom painting, allowing the custom code to paint the link entirely, or do that in addition to what MindFusion.Diagramming for .NET MAUI paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming for .NET MAUI.
Additional | The custom painting code executes after the link segments and arrowhead shapes are painted by MindFusion.Diagramming for .NET MAUI, but before text is rendered.
Full | The component does not do any standard drawing, the entire painting of the link is done by the application.
ShadowOnly | Only the shadow of the link is painted by custom code, the link itself is drawn by the component.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Destination Property

DiagramLink.Destination Property
[image]

Gets or sets the destination node of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Destination { get; set; }

Visual Basic [image] Copy Code

Public Property Destination As DiagramNode

Property Value

A reference to the destination DiagramNode of the link.

Remarks

The link's destination can be changed programmatically with this property. If any of the connected nodes has an AnchorPattern defined, links ends are placed at the nearest anchor points of the two nodes. If AutoRoute is enabled, the link is routed when changing its origin or destination.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DestinationAnchor Property

DiagramLink.DestinationAnchor Property
[image]

Gets or sets the index of the destination anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int DestinationAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationAnchor As Integer

Property Value

An integer index of an anchor point within the AnchorPattern containing it.

Remarks

Specifies the index of an anchor point contained within the Destination anchor pattern. The link is docked and stay connected to that point if the node is moved or resized.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DestinationConnection Property

DiagramLink.DestinationConnection Property
[image]

Gets or sets the ConnectionPoint object representing the link connection to its destination node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ConnectionPoint DestinationConnection { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationConnection As ConnectionPoint

Property Value

An instance of ConnectionPoint or a derived class.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DestinationIndex Property

DiagramLink.DestinationIndex Property
[image]

Gets or sets the index of link's destination anchor point or table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int DestinationIndex { get; set; }

Visual Basic [image] Copy Code

Public Property DestinationIndex As Integer

Property Value

An integer value specifying the index of table's row or the index of an anchor point within its containing AnchorPattern.

Remarks

If a link's destination is a shape node, this property lets you get or set the index of an anchor point at which the link docks to the node. If there is no AnchorPattern defined for the destination node, the property returns -1. If the link is connected to a table, the property returns or changes the related row of that table.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.DrawCrossings Property

DiagramLink.DrawCrossings Property
[image]

Gets or sets a value indicating whether the points where this link crosses other links should be drawn as arcs or dashes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DrawCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property DrawCrossings As Boolean

Property Value

true if crossing points should be drawn as arcs or dashes; otherwise, false. The default is true.

Remarks

The LinkCrossings property of the Diagram class specifies what shapes are drawn at link crossing points. Individual links cannot display shapes different from the ones drawn for other links, but the crossing points shapes can be shown or hidden for a link through this property.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Dynamic Property

DiagramLink.Dynamic Property
[image]

Gets or sets a value indicating whether a link automatically adjusts its end points positions in order to keep pointing to the centers of nodes that it connects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Dynamic { get; set; }

Visual Basic [image] Copy Code

Public Property Dynamic As Boolean

Property Value

true to make the link automatically adjust its end points; otherwise, false. Initialized with the value of DynamicLinks.

Remarks

Use the property to specify whether a link automatically repositions its end segments, so they keep pointing to the centers of nodes connected by that link. If enabled, moving a connected node recalculates the position of link's end point, placing it at appropriate location of the node outline. If the node has anchor points assigned to it, the end point is attached to one of them. End points are realigned also when moving the points next to them.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.EffectiveHeadPen Property

DiagramLink.EffectiveHeadPen Property
[image]

Gets the effective head pen of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen EffectiveHeadPen { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveHeadPen As Pen

Property Value

An instance of the Pen class.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.EndPoint Property

DiagramLink.EndPoint Property
[image]

Gets or sets the last control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point EndPoint { get; set; }

Visual Basic [image] Copy Code

Public Property EndPoint As Point

Property Value

A Point object.

Remarks

This property is a shortcut for getting or setting the last element of ControlPoints.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HandlesStyle Property

DiagramLink.HandlesStyle Property
[image]

Gets or sets the appearance of the link's selection handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle HandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration. Initialized with the value of LinkHandlesStyle.

Remarks

Specifies how link's selection status is indicated visually. You can choose between the following styles:

Member name | Description
SquareHandles | The selection is indicated by drawing square handles at the position of each control point.
DashFrame | The selection is indicated by drawing dashed line segments along the link's segments. In addition, there are square selection handles drawn at the location of each control point of the link.
Custom | MindFusion.Diagramming for .NET MAUI raises the DrawAdjustmentHandles events to let your application perform custom drawing of link's selection handles.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HeadBrush Property

DiagramLink.HeadBrush Property
[image]

Gets or sets the brush to use when filling arrow heads.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HeadBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HeadBrush As Brush

Property Value

An instance of a Brush-derived class. The default value is null.

Remarks

This property refers to a brush used to fill arrow head shapes.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HeadPen Property

DiagramLink.HeadPen Property
[image]

Gets or sets the pen to use when painting arrowheads lines.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen HeadPen { get; set; }

Visual Basic [image] Copy Code

Public Property HeadPen As Pen

Property Value

An instance of the Pen class. Initialized with a clone of LinkPen.

Remarks

This property refers to a pen used to paint arrowhead lines. To change how segment lines are painted, use the Pen property.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HeadShape Property

DiagramLink.HeadShape Property
[image]

Gets or sets the shape of this link's arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape HeadShape { get; set; }

Visual Basic [image] Copy Code

Public Property HeadShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkHeadShape.

Remarks

The property specifies what shape is displayed as an arrowhead. This shape is rotated simultaneously with the last segment of the link so that it follows the overall link direction.

The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.HeadShapeSize Property

DiagramLink.HeadShapeSize Property
[image]

Gets or sets the size of the arrowhead shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HeadShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property HeadShapeSize As Double

Property Value

A double value that measures the size. Initialized with the value of LinkHeadShapeSize.

Remarks

The property specifies how big the shape of the arrowhead is.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.IntermediateBrush Property

DiagramLink.IntermediateBrush Property
[image]

Gets or sets the brush to use when filling intermediate arrow shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush IntermediateBrush { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateBrush As Brush

Property Value

An instance of a Brush-derived class. The default value is null.

Remarks

This property refers to a brush used to fill intermediate arrow shapes.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.IntermediateShape Property

DiagramLink.IntermediateShape Property
[image]

Gets or sets the shape displayed at the middle of each segment of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape IntermediateShape { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateShape As Shape

Property Value

A Shape instance that represents an arrowhead shape. Initialized with the value of LinkIntermediateShape.

Remarks

The property specifies what shape to display at the middle of each segment of a link. This could help users to see more easily the direction of long links. The ArrowHeads class exposes several predefined shapes as static properties.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.IntermediateShapeSize Property

DiagramLink.IntermediateShapeSize Property
[image]

Gets or sets the size of the IntermediateShape shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double IntermediateShapeSize { get; set; }

Visual Basic [image] Copy Code

Public Property IntermediateShapeSize As Double

Property Value

A double value that measures the size. Initialized with the value of LinkIntermediateShapeSize.

Remarks

The property specifies how big are the shapes that are displayed in the middle of link segments.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.IsConnected Property

DiagramLink.IsConnected Property
[image]

Gets a value indicating whether the link is connected to nodes at both its ends.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsConnected { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsConnected As Boolean

Property Value

true to indicate that both ends of the link are connected to nodes; otherwise, false.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Labels Property

DiagramLink.Labels Property
[image]

Returns the list of all labels displayed by this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<LinkLabel> Labels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Labels As List(Of LinkLabel)

Property Value

A list with all link labels.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Length Property

DiagramLink.Length Property
[image]

Gets the length of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Double

Property Value

A double value that represents the total length of the link, sum of the lengths of all its segments.

Remarks

If the link's Shape is set to Bezier, an approximate length is calculated. In that case, the approximate value is almost always slightly smaller than the real length of Bézier segments.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Origin Property

DiagramLink.Origin Property
[image]

Gets or sets the origin node of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Origin { get; set; }

Visual Basic [image] Copy Code

Public Property Origin As DiagramNode

Property Value

A reference to the origin DiagramNode of the link.

Remarks

The link's origin can be changed programmatically with this property. If any of the connected nodes has an AnchorPattern defined, links ends are placed at the nearest anchor points of the two nodes. If AutoRoute is enabled, the link is routed when changing its origin or destination.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OriginAnchor Property

DiagramLink.OriginAnchor Property
[image]

Gets or sets the index of the origin anchor point within the AnchorPattern that contains it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int OriginAnchor { get; set; }

Visual Basic [image] Copy Code

Public Property OriginAnchor As Integer

Property Value

An integer index of an anchor point within its the AnchorPattern containing it.

Remarks

Specifies the index of an anchor point contained within the Origin anchor pattern. The link is docked and stay connected to that point if the node is moved or resized.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OriginConnection Property

DiagramLink.OriginConnection Property
[image]

Gets or sets the ConnectionPoint object representing the link connection to its origin node. This allows connecting the link to a constituent part of a node, such as a TableNode row or a TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ConnectionPoint OriginConnection { get; set; }

Visual Basic [image] Copy Code

Public Property OriginConnection As ConnectionPoint

Property Value

An instance of ConnectionPoint or derived class.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.OriginIndex Property

DiagramLink.OriginIndex Property
[image]

Gets or sets the index of link's origin anchor point or table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int OriginIndex { get; set; }

Visual Basic [image] Copy Code

Public Property OriginIndex As Integer

Property Value

An integer value specifying the index of table's row or index of an anchor point within its containing AnchorPattern.

Remarks

If a link's origin is a shape node, this property lets you get or set the index of an anchor point at which the link docks to the node. If there is no AnchorPattern defined for the origin node, the property returns -1. If the link is connected to a table, the property returns or changes the related row of that table.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.RetainForm Property

DiagramLink.RetainForm Property
[image]

Gets or sets a value indicating whether a link should maintain its form if the nodes connected with that link are moved around.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RetainForm { get; set; }

Visual Basic [image] Copy Code

Public Property RetainForm As Boolean

Property Value

true to retain the form of this link; otherwise, false. Initialized with the value of LinksRetainForm.

Remarks

RetainForm is useful for links that have more than two control points. If the nodes that a link connects are moved around, usually only the segments at the ends of that link are updated, so that they stay connected to their respective nodes. In that case all intermediate control points stay where they are. However, if RetainForm is enabled, all control points will move simultaneously in a way they preserve their relative position one to another, and thus preserving the overall form of the link.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.SegmentCount Property

DiagramLink.SegmentCount Property
[image]

Gets or sets the number of segments of this link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int SegmentCount { get; set; }

Visual Basic [image] Copy Code

Public Property SegmentCount As Integer

Property Value

An integer value specifying how many segments the link consists of.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Shape Property

DiagramLink.Shape Property
[image]

Gets or sets the type of link segments and how they are positioned one relatively to another.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As LinkShape

Property Value

A member of the LinkShape enumeration. Initialized with the value of LinkShape.

Remarks

This property specifies whether the segments of a link are straight lines or curves. In case of straight lines, they can be set all horizontal and vertical, each segment orthogonal to its neighbor, by using the Cascading shape. Use the SegmentCount property to set the number of segments of the link.

The orientation of the first segment of a cascading link depends on the value of CascadeOrientation. If that property is set to Auto, users may change the cascade orientation interactively.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.StartPoint Property

DiagramLink.StartPoint Property
[image]

Gets or sets the first control point of a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point StartPoint { get; set; }

Visual Basic [image] Copy Code

Public Property StartPoint As Point

Property Value

A Point object.

Remarks

This property is a shortcut for getting or setting ControlPoints[0].

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.Text Property

DiagramLink.Text Property
[image]

Gets or sets the text displayed over a link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string containing the text. Initialized with the value of LinkText.

Remarks

Gets or sets the text that should be drawn over a link. Use this to provide to end-users a short description of the relation's purpose. The text appearance can be customized through the TextBrush and TextStyle properties.

The link can display multiple labels via the LinkLabel class. Labels can automatically avoid overlapping nodes or other labels when their AutoArrange property is set.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.TextAlignment Property

DiagramLink.TextAlignment Property
[image]

Gets or sets the link's text placement and orientation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HorizontalAlignment TextAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property TextAlignment As HorizontalAlignment

Property Value

A member of the HorizontalAlignment enumeration. The default value is Center.

Remarks

Currently this property is considered only when TextStyle is set to OverLongestSegment.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.TextStyle Property

DiagramLink.TextStyle Property
[image]

Gets or sets the link's text placement and orientation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkTextStyle TextStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TextStyle As LinkTextStyle

Property Value

A member of the LinkTextStyle enumeration. Initialized with the value of LinkTextStyle.

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLink.TopLevel Property

DiagramLink.TopLevel Property
[image]

DiagramItem.TopLevel override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool TopLevel { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TopLevel As Boolean

Property Value

See Also

DiagramLink Members
DiagramLink Class


MindFusion.Diagramming.DiagramLinkCollection Class

DiagramLinkCollection Class
[image]

Represents a strongly-typed collection of DiagramLink objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLinkCollection : ItemCollectionBase<DiagramLink>

Visual Basic [image] Copy Code

Public Class DiagramLinkCollection
Inherits ItemCollectionBase(Of DiagramLink)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(DiagramLink)
MindFusion.Diagramming.ItemCollectionBase(DiagramLink)
MindFusion.Diagramming.DiagramLinkCollection

See Also

DiagramLinkCollection Members


MindFusion.Diagramming.DiagramLinkCollection Members

DiagramLinkCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly-typed collection of DiagramLink objects.

The following tables list the members exposed by the DiagramLinkCollection type.

Public Constructors

Name | Description
DiagramLinkCollection | Initializes a new instance of the DiagramLinkCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from ItemCollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from ItemCollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. Sorts the elements in this collection. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramLinkCollection Class


MindFusion.Diagramming.DiagramLinkCollection Constructor

DiagramLinkCollection Constructor
[image]

Initializes a new instance of the DiagramLinkCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkCollection Class


MindFusion.Diagramming.DiagramLinkCollection Methods

DiagramLinkCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. Sorts the elements in this collection. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramLinkCollection Class


MindFusion.Diagramming.DiagramLinkCollection.Clone Method

DiagramLinkCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As DiagramLinkCollection

Return Value

See Also

DiagramLinkCollection Members
DiagramLinkCollection Class


MindFusion.Diagramming.DiagramLinkProperties Class

DiagramLinkProperties Class
Remarks See Also
[image]

Stores the values of DiagramLink properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLinkProperties : DiagramItemProperties

Visual Basic [image] Copy Code

Public Class DiagramLinkProperties
Inherits DiagramItemProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from DiagramLink, do so by deriving from DiagramLinkProperties and overriding the DiagramLink.SaveProperties, DiagramLink.RestoreProperties, and DiagramLink.CreateProperties methods.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramLinkProperties

See Also

DiagramLinkProperties Members


MindFusion.Diagramming.DiagramLinkProperties Members

DiagramLinkProperties Members
Constructors Fields Methods
[image]

Stores the values of DiagramLink properties during undo / redo operations.

The following tables list the members exposed by the DiagramLinkProperties type.

Public Constructors

Name | Description
DiagramLinkProperties | Initializes a new instance of the DiagramLinkProperties class.

Public Fields

Name | Description
AllowMoveEnd | For internal use.
AllowMoveStart | For internal use.
AutoRoute | For internal use.
AutoSnapToNode | For internal use.
BaseShape | For internal use.
BaseShapeSize | For internal use.
CascadeOrientation | For internal use.
CrossingRadius | For internal use.
DrawCrossings | For internal use.
Dynamic | For internal use.
HeadShape | For internal use.
HeadShapeSize | For internal use.
IntermediateShape | For internal use.
IntermediateShapeSize | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use.
RetainForm | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Text | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used. (Inherited from DiagramItemProperties.)

See Also

DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties Fields

DiagramLinkProperties Fields
[image]

Public Fields

Name | Description
AllowMoveEnd | For internal use.
AllowMoveStart | For internal use.
AutoRoute | For internal use.
AutoSnapToNode | For internal use.
BaseShape | For internal use.
BaseShapeSize | For internal use.
CascadeOrientation | For internal use.
CrossingRadius | For internal use.
DrawCrossings | For internal use.
Dynamic | For internal use.
HeadShape | For internal use.
HeadShapeSize | For internal use.
IntermediateShape | For internal use.
IntermediateShapeSize | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use.
RetainForm | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Text | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

See Also

DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.AllowMoveEnd Field

DiagramLinkProperties.AllowMoveEnd Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMoveEnd

Visual Basic [image] Copy Code

Public AllowMoveEnd As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.AllowMoveStart Field

DiagramLinkProperties.AllowMoveStart Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMoveStart

Visual Basic [image] Copy Code

Public AllowMoveStart As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.AutoRoute Field

DiagramLinkProperties.AutoRoute Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoRoute

Visual Basic [image] Copy Code

Public AutoRoute As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.AutoSnapToNode Field

DiagramLinkProperties.AutoSnapToNode Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoSnapToNode

Visual Basic [image] Copy Code

Public AutoSnapToNode As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.BaseShape Field

DiagramLinkProperties.BaseShape Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape BaseShape

Visual Basic [image] Copy Code

Public BaseShape As Shape

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.BaseShapeSize Field

DiagramLinkProperties.BaseShapeSize Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BaseShapeSize

Visual Basic [image] Copy Code

Public BaseShapeSize As Double

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.CascadeOrientation Field

DiagramLinkProperties.CascadeOrientation Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation CascadeOrientation

Visual Basic [image] Copy Code

Public CascadeOrientation As Orientation

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.CrossingRadius Field

DiagramLinkProperties.CrossingRadius Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CrossingRadius

Visual Basic [image] Copy Code

Public CrossingRadius As Double

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.DrawCrossings Field

DiagramLinkProperties.DrawCrossings Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DrawCrossings

Visual Basic [image] Copy Code

Public DrawCrossings As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.Dynamic Field

DiagramLinkProperties.Dynamic Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Dynamic

Visual Basic [image] Copy Code

Public Dynamic As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.HeadShape Field

DiagramLinkProperties.HeadShape Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape HeadShape

Visual Basic [image] Copy Code

Public HeadShape As Shape

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.HeadShapeSize Field

DiagramLinkProperties.HeadShapeSize Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HeadShapeSize

Visual Basic [image] Copy Code

Public HeadShapeSize As Double

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.IntermediateShape Field

DiagramLinkProperties.IntermediateShape Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape IntermediateShape

Visual Basic [image] Copy Code

Public IntermediateShape As Shape

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.IntermediateShapeSize Field

DiagramLinkProperties.IntermediateShapeSize Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double IntermediateShapeSize

Visual Basic [image] Copy Code

Public IntermediateShapeSize As Double

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.labels Field

DiagramLinkProperties.labels Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<LinkLabel> labels

Visual Basic [image] Copy Code

Public labels As List(Of LinkLabel)

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.RetainForm Field

DiagramLinkProperties.RetainForm Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RetainForm

Visual Basic [image] Copy Code

Public RetainForm As Boolean

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties.Text Field

DiagramLinkProperties.Text Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text

Visual Basic [image] Copy Code

Public Text As String

See Also

DiagramLinkProperties Members
DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkProperties Constructor

DiagramLinkProperties Constructor
[image]

Initializes a new instance of the DiagramLinkProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkProperties Class


MindFusion.Diagramming.DiagramLinkState Class

DiagramLinkState Class
Remarks See Also
[image]

Contains a snapshot of the internal state of a DiagramLink.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLinkState : DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramLinkState
Inherits DiagramItemState

Remarks

Instances of this class are used to store the state of links for later undo or redo operations. If you derive from DiagramLink and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramLinkState and overriding the DiagramLink.CreateState, DiagramLink.SaveState and DiagramLink.RestoreState methods.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramLinkState

See Also

DiagramLinkState Members


MindFusion.Diagramming.DiagramLinkState Members

DiagramLinkState Members
Constructors
[image]

Contains a snapshot of the internal state of a DiagramLink.

The following tables list the members exposed by the DiagramLinkState type.

Public Constructors

Name | Description
DiagramLinkState | Initializes a new instance of the DiagramLinkState class.

See Also

DiagramLinkState Class


MindFusion.Diagramming.DiagramLinkState Constructor

DiagramLinkState Constructor
[image]

Initializes a new instance of the DiagramLinkState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkState Class


MindFusion.Diagramming.DiagramLinkStyle Class

DiagramLinkStyle Class
[image]

Represents a reusable set of properties that define the appearance of diagram links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramLinkStyle : DiagramItemStyle

Visual Basic [image] Copy Code

Public Class DiagramLinkStyle
Inherits DiagramItemStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramLinkStyle

See Also

DiagramLinkStyle Members


MindFusion.Diagramming.DiagramLinkStyle Members

DiagramLinkStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of diagram links.

The following tables list the members exposed by the DiagramLinkStyle type.

Public Constructors

Name | Description
DiagramLinkStyle | Initializes a new instance of the DiagramLinkStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
HeadStroke | Gets or sets the brush used to paint the arrowhead outlines of this brush.
HeadStrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline arrowheads.
HeadStrokeThickness | Gets or sets the outline thickness of the arrowheads of this brush, expressed in the current units of measure.
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JsonObject. (Inherited from DiagramItemStyle.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject. (Inherited from DiagramItemStyle.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle Constructor

DiagramLinkStyle Constructor
[image]

Initializes a new instance of the DiagramLinkStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle Properties

DiagramLinkStyle Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
HeadStroke | Gets or sets the brush used to paint the arrowhead outlines of this brush.
HeadStrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline arrowheads.
HeadStrokeThickness | Gets or sets the outline thickness of the arrowheads of this brush, expressed in the current units of measure.
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

See Also

DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle.HeadStroke Property

DiagramLinkStyle.HeadStroke Property
[image]

Gets or sets the brush used to paint the arrowhead outlines of this brush.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HeadStroke { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStroke As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramLinkStyle Members
DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle.HeadStrokeDashStyle Property

DiagramLinkStyle.HeadStrokeDashStyle Property
[image]

Gets or sets the pattern of dashes and gaps used to outline arrowheads.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle HeadStrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStrokeDashStyle As DashStyle

Property Value

A member of the DashStyle enumeration.

See Also

DiagramLinkStyle Members
DiagramLinkStyle Class


MindFusion.Diagramming.DiagramLinkStyle.HeadStrokeThickness Property

DiagramLinkStyle.HeadStrokeThickness Property
[image]

Gets or sets the outline thickness of the arrowheads of this brush, expressed in the current units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HeadStrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property HeadStrokeThickness As Double

Property Value

A double value.

See Also

DiagramLinkStyle Members
DiagramLinkStyle Class


MindFusion.Diagramming.DiagramNode Class

DiagramNode Class
Remarks See Also
[image]

Represents a diagram node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class DiagramNode : DiagramItem

Visual Basic [image] Copy Code

Public MustInherit Class DiagramNode
Inherits DiagramItem

Remarks

DiagramNode instances can represent graph vertices, nodes in organizational or flow diagrams, entities in ER diagrams, and so on. DiagramNode is an abstract class. You cannot use it directly, but instead use objects from the ShapeNode, TableNode, and ContainerNode specific classes. You can also create your own node class by deriving from DiagramNode or its descendants.

Use the Bounds property to get or change the location and size of a node. To move a node without changing its size, call the Move method. To change only the size of a node, invoke the Resize method.

Constraints upon how users are allowed to modify a node are set through the Constraints and EnabledHandles properties. The former specifies constraints on move direction and node size. The latter enables or disables specific manipulation handles of a node.

Relations between nodes are indicated by connecting the nodes with DiagramLink instances. Links are considered directed graph edges, so each node has two collections referring to links: IncomingLinks and OutgoingLinks. AnchorPattern defines to which points of a node incoming or outgoing links can be connected. The AllowIncomingLinks property lets you specify whether incoming links can be drawn to a node. The AllowOutgoingLinks property lets you do that for outgoing links.

A user is allowed to expand or collapse the tree starting from a node if Expandable is set to true. The Expanded property gets or sets whether the subtree starting from a node is expanded or not.

Nodes can be attached to other items, and be used as simple labels, image-holders or other kinds of UI elements.

Nodes can be rotated, either interactively using the rotation handle above the node, or programmatically using the RotationAngle property.

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ContainerNode
MindFusion.Diagramming.DummyNode
MindFusion.Diagramming.FreeFormNode
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.TableNode
MindFusion.Diagramming.TreeViewNode
MindFusion.Diagramming.Interaction.VirtualNode

See Also

DiagramNode Members


MindFusion.Diagramming.DiagramNode Members

DiagramNode Members
Constructors Fields Properties Methods
[image]

Represents a diagram node.

The following tables list the members exposed by the DiagramNode type.

Protected Constructors

Name | Description
DiagramNode | Overloaded. Initializes a new instance of the DiagramNode class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node.
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node.
Container | Gets the container node this item belongs to, if any.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node.
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like.
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node.
IsAttached | Gets a value indicating whether this item is attached to another item.
Labels | Returns the list of all labels displayed by this node.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
OutgoingLinks | Gets a collection of links that start from this node.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type.
AddLabel | Overloaded.
AttachManipulator | Adds the specified manipulator to this node.
AttachToLink | Overloaded. Attaches this node to a link.
AttachToNode | Attaches this node to the specified node using the specified attaching type.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node.
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
Detach | Detaches this node from its master item.
DetachManipulator | Removes the specified manipulator from this node.
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface.
DrawAnchors | Draws the anchor points of this node.
DrawHandles | DiagramItem.DrawHandles override.
DrawLocal | Override in a derived class to provide implementation specific drawing for the node.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface.
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node.
Expand | Shows all nodes and links in the subtree starting from this node.
GetAllLinks | Gets all links connected to this node.
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node.
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle.
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point.
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point.
GetOutlinePoly | DiagramItem.GetOutlinePoly override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Determines whether this node's outline intersects with the outline of the specified node.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point.
Move | Moves the node to the specified location.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed.
ReassignUnanchoredLinks | Reassigns unanchored links
RemoveLabel | Removes the specified label from this node.
Resize | Resizes the node.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates.
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | DiagramItem.LoadFromXml override.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node.
OnRemove | DiagramItem.OnRemove override.
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively.
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. Invoked when the bounding rectangle of the node has changed.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.
SetExpanded | DiagramItem.SetExpanded override.
SetIncomingLinks | Sets the incoming links collection of this node.
SetOutgoingLinks | Sets the outgoing links collection of this node.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points.
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape.
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor

DiagramNode Constructor
[image]

Initializes a new instance of the DiagramNode class.

Overload List

Name | Description
DiagramNode () | Initializes a new instance of the DiagramNode class.
DiagramNode (Diagram) | Initializes a new instance of the DiagramNode class with default values supplied form the specified Diagram.
DiagramNode (DiagramNode) | Initializes a new instance of the DiagramNode class using the specified diagram item as a prototype.

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor ()

DiagramNode Constructor ()
See Also
[image]

Initializes a new instance of the DiagramNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramNode ()

Visual Basic [image] Copy Code

Protected Sub New ()

Remarks

This constructor sets the DiagramNode properties to their default values.

See Also

DiagramNode Constructor Overload List
DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor (Diagram)

DiagramNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the DiagramNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramNode (
Diagram parent
)

Visual Basic [image] Copy Code

Protected New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the item properties.

Remarks

This constructor initializes the DiagramNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

DiagramNode Constructor Overload List
DiagramNode Class


MindFusion.Diagramming.DiagramNode Constructor (DiagramNode)

DiagramNode Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramNode class using the specified diagram item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramNode (
DiagramNode prototype
)

Visual Basic [image] Copy Code

Protected New ( _
prototype As DiagramNode _
)

Parameters

prototype

The item to use as a prototype. The properties of the new item are initialized from the property values of this item.

Remarks

This constructor copies the DiagramNode property values from the specified prototype node.

See Also

DiagramNode Constructor Overload List
DiagramNode Class


MindFusion.Diagramming.DiagramNode Methods

DiagramNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type.
AddLabel | Overloaded.
AttachManipulator | Adds the specified manipulator to this node.
AttachToLink | Overloaded. Attaches this node to a link.
AttachToNode | Attaches this node to the specified node using the specified attaching type.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node.
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
Detach | Detaches this node from its master item.
DetachManipulator | Removes the specified manipulator from this node.
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface.
DrawAnchors | Draws the anchor points of this node.
DrawHandles | DiagramItem.DrawHandles override.
DrawLocal | Override in a derived class to provide implementation specific drawing for the node.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface.
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node.
Expand | Shows all nodes and links in the subtree starting from this node.
GetAllLinks | Gets all links connected to this node.
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node.
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle.
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point.
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point.
GetOutlinePoly | DiagramItem.GetOutlinePoly override.
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Determines whether this node's outline intersects with the outline of the specified node.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point.
Move | Moves the node to the specified location.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node.
OnDragOver | Invoked when a diagram item is being dragged over this node.
OnDropOver | Invoked when a diagram item is dropped over this node.
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed.
ReassignUnanchoredLinks | Reassigns unanchored links
RemoveLabel | Removes the specified label from this node.
Resize | Resizes the node.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates.
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | DiagramItem.LoadFromXml override.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node.
OnRemove | DiagramItem.OnRemove override.
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively.
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. Invoked when the bounding rectangle of the node has changed.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override.
SaveProperties | DiagramItem.SaveProperties override.
SaveState | DiagramItem.SaveState override.
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.
SetExpanded | DiagramItem.SetExpanded override.
SetIncomingLinks | Sets the incoming links collection of this node.
SetOutgoingLinks | Sets the outgoing links collection of this node.
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points.
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape.
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode.AcceptLinks Method

DiagramNode.AcceptLinks Method
[image]

Determines whether the node can be connected with links of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool AcceptLinks (
bool outgoing
)

Visual Basic [image] Copy Code

Public Overridable Function AcceptLinks( _
outgoing As Boolean _
) As Boolean

Parameters

outgoing

true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AddLabel Method

DiagramNode.AddLabel Method
[image]

Overload List

Name | Description
DiagramNode.AddLabel (NodeLabel) | Adds the specified label to this node.
DiagramNode.AddLabel (String) | Adds a new label to this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AddLabel Method (NodeLabel)

DiagramNode.AddLabel Method (NodeLabel)
See Also
[image]

Adds the specified label to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddLabel (
NodeLabel label
)

Visual Basic [image] Copy Code

Public Sub AddLabel( _
label As NodeLabel _
)

Parameters

label

A NodeLabel instance.

See Also

AddLabel Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AddLabel Method (String)

DiagramNode.AddLabel Method (String)
See Also
[image]

Adds a new label to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeLabel AddLabel (
string text
)

Visual Basic [image] Copy Code

Public Function AddLabel( _
text As String _
) As NodeLabel

Parameters

text

The label's text.

Return Value

A NodeLabel instance.

See Also

AddLabel Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AttachManipulator Method

DiagramNode.AttachManipulator Method
[image]

Adds the specified manipulator to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AttachManipulator (
Manipulator manipulator
)

Visual Basic [image] Copy Code

Public Sub AttachManipulator( _
manipulator As Manipulator _
)

Parameters

manipulator

A Manipulator object representing the manipulator to add.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AttachToLink Method

DiagramNode.AttachToLink Method
[image]

Attaches this node to a link.

Overload List

Name | Description
DiagramNode.AttachToLink (DiagramLink, AttachToLink) | Attaches this node to the specified link using the specified attaching type.
DiagramNode.AttachToLink (DiagramLink, AttachToLink, Int32) | Attaches this node to the specified link using the specified attaching type.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AttachToLink Method (DiagramLink, AttachToLink)

DiagramNode.AttachToLink Method (DiagramLink, AttachToLink)
See Also
[image]

Attaches this node to the specified link using the specified attaching type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AttachToLink (
DiagramLink link,
AttachToLink from
)

Visual Basic [image] Copy Code

Public Sub AttachToLink( _
link As DiagramLink, _
from As AttachToLink _
)

Parameters

link

A DiagramLink to whose control point or segment to attach this node.

from

A value of the AttachToLink enumeration specifying whether to attach the node to a segment or to a control point of the link.

See Also

AttachToLink Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AttachToLink Method (DiagramLink, AttachToLink, Int32)

DiagramNode.AttachToLink Method (DiagramLink, AttachToLink, Int32)
See Also
[image]

Attaches this node to the specified link using the specified attaching type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AttachToLink (
DiagramLink link,
AttachToLink from,
int index
)

Visual Basic [image] Copy Code

Public Sub AttachToLink( _
link As DiagramLink, _
from As AttachToLink, _
index As Integer _
)

Parameters

link

A DiagramLink to whose control point or segment to attach this node.

from

A value of the AttachToLink enumeration specifying whether to attach the node to a segment or to a control point of the link.

index

An index of link's control point or segment, depending on the attType value.

See Also

AttachToLink Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AttachToNode Method

DiagramNode.AttachToNode Method
[image]

Attaches this node to the specified node using the specified attaching type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AttachToNode (
DiagramNode node,
AttachToNode from
)

Visual Basic [image] Copy Code

Public Sub AttachToNode( _
node As DiagramNode, _
from As AttachToNode _
)

Parameters

node

A reference to the node to whose corner to attach this node.

from

A member of the AttachToNode enumeration specifying to which corner of a node to attach this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Collapse Method

DiagramNode.Collapse Method
[image]

Hides all nodes and links in the subtree starting from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Collapse ()

Visual Basic [image] Copy Code

Public Sub Collapse ()

Remarks

This method is useful mostly when nodes form a tree-like hierarchical structure. Invoking Collapse on a node makes all its children in the tree invisible. It depends on the diagram's ExpandOnIncoming property which items connected to the node are considered its children.

Collapse is meant for use with tree structures and it is your responsibility to ensure that your chart is really a tree. A graph is a tree if every node has no more than one parent and there's one root node that can be reached from all nodes going in child-to-parent direction. The tree can be expanded again by calling the Expand method.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ContainsPoint Method

DiagramNode.ContainsPoint Method
[image]

DiagramItem.ContainsPoint override.

Overload List

Name | Description
DiagramNode.ContainsPoint (Point) | DiagramItem.ContainsPoint override.
DiagramNode.ContainsPoint (Point, Double) | Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ContainsPoint Method (Point)

DiagramNode.ContainsPoint Method (Point)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

Return Value

Remarks

true it this node contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ContainsPoint Method (Point, Double)

DiagramNode.ContainsPoint Method (Point, Double)
See Also
[image]

Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

The point to check.

threshold

Specifies the size of the area around the node outlines where the point is still considered inside the node.

Return Value

true it this node contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.CreateConnectionPoint Method

DiagramNode.CreateConnectionPoint Method
[image]

Creates a connection point between this node and the specified link at the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Public Overridable Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link

A DiagramLink that should be connected to this node.

pt

The point at which the link should be connected.

incoming

true if link is an incoming link, otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.CreateProperties Method

DiagramNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramNodeProperties object that will be used to store the properties of this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.CreateState Method

DiagramNode.CreateState Method
[image]

DiagramItem.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateState () As DiagramItemState

Return Value

An instance of the DiagramItemState class.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Detach Method

DiagramNode.Detach Method
[image]

Detaches this node from its master item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Detach ()

Visual Basic [image] Copy Code

Public Sub Detach ()

Remarks

The node should be previously attached using one of the AttachTo* methods.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DetachManipulator Method

DiagramNode.DetachManipulator Method
[image]

Removes the specified manipulator from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DetachManipulator (
Manipulator manipulator
)

Visual Basic [image] Copy Code

Public Sub DetachManipulator( _
manipulator As Manipulator _
)

Parameters

manipulator

A Manipulator object representing the manipulator to remove.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Draw Method

DiagramNode.Draw Method
[image]

DiagramItem.Draw override. Draws the item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the node on.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DrawAnchors Method

DiagramNode.DrawAnchors Method
[image]

Draws the anchor points of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void DrawAnchors (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawAnchors( _
graphics As IGraphics _
)

Parameters

graphics

The IGraphics surface to draw the anchor points on.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DrawHandles Method

DiagramNode.DrawHandles Method
[image]

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As IGraphics, _
style As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface on which the handles should be drawn.

style

A HandlesVisualStyle instance containing brush and pen objects that should be used when drawing handles.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DrawLocal Method

DiagramNode.DrawLocal Method
[image]

Override in a derived class to provide implementation specific drawing for the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the node on.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DrawShadow Method

DiagramNode.DrawShadow Method
[image]

DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadow( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.DrawShadowLocal Method

DiagramNode.DrawShadowLocal Method
[image]

Override in a derived class to provide implementation specific drawing for the shadow of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void DrawShadowLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawShadowLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Expand Method

DiagramNode.Expand Method
[image]

Shows all nodes and links in the subtree starting from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Expand ()

Visual Basic [image] Copy Code

Public Sub Expand ()

Remarks

This method is useful mostly when nodes form a tree-like hierarchical structure. Use Expand to show a subtree of nodes that was previously collapsed, either interactively or by calling Collapse. If the RecursiveExpand property is enabled, all tree levels are expanded recursively.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllIncomingLinks Method

DiagramNode.GetAllIncomingLinks Method
[image]

Collects all links entering this node.

Overload List

Name | Description
DiagramNode.GetAllIncomingLinks () | Gets a collection of all links entering this node.
DiagramNode.GetAllIncomingLinks (DiagramLinkCollection) | Adds all links going in this node to the specified collection.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllIncomingLinks Method ()

DiagramNode.GetAllIncomingLinks Method ()
See Also
[image]

Gets a collection of all links entering this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllIncomingLinks ()

Visual Basic [image] Copy Code

Public Function GetAllIncomingLinks () As DiagramLinkCollection

Return Value

An instance of the DiagramLinkCollection class.

See Also

GetAllIncomingLinks Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllIncomingLinks Method (DiagramLinkCollection)

DiagramNode.GetAllIncomingLinks Method (DiagramLinkCollection)
See Also
[image]

Adds all links going in this node to the specified collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void GetAllIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overridable Sub GetAllIncomingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

A DiagramLinkCollection instance.

See Also

GetAllIncomingLinks Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllLinks Method

DiagramNode.GetAllLinks Method
[image]

Gets all links connected to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllLinks ()

Visual Basic [image] Copy Code

Public Function GetAllLinks () As DiagramLinkCollection

Return Value

A DiagramLinkCollection containing the links connected to this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllOutgoingLinks Method

DiagramNode.GetAllOutgoingLinks Method
[image]

Collects all links going out of this node.

Overload List

Name | Description
DiagramNode.GetAllOutgoingLinks () | Gets a collection of all links going out of this node.
DiagramNode.GetAllOutgoingLinks (DiagramLinkCollection) | Adds all links going out of this node to the specified collection.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllOutgoingLinks Method ()

DiagramNode.GetAllOutgoingLinks Method ()
See Also
[image]

Gets a collection of all links going out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection GetAllOutgoingLinks ()

Visual Basic [image] Copy Code

Public Function GetAllOutgoingLinks () As DiagramLinkCollection

Return Value

An instance of the DiagramLinkCollection class.

See Also

GetAllOutgoingLinks Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetAllOutgoingLinks Method (DiagramLinkCollection)

DiagramNode.GetAllOutgoingLinks Method (DiagramLinkCollection)
See Also
[image]

Adds all links going out of this node to the specified collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void GetAllOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overridable Sub GetAllOutgoingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

A DiagramLinkCollection instance.

See Also

GetAllOutgoingLinks Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetCenter Method

DiagramNode.GetCenter Method
[image]

Gets the center of this node's bounding rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point GetCenter ()

Visual Basic [image] Copy Code

Public Function GetCenter () As Point

Return Value

A Point object representing the center point of this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetClosestAnchorPoint Method

DiagramNode.GetClosestAnchorPoint Method
[image]

Returns the index of the anchor point that lies at the shortest distance from the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetClosestAnchorPoint (
Point point,
bool incoming
)

Visual Basic [image] Copy Code

Public Function GetClosestAnchorPoint( _
point As Point, _
incoming As Boolean _
) As Integer

Parameters

point

A Point object specifying a location in the diagram.

incoming

true to look for anchor points that allow incoming links; false to look for ones that allow outgoing links.

Return Value

The index of the found point within the AnchorPattern definition.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetIntersection Method

DiagramNode.GetIntersection Method
[image]

Calculates the intersection point between the segment defined by the specified point pair and the node's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overridable Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart

The first point of the segment.

segmentEnd

The second point of the segment.

Return Value

A Point object representing the intersection point.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetLocalBounds Method

DiagramNode.GetLocalBounds Method
[image]

Gets this node's bounding rectangle in local coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Rect GetLocalBounds ()

Visual Basic [image] Copy Code

Protected Function GetLocalBounds () As Rect

Return Value

A Rectangle object representing the bounding rectangle of this node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetNearestBorderPoint Method

DiagramNode.GetNearestBorderPoint Method
[image]

Returns a point that lies on the outline of this node, at the shortest distance from the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Point GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overridable Function GetNearestBorderPoint( _
point As Point _
) As Point

Parameters

point

A Point instance specifying a point in the diagram.

Return Value

A Point specifying the point from the node's outline closest to the point specified as argument.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetOutlinePoly Method

DiagramNode.GetOutlinePoly Method
[image]

DiagramItem.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointCollection GetOutlinePoly (
bool rendering
)

Visual Basic [image] Copy Code

Public Overrides Function GetOutlinePoly( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRepaintRect Method

DiagramNode.GetRepaintRect Method
[image]

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected

true is related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this node is modified.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRgnInRect Method

DiagramNode.GetRgnInRect Method
[image]

Creates and returns a Region object for this node as though it is contained in the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual IGraphicsPath GetRgnInRect (
Rect rc,
bool inLocal
)

Visual Basic [image] Copy Code

Protected Overridable Function GetRgnInRect( _
rc As Rect, _
inLocal As Boolean _
) As IGraphicsPath

Parameters

rc

inLocal

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRotatedBounds Method

DiagramNode.GetRotatedBounds Method
[image]

Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point.

Overload List

Name | Description
DiagramNode.GetRotatedBounds () | DiagramItem.GetRotatedBounds override.
DiagramNode.GetRotatedBounds (Rect, Point, Double) | Gets the bounding rectangle of this node, when it is rotated at the specified angle around the specified pivot.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRotatedBounds Method ()

DiagramNode.GetRotatedBounds Method ()
See Also
[image]

DiagramItem.GetRotatedBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetRotatedBounds ()

Visual Basic [image] Copy Code

Public Overrides Function GetRotatedBounds () As Rect

Return Value

A rectangle that bounds the rotated shape of the item.

See Also

GetRotatedBounds Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.GetRotatedBounds Method (Rect, Point, Double)

DiagramNode.GetRotatedBounds Method (Rect, Point, Double)
See Also
[image]

Gets the bounding rectangle of this node, when it is rotated at the specified angle around the specified pivot.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected static Rect GetRotatedBounds (
Rect rect,
Point center,
double angle
)

Visual Basic [image] Copy Code

Protected Shared Function GetRotatedBounds( _
rect As Rect, _
center As Point, _
angle As Double _
) As Rect

Parameters

rect

The rectangle that will be rotated.

center

The pivot point.

angle

The rotation angle.

Return Value

A Rectangle representing the new bounding rectangle.

See Also

GetRotatedBounds Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.HitTestHandle Method

DiagramNode.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point,
double radius
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point, _
radius As Double _
) As AdjustmentHandle

Parameters

point

A Point value specifying where to look for a selection handle.

radius

A hit-testing threshold.

Return Value

Returns an AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Intersects Method

DiagramNode.Intersects Method
[image]

Determines whether this node's outline intersects with the outline of the specified node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Intersects (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function Intersects( _
node As DiagramNode _
) As Boolean

Parameters

node

A reference to the node to test for intersections with this one.

Return Value

true if the current node intersects with the specified node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.LabelFromPoint Method

DiagramNode.LabelFromPoint Method
[image]

Returns the label whose layout rectangle contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeLabel LabelFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public Function LabelFromPoint( _
point As Point _
) As NodeLabel

Parameters

point

A PointF instance.

Return Value

The NodeLabel that contains the specified point.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.LoadFromJson Method

DiagramNode.LoadFromJson Method
[image]

Loads the item content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the item's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Remarks

This method is invoked when an item is being deserialized from a diagram file saved in JSON format.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.LoadFromXml Method

DiagramNode.LoadFromXml Method
[image]

DiagramItem.LoadFromXml override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Move Method

DiagramNode.Move Method
[image]

Moves the node to the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Move (
double x,
double y
)

Visual Basic [image] Copy Code

Public Sub Move( _
x As Double, _
y As Double _
)

Parameters

x

A double value specifying the new x-coordinate of node's location.

y

A double value specifying the new y-coordinate of node's location.

Remarks

This method moves a node to the specified position, without changing the node's size. Moving a node also updates the control points coordinates of all links connected to the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnDragOut Method

DiagramNode.OnDragOut Method
[image]

Invoked when a diagram item is being dragged out of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnDragOut (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Sub OnDragOut( _
item As DiagramItem _
)

Parameters

item

The DiagramItem that is dragged out of the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnDragOver Method

DiagramNode.OnDragOver Method
[image]

Invoked when a diagram item is being dragged over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool OnDragOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Function OnDragOver( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem that is dragged over the node.

Return Value

false if the diagram should notify nodes below this one; otherwise, true.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnDropOver Method

DiagramNode.OnDropOver Method
[image]

Invoked when a diagram item is dropped over this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool OnDropOver (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Overridable Function OnDropOver( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem that is dropped over the node.

Return Value

false if the diagram should notify nodes below this one; otherwise, true.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnModify Method

DiagramNode.OnModify Method
[image]

Invoked when the user moves or resizes this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnModify (
Point position,
AdjustmentHandles adjustmentHandle
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnModify( _
position As Point, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

position

Specifies the touch position.

adjustmentHandle

Specifies the adjustment handle used to modify the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnRemove Method

DiagramNode.OnRemove Method
[image]

DiagramItem.OnRemove override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnRemove ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemove ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnRotationAngleChanged Method

DiagramNode.OnRotationAngleChanged Method
[image]

Invoked when the rotation angle of this node has been changed, either programmatically or interactively.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRotationAngleChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnRotationAngleChanged ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnUpdateBounds Method

DiagramNode.OnUpdateBounds Method
[image]

Invoked when the bounding rectangle of the node has changed.

Overload List

Name | Description
DiagramNode.OnUpdateBounds () | Invoked when the bounding rectangle of the node has changed.
DiagramNode.OnUpdateBounds (Boolean) | Invoked when the bounding rectangle of the node has changed.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnUpdateBounds Method ()

DiagramNode.OnUpdateBounds Method ()
See Also
[image]

Invoked when the bounding rectangle of the node has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnUpdateBounds ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnUpdateBounds ()

See Also

OnUpdateBounds Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OnUpdateBounds Method (Boolean)

DiagramNode.OnUpdateBounds Method (Boolean)
See Also
[image]

Invoked when the bounding rectangle of the node has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

true if the size has changed; false if only the position has changed.

See Also

OnUpdateBounds Method Overload List
DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.RaiseClicked Method

DiagramNode.RaiseClicked Method
[image]

Raises an event which notifies that a node has been clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RaiseClicked (
Point position,
double radius
)

Visual Basic [image] Copy Code

Protected Overrides Sub RaiseClicked( _
position As Point, _
radius As Double _
)

Parameters

position

The position of the pointer.

radius

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ReassignAnchorPoints Method

DiagramNode.ReassignAnchorPoints Method
[image]

Reassigns links to anchor points so that they are evenly distributed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReassignAnchorPoints ()

Visual Basic [image] Copy Code

Public Sub ReassignAnchorPoints ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ReassignUnanchoredLinks Method

DiagramNode.ReassignUnanchoredLinks Method
[image]

Reassigns unanchored links

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReassignUnanchoredLinks ()

Visual Basic [image] Copy Code

Public Sub ReassignUnanchoredLinks ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.RemoveLabel Method

DiagramNode.RemoveLabel Method
[image]

Removes the specified label from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveLabel (
NodeLabel label
)

Visual Basic [image] Copy Code

Public Sub RemoveLabel( _
label As NodeLabel _
)

Parameters

label

A NodeLabel instance.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Resize Method

DiagramNode.Resize Method
[image]

Resizes the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Resize (
double width,
double height
)

Visual Basic [image] Copy Code

Public Sub Resize( _
width As Double, _
height As Double _
)

Parameters

width

A double value specifying new width of the node.

height

A double value specifying new height of the node.

Remarks

This method resizes a node, without changing the node's top-left corner location. Resizing a node also updates the control points coordinates of all links connected to the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.RestoreProperties Method

DiagramNode.RestoreProperties Method
[image]

DiagramItem.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.RestoreState Method

DiagramNode.RestoreState Method
[image]

DiagramItem.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

An instance of the DiagramItemState class.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveProperties Method

DiagramNode.SaveProperties Method
[image]

DiagramItem.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveState Method

DiagramNode.SaveState Method
[image]

DiagramItem.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

An instance of the DiagramItemState class.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveToJson Method

DiagramNode.SaveToJson Method
[image]

Saves the item content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the item's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

Remarks

This method is invoked when an item is being serialized into an JSON-format diagram file.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SaveToXml Method

DiagramNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToXml( _
element As XElement, _
context As XmlPersistContext _
) As Task

Parameters

element

An XElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ScaleElements Method

DiagramNode.ScaleElements Method
[image]

Scales the node's elements by specified amount.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overridable Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetExpandable Method

DiagramNode.SetExpandable Method
[image]

Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetExpandable (
bool exp
)

Visual Basic [image] Copy Code

Protected Sub SetExpandable( _
exp As Boolean _
)

Parameters

exp

true if a collapse/expand button should be added to this node; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetExpanded Method

DiagramNode.SetExpanded Method
[image]

DiagramItem.SetExpanded override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetExpanded (
bool e
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetExpanded( _
e As Boolean _
)

Parameters

e

Specifies the new state of the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetExpandedFlag Method

DiagramNode.SetExpandedFlag Method
[image]

Sets the 'expanded' flag, repainting the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetExpandedFlag (
bool newState
)

Visual Basic [image] Copy Code

Public Sub SetExpandedFlag( _
newState As Boolean _
)

Parameters

newState

Specifies the new state of the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetIncomingLinks Method

DiagramNode.SetIncomingLinks Method
[image]

Sets the incoming links collection of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Sub SetIncomingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

A DiagramLinkCollection containing the node's incoming links.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetOutgoingLinks Method

DiagramNode.SetOutgoingLinks Method
[image]

Sets the outgoing links collection of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Sub SetOutgoingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

A DiagramLinkCollection containing the node's outgoing links.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.SetReflexive Method

DiagramNode.SetReflexive Method
[image]

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SetReflexive (
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overridable Sub SetReflexive( _
link As DiagramLink _
)

Parameters

link

Reference to the link.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.ShouldRenderAnchors Method

DiagramNode.ShouldRenderAnchors Method
[image]

Determines whether the node should render its anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool ShouldRenderAnchors (
RenderOptions options
)

Visual Basic [image] Copy Code

Protected Function ShouldRenderAnchors( _
options As RenderOptions _
) As Boolean

Parameters

options

A RenderOptions object providing more information about the current drawing context.

Return Value

true if anchor points should be rendered; otherwise, false.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.UpdateLinkIntersections Method

DiagramNode.UpdateLinkIntersections Method
[image]

Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void UpdateLinkIntersections ()

Visual Basic [image] Copy Code

Protected Sub UpdateLinkIntersections ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.UpdateLinkPositions Method

DiagramNode.UpdateLinkPositions Method
[image]

Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void UpdateLinkPositions ()

Visual Basic [image] Copy Code

Protected Sub UpdateLinkPositions ()

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode Properties

DiagramNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node.
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node.
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node.
Container | Gets the container node this item belongs to, if any.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node.
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node.
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like.
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node.
IsAttached | Gets a value indicating whether this item is attached to another item.
Labels | Returns the list of all labels displayed by this node.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any.
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.
OutgoingLinks | Gets a collection of links that start from this node.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

DiagramNode Class


MindFusion.Diagramming.DiagramNode.AllowIncomingLinks Property

DiagramNode.AllowIncomingLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw incoming links to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowIncomingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowIncomingLinks As Boolean

Property Value

true to let users draw incoming links to this node; otherwise, false. The default is true.

Remarks

Links to a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AllowOutgoingLinks Property

DiagramNode.AllowOutgoingLinks Property
[image]

Gets or sets a value indicating whether users are allowed to draw outgoing links from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowOutgoingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property AllowOutgoingLinks As Boolean

Property Value

true to let users draw outgoing links from this node; otherwise, false. The default is true.

Remarks

Links from a node can be created programmatically regardless of the value of this property.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.AnchorPattern Property

DiagramNode.AnchorPattern Property
[image]

Gets or sets the anchor points to which links are attached when connected to the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

This property specifies a set of points to which links can be attached. Each anchor point can accept either incoming links, outgoing links or both. If a node does not have any anchor points defined, links can be connected to any part of the node.

A ShapeNode whose AnchorPattern is not explicitly set uses the AnchorPattern from the Shape definition.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Bounds Property

DiagramNode.Bounds Property
[image]

Gets or sets the rectangle that defines the position of the diagram node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; set; }

Visual Basic [image] Copy Code

Public Property Bounds As Rect

Property Value

An instance of the Rectangle structure.

Remarks

Use this property to set or get the size and/or location of a node. Moving a node also updates the control points coordinates of all links connected to the node. If there are subordinate items attached to it, they are moved too by the translation vector defined by the Bounds change.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Constraints Property

DiagramNode.Constraints Property
[image]

Allows applying constraints to the location and size of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeConstraints Constraints { get; set; }

Visual Basic [image] Copy Code

Public Property Constraints As NodeConstraints

Property Value

An instance of the NodeConstraints class.

Remarks

These constraints are considered when a user modifies the node interactively. They are ignored if node placement is changed programmatically by using methods and properties.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Container Property

DiagramNode.Container Property
[image]

Gets the container node this item belongs to, if any.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode Container { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Container As ContainerNode

Property Value

An instance of the ContainerNode class.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Effects Property

DiagramNode.Effects Property
[image]

Gets a collection with all effects applied to this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<NodeEffect> Effects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Effects As IList(Of NodeEffect)

Property Value

A list with all node effects.

Remarks

The local node effects are applied after the diagram-wide node effects defined in NodeEffects. However, if the first effect in this list is null, the diagram effects are ignored.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.EnabledHandles Property

DiagramNode.EnabledHandles Property
[image]

Gets or sets the kinds of modifications that end-users are permitted to perform on the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandles EnabledHandles { get; set; }

Visual Basic [image] Copy Code

Public Property EnabledHandles As AdjustmentHandles

Property Value

A combination of the AdjustmentHandles enumeration members. The default is AdjustmentHandles.All.

Remarks

Disabling some selection handles allows restricting the types of modifications that users can perform on a node. Each manipulation handle can be enabled or disabled by setting or clearing the respective flag in the combination.

For example, to make a node resizable only horizontally, set this property to a combination of the Move, ResizeMiddleLeft and ResizeMiddleRight flags. That will disable all manipulation handles, except the left and right ones, which allow horizontal resizing, and the central one allowing movement of the node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Expandable Property

DiagramNode.Expandable Property
[image]

Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Expandable { get; set; }

Visual Basic [image] Copy Code

Public Property Expandable As Boolean

Property Value

true if users are allowed to expand / collapse the tree starting from this node; otherwise, false. The default is false.

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure. If it is enabled, a small [±] button is drawn beside the node. Clicking that button either shows or hides all children of this node in the tree. It depends on the diagram's ExpandOnIncoming property which items connected to a node are considered its children. The tree expansion continues recursively down the child nodes if the RecursiveExpand property is enabled.

A tree can be collapsed or expanded programmatically by invoking the Collapse or Expand methods on the tree root node.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Expanded Property

DiagramNode.Expanded Property
[image]

Gets or sets a value indicating whether the subtree starting from this node is expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Expanded As Boolean

Property Value

true if the tree starting from this node is expanded; otherwise, false.

Remarks

This property is useful mostly when nodes form a tree-like hierarchical structure. Set it to false to make the subtree starting from a node collapse, with all its child nodes and links becoming invisible. Set it to true to show the child nodes and links again.

A user is allowed to expand or collapse the tree that starts from a node interactively if the Expandable property of that node is enabled.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.HandlesStyle Property

DiagramNode.HandlesStyle Property
[image]

Gets or sets a value indicating how the node adjustment handles behave and what do they look like.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesStyle HandlesStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HandlesStyle As HandlesStyle

Property Value

A member of the HandlesStyle enumeration.

Remarks

Specifies how node selection status is indicated visually. In addition, this property defines how manipulation of the node can be done, that is, how to move it, resize it or link it to other nodes. You can assign any of the HandlesStyle values to this property.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.HasItems Property

DiagramNode.HasItems Property
[image]

Determines whether the node supports connections to its constituent elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool HasItems { get; }

Visual Basic [image] Copy Code

Protected Overridable ReadOnly Property HasItems As Boolean

Property Value

A boolean value.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.IncomingLinks Property

DiagramNode.IncomingLinks Property
[image]

Gets a collection of links that point to the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

A reference to a DiagramLinkCollection object.

Remarks

Use this collection to get access to every link pointing to the node, as well as get the number of such links. If the node is a table, links that connect to it as a whole entity are included in the collection, and links that connect to particular row of the table are included in IncomingLinks.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.IsAttached Property

DiagramNode.IsAttached Property
[image]

Gets a value indicating whether this item is attached to another item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsAttached { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsAttached As Boolean

Property Value

A boolean value.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Labels Property

DiagramNode.Labels Property
[image]

Returns the list of all labels displayed by this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<NodeLabel> Labels { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Labels As List(Of NodeLabel)

Property Value

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Master Property

DiagramNode.Master Property
[image]

Gets the item this item is attached to, if any.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Master { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Master As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.Obstacle Property

DiagramNode.Obstacle Property
[image]

Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Obstacle { get; set; }

Visual Basic [image] Copy Code

Public Property Obstacle As Boolean

Property Value

true makes routed links look for a path going around this node; false lets links cross the node. The default is true.

Remarks

It is useful to set this property to false for nodes used as decorative containers or labels.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.OutgoingLinks Property

DiagramNode.OutgoingLinks Property
[image]

Gets a collection of links that start from this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

A reference to a DiagramLinkCollection object.

Remarks

Use this collection to get access to every link starting from the node, as well as get the number of such links. If the node is a table, links that connect to it as a whole entity are included in the collection, and links that connect to particular row of the table are included in OutgoingLinks.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.RotationAngle Property

DiagramNode.RotationAngle Property
[image]

Gets or sets the rotation angle of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RotationAngle { get; set; }

Visual Basic [image] Copy Code

Public Property RotationAngle As Double

Property Value

A double value specifying the rotation angle in degrees.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNode.TopLevel Property

DiagramNode.TopLevel Property
[image]

DiagramItem.TopLevel override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool TopLevel { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property TopLevel As Boolean

Property Value

true if this is a top-level item in the diagram; false otherwise.

See Also

DiagramNode Members
DiagramNode Class


MindFusion.Diagramming.DiagramNodeCollection Class

DiagramNodeCollection Class
[image]

Represents a strongly-typed collection of diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeCollection : ItemCollectionBase<DiagramNode>

Visual Basic [image] Copy Code

Public Class DiagramNodeCollection
Inherits ItemCollectionBase(Of DiagramNode)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(DiagramNode)
MindFusion.Diagramming.ItemCollectionBase(DiagramNode)
MindFusion.Diagramming.DiagramNodeCollection

See Also

DiagramNodeCollection Members


MindFusion.Diagramming.DiagramNodeCollection Members

DiagramNodeCollection Members
Constructors Fields Properties Methods
[image]

Represents a strongly-typed collection of diagram nodes.

The following tables list the members exposed by the DiagramNodeCollection type.

Public Constructors

Name | Description
DiagramNodeCollection | Initializes a new instance of the DiagramNodeCollection class.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector. (Inherited from ItemCollectionBase.)
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items. (Inherited from ItemCollectionBase.)

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. Sorts the elements in this collection. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramNodeCollection Class


MindFusion.Diagramming.DiagramNodeCollection Constructor

DiagramNodeCollection Constructor
[image]

Initializes a new instance of the DiagramNodeCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeCollection Class


MindFusion.Diagramming.DiagramNodeCollection Methods

DiagramNodeCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection. (Inherited from ItemCollectionBase.)
Clear | Removes all diagram items from the collection. (Inherited from ItemCollectionBase.)
Clone | Creates a shallow copy of this collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position. (Inherited from ItemCollectionBase.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position. (Inherited from ItemCollectionBase.)
Remove | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
RemoveAt | Removes the diagram item from the collection. (Inherited from ItemCollectionBase.)
Sort | Overloaded. Sorts the elements in this collection. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event. (Inherited from ItemCollectionBase.)
RaiseInserting | Raises the Inserting event. (Inherited from ItemCollectionBase.)
RaiseRemoving | Raises the Removing event. (Inherited from ItemCollectionBase.)

See Also

DiagramNodeCollection Class


MindFusion.Diagramming.DiagramNodeCollection.Clone Method

DiagramNodeCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As DiagramNodeCollection

Return Value

An instance of the DiagramNodeCollection class.

See Also

DiagramNodeCollection Members
DiagramNodeCollection Class


MindFusion.Diagramming.DiagramNodeEventArgs Class

DiagramNodeEventArgs Class
[image]

Contains the arguments passed to the NodeSelected and NodeRemoved event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DiagramNodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DiagramNodeEventArgs

See Also

DiagramNodeEventArgs Members


MindFusion.Diagramming.DiagramNodeEventArgs Members

DiagramNodeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the NodeSelected and NodeRemoved event handlers.

The following tables list the members exposed by the DiagramNodeEventArgs type.

Public Constructors

Name | Description
DiagramNodeEventArgs | Overloaded. Initializes a new instance of the DiagramNodeEventArgs class.

Public Properties

Name | Description
Index | Gets or sets the index of the node within its containing collection.
Node | Gets the node related to the event.

See Also

DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs Constructor

DiagramNodeEventArgs Constructor
[image]

Initializes a new instance of the DiagramNodeEventArgs class.

Overload List

Name | Description
DiagramNodeEventArgs (DiagramNode) | Initializes a new instance of the DiagramNodeEventArgs class.
DiagramNodeEventArgs (DiagramNode, Int32) | Initializes a new instance of the DiagramNodeEventArgs class.

See Also

DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs Constructor (DiagramNode)

DiagramNodeEventArgs Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the DiagramNodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeEventArgs (
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode _
)

Parameters

node

The node related to the event.

See Also

DiagramNodeEventArgs Constructor Overload List
DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs Constructor (DiagramNode, Int32)

DiagramNodeEventArgs Constructor (DiagramNode, Int32)
See Also
[image]

Initializes a new instance of the DiagramNodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeEventArgs (
DiagramNode node,
int index
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
index As Integer _
)

Parameters

node

The node related to the event.

index

The zero-based index of the node within its containing collection.

See Also

DiagramNodeEventArgs Constructor Overload List
DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs Properties

DiagramNodeEventArgs Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the index of the node within its containing collection.
Node | Gets the node related to the event.

See Also

DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs.Index Property

DiagramNodeEventArgs.Index Property
[image]

Gets or sets the index of the node within its containing collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value.

See Also

DiagramNodeEventArgs Members
DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeEventArgs.Node Property

DiagramNodeEventArgs.Node Property
[image]

Gets the node related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

A DiagramNode object.

See Also

DiagramNodeEventArgs Members
DiagramNodeEventArgs Class


MindFusion.Diagramming.DiagramNodeProperties Class

DiagramNodeProperties Class
[image]

The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeProperties : DiagramItemProperties

Visual Basic [image] Copy Code

Public Class DiagramNodeProperties
Inherits DiagramItemProperties

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.ContainerNodeProperties
MindFusion.Diagramming.ShapeNodeProperties
MindFusion.Diagramming.TableNodeProperties

See Also

DiagramNodeProperties Members


MindFusion.Diagramming.DiagramNodeProperties Members

DiagramNodeProperties Members
Constructors Fields Methods
[image]

The base class for classes that store the properties for a DiagramNode-derived items during undo / redo operations.

The following tables list the members exposed by the DiagramNodeProperties type.

Public Constructors

Name | Description
DiagramNodeProperties | Initializes a new instance of the DiagramNodeProperties class.

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | Frees stored resources which will no longer be used. (Inherited from DiagramItemProperties.)

See Also

DiagramNodeProperties Class


MindFusion.Diagramming.DiagramNodeProperties Fields

DiagramNodeProperties Fields
[image]

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

See Also

DiagramNodeProperties Class


MindFusion.Diagramming.DiagramNodeProperties.labels Field

DiagramNodeProperties.labels Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<NodeLabel> labels

Visual Basic [image] Copy Code

Public labels As List(Of NodeLabel)

See Also

DiagramNodeProperties Members
DiagramNodeProperties Class


MindFusion.Diagramming.DiagramNodeProperties Constructor

DiagramNodeProperties Constructor
[image]

Initializes a new instance of the DiagramNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeProperties Class


MindFusion.Diagramming.DiagramNodeState Class

DiagramNodeState Class
Remarks See Also
[image]

Contains a snapshot of the internal state of a DiagramNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeState : DiagramItemState

Visual Basic [image] Copy Code

Public Class DiagramNodeState
Inherits DiagramItemState

Remarks

Instances of this class are used to store the state of nodes for later undo or redo operations. If you derive from DiagramNode and need to implement undo support for the additional internal state defined by your class, do so by deriving from DiagramNodeState and overriding the DiagramNode.CreateState, DiagramNode.SaveState and DiagramNode.RestoreState methods.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramNodeState
MindFusion.Diagramming.ShapeNodeState

See Also

DiagramNodeState Members


MindFusion.Diagramming.DiagramNodeState Members

DiagramNodeState Members
Constructors
[image]

Contains a snapshot of the internal state of a DiagramNode.

The following tables list the members exposed by the DiagramNodeState type.

Public Constructors

Name | Description
DiagramNodeState | Initializes a new instance of the DiagramNodeState class.

See Also

DiagramNodeState Class


MindFusion.Diagramming.DiagramNodeState Constructor

DiagramNodeState Constructor
[image]

Initializes a new instance of the DiagramNodeState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramNodeState Class


MindFusion.Diagramming.DiagramNodeStyle Class

DiagramNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of diagram nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramNodeStyle : DiagramItemStyle

Visual Basic [image] Copy Code

Public Class DiagramNodeStyle
Inherits DiagramItemStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.ContainerNodeStyle
MindFusion.Diagramming.FreeFormNodeStyle
MindFusion.Diagramming.ShapeNodeStyle
MindFusion.Diagramming.TableNodeStyle
MindFusion.Diagramming.TreeViewNodeStyle

See Also

DiagramNodeStyle Members


MindFusion.Diagramming.DiagramNodeStyle Members

DiagramNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of diagram nodes.

The following tables list the members exposed by the DiagramNodeStyle type.

Protected Constructors

Name | Description
DiagramNodeStyle | Initializes a new instance of the DiagramNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node.
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JsonObject.
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject.
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramNodeStyle Class


MindFusion.Diagramming.DiagramNodeStyle Constructor

DiagramNodeStyle Constructor
[image]

Initializes a new instance of the DiagramNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramNodeStyle ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

DiagramNodeStyle Class


MindFusion.Diagramming.DiagramNodeStyle Methods

DiagramNodeStyle Methods
[image]

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JsonObject.
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject.
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

See Also

DiagramNodeStyle Class


MindFusion.Diagramming.DiagramNodeStyle.LoadFromJson Method

DiagramNodeStyle.LoadFromJson Method
[image]

Loads the style content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the style's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNodeStyle Members
DiagramNodeStyle Class


MindFusion.Diagramming.DiagramNodeStyle.SaveToJson Method

DiagramNodeStyle.SaveToJson Method
[image]

Saves the style content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject the style's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramNodeStyle Members
DiagramNodeStyle Class


MindFusion.Diagramming.DiagramNodeStyle Properties

DiagramNodeStyle Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node.
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

See Also

DiagramNodeStyle Class


MindFusion.Diagramming.DiagramNodeStyle.Effects Property

DiagramNodeStyle.Effects Property
[image]

Gets a list of the effects applied to the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<NodeEffect> Effects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Effects As IList(Of NodeEffect)

Property Value

A list of NodeEffect objects.

See Also

DiagramNodeStyle Members
DiagramNodeStyle Class


MindFusion.Diagramming.DiagramPlatformProvider Class

DiagramPlatformProvider Class
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class DiagramPlatformProvider

Visual Basic [image] Copy Code

Public NotInheritable Class DiagramPlatformProvider

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramPlatformProvider

See Also

DiagramPlatformProvider Members


MindFusion.Diagramming.DiagramPlatformProvider Members

DiagramPlatformProvider Members
Methods
[image]

The following tables list the members exposed by the DiagramPlatformProvider type.

Public Methods

Name | Description
CreateMenuItem |

See Also

DiagramPlatformProvider Class


MindFusion.Diagramming.DiagramPlatformProvider Methods

DiagramPlatformProvider Methods
[image]

Public Methods

Name | Description
CreateMenuItem |

See Also

DiagramPlatformProvider Class


MindFusion.Diagramming.DiagramPlatformProvider.CreateMenuItem Method

DiagramPlatformProvider.CreateMenuItem Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static IMenuItem CreateMenuItem (
ImageSource source,
Size buttonSize,
Pen strokeColor,
Brush fillBrush,
Size imageSize
)

Visual Basic [image] Copy Code

Public Shared Function CreateMenuItem( _
source As ImageSource, _
buttonSize As Size, _
strokeColor As Pen, _
fillBrush As Brush, _
imageSize As Size _
) As IMenuItem

Parameters

source

buttonSize

strokeColor

fillBrush

imageSize

Return Value

See Also

DiagramPlatformProvider Members
DiagramPlatformProvider Class


MindFusion.Diagramming.DiagramPresenter Class

DiagramPresenter Class
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramPresenter : View, IResolution

Visual Basic [image] Copy Code

Public Class DiagramPresenter
Inherits View
Implements IResolution

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
MindFusion.Diagramming.DiagramPresenter

See Also

DiagramPresenter Members


MindFusion.Diagramming.DiagramPresenter Members

DiagramPresenter Members
Constructors Fields Properties Methods
[image]

The following tables list the members exposed by the DiagramPresenter type.

Public Constructors

Name | Description
DiagramPresenter |

Public Fields

Name | Description
Repaint |
ZoomFactorProperty |

Public Properties

Name | Description
Diagram |
DpiX |
DpiY |
ZoomFactor |

Protected Methods

Name | Description
MeasureOverride |

See Also

DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter Fields

DiagramPresenter Fields
[image]

Public Fields

Name | Description
Repaint |
ZoomFactorProperty |

See Also

DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter.Repaint Field

DiagramPresenter.Repaint Field
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EventHandler<RepaintEventArgs> Repaint

Visual Basic [image] Copy Code

Public Repaint As EventHandler(Of RepaintEventArgs)

See Also

DiagramPresenter Members
DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter.ZoomFactorProperty Field

DiagramPresenter.ZoomFactorProperty Field
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static BindableProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ZoomFactorProperty As BindableProperty

See Also

DiagramPresenter Members
DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter Constructor

DiagramPresenter Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramPresenter (
DiagramView diagramView,
bool internalScroll
)

Visual Basic [image] Copy Code

Public New ( _
diagramView As DiagramView, _
internalScroll As Boolean _
)

Parameters

diagramView

internalScroll

See Also

DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter Methods

DiagramPresenter Methods
[image]

Protected Methods

Name | Description
MeasureOverride |

See Also

DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter.MeasureOverride Method

DiagramPresenter.MeasureOverride Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
double widthConstraint,
double heightConstraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
widthConstraint As Double, _
heightConstraint As Double _
) As Size

Parameters

widthConstraint

heightConstraint

Return Value

See Also

DiagramPresenter Members
DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter Properties

DiagramPresenter Properties
[image]

Public Properties

Name | Description
Diagram |
DpiX |
DpiY |
ZoomFactor |

See Also

DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter.Diagram Property

DiagramPresenter.Diagram Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

See Also

DiagramPresenter Members
DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter.DpiX Property

DiagramPresenter.DpiX Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DpiX { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DpiX As Double

Property Value

See Also

DiagramPresenter Members
DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter.DpiY Property

DiagramPresenter.DpiY Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DpiY { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DpiY As Double

Property Value

See Also

DiagramPresenter Members
DiagramPresenter Class


MindFusion.Diagramming.DiagramPresenter.ZoomFactor Property

DiagramPresenter.ZoomFactor Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

See Also

DiagramPresenter Members
DiagramPresenter Class


MindFusion.Diagramming.DiagramStyle Class

DiagramStyle Class
[image]

Represents a reusable set of properties that define the appearance of diagrams.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramStyle : Style

Visual Basic [image] Copy Code

Public Class DiagramStyle
Inherits Style

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramStyle

See Also

DiagramStyle Members


MindFusion.Diagramming.DiagramStyle Members

DiagramStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of diagrams.

The following tables list the members exposed by the DiagramStyle type.

Public Constructors

Name | Description
DiagramStyle | Initializes a new instance of the DiagramStyle class.

Public Properties

Name | Description
BackBrush | Gets or sets the brush used for painting the diagram background.
Brush | Gets or sets the brush used to fill the interior of items.
FontFamily | Gets or sets the font family of the item texts.
FontSize | Gets or sets the font size of the item texts.
FontStyle | Gets or sets the font style of the item texts.
NodeEffects | Gets a list with all effects applied to the nodes of this diagram.
ShadowBrush | Gets or sets the brush used to paint the shadow of the items.
Stroke | Gets or sets the brush used to paint the outline of the items.
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items.
StrokeThickness | Gets or sets the thickness of the items' outline, expressed in the current units of measure.
TextBrush | Gets or sets the brush used to paint texts inside the items.

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JSON object.
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject.
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

DiagramStyle Class


MindFusion.Diagramming.DiagramStyle Constructor

DiagramStyle Constructor
[image]

Initializes a new instance of the DiagramStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramStyle Class


MindFusion.Diagramming.DiagramStyle Methods

DiagramStyle Methods
[image]

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JSON object.
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject.
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

See Also

DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.LoadFromJson Method

DiagramStyle.LoadFromJson Method
[image]

Loads the style content from a JSON object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the style's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.SaveToJson Method

DiagramStyle.SaveToJson Method
[image]

Saves the style content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject the style's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle Properties

DiagramStyle Properties
[image]

Public Properties

Name | Description
BackBrush | Gets or sets the brush used for painting the diagram background.
Brush | Gets or sets the brush used to fill the interior of items.
FontFamily | Gets or sets the font family of the item texts.
FontSize | Gets or sets the font size of the item texts.
FontStyle | Gets or sets the font style of the item texts.
NodeEffects | Gets a list with all effects applied to the nodes of this diagram.
ShadowBrush | Gets or sets the brush used to paint the shadow of the items.
Stroke | Gets or sets the brush used to paint the outline of the items.
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items.
StrokeThickness | Gets or sets the thickness of the items' outline, expressed in the current units of measure.
TextBrush | Gets or sets the brush used to paint texts inside the items.

See Also

DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.BackBrush Property

DiagramStyle.BackBrush Property
[image]

Gets or sets the brush used for painting the diagram background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush BackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property BackBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.Brush Property

DiagramStyle.Brush Property
[image]

Gets or sets the brush used to fill the interior of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.FontFamily Property

DiagramStyle.FontFamily Property
[image]

Gets or sets the font family of the item texts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string FontFamily { get; set; }

Visual Basic [image] Copy Code

Public Property FontFamily As String

Property Value

A string value.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.FontSize Property

DiagramStyle.FontSize Property
[image]

Gets or sets the font size of the item texts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float FontSize { get; set; }

Visual Basic [image] Copy Code

Public Property FontSize As Single

Property Value

A double value.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.FontStyle Property

DiagramStyle.FontStyle Property
[image]

Gets or sets the font style of the item texts.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FontAttributes FontStyle { get; set; }

Visual Basic [image] Copy Code

Public Property FontStyle As FontAttributes

Property Value

One or more of the members of the FontAttributes enumeration.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.NodeEffects Property

DiagramStyle.NodeEffects Property
[image]

Gets a list with all effects applied to the nodes of this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<NodeEffect> NodeEffects { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeEffects As IList(Of NodeEffect)

Property Value

A list of NodeEffect objects.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.ShadowBrush Property

DiagramStyle.ShadowBrush Property
[image]

Gets or sets the brush used to paint the shadow of the items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ShadowBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ShadowBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.Stroke Property

DiagramStyle.Stroke Property
[image]

Gets or sets the brush used to paint the outline of the items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Stroke { get; set; }

Visual Basic [image] Copy Code

Public Property Stroke As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.StrokeDashStyle Property

DiagramStyle.StrokeDashStyle Property
[image]

Gets or sets the pattern of dashes and gaps used to outline items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle StrokeDashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeDashStyle As DashStyle

Property Value

A member of the DashStyle enumeration.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.StrokeThickness Property

DiagramStyle.StrokeThickness Property
[image]

Gets or sets the thickness of the items' outline, expressed in the current units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StrokeThickness { get; set; }

Visual Basic [image] Copy Code

Public Property StrokeThickness As Double

Property Value

A double value.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramStyle.TextBrush Property

DiagramStyle.TextBrush Property
[image]

Gets or sets the brush used to paint texts inside the items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

DiagramStyle Members
DiagramStyle Class


MindFusion.Diagramming.DiagramView Class

DiagramView Class
[image]

Displays the content of a Diagram object and provides the ability to autoscroll and display scrollbars.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DiagramView : Grid

Visual Basic [image] Copy Code

Public Class DiagramView
Inherits Grid

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
Microsoft.Maui.Controls.Layout
Microsoft.Maui.Controls.Grid
MindFusion.Diagramming.DiagramView

See Also

DiagramView Members


MindFusion.Diagramming.DiagramView Members

DiagramView Members
Constructors Fields Properties Methods Events
[image]

Displays the content of a Diagram object and provides the ability to autoscroll and display scrollbars.

The following tables list the members exposed by the DiagramView type.

Public Constructors

Name | Description
DiagramView | Initializes a new instance of the DiagramView class.

Public Fields

Name | Description
ZoomFactorProperty |

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether the view will autoscroll during user interactions when the interaction happens near the edge of the view.
AllowInplaceDelete | Gets or sets a value indicating whether the users can delete items through the context menu.
AllowInplaceEdit | Gets or sets a value indicating whether the users can in-place edit items.
AutoScrollAmount | Gets or sets the step used to translate the view during autoscrolling.
Behavior | Gets or sets a value indicating how the control responds to user actions.
CustomBehavior | Gets or sets a custom behavior object specifying how MindFusion.Diagramming responds to user input.
Diagram |
HScrollBar | Gets the horizontal scrollbar of the control.
InteractionPoint | For internal use.
IsAutoScrollInteracting | For internal use.
IsDragging |
IsInteracting | For internal use.
IsScrollActive | Checks if the specified device point is located over the scroll area.
Menu | Gets a reference to the currently displayed context menu.
MultiTouchDraw | Gets or sets a value indicating whether the control allows drawing multiple items simultaneously.
MultiTouchModify | Gets or sets a value indicating whether multi-touch modifications are enabled.
MultiTouchZoom | Gets or sets a value indicating whether multi-touch zoom is enabled.
ScrollToggle | Gets the scroll toggle control associated with this diagram.
ScrollToggleActiveColor | Gets or sets the color of the scroll toggle when it is activated.
ScrollToggleColor | Gets or sets the color of the scroll toggle.
ScrollX | Gets the diagram's horizontal scroll position.
ScrollY | Gets the diagram's vertical scroll position.
ScrollZoneSize | Gets or sets the distance from the edge of the view where user interactions would trigger autoscrolling.
ShowContextMenu | Gets or sets a value indicating whether to display context menu when the user taps and holds over an item.
ShowScrollToggle | Gets or sets a value indicating whether to display the scroll toggle control in the bottom left of the diagram.
SystemScrollView |
Viewport | Returns the visible portion of the diagram area.
VScrollBar | Gets the vertical scrollbar of the control.
ZoomFactor | Gets or sets the zoom factor used to scale up or down the diagram.

Public Methods

Name | Description
AddChild |
BeginEdit | Enters inplace-edit mode, letting the user edit the text of the specified item.
CancelDrag |
ClientToDoc | Overloaded.
ClientToSystem |
DocToClient | Overloaded.
EndEdit | Exits inplace-edit mode and either accepts or rejects the changes made to the item's text.
GetGraphics | For internal use.
PresenterToView |
RemoveChild |
ScrollTo | Overloaded.
SetTransform | Overloaded.
ZoomToFit | Zooms the view to fit the document contents in the Diagram client area.

Protected Methods

Name | Description
OnAdded | Layout.OnAdded override.
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event.
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event.
OnLongPressed | Raises the LongPressed event.
OnParentSet | VisualElement.OnParentSet override.
OnRadialMenuCreated | Raises the RadialMenuCreated event.
OnRemoved | Layout.OnRemoved override.
OnSizeAllocated | Raises the size allocated event.
OnSizeRequest | This method is called during the measure pass of a layout cycle to get the desired size of an element.
OnTouchCancel | Raises the TouchCancel event.
OnTouchDown | Raises the TouchDown event.
OnTouchMove | Raises the TouchMove event.
OnTouchUp | Raises the TouchUp event.

Public Events

Name | Description
EnterInplaceEditMode | Raised when entering inplace-edit mode.
LeaveInplaceEditMode | Raised when leaving inplace-edit mode.
LongPressed | Raised when the user performs a long press gesture inside the diagram.
RadialMenuCreated | Raised when the context menu is displayed.
TouchCancel | Raised when the system cancels touch gestures.
TouchDown | Raised when the user touches inside the diagram.
TouchMove | Raised when the user drags inside the diagram.
TouchUp | Raised when the user releases a touch inside the diagram.

See Also

DiagramView Class


MindFusion.Diagramming.DiagramView Fields

DiagramView Fields
[image]

Public Fields

Name | Description
ZoomFactorProperty |

See Also

DiagramView Class


MindFusion.Diagramming.DiagramView.ZoomFactorProperty Field

DiagramView.ZoomFactorProperty Field
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static BindableProperty ZoomFactorProperty

Visual Basic [image] Copy Code

Public Shared ZoomFactorProperty As BindableProperty

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView Constructor

DiagramView Constructor
[image]

Initializes a new instance of the DiagramView class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DiagramView Class


MindFusion.Diagramming.DiagramView Methods

DiagramView Methods
[image]

Public Methods

Name | Description
AddChild |
BeginEdit | Enters inplace-edit mode, letting the user edit the text of the specified item.
CancelDrag |
ClientToDoc | Overloaded.
ClientToSystem |
DocToClient | Overloaded.
EndEdit | Exits inplace-edit mode and either accepts or rejects the changes made to the item's text.
GetGraphics | For internal use.
PresenterToView |
RemoveChild |
ScrollTo | Overloaded.
SetTransform | Overloaded.
ZoomToFit | Zooms the view to fit the document contents in the Diagram client area.

Protected Methods

Name | Description
OnAdded | Layout.OnAdded override.
OnEnterInplaceEditMode | Raises the EnterInplaceEditMode event.
OnLeaveInplaceEditMode | Raises the LeaveInplaceEditMode event.
OnLongPressed | Raises the LongPressed event.
OnParentSet | VisualElement.OnParentSet override.
OnRadialMenuCreated | Raises the RadialMenuCreated event.
OnRemoved | Layout.OnRemoved override.
OnSizeAllocated | Raises the size allocated event.
OnSizeRequest | This method is called during the measure pass of a layout cycle to get the desired size of an element.
OnTouchCancel | Raises the TouchCancel event.
OnTouchDown | Raises the TouchDown event.
OnTouchMove | Raises the TouchMove event.
OnTouchUp | Raises the TouchUp event.

See Also

DiagramView Class


MindFusion.Diagramming.DiagramView.AddChild Method

DiagramView.AddChild Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddChild (
IView child
)

Visual Basic [image] Copy Code

Public Sub AddChild( _
child As IView _
)

Parameters

child

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.BeginEdit Method

DiagramView.BeginEdit Method
[image]

Enters inplace-edit mode, letting the user edit the text of the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void BeginEdit (
DiagramItem item,
InplaceEditable obj,
Point point
)

Visual Basic [image] Copy Code

Public Sub BeginEdit( _
item As DiagramItem, _
obj As InplaceEditable, _
point As Point _
)

Parameters

item

The related diagram item.

obj

The diagram item, table cell, link label, or tree view item, whose text should be edited.

point

The touch position.

See Also

DiagramView Members
DiagramView Class
EndEdit Method


MindFusion.Diagramming.DiagramView.CancelDrag Method

DiagramView.CancelDrag Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ClientToDoc Method

DiagramView.ClientToDoc Method
[image]

Overload List

Name | Description
DiagramView.ClientToDoc (Point) | Converts the specified point from client to document coordinates.
DiagramView.ClientToDoc (Rect) | Converts the specified rectangle from client to document coordinates.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ClientToDoc Method (Point)

DiagramView.ClientToDoc Method (Point)
See Also
[image]

Converts the specified point from client to document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point ClientToDoc (
Point clientPoint
)

Visual Basic [image] Copy Code

Public Function ClientToDoc( _
clientPoint As Point _
) As Point

Parameters

clientPoint

A Point containing point's coordinates in view pixels.

Return Value

A Point containing logical coordinates in diagram's MeasureUnit.

See Also

ClientToDoc Method Overload List
DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ClientToDoc Method (Rect)

DiagramView.ClientToDoc Method (Rect)
See Also
[image]

Converts the specified rectangle from client to document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect ClientToDoc (
Rect clientRect
)

Visual Basic [image] Copy Code

Public Function ClientToDoc( _
clientRect As Rect _
) As Rect

Parameters

clientRect

A Rect containing coordinates in view pixels.

Return Value

A Rect containing logical coordinates in diagram's MeasureUnit.

See Also

ClientToDoc Method Overload List
DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ClientToSystem Method

DiagramView.ClientToSystem Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point ClientToSystem (
Point point
)

Visual Basic [image] Copy Code

Public Function ClientToSystem( _
point As Point _
) As Point

Parameters

point

Return Value

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.DocToClient Method

DiagramView.DocToClient Method
[image]

Overload List

Name | Description
DiagramView.DocToClient (Point) | Converts the specified point from document to client coordinates.
DiagramView.DocToClient (Rect) | Converts the specified rectangle from document to client coordinates.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.DocToClient Method (Point)

DiagramView.DocToClient Method (Point)
See Also
[image]

Converts the specified point from document to client coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point DocToClient (
Point docPoint
)

Visual Basic [image] Copy Code

Public Function DocToClient( _
docPoint As Point _
) As Point

Parameters

docPoint

A Point containing logical coordinates in diagram's MeasureUnit.

Return Value

A Point containing point's coordinates in view pixels.

See Also

DocToClient Method Overload List
DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.DocToClient Method (Rect)

DiagramView.DocToClient Method (Rect)
See Also
[image]

Converts the specified rectangle from document to client coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect DocToClient (
Rect docRect
)

Visual Basic [image] Copy Code

Public Function DocToClient( _
docRect As Rect _
) As Rect

Parameters

docRect

A Rect containing logical coordinates in diagram's MeasureUnit.

Return Value

A Rect containing coordinates in view pixels.

See Also

DocToClient Method Overload List
DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.EndEdit Method

DiagramView.EndEdit Method
[image]

Exits inplace-edit mode and either accepts or rejects the changes made to the item's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void EndEdit (
bool accept
)

Visual Basic [image] Copy Code

Public Sub EndEdit( _
accept As Boolean _
)

Parameters

accept

true to accept changes made to text, or false to reject them.

See Also

DiagramView Members
DiagramView Class
BeginEdit Method


MindFusion.Diagramming.DiagramView.GetGraphics Method

DiagramView.GetGraphics Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics GetGraphics ()

Visual Basic [image] Copy Code

Public Function GetGraphics () As IGraphics

Return Value

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnAdded Method

DiagramView.OnAdded Method
[image]

Layout.OnAdded override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnAdded (
View view
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnAdded( _
view As View _
)

Parameters

view

The element that was added.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnEnterInplaceEditMode Method

DiagramView.OnEnterInplaceEditMode Method
[image]

Raises the EnterInplaceEditMode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnEnterInplaceEditMode (
InPlaceEditEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnEnterInplaceEditMode( _
e As InPlaceEditEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnLeaveInplaceEditMode Method

DiagramView.OnLeaveInplaceEditMode Method
[image]

Raises the LeaveInplaceEditMode event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLeaveInplaceEditMode (
InPlaceEditEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLeaveInplaceEditMode( _
e As InPlaceEditEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnLongPressed Method

DiagramView.OnLongPressed Method
[image]

Raises the LongPressed event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnLongPressed (
TouchEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnLongPressed( _
e As TouchEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnParentSet Method

DiagramView.OnParentSet Method
[image]

VisualElement.OnParentSet override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnParentSet ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnParentSet ()

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnRadialMenuCreated Method

DiagramView.OnRadialMenuCreated Method
[image]

Raises the RadialMenuCreated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnRadialMenuCreated (
RadialMenuEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnRadialMenuCreated( _
e As RadialMenuEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnRemoved Method

DiagramView.OnRemoved Method
[image]

Layout.OnRemoved override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnRemoved (
View view
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnRemoved( _
view As View _
)

Parameters

view

The element that was removed.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnSizeAllocated Method

DiagramView.OnSizeAllocated Method
[image]

Raises the size allocated event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnSizeAllocated (
double width,
double height
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnSizeAllocated( _
width As Double, _
height As Double _
)

Parameters

width

The new width of the element.

height

The new height of the element.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnSizeRequest Method

DiagramView.OnSizeRequest Method
[image]

This method is called during the measure pass of a layout cycle to get the desired size of an element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override SizeRequest OnSizeRequest (
double widthConstraint,
double heightConstraint
)

Visual Basic [image] Copy Code

Protected Overrides Function OnSizeRequest( _
widthConstraint As Double, _
heightConstraint As Double _
) As SizeRequest

Parameters

widthConstraint

The available width for the element to use.

heightConstraint

The available height for the element to use.

Return Value

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnTouchCancel Method

DiagramView.OnTouchCancel Method
[image]

Raises the TouchCancel event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTouchCancel (
TouchEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTouchCancel( _
e As TouchEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnTouchDown Method

DiagramView.OnTouchDown Method
[image]

Raises the TouchDown event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTouchDown (
TouchEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTouchDown( _
e As TouchEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnTouchMove Method

DiagramView.OnTouchMove Method
[image]

Raises the TouchMove event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTouchMove (
TouchEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTouchMove( _
e As TouchEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.OnTouchUp Method

DiagramView.OnTouchUp Method
[image]

Raises the TouchUp event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnTouchUp (
TouchEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnTouchUp( _
e As TouchEventArgs _
)

Parameters

e

An object providing the event data.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.PresenterToView Method

DiagramView.PresenterToView Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point PresenterToView (
Point point
)

Visual Basic [image] Copy Code

Public Function PresenterToView( _
point As Point _
) As Point

Parameters

point

Return Value

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.RemoveChild Method

DiagramView.RemoveChild Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveChild (
IView child
)

Visual Basic [image] Copy Code

Public Sub RemoveChild( _
child As IView _
)

Parameters

child

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ScrollTo Method

DiagramView.ScrollTo Method
[image]

Overload List

Name | Description
DiagramView.ScrollTo (Double, Double) |
DiagramView.ScrollTo (Double, Double, Boolean) |

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ScrollTo Method (Double, Double)

DiagramView.ScrollTo Method (Double, Double)
See Also
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ScrollTo (
double x,
double y
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
x As Double, _
y As Double _
)

Parameters

x

y

See Also

ScrollTo Method Overload List
DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ScrollTo Method (Double, Double, Boolean)

DiagramView.ScrollTo Method (Double, Double, Boolean)
See Also
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ScrollTo (
double x,
double y,
bool keepInRange
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
x As Double, _
y As Double, _
keepInRange As Boolean _
)

Parameters

x

y

keepInRange

See Also

ScrollTo Method Overload List
DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.SetTransform Method

DiagramView.SetTransform Method
[image]

Overload List

Name | Description
DiagramView.SetTransform (IGraphics) | Sets the transformation of the specified graphics to correspond to the diagram's current unit, zoom and scroll.
DiagramView.SetTransform (IMatrix, IGraphics) | Sets the transformation of the specified graphics to correspond to the diagram's current unit, zoom and scroll.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.SetTransform Method (IGraphics)

DiagramView.SetTransform Method (IGraphics)
See Also
[image]

Sets the transformation of the specified graphics to correspond to the diagram's current unit, zoom and scroll.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetTransform (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Sub SetTransform( _
graphics As IGraphics _
)

Parameters

graphics

The IGraphics object to set.

See Also

SetTransform Method Overload List
DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.SetTransform Method (IMatrix, IGraphics)

DiagramView.SetTransform Method (IMatrix, IGraphics)
See Also
[image]

Sets the transformation of the specified graphics to correspond to the diagram's current unit, zoom and scroll.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetTransform (
IMatrix matrix,
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Sub SetTransform( _
matrix As IMatrix, _
graphics As IGraphics _
)

Parameters

matrix

The matrix object to set.

graphics

The IGraphics that should provide the DPI.

See Also

SetTransform Method Overload List
DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ZoomToFit Method

DiagramView.ZoomToFit Method
[image]

Zooms the view to fit the document contents in the Diagram client area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ZoomToFit ()

Visual Basic [image] Copy Code

Public Sub ZoomToFit ()

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView Properties

DiagramView Properties
[image]

Public Properties

Name | Description
AllowAutoScroll | Gets or sets a value indicating whether the view will autoscroll during user interactions when the interaction happens near the edge of the view.
AllowInplaceDelete | Gets or sets a value indicating whether the users can delete items through the context menu.
AllowInplaceEdit | Gets or sets a value indicating whether the users can in-place edit items.
AutoScrollAmount | Gets or sets the step used to translate the view during autoscrolling.
Behavior | Gets or sets a value indicating how the control responds to user actions.
CustomBehavior | Gets or sets a custom behavior object specifying how MindFusion.Diagramming responds to user input.
Diagram |
HScrollBar | Gets the horizontal scrollbar of the control.
InteractionPoint | For internal use.
IsAutoScrollInteracting | For internal use.
IsDragging |
IsInteracting | For internal use.
IsScrollActive | Checks if the specified device point is located over the scroll area.
Menu | Gets a reference to the currently displayed context menu.
MultiTouchDraw | Gets or sets a value indicating whether the control allows drawing multiple items simultaneously.
MultiTouchModify | Gets or sets a value indicating whether multi-touch modifications are enabled.
MultiTouchZoom | Gets or sets a value indicating whether multi-touch zoom is enabled.
ScrollToggle | Gets the scroll toggle control associated with this diagram.
ScrollToggleActiveColor | Gets or sets the color of the scroll toggle when it is activated.
ScrollToggleColor | Gets or sets the color of the scroll toggle.
ScrollX | Gets the diagram's horizontal scroll position.
ScrollY | Gets the diagram's vertical scroll position.
ScrollZoneSize | Gets or sets the distance from the edge of the view where user interactions would trigger autoscrolling.
ShowContextMenu | Gets or sets a value indicating whether to display context menu when the user taps and holds over an item.
ShowScrollToggle | Gets or sets a value indicating whether to display the scroll toggle control in the bottom left of the diagram.
SystemScrollView |
Viewport | Returns the visible portion of the diagram area.
VScrollBar | Gets the vertical scrollbar of the control.
ZoomFactor | Gets or sets the zoom factor used to scale up or down the diagram.

See Also

DiagramView Class


MindFusion.Diagramming.DiagramView.AllowAutoScroll Property

DiagramView.AllowAutoScroll Property
[image]

Gets or sets a value indicating whether the view will autoscroll during user interactions when the interaction happens near the edge of the view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowAutoScroll { get; set; }

Visual Basic [image] Copy Code

Public Property AllowAutoScroll As Boolean

Property Value

A boolean value.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.AllowInplaceDelete Property

DiagramView.AllowInplaceDelete Property
[image]

Gets or sets a value indicating whether the users can delete items through the context menu.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowInplaceDelete { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInplaceDelete As Boolean

Property Value

true to show a delete icon in the context menu, or false otherwise.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.AllowInplaceEdit Property

DiagramView.AllowInplaceEdit Property
[image]

Gets or sets a value indicating whether the users can in-place edit items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowInplaceEdit { get; set; }

Visual Basic [image] Copy Code

Public Property AllowInplaceEdit As Boolean

Property Value

true to show edit icon in the context menu, or false otherwise.

See Also

DiagramView Members
DiagramView Class
BeginEdit Method


MindFusion.Diagramming.DiagramView.AutoScrollAmount Property

DiagramView.AutoScrollAmount Property
[image]

Gets or sets the step used to translate the view during autoscrolling.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double AutoScrollAmount { get; set; }

Visual Basic [image] Copy Code

Public Property AutoScrollAmount As Double

Property Value

A double value.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.Behavior Property

DiagramView.Behavior Property
[image]

Gets or sets a value indicating how the control responds to user actions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Behavior Behavior { get; set; }

Visual Basic [image] Copy Code

Public Property Behavior As Behavior

Property Value

A member of the Behavior enumeration.

See Also

DiagramView Members
DiagramView Class
MultiTouchModify Property


MindFusion.Diagramming.DiagramView.CustomBehavior Property

DiagramView.CustomBehavior Property
[image]

Gets or sets a custom behavior object specifying how MindFusion.Diagramming responds to user input.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public BaseTouchBehavior CustomBehavior { get; set; }

Visual Basic [image] Copy Code

Public Property CustomBehavior As BaseTouchBehavior

Property Value

An instance of a BaseTouchBehavior-derived class. The default value is null.

Remarks

MindFusion.Diagramming for .NET MAUI provides several stock implementations of the BaseTouchBehavior class that can be used by assigning a member of the Behavior enumeration to the view's Behavior property. Create a custom behavior class only if the predefined ones don't meet your application requirements.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.Diagram Property

DiagramView.Diagram Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.HScrollBar Property

DiagramView.HScrollBar Property
[image]

Gets the horizontal scrollbar of the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScrollBarView HScrollBar { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property HScrollBar As ScrollBarView

Property Value

A ScrollBarView instance.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.InteractionPoint Property

DiagramView.InteractionPoint Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point InteractionPoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property InteractionPoint As Point

Property Value

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.IsAutoScrollInteracting Property

DiagramView.IsAutoScrollInteracting Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsAutoScrollInteracting { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsAutoScrollInteracting As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.IsDragging Property

DiagramView.IsDragging Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsDragging { get; set; }

Visual Basic [image] Copy Code

Public Property IsDragging As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.IsInteracting Property

DiagramView.IsInteracting Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsInteracting { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsInteracting As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.IsScrollActive Property

DiagramView.IsScrollActive Property
[image]

Checks if the specified device point is located over the scroll area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsScrollActive { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsScrollActive As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.Menu Property

DiagramView.Menu Property
[image]

Gets a reference to the currently displayed context menu.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RadialMenu Menu { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Menu As RadialMenu

Property Value

An instance of the RadialMenu class, or null if no menu is currently displayed.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.MultiTouchDraw Property

DiagramView.MultiTouchDraw Property
[image]

Gets or sets a value indicating whether the control allows drawing multiple items simultaneously.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MultiTouchDraw { get; set; }

Visual Basic [image] Copy Code

Public Property MultiTouchDraw As Boolean

Property Value

true to allow drawing multiple items simultaneously, or false otherwise. The default value is true.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming Namespace
MultiTouchModify Property
MultiTouchZoom Property


MindFusion.Diagramming.DiagramView.MultiTouchModify Property

DiagramView.MultiTouchModify Property
[image]

Gets or sets a value indicating whether multi-touch modifications are enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MultiTouchModify { get; set; }

Visual Basic [image] Copy Code

Public Property MultiTouchModify As Boolean

Property Value

true to enable multi-touch node modification, or false otherwise. The default value is true.

Remarks

If this property is enabled, two touches on same node will scale and rotate it. Otherwise each touch is handled independently according to current Behavior value, e.g. by drawing a new diagram link.

Multi-touch rotation is applied only if the Rotate handle bit in EnabledHandles is set.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming Namespace
MultiTouchZoom Property
MultiTouchDraw Property


MindFusion.Diagramming.DiagramView.MultiTouchZoom Property

DiagramView.MultiTouchZoom Property
[image]

Gets or sets a value indicating whether multi-touch zoom is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MultiTouchZoom { get; set; }

Visual Basic [image] Copy Code

Public Property MultiTouchZoom As Boolean

Property Value

true to enable multi-touch zoom, or false otherwise. The default value is true.

Remarks

If this property is disabled, each touch is handled independently according to current Behavior value, e.g. by drawing a new diagram item or moving an existing one.

See Also

DiagramView Members
DiagramView Class
MindFusion.Diagramming Namespace
MultiTouchDraw Property
MultiTouchModify Property


MindFusion.Diagramming.DiagramView.ScrollToggle Property

DiagramView.ScrollToggle Property
[image]

Gets the scroll toggle control associated with this diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScrollToggleView ScrollToggle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScrollToggle As ScrollToggleView

Property Value

An instance of the ScrollToggleView class.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ScrollToggleActiveColor Property

DiagramView.ScrollToggleActiveColor Property
[image]

Gets or sets the color of the scroll toggle when it is activated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ScrollToggleActiveColor { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollToggleActiveColor As Color

Property Value

A Color object.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ScrollToggleColor Property

DiagramView.ScrollToggleColor Property
[image]

Gets or sets the color of the scroll toggle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ScrollToggleColor { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollToggleColor As Color

Property Value

A Color object.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ScrollX Property

DiagramView.ScrollX Property
[image]

Gets the diagram's horizontal scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollX { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScrollX As Double

Property Value

A double specifying the horizontal scroll position in the current unit of measure.

See Also

DiagramView Members
DiagramView Class
ScrollTo Method


MindFusion.Diagramming.DiagramView.ScrollY Property

DiagramView.ScrollY Property
[image]

Gets the diagram's vertical scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollY { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScrollY As Double

Property Value

A double specifying the vertical scroll position in the current unit of measure.

See Also

DiagramView Members
DiagramView Class
ScrollTo Method


MindFusion.Diagramming.DiagramView.ScrollZoneSize Property

DiagramView.ScrollZoneSize Property
[image]

Gets or sets the distance from the edge of the view where user interactions would trigger autoscrolling.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollZoneSize { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollZoneSize As Double

Property Value

A double value.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ShowContextMenu Property

DiagramView.ShowContextMenu Property
[image]

Gets or sets a value indicating whether to display context menu when the user taps and holds over an item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowContextMenu { get; set; }

Visual Basic [image] Copy Code

Public Property ShowContextMenu As Boolean

Property Value

true to display context menu, or false otherwise.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ShowScrollToggle Property

DiagramView.ShowScrollToggle Property
[image]

Gets or sets a value indicating whether to display the scroll toggle control in the bottom left of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ShowScrollToggle { get; set; }

Visual Basic [image] Copy Code

Public Property ShowScrollToggle As Boolean

Property Value

true to display the toggle-scroll button in lower right of the view, or false otherwise.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.SystemScrollView Property

DiagramView.SystemScrollView Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SystemScrollView { get; set; }

Visual Basic [image] Copy Code

Public Property SystemScrollView As Boolean

Property Value

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.Viewport Property

DiagramView.Viewport Property
[image]

Returns the visible portion of the diagram area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Viewport { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Viewport As Rect

Property Value

A Rect instance.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.VScrollBar Property

DiagramView.VScrollBar Property
[image]

Gets the vertical scrollbar of the control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScrollBarView VScrollBar { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property VScrollBar As ScrollBarView

Property Value

A ScrollBarView instance.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.ZoomFactor Property

DiagramView.ZoomFactor Property
[image]

Gets or sets the zoom factor used to scale up or down the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ZoomFactor { get; set; }

Visual Basic [image] Copy Code

Public Property ZoomFactor As Double

Property Value

A double value specifying percent of the original diagram size. The default is 100.

Remarks

Use the property to set how far the diagram items should look. Values smaller than 100 make items appear further, bigger than 100 – nearer. The default value is 100, specifying that no scaling transformation is applied.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView Events

DiagramView Events
[image]

Public Events

Name | Description
EnterInplaceEditMode | Raised when entering inplace-edit mode.
LeaveInplaceEditMode | Raised when leaving inplace-edit mode.
LongPressed | Raised when the user performs a long press gesture inside the diagram.
RadialMenuCreated | Raised when the context menu is displayed.
TouchCancel | Raised when the system cancels touch gestures.
TouchDown | Raised when the user touches inside the diagram.
TouchMove | Raised when the user drags inside the diagram.
TouchUp | Raised when the user releases a touch inside the diagram.

See Also

DiagramView Class


MindFusion.Diagramming.DiagramView.EnterInplaceEditMode Event

DiagramView.EnterInplaceEditMode Event
[image]

Raised when entering inplace-edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<InPlaceEditEventArgs> EnterInplaceEditMode

Visual Basic [image] Copy Code

Public Event EnterInplaceEditMode As EventHandler(Of InPlaceEditEventArgs)

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.LeaveInplaceEditMode Event

DiagramView.LeaveInplaceEditMode Event
[image]

Raised when leaving inplace-edit mode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<InPlaceEditEventArgs> LeaveInplaceEditMode

Visual Basic [image] Copy Code

Public Event LeaveInplaceEditMode As EventHandler(Of InPlaceEditEventArgs)

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.LongPressed Event

DiagramView.LongPressed Event
[image]

Raised when the user performs a long press gesture inside the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<TouchEventArgs> LongPressed

Visual Basic [image] Copy Code

Public Event LongPressed As EventHandler(Of TouchEventArgs)

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.RadialMenuCreated Event

DiagramView.RadialMenuCreated Event
[image]

Raised when the context menu is displayed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<RadialMenuEventArgs> RadialMenuCreated

Visual Basic [image] Copy Code

Public Event RadialMenuCreated As EventHandler(Of RadialMenuEventArgs)

Event Data

RadialMenuCreated event handlers receive an argument of type RadialMenuEventArgs.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.TouchCancel Event

DiagramView.TouchCancel Event
[image]

Raised when the system cancels touch gestures.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<TouchEventArgs> TouchCancel

Visual Basic [image] Copy Code

Public Event TouchCancel As EventHandler(Of TouchEventArgs)

Event Data

TouchCancel event handlers receive an argument of type TouchEventArgs.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.TouchDown Event

DiagramView.TouchDown Event
[image]

Raised when the user touches inside the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<TouchEventArgs> TouchDown

Visual Basic [image] Copy Code

Public Event TouchDown As EventHandler(Of TouchEventArgs)

Event Data

TouchDown event handlers receive an argument of type TouchEventArgs.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.TouchMove Event

DiagramView.TouchMove Event
[image]

Raised when the user drags inside the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<TouchEventArgs> TouchMove

Visual Basic [image] Copy Code

Public Event TouchMove As EventHandler(Of TouchEventArgs)

Event Data

TouchMove event handlers receive an argument of type TouchEventArgs.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DiagramView.TouchUp Event

DiagramView.TouchUp Event
[image]

Raised when the user releases a touch inside the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<TouchEventArgs> TouchUp

Visual Basic [image] Copy Code

Public Event TouchUp As EventHandler(Of TouchEventArgs)

Event Data

TouchUp event handlers receive an argument of type TouchEventArgs.

See Also

DiagramView Members
DiagramView Class


MindFusion.Diagramming.DirectionConstraint Enumeration

DirectionConstraint Enumeration
[image]

Defines values that specify in what direction to constrain node movement.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum DirectionConstraint

Visual Basic [image] Copy Code

Public Enum DirectionConstraint

Members

Member name | Description
Horizontal | Users are allowed to move the node horizontally.
None | No restrictions.
Vertical | Users are allowed to move the node vertically.

See Also


MindFusion.Diagramming.DragEventArgs Class

DragEventArgs Class
[image]

Holds event data for the NodeListView drag events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DragEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DragEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DragEventArgs

See Also

DragEventArgs Members


MindFusion.Diagramming.DragEventArgs Members

DragEventArgs Members
Constructors Properties
[image]

Holds event data for the NodeListView drag events.

The following tables list the members exposed by the DragEventArgs type.

Public Constructors

Name | Description
DragEventArgs | Initializes a new isntance of the DragEventArgs class.

Public Properties

Name | Description
DragItem | The item being dragged.
Location | The current location of the dragged item.
PointerPoint |

See Also

DragEventArgs Class


MindFusion.Diagramming.DragEventArgs Constructor

DragEventArgs Constructor
[image]

Initializes a new isntance of the DragEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DragEventArgs (
Object dragItem,
Point location
)

Visual Basic [image] Copy Code

Public New ( _
dragItem As Object, _
location As Point _
)

Parameters

dragItem

location

See Also

DragEventArgs Class


MindFusion.Diagramming.DragEventArgs Properties

DragEventArgs Properties
[image]

Public Properties

Name | Description
DragItem | The item being dragged.
Location | The current location of the dragged item.
PointerPoint |

See Also

DragEventArgs Class


MindFusion.Diagramming.DragEventArgs.DragItem Property

DragEventArgs.DragItem Property
[image]

The item being dragged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object DragItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DragItem As Object

Property Value

See Also

DragEventArgs Members
DragEventArgs Class


MindFusion.Diagramming.DragEventArgs.Location Property

DragEventArgs.Location Property
[image]

The current location of the dragged item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Location { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Location As Point

Property Value

See Also

DragEventArgs Members
DragEventArgs Class


MindFusion.Diagramming.DragEventArgs.PointerPoint Property

DragEventArgs.PointerPoint Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object PointerPoint { get; set; }

Visual Basic [image] Copy Code

Public Property PointerPoint As Object

Property Value

See Also

DragEventArgs Members
DragEventArgs Class


MindFusion.Diagramming.DraggedNode Class

DraggedNode Class
[image]

Class used to hold the DiagramNode instance during drag and drop from NodeListView. It is used for easier detection of the dragged content as DragEventArgs.Data.GetData() does not check super classes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DraggedNode : Frame

Visual Basic [image] Copy Code

Public Class DraggedNode
Inherits Frame

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
Microsoft.Maui.Controls.Compatibility.Layout
Microsoft.Maui.Controls.TemplatedView
Microsoft.Maui.Controls.ContentView
Microsoft.Maui.Controls.Frame
MindFusion.Diagramming.DraggedNode

See Also

DraggedNode Members


MindFusion.Diagramming.DraggedNode Members

DraggedNode Members
Constructors Properties Methods Events
[image]

Class used to hold the DiagramNode instance during drag and drop from NodeListView. It is used for easier detection of the dragged content as DragEventArgs.Data.GetData() does not check super classes.

The following tables list the members exposed by the DraggedNode type.

Public Constructors

Name | Description
DraggedNode | Overloaded.

Public Properties

Name | Description
Label | The text to be displayed for the node.
Node | Holds the dragged DiagramNode.
Size | The size of the node.
Source |

Protected Methods

Name | Description
OnPropertyChanged |

Public Events

Name | Description
PropertyChanged |

See Also

DraggedNode Class


MindFusion.Diagramming.DraggedNode Constructor

DraggedNode Constructor
[image]

Overload List

Name | Description
DraggedNode (Element, DiagramNode, Size) | Initializes a new instance of the DraggedNode class.
DraggedNode (Element, DiagramNode, Size, String) | Initializes a new instance of the DraggedNode class.

See Also

DraggedNode Class


MindFusion.Diagramming.DraggedNode Constructor (Element, DiagramNode, Size)

DraggedNode Constructor (Element, DiagramNode, Size)
See Also
[image]

Initializes a new instance of the DraggedNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DraggedNode (
Element parent,
DiagramNode node,
Size size
)

Visual Basic [image] Copy Code

Public New ( _
parent As Element, _
node As DiagramNode, _
size As Size _
)

Parameters

parent

node

The dragged DiagramNode.

size

The size of the node.

See Also

DraggedNode Constructor Overload List
DraggedNode Class


MindFusion.Diagramming.DraggedNode Constructor (Element, DiagramNode, Size, String)

DraggedNode Constructor (Element, DiagramNode, Size, String)
See Also
[image]

Initializes a new instance of the DraggedNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DraggedNode (
Element parent,
DiagramNode node,
Size size,
string label
)

Visual Basic [image] Copy Code

Public New ( _
parent As Element, _
node As DiagramNode, _
size As Size, _
label As String _
)

Parameters

parent

node

The dragged DiagramNode.

size

The size of the node.

label

The text to be displayed for the node.

See Also

DraggedNode Constructor Overload List
DraggedNode Class


MindFusion.Diagramming.DraggedNode Methods

DraggedNode Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged |

See Also

DraggedNode Class


MindFusion.Diagramming.DraggedNode.OnPropertyChanged Method

DraggedNode.OnPropertyChanged Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected new void OnPropertyChanged (
string propertyName
)

Visual Basic [image] Copy Code

Protected Shadows Sub OnPropertyChanged( _
propertyName As String _
)

Parameters

propertyName

See Also

DraggedNode Members
DraggedNode Class


MindFusion.Diagramming.DraggedNode Properties

DraggedNode Properties
[image]

Public Properties

Name | Description
Label | The text to be displayed for the node.
Node | Holds the dragged DiagramNode.
Size | The size of the node.
Source |

See Also

DraggedNode Class


MindFusion.Diagramming.DraggedNode.Label Property

DraggedNode.Label Property
[image]

The text to be displayed for the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

See Also

DraggedNode Members
DraggedNode Class


MindFusion.Diagramming.DraggedNode.Node Property

DraggedNode.Node Property
[image]

Holds the dragged DiagramNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; set; }

Visual Basic [image] Copy Code

Public Property Node As DiagramNode

Property Value

See Also

DraggedNode Members
DraggedNode Class


MindFusion.Diagramming.DraggedNode.Size Property

DraggedNode.Size Property
[image]

The size of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size Size { get; set; }

Visual Basic [image] Copy Code

Public Property Size As Size

Property Value

See Also

DraggedNode Members
DraggedNode Class


MindFusion.Diagramming.DraggedNode.Source Property

DraggedNode.Source Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource Source { get; set; }

Visual Basic [image] Copy Code

Public Property Source As ImageSource

Property Value

See Also

DraggedNode Members
DraggedNode Class


MindFusion.Diagramming.DraggedNode Events

DraggedNode Events
[image]

Public Events

Name | Description
PropertyChanged |

See Also

DraggedNode Class


MindFusion.Diagramming.DraggedNode.PropertyChanged Event

DraggedNode.PropertyChanged Event
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

See Also

DraggedNode Members
DraggedNode Class


MindFusion.Diagramming.DrawAnchorPointEventArgs Class

DrawAnchorPointEventArgs Class
[image]

Contains the arguments passed to the DrawAnchorPoint event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawAnchorPointEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawAnchorPointEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawAnchorPointEventArgs

See Also

DrawAnchorPointEventArgs Members


MindFusion.Diagramming.DrawAnchorPointEventArgs Members

DrawAnchorPointEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawAnchorPoint event handlers.

The following tables list the members exposed by the DrawAnchorPointEventArgs type.

Public Constructors

Name | Description
DrawAnchorPointEventArgs | Initializes a new instance of the DrawAnchorPointEventArgs class.

Public Properties

Name | Description
AnchorIndex | Gets the index of the anchor point within its containing pattern.
AnchorPattern | Gets the anchor pattern containing the anchor point being drawn.
Graphics | Gets an IGraphics object whose methods should be used to draw the anchor point mark.
Location | Gets the location of the anchor point being drawn.
Node | Gets the node whose anchor point is being drawn.

See Also

DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs Constructor

DrawAnchorPointEventArgs Constructor
[image]

Initializes a new instance of the DrawAnchorPointEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawAnchorPointEventArgs (
IGraphics graphics,
Point location,
DiagramNode node,
AnchorPattern anchorPattern,
int anchorIndex
)

Visual Basic [image] Copy Code

Public New ( _
graphics As IGraphics, _
location As Point, _
node As DiagramNode, _
anchorPattern As AnchorPattern, _
anchorIndex As Integer _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

location

The position of the anchor point, expressed in document coordinates.

node

The DiagramNode related to the event.

anchorPattern

The AnchorPattern object whose point is being drawn.

anchorIndex

The zero-based index of the anchor point being drawn within its anchor pattern.

See Also

DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs Properties

DrawAnchorPointEventArgs Properties
[image]

Public Properties

Name | Description
AnchorIndex | Gets the index of the anchor point within its containing pattern.
AnchorPattern | Gets the anchor pattern containing the anchor point being drawn.
Graphics | Gets an IGraphics object whose methods should be used to draw the anchor point mark.
Location | Gets the location of the anchor point being drawn.
Node | Gets the node whose anchor point is being drawn.

See Also

DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs.AnchorIndex Property

DrawAnchorPointEventArgs.AnchorIndex Property
[image]

Gets the index of the anchor point within its containing pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorIndex As Integer

Property Value

An integer value specifying the zero-based index of the anchor point within its AnchorPattern.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs.AnchorPattern Property

DrawAnchorPointEventArgs.AnchorPattern Property
[image]

Gets the anchor pattern containing the anchor point being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs.Graphics Property

DrawAnchorPointEventArgs.Graphics Property
[image]

Gets an IGraphics object whose methods should be used to draw the anchor point mark.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs.Location Property

DrawAnchorPointEventArgs.Location Property
[image]

Gets the location of the anchor point being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Location { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Location As Point

Property Value

A Point specifying the location of the anchor point.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawAnchorPointEventArgs.Node Property

DrawAnchorPointEventArgs.Node Property
[image]

Gets the node whose anchor point is being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

DrawAnchorPointEventArgs Members
DrawAnchorPointEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs Class

DrawCellEventArgs Class
[image]

Contains the arguments passed to the DrawCell event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawCellEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawCellEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawCellEventArgs

See Also

DrawCellEventArgs Members


MindFusion.Diagramming.DrawCellEventArgs Members

DrawCellEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawCell event handlers.

The following tables list the members exposed by the DrawCellEventArgs type.

Public Constructors

Name | Description
DrawCellEventArgs | Initializes a new instance of the DrawCellEventArgs class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the cell being drawn.
Cell | Gets the cell that should be custom drawn.
Column | Gets the index of the table's column that contains Cell.
Graphics | Gets an IGraphics object whose methods should be used to draw the cell.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs Constructor

DrawCellEventArgs Constructor
[image]

Initializes a new instance of the DrawCellEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawCellEventArgs (
IGraphics graphics,
TableNode table,
int column,
int row,
Rect bounds
)

Visual Basic [image] Copy Code

Public New ( _
graphics As IGraphics, _
table As TableNode, _
column As Integer, _
row As Integer, _
bounds As Rect _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

table

The TableNode related to the event.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

bounds

The bounding rectangle of the cell being drawn.

See Also

DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs Properties

DrawCellEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the cell being drawn.
Cell | Gets the cell that should be custom drawn.
Column | Gets the index of the table's column that contains Cell.
Graphics | Gets an IGraphics object whose methods should be used to draw the cell.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Bounds Property

DrawCellEventArgs.Bounds Property
[image]

Gets the bounding rectangle of the cell being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

A Rectangle specifying the bounding rectangle of the cell.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Cell Property

DrawCellEventArgs.Cell Property
[image]

Gets the cell that should be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Column Property

DrawCellEventArgs.Column Property
[image]

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the column.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Graphics Property

DrawCellEventArgs.Graphics Property
[image]

Gets an IGraphics object whose methods should be used to draw the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Row Property

DrawCellEventArgs.Row Property
[image]

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the row.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawCellEventArgs.Table Property

DrawCellEventArgs.Table Property
[image]

Get the table that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

DrawCellEventArgs Members
DrawCellEventArgs Class


MindFusion.Diagramming.DrawItemEventArgs Class

DrawItemEventArgs Class
[image]

Contains the arguments passed to the DrawAdjustmentHandles event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawItemEventArgs

See Also

DrawItemEventArgs Members


MindFusion.Diagramming.DrawItemEventArgs Members

DrawItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawAdjustmentHandles event handlers.

The following tables list the members exposed by the DrawItemEventArgs type.

Public Constructors

Name | Description
DrawItemEventArgs | Initializes a new instance of the DrawItemEventArgs class.

Public Properties

Name | Description
Graphics | Gets an IGraphics object whose methods should be used to draw the adjustment handles.
Item | Gets the item whose selection handles are being drawn.

See Also

DrawItemEventArgs Class


MindFusion.Diagramming.DrawItemEventArgs Constructor

DrawItemEventArgs Constructor
[image]

Initializes a new instance of the DrawItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawItemEventArgs (
IGraphics graphics,
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
graphics As IGraphics, _
item As DiagramItem _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

item

The DiagramItem related to the event.

See Also

DrawItemEventArgs Class


MindFusion.Diagramming.DrawItemEventArgs Properties

DrawItemEventArgs Properties
[image]

Public Properties

Name | Description
Graphics | Gets an IGraphics object whose methods should be used to draw the adjustment handles.
Item | Gets the item whose selection handles are being drawn.

See Also

DrawItemEventArgs Class


MindFusion.Diagramming.DrawItemEventArgs.Graphics Property

DrawItemEventArgs.Graphics Property
[image]

Gets an IGraphics object whose methods should be used to draw the adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawItemEventArgs Members
DrawItemEventArgs Class


MindFusion.Diagramming.DrawItemEventArgs.Item Property

DrawItemEventArgs.Item Property
[image]

Gets the item whose selection handles are being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

DrawItemEventArgs Members
DrawItemEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs Class

DrawLinkEventArgs Class
[image]

Contains the arguments passed to the DrawLink event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawLinkEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawLinkEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawLinkEventArgs

See Also

DrawLinkEventArgs Members


MindFusion.Diagramming.DrawLinkEventArgs Members

DrawLinkEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawLink event handlers.

The following tables list the members exposed by the DrawLinkEventArgs type.

Public Constructors

Name | Description
DrawLinkEventArgs | Initializes a new instance of the DrawLinkEventArgs class.

Public Properties

Name | Description
Graphics | Gets an IGraphics object whose methods should be used to draw the link.
Link | Gets the DiagramLink object that should be custom drawn.
Points | Gets a collection of the link's control points.
Shadow | Gets a value indicating whether the event is raised to draw the link's shadow.

See Also

DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs Constructor

DrawLinkEventArgs Constructor
[image]

Initializes a new instance of the DrawLinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawLinkEventArgs (
IGraphics graphics,
DiagramLink link,
bool shadow,
PointCollection points
)

Visual Basic [image] Copy Code

Public New ( _
graphics As IGraphics, _
link As DiagramLink, _
shadow As Boolean, _
points As PointCollection _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

link

The DiagramLink related to the event.

shadow

Specifies whether to draw the link's shadow or the link itself.

points

The collection containing the coordinates of the link control points, pretranslated depending on whether drawing the shadow or not.

See Also

DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs Properties

DrawLinkEventArgs Properties
[image]

Public Properties

Name | Description
Graphics | Gets an IGraphics object whose methods should be used to draw the link.
Link | Gets the DiagramLink object that should be custom drawn.
Points | Gets a collection of the link's control points.
Shadow | Gets a value indicating whether the event is raised to draw the link's shadow.

See Also

DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs.Graphics Property

DrawLinkEventArgs.Graphics Property
[image]

Gets an IGraphics object whose methods should be used to draw the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs.Link Property

DrawLinkEventArgs.Link Property
[image]

Gets the DiagramLink object that should be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs.Points Property

DrawLinkEventArgs.Points Property
[image]

Gets a collection of the link's control points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection Points { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Points As PointCollection

Property Value

An instance of the PointCollection class.

Remarks

When drawing shadows, the points are offset as necessary.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class


MindFusion.Diagramming.DrawLinkEventArgs.Shadow Property

DrawLinkEventArgs.Shadow Property
[image]

Gets a value indicating whether the event is raised to draw the link's shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Shadow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shadow As Boolean

Property Value

true if now drawing the link's shadow; otherwise, false.

See Also

DrawLinkEventArgs Members
DrawLinkEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs Class

DrawNodeEventArgs Class
[image]

Contains the arguments passed to the DrawNode event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawNodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class DrawNodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.DrawNodeEventArgs

See Also

DrawNodeEventArgs Members


MindFusion.Diagramming.DrawNodeEventArgs Members

DrawNodeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the DrawNode event handlers.

The following tables list the members exposed by the DrawNodeEventArgs type.

Public Constructors

Name | Description
DrawNodeEventArgs | Initializes a new instance of the DrawNodeEventArgs class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the node being drawn.
Graphics | Gets an IGraphics object whose methods should be used to draw the node.
Node | Gets the DiagramNode object that should be custom drawn.
Shadow | Gets a value indicating whether the event is raised to draw the node's shadow.

See Also

DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs Constructor

DrawNodeEventArgs Constructor
[image]

Initializes a new instance of the DrawNodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawNodeEventArgs (
IGraphics graphics,
DiagramNode node,
bool shadow,
Rect bounds
)

Visual Basic [image] Copy Code

Public New ( _
graphics As IGraphics, _
node As DiagramNode, _
shadow As Boolean, _
bounds As Rect _
)

Parameters

graphics

The IGraphics object that represents the target of the drawing operation.

node

The DiagramNode related to the event.

shadow

Specifies whether to draw the node's shadow or the node itself.

bounds

The bounding rectangle of the node being drawn.

See Also

DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs Properties

DrawNodeEventArgs Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of the node being drawn.
Graphics | Gets an IGraphics object whose methods should be used to draw the node.
Node | Gets the DiagramNode object that should be custom drawn.
Shadow | Gets a value indicating whether the event is raised to draw the node's shadow.

See Also

DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs.Bounds Property

DrawNodeEventArgs.Bounds Property
[image]

Gets the bounding rectangle of the node being drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

A Rectangle instance specifying the bounding rectangle of the node being drawn.

Remarks

When drawing shadows, the rectangle is offset as necessary.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs.Graphics Property

DrawNodeEventArgs.Graphics Property
[image]

Gets an IGraphics object whose methods should be used to draw the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphics Graphics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Graphics As IGraphics

Property Value

An instance of a class implementing the IGraphics interface.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs.Node Property

DrawNodeEventArgs.Node Property
[image]

Gets the DiagramNode object that should be custom drawn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class


MindFusion.Diagramming.DrawNodeEventArgs.Shadow Property

DrawNodeEventArgs.Shadow Property
[image]

Gets a value indicating whether the event is raised to draw the node's shadow.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Shadow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Shadow As Boolean

Property Value

true if now drawing the node's shadow; otherwise, false.

See Also

DrawNodeEventArgs Members
DrawNodeEventArgs Class


MindFusion.Diagramming.DummyNode Class

DummyNode Class
[image]

Represents virtual nodes used for disconnected links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DummyNode : DiagramNode

Visual Basic [image] Copy Code

Public Class DummyNode
Inherits DiagramNode

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.DummyNode

See Also

DummyNode Members


MindFusion.Diagramming.DummyNode Members

DummyNode Members
Constructors Fields Properties Methods
[image]

Represents virtual nodes used for disconnected links.

The following tables list the members exposed by the DummyNode type.

Public Constructors

Name | Description
DummyNode | Initializes a new instance of the DummyNode class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | DiagramItem.ContainsPoint override.
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramItem.Draw override.
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override.
DrawLocal | Override in a derived class to provide implementation specific drawing for the node. (Inherited from DiagramNode.)
DrawShadow | DiagramItem.DrawShadow override.
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetIntersection | DiagramNode.GetIntersection override.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the smallest distance from the specified point.
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToJson | Saves the item content into a JsonObject. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

DummyNode Class


MindFusion.Diagramming.DummyNode Constructor

DummyNode Constructor
[image]

Initializes a new instance of the DummyNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DummyNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram this node will be associated with.

See Also

DummyNode Class


MindFusion.Diagramming.DummyNode Methods

DummyNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | DiagramItem.ContainsPoint override.
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramItem.Draw override.
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override.
DrawLocal | Override in a derived class to provide implementation specific drawing for the node. (Inherited from DiagramNode.)
DrawShadow | DiagramItem.DrawShadow override.
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetIntersection | DiagramNode.GetIntersection override.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the smallest distance from the specified point.
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToJson | Saves the item content into a JsonObject. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

DummyNode Class


MindFusion.Diagramming.DummyNode.ContainsPoint Method

DummyNode.ContainsPoint Method
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

The point to check.

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.CreateConnectionPoint Method

DummyNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Public Overrides Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link

pt

incoming

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.Draw Method

DummyNode.Draw Method
[image]

DiagramItem.Draw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the item to.

options

A RenderOptions object specifying options for the drawing operation.

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.DrawHandles Method

DummyNode.DrawHandles Method
[image]

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As IGraphics, _
style As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

style

options

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.DrawShadow Method

DummyNode.DrawShadow Method
[image]

DiagramItem.DrawShadow override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadow( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the shadow to.

options

A RenderOptions object specifying options for the drawing operation.

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.GetIntersection Method

DummyNode.GetIntersection Method
[image]

DiagramNode.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart

segmentEnd

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.GetNearestBorderPoint Method

DummyNode.GetNearestBorderPoint Method
[image]

Returns a point that lies on the outline of this node, at the smallest distance from the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function GetNearestBorderPoint( _
point As Point _
) As Point

Parameters

point

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.DummyNode.HitTestHandle Method

DummyNode.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point,
double radius
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point, _
radius As Double _
) As AdjustmentHandle

Parameters

point

radius

Return Value

See Also

DummyNode Members
DummyNode Class


MindFusion.Diagramming.EditCellTextEventArgs Class

EditCellTextEventArgs Class
[image]

Contains the arguments passed to the CellTextEdited event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class EditCellTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditCellTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditCellTextEventArgs

See Also

EditCellTextEventArgs Members


MindFusion.Diagramming.EditCellTextEventArgs Members

EditCellTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the CellTextEdited event handlers.

The following tables list the members exposed by the EditCellTextEventArgs type.

Public Constructors

Name | Description
EditCellTextEventArgs | Initializes a new instance of the EditCellTextEventArgs class.

Public Properties

Name | Description
Cell | Get the cell whose text has been edited.
Column | Gets the index of the table's column that contains Cell.
NewText | Gets the text that has just been entered by the user.
OldText | Gets the text that had been displayed in the cell before the user edited it.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs Constructor

EditCellTextEventArgs Constructor
[image]

Initializes a new instance of the EditCellTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EditCellTextEventArgs (
TableNode.Cell cell,
string oldText,
string newText,
int column,
int row
)

Visual Basic [image] Copy Code

Public New ( _
cell As TableNode.Cell, _
oldText As String, _
newText As String, _
column As Integer, _
row As Integer _
)

Parameters

cell

The TableNode.Cell related to the event.

oldText

The old text of the cell.

newText

The new text of the cell.

column

The zero-based index of the table column related to the event.

row

The zero-based index of the table row related to the event.

See Also

EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs Properties

EditCellTextEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Get the cell whose text has been edited.
Column | Gets the index of the table's column that contains Cell.
NewText | Gets the text that has just been entered by the user.
OldText | Gets the text that had been displayed in the cell before the user edited it.
Row | Gets the index of the table's row that contains Cell.
Table | Get the table that contains Cell.

See Also

EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.Cell Property

EditCellTextEventArgs.Cell Property
[image]

Get the cell whose text has been edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As TableNode.Cell

Property Value

An instance of the TableNode.Cell class.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.Column Property

EditCellTextEventArgs.Column Property
[image]

Gets the index of the table's column that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Column { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Column As Integer

Property Value

An integer value specifying the zero-based index of the column.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.NewText Property

EditCellTextEventArgs.NewText Property
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

A string specifying the new text of the cell.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.OldText Property

EditCellTextEventArgs.OldText Property
[image]

Gets the text that had been displayed in the cell before the user edited it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

A string specifying the old text of the cell.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.Row Property

EditCellTextEventArgs.Row Property
[image]

Gets the index of the table's row that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Row { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Row As Integer

Property Value

An integer value specifying the zero-based index of the row.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditCellTextEventArgs.Table Property

EditCellTextEventArgs.Table Property
[image]

Get the table that contains Cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

EditCellTextEventArgs Members
EditCellTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs Class

EditLinkTextEventArgs Class
[image]

Contains the arguments passed to the LinkTextEdited event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class EditLinkTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditLinkTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditLinkTextEventArgs

See Also

EditLinkTextEventArgs Members


MindFusion.Diagramming.EditLinkTextEventArgs Members

EditLinkTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the LinkTextEdited event handlers.

The following tables list the members exposed by the EditLinkTextEventArgs type.

Public Constructors

Name | Description
EditLinkTextEventArgs | Initializes a new instance of the EditLinkTextEventArgs class.

Public Properties

Name | Description
Label | Gets or sets a LinkLabel related to this event.
Link | Gets the link whose text was edited.
NewText | Gets the new text.
OldText | Gets the text before in-place editing.

See Also

EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs Constructor

EditLinkTextEventArgs Constructor
[image]

Initializes a new instance of the EditLinkTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EditLinkTextEventArgs (
DiagramLink link,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
oldText As String, _
newText As String _
)

Parameters

link

The link whose text is edited.

oldText

The old value of the link's Text.

newText

The new value of the link's Text.

See Also

EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs Properties

EditLinkTextEventArgs Properties
[image]

Public Properties

Name | Description
Label | Gets or sets a LinkLabel related to this event.
Link | Gets the link whose text was edited.
NewText | Gets the new text.
OldText | Gets the text before in-place editing.

See Also

EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs.Label Property

EditLinkTextEventArgs.Label Property
[image]

Gets or sets a LinkLabel related to this event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As LinkLabel

Property Value

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs.Link Property

EditLinkTextEventArgs.Link Property
[image]

Gets the link whose text was edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

An instance of the DiagramLink class.

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs.NewText Property

EditLinkTextEventArgs.NewText Property
[image]

Gets the new text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

The new value of the link's Text property.

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class


MindFusion.Diagramming.EditLinkTextEventArgs.OldText Property

EditLinkTextEventArgs.OldText Property
[image]

Gets the text before in-place editing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

The original value of the Text property of the edited link.

See Also

EditLinkTextEventArgs Members
EditLinkTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs Class

EditNodeTextEventArgs Class
[image]

Contains the arguments passed to the NodeTextEdited event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class EditNodeTextEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class EditNodeTextEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.EditNodeTextEventArgs

See Also

EditNodeTextEventArgs Members


MindFusion.Diagramming.EditNodeTextEventArgs Members

EditNodeTextEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the NodeTextEdited event handlers.

The following tables list the members exposed by the EditNodeTextEventArgs type.

Public Constructors

Name | Description
EditNodeTextEventArgs | Initializes a new instance of the EditNodeTextEventArgs class.

Public Properties

Name | Description
Label | Gets or sets a NodeLabel related to this event.
NewText | Gets the text that has just been entered by the user.
Node | Gets the node whose text has been edited.
OldText | Gets the text that had been displayed in the node before the user edited it.

See Also

EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs Constructor

EditNodeTextEventArgs Constructor
[image]

Initializes a new instance of the EditNodeTextEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EditNodeTextEventArgs (
DiagramNode node,
string oldText,
string newText
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
oldText As String, _
newText As String _
)

Parameters

node

The DiagramNode related to the event.

oldText

The old text of the node.

newText

The new text of the node.

See Also

EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs Properties

EditNodeTextEventArgs Properties
[image]

Public Properties

Name | Description
Label | Gets or sets a NodeLabel related to this event.
NewText | Gets the text that has just been entered by the user.
Node | Gets the node whose text has been edited.
OldText | Gets the text that had been displayed in the node before the user edited it.

See Also

EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs.Label Property

EditNodeTextEventArgs.Label Property
[image]

Gets or sets a NodeLabel related to this event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeLabel Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As NodeLabel

Property Value

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs.NewText Property

EditNodeTextEventArgs.NewText Property
[image]

Gets the text that has just been entered by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string NewText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewText As String

Property Value

A string specifying the new text of the node.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs.Node Property

EditNodeTextEventArgs.Node Property
[image]

Gets the node whose text has been edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class


MindFusion.Diagramming.EditNodeTextEventArgs.OldText Property

EditNodeTextEventArgs.OldText Property
[image]

Gets the text that had been displayed in the node before the user edited it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string OldText { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldText As String

Property Value

A string specifying the old text of the node.

See Also

EditNodeTextEventArgs Members
EditNodeTextEventArgs Class


MindFusion.Diagramming.ElementTemplate Class

ElementTemplate Class
[image]

Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class ElementTemplate

Visual Basic [image] Copy Code

Public MustInherit Class ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.ArcTemplate
MindFusion.Diagramming.BezierTemplate
MindFusion.Diagramming.LineTemplate
MindFusion.Diagramming.RoundRectangleTemplate

See Also

ElementTemplate Members


MindFusion.Diagramming.ElementTemplate Members

ElementTemplate Members
Constructors Properties Methods
[image]

Represents an element of a shape definition. This is the parent class of specific element types, such as ArcTemplate, LineTemplate and BezierTemplate.

The following tables list the members exposed by the ElementTemplate type.

Protected Constructors

Name | Description
ElementTemplate | Initializes a new instance of the ElementTemplate class.

Public Properties

Name | Description
Color | Gets or sets the outline color of this element.
DashStyle | Gets or sets the dash style of the outline of this element.
Width | Gets or sets the outline width of this element.

Public Methods

Name | Description
Clone | Creates an exact copy of this element.
SameAs | Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate Constructor

ElementTemplate Constructor
[image]

Initializes a new instance of the ElementTemplate class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected ElementTemplate ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate Methods

ElementTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this element.
SameAs | Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.Clone Method

ElementTemplate.Clone Method
[image]

Creates an exact copy of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract ElementTemplate Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As ElementTemplate

Return Value

An instance of the appropriate type that represents the element clone.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.GetElementPen Method

ElementTemplate.GetElementPen Method
[image]

Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Pen GetElementPen (
Pen pen
)

Visual Basic [image] Copy Code

Protected Function GetElementPen( _
pen As Pen _
) As Pen

Parameters

pen

The Pen object specifying the base pen.

Return Value

An instance of the Pen class.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.SameAs Method

ElementTemplate.SameAs Method
[image]

Checks whether the current element and the specified element resemble each other closely enough to be considered identical.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public MustOverride Function SameAs( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this element.

Return Value

true if the specified object closely approximates this element; otherwise, false.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate Properties

ElementTemplate Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the outline color of this element.
DashStyle | Gets or sets the dash style of the outline of this element.
Width | Gets or sets the outline width of this element.

See Also

ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.Color Property

ElementTemplate.Color Property
[image]

Gets or sets the outline color of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A Color instance specifying the color of the outline.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.DashStyle Property

ElementTemplate.DashStyle Property
[image]

Gets or sets the dash style of the outline of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DashStyle DashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DashStyle As DashStyle

Property Value

A member of the DashStyle enumeration specifying the style of the outline.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ElementTemplate.Width Property

ElementTemplate.Width Property
[image]

Gets or sets the outline width of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value specifying the width of the outline.

See Also

ElementTemplate Members
ElementTemplate Class


MindFusion.Diagramming.ExpandButtonAction Enumeration

ExpandButtonAction Enumeration
[image]

Specifies what action is triggered by the +/- buttons that are displayed near expandable nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ExpandButtonAction

Visual Basic [image] Copy Code

Public Enum ExpandButtonAction

Members

Member name | Description
ExpandTreeBranch | Expands or collapses the children of a node in a tree-like diagram and raises the TreeExpanded or TreeCollapsed event.
RaiseEvents | Raises the ExpandButtonClicked event.

Remarks

The members of this enumeration can be assigned to the ExpandButtonAction property of the Diagram class.

See Also


MindFusion.Diagramming.ExpandButtonPosition Enumeration

ExpandButtonPosition Enumeration
[image]

Defines values that specify possible locations for expand/collapse buttons.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ExpandButtonPosition

Visual Basic [image] Copy Code

Public Enum ExpandButtonPosition

Members

Member name | Description
OuterBottom | Place expand/collapse buttons at the bottom side of their nodes.
OuterLeft | Place expand/collapse buttons at the left-hand side of their nodes.
OuterLowerLeft | Place expand/collapse buttons at the lower-left corner of their nodes.
OuterLowerRight | Place expand/collapse buttons at the lower-right corner of their nodes.
OuterRight | Place expand/collapse buttons at the right-hand side of their nodes.
OuterTop | Place expand/collapse buttons at the top side of their nodes.
OuterUpperLeft | Place expand/collapse buttons at the upper-left corner of their nodes.
OuterUpperRight | Place expand/collapse buttons at the upper-right corner of their nodes.

Remarks

Assign values from this enumeration to the ExpandButtonPosition property of the Diagram class.

See Also


MindFusion.Diagramming.Factory Class

Factory Class
[image]

Provides shortcut methods for creating and adding instances of the standard MindFusion.Diagramming for .NET MAUI item types. Call the class methods through the Factory property of the Diagram class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Factory

Visual Basic [image] Copy Code

Public Class Factory

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Factory

See Also

Factory Members


MindFusion.Diagramming.Factory Members

Factory Members
Constructors Methods
[image]

Provides shortcut methods for creating and adding instances of the standard MindFusion.Diagramming for .NET MAUI item types. Call the class methods through the Factory property of the Diagram class.

The following tables list the members exposed by the Factory type.

Public Constructors

Name | Description
Factory | Initializes a new instance of the Factory class over the specified Diagram.

Public Methods

Name | Description
CreateContainerNode | Overloaded. Creates a new ContainerNode instance.
CreateDiagramLink | Overloaded. Creates a new DiagramLink instance.
CreateShapeNode | Overloaded. Creates a new ShapeNode instance.
CreateTableNode | Overloaded. Creates a new TableNode instance.
CreateTreeViewNode | Overloaded. Creates a new TreeViewNode instance.

See Also

Factory Class


MindFusion.Diagramming.Factory Constructor

Factory Constructor
[image]

Initializes a new instance of the Factory class over the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Factory (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram object for which to create the new factory.

See Also

Factory Class


MindFusion.Diagramming.Factory Methods

Factory Methods
[image]

Public Methods

Name | Description
CreateContainerNode | Overloaded. Creates a new ContainerNode instance.
CreateDiagramLink | Overloaded. Creates a new DiagramLink instance.
CreateShapeNode | Overloaded. Creates a new ShapeNode instance.
CreateTableNode | Overloaded. Creates a new TableNode instance.
CreateTreeViewNode | Overloaded. Creates a new TreeViewNode instance.

See Also

Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method

Factory.CreateContainerNode Method
[image]

Creates a new ContainerNode instance.

Overload List

Name | Description
Factory.CreateContainerNode (Double, Double, Double, Double) | Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Double, Double, Double, Double, Boolean) | Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Point, Size) | Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Point, Size, Boolean) | Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Rect) | Creates a new ContainerNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateContainerNode (Rect, Boolean) | Creates a new ContainerNode instance with the specified dimensions, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (Double, Double, Double, Double)

Factory.CreateContainerNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As ContainerNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by x and y. The size of the container is set by width and height.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (Double, Double, Double, Double, Boolean)

Factory.CreateContainerNode Method (Double, Double, Double, Double, Boolean)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
double x,
double y,
double width,
double height,
bool foldable
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
foldable As Boolean _
) As ContainerNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

foldable

true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by x and y. The size of the container is set by width and height. The parameter foldable specifies whether the container node is initially foldable.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (Point, Size)

Factory.CreateContainerNode Method (Point, Size)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
location As Point, _
size As Size _
) As ContainerNode

Parameters

location

The location of the ContainerNode object.

size

The size of the ContainerNode object.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by location. The size of the container is set by size.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (Point, Size, Boolean)

Factory.CreateContainerNode Method (Point, Size, Boolean)
See Also
[image]

Creates a new ContainerNode instance at the specified location with the specified size, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
Point location,
Size size,
bool foldable
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
location As Point, _
size As Size, _
foldable As Boolean _
) As ContainerNode

Parameters

location

The location of the ContainerNode object.

size

The newly created ContainerNode instance.

foldable

true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node at the position specified by location. The size of the container is set by size. The parameter foldable specifies whether the container node is initially foldable.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (Rect)

Factory.CreateContainerNode Method (Rect)
See Also
[image]

Creates a new ContainerNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
bounds As Rect _
) As ContainerNode

Parameters

bounds

The initial bounding rectangle of the new node.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node with the position and size specified by bounds.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateContainerNode Method (Rect, Boolean)

Factory.CreateContainerNode Method (Rect, Boolean)
See Also
[image]

Creates a new ContainerNode instance with the specified dimensions, optionally foldable, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode CreateContainerNode (
Rect bounds,
bool foldable
)

Visual Basic [image] Copy Code

Public Function CreateContainerNode( _
bounds As Rect, _
foldable As Boolean _
) As ContainerNode

Parameters

bounds

The initial bounding rectangle of the new node.

foldable

true if the container can be folded; otherwise, false.

Return Value

The newly created ContainerNode instance.

Remarks

The method creates a container node with the position and size specified by bounds. The parameter foldable specifies whether the container node is initially foldable.

See Also

CreateContainerNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method

Factory.CreateDiagramLink Method
[image]

Creates a new DiagramLink instance.

Overload List

Name | Description
Factory.CreateDiagramLink (DiagramNode, DiagramNode) | Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (DiagramNode, Point) | Creates a new DiagramLink instance between the specified node and the specified point, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (DiagramNode, TableNode, Int32) | Creates a new DiagramLink instance between the specified nodes and the specified table, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (Point, DiagramNode) | Creates a new DiagramLink instance between the specified point and the specified node, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (Point, Point) | Creates a new DiagramLink instance between the specified points and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (ShapeNode, Int32, ShapeNode, Int32) | Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, Int32, DiagramNode) | Creates a new DiagramLink instance between the specified table and the specified node, and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, Int32, TableNode, Int32) | Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TableNode, TableNode) | Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.
Factory.CreateDiagramLink (TreeViewNode, TreeViewItem, TreeViewNode, TreeViewItem) | Creates a new DiagramLink instance between the specified tree items and adds it to the Links collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, DiagramNode)

Factory.CreateDiagramLink Method (DiagramNode, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As DiagramNode, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the nodes specified by origin and destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, Point)

Factory.CreateDiagramLink Method (DiagramNode, Point)
See Also
[image]

Creates a new DiagramLink instance between the specified node and the specified point, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
Point destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As DiagramNode, _
destination As Point _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination point.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the node specified by origin and the point specified by destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (DiagramNode, TableNode, Int32)

Factory.CreateDiagramLink Method (DiagramNode, TableNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and the specified table, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
DiagramNode origin,
TableNode destination,
int destRow
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As DiagramNode, _
destination As TableNode, _
destRow As Integer _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination node.

destRow

The zero-based index of the destination table row of the new link.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the node specified by origin and the table specified by destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (Point, DiagramNode)

Factory.CreateDiagramLink Method (Point, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified point and the specified node, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
Point origin,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As Point, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin

The origin point.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the point specified by origin and the node specified by destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (Point, Point)

Factory.CreateDiagramLink Method (Point, Point)
See Also
[image]

Creates a new DiagramLink instance between the specified points and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
Point origin,
Point destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As Point, _
destination As Point _
) As DiagramLink

Parameters

origin

The origin point.

destination

The destination point.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the points specified by origin and destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (ShapeNode, Int32, ShapeNode, Int32)

Factory.CreateDiagramLink Method (ShapeNode, Int32, ShapeNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified nodes and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
ShapeNode origin,
int originAnchor,
ShapeNode destination,
int destAnchor
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As ShapeNode, _
originAnchor As Integer, _
destination As ShapeNode, _
destAnchor As Integer _
) As DiagramLink

Parameters

origin

The origin node.

originAnchor

The index of an anchor point within the origin node's AnchorPattern.

destination

The destination node.

destAnchor

The index of an anchor point within the destination node's AnchorPattern.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the shape nodes specified by origin and destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, Int32, DiagramNode)

Factory.CreateDiagramLink Method (TableNode, Int32, DiagramNode)
See Also
[image]

Creates a new DiagramLink instance between the specified table and the specified node, and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
int originRow,
DiagramNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As TableNode, _
originRow As Integer, _
destination As DiagramNode _
) As DiagramLink

Parameters

origin

The origin node.

originRow

The zero-based index of the destination table row of the new link.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the table specified by origin and the node specified by destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, Int32, TableNode, Int32)

Factory.CreateDiagramLink Method (TableNode, Int32, TableNode, Int32)
See Also
[image]

Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
int originRow,
TableNode destination,
int destRow
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As TableNode, _
originRow As Integer, _
destination As TableNode, _
destRow As Integer _
) As DiagramLink

Parameters

origin

The origin node.

originRow

The zero-based index of the origin table row of the new link.

destination

The destination node.

destRow

The zero-based index of the destination table row of the new link.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the tables specified by origin and destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TableNode, TableNode)

Factory.CreateDiagramLink Method (TableNode, TableNode)
See Also
[image]

Creates a new DiagramLink instance between the specified tables and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TableNode origin,
TableNode destination
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As TableNode, _
destination As TableNode _
) As DiagramLink

Parameters

origin

The origin node.

destination

The destination node.

Return Value

The newly created DiagramLink instance.

Remarks

The method creates a link connecting the tables specified by origin and destination.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateDiagramLink Method (TreeViewNode, TreeViewItem, TreeViewNode, TreeViewItem)

Factory.CreateDiagramLink Method (TreeViewNode, TreeViewItem, TreeViewNode, TreeViewItem)
See Also
[image]

Creates a new DiagramLink instance between the specified tree items and adds it to the Links collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink CreateDiagramLink (
TreeViewNode origin,
TreeViewItem originItem,
TreeViewNode destination,
TreeViewItem destinationItem
)

Visual Basic [image] Copy Code

Public Function CreateDiagramLink( _
origin As TreeViewNode, _
originItem As TreeViewItem, _
destination As TreeViewNode, _
destinationItem As TreeViewItem _
) As DiagramLink

Parameters

origin

The origin node.

originItem

The origin item.

destination

The destination node.

destinationItem

The destination item.

Return Value

The newly created DiagramLink instance.

See Also

CreateDiagramLink Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method

Factory.CreateShapeNode Method
[image]

Creates a new ShapeNode instance.

Overload List

Name | Description
Factory.CreateShapeNode (Double, Double, Double, Double) | Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Double, Double, Double, Double, Shape) | Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Point, Size) | Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Point, Size, Shape) | Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Rect) | Creates a new ShapeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateShapeNode (Rect, Shape) | Creates a new ShapeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Double, Double, Double, Double)

Factory.CreateShapeNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As ShapeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Double, Double, Double, Double, Shape)

Factory.CreateShapeNode Method (Double, Double, Double, Double, Shape)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
double x,
double y,
double width,
double height,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
shape As Shape _
) As ShapeNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by x and y. The size of the node is set by width and height. The shape of the new node is specified by shape.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Point, Size)

Factory.CreateShapeNode Method (Point, Size)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
location As Point, _
size As Size _
) As ShapeNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Point, Size, Shape)

Factory.CreateShapeNode Method (Point, Size, Shape)
See Also
[image]

Creates a new ShapeNode instance at the specified position with the specified size and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Point location,
Size size,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
location As Point, _
size As Size, _
shape As Shape _
) As ShapeNode

Parameters

location

The position of the new node.

size

The size of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node at the position specified by location. The size of the node is set by size. The shape of the new node is specified by shape.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Rect)

Factory.CreateShapeNode Method (Rect)
See Also
[image]

Creates a new ShapeNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
bounds As Rect _
) As ShapeNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateShapeNode Method (Rect, Shape)

Factory.CreateShapeNode Method (Rect, Shape)
See Also
[image]

Creates a new ShapeNode instance with the specified dimensions and shape, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode CreateShapeNode (
Rect bounds,
Shape shape
)

Visual Basic [image] Copy Code

Public Function CreateShapeNode( _
bounds As Rect, _
shape As Shape _
) As ShapeNode

Parameters

bounds

The bounding rectangle of the new node.

shape

The shape of the new node.

Return Value

The newly created ShapeNode instance.

Remarks

The method creates a shape node with dimensions specified by bounds. The shape of the new node is specified by shape.

See Also

CreateShapeNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method

Factory.CreateTableNode Method
[image]

Creates a new TableNode instance.

Overload List

Name | Description
Factory.CreateTableNode (Double, Double, Double, Double) | Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Double, Double, Double, Double, Int32, Int32) | Creates a new TableNode instance at the specified position with the specified size and the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Point, Size) | Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Point, Size, Int32, Int32) | Creates a new TableNode instance at the specified position with the specified size and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Rect) | Creates a new TableNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTableNode (Rect, Int32, Int32) | Creates a new TableNode instance with the specified dimensions and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Double, Double, Double, Double)

Factory.CreateTableNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As TableNode

Parameters

x

The x-coordinate of the upper-left corner of the new table.

y

The y-coordinate of the upper-left corner of the new table.

width

The width of the new table.

height

The height of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Double, Double, Double, Double, Int32, Int32)

Factory.CreateTableNode Method (Double, Double, Double, Double, Int32, Int32)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
double x,
double y,
double width,
double height,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

x

The x-coordinate of the upper-left corner of the new table.

y

The y-coordinate of the upper-left corner of the new table.

width

The width if the new table.

height

The height of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by x and y. The size of the node is set by width and height. The initial number of columns and rows in the table is specified by columns and rows respectively.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Point, Size)

Factory.CreateTableNode Method (Point, Size)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
location As Point, _
size As Size _
) As TableNode

Parameters

location

The position of the new table.

size

The size of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node at the position specified by location. The size of the node is set by size.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Point, Size, Int32, Int32)

Factory.CreateTableNode Method (Point, Size, Int32, Int32)
See Also
[image]

Creates a new TableNode instance at the specified position with the specified size and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Point location,
Size size,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
location As Point, _
size As Size, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

location

The position of the new table.

size

The size of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Rect)

Factory.CreateTableNode Method (Rect)
See Also
[image]

Creates a new TableNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
bounds As Rect _
) As TableNode

Parameters

bounds

The bounding rectangle of the new table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node with dimensions specified by bounds.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTableNode Method (Rect, Int32, Int32)

Factory.CreateTableNode Method (Rect, Int32, Int32)
See Also
[image]

Creates a new TableNode instance with the specified dimensions and with the specified number of columns and rows, and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode CreateTableNode (
Rect bounds,
int columns,
int rows
)

Visual Basic [image] Copy Code

Public Function CreateTableNode( _
bounds As Rect, _
columns As Integer, _
rows As Integer _
) As TableNode

Parameters

bounds

The bounding rectangle of the new table.

columns

The initial number of columns in the table.

rows

The initial number of rows in the table.

Return Value

The newly created TableNode instance.

Remarks

The method creates a table node with dimensions specified by bounds. The initial number of columns and rows in the table is specified by columns and rows respectively.

See Also

CreateTableNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method

Factory.CreateTreeViewNode Method
[image]

Creates a new TreeViewNode instance.

Overload List

Name | Description
Factory.CreateTreeViewNode (Double, Double, Double, Double) | Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTreeViewNode (Point, Size) | Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.
Factory.CreateTreeViewNode (Rect) | Creates a new TreeViewNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

See Also

Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method (Double, Double, Double, Double)

Factory.CreateTreeViewNode Method (Double, Double, Double, Double)
See Also
[image]

Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
) As TreeViewNode

Parameters

x

The x-coordinate of the upper-left corner of the new node.

y

The y-coordinate of the upper-left corner of the new node.

width

The width of the new node.

height

The height of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node at the position specified by x and y. The size of the node is set by width and height.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method (Point, Size)

Factory.CreateTreeViewNode Method (Point, Size)
See Also
[image]

Creates a new TreeViewNode instance at the specified position with the specified size and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
Point location,
Size size
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode( _
location As Point, _
size As Size _
) As TreeViewNode

Parameters

location

The position of the new node.

size

The size of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node at the position specified by location. The size of the node is set by size.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.Factory.CreateTreeViewNode Method (Rect)

Factory.CreateTreeViewNode Method (Rect)
See Also
[image]

Creates a new TreeViewNode instance with the specified dimensions and adds it to the Nodes collection of the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode CreateTreeViewNode (
Rect bounds
)

Visual Basic [image] Copy Code

Public Function CreateTreeViewNode( _
bounds As Rect _
) As TreeViewNode

Parameters

bounds

The bounding rectangle of the new node.

Return Value

The newly created TreeViewNode instance.

Remarks

The method creates a treeview node with dimensions specified by bounds.

See Also

CreateTreeViewNode Method Overload List
Factory Members
Factory Class


MindFusion.Diagramming.FitSize Enumeration

FitSize Enumeration
[image]

Specifies how the ResizeToFitText method should resize a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum FitSize

Visual Basic [image] Copy Code

Public Enum FitSize

Members

Member name | Description
KeepHeight | Specifies that the original node height should remain intact.
KeepRatio | Allows changing both the width and height of a node, but keep the original width/height ratio if possible.
KeepWidth | Specifies that the original node width should remain intact.

See Also


MindFusion.Diagramming.FreeFormHandle Class

FreeFormHandle Class
[image]

Represents an adjustment handle used to modify the outline of a FreeFormNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FreeFormHandle : NodeAdjustmentHandle

Visual Basic [image] Copy Code

Public Class FreeFormHandle
Inherits NodeAdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AdjustmentHandle
MindFusion.Diagramming.NodeAdjustmentHandle
MindFusion.Diagramming.FreeFormHandle

See Also

FreeFormHandle Members


MindFusion.Diagramming.FreeFormHandle Members

FreeFormHandle Members
Constructors Properties
[image]

Represents an adjustment handle used to modify the outline of a FreeFormNode.

The following tables list the members exposed by the FreeFormHandle type.

Public Constructors

Name | Description
FreeFormHandle |

Public Properties

Name | Description
Handles |
HandleType | Gets or sets the type of this adjustment handle. (Inherited from NodeAdjustmentHandle.)
PointIndex | Gets or sets the index of a point from FreeFormNode.Points collection that is being modified through this handle.

See Also

FreeFormHandle Class


MindFusion.Diagramming.FreeFormHandle Constructor

FreeFormHandle Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FreeFormHandle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FreeFormHandle Class


MindFusion.Diagramming.FreeFormHandle Properties

FreeFormHandle Properties
[image]

Public Properties

Name | Description
Handles |
HandleType | Gets or sets the type of this adjustment handle. (Inherited from NodeAdjustmentHandle.)
PointIndex | Gets or sets the index of a point from FreeFormNode.Points collection that is being modified through this handle.

See Also

FreeFormHandle Class


MindFusion.Diagramming.FreeFormHandle.Handles Property

FreeFormHandle.Handles Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandles Handles { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Handles As AdjustmentHandles

Property Value

See Also

FreeFormHandle Members
FreeFormHandle Class


MindFusion.Diagramming.FreeFormHandle.PointIndex Property

FreeFormHandle.PointIndex Property
[image]

Gets or sets the index of a point from FreeFormNode.Points collection that is being modified through this handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int PointIndex { get; set; }

Visual Basic [image] Copy Code

Public Property PointIndex As Integer

Property Value

See Also

FreeFormHandle Members
FreeFormHandle Class


MindFusion.Diagramming.FreeFormNode Class

FreeFormNode Class
Remarks See Also
[image]

A FreeFormNode collects all points from users' mouse or touch input and displays them as node's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FreeFormNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class FreeFormNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

To let users draw free-form nodes interactively, set Behavior to DrawFreeForms or LinkFreeForms. Use the Points property of FreeFormNode to get or set outline points programmatically.

If the Closed property is set, the node is drawn as a closed shape and its interior filled, or otherwise the node is drawn as a polyline. If the distance between first and last points drawn by user is shorter than AutoCloseDistance, the node's Closed property is automatically set to true. Initial AutoCloseDistance value is null, which always closes free-form nodes by default.

If Behavior is set to DrawFreeShapes or LinkFreeShapes, input is still collected as points and rendered using FreeFormNode during user interaction, but once user finishes drawing, the diagram creates a ShapeNode with closest matching shape. Set the FreeFormTargets property to specify which shapes are considered as free-form replacements.

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.FreeFormNode

See Also

FreeFormNode Members


MindFusion.Diagramming.FreeFormNode Members

FreeFormNode Members
Constructors Fields Properties Methods
[image]

A FreeFormNode collects all points from users' mouse or touch input and displays them as node's outline.

The following tables list the members exposed by the FreeFormNode type.

Public Constructors

Name | Description
FreeFormNode | Overloaded.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Closed | Gets or sets if the node's shape is closed.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
ConvertToShape | Gets or sets whether the FreeFormNode currently being drawn should be replaced by a matching ShapeNode.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Points | Gets or sets the node's outline points.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside the free form node.
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | Draws the node using the specified IGraphics object.
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramNode.DrawHandles override.
DrawLocal | Override in a derived class to provide implementation specific drawing for the node. (Inherited from DiagramNode.)
DrawShadow | Draws the shadow of this node on the specified IGraphics surface.
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramNode.GetOutlinePoly override.
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramNode.HitTestHandle override.
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
StandardShapeReplacement | Returns a replacement ShapeNode that most closely matches this node's position and outline shape.
UpdateFromPoints | Updates the node's internal state after its points have changed.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramNode.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramNode.RestoreState override.
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramNode.SaveState override.
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

FreeFormNode Class


MindFusion.Diagramming.FreeFormNode Constructor

FreeFormNode Constructor
[image]

Overload List

Name | Description
FreeFormNode () | Initializes a new instance of the FreeFormNode class.
FreeFormNode (Diagram) | Initializes a new instance of the FreeFormNode class.
FreeFormNode (FreeFormNode) | Initializes a new instance of the FreeFormNode class using the specified node as a prototype.

See Also

FreeFormNode Class


MindFusion.Diagramming.FreeFormNode Constructor ()

FreeFormNode Constructor ()
See Also
[image]

Initializes a new instance of the FreeFormNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FreeFormNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FreeFormNode Constructor Overload List
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode Constructor (Diagram)

FreeFormNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the FreeFormNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FreeFormNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

See Also

FreeFormNode Constructor Overload List
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode Constructor (FreeFormNode)

FreeFormNode Constructor (FreeFormNode)
See Also
[image]

Initializes a new instance of the FreeFormNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FreeFormNode (
FreeFormNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As FreeFormNode _
)

Parameters

prototype

The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

See Also

FreeFormNode Constructor Overload List
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode Methods

FreeFormNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded.
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point. (Inherited from DiagramNode.)
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | Draws the node using the specified IGraphics object.
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramNode.DrawHandles override.
DrawLocal | Override in a derived class to provide implementation specific drawing for the node. (Inherited from DiagramNode.)
DrawShadow | Draws the shadow of this node on the specified IGraphics surface.
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramNode.GetOutlinePoly override.
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramNode.HitTestHandle override.
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
StandardShapeReplacement | Returns a replacement ShapeNode that most closely matches this node's position and outline shape.
UpdateFromPoints | Updates the node's internal state after its points have changed.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramNode.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramNode.RestoreState override.
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramNode.SaveState override.
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.ContainsPoint Method

FreeFormNode.ContainsPoint Method
[image]

Overload List

Name | Description
FreeFormNode.ContainsPoint (Point) | DiagramItem.ContainsPoint override.
FreeFormNode.ContainsPoint (Point, Double) | DiagramItem.ContainsPoint override.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.ContainsPoint Method (Point)

FreeFormNode.ContainsPoint Method (Point)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

Return Value

See Also

ContainsPoint Method Overload List
FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.ContainsPoint Method (Point, Double)

FreeFormNode.ContainsPoint Method (Point, Double)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

threshold

Return Value

See Also

ContainsPoint Method Overload List
FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.CreateProperties Method

FreeFormNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.CreateState Method

FreeFormNode.CreateState Method
[image]

DiagramNode.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateState () As DiagramItemState

Return Value

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.Draw Method

FreeFormNode.Draw Method
[image]

Draws the node using the specified IGraphics object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

A IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.DrawHandles Method

FreeFormNode.DrawHandles Method
[image]

DiagramNode.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawHandles (
IGraphics graphics,
HandlesVisualStyle hstyle,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As IGraphics, _
hstyle As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

The IGraphics surface to draw the handles on.

hstyle

The style that should be used to render the handles.

options

Provides options for the drawing operation.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.DrawShadow Method

FreeFormNode.DrawShadow Method
[image]

Draws the shadow of this node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadow( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.GetIntersection Method

FreeFormNode.GetIntersection Method
[image]

Calculates the intersection point between the segment defined by the specified point pair and the node's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart

The first point of the segment.

segmentEnd

The second point of the segment.

Return Value

A PointF object representing the intersection point.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.GetOutlinePoly Method

FreeFormNode.GetOutlinePoly Method
[image]

DiagramNode.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointCollection GetOutlinePoly (
bool rendering
)

Visual Basic [image] Copy Code

Public Overrides Function GetOutlinePoly( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Return Value

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.HitTestHandle Method

FreeFormNode.HitTestHandle Method
[image]

DiagramNode.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point,
double radius
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point, _
radius As Double _
) As AdjustmentHandle

Parameters

point

A PointF value specifying where to look for a selection handle.

radius

Return Value

Returns an AdjustmentHandle instance representing the adjustment handle found at the specified location, or null if there is none.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.LoadFromJson Method

FreeFormNode.LoadFromJson Method
[image]

Loads the item content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the item's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.LoadFromXml Method

FreeFormNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.OnUpdateBounds Method

FreeFormNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.RestoreProperties Method

FreeFormNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.RestoreState Method

FreeFormNode.RestoreState Method
[image]

DiagramNode.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.SaveProperties Method

FreeFormNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.SaveState Method

FreeFormNode.SaveState Method
[image]

DiagramNode.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.SaveToJson Method

FreeFormNode.SaveToJson Method
[image]

Saves the item content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the item's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.SaveToXml Method

FreeFormNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToXml( _
xmlElement As XElement, _
context As XmlPersistContext _
) As Task

Parameters

xmlElement

An XmlElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.StandardShapeReplacement Method

FreeFormNode.StandardShapeReplacement Method
[image]

Returns a replacement ShapeNode that most closely matches this node's position and outline shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode StandardShapeReplacement (
Shape[] shapes,
Shape defaultShape
)

Visual Basic [image] Copy Code

Public Function StandardShapeReplacement( _
shapes() As Shape, _
defaultShape As Shape _
) As ShapeNode

Parameters

shapes

An array of Shapes against which the free-form outline is matched.

defaultShape

The default shape to assign to the node if there is no match.

Return Value

A ShapeNode instance.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.UpdateFromPoints Method

FreeFormNode.UpdateFromPoints Method
[image]

Updates the node's internal state after its points have changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateFromPoints ()

Visual Basic [image] Copy Code

Public Sub UpdateFromPoints ()

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode Properties

FreeFormNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Closed | Gets or sets if the node's shape is closed.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
ConvertToShape | Gets or sets whether the FreeFormNode currently being drawn should be replaced by a matching ShapeNode.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
Points | Gets or sets the node's outline points.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside the free form node.
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.Closed Property

FreeFormNode.Closed Property
[image]

Gets or sets if the node's shape is closed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Closed { get; set; }

Visual Basic [image] Copy Code

Public Property Closed As Boolean

Property Value

A boolean value.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.ConvertToShape Property

FreeFormNode.ConvertToShape Property
[image]

Gets or sets whether the FreeFormNode currently being drawn should be replaced by a matching ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ConvertToShape { get; set; }

Visual Basic [image] Copy Code

Public Property ConvertToShape As Boolean

Property Value

A boolean value.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.Points Property

FreeFormNode.Points Property
[image]

Gets or sets the node's outline points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Point> Points { get; set; }

Visual Basic [image] Copy Code

Public Property Points As List(Of Point)

Property Value

A collection of Point values.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNode.Text Property

FreeFormNode.Text Property
[image]

Gets or sets the text displayed inside the free form node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string that should be drawn inside this node.

See Also

FreeFormNode Members
FreeFormNode Class


MindFusion.Diagramming.FreeFormNodeStyle Class

FreeFormNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of free-form nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FreeFormNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class FreeFormNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.FreeFormNodeStyle

See Also

FreeFormNodeStyle Members


MindFusion.Diagramming.FreeFormNodeStyle Members

FreeFormNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of free-form nodes.

The following tables list the members exposed by the FreeFormNodeStyle type.

Public Constructors

Name | Description
FreeFormNodeStyle | Initializes a new instance of the FreeFormNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JsonObject. (Inherited from DiagramNodeStyle.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject. (Inherited from DiagramNodeStyle.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

FreeFormNodeStyle Class


MindFusion.Diagramming.FreeFormNodeStyle Constructor

FreeFormNodeStyle Constructor
[image]

Initializes a new instance of the FreeFormNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FreeFormNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FreeFormNodeStyle Class


MindFusion.Diagramming.GlassEffect Class

GlassEffect Class
Remarks See Also
[image]

Represents a glass-like visual effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class GlassEffect : NodeEffect

Visual Basic [image] Copy Code

Public NotInheritable Class GlassEffect
Inherits NodeEffect

Remarks

This effect can be applied to the nodes in a Diagram by adding an instance of this class to the NodeEffects collection.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeEffect
MindFusion.Diagramming.GlassEffect

See Also

GlassEffect Members


MindFusion.Diagramming.GlassEffect Members

GlassEffect Members
Constructors Properties Methods Events
[image]

Represents a glass-like visual effect.

The following tables list the members exposed by the GlassEffect type.

Public Constructors

Name | Description
GlassEffect | Initializes a new instance of the GlassEffect class.

Public Properties

Name | Description
GlowColor | Gets or sets the color of the glow portion of the effect.
ReflectionColor | Gets or sets the color of the reflection portion of the effect.
Type | Gets or sets the type of the glass effect.
UsePenAsGlow | Gets or sets a value indicating whether the glow portion of the effect should be painted with the Pen color of the respective node.

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation. (Inherited from NodeEffect.)

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect Constructor

GlassEffect Constructor
[image]

Initializes a new instance of the GlassEffect class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GlassEffect ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect Methods

GlassEffect Methods
[image]

Public Methods

Name | Description
Clone | NodeEffect.Clone override.

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect.Clone Method

GlassEffect.Clone Method
[image]

NodeEffect.Clone override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override NodeEffect Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As NodeEffect

Return Value

The copy of this effect.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect Properties

GlassEffect Properties
[image]

Public Properties

Name | Description
GlowColor | Gets or sets the color of the glow portion of the effect.
ReflectionColor | Gets or sets the color of the reflection portion of the effect.
Type | Gets or sets the type of the glass effect.
UsePenAsGlow | Gets or sets a value indicating whether the glow portion of the effect should be painted with the Pen color of the respective node.

See Also

GlassEffect Class


MindFusion.Diagramming.GlassEffect.GlowColor Property

GlassEffect.GlowColor Property
[image]

Gets or sets the color of the glow portion of the effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color GlowColor { get; set; }

Visual Basic [image] Copy Code

Public Property GlowColor As Color

Property Value

A Color object. The default is White.

Remarks

The recommended value for this property is Black (or other dark color) for Type4 glass effects.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.ReflectionColor Property

GlassEffect.ReflectionColor Property
[image]

Gets or sets the color of the reflection portion of the effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ReflectionColor { get; set; }

Visual Basic [image] Copy Code

Public Property ReflectionColor As Color

Property Value

A Color object. The default is White.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.Type Property

GlassEffect.Type Property
[image]

Gets or sets the type of the glass effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GlassEffectType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As GlassEffectType

Property Value

A member of the GlassEffectType enumeration. The default is Type1.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffect.UsePenAsGlow Property

GlassEffect.UsePenAsGlow Property
[image]

Gets or sets a value indicating whether the glow portion of the effect should be painted with the Pen color of the respective node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UsePenAsGlow { get; set; }

Visual Basic [image] Copy Code

Public Property UsePenAsGlow As Boolean

Property Value

true to ignore GlowColor and use the color of the pen for the effect glow; otherwise, false.

See Also

GlassEffect Members
GlassEffect Class


MindFusion.Diagramming.GlassEffectType Enumeration

GlassEffectType Enumeration
[image]

Specifies the type of a GlassEffect node effect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum GlassEffectType

Visual Basic [image] Copy Code

Public Enum GlassEffectType

Members

Member name | Description
Type1 | Indicates a glass effect with soft radial glow at the bottom and a sharp reflection at the top.
Type2 | Indicates a glass effect with linear glow at the bottom and sharp reflection at the top.
Type3 | Indicates a glass effect with radial glow at the bottom and smooth reflection and emphasized outline at the top.
Type4 | Indicates a glass effect with sharp reflection at the top and soft glow at the left and right sides.

See Also


MindFusion.Diagramming.Granularity Enumeration

Granularity Enumeration
[image]

Specifies the granularity of the obstacles map generated by QuickRouter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Granularity

Visual Basic [image] Copy Code

Public Enum Granularity

Members

Member name | Description
CoarseGrained | Merge map tiles if possible to create a coarse-grained map. The fewer tiles in the map lead to faster path-finding.
FineGrained | Reserved for future use.
Normal | Use the map tiles found by the initial division algorithm.

Remarks

Members of this enumeration can be assigned to the Granularity property of QuickRouter.

See Also


MindFusion.Diagramming.GridRouter Class

GridRouter Class
Remarks See Also
[image]

Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GridRouter : ILinkRouter

Visual Basic [image] Copy Code

Public Class GridRouter
Implements ILinkRouter

Remarks

To use this class for link routing simply assign its instance to the LinkRouter property of the Diagram class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.GridRouter

See Also

GridRouter Members


MindFusion.Diagramming.GridRouter Members

GridRouter Members
Constructors Properties Methods
[image]

Implements a link routing algorithm that uses a grid to represent the free and occupied regions in the diagram.

The following tables list the members exposed by the GridRouter type.

Public Constructors

Name | Description
GridRouter | Initializes a new instance of the GridRouter class.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter Constructor

GridRouter Constructor
[image]

Initializes a new instance of the GridRouter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GridRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter Methods

GridRouter Methods
[image]

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter.Resume Method

GridRouter.Resume Method
[image]

Implements ILinkRouter.Resume.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Public Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks

true if the links should be routed, otherwise false.

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter.RouteLink Method

GridRouter.RouteLink Method
[image]

Implements ILinkRouter.RouteLink.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function RouteLink( _
link As DiagramLink _
) As Boolean

Parameters

link

The DiagramLink to route.

Return Value

true if a path has been found successfully, otherwise false.

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter.RouteLinks Method

GridRouter.RouteLinks Method
[image]

Implements ILinkRouter.RouteLinks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Public Sub RouteLinks( _
links As DiagramLinkCollection _
)

Parameters

links

A list of DiagramLink objects that should be routed.

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter.Suspend Method

GridRouter.Suspend Method
[image]

Implements ILinkRouter.Suspend.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Suspend ()

Visual Basic [image] Copy Code

Public Sub Suspend ()

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridRouter Properties

GridRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

See Also

GridRouter Class


MindFusion.Diagramming.GridRouter.Diagram Property

GridRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

GridRouter Members
GridRouter Class


MindFusion.Diagramming.GridStyle Enumeration

GridStyle Enumeration
[image]

Defines values that specify the visual style of the alignment grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum GridStyle

Visual Basic [image] Copy Code

Public Enum GridStyle

Members

Member name | Description
Lines | The grid is represented as a series of crossing horizontal and vertical lines.
Points | The grid is painted as a matrix of points.

See Also


MindFusion.Diagramming.GroupAnchorStyles Enumeration

GroupAnchorStyles Enumeration
[image]

Specifies the master node edges to which a subordinate node can be anchored.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum GroupAnchorStyles

Visual Basic [image] Copy Code

Public Enum GroupAnchorStyles

Members

Member name | Description
Bottom | Specifies the bottom edge.
Left | Specifies the left edge.
Right | Specifies the right edge.
Top | Specifies the top edge.

See Also


MindFusion.Diagramming.GroupRotation Enumeration

GroupRotation Enumeration
[image]

Defines values that indicate how rotation of a group's master node affects the nodes attached to that group.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum GroupRotation

Visual Basic [image] Copy Code

Public Enum GroupRotation

Members

Member name | Description
FerrisWheel | Attached nodes are moved to a position corresponding to the master node's rotation angle, but they are node rotated.
IgnoreRotation | Attached nodes ignore the rotation angle applied to the master node.
RotateChildren | Attached nodes are rotated by the RotationAngle of the group's master node and around its center.

See Also


MindFusion.Diagramming.HandlesStyle Enumeration

HandlesStyle Enumeration
[image]

Enumerates possible visual styles for frames that are drawn around selected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HandlesStyle

Visual Basic [image] Copy Code

Public Enum HandlesStyle

Members

Member name | Description
Custom | MindFusion.Diagramming for .NET MAUI raises the DrawAdjustmentHandles and HitTestAdjustmentHandles events to let your application perform custom drawing and hit-testing of selection handles.
DashFrame | If selected, a node is drawn with a dashed frame. The frame enables resizing the node. The center of the node allows moving it and the edge area enables creating links.
EasyMove | Any point of the interior of a node enables moving the node, except a small area in the center that allows creating links.
HatchFrame | If selected, the object is drawn with hatched frame. Modifications can be done as with DashFrame.
HatchHandles | If selected, a node is drawn with both hatched frame and modification handles. The frame enable moving the node, and the handles enable resizing. Links are created from any point of the interior.
HatchHandles2 | Looks like HatchHandles, but allows moving the node from the interior area. Links are created from the points near the edge.
HatchHandles3 | Behaves like HatchHandles2, but paints the selection frame using a denser brush pattern.
Invisible | There is no visible difference between selected and unselected node.
InvisibleMove | There aren't any selection handles displayed. The selected node can be only moved, but not resized.
MoveOnly | If a node is selected, it can be only moved.
RoundAndSquare | Corner resize handles are round, remaining handles are square.
RoundAndSquare2 | Corner resize handles are round, remaining handles are square. In addition, there is a dashed frame drawn around selected nodes.
SquareHandles | If selected, the node is drawn with square modification handles.
SquareHandles2 | Square resize handles are drawn around a selected node. There isn't a move-handle in the center as with the SquareHandles style, but nodes can be moved by dragging their interior or caption areas. Links can be created by drawing from near the edges of a node.

Remarks

The selection style can be set independently for individual nodes and links through their DiagramNode.HandlesStyle and DiagramLink.HandlesStyle properties.

See Also


MindFusion.Diagramming.HandlesVisualStyle Class

HandlesVisualStyle Class
Remarks See Also
[image]

Defines the Pen and Brush objects used to draw items' adjustment handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HandlesVisualStyle

Visual Basic [image] Copy Code

Public Class HandlesVisualStyle

Remarks

The component uses several different HandlesVisualStyle objects depending on the context. They can be accessed through the ActiveItemHandlesStyle, SelectedItemHandlesStyle and DisabledHandlesStyle properties of Diagram.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.HandlesVisualStyle

See Also

HandlesVisualStyle Members


MindFusion.Diagramming.HandlesVisualStyle Members

HandlesVisualStyle Members
Constructors Properties Methods
[image]

Defines the Pen and Brush objects used to draw items' adjustment handles.

The following tables list the members exposed by the HandlesVisualStyle type.

Public Constructors

Name | Description
HandlesVisualStyle | Initializes a new instance of the HandlesVisualStyle class.

Public Properties

Name | Description
ControlPointBrush | Gets or sets a Brush used to fill the interior of shape control points.
DashPen | Gets or sets a Pen used to draw dashed selection frames.
HandleBrush | Gets or sets a Brush used to fill the interior of selection handles.
HandlePen | Gets or sets a Pen used to draw the border of selection handles.
HatchBrush | Gets or sets a Brush used to draw hatch frames.
PatternBrush | Gets or sets a Brush used to draw selection frames for the MoveOnly style.
RotationHandleBrush | Gets or sets a Brush used to fill the interior of the rotation handle.

Public Methods

Name | Description
LoadFromXml | Loads the style from XML.
SaveToXml | Saves the style to XML.

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle Constructor

HandlesVisualStyle Constructor
[image]

Initializes a new instance of the HandlesVisualStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HandlesVisualStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle Methods

HandlesVisualStyle Methods
[image]

Public Methods

Name | Description
LoadFromXml | Loads the style from XML.
SaveToXml | Saves the style to XML.

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.LoadFromXml Method

HandlesVisualStyle.LoadFromXml Method
[image]

Loads the style from XML.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
string elementName,
string colorElementName,
XElement parentElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
elementName As String, _
colorElementName As String, _
parentElement As XElement, _
context As XmlPersistContext _
)

Parameters

elementName

The name of the element that describes the style.

colorElementName

The name of an element that contains a fallback color.

parentElement

The parent XML element.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.SaveToXml Method

HandlesVisualStyle.SaveToXml Method
[image]

Saves the style to XML.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
string elementName,
XElement parentElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
elementName As String, _
parentElement As XElement, _
context As XmlPersistContext _
)

Parameters

elementName

The name of the element that describes the style.

parentElement

The parent XML element.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle Properties

HandlesVisualStyle Properties
[image]

Public Properties

Name | Description
ControlPointBrush | Gets or sets a Brush used to fill the interior of shape control points.
DashPen | Gets or sets a Pen used to draw dashed selection frames.
HandleBrush | Gets or sets a Brush used to fill the interior of selection handles.
HandlePen | Gets or sets a Pen used to draw the border of selection handles.
HatchBrush | Gets or sets a Brush used to draw hatch frames.
PatternBrush | Gets or sets a Brush used to draw selection frames for the MoveOnly style.
RotationHandleBrush | Gets or sets a Brush used to fill the interior of the rotation handle.

See Also

HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.ControlPointBrush Property

HandlesVisualStyle.ControlPointBrush Property
[image]

Gets or sets a Brush used to fill the interior of shape control points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ControlPointBrush { get; set; }

Visual Basic [image] Copy Code

Public Property ControlPointBrush As Brush

Property Value

An instance of a Brush-derived class. The default is solid-color yellow brush.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.DashPen Property

HandlesVisualStyle.DashPen Property
[image]

Gets or sets a Pen used to draw dashed selection frames.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen DashPen { get; set; }

Visual Basic [image] Copy Code

Public Property DashPen As Pen

Property Value

An instance of the Pen class.

Remarks

This pen is used to draw selection frame around items whose HandlesStyle property is set to DashFrame.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.HandleBrush Property

HandlesVisualStyle.HandleBrush Property
[image]

Gets or sets a Brush used to fill the interior of selection handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HandleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HandleBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

This brush is used to fill the interior of adjustment handles rendered for most of the HandlesStyle types.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.HandlePen Property

HandlesVisualStyle.HandlePen Property
[image]

Gets or sets a Pen used to draw the border of selection handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen HandlePen { get; set; }

Visual Basic [image] Copy Code

Public Property HandlePen As Pen

Property Value

An instance of the Pen class.

Remarks

This pen is used to draw the borders of adjustment handles rendered for most of the HandlesStyle types.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.HatchBrush Property

HandlesVisualStyle.HatchBrush Property
[image]

Gets or sets a Brush used to draw hatch frames.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush HatchBrush { get; set; }

Visual Basic [image] Copy Code

Public Property HatchBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

This brush is used to draw the hatch pattern for HandlesStyle types that display hatch frames.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.PatternBrush Property

HandlesVisualStyle.PatternBrush Property
[image]

Gets or sets a Brush used to draw selection frames for the MoveOnly style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush PatternBrush { get; set; }

Visual Basic [image] Copy Code

Public Property PatternBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

This brush is used to render the dot pattern for the HatchHandles3 and MoveOnly types.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HandlesVisualStyle.RotationHandleBrush Property

HandlesVisualStyle.RotationHandleBrush Property
[image]

Gets or sets a Brush used to fill the interior of the rotation handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush RotationHandleBrush { get; set; }

Visual Basic [image] Copy Code

Public Property RotationHandleBrush As Brush

Property Value

A Brush instance. The default value is null.

Remarks

If this property is set to null, the rotation brush is painted using HandleBrush.

See Also

HandlesVisualStyle Members
HandlesVisualStyle Class


MindFusion.Diagramming.HitTestEventArgs Class

HitTestEventArgs Class
[image]

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HitTestEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class HitTestEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.HitTestEventArgs

See Also

HitTestEventArgs Members


MindFusion.Diagramming.HitTestEventArgs Members

HitTestEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the HitTestAdjustmentHandles event handlers.

The following tables list the members exposed by the HitTestEventArgs type.

Public Constructors

Name | Description
HitTestEventArgs | Initializes a new instance of the HitTestEventArgs class.

Public Properties

Name | Description
HitResult | Gets or sets the adjustment handle that has been hit.
Item | Gets the item whose adjustment handles are being hit-tested.
Position | Gets the location related to the event, expressed in document coordinates.

See Also

HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs Constructor

HitTestEventArgs Constructor
[image]

Initializes a new instance of the HitTestEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HitTestEventArgs (
DiagramItem item,
Point position
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem, _
position As Point _
)

Parameters

item

The DiagramItem related to the event.

position

The location related to the event, expressed in document coordinates.

See Also

HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs Properties

HitTestEventArgs Properties
[image]

Public Properties

Name | Description
HitResult | Gets or sets the adjustment handle that has been hit.
Item | Gets the item whose adjustment handles are being hit-tested.
Position | Gets the location related to the event, expressed in document coordinates.

See Also

HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs.HitResult Property

HitTestEventArgs.HitResult Property
[image]

Gets or sets the adjustment handle that has been hit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandle HitResult { get; set; }

Visual Basic [image] Copy Code

Public Property HitResult As AdjustmentHandle

Property Value

An instance of AdjustmentHandle-derived class, or null if there is no handle located at the specified position.

See Also

HitTestEventArgs Members
HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs.Item Property

HitTestEventArgs.Item Property
[image]

Gets the item whose adjustment handles are being hit-tested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

HitTestEventArgs Members
HitTestEventArgs Class


MindFusion.Diagramming.HitTestEventArgs.Position Property

HitTestEventArgs.Position Property
[image]

Gets the location related to the event, expressed in document coordinates.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

A Point value specifying the current mouse position.

See Also

HitTestEventArgs Members
HitTestEventArgs Class


MindFusion.Diagramming.HitTestPriority Enumeration

HitTestPriority Enumeration
[image]

Defines values that specify the order of item hit-testing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HitTestPriority

Visual Basic [image] Copy Code

Public Enum HitTestPriority

Members

Member name | Description
NodesBeforeLinks | Test nodes first, then links.
ZOrder | Test items in decreasing z-order, independently of their types.

See Also


MindFusion.Diagramming.HyperLinkStyle Enumeration

HyperLinkStyle Enumeration
[image]

Specifies how various export components should treat the HyperLink property of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HyperLinkStyle

Visual Basic [image] Copy Code

Public Enum HyperLinkStyle

Members

Member name | Description
None | Do not generate hyperlinks.
Shape | Generate hyperlinks that correspond to the item's shape.
Text | Generate hyperlinks for the text bounding rectangle.

See Also


MindFusion.Diagramming.IDiagramPlatformProvider Interface

IDiagramPlatformProvider Interface
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IDiagramPlatformProvider : IPlatformProvider

Visual Basic [image] Copy Code

Public Interface IDiagramPlatformProvider
Implements IPlatformProvider

See Also

IDiagramPlatformProvider Members


MindFusion.Diagramming.IDiagramPlatformProvider Members

IDiagramPlatformProvider Members
Methods
[image]

The following tables list the members exposed by the IDiagramPlatformProvider type.

Public Methods

Name | Description
CreateMenuItem | Creates a new context menu item with the specified attributes.

See Also

IDiagramPlatformProvider Interface


MindFusion.Diagramming.IDiagramPlatformProvider Methods

IDiagramPlatformProvider Methods
[image]

Public Methods

Name | Description
CreateMenuItem | Creates a new context menu item with the specified attributes.

See Also

IDiagramPlatformProvider Interface


MindFusion.Diagramming.IDiagramPlatformProvider.CreateMenuItem Method

IDiagramPlatformProvider.CreateMenuItem Method
[image]

Creates a new context menu item with the specified attributes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

IMenuItem CreateMenuItem (
ImageSource source,
Size buttonSize,
Pen strokeColor,
Brush fillBrush,
Size imageSize
)

Visual Basic [image] Copy Code

Function CreateMenuItem( _
source As ImageSource, _
buttonSize As Size, _
strokeColor As Pen, _
fillBrush As Brush, _
imageSize As Size _
) As IMenuItem

Parameters

source

The image of the new button.

buttonSize

The size of the new button.

strokeColor

The stroke color of the new button.

fillBrush

The brush used to fill the button background.

imageSize

The size of the button image.

Return Value

The newly created menu item.

See Also

IDiagramPlatformProvider Members
IDiagramPlatformProvider Interface


MindFusion.Diagramming.IDiagramView Interface

IDiagramView Interface
[image]

Controls that display Diagram objects must implement this interface to provide screen resolution information to drawing methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IDiagramView : IResolution

Visual Basic [image] Copy Code

Public Interface IDiagramView
Implements IResolution

See Also

IDiagramView Members


MindFusion.Diagramming.IDiagramView Members

IDiagramView Members
Properties
[image]

Controls that display Diagram objects must implement this interface to provide screen resolution information to drawing methods.

The following tables list the members exposed by the IDiagramView type.

Public Properties

Name | Description
Diagram | Gets the Diagram instance displayed by this control.

See Also

IDiagramView Interface


MindFusion.Diagramming.IDiagramView Properties

IDiagramView Properties
[image]

Public Properties

Name | Description
Diagram | Gets the Diagram instance displayed by this control.

See Also

IDiagramView Interface


MindFusion.Diagramming.IDiagramView.Diagram Property

IDiagramView.Diagram Property
[image]

Gets the Diagram instance displayed by this control.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Diagram Diagram { get; }

Visual Basic [image] Copy Code

ReadOnly Property Diagram As Diagram

Property Value

See Also

IDiagramView Members
IDiagramView Interface


MindFusion.Diagramming.IItemFactory Interface

IItemFactory Interface
[image]

Defines an interface for constructing various objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IItemFactory

Visual Basic [image] Copy Code

Public Interface IItemFactory

Inheritors

MindFusion.Diagramming.Diagram

See Also

IItemFactory Members


MindFusion.Diagramming.IItemFactory Members

IItemFactory Members
Properties Methods Events
[image]

Defines an interface for constructing various objects.

The following tables list the members exposed by the IItemFactory type.

Public Properties

Name | Description
ClsidTable | Gets the table with all registered classes.
TypeTable | Gets the table with all registered classes.

Public Methods

Name | Description
CreateItem | Overloaded. Creates a new object.

Public Events

Name | Description
InstantiateItem | Lets external classes handle item instantiation.

See Also

IItemFactory Interface


MindFusion.Diagramming.IItemFactory Methods

IItemFactory Methods
[image]

Public Methods

Name | Description
CreateItem | Overloaded. Creates a new object.

See Also

IItemFactory Interface


MindFusion.Diagramming.IItemFactory.CreateItem Method

IItemFactory.CreateItem Method
[image]

Creates a new object.

Overload List

Name | Description
IItemFactory.CreateItem (Int32) | Creates a new object given its class id.
IItemFactory.CreateItem (String) | Creates a new object given its item class string identifier.

See Also

IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.IItemFactory.CreateItem Method (Int32)

IItemFactory.CreateItem Method (Int32)
See Also
[image]

Creates a new object given its class id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Object CreateItem (
int clsId
)

Visual Basic [image] Copy Code

Function CreateItem( _
clsId As Integer _
) As Object

Parameters

clsId

The class id of the item to create.

Return Value

An instance of the class with the specified id.

See Also

CreateItem Method Overload List
IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.IItemFactory.CreateItem Method (String)

IItemFactory.CreateItem Method (String)
See Also
[image]

Creates a new object given its item class string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Object CreateItem (
string itemClass
)

Visual Basic [image] Copy Code

Function CreateItem( _
itemClass As String _
) As Object

Parameters

itemClass

The class string id of the item to create.

Return Value

An instance of the class with the specified id.

See Also

CreateItem Method Overload List
IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.IItemFactory Properties

IItemFactory Properties
[image]

Public Properties

Name | Description
ClsidTable | Gets the table with all registered classes.
TypeTable | Gets the table with all registered classes.

See Also

IItemFactory Interface


MindFusion.Diagramming.IItemFactory.ClsidTable Property

IItemFactory.ClsidTable Property
[image]

Gets the table with all registered classes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Dictionary<Object, Object> ClsidTable { get; }

Visual Basic [image] Copy Code

ReadOnly Property ClsidTable As Dictionary(Of Object, Object)

Property Value

An instance of the Dictionary class that represents a map between the class types and the corresponding registered classes.

See Also

IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.IItemFactory.TypeTable Property

IItemFactory.TypeTable Property
[image]

Gets the table with all registered classes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Dictionary<Object, Object> TypeTable { get; }

Visual Basic [image] Copy Code

ReadOnly Property TypeTable As Dictionary(Of Object, Object)

Property Value

An instance of the Dictionary class that represents a map between the class string identifiers and the corresponding registered classes.

See Also

IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.IItemFactory Events

IItemFactory Events
[image]

Public Events

Name | Description
InstantiateItem | Lets external classes handle item instantiation.

See Also

IItemFactory Interface


MindFusion.Diagramming.IItemFactory.InstantiateItem Event

IItemFactory.InstantiateItem Event
[image]

Lets external classes handle item instantiation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

event EventHandler<InstantiateItemEventArgs> InstantiateItem

Visual Basic [image] Copy Code

Event InstantiateItem As EventHandler(Of InstantiateItemEventArgs)

Event Data

InstantiateItem event handlers receive an argument of type InstantiateItemEventArgs.

See Also

IItemFactory Members
IItemFactory Interface


MindFusion.Diagramming.ILinkRouter Interface

ILinkRouter Interface
[image]

Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ILinkRouter

Visual Basic [image] Copy Code

Public Interface ILinkRouter

Inheritors

MindFusion.Diagramming.GridRouter
MindFusion.Diagramming.QuickRouter

See Also

ILinkRouter Members


MindFusion.Diagramming.ILinkRouter Members

ILinkRouter Members
Properties Methods
[image]

Defines methods that should be implemented by a link-router component. The control calls them when a new link path should be set in response to changes in the diagram, such as adding or modifying nodes.

The following tables list the members exposed by the ILinkRouter type.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

Public Methods

Name | Description
Resume | Called when the control ends a batch update operation that might affect many links.
RouteLink | Called when a single link must be routed.
RouteLinks | Called when more than one links must be routed.
Suspend | Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

See Also

ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter Methods

ILinkRouter Methods
[image]

Public Methods

Name | Description
Resume | Called when the control ends a batch update operation that might affect many links.
RouteLink | Called when a single link must be routed.
RouteLinks | Called when more than one links must be routed.
Suspend | Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

See Also

ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.Resume Method

ILinkRouter.Resume Method
[image]

Called when the control ends a batch update operation that might affect many links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks

true if the links should be routed, otherwise false.

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.RouteLink Method

ILinkRouter.RouteLink Method
[image]

Called when a single link must be routed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Function RouteLink( _
link As DiagramLink _
) As Boolean

Parameters

link

A DiagramLink object representing the link.

Return Value

true if a path has been found, otherwise false.

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.RouteLinks Method

ILinkRouter.RouteLinks Method
[image]

Called when more than one links must be routed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Sub RouteLinks( _
links As DiagramLinkCollection _
)

Parameters

links

A DiagramLinkCollection containing the links that should be routed.

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.Suspend Method

ILinkRouter.Suspend Method
[image]

Called when the control starts a batch update operation that might affect many links. Implementations might collect the links specified through RouteLink and RouteLinks calls and defer finding their paths for when Resume is called.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void Suspend ()

Visual Basic [image] Copy Code

Sub Suspend ()

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter Properties

ILinkRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.

See Also

ILinkRouter Interface


MindFusion.Diagramming.ILinkRouter.Diagram Property

ILinkRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

ILinkRouter Members
ILinkRouter Interface


MindFusion.Diagramming.IMeasureUnitConverter Interface

IMeasureUnitConverter Interface
[image]

Provides means to convert between cross-type measure units.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IMeasureUnitConverter

Visual Basic [image] Copy Code

Public Interface IMeasureUnitConverter

See Also

IMeasureUnitConverter Members


MindFusion.Diagramming.IMeasureUnitConverter Members

IMeasureUnitConverter Members
Methods
[image]

Provides means to convert between cross-type measure units.

The following tables list the members exposed by the IMeasureUnitConverter type.

Public Methods

Name | Description
CanConvertFrom | Returns a value indicating whether this converter can convert from the specified target unit to the specified source unit.
CanConvertTo | Returns a value indicating whether this converter can convert from the specified source unit to the specified target unit.
ConvertFrom | Converts a value from the specified source unit to the specified target unit.
ConvertTo | Converts a value from the specified source unit to the specified target unit.

See Also

IMeasureUnitConverter Interface


MindFusion.Diagramming.IMeasureUnitConverter Methods

IMeasureUnitConverter Methods
[image]

Public Methods

Name | Description
CanConvertFrom | Returns a value indicating whether this converter can convert from the specified target unit to the specified source unit.
CanConvertTo | Returns a value indicating whether this converter can convert from the specified source unit to the specified target unit.
ConvertFrom | Converts a value from the specified source unit to the specified target unit.
ConvertTo | Converts a value from the specified source unit to the specified target unit.

See Also

IMeasureUnitConverter Interface


MindFusion.Diagramming.IMeasureUnitConverter.CanConvertFrom Method

IMeasureUnitConverter.CanConvertFrom Method
[image]

Returns a value indicating whether this converter can convert from the specified target unit to the specified source unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool CanConvertFrom (
MeasureUnit targetUnit,
MeasureUnit sourceUnit
)

Visual Basic [image] Copy Code

Function CanConvertFrom( _
targetUnit As MeasureUnit, _
sourceUnit As MeasureUnit _
) As Boolean

Parameters

targetUnit

The target MeasureUnit instance.

sourceUnit

The source MeasureUnit instance.

Return Value

true if conversion between the specified units is supported, or false otherwise.

See Also

IMeasureUnitConverter Members
IMeasureUnitConverter Interface


MindFusion.Diagramming.IMeasureUnitConverter.CanConvertTo Method

IMeasureUnitConverter.CanConvertTo Method
[image]

Returns a value indicating whether this converter can convert from the specified source unit to the specified target unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool CanConvertTo (
MeasureUnit sourceUnit,
MeasureUnit targetUnit
)

Visual Basic [image] Copy Code

Function CanConvertTo( _
sourceUnit As MeasureUnit, _
targetUnit As MeasureUnit _
) As Boolean

Parameters

sourceUnit

The source MeasureUnit instance.

targetUnit

The target MeasureUnit instance.

Return Value

true if conversion between the specified units is supported, or false otherwise.

See Also

IMeasureUnitConverter Members
IMeasureUnitConverter Interface


MindFusion.Diagramming.IMeasureUnitConverter.ConvertFrom Method

IMeasureUnitConverter.ConvertFrom Method
[image]

Converts a value from the specified source unit to the specified target unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double ConvertFrom (
MeasureUnit targetUnit,
MeasureUnit sourceUnit,
double value,
Axis axis,
Object param
)

Visual Basic [image] Copy Code

Function ConvertFrom( _
targetUnit As MeasureUnit, _
sourceUnit As MeasureUnit, _
value As Double, _
axis As Axis, _
param As Object _
) As Double

Parameters

targetUnit

The target MeasureUnit instance.

sourceUnit

The source MeasureUnit instance.

value

A double value that should be converted.

axis

A member of the Axis enumeration specifying whether the value represents a horizontal or a vertical dimension.

param

An object providing device resolution information.

Return Value

The converted value.

See Also

IMeasureUnitConverter Members
IMeasureUnitConverter Interface


MindFusion.Diagramming.IMeasureUnitConverter.ConvertTo Method

IMeasureUnitConverter.ConvertTo Method
[image]

Converts a value from the specified source unit to the specified target unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double ConvertTo (
MeasureUnit sourceUnit,
MeasureUnit targetUnit,
double value,
Axis axis,
Object param
)

Visual Basic [image] Copy Code

Function ConvertTo( _
sourceUnit As MeasureUnit, _
targetUnit As MeasureUnit, _
value As Double, _
axis As Axis, _
param As Object _
) As Double

Parameters

sourceUnit

The source MeasureUnit instance.

targetUnit

The target MeasureUnit instance.

value

A double value that should be converted.

axis

A member of the Axis enumeration specifying whether the value represents a horizontal or a vertical dimension.

param

An object providing device resolution information.

Return Value

The converted value.

See Also

IMeasureUnitConverter Members
IMeasureUnitConverter Interface


MindFusion.Diagramming.IMenuItem Interface

IMenuItem Interface
[image]

Represents an item in a radial menu.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IMenuItem

Visual Basic [image] Copy Code

Public Interface IMenuItem

See Also

IMenuItem Members


MindFusion.Diagramming.IMenuItem Members

IMenuItem Members
Properties Methods Events
[image]

Represents an item in a radial menu.

The following tables list the members exposed by the IMenuItem type.

Public Properties

Name | Description
Bounds | Gets the actual bounds of the item.
FillBrush | Gets or sets the brush used to fill the item background.
Image | Gets or sets the image associated with the item.
ImageSize | Gets or sets the size of the image associated with the item.
ItemSize | Gets or sets the item size.
StrokeColor | Gets or sets the color of the stroke.

Public Methods

Name | Description
RaiseClicked | Raises the Clicked event for this item.

Public Events

Name | Description
Clicked | Raised when the button is clicked.

See Also

IMenuItem Interface


MindFusion.Diagramming.IMenuItem Methods

IMenuItem Methods
[image]

Public Methods

Name | Description
RaiseClicked | Raises the Clicked event for this item.

See Also

IMenuItem Interface


MindFusion.Diagramming.IMenuItem.RaiseClicked Method

IMenuItem.RaiseClicked Method
[image]

Raises the Clicked event for this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void RaiseClicked (
MenuItemEventArgs e
)

Visual Basic [image] Copy Code

Sub RaiseClicked( _
e As MenuItemEventArgs _
)

Parameters

e

An object providing the event argument.

See Also

IMenuItem Members
IMenuItem Interface


MindFusion.Diagramming.IMenuItem Properties

IMenuItem Properties
[image]

Public Properties

Name | Description
Bounds | Gets the actual bounds of the item.
FillBrush | Gets or sets the brush used to fill the item background.
Image | Gets or sets the image associated with the item.
ImageSize | Gets or sets the size of the image associated with the item.
ItemSize | Gets or sets the item size.
StrokeColor | Gets or sets the color of the stroke.

See Also

IMenuItem Interface


MindFusion.Diagramming.IMenuItem.Bounds Property

IMenuItem.Bounds Property
[image]

Gets the actual bounds of the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Rect Bounds { get; }

Visual Basic [image] Copy Code

ReadOnly Property Bounds As Rect

Property Value

A Rectangle object.

See Also

IMenuItem Members
IMenuItem Interface


MindFusion.Diagramming.IMenuItem.FillBrush Property

IMenuItem.FillBrush Property
[image]

Gets or sets the brush used to fill the item background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Brush FillBrush { get; set; }

Visual Basic [image] Copy Code

Property FillBrush As Brush

Property Value

An instance of the Brush class.

See Also

IMenuItem Members
IMenuItem Interface


MindFusion.Diagramming.IMenuItem.Image Property

IMenuItem.Image Property
[image]

Gets or sets the image associated with the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Property Image As ImageSource

Property Value

An instance of the ImageSource class.

See Also

IMenuItem Members
IMenuItem Interface


MindFusion.Diagramming.IMenuItem.ImageSize Property

IMenuItem.ImageSize Property
[image]

Gets or sets the size of the image associated with the item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Size ImageSize { get; set; }

Visual Basic [image] Copy Code

Property ImageSize As Size

Property Value

A Size object.

See Also

IMenuItem Members
IMenuItem Interface


MindFusion.Diagramming.IMenuItem.ItemSize Property

IMenuItem.ItemSize Property
[image]

Gets or sets the item size.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Size ItemSize { get; set; }

Visual Basic [image] Copy Code

Property ItemSize As Size

Property Value

A Size object.

See Also

IMenuItem Members
IMenuItem Interface


MindFusion.Diagramming.IMenuItem.StrokeColor Property

IMenuItem.StrokeColor Property
[image]

Gets or sets the color of the stroke.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Pen StrokeColor { get; set; }

Visual Basic [image] Copy Code

Property StrokeColor As Pen

Property Value

An instance of the Pen class.

See Also

IMenuItem Members
IMenuItem Interface


MindFusion.Diagramming.IMenuItem Events

IMenuItem Events
[image]

Public Events

Name | Description
Clicked | Raised when the button is clicked.

See Also

IMenuItem Interface


MindFusion.Diagramming.IMenuItem.Clicked Event

IMenuItem.Clicked Event
[image]

Raised when the button is clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

event EventHandler<MenuItemEventArgs> Clicked

Visual Basic [image] Copy Code

Event Clicked As EventHandler(Of MenuItemEventArgs)

Event Data

Clicked event handlers receive an argument of type MenuItemEventArgs.

See Also

IMenuItem Members
IMenuItem Interface


MindFusion.Diagramming.InplaceEditable Interface

InplaceEditable Interface
[image]

Represents an inplace-editable object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface InplaceEditable

Visual Basic [image] Copy Code

Public Interface InplaceEditable

Inheritors

MindFusion.Diagramming.ContainerNode
MindFusion.Diagramming.DiagramLink
MindFusion.Diagramming.FreeFormNode
MindFusion.Diagramming.ItemLabel
MindFusion.Diagramming.ShapeNode
MindFusion.Diagramming.TableNode
MindFusion.Diagramming.TableNode.Cell
MindFusion.Diagramming.TreeViewItem
MindFusion.Diagramming.TreeViewNode

See Also

InplaceEditable Members


MindFusion.Diagramming.InplaceEditable Members

InplaceEditable Members
Methods
[image]

Represents an inplace-editable object.

The following tables list the members exposed by the InplaceEditable type.

Public Methods

Name | Description
GetEditRect | Returns the rectangle where the in-place edit text box should appear (in document coordinates).
GetTextToEdit | Returns the text of the object which should be displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable Methods

InplaceEditable Methods
[image]

Public Methods

Name | Description
GetEditRect | Returns the rectangle where the in-place edit text box should appear (in document coordinates).
GetTextToEdit | Returns the text of the object which should be displayed initially when the object is in-place edited.
SetEditedText | Sets the edited text to the object after the in-place editing operation has been completed successfully.

See Also

InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable.GetEditRect Method

InplaceEditable.GetEditRect Method
[image]

Returns the rectangle where the in-place edit text box should appear (in document coordinates).

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Rect GetEditRect (
DiagramItem item,
Point position
)

Visual Basic [image] Copy Code

Function GetEditRect( _
item As DiagramItem, _
position As Point _
) As Rect

Parameters

item

The item being edited.

position

A Point instance specifying the mouse position.

Return Value

A Rectangle instance that represents the destination rectangle of the in-place edit box.

See Also

InplaceEditable Members
InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable.GetTextToEdit Method

InplaceEditable.GetTextToEdit Method
[image]

Returns the text of the object which should be displayed initially when the object is in-place edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

string GetTextToEdit ()

Visual Basic [image] Copy Code

Function GetTextToEdit () As String

Return Value

A string value that represents the initial contents of the in-place edit box.

See Also

InplaceEditable Members
InplaceEditable Interface


MindFusion.Diagramming.InplaceEditable.SetEditedText Method

InplaceEditable.SetEditedText Method
[image]

Sets the edited text to the object after the in-place editing operation has been completed successfully.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetEditedText (
string newText
)

Visual Basic [image] Copy Code

Sub SetEditedText( _
newText As String _
)

Parameters

newText

The new text of the in-place edited object.

See Also

InplaceEditable Members
InplaceEditable Interface


MindFusion.Diagramming.InPlaceEditEventArgs Class

InPlaceEditEventArgs Class
[image]

Contains the arguments passed to the EnterInplaceEditMode and LeaveInplaceEditMode event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class InPlaceEditEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class InPlaceEditEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.InPlaceEditEventArgs

See Also

InPlaceEditEventArgs Members


MindFusion.Diagramming.InPlaceEditEventArgs Members

InPlaceEditEventArgs Members
Properties
[image]

Contains the arguments passed to the EnterInplaceEditMode and LeaveInplaceEditMode event handlers.

The following tables list the members exposed by the InPlaceEditEventArgs type.

Public Properties

Name | Description
Item | Gets a reference to the item being edited.
Node | Gets the diagram node being edited.
TextEditor | Gets the control used to edit the item's text.

See Also

InPlaceEditEventArgs Class


MindFusion.Diagramming.InPlaceEditEventArgs Properties

InPlaceEditEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to the item being edited.
Node | Gets the diagram node being edited.
TextEditor | Gets the control used to edit the item's text.

See Also

InPlaceEditEventArgs Class


MindFusion.Diagramming.InPlaceEditEventArgs.Item Property

InPlaceEditEventArgs.Item Property
[image]

Gets a reference to the item being edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InplaceEditable Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As InplaceEditable

Property Value

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class


MindFusion.Diagramming.InPlaceEditEventArgs.Node Property

InPlaceEditEventArgs.Node Property
[image]

Gets the diagram node being edited.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class


MindFusion.Diagramming.InPlaceEditEventArgs.TextEditor Property

InPlaceEditEventArgs.TextEditor Property
[image]

Gets the control used to edit the item's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TextEditor TextEditor { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TextEditor As TextEditor

Property Value

See Also

InPlaceEditEventArgs Members
InPlaceEditEventArgs Class


MindFusion.Diagramming.InstantiateItemEventArgs Class

InstantiateItemEventArgs Class
[image]

Contains the arguments passed to the InstantiateItem event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class InstantiateItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class InstantiateItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.InstantiateItemEventArgs

See Also

InstantiateItemEventArgs Members


MindFusion.Diagramming.InstantiateItemEventArgs Members

InstantiateItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the InstantiateItem event handlers.

The following tables list the members exposed by the InstantiateItemEventArgs type.

Public Constructors

Name | Description
InstantiateItemEventArgs | Initializes a new instance of the InstantiateItemEventArgs class.

Public Properties

Name | Description
Item | Gets or sets a reference to the created diagram item.
ItemClass | Gets the item class identifier.

See Also

InstantiateItemEventArgs Class


MindFusion.Diagramming.InstantiateItemEventArgs Constructor

InstantiateItemEventArgs Constructor
[image]

Initializes a new instance of the InstantiateItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InstantiateItemEventArgs (
string itemClass
)

Visual Basic [image] Copy Code

Public New ( _
itemClass As String _
)

Parameters

itemClass

The class string identifier specifying the type of the new item.

See Also

InstantiateItemEventArgs Class


MindFusion.Diagramming.InstantiateItemEventArgs Properties

InstantiateItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets or sets a reference to the created diagram item.
ItemClass | Gets the item class identifier.

See Also

InstantiateItemEventArgs Class


MindFusion.Diagramming.InstantiateItemEventArgs.Item Property

InstantiateItemEventArgs.Item Property
[image]

Gets or sets a reference to the created diagram item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class


MindFusion.Diagramming.InstantiateItemEventArgs.ItemClass Property

InstantiateItemEventArgs.ItemClass Property
[image]

Gets the item class identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ItemClass { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ItemClass As String

Property Value

A string value specifying the item class identifier.

See Also

InstantiateItemEventArgs Members
InstantiateItemEventArgs Class


MindFusion.Diagramming.InternalUtils Class

InternalUtils Class
Remarks See Also
[image]

Contains common helper methods.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class InternalUtils

Visual Basic [image] Copy Code

Public NotInheritable Class InternalUtils

Remarks

This class supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.InternalUtils

See Also

InternalUtils Members


MindFusion.Diagramming.InternalUtils Members

InternalUtils Members
Methods
[image]

Contains common helper methods.

The following tables list the members exposed by the InternalUtils type.

Public Methods

Name | Description
AddToRect | Appends the specified values to the width and the height of the specified rectangle.
ApproxEllipse | Approximates the ellipse contained in the specified rectangle with a polyline. The specified quality parameter varies in the interval [1, …) and is proportional to the number of points in the resulting polyline.
Blend | Creates a normalized [0…1] color blend out of the specified colors and positions.
CheckIntersect | Checks if the specified rectangle and circle intersect.
ConvertUnits | Converts a value between different measure units.
DistanceAlongLength | Returns the distance from the specified point to the start of the specified path along the path's length.
DistanceSq | Calculates the square of the distance between the specified points.
DistToPolyline | Overloaded. Calculates the shortest distance from a point to a polyline.
DistToRectPoint | Returns the nearest to pt point that lies on the outline of rectangle.
DrawExpandButton | Renders an expand/collapse button on the specified IGraphics canvas.
DrawSelHandles | Draws the selection handles.
GetEllipseIntr | Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.
LinearGradient | Creates a linear gradient brush with the specified blend and orientation angle.
MatchPointsMinLength | Returns an array of node anchor points which match current node links anchor point
MidPoint | Returns the middle point of the segment defined by the specified points.
MinDistToRect | Calculates the minimum distance between a given point and a given rectangle.
OffsetPath | Moves a path by the specified offset.
PointAlongLength | Overloaded.
PointInRect | Checks whether the specified rectangle contains the specified point.
RectangleToPoints | Returns the points of the rectangle as an array
UnionNonEmptyRects | Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.

See Also

InternalUtils Class


MindFusion.Diagramming.InternalUtils Methods

InternalUtils Methods
[image]

Public Methods

Name | Description
AddToRect | Appends the specified values to the width and the height of the specified rectangle.
ApproxEllipse | Approximates the ellipse contained in the specified rectangle with a polyline. The specified quality parameter varies in the interval [1, …) and is proportional to the number of points in the resulting polyline.
Blend | Creates a normalized [0…1] color blend out of the specified colors and positions.
CheckIntersect | Checks if the specified rectangle and circle intersect.
ConvertUnits | Converts a value between different measure units.
DistanceAlongLength | Returns the distance from the specified point to the start of the specified path along the path's length.
DistanceSq | Calculates the square of the distance between the specified points.
DistToPolyline | Overloaded. Calculates the shortest distance from a point to a polyline.
DistToRectPoint | Returns the nearest to pt point that lies on the outline of rectangle.
DrawExpandButton | Renders an expand/collapse button on the specified IGraphics canvas.
DrawSelHandles | Draws the selection handles.
GetEllipseIntr | Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.
LinearGradient | Creates a linear gradient brush with the specified blend and orientation angle.
MatchPointsMinLength | Returns an array of node anchor points which match current node links anchor point
MidPoint | Returns the middle point of the segment defined by the specified points.
MinDistToRect | Calculates the minimum distance between a given point and a given rectangle.
OffsetPath | Moves a path by the specified offset.
PointAlongLength | Overloaded.
PointInRect | Checks whether the specified rectangle contains the specified point.
RectangleToPoints | Returns the points of the rectangle as an array
UnionNonEmptyRects | Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.

See Also

InternalUtils Class


MindFusion.Diagramming.InternalUtils.AddToRect Method

InternalUtils.AddToRect Method
[image]

Appends the specified values to the width and the height of the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void AddToRect (
ref Rect rect,
double w,
double h
)

Visual Basic [image] Copy Code

Public Shared Sub AddToRect( _
ByRef rect As Rect, _
w As Double, _
h As Double _
)

Parameters

rect

The Rectangle instance that must be modified.

w

The increment/decrement of the rectangle width.

h

The increment/decrement of the rectangle height.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.ApproxEllipse Method

InternalUtils.ApproxEllipse Method
[image]

Approximates the ellipse contained in the specified rectangle with a polyline. The specified quality parameter varies in the interval [1, …) and is proportional to the number of points in the resulting polyline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static PointCollection ApproxEllipse (
Rect rect,
int quality
)

Visual Basic [image] Copy Code

Public Shared Function ApproxEllipse( _
rect As Rect, _
quality As Integer _
) As PointCollection

Parameters

rect

A Rectangle instance, which defines the source ellipse.

quality

The quality of the produced approximation.

Return Value

An instance of the PointCollection class containing the points of the calculated approximation.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.Blend Method

InternalUtils.Blend Method
[image]

Creates a normalized [0…1] color blend out of the specified colors and positions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void Blend (
List<Double> positions,
List<Color> colors,
Object[] positionsAndColors
)

Visual Basic [image] Copy Code

Public Shared Sub Blend( _
positions As List(Of Double), _
colors As List(Of Color), _
positionsAndColors() As Object _
)

Parameters

positions

A list of double value that will receive the gradient stops.

colors

A list of Color objects that will receive the gradient colors.

positionsAndColors

An alternating sequence of double and Color pairs where each pair defines a gradient stop. The positions in the sequence need to be in ascending order.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.CheckIntersect Method

InternalUtils.CheckIntersect Method
[image]

Checks if the specified rectangle and circle intersect.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool CheckIntersect (
Point pt,
Rect rc,
double rad
)

Visual Basic [image] Copy Code

Public Shared Function CheckIntersect( _
pt As Point, _
rc As Rect, _
rad As Double _
) As Boolean

Parameters

pt

rc

rad

Return Value

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.ConvertUnits Method

InternalUtils.ConvertUnits Method
[image]

Converts a value between different measure units.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double ConvertUnits (
double value,
MeasureUnit srcUnit,
MeasureUnit targetUnit
)

Visual Basic [image] Copy Code

Public Shared Function ConvertUnits( _
value As Double, _
srcUnit As MeasureUnit, _
targetUnit As MeasureUnit _
) As Double

Parameters

value

srcUnit

targetUnit

Return Value

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistanceAlongLength Method

InternalUtils.DistanceAlongLength Method
[image]

Returns the distance from the specified point to the start of the specified path along the path's length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistanceAlongLength (
Point point,
PointCollection segments
)

Visual Basic [image] Copy Code

Public Shared Function DistanceAlongLength( _
point As Point, _
segments As PointCollection _
) As Double

Parameters

point

A Point whose distance to the path start to calculate.

segments

A PointCollection specifying the path.

Return Value

A double value specifying distance from the point to the path origin.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistanceSq Method

InternalUtils.DistanceSq Method
[image]

Calculates the square of the distance between the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistanceSq (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Shared Function DistanceSq( _
pt1 As Point, _
pt2 As Point _
) As Double

Parameters

pt1

pt2

Return Value

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistToPolyline Method

InternalUtils.DistToPolyline Method
[image]

Calculates the shortest distance from a point to a polyline.

Overload List

Name | Description
InternalUtils.DistToPolyline (Point, IList(Point), Int32) | Calculates the shortest distance from the specified point to the specified polyline.
InternalUtils.DistToPolyline (Point, IList(Point), Int32, Int32@) | Calculates the shortest distance from the specified point to the specified polyline, also returning the index of the segment the point is closest to.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistToPolyline Method (Point, IList(Point), Int32)

InternalUtils.DistToPolyline Method (Point, IList(Point), Int32)
See Also
[image]

Calculates the shortest distance from the specified point to the specified polyline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistToPolyline (
Point pt,
IList<Point> line_pts,
int nPoints
)

Visual Basic [image] Copy Code

Public Shared Function DistToPolyline( _
pt As Point, _
line_pts As IList(Of Point), _
nPoints As Integer _
) As Double

Parameters

pt

line_pts

nPoints

Return Value

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

DistToPolyline Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistToPolyline Method (Point, IList(Point), Int32, Int32@)

InternalUtils.DistToPolyline Method (Point, IList(Point), Int32, Int32@)
See Also
[image]

Calculates the shortest distance from the specified point to the specified polyline, also returning the index of the segment the point is closest to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double DistToPolyline (
Point pt,
IList<Point> line_pts,
int nPoints,
ref int segmNum
)

Visual Basic [image] Copy Code

Public Shared Function DistToPolyline( _
pt As Point, _
line_pts As IList(Of Point), _
nPoints As Integer, _
ByRef segmNum As Integer _
) As Double

Parameters

pt

line_pts

nPoints

segmNum

Return Value

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

DistToPolyline Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DistToRectPoint Method

InternalUtils.DistToRectPoint Method
[image]

Returns the nearest to pt point that lies on the outline of rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point DistToRectPoint (
Point pt,
Rect r
)

Visual Basic [image] Copy Code

Public Shared Function DistToRectPoint( _
pt As Point, _
r As Rect _
) As Point

Parameters

pt

r

Return Value

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DrawExpandButton Method

InternalUtils.DrawExpandButton Method
[image]

Renders an expand/collapse button on the specified IGraphics canvas.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void DrawExpandButton (
IGraphics graphics,
bool expanded,
Rect bounds,
MeasureUnit measureUnit,
Brush shadowBrush
)

Visual Basic [image] Copy Code

Public Shared Sub DrawExpandButton( _
graphics As IGraphics, _
expanded As Boolean, _
bounds As Rect, _
measureUnit As MeasureUnit, _
shadowBrush As Brush _
)

Parameters

graphics

expanded

bounds

measureUnit

shadowBrush

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.DrawSelHandles Method

InternalUtils.DrawSelHandles Method
[image]

Draws the selection handles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void DrawSelHandles (
Diagram diagram,
IGraphics graphics,
HandlesVisualStyle enabledStyle,
HandlesVisualStyle disabledStyle,
Rect rc,
double rotationAngle,
AdjustmentHandles mask,
bool showDsbl,
HandlesStyle st,
double size,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Shared Sub DrawSelHandles( _
diagram As Diagram, _
graphics As IGraphics, _
enabledStyle As HandlesVisualStyle, _
disabledStyle As HandlesVisualStyle, _
rc As Rect, _
rotationAngle As Double, _
mask As AdjustmentHandles, _
showDsbl As Boolean, _
st As HandlesStyle, _
size As Double, _
options As RenderOptions _
)

Parameters

diagram

graphics

enabledStyle

disabledStyle

rc

rotationAngle

mask

showDsbl

st

size

options

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.GetEllipseIntr Method

InternalUtils.GetEllipseIntr Method
[image]

Calculate the intersection point between the ellipse with the specified bounds and the line segment defined by the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void GetEllipseIntr (
Rect rcBox,
Point pt1,
Point pt2,
ref Point pt
)

Visual Basic [image] Copy Code

Public Shared Sub GetEllipseIntr( _
rcBox As Rect, _
pt1 As Point, _
pt2 As Point, _
ByRef pt As Point _
)

Parameters

rcBox

pt1

pt2

pt

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.LinearGradient Method

InternalUtils.LinearGradient Method
[image]

Creates a linear gradient brush with the specified blend and orientation angle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static LinearGradientBrush LinearGradient (
double angle,
Object[] positionsAndColors
)

Visual Basic [image] Copy Code

Public Shared Function LinearGradient( _
angle As Double, _
positionsAndColors() As Object _
) As LinearGradientBrush

Parameters

angle

The angle of the linear gradient.

positionsAndColors

An alternating sequence of double and Color pairs where each pair defines a gradient stop. The positions in the sequence need to be in ascending order.

Return Value

An instance of the LinearGradientBrush class corresponding to the specified settings.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.MatchPointsMinLength Method

InternalUtils.MatchPointsMinLength Method
[image]

Returns an array of node anchor points which match current node links anchor point

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int[] MatchPointsMinLength (
Point[] nodeAnchorPoints,
int[] pointRealIndexes,
Point[] fixedLinksAnchorPoints,
List<Int32> usedAnchorPointIndexes
)

Visual Basic [image] Copy Code

Public Shared Function MatchPointsMinLength( _
nodeAnchorPoints() As Point, _
pointRealIndexes() As Integer, _
fixedLinksAnchorPoints() As Point, _
usedAnchorPointIndexes As List(Of Int32) _
) As Integer()

Parameters

nodeAnchorPoints

pointRealIndexes

fixedLinksAnchorPoints

usedAnchorPointIndexes

Return Value

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.MidPoint Method

InternalUtils.MidPoint Method
[image]

Returns the middle point of the segment defined by the specified points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point MidPoint (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Shared Function MidPoint( _
pt1 As Point, _
pt2 As Point _
) As Point

Parameters

pt1

The first point.

pt2

The second point.

Return Value

A Point instance that represents the middle point.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.MinDistToRect Method

InternalUtils.MinDistToRect Method
[image]

Calculates the minimum distance between a given point and a given rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static double MinDistToRect (
Point pt,
Rect rc
)

Visual Basic [image] Copy Code

Public Shared Function MinDistToRect( _
pt As Point, _
rc As Rect _
) As Double

Parameters

pt

rc

Return Value

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.OffsetPath Method

InternalUtils.OffsetPath Method
[image]

Moves a path by the specified offset.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void OffsetPath (
IGraphicsPath path,
double dx,
double dy
)

Visual Basic [image] Copy Code

Public Shared Sub OffsetPath( _
path As IGraphicsPath, _
dx As Double, _
dy As Double _
)

Parameters

path

dx

dy

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.PointAlongLength Method

InternalUtils.PointAlongLength Method
[image]

Overload List

Name | Description
InternalUtils.PointAlongLength (Double, IList(Point)) | Returns a point lying at the specified distance from the start point along the path specified via the collection of points.
InternalUtils.PointAlongLength (Double, PointCollection) | Returns a point lying at the specified distance from the start point along the path specified via the collection of points.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.PointAlongLength Method (Double, IList(Point))

InternalUtils.PointAlongLength Method (Double, IList(Point))
See Also
[image]

Returns a point lying at the specified distance from the start point along the path specified via the collection of points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point PointAlongLength (
double distance,
IList<Point> segments
)

Visual Basic [image] Copy Code

Public Shared Function PointAlongLength( _
distance As Double, _
segments As IList(Of Point) _
) As Point

Parameters

distance

A float value specifying the desired distance.

segments

A list of points specifying the path.

Return Value

A Point structure specifying the point coordinates.

See Also

PointAlongLength Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.PointAlongLength Method (Double, PointCollection)

InternalUtils.PointAlongLength Method (Double, PointCollection)
See Also
[image]

Returns a point lying at the specified distance from the start point along the path specified via the collection of points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point PointAlongLength (
double distance,
PointCollection segments
)

Visual Basic [image] Copy Code

Public Shared Function PointAlongLength( _
distance As Double, _
segments As PointCollection _
) As Point

Parameters

distance

A double value specifying the desired distance.

segments

A PointCollection specifying the path.

Return Value

A Point structure specifying the point coordinates.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

PointAlongLength Method Overload List
InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.PointInRect Method

InternalUtils.PointInRect Method
[image]

Checks whether the specified rectangle contains the specified point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static bool PointInRect (
Point pt,
Rect rc
)

Visual Basic [image] Copy Code

Public Shared Function PointInRect( _
pt As Point, _
rc As Rect _
) As Boolean

Parameters

pt

The point to be checked.

rc

The rectangle to be checked.

Return Value

true if the specified rectangle contains the specified point; otherwise, false.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.RectangleToPoints Method

InternalUtils.RectangleToPoints Method
[image]

Returns the points of the rectangle as an array

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point[] RectangleToPoints (
Rect r
)

Visual Basic [image] Copy Code

Public Shared Function RectangleToPoints( _
r As Rect _
) As Point()

Parameters

r

The source rectangle.

Return Value

An array of Point objects, which contains the vertices of the rectangle.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.InternalUtils.UnionNonEmptyRects Method

InternalUtils.UnionNonEmptyRects Method
[image]

Returns the smallest possible rectangle containing both of the specified rectangles, but only if the rectangles are non-empty.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Rect UnionNonEmptyRects (
Rect rc1,
Rect rc2
)

Visual Basic [image] Copy Code

Public Shared Function UnionNonEmptyRects( _
rc1 As Rect, _
rc2 As Rect _
) As Rect

Parameters

rc1

The first rectangle.

rc2

The second rectangle.

Return Value

A Rectangle instance that represents the union of the specified arguments.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

InternalUtils Members
InternalUtils Class


MindFusion.Diagramming.IProperty Interface

IProperty Interface
[image]

Represents a property that can have an undefined value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IProperty

Visual Basic [image] Copy Code

Public Interface IProperty

See Also

IProperty Members


MindFusion.Diagramming.IProperty Members

IProperty Members
Properties Methods
[image]

Represents a property that can have an undefined value.

The following tables list the members exposed by the IProperty type.

Public Properties

Name | Description
HasValue | Gets a value indicating whether the property has a value.
Name | Gets the name of the property.

Public Methods

Name | Description
GetValue | Gets the value of the property.
SetValue | Sets the value of the property.
Unset | Clears the value of the property.

See Also

IProperty Interface


MindFusion.Diagramming.IProperty Methods

IProperty Methods
[image]

Public Methods

Name | Description
GetValue | Gets the value of the property.
SetValue | Sets the value of the property.
Unset | Clears the value of the property.

See Also

IProperty Interface


MindFusion.Diagramming.IProperty.GetValue Method

IProperty.GetValue Method
[image]

Gets the value of the property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Object GetValue ()

Visual Basic [image] Copy Code

Function GetValue () As Object

Return Value

See Also

IProperty Members
IProperty Interface


MindFusion.Diagramming.IProperty.SetValue Method

IProperty.SetValue Method
[image]

Sets the value of the property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetValue (
Object value
)

Visual Basic [image] Copy Code

Sub SetValue( _
value As Object _
)

Parameters

value

See Also

IProperty Members
IProperty Interface


MindFusion.Diagramming.IProperty.Unset Method

IProperty.Unset Method
[image]

Clears the value of the property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void Unset ()

Visual Basic [image] Copy Code

Sub Unset ()

See Also

IProperty Members
IProperty Interface


MindFusion.Diagramming.IProperty Properties

IProperty Properties
[image]

Public Properties

Name | Description
HasValue | Gets a value indicating whether the property has a value.
Name | Gets the name of the property.

See Also

IProperty Interface


MindFusion.Diagramming.IProperty.HasValue Property

IProperty.HasValue Property
[image]

Gets a value indicating whether the property has a value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool HasValue { get; }

Visual Basic [image] Copy Code

ReadOnly Property HasValue As Boolean

Property Value

See Also

IProperty Members
IProperty Interface


MindFusion.Diagramming.IProperty.Name Property

IProperty.Name Property
[image]

Gets the name of the property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

string Name { get; }

Visual Basic [image] Copy Code

ReadOnly Property Name As String

Property Value

See Also

IProperty Members
IProperty Interface


MindFusion.Diagramming.IResolution Interface

IResolution Interface
[image]

Provides information about device resolution.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface IResolution

Visual Basic [image] Copy Code

Public Interface IResolution

Inheritors

MindFusion.Diagramming.DiagramPresenter
MindFusion.Diagramming.IDiagramView

See Also

IResolution Members


MindFusion.Diagramming.IResolution Members

IResolution Members
Properties
[image]

Provides information about device resolution.

The following tables list the members exposed by the IResolution type.

Public Properties

Name | Description
DpiX | Gets the horizontal resolution of the device.
DpiY | Gets the vertical resolution of the device.

See Also

IResolution Interface


MindFusion.Diagramming.IResolution Properties

IResolution Properties
[image]

Public Properties

Name | Description
DpiX | Gets the horizontal resolution of the device.
DpiY | Gets the vertical resolution of the device.

See Also

IResolution Interface


MindFusion.Diagramming.IResolution.DpiX Property

IResolution.DpiX Property
[image]

Gets the horizontal resolution of the device.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double DpiX { get; }

Visual Basic [image] Copy Code

ReadOnly Property DpiX As Double

Property Value

A double value specifying horizontal dots-per-inch resolution.

See Also

IResolution Members
IResolution Interface


MindFusion.Diagramming.IResolution.DpiY Property

IResolution.DpiY Property
[image]

Gets the vertical resolution of the device.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double DpiY { get; }

Visual Basic [image] Copy Code

ReadOnly Property DpiY As Double

Property Value

A double value specifying vertical dots-per-inch resolution.

See Also

IResolution Members
IResolution Interface


MindFusion.Diagramming.ItemCollectionBase(T) Class

ItemCollectionBase(T) Class
[image]

A base collection class for the diagram item collections.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class ItemCollectionBase<T> : CollectionBase<T> where T : DiagramItem

Visual Basic [image] Copy Code

Public MustInherit Class ItemCollectionBase(Of T As DiagramItem)
Inherits CollectionBase(Of T)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.CollectionBase(T)
MindFusion.Diagramming.ItemCollectionBase(T)
MindFusion.Diagramming.DiagramItemCollection
MindFusion.Diagramming.DiagramLinkCollection
MindFusion.Diagramming.DiagramNodeCollection

See Also

ItemCollectionBase(T) Members


MindFusion.Diagramming.ItemCollectionBase(T) Members

ItemCollectionBase(T) Members
Fields Properties Methods
[image]

A base collection class for the diagram item collections.

The following tables list the members exposed by the ItemCollectionBase(T) type.

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Public Properties

Name | Description
Count | Gets the number of elements actually contained in the collection. (Inherited from CollectionBase.)
IsReadOnly | Gets a value indicating whether the collection is read-only. (Inherited from CollectionBase.)
Item | Gets or sets the element at the specified index. (Inherited from CollectionBase.)

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection.
Clear | Removes all diagram items from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position.
Remove | Removes the diagram item from the collection.
RemoveAt | Removes the diagram item from the collection.
Sort | Overloaded. Sorts the elements in this collection. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T) Fields

ItemCollectionBase(T) Fields
[image]

Protected Fields

Name | Description
InnerList | Gets a List<T> containing the list of elements in the collection instance. (Inherited from CollectionBase.)
itemEventArgs | A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.
notifyParent | If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

See Also

ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).itemEventArgs Field

ItemCollectionBase(T).itemEventArgs Field
[image]

A ItemEventArgs instance used for passing arguments to the event handlers for the events of this collection. Used to avoid creating many small objects that would burden the garbage collector.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected ItemEventArgs itemEventArgs

Visual Basic [image] Copy Code

Protected itemEventArgs As ItemEventArgs

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).notifyParent Field

ItemCollectionBase(T).notifyParent Field
[image]

If enabled, the collection raises events to let their containing objects handle the addition or removal of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool notifyParent

Visual Basic [image] Copy Code

Protected notifyParent As Boolean

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T) Methods

ItemCollectionBase(T) Methods
[image]

Public Methods

Name | Description
Add | Adds the specified diagram item to the collection.
Clear | Removes all diagram items from the collection.
Contains | Determines whether an element is in the collection. (Inherited from CollectionBase.)
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from CollectionBase.)
GetAt | Gets the diagram item at the specified position.
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from CollectionBase.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire collection. (Inherited from CollectionBase.)
Insert | Inserts the specified diagram item into the collection at the specified position.
Remove | Removes the diagram item from the collection.
RemoveAt | Removes the diagram item from the collection.
Sort | Overloaded. Sorts the elements in this collection. (Inherited from CollectionBase.)

Protected Methods

Name | Description
RaiseAdding | Raises the Adding event.
RaiseInserting | Raises the Inserting event.
RaiseRemoving | Raises the Removing event.

See Also

ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).Add Method

ItemCollectionBase(T).Add Method
[image]

Adds the specified diagram item to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Add (
T item
)

Visual Basic [image] Copy Code

Public Overrides Sub Add( _
item As T _
)

Parameters

item

The DiagramItem object to add to the collection.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).Clear Method

ItemCollectionBase(T).Clear Method
[image]

Removes all diagram items from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Clear ()

Visual Basic [image] Copy Code

Public Overrides Sub Clear ()

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).GetAt Method

ItemCollectionBase(T).GetAt Method
[image]

Gets the diagram item at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As DiagramItem

Parameters

index

The zero-based index of the item to retrieve.

Return Value

An instance of the DiagramItem class that represents the item at the specified position.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).Insert Method

ItemCollectionBase(T).Insert Method
[image]

Inserts the specified diagram item into the collection at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Insert (
int index,
T item
)

Visual Basic [image] Copy Code

Public Overrides Sub Insert( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index at which to insert the item.

item

The DiagramItem object to add to the collection.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).RaiseAdding Method

ItemCollectionBase(T).RaiseAdding Method
[image]

Raises the Adding event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseAdding (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Sub RaiseAdding( _
item As DiagramItem _
)

Parameters

item

The diagram item that is being added.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).RaiseInserting Method

ItemCollectionBase(T).RaiseInserting Method
[image]

Raises the Inserting event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseInserting (
DiagramItem item,
int index
)

Visual Basic [image] Copy Code

Protected Sub RaiseInserting( _
item As DiagramItem, _
index As Integer _
)

Parameters

item

The diagram item that is being inserted.

index

Index of the new item.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).RaiseRemoving Method

ItemCollectionBase(T).RaiseRemoving Method
[image]

Raises the Removing event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void RaiseRemoving (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected Sub RaiseRemoving( _
item As DiagramItem _
)

Parameters

item

The diagram item that is being removed.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).Remove Method

ItemCollectionBase(T).Remove Method
[image]

Removes the diagram item from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Remove (
T item
)

Visual Basic [image] Copy Code

Public Overrides Function Remove( _
item As T _
) As Boolean

Parameters

item

The DiagramItem object to remove from the collection.

Return Value

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemCollectionBase(T).RemoveAt Method

ItemCollectionBase(T).RemoveAt Method
[image]

Removes the diagram item from the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Overrides Sub RemoveAt( _
index As Integer _
)

Parameters

index

Index of the object that should be removed from this collection.

See Also

ItemCollectionBase(T) Members
ItemCollectionBase(T) Class


MindFusion.Diagramming.ItemEventArgs Class

ItemEventArgs Class
[image]

Contains the arguments passed to item instantiation event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class ItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.ItemEventArgs

See Also

ItemEventArgs Members


MindFusion.Diagramming.ItemEventArgs Members

ItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to item instantiation event handlers.

The following tables list the members exposed by the ItemEventArgs type.

Public Constructors

Name | Description
ItemEventArgs | Initializes a new instance of the ItemEventArgs class.

Public Properties

Name | Description
Index | Gets an integer index related to the event.
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs Constructor

ItemEventArgs Constructor
[image]

Initializes a new instance of the ItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ItemEventArgs (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem related to the event.

See Also

ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs Properties

ItemEventArgs Properties
[image]

Public Properties

Name | Description
Index | Gets an integer index related to the event.
Item | Gets the item for which the event is raised.

See Also

ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs.Index Property

ItemEventArgs.Index Property
[image]

Gets an integer index related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Index As Integer

Property Value

An integer value specifying the item's position within its containing collection.

See Also

ItemEventArgs Members
ItemEventArgs Class


MindFusion.Diagramming.ItemEventArgs.Item Property

ItemEventArgs.Item Property
[image]

Gets the item for which the event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

ItemEventArgs Members
ItemEventArgs Class


MindFusion.Diagramming.ItemLabel Class

ItemLabel Class
[image]

The base class for node and link labels.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ItemLabel : InplaceEditable

Visual Basic [image] Copy Code

Public Class ItemLabel
Implements InplaceEditable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ItemLabel
MindFusion.Diagramming.LinkLabel
MindFusion.Diagramming.NodeLabel

See Also

ItemLabel Members


MindFusion.Diagramming.ItemLabel Members

ItemLabel Members
Constructors Properties Methods
[image]

The base class for node and link labels.

The following tables list the members exposed by the ItemLabel type.

Public Constructors

Name | Description
ItemLabel | Overloaded.

Public Properties

Name | Description
Brush | Gets or sets the brush used to draw the label's background.
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped.
Font | Gets or sets the label's font.
HorizontalAlign | Gets or sets the label's horizontal alignment.
HorizontalOffset | Gets or sets the label's horizontal offset.
Index | Gets or sets the index of the edge or corner point this label is relative to.
Item | Gets or sets the DiagramItem that displays this label.
Margin | Gets or sets the label's margin.
MaxWidth | Gets or sets the maximum width of the label.
Text | Gets or sets the label's text.
TextBrush | Gets or sets the brush used to draw the label's text.
VerticalAlign | Gets or sets the label's vertical alignment.
VerticalOffset | Gets or sets the label's vertical offset.

Public Methods

Name | Description
Cancel | Called when drag operation is canceled.
Draw | Draws the label on the specified IGraphics surface.
GetEditRect | InplaceEditable.GetEditRect implementation.
GetTextToEdit | InplaceEditable.GetTextToEdit implementation.
LoadFromXml | Loads the label from the specified XML element.
OnTouchDown | Called when the left mouse button is pressed while the pointer is over this label.
OnTouchMove | Called when the mouse is moved while this label tracks the mouse events.
OnTouchUp | Called when the left mouse button is released while this label tracks the mouse events.
SaveToXml | Saves the label into the specified XML element.
SetEditedText | InplaceEditable.SetEditedText implementation.
UpdateValue | Called while drag operation is in progress.

Protected Methods

Name | Description
LoadFromJson | Loads the label from a JsonObject.
SaveToJson | Saves the label into a JsonObject.

See Also

ItemLabel Class


MindFusion.Diagramming.ItemLabel Constructor

ItemLabel Constructor
[image]

Overload List

Name | Description
ItemLabel () | Initializes a new instance of the ItemLabel class.
ItemLabel (DiagramItem) | Initializes a new instance of the ItemLabel class.

See Also

ItemLabel Class


MindFusion.Diagramming.ItemLabel Constructor ()

ItemLabel Constructor ()
See Also
[image]

Initializes a new instance of the ItemLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ItemLabel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ItemLabel Constructor Overload List
ItemLabel Class


MindFusion.Diagramming.ItemLabel Constructor (DiagramItem)

ItemLabel Constructor (DiagramItem)
See Also
[image]

Initializes a new instance of the ItemLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ItemLabel (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

The DiagramItem that displays the label.

See Also

ItemLabel Constructor Overload List
ItemLabel Class


MindFusion.Diagramming.ItemLabel Methods

ItemLabel Methods
[image]

Public Methods

Name | Description
Cancel | Called when drag operation is canceled.
Draw | Draws the label on the specified IGraphics surface.
GetEditRect | InplaceEditable.GetEditRect implementation.
GetTextToEdit | InplaceEditable.GetTextToEdit implementation.
LoadFromXml | Loads the label from the specified XML element.
OnTouchDown | Called when the left mouse button is pressed while the pointer is over this label.
OnTouchMove | Called when the mouse is moved while this label tracks the mouse events.
OnTouchUp | Called when the left mouse button is released while this label tracks the mouse events.
SaveToXml | Saves the label into the specified XML element.
SetEditedText | InplaceEditable.SetEditedText implementation.
UpdateValue | Called while drag operation is in progress.

Protected Methods

Name | Description
LoadFromJson | Loads the label from a JsonObject.
SaveToJson | Saves the label into a JsonObject.

See Also

ItemLabel Class


MindFusion.Diagramming.ItemLabel.Cancel Method

ItemLabel.Cancel Method
[image]

Called when drag operation is canceled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void Cancel ()

Visual Basic [image] Copy Code

Public Overridable Sub Cancel ()

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.Draw Method

ItemLabel.Draw Method
[image]

Draws the label on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void Draw (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overridable Sub Draw( _
graphics As IGraphics _
)

Parameters

graphics

An IGraphics object where the label should be rendered.

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.GetEditRect Method

ItemLabel.GetEditRect Method
[image]

InplaceEditable.GetEditRect implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetEditRect (
DiagramItem item,
Point mousePosition
)

Visual Basic [image] Copy Code

Public Function GetEditRect( _
item As DiagramItem, _
mousePosition As Point _
) As Rect

Parameters

item

mousePosition

Return Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.GetTextToEdit Method

ItemLabel.GetTextToEdit Method
[image]

InplaceEditable.GetTextToEdit implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string GetTextToEdit ()

Visual Basic [image] Copy Code

Public Function GetTextToEdit () As String

Return Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.LoadFromJson Method

ItemLabel.LoadFromJson Method
[image]

Loads the label from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the label's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.LoadFromXml Method

ItemLabel.LoadFromXml Method
[image]

Loads the label from the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Overridable Sub LoadFromXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement instance.

context

An XmlPersistContext instance.

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.OnTouchDown Method

ItemLabel.OnTouchDown Method
[image]

Called when the left mouse button is pressed while the pointer is over this label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnTouchDown (
Point mousePosition
)

Visual Basic [image] Copy Code

Public Overridable Sub OnTouchDown( _
mousePosition As Point _
)

Parameters

mousePosition

A PointF instance that specifies the current mouse position.

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.OnTouchMove Method

ItemLabel.OnTouchMove Method
[image]

Called when the mouse is moved while this label tracks the mouse events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnTouchMove (
Point mousePosition
)

Visual Basic [image] Copy Code

Public Overridable Sub OnTouchMove( _
mousePosition As Point _
)

Parameters

mousePosition

A PointF instance that specifies the current mouse position.

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.OnTouchUp Method

ItemLabel.OnTouchUp Method
[image]

Called when the left mouse button is released while this label tracks the mouse events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnTouchUp (
Point mousePosition
)

Visual Basic [image] Copy Code

Public Overridable Sub OnTouchUp( _
mousePosition As Point _
)

Parameters

mousePosition

A PointF instance that specifies the current mouse position.

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.SaveToJson Method

ItemLabel.SaveToJson Method
[image]

Saves the label into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the label's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.SaveToXml Method

ItemLabel.SaveToXml Method
[image]

Saves the label into the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Task SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Overridable Function SaveToXml( _
xmlElement As XElement, _
context As XmlPersistContext _
) As Task

Parameters

xmlElement

An XmlElement instance.

context

An XmlPersistContext instance.

Return Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.SetEditedText Method

ItemLabel.SetEditedText Method
[image]

InplaceEditable.SetEditedText implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetEditedText (
string newText
)

Visual Basic [image] Copy Code

Public Sub SetEditedText( _
newText As String _
)

Parameters

newText

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.UpdateValue Method

ItemLabel.UpdateValue Method
[image]

Called while drag operation is in progress.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void UpdateValue (
Point current
)

Visual Basic [image] Copy Code

Public Overridable Sub UpdateValue( _
current As Point _
)

Parameters

current

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel Properties

ItemLabel Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to draw the label's background.
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped.
Font | Gets or sets the label's font.
HorizontalAlign | Gets or sets the label's horizontal alignment.
HorizontalOffset | Gets or sets the label's horizontal offset.
Index | Gets or sets the index of the edge or corner point this label is relative to.
Item | Gets or sets the DiagramItem that displays this label.
Margin | Gets or sets the label's margin.
MaxWidth | Gets or sets the maximum width of the label.
Text | Gets or sets the label's text.
TextBrush | Gets or sets the brush used to draw the label's text.
VerticalAlign | Gets or sets the label's vertical alignment.
VerticalOffset | Gets or sets the label's vertical offset.

See Also

ItemLabel Class


MindFusion.Diagramming.ItemLabel.Brush Property

ItemLabel.Brush Property
[image]

Gets or sets the brush used to draw the label's background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.EnableWrap Property

ItemLabel.EnableWrap Property
[image]

Gets or sets a value indicating whether the label's text can be wrapped.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableWrap { get; set; }

Visual Basic [image] Copy Code

Public Property EnableWrap As Boolean

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.Font Property

ItemLabel.Font Property
[image]

Gets or sets the label's font.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Font> Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Nullable(Of Font)

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.HorizontalAlign Property

ItemLabel.HorizontalAlign Property
[image]

Gets or sets the label's horizontal alignment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HorizontalAlignment HorizontalAlign { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalAlign As HorizontalAlignment

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.HorizontalOffset Property

ItemLabel.HorizontalOffset Property
[image]

Gets or sets the label's horizontal offset.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HorizontalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalOffset As Double

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.Index Property

ItemLabel.Index Property
[image]

Gets or sets the index of the edge or corner point this label is relative to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.Item Property

ItemLabel.Item Property
[image]

Gets or sets the DiagramItem that displays this label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As DiagramItem

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.Margin Property

ItemLabel.Margin Property
[image]

Gets or sets the label's margin.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness Margin { get; set; }

Visual Basic [image] Copy Code

Public Property Margin As Thickness

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.MaxWidth Property

ItemLabel.MaxWidth Property
[image]

Gets or sets the maximum width of the label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MaxWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MaxWidth As Double

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.Text Property

ItemLabel.Text Property
[image]

Gets or sets the label's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.TextBrush Property

ItemLabel.TextBrush Property
[image]

Gets or sets the brush used to draw the label's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.VerticalAlign Property

ItemLabel.VerticalAlign Property
[image]

Gets or sets the label's vertical alignment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VerticalAlignment VerticalAlign { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalAlign As VerticalAlignment

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.ItemLabel.VerticalOffset Property

ItemLabel.VerticalOffset Property
[image]

Gets or sets the label's vertical offset.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double VerticalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalOffset As Double

Property Value

See Also

ItemLabel Members
ItemLabel Class


MindFusion.Diagramming.JsonOptions Class

JsonOptions Class
[image]

Defines properties used to customize the JSON serialization process.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class JsonOptions

Visual Basic [image] Copy Code

Public Class JsonOptions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.JsonOptions

See Also

JsonOptions Members


MindFusion.Diagramming.JsonOptions Members

JsonOptions Members
Constructors Properties
[image]

Defines properties used to customize the JSON serialization process.

The following tables list the members exposed by the JsonOptions type.

Public Constructors

Name | Description
JsonOptions | Initializes a new instance of the JsonOptions class.

Public Properties

Name | Description
SerializeImages | Gets or sets whether the ShapeNode images should be serialized.

See Also

JsonOptions Class


MindFusion.Diagramming.JsonOptions Constructor

JsonOptions Constructor
[image]

Initializes a new instance of the JsonOptions class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

JsonOptions Class


MindFusion.Diagramming.JsonOptions Properties

JsonOptions Properties
[image]

Public Properties

Name | Description
SerializeImages | Gets or sets whether the ShapeNode images should be serialized.

See Also

JsonOptions Class


MindFusion.Diagramming.JsonOptions.SerializeImages Property

JsonOptions.SerializeImages Property
[image]

Gets or sets whether the ShapeNode images should be serialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SerializeImages { get; set; }

Visual Basic [image] Copy Code

Public Property SerializeImages As Boolean

Property Value

See Also

JsonOptions Members
JsonOptions Class


MindFusion.Diagramming.JsonPersistContext Class

JsonPersistContext Class
[image]

Contains methods that can help you serialize and deserialize MindFusion.Diagramming items to and from JSON.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class JsonPersistContext : JsonContext

Visual Basic [image] Copy Code

Public Class JsonPersistContext
Inherits JsonContext

Inheritance Hierarchy

System.Object
MindFusion.Json.JsonContext
MindFusion.Diagramming.JsonPersistContext

See Also

JsonPersistContext Members


MindFusion.Diagramming.JsonPersistContext Members

JsonPersistContext Members
Constructors Fields Properties Methods
[image]

Contains methods that can help you serialize and deserialize MindFusion.Diagramming items to and from JSON.

The following tables list the members exposed by the JsonPersistContext type.

Public Constructors

Name | Description
JsonPersistContext | Overloaded.

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

Protected Fields

Name | Description
brushes | A list of all brushes. (Inherited from JsonContext.)
inplaceImages | Specifies whether images are encoded in place. (Inherited from JsonContext.)
inplaceResources | Specifies whether resource accumulation is disabled. (Inherited from JsonContext.)

Public Properties

Name | Description
Diagram | Gets the underlying diagram object.
FileVersion | Gets the format revision number for the file being currently serialized.
JsonOptions | A JsonOptions object providing properties for customizing the JSON serialization process.

Public Methods

Name | Description
LoadItem | Reads a diagram item from the specified JsonObject.
Parse | Deserializes the specified JSON formatted string to a JsonObject. (Inherited from JsonContext.)
ReadAnchorPattern | Reads an AnchorPattern object.
ReadBrush | Overloaded. (Inherited from JsonContext.)
ReadBrushColor | Reads a Brush object with the specified color. (Inherited from JsonContext.)
ReadBrushes | Reads all brushes. (Inherited from JsonContext.)
ReadColor | Overloaded. (Inherited from JsonContext.)
ReadColorBlend | Overloaded. (Inherited from JsonContext.)
ReadEffect | Reads a NodeEffect object.
ReadEnum | Reads an enum value. (Inherited from JsonContext.)
ReadFloatArray | Reads a float array. (Inherited from JsonContext.)
ReadFont | Reads a Font object.
ReadImage | Reads an Image object. (Inherited from JsonContext.)
ReadImages | Reads all images. (Inherited from JsonContext.)
ReadItemId | Reads an item reference.
ReadObject | Reads an object. (Inherited from JsonContext.)
ReadPen | Overloaded. (Inherited from JsonContext.)
ReadPoint | Reads a PointF object. (Inherited from JsonContext.)
ReadPointString | Reads a Point string. (Inherited from JsonContext.)
ReadRectangle | Reads a RectangleF object. (Inherited from JsonContext.)
ReadShape | Reads a Shape object.
ReadSize | Reads a SizeF object. (Inherited from JsonContext.)
ReadStringFormat | Reads a StringFormat object. (Inherited from JsonContext.)
ReadStyle | Reads a Style object.
ReadTag | Reads the specified tag for the specified object.
ReadTheme | Reads a Theme object.
ReadThickness | Reads a Thickness object.
SaveItem | Saves the specified diagram item to a JsonObject.
Serialize | Serializes the specified JsonObject to a JSON formatted string. (Inherited from JsonContext.)
WriteAnchorPattern | Writes an AnchorPattern object.
WriteBrush | Writes a MindFusion.Drawing.Brush object. (Inherited from JsonContext.)
WriteBrushColor | Writes the color of the specified brush. (Inherited from JsonContext.)
WriteBrushes | Writes all currently accumulated brushes. (Inherited from JsonContext.)
WriteColor | Writes a Color object. (Inherited from JsonContext.)
WriteColorBlend | Overloaded. (Inherited from JsonContext.)
WriteEffect | Writes a NodeEffect object.
WriteEnum | Writes an enum value. (Inherited from JsonContext.)
WriteFont | Writes a Font object.
WriteImage | Writes an Image object. (Inherited from JsonContext.)
WriteImageAsync | Writes an Image object. (Inherited from JsonContext.)
WriteImages | Writes all currently accumulated images. (Inherited from JsonContext.)
WriteImagesAsync | Writes all currently accumulated images asynchronously. (Inherited from JsonContext.)
WriteItemId | Writes a reference to the specified item.
WriteItemType | Writes an item type.
WriteObject | Writes an object. (Inherited from JsonContext.)
WritePen | Writes a MindFusion.Drawing.Pen object. (Inherited from JsonContext.)
WritePoint | Writes a PointF object. (Inherited from JsonContext.)
WritePointString | Writes a Point string. (Inherited from JsonContext.)
WriteRectangle | Writes a RectangleF object. (Inherited from JsonContext.)
WriteShape | Writes a Shape object.
WriteSize | Writes a SizeF object. (Inherited from JsonContext.)
WriteStringFormat | Writes a StringFormat object. (Inherited from JsonContext.)
WriteStyle | Writes a Style object.
WriteTag | Writes the specified tag of the specified object.
WriteTheme | Writes a Theme object.
WriteThickness | Writes a Thickness object.

Protected Methods

Name | Description
Base64Decode | Decodes a string from Base64 representation. (Inherited from JsonContext.)
Base64Encode | Encodes a string to Base64 representation. (Inherited from JsonContext.)
ToCamelCase | Converts a string to Pascal case. (Inherited from JsonContext.)
ToPascalCase | Converts a string to Camel case. (Inherited from JsonContext.)

See Also

JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext Fields

JsonPersistContext Fields
[image]

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

Protected Fields

Name | Description
brushes | A list of all brushes. (Inherited from JsonContext.)
inplaceImages | Specifies whether images are encoded in place. (Inherited from JsonContext.)
inplaceResources | Specifies whether resource accumulation is disabled. (Inherited from JsonContext.)

See Also

JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.LatestFormat Field

JsonPersistContext.LatestFormat Field
[image]

Specifies the latest file format revision number.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int LatestFormat

Visual Basic [image] Copy Code

Public Shared LatestFormat As Integer

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext Constructor

JsonPersistContext Constructor
[image]

Overload List

Name | Description
JsonPersistContext (Diagram, Int32) | Initializes a new instance of the JsonPersistContext class.
JsonPersistContext (Diagram, Int32, Boolean) | Initializes a new instance of the JsonPersistContext class.

See Also

JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext Constructor (Diagram, Int32)

JsonPersistContext Constructor (Diagram, Int32)
See Also
[image]

Initializes a new instance of the JsonPersistContext class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonPersistContext (
Diagram diagram,
int fileVersion
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
fileVersion As Integer _
)

Parameters

diagram

The Diagram that will be serialized or deserialized.

fileVersion

Specifies the current file format number.

See Also

JsonPersistContext Constructor Overload List
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext Constructor (Diagram, Int32, Boolean)

JsonPersistContext Constructor (Diagram, Int32, Boolean)
See Also
[image]

Initializes a new instance of the JsonPersistContext class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonPersistContext (
Diagram diagram,
int fileVersion,
bool trackItems
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
fileVersion As Integer, _
trackItems As Boolean _
)

Parameters

diagram

The Diagram that will be serialized or deserialized.

fileVersion

Specifies the current file format number.

trackItems

true to track shared item instances by their identifier, or false otherwise.

See Also

JsonPersistContext Constructor Overload List
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext Methods

JsonPersistContext Methods
[image]

Public Methods

Name | Description
LoadItem | Reads a diagram item from the specified JsonObject.
Parse | Deserializes the specified JSON formatted string to a JsonObject. (Inherited from JsonContext.)
ReadAnchorPattern | Reads an AnchorPattern object.
ReadBrush | Overloaded. (Inherited from JsonContext.)
ReadBrushColor | Reads a Brush object with the specified color. (Inherited from JsonContext.)
ReadBrushes | Reads all brushes. (Inherited from JsonContext.)
ReadColor | Overloaded. (Inherited from JsonContext.)
ReadColorBlend | Overloaded. (Inherited from JsonContext.)
ReadEffect | Reads a NodeEffect object.
ReadEnum | Reads an enum value. (Inherited from JsonContext.)
ReadFloatArray | Reads a float array. (Inherited from JsonContext.)
ReadFont | Reads a Font object.
ReadImage | Reads an Image object. (Inherited from JsonContext.)
ReadImages | Reads all images. (Inherited from JsonContext.)
ReadItemId | Reads an item reference.
ReadObject | Reads an object. (Inherited from JsonContext.)
ReadPen | Overloaded. (Inherited from JsonContext.)
ReadPoint | Reads a PointF object. (Inherited from JsonContext.)
ReadPointString | Reads a Point string. (Inherited from JsonContext.)
ReadRectangle | Reads a RectangleF object. (Inherited from JsonContext.)
ReadShape | Reads a Shape object.
ReadSize | Reads a SizeF object. (Inherited from JsonContext.)
ReadStringFormat | Reads a StringFormat object. (Inherited from JsonContext.)
ReadStyle | Reads a Style object.
ReadTag | Reads the specified tag for the specified object.
ReadTheme | Reads a Theme object.
ReadThickness | Reads a Thickness object.
SaveItem | Saves the specified diagram item to a JsonObject.
Serialize | Serializes the specified JsonObject to a JSON formatted string. (Inherited from JsonContext.)
WriteAnchorPattern | Writes an AnchorPattern object.
WriteBrush | Writes a MindFusion.Drawing.Brush object. (Inherited from JsonContext.)
WriteBrushColor | Writes the color of the specified brush. (Inherited from JsonContext.)
WriteBrushes | Writes all currently accumulated brushes. (Inherited from JsonContext.)
WriteColor | Writes a Color object. (Inherited from JsonContext.)
WriteColorBlend | Overloaded. (Inherited from JsonContext.)
WriteEffect | Writes a NodeEffect object.
WriteEnum | Writes an enum value. (Inherited from JsonContext.)
WriteFont | Writes a Font object.
WriteImage | Writes an Image object. (Inherited from JsonContext.)
WriteImageAsync | Writes an Image object. (Inherited from JsonContext.)
WriteImages | Writes all currently accumulated images. (Inherited from JsonContext.)
WriteImagesAsync | Writes all currently accumulated images asynchronously. (Inherited from JsonContext.)
WriteItemId | Writes a reference to the specified item.
WriteItemType | Writes an item type.
WriteObject | Writes an object. (Inherited from JsonContext.)
WritePen | Writes a MindFusion.Drawing.Pen object. (Inherited from JsonContext.)
WritePoint | Writes a PointF object. (Inherited from JsonContext.)
WritePointString | Writes a Point string. (Inherited from JsonContext.)
WriteRectangle | Writes a RectangleF object. (Inherited from JsonContext.)
WriteShape | Writes a Shape object.
WriteSize | Writes a SizeF object. (Inherited from JsonContext.)
WriteStringFormat | Writes a StringFormat object. (Inherited from JsonContext.)
WriteStyle | Writes a Style object.
WriteTag | Writes the specified tag of the specified object.
WriteTheme | Writes a Theme object.
WriteThickness | Writes a Thickness object.

Protected Methods

Name | Description
Base64Decode | Decodes a string from Base64 representation. (Inherited from JsonContext.)
Base64Encode | Encodes a string to Base64 representation. (Inherited from JsonContext.)
ToCamelCase | Converts a string to Pascal case. (Inherited from JsonContext.)
ToPascalCase | Converts a string to Camel case. (Inherited from JsonContext.)

See Also

JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.LoadItem Method

JsonPersistContext.LoadItem Method
[image]

Reads a diagram item from the specified JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem LoadItem (
JsonObject obj
)

Visual Basic [image] Copy Code

Public Function LoadItem( _
obj As JsonObject _
) As DiagramItem

Parameters

obj

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.ReadAnchorPattern Method

JsonPersistContext.ReadAnchorPattern Method
[image]

Reads an AnchorPattern object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern ReadAnchorPattern (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadAnchorPattern( _
value As JsonValue _
) As AnchorPattern

Parameters

value

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.ReadEffect Method

JsonPersistContext.ReadEffect Method
[image]

Reads a NodeEffect object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEffect ReadEffect (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
value As JsonValue _
) As NodeEffect

Parameters

value

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.ReadFont Method

JsonPersistContext.ReadFont Method
[image]

Reads a Font object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Font ReadFont (
JsonObject obj,
Font defaultFont
)

Visual Basic [image] Copy Code

Public Overrides Function ReadFont( _
obj As JsonObject, _
defaultFont As Font _
) As Font

Parameters

obj

defaultFont

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.ReadItemId Method

JsonPersistContext.ReadItemId Method
[image]

Reads an item reference.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem ReadItemId (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadItemId( _
value As JsonValue _
) As DiagramItem

Parameters

value

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.ReadShape Method

JsonPersistContext.ReadShape Method
[image]

Reads a Shape object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape ReadShape (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadShape( _
value As JsonValue _
) As Shape

Parameters

value

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.ReadStyle Method

JsonPersistContext.ReadStyle Method
[image]

Reads a Style object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReadStyle (
JsonValue value,
Style style
)

Visual Basic [image] Copy Code

Public Sub ReadStyle( _
value As JsonValue, _
style As Style _
)

Parameters

value

style

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.ReadTag Method

JsonPersistContext.ReadTag Method
[image]

Reads the specified tag for the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadTag (
Object item,
JsonValue tagValue,
string propertyName
)

Visual Basic [image] Copy Code

Public Function ReadTag( _
item As Object, _
tagValue As JsonValue, _
propertyName As String _
) As Object

Parameters

item

tagValue

propertyName

Return Value

Remarks

Tags are read similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom deserialization through event handling.

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.ReadTheme Method

JsonPersistContext.ReadTheme Method
[image]

Reads a Theme object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme ReadTheme (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadTheme( _
value As JsonValue _
) As Theme

Parameters

value

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.ReadThickness Method

JsonPersistContext.ReadThickness Method
[image]

Reads a Thickness object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness ReadThickness (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadThickness( _
value As JsonValue _
) As Thickness

Parameters

value

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.SaveItem Method

JsonPersistContext.SaveItem Method
[image]

Saves the specified diagram item to a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<JsonObject> SaveItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function SaveItem( _
item As DiagramItem _
) As Task(Of JsonObject)

Parameters

item

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.WriteAnchorPattern Method

JsonPersistContext.WriteAnchorPattern Method
[image]

Writes an AnchorPattern object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonValue WriteAnchorPattern (
AnchorPattern anchorPattern
)

Visual Basic [image] Copy Code

Public Function WriteAnchorPattern( _
anchorPattern As AnchorPattern _
) As JsonValue

Parameters

anchorPattern

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.WriteEffect Method

JsonPersistContext.WriteEffect Method
[image]

Writes a NodeEffect object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonValue WriteEffect (
NodeEffect effect
)

Visual Basic [image] Copy Code

Public Function WriteEffect( _
effect As NodeEffect _
) As JsonValue

Parameters

effect

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.WriteFont Method

JsonPersistContext.WriteFont Method
[image]

Writes a Font object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override JsonObject WriteFont (
Nullable<Font> font
)

Visual Basic [image] Copy Code

Public Overrides Function WriteFont( _
font As Nullable(Of Font) _
) As JsonObject

Parameters

font

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.WriteItemId Method

JsonPersistContext.WriteItemId Method
[image]

Writes a reference to the specified item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonValue WriteItemId (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function WriteItemId( _
item As DiagramItem _
) As JsonValue

Parameters

item

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.WriteItemType Method

JsonPersistContext.WriteItemType Method
[image]

Writes an item type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonValue WriteItemType (
Type itemType
)

Visual Basic [image] Copy Code

Public Function WriteItemType( _
itemType As Type _
) As JsonValue

Parameters

itemType

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.WriteShape Method

JsonPersistContext.WriteShape Method
[image]

Writes a Shape object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonValue WriteShape (
Shape shape
)

Visual Basic [image] Copy Code

Public Function WriteShape( _
shape As Shape _
) As JsonValue

Parameters

shape

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.WriteStyle Method

JsonPersistContext.WriteStyle Method
[image]

Writes a Style object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonValue WriteStyle (
Style style
)

Visual Basic [image] Copy Code

Public Function WriteStyle( _
style As Style _
) As JsonValue

Parameters

style

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.WriteTag Method

JsonPersistContext.WriteTag Method
[image]

Writes the specified tag of the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonValue WriteTag (
Object item,
Object tagValue,
string propertyName
)

Visual Basic [image] Copy Code

Public Function WriteTag( _
item As Object, _
tagValue As Object, _
propertyName As String _
) As JsonValue

Parameters

item

tagValue

propertyName

Return Value

Remarks

Tags are written similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom serialization through event handling.

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.WriteTheme Method

JsonPersistContext.WriteTheme Method
[image]

Writes a Theme object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonObject WriteTheme (
Theme theme
)

Visual Basic [image] Copy Code

Public Function WriteTheme( _
theme As Theme _
) As JsonObject

Parameters

theme

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.WriteThickness Method

JsonPersistContext.WriteThickness Method
[image]

Writes a Thickness object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonObject WriteThickness (
Thickness thickness
)

Visual Basic [image] Copy Code

Public Function WriteThickness( _
thickness As Thickness _
) As JsonObject

Parameters

thickness

Return Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext Properties

JsonPersistContext Properties
[image]

Public Properties

Name | Description
Diagram | Gets the underlying diagram object.
FileVersion | Gets the format revision number for the file being currently serialized.
JsonOptions | A JsonOptions object providing properties for customizing the JSON serialization process.

See Also

JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.Diagram Property

JsonPersistContext.Diagram Property
[image]

Gets the underlying diagram object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diagram As Diagram

Property Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.FileVersion Property

JsonPersistContext.FileVersion Property
[image]

Gets the format revision number for the file being currently serialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonPersistContext.JsonOptions Property

JsonPersistContext.JsonOptions Property
[image]

A JsonOptions object providing properties for customizing the JSON serialization process.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonOptions JsonOptions { get; set; }

Visual Basic [image] Copy Code

Public Property JsonOptions As JsonOptions

Property Value

See Also

JsonPersistContext Members
JsonPersistContext Class


MindFusion.Diagramming.JsonSerializeTagEventArgs Class

JsonSerializeTagEventArgs Class
[image]

Contains the arguments passed to the JsonSerializeTag and JsonDeserializeTag event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class JsonSerializeTagEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class JsonSerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.JsonSerializeTagEventArgs

See Also

JsonSerializeTagEventArgs Members


MindFusion.Diagramming.JsonSerializeTagEventArgs Members

JsonSerializeTagEventArgs Members
Properties
[image]

Contains the arguments passed to the JsonSerializeTag and JsonDeserializeTag event handlers.

The following tables list the members exposed by the JsonSerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the object being serialized/deserialized.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets the JsonObject, representing the tag object being serialized / deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

JsonSerializeTagEventArgs Class


MindFusion.Diagramming.JsonSerializeTagEventArgs Properties

JsonSerializeTagEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the object being serialized/deserialized.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets the JsonObject, representing the tag object being serialized / deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

JsonSerializeTagEventArgs Class


MindFusion.Diagramming.JsonSerializeTagEventArgs.Context Property

JsonSerializeTagEventArgs.Context Property
[image]

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonPersistContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As JsonPersistContext

Property Value

See Also

JsonSerializeTagEventArgs Members
JsonSerializeTagEventArgs Class


MindFusion.Diagramming.JsonSerializeTagEventArgs.Handled Property

JsonSerializeTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

JsonSerializeTagEventArgs Members
JsonSerializeTagEventArgs Class


MindFusion.Diagramming.JsonSerializeTagEventArgs.Object Property

JsonSerializeTagEventArgs.Object Property
[image]

Gets the object being serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Object { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Object As Object

Property Value

See Also

JsonSerializeTagEventArgs Members
JsonSerializeTagEventArgs Class


MindFusion.Diagramming.JsonSerializeTagEventArgs.PropertyName Property

JsonSerializeTagEventArgs.PropertyName Property
[image]

Gets the name of the property being serialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string PropertyName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PropertyName As String

Property Value

See Also

JsonSerializeTagEventArgs Members
JsonSerializeTagEventArgs Class


MindFusion.Diagramming.JsonSerializeTagEventArgs.Representation Property

JsonSerializeTagEventArgs.Representation Property
[image]

Gets or sets the JsonObject, representing the tag object being serialized / deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public JsonObject Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As JsonObject

Property Value

See Also

JsonSerializeTagEventArgs Members
JsonSerializeTagEventArgs Class


MindFusion.Diagramming.JsonSerializeTagEventArgs.Tag Property

JsonSerializeTagEventArgs.Tag Property
[image]

Gets or sets the tag object being serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

See Also

JsonSerializeTagEventArgs Members
JsonSerializeTagEventArgs Class


MindFusion.Diagramming.Layer Class

Layer Class
[image]

Represents a layer in a Diagram object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Layer : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public Class Layer
Implements INotifyPropertyChanged

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layer

See Also

Layer Members


MindFusion.Diagramming.Layer Members

Layer Members
Constructors Properties Methods Events
[image]

Represents a layer in a Diagram object.

The following tables list the members exposed by the Layer type.

Public Constructors

Name | Description
Layer | Initializes a new instance of the Layer class.

Public Properties

Name | Description
Locked | Gets or sets a value indicating whether the layer is locked.
Title | Gets or sets a title associated with the layer.
Visible | Gets or sets a value indicating whether the layer is visible.
ZIndex | Gets or sets the z-index of the layer.

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Layer Class


MindFusion.Diagramming.Layer Constructor

Layer Constructor
[image]

Initializes a new instance of the Layer class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Layer Class


MindFusion.Diagramming.Layer Methods

Layer Methods
[image]

Protected Methods

Name | Description
OnPropertyChanged | Raises the PropertyChanged event.

See Also

Layer Class


MindFusion.Diagramming.Layer.OnPropertyChanged Method

Layer.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
PropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As PropertyChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer Properties

Layer Properties
[image]

Public Properties

Name | Description
Locked | Gets or sets a value indicating whether the layer is locked.
Title | Gets or sets a title associated with the layer.
Visible | Gets or sets a value indicating whether the layer is visible.
ZIndex | Gets or sets the z-index of the layer.

See Also

Layer Class


MindFusion.Diagramming.Layer.Locked Property

Layer.Locked Property
[image]

Gets or sets a value indicating whether the layer is locked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Locked { get; set; }

Visual Basic [image] Copy Code

Public Property Locked As Boolean

Property Value

true if the layer is locked; otherwise, false.

Remarks

Items associated with locked layers cannot be modified interactively, regardless of their own Locked property.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.Title Property

Layer.Title Property
[image]

Gets or sets a title associated with the layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string value.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.Visible Property

Layer.Visible Property
[image]

Gets or sets a value indicating whether the layer is visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Visible { get; set; }

Visual Basic [image] Copy Code

Public Property Visible As Boolean

Property Value

true if the layer is visible; otherwise, false.

Remarks

Items associated with hidden layers are not displayed, regardless of their own Visible property.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer.ZIndex Property

Layer.ZIndex Property
[image]

Gets or sets the z-index of the layer.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ZIndex { get; set; }

Visual Basic [image] Copy Code

Public Property ZIndex As Integer

Property Value

An integer value.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.Layer Events

Layer Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

Layer Class


MindFusion.Diagramming.Layer.PropertyChanged Event

Layer.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

Layer Members
Layer Class


MindFusion.Diagramming.LayerEventArgs Class

LayerEventArgs Class
[image]

Contains the arguments passed to the LayerVisibilityChanged event handler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LayerEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class LayerEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LayerEventArgs

See Also

LayerEventArgs Members


MindFusion.Diagramming.LayerEventArgs Members

LayerEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the LayerVisibilityChanged event handler.

The following tables list the members exposed by the LayerEventArgs type.

Public Constructors

Name | Description
LayerEventArgs | Initializes a new instance of the LayerEventArgs class.

Public Properties

Name | Description
Index | Gets or sets the layer index related to the current event.
Layer | Gets or sets the Layer related to the current event.

See Also

LayerEventArgs Class


MindFusion.Diagramming.LayerEventArgs Constructor

LayerEventArgs Constructor
[image]

Initializes a new instance of the LayerEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayerEventArgs (
Layer layer,
int index
)

Visual Basic [image] Copy Code

Public New ( _
layer As Layer, _
index As Integer _
)

Parameters

layer

index

See Also

LayerEventArgs Class


MindFusion.Diagramming.LayerEventArgs Properties

LayerEventArgs Properties
[image]

Public Properties

Name | Description
Index | Gets or sets the layer index related to the current event.
Layer | Gets or sets the Layer related to the current event.

See Also

LayerEventArgs Class


MindFusion.Diagramming.LayerEventArgs.Index Property

LayerEventArgs.Index Property
[image]

Gets or sets the layer index related to the current event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value.

See Also

LayerEventArgs Members
LayerEventArgs Class


MindFusion.Diagramming.LayerEventArgs.Layer Property

LayerEventArgs.Layer Property
[image]

Gets or sets the Layer related to the current event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Layer Layer { get; set; }

Visual Basic [image] Copy Code

Public Property Layer As Layer

Property Value

An instance of the Layer class.

See Also

LayerEventArgs Members
LayerEventArgs Class


MindFusion.Diagramming.LineTemplate Class

LineTemplate Class
[image]

Represents a line segment in a shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LineTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class LineTemplate
Inherits ElementTemplate

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.LineTemplate

See Also

LineTemplate Members


MindFusion.Diagramming.LineTemplate Members

LineTemplate Members
Constructors Properties Methods
[image]

Represents a line segment in a shape definition.

The following tables list the members exposed by the LineTemplate type.

Public Constructors

Name | Description
LineTemplate | Overloaded. Initializes a new instance of the LineTemplate class.

Public Properties

Name | Description
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a double array containing the coordinates of the end points of this line segment.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Create an exact copy of this LineTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate Constructor

LineTemplate Constructor
[image]

Initializes a new instance of the LineTemplate class.

Overload List

Name | Description
LineTemplate (Double, Double, Double, Double) | Initializes a new instance of the LineTemplate class with the specified start and end point.
LineTemplate (Double, Double, Double, Double, Color, DashStyle, Double) | Initializes a new instance of the LineTemplate class with the specified start and end points, and the specified color and style.

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate Constructor (Double, Double, Double, Double)

LineTemplate Constructor (Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the LineTemplate class with the specified start and end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LineTemplate (
double x1,
double y1,
double x2,
double y2
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double _
)

Parameters

x1

The x-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

y1

The y-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

x2

The x-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

y2

The y-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

Remarks

A line template is defined by two points whose coordinates are passed as arguments.

See Also

LineTemplate Constructor Overload List
LineTemplate Class


MindFusion.Diagramming.LineTemplate Constructor (Double, Double, Double, Double, Color, DashStyle, Double)

LineTemplate Constructor (Double, Double, Double, Double, Color, DashStyle, Double)
See Also
[image]

Initializes a new instance of the LineTemplate class with the specified start and end points, and the specified color and style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LineTemplate (
double x1,
double y1,
double x2,
double y2,
Color color,
DashStyle dashStyle,
double width
)

Visual Basic [image] Copy Code

Public New ( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double, _
color As Color, _
dashStyle As DashStyle, _
width As Double _
)

Parameters

x1

The x-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

y1

The y-coordinate of the first point, expressed in percents of a shape node's bounding rectangle.

x2

The x-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

y2

The y-coordinate of the second point, expressed in percents of a shape node's bounding rectangle.

color

The color of this segment.

dashStyle

The dash style of this segment.

width

The width of this segment.

Remarks

A line template is defined by two points whose coordinates are passed as arguments.

See Also

LineTemplate Constructor Overload List
LineTemplate Class


MindFusion.Diagramming.LineTemplate Methods

LineTemplate Methods
[image]

Public Methods

Name | Description
Clone | Create an exact copy of this LineTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate.Clone Method

LineTemplate.Clone Method
[image]

Create an exact copy of this LineTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override ElementTemplate Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As ElementTemplate

Return Value

An instance of the LineTemplate class.

See Also

LineTemplate Members
LineTemplate Class


MindFusion.Diagramming.LineTemplate.SameAs Method

LineTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is a LineTemplate closely approximating this template; otherwise, false.

See Also

LineTemplate Members
LineTemplate Class


MindFusion.Diagramming.LineTemplate Properties

LineTemplate Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
Coordinates | Gets a double array containing the coordinates of the end points of this line segment.
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

LineTemplate Class


MindFusion.Diagramming.LineTemplate.Coordinates Property

LineTemplate.Coordinates Property
[image]

Gets a double array containing the coordinates of the end points of this line segment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double[] Coordinates { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Coordinates As Double()

Property Value

An array of double values containing the coordinates of the points composing this element.

See Also

LineTemplate Members
LineTemplate Class


MindFusion.Diagramming.LinkAdjustmentHandle Class

LinkAdjustmentHandle Class
[image]

Represents an adjustment handle used to modify the position of a link's control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkAdjustmentHandle : AdjustmentHandle

Visual Basic [image] Copy Code

Public Class LinkAdjustmentHandle
Inherits AdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AdjustmentHandle
MindFusion.Diagramming.LinkAdjustmentHandle

See Also

LinkAdjustmentHandle Members


MindFusion.Diagramming.LinkAdjustmentHandle Members

LinkAdjustmentHandle Members
Constructors Properties
[image]

Represents an adjustment handle used to modify the position of a link's control point.

The following tables list the members exposed by the LinkAdjustmentHandle type.

Public Constructors

Name | Description
LinkAdjustmentHandle | Initializes a new instance of the LinkAdjustmentHandle class.

Public Properties

Name | Description
PointIndex | Gets or sets the index of a link's control point that will be adjusted by this handle.

See Also

LinkAdjustmentHandle Class


MindFusion.Diagramming.LinkAdjustmentHandle Constructor

LinkAdjustmentHandle Constructor
[image]

Initializes a new instance of the LinkAdjustmentHandle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkAdjustmentHandle (
int index
)

Visual Basic [image] Copy Code

Public New ( _
index As Integer _
)

Parameters

index

An integer value specifying the index of a link's control point that will be adjusted by this handle.

Remarks

When the user moves this handle, the respective element in link's ControlPoints collection is set to the handle's position.

See Also

LinkAdjustmentHandle Class


MindFusion.Diagramming.LinkAdjustmentHandle Properties

LinkAdjustmentHandle Properties
[image]

Public Properties

Name | Description
PointIndex | Gets or sets the index of a link's control point that will be adjusted by this handle.

See Also

LinkAdjustmentHandle Class


MindFusion.Diagramming.LinkAdjustmentHandle.PointIndex Property

LinkAdjustmentHandle.PointIndex Property
[image]

Gets or sets the index of a link's control point that will be adjusted by this handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int PointIndex { get; set; }

Visual Basic [image] Copy Code

Public Property PointIndex As Integer

Property Value

An integer index specifying which element of link's ControlPoints collection is updated by this handle.

See Also

LinkAdjustmentHandle Members
LinkAdjustmentHandle Class


MindFusion.Diagramming.LinkCrossings Enumeration

LinkCrossings Enumeration
[image]

Defines values that indicate how to render link intersection points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LinkCrossings

Visual Basic [image] Copy Code

Public Enum LinkCrossings

Members

Member name | Description
Arcs | An arc is drawn at the intersection point of two links. It connects the segments of the link at higher Z position and goes over the link at lower Z.
Cut | The intersection segments of links at lower Z position are cut by links at higher Z position.
Straight | No special indication for link intersection points.

Remarks

Values from this enumeration can be assigned to LinkCrossings.

See Also


MindFusion.Diagramming.LinkEventArgs Class

LinkEventArgs Class
[image]

Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class LinkEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkShapeEventArgs
MindFusion.Diagramming.LinkValidationEventArgs

See Also

LinkEventArgs Members


MindFusion.Diagramming.LinkEventArgs Members

LinkEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of link related events, such as LinkCreated and LinkDeleted.

The following tables list the members exposed by the LinkEventArgs type.

Public Constructors

Name | Description
LinkEventArgs | Overloaded. Initializes a new instance of the LinkEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
Link | Gets the link for which the event raised.
Position | Gets the location related to the event.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor

LinkEventArgs Constructor
[image]

Initializes a new instance of the LinkEventArgs class.

Overload List

Name | Description
LinkEventArgs (DiagramLink) | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (DiagramLink, Point) | Initializes a new instance of the LinkEventArgs class.
LinkEventArgs (DiagramLink, Point, Int32) | Initializes a new instance of the LinkEventArgs class.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink)

LinkEventArgs Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink related to the event.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink, Point)

LinkEventArgs Constructor (DiagramLink, Point)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link,
Point position
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
position As Point _
)

Parameters

link

The DiagramLink related to the event.

position

The zero-based index of the control point related to the event.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Constructor (DiagramLink, Point, Int32)

LinkEventArgs Constructor (DiagramLink, Point, Int32)
See Also
[image]

Initializes a new instance of the LinkEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkEventArgs (
DiagramLink link,
Point position,
int adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
position As Point, _
adjustmentHandle As Integer _
)

Parameters

link

The DiagramLink related to the event.

position

The location related to the event.

adjustmentHandle

The zero-based index of the adjustment handle related to the event.

See Also

LinkEventArgs Constructor Overload List
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs Properties

LinkEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user.
Link | Gets the link for which the event raised.
Position | Gets the location related to the event.

See Also

LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.AdjustmentHandle Property

LinkEventArgs.AdjustmentHandle Property
[image]

Gets or sets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AdjustmentHandle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AdjustmentHandle As Integer

Property Value

An integer that represents the index of the link's control point being moved.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.Link Property

LinkEventArgs.Link Property
[image]

Gets the link for which the event raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Link As DiagramLink

Property Value

A DiagramLink instance.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkEventArgs.Position Property

LinkEventArgs.Position Property
[image]

Gets the location related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

A Point object specifying the current mouse position.

See Also

LinkEventArgs Members
LinkEventArgs Class


MindFusion.Diagramming.LinkLabel Class

LinkLabel Class
Remarks See Also
[image]

Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkLabel : ItemLabel

Visual Basic [image] Copy Code

Public Class LinkLabel
Inherits ItemLabel

Remarks

The text displayed by a LinkLabel is set via the Text property, and its attributes are specified via Font. The label's foreground and background can be set via TextBrush and Brush properties.

The target position of a label along link segments is specified through RelativeTo and Index, and offset from that position via HorizontalOffset and VerticalOffset properties. Instead of using fixed offsets, enable the AutoArrange property to let links automatically choose positions of their labels that won't intersect nodes or other labels.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ItemLabel
MindFusion.Diagramming.LinkLabel

See Also

LinkLabel Members


MindFusion.Diagramming.LinkLabel Members

LinkLabel Members
Constructors Properties Methods
[image]

Represents a label displayed by a DiagramLink. New labels can be added to a link by calling the DiagramLink.AddLabel method.

The following tables list the members exposed by the LinkLabel type.

Public Constructors

Name | Description
LinkLabel | Overloaded. Initializes a new instance of the LinkLabel class.

Public Properties

Name | Description
AutoArrange | Gets or sets a value indicating whether the label can be auto arranged.
Brush | Gets or sets the brush used to draw the label's background.
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped.
Font | Gets or sets the label's font.
HorizontalAlign | Gets or sets the label's horizontal alignment.
HorizontalOffset | Gets or sets the label's horizontal offset.
Index | Gets or sets the index of the segment or control point this label is relative to.
Item | Gets or sets the DiagramItem that displays this label. (Inherited from ItemLabel.)
LengthFactor | Gets or sets the length factor if the RelativeTo property is set to RelativeToLink.LinkLength.
Link | Gets or sets the DiagramLink that displays this label.
Margin | Gets or sets the label's margin.
MaxWidth | Gets or sets the maximum width of the label.
RelativeTo | Gets or sets the label's relative positioning.
Text | Gets or sets the label's text.
TextBrush | Gets or sets the brush used to draw the label's text.
VerticalAlign | Gets or sets the label's vertical alignment.
VerticalOffset | Gets or sets the label's vertical offset.

Public Methods

Name | Description
Cancel | Called when drag operation is canceled. (Inherited from ItemLabel.)
Clone | Creates a clone of this label.
Draw | Draws the link label on the specified IGraphics surface.
GetEditRect | InplaceEditable.GetEditRect implementation. (Inherited from ItemLabel.)
GetEditRect | InplaceEditable.GetEditRect implementation.
GetTextToEdit | InplaceEditable.GetTextToEdit implementation.
LoadFromXml | Loads the label from the specified XML element.
OnTouchDown | Called when the left mouse button is pressed while the pointer is over this label. (Inherited from ItemLabel.)
OnTouchMove | Called when the mouse is moved while this label tracks the mouse events. (Inherited from ItemLabel.)
OnTouchUp | Called when the left mouse button is released while this label tracks the mouse events. (Inherited from ItemLabel.)
SaveToXml | Saves the label into the specified XML element.
SetControlPointPosition | Positions this label relatively to the specified control point.
SetEditedText | InplaceEditable.SetEditedText implementation.
SetLinkLengthPosition | Positions this label relatively to the link length.
SetSegmentPosition | Positions this label relatively to the specified link segment.
UpdateValue | Called while drag operation is in progress. (Inherited from ItemLabel.)

Protected Methods

Name | Description
LoadFromJson | Loads the label from a JsonObject.
PointAlongLength | Overloaded.
SaveToJson | Saves the label into a JsonObject.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor

LinkLabel Constructor
[image]

Initializes a new instance of the LinkLabel class.

Overload List

Name | Description
LinkLabel () | Initializes a new instance of the LinkLabel class.
LinkLabel (DiagramLink) | Initializes a new instance of the LinkLabel class.
LinkLabel (DiagramLink, String) | Initializes a new instance of the LinkLabel class.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor ()

LinkLabel Constructor ()
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LinkLabel Constructor Overload List
LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor (DiagramLink)

LinkLabel Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink that displays the label.

See Also

LinkLabel Constructor Overload List
LinkLabel Class


MindFusion.Diagramming.LinkLabel Constructor (DiagramLink, String)

LinkLabel Constructor (DiagramLink, String)
See Also
[image]

Initializes a new instance of the LinkLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel (
DiagramLink link,
string text
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
text As String _
)

Parameters

link

The DiagramLink that displays the label.

text

The label's text.

See Also

LinkLabel Constructor Overload List
LinkLabel Class


MindFusion.Diagramming.LinkLabel Methods

LinkLabel Methods
[image]

Public Methods

Name | Description
Cancel | Called when drag operation is canceled. (Inherited from ItemLabel.)
Clone | Creates a clone of this label.
Draw | Draws the link label on the specified IGraphics surface.
GetEditRect | InplaceEditable.GetEditRect implementation. (Inherited from ItemLabel.)
GetEditRect | InplaceEditable.GetEditRect implementation.
GetTextToEdit | InplaceEditable.GetTextToEdit implementation.
LoadFromXml | Loads the label from the specified XML element.
OnTouchDown | Called when the left mouse button is pressed while the pointer is over this label. (Inherited from ItemLabel.)
OnTouchMove | Called when the mouse is moved while this label tracks the mouse events. (Inherited from ItemLabel.)
OnTouchUp | Called when the left mouse button is released while this label tracks the mouse events. (Inherited from ItemLabel.)
SaveToXml | Saves the label into the specified XML element.
SetControlPointPosition | Positions this label relatively to the specified control point.
SetEditedText | InplaceEditable.SetEditedText implementation.
SetLinkLengthPosition | Positions this label relatively to the link length.
SetSegmentPosition | Positions this label relatively to the specified link segment.
UpdateValue | Called while drag operation is in progress. (Inherited from ItemLabel.)

Protected Methods

Name | Description
LoadFromJson | Loads the label from a JsonObject.
PointAlongLength | Overloaded.
SaveToJson | Saves the label into a JsonObject.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel.Clone Method

LinkLabel.Clone Method
[image]

Creates a clone of this label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As LinkLabel

Return Value

A new LinkLabel instance that is an exact copy of this label.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Draw Method

LinkLabel.Draw Method
[image]

Draws the link label on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void Draw (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overridable Sub Draw( _
graphics As IGraphics _
)

Parameters

graphics

An IGraphics object where the link label should be rendered.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.GetEditRect Method

LinkLabel.GetEditRect Method
[image]

InplaceEditable.GetEditRect implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetEditRect (
DiagramItem item,
Point position
)

Visual Basic [image] Copy Code

Public Function GetEditRect( _
item As DiagramItem, _
position As Point _
) As Rect

Parameters

item

The item being edited.

position

A Point instance specifying the mouse position.

Return Value

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.GetTextToEdit Method

LinkLabel.GetTextToEdit Method
[image]

InplaceEditable.GetTextToEdit implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string GetTextToEdit ()

Visual Basic [image] Copy Code

Public Function GetTextToEdit () As String

Return Value

A string value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.LoadFromJson Method

LinkLabel.LoadFromJson Method
[image]

Loads the label from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the label's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.LoadFromXml Method

LinkLabel.LoadFromXml Method
[image]

Loads the label from the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

A XElement instance.

context

A XmlPersistContext instance.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.PointAlongLength Method

LinkLabel.PointAlongLength Method
[image]

Overload List

Name | Description
LinkLabel.PointAlongLength (Double, IList(Point)) | Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.
LinkLabel.PointAlongLength (Double, PointCollection) | Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.PointAlongLength Method (Double, IList(Point))

LinkLabel.PointAlongLength Method (Double, IList(Point))
See Also
[image]

Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Point PointAlongLength (
double lengthFactor,
IList<Point> segments
)

Visual Basic [image] Copy Code

Protected Function PointAlongLength( _
lengthFactor As Double, _
segments As IList(Of Point) _
) As Point

Parameters

lengthFactor

A value from 0 to 1 specifying a portion of link's length.

segments

A list of points specifying the polyline segments.

Return Value

A Point instance.

See Also

PointAlongLength Method Overload List
LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.PointAlongLength Method (Double, PointCollection)

LinkLabel.PointAlongLength Method (Double, PointCollection)
See Also
[image]

Returns a point lying on a polyline that is positioned at a relative position along the polyline's length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Point PointAlongLength (
double lengthFactor,
PointCollection segments
)

Visual Basic [image] Copy Code

Protected Function PointAlongLength( _
lengthFactor As Double, _
segments As PointCollection _
) As Point

Parameters

lengthFactor

A value from 0 to 1 specifying a portion of link's length.

segments

A list of points specifying the polyline segments.

Return Value

A Point instance.

See Also

PointAlongLength Method Overload List
LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SaveToJson Method

LinkLabel.SaveToJson Method
[image]

Saves the label into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the label's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SaveToXml Method

LinkLabel.SaveToXml Method
[image]

Saves the label into the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Task SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Overrides Function SaveToXml( _
element As XElement, _
context As XmlPersistContext _
) As Task

Parameters

element

A XElement instance.

context

A XmlPersistContext instance.

Return Value

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetControlPointPosition Method

LinkLabel.SetControlPointPosition Method
[image]

Positions this label relatively to the specified control point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetControlPointPosition (
int controlPoint,
double dx,
double dy
)

Visual Basic [image] Copy Code

Public Sub SetControlPointPosition( _
controlPoint As Integer, _
dx As Double, _
dy As Double _
)

Parameters

controlPoint

The control point index.

dx

Horizontal offset from the point.

dy

Vertical offset from the point.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetEditedText Method

LinkLabel.SetEditedText Method
[image]

InplaceEditable.SetEditedText implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetEditedText (
string newText
)

Visual Basic [image] Copy Code

Public Sub SetEditedText( _
newText As String _
)

Parameters

newText

The new text of the in-place edited object.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetLinkLengthPosition Method

LinkLabel.SetLinkLengthPosition Method
[image]

Positions this label relatively to the link length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetLinkLengthPosition (
double lengthFactor
)

Visual Basic [image] Copy Code

Public Sub SetLinkLengthPosition( _
lengthFactor As Double _
)

Parameters

lengthFactor

A value between 0 and 1 specifying the position of the label relatively to the link's length.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.SetSegmentPosition Method

LinkLabel.SetSegmentPosition Method
[image]

Positions this label relatively to the specified link segment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetSegmentPosition (
int segment,
double dx,
double dy
)

Visual Basic [image] Copy Code

Public Sub SetSegmentPosition( _
segment As Integer, _
dx As Double, _
dy As Double _
)

Parameters

segment

The segment index.

dx

Horizontal offset from the segment center.

dy

Vertical offset from the segment center.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel Properties

LinkLabel Properties
[image]

Public Properties

Name | Description
AutoArrange | Gets or sets a value indicating whether the label can be auto arranged.
Brush | Gets or sets the brush used to draw the label's background.
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped.
Font | Gets or sets the label's font.
HorizontalAlign | Gets or sets the label's horizontal alignment.
HorizontalOffset | Gets or sets the label's horizontal offset.
Index | Gets or sets the index of the segment or control point this label is relative to.
Item | Gets or sets the DiagramItem that displays this label. (Inherited from ItemLabel.)
LengthFactor | Gets or sets the length factor if the RelativeTo property is set to RelativeToLink.LinkLength.
Link | Gets or sets the DiagramLink that displays this label.
Margin | Gets or sets the label's margin.
MaxWidth | Gets or sets the maximum width of the label.
RelativeTo | Gets or sets the label's relative positioning.
Text | Gets or sets the label's text.
TextBrush | Gets or sets the brush used to draw the label's text.
VerticalAlign | Gets or sets the label's vertical alignment.
VerticalOffset | Gets or sets the label's vertical offset.

See Also

LinkLabel Class


MindFusion.Diagramming.LinkLabel.AutoArrange Property

LinkLabel.AutoArrange Property
[image]

Gets or sets a value indicating whether the label can be auto arranged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AutoArrange { get; set; }

Visual Basic [image] Copy Code

Public Property AutoArrange As Boolean

Property Value

true to automatically place the label; otherwise, false.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Brush Property

LinkLabel.Brush Property
[image]

Gets or sets the brush used to draw the label's background.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

A Brush used to paint the label's background. The default value is null.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.EnableWrap Property

LinkLabel.EnableWrap Property
[image]

Gets or sets a value indicating whether the label's text can be wrapped.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableWrap { get; set; }

Visual Basic [image] Copy Code

Public Property EnableWrap As Boolean

Property Value

true to enable text wrapping; otherwise, false.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Font Property

LinkLabel.Font Property
[image]

Gets or sets the label's font.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Font> Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Nullable(Of Font)

Property Value

A Font object.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.HorizontalAlign Property

LinkLabel.HorizontalAlign Property
[image]

Gets or sets the label's horizontal alignment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HorizontalAlignment HorizontalAlign { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalAlign As HorizontalAlignment

Property Value

A member of the HorizontalAlignment enumeration. The default is Center.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.HorizontalOffset Property

LinkLabel.HorizontalOffset Property
[image]

Gets or sets the label's horizontal offset.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HorizontalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalOffset As Double

Property Value

A double value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Index Property

LinkLabel.Index Property
[image]

Gets or sets the index of the segment or control point this label is relative to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Index { get; set; }

Visual Basic [image] Copy Code

Public Property Index As Integer

Property Value

An integer value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.LengthFactor Property

LinkLabel.LengthFactor Property
[image]

Gets or sets the length factor if the RelativeTo property is set to RelativeToLink.LinkLength.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LengthFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LengthFactor As Double

Property Value

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Link Property

LinkLabel.Link Property
[image]

Gets or sets the DiagramLink that displays this label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Link { get; set; }

Visual Basic [image] Copy Code

Public Property Link As DiagramLink

Property Value

A DiagramLink object.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Margin Property

LinkLabel.Margin Property
[image]

Gets or sets the label's margin.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness Margin { get; set; }

Visual Basic [image] Copy Code

Public Property Margin As Thickness

Property Value

A Thickness instance specifying the size of text margins.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.MaxWidth Property

LinkLabel.MaxWidth Property
[image]

Gets or sets the maximum width of the label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MaxWidth { get; set; }

Visual Basic [image] Copy Code

Public Property MaxWidth As Double

Property Value

A double value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.RelativeTo Property

LinkLabel.RelativeTo Property
[image]

Gets or sets the label's relative positioning.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RelativeToLink RelativeTo { get; set; }

Visual Basic [image] Copy Code

Public Property RelativeTo As RelativeToLink

Property Value

A member of the RelativeToLink enumeration. The default is LinkLength.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.Text Property

LinkLabel.Text Property
[image]

Gets or sets the label's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.TextBrush Property

LinkLabel.TextBrush Property
[image]

Gets or sets the brush used to draw the label's text.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.VerticalAlign Property

LinkLabel.VerticalAlign Property
[image]

Gets or sets the label's vertical alignment.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VerticalAlignment VerticalAlign { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalAlign As VerticalAlignment

Property Value

A member of the VerticalAlignment enumeration. The default is Center.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabel.VerticalOffset Property

LinkLabel.VerticalOffset Property
[image]

Gets or sets the label's vertical offset.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double VerticalOffset { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalOffset As Double

Property Value

A double value.

See Also

LinkLabel Members
LinkLabel Class


MindFusion.Diagramming.LinkLabelEventArgs Class

LinkLabelEventArgs Class
[image]

Contains the arguments passed to handlers of link label related events, such as LabelClicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkLabelEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class LinkLabelEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkLabelEventArgs

See Also

LinkLabelEventArgs Members


MindFusion.Diagramming.LinkLabelEventArgs Members

LinkLabelEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of link label related events, such as LabelClicked.

The following tables list the members exposed by the LinkLabelEventArgs type.

Public Constructors

Name | Description
LinkLabelEventArgs | Overloaded.

Public Properties

Name | Description
Label | Gets the link label for which the event raised.
Position | Gets the location related to the event.

See Also

LinkLabelEventArgs Class


MindFusion.Diagramming.LinkLabelEventArgs Constructor

LinkLabelEventArgs Constructor
[image]

Overload List

Name | Description
LinkLabelEventArgs (LinkLabel) | Initializes a new instance of the LinkLabelEventArgs class.
LinkLabelEventArgs (LinkLabel, Point) | Initializes a new instance of the LinkLabelEventArgs class.

See Also

LinkLabelEventArgs Class


MindFusion.Diagramming.LinkLabelEventArgs Constructor (LinkLabel)

LinkLabelEventArgs Constructor (LinkLabel)
See Also
[image]

Initializes a new instance of the LinkLabelEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabelEventArgs (
LinkLabel label
)

Visual Basic [image] Copy Code

Public New ( _
label As LinkLabel _
)

Parameters

label

The LinkLabel related to the event.

See Also

LinkLabelEventArgs Constructor Overload List
LinkLabelEventArgs Class


MindFusion.Diagramming.LinkLabelEventArgs Constructor (LinkLabel, Point)

LinkLabelEventArgs Constructor (LinkLabel, Point)
See Also
[image]

Initializes a new instance of the LinkLabelEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabelEventArgs (
LinkLabel label,
Point position
)

Visual Basic [image] Copy Code

Public New ( _
label As LinkLabel, _
position As Point _
)

Parameters

label

The LinkLabel related to the event.

position

The location related to the event.

See Also

LinkLabelEventArgs Constructor Overload List
LinkLabelEventArgs Class


MindFusion.Diagramming.LinkLabelEventArgs Properties

LinkLabelEventArgs Properties
[image]

Public Properties

Name | Description
Label | Gets the link label for which the event raised.
Position | Gets the location related to the event.

See Also

LinkLabelEventArgs Class


MindFusion.Diagramming.LinkLabelEventArgs.Label Property

LinkLabelEventArgs.Label Property
[image]

Gets the link label for which the event raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel Label { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Label As LinkLabel

Property Value

See Also

LinkLabelEventArgs Members
LinkLabelEventArgs Class


MindFusion.Diagramming.LinkLabelEventArgs.Position Property

LinkLabelEventArgs.Position Property
[image]

Gets the location related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

See Also

LinkLabelEventArgs Members
LinkLabelEventArgs Class


MindFusion.Diagramming.LinkShape Enumeration

LinkShape Enumeration
[image]

Specifies available styles for the segments of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LinkShape

Visual Basic [image] Copy Code

Public Enum LinkShape

Members

Member name | Description
Bezier | The segments of an link are Bezier curves.
Cascading | The segments of an link are horizontal and vertical lines, each one orthogonal to each adjacent segment.
Polyline | The segments of the link are straight lines.
Spline | The segments of the link are cardinal splines.

Remarks

Values from this enumeration can be assigned to the Shape property of links or to the LinkShape property of the diagram.

See Also


MindFusion.Diagramming.LinkShapeEventArgs Class

LinkShapeEventArgs Class
[image]

Contains the arguments passed to the SetSelfLoopShape event handler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkShapeEventArgs : LinkEventArgs

Visual Basic [image] Copy Code

Public Class LinkShapeEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkShapeEventArgs

See Also

LinkShapeEventArgs Members


MindFusion.Diagramming.LinkShapeEventArgs Members

LinkShapeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the SetSelfLoopShape event handler.

The following tables list the members exposed by the LinkShapeEventArgs type.

Public Constructors

Name | Description
LinkShapeEventArgs | Initializes a new instance of the LinkShapeEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Handled | Indicates whether the event handler has set a custom loop shape.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
Position | Gets the location related to the event. (Inherited from LinkEventArgs.)

See Also

LinkShapeEventArgs Class


MindFusion.Diagramming.LinkShapeEventArgs Constructor

LinkShapeEventArgs Constructor
[image]

Initializes a new instance of the LinkShapeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkShapeEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink that becomes a self-loop.

See Also

LinkShapeEventArgs Class


MindFusion.Diagramming.LinkShapeEventArgs Properties

LinkShapeEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
Handled | Indicates whether the event handler has set a custom loop shape.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
Position | Gets the location related to the event. (Inherited from LinkEventArgs.)

See Also

LinkShapeEventArgs Class


MindFusion.Diagramming.LinkShapeEventArgs.Handled Property

LinkShapeEventArgs.Handled Property
[image]

Indicates whether the event handler has set a custom loop shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

true if a custom shape is specified and the control should not set the standard loop shape; otherwise, false. The default value is false.

See Also

LinkShapeEventArgs Members
LinkShapeEventArgs Class


MindFusion.Diagramming.LinkTextStyle Enumeration

LinkTextStyle Enumeration
[image]

Specifies the position and alignment of links' labels.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LinkTextStyle

Visual Basic [image] Copy Code

Public Enum LinkTextStyle

Members

Member name | Description
Center | The text is displayed horizontally above the middle link segment or control point, depending on whether there are an odd or even number of segments.
Follow | The label text starts from the first point of the link and follows the path defined by the link segments. This style is useful for displaying long text.
MiddleSegment | The text is displayed horizontally above the middle link segment. If there are an even number of segments, the label is drawn over the longer from the two segments adjacent to the middle control point.
MiddleSegmentRotated | The text is displayed rotated at the same angle as the segment where the text is placed. A long enough segment from the middle link segments is chosen for that purpose.
OverLongestSegment | The text follows the longest link segment and is displayed centered at the segment's middle point.
Rotate | The text is displayed rotated at the same angle as the segment where the text is placed. A long enough segment from the middle link segments is chosen for that purpose.

Remarks

Values from this enumeration can be assigned to the TextStyle property of links or the LinkTextStyle property of the diagram.

See Also


MindFusion.Diagramming.LinkValidationEventArgs Class

LinkValidationEventArgs Class
[image]

Contains the arguments passed to handlers of link validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkValidationEventArgs : LinkEventArgs

Visual Basic [image] Copy Code

Public Class LinkValidationEventArgs
Inherits LinkEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.LinkEventArgs
MindFusion.Diagramming.LinkValidationEventArgs

See Also

LinkValidationEventArgs Members


MindFusion.Diagramming.LinkValidationEventArgs Members

LinkValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to handlers of link validation events.

The following tables list the members exposed by the LinkValidationEventArgs type.

Public Constructors

Name | Description
LinkValidationEventArgs | Overloaded. Initializes a new instance of the LinkValidationEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
AnchorIndex | Gets the anchor point related to a link validation event.
Cancel | Gets or sets a value indicating whether to cancel the current operation.
ChangingDestination | Gets a value indicating whether the user modifies the link's destination end point.
ChangingOrigin | Gets a value indicating whether the user modifies the link's origin end point.
Destination | Gets the node that will become the link's destination if the event is validated.
Label | Gets or sets a LinkLabel related to this event.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
Node | Gets the node to which the link will be connected.
Origin | Gets the node that would become the link's origin if the event is validated.
Position | Gets the location related to the event. (Inherited from LinkEventArgs.)
SelectionRectangle | Gets the current selection rectangle.
TableRow | Gets the table row related to a link validation event.

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the link.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor

LinkValidationEventArgs Constructor
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Overload List

Name | Description
LinkValidationEventArgs (DiagramLink) | Initializes a new instance of the LinkValidationEventArgs class.
LinkValidationEventArgs (DiagramLink, Point, Int32, DiagramNode, Int32, Int32) | Initializes a new instance of the LinkValidationEventArgs class.
LinkValidationEventArgs (DiagramLink, Rect) | Initializes a new instance of the LinkValidationEventArgs class.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink)

LinkValidationEventArgs Constructor (DiagramLink)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink _
)

Parameters

link

The DiagramLink related to the event.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink, Point, Int32, DiagramNode, Int32, Int32)

LinkValidationEventArgs Constructor (DiagramLink, Point, Int32, DiagramNode, Int32, Int32)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link,
Point position,
int adjustmentHandle,
DiagramNode node,
int anchorIndex,
int tableRow
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
position As Point, _
adjustmentHandle As Integer, _
node As DiagramNode, _
anchorIndex As Integer, _
tableRow As Integer _
)

Parameters

link

The DiagramLink related to the event.

position

The location related to the event, in document coordinates.

adjustmentHandle

The zero-based index of the control point related to the event.

node

The DiagramNode related to the event.

anchorIndex

The zero-based index of the anchor point related to the event.

tableRow

The zero-based index of the table row related to the event.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Constructor (DiagramLink, Rect)

LinkValidationEventArgs Constructor (DiagramLink, Rect)
See Also
[image]

Initializes a new instance of the LinkValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkValidationEventArgs (
DiagramLink link,
Rect selectionRectangle
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
selectionRectangle As Rect _
)

Parameters

link

The DiagramLink related to the event.

selectionRectangle

A Rectangle object that represents the current selection rectangle.

See Also

LinkValidationEventArgs Constructor Overload List
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Methods

LinkValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the link.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.CancelDrag Method

LinkValidationEventArgs.CancelDrag Method
[image]

Cancels the creation or modification of the link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation. On the other hand, setting Cancel to true only cancels the operation when the user releases.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs Properties

LinkValidationEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets or sets the adjustment handle being moved by the user. (Inherited from LinkEventArgs.)
AnchorIndex | Gets the anchor point related to a link validation event.
Cancel | Gets or sets a value indicating whether to cancel the current operation.
ChangingDestination | Gets a value indicating whether the user modifies the link's destination end point.
ChangingOrigin | Gets a value indicating whether the user modifies the link's origin end point.
Destination | Gets the node that will become the link's destination if the event is validated.
Label | Gets or sets a LinkLabel related to this event.
Link | Gets the link for which the event raised. (Inherited from LinkEventArgs.)
Node | Gets the node to which the link will be connected.
Origin | Gets the node that would become the link's origin if the event is validated.
Position | Gets the location related to the event. (Inherited from LinkEventArgs.)
SelectionRectangle | Gets the current selection rectangle.
TableRow | Gets the table row related to a link validation event.

See Also

LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.AnchorIndex Property

LinkValidationEventArgs.AnchorIndex Property
[image]

Gets the anchor point related to a link validation event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AnchorIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AnchorIndex As Integer

Property Value

An integer value specifying the index of an anchor point within an AnchorPattern.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Cancel Property

LinkValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.ChangingDestination Property

LinkValidationEventArgs.ChangingDestination Property
[image]

Gets a value indicating whether the user modifies the link's destination end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ChangingDestination { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ChangingDestination As Boolean

Property Value

true if the user is changing the destination point; otherwise, false.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.ChangingOrigin Property

LinkValidationEventArgs.ChangingOrigin Property
[image]

Gets a value indicating whether the user modifies the link's origin end point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ChangingOrigin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ChangingOrigin As Boolean

Property Value

true if the user is changing the origin point; otherwise, false.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Destination Property

LinkValidationEventArgs.Destination Property
[image]

Gets the node that will become the link's destination if the event is validated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Destination { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Destination As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Label Property

LinkValidationEventArgs.Label Property
[image]

Gets or sets a LinkLabel related to this event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkLabel Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As LinkLabel

Property Value

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Node Property

LinkValidationEventArgs.Node Property
[image]

Gets the node to which the link will be connected.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.Origin Property

LinkValidationEventArgs.Origin Property
[image]

Gets the node that would become the link's origin if the event is validated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Origin { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Origin As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.SelectionRectangle Property

LinkValidationEventArgs.SelectionRectangle Property
[image]

Gets the current selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect SelectionRectangle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectionRectangle As Rect

Property Value

A Rectangle instance representing the selection rectangle.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.LinkValidationEventArgs.TableRow Property

LinkValidationEventArgs.TableRow Property
[image]

Gets the table row related to a link validation event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int TableRow { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableRow As Integer

Property Value

An integer value specifying the zero-based index of a TableNode row.

See Also

LinkValidationEventArgs Members
LinkValidationEventArgs Class


MindFusion.Diagramming.MarkStyle Enumeration

MarkStyle Enumeration
[image]

Specifies the visual style of anchor point marks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MarkStyle

Visual Basic [image] Copy Code

Public Enum MarkStyle

Members

Member name | Description
Circle | Anchor point marked with a circle.
Cross | No visual indication for the anchor point.
Custom | A DrawAnchorPoint event is fired, allowing custom painting of anchor points.
None | No visual indication for the anchor point.
Rectangle | Anchor point marked with a rectangle.
X | Anchor point marked with an 'X'.

Remarks

Members of this enumeration are used as values of the MarkStyle property of the AnchorPoint class.

See Also


MindFusion.Diagramming.MeasureUnit Class

MeasureUnit Class
Remarks See Also
[image]

Represents a unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class MeasureUnit

Visual Basic [image] Copy Code

Public NotInheritable Class MeasureUnit

Remarks

Instances of this class can be assigned to the MeasureUnit property of the Diagram class to indicate how size and length property values should be mapped to device pixels.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.MeasureUnit

See Also

MeasureUnit Members


MindFusion.Diagramming.MeasureUnit Members

MeasureUnit Members
Constructors Fields Properties Methods
[image]

Represents a unit of measure.

The following tables list the members exposed by the MeasureUnit type.

Public Constructors

Name | Description
MeasureUnit | Overloaded. Initializes a new instance of the MeasureUnit class.

Public Fields

Name | Description
Centimeter | Specifies centimeters as the unit of measure.
Document | Specifies document units (1/300 inch) as the unit of measure.
Inch | Specifies inches as the unit of measure.
Millimeter | Specifies millimeters as the unit of measure.
Percent | Specifies percents as the unit of measure.
Pixel | Specifies device pixels as the unit of measure.
Point | Specifies printer's points (1/72 inch) as the unit of measure.
WpfPoint | Specifies device-independent pixels (1/96 inch) as the unit of measure.

Public Properties

Name | Description
Amount | Gets the unit's size in inches.
Id | Gets the unit identifier.
Name | Gets the name of the unit.
StandardDivisions | Gets the number of subunits that measures of this unit type are commonly divided to.

Public Methods

Name | Description
ApplyTo | Overloaded. Applies this unit to a IGraphics drawing surface.
Convert | Overloaded. Converts a value from this unit to another unit.
Equals | Overloaded. Determines whether a measure unit is equal to the current measure unit.
FromId | Returns a MeasureUnit from its integer identifier.
GetHashCode | Object.GetHashCode override.
ToString | Object.ToString override.

See Also

MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Fields

MeasureUnit Fields
[image]

Public Fields

Name | Description
Centimeter | Specifies centimeters as the unit of measure.
Document | Specifies document units (1/300 inch) as the unit of measure.
Inch | Specifies inches as the unit of measure.
Millimeter | Specifies millimeters as the unit of measure.
Percent | Specifies percents as the unit of measure.
Pixel | Specifies device pixels as the unit of measure.
Point | Specifies printer's points (1/72 inch) as the unit of measure.
WpfPoint | Specifies device-independent pixels (1/96 inch) as the unit of measure.

See Also

MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Centimeter Field

MeasureUnit.Centimeter Field
[image]

Specifies centimeters as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Centimeter

Visual Basic [image] Copy Code

Public Shared ReadOnly Centimeter As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Document Field

MeasureUnit.Document Field
[image]

Specifies document units (1/300 inch) as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Document

Visual Basic [image] Copy Code

Public Shared ReadOnly Document As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Inch Field

MeasureUnit.Inch Field
[image]

Specifies inches as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Inch

Visual Basic [image] Copy Code

Public Shared ReadOnly Inch As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Millimeter Field

MeasureUnit.Millimeter Field
[image]

Specifies millimeters as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Millimeter

Visual Basic [image] Copy Code

Public Shared ReadOnly Millimeter As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Percent Field

MeasureUnit.Percent Field
[image]

Specifies percents as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Percent

Visual Basic [image] Copy Code

Public Shared ReadOnly Percent As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Pixel Field

MeasureUnit.Pixel Field
[image]

Specifies device pixels as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Pixel

Visual Basic [image] Copy Code

Public Shared ReadOnly Pixel As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Point Field

MeasureUnit.Point Field
[image]

Specifies printer's points (1/72 inch) as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit Point

Visual Basic [image] Copy Code

Public Shared ReadOnly Point As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.WpfPoint Field

MeasureUnit.WpfPoint Field
[image]

Specifies device-independent pixels (1/96 inch) as the unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly MeasureUnit WpfPoint

Visual Basic [image] Copy Code

Public Shared ReadOnly WpfPoint As MeasureUnit

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor

MeasureUnit Constructor
[image]

Initializes a new instance of the MeasureUnit class.

Overload List

Name | Description
MeasureUnit (Int32, String, MeasureUnitType, Double, Int32) | Initializes one of the built-in units of measure.
MeasureUnit (Int32, String, MeasureUnitType, Double, Int32, IMeasureUnitConverter) | Initializes one of the built-in units of measure.
MeasureUnit (String, Double) | Initializes a new instance of the MeasureUnit class with the specified resolution.
MeasureUnit (String, Double, Int32) | Initializes a new instance of the MeasureUnit class with the specified resolution.
MeasureUnit (String, MeasureUnit, Double) | Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.
MeasureUnit (String, MeasureUnit, Double, Int32) | Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.

See Also

MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (Int32, String, MeasureUnitType, Double, Int32)

MeasureUnit Constructor (Int32, String, MeasureUnitType, Double, Int32)
See Also
[image]

Initializes one of the built-in units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
int id,
string name,
MeasureUnitType type,
double unitsPerInch,
int standardDivisions
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer, _
name As String, _
type As MeasureUnitType, _
unitsPerInch As Double, _
standardDivisions As Integer _
)

Parameters

id

An integer identifier used to represent this unit in saved diagram files.

name

The display name of this unit.

type

A MeasureUnitType enumeration member specifying how unit size should be calculated.

unitsPerInch

A double value specifying how many units of this type fit within an inch.

standardDivisions

An integer value specifying how many standard divisions should be displayed for this unit in the scales of a Ruler control.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (Int32, String, MeasureUnitType, Double, Int32, IMeasureUnitConverter)

MeasureUnit Constructor (Int32, String, MeasureUnitType, Double, Int32, IMeasureUnitConverter)
See Also
[image]

Initializes one of the built-in units of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
int id,
string name,
MeasureUnitType type,
double unitsPerInch,
int standardDivisions,
IMeasureUnitConverter converter
)

Visual Basic [image] Copy Code

Public New ( _
id As Integer, _
name As String, _
type As MeasureUnitType, _
unitsPerInch As Double, _
standardDivisions As Integer, _
converter As IMeasureUnitConverter _
)

Parameters

id

An integer identifier used to represent this unit in saved diagram files.

name

The display name of this unit.

type

A MeasureUnitType enumeration member specifying how unit size should be calculated.

unitsPerInch

A double value specifying how many units of this type fit within an inch.

standardDivisions

An integer value specifying how many standard divisions should be displayed for this unit in the scales of a Ruler control.

converter

An IMeasureUnitConverter object used to convert values from this unit to device pixels or other logical units.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (String, Double)

MeasureUnit Constructor (String, Double)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified resolution.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
double unitsPerInch
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
unitsPerInch As Double _
)

Parameters

name

The name of the new unit.

unitsPerInch

The amount of the new unit that is equal to one inch.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (String, Double, Int32)

MeasureUnit Constructor (String, Double, Int32)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified resolution.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
double unitsPerInch,
int standardDivisions
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
unitsPerInch As Double, _
standardDivisions As Integer _
)

Parameters

name

The name of the new unit.

unitsPerInch

The amount of the new unit that is equal to one inch.

standardDivisions

The number of divisions of the new unit.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (String, MeasureUnit, Double)

MeasureUnit Constructor (String, MeasureUnit, Double)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
MeasureUnit baseUnit,
double scale
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
baseUnit As MeasureUnit, _
scale As Double _
)

Parameters

name

The name of the new unit.

baseUnit

The base of the new unit.

scale

The scale of the new unit, relatively to the base.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Constructor (String, MeasureUnit, Double, Int32)

MeasureUnit Constructor (String, MeasureUnit, Double, Int32)
See Also
[image]

Initializes a new instance of the MeasureUnit class with the specified unit of measure as a base.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit (
string name,
MeasureUnit baseUnit,
double scale,
int standardDivisions
)

Visual Basic [image] Copy Code

Public New ( _
name As String, _
baseUnit As MeasureUnit, _
scale As Double, _
standardDivisions As Integer _
)

Parameters

name

The name of the new unit.

baseUnit

The base of the new unit.

scale

The scale of the new unit, relatively to the base.

standardDivisions

The number of divisions of the new unit.

See Also

MeasureUnit Constructor Overload List
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Methods

MeasureUnit Methods
[image]

Public Methods

Name | Description
ApplyTo | Overloaded. Applies this unit to a IGraphics drawing surface.
Convert | Overloaded. Converts a value from this unit to another unit.
Equals | Overloaded. Determines whether a measure unit is equal to the current measure unit.
FromId | Returns a MeasureUnit from its integer identifier.
GetHashCode | Object.GetHashCode override.
ToString | Object.ToString override.

See Also

MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.ApplyTo Method

MeasureUnit.ApplyTo Method
[image]

Applies this unit to a IGraphics drawing surface.

Overload List

Name | Description
MeasureUnit.ApplyTo (IGraphics) | Applies this unit to the specified IGraphics drawing surface.
MeasureUnit.ApplyTo (IMatrix, IGraphics) | Applies this unit to the specified IMatrix.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.ApplyTo Method (IGraphics)

MeasureUnit.ApplyTo Method (IGraphics)
See Also
[image]

Applies this unit to the specified IGraphics drawing surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ApplyTo (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Sub ApplyTo( _
graphics As IGraphics _
)

Parameters

graphics

An IGraphics instance.

See Also

ApplyTo Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.ApplyTo Method (IMatrix, IGraphics)

MeasureUnit.ApplyTo Method (IMatrix, IGraphics)
See Also
[image]

Applies this unit to the specified IMatrix.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ApplyTo (
IMatrix matrix,
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Sub ApplyTo( _
matrix As IMatrix, _
graphics As IGraphics _
)

Parameters

matrix

An IMatrix instance that should be set to match the resolution of this unit.

graphics

An IGraphics that should supply the DPI.

See Also

ApplyTo Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Convert Method

MeasureUnit.Convert Method
[image]

Converts a value from this unit to another unit.

Overload List

Name | Description
MeasureUnit.Convert (Double, MeasureUnit, Object) | Converts the specified value from this unit to the specified unit.
MeasureUnit.Convert (Double, MeasureUnit, Object, Axis) | Converts the specified value from this unit to the specified unit.
MeasureUnit.Convert (Point, MeasureUnit, Object) | Converts the specified point from this unit to the specified unit.
MeasureUnit.Convert (Rect, MeasureUnit, Object) | Converts the specified rectangle from this unit to the specified unit.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Convert Method (Double, MeasureUnit, Object)

MeasureUnit.Convert Method (Double, MeasureUnit, Object)
See Also
[image]

Converts the specified value from this unit to the specified unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Convert (
double value,
MeasureUnit targetUnit,
Object context
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Double, _
targetUnit As MeasureUnit, _
context As Object _
) As Double

Parameters

value

The value to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units. This can be either IGraphics or IResolution.

Return Value

The converted value.

Remarks

If the target represents logical unit (such as millimeter, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Convert Method (Double, MeasureUnit, Object, Axis)

MeasureUnit.Convert Method (Double, MeasureUnit, Object, Axis)
See Also
[image]

Converts the specified value from this unit to the specified unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Convert (
double value,
MeasureUnit targetUnit,
Object context,
Axis axis
)

Visual Basic [image] Copy Code

Public Function Convert( _
value As Double, _
targetUnit As MeasureUnit, _
context As Object, _
axis As Axis _
) As Double

Parameters

value

The value to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units. This can be either IGraphics or IResolution.

axis

One of the coordinate axes.

Return Value

The converted value.

Remarks

If the target represents logical unit (such as millimeter, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Convert Method (Point, MeasureUnit, Object)

MeasureUnit.Convert Method (Point, MeasureUnit, Object)
See Also
[image]

Converts the specified point from this unit to the specified unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Convert (
Point p,
MeasureUnit targetUnit,
Object context
)

Visual Basic [image] Copy Code

Public Function Convert( _
p As Point, _
targetUnit As MeasureUnit, _
context As Object _
) As Point

Parameters

p

The point to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units. This can be either IGraphics or IResolution.

Return Value

The converted point.

Remarks

If the target represents logical unit (such as millimeter, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion. If both units are of the same generic type, graphics is ignored.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Convert Method (Rect, MeasureUnit, Object)

MeasureUnit.Convert Method (Rect, MeasureUnit, Object)
See Also
[image]

Converts the specified rectangle from this unit to the specified unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Convert (
Rect r,
MeasureUnit targetUnit,
Object context
)

Visual Basic [image] Copy Code

Public Function Convert( _
r As Rect, _
targetUnit As MeasureUnit, _
context As Object _
) As Rect

Parameters

r

The rectangle to convert, expressed in the current measure unit.

targetUnit

The target measure unit.

context

A parameter that is used when converting from logical units (such as inches and millimeters) to device units (such as pixels) or special units. This can be either IGraphics or IResolution.

Return Value

The converted rectangle.

Remarks

If the target represents logical unit (such as mm, inch, point) or a unit derived from a logical unit, and the current unit is not logical (for example pixel), the third parameter is required to perform the conversion. If both units are of the same generic type, graphics is ignored.

See Also

Convert Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Equals Method

MeasureUnit.Equals Method
[image]

Determines whether a measure unit is equal to the current measure unit.

Overload List

Name | Description
MeasureUnit.Equals (MeasureUnit) | Determines whether the specified measure unit is equal to the current measure unit.
MeasureUnit.Equals (Object) | Object.Equals override.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Equals Method (MeasureUnit)

MeasureUnit.Equals Method (MeasureUnit)
See Also
[image]

Determines whether the specified measure unit is equal to the current measure unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new bool Equals (
MeasureUnit unit
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
unit As MeasureUnit _
) As Boolean

Parameters

unit

The object to compare to this measure unit.

Return Value

true if the specified measure unit is equal to this object; otherwise, false.

See Also

Equals Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Equals Method (Object)

MeasureUnit.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with the current unit.

Return Value

true if the specified object is the same as or is equal to the current unit; otherwise, false.

See Also

Equals Method Overload List
MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.FromId Method

MeasureUnit.FromId Method
[image]

Returns a MeasureUnit from its integer identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static MeasureUnit FromId (
int id
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As Integer _
) As MeasureUnit

Parameters

id

The identifier of one of the built-in measure units.

Return Value

The built-in MeasureUnit corresponding to the specified identifier.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.GetHashCode Method

MeasureUnit.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for the current unit.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.ToString Method

MeasureUnit.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

The name of the unit.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit Properties

MeasureUnit Properties
[image]

Public Properties

Name | Description
Amount | Gets the unit's size in inches.
Id | Gets the unit identifier.
Name | Gets the name of the unit.
StandardDivisions | Gets the number of subunits that measures of this unit type are commonly divided to.

See Also

MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Amount Property

MeasureUnit.Amount Property
[image]

Gets the unit's size in inches.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Amount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Amount As Double

Property Value

A double value specifying the size in inches of a single unit of this type.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Id Property

MeasureUnit.Id Property
[image]

Gets the unit identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Integer

Property Value

An integer value.

Remarks

This property returns the integer identifier passed to MeasureUnit constructors.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.Name Property

MeasureUnit.Name Property
[image]

Gets the name of the unit.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Name { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Name As String

Property Value

The name passed to MeasureUnit constructors.

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnit.StandardDivisions Property

MeasureUnit.StandardDivisions Property
[image]

Gets the number of subunits that measures of this unit type are commonly divided to.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int StandardDivisions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StandardDivisions As Integer

Property Value

See Also

MeasureUnit Members
MeasureUnit Class


MindFusion.Diagramming.MeasureUnitType Enumeration

MeasureUnitType Enumeration
[image]

Specifies the type of a unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MeasureUnitType

Visual Basic [image] Copy Code

Public Enum MeasureUnitType

Members

Member name | Description
Device | Indicates device-dependent unit of measure, expressed in device pixels.
Logical | Indicates logical unit of measure, expressed as units-per-inch.
Special | Indicates special unit of measure, such as percent.

See Also


MindFusion.Diagramming.MenuItemEventArgs Class

MenuItemEventArgs Class
[image]

Provides the arguments passed to the Clicked event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class MenuItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class MenuItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.MenuItemEventArgs

See Also

MenuItemEventArgs Members


MindFusion.Diagramming.MenuItemEventArgs Members

MenuItemEventArgs Members
Properties
[image]

Provides the arguments passed to the Clicked event handlers.

The following tables list the members exposed by the MenuItemEventArgs type.

Public Properties

Name | Description
Item | Gets the diagram item related to the event.
X | Gets the x-coordinates of the input touch that triggered the event.
Y | Gets the y-coordinates of the input touch that triggered the event.

See Also

MenuItemEventArgs Class


MindFusion.Diagramming.MenuItemEventArgs Properties

MenuItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Gets the diagram item related to the event.
X | Gets the x-coordinates of the input touch that triggered the event.
Y | Gets the y-coordinates of the input touch that triggered the event.

See Also

MenuItemEventArgs Class


MindFusion.Diagramming.MenuItemEventArgs.Item Property

MenuItemEventArgs.Item Property
[image]

Gets the diagram item related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; set; }

Visual Basic [image] Copy Code

Public Property Item As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

MenuItemEventArgs Members
MenuItemEventArgs Class


MindFusion.Diagramming.MenuItemEventArgs.X Property

MenuItemEventArgs.X Property
[image]

Gets the x-coordinates of the input touch that triggered the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double X { get; set; }

Visual Basic [image] Copy Code

Public Property X As Double

Property Value

A double value.

See Also

MenuItemEventArgs Members
MenuItemEventArgs Class


MindFusion.Diagramming.MenuItemEventArgs.Y Property

MenuItemEventArgs.Y Property
[image]

Gets the y-coordinates of the input touch that triggered the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Y { get; set; }

Visual Basic [image] Copy Code

Public Property Y As Double

Property Value

A double value.

See Also

MenuItemEventArgs Members
MenuItemEventArgs Class


MindFusion.Diagramming.NodeAdjustmentHandle Class

NodeAdjustmentHandle Class
[image]

Represents an adjustment handle used to move, resize or rotate a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeAdjustmentHandle : AdjustmentHandle

Visual Basic [image] Copy Code

Public Class NodeAdjustmentHandle
Inherits AdjustmentHandle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.AdjustmentHandle
MindFusion.Diagramming.NodeAdjustmentHandle
MindFusion.Diagramming.FreeFormHandle

See Also

NodeAdjustmentHandle Members


MindFusion.Diagramming.NodeAdjustmentHandle Members

NodeAdjustmentHandle Members
Constructors Properties
[image]

Represents an adjustment handle used to move, resize or rotate a node.

The following tables list the members exposed by the NodeAdjustmentHandle type.

Public Constructors

Name | Description
NodeAdjustmentHandle | Overloaded. Initializes a new instance of the NodeAdjustmentHandle class.

Public Properties

Name | Description
Handles | Gets the type of this adjustment handle.
HandleType | Gets or sets the type of this adjustment handle.

See Also

NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle Constructor

NodeAdjustmentHandle Constructor
[image]

Initializes a new instance of the NodeAdjustmentHandle class.

Overload List

Name | Description
NodeAdjustmentHandle () | Initializes a new instance of the NodeAdjustmentHandle class.
NodeAdjustmentHandle (NodeHandleType) | Initializes a new instance of the NodeAdjustmentHandle class.

See Also

NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle Constructor ()

NodeAdjustmentHandle Constructor ()
See Also
[image]

Initializes a new instance of the NodeAdjustmentHandle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeAdjustmentHandle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeAdjustmentHandle Constructor Overload List
NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle Constructor (NodeHandleType)

NodeAdjustmentHandle Constructor (NodeHandleType)
See Also
[image]

Initializes a new instance of the NodeAdjustmentHandle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeAdjustmentHandle (
NodeHandleType handleType
)

Visual Basic [image] Copy Code

Public New ( _
handleType As NodeHandleType _
)

Parameters

handleType

A member of the NodeHandleType enumeration identifying the handle type.

See Also

NodeAdjustmentHandle Constructor Overload List
NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle Properties

NodeAdjustmentHandle Properties
[image]

Public Properties

Name | Description
Handles | Gets the type of this adjustment handle.
HandleType | Gets or sets the type of this adjustment handle.

See Also

NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle.Handles Property

NodeAdjustmentHandle.Handles Property
[image]

Gets the type of this adjustment handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual AdjustmentHandles Handles { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property Handles As AdjustmentHandles

Property Value

A member of the AdjustmentHandles enumeration.

See Also

NodeAdjustmentHandle Members
NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeAdjustmentHandle.HandleType Property

NodeAdjustmentHandle.HandleType Property
[image]

Gets or sets the type of this adjustment handle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeHandleType HandleType { get; set; }

Visual Basic [image] Copy Code

Public Property HandleType As NodeHandleType

Property Value

A member of the NodeHandleType enumeration specifying the type of this handle.

See Also

NodeAdjustmentHandle Members
NodeAdjustmentHandle Class


MindFusion.Diagramming.NodeConstraints Class

NodeConstraints Class
Remarks See Also
[image]

Defines specific constraints that can be applied to the size and location of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeConstraints

Visual Basic [image] Copy Code

Public Class NodeConstraints

Remarks

Instances of this class can be assigned to the Constraints property of nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeConstraints

See Also

NodeConstraints Members


MindFusion.Diagramming.NodeConstraints Members

NodeConstraints Members
Constructors Properties Methods
[image]

Defines specific constraints that can be applied to the size and location of nodes.

The following tables list the members exposed by the NodeConstraints type.

Public Constructors

Name | Description
NodeConstraints | Initializes a new instance of the NodeConstraints class.

Public Properties

Name | Description
KeepInsideParent | Gets or sets a value indicating whether a node should always stay in the boundaries of its group master node.
MoveDirection | Gets or sets constraints on movement direction.

Public Methods

Name | Description
Clone | Creates a copy of this object.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the constraint into the specified XML element.

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints Constructor

NodeConstraints Constructor
[image]

Initializes a new instance of the NodeConstraints class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeConstraints ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints Methods

NodeConstraints Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this object.
LoadFromXml | Loads the label from the specified XML element.
SaveToXml | Saves the constraint into the specified XML element.

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.Clone Method

NodeConstraints.Clone Method
[image]

Creates a copy of this object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeConstraints Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As NodeConstraints

Return Value

An Object instance that is a copy of the current NodeConstraints instance.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.LoadFromXml Method

NodeConstraints.LoadFromXml Method
[image]

Loads the label from the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement instance.

context

An XmlPersistContext instance.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.SaveToXml Method

NodeConstraints.SaveToXml Method
[image]

Saves the constraint into the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement instance.

context

An XmlPersistContext instance.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints Properties

NodeConstraints Properties
[image]

Public Properties

Name | Description
KeepInsideParent | Gets or sets a value indicating whether a node should always stay in the boundaries of its group master node.
MoveDirection | Gets or sets constraints on movement direction.

See Also

NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.KeepInsideParent Property

NodeConstraints.KeepInsideParent Property
[image]

Gets or sets a value indicating whether a node should always stay in the boundaries of its group master node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepInsideParent { get; set; }

Visual Basic [image] Copy Code

Public Property KeepInsideParent As Boolean

Property Value

true if users should be prevented from moving the node out of its parent; otherwise, false. The default is false.

Remarks

This property lets you restrict nodes attached to another node via the AttachToNode method so that users cannot move the attached nodes out of the bounds of their parent.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeConstraints.MoveDirection Property

NodeConstraints.MoveDirection Property
[image]

Gets or sets constraints on movement direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DirectionConstraint MoveDirection { get; set; }

Visual Basic [image] Copy Code

Public Property MoveDirection As DirectionConstraint

Property Value

One of the DirectionConstraint enumeration values; the default is None.

See Also

NodeConstraints Members
NodeConstraints Class


MindFusion.Diagramming.NodeEffect Class

NodeEffect Class
Remarks See Also
[image]

Represents the base class of all visual effects that can be applied to the nodes in a Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class NodeEffect : INotifyPropertyChanged

Visual Basic [image] Copy Code

Public MustInherit Class NodeEffect
Implements INotifyPropertyChanged

Remarks

Effects can be applied by adding instances of the concrete effect classes to the NodeEffects collection of the Diagram.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.NodeEffect
MindFusion.Diagramming.AeroEffect
MindFusion.Diagramming.GlassEffect

See Also

NodeEffect Members


MindFusion.Diagramming.NodeEffect Members

NodeEffect Members
Constructors Methods Events
[image]

Represents the base class of all visual effects that can be applied to the nodes in a Diagram.

The following tables list the members exposed by the NodeEffect type.

Protected Constructors

Name | Description
NodeEffect | Initializes a new instance of the NodeEffect class.

Public Methods

Name | Description
Clone | ICloneable.Clone implementation.

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect Constructor

NodeEffect Constructor
[image]

Initializes a new instance of the NodeEffect class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected NodeEffect ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect Methods

NodeEffect Methods
[image]

Public Methods

Name | Description
Clone | ICloneable.Clone implementation.

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect.Clone Method

NodeEffect.Clone Method
[image]

ICloneable.Clone implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract NodeEffect Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As NodeEffect

Return Value

A new effect that is a copy of this effect.

See Also

NodeEffect Members
NodeEffect Class


MindFusion.Diagramming.NodeEffect Events

NodeEffect Events
[image]

Public Events

Name | Description
PropertyChanged | INotifyPropertyChanged.PropertyChanged implementation.

See Also

NodeEffect Class


MindFusion.Diagramming.NodeEffect.PropertyChanged Event

NodeEffect.PropertyChanged Event
[image]

INotifyPropertyChanged.PropertyChanged implementation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

NodeEffect Members
NodeEffect Class


MindFusion.Diagramming.NodeEventArgs Class

NodeEventArgs Class
[image]

Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class NodeEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.ContainerChildEventArgs
MindFusion.Diagramming.NodeValidationEventArgs

See Also

NodeEventArgs Members


MindFusion.Diagramming.NodeEventArgs Members

NodeEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of node-related events, such as TreeCollapsed and TreeExpanded.

The following tables list the members exposed by the NodeEventArgs type.

Public Constructors

Name | Description
NodeEventArgs | Overloaded. Initializes a new instance of the NodeEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user.
Node | Gets the node for which the event was raised.
Position | Gets the location related to the event.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor

NodeEventArgs Constructor
[image]

Initializes a new instance of the NodeEventArgs class.

Overload List

Name | Description
NodeEventArgs (DiagramNode) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, Point) | Initializes a new instance of the NodeEventArgs class.
NodeEventArgs (DiagramNode, Point, AdjustmentHandles) | Initializes a new instance of the NodeEventArgs class.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode)

NodeEventArgs Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode _
)

Parameters

node

The DiagramNode related to the event.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode, Point)

NodeEventArgs Constructor (DiagramNode, Point)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node,
Point position
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
position As Point _
)

Parameters

node

The DiagramNode related to the event.

position

The location related to the event, in document coordinates.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)

NodeEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)
See Also
[image]

Initializes a new instance of the NodeEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEventArgs (
DiagramNode node,
Point position,
AdjustmentHandles adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
position As Point, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

node

The DiagramNode related to the event.

position

The location related to the event, in document coordinates.

adjustmentHandle

The zero-based index of the adjustment handle related to the event.

See Also

NodeEventArgs Constructor Overload List
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs Properties

NodeEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user.
Node | Gets the node for which the event was raised.
Position | Gets the location related to the event.

See Also

NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.AdjustmentHandle Property

NodeEventArgs.AdjustmentHandle Property
[image]

Gets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandles AdjustmentHandle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AdjustmentHandle As AdjustmentHandles

Property Value

A member of the AdjustmentHandles enumeration specifying what handle has been used.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.Node Property

NodeEventArgs.Node Property
[image]

Gets the node for which the event was raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

An instance of the DiagramNode class.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeEventArgs.Position Property

NodeEventArgs.Position Property
[image]

Gets the location related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

A Point object specifying the current touch position.

See Also

NodeEventArgs Members
NodeEventArgs Class


MindFusion.Diagramming.NodeHandleType Enumeration

NodeHandleType Enumeration
[image]

Identifies the types of selection handles of a node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum NodeHandleType

Visual Basic [image] Copy Code

Public Enum NodeHandleType

Members

Member name | Description
Move | A central selection handle that can be used to move the node.
ResizeBottomCenter | A bottom-center handle that can be used to resize the node vertically.
ResizeBottomLeft | A bottom-left handle that can be used to resize the node.
ResizeBottomRight | A bottom-right handle that can be used to resize the node.
ResizeMiddleLeft | A middle-left handle that can be used to resize the node horizontally.
ResizeMiddleRight | A middle-right handle that can be used to resize the node horizontally.
ResizeTopCenter | A top-center handle that can be used to resize the node vertically.
ResizeTopLeft | A top-left handle that can be used to resize the node.
ResizeTopRight | A top-right handle that can be used to resize the node.
Rotate | A rotation handle that can be used to rotate the node.

See Also


MindFusion.Diagramming.NodeLabel Class

NodeLabel Class
[image]

Represents a label displayed by a DiagramNode. New labels can be added to a node by calling the DiagramNode.AddLabel method.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeLabel : ItemLabel

Visual Basic [image] Copy Code

Public Class NodeLabel
Inherits ItemLabel

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ItemLabel
MindFusion.Diagramming.NodeLabel

See Also

NodeLabel Members


MindFusion.Diagramming.NodeLabel Members

NodeLabel Members
Constructors Properties Methods
[image]

Represents a label displayed by a DiagramNode. New labels can be added to a node by calling the DiagramNode.AddLabel method.

The following tables list the members exposed by the NodeLabel type.

Public Constructors

Name | Description
NodeLabel | Overloaded.

Public Properties

Name | Description
Brush | Gets or sets the brush used to draw the label's background. (Inherited from ItemLabel.)
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped. (Inherited from ItemLabel.)
Font | Gets or sets the label's font. (Inherited from ItemLabel.)
HorizontalAlign | Gets or sets the label's horizontal alignment. (Inherited from ItemLabel.)
HorizontalOffset | Gets or sets the label's horizontal offset. (Inherited from ItemLabel.)
Index | Gets or sets the index of the edge or corner point this label is relative to. (Inherited from ItemLabel.)
Item | Gets or sets the DiagramItem that displays this label. (Inherited from ItemLabel.)
Margin | Gets or sets the label's margin. (Inherited from ItemLabel.)
MaxWidth | Gets or sets the maximum width of the label. (Inherited from ItemLabel.)
Node | Gets or sets the DiagramNode that displays this label.
RelativeTo | Gets or sets the label's relative positioning.
Text | Gets or sets the label's text. (Inherited from ItemLabel.)
TextBrush | Gets or sets the brush used to draw the label's text. (Inherited from ItemLabel.)
VerticalAlign | Gets or sets the label's vertical alignment. (Inherited from ItemLabel.)
VerticalOffset | Gets or sets the label's vertical offset. (Inherited from ItemLabel.)

Public Methods

Name | Description
Cancel | Called when drag operation is canceled. (Inherited from ItemLabel.)
Clone | Creates a clone of this label.
Draw | Draws the label on the specified IGraphics surface. (Inherited from ItemLabel.)
GetEditRect | InplaceEditable.GetEditRect implementation. (Inherited from ItemLabel.)
GetTextToEdit | InplaceEditable.GetTextToEdit implementation. (Inherited from ItemLabel.)
LoadFromXml | Loads the label from the specified XML element.
OnTouchDown | Called when the left mouse button is pressed while the pointer is over this label. (Inherited from ItemLabel.)
OnTouchMove | Called when the mouse is moved while this label tracks the mouse events. (Inherited from ItemLabel.)
OnTouchUp | Called when the left mouse button is released while this label tracks the mouse events. (Inherited from ItemLabel.)
SaveToXml | Saves the label into the specified XML element.
SetCenterPosition | Positions this label relatively to the node center.
SetCornerPosition | Positions this label relatively to the specified corner point.
SetEdgePosition | Positions this label relatively to the specified node edge.
SetEditedText | InplaceEditable.SetEditedText implementation. (Inherited from ItemLabel.)
UpdateValue | Called while drag operation is in progress. (Inherited from ItemLabel.)

Protected Methods

Name | Description
LoadFromJson | Loads the label from a JsonObject.
SaveToJson | Saves the label into a JsonObject.

See Also

NodeLabel Class


MindFusion.Diagramming.NodeLabel Constructor

NodeLabel Constructor
[image]

Overload List

Name | Description
NodeLabel () | Initializes a new instance of the NodeLabel class.
NodeLabel (DiagramNode) | Initializes a new instance of the NodeLabel class.
NodeLabel (DiagramNode, String) | Initializes a new instance of the NodeLabel class.

See Also

NodeLabel Class


MindFusion.Diagramming.NodeLabel Constructor ()

NodeLabel Constructor ()
See Also
[image]

Initializes a new instance of the NodeLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeLabel ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeLabel Constructor Overload List
NodeLabel Class


MindFusion.Diagramming.NodeLabel Constructor (DiagramNode)

NodeLabel Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the NodeLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeLabel (
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode _
)

Parameters

node

The DiagramNode that displays the label.

See Also

NodeLabel Constructor Overload List
NodeLabel Class


MindFusion.Diagramming.NodeLabel Constructor (DiagramNode, String)

NodeLabel Constructor (DiagramNode, String)
See Also
[image]

Initializes a new instance of the NodeLabel class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeLabel (
DiagramNode node,
string text
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
text As String _
)

Parameters

node

The DiagramNode that displays the label.

text

The label's text.

See Also

NodeLabel Constructor Overload List
NodeLabel Class


MindFusion.Diagramming.NodeLabel Methods

NodeLabel Methods
[image]

Public Methods

Name | Description
Cancel | Called when drag operation is canceled. (Inherited from ItemLabel.)
Clone | Creates a clone of this label.
Draw | Draws the label on the specified IGraphics surface. (Inherited from ItemLabel.)
GetEditRect | InplaceEditable.GetEditRect implementation. (Inherited from ItemLabel.)
GetTextToEdit | InplaceEditable.GetTextToEdit implementation. (Inherited from ItemLabel.)
LoadFromXml | Loads the label from the specified XML element.
OnTouchDown | Called when the left mouse button is pressed while the pointer is over this label. (Inherited from ItemLabel.)
OnTouchMove | Called when the mouse is moved while this label tracks the mouse events. (Inherited from ItemLabel.)
OnTouchUp | Called when the left mouse button is released while this label tracks the mouse events. (Inherited from ItemLabel.)
SaveToXml | Saves the label into the specified XML element.
SetCenterPosition | Positions this label relatively to the node center.
SetCornerPosition | Positions this label relatively to the specified corner point.
SetEdgePosition | Positions this label relatively to the specified node edge.
SetEditedText | InplaceEditable.SetEditedText implementation. (Inherited from ItemLabel.)
UpdateValue | Called while drag operation is in progress. (Inherited from ItemLabel.)

Protected Methods

Name | Description
LoadFromJson | Loads the label from a JsonObject.
SaveToJson | Saves the label into a JsonObject.

See Also

NodeLabel Class


MindFusion.Diagramming.NodeLabel.Clone Method

NodeLabel.Clone Method
[image]

Creates a clone of this label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeLabel Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As NodeLabel

Return Value

A new NodeLabel instance that is an exact copy of this label.

See Also

NodeLabel Members
NodeLabel Class


MindFusion.Diagramming.NodeLabel.LoadFromJson Method

NodeLabel.LoadFromJson Method
[image]

Loads the label from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the label's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

NodeLabel Members
NodeLabel Class


MindFusion.Diagramming.NodeLabel.LoadFromXml Method

NodeLabel.LoadFromXml Method
[image]

Loads the label from the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void LoadFromXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Overrides Sub LoadFromXml( _
xmlElement As XElement, _
context As XmlPersistContext _
)

Parameters

xmlElement

An XmlElement instance.

context

An XmlPersistContext instance.

See Also

NodeLabel Members
NodeLabel Class


MindFusion.Diagramming.NodeLabel.SaveToJson Method

NodeLabel.SaveToJson Method
[image]

Saves the label into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the label's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

NodeLabel Members
NodeLabel Class


MindFusion.Diagramming.NodeLabel.SaveToXml Method

NodeLabel.SaveToXml Method
[image]

Saves the label into the specified XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Task SaveToXml (
XElement xmlElement,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Overrides Function SaveToXml( _
xmlElement As XElement, _
context As XmlPersistContext _
) As Task

Parameters

xmlElement

An XmlElement instance.

context

An XmlPersistContext instance.

Return Value

See Also

NodeLabel Members
NodeLabel Class


MindFusion.Diagramming.NodeLabel.SetCenterPosition Method

NodeLabel.SetCenterPosition Method
[image]

Positions this label relatively to the node center.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetCenterPosition (
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Sub SetCenterPosition( _
dx As Single, _
dy As Single _
)

Parameters

dx

Horizontal offset from the center point.

dy

Vertical offset from the center point.

See Also

NodeLabel Members
NodeLabel Class


MindFusion.Diagramming.NodeLabel.SetCornerPosition Method

NodeLabel.SetCornerPosition Method
[image]

Positions this label relatively to the specified corner point.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetCornerPosition (
int cornerPoint,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Sub SetCornerPosition( _
cornerPoint As Integer, _
dx As Single, _
dy As Single _
)

Parameters

cornerPoint

The corner point index.

dx

Horizontal offset from the point.

dy

Vertical offset from the point.

See Also

NodeLabel Members
NodeLabel Class


MindFusion.Diagramming.NodeLabel.SetEdgePosition Method

NodeLabel.SetEdgePosition Method
[image]

Positions this label relatively to the specified node edge.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetEdgePosition (
int edge,
float dx,
float dy
)

Visual Basic [image] Copy Code

Public Sub SetEdgePosition( _
edge As Integer, _
dx As Single, _
dy As Single _
)

Parameters

edge

The edge index.

dx

Horizontal offset from the edge center.

dy

Vertical offset from the edge center.

See Also

NodeLabel Members
NodeLabel Class


MindFusion.Diagramming.NodeLabel Properties

NodeLabel Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to draw the label's background. (Inherited from ItemLabel.)
EnableWrap | Gets or sets a value indicating whether the label's text can be wrapped. (Inherited from ItemLabel.)
Font | Gets or sets the label's font. (Inherited from ItemLabel.)
HorizontalAlign | Gets or sets the label's horizontal alignment. (Inherited from ItemLabel.)
HorizontalOffset | Gets or sets the label's horizontal offset. (Inherited from ItemLabel.)
Index | Gets or sets the index of the edge or corner point this label is relative to. (Inherited from ItemLabel.)
Item | Gets or sets the DiagramItem that displays this label. (Inherited from ItemLabel.)
Margin | Gets or sets the label's margin. (Inherited from ItemLabel.)
MaxWidth | Gets or sets the maximum width of the label. (Inherited from ItemLabel.)
Node | Gets or sets the DiagramNode that displays this label.
RelativeTo | Gets or sets the label's relative positioning.
Text | Gets or sets the label's text. (Inherited from ItemLabel.)
TextBrush | Gets or sets the brush used to draw the label's text. (Inherited from ItemLabel.)
VerticalAlign | Gets or sets the label's vertical alignment. (Inherited from ItemLabel.)
VerticalOffset | Gets or sets the label's vertical offset. (Inherited from ItemLabel.)

See Also

NodeLabel Class


MindFusion.Diagramming.NodeLabel.Node Property

NodeLabel.Node Property
[image]

Gets or sets the DiagramNode that displays this label.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; set; }

Visual Basic [image] Copy Code

Public Property Node As DiagramNode

Property Value

See Also

NodeLabel Members
NodeLabel Class


MindFusion.Diagramming.NodeLabel.RelativeTo Property

NodeLabel.RelativeTo Property
[image]

Gets or sets the label's relative positioning.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RelativeToNode RelativeTo { get; set; }

Visual Basic [image] Copy Code

Public Property RelativeTo As RelativeToNode

Property Value

See Also

NodeLabel Members
NodeLabel Class


MindFusion.Diagramming.NodeListView Class

NodeListView Class
Remarks See Also
[image]

Represents a list view containing DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeListView : ListView

Visual Basic [image] Copy Code

Public Class NodeListView
Inherits ListView

Remarks

Call the AddNode method to add a node to the view.

Drag-and-drop operations create a clone of the dragged node by calling its Clone method. You can override Clone to copy property values of custom node subclasses.

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
Microsoft.Maui.Controls.ItemsView(Cell)
Microsoft.Maui.Controls.ListView
MindFusion.Diagramming.NodeListView

See Also

NodeListView Members


MindFusion.Diagramming.NodeListView Members

NodeListView Members
Constructors Properties Methods Events
[image]

Represents a list view containing DiagramNode objects.

The following tables list the members exposed by the NodeListView type.

Public Constructors

Name | Description
NodeListView | Initializes a new instance of the NodeListView class.

Public Properties

Name | Description
DefaultNodeSize | Gets or sets the default size with which nodes dragged onto a diagram will be created.
IconMargin | Gets or sets the horizontal and vertical margins around the nodes.
IconSize | Gets or sets the size of the nodes displayed in the view.
MeasureUnit | Gets or sets the unit of measure used when drawing nodes.
NodesCount | Gets the number of nodes in the list view.
Target | The target DiagramView for drag/drop interactions.

Public Methods

Name | Description
AddNode | Overloaded. Adds a new node to the end of the list view.
AddNodes | Overloaded. Adds the specified nodes to the end of the list view.
ClearNodes | Removes all nodes from the list view.
GetItemAt | For internal use.
GetNodeAt | Gets the node at the specified position.
GetScreenCoords |
InsertNode | Overloaded.
OnDragComplete | Raises the DragComplete event.
RefreshItemsSource | Force refresh the items source binding.
RemoveNode | Removes the node from the list box.
RemoveNodeAt | Removes the node at the specified position.
ResumeLayout | Resume the backing items source binding refresh.
SuspendLayout | Suspend the backing items source binding refresh.

Protected Methods

Name | Description
MeasureOverride |
OnNodeClicked | Invoked when the user clicks a node in this list box.
OnNodeDoubleClicked | Invoked when the user double-clicks a node in this list box.
OnNodeRemoved | Invoked when the user removes a node from the list view.
OnNodeSelected | Invoked when the user selects a node in this list box.

Public Events

Name | Description
DragComplete |
DragStarting |
NodeClicked | Raised when the user clicks a node in the list view.
NodeDoubleClicked | Raised when the user double-clicks a node in the list view.
NodeRemoved | Raised when the user removes a node from the list view.
NodeSelected | Raised when the user selects a node in the list view.

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView Constructor

NodeListView Constructor
[image]

Initializes a new instance of the NodeListView class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeListView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView Methods

NodeListView Methods
[image]

Public Methods

Name | Description
AddNode | Overloaded. Adds a new node to the end of the list view.
AddNodes | Overloaded. Adds the specified nodes to the end of the list view.
ClearNodes | Removes all nodes from the list view.
GetItemAt | For internal use.
GetNodeAt | Gets the node at the specified position.
GetScreenCoords |
InsertNode | Overloaded.
OnDragComplete | Raises the DragComplete event.
RefreshItemsSource | Force refresh the items source binding.
RemoveNode | Removes the node from the list box.
RemoveNodeAt | Removes the node at the specified position.
ResumeLayout | Resume the backing items source binding refresh.
SuspendLayout | Suspend the backing items source binding refresh.

Protected Methods

Name | Description
MeasureOverride |
OnNodeClicked | Invoked when the user clicks a node in this list box.
OnNodeDoubleClicked | Invoked when the user double-clicks a node in this list box.
OnNodeRemoved | Invoked when the user removes a node from the list view.
OnNodeSelected | Invoked when the user selects a node in this list box.

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView.AddNode Method

NodeListView.AddNode Method
[image]

Adds a new node to the end of the list view.

Overload List

Name | Description
NodeListView.AddNode (DiagramNode) | Adds a new node to the end of the list view.
NodeListView.AddNode (DiagramNode, String) | Adds a new node to the end of the list view.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.AddNode Method (DiagramNode)

NodeListView.AddNode Method (DiagramNode)
See Also
[image]

Adds a new node to the end of the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddNode (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub AddNode( _
node As DiagramNode _
)

Parameters

node

The node to add.

See Also

AddNode Method Overload List
NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.AddNode Method (DiagramNode, String)

NodeListView.AddNode Method (DiagramNode, String)
See Also
[image]

Adds a new node to the end of the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddNode (
DiagramNode node,
string label
)

Visual Basic [image] Copy Code

Public Sub AddNode( _
node As DiagramNode, _
label As String _
)

Parameters

node

The node to add.

label

The text to be displayed for the node.

See Also

AddNode Method Overload List
NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.AddNodes Method

NodeListView.AddNodes Method
[image]

Adds the specified nodes to the end of the list view.

Overload List

Name | Description
NodeListView.AddNodes (DiagramNode[], String[]) | Adds the specified nodes to the end of the list view.
NodeListView.AddNodes (DiagramNodeCollection) | Adds the specified nodes to the end of the list view.
NodeListView.AddNodes (DiagramNodeCollection, String[]) | Adds the specified nodes to the end of the list view.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.AddNodes Method (DiagramNode[], String[])

NodeListView.AddNodes Method (DiagramNode[], String[])
See Also
[image]

Adds the specified nodes to the end of the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddNodes (
DiagramNode[] nodes,
string[] labels
)

Visual Basic [image] Copy Code

Public Sub AddNodes( _
nodes() As DiagramNode, _
labels() As String _
)

Parameters

nodes

The array of nodes to add.

labels

The array of texts to be displayed for the nodes.

See Also

AddNodes Method Overload List
NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.AddNodes Method (DiagramNodeCollection)

NodeListView.AddNodes Method (DiagramNodeCollection)
See Also
[image]

Adds the specified nodes to the end of the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddNodes (
DiagramNodeCollection nodes
)

Visual Basic [image] Copy Code

Public Sub AddNodes( _
nodes As DiagramNodeCollection _
)

Parameters

nodes

The collection of nodes to add.

See Also

AddNodes Method Overload List
NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.AddNodes Method (DiagramNodeCollection, String[])

NodeListView.AddNodes Method (DiagramNodeCollection, String[])
See Also
[image]

Adds the specified nodes to the end of the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddNodes (
DiagramNodeCollection nodes,
string[] labels
)

Visual Basic [image] Copy Code

Public Sub AddNodes( _
nodes As DiagramNodeCollection, _
labels() As String _
)

Parameters

nodes

The collection of nodes to add.

labels

The array of texts to be displayed for the nodes.

See Also

AddNodes Method Overload List
NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.ClearNodes Method

NodeListView.ClearNodes Method
[image]

Removes all nodes from the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ClearNodes ()

Visual Basic [image] Copy Code

Public Sub ClearNodes ()

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.GetItemAt Method

NodeListView.GetItemAt Method
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DraggedNode GetItemAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetItemAt( _
index As Integer _
) As DraggedNode

Parameters

index

Return Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.GetNodeAt Method

NodeListView.GetNodeAt Method
[image]

Gets the node at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode GetNodeAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetNodeAt( _
index As Integer _
) As DiagramNode

Parameters

index

Return Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.GetScreenCoords Method

NodeListView.GetScreenCoords Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Point GetScreenCoords (
VisualElement view
)

Visual Basic [image] Copy Code

Public Shared Function GetScreenCoords( _
view As VisualElement _
) As Point

Parameters

view

Return Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.InsertNode Method

NodeListView.InsertNode Method
[image]

Overload List

Name | Description
NodeListView.InsertNode (Int32, DiagramNode) | Inserts the node at the specified position.
NodeListView.InsertNode (Int32, DiagramNode, String) | Inserts the node at the specified position.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.InsertNode Method (Int32, DiagramNode)

NodeListView.InsertNode Method (Int32, DiagramNode)
See Also
[image]

Inserts the node at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InsertNode (
int index,
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub InsertNode( _
index As Integer, _
node As DiagramNode _
)

Parameters

index

The zero-based index at which the node should be inserted.

node

The node to insert.

See Also

InsertNode Method Overload List
NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.InsertNode Method (Int32, DiagramNode, String)

NodeListView.InsertNode Method (Int32, DiagramNode, String)
See Also
[image]

Inserts the node at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InsertNode (
int index,
DiagramNode node,
string label
)

Visual Basic [image] Copy Code

Public Sub InsertNode( _
index As Integer, _
node As DiagramNode, _
label As String _
)

Parameters

index

The zero-based index at which the node should be inserted.

node

The node to insert.

label

The text to be displayed for the node.

See Also

InsertNode Method Overload List
NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.MeasureOverride Method

NodeListView.MeasureOverride Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size MeasureOverride (
double widthConstraint,
double heightConstraint
)

Visual Basic [image] Copy Code

Protected Overrides Function MeasureOverride( _
widthConstraint As Double, _
heightConstraint As Double _
) As Size

Parameters

widthConstraint

heightConstraint

Return Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.OnDragComplete Method

NodeListView.OnDragComplete Method
[image]

Raises the DragComplete event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnDragComplete (
DragEventArgs e
)

Visual Basic [image] Copy Code

Public Overridable Sub OnDragComplete( _
e As DragEventArgs _
)

Parameters

e

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.OnNodeClicked Method

NodeListView.OnNodeClicked Method
[image]

Invoked when the user clicks a node in this list box.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeClicked (
DiagramNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeClicked( _
e As DiagramNodeEventArgs _
)

Parameters

e

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.OnNodeDoubleClicked Method

NodeListView.OnNodeDoubleClicked Method
[image]

Invoked when the user double-clicks a node in this list box.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeDoubleClicked (
DiagramNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeDoubleClicked( _
e As DiagramNodeEventArgs _
)

Parameters

e

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.OnNodeRemoved Method

NodeListView.OnNodeRemoved Method
[image]

Invoked when the user removes a node from the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeRemoved (
DiagramNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeRemoved( _
e As DiagramNodeEventArgs _
)

Parameters

e

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.OnNodeSelected Method

NodeListView.OnNodeSelected Method
[image]

Invoked when the user selects a node in this list box.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnNodeSelected (
DiagramNodeEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnNodeSelected( _
e As DiagramNodeEventArgs _
)

Parameters

e

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.RefreshItemsSource Method

NodeListView.RefreshItemsSource Method
[image]

Force refresh the items source binding.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RefreshItemsSource ()

Visual Basic [image] Copy Code

Public Sub RefreshItemsSource ()

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.RemoveNode Method

NodeListView.RemoveNode Method
[image]

Removes the node from the list box.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveNode (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Sub RemoveNode( _
node As DiagramNode _
)

Parameters

node

The diagram node to remove.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.RemoveNodeAt Method

NodeListView.RemoveNodeAt Method
[image]

Removes the node at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveNodeAt (
int index
)

Visual Basic [image] Copy Code

Public Sub RemoveNodeAt( _
index As Integer _
)

Parameters

index

The zero-based index of the node to remove.

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.ResumeLayout Method

NodeListView.ResumeLayout Method
[image]

Resume the backing items source binding refresh.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResumeLayout ()

Visual Basic [image] Copy Code

Public Sub ResumeLayout ()

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.SuspendLayout Method

NodeListView.SuspendLayout Method
[image]

Suspend the backing items source binding refresh.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SuspendLayout ()

Visual Basic [image] Copy Code

Public Sub SuspendLayout ()

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView Properties

NodeListView Properties
[image]

Public Properties

Name | Description
DefaultNodeSize | Gets or sets the default size with which nodes dragged onto a diagram will be created.
IconMargin | Gets or sets the horizontal and vertical margins around the nodes.
IconSize | Gets or sets the size of the nodes displayed in the view.
MeasureUnit | Gets or sets the unit of measure used when drawing nodes.
NodesCount | Gets the number of nodes in the list view.
Target | The target DiagramView for drag/drop interactions.

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView.DefaultNodeSize Property

NodeListView.DefaultNodeSize Property
[image]

Gets or sets the default size with which nodes dragged onto a diagram will be created.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size DefaultNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultNodeSize As Size

Property Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.IconMargin Property

NodeListView.IconMargin Property
[image]

Gets or sets the horizontal and vertical margins around the nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size IconMargin { get; set; }

Visual Basic [image] Copy Code

Public Property IconMargin As Size

Property Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.IconSize Property

NodeListView.IconSize Property
[image]

Gets or sets the size of the nodes displayed in the view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size IconSize { get; set; }

Visual Basic [image] Copy Code

Public Property IconSize As Size

Property Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.MeasureUnit Property

NodeListView.MeasureUnit Property
[image]

Gets or sets the unit of measure used when drawing nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As MeasureUnit

Property Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.NodesCount Property

NodeListView.NodesCount Property
[image]

Gets the number of nodes in the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int NodesCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodesCount As Integer

Property Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.Target Property

NodeListView.Target Property
[image]

The target DiagramView for drag/drop interactions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramView Target { get; set; }

Visual Basic [image] Copy Code

Public Property Target As DiagramView

Property Value

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView Events

NodeListView Events
[image]

Public Events

Name | Description
DragComplete |
DragStarting |
NodeClicked | Raised when the user clicks a node in the list view.
NodeDoubleClicked | Raised when the user double-clicks a node in the list view.
NodeRemoved | Raised when the user removes a node from the list view.
NodeSelected | Raised when the user selects a node in the list view.

See Also

NodeListView Class


MindFusion.Diagramming.NodeListView.DragComplete Event

NodeListView.DragComplete Event
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DragEventArgs> DragComplete

Visual Basic [image] Copy Code

Public Event DragComplete As EventHandler(Of DragEventArgs)

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.DragStarting Event

NodeListView.DragStarting Event
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DragEventArgs> DragStarting

Visual Basic [image] Copy Code

Public Event DragStarting As EventHandler(Of DragEventArgs)

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.NodeClicked Event

NodeListView.NodeClicked Event
[image]

Raised when the user clicks a node in the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramNodeEventArgs> NodeClicked

Visual Basic [image] Copy Code

Public Event NodeClicked As EventHandler(Of DiagramNodeEventArgs)

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.NodeDoubleClicked Event

NodeListView.NodeDoubleClicked Event
[image]

Raised when the user double-clicks a node in the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramNodeEventArgs> NodeDoubleClicked

Visual Basic [image] Copy Code

Public Event NodeDoubleClicked As EventHandler(Of DiagramNodeEventArgs)

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.NodeRemoved Event

NodeListView.NodeRemoved Event
[image]

Raised when the user removes a node from the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramNodeEventArgs> NodeRemoved

Visual Basic [image] Copy Code

Public Event NodeRemoved As EventHandler(Of DiagramNodeEventArgs)

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeListView.NodeSelected Event

NodeListView.NodeSelected Event
[image]

Raised when the user selects a node in the list view.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<DiagramNodeEventArgs> NodeSelected

Visual Basic [image] Copy Code

Public Event NodeSelected As EventHandler(Of DiagramNodeEventArgs)

See Also

NodeListView Members
NodeListView Class


MindFusion.Diagramming.NodeValidationEventArgs Class

NodeValidationEventArgs Class
[image]

Contains the arguments passed to handlers of node validation events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NodeValidationEventArgs : NodeEventArgs

Visual Basic [image] Copy Code

Public Class NodeValidationEventArgs
Inherits NodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NodeEventArgs
MindFusion.Diagramming.NodeValidationEventArgs

See Also

NodeValidationEventArgs Members


MindFusion.Diagramming.NodeValidationEventArgs Members

NodeValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to handlers of node validation events.

The following tables list the members exposed by the NodeValidationEventArgs type.

Public Constructors

Name | Description
NodeValidationEventArgs | Overloaded. Initializes a new instance of the NodeValidationEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Cancel | Gets or sets a value indicating whether to cancel the current operation.
Label | Gets or sets a NodeLabel related to this event.
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)
OverrideBounds | Gets or sets a rectangle that should be assigned to the Bounds property of nodes after NodeModifying event is raised.
Position | Gets the location related to the event. (Inherited from NodeEventArgs.)
SelectionRectangle | Gets the current selection rectangle.

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the node.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor

NodeValidationEventArgs Constructor
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Overload List

Name | Description
NodeValidationEventArgs (DiagramNode) | Initializes a new instance of the NodeValidationEventArgs class.
NodeValidationEventArgs (DiagramNode, Point, AdjustmentHandles) | Initializes a new instance of the NodeValidationEventArgs class.
NodeValidationEventArgs (DiagramNode, Rect) | Initializes a new instance of the NodeValidationEventArgs class.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode)

NodeValidationEventArgs Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode _
)

Parameters

node

The DiagramNode related to the event.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)

NodeValidationEventArgs Constructor (DiagramNode, Point, AdjustmentHandles)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node,
Point position,
AdjustmentHandles adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
position As Point, _
adjustmentHandle As AdjustmentHandles _
)

Parameters

node

The DiagramNode related to the event.

position

The location related to the event, in document coordinates.

adjustmentHandle

The zero-based index of the adjustment handle related to the event.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Constructor (DiagramNode, Rect)

NodeValidationEventArgs Constructor (DiagramNode, Rect)
See Also
[image]

Initializes a new instance of the NodeValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeValidationEventArgs (
DiagramNode node,
Rect selectionRectangle
)

Visual Basic [image] Copy Code

Public New ( _
node As DiagramNode, _
selectionRectangle As Rect _
)

Parameters

node

The DiagramNode related to the event.

selectionRectangle

A Rectangle object representing the selection rectangle.

See Also

NodeValidationEventArgs Constructor Overload List
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Methods

NodeValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the creation or modification of the node.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.CancelDrag Method

NodeValidationEventArgs.CancelDrag Method
[image]

Cancels the creation or modification of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

Remarks

Calling this method immediately stops the operation.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs Properties

NodeValidationEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user. (Inherited from NodeEventArgs.)
Cancel | Gets or sets a value indicating whether to cancel the current operation.
Label | Gets or sets a NodeLabel related to this event.
Node | Gets the node for which the event was raised. (Inherited from NodeEventArgs.)
OverrideBounds | Gets or sets a rectangle that should be assigned to the Bounds property of nodes after NodeModifying event is raised.
Position | Gets the location related to the event. (Inherited from NodeEventArgs.)
SelectionRectangle | Gets the current selection rectangle.

See Also

NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.Cancel Property

NodeValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to cancel the current operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

true to cancel the operation; false to approve it.

Remarks

Set this property to true to prevent the user from completing the operation.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.Label Property

NodeValidationEventArgs.Label Property
[image]

Gets or sets a NodeLabel related to this event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeLabel Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As NodeLabel

Property Value

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.OverrideBounds Property

NodeValidationEventArgs.OverrideBounds Property
[image]

Gets or sets a rectangle that should be assigned to the Bounds property of nodes after NodeModifying event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect OverrideBounds { get; set; }

Visual Basic [image] Copy Code

Public Property OverrideBounds As Rect

Property Value

A Rectangle instance. The default value is Empty, signifying that the control should apply standard interaction logic when calculating new coordinates.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NodeValidationEventArgs.SelectionRectangle Property

NodeValidationEventArgs.SelectionRectangle Property
[image]

Gets the current selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect SelectionRectangle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SelectionRectangle As Rect

Property Value

A Rectangle instance representing the selection rectangle.

See Also

NodeValidationEventArgs Members
NodeValidationEventArgs Class


MindFusion.Diagramming.NotATreeException Class

NotATreeException Class
[image]

An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NotATreeException : Exception

Visual Basic [image] Copy Code

Public Class NotATreeException
Inherits Exception

Inheritance Hierarchy

System.Object
System.Exception
MindFusion.Diagramming.NotATreeException

See Also

NotATreeException Members


MindFusion.Diagramming.NotATreeException Members

NotATreeException Members
Constructors
[image]

An exception raised by the TreeEnumerator class if the specified node does not represent a root of a tree.

The following tables list the members exposed by the NotATreeException type.

Public Constructors

Name | Description
NotATreeException | Initializes a new instance of the NotATreeException class.

See Also

NotATreeException Class


MindFusion.Diagramming.NotATreeException Constructor

NotATreeException Constructor
[image]

Initializes a new instance of the NotATreeException class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NotATreeException ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

NotATreeException Class


MindFusion.Diagramming.NotifyCollectionChangedAction Enumeration

NotifyCollectionChangedAction Enumeration
[image]

Describes the action that caused a CollectionChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum NotifyCollectionChangedAction

Visual Basic [image] Copy Code

Public Enum NotifyCollectionChangedAction

Members

Member name | Description
Add | One or more items were added to the collection.
Remove | One or more items were removed from the collection.
Replace | One or more items were replaced in the collection.
Reset | The content of the collection changed dramatically.

See Also


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T) Class

NotifyCollectionChangedEventArgs(T) Class
[image]

Provides data for the ObservableCollection<T>.CollectionChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class NotifyCollectionChangedEventArgs<T> : EventArgs

Visual Basic [image] Copy Code

Public Class NotifyCollectionChangedEventArgs(Of T)
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T)

See Also

NotifyCollectionChangedEventArgs(T) Members


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T) Members

NotifyCollectionChangedEventArgs(T) Members
Constructors Properties
[image]

Provides data for the ObservableCollection<T>.CollectionChanged event.

The following tables list the members exposed by the NotifyCollectionChangedEventArgs(T) type.

Public Constructors

Name | Description
NotifyCollectionChangedEventArgs | Initializes a new instance of the NotifyCollectionChangedEventArgs class.

Public Properties

Name | Description
Action | Gets or sets the action that caused the event.
NewItems | Gets the list of new items involved in the change.
OldItems | Gets the list of items affected by a Replace, Remove, or Reset action.

See Also

NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T) Constructor

NotifyCollectionChangedEventArgs(T) Constructor
[image]

Initializes a new instance of the NotifyCollectionChangedEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NotifyCollectionChangedEventArgs<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T) Properties

NotifyCollectionChangedEventArgs(T) Properties
[image]

Public Properties

Name | Description
Action | Gets or sets the action that caused the event.
NewItems | Gets the list of new items involved in the change.
OldItems | Gets the list of items affected by a Replace, Remove, or Reset action.

See Also

NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T).Action Property

NotifyCollectionChangedEventArgs(T).Action Property
[image]

Gets or sets the action that caused the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NotifyCollectionChangedAction Action { get; set; }

Visual Basic [image] Copy Code

Public Property Action As NotifyCollectionChangedAction

Property Value

A member of the NotifyCollectionChangedAction enumeration.

See Also

NotifyCollectionChangedEventArgs(T) Members
NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T).NewItems Property

NotifyCollectionChangedEventArgs(T).NewItems Property
[image]

Gets the list of new items involved in the change.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public T[] NewItems { get; set; }

Visual Basic [image] Copy Code

Public Property NewItems As T()

Property Value

A list with the new items added to the collection. This can be null.

See Also

NotifyCollectionChangedEventArgs(T) Members
NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.NotifyCollectionChangedEventArgs(T).OldItems Property

NotifyCollectionChangedEventArgs(T).OldItems Property
[image]

Gets the list of items affected by a Replace, Remove, or Reset action.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public T[] OldItems { get; set; }

Visual Basic [image] Copy Code

Public Property OldItems As T()

Property Value

A list with the items removed from the collection. This can be null.

See Also

NotifyCollectionChangedEventArgs(T) Members
NotifyCollectionChangedEventArgs(T) Class


MindFusion.Diagramming.ObservableCollection(T) Class

ObservableCollection(T) Class
[image]

Represents a dynamic data collection that provides notifications when items get added, removed, or when the whole list is refreshed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ObservableCollection<T> : Collection<T>, INotifyCollectionChanged

Visual Basic [image] Copy Code

Public Class ObservableCollection(Of T)
Inherits Collection(Of T)
Implements INotifyCollectionChanged

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection(T)
MindFusion.Diagramming.ObservableCollection(T)

See Also

ObservableCollection(T) Members


MindFusion.Diagramming.ObservableCollection(T) Members

ObservableCollection(T) Members
Constructors Methods Events
[image]

Represents a dynamic data collection that provides notifications when items get added, removed, or when the whole list is refreshed.

The following tables list the members exposed by the ObservableCollection(T) type.

Public Constructors

Name | Description
ObservableCollection | Overloaded. Initializes a new instance of the ObservableCollection<T> class.

Public Methods

Name | Description
AddRange | Adds the specified objects to the end of the collection.

Protected Methods

Name | Description
ClearItems | Collection<T>.ClearItems override.
InsertItem | Collection<T>.InsertItem override.
OnCollectionChanged | Raises the CollectionChanged event.
RemoveItem | Collection<T>.RemoveItem override.
SetItem | Collection<T>.SetItem override.

Public Events

Name | Description
CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.

See Also

ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T) Constructor

ObservableCollection(T) Constructor
[image]

Initializes a new instance of the ObservableCollection<T> class.

Overload List

Name | Description
ObservableCollection(T) () | Initializes a new instance of the ObservableCollection<T> class.
ObservableCollection(T) (ICollection(T)) | Initializes a new instance of the ObservableCollection<T> class.

See Also

ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T) Constructor ()

ObservableCollection(T) Constructor ()
See Also
[image]

Initializes a new instance of the ObservableCollection<T> class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ObservableCollection<T> ()

Visual Basic [image] Copy Code

Public Sub New(Of T) ()

See Also

ObservableCollection(T) Constructor Overload List
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T) Constructor (ICollection(T))

ObservableCollection(T) Constructor (ICollection(T))
See Also
[image]

Initializes a new instance of the ObservableCollection<T> class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ObservableCollection<T> (
ICollection<T> items
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
items As ICollection(Of T) _
)

Parameters

items

The initial contents of the collection.

See Also

ObservableCollection(T) Constructor Overload List
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T) Methods

ObservableCollection(T) Methods
[image]

Public Methods

Name | Description
AddRange | Adds the specified objects to the end of the collection.

Protected Methods

Name | Description
ClearItems | Collection<T>.ClearItems override.
InsertItem | Collection<T>.InsertItem override.
OnCollectionChanged | Raises the CollectionChanged event.
RemoveItem | Collection<T>.RemoveItem override.
SetItem | Collection<T>.SetItem override.

See Also

ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).AddRange Method

ObservableCollection(T).AddRange Method
[image]

Adds the specified objects to the end of the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddRange (
ICollection<T> items
)

Visual Basic [image] Copy Code

Public Sub AddRange( _
items As ICollection(Of T) _
)

Parameters

items

The objects to add.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).ClearItems Method

ObservableCollection(T).ClearItems Method
[image]

Collection<T>.ClearItems override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ClearItems ()

Visual Basic [image] Copy Code

Protected Overrides Sub ClearItems ()

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).InsertItem Method

ObservableCollection(T).InsertItem Method
[image]

Collection<T>.InsertItem override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void InsertItem (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overrides Sub InsertItem( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index at which item should be inserted.

item

The object to insert. The value can be null for reference types.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).OnCollectionChanged Method

ObservableCollection(T).OnCollectionChanged Method
[image]

Raises the CollectionChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnCollectionChanged (
NotifyCollectionChangedEventArgs<T> e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnCollectionChanged( _
e As NotifyCollectionChangedEventArgs(Of T) _
)

Parameters

e

An object, containing the event data.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).RemoveItem Method

ObservableCollection(T).RemoveItem Method
[image]

Collection<T>.RemoveItem override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RemoveItem (
int index
)

Visual Basic [image] Copy Code

Protected Overrides Sub RemoveItem( _
index As Integer _
)

Parameters

index

The zero-based index of the element to remove.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).SetItem Method

ObservableCollection(T).SetItem Method
[image]

Collection<T>.SetItem override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetItem (
int index,
T item
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetItem( _
index As Integer, _
item As T _
)

Parameters

index

The zero-based index of the element to replace.

item

The new value for the element at the specified index. The value can be null for reference types.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T) Events

ObservableCollection(T) Events
[image]

Public Events

Name | Description
CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.

See Also

ObservableCollection(T) Class


MindFusion.Diagramming.ObservableCollection(T).CollectionChanged Event

ObservableCollection(T).CollectionChanged Event
[image]

Occurs when an item is added, removed, changed, moved, or the entire list is refreshed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<NotifyCollectionChangedEventArgs<T>> CollectionChanged

Visual Basic [image] Copy Code

Public Event CollectionChanged As EventHandler(Of NotifyCollectionChangedEventArgs(Of T))

Event Data

CollectionChanged events receive an argument of type NotifyCollectionChangedEventArgs.

See Also

ObservableCollection(T) Members
ObservableCollection(T) Class


MindFusion.Diagramming.Orientation Enumeration

Orientation Enumeration
[image]

Defines values that specify the orientation of the first segment of cascading links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Orientation

Visual Basic [image] Copy Code

Public Enum Orientation

Members

Member name | Description
Auto | MindFusion.Diagramming for .NET MAUI determines automatically the initial direction of link's first segment.
Horizontal | The first segment of the link is always horizontal.
Vertical | The first segment of the link is always vertical.

See Also


MindFusion.Diagramming.Path Class

Path Class
Remarks See Also
[image]

Represents a sequence of connected DiagramNode and DiagramLink elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Path

Visual Basic [image] Copy Code

Public NotInheritable Class Path

Remarks

Path instances are returned by methods of the PathFinder class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Path

See Also

Path Members


MindFusion.Diagramming.Path Members

Path Members
Properties Methods
[image]

Represents a sequence of connected DiagramNode and DiagramLink elements.

The following tables list the members exposed by the Path type.

Public Properties

Name | Description
Items | Gets a collection of all DiagramNode and DiagramLink elements in the path.
Length | Gets the length of the Path expressed as the number of Links participating in it.
Links | Gets a collection of all DiagramLink elements participating in the path.
Nodes | Gets a collection of all DiagramNode elements participating in the path.

Public Methods

Name | Description
GetWeight | Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

See Also

Path Class


MindFusion.Diagramming.Path Methods

Path Methods
[image]

Public Methods

Name | Description
GetWeight | Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

See Also

Path Class


MindFusion.Diagramming.Path.GetWeight Method

Path.GetWeight Method
[image]

Calculates the weight of this Path by accumulating the Weight of all participating Diagram elements.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GetWeight (
bool incNodes,
bool incLinks
)

Visual Basic [image] Copy Code

Public Function GetWeight( _
incNodes As Boolean, _
incLinks As Boolean _
) As Double

Parameters

incNodes

A boolean value, which specifies whether the Weight of DiagramNode elements should be considered.

incLinks

A boolean value, which specifies whether the Weight of DiagramLink elements should be considered.

Return Value

A double value that represents the total weight of the elements in this Path according to the incNodes and incLinks parameters.

See Also

Path Members
Path Class


MindFusion.Diagramming.Path Properties

Path Properties
[image]

Public Properties

Name | Description
Items | Gets a collection of all DiagramNode and DiagramLink elements in the path.
Length | Gets the length of the Path expressed as the number of Links participating in it.
Links | Gets a collection of all DiagramLink elements participating in the path.
Nodes | Gets a collection of all DiagramNode elements participating in the path.

See Also

Path Class


MindFusion.Diagramming.Path.Items Property

Path.Items Property
[image]

Gets a collection of all DiagramNode and DiagramLink elements in the path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

The collection contains consecutive DiagramNode and DiagramLink objects.

See Also

Path Members
Path Class


MindFusion.Diagramming.Path.Length Property

Path.Length Property
[image]

Gets the length of the Path expressed as the number of Links participating in it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Length { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Length As Integer

Property Value

An integer value that represents the number of edges (links) in the path.

See Also

Path Members
Path Class


MindFusion.Diagramming.Path.Links Property

Path.Links Property
[image]

Gets a collection of all DiagramLink elements participating in the path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

Use Nodes to get all DiagramNode elements in the Path.

See Also

Path Members
Path Class


MindFusion.Diagramming.Path.Nodes Property

Path.Nodes Property
[image]

Gets a collection of all DiagramNode elements participating in the path.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class.

Remarks

Use Links to get all DiagramLink elements in the Path.

See Also

Path Members
Path Class


MindFusion.Diagramming.PathCollection Class

PathCollection Class
[image]

Represents a strongly-typed collection of Path objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class PathCollection : List<Path>

Visual Basic [image] Copy Code

Public NotInheritable Class PathCollection
Inherits List(Of Path)

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(Path)
MindFusion.Diagramming.PathCollection

See Also

PathCollection Members


MindFusion.Diagramming.PathCollection Members

PathCollection Members
Constructors Methods
[image]

Represents a strongly-typed collection of Path objects.

The following tables list the members exposed by the PathCollection type.

Public Constructors

Name | Description
PathCollection | Initializes a new instance of the PathCollection class.

Public Methods

Name | Description
GetAt | Gets the Path at the specified position.

See Also

PathCollection Class


MindFusion.Diagramming.PathCollection Constructor

PathCollection Constructor
[image]

Initializes a new instance of the PathCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

PathCollection Class


MindFusion.Diagramming.PathCollection Methods

PathCollection Methods
[image]

Public Methods

Name | Description
GetAt | Gets the Path at the specified position.

See Also

PathCollection Class


MindFusion.Diagramming.PathCollection.GetAt Method

PathCollection.GetAt Method
[image]

Gets the Path at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As Path

Parameters

index

The zero-based index of the Path element to get.

Return Value

The Path at the specified position in the PathCollection.

See Also

PathCollection Members
PathCollection Class


MindFusion.Diagramming.PathFinder Class

PathFinder Class
Remarks See Also
[image]

Provides methods that help you find paths and cycles in a graph.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class PathFinder

Visual Basic [image] Copy Code

Public NotInheritable Class PathFinder

Remarks

By default the direction of links is taken into account when looking for paths or cycles. In that case the direction of a path is considered to be the direction defined by the outgoing links of nodes. Use the second constructor override to specify that link direction should be ignored when looking for paths.

A path-finder object caches graph information between method calls in order to achieve better performance when path and cycle -finding methods are called on the same diagram more than once. However if the diagram structure changes, you must create a new PathFinder instance in order to use the new structure of the diagram graph.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.PathFinder

See Also

PathFinder Members


MindFusion.Diagramming.PathFinder Members

PathFinder Members
Constructors Methods
[image]

Provides methods that help you find paths and cycles in a graph.

The following tables list the members exposed by the PathFinder type.

Public Constructors

Name | Description
PathFinder | Overloaded. Initializes a new instance of the PathFinder class.

Public Methods

Name | Description
EnumAllCycles | Enumerates all cycles in the underlying diagram.
FindAllCycles | Finds all cycles in the underlying diagram.
FindAllPaths | Overloaded. Finds and returns all paths that exist between two DiagramNode objects.
FindCycle | Overloaded. Finds a cycle in the Diagram.
FindLongestPath | Overloaded. Finds the longest path in the graph.
FindShortestPath | Overloaded. Finds and returns the shortest Path between two nodes.

See Also

PathFinder Class


MindFusion.Diagramming.PathFinder Constructor

PathFinder Constructor
[image]

Initializes a new instance of the PathFinder class.

Overload List

Name | Description
PathFinder (Diagram) | Initializes a new instance of the PathFinder class. Path-finding will depend on the direction of links.
PathFinder (Diagram, Boolean) | Initializes a new instance of the PathFinder class, optionally ignoring the link direction.

See Also

PathFinder Class


MindFusion.Diagramming.PathFinder Constructor (Diagram)

PathFinder Constructor (Diagram)
See Also
[image]

Initializes a new instance of the PathFinder class. Path-finding will depend on the direction of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathFinder (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

An instance of the Diagram class in which to look for paths or cycles.

See Also

PathFinder Constructor Overload List
PathFinder Class


MindFusion.Diagramming.PathFinder Constructor (Diagram, Boolean)

PathFinder Constructor (Diagram, Boolean)
See Also
[image]

Initializes a new instance of the PathFinder class, optionally ignoring the link direction.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathFinder (
Diagram diagram,
bool ignoreDirection
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
ignoreDirection As Boolean _
)

Parameters

diagram

A Diagram instance in which to look for paths or cycles.

ignoreDirection

Specifies whether the direction of links should be considered when looking for paths or cycles.

See Also

PathFinder Constructor Overload List
PathFinder Class


MindFusion.Diagramming.PathFinder Methods

PathFinder Methods
[image]

Public Methods

Name | Description
EnumAllCycles | Enumerates all cycles in the underlying diagram.
FindAllCycles | Finds all cycles in the underlying diagram.
FindAllPaths | Overloaded. Finds and returns all paths that exist between two DiagramNode objects.
FindCycle | Overloaded. Finds a cycle in the Diagram.
FindLongestPath | Overloaded. Finds the longest path in the graph.
FindShortestPath | Overloaded. Finds and returns the shortest Path between two nodes.

See Also

PathFinder Class


MindFusion.Diagramming.PathFinder.EnumAllCycles Method

PathFinder.EnumAllCycles Method
[image]

Enumerates all cycles in the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerable<Path> EnumAllCycles ()

Visual Basic [image] Copy Code

Public Function EnumAllCycles () As IEnumerable(Of Path)

Return Value

A collection of Path objects; if no cycles are detected, the collection is empty.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindAllCycles Method

PathFinder.FindAllCycles Method
[image]

Finds all cycles in the underlying diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathCollection FindAllCycles ()

Visual Basic [image] Copy Code

Public Function FindAllCycles () As PathCollection

Return Value

A collection of Path objects; if no cycles are detected, the collection is empty.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindAllPaths Method

PathFinder.FindAllPaths Method
[image]

Finds and returns all paths that exist between two DiagramNode objects.

Overload List

Name | Description
PathFinder.FindAllPaths (DiagramNode, DiagramNode) | Finds and returns all paths that exist between two DiagramNode objects.
PathFinder.FindAllPaths (DiagramNode, DiagramNode, Int32) | Finds and returns all paths that exist between two DiagramNode objects.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindAllPaths Method (DiagramNode, DiagramNode)

PathFinder.FindAllPaths Method (DiagramNode, DiagramNode)
See Also
[image]

Finds and returns all paths that exist between two DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathCollection FindAllPaths (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindAllPaths( _
from As DiagramNode, _
to As DiagramNode _
) As PathCollection

Parameters

from

The first DiagramNode in the Path.

to

The last DiagramNode in the Path.

Return Value

A collection of Path objects; if no paths are found, the collection is empty.

Remarks

The returned Path instances include the from an to nodes.

See Also

FindAllPaths Method Overload List
PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindAllPaths Method (DiagramNode, DiagramNode, Int32)

PathFinder.FindAllPaths Method (DiagramNode, DiagramNode, Int32)
See Also
[image]

Finds and returns all paths that exist between two DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PathCollection FindAllPaths (
DiagramNode from,
DiagramNode to,
int maxPaths
)

Visual Basic [image] Copy Code

Public Function FindAllPaths( _
from As DiagramNode, _
to As DiagramNode, _
maxPaths As Integer _
) As PathCollection

Parameters

from

The first DiagramNode in the Path.

to

The last DiagramNode in the Path.

maxPaths

The maximum number of paths to find.

Return Value

A collection of Path objects; if no paths are found, the collection is empty.

Remarks

The returned Path instances include the from an to nodes.

See Also

FindAllPaths Method Overload List
PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindCycle Method

PathFinder.FindCycle Method
[image]

Finds a cycle in the Diagram.

Overload List

Name | Description
PathFinder.FindCycle () | Finds a cycle in the Diagram.
PathFinder.FindCycle (DiagramNode) | Detects whether the specified DiagramNode participates in a cycle.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindCycle Method ()

PathFinder.FindCycle Method ()
See Also
[image]

Finds a cycle in the Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindCycle ()

Visual Basic [image] Copy Code

Public Function FindCycle () As Path

Return Value

A Path instance that represents the found cycle; null if no cycle is detected.

See Also

FindCycle Method Overload List
PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindCycle Method (DiagramNode)

PathFinder.FindCycle Method (DiagramNode)
See Also
[image]

Detects whether the specified DiagramNode participates in a cycle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindCycle (
DiagramNode participant
)

Visual Basic [image] Copy Code

Public Function FindCycle( _
participant As DiagramNode _
) As Path

Parameters

participant

A DiagramNode element which should participate in the found cycle.

Return Value

A Path instance that represents the found cycle; null if no cycle is detected.

See Also

FindCycle Method Overload List
PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindLongestPath Method

PathFinder.FindLongestPath Method
[image]

Finds the longest path in the graph.

Overload List

Name | Description
PathFinder.FindLongestPath () | Finds the longest path in the graph.
PathFinder.FindLongestPath (DiagramNode, DiagramNode) | Finds the longest path between the specified DiagramNode objects.
PathFinder.FindLongestPath (Int64) | Finds the longest path in the diagram.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindLongestPath Method ()

PathFinder.FindLongestPath Method ()
See Also
[image]

Finds the longest path in the graph.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindLongestPath ()

Visual Basic [image] Copy Code

Public Function FindLongestPath () As Path

Return Value

A Path instance that represents the longest path found; null if there are no DiagramNode elements in the graph.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindLongestPath Method (DiagramNode, DiagramNode)

PathFinder.FindLongestPath Method (DiagramNode, DiagramNode)
See Also
[image]

Finds the longest path between the specified DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindLongestPath (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindLongestPath( _
from As DiagramNode, _
to As DiagramNode _
) As Path

Parameters

from

The first DiagramNode element in the Path.

to

The last DiagramNode element in the Path.

Return Value

A Path instance that represents the longest path found; null if there is no Path connecting from and to.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindLongestPath Method (Int64)

PathFinder.FindLongestPath Method (Int64)
See Also
[image]

Finds the longest path in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindLongestPath (
long timeLimit
)

Visual Basic [image] Copy Code

Public Function FindLongestPath( _
timeLimit As Long _
) As Path

Parameters

timeLimit

The maximum duration of the search process, in milliseconds.

Return Value

The longest Path found; null if no Path has been detected.

See Also

FindLongestPath Method Overload List
PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindShortestPath Method

PathFinder.FindShortestPath Method
[image]

Finds and returns the shortest Path between two nodes.

Overload List

Name | Description
PathFinder.FindShortestPath (DiagramNode, DiagramNode) | Finds and returns the shortest Path between the specified DiagramNode objects.
PathFinder.FindShortestPath (DiagramNode, DiagramNode, Boolean, Boolean) | Finds and returns the shortest path between two DiagramNode elements, considering the Weight of the nodes, the Weight of the links or both.

See Also

PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindShortestPath Method (DiagramNode, DiagramNode)

PathFinder.FindShortestPath Method (DiagramNode, DiagramNode)
See Also
[image]

Finds and returns the shortest Path between the specified DiagramNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindShortestPath (
DiagramNode from,
DiagramNode to
)

Visual Basic [image] Copy Code

Public Function FindShortestPath( _
from As DiagramNode, _
to As DiagramNode _
) As Path

Parameters

from

The first DiagramNode in the Path.

to

The last DiagramNode in the Path.

Return Value

A Path instance that represents the shortest path found; null if there is no path connecting from and to.

See Also

FindShortestPath Method Overload List
PathFinder Members
PathFinder Class


MindFusion.Diagramming.PathFinder.FindShortestPath Method (DiagramNode, DiagramNode, Boolean, Boolean)

PathFinder.FindShortestPath Method (DiagramNode, DiagramNode, Boolean, Boolean)
See Also
[image]

Finds and returns the shortest path between two DiagramNode elements, considering the Weight of the nodes, the Weight of the links or both.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Path FindShortestPath (
DiagramNode from,
DiagramNode to,
bool useNodeWeights,
bool useLinkWeights
)

Visual Basic [image] Copy Code

Public Function FindShortestPath( _
from As DiagramNode, _
to As DiagramNode, _
useNodeWeights As Boolean, _
useLinkWeights As Boolean _
) As Path

Parameters

from

The first DiagramNode in the Path.

to

The last DiagramNode in the Path.

useNodeWeights

If true, the Path with minimal total weight is found, summing the Weight of nodes in the Path.

useLinkWeights

If true, the Path with minimal total weight is found, summing the Weight of links in the Path.

Return Value

A Path instance that represents the shortest Path found or null if there is no Path connecting from and to.

See Also

FindShortestPath Method Overload List
PathFinder Members
PathFinder Class


MindFusion.Diagramming.PointCollection Class

PointCollection Class
[image]

Represents a strongly-typed collection of points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class PointCollection : List<Point>

Visual Basic [image] Copy Code

Public Class PointCollection
Inherits List(Of Point)

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(Point)
MindFusion.Diagramming.PointCollection

See Also

PointCollection Members


MindFusion.Diagramming.PointCollection Members

PointCollection Members
Constructors Properties Methods
[image]

Represents a strongly-typed collection of points.

The following tables list the members exposed by the PointCollection type.

Public Constructors

Name | Description
PointCollection | Overloaded. Initializes a new instance of the PointCollection class.

Public Properties

Name | Description
First | Gets or sets the first point in the colleciton.
Last | Gets or sets the last point in the colleciton.

Public Methods

Name | Description
Clone | Creates a shallow copy of this collection.
GetAt | Gets the point at the specified position.

See Also

PointCollection Class


MindFusion.Diagramming.PointCollection Constructor

PointCollection Constructor
[image]

Initializes a new instance of the PointCollection class.

Overload List

Name | Description
PointCollection (IEnumerable(Point)) | Initializes a new instance of the PointCollection class.
PointCollection (Int32) | Initializes a new instance of the PointCollection class.

See Also

PointCollection Class


MindFusion.Diagramming.PointCollection Constructor (IEnumerable(Point))

PointCollection Constructor (IEnumerable(Point))
See Also
[image]

Initializes a new instance of the PointCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection (
IEnumerable<Point> collection
)

Visual Basic [image] Copy Code

Public New ( _
collection As IEnumerable(Of Point) _
)

Parameters

collection

An array of Point values that supplies the elements initially contained in the collection.

See Also

PointCollection Constructor Overload List
PointCollection Class


MindFusion.Diagramming.PointCollection Constructor (Int32)

PointCollection Constructor (Int32)
See Also
[image]

Initializes a new instance of the PointCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection (
int size
)

Visual Basic [image] Copy Code

Public New ( _
size As Integer _
)

Parameters

size

The initial size of the collection.

See Also

PointCollection Constructor Overload List
PointCollection Class


MindFusion.Diagramming.PointCollection Methods

PointCollection Methods
[image]

Public Methods

Name | Description
Clone | Creates a shallow copy of this collection.
GetAt | Gets the point at the specified position.

See Also

PointCollection Class


MindFusion.Diagramming.PointCollection.Clone Method

PointCollection.Clone Method
[image]

Creates a shallow copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As PointCollection

Return Value

An instance of the PointCollection class.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.GetAt Method

PointCollection.GetAt Method
[image]

Gets the point at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As Point

Parameters

index

The zero-based index of the point to retrieve.

Return Value

The Point object at the specified index.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection Properties

PointCollection Properties
[image]

Public Properties

Name | Description
First | Gets or sets the first point in the colleciton.
Last | Gets or sets the last point in the colleciton.

See Also

PointCollection Class


MindFusion.Diagramming.PointCollection.First Property

PointCollection.First Property
[image]

Gets or sets the first point in the colleciton.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point First { get; set; }

Visual Basic [image] Copy Code

Public Property First As Point

Property Value

The Point object.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.PointCollection.Last Property

PointCollection.Last Property
[image]

Gets or sets the last point in the colleciton.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Last { get; set; }

Visual Basic [image] Copy Code

Public Property Last As Point

Property Value

The Point object.

See Also

PointCollection Members
PointCollection Class


MindFusion.Diagramming.QuickRouter Class

QuickRouter Class
[image]

Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class QuickRouter : ILinkRouter

Visual Basic [image] Copy Code

Public Class QuickRouter
Implements ILinkRouter

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.QuickRouter

See Also

QuickRouter Members


MindFusion.Diagramming.QuickRouter Members

QuickRouter Members
Constructors Properties Methods
[image]

Implements a very fast link routing algorithm that uses a tree to represent the free and occupied regions in the diagram.

The following tables list the members exposed by the QuickRouter type.

Public Constructors

Name | Description
QuickRouter | Overloaded. Initializes a new instance of the QuickRouter class.

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.
Granularity | Gets or sets the granularity of the obstacles map generated by QuickRouter.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.
UBendMaxLen | Gets or sets the maximum U-bend length.

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteAllLinks | Routes all links in the diagram.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter Constructor

QuickRouter Constructor
[image]

Initializes a new instance of the QuickRouter class.

Overload List

Name | Description
QuickRouter () | Initializes a new instance of the QuickRouter class.
QuickRouter (Diagram) | Initializes a new instance of the QuickRouter class.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter Constructor ()

QuickRouter Constructor ()
See Also
[image]

Initializes a new instance of the QuickRouter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public QuickRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

QuickRouter Constructor Overload List
QuickRouter Class


MindFusion.Diagramming.QuickRouter Constructor (Diagram)

QuickRouter Constructor (Diagram)
See Also
[image]

Initializes a new instance of the QuickRouter class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public QuickRouter (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram this router will operate on.

See Also

QuickRouter Constructor Overload List
QuickRouter Class


MindFusion.Diagramming.QuickRouter Methods

QuickRouter Methods
[image]

Public Methods

Name | Description
Resume | Implements ILinkRouter.Resume.
RouteAllLinks | Routes all links in the diagram.
RouteLink | Implements ILinkRouter.RouteLink.
RouteLinks | Implements ILinkRouter.RouteLinks.
Suspend | Implements ILinkRouter.Suspend.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter.Resume Method

QuickRouter.Resume Method
[image]

Implements ILinkRouter.Resume.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Resume (
bool routeDeferredLinks
)

Visual Basic [image] Copy Code

Public Sub Resume( _
routeDeferredLinks As Boolean _
)

Parameters

routeDeferredLinks

true if the links should be routed, otherwise false.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.RouteAllLinks Method

QuickRouter.RouteAllLinks Method
[image]

Routes all links in the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RouteAllLinks ()

Visual Basic [image] Copy Code

Public Sub RouteAllLinks ()

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.RouteLink Method

QuickRouter.RouteLink Method
[image]

Implements ILinkRouter.RouteLink.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RouteLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function RouteLink( _
link As DiagramLink _
) As Boolean

Parameters

link

The DiagramLink to route.

Return Value

true if a path has been found successfully, otherwise false.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.RouteLinks Method

QuickRouter.RouteLinks Method
[image]

Implements ILinkRouter.RouteLinks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RouteLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Public Sub RouteLinks( _
links As DiagramLinkCollection _
)

Parameters

links

A list of DiagramLink objects that should be routed.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.Suspend Method

QuickRouter.Suspend Method
[image]

Implements ILinkRouter.Suspend.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Suspend ()

Visual Basic [image] Copy Code

Public Sub Suspend ()

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter Properties

QuickRouter Properties
[image]

Public Properties

Name | Description
Diagram | Gets or sets the diagram this router is associated with.
Granularity | Gets or sets the granularity of the obstacles map generated by QuickRouter.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.
UBendMaxLen | Gets or sets the maximum U-bend length.

See Also

QuickRouter Class


MindFusion.Diagramming.QuickRouter.Diagram Property

QuickRouter.Diagram Property
[image]

Gets or sets the diagram this router is associated with.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; set; }

Visual Basic [image] Copy Code

Public Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.Granularity Property

QuickRouter.Granularity Property
[image]

Gets or sets the granularity of the obstacles map generated by QuickRouter.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Granularity Granularity { get; set; }

Visual Basic [image] Copy Code

Public Property Granularity As Granularity

Property Value

A member of the Granularity enumeration. The default value is CoarseGrained.

Remarks

A CoarseGrained obstacle map leads to faster path finding, however the found paths might be longer than necessary in a small percent of the cases. The coarse-grained map also takes slightly more time to build, so you might disable it if there are aren't many links in the diagram.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.TurnCost Property

QuickRouter.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TurnCost { get; set; }

Visual Basic [image] Copy Code

Public Property TurnCost As Double

Property Value

A double value.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.QuickRouter.UBendMaxLen Property

QuickRouter.UBendMaxLen Property
[image]

Gets or sets the maximum U-bend length.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double UBendMaxLen { get; set; }

Visual Basic [image] Copy Code

Public Property UBendMaxLen As Double

Property Value

A double value specifying the maximum length of U-bends. The default is 30.

See Also

QuickRouter Members
QuickRouter Class


MindFusion.Diagramming.RadialMenu Class

RadialMenu Class
[image]

Represents a context menu that can be used to in-place edit and delete diagram items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RadialMenu : AbsoluteLayout

Visual Basic [image] Copy Code

Public Class RadialMenu
Inherits AbsoluteLayout

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
Microsoft.Maui.Controls.Layout
Microsoft.Maui.Controls.AbsoluteLayout
MindFusion.Diagramming.RadialMenu

See Also

RadialMenu Members


MindFusion.Diagramming.RadialMenu Members

RadialMenu Members
Properties Methods
[image]

Represents a context menu that can be used to in-place edit and delete diagram items.

The following tables list the members exposed by the RadialMenu type.

Public Properties

Name | Description
DefaultFillBrush | Gets or sets the default fill brush of the menu items.
DefaultItem | Gets or sets the default menu item.
DefaultItemsSize | Gets or sets the default size of the menu items.
DefaultStroke | Gets or sets the default stroke of the menu items.
HitTestThreshold | Gets or sets the threshold to consider when hit-testing menu items for selection
Location | Gets the location of the menu
Position | Gets or sets the position of the menu items relative to the menu center.
SelectedItem | Gets or sets the selected menu item.

Public Methods

Name | Description
AddMenuItem | Overloaded.
ClearItems | Clears the contents of the menu's items collection.
RemoveMenuItem | Removes an existing menu item from the menu's items collection.

See Also

RadialMenu Class


MindFusion.Diagramming.RadialMenu Methods

RadialMenu Methods
[image]

Public Methods

Name | Description
AddMenuItem | Overloaded.
ClearItems | Clears the contents of the menu's items collection.
RemoveMenuItem | Removes an existing menu item from the menu's items collection.

See Also

RadialMenu Class


MindFusion.Diagramming.RadialMenu.AddMenuItem Method

RadialMenu.AddMenuItem Method
[image]

Overload List

Name | Description
RadialMenu.AddMenuItem (ImageSource) |
RadialMenu.AddMenuItem (String) | Adds a new menu item, initialized with the specified image, to the radial menu.

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.AddMenuItem Method (ImageSource)

RadialMenu.AddMenuItem Method (ImageSource)
See Also
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IMenuItem AddMenuItem (
ImageSource image
)

Visual Basic [image] Copy Code

Public Function AddMenuItem( _
image As ImageSource _
) As IMenuItem

Parameters

image

Return Value

See Also

AddMenuItem Method Overload List
RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.AddMenuItem Method (String)

RadialMenu.AddMenuItem Method (String)
See Also
[image]

Adds a new menu item, initialized with the specified image, to the radial menu.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IMenuItem AddMenuItem (
string fileName
)

Visual Basic [image] Copy Code

Public Function AddMenuItem( _
fileName As String _
) As IMenuItem

Parameters

fileName

The file name of the item image.

Return Value

The newly created item.

See Also

AddMenuItem Method Overload List
RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.ClearItems Method

RadialMenu.ClearItems Method
[image]

Clears the contents of the menu's items collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ClearItems ()

Visual Basic [image] Copy Code

Public Sub ClearItems ()

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.RemoveMenuItem Method

RadialMenu.RemoveMenuItem Method
[image]

Removes an existing menu item from the menu's items collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RemoveMenuItem (
IMenuItem item
)

Visual Basic [image] Copy Code

Public Function RemoveMenuItem( _
item As IMenuItem _
) As Boolean

Parameters

item

The item to remove.

Return Value

true if the item was successfully removed, otherwise false.

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu Properties

RadialMenu Properties
[image]

Public Properties

Name | Description
DefaultFillBrush | Gets or sets the default fill brush of the menu items.
DefaultItem | Gets or sets the default menu item.
DefaultItemsSize | Gets or sets the default size of the menu items.
DefaultStroke | Gets or sets the default stroke of the menu items.
HitTestThreshold | Gets or sets the threshold to consider when hit-testing menu items for selection
Location | Gets the location of the menu
Position | Gets or sets the position of the menu items relative to the menu center.
SelectedItem | Gets or sets the selected menu item.

See Also

RadialMenu Class


MindFusion.Diagramming.RadialMenu.DefaultFillBrush Property

RadialMenu.DefaultFillBrush Property
[image]

Gets or sets the default fill brush of the menu items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush DefaultFillBrush { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultFillBrush As Brush

Property Value

An instance of the Brush class.

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.DefaultItem Property

RadialMenu.DefaultItem Property
[image]

Gets or sets the default menu item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IMenuItem DefaultItem { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultItem As IMenuItem

Property Value

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.DefaultItemsSize Property

RadialMenu.DefaultItemsSize Property
[image]

Gets or sets the default size of the menu items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size DefaultItemsSize { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultItemsSize As Size

Property Value

A Size object.

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.DefaultStroke Property

RadialMenu.DefaultStroke Property
[image]

Gets or sets the default stroke of the menu items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen DefaultStroke { get; set; }

Visual Basic [image] Copy Code

Public Property DefaultStroke As Pen

Property Value

An instance of the Pen class.

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.HitTestThreshold Property

RadialMenu.HitTestThreshold Property
[image]

Gets or sets the threshold to consider when hit-testing menu items for selection

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HitTestThreshold { get; set; }

Visual Basic [image] Copy Code

Public Property HitTestThreshold As Double

Property Value

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.Location Property

RadialMenu.Location Property
[image]

Gets the location of the menu

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Location { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Location As Point

Property Value

A Point value specifying the menu location.

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.Position Property

RadialMenu.Position Property
[image]

Gets or sets the position of the menu items relative to the menu center.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VisualizationPosition Position { get; set; }

Visual Basic [image] Copy Code

Public Property Position As VisualizationPosition

Property Value

A member of the VisualizationPosition enumeration.

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenu.SelectedItem Property

RadialMenu.SelectedItem Property
[image]

Gets or sets the selected menu item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IMenuItem SelectedItem { get; set; }

Visual Basic [image] Copy Code

Public Property SelectedItem As IMenuItem

Property Value

See Also

RadialMenu Members
RadialMenu Class


MindFusion.Diagramming.RadialMenuEventArgs Class

RadialMenuEventArgs Class
[image]

Contains the arguments passed to the ContextMenuShowing event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RadialMenuEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class RadialMenuEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.RadialMenuEventArgs

See Also

RadialMenuEventArgs Members


MindFusion.Diagramming.RadialMenuEventArgs Members

RadialMenuEventArgs Members
Properties
[image]

Contains the arguments passed to the ContextMenuShowing event handlers.

The following tables list the members exposed by the RadialMenuEventArgs type.

Public Properties

Name | Description
Menu | Gets a reference to the menu.
Target |

See Also

RadialMenuEventArgs Class


MindFusion.Diagramming.RadialMenuEventArgs Properties

RadialMenuEventArgs Properties
[image]

Public Properties

Name | Description
Menu | Gets a reference to the menu.
Target |

See Also

RadialMenuEventArgs Class


MindFusion.Diagramming.RadialMenuEventArgs.Menu Property

RadialMenuEventArgs.Menu Property
[image]

Gets a reference to the menu.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RadialMenu Menu { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Menu As RadialMenu

Property Value

An instance of the RadialMenu class.

See Also

RadialMenuEventArgs Members
RadialMenuEventArgs Class


MindFusion.Diagramming.RadialMenuEventArgs.Target Property

RadialMenuEventArgs.Target Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Target { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Target As Object

Property Value

See Also

RadialMenuEventArgs Members
RadialMenuEventArgs Class


MindFusion.Diagramming.ReadOnlyCollection(T) Class

ReadOnlyCollection(T) Class
[image]

Represents a read-only wrapper of a collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ReadOnlyCollection<T> : ICollection, IEnumerable

Visual Basic [image] Copy Code

Public Class ReadOnlyCollection(Of T)
Implements ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection(T)
MindFusion.Diagramming.ReadOnlyDiagramItemCollection
MindFusion.Diagramming.ReadOnlyDiagramLinkCollection
MindFusion.Diagramming.ReadOnlyDiagramNodeCollection

See Also

ReadOnlyCollection(T) Members


MindFusion.Diagramming.ReadOnlyCollection(T) Members

ReadOnlyCollection(T) Members
Constructors Properties Methods
[image]

Represents a read-only wrapper of a collection.

The following tables list the members exposed by the ReadOnlyCollection(T) type.

Public Constructors

Name | Description
ReadOnlyCollection | Initializes a new instance of the ReadonlyCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Name | Description
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that can iterate through the collection.

See Also

ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T) Constructor

ReadOnlyCollection(T) Constructor
[image]

Initializes a new instance of the ReadonlyCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyCollection<T> (
ICollection<T> innerCollection
)

Visual Basic [image] Copy Code

Public New (Of T) ( _
innerCollection As ICollection(Of T) _
)

Parameters

innerCollection

An ICollection that represents the collection to wrap.

See Also

ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T) Methods

ReadOnlyCollection(T) Methods
[image]

Public Methods

Name | Description
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that can iterate through the collection.

See Also

ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T).CopyTo Method

ReadOnlyCollection(T).CopyTo Method
[image]

Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CopyTo (
Array array,
int index
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array As Array, _
index As Integer _
)

Parameters

array

The one-dimensional Array that is the destination of the elements copied from the current collection.

index

A 32-bit integer that represents the index in array at which copying begins.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T).GetEnumerator Method

ReadOnlyCollection(T).GetEnumerator Method
[image]

Returns an enumerator that can iterate through the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerator GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator

Return Value

An IEnumerator for the collection.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T) Properties

ReadOnlyCollection(T) Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T).Count Property

ReadOnlyCollection(T).Count Property
[image]

Gets the number of elements contained in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

The number of elements actually contained in the collection.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T).IsSynchronized Property

ReadOnlyCollection(T).IsSynchronized Property
[image]

Gets a value indicating whether the access to the collection is synchronized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsSynchronized { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSynchronized As Boolean

Property Value

true if access to the collection is synchronized (thread safe); otherwise, false.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyCollection(T).SyncRoot Property

ReadOnlyCollection(T).SyncRoot Property
[image]

Gets an object that can be used to synchronize access to the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object SyncRoot { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SyncRoot As Object

Property Value

An object that can be used to synchronize access to the collection.

See Also

ReadOnlyCollection(T) Members
ReadOnlyCollection(T) Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Class

ReadOnlyDiagramItemCollection Class
[image]

Represents a read-only collection of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ReadOnlyDiagramItemCollection : ReadOnlyCollection<DiagramItem>

Visual Basic [image] Copy Code

Public Class ReadOnlyDiagramItemCollection
Inherits ReadOnlyCollection(Of DiagramItem)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection(DiagramItem)
MindFusion.Diagramming.ReadOnlyDiagramItemCollection

See Also

ReadOnlyDiagramItemCollection Members


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Members

ReadOnlyDiagramItemCollection Members
Constructors Properties Methods
[image]

Represents a read-only collection of items.

The following tables list the members exposed by the ReadOnlyDiagramItemCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramItemCollection | Initializes a new instance of the ReadOnlyDiagramItemCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramItem at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

Public Methods

Name | Description
Contains | Checks whether the specified DiagramItem is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Constructor

ReadOnlyDiagramItemCollection Constructor
[image]

Initializes a new instance of the ReadOnlyDiagramItemCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyDiagramItemCollection (
DiagramItemCollection innerCollection
)

Visual Basic [image] Copy Code

Public New ( _
innerCollection As DiagramItemCollection _
)

Parameters

innerCollection

A DiagramItemCollection object that represents the collection to wrap.

Remarks

A DiagramItemCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Methods

ReadOnlyDiagramItemCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified DiagramItem is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection.Contains Method

ReadOnlyDiagramItemCollection.Contains Method
[image]

Checks whether the specified DiagramItem is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function Contains( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to search for in the collection.

Return Value

true if the specified item is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection.IndexOf Method

ReadOnlyDiagramItemCollection.IndexOf Method
[image]

Searches for the specified DiagramItem and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
item As DiagramItem _
) As Integer

Parameters

item

The DiagramItem whose index to retrieve from the collection.

Return Value

The zero-based index of the specified item within the collection; or -1 if the item is not found.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection Properties

ReadOnlyDiagramItemCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramItem at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

See Also

ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramItemCollection.Item Property

ReadOnlyDiagramItemCollection.Item Property
[image]

Gets the DiagramItem at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As DiagramItem

Parameters

index

The zero-based index of the item to get.

Property Value

An instance of the DiagramItem class that represents the item at the specified position.

See Also

ReadOnlyDiagramItemCollection Members
ReadOnlyDiagramItemCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Class

ReadOnlyDiagramLinkCollection Class
[image]

Represents a read-only collection of links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ReadOnlyDiagramLinkCollection : ReadOnlyCollection<DiagramLink>

Visual Basic [image] Copy Code

Public Class ReadOnlyDiagramLinkCollection
Inherits ReadOnlyCollection(Of DiagramLink)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection(DiagramLink)
MindFusion.Diagramming.ReadOnlyDiagramLinkCollection

See Also

ReadOnlyDiagramLinkCollection Members


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Members

ReadOnlyDiagramLinkCollection Members
Constructors Properties Methods
[image]

Represents a read-only collection of links.

The following tables list the members exposed by the ReadOnlyDiagramLinkCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramLinkCollection | Initializes a new instance of the ReadOnlyDiagramLinkCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramLink at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

Public Methods

Name | Description
Contains | Checks whether the specified DiagramLink is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Constructor

ReadOnlyDiagramLinkCollection Constructor
[image]

Initializes a new instance of the ReadOnlyDiagramLinkCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyDiagramLinkCollection (
DiagramLinkCollection innerCollection
)

Visual Basic [image] Copy Code

Public New ( _
innerCollection As DiagramLinkCollection _
)

Parameters

innerCollection

A DiagramLinkCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Methods

ReadOnlyDiagramLinkCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified DiagramLink is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection.Contains Method

ReadOnlyDiagramLinkCollection.Contains Method
[image]

Checks whether the specified DiagramLink is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function Contains( _
link As DiagramLink _
) As Boolean

Parameters

link

The DiagramLink to search for in the collection.

Return Value

true if the specified link is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection.IndexOf Method

ReadOnlyDiagramLinkCollection.IndexOf Method
[image]

Searches for the specified DiagramLink and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
link As DiagramLink _
) As Integer

Parameters

link

The DiagramLink whose index to retrieve from the collection.

Return Value

The zero-based index of the specified link within the collection; or -1 if the link is not found.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection Properties

ReadOnlyDiagramLinkCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramLink at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

See Also

ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramLinkCollection.Item Property

ReadOnlyDiagramLinkCollection.Item Property
[image]

Gets the DiagramLink at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As DiagramLink

Parameters

index

The zero-based index of the link to get.

Property Value

An instance of the DiagramLink class that represents the link at the specified position.

See Also

ReadOnlyDiagramLinkCollection Members
ReadOnlyDiagramLinkCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Class

ReadOnlyDiagramNodeCollection Class
[image]

Represents a read-only collection of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ReadOnlyDiagramNodeCollection : ReadOnlyCollection<DiagramNode>

Visual Basic [image] Copy Code

Public Class ReadOnlyDiagramNodeCollection
Inherits ReadOnlyCollection(Of DiagramNode)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ReadOnlyCollection(DiagramNode)
MindFusion.Diagramming.ReadOnlyDiagramNodeCollection

See Also

ReadOnlyDiagramNodeCollection Members


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Members

ReadOnlyDiagramNodeCollection Members
Constructors Properties Methods
[image]

Represents a read-only collection of nodes.

The following tables list the members exposed by the ReadOnlyDiagramNodeCollection type.

Public Constructors

Name | Description
ReadOnlyDiagramNodeCollection | Initializes a new instance of the ReadOnlyDiagramNodeCollection class.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramNode at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

Public Methods

Name | Description
Contains | Checks whether the specified DiagramNode is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Constructor

ReadOnlyDiagramNodeCollection Constructor
[image]

Initializes a new instance of the ReadOnlyDiagramNodeCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ReadOnlyDiagramNodeCollection (
DiagramNodeCollection innerCollection
)

Visual Basic [image] Copy Code

Public New ( _
innerCollection As DiagramNodeCollection _
)

Parameters

innerCollection

A DiagramNodeCollection object that represents the collection to wrap.

See Also

ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Methods

ReadOnlyDiagramNodeCollection Methods
[image]

Public Methods

Name | Description
Contains | Checks whether the specified DiagramNode is contained within the collection.
CopyTo | Copies a range of elements from this collection to a compatible one-dimensional System.Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection.)
GetEnumerator | Returns an enumerator that can iterate through the collection. (Inherited from ReadOnlyCollection.)
IndexOf | Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

See Also

ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection.Contains Method

ReadOnlyDiagramNodeCollection.Contains Method
[image]

Checks whether the specified DiagramNode is contained within the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function Contains( _
node As DiagramNode _
) As Boolean

Parameters

node

The DiagramNode to search for in the collection.

Return Value

true if the specified node is contained in the collection; otherwise, false.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection.IndexOf Method

ReadOnlyDiagramNodeCollection.IndexOf Method
[image]

Searches for the specified DiagramNode and returns the 0-based index of the first occurrence within the entire collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
DiagramNode node
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
node As DiagramNode _
) As Integer

Parameters

node

The DiagramNode whose index to retrieve from the collection.

Return Value

The zero-based index of the specified node within the collection; or -1 if the node is not found.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection Properties

ReadOnlyDiagramNodeCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection. (Inherited from ReadOnlyCollection.)
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized. (Inherited from ReadOnlyCollection.)
Item | Gets the DiagramNode at the specified position.
SyncRoot | Gets an object that can be used to synchronize access to the collection. (Inherited from ReadOnlyCollection.)

See Also

ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.ReadOnlyDiagramNodeCollection.Item Property

ReadOnlyDiagramNodeCollection.Item Property
[image]

Gets the DiagramNode at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As DiagramNode

Parameters

index

The zero-based index of the node to get.

Property Value

An instance of the DiagramNode class that represents the node at the specified position.

See Also

ReadOnlyDiagramNodeCollection Members
ReadOnlyDiagramNodeCollection Class


MindFusion.Diagramming.Relationship Enumeration

Relationship Enumeration
[image]

Specifies the type of relationship between two tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Relationship

Visual Basic [image] Copy Code

Public Enum Relationship

Members

Member name | Description
ManyToOne | The relationship is of type M:1, that is, many to one.
OneToMany | The relationship is of type 1:M, that is, one to many.

Remarks

Use the enumeration values when drawing database diagrams. It helps you specify how database tables' fields are related.

See Also


MindFusion.Diagramming.RelativeToLink Enumeration

RelativeToLink Enumeration
[image]

Specifies how the link labels are positioned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RelativeToLink

Visual Basic [image] Copy Code

Public Enum RelativeToLink

Members

Member name | Description
ControlPoint | Indicates that the link labels are positioned relative to a specified control point.
LinkLength | Indicates that the link labels are positioned relative to the link.
Segment | Indicates that the link labels are positioned relative to a specified segment.

See Also


MindFusion.Diagramming.RelativeToNode Enumeration

RelativeToNode Enumeration
[image]

Specifies how the node labels are positioned.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RelativeToNode

Visual Basic [image] Copy Code

Public Enum RelativeToNode

Members

Member name | Description
Center | Indicates that the node labels are positioned relative to the node center.
Corner | Indicates that the node labels are positioned relative to a specified corner point.
Edge | Indicates that the node labels are positioned relative to a specified edge.

See Also


MindFusion.Diagramming.RenderOptions Class

RenderOptions Class
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RenderOptions

Visual Basic [image] Copy Code

Public Class RenderOptions

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.RenderOptions

See Also

RenderOptions Members


MindFusion.Diagramming.RenderOptions Members

RenderOptions Members
Constructors Properties
[image]

Provides properties that allow customization of various aspects of printing and print-preview.

The following tables list the members exposed by the RenderOptions type.

Public Constructors

Name | Description
RenderOptions | Initializes a new instance of the RenderOptions class

Public Properties

Name | Description
EnableAnchors | Gets or sets a value indicating whether the printing of anchor point marks is enabled.
EnableBackground | Gets or sets a value indicating whether the printing of the background color is enabled.
EnableBackgroundImage | Gets or sets a value indicating whether the printing of the background image is enabled.
EnableEffects | Enables or disables special effects, such as emboss.
EnableGrid | Gets or sets a value indicating whether the alignment grid is rendered.
EnableImages | Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.
EnableInterior | Gets or sets a value indicating whether the printing of node interiors is enabled.
EnableShadows | Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.
EnableText | Gets or sets a value indicating whether the printing of the text of diagram items is enabled.
HyperLinkStyle | Specifies how various export components should treat the HyperLink property of items.
HyperLinkTarget | Specifies the value of the Target attribute generated by various export components for the HyperLink property of items.
InternalMsg | For internal use.
MeasureUnit | Specifies the diagram's unit of measure.
RenderTarget | Gets or sets the rendering target.
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
TargetView | Gets or sets the object that currently displays the Diagram.
VisibleRect | Specifies which part of the diagram is currently visible.

See Also

RenderOptions Class


MindFusion.Diagramming.RenderOptions Constructor

RenderOptions Constructor
[image]

Initializes a new instance of the RenderOptions class

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RenderOptions ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RenderOptions Class


MindFusion.Diagramming.RenderOptions Properties

RenderOptions Properties
[image]

Public Properties

Name | Description
EnableAnchors | Gets or sets a value indicating whether the printing of anchor point marks is enabled.
EnableBackground | Gets or sets a value indicating whether the printing of the background color is enabled.
EnableBackgroundImage | Gets or sets a value indicating whether the printing of the background image is enabled.
EnableEffects | Enables or disables special effects, such as emboss.
EnableGrid | Gets or sets a value indicating whether the alignment grid is rendered.
EnableImages | Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.
EnableInterior | Gets or sets a value indicating whether the printing of node interiors is enabled.
EnableShadows | Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.
EnableText | Gets or sets a value indicating whether the printing of the text of diagram items is enabled.
HyperLinkStyle | Specifies how various export components should treat the HyperLink property of items.
HyperLinkTarget | Specifies the value of the Target attribute generated by various export components for the HyperLink property of items.
InternalMsg | For internal use.
MeasureUnit | Specifies the diagram's unit of measure.
RenderTarget | Gets or sets the rendering target.
Scale | Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.
ScrollX | Gets or sets the document's X scroll position.
ScrollY | Gets or sets the document's Y scroll position.
TargetView | Gets or sets the object that currently displays the Diagram.
VisibleRect | Specifies which part of the diagram is currently visible.

See Also

RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableAnchors Property

RenderOptions.EnableAnchors Property
[image]

Gets or sets a value indicating whether the printing of anchor point marks is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableAnchors { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAnchors As Boolean

Property Value

true if anchor point marks should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableBackground Property

RenderOptions.EnableBackground Property
[image]

Gets or sets a value indicating whether the printing of the background color is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableBackground { get; set; }

Visual Basic [image] Copy Code

Public Property EnableBackground As Boolean

Property Value

true if the diagram background should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableBackgroundImage Property

RenderOptions.EnableBackgroundImage Property
[image]

Gets or sets a value indicating whether the printing of the background image is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableBackgroundImage { get; set; }

Visual Basic [image] Copy Code

Public Property EnableBackgroundImage As Boolean

Property Value

true if the background image should be printed; otherwise, false. The default is false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableEffects Property

RenderOptions.EnableEffects Property
[image]

Enables or disables special effects, such as emboss.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableEffects { get; set; }

Visual Basic [image] Copy Code

Public Property EnableEffects As Boolean

Property Value

A boolean value.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableGrid Property

RenderOptions.EnableGrid Property
[image]

Gets or sets a value indicating whether the alignment grid is rendered.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableGrid { get; set; }

Visual Basic [image] Copy Code

Public Property EnableGrid As Boolean

Property Value

true to render the alignment grid, if visible; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableImages Property

RenderOptions.EnableImages Property
[image]

Gets or sets a value indicating whether the printing of images that are displayed in nodes is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableImages { get; set; }

Visual Basic [image] Copy Code

Public Property EnableImages As Boolean

Property Value

true to print node images; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableInterior Property

RenderOptions.EnableInterior Property
[image]

Gets or sets a value indicating whether the printing of node interiors is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableInterior { get; set; }

Visual Basic [image] Copy Code

Public Property EnableInterior As Boolean

Property Value

true to print node interiors; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableShadows Property

RenderOptions.EnableShadows Property
[image]

Gets or sets a value indicating whether the printing of the shadows of diagram items is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableShadows { get; set; }

Visual Basic [image] Copy Code

Public Property EnableShadows As Boolean

Property Value

true to print item shadows; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.EnableText Property

RenderOptions.EnableText Property
[image]

Gets or sets a value indicating whether the printing of the text of diagram items is enabled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableText { get; set; }

Visual Basic [image] Copy Code

Public Property EnableText As Boolean

Property Value

true to print item texts; otherwise, false.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.HyperLinkStyle Property

RenderOptions.HyperLinkStyle Property
[image]

Specifies how various export components should treat the HyperLink property of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HyperLinkStyle HyperLinkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLinkStyle As HyperLinkStyle

Property Value

A member of the HyperLinkStyle enumeration.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.HyperLinkTarget Property

RenderOptions.HyperLinkTarget Property
[image]

Specifies the value of the Target attribute generated by various export components for the HyperLink property of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string HyperLinkTarget { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLinkTarget As String

Property Value

The default value is "_self".

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.InternalMsg Property

RenderOptions.InternalMsg Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static string InternalMsg { get; set; }

Visual Basic [image] Copy Code

Public Shared Property InternalMsg As String

Property Value

A string value.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.MeasureUnit Property

RenderOptions.MeasureUnit Property
[image]

Specifies the diagram's unit of measure.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MeasureUnit MeasureUnit { get; set; }

Visual Basic [image] Copy Code

Public Property MeasureUnit As MeasureUnit

Property Value

An instance of the MeasureUnit class specifying the diagram's unit of measure.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.RenderTarget Property

RenderOptions.RenderTarget Property
[image]

Gets or sets the rendering target.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RenderTarget RenderTarget { get; set; }

Visual Basic [image] Copy Code

Public Property RenderTarget As RenderTarget

Property Value

A value from the RenderTarget enumeration specifying whether rendering is done on the screen or on a printer.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.Scale Property

RenderOptions.Scale Property
[image]

Gets or sets the scale of the print output relatively to the original on-screen size of the diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Scale { get; set; }

Visual Basic [image] Copy Code

Public Property Scale As Double

Property Value

A double value specifying the scale of the print output as percentage of original size.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.ScrollX Property

RenderOptions.ScrollX Property
[image]

Gets or sets the document's X scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollX { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollX As Double

Property Value

A double value specifying the X scroll position.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.ScrollY Property

RenderOptions.ScrollY Property
[image]

Gets or sets the document's Y scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollY { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollY As Double

Property Value

A double value specifying the Y scroll position.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.TargetView Property

RenderOptions.TargetView Property
[image]

Gets or sets the object that currently displays the Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object TargetView { get; set; }

Visual Basic [image] Copy Code

Public Property TargetView As Object

Property Value

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderOptions.VisibleRect Property

RenderOptions.VisibleRect Property
[image]

Specifies which part of the diagram is currently visible.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect VisibleRect { get; set; }

Visual Basic [image] Copy Code

Public Property VisibleRect As Rect

Property Value

A Rectangle object.

See Also

RenderOptions Members
RenderOptions Class


MindFusion.Diagramming.RenderTarget Enumeration

RenderTarget Enumeration
[image]

Specifies where the diagram is being rendered.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RenderTarget

Visual Basic [image] Copy Code

Public Enum RenderTarget

Members

Member name | Description
Display | The disgram is rendered on the screen.
Printer | The disgram is rendered on a printer.

See Also


MindFusion.Diagramming.RepaintEventArgs Class

RepaintEventArgs Class
[image]

Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RepaintEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class RepaintEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.RepaintEventArgs

See Also

RepaintEventArgs Members


MindFusion.Diagramming.RepaintEventArgs Members

RepaintEventArgs Members
Constructors Properties
[image]

Specifies the coordinates of the area that should be repainted by views when the Repaint event is raised.

The following tables list the members exposed by the RepaintEventArgs type.

Public Constructors

Name | Description
RepaintEventArgs | Overloaded. Initializes a new instance of the RepaintEventArgs class.

Public Properties

Name | Description
InvalidRect | Gets the rectangular area in the diagram document that should be repainted.
RedrawCacheImage | Gets a value indicating whether the back-buffer cache image should be repainted as well.
SourceView | Gets the view object that raised the event.

See Also

RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs Constructor

RepaintEventArgs Constructor
[image]

Initializes a new instance of the RepaintEventArgs class.

Overload List

Name | Description
RepaintEventArgs (Rect) | Initializes a new instance of the RepaintEventArgs class.
RepaintEventArgs (Rect, Boolean) | Initializes a new instance of the RepaintEventArgs class.
RepaintEventArgs (Rect, Object) | Initializes a new instance of the RepaintEventArgs class.

See Also

RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs Constructor (Rect)

RepaintEventArgs Constructor (Rect)
See Also
[image]

Initializes a new instance of the RepaintEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RepaintEventArgs (
Rect invalidRect
)

Visual Basic [image] Copy Code

Public New ( _
invalidRect As Rect _
)

Parameters

invalidRect

A Rectangle object representing the rectangle that should be repainted.

See Also

RepaintEventArgs Constructor Overload List
RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs Constructor (Rect, Boolean)

RepaintEventArgs Constructor (Rect, Boolean)
See Also
[image]

Initializes a new instance of the RepaintEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RepaintEventArgs (
Rect invalidRect,
bool redrawCacheImage
)

Visual Basic [image] Copy Code

Public New ( _
invalidRect As Rect, _
redrawCacheImage As Boolean _
)

Parameters

invalidRect

A Rectangle object representing the rectangle that should be repainted.

redrawCacheImage

A boolean value specifying whether the diagram cache image used during modification should be re-created.

See Also

RepaintEventArgs Constructor Overload List
RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs Constructor (Rect, Object)

RepaintEventArgs Constructor (Rect, Object)
See Also
[image]

Initializes a new instance of the RepaintEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RepaintEventArgs (
Rect invalidRect,
Object sourceView
)

Visual Basic [image] Copy Code

Public New ( _
invalidRect As Rect, _
sourceView As Object _
)

Parameters

invalidRect

A Rectangle object representing the rectangle that should be repainted.

sourceView

The view object that raised the event.

See Also

RepaintEventArgs Constructor Overload List
RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs Properties

RepaintEventArgs Properties
[image]

Public Properties

Name | Description
InvalidRect | Gets the rectangular area in the diagram document that should be repainted.
RedrawCacheImage | Gets a value indicating whether the back-buffer cache image should be repainted as well.
SourceView | Gets the view object that raised the event.

See Also

RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs.InvalidRect Property

RepaintEventArgs.InvalidRect Property
[image]

Gets the rectangular area in the diagram document that should be repainted.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect InvalidRect { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property InvalidRect As Rect

Property Value

A Rectangle instance specifying the invalid rectangle. The value of Empty indicates that the whole view should be repainted.

See Also

RepaintEventArgs Members
RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs.RedrawCacheImage Property

RepaintEventArgs.RedrawCacheImage Property
[image]

Gets a value indicating whether the back-buffer cache image should be repainted as well.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RedrawCacheImage { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RedrawCacheImage As Boolean

Property Value

true to redraw the back-buffer image; otherwise, false.

See Also

RepaintEventArgs Members
RepaintEventArgs Class


MindFusion.Diagramming.RepaintEventArgs.SourceView Property

RepaintEventArgs.SourceView Property
[image]

Gets the view object that raised the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object SourceView { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SourceView As Object

Property Value

An object identifying the view that raised the event.

See Also

RepaintEventArgs Members
RepaintEventArgs Class


MindFusion.Diagramming.RerouteLinks Enumeration

RerouteLinks Enumeration
[image]

Provides values indicating in what circumstances links must be rerouted automatically.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RerouteLinks

Visual Basic [image] Copy Code

Public Enum RerouteLinks

Members

Member name | Description
Never | Do not reroute links automatically.
WhenIntersectNode | Reroute a link if it intersects a node.
WhenModified | Reroute a link if its end points are moved around.
WhileCreating | Route new links while the user draw them.
WhileModifying | Route links while the user modifies them or drags their incident nodes.

Remarks

These values can be assigned to the TriggerRerouting property of RoutingOptions.

See Also


MindFusion.Diagramming.RestrictToBounds Enumeration

RestrictToBounds Enumeration
[image]

Specifies the restriction of the position of an object as to the document extents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum RestrictToBounds

Visual Basic [image] Copy Code

Public Enum RestrictToBounds

Members

Member name | Description
InsideOnly | Items must be located entirely inside the document extents.
Intersection | Items must be located at least partially inside the document extents.
NoRestriction | No restriction on the position of items.

Remarks

This enumeration specifies the possible values of the RestrictItemsToBounds property.

See Also


MindFusion.Diagramming.RoundRectangleTemplate Class

RoundRectangleTemplate Class
Remarks See Also
[image]

Represents an ElementTemplate that draws round rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RoundRectangleTemplate : ElementTemplate

Visual Basic [image] Copy Code

Public Class RoundRectangleTemplate
Inherits ElementTemplate

Remarks

This class ensures that the round corners do not change during resizing which is visually better.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ElementTemplate
MindFusion.Diagramming.RoundRectangleTemplate

See Also

RoundRectangleTemplate Members


MindFusion.Diagramming.RoundRectangleTemplate Members

RoundRectangleTemplate Members
Constructors Properties Methods
[image]

Represents an ElementTemplate that draws round rectangle.

The following tables list the members exposed by the RoundRectangleTemplate type.

Public Constructors

Name | Description
RoundRectangleTemplate | Overloaded. Initializes a new instance of the RoundRectangleTemplate class.

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Radius | Gets or sets the round radius of this element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

Public Methods

Name | Description
Clone | Creates an exact copy of this RoundRectangleTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor

RoundRectangleTemplate Constructor
[image]

Initializes a new instance of the RoundRectangleTemplate class.

Overload List

Name | Description
RoundRectangleTemplate () | Initializes a new instance of the RoundRectangleTemplate class.
RoundRectangleTemplate (Double, Double, Double, Double, Double) | Initializes a new instance of the RoundRectangleTemplate class with the specified settings.
RoundRectangleTemplate (Double, Double, Double, Double, Double, Color, DashStyle, Double) | Initializes a new instance of the RoundRectangleTemplate class with the specified settings.

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor ()

RoundRectangleTemplate Constructor ()
See Also
[image]

Initializes a new instance of the RoundRectangleTemplate class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoundRectangleTemplate ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor (Double, Double, Double, Double, Double)

RoundRectangleTemplate Constructor (Double, Double, Double, Double, Double)
See Also
[image]

Initializes a new instance of the RoundRectangleTemplate class with the specified settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoundRectangleTemplate (
double x,
double y,
double w,
double h,
double r
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
r As Double _
)

Parameters

x

The x-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

y

The y-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

w

The width of the rectangle, expressed in percents of a shape node's bounding rectangle.

h

The height of the rectangle, expressed in percents of a shape node's bounding rectangle.

r

The round radius of the rectangle.

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Constructor (Double, Double, Double, Double, Double, Color, DashStyle, Double)

RoundRectangleTemplate Constructor (Double, Double, Double, Double, Double, Color, DashStyle, Double)
See Also
[image]

Initializes a new instance of the RoundRectangleTemplate class with the specified settings.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RoundRectangleTemplate (
double x,
double y,
double w,
double h,
double r,
Color color,
DashStyle dashStyle,
double width
)

Visual Basic [image] Copy Code

Public New ( _
x As Double, _
y As Double, _
w As Double, _
h As Double, _
r As Double, _
color As Color, _
dashStyle As DashStyle, _
width As Double _
)

Parameters

x

The x-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

y

The y-coordinate of the top-left corner of the rectangle, expressed in percents of a shape node's bounding rectangle.

w

The width of the rectangle, expressed in percents of a shape node's bounding rectangle.

h

The height of the rectangle, expressed in percents of a shape node's bounding rectangle.

r

The round radius of the rectangle.

color

The color of this segment.

dashStyle

The dash style of this segment.

width

The width of this segment.

See Also

RoundRectangleTemplate Constructor Overload List
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Methods

RoundRectangleTemplate Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this RoundRectangleTemplate element.
SameAs | ElementTemplate.SameAs override.

Protected Methods

Name | Description
GetElementPen | Gets a pen used to render the element. If no pen properties are explicitly specified for this element, returns the pen passed as an argument. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.Clone Method

RoundRectangleTemplate.Clone Method
[image]

Creates an exact copy of this RoundRectangleTemplate element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override ElementTemplate Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As ElementTemplate

Return Value

An instance of the RoundRectangleTemplate class.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.SameAs Method

RoundRectangleTemplate.SameAs Method
[image]

ElementTemplate.SameAs override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool SameAs (
ElementTemplate obj
)

Visual Basic [image] Copy Code

Public Overrides Function SameAs( _
obj As ElementTemplate _
) As Boolean

Parameters

obj

The ElementTemplate to compare to this template.

Return Value

true if the specified object is a RoundRectangleTemplate closely approximating this template; otherwise, false.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate Properties

RoundRectangleTemplate Properties
[image]

Public Properties

Name | Description
Bounds | Gets the bounding rectangle of this element.
Color | Gets or sets the outline color of this element. (Inherited from ElementTemplate.)
DashStyle | Gets or sets the dash style of the outline of this element. (Inherited from ElementTemplate.)
Radius | Gets or sets the round radius of this element.
Width | Gets or sets the outline width of this element. (Inherited from ElementTemplate.)

See Also

RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.Bounds Property

RoundRectangleTemplate.Bounds Property
[image]

Gets the bounding rectangle of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

A Rectangle object that represents the bounding rectangle of this element.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoundRectangleTemplate.Radius Property

RoundRectangleTemplate.Radius Property
[image]

Gets or sets the round radius of this element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Double

Property Value

A float value specifying the round radius of this element.

See Also

RoundRectangleTemplate Members
RoundRectangleTemplate Class


MindFusion.Diagramming.RoutingOptions Class

RoutingOptions Class
Remarks See Also
[image]

Allows customization of various aspects of the link routing algorithm.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RoutingOptions : RoutingOptions

Visual Basic [image] Copy Code

Public Class RoutingOptions
Implements RoutingOptions

Remarks

Use the RoutingOptions member of the Diagram class to access the sole instance of this class.

MindFusion.Diagramming for .NET MAUI uses a cost minimization algorithm to route links between nodes. For each link, there is a routing grid built for the area that encloses the link and its origin and destination nodes. The size of the grid pieces is set via GridSize. Each piece of the grid is marked as an obstacle if it intersects an Obstacle node. Some cost values are assigned to the remaining pieces, depending on how distant they are from nodes and other links.

That algorithm evaluates possible paths across the routing grid aiming to find one that has a minimal cost. The values of LengthCost, TurnCost, CrossingCost and NodeVicinityCost are added to the total cost of a route and have a great influence over the shape of the chosen path.

The StartOrientation and EndOrientation properties specify the orientation of the first and last segments of routed links, and Anchoring specifies whether link ends should be aligned to the anchor points defined for nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.RoutingOptions

See Also

RoutingOptions Members


MindFusion.Diagramming.RoutingOptions Members

RoutingOptions Members
Properties Methods
[image]

Allows customization of various aspects of the link routing algorithm.

The following tables list the members exposed by the RoutingOptions type.

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating whether to align link ends to the anchor points of nodes.
CrossingCost | Gets or sets a value added to the total cost of a route if it causes a link to cross another link.
Distance | Gets a heuristic delegate function that returns the double distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.
DistSquare | Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.
DontOptimizeLongRoutes | Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
EndPointsOffset | Gets or sets the minimum number of routing grid cells the end segments of links should occupy before they are allowed to bend.
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
MaxAbs | Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
NodeVicinitySize | Gets or sets the size of a buffer zone around a node in which routes get a penalty cost if they pass through it.
RouteHeuristics | Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.
SmartPolylineEnds | Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.
TriggerRerouting | Gets or sets a value indicating under what circumstances links are rerouted automatically.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

Public Methods

Name | Description
SetDefaultMode | Resets all routing properties to their default values.
SetMinSegmentsMode | Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.
SetQuickMode | Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

See Also

RoutingOptions Class


MindFusion.Diagramming.RoutingOptions Methods

RoutingOptions Methods
[image]

Public Methods

Name | Description
SetDefaultMode | Resets all routing properties to their default values.
SetMinSegmentsMode | Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.
SetQuickMode | Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

See Also

RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.SetDefaultMode Method

RoutingOptions.SetDefaultMode Method
[image]

Resets all routing properties to their default values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetDefaultMode ()

Visual Basic [image] Copy Code

Public Sub SetDefaultMode ()

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.SetMinSegmentsMode Method

RoutingOptions.SetMinSegmentsMode Method
[image]

Assigns to the routing properties a predefined set of values which allow finding paths that have a small number of segments.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetMinSegmentsMode ()

Visual Basic [image] Copy Code

Public Sub SetMinSegmentsMode ()

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.SetQuickMode Method

RoutingOptions.SetQuickMode Method
[image]

Assigns to the routing properties a predefined set of values which allow finding paths quickly but the found paths are of low quality.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetQuickMode ()

Visual Basic [image] Copy Code

Public Sub SetQuickMode ()

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions Properties

RoutingOptions Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets a value indicating whether to align link ends to the anchor points of nodes.
CrossingCost | Gets or sets a value added to the total cost of a route if it causes a link to cross another link.
Distance | Gets a heuristic delegate function that returns the double distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.
DistSquare | Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.
DontOptimizeLongRoutes | Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
EndPointsOffset | Gets or sets the minimum number of routing grid cells the end segments of links should occupy before they are allowed to bend.
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
MaxAbs | Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
NodeVicinitySize | Gets or sets the size of a buffer zone around a node in which routes get a penalty cost if they pass through it.
RouteHeuristics | Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.
SmartPolylineEnds | Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.
TriggerRerouting | Gets or sets a value indicating under what circumstances links are rerouted automatically.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.Anchoring Property

RoutingOptions.Anchoring Property
[image]

Gets or sets a value indicating whether to align link ends to the anchor points of nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Anchoring Anchoring { get; set; }

Visual Basic [image] Copy Code

Public Property Anchoring As Anchoring

Property Value

A member of the Anchoring enumeration. The default is Ignore.

Remarks

By default, the routing algorithm ignores anchor points. To make it align link ends to the points specified in the AnchorPattern property of nodes, set Anchoring to Keep or Reassign. Keep specifies that the routing algorithm does not change the positions of link end points. Reassign lets the routing algorithm choose new end points for a link from the ones specified in the AnchorPattern of its origin and destination nodes.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.CrossingCost Property

RoutingOptions.CrossingCost Property
[image]

Gets or sets a value added to the total cost of a route if it causes a link to cross another link.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte CrossingCost { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingCost As Byte

Property Value

A byte value specifying the crossing cost. The default is 4.

Remarks

This is a penalty value added to the total cost of an evaluated link route if it crosses another link. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to CrossingCost leads to fewer link intersections. At this time CrossingCost processing is implemented only for links with Shape set to Cascading.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.Distance Property

RoutingOptions.Distance Property
[image]

Gets a heuristic delegate function that returns the double distance sqrt(dx^2 + dy^2) between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RouteHeuristics Distance { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Distance As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

Distance is a predefined delegate that assigns to pieces a heuristic value equaling the piece distance to the target. Thus of the four pieces adjacent to the current one, the piece closest to the target has the smallest value and the route generation continues through it. Distance is the default value of the RouteHeuristics property.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.DistSquare Property

RoutingOptions.DistSquare Property
[image]

Gets a heuristic delegate function that returns the square distance dx^2 + dy^2 as a cost evaluation of the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RouteHeuristics DistSquare { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DistSquare As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

DistSquare is a predefined delegate that assigns to pieces a heuristic value equaling the piece distance to the target raised to the second power. DistSquare can be assigned to the RouteHeuristics property. By returning larger values than the default heuristic function Distance, it makes the prediction part of the routing algorithm have greater impact on the evaluated routes.That would lead to faster path-finding, but the real cost functions might have less impact and thus the quality of the found routes could be low.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.DontOptimizeLongRoutes Property

RoutingOptions.DontOptimizeLongRoutes Property
[image]

Gets or sets a value indicating whether long routes don't have their number of segments minimized in order to save up processing time.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DontOptimizeLongRoutes { get; set; }

Visual Basic [image] Copy Code

Public Property DontOptimizeLongRoutes As Boolean

Property Value

true to disable route optimization for long links; otherwise, false. The default is false.

Remarks

Segment optimization done on routed links might need much processing time. The control allows disabling that optimization for long links. That would make the found routes have a "staircase" pattern when they run diagonally.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.EndOrientation Property

RoutingOptions.EndOrientation Property
[image]

Gets or sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation EndOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property EndOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. EndOrientation specifies what orientation of links' last segments to be applied by the routing algorithm.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.EndPointsOffset Property

RoutingOptions.EndPointsOffset Property
[image]

Gets or sets the minimum number of routing grid cells the end segments of links should occupy before they are allowed to bend.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int EndPointsOffset { get; set; }

Visual Basic [image] Copy Code

Public Property EndPointsOffset As Integer

Property Value

Number of routing grid cells the end segments of links should occupy before a bend is allowed. The default value is 0.

Remarks

Set this property to a value greater than 0 to ensure the first bend the link makes is not too close to the node boundaries.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.GridSize Property

RoutingOptions.GridSize Property
[image]

Gets or sets the size of the pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

A double value specifying the size of the pieces of the routing grid. The default is 4.

Remarks

A smaller size of routing grid pieces helps finding more precise paths, however since the number of pieces increases, there would be more time needed to find a path.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.IgnoreAnchoring Property

RoutingOptions.IgnoreAnchoring Property
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreAnchoring { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IgnoreAnchoring As Boolean

Property Value

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.LengthCost Property

RoutingOptions.LengthCost Property
[image]

Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte LengthCost { get; set; }

Visual Basic [image] Copy Code

Public Property LengthCost As Byte

Property Value

A byte value specifying the length cost. The default is 2.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each piece of the routing grid it occupies. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to LengthCost leads to generating shorter paths.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.MaxAbs Property

RoutingOptions.MaxAbs Property
[image]

Gets a heuristic delegate function that returns max(dx, dy) as a cost evaluation of the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static RouteHeuristics MaxAbs { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MaxAbs As RouteHeuristics

Property Value

A predefined RouteHeuristics delegate instance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by a RouteHeuristics delegate function. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

MaxAbs is a predefined delegate that assigns to pieces the higher value from the horizontal or vertical -only distances between a piece and the target. MaxAbs can be assigned to the RouteHeuristics property. By returning smaller values than the default heuristic function Distance, it makes the prediction part of the routing algorithm have less impact on the evaluated routes. That might lead to slower path-finding, but the real cost functions would have greater impact and thus the quality of the found routes could be higher.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.NodeVicinityCost Property

RoutingOptions.NodeVicinityCost Property
[image]

Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte NodeVicinityCost { get; set; }

Visual Basic [image] Copy Code

Public Property NodeVicinityCost As Byte

Property Value

A byte value specifying the node vicinity cost. The default is 2.

Remarks

This is a penalty value added to the total cost of an evaluated link route if it passes too close to a node. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to NodeVicinityCost makes links avoid passing close to nodes. The size of the buffer area around nodes in which passing links get a penalty cost is set via NodeVicinitySize.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.NodeVicinitySize Property

RoutingOptions.NodeVicinitySize Property
[image]

Gets or sets the size of a buffer zone around a node in which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeVicinitySize { get; set; }

Visual Basic [image] Copy Code

Public Property NodeVicinitySize As Double

Property Value

A double value specifying the size of the buffer area in which passing routes receive a penalty cost. The default is 12.

Remarks

The pieces of the routing grid that are closest to a node have the value of NodeVicinityCost assigned as their cost. The outer pieces of the buffer zone are assigned a portion of NodeVicinityCost proportional to their distance to the node.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.RouteHeuristics Property

RoutingOptions.RouteHeuristics Property
[image]

Gets or sets a heuristic function used to evaluate the distance between two pieces of the routing grid.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RouteHeuristics RouteHeuristics { get; set; }

Visual Basic [image] Copy Code

Public Property RouteHeuristics As RouteHeuristics

Property Value

A RouteHeuristics delegate used to evaluate the distance from a current routing grid piece to the target one. The default is Distance.

Remarks

While generating a path, the routing algorithm evaluates pieces of the routing grid adjacent to the current one. It takes into account the cost for passing trough a piece and adds to that cost a heuristic value calculated by RouteHeuristics. So the smaller heuristic value a piece has, the greater the chance the found route to go through that piece.

There are three predefined heuristic functions that can be assigned to RouteHeuristics: Distance, DistSquare and MaxAbs. All of them assign to pieces heuristic values that are larger for larger distances to the target. Thus of the four pieces adjacent to the current one, the piece closest to the target has the smallest value and the route generation continues through it.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.SmartPolylineEnds Property

RoutingOptions.SmartPolylineEnds Property
[image]

Gets or sets a value indicating whether the end segments of polyline links should be oriented orthogonally to the node bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SmartPolylineEnds { get; set; }

Visual Basic [image] Copy Code

Public Property SmartPolylineEnds As Boolean

Property Value

true to orient the end segments orthogonally to the node bounds; otherwise, false.

Remarks

This property is valid only for links of style Polyline.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.StartOrientation Property

RoutingOptions.StartOrientation Property
[image]

Gets or sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation StartOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property StartOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Auto.

Remarks

For some diagrams it might be desirable that first and last segments of links always have a specific direction. For example, in database ER diagrams links usually connect to table rows on the left- or right-hand sides of tables; in that case their end segments must be horizontal. StartOrientation specifies what orientation of links' first segments to be applied by the routing algorithm.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.TriggerRerouting Property

RoutingOptions.TriggerRerouting Property
[image]

Gets or sets a value indicating under what circumstances links are rerouted automatically.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RerouteLinks TriggerRerouting { get; set; }

Visual Basic [image] Copy Code

Public Property TriggerRerouting As RerouteLinks

Property Value

A member of the RerouteLinks enumeration. The default is WhenModified.

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RoutingOptions.TurnCost Property

RoutingOptions.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte TurnCost { get; set; }

Visual Basic [image] Copy Code

Public Property TurnCost As Byte

Property Value

A byte value specifying the turn cost. The default is 4.

Remarks

This is a penalty value added to the total cost of an evaluated link route for each turn it makes. The routing algorithm aims to find paths that have a minimal cost, so assigning a greater value to TurnCost leads paths that make less turns (hence they have less segments).

See Also

RoutingOptions Members
RoutingOptions Class


MindFusion.Diagramming.RowEventArgs Class

RowEventArgs Class
[image]

Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RowEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class RowEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.RowEventArgs

See Also

RowEventArgs Members


MindFusion.Diagramming.RowEventArgs Members

RowEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of table row-related events, such as TableSectionCollapsed and TableSectionExpanded.

The following tables list the members exposed by the RowEventArgs type.

Public Constructors

Name | Description
RowEventArgs | Initializes a new instance of the RowEventArgs class.

Public Properties

Name | Description
RowIndex | Gets the index of the table row for which the event has been raised.
Table | Get the table for which the event has been raised.

See Also

RowEventArgs Class


MindFusion.Diagramming.RowEventArgs Constructor

RowEventArgs Constructor
[image]

Initializes a new instance of the RowEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RowEventArgs (
TableNode table,
int rowIndex
)

Visual Basic [image] Copy Code

Public New ( _
table As TableNode, _
rowIndex As Integer _
)

Parameters

table

The TableNode related to the event.

rowIndex

The zero-based index of the table row related to the event.

See Also

RowEventArgs Class


MindFusion.Diagramming.RowEventArgs Properties

RowEventArgs Properties
[image]

Public Properties

Name | Description
RowIndex | Gets the index of the table row for which the event has been raised.
Table | Get the table for which the event has been raised.

See Also

RowEventArgs Class


MindFusion.Diagramming.RowEventArgs.RowIndex Property

RowEventArgs.RowIndex Property
[image]

Gets the index of the table row for which the event has been raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RowIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowIndex As Integer

Property Value

An integer value specifying the row's index.

See Also

RowEventArgs Members
RowEventArgs Class


MindFusion.Diagramming.RowEventArgs.Table Property

RowEventArgs.Table Property
[image]

Get the table for which the event has been raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class.

See Also

RowEventArgs Members
RowEventArgs Class


MindFusion.Diagramming.SaveToStringFormat Enumeration

SaveToStringFormat Enumeration
[image]

Specifies in what format to save the diagram when generating a string using the SaveToString method.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SaveToStringFormat

Visual Basic [image] Copy Code

Public Enum SaveToStringFormat

Members

Member name | Description
Xml | Indicates a non-compressed XML output.

See Also


MindFusion.Diagramming.ScrollBarView Class

ScrollBarView Class
[image]

Represents a scrollbar in a DiagramView.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ScrollBarView : View

Visual Basic [image] Copy Code

Public Class ScrollBarView
Inherits View

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
MindFusion.Diagramming.ScrollBarView

See Also

ScrollBarView Members


MindFusion.Diagramming.ScrollBarView Members

ScrollBarView Members
Constructors Fields Properties Methods Events
[image]

Represents a scrollbar in a DiagramView.

The following tables list the members exposed by the ScrollBarView type.

Public Constructors

Name | Description
ScrollBarView | Initializes a new instance of the ScrollBarView class.

Public Fields

Name | Description
ColorProperty | Identifies the Color property.
IsHorizontalProperty | Identifies the IsHorizontal property.
LargeStepProperty | Identifies the LargeStep property.
MaximumProperty | Identifies the Maximum property.
MinimumProperty | Identifies the Minimum property.
PaddingProperty | Identifies the Padding property.
ValueProperty | Identifies the Value property.

Public Properties

Name | Description
Color | Gets or sets the color of the scrollbar.
IsHorizontal | Gets or sets a value indicating whether the scrollbar is horizontal (true) or vertical (false).
LargeStep | Gets or sets the large step of the scrollbar.
Maximum | Gets or sets the maximum value of the scrollbar.
Minimum | Gets or sets the minimum value of the scrollbar.
Padding | Gets or sets the padding of the scrollbar.
Value | Gets or sets the value of the scrollbar.

Public Methods

Name | Description
Draw | Draws the view in the specified IGraphics.
GetThumbRect |
ScrollThumb |
ThumbContainsPoint |
UpdateScroll |

Public Events

Name | Description
Scroll |

See Also

ScrollBarView Class


MindFusion.Diagramming.ScrollBarView Fields

ScrollBarView Fields
[image]

Public Fields

Name | Description
ColorProperty | Identifies the Color property.
IsHorizontalProperty | Identifies the IsHorizontal property.
LargeStepProperty | Identifies the LargeStep property.
MaximumProperty | Identifies the Maximum property.
MinimumProperty | Identifies the Minimum property.
PaddingProperty | Identifies the Padding property.
ValueProperty | Identifies the Value property.

See Also

ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.ColorProperty Field

ScrollBarView.ColorProperty Field
[image]

Identifies the Color property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty ColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ColorProperty As BindableProperty

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.IsHorizontalProperty Field

ScrollBarView.IsHorizontalProperty Field
[image]

Identifies the IsHorizontal property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty IsHorizontalProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsHorizontalProperty As BindableProperty

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.LargeStepProperty Field

ScrollBarView.LargeStepProperty Field
[image]

Identifies the LargeStep property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty LargeStepProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly LargeStepProperty As BindableProperty

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.MaximumProperty Field

ScrollBarView.MaximumProperty Field
[image]

Identifies the Maximum property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty MaximumProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MaximumProperty As BindableProperty

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.MinimumProperty Field

ScrollBarView.MinimumProperty Field
[image]

Identifies the Minimum property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty MinimumProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly MinimumProperty As BindableProperty

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.PaddingProperty Field

ScrollBarView.PaddingProperty Field
[image]

Identifies the Padding property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty PaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingProperty As BindableProperty

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.ValueProperty Field

ScrollBarView.ValueProperty Field
[image]

Identifies the Value property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty ValueProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ValueProperty As BindableProperty

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView Constructor

ScrollBarView Constructor
[image]

Initializes a new instance of the ScrollBarView class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScrollBarView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ScrollBarView Class


MindFusion.Diagramming.ScrollBarView Methods

ScrollBarView Methods
[image]

Public Methods

Name | Description
Draw | Draws the view in the specified IGraphics.
GetThumbRect |
ScrollThumb |
ThumbContainsPoint |
UpdateScroll |

See Also

ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.Draw Method

ScrollBarView.Draw Method
[image]

Draws the view in the specified IGraphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Draw (
IGraphics graphics,
Rect rectangle
)

Visual Basic [image] Copy Code

Public Sub Draw( _
graphics As IGraphics, _
rectangle As Rect _
)

Parameters

graphics

rectangle

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.GetThumbRect Method

ScrollBarView.GetThumbRect Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetThumbRect ()

Visual Basic [image] Copy Code

Public Function GetThumbRect () As Rect

Return Value

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.ScrollThumb Method

ScrollBarView.ScrollThumb Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ScrollThumb (
Point pointer,
Point pointerRelative
)

Visual Basic [image] Copy Code

Public Sub ScrollThumb( _
pointer As Point, _
pointerRelative As Point _
)

Parameters

pointer

pointerRelative

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.ThumbContainsPoint Method

ScrollBarView.ThumbContainsPoint Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ThumbContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Function ThumbContainsPoint( _
point As Point _
) As Boolean

Parameters

point

Return Value

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.UpdateScroll Method

ScrollBarView.UpdateScroll Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateScroll (
double newValue
)

Visual Basic [image] Copy Code

Public Sub UpdateScroll( _
newValue As Double _
)

Parameters

newValue

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView Properties

ScrollBarView Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the color of the scrollbar.
IsHorizontal | Gets or sets a value indicating whether the scrollbar is horizontal (true) or vertical (false).
LargeStep | Gets or sets the large step of the scrollbar.
Maximum | Gets or sets the maximum value of the scrollbar.
Minimum | Gets or sets the minimum value of the scrollbar.
Padding | Gets or sets the padding of the scrollbar.
Value | Gets or sets the value of the scrollbar.

See Also

ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.Color Property

ScrollBarView.Color Property
[image]

Gets or sets the color of the scrollbar.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A Color object.

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.IsHorizontal Property

ScrollBarView.IsHorizontal Property
[image]

Gets or sets a value indicating whether the scrollbar is horizontal (true) or vertical (false).

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsHorizontal { get; set; }

Visual Basic [image] Copy Code

Public Property IsHorizontal As Boolean

Property Value

A boolean value.

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.LargeStep Property

ScrollBarView.LargeStep Property
[image]

Gets or sets the large step of the scrollbar.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LargeStep { get; set; }

Visual Basic [image] Copy Code

Public Property LargeStep As Double

Property Value

A double value.

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.Maximum Property

ScrollBarView.Maximum Property
[image]

Gets or sets the maximum value of the scrollbar.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Maximum { get; set; }

Visual Basic [image] Copy Code

Public Property Maximum As Double

Property Value

A double value.

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.Minimum Property

ScrollBarView.Minimum Property
[image]

Gets or sets the minimum value of the scrollbar.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Minimum { get; set; }

Visual Basic [image] Copy Code

Public Property Minimum As Double

Property Value

A double value.

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.Padding Property

ScrollBarView.Padding Property
[image]

Gets or sets the padding of the scrollbar.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

A double value.

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.Value Property

ScrollBarView.Value Property
[image]

Gets or sets the value of the scrollbar.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Value { get; set; }

Visual Basic [image] Copy Code

Public Property Value As Double

Property Value

A double value.

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollBarView Events

ScrollBarView Events
[image]

Public Events

Name | Description
Scroll |

See Also

ScrollBarView Class


MindFusion.Diagramming.ScrollBarView.Scroll Event

ScrollBarView.Scroll Event
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler Scroll

Visual Basic [image] Copy Code

Public Event Scroll As EventHandler

See Also

ScrollBarView Members
ScrollBarView Class


MindFusion.Diagramming.ScrollTarget Interface

ScrollTarget Interface
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ScrollTarget

Visual Basic [image] Copy Code

Public Interface ScrollTarget

See Also

ScrollTarget Members


MindFusion.Diagramming.ScrollTarget Members

ScrollTarget Members
Properties
[image]

The following tables list the members exposed by the ScrollTarget type.

Public Properties

Name | Description
MaxScrollX |
MaxScrollY |
MinScrollX |
MinScrollY |
ScrollX |
ScrollY |

See Also

ScrollTarget Interface


MindFusion.Diagramming.ScrollTarget Properties

ScrollTarget Properties
[image]

Public Properties

Name | Description
MaxScrollX |
MaxScrollY |
MinScrollX |
MinScrollY |
ScrollX |
ScrollY |

See Also

ScrollTarget Interface


MindFusion.Diagramming.ScrollTarget.MaxScrollX Property

ScrollTarget.MaxScrollX Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double MaxScrollX { get; }

Visual Basic [image] Copy Code

ReadOnly Property MaxScrollX As Double

Property Value

See Also

ScrollTarget Members
ScrollTarget Interface


MindFusion.Diagramming.ScrollTarget.MaxScrollY Property

ScrollTarget.MaxScrollY Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double MaxScrollY { get; }

Visual Basic [image] Copy Code

ReadOnly Property MaxScrollY As Double

Property Value

See Also

ScrollTarget Members
ScrollTarget Interface


MindFusion.Diagramming.ScrollTarget.MinScrollX Property

ScrollTarget.MinScrollX Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double MinScrollX { get; }

Visual Basic [image] Copy Code

ReadOnly Property MinScrollX As Double

Property Value

See Also

ScrollTarget Members
ScrollTarget Interface


MindFusion.Diagramming.ScrollTarget.MinScrollY Property

ScrollTarget.MinScrollY Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double MinScrollY { get; }

Visual Basic [image] Copy Code

ReadOnly Property MinScrollY As Double

Property Value

See Also

ScrollTarget Members
ScrollTarget Interface


MindFusion.Diagramming.ScrollTarget.ScrollX Property

ScrollTarget.ScrollX Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double ScrollX { get; set; }

Visual Basic [image] Copy Code

Property ScrollX As Double

Property Value

See Also

ScrollTarget Members
ScrollTarget Interface


MindFusion.Diagramming.ScrollTarget.ScrollY Property

ScrollTarget.ScrollY Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double ScrollY { get; set; }

Visual Basic [image] Copy Code

Property ScrollY As Double

Property Value

See Also

ScrollTarget Members
ScrollTarget Interface


MindFusion.Diagramming.ScrollToggleView Class

ScrollToggleView Class
[image]

Represents a small toggle control that can be used to turn pan mode on and off in a diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ScrollToggleView : View

Visual Basic [image] Copy Code

Public Class ScrollToggleView
Inherits View

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
MindFusion.Diagramming.ScrollToggleView

See Also

ScrollToggleView Members


MindFusion.Diagramming.ScrollToggleView Members

ScrollToggleView Members
Constructors Fields Properties Methods
[image]

Represents a small toggle control that can be used to turn pan mode on and off in a diagram.

The following tables list the members exposed by the ScrollToggleView type.

Public Constructors

Name | Description
ScrollToggleView | Initializes a new instance of the ScrollToggleView class.

Public Fields

Name | Description
ActiveColorProperty | Identifies the ActiveColor property.
ColorProperty | Identifies the Color property.
IsActiveProperty | Identifies the IsActive property.
PaddingProperty | Identifies the Padding property.

Public Properties

Name | Description
ActiveColor | Gets or sets the foreground color of the toggle when it is active.
Color | Gets or sets the foreground color of the toggle.
IsActive | Gets or sets a value indicating whether the toggle is active.
Padding | Gets or sets the padding of the toggle.

Public Methods

Name | Description
Draw | Draws the view in the specified IGraphics.

See Also

ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView Fields

ScrollToggleView Fields
[image]

Public Fields

Name | Description
ActiveColorProperty | Identifies the ActiveColor property.
ColorProperty | Identifies the Color property.
IsActiveProperty | Identifies the IsActive property.
PaddingProperty | Identifies the Padding property.

See Also

ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView.ActiveColorProperty Field

ScrollToggleView.ActiveColorProperty Field
[image]

Identifies the ActiveColor property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty ActiveColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ActiveColorProperty As BindableProperty

See Also

ScrollToggleView Members
ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView.ColorProperty Field

ScrollToggleView.ColorProperty Field
[image]

Identifies the Color property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty ColorProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly ColorProperty As BindableProperty

See Also

ScrollToggleView Members
ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView.IsActiveProperty Field

ScrollToggleView.IsActiveProperty Field
[image]

Identifies the IsActive property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty IsActiveProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly IsActiveProperty As BindableProperty

See Also

ScrollToggleView Members
ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView.PaddingProperty Field

ScrollToggleView.PaddingProperty Field
[image]

Identifies the Padding property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static readonly BindableProperty PaddingProperty

Visual Basic [image] Copy Code

Public Shared ReadOnly PaddingProperty As BindableProperty

See Also

ScrollToggleView Members
ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView Constructor

ScrollToggleView Constructor
[image]

Initializes a new instance of the ScrollToggleView class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScrollToggleView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView Methods

ScrollToggleView Methods
[image]

Public Methods

Name | Description
Draw | Draws the view in the specified IGraphics.

See Also

ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView.Draw Method

ScrollToggleView.Draw Method
[image]

Draws the view in the specified IGraphics.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Draw (
IGraphics graphics,
Rect rectangle
)

Visual Basic [image] Copy Code

Public Sub Draw( _
graphics As IGraphics, _
rectangle As Rect _
)

Parameters

graphics

rectangle

See Also

ScrollToggleView Members
ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView Properties

ScrollToggleView Properties
[image]

Public Properties

Name | Description
ActiveColor | Gets or sets the foreground color of the toggle when it is active.
Color | Gets or sets the foreground color of the toggle.
IsActive | Gets or sets a value indicating whether the toggle is active.
Padding | Gets or sets the padding of the toggle.

See Also

ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView.ActiveColor Property

ScrollToggleView.ActiveColor Property
[image]

Gets or sets the foreground color of the toggle when it is active.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ActiveColor { get; set; }

Visual Basic [image] Copy Code

Public Property ActiveColor As Color

Property Value

A Color object.

See Also

ScrollToggleView Members
ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView.Color Property

ScrollToggleView.Color Property
[image]

Gets or sets the foreground color of the toggle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A Color object.

See Also

ScrollToggleView Members
ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView.IsActive Property

ScrollToggleView.IsActive Property
[image]

Gets or sets a value indicating whether the toggle is active.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsActive { get; set; }

Visual Basic [image] Copy Code

Public Property IsActive As Boolean

Property Value

A boolean value.

See Also

ScrollToggleView Members
ScrollToggleView Class


MindFusion.Diagramming.ScrollToggleView.Padding Property

ScrollToggleView.Padding Property
[image]

Gets or sets the padding of the toggle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

A double value.

See Also

ScrollToggleView Members
ScrollToggleView Class


MindFusion.Diagramming.Selection Class

Selection Class
[image]

Represents a set of items selected in the diagram document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Selection : DiagramItem

Visual Basic [image] Copy Code

Public NotInheritable Class Selection
Inherits DiagramItem

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.Selection

See Also

Selection Members


MindFusion.Diagramming.Selection Members

Selection Members
Fields Properties Methods
[image]

Represents a set of items selected in the diagram document.

The following tables list the members exposed by the Selection type.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowMultipleSelection | Gets or sets a value indicating whether more than one items can be selected simultaneously.
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets the rectangle that bounds all selected items.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncludeItemsIfIntersect | Gets or sets a value indicating which items are selected when drawing a selection rectangle.
Items | Gets a collection of all selected items.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Links | Gets the collection of all links in the selection.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Nodes | Gets a collection of all selected nodes.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
SetsDirtyFlag | Gets or sets a value indicating whether the diagram's Dirty flag should be set when selection changes.
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets a value indicating how to display multiple selection of items.
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AddItem | Adds a new item to the current selection.
Change | Selects an item and deselects all others.
Clear | Removes all items from the selection.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override.
Draw | DiagramItem.Draw override.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | DiagramItem.DrawShadow override.
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetOutlinePoly | Gets a polygon approximating the outline of this object. (Inherited from DiagramItem.)
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
GetSize | Gets the number of selected items.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
RemoveItem | Removes an item from the selection.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
Toggle | Toggles the selection state of an item.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | DiagramItem.FreeResources override.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject. (Inherited from DiagramItem.)
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that an item has been clicked. (Inherited from DiagramItem.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | Restores the properties of this diagram item. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveProperties | Saves the properties of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveToJson | Saves the item content into a JsonObject. (Inherited from DiagramItem.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)

See Also

Selection Class


MindFusion.Diagramming.Selection Methods

Selection Methods
[image]

Public Methods

Name | Description
AddItem | Adds a new item to the current selection.
Change | Selects an item and deselects all others.
Clear | Removes all items from the selection.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override.
Draw | DiagramItem.Draw override.
DrawHandles | DiagramItem.DrawHandles override.
DrawShadow | DiagramItem.DrawShadow override.
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetOutlinePoly | Gets a polygon approximating the outline of this object. (Inherited from DiagramItem.)
GetRepaintRect | DiagramItem.GetRepaintRect override.
GetRotatedBounds | Gets the bounding rectangle of this item when it is rotated. (Inherited from DiagramItem.)
GetSize | Gets the number of selected items.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override.
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
RemoveItem | Removes an item from the selection.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
Toggle | Toggles the selection state of an item.
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | Creates an item property set corresponding to the type of this diagram item. (Inherited from DiagramItem.)
CreateState | Creates an item state corresponding to the type of this diagram item. (Inherited from DiagramItem.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | DiagramItem.FreeResources override.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject. (Inherited from DiagramItem.)
LoadFromXml | Loads the item content from an XML element. (Inherited from DiagramItem.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnRemove | Called when an item is removed from a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that an item has been clicked. (Inherited from DiagramItem.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | Restores the properties of this diagram item. (Inherited from DiagramItem.)
RestoreState | Restores the state of this diagram item. (Inherited from DiagramItem.)
SaveProperties | Saves the properties of this diagram item. (Inherited from DiagramItem.)
SaveState | Saves the state of this diagram item. (Inherited from DiagramItem.)
SaveToJson | Saves the item content into a JsonObject. (Inherited from DiagramItem.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramItem.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpanded | Sets whether the item is in expanded or collapsed state. (Inherited from DiagramItem.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)

See Also

Selection Class


MindFusion.Diagramming.Selection.AddItem Method

Selection.AddItem Method
[image]

Adds a new item to the current selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub AddItem( _
item As DiagramItem _
)

Parameters

item

The DiagramItem to be added to the selection.

Remarks

This method adds a new item to the selection. It also deactivates the ActiveItem, if any, and makes the newly added item the active one.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Change Method

Selection.Change Method
[image]

Selects an item and deselects all others.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Change (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub Change( _
item As DiagramItem _
)

Parameters

item

The DiagramItem which should be made active.

Remarks

Call this method to select an item and make it the ActiveItem. The method doesn't let you select locked items.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Clear Method

Selection.Clear Method
[image]

Removes all items from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

Remarks

Call Clear to deselect all items. The items are not deleted. The method also sets the diagram's ActiveItem to null.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.ContainsPoint Method

Selection.ContainsPoint Method
[image]

DiagramItem.ContainsPoint override.

Overload List

Name | Description
Selection.ContainsPoint (Point) | DiagramItem.ContainsPoint override.
Selection.ContainsPoint (Point, Double) | DiagramItem.ContainsPoint override.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.ContainsPoint Method (Point)

Selection.ContainsPoint Method (Point)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

The point to check.

Return Value

true it this item contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
Selection Members
Selection Class


MindFusion.Diagramming.Selection.ContainsPoint Method (Point, Double)

Selection.ContainsPoint Method (Point, Double)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

A Point value specifying the logical coordinates of a diagram point.

threshold

Specifies the size of the area around the item outlines where the point is still considered inside the item.

Return Value

true it this item contains the specified point; otherwise, false.

See Also

ContainsPoint Method Overload List
Selection Members
Selection Class


MindFusion.Diagramming.Selection.Draw Method

Selection.Draw Method
[image]

DiagramItem.Draw override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void Draw (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub Draw( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

options

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.DrawHandles Method

Selection.DrawHandles Method
[image]

DiagramItem.DrawHandles override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawHandles (
IGraphics graphics,
HandlesVisualStyle style,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawHandles( _
graphics As IGraphics, _
style As HandlesVisualStyle, _
options As RenderOptions _
)

Parameters

graphics

style

options

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.DrawShadow Method

Selection.DrawShadow Method
[image]

DiagramItem.DrawShadow override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadow (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadow( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

A RenderOptions object specifying options for the drawing operation.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.FreeResources Method

Selection.FreeResources Method
[image]

DiagramItem.FreeResources override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void FreeResources ()

Visual Basic [image] Copy Code

Protected Overrides Sub FreeResources ()

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.GetRepaintRect Method

Selection.GetRepaintRect Method
[image]

DiagramItem.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected

Return Value

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.GetSize Method

Selection.GetSize Method
[image]

Gets the number of selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetSize ()

Visual Basic [image] Copy Code

Public Function GetSize () As Integer

Return Value

An integer value indicating the size of the collection.

Remarks

Call this method to get the number of selected items, including both nodes and links.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.HitTestHandle Method

Selection.HitTestHandle Method
[image]

DiagramItem.HitTestHandle override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override AdjustmentHandle HitTestHandle (
Point point,
double radius
)

Visual Basic [image] Copy Code

Public Overrides Function HitTestHandle( _
point As Point, _
radius As Double _
) As AdjustmentHandle

Parameters

point

radius

Return Value

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.RemoveItem Method

Selection.RemoveItem Method
[image]

Removes an item from the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RemoveItem (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Function RemoveItem( _
item As DiagramItem _
) As Boolean

Parameters

item

The DiagramItem to be removed from the selection.

Return Value

true if the item has been successfully removed; otherwise, false.

Remarks

Call this method to deselect an item. Note that the item is not deleted, but just removed from the selection.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Toggle Method

Selection.Toggle Method
[image]

Toggles the selection state of an item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Toggle (
DiagramItem item
)

Visual Basic [image] Copy Code

Public Sub Toggle( _
item As DiagramItem _
)

Parameters

item

The DiagramItem whose selection state should be changed.

Remarks

Call this method to toggle an item's selection state. The method selects the diagram item passed as argument if previously it was deselected. If the item was selected, the method deselects it.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection Properties

Selection Properties
[image]

Public Properties

Name | Description
AllowMultipleSelection | Gets or sets a value indicating whether more than one items can be selected simultaneously.
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets the rectangle that bounds all selected items.
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncludeItemsIfIntersect | Gets or sets a value indicating which items are selected when drawing a selection rectangle.
Items | Gets a collection of all selected items.
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Links | Gets the collection of all links in the selection.
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Nodes | Gets a collection of all selected nodes.
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
SetsDirtyFlag | Gets or sets a value indicating whether the diagram's Dirty flag should be set when selection changes.
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets a value indicating how to display multiple selection of items.
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | True if this is a top-level item in the diagram, or false if it is inside a container. (Inherited from DiagramItem.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

Selection Class


MindFusion.Diagramming.Selection.AllowMultipleSelection Property

Selection.AllowMultipleSelection Property
[image]

Gets or sets a value indicating whether more than one items can be selected simultaneously.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowMultipleSelection { get; set; }

Visual Basic [image] Copy Code

Public Property AllowMultipleSelection As Boolean

Property Value

A boolean flag indicating whether multiple items can be selected simultaneously by the user.

Remarks

The property controls whether multiple items can be selected interactively. If it is disabled, multiple items can still be selected programmatically.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Bounds Property

Selection.Bounds Property
[image]

Gets the rectangle that bounds all selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect Bounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Bounds As Rect

Property Value

An instance of the Rectangle structure.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.IncludeItemsIfIntersect Property

Selection.IncludeItemsIfIntersect Property
[image]

Gets or sets a value indicating which items are selected when drawing a selection rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IncludeItemsIfIntersect { get; set; }

Visual Basic [image] Copy Code

Public Property IncludeItemsIfIntersect As Boolean

Property Value

true to select items that intersect the drawn selection rectangle; false to select items only if they are entirely inside the selection rectangle. The default is true.

Remarks

The value of this property is considered when users draw a selection rectangle using a pointing device. By default, all items inside the drawn rectangle and the ones that are only partially inside it are selected. Set the property to false to let users select items only when the items are entirely inside the selection rectangle.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Items Property

Selection.Items Property
[image]

Gets a collection of all selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class that represents the selected diagram items.

Remarks

You can select items programmatically by adding them to this collection.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Links Property

Selection.Links Property
[image]

Gets the collection of all links in the selection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection Links { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Links As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class that represents the selected diagram items.

Remarks

You can select links programmatically by adding them to this collection.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Nodes Property

Selection.Nodes Property
[image]

Gets a collection of all selected nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

An instance of the DiagramNodeCollection class that represents the nodes in the selection.

Remarks

You can select nodes programmatically by adding them to this collection.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.SetsDirtyFlag Property

Selection.SetsDirtyFlag Property
[image]

Gets or sets a value indicating whether the diagram's Dirty flag should be set when selection changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SetsDirtyFlag { get; set; }

Visual Basic [image] Copy Code

Public Property SetsDirtyFlag As Boolean

Property Value

true to set the flag when selection changes, otherwise false. The default value is true.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.Selection.Style Property

Selection.Style Property
[image]

Gets or sets a value indicating how to display multiple selection of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new SelectionStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property Style As SelectionStyle

Property Value

A member of the SelectionStyle enumeration. The default is SelectionHandles.

Remarks

The property specifies how multiple-selection is presented visually to users – with manipulation handles painted around each item or with a rectangle painted around all items.

See Also

Selection Members
Selection Class


MindFusion.Diagramming.SelectionCopy Class

SelectionCopy Class
Remarks See Also
[image]

Used internally in the implementation of copy/paste functions.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class SelectionCopy

Visual Basic [image] Copy Code

Public NotInheritable Class SelectionCopy

Remarks

This class supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.SelectionCopy

See Also

SelectionCopy Members


MindFusion.Diagramming.SelectionCopy Members

SelectionCopy Members
Constructors Properties
[image]

Used internally in the implementation of copy/paste functions.

The following tables list the members exposed by the SelectionCopy type.

Public Constructors

Name | Description
SelectionCopy | Initializes a new instance of the SelectionCopy class.

Public Properties

Name | Description
Items | Gets the underlying collection of items.
OriginalItems | Gets a collection of the original items.

See Also

SelectionCopy Class


MindFusion.Diagramming.SelectionCopy Constructor

SelectionCopy Constructor
[image]

Initializes a new instance of the SelectionCopy class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectionCopy (
DiagramItemCollection items,
DiagramItemCollection originalItems
)

Visual Basic [image] Copy Code

Public New ( _
items As DiagramItemCollection, _
originalItems As DiagramItemCollection _
)

Parameters

items

A collection containing the item copies.

originalItems

A collection containing the original items.

Remarks

This constructor supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Class


MindFusion.Diagramming.SelectionCopy Properties

SelectionCopy Properties
[image]

Public Properties

Name | Description
Items | Gets the underlying collection of items.
OriginalItems | Gets a collection of the original items.

See Also

SelectionCopy Class


MindFusion.Diagramming.SelectionCopy.Items Property

SelectionCopy.Items Property
[image]

Gets the underlying collection of items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection Items { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Items As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This property supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class


MindFusion.Diagramming.SelectionCopy.OriginalItems Property

SelectionCopy.OriginalItems Property
[image]

Gets a collection of the original items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItemCollection OriginalItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OriginalItems As DiagramItemCollection

Property Value

An instance of the DiagramItemCollection class.

Remarks

This property supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

SelectionCopy Members
SelectionCopy Class


MindFusion.Diagramming.SelectionEventArgs Class

SelectionEventArgs Class
[image]

Contains the arguments passed to the SelectionModified event handler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SelectionEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SelectionEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.SelectionEventArgs
MindFusion.Diagramming.SelectionValidationEventArgs

See Also

SelectionEventArgs Members


MindFusion.Diagramming.SelectionEventArgs Members

SelectionEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to the SelectionModified event handler.

The following tables list the members exposed by the SelectionEventArgs type.

Public Constructors

Name | Description
SelectionEventArgs | Initializes a new instance of the SelectionEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user.
Position | Gets the location related to the event.

See Also

SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs Constructor

SelectionEventArgs Constructor
[image]

Initializes a new instance of the SelectionEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectionEventArgs (
Point position,
AdjustmentHandle adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
position As Point, _
adjustmentHandle As AdjustmentHandle _
)

Parameters

position

adjustmentHandle

See Also

SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs Properties

SelectionEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user.
Position | Gets the location related to the event.

See Also

SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs.AdjustmentHandle Property

SelectionEventArgs.AdjustmentHandle Property
[image]

Gets the adjustment handle being moved by the user.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandle AdjustmentHandle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property AdjustmentHandle As AdjustmentHandle

Property Value

An instance of the AdjustmentHandle class.

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Diagramming.SelectionEventArgs.Position Property

SelectionEventArgs.Position Property
[image]

Gets the location related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

A Point object.

See Also

SelectionEventArgs Members
SelectionEventArgs Class


MindFusion.Diagramming.SelectionStyle Enumeration

SelectionStyle Enumeration
[image]

Defines values that specify how multiple selected items are indicated visually.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SelectionStyle

Visual Basic [image] Copy Code

Public Enum SelectionStyle

Members

Member name | Description
Frame | A dashed rectangle is drawn around selected items.
SelectionHandles | Rectangular manipulation handles are painted over selected items.

Remarks

These values affect multiple selection of items. If only a single item is selected, it is drawn with manipulation handles around it.

See Also


MindFusion.Diagramming.SelectionValidationEventArgs Class

SelectionValidationEventArgs Class
[image]

Contains the arguments passed to the SelectionModifying event handler.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SelectionValidationEventArgs : SelectionEventArgs

Visual Basic [image] Copy Code

Public Class SelectionValidationEventArgs
Inherits SelectionEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.SelectionEventArgs
MindFusion.Diagramming.SelectionValidationEventArgs

See Also

SelectionValidationEventArgs Members


MindFusion.Diagramming.SelectionValidationEventArgs Members

SelectionValidationEventArgs Members
Constructors Properties Methods
[image]

Contains the arguments passed to the SelectionModifying event handler.

The following tables list the members exposed by the SelectionValidationEventArgs type.

Public Constructors

Name | Description
SelectionValidationEventArgs | Initializes a new instance of the SelectionValidationEventArgs class.

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user. (Inherited from SelectionEventArgs.)
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Position | Gets the location related to the event. (Inherited from SelectionEventArgs.)

Public Methods

Name | Description
CancelDrag | Cancels the modification of the selected items.

See Also

SelectionValidationEventArgs Class


MindFusion.Diagramming.SelectionValidationEventArgs Constructor

SelectionValidationEventArgs Constructor
[image]

Initializes a new instance of the SelectionValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectionValidationEventArgs (
Point position,
AdjustmentHandle adjustmentHandle
)

Visual Basic [image] Copy Code

Public New ( _
position As Point, _
adjustmentHandle As AdjustmentHandle _
)

Parameters

position

adjustmentHandle

See Also

SelectionValidationEventArgs Class


MindFusion.Diagramming.SelectionValidationEventArgs Methods

SelectionValidationEventArgs Methods
[image]

Public Methods

Name | Description
CancelDrag | Cancels the modification of the selected items.

See Also

SelectionValidationEventArgs Class


MindFusion.Diagramming.SelectionValidationEventArgs.CancelDrag Method

SelectionValidationEventArgs.CancelDrag Method
[image]

Cancels the modification of the selected items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CancelDrag ()

Visual Basic [image] Copy Code

Public Sub CancelDrag ()

See Also

SelectionValidationEventArgs Members
SelectionValidationEventArgs Class


MindFusion.Diagramming.SelectionValidationEventArgs Properties

SelectionValidationEventArgs Properties
[image]

Public Properties

Name | Description
AdjustmentHandle | Gets the adjustment handle being moved by the user. (Inherited from SelectionEventArgs.)
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Position | Gets the location related to the event. (Inherited from SelectionEventArgs.)

See Also

SelectionValidationEventArgs Class


MindFusion.Diagramming.SelectionValidationEventArgs.Cancel Property

SelectionValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to prevent the user from completing the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

See Also

SelectionValidationEventArgs Members
SelectionValidationEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs Class

SerializeTagEventArgs Class
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SerializeTagEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class SerializeTagEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.SerializeTagEventArgs

See Also

SerializeTagEventArgs Members


MindFusion.Diagramming.SerializeTagEventArgs Members

SerializeTagEventArgs Members
Properties
[image]

Contains the arguments passed to the SerializeTag and DeserializeTag event handlers.

The following tables list the members exposed by the SerializeTagEventArgs type.

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the diagram element whose tag is being serialized/deserialized.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets an XElement object where the tag should be serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs Properties

SerializeTagEventArgs Properties
[image]

Public Properties

Name | Description
Context | Gets a context object that can help you write and read various values.
Handled | Gets or sets a value indicating whether the event is handled.
Object | Gets the diagram element whose tag is being serialized/deserialized.
PropertyName | Gets the name of the property being serialized.
Representation | Gets or sets an XElement object where the tag should be serialized/deserialized.
Tag | Gets or sets the tag object being serialized/deserialized.

See Also

SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Context Property

SerializeTagEventArgs.Context Property
[image]

Gets a context object that can help you write and read various values.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlPersistContext Context { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Context As XmlPersistContext

Property Value

An instance of the XmlPersistContext class.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Handled Property

SerializeTagEventArgs.Handled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Handled { get; set; }

Visual Basic [image] Copy Code

Public Property Handled As Boolean

Property Value

true if you have serialized/deserialized the tag object; otherwise, false.

Remarks

Always set this flag to true if you perform custom tag serialization.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Object Property

SerializeTagEventArgs.Object Property
[image]

Gets the diagram element whose tag is being serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Object { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Object As Object

Property Value

A diagram item, cell or anchor point.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.PropertyName Property

SerializeTagEventArgs.PropertyName Property
[image]

Gets the name of the property being serialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string PropertyName { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PropertyName As String

Property Value

Either "Id" or "Tag", indicating which property is being serialized.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Representation Property

SerializeTagEventArgs.Representation Property
[image]

Gets or sets an XElement object where the tag should be serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement Representation { get; set; }

Visual Basic [image] Copy Code

Public Property Representation As XElement

Property Value

An instance of the XElement class that represents the root of the XML branch where the tag is / should be stored.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.SerializeTagEventArgs.Tag Property

SerializeTagEventArgs.Tag Property
[image]

Gets or sets the tag object being serialized/deserialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An object containing the custom tag data.

See Also

SerializeTagEventArgs Members
SerializeTagEventArgs Class


MindFusion.Diagramming.ShadowsStyle Enumeration

ShadowsStyle Enumeration
[image]

Enumerates possible shadows-drawing styles.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ShadowsStyle

Visual Basic [image] Copy Code

Public Enum ShadowsStyle

Members

Member name | Description
None | No shadows are drawn.
OneLevel | All shadows are drawn at the lowest z-level, and appear to be on one level.
ZOrder | Every shadows is drawn just below its object, possibly covering other objects.

Remarks

This enumeration provides the possible values for the ShadowsStyle property of the Diagram class.

See Also


MindFusion.Diagramming.Shape Class

Shape Class
Remarks See Also
[image]

An instance of this class represents a shape defined through a series of arc, line and Bézier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Shape

Visual Basic [image] Copy Code

Public Class Shape

Remarks

Shape Definitions

The Shape class provides the means for defining complex node shapes. With its help you can design any shape composed of lines, arcs and Bézier-curves. A shape template should contain an outline to be used for hit testing, clipping and finding intersections with other items. If the outline is not defined, the rectangle specified by the Bounds property of nodes is used for hit-testing. Optionally, shapes can contain decoration elements and text region definitions. Decorations are visual elements that do not take part in clipping, and are used for hit-testing only if DecorationHitTesting is enabled. Text regions are the parts of shapes in which node's text is laid out and rendered.

Predefined Shapes

MindFusion.Diagramming for .NET MAUI provides a set of about 100 predefined shape templates accessible through the static Shapes collection and the FromId method of Shape. A shape template can be applied to a node by assigning it to the Shape property of shape nodes. The predefined shapes are also exposed as properties of the Shapes class.

Custom Shapes

There are several Shape constructor overrides you might choose from, depending on the complexity of the shapes you want to create. They take arrays of ElementTemplate objects as arguments, which define the outline, decorations and text region definitions. Templates are described with coordinates expressed as percents of a shape node's area. It is also possible to associate an image with a shape definition by means of the Image property and to define the area in which the image is displayed by ImageRectangle.

Link Arrowheads

A Shape instance can be assigned to the HeadShape, BaseShape or IntermediateShape properties of a DiagramLink. When used for arrowheads, position (50, 0) in the shape definition corresponds to the arrowhead's tip point. Several predefined arrowhead shapes are provided as static properties of the ArrowHeads class.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Shape

See Also

Shape Members


MindFusion.Diagramming.Shape Members

Shape Members
Constructors Properties Methods
[image]

An instance of this class represents a shape defined through a series of arc, line and Bézier segments. The segments can be a part of the shape outline, in which case they define the part of the shape is filled, used for hit-testing and for aligning links to the node edges. Segments can also be added as decoration elements, in which case they only affect the appearance of a ShapeNode.

The following tables list the members exposed by the Shape type.

Public Constructors

Name | Description
Shape | Overloaded. Initializes a new instance of the Shape class.

Public Properties

Name | Description
AnchorPattern | Gets or sets the anchor pattern to use for nodes using this shape, if their anchor pattern is set to null.
DecorationHitTesting | Gets or sets a value indicating whether decoration lines should be considered when hit-testing.
Decorations | Gets or sets a list with all decorations of this shape.
DisplayName | Gets or sets the name that should be displayed for this shape in user interface objects.
EnableOutline | Gets or sets a value indicating whether to enable the shape's outline.
FillMode | Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.
Id | Gets or sets the shape identifier.
Image | Gets or sets the image displayed in all instances of this shape.
ImageRectangle | Gets or sets the position of the images displayed in instances of this shape.
IsArrowhead | Specifies if this shape is used as arrowhead.
LinkSegmentInset | Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.
Outline | Gets or sets the outline of this shape.
ShapeDecorations | Gets or sets the ShapeDecoration objects associated with this shape.
Shapes | Gets a read-only collection of all named shapes.
TextArea | Gets or sets the outline of the text area of this shape.

Public Methods

Name | Description
Clone | Creates an exact copy of this shape.
Draw | Overloaded. Draws this shape on an IGraphics surface.
Equals | Checks whether this shape template is equivalent to the specified shape.
FromId | Returns a reference to the shape with the specified string identifier.
GetHitPath | Overloaded.
GetRenderingPath | Overloaded.
LoadFromXml | Loads the shape content from an XML element.
SaveToXml | Saves the shape content into an XML element.
ToString | Returns the identifier of this shape template.

See Also

Shape Class


MindFusion.Diagramming.Shape Constructor

Shape Constructor
[image]

Initializes a new instance of the Shape class.

Overload List

Name | Description
Shape (Byte[]) | Initializes a new instance of the Shape class with the specified outline.
Shape (Byte[], String) | Initializes a new instance of the Shape class with the specified outline and id.
Shape (CreatePathDelegate, CreatePathDelegate, String) | Initializes a new instance of the Shape class with the specified outline and decorations formulas and id.
Shape (CreatePathDelegate, String) | Initializes a new instance of the Shape class with the specified outline formula and id.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode) | Initializes a new instance of the Shape class with the specified outline, decorations and text area.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String, ShapeDecoration[]) | Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.
Shape (ElementTemplate[], FillMode) | Initializes a new instance of the Shape class with the specified outline.
Shape (ElementTemplate[], FillMode, String) | Initializes a new instance of the Shape class with the specified outline and id.

See Also

Shape Class


MindFusion.Diagramming.Shape Constructor (Byte[])

Shape Constructor (Byte[])
See Also
[image]

Initializes a new instance of the Shape class with the specified outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
byte[] outline
)

Visual Basic [image] Copy Code

Public New ( _
outline() As Byte _
)

Parameters

outline

An array containing even number of coordinate values, which define the points of the shape outline.

Remarks

The specified array should contain even number of values. Each odd value represents the x-coordinate and each even value represents the y-coordinate of the corresponding point in the shape outline.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (Byte[], String)

Shape Constructor (Byte[], String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
byte[] outline,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outline() As Byte, _
id As String _
)

Parameters

outline

An array containing even number of coordinate values, which define the points of the shape outline.

id

The string identifier of the new shape.

Remarks

The specified array should contain even number of values. Each odd value represents the x-coordinate and each even value represents the y-coordinate of the corresponding point in the shape outline.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (CreatePathDelegate, CreatePathDelegate, String)

Shape Constructor (CreatePathDelegate, CreatePathDelegate, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and decorations formulas and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
CreatePathDelegate outlineDelegate,
CreatePathDelegate decorationsDelegate,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineDelegate As CreatePathDelegate, _
decorationsDelegate As CreatePathDelegate, _
id As String _
)

Parameters

outlineDelegate

A delegate called to generate IGraphicsPath objects representing the shape outline.

decorationsDelegate

A string containing the formula that defines the shape.

id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (CreatePathDelegate, String)

Shape Constructor (CreatePathDelegate, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline formula and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
CreatePathDelegate outlineDelegate,
string id
)

Visual Basic [image] Copy Code

Public New ( _
outlineDelegate As CreatePathDelegate, _
id As String _
)

Parameters

outlineDelegate

A delegate called to generate IGraphicsPath objects representing the shape outline.

id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode)

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations and text area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillMode fillMode
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textArea() As ElementTemplate, _
fillMode As FillMode _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bezier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bezier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bezier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillMode

Specifies how areas are filled if the outline path intersects itself.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String)

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillMode fillMode,
string id
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textArea() As ElementTemplate, _
fillMode As FillMode, _
id As String _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bezier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bezier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bezier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillMode

Specifies how areas are filled if the outline path intersects itself.

id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String, ShapeDecoration[])

Shape Constructor (ElementTemplate[], ElementTemplate[], ElementTemplate[], FillMode, String, ShapeDecoration[])
See Also
[image]

Initializes a new instance of the Shape class with the specified outline, decorations, text area and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
ElementTemplate[] decorations,
ElementTemplate[] textArea,
FillMode fillMode,
string id,
ShapeDecoration[] closedDecorations
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
decorations() As ElementTemplate, _
textArea() As ElementTemplate, _
fillMode As FillMode, _
id As String, _
closedDecorations() As ShapeDecoration _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bezier curves.

decorations

An array of shape template elements that define shape decorations. Can contain lines, arcs and Bezier curves. Decorations are visual elements that do not take part in hit testing and clipping.

textArea

An array of shape template elements that define the region of a node in which text is laid out and rendered. Can contain lines, arcs and Bezier curves. Latter two are approximated to polygons by the text-formatting algorithm.

fillMode

Specifies how areas are filled if the outline path intersects itself.

id

The string identifier of the new shape.

closedDecorations

An array of ShapeDecoration objects.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], FillMode)

Shape Constructor (ElementTemplate[], FillMode)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
FillMode fillMode
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
fillMode As FillMode _
)

Parameters

elements

An array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bezier curves.

fillMode

Specifies how areas are filled if the outline path intersects itself.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Constructor (ElementTemplate[], FillMode, String)

Shape Constructor (ElementTemplate[], FillMode, String)
See Also
[image]

Initializes a new instance of the Shape class with the specified outline and id.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape (
ElementTemplate[] elements,
FillMode fillMode,
string id
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
fillMode As FillMode, _
id As String _
)

Parameters

elements

Refers to an array of shape template elements that define the outline of a shape. Can contain lines, arcs and Bezier curves.

fillMode

Specifies how areas are filled if the outline path intersects itself.

id

The string identifier of the new shape.

See Also

Shape Constructor Overload List
Shape Class


MindFusion.Diagramming.Shape Methods

Shape Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this shape.
Draw | Overloaded. Draws this shape on an IGraphics surface.
Equals | Checks whether this shape template is equivalent to the specified shape.
FromId | Returns a reference to the shape with the specified string identifier.
GetHitPath | Overloaded.
GetRenderingPath | Overloaded.
LoadFromXml | Loads the shape content from an XML element.
SaveToXml | Saves the shape content into an XML element.
ToString | Returns the identifier of this shape template.

See Also

Shape Class


MindFusion.Diagramming.Shape.Clone Method

Shape.Clone Method
[image]

Creates an exact copy of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Object

Return Value

An instance of the Shape class representing the newly created clone.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Draw Method

Shape.Draw Method
[image]

Draws this shape on an IGraphics surface.

Overload List

Name | Description
Shape.Draw (IGraphics, Brush, Pen, Boolean) | Draws this shape on the specified IGraphics surface.
Shape.Draw (IGraphics, Brush, Pen, Boolean, Rect, Double) | Draws this shape on the specified IGraphics surface.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Draw Method (IGraphics, Brush, Pen, Boolean)

Shape.Draw Method (IGraphics, Brush, Pen, Boolean)
See Also
[image]

Draws this shape on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Draw (
IGraphics drawingContext,
Brush brush,
Pen pen,
bool shadow
)

Visual Basic [image] Copy Code

Public Sub Draw( _
drawingContext As IGraphics, _
brush As Brush, _
pen As Pen, _
shadow As Boolean _
)

Parameters

drawingContext

The IGraphics to draw the shape on.

brush

A Brush used to fill the shape.

pen

A Pen used to draw the shape outline.

shadow

When shadow is true the brush and pen parameters have higher priority over shape's brush and pen.

See Also

Draw Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.Draw Method (IGraphics, Brush, Pen, Boolean, Rect, Double)

Shape.Draw Method (IGraphics, Brush, Pen, Boolean, Rect, Double)
See Also
[image]

Draws this shape on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Draw (
IGraphics drawingContext,
Brush brush,
Pen pen,
bool shadow,
Rect rc,
double orientation
)

Visual Basic [image] Copy Code

Public Sub Draw( _
drawingContext As IGraphics, _
brush As Brush, _
pen As Pen, _
shadow As Boolean, _
rc As Rect, _
orientation As Double _
)

Parameters

drawingContext

The IGraphics to draw the shape on.

brush

A Brush used to fill the shape.

pen

A Pen used to draw the shape outline.

shadow

When shadow is true the brush and pen parameters have higher priority over shape's brush and pen.

rc

The bounding rectangle.

orientation

Orientation of the shape.

See Also

Draw Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.Equals Method

Shape.Equals Method
[image]

Checks whether this shape template is equivalent to the specified shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new bool Equals (
Shape shape
)

Visual Basic [image] Copy Code

Public Shadows Function Equals( _
shape As Shape _
) As Boolean

Parameters

shape

The shape to check for equality with the current shape.

Return Value

true if the current shape is equivalent to the specified shape; otherwise, false.

Remarks

Two shapes are considered equivalent if they have the same fill type, the same number and type of segments and if the points of those segments are close enough to each other.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.FromId Method

Shape.FromId Method
[image]

Returns a reference to the shape with the specified string identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape FromId (
string id
)

Visual Basic [image] Copy Code

Public Shared Function FromId( _
id As String _
) As Shape

Parameters

id

The identifier of the shape of interest.

Return Value

A reference to the Shape with the specified identifier or a null reference if there is no such shape.

Remarks

The id argument should match an identifier passed to a constructor of the existing shape templates.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetHitPath Method

Shape.GetHitPath Method
[image]

Overload List

Name | Description
Shape.GetHitPath (Rect, Double, Double) | Returns a IGraphicsPath object corresponding to the outline of the specified shape when rotated at the specified angle. This IGraphicsPath can be used for hit-testing and intersection checks.
Shape.GetHitPath (Rect, Double, Double, Boolean, Boolean) | Returns an IGraphicsPath object corresponding to the outline of the specified shape when rotated at the specified angle. This IGraphicsPath can be used for hit-testing and intersection checks.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetHitPath Method (Rect, Double, Double)

Shape.GetHitPath Method (Rect, Double, Double)
See Also
[image]

Returns a IGraphicsPath object corresponding to the outline of the specified shape when rotated at the specified angle. This IGraphicsPath can be used for hit-testing and intersection checks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphicsPath GetHitPath (
Rect nodeBounds,
double rotationAngle,
double orientation
)

Visual Basic [image] Copy Code

Public Function GetHitPath( _
nodeBounds As Rect, _
rotationAngle As Double, _
orientation As Double _
) As IGraphicsPath

Parameters

nodeBounds

The bounding rectangle of the ShapeNode.

rotationAngle

The node's rotation angle.

orientation

The shape's orientation angle.

Return Value

An IGraphicsPath representing the shape's outline.

See Also

GetHitPath Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetHitPath Method (Rect, Double, Double, Boolean, Boolean)

Shape.GetHitPath Method (Rect, Double, Double, Boolean, Boolean)
See Also
[image]

Returns an IGraphicsPath object corresponding to the outline of the specified shape when rotated at the specified angle. This IGraphicsPath can be used for hit-testing and intersection checks.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphicsPath GetHitPath (
Rect nodeBounds,
double rotationAngle,
double orientation,
bool flipX,
bool flipY
)

Visual Basic [image] Copy Code

Public Function GetHitPath( _
nodeBounds As Rect, _
rotationAngle As Double, _
orientation As Double, _
flipX As Boolean, _
flipY As Boolean _
) As IGraphicsPath

Parameters

nodeBounds

rotationAngle

orientation

flipX

flipY

Return Value

See Also

GetHitPath Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetRenderingPath Method

Shape.GetRenderingPath Method
[image]

Overload List

Name | Description
Shape.GetRenderingPath (Rect, Double, Double) | Returns an IGraphicsPath object corresponding to the outline of the shape when rotated at the specified angle. This IGraphicsPath can (and should) be used when drawing the shape's outline.
Shape.GetRenderingPath (Rect, Double, Double, Boolean, Boolean) | Returns an IGraphicsPath object corresponding to the outline of the shape when rotated at the specified angle. This IGraphicsPath can (and should) be used when drawing the shape's outline.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetRenderingPath Method (Rect, Double, Double)

Shape.GetRenderingPath Method (Rect, Double, Double)
See Also
[image]

Returns an IGraphicsPath object corresponding to the outline of the shape when rotated at the specified angle. This IGraphicsPath can (and should) be used when drawing the shape's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphicsPath GetRenderingPath (
Rect nodeBounds,
double rotationAngle,
double orientation
)

Visual Basic [image] Copy Code

Public Function GetRenderingPath( _
nodeBounds As Rect, _
rotationAngle As Double, _
orientation As Double _
) As IGraphicsPath

Parameters

nodeBounds

The bounding rectangle of the ShapeNode.

rotationAngle

The node's rotation angle.

orientation

The shape's orientation angle.

Return Value

An IGraphicsPath representing the shape's outline.

Remarks

This method returns an empty IGraphicsPath when EnableOutline is set to false regardless of the contents of the Outline property.

See Also

GetRenderingPath Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.GetRenderingPath Method (Rect, Double, Double, Boolean, Boolean)

Shape.GetRenderingPath Method (Rect, Double, Double, Boolean, Boolean)
See Also
[image]

Returns an IGraphicsPath object corresponding to the outline of the shape when rotated at the specified angle. This IGraphicsPath can (and should) be used when drawing the shape's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IGraphicsPath GetRenderingPath (
Rect nodeBounds,
double rotationAngle,
double orientation,
bool flipX,
bool flipY
)

Visual Basic [image] Copy Code

Public Function GetRenderingPath( _
nodeBounds As Rect, _
rotationAngle As Double, _
orientation As Double, _
flipX As Boolean, _
flipY As Boolean _
) As IGraphicsPath

Parameters

nodeBounds

rotationAngle

orientation

flipX

flipY

Return Value

Remarks

This method returns an empty IGraphicsPath when EnableOutline is set to false regardless of the contents of the Outline property.

See Also

GetRenderingPath Method Overload List
Shape Members
Shape Class


MindFusion.Diagramming.Shape.LoadFromXml Method

Shape.LoadFromXml Method
[image]

Loads the shape content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

The XElement containing the shape's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.SaveToXml Method

Shape.SaveToXml Method
[image]

Saves the shape content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Function SaveToXml( _
element As XElement, _
context As XmlPersistContext _
) As Task

Parameters

element

The XElement the shape's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.ToString Method

Shape.ToString Method
[image]

Returns the identifier of this shape template.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

A string value representing the shape identifier.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape Properties

Shape Properties
[image]

Public Properties

Name | Description
AnchorPattern | Gets or sets the anchor pattern to use for nodes using this shape, if their anchor pattern is set to null.
DecorationHitTesting | Gets or sets a value indicating whether decoration lines should be considered when hit-testing.
Decorations | Gets or sets a list with all decorations of this shape.
DisplayName | Gets or sets the name that should be displayed for this shape in user interface objects.
EnableOutline | Gets or sets a value indicating whether to enable the shape's outline.
FillMode | Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.
Id | Gets or sets the shape identifier.
Image | Gets or sets the image displayed in all instances of this shape.
ImageRectangle | Gets or sets the position of the images displayed in instances of this shape.
IsArrowhead | Specifies if this shape is used as arrowhead.
LinkSegmentInset | Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.
Outline | Gets or sets the outline of this shape.
ShapeDecorations | Gets or sets the ShapeDecoration objects associated with this shape.
Shapes | Gets a read-only collection of all named shapes.
TextArea | Gets or sets the outline of the text area of this shape.

See Also

Shape Class


MindFusion.Diagramming.Shape.AnchorPattern Property

Shape.AnchorPattern Property
[image]

Gets or sets the anchor pattern to use for nodes using this shape, if their anchor pattern is set to null.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

An AnchorPattern instance. The default value is null.

Remarks

If the AnchorPattern of a ShapeNode is set, it overrides the one associated with the Shape definition.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.DecorationHitTesting Property

Shape.DecorationHitTesting Property
[image]

Gets or sets a value indicating whether decoration lines should be considered when hit-testing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool DecorationHitTesting { get; set; }

Visual Basic [image] Copy Code

Public Property DecorationHitTesting As Boolean

Property Value

true if decoration lines should be considered for hit-testing; otherwise, false. The default is false.

Remarks

If this property is enabled, users are able to select shape nodes of such shape by clicking near a decoration line or curve, even if it lies outside the shape outlines.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Decorations Property

Shape.Decorations Property
[image]

Gets or sets a list with all decorations of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ElementTemplate[] Decorations { get; set; }

Visual Basic [image] Copy Code

Public Property Decorations As ElementTemplate()

Property Value

An array of ElementTemplate objects specifying the decorations of this shape.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.DisplayName Property

Shape.DisplayName Property
[image]

Gets or sets the name that should be displayed for this shape in user interface objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string DisplayName { get; set; }

Visual Basic [image] Copy Code

Public Property DisplayName As String

Property Value

The DisplayName of all predefined shapes is set to the value of their Id property.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.EnableOutline Property

Shape.EnableOutline Property
[image]

Gets or sets a value indicating whether to enable the shape's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableOutline { get; set; }

Visual Basic [image] Copy Code

Public Property EnableOutline As Boolean

Property Value

A boolean value.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.FillMode Property

Shape.FillMode Property
[image]

Gets or sets a value indicating how areas are filled if the outline path of the shape intersects itself.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FillMode FillMode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FillMode As FillMode

Property Value

A member of the FillMode enumeration specifying the fill type of the shape.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Id Property

Shape.Id Property
[image]

Gets or sets the shape identifier.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Id { get; set; }

Visual Basic [image] Copy Code

Public Property Id As String

Property Value

A string id that has been passed as an argument of the Shape constructor.

Remarks

Once assigned through the constructor, the shape identifier should not be changed, that is, do not use the set accessor of this property. To get the shape with a specified id, call the static FromId method.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Image Property

Shape.Image Property
[image]

Gets or sets the image displayed in all instances of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the ImageSource class. The default is null.

Remarks

The image is displayed in the rectangle specified in ImageRectangle. If the Image property of a shape node is set, it overrides the image specified in the shape definition.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.ImageRectangle Property

Shape.ImageRectangle Property
[image]

Gets or sets the position of the images displayed in instances of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect ImageRectangle { get; set; }

Visual Basic [image] Copy Code

Public Property ImageRectangle As Rect

Property Value

A Rectangle object specifying the location of an image relatively to the shape node that displays the image.

Remarks

The coordinates of the image location are specified in percent, relatively to the rectangular bounds of shape nodes. The default value (0, 0, 100, 100) makes the image displayed in the whole area of that node.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.IsArrowhead Property

Shape.IsArrowhead Property
[image]

Specifies if this shape is used as arrowhead.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsArrowhead { get; set; }

Visual Basic [image] Copy Code

Public Property IsArrowhead As Boolean

Property Value

true if this shape is designated as arrowhead; otherwise false.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.LinkSegmentInset Property

Shape.LinkSegmentInset Property
[image]

Specifies what length of link's line segment is drawn inside the arrowhead shape, expressed as percents of arrowhead size.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkSegmentInset { get; set; }

Visual Basic [image] Copy Code

Public Property LinkSegmentInset As Double

Property Value

A double value specifying percents of arrowhead size. The default value is 100.

Remarks

The inset value matters when using transparent or semi-transparent arrowhead brush, or when the link's Pen is thicker than one pixel and its cap might extend beyond the arrowhead outline. LinkSegmentInset is set to appropriate values for all shapes from the ArrowHeads class. You might want to set it when using custom arrowhead shapes for which the link's end segment should not reach all the way to the arrowhead tip.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Outline Property

Shape.Outline Property
[image]

Gets or sets the outline of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ElementTemplate[] Outline { get; set; }

Visual Basic [image] Copy Code

Public Property Outline As ElementTemplate()

Property Value

An array of ElementTemplate objects specifying the outline of the shape.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.ShapeDecorations Property

Shape.ShapeDecorations Property
[image]

Gets or sets the ShapeDecoration objects associated with this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeDecoration[] ShapeDecorations { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeDecorations As ShapeDecoration()

Property Value

An array of ShapeDecoration objects.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.Shapes Property

Shape.Shapes Property
[image]

Gets a read-only collection of all named shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ShapeCollection Shapes { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Shapes As ShapeCollection

Property Value

An instance of the ShapeCollection class.

Remarks

Initially the collection contains only the predefined shapes. Any new shape you create is added automatically to Shapes if an identifier has been specified via the Shape constructor.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.Shape.TextArea Property

Shape.TextArea Property
[image]

Gets or sets the outline of the text area of this shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ElementTemplate[] TextArea { get; set; }

Visual Basic [image] Copy Code

Public Property TextArea As ElementTemplate()

Property Value

An array of ElementTemplate objects specifying the text area of this shape.

See Also

Shape Members
Shape Class


MindFusion.Diagramming.ShapeCollection Class

ShapeCollection Class
[image]

Represents a read-only collection of shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeCollection : List<Shape>

Visual Basic [image] Copy Code

Public Class ShapeCollection
Inherits List(Of Shape)

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(Shape)
MindFusion.Diagramming.ShapeCollection

See Also

ShapeCollection Members


MindFusion.Diagramming.ShapeCollection Members

ShapeCollection Members
Methods
[image]

Represents a read-only collection of shapes.

The following tables list the members exposed by the ShapeCollection type.

Public Methods

Name | Description
GetAt | Gets the shape at the specified position.

See Also

ShapeCollection Class


MindFusion.Diagramming.ShapeCollection Methods

ShapeCollection Methods
[image]

Public Methods

Name | Description
GetAt | Gets the shape at the specified position.

See Also

ShapeCollection Class


MindFusion.Diagramming.ShapeCollection.GetAt Method

ShapeCollection.GetAt Method
[image]

Gets the shape at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape GetAt (
int index
)

Visual Basic [image] Copy Code

Public Function GetAt( _
index As Integer _
) As Shape

Parameters

index

The zero-based index of the shape to retrieve.

Return Value

An instance of the Shape class that represents the shape at the specified position.

See Also

ShapeCollection Members
ShapeCollection Class


MindFusion.Diagramming.ShapeDecoration Class

ShapeDecoration Class
[image]

Defines decoration elements that are displayed as filled shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeDecoration

Visual Basic [image] Copy Code

Public Class ShapeDecoration

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeDecoration

See Also

ShapeDecoration Members


MindFusion.Diagramming.ShapeDecoration Members

ShapeDecoration Members
Constructors Properties Methods
[image]

Defines decoration elements that are displayed as filled shapes.

The following tables list the members exposed by the ShapeDecoration type.

Public Constructors

Name | Description
ShapeDecoration | Initializes a new instance of the ShapeDecoration class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the decoration shape interior.
Elements | Gets the elements that define the decoration's shape.
FillMode | Gets or sets how areas are filled if the outline path intersects itself.
Pen | Gets or sets the brush used to draw the decoration shape outline.

Public Methods

Name | Description
Clone | Clones this ShapeDecoration object.
LoadFromXml | Loads the ShapeDecoration definition from an XML document.
SaveToXml | Saves the ShapeDecoration definition in an XML document.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration Constructor

ShapeDecoration Constructor
[image]

Initializes a new instance of the ShapeDecoration class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeDecoration (
ElementTemplate[] elements,
Brush brush,
FillMode fillMode,
Pen pen
)

Visual Basic [image] Copy Code

Public New ( _
elements() As ElementTemplate, _
brush As Brush, _
fillMode As FillMode, _
pen As Pen _
)

Parameters

elements

An array of ElementTemplate objects that define the decoration shape outline.

brush

A Brush object used to fill the decoration shape interior.

fillMode

Specifies how areas are filled if the outline path intersects itself.

pen

A Pen object used to draw the decoration shape outline.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration Methods

ShapeDecoration Methods
[image]

Public Methods

Name | Description
Clone | Clones this ShapeDecoration object.
LoadFromXml | Loads the ShapeDecoration definition from an XML document.
SaveToXml | Saves the ShapeDecoration definition in an XML document.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.Clone Method

ShapeDecoration.Clone Method
[image]

Clones this ShapeDecoration object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeDecoration Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As ShapeDecoration

Return Value

A copy of the ShapeDecoration.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.LoadFromXml Method

ShapeDecoration.LoadFromXml Method
[image]

Loads the ShapeDecoration definition from an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

The parent XElement object.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.SaveToXml Method

ShapeDecoration.SaveToXml Method
[image]

Saves the ShapeDecoration definition in an XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

The parent XElement object.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration Properties

ShapeDecoration Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the decoration shape interior.
Elements | Gets the elements that define the decoration's shape.
FillMode | Gets or sets how areas are filled if the outline path intersects itself.
Pen | Gets or sets the brush used to draw the decoration shape outline.

See Also

ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.Brush Property

ShapeDecoration.Brush Property
[image]

Gets or sets the brush used to fill the decoration shape interior.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the Brush class.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.Elements Property

ShapeDecoration.Elements Property
[image]

Gets the elements that define the decoration's shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ElementTemplate[] Elements { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Elements As ElementTemplate()

Property Value

An array of ElementTemplate objects.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.FillMode Property

ShapeDecoration.FillMode Property
[image]

Gets or sets how areas are filled if the outline path intersects itself.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FillMode FillMode { get; set; }

Visual Basic [image] Copy Code

Public Property FillMode As FillMode

Property Value

A member of the FillMode enumeration.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeDecoration.Pen Property

ShapeDecoration.Pen Property
[image]

Gets or sets the brush used to draw the decoration shape outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen Pen { get; set; }

Visual Basic [image] Copy Code

Public Property Pen As Pen

Property Value

An instance of the Pen class.

See Also

ShapeDecoration Members
ShapeDecoration Class


MindFusion.Diagramming.ShapeLibrary Class

ShapeLibrary Class
Remarks See Also
[image]

The ShapeLibrary class represents a collection of shape definitions stored together.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeLibrary

Visual Basic [image] Copy Code

Public Class ShapeLibrary

Remarks

A shape library can be saved and loaded to/from a file in XML-based format using the SaveToXml and LoadFromXml methods. The loaded shapes can be accessed through the Shapes property. They will be automatically added to the shared list of shapes kept in the Shape class, which lets you access them through the FromId method.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ShapeLibrary

See Also

ShapeLibrary Members


MindFusion.Diagramming.ShapeLibrary Members

ShapeLibrary Members
Constructors Properties Methods
[image]

The ShapeLibrary class represents a collection of shape definitions stored together.

The following tables list the members exposed by the ShapeLibrary type.

Public Constructors

Name | Description
ShapeLibrary | Overloaded. Initializes a new instance of the ShapeLibrary class.

Public Properties

Name | Description
Shapes | Gets or sets the list with all shapes contained in the library.

Public Methods

Name | Description
LoadFrom | Loads a shape library from the specified straem.
LoadFromXml | Overloaded. Loads this library from a stream or a XML document.
SaveToXml | Overloaded. Saves this library to a stream or an XML document.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Constructor

ShapeLibrary Constructor
[image]

Initializes a new instance of the ShapeLibrary class.

Overload List

Name | Description
ShapeLibrary () | Initializes a new empty instance of the ShapeLibrary class.
ShapeLibrary (Shape[]) | Initializes a new instance of the ShapeLibrary class.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Constructor ()

ShapeLibrary Constructor ()
See Also
[image]

Initializes a new empty instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeLibrary ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeLibrary Constructor Overload List
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Constructor (Shape[])

ShapeLibrary Constructor (Shape[])
See Also
[image]

Initializes a new instance of the ShapeLibrary class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeLibrary (
Shape[] shapes
)

Visual Basic [image] Copy Code

Public New ( _
shapes() As Shape _
)

Parameters

shapes

An array of Shape object to initialize the library with.

See Also

ShapeLibrary Constructor Overload List
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Methods

ShapeLibrary Methods
[image]

Public Methods

Name | Description
LoadFrom | Loads a shape library from the specified straem.
LoadFromXml | Overloaded. Loads this library from a stream or a XML document.
SaveToXml | Overloaded. Saves this library to a stream or an XML document.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFrom Method

ShapeLibrary.LoadFrom Method
[image]

Loads a shape library from the specified straem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static ShapeLibrary LoadFrom (
Stream stream
)

Visual Basic [image] Copy Code

Public Shared Function LoadFrom( _
stream As Stream _
) As ShapeLibrary

Parameters

stream

The name of the file that contains the shape library.

Return Value

An instance of the ShapeLibrary class whose Shapes array contains the loaded shape definitions.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method

ShapeLibrary.LoadFromXml Method
[image]

Loads this library from a stream or a XML document.

Overload List

Name | Description
ShapeLibrary.LoadFromXml (Stream) | Loads this library from the specified stream.
ShapeLibrary.LoadFromXml (XDocument) | Loads the shape library from the specified XML document.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (Stream)

ShapeLibrary.LoadFromXml Method (Stream)
See Also
[image]

Loads this library from the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
stream As Stream _
)

Parameters

stream

The stream from which to load the shape library.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.LoadFromXml Method (XDocument)

ShapeLibrary.LoadFromXml Method (XDocument)
See Also
[image]

Loads the shape library from the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
document As XDocument _
)

Parameters

document

The document to load the library from.

See Also

LoadFromXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method

ShapeLibrary.SaveToXml Method
[image]

Saves this library to a stream or an XML document.

Overload List

Name | Description
ShapeLibrary.SaveToXml (Stream) | Saves this library to the specified stream.
ShapeLibrary.SaveToXml (XDocument) | Saves the shape library into the specified XML document.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (Stream)

ShapeLibrary.SaveToXml Method (Stream)
See Also
[image]

Saves this library to the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task SaveToXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Function SaveToXml( _
stream As Stream _
) As Task

Parameters

stream

The stream where to save the shape library.

Return Value

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.SaveToXml Method (XDocument)

ShapeLibrary.SaveToXml Method (XDocument)
See Also
[image]

Saves the shape library into the specified XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task SaveToXml (
XDocument document
)

Visual Basic [image] Copy Code

Public Function SaveToXml( _
document As XDocument _
) As Task

Parameters

document

The document to save the library to.

Return Value

See Also

SaveToXml Method Overload List
ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary Properties

ShapeLibrary Properties
[image]

Public Properties

Name | Description
Shapes | Gets or sets the list with all shapes contained in the library.

See Also

ShapeLibrary Class


MindFusion.Diagramming.ShapeLibrary.Shapes Property

ShapeLibrary.Shapes Property
[image]

Gets or sets the list with all shapes contained in the library.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape[] Shapes { get; set; }

Visual Basic [image] Copy Code

Public Property Shapes As Shape()

Property Value

An array of Shape objects containing the shape definitions.

See Also

ShapeLibrary Members
ShapeLibrary Class


MindFusion.Diagramming.ShapeNode Class

ShapeNode Class
Remarks See Also
[image]

ShapeNode instances are diagram nodes that represent geometric shapes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class ShapeNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

A ShapeNode instance represents nodes in graphs, tree, process diagrams, and so on.

The shape of a node is specified through the Shape property. Shapes can be rotated, either interactively using the rotation handle above the node, or programmatically using the RotationAngle property.

Shape nodes can display images and text. Set an image to be painted inside a node by assigning it to the Image property. The position of the image within the node and its alignment are set by the ImageAlign property.

Text inside a shape node is represented by the Text property. Its attributes can be changed by the TextBrush and TextFormat properties.

To let users edit a node's text inline, call the BeginEdit method of Diagram. Call EndEdit to exit in-place editing mode.

Fill and border colors can be specified by setting the Pen and Brush properties. Shape nodes can be transparent as set through the Transparent property.

Shape nodes can have incoming and outgoing DiagramLink objects accessible through the IncomingLinks and OutgoingLinks properties defined in the DiagramNode class.

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.ShapeNode

See Also

ShapeNode Members


MindFusion.Diagramming.ShapeNode Members

ShapeNode Members
Constructors Fields Properties Methods Events
[image]

ShapeNode instances are diagram nodes that represent geometric shapes.

The following tables list the members exposed by the ShapeNode type.

Public Constructors

Name | Description
ShapeNode | Overloaded. Initializes a new instance of the ShapeNode class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowFlip | Gets or sets a value indicating whether the node's shape flips when an edge is dragged over its opposite edge.
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
CustomDraw | Gets or sets the type of custom drawing performed on this shape node.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FlipX | Gets or sets a value indicating whether the node's shape is flipped horizontally.
FlipY | Gets or sets a value indicating whether the node's shape is flipped vertically.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this shape node.
ImageAlign | Gets or sets the alignment of the image displayed in this shape node.
ImagePadding | Gets or sets the padding distance between node's borders and image.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RotateImage | Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.
RotateText | Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets a reference to the node's geometric shape definition.
ShapeOrientation | Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside the shape node.
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes.
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Transparent | Gets or sets a value indicating whether this shape node is transparent.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override.
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramNode.GetOutlinePoly override.
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramNode.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node. (Inherited from DiagramNode.)
GetImageRect | Overloaded. Gets the destination rectangle of the node's image.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns an IGraphicsPath object for this node as though it is contained in the specified rectangle.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by users, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramNode.RestoreState override.
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramNode.SaveState override.
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

Public Events

Name | Description
ImageReady | For internal use.

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor

ShapeNode Constructor
[image]

Initializes a new instance of the ShapeNode class.

Overload List

Name | Description
ShapeNode () | Initializes a new instance of the ShapeNode class.
ShapeNode (Diagram) | Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.
ShapeNode (ShapeNode) | Initializes a new instance of the ShapeNode class using the specified node as a prototype.

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor ()

ShapeNode Constructor ()
See Also
[image]

Initializes a new instance of the ShapeNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNode Constructor Overload List
ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor (Diagram)

ShapeNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the ShapeNode class with default values supplied form the specified Diagram.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the ShapeNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

ShapeNode Constructor Overload List
ShapeNode Class


MindFusion.Diagramming.ShapeNode Constructor (ShapeNode)

ShapeNode Constructor (ShapeNode)
See Also
[image]

Initializes a new instance of the ShapeNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNode (
ShapeNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As ShapeNode _
)

Parameters

prototype

The node to use as a prototype. The properties of the new node are initialized from the property values of this node.

Remarks

This constructor copies the ShapeNode property values from the specified prototype node.

See Also

ShapeNode Constructor Overload List
ShapeNode Class


MindFusion.Diagramming.ShapeNode Methods

ShapeNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override.
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramNode.GetOutlinePoly override.
GetRepaintRect | DiagramNode.GetRepaintRect override.
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramNode.CreateState override.
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node. (Inherited from DiagramNode.)
GetImageRect | Overloaded. Gets the destination rectangle of the node's image.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns an IGraphicsPath object for this node as though it is contained in the specified rectangle.
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by users, programmatically or via undo / redo.
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramNode.RestoreState override.
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramNode.SaveState override.
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode.ContainsPoint Method

ShapeNode.ContainsPoint Method
[image]

DiagramItem.ContainsPoint override.

Overload List

Name | Description
ShapeNode.ContainsPoint (Point) | DiagramItem.ContainsPoint override.
ShapeNode.ContainsPoint (Point, Double) | Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ContainsPoint Method (Point)

ShapeNode.ContainsPoint Method (Point)
See Also
[image]

DiagramItem.ContainsPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point _
) As Boolean

Parameters

point

Return Value

See Also

ContainsPoint Method Overload List
ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ContainsPoint Method (Point, Double)

ShapeNode.ContainsPoint Method (Point, Double)
See Also
[image]

Tests whether the specified point is contained within the outline of this node, relaxed with the specified threshold.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool ContainsPoint (
Point point,
double threshold
)

Visual Basic [image] Copy Code

Public Overrides Function ContainsPoint( _
point As Point, _
threshold As Double _
) As Boolean

Parameters

point

threshold

Return Value

See Also

ContainsPoint Method Overload List
ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.CreateConnectionPoint Method

ShapeNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Public Overrides Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link

A DiagramLink that should be connected to this node.

pt

The point at which the link should be connected.

incoming

true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.CreateProperties Method

ShapeNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.CreateState Method

ShapeNode.CreateState Method
[image]

DiagramNode.CreateState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemState CreateState ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateState () As DiagramItemState

Return Value

A ShapeNodeState instance.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.DrawLocal Method

ShapeNode.DrawLocal Method
[image]

Draws the node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.DrawShadowLocal Method

ShapeNode.DrawShadowLocal Method
[image]

Draws the shadow of this node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadowLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadowLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetImageRect Method

ShapeNode.GetImageRect Method
[image]

Gets the destination rectangle of the node's image.

Overload List

Name | Description
ShapeNode.GetImageRect () | Gets the image rectangle from the associated shape template or the node's bounding rectangle if there is no associated shape template.
ShapeNode.GetImageRect (Boolean) | Gets the image rectangle from the associated shape template or the node's bounding rectangle if there is no associated shape template.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetImageRect Method ()

ShapeNode.GetImageRect Method ()
See Also
[image]

Gets the image rectangle from the associated shape template or the node's bounding rectangle if there is no associated shape template.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Rect GetImageRect ()

Visual Basic [image] Copy Code

Protected Function GetImageRect () As Rect

Return Value

A Rectangle specifying the region inside this node where its associated Image will be rendered.

See Also

GetImageRect Method Overload List
ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetImageRect Method (Boolean)

ShapeNode.GetImageRect Method (Boolean)
See Also
[image]

Gets the image rectangle from the associated shape template or the node's bounding rectangle if there is no associated shape template.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Rect GetImageRect (
bool inLocal
)

Visual Basic [image] Copy Code

Protected Function GetImageRect( _
inLocal As Boolean _
) As Rect

Parameters

inLocal

Return Value

A Rectangle specifying the region inside this node where its associated Image will be rendered.

See Also

GetImageRect Method Overload List
ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetIntersection Method

ShapeNode.GetIntersection Method
[image]

Calculates the intersection point between the segment defined by the specified point pair and the node's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart

The first point of the segment.

segmentEnd

The second point of the segment.

Return Value

A Point object representing the intersection point.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetOutlinePoly Method

ShapeNode.GetOutlinePoly Method
[image]

DiagramNode.GetOutlinePoly override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override PointCollection GetOutlinePoly (
bool rendering
)

Visual Basic [image] Copy Code

Public Overrides Function GetOutlinePoly( _
rendering As Boolean _
) As PointCollection

Parameters

rendering

Return Value

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetRepaintRect Method

ShapeNode.GetRepaintRect Method
[image]

DiagramNode.GetRepaintRect override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Rect GetRepaintRect (
bool includeConnected
)

Visual Basic [image] Copy Code

Public Overrides Function GetRepaintRect( _
includeConnected As Boolean _
) As Rect

Parameters

includeConnected

true is related items should be considered too; otherwise, false.

Return Value

A rectangular region that should be repainted when this node is modified.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.GetRgnInRect Method

ShapeNode.GetRgnInRect Method
[image]

Creates and returns an IGraphicsPath object for this node as though it is contained in the specified rectangle.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override IGraphicsPath GetRgnInRect (
Rect rc,
bool inLocal
)

Visual Basic [image] Copy Code

Protected Overrides Function GetRgnInRect( _
rc As Rect, _
inLocal As Boolean _
) As IGraphicsPath

Parameters

rc

inLocal

Return Value

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.LoadFromJson Method

ShapeNode.LoadFromJson Method
[image]

Loads the item content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the item's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.LoadFromXml Method

ShapeNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.OnAdd Method

ShapeNode.OnAdd Method
[image]

Called when the item is added to a Diagram, either by users, programmatically or via undo / redo.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnAdd ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnAdd ()

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.OnUpdateBounds Method

ShapeNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

true if the size has changed; false if only the position has changed.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.RestoreProperties Method

ShapeNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.RestoreState Method

ShapeNode.RestoreState Method
[image]

DiagramNode.RestoreState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreState( _
state As DiagramItemState _
)

Parameters

state

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SaveProperties Method

ShapeNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SaveState Method

ShapeNode.SaveState Method
[image]

DiagramNode.SaveState override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveState (
DiagramItemState state
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveState( _
state As DiagramItemState _
)

Parameters

state

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SaveToJson Method

ShapeNode.SaveToJson Method
[image]

Saves the item content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the item's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.SaveToXml Method

ShapeNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToXml( _
element As XElement, _
context As XmlPersistContext _
) As Task

Parameters

element

An XElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode Properties

ShapeNode Properties
[image]

Public Properties

Name | Description
AllowFlip | Gets or sets a value indicating whether the node's shape flips when an edge is dragged over its opposite edge.
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
CustomDraw | Gets or sets the type of custom drawing performed on this shape node.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
FlipX | Gets or sets a value indicating whether the node's shape is flipped horizontally.
FlipY | Gets or sets a value indicating whether the node's shape is flipped vertically.
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this shape node.
ImageAlign | Gets or sets the alignment of the image displayed in this shape node.
ImagePadding | Gets or sets the padding distance between node's borders and image.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RotateImage | Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.
RotateText | Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets a reference to the node's geometric shape definition.
ShapeOrientation | Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
Text | Gets or sets the text displayed inside the shape node.
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of the text that is displayed inside shape nodes.
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Transparent | Gets or sets a value indicating whether this shape node is transparent.
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode.AllowFlip Property

ShapeNode.AllowFlip Property
[image]

Gets or sets a value indicating whether the node's shape flips when an edge is dragged over its opposite edge.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowFlip { get; set; }

Visual Basic [image] Copy Code

Public Property AllowFlip As Boolean

Property Value

true to let users flip the shape, or false otherwise. The default value is false.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
FlipX Property
FlipY Property
EnabledHandles Property
Shape Property


MindFusion.Diagramming.ShapeNode.CustomDraw Property

ShapeNode.CustomDraw Property
[image]

Gets or sets the type of custom drawing performed on this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw CustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of ShapeCustomDraw.

Remarks

This property allows invoking custom painting code for a shape node. That code must execute in response to the DrawNode event. There are several modes of custom painting, allowing the custom code to paint the shape node entirely, or do that in addition to what MindFusion.Diagramming for .NET MAUI paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming for .NET MAUI.
Additional | The custom painting code executes after the node interior and frame are painted by MindFusion.Diagramming for .NET MAUI, but before text is rendered. In this mode, the IGraphics instance passed to the custom drawing event handler has a clipping region applied to it.
Full | The component does not do any standard drawing, the entire painting of the node is done by the application.
ShadowOnly | Only the shadow of the node is painted by custom code, the node itself is drawn by the component.
Additional2 | The custom painting code executes after all parts of the node are painted by MindFusion.Diagramming for .NET MAUI. In this mode, the IGraphics instance passed to the custom drawing event handler doesn't have a clipping region applied to it.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.FlipX Property

ShapeNode.FlipX Property
[image]

Gets or sets a value indicating whether the node's shape is flipped horizontally.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool FlipX { get; set; }

Visual Basic [image] Copy Code

Public Property FlipX As Boolean

Property Value

true if the shape is flipped horizontally, or false otherwise.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
FlipY Property
AllowFlip Property


MindFusion.Diagramming.ShapeNode.FlipY Property

ShapeNode.FlipY Property
[image]

Gets or sets a value indicating whether the node's shape is flipped vertically.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool FlipY { get; set; }

Visual Basic [image] Copy Code

Public Property FlipY As Boolean

Property Value

true if the shape is flipped vertically, or false otherwise.

See Also

ShapeNode Members
ShapeNode Class
MindFusion.Diagramming Namespace
FlipX Property
AllowFlip Property


MindFusion.Diagramming.ShapeNode.Image Property

ShapeNode.Image Property
[image]

Gets or sets the image that is displayed in this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the ImageSource class. The default value is null.

Remarks

This property lets you display an image inside the node. The ImageRectangle attribute of the shape definition specifies a rectangular area inside the node in which the image is displayed. Use the ImageAlign property to specify how the image is aligned to that area. By default, the image is displayed in the center of the bounding rectangle of the node.

If there isn't any image assigned to this property, the shape node displays the Image specified in its Shape template.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ImageAlign Property

ShapeNode.ImageAlign Property
[image]

Gets or sets the alignment of the image displayed in this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageAlignment ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlignment

Property Value

A member of the ImageAlignment enumeration. The default is Center.

Remarks

This property specifies how the Image is aligned to the bounding rectangle of this node. The image is aligned relatively to the rectangle specified in the ImageRectangle attribute of the Shape definition.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ImagePadding Property

ShapeNode.ImagePadding Property
[image]

Gets or sets the padding distance between node's borders and image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Thickness> ImagePadding { get; set; }

Visual Basic [image] Copy Code

Public Property ImagePadding As Nullable(Of Thickness)

Property Value

An optional Thickness instance.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.RotateImage Property

ShapeNode.RotateImage Property
[image]

Gets or sets a value indicating whether the Image should be rotated when the shape node is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RotateImage { get; set; }

Visual Basic [image] Copy Code

Public Property RotateImage As Boolean

Property Value

true to rotate the node's image; otherwise, false. The default is true.

Remarks

The image is clipped by the rotated shape outline, even if this property is set to false.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.RotateText Property

ShapeNode.RotateText Property
[image]

Gets or sets a value indicating whether the Text should be rotated when the shape node is rotated.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RotateText { get; set; }

Visual Basic [image] Copy Code

Public Property RotateText As Boolean

Property Value

true to rotate the node's text; otherwise, false. The default is false.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.Shape Property

ShapeNode.Shape Property
[image]

Gets or sets a reference to the node's geometric shape definition.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As Shape

Property Value

An instance of the Shape class.

Remarks

Use this property to assign a complex shape to a node.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.ShapeOrientation Property

ShapeNode.ShapeOrientation Property
[image]

Gets or sets the angle specifying the orientation with which a shape template is applied to the node bounds.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ShapeOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property ShapeOrientation As Double

Property Value

A double value specifying the orientation angle in degrees. Initialized with the value of ShapeOrientation.

Remarks

That property does not rotate the node, that is, does not rotate the bounding rectangle of the node around its center. It specifies a rotation transformation to be performed on the definition of the Shape when it is applied to a node; the node's bounding rectangle (location, width and height) remain intact. In the current MindFusion.Diagramming for .NET MAUI version, only 0, 90, 180 or 270 can be set as value of ShapeOrientation.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.Text Property

ShapeNode.Text Property
[image]

Gets or sets the text displayed inside the shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string containing the node's text. Initialized with the value of ShapeText.

Remarks

This property specifies the text that should be drawn inside the shape. The text appearance can be customized through the TextBrush and TextFormat properties.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.TextFormat Property

ShapeNode.TextFormat Property
[image]

Gets or sets the alignment of the text that is displayed inside shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the StringFormat class. Initialized with the value of TextFormat.

Remarks

Use this property to specify the wrapping mode and alignment of the text that is contained in nodes.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode.Transparent Property

ShapeNode.Transparent Property
[image]

Gets or sets a value indicating whether this shape node is transparent.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Transparent { get; set; }

Visual Basic [image] Copy Code

Public Property Transparent As Boolean

Property Value

true if the shape node is transparent; otherwise, false. The default is false.

Remarks

If a node is transparent, only its image and text are drawn. Shape, filling and frames are not painted.

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNode Events

ShapeNode Events
[image]

Public Events

Name | Description
ImageReady | For internal use.

See Also

ShapeNode Class


MindFusion.Diagramming.ShapeNode.ImageReady Event

ShapeNode.ImageReady Event
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler ImageReady

Visual Basic [image] Copy Code

Public Event ImageReady As EventHandler

See Also

ShapeNode Members
ShapeNode Class


MindFusion.Diagramming.ShapeNodeProperties Class

ShapeNodeProperties Class
Remarks See Also
[image]

Stores the values of ShapeNode properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class ShapeNodeProperties
Inherits DiagramNodeProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from ShapeNode, do so by deriving from ShapeNodeProperties and overriding the ShapeNode.SaveProperties, ShapeNode.RestoreProperties, and ShapeNode.CreateProperties methods.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.ShapeNodeProperties

See Also

ShapeNodeProperties Members


MindFusion.Diagramming.ShapeNodeProperties Members

ShapeNodeProperties Members
Constructors Fields Methods
[image]

Stores the values of ShapeNode properties during undo / redo operations.

The following tables list the members exposed by the ShapeNodeProperties type.

Public Constructors

Name | Description
ShapeNodeProperties | Initializes a new instance of the ShapeNodeProperties class.

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use. (Inherited from DiagramNodeProperties.)
RotateText | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Shape | For internal use.
ShapeOrientation | For internal use.
Text | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
Transparent | For internal use.
UsePolyTextLt | For internal use.
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties Fields

ShapeNodeProperties Fields
[image]

Public Fields

Name | Description
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use. (Inherited from DiagramNodeProperties.)
RotateText | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
Shape | For internal use.
ShapeOrientation | For internal use.
Text | For internal use.
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
Transparent | For internal use.
UsePolyTextLt | For internal use.
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

See Also

ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.RotateText Field

ShapeNodeProperties.RotateText Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RotateText

Visual Basic [image] Copy Code

Public RotateText As Boolean

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.Shape Field

ShapeNodeProperties.Shape Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape Shape

Visual Basic [image] Copy Code

Public Shape As Shape

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.ShapeOrientation Field

ShapeNodeProperties.ShapeOrientation Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ShapeOrientation

Visual Basic [image] Copy Code

Public ShapeOrientation As Double

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.Text Field

ShapeNodeProperties.Text Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text

Visual Basic [image] Copy Code

Public Text As String

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.Transparent Field

ShapeNodeProperties.Transparent Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Transparent

Visual Basic [image] Copy Code

Public Transparent As Boolean

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.UsePolyTextLt Field

ShapeNodeProperties.UsePolyTextLt Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UsePolyTextLt

Visual Basic [image] Copy Code

Public UsePolyTextLt As Boolean

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties Constructor

ShapeNodeProperties Constructor
[image]

Initializes a new instance of the ShapeNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties Methods

ShapeNodeProperties Methods
[image]

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeProperties.FreeResources Method

ShapeNodeProperties.FreeResources Method
[image]

DiagramItemProperties.FreeResources override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void FreeResources ()

Visual Basic [image] Copy Code

Public Overrides Sub FreeResources ()

See Also

ShapeNodeProperties Members
ShapeNodeProperties Class


MindFusion.Diagramming.ShapeNodeState Class

ShapeNodeState Class
[image]

Contains a snapshot of the internal state of a ShapeNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeNodeState : DiagramNodeState

Visual Basic [image] Copy Code

Public Class ShapeNodeState
Inherits DiagramNodeState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemState
MindFusion.Diagramming.DiagramNodeState
MindFusion.Diagramming.ShapeNodeState

See Also

ShapeNodeState Members


MindFusion.Diagramming.ShapeNodeState Members

ShapeNodeState Members
Constructors
[image]

Contains a snapshot of the internal state of a ShapeNode.

The following tables list the members exposed by the ShapeNodeState type.

Public Constructors

Name | Description
ShapeNodeState | Initializes a new instance of the ShapeNodeState class.

See Also

ShapeNodeState Class


MindFusion.Diagramming.ShapeNodeState Constructor

ShapeNodeState Constructor
[image]

Initializes a new instance of the ShapeNodeState class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNodeState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNodeState Class


MindFusion.Diagramming.ShapeNodeStyle Class

ShapeNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of shape nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ShapeNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class ShapeNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.ShapeNodeStyle

See Also

ShapeNodeStyle Members


MindFusion.Diagramming.ShapeNodeStyle Members

ShapeNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of shape nodes.

The following tables list the members exposed by the ShapeNodeStyle type.

Public Constructors

Name | Description
ShapeNodeStyle | Initializes a new instance of the ShapeNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JsonObject. (Inherited from DiagramNodeStyle.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject. (Inherited from DiagramNodeStyle.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

ShapeNodeStyle Class


MindFusion.Diagramming.ShapeNodeStyle Constructor

ShapeNodeStyle Constructor
[image]

Initializes a new instance of the ShapeNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ShapeNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

ShapeNodeStyle Class


MindFusion.Diagramming.Shapes Class

Shapes Class
[image]

Provides alternative method of access to the MindFusion.Diagramming for .NET MAUI predefined shapes, that allows code completion, which is not available when using Shape.FromId.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class Shapes

Visual Basic [image] Copy Code

Public NotInheritable Class Shapes

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Shapes

See Also

Shapes Members


MindFusion.Diagramming.Shapes Members

Shapes Members
Properties
[image]

Provides alternative method of access to the MindFusion.Diagramming for .NET MAUI predefined shapes, that allows code completion, which is not available when using Shape.FromId.

The following tables list the members exposed by the Shapes type.

Public Properties

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
BpmnComplex | Gets the BpmnComplex predefined shape.
BpmnDataBasedXor | Gets the BpmnDataBasedXor predefined shape.
BpmnEndCancel | Gets the BpmnEndCancel predefined shape.
BpmnEndCompensation | Gets the BpmnEndCompensation predefined shape.
BpmnEndError | Gets the BpmnEndError predefined shape.
BpmnEndLink | Gets the BpmnEndLink predefined shape.
BpmnEndMessage | Gets the BpmnEndMessage predefined shape.
BpmnEndMultiple | Gets the BpmnEndMultiple predefined shape.
BpmnEndTerminate | Gets the BpmnEndTerminate predefined shape.
BpmnEventBasedXor | Gets the BpmnEventBasedXor predefined shape.
BpmnInclusive | Gets the BpmnInclusive predefined shape.
BpmnIntermediateCancel | Gets the BpmnIntermediateCancel predefined shape.
BpmnIntermediateCompensation | Gets the BpmnIntermediateCompensation predefined shape.
BpmnIntermediateError | Gets the BpmnIntermediateError predefined shape.
BpmnIntermediateLink | Gets the BpmnIntermediateLink predefined shape.
BpmnIntermediateMessage | Gets the BpmnIntermediateMessage predefined shape.
BpmnIntermediateMultiple | Gets the BpmnIntermediateMultiple predefined shape.
BpmnIntermediateRule | Gets the BpmnIntermediateRule predefined shape.
BpmnIntermediateTimer | Gets the BpmnIntermediateTimer predefined shape.
BpmnParallelFork | Gets the BpmnParallelFork predefined shape.
BpmnStartLink | Gets the BpmnStartLink predefined shape.
BpmnStartMessage | Gets the BpmnStartMessage predefined shape.
BpmnStartMultiple | Gets the BpmnStartMultiple predefined shape.
BpmnStartRule | Gets the BpmnStartRule predefined shape.
BpmnStartTimer | Gets the BpmnStartTimer predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decagon | Gets the Decagon predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
Donut | Gets the Donut predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
Plaque | Gets the Plaque predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Rectangle | Gets the Rectangle predefined shape.
RightTriangle | Gets the RightTriangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Star16Pointed | Gets the Star16Pointed predefined shape.
Star24Pointed | Gets the Star24Pointed predefined shape.
Star32Pointed | Gets the Star32Pointed predefined shape.
Star4Pointed | Gets the Star4Pointed predefined shape.
Star5Pointed | Gets the Star5Pointed predefined shape.
Star6Pointed | Gets the Star6Pointed predefined shape.
Star7Pointed | Gets the Star7Pointed predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.
Trapezoid | Gets the Trapezoid predefined shape.

See Also

Shapes Class


MindFusion.Diagramming.Shapes Properties

Shapes Properties
[image]

Public Properties

Name | Description
Actor | Gets the Actor predefined shape.
Alternative | Gets the Alternative predefined shape.
Arrow1 | Gets the Arrow1 predefined shape.
Arrow2 | Gets the Arrow2 predefined shape.
Arrow3 | Gets the Arrow3 predefined shape.
Arrow4 | Gets the Arrow4 predefined shape.
Arrow5 | Gets the Arrow5 predefined shape.
Arrow6 | Gets the Arrow6 predefined shape.
Arrow7 | Gets the Arrow7 predefined shape.
Arrow8 | Gets the Arrow8 predefined shape.
Arrow9 | Gets the Arrow9 predefined shape.
BeginLoop | Gets the BeginLoop predefined shape.
BpmnComplex | Gets the BpmnComplex predefined shape.
BpmnDataBasedXor | Gets the BpmnDataBasedXor predefined shape.
BpmnEndCancel | Gets the BpmnEndCancel predefined shape.
BpmnEndCompensation | Gets the BpmnEndCompensation predefined shape.
BpmnEndError | Gets the BpmnEndError predefined shape.
BpmnEndLink | Gets the BpmnEndLink predefined shape.
BpmnEndMessage | Gets the BpmnEndMessage predefined shape.
BpmnEndMultiple | Gets the BpmnEndMultiple predefined shape.
BpmnEndTerminate | Gets the BpmnEndTerminate predefined shape.
BpmnEventBasedXor | Gets the BpmnEventBasedXor predefined shape.
BpmnInclusive | Gets the BpmnInclusive predefined shape.
BpmnIntermediateCancel | Gets the BpmnIntermediateCancel predefined shape.
BpmnIntermediateCompensation | Gets the BpmnIntermediateCompensation predefined shape.
BpmnIntermediateError | Gets the BpmnIntermediateError predefined shape.
BpmnIntermediateLink | Gets the BpmnIntermediateLink predefined shape.
BpmnIntermediateMessage | Gets the BpmnIntermediateMessage predefined shape.
BpmnIntermediateMultiple | Gets the BpmnIntermediateMultiple predefined shape.
BpmnIntermediateRule | Gets the BpmnIntermediateRule predefined shape.
BpmnIntermediateTimer | Gets the BpmnIntermediateTimer predefined shape.
BpmnParallelFork | Gets the BpmnParallelFork predefined shape.
BpmnStartLink | Gets the BpmnStartLink predefined shape.
BpmnStartMessage | Gets the BpmnStartMessage predefined shape.
BpmnStartMultiple | Gets the BpmnStartMultiple predefined shape.
BpmnStartRule | Gets the BpmnStartRule predefined shape.
BpmnStartTimer | Gets the BpmnStartTimer predefined shape.
Cloud | Gets the Cloud predefined shape.
Collate | Gets the Collate predefined shape.
ConeDown | Gets the ConeDown predefined shape.
ConeUp | Gets the ConeUp predefined shape.
ConnectedIssues | Gets the ConnectedIssues predefined shape.
CreateRequest | Gets the CreateRequest predefined shape.
Cross | Gets the Cross predefined shape.
Cube | Gets the Cube predefined shape.
Cylinder | Gets the Cylinder predefined shape.
Database | Gets the Database predefined shape.
DataTransmition | Gets the DataTransmition predefined shape.
DDelay | Gets the DDelay predefined shape.
Decagon | Gets the Decagon predefined shape.
Decision | Gets the Decision predefined shape.
Decision2 | Gets the Decision2 predefined shape.
Delay | Gets the Delay predefined shape.
DInDelay | Gets the DInDelay predefined shape.
DirectAccessStorage | Gets the DirectAccessStorage predefined shape.
DiskStorage | Gets the DiskStorage predefined shape.
Display | Gets the Display predefined shape.
DividedEvent | Gets the DividedEvent predefined shape.
DividedProcess | Gets the DividedProcess predefined shape.
Document | Gets the Document predefined shape.
Donut | Gets the Donut predefined shape.
DOutDelay | Gets the DOutDelay predefined shape.
Ellipse | Gets the Ellipse predefined shape.
EndLoop | Gets the EndLoop predefined shape.
ExternalOrganization | Gets the ExternalOrganization predefined shape.
ExternalProcess | Gets the ExternalProcess predefined shape.
File | Gets the File predefined shape.
FramedRectangle | Gets the FramedRectangle predefined shape.
Gate | Gets the Gate predefined shape.
Heart | Gets the Heart predefined shape.
Heptagon | Gets the Heptagon predefined shape.
Hourglass | Gets the Hourglass predefined shape.
Input | Gets the Input predefined shape.
InternalStorage | Gets the InternalStorage predefined shape.
Interrupt | Gets the Interrupt predefined shape.
Interrupt2 | Gets the Interrupt2 predefined shape.
IsoProcess | Gets the IsoProcess predefined shape.
Junction | Gets the Junction predefined shape.
Lightning | Gets the Lightning predefined shape.
LinedDocument | Gets the LinedDocument predefined shape.
ManualOperation | Gets the ManualOperation predefined shape.
Merge | Gets the Merge predefined shape.
MessageFromUser | Gets the MessageFromUser predefined shape.
MessageToUser | Gets the MessageToUser predefined shape.
Microform | Gets the Microform predefined shape.
MicroformProcessing | Gets the MicroformProcessing predefined shape.
MicroformRecording | Gets the MicroformRecording predefined shape.
MultiDocument | Gets the MultiDocument predefined shape.
MultiProc | Gets the MultiProc predefined shape.
Octagon | Gets the Octagon predefined shape.
OfflineStorage | Gets the OfflineStorage predefined shape.
OffpageConnection | Gets the OffpageConnection predefined shape.
OffpageReference | Gets the OffpageReference predefined shape.
Or | Gets the Or predefined shape.
Pentagon | Gets the Pentagon predefined shape.
Plaque | Gets the Plaque predefined shape.
PrimitiveFromCall | Gets the PrimitiveFromCall predefined shape.
PrimitiveToCall | Gets the PrimitiveToCall predefined shape.
Procedure | Gets the Procedure predefined shape.
Process | Gets the Process predefined shape.
Prysm | Gets the Prysm predefined shape.
PunchedCard | Gets the PunchedCard predefined shape.
PyramidDown | Gets the PyramidDown predefined shape.
PyramidUp | Gets the PyramidUp predefined shape.
Rectangle | Gets the Rectangle predefined shape.
RightTriangle | Gets the RightTriangle predefined shape.
RoundRect | Gets the RoundRect predefined shape.
RSave | Gets the RSave predefined shape.
Save | Gets the Save predefined shape.
Sort | Gets the Sort predefined shape.
Sphere | Gets the Sphere predefined shape.
Star | Gets the Star predefined shape.
Star16Pointed | Gets the Star16Pointed predefined shape.
Star24Pointed | Gets the Star24Pointed predefined shape.
Star32Pointed | Gets the Star32Pointed predefined shape.
Star4Pointed | Gets the Star4Pointed predefined shape.
Star5Pointed | Gets the Star5Pointed predefined shape.
Star6Pointed | Gets the Star6Pointed predefined shape.
Star7Pointed | Gets the Star7Pointed predefined shape.
Start | Gets the Start predefined shape.
Tape | Gets the Tape predefined shape.
Terminator | Gets the Terminator predefined shape.
TransmittalTape | Gets the TransmittalTape predefined shape.
Trapezoid | Gets the Trapezoid predefined shape.

See Also

Shapes Class


MindFusion.Diagramming.Shapes.Actor Property

Shapes.Actor Property
[image]

Gets the Actor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Actor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Actor As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Alternative Property

Shapes.Alternative Property
[image]

Gets the Alternative predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Alternative { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Alternative As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow1 Property

Shapes.Arrow1 Property
[image]

Gets the Arrow1 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow1 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow1 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow2 Property

Shapes.Arrow2 Property
[image]

Gets the Arrow2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow3 Property

Shapes.Arrow3 Property
[image]

Gets the Arrow3 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow3 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow3 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow4 Property

Shapes.Arrow4 Property
[image]

Gets the Arrow4 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow4 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow4 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow5 Property

Shapes.Arrow5 Property
[image]

Gets the Arrow5 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow5 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow5 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow6 Property

Shapes.Arrow6 Property
[image]

Gets the Arrow6 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow6 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow6 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow7 Property

Shapes.Arrow7 Property
[image]

Gets the Arrow7 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow7 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow7 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow8 Property

Shapes.Arrow8 Property
[image]

Gets the Arrow8 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow8 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow8 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Arrow9 Property

Shapes.Arrow9 Property
[image]

Gets the Arrow9 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Arrow9 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Arrow9 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BeginLoop Property

Shapes.BeginLoop Property
[image]

Gets the BeginLoop predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BeginLoop { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BeginLoop As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnComplex Property

Shapes.BpmnComplex Property
[image]

Gets the BpmnComplex predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnComplex { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnComplex As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnDataBasedXor Property

Shapes.BpmnDataBasedXor Property
[image]

Gets the BpmnDataBasedXor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnDataBasedXor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnDataBasedXor As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndCancel Property

Shapes.BpmnEndCancel Property
[image]

Gets the BpmnEndCancel predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndCancel { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndCancel As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndCompensation Property

Shapes.BpmnEndCompensation Property
[image]

Gets the BpmnEndCompensation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndCompensation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndCompensation As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndError Property

Shapes.BpmnEndError Property
[image]

Gets the BpmnEndError predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndError { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndError As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndLink Property

Shapes.BpmnEndLink Property
[image]

Gets the BpmnEndLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndLink As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndMessage Property

Shapes.BpmnEndMessage Property
[image]

Gets the BpmnEndMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndMessage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndMultiple Property

Shapes.BpmnEndMultiple Property
[image]

Gets the BpmnEndMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndMultiple As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEndTerminate Property

Shapes.BpmnEndTerminate Property
[image]

Gets the BpmnEndTerminate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEndTerminate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEndTerminate As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnEventBasedXor Property

Shapes.BpmnEventBasedXor Property
[image]

Gets the BpmnEventBasedXor predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnEventBasedXor { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnEventBasedXor As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnInclusive Property

Shapes.BpmnInclusive Property
[image]

Gets the BpmnInclusive predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnInclusive { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnInclusive As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateCancel Property

Shapes.BpmnIntermediateCancel Property
[image]

Gets the BpmnIntermediateCancel predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateCancel { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateCancel As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateCompensation Property

Shapes.BpmnIntermediateCompensation Property
[image]

Gets the BpmnIntermediateCompensation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateCompensation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateCompensation As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateError Property

Shapes.BpmnIntermediateError Property
[image]

Gets the BpmnIntermediateError predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateError { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateError As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateLink Property

Shapes.BpmnIntermediateLink Property
[image]

Gets the BpmnIntermediateLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateLink As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateMessage Property

Shapes.BpmnIntermediateMessage Property
[image]

Gets the BpmnIntermediateMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateMessage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateMultiple Property

Shapes.BpmnIntermediateMultiple Property
[image]

Gets the BpmnIntermediateMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateMultiple As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateRule Property

Shapes.BpmnIntermediateRule Property
[image]

Gets the BpmnIntermediateRule predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateRule { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateRule As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnIntermediateTimer Property

Shapes.BpmnIntermediateTimer Property
[image]

Gets the BpmnIntermediateTimer predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnIntermediateTimer { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnIntermediateTimer As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnParallelFork Property

Shapes.BpmnParallelFork Property
[image]

Gets the BpmnParallelFork predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnParallelFork { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnParallelFork As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartLink Property

Shapes.BpmnStartLink Property
[image]

Gets the BpmnStartLink predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartLink { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartLink As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartMessage Property

Shapes.BpmnStartMessage Property
[image]

Gets the BpmnStartMessage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartMessage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartMessage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartMultiple Property

Shapes.BpmnStartMultiple Property
[image]

Gets the BpmnStartMultiple predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartMultiple { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartMultiple As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartRule Property

Shapes.BpmnStartRule Property
[image]

Gets the BpmnStartRule predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartRule { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartRule As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.BpmnStartTimer Property

Shapes.BpmnStartTimer Property
[image]

Gets the BpmnStartTimer predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape BpmnStartTimer { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property BpmnStartTimer As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cloud Property

Shapes.Cloud Property
[image]

Gets the Cloud predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cloud { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cloud As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Collate Property

Shapes.Collate Property
[image]

Gets the Collate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Collate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Collate As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConeDown Property

Shapes.ConeDown Property
[image]

Gets the ConeDown predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ConeDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConeDown As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConeUp Property

Shapes.ConeUp Property
[image]

Gets the ConeUp predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ConeUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConeUp As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ConnectedIssues Property

Shapes.ConnectedIssues Property
[image]

Gets the ConnectedIssues predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ConnectedIssues { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ConnectedIssues As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.CreateRequest Property

Shapes.CreateRequest Property
[image]

Gets the CreateRequest predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape CreateRequest { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property CreateRequest As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cross Property

Shapes.Cross Property
[image]

Gets the Cross predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cross { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cross As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cube Property

Shapes.Cube Property
[image]

Gets the Cube predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cube { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cube As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Cylinder Property

Shapes.Cylinder Property
[image]

Gets the Cylinder predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Cylinder { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Cylinder As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Database Property

Shapes.Database Property
[image]

Gets the Database predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Database { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Database As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DataTransmition Property

Shapes.DataTransmition Property
[image]

Gets the DataTransmition predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DataTransmition { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DataTransmition As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DDelay Property

Shapes.DDelay Property
[image]

Gets the DDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decagon Property

Shapes.Decagon Property
[image]

Gets the Decagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Decagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decision Property

Shapes.Decision Property
[image]

Gets the Decision predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Decision { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Decision2 Property

Shapes.Decision2 Property
[image]

Gets the Decision2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Decision2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Decision2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Delay Property

Shapes.Delay Property
[image]

Gets the Delay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Delay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Delay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DInDelay Property

Shapes.DInDelay Property
[image]

Gets the DInDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DInDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DInDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DirectAccessStorage Property

Shapes.DirectAccessStorage Property
[image]

Gets the DirectAccessStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DirectAccessStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DirectAccessStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DiskStorage Property

Shapes.DiskStorage Property
[image]

Gets the DiskStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DiskStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DiskStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Display Property

Shapes.Display Property
[image]

Gets the Display predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Display { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Display As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DividedEvent Property

Shapes.DividedEvent Property
[image]

Gets the DividedEvent predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DividedEvent { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DividedEvent As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DividedProcess Property

Shapes.DividedProcess Property
[image]

Gets the DividedProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DividedProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DividedProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Document Property

Shapes.Document Property
[image]

Gets the Document predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Document { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Document As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Donut Property

Shapes.Donut Property
[image]

Gets the Donut predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Donut { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Donut As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.DOutDelay Property

Shapes.DOutDelay Property
[image]

Gets the DOutDelay predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape DOutDelay { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property DOutDelay As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Ellipse Property

Shapes.Ellipse Property
[image]

Gets the Ellipse predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Ellipse { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Ellipse As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.EndLoop Property

Shapes.EndLoop Property
[image]

Gets the EndLoop predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape EndLoop { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property EndLoop As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ExternalOrganization Property

Shapes.ExternalOrganization Property
[image]

Gets the ExternalOrganization predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ExternalOrganization { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ExternalOrganization As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ExternalProcess Property

Shapes.ExternalProcess Property
[image]

Gets the ExternalProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ExternalProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ExternalProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.File Property

Shapes.File Property
[image]

Gets the File predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape File { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property File As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.FramedRectangle Property

Shapes.FramedRectangle Property
[image]

Gets the FramedRectangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape FramedRectangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property FramedRectangle As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Gate Property

Shapes.Gate Property
[image]

Gets the Gate predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Gate { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Gate As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Heart Property

Shapes.Heart Property
[image]

Gets the Heart predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Heart { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Heart As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Heptagon Property

Shapes.Heptagon Property
[image]

Gets the Heptagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Heptagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Heptagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Hourglass Property

Shapes.Hourglass Property
[image]

Gets the Hourglass predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Hourglass { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Hourglass As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Input Property

Shapes.Input Property
[image]

Gets the Input predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Input { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Input As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.InternalStorage Property

Shapes.InternalStorage Property
[image]

Gets the InternalStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape InternalStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property InternalStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Interrupt Property

Shapes.Interrupt Property
[image]

Gets the Interrupt predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Interrupt { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Interrupt As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Interrupt2 Property

Shapes.Interrupt2 Property
[image]

Gets the Interrupt2 predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Interrupt2 { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Interrupt2 As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.IsoProcess Property

Shapes.IsoProcess Property
[image]

Gets the IsoProcess predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape IsoProcess { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property IsoProcess As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Junction Property

Shapes.Junction Property
[image]

Gets the Junction predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Junction { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Junction As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Lightning Property

Shapes.Lightning Property
[image]

Gets the Lightning predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Lightning { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Lightning As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.LinedDocument Property

Shapes.LinedDocument Property
[image]

Gets the LinedDocument predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape LinedDocument { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property LinedDocument As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.ManualOperation Property

Shapes.ManualOperation Property
[image]

Gets the ManualOperation predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape ManualOperation { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property ManualOperation As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Merge Property

Shapes.Merge Property
[image]

Gets the Merge predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Merge { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Merge As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MessageFromUser Property

Shapes.MessageFromUser Property
[image]

Gets the MessageFromUser predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MessageFromUser { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MessageFromUser As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MessageToUser Property

Shapes.MessageToUser Property
[image]

Gets the MessageToUser predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MessageToUser { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MessageToUser As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Microform Property

Shapes.Microform Property
[image]

Gets the Microform predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Microform { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Microform As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MicroformProcessing Property

Shapes.MicroformProcessing Property
[image]

Gets the MicroformProcessing predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MicroformProcessing { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MicroformProcessing As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MicroformRecording Property

Shapes.MicroformRecording Property
[image]

Gets the MicroformRecording predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MicroformRecording { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MicroformRecording As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MultiDocument Property

Shapes.MultiDocument Property
[image]

Gets the MultiDocument predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MultiDocument { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MultiDocument As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.MultiProc Property

Shapes.MultiProc Property
[image]

Gets the MultiProc predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape MultiProc { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property MultiProc As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Octagon Property

Shapes.Octagon Property
[image]

Gets the Octagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Octagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Octagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OfflineStorage Property

Shapes.OfflineStorage Property
[image]

Gets the OfflineStorage predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape OfflineStorage { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OfflineStorage As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OffpageConnection Property

Shapes.OffpageConnection Property
[image]

Gets the OffpageConnection predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape OffpageConnection { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OffpageConnection As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.OffpageReference Property

Shapes.OffpageReference Property
[image]

Gets the OffpageReference predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape OffpageReference { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property OffpageReference As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Or Property

Shapes.Or Property
[image]

Gets the Or predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Or { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Or As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Pentagon Property

Shapes.Pentagon Property
[image]

Gets the Pentagon predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Pentagon { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Pentagon As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Plaque Property

Shapes.Plaque Property
[image]

Gets the Plaque predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Plaque { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Plaque As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PrimitiveFromCall Property

Shapes.PrimitiveFromCall Property
[image]

Gets the PrimitiveFromCall predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PrimitiveFromCall { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PrimitiveFromCall As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PrimitiveToCall Property

Shapes.PrimitiveToCall Property
[image]

Gets the PrimitiveToCall predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PrimitiveToCall { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PrimitiveToCall As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Procedure Property

Shapes.Procedure Property
[image]

Gets the Procedure predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Procedure { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Procedure As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Process Property

Shapes.Process Property
[image]

Gets the Process predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Process { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Process As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Prysm Property

Shapes.Prysm Property
[image]

Gets the Prysm predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Prysm { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Prysm As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PunchedCard Property

Shapes.PunchedCard Property
[image]

Gets the PunchedCard predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PunchedCard { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PunchedCard As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PyramidDown Property

Shapes.PyramidDown Property
[image]

Gets the PyramidDown predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PyramidDown { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PyramidDown As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.PyramidUp Property

Shapes.PyramidUp Property
[image]

Gets the PyramidUp predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape PyramidUp { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property PyramidUp As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Rectangle Property

Shapes.Rectangle Property
[image]

Gets the Rectangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Rectangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Rectangle As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RightTriangle Property

Shapes.RightTriangle Property
[image]

Gets the RightTriangle predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RightTriangle { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RightTriangle As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RoundRect Property

Shapes.RoundRect Property
[image]

Gets the RoundRect predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RoundRect { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RoundRect As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.RSave Property

Shapes.RSave Property
[image]

Gets the RSave predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape RSave { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property RSave As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Save Property

Shapes.Save Property
[image]

Gets the Save predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Save { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Save As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Sort Property

Shapes.Sort Property
[image]

Gets the Sort predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Sort { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Sort As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Sphere Property

Shapes.Sphere Property
[image]

Gets the Sphere predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Sphere { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Sphere As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star Property

Shapes.Star Property
[image]

Gets the Star predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star16Pointed Property

Shapes.Star16Pointed Property
[image]

Gets the Star16Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star16Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star16Pointed As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star24Pointed Property

Shapes.Star24Pointed Property
[image]

Gets the Star24Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star24Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star24Pointed As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star32Pointed Property

Shapes.Star32Pointed Property
[image]

Gets the Star32Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star32Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star32Pointed As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star4Pointed Property

Shapes.Star4Pointed Property
[image]

Gets the Star4Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star4Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star4Pointed As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star5Pointed Property

Shapes.Star5Pointed Property
[image]

Gets the Star5Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star5Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star5Pointed As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star6Pointed Property

Shapes.Star6Pointed Property
[image]

Gets the Star6Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star6Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star6Pointed As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Star7Pointed Property

Shapes.Star7Pointed Property
[image]

Gets the Star7Pointed predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Star7Pointed { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Star7Pointed As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Start Property

Shapes.Start Property
[image]

Gets the Start predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Start { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Start As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Tape Property

Shapes.Tape Property
[image]

Gets the Tape predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Tape { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Tape As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Terminator Property

Shapes.Terminator Property
[image]

Gets the Terminator predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Terminator { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Terminator As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.TransmittalTape Property

Shapes.TransmittalTape Property
[image]

Gets the TransmittalTape predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape TransmittalTape { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property TransmittalTape As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.Shapes.Trapezoid Property

Shapes.Trapezoid Property
[image]

Gets the Trapezoid predefined shape.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static Shape Trapezoid { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property Trapezoid As Shape

Property Value

An instance of the Shape class representing the predefined shape.

See Also

Shapes Members
Shapes Class


MindFusion.Diagramming.ShowAnchors Enumeration

ShowAnchors Enumeration
[image]

Specifies when anchors points should be displayed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ShowAnchors

Visual Basic [image] Copy Code

Public Enum ShowAnchors

Members

Member name | Description
Always | Anchor point marks are always painted.
Never | Anchor point marks are never painted.
Selected | Anchor point marks are painted for the selected node.

Remarks

Members of this enumeration are used as values of the ShowAnchors property of the Diagram class.

See Also


MindFusion.Diagramming.SimpleShape Enumeration

SimpleShape Enumeration
[image]

Defines the possible values for Shape property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SimpleShape

Visual Basic [image] Copy Code

Public Enum SimpleShape

Members

Member name | Description
Rectangle | Sets table's shape to rectangle.
RoundedRectangle | Sets table's shape to rounded rectangle.

See Also


MindFusion.Diagramming.SnapToAnchor Enumeration

SnapToAnchor Enumeration
[image]

Specifies when link ends are snapped to nearest anchor points.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SnapToAnchor

Visual Basic [image] Copy Code

Public Enum SnapToAnchor

Members

Member name | Description
OnCreate | Snap to anchor point when creating a new link.
OnCreateOrModify | Snap to anchor point when creating or modifying a link.

Remarks

Members of this enumeration are used as values of the SnapToAnchor property of the Diagram class.

See Also


MindFusion.Diagramming.Style Class

Style Class
[image]

Represents an unordered dynamic collection of properties that can be identified by name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Style

Visual Basic [image] Copy Code

Public Class Style

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramStyle

See Also

Style Members


MindFusion.Diagramming.Style Members

Style Members
Constructors Methods Events
[image]

Represents an unordered dynamic collection of properties that can be identified by name.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Initializes a new instance of the Style class.

Public Methods

Name | Description
GetProperties | Gets all properties in the style.
GetProperty | Returns the property with the specified name, if any.
RegisterType | Associates a type with an alias.

Protected Methods

Name | Description
GetValue | Gets the value of the specified property.
IsPropertySet | Checks whether the specified property has a value.
LoadFromXml | Loads the style content from an XML element.
OnPropertyChanged | Raises the PropertyChanged event.
RegisterProperty | Registers a new property with the specified name and type.
SaveToXml | Saves the style content into an XML element.
SetValue | Sets the value of the specified property.
UnsetValue | Clears the value of the specified property.

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed.

See Also

Style Class


MindFusion.Diagramming.Style Constructor

Style Constructor
[image]

Initializes a new instance of the Style class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Style Class


MindFusion.Diagramming.Style Methods

Style Methods
[image]

Public Methods

Name | Description
GetProperties | Gets all properties in the style.
GetProperty | Returns the property with the specified name, if any.
RegisterType | Associates a type with an alias.

Protected Methods

Name | Description
GetValue | Gets the value of the specified property.
IsPropertySet | Checks whether the specified property has a value.
LoadFromXml | Loads the style content from an XML element.
OnPropertyChanged | Raises the PropertyChanged event.
RegisterProperty | Registers a new property with the specified name and type.
SaveToXml | Saves the style content into an XML element.
SetValue | Sets the value of the specified property.
UnsetValue | Clears the value of the specified property.

See Also

Style Class


MindFusion.Diagramming.Style.GetProperties Method

Style.GetProperties Method
[image]

Gets all properties in the style.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerable<IProperty> GetProperties ()

Visual Basic [image] Copy Code

Public Function GetProperties () As IEnumerable(Of IProperty)

Return Value

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.GetProperty Method

Style.GetProperty Method
[image]

Returns the property with the specified name, if any.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IProperty GetProperty (
string name
)

Visual Basic [image] Copy Code

Public Function GetProperty( _
name As String _
) As IProperty

Parameters

name

Return Value

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.GetValue Method

Style.GetValue Method
[image]

Gets the value of the specified property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Object GetValue (
Object property
)

Visual Basic [image] Copy Code

Protected Function GetValue( _
property As Object _
) As Object

Parameters

property

The property to get.

Return Value

The value of the property or null if the property is not defined.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.IsPropertySet Method

Style.IsPropertySet Method
[image]

Checks whether the specified property has a value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool IsPropertySet (
Object property
)

Visual Basic [image] Copy Code

Protected Function IsPropertySet( _
property As Object _
) As Boolean

Parameters

property

The property to check.

Return Value

true if the property has a local value; otherwise, false.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.LoadFromXml Method

Style.LoadFromXml Method
[image]

Loads the style content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the style's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.OnPropertyChanged Method

Style.OnPropertyChanged Method
[image]

Raises the PropertyChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnPropertyChanged (
StylePropertyChangedEventArgs e
)

Visual Basic [image] Copy Code

Protected Overridable Sub OnPropertyChanged( _
e As StylePropertyChangedEventArgs _
)

Parameters

e

An object providing the event data.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.RegisterProperty Method

Style.RegisterProperty Method
[image]

Registers a new property with the specified name and type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Object RegisterProperty (
string name
)

Visual Basic [image] Copy Code

Protected Function RegisterProperty( _
name As String _
) As Object

Parameters

name

The name of the property.

Return Value

An object that can be used to identify the property in subsequent calls to methods like SetValue and GetValue.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.RegisterType Method

Style.RegisterType Method
[image]

Associates a type with an alias.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static void RegisterType (
Type type,
string alias
)

Visual Basic [image] Copy Code

Public Shared Sub RegisterType( _
type As Type, _
alias As String _
)

Parameters

type

The type to associate.

alias

The unique alias for the type.

Remarks

The alias is used when saving and loading objects of the specified type during style serialization and deserialization.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.SaveToXml Method

Style.SaveToXml Method
[image]

Saves the style content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement the style's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.SetValue Method

Style.SetValue Method
[image]

Sets the value of the specified property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SetValue (
Object property,
Object value
)

Visual Basic [image] Copy Code

Protected Sub SetValue( _
property As Object, _
value As Object _
)

Parameters

property

The property to set.

value

The new property value.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style.UnsetValue Method

Style.UnsetValue Method
[image]

Clears the value of the specified property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void UnsetValue (
Object property
)

Visual Basic [image] Copy Code

Protected Sub UnsetValue( _
property As Object _
)

Parameters

property

The property to clear.

See Also

Style Members
Style Class


MindFusion.Diagramming.Style Events

Style Events
[image]

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed.

See Also

Style Class


MindFusion.Diagramming.Style.PropertyChanged Event

Style.PropertyChanged Event
[image]

Raised when any of the registered style properties has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<StylePropertyChangedEventArgs> PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As EventHandler(Of StylePropertyChangedEventArgs)

Event Data

PropertyChanged event handlers receive an argument of type StylePropertyChangedEventArgs.

See Also

Style Members
Style Class


MindFusion.Diagramming.StylePropertyChangedEventArgs Class

StylePropertyChangedEventArgs Class
[image]

Contains the arguments passed to handlers of the PropertyChanged event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class StylePropertyChangedEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class StylePropertyChangedEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.StylePropertyChangedEventArgs

See Also

StylePropertyChangedEventArgs Members


MindFusion.Diagramming.StylePropertyChangedEventArgs Members

StylePropertyChangedEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the PropertyChanged event.

The following tables list the members exposed by the StylePropertyChangedEventArgs type.

Public Properties

Name | Description
NewValue | Gets the new (current) value of the changed property.
OldValue | Gets the previous value of the changed property.
Property | Gets the property that has changed.

See Also

StylePropertyChangedEventArgs Class


MindFusion.Diagramming.StylePropertyChangedEventArgs Properties

StylePropertyChangedEventArgs Properties
[image]

Public Properties

Name | Description
NewValue | Gets the new (current) value of the changed property.
OldValue | Gets the previous value of the changed property.
Property | Gets the property that has changed.

See Also

StylePropertyChangedEventArgs Class


MindFusion.Diagramming.StylePropertyChangedEventArgs.NewValue Property

StylePropertyChangedEventArgs.NewValue Property
[image]

Gets the new (current) value of the changed property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object NewValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewValue As Object

Property Value

An object representing the new property value.

See Also

StylePropertyChangedEventArgs Members
StylePropertyChangedEventArgs Class


MindFusion.Diagramming.StylePropertyChangedEventArgs.OldValue Property

StylePropertyChangedEventArgs.OldValue Property
[image]

Gets the previous value of the changed property.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object OldValue { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldValue As Object

Property Value

An object representing the old property value.

See Also

StylePropertyChangedEventArgs Members
StylePropertyChangedEventArgs Class


MindFusion.Diagramming.StylePropertyChangedEventArgs.Property Property

StylePropertyChangedEventArgs.Property Property
[image]

Gets the property that has changed.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Property { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Property As Object

Property Value

An object identifying the changed property.

See Also

StylePropertyChangedEventArgs Members
StylePropertyChangedEventArgs Class


MindFusion.Diagramming.SyncScrollView Class

SyncScrollView Class
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SyncScrollView : Grid

Visual Basic [image] Copy Code

Public Class SyncScrollView
Inherits Grid

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
Microsoft.Maui.Controls.Layout
Microsoft.Maui.Controls.Grid
MindFusion.Diagramming.SyncScrollView

See Also

SyncScrollView Members


MindFusion.Diagramming.SyncScrollView Members

SyncScrollView Members
Constructors Properties Methods
[image]

The following tables list the members exposed by the SyncScrollView type.

Public Constructors

Name | Description
SyncScrollView |

Public Properties

Name | Description
Content |
ScrollX |
ScrollY |

Public Methods

Name | Description
ScrollTo |

See Also

SyncScrollView Class


MindFusion.Diagramming.SyncScrollView Constructor

SyncScrollView Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SyncScrollView ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SyncScrollView Class


MindFusion.Diagramming.SyncScrollView Methods

SyncScrollView Methods
[image]

Public Methods

Name | Description
ScrollTo |

See Also

SyncScrollView Class


MindFusion.Diagramming.SyncScrollView.ScrollTo Method

SyncScrollView.ScrollTo Method
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ScrollTo (
double x,
double y
)

Visual Basic [image] Copy Code

Public Sub ScrollTo( _
x As Double, _
y As Double _
)

Parameters

x

y

See Also

SyncScrollView Members
SyncScrollView Class


MindFusion.Diagramming.SyncScrollView Properties

SyncScrollView Properties
[image]

Public Properties

Name | Description
Content |
ScrollX |
ScrollY |

See Also

SyncScrollView Class


MindFusion.Diagramming.SyncScrollView.Content Property

SyncScrollView.Content Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public View Content { get; set; }

Visual Basic [image] Copy Code

Public Property Content As View

Property Value

See Also

SyncScrollView Members
SyncScrollView Class


MindFusion.Diagramming.SyncScrollView.ScrollX Property

SyncScrollView.ScrollX Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollX { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScrollX As Double

Property Value

See Also

SyncScrollView Members
SyncScrollView Class


MindFusion.Diagramming.SyncScrollView.ScrollY Property

SyncScrollView.ScrollY Property
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollY { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ScrollY As Double

Property Value

See Also

SyncScrollView Members
SyncScrollView Class


MindFusion.Diagramming.TableConnectionStyle Enumeration

TableConnectionStyle Enumeration
[image]

Specifies the possible values for the ConnectionStyle property of tables.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TableConnectionStyle

Visual Basic [image] Copy Code

Public Enum TableConnectionStyle

Members

Member name | Description
Both | Users are allowed to create relations both to the rows of a table or the the table as a whole.
Rows | Users are allowed to create relations to the rows of a table.
Table | Users are allowed to create relations to a table as whole entity.

Remarks

The enumeration provides possible values for the ConnectionStyle property, which specifies whether relation ends are the rows of a table or the table as a whole entity.

See Also


MindFusion.Diagramming.TableNode Class

TableNode Class
Remarks See Also
[image]

Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class TableNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

Tables in flow diagrams are represented by instances of the TableNode class. Probably the most important property of tables is ConnectionStyle, which specifies whether users are allowed to draw links to the rows of a table, to the table as an integral entity, or both.

Tables consist of Cell instances distributed across rows and columns. Number of rows and columns can be set with the RowCount and ColumnCount properties. The width of the columns is set with ColumnWidth property and the height of the rows with the RowHeight property. Cells can be made to span several rows and columns by setting their RowSpan and ColumnSpan properties to values larger than one.

Rows can be assigned to distinct sections of the table. Each section can be collapsed or expanded, hiding or showing all rows in the section except the header one. To define a section, set a Header row. A section consists of all rows after a header row and spans to the next header. Each header row displays a [±] button that allows expanding or collapsing the section interactively. The button appears either on the left of the first cell of a header row or in a separate column, as set in OffsetHeaderRows. Clicking that button raises the TableSectionCollapsed and TableSectionExpanded events. Sections can be collapsed or expanded programmatically using the Expanded property of their header rows.

The structure of a table can be dynamically changed by adding and deleting rows and columns. This can be done with the AddColumn and AddRow methods as well as with the InsertColumn, InsertRow and RedimTable methods. DeleteRow and DeleteColumn methods delete existing rows and columns.

Table cells contain Text, displayed as specified through TextBrush and TextFormat. A table can also have a caption, whose text is set by the Caption property. The height of the caption and the alignment of the text are specified by CaptionHeight and CaptionFormat properties.

To display a text box that lets users edit the table caption or the text of a cell, call the BeginEdit method of Diagram. Call EndEdit to exit the in-place editing mode. If the view's ShowContextMenu property is enabled, users can long tap over the table caption bar or a cell in order to edit their text.

The interior of tables is filled using their Brush property. The color of the table and cell borders can be set by using the Pen property. The table caption area is painted using the CaptionBackBrush brush.

In order to set an image as table's background use the Image property. The alignment of the image in relation to the table's rectangle is set through the ImageAlign property. The table can be resized to fit the size of its image by calling the ResizeToFitImage method.

The rectangle, which a table occupies, is accessible with the Bounds property. Rows and columns that build the table are stored and accessed by means of the Rows and Columns collections.

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.TableNode

See Also

TableNode Members


MindFusion.Diagramming.TableNode Members

TableNode Members
Constructors Fields Properties Methods
[image]

Tables are diagram nodes that can contain multiple cells and can be related to other nodes through their rows.

The following tables list the members exposed by the TableNode type.

Public Constructors

Name | Description
TableNode | Overloaded. Initializes a new instance of the TableNode class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the table.
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CaptionBrush | Gets or sets the brush used to paint the table caption.
CaptionFormat | Gets or sets the alignment and line position of the text used as table caption.
CaptionHeight | Gets or sets the height of the table's caption area.
CellCustomDraw | Gets or sets the type of custom drawing performed on the table cells.
CellFrameStyle | Gets or sets the style of the table cells.
CellTextBrush | Gets or sets the brush used to paint texts inside table cells.
ColumnCount | Gets or sets the number of columns in the table.
Columns | Gets a list of all columns in the table.
ColumnWidth | Gets or sets the default width of the table columns.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
CurrentScrollRow | Gets or sets the index of the first visible row in the table.
CustomDraw | Gets or sets the type of custom drawing performed on this table.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveCaptionBackBrush | Gets the effective caption back brush of the table.
EffectiveCaptionBrush | Gets the effective caption brush of the table.
EffectiveCellTextBrush | Gets the effective text brush of the table cells.
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightedRow | Gets or sets the highlighted row.
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this table.
ImageAlign | Gets or sets the alignment of the image displayed in this table.
ImagePadding | Gets or sets the padding distance between node's borders and image.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Item | Gets the Cell instance at the specified position.
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OffsetHeaderRows | Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RowAnchorPattern | Gets or sets the default anchor pattern for the rows of a table.
RowCount | Gets or sets the number of rows in the table.
RowHeight | Gets or sets the default height of table rows.
Rows | Gets a list of all rows in the table.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Scrollable | Gets or sets a value indicating whether users are allowed to scroll table rows.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the table's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | DiagramNode.HasItems override.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AddColumn | Adds new empty column at the right end of the table.
AddLabel | Overloaded. (Inherited from DiagramNode.)
AddRelation | Creates a relation with the specified table.
AddRow | Adds new empty row at the bottom of the table.
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
BreakRelation | Breaks the relation with the specified table.
CellFromPoint | Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
DeleteColumn | Deletes the column with the specified index within the table.
DeleteRow | Deletes the row at the specified position within the table.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | DiagramNode.DrawAnchors override.
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetIntersection | DiagramNode.GetIntersection override.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetSpannedCellRect | Overloaded. Calculates the bounding rectangle of the specified cell, taking in consideration the cell's row and column spans.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
InsertColumn | Inserts new empty column at the specified position within the table.
InsertRow | Inserts new empty row at the specified position within the table.
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override.
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RedimTable | Sets new number of rows and columns for this table.
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes a table as big as the image it displays.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
ScrollDown | Scrolls the table downwards.
ScrollUp | Scrolls the table upwards.
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | DiagramNode.GetAllIncomingLinks override.
GetAllOutgoingLinks | DiagramNode.GetAllOutgoingLinks override.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a table node has been clicked.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

TableNode Class


MindFusion.Diagramming.TableNode Constructor

TableNode Constructor
[image]

Initializes a new instance of the TableNode class.

Overload List

Name | Description
TableNode () | Initializes a new instance of the TableNode class.
TableNode (Diagram) | Initializes a new instance of the TableNode class.
TableNode (TableNode) | Initializes a new instance of the TableNode class using the specified node as a prototype.

See Also

TableNode Class


MindFusion.Diagramming.TableNode Constructor ()

TableNode Constructor ()
See Also
[image]

Initializes a new instance of the TableNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNode Constructor Overload List
TableNode Class


MindFusion.Diagramming.TableNode Constructor (Diagram)

TableNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the TableNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode (
Diagram parent
)

Visual Basic [image] Copy Code

Public New ( _
parent As Diagram _
)

Parameters

parent

The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the TableNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

TableNode Constructor Overload List
TableNode Class


MindFusion.Diagramming.TableNode Constructor (TableNode)

TableNode Constructor (TableNode)
See Also
[image]

Initializes a new instance of the TableNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode (
TableNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TableNode _
)

Parameters

prototype

The table node to use as a prototype. The properties of the new table are initialized from the property values of prototype.

Remarks

This constructor copies the TableNode property values from the specified prototype node.

See Also

TableNode Constructor Overload List
TableNode Class


MindFusion.Diagramming.TableNode Methods

TableNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AddColumn | Adds new empty column at the right end of the table.
AddLabel | Overloaded. (Inherited from DiagramNode.)
AddRelation | Creates a relation with the specified table.
AddRow | Adds new empty row at the bottom of the table.
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
BreakRelation | Breaks the relation with the specified table.
CellFromPoint | Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
DeleteColumn | Deletes the column with the specified index within the table.
DeleteRow | Deletes the row at the specified position within the table.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | DiagramNode.DrawAnchors override.
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Draws the shadow of this node on the specified IGraphics surface.
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetIntersection | DiagramNode.GetIntersection override.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
GetSpannedCellRect | Overloaded. Calculates the bounding rectangle of the specified cell, taking in consideration the cell's row and column spans.
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
InsertColumn | Inserts new empty column at the specified position within the table.
InsertRow | Inserts new empty row at the specified position within the table.
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override.
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RedimTable | Sets new number of rows and columns for this table.
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitImage | Makes a table as big as the image it displays.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
ScrollDown | Scrolls the table downwards.
ScrollUp | Scrolls the table upwards.
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | DiagramNode.GetAllIncomingLinks override.
GetAllOutgoingLinks | DiagramNode.GetAllOutgoingLinks override.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a table node has been clicked.
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

TableNode Class


MindFusion.Diagramming.TableNode.AcceptLinks Method

TableNode.AcceptLinks Method
[image]

DiagramNode.AcceptLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool AcceptLinks (
bool outgoing
)

Visual Basic [image] Copy Code

Public Overrides Function AcceptLinks( _
outgoing As Boolean _
) As Boolean

Parameters

outgoing

true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.AddColumn Method

TableNode.AddColumn Method
[image]

Adds new empty column at the right end of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AddColumn ()

Visual Basic [image] Copy Code

Public Function AddColumn () As Integer

Return Value

Returns the index of the newly added column within the Columns collection.

Remarks

Call the method to add new columns at the end of the table. The size of the table is automatically updated and the columns are added to the column collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.AddRelation Method

TableNode.AddRelation Method
[image]

Creates a relation with the specified table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLink AddRelation (
int row,
Relationship rel,
TableNode tableNode,
int relRow
)

Visual Basic [image] Copy Code

Public Function AddRelation( _
row As Integer, _
rel As Relationship, _
tableNode As TableNode, _
relRow As Integer _
) As DiagramLink

Parameters

row

Zero-based index of a row in this table to be related.

rel

The type of the relation (and the direction of the link).

tableNode

The other table in the relation.

relRow

Zero-based index of the row in the other table.

Return Value

A DiagramLink object representing the relation.

Remarks

Call this method to link rows of two tables.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.AddRow Method

TableNode.AddRow Method
[image]

Adds new empty row at the bottom of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int AddRow ()

Visual Basic [image] Copy Code

Public Function AddRow () As Integer

Return Value

Returns the index of the newly added row within the Rows collection.

Remarks

Call the method to add new rows at the end of the table. The size of the table is automatically updated and the rows are added to the row collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.BreakRelation Method

TableNode.BreakRelation Method
[image]

Breaks the relation with the specified table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void BreakRelation (
int row,
Relationship rel,
TableNode tableNode
)

Visual Basic [image] Copy Code

Public Sub BreakRelation( _
row As Integer, _
rel As Relationship, _
tableNode As TableNode _
)

Parameters

row

Zero-based index of a row in this table that is related to a row in another.

rel

The type of the relation (and the direction of the link).

tableNode

The other table in the relation.

Remarks

Call this method to break the link between two tables.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CellFromPoint Method

TableNode.CellFromPoint Method
[image]

Returns the row and column indices of the cell located at the specified point, taking into consideration the cells span.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CellFromPoint (
Point point,
ref int row,
ref int col
)

Visual Basic [image] Copy Code

Public Function CellFromPoint( _
point As Point, _
ByRef row As Integer, _
ByRef col As Integer _
) As Boolean

Parameters

point

The point to check.

row

Receives the row index if a cell is found at the specified position.

col

Receives the column index if a cell is found at the specified position.

Return Value

true if a cell of this table contains the specified point; otherwise, false.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CreateConnectionPoint Method

TableNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Public Overrides Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link

A DiagramLink that should be connected to this node.

pt

The point at which the link should be connected.

incoming

true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CreateProperties Method

TableNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DeleteColumn Method

TableNode.DeleteColumn Method
[image]

Deletes the column with the specified index within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DeleteColumn (
int col
)

Visual Basic [image] Copy Code

Public Sub DeleteColumn( _
col As Integer _
)

Parameters

col

The zero-based index of the column to be deleted.

Remarks

Call the method to delete a column from the table. The size of the table is automatically updated and the columns are removed from the column collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DeleteRow Method

TableNode.DeleteRow Method
[image]

Deletes the row at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void DeleteRow (
int row
)

Visual Basic [image] Copy Code

Public Sub DeleteRow( _
row As Integer _
)

Parameters

row

The zero-based index of the row to be deleted.

Remarks

Call the method to delete a row from the table. The size of the table is automatically updated and the rows are removed from the row collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DrawAnchors Method

TableNode.DrawAnchors Method
[image]

DiagramNode.DrawAnchors override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawAnchors (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawAnchors( _
graphics As IGraphics _
)

Parameters

graphics

The IGraphics object to draw the anchor points on.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DrawLocal Method

TableNode.DrawLocal Method
[image]

Draws the node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.DrawShadowLocal Method

TableNode.DrawShadowLocal Method
[image]

Draws the shadow of this node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawShadowLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawShadowLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the shadow should be rendered.

options

Provides options for the drawing operation.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetAllIncomingLinks Method

TableNode.GetAllIncomingLinks Method
[image]

DiagramNode.GetAllIncomingLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void GetAllIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overrides Sub GetAllIncomingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

An instance of the DiagramLinkCollection class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetAllOutgoingLinks Method

TableNode.GetAllOutgoingLinks Method
[image]

DiagramNode.GetAllOutgoingLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void GetAllOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overrides Sub GetAllOutgoingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

An instance of the DiagramLinkCollection class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetIntersection Method

TableNode.GetIntersection Method
[image]

DiagramNode.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point segmentStart,
Point segmentEnd
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
segmentStart As Point, _
segmentEnd As Point _
) As Point

Parameters

segmentStart

The first point of the segment.

segmentEnd

The second point of the segment.

Return Value

A Point object representing the intersection point.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetSpannedCellRect Method

TableNode.GetSpannedCellRect Method
[image]

Calculates the bounding rectangle of the specified cell, taking in consideration the cell's row and column spans.

Overload List

Name | Description
TableNode.GetSpannedCellRect (Int32, Int32) | Calculates the bounding rectangle of the cell in the specified row and column also taking in consideration the cell row and column spanning.
TableNode.GetSpannedCellRect (TableNode.Cell) | Calculates the bounding rectangle of the specified cell also taking in consideration the cell row and column spanning.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetSpannedCellRect Method (Int32, Int32)

TableNode.GetSpannedCellRect Method (Int32, Int32)
See Also
[image]

Calculates the bounding rectangle of the cell in the specified row and column also taking in consideration the cell row and column spanning.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetSpannedCellRect (
int row,
int col
)

Visual Basic [image] Copy Code

Public Function GetSpannedCellRect( _
row As Integer, _
col As Integer _
) As Rect

Parameters

row

An integer value specifying the cell's row.

col

An integer value specifying the cell's column.

Return Value

A Rectangle instance representing the cell's bounding rectangle.

See Also

GetSpannedCellRect Method Overload List
TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.GetSpannedCellRect Method (TableNode.Cell)

TableNode.GetSpannedCellRect Method (TableNode.Cell)
See Also
[image]

Calculates the bounding rectangle of the specified cell also taking in consideration the cell row and column spanning.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetSpannedCellRect (
TableNode.Cell cell
)

Visual Basic [image] Copy Code

Public Function GetSpannedCellRect( _
cell As TableNode.Cell _
) As Rect

Parameters

cell

A Cell instance.

Return Value

A Rectangle instance representing the cell's bounding rectangle.

See Also

GetSpannedCellRect Method Overload List
TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.InsertColumn Method

TableNode.InsertColumn Method
[image]

Inserts new empty column at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InsertColumn (
int col
)

Visual Basic [image] Copy Code

Public Sub InsertColumn( _
col As Integer _
)

Parameters

col

The zero-based index of the column to be inserted.

Remarks

Call the method to add new column at a given position in the table. The size of the table is automatically updated and the columns are added to the column collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.InsertRow Method

TableNode.InsertRow Method
[image]

Inserts new empty row at the specified position within the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void InsertRow (
int row
)

Visual Basic [image] Copy Code

Public Sub InsertRow( _
row As Integer _
)

Parameters

row

The zero-based index of the row to be inserted.

Remarks

Call the method to add new row at a given position in the table. The size of the table is automatically updated and the rows are added to the row collection.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.LoadFromJson Method

TableNode.LoadFromJson Method
[image]

Loads the item content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the item's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.LoadFromXml Method

TableNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OnLoad Method

TableNode.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnLoad ()

Visual Basic [image] Copy Code

Public Overrides Sub OnLoad ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OnMeasureUnitChanged Method

TableNode.OnMeasureUnitChanged Method
[image]

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OnUpdateBounds Method

TableNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

true if the size has changed; false if only the position has changed.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RaiseClicked Method

TableNode.RaiseClicked Method
[image]

Raises an event which notifies that a table node has been clicked.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RaiseClicked (
Point position,
double radius
)

Visual Basic [image] Copy Code

Protected Overrides Sub RaiseClicked( _
position As Point, _
radius As Double _
)

Parameters

position

The position of the pointer.

radius

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RedimTable Method

TableNode.RedimTable Method
[image]

Sets new number of rows and columns for this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RedimTable (
int cols,
int rows
)

Visual Basic [image] Copy Code

Public Sub RedimTable( _
cols As Integer, _
rows As Integer _
)

Parameters

cols

The new number of columns.

rows

The new number of rows.

Remarks

This method does not preserve the old contents of table cells. After its invocation all cells are empty and columns and rows are with default sizes.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ResizeToFitImage Method

TableNode.ResizeToFitImage Method
[image]

Makes a table as big as the image it displays.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitImage ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitImage ()

Remarks

Call this method to make a table exactly the same size as the image it contains. The dots-per-inch resolution of the image is considered too when calculating the new table size. You can use ImageAlign to specify position of the picture and Image to set the picture itself.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RestoreProperties Method

TableNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SaveProperties Method

TableNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SaveToJson Method

TableNode.SaveToJson Method
[image]

Saves the item content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the item's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SaveToXml Method

TableNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToXml( _
element As XElement, _
context As XmlPersistContext _
) As Task

Parameters

element

An XElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ScaleElements Method

TableNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ScrollDown Method

TableNode.ScrollDown Method
[image]

Scrolls the table downwards.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ScrollDown ()

Visual Basic [image] Copy Code

Public Sub ScrollDown ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ScrollUp Method

TableNode.ScrollUp Method
[image]

Scrolls the table upwards.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ScrollUp ()

Visual Basic [image] Copy Code

Public Sub ScrollUp ()

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.SetReflexive Method

TableNode.SetReflexive Method
[image]

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetReflexive (
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReflexive( _
link As DiagramLink _
)

Parameters

link

Reference to the link.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode Properties

TableNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the table.
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CaptionBrush | Gets or sets the brush used to paint the table caption.
CaptionFormat | Gets or sets the alignment and line position of the text used as table caption.
CaptionHeight | Gets or sets the height of the table's caption area.
CellCustomDraw | Gets or sets the type of custom drawing performed on the table cells.
CellFrameStyle | Gets or sets the style of the table cells.
CellTextBrush | Gets or sets the brush used to paint texts inside table cells.
ColumnCount | Gets or sets the number of columns in the table.
Columns | Gets a list of all columns in the table.
ColumnWidth | Gets or sets the default width of the table columns.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
CurrentScrollRow | Gets or sets the index of the first visible row in the table.
CustomDraw | Gets or sets the type of custom drawing performed on this table.
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveCaptionBackBrush | Gets the effective caption back brush of the table.
EffectiveCaptionBrush | Gets the effective caption brush of the table.
EffectiveCellTextBrush | Gets the effective text brush of the table cells.
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HighlightedRow | Gets or sets the highlighted row.
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
Image | Gets or sets the image that is displayed in this table.
ImageAlign | Gets or sets the alignment of the image displayed in this table.
ImagePadding | Gets or sets the padding distance between node's borders and image.
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Item | Gets the Cell instance at the specified position.
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OffsetHeaderRows | Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RowAnchorPattern | Gets or sets the default anchor pattern for the rows of a table.
RowCount | Gets or sets the number of rows in the table.
RowHeight | Gets or sets the default height of table rows.
Rows | Gets a list of all rows in the table.
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Scrollable | Gets or sets a value indicating whether users are allowed to scroll table rows.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the table's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | DiagramNode.HasItems override.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

TableNode Class


MindFusion.Diagramming.TableNode.Caption Property

TableNode.Caption Property
[image]

Gets or sets the text displayed as caption of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

true to let users resize columns, or false otherwise. The default value is false.

Remarks

A column can be resized by dragging its right border. If the ColumnStyle property of a column is set to AutoWidth, it is automatically reset to FixedWidth when the column is resized. Rightmost columns always fill all remaining space in their tables and cannot be resized.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CaptionBackBrush Property

TableNode.CaptionBackBrush Property
[image]

Gets or sets the brush used to paint the caption area of this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CaptionBackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBackBrush As Brush

Property Value

An instance of a Brush-derived class. The default is null.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CaptionBrush Property

TableNode.CaptionBrush Property
[image]

Gets or sets the brush used to paint the table caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CaptionBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBrush As Brush

Property Value

An instance of a Brush-derived class.

Remarks

Use the property to make table caption more distinguished.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CaptionFormat Property

TableNode.CaptionFormat Property
[image]

Gets or sets the alignment and line position of the text used as table caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat CaptionFormat { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionFormat As StringFormat

Property Value

An instance of the StringFormat class.

Remarks

Use this property to change the alignment of text or its position inside the caption area.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CaptionHeight Property

TableNode.CaptionHeight Property
[image]

Gets or sets the height of the table's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Double

Property Value

A double value specifying the height of the table caption. Initialized with the value of TableCaptionHeight.

Remarks

Keep in mind that tables are moved by clicking their captions and dragging. Don't make captions too narrow or they would become harder to move.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CellCustomDraw Property

TableNode.CellCustomDraw Property
[image]

Gets or sets the type of custom drawing performed on the table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw CellCustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CellCustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of CellCustomDraw.

Remarks

This property allows invoking custom painting code for the cells of a table. That code must execute in response to the DrawCell event. There are several modes of custom painting, allowing the custom code to paint the cell entirely, or do that in addition to what MindFusion.Diagramming for .NET MAUI paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming for .NET MAUI.
Additional | The custom painting code executes after the cell interior is painted by MindFusion.Diagramming for .NET MAUI, but before the cell's text is rendered.
Full | The component does not do any standard drawing of the cell, the entire painting is left for the application.
Additional2 | The custom painting code executes after all parts of the cell, including its text, are painted by MindFusion.Diagramming for .NET MAUI.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CellFrameStyle Property

TableNode.CellFrameStyle Property
[image]

Gets or sets the style of the table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CellFrameStyle CellFrameStyle { get; set; }

Visual Basic [image] Copy Code

Public Property CellFrameStyle As CellFrameStyle

Property Value

A member of the CellFrameStyle enumeration. Initialized with the value of CellFrameStyle.

Remarks

This property specifies whether there are borders drawn around table cells, and if yes, their appearance.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CellTextBrush Property

TableNode.CellTextBrush Property
[image]

Gets or sets the brush used to paint texts inside table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CellTextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CellTextBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ColumnCount Property

TableNode.ColumnCount Property
[image]

Gets or sets the number of columns in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnCount As Integer

Property Value

An integer value indicating the number of columns in the table.

Remarks

If you increase the number of columns the contents of the old columns will remain intact. If you decrease the number, the last columns are removed and the other remain unchanged.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Columns Property

TableNode.Columns Property
[image]

Gets a list of all columns in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.ColumnCollection Columns { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Columns As TableNode.ColumnCollection

Property Value

An instance of the ColumnCollection class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ColumnWidth Property

TableNode.ColumnWidth Property
[image]

Gets or sets the default width of the table columns.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ColumnWidth { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnWidth As Double

Property Value

A double value specifying the width of the table columns. Initialized with the value of TableColumnWidth.

Remarks

The value of this property is used to initialize the width of new columns when they are created.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ConnectionStyle Property

TableNode.ConnectionStyle Property
[image]

Gets or sets a value indicating whether drawing a link from/to this table, should connect a row of the table, or the whole table as single entity.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableConnectionStyle ConnectionStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ConnectionStyle As TableConnectionStyle

Property Value

A member of the TableConnectionStyle enumeration. Initialized with the value of TableConnectionStyle.

Remarks

There are three possible ways to relate tables to other nodes. This property specifies how users are allowed to create such relations:

  • Rows – relation ends are the rows of a table. A link connected to the table is connected to a particular row. This mode is convenient for database diagrams.
  • Table – relations target the table as a whole entity, and not any particular row. This mode is convenient for class diagrams.
  • Both – a mixed mode where links can target either a row of the table or the table itself.

Programmatically, links can be connected to a table in any way, regardless of the ConnectionStyle. ConnectionStyle value is considered only when end-users draw links to or from a table. To link to a table as an entity and not to a specific row, pass -1 as row argument of the CreateDiagramLink method.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CurrentScrollRow Property

TableNode.CurrentScrollRow Property
[image]

Gets or sets the index of the first visible row in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int CurrentScrollRow { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentScrollRow As Integer

Property Value

An integer value indicating the index of the first visible row.

Remarks

To allow users to scroll the table interactively, enable the Scrollable property.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.CustomDraw Property

TableNode.CustomDraw Property
[image]

Gets or sets the type of custom drawing performed on this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CustomDraw CustomDraw { get; set; }

Visual Basic [image] Copy Code

Public Property CustomDraw As CustomDraw

Property Value

A member of the CustomDraw enumeration. Initialized with the value of TableCustomDraw.

Remarks

This property allows invoking custom painting code for a table. That code must execute in response to the DrawNode event. There are several modes of custom painting, allowing the custom code to paint the table entirely, or do that in addition to what MindFusion.Diagramming for .NET MAUI paints by default. The following CustomDraw members can be assigned to this property to specify the custom painting mode:

Member Name | Description
None | Do not perform custom drawing, let all painting be done by MindFusion.Diagramming for .NET MAUI.
Additional | The custom painting code executes after the table interior and frame are painted by MindFusion.Diagramming for .NET MAUI, but before cells are rendered.
Full | The component does not do any standard drawing of the table frame, whose painting is left for the application. Cells are painted independently, as set in CellCustomDraw.
ShadowOnly | Only the shadow of the table is painted by custom code, the table itself is drawn by the component.
Additional2 | The custom painting code executes after all parts of the table, including its cells, are painted by MindFusion.Diagramming for .NET MAUI.

This property doesn't affect the painting of table cells. Table cells can be custom painted in the DrawCell event as set in CellCustomDraw.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.EffectiveCaptionBackBrush Property

TableNode.EffectiveCaptionBackBrush Property
[image]

Gets the effective caption back brush of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveCaptionBackBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveCaptionBackBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.EffectiveCaptionBrush Property

TableNode.EffectiveCaptionBrush Property
[image]

Gets the effective caption brush of the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveCaptionBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveCaptionBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.EffectiveCellTextBrush Property

TableNode.EffectiveCellTextBrush Property
[image]

Gets the effective text brush of the table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush EffectiveCellTextBrush { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property EffectiveCellTextBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.HasItems Property

TableNode.HasItems Property
[image]

DiagramNode.HasItems override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool HasItems { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property HasItems As Boolean

Property Value

A boolean value.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.HighlightedRow Property

TableNode.HighlightedRow Property
[image]

Gets or sets the highlighted row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int HighlightedRow { get; set; }

Visual Basic [image] Copy Code

Public Property HighlightedRow As Integer

Property Value

An integer value.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Image Property

TableNode.Image Property
[image]

Gets or sets the image that is displayed in this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the ImageSource class.

Remarks

Use the property to customize your table's background. Further customization can be done with the ImageAlign property.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ImageAlign Property

TableNode.ImageAlign Property
[image]

Gets or sets the alignment of the image displayed in this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageAlignment ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlignment

Property Value

A member of the ImageAlignment enumeration. The default value is Fit.

Remarks

This property specifies how images are positioned inside tables.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.ImagePadding Property

TableNode.ImagePadding Property
[image]

Gets or sets the padding distance between node's borders and image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Thickness> ImagePadding { get; set; }

Visual Basic [image] Copy Code

Public Property ImagePadding As Nullable(Of Thickness)

Property Value

An optional Thickness instance.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Item Property

TableNode.Item Property
[image]

Gets the Cell instance at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Item [
int col,
int row
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
col As Integer, _
row As Integer _
) As TableNode.Cell

Parameters

col

The zero-based index of the cell's column.

row

The zero-based index of the cell's row.

Property Value

An instance of the Cell class that represents the cell of the table at the specified position.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.OffsetHeaderRows Property

TableNode.OffsetHeaderRows Property
[image]

Gets or sets a value indicating whether the table cells are offset to the right to accommodate for the expand buttons of Header rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool OffsetHeaderRows { get; set; }

Visual Basic [image] Copy Code

Public Property OffsetHeaderRows As Boolean

Property Value

true to offset table cells when there are header rows defined; otherwise, false. The default is false.

Remarks

If this property is set to false, the [±] buttons used to expand or collapse table sections are drawn inside the first cell of each header row. Otherwise, the buttons are drawn in their own column in front of the table's first column of cells.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RowAnchorPattern Property

TableNode.RowAnchorPattern Property
[image]

Gets or sets the default anchor pattern for the rows of a table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern RowAnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property RowAnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class. The default is null.

Remarks

Defines a default value for the AnchorPattern property of the rows of a table.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RowCount Property

TableNode.RowCount Property
[image]

Gets or sets the number of rows in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RowCount { get; set; }

Visual Basic [image] Copy Code

Public Property RowCount As Integer

Property Value

An integer value specifying the number of rows in the table.

Remarks

If you increase the number of rows the content of the initial rows will remain intact. If you decrease the number, the last rows are removed and the other remain unchanged.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.RowHeight Property

TableNode.RowHeight Property
[image]

Gets or sets the default height of table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RowHeight { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeight As Double

Property Value

A double value specifying the height of the table rows. Initialized with the value of TableRowHeight.

Remarks

The value of this property is used to initialize the height of new rows when they are created.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Rows Property

TableNode.Rows Property
[image]

Gets a list of all rows in the table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.RowCollection Rows { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Rows As TableNode.RowCollection

Property Value

An instance of the RowCollection class.

Remarks

The property refers to the collection of all rows that compose the table. Do not add or remove rows through this collection, but use the table's AddRow, InsertRow or DeleteRow methods.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Scrollable Property

TableNode.Scrollable Property
[image]

Gets or sets a value indicating whether users are allowed to scroll table rows.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Scrollable { get; set; }

Visual Basic [image] Copy Code

Public Property Scrollable As Boolean

Property Value

true to allow scrolling the table up or down; otherwise, false. Initialized with the value of TablesScrollable.

Remarks

A button containing up and down arrows appears in the caption area of a table for which scrolling is enabled. If a user clicks these arrows, table rows scroll up or down. The table can always be scrolled programmatically using the CurrentScrollRow property.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Shape Property

TableNode.Shape Property
[image]

Gets or sets the shape of the table's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As SimpleShape

Property Value

A member of the SimpleShape enumeration. Initialized with the value of TableShape.

See Also

TableNode Members
TableNode Class


MindFusion.Diagramming.TableNode.Cell Class

TableNode.Cell Class
Remarks See Also
[image]

Represents a cell in a TableNode instance.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.Cell : InplaceEditable

Visual Basic [image] Copy Code

Public Class TableNode.Cell
Implements InplaceEditable

Remarks

Cells are the building blocks of tables. They get their height and width indirectly, from the width of table columns and the height of table rows as set by the ColumnWidth and RowHeight properties. Cells can be made to span several rows and columns by setting their RowSpan and ColumnSpan properties to values larger than 1.

Cells can hold text, which is set by their Text property. The text can be aligned and this is set by the TextFormat property. Color of the text in the cells is set with the TextBrush property.

Appearance of a cell can be customized further by the Brush and Image properties.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TableNode.Cell

See Also

TableNode.Cell Members


MindFusion.Diagramming.TableNode.Cell Members

TableNode.Cell Members
Constructors Properties Methods
[image]

Represents a cell in a TableNode instance.

The following tables list the members exposed by the TableNode.Cell type.

Public Constructors

Name | Description
TableNode.Cell | Initializes a new instance of the TableNode.Cell class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill this cell.
ColumnSpan | Gets or sets how many columns the cell should span.
Font | Gets or sets the font used to draw text inside this cell.
HyperLink | Gets or sets the hyperlink associated with the cell.
Image | Gets or sets the image that is displayed in this cell.
ImageAlign | Gets or sets the alignment of the image displayed in this cell.
ImagePadding | Gets or sets the padding distance between cell's borders and image.
RowSpan | Gets or sets how many rows the cell should span.
Table | Gets a reference to the TableNode containing this cell.
Tag | Gets or sets custom data associated with this cell.
Text | Gets or sets text displayed inside the cell.
TextBrush | Gets or sets the brush used to paint the text of the cell.
TextFormat | Gets or sets the alignment of the text that is displayed inside the cell.

Public Methods

Name | Description
Clone | Creates a copy of this cell.

Protected Methods

Name | Description
LoadFromJson | Loads the cell content from a JsonObject.
LoadFromXml | Loads the cell content from an XML element.
SaveToJson | Saves the cell content into a JsonObject.
SaveToXml | Saves the cell content into an XML element.

See Also

TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell Constructor

TableNode.Cell Constructor
[image]

Initializes a new instance of the TableNode.Cell class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell (
TableNode table
)

Visual Basic [image] Copy Code

Public New ( _
table As TableNode _
)

Parameters

table

The TableNode this cell belongs to.

See Also

TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell Methods

TableNode.Cell Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this cell.

Protected Methods

Name | Description
LoadFromJson | Loads the cell content from a JsonObject.
LoadFromXml | Loads the cell content from an XML element.
SaveToJson | Saves the cell content into a JsonObject.
SaveToXml | Saves the cell content into an XML element.

See Also

TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Clone Method

TableNode.Cell.Clone Method
[image]

Creates a copy of this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Cell Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.Cell

Return Value

An instance of the TableNode.Cell class.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.LoadFromJson Method

TableNode.Cell.LoadFromJson Method
[image]

Loads the cell content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the cell's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.LoadFromXml Method

TableNode.Cell.LoadFromXml Method
[image]

Loads the cell content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the cell's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.SaveToJson Method

TableNode.Cell.SaveToJson Method
[image]

Saves the cell content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the cell's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.SaveToXml Method

TableNode.Cell.SaveToXml Method
[image]

Saves the cell content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Task SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Function SaveToXml( _
element As XElement, _
context As XmlPersistContext _
) As Task

Parameters

element

An XElement the cell's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell Properties

TableNode.Cell Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill this cell.
ColumnSpan | Gets or sets how many columns the cell should span.
Font | Gets or sets the font used to draw text inside this cell.
HyperLink | Gets or sets the hyperlink associated with the cell.
Image | Gets or sets the image that is displayed in this cell.
ImageAlign | Gets or sets the alignment of the image displayed in this cell.
ImagePadding | Gets or sets the padding distance between cell's borders and image.
RowSpan | Gets or sets how many rows the cell should span.
Table | Gets a reference to the TableNode containing this cell.
Tag | Gets or sets custom data associated with this cell.
Text | Gets or sets text displayed inside the cell.
TextBrush | Gets or sets the brush used to paint the text of the cell.
TextFormat | Gets or sets the alignment of the text that is displayed inside the cell.

See Also

TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Brush Property

TableNode.Cell.Brush Property
[image]

Gets or sets the brush used to fill this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of a Brush-derived class. The default is null.

Remarks

This property refers to a brush used to paint the cell's interior. You can assign to it an instance of one of the following classes: HatchBrush, LinearGradientBrush, PathGradientBrush, or SolidBrush, located in the MindFusion.Drawing namespace. If the default null value is used, the cell's interior is painted with the table's Brush instead of cell's one.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.ColumnSpan Property

TableNode.Cell.ColumnSpan Property
[image]

Gets or sets how many columns the cell should span.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ColumnSpan { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnSpan As Integer

Property Value

A positive integer value specifying how many columns the cell spans to the right. The default is 1.

Remarks

Use this property and RowSpan to define a cell that overlaps several columns and rows of the table's grid. The spanning cell covers any non-spanning cells to the right or below it, as far as the spanned columns and rows go. The Image and Text of spanning cells are aligned and laid out inside the enlarged bounding rectangles of the cells. That allows composing nodes with a very elaborate structure using spanning cells, as alternative to attaching ShapeNode objects to a container/master node.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Font Property

TableNode.Cell.Font Property
[image]

Gets or sets the font used to draw text inside this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Font> Font { get; set; }

Visual Basic [image] Copy Code

Public Property Font As Nullable(Of Font)

Property Value

A Font used to render the cell's Text, or null if the text should be rendered using the table's Font.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.HyperLink Property

TableNode.Cell.HyperLink Property
[image]

Gets or sets the hyperlink associated with the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string HyperLink { get; set; }

Visual Basic [image] Copy Code

Public Property HyperLink As String

Property Value

A string value containing the hyperlink URL.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Image Property

TableNode.Cell.Image Property
[image]

Gets or sets the image that is displayed in this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the ImageSource class. The default is null.

Remarks

Use this property to set an image to be displayed in the cell. Use the ImageAlign property to specify how the image is placed.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.ImageAlign Property

TableNode.Cell.ImageAlign Property
[image]

Gets or sets the alignment of the image displayed in this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageAlignment ImageAlign { get; set; }

Visual Basic [image] Copy Code

Public Property ImageAlign As ImageAlignment

Property Value

A member of the ImageAlignment enumeration.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.ImagePadding Property

TableNode.Cell.ImagePadding Property
[image]

Gets or sets the padding distance between cell's borders and image.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Thickness> ImagePadding { get; set; }

Visual Basic [image] Copy Code

Public Property ImagePadding As Nullable(Of Thickness)

Property Value

An optional Thickness instance.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.RowSpan Property

TableNode.Cell.RowSpan Property
[image]

Gets or sets how many rows the cell should span.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RowSpan { get; set; }

Visual Basic [image] Copy Code

Public Property RowSpan As Integer

Property Value

A positive integer value specifying how many rows the cell spans downwards. The default is 1.

Remarks

Use this property and ColumnSpan to define a cell that overlaps several columns and rows of the table's grid. The spanning cell covers any non-spanning cells to the right or below it, as far as the spanned columns and rows go. The Image and Text displayed in spanning cells are aligned and laid out inside the enlarged bounding rectangles of the cells. That allows composing nodes with a very elaborate structure using spanning cells, as an alternative to attaching ShapeNode objects to a container/master node.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Table Property

TableNode.Cell.Table Property
[image]

Gets a reference to the TableNode containing this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

An instance of the TableNode class representing the table containing this cell.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Tag Property

TableNode.Cell.Tag Property
[image]

Gets or sets custom data associated with this cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default value is null.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.Text Property

TableNode.Cell.Text Property
[image]

Gets or sets text displayed inside the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Text { get; set; }

Visual Basic [image] Copy Code

Public Property Text As String

Property Value

A string value containing the text. The default is an empty string.

Remarks

The property specifies text that appears inside a cell. Text can be customized via the TextBrush and TextFormat properties.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.TextBrush Property

TableNode.Cell.TextBrush Property
[image]

Gets or sets the brush used to paint the text of the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush TextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property TextBrush As Brush

Property Value

An instance of a Brush-derived class. The default is null.

Remarks

The Text of the cell is painted with this brush. However, if the property is set to the default null value, the table's CellTextBrush property is used instead of the cell's one.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.Cell.TextFormat Property

TableNode.Cell.TextFormat Property
[image]

Gets or sets the alignment of the text that is displayed inside the cell.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the StringFormat class.

Remarks

Use this property to specify the alignment of the text that is contained in cells.

See Also

TableNode.Cell Members
TableNode.Cell Class


MindFusion.Diagramming.TableNode.CellCollection Class

TableNode.CellCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of TableNode.Cell objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.CellCollection : List<TableNode.Cell>

Visual Basic [image] Copy Code

Public Class TableNode.CellCollection
Inherits List(Of TableNode.Cell)

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove cells from a table, use the AddRow, AddColumn, InsertRow, InsertColumn, DeleteRow, DeleteColumn and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(TableNode.Cell)
MindFusion.Diagramming.TableNode.CellCollection

See Also

TableNode.CellCollection Members


MindFusion.Diagramming.TableNode.CellCollection Members

TableNode.CellCollection Members
Constructors Methods
[image]

Represents a strongly-typed collection of TableNode.Cell objects.

The following tables list the members exposed by the TableNode.CellCollection type.

Public Constructors

Name | Description
TableNode.CellCollection | Overloaded. Initializes a new instance of the CellCollection class.

Public Methods

Name | Description
Clone | Creates a deep copy of this collection.

See Also

TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection Constructor

TableNode.CellCollection Constructor
[image]

Initializes a new instance of the CellCollection class.

Overload List

Name | Description
TableNode.CellCollection () | Initializes a new instance of the CellCollection class.
TableNode.CellCollection (IEnumerable(TableNode.Cell)) | Initializes a new instance of the CellCollection class.

See Also

TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection Constructor ()

TableNode.CellCollection Constructor ()
See Also
[image]

Initializes a new instance of the CellCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.CellCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNode.CellCollection Constructor Overload List
TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection Constructor (IEnumerable(TableNode.Cell))

TableNode.CellCollection Constructor (IEnumerable(TableNode.Cell))
See Also
[image]

Initializes a new instance of the CellCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.CellCollection (
IEnumerable<TableNode.Cell> collection
)

Visual Basic [image] Copy Code

Public New ( _
collection As IEnumerable(Of TableNode.Cell) _
)

Parameters

collection

See Also

TableNode.CellCollection Constructor Overload List
TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection Methods

TableNode.CellCollection Methods
[image]

Public Methods

Name | Description
Clone | Creates a deep copy of this collection.

See Also

TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.CellCollection.Clone Method

TableNode.CellCollection.Clone Method
[image]

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.CellCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.CellCollection

Return Value

An instance of the TableNode.CellCollection class.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

TableNode.CellCollection Members
TableNode.CellCollection Class


MindFusion.Diagramming.TableNode.Column Class

TableNode.Column Class
Remarks See Also
[image]

Represents a column of a TableNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.Column

Visual Basic [image] Copy Code

Public Class TableNode.Column

Remarks

The width of a column can be set via its Width property. The width of a column determines the width of all cells contained within the column.

When resizing a table, its columns can be resized too. That depends on the value of ColumnStyle, which specifies whether columns are with fixed width or they resize to keep column-to-table width ratio.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TableNode.Column

See Also

TableNode.Column Members


MindFusion.Diagramming.TableNode.Column Members

TableNode.Column Members
Constructors Properties Methods
[image]

Represents a column of a TableNode.

The following tables list the members exposed by the TableNode.Column type.

Public Constructors

Name | Description
TableNode.Column | Initializes a new instance of the TableNode.Column class.

Public Properties

Name | Description
ColumnStyle | Gets or sets the manner in which column's width is set.
Width | Gets or sets the width of the table column.

Public Methods

Name | Description
Clone | Creates a copy of this column.

Protected Methods

Name | Description
LoadFromJson | Loads the column properties from a JsonObject.
LoadFromXml | Loads the column properties from an XML element.
SaveToJson | Saves the column properties into a JsonObject.
SaveToXml | Saves the column properties into an XML element.

See Also

TableNode.Column Class


MindFusion.Diagramming.TableNode.Column Constructor

TableNode.Column Constructor
[image]

Initializes a new instance of the TableNode.Column class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Column (
TableNode tableNode
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode _
)

Parameters

tableNode

The TableNode this column belongs to.

See Also

TableNode.Column Class


MindFusion.Diagramming.TableNode.Column Methods

TableNode.Column Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this column.

Protected Methods

Name | Description
LoadFromJson | Loads the column properties from a JsonObject.
LoadFromXml | Loads the column properties from an XML element.
SaveToJson | Saves the column properties into a JsonObject.
SaveToXml | Saves the column properties into an XML element.

See Also

TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.Clone Method

TableNode.Column.Clone Method
[image]

Creates a copy of this column.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Column Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.Column

Return Value

An instance of the TableNode.Column class.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.LoadFromJson Method

TableNode.Column.LoadFromJson Method
[image]

Loads the column properties from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the column's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.LoadFromXml Method

TableNode.Column.LoadFromXml Method
[image]

Loads the column properties from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the column's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.SaveToJson Method

TableNode.Column.SaveToJson Method
[image]

Saves the column properties into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject the column's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.SaveToXml Method

TableNode.Column.SaveToXml Method
[image]

Saves the column properties into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement the column's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.Column Properties

TableNode.Column Properties
[image]

Public Properties

Name | Description
ColumnStyle | Gets or sets the manner in which column's width is set.
Width | Gets or sets the width of the table column.

See Also

TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.ColumnStyle Property

TableNode.Column.ColumnStyle Property
[image]

Gets or sets the manner in which column's width is set.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ColumnStyle ColumnStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnStyle As ColumnStyle

Property Value

An instance of the ColumnStyle enumeration.

Remarks

This property is used for calculating the width of a table column. The column can have either a fixed width set through the Width property, or can be resized proportionally to the table width.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.Column.Width Property

TableNode.Column.Width Property
[image]

Gets or sets the width of the table column.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value indicating the width of the column. The default is 50.

See Also

TableNode.Column Members
TableNode.Column Class


MindFusion.Diagramming.TableNode.ColumnCollection Class

TableNode.ColumnCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of TableNode.Column objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.ColumnCollection : List<TableNode.Column>

Visual Basic [image] Copy Code

Public Class TableNode.ColumnCollection
Inherits List(Of TableNode.Column)

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove columns from a table, use the AddColumn, InsertColumn, DeleteColumn and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(TableNode.Column)
MindFusion.Diagramming.TableNode.ColumnCollection

See Also

TableNode.ColumnCollection Members


MindFusion.Diagramming.TableNode.ColumnCollection Members

TableNode.ColumnCollection Members
Constructors Methods
[image]

Represents a strongly-typed collection of TableNode.Column objects.

The following tables list the members exposed by the TableNode.ColumnCollection type.

Public Constructors

Name | Description
TableNode.ColumnCollection | Overloaded. Initializes a new instance of the ColumnCollection class.

Public Methods

Name | Description
Clone | Creates a deep copy of this collection.

See Also

TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection Constructor

TableNode.ColumnCollection Constructor
[image]

Initializes a new instance of the ColumnCollection class.

Overload List

Name | Description
TableNode.ColumnCollection () | Initializes a new instance of the ColumnCollection class.
TableNode.ColumnCollection (IEnumerable(TableNode.Column)) | Initializes a new instance of the ColumnCollection class.

See Also

TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection Constructor ()

TableNode.ColumnCollection Constructor ()
See Also
[image]

Initializes a new instance of the ColumnCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.ColumnCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNode.ColumnCollection Constructor Overload List
TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection Constructor (IEnumerable(TableNode.Column))

TableNode.ColumnCollection Constructor (IEnumerable(TableNode.Column))
See Also
[image]

Initializes a new instance of the ColumnCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.ColumnCollection (
IEnumerable<TableNode.Column> collection
)

Visual Basic [image] Copy Code

Public New ( _
collection As IEnumerable(Of TableNode.Column) _
)

Parameters

collection

See Also

TableNode.ColumnCollection Constructor Overload List
TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection Methods

TableNode.ColumnCollection Methods
[image]

Public Methods

Name | Description
Clone | Creates a deep copy of this collection.

See Also

TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.ColumnCollection.Clone Method

TableNode.ColumnCollection.Clone Method
[image]

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.ColumnCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.ColumnCollection

Return Value

An instance of the TableNode.ColumnCollection class.

Remarks

This method supports the MindFusion.Diagramming for .NET MAUI infrastructure and is not intended to be used directly from your code.

See Also

TableNode.ColumnCollection Members
TableNode.ColumnCollection Class


MindFusion.Diagramming.TableNode.Row Class

TableNode.Row Class
Remarks See Also
[image]

Represents a row in TableNode node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.Row

Visual Basic [image] Copy Code

Public Class TableNode.Row

Remarks

Table rows can be assigned to distinct sections of a table. For example, sections could contain rows representing different types of class members in class diagrams, there could be one section displaying the methods, another one for the events and one more for the properties of a class. Each section can be collapsed or expanded, hiding or showing all rows in the section except the header one. To define a section, set a Header row. A section consists of all rows after a header row and spans to the next header. Each header row displays a [±] button that allows expanding or collapsing the section interactively. Sections can be collapsed and expanded programmatically using the Expanded property of the header row.

The height of a row is set via the Height property. That determines the height of all non-spanning cells contained within the row. Cells can be made to span several rows by setting their RowSpan property.

Rows can be bound together to represent relationship between database tables. The relationship can be one to many and many to one. The tables that stay on the left side of M:1 relationships are stored in the RelatedManyToOne collection; the tables in 1:M relationship with the row are stored in the RelatedOneToMany collection.

The relationship between tables is shown with links. You can access the DiagramLink elements that go out of a table row via the OutgoingLinks property. Links that come into a given row can be accessed with the IncomingLinks property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TableNode.Row

See Also

TableNode.Row Members


MindFusion.Diagramming.TableNode.Row Members

TableNode.Row Members
Constructors Properties Methods
[image]

Represents a row in TableNode node.

The following tables list the members exposed by the TableNode.Row type.

Public Constructors

Name | Description
TableNode.Row | Initializes a new instance of the Row class.

Public Properties

Name | Description
AnchorPattern | Gets or sets a set of anchor points to which links can dock when connected to this row.
Expanded | Gets or sets a value indicating whether the table section starting from this Header row is collapsed or expanded.
Header | Gets or sets a value indicating whether this row is a section header.
Height | Gets or sets the height of the table row.
IncomingLinks | Gets a collection of all links that point to this table row.
OutgoingLinks | Gets a collection of all links that go out of this table row.
RelatedManyToOne | Gets a collection of all tables that are in many-to-one relation with this table row.
RelatedOneToMany | Gets a collection of all tables that are in one-to-many relation with this table row.
Table | Gets the TableNode that contains this row.

Public Methods

Name | Description
Clone | Creates a copy of this row.

Protected Methods

Name | Description
LoadFromJson | Loads the row properties from a JsonObject.
LoadFromXml | Loads the row properties from an XML element.
SaveToJson | Saves the row properties into a JsonObject.
SaveToXml | Saves the row properties into an XML element.

See Also

TableNode.Row Class


MindFusion.Diagramming.TableNode.Row Constructor

TableNode.Row Constructor
[image]

Initializes a new instance of the Row class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Row (
TableNode table
)

Visual Basic [image] Copy Code

Public New ( _
table As TableNode _
)

Parameters

table

The TableNode this row belongs to.

See Also

TableNode.Row Class


MindFusion.Diagramming.TableNode.Row Methods

TableNode.Row Methods
[image]

Public Methods

Name | Description
Clone | Creates a copy of this row.

Protected Methods

Name | Description
LoadFromJson | Loads the row properties from a JsonObject.
LoadFromXml | Loads the row properties from an XML element.
SaveToJson | Saves the row properties into a JsonObject.
SaveToXml | Saves the row properties into an XML element.

See Also

TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.Clone Method

TableNode.Row.Clone Method
[image]

Creates a copy of this row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.Row Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.Row

Return Value

An instance of the TableNode.Row class.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.LoadFromJson Method

TableNode.Row.LoadFromJson Method
[image]

Loads the row properties from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the row's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.LoadFromXml Method

TableNode.Row.LoadFromXml Method
[image]

Loads the row properties from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the row's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.SaveToJson Method

TableNode.Row.SaveToJson Method
[image]

Saves the row properties into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject the row's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.SaveToXml Method

TableNode.Row.SaveToXml Method
[image]

Saves the row properties into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected void SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Sub SaveToXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement the row's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row Properties

TableNode.Row Properties
[image]

Public Properties

Name | Description
AnchorPattern | Gets or sets a set of anchor points to which links can dock when connected to this row.
Expanded | Gets or sets a value indicating whether the table section starting from this Header row is collapsed or expanded.
Header | Gets or sets a value indicating whether this row is a section header.
Height | Gets or sets the height of the table row.
IncomingLinks | Gets a collection of all links that point to this table row.
OutgoingLinks | Gets a collection of all links that go out of this table row.
RelatedManyToOne | Gets a collection of all tables that are in many-to-one relation with this table row.
RelatedOneToMany | Gets a collection of all tables that are in one-to-many relation with this table row.
Table | Gets the TableNode that contains this row.

See Also

TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.AnchorPattern Property

TableNode.Row.AnchorPattern Property
[image]

Gets or sets a set of anchor points to which links can dock when connected to this row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern AnchorPattern { get; set; }

Visual Basic [image] Copy Code

Public Property AnchorPattern As AnchorPattern

Property Value

An instance of the AnchorPattern class.

Remarks

AnchorPattern defines a set of locations where links connected to a row are allowed to connect. When a link is connected to a row, the respective end of the link is aligned to the nearest AnchorPoint assigned to that row. If a row does not have associated anchor points of the appropriate type (incoming/outgoing), the link will be connected to the nearest row that has such anchors defined. If none of the rows of a table has an associated anchor pattern, links are connected to the middle of the left or right side of the pointed row.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.Expanded Property

TableNode.Row.Expanded Property
[image]

Gets or sets a value indicating whether the table section starting from this Header row is collapsed or expanded.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Property Expanded As Boolean

Property Value

true if the table section that starts from this row is expanded; otherwise, false. The default is true.

Remarks

This property can be set only if the row is a Header. Links connected to the rows of a collapsed table section appear to be connected to the section header row.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.Header Property

TableNode.Row.Header Property
[image]

Gets or sets a value indicating whether this row is a section header.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As Boolean

Property Value

true if this is the header row of a table section, otherwise false. The default is false.

Remarks

Each header row defines a section of the table that includes all non-header rows after the header. Such sections can be expanded or collapsed, that is, the rows included in them can be shown or hidden. This can be done interactively by pressing the [±] button displayed in header rows, or programmatically by setting the Expanded property. The TableSectionCollapsed and TableSectionExpanded events are raised when a user clicks the [±] button.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.Height Property

TableNode.Row.Height Property
[image]

Gets or sets the height of the table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

A double value indicating the height of the row. The default is 22.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.IncomingLinks Property

TableNode.Row.IncomingLinks Property
[image]

Gets a collection of all links that point to this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

A DiagramLinkCollection containing references to the incoming links.

Remarks

The property returns a collection of all links that point to this table row. Use it to access the links or get their number.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.OutgoingLinks Property

TableNode.Row.OutgoingLinks Property
[image]

Gets a collection of all links that go out of this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

A DiagramLinkCollection containing references to the outgoing links.

Remarks

The property returns a collection of all links that start from this table row. Use it to access the links or get their number.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.RelatedManyToOne Property

TableNode.Row.RelatedManyToOne Property
[image]

Gets a collection of all tables that are in many-to-one relation with this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection RelatedManyToOne { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RelatedManyToOne As DiagramNodeCollection

Property Value

A DiagramNodeCollection containing references to the TableNode objects, which are in relation M:1 with this row.

Remarks

When working with database diagrams, use this property to find all tables which are in M:1 relation with this row.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.RelatedOneToMany Property

TableNode.Row.RelatedOneToMany Property
[image]

Gets a collection of all tables that are in one-to-many relation with this table row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection RelatedOneToMany { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RelatedOneToMany As DiagramNodeCollection

Property Value

A DiagramNodeCollection containing references to the TableNode objects, which are in relation 1:M with this row.

Remarks

When working with database diagrams, use this property to find all tables which are in 1:M relation with this row.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.Row.Table Property

TableNode.Row.Table Property
[image]

Gets the TableNode that contains this row.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode Table { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Table As TableNode

Property Value

A TableNode instance.

See Also

TableNode.Row Members
TableNode.Row Class


MindFusion.Diagramming.TableNode.RowCollection Class

TableNode.RowCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of TableNode.Row objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNode.RowCollection : List<TableNode.Row>

Visual Basic [image] Copy Code

Public Class TableNode.RowCollection
Inherits List(Of TableNode.Row)

Remarks

Do not use the methods and properties of this class to modify the contents of this collection directly. If you want to add or remove rows from a table, use the AddRow, InsertRow, DeleteRow and RedimTable methods of the TableNode class instead.

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(TableNode.Row)
MindFusion.Diagramming.TableNode.RowCollection

See Also

TableNode.RowCollection Members


MindFusion.Diagramming.TableNode.RowCollection Members

TableNode.RowCollection Members
Constructors Methods
[image]

Represents a strongly-typed collection of TableNode.Row objects.

The following tables list the members exposed by the TableNode.RowCollection type.

Public Constructors

Name | Description
TableNode.RowCollection | Overloaded. Initializes a new instance of the RowCollection class.

Public Methods

Name | Description
Clone | Creates a deep copy of this collection.

See Also

TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection Constructor

TableNode.RowCollection Constructor
[image]

Initializes a new instance of the RowCollection class.

Overload List

Name | Description
TableNode.RowCollection () | Initializes a new instance of the RowCollection class.
TableNode.RowCollection (IEnumerable(TableNode.Row)) | Initializes a new instance of the RowCollection class.

See Also

TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection Constructor ()

TableNode.RowCollection Constructor ()
See Also
[image]

Initializes a new instance of the RowCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.RowCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNode.RowCollection Constructor Overload List
TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection Constructor (IEnumerable(TableNode.Row))

TableNode.RowCollection Constructor (IEnumerable(TableNode.Row))
See Also
[image]

Initializes a new instance of the RowCollection class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.RowCollection (
IEnumerable<TableNode.Row> collection
)

Visual Basic [image] Copy Code

Public New ( _
collection As IEnumerable(Of TableNode.Row) _
)

Parameters

collection

See Also

TableNode.RowCollection Constructor Overload List
TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection Methods

TableNode.RowCollection Methods
[image]

Public Methods

Name | Description
Clone | Creates a deep copy of this collection.

See Also

TableNode.RowCollection Class


MindFusion.Diagramming.TableNode.RowCollection.Clone Method

TableNode.RowCollection.Clone Method
[image]

Creates a deep copy of this collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode.RowCollection Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As TableNode.RowCollection

Return Value

An instance of the TableNode.RowCollection class.

See Also

TableNode.RowCollection Members
TableNode.RowCollection Class


MindFusion.Diagramming.TableNodeProperties Class

TableNodeProperties Class
Remarks See Also
[image]

Stores the values of TableNode properties during undo / redo operations.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNodeProperties : DiagramNodeProperties

Visual Basic [image] Copy Code

Public Class TableNodeProperties
Inherits DiagramNodeProperties

Remarks

If you need to implement undo support for the additional properties defined by a class derived from TableNode, do so by deriving from TableNodeProperties and overriding the TableNode.SaveProperties, TableNode.RestoreProperties, and TableNode.CreateProperties methods.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.DiagramItemProperties
MindFusion.Diagramming.DiagramNodeProperties
MindFusion.Diagramming.TableNodeProperties

See Also

TableNodeProperties Members


MindFusion.Diagramming.TableNodeProperties Members

TableNodeProperties Members
Constructors Fields Methods
[image]

Stores the values of TableNode properties during undo / redo operations.

The following tables list the members exposed by the TableNodeProperties type.

Public Constructors

Name | Description
TableNodeProperties | Initializes a new instance of the TableNodeProperties class.

Public Fields

Name | Description
Caption | For internal use.
CaptionHeight | For internal use.
CellTextBrush | For internal use.
ColumnWidth | For internal use.
CurrScrollRow | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use. (Inherited from DiagramNodeProperties.)
RowHeight | For internal use.
Scrollable | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties Fields

TableNodeProperties Fields
[image]

Public Fields

Name | Description
Caption | For internal use.
CaptionHeight | For internal use.
CellTextBrush | For internal use.
ColumnWidth | For internal use.
CurrScrollRow | For internal use.
ItemClass | For internal use. (Inherited from DiagramItemProperties.)
labels | For internal use. (Inherited from DiagramNodeProperties.)
RowHeight | For internal use.
Scrollable | For internal use.
Selected | For internal use. (Inherited from DiagramItemProperties.)
TextPadding | For internal use. (Inherited from DiagramItemProperties.)
ZIndex | For internal use. (Inherited from DiagramItemProperties.)

See Also

TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.Caption Field

TableNodeProperties.Caption Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption

Visual Basic [image] Copy Code

Public Caption As String

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.CaptionHeight Field

TableNodeProperties.CaptionHeight Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CaptionHeight

Visual Basic [image] Copy Code

Public CaptionHeight As Double

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.CellTextBrush Field

TableNodeProperties.CellTextBrush Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CellTextBrush

Visual Basic [image] Copy Code

Public CellTextBrush As Brush

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.ColumnWidth Field

TableNodeProperties.ColumnWidth Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ColumnWidth

Visual Basic [image] Copy Code

Public ColumnWidth As Double

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.CurrScrollRow Field

TableNodeProperties.CurrScrollRow Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int CurrScrollRow

Visual Basic [image] Copy Code

Public CurrScrollRow As Integer

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.RowHeight Field

TableNodeProperties.RowHeight Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RowHeight

Visual Basic [image] Copy Code

Public RowHeight As Double

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.Scrollable Field

TableNodeProperties.Scrollable Field
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Scrollable

Visual Basic [image] Copy Code

Public Scrollable As Boolean

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties Constructor

TableNodeProperties Constructor
[image]

Initializes a new instance of the TableNodeProperties class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNodeProperties ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties Methods

TableNodeProperties Methods
[image]

Public Methods

Name | Description
FreeResources | DiagramItemProperties.FreeResources override.

See Also

TableNodeProperties Class


MindFusion.Diagramming.TableNodeProperties.FreeResources Method

TableNodeProperties.FreeResources Method
[image]

DiagramItemProperties.FreeResources override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void FreeResources ()

Visual Basic [image] Copy Code

Public Overrides Sub FreeResources ()

See Also

TableNodeProperties Members
TableNodeProperties Class


MindFusion.Diagramming.TableNodeStyle Class

TableNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of table nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TableNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class TableNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.TableNodeStyle

See Also

TableNodeStyle Members


MindFusion.Diagramming.TableNodeStyle Members

TableNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of table nodes.

The following tables list the members exposed by the TableNodeStyle type.

Public Constructors

Name | Description
TableNodeStyle | Initializes a new instance of the TableNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CellTextBrush | Gets or sets the brush used to paint texts inside table cells.
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JsonObject. (Inherited from DiagramNodeStyle.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject. (Inherited from DiagramNodeStyle.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

TableNodeStyle Class


MindFusion.Diagramming.TableNodeStyle Constructor

TableNodeStyle Constructor
[image]

Initializes a new instance of the TableNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TableNodeStyle Class


MindFusion.Diagramming.TableNodeStyle Properties

TableNodeStyle Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
CaptionBackBrush | Gets or sets the brush used to paint the caption area of this table.
CellTextBrush | Gets or sets the brush used to paint texts inside table cells.
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

See Also

TableNodeStyle Class


MindFusion.Diagramming.TableNodeStyle.CaptionBackBrush Property

TableNodeStyle.CaptionBackBrush Property
[image]

Gets or sets the brush used to paint the caption area of this table.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CaptionBackBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionBackBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

TableNodeStyle Members
TableNodeStyle Class


MindFusion.Diagramming.TableNodeStyle.CellTextBrush Property

TableNodeStyle.CellTextBrush Property
[image]

Gets or sets the brush used to paint texts inside table cells.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush CellTextBrush { get; set; }

Visual Basic [image] Copy Code

Public Property CellTextBrush As Brush

Property Value

An instance of a Brush-derived class.

See Also

TableNodeStyle Members
TableNodeStyle Class


MindFusion.Diagramming.TextEditor Class

TextEditor Class
[image]

For internal use.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TextEditor : Editor

Visual Basic [image] Copy Code

Public Class TextEditor
Inherits Editor

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
Microsoft.Maui.Controls.Element
Microsoft.Maui.Controls.NavigableElement
Microsoft.Maui.Controls.VisualElement
Microsoft.Maui.Controls.View
Microsoft.Maui.Controls.InputView
Microsoft.Maui.Controls.Editor
MindFusion.Diagramming.TextEditor

See Also

TextEditor Members


MindFusion.Diagramming.TextEditor Members

TextEditor Members
Constructors
[image]

For internal use.

The following tables list the members exposed by the TextEditor type.

Public Constructors

Name | Description
TextEditor |

See Also

TextEditor Class


MindFusion.Diagramming.TextEditor Constructor

TextEditor Constructor
[image]

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TextEditor ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TextEditor Class


MindFusion.Diagramming.Theme Class

Theme Class
[image]

Represents a set of Style objects for different diagram item types.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Theme

Visual Basic [image] Copy Code

Public Class Theme

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Theme

See Also

Theme Members


MindFusion.Diagramming.Theme Members

Theme Members
Constructors Methods
[image]

Represents a set of Style objects for different diagram item types.

The following tables list the members exposed by the Theme type.

Public Constructors

Name | Description
Theme | Initializes a new instance of the Theme class.

Public Methods

Name | Description
GetStyle | Gets the Style object, if any, associated with the specified type.
LoadFromString | Loads the theme from an XML string.
LoadFromXml | Loads the theme from an XML file.
RegisterStyle | Registers the specified Style object for the items of the specified type.
SaveToString | Saves the theme into an XML string.
SaveToXml | Saves the theme to an XML file.
UnregisterStyle | Unregisters the Style object associated with the specified type.

See Also

Theme Class


MindFusion.Diagramming.Theme Constructor

Theme Constructor
[image]

Initializes a new instance of the Theme class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Theme Class


MindFusion.Diagramming.Theme Methods

Theme Methods
[image]

Public Methods

Name | Description
GetStyle | Gets the Style object, if any, associated with the specified type.
LoadFromString | Loads the theme from an XML string.
LoadFromXml | Loads the theme from an XML file.
RegisterStyle | Registers the specified Style object for the items of the specified type.
SaveToString | Saves the theme into an XML string.
SaveToXml | Saves the theme to an XML file.
UnregisterStyle | Unregisters the Style object associated with the specified type.

See Also

Theme Class


MindFusion.Diagramming.Theme.GetStyle Method

Theme.GetStyle Method
[image]

Gets the Style object, if any, associated with the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style GetStyle (
Type type
)

Visual Basic [image] Copy Code

Public Function GetStyle( _
type As Type _
) As Style

Parameters

type

The runtime type whose style to retrieve.

Return Value

The Style associated with the type, or null.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.LoadFromString Method

Theme.LoadFromString Method
[image]

Loads the theme from an XML string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromString (
string xml
)

Visual Basic [image] Copy Code

Public Sub LoadFromString( _
xml As String _
)

Parameters

xml

The string to load from.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.LoadFromXml Method

Theme.LoadFromXml Method
[image]

Loads the theme from an XML file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void LoadFromXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub LoadFromXml( _
stream As Stream _
)

Parameters

stream

The stream to load from.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.RegisterStyle Method

Theme.RegisterStyle Method
[image]

Registers the specified Style object for the items of the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RegisterStyle (
Type type,
Style style
)

Visual Basic [image] Copy Code

Public Sub RegisterStyle( _
type As Type, _
style As Style _
)

Parameters

type

The runtime type to register.

style

The style to associate with the specified type. The previously associated style, if any, is discarded.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.SaveToString Method

Theme.SaveToString Method
[image]

Saves the theme into an XML string.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string SaveToString ()

Visual Basic [image] Copy Code

Public Function SaveToString () As String

Return Value

The serialized string.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.SaveToXml Method

Theme.SaveToXml Method
[image]

Saves the theme to an XML file.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SaveToXml (
Stream stream
)

Visual Basic [image] Copy Code

Public Sub SaveToXml( _
stream As Stream _
)

Parameters

stream

The stream to save to.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.Theme.UnregisterStyle Method

Theme.UnregisterStyle Method
[image]

Unregisters the Style object associated with the specified type.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UnregisterStyle (
Type type
)

Visual Basic [image] Copy Code

Public Sub UnregisterStyle( _
type As Type _
)

Parameters

type

The runtime type to unregister.

See Also

Theme Members
Theme Class


MindFusion.Diagramming.TimerEventArgs Class

TimerEventArgs Class
[image]

Contains the arguments passed to timer-related event handlers.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TimerEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class TimerEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.TimerEventArgs

See Also

TimerEventArgs Members


MindFusion.Diagramming.TimerEventArgs Members

TimerEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to timer-related event handlers.

The following tables list the members exposed by the TimerEventArgs type.

Public Constructors

Name | Description
TimerEventArgs | Overloaded. Initializes a new instance of the TimerEventArgs class.

Public Properties

Name | Description
Handler | Gets the tick handler of the timer when a new timer is requested.
Interval | Gets the timer interval when a new timer is requested.
IsHandled | Gets or sets a value indicating whether the event is handled.
IsStart | Gets a value indicating whether a new timer is being created or an existing timer is being stopped.
Timer | Gets or sets the timer related to the operation.

See Also

TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs Constructor

TimerEventArgs Constructor
[image]

Initializes a new instance of the TimerEventArgs class.

Overload List

Name | Description
TimerEventArgs (Int32, EventHandler) | Initializes a new instance of the TimerEventArgs class.
TimerEventArgs (Object) | Initializes a new instance of the TimerEventArgs class.

See Also

TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs Constructor (Int32, EventHandler)

TimerEventArgs Constructor (Int32, EventHandler)
See Also
[image]

Initializes a new instance of the TimerEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TimerEventArgs (
int interval,
EventHandler handler
)

Visual Basic [image] Copy Code

Public New ( _
interval As Integer, _
handler As EventHandler _
)

Parameters

interval

handler

See Also

TimerEventArgs Constructor Overload List
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs Constructor (Object)

TimerEventArgs Constructor (Object)
See Also
[image]

Initializes a new instance of the TimerEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TimerEventArgs (
Object timer
)

Visual Basic [image] Copy Code

Public New ( _
timer As Object _
)

Parameters

timer

See Also

TimerEventArgs Constructor Overload List
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs Properties

TimerEventArgs Properties
[image]

Public Properties

Name | Description
Handler | Gets the tick handler of the timer when a new timer is requested.
Interval | Gets the timer interval when a new timer is requested.
IsHandled | Gets or sets a value indicating whether the event is handled.
IsStart | Gets a value indicating whether a new timer is being created or an existing timer is being stopped.
Timer | Gets or sets the timer related to the operation.

See Also

TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs.Handler Property

TimerEventArgs.Handler Property
[image]

Gets the tick handler of the timer when a new timer is requested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public EventHandler Handler { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Handler As EventHandler

Property Value

See Also

TimerEventArgs Members
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs.Interval Property

TimerEventArgs.Interval Property
[image]

Gets the timer interval when a new timer is requested.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Interval { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Interval As Integer

Property Value

See Also

TimerEventArgs Members
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs.IsHandled Property

TimerEventArgs.IsHandled Property
[image]

Gets or sets a value indicating whether the event is handled.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsHandled { get; set; }

Visual Basic [image] Copy Code

Public Property IsHandled As Boolean

Property Value

See Also

TimerEventArgs Members
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs.IsStart Property

TimerEventArgs.IsStart Property
[image]

Gets a value indicating whether a new timer is being created or an existing timer is being stopped.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsStart { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsStart As Boolean

Property Value

See Also

TimerEventArgs Members
TimerEventArgs Class


MindFusion.Diagramming.TimerEventArgs.Timer Property

TimerEventArgs.Timer Property
[image]

Gets or sets the timer related to the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Timer { get; set; }

Visual Basic [image] Copy Code

Public Property Timer As Object

Property Value

See Also

TimerEventArgs Members
TimerEventArgs Class


MindFusion.Diagramming.TreeEnumerator Class

TreeEnumerator Class
Remarks See Also
[image]

Enables an easy standard method to iterate over the elements of a tree-like structure of objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeEnumerator : IEnumerator

Visual Basic [image] Copy Code

Public Class TreeEnumerator
Implements IEnumerator

Remarks

The TreeEnumerator class implements the standard IEnumerator interface. It provides an easy method to iterate over the elements of a tree-like structure of diagram items.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TreeEnumerator

See Also

TreeEnumerator Members


MindFusion.Diagramming.TreeEnumerator Members

TreeEnumerator Members
Constructors Properties Methods
[image]

Enables an easy standard method to iterate over the elements of a tree-like structure of objects.

The following tables list the members exposed by the TreeEnumerator type.

Public Constructors

Name | Description
TreeEnumerator | Initializes a new instance of the TreeEnumerator class.

Public Properties

Name | Description
Current | Gets the current element of the iteration.

Public Methods

Name | Description
MoveNext | Advances the enumerator to the next element of the tree.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator Constructor

TreeEnumerator Constructor
[image]

Initializes a new instance of the TreeEnumerator class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeEnumerator (
DiagramNode root,
bool enumLinks,
bool strict
)

Visual Basic [image] Copy Code

Public New ( _
root As DiagramNode, _
enumLinks As Boolean, _
strict As Boolean _
)

Parameters

root

The root of the tree or subtree to be enumerated.

enumLinks

Specifies whether to enumerate links.

strict

Specifies whether to check strictly if the passed structure is a tree.

See Also

TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator Methods

TreeEnumerator Methods
[image]

Public Methods

Name | Description
MoveNext | Advances the enumerator to the next element of the tree.
Reset | Sets the enumerator to its initial position, which is before the first element in the collection.

See Also

TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator.MoveNext Method

TreeEnumerator.MoveNext Method
[image]

Advances the enumerator to the next element of the tree.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MoveNext ()

Visual Basic [image] Copy Code

Public Function MoveNext () As Boolean

Return Value

true if the enumerator has successfully passed to the next DiagramItem in the collection; false if there are no more elements available to enumerate.

Remarks

Initially an enumerator is positioned before the first element of the tree (the root), and the first call to MoveNext moves the enumerator over that first element.

See Also

TreeEnumerator Members
TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator.Reset Method

TreeEnumerator.Reset Method
[image]

Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Reset ()

Visual Basic [image] Copy Code

Public Sub Reset ()

See Also

TreeEnumerator Members
TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator Properties

TreeEnumerator Properties
[image]

Public Properties

Name | Description
Current | Gets the current element of the iteration.

See Also

TreeEnumerator Class


MindFusion.Diagramming.TreeEnumerator.Current Property

TreeEnumerator.Current Property
[image]

Gets the current element of the iteration.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Current { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Current As Object

Property Value

The DiagramItem that is current in the enumeration.

Remarks

If the enumLinks constructor argument is set to false, only nodes are enumerated. After an enumerator is created or after a Reset, MoveNext must be called to advance the enumerator to the first element before reading the value of Current; otherwise, Current is undefined.

See Also

TreeEnumerator Members
TreeEnumerator Class


MindFusion.Diagramming.TreeItemEventArgs Class

TreeItemEventArgs Class
[image]

Contains the arguments passed to handlers of TreeViewItem-related events.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeItemEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class TreeItemEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.TreeItemEventArgs
MindFusion.Diagramming.TreeItemValidationEventArgs

See Also

TreeItemEventArgs Members


MindFusion.Diagramming.TreeItemEventArgs Members

TreeItemEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to handlers of TreeViewItem-related events.

The following tables list the members exposed by the TreeItemEventArgs type.

Public Constructors

Name | Description
TreeItemEventArgs | Initializes a new instance of the TreeItemEventArgs class.

Public Properties

Name | Description
Item | Get the item for which the event is raised.
Position | Gets the location related to the event.

See Also

TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemEventArgs Constructor

TreeItemEventArgs Constructor
[image]

Initializes a new instance of the TreeItemEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeItemEventArgs (
TreeViewItem item,
Point position
)

Visual Basic [image] Copy Code

Public New ( _
item As TreeViewItem, _
position As Point _
)

Parameters

item

The TreeViewItem related to the event.

position

The location related to the event.

See Also

TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemEventArgs Properties

TreeItemEventArgs Properties
[image]

Public Properties

Name | Description
Item | Get the item for which the event is raised.
Position | Gets the location related to the event.

See Also

TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemEventArgs.Item Property

TreeItemEventArgs.Item Property
[image]

Get the item for which the event is raised.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As TreeViewItem

Property Value

An instance of the TreeViewItem class.

See Also

TreeItemEventArgs Members
TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemEventArgs.Position Property

TreeItemEventArgs.Position Property
[image]

Gets the location related to the event.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Position { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Position As Point

Property Value

A Point object.

See Also

TreeItemEventArgs Members
TreeItemEventArgs Class


MindFusion.Diagramming.TreeItemValidationEventArgs Class

TreeItemValidationEventArgs Class
[image]

Contains the arguments passed to event handlers, such as TreeItemTextEditing.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeItemValidationEventArgs : TreeItemEventArgs

Visual Basic [image] Copy Code

Public Class TreeItemValidationEventArgs
Inherits TreeItemEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.TreeItemEventArgs
MindFusion.Diagramming.TreeItemValidationEventArgs

See Also

TreeItemValidationEventArgs Members


MindFusion.Diagramming.TreeItemValidationEventArgs Members

TreeItemValidationEventArgs Members
Constructors Properties
[image]

Contains the arguments passed to event handlers, such as TreeItemTextEditing.

The following tables list the members exposed by the TreeItemValidationEventArgs type.

Public Constructors

Name | Description
TreeItemValidationEventArgs | Initializes a new instance of the TreeItemValidationEventArgs class.

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Item | Get the item for which the event is raised. (Inherited from TreeItemEventArgs.)
Position | Gets the location related to the event. (Inherited from TreeItemEventArgs.)

See Also

TreeItemValidationEventArgs Class


MindFusion.Diagramming.TreeItemValidationEventArgs Constructor

TreeItemValidationEventArgs Constructor
[image]

Initializes a new instance of the TreeItemValidationEventArgs class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeItemValidationEventArgs (
TreeViewItem item,
Point position
)

Visual Basic [image] Copy Code

Public New ( _
item As TreeViewItem, _
position As Point _
)

Parameters

item

The TreeViewItem related to the event.

position

The location related to the event.

See Also

TreeItemValidationEventArgs Class


MindFusion.Diagramming.TreeItemValidationEventArgs Properties

TreeItemValidationEventArgs Properties
[image]

Public Properties

Name | Description
Cancel | Gets or sets a value indicating whether to prevent the user from completing the operation.
Item | Get the item for which the event is raised. (Inherited from TreeItemEventArgs.)
Position | Gets the location related to the event. (Inherited from TreeItemEventArgs.)

See Also

TreeItemValidationEventArgs Class


MindFusion.Diagramming.TreeItemValidationEventArgs.Cancel Property

TreeItemValidationEventArgs.Cancel Property
[image]

Gets or sets a value indicating whether to prevent the user from completing the operation.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Cancel { get; set; }

Visual Basic [image] Copy Code

Public Property Cancel As Boolean

Property Value

See Also

TreeItemValidationEventArgs Members
TreeItemValidationEventArgs Class


MindFusion.Diagramming.TreeViewConnectionPoint Class

TreeViewConnectionPoint Class
[image]

Represents a connection between a link and a TreeViewNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewConnectionPoint : ConnectionPoint

Visual Basic [image] Copy Code

Public Class TreeViewConnectionPoint
Inherits ConnectionPoint

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ConnectionPoint
MindFusion.Diagramming.TreeViewConnectionPoint

See Also

TreeViewConnectionPoint Members


MindFusion.Diagramming.TreeViewConnectionPoint Members

TreeViewConnectionPoint Members
Constructors Properties Methods
[image]

Represents a connection between a link and a TreeViewNode.

The following tables list the members exposed by the TreeViewConnectionPoint type.

Public Constructors

Name | Description
TreeViewConnectionPoint | Overloaded. Initializes a new instance of the TreeViewConnectionPoint class.

Public Properties

Name | Description
Anchor | Gets or sets the anchor point associated with the connection point. (Inherited from ConnectionPoint.)
Row | ConnectionPoint.Row override.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
AlignToNode | Aligns the specified point to the nearest anchor point of the connected node. (Inherited from ConnectionPoint.)
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes. (Inherited from ConnectionPoint.)
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point. (Inherited from ConnectionPoint.)
GetAnchorPos | Overloaded. Returns a point from the node's associated anchor pattern. (Inherited from ConnectionPoint.)
GetEndPoint | ConnectionPoint.GetEndPoint override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetIntersection | ConnectionPoint.GetIntersection override.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | ConnectionPoint.LinkChanges override.
NearestAnchorPoint | Returns the anchor point closest to the specified point from the node's associated anchor pattern. (Inherited from ConnectionPoint.)
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
PositionFromNode | Overloaded. Returns the position of the connection point. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node. (Inherited from ConnectionPoint.)

Protected Methods

Name | Description
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Constructor

TreeViewConnectionPoint Constructor
[image]

Initializes a new instance of the TreeViewConnectionPoint class.

Overload List

Name | Description
TreeViewConnectionPoint () | Initializes a new instance of the TreeViewConnectionPoint class.
TreeViewConnectionPoint (TreeViewNode, DiagramLink, Boolean, TreeViewItem) | Initializes a new instance of the TreeViewConnectionPoint class.

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Constructor ()

TreeViewConnectionPoint Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewConnectionPoint class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewConnectionPoint ()

Visual Basic [image] Copy Code

Public Sub New ()

Remarks

This constructor is used only during deserialization.

See Also

TreeViewConnectionPoint Constructor Overload List
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Constructor (TreeViewNode, DiagramLink, Boolean, TreeViewItem)

TreeViewConnectionPoint Constructor (TreeViewNode, DiagramLink, Boolean, TreeViewItem)
See Also
[image]

Initializes a new instance of the TreeViewConnectionPoint class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewConnectionPoint (
TreeViewNode node,
DiagramLink link,
bool incoming,
TreeViewItem item
)

Visual Basic [image] Copy Code

Public New ( _
node As TreeViewNode, _
link As DiagramLink, _
incoming As Boolean, _
item As TreeViewItem _
)

Parameters

node

A TreeViewNode instance.

link

A DiagramLink instance.

incoming

Specifies which end of the link is represented by this TreeViewConnectionPoint.

item

The TreeViewItem to which the link connects.

See Also

TreeViewConnectionPoint Constructor Overload List
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Methods

TreeViewConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
AlignToNode | Aligns the specified point to the nearest anchor point of the connected node. (Inherited from ConnectionPoint.)
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes. (Inherited from ConnectionPoint.)
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point. (Inherited from ConnectionPoint.)
GetAnchorPos | Overloaded. Returns a point from the node's associated anchor pattern. (Inherited from ConnectionPoint.)
GetEndPoint | ConnectionPoint.GetEndPoint override.
GetInitialPoint | ConnectionPoint.GetInitialPoint override.
GetIntersection | ConnectionPoint.GetIntersection override.
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | ConnectionPoint.LinkChanges override.
NearestAnchorPoint | Returns the anchor point closest to the specified point from the node's associated anchor pattern. (Inherited from ConnectionPoint.)
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
PositionFromNode | Overloaded. Returns the position of the connection point. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node. (Inherited from ConnectionPoint.)

Protected Methods

Name | Description
GetNearestBorderPoint | ConnectionPoint.GetNearestBorderPoint override.
UpdateFromPoint | Updates the connection stated according to the specified point, without changing the related node.

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.AddLinkToNode Method

TreeViewConnectionPoint.AddLinkToNode Method
[image]

ConnectionPoint.AddLinkToNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overrides Sub AddLinkToNode ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetEndPoint Method

TreeViewConnectionPoint.GetEndPoint Method
[image]

ConnectionPoint.GetEndPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetEndPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetEndPoint () As Point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetInitialPoint Method

TreeViewConnectionPoint.GetInitialPoint Method
[image]

ConnectionPoint.GetInitialPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetInitialPoint ()

Visual Basic [image] Copy Code

Public Overrides Function GetInitialPoint () As Point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetIntersection Method

TreeViewConnectionPoint.GetIntersection Method
[image]

ConnectionPoint.GetIntersection override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override Point GetIntersection (
Point pt1,
Point pt2
)

Visual Basic [image] Copy Code

Public Overrides Function GetIntersection( _
pt1 As Point, _
pt2 As Point _
) As Point

Parameters

pt1

pt2

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.GetNearestBorderPoint Method

TreeViewConnectionPoint.GetNearestBorderPoint Method
[image]

ConnectionPoint.GetNearestBorderPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Point GetNearestBorderPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overrides Function GetNearestBorderPoint( _
point As Point _
) As Point

Parameters

point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.LinkChanges Method

TreeViewConnectionPoint.LinkChanges Method
[image]

ConnectionPoint.LinkChanges override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool LinkChanges (
DiagramItem item,
Point point
)

Visual Basic [image] Copy Code

Public Overrides Function LinkChanges( _
item As DiagramItem, _
point As Point _
) As Boolean

Parameters

item

point

Return Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.RemoveLinkFromNode Method

TreeViewConnectionPoint.RemoveLinkFromNode Method
[image]

ConnectionPoint.RemoveLinkFromNode override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overrides Sub RemoveLinkFromNode ()

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.UpdateFromPoint Method

TreeViewConnectionPoint.UpdateFromPoint Method
[image]

Updates the connection stated according to the specified point, without changing the related node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void UpdateFromPoint (
Point point
)

Visual Basic [image] Copy Code

Protected Overrides Sub UpdateFromPoint( _
point As Point _
)

Parameters

point

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint Properties

TreeViewConnectionPoint Properties
[image]

Public Properties

Name | Description
Anchor | Gets or sets the anchor point associated with the connection point. (Inherited from ConnectionPoint.)
Row | ConnectionPoint.Row override.

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)

See Also

TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionPoint.Row Property

TreeViewConnectionPoint.Row Property
[image]

ConnectionPoint.Row override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override int Row { get; set; }

Visual Basic [image] Copy Code

Public Overrides Property Row As Integer

Property Value

See Also

TreeViewConnectionPoint Members
TreeViewConnectionPoint Class


MindFusion.Diagramming.TreeViewConnectionStyle Enumeration

TreeViewConnectionStyle Enumeration
[image]

Specifies the possible values for the ConnectionStyle property of TreeViewNode objects.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeViewConnectionStyle

Visual Basic [image] Copy Code

Public Enum TreeViewConnectionStyle

Members

Member name | Description
Items | Users are allowed to create relations to the items of a TreeViewNode.
Node | Users are allowed to create relations to the TreeViewNode as an integral entity.

See Also


MindFusion.Diagramming.TreeViewItem Class

TreeViewItem Class
[image]

Represents a constituent item of the hierarchy displayed inside a TreeViewNode.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewItem : INotifyPropertyChanged, InplaceEditable

Visual Basic [image] Copy Code

Public Class TreeViewItem
Implements INotifyPropertyChanged, InplaceEditable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.TreeViewItem

See Also

TreeViewItem Members


MindFusion.Diagramming.TreeViewItem Members

TreeViewItem Members
Constructors Properties Events
[image]

Represents a constituent item of the hierarchy displayed inside a TreeViewNode.

The following tables list the members exposed by the TreeViewItem type.

Public Constructors

Name | Description
TreeViewItem | Overloaded. Initializes a new instance of the TreeViewItem class.

Public Properties

Name | Description
Children | Gets a list of this item's children in the hierarchy.
Expanded | Gets or sets whether this item is expanded to show its children.
Height | Gets or sets the height of this item.
Image | Gets or sets the image that is displayed in this treeview item.
IncomingLinks | Gets a collection of all links that point to this item.
Label | Gets or sets the label of this item.
LabelBrush | Gets or sets the brush used to draw the label of this item.
LabelFont | Gets or sets the label font of this item.
OutgoingLinks | Gets a collection of all links that go out of this item.
Parent | Gets the parent item of this item.
Tag | Gets or sets custom data associated with this item.

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.PropertyChanged.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor

TreeViewItem Constructor
[image]

Initializes a new instance of the TreeViewItem class.

Overload List

Name | Description
TreeViewItem () | Initializes a new instance of the TreeViewItem class.
TreeViewItem (String) | Initializes a new instance of the TreeViewItem class.
TreeViewItem (TreeViewItem) | Initializes a new instance of the TreeViewItem class using the specified item as a prototype.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor ()

TreeViewItem Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor (String)

TreeViewItem Constructor (String)
See Also
[image]

Initializes a new instance of the TreeViewItem class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem (
string label
)

Visual Basic [image] Copy Code

Public New ( _
label As String _
)

Parameters

label

The text initially displayed by the item.

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Constructor (TreeViewItem)

TreeViewItem Constructor (TreeViewItem)
See Also
[image]

Initializes a new instance of the TreeViewItem class using the specified item as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem (
TreeViewItem prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TreeViewItem _
)

Parameters

prototype

The treeview item to use as a prototype. The properties of the new treeview are initialized from the property values of prototype.

Remarks

This constructor copies the TreeViewItem property values from the specified prototype item.

See Also

TreeViewItem Constructor Overload List
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Properties

TreeViewItem Properties
[image]

Public Properties

Name | Description
Children | Gets a list of this item's children in the hierarchy.
Expanded | Gets or sets whether this item is expanded to show its children.
Height | Gets or sets the height of this item.
Image | Gets or sets the image that is displayed in this treeview item.
IncomingLinks | Gets a collection of all links that point to this item.
Label | Gets or sets the label of this item.
LabelBrush | Gets or sets the brush used to draw the label of this item.
LabelFont | Gets or sets the label font of this item.
OutgoingLinks | Gets a collection of all links that go out of this item.
Parent | Gets the parent item of this item.
Tag | Gets or sets custom data associated with this item.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Children Property

TreeViewItem.Children Property
[image]

Gets a list of this item's children in the hierarchy.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<TreeViewItem> Children { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Children As IList(Of TreeViewItem)

Property Value

A list of child TreeViewItem objects.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Expanded Property

TreeViewItem.Expanded Property
[image]

Gets or sets whether this item is expanded to show its children.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Expanded { get; set; }

Visual Basic [image] Copy Code

Public Property Expanded As Boolean

Property Value

true to show the children of this item, otherwise false; the default value is true.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Height Property

TreeViewItem.Height Property
[image]

Gets or sets the height of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

A double value specifying the item's height. The default value is 5.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Image Property

TreeViewItem.Image Property
[image]

Gets or sets the image that is displayed in this treeview item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource Image { get; set; }

Visual Basic [image] Copy Code

Public Property Image As ImageSource

Property Value

An instance of the ImageSource class.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.IncomingLinks Property

TreeViewItem.IncomingLinks Property
[image]

Gets a collection of all links that point to this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection IncomingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IncomingLinks As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

The property returns a collection of all links that point to this item. Use it to access the links or get their number.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Label Property

TreeViewItem.Label Property
[image]

Gets or sets the label of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Label { get; set; }

Visual Basic [image] Copy Code

Public Property Label As String

Property Value

A string specifying the item's label.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.LabelBrush Property

TreeViewItem.LabelBrush Property
[image]

Gets or sets the brush used to draw the label of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush LabelBrush { get; set; }

Visual Basic [image] Copy Code

Public Property LabelBrush As Brush

Property Value

An instance of a Brush-derived class. The default value is null.

Remarks

It this property is set to null, the label is rendered using the TextBrush value of the parent node.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.LabelFont Property

TreeViewItem.LabelFont Property
[image]

Gets or sets the label font of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Font> LabelFont { get; set; }

Visual Basic [image] Copy Code

Public Property LabelFont As Nullable(Of Font)

Property Value

An instance of the Font class. The default value is null.

Remarks

It this property is set to null, the label is rendered using the Font of the parent node.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.OutgoingLinks Property

TreeViewItem.OutgoingLinks Property
[image]

Gets a collection of all links that go out of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramLinkCollection OutgoingLinks { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OutgoingLinks As DiagramLinkCollection

Property Value

An instance of the DiagramLinkCollection class.

Remarks

The property returns a collection of all links that start from this item. Use it to access the links or get their number.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Parent Property

TreeViewItem.Parent Property
[image]

Gets the parent item of this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem Parent { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Parent As TreeViewItem

Property Value

A TreeViewItem instance.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.Tag Property

TreeViewItem.Tag Property
[image]

Gets or sets custom data associated with this item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object Tag { get; set; }

Visual Basic [image] Copy Code

Public Property Tag As Object

Property Value

An instance of any class derived from System.Object. The default value is null.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewItem Events

TreeViewItem Events
[image]

Public Events

Name | Description
PropertyChanged | Implements INotifyPropertyChanged.PropertyChanged.

See Also

TreeViewItem Class


MindFusion.Diagramming.TreeViewItem.PropertyChanged Event

TreeViewItem.PropertyChanged Event
[image]

Implements INotifyPropertyChanged.PropertyChanged.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event PropertyChangedEventHandler PropertyChanged

Visual Basic [image] Copy Code

Public Event PropertyChanged As PropertyChangedEventHandler

Event Data

PropertyChanged event handlers receive an argument of type PropertyChangedEventArgs.

See Also

TreeViewItem Members
TreeViewItem Class


MindFusion.Diagramming.TreeViewNode Class

TreeViewNode Class
Remarks See Also
[image]

Represents nodes that can draw hierarchical data.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewNode : DiagramNode, InplaceEditable

Visual Basic [image] Copy Code

Public Class TreeViewNode
Inherits DiagramNode
Implements InplaceEditable

Remarks

The root items displayed in the node can be accessed through the RootItems property. New items can be added to and removed from the returned collection. The root items can have child items on their own and so on. For more information, refer to the TreeViewItem class.

The text and image displayed in the node caption can be customized through the Caption and CaptionImage properties respectively. The scroll position can be manipulated through ScrollPosition.

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.TreeViewNode

See Also

TreeViewNode Members


MindFusion.Diagramming.TreeViewNode Members

TreeViewNode Members
Constructors Fields Properties Methods
[image]

Represents nodes that can draw hierarchical data.

The following tables list the members exposed by the TreeViewNode type.

Public Constructors

Name | Description
TreeViewNode | Overloaded. Initializes a new instance of the TreeViewNode class.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the node.
CaptionHeight | Gets or sets the height of the node's caption area.
CaptionImage | Gets or sets the image that is displayed in the caption.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RootItems | Gets a list of the root TreeViewItem objects displayed in this node.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
ScrollPosition | Gets or sets the current scroll position.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the table's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of texts displayed inside this shape node.
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | DiagramNode.HasItems override.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetFlatItemList | Gets a list with all items of this node.
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetItemRect | Gets the location and size of the specified TreeViewItem.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestExpander | Gets whether there is a collapse/expand button located at the specified position.
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
ItemFromPoint | Returns the item at the specified location.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override.
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveItem | Removes the specified item from the node.
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitText | Resizes the tree view so that it is large enough to fit the text of its items.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | DiagramNode.GetAllIncomingLinks override.
GetAllOutgoingLinks | DiagramNode.GetAllOutgoingLinks override.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | DiagramItem.HandleTap override.
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor

TreeViewNode Constructor
[image]

Initializes a new instance of the TreeViewNode class.

Overload List

Name | Description
TreeViewNode () | Initializes a new instance of the TreeViewNode class.
TreeViewNode (Diagram) | Initializes a new instance of the TreeViewNode class.
TreeViewNode (TreeViewNode) | Initializes a new instance of the TreeViewNode class using the specified node as a prototype.

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor ()

TreeViewNode Constructor ()
See Also
[image]

Initializes a new instance of the TreeViewNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor (Diagram)

TreeViewNode Constructor (Diagram)
See Also
[image]

Initializes a new instance of the TreeViewNode class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode (
Diagram diagram
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram _
)

Parameters

diagram

The Diagram from which to obtain default values for the node properties.

Remarks

This constructor initializes the TreeViewNode properties with the values specified in the respective default-value properties of the Diagram object.

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Constructor (TreeViewNode)

TreeViewNode Constructor (TreeViewNode)
See Also
[image]

Initializes a new instance of the TreeViewNode class using the specified node as a prototype.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode (
TreeViewNode prototype
)

Visual Basic [image] Copy Code

Public New ( _
prototype As TreeViewNode _
)

Parameters

prototype

The treeview node to use as a prototype. The properties of the new treeview are initialized from the property values of prototype.

Remarks

This constructor copies the TreeViewNode property values from the specified prototype node.

See Also

TreeViewNode Constructor Overload List
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Methods

TreeViewNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | DiagramNode.AcceptLinks override.
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
CreateConnectionPoint | DiagramNode.CreateConnectionPoint override.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Draws the node on the specified IGraphics surface.
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetFlatItemList | Gets a list with all items of this node.
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetItemRect | Gets the location and size of the specified TreeViewItem.
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestExpander | Gets whether there is a collapse/expand button located at the specified position.
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
ItemFromPoint | Returns the item at the specified location.
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | DiagramItem.OnLoad override.
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveItem | Removes the specified item from the node.
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
ResizeToFitText | Resizes the tree view so that it is large enough to fit the text of its items.
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override.
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | DiagramNode.GetAllIncomingLinks override.
GetAllOutgoingLinks | DiagramNode.GetAllOutgoingLinks override.
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | DiagramItem.HandleTap override.
LoadFromJson | Loads the item content from a JsonObject.
LoadFromXml | Loads the item content from an XML element.
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the Diagram's MeasureUnit changes.
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | DiagramNode.OnUpdateBounds override.
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramNode.RestoreProperties override.
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramNode.SaveProperties override.
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToJson | Saves the item content into a JsonObject.
SaveToXml | Saves the item content into an XML element.
ScaleElements | DiagramNode.ScaleElements override.
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it.
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.AcceptLinks Method

TreeViewNode.AcceptLinks Method
[image]

DiagramNode.AcceptLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool AcceptLinks (
bool outgoing
)

Visual Basic [image] Copy Code

Public Overrides Function AcceptLinks( _
outgoing As Boolean _
) As Boolean

Parameters

outgoing

true to check for outgoing links; otherwise, false.

Return Value

true if the node accepts connections of the specified type; otherwise, false.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CreateConnectionPoint Method

TreeViewNode.CreateConnectionPoint Method
[image]

DiagramNode.CreateConnectionPoint override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Public Overrides Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link

A DiagramLink that should be connected to this node.

pt

The point at which the link should be connected.

incoming

true if link is an incoming link; otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CreateProperties Method

TreeViewNode.CreateProperties Method
[image]

DiagramItem.CreateProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override DiagramItemProperties CreateProperties ()

Visual Basic [image] Copy Code

Protected Overrides Function CreateProperties () As DiagramItemProperties

Return Value

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.DrawLocal Method

TreeViewNode.DrawLocal Method
[image]

Draws the node on the specified IGraphics surface.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void DrawLocal (
IGraphics graphics,
RenderOptions options
)

Visual Basic [image] Copy Code

Public Overrides Sub DrawLocal( _
graphics As IGraphics, _
options As RenderOptions _
)

Parameters

graphics

An IGraphics object where the node should be rendered.

options

Provides options for the drawing operation.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.GetAllIncomingLinks Method

TreeViewNode.GetAllIncomingLinks Method
[image]

DiagramNode.GetAllIncomingLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void GetAllIncomingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overrides Sub GetAllIncomingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

A DiagramLinkCollection the links should be added to.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.GetAllOutgoingLinks Method

TreeViewNode.GetAllOutgoingLinks Method
[image]

DiagramNode.GetAllOutgoingLinks override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void GetAllOutgoingLinks (
DiagramLinkCollection links
)

Visual Basic [image] Copy Code

Protected Overrides Sub GetAllOutgoingLinks( _
links As DiagramLinkCollection _
)

Parameters

links

A DiagramLinkCollection the links should be added to.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.GetFlatItemList Method

TreeViewNode.GetFlatItemList Method
[image]

Gets a list with all items of this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<TreeViewItem> GetFlatItemList ()

Visual Basic [image] Copy Code

Public Function GetFlatItemList () As List(Of TreeViewItem)

Return Value

A list of TreeViewItem objects.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.GetItemRect Method

TreeViewNode.GetItemRect Method
[image]

Gets the location and size of the specified TreeViewItem.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetItemRect (
TreeViewItem treeItem
)

Visual Basic [image] Copy Code

Public Function GetItemRect( _
treeItem As TreeViewItem _
) As Rect

Parameters

treeItem

A TreeViewItem instance.

Return Value

A Rectangle specifying the item's position and size.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.HandleTap Method

TreeViewNode.HandleTap Method
[image]

DiagramItem.HandleTap override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void HandleTap (
Point position,
double radius
)

Visual Basic [image] Copy Code

Protected Overrides Sub HandleTap( _
position As Point, _
radius As Double _
)

Parameters

position

The release location.

radius

The touch radius.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.HitTestExpander Method

TreeViewNode.HitTestExpander Method
[image]

Gets whether there is a collapse/expand button located at the specified position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HitTestExpander (
Point point,
double radius
)

Visual Basic [image] Copy Code

Public Function HitTestExpander( _
point As Point, _
radius As Double _
) As Boolean

Parameters

point

The point to check.

radius

The touch radius.

Return Value

true if there is [±] icon at the specified position, otherwise false.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ItemFromPoint Method

TreeViewNode.ItemFromPoint Method
[image]

Returns the item at the specified location.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem ItemFromPoint (
Point point
)

Visual Basic [image] Copy Code

Public Function ItemFromPoint( _
point As Point _
) As TreeViewItem

Parameters

point

The point to check.

Return Value

The TreeViewItem instance that contains the specified point.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.LoadFromJson Method

TreeViewNode.LoadFromJson Method
[image]

Loads the item content from a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

A JsonObject containing the item's data.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.LoadFromXml Method

TreeViewNode.LoadFromXml Method
[image]

Loads the item content from an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the item's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnLoad Method

TreeViewNode.OnLoad Method
[image]

DiagramItem.OnLoad override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnLoad ()

Visual Basic [image] Copy Code

Public Overrides Sub OnLoad ()

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnMeasureUnitChanged Method

TreeViewNode.OnMeasureUnitChanged Method
[image]

Called when the Diagram's MeasureUnit changes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnMeasureUnitChanged ()

Visual Basic [image] Copy Code

Protected Overrides Sub OnMeasureUnitChanged ()

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.OnUpdateBounds Method

TreeViewNode.OnUpdateBounds Method
[image]

DiagramNode.OnUpdateBounds override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void OnUpdateBounds (
bool sizeChanged
)

Visual Basic [image] Copy Code

Protected Overrides Sub OnUpdateBounds( _
sizeChanged As Boolean _
)

Parameters

sizeChanged

true if the size has changed; false if only the position has changed.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.RemoveItem Method

TreeViewNode.RemoveItem Method
[image]

Removes the specified item from the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveItem (
TreeViewItem item
)

Visual Basic [image] Copy Code

Public Sub RemoveItem( _
item As TreeViewItem _
)

Parameters

item

The TreeViewItem to remove.

Remarks

The method removes the specified item and all its direct or indirect children, as well as the links connecting to them.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ResizeToFitText Method

TreeViewNode.ResizeToFitText Method
[image]

Resizes the tree view so that it is large enough to fit the text of its items.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeToFitText ()

Visual Basic [image] Copy Code

Public Sub ResizeToFitText ()

Remarks

This method also resizes the node vertically so that its height fits all items.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.RestoreProperties Method

TreeViewNode.RestoreProperties Method
[image]

DiagramNode.RestoreProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void RestoreProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub RestoreProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object containing a snapshot of the item's properties.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SaveProperties Method

TreeViewNode.SaveProperties Method
[image]

DiagramNode.SaveProperties override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SaveProperties (
DiagramItemProperties props
)

Visual Basic [image] Copy Code

Protected Overrides Sub SaveProperties( _
props As DiagramItemProperties _
)

Parameters

props

A DiagramItemProperties-derived object where the item's properties should be saved.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SaveToJson Method

TreeViewNode.SaveToJson Method
[image]

Saves the item content into a JsonObject.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

A JsonObject the item's data should be stored into.

context

A JsonPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SaveToXml Method

TreeViewNode.SaveToXml Method
[image]

Saves the item content into an XML element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Task SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overrides Function SaveToXml( _
element As XElement, _
context As XmlPersistContext _
) As Task

Parameters

element

An XElement the item's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ScaleElements Method

TreeViewNode.ScaleElements Method
[image]

DiagramNode.ScaleElements override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void ScaleElements (
double scale
)

Visual Basic [image] Copy Code

Protected Overrides Sub ScaleElements( _
scale As Double _
)

Parameters

scale

The value by which to multiply node elements' sizes.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.SetReflexive Method

TreeViewNode.SetReflexive Method
[image]

Invoked to let a node set the shape of a reflexive link connected to it.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void SetReflexive (
DiagramLink link
)

Visual Basic [image] Copy Code

Protected Overrides Sub SetReflexive( _
link As DiagramLink _
)

Parameters

link

Reference to the link.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode Properties

TreeViewNode Properties
[image]

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Caption | Gets or sets the text displayed as caption of the node.
CaptionHeight | Gets or sets the height of the node's caption area.
CaptionImage | Gets or sets the image that is displayed in the caption.
ConnectionStyle | Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RootItems | Gets a list of the root TreeViewItem objects displayed in this node.
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
ScrollPosition | Gets or sets the current scroll position.
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Shape | Gets or sets the shape of the table's outline.
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextFormat | Gets or sets the alignment of texts displayed inside this shape node.
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | DiagramNode.HasItems override.
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

See Also

TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.Caption Property

TreeViewNode.Caption Property
[image]

Gets or sets the text displayed as caption of the node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Caption { get; set; }

Visual Basic [image] Copy Code

Public Property Caption As String

Property Value

A string specifying the caption text.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CaptionHeight Property

TreeViewNode.CaptionHeight Property
[image]

Gets or sets the height of the node's caption area.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CaptionHeight { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionHeight As Double

Property Value

A double value specifying the caption area height. The default value is 8.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.CaptionImage Property

TreeViewNode.CaptionImage Property
[image]

Gets or sets the image that is displayed in the caption.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource CaptionImage { get; set; }

Visual Basic [image] Copy Code

Public Property CaptionImage As ImageSource

Property Value

An instance of the ImageSource class.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ConnectionStyle Property

TreeViewNode.ConnectionStyle Property
[image]

Gets or sets a value indicating whether drawing a link from/to this node should connect an item or the whole node as an integral entity.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewConnectionStyle ConnectionStyle { get; set; }

Visual Basic [image] Copy Code

Public Property ConnectionStyle As TreeViewConnectionStyle

Property Value

A member of the TreeViewConnectionStyle enumeration. The default value is Items.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.HasItems Property

TreeViewNode.HasItems Property
[image]

DiagramNode.HasItems override.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool HasItems { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property HasItems As Boolean

Property Value

A boolean value.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.RootItems Property

TreeViewNode.RootItems Property
[image]

Gets a list of the root TreeViewItem objects displayed in this node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IList<TreeViewItem> RootItems { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RootItems As IList(Of TreeViewItem)

Property Value

An instance of the TreeViewItem class.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.ScrollPosition Property

TreeViewNode.ScrollPosition Property
[image]

Gets or sets the current scroll position.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ScrollPosition { get; set; }

Visual Basic [image] Copy Code

Public Property ScrollPosition As Double

Property Value

A double value.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.Shape Property

TreeViewNode.Shape Property
[image]

Gets or sets the shape of the table's outline.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SimpleShape Shape { get; set; }

Visual Basic [image] Copy Code

Public Property Shape As SimpleShape

Property Value

A member of the SimpleShape enumeration. The default is Rectangle.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNode.TextFormat Property

TreeViewNode.TextFormat Property
[image]

Gets or sets the alignment of texts displayed inside this shape node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TextFormat As StringFormat

Property Value

An instance of the StringFormat class.

Remarks

Use this property to specify the wrapping mode and alignment of the text that is contained in nodes.

See Also

TreeViewNode Members
TreeViewNode Class


MindFusion.Diagramming.TreeViewNodeStyle Class

TreeViewNodeStyle Class
[image]

Represents a reusable set of properties that define the appearance of tree view nodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeViewNodeStyle : DiagramNodeStyle

Visual Basic [image] Copy Code

Public Class TreeViewNodeStyle
Inherits DiagramNodeStyle

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Style
MindFusion.Diagramming.DiagramItemStyle
MindFusion.Diagramming.DiagramNodeStyle
MindFusion.Diagramming.TreeViewNodeStyle

See Also

TreeViewNodeStyle Members


MindFusion.Diagramming.TreeViewNodeStyle Members

TreeViewNodeStyle Members
Constructors Properties Methods Events
[image]

Represents a reusable set of properties that define the appearance of tree view nodes.

The following tables list the members exposed by the TreeViewNodeStyle type.

Public Constructors

Name | Description
TreeViewNodeStyle | Initializes a new instance of the TreeViewNodeStyle class.

Public Properties

Name | Description
Brush | Gets or sets the brush used to fill the interior of the item. (Inherited from DiagramItemStyle.)
Effects | Gets a list of the effects applied to the node. (Inherited from DiagramNodeStyle.)
FontFamily | Gets or sets the font family of the item text. (Inherited from DiagramItemStyle.)
FontSize | Gets or sets the font size of the item text. (Inherited from DiagramItemStyle.)
FontStyle | Gets or sets the font style of the item text. (Inherited from DiagramItemStyle.)
ShadowBrush | Gets or sets the brush used to paint the shadow of the item. (Inherited from DiagramItemStyle.)
Stroke | Gets or sets the brush used to paint the outline of the item. (Inherited from DiagramItemStyle.)
StrokeDashStyle | Gets or sets the pattern of dashes and gaps used to outline items. (Inherited from DiagramItemStyle.)
StrokeThickness | Gets or sets the thickness of the item's outline, expressed in the current units of measure. (Inherited from DiagramItemStyle.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItemStyle.)

Public Methods

Name | Description
GetProperties | Gets all properties in the style. (Inherited from Style.)
GetProperty | Returns the property with the specified name, if any. (Inherited from Style.)
RegisterType | Associates a type with an alias. (Inherited from Style.)

Protected Methods

Name | Description
GetValue | Gets the value of the specified property. (Inherited from Style.)
IsPropertySet | Checks whether the specified property has a value. (Inherited from Style.)
LoadFromJson | Loads the style content from a JsonObject. (Inherited from DiagramNodeStyle.)
LoadFromXml | Loads the style content from an XML element. (Inherited from Style.)
OnPropertyChanged | Raises the PropertyChanged event. (Inherited from Style.)
RegisterProperty | Registers a new property with the specified name and type. (Inherited from Style.)
SaveToJson | Saves the style content into a JsonObject. (Inherited from DiagramNodeStyle.)
SaveToXml | Saves the style content into an XML element. (Inherited from Style.)
SetValue | Sets the value of the specified property. (Inherited from Style.)
UnsetValue | Clears the value of the specified property. (Inherited from Style.)

Public Events

Name | Description
PropertyChanged | Raised when any of the registered style properties has changed. (Inherited from Style.)

See Also

TreeViewNodeStyle Class


MindFusion.Diagramming.TreeViewNodeStyle Constructor

TreeViewNodeStyle Constructor
[image]

Initializes a new instance of the TreeViewNodeStyle class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNodeStyle ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeViewNodeStyle Class


MindFusion.Diagramming.UnitType Enumeration

UnitType Enumeration
[image]

Defines values that indicate whether point positions are specified in percentage, or in absolute units relative to the node's top-left corner.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum UnitType

Visual Basic [image] Copy Code

Public Enum UnitType

Members

Member name | Description
Fixed | Point coordinates designate fixed offset from the node's top-left corner.
Percentage | Point coordinates are specified as percentage of the node's size.

See Also


MindFusion.Diagramming.VisitNode Delegate

VisitNode Delegate
[image]

Defines the prototype for methods called by VisitNodes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate bool VisitNode (
DiagramNode node,
DiagramItem relatedItem
)

Visual Basic [image] Copy Code

Public Delegate Function VisitNode( _
node As DiagramNode, _
relatedItem As DiagramItem _
) As Boolean

Parameters

node

relatedItem

Return Value

See Also


MindFusion.Diagramming.VisualizationPosition Enumeration

VisualizationPosition Enumeration
[image]

Specifies the alignment of the radial menu items relative to the menu center.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum VisualizationPosition

Visual Basic [image] Copy Code

Public Enum VisualizationPosition

Members

Member name | Description
Bottom | Indicates that the menu items are aligned below the menu center.
Left | Indicates that the menu items are aligned to the left of the menu center.
Right | Indicates that the menu items are aligned to the right of the menu center.
Top | Indicates that the menu items are aligned above the menu center.

See Also


MindFusion.Diagramming.XmlPersistContext Class

XmlPersistContext Class
[image]

Contains methods that can help you serialize and deserialize MindFusion.Diagramming for .NET MAUI items to and from XML documents.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class XmlPersistContext

Visual Basic [image] Copy Code

Public Class XmlPersistContext

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.XmlPersistContext

See Also

XmlPersistContext Members


MindFusion.Diagramming.XmlPersistContext Members

XmlPersistContext Members
Constructors Fields Properties Methods
[image]

Contains methods that can help you serialize and deserialize MindFusion.Diagramming for .NET MAUI items to and from XML documents.

The following tables list the members exposed by the XmlPersistContext type.

Public Constructors

Name | Description
XmlPersistContext | Initializes a new instance of the XmlPersistContext class.

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
Diagram | Gets the underlying diagram object.
FileVersion | Gets the format revision number for the file being currently serialized.
IncludeUnalteredProperties | Gets or sets a value specifies whether properties that have their default value should be serialized to XML.
XmlDocument | Gets the underlying XML document.

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node to another node.
ReadAnchorPattern | Reads an AnchorPattern with the specified name.
ReadBool | Overloaded. Reads a boolean value with a specified name.
ReadBrush | Overloaded. Reads a Brush object with a specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Overloaded. Reads a color with a specified name.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Overloaded. Reads a double value with a specified name.
ReadDoubleArray | Reads a double array with the specified name.
ReadEffect | Overloaded. Reads a NodeEffect object with the specified name.
ReadEnum | Overloaded. Reads an enum value with a specified name.
ReadFloat | Overloaded. Reads a float value with a specified name.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Overloaded. Reads a Font object with a specified name.
ReadGroup | Reads a group object with the specified name.
ReadHashtable | Reads a hash or traits table object with the specified name.
ReadImage | Reads an ImageSource object with the specified name.
ReadInt | Overloaded. Reads an integer value with the specified name.
ReadItemReference | Overloaded. Reads an item reference from an element.
ReadLong | Reads a long value with the specified name.
ReadNodeConstraints | Reads a NodeConstraints object with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Overloaded. Reads a Pen object with a specified name.
ReadPoint | Overloaded. Reads a Point object.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadPointCoordinates | Reads a List<PointF> object with the specified name.
ReadRectangle | Reads a Rectangle object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShape | Reads a Shape object with the specified name.
ReadShort | Overloaded. Reads a short value with a specified name.
ReadSize | Reads a Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded. Reads a string value with the specified name.
ReadStringFormat | Overloaded. Reads a StringFormat object with the specified name.
ReadStyle | Reads a Style object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadTheme | Reads a Theme object with the specified name.
ReadThickness | Reads a Thickness object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
SelectNode | Returns the child node with the specified name.
SelectNodes | Returns the child nodes with the specified name.
WriteAnchorPattern | Writes the specified anchor pattern.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteDoubleArray | Writes the specified array.
WriteEffect | Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteGroup | Writes the specified group object.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteImageAsync | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteItemReference | Writes a reference to the specified item with the specified name.
WriteLong | Writes a long value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePoint | Overloaded. Writes a Point object.
WritePointCollection | Writes the specified point collection.
WritePointCoordinates | Writes the specified List<PointF>.
WriteRectangle | Writes a Rectangle with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShape | Writes the specified shape with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSize | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteStyle | Writes a reference to the specified style. The style is registered within the internal hashtable for subsequent serialization.
WriteTag | Writes the specified tag of the specified object.
WriteTheme | Writes the specified Theme object.
WriteThickness | Writes a Thickness with the specified name.
WriteTraits | Writes the specified traits hashtable.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Fields

XmlPersistContext Fields
[image]

Public Fields

Name | Description
LatestFormat | Specifies the latest file format revision number.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.LatestFormat Field

XmlPersistContext.LatestFormat Field
[image]

Specifies the latest file format revision number.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static int LatestFormat

Visual Basic [image] Copy Code

Public Shared LatestFormat As Integer

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Constructor

XmlPersistContext Constructor
[image]

Initializes a new instance of the XmlPersistContext class.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XmlPersistContext (
Diagram diagram,
XDocument document,
int fileVersion
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
document As XDocument, _
fileVersion As Integer _
)

Parameters

diagram

The Diagram that will be serialized or deserialized.

document

The associated XDocument.

fileVersion

Specifies the current file format number.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Methods

XmlPersistContext Methods
[image]

Public Methods

Name | Description
AddChildElement | Overloaded. Adds a new child node to another node.
ReadAnchorPattern | Reads an AnchorPattern with the specified name.
ReadBool | Overloaded. Reads a boolean value with a specified name.
ReadBrush | Overloaded. Reads a Brush object with a specified name.
ReadByte | Reads a byte value with the specified name.
ReadChar | Reads a char value with the specified name.
ReadColor | Overloaded. Reads a color with a specified name.
ReadColorArray | Reads a color array with the specified name.
ReadDecimal | Reads a decimal value with the specified name.
ReadDouble | Overloaded. Reads a double value with a specified name.
ReadDoubleArray | Reads a double array with the specified name.
ReadEffect | Overloaded. Reads a NodeEffect object with the specified name.
ReadEnum | Overloaded. Reads an enum value with a specified name.
ReadFloat | Overloaded. Reads a float value with a specified name.
ReadFloatArray | Reads a float array with the specified name.
ReadFont | Overloaded. Reads a Font object with a specified name.
ReadGroup | Reads a group object with the specified name.
ReadHashtable | Reads a hash or traits table object with the specified name.
ReadImage | Reads an ImageSource object with the specified name.
ReadInt | Overloaded. Reads an integer value with the specified name.
ReadItemReference | Overloaded. Reads an item reference from an element.
ReadLong | Reads a long value with the specified name.
ReadNodeConstraints | Reads a NodeConstraints object with the specified name.
ReadObject | Reads an object with the specified name.
ReadPen | Overloaded. Reads a Pen object with a specified name.
ReadPoint | Overloaded. Reads a Point object.
ReadPointCollection | Reads a PointCollection object with the specified name.
ReadPointCoordinates | Reads a List<PointF> object with the specified name.
ReadRectangle | Reads a Rectangle object with the specified name.
ReadSByte | Reads a 8-bit signed integer value with the specified name.
ReadShape | Reads a Shape object with the specified name.
ReadShort | Overloaded. Reads a short value with a specified name.
ReadSize | Reads a Size object with the specified name.
ReadStream | Reads a stream with the specified name.
ReadString | Overloaded. Reads a string value with the specified name.
ReadStringFormat | Overloaded. Reads a StringFormat object with the specified name.
ReadStyle | Reads a Style object with the specified name.
ReadTag | Reads the specified tag for the specified object.
ReadTheme | Reads a Theme object with the specified name.
ReadThickness | Reads a Thickness object with the specified name.
ReadUInt | Reads an unsigned integer value with the specified name.
ReadULong | Reads an unsigned long value with the specified name.
ReadUShort | Reads an unsigned short value with the specified name.
SelectNode | Returns the child node with the specified name.
SelectNodes | Returns the child nodes with the specified name.
WriteAnchorPattern | Writes the specified anchor pattern.
WriteBool | Writes a boolean value with the specified name.
WriteBrush | Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.
WriteByte | Write a byte value with the specified name.
WriteChar | Write a char value with the specified name.
WriteColor | Writes the specified color.
WriteColorArray | Writes the specified array.
WriteDecimal | Write a decimal value with the specified name.
WriteDouble | Writes a double value with the specified name.
WriteDoubleArray | Writes the specified array.
WriteEffect | Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.
WriteEnum | Writes the specified enum value.
WriteFloat | Writes a float value with the specified name.
WriteFloatArray | Writes the specified array.
WriteFont | Writes the specified font.
WriteGroup | Writes the specified group object.
WriteHashtable | Writes the specified hashtable.
WriteImage | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteImageAsync | Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.
WriteInt | Writes an integer value with the specified name.
WriteItemReference | Writes a reference to the specified item with the specified name.
WriteLong | Writes a long value with the specified name.
WriteObject | Writes the specified object under the specified name.
WritePen | Writes the specified pen.
WritePoint | Overloaded. Writes a Point object.
WritePointCollection | Writes the specified point collection.
WritePointCoordinates | Writes the specified List<PointF>.
WriteRectangle | Writes a Rectangle with the specified name.
WriteSByte | Write a 8-bit signed integer value with the specified name.
WriteShape | Writes the specified shape with the specified name.
WriteShort | Writes a short value with the specified name.
WriteSize | Writes a Size with the specified name.
WriteStream | Writes the specified stream.
WriteString | Writes a string value with the specified name.
WriteStringFormat | Writes the specified StringFormat object.
WriteStyle | Writes a reference to the specified style. The style is registered within the internal hashtable for subsequent serialization.
WriteTag | Writes the specified tag of the specified object.
WriteTheme | Writes the specified Theme object.
WriteThickness | Writes a Thickness with the specified name.
WriteTraits | Writes the specified traits hashtable.
WriteUInt | Writes an unsigned integer value with the specified name.
WriteULong | Writes an unsigned long value with the specified name.
WriteUShort | Writes an unsigned short value with the specified name.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method

XmlPersistContext.AddChildElement Method
[image]

Adds a new child node to another node.

Overload List

Name | Description
XmlPersistContext.AddChildElement (String, XElement) | Adds a new child node with the specified name to the specified parent node.
XmlPersistContext.AddChildElement (String, XElement, String) | Adds a new child node with the specified name and value to the specified parent node.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method (String, XElement)

XmlPersistContext.AddChildElement Method (String, XElement)
See Also
[image]

Adds a new child node with the specified name to the specified parent node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement AddChildElement (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

elementName

parentElement

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.AddChildElement Method (String, XElement, String)

XmlPersistContext.AddChildElement Method (String, XElement, String)
See Also
[image]

Adds a new child node with the specified name and value to the specified parent node.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement AddChildElement (
string elementName,
XElement parentElement,
string innerText
)

Visual Basic [image] Copy Code

Public Function AddChildElement( _
elementName As String, _
parentElement As XElement, _
innerText As String _
) As XElement

Parameters

elementName

parentElement

innerText

Return Value

See Also

AddChildElement Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadAnchorPattern Method

XmlPersistContext.ReadAnchorPattern Method
[image]

Reads an AnchorPattern with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnchorPattern ReadAnchorPattern (
string elementName,
XElement parentElement,
bool standalone
)

Visual Basic [image] Copy Code

Public Function ReadAnchorPattern( _
elementName As String, _
parentElement As XElement, _
standalone As Boolean _
) As AnchorPattern

Parameters

elementName

parentElement

standalone

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBool Method

XmlPersistContext.ReadBool Method
[image]

Reads a boolean value with a specified name.

Overload List

Name | Description
XmlPersistContext.ReadBool (String, XElement) | Reads a boolean value with the specified name.
XmlPersistContext.ReadBool (String, XElement, Boolean) | Reads a boolean value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBool Method (String, XElement)

XmlPersistContext.ReadBool Method (String, XElement)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XElement _
) As Boolean

Parameters

elementName

parentElement

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBool Method (String, XElement, Boolean)

XmlPersistContext.ReadBool Method (String, XElement, Boolean)
See Also
[image]

Reads a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReadBool (
string elementName,
XElement parentElement,
bool defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBool( _
elementName As String, _
parentElement As XElement, _
defaultValue As Boolean _
) As Boolean

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadBool Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBrush Method

XmlPersistContext.ReadBrush Method
[image]

Reads a Brush object with a specified name.

Overload List

Name | Description
XmlPersistContext.ReadBrush (String, XElement) | Reads a Brush object with the specified name.
XmlPersistContext.ReadBrush (String, XElement, Brush) | Reads a Brush object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBrush Method (String, XElement)

XmlPersistContext.ReadBrush Method (String, XElement)
See Also
[image]

Reads a Brush object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As String, _
parentElement As XElement _
) As Brush

Parameters

elementName

parentElement

Return Value

See Also

ReadBrush Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadBrush Method (String, XElement, Brush)

XmlPersistContext.ReadBrush Method (String, XElement, Brush)
See Also
[image]

Reads a Brush object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Brush ReadBrush (
string elementName,
XElement parentElement,
Brush defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
elementName As String, _
parentElement As XElement, _
defaultValue As Brush _
) As Brush

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadBrush Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadByte Method

XmlPersistContext.ReadByte Method
[image]

Reads a byte value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public byte ReadByte (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadByte( _
elementName As String, _
parentElement As XElement _
) As Byte

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadChar Method

XmlPersistContext.ReadChar Method
[image]

Reads a char value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public char ReadChar (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadChar( _
elementName As String, _
parentElement As XElement _
) As Char

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadColor Method

XmlPersistContext.ReadColor Method
[image]

Reads a color with a specified name.

Overload List

Name | Description
XmlPersistContext.ReadColor (String, XElement) | Reads a color with the specified name.
XmlPersistContext.ReadColor (String, XElement, Color) | Reads a color with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadColor Method (String, XElement)

XmlPersistContext.ReadColor Method (String, XElement)
See Also
[image]

Reads a color with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XElement _
) As Color

Parameters

elementName

parentElement

Return Value

See Also

ReadColor Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadColor Method (String, XElement, Color)

XmlPersistContext.ReadColor Method (String, XElement, Color)
See Also
[image]

Reads a color with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color ReadColor (
string elementName,
XElement parentElement,
Color defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
elementName As String, _
parentElement As XElement, _
defaultValue As Color _
) As Color

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadColor Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadColorArray Method

XmlPersistContext.ReadColorArray Method
[image]

Reads a color array with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color[] ReadColorArray (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadColorArray( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As Color()

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDecimal Method

XmlPersistContext.ReadDecimal Method
[image]

Reads a decimal value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public decimal ReadDecimal (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDecimal( _
elementName As String, _
parentElement As XElement _
) As Decimal

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDouble Method

XmlPersistContext.ReadDouble Method
[image]

Reads a double value with a specified name.

Overload List

Name | Description
XmlPersistContext.ReadDouble (String, XElement) | Reads a double value with the specified name.
XmlPersistContext.ReadDouble (String, XElement, Double) | Reads a double value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDouble Method (String, XElement)

XmlPersistContext.ReadDouble Method (String, XElement)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XElement _
) As Double

Parameters

elementName

parentElement

Return Value

See Also

ReadDouble Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDouble Method (String, XElement, Double)

XmlPersistContext.ReadDouble Method (String, XElement, Double)
See Also
[image]

Reads a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ReadDouble (
string elementName,
XElement parentElement,
double defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadDouble( _
elementName As String, _
parentElement As XElement, _
defaultValue As Double _
) As Double

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadDouble Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadDoubleArray Method

XmlPersistContext.ReadDoubleArray Method
[image]

Reads a double array with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double[] ReadDoubleArray (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadDoubleArray( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As Double()

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEffect Method

XmlPersistContext.ReadEffect Method
[image]

Reads a NodeEffect object with the specified name.

Overload List

Name | Description
XmlPersistContext.ReadEffect (String, XElement) | Reads a NodeEffect object with the specified name.
XmlPersistContext.ReadEffect (XElement) | Reads a NodeEffect object from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEffect Method (String, XElement)

XmlPersistContext.ReadEffect Method (String, XElement)
See Also
[image]

Reads a NodeEffect object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEffect ReadEffect (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
elementName As String, _
parentElement As XElement _
) As NodeEffect

Parameters

elementName

parentElement

Return Value

See Also

ReadEffect Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEffect Method (XElement)

XmlPersistContext.ReadEffect Method (XElement)
See Also
[image]

Reads a NodeEffect object from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeEffect ReadEffect (
XElement element
)

Visual Basic [image] Copy Code

Public Function ReadEffect( _
element As XElement _
) As NodeEffect

Parameters

element

Return Value

See Also

ReadEffect Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method

XmlPersistContext.ReadEnum Method
[image]

Reads an enum value with a specified name.

Overload List

Name | Description
XmlPersistContext.ReadEnum (String, XElement) | Reads an enum value with the specified name.
XmlPersistContext.ReadEnum (String, XElement, Object) | Reads an enum value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method (String, XElement)

XmlPersistContext.ReadEnum Method (String, XElement)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadEnum Method (String, XElement, Object)

XmlPersistContext.ReadEnum Method (String, XElement, Object)
See Also
[image]

Reads an enum value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadEnum (
string elementName,
XElement parentElement,
Object defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
elementName As String, _
parentElement As XElement, _
defaultValue As Object _
) As Object

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadEnum Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method

XmlPersistContext.ReadFloat Method
[image]

Reads a float value with a specified name.

Overload List

Name | Description
XmlPersistContext.ReadFloat (String, XElement) | Reads a float value with the specified name.
XmlPersistContext.ReadFloat (String, XElement, Single) | Reads a float value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method (String, XElement)

XmlPersistContext.ReadFloat Method (String, XElement)
See Also
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ReadFloat (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XElement _
) As Single

Parameters

elementName

parentElement

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloat Method (String, XElement, Single)

XmlPersistContext.ReadFloat Method (String, XElement, Single)
See Also
[image]

Reads a float value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float ReadFloat (
string elementName,
XElement parentElement,
float defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadFloat( _
elementName As String, _
parentElement As XElement, _
defaultValue As Single _
) As Single

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadFloat Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFloatArray Method

XmlPersistContext.ReadFloatArray Method
[image]

Reads a float array with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public float[] ReadFloatArray (
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFloatArray( _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As Single()

Parameters

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFont Method

XmlPersistContext.ReadFont Method
[image]

Reads a Font object with a specified name.

Overload List

Name | Description
XmlPersistContext.ReadFont (String, XElement) | Reads a Font object with the specified name.
XmlPersistContext.ReadFont (String, XElement, Nullable(Font)) | Reads a Font object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFont Method (String, XElement)

XmlPersistContext.ReadFont Method (String, XElement)
See Also
[image]

Reads a Font object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Font> ReadFont (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
elementName As String, _
parentElement As XElement _
) As Nullable(Of Font)

Parameters

elementName

parentElement

Return Value

See Also

ReadFont Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadFont Method (String, XElement, Nullable(Font))

XmlPersistContext.ReadFont Method (String, XElement, Nullable(Font))
See Also
[image]

Reads a Font object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Font> ReadFont (
string elementName,
XElement parentElement,
Nullable<Font> defaultFont
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
elementName As String, _
parentElement As XElement, _
defaultFont As Nullable(Of Font) _
) As Nullable(Of Font)

Parameters

elementName

parentElement

defaultFont

Return Value

See Also

ReadFont Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadGroup Method

XmlPersistContext.ReadGroup Method
[image]

Reads a group object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ReadGroup (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Sub ReadGroup( _
elementName As String, _
parentElement As XElement _
)

Parameters

elementName

parentElement

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadHashtable Method

XmlPersistContext.ReadHashtable Method
[image]

Reads a hash or traits table object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<Object, Object> ReadHashtable (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadHashtable( _
elementName As String, _
parentElement As XElement _
) As Dictionary(Of Object, Object)

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadImage Method

XmlPersistContext.ReadImage Method
[image]

Reads an ImageSource object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ImageSource ReadImage (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadImage( _
elementName As String, _
parentElement As XElement _
) As ImageSource

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadInt Method

XmlPersistContext.ReadInt Method
[image]

Reads an integer value with the specified name.

Overload List

Name | Description
XmlPersistContext.ReadInt (String, XElement) | Reads an integer value with the specified name.
XmlPersistContext.ReadInt (String, XElement, Int32) | Reads an integer value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadInt Method (String, XElement)

XmlPersistContext.ReadInt Method (String, XElement)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XElement _
) As Integer

Parameters

elementName

parentElement

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadInt Method (String, XElement, Int32)

XmlPersistContext.ReadInt Method (String, XElement, Int32)
See Also
[image]

Reads an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ReadInt (
string elementName,
XElement parentElement,
int defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadInt( _
elementName As String, _
parentElement As XElement, _
defaultValue As Integer _
) As Integer

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadInt Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method

XmlPersistContext.ReadItemReference Method
[image]

Reads an item reference from an element.

Overload List

Name | Description
XmlPersistContext.ReadItemReference (String, XElement) | Reads a reference to the item with the specified name.
XmlPersistContext.ReadItemReference (XElement) | Reads an item reference from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method (String, XElement)

XmlPersistContext.ReadItemReference Method (String, XElement)
See Also
[image]

Reads a reference to the item with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem ReadItemReference (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadItemReference( _
elementName As String, _
parentElement As XElement _
) As DiagramItem

Parameters

elementName

parentElement

Return Value

See Also

ReadItemReference Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadItemReference Method (XElement)

XmlPersistContext.ReadItemReference Method (XElement)
See Also
[image]

Reads an item reference from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem ReadItemReference (
XElement itemElement
)

Visual Basic [image] Copy Code

Public Function ReadItemReference( _
itemElement As XElement _
) As DiagramItem

Parameters

itemElement

Return Value

See Also

ReadItemReference Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadLong Method

XmlPersistContext.ReadLong Method
[image]

Reads a long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public long ReadLong (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadLong( _
elementName As String, _
parentElement As XElement _
) As Long

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadNodeConstraints Method

XmlPersistContext.ReadNodeConstraints Method
[image]

Reads a NodeConstraints object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public NodeConstraints ReadNodeConstraints (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadNodeConstraints( _
elementName As String, _
parentElement As XElement _
) As NodeConstraints

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadObject Method

XmlPersistContext.ReadObject Method
[image]

Reads an object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadObject (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPen Method

XmlPersistContext.ReadPen Method
[image]

Reads a Pen object with a specified name.

Overload List

Name | Description
XmlPersistContext.ReadPen (String, XElement) | Reads a Pen object with the specified name.
XmlPersistContext.ReadPen (String, XElement, Pen) | Reads a Pen object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPen Method (String, XElement)

XmlPersistContext.ReadPen Method (String, XElement)
See Also
[image]

Reads a Pen object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ReadPen (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
elementName As String, _
parentElement As XElement _
) As Pen

Parameters

elementName

parentElement

Return Value

See Also

ReadPen Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPen Method (String, XElement, Pen)

XmlPersistContext.ReadPen Method (String, XElement, Pen)
See Also
[image]

Reads a Pen object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pen ReadPen (
string elementName,
XElement parentElement,
Pen defaultPen
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
elementName As String, _
parentElement As XElement, _
defaultPen As Pen _
) As Pen

Parameters

elementName

parentElement

defaultPen

Return Value

See Also

ReadPen Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPoint Method

XmlPersistContext.ReadPoint Method
[image]

Reads a Point object.

Overload List

Name | Description
XmlPersistContext.ReadPoint (String, XElement) | Reads a Point object with the specified name.
XmlPersistContext.ReadPoint (XElement) | Reads a Point object from the specified element.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPoint Method (String, XElement)

XmlPersistContext.ReadPoint Method (String, XElement)
See Also
[image]

Reads a Point object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point ReadPoint (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPoint( _
elementName As String, _
parentElement As XElement _
) As Point

Parameters

elementName

parentElement

Return Value

See Also

ReadPoint Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPoint Method (XElement)

XmlPersistContext.ReadPoint Method (XElement)
See Also
[image]

Reads a Point object from the specified element.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point ReadPoint (
XElement element
)

Visual Basic [image] Copy Code

Public Function ReadPoint( _
element As XElement _
) As Point

Parameters

element

Return Value

See Also

ReadPoint Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPointCollection Method

XmlPersistContext.ReadPointCollection Method
[image]

Reads a PointCollection object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PointCollection ReadPointCollection (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointCollection( _
elementName As String, _
parentElement As XElement _
) As PointCollection

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadPointCoordinates Method

XmlPersistContext.ReadPointCoordinates Method
[image]

Reads a List<PointF> object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Point> ReadPointCoordinates (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadPointCoordinates( _
elementName As String, _
parentElement As XElement _
) As List(Of Point)

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadRectangle Method

XmlPersistContext.ReadRectangle Method
[image]

Reads a Rectangle object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect ReadRectangle (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadRectangle( _
elementName As String, _
parentElement As XElement _
) As Rect

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadSByte Method

XmlPersistContext.ReadSByte Method
[image]

Reads a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sbyte ReadSByte (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSByte( _
elementName As String, _
parentElement As XElement _
) As SByte

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShape Method

XmlPersistContext.ReadShape Method
[image]

Reads a Shape object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Shape ReadShape (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShape( _
elementName As String, _
parentElement As XElement _
) As Shape

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShort Method

XmlPersistContext.ReadShort Method
[image]

Reads a short value with a specified name.

Overload List

Name | Description
XmlPersistContext.ReadShort (String, XElement) | Reads a short value with the specified name.
XmlPersistContext.ReadShort (String, XElement, Int16) | Reads a short value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShort Method (String, XElement)

XmlPersistContext.ReadShort Method (String, XElement)
See Also
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XElement _
) As Short

Parameters

elementName

parentElement

Return Value

See Also

ReadShort Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadShort Method (String, XElement, Int16)

XmlPersistContext.ReadShort Method (String, XElement, Int16)
See Also
[image]

Reads a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public short ReadShort (
string elementName,
XElement parentElement,
short defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadShort( _
elementName As String, _
parentElement As XElement, _
defaultValue As Short _
) As Short

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadShort Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadSize Method

XmlPersistContext.ReadSize Method
[image]

Reads a Size object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size ReadSize (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadSize( _
elementName As String, _
parentElement As XElement _
) As Size

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStream Method

XmlPersistContext.ReadStream Method
[image]

Reads a stream with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Stream ReadStream (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStream( _
elementName As String, _
parentElement As XElement _
) As Stream

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadString Method

XmlPersistContext.ReadString Method
[image]

Reads a string value with the specified name.

Overload List

Name | Description
XmlPersistContext.ReadString (String, XElement) | Reads a string value with the specified name.
XmlPersistContext.ReadString (String, XElement, String) | Reads a string value with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadString Method (String, XElement)

XmlPersistContext.ReadString Method (String, XElement)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XElement _
) As String

Parameters

elementName

parentElement

Return Value

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadString Method (String, XElement, String)

XmlPersistContext.ReadString Method (String, XElement, String)
See Also
[image]

Reads a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string ReadString (
string elementName,
XElement parentElement,
string defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadString( _
elementName As String, _
parentElement As XElement, _
defaultValue As String _
) As String

Parameters

elementName

parentElement

defaultValue

Return Value

See Also

ReadString Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStringFormat Method

XmlPersistContext.ReadStringFormat Method
[image]

Reads a StringFormat object with the specified name.

Overload List

Name | Description
XmlPersistContext.ReadStringFormat (String, XElement) | Reads a StringFormat object with the specified name.
XmlPersistContext.ReadStringFormat (String, XElement, StringFormat) | Reads a StringFormat object with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStringFormat Method (String, XElement)

XmlPersistContext.ReadStringFormat Method (String, XElement)
See Also
[image]

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
elementName As String, _
parentElement As XElement _
) As StringFormat

Parameters

elementName

parentElement

Return Value

See Also

ReadStringFormat Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStringFormat Method (String, XElement, StringFormat)

XmlPersistContext.ReadStringFormat Method (String, XElement, StringFormat)
See Also
[image]

Reads a StringFormat object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
string elementName,
XElement parentElement,
StringFormat defultFormat
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
elementName As String, _
parentElement As XElement, _
defultFormat As StringFormat _
) As StringFormat

Parameters

elementName

parentElement

defultFormat

Return Value

See Also

ReadStringFormat Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadStyle Method

XmlPersistContext.ReadStyle Method
[image]

Reads a Style object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style ReadStyle (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadStyle( _
elementName As String, _
parentElement As XElement _
) As Style

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadTag Method

XmlPersistContext.ReadTag Method
[image]

Reads the specified tag for the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object ReadTag (
Object item,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTag( _
item As Object, _
elementName As String, _
parentElement As XElement _
) As Object

Parameters

item

elementName

parentElement

Return Value

Remarks

Tags are read similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom deserialization through event handling.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadTheme Method

XmlPersistContext.ReadTheme Method
[image]

Reads a Theme object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Theme ReadTheme (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadTheme( _
elementName As String, _
parentElement As XElement _
) As Theme

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadThickness Method

XmlPersistContext.ReadThickness Method
[image]

Reads a Thickness object with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Thickness ReadThickness (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadThickness( _
elementName As String, _
parentElement As XElement _
) As Thickness

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadUInt Method

XmlPersistContext.ReadUInt Method
[image]

Reads an unsigned integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public uint ReadUInt (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUInt( _
elementName As String, _
parentElement As XElement _
) As UInteger

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadULong Method

XmlPersistContext.ReadULong Method
[image]

Reads an unsigned long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ulong ReadULong (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadULong( _
elementName As String, _
parentElement As XElement _
) As ULong

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ReadUShort Method

XmlPersistContext.ReadUShort Method
[image]

Reads an unsigned short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ushort ReadUShort (
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function ReadUShort( _
elementName As String, _
parentElement As XElement _
) As UShort

Parameters

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.SelectNode Method

XmlPersistContext.SelectNode Method
[image]

Returns the child node with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement SelectNode (
XElement parentElement,
string name
)

Visual Basic [image] Copy Code

Public Function SelectNode( _
parentElement As XElement, _
name As String _
) As XElement

Parameters

parentElement

The parent XML element.

name

A string specifying the name of the child node.

Return Value

An XElement corresponding to the child node.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.SelectNodes Method

XmlPersistContext.SelectNodes Method
[image]

Returns the child nodes with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerable<XElement> SelectNodes (
XElement parentElement,
string name
)

Visual Basic [image] Copy Code

Public Function SelectNodes( _
parentElement As XElement, _
name As String _
) As IEnumerable(Of XElement)

Parameters

parentElement

The parent XML element.

name

A string specifying the name of the child nodes.

Return Value

An enumerable containing the found child nodes.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteAnchorPattern Method

XmlPersistContext.WriteAnchorPattern Method
[image]

Writes the specified anchor pattern.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteAnchorPattern (
AnchorPattern anchorPattern,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteAnchorPattern( _
anchorPattern As AnchorPattern, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

anchorPattern

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteBool Method

XmlPersistContext.WriteBool Method
[image]

Writes a boolean value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteBool (
bool boolValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBool( _
boolValue As Boolean, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

boolValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteBrush Method

XmlPersistContext.WriteBrush Method
[image]

Writes a reference to the specified brush. The brush is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteBrush (
Brush brush,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteBrush( _
brush As Brush, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

brush

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteByte Method

XmlPersistContext.WriteByte Method
[image]

Write a byte value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteByte (
byte byteValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteByte( _
byteValue As Byte, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

byteValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteChar Method

XmlPersistContext.WriteChar Method
[image]

Write a char value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteChar (
char charValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteChar( _
charValue As Char, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

charValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteColor Method

XmlPersistContext.WriteColor Method
[image]

Writes the specified color.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteColor (
Color color,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColor( _
color As Color, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

color

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteColorArray Method

XmlPersistContext.WriteColorArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteColorArray (
Color[] array,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteColorArray( _
array() As Color, _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

array

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteDecimal Method

XmlPersistContext.WriteDecimal Method
[image]

Write a decimal value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteDecimal (
decimal decimalValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDecimal( _
decimalValue As Decimal, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

decimalValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteDouble Method

XmlPersistContext.WriteDouble Method
[image]

Writes a double value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteDouble (
double doubleValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDouble( _
doubleValue As Double, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

doubleValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteDoubleArray Method

XmlPersistContext.WriteDoubleArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteDoubleArray (
double[] array,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteDoubleArray( _
array() As Double, _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

array

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteEffect Method

XmlPersistContext.WriteEffect Method
[image]

Writes a reference to the specified effect. The effect is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteEffect (
NodeEffect effect,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEffect( _
effect As NodeEffect, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

effect

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteEnum Method

XmlPersistContext.WriteEnum Method
[image]

Writes the specified enum value.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteEnum (
Object enumValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
enumValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

enumValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFloat Method

XmlPersistContext.WriteFloat Method
[image]

Writes a float value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteFloat (
float floatValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloat( _
floatValue As Single, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

floatValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFloatArray Method

XmlPersistContext.WriteFloatArray Method
[image]

Writes the specified array.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteFloatArray (
float[] array,
string elementName,
string subElementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFloatArray( _
array() As Single, _
elementName As String, _
subElementName As String, _
parentElement As XElement _
) As XElement

Parameters

array

elementName

subElementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteFont Method

XmlPersistContext.WriteFont Method
[image]

Writes the specified font.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteFont (
Nullable<Font> font,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteFont( _
font As Nullable(Of Font), _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

font

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteGroup Method

XmlPersistContext.WriteGroup Method
[image]

Writes the specified group object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteGroup (
DiagramItem master,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteGroup( _
master As DiagramItem, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

master

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteHashtable Method

XmlPersistContext.WriteHashtable Method
[image]

Writes the specified hashtable.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteHashtable (
IDictionary hashtable,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteHashtable( _
hashtable As IDictionary, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

hashtable

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteImage Method

XmlPersistContext.WriteImage Method
[image]

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteImage (
ImageSource image,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteImage( _
image As ImageSource, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

image

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteImageAsync Method

XmlPersistContext.WriteImageAsync Method
[image]

Writes a reference to the specified image. The image is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Task<XElement> WriteImageAsync (
ImageSource image,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteImageAsync( _
image As ImageSource, _
elementName As String, _
parentElement As XElement _
) As Task(Of XElement)

Parameters

image

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteInt Method

XmlPersistContext.WriteInt Method
[image]

Writes an integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteInt (
int intValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteInt( _
intValue As Integer, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

intValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteItemReference Method

XmlPersistContext.WriteItemReference Method
[image]

Writes a reference to the specified item with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteItemReference (
DiagramItem item,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteItemReference( _
item As DiagramItem, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

item

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteLong Method

XmlPersistContext.WriteLong Method
[image]

Writes a long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteLong (
long longValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteLong( _
longValue As Long, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

longValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteObject Method

XmlPersistContext.WriteObject Method
[image]

Writes the specified object under the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteObject (
Object objectValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
objectValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

objectValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePen Method

XmlPersistContext.WritePen Method
[image]

Writes the specified pen.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WritePen (
Pen pen,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePen( _
pen As Pen, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

pen

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePoint Method

XmlPersistContext.WritePoint Method
[image]

Writes a Point object.

Overload List

Name | Description
XmlPersistContext.WritePoint (Double, Double, String, XElement) | Writes the specified Point under the specified name. The x and y components of the point are written as attributes.
XmlPersistContext.WritePoint (Point, String, XElement) | Writes a Point with the specified name.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePoint Method (Double, Double, String, XElement)

XmlPersistContext.WritePoint Method (Double, Double, String, XElement)
See Also
[image]

Writes the specified Point under the specified name. The x and y components of the point are written as attributes.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WritePoint (
double x,
double y,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePoint( _
x As Double, _
y As Double, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

x

y

elementName

parentElement

Return Value

See Also

WritePoint Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePoint Method (Point, String, XElement)

XmlPersistContext.WritePoint Method (Point, String, XElement)
See Also
[image]

Writes a Point with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WritePoint (
Point point,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePoint( _
point As Point, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

point

elementName

parentElement

Return Value

See Also

WritePoint Method Overload List
XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePointCollection Method

XmlPersistContext.WritePointCollection Method
[image]

Writes the specified point collection.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WritePointCollection (
PointCollection points,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointCollection( _
points As PointCollection, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

points

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WritePointCoordinates Method

XmlPersistContext.WritePointCoordinates Method
[image]

Writes the specified List<PointF>.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WritePointCoordinates (
List<Point> points,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WritePointCoordinates( _
points As List(Of Point), _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

points

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteRectangle Method

XmlPersistContext.WriteRectangle Method
[image]

Writes a Rectangle with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteRectangle (
Rect rectangle,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteRectangle( _
rectangle As Rect, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

rectangle

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteSByte Method

XmlPersistContext.WriteSByte Method
[image]

Write a 8-bit signed integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteSByte (
sbyte byteValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSByte( _
byteValue As SByte, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

byteValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteShape Method

XmlPersistContext.WriteShape Method
[image]

Writes the specified shape with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteShape (
Shape shape,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShape( _
shape As Shape, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

shape

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteShort Method

XmlPersistContext.WriteShort Method
[image]

Writes a short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteShort (
short shortValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteShort( _
shortValue As Short, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

shortValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteSize Method

XmlPersistContext.WriteSize Method
[image]

Writes a Size with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteSize (
Size size,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteSize( _
size As Size, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

size

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteStream Method

XmlPersistContext.WriteStream Method
[image]

Writes the specified stream.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteStream (
Stream stream,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStream( _
stream As Stream, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stream

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteString Method

XmlPersistContext.WriteString Method
[image]

Writes a string value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteString (
string stringValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteString( _
stringValue As String, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stringValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteStringFormat Method

XmlPersistContext.WriteStringFormat Method
[image]

Writes the specified StringFormat object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteStringFormat (
StringFormat stringFormat,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStringFormat( _
stringFormat As StringFormat, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

stringFormat

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteStyle Method

XmlPersistContext.WriteStyle Method
[image]

Writes a reference to the specified style. The style is registered within the internal hashtable for subsequent serialization.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteStyle (
Style style,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteStyle( _
style As Style, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

style

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteTag Method

XmlPersistContext.WriteTag Method
[image]

Writes the specified tag of the specified object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteTag (
Object item,
Object tagValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTag( _
item As Object, _
tagValue As Object, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

item

tagValue

elementName

parentElement

Return Value

Remarks

Tags are written similarly to arbitrary objects except that the client of the diagram is given a chance to perform custom serialization through event handling.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteTheme Method

XmlPersistContext.WriteTheme Method
[image]

Writes the specified Theme object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteTheme (
Theme theme,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTheme( _
theme As Theme, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

theme

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteThickness Method

XmlPersistContext.WriteThickness Method
[image]

Writes a Thickness with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteThickness (
Thickness thickness,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteThickness( _
thickness As Thickness, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

thickness

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteTraits Method

XmlPersistContext.WriteTraits Method
[image]

Writes the specified traits hashtable.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteTraits (
IDictionary traits,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteTraits( _
traits As IDictionary, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

traits

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteUInt Method

XmlPersistContext.WriteUInt Method
[image]

Writes an unsigned integer value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteUInt (
uint uintValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUInt( _
uintValue As UInteger, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

uintValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteULong Method

XmlPersistContext.WriteULong Method
[image]

Writes an unsigned long value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteULong (
ulong ulongValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteULong( _
ulongValue As ULong, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

ulongValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.WriteUShort Method

XmlPersistContext.WriteUShort Method
[image]

Writes an unsigned short value with the specified name.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XElement WriteUShort (
ushort ushortValue,
string elementName,
XElement parentElement
)

Visual Basic [image] Copy Code

Public Function WriteUShort( _
ushortValue As UShort, _
elementName As String, _
parentElement As XElement _
) As XElement

Parameters

ushortValue

elementName

parentElement

Return Value

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext Properties

XmlPersistContext Properties
[image]

Public Properties

Name | Description
ClassVersion | Gets the class version of the currently deserialized item.
Diagram | Gets the underlying diagram object.
FileVersion | Gets the format revision number for the file being currently serialized.
IncludeUnalteredProperties | Gets or sets a value specifies whether properties that have their default value should be serialized to XML.
XmlDocument | Gets the underlying XML document.

See Also

XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.ClassVersion Property

XmlPersistContext.ClassVersion Property
[image]

Gets the class version of the currently deserialized item.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ClassVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ClassVersion As Integer

Property Value

An integer value.

Remarks

This property is only useful when deserializing items.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.Diagram Property

XmlPersistContext.Diagram Property
[image]

Gets the underlying diagram object.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Diagram { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.FileVersion Property

XmlPersistContext.FileVersion Property
[image]

Gets the format revision number for the file being currently serialized.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int FileVersion { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property FileVersion As Integer

Property Value

An integer value.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.IncludeUnalteredProperties Property

XmlPersistContext.IncludeUnalteredProperties Property
[image]

Gets or sets a value specifies whether properties that have their default value should be serialized to XML.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IncludeUnalteredProperties { get; set; }

Visual Basic [image] Copy Code

Public Property IncludeUnalteredProperties As Boolean

Property Value

A boolean value.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.XmlPersistContext.XmlDocument Property

XmlPersistContext.XmlDocument Property
[image]

Gets the underlying XML document.

Namespace: MindFusion.Diagramming
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public XDocument XmlDocument { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property XmlDocument As XDocument

Property Value

A XDocument object.

See Also

XmlPersistContext Members
XmlPersistContext Class


MindFusion.Diagramming.Commands Namespace
Classes

Classes

Class | Description
AddItemCmd | Implements creation of new diagram items.
AddToContainerCmd | Undoable command that implements an addition of a node to a container.
ChangeItemCmd | Handles undo / redo of programmatic property changes.
Command | Represent an action that can be carried out on a diagram, and later undone or redone.
CommandCollection | A collection of commands.
CommandContext | The context of an executing command.
CommandList | Represents a read-only collection of Command objects.
CompositeCmd | Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.
ExpandHeaderRowCmd | Implements undo and redo of collapsing or expanding the header row of a table section.
ExpandItemCmd | Undoable command that implements expanding/collapsing trees of items.
ExpandTreeViewItemCmd | Implements support for undo of TreeViewItem collapse/expand operations.
FoldContainerCmd | Undoable command that implements scrolling of table rows.
ModifyItemCmd | Implements changes of item's size and position.
RedimTableCmd | Implements changes to the number of table's rows and columns.
RemoveFromContainerCmd | Undoable command that implements an addition of a node to a container.
RemoveItemCmd | Implements deletion of diagram items.
ScrollTableCmd | Implements scrolling of table's rows.
ScrollTreeViewCmd | Implements support for undo of TreeViewNode scroll operations.


MindFusion.Diagramming.Commands.AddItemCmd Class

AddItemCmd Class
Remarks See Also
[image]

Implements creation of new diagram items.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AddItemCmd : Command

Visual Basic [image] Copy Code

Public Class AddItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for .NET MAUI in response to users drawing new items or to programmatically calling the Add method of the diagram's Nodes or Links collections.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.AddItemCmd

See Also

AddItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd Members

AddItemCmd Members
Constructors Properties Methods
[image]

Implements creation of new diagram items.

The following tables list the members exposed by the AddItemCmd type.

Public Constructors

Name | Description
AddItemCmd | Initializes a new instance of the AddItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to the newly added item.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd Constructor

AddItemCmd Constructor
[image]

Initializes a new instance of the AddItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AddItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

See Also

AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd Methods

AddItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd.Execute Method

AddItemCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd.Redo Method

AddItemCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd.Undo Method

AddItemCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd Properties

AddItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to the newly added item.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddItemCmd.Item Property

AddItemCmd.Item Property
[image]

Gets a reference to the newly added item.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

AddItemCmd Members
AddItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd Class

AddToContainerCmd Class
[image]

Undoable command that implements an addition of a node to a container.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AddToContainerCmd : Command

Visual Basic [image] Copy Code

Public Class AddToContainerCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.AddToContainerCmd

See Also

AddToContainerCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd Members

AddToContainerCmd Members
Constructors Properties Methods
[image]

Undoable command that implements an addition of a node to a container.

The following tables list the members exposed by the AddToContainerCmd type.

Protected Constructors

Name | Description
AddToContainerCmd | Initializes a new instance of the AddToContainerCmd class.

Public Properties

Name | Description
Container | Gets the container node associated with the command.
Nodes | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative.
Redo | Redoes the command.
Undo | Undoes the command.

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd Constructor

AddToContainerCmd Constructor
[image]

Initializes a new instance of the AddToContainerCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected AddToContainerCmd (
ContainerNode container,
DiagramNodeCollection nodes,
bool interactive
)

Visual Basic [image] Copy Code

Protected New ( _
container As ContainerNode, _
nodes As DiagramNodeCollection, _
interactive As Boolean _
)

Parameters

container

nodes

interactive

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd Methods

AddToContainerCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative.
Redo | Redoes the command.
Undo | Undoes the command.

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Adopt Method

AddToContainerCmd.Adopt Method
[image]

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool Adopt (
Command command
)

Visual Basic [image] Copy Code

Protected Overrides Function Adopt( _
command As Command _
) As Boolean

Parameters

command

The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Execute Method

AddToContainerCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.IsContainerOf Method

AddToContainerCmd.IsContainerOf Method
[image]

Determines whether a command has been initiated by this command and should be treated as a derivative.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool IsContainerOf (
Command command
)

Visual Basic [image] Copy Code

Protected Overrides Function IsContainerOf( _
command As Command _
) As Boolean

Parameters

command

The Command for which to determine whether it is a derivative.

Return Value

true if the specified command should be considered a derivative; otherwise, false.

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Redo Method

AddToContainerCmd.Redo Method
[image]

Redoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Undo Method

AddToContainerCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd Properties

AddToContainerCmd Properties
[image]

Public Properties

Name | Description
Container | Gets the container node associated with the command.
Nodes | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Container Property

AddToContainerCmd.Container Property
[image]

Gets the container node associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode Container { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Container As ContainerNode

Property Value

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.AddToContainerCmd.Nodes Property

AddToContainerCmd.Nodes Property
[image]

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNodeCollection Nodes { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Nodes As DiagramNodeCollection

Property Value

See Also

AddToContainerCmd Members
AddToContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd Class

ChangeItemCmd Class
Remarks See Also
[image]

Handles undo / redo of programmatic property changes.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ChangeItemCmd : Command

Visual Basic [image] Copy Code

Public Class ChangeItemCmd
Inherits Command

Remarks

You would create an instance of this class in order to enable undo / redo of changes to item's properties. The constructor records the initial state of the item and the Execute method records the final state and adds the ChangeItemCmd object to the undo manager's history.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ChangeItemCmd

See Also

ChangeItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd Members

ChangeItemCmd Members
Constructors Properties Methods
[image]

Handles undo / redo of programmatic property changes.

The following tables list the members exposed by the ChangeItemCmd type.

Public Constructors

Name | Description
ChangeItemCmd | Initializes a new instance of the ChangeItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Overloaded.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd Constructor

ChangeItemCmd Constructor
[image]

Initializes a new instance of the ChangeItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ChangeItemCmd (
DiagramItem item,
string title
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem, _
title As String _
)

Parameters

item

title

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd Methods

ChangeItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Overloaded.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Execute Method

ChangeItemCmd.Execute Method
[image]

Overload List

Name | Description
ChangeItemCmd.Execute () | Executes the command, adding it to the command history.
ChangeItemCmd.Execute (Boolean) | Carries out the command action.

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Execute Method ()

ChangeItemCmd.Execute Method ()
See Also
[image]

Executes the command, adding it to the command history.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Execute ()

Visual Basic [image] Copy Code

Public Sub Execute ()

Remarks

Subcommands are executed or redone in the same order in which they were added to the composite, and are undone in the opposite order.

See Also

Execute Method Overload List
ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Execute Method (Boolean)

ChangeItemCmd.Execute Method (Boolean)
See Also
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

Execute Method Overload List
ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Redo Method

ChangeItemCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Undo Method

ChangeItemCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd Properties

ChangeItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ChangeItemCmd.Item Property

ChangeItemCmd.Item Property
[image]

Gets a reference to diagram item affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

ChangeItemCmd Members
ChangeItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command Class

Command Class
[image]

Represent an action that can be carried out on a diagram, and later undone or redone.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class Command

Visual Basic [image] Copy Code

Public MustInherit Class Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.AddItemCmd
MindFusion.Diagramming.Commands.AddToContainerCmd
MindFusion.Diagramming.Commands.ChangeItemCmd
MindFusion.Diagramming.Commands.CompositeCmd
MindFusion.Diagramming.Commands.ExpandHeaderRowCmd
MindFusion.Diagramming.Commands.ExpandItemCmd
MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd
MindFusion.Diagramming.Commands.FoldContainerCmd
MindFusion.Diagramming.Commands.ModifyItemCmd
MindFusion.Diagramming.Commands.RedimTableCmd
MindFusion.Diagramming.Commands.RemoveFromContainerCmd
MindFusion.Diagramming.Commands.RemoveItemCmd
MindFusion.Diagramming.Commands.ScrollTableCmd
MindFusion.Diagramming.Commands.ScrollTreeViewCmd

See Also

Command Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command Members

Command Members
Constructors Properties Methods
[image]

Represent an action that can be carried out on a diagram, and later undone or redone.

The following tables list the members exposed by the Command type.

Protected Constructors

Name | Description
Command | Initializes a new instance of the Command class.

Public Properties

Name | Description
Title | Gets or sets the text associated with the action.

Protected Properties

Name | Description
Context | Gets the command's context.
SubCommands | Gets a collection of all command objects contained within the composite one.

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command.

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out an action, usually changing the diagram in some way.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command Constructor

Command Constructor
[image]

Initializes a new instance of the Command class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Command (
string title
)

Visual Basic [image] Copy Code

Protected New ( _
title As String _
)

Parameters

title

See Also

Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command Methods

Command Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command.

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out an action, usually changing the diagram in some way.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative.
Redo | Repeats an action that has been undone.
Undo | Undoes an action, restoring the diagram to the state it was in before carrying out the action.

See Also

Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.AddSubCmd Method

Command.AddSubCmd Method
[image]

Adds an action to a composite command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void AddSubCmd (
Command cmd
)

Visual Basic [image] Copy Code

Public Sub AddSubCmd( _
cmd As Command _
)

Parameters

cmd

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Adopt Method

Command.Adopt Method
[image]

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool Adopt (
Command command
)

Visual Basic [image] Copy Code

Protected Overridable Function Adopt( _
command As Command _
) As Boolean

Parameters

command

The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Execute Method

Command.Execute Method
[image]

Carries out an action, usually changing the diagram in some way.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected MustOverride Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

Specifies whether undo/redo is enabled. If undo is disabled, the command won't be saved in undo history and will never be called to undo or redo itself. In such case you might choose to skip some housekeeping operations such as saving state variables for later undo/redo.

Remarks

Implement your action's logic here. You must not execute commands by calling this method - instead pass them to diagram's ExecuteCommand. ExecuteCommand calls Execute and if UndoEnabled is set to true, adds the command to the undo manager's history.

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.IsContainerOf Method

Command.IsContainerOf Method
[image]

Determines whether a command has been initiated by this command and should be treated as a derivative.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual bool IsContainerOf (
Command command
)

Visual Basic [image] Copy Code

Protected Overridable Function IsContainerOf( _
command As Command _
) As Boolean

Parameters

command

The Command for which to determine whether it is a derivative.

Return Value

true if the specified command should be considered a derivative; otherwise, false.

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Redo Method

Command.Redo Method
[image]

Repeats an action that has been undone.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void Redo ()

Visual Basic [image] Copy Code

Protected Overridable Sub Redo ()

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Undo Method

Command.Undo Method
[image]

Undoes an action, restoring the diagram to the state it was in before carrying out the action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void Undo ()

Visual Basic [image] Copy Code

Protected Overridable Sub Undo ()

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command Properties

Command Properties
[image]

Public Properties

Name | Description
Title | Gets or sets the text associated with the action.

Protected Properties

Name | Description
Context | Gets the command's context.
SubCommands | Gets a collection of all command objects contained within the composite one.

See Also

Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Context Property

Command.Context Property
[image]

Gets the command's context.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected CommandContext Context { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Context As CommandContext

Property Value

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.SubCommands Property

Command.SubCommands Property
[image]

Gets a collection of all command objects contained within the composite one.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected CommandCollection SubCommands { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property SubCommands As CommandCollection

Property Value

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.Command.Title Property

Command.Title Property
[image]

Gets or sets the text associated with the action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

Remarks

This text can be used to indicate to users what exactly will be undone or redone.

See Also

Command Members
Command Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Class

CommandCollection Class
[image]

A collection of commands.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CommandCollection : List<Command>

Visual Basic [image] Copy Code

Public Class CommandCollection
Inherits List(Of Command)

Inheritance Hierarchy

System.Object
System.Collections.Generic.List(Command)
MindFusion.Diagramming.Commands.CommandCollection

See Also

CommandCollection Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Members

CommandCollection Members
Constructors
[image]

A collection of commands.

The following tables list the members exposed by the CommandCollection type.

Public Constructors

Name | Description
CommandCollection | Overloaded. Initializes a new instance of the CommandCollection class.

See Also

CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Constructor

CommandCollection Constructor
[image]

Initializes a new instance of the CommandCollection class.

Overload List

Name | Description
CommandCollection () | Initializes a new instance of the CommandCollection class with the default initial capacity.
CommandCollection (Int32) | Initializes a new instance of the CommandCollection class with the specified initial capacity.

See Also

CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Constructor ()

CommandCollection Constructor ()
See Also
[image]

Initializes a new instance of the CommandCollection class with the default initial capacity.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CommandCollection ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CommandCollection Constructor Overload List
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandCollection Constructor (Int32)

CommandCollection Constructor (Int32)
See Also
[image]

Initializes a new instance of the CommandCollection class with the specified initial capacity.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CommandCollection (
int capacity
)

Visual Basic [image] Copy Code

Public New ( _
capacity As Integer _
)

Parameters

capacity

See Also

CommandCollection Constructor Overload List
CommandCollection Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandContext Class

CommandContext Class
[image]

The context of an executing command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CommandContext

Visual Basic [image] Copy Code

Public Class CommandContext

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.CommandContext

See Also

CommandContext Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandContext Members

CommandContext Members
Properties
[image]

The context of an executing command.

The following tables list the members exposed by the CommandContext type.

Public Properties

Name | Description
Document | Gets the document this command will operate on.

See Also

CommandContext Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandContext Properties

CommandContext Properties
[image]

Public Properties

Name | Description
Document | Gets the document this command will operate on.

See Also

CommandContext Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandContext.Document Property

CommandContext.Document Property
[image]

Gets the document this command will operate on.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Diagram Document { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Document As Diagram

Property Value

See Also

CommandContext Members
CommandContext Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList Class

CommandList Class
[image]

Represents a read-only collection of Command objects.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CommandList : ICollection, IEnumerable

Visual Basic [image] Copy Code

Public Class CommandList
Implements ICollection, IEnumerable

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.CommandList

See Also

CommandList Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList Members

CommandList Members
Constructors Properties Methods
[image]

Represents a read-only collection of Command objects.

The following tables list the members exposed by the CommandList type.

Public Constructors

Name | Description
CommandList | Initializes a new instance of the CommandList class.

Public Properties

Name | Description
Count | Gets the number of commands contained within the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
Item | Gets the command at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Methods

Name | Description
Contains | Determines whether the specified command is contained within the collection.
CopyTo | Copies a range of commands from the current collection to the specified array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator for the collection.
IndexOf | Returns the zero-based index of the specified command within the collection.

See Also

CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList Constructor

CommandList Constructor
[image]

Initializes a new instance of the CommandList class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CommandList (
CommandCollection innerCollection
)

Visual Basic [image] Copy Code

Public New ( _
innerCollection As CommandCollection _
)

Parameters

innerCollection

See Also

CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList Methods

CommandList Methods
[image]

Public Methods

Name | Description
Contains | Determines whether the specified command is contained within the collection.
CopyTo | Copies a range of commands from the current collection to the specified array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator for the collection.
IndexOf | Returns the zero-based index of the specified command within the collection.

See Also

CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.Contains Method

CommandList.Contains Method
[image]

Determines whether the specified command is contained within the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
Command value
)

Visual Basic [image] Copy Code

Public Function Contains( _
value As Command _
) As Boolean

Parameters

value

Return Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.CopyTo Method

CommandList.CopyTo Method
[image]

Copies a range of commands from the current collection to the specified array, starting at the specified index of the target array.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CopyTo (
Array array,
int index
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array As Array, _
index As Integer _
)

Parameters

array

index

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.GetEnumerator Method

CommandList.GetEnumerator Method
[image]

Returns an enumerator for the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerator GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator

Return Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.IndexOf Method

CommandList.IndexOf Method
[image]

Returns the zero-based index of the specified command within the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
Command value
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
value As Command _
) As Integer

Parameters

value

Return Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList Properties

CommandList Properties
[image]

Public Properties

Name | Description
Count | Gets the number of commands contained within the collection.
IsSynchronized | Gets a value indicating whether the access to the collection is synchronized.
Item | Gets the command at the specified index.
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.Count Property

CommandList.Count Property
[image]

Gets the number of commands contained within the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.IsSynchronized Property

CommandList.IsSynchronized Property
[image]

Gets a value indicating whether the access to the collection is synchronized.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsSynchronized { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsSynchronized As Boolean

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.Item Property

CommandList.Item Property
[image]

Gets the command at the specified index.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Command Item [
int index
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
index As Integer _
) As Command

Parameters

index

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CommandList.SyncRoot Property

CommandList.SyncRoot Property
[image]

Gets an object that can be used to synchronize access to the collection.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object SyncRoot { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SyncRoot As Object

Property Value

See Also

CommandList Members
CommandList Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Class

CompositeCmd Class
Remarks See Also
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CompositeCmd : Command

Visual Basic [image] Copy Code

Public Class CompositeCmd
Inherits Command

Remarks

To add a subaction to the composite call the AddSubCmd method. The Execute method executes all subactions and adds the composite to undo manager's history.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.CompositeCmd

See Also

CompositeCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Members

CompositeCmd Members
Constructors Properties Methods
[image]

Represents a set of Command instances as a single operation. Undoing or redoing the composite action, respectively undoes or redoes all its constituent subactions at the same time.

The following tables list the members exposed by the CompositeCmd type.

Public Constructors

Name | Description
CompositeCmd | Overloaded. Initializes a new instance of the CompositeCmd class.

Public Properties

Name | Description
SubCommands | Gets a collection of all command objects contained within the composite one.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Overloaded. Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Constructor

CompositeCmd Constructor
[image]

Initializes a new instance of the CompositeCmd class.

Overload List

Name | Description
CompositeCmd (Diagram, String) | Initializes a new instance of the CompositeCmd class.
CompositeCmd (Diagram, String, Boolean) | Initializes a new instance of the CompositeCmd class.

See Also

CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Constructor (Diagram, String)

CompositeCmd Constructor (Diagram, String)
See Also
[image]

Initializes a new instance of the CompositeCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeCmd (
Diagram diagram,
string title
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
title As String _
)

Parameters

diagram

title

See Also

CompositeCmd Constructor Overload List
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Constructor (Diagram, String, Boolean)

CompositeCmd Constructor (Diagram, String, Boolean)
See Also
[image]

Initializes a new instance of the CompositeCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CompositeCmd (
Diagram diagram,
string title,
bool saveZOrder
)

Visual Basic [image] Copy Code

Public New ( _
diagram As Diagram, _
title As String, _
saveZOrder As Boolean _
)

Parameters

diagram

title

saveZOrder

See Also

CompositeCmd Constructor Overload List
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Methods

CompositeCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Overloaded. Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.Execute Method

CompositeCmd.Execute Method
[image]

Carries out the command action.

Overload List

Name | Description
CompositeCmd.Execute () | Executes the command, adding it to the command history.
CompositeCmd.Execute (Boolean) | Carries out the command action.

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.Execute Method ()

CompositeCmd.Execute Method ()
See Also
[image]

Executes the command, adding it to the command history.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Execute ()

Visual Basic [image] Copy Code

Public Sub Execute ()

Remarks

Subcommands are executed or redone in the same order in which they were added to the composite, and are undone in the opposite order.

See Also

Execute Method Overload List
CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.Execute Method (Boolean)

CompositeCmd.Execute Method (Boolean)
See Also
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

Execute Method Overload List
CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.Redo Method

CompositeCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.Undo Method

CompositeCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd Properties

CompositeCmd Properties
[image]

Public Properties

Name | Description
SubCommands | Gets a collection of all command objects contained within the composite one.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)

See Also

CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.CompositeCmd.SubCommands Property

CompositeCmd.SubCommands Property
[image]

Gets a collection of all command objects contained within the composite one.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new CommandCollection SubCommands { get; }

Visual Basic [image] Copy Code

Public Shadows ReadOnly Property SubCommands As CommandCollection

Property Value

See Also

CompositeCmd Members
CompositeCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd Class

ExpandHeaderRowCmd Class
Remarks See Also
[image]

Implements undo and redo of collapsing or expanding the header row of a table section.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ExpandHeaderRowCmd : Command

Visual Basic [image] Copy Code

Public Class ExpandHeaderRowCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for .NET MAUI in response to expanding or collapsing Header rows, either interactively or programmatically.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ExpandHeaderRowCmd

See Also

ExpandHeaderRowCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd Members

ExpandHeaderRowCmd Members
Constructors Properties Methods
[image]

Implements undo and redo of collapsing or expanding the header row of a table section.

The following tables list the members exposed by the ExpandHeaderRowCmd type.

Public Constructors

Name | Description
ExpandHeaderRowCmd | Initializes a new instance of the ExpandHeaderRowCmd class.

Public Properties

Name | Description
RowIndex | Gets the index of the header row whose section is expanded or collapsed.
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd Constructor

ExpandHeaderRowCmd Constructor
[image]

Initializes a new instance of the ExpandHeaderRowCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ExpandHeaderRowCmd (
TableNode tableNode,
int rowIndex
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode, _
rowIndex As Integer _
)

Parameters

tableNode

rowIndex

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd Methods

ExpandHeaderRowCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd.Execute Method

ExpandHeaderRowCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd.Redo Method

ExpandHeaderRowCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd.Undo Method

ExpandHeaderRowCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd Properties

ExpandHeaderRowCmd Properties
[image]

Public Properties

Name | Description
RowIndex | Gets the index of the header row whose section is expanded or collapsed.
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd.RowIndex Property

ExpandHeaderRowCmd.RowIndex Property
[image]

Gets the index of the header row whose section is expanded or collapsed.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RowIndex { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowIndex As Integer

Property Value

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandHeaderRowCmd.TableNode Property

ExpandHeaderRowCmd.TableNode Property
[image]

Gets a reference to table affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode TableNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

ExpandHeaderRowCmd Members
ExpandHeaderRowCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd Class

ExpandItemCmd Class
[image]

Undoable command that implements expanding/collapsing trees of items.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ExpandItemCmd : Command

Visual Basic [image] Copy Code

Public Class ExpandItemCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ExpandItemCmd

See Also

ExpandItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd Members

ExpandItemCmd Members
Constructors Properties Methods
[image]

Undoable command that implements expanding/collapsing trees of items.

The following tables list the members exposed by the ExpandItemCmd type.

Public Constructors

Name | Description
ExpandItemCmd | Initializes a new instance of the ExpandItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd Constructor

ExpandItemCmd Constructor
[image]

Initializes a new instance of the ExpandItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ExpandItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd Methods

ExpandItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd.Execute Method

ExpandItemCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd.Redo Method

ExpandItemCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd.Undo Method

ExpandItemCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd Properties

ExpandItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to diagram item affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandItemCmd.Item Property

ExpandItemCmd.Item Property
[image]

Gets a reference to diagram item affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

ExpandItemCmd Members
ExpandItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd Class

ExpandTreeViewItemCmd Class
[image]

Implements support for undo of TreeViewItem collapse/expand operations.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ExpandTreeViewItemCmd : Command

Visual Basic [image] Copy Code

Public Class ExpandTreeViewItemCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd

See Also

ExpandTreeViewItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd Members

ExpandTreeViewItemCmd Members
Constructors Properties Methods
[image]

Implements support for undo of TreeViewItem collapse/expand operations.

The following tables list the members exposed by the ExpandTreeViewItemCmd type.

Public Constructors

Name | Description
ExpandTreeViewItemCmd | Initializes a new instance of the ExpandTreeViewItemCmd class.

Public Properties

Name | Description
Item | Gets the TreeViewItem that has been collapsed or expanded.
Title | Gets or sets the text associated with the action. (Inherited from Command.)
TreeViewNode | Gets the parent TreeViewNode.

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Command.Execute override.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd Constructor

ExpandTreeViewItemCmd Constructor
[image]

Initializes a new instance of the ExpandTreeViewItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ExpandTreeViewItemCmd (
TreeViewNode node,
TreeViewItem item
)

Visual Basic [image] Copy Code

Public New ( _
node As TreeViewNode, _
item As TreeViewItem _
)

Parameters

node

The parent TreeViewNode.

item

The TreeViewItem that has been collapsed or expanded.

See Also

ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd Methods

ExpandTreeViewItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Command.Execute override.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd.Execute Method

ExpandTreeViewItemCmd.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

Specifies whether undo/redo is enabled. If undo is disabled, the command won't be saved in undo history and will never be called to undo or redo itself. In such case you might choose to skip some housekeeping operations such as saving state variables for later undo/redo.

See Also

ExpandTreeViewItemCmd Members
ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd.Redo Method

ExpandTreeViewItemCmd.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ExpandTreeViewItemCmd Members
ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd.Undo Method

ExpandTreeViewItemCmd.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ExpandTreeViewItemCmd Members
ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd Properties

ExpandTreeViewItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets the TreeViewItem that has been collapsed or expanded.
Title | Gets or sets the text associated with the action. (Inherited from Command.)
TreeViewNode | Gets the parent TreeViewNode.

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd.Item Property

ExpandTreeViewItemCmd.Item Property
[image]

Gets the TreeViewItem that has been collapsed or expanded.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As TreeViewItem

Property Value

See Also

ExpandTreeViewItemCmd Members
ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ExpandTreeViewItemCmd.TreeViewNode Property

ExpandTreeViewItemCmd.TreeViewNode Property
[image]

Gets the parent TreeViewNode.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode TreeViewNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TreeViewNode As TreeViewNode

Property Value

See Also

ExpandTreeViewItemCmd Members
ExpandTreeViewItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd Class

FoldContainerCmd Class
[image]

Undoable command that implements scrolling of table rows.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FoldContainerCmd : Command

Visual Basic [image] Copy Code

Public Class FoldContainerCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.FoldContainerCmd

See Also

FoldContainerCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd Members

FoldContainerCmd Members
Constructors Properties Methods
[image]

Undoable command that implements scrolling of table rows.

The following tables list the members exposed by the FoldContainerCmd type.

Public Constructors

Name | Description
FoldContainerCmd | Initializes a new instance of the FoldContainerCmd class.

Public Properties

Name | Description
Container | Gets the table associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd Constructor

FoldContainerCmd Constructor
[image]

Initializes a new instance of the FoldContainerCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FoldContainerCmd (
ContainerNode container
)

Visual Basic [image] Copy Code

Public New ( _
container As ContainerNode _
)

Parameters

container

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd Methods

FoldContainerCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd.Execute Method

FoldContainerCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd.Redo Method

FoldContainerCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd.Undo Method

FoldContainerCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd Properties

FoldContainerCmd Properties
[image]

Public Properties

Name | Description
Container | Gets the table associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.FoldContainerCmd.Container Property

FoldContainerCmd.Container Property
[image]

Gets the table associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode Container { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Container As ContainerNode

Property Value

See Also

FoldContainerCmd Members
FoldContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd Class

ModifyItemCmd Class
Remarks See Also
[image]

Implements changes of item's size and position.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ModifyItemCmd : Command

Visual Basic [image] Copy Code

Public Class ModifyItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for .NET MAUI in response to moving or resizing items, either interactively or programmatically.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ModifyItemCmd

See Also

ModifyItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd Members

ModifyItemCmd Members
Constructors Properties Methods
[image]

Implements changes of item's size and position.

The following tables list the members exposed by the ModifyItemCmd type.

Public Constructors

Name | Description
ModifyItemCmd | Initializes a new instance of the ModifyItemCmd class.

Public Properties

Name | Description
Item | Gets a reference to the modified item.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd Constructor

ModifyItemCmd Constructor
[image]

Initializes a new instance of the ModifyItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ModifyItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd Methods

ModifyItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd.Adopt Method

ModifyItemCmd.Adopt Method
[image]

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool Adopt (
Command command
)

Visual Basic [image] Copy Code

Protected Overrides Function Adopt( _
command As Command _
) As Boolean

Parameters

command

The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd.Execute Method

ModifyItemCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd.Redo Method

ModifyItemCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd.Undo Method

ModifyItemCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd Properties

ModifyItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets a reference to the modified item.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ModifyItemCmd.Item Property

ModifyItemCmd.Item Property
[image]

Gets a reference to the modified item.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

ModifyItemCmd Members
ModifyItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd Class

RedimTableCmd Class
Remarks See Also
[image]

Implements changes to the number of table's rows and columns.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RedimTableCmd : Command

Visual Basic [image] Copy Code

Public Class RedimTableCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for .NET MAUI in response to method calls and property changes that alter the number of table's rows or columns.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.RedimTableCmd

See Also

RedimTableCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd Members

RedimTableCmd Members
Constructors Properties Methods
[image]

Implements changes to the number of table's rows and columns.

The following tables list the members exposed by the RedimTableCmd type.

Public Constructors

Name | Description
RedimTableCmd | Initializes a new instance of the RedimTableCmd class.

Public Properties

Name | Description
TableNode | Gets a reference to the modified table.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd Constructor

RedimTableCmd Constructor
[image]

Initializes a new instance of the RedimTableCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RedimTableCmd (
TableNode tableNode,
string title
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode, _
title As String _
)

Parameters

tableNode

title

See Also

RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd Methods

RedimTableCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd.Execute Method

RedimTableCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd.Redo Method

RedimTableCmd.Redo Method
[image]

Redoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd.Undo Method

RedimTableCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd Properties

RedimTableCmd Properties
[image]

Public Properties

Name | Description
TableNode | Gets a reference to the modified table.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RedimTableCmd.TableNode Property

RedimTableCmd.TableNode Property
[image]

Gets a reference to the modified table.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode TableNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

RedimTableCmd Members
RedimTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd Class

RemoveFromContainerCmd Class
[image]

Undoable command that implements an addition of a node to a container.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RemoveFromContainerCmd : Command

Visual Basic [image] Copy Code

Public Class RemoveFromContainerCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.RemoveFromContainerCmd

See Also

RemoveFromContainerCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd Members

RemoveFromContainerCmd Members
Constructors Properties Methods
[image]

Undoable command that implements an addition of a node to a container.

The following tables list the members exposed by the RemoveFromContainerCmd type.

Protected Constructors

Name | Description
RemoveFromContainerCmd | Initializes a new instance of the AddToContainerCmd class.

Public Properties

Name | Description
Container | Gets the group associated with the command.
Node | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd Constructor

RemoveFromContainerCmd Constructor
[image]

Initializes a new instance of the AddToContainerCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected RemoveFromContainerCmd (
ContainerNode container,
DiagramNode node,
bool interactive
)

Visual Basic [image] Copy Code

Protected New ( _
container As ContainerNode, _
node As DiagramNode, _
interactive As Boolean _
)

Parameters

container

node

interactive

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd Methods

RemoveFromContainerCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related.
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command.
Undo | Undoes the command.

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Adopt Method

RemoveFromContainerCmd.Adopt Method
[image]

Merges adjacent commands in the history queue if they are related.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override bool Adopt (
Command command
)

Visual Basic [image] Copy Code

Protected Overrides Function Adopt( _
command As Command _
) As Boolean

Parameters

command

The Command that might be adopted by this command.

Return Value

true if the specified command has been adopted; otherwise, false.

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Execute Method

RemoveFromContainerCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Redo Method

RemoveFromContainerCmd.Redo Method
[image]

Redoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Undo Method

RemoveFromContainerCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd Properties

RemoveFromContainerCmd Properties
[image]

Public Properties

Name | Description
Container | Gets the group associated with the command.
Node | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Container Property

RemoveFromContainerCmd.Container Property
[image]

Gets the group associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ContainerNode Container { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Container As ContainerNode

Property Value

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveFromContainerCmd.Node Property

RemoveFromContainerCmd.Node Property
[image]

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Node { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Node As DiagramNode

Property Value

See Also

RemoveFromContainerCmd Members
RemoveFromContainerCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd Class

RemoveItemCmd Class
Remarks See Also
[image]

Implements deletion of diagram items.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class RemoveItemCmd : Command

Visual Basic [image] Copy Code

Public Class RemoveItemCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for .NET MAUI in response to deleting items interactively or programmatically.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.RemoveItemCmd

See Also

RemoveItemCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd Members

RemoveItemCmd Members
Constructors Properties Methods
[image]

Implements deletion of diagram items.

The following tables list the members exposed by the RemoveItemCmd type.

Public Constructors

Name | Description
RemoveItemCmd | Initializes a new instance of the RemoveItemCmd class.

Public Properties

Name | Description
Item | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd Constructor

RemoveItemCmd Constructor
[image]

Initializes a new instance of the RemoveItemCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public RemoveItemCmd (
DiagramItem item
)

Visual Basic [image] Copy Code

Public New ( _
item As DiagramItem _
)

Parameters

item

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd Methods

RemoveItemCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd.Execute Method

RemoveItemCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd.Redo Method

RemoveItemCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd.Undo Method

RemoveItemCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd Properties

RemoveItemCmd Properties
[image]

Public Properties

Name | Description
Item | Gets the item associated with the command.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.RemoveItemCmd.Item Property

RemoveItemCmd.Item Property
[image]

Gets the item associated with the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem Item { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item As DiagramItem

Property Value

See Also

RemoveItemCmd Members
RemoveItemCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd Class

ScrollTableCmd Class
Remarks See Also
[image]

Implements scrolling of table's rows.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ScrollTableCmd : Command

Visual Basic [image] Copy Code

Public Class ScrollTableCmd
Inherits Command

Remarks

Instances of this class are implicitly created by MindFusion.Diagramming for .NET MAUI in response to scrolling table's rows, either interactively or programmatically.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ScrollTableCmd

See Also

ScrollTableCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd Members

ScrollTableCmd Members
Constructors Properties Methods
[image]

Implements scrolling of table's rows.

The following tables list the members exposed by the ScrollTableCmd type.

Public Constructors

Name | Description
ScrollTableCmd | Initializes a new instance of the ScrollTableCmd class.

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd Constructor

ScrollTableCmd Constructor
[image]

Initializes a new instance of the ScrollTableCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScrollTableCmd (
TableNode tableNode
)

Visual Basic [image] Copy Code

Public New ( _
tableNode As TableNode _
)

Parameters

tableNode

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd Methods

ScrollTableCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Carries out the command action.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Redoes the command action.
Undo | Undoes the command.

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd.Execute Method

ScrollTableCmd.Execute Method
[image]

Carries out the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd.Redo Method

ScrollTableCmd.Redo Method
[image]

Redoes the command action.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd.Undo Method

ScrollTableCmd.Undo Method
[image]

Undoes the command.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd Properties

ScrollTableCmd Properties
[image]

Public Properties

Name | Description
TableNode | Gets a reference to table affected by this operation.
Title | Gets or sets the text associated with the action. (Inherited from Command.)

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTableCmd.TableNode Property

ScrollTableCmd.TableNode Property
[image]

Gets a reference to table affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TableNode TableNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TableNode As TableNode

Property Value

See Also

ScrollTableCmd Members
ScrollTableCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTreeViewCmd Class

ScrollTreeViewCmd Class
[image]

Implements support for undo of TreeViewNode scroll operations.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ScrollTreeViewCmd : Command

Visual Basic [image] Copy Code

Public Class ScrollTreeViewCmd
Inherits Command

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Commands.Command
MindFusion.Diagramming.Commands.ScrollTreeViewCmd

See Also

ScrollTreeViewCmd Members
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTreeViewCmd Members

ScrollTreeViewCmd Members
Constructors Properties Methods
[image]

Implements support for undo of TreeViewNode scroll operations.

The following tables list the members exposed by the ScrollTreeViewCmd type.

Public Constructors

Name | Description
ScrollTreeViewCmd | Initializes a new instance of the ScrollTreeViewCmd class.

Public Properties

Name | Description
Title | Gets or sets the text associated with the action. (Inherited from Command.)
TreeViewNode | Gets a reference to the TreeViewNode affected by this operation.

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Command.Execute override.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ScrollTreeViewCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTreeViewCmd Constructor

ScrollTreeViewCmd Constructor
[image]

Initializes a new instance of the ScrollTreeViewCmd class.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ScrollTreeViewCmd (
TreeViewNode node
)

Visual Basic [image] Copy Code

Public New ( _
node As TreeViewNode _
)

Parameters

node

The related TreeViewNode.

See Also

ScrollTreeViewCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTreeViewCmd Methods

ScrollTreeViewCmd Methods
[image]

Public Methods

Name | Description
AddSubCmd | Adds an action to a composite command. (Inherited from Command.)

Protected Methods

Name | Description
Adopt | Merges adjacent commands in the history queue if they are related. (Inherited from Command.)
Execute | Command.Execute override.
IsContainerOf | Determines whether a command has been initiated by this command and should be treated as a derivative. (Inherited from Command.)
Redo | Command.Redo override.
Undo | Command.Undo override.

See Also

ScrollTreeViewCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTreeViewCmd.Execute Method

ScrollTreeViewCmd.Execute Method
[image]

Command.Execute override.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Execute (
bool undoEnabled
)

Visual Basic [image] Copy Code

Protected Overrides Sub Execute( _
undoEnabled As Boolean _
)

Parameters

undoEnabled

Specifies whether undo/redo is enabled. If undo is disabled, the command won't be saved in undo history and will never be called to undo or redo itself. In such case you might choose to skip some housekeeping operations such as saving state variables for later undo/redo.

See Also

ScrollTreeViewCmd Members
ScrollTreeViewCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTreeViewCmd.Redo Method

ScrollTreeViewCmd.Redo Method
[image]

Command.Redo override.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Redo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Redo ()

See Also

ScrollTreeViewCmd Members
ScrollTreeViewCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTreeViewCmd.Undo Method

ScrollTreeViewCmd.Undo Method
[image]

Command.Undo override.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override void Undo ()

Visual Basic [image] Copy Code

Protected Overrides Sub Undo ()

See Also

ScrollTreeViewCmd Members
ScrollTreeViewCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTreeViewCmd Properties

ScrollTreeViewCmd Properties
[image]

Public Properties

Name | Description
Title | Gets or sets the text associated with the action. (Inherited from Command.)
TreeViewNode | Gets a reference to the TreeViewNode affected by this operation.

Protected Properties

Name | Description
Context | Gets the command's context. (Inherited from Command.)
SubCommands | Gets a collection of all command objects contained within the composite one. (Inherited from Command.)

See Also

ScrollTreeViewCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Commands.ScrollTreeViewCmd.TreeViewNode Property

ScrollTreeViewCmd.TreeViewNode Property
[image]

Gets a reference to the TreeViewNode affected by this operation.

Namespace: MindFusion.Diagramming.Commands
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeViewNode TreeViewNode { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TreeViewNode As TreeViewNode

Property Value

See Also

ScrollTreeViewCmd Members
ScrollTreeViewCmd Class
MindFusion.Diagramming.Commands Namespace


MindFusion.Diagramming.Interaction Namespace
Classes

Classes

Class | Description
BaseController | Represents objects that handle user input via pointing device.
BaseTouchBehavior | An abstract base class for classes that define how the Diagram responds to user gestures.
DrawFreeFormsTouchBehavior | This class is used when the diagram behavior is set to Behavior.DrawFreeForms.
DrawLinksTouchBehavior | Represents a behavior that is suitable for creating links. Drawing started over a node creates a DiagramLink. Otherwise a lasso rectangle is displayed allowing the selection of items.
DrawNodesTouchBehavior(TNodeType) | Represents a behavior that is suitable for creating node nodes. Drawing anywhere on the screen creates DiagramNode instances.
InputState | Encapsulates touch information, provided to the behavior classes.
LinkFreeFormsTouchBehavior | This class is used when the diagram behavior is set to Behavior.LinkFreeForms.
LinkNodesTouchBehavior(TNodeType) | Represents a behavior that is suitable for creating whole diagrams. Drawing over empty screen areas creates DiagramNode instances. Drawing started over a node creates a DiagramLink.
ModifyLabelController |
ModifyTouchBehavior | Represents a behavior that can be used only to select and modify existing items. New items cannot be created.
MoveLabelsTouchBehavior | This class is used when the diagram behavior is set to Behavior.MoveLabels.
MoveNodesTouchBehavior | This class is used when the diagram behavior is set to Behavior.MoveNodes.
PanTouchBehavior | Represents a behavior that can be used to pan the diagram.
PointerInfo | Provides information to touch controllers about the user action.
SelectTouchBehavior | Represents a behavior that can be used only to select existing items. Modifying items and creating new items is disabled.
TouchController | Represents objects that handle user touch input.
TouchEventArgs | Contains the arguments passed to the event handlers of touch-related events.
VirtualConnectionPoint | Represents the connection points of disconnected links.
VirtualNode | A special node used as origin or destination of disconnected links.


MindFusion.Diagramming.Interaction.BaseController Class

BaseController Class
[image]

Represents objects that handle user input via pointing device.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class BaseController

Visual Basic [image] Copy Code

Public MustInherit Class BaseController

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseController
MindFusion.Diagramming.Interaction.TouchController

See Also

BaseController Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseController Members

BaseController Members
Constructors Fields Methods
[image]

Represents objects that handle user input via pointing device.

The following tables list the members exposed by the BaseController type.

Protected Constructors

Name | Description
BaseController |

Protected Fields

Name | Description
canceled |
validated |

Public Methods

Name | Description
DisallowCursor |
DrawInteraction | Called on the current controller to let it draw an appropriate feedback for the current user action.
Validate | Called to validate the operation at current pointer position.

See Also

BaseController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseController Fields

BaseController Fields
[image]

Protected Fields

Name | Description
canceled |
validated |

See Also

BaseController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseController.canceled Field

BaseController.canceled Field
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool canceled

Visual Basic [image] Copy Code

Protected canceled As Boolean

See Also

BaseController Members
BaseController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseController.validated Field

BaseController.validated Field
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool validated

Visual Basic [image] Copy Code

Protected validated As Boolean

See Also

BaseController Members
BaseController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseController Constructor

BaseController Constructor
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected BaseController ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

BaseController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseController Methods

BaseController Methods
[image]

Public Methods

Name | Description
DisallowCursor |
DrawInteraction | Called on the current controller to let it draw an appropriate feedback for the current user action.
Validate | Called to validate the operation at current pointer position.

See Also

BaseController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseController.DisallowCursor Method

BaseController.DisallowCursor Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual CursorHint DisallowCursor ()

Visual Basic [image] Copy Code

Public Overridable Function DisallowCursor () As CursorHint

Return Value

See Also

BaseController Members
BaseController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseController.DrawInteraction Method

BaseController.DrawInteraction Method
[image]

Called on the current controller to let it draw an appropriate feedback for the current user action.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void DrawInteraction (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public Overridable Sub DrawInteraction( _
graphics As IGraphics _
)

Parameters

graphics

An IGraphics instance that should be used to perform the draw.

See Also

BaseController Members
BaseController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseController.Validate Method

BaseController.Validate Method
[image]

Called to validate the operation at current pointer position.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Validate ()

Visual Basic [image] Copy Code

Public Overridable Function Validate () As Boolean

Return Value

true to accept the operation, or false otherwise.

See Also

BaseController Members
BaseController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseTouchBehavior Class

BaseTouchBehavior Class
[image]

An abstract base class for classes that define how the Diagram responds to user gestures.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class BaseTouchBehavior

Visual Basic [image] Copy Code

Public MustInherit Class BaseTouchBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.DrawLinksTouchBehavior
MindFusion.Diagramming.Interaction.DrawNodesTouchBehavior(TNodeType)
MindFusion.Diagramming.Interaction.LinkNodesTouchBehavior(TNodeType)
MindFusion.Diagramming.Interaction.ModifyTouchBehavior
MindFusion.Diagramming.Interaction.MoveLabelsTouchBehavior
MindFusion.Diagramming.Interaction.MoveNodesTouchBehavior
MindFusion.Diagramming.Interaction.PanTouchBehavior
MindFusion.Diagramming.Interaction.SelectTouchBehavior

See Also

BaseTouchBehavior Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseTouchBehavior Members

BaseTouchBehavior Members
Constructors Properties Methods
[image]

An abstract base class for classes that define how the Diagram responds to user gestures.

The following tables list the members exposed by the BaseTouchBehavior type.

Protected Constructors

Name | Description
BaseTouchBehavior | Initializes a new instance of the BaseTouchBehavior class.

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior.

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with.

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor |

Protected Methods

Name | Description
SelectHandleCursor |

See Also

BaseTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseTouchBehavior Constructor

BaseTouchBehavior Constructor
[image]

Initializes a new instance of the BaseTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected BaseTouchBehavior (
DiagramView diagramView
)

Visual Basic [image] Copy Code

Protected New ( _
diagramView As DiagramView _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

See Also

BaseTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseTouchBehavior Methods

BaseTouchBehavior Methods
[image]

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor |

Protected Methods

Name | Description
SelectHandleCursor |

See Also

BaseTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseTouchBehavior.SelectController Method

BaseTouchBehavior.SelectController Method
[image]

Selects a controller based on the specified input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overridable Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

The input state.

Return Value

A TouchController representing the object that will manage the interaction.

See Also

BaseTouchBehavior Members
BaseTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseTouchBehavior.SelectHandleCursor Method

BaseTouchBehavior.SelectHandleCursor Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected CursorHint SelectHandleCursor (
InputState state
)

Visual Basic [image] Copy Code

Protected Function SelectHandleCursor( _
state As InputState _
) As CursorHint

Parameters

state

Return Value

See Also

BaseTouchBehavior Members
BaseTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseTouchBehavior.SelectMouseCursor Method

BaseTouchBehavior.SelectMouseCursor Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual CursorHint SelectMouseCursor (
InputState state
)

Visual Basic [image] Copy Code

Public Overridable Function SelectMouseCursor( _
state As InputState _
) As CursorHint

Parameters

state

Return Value

See Also

BaseTouchBehavior Members
BaseTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseTouchBehavior Properties

BaseTouchBehavior Properties
[image]

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior.

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with.

See Also

BaseTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseTouchBehavior.Diagram Property

BaseTouchBehavior.Diagram Property
[image]

Gets a reference to the Diagram instance this behavior is associated with.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Diagram Diagram { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Diagram As Diagram

Property Value

An instance of the Diagram class.

See Also

BaseTouchBehavior Members
BaseTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.BaseTouchBehavior.DiagramView Property

BaseTouchBehavior.DiagramView Property
[image]

Gets the diagram view associated with the behavior.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramView DiagramView { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DiagramView As DiagramView

Property Value

See Also

BaseTouchBehavior Members
BaseTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawFreeFormsTouchBehavior Class

DrawFreeFormsTouchBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.DrawFreeForms.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawFreeFormsTouchBehavior : DrawNodesTouchBehavior<FreeFormNode>

Visual Basic [image] Copy Code

Public Class DrawFreeFormsTouchBehavior
Inherits DrawNodesTouchBehavior(Of FreeFormNode)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.DrawNodesTouchBehavior(FreeFormNode)
MindFusion.Diagramming.Interaction.DrawFreeFormsTouchBehavior

See Also

DrawFreeFormsTouchBehavior Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawFreeFormsTouchBehavior Members

DrawFreeFormsTouchBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.DrawFreeForms.

The following tables list the members exposed by the DrawFreeFormsTouchBehavior type.

Public Constructors

Name | Description
DrawFreeFormsTouchBehavior | Initializes a new instance of the DrawFreeFormsTouchBehavior class.

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior. (Inherited from BaseTouchBehavior.)

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with. (Inherited from BaseTouchBehavior.)

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor | (Inherited from DrawNodesTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

DrawFreeFormsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawFreeFormsTouchBehavior Constructor

DrawFreeFormsTouchBehavior Constructor
[image]

Initializes a new instance of the DrawFreeFormsTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawFreeFormsTouchBehavior (
DiagramView diagramView,
bool convertToShape
)

Visual Basic [image] Copy Code

Public New ( _
diagramView As DiagramView, _
convertToShape As Boolean _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

convertToShape

true to convert the FreeFormNode to a ShapeNode once user finishes drawing it, or false otherwise.

See Also

DrawFreeFormsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawFreeFormsTouchBehavior Methods

DrawFreeFormsTouchBehavior Methods
[image]

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor | (Inherited from DrawNodesTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

DrawFreeFormsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawFreeFormsTouchBehavior.SelectController Method

DrawFreeFormsTouchBehavior.SelectController Method
[image]

Selects a controller based on the specified input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

The input state.

Return Value

A TouchController representing the object that will manage the interaction.

See Also

DrawFreeFormsTouchBehavior Members
DrawFreeFormsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawLinksTouchBehavior Class

DrawLinksTouchBehavior Class
[image]

Represents a behavior that is suitable for creating links. Drawing started over a node creates a DiagramLink. Otherwise a lasso rectangle is displayed allowing the selection of items.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawLinksTouchBehavior : BaseTouchBehavior

Visual Basic [image] Copy Code

Public Class DrawLinksTouchBehavior
Inherits BaseTouchBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.DrawLinksTouchBehavior

See Also

DrawLinksTouchBehavior Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawLinksTouchBehavior Members

DrawLinksTouchBehavior Members
Constructors Properties Methods
[image]

Represents a behavior that is suitable for creating links. Drawing started over a node creates a DiagramLink. Otherwise a lasso rectangle is displayed allowing the selection of items.

The following tables list the members exposed by the DrawLinksTouchBehavior type.

Public Constructors

Name | Description
DrawLinksTouchBehavior | Initializes a new instance of the DrawLinksTouchBehavior class.

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior. (Inherited from BaseTouchBehavior.)

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with. (Inherited from BaseTouchBehavior.)

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor |

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

DrawLinksTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawLinksTouchBehavior Constructor

DrawLinksTouchBehavior Constructor
[image]

Initializes a new instance of the DrawLinksTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawLinksTouchBehavior (
DiagramView diagramView
)

Visual Basic [image] Copy Code

Public New ( _
diagramView As DiagramView _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

See Also

DrawLinksTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawLinksTouchBehavior Methods

DrawLinksTouchBehavior Methods
[image]

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor |

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

DrawLinksTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawLinksTouchBehavior.SelectController Method

DrawLinksTouchBehavior.SelectController Method
[image]

Selects a controller based on the specified input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

The input state.

Return Value

A TouchController representing the object that will manage the interaction.

See Also

DrawLinksTouchBehavior Members
DrawLinksTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawLinksTouchBehavior.SelectMouseCursor Method

DrawLinksTouchBehavior.SelectMouseCursor Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override CursorHint SelectMouseCursor (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectMouseCursor( _
state As InputState _
) As CursorHint

Parameters

state

Return Value

See Also

DrawLinksTouchBehavior Members
DrawLinksTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawNodesTouchBehavior(TNodeType) Class

DrawNodesTouchBehavior(TNodeType) Class
[image]

Represents a behavior that is suitable for creating node nodes. Drawing anywhere on the screen creates DiagramNode instances.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DrawNodesTouchBehavior<TNodeType> : BaseTouchBehavior where TNodeType : DiagramNode

Visual Basic [image] Copy Code

Public Class DrawNodesTouchBehavior(Of TNodeType As DiagramNode)
Inherits BaseTouchBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.DrawNodesTouchBehavior(TNodeType)
MindFusion.Diagramming.Interaction.DrawFreeFormsTouchBehavior

See Also

DrawNodesTouchBehavior(TNodeType) Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawNodesTouchBehavior(TNodeType) Members

DrawNodesTouchBehavior(TNodeType) Members
Constructors Properties Methods
[image]

Represents a behavior that is suitable for creating node nodes. Drawing anywhere on the screen creates DiagramNode instances.

The following tables list the members exposed by the DrawNodesTouchBehavior(TNodeType) type.

Public Constructors

Name | Description
DrawNodesTouchBehavior | Initializes a new instance of the DrawNodesTouchBehavior class. (Inherited from DrawNodesTouchBehavior.)

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior. (Inherited from BaseTouchBehavior.)

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with. (Inherited from BaseTouchBehavior.)

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input. (Inherited from DrawNodesTouchBehavior.)
SelectMouseCursor | (Inherited from DrawNodesTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

DrawNodesTouchBehavior(TNodeType) Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawNodesTouchBehavior(TNodeType) Constructor

DrawNodesTouchBehavior(TNodeType) Constructor
[image]

Initializes a new instance of the DrawNodesTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DrawNodesTouchBehavior<TNodeType> (
DiagramView diagramView
)

Visual Basic [image] Copy Code

Public New (Of TNodeType) ( _
diagramView As DiagramView _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

See Also

DrawNodesTouchBehavior(TNodeType) Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawNodesTouchBehavior(TNodeType) Methods

DrawNodesTouchBehavior(TNodeType) Methods
[image]

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input. (Inherited from DrawNodesTouchBehavior.)
SelectMouseCursor | (Inherited from DrawNodesTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

DrawNodesTouchBehavior(TNodeType) Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawNodesTouchBehavior(TNodeType).SelectController Method

DrawNodesTouchBehavior(TNodeType).SelectController Method
[image]

Selects a controller based on the specified input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

The input state.

Return Value

A TouchController representing the object that will manage the interaction.

See Also

DrawNodesTouchBehavior(TNodeType) Members
DrawNodesTouchBehavior(TNodeType) Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.DrawNodesTouchBehavior(TNodeType).SelectMouseCursor Method

DrawNodesTouchBehavior(TNodeType).SelectMouseCursor Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override CursorHint SelectMouseCursor (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectMouseCursor( _
state As InputState _
) As CursorHint

Parameters

state

Return Value

See Also

DrawNodesTouchBehavior(TNodeType) Members
DrawNodesTouchBehavior(TNodeType) Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.InputState Class

InputState Class
[image]

Encapsulates touch information, provided to the behavior classes.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class InputState

Visual Basic [image] Copy Code

Public Class InputState

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.InputState

See Also

InputState Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.InputState Members

InputState Members
Constructors Properties
[image]

Encapsulates touch information, provided to the behavior classes.

The following tables list the members exposed by the InputState type.

Public Constructors

Name | Description
InputState | Initializes a new instance of the InputState class.

Public Properties

Name | Description
DragDistance | Gets or sets the distance between the initial touch and the current touch location, expressed in millimeters.
PointedHandle | Gets the manipulation handle at the touch location.
PointedItem | Gets the item at the touch location.
PointedLabel | Gets the item label at the touch location.
PointedManipulator | Gets the manipulator at the touch location.
PointerPosition | Gets the touch location, in document coordinates.

See Also

InputState Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.InputState Constructor

InputState Constructor
[image]

Initializes a new instance of the InputState class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public InputState ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

InputState Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.InputState Properties

InputState Properties
[image]

Public Properties

Name | Description
DragDistance | Gets or sets the distance between the initial touch and the current touch location, expressed in millimeters.
PointedHandle | Gets the manipulation handle at the touch location.
PointedItem | Gets the item at the touch location.
PointedLabel | Gets the item label at the touch location.
PointedManipulator | Gets the manipulator at the touch location.
PointerPosition | Gets the touch location, in document coordinates.

See Also

InputState Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.InputState.DragDistance Property

InputState.DragDistance Property
[image]

Gets or sets the distance between the initial touch and the current touch location, expressed in millimeters.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DragDistance { get; set; }

Visual Basic [image] Copy Code

Public Property DragDistance As Double

Property Value

A double value.

See Also

InputState Members
InputState Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.InputState.PointedHandle Property

InputState.PointedHandle Property
[image]

Gets the manipulation handle at the touch location.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AdjustmentHandle PointedHandle { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PointedHandle As AdjustmentHandle

Property Value

An instance of the AdjustmentHandle class.

See Also

InputState Members
InputState Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.InputState.PointedItem Property

InputState.PointedItem Property
[image]

Gets the item at the touch location.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramItem PointedItem { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PointedItem As DiagramItem

Property Value

An instance of the DiagramItem class.

See Also

InputState Members
InputState Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.InputState.PointedLabel Property

InputState.PointedLabel Property
[image]

Gets the item label at the touch location.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ItemLabel PointedLabel { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PointedLabel As ItemLabel

Property Value

See Also

InputState Members
InputState Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.InputState.PointedManipulator Property

InputState.PointedManipulator Property
[image]

Gets the manipulator at the touch location.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Manipulator PointedManipulator { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PointedManipulator As Manipulator

Property Value

An instance of the Manipulator class.

See Also

InputState Members
InputState Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.InputState.PointerPosition Property

InputState.PointerPosition Property
[image]

Gets the touch location, in document coordinates.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point PointerPosition { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PointerPosition As Point

Property Value

An instance of the Point structure.

See Also

InputState Members
InputState Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkFreeFormsTouchBehavior Class

LinkFreeFormsTouchBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.LinkFreeForms.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkFreeFormsTouchBehavior : LinkNodesTouchBehavior<FreeFormNode>

Visual Basic [image] Copy Code

Public Class LinkFreeFormsTouchBehavior
Inherits LinkNodesTouchBehavior(Of FreeFormNode)

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.LinkNodesTouchBehavior(FreeFormNode)
MindFusion.Diagramming.Interaction.LinkFreeFormsTouchBehavior

See Also

LinkFreeFormsTouchBehavior Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkFreeFormsTouchBehavior Members

LinkFreeFormsTouchBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.LinkFreeForms.

The following tables list the members exposed by the LinkFreeFormsTouchBehavior type.

Public Constructors

Name | Description
LinkFreeFormsTouchBehavior | Initializes a new instance of the LinkFreeFormsTouchBehavior class.

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior. (Inherited from BaseTouchBehavior.)

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with. (Inherited from BaseTouchBehavior.)

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor | (Inherited from LinkNodesTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

LinkFreeFormsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkFreeFormsTouchBehavior Constructor

LinkFreeFormsTouchBehavior Constructor
[image]

Initializes a new instance of the LinkFreeFormsTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkFreeFormsTouchBehavior (
DiagramView diagramView,
bool convertToShape
)

Visual Basic [image] Copy Code

Public New ( _
diagramView As DiagramView, _
convertToShape As Boolean _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

convertToShape

true to convert the FreeFormNode to a ShapeNode once user finishes drawing it, or false otherwise.

See Also

LinkFreeFormsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkFreeFormsTouchBehavior Methods

LinkFreeFormsTouchBehavior Methods
[image]

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor | (Inherited from LinkNodesTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

LinkFreeFormsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkFreeFormsTouchBehavior.SelectController Method

LinkFreeFormsTouchBehavior.SelectController Method
[image]

Selects a controller based on the specified input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

The input state.

Return Value

A TouchController representing the object that will manage the interaction.

See Also

LinkFreeFormsTouchBehavior Members
LinkFreeFormsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkNodesTouchBehavior(TNodeType) Class

LinkNodesTouchBehavior(TNodeType) Class
[image]

Represents a behavior that is suitable for creating whole diagrams. Drawing over empty screen areas creates DiagramNode instances. Drawing started over a node creates a DiagramLink.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LinkNodesTouchBehavior<TNodeType> : BaseTouchBehavior where TNodeType : DiagramNode

Visual Basic [image] Copy Code

Public Class LinkNodesTouchBehavior(Of TNodeType As DiagramNode)
Inherits BaseTouchBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.LinkNodesTouchBehavior(TNodeType)
MindFusion.Diagramming.Interaction.LinkFreeFormsTouchBehavior

See Also

LinkNodesTouchBehavior(TNodeType) Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkNodesTouchBehavior(TNodeType) Members

LinkNodesTouchBehavior(TNodeType) Members
Constructors Properties Methods
[image]

Represents a behavior that is suitable for creating whole diagrams. Drawing over empty screen areas creates DiagramNode instances. Drawing started over a node creates a DiagramLink.

The following tables list the members exposed by the LinkNodesTouchBehavior(TNodeType) type.

Public Constructors

Name | Description
LinkNodesTouchBehavior | Initializes a new instance of the LinkNodesTouchBehavior class. (Inherited from LinkNodesTouchBehavior.)

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior. (Inherited from BaseTouchBehavior.)

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with. (Inherited from BaseTouchBehavior.)

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input. (Inherited from LinkNodesTouchBehavior.)
SelectMouseCursor | (Inherited from LinkNodesTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

LinkNodesTouchBehavior(TNodeType) Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkNodesTouchBehavior(TNodeType) Constructor

LinkNodesTouchBehavior(TNodeType) Constructor
[image]

Initializes a new instance of the LinkNodesTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LinkNodesTouchBehavior<TNodeType> (
DiagramView diagramView
)

Visual Basic [image] Copy Code

Public New (Of TNodeType) ( _
diagramView As DiagramView _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

See Also

LinkNodesTouchBehavior(TNodeType) Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkNodesTouchBehavior(TNodeType) Methods

LinkNodesTouchBehavior(TNodeType) Methods
[image]

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input. (Inherited from LinkNodesTouchBehavior.)
SelectMouseCursor | (Inherited from LinkNodesTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

LinkNodesTouchBehavior(TNodeType) Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkNodesTouchBehavior(TNodeType).SelectController Method

LinkNodesTouchBehavior(TNodeType).SelectController Method
[image]

Selects a controller based on the specified input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

The input state.

Return Value

A TouchController representing the object that will manage the interaction.

See Also

LinkNodesTouchBehavior(TNodeType) Members
LinkNodesTouchBehavior(TNodeType) Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.LinkNodesTouchBehavior(TNodeType).SelectMouseCursor Method

LinkNodesTouchBehavior(TNodeType).SelectMouseCursor Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override CursorHint SelectMouseCursor (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectMouseCursor( _
state As InputState _
) As CursorHint

Parameters

state

Return Value

See Also

LinkNodesTouchBehavior(TNodeType) Members
LinkNodesTouchBehavior(TNodeType) Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyLabelController Class

ModifyLabelController Class
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ModifyLabelController : TouchController

Visual Basic [image] Copy Code

Public Class ModifyLabelController
Inherits TouchController

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseController
MindFusion.Diagramming.Interaction.TouchController
MindFusion.Diagramming.Interaction.ModifyLabelController

See Also

ModifyLabelController Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyLabelController Members

ModifyLabelController Members
Constructors Fields Methods
[image]

The following tables list the members exposed by the ModifyLabelController type.

Public Constructors

Name | Description
ModifyLabelController |

Protected Fields

Name | Description
canceled | (Inherited from BaseController.)
validated | (Inherited from BaseController.)

Public Methods

Name | Description
DisallowCursor | (Inherited from BaseController.)
DrawInteraction | Called on the current controller to let it draw an appropriate feedback for the current user action. (Inherited from BaseController.)
OnCancel |
OnTouchDown |
OnTouchMove |
OnTouchUp |
Validate | Called to validate the operation at current pointer position. (Inherited from BaseController.)

See Also

ModifyLabelController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyLabelController Constructor

ModifyLabelController Constructor
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ModifyLabelController (
ItemLabel label
)

Visual Basic [image] Copy Code

Public New ( _
label As ItemLabel _
)

Parameters

label

See Also

ModifyLabelController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyLabelController Methods

ModifyLabelController Methods
[image]

Public Methods

Name | Description
DisallowCursor | (Inherited from BaseController.)
DrawInteraction | Called on the current controller to let it draw an appropriate feedback for the current user action. (Inherited from BaseController.)
OnCancel |
OnTouchDown |
OnTouchMove |
OnTouchUp |
Validate | Called to validate the operation at current pointer position. (Inherited from BaseController.)

See Also

ModifyLabelController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyLabelController.OnCancel Method

ModifyLabelController.OnCancel Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnCancel (
PointerInfo info
)

Visual Basic [image] Copy Code

Public Overrides Sub OnCancel( _
info As PointerInfo _
)

Parameters

info

See Also

ModifyLabelController Members
ModifyLabelController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyLabelController.OnTouchDown Method

ModifyLabelController.OnTouchDown Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnTouchDown (
PointerInfo info
)

Visual Basic [image] Copy Code

Public Overrides Sub OnTouchDown( _
info As PointerInfo _
)

Parameters

info

See Also

ModifyLabelController Members
ModifyLabelController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyLabelController.OnTouchMove Method

ModifyLabelController.OnTouchMove Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnTouchMove (
PointerInfo info
)

Visual Basic [image] Copy Code

Public Overrides Sub OnTouchMove( _
info As PointerInfo _
)

Parameters

info

See Also

ModifyLabelController Members
ModifyLabelController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyLabelController.OnTouchUp Method

ModifyLabelController.OnTouchUp Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void OnTouchUp (
PointerInfo info
)

Visual Basic [image] Copy Code

Public Overrides Sub OnTouchUp( _
info As PointerInfo _
)

Parameters

info

See Also

ModifyLabelController Members
ModifyLabelController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyTouchBehavior Class

ModifyTouchBehavior Class
[image]

Represents a behavior that can be used only to select and modify existing items. New items cannot be created.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class ModifyTouchBehavior : BaseTouchBehavior

Visual Basic [image] Copy Code

Public Class ModifyTouchBehavior
Inherits BaseTouchBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.ModifyTouchBehavior

See Also

ModifyTouchBehavior Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyTouchBehavior Members

ModifyTouchBehavior Members
Constructors Properties Methods
[image]

Represents a behavior that can be used only to select and modify existing items. New items cannot be created.

The following tables list the members exposed by the ModifyTouchBehavior type.

Public Constructors

Name | Description
ModifyTouchBehavior | Initializes a new instance of the ModifyTouchBehavior class.

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior. (Inherited from BaseTouchBehavior.)

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with. (Inherited from BaseTouchBehavior.)

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor |

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

ModifyTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyTouchBehavior Constructor

ModifyTouchBehavior Constructor
[image]

Initializes a new instance of the ModifyTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ModifyTouchBehavior (
DiagramView diagramView
)

Visual Basic [image] Copy Code

Public New ( _
diagramView As DiagramView _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

See Also

ModifyTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyTouchBehavior Methods

ModifyTouchBehavior Methods
[image]

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor |

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

ModifyTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyTouchBehavior.SelectController Method

ModifyTouchBehavior.SelectController Method
[image]

Selects a controller based on the specified input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

The input state.

Return Value

A TouchController representing the object that will manage the interaction.

See Also

ModifyTouchBehavior Members
ModifyTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.ModifyTouchBehavior.SelectMouseCursor Method

ModifyTouchBehavior.SelectMouseCursor Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override CursorHint SelectMouseCursor (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectMouseCursor( _
state As InputState _
) As CursorHint

Parameters

state

Return Value

See Also

ModifyTouchBehavior Members
ModifyTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveLabelsTouchBehavior Class

MoveLabelsTouchBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.MoveLabels.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class MoveLabelsTouchBehavior : BaseTouchBehavior

Visual Basic [image] Copy Code

Public Class MoveLabelsTouchBehavior
Inherits BaseTouchBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.MoveLabelsTouchBehavior

See Also

MoveLabelsTouchBehavior Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveLabelsTouchBehavior Members

MoveLabelsTouchBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.MoveLabels.

The following tables list the members exposed by the MoveLabelsTouchBehavior type.

Protected Constructors

Name | Description
MoveLabelsTouchBehavior | Initializes a new instance of the MoveLabelsTouchBehavior class.

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior. (Inherited from BaseTouchBehavior.)

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with. (Inherited from BaseTouchBehavior.)

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor | (Inherited from BaseTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

MoveLabelsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveLabelsTouchBehavior Constructor

MoveLabelsTouchBehavior Constructor
[image]

Initializes a new instance of the MoveLabelsTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected MoveLabelsTouchBehavior (
DiagramView diagramView
)

Visual Basic [image] Copy Code

Protected New ( _
diagramView As DiagramView _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

See Also

MoveLabelsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveLabelsTouchBehavior Methods

MoveLabelsTouchBehavior Methods
[image]

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor | (Inherited from BaseTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

MoveLabelsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveLabelsTouchBehavior.SelectController Method

MoveLabelsTouchBehavior.SelectController Method
[image]

Selects a controller based on the specified input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

The input state.

Return Value

A TouchController representing the object that will manage the interaction.

See Also

MoveLabelsTouchBehavior Members
MoveLabelsTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveNodesTouchBehavior Class

MoveNodesTouchBehavior Class
[image]

This class is used when the diagram behavior is set to Behavior.MoveNodes.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class MoveNodesTouchBehavior : BaseTouchBehavior

Visual Basic [image] Copy Code

Public Class MoveNodesTouchBehavior
Inherits BaseTouchBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.MoveNodesTouchBehavior

See Also

MoveNodesTouchBehavior Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveNodesTouchBehavior Members

MoveNodesTouchBehavior Members
Constructors Properties Methods
[image]

This class is used when the diagram behavior is set to Behavior.MoveNodes.

The following tables list the members exposed by the MoveNodesTouchBehavior type.

Protected Constructors

Name | Description
MoveNodesTouchBehavior | Initializes a new instance of the MoveNodesTouchBehavior class.

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior. (Inherited from BaseTouchBehavior.)

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with. (Inherited from BaseTouchBehavior.)

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor |

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

MoveNodesTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveNodesTouchBehavior Constructor

MoveNodesTouchBehavior Constructor
[image]

Initializes a new instance of the MoveNodesTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected MoveNodesTouchBehavior (
DiagramView diagramView
)

Visual Basic [image] Copy Code

Protected New ( _
diagramView As DiagramView _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

See Also

MoveNodesTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveNodesTouchBehavior Methods

MoveNodesTouchBehavior Methods
[image]

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor |

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

MoveNodesTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveNodesTouchBehavior.SelectController Method

MoveNodesTouchBehavior.SelectController Method
[image]

Selects a controller based on the specified input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

The input state.

Return Value

A TouchController representing the object that will manage the interaction.

See Also

MoveNodesTouchBehavior Members
MoveNodesTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.MoveNodesTouchBehavior.SelectMouseCursor Method

MoveNodesTouchBehavior.SelectMouseCursor Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override CursorHint SelectMouseCursor (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectMouseCursor( _
state As InputState _
) As CursorHint

Parameters

state

Return Value

See Also

MoveNodesTouchBehavior Members
MoveNodesTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PanTouchBehavior Class

PanTouchBehavior Class
[image]

Represents a behavior that can be used to pan the diagram.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class PanTouchBehavior : BaseTouchBehavior

Visual Basic [image] Copy Code

Public Class PanTouchBehavior
Inherits BaseTouchBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.PanTouchBehavior

See Also

PanTouchBehavior Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PanTouchBehavior Members

PanTouchBehavior Members
Constructors Properties Methods
[image]

Represents a behavior that can be used to pan the diagram.

The following tables list the members exposed by the PanTouchBehavior type.

Public Constructors

Name | Description
PanTouchBehavior | Initializes a new instance of the PanTouchBehavior class.

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior. (Inherited from BaseTouchBehavior.)

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with. (Inherited from BaseTouchBehavior.)

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor |

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

PanTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PanTouchBehavior Constructor

PanTouchBehavior Constructor
[image]

Initializes a new instance of the PanTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public PanTouchBehavior (
DiagramView diagramView,
bool supportsModify
)

Visual Basic [image] Copy Code

Public New ( _
diagramView As DiagramView, _
supportsModify As Boolean _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

supportsModify

true to enable item modification, or false otherwise.

See Also

PanTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PanTouchBehavior Methods

PanTouchBehavior Methods
[image]

Public Methods

Name | Description
SelectController | Selects a controller based on the specified input.
SelectMouseCursor |

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

PanTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PanTouchBehavior.SelectController Method

PanTouchBehavior.SelectController Method
[image]

Selects a controller based on the specified input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

The input state.

Return Value

A TouchController representing the object that will manage the interaction.

See Also

PanTouchBehavior Members
PanTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PanTouchBehavior.SelectMouseCursor Method

PanTouchBehavior.SelectMouseCursor Method
[image]

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override CursorHint SelectMouseCursor (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectMouseCursor( _
state As InputState _
) As CursorHint

Parameters

state

Return Value

See Also

PanTouchBehavior Members
PanTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PointerInfo Class

PointerInfo Class
[image]

Provides information to touch controllers about the user action.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class PointerInfo

Visual Basic [image] Copy Code

Public Class PointerInfo

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.PointerInfo

See Also

PointerInfo Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PointerInfo Members

PointerInfo Members
Properties
[image]

Provides information to touch controllers about the user action.

The following tables list the members exposed by the PointerInfo type.

Public Properties

Name | Description
CurrentDevicePoint | Gets or sets the current point of the interaction, in device coordinates.
CurrentPoint | Gets or sets the current point of the interaction, in document coordinates.
Id | Gets the pointer identifier.
StartDevicePoint | Gets the initial point, in device coordinates, where the current interaction began.
StartPoint | Gets the initial point, in document coordinates, where the current interaction began.

See Also

PointerInfo Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PointerInfo Properties

PointerInfo Properties
[image]

Public Properties

Name | Description
CurrentDevicePoint | Gets or sets the current point of the interaction, in device coordinates.
CurrentPoint | Gets or sets the current point of the interaction, in document coordinates.
Id | Gets the pointer identifier.
StartDevicePoint | Gets the initial point, in device coordinates, where the current interaction began.
StartPoint | Gets the initial point, in document coordinates, where the current interaction began.

See Also

PointerInfo Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PointerInfo.CurrentDevicePoint Property

PointerInfo.CurrentDevicePoint Property
[image]

Gets or sets the current point of the interaction, in device coordinates.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point CurrentDevicePoint { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentDevicePoint As Point

Property Value

See Also

PointerInfo Members
PointerInfo Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PointerInfo.CurrentPoint Property

PointerInfo.CurrentPoint Property
[image]

Gets or sets the current point of the interaction, in document coordinates.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point CurrentPoint { get; set; }

Visual Basic [image] Copy Code

Public Property CurrentPoint As Point

Property Value

See Also

PointerInfo Members
PointerInfo Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PointerInfo.Id Property

PointerInfo.Id Property
[image]

Gets the pointer identifier.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Id { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Id As Integer

Property Value

See Also

PointerInfo Members
PointerInfo Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PointerInfo.StartDevicePoint Property

PointerInfo.StartDevicePoint Property
[image]

Gets the initial point, in device coordinates, where the current interaction began.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point StartDevicePoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartDevicePoint As Point

Property Value

See Also

PointerInfo Members
PointerInfo Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.PointerInfo.StartPoint Property

PointerInfo.StartPoint Property
[image]

Gets the initial point, in document coordinates, where the current interaction began.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point StartPoint { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property StartPoint As Point

Property Value

See Also

PointerInfo Members
PointerInfo Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.SelectTouchBehavior Class

SelectTouchBehavior Class
[image]

Represents a behavior that can be used only to select existing items. Modifying items and creating new items is disabled.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SelectTouchBehavior : BaseTouchBehavior

Visual Basic [image] Copy Code

Public Class SelectTouchBehavior
Inherits BaseTouchBehavior

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseTouchBehavior
MindFusion.Diagramming.Interaction.SelectTouchBehavior

See Also

SelectTouchBehavior Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.SelectTouchBehavior Members

SelectTouchBehavior Members
Constructors Properties Methods
[image]

Represents a behavior that can be used only to select existing items. Modifying items and creating new items is disabled.

The following tables list the members exposed by the SelectTouchBehavior type.

Public Constructors

Name | Description
SelectTouchBehavior | Initializes a new instance of the SelectTouchBehavior class.

Public Properties

Name | Description
DiagramView | Gets the diagram view associated with the behavior. (Inherited from BaseTouchBehavior.)

Protected Properties

Name | Description
Diagram | Gets a reference to the Diagram instance this behavior is associated with. (Inherited from BaseTouchBehavior.)

Public Methods

Name | Description
SelectController | BaseTouchBehavior.SelectController override.
SelectMouseCursor | (Inherited from BaseTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

SelectTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.SelectTouchBehavior Constructor

SelectTouchBehavior Constructor
[image]

Initializes a new instance of the SelectTouchBehavior class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SelectTouchBehavior (
DiagramView diagramView
)

Visual Basic [image] Copy Code

Public New ( _
diagramView As DiagramView _
)

Parameters

diagramView

The diagram view this behavior will be associated with.

See Also

SelectTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.SelectTouchBehavior Methods

SelectTouchBehavior Methods
[image]

Public Methods

Name | Description
SelectController | BaseTouchBehavior.SelectController override.
SelectMouseCursor | (Inherited from BaseTouchBehavior.)

Protected Methods

Name | Description
SelectHandleCursor | (Inherited from BaseTouchBehavior.)

See Also

SelectTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.SelectTouchBehavior.SelectController Method

SelectTouchBehavior.SelectController Method
[image]

BaseTouchBehavior.SelectController override.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override TouchController SelectController (
InputState state
)

Visual Basic [image] Copy Code

Public Overrides Function SelectController( _
state As InputState _
) As TouchController

Parameters

state

Return Value

See Also

SelectTouchBehavior Members
SelectTouchBehavior Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchController Class

TouchController Class
[image]

Represents objects that handle user touch input.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class TouchController : BaseController

Visual Basic [image] Copy Code

Public MustInherit Class TouchController
Inherits BaseController

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Interaction.BaseController
MindFusion.Diagramming.Interaction.TouchController
MindFusion.Diagramming.Interaction.ModifyLabelController

See Also

TouchController Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchController Members

TouchController Members
Constructors Fields Methods
[image]

Represents objects that handle user touch input.

The following tables list the members exposed by the TouchController type.

Protected Constructors

Name | Description
TouchController | Initializes a new instance of the TouchController class.

Protected Fields

Name | Description
canceled | (Inherited from BaseController.)
validated | (Inherited from BaseController.)

Public Methods

Name | Description
DisallowCursor | (Inherited from BaseController.)
DrawInteraction | Called on the current controller to let it draw an appropriate feedback for the current user action. (Inherited from BaseController.)
OnCancel | Called when the operation is canceled.
OnTouchDown | Called when the user touches the surface.
OnTouchMove | Called when the user moves his finger across the surface.
OnTouchUp | Called when the user lifts his finger from the surface.
Validate | Called to validate the operation at current pointer position. (Inherited from BaseController.)

See Also

TouchController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchController Constructor

TouchController Constructor
[image]

Initializes a new instance of the TouchController class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected TouchController ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

TouchController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchController Methods

TouchController Methods
[image]

Public Methods

Name | Description
DisallowCursor | (Inherited from BaseController.)
DrawInteraction | Called on the current controller to let it draw an appropriate feedback for the current user action. (Inherited from BaseController.)
OnCancel | Called when the operation is canceled.
OnTouchDown | Called when the user touches the surface.
OnTouchMove | Called when the user moves his finger across the surface.
OnTouchUp | Called when the user lifts his finger from the surface.
Validate | Called to validate the operation at current pointer position. (Inherited from BaseController.)

See Also

TouchController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchController.OnCancel Method

TouchController.OnCancel Method
[image]

Called when the operation is canceled.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnCancel (
PointerInfo info
)

Visual Basic [image] Copy Code

Public Overridable Sub OnCancel( _
info As PointerInfo _
)

Parameters

info

An object that provides information about the touch.

See Also

TouchController Members
TouchController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchController.OnTouchDown Method

TouchController.OnTouchDown Method
[image]

Called when the user touches the surface.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnTouchDown (
PointerInfo info
)

Visual Basic [image] Copy Code

Public Overridable Sub OnTouchDown( _
info As PointerInfo _
)

Parameters

info

An object that provides information about the touch.

See Also

TouchController Members
TouchController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchController.OnTouchMove Method

TouchController.OnTouchMove Method
[image]

Called when the user moves his finger across the surface.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnTouchMove (
PointerInfo info
)

Visual Basic [image] Copy Code

Public Overridable Sub OnTouchMove( _
info As PointerInfo _
)

Parameters

info

An object that provides information about the touch.

See Also

TouchController Members
TouchController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchController.OnTouchUp Method

TouchController.OnTouchUp Method
[image]

Called when the user lifts his finger from the surface.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnTouchUp (
PointerInfo info
)

Visual Basic [image] Copy Code

Public Overridable Sub OnTouchUp( _
info As PointerInfo _
)

Parameters

info

An object that provides information about the touch.

See Also

TouchController Members
TouchController Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchEventArgs Class

TouchEventArgs Class
[image]

Contains the arguments passed to the event handlers of touch-related events.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TouchEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class TouchEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Interaction.TouchEventArgs

See Also

TouchEventArgs Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchEventArgs Members

TouchEventArgs Members
Properties
[image]

Contains the arguments passed to the event handlers of touch-related events.

The following tables list the members exposed by the TouchEventArgs type.

Public Properties

Name | Description
ContactSize | Gets the touch size.
DeviceLocation | Gets the touch location, in device coordinates.
Flags | For internal use.
Location | Gets the touch location, in document coordinates.
Mask | For internal use.
Timestamp | Gets a value indicating when the touch occurred.
TouchId | Gets the touch identifier.

See Also

TouchEventArgs Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchEventArgs Properties

TouchEventArgs Properties
[image]

Public Properties

Name | Description
ContactSize | Gets the touch size.
DeviceLocation | Gets the touch location, in device coordinates.
Flags | For internal use.
Location | Gets the touch location, in document coordinates.
Mask | For internal use.
Timestamp | Gets a value indicating when the touch occurred.
TouchId | Gets the touch identifier.

See Also

TouchEventArgs Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchEventArgs.ContactSize Property

TouchEventArgs.ContactSize Property
[image]

Gets the touch size.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size ContactSize { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ContactSize As Size

Property Value

A Size object.

See Also

TouchEventArgs Members
TouchEventArgs Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchEventArgs.DeviceLocation Property

TouchEventArgs.DeviceLocation Property
[image]

Gets the touch location, in device coordinates.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point DeviceLocation { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property DeviceLocation As Point

Property Value

A Point object.

See Also

TouchEventArgs Members
TouchEventArgs Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchEventArgs.Flags Property

TouchEventArgs.Flags Property
[image]

For internal use.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Flags { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Flags As Integer

Property Value

An integer value.

See Also

TouchEventArgs Members
TouchEventArgs Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchEventArgs.Location Property

TouchEventArgs.Location Property
[image]

Gets the touch location, in document coordinates.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Point Location { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Location As Point

Property Value

A Point object.

See Also

TouchEventArgs Members
TouchEventArgs Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchEventArgs.Mask Property

TouchEventArgs.Mask Property
[image]

For internal use.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Mask { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Mask As Integer

Property Value

An integer value.

See Also

TouchEventArgs Members
TouchEventArgs Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchEventArgs.Timestamp Property

TouchEventArgs.Timestamp Property
[image]

Gets a value indicating when the touch occurred.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Timestamp { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Timestamp As Integer

Property Value

An integer value.

See Also

TouchEventArgs Members
TouchEventArgs Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.TouchEventArgs.TouchId Property

TouchEventArgs.TouchId Property
[image]

Gets the touch identifier.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int TouchId { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property TouchId As Integer

Property Value

An integer value.

See Also

TouchEventArgs Members
TouchEventArgs Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualConnectionPoint Class

VirtualConnectionPoint Class
[image]

Represents the connection points of disconnected links.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VirtualConnectionPoint : ConnectionPoint

Visual Basic [image] Copy Code

Public Class VirtualConnectionPoint
Inherits ConnectionPoint

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.ConnectionPoint
MindFusion.Diagramming.Interaction.VirtualConnectionPoint

See Also

VirtualConnectionPoint Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualConnectionPoint Members

VirtualConnectionPoint Members
Constructors Properties Methods
[image]

Represents the connection points of disconnected links.

The following tables list the members exposed by the VirtualConnectionPoint type.

Public Constructors

Name | Description
VirtualConnectionPoint | Initializes a new instance of the VirtualConnectionPoint class.

Public Properties

Name | Description
Anchor | Gets or sets the anchor point associated with the connection point. (Inherited from ConnectionPoint.)
Row | Gets the index of a constituent item within the associated node where the link represented by this connection point is connected, or -1, if the link is connected to the node itself. (Inherited from ConnectionPoint.)

Protected Properties

Name | Description
Incoming | Gets a flag indicating whether this connection point is at the origin or the destination of the associated link. (Inherited from ConnectionPoint.)
Link | Gets the link associated with this connection point. (Inherited from ConnectionPoint.)
Node | Gets the node associated with this connection point. (Inherited from ConnectionPoint.)

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
AlignToNode | ConnectionPoint.AlignToNode override.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes. (Inherited from ConnectionPoint.)
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point. (Inherited from ConnectionPoint.)
GetAnchorPos | Overloaded. Returns a point from the node's associated anchor pattern. (Inherited from ConnectionPoint.)
GetEndPoint | Calculates the coordinates of the this connection point expressed in document coordinates. (Inherited from ConnectionPoint.)
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node. (Inherited from ConnectionPoint.)
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point. (Inherited from ConnectionPoint.)
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | Checks whether the relationship represented by the associated link would change if the link is attached to the specified node at the specified point. (Inherited from ConnectionPoint.)
NearestAnchorPoint | Returns the anchor point closest to the specified point from the node's associated anchor pattern. (Inherited from ConnectionPoint.)
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
PositionFromNode | Overloaded. Returns the position of the connection point. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node. (Inherited from ConnectionPoint.)

Protected Methods

Name | Description
GetNearestBorderPoint | Returns the nearest point lying on the node border. (Inherited from ConnectionPoint.)
UpdateFromPoint | Updates the connection state according to the specified point, without changing the related node. (Inherited from ConnectionPoint.)

See Also

VirtualConnectionPoint Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualConnectionPoint Constructor

VirtualConnectionPoint Constructor
[image]

Initializes a new instance of the VirtualConnectionPoint class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public VirtualConnectionPoint (
DiagramLink link,
bool incoming
)

Visual Basic [image] Copy Code

Public New ( _
link As DiagramLink, _
incoming As Boolean _
)

Parameters

link

The link whose connection to a node is managed by this ConnectionPoint.

incoming

Specifies which end of the link is represented by this ConnectionPoint.

See Also

VirtualConnectionPoint Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualConnectionPoint Methods

VirtualConnectionPoint Methods
[image]

Public Methods

Name | Description
AddLinkToNode | ConnectionPoint.AddLinkToNode override.
AlignToNode | ConnectionPoint.AlignToNode override.
CalculateIntersections | Determines whether the end of a link should be aligned to the point where the node contour is intersected by the line connecting the centers of the connected nodes. (Inherited from ConnectionPoint.)
CanMoveLink | Checks whether the specified point, expressed in document coordinates, is a valid location for this connection point. (Inherited from ConnectionPoint.)
GetAnchorPos | Overloaded. Returns a point from the node's associated anchor pattern. (Inherited from ConnectionPoint.)
GetEndPoint | Calculates the coordinates of the this connection point expressed in document coordinates. (Inherited from ConnectionPoint.)
GetInitialPoint | Returns a point (usually the center of the bounding rectangle) contained within the associated node. (Inherited from ConnectionPoint.)
GetIntersection | Calculates the intersection point between the specified line segment and the contour of the node associated with this connection point. (Inherited from ConnectionPoint.)
GetNodeRect | Returns the bounding rectangle of the node associated with this connection point. (Inherited from ConnectionPoint.)
LinkChanges | Checks whether the relationship represented by the associated link would change if the link is attached to the specified node at the specified point. (Inherited from ConnectionPoint.)
NearestAnchorPoint | Returns the anchor point closest to the specified point from the node's associated anchor pattern. (Inherited from ConnectionPoint.)
NodesIntersect | Checks whether the node associated with the current connection point and the node associated with the specified connection point intersect. (Inherited from ConnectionPoint.)
PositionFromNode | Overloaded. Returns the position of the connection point. (Inherited from ConnectionPoint.)
RemoveLinkFromNode | ConnectionPoint.RemoveLinkFromNode override.
SameNode | Checks whether the current connection point and the specified connection point are associated with the same node. (Inherited from ConnectionPoint.)

Protected Methods

Name | Description
GetNearestBorderPoint | Returns the nearest point lying on the node border. (Inherited from ConnectionPoint.)
UpdateFromPoint | Updates the connection state according to the specified point, without changing the related node. (Inherited from ConnectionPoint.)

See Also

VirtualConnectionPoint Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualConnectionPoint.AddLinkToNode Method

VirtualConnectionPoint.AddLinkToNode Method
[image]

ConnectionPoint.AddLinkToNode override.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void AddLinkToNode ()

Visual Basic [image] Copy Code

Public Overrides Sub AddLinkToNode ()

See Also

VirtualConnectionPoint Members
VirtualConnectionPoint Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualConnectionPoint.AlignToNode Method

VirtualConnectionPoint.AlignToNode Method
[image]

ConnectionPoint.AlignToNode override.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void AlignToNode (
Point point
)

Visual Basic [image] Copy Code

Public Overrides Sub AlignToNode( _
point As Point _
)

Parameters

point

The point to align.

See Also

VirtualConnectionPoint Members
VirtualConnectionPoint Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualConnectionPoint.RemoveLinkFromNode Method

VirtualConnectionPoint.RemoveLinkFromNode Method
[image]

ConnectionPoint.RemoveLinkFromNode override.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override void RemoveLinkFromNode ()

Visual Basic [image] Copy Code

Public Overrides Sub RemoveLinkFromNode ()

See Also

VirtualConnectionPoint Members
VirtualConnectionPoint Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualNode Class

VirtualNode Class
[image]

A special node used as origin or destination of disconnected links.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class VirtualNode : DiagramNode

Visual Basic [image] Copy Code

Public Class VirtualNode
Inherits DiagramNode

Inheritance Hierarchy

System.Object
Microsoft.Maui.Controls.BindableObject
MindFusion.Diagramming.DiagramItem
MindFusion.Diagramming.DiagramNode
MindFusion.Diagramming.Interaction.VirtualNode

See Also

VirtualNode Members
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualNode Members

VirtualNode Members
Fields Properties Methods
[image]

A special node used as origin or destination of disconnected links.

The following tables list the members exposed by the VirtualNode type.

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
Instance | The sole instance of this class.
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

Public Properties

Name | Description
AllowIncomingLinks | Gets or sets a value indicating whether users are allowed to draw incoming links to this node. (Inherited from DiagramNode.)
AllowOutgoingLinks | Gets or sets a value indicating whether users are allowed to draw outgoing links from this node. (Inherited from DiagramNode.)
AnchorPattern | Gets or sets the anchor points to which links are attached when connected to the node. (Inherited from DiagramNode.)
AttachedNodes | Gets a reference to the list of items that are attached to this one. (Inherited from DiagramItem.)
Bounds | Gets or sets the rectangle that defines the position of the diagram node. (Inherited from DiagramNode.)
Brush | Gets or sets the brush used to fill the interior of this item. (Inherited from DiagramItem.)
Constraints | Allows applying constraints to the location and size of the node. (Inherited from DiagramNode.)
Container | Gets the container node this item belongs to, if any. (Inherited from DiagramNode.)
EffectiveBrush | Gets the effective brush of the item. (Inherited from DiagramItem.)
EffectiveFont | Gets the currently effective font of the item. (Inherited from DiagramItem.)
EffectivePen | Gets the effective pen of the item. (Inherited from DiagramItem.)
EffectiveShadowBrush | Gets the effective shadow brush of the item. (Inherited from DiagramItem.)
EffectiveTextBrush | Gets the effective text brush of the item. (Inherited from DiagramItem.)
Effects | Gets a collection with all effects applied to this node. (Inherited from DiagramNode.)
EnabledHandles | Gets or sets the kinds of modifications that end-users are permitted to perform on the node. (Inherited from DiagramNode.)
Expandable | Gets or sets a value indicating whether users are allowed to expand or collapse the subtree that starts from this node. (Inherited from DiagramNode.)
Expanded | Gets or sets a value indicating whether the subtree starting from this node is expanded. (Inherited from DiagramNode.)
Font | Gets or sets the font used to render the item's text. (Inherited from DiagramItem.)
HandlesStyle | Gets or sets a value indicating how the node adjustment handles behave and what do they look like. (Inherited from DiagramNode.)
HyperLink | Gets or sets the hyper link. (Inherited from DiagramItem.)
Id | Gets or sets user-defined identifier associated with this item. (Inherited from DiagramItem.)
IgnoreLayout | Gets or sets a value indicating whether the position of this item should not be changed by automatic layout methods. (Inherited from DiagramItem.)
IncomingLinks | Gets a collection of links that point to the node. (Inherited from DiagramNode.)
IsAttached | Gets a value indicating whether this item is attached to another item. (Inherited from DiagramNode.)
Labels | Returns the list of all labels displayed by this node. (Inherited from DiagramNode.)
LayerIndex | Gets or sets the zero-based index of the layer this item is associated with, or -1, if the item is not associated with a layer. (Inherited from DiagramItem.)
LayoutTraits | Contains properties specific to each layout algorithm. (Inherited from DiagramItem.)
Locked | Gets or sets a value indicating whether users are allowed to edit the diagram item. (Inherited from DiagramItem.)
Master | Gets the item this item is attached to, if any. (Inherited from DiagramNode.)
Obstacle | Gets or sets a value indicating whether this node is considered an obstacle by the link-routing algorithm. (Inherited from DiagramNode.)
OutgoingLinks | Gets a collection of links that start from this node. (Inherited from DiagramNode.)
Parent | Gets the diagram that contains this item. (Inherited from DiagramItem.)
Pen | Gets or sets the pen used to paint the frame of the item. (Inherited from DiagramItem.)
RotationAngle | Gets or sets the rotation angle of this node. (Inherited from DiagramNode.)
RuntimeIndex | For internal use. (Inherited from DiagramItem.)
Selected | Gets or sets a value indicating whether a diagram item is selected. (Inherited from DiagramItem.)
ShadowBrush | Gets or sets the brush used to paint the item's shadow. (Inherited from DiagramItem.)
ShadowOffsetX | Gets or sets the horizontal offset of the shadow of this item. (Inherited from DiagramItem.)
ShadowOffsetY | Gets or sets the vertical offset of the shadow of this item. (Inherited from DiagramItem.)
Style | Gets or sets the style associated with the item. (Inherited from DiagramItem.)
Tag | Gets or sets user-defined data associated with this item. (Inherited from DiagramItem.)
TextBrush | Gets or sets the brush used to paint texts inside the item. (Inherited from DiagramItem.)
TextPadding | Gets or sets the spacing between the item boundaries and its text. (Inherited from DiagramItem.)
TopLevel | DiagramItem.TopLevel override. (Inherited from DiagramNode.)
Visible | Gets or sets a value indicating whether this item is visible. (Inherited from DiagramItem.)
Weight | Gets or sets a weight value used in layout and path-finding algorithms. (Inherited from DiagramItem.)
ZIndex | Gets or sets the z-order position of this item. (Inherited from DiagramItem.)

Protected Properties

Name | Description
HasItems | Determines whether the node supports connections to its constituent elements. (Inherited from DiagramNode.)
MeasureUnit | Returns the diagram measure unit. (Inherited from DiagramItem.)

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Override in a derived class to provide implementation specific drawing for the node. (Inherited from DiagramNode.)
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToJson | Saves the item content into a JsonObject. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

VirtualNode Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualNode Fields

VirtualNode Fields
[image]

Public Fields

Name | Description
BrushProperty | Identifies the Brush property. (Inherited from DiagramItem.)
HyperLinkProperty | Identifies the HyperLink property. (Inherited from DiagramItem.)
IdProperty | Identifies the Id property. (Inherited from DiagramItem.)
IgnoreLayoutProperty | Identifies the IgnoreLayout property. (Inherited from DiagramItem.)
Instance | The sole instance of this class.
LayerIndexProperty | Identifies the LayerIndex property. (Inherited from DiagramItem.)
LockedProperty | Identifies the Locked property. (Inherited from DiagramItem.)
PenProperty | Identifies the Pen property. (Inherited from DiagramItem.)
ShadowBrushProperty | Identifies the ShadowBrush property. (Inherited from DiagramItem.)
ShadowOffsetXProperty | Identifies the ShadowOffsetX property. (Inherited from DiagramItem.)
ShadowOffsetYProperty | Identifies the ShadowOffsetY property. (Inherited from DiagramItem.)
TagProperty | Identifies the Tag property. (Inherited from DiagramItem.)
TextBrushProperty | Identifies the TextBrush property. (Inherited from DiagramItem.)
TextPaddingProperty | Identifies the TextPadding property. (Inherited from DiagramItem.)
VisibleProperty | Identifies the Visible property. (Inherited from DiagramItem.)
WeightProperty | Idenitifies the Weight property. (Inherited from DiagramItem.)
ZIndexProperty | Identifies the ZIndex property. (Inherited from DiagramItem.)

See Also

VirtualNode Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualNode.Instance Field

VirtualNode.Instance Field
[image]

The sole instance of this class.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public static VirtualNode Instance

Visual Basic [image] Copy Code

Public Shared Instance As VirtualNode

See Also

VirtualNode Members
VirtualNode Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualNode Methods

VirtualNode Methods
[image]

Public Methods

Name | Description
AcceptLinks | Determines whether the node can be connected with links of the specified type. (Inherited from DiagramNode.)
AddLabel | Overloaded. (Inherited from DiagramNode.)
AttachManipulator | Adds the specified manipulator to this node. (Inherited from DiagramNode.)
AttachToLink | Overloaded. Attaches this node to a link. (Inherited from DiagramNode.)
AttachToNode | Attaches this node to the specified node using the specified attaching type. (Inherited from DiagramNode.)
Clone | Creates a copy of this item. (Inherited from DiagramItem.)
Collapse | Hides all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
ContainsPoint | Overloaded. DiagramItem.ContainsPoint override. (Inherited from DiagramNode.)
CreateConnectionPoint | Creates a connection point between this node and the specified link at the specified point.
Detach | Detaches this node from its master item. (Inherited from DiagramNode.)
DetachManipulator | Removes the specified manipulator from this node. (Inherited from DiagramNode.)
Draw | DiagramItem.Draw override. Draws the item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawAnchors | Draws the anchor points of this node. (Inherited from DiagramNode.)
DrawHandles | DiagramItem.DrawHandles override. (Inherited from DiagramNode.)
DrawLocal | Override in a derived class to provide implementation specific drawing for the node. (Inherited from DiagramNode.)
DrawShadow | DiagramItem.DrawShadow override. Draws the shadow of this item on the specified IGraphics surface. (Inherited from DiagramNode.)
DrawShadowLocal | Override in a derived class to provide implementation specific drawing for the shadow of the node. (Inherited from DiagramNode.)
Expand | Shows all nodes and links in the subtree starting from this node. (Inherited from DiagramNode.)
GetAllLinks | Gets all links connected to this node. (Inherited from DiagramNode.)
GetAllOutgoingLinks | Overloaded. Collects all links going out of this node. (Inherited from DiagramNode.)
GetBounds | Gets the bounding rectangle of this item. (Inherited from DiagramItem.)
GetCenter | Gets the center of this node's bounding rectangle. (Inherited from DiagramNode.)
GetClosestAnchorPoint | Returns the index of the anchor point that lies at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetIntersection | Calculates the intersection point between the segment defined by the specified point pair and the node's outline. (Inherited from DiagramNode.)
GetNearestBorderPoint | Returns a point that lies on the outline of this node, at the shortest distance from the specified point. (Inherited from DiagramNode.)
GetOutlinePoly | DiagramItem.GetOutlinePoly override. (Inherited from DiagramNode.)
GetRepaintRect | DiagramItem.GetRepaintRect override. (Inherited from DiagramNode.)
GetRotatedBounds | Overloaded. Gets the bounding rectangle of this node or the bounding rectangle of another rectangle rotated at a specified angle around a specified point. (Inherited from DiagramNode.)
HitTest | Returns the diagram item that contains the specified point. (Inherited from DiagramItem.)
HitTestHandle | DiagramItem.HitTestHandle override. (Inherited from DiagramNode.)
Intersects | Determines whether this node's outline intersects with the outline of the specified node. (Inherited from DiagramNode.)
LabelFromPoint | Returns the label whose layout rectangle contains the specified point. (Inherited from DiagramNode.)
Move | Moves the node to the specified location. (Inherited from DiagramNode.)
NotInteractive | Gets whether the user is prevented from manipulating this item. (Inherited from DiagramItem.)
OnDragOut | Invoked when a diagram item is being dragged out of this node. (Inherited from DiagramNode.)
OnDragOver | Invoked when a diagram item is being dragged over this node. (Inherited from DiagramNode.)
OnDropOver | Invoked when a diagram item is dropped over this node. (Inherited from DiagramNode.)
OnLoad | Called after successful deserialization. (Inherited from DiagramItem.)
ReassignAnchorPoints | Reassigns links to anchor points so that they are evenly distributed. (Inherited from DiagramNode.)
ReassignUnanchoredLinks | Reassigns unanchored links (Inherited from DiagramNode.)
RemoveLabel | Removes the specified label from this node. (Inherited from DiagramNode.)
Resize | Resizes the node. (Inherited from DiagramNode.)
RestoreItemProperties | For internal use. (Inherited from DiagramItem.)
SaveItemProperties | For internal use. (Inherited from DiagramItem.)
SetExpandedFlag | Sets the 'expanded' flag, repainting the node. (Inherited from DiagramNode.)
ZBottom | Moves the item to the bottom of the z-order. (Inherited from DiagramItem.)
ZLevelDown | Moves the item one level down in the z-order. (Inherited from DiagramItem.)
ZLevelUp | Moves the item one level up in the z-order. (Inherited from DiagramItem.)
ZTop | Moves the item to the top of the z-order. (Inherited from DiagramItem.)

Protected Methods

Name | Description
AddManipulator | Adds the specified manipulator to this object. (Inherited from DiagramItem.)
CreateProperties | DiagramItem.CreateProperties override. (Inherited from DiagramNode.)
CreateState | DiagramItem.CreateState override. (Inherited from DiagramNode.)
DrawManipulators | Overloaded. Draws the associated manipulators on a specified graphics. (Inherited from DiagramItem.)
FreeResources | Called when the item is completely disassociated from a Diagram, that is, when it is no longer referenced from an item collection or the undo/redo history. (Inherited from DiagramItem.)
GetAllIncomingLinks | Overloaded. Collects all links entering this node. (Inherited from DiagramNode.)
GetLocalBounds | Gets this node's bounding rectangle in local coordinates. (Inherited from DiagramNode.)
GetRgnInRect | Creates and returns a Region object for this node as though it is contained in the specified rectangle. (Inherited from DiagramNode.)
GetValue | Gets the effective value of the style property with the specified name. (Inherited from DiagramItem.)
HandleTap | Invoked when the user releases his finger over this item. (Inherited from DiagramItem.)
LoadFromJson | Loads the item content from a JsonObject. (Inherited from DiagramNode.)
LoadFromXml | DiagramItem.LoadFromXml override. (Inherited from DiagramNode.)
OnAdd | Called when the item is added to a Diagram, either by the user, programmatically or via undo / redo. (Inherited from DiagramItem.)
OnChildModified | Called when a group child node has been modified. (Inherited from DiagramItem.)
OnFontChanged | Invoked when the Font property has changed. (Inherited from DiagramItem.)
OnMeasureUnitChanged | Called when the diagram's MeasureUnit changes. (Inherited from DiagramItem.)
OnModify | Invoked when the user moves or resizes this node. (Inherited from DiagramNode.)
OnRemove | DiagramItem.OnRemove override. (Inherited from DiagramNode.)
OnRotationAngleChanged | Invoked when the rotation angle of this node has been changed, either programmatically or interactively. (Inherited from DiagramNode.)
OnStyleChanged | Invoked when the associated style or theme have changed. (Inherited from DiagramItem.)
OnUpdateBounds | Overloaded. Invoked when the bounding rectangle of the node has changed. (Inherited from DiagramNode.)
OnZoomChanged | Called when the MindFusion.Diagramming for .NET MAUI's ZoomFactor changes. (Inherited from DiagramItem.)
RaiseClicked | Raises an event which notifies that a node has been clicked. (Inherited from DiagramNode.)
RemoveManipulator | Removes the specified manipulator from the object. (Inherited from DiagramItem.)
Repaint | Overloaded. Repaints the specified region of the diagram. (Inherited from DiagramItem.)
RestoreProperties | DiagramItem.RestoreProperties override. (Inherited from DiagramNode.)
RestoreState | DiagramItem.RestoreState override. (Inherited from DiagramNode.)
SaveProperties | DiagramItem.SaveProperties override. (Inherited from DiagramNode.)
SaveState | DiagramItem.SaveState override. (Inherited from DiagramNode.)
SaveToJson | Saves the item content into a JsonObject. (Inherited from DiagramNode.)
SaveToXml | Saves the item content into an XML element. (Inherited from DiagramNode.)
ScaleElements | Scales the node's elements by specified amount. (Inherited from DiagramNode.)
SetDiagramDirty | Marks the diagram as changed. (Inherited from DiagramItem.)
SetExpandable | Internally sets the expandable state of this object to the specified value, adding or removing an Expander manipulator object if necessary. (Inherited from DiagramNode.)
SetExpanded | DiagramItem.SetExpanded override. (Inherited from DiagramNode.)
SetIncomingLinks | Sets the incoming links collection of this node. (Inherited from DiagramNode.)
SetOutgoingLinks | Sets the outgoing links collection of this node. (Inherited from DiagramNode.)
SetReflexive | Invoked to let a node set the shape of a reflexive link connected to it. (Inherited from DiagramNode.)
ShouldRender | Determines whether the item should be rendered in the current context. (Inherited from DiagramItem.)
ShouldRenderAnchors | Determines whether the node should render its anchor points. (Inherited from DiagramNode.)
UpdateLinkIntersections | Updates the intersection points of links, connected to this node and its outline, usually in response to change in the node's shape. (Inherited from DiagramNode.)
UpdateLinkPositions | Updates the end points of the links, connected to this node, usually in response to change in the node's size or shape. (Inherited from DiagramNode.)

See Also

VirtualNode Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Interaction.VirtualNode.CreateConnectionPoint Method

VirtualNode.CreateConnectionPoint Method
[image]

Creates a connection point between this node and the specified link at the specified point.

Namespace: MindFusion.Diagramming.Interaction
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override ConnectionPoint CreateConnectionPoint (
DiagramLink link,
Point pt,
bool incoming
)

Visual Basic [image] Copy Code

Public Overrides Function CreateConnectionPoint( _
link As DiagramLink, _
pt As Point, _
incoming As Boolean _
) As ConnectionPoint

Parameters

link

A DiagramLink that should be connected to this node.

pt

The point at which the link should be connected.

incoming

true if link is an incoming link, otherwise, false.

Return Value

A ConnectionPoint instance representing the connection.

See Also

VirtualNode Members
VirtualNode Class
MindFusion.Diagramming.Interaction Namespace


MindFusion.Diagramming.Lanes Namespace
Classes Interfaces Enumerations

Classes

Class | Description
CellBoundsEventArgs | Contains the arguments passed to handlers of the CellBoundsChanged event.
Grid | Represents a lane grid.
Header | Represents a header in a grid view.
HeaderCollection | Represents a strongly-typed collection of Header objects.
HeaderEventArgs | Contains the arguments passed to handlers of header-related events.
HeaderResizeEventArgs | Contains the arguments passed to handlers of header resize events.
Style | Encapsulates the appearance properties of an element in a lane grid.

Interfaces

Interface | Description
ICell | Defines a base for cells in a lane list.

Enumerations

Enumeration | Description
ResizeType | Specifies how to resize child columns and rows in the lanes grid when their parent column or row is resized.


MindFusion.Diagramming.Lanes.CellBoundsEventArgs Class

CellBoundsEventArgs Class
[image]

Contains the arguments passed to handlers of the CellBoundsChanged event.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CellBoundsEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class CellBoundsEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Lanes.CellBoundsEventArgs

See Also

CellBoundsEventArgs Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs Members

CellBoundsEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of the CellBoundsChanged event.

The following tables list the members exposed by the CellBoundsEventArgs type.

Public Properties

Name | Description
Cell | Gets the cell which has been resized.
NewBounds | Gets the new bounding rectangle of the cell.
OldBounds | Gets the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs Properties

CellBoundsEventArgs Properties
[image]

Public Properties

Name | Description
Cell | Gets the cell which has been resized.
NewBounds | Gets the new bounding rectangle of the cell.
OldBounds | Gets the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs.Cell Property

CellBoundsEventArgs.Cell Property
[image]

Gets the cell which has been resized.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ICell Cell { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Cell As ICell

Property Value

An instance of a class implementing the ICell interface that represents the cell that has been resized.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs.NewBounds Property

CellBoundsEventArgs.NewBounds Property
[image]

Gets the new bounding rectangle of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect NewBounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NewBounds As Rect

Property Value

A Rectangle object specifying the new bounding rectangle of the cell.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.CellBoundsEventArgs.OldBounds Property

CellBoundsEventArgs.OldBounds Property
[image]

Gets the old bounding rectangle of the cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect OldBounds { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property OldBounds As Rect

Property Value

A Rectangle object specifying the old bounding rectangle of the cell.

See Also

CellBoundsEventArgs Members
CellBoundsEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Class

Grid Class
Remarks See Also
[image]

Represents a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Grid

Visual Basic [image] Copy Code

Public Class Grid

Remarks

The Grid class lets you define a background grid or table that can be used in Swimlane diagrams or Gantt charts. To activate the grid, set the EnableLanes property of the Diagram class to true.

Grids can include varying number of lanes, divided into child rows and columns whose intersections form cells. The grid can be resized by setting the ColumnCount and RowCount properties or by adding headers to the ColumnHeaders and RowHeaders collections. A column or row can be divided into child elements by adding to the SubHeaders collection of a Header, which lets you form a complex hierarchy of unlimited depth.

The intersection of rows and columns can be either a simple cell for bottommost elements in the lane hierarchy, or a group of cells for parent rows and columns. Cells or cell groups can be accessed by the Item property, that lets you index cells either by their integer positions, or by their Header objects.

The position of the grid and grid headers within the diagram document is defined by TopMargin and LeftMargin, which specify the grid offset relative to Bounds. HookHeaders enables lane headers to be anchored to the left or right side of the control's visible area. The sizes of headers at different levels in the lane hierarchy can be set in a single operation by using the RowHeadersWidths and ColumnHeadersHeights properties.

The appearance of the lanes grid can be customized further in the AlignCells property which specifies whether cells are aligned to each other, the HeadersOnTop property which specifies whether headers should appear on top of the z-order, and the TopLeftAreaStyle specifying the appearance of the grid's top left corner.

The Grid class provides many miscellaneous methods that can be used to find grid elements, for determining their bounds and for hit-testing.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.Grid

See Also

Grid Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Members

Grid Members
Properties Methods Events
[image]

Represents a lane grid.

The following tables list the members exposed by the Grid type.

Public Properties

Name | Description
AlignCells | Gets or sets a value indicating whether cells are aligned one next to another so that their borders don't overlap.
AllowResizeHeaders | Gets or sets a value indicating whether users can resize the headers of the grid interactively.
ColumnCount | Gets or sets the number of columns in the grid.
ColumnHeaders | Gets the collection with the topmost column headers.
ColumnHeadersHeights | Gets or sets an array with float values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.
HeadersOnTop | Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.
HookHeaders | Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
Item | Overloaded. Gets a cell or cluster of cells from the grid.
LeftMargin | Gets or sets the offset of the lane grid from the left side of the document bounds.
MinHeaderSize | Gets or sets the minimum size of a header.
RowCount | Gets or sets the number of rows in the grid.
RowHeaders | Gets the collection with the leftmost row headers.
RowHeadersWidths | Gets or sets an array with float values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.
TopLeftAreaStyle | Gets or sets the style of the area above all row headers and to the left of all column headers.
TopLeftAreaText | Gets or sets the text displayed in the top left area.
TopLeftAreaTextColor | Gets or sets the color of the text displayed in the top left area.
TopLeftAreaTextFont | Gets or sets the font used to display text in the top left area.
TopLeftAreaTextFormat | Gets or sets the format of the text displayed in the top left area.
TopMargin | Gets or sets the offset of the lane grid from the top side of the document bounds.

Public Methods

Name | Description
FindColumn | Returns the first column header matching the specified caption.
FindRow | Finds the first row whose header caption matches the specified string.
GetCellBounds | Overloaded. Returns the bounding rectangle of a cell.
GetCellColumn | Returns the column index of the specified cell.
GetCellFromPoint | Gets the cell located at the specified point.
GetCellRow | Returns the row index of the specified cell.
GetColumn | Returns the column header with the specified index from the bottommost column header level.
GetColumnCount | Returns the number of columns in the bottommost column header level.
GetColumnHeaderBounds | Returns the bounding rectangle of all column headers.
GetColumnIndex | Returns the 0-based index of the specified column.
GetHeaderBounds | Returns the bounding rectangle of the specified header.
GetHeaderFromPoint | Overloaded. Gets the Header that is located at the specified point.
GetHeaderLevel | Gets the level of the specified header.
GetHeaderParent | Returns the header containing the specified header, or null, if the header is a top-level header.
GetRow | Returns the row header with the specified index from the bottommost row header level.
GetRowCount | Returns the number of rows in the bottommost row header level.
GetRowHeaderBounds | Returns the bounding rectangle of all row headers.
GetRowIndex | Returns the 0-based index of the specified row.
InsertAfter | Inserts a new header after the specified header and returns a reference to it.
InsertBefore | Inserts a new header before the specified header and returns a reference to it.
RaiseHeaderAdded | Raises the HeaderAdded event from outside the lane grid.
RaiseHeaderResized | Raises the HeaderResized event from outside the lane grid.
RaiseHeaderStartResizing | Raises the HeaderStartResizing event from outside the lane grid.
ResizeColumnHeaderHeights | Resizes the heights of all column headers from the specified level with the specified amount.
ResizeRowHeaderWidths | Resizes the widths of all row headers from the specified level with the specified amount.

Public Events

Name | Description
CellBoundsChanged | Raised when the bounding rectangle of a cell has been changed.
HeaderAdded | Raised when a header has been inserted to the grid through a call to the InsertBefore or InsertAfter methods.
HeaderResized | Raised when the user finished resizing a header.
HeaderStartResizing | Raises when the user starts resizing a header.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Methods

Grid Methods
[image]

Public Methods

Name | Description
FindColumn | Returns the first column header matching the specified caption.
FindRow | Finds the first row whose header caption matches the specified string.
GetCellBounds | Overloaded. Returns the bounding rectangle of a cell.
GetCellColumn | Returns the column index of the specified cell.
GetCellFromPoint | Gets the cell located at the specified point.
GetCellRow | Returns the row index of the specified cell.
GetColumn | Returns the column header with the specified index from the bottommost column header level.
GetColumnCount | Returns the number of columns in the bottommost column header level.
GetColumnHeaderBounds | Returns the bounding rectangle of all column headers.
GetColumnIndex | Returns the 0-based index of the specified column.
GetHeaderBounds | Returns the bounding rectangle of the specified header.
GetHeaderFromPoint | Overloaded. Gets the Header that is located at the specified point.
GetHeaderLevel | Gets the level of the specified header.
GetHeaderParent | Returns the header containing the specified header, or null, if the header is a top-level header.
GetRow | Returns the row header with the specified index from the bottommost row header level.
GetRowCount | Returns the number of rows in the bottommost row header level.
GetRowHeaderBounds | Returns the bounding rectangle of all row headers.
GetRowIndex | Returns the 0-based index of the specified row.
InsertAfter | Inserts a new header after the specified header and returns a reference to it.
InsertBefore | Inserts a new header before the specified header and returns a reference to it.
RaiseHeaderAdded | Raises the HeaderAdded event from outside the lane grid.
RaiseHeaderResized | Raises the HeaderResized event from outside the lane grid.
RaiseHeaderStartResizing | Raises the HeaderStartResizing event from outside the lane grid.
ResizeColumnHeaderHeights | Resizes the heights of all column headers from the specified level with the specified amount.
ResizeRowHeaderWidths | Resizes the widths of all row headers from the specified level with the specified amount.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.FindColumn Method

Grid.FindColumn Method
[image]

Returns the first column header matching the specified caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header FindColumn (
string title
)

Visual Basic [image] Copy Code

Public Function FindColumn( _
title As String _
) As Header

Parameters

title

A string containing the header title to look for.

Return Value

Returns the first column Header that has the specified caption.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.FindRow Method

Grid.FindRow Method
[image]

Finds the first row whose header caption matches the specified string.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header FindRow (
string title
)

Visual Basic [image] Copy Code

Public Function FindRow( _
title As String _
) As Header

Parameters

title

A string containing the header title to look for.

Return Value

Returns the first row Header that has the specified caption.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellBounds Method

Grid.GetCellBounds Method
[image]

Returns the bounding rectangle of a cell.

Overload List

Name | Description
Grid.GetCellBounds (ICell) | Returns the bounding rectangle of the specified cell.
Grid.GetCellBounds (Int32, Int32) | Returns the bounding rectangle of the cell with the specified row and column.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellBounds Method (ICell)

Grid.GetCellBounds Method (ICell)
See Also
[image]

Returns the bounding rectangle of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetCellBounds (
ICell cell
)

Visual Basic [image] Copy Code

Public Function GetCellBounds( _
cell As ICell _
) As Rect

Parameters

cell

An ICell object representing a cell or a group of cells in the grid.

Return Value

A Rectangle instance representing the rectangle that bounds the specified cell or group of cells.

See Also

GetCellBounds Method Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellBounds Method (Int32, Int32)

Grid.GetCellBounds Method (Int32, Int32)
See Also
[image]

Returns the bounding rectangle of the cell with the specified row and column.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetCellBounds (
int c,
int r
)

Visual Basic [image] Copy Code

Public Function GetCellBounds( _
c As Integer, _
r As Integer _
) As Rect

Parameters

c

The 0-based index of the cell column.

r

The 0-based index of the cell row.

Return Value

A Rectangle instance representing the rectangle that bounds the specified cell.

See Also

GetCellBounds Method Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellColumn Method

Grid.GetCellColumn Method
[image]

Returns the column index of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetCellColumn (
ICell cell
)

Visual Basic [image] Copy Code

Public Function GetCellColumn( _
cell As ICell _
) As Integer

Parameters

cell

An ICell object representing a single cell in the grid.

Return Value

The index of the column that contains cell; -1 if cell is not found or refers to a group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellFromPoint Method

Grid.GetCellFromPoint Method
[image]

Gets the cell located at the specified point.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ICell GetCellFromPoint (
Point point,
ref Rect cellBounds
)

Visual Basic [image] Copy Code

Public Function GetCellFromPoint( _
point As Point, _
ByRef cellBounds As Rect _
) As ICell

Parameters

point

A Point instance specifying a point within the grid.

cellBounds

A Rectangle instance that receives the coordinates of the found cell.

Return Value

An ICell reference to the found cell, or null if there is no cell located at the specified point.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetCellRow Method

Grid.GetCellRow Method
[image]

Returns the row index of the specified cell.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetCellRow (
ICell cell
)

Visual Basic [image] Copy Code

Public Function GetCellRow( _
cell As ICell _
) As Integer

Parameters

cell

An ICell object representing a single cell in the grid.

Return Value

The index of the row that contains cell; -1 if cell is not found or refers to a group of cells.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetColumn Method

Grid.GetColumn Method
[image]

Returns the column header with the specified index from the bottommost column header level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header GetColumn (
int index
)

Visual Basic [image] Copy Code

Public Function GetColumn( _
index As Integer _
) As Header

Parameters

index

An integer value specifying the column index.

Return Value

A Header object representing the column at the specified index.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetColumnCount Method

Grid.GetColumnCount Method
[image]

Returns the number of columns in the bottommost column header level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetColumnCount ()

Visual Basic [image] Copy Code

Public Function GetColumnCount () As Integer

Return Value

An integer value.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetColumnHeaderBounds Method

Grid.GetColumnHeaderBounds Method
[image]

Returns the bounding rectangle of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetColumnHeaderBounds ()

Visual Basic [image] Copy Code

Public Function GetColumnHeaderBounds () As Rect

Return Value

A Rectangle that bounds all column headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetColumnIndex Method

Grid.GetColumnIndex Method
[image]

Returns the 0-based index of the specified column.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetColumnIndex (
Header column
)

Visual Basic [image] Copy Code

Public Function GetColumnIndex( _
column As Header _
) As Integer

Parameters

column

A Header instance that represents a grid column.

Return Value

The index of column, or -1 if the specified header represents a row or a group of child columns.

Remarks

Only works for bottommost headers. If the specified column is a group header, returns -1.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderBounds Method

Grid.GetHeaderBounds Method
[image]

Returns the bounding rectangle of the specified header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetHeaderBounds (
Header header,
bool includeSubHeaders
)

Visual Basic [image] Copy Code

Public Function GetHeaderBounds( _
header As Header, _
includeSubHeaders As Boolean _
) As Rect

Parameters

header

The Header object whose coordinates to return.

includeSubHeaders

true to include the coordinates of the child headers in the returned rectangle; otherwise, false.

Return Value

A Rectangle that bounds the specified header, and optionally its child headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderFromPoint Method

Grid.GetHeaderFromPoint Method
[image]

Gets the Header that is located at the specified point.

Overload List

Name | Description
Grid.GetHeaderFromPoint (Point, Rect@) | Gets the Header that is located at the specified point.
Grid.GetHeaderFromPoint (Point, Rect@, Point) | Gets the Header that is located at the specified point.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderFromPoint Method (Point, Rect@)

Grid.GetHeaderFromPoint Method (Point, Rect@)
See Also
[image]

Gets the Header that is located at the specified point.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header GetHeaderFromPoint (
Point point,
ref Rect headerBounds
)

Visual Basic [image] Copy Code

Public Function GetHeaderFromPoint( _
point As Point, _
ByRef headerBounds As Rect _
) As Header

Parameters

point

A Point instance specifying a point within the grid.

headerBounds

A Rectangle instance that receives the coordinates of the found header.

Return Value

The found Header object, or null if there is no header located at the specified point.

See Also

GetHeaderFromPoint Method Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderFromPoint Method (Point, Rect@, Point)

Grid.GetHeaderFromPoint Method (Point, Rect@, Point)
See Also
[image]

Gets the Header that is located at the specified point.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header GetHeaderFromPoint (
Point point,
ref Rect headerBounds,
Point scrollPosition
)

Visual Basic [image] Copy Code

Public Function GetHeaderFromPoint( _
point As Point, _
ByRef headerBounds As Rect, _
scrollPosition As Point _
) As Header

Parameters

point

A Point instance specifying a point within the grid.

headerBounds

A Rectangle instance that receives the coordinates of the found header.

scrollPosition

When the headers are hooked this parameter should provide information about the current scroll position in the view.

Return Value

The found Header object, or null if there is no header located at the specified point.

See Also

GetHeaderFromPoint Method Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderLevel Method

Grid.GetHeaderLevel Method
[image]

Gets the level of the specified header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetHeaderLevel (
Header header
)

Visual Basic [image] Copy Code

Public Function GetHeaderLevel( _
header As Header _
) As Integer

Parameters

header

Return Value

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetHeaderParent Method

Grid.GetHeaderParent Method
[image]

Returns the header containing the specified header, or null, if the header is a top-level header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header GetHeaderParent (
Header header
)

Visual Basic [image] Copy Code

Public Function GetHeaderParent( _
header As Header _
) As Header

Parameters

header

The header whose parent is being searched for.

Return Value

The parent header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetRow Method

Grid.GetRow Method
[image]

Returns the row header with the specified index from the bottommost row header level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header GetRow (
int index
)

Visual Basic [image] Copy Code

Public Function GetRow( _
index As Integer _
) As Header

Parameters

index

An integer value specifying the row index.

Return Value

A Header object representing the row at the specified index.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetRowCount Method

Grid.GetRowCount Method
[image]

Returns the number of rows in the bottommost row header level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetRowCount ()

Visual Basic [image] Copy Code

Public Function GetRowCount () As Integer

Return Value

An integer value.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetRowHeaderBounds Method

Grid.GetRowHeaderBounds Method
[image]

Returns the bounding rectangle of all row headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect GetRowHeaderBounds ()

Visual Basic [image] Copy Code

Public Function GetRowHeaderBounds () As Rect

Return Value

A Rectangle that bounds all row headers.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.GetRowIndex Method

Grid.GetRowIndex Method
[image]

Returns the 0-based index of the specified row.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetRowIndex (
Header row
)

Visual Basic [image] Copy Code

Public Function GetRowIndex( _
row As Header _
) As Integer

Parameters

row

A Header instance that represents a grid row.

Return Value

The index of row, or -1 if the specified header represents a column or a group of child rows.

Remarks

Only works for bottommost headers. If the specified row is a group header, returns -1;

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.InsertAfter Method

Grid.InsertAfter Method
[image]

Inserts a new header after the specified header and returns a reference to it.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header InsertAfter (
Header header
)

Visual Basic [image] Copy Code

Public Function InsertAfter( _
header As Header _
) As Header

Parameters

header

The header after which to insert the new header.

Return Value

A reference to the newly created header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.InsertBefore Method

Grid.InsertBefore Method
[image]

Inserts a new header before the specified header and returns a reference to it.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header InsertBefore (
Header header
)

Visual Basic [image] Copy Code

Public Function InsertBefore( _
header As Header _
) As Header

Parameters

header

The header before which to insert the new header.

Return Value

A reference to the newly created header.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RaiseHeaderAdded Method

Grid.RaiseHeaderAdded Method
[image]

Raises the HeaderAdded event from outside the lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseHeaderAdded (
Header header
)

Visual Basic [image] Copy Code

Public Sub RaiseHeaderAdded( _
header As Header _
)

Parameters

header

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RaiseHeaderResized Method

Grid.RaiseHeaderResized Method
[image]

Raises the HeaderResized event from outside the lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseHeaderResized (
Header header,
bool horizontal,
bool vertical
)

Visual Basic [image] Copy Code

Public Sub RaiseHeaderResized( _
header As Header, _
horizontal As Boolean, _
vertical As Boolean _
)

Parameters

header

horizontal

vertical

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RaiseHeaderStartResizing Method

Grid.RaiseHeaderStartResizing Method
[image]

Raises the HeaderStartResizing event from outside the lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RaiseHeaderStartResizing (
Header header,
bool horizontal,
bool vertical
)

Visual Basic [image] Copy Code

Public Sub RaiseHeaderStartResizing( _
header As Header, _
horizontal As Boolean, _
vertical As Boolean _
)

Parameters

header

horizontal

vertical

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ResizeColumnHeaderHeights Method

Grid.ResizeColumnHeaderHeights Method
[image]

Resizes the heights of all column headers from the specified level with the specified amount.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeColumnHeaderHeights (
int level,
double increase
)

Visual Basic [image] Copy Code

Public Sub ResizeColumnHeaderHeights( _
level As Integer, _
increase As Double _
)

Parameters

level

increase

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ResizeRowHeaderWidths Method

Grid.ResizeRowHeaderWidths Method
[image]

Resizes the widths of all row headers from the specified level with the specified amount.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void ResizeRowHeaderWidths (
int level,
double increase
)

Visual Basic [image] Copy Code

Public Sub ResizeRowHeaderWidths( _
level As Integer, _
increase As Double _
)

Parameters

level

increase

Remarks

This method is for internal use only.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Properties

Grid Properties
[image]

Public Properties

Name | Description
AlignCells | Gets or sets a value indicating whether cells are aligned one next to another so that their borders don't overlap.
AllowResizeHeaders | Gets or sets a value indicating whether users can resize the headers of the grid interactively.
ColumnCount | Gets or sets the number of columns in the grid.
ColumnHeaders | Gets the collection with the topmost column headers.
ColumnHeadersHeights | Gets or sets an array with float values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.
HeadersOnTop | Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.
HookHeaders | Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).
Item | Overloaded. Gets a cell or cluster of cells from the grid.
LeftMargin | Gets or sets the offset of the lane grid from the left side of the document bounds.
MinHeaderSize | Gets or sets the minimum size of a header.
RowCount | Gets or sets the number of rows in the grid.
RowHeaders | Gets the collection with the leftmost row headers.
RowHeadersWidths | Gets or sets an array with float values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.
TopLeftAreaStyle | Gets or sets the style of the area above all row headers and to the left of all column headers.
TopLeftAreaText | Gets or sets the text displayed in the top left area.
TopLeftAreaTextColor | Gets or sets the color of the text displayed in the top left area.
TopLeftAreaTextFont | Gets or sets the font used to display text in the top left area.
TopLeftAreaTextFormat | Gets or sets the format of the text displayed in the top left area.
TopMargin | Gets or sets the offset of the lane grid from the top side of the document bounds.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.AlignCells Property

Grid.AlignCells Property
[image]

Gets or sets a value indicating whether cells are aligned one next to another so that their borders don't overlap.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AlignCells { get; set; }

Visual Basic [image] Copy Code

Public Property AlignCells As Boolean

Property Value

true to align cells; otherwise, false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.AllowResizeHeaders Property

Grid.AllowResizeHeaders Property
[image]

Gets or sets a value indicating whether users can resize the headers of the grid interactively.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AllowResizeHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property AllowResizeHeaders As Boolean

Property Value

true to let users resize the grid elements; otherwise, false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ColumnCount Property

Grid.ColumnCount Property
[image]

Gets or sets the number of columns in the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int ColumnCount { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnCount As Integer

Property Value

An integer value indicating the number of columns in the grid.

Remarks

If a smaller value is assigned to this property, the control will reduce the number of child columns. If all child columns in a parent column are removed, the parent will be removed too. To have greater control over where in the hierarchy columns will be added or removed, use the ColumnHeaders and the SubHeaders properties.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ColumnHeaders Property

Grid.ColumnHeaders Property
[image]

Gets the collection with the topmost column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HeaderCollection ColumnHeaders { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property ColumnHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class containing the topmost column headers.

Remarks

Adding headers to or removing them from this collection also adds or removes top-level columns. Columns can be further divided into child columns by adding to the SubHeaders collection of the Header that represents a parent column.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.ColumnHeadersHeights Property

Grid.ColumnHeadersHeights Property
[image]

Gets or sets an array with float values specifying the heights of individual column levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the height is calculated as the maximum height of the columns in that level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double[] ColumnHeadersHeights { get; set; }

Visual Basic [image] Copy Code

Public Property ColumnHeadersHeights As Double()

Property Value

An array of float values where each value represents the height of an individual level of column headers.

Remarks

The first level of column headers is the one defined by the ColumnHeaders collection. Each next level is defined by the SubHeaders collection of the headers in the upper level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeadersOnTop Property

Grid.HeadersOnTop Property
[image]

Gets or sets a value indicating whether lane headers appear at the top of the z-order above all other items.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HeadersOnTop { get; set; }

Visual Basic [image] Copy Code

Public Property HeadersOnTop As Boolean

Property Value

true if lane headers should be displayed on top, otherwise false. The default is true.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HookHeaders Property

Grid.HookHeaders Property
[image]

Gets or sets a value indicating whether headers will be anchored to the corresponding side (that is, the column header anchored to the top side and the row header anchored to the left side).

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HookHeaders { get; set; }

Visual Basic [image] Copy Code

Public Property HookHeaders As Boolean

Property Value

true if lane headers should be anchored to their corresponding side; otherwise, false. The default is true.

Remarks

If this property is equal to false, the lane grid headers will follow the diagram scroll position, thus they might be hidden from view. Otherwise the headers will always be rendered in the currently visible area of the diagram.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.Item Property

Grid.Item Property
[image]

Gets a cell or cluster of cells from the grid.

Overload List

Name | Description
Grid.Item (Header, Header) | Gets the cell or the cluster of cells corresponding to the specified row and column.
Grid.Item (Int32, Int32) | Gets the cell at the specified position.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.Item Property (Header, Header)

Grid.Item Property (Header, Header)
See Also
[image]

Gets the cell or the cluster of cells corresponding to the specified row and column.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ICell Item [
Header column,
Header row
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
column As Header, _
row As Header _
) As ICell

Parameters

column

A Header object that represents the column of the cell to get.

row

A Header object that represents the row of the cell to get.

Property Value

An ICell instance representing all grid cell corresponding to the specified headers.

Remarks

If both Header parameters are null, a group containing all cells in the grid is returned. If only one of the Header parameters is null, the returned cell group contains all cells from the row or a column specified through the other parameter. This feature lets you set the Style of all cells in a group through a single assignment.

See Also

Item Property Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.Item Property (Int32, Int32)

Grid.Item Property (Int32, Int32)
See Also
[image]

Gets the cell at the specified position.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ICell Item [
int column,
int row
] { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Item( _
column As Integer, _
row As Integer _
) As ICell

Parameters

column

An integer value that represents the column of the cell to get.

row

An integer value that represents the index of the row to get.

Property Value

An ICell instance representing the cell at the specified position.

See Also

Item Property Overload List
Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.LeftMargin Property

Grid.LeftMargin Property
[image]

Gets or sets the offset of the lane grid from the left side of the document bounds.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LeftMargin { get; set; }

Visual Basic [image] Copy Code

Public Property LeftMargin As Double

Property Value

A double value specifying the left margin size in MeasureUnit.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.MinHeaderSize Property

Grid.MinHeaderSize Property
[image]

Gets or sets the minimum size of a header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MinHeaderSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinHeaderSize As Double

Property Value

A double value specifying the minimal size of a header. The default is 10.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RowCount Property

Grid.RowCount Property
[image]

Gets or sets the number of rows in the grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RowCount { get; set; }

Visual Basic [image] Copy Code

Public Property RowCount As Integer

Property Value

An integer value indicating the number of rows in the grid.

Remarks

If a smaller value is assigned to this property, the control will reduce the number of child rows. If all child rows in a parent row are removed, the parent will be removed too. To have greater control over where in the hierarchy rows will be added or removed, use the RowHeaders and the SubHeaders properties.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RowHeaders Property

Grid.RowHeaders Property
[image]

Gets the collection with the leftmost row headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HeaderCollection RowHeaders { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property RowHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class containing the leftmost row headers.

Remarks

Adding headers to or removing them from this collection also adds or removes top-level rows. Rows can be further divided into child rows by adding to the SubHeaders collection of the Header that represents a parent row.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.RowHeadersWidths Property

Grid.RowHeadersWidths Property
[image]

Gets or sets an array with float values specifying the widths of individual row levels. If a value is non-positive or does not exist because the array has less arguments than the number of rows, then the width is calculated as the maximum width of the rows in that level.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double[] RowHeadersWidths { get; set; }

Visual Basic [image] Copy Code

Public Property RowHeadersWidths As Double()

Property Value

An array of float values where each value represents the width of an individual level of row headers.

Remarks

The first level of row headers is the one defined by the RowHeaders collection. Each next level is defined by the SubHeaders collection of the headers in the upper level.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaStyle Property

Grid.TopLeftAreaStyle Property
[image]

Gets or sets the style of the area above all row headers and to the left of all column headers.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style TopLeftAreaStyle { get; set; }

Visual Basic [image] Copy Code

Public Property TopLeftAreaStyle As Style

Property Value

An instance of the Style class specifying how to paint the top left corner. The default value is null.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaText Property

Grid.TopLeftAreaText Property
[image]

Gets or sets the text displayed in the top left area.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string TopLeftAreaText { get; set; }

Visual Basic [image] Copy Code

Public Property TopLeftAreaText As String

Property Value

A string value.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaTextColor Property

Grid.TopLeftAreaTextColor Property
[image]

Gets or sets the color of the text displayed in the top left area.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color TopLeftAreaTextColor { get; set; }

Visual Basic [image] Copy Code

Public Property TopLeftAreaTextColor As Color

Property Value

A Color object.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaTextFont Property

Grid.TopLeftAreaTextFont Property
[image]

Gets or sets the font used to display text in the top left area.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Font> TopLeftAreaTextFont { get; set; }

Visual Basic [image] Copy Code

Public Property TopLeftAreaTextFont As Nullable(Of Font)

Property Value

A Font object.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopLeftAreaTextFormat Property

Grid.TopLeftAreaTextFormat Property
[image]

Gets or sets the format of the text displayed in the top left area.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TopLeftAreaTextFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TopLeftAreaTextFormat As StringFormat

Property Value

An instance of the StringFormat class.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.TopMargin Property

Grid.TopMargin Property
[image]

Gets or sets the offset of the lane grid from the top side of the document bounds.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TopMargin { get; set; }

Visual Basic [image] Copy Code

Public Property TopMargin As Double

Property Value

A double value specifying the top margin size in MeasureUnit.

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid Events

Grid Events
[image]

Public Events

Name | Description
CellBoundsChanged | Raised when the bounding rectangle of a cell has been changed.
HeaderAdded | Raised when a header has been inserted to the grid through a call to the InsertBefore or InsertAfter methods.
HeaderResized | Raised when the user finished resizing a header.
HeaderStartResizing | Raises when the user starts resizing a header.

See Also

Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.CellBoundsChanged Event

Grid.CellBoundsChanged Event
[image]

Raised when the bounding rectangle of a cell has been changed.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<CellBoundsEventArgs> CellBoundsChanged

Visual Basic [image] Copy Code

Public Event CellBoundsChanged As EventHandler(Of CellBoundsEventArgs)

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeaderAdded Event

Grid.HeaderAdded Event
[image]

Raised when a header has been inserted to the grid through a call to the InsertBefore or InsertAfter methods.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<HeaderEventArgs> HeaderAdded

Visual Basic [image] Copy Code

Public Event HeaderAdded As EventHandler(Of HeaderEventArgs)

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeaderResized Event

Grid.HeaderResized Event
[image]

Raised when the user finished resizing a header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<HeaderResizeEventArgs> HeaderResized

Visual Basic [image] Copy Code

Public Event HeaderResized As EventHandler(Of HeaderResizeEventArgs)

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Grid.HeaderStartResizing Event

Grid.HeaderStartResizing Event
[image]

Raises when the user starts resizing a header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public event EventHandler<HeaderResizeEventArgs> HeaderStartResizing

Visual Basic [image] Copy Code

Public Event HeaderStartResizing As EventHandler(Of HeaderResizeEventArgs)

See Also

Grid Members
Grid Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Class

Header Class
Remarks See Also
[image]

Represents a header in a grid view.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Header

Visual Basic [image] Copy Code

Public Class Header

Remarks

The Header class provides the properties to define and adjust headers in the lanes grid.

The size of a header can be set through the Height and Width properties. Note that the size of the rows and columns in the grid is controlled through the size of their headers. The SubHeaders property lets you add child rows or columns to the grid. The ResizeType property is used to specify how to resize child columns and rows when the topmost headers are resized. The possible values for the ResizeType property are defined in the ResizeType enumeration.

In order to specify the color, font or alignment of the header Title, set the TitleColor, TitleFont or TitleFormat properties.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.Header

See Also

Header Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Members

Header Members
Constructors Properties Methods
[image]

Represents a header in a grid view.

The following tables list the members exposed by the Header type.

Public Constructors

Name | Description
Header | Overloaded. Initializes a new instance of the Header class.

Public Properties

Name | Description
Height | Gets or sets the height of this header.
IsColumnHeader | Gets a value indicating whether this header is a column header.
IsRowHeader | Gets a value indicating whether this header is a row header.
ResizeType | Gets or sets how a row or a column is resized relatively to its parent.
RotateTitle | Gets or sets a value indicating whether to rotate the header caption at 90 degree.
Style | Gets or sets the style of this header.
SubHeaders | Gets a collection of the subheaders of this header.
Title | Gets or sets the header caption.
TitleColor | Gets or sets the color of the header caption.
TitleFont | Gets or sets the font of the header caption.
TitleFormat | Gets or sets the alignment of the header caption.
Width | Gets or sets the width of this header.

Protected Methods

Name | Description
LoadFromJson | Loads the header from the specified JsonObject using the specified context.
LoadFromXml | Loads the header from the specified XElement using the specified context.
SaveToJson | Saves the header to the specified JsonObject using the specified context.
SaveToXml | Saves the header to the specified XElement using the specified context.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Constructor

Header Constructor
[image]

Initializes a new instance of the Header class.

Overload List

Name | Description
Header () | Initializes a new instance of the Header class.
Header (String) | Initializes a new instance of the Header class with the specified title.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Constructor ()

Header Constructor ()
See Also
[image]

Initializes a new instance of the Header class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Header Constructor Overload List
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Constructor (String)

Header Constructor (String)
See Also
[image]

Initializes a new instance of the Header class with the specified title.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header (
string title
)

Visual Basic [image] Copy Code

Public New ( _
title As String _
)

Parameters

title

A string value that represents the title for this Header object.

See Also

Header Constructor Overload List
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Methods

Header Methods
[image]

Protected Methods

Name | Description
LoadFromJson | Loads the header from the specified JsonObject using the specified context.
LoadFromXml | Loads the header from the specified XElement using the specified context.
SaveToJson | Saves the header to the specified JsonObject using the specified context.
SaveToXml | Saves the header to the specified XElement using the specified context.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.LoadFromJson Method

Header.LoadFromJson Method
[image]

Loads the header from the specified JsonObject using the specified context.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromJson( _
obj As JsonObject, _
context As JsonPersistContext _
)

Parameters

obj

context

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.LoadFromXml Method

Header.LoadFromXml Method
[image]

Loads the header from the specified XElement using the specified context.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void LoadFromXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub LoadFromXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement containing the header's data.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.SaveToJson Method

Header.SaveToJson Method
[image]

Saves the header to the specified JsonObject using the specified context.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual Task SaveToJson (
JsonObject obj,
JsonPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Function SaveToJson( _
obj As JsonObject, _
context As JsonPersistContext _
) As Task

Parameters

obj

context

Return Value

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.SaveToXml Method

Header.SaveToXml Method
[image]

Saves the header to the specified XElement using the specified context.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void SaveToXml (
XElement element,
XmlPersistContext context
)

Visual Basic [image] Copy Code

Protected Overridable Sub SaveToXml( _
element As XElement, _
context As XmlPersistContext _
)

Parameters

element

An XElement the header's data should be stored into.

context

An XmlPersistContext object providing contextual information about the serialization process and some helper serialization methods.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header Properties

Header Properties
[image]

Public Properties

Name | Description
Height | Gets or sets the height of this header.
IsColumnHeader | Gets a value indicating whether this header is a column header.
IsRowHeader | Gets a value indicating whether this header is a row header.
ResizeType | Gets or sets how a row or a column is resized relatively to its parent.
RotateTitle | Gets or sets a value indicating whether to rotate the header caption at 90 degree.
Style | Gets or sets the style of this header.
SubHeaders | Gets a collection of the subheaders of this header.
Title | Gets or sets the header caption.
TitleColor | Gets or sets the color of the header caption.
TitleFont | Gets or sets the font of the header caption.
TitleFormat | Gets or sets the alignment of the header caption.
Width | Gets or sets the width of this header.

See Also

Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Height Property

Header.Height Property
[image]

Gets or sets the height of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Height { get; set; }

Visual Basic [image] Copy Code

Public Property Height As Double

Property Value

A double value specifying the header height. The default is 0.

Remarks

If this is a row header, the property specifies the height of the whole row.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.IsColumnHeader Property

Header.IsColumnHeader Property
[image]

Gets a value indicating whether this header is a column header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool IsColumnHeader { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsColumnHeader As Boolean

Property Value

true if the header is a column header; otherwise, false.

Remarks

Both IsColumnHeader and IsRowHeader return false if the header is not attached to a lane grid.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace
IsRowHeader Property


MindFusion.Diagramming.Lanes.Header.IsRowHeader Property

Header.IsRowHeader Property
[image]

Gets a value indicating whether this header is a row header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool IsRowHeader { get; }

Visual Basic [image] Copy Code

Public Overridable ReadOnly Property IsRowHeader As Boolean

Property Value

true if the header is a row header; otherwise, false.

Remarks

Both IsColumnHeader and IsRowHeader return false if the header is not attached to a lane grid.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace
IsColumnHeader Property


MindFusion.Diagramming.Lanes.Header.ResizeType Property

Header.ResizeType Property
[image]

Gets or sets how a row or a column is resized relatively to its parent.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ResizeType ResizeType { get; set; }

Visual Basic [image] Copy Code

Public Property ResizeType As ResizeType

Property Value

A member of the ResizeType enumeration. The default is Proportional.

Remarks

When a topmost header is resized, the child elements of the row or column related to the header either keep their size or are resized as set through this property.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace
SubHeaders Property


MindFusion.Diagramming.Lanes.Header.RotateTitle Property

Header.RotateTitle Property
[image]

Gets or sets a value indicating whether to rotate the header caption at 90 degree.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RotateTitle { get; set; }

Visual Basic [image] Copy Code

Public Property RotateTitle As Boolean

Property Value

true if the title should be rotated; otherwise, false. The default is false.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Style Property

Header.Style Property
[image]

Gets or sets the style of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style Style { get; set; }

Visual Basic [image] Copy Code

Public Property Style As Style

Property Value

An instance of the Style class that specifies the appearance of the header.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.SubHeaders Property

Header.SubHeaders Property
[image]

Gets a collection of the subheaders of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HeaderCollection SubHeaders { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property SubHeaders As HeaderCollection

Property Value

An instance of the HeaderCollection class.

Remarks

Adding SubHeaders to a row header creates child rows controlled through the same parent header. In the same way you can add child columns to a column by adding SubHeaders to the column header.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Title Property

Header.Title Property
[image]

Gets or sets the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public string Title { get; set; }

Visual Basic [image] Copy Code

Public Property Title As String

Property Value

A string containing the caption text. The default is an empty string.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.TitleColor Property

Header.TitleColor Property
[image]

Gets or sets the color of the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Color TitleColor { get; set; }

Visual Basic [image] Copy Code

Public Property TitleColor As Color

Property Value

A Color object. The default is Black.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.TitleFont Property

Header.TitleFont Property
[image]

Gets or sets the font of the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Font> TitleFont { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFont As Nullable(Of Font)

Property Value

A Font object. The default is null.

Remarks

If this property is set to null, the header text will be rendered using the diagram's Font.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.TitleFormat Property

Header.TitleFormat Property
[image]

Gets or sets the alignment of the header caption.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public StringFormat TitleFormat { get; set; }

Visual Basic [image] Copy Code

Public Property TitleFormat As StringFormat

Property Value

An instance of the StringFormat class. The default is null.

Remarks

Set this property to null to use the default (centered) alignment.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Header.Width Property

Header.Width Property
[image]

Gets or sets the width of this header.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value specifying the header width. The default is 0.

Remarks

If this is a column header, the property specifies the width of the whole column.

See Also

Header Members
Header Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Class

HeaderCollection Class
Remarks See Also
[image]

Represents a strongly-typed collection of Header objects.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HeaderCollection : IList<Header>, ICollection<Header>, IEnumerable<Header>, IEnumerable

Visual Basic [image] Copy Code

Public Class HeaderCollection
Implements IList(Of Header), ICollection(Of Header), IEnumerable(Of Header), IEnumerable

Remarks

The ColumnHeaders and RowHeaders properties of the Grid class are of this collection type. Adding or removing headers to them automatically adds or removes parent columns and rows to the grid. Adding to or removing form the SubHeaders property of the Header class automatically adds or removes child columns or rows.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.HeaderCollection

See Also

HeaderCollection Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Members

HeaderCollection Members
Properties Methods
[image]

Represents a strongly-typed collection of Header objects.

The following tables list the members exposed by the HeaderCollection type.

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the Header at the specified position.

Public Methods

Name | Description
Add | Adds the specified header to the collection.
Clear | Removes all headers from the collection.
Contains | Checks whether a Header is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Gets the index of the specified header within this collection.
Insert | Inserts the specified Header at the specified position within the HeaderCollection.
Remove | Removes the first occurrence of the specified Header from the collection.
RemoveAt | Removes the Header at the specified position within the collection.

See Also

HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Methods

HeaderCollection Methods
[image]

Public Methods

Name | Description
Add | Adds the specified header to the collection.
Clear | Removes all headers from the collection.
Contains | Checks whether a Header is in the collection.
CopyTo | Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.
GetEnumerator | Returns an enumerator that iterates through the collection.
IndexOf | Gets the index of the specified header within this collection.
Insert | Inserts the specified Header at the specified position within the HeaderCollection.
Remove | Removes the first occurrence of the specified Header from the collection.
RemoveAt | Removes the Header at the specified position within the collection.

See Also

HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Add Method

HeaderCollection.Add Method
[image]

Adds the specified header to the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Add (
Header header
)

Visual Basic [image] Copy Code

Public Sub Add( _
header As Header _
)

Parameters

header

The Header object to add.

Remarks

The method adds a Header object to the end of the collection. If you need to place the Header at a certain position, you should use Insert method instead.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Clear Method

HeaderCollection.Clear Method
[image]

Removes all headers from the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Clear ()

Visual Basic [image] Copy Code

Public Sub Clear ()

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Contains Method

HeaderCollection.Contains Method
[image]

Checks whether a Header is in the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Contains (
Header header
)

Visual Basic [image] Copy Code

Public Function Contains( _
header As Header _
) As Boolean

Parameters

header

The Header to locate in the collection.

Return Value

true if the header was found in the collection; otherwise, false.

Remarks

Call the method to determine whether a Header is contained within the collection. If not, you can add it with the Add method. Otherwise, if it is there, you can remove it with Remove.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.CopyTo Method

HeaderCollection.CopyTo Method
[image]

Copies the entire collection to a compatible one-dimensional array, starting at the specified index of the target array.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void CopyTo (
Header[] array,
int arrayIndex
)

Visual Basic [image] Copy Code

Public Sub CopyTo( _
array() As Header, _
arrayIndex As Integer _
)

Parameters

array

The one-dimensional Array that is the destination of the copied elements.

arrayIndex

The zero-based index in array at which copying begins.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.GetEnumerator Method

HeaderCollection.GetEnumerator Method
[image]

Returns an enumerator that iterates through the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public IEnumerator<Header> GetEnumerator ()

Visual Basic [image] Copy Code

Public Function GetEnumerator () As IEnumerator(Of Header)

Return Value

An enumerator for the collection.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.IndexOf Method

HeaderCollection.IndexOf Method
[image]

Gets the index of the specified header within this collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IndexOf (
Header header
)

Visual Basic [image] Copy Code

Public Function IndexOf( _
header As Header _
) As Integer

Parameters

header

The Header to locate in the HeaderCollection. The value can be a null reference.

Return Value

The zero-based index of the first occurrence of value within the entire HeaderCollection, if found; otherwise, -1.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Insert Method

HeaderCollection.Insert Method
[image]

Inserts the specified Header at the specified position within the HeaderCollection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Insert (
int index,
Header header
)

Visual Basic [image] Copy Code

Public Sub Insert( _
index As Integer, _
header As Header _
)

Parameters

index

The zero-based index at which the Header should be inserted.

header

The Header object to insert.

Remarks

Use this method to insert Header objects at a specific position in the collection. If you do not need to specify header's position, use the Add method instead, which adds new headers to the end of the list.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Remove Method

HeaderCollection.Remove Method
[image]

Removes the first occurrence of the specified Header from the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Remove (
Header header
)

Visual Basic [image] Copy Code

Public Function Remove( _
header As Header _
) As Boolean

Parameters

header

The Header object to remove.

Return Value

true if the header is successfully; otherwise, false.

Remarks

Use this method to remove headers from the collection. Headers can be added to the collection with the Add or Insert methods.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.RemoveAt Method

HeaderCollection.RemoveAt Method
[image]

Removes the Header at the specified position within the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void RemoveAt (
int index
)

Visual Basic [image] Copy Code

Public Sub RemoveAt( _
index As Integer _
)

Parameters

index

The index at which the Header object should be removed.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection Properties

HeaderCollection Properties
[image]

Public Properties

Name | Description
Count | Gets the number of elements contained in the collection.
IsReadOnly | Gets a value indicating whether the collection is read-only.
Item | Gets or sets the Header at the specified position.

See Also

HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Count Property

HeaderCollection.Count Property
[image]

Gets the number of elements contained in the collection.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Count { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Count As Integer

Property Value

An integer value.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.IsReadOnly Property

HeaderCollection.IsReadOnly Property
[image]

Gets a value indicating whether the collection is read-only.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsReadOnly { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsReadOnly As Boolean

Property Value

A boolean value.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderCollection.Item Property

HeaderCollection.Item Property
[image]

Gets or sets the Header at the specified position.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header Item [
int index
] { get; set; }

Visual Basic [image] Copy Code

Public Property Item( _
index As Integer _
) As Header

Parameters

index

The 0-based index of the Header to get.

Property Value

An instance of the Header class that represents the header at the specified position.

See Also

HeaderCollection Members
HeaderCollection Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderEventArgs Class

HeaderEventArgs Class
[image]

Contains the arguments passed to handlers of header-related events.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HeaderEventArgs : EventArgs

Visual Basic [image] Copy Code

Public Class HeaderEventArgs
Inherits EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Lanes.HeaderEventArgs
MindFusion.Diagramming.Lanes.HeaderResizeEventArgs

See Also

HeaderEventArgs Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderEventArgs Members

HeaderEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of header-related events.

The following tables list the members exposed by the HeaderEventArgs type.

Public Properties

Name | Description
Header | Gets or sets the header related to the event.

See Also

HeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderEventArgs Properties

HeaderEventArgs Properties
[image]

Public Properties

Name | Description
Header | Gets or sets the header related to the event.

See Also

HeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderEventArgs.Header Property

HeaderEventArgs.Header Property
[image]

Gets or sets the header related to the event.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Header Header { get; set; }

Visual Basic [image] Copy Code

Public Property Header As Header

Property Value

An instance of the Header class.

See Also

HeaderEventArgs Members
HeaderEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderResizeEventArgs Class

HeaderResizeEventArgs Class
[image]

Contains the arguments passed to handlers of header resize events.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HeaderResizeEventArgs : HeaderEventArgs

Visual Basic [image] Copy Code

Public Class HeaderResizeEventArgs
Inherits HeaderEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
MindFusion.Diagramming.Lanes.HeaderEventArgs
MindFusion.Diagramming.Lanes.HeaderResizeEventArgs

See Also

HeaderResizeEventArgs Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderResizeEventArgs Members

HeaderResizeEventArgs Members
Properties
[image]

Contains the arguments passed to handlers of header resize events.

The following tables list the members exposed by the HeaderResizeEventArgs type.

Public Properties

Name | Description
Header | Gets or sets the header related to the event. (Inherited from HeaderEventArgs.)
IsHorizontal | Gets a value indicating whether the user resizes the header horizontally.
IsVertical | Gets a value indicating whether the user resizes the header vertically.

See Also

HeaderResizeEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderResizeEventArgs Properties

HeaderResizeEventArgs Properties
[image]

Public Properties

Name | Description
Header | Gets or sets the header related to the event. (Inherited from HeaderEventArgs.)
IsHorizontal | Gets a value indicating whether the user resizes the header horizontally.
IsVertical | Gets a value indicating whether the user resizes the header vertically.

See Also

HeaderResizeEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderResizeEventArgs.IsHorizontal Property

HeaderResizeEventArgs.IsHorizontal Property
[image]

Gets a value indicating whether the user resizes the header horizontally.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsHorizontal { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsHorizontal As Boolean

Property Value

See Also

HeaderResizeEventArgs Members
HeaderResizeEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.HeaderResizeEventArgs.IsVertical Property

HeaderResizeEventArgs.IsVertical Property
[image]

Gets a value indicating whether the user resizes the header vertically.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsVertical { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property IsVertical As Boolean

Property Value

See Also

HeaderResizeEventArgs Members
HeaderResizeEventArgs Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell Interface

ICell Interface
[image]

Defines a base for cells in a lane list.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ICell

Visual Basic [image] Copy Code

Public Interface ICell

See Also

ICell Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell Members

ICell Members
Properties
[image]

Defines a base for cells in a lane list.

The following tables list the members exposed by the ICell type.

Public Properties

Name | Description
Style | Gets or sets the Style of the cell or group of cells.
Text | Gets or sets the text of the cell or group of cells.
TextColor | Gets or sets the text color of the cell or group of cells.
TextFont | Gets or sets the font of the cell or group of cells.
TextFormat | Gets or sets the text format of the cell or group of cells.

See Also

ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell Properties

ICell Properties
[image]

Public Properties

Name | Description
Style | Gets or sets the Style of the cell or group of cells.
Text | Gets or sets the text of the cell or group of cells.
TextColor | Gets or sets the text color of the cell or group of cells.
TextFont | Gets or sets the font of the cell or group of cells.
TextFormat | Gets or sets the text format of the cell or group of cells.

See Also

ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.Style Property

ICell.Style Property
[image]

Gets or sets the Style of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Style Style { get; set; }

Visual Basic [image] Copy Code

Property Style As Style

Property Value

An instance of the Lanes.Style class that specifies the style of this cell.

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the style of all cells in the group with a single assignment.

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.Text Property

ICell.Text Property
[image]

Gets or sets the text of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

string Text { get; set; }

Visual Basic [image] Copy Code

Property Text As String

Property Value

A string value.

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the text of all cells in the group with a single assignment.

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.TextColor Property

ICell.TextColor Property
[image]

Gets or sets the text color of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Color TextColor { get; set; }

Visual Basic [image] Copy Code

Property TextColor As Color

Property Value

A Color object.

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the text color of all cells in the group with a single assignment.

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.TextFont Property

ICell.TextFont Property
[image]

Gets or sets the font of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

Nullable<Font> TextFont { get; set; }

Visual Basic [image] Copy Code

Property TextFont As Nullable(Of Font)

Property Value

A Font object.

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the font of all cells in the group with a single assignment.

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ICell.TextFormat Property

ICell.TextFormat Property
[image]

Gets or sets the text format of the cell or group of cells.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

StringFormat TextFormat { get; set; }

Visual Basic [image] Copy Code

Property TextFormat As StringFormat

Property Value

An instance of the StringFormat class.

Remarks

The Item property of the Grid class lets you access a group of cells through a single ICell reference, which lets you set the text format of all cells in the group with a single assignment.

See Also

ICell Members
ICell Interface
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.ResizeType Enumeration

ResizeType Enumeration
[image]

Specifies how to resize child columns and rows in the lanes grid when their parent column or row is resized.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum ResizeType

Visual Basic [image] Copy Code

Public Enum ResizeType

Members

Member name | Description
Fixed | The header's size (width or height) is fixed and does not change when its parent header is being resized unless all its siblings have fixed size too.
Proportional | The header resizes in proportion to its parent header.

Remarks

This enumeration specifies the possible values of the ResizeType property of the Header class.

See Also

MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Class

Style Class
[image]

Encapsulates the appearance properties of an element in a lane grid.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Style

Visual Basic [image] Copy Code

Public Class Style

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Lanes.Style

See Also

Style Members
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Members

Style Members
Constructors Properties
[image]

Encapsulates the appearance properties of an element in a lane grid.

The following tables list the members exposed by the Style type.

Public Constructors

Name | Description
Style | Initializes a new instance of the Style class.

Public Properties

Name | Description
BackgroundBrush | Gets or sets the background Brush of this style.
BottomBorderPen | Gets or sets the Pen for drawing the bottom border for this style.
LeftBorderPen | Gets or sets the Pen for drawing the left border for this style.
RightBorderPen | Gets or sets the Pen for drawing the right border for this style.
TopBorderPen | Gets or sets the Pen for drawing the top border for this style.

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Constructor

Style Constructor
[image]

Initializes a new instance of the Style class.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Style ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style Properties

Style Properties
[image]

Public Properties

Name | Description
BackgroundBrush | Gets or sets the background Brush of this style.
BottomBorderPen | Gets or sets the Pen for drawing the bottom border for this style.
LeftBorderPen | Gets or sets the Pen for drawing the left border for this style.
RightBorderPen | Gets or sets the Pen for drawing the right border for this style.
TopBorderPen | Gets or sets the Pen for drawing the top border for this style.

See Also

Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.BackgroundBrush Property

Style.BackgroundBrush Property
[image]

Gets or sets the background Brush of this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Brush BackgroundBrush { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property BackgroundBrush As Brush

Property Value

An instance of the Brush class.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.BottomBorderPen Property

Style.BottomBorderPen Property
[image]

Gets or sets the Pen for drawing the bottom border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Pen BottomBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property BottomBorderPen As Pen

Property Value

An instance of the Pen class.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.LeftBorderPen Property

Style.LeftBorderPen Property
[image]

Gets or sets the Pen for drawing the left border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Pen LeftBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LeftBorderPen As Pen

Property Value

An instance of the Pen class.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.RightBorderPen Property

Style.RightBorderPen Property
[image]

Gets or sets the Pen for drawing the right border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Pen RightBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property RightBorderPen As Pen

Property Value

An instance of the Pen class.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Lanes.Style.TopBorderPen Property

Style.TopBorderPen Property
[image]

Gets or sets the Pen for drawing the top border for this style.

Namespace: MindFusion.Diagramming.Lanes
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual Pen TopBorderPen { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property TopBorderPen As Pen

Property Value

An instance of the Pen class.

See Also

Style Members
Style Class
MindFusion.Diagramming.Lanes Namespace


MindFusion.Diagramming.Layout Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AnnealLayout | Implements a simulated annealing graph layout algorithm.
CascadeLayout | Performs cascading layout on simple, connected graphs.
CircularLayout | Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.
DecisionLayout | Implements a decision graph layout algorithm.
FlowchartLayout | Implements a flowchart, workflow and process diagrams layout algorithm.
FractalLayout | A tree layout algorithm that places child nodes symmetrically around their parent node.
GridLayout | Implements a grid graph layout algorithm.
HierarchicalLayout | Performs hierarchical layout on simple, connected, level-planar graphs.
LaneGrid | Represents an ISwimlaneGrid which operates on a Grid object.
LayeredLayout | Implements a layered graph layout algorithm.
LayeredLayoutStatistics | Encapsulates information about a layered layout which has already complete.
Layout | The base class for all layout classes.
OneWayLayout | Implements a one-way graph layout algorithm.
OrthogonalLayout | Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.
OrthogonalRouter | Implements an orthogonal link routing algorithm.
SpringLayout | Implements the Spring-Embedder graph layout algorithm.
SwimlaneLayout | Implements an algorithm which arranges nodes in lanes.
TopologicalLayout | Implements a topological ordering.
TreeLayout | Implements several algorithms for arranging tree structures.
TreeMapLayout | Implements a tree map layout algorithm.
TriangularLayout | Performs triangular layout on simple, connected graphs.

Interfaces

Interface | Description
ILayout | Common interface for all layout classes.
ISwimlaneGrid | Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

Delegates

Delegate | Description
LayoutLink | Represents methods that are called by the layout algorithms when the position of a link changes.
LayoutNode | Represents methods that are called by the layout algorithms when the position of a node changes.
LayoutProgress | Represents methods that are called to report on progress of layout algorithms.
LayoutSubgraph | Represents methods that are called by the layout algorithms in order to perform custom arrangement of a subgraph.

Enumerations

Enumeration | Description
Direction | Specifies a layout direction.
LayeredLayoutLinkType | Specifies the style of the links after they are laid out.
MultipleGraphsPlacement | Specifies graph orientation.
Orientation | Specifies axial orientation.
SpringLayoutLinkType | Specifies the style of the diagram links after they are laid out.
TreeLayoutBalance | Specifies how to order child nodes in order to produce tree layouts with custom balance.
TreeLayoutDirections | Specifies the direction of a tree layout.
TreeLayoutLinkType | Specifies the shape of the diagram links after they are laid out.
TreeLayoutType | Specifies the type of a tree layout.


MindFusion.Diagramming.Layout.AnnealLayout Class

AnnealLayout Class
Remarks See Also
[image]

Implements a simulated annealing graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnnealLayout : Layout

Visual Basic [image] Copy Code

Public Class AnnealLayout
Inherits Layout

Remarks

Simulated Annealing is a general-purpose optimization method used to solve large-scale combinatorial problems by simulating the process of heating and cooling of metal to achieve freedom from defects. Finding a nice arrangement of a graph is a combinatorial problem that can be reduced to assigning costs to graph configurations and finding the minimum cost configuration. In that case, a cost is assigned to a graph configuration by evaluating different aesthetic criteria such as distance between nodes, length of links and the number of link crossings.

The AnnealLayout class implements a Simulated Annealing graph layout algorithm that can be used to arrange MindFusion.Diagramming for .NET MAUI diagrams. To arrange a diagram, create an AnnealLayout instance, set its properties and call the Arrange method.

The algorithm starts the simulation with the temperature set in InitialTemperature, and runs several cooling Stages. At each stage the algorithm evaluates several graph configurations for each node, as set in IterationsPerStage. At the end of each stage, the algorithm selects the configuration that has a minimum cost and decreases the temperature by multiplying it by TemperatureScale. The relative weight of an aesthetic criterion relative to the other criteria is set by the DistributionFactor, LinkLengthFactor, BoundaryFactor and CrossingLinksCost properties.

Anchoring specifies whether the layout algorithm must attach links to the anchor points of graphs nodes. The layout algorithm produces best results if it can place link ends at arbitrary positions over the nodes outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.AnnealLayout

See Also

AnnealLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Members

AnnealLayout Members
Constructors Properties Methods
[image]

Implements a simulated annealing graph layout algorithm.

The following tables list the members exposed by the AnnealLayout type.

Public Constructors

Name | Description
AnnealLayout | Initializes a new instance of the AnnealLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
ApproximateLinkLength | Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.
BoundaryFactor | Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
GatherStatistics | Gets or sets a value specifying whether the layout should gather statistics while running.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
InitialTemperature | Gets or sets the initial temperature of the simulated annealing process.
IterationsPerStage | Gets or sets how many node shift iterations to perform at each stage of the algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkLengthFactor | Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeLinkCrossingCost | Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Gets or sets how many cool-down stages the algorithm should simulate.
Statistics | Gets statistics about the layout execution and end results.
TemperatureScale | Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Gets or sets what width/height ratio the layout area should have.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution started with a call to BeginArrange.
Iterate | Runs one or more layout iterations.

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Constructor

AnnealLayout Constructor
[image]

Initializes a new instance of the AnnealLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnnealLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Methods

AnnealLayout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution started with a call to BeginArrange.
Iterate | Runs one or more layout iterations.

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.BeginArrange Method

AnnealLayout.BeginArrange Method
[image]

Initializes the layout object for a step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BeginArrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Function BeginArrange( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram

The Diagram that will be arranged.

items

A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the layout object has been initialized successfully; otherwise, false.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.EndArrange Method

AnnealLayout.EndArrange Method
[image]

Completes the step-by-step execution started with a call to BeginArrange.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void EndArrange ()

Visual Basic [image] Copy Code

Public Sub EndArrange ()

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Iterate Method

AnnealLayout.Iterate Method
[image]

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Iterate (
int iterationFrom,
int iterationTo
)

Visual Basic [image] Copy Code

Public Sub Iterate( _
iterationFrom As Integer, _
iterationTo As Integer _
)

Parameters

iterationFrom

Specifies from which iteration to start.

iterationTo

Specifies at which iteration to stop.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate starts from the iteration next to the one where the previous call has stopped.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout Properties

AnnealLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
ApproximateLinkLength | Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.
BoundaryFactor | Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.
CrossingLinksCost | Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.
DistributionFactor | Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.
GatherStatistics | Gets or sets a value specifying whether the layout should gather statistics while running.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
InitialTemperature | Gets or sets the initial temperature of the simulated annealing process.
IterationsPerStage | Gets or sets how many node shift iterations to perform at each stage of the algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkLengthFactor | Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeLinkCrossingCost | Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.
NodeLinkDistFactor | Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.
Stages | Gets or sets how many cool-down stages the algorithm should simulate.
Statistics | Gets statistics about the layout execution and end results.
TemperatureScale | Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.
WidthHeightRatio | Gets or sets what width/height ratio the layout area should have.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.ApproximateLinkLength Property

AnnealLayout.ApproximateLinkLength Property
[image]

Gets or sets a value indicating whether the layout should approximate the length of graph links by calculating the distance between the centers of their incident nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ApproximateLinkLength { get; set; }

Visual Basic [image] Copy Code

Public Property ApproximateLinkLength As Boolean

Property Value

A boolean value.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.BoundaryFactor Property

AnnealLayout.BoundaryFactor Property
[image]

Gets or sets a value indicating the importance of the distance between nodes and the layout area boundaries, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BoundaryFactor { get; set; }

Visual Basic [image] Copy Code

Public Property BoundaryFactor As Double

Property Value

A double multiplier applied to the node-to-boundary distance cost when evaluating the total cost of a graph configuration. The default is 3000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which nodes are placed farther from the layout area bounds, that is, nodes will tend to gather in the center of the layout area.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.CrossingLinksCost Property

AnnealLayout.CrossingLinksCost Property
[image]

Gets or sets a value indicating the importance of the low number of link crossings, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double CrossingLinksCost { get; set; }

Visual Basic [image] Copy Code

Public Property CrossingLinksCost As Double

Property Value

A double value added to the total cost of a graph configuration for each pair of crossing links. The default is 120000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations with fewer link crossings.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.DefaultMarginValue Property

AnnealLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.DistributionFactor Property

AnnealLayout.DistributionFactor Property
[image]

Gets or sets a value indicating the importance of the node distribution, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DistributionFactor { get; set; }

Visual Basic [image] Copy Code

Public Property DistributionFactor As Double

Property Value

A double multiplier applied to the node distribution cost when evaluating the total cost of a graph configuration. The default is 40000.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which the nodes are placed farther one from another.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.GatherStatistics Property

AnnealLayout.GatherStatistics Property
[image]

Gets or sets a value specifying whether the layout should gather statistics while running.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool GatherStatistics { get; set; }

Visual Basic [image] Copy Code

Public Property GatherStatistics As Boolean

Property Value

A boolean value.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.InitialTemperature Property

AnnealLayout.InitialTemperature Property
[image]

Gets or sets the initial temperature of the simulated annealing process.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double InitialTemperature { get; set; }

Visual Basic [image] Copy Code

Public Property InitialTemperature As Double

Property Value

A double value specifying the initial temperature of the simulation. The default is 40.

Remarks

A low initial temperature prevents nodes from moving far from their initial position. If you need the final arrangement to have resemblance to the initial formation of the graph elements, set a lower initial temperature and disable Randomize.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.IterationsPerStage Property

AnnealLayout.IterationsPerStage Property
[image]

Gets or sets how many node shift iterations to perform at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IterationsPerStage { get; set; }

Visual Basic [image] Copy Code

Public Property IterationsPerStage As Integer

Property Value

An integer value specifying the number of node shift iterations. The default is 50.

Remarks

IterationsPerStage specifies how many node configurations to evaluate at each stage of the temperature cool-down simulation. More iterations will yield better layouts but require more time to complete.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.LayoutArea Property

AnnealLayout.LayoutArea Property
[image]

Gets or sets the size of the layout area.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As Rect

Property Value

A Rectangle representing the boundaries of the layout area. The default is Empty.

Remarks

If the layout area is not explicitly set, the algorithm will choose one suitable for the graph size. In that case the WidthHeightRatio property specifies how much larger the layout area width should be than its height.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.LinkLengthFactor Property

AnnealLayout.LinkLengthFactor Property
[image]

Gets or sets a value indicating the importance of the short length of links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkLengthFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinkLengthFactor As Double

Property Value

A double multiplier applied to the link length cost when evaluating the total cost of a graph configuration. The default is 0.25.

Remarks

Assigning a larger value to this property will make the algorithm choose graph configurations in which links are shorter.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Name Property

AnnealLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Anneal layout".

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.NodeLinkCrossingCost Property

AnnealLayout.NodeLinkCrossingCost Property
[image]

Gets or sets a value indicating the importance of low number of overlaps between links and nodes relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeLinkCrossingCost { get; set; }

Visual Basic [image] Copy Code

Public Property NodeLinkCrossingCost As Double

Property Value

A double value added to the total cost of a graph configuration when a link crosses a node. The default is 15000.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.NodeLinkDistFactor Property

AnnealLayout.NodeLinkDistFactor Property
[image]

Gets or sets a value indicating the importance of the distance between nodes and links, relative to the other criteria considered by the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeLinkDistFactor { get; set; }

Visual Basic [image] Copy Code

Public Property NodeLinkDistFactor As Double

Property Value

A double value specifying the distance factor.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Randomize Property

AnnealLayout.Randomize Property
[image]

Gets or sets a value indicating whether the nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Randomize { get; set; }

Visual Basic [image] Copy Code

Public Property Randomize As Boolean

Property Value

true to start the simulation with random node positions; false to start it with the original node positions. The default is true.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Root Property

AnnealLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

A DiagramNode whose containing graph should be arranged. The default is null.

Remarks

If a root nodes is specified and SplitGraph is enabled, only the graph that contains the root node is laid out by Arrange.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.SplitGraph Property

AnnealLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is false.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area. If a Root node is specified and SplitGraph is true, only the graph that contains the root node will be arranged.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Stages Property

AnnealLayout.Stages Property
[image]

Gets or sets how many cool-down stages the algorithm should simulate.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Stages { get; set; }

Visual Basic [image] Copy Code

Public Property Stages As Integer

Property Value

An integer value specifying the number of temperature decreases the simulation should run. The default is 15.

Remarks

At each stage the algorithm evaluates different graph arrangements produced by modifying the best configuration from the previous stage. The modifications are done by shifting nodes by a distance that depends on the current temperature. The TemperatureScale property specifies how much the temperature decreases at each stage. IterationsPerStage specifies how many configurations are evaluated at each stage.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.Statistics Property

AnnealLayout.Statistics Property
[image]

Gets statistics about the layout execution and end results.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnnealLayoutStatistics Statistics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Statistics As AnnealLayoutStatistics

Property Value

An instance of the AnnealLayoutStatistics class.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.TemperatureScale Property

AnnealLayout.TemperatureScale Property
[image]

Gets or sets how much the simulated temperature is decreased at each stage of the algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double TemperatureScale { get; set; }

Visual Basic [image] Copy Code

Public Property TemperatureScale As Double

Property Value

A double multiplier applied to the simulated temperature at each stage of the algorithm. The default is 0.75.

Remarks

This value should be in the interval (0, 1). The algorithm produces better results when running for many Stages with a gradual temperature decrease, that is, a TemperatureScale closer to 1.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.AnnealLayout.WidthHeightRatio Property

AnnealLayout.WidthHeightRatio Property
[image]

Gets or sets what width/height ratio the layout area should have.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double WidthHeightRatio { get; set; }

Visual Basic [image] Copy Code

Public Property WidthHeightRatio As Double

Property Value

A double value specifying the layout area width to height ratio. The default is 1.

Remarks

If the LayoutArea is not explicitly set, the algorithm will choose one suitable for the graph size. In that case the WidthHeightRatio property specifies how much larger the layout area width should be than its height.

See Also

AnnealLayout Members
AnnealLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Class

CascadeLayout Class
Remarks See Also
[image]

Performs cascading layout on simple, connected graphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CascadeLayout : Layout

Visual Basic [image] Copy Code

Public Class CascadeLayout
Inherits Layout

Remarks

CascadeLayout places nodes on a virtual grid and arranges links orthogonally, such that if the source graph is planar all links are guaranteed to have no more than two bends and will not intersect. By default the layout method arranges nodes in rows and link segments in columns; this can be changed by setting the Orientation property.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.CascadeLayout

See Also

CascadeLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Members

CascadeLayout Members
Constructors Properties Methods
[image]

Performs cascading layout on simple, connected graphs.

The following tables list the members exposed by the CascadeLayout type.

Public Constructors

Name | Description
CascadeLayout | Initializes a new instance of the CascadeLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Padding | Gets or sets the spacing between nodes in adjacent layers.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Constructor

CascadeLayout Constructor
[image]

Initializes a new instance of the CascadeLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CascadeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout Properties

CascadeLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Padding | Gets or sets the spacing between nodes in adjacent layers.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.DefaultMarginValue Property

CascadeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.Name Property

CascadeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Cascade layout".

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.Orientation Property

CascadeLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CascadeLayout.Padding Property

CascadeLayout.Padding Property
[image]

Gets or sets the spacing between nodes in adjacent layers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

A double value. The default value is 15.

See Also

CascadeLayout Members
CascadeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Class

CircularLayout Class
[image]

Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class CircularLayout : Layout

Visual Basic [image] Copy Code

Public Class CircularLayout
Inherits Layout

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.CircularLayout

See Also

CircularLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Members

CircularLayout Members
Constructors Properties Methods
[image]

Implements a circular graph layout algorithm. Nodes are distributed evenly on the circumference of a circle at positions that result in as few link crossing as possible.

The following tables list the members exposed by the CircularLayout type.

Public Constructors

Name | Description
CircularLayout | Initializes a new instance of the CircularLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
AutoRadiusFactor | Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Radius | Gets or sets the radius of the layout circle.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SiftingRounds | Gets or sets the number of sifts to perform during the layout.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Constructor

CircularLayout Constructor
[image]

Initializes a new instance of the CircularLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public CircularLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout Properties

CircularLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
AutoRadiusFactor | Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Radius | Gets or sets the radius of the layout circle.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SiftingRounds | Gets or sets the number of sifts to perform during the layout.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.AutoRadiusFactor Property

CircularLayout.AutoRadiusFactor Property
[image]

Gets or sets a multiplier for the automatically calculated radius when Radius is set to 0.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double AutoRadiusFactor { get; set; }

Visual Basic [image] Copy Code

Public Property AutoRadiusFactor As Double

Property Value

A double value.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.DefaultMarginValue Property

CircularLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.Name Property

CircularLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Circular layout".

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.Radius Property

CircularLayout.Radius Property
[image]

Gets or sets the radius of the layout circle.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Radius { get; set; }

Visual Basic [image] Copy Code

Public Property Radius As Double

Property Value

A double value specifying the radius. The default value is 60.

Remarks

If this property is set to 0, the layout will try to find an appropriate radius depending on the number and size of the participating nodes.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.SiftingRounds Property

CircularLayout.SiftingRounds Property
[image]

Gets or sets the number of sifts to perform during the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int SiftingRounds { get; set; }

Visual Basic [image] Copy Code

Public Property SiftingRounds As Integer

Property Value

An integer value specifying the number of sifting rounds. The default value is 1.

Remarks

After calculating the initial placement of nodes using a fast but inaccurate layout function, the algorithm can run a few sifting rounds to reduce the link crossings, as set in this property.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.CircularLayout.SplitGraph Property

CircularLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is true.

See Also

CircularLayout Members
CircularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout Class

DecisionLayout Class
Remarks See Also
[image]

Implements a decision graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class DecisionLayout : Layout

Visual Basic [image] Copy Code

Public Class DecisionLayout
Inherits Layout

Remarks

This algorithm arranges simple flowcharts consisting of decision boxes with up to three outgoing links per node and activity boxes with a single outgoing link per node. The nodes are arranged in columns and rows, whose distance depends on the HorizontalPadding and VerticalPadding property values. When links share the same row or column, they are placed at a distance specified via LinkPadding.

The layout arranges nodes recursively starting from StartNode. If StartNode is not specified, the algorithm selects the root of the deepest branch of the graph's spanning tree as start node.

The overall orientation of the layout can be set via the Orientation property. There is no distinction made between yes/no links, and the node sides by which links are aligned depend only on the order of links in OutgoingLinks collection. If you have a preferred position for links depending on their yes/no type, make sure the OutgoingLinks collections of nodes are sorted by links' logical values.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.DecisionLayout

See Also

DecisionLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout Members

DecisionLayout Members
Constructors Properties Methods
[image]

Implements a decision graph layout algorithm.

The following tables list the members exposed by the DecisionLayout type.

Public Constructors

Name | Description
DecisionLayout | Initializes a new instance of the DecisionLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
HorizontalPadding | Gets or sets the horizontal distance between adjacent nodes.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets the distance between parallel links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
StartNode | Gets or sets the initial (top-left) node in the arranged diagram.
VerticalPadding | Gets or sets the vertical distance between adjacent nodes.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout Constructor

DecisionLayout Constructor
[image]

Initializes a new instance of the DecisionLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DecisionLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout Properties

DecisionLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
HorizontalPadding | Gets or sets the horizontal distance between adjacent nodes.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets the distance between parallel links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
StartNode | Gets or sets the initial (top-left) node in the arranged diagram.
VerticalPadding | Gets or sets the vertical distance between adjacent nodes.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.DefaultMarginValue Property

DecisionLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.HorizontalPadding Property

DecisionLayout.HorizontalPadding Property
[image]

Gets or sets the horizontal distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double HorizontalPadding { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalPadding As Double

Property Value

A double value specifying the distance between adjacent nodes in same row. The default value is 15.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.LinkPadding Property

DecisionLayout.LinkPadding Property
[image]

Gets or sets the distance between parallel links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkPadding { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPadding As Double

Property Value

A double value specifying the distance between links that share the same row or column. The default value is 2.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.Name Property

DecisionLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Decision layout".

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.Orientation Property

DecisionLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration specifying the overall layout orientation. The default value is Vertical.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.StartNode Property

DecisionLayout.StartNode Property
[image]

Gets or sets the initial (top-left) node in the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As DiagramNode

Property Value

A DiagramNode instance specifying the start node.

Remarks

If this property is null, the layout will pick-up the start node automatically.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.DecisionLayout.VerticalPadding Property

DecisionLayout.VerticalPadding Property
[image]

Gets or sets the vertical distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double VerticalPadding { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalPadding As Double

Property Value

A double value specifying the distance between adjacent nodes in same column. The default value is 15.

See Also

DecisionLayout Members
DecisionLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Direction Enumeration

Direction Enumeration
[image]

Specifies a layout direction.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Direction

Visual Basic [image] Copy Code

Public Enum Direction

Members

Member name | Description
Reversed | Indicates either right-to-left or bottom-to-top direction.
Straight | Indicates either left-to-right or top-to-bottom direction.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout Class

FlowchartLayout Class
Remarks See Also
[image]

Implements a flowchart, workflow and process diagrams layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FlowchartLayout : Layout

Visual Basic [image] Copy Code

Public Class FlowchartLayout
Inherits Layout

Remarks

The algorithm recognizes program code -like patterns in the graph, such as loops, sequences and if/switch branchings, and arranges them recursively. FlowchartLayout could be used to arrange other types of graphs as well, though with some restrictions. For example it treats all back links as loops in the code, and expects that they are nested – loop links starting closer to the stop node should end closer to the start node. Another similar restriction is that there shouldn't be any cross-links that connect different branches of a decision sub-graph.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.FlowchartLayout

See Also

FlowchartLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout Members

FlowchartLayout Members
Constructors Properties Methods
[image]

Implements a flowchart, workflow and process diagrams layout algorithm.

The following tables list the members exposed by the FlowchartLayout type.

Public Constructors

Name | Description
FlowchartLayout | Initializes a new instance of the FlowchartLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BranchPadding | Gets or sets how much space to leave between adjacent decision branches in the flowchart.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
IgnoreRepeatingLinks | Gets or sets a value indicating whether to ignore repeating links.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets how much space to leave between adjacent back links designating nested loops.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between consecutive nodes in the flowchart.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout Constructor

FlowchartLayout Constructor
[image]

Initializes a new instance of the FlowchartLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FlowchartLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout Properties

FlowchartLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BranchPadding | Gets or sets how much space to leave between adjacent decision branches in the flowchart.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
IgnoreRepeatingLinks | Gets or sets a value indicating whether to ignore repeating links.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkPadding | Gets or sets how much space to leave between adjacent back links designating nested loops.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between consecutive nodes in the flowchart.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.BranchPadding Property

FlowchartLayout.BranchPadding Property
[image]

Gets or sets how much space to leave between adjacent decision branches in the flowchart.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BranchPadding { get; set; }

Visual Basic [image] Copy Code

Public Property BranchPadding As Double

Property Value

A double value specifying the distance between adjacent branches.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.DefaultMarginValue Property

FlowchartLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.IgnoreRepeatingLinks Property

FlowchartLayout.IgnoreRepeatingLinks Property
[image]

Gets or sets a value indicating whether to ignore repeating links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreRepeatingLinks { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreRepeatingLinks As Boolean

Property Value

true to ignore repeating links, otherwise false. The default value is false.

Remarks

If there are many links connecting the same pair of nodes in the same direction, the analysis of the inherent flowchart structure might fail. In such cases, set this property to true.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.LinkPadding Property

FlowchartLayout.LinkPadding Property
[image]

Gets or sets how much space to leave between adjacent back links designating nested loops.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkPadding { get; set; }

Visual Basic [image] Copy Code

Public Property LinkPadding As Double

Property Value

A double value specifying the distance between adjacent back links.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.Name Property

FlowchartLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Flowchart layout".

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.NodeDistance Property

FlowchartLayout.NodeDistance Property
[image]

Gets or sets the distance between consecutive nodes in the flowchart.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between neighbor nodes in the same sequence.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.Orientation Property

FlowchartLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FlowchartLayout.SplitGraph Property

FlowchartLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true to arrange each subgraph on its own, otherwise false. The default value is true.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area.

See Also

FlowchartLayout Members
FlowchartLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Class

FractalLayout Class
Remarks See Also
[image]

A tree layout algorithm that places child nodes symmetrically around their parent node.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class FractalLayout : Layout

Visual Basic [image] Copy Code

Public Class FractalLayout
Inherits Layout

Remarks

Nodes at the lowest level are arranged directly in a circle around their parent. At the upper level, the already arranged nodes form branches that are arranged in a circle around the new parent node. The algorithm is recursively repeated till the highest level is reached. If nodes in the tree have uniform number of children, the end result has fractal-like appearance (subsets of the graph look like scaled-down copies of the whole graph).

You can choose which node should be displayed at the center of the topmost circle by setting the Root property. If it is not specified, the algorithm automatically selects a root that leads to more balanced distribution of nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.FractalLayout

See Also

FractalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Members

FractalLayout Members
Constructors Properties Methods
[image]

A tree layout algorithm that places child nodes symmetrically around their parent node.

The following tables list the members exposed by the FractalLayout type.

Public Constructors

Name | Description
FractalLayout | Initializes a new instance of the FractalLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Constructor

FractalLayout Constructor
[image]

Initializes a new instance of the FractalLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public FractalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout Properties

FractalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets the tree root.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout.DefaultMarginValue Property

FractalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

A Size object.

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout.Name Property

FractalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Fractal layout".

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.FractalLayout.Root Property

FractalLayout.Root Property
[image]

Gets or sets the tree root.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

A DiagramNode that should be placed at the center of the arranged tree. The default value is null.

Remarks

If there is no root specified, the algorithm automatically selects one that will lead to more balanced branch sizes.

See Also

FractalLayout Members
FractalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Class

GridLayout Class
Remarks See Also
[image]

Implements a grid graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class GridLayout : Layout

Visual Basic [image] Copy Code

Public Class GridLayout
Inherits Layout

Remarks

GridLayout arranges diagram nodes in a grid, keeping connected nodes close together. The algorithm strives to achieve a small number of link crossings. It is based on an iterative process whose initial steps shuffle the grid nodes randomly. That can lead to very different results each time the algorithm is run.

To apply the layout to a diagram, create a GridLayout instance, set its members and invoke the Arrange method. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

The distance between points in the layout grid can be changed through GridSize. Nodes to be placed at the upper-left and lower-right corners of the grid can be assigned to StartNode and EndNode.

Anchoring specifies whether the layout algorithm must attach links to the anchor points of graphs nodes. The grid layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.GridLayout

See Also

GridLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Members

GridLayout Members
Constructors Properties Methods
[image]

Implements a grid graph layout algorithm.

The following tables list the members exposed by the GridLayout type.

Public Constructors

Name | Description
GridLayout | Initializes a new instance of the GridLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EndNode | Gets or sets the node that is placed at the lower right corner of the grid.
GridSize | Gets or sets the desired distance between adjacent grid points.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
Iterations | Gets or sets for how many iterations to run the grid layout algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Gets or sets the node that is placed at the upper left corner of the grid.
TimeLimit | Gets or sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Constructor

GridLayout Constructor
[image]

Initializes a new instance of the GridLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public GridLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout Properties

GridLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EndNode | Gets or sets the node that is placed at the lower right corner of the grid.
GridSize | Gets or sets the desired distance between adjacent grid points.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
Iterations | Gets or sets for how many iterations to run the grid layout algorithm.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram should be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
StartNode | Gets or sets the node that is placed at the upper left corner of the grid.
TimeLimit | Gets or sets a time-out value for the path-finding part of the grid layout algorithm.
UseLongestPath | Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.DefaultMarginValue Property

GridLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(10, 10).

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.EndNode Property

GridLayout.EndNode Property
[image]

Gets or sets the node that is placed at the lower right corner of the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode EndNode { get; set; }

Visual Basic [image] Copy Code

Public Property EndNode As DiagramNode

Property Value

An instance of the DiagramNode class. Default value is null.

Remarks

If you assign a node to that property, then StartNode cannot be null and must be set too. GridLayout usually produces better layouts if both StartNode and EndNode are null references; in such a case the algorithm automatically selects suitable nodes.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.GridSize Property

GridLayout.GridSize Property
[image]

Gets or sets the desired distance between adjacent grid points.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

A double number specifying the grid size. The default is 25.

Remarks

When placing a node at a grid position, the node center point is aligned to the grid point at that position.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Iterations Property

GridLayout.Iterations Property
[image]

Gets or sets for how many iterations to run the grid layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int Iterations { get; set; }

Visual Basic [image] Copy Code

Public Property Iterations As Integer

Property Value

An integer number specifying the number of iterations. The default is 3000.

Remarks

More iterations would yield better layouts but require more time to complete.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Name Property

GridLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Grid layout".

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.RandomSeed Property

GridLayout.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

An integer value.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.Root Property

GridLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram should be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference.

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.SplitGraph Property

GridLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true to split the graph; otherwise, false.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.StartNode Property

GridLayout.StartNode Property
[image]

Gets or sets the node that is placed at the upper left corner of the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As DiagramNode

Property Value

An instance of the DiagramNode class. The default is null.

Remarks

If you assign a node to that property, then EndNode cannot be null and must be set too. GridLayout usually produces better layouts if both StartNode and EndNode are null references; in such a case the algorithm automatically selects suitable nodes.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.TimeLimit Property

GridLayout.TimeLimit Property
[image]

Gets or sets a time-out value for the path-finding part of the grid layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public long TimeLimit { get; set; }

Visual Basic [image] Copy Code

Public Property TimeLimit As Long

Property Value

An integer value specifying time-out in milliseconds. The default is 10000 (10 seconds).

Remarks

The grid layout algorithm arranges graph nodes and links along the longest path in the graph. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. When the time-out set with this property occurs, the path-finding routine stops and the layout algorithm uses the longest path known at that moment. Usually, for graphs containing several hundreds of nodes, 1-2 seconds are enough to find a path long enough to produce a nice layout.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.GridLayout.UseLongestPath Property

GridLayout.UseLongestPath Property
[image]

Gets or sets a value indicating whether the algorithm should arrange nodes around the longest path in the graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool UseLongestPath { get; set; }

Visual Basic [image] Copy Code

Public Property UseLongestPath As Boolean

Property Value

true to look for the longest path in the graph and arrange nodes around it; otherwise, false.

Remarks

Initially, the algorithm places nodes and links from the longest path in the graph at the grid diagonal, and arranges the rest of the nodes around the diagonal. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. Disabling this property will let you skip the path-finding part of the algorithm, which will make it work much faster.

See Also

GridLayout Members
GridLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Class

HierarchicalLayout Class
Remarks See Also
[image]

Performs hierarchical layout on simple, connected, level-planar graphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class HierarchicalLayout : Layout

Visual Basic [image] Copy Code

Public Class HierarchicalLayout
Inherits Layout

Remarks

HierarchicalLayout places nodes on user-defined levels, such that if the source graph is level-planar, all links are guaranteed to have a single segment and will not intersect. A graph is considered level-planar if it is possible to draw it without link intersections when its nodes are positioned on predefined levels. The layout method requires that for each node LayoutTraits contains a HierarchicalLayoutTraits.Level entry specifying the level, and no two connected nodes must be on the same level.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.HierarchicalLayout

See Also

HierarchicalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Members

HierarchicalLayout Members
Constructors Properties Methods
[image]

Performs hierarchical layout on simple, connected, level-planar graphs.

The following tables list the members exposed by the HierarchicalLayout type.

Public Constructors

Name | Description
HierarchicalLayout | Initializes a new instance of the HierarchicalLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets the distance between adjacent levels in the hierarchical layout.
LinkBendFactor | Gets or sets the bending factor of links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Constructor

HierarchicalLayout Constructor
[image]

Initializes a new instance of the HierarchicalLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public HierarchicalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout Properties

HierarchicalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets the distance between adjacent levels in the hierarchical layout.
LinkBendFactor | Gets or sets the bending factor of links.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.DefaultMarginValue Property

HierarchicalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.LevelDistance Property

HierarchicalLayout.LevelDistance Property
[image]

Gets or sets the distance between adjacent levels in the hierarchical layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Double

Property Value

A double value. The default value is 40.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.LinkBendFactor Property

HierarchicalLayout.LinkBendFactor Property
[image]

Gets or sets the bending factor of links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkBendFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinkBendFactor As Double

Property Value

The default value is 1.

Remarks

A value of 1 indicates that the links should not bend. A value less than 1 indicates that the links should bend towards the geometric center of the graph. A value greater than 1 indicates that the links should bend outwards.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.Name Property

HierarchicalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Hierarchical layout".

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.HierarchicalLayout.Orientation Property

HierarchicalLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

HierarchicalLayout Members
HierarchicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Interface

ILayout Interface
[image]

Common interface for all layout classes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ILayout

Visual Basic [image] Copy Code

Public Interface ILayout

Inheritors

MindFusion.Diagramming.Layout.Layout

See Also

ILayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Members

ILayout Members
Properties Methods
[image]

Common interface for all layout classes.

The following tables list the members exposed by the ILayout type.

Public Properties

Name | Description
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Public Methods

Name | Description
Arrange | Applies the layout to the specified Diagram instance.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Methods

ILayout Methods
[image]

Public Methods

Name | Description
Arrange | Applies the layout to the specified Diagram instance.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.Arrange Method

ILayout.Arrange Method
[image]

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool Arrange (
Diagram diagram
)

Visual Basic [image] Copy Code

Function Arrange( _
diagram As Diagram _
) As Boolean

Parameters

diagram

The Diagram that should be arranged.

Return Value

Returns whether the arrangement was successful.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout Properties

ILayout Properties
[image]

Public Properties

Name | Description
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

See Also

ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.LayoutLink Property

ILayout.LayoutLink Property
[image]

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

LayoutLink LayoutLink { get; set; }

Visual Basic [image] Copy Code

Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ILayout.LayoutNode Property

ILayout.LayoutNode Property
[image]

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

LayoutNode LayoutNode { get; set; }

Visual Basic [image] Copy Code

Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

ILayout Members
ILayout Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid Interface

ISwimlaneGrid Interface
[image]

Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface ISwimlaneGrid

Visual Basic [image] Copy Code

Public Interface ISwimlaneGrid

Inheritors

MindFusion.Diagramming.Layout.LaneGrid

See Also

ISwimlaneGrid Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid Members

ISwimlaneGrid Members
Methods
[image]

Represents an object which can be used by a SwimlaneLayout to adjust the corresponding swimlane grid.

The following tables list the members exposed by the ISwimlaneGrid type.

Public Methods

Name | Description
GetColumnCount | Gets the number of columns in the grid.
GetColumnWidth | Gets the the width of the specified column in the swimlane grid.
GetRowCount | Gets the number of rows in the swimlane grid.
GetRowHeight | Gets the the height of the specified row in the swimlane grid.
SetColumnCount | Sets the number of columns in the swimlane grid.
SetColumnWidth | Sets the the width of the specified column in the swimlane grid.
SetLeftMargin | Sets the left margin of the swimlane grid.
SetRowCount | Sets the number of rows in the swimlane grid.
SetRowHeight | Sets the the height of the specified row in the swimlane grid.
SetTopMargin | Sets the top margin of the swimlane grid.

See Also

ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid Methods

ISwimlaneGrid Methods
[image]

Public Methods

Name | Description
GetColumnCount | Gets the number of columns in the grid.
GetColumnWidth | Gets the the width of the specified column in the swimlane grid.
GetRowCount | Gets the number of rows in the swimlane grid.
GetRowHeight | Gets the the height of the specified row in the swimlane grid.
SetColumnCount | Sets the number of columns in the swimlane grid.
SetColumnWidth | Sets the the width of the specified column in the swimlane grid.
SetLeftMargin | Sets the left margin of the swimlane grid.
SetRowCount | Sets the number of rows in the swimlane grid.
SetRowHeight | Sets the the height of the specified row in the swimlane grid.
SetTopMargin | Sets the top margin of the swimlane grid.

See Also

ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetColumnCount Method

ISwimlaneGrid.GetColumnCount Method
[image]

Gets the number of columns in the grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

int GetColumnCount ()

Visual Basic [image] Copy Code

Function GetColumnCount () As Integer

Return Value

The number of columns in the grid.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetColumnWidth Method

ISwimlaneGrid.GetColumnWidth Method
[image]

Gets the the width of the specified column in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double GetColumnWidth (
int index
)

Visual Basic [image] Copy Code

Function GetColumnWidth( _
index As Integer _
) As Double

Parameters

index

The zero-based index of the column.

Return Value

The width of the column.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetRowCount Method

ISwimlaneGrid.GetRowCount Method
[image]

Gets the number of rows in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

int GetRowCount ()

Visual Basic [image] Copy Code

Function GetRowCount () As Integer

Return Value

The number of rows in the grid.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.GetRowHeight Method

ISwimlaneGrid.GetRowHeight Method
[image]

Gets the the height of the specified row in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double GetRowHeight (
int index
)

Visual Basic [image] Copy Code

Function GetRowHeight( _
index As Integer _
) As Double

Parameters

index

The zero-based index of the row.

Return Value

The height of the row.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetColumnCount Method

ISwimlaneGrid.SetColumnCount Method
[image]

Sets the number of columns in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetColumnCount (
int value
)

Visual Basic [image] Copy Code

Sub SetColumnCount( _
value As Integer _
)

Parameters

value

A non-negative integer value specifying the number of columns.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetColumnWidth Method

ISwimlaneGrid.SetColumnWidth Method
[image]

Sets the the width of the specified column in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetColumnWidth (
int index,
double value
)

Visual Basic [image] Copy Code

Sub SetColumnWidth( _
index As Integer, _
value As Double _
)

Parameters

index

The zero-based index of the column.

value

The new width of the column.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetLeftMargin Method

ISwimlaneGrid.SetLeftMargin Method
[image]

Sets the left margin of the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetLeftMargin (
double value
)

Visual Basic [image] Copy Code

Sub SetLeftMargin( _
value As Double _
)

Parameters

value

The distance between the left side of the grid and the diagram bounds.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetRowCount Method

ISwimlaneGrid.SetRowCount Method
[image]

Sets the number of rows in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetRowCount (
int value
)

Visual Basic [image] Copy Code

Sub SetRowCount( _
value As Integer _
)

Parameters

value

A non-negative integer value specifying the number of rows.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetRowHeight Method

ISwimlaneGrid.SetRowHeight Method
[image]

Sets the the height of the specified row in the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetRowHeight (
int index,
double value
)

Visual Basic [image] Copy Code

Sub SetRowHeight( _
index As Integer, _
value As Double _
)

Parameters

index

The zero-based index of the row.

value

The new height of the row.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.ISwimlaneGrid.SetTopMargin Method

ISwimlaneGrid.SetTopMargin Method
[image]

Sets the top margin of the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

void SetTopMargin (
double value
)

Visual Basic [image] Copy Code

Sub SetTopMargin( _
value As Double _
)

Parameters

value

The distance between the top side of the grid and the diagram bounds.

See Also

ISwimlaneGrid Members
ISwimlaneGrid Interface
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Class

LaneGrid Class
[image]

Represents an ISwimlaneGrid which operates on a Grid object.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LaneGrid : ISwimlaneGrid

Visual Basic [image] Copy Code

Public Class LaneGrid
Implements ISwimlaneGrid

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.LaneGrid

See Also

LaneGrid Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Members

LaneGrid Members
Constructors Methods
[image]

Represents an ISwimlaneGrid which operates on a Grid object.

The following tables list the members exposed by the LaneGrid type.

Public Constructors

Name | Description
LaneGrid | Initializes a new instance of the LaneGrid class.

Public Methods

Name | Description
GetColumnCount | ISwimlaneGrid.GetColumnCount implementation.
GetColumnWidth | ISwimlaneGrid.GetColumnCount implementation.
GetRowCount | ISwimlaneGrid.GetRowCount implementation.
GetRowHeight | ISwimlaneGrid.GetRowHeight implementation.
SetColumnCount | ISwimlaneGrid.SetColumnCount implementation.
SetColumnWidth | ISwimlaneGrid.SetColumnCount implementation.
SetLeftMargin | ISwimlaneGrid.SetLeftMargin implementation.
SetRowCount | ISwimlaneGrid.SetRowCount implementation.
SetRowHeight | ISwimlaneGrid.SetRowHeight implementation.
SetTopMargin | ISwimlaneGrid.SetTopMargin implementation.

See Also

LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Constructor

LaneGrid Constructor
[image]

Initializes a new instance of the LaneGrid class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LaneGrid (
Grid grid
)

Visual Basic [image] Copy Code

Public New ( _
grid As Grid _
)

Parameters

grid

The underlyng Grid object.

See Also

LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid Methods

LaneGrid Methods
[image]

Public Methods

Name | Description
GetColumnCount | ISwimlaneGrid.GetColumnCount implementation.
GetColumnWidth | ISwimlaneGrid.GetColumnCount implementation.
GetRowCount | ISwimlaneGrid.GetRowCount implementation.
GetRowHeight | ISwimlaneGrid.GetRowHeight implementation.
SetColumnCount | ISwimlaneGrid.SetColumnCount implementation.
SetColumnWidth | ISwimlaneGrid.SetColumnCount implementation.
SetLeftMargin | ISwimlaneGrid.SetLeftMargin implementation.
SetRowCount | ISwimlaneGrid.SetRowCount implementation.
SetRowHeight | ISwimlaneGrid.SetRowHeight implementation.
SetTopMargin | ISwimlaneGrid.SetTopMargin implementation.

See Also

LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetColumnCount Method

LaneGrid.GetColumnCount Method
[image]

ISwimlaneGrid.GetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetColumnCount ()

Visual Basic [image] Copy Code

Public Function GetColumnCount () As Integer

Return Value

The number of columns in the grid.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetColumnWidth Method

LaneGrid.GetColumnWidth Method
[image]

ISwimlaneGrid.GetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GetColumnWidth (
int index
)

Visual Basic [image] Copy Code

Public Function GetColumnWidth( _
index As Integer _
) As Double

Parameters

index

The zero-based index of the column.

Return Value

The width of the column.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetRowCount Method

LaneGrid.GetRowCount Method
[image]

ISwimlaneGrid.GetRowCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int GetRowCount ()

Visual Basic [image] Copy Code

Public Function GetRowCount () As Integer

Return Value

The number of rows in the grid.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.GetRowHeight Method

LaneGrid.GetRowHeight Method
[image]

ISwimlaneGrid.GetRowHeight implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GetRowHeight (
int index
)

Visual Basic [image] Copy Code

Public Function GetRowHeight( _
index As Integer _
) As Double

Parameters

index

The zero-based index of the row.

Return Value

The height of the row.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetColumnCount Method

LaneGrid.SetColumnCount Method
[image]

ISwimlaneGrid.SetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetColumnCount (
int value
)

Visual Basic [image] Copy Code

Public Sub SetColumnCount( _
value As Integer _
)

Parameters

value

A non-negative integer value specifying the number of columns.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetColumnWidth Method

LaneGrid.SetColumnWidth Method
[image]

ISwimlaneGrid.SetColumnCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetColumnWidth (
int index,
double value
)

Visual Basic [image] Copy Code

Public Sub SetColumnWidth( _
index As Integer, _
value As Double _
)

Parameters

index

The zero-based index of the column.

value

The new width of the column.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetLeftMargin Method

LaneGrid.SetLeftMargin Method
[image]

ISwimlaneGrid.SetLeftMargin implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetLeftMargin (
double value
)

Visual Basic [image] Copy Code

Public Sub SetLeftMargin( _
value As Double _
)

Parameters

value

The distance between the left side of the grid and the diagram bounds.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetRowCount Method

LaneGrid.SetRowCount Method
[image]

ISwimlaneGrid.SetRowCount implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetRowCount (
int value
)

Visual Basic [image] Copy Code

Public Sub SetRowCount( _
value As Integer _
)

Parameters

value

A non-negative integer value specifying the number of rows.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetRowHeight Method

LaneGrid.SetRowHeight Method
[image]

ISwimlaneGrid.SetRowHeight implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetRowHeight (
int index,
double value
)

Visual Basic [image] Copy Code

Public Sub SetRowHeight( _
index As Integer, _
value As Double _
)

Parameters

index

The zero-based index of the row.

value

The new height of the row.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LaneGrid.SetTopMargin Method

LaneGrid.SetTopMargin Method
[image]

ISwimlaneGrid.SetTopMargin implementation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void SetTopMargin (
double value
)

Visual Basic [image] Copy Code

Public Sub SetTopMargin( _
value As Double _
)

Parameters

value

The distance between the top side of the grid and the diagram bounds.

See Also

LaneGrid Members
LaneGrid Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Class

LayeredLayout Class
Remarks See Also
[image]

Implements a layered graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LayeredLayout : Layout

Visual Basic [image] Copy Code

Public Class LayeredLayout
Inherits Layout

Remarks

This algorithm assigns diagram nodes to distinct horizontal or vertical layers. While arranging the layers, the layout routine seeks to meet the following criteria:

  • connected nodes must be placed close together;
  • links must flow in one direction if possible;
  • links must cross as few layers as possible;
  • links must not cross other links;

To apply this layout to a diagram, create a LayeredLayout instance, set its members and invoke the Arrange method. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

The final appearance of arranged graphs depends mostly on the Orientation and Direction properties which define the overall orientation of the layout. The LayerDistance and NodeDistance properties specify how much space to leave between adjacent layers and adjacent nodes in a layer.

The performance of LayeredLayout is dependent on the number of links in the diagram. At its first stage, the algorithm looks for the longest sequence of links in the graph and builds the node layers along it. That stage can be the most time consuming if there are a lot of links in a graph, so there is the TimeLimit property provided to control how much time the layout routine is allowed to spend on path-finding. Next, if there are layers much longer than the other ones and SplitLayers is enabled, nodes from these layers are moved to new ones so the graph width is uniformly distributed.

The layout routine continues by shuffling nodes and link points across their layers, so the criteria mentioned above are approximated. Finally, link ends are aligned to anchor points if Anchoring is enabled and the distance between outermost links is decreased as set in LinksCompactFactor.

The layered graph layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.LayeredLayout

See Also

LayeredLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Members

LayeredLayout Members
Constructors Properties Methods
[image]

Implements a layered graph layout algorithm.

The following tables list the members exposed by the LayeredLayout type.

Public Constructors

Name | Description
LayeredLayout | Overloaded. Initializes a new instance of the LayeredLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
Direction | Gets or sets the direction of the arranged diagram.
EnableCustomLayers | Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.
EndNode | Gets or sets the node that should be placed in the last layer of the arranged graph.
EnforceLinkFlow | Gets or sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
IgnoreNodeSize | Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to preserve the position of the root node.
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinksCompactFactor | Gets or sets a value indicating how much to compact the outermost arrows.
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Gets or sets a value indicating whether to split layers that are much wider than the other layers.
StableSort | Gets or sets a value indicating whether to apply stable sorting during the layout algorithm. Stable sorting sometimes produces more readable results.
StartNode | Gets or sets the node that should be placed in the first layer of the arranged graph.
Statistics | Gets layout-specific information about the nodes and links participating in the layout.
StraightenLongLinks | Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.
SwapPairsIterations | Gets or sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor

LayeredLayout Constructor
[image]

Initializes a new instance of the LayeredLayout class.

Overload List

Name | Description
LayeredLayout () | Initializes a new instance of the LayeredLayout class with the default settings.
LayeredLayout (Orientation, Double, Double, Size) | Initializes a new instance of the LayeredLayout class with the specified settings.

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor ()

LayeredLayout Constructor ()
See Also
[image]

Initializes a new instance of the LayeredLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayeredLayout Constructor Overload List
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Constructor (Orientation, Double, Double, Size)

LayeredLayout Constructor (Orientation, Double, Double, Size)
See Also
[image]

Initializes a new instance of the LayeredLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayout (
Orientation orientation,
double layerDistance,
double nodeDistance,
Size margins
)

Visual Basic [image] Copy Code

Public New ( _
orientation As Orientation, _
layerDistance As Double, _
nodeDistance As Double, _
margins As Size _
)

Parameters

orientation

The orientation of the layout.

layerDistance

The distance between adjacent layers.

nodeDistance

The distance between adjacent nodes within the same layer.

margins

The margin between the produced graph and the left side of the diagram bounding rectangle.

See Also

LayeredLayout Constructor Overload List
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout Properties

LayeredLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
Direction | Gets or sets the direction of the arranged diagram.
EnableCustomLayers | Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.
EndNode | Gets or sets the node that should be placed in the last layer of the arranged graph.
EnforceLinkFlow | Gets or sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
IgnoreNodeSize | Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to preserve the position of the root node.
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinksCompactFactor | Gets or sets a value indicating how much to compact the outermost arrows.
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitLayers | Gets or sets a value indicating whether to split layers that are much wider than the other layers.
StableSort | Gets or sets a value indicating whether to apply stable sorting during the layout algorithm. Stable sorting sometimes produces more readable results.
StartNode | Gets or sets the node that should be placed in the first layer of the arranged graph.
Statistics | Gets layout-specific information about the nodes and links participating in the layout.
StraightenLongLinks | Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.
SwapPairsIterations | Gets or sets how many times to perform pair-swapping iterations on each layer.
TimeLimit | Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.DefaultMarginValue Property

LayeredLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Direction Property

LayeredLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default is Straight.

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.EnableCustomLayers Property

LayeredLayout.EnableCustomLayers Property
[image]

Gets or sets a value indicating whether to indicating whether the layered layout will honor the LayeredLayoutTraits.Layer flags.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableCustomLayers { get; set; }

Visual Basic [image] Copy Code

Public Property EnableCustomLayers As Boolean

Property Value

A boolean value.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.EndNode Property

LayeredLayout.EndNode Property
[image]

Gets or sets the node that should be placed in the last layer of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode EndNode { get; set; }

Visual Basic [image] Copy Code

Public Property EndNode As DiagramNode

Property Value

A DiagramNode object representing the end node.

Remarks

This value is honored only if StartNode is specified too.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.EnforceLinkFlow Property

LayeredLayout.EnforceLinkFlow Property
[image]

Gets or sets a value indicating whether to attempt to force all links to go in the same direction. If the graph being arranged has cycles, some of the links will still go backward.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnforceLinkFlow { get; set; }

Visual Basic [image] Copy Code

Public Property EnforceLinkFlow As Boolean

Property Value

A boolean value.

Remarks

EnableCustomLayers and SplitLayers are ignored if this property is set to true.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.IgnoreNodeSize Property

LayeredLayout.IgnoreNodeSize Property
[image]

Gets or sets a value indicating whether the distance between adjacent nodes in the final layout should be independent of the nodes' size.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreNodeSize { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreNodeSize As Boolean

Property Value

true to ignore the node size; otherwise, false. The default is true.

Remarks

At this time, considering the size of nodes deteriorates the performance of the algorithm, so that's disabled by default.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.KeepRootPosition Property

LayeredLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to preserve the position of the root node.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

A boolean value.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LayerDistance Property

LayeredLayout.LayerDistance Property
[image]

Gets or sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LayerDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LayerDistance As Double

Property Value

A double value specifying the distance between layers. The default is 25.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LinksCompactFactor Property

LayeredLayout.LinksCompactFactor Property
[image]

Gets or sets a value indicating how much to compact the outermost arrows.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinksCompactFactor { get; set; }

Visual Basic [image] Copy Code

Public Property LinksCompactFactor As Double

Property Value

A double number in the interval [0, 1]. The default is 1.

Remarks

Links and nodes on the same graph layer are distributed uniformly as specified by the NodeDistance value. However, if there are more than 2-3 outermost links on a layer, they usually take up too much space without improving the visual quality of the diagram layout. This property allows compacting such links to save space. The factor specifies roughly a fraction of NodeDistance to leave between outer links.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.LinkType Property

LayeredLayout.LinkType Property
[image]

Gets or sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayoutLinkType LinkType { get; set; }

Visual Basic [image] Copy Code

Public Property LinkType As LayeredLayoutLinkType

Property Value

A member of the LayeredLayoutLinkType enumeration. The default is Straight.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Name Property

LayeredLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Layered layout".

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.NodeDistance Property

LayeredLayout.NodeDistance Property
[image]

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between adjacent nodes. The default is 20.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Orientation Property

LayeredLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Vertical.

Remarks

Specify Orientation.Vertical to have links flow in vertical direction and Orientation.Horizontal to have links flow in horizontal direction. The orientation of the resulting layers is opposite to that of the links. Thus, if the link tends to go in a vertical direction, the nodes are distributed in horizontal layers.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Root Property

LayeredLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference.

Remarks

All links and nodes that can be reached from the root by following recursively its links form a graph. If the root is specified, only the graph containing it is laid out by Arrange.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.SplitLayers Property

LayeredLayout.SplitLayers Property
[image]

Gets or sets a value indicating whether to split layers that are much wider than the other layers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitLayers { get; set; }

Visual Basic [image] Copy Code

Public Property SplitLayers As Boolean

Property Value

true to split wide layers; otherwise, false. The default is false.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.StableSort Property

LayeredLayout.StableSort Property
[image]

Gets or sets a value indicating whether to apply stable sorting during the layout algorithm. Stable sorting sometimes produces more readable results.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool StableSort { get; set; }

Visual Basic [image] Copy Code

Public Property StableSort As Boolean

Property Value

true to apply stable sorting algorithm, otherwise false. The default value is false.

Remarks

By default .NET sorts arrays using unstable sort, where if two elements have equal values, their order might not be the same between different runs of the sort method. This could lead to LayeredLayout not preserving the order of some nodes in a layer between different runs if there are more than one candidates for the same position. If you need the same order to be reproduced consistently, set StableSort to true.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.StartNode Property

LayeredLayout.StartNode Property
[image]

Gets or sets the node that should be placed in the first layer of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode StartNode { get; set; }

Visual Basic [image] Copy Code

Public Property StartNode As DiagramNode

Property Value

A DiagramNode object representing the start node.

Remarks

If there is no start node specified, the algorithm automatically selects one based on other LayeredLayout properties, such as EnforceLinkFlow.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.Statistics Property

LayeredLayout.Statistics Property
[image]

Gets layout-specific information about the nodes and links participating in the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayeredLayoutStatistics Statistics { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Statistics As LayeredLayoutStatistics

Property Value

An instance of the LayeredLayoutStatistics class containing detailed information about the performed layout, such as the layers individual nodes were assigned to.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.StraightenLongLinks Property

LayeredLayout.StraightenLongLinks Property
[image]

Gets or sets whether the layout algorithm should strive to straighten links that cross more than one layer of the graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool StraightenLongLinks { get; set; }

Visual Basic [image] Copy Code

Public Property StraightenLongLinks As Boolean

Property Value

true to straighten long links; otherwise false. The default value is false.

Remarks

If this property is enabled, links that cross multiple layers have at most two bends. Because of the additional horizontal alignment constraints, the arranged graph usually occupies a larger area than when not using StraightenLongLinks.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.SwapPairsIterations Property

LayeredLayout.SwapPairsIterations Property
[image]

Gets or sets how many times to perform pair-swapping iterations on each layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int SwapPairsIterations { get; set; }

Visual Basic [image] Copy Code

Public Property SwapPairsIterations As Integer

Property Value

An integer value specifying how many pair-swapping iterations to perform. The default is 5.

Remarks

The algorithm swaps node pairs on each layer aiming to decrease the number of crossing links. Setting a higher value to this property helps to decrease the number of crossings.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayout.TimeLimit Property

LayeredLayout.TimeLimit Property
[image]

Gets or sets a time-out value for the path-finding part of the layered layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public long TimeLimit { get; set; }

Visual Basic [image] Copy Code

Public Property TimeLimit As Long

Property Value

An integer value specifying time-out in milliseconds. The default is 10000 (10 seconds).

Remarks

The layered layout algorithm arranges graph nodes and links along the longest path in the graph. Large graphs with many links could contain hundreds of thousands of possible paths, so finding the longest one would be very time-consuming. When the time-out set with this property occurs, the path-finding routine stops and the layout algorithm uses the longest path known at that moment. Usually, for graphs containing several hundreds of nodes, 1-2 seconds are enough to find a long-enough path to produce nice layered layout.

See Also

LayeredLayout Members
LayeredLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutLinkType Enumeration

LayeredLayoutLinkType Enumeration
[image]

Specifies the style of the links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LayeredLayoutLinkType

Visual Basic [image] Copy Code

Public Enum LayeredLayoutLinkType

Members

Member name | Description
Cascading | Indicates cascading links.
Straight | Indicates straight links.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics Class

LayeredLayoutStatistics Class
[image]

Encapsulates information about a layered layout which has already complete.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public sealed class LayeredLayoutStatistics

Visual Basic [image] Copy Code

Public NotInheritable Class LayeredLayoutStatistics

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.LayeredLayoutStatistics

See Also

LayeredLayoutStatistics Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics Members

LayeredLayoutStatistics Members
Properties
[image]

Encapsulates information about a layered layout which has already complete.

The following tables list the members exposed by the LayeredLayoutStatistics type.

Public Properties

Name | Description
LayerCount | Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.
LinkLayerCount | Gets a mapping between links and the number of layers they run through.
NodeGridPositions | Gets a mapping between nodes and their assigned grid positions.
NodeLayerIndices | Gets a mapping between nodes and their assigned layers.

See Also

LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics Properties

LayeredLayoutStatistics Properties
[image]

Public Properties

Name | Description
LayerCount | Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.
LinkLayerCount | Gets a mapping between links and the number of layers they run through.
NodeGridPositions | Gets a mapping between nodes and their assigned grid positions.
NodeLayerIndices | Gets a mapping between nodes and their assigned layers.

See Also

LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.LayerCount Property

LayeredLayoutStatistics.LayerCount Property
[image]

Gets the total number of layers in the layout. If more than one subgraph is laid out, this property returns the number of layers in the last subgraph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int LayerCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LayerCount As Integer

Property Value

An integer value.

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.LinkLayerCount Property

LayeredLayoutStatistics.LinkLayerCount Property
[image]

Gets a mapping between links and the number of layers they run through.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<DiagramLink, Int32> LinkLayerCount { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property LinkLayerCount As Dictionary(Of DiagramLink, Int32)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.NodeGridPositions Property

LayeredLayoutStatistics.NodeGridPositions Property
[image]

Gets a mapping between nodes and their assigned grid positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<DiagramNode, Double> NodeGridPositions { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeGridPositions As Dictionary(Of DiagramNode, Double)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayeredLayoutStatistics.NodeLayerIndices Property

LayeredLayoutStatistics.NodeLayerIndices Property
[image]

Gets a mapping between nodes and their assigned layers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Dictionary<DiagramNode, Int32> NodeLayerIndices { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property NodeLayerIndices As Dictionary(Of DiagramNode, Int32)

Property Value

See Also

LayeredLayoutStatistics Members
LayeredLayoutStatistics Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Class

Layout Class
[image]

The base class for all layout classes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class Layout : ILayout

Visual Basic [image] Copy Code

Public MustInherit Class Layout
Implements ILayout

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.AnnealLayout
MindFusion.Diagramming.Layout.CascadeLayout
MindFusion.Diagramming.Layout.CircularLayout
MindFusion.Diagramming.Layout.DecisionLayout
MindFusion.Diagramming.Layout.FlowchartLayout
MindFusion.Diagramming.Layout.FractalLayout
MindFusion.Diagramming.Layout.GridLayout
MindFusion.Diagramming.Layout.HierarchicalLayout
MindFusion.Diagramming.Layout.LayeredLayout
MindFusion.Diagramming.Layout.OneWayLayout
MindFusion.Diagramming.Layout.OrthogonalLayout
MindFusion.Diagramming.Layout.OrthogonalRouter
MindFusion.Diagramming.Layout.SpringLayout
MindFusion.Diagramming.Layout.SwimlaneLayout
MindFusion.Diagramming.Layout.TopologicalLayout
MindFusion.Diagramming.Layout.TreeLayout
MindFusion.Diagramming.Layout.TreeMapLayout
MindFusion.Diagramming.Layout.TriangularLayout

See Also

Layout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Members

Layout Members
Constructors Properties Methods
[image]

The base class for all layout classes.

The following tables list the members exposed by the Layout type.

Protected Constructors

Name | Description
Layout | Initializes a new instance of the Layout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate.
RepeatingLinksPadding | Specifies the padding distance between repeating links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Constructor

Layout Constructor
[image]

Initializes a new instance of the Layout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Layout ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Methods

Layout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method

Layout.Arrange Method
[image]

Applies the layout to a Diagram instance.

Overload List

Name | Description
Layout.Arrange (Diagram) | Applies the layout to the specified Diagram instance.
Layout.Arrange (Diagram, DiagramItemCollection) | Applies the layout to the specified subset of items from the specified Diagram instance.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method (Diagram)

Layout.Arrange Method (Diagram)
See Also
[image]

Applies the layout to the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Arrange (
Diagram diagram
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange( _
diagram As Diagram _
) As Boolean

Parameters

diagram

The Diagram that should be arranged.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Arrange Method (Diagram, DiagramItemCollection)

Layout.Arrange Method (Diagram, DiagramItemCollection)
See Also
[image]

Applies the layout to the specified subset of items from the specified Diagram instance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool Arrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Overridable Function Arrange( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram

The Diagram that should be arranged.

items

A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the diagram has been arranged successfully; otherwise, false.

See Also

Arrange Method Overload List
Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout Properties

Layout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
Progress | Gets or sets the progress callback delegate.
RepeatingLinksPadding | Specifies the padding distance between repeating links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value for the Margins property, which may vary accross different layouts.

See Also

Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Anchoring Property

Layout.Anchoring Property
[image]

Gets or sets how to align links to the anchor points of nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Anchoring Anchoring { get; set; }

Visual Basic [image] Copy Code

Public Property Anchoring As Anchoring

Property Value

A member of the Anchoring enumeration. The default is Ignore.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.DefaultMarginValue Property

Layout.DefaultMarginValue Property
[image]

Gets the default value for the Margins property, which may vary accross different layouts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected abstract Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected MustOverride ReadOnly Property DefaultMarginValue As Size

Property Value

A Size object.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.GrowToFit Property

Layout.GrowToFit Property
[image]

Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool GrowToFit { get; set; }

Visual Basic [image] Copy Code

Public Property GrowToFit As Boolean

Property Value

true to grow diagram's Bounds if the arranged items would not fit, or false otherwise. The default value is true.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.KeepGroupLayout Property

Layout.KeepGroupLayout Property
[image]

Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepGroupLayout { get; set; }

Visual Basic [image] Copy Code

Public Property KeepGroupLayout As Boolean

Property Value

true if each group should be processed as an integral graph node; otherwise, false. The default is false.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.LayoutLink Property

Layout.LayoutLink Property
[image]

Gets or sets a delegate, which is invoked when the position of a link is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual LayoutLink LayoutLink { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LayoutLink As LayoutLink

Property Value

An instance of the LayoutLink delegate.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.LayoutNode Property

Layout.LayoutNode Property
[image]

Gets or sets a delegate, which is invoked when the position of a node is changed by the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual LayoutNode LayoutNode { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property LayoutNode As LayoutNode

Property Value

An instance of the LayoutNode delegate.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Margins Property

Layout.Margins Property
[image]

Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Size Margins { get; set; }

Visual Basic [image] Copy Code

Public Property Margins As Size

Property Value

A Size object.

Remarks

This value is also set as the distance between unconnected sub-graphs when they are placed as specified via MultipleGraphsPlacement.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.MultipleGraphsPlacement Property

Layout.MultipleGraphsPlacement Property
[image]

Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }

Visual Basic [image] Copy Code

Public Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Horizontal.

Remarks

If the diagram contains several unconnected subgraphs, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Name Property

Layout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract string Name { get; }

Visual Basic [image] Copy Code

Public MustOverride ReadOnly Property Name As String

Property Value

A string value.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.Progress Property

Layout.Progress Property
[image]

Gets or sets the progress callback delegate.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual LayoutProgress Progress { get; set; }

Visual Basic [image] Copy Code

Public Overridable Property Progress As LayoutProgress

Property Value

A LayoutProgress delegate method to call while the algorithm proceeds.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Layout.RepeatingLinksPadding Property

Layout.RepeatingLinksPadding Property
[image]

Specifies the padding distance between repeating links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RepeatingLinksPadding { get; set; }

Visual Basic [image] Copy Code

Public Property RepeatingLinksPadding As Double

Property Value

A double value.

See Also

Layout Members
Layout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutLink Delegate

LayoutLink Delegate
[image]

Represents methods that are called by the layout algorithms when the position of a link changes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void LayoutLink (
DiagramLink link
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutLink( _
link As DiagramLink _
)

Parameters

link

A reference to the link being laid out.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutNode Delegate

LayoutNode Delegate
[image]

Represents methods that are called by the layout algorithms when the position of a node changes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void LayoutNode (
DiagramNode node,
Rect oldBounds
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutNode( _
node As DiagramNode, _
oldBounds As Rect _
)

Parameters

node

A reference to the node being laid out.

oldBounds

The bounding rectangle of the node before it was repositioned by the layouting algorithm.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutProgress Delegate

LayoutProgress Delegate
[image]

Represents methods that are called to report on progress of layout algorithms.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate void LayoutProgress (
int current,
int total
)

Visual Basic [image] Copy Code

Public Delegate Sub LayoutProgress( _
current As Integer, _
total As Integer _
)

Parameters

current

An integer value specifying the current relative progress of the layout algorithm.

total

An integer value specifying the total number of steps required by the layouting algorithm in order to finish.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.LayoutSubgraph Delegate

LayoutSubgraph Delegate
[image]

Represents methods that are called by the layout algorithms in order to perform custom arrangement of a subgraph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate bool LayoutSubgraph (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Delegate Function LayoutSubgraph( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram

The diagram being arranged.

items

The subset of items to arrange.

Return Value

true if the items were arranged; otherwise, false.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.MultipleGraphsPlacement Enumeration

MultipleGraphsPlacement Enumeration
[image]

Specifies graph orientation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum MultipleGraphsPlacement

Visual Basic [image] Copy Code

Public Enum MultipleGraphsPlacement

Members

Member name | Description
Horizontal | Indicates that graphs should be placed in a row.
HorizontalSortAscending | Indicates that graphs should be placed in a row and sorted by the number of vertices they contain in an ascending order.
HorizontalSortDescending | Indicates that graphs should be placed in a row and sorted by the number of vertices they contain in a descending order.
MinimalArea | Indicates that graphs should be placed so that they cover minimal area.
Vertical | Indicates that graphs should be placed in a column.
VerticalSortAscending | Indicates that graphs should be placed in a column and sorted by the number of vertices they contain in an ascending order.
VerticalSortDescending | Indicates that graphs should be placed in a column and sorted by the number of vertices they contain in a descending order.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Class

OneWayLayout Class
Remarks See Also
[image]

Implements a one-way graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class OneWayLayout : Layout

Visual Basic [image] Copy Code

Public Class OneWayLayout
Inherits Layout

Remarks

The one-way layout ensures that links enter into nodes from the same general direction and exit them from the opposite side. If the graph contains cycles, some links bend around the nodes to keep the enter/exit direction consistent. The algorithm aims to minimize the number of such links.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OneWayLayout

See Also

OneWayLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Members

OneWayLayout Members
Constructors Properties Methods
[image]

Implements a one-way graph layout algorithm.

The following tables list the members exposed by the OneWayLayout type.

Public Constructors

Name | Description
OneWayLayout | Initializes a new instance of the OneWayLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimum spacing between adjacent nodes in the final layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
RoundedLinks | Gets or sets a value indicating whether the layout should smooth link bends.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Constructor

OneWayLayout Constructor
[image]

Initializes a new instance of the OneWayLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public OneWayLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout Properties

OneWayLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the minimum spacing between adjacent nodes in the final layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
RoundedLinks | Gets or sets a value indicating whether the layout should smooth link bends.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.DefaultMarginValue Property

OneWayLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.Name Property

OneWayLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "One-way layout".

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.NodeDistance Property

OneWayLayout.NodeDistance Property
[image]

Gets or sets the minimum spacing between adjacent nodes in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double number specifying the distance. The default is 20.

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.Orientation Property

OneWayLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Vertical.

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OneWayLayout.RoundedLinks Property

OneWayLayout.RoundedLinks Property
[image]

Gets or sets a value indicating whether the layout should smooth link bends.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool RoundedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property RoundedLinks As Boolean

Property Value

true to smooth link bends; otherwise, false.

See Also

OneWayLayout Members
OneWayLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.Orientation Enumeration

Orientation Enumeration
[image]

Specifies axial orientation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum Orientation

Visual Basic [image] Copy Code

Public Enum Orientation

Members

Member name | Description
Horizontal | Indicates horizontal orientation.
Vertical | Indicates vertical orientation.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Class

OrthogonalLayout Class
Remarks See Also
[image]

Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class OrthogonalLayout : Layout

Visual Basic [image] Copy Code

Public Class OrthogonalLayout
Inherits Layout

Remarks

This algorithm was designed for planar graphs where the nodes have at most four incident links, and produces best results with such graphs as input. It can arrange any arbitrary graph as well, by adding some dummy nodes and links to planarize the graph and reduce its vertex degree, and removing them after the layout. However this might lead to using larger area than necessary, due to the space occupied by dummy elements.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OrthogonalLayout

See Also

OrthogonalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Members

OrthogonalLayout Members
Constructors Properties Methods
[image]

Implements an orthogonal graph layout algorithm. Each link is drawn as a chain of alternating horizontal and vertical segments. Nodes are placed in a way that facilitates few links bends and crossings.

The following tables list the members exposed by the OrthogonalLayout type.

Public Constructors

Name | Description
OrthogonalLayout | Initializes a new instance of the OrthogonalLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
Directed | Gets or sets a value indicating whether the graph being laid out is directed.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MinimizeLinkBends | Gets or sets a value indicating whether the layout should attempt to minimize link bending.
MinLaneSize | Gets or sets a value indicating the minimum size of a lane.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Padding | Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Refine | Gets or sets a value indicating whether to refine the layout.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Constructor

OrthogonalLayout Constructor
[image]

Initializes a new instance of the OrthogonalLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public OrthogonalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout Properties

OrthogonalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
Directed | Gets or sets a value indicating whether the graph being laid out is directed.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MinimizeLinkBends | Gets or sets a value indicating whether the layout should attempt to minimize link bending.
MinLaneSize | Gets or sets a value indicating the minimum size of a lane.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Padding | Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Refine | Gets or sets a value indicating whether to refine the layout.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.DefaultMarginValue Property

OrthogonalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Directed Property

OrthogonalLayout.Directed Property
[image]

Gets or sets a value indicating whether the graph being laid out is directed.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Directed { get; set; }

Visual Basic [image] Copy Code

Public Property Directed As Boolean

Property Value

true to consider the direction of graph edges, false to ignore it; the default value is false.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.MinimizeLinkBends Property

OrthogonalLayout.MinimizeLinkBends Property
[image]

Gets or sets a value indicating whether the layout should attempt to minimize link bending.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MinimizeLinkBends { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizeLinkBends As Boolean

Property Value

true to minimize link bends, otherwise false. The default value is true.

Remarks

If this option is disabled, the layout class applies a fast linear time algorithm, however the layouts produced usually contain more bending links and occupy more space. If enabled, the layout class applies an algorithm of polynomial complexity and runs much slower.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.MinLaneSize Property

OrthogonalLayout.MinLaneSize Property
[image]

Gets or sets a value indicating the minimum size of a lane.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double MinLaneSize { get; set; }

Visual Basic [image] Copy Code

Public Property MinLaneSize As Double

Property Value

A double value specifying the minimum lane size. The default value is 10.

Remarks

The result of the layout's Arrange is a grid that contains the diagram's nodes and links. This property specifies the size of lanes which does not contain nodes, but only links.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Name Property

OrthogonalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Orthogonal layout".

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Padding Property

OrthogonalLayout.Padding Property
[image]

Gets or sets a value indicating how much space to leave between nodes in adjacent lanes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

A double value specifying the padding. The default is 15.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalLayout.Refine Property

OrthogonalLayout.Refine Property
[image]

Gets or sets a value indicating whether to refine the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Refine { get; set; }

Visual Basic [image] Copy Code

Public Property Refine As Boolean

Property Value

true to run a refinement pass, otherwise false. The default value is true.

See Also

OrthogonalLayout Members
OrthogonalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Class

OrthogonalRouter Class
Remarks See Also
[image]

Implements an orthogonal link routing algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class OrthogonalRouter : Layout

Visual Basic [image] Copy Code

Public Class OrthogonalRouter
Inherits Layout

Remarks

OrthogonalRouter is a secondary layout algorithm that can be used to arrange links after an initial node arrangement has already been applied. The orthogonal layout is useful when there are much more links than nodes in a graph. The algorithm strives to achieve the following criteria, while preserving as much of the initial node configuration as possible.

  • links must not overlap;
  • only vertical and horizontal routing lines are used;
  • graph routing is performed with respect to the specified main layout direction;
  • links crossings are minimized;
  • bends are minimized;

To arrange a diagram, create an OrthogonalRouter instance, set its properties and call the Arrange method.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.OrthogonalRouter

See Also

OrthogonalRouter Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Members

OrthogonalRouter Members
Constructors Properties Methods
[image]

Implements an orthogonal link routing algorithm.

The following tables list the members exposed by the OrthogonalRouter type.

Public Constructors

Name | Description
OrthogonalRouter | Initializes a new instance of the OrthogonalRouter class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendDistance | Gets or sets how far from its adjacent node a link should bend.
Direction | Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
PutEndPointsAtNodeBorders | Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Constructor

OrthogonalRouter Constructor
[image]

Initializes a new instance of the OrthogonalRouter class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public OrthogonalRouter ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter Properties

OrthogonalRouter Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendDistance | Gets or sets how far from its adjacent node a link should bend.
Direction | Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.
EndOrientation | Gets or sets the desired orientation of the last segments of routed links.
GridSize | Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayerDistance | Gets or sets the desired distance between layer axis lines.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between adjacent nodes in a layer.
Orientation | Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
PutEndPointsAtNodeBorders | Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
StartOrientation | Gets or sets the desired orientation of the first segments of routed links.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.BendDistance Property

OrthogonalRouter.BendDistance Property
[image]

Gets or sets how far from its adjacent node a link should bend.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BendDistance { get; set; }

Visual Basic [image] Copy Code

Public Property BendDistance As Double

Property Value

A double value specifying the distance from a link's first bend to its adjacent node. The default is 0, specifying that the algorithm should automatically choose a value for this parameter.

Remarks

This should be a value between 0 and 1, specifying a distance proportional to the node size.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.DefaultMarginValue Property

OrthogonalRouter.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(10, 10).

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Direction Property

OrthogonalRouter.Direction Property
[image]

Gets or sets the direction of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration.

Remarks

This value is assigned to the Direction property of the base LayeredLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.EndOrientation Property

OrthogonalRouter.EndOrientation Property
[image]

Gets or sets the desired orientation of the last segments of routed links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation EndOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property EndOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

If this property is set to Horizontal, links will end at the left or right sides of nodes. If set to Vertical, links will end at the top or bottom sides.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.GridSize Property

OrthogonalRouter.GridSize Property
[image]

Gets or sets the distance between adjacent grid points when BaseLayout is set to Grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

A double value.

Remarks

This value is assigned to the GridSize property of the base GridLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.LayerDistance Property

OrthogonalRouter.LayerDistance Property
[image]

Gets or sets the desired distance between layer axis lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LayerDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LayerDistance As Double

Property Value

A double value.

Remarks

Gets or sets the distance between layers when BaseLayout is set to Layered or Cascading.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Name Property

OrthogonalRouter.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Orthogonal router".

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.NodeDistance Property

OrthogonalRouter.NodeDistance Property
[image]

Gets or sets the desired distance between adjacent nodes in a layer.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value.

Remarks

Gets or sets the distance between nodes in the same layer when BaseLayout is set to Layered or Cascading.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.Orientation Property

OrthogonalRouter.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram when BaseLayout is set to Layered.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration.

Remarks

This value is assigned to the Orientation property of the base LayeredLayout.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.PutEndPointsAtNodeBorders Property

OrthogonalRouter.PutEndPointsAtNodeBorders Property
[image]

Gets or sets a value indicating whether the end points of a link should be placed at the outlines of the nodes connected by that link.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool PutEndPointsAtNodeBorders { get; set; }

Visual Basic [image] Copy Code

Public Property PutEndPointsAtNodeBorders As Boolean

Property Value

A boolean value.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.RandomSeed Property

OrthogonalRouter.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

An integer value.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.OrthogonalRouter.StartOrientation Property

OrthogonalRouter.StartOrientation Property
[image]

Gets or sets the desired orientation of the first segments of routed links.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation StartOrientation { get; set; }

Visual Basic [image] Copy Code

Public Property StartOrientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Auto.

Remarks

If this property is set to Horizontal, links will end at the left or right sides of nodes. If set to Vertical, links will end at the top or bottom sides.

See Also

OrthogonalRouter Members
OrthogonalRouter Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Class

SpringLayout Class
Remarks See Also
[image]

Implements the Spring-Embedder graph layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SpringLayout : Layout

Visual Basic [image] Copy Code

Public Class SpringLayout
Inherits Layout

Remarks

Spring-Embedder produces layouts having uniform distribution of nodes by simulating a physical system in which nodes repulse each other and the links between them act as confining springs. Nodes are moved around in an iterative process. The forces that act on a node are calculated, taking in account the positions of surrounding nodes and links from the previous iteration.

To apply this layout to a diagram, call the Arrange method of a SpringLayout instance. Arrange lays out all subgraphs in a diagram, unless the Root property is set.

If the LayoutTraits value associated with a node through SpringLayoutTraits.Frozen is true, SpringLayout considers the repulsion forces exerted by the node on other nodes, but ignores forces acting on the node and keeps it in place.

The final appearance of arranged graphs depends mostly on the values of EnableClusters and NodeDistance properties that specify how nodes are distributed by the layout routine. Enabling the MinimizeCrossings property helps to decrease the number of link crossings, though that makes the algorithm run somewhat slower.

The layout routine runs as much iterations as set in IterationCount, calculating better node positions at each step. When that stage of the algorithm completes, if Anchoring is enabled, link ends are aligned to nodes' anchor points.

The Spring-Embedder layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.SpringLayout

See Also

SpringLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Members

SpringLayout Members
Constructors Properties Methods
[image]

Implements the Spring-Embedder graph layout algorithm.

The following tables list the members exposed by the SpringLayout type.

Public Constructors

Name | Description
SpringLayout | Overloaded. Initializes a new instance of the SpringLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableClusters | Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
IterationCount | Gets or sets for how many iterations to run the layout routine.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutMethod | Specifies what energy model to use for the simulation.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MinimizeCrossings | Gets or sets a value indicating whether crossing minimization mode is enabled.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between nodes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
RepulsionFactor | Gets or sets the multiplier applied to repulsion forces between nodes.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
Stretch | Gets or sets the link stretch factor.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution.
Iterate | Runs one or more layout iterations.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor

SpringLayout Constructor
[image]

Initializes a new instance of the SpringLayout class.

Overload List

Name | Description
SpringLayout () | Initializes a new instance of the SpringLayout class with the default settings.
SpringLayout (Int32, Double, Boolean) | Initializes a new instance of the SpringLayout class with the specified settings.
SpringLayout (Int32, Double, Boolean, Boolean) | Initializes a new instance of the SpringLayout class with the specified settings.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor ()

SpringLayout Constructor ()
See Also
[image]

Initializes a new instance of the SpringLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor (Int32, Double, Boolean)

SpringLayout Constructor (Int32, Double, Boolean)
See Also
[image]

Initializes a new instance of the SpringLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayout (
int iterationCount,
double nodeDistance,
bool minimizeCrossings
)

Visual Basic [image] Copy Code

Public New ( _
iterationCount As Integer, _
nodeDistance As Double, _
minimizeCrossings As Boolean _
)

Parameters

iterationCount

The number of iterations to perform.

nodeDistance

The distance between nodes.

minimizeCrossings

Specifies whether to try to minimize crossings while layouting.

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Constructor (Int32, Double, Boolean, Boolean)

SpringLayout Constructor (Int32, Double, Boolean, Boolean)
See Also
[image]

Initializes a new instance of the SpringLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayout (
int iterationCount,
double nodeDistance,
bool minimizeCrossings,
bool keepGroupLayout
)

Visual Basic [image] Copy Code

Public New ( _
iterationCount As Integer, _
nodeDistance As Double, _
minimizeCrossings As Boolean, _
keepGroupLayout As Boolean _
)

Parameters

iterationCount

The number of iterations to perform.

nodeDistance

The distance between nodes.

minimizeCrossings

Specifies whether to try to minimize crossings while layouting.

keepGroupLayout

Specifies whether to keep the relative position of grouped items.

See Also

SpringLayout Constructor Overload List
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Methods

SpringLayout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
BeginArrange | Initializes the layout object for a step-by-step execution.
EndArrange | Completes the step-by-step execution.
Iterate | Runs one or more layout iterations.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.BeginArrange Method

SpringLayout.BeginArrange Method
[image]

Initializes the layout object for a step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BeginArrange (
Diagram diagram,
DiagramItemCollection items
)

Visual Basic [image] Copy Code

Public Function BeginArrange( _
diagram As Diagram, _
items As DiagramItemCollection _
) As Boolean

Parameters

diagram

The Diagram that is arranged.

items

A collection of nodes and links from diagram that define the subgraph to arrange.

Return Value

true if the layout object has been initialized successfully; otherwise, false.

Remarks

You can use this method together with Iterate and EndArrange to display an animation of the layout process. To run all iterations of the process at once and display just the end result, call Arrange.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.EndArrange Method

SpringLayout.EndArrange Method
[image]

Completes the step-by-step execution.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void EndArrange ()

Visual Basic [image] Copy Code

Public Sub EndArrange ()

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Iterate Method

SpringLayout.Iterate Method
[image]

Runs one or more layout iterations.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void Iterate (
int iterationFrom,
int iterationTo
)

Visual Basic [image] Copy Code

Public Sub Iterate( _
iterationFrom As Integer, _
iterationTo As Integer _
)

Parameters

iterationFrom

Specifies from which iteration to start.

iterationTo

Specifies at which iteration to stop.

Remarks

Use this method to create an animation of the layout process, for example, by calling it from a timer. Call BeginArrange to prepare the layout object for use of Iterate, and call EndArrange when done. Each call to Iterate starts from the iteration next to the one where the previous call has stopped.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout Properties

SpringLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
EnableClusters | Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
IterationCount | Gets or sets for how many iterations to run the layout routine.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the size of the layout area.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutMethod | Specifies what energy model to use for the simulation.
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LinkType | Gets or sets the appearance of the links in the final layout.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MinimizeCrossings | Gets or sets a value indicating whether crossing minimization mode is enabled.
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the desired distance between nodes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
Randomize | Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.
RandomSeed | Gets or sets the randomization seed to use for generating random node positions.
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
RepulsionFactor | Gets or sets the multiplier applied to repulsion forces between nodes.
Root | Gets or sets a node indicating which subgraph of the diagram must be laid out.
SplitGraph | Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.
Stretch | Gets or sets the link stretch factor.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.DefaultMarginValue Property

SpringLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.EnableClusters Property

SpringLayout.EnableClusters Property
[image]

Gets or sets a value indicating whether to enable allocation of nodes to distinct clusters.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableClusters { get; set; }

Visual Basic [image] Copy Code

Public Property EnableClusters As Boolean

Property Value

true to detect and process node clusters; otherwise, false. The default is false.

Remarks

If enabled, the SpringLayout algorithm detects node clusters and places them at distinct positions. Each cluster consists of a center node surrounded by several local nodes. Clusters might be connected with other clusters via their center nodes. Best-looking results are achieved when there aren't links between the local nodes in a cluster.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.IterationCount Property

SpringLayout.IterationCount Property
[image]

Gets or sets for how many iterations to run the layout routine.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int IterationCount { get; set; }

Visual Basic [image] Copy Code

Public Property IterationCount As Integer

Property Value

An integer value specifying the number of iterations. The default is 200.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.LayoutArea Property

SpringLayout.LayoutArea Property
[image]

Gets or sets the size of the layout area.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Rect LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As Rect

Property Value

A Rectangle representing the boundaries of the layout area. The default is an empty rectangle.

Remarks

If the layout area is not explicitly set, the algorithm will choose one suitable for the graph size.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.LayoutMethod Property

SpringLayout.LayoutMethod Property
[image]

Specifies what energy model to use for the simulation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayoutMethod LayoutMethod { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutMethod As SpringLayoutMethod

Property Value

A member of the SpringLayoutMethod enumeration. The default value is FruchtermanReingold.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.LinkType Property

SpringLayout.LinkType Property
[image]

Gets or sets the appearance of the links in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SpringLayoutLinkType LinkType { get; set; }

Visual Basic [image] Copy Code

Public Property LinkType As SpringLayoutLinkType

Property Value

A member of the SpringLayoutLinkType enumeration. The default value is Straight.

Remarks

If this property is set to Rounded, the layout method sets the links' Shape to Bezier and simulates repulsion forces exerted by their intermediate control points. The Rounded option produces better results when LayoutMethod is set to Classic.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.MinimizeCrossings Property

SpringLayout.MinimizeCrossings Property
[image]

Gets or sets a value indicating whether crossing minimization mode is enabled.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool MinimizeCrossings { get; set; }

Visual Basic [image] Copy Code

Public Property MinimizeCrossings As Boolean

Property Value

true to attempt crossing minimization; otherwise, false. The default is true.

Remarks

If enabled, the algorithm tries to decrease number of crossing links. For better results, use greater IterationCount.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Name Property

SpringLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Spring layout".

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.NodeDistance Property

SpringLayout.NodeDistance Property
[image]

Gets or sets the desired distance between nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between nodes. The default is 30.

Remarks

The final distance between connected nodes is determined by multiplying the Weight of the link that connects them by the value of NodeDistance.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Randomize Property

SpringLayout.Randomize Property
[image]

Gets or sets a value indicating whether nodes should be placed at random positions when the layout routine starts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Randomize { get; set; }

Visual Basic [image] Copy Code

Public Property Randomize As Boolean

Property Value

true to start with random node positions, otherwise false. The default value is false.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.RandomSeed Property

SpringLayout.RandomSeed Property
[image]

Gets or sets the randomization seed to use for generating random node positions.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int RandomSeed { get; set; }

Visual Basic [image] Copy Code

Public Property RandomSeed As Integer

Property Value

An integer value passed as a seed to the random number generator. The default value is 0.

Remarks

If set to 0, SpringLayout uses the current time as a seed value. Set a value greater than 0 to use a fixed seed. Random numbers are generated when nodes are at the same initial position or when Randomize is enabled. Using a fixed seed helps producing consistent layouts at each run of the Arrange method.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.RepulsionFactor Property

SpringLayout.RepulsionFactor Property
[image]

Gets or sets the multiplier applied to repulsion forces between nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double RepulsionFactor { get; set; }

Visual Basic [image] Copy Code

Public Property RepulsionFactor As Double

Property Value

A double value specifying the repulsion factor. The default value is 150.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Root Property

SpringLayout.Root Property
[image]

Gets or sets a node indicating which subgraph of the diagram must be laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class. The default is a null reference.

Remarks

All links and nodes that can be reached from the root by following recursively its links from a graph. If the root is specified, only the graph which it defines is laid out by Arrange.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.SplitGraph Property

SpringLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether to split the graph to its interconnected subgraphs and arrange the subgraphs independently or arrange the graph as a whole.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is false.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area. If a Root node is specified and SplitGraph is true, only the graph that contains the root node will be arranged.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayout.Stretch Property

SpringLayout.Stretch Property
[image]

Gets or sets the link stretch factor.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Stretch { get; set; }

Visual Basic [image] Copy Code

Public Property Stretch As Double

Property Value

A double value specifying the stretch factor used by the spring layout.

See Also

SpringLayout Members
SpringLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SpringLayoutLinkType Enumeration

SpringLayoutLinkType Enumeration
[image]

Specifies the style of the diagram links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SpringLayoutLinkType

Visual Basic [image] Copy Code

Public Enum SpringLayoutLinkType

Members

Member name | Description
Rounded | Indicates Bezier links with a single segment.
Straight | Indicates straight links with a single segment.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Class

SwimlaneLayout Class
Remarks See Also
[image]

Implements an algorithm which arranges nodes in lanes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class SwimlaneLayout : Layout

Visual Basic [image] Copy Code

Public Class SwimlaneLayout
Inherits Layout

Remarks

This layout algorithm can be used to arrange process diagrams in which nodes representing activities are placed in swimlanes representing resources. The index of the resource allocated to an activity should be assigned to the corresponding node's LayoutTraits[SwimlaneLayoutTraits.Lane].

By default, the algorithm works with the diagram's LaneGrid, but its SwimlaneGrid property can be set to any class that implements ISwimlaneGrid. This allows applying the layout to a custom-drawn grid rendered through the DrawBackground event, or one composed of locked background nodes.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.SwimlaneLayout

See Also

SwimlaneLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Members

SwimlaneLayout Members
Constructors Properties Methods
[image]

Implements an algorithm which arranges nodes in lanes.

The following tables list the members exposed by the SwimlaneLayout type.

Public Constructors

Name | Description
SwimlaneLayout | Initializes a new instance of the SwimlaneLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
CollapseEmptyLanes | Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.
CompactNodes | Gets or sets a value indicating whether the nodes within individual lanes are compacted.
CustomSortOrder | Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.
Direction | Gets or sets the direction of the arranged diagram.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepLaneSizes | Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.
LaneDistance | Gets or sets the spacing between adjacent lanes in the final layout.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the spacing between adjacent nodes within a lane in the final layout.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SwimlaneGrid | Gets or sets the object through which the layout can manipulate the swimlane grid.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Constructor

SwimlaneLayout Constructor
[image]

Initializes a new instance of the SwimlaneLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public SwimlaneLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout Properties

SwimlaneLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
CollapseEmptyLanes | Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.
CompactNodes | Gets or sets a value indicating whether the nodes within individual lanes are compacted.
CustomSortOrder | Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.
Direction | Gets or sets the direction of the arranged diagram.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepLaneSizes | Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.
LaneDistance | Gets or sets the spacing between adjacent lanes in the final layout.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the spacing between adjacent nodes within a lane in the final layout.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SwimlaneGrid | Gets or sets the object through which the layout can manipulate the swimlane grid.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.CollapseEmptyLanes Property

SwimlaneLayout.CollapseEmptyLanes Property
[image]

Get or sets a value indicating whether lanes without associated nodes will shrink to zero size. By default, empty lanes will have size equal to LaneDistance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CollapseEmptyLanes { get; set; }

Visual Basic [image] Copy Code

Public Property CollapseEmptyLanes As Boolean

Property Value

true to collapse empty lanes, otherwise false. The default value is false.

Remarks

To be able to shrink the lanes of a LaneGrid to zero size, the MinHeaderSize property of the lane grid must be set to an appropriate value.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.CompactNodes Property

SwimlaneLayout.CompactNodes Property
[image]

Gets or sets a value indicating whether the nodes within individual lanes are compacted.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CompactNodes { get; set; }

Visual Basic [image] Copy Code

Public Property CompactNodes As Boolean

Property Value

true to compact nodes, otherwise false. The default value is true.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.CustomSortOrder Property

SwimlaneLayout.CustomSortOrder Property
[image]

Gets or sets a value indicating whether the nodes in a lane should be arranged according to the custom sort order specified through LayoutTraits.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CustomSortOrder { get; set; }

Visual Basic [image] Copy Code

Public Property CustomSortOrder As Boolean

Property Value

A boolean value.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.DefaultMarginValue Property

SwimlaneLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(20, 20).

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.Direction Property

SwimlaneLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default value is Straight.

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.KeepLaneSizes Property

SwimlaneLayout.KeepLaneSizes Property
[image]

Gets or sets a value indicating whether the layout will attempt to preserve the original sizes of the lanes in the supplied grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepLaneSizes { get; set; }

Visual Basic [image] Copy Code

Public Property KeepLaneSizes As Boolean

Property Value

true to preserve lane sizes, otherwise false. The default value is false.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.LaneDistance Property

SwimlaneLayout.LaneDistance Property
[image]

Gets or sets the spacing between adjacent lanes in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LaneDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LaneDistance As Double

Property Value

A double value specifying the distance between swimlanes. The default value is 20.

Remarks

For each pair of swimlanes, this value specifies the distance between the bottommost node border from the upper swimlane and the topmost node border from the lower swimlane.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.Name Property

SwimlaneLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Swimlane layout".

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.NodeDistance Property

SwimlaneLayout.NodeDistance Property
[image]

Gets or sets the spacing between adjacent nodes within a lane in the final layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between adjacent nodes in the same swimlane. The default is 25.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.Orientation Property

SwimlaneLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Horizontal.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.SwimlaneLayout.SwimlaneGrid Property

SwimlaneLayout.SwimlaneGrid Property
[image]

Gets or sets the object through which the layout can manipulate the swimlane grid.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public ISwimlaneGrid SwimlaneGrid { get; set; }

Visual Basic [image] Copy Code

Public Property SwimlaneGrid As ISwimlaneGrid

Property Value

An instance of a class that implements the ISwimlaneGrid interface. The default is null (Nothing in VB.NET).

Remarks

If this is null at the time of layout, the layout will operate on the diagram's lane grid.

See Also

SwimlaneLayout Members
SwimlaneLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Class

TopologicalLayout Class
Remarks See Also
[image]

Implements a topological ordering.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TopologicalLayout : Layout

Visual Basic [image] Copy Code

Public Class TopologicalLayout
Inherits Layout

Remarks

The algorithm arranges nodes in a row or a column (depending on the value of the Orientation property) in such a way that there are as fewer back links as possible. The links connecting nonadjacent nodes are rendered as arcs. The links connecting adjacent nodes are rendered either as arcs or as straight lines, depending on the BendAdjacentLinks property. The amplitude of the link arcs is proportional to the distance between the connected nodes.

All forward links are rendered at one side of the nodes and all back links are rendered at the opposite side. Thus, all bent links follow the same rotation direction.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TopologicalLayout

See Also

TopologicalLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Members

TopologicalLayout Members
Constructors Properties Methods
[image]

Implements a topological ordering.

The following tables list the members exposed by the TopologicalLayout type.

Public Constructors

Name | Description
TopologicalLayout | Initializes a new instance of the TopologicalLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendAdjacentLinks | Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.
Direction | Gets or sets the direction of the arranged diagram.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between adjacent nodes in the diagram.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Constructor

TopologicalLayout Constructor
[image]

Initializes a new instance of the TopologicalLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TopologicalLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout Properties

TopologicalLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendAdjacentLinks | Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.
Direction | Gets or sets the direction of the arranged diagram.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets the distance between adjacent nodes in the diagram.
Orientation | Gets or sets the overall orientation of the arranged diagram.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
SplitGraph | Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.BendAdjacentLinks Property

TopologicalLayout.BendAdjacentLinks Property
[image]

Gets or sets a value indicating whether to bend links connecting adjacent nodes or draw them as straight lines.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BendAdjacentLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendAdjacentLinks As Boolean

Property Value

true to bend links connecting adjacent nodes; false, to draw them as straight lines. The default is false.

Remarks

This property applies only to forward link. Back links connecting adjacent nodes are always rendered as bent.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.DefaultMarginValue Property

TopologicalLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.Direction Property

TopologicalLayout.Direction Property
[image]

Gets or sets the direction of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Direction Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As Direction

Property Value

A member of the Direction enumeration. The default is Straight.

Remarks

If Orientation is set to Horizontal, Direction.Straight stands for "left to right" and Direction.Reversed for "right to left". If Orientation is set to Vertical, Direction.Straight stands for "top to bottom" and Direction.Reversed for "bottom to top".

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.MultipleGraphsPlacement Property

TopologicalLayout.MultipleGraphsPlacement Property
[image]

Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public new MultipleGraphsPlacement MultipleGraphsPlacement { get; set; }

Visual Basic [image] Copy Code

Public Shadows Property MultipleGraphsPlacement As MultipleGraphsPlacement

Property Value

A member of the MultipleGraphsPlacement enumeration. The default value is Vertical.

Remarks

If the diagram contains several unconnected subgraphs and SplitGraph is set to true, each of them is processed by the algorithm independently from the others. This property specifies how such subgraphs should be placed one relatively to another. The possible options are to arrange them in a row, in a column, or in such a way that the diagram covers a minimal area.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.Name Property

TopologicalLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Topological layout".

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.NodeDistance Property

TopologicalLayout.NodeDistance Property
[image]

Gets or sets the distance between adjacent nodes in the diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between adjacent nodes. The default is 20.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.Orientation Property

TopologicalLayout.Orientation Property
[image]

Gets or sets the overall orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default is Horizontal.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TopologicalLayout.SplitGraph Property

TopologicalLayout.SplitGraph Property
[image]

Gets or sets a value indicating whether unconnected subgraphs should be laid out independently from each other.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool SplitGraph { get; set; }

Visual Basic [image] Copy Code

Public Property SplitGraph As Boolean

Property Value

true if unconnected graphs in the diagram should be laid out independently; otherwise, false. The default is true.

Remarks

If this property is set to true, each independent graph in the diagram is laid out in its own layout area. Otherwise all subgraphs are arranged in the same layout area.

See Also

TopologicalLayout Members
TopologicalLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Class

TreeLayout Class
Remarks See Also
[image]

Implements several algorithms for arranging tree structures.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeLayout : Layout

Visual Basic [image] Copy Code

Public Class TreeLayout
Inherits Layout

Remarks

Set the Type property of a TreeLayout instance to select which tree layout algorithm to run, and call the Arrange method to apply the layout on a tree/subtree in the current diagram.

As long as the graph is a tree, the algorithm can find the root node automatically. You can override it by setting the Root property, e.g. in order to arrange only a selected branch of the tree. The distance between the root and the second level and between all subsequent levels can be set through the LevelDistance property. The distance between adjacent nodes in the same level is set through NodeDistance.

In addition to arranging the tree nodes, TreeLayout also sets the shape of links as set through its LinkStyle property. Anchoring specifies whether the links should be attached to the anchor points of tree nodes. Note that links that are not part of the tree are ignored, e.g. graph links that go in opposite direction of the general parent-to-child flow or cross-links that connect different tree branches. The tree layout algorithm produces best results if it can place link ends at arbitrary positions over nodes' outlines, that is, when using the Ignore value. If your application logic requires links to be always attached to anchor points, use the other two values. In such cases Reassign would yield better results. You can post-process such links after calling Arrange, for example by setting their ControlPoints coordinates or by calling their Route method.

By default, the order of child nodes arranged under a parent corresponds to the order of links in the parent's OutgoingLinks collection. The Balance property can be set to Preserve to keep the original geometric order of child nodes when arranging them under their parent. This can be used to arrange tree branches in a specific order by first placing them in increasing horizontal or vertical positions. Another possibility is to apply TreeLayout from NodeModified handler to let users rearrange the tree branches by dragging and dropping a node.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TreeLayout

See Also

TreeLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Members

TreeLayout Members
Constructors Properties Methods
[image]

Implements several algorithms for arranging tree structures.

The following tables list the members exposed by the TreeLayout type.

Public Constructors

Name | Description
TreeLayout | Overloaded. Initializes a new instance of the TreeLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
Balance | Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
CompactAssistants | Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
Direction | Gets or sets the tree direction.
EnableAssistants | Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets how much space to leave between levels of the tree.
LinkOffset | Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.
LinkStyle | Gets or sets a value indicating how links in the arranged tree should look.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets how much space to leave between nodes on the same level.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the root node of the tree.
StretchFactor | Gets or sets the stretch factor applied on Radial tree layouts.
Type | Gets or sets what type of tree layout to apply to the diagram.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
UpdateLink | Updates the style and position of the specified arrow.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor

TreeLayout Constructor
[image]

Initializes a new instance of the TreeLayout class.

Overload List

Name | Description
TreeLayout () | Initializes a new instance of the TreeLayout class with the default settings.
TreeLayout (DiagramNode) | Initializes a new instance of the TreeLayout class with the specified node as root.
TreeLayout (DiagramNode, TreeLayoutType) | Initializes a new instance of the TreeLayout class with the specified node as root and the specified type.
TreeLayout (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size) | Initializes a new instance of the TreeLayout class with the specified settings.
TreeLayout (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size, Boolean) | Initializes a new instance of the TreeLayout class.
TreeLayout (TreeLayoutType) | Initializes a new instance of the TreeLayout class with the specified type.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor ()

TreeLayout Constructor ()
See Also
[image]

Initializes a new instance of the TreeLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode)

TreeLayout Constructor (DiagramNode)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified node as root.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
DiagramNode root
)

Visual Basic [image] Copy Code

Public New ( _
root As DiagramNode _
)

Parameters

root

The root of the arranged tree.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode, TreeLayoutType)

TreeLayout Constructor (DiagramNode, TreeLayoutType)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified node as root and the specified type.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
DiagramNode root,
TreeLayoutType type
)

Visual Basic [image] Copy Code

Public New ( _
root As DiagramNode, _
type As TreeLayoutType _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size)

TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
DiagramNode root,
TreeLayoutType type,
bool reversedLinks,
TreeLayoutLinkType linkStyle,
TreeLayoutDirections direction,
double levelDistance,
double nodeDistance,
bool keepRootPosition,
Size margins
)

Visual Basic [image] Copy Code

Public New ( _
root As DiagramNode, _
type As TreeLayoutType, _
reversedLinks As Boolean, _
linkStyle As TreeLayoutLinkType, _
direction As TreeLayoutDirections, _
levelDistance As Double, _
nodeDistance As Double, _
keepRootPosition As Boolean, _
margins As Size _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

reversedLinks

Specifies whether the parent-to-child direction in the tree should be reversed, that is, from the end of the link towards its beginning.

linkStyle

The style of the links in the produced layout.

direction

The layout direction.

levelDistance

The distance between adjacent levels.

nodeDistance

The distance between adjacent nodes.

keepRootPosition

Specifies whether to keep the position of the tree root.

margins

The margin between the produced tree and the left side of the diagram bounding rectangle.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size, Boolean)

TreeLayout Constructor (DiagramNode, TreeLayoutType, Boolean, TreeLayoutLinkType, TreeLayoutDirections, Double, Double, Boolean, Size, Boolean)
See Also
[image]

Initializes a new instance of the TreeLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
DiagramNode root,
TreeLayoutType type,
bool reversedLinks,
TreeLayoutLinkType linkStyle,
TreeLayoutDirections direction,
double levelDistance,
double nodeDistance,
bool keepRootPosition,
Size margins,
bool keepGroupLayout
)

Visual Basic [image] Copy Code

Public New ( _
root As DiagramNode, _
type As TreeLayoutType, _
reversedLinks As Boolean, _
linkStyle As TreeLayoutLinkType, _
direction As TreeLayoutDirections, _
levelDistance As Double, _
nodeDistance As Double, _
keepRootPosition As Boolean, _
margins As Size, _
keepGroupLayout As Boolean _
)

Parameters

root

The root of the arranged tree.

type

The type of the tree layout.

reversedLinks

Specifies whether the parent-to-child direction in the tree should be reversed, that is, from the end of the link towards its beginning.

linkStyle

The style of the links in the produced layout.

direction

The layout direction.

levelDistance

The distance between adjacent levels.

nodeDistance

The distance between adjacent nodes.

keepRootPosition

Specifies whether to keep the position of the tree root.

margins

The margin between the produced tree and the left side of the diagram bounding rectangle.

keepGroupLayout

Specifies whether to keep the relative position of grouped items.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Constructor (TreeLayoutType)

TreeLayout Constructor (TreeLayoutType)
See Also
[image]

Initializes a new instance of the TreeLayout class with the specified type.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayout (
TreeLayoutType type
)

Visual Basic [image] Copy Code

Public New ( _
type As TreeLayoutType _
)

Parameters

type

The type of the tree layout.

See Also

TreeLayout Constructor Overload List
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Methods

TreeLayout Methods
[image]

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)
UpdateLink | Updates the style and position of the specified arrow.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.UpdateLink Method

TreeLayout.UpdateLink Method
[image]

Updates the style and position of the specified arrow.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public void UpdateLink (
DiagramLink a,
bool ignoredDirection
)

Visual Basic [image] Copy Code

Public Sub UpdateLink( _
a As DiagramLink, _
ignoredDirection As Boolean _
)

Parameters

a

A DiagramLink that will be updated.

ignoredDirection

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout Properties

TreeLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
Balance | Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.
CompactAssistants | Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.
Direction | Gets or sets the tree direction.
EnableAssistants | Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
IgnoreLinkDirection | Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
KeepRootPosition | Gets or sets a value indicating whether to keep the root node at its original position.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
LevelDistance | Gets or sets how much space to leave between levels of the tree.
LinkOffset | Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.
LinkStyle | Gets or sets a value indicating how links in the arranged tree should look.
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
NodeDistance | Gets or sets how much space to leave between nodes on the same level.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
ReversedLinks | Gets or sets a value indicating the link direction that relates parent nodes to child nodes.
Root | Gets or sets the root node of the tree.
StretchFactor | Gets or sets the stretch factor applied on Radial tree layouts.
Type | Gets or sets what type of tree layout to apply to the diagram.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Balance Property

TreeLayout.Balance Property
[image]

Gets or sets a value indicating the ordering of the child nodes in order to produce layouts with custom balance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutBalance Balance { get; set; }

Visual Basic [image] Copy Code

Public Property Balance As TreeLayoutBalance

Property Value

A member of the TreeLayoutBalance enumeration. The default value is Original.

Remarks

The LeftHeavy, Original and RightHeavy values are considered when Type is set to HorizontalVertical. The Preserve and Reversed values are considered by all other tree layout types, and will lead to sorting tree branches by the original horizontal, vertical or angular positions of nodes.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.CompactAssistants Property

TreeLayout.CompactAssistants Property
[image]

Gets or sets a value indicating whether the "assistant" nodes on the same side of a single parent are arranged as close enough to each other as possible. Turning this off will force the nodes on one side to be aligned with their counterparts in the other and occasionally leaving space between adjacent branches.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool CompactAssistants { get; set; }

Visual Basic [image] Copy Code

Public Property CompactAssistants As Boolean

Property Value

A boolean value.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.DefaultMarginValue Property

TreeLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Direction Property

TreeLayout.Direction Property
[image]

Gets or sets the tree direction.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutDirections Direction { get; set; }

Visual Basic [image] Copy Code

Public Property Direction As TreeLayoutDirections

Property Value

A member of the TreeLayoutDirections enumeration.

Remarks

This property must be set to a combination of two TreeLayoutDirections members when using Type is HorizontalVertical.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.EnableAssistants Property

TreeLayout.EnableAssistants Property
[image]

Gets or sets a value indicating whether the "assistant" trait is regarded when performing the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool EnableAssistants { get; set; }

Visual Basic [image] Copy Code

Public Property EnableAssistants As Boolean

Property Value

true to enable assistant nodes, otherwise false; the default value is false.

Remarks

Enabling this property lets you create organizational charts as in MS office. To designate some nodes as assistants, assign true as a value for the TreeLayoutTraits.Assistant key in the node's LayoutTraits.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.IgnoreLinkDirection Property

TreeLayout.IgnoreLinkDirection Property
[image]

Gets or sets a value indicating whether the tree layout algorithm should ignore the direction of links when arranging a tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IgnoreLinkDirection { get; set; }

Visual Basic [image] Copy Code

Public Property IgnoreLinkDirection As Boolean

Property Value

true to ignore link direction; otherwise, false. The default is false.

Remarks

Parent-child direction is considered the one in which nodes go further from the root, instead that of the links. If IgnoreLinkDirection is set to true, you must explicitly specify the tree Root.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.KeepRootPosition Property

TreeLayout.KeepRootPosition Property
[image]

Gets or sets a value indicating whether to keep the root node at its original position.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool KeepRootPosition { get; set; }

Visual Basic [image] Copy Code

Public Property KeepRootPosition As Boolean

Property Value

true to keep the root position; otherwise, false.

Remarks

If the root position is not kept, that is, the value of this property is false, the entire tree is dispositioned after the layout is complete, according to the values of Margins.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LevelDistance Property

TreeLayout.LevelDistance Property
[image]

Gets or sets how much space to leave between levels of the tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LevelDistance { get; set; }

Visual Basic [image] Copy Code

Public Property LevelDistance As Double

Property Value

A double value specifying the distance between adjacent levels in the tree.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LinkOffset Property

TreeLayout.LinkOffset Property
[image]

Gets or sets the links' offset from the centers of the nodes. This property is applicable only for Centered tree layouts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double LinkOffset { get; set; }

Visual Basic [image] Copy Code

Public Property LinkOffset As Double

Property Value

A double value specifying offset of links from the parent node's center. The default value is 0.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.LinkStyle Property

TreeLayout.LinkStyle Property
[image]

Gets or sets a value indicating how links in the arranged tree should look.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutLinkType LinkStyle { get; set; }

Visual Basic [image] Copy Code

Public Property LinkStyle As TreeLayoutLinkType

Property Value

A member of the TreeLayoutLinkType enumeration.

Remarks

This property is ignored if Type is set to Radial.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Name Property

TreeLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Tree layout".

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.NodeDistance Property

TreeLayout.NodeDistance Property
[image]

Gets or sets how much space to leave between nodes on the same level.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeDistance As Double

Property Value

A double value specifying the distance between adjacent nodes.

Remarks

This property is ignored if Type is set to Radial.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.ReversedLinks Property

TreeLayout.ReversedLinks Property
[image]

Gets or sets a value indicating the link direction that relates parent nodes to child nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool ReversedLinks { get; set; }

Visual Basic [image] Copy Code

Public Property ReversedLinks As Boolean

Property Value

true to indicate reversed direction, that is, the parent node is the one the link points to; otherwise, false.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Root Property

TreeLayout.Root Property
[image]

Gets or sets the root node of the tree.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public DiagramNode Root { get; set; }

Visual Basic [image] Copy Code

Public Property Root As DiagramNode

Property Value

An instance of the DiagramNode class that represents the root node.

Remarks

If not set, MindFusion.Diagramming for .NET MAUI will try to find the root automatically. This root must be specified if IgnoreLinkDirection is set to true.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.StretchFactor Property

TreeLayout.StretchFactor Property
[image]

Gets or sets the stretch factor applied on Radial tree layouts.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double StretchFactor { get; set; }

Visual Basic [image] Copy Code

Public Property StretchFactor As Double

Property Value

A double value specifying the ratio between the horizontal and vertical radii of radial layout outlines. The default is 1.

Remarks

When applying a radial layout, node layers are laid out in concentric circles around the Root node. Stretching them by changing this property makes layers laid out in elliptic outlines.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayout.Type Property

TreeLayout.Type Property
[image]

Gets or sets what type of tree layout to apply to the diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeLayoutType Type { get; set; }

Visual Basic [image] Copy Code

Public Property Type As TreeLayoutType

Property Value

A member of the TreeLayoutType enumeration.

See Also

TreeLayout Members
TreeLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutBalance Enumeration

TreeLayoutBalance Enumeration
[image]

Specifies how to order child nodes in order to produce tree layouts with custom balance.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutBalance

Visual Basic [image] Copy Code

Public Enum TreeLayoutBalance

Members

Member name | Description
LeftHeavy | Indicates that the child nodes with most total children will be processed first, thus producing a left-heavy layout.
Original | Indicates that the child order should not be changed.
Preserve | Indicates that the layout will attempt to preserve the initial relative ordering of nodes.
Reversed | Indicates that the child order should be reversed.
RightHeavy | Indicates that the child nodes with least total children will be processed first, thus producing a right-heavy layout.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutDirections Enumeration

TreeLayoutDirections Enumeration
[image]

Specifies the direction of a tree layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutDirections

Visual Basic [image] Copy Code

Public Enum TreeLayoutDirections

Members

Member name | Description
BottomToTop | Indicates a bottom-to-top direction.
LeftToRight | Indicates a left-to-right direction.
RightToLeft | Indicates a right-to-left direction.
TopToBottom | Indicates a top-to-bottom direction.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutLinkType Enumeration

TreeLayoutLinkType Enumeration
[image]

Specifies the shape of the diagram links after they are laid out.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutLinkType

Visual Basic [image] Copy Code

Public Enum TreeLayoutLinkType

Members

Member name | Description
Cascading2 | Indicates cascading links with two segments.
Cascading3 | Indicates cascading links with three segments.
Rounded | Indicates Bezier links with a single segment.
Straight | Indicates straight links with a single segment.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeLayoutType Enumeration

TreeLayoutType Enumeration
[image]

Specifies the type of a tree layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutType

Visual Basic [image] Copy Code

Public Enum TreeLayoutType

Members

Member name | Description
Cascading | Indicates cascading tree layout.
Centered | Indicates centered tree layout.
HorizontalVertical | Indicates a Horizontal-Vertical binary tree layout.
Radial | Indicates radial tree layout.

See Also

MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Class

TreeMapLayout Class
Remarks See Also
[image]

Implements a tree map layout algorithm.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TreeMapLayout : Layout

Visual Basic [image] Copy Code

Public Class TreeMapLayout
Inherits Layout

Remarks

Tree maps represent hierarchies by nesting child nodes within their parents, where the areas of leaf nodes are proportional to their Weight values. Unlike other layout algorithms, TreeMapLayout expects hierarchies to be defined via grouping or containment, and will ignore any links in the diagram.

The diagram area covered by the topmost nodes in a hierarchy is specified via the LayoutArea property. By default, the layout tries to keep the ratio of node sides as close as possible to one. However this could make it hard to distinguish separate levels of the hierarchy. To alleviate that, set Squarify to false, and child nodes will be arranged either as a row or a column inside their parent node, alternating directions for each level. The drawback is that when Weight ratios differ greatly or nodes contain many children, some nodes could end up with very narrow rectangles.

The padding size between parent nodes and their outermost children is specified via the ContainerPadding property. The padding size between child nodes is specified via Padding.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TreeMapLayout

See Also

TreeMapLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Members

TreeMapLayout Members
Constructors Properties Methods
[image]

Implements a tree map layout algorithm.

The following tables list the members exposed by the TreeMapLayout type.

Public Constructors

Name | Description
TreeMapLayout | Initializes a new instance of the TreeMapLayout class with the default settings.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
ContainerPadding | Gets or sets the padding inside containers.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Padding | Gets or sets the distance between adjacent nodes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Squarify | Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Constructor

TreeMapLayout Constructor
[image]

Initializes a new instance of the TreeMapLayout class with the default settings.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TreeMapLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout Properties

TreeMapLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
ContainerPadding | Gets or sets the padding inside containers.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutArea | Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged diagram.
Padding | Gets or sets the distance between adjacent nodes.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)
Squarify | Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.ContainerPadding Property

TreeMapLayout.ContainerPadding Property
[image]

Gets or sets the padding inside containers.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double ContainerPadding { get; set; }

Visual Basic [image] Copy Code

Public Property ContainerPadding As Double

Property Value

A double value specifying the padding size between parent nodes and their outermost children. The default value is 0.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.DefaultMarginValue Property

TreeMapLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.LayoutArea Property

TreeMapLayout.LayoutArea Property
[image]

Gets or sets the rectangle in which the layout will try to arrange the nodes, or null, to use the diagram bounds.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Nullable<Rect> LayoutArea { get; set; }

Visual Basic [image] Copy Code

Public Property LayoutArea As Nullable(Of Rect)

Property Value

A Rectangle? specifying the area where topmost nodes in the hierarchy are laid out. The default value is null.

Remarks

If this property is not set, the algorithm uses the value of diagram's Bounds property as target layout rectangle.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.Name Property

TreeMapLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Tree map layout".

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.Orientation Property

TreeMapLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged diagram.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

Remarks

This value is used only when Squarify is set to false, and specifies the orientation of the topmost level of the hierarchy. The algorithm alternates the orientation of each subsequent level, arranging its nodes either in rows or columns.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.Padding Property

TreeMapLayout.Padding Property
[image]

Gets or sets the distance between adjacent nodes.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double Padding { get; set; }

Visual Basic [image] Copy Code

Public Property Padding As Double

Property Value

A double value specifying the padding size between sibling nodes. The default value is 1.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TreeMapLayout.Squarify Property

TreeMapLayout.Squarify Property
[image]

Gets or sets a value indicating whether the layout should attempt to keep the dimension ratio of the nodes closer to 1.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Squarify { get; set; }

Visual Basic [image] Copy Code

Public Property Squarify As Boolean

Property Value

true to keep the ratio of node sides as close as possible to one, or false otherwise. The default value is true.

Remarks

If set to false, each level of the hierarchy is arranged in rows or columns with same height/width, which might create very narrow rectangles when Weight values differ greatly or nodes have many children. The alternating orientation between levels however helps to distinguish between different levels in the hierarchy. The initial direction of nodes (in topmost level) depends on the value of Orientation.

See Also

TreeMapLayout Members
TreeMapLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Class

TriangularLayout Class
Remarks See Also
[image]

Performs triangular layout on simple, connected graphs.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class TriangularLayout : Layout

Visual Basic [image] Copy Code

Public Class TriangularLayout
Inherits Layout

Remarks

TriangularLayout places nodes on a virtual grid, such that if the source graph is planar, all links are guaranteed to have a single segment and not intersect. If the graph is not planar, its intersecting links can be optionally segmented and bended in order to improve readability. The layout method places the nodes from the external face on a triangle and recursively adds the rest of the nodes as vertices of internal triangles. As a result, it is very effective for near maximal-planar (a.k.a. triangular) graphs.

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Layout.Layout
MindFusion.Diagramming.Layout.TriangularLayout

See Also

TriangularLayout Members
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Members

TriangularLayout Members
Constructors Properties Methods
[image]

Performs triangular layout on simple, connected graphs.

The following tables list the members exposed by the TriangularLayout type.

Public Constructors

Name | Description
TriangularLayout | Initializes a new instance of the TriangularLayout class.

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendNonplanarLinks | Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.
GridSize | Gets or sets the size of the virtual grid the layout will place vertices on.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

Public Methods

Name | Description
Arrange | Overloaded. Applies the layout to a Diagram instance. (Inherited from Layout.)

See Also

TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Constructor

TriangularLayout Constructor
[image]

Initializes a new instance of the TriangularLayout class.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public TriangularLayout ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout Properties

TriangularLayout Properties
[image]

Public Properties

Name | Description
Anchoring | Gets or sets how to align links to the anchor points of nodes. (Inherited from Layout.)
BendNonplanarLinks | Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.
GridSize | Gets or sets the size of the virtual grid the layout will place vertices on.
GrowToFit | Gets or sets a value indicating whether the layout should increase the diagram bounds to fit the arranged content. (Inherited from Layout.)
KeepGroupLayout | Gets or sets a value indicating whether to treat each group of nodes as a single vertex in the arranged graph. (Inherited from Layout.)
LayoutLink | Gets or sets a delegate, which is invoked when the position of a link is changed by the layout. (Inherited from Layout.)
LayoutNode | Gets or sets a delegate, which is invoked when the position of a node is changed by the layout. (Inherited from Layout.)
Margins | Gets or sets the distance between the top-left corner of the smallest rectangle containing the arranged diagram and the top-left point of the document bounds. (Inherited from Layout.)
MultipleGraphsPlacement | Gets or sets a value indicating how multiple independent graphs in the diagram should be positioned relatively to each other. (Inherited from Layout.)
Name | Gets a user-friendly name of the layout.
Orientation | Gets or sets the orientation of the arranged graph.
Progress | Gets or sets the progress callback delegate. (Inherited from Layout.)
RepeatingLinksPadding | Specifies the padding distance between repeating links. (Inherited from Layout.)

Protected Properties

Name | Description
DefaultMarginValue | Gets the default value of the Margins property.

See Also

TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.BendNonplanarLinks Property

TriangularLayout.BendNonplanarLinks Property
[image]

Gets or sets a value indicating whether the intersecting links in a non-planar graphs will be segmented and bended to improve presentation.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool BendNonplanarLinks { get; set; }

Visual Basic [image] Copy Code

Public Property BendNonplanarLinks As Boolean

Property Value

true to bend links, otherwise false. The default value is false.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.DefaultMarginValue Property

TriangularLayout.DefaultMarginValue Property
[image]

Gets the default value of the Margins property.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected override Size DefaultMarginValue { get; }

Visual Basic [image] Copy Code

Protected Overrides ReadOnly Property DefaultMarginValue As Size

Property Value

Returns new Size(5, 5).

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.GridSize Property

TriangularLayout.GridSize Property
[image]

Gets or sets the size of the virtual grid the layout will place vertices on.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double GridSize { get; set; }

Visual Basic [image] Copy Code

Public Property GridSize As Double

Property Value

A double value. The default is 20.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.Name Property

TriangularLayout.Name Property
[image]

Gets a user-friendly name of the layout.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string Name { get; }

Visual Basic [image] Copy Code

Public Overrides ReadOnly Property Name As String

Property Value

Returns "Triangular layout".

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Layout.TriangularLayout.Orientation Property

TriangularLayout.Orientation Property
[image]

Gets or sets the orientation of the arranged graph.

Namespace: MindFusion.Diagramming.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Orientation Orientation { get; set; }

Visual Basic [image] Copy Code

Public Property Orientation As Orientation

Property Value

A member of the Orientation enumeration. The default value is Vertical.

See Also

TriangularLayout Members
TriangularLayout Class
MindFusion.Diagramming.Layout Namespace


MindFusion.Diagramming.Manipulators Namespace
Classes

Classes

Class | Description
Manipulator | Base class for flowchart manipulators, which are user interface elements attached to a diagram item. The user can perform various manipulations on objects through their attached manipulators.


MindFusion.Diagramming.Manipulators.Manipulator Class

Manipulator Class
[image]

Base class for flowchart manipulators, which are user interface elements attached to a diagram item. The user can perform various manipulations on objects through their attached manipulators.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract class Manipulator

Visual Basic [image] Copy Code

Public MustInherit Class Manipulator

Inheritance Hierarchy

System.Object
MindFusion.Diagramming.Manipulators.Manipulator

See Also

Manipulator Members
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator Members

Manipulator Members
Constructors Properties Methods
[image]

Base class for flowchart manipulators, which are user interface elements attached to a diagram item. The user can perform various manipulations on objects through their attached manipulators.

The following tables list the members exposed by the Manipulator type.

Protected Constructors

Name | Description
Manipulator | Initializes a new instance of the Manipulator class.

Public Properties

Name | Description
Focusable | Gets or sets a value indicating whether this manipulator can receive input focus.
IsEnabled | Gets or sets a value indicating whether this manipulator is enabled and can be interacted with.

Protected Properties

Name | Description
IsFocused | Gets or sets a value indicating whether the manipulator currently holds the input focus.
Item | Gets or sets the item this manipulator is attached to.

Public Methods

Name | Description
AddToRepaintRect | Adds the manipulator's repaint area to the specified rectangle.
Draw | Renders the manipulator.
DrawsInLocalCoordinates | Returns whether the manipulator object draws in local or global coordinates.
HitTest | Overloaded. Checks whether the specified point lies within the manipulator.
NeedsDragMessages | Returns whether the manipulator object needs to track touch events.
OnClick | Tests if the specified point lies within the dedicated area and performs the appropriate manipulator action.
OnGotFocus | Called when the manipulator receives input focus.
OnKeyPress | Called when a character key is pressed when this manipulator has the input focus.
OnLostFocus | Called when the manipulator loses the input focus.
OnTouchDown | Called when the user touches over this manipulator.
OnTouchMove | Called when the drags while this manipulator tracks touch events.
OnTouchUp | Called when the releases a touch while this manipulator tracks touch events.
OnZoomChanged | Called when the zoom factor in the diagram containing the manipulator has changed.
SupportClipping | Gets a value indicating whether the manipulator supports clipping.

Protected Methods

Name | Description
OnIsEnabledChanged | Called when IsEnabled changes.

See Also

Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator Constructor

Manipulator Constructor
[image]

Initializes a new instance of the Manipulator class.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected Manipulator (
DiagramItem item
)

Visual Basic [image] Copy Code

Protected New ( _
item As DiagramItem _
)

Parameters

item

A reference to the parent item.

See Also

Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator Methods

Manipulator Methods
[image]

Public Methods

Name | Description
AddToRepaintRect | Adds the manipulator's repaint area to the specified rectangle.
Draw | Renders the manipulator.
DrawsInLocalCoordinates | Returns whether the manipulator object draws in local or global coordinates.
HitTest | Overloaded. Checks whether the specified point lies within the manipulator.
NeedsDragMessages | Returns whether the manipulator object needs to track touch events.
OnClick | Tests if the specified point lies within the dedicated area and performs the appropriate manipulator action.
OnGotFocus | Called when the manipulator receives input focus.
OnKeyPress | Called when a character key is pressed when this manipulator has the input focus.
OnLostFocus | Called when the manipulator loses the input focus.
OnTouchDown | Called when the user touches over this manipulator.
OnTouchMove | Called when the drags while this manipulator tracks touch events.
OnTouchUp | Called when the releases a touch while this manipulator tracks touch events.
OnZoomChanged | Called when the zoom factor in the diagram containing the manipulator has changed.
SupportClipping | Gets a value indicating whether the manipulator supports clipping.

Protected Methods

Name | Description
OnIsEnabledChanged | Called when IsEnabled changes.

See Also

Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.AddToRepaintRect Method

Manipulator.AddToRepaintRect Method
[image]

Adds the manipulator's repaint area to the specified rectangle.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void AddToRepaintRect (
ref Rect rect
)

Visual Basic [image] Copy Code

Public MustOverride Sub AddToRepaintRect( _
ByRef rect As Rect _
)

Parameters

rect

The accumulated rectangle representing the area to invalidate.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.Draw Method

Manipulator.Draw Method
[image]

Renders the manipulator.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void Draw (
IGraphics graphics
)

Visual Basic [image] Copy Code

Public MustOverride Sub Draw( _
graphics As IGraphics _
)

Parameters

graphics

The drawing target.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.DrawsInLocalCoordinates Method

Manipulator.DrawsInLocalCoordinates Method
[image]

Returns whether the manipulator object draws in local or global coordinates.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool DrawsInLocalCoordinates ()

Visual Basic [image] Copy Code

Public Overridable Function DrawsInLocalCoordinates () As Boolean

Return Value

true if drawn in local coordinates, otherwise, false.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.HitTest Method

Manipulator.HitTest Method
[image]

Checks whether the specified point lies within the manipulator.

Overload List

Name | Description
Manipulator.HitTest (Point, Double) | Checks whether the specified point lies within the manipulator.
Manipulator.HitTest (Point, Double, Double@) | Checks whether the specified point lies within the manipulator.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.HitTest Method (Point, Double)

Manipulator.HitTest Method (Point, Double)
See Also
[image]

Checks whether the specified point lies within the manipulator.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool HitTest (
Point pt,
double radius
)

Visual Basic [image] Copy Code

Public Function HitTest( _
pt As Point, _
radius As Double _
) As Boolean

Parameters

pt

The point to test.

radius

A hit-testing threshold.

Return Value

true if the point is within the manipulator and the manipulator performed an action; otherwise, false.

See Also

HitTest Method Overload List
Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.HitTest Method (Point, Double, Double@)

Manipulator.HitTest Method (Point, Double, Double@)
See Also
[image]

Checks whether the specified point lies within the manipulator.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool HitTest (
Point pt,
double radius,
out double distance
)

Visual Basic [image] Copy Code

Public MustOverride Function HitTest( _
pt As Point, _
radius As Double, _
<System.Runtime.InteropServices.Out()> ByRef distance As Double _
) As Boolean

Parameters

pt

The point to test.

radius

A hit-testing threshold.

distance

Return Value

true if the point is within the manipulator and the manipulator performed an action; otherwise, false.

See Also

HitTest Method Overload List
Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.NeedsDragMessages Method

Manipulator.NeedsDragMessages Method
[image]

Returns whether the manipulator object needs to track touch events.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool NeedsDragMessages ()

Visual Basic [image] Copy Code

Public Overridable Function NeedsDragMessages () As Boolean

Return Value

true to track touch events; otherwise, false.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.OnClick Method

Manipulator.OnClick Method
[image]

Tests if the specified point lies within the dedicated area and performs the appropriate manipulator action.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract void OnClick (
Point point,
double radius
)

Visual Basic [image] Copy Code

Public MustOverride Sub OnClick( _
point As Point, _
radius As Double _
)

Parameters

point

radius

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.OnGotFocus Method

Manipulator.OnGotFocus Method
[image]

Called when the manipulator receives input focus.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnGotFocus ()

Visual Basic [image] Copy Code

Public Overridable Sub OnGotFocus ()

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.OnIsEnabledChanged Method

Manipulator.OnIsEnabledChanged Method
[image]

Called when IsEnabled changes.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected virtual void OnIsEnabledChanged ()

Visual Basic [image] Copy Code

Protected Overridable Sub OnIsEnabledChanged ()

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.OnKeyPress Method

Manipulator.OnKeyPress Method
[image]

Called when a character key is pressed when this manipulator has the input focus.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnKeyPress (
char keyChar
)

Visual Basic [image] Copy Code

Public Overridable Sub OnKeyPress( _
keyChar As Char _
)

Parameters

keyChar

The character representing the pressed key.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.OnLostFocus Method

Manipulator.OnLostFocus Method
[image]

Called when the manipulator loses the input focus.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnLostFocus ()

Visual Basic [image] Copy Code

Public Overridable Sub OnLostFocus ()

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.OnTouchDown Method

Manipulator.OnTouchDown Method
[image]

Called when the user touches over this manipulator.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnTouchDown (
Point position,
double radius
)

Visual Basic [image] Copy Code

Public Overridable Sub OnTouchDown( _
position As Point, _
radius As Double _
)

Parameters

position

A Point instance that specifies the touch position.

radius

A hit-testing threshold.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.OnTouchMove Method

Manipulator.OnTouchMove Method
[image]

Called when the drags while this manipulator tracks touch events.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnTouchMove (
Point position,
double radius
)

Visual Basic [image] Copy Code

Public Overridable Sub OnTouchMove( _
position As Point, _
radius As Double _
)

Parameters

position

A Point instance that specifies the touch position.

radius

A hit-testing threshold.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.OnTouchUp Method

Manipulator.OnTouchUp Method
[image]

Called when the releases a touch while this manipulator tracks touch events.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnTouchUp (
Point position,
double radius
)

Visual Basic [image] Copy Code

Public Overridable Sub OnTouchUp( _
position As Point, _
radius As Double _
)

Parameters

position

A Point instance that specifies the touch position.

radius

A hit-testing threshold.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.OnZoomChanged Method

Manipulator.OnZoomChanged Method
[image]

Called when the zoom factor in the diagram containing the manipulator has changed.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual void OnZoomChanged ()

Visual Basic [image] Copy Code

Public Overridable Sub OnZoomChanged ()

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.SupportClipping Method

Manipulator.SupportClipping Method
[image]

Gets a value indicating whether the manipulator supports clipping.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public abstract bool SupportClipping ()

Visual Basic [image] Copy Code

Public MustOverride Function SupportClipping () As Boolean

Return Value

true if the manipulator is clipped by its item's outline; otherwise, false.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator Properties

Manipulator Properties
[image]

Public Properties

Name | Description
Focusable | Gets or sets a value indicating whether this manipulator can receive input focus.
IsEnabled | Gets or sets a value indicating whether this manipulator is enabled and can be interacted with.

Protected Properties

Name | Description
IsFocused | Gets or sets a value indicating whether the manipulator currently holds the input focus.
Item | Gets or sets the item this manipulator is attached to.

See Also

Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.Focusable Property

Manipulator.Focusable Property
[image]

Gets or sets a value indicating whether this manipulator can receive input focus.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool Focusable { get; set; }

Visual Basic [image] Copy Code

Public Property Focusable As Boolean

Property Value

true if the manipulator can receive input focus; otherwise, false.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.IsEnabled Property

Manipulator.IsEnabled Property
[image]

Gets or sets a value indicating whether this manipulator is enabled and can be interacted with.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool IsEnabled { get; set; }

Visual Basic [image] Copy Code

Public Property IsEnabled As Boolean

Property Value

true if the manipulator is enabled; otherwise, false.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.IsFocused Property

Manipulator.IsFocused Property
[image]

Gets or sets a value indicating whether the manipulator currently holds the input focus.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected bool IsFocused { get; set; }

Visual Basic [image] Copy Code

Protected Property IsFocused As Boolean

Property Value

true if the manipulator is focused; otherwise, false.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Diagramming.Manipulators.Manipulator.Item Property

Manipulator.Item Property
[image]

Gets or sets the item this manipulator is attached to.

Namespace: MindFusion.Diagramming.Manipulators
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

protected DiagramItem Item { get; }

Visual Basic [image] Copy Code

Protected ReadOnly Property Item As DiagramItem

Property Value

An instance of an DiagramItem-derived class.

See Also

Manipulator Members
Manipulator Class
MindFusion.Diagramming.Manipulators Namespace


MindFusion.Drawing Namespace
Classes Interfaces Enumerations

Classes

Class | Description
Brush | Represents an object that can be used to fill the interiors of geometric shapes.
Brushes | Provides a set of predefined brushes.
CardinalSpline |
Colors | Provides a set of predefined colors.
GraphicsFactory | A factory class for various graphical objects.
HatchBrush | Represents a brush that fills the interiors of objects with a hatch pattern.
LinearGradientBrush | Represents a brush that fills the interiors of objects with a linear gradient.
PathGradientBrush | Encapsulates a Brush object that fills the interior of an IGraphicsPath object with a gradient.
Pen | Represents an object used to draw lines and curves.
SolidBrush | Represents a brush that fills the interiors of objects with a solid color.
StringFormat | Encapsulates text layout information (such as alignment).

Interfaces

Interface | Description
IGraphics | Represents a platform-independent object that can be used to perform drawing.
IGraphicsFactory | A factory class for various graphical objects.
IGraphicsPath | Represents a series of connected lines and curves.
IMatrix | Encapsulates an affine matrix that represents a geometric transform.

Enumerations

Enumeration | Description
CombineMode | Specifies how different clipping regions can be combined.
ContentAlignment | Specifies alignment of content on the drawing surface.
CursorHint | Specifies what mouse cursor to display while a user interacts with the diagram.
DashStyle | Specifies the style of dashed lines.
FillMode | Specifies how the interior of a closed path is filled.
HatchStyle | Represents the available hatch patterns.
HorizontalAlignment | Specifies the horizontal alignment of an element.
ImageAlignment | Specifies the position and alignment of a picture relative to its destination rectangle.
LineJoin | Describes the shape that joins two lines or segments.
PenUnit | Specifies the unit of the width of a pen.
TextAlignment | Specifies the alignment of text on the drawing surface.
VerticalAlignment | Specifies the vertical alignment of an element.


MindFusion.Drawing.Brush Class

Brush Class
[image]

Represents an object that can be used to fill the interiors of geometric shapes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract class Brush

Visual Basic [image] Copy Code

Public MustInherit Class Brush

Inheritance Hierarchy

System.Object
MindFusion.Drawing.Brush
MindFusion.Drawing.HatchBrush
MindFusion.Drawing.LinearGradientBrush
MindFusion.Drawing.PathGradientBrush
MindFusion.Drawing.SolidBrush

See Also

Brush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Members

Brush Members
Constructors Methods
[image]

Represents an object that can be used to fill the interiors of geometric shapes.

The following tables list the members exposed by the Brush type.

Protected Constructors

Name | Description
Brush | Initializes a new instance of the Brush class.

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
Equals | Overloaded.
GetHashCode | Object.GethashCode override.
ToColor | Returns a solid color approximating the brush.

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Constructor

Brush Constructor
[image]

Initializes a new instance of the Brush class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected Brush ()

Visual Basic [image] Copy Code

Protected Sub New ()

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush Methods

Brush Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this brush.
Equals | Overloaded.
GetHashCode | Object.GethashCode override.
ToColor | Returns a solid color approximating the brush.

See Also

Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.Clone Method

Brush.Clone Method
[image]

Creates an exact copy of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract Brush Clone ()

Visual Basic [image] Copy Code

Public MustOverride Function Clone () As Brush

Return Value

An instance of the Brush class.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.Equals Method

Brush.Equals Method
[image]

Overload List

Name | Description
Brush.Equals (Brush) | Determines whether the specified Brush is equal to the current Brush.
Brush.Equals (Object) | Object.Equals override.

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.Equals Method (Brush)

Brush.Equals Method (Brush)
See Also
[image]

Determines whether the specified Brush is equal to the current Brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract bool Equals (
Brush other
)

Visual Basic [image] Copy Code

Public MustOverride Function Equals( _
other As Brush _
) As Boolean

Parameters

other

The Brush to compare with the current Brush.

Return Value

true if the specified Brush is equal to the current Brush; otherwise, false.

See Also

Equals Method Overload List
Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.Equals Method (Object)

Brush.Equals Method (Object)
See Also
[image]

Object.Equals override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with the current Brush.

Return Value

true if the specified object is equal to the current Brush; otherwise, false.

See Also

Equals Method Overload List
Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.GetHashCode Method

Brush.GetHashCode Method
[image]

Object.GethashCode override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brush.ToColor Method

Brush.ToColor Method
[image]

Returns a solid color approximating the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public abstract Color ToColor ()

Visual Basic [image] Copy Code

Public MustOverride Function ToColor () As Color

Return Value

See Also

Brush Members
Brush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes Class

Brushes Class
[image]

Provides a set of predefined brushes.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class Brushes

Visual Basic [image] Copy Code

Public NotInheritable Class Brushes

Inheritance Hierarchy

System.Object
MindFusion.Drawing.Brushes

See Also

Brushes Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes Members

Brushes Members
Fields
[image]

Provides a set of predefined brushes.

The following tables list the members exposed by the Brushes type.

Public Fields

Name | Description
AliceBlue | A solid brush with the AntiqueWhite color.
AntiqueWhite | A solid brush with the AntiqueWhite color.
Aqua | A solid brush with the Aqua color.
Aquamarine | A solid brush with the Aquamarine color.
Azure | A solid brush with the Azure color.
Beige | A solid brush with the Beige color.
Bisque | A solid brush with the Bisque color.
Black | A solid brush with the Black color.
BlanchedAlmond | A solid brush with the BlanchedAlmond color.
Blue | A solid brush with the Blue color.
BlueViolet | A solid brush with the BlueViolet color.
Brown | A solid brush with the Brown color.
BurlyWood | A solid brush with the BurlyWood color.
CadetBlue | A solid brush with the CadetBlue color.
Chartreuse | A solid brush with the Chartreuse color.
Chocolate | A solid brush with the Chocolate color.
Coral | A solid brush with the Coral color.
CornflowerBlue | A solid brush with the CornflowerBlue color.
Cornsilk | A solid brush with the Cornsilk color.
Crimson | A solid brush with the Crimson color.
Cyan | A solid brush with the Cyan color.
DarkBlue | A solid brush with the DarkBlue color.
DarkCyan | A solid brush with the DarkCyan color.
DarkGoldenrod | A solid brush with the DarkGoldenrod color.
DarkGray | A solid brush with the DarkGray color.
DarkGreen | A solid brush with the DarkGreen color.
DarkKhaki | A solid brush with the DarkKhaki color.
DarkMagenta | A solid brush with the DarkMagenta color.
DarkOliveGreen | A solid brush with the DarkOliveGreen color.
DarkOrange | A solid brush with the DarkOrange color.
DarkOrchid | A solid brush with the DarkOrchid color.
DarkRed | A solid brush with the DarkRed color.
DarkSalmon | A solid brush with the DarkSalmon color.
DarkSeaGreen | A solid brush with the DarkSeaGreen color.
DarkSlateBlue | A solid brush with the DarkSlateBlue color.
DarkSlateGray | A solid brush with the DarkSlateGray color.
DarkTurquoise | A solid brush with the DarkTurquoise color.
DarkViolet | A solid brush with the DarkViolet color.
DeepPink | A solid brush with the DeepPink color.
DeepSkyBlue | A solid brush with the DeepSkyBlue color.
DimGray | A solid brush with the DimGray color.
DodgerBlue | A solid brush with the DodgerBlue color.
Firebrick | A solid brush with the Firebrick color.
FloralWhite | A solid brush with the FloralWhite color.
ForestGreen | A solid brush with the ForestGreen color.
Fuchsia | A solid brush with the Fuchsia color.
Gainsboro | A solid brush with the Gainsboro color.
GhostWhite | A solid brush with the GhostWhite color.
Gold | A solid brush with the Gold color.
Goldenrod | A solid brush with the Goldenrod color.
Gray | A solid brush with the Gray color.
Green | A solid brush with the Green color.
GreenYellow | A solid brush with the GreenYellow color.
Honeydew | A solid brush with the Honeydew color.
HotPink | A solid brush with the HotPink color.
IndianRed | A solid brush with the IndianRed color.
Indigo | A solid brush with the Indigo color.
Ivory | A solid brush with the Ivory color.
Khaki | A solid brush with the Khaki color.
Lavender | A solid brush with the Lavender color.
LavenderBlush | A solid brush with the LavenderBlush color.
LawnGreen | A solid brush with the LawnGreen color.
LemonChiffon | A solid brush with the LemonChiffon color.
LightBlue | A solid brush with the LightBlue color.
LightCoral | A solid brush with the LightCoral color.
LightCyan | A solid brush with the LightCyan color.
LightGoldenrodYellow | A solid brush with the LightGoldenrodYellow color.
LightGray | A solid brush with the LightGray color.
LightGreen | A solid brush with the LightGreen color.
LightPink | A solid brush with the LightPink color.
LightSalmon | A solid brush with the LightSalmon color.
LightSeaGreen | A solid brush with the LightSeaGreen color.
LightSkyBlue | A solid brush with the LightSkyBlue color.
LightSlateGray | A solid brush with the LightSlateGray color.
LightSteelBlue | A solid brush with the LightSteelBlue color.
LightYellow | A solid brush with the LightYellow color.
Lime | A solid brush with the Lime color.
LimeGreen | A solid brush with the LimeGreen color.
Linen | A solid brush with the Linen color.
Magenta | A solid brush with the Magenta color.
Maroon | A solid brush with the Maroon color.
MediumAquamarine | A solid brush with the MediumAquamarine color.
MediumBlue | A solid brush with the MediumBlue color.
MediumOrchid | A solid brush with the MediumOrchid color.
MediumPurple | A solid brush with the MediumPurple color.
MediumSeaGreen | A solid brush with the MediumSeaGreen color.
MediumSlateBlue | A solid brush with the MediumSlateBlue color.
MediumSpringGreen | A solid brush with the MediumSpringGreen color.
MediumTurquoise | A solid brush with the MediumTurquoise color.
MediumVioletRed | A solid brush with the MediumVioletRed color.
MidnightBlue | A solid brush with the MidnightBlue color.
MintCream | A solid brush with the MintCream color.
MistyRose | A solid brush with the MistyRose color.
Moccasin | A solid brush with the Moccasin color.
NavajoWhite | A solid brush with the NavajoWhite color.
Navy | A solid brush with the Navy color.
OldLace | A solid brush with the OldLace color.
Olive | A solid brush with the Olive color.
OliveDrab | A solid brush with the OliveDrab color.
Orange | A solid brush with the Orange color.
OrangeRed | A solid brush with the OrangeRed color.
Orchid | A solid brush with the Orchid color.
PaleGoldenrod | A solid brush with the PaleGoldenrod color.
PaleGreen | A solid brush with the PaleGreen color.
PaleTurquoise | A solid brush with the PaleTurquoise color.
PaleVioletRed | A solid brush with the PaleVioletRed color.
PapayaWhip | A solid brush with the PapayaWhip color.
PeachPuff | A solid brush with the PeachPuff color.
Peru | A solid brush with the Peru color.
Pink | A solid brush with the Pink color.
Plum | A solid brush with the Plum color.
PowderBlue | A solid brush with the PowderBlue color.
Purple | A solid brush with the Purple color.
Red | A solid brush with the Red color.
RosyBrown | A solid brush with the RosyBrown color.
RoyalBlue | A solid brush with the RoyalBlue color.
SaddleBrown | A solid brush with the SaddleBrown color.
Salmon | A solid brush with the Salmon color.
SandyBrown | A solid brush with the SandyBrown color.
SeaGreen | A solid brush with the SeaGreen color.
SeaShell | A solid brush with the SeaShell color.
Sienna | A solid brush with the Sienna color.
Silver | A solid brush with the Silver color.
SkyBlue | A solid brush with the SkyBlue color.
SlateBlue | A solid brush with the SlateBlue color.
SlateGray | A solid brush with the SlateGray color.
Snow | A solid brush with the Snow color.
SpringGreen | A solid brush with the SpringGreen color.
SteelBlue | A solid brush with the SteelBlue color.
Tan | A solid brush with the Tan color.
Teal | A solid brush with the Teal color.
Thistle | A solid brush with the Thistle color.
Tomato | A solid brush with the Tomato color.
Transparent | A solid brush with the Transparent color.
Turquoise | A solid brush with the Turquoise color.
Violet | A solid brush with the Violet color.
Wheat | A solid brush with the Wheat color.
White | A solid brush with the White color.
WhiteSmoke | A solid brush with the WhiteSmoke color.
Yellow | A solid brush with the Yellow color.
YellowGreen | A solid brush with the YellowGreen color.

See Also

Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes Fields

Brushes Fields
[image]

Public Fields

Name | Description
AliceBlue | A solid brush with the AntiqueWhite color.
AntiqueWhite | A solid brush with the AntiqueWhite color.
Aqua | A solid brush with the Aqua color.
Aquamarine | A solid brush with the Aquamarine color.
Azure | A solid brush with the Azure color.
Beige | A solid brush with the Beige color.
Bisque | A solid brush with the Bisque color.
Black | A solid brush with the Black color.
BlanchedAlmond | A solid brush with the BlanchedAlmond color.
Blue | A solid brush with the Blue color.
BlueViolet | A solid brush with the BlueViolet color.
Brown | A solid brush with the Brown color.
BurlyWood | A solid brush with the BurlyWood color.
CadetBlue | A solid brush with the CadetBlue color.
Chartreuse | A solid brush with the Chartreuse color.
Chocolate | A solid brush with the Chocolate color.
Coral | A solid brush with the Coral color.
CornflowerBlue | A solid brush with the CornflowerBlue color.
Cornsilk | A solid brush with the Cornsilk color.
Crimson | A solid brush with the Crimson color.
Cyan | A solid brush with the Cyan color.
DarkBlue | A solid brush with the DarkBlue color.
DarkCyan | A solid brush with the DarkCyan color.
DarkGoldenrod | A solid brush with the DarkGoldenrod color.
DarkGray | A solid brush with the DarkGray color.
DarkGreen | A solid brush with the DarkGreen color.
DarkKhaki | A solid brush with the DarkKhaki color.
DarkMagenta | A solid brush with the DarkMagenta color.
DarkOliveGreen | A solid brush with the DarkOliveGreen color.
DarkOrange | A solid brush with the DarkOrange color.
DarkOrchid | A solid brush with the DarkOrchid color.
DarkRed | A solid brush with the DarkRed color.
DarkSalmon | A solid brush with the DarkSalmon color.
DarkSeaGreen | A solid brush with the DarkSeaGreen color.
DarkSlateBlue | A solid brush with the DarkSlateBlue color.
DarkSlateGray | A solid brush with the DarkSlateGray color.
DarkTurquoise | A solid brush with the DarkTurquoise color.
DarkViolet | A solid brush with the DarkViolet color.
DeepPink | A solid brush with the DeepPink color.
DeepSkyBlue | A solid brush with the DeepSkyBlue color.
DimGray | A solid brush with the DimGray color.
DodgerBlue | A solid brush with the DodgerBlue color.
Firebrick | A solid brush with the Firebrick color.
FloralWhite | A solid brush with the FloralWhite color.
ForestGreen | A solid brush with the ForestGreen color.
Fuchsia | A solid brush with the Fuchsia color.
Gainsboro | A solid brush with the Gainsboro color.
GhostWhite | A solid brush with the GhostWhite color.
Gold | A solid brush with the Gold color.
Goldenrod | A solid brush with the Goldenrod color.
Gray | A solid brush with the Gray color.
Green | A solid brush with the Green color.
GreenYellow | A solid brush with the GreenYellow color.
Honeydew | A solid brush with the Honeydew color.
HotPink | A solid brush with the HotPink color.
IndianRed | A solid brush with the IndianRed color.
Indigo | A solid brush with the Indigo color.
Ivory | A solid brush with the Ivory color.
Khaki | A solid brush with the Khaki color.
Lavender | A solid brush with the Lavender color.
LavenderBlush | A solid brush with the LavenderBlush color.
LawnGreen | A solid brush with the LawnGreen color.
LemonChiffon | A solid brush with the LemonChiffon color.
LightBlue | A solid brush with the LightBlue color.
LightCoral | A solid brush with the LightCoral color.
LightCyan | A solid brush with the LightCyan color.
LightGoldenrodYellow | A solid brush with the LightGoldenrodYellow color.
LightGray | A solid brush with the LightGray color.
LightGreen | A solid brush with the LightGreen color.
LightPink | A solid brush with the LightPink color.
LightSalmon | A solid brush with the LightSalmon color.
LightSeaGreen | A solid brush with the LightSeaGreen color.
LightSkyBlue | A solid brush with the LightSkyBlue color.
LightSlateGray | A solid brush with the LightSlateGray color.
LightSteelBlue | A solid brush with the LightSteelBlue color.
LightYellow | A solid brush with the LightYellow color.
Lime | A solid brush with the Lime color.
LimeGreen | A solid brush with the LimeGreen color.
Linen | A solid brush with the Linen color.
Magenta | A solid brush with the Magenta color.
Maroon | A solid brush with the Maroon color.
MediumAquamarine | A solid brush with the MediumAquamarine color.
MediumBlue | A solid brush with the MediumBlue color.
MediumOrchid | A solid brush with the MediumOrchid color.
MediumPurple | A solid brush with the MediumPurple color.
MediumSeaGreen | A solid brush with the MediumSeaGreen color.
MediumSlateBlue | A solid brush with the MediumSlateBlue color.
MediumSpringGreen | A solid brush with the MediumSpringGreen color.
MediumTurquoise | A solid brush with the MediumTurquoise color.
MediumVioletRed | A solid brush with the MediumVioletRed color.
MidnightBlue | A solid brush with the MidnightBlue color.
MintCream | A solid brush with the MintCream color.
MistyRose | A solid brush with the MistyRose color.
Moccasin | A solid brush with the Moccasin color.
NavajoWhite | A solid brush with the NavajoWhite color.
Navy | A solid brush with the Navy color.
OldLace | A solid brush with the OldLace color.
Olive | A solid brush with the Olive color.
OliveDrab | A solid brush with the OliveDrab color.
Orange | A solid brush with the Orange color.
OrangeRed | A solid brush with the OrangeRed color.
Orchid | A solid brush with the Orchid color.
PaleGoldenrod | A solid brush with the PaleGoldenrod color.
PaleGreen | A solid brush with the PaleGreen color.
PaleTurquoise | A solid brush with the PaleTurquoise color.
PaleVioletRed | A solid brush with the PaleVioletRed color.
PapayaWhip | A solid brush with the PapayaWhip color.
PeachPuff | A solid brush with the PeachPuff color.
Peru | A solid brush with the Peru color.
Pink | A solid brush with the Pink color.
Plum | A solid brush with the Plum color.
PowderBlue | A solid brush with the PowderBlue color.
Purple | A solid brush with the Purple color.
Red | A solid brush with the Red color.
RosyBrown | A solid brush with the RosyBrown color.
RoyalBlue | A solid brush with the RoyalBlue color.
SaddleBrown | A solid brush with the SaddleBrown color.
Salmon | A solid brush with the Salmon color.
SandyBrown | A solid brush with the SandyBrown color.
SeaGreen | A solid brush with the SeaGreen color.
SeaShell | A solid brush with the SeaShell color.
Sienna | A solid brush with the Sienna color.
Silver | A solid brush with the Silver color.
SkyBlue | A solid brush with the SkyBlue color.
SlateBlue | A solid brush with the SlateBlue color.
SlateGray | A solid brush with the SlateGray color.
Snow | A solid brush with the Snow color.
SpringGreen | A solid brush with the SpringGreen color.
SteelBlue | A solid brush with the SteelBlue color.
Tan | A solid brush with the Tan color.
Teal | A solid brush with the Teal color.
Thistle | A solid brush with the Thistle color.
Tomato | A solid brush with the Tomato color.
Transparent | A solid brush with the Transparent color.
Turquoise | A solid brush with the Turquoise color.
Violet | A solid brush with the Violet color.
Wheat | A solid brush with the Wheat color.
White | A solid brush with the White color.
WhiteSmoke | A solid brush with the WhiteSmoke color.
Yellow | A solid brush with the Yellow color.
YellowGreen | A solid brush with the YellowGreen color.

See Also

Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.AliceBlue Field

Brushes.AliceBlue Field
[image]

A solid brush with the AntiqueWhite color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush AliceBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly AliceBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.AntiqueWhite Field

Brushes.AntiqueWhite Field
[image]

A solid brush with the AntiqueWhite color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush AntiqueWhite

Visual Basic [image] Copy Code

Public Shared ReadOnly AntiqueWhite As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Aqua Field

Brushes.Aqua Field
[image]

A solid brush with the Aqua color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Aqua

Visual Basic [image] Copy Code

Public Shared ReadOnly Aqua As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Aquamarine Field

Brushes.Aquamarine Field
[image]

A solid brush with the Aquamarine color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Aquamarine

Visual Basic [image] Copy Code

Public Shared ReadOnly Aquamarine As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Azure Field

Brushes.Azure Field
[image]

A solid brush with the Azure color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Azure

Visual Basic [image] Copy Code

Public Shared ReadOnly Azure As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Beige Field

Brushes.Beige Field
[image]

A solid brush with the Beige color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Beige

Visual Basic [image] Copy Code

Public Shared ReadOnly Beige As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Bisque Field

Brushes.Bisque Field
[image]

A solid brush with the Bisque color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Bisque

Visual Basic [image] Copy Code

Public Shared ReadOnly Bisque As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Black Field

Brushes.Black Field
[image]

A solid brush with the Black color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Black

Visual Basic [image] Copy Code

Public Shared ReadOnly Black As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.BlanchedAlmond Field

Brushes.BlanchedAlmond Field
[image]

A solid brush with the BlanchedAlmond color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush BlanchedAlmond

Visual Basic [image] Copy Code

Public Shared ReadOnly BlanchedAlmond As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Blue Field

Brushes.Blue Field
[image]

A solid brush with the Blue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Blue

Visual Basic [image] Copy Code

Public Shared ReadOnly Blue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.BlueViolet Field

Brushes.BlueViolet Field
[image]

A solid brush with the BlueViolet color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush BlueViolet

Visual Basic [image] Copy Code

Public Shared ReadOnly BlueViolet As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Brown Field

Brushes.Brown Field
[image]

A solid brush with the Brown color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Brown

Visual Basic [image] Copy Code

Public Shared ReadOnly Brown As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.BurlyWood Field

Brushes.BurlyWood Field
[image]

A solid brush with the BurlyWood color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush BurlyWood

Visual Basic [image] Copy Code

Public Shared ReadOnly BurlyWood As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.CadetBlue Field

Brushes.CadetBlue Field
[image]

A solid brush with the CadetBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush CadetBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly CadetBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Chartreuse Field

Brushes.Chartreuse Field
[image]

A solid brush with the Chartreuse color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Chartreuse

Visual Basic [image] Copy Code

Public Shared ReadOnly Chartreuse As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Chocolate Field

Brushes.Chocolate Field
[image]

A solid brush with the Chocolate color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Chocolate

Visual Basic [image] Copy Code

Public Shared ReadOnly Chocolate As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Coral Field

Brushes.Coral Field
[image]

A solid brush with the Coral color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Coral

Visual Basic [image] Copy Code

Public Shared ReadOnly Coral As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.CornflowerBlue Field

Brushes.CornflowerBlue Field
[image]

A solid brush with the CornflowerBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush CornflowerBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly CornflowerBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Cornsilk Field

Brushes.Cornsilk Field
[image]

A solid brush with the Cornsilk color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Cornsilk

Visual Basic [image] Copy Code

Public Shared ReadOnly Cornsilk As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Crimson Field

Brushes.Crimson Field
[image]

A solid brush with the Crimson color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Crimson

Visual Basic [image] Copy Code

Public Shared ReadOnly Crimson As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Cyan Field

Brushes.Cyan Field
[image]

A solid brush with the Cyan color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Cyan

Visual Basic [image] Copy Code

Public Shared ReadOnly Cyan As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkBlue Field

Brushes.DarkBlue Field
[image]

A solid brush with the DarkBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkCyan Field

Brushes.DarkCyan Field
[image]

A solid brush with the DarkCyan color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkCyan

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkCyan As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkGoldenrod Field

Brushes.DarkGoldenrod Field
[image]

A solid brush with the DarkGoldenrod color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkGoldenrod

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkGoldenrod As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkGray Field

Brushes.DarkGray Field
[image]

A solid brush with the DarkGray color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkGray

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkGray As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkGreen Field

Brushes.DarkGreen Field
[image]

A solid brush with the DarkGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkKhaki Field

Brushes.DarkKhaki Field
[image]

A solid brush with the DarkKhaki color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkKhaki

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkKhaki As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkMagenta Field

Brushes.DarkMagenta Field
[image]

A solid brush with the DarkMagenta color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkMagenta

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkMagenta As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkOliveGreen Field

Brushes.DarkOliveGreen Field
[image]

A solid brush with the DarkOliveGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkOliveGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkOliveGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkOrange Field

Brushes.DarkOrange Field
[image]

A solid brush with the DarkOrange color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkOrange

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkOrange As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkOrchid Field

Brushes.DarkOrchid Field
[image]

A solid brush with the DarkOrchid color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkOrchid

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkOrchid As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkRed Field

Brushes.DarkRed Field
[image]

A solid brush with the DarkRed color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkRed

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkRed As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkSalmon Field

Brushes.DarkSalmon Field
[image]

A solid brush with the DarkSalmon color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkSalmon

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkSalmon As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkSeaGreen Field

Brushes.DarkSeaGreen Field
[image]

A solid brush with the DarkSeaGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkSeaGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkSeaGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkSlateBlue Field

Brushes.DarkSlateBlue Field
[image]

A solid brush with the DarkSlateBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkSlateBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkSlateBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkSlateGray Field

Brushes.DarkSlateGray Field
[image]

A solid brush with the DarkSlateGray color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkSlateGray

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkSlateGray As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkTurquoise Field

Brushes.DarkTurquoise Field
[image]

A solid brush with the DarkTurquoise color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkTurquoise

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkTurquoise As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DarkViolet Field

Brushes.DarkViolet Field
[image]

A solid brush with the DarkViolet color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DarkViolet

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkViolet As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DeepPink Field

Brushes.DeepPink Field
[image]

A solid brush with the DeepPink color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DeepPink

Visual Basic [image] Copy Code

Public Shared ReadOnly DeepPink As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DeepSkyBlue Field

Brushes.DeepSkyBlue Field
[image]

A solid brush with the DeepSkyBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DeepSkyBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly DeepSkyBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DimGray Field

Brushes.DimGray Field
[image]

A solid brush with the DimGray color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DimGray

Visual Basic [image] Copy Code

Public Shared ReadOnly DimGray As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.DodgerBlue Field

Brushes.DodgerBlue Field
[image]

A solid brush with the DodgerBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush DodgerBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly DodgerBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Firebrick Field

Brushes.Firebrick Field
[image]

A solid brush with the Firebrick color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Firebrick

Visual Basic [image] Copy Code

Public Shared ReadOnly Firebrick As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.FloralWhite Field

Brushes.FloralWhite Field
[image]

A solid brush with the FloralWhite color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush FloralWhite

Visual Basic [image] Copy Code

Public Shared ReadOnly FloralWhite As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.ForestGreen Field

Brushes.ForestGreen Field
[image]

A solid brush with the ForestGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush ForestGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly ForestGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Fuchsia Field

Brushes.Fuchsia Field
[image]

A solid brush with the Fuchsia color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Fuchsia

Visual Basic [image] Copy Code

Public Shared ReadOnly Fuchsia As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Gainsboro Field

Brushes.Gainsboro Field
[image]

A solid brush with the Gainsboro color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Gainsboro

Visual Basic [image] Copy Code

Public Shared ReadOnly Gainsboro As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.GhostWhite Field

Brushes.GhostWhite Field
[image]

A solid brush with the GhostWhite color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush GhostWhite

Visual Basic [image] Copy Code

Public Shared ReadOnly GhostWhite As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Gold Field

Brushes.Gold Field
[image]

A solid brush with the Gold color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Gold

Visual Basic [image] Copy Code

Public Shared ReadOnly Gold As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Goldenrod Field

Brushes.Goldenrod Field
[image]

A solid brush with the Goldenrod color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Goldenrod

Visual Basic [image] Copy Code

Public Shared ReadOnly Goldenrod As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Gray Field

Brushes.Gray Field
[image]

A solid brush with the Gray color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Gray

Visual Basic [image] Copy Code

Public Shared ReadOnly Gray As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Green Field

Brushes.Green Field
[image]

A solid brush with the Green color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Green

Visual Basic [image] Copy Code

Public Shared ReadOnly Green As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.GreenYellow Field

Brushes.GreenYellow Field
[image]

A solid brush with the GreenYellow color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush GreenYellow

Visual Basic [image] Copy Code

Public Shared ReadOnly GreenYellow As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Honeydew Field

Brushes.Honeydew Field
[image]

A solid brush with the Honeydew color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Honeydew

Visual Basic [image] Copy Code

Public Shared ReadOnly Honeydew As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.HotPink Field

Brushes.HotPink Field
[image]

A solid brush with the HotPink color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush HotPink

Visual Basic [image] Copy Code

Public Shared ReadOnly HotPink As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.IndianRed Field

Brushes.IndianRed Field
[image]

A solid brush with the IndianRed color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush IndianRed

Visual Basic [image] Copy Code

Public Shared ReadOnly IndianRed As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Indigo Field

Brushes.Indigo Field
[image]

A solid brush with the Indigo color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Indigo

Visual Basic [image] Copy Code

Public Shared ReadOnly Indigo As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Ivory Field

Brushes.Ivory Field
[image]

A solid brush with the Ivory color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Ivory

Visual Basic [image] Copy Code

Public Shared ReadOnly Ivory As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Khaki Field

Brushes.Khaki Field
[image]

A solid brush with the Khaki color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Khaki

Visual Basic [image] Copy Code

Public Shared ReadOnly Khaki As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Lavender Field

Brushes.Lavender Field
[image]

A solid brush with the Lavender color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Lavender

Visual Basic [image] Copy Code

Public Shared ReadOnly Lavender As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LavenderBlush Field

Brushes.LavenderBlush Field
[image]

A solid brush with the LavenderBlush color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LavenderBlush

Visual Basic [image] Copy Code

Public Shared ReadOnly LavenderBlush As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LawnGreen Field

Brushes.LawnGreen Field
[image]

A solid brush with the LawnGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LawnGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly LawnGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LemonChiffon Field

Brushes.LemonChiffon Field
[image]

A solid brush with the LemonChiffon color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LemonChiffon

Visual Basic [image] Copy Code

Public Shared ReadOnly LemonChiffon As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightBlue Field

Brushes.LightBlue Field
[image]

A solid brush with the LightBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly LightBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightCoral Field

Brushes.LightCoral Field
[image]

A solid brush with the LightCoral color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightCoral

Visual Basic [image] Copy Code

Public Shared ReadOnly LightCoral As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightCyan Field

Brushes.LightCyan Field
[image]

A solid brush with the LightCyan color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightCyan

Visual Basic [image] Copy Code

Public Shared ReadOnly LightCyan As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightGoldenrodYellow Field

Brushes.LightGoldenrodYellow Field
[image]

A solid brush with the LightGoldenrodYellow color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightGoldenrodYellow

Visual Basic [image] Copy Code

Public Shared ReadOnly LightGoldenrodYellow As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightGray Field

Brushes.LightGray Field
[image]

A solid brush with the LightGray color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightGray

Visual Basic [image] Copy Code

Public Shared ReadOnly LightGray As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightGreen Field

Brushes.LightGreen Field
[image]

A solid brush with the LightGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly LightGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightPink Field

Brushes.LightPink Field
[image]

A solid brush with the LightPink color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightPink

Visual Basic [image] Copy Code

Public Shared ReadOnly LightPink As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightSalmon Field

Brushes.LightSalmon Field
[image]

A solid brush with the LightSalmon color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightSalmon

Visual Basic [image] Copy Code

Public Shared ReadOnly LightSalmon As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightSeaGreen Field

Brushes.LightSeaGreen Field
[image]

A solid brush with the LightSeaGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightSeaGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly LightSeaGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightSkyBlue Field

Brushes.LightSkyBlue Field
[image]

A solid brush with the LightSkyBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightSkyBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly LightSkyBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightSlateGray Field

Brushes.LightSlateGray Field
[image]

A solid brush with the LightSlateGray color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightSlateGray

Visual Basic [image] Copy Code

Public Shared ReadOnly LightSlateGray As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightSteelBlue Field

Brushes.LightSteelBlue Field
[image]

A solid brush with the LightSteelBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightSteelBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly LightSteelBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LightYellow Field

Brushes.LightYellow Field
[image]

A solid brush with the LightYellow color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LightYellow

Visual Basic [image] Copy Code

Public Shared ReadOnly LightYellow As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Lime Field

Brushes.Lime Field
[image]

A solid brush with the Lime color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Lime

Visual Basic [image] Copy Code

Public Shared ReadOnly Lime As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.LimeGreen Field

Brushes.LimeGreen Field
[image]

A solid brush with the LimeGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush LimeGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly LimeGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Linen Field

Brushes.Linen Field
[image]

A solid brush with the Linen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Linen

Visual Basic [image] Copy Code

Public Shared ReadOnly Linen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Magenta Field

Brushes.Magenta Field
[image]

A solid brush with the Magenta color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Magenta

Visual Basic [image] Copy Code

Public Shared ReadOnly Magenta As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Maroon Field

Brushes.Maroon Field
[image]

A solid brush with the Maroon color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Maroon

Visual Basic [image] Copy Code

Public Shared ReadOnly Maroon As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MediumAquamarine Field

Brushes.MediumAquamarine Field
[image]

A solid brush with the MediumAquamarine color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MediumAquamarine

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumAquamarine As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MediumBlue Field

Brushes.MediumBlue Field
[image]

A solid brush with the MediumBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MediumBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MediumOrchid Field

Brushes.MediumOrchid Field
[image]

A solid brush with the MediumOrchid color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MediumOrchid

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumOrchid As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MediumPurple Field

Brushes.MediumPurple Field
[image]

A solid brush with the MediumPurple color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MediumPurple

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumPurple As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MediumSeaGreen Field

Brushes.MediumSeaGreen Field
[image]

A solid brush with the MediumSeaGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MediumSeaGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumSeaGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MediumSlateBlue Field

Brushes.MediumSlateBlue Field
[image]

A solid brush with the MediumSlateBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MediumSlateBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumSlateBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MediumSpringGreen Field

Brushes.MediumSpringGreen Field
[image]

A solid brush with the MediumSpringGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MediumSpringGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumSpringGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MediumTurquoise Field

Brushes.MediumTurquoise Field
[image]

A solid brush with the MediumTurquoise color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MediumTurquoise

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumTurquoise As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MediumVioletRed Field

Brushes.MediumVioletRed Field
[image]

A solid brush with the MediumVioletRed color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MediumVioletRed

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumVioletRed As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MidnightBlue Field

Brushes.MidnightBlue Field
[image]

A solid brush with the MidnightBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MidnightBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly MidnightBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MintCream Field

Brushes.MintCream Field
[image]

A solid brush with the MintCream color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MintCream

Visual Basic [image] Copy Code

Public Shared ReadOnly MintCream As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.MistyRose Field

Brushes.MistyRose Field
[image]

A solid brush with the MistyRose color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush MistyRose

Visual Basic [image] Copy Code

Public Shared ReadOnly MistyRose As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Moccasin Field

Brushes.Moccasin Field
[image]

A solid brush with the Moccasin color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Moccasin

Visual Basic [image] Copy Code

Public Shared ReadOnly Moccasin As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.NavajoWhite Field

Brushes.NavajoWhite Field
[image]

A solid brush with the NavajoWhite color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush NavajoWhite

Visual Basic [image] Copy Code

Public Shared ReadOnly NavajoWhite As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Navy Field

Brushes.Navy Field
[image]

A solid brush with the Navy color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Navy

Visual Basic [image] Copy Code

Public Shared ReadOnly Navy As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.OldLace Field

Brushes.OldLace Field
[image]

A solid brush with the OldLace color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush OldLace

Visual Basic [image] Copy Code

Public Shared ReadOnly OldLace As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Olive Field

Brushes.Olive Field
[image]

A solid brush with the Olive color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Olive

Visual Basic [image] Copy Code

Public Shared ReadOnly Olive As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.OliveDrab Field

Brushes.OliveDrab Field
[image]

A solid brush with the OliveDrab color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush OliveDrab

Visual Basic [image] Copy Code

Public Shared ReadOnly OliveDrab As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Orange Field

Brushes.Orange Field
[image]

A solid brush with the Orange color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Orange

Visual Basic [image] Copy Code

Public Shared ReadOnly Orange As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.OrangeRed Field

Brushes.OrangeRed Field
[image]

A solid brush with the OrangeRed color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush OrangeRed

Visual Basic [image] Copy Code

Public Shared ReadOnly OrangeRed As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Orchid Field

Brushes.Orchid Field
[image]

A solid brush with the Orchid color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Orchid

Visual Basic [image] Copy Code

Public Shared ReadOnly Orchid As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.PaleGoldenrod Field

Brushes.PaleGoldenrod Field
[image]

A solid brush with the PaleGoldenrod color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush PaleGoldenrod

Visual Basic [image] Copy Code

Public Shared ReadOnly PaleGoldenrod As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.PaleGreen Field

Brushes.PaleGreen Field
[image]

A solid brush with the PaleGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush PaleGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly PaleGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.PaleTurquoise Field

Brushes.PaleTurquoise Field
[image]

A solid brush with the PaleTurquoise color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush PaleTurquoise

Visual Basic [image] Copy Code

Public Shared ReadOnly PaleTurquoise As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.PaleVioletRed Field

Brushes.PaleVioletRed Field
[image]

A solid brush with the PaleVioletRed color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush PaleVioletRed

Visual Basic [image] Copy Code

Public Shared ReadOnly PaleVioletRed As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.PapayaWhip Field

Brushes.PapayaWhip Field
[image]

A solid brush with the PapayaWhip color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush PapayaWhip

Visual Basic [image] Copy Code

Public Shared ReadOnly PapayaWhip As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.PeachPuff Field

Brushes.PeachPuff Field
[image]

A solid brush with the PeachPuff color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush PeachPuff

Visual Basic [image] Copy Code

Public Shared ReadOnly PeachPuff As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Peru Field

Brushes.Peru Field
[image]

A solid brush with the Peru color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Peru

Visual Basic [image] Copy Code

Public Shared ReadOnly Peru As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Pink Field

Brushes.Pink Field
[image]

A solid brush with the Pink color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Pink

Visual Basic [image] Copy Code

Public Shared ReadOnly Pink As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Plum Field

Brushes.Plum Field
[image]

A solid brush with the Plum color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Plum

Visual Basic [image] Copy Code

Public Shared ReadOnly Plum As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.PowderBlue Field

Brushes.PowderBlue Field
[image]

A solid brush with the PowderBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush PowderBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly PowderBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Purple Field

Brushes.Purple Field
[image]

A solid brush with the Purple color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Purple

Visual Basic [image] Copy Code

Public Shared ReadOnly Purple As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Red Field

Brushes.Red Field
[image]

A solid brush with the Red color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Red

Visual Basic [image] Copy Code

Public Shared ReadOnly Red As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.RosyBrown Field

Brushes.RosyBrown Field
[image]

A solid brush with the RosyBrown color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush RosyBrown

Visual Basic [image] Copy Code

Public Shared ReadOnly RosyBrown As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.RoyalBlue Field

Brushes.RoyalBlue Field
[image]

A solid brush with the RoyalBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush RoyalBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly RoyalBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.SaddleBrown Field

Brushes.SaddleBrown Field
[image]

A solid brush with the SaddleBrown color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush SaddleBrown

Visual Basic [image] Copy Code

Public Shared ReadOnly SaddleBrown As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Salmon Field

Brushes.Salmon Field
[image]

A solid brush with the Salmon color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Salmon

Visual Basic [image] Copy Code

Public Shared ReadOnly Salmon As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.SandyBrown Field

Brushes.SandyBrown Field
[image]

A solid brush with the SandyBrown color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush SandyBrown

Visual Basic [image] Copy Code

Public Shared ReadOnly SandyBrown As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.SeaGreen Field

Brushes.SeaGreen Field
[image]

A solid brush with the SeaGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush SeaGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly SeaGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.SeaShell Field

Brushes.SeaShell Field
[image]

A solid brush with the SeaShell color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush SeaShell

Visual Basic [image] Copy Code

Public Shared ReadOnly SeaShell As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Sienna Field

Brushes.Sienna Field
[image]

A solid brush with the Sienna color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Sienna

Visual Basic [image] Copy Code

Public Shared ReadOnly Sienna As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Silver Field

Brushes.Silver Field
[image]

A solid brush with the Silver color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Silver

Visual Basic [image] Copy Code

Public Shared ReadOnly Silver As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.SkyBlue Field

Brushes.SkyBlue Field
[image]

A solid brush with the SkyBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush SkyBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly SkyBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.SlateBlue Field

Brushes.SlateBlue Field
[image]

A solid brush with the SlateBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush SlateBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly SlateBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.SlateGray Field

Brushes.SlateGray Field
[image]

A solid brush with the SlateGray color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush SlateGray

Visual Basic [image] Copy Code

Public Shared ReadOnly SlateGray As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Snow Field

Brushes.Snow Field
[image]

A solid brush with the Snow color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Snow

Visual Basic [image] Copy Code

Public Shared ReadOnly Snow As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.SpringGreen Field

Brushes.SpringGreen Field
[image]

A solid brush with the SpringGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush SpringGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly SpringGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.SteelBlue Field

Brushes.SteelBlue Field
[image]

A solid brush with the SteelBlue color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush SteelBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly SteelBlue As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Tan Field

Brushes.Tan Field
[image]

A solid brush with the Tan color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Tan

Visual Basic [image] Copy Code

Public Shared ReadOnly Tan As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Teal Field

Brushes.Teal Field
[image]

A solid brush with the Teal color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Teal

Visual Basic [image] Copy Code

Public Shared ReadOnly Teal As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Thistle Field

Brushes.Thistle Field
[image]

A solid brush with the Thistle color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Thistle

Visual Basic [image] Copy Code

Public Shared ReadOnly Thistle As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Tomato Field

Brushes.Tomato Field
[image]

A solid brush with the Tomato color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Tomato

Visual Basic [image] Copy Code

Public Shared ReadOnly Tomato As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Transparent Field

Brushes.Transparent Field
[image]

A solid brush with the Transparent color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Transparent

Visual Basic [image] Copy Code

Public Shared ReadOnly Transparent As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Turquoise Field

Brushes.Turquoise Field
[image]

A solid brush with the Turquoise color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Turquoise

Visual Basic [image] Copy Code

Public Shared ReadOnly Turquoise As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Violet Field

Brushes.Violet Field
[image]

A solid brush with the Violet color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Violet

Visual Basic [image] Copy Code

Public Shared ReadOnly Violet As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Wheat Field

Brushes.Wheat Field
[image]

A solid brush with the Wheat color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Wheat

Visual Basic [image] Copy Code

Public Shared ReadOnly Wheat As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.White Field

Brushes.White Field
[image]

A solid brush with the White color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush White

Visual Basic [image] Copy Code

Public Shared ReadOnly White As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.WhiteSmoke Field

Brushes.WhiteSmoke Field
[image]

A solid brush with the WhiteSmoke color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush WhiteSmoke

Visual Basic [image] Copy Code

Public Shared ReadOnly WhiteSmoke As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.Yellow Field

Brushes.Yellow Field
[image]

A solid brush with the Yellow color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush Yellow

Visual Basic [image] Copy Code

Public Shared ReadOnly Yellow As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Brushes.YellowGreen Field

Brushes.YellowGreen Field
[image]

A solid brush with the YellowGreen color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Brush YellowGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly YellowGreen As Brush

See Also

Brushes Members
Brushes Class
MindFusion.Drawing Namespace


MindFusion.Drawing.CardinalSpline Class

CardinalSpline Class
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class CardinalSpline

Visual Basic [image] Copy Code

Public Class CardinalSpline

Inheritance Hierarchy

System.Object
MindFusion.Drawing.CardinalSpline

See Also

CardinalSpline Members
MindFusion.Drawing Namespace


MindFusion.Drawing.CardinalSpline Members

CardinalSpline Members
Constructors Methods
[image]

The following tables list the members exposed by the CardinalSpline type.

Public Constructors

Name | Description
CardinalSpline | Overloaded.

Public Methods

Name | Description
AddToPath |
Draw |
GetPoints |

See Also

CardinalSpline Class
MindFusion.Drawing Namespace


MindFusion.Drawing.CardinalSpline Constructor

CardinalSpline Constructor
[image]

Overload List

Name | Description
CardinalSpline (List(Point)) |
CardinalSpline (List(Point), Nullable(Point), Nullable(Point)) |

See Also

CardinalSpline Class
MindFusion.Drawing Namespace


MindFusion.Drawing.CardinalSpline Constructor (List(Point))

CardinalSpline Constructor (List(Point))
See Also
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public CardinalSpline (
List<Point> points
)

Visual Basic [image] Copy Code

Public New ( _
points As List(Of Point) _
)

Parameters

points

See Also

CardinalSpline Constructor Overload List
CardinalSpline Class
MindFusion.Drawing Namespace


MindFusion.Drawing.CardinalSpline Constructor (List(Point), Nullable(Point), Nullable(Point))

CardinalSpline Constructor (List(Point), Nullable(Point), Nullable(Point))
See Also
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public CardinalSpline (
List<Point> points,
Nullable<Point> from,
Nullable<Point> to
)

Visual Basic [image] Copy Code

Public New ( _
points As List(Of Point), _
from As Nullable(Of Point), _
to As Nullable(Of Point) _
)

Parameters

points

from

to

See Also

CardinalSpline Constructor Overload List
CardinalSpline Class
MindFusion.Drawing Namespace


MindFusion.Drawing.CardinalSpline Methods

CardinalSpline Methods
[image]

Public Methods

Name | Description
AddToPath |
Draw |
GetPoints |

See Also

CardinalSpline Class
MindFusion.Drawing Namespace


MindFusion.Drawing.CardinalSpline.AddToPath Method

CardinalSpline.AddToPath Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void AddToPath (
IGraphicsPath path
)

Visual Basic [image] Copy Code

Public Sub AddToPath( _
path As IGraphicsPath _
)

Parameters

path

See Also

CardinalSpline Members
CardinalSpline Class
MindFusion.Drawing Namespace


MindFusion.Drawing.CardinalSpline.Draw Method

CardinalSpline.Draw Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void Draw (
IGraphics graphics,
Pen pen
)

Visual Basic [image] Copy Code

Public Sub Draw( _
graphics As IGraphics, _
pen As Pen _
)

Parameters

graphics

pen

See Also

CardinalSpline Members
CardinalSpline Class
MindFusion.Drawing Namespace


MindFusion.Drawing.CardinalSpline.GetPoints Method

CardinalSpline.GetPoints Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Point[] GetPoints ()

Visual Basic [image] Copy Code

Public Function GetPoints () As Point()

Return Value

See Also

CardinalSpline Members
CardinalSpline Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors Class

Colors Class
[image]

Provides a set of predefined colors.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class Colors

Visual Basic [image] Copy Code

Public NotInheritable Class Colors

Inheritance Hierarchy

System.Object
MindFusion.Drawing.Colors

See Also

Colors Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors Members

Colors Members
Fields
[image]

Provides a set of predefined colors.

The following tables list the members exposed by the Colors type.

Public Fields

Name | Description
AliceBlue | A color that has a hexadecimal value of #FFF0F8FF.
AntiqueWhite | A color that has a hexadecimal value of #FFFAEBD7.
Aqua | A color that has a hexadecimal value of #FF00FFFF.
Aquamarine | A color that has a hexadecimal value of #FF7FFFD4.
Azure | A color that has a hexadecimal value of #FFF0FFFF.
Beige | A color that has a hexadecimal value of #FFF5F5DC.
Bisque | A color that has a hexadecimal value of #FFFFE40C4.
Black | A color that has a hexadecimal value of #FF000000.
BlanchedAlmond | A color that has a hexadecimal value of #FFFFEBCD.
Blue | A color that has a hexadecimal value of #FF0000FF.
BlueViolet | A color that has a hexadecimal value of #FF8A2BE2.
Brown | A color that has a hexadecimal value of #FFA52A2A.
BurlyWood | A color that has a hexadecimal value of #FFDEB887.
CadetBlue | A color that has a hexadecimal value of #FF5F9EA0.
Chartreuse | A color that has a hexadecimal value of #FF7FFF00.
Chocolate | A color that has a hexadecimal value of #FFD2691E.
ControlDark | A color that has a hexadecimal value of #FFA0A0A0.
ControlDarkDark | A color that has a hexadecimal value of #FF696996.
ControlLight | A color that has a hexadecimal value of #FFE3E3E3.
ControlLightLight | A color that has a hexadecimal value of #FFFFFFFF.
Coral | A color that has a hexadecimal value of #FFFF7F50.
CornflowerBlue | A color that has a hexadecimal value of #FF6495ED.
Cornsilk | A color that has a hexadecimal value of #FFFFF8DC.
Crimson | A color that has a hexadecimal value of #FFDC143C.
Cyan | A color that has a hexadecimal value of #FF00FFFF.
DarkBlue | A color that has a hexadecimal value of #FF00008B.
DarkCyan | A color that has a hexadecimal value of #FF008B8B.
DarkGoldenrod | A color that has a hexadecimal value of #FFB8860B.
DarkGray | A color that has a hexadecimal value of #FFA9A9A9.
DarkGreen | A color that has a hexadecimal value of #FF006400.
DarkKhaki | A color that has a hexadecimal value of #FFBDB76B.
DarkMagenta | A color that has a hexadecimal value of #FF8B008B.
DarkOliveGreen | A color that has a hexadecimal value of #FF556B2F.
DarkOrange | A color that has a hexadecimal value of #FFFF8C00.
DarkOrchid | A color that has a hexadecimal value of #FF9932CC.
DarkRed | A color that has a hexadecimal value of #FF8B0000.
DarkSalmon | A color that has a hexadecimal value of #FFE9967A.
DarkSeaGreen | A color that has a hexadecimal value of #FF8FBC8F.
DarkSlateBlue | A color that has a hexadecimal value of #FF483D8B.
DarkSlateGray | A color that has a hexadecimal value of #FF2F4F4F.
DarkTurquoise | A color that has a hexadecimal value of #FF00CED1.
DarkViolet | A color that has a hexadecimal value of #FF9400D3.
DeepPink | A color that has a hexadecimal value of #FFFF1493.
DeepSkyBlue | A color that has a hexadecimal value of #FF00BFFF.
DimGray | A color that has a hexadecimal value of #FF696969.
DodgerBlue | A color that has a hexadecimal value of #FF1E90FF.
Empty | A color that has a hexadecimal value of #00000000.
Firebrick | A color that has a hexadecimal value of #FFB22222.
FloralWhite | A color that has a hexadecimal value of #FFFFFAF0.
ForestGreen | A color that has a hexadecimal value of #FF228B22.
Fuchsia | A color that has a hexadecimal value of #FFFF00FF.
Gainsboro | A color that has a hexadecimal value of #FFDCDCDC.
GhostWhite | A color that has a hexadecimal value of #FFF8F8FF.
Gold | A color that has a hexadecimal value of #FFFFD700.
Goldenrod | A color that has a hexadecimal value of #FFDAA520.
Gray | A color that has a hexadecimal value of #FF808080.
Green | A color that has a hexadecimal value of #FF008000.
GreenYellow | A color that has a hexadecimal value of #FFADFF2F.
Highlight | A color that has a hexadecimal value of #FF3399FF.
Honeydew | A color that has a hexadecimal value of #FFF0FFF0.
HotPink | A color that has a hexadecimal value of #FFFF69B4.
IndianRed | A color that has a hexadecimal value of #FFCD5C5C.
Indigo | A color that has a hexadecimal value of #FF4B0082.
Ivory | A color that has a hexadecimal value of #FFFFFFF0.
Khaki | A color that has a hexadecimal value of #FFF0E68C.
Lavender | A color that has a hexadecimal value of #FFE6E6FA.
LavenderBlush | A color that has a hexadecimal value of #FFFFF0F5.
LawnGreen | A color that has a hexadecimal value of #FF7CFC00.
LemonChiffon | A color that has a hexadecimal value of #FFFFFACD.
LightBlue | A color that has a hexadecimal value of #FFADD8E6.
LightCoral | A color that has a hexadecimal value of #FFF08080.
LightCyan | A color that has a hexadecimal value of #FFE0FFFF.
LightGoldenrodYellow | A color that has a hexadecimal value of #FFFAFAD2.
LightGray | A color that has a hexadecimal value of #FFD3D3D3.
LightGreen | A color that has a hexadecimal value of #FF90EE90.
LightPink | A color that has a hexadecimal value of #FFFFB6C1.
LightSalmon | A color that has a hexadecimal value of #FFFFA07A.
LightSeaGreen | A color that has a hexadecimal value of #FF20B2AA.
LightSkyBlue | A color that has a hexadecimal value of #FF87CEFA.
LightSlateGray | A color that has a hexadecimal value of #FF778899.
LightSteelBlue | A color that has a hexadecimal value of #FFB0C4DE.
LightYellow | A color that has a hexadecimal value of #FFFFFFE0.
Lime | A color that has a hexadecimal value of #FF00FF00.
LimeGreen | A color that has a hexadecimal value of #FF32CD32.
Linen | A color that has a hexadecimal value of #FFFAF0E6.
Magenta | A color that has a hexadecimal value of #FFFF00FF.
Maroon | A color that has a hexadecimal value of #FF800000.
MediumAquamarine | A color that has a hexadecimal value of #FF66CDAA.
MediumBlue | A color that has a hexadecimal value of #FF0000CD.
MediumOrchid | A color that has a hexadecimal value of #FFBA55D3.
MediumPurple | A color that has a hexadecimal value of #FF9370DB.
MediumSeaGreen | A color that has a hexadecimal value of #FF3CB371.
MediumSlateBlue | A color that has a hexadecimal value of #FF7B68EE.
MediumSpringGreen | A color that has a hexadecimal value of #FF00FA9A.
MediumTurquoise | A color that has a hexadecimal value of #FF48D1CC.
MediumVioletRed | A color that has a hexadecimal value of #FFC71585.
MidnightBlue | A color that has a hexadecimal value of #FF191970.
MintCream | A color that has a hexadecimal value of #FFF5FFFA.
MistyRose | A color that has a hexadecimal value of #FFFFE4E1.
Moccasin | A color that has a hexadecimal value of #FFFFE4B5.
NavajoWhite | A color that has a hexadecimal value of #FFFFDEAD.
Navy | A color that has a hexadecimal value of #FF000080.
OldLace | A color that has a hexadecimal value of #FFFDF5E6.
Olive | A color that has a hexadecimal value of #FF808000.
OliveDrab | A color that has a hexadecimal value of #FF6B8E23.
Orange | A color that has a hexadecimal value of #FFFFA500.
OrangeRed | A color that has a hexadecimal value of #FFFF4500.
Orchid | A color that has a hexadecimal value of #FFDA70D6.
PaleGoldenrod | A color that has a hexadecimal value of #FFEEE8AA.
PaleGreen | A color that has a hexadecimal value of #FF98FB98.
PaleTurquoise | A color that has a hexadecimal value of #FFAFEEEE.
PaleVioletRed | A color that has a hexadecimal value of #FFDB7093.
PapayaWhip | A color that has a hexadecimal value of #FFFFEFD5.
PeachPuff | A color that has a hexadecimal value of #FFFFDAB9.
Peru | A color that has a hexadecimal value of #FFCD853F.
Pink | A color that has a hexadecimal value of #FFFFC0CB.
Plum | A color that has a hexadecimal value of #FFDDA0DD.
PowderBlue | A color that has a hexadecimal value of #FFB0E0E6.
Purple | A color that has a hexadecimal value of #FF800080.
Red | A color that has a hexadecimal value of #FFFF0000.
RosyBrown | A color that has a hexadecimal value of #FFBC8F8F.
RoyalBlue | A color that has a hexadecimal value of #FF4169E1.
SaddleBrown | A color that has a hexadecimal value of #FF8B4513.
Salmon | A color that has a hexadecimal value of #FFFA8072.
SandyBrown | A color that has a hexadecimal value of #FFF4A460.
SeaGreen | A color that has a hexadecimal value of #FF2E8B57.
SeaShell | A color that has a hexadecimal value of #FFFFF5EE.
Sienna | A color that has a hexadecimal value of #FFA0522D.
Silver | A color that has a hexadecimal value of #FFC0C0C0.
SkyBlue | A color that has a hexadecimal value of #FF87CEEB.
SlateBlue | A color that has a hexadecimal value of #FF6A5ACD.
SlateGray | A color that has a hexadecimal value of #FF708090.
Snow | A color that has a hexadecimal value of #FFFFFAFA.
SpringGreen | A color that has a hexadecimal value of #FF00FF7F.
SteelBlue | A color that has a hexadecimal value of #FF4682B4.
Tan | A color that has a hexadecimal value of #FFD2B48C.
Teal | A color that has a hexadecimal value of #FF008080.
Thistle | A color that has a hexadecimal value of #FFD8BFD8.
Tomato | A color that has a hexadecimal value of #FFFF6347.
Transparent | A color that has a hexadecimal value of #00FFFFFF.
Turquoise | A color that has a hexadecimal value of #FF40E0D0.
Violet | A color that has a hexadecimal value of #FFEE82EE.
Wheat | A color that has a hexadecimal value of #FFF5DEB3.
White | A color that has a hexadecimal value of #FFFFFFFF.
WhiteSmoke | A color that has a hexadecimal value of #FFF5F5F5.
Yellow | A color that has a hexadecimal value of #FFFFFF00.
YellowGreen | A color that has a hexadecimal value of #FF9ACD32.

See Also

Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors Fields

Colors Fields
[image]

Public Fields

Name | Description
AliceBlue | A color that has a hexadecimal value of #FFF0F8FF.
AntiqueWhite | A color that has a hexadecimal value of #FFFAEBD7.
Aqua | A color that has a hexadecimal value of #FF00FFFF.
Aquamarine | A color that has a hexadecimal value of #FF7FFFD4.
Azure | A color that has a hexadecimal value of #FFF0FFFF.
Beige | A color that has a hexadecimal value of #FFF5F5DC.
Bisque | A color that has a hexadecimal value of #FFFFE40C4.
Black | A color that has a hexadecimal value of #FF000000.
BlanchedAlmond | A color that has a hexadecimal value of #FFFFEBCD.
Blue | A color that has a hexadecimal value of #FF0000FF.
BlueViolet | A color that has a hexadecimal value of #FF8A2BE2.
Brown | A color that has a hexadecimal value of #FFA52A2A.
BurlyWood | A color that has a hexadecimal value of #FFDEB887.
CadetBlue | A color that has a hexadecimal value of #FF5F9EA0.
Chartreuse | A color that has a hexadecimal value of #FF7FFF00.
Chocolate | A color that has a hexadecimal value of #FFD2691E.
ControlDark | A color that has a hexadecimal value of #FFA0A0A0.
ControlDarkDark | A color that has a hexadecimal value of #FF696996.
ControlLight | A color that has a hexadecimal value of #FFE3E3E3.
ControlLightLight | A color that has a hexadecimal value of #FFFFFFFF.
Coral | A color that has a hexadecimal value of #FFFF7F50.
CornflowerBlue | A color that has a hexadecimal value of #FF6495ED.
Cornsilk | A color that has a hexadecimal value of #FFFFF8DC.
Crimson | A color that has a hexadecimal value of #FFDC143C.
Cyan | A color that has a hexadecimal value of #FF00FFFF.
DarkBlue | A color that has a hexadecimal value of #FF00008B.
DarkCyan | A color that has a hexadecimal value of #FF008B8B.
DarkGoldenrod | A color that has a hexadecimal value of #FFB8860B.
DarkGray | A color that has a hexadecimal value of #FFA9A9A9.
DarkGreen | A color that has a hexadecimal value of #FF006400.
DarkKhaki | A color that has a hexadecimal value of #FFBDB76B.
DarkMagenta | A color that has a hexadecimal value of #FF8B008B.
DarkOliveGreen | A color that has a hexadecimal value of #FF556B2F.
DarkOrange | A color that has a hexadecimal value of #FFFF8C00.
DarkOrchid | A color that has a hexadecimal value of #FF9932CC.
DarkRed | A color that has a hexadecimal value of #FF8B0000.
DarkSalmon | A color that has a hexadecimal value of #FFE9967A.
DarkSeaGreen | A color that has a hexadecimal value of #FF8FBC8F.
DarkSlateBlue | A color that has a hexadecimal value of #FF483D8B.
DarkSlateGray | A color that has a hexadecimal value of #FF2F4F4F.
DarkTurquoise | A color that has a hexadecimal value of #FF00CED1.
DarkViolet | A color that has a hexadecimal value of #FF9400D3.
DeepPink | A color that has a hexadecimal value of #FFFF1493.
DeepSkyBlue | A color that has a hexadecimal value of #FF00BFFF.
DimGray | A color that has a hexadecimal value of #FF696969.
DodgerBlue | A color that has a hexadecimal value of #FF1E90FF.
Empty | A color that has a hexadecimal value of #00000000.
Firebrick | A color that has a hexadecimal value of #FFB22222.
FloralWhite | A color that has a hexadecimal value of #FFFFFAF0.
ForestGreen | A color that has a hexadecimal value of #FF228B22.
Fuchsia | A color that has a hexadecimal value of #FFFF00FF.
Gainsboro | A color that has a hexadecimal value of #FFDCDCDC.
GhostWhite | A color that has a hexadecimal value of #FFF8F8FF.
Gold | A color that has a hexadecimal value of #FFFFD700.
Goldenrod | A color that has a hexadecimal value of #FFDAA520.
Gray | A color that has a hexadecimal value of #FF808080.
Green | A color that has a hexadecimal value of #FF008000.
GreenYellow | A color that has a hexadecimal value of #FFADFF2F.
Highlight | A color that has a hexadecimal value of #FF3399FF.
Honeydew | A color that has a hexadecimal value of #FFF0FFF0.
HotPink | A color that has a hexadecimal value of #FFFF69B4.
IndianRed | A color that has a hexadecimal value of #FFCD5C5C.
Indigo | A color that has a hexadecimal value of #FF4B0082.
Ivory | A color that has a hexadecimal value of #FFFFFFF0.
Khaki | A color that has a hexadecimal value of #FFF0E68C.
Lavender | A color that has a hexadecimal value of #FFE6E6FA.
LavenderBlush | A color that has a hexadecimal value of #FFFFF0F5.
LawnGreen | A color that has a hexadecimal value of #FF7CFC00.
LemonChiffon | A color that has a hexadecimal value of #FFFFFACD.
LightBlue | A color that has a hexadecimal value of #FFADD8E6.
LightCoral | A color that has a hexadecimal value of #FFF08080.
LightCyan | A color that has a hexadecimal value of #FFE0FFFF.
LightGoldenrodYellow | A color that has a hexadecimal value of #FFFAFAD2.
LightGray | A color that has a hexadecimal value of #FFD3D3D3.
LightGreen | A color that has a hexadecimal value of #FF90EE90.
LightPink | A color that has a hexadecimal value of #FFFFB6C1.
LightSalmon | A color that has a hexadecimal value of #FFFFA07A.
LightSeaGreen | A color that has a hexadecimal value of #FF20B2AA.
LightSkyBlue | A color that has a hexadecimal value of #FF87CEFA.
LightSlateGray | A color that has a hexadecimal value of #FF778899.
LightSteelBlue | A color that has a hexadecimal value of #FFB0C4DE.
LightYellow | A color that has a hexadecimal value of #FFFFFFE0.
Lime | A color that has a hexadecimal value of #FF00FF00.
LimeGreen | A color that has a hexadecimal value of #FF32CD32.
Linen | A color that has a hexadecimal value of #FFFAF0E6.
Magenta | A color that has a hexadecimal value of #FFFF00FF.
Maroon | A color that has a hexadecimal value of #FF800000.
MediumAquamarine | A color that has a hexadecimal value of #FF66CDAA.
MediumBlue | A color that has a hexadecimal value of #FF0000CD.
MediumOrchid | A color that has a hexadecimal value of #FFBA55D3.
MediumPurple | A color that has a hexadecimal value of #FF9370DB.
MediumSeaGreen | A color that has a hexadecimal value of #FF3CB371.
MediumSlateBlue | A color that has a hexadecimal value of #FF7B68EE.
MediumSpringGreen | A color that has a hexadecimal value of #FF00FA9A.
MediumTurquoise | A color that has a hexadecimal value of #FF48D1CC.
MediumVioletRed | A color that has a hexadecimal value of #FFC71585.
MidnightBlue | A color that has a hexadecimal value of #FF191970.
MintCream | A color that has a hexadecimal value of #FFF5FFFA.
MistyRose | A color that has a hexadecimal value of #FFFFE4E1.
Moccasin | A color that has a hexadecimal value of #FFFFE4B5.
NavajoWhite | A color that has a hexadecimal value of #FFFFDEAD.
Navy | A color that has a hexadecimal value of #FF000080.
OldLace | A color that has a hexadecimal value of #FFFDF5E6.
Olive | A color that has a hexadecimal value of #FF808000.
OliveDrab | A color that has a hexadecimal value of #FF6B8E23.
Orange | A color that has a hexadecimal value of #FFFFA500.
OrangeRed | A color that has a hexadecimal value of #FFFF4500.
Orchid | A color that has a hexadecimal value of #FFDA70D6.
PaleGoldenrod | A color that has a hexadecimal value of #FFEEE8AA.
PaleGreen | A color that has a hexadecimal value of #FF98FB98.
PaleTurquoise | A color that has a hexadecimal value of #FFAFEEEE.
PaleVioletRed | A color that has a hexadecimal value of #FFDB7093.
PapayaWhip | A color that has a hexadecimal value of #FFFFEFD5.
PeachPuff | A color that has a hexadecimal value of #FFFFDAB9.
Peru | A color that has a hexadecimal value of #FFCD853F.
Pink | A color that has a hexadecimal value of #FFFFC0CB.
Plum | A color that has a hexadecimal value of #FFDDA0DD.
PowderBlue | A color that has a hexadecimal value of #FFB0E0E6.
Purple | A color that has a hexadecimal value of #FF800080.
Red | A color that has a hexadecimal value of #FFFF0000.
RosyBrown | A color that has a hexadecimal value of #FFBC8F8F.
RoyalBlue | A color that has a hexadecimal value of #FF4169E1.
SaddleBrown | A color that has a hexadecimal value of #FF8B4513.
Salmon | A color that has a hexadecimal value of #FFFA8072.
SandyBrown | A color that has a hexadecimal value of #FFF4A460.
SeaGreen | A color that has a hexadecimal value of #FF2E8B57.
SeaShell | A color that has a hexadecimal value of #FFFFF5EE.
Sienna | A color that has a hexadecimal value of #FFA0522D.
Silver | A color that has a hexadecimal value of #FFC0C0C0.
SkyBlue | A color that has a hexadecimal value of #FF87CEEB.
SlateBlue | A color that has a hexadecimal value of #FF6A5ACD.
SlateGray | A color that has a hexadecimal value of #FF708090.
Snow | A color that has a hexadecimal value of #FFFFFAFA.
SpringGreen | A color that has a hexadecimal value of #FF00FF7F.
SteelBlue | A color that has a hexadecimal value of #FF4682B4.
Tan | A color that has a hexadecimal value of #FFD2B48C.
Teal | A color that has a hexadecimal value of #FF008080.
Thistle | A color that has a hexadecimal value of #FFD8BFD8.
Tomato | A color that has a hexadecimal value of #FFFF6347.
Transparent | A color that has a hexadecimal value of #00FFFFFF.
Turquoise | A color that has a hexadecimal value of #FF40E0D0.
Violet | A color that has a hexadecimal value of #FFEE82EE.
Wheat | A color that has a hexadecimal value of #FFF5DEB3.
White | A color that has a hexadecimal value of #FFFFFFFF.
WhiteSmoke | A color that has a hexadecimal value of #FFF5F5F5.
Yellow | A color that has a hexadecimal value of #FFFFFF00.
YellowGreen | A color that has a hexadecimal value of #FF9ACD32.

See Also

Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.AliceBlue Field

Colors.AliceBlue Field
[image]

A color that has a hexadecimal value of #FFF0F8FF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color AliceBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly AliceBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.AntiqueWhite Field

Colors.AntiqueWhite Field
[image]

A color that has a hexadecimal value of #FFFAEBD7.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color AntiqueWhite

Visual Basic [image] Copy Code

Public Shared ReadOnly AntiqueWhite As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Aqua Field

Colors.Aqua Field
[image]

A color that has a hexadecimal value of #FF00FFFF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Aqua

Visual Basic [image] Copy Code

Public Shared ReadOnly Aqua As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Aquamarine Field

Colors.Aquamarine Field
[image]

A color that has a hexadecimal value of #FF7FFFD4.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Aquamarine

Visual Basic [image] Copy Code

Public Shared ReadOnly Aquamarine As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Azure Field

Colors.Azure Field
[image]

A color that has a hexadecimal value of #FFF0FFFF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Azure

Visual Basic [image] Copy Code

Public Shared ReadOnly Azure As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Beige Field

Colors.Beige Field
[image]

A color that has a hexadecimal value of #FFF5F5DC.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Beige

Visual Basic [image] Copy Code

Public Shared ReadOnly Beige As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Bisque Field

Colors.Bisque Field
[image]

A color that has a hexadecimal value of #FFFFE40C4.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Bisque

Visual Basic [image] Copy Code

Public Shared ReadOnly Bisque As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Black Field

Colors.Black Field
[image]

A color that has a hexadecimal value of #FF000000.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Black

Visual Basic [image] Copy Code

Public Shared ReadOnly Black As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.BlanchedAlmond Field

Colors.BlanchedAlmond Field
[image]

A color that has a hexadecimal value of #FFFFEBCD.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color BlanchedAlmond

Visual Basic [image] Copy Code

Public Shared ReadOnly BlanchedAlmond As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Blue Field

Colors.Blue Field
[image]

A color that has a hexadecimal value of #FF0000FF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Blue

Visual Basic [image] Copy Code

Public Shared ReadOnly Blue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.BlueViolet Field

Colors.BlueViolet Field
[image]

A color that has a hexadecimal value of #FF8A2BE2.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color BlueViolet

Visual Basic [image] Copy Code

Public Shared ReadOnly BlueViolet As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Brown Field

Colors.Brown Field
[image]

A color that has a hexadecimal value of #FFA52A2A.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Brown

Visual Basic [image] Copy Code

Public Shared ReadOnly Brown As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.BurlyWood Field

Colors.BurlyWood Field
[image]

A color that has a hexadecimal value of #FFDEB887.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color BurlyWood

Visual Basic [image] Copy Code

Public Shared ReadOnly BurlyWood As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.CadetBlue Field

Colors.CadetBlue Field
[image]

A color that has a hexadecimal value of #FF5F9EA0.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color CadetBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly CadetBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Chartreuse Field

Colors.Chartreuse Field
[image]

A color that has a hexadecimal value of #FF7FFF00.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Chartreuse

Visual Basic [image] Copy Code

Public Shared ReadOnly Chartreuse As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Chocolate Field

Colors.Chocolate Field
[image]

A color that has a hexadecimal value of #FFD2691E.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Chocolate

Visual Basic [image] Copy Code

Public Shared ReadOnly Chocolate As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.ControlDark Field

Colors.ControlDark Field
[image]

A color that has a hexadecimal value of #FFA0A0A0.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color ControlDark

Visual Basic [image] Copy Code

Public Shared ReadOnly ControlDark As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.ControlDarkDark Field

Colors.ControlDarkDark Field
[image]

A color that has a hexadecimal value of #FF696996.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color ControlDarkDark

Visual Basic [image] Copy Code

Public Shared ReadOnly ControlDarkDark As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.ControlLight Field

Colors.ControlLight Field
[image]

A color that has a hexadecimal value of #FFE3E3E3.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color ControlLight

Visual Basic [image] Copy Code

Public Shared ReadOnly ControlLight As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.ControlLightLight Field

Colors.ControlLightLight Field
[image]

A color that has a hexadecimal value of #FFFFFFFF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color ControlLightLight

Visual Basic [image] Copy Code

Public Shared ReadOnly ControlLightLight As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Coral Field

Colors.Coral Field
[image]

A color that has a hexadecimal value of #FFFF7F50.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Coral

Visual Basic [image] Copy Code

Public Shared ReadOnly Coral As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.CornflowerBlue Field

Colors.CornflowerBlue Field
[image]

A color that has a hexadecimal value of #FF6495ED.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color CornflowerBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly CornflowerBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Cornsilk Field

Colors.Cornsilk Field
[image]

A color that has a hexadecimal value of #FFFFF8DC.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Cornsilk

Visual Basic [image] Copy Code

Public Shared ReadOnly Cornsilk As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Crimson Field

Colors.Crimson Field
[image]

A color that has a hexadecimal value of #FFDC143C.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Crimson

Visual Basic [image] Copy Code

Public Shared ReadOnly Crimson As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Cyan Field

Colors.Cyan Field
[image]

A color that has a hexadecimal value of #FF00FFFF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Cyan

Visual Basic [image] Copy Code

Public Shared ReadOnly Cyan As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkBlue Field

Colors.DarkBlue Field
[image]

A color that has a hexadecimal value of #FF00008B.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkCyan Field

Colors.DarkCyan Field
[image]

A color that has a hexadecimal value of #FF008B8B.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkCyan

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkCyan As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkGoldenrod Field

Colors.DarkGoldenrod Field
[image]

A color that has a hexadecimal value of #FFB8860B.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkGoldenrod

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkGoldenrod As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkGray Field

Colors.DarkGray Field
[image]

A color that has a hexadecimal value of #FFA9A9A9.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkGray

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkGray As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkGreen Field

Colors.DarkGreen Field
[image]

A color that has a hexadecimal value of #FF006400.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkKhaki Field

Colors.DarkKhaki Field
[image]

A color that has a hexadecimal value of #FFBDB76B.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkKhaki

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkKhaki As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkMagenta Field

Colors.DarkMagenta Field
[image]

A color that has a hexadecimal value of #FF8B008B.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkMagenta

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkMagenta As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkOliveGreen Field

Colors.DarkOliveGreen Field
[image]

A color that has a hexadecimal value of #FF556B2F.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkOliveGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkOliveGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkOrange Field

Colors.DarkOrange Field
[image]

A color that has a hexadecimal value of #FFFF8C00.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkOrange

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkOrange As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkOrchid Field

Colors.DarkOrchid Field
[image]

A color that has a hexadecimal value of #FF9932CC.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkOrchid

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkOrchid As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkRed Field

Colors.DarkRed Field
[image]

A color that has a hexadecimal value of #FF8B0000.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkRed

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkRed As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkSalmon Field

Colors.DarkSalmon Field
[image]

A color that has a hexadecimal value of #FFE9967A.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkSalmon

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkSalmon As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkSeaGreen Field

Colors.DarkSeaGreen Field
[image]

A color that has a hexadecimal value of #FF8FBC8F.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkSeaGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkSeaGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkSlateBlue Field

Colors.DarkSlateBlue Field
[image]

A color that has a hexadecimal value of #FF483D8B.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkSlateBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkSlateBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkSlateGray Field

Colors.DarkSlateGray Field
[image]

A color that has a hexadecimal value of #FF2F4F4F.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkSlateGray

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkSlateGray As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkTurquoise Field

Colors.DarkTurquoise Field
[image]

A color that has a hexadecimal value of #FF00CED1.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkTurquoise

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkTurquoise As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DarkViolet Field

Colors.DarkViolet Field
[image]

A color that has a hexadecimal value of #FF9400D3.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DarkViolet

Visual Basic [image] Copy Code

Public Shared ReadOnly DarkViolet As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DeepPink Field

Colors.DeepPink Field
[image]

A color that has a hexadecimal value of #FFFF1493.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DeepPink

Visual Basic [image] Copy Code

Public Shared ReadOnly DeepPink As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DeepSkyBlue Field

Colors.DeepSkyBlue Field
[image]

A color that has a hexadecimal value of #FF00BFFF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DeepSkyBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly DeepSkyBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DimGray Field

Colors.DimGray Field
[image]

A color that has a hexadecimal value of #FF696969.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DimGray

Visual Basic [image] Copy Code

Public Shared ReadOnly DimGray As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.DodgerBlue Field

Colors.DodgerBlue Field
[image]

A color that has a hexadecimal value of #FF1E90FF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color DodgerBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly DodgerBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Empty Field

Colors.Empty Field
[image]

A color that has a hexadecimal value of #00000000.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Empty

Visual Basic [image] Copy Code

Public Shared ReadOnly Empty As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Firebrick Field

Colors.Firebrick Field
[image]

A color that has a hexadecimal value of #FFB22222.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Firebrick

Visual Basic [image] Copy Code

Public Shared ReadOnly Firebrick As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.FloralWhite Field

Colors.FloralWhite Field
[image]

A color that has a hexadecimal value of #FFFFFAF0.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color FloralWhite

Visual Basic [image] Copy Code

Public Shared ReadOnly FloralWhite As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.ForestGreen Field

Colors.ForestGreen Field
[image]

A color that has a hexadecimal value of #FF228B22.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color ForestGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly ForestGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Fuchsia Field

Colors.Fuchsia Field
[image]

A color that has a hexadecimal value of #FFFF00FF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Fuchsia

Visual Basic [image] Copy Code

Public Shared ReadOnly Fuchsia As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Gainsboro Field

Colors.Gainsboro Field
[image]

A color that has a hexadecimal value of #FFDCDCDC.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Gainsboro

Visual Basic [image] Copy Code

Public Shared ReadOnly Gainsboro As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.GhostWhite Field

Colors.GhostWhite Field
[image]

A color that has a hexadecimal value of #FFF8F8FF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color GhostWhite

Visual Basic [image] Copy Code

Public Shared ReadOnly GhostWhite As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Gold Field

Colors.Gold Field
[image]

A color that has a hexadecimal value of #FFFFD700.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Gold

Visual Basic [image] Copy Code

Public Shared ReadOnly Gold As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Goldenrod Field

Colors.Goldenrod Field
[image]

A color that has a hexadecimal value of #FFDAA520.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Goldenrod

Visual Basic [image] Copy Code

Public Shared ReadOnly Goldenrod As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Gray Field

Colors.Gray Field
[image]

A color that has a hexadecimal value of #FF808080.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Gray

Visual Basic [image] Copy Code

Public Shared ReadOnly Gray As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Green Field

Colors.Green Field
[image]

A color that has a hexadecimal value of #FF008000.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Green

Visual Basic [image] Copy Code

Public Shared ReadOnly Green As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.GreenYellow Field

Colors.GreenYellow Field
[image]

A color that has a hexadecimal value of #FFADFF2F.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color GreenYellow

Visual Basic [image] Copy Code

Public Shared ReadOnly GreenYellow As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Highlight Field

Colors.Highlight Field
[image]

A color that has a hexadecimal value of #FF3399FF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Highlight

Visual Basic [image] Copy Code

Public Shared ReadOnly Highlight As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Honeydew Field

Colors.Honeydew Field
[image]

A color that has a hexadecimal value of #FFF0FFF0.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Honeydew

Visual Basic [image] Copy Code

Public Shared ReadOnly Honeydew As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.HotPink Field

Colors.HotPink Field
[image]

A color that has a hexadecimal value of #FFFF69B4.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color HotPink

Visual Basic [image] Copy Code

Public Shared ReadOnly HotPink As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.IndianRed Field

Colors.IndianRed Field
[image]

A color that has a hexadecimal value of #FFCD5C5C.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color IndianRed

Visual Basic [image] Copy Code

Public Shared ReadOnly IndianRed As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Indigo Field

Colors.Indigo Field
[image]

A color that has a hexadecimal value of #FF4B0082.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Indigo

Visual Basic [image] Copy Code

Public Shared ReadOnly Indigo As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Ivory Field

Colors.Ivory Field
[image]

A color that has a hexadecimal value of #FFFFFFF0.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Ivory

Visual Basic [image] Copy Code

Public Shared ReadOnly Ivory As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Khaki Field

Colors.Khaki Field
[image]

A color that has a hexadecimal value of #FFF0E68C.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Khaki

Visual Basic [image] Copy Code

Public Shared ReadOnly Khaki As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Lavender Field

Colors.Lavender Field
[image]

A color that has a hexadecimal value of #FFE6E6FA.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Lavender

Visual Basic [image] Copy Code

Public Shared ReadOnly Lavender As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LavenderBlush Field

Colors.LavenderBlush Field
[image]

A color that has a hexadecimal value of #FFFFF0F5.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LavenderBlush

Visual Basic [image] Copy Code

Public Shared ReadOnly LavenderBlush As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LawnGreen Field

Colors.LawnGreen Field
[image]

A color that has a hexadecimal value of #FF7CFC00.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LawnGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly LawnGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LemonChiffon Field

Colors.LemonChiffon Field
[image]

A color that has a hexadecimal value of #FFFFFACD.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LemonChiffon

Visual Basic [image] Copy Code

Public Shared ReadOnly LemonChiffon As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightBlue Field

Colors.LightBlue Field
[image]

A color that has a hexadecimal value of #FFADD8E6.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly LightBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightCoral Field

Colors.LightCoral Field
[image]

A color that has a hexadecimal value of #FFF08080.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightCoral

Visual Basic [image] Copy Code

Public Shared ReadOnly LightCoral As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightCyan Field

Colors.LightCyan Field
[image]

A color that has a hexadecimal value of #FFE0FFFF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightCyan

Visual Basic [image] Copy Code

Public Shared ReadOnly LightCyan As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightGoldenrodYellow Field

Colors.LightGoldenrodYellow Field
[image]

A color that has a hexadecimal value of #FFFAFAD2.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightGoldenrodYellow

Visual Basic [image] Copy Code

Public Shared ReadOnly LightGoldenrodYellow As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightGray Field

Colors.LightGray Field
[image]

A color that has a hexadecimal value of #FFD3D3D3.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightGray

Visual Basic [image] Copy Code

Public Shared ReadOnly LightGray As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightGreen Field

Colors.LightGreen Field
[image]

A color that has a hexadecimal value of #FF90EE90.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly LightGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightPink Field

Colors.LightPink Field
[image]

A color that has a hexadecimal value of #FFFFB6C1.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightPink

Visual Basic [image] Copy Code

Public Shared ReadOnly LightPink As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightSalmon Field

Colors.LightSalmon Field
[image]

A color that has a hexadecimal value of #FFFFA07A.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightSalmon

Visual Basic [image] Copy Code

Public Shared ReadOnly LightSalmon As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightSeaGreen Field

Colors.LightSeaGreen Field
[image]

A color that has a hexadecimal value of #FF20B2AA.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightSeaGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly LightSeaGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightSkyBlue Field

Colors.LightSkyBlue Field
[image]

A color that has a hexadecimal value of #FF87CEFA.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightSkyBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly LightSkyBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightSlateGray Field

Colors.LightSlateGray Field
[image]

A color that has a hexadecimal value of #FF778899.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightSlateGray

Visual Basic [image] Copy Code

Public Shared ReadOnly LightSlateGray As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightSteelBlue Field

Colors.LightSteelBlue Field
[image]

A color that has a hexadecimal value of #FFB0C4DE.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightSteelBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly LightSteelBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LightYellow Field

Colors.LightYellow Field
[image]

A color that has a hexadecimal value of #FFFFFFE0.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LightYellow

Visual Basic [image] Copy Code

Public Shared ReadOnly LightYellow As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Lime Field

Colors.Lime Field
[image]

A color that has a hexadecimal value of #FF00FF00.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Lime

Visual Basic [image] Copy Code

Public Shared ReadOnly Lime As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.LimeGreen Field

Colors.LimeGreen Field
[image]

A color that has a hexadecimal value of #FF32CD32.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color LimeGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly LimeGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Linen Field

Colors.Linen Field
[image]

A color that has a hexadecimal value of #FFFAF0E6.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Linen

Visual Basic [image] Copy Code

Public Shared ReadOnly Linen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Magenta Field

Colors.Magenta Field
[image]

A color that has a hexadecimal value of #FFFF00FF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Magenta

Visual Basic [image] Copy Code

Public Shared ReadOnly Magenta As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Maroon Field

Colors.Maroon Field
[image]

A color that has a hexadecimal value of #FF800000.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Maroon

Visual Basic [image] Copy Code

Public Shared ReadOnly Maroon As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MediumAquamarine Field

Colors.MediumAquamarine Field
[image]

A color that has a hexadecimal value of #FF66CDAA.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MediumAquamarine

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumAquamarine As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MediumBlue Field

Colors.MediumBlue Field
[image]

A color that has a hexadecimal value of #FF0000CD.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MediumBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MediumOrchid Field

Colors.MediumOrchid Field
[image]

A color that has a hexadecimal value of #FFBA55D3.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MediumOrchid

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumOrchid As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MediumPurple Field

Colors.MediumPurple Field
[image]

A color that has a hexadecimal value of #FF9370DB.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MediumPurple

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumPurple As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MediumSeaGreen Field

Colors.MediumSeaGreen Field
[image]

A color that has a hexadecimal value of #FF3CB371.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MediumSeaGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumSeaGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MediumSlateBlue Field

Colors.MediumSlateBlue Field
[image]

A color that has a hexadecimal value of #FF7B68EE.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MediumSlateBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumSlateBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MediumSpringGreen Field

Colors.MediumSpringGreen Field
[image]

A color that has a hexadecimal value of #FF00FA9A.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MediumSpringGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumSpringGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MediumTurquoise Field

Colors.MediumTurquoise Field
[image]

A color that has a hexadecimal value of #FF48D1CC.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MediumTurquoise

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumTurquoise As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MediumVioletRed Field

Colors.MediumVioletRed Field
[image]

A color that has a hexadecimal value of #FFC71585.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MediumVioletRed

Visual Basic [image] Copy Code

Public Shared ReadOnly MediumVioletRed As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MidnightBlue Field

Colors.MidnightBlue Field
[image]

A color that has a hexadecimal value of #FF191970.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MidnightBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly MidnightBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MintCream Field

Colors.MintCream Field
[image]

A color that has a hexadecimal value of #FFF5FFFA.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MintCream

Visual Basic [image] Copy Code

Public Shared ReadOnly MintCream As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.MistyRose Field

Colors.MistyRose Field
[image]

A color that has a hexadecimal value of #FFFFE4E1.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color MistyRose

Visual Basic [image] Copy Code

Public Shared ReadOnly MistyRose As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Moccasin Field

Colors.Moccasin Field
[image]

A color that has a hexadecimal value of #FFFFE4B5.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Moccasin

Visual Basic [image] Copy Code

Public Shared ReadOnly Moccasin As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.NavajoWhite Field

Colors.NavajoWhite Field
[image]

A color that has a hexadecimal value of #FFFFDEAD.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color NavajoWhite

Visual Basic [image] Copy Code

Public Shared ReadOnly NavajoWhite As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Navy Field

Colors.Navy Field
[image]

A color that has a hexadecimal value of #FF000080.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Navy

Visual Basic [image] Copy Code

Public Shared ReadOnly Navy As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.OldLace Field

Colors.OldLace Field
[image]

A color that has a hexadecimal value of #FFFDF5E6.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color OldLace

Visual Basic [image] Copy Code

Public Shared ReadOnly OldLace As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Olive Field

Colors.Olive Field
[image]

A color that has a hexadecimal value of #FF808000.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Olive

Visual Basic [image] Copy Code

Public Shared ReadOnly Olive As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.OliveDrab Field

Colors.OliveDrab Field
[image]

A color that has a hexadecimal value of #FF6B8E23.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color OliveDrab

Visual Basic [image] Copy Code

Public Shared ReadOnly OliveDrab As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Orange Field

Colors.Orange Field
[image]

A color that has a hexadecimal value of #FFFFA500.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Orange

Visual Basic [image] Copy Code

Public Shared ReadOnly Orange As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.OrangeRed Field

Colors.OrangeRed Field
[image]

A color that has a hexadecimal value of #FFFF4500.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color OrangeRed

Visual Basic [image] Copy Code

Public Shared ReadOnly OrangeRed As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Orchid Field

Colors.Orchid Field
[image]

A color that has a hexadecimal value of #FFDA70D6.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Orchid

Visual Basic [image] Copy Code

Public Shared ReadOnly Orchid As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.PaleGoldenrod Field

Colors.PaleGoldenrod Field
[image]

A color that has a hexadecimal value of #FFEEE8AA.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color PaleGoldenrod

Visual Basic [image] Copy Code

Public Shared ReadOnly PaleGoldenrod As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.PaleGreen Field

Colors.PaleGreen Field
[image]

A color that has a hexadecimal value of #FF98FB98.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color PaleGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly PaleGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.PaleTurquoise Field

Colors.PaleTurquoise Field
[image]

A color that has a hexadecimal value of #FFAFEEEE.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color PaleTurquoise

Visual Basic [image] Copy Code

Public Shared ReadOnly PaleTurquoise As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.PaleVioletRed Field

Colors.PaleVioletRed Field
[image]

A color that has a hexadecimal value of #FFDB7093.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color PaleVioletRed

Visual Basic [image] Copy Code

Public Shared ReadOnly PaleVioletRed As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.PapayaWhip Field

Colors.PapayaWhip Field
[image]

A color that has a hexadecimal value of #FFFFEFD5.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color PapayaWhip

Visual Basic [image] Copy Code

Public Shared ReadOnly PapayaWhip As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.PeachPuff Field

Colors.PeachPuff Field
[image]

A color that has a hexadecimal value of #FFFFDAB9.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color PeachPuff

Visual Basic [image] Copy Code

Public Shared ReadOnly PeachPuff As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Peru Field

Colors.Peru Field
[image]

A color that has a hexadecimal value of #FFCD853F.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Peru

Visual Basic [image] Copy Code

Public Shared ReadOnly Peru As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Pink Field

Colors.Pink Field
[image]

A color that has a hexadecimal value of #FFFFC0CB.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Pink

Visual Basic [image] Copy Code

Public Shared ReadOnly Pink As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Plum Field

Colors.Plum Field
[image]

A color that has a hexadecimal value of #FFDDA0DD.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Plum

Visual Basic [image] Copy Code

Public Shared ReadOnly Plum As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.PowderBlue Field

Colors.PowderBlue Field
[image]

A color that has a hexadecimal value of #FFB0E0E6.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color PowderBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly PowderBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Purple Field

Colors.Purple Field
[image]

A color that has a hexadecimal value of #FF800080.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Purple

Visual Basic [image] Copy Code

Public Shared ReadOnly Purple As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Red Field

Colors.Red Field
[image]

A color that has a hexadecimal value of #FFFF0000.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Red

Visual Basic [image] Copy Code

Public Shared ReadOnly Red As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.RosyBrown Field

Colors.RosyBrown Field
[image]

A color that has a hexadecimal value of #FFBC8F8F.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color RosyBrown

Visual Basic [image] Copy Code

Public Shared ReadOnly RosyBrown As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.RoyalBlue Field

Colors.RoyalBlue Field
[image]

A color that has a hexadecimal value of #FF4169E1.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color RoyalBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly RoyalBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.SaddleBrown Field

Colors.SaddleBrown Field
[image]

A color that has a hexadecimal value of #FF8B4513.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color SaddleBrown

Visual Basic [image] Copy Code

Public Shared ReadOnly SaddleBrown As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Salmon Field

Colors.Salmon Field
[image]

A color that has a hexadecimal value of #FFFA8072.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Salmon

Visual Basic [image] Copy Code

Public Shared ReadOnly Salmon As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.SandyBrown Field

Colors.SandyBrown Field
[image]

A color that has a hexadecimal value of #FFF4A460.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color SandyBrown

Visual Basic [image] Copy Code

Public Shared ReadOnly SandyBrown As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.SeaGreen Field

Colors.SeaGreen Field
[image]

A color that has a hexadecimal value of #FF2E8B57.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color SeaGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly SeaGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.SeaShell Field

Colors.SeaShell Field
[image]

A color that has a hexadecimal value of #FFFFF5EE.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color SeaShell

Visual Basic [image] Copy Code

Public Shared ReadOnly SeaShell As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Sienna Field

Colors.Sienna Field
[image]

A color that has a hexadecimal value of #FFA0522D.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Sienna

Visual Basic [image] Copy Code

Public Shared ReadOnly Sienna As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Silver Field

Colors.Silver Field
[image]

A color that has a hexadecimal value of #FFC0C0C0.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Silver

Visual Basic [image] Copy Code

Public Shared ReadOnly Silver As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.SkyBlue Field

Colors.SkyBlue Field
[image]

A color that has a hexadecimal value of #FF87CEEB.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color SkyBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly SkyBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.SlateBlue Field

Colors.SlateBlue Field
[image]

A color that has a hexadecimal value of #FF6A5ACD.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color SlateBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly SlateBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.SlateGray Field

Colors.SlateGray Field
[image]

A color that has a hexadecimal value of #FF708090.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color SlateGray

Visual Basic [image] Copy Code

Public Shared ReadOnly SlateGray As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Snow Field

Colors.Snow Field
[image]

A color that has a hexadecimal value of #FFFFFAFA.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Snow

Visual Basic [image] Copy Code

Public Shared ReadOnly Snow As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.SpringGreen Field

Colors.SpringGreen Field
[image]

A color that has a hexadecimal value of #FF00FF7F.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color SpringGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly SpringGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.SteelBlue Field

Colors.SteelBlue Field
[image]

A color that has a hexadecimal value of #FF4682B4.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color SteelBlue

Visual Basic [image] Copy Code

Public Shared ReadOnly SteelBlue As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Tan Field

Colors.Tan Field
[image]

A color that has a hexadecimal value of #FFD2B48C.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Tan

Visual Basic [image] Copy Code

Public Shared ReadOnly Tan As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Teal Field

Colors.Teal Field
[image]

A color that has a hexadecimal value of #FF008080.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Teal

Visual Basic [image] Copy Code

Public Shared ReadOnly Teal As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Thistle Field

Colors.Thistle Field
[image]

A color that has a hexadecimal value of #FFD8BFD8.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Thistle

Visual Basic [image] Copy Code

Public Shared ReadOnly Thistle As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Tomato Field

Colors.Tomato Field
[image]

A color that has a hexadecimal value of #FFFF6347.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Tomato

Visual Basic [image] Copy Code

Public Shared ReadOnly Tomato As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Transparent Field

Colors.Transparent Field
[image]

A color that has a hexadecimal value of #00FFFFFF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Transparent

Visual Basic [image] Copy Code

Public Shared ReadOnly Transparent As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Turquoise Field

Colors.Turquoise Field
[image]

A color that has a hexadecimal value of #FF40E0D0.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Turquoise

Visual Basic [image] Copy Code

Public Shared ReadOnly Turquoise As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Violet Field

Colors.Violet Field
[image]

A color that has a hexadecimal value of #FFEE82EE.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Violet

Visual Basic [image] Copy Code

Public Shared ReadOnly Violet As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Wheat Field

Colors.Wheat Field
[image]

A color that has a hexadecimal value of #FFF5DEB3.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Wheat

Visual Basic [image] Copy Code

Public Shared ReadOnly Wheat As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.White Field

Colors.White Field
[image]

A color that has a hexadecimal value of #FFFFFFFF.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color White

Visual Basic [image] Copy Code

Public Shared ReadOnly White As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.WhiteSmoke Field

Colors.WhiteSmoke Field
[image]

A color that has a hexadecimal value of #FFF5F5F5.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color WhiteSmoke

Visual Basic [image] Copy Code

Public Shared ReadOnly WhiteSmoke As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.Yellow Field

Colors.Yellow Field
[image]

A color that has a hexadecimal value of #FFFFFF00.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color Yellow

Visual Basic [image] Copy Code

Public Shared ReadOnly Yellow As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Colors.YellowGreen Field

Colors.YellowGreen Field
[image]

A color that has a hexadecimal value of #FF9ACD32.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly Color YellowGreen

Visual Basic [image] Copy Code

Public Shared ReadOnly YellowGreen As Color

See Also

Colors Members
Colors Class
MindFusion.Drawing Namespace


MindFusion.Drawing.CombineMode Enumeration

CombineMode Enumeration
[image]

Specifies how different clipping regions can be combined.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum CombineMode

Visual Basic [image] Copy Code

Public Enum CombineMode

Members

Member name | Description
Complement | Specifies that the existing region is replaced by the result of the existing region being removed from the new region. Said differently, the existing region is excluded from the new region.
Exclude | Specifies that the existing region is replaced by the result of the new region being removed from the existing region. Said differently, the new region is excluded from the existing region.
Intersect | Two clipping regions are combined by taking their intersection.
Replace | One clipping region is replaced by another.
Union | Two clipping regions are combined by taking the union of both.
Xor | Two clipping regions are combined by taking only the areas enclosed by one or the other region, but not both.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.ContentAlignment Enumeration

ContentAlignment Enumeration
[image]

Specifies alignment of content on the drawing surface.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum ContentAlignment

Visual Basic [image] Copy Code

Public Enum ContentAlignment

Members

Member name | Description
BottomCenter | Content is vertically aligned at the bottom, and horizontally aligned at the center.
BottomLeft | Content is vertically aligned at the bottom, and horizontally aligned on the left.
BottomRight | Content is vertically aligned at the bottom, and horizontally aligned on the right.
MiddleCenter | Content is vertically aligned in the middle, and horizontally aligned at the center.
MiddleLeft | Content is vertically aligned in the middle, and horizontally aligned on the left.
MiddleRight | Content is vertically aligned in the middle, and horizontally aligned on the right.
TopCenter | Content is vertically aligned at the top, and horizontally aligned at the center.
TopLeft | Content is vertically aligned at the top, and horizontally aligned on the left.
TopRight | Content is vertically aligned at the top, and horizontally aligned on the right.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.CursorHint Enumeration

CursorHint Enumeration
[image]

Specifies what mouse cursor to display while a user interacts with the diagram.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum CursorHint

Visual Basic [image] Copy Code

Public Enum CursorHint

Members

Member name | Description
AllowLink | Indicates the cursor specified by the AllowLinkCursor property.
CounterDiagonalResize | Indicates the cursor specified by the CounterDiagonalResizeCursor property.
DiagonalResize | Indicates the cursor specified by the DiagonalResizeCursor property.
Disallow | Indicates the cursor specified by the DisallowCursor property.
DisallowLink | Indicates the cursor specified by the DisallowLinkCursor property.
DontChange | Indicates the cursor specified by the Cursor property.
DrawLink | Indicates the cursor specified by the DrawLinkCursor property.
EditText | Indicates the cursor specified by the EditTextCursor property.
HorizontalResize | Indicates the cursor specified by the HorizontalResizeCursor property.
Move | Indicates the cursor specified by the MoveCursor property.
Pointer | Indicates the cursor specified by the PointerCursor property.
Rotate | Indicates the cursor specified by the RotateCursor property.
VerticalResize | Indicates the cursor specified by the VerticalResizeCursor property.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.DashStyle Enumeration

DashStyle Enumeration
[image]

Specifies the style of dashed lines.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum DashStyle

Visual Basic [image] Copy Code

Public Enum DashStyle

Members

Member name | Description
Custom | Specifies a user-defined dash style.
Dash | Specifies a line consisting of dashes.
DashDot | Specifies a line consisting of a repeating pattern of dash-dot.
DashDotDot | Specifies a line consisting of a repeating pattern of dash-dot-dot.
Dot | Specifies a line consisting of dots.
Solid | Specifies a solid line.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.FillMode Enumeration

FillMode Enumeration
[image]

Specifies how the interior of a closed path is filled.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum FillMode

Visual Basic [image] Copy Code

Public Enum FillMode

Members

Member name | Description
Alternate | Specifies the alternate fill mode.
Winding | Specifies the winding fill mode.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory Class

GraphicsFactory Class
[image]

A factory class for various graphical objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class GraphicsFactory

Visual Basic [image] Copy Code

Public NotInheritable Class GraphicsFactory

Inheritance Hierarchy

System.Object
MindFusion.Drawing.GraphicsFactory

See Also

GraphicsFactory Members
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory Members

GraphicsFactory Members
Properties Methods
[image]

A factory class for various graphical objects.

The following tables list the members exposed by the GraphicsFactory type.

Public Properties

Name | Description
IsContextReady | Gets a value indicating whether the factory is ready for use.

Public Methods

Name | Description
CreateGraphics | Creates an IGraphics object.
CreateImageGraphics | Creates an IGraphics object specifically to output to an image.
CreateMatrix | Creates an IMatrix object.
CreatePath | Overloaded.

See Also

GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory Methods

GraphicsFactory Methods
[image]

Public Methods

Name | Description
CreateGraphics | Creates an IGraphics object.
CreateImageGraphics | Creates an IGraphics object specifically to output to an image.
CreateMatrix | Creates an IMatrix object.
CreatePath | Overloaded.

See Also

GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory.CreateGraphics Method

GraphicsFactory.CreateGraphics Method
[image]

Creates an IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static IGraphics CreateGraphics ()

Visual Basic [image] Copy Code

Public Shared Function CreateGraphics () As IGraphics

Return Value

An instance of the IGraphics interface.

See Also

GraphicsFactory Members
GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory.CreateImageGraphics Method

GraphicsFactory.CreateImageGraphics Method
[image]

Creates an IGraphics object specifically to output to an image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static IGraphics CreateImageGraphics (
Rect bounds
)

Visual Basic [image] Copy Code

Public Shared Function CreateImageGraphics( _
bounds As Rect _
) As IGraphics

Parameters

bounds

Return Value

An instance of the IGraphics interface.

See Also

GraphicsFactory Members
GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory.CreateMatrix Method

GraphicsFactory.CreateMatrix Method
[image]

Creates an IMatrix object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static IMatrix CreateMatrix ()

Visual Basic [image] Copy Code

Public Shared Function CreateMatrix () As IMatrix

Return Value

An instance of the IMatrix interface.

See Also

GraphicsFactory Members
GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory.CreatePath Method

GraphicsFactory.CreatePath Method
[image]

Overload List

Name | Description
GraphicsFactory.CreatePath () | Creates an IGraphicsPath object.
GraphicsFactory.CreatePath (FillMode) | Creates an IGraphicsPath object with the specified fill mode.
GraphicsFactory.CreatePath (Rect) | Creates an IGraphicsPath object from the specified rectangle.

See Also

GraphicsFactory Members
GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory.CreatePath Method ()

GraphicsFactory.CreatePath Method ()
See Also
[image]

Creates an IGraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static IGraphicsPath CreatePath ()

Visual Basic [image] Copy Code

Public Shared Function CreatePath () As IGraphicsPath

Return Value

An instance of the IGraphicsPath interface.

See Also

CreatePath Method Overload List
GraphicsFactory Members
GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory.CreatePath Method (FillMode)

GraphicsFactory.CreatePath Method (FillMode)
See Also
[image]

Creates an IGraphicsPath object with the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static IGraphicsPath CreatePath (
FillMode fillMode
)

Visual Basic [image] Copy Code

Public Shared Function CreatePath( _
fillMode As FillMode _
) As IGraphicsPath

Parameters

fillMode

A member of the FillMode enumeration.

Return Value

An instance of the IGraphicsPath interface.

See Also

CreatePath Method Overload List
GraphicsFactory Members
GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory.CreatePath Method (Rect)

GraphicsFactory.CreatePath Method (Rect)
See Also
[image]

Creates an IGraphicsPath object from the specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static IGraphicsPath CreatePath (
Rect rect
)

Visual Basic [image] Copy Code

Public Shared Function CreatePath( _
rect As Rect _
) As IGraphicsPath

Parameters

rect

A Rectangle structure.

Return Value

An instance of the IGraphicsPath interface.

See Also

CreatePath Method Overload List
GraphicsFactory Members
GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory Properties

GraphicsFactory Properties
[image]

Public Properties

Name | Description
IsContextReady | Gets a value indicating whether the factory is ready for use.

See Also

GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.GraphicsFactory.IsContextReady Property

GraphicsFactory.IsContextReady Property
[image]

Gets a value indicating whether the factory is ready for use.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool IsContextReady { get; }

Visual Basic [image] Copy Code

Public Shared ReadOnly Property IsContextReady As Boolean

Property Value

See Also

GraphicsFactory Members
GraphicsFactory Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Class

HatchBrush Class
[image]

Represents a brush that fills the interiors of objects with a hatch pattern.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class HatchBrush : Brush

Visual Basic [image] Copy Code

Public Class HatchBrush
Inherits Brush

Inheritance Hierarchy

System.Object
MindFusion.Drawing.Brush
MindFusion.Drawing.HatchBrush

See Also

HatchBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Members

HatchBrush Members
Constructors Properties Methods
[image]

Represents a brush that fills the interiors of objects with a hatch pattern.

The following tables list the members exposed by the HatchBrush type.

Public Constructors

Name | Description
HatchBrush | Initializes a new instance of the HatchBrush class.

Public Properties

Name | Description
BackgroundColor | Gets the color of spaces between the hatch lines drawn by this brush.
ForegroundColor | Gets the color of hatch lines drawn by this brush.
Style | Gets the hatch style of this brush.

Public Methods

Name | Description
Clone | Brush.Clone override.
Equals | Brush.Equals override.
GetHashCode | Brush.GetHashCode override.
ToColor | Brush.ToColor override.

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Constructor

HatchBrush Constructor
[image]

Initializes a new instance of the HatchBrush class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HatchBrush (
HatchStyle style,
Color foregroundColor,
Color backgroundColor
)

Visual Basic [image] Copy Code

Public New ( _
style As HatchStyle, _
foregroundColor As Color, _
backgroundColor As Color _
)

Parameters

style

A member of the HatchStyle enumeration that represents the pattern drawn by this brush.

foregroundColor

A Color structure that specifies the color of lines drawn by this brush.

backgroundColor

A Color structure that specifies the color of spaces between the lines drawn by this brush.

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Methods

HatchBrush Methods
[image]

Public Methods

Name | Description
Clone | Brush.Clone override.
Equals | Brush.Equals override.
GetHashCode | Brush.GetHashCode override.
ToColor | Brush.ToColor override.

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.Clone Method

HatchBrush.Clone Method
[image]

Brush.Clone override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Brush

Return Value

An instance of the Brush class.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.Equals Method

HatchBrush.Equals Method
[image]

Brush.Equals override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Brush other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
other As Brush _
) As Boolean

Parameters

other

The Brush to compare with the current Brush.

Return Value

true if the specified Brush is equal to the current Brush; otherwise, false.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.GetHashCode Method

HatchBrush.GetHashCode Method
[image]

Brush.GetHashCode override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.ToColor Method

HatchBrush.ToColor Method
[image]

Brush.ToColor override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Color ToColor ()

Visual Basic [image] Copy Code

Public Overrides Function ToColor () As Color

Return Value

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush Properties

HatchBrush Properties
[image]

Public Properties

Name | Description
BackgroundColor | Gets the color of spaces between the hatch lines drawn by this brush.
ForegroundColor | Gets the color of hatch lines drawn by this brush.
Style | Gets the hatch style of this brush.

See Also

HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.BackgroundColor Property

HatchBrush.BackgroundColor Property
[image]

Gets the color of spaces between the hatch lines drawn by this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color BackgroundColor { get; set; }

Visual Basic [image] Copy Code

Public Property BackgroundColor As Color

Property Value

An instance of the Color structure that represents the background color of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.ForegroundColor Property

HatchBrush.ForegroundColor Property
[image]

Gets the color of hatch lines drawn by this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color ForegroundColor { get; set; }

Visual Basic [image] Copy Code

Public Property ForegroundColor As Color

Property Value

An instance of the Color structure that represents the foreground color of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchBrush.Style Property

HatchBrush.Style Property
[image]

Gets the hatch style of this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HatchStyle Style { get; set; }

Visual Basic [image] Copy Code

Public Property Style As HatchStyle

Property Value

A member of the HatchStyle enumeration that represents the pattern of this brush.

See Also

HatchBrush Members
HatchBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.HatchStyle Enumeration

HatchStyle Enumeration
[image]

Represents the available hatch patterns.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum HatchStyle

Visual Basic [image] Copy Code

Public Enum HatchStyle

Members

Member name | Description
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left.
Cross | Specifies horizontal and vertical lines that cross.
DarkDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, are spaced 50 percent closer together than, and are twice the width of ForwardDiagonal.
DarkHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal and are twice the width of Horizontal.
DarkUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, are spaced 50 percent closer together than BackwardDiagonal, and are twice its width.
DarkVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical and are twice its width.
DashedDownwardDiagonal | Specifies dashed diagonal lines, that slant to the right from top points to bottom points.
DashedHorizontal | Specifies dashed horizontal lines.
DashedUpwardDiagonal | Specifies dashed diagonal lines, that slant to the left from top points to bottom points.
DashedVertical | Specifies dashed vertical lines.
DiagonalBrick | Specifies a hatch that has the appearance of layered bricks that slant to the left from top points to bottom points.
DiagonalCross | A pattern of crisscross diagonal lines.
Divot | Specifies a hatch that has the appearance of divots.
DottedDiamond | Specifies forward diagonal and backward diagonal lines, each of which is composed of dots, that cross.
DottedGrid | Specifies horizontal and vertical lines, each of which is composed of dots, that cross.
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right.
Horizontal | A pattern of horizontal lines.
HorizontalBrick | Specifies a hatch that has the appearance of horizontally layered bricks.
LargeCheckerBoard | Specifies a hatch that has the appearance of a checkerboard with squares that are twice the size of SmallCheckerBoard.
LargeConfetti | Specifies a hatch that has the appearance of confetti, and is composed of larger pieces than SmallConfetti.
LargeGrid | Specifies the hatch style Cross.
LightDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points and are spaced 50 percent closer together than ForwardDiagonal, but are not antialiased.
LightHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal.
LightUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points and are spaced 50 percent closer together than BackwardDiagonal.
LightVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical.
Max | Specifies hatch style SolidDiamond.
Min | Specifies hatch style Horizontal.
NarrowHorizontal | Specifies horizontal lines that are spaced 75 percent closer together than hatch style Horizontal.
NarrowVertical | Specifies vertical lines that are spaced 75 percent closer together than hatch style Vertical.
OutlinedDiamond | Specifies forward diagonal and backward diagonal lines that cross.
Percent05 | Specifies a 5-percent hatch. The ratio of foreground color to background color is 5:100.
Percent10 | Specifies a 10-percent hatch. The ratio of foreground color to background color is 10:100.
Percent20 | Specifies a 20-percent hatch. The ratio of foreground color to background color is 20:100.
Percent25 | Specifies a 25-percent hatch. The ratio of foreground color to background color is 25:100.
Percent30 | Specifies a 30-percent hatch. The ratio of foreground color to background color is 30:100.
Percent40 | Specifies a 40-percent hatch. The ratio of foreground color to background color is 40:100.
Percent50 | Specifies a 50-percent hatch. The ratio of foreground color to background color is 50:100.
Percent60 | Specifies a 60-percent hatch. The ratio of foreground color to background color is 60:100.
Percent70 | Specifies a 70-percent hatch. The ratio of foreground color to background color is 70:100.
Percent75 | Specifies a 75-percent hatch. The ratio of foreground color to background color is 75:100.
Percent80 | Specifies a 80-percent hatch. The ratio of foreground color to background color is 80:100.
Percent90 | Specifies a 90-percent hatch. The ratio of foreground color to background color is 90:100.
Plaid | Specifies a hatch that has the appearance of a plaid material.
Shingle | Specifies a hatch that has the appearance of diagonally layered shingles that slant to the right from top points to bottom points.
SmallCheckerBoard | Specifies a hatch that has the appearance of a checkerboard.
SmallConfetti | Specifies a hatch that has the appearance of confetti.
SmallGrid | Specifies horizontal and vertical lines that cross and are spaced 50 percent closer together than hatch style Cross.
SolidDiamond | Specifies a hatch that has the appearance of a checkerboard placed diagonally.
Sphere | Specifies a hatch that has the appearance of spheres laid adjacent to one another.
Trellis | Specifies a hatch that has the appearance of a trellis.
Vertical | A pattern of vertical lines.
Wave | Specifies horizontal lines that are composed of tildes.
Weave | Specifies a hatch that has the appearance of a woven material.
WideDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, have the same spacing as hatch style ForwardDiagonal, and are triple its width.
WideUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, have the same spacing as hatch style BackwardDiagonal, and are triple its width.
ZigZag | Specifies horizontal lines that are composed of zigzags.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.HorizontalAlignment Enumeration

HorizontalAlignment Enumeration
[image]

Specifies the horizontal alignment of an element.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum HorizontalAlignment

Visual Basic [image] Copy Code

Public Enum HorizontalAlignment

Members

Member name | Description
Center | Indicates that an element is centered in its container.
Left | Indicates that an element is left-aligned to its container.
Right | Indicates that an element is right-aligned in its container.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Interface

IGraphics Interface
[image]

Represents a platform-independent object that can be used to perform drawing.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public interface IGraphics

Visual Basic [image] Copy Code

Public Interface IGraphics

See Also

IGraphics Members
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Members

IGraphics Members
Properties Methods Events
[image]

Represents a platform-independent object that can be used to perform drawing.

The following tables list the members exposed by the IGraphics type.

Public Properties

Name | Description
DpiX | Gets or sets the horizontal resolution of this IGraphics object.
DpiY | Gets or sets the vertical resolution of this IGraphics object.
EnableAntialiasing |
SupportsPenWidth0 | Gets a value indicating whether the IGraphics object supports pens with zero width.
Transform | Gets the transformation for this IGraphics object.

Public Methods

Name | Description
BeginHyperLink |
ClipImage | Overloaded.
CreateImage | Creates an image from the current drawing associated with this IGraphics object.
DrawArc | Overloaded. Draws an arc.
DrawBezier | Draws a Bézier spline defined by four Point structures.
DrawBeziers | Draws a series of Bézier splines from an array of Point structures.
DrawCurve | Draws a curve from an array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse.
DrawImage | Overloaded. Draws an image.
DrawLine | Overloaded. Draws a line.
DrawLines | Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws an IGraphicsPath object.
DrawPoint | Overloaded.
DrawPolygon | Draws a polygon specified by a poins list.
DrawRectangle | Overloaded. Draws a rectangle.
DrawString | Overloaded. Draws a text string.
EndHyperLink |
FillEllipse | Overloaded. Fills the interior of an ellipse.
FillPath | Fills the interior of an IGraphicsPath object.
FillPolygon | Fills the interior of a polygon specified by a points list.
FillRectangle | Overloaded. Fills the interior of a rectangle.
GetFontHeight | Gets the height of the specified font.
GetImageSize | Returns the physical size of the specified image.
MeasureString | Overloaded. Measures a string.
ResetTransform | Resets the transformation matrix of this IGraphics object to the identity matrix.
Restore | Restores the state of this IGraphics object to the specified state.
RotateTransform | Prepends the specified rotation to the transformation matrix of this IGraphics object.
Save | Saves the current state of this IGraphics object.
ScaleTransform | Prepends the specified scaling operation to the transformation matrix of this IGraphics.
SetClip | Overloaded. Sets the clipping region of this IGraphics object.
TranslateTransform | Prepends the specified translation to the transformation matrix of this IGraphics object.

Public Events

Name | Description
ImageReady |

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Methods

IGraphics Methods
[image]

Public Methods

Name | Description
BeginHyperLink |
ClipImage | Overloaded.
CreateImage | Creates an image from the current drawing associated with this IGraphics object.
DrawArc | Overloaded. Draws an arc.
DrawBezier | Draws a Bézier spline defined by four Point structures.
DrawBeziers | Draws a series of Bézier splines from an array of Point structures.
DrawCurve | Draws a curve from an array of Point structures.
DrawEllipse | Overloaded. Draws an ellipse.
DrawImage | Overloaded. Draws an image.
DrawLine | Overloaded. Draws a line.
DrawLines | Draws a series of line segments that connect an array of Point structures.
DrawPath | Draws an IGraphicsPath object.
DrawPoint | Overloaded.
DrawPolygon | Draws a polygon specified by a poins list.
DrawRectangle | Overloaded. Draws a rectangle.
DrawString | Overloaded. Draws a text string.
EndHyperLink |
FillEllipse | Overloaded. Fills the interior of an ellipse.
FillPath | Fills the interior of an IGraphicsPath object.
FillPolygon | Fills the interior of a polygon specified by a points list.
FillRectangle | Overloaded. Fills the interior of a rectangle.
GetFontHeight | Gets the height of the specified font.
GetImageSize | Returns the physical size of the specified image.
MeasureString | Overloaded. Measures a string.
ResetTransform | Resets the transformation matrix of this IGraphics object to the identity matrix.
Restore | Restores the state of this IGraphics object to the specified state.
RotateTransform | Prepends the specified rotation to the transformation matrix of this IGraphics object.
Save | Saves the current state of this IGraphics object.
ScaleTransform | Prepends the specified scaling operation to the transformation matrix of this IGraphics.
SetClip | Overloaded. Sets the clipping region of this IGraphics object.
TranslateTransform | Prepends the specified translation to the transformation matrix of this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.BeginHyperLink Method

IGraphics.BeginHyperLink Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void BeginHyperLink (
string hyperlink,
string target
)

Visual Basic [image] Copy Code

Sub BeginHyperLink( _
hyperlink As String, _
target As String _
)

Parameters

hyperlink

target

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ClipImage Method

IGraphics.ClipImage Method
[image]

Overload List

Name | Description
IGraphics.ClipImage (ImageSource, IGraphicsPath) | Applies a clipping path to an image.
IGraphics.ClipImage (ImageSource, Point[]) | Applies a clipping path to an image.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ClipImage Method (ImageSource, IGraphicsPath)

IGraphics.ClipImage Method (ImageSource, IGraphicsPath)
See Also
[image]

Applies a clipping path to an image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Task<ImageSource> ClipImage (
ImageSource sourceImage,
IGraphicsPath clip
)

Visual Basic [image] Copy Code

Function ClipImage( _
sourceImage As ImageSource, _
clip As IGraphicsPath _
) As Task(Of ImageSource)

Parameters

sourceImage

The image to clip.

clip

The path used for the clip.

Return Value

The clipped image.

See Also

ClipImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ClipImage Method (ImageSource, Point[])

IGraphics.ClipImage Method (ImageSource, Point[])
See Also
[image]

Applies a clipping path to an image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Task<ImageSource> ClipImage (
ImageSource sourceImage,
Point[] clipPoly
)

Visual Basic [image] Copy Code

Function ClipImage( _
sourceImage As ImageSource, _
clipPoly() As Point _
) As Task(Of ImageSource)

Parameters

sourceImage

The image to clip.

clipPoly

A polygon defined by a point collection used for the clip.

Return Value

The clipped image.

See Also

ClipImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.CreateImage Method

IGraphics.CreateImage Method
[image]

Creates an image from the current drawing associated with this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Task<ImageSource> CreateImage (
IGraphicsPath clip = null
)

Visual Basic [image] Copy Code

Function CreateImage( _
Optional clip As IGraphicsPath = Nothing _
) As Task(Of ImageSource)

Parameters

clip
Optional.

An optional clip path.

Return Value

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method

IGraphics.DrawArc Method
[image]

Draws an arc.

Overload List

Name | Description
IGraphics.DrawArc (Pen, Double, Double, Double, Double, Double, Double) | Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.
IGraphics.DrawArc (Pen, Rect, Double, Double) | Draws an arc representing a portion of an ellipse specified by a Rectangle structure.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Double, Double, Double, Double, Double, Double)

IGraphics.DrawArc Method (Pen, Double, Double, Double, Double, Double, Double)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawArc (
Pen pen,
double x,
double y,
double width,
double height,
double startAngle,
double sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawArc( _
pen As Pen, _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
startAngle As Double, _
sweepAngle As Double _
)

Parameters

pen

A Pen object that determines the color, width, and style of the arc.

x

The x-coordinate of the upper-left corner of the rectangle that defines the ellipse.

y

The y-coordinate of the upper-left corner of the rectangle that defines the ellipse.

width

The width of the rectangle that defines the ellipse.

height

The height of the rectangle that defines the ellipse.

startAngle

Angle in degrees measured clockwise from the x-axis to the starting point of the arc.

sweepAngle

Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawArc Method (Pen, Rect, Double, Double)

IGraphics.DrawArc Method (Pen, Rect, Double, Double)
See Also
[image]

Draws an arc representing a portion of an ellipse specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawArc (
Pen pen,
Rect rect,
double startAngle,
double sweepAngle
)

Visual Basic [image] Copy Code

Sub DrawArc( _
pen As Pen, _
rect As Rect, _
startAngle As Double, _
sweepAngle As Double _
)

Parameters

pen

A Pen object that determines the color, width, and style of the arc.

rect

A Rectangle structure that defines the boundaries of the ellipse.

startAngle

Angle in degrees measured clockwise from the x-axis to the starting point of the arc.

sweepAngle

Angle in degrees measured clockwise from the startAngle parameter to ending point of the arc.

See Also

DrawArc Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBezier Method

IGraphics.DrawBezier Method
[image]

Draws a Bézier spline defined by four Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBezier (
Pen pen,
Point p1,
Point p2,
Point p3,
Point p4
)

Visual Basic [image] Copy Code

Sub DrawBezier( _
pen As Pen, _
p1 As Point, _
p2 As Point, _
p3 As Point, _
p4 As Point _
)

Parameters

pen

A Pen object that determines the color, width, and style of the curve.

p1

A Point structure that represents the starting point of the curve.

p2

A Point structure that represents the first control point for the curve.

p3

A Point structure that represents the second control point for the curve.

p4

A Point structure that represents the ending point of the curve.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawBeziers Method

IGraphics.DrawBeziers Method
[image]

Draws a series of Bézier splines from an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawBeziers (
Pen pen,
IList<Point> points
)

Visual Basic [image] Copy Code

Sub DrawBeziers( _
pen As Pen, _
points As IList(Of Point) _
)

Parameters

pen

A Pen object that determines the color, width, and style of the curve.

points

An array of Point structures that represent the points that determine the curve.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawCurve Method

IGraphics.DrawCurve Method
[image]

Draws a curve from an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawCurve (
Pen pen,
Point[] points
)

Visual Basic [image] Copy Code

Sub DrawCurve( _
pen As Pen, _
points() As Point _
)

Parameters

pen

A Pen object that determines the color, width, and style of the curve.

points

An array of Point structures that represent the points that determine the curve.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method

IGraphics.DrawEllipse Method
[image]

Draws an ellipse.

Overload List

Name | Description
IGraphics.DrawEllipse (Pen, Double, Double, Double, Double) | Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.
IGraphics.DrawEllipse (Pen, Rect) | Draws an ellipse specified by a bounding Rectangle structure.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Double, Double, Double, Double)

IGraphics.DrawEllipse Method (Pen, Double, Double, Double, Double)
See Also
[image]

Draws an ellipse defined by a bounding rectangle specified by a pair of coordinates, a height, and a width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawEllipse (
Pen pen,
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Sub DrawEllipse( _
pen As Pen, _
x As Double, _
y As Double, _
width As Double, _
height As Double _
)

Parameters

pen

A Pen object that determines the color, width, and style of the ellipse.

x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y

The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

width

The width of the bounding rectangle that defines the ellipse.

height

The height of the bounding rectangle that defines the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawEllipse Method (Pen, Rect)

IGraphics.DrawEllipse Method (Pen, Rect)
See Also
[image]

Draws an ellipse specified by a bounding Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawEllipse (
Pen pen,
Rect rect
)

Visual Basic [image] Copy Code

Sub DrawEllipse( _
pen As Pen, _
rect As Rect _
)

Parameters

pen

A Pen object that determines the color, width, and style of the ellipse.

rect

A Rectangle structure that defines the boundaries of the ellipse.

See Also

DrawEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method

IGraphics.DrawImage Method
[image]

Draws an image.

Overload List

Name | Description
IGraphics.DrawImage (ImageSource, Double, Double) | Draws the image represented by the specified ImageSource object, using its original physical size, at the specified location.
IGraphics.DrawImage (ImageSource, Rect) | Draws the image represented by the specified ImageSource object at the specified location and with the specified size.
IGraphics.DrawImage (ImageSource, Rect, ImageAlignment, Double, Point) | Draws the image represented by the specified ImageSource object at the specified location, with the specified alignment and rotation.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (ImageSource, Double, Double)

IGraphics.DrawImage Method (ImageSource, Double, Double)
See Also
[image]

Draws the image represented by the specified ImageSource object, using its original physical size, at the specified location.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
ImageSource image,
double x,
double y
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As ImageSource, _
x As Double, _
y As Double _
)

Parameters

image

An ImageSource representing the image to draw.

x

The x-coordinate of the upper-left corner of the drawn image.

y

The y-coordinate of the upper-left corner of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (ImageSource, Rect)

IGraphics.DrawImage Method (ImageSource, Rect)
See Also
[image]

Draws the image represented by the specified ImageSource object at the specified location and with the specified size.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
ImageSource image,
Rect rect
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As ImageSource, _
rect As Rect _
)

Parameters

image

An ImageSource representing the image to draw.

rect

A Rectangle structure that specifies the location and size of the drawn image.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawImage Method (ImageSource, Rect, ImageAlignment, Double, Point)

IGraphics.DrawImage Method (ImageSource, Rect, ImageAlignment, Double, Point)
See Also
[image]

Draws the image represented by the specified ImageSource object at the specified location, with the specified alignment and rotation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawImage (
ImageSource image,
Rect rect,
ImageAlignment imageAlign,
double rotationAngle,
Point pivot
)

Visual Basic [image] Copy Code

Sub DrawImage( _
image As ImageSource, _
rect As Rect, _
imageAlign As ImageAlignment, _
rotationAngle As Double, _
pivot As Point _
)

Parameters

image

An ImageSource representing the image to draw.

rect

A Rectangle structure that specifies the location and size of the drawn image.

imageAlign

The alignment of the image within the specified rectangle.

rotationAngle

The rotation angle of the drawn image.

pivot

The pivot of the rotation.

See Also

DrawImage Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method

IGraphics.DrawLine Method
[image]

Draws a line.

Overload List

Name | Description
IGraphics.DrawLine (Pen, Double, Double, Double, Double) | Draws a line connecting the two points specified by coordinate pairs.
IGraphics.DrawLine (Pen, Point, Point) | Draws a line connecting two Point structures.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Double, Double, Double, Double)

IGraphics.DrawLine Method (Pen, Double, Double, Double, Double)
See Also
[image]

Draws a line connecting the two points specified by coordinate pairs.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLine (
Pen pen,
double x1,
double y1,
double x2,
double y2
)

Visual Basic [image] Copy Code

Sub DrawLine( _
pen As Pen, _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double _
)

Parameters

pen

A Pen object that determines the color, width, and style of the line.

x1

The x-coordinate of the first point.

y1

The y-coordinate of the first point.

x2

The x-coordinate of the second point.

y2

The y-coordinate of the second point.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLine Method (Pen, Point, Point)

IGraphics.DrawLine Method (Pen, Point, Point)
See Also
[image]

Draws a line connecting two Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLine (
Pen pen,
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Sub DrawLine( _
pen As Pen, _
p1 As Point, _
p2 As Point _
)

Parameters

pen

A Pen object that determines the color, width, and style of the line.

p1

A Point structure that represents the first point to connect.

p2

A Point structure that represents the second point to connect.

See Also

DrawLine Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawLines Method

IGraphics.DrawLines Method
[image]

Draws a series of line segments that connect an array of Point structures.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawLines (
Pen pen,
IList<Point> points
)

Visual Basic [image] Copy Code

Sub DrawLines( _
pen As Pen, _
points As IList(Of Point) _
)

Parameters

pen

A Pen object that determines the color, width, and style of the line segments.

points

An array of Point structures that represent the points to connect.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPath Method

IGraphics.DrawPath Method
[image]

Draws an IGraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPath (
Pen pen,
IGraphicsPath path
)

Visual Basic [image] Copy Code

Sub DrawPath( _
pen As Pen, _
path As IGraphicsPath _
)

Parameters

pen

A Pen object that determines the color, width, and style of the path.

path

An IGraphicsPath object to draw.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPoint Method

IGraphics.DrawPoint Method
[image]

Overload List

Name | Description
IGraphics.DrawPoint (Pen, Double, Double) | Draws a point at the specified coordinates.
IGraphics.DrawPoint (SolidBrush, Double, Double, Double) | Draws a point at the specified coordinates.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPoint Method (Pen, Double, Double)

IGraphics.DrawPoint Method (Pen, Double, Double)
See Also
[image]

Draws a point at the specified coordinates.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPoint (
Pen pen,
double x,
double y
)

Visual Basic [image] Copy Code

Sub DrawPoint( _
pen As Pen, _
x As Double, _
y As Double _
)

Parameters

pen

A Pen object that determines the color, width, and style of the point.

x

The x-coordinate of the point.

y

The y-coordinate of the point.

See Also

DrawPoint Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPoint Method (SolidBrush, Double, Double, Double)

IGraphics.DrawPoint Method (SolidBrush, Double, Double, Double)
See Also
[image]

Draws a point at the specified coordinates.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPoint (
SolidBrush brush,
double x,
double y,
double size
)

Visual Basic [image] Copy Code

Sub DrawPoint( _
brush As SolidBrush, _
x As Double, _
y As Double, _
size As Double _
)

Parameters

brush

A SolidBrush object that determines the color of the point.

x

The x-coordinate of the point.

y

The y-coordinate of the point.

size

The points' size.

See Also

DrawPoint Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawPolygon Method

IGraphics.DrawPolygon Method
[image]

Draws a polygon specified by a poins list.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawPolygon (
Pen pen,
IList<Point> points
)

Visual Basic [image] Copy Code

Sub DrawPolygon( _
pen As Pen, _
points As IList(Of Point) _
)

Parameters

pen

A Pen object that determines the color, width, and style of the polygon.

points

A list of points that represents the polygon to draw.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method

IGraphics.DrawRectangle Method
[image]

Draws a rectangle.

Overload List

Name | Description
IGraphics.DrawRectangle (Pen, Double, Double, Double, Double) | Draws a rectangle specified by a coordinate pair, a width, and a height.
IGraphics.DrawRectangle (Pen, Rect) | Draws a rectangle specified by a Rectangle structure.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Double, Double, Double, Double)

IGraphics.DrawRectangle Method (Pen, Double, Double, Double, Double)
See Also
[image]

Draws a rectangle specified by a coordinate pair, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangle (
Pen pen,
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Sub DrawRectangle( _
pen As Pen, _
x As Double, _
y As Double, _
width As Double, _
height As Double _
)

Parameters

pen

A Pen object that determines the color, width, and style of the rectangle.

x

The x-coordinate of the upper-left corner of the rectangle to draw.

y

The y-coordinate of the upper-left corner of the rectangle to draw.

width

The width of the rectangle to draw.

height

The height of the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawRectangle Method (Pen, Rect)

IGraphics.DrawRectangle Method (Pen, Rect)
See Also
[image]

Draws a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawRectangle (
Pen pen,
Rect rect
)

Visual Basic [image] Copy Code

Sub DrawRectangle( _
pen As Pen, _
rect As Rect _
)

Parameters

pen

A Pen object that determines the color, width, and style of the rectangle.

rect

A Rectangle structure that represents the rectangle to draw.

See Also

DrawRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method

IGraphics.DrawString Method
[image]

Draws a text string.

Overload List

Name | Description
IGraphics.DrawString (String, Font, Brush, Double, Double) | Draws the specified text string at the specified location with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, Point, StringFormat) | Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.
IGraphics.DrawString (String, Font, Brush, Rect) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects.
IGraphics.DrawString (String, Font, Brush, Rect, StringFormat) | Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, Double, Double)

IGraphics.DrawString Method (String, Font, Brush, Double, Double)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string text,
Font font,
Brush brush,
double x,
double y
)

Visual Basic [image] Copy Code

Sub DrawString( _
text As String, _
font As Font, _
brush As Brush, _
x As Double, _
y As Double _
)

Parameters

text

The string to draw.

font

A Font object that defines the text format of the string.

brush

A Brush object that determines the color and texture of the drawn text.

x

The x-coordinate of the upper-left corner of the drawn text.

y

The y-coordinate of the upper-left corner of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, Point, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, Point, StringFormat)
See Also
[image]

Draws the specified text string at the specified location with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string text,
Font font,
Brush brush,
Point location,
StringFormat format
)

Visual Basic [image] Copy Code

Sub DrawString( _
text As String, _
font As Font, _
brush As Brush, _
location As Point, _
format As StringFormat _
)

Parameters

text

The string to draw.

font

A Font object that defines the text format of the string.

brush

A Brush object that determines the color and texture of the drawn text.

location

A Point structure that specifies the upper-left corner of the drawn text.

format

A StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, Rect)

IGraphics.DrawString Method (String, Font, Brush, Rect)
See Also
[image]

Draws the specified text string in the specified rectangle with the specified Brush and Font objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string text,
Font font,
Brush brush,
Rect rect
)

Visual Basic [image] Copy Code

Sub DrawString( _
text As String, _
font As Font, _
brush As Brush, _
rect As Rect _
)

Parameters

text

The string to draw.

font

A Font object that defines the text format of the string.

brush

A Brush object that determines the color and texture of the drawn text.

rect

A Rectangle structure that specifies the location of the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DrawString Method (String, Font, Brush, Rect, StringFormat)

IGraphics.DrawString Method (String, Font, Brush, Rect, StringFormat)
See Also
[image]

Draws the specified text string in the specified rectangle with the specified Brush and Font objects using the formatting attributes of the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void DrawString (
string text,
Font font,
Brush brush,
Rect rect,
StringFormat format
)

Visual Basic [image] Copy Code

Sub DrawString( _
text As String, _
font As Font, _
brush As Brush, _
rect As Rect, _
format As StringFormat _
)

Parameters

text

The string to draw.

font

A Font object that defines the text format of the string.

brush

A Brush object that determines the color and texture of the drawn text.

rect

A Rectangle structure that specifies the location of the drawn text.

format

A StringFormat object that specifies formatting attributes, such as line spacing and alignment, that are applied to the drawn text.

See Also

DrawString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.EndHyperLink Method

IGraphics.EndHyperLink Method
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void EndHyperLink ()

Visual Basic [image] Copy Code

Sub EndHyperLink ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method

IGraphics.FillEllipse Method
[image]

Fills the interior of an ellipse.

Overload List

Name | Description
IGraphics.FillEllipse (Brush, Double, Double, Double, Double) | Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.
IGraphics.FillEllipse (Brush, Rect) | Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Double, Double, Double, Double)

IGraphics.FillEllipse Method (Brush, Double, Double, Double, Double)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillEllipse (
Brush brush,
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Sub FillEllipse( _
brush As Brush, _
x As Double, _
y As Double, _
width As Double, _
height As Double _
)

Parameters

brush

A Brush object that determines the characteristics of the fill.

x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y

The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

width

The width of the bounding rectangle that defines the ellipse.

height

The height of the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillEllipse Method (Brush, Rect)

IGraphics.FillEllipse Method (Brush, Rect)
See Also
[image]

Fills the interior of an ellipse defined by a bounding rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillEllipse (
Brush brush,
Rect rect
)

Visual Basic [image] Copy Code

Sub FillEllipse( _
brush As Brush, _
rect As Rect _
)

Parameters

brush

A Brush object that determines the characteristics of the fill.

rect

A Rectangle structure that represents the bounding rectangle that defines the ellipse.

See Also

FillEllipse Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPath Method

IGraphics.FillPath Method
[image]

Fills the interior of an IGraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPath (
Brush brush,
IGraphicsPath path
)

Visual Basic [image] Copy Code

Sub FillPath( _
brush As Brush, _
path As IGraphicsPath _
)

Parameters

brush

A Brush object that determines the characteristics of the fill.

path

An IGraphicsPath object that represents the path to fill.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillPolygon Method

IGraphics.FillPolygon Method
[image]

Fills the interior of a polygon specified by a points list.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillPolygon (
Brush brush,
IList<Point> points
)

Visual Basic [image] Copy Code

Sub FillPolygon( _
brush As Brush, _
points As IList(Of Point) _
)

Parameters

brush

A Brush object that determines the characteristics of the fill.

points

A list of points that represents the polygon to fill.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method

IGraphics.FillRectangle Method
[image]

Fills the interior of a rectangle.

Overload List

Name | Description
IGraphics.FillRectangle (Brush, Double, Double, Double, Double) | Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.
IGraphics.FillRectangle (Brush, Rect) | Fills the interior of a rectangle specified by a Rectangle structure.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Double, Double, Double, Double)

IGraphics.FillRectangle Method (Brush, Double, Double, Double, Double)
See Also
[image]

Fills the interior of a rectangle specified by a pair of coordinates, a width, and a height.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangle (
Brush brush,
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Sub FillRectangle( _
brush As Brush, _
x As Double, _
y As Double, _
width As Double, _
height As Double _
)

Parameters

brush

A Brush object that determines the characteristics of the fill.

x

The x-coordinate of the upper-left corner of the rectangle to fill.

y

The y-coordinate of the upper-left corner of the rectangle to fill.

width

The width of the rectangle to fill.

height

The height of the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.FillRectangle Method (Brush, Rect)

IGraphics.FillRectangle Method (Brush, Rect)
See Also
[image]

Fills the interior of a rectangle specified by a Rectangle structure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void FillRectangle (
Brush brush,
Rect rect
)

Visual Basic [image] Copy Code

Sub FillRectangle( _
brush As Brush, _
rect As Rect _
)

Parameters

brush

A Brush object that determines the characteristics of the fill.

rect

A Rectangle structure that represents the rectangle to fill.

See Also

FillRectangle Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetFontHeight Method

IGraphics.GetFontHeight Method
[image]

Gets the height of the specified font.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

double GetFontHeight (
Font font
)

Visual Basic [image] Copy Code

Function GetFontHeight( _
font As Font _
) As Double

Parameters

font

The font to measure.

Return Value

The height of the font.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.GetImageSize Method

IGraphics.GetImageSize Method
[image]

Returns the physical size of the specified image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Size GetImageSize (
ImageSource image
)

Visual Basic [image] Copy Code

Function GetImageSize( _
image As ImageSource _
) As Size

Parameters

image

The image to test.

Return Value

The size of the image.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method

IGraphics.MeasureString Method
[image]

Measures a string.

Overload List

Name | Description
IGraphics.MeasureString (String, Font) | Measures the specified string when drawn with the specified Font object.
IGraphics.MeasureString (String, Font, Double, StringFormat) | Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font)

IGraphics.MeasureString Method (String, Font)
See Also
[image]

Measures the specified string when drawn with the specified Font object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Size MeasureString (
string text,
Font font
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font _
) As Size

Parameters

text

The string to measure.

font

A Font object that defines the text format of the string.

Return Value

A Size structure that represents the size, in pixels, of the string specified by the text parameter as drawn with the font parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.MeasureString Method (String, Font, Double, StringFormat)

IGraphics.MeasureString Method (String, Font, Double, StringFormat)
See Also
[image]

Measures the specified string when drawn with the specified Font object and formatted with the specified StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Size MeasureString (
string text,
Font font,
double maxWidth,
StringFormat format
)

Visual Basic [image] Copy Code

Function MeasureString( _
text As String, _
font As Font, _
maxWidth As Double, _
format As StringFormat _
) As Size

Parameters

text

The string to measure.

font

A Font object that defines the text format of the string.

maxWidth

The maximum width of the string.

format

A StringFormat object that represents formatting information, such as line spacing, for the string.

Return Value

A Size structure that represents the size, in pixels, of the string specified in the text parameter as drawn with the font parameter and the stringFormat parameter.

See Also

MeasureString Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ResetTransform Method

IGraphics.ResetTransform Method
[image]

Resets the transformation matrix of this IGraphics object to the identity matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ResetTransform ()

Visual Basic [image] Copy Code

Sub ResetTransform ()

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Restore Method

IGraphics.Restore Method
[image]

Restores the state of this IGraphics object to the specified state.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Restore (
Object state
)

Visual Basic [image] Copy Code

Sub Restore( _
state As Object _
)

Parameters

state

An object that represents the state to which to restore this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.RotateTransform Method

IGraphics.RotateTransform Method
[image]

Prepends the specified rotation to the transformation matrix of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void RotateTransform (
double angle
)

Visual Basic [image] Copy Code

Sub RotateTransform( _
angle As Double _
)

Parameters

angle

The angle of rotation in degrees.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Save Method

IGraphics.Save Method
[image]

Saves the current state of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Object Save ()

Visual Basic [image] Copy Code

Function Save () As Object

Return Value

An object that represents the saved state.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ScaleTransform Method

IGraphics.ScaleTransform Method
[image]

Prepends the specified scaling operation to the transformation matrix of this IGraphics.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void ScaleTransform (
double sx,
double sy
)

Visual Basic [image] Copy Code

Sub ScaleTransform( _
sx As Double, _
sy As Double _
)

Parameters

sx

The scale factor in the x direction.

sy

The scale factor in the y direction.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method

IGraphics.SetClip Method
[image]

Sets the clipping region of this IGraphics object.

Overload List

Name | Description
IGraphics.SetClip (IGraphicsPath) | Sets the clipping region of this IGraphics object to the specified IGraphicsPath object.
IGraphics.SetClip (IGraphicsPath, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified IGraphicsPath object.
IGraphics.SetClip (Rect) | Sets the clipping region of this IGraphics object to the specified rectangle.
IGraphics.SetClip (Rect, CombineMode) | Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified rectangle.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (IGraphicsPath)

IGraphics.SetClip Method (IGraphicsPath)
See Also
[image]

Sets the clipping region of this IGraphics object to the specified IGraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
IGraphicsPath path
)

Visual Basic [image] Copy Code

Sub SetClip( _
path As IGraphicsPath _
)

Parameters

path

An IGraphicsPath object that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (IGraphicsPath, CombineMode)

IGraphics.SetClip Method (IGraphicsPath, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified IGraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
IGraphicsPath path,
CombineMode mode
)

Visual Basic [image] Copy Code

Sub SetClip( _
path As IGraphicsPath, _
mode As CombineMode _
)

Parameters

path

An IGraphicsPath object to combine.

mode

Member of the CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Rect)

IGraphics.SetClip Method (Rect)
See Also
[image]

Sets the clipping region of this IGraphics object to the specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
Rect rect
)

Visual Basic [image] Copy Code

Sub SetClip( _
rect As Rect _
)

Parameters

rect

A Rectangle structure that represents the new clip region.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SetClip Method (Rect, CombineMode)

IGraphics.SetClip Method (Rect, CombineMode)
See Also
[image]

Sets the clipping region of this IGraphics object to the result of the specified operation combining the current clip region and the specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void SetClip (
Rect rect,
CombineMode mode
)

Visual Basic [image] Copy Code

Sub SetClip( _
rect As Rect, _
mode As CombineMode _
)

Parameters

rect

A Rectangle structure to combine.

mode

Member of the CombineMode enumeration that specifies the combining operation to use.

See Also

SetClip Method Overload List
IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.TranslateTransform Method

IGraphics.TranslateTransform Method
[image]

Prepends the specified translation to the transformation matrix of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TranslateTransform (
double dx,
double dy
)

Visual Basic [image] Copy Code

Sub TranslateTransform( _
dx As Double, _
dy As Double _
)

Parameters

dx

The x component of the translation.

dy

The y component of the translation.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Properties

IGraphics Properties
[image]

Public Properties

Name | Description
DpiX | Gets or sets the horizontal resolution of this IGraphics object.
DpiY | Gets or sets the vertical resolution of this IGraphics object.
EnableAntialiasing |
SupportsPenWidth0 | Gets a value indicating whether the IGraphics object supports pens with zero width.
Transform | Gets the transformation for this IGraphics object.

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DpiX Property

IGraphics.DpiX Property
[image]

Gets or sets the horizontal resolution of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

double DpiX { get; set; }

Visual Basic [image] Copy Code

Property DpiX As Double

Property Value

This property indicates a value, in dots per inch, for the horizontal resolution supported by this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.DpiY Property

IGraphics.DpiY Property
[image]

Gets or sets the vertical resolution of this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

double DpiY { get; set; }

Visual Basic [image] Copy Code

Property DpiY As Double

Property Value

This property indicates a value, in dots per inch, for the vertical resolution supported by this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.EnableAntialiasing Property

IGraphics.EnableAntialiasing Property
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool EnableAntialiasing { get; set; }

Visual Basic [image] Copy Code

Property EnableAntialiasing As Boolean

Property Value

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.SupportsPenWidth0 Property

IGraphics.SupportsPenWidth0 Property
[image]

Gets a value indicating whether the IGraphics object supports pens with zero width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool SupportsPenWidth0 { get; }

Visual Basic [image] Copy Code

ReadOnly Property SupportsPenWidth0 As Boolean

Property Value

A boolean value.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.Transform Property

IGraphics.Transform Property
[image]

Gets the transformation for this IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IMatrix Transform { get; }

Visual Basic [image] Copy Code

ReadOnly Property Transform As IMatrix

Property Value

This property specifies an IMatrix object that represents the world transformation for this IGraphics object.

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics Events

IGraphics Events
[image]

Public Events

Name | Description
ImageReady |

See Also

IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphics.ImageReady Event

IGraphics.ImageReady Event
[image]

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

event EventHandler<EventArgs> ImageReady

Visual Basic [image] Copy Code

Event ImageReady As EventHandler(Of EventArgs)

See Also

IGraphics Members
IGraphics Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory Interface

IGraphicsFactory Interface
[image]

A factory class for various graphical objects.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public interface IGraphicsFactory

Visual Basic [image] Copy Code

Public Interface IGraphicsFactory

See Also

IGraphicsFactory Members
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory Members

IGraphicsFactory Members
Properties Methods
[image]

A factory class for various graphical objects.

The following tables list the members exposed by the IGraphicsFactory type.

Public Properties

Name | Description
IsContextReady | Gets a value indicating whether the factory is ready.

Public Methods

Name | Description
CreateGraphics | Creates an IGraphics object.
CreateImageGraphics | Creates an IGraphics object specifically to output to an image.
CreateMatrix | Creates an IMatrix object.
CreatePath | Overloaded. Creates an IGraphicsPath object.

See Also

IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory Methods

IGraphicsFactory Methods
[image]

Public Methods

Name | Description
CreateGraphics | Creates an IGraphics object.
CreateImageGraphics | Creates an IGraphics object specifically to output to an image.
CreateMatrix | Creates an IMatrix object.
CreatePath | Overloaded. Creates an IGraphicsPath object.

See Also

IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory.CreateGraphics Method

IGraphicsFactory.CreateGraphics Method
[image]

Creates an IGraphics object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IGraphics CreateGraphics ()

Visual Basic [image] Copy Code

Function CreateGraphics () As IGraphics

Return Value

An instance of the IGraphics interface.

See Also

IGraphicsFactory Members
IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory.CreateImageGraphics Method

IGraphicsFactory.CreateImageGraphics Method
[image]

Creates an IGraphics object specifically to output to an image.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IGraphics CreateImageGraphics (
Rect bounds
)

Visual Basic [image] Copy Code

Function CreateImageGraphics( _
bounds As Rect _
) As IGraphics

Parameters

bounds

Return Value

An instance of the IGraphics interface.

See Also

IGraphicsFactory Members
IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory.CreateMatrix Method

IGraphicsFactory.CreateMatrix Method
[image]

Creates an IMatrix object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IMatrix CreateMatrix ()

Visual Basic [image] Copy Code

Function CreateMatrix () As IMatrix

Return Value

An instance of the IMatrix interface.

See Also

IGraphicsFactory Members
IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory.CreatePath Method

IGraphicsFactory.CreatePath Method
[image]

Creates an IGraphicsPath object.

Overload List

Name | Description
IGraphicsFactory.CreatePath () | Creates an IGraphicsPath object.
IGraphicsFactory.CreatePath (FillMode) | Creates an IGraphicsPath object with the specified fill mode.
IGraphicsFactory.CreatePath (Rect) | Creates an IGraphicsPath object from the specified rectangle.

See Also

IGraphicsFactory Members
IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory.CreatePath Method ()

IGraphicsFactory.CreatePath Method ()
See Also
[image]

Creates an IGraphicsPath object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IGraphicsPath CreatePath ()

Visual Basic [image] Copy Code

Function CreatePath () As IGraphicsPath

Return Value

An instance of the IGraphicsPath interface.

See Also

CreatePath Method Overload List
IGraphicsFactory Members
IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory.CreatePath Method (FillMode)

IGraphicsFactory.CreatePath Method (FillMode)
See Also
[image]

Creates an IGraphicsPath object with the specified fill mode.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IGraphicsPath CreatePath (
FillMode fillMode
)

Visual Basic [image] Copy Code

Function CreatePath( _
fillMode As FillMode _
) As IGraphicsPath

Parameters

fillMode

A member of the FillMode enumeration.

Return Value

An instance of the IGraphicsPath interface.

See Also

CreatePath Method Overload List
IGraphicsFactory Members
IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory.CreatePath Method (Rect)

IGraphicsFactory.CreatePath Method (Rect)
See Also
[image]

Creates an IGraphicsPath object from the specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IGraphicsPath CreatePath (
Rect rect
)

Visual Basic [image] Copy Code

Function CreatePath( _
rect As Rect _
) As IGraphicsPath

Parameters

rect

A Rectangle structure.

Return Value

An instance of the IGraphicsPath interface.

See Also

CreatePath Method Overload List
IGraphicsFactory Members
IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory Properties

IGraphicsFactory Properties
[image]

Public Properties

Name | Description
IsContextReady | Gets a value indicating whether the factory is ready.

See Also

IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsFactory.IsContextReady Property

IGraphicsFactory.IsContextReady Property
[image]

Gets a value indicating whether the factory is ready.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsContextReady { get; }

Visual Basic [image] Copy Code

ReadOnly Property IsContextReady As Boolean

Property Value

A boolean value.

See Also

IGraphicsFactory Members
IGraphicsFactory Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath Interface

IGraphicsPath Interface
[image]

Represents a series of connected lines and curves.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public interface IGraphicsPath

Visual Basic [image] Copy Code

Public Interface IGraphicsPath

See Also

IGraphicsPath Members
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath Members

IGraphicsPath Members
Properties Methods
[image]

Represents a series of connected lines and curves.

The following tables list the members exposed by the IGraphicsPath type.

Public Properties

Name | Description
PathPoints | Gets the points in the path.
PointCount | Gets the number of points in the path.

Public Methods

Name | Description
AddArc | Overloaded. Appends an elliptical arc to the current figure.
AddBezier | Overloaded. Adds a cubic Bézier curve to the current figure.
AddBeziers | Adds a sequence of connected cubic Bézier curves to the current figure.
AddEllipse | Overloaded. Adds an ellipse to the current path.
AddLine | Overloaded. Appends a line segment to the current figure.
AddLines | Appends a series of connected line segments to the end of this IGraphicsPath.
AddPolygon | Adds a polygon to the current figure.
AddRectangle | Overloaded. Adds a rectangle to this path.
AddRoundRect | Adds a rounded rectangle to this path.
CloseFigure | Closes the current figure and starts a new figure. If the current figure contains a sequence of connected lines and curves, the method closes the loop by connecting a line from the endpoint to the starting point.
Flatten | Overloaded. Converts each curve in this path into a sequence of connected line segments.
GetBounds | Returns a rectangle that bounds this IGraphicsPath.
GetLastPoint | Gets the current last point in the path, if any, otherwise, null.
IntersectsWith | Checks whether this IGraphicsPath intersects with the specified IGraphicsPath.
IsVisible | Indicates whether the specified point is contained within this IGraphicsPath.
StartFigure | Starts a new figure without closing the current figure. All subsequent points added to the path are added to this new figure.
Transform | Applies a transform matrix to this IGraphicsPath.

See Also

IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath Methods

IGraphicsPath Methods
[image]

Public Methods

Name | Description
AddArc | Overloaded. Appends an elliptical arc to the current figure.
AddBezier | Overloaded. Adds a cubic Bézier curve to the current figure.
AddBeziers | Adds a sequence of connected cubic Bézier curves to the current figure.
AddEllipse | Overloaded. Adds an ellipse to the current path.
AddLine | Overloaded. Appends a line segment to the current figure.
AddLines | Appends a series of connected line segments to the end of this IGraphicsPath.
AddPolygon | Adds a polygon to the current figure.
AddRectangle | Overloaded. Adds a rectangle to this path.
AddRoundRect | Adds a rounded rectangle to this path.
CloseFigure | Closes the current figure and starts a new figure. If the current figure contains a sequence of connected lines and curves, the method closes the loop by connecting a line from the endpoint to the starting point.
Flatten | Overloaded. Converts each curve in this path into a sequence of connected line segments.
GetBounds | Returns a rectangle that bounds this IGraphicsPath.
GetLastPoint | Gets the current last point in the path, if any, otherwise, null.
IntersectsWith | Checks whether this IGraphicsPath intersects with the specified IGraphicsPath.
IsVisible | Indicates whether the specified point is contained within this IGraphicsPath.
StartFigure | Starts a new figure without closing the current figure. All subsequent points added to the path are added to this new figure.
Transform | Applies a transform matrix to this IGraphicsPath.

See Also

IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddArc Method

IGraphicsPath.AddArc Method
[image]

Appends an elliptical arc to the current figure.

Overload List

Name | Description
IGraphicsPath.AddArc (Double, Double, Double, Double, Double, Double) | Appends an elliptical arc to the current figure.
IGraphicsPath.AddArc (Rect, Double, Double) | Appends an elliptical arc to the current figure.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddArc Method (Double, Double, Double, Double, Double, Double)

IGraphicsPath.AddArc Method (Double, Double, Double, Double, Double, Double)
See Also
[image]

Appends an elliptical arc to the current figure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddArc (
double x,
double y,
double width,
double height,
double startAngle,
double sweepAngle
)

Visual Basic [image] Copy Code

Sub AddArc( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
startAngle As Double, _
sweepAngle As Double _
)

Parameters

x

The x-coordinate of the upper-left corner of the rectangular region that defines the ellipse from which the arc is drawn.

y

The y-coordinate of the upper-left corner of the rectangular region that defines the ellipse from which the arc is drawn.

width

The width of the rectangular region that defines the ellipse from which the arc is drawn.

height

The height of the rectangular region that defines the ellipse from which the arc is drawn.

startAngle

The starting angle of the arc, measured in degrees clockwise from the x-axis.

sweepAngle

The angle between startAngle and the end of the arc.

See Also

AddArc Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddArc Method (Rect, Double, Double)

IGraphicsPath.AddArc Method (Rect, Double, Double)
See Also
[image]

Appends an elliptical arc to the current figure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddArc (
Rect rect,
double startAngle,
double sweepAngle
)

Visual Basic [image] Copy Code

Sub AddArc( _
rect As Rect, _
startAngle As Double, _
sweepAngle As Double _
)

Parameters

rect

A Rectangle that represents the rectangular bounds of the ellipse from which the arc is taken.

startAngle

The starting angle of the arc, measured in degrees clockwise from the x-axis.

sweepAngle

The angle between startAngle and the end of the arc.

See Also

AddArc Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddBezier Method

IGraphicsPath.AddBezier Method
[image]

Adds a cubic Bézier curve to the current figure.

Overload List

Name | Description
IGraphicsPath.AddBezier (Double, Double, Double, Double, Double, Double, Double, Double) | Adds a cubic Bézier curve to the current figure.
IGraphicsPath.AddBezier (Point, Point, Point, Point) | Adds a cubic Bézier curve to the current figure.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddBezier Method (Double, Double, Double, Double, Double, Double, Double, Double)

IGraphicsPath.AddBezier Method (Double, Double, Double, Double, Double, Double, Double, Double)
See Also
[image]

Adds a cubic Bézier curve to the current figure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddBezier (
double x1,
double y1,
double x2,
double y2,
double x3,
double y3,
double x4,
double y4
)

Visual Basic [image] Copy Code

Sub AddBezier( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double, _
x3 As Double, _
y3 As Double, _
x4 As Double, _
y4 As Double _
)

Parameters

x1

The x-coordinate of the starting point of the curve.

y1

The y-coordinate of the starting point of the curve.

x2

The x-coordinate of the first control point for the curve.

y2

The y-coordinate of the first control point for the curve.

x3

The x-coordinate of the second control point for the curve.

y3

The y-coordinate of the second control point for the curve.

x4

The x-coordinate of the endpoint of the curve.

y4

The y-coordinate of the endpoint of the curve.

See Also

AddBezier Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddBezier Method (Point, Point, Point, Point)

IGraphicsPath.AddBezier Method (Point, Point, Point, Point)
See Also
[image]

Adds a cubic Bézier curve to the current figure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddBezier (
Point p1,
Point p2,
Point p3,
Point p4
)

Visual Basic [image] Copy Code

Sub AddBezier( _
p1 As Point, _
p2 As Point, _
p3 As Point, _
p4 As Point _
)

Parameters

p1

A Point that represents the starting point of the curve.

p2

A Point that represents the first control point for the curve.

p3

A Point that represents the second control point for the curve.

p4

A Point that represents the endpoint of the curve.

See Also

AddBezier Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddBeziers Method

IGraphicsPath.AddBeziers Method
[image]

Adds a sequence of connected cubic Bézier curves to the current figure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddBeziers (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub AddBeziers( _
points As IList(Of Point) _
)

Parameters

points

An array of Point structures that represents the points that define the curves.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddEllipse Method

IGraphicsPath.AddEllipse Method
[image]

Adds an ellipse to the current path.

Overload List

Name | Description
IGraphicsPath.AddEllipse (Double, Double, Double, Double) | Adds an ellipse to the current path.
IGraphicsPath.AddEllipse (Rect) | Adds an ellipse to the current path.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddEllipse Method (Double, Double, Double, Double)

IGraphicsPath.AddEllipse Method (Double, Double, Double, Double)
See Also
[image]

Adds an ellipse to the current path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddEllipse (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Sub AddEllipse( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
)

Parameters

x

The x-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

y

The y-coordinate of the upper-left corner of the bounding rectangle that defines the ellipse.

width

The width of the bounding rectangle that defines the ellipse.

height

The height of the bounding rectangle that defines the ellipse.

See Also

AddEllipse Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddEllipse Method (Rect)

IGraphicsPath.AddEllipse Method (Rect)
See Also
[image]

Adds an ellipse to the current path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddEllipse (
Rect rect
)

Visual Basic [image] Copy Code

Sub AddEllipse( _
rect As Rect _
)

Parameters

rect

A Rectangle that represents the bounding rectangle that defines the ellipse.

See Also

AddEllipse Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddLine Method

IGraphicsPath.AddLine Method
[image]

Appends a line segment to the current figure.

Overload List

Name | Description
IGraphicsPath.AddLine (Double, Double, Double, Double) | Appends a line segment to the current figure.
IGraphicsPath.AddLine (Point, Point) | Appends a line segment to this IGraphicsPath.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddLine Method (Double, Double, Double, Double)

IGraphicsPath.AddLine Method (Double, Double, Double, Double)
See Also
[image]

Appends a line segment to the current figure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddLine (
double x1,
double y1,
double x2,
double y2
)

Visual Basic [image] Copy Code

Sub AddLine( _
x1 As Double, _
y1 As Double, _
x2 As Double, _
y2 As Double _
)

Parameters

x1

The x-coordinate of the starting point of the line.

y1

The y-coordinate of the starting point of the line.

x2

The x-coordinate of the endpoint of the line.

y2

The y-coordinate of the endpoint of the line.

See Also

AddLine Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddLine Method (Point, Point)

IGraphicsPath.AddLine Method (Point, Point)
See Also
[image]

Appends a line segment to this IGraphicsPath.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddLine (
Point p1,
Point p2
)

Visual Basic [image] Copy Code

Sub AddLine( _
p1 As Point, _
p2 As Point _
)

Parameters

p1

A Point that represents the starting point of the line.

p2

A Point that represents the endpoint of the line.

See Also

AddLine Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddLines Method

IGraphicsPath.AddLines Method
[image]

Appends a series of connected line segments to the end of this IGraphicsPath.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddLines (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub AddLines( _
points As IList(Of Point) _
)

Parameters

points

A list of Point structures that represents the points that define the line segments to add.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddPolygon Method

IGraphicsPath.AddPolygon Method
[image]

Adds a polygon to the current figure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddPolygon (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub AddPolygon( _
points As IList(Of Point) _
)

Parameters

points

A list of points that define the polygon.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddRectangle Method

IGraphicsPath.AddRectangle Method
[image]

Adds a rectangle to this path.

Overload List

Name | Description
IGraphicsPath.AddRectangle (Double, Double, Double, Double) | Adds a rectangle to this path.
IGraphicsPath.AddRectangle (Rect) | Adds a rectangle to this path.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddRectangle Method (Double, Double, Double, Double)

IGraphicsPath.AddRectangle Method (Double, Double, Double, Double)
See Also
[image]

Adds a rectangle to this path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddRectangle (
double x,
double y,
double width,
double height
)

Visual Basic [image] Copy Code

Sub AddRectangle( _
x As Double, _
y As Double, _
width As Double, _
height As Double _
)

Parameters

x

The x-coordinate of the upper-left corner of the rectangle to add.

y

The y-coordinate of the upper-left corner of the rectangle to add.

width

The width of the rectangle to add.

height

The height of the rectangle to add.

See Also

AddRectangle Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddRectangle Method (Rect)

IGraphicsPath.AddRectangle Method (Rect)
See Also
[image]

Adds a rectangle to this path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddRectangle (
Rect rect
)

Visual Basic [image] Copy Code

Sub AddRectangle( _
rect As Rect _
)

Parameters

rect

The rectangle to add.

See Also

AddRectangle Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.AddRoundRect Method

IGraphicsPath.AddRoundRect Method
[image]

Adds a rounded rectangle to this path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void AddRoundRect (
double x,
double y,
double width,
double height,
double radius
)

Visual Basic [image] Copy Code

Sub AddRoundRect( _
x As Double, _
y As Double, _
width As Double, _
height As Double, _
radius As Double _
)

Parameters

x

The x-coordinate of the upper-left corner of the rectangle to add.

y

The y-coordinate of the upper-left corner of the rectangle to add.

width

The width of the rectangle to add.

height

The height of the rectangle to add.

radius

The roundness of the rectangle corners.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.CloseFigure Method

IGraphicsPath.CloseFigure Method
[image]

Closes the current figure and starts a new figure. If the current figure contains a sequence of connected lines and curves, the method closes the loop by connecting a line from the endpoint to the starting point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void CloseFigure ()

Visual Basic [image] Copy Code

Sub CloseFigure ()

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.Flatten Method

IGraphicsPath.Flatten Method
[image]

Converts each curve in this path into a sequence of connected line segments.

Overload List

Name | Description
IGraphicsPath.Flatten () | Converts each curve in this path into a sequence of connected line segments.
IGraphicsPath.Flatten (Double) | Converts each curve in this path into a sequence of connected line segments using the specified factor.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.Flatten Method ()

IGraphicsPath.Flatten Method ()
See Also
[image]

Converts each curve in this path into a sequence of connected line segments.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Flatten ()

Visual Basic [image] Copy Code

Sub Flatten ()

See Also

Flatten Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.Flatten Method (Double)

IGraphicsPath.Flatten Method (Double)
See Also
[image]

Converts each curve in this path into a sequence of connected line segments using the specified factor.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Flatten (
double flatness
)

Visual Basic [image] Copy Code

Sub Flatten( _
flatness As Double _
)

Parameters

flatness

Specifies the factor of the flatness. This value ranges between 1 and 100. Reducing the flatness value will increase the number of line segments in the approximation.

See Also

Flatten Method Overload List
IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.GetBounds Method

IGraphicsPath.GetBounds Method
[image]

Returns a rectangle that bounds this IGraphicsPath.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Rect GetBounds ()

Visual Basic [image] Copy Code

Function GetBounds () As Rect

Return Value

A Rectangle that represents a rectangle that bounds this IGraphicsPath.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.GetLastPoint Method

IGraphicsPath.GetLastPoint Method
[image]

Gets the current last point in the path, if any, otherwise, null.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Nullable<Point> GetLastPoint ()

Visual Basic [image] Copy Code

Function GetLastPoint () As Nullable(Of Point)

Return Value

A Point object representing the last point in the path or null.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.IntersectsWith Method

IGraphicsPath.IntersectsWith Method
[image]

Checks whether this IGraphicsPath intersects with the specified IGraphicsPath.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IntersectsWith (
IGraphicsPath path
)

Visual Basic [image] Copy Code

Function IntersectsWith( _
path As IGraphicsPath _
) As Boolean

Parameters

path

The IGraphicsPath to test.

Return Value

true if the two paths intersect; otherwise, false.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.IsVisible Method

IGraphicsPath.IsVisible Method
[image]

Indicates whether the specified point is contained within this IGraphicsPath.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsVisible (
Point point
)

Visual Basic [image] Copy Code

Function IsVisible( _
point As Point _
) As Boolean

Parameters

point

The point to test.

Return Value

true if the specified point is contained within this IGraphicsPath; otherwise, false.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.StartFigure Method

IGraphicsPath.StartFigure Method
[image]

Starts a new figure without closing the current figure. All subsequent points added to the path are added to this new figure.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void StartFigure ()

Visual Basic [image] Copy Code

Sub StartFigure ()

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.Transform Method

IGraphicsPath.Transform Method
[image]

Applies a transform matrix to this IGraphicsPath.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Transform (
IMatrix matrix
)

Visual Basic [image] Copy Code

Sub Transform( _
matrix As IMatrix _
)

Parameters

matrix

An IMatrix that represents the transformation to apply.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath Properties

IGraphicsPath Properties
[image]

Public Properties

Name | Description
PathPoints | Gets the points in the path.
PointCount | Gets the number of points in the path.

See Also

IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.PathPoints Property

IGraphicsPath.PathPoints Property
[image]

Gets the points in the path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

List<Point> PathPoints { get; }

Visual Basic [image] Copy Code

ReadOnly Property PathPoints As List(Of Point)

Property Value

A list of Point objects.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IGraphicsPath.PointCount Property

IGraphicsPath.PointCount Property
[image]

Gets the number of points in the path.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

int PointCount { get; }

Visual Basic [image] Copy Code

ReadOnly Property PointCount As Integer

Property Value

An integer value.

See Also

IGraphicsPath Members
IGraphicsPath Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.ImageAlignment Enumeration

ImageAlignment Enumeration
[image]

Specifies the position and alignment of a picture relative to its destination rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum ImageAlignment

Visual Basic [image] Copy Code

Public Enum ImageAlignment

Members

Member name | Description
BottomCenter | The image is centered horizontally and aligned to the bottom side.
BottomLeft | The image is aligned to the bottom left corner.
BottomRight | The image is aligned to the bottom right corner.
Center | The image is centered.
Fit | The image is resized to fit the size the destination rectangle.
FitBottom | The image is resized to fit the size of the object and aligned to bottom side.
FitLeft | The image is resized to fit the size of the object and aligned to left side.
FitRight | The image is resized to fit the size of the object and aligned to right side.
FitTop | The image is resized to fit the size of the object and aligned to top side.
MiddleLeft | The image is centered vertically and aligned to the left-hand side.
MiddleRight | The image is centered vertically and aligned to the right-hand side.
Stretch | The image is stretched to fill the destination rectangle.
Tile | The image is tiled across the destination rectangle.
TopCenter | The image is centered horizontally and aligned to the top side.
TopLeft | The image is aligned to the top left corner.
TopRight | The image is aligned o the top right corner.
Unspecified | Invalid image alignment.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix Interface

IMatrix Interface
[image]

Encapsulates an affine matrix that represents a geometric transform.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public interface IMatrix : IDisposable

Visual Basic [image] Copy Code

Public Interface IMatrix
Implements IDisposable

See Also

IMatrix Members
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix Members

IMatrix Members
Properties Methods
[image]

Encapsulates an affine matrix that represents a geometric transform.

The following tables list the members exposed by the IMatrix type.

Public Properties

Name | Description
IsIdentity | Gets a value indicating whether this IMatrix is the identity matrix.
OffsetX | Gets the translation of this matrix along the x-axis.
OffsetY | Gets the translation of this matrix along the y-axis.

Public Methods

Name | Description
Clone | Creates an exact clone of this matrix.
Inverse | Inverts this matrix, if it is invertible.
Reset | Reset this matrix.
RotateAt | Overloaded. Applies a rotation to this matrix.
Scale | Applies the specified scale vector to this IMatrix by prepending the scale vector.
TransformPoint | Applies the geometric transform represented by this IMatrix to the specified point.
TransformPoints | Applies the geometric transform represented by this IMatrix to the specified array of points.
TransformRect | Applies the geometric transform represented by this IMatrix to the specified rectangle.
Translate | Applies the specified translation to this IMatrix by prepending the translation.

See Also

IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix Methods

IMatrix Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this matrix.
Inverse | Inverts this matrix, if it is invertible.
Reset | Reset this matrix.
RotateAt | Overloaded. Applies a rotation to this matrix.
Scale | Applies the specified scale vector to this IMatrix by prepending the scale vector.
TransformPoint | Applies the geometric transform represented by this IMatrix to the specified point.
TransformPoints | Applies the geometric transform represented by this IMatrix to the specified array of points.
TransformRect | Applies the geometric transform represented by this IMatrix to the specified rectangle.
Translate | Applies the specified translation to this IMatrix by prepending the translation.

See Also

IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.Clone Method

IMatrix.Clone Method
[image]

Creates an exact clone of this matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IMatrix Clone ()

Visual Basic [image] Copy Code

Function Clone () As IMatrix

Return Value

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.Inverse Method

IMatrix.Inverse Method
[image]

Inverts this matrix, if it is invertible.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

IMatrix Inverse ()

Visual Basic [image] Copy Code

Function Inverse () As IMatrix

Return Value

An instance of the IMatrix interface.

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.Reset Method

IMatrix.Reset Method
[image]

Reset this matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Reset ()

Visual Basic [image] Copy Code

Sub Reset ()

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.RotateAt Method

IMatrix.RotateAt Method
[image]

Applies a rotation to this matrix.

Overload List

Name | Description
IMatrix.RotateAt (Double) | Prepend to this IMatrix a clockwise rotation by the specified angle.
IMatrix.RotateAt (Double, Point) | Applies a clockwise rotation to this IMatrix around the point specified in the point parameter, and by prepending the rotation.

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.RotateAt Method (Double)

IMatrix.RotateAt Method (Double)
See Also
[image]

Prepend to this IMatrix a clockwise rotation by the specified angle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void RotateAt (
double angle
)

Visual Basic [image] Copy Code

Sub RotateAt( _
angle As Double _
)

Parameters

angle

The angle of the rotation, in degrees.

See Also

RotateAt Method Overload List
IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.RotateAt Method (Double, Point)

IMatrix.RotateAt Method (Double, Point)
See Also
[image]

Applies a clockwise rotation to this IMatrix around the point specified in the point parameter, and by prepending the rotation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void RotateAt (
double angle,
Point point
)

Visual Basic [image] Copy Code

Sub RotateAt( _
angle As Double, _
point As Point _
)

Parameters

angle

The angle of the rotation, in degrees.

point

A Point that represents the center of the rotation.

See Also

RotateAt Method Overload List
IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.Scale Method

IMatrix.Scale Method
[image]

Applies the specified scale vector to this IMatrix by prepending the scale vector.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Scale (
double sx,
double sy
)

Visual Basic [image] Copy Code

Sub Scale( _
sx As Double, _
sy As Double _
)

Parameters

sx

The value by which to scale this IMatrix in the x-axis direction.

sy

The value by which to scale this IMatrix in the y-axis direction.

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.TransformPoint Method

IMatrix.TransformPoint Method
[image]

Applies the geometric transform represented by this IMatrix to the specified point.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Point TransformPoint (
Point point
)

Visual Basic [image] Copy Code

Function TransformPoint( _
point As Point _
) As Point

Parameters

point

The point to transform.

Return Value

The transformed point.

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.TransformPoints Method

IMatrix.TransformPoints Method
[image]

Applies the geometric transform represented by this IMatrix to the specified array of points.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void TransformPoints (
IList<Point> points
)

Visual Basic [image] Copy Code

Sub TransformPoints( _
points As IList(Of Point) _
)

Parameters

points

A list of Point structures that represents the points to transform.

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.TransformRect Method

IMatrix.TransformRect Method
[image]

Applies the geometric transform represented by this IMatrix to the specified rectangle.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

Rect TransformRect (
Rect rect
)

Visual Basic [image] Copy Code

Function TransformRect( _
rect As Rect _
) As Rect

Parameters

rect

The rectangle to transform.

Return Value

The transformed rectangle.

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.Translate Method

IMatrix.Translate Method
[image]

Applies the specified translation to this IMatrix by prepending the translation.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

void Translate (
double dx,
double dy
)

Visual Basic [image] Copy Code

Sub Translate( _
dx As Double, _
dy As Double _
)

Parameters

dx

The x value by which to translate this IMatrix.

dy

The y value by which to translate this IMatrix.

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix Properties

IMatrix Properties
[image]

Public Properties

Name | Description
IsIdentity | Gets a value indicating whether this IMatrix is the identity matrix.
OffsetX | Gets the translation of this matrix along the x-axis.
OffsetY | Gets the translation of this matrix along the y-axis.

See Also

IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.IsIdentity Property

IMatrix.IsIdentity Property
[image]

Gets a value indicating whether this IMatrix is the identity matrix.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

bool IsIdentity { get; }

Visual Basic [image] Copy Code

ReadOnly Property IsIdentity As Boolean

Property Value

A boolean value.

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.OffsetX Property

IMatrix.OffsetX Property
[image]

Gets the translation of this matrix along the x-axis.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

double OffsetX { get; }

Visual Basic [image] Copy Code

ReadOnly Property OffsetX As Double

Property Value

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.IMatrix.OffsetY Property

IMatrix.OffsetY Property
[image]

Gets the translation of this matrix along the y-axis.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

double OffsetY { get; }

Visual Basic [image] Copy Code

ReadOnly Property OffsetY As Double

Property Value

See Also

IMatrix Members
IMatrix Interface
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Class

LinearGradientBrush Class
[image]

Represents a brush that fills the interiors of objects with a linear gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class LinearGradientBrush : Brush

Visual Basic [image] Copy Code

Public Class LinearGradientBrush
Inherits Brush

Inheritance Hierarchy

System.Object
MindFusion.Drawing.Brush
MindFusion.Drawing.LinearGradientBrush

See Also

LinearGradientBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Members

LinearGradientBrush Members
Constructors Properties Methods
[image]

Represents a brush that fills the interiors of objects with a linear gradient.

The following tables list the members exposed by the LinearGradientBrush type.

Public Constructors

Name | Description
LinearGradientBrush | Overloaded. Initializes a new instance of the LinearGradientBrush class.

Public Properties

Name | Description
Angle | Gets or sets the angle of the gradient.
Colors | Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.
Positions | Gets or sets the positions along a gradient line.

Public Methods

Name | Description
Clone | Brush.Clone override.
Equals | Brush.Equals override.
GetHashCode | Brush.GetHashCode override.
ToColor | Brush.ToColor override.

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor

LinearGradientBrush Constructor
[image]

Initializes a new instance of the LinearGradientBrush class.

Overload List

Name | Description
LinearGradientBrush (Color, Color, Double) | Initializes a new instance of the LinearGradientBrush class.
LinearGradientBrush (Double[], Color[], Double) | Initializes a new instance of the LinearGradientBrush class.

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (Color, Color, Double)

LinearGradientBrush Constructor (Color, Color, Double)
See Also
[image]

Initializes a new instance of the LinearGradientBrush class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LinearGradientBrush (
Color startColor,
Color endColor,
double angle
)

Visual Basic [image] Copy Code

Public New ( _
startColor As Color, _
endColor As Color, _
angle As Double _
)

Parameters

startColor

The start color of the gradient.

endColor

The end color of the gradient.

angle

The angle of the gradient.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Constructor (Double[], Color[], Double)

LinearGradientBrush Constructor (Double[], Color[], Double)
See Also
[image]

Initializes a new instance of the LinearGradientBrush class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LinearGradientBrush (
double[] positions,
Color[] colors,
double angle
)

Visual Basic [image] Copy Code

Public New ( _
positions() As Double, _
colors() As Color, _
angle As Double _
)

Parameters

positions

The positions of the colors of the gradient.

colors

The colors of the gradient.

angle

The angle of the gradient.

See Also

LinearGradientBrush Constructor Overload List
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Methods

LinearGradientBrush Methods
[image]

Public Methods

Name | Description
Clone | Brush.Clone override.
Equals | Brush.Equals override.
GetHashCode | Brush.GetHashCode override.
ToColor | Brush.ToColor override.

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Clone Method

LinearGradientBrush.Clone Method
[image]

Brush.Clone override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Brush

Return Value

An instance of the Brush class.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Equals Method

LinearGradientBrush.Equals Method
[image]

Brush.Equals override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Brush other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
other As Brush _
) As Boolean

Parameters

other

The Brush to compare with the current Brush.

Return Value

true if the specified Brush is equal to the current Brush; otherwise, false.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.GetHashCode Method

LinearGradientBrush.GetHashCode Method
[image]

Brush.GetHashCode override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.ToColor Method

LinearGradientBrush.ToColor Method
[image]

Brush.ToColor override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Color ToColor ()

Visual Basic [image] Copy Code

Public Overrides Function ToColor () As Color

Return Value

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush Properties

LinearGradientBrush Properties
[image]

Public Properties

Name | Description
Angle | Gets or sets the angle of the gradient.
Colors | Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.
Positions | Gets or sets the positions along a gradient line.

See Also

LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Angle Property

LinearGradientBrush.Angle Property
[image]

Gets or sets the angle of the gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public double Angle { get; set; }

Visual Basic [image] Copy Code

Public Property Angle As Double

Property Value

A double value.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Colors Property

LinearGradientBrush.Colors Property
[image]

Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color[] Colors { get; set; }

Visual Basic [image] Copy Code

Public Property Colors As Color()

Property Value

An array of Color objects.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LinearGradientBrush.Positions Property

LinearGradientBrush.Positions Property
[image]

Gets or sets the positions along a gradient line.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public double[] Positions { get; set; }

Visual Basic [image] Copy Code

Public Property Positions As Double()

Property Value

An array of double values.

See Also

LinearGradientBrush Members
LinearGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.LineJoin Enumeration

LineJoin Enumeration
[image]

Describes the shape that joins two lines or segments.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum LineJoin

Visual Basic [image] Copy Code

Public Enum LineJoin

Members

Member name | Description
Bevel | Beveled vertices.
Miter | Regular angular vertices.
Round | Rounded vertices.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Class

PathGradientBrush Class
[image]

Encapsulates a Brush object that fills the interior of an IGraphicsPath object with a gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class PathGradientBrush : Brush

Visual Basic [image] Copy Code

Public Class PathGradientBrush
Inherits Brush

Inheritance Hierarchy

System.Object
MindFusion.Drawing.Brush
MindFusion.Drawing.PathGradientBrush

See Also

PathGradientBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Members

PathGradientBrush Members
Constructors Properties Methods
[image]

Encapsulates a Brush object that fills the interior of an IGraphicsPath object with a gradient.

The following tables list the members exposed by the PathGradientBrush type.

Public Constructors

Name | Description
PathGradientBrush | Initializes a new instance of the PathGradientBrush class.

Public Properties

Name | Description
Colors | Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.
Path | Gets or sets the IGraphicsPath that defines the area filled by this brush.
Positions | Gets or sets the positions along a gradient line.

Public Methods

Name | Description
Clone | Brush.Clone override.
Equals | Brush.Equals override.
GetHashCode | Brush.GetHashCode override.
ToColor | Brush.ToColor override.

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Constructor

PathGradientBrush Constructor
[image]

Initializes a new instance of the PathGradientBrush class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PathGradientBrush (
IGraphicsPath path
)

Visual Basic [image] Copy Code

Public New ( _
path As IGraphicsPath _
)

Parameters

path

The IGraphicsPath that defines the area filled by this brush.

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Methods

PathGradientBrush Methods
[image]

Public Methods

Name | Description
Clone | Brush.Clone override.
Equals | Brush.Equals override.
GetHashCode | Brush.GetHashCode override.
ToColor | Brush.ToColor override.

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.Clone Method

PathGradientBrush.Clone Method
[image]

Brush.Clone override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Brush

Return Value

An instance of the Brush class.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.Equals Method

PathGradientBrush.Equals Method
[image]

Brush.Equals override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Brush other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
other As Brush _
) As Boolean

Parameters

other

The Brush to compare with the current Brush.

Return Value

true if the specified Brush is equal to the current Brush; otherwise, false.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.GetHashCode Method

PathGradientBrush.GetHashCode Method
[image]

Brush.GetHashCode override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.ToColor Method

PathGradientBrush.ToColor Method
[image]

Brush.ToColor override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Color ToColor ()

Visual Basic [image] Copy Code

Public Overrides Function ToColor () As Color

Return Value

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush Properties

PathGradientBrush Properties
[image]

Public Properties

Name | Description
Colors | Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.
Path | Gets or sets the IGraphicsPath that defines the area filled by this brush.
Positions | Gets or sets the positions along a gradient line.

See Also

PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.Colors Property

PathGradientBrush.Colors Property
[image]

Gets or sets an array of colors that represents the colors to use at corresponding positions along a gradient.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color[] Colors { get; set; }

Visual Basic [image] Copy Code

Public Property Colors As Color()

Property Value

An array of Color objects.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.Path Property

PathGradientBrush.Path Property
[image]

Gets or sets the IGraphicsPath that defines the area filled by this brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public IGraphicsPath Path { get; set; }

Visual Basic [image] Copy Code

Public Property Path As IGraphicsPath

Property Value

An IGraphicsPath object.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PathGradientBrush.Positions Property

PathGradientBrush.Positions Property
[image]

Gets or sets the positions along a gradient line.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public double[] Positions { get; set; }

Visual Basic [image] Copy Code

Public Property Positions As Double()

Property Value

An array of double values.

See Also

PathGradientBrush Members
PathGradientBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Class

Pen Class
[image]

Represents an object used to draw lines and curves.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class Pen

Visual Basic [image] Copy Code

Public Class Pen

Inheritance Hierarchy

System.Object
MindFusion.Drawing.Pen

See Also

Pen Members
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Members

Pen Members
Constructors Properties Methods
[image]

Represents an object used to draw lines and curves.

The following tables list the members exposed by the Pen type.

Public Constructors

Name | Description
Pen | Overloaded. Initializes a new instance of the Pen class.

Public Properties

Name | Description
Brush | Gets or sets the Brush that determines attributes of this pen.
Color | Gets or sets the color of this pen.
DashPattern | Gets or sets an array of custom dashes and spaces.
DashStyle | Gets or sets the style used for dashed lines drawn with this pen.
LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object.
MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Unit | Gets or sets the unit of the pen width.
Width | Gets or sets the width of this pen.

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor

Pen Constructor
[image]

Initializes a new instance of the Pen class.

Overload List

Name | Description
Pen (Brush, Double) | Initializes a new instance of the Pen class.
Pen (Color) | Initializes a new instance of the Pen class.
Pen (Color, Double) | Initializes a new instance of the Pen class.
Pen (Color, Double, PenUnit) | Initializes a new instance of the Pen class.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Brush, Double)

Pen Constructor (Brush, Double)
See Also
[image]

Initializes a new instance of the Pen class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Brush brush,
double width
)

Visual Basic [image] Copy Code

Public New ( _
brush As Brush, _
width As Double _
)

Parameters

brush

A brush object that defines the fill properties of the pen.

width

The initial width of the pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Color)

Pen Constructor (Color)
See Also
[image]

Initializes a new instance of the Pen class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Color color
)

Visual Basic [image] Copy Code

Public New ( _
color As Color _
)

Parameters

color

The initial color of the pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Color, Double)

Pen Constructor (Color, Double)
See Also
[image]

Initializes a new instance of the Pen class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Color color,
double width
)

Visual Basic [image] Copy Code

Public New ( _
color As Color, _
width As Double _
)

Parameters

color

The initial color of the pen.

width

The initial width of the pen.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Constructor (Color, Double, PenUnit)

Pen Constructor (Color, Double, PenUnit)
See Also
[image]

Initializes a new instance of the Pen class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen (
Color color,
double width,
PenUnit unit
)

Visual Basic [image] Copy Code

Public New ( _
color As Color, _
width As Double, _
unit As PenUnit _
)

Parameters

color

The initial color of the pen.

width

The initial width of the pen.

unit

The initial unit of the pen width.

See Also

Pen Constructor Overload List
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Methods

Pen Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact copy of this pen.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Clone Method

Pen.Clone Method
[image]

Creates an exact copy of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As Pen

Return Value

An instance of the Pen class.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen Properties

Pen Properties
[image]

Public Properties

Name | Description
Brush | Gets or sets the Brush that determines attributes of this pen.
Color | Gets or sets the color of this pen.
DashPattern | Gets or sets an array of custom dashes and spaces.
DashStyle | Gets or sets the style used for dashed lines drawn with this pen.
LineJoin | Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object.
MiterLimit | Gets or sets the limit of the thickness of the join on a mitered corner.
Unit | Gets or sets the unit of the pen width.
Width | Gets or sets the width of this pen.

See Also

Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Brush Property

Pen.Brush Property
[image]

Gets or sets the Brush that determines attributes of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Brush Brush { get; set; }

Visual Basic [image] Copy Code

Public Property Brush As Brush

Property Value

An instance of the Brush class.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Color Property

Pen.Color Property
[image]

Gets or sets the color of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A Color object.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashPattern Property

Pen.DashPattern Property
[image]

Gets or sets an array of custom dashes and spaces.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public double[] DashPattern { get; set; }

Visual Basic [image] Copy Code

Public Property DashPattern As Double()

Property Value

An array of double values.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.DashStyle Property

Pen.DashStyle Property
[image]

Gets or sets the style used for dashed lines drawn with this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public DashStyle DashStyle { get; set; }

Visual Basic [image] Copy Code

Public Property DashStyle As DashStyle

Property Value

An instance of the DashStyle enumeration.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.LineJoin Property

Pen.LineJoin Property
[image]

Gets or sets the join style for the ends of two consecutive lines drawn with this Pen object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public LineJoin LineJoin { get; set; }

Visual Basic [image] Copy Code

Public Property LineJoin As LineJoin

Property Value

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.MiterLimit Property

Pen.MiterLimit Property
[image]

Gets or sets the limit of the thickness of the join on a mitered corner.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float MiterLimit { get; set; }

Visual Basic [image] Copy Code

Public Property MiterLimit As Single

Property Value

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Unit Property

Pen.Unit Property
[image]

Gets or sets the unit of the pen width.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public PenUnit Unit { get; set; }

Visual Basic [image] Copy Code

Public Property Unit As PenUnit

Property Value

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.Pen.Width Property

Pen.Width Property
[image]

Gets or sets the width of this pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public double Width { get; set; }

Visual Basic [image] Copy Code

Public Property Width As Double

Property Value

A double value.

See Also

Pen Members
Pen Class
MindFusion.Drawing Namespace


MindFusion.Drawing.PenUnit Enumeration

PenUnit Enumeration
[image]

Specifies the unit of the width of a pen.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum PenUnit

Visual Basic [image] Copy Code

Public Enum PenUnit

Members

Member name | Description
Dip | Indicates that the width of the pen is expressed as device-independent pixels.
Pixel | Indicates that the width of the pen is expressed as physical pixels.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Class

SolidBrush Class
[image]

Represents a brush that fills the interiors of objects with a solid color.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class SolidBrush : Brush

Visual Basic [image] Copy Code

Public Class SolidBrush
Inherits Brush

Inheritance Hierarchy

System.Object
MindFusion.Drawing.Brush
MindFusion.Drawing.SolidBrush

See Also

SolidBrush Members
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Members

SolidBrush Members
Constructors Properties Methods
[image]

Represents a brush that fills the interiors of objects with a solid color.

The following tables list the members exposed by the SolidBrush type.

Public Constructors

Name | Description
SolidBrush | Initializes a new instance of the SolidBrush class.

Public Properties

Name | Description
Color | Gets or sets the color of the brush.

Public Methods

Name | Description
Clone | Brush.Clone override.
Equals | Brush.Equals override.
GetHashCode | Brush.GetHashCode override.
ToColor | Brush.ToColor override.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Constructor

SolidBrush Constructor
[image]

Initializes a new instance of the SolidBrush class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public SolidBrush (
Color color
)

Visual Basic [image] Copy Code

Public New ( _
color As Color _
)

Parameters

color

The initial color of the brush.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Methods

SolidBrush Methods
[image]

Public Methods

Name | Description
Clone | Brush.Clone override.
Equals | Brush.Equals override.
GetHashCode | Brush.GetHashCode override.
ToColor | Brush.ToColor override.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Clone Method

SolidBrush.Clone Method
[image]

Brush.Clone override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Brush Clone ()

Visual Basic [image] Copy Code

Public Overrides Function Clone () As Brush

Return Value

An instance of the Brush class.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Equals Method

SolidBrush.Equals Method
[image]

Brush.Equals override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Brush other
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
other As Brush _
) As Boolean

Parameters

other

The Brush to compare with the current Brush.

Return Value

true if the specified Brush is equal to the current Brush; otherwise, false.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.GetHashCode Method

SolidBrush.GetHashCode Method
[image]

Brush.GetHashCode override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.ToColor Method

SolidBrush.ToColor Method
[image]

Brush.ToColor override.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override Color ToColor ()

Visual Basic [image] Copy Code

Public Overrides Function ToColor () As Color

Return Value

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush Properties

SolidBrush Properties
[image]

Public Properties

Name | Description
Color | Gets or sets the color of the brush.

See Also

SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.SolidBrush.Color Property

SolidBrush.Color Property
[image]

Gets or sets the color of the brush.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color Color { get; set; }

Visual Basic [image] Copy Code

Public Property Color As Color

Property Value

A Color object.

See Also

SolidBrush Members
SolidBrush Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat Class

StringFormat Class
[image]

Encapsulates text layout information (such as alignment).

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class StringFormat

Visual Basic [image] Copy Code

Public Class StringFormat

Inheritance Hierarchy

System.Object
MindFusion.Drawing.StringFormat

See Also

StringFormat Members
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat Members

StringFormat Members
Constructors Fields Properties Methods
[image]

Encapsulates text layout information (such as alignment).

The following tables list the members exposed by the StringFormat type.

Public Constructors

Name | Description
StringFormat | Overloaded. Initializes a new instance of the StringFormat class.

Public Fields

Name | Description
Default | The default string format.

Public Properties

Name | Description
ClipText | Gets or sets a value indicating whether to clip the text to bounds.
HorizontalAlignment | Gets or sets horizontal alignment of the string.
VerticalAlignment | Gets or sets the vertical alignment of the string.
WrapText | Gets or sets a value indicating whether to wrap the text.

Public Methods

Name | Description
Clone | Creates an exact clone of this object.
Equals | Determines whether the specified object is equal to the current StringFormat.
GetHashCode | Serves as a hash function for a StringFormat object.

See Also

StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat Fields

StringFormat Fields
[image]

Public Fields

Name | Description
Default | The default string format.

See Also

StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat.Default Field

StringFormat.Default Field
[image]

The default string format.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static readonly StringFormat Default

Visual Basic [image] Copy Code

Public Shared ReadOnly Default As StringFormat

See Also

StringFormat Members
StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat Constructor

StringFormat Constructor
[image]

Initializes a new instance of the StringFormat class.

Overload List

Name | Description
StringFormat () | Initializes a new instance of the StringFormat class.
StringFormat (StringFormat) | Initializes a new instance of the StringFormat class.

See Also

StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat Constructor ()

StringFormat Constructor ()
See Also
[image]

Initializes a new instance of the StringFormat class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public StringFormat ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

StringFormat Constructor Overload List
StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat Constructor (StringFormat)

StringFormat Constructor (StringFormat)
See Also
[image]

Initializes a new instance of the StringFormat class.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public StringFormat (
StringFormat format
)

Visual Basic [image] Copy Code

Public New ( _
format As StringFormat _
)

Parameters

format

The StringFormat object from which to initialize this object.

See Also

StringFormat Constructor Overload List
StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat Methods

StringFormat Methods
[image]

Public Methods

Name | Description
Clone | Creates an exact clone of this object.
Equals | Determines whether the specified object is equal to the current StringFormat.
GetHashCode | Serves as a hash function for a StringFormat object.

See Also

StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat.Clone Method

StringFormat.Clone Method
[image]

Creates an exact clone of this object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public StringFormat Clone ()

Visual Basic [image] Copy Code

Public Function Clone () As StringFormat

Return Value

An instance of the StringFormat class.

See Also

StringFormat Members
StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat.Equals Method

StringFormat.Equals Method
[image]

Determines whether the specified object is equal to the current StringFormat.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

The object to compare with the current StringFormat.

Return Value

true if the specified object is equal to the current StringFormat; otherwise, false.

See Also

StringFormat Members
StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat.GetHashCode Method

StringFormat.GetHashCode Method
[image]

Serves as a hash function for a StringFormat object.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

A hash code for this instance that is suitable for use in hashing algorithms and data structures such as a hash table.

See Also

StringFormat Members
StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat Properties

StringFormat Properties
[image]

Public Properties

Name | Description
ClipText | Gets or sets a value indicating whether to clip the text to bounds.
HorizontalAlignment | Gets or sets horizontal alignment of the string.
VerticalAlignment | Gets or sets the vertical alignment of the string.
WrapText | Gets or sets a value indicating whether to wrap the text.

See Also

StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat.ClipText Property

StringFormat.ClipText Property
[image]

Gets or sets a value indicating whether to clip the text to bounds.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public bool ClipText { get; set; }

Visual Basic [image] Copy Code

Public Property ClipText As Boolean

Property Value

See Also

StringFormat Members
StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat.HorizontalAlignment Property

StringFormat.HorizontalAlignment Property
[image]

Gets or sets horizontal alignment of the string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public HorizontalAlignment HorizontalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property HorizontalAlignment As HorizontalAlignment

Property Value

A member of the HorizontalAlignment enumeration.

See Also

StringFormat Members
StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat.VerticalAlignment Property

StringFormat.VerticalAlignment Property
[image]

Gets or sets the vertical alignment of the string.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public VerticalAlignment VerticalAlignment { get; set; }

Visual Basic [image] Copy Code

Public Property VerticalAlignment As VerticalAlignment

Property Value

A member of the VerticalAlignment enumeration.

See Also

StringFormat Members
StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.StringFormat.WrapText Property

StringFormat.WrapText Property
[image]

Gets or sets a value indicating whether to wrap the text.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public bool WrapText { get; set; }

Visual Basic [image] Copy Code

Public Property WrapText As Boolean

Property Value

See Also

StringFormat Members
StringFormat Class
MindFusion.Drawing Namespace


MindFusion.Drawing.TextAlignment Enumeration

TextAlignment Enumeration
[image]

Specifies the alignment of text on the drawing surface.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum TextAlignment

Visual Basic [image] Copy Code

Public Enum TextAlignment

Members

Member name | Description
AlignmentFlag | For internal use only.
BottomCenter | Text is vertically aligned at the bottom, and horizontally aligned at the center.
BottomLeft | Text is vertically aligned at the bottom, and horizontally aligned on the left.
BottomRight | Text is vertically aligned at the bottom, and horizontally aligned on the right.
MiddleCenter | Text is vertically aligned in the middle, and horizontally aligned at the center.
MiddleLeft | Text is vertically aligned in the middle, and horizontally aligned on the left.
MiddleRight | Text is vertically aligned in the middle, and horizontally aligned on the right.
NoWrap | The only flag that can be combines with any of the alignment flags. Specifies that the drawn text should not wrap when the text does not fit in a single line.
TopCenter | Text is vertically aligned at the top, and horizontally aligned at the center.
TopLeft | Text is vertically aligned at the top, and horizontally aligned on the left.
TopRight | Text is vertically aligned at the top, and horizontally aligned on the right.
Unspecified | No alignment is specified.

See Also

MindFusion.Drawing Namespace


MindFusion.Drawing.VerticalAlignment Enumeration

VerticalAlignment Enumeration
[image]

Specifies the vertical alignment of an element.

Namespace: MindFusion.Drawing
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public enum VerticalAlignment

Visual Basic [image] Copy Code

Public Enum VerticalAlignment

Members

Member name | Description
Bottom | Indicates that an element is bottom-aligned to its container.
Center | Indicates that an element is centered in its container.
Top | Indicates that an element is top-aligned to its container.

See Also

MindFusion.Drawing Namespace


MindFusion.Json Namespace
Classes

Classes

Class | Description
Converter | Provides capabilities to convert various types to and from strings in a cutlure-independent way.
JsonContext | Contains methods that can help you serialize and deserialize to and from JSON.
JsonObject | Represents a dictionary of property names and values.
JsonValue | Represents a property value.
Parser | Deserializes objects from a JSON-formatted string.
Serializer | Serializes objects to JSON format.


MindFusion.Json.Converter Class

Converter Class
[image]

Provides capabilities to convert various types to and from strings in a cutlure-independent way.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public sealed class Converter

Visual Basic [image] Copy Code

Public NotInheritable Class Converter

Inheritance Hierarchy

System.Object
MindFusion.Json.Converter

See Also

Converter Members
MindFusion.Json Namespace


MindFusion.Json.Converter Members

Converter Members
Methods
[image]

Provides capabilities to convert various types to and from strings in a cutlure-independent way.

The following tables list the members exposed by the Converter type.

Public Methods

Name | Description
FromBase64String | Converts the specified Base64String to a string.
FromBoolean | Converts the specified bool value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDouble | Converts the specified double value to string.
FromImage | Converts the specified image to string.
FromImageAsync | Converts the specified image to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromPointString | Converts the specified comma separated string to a list of PointF objects.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
ToBase64String | Converts the specified string to a Base64String.
ToBoolean | Converts the specified string value to bool.
ToColor | Converts the specified string value to Color.
ToDateTime | Converts the specified string value to DateTime.
ToDouble | Converts the specified string value to double.
ToImage | Converts the specified string value to image.
ToInt32 | Converts the specified string value to 32-bit integer.
ToInt64 | Converts the specified string value to 64-bit integer.
ToPointString | Converts the list of PointF objects to a comma separated string.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.

See Also

Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter Methods

Converter Methods
[image]

Public Methods

Name | Description
FromBase64String | Converts the specified Base64String to a string.
FromBoolean | Converts the specified bool value to string.
FromColor | Converts the specified color value to string in the format #AARRGGBB.
FromDouble | Converts the specified double value to string.
FromImage | Converts the specified image to string.
FromImageAsync | Converts the specified image to string.
FromInt32 | Converts the specified 32-bit integer value to string.
FromInt64 | Converts the specified 64-bit integer to string.
FromPointString | Converts the specified comma separated string to a list of PointF objects.
FromSingle | Converts the specified float value to string.
FromStream | Converts the specified stream to string.
FromStreamV4 | Converts the specified memory stream to string.
ToBase64String | Converts the specified string to a Base64String.
ToBoolean | Converts the specified string value to bool.
ToColor | Converts the specified string value to Color.
ToDateTime | Converts the specified string value to DateTime.
ToDouble | Converts the specified string value to double.
ToImage | Converts the specified string value to image.
ToInt32 | Converts the specified string value to 32-bit integer.
ToInt64 | Converts the specified string value to 64-bit integer.
ToPointString | Converts the list of PointF objects to a comma separated string.
ToSingle | Converts the specified string value to float.
ToStream | Converts the specified string value to stream.
ToStreamV4 | Converts the specified string value to stream.

See Also

Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromBase64String Method

Converter.FromBase64String Method
[image]

Converts the specified Base64String to a string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string FromBase64String (
string base64EncodedData
)

Visual Basic [image] Copy Code

Public Shared Function FromBase64String( _
base64EncodedData As String _
) As String

Parameters

base64EncodedData

The Base64String to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromBoolean Method

Converter.FromBoolean Method
[image]

Converts the specified bool value to string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string FromBoolean (
bool val
)

Visual Basic [image] Copy Code

Public Shared Function FromBoolean( _
val As Boolean _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromColor Method

Converter.FromColor Method
[image]

Converts the specified color value to string in the format #AARRGGBB.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string FromColor (
Color val
)

Visual Basic [image] Copy Code

Public Shared Function FromColor( _
val As Color _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromDouble Method

Converter.FromDouble Method
[image]

Converts the specified double value to string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string FromDouble (
double val
)

Visual Basic [image] Copy Code

Public Shared Function FromDouble( _
val As Double _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromImage Method

Converter.FromImage Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string FromImage (
ImageSource val,
out string type
)

Visual Basic [image] Copy Code

Public Shared Function FromImage( _
val As ImageSource, _
<System.Runtime.InteropServices.Out()> ByRef type As String _
) As String

Parameters

val

The image object to convert.

type

The type of the specified image representation.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromImageAsync Method

Converter.FromImageAsync Method
[image]

Converts the specified image to string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Task<string> FromImageAsync (
ImageSource val
)

Visual Basic [image] Copy Code

Public Shared Function FromImageAsync( _
val As ImageSource _
) As Task(Of String)

Parameters

val

The image object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromInt32 Method

Converter.FromInt32 Method
[image]

Converts the specified 32-bit integer value to string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string FromInt32 (
int val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt32( _
val As Integer _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromInt64 Method

Converter.FromInt64 Method
[image]

Converts the specified 64-bit integer to string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string FromInt64 (
long val
)

Visual Basic [image] Copy Code

Public Shared Function FromInt64( _
val As Long _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromPointString Method

Converter.FromPointString Method
[image]

Converts the specified comma separated string to a list of PointF objects.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static List<Point> FromPointString (
string s
)

Visual Basic [image] Copy Code

Public Shared Function FromPointString( _
s As String _
) As List(Of Point)

Parameters

s

The comma separated string.

Return Value

A list of PointF objects.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromSingle Method

Converter.FromSingle Method
[image]

Converts the specified float value to string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string FromSingle (
float val
)

Visual Basic [image] Copy Code

Public Shared Function FromSingle( _
val As Single _
) As String

Parameters

val

The value to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromStream Method

Converter.FromStream Method
[image]

Converts the specified stream to string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string FromStream (
Stream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStream( _
val As Stream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.FromStreamV4 Method

Converter.FromStreamV4 Method
[image]

Converts the specified memory stream to string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string FromStreamV4 (
MemoryStream val
)

Visual Basic [image] Copy Code

Public Shared Function FromStreamV4( _
val As MemoryStream _
) As String

Parameters

val

The Stream object to convert.

Return Value

A string representing the specified value.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToBase64String Method

Converter.ToBase64String Method
[image]

Converts the specified string to a Base64String.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string ToBase64String (
string plainText
)

Visual Basic [image] Copy Code

Public Shared Function ToBase64String( _
plainText As String _
) As String

Parameters

plainText

The string value to convert from.

Return Value

A Base64String.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToBoolean Method

Converter.ToBoolean Method
[image]

Converts the specified string value to bool.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static bool ToBoolean (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToBoolean( _
s As String _
) As Boolean

Parameters

s

The string value to convert from.

Return Value

A boolean value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToColor Method

Converter.ToColor Method
[image]

Converts the specified string value to Color.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Color ToColor (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToColor( _
s As String _
) As Color

Parameters

s

The string value to convert from.

Return Value

A Color value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToDateTime Method

Converter.ToDateTime Method
[image]

Converts the specified string value to DateTime.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Nullable<DateTime> ToDateTime (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDateTime( _
s As String _
) As Nullable(Of DateTime)

Parameters

s

The string value to convert from.

Return Value

A DateTime value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToDouble Method

Converter.ToDouble Method
[image]

Converts the specified string value to double.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static double ToDouble (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToDouble( _
s As String _
) As Double

Parameters

s

The string value to convert from.

Return Value

A double value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToImage Method

Converter.ToImage Method
[image]

Converts the specified string value to image.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static ImageSource ToImage (
string s,
string type
)

Visual Basic [image] Copy Code

Public Shared Function ToImage( _
s As String, _
type As String _
) As ImageSource

Parameters

s

type

Return Value

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToInt32 Method

Converter.ToInt32 Method
[image]

Converts the specified string value to 32-bit integer.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static int ToInt32 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt32( _
s As String _
) As Integer

Parameters

s

The string value to convert from.

Return Value

A 32-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToInt64 Method

Converter.ToInt64 Method
[image]

Converts the specified string value to 64-bit integer.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static long ToInt64 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToInt64( _
s As String _
) As Long

Parameters

s

The string value to convert from.

Return Value

A 64-bit integer value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToPointString Method

Converter.ToPointString Method
[image]

Converts the list of PointF objects to a comma separated string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static string ToPointString (
List<Point> points
)

Visual Basic [image] Copy Code

Public Shared Function ToPointString( _
points As List(Of Point) _
) As String

Parameters

points

The list of PointF objects to convert.

Return Value

A comma separated string.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToSingle Method

Converter.ToSingle Method
[image]

Converts the specified string value to float.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static float ToSingle (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToSingle( _
s As String _
) As Single

Parameters

s

The string value to convert from.

Return Value

A float value that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToStream Method

Converter.ToStream Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Stream ToStream (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStream( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A Stream object that is deserialized from the specified string.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.Converter.ToStreamV4 Method

Converter.ToStreamV4 Method
[image]

Converts the specified string value to stream.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static Stream ToStreamV4 (
string s
)

Visual Basic [image] Copy Code

Public Shared Function ToStreamV4( _
s As String _
) As Stream

Parameters

s

The string value to convert from.

Return Value

A Stream object that is deserialized from the specified string.

Remarks

This method is used in XML file format 4 and earlier.

See Also

Converter Members
Converter Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext Class

JsonContext Class
[image]

Contains methods that can help you serialize and deserialize to and from JSON.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class JsonContext

Visual Basic [image] Copy Code

Public Class JsonContext

Inheritance Hierarchy

System.Object
MindFusion.Json.JsonContext
MindFusion.Diagramming.JsonPersistContext

See Also

JsonContext Members
MindFusion.Json Namespace


MindFusion.Json.JsonContext Members

JsonContext Members
Constructors Fields Methods
[image]

Contains methods that can help you serialize and deserialize to and from JSON.

The following tables list the members exposed by the JsonContext type.

Public Constructors

Name | Description
JsonContext | Initializes a new instance of the JsonContext class.

Protected Fields

Name | Description
brushes | A list of all brushes.
inplaceImages | Specifies whether images are encoded in place.
inplaceResources | Specifies whether resource accumulation is disabled.

Public Methods

Name | Description
Parse | Deserializes the specified JSON formatted string to a JsonObject.
ReadBrush | Overloaded.
ReadBrushColor | Reads a Brush object with the specified color.
ReadBrushes | Reads all brushes.
ReadColor | Overloaded.
ReadColorBlend | Overloaded.
ReadEnum | Reads an enum value.
ReadFloatArray | Reads a float array.
ReadFont | Overloaded.
ReadImage | Reads an Image object.
ReadImages | Reads all images.
ReadObject | Reads an object.
ReadPen | Overloaded.
ReadPoint | Reads a PointF object.
ReadPointString | Reads a Point string.
ReadRectangle | Reads a RectangleF object.
ReadSize | Reads a SizeF object.
ReadStringFormat | Reads a StringFormat object.
Serialize | Serializes the specified JsonObject to a JSON formatted string.
WriteBrush | Writes a MindFusion.Drawing.Brush object.
WriteBrushColor | Writes the color of the specified brush.
WriteBrushes | Writes all currently accumulated brushes.
WriteColor | Writes a Color object.
WriteColorBlend | Overloaded.
WriteEnum | Writes an enum value.
WriteFont | Writes a Font object.
WriteImage | Writes an Image object.
WriteImageAsync | Writes an Image object.
WriteImages | Writes all currently accumulated images.
WriteImagesAsync | Writes all currently accumulated images asynchronously.
WriteObject | Writes an object.
WritePen | Writes a MindFusion.Drawing.Pen object.
WritePoint | Writes a PointF object.
WritePointString | Writes a Point string.
WriteRectangle | Writes a RectangleF object.
WriteSize | Writes a SizeF object.
WriteStringFormat | Writes a StringFormat object.

Protected Methods

Name | Description
Base64Decode | Decodes a string from Base64 representation.
Base64Encode | Encodes a string to Base64 representation.
ToCamelCase | Converts a string to Pascal case.
ToPascalCase | Converts a string to Camel case.

See Also

JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext Fields

JsonContext Fields
[image]

Protected Fields

Name | Description
brushes | A list of all brushes.
inplaceImages | Specifies whether images are encoded in place.
inplaceResources | Specifies whether resource accumulation is disabled.

See Also

JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.brushes Field

JsonContext.brushes Field
[image]

A list of all brushes.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected List<Brush> brushes

Visual Basic [image] Copy Code

Protected brushes As List(Of Brush)

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.inplaceImages Field

JsonContext.inplaceImages Field
[image]

Specifies whether images are encoded in place.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected bool inplaceImages

Visual Basic [image] Copy Code

Protected inplaceImages As Boolean

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.inplaceResources Field

JsonContext.inplaceResources Field
[image]

Specifies whether resource accumulation is disabled.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected bool inplaceResources

Visual Basic [image] Copy Code

Protected inplaceResources As Boolean

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext Constructor

JsonContext Constructor
[image]

Initializes a new instance of the JsonContext class.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonContext ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext Methods

JsonContext Methods
[image]

Public Methods

Name | Description
Parse | Deserializes the specified JSON formatted string to a JsonObject.
ReadBrush | Overloaded.
ReadBrushColor | Reads a Brush object with the specified color.
ReadBrushes | Reads all brushes.
ReadColor | Overloaded.
ReadColorBlend | Overloaded.
ReadEnum | Reads an enum value.
ReadFloatArray | Reads a float array.
ReadFont | Overloaded.
ReadImage | Reads an Image object.
ReadImages | Reads all images.
ReadObject | Reads an object.
ReadPen | Overloaded.
ReadPoint | Reads a PointF object.
ReadPointString | Reads a Point string.
ReadRectangle | Reads a RectangleF object.
ReadSize | Reads a SizeF object.
ReadStringFormat | Reads a StringFormat object.
Serialize | Serializes the specified JsonObject to a JSON formatted string.
WriteBrush | Writes a MindFusion.Drawing.Brush object.
WriteBrushColor | Writes the color of the specified brush.
WriteBrushes | Writes all currently accumulated brushes.
WriteColor | Writes a Color object.
WriteColorBlend | Overloaded.
WriteEnum | Writes an enum value.
WriteFont | Writes a Font object.
WriteImage | Writes an Image object.
WriteImageAsync | Writes an Image object.
WriteImages | Writes all currently accumulated images.
WriteImagesAsync | Writes all currently accumulated images asynchronously.
WriteObject | Writes an object.
WritePen | Writes a MindFusion.Drawing.Pen object.
WritePoint | Writes a PointF object.
WritePointString | Writes a Point string.
WriteRectangle | Writes a RectangleF object.
WriteSize | Writes a SizeF object.
WriteStringFormat | Writes a StringFormat object.

Protected Methods

Name | Description
Base64Decode | Decodes a string from Base64 representation.
Base64Encode | Encodes a string to Base64 representation.
ToCamelCase | Converts a string to Pascal case.
ToPascalCase | Converts a string to Camel case.

See Also

JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.Base64Decode Method

JsonContext.Base64Decode Method
[image]

Decodes a string from Base64 representation.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected static string Base64Decode (
string base64EncodedData
)

Visual Basic [image] Copy Code

Protected Shared Function Base64Decode( _
base64EncodedData As String _
) As String

Parameters

base64EncodedData

Input base64 encoded string.

Return Value

The decoded string.

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.Base64Encode Method

JsonContext.Base64Encode Method
[image]

Encodes a string to Base64 representation.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected static string Base64Encode (
string plainText
)

Visual Basic [image] Copy Code

Protected Shared Function Base64Encode( _
plainText As String _
) As String

Parameters

plainText

Input string.

Return Value

Base64 encoded string.

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.Parse Method

JsonContext.Parse Method
[image]

Deserializes the specified JSON formatted string to a JsonObject.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonObject Parse (
string json
)

Visual Basic [image] Copy Code

Public Function Parse( _
json As String _
) As JsonObject

Parameters

json

The JSON string.

Return Value

The deserialized JsonObject.

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadBrush Method

JsonContext.ReadBrush Method
[image]

Overload List

Name | Description
JsonContext.ReadBrush (JsonValue) | Reads a MindFusion.Drawing.Brush object.
JsonContext.ReadBrush (JsonValue, Brush) | Reads a MindFusion.Drawing.Brush object.

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadBrush Method (JsonValue)

JsonContext.ReadBrush Method (JsonValue)
See Also
[image]

Reads a MindFusion.Drawing.Brush object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Brush ReadBrush (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
value As JsonValue _
) As Brush

Parameters

value

Return Value

See Also

ReadBrush Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadBrush Method (JsonValue, Brush)

JsonContext.ReadBrush Method (JsonValue, Brush)
See Also
[image]

Reads a MindFusion.Drawing.Brush object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Brush ReadBrush (
JsonValue value,
Brush defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadBrush( _
value As JsonValue, _
defaultValue As Brush _
) As Brush

Parameters

value

defaultValue

Return Value

See Also

ReadBrush Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadBrushColor Method

JsonContext.ReadBrushColor Method
[image]

Reads a Brush object with the specified color.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Brush ReadBrushColor (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadBrushColor( _
value As JsonValue _
) As Brush

Parameters

value

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadBrushes Method

JsonContext.ReadBrushes Method
[image]

Reads all brushes.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void ReadBrushes (
JsonValue value
)

Visual Basic [image] Copy Code

Public Sub ReadBrushes( _
value As JsonValue _
)

Parameters

value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadColor Method

JsonContext.ReadColor Method
[image]

Overload List

Name | Description
JsonContext.ReadColor (JsonValue) | Reads a color.
JsonContext.ReadColor (JsonValue, Color) | Reads a color.

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadColor Method (JsonValue)

JsonContext.ReadColor Method (JsonValue)
See Also
[image]

Reads a color.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color ReadColor (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
value As JsonValue _
) As Color

Parameters

value

Return Value

See Also

ReadColor Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadColor Method (JsonValue, Color)

JsonContext.ReadColor Method (JsonValue, Color)
See Also
[image]

Reads a color.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Color ReadColor (
JsonValue value,
Color defaultValue
)

Visual Basic [image] Copy Code

Public Function ReadColor( _
value As JsonValue, _
defaultValue As Color _
) As Color

Parameters

value

defaultValue

Return Value

See Also

ReadColor Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadColorBlend Method

JsonContext.ReadColorBlend Method
[image]

Overload List

Name | Description
JsonContext.ReadColorBlend (JsonValue, LinearGradientBrush@) | Reads a ColorBlend object.
JsonContext.ReadColorBlend (JsonValue, PathGradientBrush@) | Reads a ColorBlend object.

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadColorBlend Method (JsonValue, LinearGradientBrush@)

JsonContext.ReadColorBlend Method (JsonValue, LinearGradientBrush@)
See Also
[image]

Reads a ColorBlend object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void ReadColorBlend (
JsonValue value,
ref LinearGradientBrush brush
)

Visual Basic [image] Copy Code

Public Sub ReadColorBlend( _
value As JsonValue, _
ByRef brush As LinearGradientBrush _
)

Parameters

value

brush

See Also

ReadColorBlend Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadColorBlend Method (JsonValue, PathGradientBrush@)

JsonContext.ReadColorBlend Method (JsonValue, PathGradientBrush@)
See Also
[image]

Reads a ColorBlend object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void ReadColorBlend (
JsonValue value,
ref PathGradientBrush brush
)

Visual Basic [image] Copy Code

Public Sub ReadColorBlend( _
value As JsonValue, _
ByRef brush As PathGradientBrush _
)

Parameters

value

brush

See Also

ReadColorBlend Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadEnum Method

JsonContext.ReadEnum Method
[image]

Reads an enum value.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Object ReadEnum (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadEnum( _
value As JsonValue _
) As Object

Parameters

value

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadFloatArray Method

JsonContext.ReadFloatArray Method
[image]

Reads a float array.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public float[] ReadFloatArray (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadFloatArray( _
value As JsonValue _
) As Single()

Parameters

value

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadFont Method

JsonContext.ReadFont Method
[image]

Overload List

Name | Description
JsonContext.ReadFont (JsonObject) | Reads a Font object.
JsonContext.ReadFont (JsonObject, Font) | Reads a Font object.

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadFont Method (JsonObject)

JsonContext.ReadFont Method (JsonObject)
See Also
[image]

Reads a Font object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Font ReadFont (
JsonObject obj
)

Visual Basic [image] Copy Code

Public Function ReadFont( _
obj As JsonObject _
) As Font

Parameters

obj

Return Value

See Also

ReadFont Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadFont Method (JsonObject, Font)

JsonContext.ReadFont Method (JsonObject, Font)
See Also
[image]

Reads a Font object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual Font ReadFont (
JsonObject obj,
Font defaultFont
)

Visual Basic [image] Copy Code

Public Overridable Function ReadFont( _
obj As JsonObject, _
defaultFont As Font _
) As Font

Parameters

obj

defaultFont

Return Value

See Also

ReadFont Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadImage Method

JsonContext.ReadImage Method
[image]

Reads an Image object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public ImageSource ReadImage (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadImage( _
value As JsonValue _
) As ImageSource

Parameters

value

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadImages Method

JsonContext.ReadImages Method
[image]

Reads all images.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public void ReadImages (
JsonValue value
)

Visual Basic [image] Copy Code

Public Sub ReadImages( _
value As JsonValue _
)

Parameters

value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadObject Method

JsonContext.ReadObject Method
[image]

Reads an object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Object ReadObject (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadObject( _
value As JsonValue _
) As Object

Parameters

value

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadPen Method

JsonContext.ReadPen Method
[image]

Overload List

Name | Description
JsonContext.ReadPen (JsonValue) | Reads a MindFusion.Drawing.Pen object.
JsonContext.ReadPen (JsonValue, Pen) | Reads a MindFusion.Drawing.Pen object.

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadPen Method (JsonValue)

JsonContext.ReadPen Method (JsonValue)
See Also
[image]

Reads a MindFusion.Drawing.Pen object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen ReadPen (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
value As JsonValue _
) As Pen

Parameters

value

Return Value

See Also

ReadPen Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadPen Method (JsonValue, Pen)

JsonContext.ReadPen Method (JsonValue, Pen)
See Also
[image]

Reads a MindFusion.Drawing.Pen object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Pen ReadPen (
JsonValue value,
Pen defaultPen
)

Visual Basic [image] Copy Code

Public Function ReadPen( _
value As JsonValue, _
defaultPen As Pen _
) As Pen

Parameters

value

defaultPen

Return Value

See Also

ReadPen Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadPoint Method

JsonContext.ReadPoint Method
[image]

Reads a PointF object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Point ReadPoint (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadPoint( _
value As JsonValue _
) As Point

Parameters

value

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadPointString Method

JsonContext.ReadPointString Method
[image]

Reads a Point string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public List<Point> ReadPointString (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadPointString( _
value As JsonValue _
) As List(Of Point)

Parameters

value

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadRectangle Method

JsonContext.ReadRectangle Method
[image]

Reads a RectangleF object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Rect ReadRectangle (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadRectangle( _
value As JsonValue _
) As Rect

Parameters

value

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadSize Method

JsonContext.ReadSize Method
[image]

Reads a SizeF object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Size ReadSize (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadSize( _
value As JsonValue _
) As Size

Parameters

value

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ReadStringFormat Method

JsonContext.ReadStringFormat Method
[image]

Reads a StringFormat object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public StringFormat ReadStringFormat (
JsonValue value
)

Visual Basic [image] Copy Code

Public Function ReadStringFormat( _
value As JsonValue _
) As StringFormat

Parameters

value

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.Serialize Method

JsonContext.Serialize Method
[image]

Serializes the specified JsonObject to a JSON formatted string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public string Serialize (
JsonObject obj
)

Visual Basic [image] Copy Code

Public Function Serialize( _
obj As JsonObject _
) As String

Parameters

obj

The JsonObject to serialize.

Return Value

The serialized string.

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ToCamelCase Method

JsonContext.ToCamelCase Method
[image]

Converts a string to Pascal case.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected static string ToCamelCase (
string text
)

Visual Basic [image] Copy Code

Protected Shared Function ToCamelCase( _
text As String _
) As String

Parameters

text

Input string.

Return Value

The string in Pascal case

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.ToPascalCase Method

JsonContext.ToPascalCase Method
[image]

Converts a string to Camel case.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

protected static string ToPascalCase (
string text
)

Visual Basic [image] Copy Code

Protected Shared Function ToPascalCase( _
text As String _
) As String

Parameters

text

Input string.

Return Value

The string in Camel case

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteBrush Method

JsonContext.WriteBrush Method
[image]

Writes a MindFusion.Drawing.Brush object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WriteBrush (
Brush brush
)

Visual Basic [image] Copy Code

Public Function WriteBrush( _
brush As Brush _
) As JsonValue

Parameters

brush

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteBrushColor Method

JsonContext.WriteBrushColor Method
[image]

Writes the color of the specified brush.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WriteBrushColor (
Brush brush
)

Visual Basic [image] Copy Code

Public Function WriteBrushColor( _
brush As Brush _
) As JsonValue

Parameters

brush

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteBrushes Method

JsonContext.WriteBrushes Method
[image]

Writes all currently accumulated brushes.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WriteBrushes ()

Visual Basic [image] Copy Code

Public Function WriteBrushes () As JsonValue

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteColor Method

JsonContext.WriteColor Method
[image]

Writes a Color object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual JsonValue WriteColor (
Color color
)

Visual Basic [image] Copy Code

Public Overridable Function WriteColor( _
color As Color _
) As JsonValue

Parameters

color

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteColorBlend Method

JsonContext.WriteColorBlend Method
[image]

Overload List

Name | Description
JsonContext.WriteColorBlend (LinearGradientBrush) | Writes a ColorBlend object.
JsonContext.WriteColorBlend (PathGradientBrush) | Writes a ColorBlend object.

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteColorBlend Method (LinearGradientBrush)

JsonContext.WriteColorBlend Method (LinearGradientBrush)
See Also
[image]

Writes a ColorBlend object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WriteColorBlend (
LinearGradientBrush brush
)

Visual Basic [image] Copy Code

Public Function WriteColorBlend( _
brush As LinearGradientBrush _
) As JsonValue

Parameters

brush

Return Value

See Also

WriteColorBlend Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteColorBlend Method (PathGradientBrush)

JsonContext.WriteColorBlend Method (PathGradientBrush)
See Also
[image]

Writes a ColorBlend object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WriteColorBlend (
PathGradientBrush brush
)

Visual Basic [image] Copy Code

Public Function WriteColorBlend( _
brush As PathGradientBrush _
) As JsonValue

Parameters

brush

Return Value

See Also

WriteColorBlend Method Overload List
JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteEnum Method

JsonContext.WriteEnum Method
[image]

Writes an enum value.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WriteEnum (
Object enumValue
)

Visual Basic [image] Copy Code

Public Function WriteEnum( _
enumValue As Object _
) As JsonValue

Parameters

enumValue

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteFont Method

JsonContext.WriteFont Method
[image]

Writes a Font object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public virtual JsonObject WriteFont (
Nullable<Font> font
)

Visual Basic [image] Copy Code

Public Overridable Function WriteFont( _
font As Nullable(Of Font) _
) As JsonObject

Parameters

font

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteImage Method

JsonContext.WriteImage Method
[image]

Writes an Image object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WriteImage (
ImageSource image
)

Visual Basic [image] Copy Code

Public Function WriteImage( _
image As ImageSource _
) As JsonValue

Parameters

image

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteImageAsync Method

JsonContext.WriteImageAsync Method
[image]

Writes an Image object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Task<JsonValue> WriteImageAsync (
ImageSource image
)

Visual Basic [image] Copy Code

Public Function WriteImageAsync( _
image As ImageSource _
) As Task(Of JsonValue)

Parameters

image

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteImages Method

JsonContext.WriteImages Method
[image]

Writes all currently accumulated images.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WriteImages ()

Visual Basic [image] Copy Code

Public Function WriteImages () As JsonValue

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteImagesAsync Method

JsonContext.WriteImagesAsync Method
[image]

Writes all currently accumulated images asynchronously.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Task<JsonValue> WriteImagesAsync ()

Visual Basic [image] Copy Code

Public Function WriteImagesAsync () As Task(Of JsonValue)

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteObject Method

JsonContext.WriteObject Method
[image]

Writes an object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WriteObject (
Object objectValue
)

Visual Basic [image] Copy Code

Public Function WriteObject( _
objectValue As Object _
) As JsonValue

Parameters

objectValue

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WritePen Method

JsonContext.WritePen Method
[image]

Writes a MindFusion.Drawing.Pen object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WritePen (
Pen pen
)

Visual Basic [image] Copy Code

Public Function WritePen( _
pen As Pen _
) As JsonValue

Parameters

pen

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WritePoint Method

JsonContext.WritePoint Method
[image]

Writes a PointF object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonObject WritePoint (
Point point
)

Visual Basic [image] Copy Code

Public Function WritePoint( _
point As Point _
) As JsonObject

Parameters

point

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WritePointString Method

JsonContext.WritePointString Method
[image]

Writes a Point string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WritePointString (
List<Point> points
)

Visual Basic [image] Copy Code

Public Function WritePointString( _
points As List(Of Point) _
) As JsonValue

Parameters

points

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteRectangle Method

JsonContext.WriteRectangle Method
[image]

Writes a RectangleF object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonObject WriteRectangle (
Rect rectangle
)

Visual Basic [image] Copy Code

Public Function WriteRectangle( _
rectangle As Rect _
) As JsonObject

Parameters

rectangle

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteSize Method

JsonContext.WriteSize Method
[image]

Writes a SizeF object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonObject WriteSize (
Size size
)

Visual Basic [image] Copy Code

Public Function WriteSize( _
size As Size _
) As JsonObject

Parameters

size

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonContext.WriteStringFormat Method

JsonContext.WriteStringFormat Method
[image]

Writes a StringFormat object.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue WriteStringFormat (
StringFormat stringFormat
)

Visual Basic [image] Copy Code

Public Function WriteStringFormat( _
stringFormat As StringFormat _
) As JsonValue

Parameters

stringFormat

Return Value

See Also

JsonContext Members
JsonContext Class
MindFusion.Json Namespace


MindFusion.Json.JsonObject Class

JsonObject Class
[image]

Represents a dictionary of property names and values.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class JsonObject : Dictionary<string, JsonValue>

Visual Basic [image] Copy Code

Public Class JsonObject
Inherits Dictionary(Of String, JsonValue)

Inheritance Hierarchy

System.Object
System.Collections.Generic.Dictionary(String, JsonValue)
MindFusion.Json.JsonObject

See Also

JsonObject Members
MindFusion.Json Namespace


MindFusion.Json.JsonObject Members

JsonObject Members
Constructors Methods
[image]

Represents a dictionary of property names and values.

The following tables list the members exposed by the JsonObject type.

Public Constructors

Name | Description
JsonObject | Initializes a new instance of the JsonObject class.

Public Methods

Name | Description
FromDictionary | Converts a generic dictionary to a JsonObject.
GetValue | Overloaded.

See Also

JsonObject Class
MindFusion.Json Namespace


MindFusion.Json.JsonObject Constructor

JsonObject Constructor
[image]

Initializes a new instance of the JsonObject class.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonObject ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

JsonObject Class
MindFusion.Json Namespace


MindFusion.Json.JsonObject Methods

JsonObject Methods
[image]

Public Methods

Name | Description
FromDictionary | Converts a generic dictionary to a JsonObject.
GetValue | Overloaded.

See Also

JsonObject Class
MindFusion.Json Namespace


MindFusion.Json.JsonObject.FromDictionary(TKey, TValue) Method

JsonObject.FromDictionary(TKey, TValue) Method
[image]

Converts a generic dictionary to a JsonObject.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public static JsonObject FromDictionary<TKey, TValue> (
Dictionary<TKey, TValue> dictionary
)

Visual Basic [image] Copy Code

Public Shared Function FromDictionary(Of TKey, TValue) ( _
dictionary As Dictionary(Of TKey, TValue) _
) As JsonObject

Parameters

dictionary

Return Value

See Also

JsonObject Members
JsonObject Class
MindFusion.Json Namespace


MindFusion.Json.JsonObject.GetValue Method

JsonObject.GetValue Method
[image]

Overload List

Name | Description
JsonObject.GetValue (String) | Returns the value associated with the specified key, or a default value if the key is not present in the dictionary.
JsonObject.GetValue (String, JsonValue) | Returns the value associated with the specified key, or a default value if the key is not present in the dictionary.

See Also

JsonObject Members
JsonObject Class
MindFusion.Json Namespace


MindFusion.Json.JsonObject.GetValue Method (String)

JsonObject.GetValue Method (String)
See Also
[image]

Returns the value associated with the specified key, or a default value if the key is not present in the dictionary.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue GetValue (
string key
)

Visual Basic [image] Copy Code

Public Function GetValue( _
key As String _
) As JsonValue

Parameters

key

Return Value

See Also

GetValue Method Overload List
JsonObject Members
JsonObject Class
MindFusion.Json Namespace


MindFusion.Json.JsonObject.GetValue Method (String, JsonValue)

JsonObject.GetValue Method (String, JsonValue)
See Also
[image]

Returns the value associated with the specified key, or a default value if the key is not present in the dictionary.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue GetValue (
string key,
JsonValue defaultValue
)

Visual Basic [image] Copy Code

Public Function GetValue( _
key As String, _
defaultValue As JsonValue _
) As JsonValue

Parameters

key

defaultValue

Return Value

See Also

GetValue Method Overload List
JsonObject Members
JsonObject Class
MindFusion.Json Namespace


MindFusion.Json.JsonValue Class

JsonValue Class
[image]

Represents a property value.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class JsonValue

Visual Basic [image] Copy Code

Public Class JsonValue

Inheritance Hierarchy

System.Object
MindFusion.Json.JsonValue

See Also

JsonValue Members
MindFusion.Json Namespace


MindFusion.Json.JsonValue Members

JsonValue Members
Constructors Properties Methods
[image]

Represents a property value.

The following tables list the members exposed by the JsonValue type.

Public Constructors

Name | Description
JsonValue | Initializes a new instance of the JsonValue class.

Public Properties

Name | Description
Value | Gets the value.

Public Methods

Name | Description
Equals | Object.Equals overload.
GetHashCode | Object.GetHashCode overload.
ToArrayList | Converts the value to ArrayList.
ToString | Object.ToString overload.

See Also

JsonValue Class
MindFusion.Json Namespace


MindFusion.Json.JsonValue Constructor

JsonValue Constructor
[image]

Initializes a new instance of the JsonValue class.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonValue (
Object value
)

Visual Basic [image] Copy Code

Public New ( _
value As Object _
)

Parameters

value

See Also

JsonValue Class
MindFusion.Json Namespace


MindFusion.Json.JsonValue Methods

JsonValue Methods
[image]

Public Methods

Name | Description
Equals | Object.Equals overload.
GetHashCode | Object.GetHashCode overload.
ToArrayList | Converts the value to ArrayList.
ToString | Object.ToString overload.

See Also

JsonValue Class
MindFusion.Json Namespace


MindFusion.Json.JsonValue.Equals Method

JsonValue.Equals Method
[image]

Object.Equals overload.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

Return Value

See Also

JsonValue Members
JsonValue Class
MindFusion.Json Namespace


MindFusion.Json.JsonValue.GetHashCode Method

JsonValue.GetHashCode Method
[image]

Object.GetHashCode overload.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

JsonValue Members
JsonValue Class
MindFusion.Json Namespace


MindFusion.Json.JsonValue.ToArrayList Method

JsonValue.ToArrayList Method
[image]

Converts the value to ArrayList.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public ArrayList ToArrayList ()

Visual Basic [image] Copy Code

Public Function ToArrayList () As ArrayList

Return Value

See Also

JsonValue Members
JsonValue Class
MindFusion.Json Namespace


MindFusion.Json.JsonValue.ToString Method

JsonValue.ToString Method
[image]

Object.ToString overload.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

JsonValue Members
JsonValue Class
MindFusion.Json Namespace


MindFusion.Json.JsonValue Properties

JsonValue Properties
[image]

Public Properties

Name | Description
Value | Gets the value.

See Also

JsonValue Class
MindFusion.Json Namespace


MindFusion.Json.JsonValue.Value Property

JsonValue.Value Property
[image]

Gets the value.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Object Value { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property Value As Object

Property Value

See Also

JsonValue Members
JsonValue Class
MindFusion.Json Namespace


MindFusion.Json.Parser Class

Parser Class
[image]

Deserializes objects from a JSON-formatted string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class Parser

Visual Basic [image] Copy Code

Public Class Parser

Inheritance Hierarchy

System.Object
MindFusion.Json.Parser

See Also

Parser Members
MindFusion.Json Namespace


MindFusion.Json.Parser Members

Parser Members
Constructors Methods
[image]

Deserializes objects from a JSON-formatted string.

The following tables list the members exposed by the Parser type.

Public Constructors

Name | Description
Parser | Initializes a new instance of the Parser class.

Public Methods

Name | Description
ReadJsonObject | Deserializes a JsonObject from the specified JSON-formatted string.

See Also

Parser Class
MindFusion.Json Namespace


MindFusion.Json.Parser Constructor

Parser Constructor
[image]

Initializes a new instance of the Parser class.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Parser ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Parser Class
MindFusion.Json Namespace


MindFusion.Json.Parser Methods

Parser Methods
[image]

Public Methods

Name | Description
ReadJsonObject | Deserializes a JsonObject from the specified JSON-formatted string.

See Also

Parser Class
MindFusion.Json Namespace


MindFusion.Json.Parser.ReadJsonObject Method

Parser.ReadJsonObject Method
[image]

Deserializes a JsonObject from the specified JSON-formatted string.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public JsonObject ReadJsonObject (
string json,
JsonContext context
)

Visual Basic [image] Copy Code

Public Function ReadJsonObject( _
json As String, _
context As JsonContext _
) As JsonObject

Parameters

json

The JSON-formatted string.

context

A JsonContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

Parser Members
Parser Class
MindFusion.Json Namespace


MindFusion.Json.Serializer Class

Serializer Class
[image]

Serializes objects to JSON format.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public class Serializer

Visual Basic [image] Copy Code

Public Class Serializer

Inheritance Hierarchy

System.Object
MindFusion.Json.Serializer

See Also

Serializer Members
MindFusion.Json Namespace


MindFusion.Json.Serializer Members

Serializer Members
Constructors Methods
[image]

Serializes objects to JSON format.

The following tables list the members exposed by the Serializer type.

Public Constructors

Name | Description
Serializer | Initializes a new instance of the Serializer class.

Public Methods

Name | Description
Serialize | Serializes the specified JsonObject.

See Also

Serializer Class
MindFusion.Json Namespace


MindFusion.Json.Serializer Constructor

Serializer Constructor
[image]

Initializes a new instance of the Serializer class.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public Serializer ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Serializer Class
MindFusion.Json Namespace


MindFusion.Json.Serializer Methods

Serializer Methods
[image]

Public Methods

Name | Description
Serialize | Serializes the specified JsonObject.

See Also

Serializer Class
MindFusion.Json Namespace


MindFusion.Json.Serializer.Serialize Method

Serializer.Serialize Method
[image]

Serializes the specified JsonObject.

Namespace: MindFusion.Json
Assembly: MindFusion.Common

Syntax

C# [image] Copy Code

public string Serialize (
JsonObject obj,
JsonContext context
)

Visual Basic [image] Copy Code

Public Function Serialize( _
obj As JsonObject, _
context As JsonContext _
) As String

Parameters

obj

The JsonObject to serialize.

context

A JsonContext object providing contextual information about the serialization process and some helper serialization methods.

Return Value

See Also

Serializer Members
Serializer Class
MindFusion.Json Namespace


MindFusion.Layout Namespace
Classes Interfaces Delegates Enumerations

Classes

Class | Description
AnnealLayoutStatistics | Contains the accumulated costs for a graph configuration produced by AnnealLayout.
LayoutRules |
Pair | A pair of objects.

Interfaces

Interface | Description
RoutingOptions | Allows customization of various aspects of the link routing algorithm.

Delegates

Delegate | Description
RouteHeuristics | The link routing algorithm uses a heuristic function of this type in its prediction steps.

Enumerations

Enumeration | Description
AssistantType | Indicates the type of an assistant node in a tree.
BaseLayout | Specifies how OrthogonalRouter should arrange nodes.
HierarchicalLayoutTraits | Indicates item traits specific to hierarchical layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
LayeredLayoutTraits | Indicates item traits specific to layered layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
PreferredRules | Specifies which set of rules to use.
SpringLayoutMethod | Specifies what energy model SpringLayout should use for the simulation.
SpringLayoutTraits | Indicates item traits specific to SpringLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
SwimlaneLayoutTraits | Indicates item traits specific to swimlane layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
TreeLayoutTraits | Indicates item traits specific to tree layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.
TreeMapLayoutTraits | Indicates item traits specific to tree map layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.


MindFusion.Layout.AnnealLayoutStatistics Class

AnnealLayoutStatistics Class
[image]

Contains the accumulated costs for a graph configuration produced by AnnealLayout.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class AnnealLayoutStatistics

Visual Basic [image] Copy Code

Public Class AnnealLayoutStatistics

Inheritance Hierarchy

System.Object
MindFusion.Layout.AnnealLayoutStatistics

See Also

AnnealLayoutStatistics Members
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Members

AnnealLayoutStatistics Members
Constructors Properties Methods
[image]

Contains the accumulated costs for a graph configuration produced by AnnealLayout.

The following tables list the members exposed by the AnnealLayoutStatistics type.

Public Constructors

Name | Description
AnnealLayoutStatistics | Initializes a new instance of the AnnealLayoutStatistics class.

Public Properties

Name | Description
BoundaryCost | The total distance-to-boundary cost of a graph configuration.
DistributionCost | The total distribution cost of a graph configuration.
EdgeCrossingsCost | The total edge crossings cost of a graph configuration.
EdgeCrossingsFound | The number of edge crossings in the graph configuration.
EdgeLengthsCost | The total edge lengths cost of a graph configuration.
NodeEdgeDistance | The total node-to-edge-distance cost of a graph configuration.

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Constructor

AnnealLayoutStatistics Constructor
[image]

Initializes a new instance of the AnnealLayoutStatistics class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public AnnealLayoutStatistics ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Methods

AnnealLayoutStatistics Methods
[image]

Public Methods

Name | Description
ToString | Object.ToString override.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.ToString Method

AnnealLayoutStatistics.ToString Method
[image]

Object.ToString override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override string ToString ()

Visual Basic [image] Copy Code

Public Overrides Function ToString () As String

Return Value

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics Properties

AnnealLayoutStatistics Properties
[image]

Public Properties

Name | Description
BoundaryCost | The total distance-to-boundary cost of a graph configuration.
DistributionCost | The total distribution cost of a graph configuration.
EdgeCrossingsCost | The total edge crossings cost of a graph configuration.
EdgeCrossingsFound | The number of edge crossings in the graph configuration.
EdgeLengthsCost | The total edge lengths cost of a graph configuration.
NodeEdgeDistance | The total node-to-edge-distance cost of a graph configuration.

See Also

AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.BoundaryCost Property

AnnealLayoutStatistics.BoundaryCost Property
[image]

The total distance-to-boundary cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double BoundaryCost { get; set; }

Visual Basic [image] Copy Code

Public Property BoundaryCost As Double

Property Value

A double value.

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.DistributionCost Property

AnnealLayoutStatistics.DistributionCost Property
[image]

The total distribution cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double DistributionCost { get; set; }

Visual Basic [image] Copy Code

Public Property DistributionCost As Double

Property Value

A double value.

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeCrossingsCost Property

AnnealLayoutStatistics.EdgeCrossingsCost Property
[image]

The total edge crossings cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double EdgeCrossingsCost { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeCrossingsCost As Double

Property Value

A double value.

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeCrossingsFound Property

AnnealLayoutStatistics.EdgeCrossingsFound Property
[image]

The number of edge crossings in the graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int EdgeCrossingsFound { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeCrossingsFound As Integer

Property Value

An integer value.

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.EdgeLengthsCost Property

AnnealLayoutStatistics.EdgeLengthsCost Property
[image]

The total edge lengths cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double EdgeLengthsCost { get; set; }

Visual Basic [image] Copy Code

Public Property EdgeLengthsCost As Double

Property Value

A double value.

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AnnealLayoutStatistics.NodeEdgeDistance Property

AnnealLayoutStatistics.NodeEdgeDistance Property
[image]

The total node-to-edge-distance cost of a graph configuration.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public double NodeEdgeDistance { get; set; }

Visual Basic [image] Copy Code

Public Property NodeEdgeDistance As Double

Property Value

A double value.

See Also

AnnealLayoutStatistics Members
AnnealLayoutStatistics Class
MindFusion.Layout Namespace


MindFusion.Layout.AssistantType Enumeration

AssistantType Enumeration
[image]

Indicates the type of an assistant node in a tree.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum AssistantType

Visual Basic [image] Copy Code

Public Enum AssistantType

Members

Member name | Description
Left | The node is an assistant and it is always positioned to the left of its parent.
None | The node is not an assistant.
Normal | The node is an assistant and its relative position is determined automatically by the layout.
Right | The node is an assistant and it is always positioned to the right of its parent.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.BaseLayout Enumeration

BaseLayout Enumeration
[image]

Specifies how OrthogonalRouter should arrange nodes.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum BaseLayout

Visual Basic [image] Copy Code

Public Enum BaseLayout

Members

Member name | Description
Cascading | Use TreeLayout to arrange nodes.
Custom | Use the current node configuration.
Grid | Use GridLayout to arrange nodes.
Layered | Use LayeredLayout to arrange nodes.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.HierarchicalLayoutTraits Enumeration

HierarchicalLayoutTraits Enumeration
[image]

Indicates item traits specific to hierarchical layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum HierarchicalLayoutTraits

Visual Basic [image] Copy Code

Public Enum HierarchicalLayoutTraits

Members

Member name | Description
Level | The number associated with this key specifies the index of the level of the item in the level-planar graph.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.LayeredLayoutTraits Enumeration

LayeredLayoutTraits Enumeration
[image]

Indicates item traits specific to layered layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum LayeredLayoutTraits

Visual Basic [image] Copy Code

Public Enum LayeredLayoutTraits

Members

Member name | Description
Layer | The number associated with this key specifies the index of the layer the layout should attempt to place the node to. Specifying a negative number indicates a layer starting from the last. For example, -1 would indicate the last layer, -2 – the layer before the last, and so on.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Class

LayoutRules Class
[image]

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class LayoutRules

Visual Basic [image] Copy Code

Public Class LayoutRules

Inheritance Hierarchy

System.Object
MindFusion.Layout.LayoutRules

See Also

LayoutRules Members
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Members

LayoutRules Members
Constructors Methods
[image]

The following tables list the members exposed by the LayoutRules type.

Public Constructors

Name | Description
LayoutRules | Initializes a new instance of the LayoutRules class.

Public Methods

Name | Description
AddLayoutRule | Overloaded. Adds or sets a new rule.
BuildKey | Builds a key – object for the new rule, as a pair of two objects: obj1 and obj2
GetLayoutRule | If there is rule with key – Key initializes – Value otherwise fails;

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Constructor

LayoutRules Constructor
[image]

Initializes a new instance of the LayoutRules class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public LayoutRules ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules Methods

LayoutRules Methods
[image]

Public Methods

Name | Description
AddLayoutRule | Overloaded. Adds or sets a new rule.
BuildKey | Builds a key – object for the new rule, as a pair of two objects: obj1 and obj2
GetLayoutRule | If there is rule with key – Key initializes – Value otherwise fails;

See Also

LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method

LayoutRules.AddLayoutRule Method
[image]

Adds or sets a new rule.

Overload List

Name | Description
LayoutRules.AddLayoutRule (Object, Object) | Adds or sets a new rule, depending on if the rule with key – Key already exists or no;
LayoutRules.AddLayoutRule (Object, Object, Object) | Builds a key as a pair of the objects Object1 and Object2 and adds or sets a new rule, with this key and value – Value;

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method (Object, Object)

LayoutRules.AddLayoutRule Method (Object, Object)
See Also
[image]

Adds or sets a new rule, depending on if the rule with key – Key already exists or no;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddLayoutRule (
Object Key,
Object Value
)

Visual Basic [image] Copy Code

Public Function AddLayoutRule( _
Key As Object, _
Value As Object _
) As Boolean

Parameters

Key

Value

Return Value

See Also

AddLayoutRule Method Overload List
LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.AddLayoutRule Method (Object, Object, Object)

LayoutRules.AddLayoutRule Method (Object, Object, Object)
See Also
[image]

Builds a key as a pair of the objects Object1 and Object2 and adds or sets a new rule, with this key and value – Value;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public bool AddLayoutRule (
Object Object1,
Object Object2,
Object Value
)

Visual Basic [image] Copy Code

Public Function AddLayoutRule( _
Object1 As Object, _
Object2 As Object, _
Value As Object _
) As Boolean

Parameters

Object1

Object2

Value

Return Value

See Also

AddLayoutRule Method Overload List
LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.BuildKey Method

LayoutRules.BuildKey Method
[image]

Builds a key – object for the new rule, as a pair of two objects: obj1 and obj2

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object BuildKey (
Object obj1,
Object obj2
)

Visual Basic [image] Copy Code

Public Function BuildKey( _
obj1 As Object, _
obj2 As Object _
) As Object

Parameters

obj1

obj2

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.LayoutRules.GetLayoutRule Method

LayoutRules.GetLayoutRule Method
[image]

If there is rule with key – Key initializes – Value otherwise fails;

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public virtual bool GetLayoutRule (
Object Key,
out Object Value
)

Visual Basic [image] Copy Code

Public Overridable Function GetLayoutRule( _
Key As Object, _
<System.Runtime.InteropServices.Out()> ByRef Value As Object _
) As Boolean

Parameters

Key

Value

Return Value

See Also

LayoutRules Members
LayoutRules Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Class

Pair Class
[image]

A pair of objects.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public class Pair : IComparable

Visual Basic [image] Copy Code

Public Class Pair
Implements IComparable

Inheritance Hierarchy

System.Object
MindFusion.Layout.Pair

See Also

Pair Members
MindFusion.Layout Namespace


MindFusion.Layout.Pair Members

Pair Members
Constructors Properties Methods
[image]

A pair of objects.

The following tables list the members exposed by the Pair type.

Public Constructors

Name | Description
Pair | Overloaded.

Public Properties

Name | Description
FirstObject | Gets or sets the first pair object.
PairElements | Gets the elements of the pair as an arraylist
SecondObject | Gets or sets the second pair object.

Public Methods

Name | Description
CompareTo | Implements IComparable.CompareTo.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor

Pair Constructor
[image]

Overload List

Name | Description
Pair () | Initializes a new instance of the Pair class.
Pair (Object, Object) | Initializes a new instance of the Pair class.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor ()

Pair Constructor ()
See Also
[image]

Initializes a new instance of the Pair class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pair ()

Visual Basic [image] Copy Code

Public Sub New ()

See Also

Pair Constructor Overload List
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Constructor (Object, Object)

Pair Constructor (Object, Object)
See Also
[image]

Initializes a new instance of the Pair class.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Pair (
Object obj1,
Object obj2
)

Visual Basic [image] Copy Code

Public New ( _
obj1 As Object, _
obj2 As Object _
)

Parameters

obj1

obj2

See Also

Pair Constructor Overload List
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Methods

Pair Methods
[image]

Public Methods

Name | Description
CompareTo | Implements IComparable.CompareTo.
Equals | Object.Equals override.
GetHashCode | Object.GetHashCode override.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.CompareTo Method

Pair.CompareTo Method
[image]

Implements IComparable.CompareTo.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public int CompareTo (
Object obj
)

Visual Basic [image] Copy Code

Public Function CompareTo( _
obj As Object _
) As Integer

Parameters

obj

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.Equals Method

Pair.Equals Method
[image]

Object.Equals override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override bool Equals (
Object obj
)

Visual Basic [image] Copy Code

Public Overrides Function Equals( _
obj As Object _
) As Boolean

Parameters

obj

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.GetHashCode Method

Pair.GetHashCode Method
[image]

Object.GetHashCode override.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public override int GetHashCode ()

Visual Basic [image] Copy Code

Public Overrides Function GetHashCode () As Integer

Return Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair Properties

Pair Properties
[image]

Public Properties

Name | Description
FirstObject | Gets or sets the first pair object.
PairElements | Gets the elements of the pair as an arraylist
SecondObject | Gets or sets the second pair object.

See Also

Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.FirstObject Property

Pair.FirstObject Property
[image]

Gets or sets the first pair object.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object FirstObject { get; set; }

Visual Basic [image] Copy Code

Public Property FirstObject As Object

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.PairElements Property

Pair.PairElements Property
[image]

Gets the elements of the pair as an arraylist

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public List<Object> PairElements { get; }

Visual Basic [image] Copy Code

Public ReadOnly Property PairElements As List(Of Object)

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.Pair.SecondObject Property

Pair.SecondObject Property
[image]

Gets or sets the second pair object.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public Object SecondObject { get; set; }

Visual Basic [image] Copy Code

Public Property SecondObject As Object

Property Value

See Also

Pair Members
Pair Class
MindFusion.Layout Namespace


MindFusion.Layout.PreferredRules Enumeration

PreferredRules Enumeration
[image]

Specifies which set of rules to use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum PreferredRules

Visual Basic [image] Copy Code

Public Enum PreferredRules

Members

Member name | Description
ConnectorRules | Use connector rules.
NodeRules | Use node rules.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.RouteHeuristics Delegate

RouteHeuristics Delegate
[image]

The link routing algorithm uses a heuristic function of this type in its prediction steps.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public delegate int RouteHeuristics (
PointI start,
PointI end
)

Visual Basic [image] Copy Code

Public Delegate Function RouteHeuristics( _
start As PointI, _
end As PointI _
) As Integer

Parameters

start

A Point specifying the first of the points, between which the distance is calculated.

end

A Point specifying the first of the points, between which the distance is calculated.

Return Value

An integer value indicating the calculated distance between the specified points.

Remarks

Functions of this type can be assigned to the RouteHeuristics property of the RoutingOptions class.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Interface

RoutingOptions Interface
[image]

Allows customization of various aspects of the link routing algorithm.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public interface RoutingOptions

Visual Basic [image] Copy Code

Public Interface RoutingOptions

Inheritors

MindFusion.Diagramming.RoutingOptions

See Also

RoutingOptions Members
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Members

RoutingOptions Members
Properties
[image]

Allows customization of various aspects of the link routing algorithm.

The following tables list the members exposed by the RoutingOptions type.

Public Properties

Name | Description
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions Properties

RoutingOptions Properties
[image]

Public Properties

Name | Description
GridSize | Gets or sets the size of the pieces of the routing grid.
IgnoreAnchoring | For internal use.
LengthCost | Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.
NodeVicinityCost | Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.
TurnCost | Gets or sets a value added to the total cost of a route if it makes a turn.

See Also

RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.GridSize Property

RoutingOptions.GridSize Property
[image]

Gets or sets the size of the pieces of the routing grid.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

double GridSize { get; set; }

Visual Basic [image] Copy Code

Property GridSize As Double

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.IgnoreAnchoring Property

RoutingOptions.IgnoreAnchoring Property
[image]

For internal use.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

bool IgnoreAnchoring { get; }

Visual Basic [image] Copy Code

ReadOnly Property IgnoreAnchoring As Boolean

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.LengthCost Property

RoutingOptions.LengthCost Property
[image]

Gets or sets a value added to the total cost of a route for each piece of the routing grid occupied by the route.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

byte LengthCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property LengthCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.NodeVicinityCost Property

RoutingOptions.NodeVicinityCost Property
[image]

Gets or sets the size of a buffer zone around a node for which routes get a penalty cost if they pass through it.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

byte NodeVicinityCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property NodeVicinityCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.RoutingOptions.TurnCost Property

RoutingOptions.TurnCost Property
[image]

Gets or sets a value added to the total cost of a route if it makes a turn.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

byte TurnCost { get; }

Visual Basic [image] Copy Code

ReadOnly Property TurnCost As Byte

Property Value

See Also

RoutingOptions Members
RoutingOptions Interface
MindFusion.Layout Namespace


MindFusion.Layout.SpringLayoutMethod Enumeration

SpringLayoutMethod Enumeration
[image]

Specifies what energy model SpringLayout should use for the simulation.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SpringLayoutMethod

Visual Basic [image] Copy Code

Public Enum SpringLayoutMethod

Members

Member name | Description
Classic | Use Hooke's law of elasticity to treat links as springs, and Coulomb's inverse square law to implement repulsion between nodes.
FruchtermanReingold | Use artificial attraction forces for links and repulsion forces for nodes that cancel each other at about the distance specified in NodeDistance, along with a simulated cooling schedule used for fine-tuning. Based on the method of Thomas Fruchterman and Edward Reingold.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SpringLayoutTraits Enumeration

SpringLayoutTraits Enumeration
[image]

Indicates item traits specific to SpringLayout. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SpringLayoutTraits

Visual Basic [image] Copy Code

Public Enum SpringLayoutTraits

Members

Member name | Description
Frozen | If the LayoutTraits value associated with a node through this key is true, SpringLayout considers the repulsion forces exerted by the node to other nodes, but ignores forces acting on the node and keeps it in place.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.SwimlaneLayoutTraits Enumeration

SwimlaneLayoutTraits Enumeration
[image]

Indicates item traits specific to swimlane layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum SwimlaneLayoutTraits

Visual Basic [image] Copy Code

Public Enum SwimlaneLayoutTraits

Members

Member name | Description
Lane | Specifies the lane to which a node should be assigned.
SortOrder | Specifies custom sort order of nodes in the same lane.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.TreeLayoutTraits Enumeration

TreeLayoutTraits Enumeration
[image]

Indicates item traits specific to tree layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeLayoutTraits

Visual Basic [image] Copy Code

Public Enum TreeLayoutTraits

Members

Member name | Description
Assistant | If the LayoutTraits value associated with a node through this key is true, the CenterTreeLayout treats this node as an "assistant" during the arrangement. If the value is false or is not present, the node is treated as "subordinate". The associated value can also be of type AssistantType if it is required to specify the position of the assistant node relative to its parent.

See Also

MindFusion.Layout Namespace


MindFusion.Layout.TreeMapLayoutTraits Enumeration

TreeMapLayoutTraits Enumeration
[image]

Indicates item traits specific to tree map layouts. Members of this enumeration can be used as keys in the DiagramItem.LayoutTraits hashtable.

Namespace: MindFusion.Layout
Assembly: MindFusion.Diagramming

Syntax

C# [image] Copy Code

public enum TreeMapLayoutTraits

Visual Basic [image] Copy Code

Public Enum TreeMapLayoutTraits

Members

Member name | Description
HeaderSize | The header size of a master node in a tree-map layout.

See Also

MindFusion.Layout Namespace


Table of Predefined Shapes

Shape | Identifier | Common Uses
 | Actor | An user An actor in use case model
 | Alternative | An alternative in SDL An extraction in flowcharts Storage in quality management
 | Arrow1 | Use as desired
 | Arrow2 | Use as desired
 | Arrow3 | Transportation in quality management A reference point
 | Arrow4 | Use as desired
 | Arrow5 | Use as desired
 | Arrow6 | Use as desired
 | Arrow7 | A signal Electronic transmission of data
 | Arrow8 | Use as desired
 | Arrow9 | Use as desired
 | BeginLoop | Begin of a loop
 | BpmnComplex | BPMN Gateways: Complex Decision/Merge
 | BpmnDataBasedXor | BPMN Gateways: Data-Based Exclusive Decision/Merge (XOR)
 | BpmnEndCancel | BPMN Events: Cancel (End)
 | BpmnEndCompensation | BPMN Events: Compensation (End)
 | BpmnEndError | BPMN Events: Error (End)
 | BpmnEndLink | BPMN Events: Link (End)
 | BpmnEndMessage | BPMN Events: Message (End)
 | BpmnEndMultiple | BPMN Events: Multiple (End)
 | BpmnEndTerminate | BPMN Events: Terminate (End)
 | BpmnEventBasedXor | BPMN Gateways: Event-Based Exclusive Decision/Merge (XOR)
 | BpmnInclusive | BPMN Gateways: Inclusive Decision/Merge (OR)
 | BpmnIntermediateCancel | BPMN Events: Cancel (Intermediate)
 | BpmnIntermediateCompensation | BPMN Events: Compensation (Intermediate)
 | BpmnIntermediateError | BPMN Events: Error (Intermediate)
 | BpmnIntermediateLink | BPMN Events: Link (Intermediate)
 | BpmnIntermediateMessage | BPMN Events: Message (Intermediate)
 | BpmnIntermediateMultiple | BPMN Events: Multiple (Intermediate)
 | BpmnIntermediateRule | BPMN Events: Rule (Intermediate)
 | BpmnIntermediateTimer | BPMN Events: Timer (Intermediate)
 | BpmnParallelFork | BPMN Gateways: Parallel Fork/Join (AND)
 | BpmnStartLink | BPMN Events: Link (Start)
 | BpmnStartMessage | BPMN Events: Message (Start)
 | BpmnStartMultiple | BPMN Events: Multiple (Start)
 | BpmnStartRule | BPMN Events: Rule (Start)
 | BpmnStartTimer | BPMN Events: Timer (Start)
 | Cloud | Object instance in data flow diagrams
 | Collate | A collation in flowcharts
 | ConeDown | Use as desired
 | ConeUp | Use as desired
 | ConnectedIssues | Connected issues in quality management
 | CreateRequest | Request to create in SDL
 | Cross | Use as desired
 | Cube | Use as desired
 | Cylinder | Use as desired
 | Database | A database in flowcharts
 | DataTransmition | Electronic transmission of data
 | DDelay | Use as desired
 | Decagon | Use as desired
 | Decision | Decision in flowcharts A comparison in flowcharts Relationship in data flow diagrams
 | Decision2 | A decision in SDL
 | Delay | A delay in process diagrams
 | DInDelay | Use as desired
 | DirectAccessStorage | A direct access storage
 | DiskStorage | Data stored on disk in flowcharts
 | Display | Data that is displayed for human use
 | DividedEvent | An event
 | DividedProcess | A process or document in flowcharts Entity in data flow diagrams
 | Document | A document
 | Donut | Use as desired
 | DOutDelay | Use as desired
 | Ellipse | A cross-reference within the same page of a flowchart Process in data flow diagrams State in data flow diagrams A continuation of the flowchart in SDL An use case Operation in quality management
 | EndLoop | End of a loop
 | ExternalOrganization | An external organization
 | ExternalProcess | An external process
 | File | A file
 | FramedRectangle | Use as desired
 | Gate | A gateway
 | Heart | Use as desired
 | Heptagon | Use as desired
 | Hourglass | Use as desired
 | Input | Data that is input by manual means
 | InternalStorage | An internal storage
 | Interrupt | An interrupt
 | Interrupt2 | An interrupt
 | IsoProcess | Iso9000 process
 | Junction | A summing junction A return in SDL
 | Lightning | Use as desired
 | LinedDocument | A document in flowcharts
 | ManualOperation | Operation performed by a human
 | Merge | A merger in flowcharts Inbound goods in quality management Non-electronic file Stop state in data flow diagrams
 | MessageFromUser | A message from user side in SDL
 | MessageToUser | A message to user side in SDL
 | Microform | A microform
 | MicroformProcessing | A microform processing
 | MicroformRecording | A microform recording
 | MultiDocument | A multiple document in flowcharts
 | MultiProc | A multiple process or document in flowcharts
 | Octagon | Use as desired
 | OfflineStorage | An offline storage
 | OffpageConnection | A cross-reference to another page of a flowchart
 | OffpageReference | A cross-reference to another page of a flowchart A foreign module
 | Or | An 'or' statement
 | Pentagon | Use as desired
 | Plaque | Use as desired
 | PrimitiveFromCall | A primitive from call control in SDL
 | PrimitiveToCall | A primitive to call control in SDL
 | Procedure | Procedure in SDL
 | Process | A process or document in flowcharts A file or data storage
 | Prysm | Use as desired
 | PunchedCard | A punched card
 | PyramidDown | Use as desired
 | PyramidUp | Use as desired
 | Rectangle | A metric operation 'External interactor' in data flow diagrams Inspection in quality management
 | RightTriangle | Use as desired
 | RoundRect | A process or item in flowcharts An event An issue in quality management
 | RSave | Input or output data in flowcharts
 | Save | A save in SDL Input or output data in flowcharts
 | Sort | A sort operation
 | Sphere | Use as desired
 | Star | Use as desired
 | Star4Pointed | Use as desired
 | Star5Pointed | Use as desired
 | Star6Pointed | Use as desired
 | Star7Pointed | Use as desired
 | Star16Pointed | Use as desired
 | Star24Pointed | Use as desired
 | Star32Pointed | Use as desired
 | Start | Start of a program flow A starting point in SDL
 | Tape | Sequentially accessible data
 | Terminator | Start or end of a program flow
 | TransmittalTape | A transmittal tape
 | Trapezoid | Use as desired


Technical Support

Detailed information about everything connected with software products offered by MindFusion – online documentation, demos, information about forthcoming products can be found at http://www.mindfusion.eu. The site is updated every day, so make sure you visit it regularly to catch up with the newest from us.

Apart from that, MindFusion employs a dedicated and technically proficient support team. This guarantees that all your questions and inquiries will be answered in quick and professional manner. They can be reached by e-mail at support@mindfusion.eu or by phone at +359 889 199 729.

You can post a question on the MindFusion.Diagramming for .NET MAUI discussion board here:

http://mindfusion.eu/Forum/YaBB.pl?board=diag_xamarin

or visit our Help Desk site:

http://www.mindfusion.eu/HelpDesk/index.php

We will be happy to hear any suggestions and recommendations you might have regarding MindFusion.Diagramming for .NET MAUI. We do take in account the opinion of every single person who has shown interest in our products.


Licensing

There are no separate trial builds of MindFusion assemblies. When you purchase a component you can find the license key for this component listed on the Keys & Downloads page at the customer's portal. Assign this license key to the LicenseKey property to disable the component's evaluation mode and stop displaying trial messages. If your application contains more than one MindFusion component, you could call MindFusion.Licensing.LicenseManager.AddLicense(key) method from application start-up code to specify the key once instead of setting it per each control.


MindFusion Products

MindFusion offers various programming components for different platforms. Below is a list of our products with links to their sections on our website as well link to download a trial version. Clients that have already purchased a product use an increasing discount for each subsequent one.

Diagramming | Links
Diagramming for WPF | Product Information Download
Diagramming for WinForms | Product Information Download
Diagramming for Java Swing | Product Information Download
Diagramming for JavaScript | Product Information Download
Diagramming for ASP.NET | Product Information Download
Diagramming for ASP.NET MVC | Product Information Download
Diagramming for Xamarin | Product Information Download
Diagramming for UWP | Product Information Download
Diagramming for Android | Product Information Download
DiagramViewer for iOS/Cocoa Touch | Product Information Download
Diagramming for ActiveX | Product Information Download
Diagramming for Silverlight | Product Information Download

Charting | Links
Charting for WPF | Product Information Download
Charting for WinForms | Product Information Download
Charting for Java Swing | Product Information Download
Charting for JavaScript | Product Information Download
Charting for ASP.NET | Product Information Download
Charting for Xamarin | Product Information Download
Charting for Android | Product Information Download
Charting for Silverlight | Product Information Download

Scheduling | Links
Scheduling for WPF | Product Information Download
Scheduling for WinForms | Product Information Download
Scheduling for Java Swing | Product Information Download
Scheduling for JavaScript | Product Information Download
Scheduling for ASP.NET | Product Information Download
Scheduling for Xamarin | Product Information Download
Scheduling for Silverlight | Product Information Download

Spreadsheet | Links
Spreadsheet for WPF | Product Information Download
Spreadsheet for WinForms | Product Information Download
Spreadsheet for Java Swing | Product Information Download

Reporting | Links
Reporting for WPF | Product Information Download
Reporting for WinForms | Product Information Download
Reporting for Silverlight | Product Information Download

Virtual Keyboard | Links
Virtual Keyboard for WPF | Product Information Download
Virtual Keyboard for WinForms | Product Information Download
Virtual Keyboard for Java Swing | Product Information Download
Virtual Keyboard for JavaScript | Product Information Download

Mapping | Links
Mapping for WPF | Product Information Download
Mapping for WinForms | Product Information Download
Mapping for ASP.NET | Product Information Download
Mapping for Silverlight | Product Information Download

Suites | Links
Pack for WPF | Product Information Download
Pack for WinForms | Product Information Download
Pack for Java Swing | Product Information Download
Pack for JavaScript | Product Information Download
Pack for ASP.NET | Product Information Download
Pack for Xamarin | Product Information Download
Pack for Silverlight | Product Information Download
Pack for Diagramming | Product Information Download
Pack for Scheduling | Product Information Download