/n software SharePoint Extensions V3

Thank you for choosing /n software SharePoint Extensions, a product based on our award-winning IP*Works! Internet Toolkit, one of the best software packages available for developing high performance applications for the Internet or Intranets.

By choosing /n software, you are counting on us to be a key component in your business and expect us to provide you with ongoing enhancements, support, and innovative products. We will do our best to meet your expectations!

You will always find our SharePoint Extensions and any updates to the product at our web site - www.nsoftware.com. You may download full versions of our product for a free 30 day evaluation period.

Please direct all your technical questions to support@nsoftware.com. You will speed up your answers if you provide an accurate description of your problem, the results you expected and the results you received when using our product. For all other inquiries, please direct your questions to sales@nsoftware.com.


Installing Activities

When the installer complete, an optional deployment utility can be automatically launched to deploy the installed activities to SharePoint. The demo actions are also deployed as a separate feature.

Once you have installed the features, you must activate them. To do this, follow the steps below:

  1. Browse to the Central Administration page for your SharePoint installation.
  2. There, click on "Application Management", and then under the "SharePoint Web Application Management" heading click on "Manage Web Application Features".
  3. Make sure that the highlighted "Web Application" dropdown menu displays the correct web site on which you'd like to activate the activities.
  4. Here you'll find a listing of all the activities installed under the SharePoint installation. For all of the /n Software Extensions that you'd like to use, click the "Activate" button.

More Info

Please click here for updates, questions, feedback, and more information on this particular topic.

/n software SharePoint Extensions V3 sp Edition. - Copyright (c) 2009 /n software inc. - All rights reserved. - For more info, please visit our website at www.nsoftware.com.


Workflow Configuration

Once the activities have been properly installed and activated on the SharePoint site, workflows are ready to be created. SharePoint Designer and Visual Studio are both are capable of creating workflows to add functionality to the SharePoint site. Configuring your workflows using both tools is briefly described below.

Creating Workflows with SharePoint Designer

In order to create workflows using SharePoint designer, the Demo Actions must have been deployed after installation or you must define your own custom actions (see Actions Configuration). To create a new Workflow using the newly installed activities through Microsoft SharePoint Designer, follow these steps:

  1. Start Microsoft Office SharePoint Designer, and open the main SharePoint site.
  2. In the File menu, select New, and then Workflow.
  3. Name the new workflow, and attach it to a list (ie, Documents).
  4. Select the startup option and click "Next".
  5. For "Step 1", apply any desired conditions and then under the Actions dropdown menu select "More Actions".
  6. There will be a category called "/n Software SharePoint Extensions", which will contain sample actions for each of the /n Software SharePoint Extensions that were installed. Select the desired action, click "Add", and then select that action from the dropdown menu before clicking "Next".
  7. Click on any words or phrases which contains links within the selected sentence, and enter correct data to configure the action.
  8. Once the sentence contains no errors and is ready to deploy, press "Finish".
  9. This will deploy the workflow to the SharePoint site, and the new workflow will be enabled.

Note: The actions that appear in the "More Actions" list are those installed in SharePoints workflow templates folder (See the Actions Configuration page for more information on finding and configuring these actions).

Creating Workflows with Visual Studio

During installation, if toolbox installation was selected, the activities will already be installed to the Visual Studio toolbox. The activities are then ready to be dragged and dropped onto the workflow form and configured in the properties window. Refer to Microsoft documentation on using Visual Studio to create SharePoint workflows. Below is a screenshot of the activities that are installed to the toolbox:

More Info


Actions Configuration

This section provides step-by-step instructions for creating and configuring actions created for the SharePoint Designer. It is assumed that users are familiar with Microsoft SharePoint and Microsoft SharePoint Designer and the concepts of the transfer protocol used by the /n software SharePoint Extensions.

Action Configuration

After running the setup application and enabling the feature for each individual activity and the demo actions feature, all of the necessary files will be installed on the system.

To modify the default demo actions, first locate the .ACTIONS file. There will be an individual file for each activity set that was installed. The actions files are located in this default directory:

%ProgramFiles%\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\1033\Workflow\.

If you cannot locate this directory on your machine, and SharePoint is installed, look for the folder location at this registry key:

HKLM\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\Location.

Once the .ACTIONS file has been located, actions may be removed and added as desired for the given activities. Following is a step-by-step guide to creating your own custom actions.

  1. Open the file in an editor of your choice.
  2. Notice that one or more demo actions have been provided. These actions may be modified. However, if you are creating a new action, make sure that the new action contains a name and an open and closing brace. The name will be the name which is displayed inside of the SharePoint Designer. In the following example, the Action opening and closing tags and its attributes are bold, although all of the attributes are not necessary:

    <Action Name="FTP Send Sample"
    ClassName="nsoftware.SharePoint.FTPSend.FTPSendActivity"
    Assembly="nsoftware.SharePoint.FTPSend, Version=2.0.3099.0, Culture=neutral, PublicKeyToken=cdc168f89cffe9cf"
    AppliesTo="list"
    Category="/n Software SharePoint Extensions"
    UsesCurrentItem="true">
  <RuleDesigner Sentence="FTP to %1 using %2 and %3 to login.">
    <FieldBind Id="1" Field="FTPServer" Text="this server" DesignerType="TextArea" />
    <FieldBind Id="2" Field="User" Text="this username" DesignerType="TextArea" />
    <FieldBind Id="3" Field="Password" Text="password" DesignerType="TextArea" />
  </RuleDesigner>
  <Parameters>
    <Parameter Name="__Context" Type="Microsoft.SharePoint.WorkflowActions.WorkflowContext, Microsoft.SharePoint.WorkflowActions" Direction="In" />
    <Parameter Name="__ListId" Type="System.String, mscorlib" Direction="In" />
    <Parameter Name="__ListItem" Type="System.Int32, mscorlib" Direction="In"  />
    <Parameter Name="FTPPort" Type="System.Int32, mscorlib" Direction="Optional" InitialValue="21" />
    <Parameter Name="FTPServer" Type="System.String, mscorlib" Direction="In" />
    <Parameter Name="Password" Type="System.String, mscorlib" Direction="Optional" />
    <Parameter Name="User" Type="System.String, mscorlib" Direction="Optional" />
  </Parameters>
</Action>

  3. The ClassName and AssemblyName attributes MUST be exact for the activity desired, including the full name of the signed assembly.
  4. Set the AppliesTo attribute and any other desired attributes you may desire. Attributes will be discussed in further detail later.
  5. The sentence for the action is located in the RuleDesigner section. The sentence you choose must have percent signs followed by increasing numbers where links to designer types are desired. For instance, the words "this server" in the following example will be a link to a textbox where the user can input the server name. The words "this server" have been replaced in the sentence with "%1". The sentence reference and the actual text which is displayed are bold in the following example:

    <RuleDesigner Sentence="FTP to %1 using %2 and %3 to login.">
  <FieldBind Id="1" Field="FTPServer" Text="this server" DesignerType="TextArea" />
  <FieldBind Id="2" Field="User" Text="this username" DesignerType="TextArea" />
  <FieldBind Id="3" Field="Password" Text="password" DesignerType="TextArea" />
</RuleDesigner>

  6. When the sentence is complete, the numbered variables must be bound to fields inside of the activity. Each "%X" contained in the sentence must have a FieldBind element associated with it, which defines the Id, Field, and DesignerType.
  7. The Id attribute value is the number that represents this link in the sentence. The Field attribute value represents the property of the workflow activity that this value links to. The DesignerType tells the designer what type to use for input. Look at the Designer Types section for more information on different designer types. The Text parameter represents the actual text that gets displayed in the link.
  8. Define all variables to be set within the activity. This is done in the parameters section. Here, all of the fields which were bound to in the previous section must be defined. Any properties of the activity that are set for the user may be defined here as well. For example, if the Server property is going to be set without being displayed in the sentence, an InitialValue attribute of that parameter may be added and set to our desired server. Example:

    <Parameter Name="FTPServer" Type="System.String, mscorlib" Direction="In" InitialValue="MyServer" />
    NOTE: All properties for the component must be listed in the parameters section to ensure that proper initial values are set by Sharepoint. Otherwise, primitive defaults will be given to the properties which may produce undesired effects.

  9. An iisreset must be done in order for the changes to take place. Once SharePoint Designer has been restarted, the new action will appear.

Designer Types

Following is a list of several commonly used designer types and their descriptions.

TextArea | A simple textbox which also allows data binding.
stringbuilder | A multi-line text box which also supports binding data within the editor. This is used when text may be multi-line, such as the body of an email.
Operator | In the examples provided, this type is used for drop-down menus, which are associated with properties that contain either boolean values or enumeration values. NOTE: Enumeration properties are actually strings within the activity.
Integer | Allows the user to input an integer only.

Action Attributes

These attributes can be found in the Action tag. Here are a few of the important ones:

Category | This defines which category the new action will be listed in. All default actions are in the "/n Software SharePoint Extensions" category.
UsesCurrentItem | This is a special attribute which you may set on a given action if the activity will be performed on that item. Workflows are attached to lists, and can be started when items are created or changed. You must also set the AppliesTo attribute for this action to be "list". Furthermore, when using this attribute, you must define the __ListId and __ListItem properties in the Parameters section for that action. SharePoint will automatically set the values of these two properties to point to the current item when this attribute exists.

Additional information and trouble shooting

The defaults listed in the help files are not picked up by the sharepoint designer. To ensure the desired defaults are picked up and validated correctly, these values MUST be set explicitly in the actions file by using the InitialValue attribute.


Email Activity

Properties Configuration Settings

The Email Activity adds SSL-protected email capability to your SharePoint site.

Assembly

nsoftware.SharePoint.EmailActivities.dll

Remarks

The Email Activity provides an all-encompassing SMTP client implementation to your SharePoint site.

Email Send Activity

The Email Send Activity is a complete SMTP client. To send emails from the activity you must set at a minimum your SMTPServer, as well as your From and SendTo email addresses. Should you need to guarantee a secure transmission, you may turn on SSL by setting the appropriate SSL properties.

You may also add carbon copy and blind carbon copy recipients via the Cc and BCc properties. If you wish to receive delivery or read notifications, you can set the DeliveryReceipt and ReadReceipt properties.

Additionally, you may set the Subject of your message. The contents of the Text property will be sent as the body of the email.

Attachments of files associated with items may also be included in emails by setting the UsesCurrentItem attribute for the action if using SharePoint Designer or the WorkflowProperties property if using Visual Studio.

Property List

The following is the full list of the properties of the activity with short descriptions. Click on the links for complete descriptions.

AuthMode | The authentication mode to be used when connecting to the MailServer .
BCc | A comma separated list of addresses for blind carbon copies (optional).
Cc | A comma separated list of addresses for carbon copies (optional).
Delete | Controls if the email is deleted after download.
DeleteMode | Controls if and when the email is deleted after download.
DeliveryReceipt | Whether or not a delivery receipt should be returned to the sender.
Filter | A filter to be applied to the inbox when selecting messages.
FirewallAutoDetect | Tells the activity whether or not to automatically detect and use firewall system settings, if available.
FirewallType | Determines the type of firewall to connect through.
FirewallHost | Name or IP address of firewall (optional).
FirewallPassword | A password if authentication is to be used when connecting through the firewall.
FirewallPort | The TCP port for the firewall Host .
FirewallUser | A user name if authentication is to be used connecting through a firewall.
From | The email address of the sender (required).
IncludeHeaders | Instructs the activity to include or ignore message headers.
LogMode | What information gets logged during activity execution.
MailFolder | Name of the mailbox selected on the server.
MailPort | The port of the mail server (IMAP or POP3).
MailServer | The name or address of the mail server (IMAP or POP3).
MessageCc | A comma separated list of addresses for carbon copies.
MessageDate | The date a message was sent.
MessageFrom | The email address of the sender.
MessageId | The id of the current message.
MessageSize | The size of the current message.
MessageSubject | The subject of the mail message.
MessageTo | A comma separated list of addresses for destinations.
Other | Defines a set of configuration settings to be used by the activity.
Password | A login password to login with in the mail server.
ReadReceipt | Whether or not a receipt should be sent when the email has been read.
ReplyTo | A mail address to reply to (optional).
SendTo | A comma separated list of addresses for destinations (required).
ServerType | The type of server for your email account.
SMTPPort | The server port for SMTP (default 25).
SMTPServer | The name or address of a mail server (mail relay).
SSLAcceptServerCertStore | The name of the certificate store for the client certificate.
SSLAcceptServerCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLAcceptServerCertStoreType | The type of certificate store for this certificate.
SSLAcceptServerCertSubject | The subject of the certificate used for client authentication.
SSLAcceptServerCertAcceptAny | Tells the activity to accept any server certificate.
SSLCertStore | The name of the certificate store for the client certificate.
SSLCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLCertStoreType | The type of certificate store for this certificate.
SSLCertSubject | The subject of the certificate used for client authentication.
SSLStartMode | Determines how the activity starts the SSL negotiation.
Subject | The subject of the mail message (optional).
Text | The text of the mail message (optional).
Timeout | A timeout for the activity.
User | A user id to login as in the mail server.

Configuration Settings

The following is a list of configuration settings for the activity with short descriptions. Click on the links for complete descriptions.

AbsoluteTimeout | Determines whether timeouts are inactivity timeouts or absolute timeouts.
LocalHost | The name of the local host or user-assigned IP interface through which connections are initiated or accepted.


AuthMode Property

AuthMode Property (Email Activity)

The authentication mode to be used when connecting to the MailServer .

Possible Values

Login(0)
CRAMMD5(1)
NTLM(2)
APOP(3)
SASLPlain(4)

Data Type

string

Default Value

0

Remarks

The following authentication modes are supported by the Email activity:

Login | The User and Password are sent in a basic authentication command.
CRAMMD5 | The User and Password are digested using MD5 and sent to the server in a secure authentication command.
NTLM | Windows NTLM authentication. If User and Password are not supplied, the credentials for the current Windows account are used.
APOP | POP authentication. This value is only valid for the Email receiver activity when ServerType is set to POP3.
SASL Plain | The User and Password are concatenated into a plaintext SASL authentication command. This value is only valid for the Email receiver activity when ServerType is set to IMAP.

The default AuthMode is Login.


BCc Property

BCc Property (Email Activity)

A comma separated list of addresses for blind carbon copies (optional).

Data Type

string

Default Value

""

Remarks

The BCc property specifies a comma separated list of destinations for blind carbon copies of the mail message. A copy of the message is sent to each destination, but no BCc SMTP header is created containing the destination addresses, so individual recipients never see the list of the other recipients.

The activity will stop processing the message and log an error if the SMTPServer returns an error code about any email address specified in SendTo or Cc, but it will only log warnings if the same happens with an email address specified in BCc.


Cc Property

Cc Property (Email Activity)

A comma separated list of addresses for carbon copies (optional).

Data Type

string

Default Value

""

Remarks

The Cc property specifies a comma separated list of destinations for carbon copies of the mail message. A copy of the message is sent to each destination, and a Cc SMTP header is created containing the destination addresses. This header is sent to every recipient of the message. If you don't want to copy this information to every recipient, then use blind carbon copies instead (see the description of the BCc).

The activity will stop processing the message and log an error if the SMTPServer returns an error code about any email address specified in SendTo or Cc, but it will only log warnings if the same happens with an email address specified in BCc.


DeliveryReceipt Property

DeliveryReceipt Property (Email Activity)

Whether or not a delivery receipt should be returned to the sender.

Data Type

bool

Default Value

false

Remarks

When set to True, a Return-Receipt-To header is added to the message. If the email recipient so chooses, a delivery receipt will be sent to the email address in the From property.


FirewallAutoDetect Property

FirewallAutoDetect Property (Email Activity)

Tells the activity whether or not to automatically detect and use firewall system settings, if available.

Data Type

bool

Default Value

false

Remarks

Tells the activity whether or not to automatically detect and use firewall system settings, if available.


FirewallType Property

FirewallType Property (Email Activity)

Determines the type of firewall to connect through.

Possible Values

None(0)
Tunnel(1)
SOCKS4(2)
SOCKS5(3)

Data Type

string

Default Value

0

Remarks

Determines the type of firewall to connect through. The applicable values are the following:

fwNone (0) | No firewall (default setting).
fwTunnel (1) | Connect through a tunneling proxy. FirewallPort is set to 80.
fwSOCKS4 (2) | Connect through a SOCKS4 Proxy. FirewallPort is set to 1080.
fwSOCKS5 (3) | Connect through a SOCKS5 Proxy. FirewallPort is set to 1080.


FirewallHost Property

FirewallHost Property (Email Activity)

Name or IP address of firewall (optional).

Data Type

string

Default Value

""

Remarks

Name or IP address of firewall (optional). If a FirewallHost is given, requested connections will be authenticated through the specified firewall when connecting.

If the FirewallHost property is set to a Domain Name, a DNS request is initiated. Upon successful termination of the request, the FirewallHost property is set to the corresponding address. If the search is not successful, an error is returned.


FirewallPassword Property

FirewallPassword Property (Email Activity)

A password if authentication is to be used when connecting through the firewall.

Data Type

string

Default Value

""

Remarks

A password if authentication is to be used when connecting through the firewall. If FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given firewall. If the authentication fails, a trappable error is fired.


FirewallPort Property

FirewallPort Property (Email Activity)

The TCP port for the firewall Host .

Data Type

int

Default Value

0

Remarks

The TCP port for the firewall FirewallHost. See the description of the FirewallHost property for details.

Note that the FirewallPort is set automatically when FirewallFirewallType is set to a valid value. See the description of the FirewallFirewallType property for details.


FirewallUser Property

FirewallUser Property (Email Activity)

A user name if authentication is to be used connecting through a firewall.

Data Type

string

Default Value

""

Remarks

A user name if authentication is to be used connecting through a firewall. If the FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given Firewall. If the authentication fails, a trappable error is fired.


From Property

From Property (Email Activity)

The email address of the sender (required).

Data Type

string

Default Value

""

Remarks

The From property is used to create a From SMTP header. This header identifies the sender of the message. A valid email address is required. Examples of valid addresses are: "Friendly Name" <address@company.com> or address@company.com


LogMode Property

LogMode Property (Email Activity)

What information gets logged during activity execution.

Possible Values

Verbose(0)
Debug(1)
Warning(2)
Error(3)
Fatal(4)

Data Type

string

Default Value

3

Remarks

This property controls what information the activity logs. The possible values have the following affect on the activity's behavior:

Verbose | The activity will report all information regarding the transport.
Debug | The activity will report all major operations, as well as all warnings and errors.
Warning | The activity will report any conditions that could result in unpredictable behavior as well as errors.
Error | The activity will report all errors that prevent normal operations from completing.
Fatal | The activity will report only serious errors that cause the activity to completely stop functioning.


Other Property

Other Property (Email Activity)

Defines a set of configuration settings to be used by the activity.

Data Type

string

Default Value

""

Remarks

The activity accepts one or more configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

The Other property should be set to list of name/value pairs separated by the '|' character, e.g:

configname1=value1|configname2=value2


Password Property

Password Property (Email Activity)

A login password to login with in the mail server.

Data Type

string

Default Value

""

Remarks

If the Password property is set to a non-empty string, then when connecting to the mail server an AUTH or CRAM-MD5 (depending on the value of AuthMode) command is sent in order to provide authentication information for the user.


ReadReceipt Property

ReadReceipt Property (Email Activity)

Whether or not a receipt should be sent when the email has been read.

Data Type

bool

Default Value

false

Remarks

When set, a Disposition-Notification-To header is added to the message. If the email recipient so chooses, a receipt will be sent to the email address in the From property.


ReplyTo Property

ReplyTo Property (Email Activity)

A mail address to reply to (optional).

Data Type

string

Default Value

""

Remarks

If the ReplyTo property contains a non-empty string, a Reply-To SMTP header is created for the message. This header shows the address to use for replies (useful if this address is different from the one in From).


SendTo Property

SendTo Property (Email Activity)

A comma separated list of addresses for destinations (required).

Data Type

string

Default Value

""

Remarks

The SendTo property specifies a comma separated list of destinations for the mail message. A copy of the message is sent to each of them, and a To SMTP header is created containing the destination addresses.

Examples of valid addresses are: "Friendly Name" <address@company.com> or address@company.com

The activity will stop processing the message and log an error if the SMTPServer returns an error code about any email address specified in SendTo or Cc, but it will only log warnings if the same happens with an email address specified in BCc.


SMTPPort Property

SMTPPort Property (Email Activity)

The server port for SMTP (default 25).

Data Type

int

Default Value

25

Remarks

A valid port number (a value between 1 and 65535) is required for the connection to take place. The property must be set before a connection is established by the activity

For implicit SSL, use port 465 (please refer to the SSLStartMode property for more information).


SMTPServer Property

SMTPServer Property (Email Activity)

The name or address of a mail server (mail relay).

Data Type

string

Default Value

""

Remarks

The SMTPServer property specifies the IP address (IP number in dotted internet format) or Domain Name for a mail relay through which messages will be routed.

The current version of the activity does not provide a default value for the mail relay. You must provide a host name yourself. Generally, any internet host with an SMTP server will suffice (a UNIX host for example), but it is preferable to select an SMTPServer that is close to the machine sending mail.


SSLAcceptServerCertStore Property

SSLAcceptServerCertStore Property (Email Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLAcceptServerCertStoreType property specifies the type of the certificate store specified by SSLAcceptServerCertStore. If the store is password protected, specify the password in SSLAcceptServerCertStorePassword.

SSLAcceptServerCertStore is used in conjunction with the SSLAcceptServerCertSubject property in order to specify client certificates. If SSLAcceptServerCertStore has a value, and SSLAcceptServerCertSubject is set, a search for a certificate is initiated. Please refer to the SSLAcceptServerCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLAcceptServerCertStorePassword Property

SSLAcceptServerCertStorePassword Property (Email Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLAcceptServerCertStoreType Property

SSLAcceptServerCertStoreType Property (Email Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLAcceptServerCertSubject Property

SSLAcceptServerCertSubject Property (Email Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLAcceptServerCertSubject is set to the full subject of the matching certificate.


SSLAcceptServerCertAcceptAny Property

SSLAcceptServerCertAcceptAny Property (Email Activity)

Tells the activity to accept any server certificate.

Data Type

bool

Default Value

false

Remarks

When set to true, the activity will unilaterally authenticate any server during the security handshake. It is strongly recommended that you use this only for testing purposes.


SSLCertStore Property

SSLCertStore Property (Email Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLCertStoreType property specifies the type of the certificate store specified by SSLCertStore. If the store is password protected, specify the password in SSLCertStorePassword.

SSLCertStore is used in conjunction with the SSLCertSubject property in order to specify client certificates. If SSLCertStore has a value, and SSLCertSubject is set, a search for a certificate is initiated. Please refer to the SSLCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLCertStorePassword Property

SSLCertStorePassword Property (Email Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLCertStoreType Property

SSLCertStoreType Property (Email Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLCertSubject Property

SSLCertSubject Property (Email Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLCertSubject is set to the full subject of the matching certificate.


SSLStartMode Property

SSLStartMode Property (Email Activity)

Determines how the activity starts the SSL negotiation.

Possible Values

Automatic(0)
Implicit(1)
Explicit(2)
None(3)

Data Type

string

Default Value

0

Remarks

The SSLStartMode property may have one of the following values:

Automatic | If the remote port is set to the standard plaintext port of the protocol (where applicable), the activity will behave the same as if SSLStartMode is set to Explicit. In all other cases, SSL negotiation will be implicit (Implicit).
Implicit | The SSL negotiation will start immediately after the connection is established.
Explicit | The activity will first connect in plaintext, and then explicitly start SSL negotiation through a protocol command such as STARTTLS.
None | No SSL negotiation, no SSL security. All communication will be in plaintext mode.


Subject Property

Subject Property (Email Activity)

The subject of the mail message (optional).

Data Type

string

Default Value

""

Remarks

The string in Subject is sent with a Subject SMTP header to the mail recipient.


Text Property

Text Property (Email Activity)

The text of the mail message (optional).

Data Type

string

Default Value

""

Remarks

The string in Text is sent as the text of the message.


Timeout Property

Timeout Property (Email Activity)

A timeout for the activity.

Data Type

int

Default Value

60

Remarks

If the Timeout property is set to 0, all operations will run uninterrupted until successful completion, or an error condition is encountered.

If Timeout is set to a positive value, the activity will wait for the operation to complete before returning control.

If Timeout expires, and the operation is not yet complete, the activity fails with an error.

Please note that by default, all timeouts are inactivity timeouts, i.e. the timeout period is extended by Timeout seconds when data is successfully sent or received.

Optionally, the behavior of the activity may be changed to absolute timeouts, i.e. the activity will wait for a maximum of Timeout seconds since the beginning of the operation, without extending the timeout period during communications.

This behavior is controlled by the AbsoluteTimeout configuration setting.

The default value for the Timeout property is 60 (seconds).


User Property

User Property (Email Activity)

A user id to login as in the mail server.

Data Type

string

Default Value

""

Remarks

If the User property is set to a non-empty string, then when connecting to the mail server an AUTH or CRAM-MD5 (depending on the value of AuthMode) command is sent in order to provide authentication information for the user.

NOTE: POP3 and IMAP servers typically require User to be set.


Email Configuration

Configuration Settings (Email Activity)

The activity accepts one or more of the following configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

Email Configuration Settings

General Configuration Settings

AbsoluteTimeout: Determines whether timeouts are inactivity timeouts or absolute timeouts.

If AbsoluteTimeout is set to True, any method which does not complete within Timeout seconds will be aborted. By default, AbsoluteTimeout is False, and the timeout is an inactivity timeout.

LocalHost: The name of the local host or user-assigned IP interface through which connections are initiated or accepted.

The LocalHost configuration contains the name of the local host as obtained by the Gethostname() system call, or if the user has assigned an IP address, the value of that address.

In multihomed hosts (machines with more than one IP interface) setting LocalHost to the value of an interface will make the activity initiate connections (or accept in the case of server activitys) only through that interface.

If the activity is connected, the LocalHost configuration shows the IP address of the interface through which the connection is made in internet dotted format (aaa.bbb.ccc.ddd). In most cases, this is the address of the local host, except for multihomed hosts (machines with more than one IP interface).


Ftp Activity

Properties Configuration Settings

The FTP Activity adds SSL-enabled FTP send capabilities to your SharePoint site.

Assembly

nsoftware.SharePoint.FTPActivities.dll

Remarks

The FTP Activity adds complete FTP send functionality to your SharePoint site that enables it with plaintext or SSL-secured file upload capability.

FTP Send Activity

The FTP Send Activity requires an FTPServer to be set. In addition, an item must also be specified by either setting the UsesCurrentItem attribute for the action if using SharePoint Designer or the WorkflowProperties property if using Visual Studio. If your server does not operate on the default FTP port, you will need to specify the correct port via FTPPort. For servers that do not allow anonymous uploads, you may also need to set User, Password, and/or Account. If you wish to enable SSL, you can turn it on by setting the appropriate SSL properties.

The activity will connect to the FTP server whenever it has a message to send. The activity will attempt to upload to the specified RemotePath. You may set the RemoteFile property if a name other than the name which the SharePoint site has for that file is desired. If Overwrite is set to True, the activity will delete or overwrite remote files as necessary to complete the operation.

Property List

The following is the full list of the properties of the activity with short descriptions. Click on the links for complete descriptions.

Account | The user Account to login with.
AfterConnect | A set of FTP commands to be executed immediately after connecting to the FTPServer .
AfterGet | A set of FTP commands to be executed after the GET.
AfterPut | A set of FTP commands to be executed after the PUT.
Append | Whether or not the activity should append data to the RemoteFile .
BeforeGet | A set of FTP commands to be executed before the GET.
BeforePut | A set of FTP commands to be executed before the PUT.
Delete | Controls if the remote file is deleted after download.
DeleteMode | Controls if and when the remote file is deleted after download.
FileMask | Indicates the type of files to download from the FTP server.
FirewallAutoDetect | Tells the activity whether or not to automatically detect and use firewall system settings, if available.
FirewallType | Determines the type of firewall to connect through.
FirewallHost | Name or IP address of firewall (optional).
FirewallPassword | A password if authentication is to be used when connecting through the firewall.
FirewallPort | The TCP port for the firewall Host .
FirewallUser | A user name if authentication is to be used connecting through a firewall.
FTPPort | The port for the FTP service (default is 21).
FTPServer | The domain name or IP address of the FTP server.
LocalDirectory | The directory on the local machine to write downloaded files to.
LogMode | What information gets logged during activity execution.
Operation | The operation which will be executed by the FTP task.
Other | Defines a set of configuration settings to be used by the activity.
Overwrite | Whether or not the activity should overwrite files during transfer.
Passive | Controls whether to direct the server into passive mode. Recommended if behind a firewall.
Password | The password to login with.
ReceivedFileDate | The date of the remote file received by the FTP activity.
ReceivedFileName | The name of the remote file received by the FTP activity.
ReceivedFileSize | The size of the remote file received by the FTP activity.
ReceivedFileUser | The user name used to by the FTP activity when downloading the remote file.
RemoteFile | The name of the destination file on the FTP server for uploading.
RemotePath | The current path in the FTP server.
RemoteTempPath | A temporary directory on the server to store files before moving them to RemotePath .
SSLAcceptServerCertStore | The name of the certificate store for the client certificate.
SSLAcceptServerCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLAcceptServerCertStoreType | The type of certificate store for this certificate.
SSLAcceptServerCertSubject | The subject of the certificate used for client authentication.
SSLAcceptServerCertAcceptAny | Tells the activity to accept any server certificate.
SSLCertStore | The name of the certificate store for the client certificate.
SSLCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLCertStoreType | The type of certificate store for this certificate.
SSLCertSubject | The subject of the certificate used for client authentication.
SSLStartMode | Determines how the activity starts the SSL negotiation.
Timeout | A timeout for the activity.
TransferMode | The transfer mode (ASCII or Binary). If the value is 0 (default), the initial server mode will be used.
User | The user id to login as.

Configuration Settings

The following is a list of configuration settings for the activity with short descriptions. Click on the links for complete descriptions.

PortRange | Allows the specification of a port range where the activity listens to.
TemporaryDownloadExtension | An extension to be appended to the during download
TemporaryUploadExtension | An extension to be appended to the during upload
UseClearCommandChannel | Allows for the Clear Command Channel (CCC) command
UseClearDataChannel | Allows for the PROT C command
UseProtWhenImplicit | Sends PROT P to the server.
UseRemoteHostAddressForPassive | Instructs the activity to use the in passive mode
UseSimpleDirList | Instructs the activity to issue the NLST command instead of LIST
AbsoluteTimeout | Determines whether timeouts are inactivity timeouts or absolute timeouts.
LocalHost | The name of the local host or user-assigned IP interface through which connections are initiated or accepted.


Account Property

Account Property (Ftp Activity)

The user Account to login with.

Data Type

string

Default Value

""

Remarks

Some servers may require an Account for logon or in order to access specific privileges, like uploading or deleting files.


AfterConnect Property

AfterConnect Property (Ftp Activity)

A set of FTP commands to be executed immediately after connecting to the FTPServer .

Data Type

string

Default Value

""

Remarks

AfterConnect is a script that is executed immediately following a successful connection.

The script may contain any number of standard FTP commands.

Each line in the script is treated as a single command. By default, if the activity encounters any errors while executing a command, it will log the error message and will continue to process the script. This behavior can be turned off by inserting "ONERROR FAIL" at any point in the script, which will cause the script to terminate on error but will not interrupt the normal operation of the activity. The default behavior can be restored at any point in the script by inserting the line "ONERROR RESUME".

Valid additional scripting commands are listed below:

cd Path | Change the remote directory to the specified path.
del Filename | Delete the specified file from the remote server.
mkdir Directory | Create the specified remote directory on the server.
rn Filename NewFilename | Rename the remote file specified by Filename to the NewFilename.
move Filename NewFilename | Move the remote file located at Filename to the NewFilename.
rm Filename | Remove the specified file from the remote server.
rmdir Directory | Remove the remote directory from the server.


AfterPut Property

AfterPut Property (Ftp Activity)

A set of FTP commands to be executed after the PUT.

Data Type

string

Default Value

""

Remarks

AfterPut is a script that is executed immediately following each successful FTP PUT operation.

The script may contain any number of standard FTP commands.

Each line in the script is treated as a single command. By default, if the activity encounters any errors while executing a command, it will log the error message and will continue to process the script. This behavior can be turned off by inserting "ONERROR FAIL" at any point in the script, which will cause the script to terminate on error but will not interrupt the normal operation of the activity. The default behavior can be restored at any point in the script by inserting the line "ONERROR RESUME".

Valid additional scripting commands are listed below:

cd Path | Change the remote directory to the specified path.
del Filename | Delete the specified file from the remote server.
mkdir Directory | Create the specified remote directory on the server.
rn Filename NewFilename | Rename the remote file specified by Filename to the NewFilename.
move Filename NewFilename | Move the remote file located at Filename to the NewFilename.
rm Filename | Remove the specified file from the remote server.
rmdir Directory | Remove the remote directory from the server.


Append Property

Append Property (Ftp Activity)

Whether or not the activity should append data to the RemoteFile .

Data Type

bool

Default Value

false

Remarks

This property controls the activity's upload behavior. When set to TRUE, the activity will append data to the file specified by RemoteFile rather than creating or overwriting it.


BeforePut Property

BeforePut Property (Ftp Activity)

A set of FTP commands to be executed before the PUT.

Data Type

string

Default Value

""

Remarks

BeforePut is a script that is executed immediately before each successful FTP PUT operation.

The script may contain any number of standard FTP commands.

Each line in the script is treated as a single command. By default, if the activity encounters any errors while executing a command, it will log the error message and will continue to process the script. This behavior can be turned off by inserting "ONERROR FAIL" at any point in the script, which will cause the script to terminate on error but will not interrupt the normal operation of the activity. The default behavior can be restored at any point in the script by inserting the line "ONERROR RESUME".

Valid additional scripting commands are listed below:

cd Path | Change the remote directory to the specified path.
del Filename | Delete the specified file from the remote server.
mkdir Directory | Create the specified remote directory on the server.
rn Filename NewFilename | Rename the remote file specified by Filename to the NewFilename.
move Filename NewFilename | Move the remote file located at Filename to the NewFilename.
rm Filename | Remove the specified file from the remote server.
rmdir Directory | Remove the remote directory from the server.


FirewallAutoDetect Property

FirewallAutoDetect Property (Ftp Activity)

Tells the activity whether or not to automatically detect and use firewall system settings, if available.

Data Type

bool

Default Value

false

Remarks

Tells the activity whether or not to automatically detect and use firewall system settings, if available.


FirewallType Property

FirewallType Property (Ftp Activity)

Determines the type of firewall to connect through.

Possible Values

None(0)
Tunnel(1)
SOCKS4(2)
SOCKS5(3)

Data Type

string

Default Value

0

Remarks

Determines the type of firewall to connect through. The applicable values are the following:

fwNone (0) | No firewall (default setting).
fwTunnel (1) | Connect through a tunneling proxy. FirewallPort is set to 80.
fwSOCKS4 (2) | Connect through a SOCKS4 Proxy. FirewallPort is set to 1080.
fwSOCKS5 (3) | Connect through a SOCKS5 Proxy. FirewallPort is set to 1080.


FirewallHost Property

FirewallHost Property (Ftp Activity)

Name or IP address of firewall (optional).

Data Type

string

Default Value

""

Remarks

Name or IP address of firewall (optional). If a FirewallHost is given, requested connections will be authenticated through the specified firewall when connecting.

If the FirewallHost property is set to a Domain Name, a DNS request is initiated. Upon successful termination of the request, the FirewallHost property is set to the corresponding address. If the search is not successful, an error is returned.


FirewallPassword Property

FirewallPassword Property (Ftp Activity)

A password if authentication is to be used when connecting through the firewall.

Data Type

string

Default Value

""

Remarks

A password if authentication is to be used when connecting through the firewall. If FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given firewall. If the authentication fails, a trappable error is fired.


FirewallPort Property

FirewallPort Property (Ftp Activity)

The TCP port for the firewall Host .

Data Type

int

Default Value

0

Remarks

The TCP port for the firewall FirewallHost. See the description of the FirewallHost property for details.

Note that the FirewallPort is set automatically when FirewallFirewallType is set to a valid value. See the description of the FirewallFirewallType property for details.


FirewallUser Property

FirewallUser Property (Ftp Activity)

A user name if authentication is to be used connecting through a firewall.

Data Type

string

Default Value

""

Remarks

A user name if authentication is to be used connecting through a firewall. If the FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given Firewall. If the authentication fails, a trappable error is fired.


FTPPort Property

FTPPort Property (Ftp Activity)

The port for the FTP service (default is 21).

Data Type

int

Default Value

21

Remarks

A valid port number (a value between 1 and 65535) is required for the connection to take place.


FTPServer Property

FTPServer Property (Ftp Activity)

The domain name or IP address of the FTP server.

Data Type

string

Default Value

""

Remarks

The FTPServer property specifies the IP address (IP number in dotted internet format) or Domain Name of the FTP server.

If the FTPServer property is set to a Domain Name, a DNS request is initiated and upon successful termination of the request, the FTPServer property is set to the corresponding address. If the search is not successful, an error is returned.


LogMode Property

LogMode Property (Ftp Activity)

What information gets logged during activity execution.

Possible Values

Verbose(0)
Debug(1)
Warning(2)
Error(3)
Fatal(4)

Data Type

string

Default Value

3

Remarks

This property controls what information the activity logs. The possible values have the following affect on the activity's behavior:

Verbose | The activity will report all information regarding the transport.
Debug | The activity will report all major operations, as well as all warnings and errors.
Warning | The activity will report any conditions that could result in unpredictable behavior as well as errors.
Error | The activity will report all errors that prevent normal operations from completing.
Fatal | The activity will report only serious errors that cause the activity to completely stop functioning.


Other Property

Other Property (Ftp Activity)

Defines a set of configuration settings to be used by the activity.

Data Type

string

Default Value

""

Remarks

The activity accepts one or more configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

The Other property should be set to list of name/value pairs separated by the '|' character, e.g:

configname1=value1|configname2=value2


Overwrite Property

Overwrite Property (Ftp Activity)

Whether or not the activity should overwrite files during transfer.

Data Type

bool

Default Value

false

Remarks

This property is a value indicating whether or not the activity should overwrite files on the server or local system if they already exist. If Overwrite is false, an error will be thrown whenever RemoteFile exists before an upload operation, or the file exists in LocalDirectory before a download operation.


Passive Property

Passive Property (Ftp Activity)

Controls whether to direct the server into passive mode. Recommended if behind a firewall.

Data Type

bool

Default Value

true

Remarks

When false, FTP communications take place in Active mode. In an Active mode connection, data connections are established from server to client on an IP address and port specified by the client in a PORT command to the server.

Many firewalls will not allow the FTP server to open a connection from outside to the higher ports where the FTP client activity expects them. By default, Passive is set to TRUE, and the activity will request that FTP communications take place in Passive mode. In Passive mode, the activity will use the PASV instead of the PORT command and data connections will be established from the client to the server.


Password Property

Password Property (Ftp Activity)

The password to login with.

Data Type

string

Default Value

""

Remarks

This property must be set before the activity connects to the FTP server.


RemoteFile Property

RemoteFile Property (Ftp Activity)

The name of the destination file on the FTP server for uploading.

Data Type

string

Default Value

"%SourceFileName%"

Remarks

The RemoteFile is either an absolute file path, or a relative path based on RemotePath.


RemotePath Property

RemotePath Property (Ftp Activity)

The current path in the FTP server.

Data Type

string

Default Value

""

Remarks

The RemotePath can be used to set the working directory by setting it to either an absolute directory path or a path relative to the initial remote directory when the activity connects to the FTP server.


RemoteTempPath Property

RemoteTempPath Property (Ftp Activity)

A temporary directory on the server to store files before moving them to RemotePath .

Data Type

string

Default Value

""

Remarks

If a value is specified, the activity will directly upload the file to RemoteTempPath. Once the file transfer is complete, the activity will move the file to the RemotePath.


SSLAcceptServerCertStore Property

SSLAcceptServerCertStore Property (Ftp Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLAcceptServerCertStoreType property specifies the type of the certificate store specified by SSLAcceptServerCertStore. If the store is password protected, specify the password in SSLAcceptServerCertStorePassword.

SSLAcceptServerCertStore is used in conjunction with the SSLAcceptServerCertSubject property in order to specify client certificates. If SSLAcceptServerCertStore has a value, and SSLAcceptServerCertSubject is set, a search for a certificate is initiated. Please refer to the SSLAcceptServerCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLAcceptServerCertStorePassword Property

SSLAcceptServerCertStorePassword Property (Ftp Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLAcceptServerCertStoreType Property

SSLAcceptServerCertStoreType Property (Ftp Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLAcceptServerCertSubject Property

SSLAcceptServerCertSubject Property (Ftp Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLAcceptServerCertSubject is set to the full subject of the matching certificate.


SSLAcceptServerCertAcceptAny Property

SSLAcceptServerCertAcceptAny Property (Ftp Activity)

Tells the activity to accept any server certificate.

Data Type

bool

Default Value

false

Remarks

When set to true, the activity will unilaterally authenticate any server during the security handshake. It is strongly recommended that you use this only for testing purposes.


SSLCertStore Property

SSLCertStore Property (Ftp Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLCertStoreType property specifies the type of the certificate store specified by SSLCertStore. If the store is password protected, specify the password in SSLCertStorePassword.

SSLCertStore is used in conjunction with the SSLCertSubject property in order to specify client certificates. If SSLCertStore has a value, and SSLCertSubject is set, a search for a certificate is initiated. Please refer to the SSLCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLCertStorePassword Property

SSLCertStorePassword Property (Ftp Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLCertStoreType Property

SSLCertStoreType Property (Ftp Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLCertSubject Property

SSLCertSubject Property (Ftp Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLCertSubject is set to the full subject of the matching certificate.


SSLStartMode Property

SSLStartMode Property (Ftp Activity)

Determines how the activity starts the SSL negotiation.

Possible Values

Automatic(0)
Implicit(1)
Explicit(2)
None(3)

Data Type

string

Default Value

0

Remarks

The SSLStartMode property may have one of the following values:

Automatic | If the remote port is set to the standard plaintext port of the protocol (where applicable), the activity will behave the same as if SSLStartMode is set to Explicit. In all other cases, SSL negotiation will be implicit (Implicit).
Implicit | The SSL negotiation will start immediately after the connection is established.
Explicit | The activity will first connect in plaintext, and then explicitly start SSL negotiation through a protocol command such as STARTTLS.
None | No SSL negotiation, no SSL security. All communication will be in plaintext mode.


Timeout Property

Timeout Property (Ftp Activity)

A timeout for the activity.

Data Type

int

Default Value

60

Remarks

If the Timeout property is set to 0, all operations will run uninterrupted until successful completion, or an error condition is encountered.

If Timeout is set to a positive value, the activity will wait for the operation to complete before returning control.

If Timeout expires, and the operation is not yet complete, the activity fails with an error.

Please note that by default, all timeouts are inactivity timeouts, i.e. the timeout period is extended by Timeout seconds when data is successfully sent or received.

Optionally, the behavior of the activity may be changed to absolute timeouts, i.e. the activity will wait for a maximum of Timeout seconds since the beginning of the operation, without extending the timeout period during communications.

This behavior is controlled by the AbsoluteTimeout configuration setting.

The default value for the Timeout property is 60 (seconds).


TransferMode Property

TransferMode Property (Ftp Activity)

The transfer mode (ASCII or Binary). If the value is 0 (default), the initial server mode will be used.

Possible Values

Default(0)
ASCII(1)
Binary(2)

Data Type

string

Default Value

0

Remarks

The valid options for the TransferMode property are as follows:

Default | The initial mode of the FTP server is taken. No change.
ASCII | Files are transferred in ASCII mode (TYPE A).
Binary | Files are transferred in Binary mode (TYPE I).


User Property

User Property (Ftp Activity)

The user id to login as.

Data Type

string

Default Value

""

Remarks

This property must be set before the activity connects to the FTP server.


Ftp Configuration

Configuration Settings (Ftp Activity)

The activity accepts one or more of the following configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

FTP Configuration Settings

PortRange: Allows the specification of a port range where the activity listens to.

When set to use active mode (Passive = False), the activity uses any available port to listen to incoming connections from the server. You can override this behavior by setting PortRange to a value containing the range of ports the activity will be listening to.

The range is provided as start-end, for instance: "1024-" stands for anything higher than 1024, "1024-2048" stands for ports between 1024 and 2048 inclusive, "4000-4010, 50000-50010" stands for ports between 4000 and 40010 or between 50000 and 50010.

TemporaryDownloadExtension: An extension to be appended to the during download.

During download, it may be necessary for the file on the server to be renamed. After the download is complete the file will be renamed back to the original name.

TemporaryUploadExtension: An extension to be appended to the during upload.

During upload, it may be necessary for the RemoteFile to be written to a temporary file name. For example, some business process may be set up to expect a specific file extension. Using this setting will allow the activity to upload the file without the remainder of the process attempting to pick up the incomplete file.

UseClearCommandChannel: Allows for the Clear Command Channel (CCC) command.

When set, the activity will send the CCC command to the server requesting a clear (unprotected) command channel.

UseClearDataChannel: Allows for the PROT C command.

When this is set, the activity will use a clear (unprotected) data channel by sending the PROT C command to the server.

UseProtWhenImplicit: Sends PROT P to the server.

The task/adapter will send the PROT P command to the server explicitly indicating that the data channel will be protected when this is set. This only applies when the SSLStartMode is set to sslImplicit.

UseRemoteHostAddressForPassive: Instructs the activity to use the in passive mode.

This setting is only used when Passive is true. When this is set to false (default), the activity parses the remote host to send replies to from the previous response from the server. If this is true, the activity uses the value at FTPServer instead.

UseSimpleDirList: Instructs the activity to issue the NLST command instead of LIST.

When this is set to true, the activity will send the NLST command to the server. This tells the server to return a more simply formatted listing. If the server's directory listing can not be parsed when this is false, setting this to true will be helpful.

General Configuration Settings

AbsoluteTimeout: Determines whether timeouts are inactivity timeouts or absolute timeouts.

If AbsoluteTimeout is set to True, any method which does not complete within Timeout seconds will be aborted. By default, AbsoluteTimeout is False, and the timeout is an inactivity timeout.

LocalHost: The name of the local host or user-assigned IP interface through which connections are initiated or accepted.

The LocalHost configuration contains the name of the local host as obtained by the Gethostname() system call, or if the user has assigned an IP address, the value of that address.

In multihomed hosts (machines with more than one IP interface) setting LocalHost to the value of an interface will make the activity initiate connections (or accept in the case of server activitys) only through that interface.

If the activity is connected, the LocalHost configuration shows the IP address of the interface through which the connection is made in internet dotted format (aaa.bbb.ccc.ddd). In most cases, this is the address of the local host, except for multihomed hosts (machines with more than one IP interface).


S3 Activity

Properties Configuration Settings

The S3 activity provides access to Amazon's Simple Storage Service (S3).

Assembly

nsoftware.SharePoint.S3Activities.dll

Remarks

The S3 activity allows you to access Amazon's Simple Storage Service (S3) securely over an SSL connection. S3 allows you to store arbitrary data in buckets on Amazon's server and access them from anywhere using an Internet connection. Please refer to Amazon S3 documentation> for additional details.

You will first need to sign up for the S3 service and obtain the AccessKey and SecretKey from Amazon. Once you have a valid AccessKey and SecretKey, you may begin uploading files to your buckets.

S3 Send Activity

The S3 Send Activity requires a Bucket and a ObjectKey to specify the location to upload to. The AccessKey and SecretKey properties must be set in order to authenticate with the Amazon server. If you wish to enable SSL, you can turn it on by setting the UseSSL property to true and setting an appropriate SSLCert and SSLAcceptServerCert.

Property List

The following is the full list of the properties of the activity with short descriptions. Click on the links for complete descriptions.

AccessKey | The Access Key Id for the Amazon Web Services account.
AccessPolicy | The AccessPolicy are used to set permissions when an object is updated.
Bucket | The name of the current bucket.
ContentDisposition | Content disposition for the object.
ContentType | Content type for the object.
EncryptionPassword | The password to use when encrypting the object.
FirewallAutoDetect | Tells the activity whether or not to automatically detect and use firewall system settings, if available.
FirewallType | Determines the type of firewall to connect through.
FirewallHost | Name or IP address of firewall (optional).
FirewallPassword | A password if authentication is to be used when connecting through the firewall.
FirewallPort | The TCP port for the firewall Host .
FirewallUser | A user name if authentication is to be used connecting through a firewall.
HTTPProxyAuthScheme | Use the AuthScheme property to tell the activity which type of authorization to perform when connecting to the proxy.
HTTPProxyAutoDetect | Tells the activity whether or not to automatically detect and use proxy system settings, if available.
HTTPProxyPassword | A password if authentication is to be used for the proxy.
HTTPProxyPort | The TCP port for the proxy Server (default 80).
HTTPProxyServer | If a proxy Server is given, then the HTTP request is sent to the proxy instead of the server otherwise specified.
HTTPProxySSL | Determines when to use SSL for the connection to the proxy.
HTTPProxyUser | A user name, if authentication is to be used for the proxy.
LocalDirectory | The directory on the local machine to write downloaded objects to.
LogMode | What information gets logged during activity execution.
ObjectKey | This is the name of file being uploaded to the server.
ObjectMask | Indicates the type of files to download from the S3 server.
Operation | The operation which will be executed by the S3 task.
Other | Defines a set of configuration settings to be used by the activity.
Overwrite | Whether or not the activity should overwrite files during transfer.
ReceivedObjectDate | The date of the remote object received by the S3 activity.
ReceivedObjectName | The name of the remote object received by the S3 activity.
ReceivedObjectSize | The size of the remote object received by the S3 activity.
SecretKey | The Secret Access Key for the Amazon Web Services account.
SSLAcceptServerCertStore | The name of the certificate store for the client certificate.
SSLAcceptServerCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLAcceptServerCertStoreType | The type of certificate store for this certificate.
SSLAcceptServerCertSubject | The subject of the certificate used for client authentication.
SSLAcceptServerCertAcceptAny | Tells the activity to accept any server certificate.
SSLCertStore | The name of the certificate store for the client certificate.
SSLCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLCertStoreType | The type of certificate store for this certificate.
SSLCertSubject | The subject of the certificate used for client authentication.
Timeout | A timeout for the activity.
UseSSL | Use SSL to access Amazon S3.
UseVirtualHosting | Determines which style request to use.

Configuration Settings

The following is a list of configuration settings for the activity with short descriptions. Click on the links for complete descriptions.

AbsoluteTimeout | Determines whether timeouts are inactivity timeouts or absolute timeouts.
LocalHost | The name of the local host or user-assigned IP interface through which connections are initiated or accepted.


AccessKey Property

AccessKey Property (S3 Activity)

The Access Key Id for the Amazon Web Services account.

Data Type

string

Default Value

""

Remarks

For more information, please refer to the Amazon documentation.


AccessPolicy Property

AccessPolicy Property (S3 Activity)

The AccessPolicy are used to set permissions when an object is updated.

Possible Values

Private(0)
Public_Read(1)
Public_Read_Write(2)
Authenticated_Read(3)

Data Type

string

Default Value

0

Remarks

Amazon S3 allows objects to be publicly accessible, this can be achieved by setting a suitable AccessPolicy.


Bucket Property

Bucket Property (S3 Activity)

The name of the current bucket.

Data Type

string

Default Value

""

Remarks

This describes which bucket the file is either being downloaded from or uploaded to on the server.


ContentDisposition Property

ContentDisposition Property (S3 Activity)

Content disposition for the object.

Data Type

string

Default Value

""

Remarks

If the ContentDisposition property contains a non-empty string, a Content-Disposition HTTP header is added to the request. The purpose of the header is to show the content disposition of the data being POST-ed to the server. Please refer to RFC 2183 for more info on this header.

This property is not available at design time.


ContentType Property

ContentType Property (S3 Activity)

Content type for the object.

Data Type

string

Default Value

""

Remarks

If the ContentType property contains a non-empty string, a Content-Type HTTP header is added to the request. The purpose of the header is to show the contents of the data being POST-ed to the server.

This property is not available at design time.


EncryptionPassword Property

EncryptionPassword Property (S3 Activity)

The password to use when encrypting the object.

Data Type

string

Default Value

""

Remarks

EncryptionPassword is used to tell the activity to encrypt or decrypt the data.

When an object is uploaded to the Amazon server, if this property contains a non-empty string, the data that is sent will be AES encrypted using 256 bit keys.

When on object is downloaded from the Amazon server, and this property contains a non-empty string, the returned data will be AES decrypted.

The activity does not control determining which objects have and have not been encrypted.


FirewallAutoDetect Property

FirewallAutoDetect Property (S3 Activity)

Tells the activity whether or not to automatically detect and use firewall system settings, if available.

Data Type

bool

Default Value

false

Remarks

Tells the activity whether or not to automatically detect and use firewall system settings, if available.


FirewallType Property

FirewallType Property (S3 Activity)

Determines the type of firewall to connect through.

Possible Values

None(0)
Tunnel(1)
SOCKS4(2)
SOCKS5(3)

Data Type

string

Default Value

0

Remarks

Determines the type of firewall to connect through. The applicable values are the following:

fwNone (0) | No firewall (default setting).
fwTunnel (1) | Connect through a tunneling proxy. FirewallPort is set to 80.
fwSOCKS4 (2) | Connect through a SOCKS4 Proxy. FirewallPort is set to 1080.
fwSOCKS5 (3) | Connect through a SOCKS5 Proxy. FirewallPort is set to 1080.


FirewallHost Property

FirewallHost Property (S3 Activity)

Name or IP address of firewall (optional).

Data Type

string

Default Value

""

Remarks

Name or IP address of firewall (optional). If a FirewallHost is given, requested connections will be authenticated through the specified firewall when connecting.

If the FirewallHost property is set to a Domain Name, a DNS request is initiated. Upon successful termination of the request, the FirewallHost property is set to the corresponding address. If the search is not successful, an error is returned.


FirewallPassword Property

FirewallPassword Property (S3 Activity)

A password if authentication is to be used when connecting through the firewall.

Data Type

string

Default Value

""

Remarks

A password if authentication is to be used when connecting through the firewall. If FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given firewall. If the authentication fails, a trappable error is fired.


FirewallPort Property

FirewallPort Property (S3 Activity)

The TCP port for the firewall Host .

Data Type

int

Default Value

0

Remarks

The TCP port for the firewall FirewallHost. See the description of the FirewallHost property for details.

Note that the FirewallPort is set automatically when FirewallFirewallType is set to a valid value. See the description of the FirewallFirewallType property for details.


FirewallUser Property

FirewallUser Property (S3 Activity)

A user name if authentication is to be used connecting through a firewall.

Data Type

string

Default Value

""

Remarks

A user name if authentication is to be used connecting through a firewall. If the FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given Firewall. If the authentication fails, a trappable error is fired.


HTTPProxyAuthScheme Property

HTTPProxyAuthScheme Property (S3 Activity)

Use the AuthScheme property to tell the activity which type of authorization to perform when connecting to the proxy.

Possible Values

Basic(0)
Digest(1)
Proprietary(2)
None(3)
Ntlm(4)

Data Type

string

Default Value

0

Remarks

Use the HTTPProxyAuthScheme property to tell the activity which type of authorization to perform when connecting to the proxy. This is only used when the HTTPProxyUser and HTTPProxyPassword properties are set.

HTTPProxyAuthScheme should be set to authNone (3) when no authentication is expected.

By default, HTTPProxyAuthScheme is authBasic (0), and if the HTTPProxyUser and HTTPProxyPassword properties are set, the component will attempt basic authentication. If HTTPProxyAuthScheme is set to authDigest (1), digest authentication will be attempted instead.

If HTTPProxyAuthScheme is set to authProprietary (2), then the authorization token will not be generated by the activity. Look at the configuration file for the activity being used to find more information about manually setting this token.

If HTTPProxyAuthScheme is set to authNtlm (4), NTLM authentication will be used. This option is only available in the SSL package.

For security reasons, setting this property will clear the values of HTTPProxyUser and HTTPProxyPassword.


HTTPProxyAutoDetect Property

HTTPProxyAutoDetect Property (S3 Activity)

Tells the activity whether or not to automatically detect and use proxy system settings, if available.

Data Type

bool

Default Value

false

Remarks

Tells the activity whether or not to automatically detect and use proxy system settings, if available.


HTTPProxyPassword Property

HTTPProxyPassword Property (S3 Activity)

A password if authentication is to be used for the proxy.

Data Type

string

Default Value

""

Remarks

A password if authentication is to be used for the proxy.

If HTTPProxyAuthScheme is set to Basic Authentication, the HTTPProxyUser and HTTPProxyPassword are Base64 encoded and the proxy authentication token will be generated in the form "Basic [encoded-user-password]".

If HTTPProxyAuthScheme is set to Digest Authentication, the HTTPProxyUser and HTTPProxyPassword properties are used to respond to the Digest Authentication challenge from the server.

If HTTPProxyAuthScheme is set to NTLM Authentication, the HTTPProxyUser and HTTPProxyPassword properties are used to authenticate through NTLM negotiation.


HTTPProxyPort Property

HTTPProxyPort Property (S3 Activity)

The TCP port for the proxy Server (default 80).

Data Type

int

Default Value

80

Remarks

The TCP port for the proxy HTTPProxyServer (default 80). See the description of the HTTPProxyServer property for details.


HTTPProxyServer Property

HTTPProxyServer Property (S3 Activity)

If a proxy Server is given, then the HTTP request is sent to the proxy instead of the server otherwise specified.

Data Type

string

Default Value

""

Remarks

If a proxy HTTPProxyServer is given, then the HTTP request is sent to the proxy instead of the server otherwise specified.

If the HTTPProxyServer property is set to a Domain Name, a DNS request is initiated and upon successful termination of the request, the HTTPProxyServer property is set to the corresponding address. If the search is not successful, an error is returned.


HTTPProxySSL Property

HTTPProxySSL Property (S3 Activity)

Determines when to use SSL for the connection to the proxy.

Possible Values

Automatic(0)
Always(1)
Never(2)
Tunnel(3)

Data Type

string

Default Value

0

Remarks

Determines when to use SSL for the connection to the proxy. The applicable values are the following:

psAutomatic (0) | Default setting. The connection to the HTTPProxyServer is SSL-enabled for 'https' URL-s, and non SSL-enabled for other URL-s.
psAlways (1) | The connection is always SSL-enabled.
psNever (2) | The connection is not SSL-enabled.
psTunnel (3) | The connection is through a tunneling (HTTP) proxy.


HTTPProxyUser Property

HTTPProxyUser Property (S3 Activity)

A user name, if authentication is to be used for the proxy.

Data Type

string

Default Value

""

Remarks

A user name, if authentication is to be used for the proxy.

If HTTPProxyAuthScheme is set to Basic Authentication, the HTTPProxyUser and HTTPProxyPassword are Base64 encoded and the proxy authentication token will be generated in the form "Basic [encoded-user-password]".

If HTTPProxyAuthScheme is set to Digest Authentication, the HTTPProxyUser and HTTPProxyPassword properties are used to respond to the Digest Authentication challenge from the server.

If HTTPProxyAuthScheme is set to NTLM Authentication, the HTTPProxyUser and HTTPProxyPassword properties are used to authenticate through NTLM negotiation.


LogMode Property

LogMode Property (S3 Activity)

What information gets logged during activity execution.

Possible Values

Verbose(0)
Debug(1)
Warning(2)
Error(3)
Fatal(4)

Data Type

string

Default Value

3

Remarks

This property controls what information the activity logs. The possible values have the following affect on the activity's behavior:

Verbose | The activity will report all information regarding the transport.
Debug | The activity will report all major operations, as well as all warnings and errors.
Warning | The activity will report any conditions that could result in unpredictable behavior as well as errors.
Error | The activity will report all errors that prevent normal operations from completing.
Fatal | The activity will report only serious errors that cause the activity to completely stop functioning.


ObjectKey Property

ObjectKey Property (S3 Activity)

This is the name of file being uploaded to the server.

Data Type

string

Default Value

"%SourceFileName%"

Remarks

This should be the name of the file as it appears on the server when it is uploaded.


Other Property

Other Property (S3 Activity)

Defines a set of configuration settings to be used by the activity.

Data Type

string

Default Value

""

Remarks

The activity accepts one or more configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

The Other property should be set to list of name/value pairs separated by the '|' character, e.g:

configname1=value1|configname2=value2


SecretKey Property

SecretKey Property (S3 Activity)

The Secret Access Key for the Amazon Web Services account.

Data Type

string

Default Value

""

Remarks

For more information, please refer to the Amazon documentation.


SSLAcceptServerCertStore Property

SSLAcceptServerCertStore Property (S3 Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLAcceptServerCertStoreType property specifies the type of the certificate store specified by SSLAcceptServerCertStore. If the store is password protected, specify the password in SSLAcceptServerCertStorePassword.

SSLAcceptServerCertStore is used in conjunction with the SSLAcceptServerCertSubject property in order to specify client certificates. If SSLAcceptServerCertStore has a value, and SSLAcceptServerCertSubject is set, a search for a certificate is initiated. Please refer to the SSLAcceptServerCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLAcceptServerCertStorePassword Property

SSLAcceptServerCertStorePassword Property (S3 Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLAcceptServerCertStoreType Property

SSLAcceptServerCertStoreType Property (S3 Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLAcceptServerCertSubject Property

SSLAcceptServerCertSubject Property (S3 Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLAcceptServerCertSubject is set to the full subject of the matching certificate.


SSLAcceptServerCertAcceptAny Property

SSLAcceptServerCertAcceptAny Property (S3 Activity)

Tells the activity to accept any server certificate.

Data Type

bool

Default Value

false

Remarks

When set to true, the activity will unilaterally authenticate any server during the security handshake. It is strongly recommended that you use this only for testing purposes.


SSLCertStore Property

SSLCertStore Property (S3 Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLCertStoreType property specifies the type of the certificate store specified by SSLCertStore. If the store is password protected, specify the password in SSLCertStorePassword.

SSLCertStore is used in conjunction with the SSLCertSubject property in order to specify client certificates. If SSLCertStore has a value, and SSLCertSubject is set, a search for a certificate is initiated. Please refer to the SSLCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLCertStorePassword Property

SSLCertStorePassword Property (S3 Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLCertStoreType Property

SSLCertStoreType Property (S3 Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLCertSubject Property

SSLCertSubject Property (S3 Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLCertSubject is set to the full subject of the matching certificate.


Timeout Property

Timeout Property (S3 Activity)

A timeout for the activity.

Data Type

int

Default Value

60

Remarks

If the Timeout property is set to 0, all operations will run uninterrupted until successful completion, or an error condition is encountered.

If Timeout is set to a positive value, the activity will wait for the operation to complete before returning control.

If Timeout expires, and the operation is not yet complete, the activity fails with an error.

Please note that by default, all timeouts are inactivity timeouts, i.e. the timeout period is extended by Timeout seconds when data is successfully sent or received.

Optionally, the behavior of the activity may be changed to absolute timeouts, i.e. the activity will wait for a maximum of Timeout seconds since the beginning of the operation, without extending the timeout period during communications.

This behavior is controlled by the AbsoluteTimeout configuration setting.

The default value for the Timeout property is 60 (seconds).


UseSSL Property

UseSSL Property (S3 Activity)

Use SSL to access Amazon S3.

Data Type

bool

Default Value

false

Remarks

Use this property to determine whether the activity uses SSL to connect with Amazon S3 servers.


UseVirtualHosting Property

UseVirtualHosting Property (S3 Activity)

Determines which style request to use.

Data Type

bool

Default Value

false

Remarks

If set to true, buckets will be referenced in the request using the hosted-style request: http://yourbucket.s3.amazonaws.com/yourobject. If false (default), the activity will use the path-style request: http://s3.amazonaws.com/yourbucket/yourobject.


S3 Configuration

Configuration Settings (S3 Activity)

The activity accepts one or more of the following configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

General Configuration Settings

AbsoluteTimeout: Determines whether timeouts are inactivity timeouts or absolute timeouts.

If AbsoluteTimeout is set to True, any method which does not complete within Timeout seconds will be aborted. By default, AbsoluteTimeout is False, and the timeout is an inactivity timeout.

LocalHost: The name of the local host or user-assigned IP interface through which connections are initiated or accepted.

The LocalHost configuration contains the name of the local host as obtained by the Gethostname() system call, or if the user has assigned an IP address, the value of that address.

In multihomed hosts (machines with more than one IP interface) setting LocalHost to the value of an interface will make the activity initiate connections (or accept in the case of server activitys) only through that interface.

If the activity is connected, the LocalHost configuration shows the IP address of the interface through which the connection is made in internet dotted format (aaa.bbb.ccc.ddd). In most cases, this is the address of the local host, except for multihomed hosts (machines with more than one IP interface).


Sexec Activity

Properties Configuration Settings

The SExec Activity enables your SharePoint site to execute remote commands over SSH.

Assembly

nsoftware.SharePoint.SExecActivities.dll

Remarks

The SExec Activity uses the SSH "exec" subsystem to remotely execute commands from your SharePoint site.

SExec Send Activity

The SExec Send Activity provides an ultra light-weight remote command execution client for your SharePoint site. You must first set an SSHHost. If the SSH server requires authentication, you should set the necessary SSHUser, and either SSHPassword or SSHCert depending on the SSHAuthMode you wish to use. Once the SSH server information is set, you must enter the Command you wish to execute.

Whenever called from the WorkFlow, the activity will execute the given command. If the Stdin property has any data, that data will supplied to the executing command's standard in pipe. If CloseAfterStdin is true, the activity will force a disconnection as soon as it has finished uploading the standard in data.

Once the command has finished executing, the activity will write the output from the command's standard out pipe to the variable pointed to by the CommandStdOut property. It will also write the command's exit code to the variable pointed to by the CommandExitStatus property, and any data from the standard err pipe to the variable pointed to by the CommandErrorMessage property.

Property List

The following is the full list of the properties of the activity with short descriptions. Click on the links for complete descriptions.

Command | The command to be sent to the remote host.
CommandErrorMessage | The error message, if any, returned by the server after command execution.
CommandExitStatus | The exit code for the executed command for the current message.
CommandStdErr | The standard error output of the executed Command .
CommandStdOut | The standard output of the executed Command .
FailOnError | Controls how the activity treats error codes returned by command execution.
FirewallAutoDetect | Tells the activity whether or not to automatically detect and use firewall system settings, if available.
FirewallType | Determines the type of firewall to connect through.
FirewallHost | Name or IP address of firewall (optional).
FirewallPassword | A password if authentication is to be used when connecting through the firewall.
FirewallPort | The TCP port for the firewall Host .
FirewallUser | A user name if authentication is to be used connecting through a firewall.
LogMode | What information gets logged during activity execution.
Other | Defines a set of configuration settings to be used by the activity.
SSHAcceptServerHostKeyStore | The name of the certificate store for the client certificate.
SSHAcceptServerHostKeyStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSHAcceptServerHostKeyStoreType | The type of certificate store for this certificate.
SSHAcceptServerHostKeySubject | The subject of the certificate used for client authentication.
SSHAcceptServerHostKeyAcceptAny | Tells the activity to accept any server certificate.
SSHAuthMode | The type of authentication used by the activity.
SSHCertStore | The name of the certificate store for the client certificate.
SSHCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSHCertStoreType | The type of certificate store for this certificate.
SSHCertSubject | The subject of the certificate used for client authentication.
SSHCompressionAlgorithms | A comma-separated list of compression algorithms allowed for this connection.
SSHHost | The address of the SSH host.
SSHPassword | The password for SSH password-based authentication.
SSHPort | The port on the SSH server where the SSH service is running; by default, 22.
SSHUser | The username for SSH authentication.
Stdin | A string of data that will be supplied to the executing command's standard in pipe.
Timeout | A timeout for the activity.

Configuration Settings

The following is a list of configuration settings for the activity with short descriptions. Click on the links for complete descriptions.

SSHAcceptServerHostKeyFingerPrint | Instructs the activity to accept the server's host key with this fingerprint.


Command Property

Command Property (Sexec Activity)

The command to be sent to the remote host.

Data Type

string

Default Value

""

Remarks

Assigning a UNIX command to this property makes the activity attempt to connect to the SSHHost and execute the command under the user's default shell. There is no need to append an end-of-line character to the command. All output from the remote application will be returned to the activity.

Note: the activity will terminate the connection once the remote application has finished executing.


CommandErrorMessage Property

CommandErrorMessage Property (Sexec Activity)

The error message, if any, returned by the server after command execution.

Data Type

string

Default Value

""

Remarks

After executing the Command, the server will send a notification containing the CommandExitStatus. The server may also send a textual representation of that code, which will be stored in CommandErrorMessage.

This property is contains output that exists after execution of the activity. You may bind this to a variable within a workflow so that the contents of the output are written there as well.

NOTE: SharePoint Designer users may want to use the "ParameterNames" DesignerType when setting this property.


CommandExitStatus Property

CommandExitStatus Property (Sexec Activity)

The exit code for the executed command for the current message.

Data Type

int

Default Value

0

Remarks

After executing the Command, the server will send a notification containing the CommandExitStatus. The server may also send a textual representation of that code, which will be stored in CommandErrorMessage.

This property is contains output that exists after execution of the activity. You may bind this to a variable within a workflow so that the contents of the output are written there as well.

NOTE: SharePoint Designer users may want to use the "ParameterNames" DesignerType when setting this property.


CommandStdErr Property

CommandStdErr Property (Sexec Activity)

The standard error output of the executed Command .

Data Type

string

Default Value

""

Remarks

This property will contain the standard error output of the Command once execution has completed.

This property is contains output that exists after execution of the activity. You may bind this to a variable within a workflow so that the contents of the output are written there as well.

NOTE: SharePoint Designer users may want to use the "ParameterNames" DesignerType when setting this property.


CommandStdOut Property

CommandStdOut Property (Sexec Activity)

The standard output of the executed Command .

Data Type

string

Default Value

""

Remarks

This property will contain the standard output of the Command once execution has completed.

This property is contains output that exists after execution of the activity. You may bind this to a variable within a workflow so that the contents of the output are written there as well.

NOTE: SharePoint Designer users may want to use the "ParameterNames" DesignerType when setting this property.


FailOnError Property

FailOnError Property (Sexec Activity)

Controls how the activity treats error codes returned by command execution.

Data Type

bool

Default Value

true

Remarks

If set to True, FailOnError will cause the activity to stop processing the inbound data and raise an error if the SSHHost returns an unsuccessful error code when executing the Command.

If set to False, the activity will return all error information through the CommandExitStatus and CommandErrorMessage. Any standard output from the command's execution will be stored as usual in the message body.

Note: since FailOnError defaults to True, some improper command values may result in unexpected errors. In this case, it is useful to examine the standard output for any hints on proper command usage by setting FailOnError to false and writing the contents of the message to a file.


FirewallAutoDetect Property

FirewallAutoDetect Property (Sexec Activity)

Tells the activity whether or not to automatically detect and use firewall system settings, if available.

Data Type

bool

Default Value

false

Remarks

Tells the activity whether or not to automatically detect and use firewall system settings, if available.


FirewallType Property

FirewallType Property (Sexec Activity)

Determines the type of firewall to connect through.

Possible Values

None(0)
Tunnel(1)
SOCKS4(2)
SOCKS5(3)

Data Type

string

Default Value

0

Remarks

Determines the type of firewall to connect through. The applicable values are the following:

fwNone (0) | No firewall (default setting).
fwTunnel (1) | Connect through a tunneling proxy. FirewallPort is set to 80.
fwSOCKS4 (2) | Connect through a SOCKS4 Proxy. FirewallPort is set to 1080.
fwSOCKS5 (3) | Connect through a SOCKS5 Proxy. FirewallPort is set to 1080.


FirewallHost Property

FirewallHost Property (Sexec Activity)

Name or IP address of firewall (optional).

Data Type

string

Default Value

""

Remarks

Name or IP address of firewall (optional). If a FirewallHost is given, requested connections will be authenticated through the specified firewall when connecting.

If the FirewallHost property is set to a Domain Name, a DNS request is initiated. Upon successful termination of the request, the FirewallHost property is set to the corresponding address. If the search is not successful, an error is returned.


FirewallPassword Property

FirewallPassword Property (Sexec Activity)

A password if authentication is to be used when connecting through the firewall.

Data Type

string

Default Value

""

Remarks

A password if authentication is to be used when connecting through the firewall. If FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given firewall. If the authentication fails, a trappable error is fired.


FirewallPort Property

FirewallPort Property (Sexec Activity)

The TCP port for the firewall Host .

Data Type

int

Default Value

0

Remarks

The TCP port for the firewall FirewallHost. See the description of the FirewallHost property for details.

Note that the FirewallPort is set automatically when FirewallFirewallType is set to a valid value. See the description of the FirewallFirewallType property for details.


FirewallUser Property

FirewallUser Property (Sexec Activity)

A user name if authentication is to be used connecting through a firewall.

Data Type

string

Default Value

""

Remarks

A user name if authentication is to be used connecting through a firewall. If the FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given Firewall. If the authentication fails, a trappable error is fired.


LogMode Property

LogMode Property (Sexec Activity)

What information gets logged during activity execution.

Possible Values

Verbose(0)
Debug(1)
Warning(2)
Error(3)
Fatal(4)

Data Type

string

Default Value

3

Remarks

This property controls what information the activity logs. The possible values have the following affect on the activity's behavior:

Verbose | The activity will report all information regarding the transport.
Debug | The activity will report all major operations, as well as all warnings and errors.
Warning | The activity will report any conditions that could result in unpredictable behavior as well as errors.
Error | The activity will report all errors that prevent normal operations from completing.
Fatal | The activity will report only serious errors that cause the activity to completely stop functioning.


Other Property

Other Property (Sexec Activity)

Defines a set of configuration settings to be used by the activity.

Data Type

string

Default Value

""

Remarks

The activity accepts one or more configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

The Other property should be set to list of name/value pairs separated by the '|' character, e.g:

configname1=value1|configname2=value2


SSHAcceptServerHostKeyStore Property

SSHAcceptServerHostKeyStore Property (Sexec Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSHAcceptServerHostKeyStoreType property specifies the type of the certificate store specified by SSHAcceptServerHostKeyStore. If the store is password protected, specify the password in SSHAcceptServerHostKeyStorePassword.

SSHAcceptServerHostKeyStore is used in conjunction with the SSHAcceptServerHostKeySubject property in order to specify client certificates. If SSHAcceptServerHostKeyStore has a value, and SSHAcceptServerHostKeySubject is set, a search for a certificate is initiated. Please refer to the SSHAcceptServerHostKeySubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSHAcceptServerHostKeyStorePassword Property

SSHAcceptServerHostKeyStorePassword Property (Sexec Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSHAcceptServerHostKeyStoreType Property

SSHAcceptServerHostKeyStoreType Property (Sexec Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSHAcceptServerHostKeySubject Property

SSHAcceptServerHostKeySubject Property (Sexec Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSHAcceptServerHostKeySubject is set to the full subject of the matching certificate.


SSHAcceptServerHostKeyAcceptAny Property

SSHAcceptServerHostKeyAcceptAny Property (Sexec Activity)

Tells the activity to accept any server certificate.

Data Type

bool

Default Value

false

Remarks

When set to true, the activity will unilaterally authenticate any server during the security handshake. It is strongly recommended that you use this only for testing purposes.


SSHAuthMode Property

SSHAuthMode Property (Sexec Activity)

The type of authentication used by the activity.

Possible Values

None(0)
MultiFactor(1)
Password(2)
PublicKey(3)
KeyboardInteractive(4)

Data Type

string

Default Value

2

Remarks

SSHAuthMode controls how the activity attempts to authenticate when connecting to the SSHHost. The following authentication methods are available:

None | The activity will attempt anonymous authentication.
Multi-Factor | The activity will attempt as many authentication steps as the server requires using whatever credentials it has available.
Password | The activity will send the SSHPassword to the server.
Public Key | The activity will send the SSHCert to the server;
Keyboard-Interactive | The activity will perform SSH keyboard-interactive authentication, responding automatically to the server's authentication prompts. It will supply the value of SSHPassword as the response to the "password" prompt. Note: this method is not truly keyboard-interactive, and the activity may not recognize all prompts supplied by the server. It should be used only when the SSHHost cannot be configured to authenticate the SSHUser via more easily automated methods such as Password or Public Key.


SSHCertStore Property

SSHCertStore Property (Sexec Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSHCertStoreType property specifies the type of the certificate store specified by SSHCertStore. If the store is password protected, specify the password in SSHCertStorePassword.

SSHCertStore is used in conjunction with the SSHCertSubject property in order to specify client certificates. If SSHCertStore has a value, and SSHCertSubject is set, a search for a certificate is initiated. Please refer to the SSHCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSHCertStorePassword Property

SSHCertStorePassword Property (Sexec Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSHCertStoreType Property

SSHCertStoreType Property (Sexec Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSHCertSubject Property

SSHCertSubject Property (Sexec Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSHCertSubject is set to the full subject of the matching certificate.


SSHCompressionAlgorithms Property

SSHCompressionAlgorithms Property (Sexec Activity)

A comma-separated list of compression algorithms allowed for this connection.

Data Type

string

Default Value

"none"

Remarks

This list is used for both directions: client to server and server to client. When negotiating algorithms, each side sends a list of all algorithms it supports or allows. The algorithm chosen for each direction is the first algorithm to appear in the sender's list that the receiver supports, so it is important to list multiple algorithms in preferential order. If no algorithm can be agreed upon, the activity will raise an error and the connection will be aborted.

SSHCompressionAlgorithms must be set to a comma-separated list containing at least one of the following values:

zlib | Zlib compression is allowed for this connection.
none | No compression is allowed for this connection.


SSHHost Property

SSHHost Property (Sexec Activity)

The address of the SSH host.

Data Type

string

Default Value

""

Remarks

The SSHHost property specifies the IP address (IP number in dotted internet format) or Domain Name of the remote host. It is set before a connection is attempted and cannot be changed once a connection is established.

If the SSHHost property is set to a Domain Name, a DNS request is initiated, and upon successful termination of the request, the SSHHost property is set to the corresponding address. If the search is not successful, an error is logged.


SSHPassword Property

SSHPassword Property (Sexec Activity)

The password for SSH password-based authentication.

Data Type

string

Default Value

""

Remarks

SSHPassword specifies the password which is used to authenticate the client to the SSH server.


SSHPort Property

SSHPort Property (Sexec Activity)

The port on the SSH server where the SSH service is running; by default, 22.

Data Type

int

Default Value

22

Remarks

The SSHPort specifies a service port on the SSH host to connect to.


SSHUser Property

SSHUser Property (Sexec Activity)

The username for SSH authentication.

Data Type

string

Default Value

""

Remarks

SSHUser specifies the username which is used to authenticate the client to the SSH server. This property is required.


Stdin Property

Stdin Property (Sexec Activity)

A string of data that will be supplied to the executing command's standard in pipe.

Data Type

string

Default Value

""

Remarks

During execution of the Command property, if the Stdin property has any data, that data will supplied to the executing command's standard in pipe.

Note:, If CloseAfterStdin is true, the activity will force a disconnection as soon as it has finished uploading the standard in data.

This property is write-only and not available at design time.


Timeout Property

Timeout Property (Sexec Activity)

A timeout for the activity.

Data Type

int

Default Value

60

Remarks

If the Timeout property is set to 0, all operations will run uninterrupted until successful completion, or an error condition is encountered.

If Timeout is set to a positive value, the activity will wait for the operation to complete before returning control.

If Timeout expires, and the operation is not yet complete, the activity fails with an error.

Please note that by default, all timeouts are inactivity timeouts, i.e. the timeout period is extended by Timeout seconds when data is successfully sent or received.

Optionally, the behavior of the activity may be changed to absolute timeouts, i.e. the activity will wait for a maximum of Timeout seconds since the beginning of the operation, without extending the timeout period during communications.

This behavior is controlled by the AbsoluteTimeout configuration setting.

The default value for the Timeout property is 60 (seconds).


Sexec Configuration

Configuration Settings (Sexec Activity)

The activity accepts one or more of the following configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

SExec Configuration Settings

SSHAcceptServerHostKeyFingerPrint: Instructs the activity to accept the server's host key with this fingerprint.

This may be set to the 16-byte MD5 fingerprint of the host's key. You may supply it by HEX encoding the values in the form "0a:1b:2c:3d".


Sftp Activity

Properties Configuration Settings

The SFTP Activity adds SSH-secured file transfer capabilities to your SharePoint site.

Assembly

nsoftware.SharePoint.SFTPActivities.dll

Remarks

The SFTP Activity adds a complete SFTP client to your SharePoint site that enables it with SSH-secured file upload functionality.

SFTP Send Activity

The SFTP Send Activity requires an SSHHost to be set. In addition, an item must also be specified by either setting the UsesCurrentItem attribute for the action if using SharePoint Designer or the WorkflowProperties property if using Visual Studio. You may also set an SSHPort if the server is not running on the default SSH port. In order to authenticate with the SSH server, you will need to specify an SSHUser, and either SSHPassword or an SSH client certificate by using the SSH cert properties depending upon the SSHAuthMode to be used.

The activity will connect to the SFTP server whenever it has a message to send. The activity will attempt to upload to the specified RemotePath. You may set the RemoteFile property if a name other than the name which the SharePoint site has for that file is desired. In order to prevent parallel processing by another application before your upload is complete, you may need to set a temporary upload directory via RemoteTempDir. If the temporary directory is set, the file will first be uploaded to the specified temporary directory, and will be moved to the final destination path once the upload has completed. If Overwrite is set to True, the activity will delete or overwrite remote files as necessary to complete the operation.

Property List

The following is the full list of the properties of the activity with short descriptions. Click on the links for complete descriptions.

AfterConnect | A set of FTP-style commands to be executed immediately after connecting to the SSHHost .
AfterGet | A set of FTP-style commands to be executed after the download.
AfterPut | A set of FTP-style commands to be executed after the upload.
Append | Whether or not the activity should append data to the RemoteFile .
BeforeGet | A set of FTP-style commands to be executed before the download.
BeforePut | A set of FTP-style commands to be executed before the upload.
Delete | Controls if the remote file is deleted after download.
DeleteMode | Controls if and when the remote file is deleted after download.
FileMask | Indicates the type of files to download from the FTP server.
FirewallAutoDetect | Tells the activity whether or not to automatically detect and use firewall system settings, if available.
FirewallType | Determines the type of firewall to connect through.
FirewallHost | Name or IP address of firewall (optional).
FirewallPassword | A password if authentication is to be used when connecting through the firewall.
FirewallPort | The TCP port for the firewall Host .
FirewallUser | A user name if authentication is to be used connecting through a firewall.
LocalDirectory | The directory on the local machine to write downloaded files to.
LogMode | What information gets logged during activity execution.
Operation | The operation which will be executed by the FTP task.
Other | Defines a set of configuration settings to be used by the activity.
Overwrite | Whether or not the activity should overwrite files during transfer.
ReceivedFileDate | The date of the remote file received by the SFTP activity.
ReceivedFileName | The name of the remote file received by the SFTP activity.
ReceivedFileSize | The size of the remote file received by the SFTP activity.
ReceivedFileSSHUser | The SSH user name used to by the SFTP activity when downloading the remote file.
RemoteFile | The name of the destination file on the SFTP server for uploading.
RemotePath | The current path in the SFTP server.
RemoteTempPath | A temporary directory on the server to store files before moving them to RemotePath .
SSHAcceptServerHostKeyStore | The name of the certificate store for the client certificate.
SSHAcceptServerHostKeyStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSHAcceptServerHostKeyStoreType | The type of certificate store for this certificate.
SSHAcceptServerHostKeySubject | The subject of the certificate used for client authentication.
SSHAcceptServerHostKeyAcceptAny | Tells the activity to accept any server certificate.
SSHAuthMode | The type of authentication used by the activity.
SSHCertStore | The name of the certificate store for the client certificate.
SSHCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSHCertStoreType | The type of certificate store for this certificate.
SSHCertSubject | The subject of the certificate used for client authentication.
SSHCompressionAlgorithms | A comma-separated list of compression algorithms allowed for this connection.
SSHHost | The address of the SSH host.
SSHPassword | The password for SSH password-based authentication.
SSHPort | The port on the SSH server where the SSH service is running; by default, 22.
SSHUser | The username for SSH authentication.
Timeout | A timeout for the activity.

Configuration Settings

The following is a list of configuration settings for the activity with short descriptions. Click on the links for complete descriptions.

IgnoreFileMaskCasing | Instructs the activity to ignore casing of when FileMask is set.
MaxFileData | Specifies the maximum payload size of an SFTP packet.
RenameTo | Specifies the value to which a file will be renamed.
SSHAcceptServerHostKeyFingerPrint | Instructs the activity to accept the server's host key with this fingerprint.
TemporaryDownloadExtension | An extension to be appended to the during download
TemporaryUploadExtension | An extension to be appended to the during upload
AbsoluteTimeout | Determines whether timeouts are inactivity timeouts or absolute timeouts.
LocalHost | The name of the local host or user-assigned IP interface through which connections are initiated or accepted.


AfterConnect Property

AfterConnect Property (Sftp Activity)

A set of FTP-style commands to be executed immediately after connecting to the SSHHost .

Data Type

string

Default Value

""

Remarks

AfterConnect is a script that is executed immediately following a successful connection.

Each line in the script is treated as a single command. By default, if the activity encounters any errors while executing a command, it will log the error message and will continue to process the script. This behavior can be turned off by inserting "ONERROR FAIL" at any point in the script, which will cause the script to terminate on error but will not interrupt the normal operation of the activity. The default behavior can be restored at any point in the script by inserting the line "ONERROR RESUME".

Valid additional scripting commands are listed below:

cd Path | Change the remote directory to the specified path.
del Filename | Delete the specified file from the remote server.
mkdir Directory | Create the specified remote directory on the server.
rn Filename NewFilename | Rename the remote file specified by Filename to the NewFilename.
move Filename NewFilename | Move the remote file located at Filename to the NewFilename.
rm Filename | Remove the specified file from the remote server.
rmdir Directory | Remove the remote directory from the server.


AfterPut Property

AfterPut Property (Sftp Activity)

A set of FTP-style commands to be executed after the upload.

Data Type

string

Default Value

""

Remarks

AfterPut is a script that is executed immediately following each successful upload operation.

Each line in the script is treated as a single command. By default, if the activity encounters any errors while executing a command, it will log the error message and will continue to process the script. This behavior can be turned off by inserting "ONERROR FAIL" at any point in the script, which will cause the script to terminate on error but will not interrupt the normal operation of the activity. The default behavior can be restored at any point in the script by inserting the line "ONERROR RESUME".

Valid additional scripting commands are listed below:

cd Path | Change the remote directory to the specified path.
del Filename | Delete the specified file from the remote server.
mkdir Directory | Create the specified remote directory on the server.
rn Filename NewFilename | Rename the remote file specified by Filename to the NewFilename.
move Filename NewFilename | Move the remote file located at Filename to the NewFilename.
rm Filename | Remove the specified file from the remote server.
rmdir Directory | Remove the remote directory from the server.


Append Property

Append Property (Sftp Activity)

Whether or not the activity should append data to the RemoteFile .

Data Type

bool

Default Value

false

Remarks

This property controls the activity's upload behavior. When set to TRUE, the activity will append data to the file specified by RemoteFile rather than creating or overwriting it.


BeforePut Property

BeforePut Property (Sftp Activity)

A set of FTP-style commands to be executed before the upload.

Data Type

string

Default Value

""

Remarks

BeforePut is a script that is executed immediately before each upload operation.

Each line in the script is treated as a single command. By default, if the activity encounters any errors while executing a command, it will log the error message and will continue to process the script. This behavior can be turned off by inserting "ONERROR FAIL" at any point in the script, which will cause the script to terminate on error but will not interrupt the normal operation of the activity. The default behavior can be restored at any point in the script by inserting the line "ONERROR RESUME".

Valid additional scripting commands are listed below:

cd Path | Change the remote directory to the specified path.
del Filename | Delete the specified file from the remote server.
mkdir Directory | Create the specified remote directory on the server.
rn Filename NewFilename | Rename the remote file specified by Filename to the NewFilename.
move Filename NewFilename | Move the remote file located at Filename to the NewFilename.
rm Filename | Remove the specified file from the remote server.
rmdir Directory | Remove the remote directory from the server.


FirewallAutoDetect Property

FirewallAutoDetect Property (Sftp Activity)

Tells the activity whether or not to automatically detect and use firewall system settings, if available.

Data Type

bool

Default Value

false

Remarks

Tells the activity whether or not to automatically detect and use firewall system settings, if available.


FirewallType Property

FirewallType Property (Sftp Activity)

Determines the type of firewall to connect through.

Possible Values

None(0)
Tunnel(1)
SOCKS4(2)
SOCKS5(3)

Data Type

string

Default Value

0

Remarks

Determines the type of firewall to connect through. The applicable values are the following:

fwNone (0) | No firewall (default setting).
fwTunnel (1) | Connect through a tunneling proxy. FirewallPort is set to 80.
fwSOCKS4 (2) | Connect through a SOCKS4 Proxy. FirewallPort is set to 1080.
fwSOCKS5 (3) | Connect through a SOCKS5 Proxy. FirewallPort is set to 1080.


FirewallHost Property

FirewallHost Property (Sftp Activity)

Name or IP address of firewall (optional).

Data Type

string

Default Value

""

Remarks

Name or IP address of firewall (optional). If a FirewallHost is given, requested connections will be authenticated through the specified firewall when connecting.

If the FirewallHost property is set to a Domain Name, a DNS request is initiated. Upon successful termination of the request, the FirewallHost property is set to the corresponding address. If the search is not successful, an error is returned.


FirewallPassword Property

FirewallPassword Property (Sftp Activity)

A password if authentication is to be used when connecting through the firewall.

Data Type

string

Default Value

""

Remarks

A password if authentication is to be used when connecting through the firewall. If FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given firewall. If the authentication fails, a trappable error is fired.


FirewallPort Property

FirewallPort Property (Sftp Activity)

The TCP port for the firewall Host .

Data Type

int

Default Value

0

Remarks

The TCP port for the firewall FirewallHost. See the description of the FirewallHost property for details.

Note that the FirewallPort is set automatically when FirewallFirewallType is set to a valid value. See the description of the FirewallFirewallType property for details.


FirewallUser Property

FirewallUser Property (Sftp Activity)

A user name if authentication is to be used connecting through a firewall.

Data Type

string

Default Value

""

Remarks

A user name if authentication is to be used connecting through a firewall. If the FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given Firewall. If the authentication fails, a trappable error is fired.


LogMode Property

LogMode Property (Sftp Activity)

What information gets logged during activity execution.

Possible Values

Verbose(0)
Debug(1)
Warning(2)
Error(3)
Fatal(4)

Data Type

string

Default Value

3

Remarks

This property controls what information the activity logs. The possible values have the following affect on the activity's behavior:

Verbose | The activity will report all information regarding the transport.
Debug | The activity will report all major operations, as well as all warnings and errors.
Warning | The activity will report any conditions that could result in unpredictable behavior as well as errors.
Error | The activity will report all errors that prevent normal operations from completing.
Fatal | The activity will report only serious errors that cause the activity to completely stop functioning.


Other Property

Other Property (Sftp Activity)

Defines a set of configuration settings to be used by the activity.

Data Type

string

Default Value

""

Remarks

The activity accepts one or more configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

The Other property should be set to list of name/value pairs separated by the '|' character, e.g:

configname1=value1|configname2=value2


Overwrite Property

Overwrite Property (Sftp Activity)

Whether or not the activity should overwrite files during transfer.

Data Type

bool

Default Value

false

Remarks

This property is a value indicating whether or not the activity should overwrite files on the server or local system if they already exist. If Overwrite is false, an error will be thrown whenever RemoteFile exists before an upload operation, or the file exists in LocalDirectory before a download operation.


RemoteFile Property

RemoteFile Property (Sftp Activity)

The name of the destination file on the SFTP server for uploading.

Data Type

string

Default Value

"%SourceFileName%"

Remarks

The RemoteFile is either an absolute file path, or a relative path based on RemotePath.


RemotePath Property

RemotePath Property (Sftp Activity)

The current path in the SFTP server.

Data Type

string

Default Value

""

Remarks

The RemotePath can be used to set the working directory by setting it to either an absolute directory path or a path relative to the initial remote directory when the activity connects to the SFTP server.

The activity will check to make sure that RemotePath exists. If it does not, the activity will attempt to create each subdirectory in RemotePath.


RemoteTempPath Property

RemoteTempPath Property (Sftp Activity)

A temporary directory on the server to store files before moving them to RemotePath .

Data Type

string

Default Value

""

Remarks

If a value is specified, the activity will directly upload the file to RemoteTempPath. Once the file transfer is complete, the activity will move the file to the RemotePath.


SSHAcceptServerHostKeyStore Property

SSHAcceptServerHostKeyStore Property (Sftp Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSHAcceptServerHostKeyStoreType property specifies the type of the certificate store specified by SSHAcceptServerHostKeyStore. If the store is password protected, specify the password in SSHAcceptServerHostKeyStorePassword.

SSHAcceptServerHostKeyStore is used in conjunction with the SSHAcceptServerHostKeySubject property in order to specify client certificates. If SSHAcceptServerHostKeyStore has a value, and SSHAcceptServerHostKeySubject is set, a search for a certificate is initiated. Please refer to the SSHAcceptServerHostKeySubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSHAcceptServerHostKeyStorePassword Property

SSHAcceptServerHostKeyStorePassword Property (Sftp Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSHAcceptServerHostKeyStoreType Property

SSHAcceptServerHostKeyStoreType Property (Sftp Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSHAcceptServerHostKeySubject Property

SSHAcceptServerHostKeySubject Property (Sftp Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSHAcceptServerHostKeySubject is set to the full subject of the matching certificate.


SSHAcceptServerHostKeyAcceptAny Property

SSHAcceptServerHostKeyAcceptAny Property (Sftp Activity)

Tells the activity to accept any server certificate.

Data Type

bool

Default Value

false

Remarks

When set to true, the activity will unilaterally authenticate any server during the security handshake. It is strongly recommended that you use this only for testing purposes.


SSHAuthMode Property

SSHAuthMode Property (Sftp Activity)

The type of authentication used by the activity.

Possible Values

None(0)
MultiFactor(1)
Password(2)
PublicKey(3)
KeyboardInteractive(4)

Data Type

string

Default Value

2

Remarks

SSHAuthMode controls how the activity attempts to authenticate when connecting to the SSHHost. The following authentication methods are available:

None | The activity will attempt anonymous authentication.
Multi-Factor | The activity will attempt as many authentication steps as the server requires using whatever credentials it has available.
Password | The activity will send the SSHPassword to the server.
Public Key | The activity will send the SSHCert to the server;
Keyboard-Interactive | The activity will perform SSH keyboard-interactive authentication, responding automatically to the server's authentication prompts. It will supply the value of SSHPassword as the response to the "password" prompt. Note: this method is not truly keyboard-interactive, and the activity may not recognize all prompts supplied by the server. It should be used only when the SSHHost cannot be configured to authenticate the SSHUser via more easily automated methods such as Password or Public Key.


SSHCertStore Property

SSHCertStore Property (Sftp Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSHCertStoreType property specifies the type of the certificate store specified by SSHCertStore. If the store is password protected, specify the password in SSHCertStorePassword.

SSHCertStore is used in conjunction with the SSHCertSubject property in order to specify client certificates. If SSHCertStore has a value, and SSHCertSubject is set, a search for a certificate is initiated. Please refer to the SSHCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSHCertStorePassword Property

SSHCertStorePassword Property (Sftp Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSHCertStoreType Property

SSHCertStoreType Property (Sftp Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSHCertSubject Property

SSHCertSubject Property (Sftp Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSHCertSubject is set to the full subject of the matching certificate.


SSHCompressionAlgorithms Property

SSHCompressionAlgorithms Property (Sftp Activity)

A comma-separated list of compression algorithms allowed for this connection.

Data Type

string

Default Value

"none"

Remarks

This list is used for both directions: client to server and server to client. When negotiating algorithms, each side sends a list of all algorithms it supports or allows. The algorithm chosen for each direction is the first algorithm to appear in the sender's list that the receiver supports, so it is important to list multiple algorithms in preferential order. If no algorithm can be agreed upon, the activity will raise an error and the connection will be aborted.

SSHCompressionAlgorithms must be set to a comma-separated list containing at least one of the following values:

zlib | Zlib compression is allowed for this connection.
none | No compression is allowed for this connection.


SSHHost Property

SSHHost Property (Sftp Activity)

The address of the SSH host.

Data Type

string

Default Value

""

Remarks

The SSHHost property specifies the IP address (IP number in dotted internet format) or Domain Name of the remote host. It is set before a connection is attempted and cannot be changed once a connection is established.

If the SSHHost property is set to a Domain Name, a DNS request is initiated, and upon successful termination of the request, the SSHHost property is set to the corresponding address. If the search is not successful, an error is logged.


SSHPassword Property

SSHPassword Property (Sftp Activity)

The password for SSH password-based authentication.

Data Type

string

Default Value

""

Remarks

SSHPassword specifies the password which is used to authenticate the client to the SSH server.


SSHPort Property

SSHPort Property (Sftp Activity)

The port on the SSH server where the SSH service is running; by default, 22.

Data Type

int

Default Value

22

Remarks

The SSHPort specifies a service port on the SSH host to connect to.


SSHUser Property

SSHUser Property (Sftp Activity)

The username for SSH authentication.

Data Type

string

Default Value

""

Remarks

SSHUser specifies the username which is used to authenticate the client to the SSH server. This property is required.


Timeout Property

Timeout Property (Sftp Activity)

A timeout for the activity.

Data Type

int

Default Value

60

Remarks

If the Timeout property is set to 0, all operations will run uninterrupted until successful completion, or an error condition is encountered.

If Timeout is set to a positive value, the activity will wait for the operation to complete before returning control.

If Timeout expires, and the operation is not yet complete, the activity fails with an error.

Please note that by default, all timeouts are inactivity timeouts, i.e. the timeout period is extended by Timeout seconds when data is successfully sent or received.

Optionally, the behavior of the activity may be changed to absolute timeouts, i.e. the activity will wait for a maximum of Timeout seconds since the beginning of the operation, without extending the timeout period during communications.

This behavior is controlled by the AbsoluteTimeout configuration setting.

The default value for the Timeout property is 60 (seconds).


Sftp Configuration

Configuration Settings (Sftp Activity)

The activity accepts one or more of the following configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

SFTP Configuration Settings

IgnoreFileMaskCasing: Instructs the activity to ignore casing of when FileMask is set.

By default the value of this setting is false. If set to true the activity will ignore case when matching a value to the FileMask.

MaxFileData: Specifies the maximum payload size of an SFTP packet.

While the SSH specification requires servers and clients to support SSH packets of at least 32000 bytes, some server implementations limit packet size to smaller values. MaxPayload provides a means by which the user can specify the maximum amount of data that can be put into an SFTP packet so that the activity can communicate effectively with these servers. If you are having difficulty when uploading to a server, try setting MaxPayload size to value smaller than 32000.

Most servers that use smaller values will use a maximum SSH packet size of 16KB (16384). In order to most efficiently communicate with such servers, MaxPayload size should be set to 14745.

RenameTo: Specifies the value to which a file will be renamed.

This can be set to any combination of macros and values. When used in conjunction with the receive adapter the file will be renamed instead of deleted as controlled by the DeleteMode property. When used in conjunction with the send adapter the file will always be renamed after a successful upload.

SSHAcceptServerHostKeyFingerPrint: Instructs the activity to accept the server's host key with this fingerprint.

This may be set to the 16-byte MD5 fingerprint of the host's key. You may supply it by HEX encoding the values in the form "0a:1b:2c:3d".

TemporaryDownloadExtension: An extension to be appended to the during download.

During download, it may be necessary for the file on the server to be renamed. After the download is complete the file will be renamed back to the original name.

TemporaryUploadExtension: An extension to be appended to the during upload.

During upload, it may be necessary for the RemoteFile to be written to a temporary file name. For example, some business process may be set up to expect a specific file extension. Using this setting will allow the activity to upload the file without the remainder of the process attempting to pick up the incomplete file.

General Configuration Settings

AbsoluteTimeout: Determines whether timeouts are inactivity timeouts or absolute timeouts.

If AbsoluteTimeout is set to True, any method which does not complete within Timeout seconds will be aborted. By default, AbsoluteTimeout is False, and the timeout is an inactivity timeout.

LocalHost: The name of the local host or user-assigned IP interface through which connections are initiated or accepted.

The LocalHost configuration contains the name of the local host as obtained by the Gethostname() system call, or if the user has assigned an IP address, the value of that address.

In multihomed hosts (machines with more than one IP interface) setting LocalHost to the value of an interface will make the activity initiate connections (or accept in the case of server activitys) only through that interface.

If the activity is connected, the LocalHost configuration shows the IP address of the interface through which the connection is made in internet dotted format (aaa.bbb.ccc.ddd). In most cases, this is the address of the local host, except for multihomed hosts (machines with more than one IP interface).


Smpp Activity

Properties Configuration Settings

The SMPP Activity implements Short Message Peer-to-Peer message transmission functionality.

Assembly

nsoftware.SharePoint.SMPPActivities.dll

Remarks

The SMPP Activity implements a Short Message Peer-to-Peer client that can be used to send SMS messages from your SharePoint site to any SMS-enabled entity.

SMPP Send Activity

Before using the SMPP Activity. you must first contact a Short Message Service (SMS) vendor to create an account. Once your account is properly set up, you must set the server information on your activity through the SMPPServer and SMPPPort properties. If your SMS vendor supplies you with a UserId or Password, you should enter those as well. Some vendors may also require specific SystemType values in order to communicate with a client. If this is the case, the vendor will supply you with that information as well.

The activity also supports Secure Socket Layer (SSL) transport security. This may be enabled by selecting an SSLCert and a valid SSLAcceptServerCert, and then setting the SSLStartMode to an appropriate value.

Once the send port is set up, it will connect to the SMPP server whenever it has a message to send. It will send the contents of the MessageText property as the text of the short message.

The activity allows you to send text messages to one or more RecipientAddress. You may also set the SendAsData property to send large (greater than 64KB) messages as binary data instead of as a text message.

Property List

The following is the full list of the properties of the activity with short descriptions. Click on the links for complete descriptions.

FirewallAutoDetect | Tells the activity whether or not to automatically detect and use firewall system settings, if available.
FirewallType | Determines the type of firewall to connect through.
FirewallHost | Name or IP address of firewall (optional).
FirewallPassword | A password if authentication is to be used when connecting through the firewall.
FirewallPort | The TCP port for the firewall Host .
FirewallUser | A user name if authentication is to be used connecting through a firewall.
LogMode | What information gets logged during activity execution.
MessageExpiration | Denotes the validity period of the current message.
MessagePriority | This is the priority level of the current message.
MessageText | The text of the short message to be sent.
Other | Defines a set of configuration settings to be used by the activity.
Password | This is the user's password.
RecipientAddress | A comma-separated list of the recipient addresses of the current short message.
RecipientType | Indicates the type of entities receiving the current short message.
ScheduledDelivery | This value tells the server when to deliver the current message.
SendAsData | A boolean switch indicating whether the current short message should be sent as a data message.
SenderAddress | The addresses from which the current short message will be sent.
ServiceType | This indicates the type of service for the current message.
SMPPPort | The server port for secure SMPP (default 3551).
SMPPServer | This is the SMPP entity to which the component will connect.
SMPPVersion | This is the SMPP version to be used throughout the connection.
SourceAddress | The source address of the current message.
SSLAcceptServerCertStore | The name of the certificate store for the client certificate.
SSLAcceptServerCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLAcceptServerCertStoreType | The type of certificate store for this certificate.
SSLAcceptServerCertSubject | The subject of the certificate used for client authentication.
SSLAcceptServerCertAcceptAny | Tells the activity to accept any server certificate.
SSLCertStore | The name of the certificate store for the client certificate.
SSLCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLCertStoreType | The type of certificate store for this certificate.
SSLCertSubject | The subject of the certificate used for client authentication.
SSLStartMode | Determines how the activity starts the SSL negotiation.
SystemType | This is a string representing the type of system during a connection.
Timeout | A timeout for the activity.
UserId | This value is used for identification with the SMPP service.
ValidityPeriod | The validity period of the current message.

Configuration Settings

The following is a list of configuration settings for the activity with short descriptions. Click on the links for complete descriptions.

DestinationTON | The Type of Number for the destination ESME
DestinationNPI | The Number Planning Indicator for the destination ESME
DataCoding | The data encoding mechanism to be used for the current message.
MCReceipt | The type of receipt you wish to receive for the current message.
ProtocolId | The protocol identifier
SMEAcknowledgement | The type of acknowledgement you wish to receive for the current message.
SourceNPI | The Number Planning Indicator for the ESME
SourceTON | The Type of Number for the ESME


FirewallAutoDetect Property

FirewallAutoDetect Property (Smpp Activity)

Tells the activity whether or not to automatically detect and use firewall system settings, if available.

Data Type

bool

Default Value

false

Remarks

Tells the activity whether or not to automatically detect and use firewall system settings, if available.


FirewallType Property

FirewallType Property (Smpp Activity)

Determines the type of firewall to connect through.

Possible Values

None(0)
Tunnel(1)
SOCKS4(2)
SOCKS5(3)

Data Type

string

Default Value

0

Remarks

Determines the type of firewall to connect through. The applicable values are the following:

fwNone (0) | No firewall (default setting).
fwTunnel (1) | Connect through a tunneling proxy. FirewallPort is set to 80.
fwSOCKS4 (2) | Connect through a SOCKS4 Proxy. FirewallPort is set to 1080.
fwSOCKS5 (3) | Connect through a SOCKS5 Proxy. FirewallPort is set to 1080.


FirewallHost Property

FirewallHost Property (Smpp Activity)

Name or IP address of firewall (optional).

Data Type

string

Default Value

""

Remarks

Name or IP address of firewall (optional). If a FirewallHost is given, requested connections will be authenticated through the specified firewall when connecting.

If the FirewallHost property is set to a Domain Name, a DNS request is initiated. Upon successful termination of the request, the FirewallHost property is set to the corresponding address. If the search is not successful, an error is returned.


FirewallPassword Property

FirewallPassword Property (Smpp Activity)

A password if authentication is to be used when connecting through the firewall.

Data Type

string

Default Value

""

Remarks

A password if authentication is to be used when connecting through the firewall. If FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given firewall. If the authentication fails, a trappable error is fired.


FirewallPort Property

FirewallPort Property (Smpp Activity)

The TCP port for the firewall Host .

Data Type

int

Default Value

0

Remarks

The TCP port for the firewall FirewallHost. See the description of the FirewallHost property for details.

Note that the FirewallPort is set automatically when FirewallFirewallType is set to a valid value. See the description of the FirewallFirewallType property for details.


FirewallUser Property

FirewallUser Property (Smpp Activity)

A user name if authentication is to be used connecting through a firewall.

Data Type

string

Default Value

""

Remarks

A user name if authentication is to be used connecting through a firewall. If the FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given Firewall. If the authentication fails, a trappable error is fired.


LogMode Property

LogMode Property (Smpp Activity)

What information gets logged during activity execution.

Possible Values

Verbose(0)
Debug(1)
Warning(2)
Error(3)
Fatal(4)

Data Type

string

Default Value

3

Remarks

This property controls what information the activity logs. The possible values have the following affect on the activity's behavior:

Verbose | The activity will report all information regarding the transport.
Debug | The activity will report all major operations, as well as all warnings and errors.
Warning | The activity will report any conditions that could result in unpredictable behavior as well as errors.
Error | The activity will report all errors that prevent normal operations from completing.
Fatal | The activity will report only serious errors that cause the activity to completely stop functioning.


MessageExpiration Property

MessageExpiration Property (Smpp Activity)

Denotes the validity period of the current message.

Data Type

string

Default Value

""

Remarks

The MessageExpiration property indicates the MC expiration time, after which the message should be discarded if not delivered to the destination. It can be set using absolute or relative time formats.

Absolute Time Format is a 16-character string represented as "YYMMDDhhmmsstnnp" where:

YY | the last two digits of the year (00-99)
MM | month (01-12)
DD | day (01-31)
hh | hour (00-23)
mm | minute (00-59)
ss | second (00-59)
t | tenths of a second (0-9)
nn | quarter-hour time difference between local time and UTC time (00-48)
p | "+" or "-" indicating the direction of the time offset in nn

Relative Time Format is the same 16-character string where "p" should be set to "R" for "relative". For relative time, "tnn" are ignored and thus should be set to a constant value of "000".


MessagePriority Property

MessagePriority Property (Smpp Activity)

This is the priority level of the current message.

Possible Values

MessagePriorityLow(0)
MessagePriorityNormal(1)
MessagePriorityHigh(2)
MessagePriorityUrgent(3)

Data Type

string

Default Value

0

Remarks

When sending a message, the MessagePriority property will tell the server what type of priority to assign to the message. The effect of the message priority setting is dependent upon the Message Center manufacturer and the network on which the target recipient lies. For example, some MCs may immediately forward "urgent" messages, some networks may use the priority setting as a visual indicator of the message's urgency (e.g. blinking icons, etc.), and some networks may entirely ignore the priority setting.


MessageText Property

MessageText Property (Smpp Activity)

The text of the short message to be sent.

Data Type

string

Default Value

""

Remarks

Normally, the activity will transmit the contents of the current WF collection as the message text. However, this behavior can be overridden by setting the MessageText property. If this property is present in the WF collection, its value will be sent as the message text.

This property is not available at design time.


Other Property

Other Property (Smpp Activity)

Defines a set of configuration settings to be used by the activity.

Data Type

string

Default Value

""

Remarks

The activity accepts one or more configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

The Other property should be set to list of name/value pairs separated by the '|' character, e.g:

configname1=value1|configname2=value2


Password Property

Password Property (Smpp Activity)

This is the user's password.

Data Type

string

Default Value

""

Remarks

When binding to the SMPPServer, the client must provide a known user id and a valid password for that id.


RecipientAddress Property

RecipientAddress Property (Smpp Activity)

A comma-separated list of the recipient addresses of the current short message.

Data Type

string

Default Value

""

Remarks

The RecipientAddress property can be used for setting single or multiple recipients. It is a comma-separated list of addresses whose format depends on the value of RecipientType.

For a recipient type of normal, the values in RecipientAddress should be either the dotted IPv4 of an SMS-enabled device or the directory number of a target mobile phone. For distributed lists, the value should be the name of the list as it is stored on the SMPPServer.


RecipientType Property

RecipientType Property (Smpp Activity)

Indicates the type of entities receiving the current short message.

Possible Values

RecipientTypeNormal(0)
RecipientTypeList(1)

Data Type

string

Default Value

0

Remarks

The RecipientType property is used only for multiple message recipients. The value of RecipientType determines the format of the values in RecipientAddress.

For a recipient type of normal, the values in RecipientAddress should be either the dotted IPv4 of an SMS-enabled device or the directory number of a target mobile phone. For distributed lists, the value should be the name of the list as it is stored on the SMPPServer.


ScheduledDelivery Property

ScheduledDelivery Property (Smpp Activity)

This value tells the server when to deliver the current message.

Data Type

string

Default Value

""

Remarks

ScheduledDelivery is used by the activity when sending a message to inform the Message Center (MC) to forward the message to the intended recipients at a specific time. It can be set using absolute or relative time formats.

Absolute Time Format is a 16-character string represented as "YYMMDDhhmmsstnnp" where:

YY | the last two digits of the year (00-99)
MM | month (01-12)
DD | day (01-31)
hh | hour (00-23)
mm | minute (00-59)
ss | second (00-59)
t | tenths of a second (0-9)
nn | quarter-hour time difference between local time and UTC time (00-48)
p | "+" or "-" indicating the direction of the time offset in nn

Relative Time Format is the same 16-character string where "p" should be set to "R" for "relative". For relative time, "tnn" are ignored and thus should be set to a constant value of "000".


SendAsData Property

SendAsData Property (Smpp Activity)

A boolean switch indicating whether the current short message should be sent as a data message.

Data Type

bool

Default Value

false

Remarks

Ordinarily, there is a size limit of 255 characters on the length of the message that can be sent. If SendAsData is set to true, a longer message of up to 64KB can be sent. Note that if multiple recipients are specified in RecipientAddress, the activity must issue separate requests for each address if SendAsData is true.


SenderAddress Property

SenderAddress Property (Smpp Activity)

The addresses from which the current short message will be sent.

Data Type

string

Default Value

""

Remarks

The SMPP protocol allows an External Short Messaging Entity (ESME) to specify its address, whether it is a phone number or an IP address. If SenderAddress is not set, it will default to the system's local IP address.


ServiceType Property

ServiceType Property (Smpp Activity)

This indicates the type of service for the current message.

Possible Values

ServiceDefault(0)
ServiceCMT(1)
ServiceCPT(2)
ServiceVMN(3)
ServiceVMA(4)
ServiceWAP(5)
ServiceUSSD(6)
ServiceCBS(7)

Data Type

string

Default Value

0

Remarks

When sending messages, the ServiceType property is used define the SMS application service to be associated with the message. The MC will use the value to determine the availability of enhanced messaging services and to control the teleservice used on the air interface.

The values are defined in the SMPP 5.0 specification as the following:

"" (NULL) | the MC default
CMT | Cellular Messaging
CPT | Cellular Paging
VMN | Voice Mail Notification
VMA | Voice Mail Alerting
WAP | Wireless Application Protocol
USSD | Unstructured Supplementary Services Data
CBS | Cell Broadcast Service


SMPPPort Property

SMPPPort Property (Smpp Activity)

The server port for secure SMPP (default 3551).

Data Type

int

Default Value

3551

Remarks

A valid port number (a value between 1 and 65535) is required for the connection to take place. For a plain text connection, use port 2775 (please refer to the SSLStartMode property for more information).


SMPPServer Property

SMPPServer Property (Smpp Activity)

This is the SMPP entity to which the component will connect.

Data Type

string

Default Value

""

Remarks

This is the instant messaging server to which the activity will connect. The SMPPServer property must contain a valid SMPP service application address.


SMPPVersion Property

SMPPVersion Property (Smpp Activity)

This is the SMPP version to be used throughout the connection.

Possible Values

Version50(0)
Version34(1)
Version33(2)

Data Type

string

Default Value

0

Remarks

Currently, the most widely used version of the SMPP protocol is version 3.4. However, since the newest version is 5.0, the default value for the activity is Version 50. The value is used by the activity when binding to the SMPPServer to indicate to the server which version of the protocol to use when interpreting commands received from the activity.

Changing the value will not limit the functionality of the activity when performing any operation, as each version of SMPP is backward compatible with previous implementations. However, if the SMPPServer does not recognize a particular command, it will respond with an error indicating that the PDU was erred. Which commands are recognizable is strictly dependent on the implementation of the server, and the adherence to protocol guidelines of that implementation.


SSLAcceptServerCertStore Property

SSLAcceptServerCertStore Property (Smpp Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLAcceptServerCertStoreType property specifies the type of the certificate store specified by SSLAcceptServerCertStore. If the store is password protected, specify the password in SSLAcceptServerCertStorePassword.

SSLAcceptServerCertStore is used in conjunction with the SSLAcceptServerCertSubject property in order to specify client certificates. If SSLAcceptServerCertStore has a value, and SSLAcceptServerCertSubject is set, a search for a certificate is initiated. Please refer to the SSLAcceptServerCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLAcceptServerCertStorePassword Property

SSLAcceptServerCertStorePassword Property (Smpp Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLAcceptServerCertStoreType Property

SSLAcceptServerCertStoreType Property (Smpp Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLAcceptServerCertSubject Property

SSLAcceptServerCertSubject Property (Smpp Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLAcceptServerCertSubject is set to the full subject of the matching certificate.


SSLAcceptServerCertAcceptAny Property

SSLAcceptServerCertAcceptAny Property (Smpp Activity)

Tells the activity to accept any server certificate.

Data Type

bool

Default Value

false

Remarks

When set to true, the activity will unilaterally authenticate any server during the security handshake. It is strongly recommended that you use this only for testing purposes.


SSLCertStore Property

SSLCertStore Property (Smpp Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLCertStoreType property specifies the type of the certificate store specified by SSLCertStore. If the store is password protected, specify the password in SSLCertStorePassword.

SSLCertStore is used in conjunction with the SSLCertSubject property in order to specify client certificates. If SSLCertStore has a value, and SSLCertSubject is set, a search for a certificate is initiated. Please refer to the SSLCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLCertStorePassword Property

SSLCertStorePassword Property (Smpp Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLCertStoreType Property

SSLCertStoreType Property (Smpp Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLCertSubject Property

SSLCertSubject Property (Smpp Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLCertSubject is set to the full subject of the matching certificate.


SSLStartMode Property

SSLStartMode Property (Smpp Activity)

Determines how the activity starts the SSL negotiation.

Possible Values

Automatic(0)
Implicit(1)
Explicit(2)
None(3)

Data Type

string

Default Value

0

Remarks

The SSLStartMode property may have one of the following values:

Automatic | If the remote port is set to the standard plaintext port of the protocol (where applicable), the activity will behave the same as if SSLStartMode is set to Explicit. In all other cases, SSL negotiation will be implicit (Implicit).
Implicit | The SSL negotiation will start immediately after the connection is established.
Explicit | The activity will first connect in plaintext, and then explicitly start SSL negotiation through a protocol command such as STARTTLS.
None | No SSL negotiation, no SSL security. All communication will be in plaintext mode.


SystemType Property

SystemType Property (Smpp Activity)

This is a string representing the type of system during a connection.

Data Type

string

Default Value

""

Remarks

Some SMS servers require that a system type be supplied during connection. The system type is a string representation, usually as an abbreviation, of a particular kind of system. The string cannot exceed 12 bytes.

Your SMPP service provider should supply you with the correct value for SystemType should they require it to be set.


Timeout Property

Timeout Property (Smpp Activity)

A timeout for the activity.

Data Type

int

Default Value

60

Remarks

If the Timeout property is set to 0, all operations will run uninterrupted until successful completion, or an error condition is encountered.

If Timeout is set to a positive value, the activity will wait for the operation to complete before returning control.

If Timeout expires, and the operation is not yet complete, the activity fails with an error.

Please note that by default, all timeouts are inactivity timeouts, i.e. the timeout period is extended by Timeout seconds when data is successfully sent or received.

Optionally, the behavior of the activity may be changed to absolute timeouts, i.e. the activity will wait for a maximum of Timeout seconds since the beginning of the operation, without extending the timeout period during communications.

This behavior is controlled by the AbsoluteTimeout configuration setting.

The default value for the Timeout property is 60 (seconds).


UserId Property

UserId Property (Smpp Activity)

This value is used for identification with the SMPP service.

Data Type

string

Default Value

""

Remarks

When binding to the SMPPServer, the client must provide a known user id and a valid password for that id.


Smpp Configuration

Configuration Settings (Smpp Activity)

The activity accepts one or more of the following configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

SMPP Configuration Settings

DestinationTON: The Type of Number for the destination ESME.

When sending messages, this value is used to indicate the Type of Number for the destination ESME. For a list of possible values, please see SourceTON.

DestinationNPI: The Number Planning Indicator for the destination ESME.

When sending messages, this value is used to indicate the numbering plan the destination ESME. For a list of possible values, please see SourceNPI.

DataCoding: The data encoding mechanism to be used for the current message.

This value informs the message recipient about how the data was encoded. The possible values are as follows:

0 | MC Specific encoding
1 | IA5 (CCITT T.50)/ASCII (ANSI X3.4)
2 | Octet unspecified (8-bit binary)
3 | Latin 1 (ISO-8859-1)
4 | Octet unspecified (8-bit binary)
5 | JIS (X 0208-1990)
6 | Cyrillic (ISO-8859-5)
7 | Latin/Hebrew (ISO-8859-8)
8 | UCS2 (ISO/IEC-10646)
9 | Pictogram Encoding
10 | ISO-2022-JP (Music Codes)
11 | Reserved
12 | Reserved 2
13 | Extended Kanji JIS (X 0212-1990)
14 | KS C 5601

MCReceipt: The type of receipt you wish to receive for the current message.

Setting this config property will cause the component to ask the SMSC for a message delivery receipt. The default value is None (0). The possible values are:

None (0) | The SMSC will send no notification.
Final (1) | The SMSC will only send a notification when the message has been delivered.
Failure (2) | The SMSC will only send a notification if the message encounters an error.
Success (3) | The SMSC will only send a notification when it has successfully received the message from the SME.

ProtocolId: The protocol identifier.

This config property allows control of the protocol identifier field value used in the outgoing messages.

SMEAcknowledgement: The type of acknowledgement you wish to receive for the current message.

Setting this config property will cause the component to ask the remote SME for a delivery acknowledgement. The default value is None (0). The possible values are:

None (0) | The SME need not acknowledge the message.
Delivery (1) | The SME should acknowledge when it has received the message.
Manual (2) | The SME should prompt a user to manually acknowledge the message, typically once they have read it.
Both (3) | The SME should perform both types of acknowledgement.

SourceNPI: The Number Planning Indicator for the ESME.

When binding, this value is used to specify the numbering plan of the ESME. Mobiles tend to set this value to 1. Since most ESMEs are mobiles, the default value for SourceNPI is 1. The possible value are:

Unknown (0)
ISDN (1)
Data (3)
Telex (4)
LandMobile (6)
National (8)
Private (9)
ERMES (10)
Internet (14)
WAP (18)

SourceTON: The Type of Number for the ESME.

When binding, this value is used to indicate the Type of Number for the ESME address. The possible values are:

Unknown (0) | The number type is unknown
International (1) | The number includes the international trunk prefix
National (2) | The number includes the national trunk prefix
NetworkSpecific (3) | The number exists on a network that uses a specific delivery protocol
SubscriberNumber (4) | The number is just the subscriber number, without prefixes
Alphanumeric (5) | The address is human-readable (contains letters and digits)
Abbreviated (6) | The number is abbreviated


Snpp Activity

Properties Configuration Settings

The SNPP Activity adds paging send functionality to your SharePoint site.

Assembly

nsoftware.SharePoint.SNPPActivities.dll

Remarks

The SNPP Activity implements a Simple Network Paging Protocol transmission client that can be used to send pages from your SharePoint site to any paging-enabled device.

SNPP Send Activity

The SNPP Send Activity requires that you set a ServerName and ServerPort to connect to. You must also specify the recipient's PagerId. There is an optional CallerId property that will identify a number for the recipient to call.

The activity also supports Secure Socket Layer (SSL) transport security. This may be enabled by selecting an SSLCert and a valid SSLAcceptServerCert, and then setting the SSLStartMode to an appropriate value.

The activity will send the contents of the MessageText property as the text of the short message.

Property List

The following is the full list of the properties of the activity with short descriptions. Click on the links for complete descriptions.

CallerId | The id of the caller.
FirewallAutoDetect | Tells the activity whether or not to automatically detect and use firewall system settings, if available.
FirewallType | Determines the type of firewall to connect through.
FirewallHost | Name or IP address of firewall (optional).
FirewallPassword | A password if authentication is to be used when connecting through the firewall.
FirewallPort | The TCP port for the firewall Host .
FirewallUser | A user name if authentication is to be used connecting through a firewall.
LogMode | What information gets logged during activity execution.
MessageText | The message being sent (alphanumeric).
Other | Defines a set of configuration settings to be used by the activity.
PagerId | The id number of the pager which will receive the current page message.
ServerName | The name or address of the SNPP server.
ServerPort | The server port for SNPP (default 444).
SSLAcceptServerCertStore | The name of the certificate store for the client certificate.
SSLAcceptServerCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLAcceptServerCertStoreType | The type of certificate store for this certificate.
SSLAcceptServerCertSubject | The subject of the certificate used for client authentication.
SSLAcceptServerCertAcceptAny | Tells the activity to accept any server certificate.
SSLCertStore | The name of the certificate store for the client certificate.
SSLCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLCertStoreType | The type of certificate store for this certificate.
SSLCertSubject | The subject of the certificate used for client authentication.
SSLStartMode | Determines how the activity starts the SSL negotiation.
Timeout | A timeout for the activity.

Configuration Settings

The following is a list of configuration settings for the activity with short descriptions. Click on the links for complete descriptions.

AbsoluteTimeout | Determines whether timeouts are inactivity timeouts or absolute timeouts.
LocalHost | The name of the local host or user-assigned IP interface through which connections are initiated or accepted.


CallerId Property

CallerId Property (Snpp Activity)

The id of the caller.

Data Type

string

Default Value

""

Remarks

This may also provide authentication to the SNPP server and may include other authentication information as requested by the server you are connecting to.


FirewallAutoDetect Property

FirewallAutoDetect Property (Snpp Activity)

Tells the activity whether or not to automatically detect and use firewall system settings, if available.

Data Type

bool

Default Value

false

Remarks

Tells the activity whether or not to automatically detect and use firewall system settings, if available.


FirewallType Property

FirewallType Property (Snpp Activity)

Determines the type of firewall to connect through.

Possible Values

None(0)
Tunnel(1)
SOCKS4(2)
SOCKS5(3)

Data Type

string

Default Value

0

Remarks

Determines the type of firewall to connect through. The applicable values are the following:

fwNone (0) | No firewall (default setting).
fwTunnel (1) | Connect through a tunneling proxy. FirewallPort is set to 80.
fwSOCKS4 (2) | Connect through a SOCKS4 Proxy. FirewallPort is set to 1080.
fwSOCKS5 (3) | Connect through a SOCKS5 Proxy. FirewallPort is set to 1080.


FirewallHost Property

FirewallHost Property (Snpp Activity)

Name or IP address of firewall (optional).

Data Type

string

Default Value

""

Remarks

Name or IP address of firewall (optional). If a FirewallHost is given, requested connections will be authenticated through the specified firewall when connecting.

If the FirewallHost property is set to a Domain Name, a DNS request is initiated. Upon successful termination of the request, the FirewallHost property is set to the corresponding address. If the search is not successful, an error is returned.


FirewallPassword Property

FirewallPassword Property (Snpp Activity)

A password if authentication is to be used when connecting through the firewall.

Data Type

string

Default Value

""

Remarks

A password if authentication is to be used when connecting through the firewall. If FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given firewall. If the authentication fails, a trappable error is fired.


FirewallPort Property

FirewallPort Property (Snpp Activity)

The TCP port for the firewall Host .

Data Type

int

Default Value

0

Remarks

The TCP port for the firewall FirewallHost. See the description of the FirewallHost property for details.

Note that the FirewallPort is set automatically when FirewallFirewallType is set to a valid value. See the description of the FirewallFirewallType property for details.


FirewallUser Property

FirewallUser Property (Snpp Activity)

A user name if authentication is to be used connecting through a firewall.

Data Type

string

Default Value

""

Remarks

A user name if authentication is to be used connecting through a firewall. If the FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given Firewall. If the authentication fails, a trappable error is fired.


LogMode Property

LogMode Property (Snpp Activity)

What information gets logged during activity execution.

Possible Values

Verbose(0)
Debug(1)
Warning(2)
Error(3)
Fatal(4)

Data Type

string

Default Value

3

Remarks

This property controls what information the activity logs. The possible values have the following affect on the activity's behavior:

Verbose | The activity will report all information regarding the transport.
Debug | The activity will report all major operations, as well as all warnings and errors.
Warning | The activity will report any conditions that could result in unpredictable behavior as well as errors.
Error | The activity will report all errors that prevent normal operations from completing.
Fatal | The activity will report only serious errors that cause the activity to completely stop functioning.


MessageText Property

MessageText Property (Snpp Activity)

The message being sent (alphanumeric).

Data Type

string

Default Value

""

Remarks

The message can be a single a line or split over multiple lines depending on what the restrictions of the receiving device and gateway. Normally messages are no longer than 100 bytes long.

Normally, the activity will transmit the contents of the current WF collection as the message text. However, this behavior can be overridden by setting the MessageText property. If this property is present in the WF collection, its value will be sent as the message text.


Other Property

Other Property (Snpp Activity)

Defines a set of configuration settings to be used by the activity.

Data Type

string

Default Value

""

Remarks

The activity accepts one or more configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

The Other property should be set to list of name/value pairs separated by the '|' character, e.g:

configname1=value1|configname2=value2


PagerId Property

PagerId Property (Snpp Activity)

The id number of the pager which will receive the current page message.

Data Type

string

Default Value

""

Remarks

Additional information such as a password or a PIN may be appended to the PagerId depending upon server requirements.


ServerName Property

ServerName Property (Snpp Activity)

The name or address of the SNPP server.

Data Type

string

Default Value

""

Remarks

The ServerName property specifies the IP address (IP number in dotted internet format) or Domain Name of the SNPP server.


ServerPort Property

ServerPort Property (Snpp Activity)

The server port for SNPP (default 444).

Data Type

int

Default Value

444

Remarks

A valid port number (a value between 1 and 65535) is required for the connection to take place.


SSLAcceptServerCertStore Property

SSLAcceptServerCertStore Property (Snpp Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLAcceptServerCertStoreType property specifies the type of the certificate store specified by SSLAcceptServerCertStore. If the store is password protected, specify the password in SSLAcceptServerCertStorePassword.

SSLAcceptServerCertStore is used in conjunction with the SSLAcceptServerCertSubject property in order to specify client certificates. If SSLAcceptServerCertStore has a value, and SSLAcceptServerCertSubject is set, a search for a certificate is initiated. Please refer to the SSLAcceptServerCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLAcceptServerCertStorePassword Property

SSLAcceptServerCertStorePassword Property (Snpp Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLAcceptServerCertStoreType Property

SSLAcceptServerCertStoreType Property (Snpp Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLAcceptServerCertSubject Property

SSLAcceptServerCertSubject Property (Snpp Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLAcceptServerCertSubject is set to the full subject of the matching certificate.


SSLAcceptServerCertAcceptAny Property

SSLAcceptServerCertAcceptAny Property (Snpp Activity)

Tells the activity to accept any server certificate.

Data Type

bool

Default Value

false

Remarks

When set to true, the activity will unilaterally authenticate any server during the security handshake. It is strongly recommended that you use this only for testing purposes.


SSLCertStore Property

SSLCertStore Property (Snpp Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLCertStoreType property specifies the type of the certificate store specified by SSLCertStore. If the store is password protected, specify the password in SSLCertStorePassword.

SSLCertStore is used in conjunction with the SSLCertSubject property in order to specify client certificates. If SSLCertStore has a value, and SSLCertSubject is set, a search for a certificate is initiated. Please refer to the SSLCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLCertStorePassword Property

SSLCertStorePassword Property (Snpp Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLCertStoreType Property

SSLCertStoreType Property (Snpp Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLCertSubject Property

SSLCertSubject Property (Snpp Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLCertSubject is set to the full subject of the matching certificate.


SSLStartMode Property

SSLStartMode Property (Snpp Activity)

Determines how the activity starts the SSL negotiation.

Possible Values

Automatic(0)
Implicit(1)
Explicit(2)
None(3)

Data Type

string

Default Value

0

Remarks

The SSLStartMode property may have one of the following values:

Automatic | If the remote port is set to the standard plaintext port of the protocol (where applicable), the activity will behave the same as if SSLStartMode is set to Explicit. In all other cases, SSL negotiation will be implicit (Implicit).
Implicit | The SSL negotiation will start immediately after the connection is established.
Explicit | The activity will first connect in plaintext, and then explicitly start SSL negotiation through a protocol command such as STARTTLS.
None | No SSL negotiation, no SSL security. All communication will be in plaintext mode.


Timeout Property

Timeout Property (Snpp Activity)

A timeout for the activity.

Data Type

int

Default Value

60

Remarks

If the Timeout property is set to 0, all operations will run uninterrupted until successful completion, or an error condition is encountered.

If Timeout is set to a positive value, the activity will wait for the operation to complete before returning control.

If Timeout expires, and the operation is not yet complete, the activity fails with an error.

Please note that by default, all timeouts are inactivity timeouts, i.e. the timeout period is extended by Timeout seconds when data is successfully sent or received.

Optionally, the behavior of the activity may be changed to absolute timeouts, i.e. the activity will wait for a maximum of Timeout seconds since the beginning of the operation, without extending the timeout period during communications.

This behavior is controlled by the AbsoluteTimeout configuration setting.

The default value for the Timeout property is 60 (seconds).


Snpp Configuration

Configuration Settings (Snpp Activity)

The activity accepts one or more of the following configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

SNPP Configuration Settings

General Configuration Settings

AbsoluteTimeout: Determines whether timeouts are inactivity timeouts or absolute timeouts.

If AbsoluteTimeout is set to True, any method which does not complete within Timeout seconds will be aborted. By default, AbsoluteTimeout is False, and the timeout is an inactivity timeout.

LocalHost: The name of the local host or user-assigned IP interface through which connections are initiated or accepted.

The LocalHost configuration contains the name of the local host as obtained by the Gethostname() system call, or if the user has assigned an IP address, the value of that address.

In multihomed hosts (machines with more than one IP interface) setting LocalHost to the value of an interface will make the activity initiate connections (or accept in the case of server activitys) only through that interface.

If the activity is connected, the LocalHost configuration shows the IP address of the interface through which the connection is made in internet dotted format (aaa.bbb.ccc.ddd). In most cases, this is the address of the local host, except for multihomed hosts (machines with more than one IP interface).


Xmpp Activity

Properties Configuration Settings

The XMPP Activity adds instant messaging functionality to your SharePoint site.

Assembly

nsoftware.SharePoint.XMPPActivities.dll

Remarks

eXtensible Messaging and Presence Protocol is a highly extensible instant message service based on XML packets. The XMPP activity adds the capability to leverage this protocol within your SharePoint site to send instant messages to any XMPP client within your XMPP service's network.

XMPP Send Activity

The XMPP Send Activity implements a lightweight XMPP instant messaging client. At a minimum, you must supply an IMServer, IMPort for the connection and a ToJID for the intended recipient of the message.

The activity will send the contents of the MessageText property as the instant message body

The activity also supports sending HTML entities with the message via the MessageHTML property. The default behavior of sending the SharePoint site message contents as a simple text message can also be overridden via the TreatAsHTML property. Also, when sending to clients that may not support reading HTML entities, ParseHTML can be set to cause the activity to parse an HTML entity into the simple text body of the instant message.

The XMPP Send Activity has support for SSL transport layer security. This may be enabled by setting SSLStartMode, SSLCert and SSLAcceptServerCert to appropriate values.

Property List

The following is the full list of the properties of the activity with short descriptions. Click on the links for complete descriptions.

FirewallAutoDetect | Tells the activity whether or not to automatically detect and use firewall system settings, if available.
FirewallType | Determines the type of firewall to connect through.
FirewallHost | Name or IP address of firewall (optional).
FirewallPassword | A password if authentication is to be used when connecting through the firewall.
FirewallPort | The TCP port for the firewall Host .
FirewallUser | A user name if authentication is to be used connecting through a firewall.
IMPort | The server port for XMPP (default 5222).
IMServer | This is the instant messaging server.
LogMode | What information gets logged during activity execution.
MessageHTML | This is the HTML version of the current message.
MessageSubject | This is the subject of the current message.
MessageText | This is the plain text of the current message.
MessageThread | This is the thread name of the current message.
MessageType | This is the type of the current message.
Other | Defines a set of configuration settings to be used by the activity.
Password | This is the user's password.
Resource | This is the resource for the current session.
SSLAcceptServerCertStore | The name of the certificate store for the client certificate.
SSLAcceptServerCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLAcceptServerCertStoreType | The type of certificate store for this certificate.
SSLAcceptServerCertSubject | The subject of the certificate used for client authentication.
SSLAcceptServerCertAcceptAny | Tells the activity to accept any server certificate.
SSLCertStore | The name of the certificate store for the client certificate.
SSLCertStorePassword | If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.
SSLCertStoreType | The type of certificate store for this certificate.
SSLCertSubject | The subject of the certificate used for client authentication.
SSLStartMode | Determines how the activity starts the SSL negotiation.
Timeout | A timeout for the activity.
ToJID | A semicolon-separated list of destination nodes to receive the current message.
User | The user portion of this entity's Jabber ID.

Configuration Settings

The following is a list of configuration settings for the activity with short descriptions. Click on the links for complete descriptions.

AuthDomain | The domain under which the must authenticate.
ParseHTML | Tells the activity to parse into a plaintext representation.
ServerDomain | This is the domain of the XMPP service.
TreatAsHTML | Tells the activity to treat the message contents as HTML.
UserDomain | The domain under which the has registered with the XMPP service.


FirewallAutoDetect Property

FirewallAutoDetect Property (Xmpp Activity)

Tells the activity whether or not to automatically detect and use firewall system settings, if available.

Data Type

bool

Default Value

false

Remarks

Tells the activity whether or not to automatically detect and use firewall system settings, if available.


FirewallType Property

FirewallType Property (Xmpp Activity)

Determines the type of firewall to connect through.

Possible Values

None(0)
Tunnel(1)
SOCKS4(2)
SOCKS5(3)

Data Type

string

Default Value

0

Remarks

Determines the type of firewall to connect through. The applicable values are the following:

fwNone (0) | No firewall (default setting).
fwTunnel (1) | Connect through a tunneling proxy. FirewallPort is set to 80.
fwSOCKS4 (2) | Connect through a SOCKS4 Proxy. FirewallPort is set to 1080.
fwSOCKS5 (3) | Connect through a SOCKS5 Proxy. FirewallPort is set to 1080.


FirewallHost Property

FirewallHost Property (Xmpp Activity)

Name or IP address of firewall (optional).

Data Type

string

Default Value

""

Remarks

Name or IP address of firewall (optional). If a FirewallHost is given, requested connections will be authenticated through the specified firewall when connecting.

If the FirewallHost property is set to a Domain Name, a DNS request is initiated. Upon successful termination of the request, the FirewallHost property is set to the corresponding address. If the search is not successful, an error is returned.


FirewallPassword Property

FirewallPassword Property (Xmpp Activity)

A password if authentication is to be used when connecting through the firewall.

Data Type

string

Default Value

""

Remarks

A password if authentication is to be used when connecting through the firewall. If FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given firewall. If the authentication fails, a trappable error is fired.


FirewallPort Property

FirewallPort Property (Xmpp Activity)

The TCP port for the firewall Host .

Data Type

int

Default Value

0

Remarks

The TCP port for the firewall FirewallHost. See the description of the FirewallHost property for details.

Note that the FirewallPort is set automatically when FirewallFirewallType is set to a valid value. See the description of the FirewallFirewallType property for details.


FirewallUser Property

FirewallUser Property (Xmpp Activity)

A user name if authentication is to be used connecting through a firewall.

Data Type

string

Default Value

""

Remarks

A user name if authentication is to be used connecting through a firewall. If the FirewallHost is specified, the FirewallUser and FirewallPassword properties are used to connect and authenticate to the given Firewall. If the authentication fails, a trappable error is fired.


IMPort Property

IMPort Property (Xmpp Activity)

The server port for XMPP (default 5222).

Data Type

int

Default Value

5222

Remarks

A valid port number (a value between 1 and 65535) is required for the connection to take place. For an implicit SSL connection, use port 5223 (please refer to the SSLStartMode property for more information).


IMServer Property

IMServer Property (Xmpp Activity)

This is the instant messaging server.

Data Type

string

Default Value

""

Remarks

This is the instant messaging server to which the activity will connect. The IMServer property must contain a valid XMPP (Jabber) server, or any attempt to connect to the server will fail.


LogMode Property

LogMode Property (Xmpp Activity)

What information gets logged during activity execution.

Possible Values

Verbose(0)
Debug(1)
Warning(2)
Error(3)
Fatal(4)

Data Type

string

Default Value

3

Remarks

This property controls what information the activity logs. The possible values have the following affect on the activity's behavior:

Verbose | The activity will report all information regarding the transport.
Debug | The activity will report all major operations, as well as all warnings and errors.
Warning | The activity will report any conditions that could result in unpredictable behavior as well as errors.
Error | The activity will report all errors that prevent normal operations from completing.
Fatal | The activity will report only serious errors that cause the activity to completely stop functioning.


MessageHTML Property

MessageHTML Property (Xmpp Activity)

This is the HTML version of the current message.

Data Type

string

Default Value

""

Remarks

If the user wishes to send an HTML entity as a part of the message, it must be set in the MessageHTML property. The HTML must be an entire HTML document, including the <html> and <body> tags.

If TreatAsHTML is set to True, and MessageHTML is not set, the contents of the message will be treated as the HTML entity. If ParseHTML is set to True, the HTML entity will be parsed and its textual contents sent in the <body> element. This behavior will be overridden if any value is found in MessageText.

Note: if the HTML entity does not conform to a strict XML structure (e.g., has unbalanced tags), the XMPP activity will fail with an error.


MessageSubject Property

MessageSubject Property (Xmpp Activity)

This is the subject of the current message.

Data Type

string

Default Value

""

Remarks

MessageSubject will contain any subject associated with the message. Most Jabber clients will ignore the subject unless the MessageType is set to "Headline".


MessageText Property

MessageText Property (Xmpp Activity)

This is the plain text of the current message.

Data Type

string

Default Value

""

Remarks

MessageText is the plain text version of the current message, contained in the message XML's "body" child element. The text in this property is automatically escaped to ensure valid XML parsing by the recipient.

By default, the contents of the current message are sent in the <body/> element of the XMPP instant message. If MessageText contains a value, it will be used in place of the message contents. However, this behavior can be controlled by TreatAsHTML, which will treat the BizTalk message contents as an HTML entity.


MessageThread Property

MessageThread Property (Xmpp Activity)

This is the thread name of the current message.

Data Type

string

Default Value

""

Remarks

MessageThread will contain the name of the thread associated with the message. Threads are useful for tracking messages where the MessageType is "Chat" or "Group Chat".

This property is not available at design time.


MessageType Property

MessageType Property (Xmpp Activity)

This is the type of the current message.

Possible Values

Normal(0)
Chat(1)
GroupChat(2)
Headline(3)
Error(4)

Data Type

string

Default Value

0

Remarks

MessageType is the type of the message as specified in the XMPP RFC. The possible values are defined in the protocol specification as follows:

Normal | A single message.
Chat | A message sent in the context of two-way chat between two entities.
Group Chat | A message sent in the context of multi-user chat among multiple entities.
Headline | A message that represents one of a list of items (e.g., in a news feed or information ticker).
Error | A message returned to a sender specifying an error associated with a previous message sent by the sender to an intended recipient.


Other Property

Other Property (Xmpp Activity)

Defines a set of configuration settings to be used by the activity.

Data Type

string

Default Value

""

Remarks

The activity accepts one or more configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

The Other property should be set to list of name/value pairs separated by the '|' character, e.g:

configname1=value1|configname2=value2


Password Property

Password Property (Xmpp Activity)

This is the user's password.

Data Type

string

Default Value

""

Remarks

This must be set before a connection is attempted.


Resource Property

Resource Property (Xmpp Activity)

This is the resource for the current session.

Data Type

string

Default Value

"IP*Works! XMPP Agent"

Remarks

Whenever an entity logs in to an XMPP (Jabber) server, it must provide account information as well as a resource. Resources allow multiple clients to log in using the same account. The server will forward all messages and PI data aimed at a specific resource to that resource. If a command or message is to be sent to a Jabber ID with no specified resource, the server will push that command or message out to all connected resources.


SSLAcceptServerCertStore Property

SSLAcceptServerCertStore Property (Xmpp Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLAcceptServerCertStoreType property specifies the type of the certificate store specified by SSLAcceptServerCertStore. If the store is password protected, specify the password in SSLAcceptServerCertStorePassword.

SSLAcceptServerCertStore is used in conjunction with the SSLAcceptServerCertSubject property in order to specify client certificates. If SSLAcceptServerCertStore has a value, and SSLAcceptServerCertSubject is set, a search for a certificate is initiated. Please refer to the SSLAcceptServerCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLAcceptServerCertStorePassword Property

SSLAcceptServerCertStorePassword Property (Xmpp Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLAcceptServerCertStoreType Property

SSLAcceptServerCertStoreType Property (Xmpp Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLAcceptServerCertSubject Property

SSLAcceptServerCertSubject Property (Xmpp Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLAcceptServerCertSubject is set to the full subject of the matching certificate.


SSLAcceptServerCertAcceptAny Property

SSLAcceptServerCertAcceptAny Property (Xmpp Activity)

Tells the activity to accept any server certificate.

Data Type

bool

Default Value

false

Remarks

When set to true, the activity will unilaterally authenticate any server during the security handshake. It is strongly recommended that you use this only for testing purposes.


SSLCertStore Property

SSLCertStore Property (Xmpp Activity)

The name of the certificate store for the client certificate.

Data Type

byte[]

Default Value

Converter.GetPlatformBytes("MY")

Remarks

The name of the certificate store for the client certificate.

The SSLCertStoreType property specifies the type of the certificate store specified by SSLCertStore. If the store is password protected, specify the password in SSLCertStorePassword.

SSLCertStore is used in conjunction with the SSLCertSubject property in order to specify client certificates. If SSLCertStore has a value, and SSLCertSubject is set, a search for a certificate is initiated. Please refer to the SSLCertSubject property for details.

Designations of certificate stores are platform-dependent.

The following are designations of the most common User and Machine certificate stores in Windows:

MY | A certificate store holding personal certificates with their associated private keys.
CA | Certifying authority certificates.
ROOT | Root certificates.
SPC | Software publisher certificates.

In Java, the certificate store normally is a file containing certificates and optional private keys.

When the certificate store type is PFXFile, this property must be set to the name of the file. When the type is PFXBlob, the property must be set to the binary contents of a PFX file (i.e. PKCS12 certificate store).

If the provider is OpenSSL, the certificate store is a file containing a certificate and a private key. This property must be set to the name of the file.


SSLCertStorePassword Property

SSLCertStorePassword Property (Xmpp Activity)

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.

Data Type

string

Default Value

""

Remarks

If the certificate store is of a type that requires a password, this property is used to specify that password in order to open the certificate store.


SSLCertStoreType Property

SSLCertStoreType Property (Xmpp Activity)

The type of certificate store for this certificate.

Possible Values

User(0)
Machine(1)
PFXFile(2)
PFXBlob(3)
JKSFile(4)
JKSBlob(5)
PEMKeyFile(6)
PEMKeyBlob(7)
PublicKeyFile(8)
PublicKeyBlob(9)
SSHPublicKey(10)

Data Type

string

Default Value

0

Remarks

The type of certificate store for this certificate.

This property can take one of the following values:

0 (cstUser - default) | For Windows, this specifies that the certificate store is a certificate store owned by the current user. Note: this store type is not available in Java.
1 (cstMachine) | For Windows, this specifies that the certificate store is a machine store. Note: this store type is not available in Java.
2 (cstPFXFile) | The certificate store is the name of a PFX (PKCS12) file containing certificates. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
3 (cstPFXBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in PFX (PKCS12) format. Note: this functionality is only available on mobile devices with Windows CE 5.0 or later.
4 (cstJKSFile) | The certificate store is the name of a Java Key Store (JKS) file containing certificates. Note: this store type is not available in Windows. This is the default store type in Java.
5 (cstJKSBlob) | The certificate store is a string (binary or base64-encoded) representing a certificate store in Java Key Store (JKS) format. Note: this store type is not available in Windows.
6 (cstPEMKeyFile) | The certificate store is the name of a PEM-encoded file that contains a private key and an optional certificate.
7 (cstPEMKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a private key and an optional certificate.
8 (cstPublicKeyFile) | The certificate store is the name of a file that contains a PEM- or DER-encoded public key certificate.
9 (cstPublicKeyBlob) | The certificate store is a string (binary or base64-encoded) that contains a PEM- or DER-encoded public key certificate.
10 (cstSSHPublicKey) | The certificate store is a string (binary or base64-encoded) that contains an SSH-style public key.


SSLCertSubject Property

SSLCertSubject Property (Xmpp Activity)

The subject of the certificate used for client authentication.

Data Type

string

Default Value

""

Remarks

The subject of the certificate used for client authentication.

When this property is set, a search is performed in the current certificate store certificate with matching subject.

If an exact match is not found, the store is searched for subjects containing the value of the property.

When setting the property to a partial subject, CN= should be omitted. For example, the following code would find the certificate with subject CN=Test Certificate, OU=People, C=US

Example (Searching with partial subject)

Control.CertSubject = "Test"

If a match is not found, the property is set to an empty string, and no certificate is selected.

The special value "*" picks a random certificate in the certificate store.

If a matching certificate is found, SSLCertSubject is set to the full subject of the matching certificate.


SSLStartMode Property

SSLStartMode Property (Xmpp Activity)

Determines how the activity starts the SSL negotiation.

Possible Values

Automatic(0)
Implicit(1)
Explicit(2)
None(3)

Data Type

string

Default Value

0

Remarks

The SSLStartMode property may have one of the following values:

Automatic | If the remote port is set to the standard plaintext port of the protocol (where applicable), the activity will behave the same as if SSLStartMode is set to Explicit. In all other cases, SSL negotiation will be implicit (Implicit).
Implicit | The SSL negotiation will start immediately after the connection is established.
Explicit | The activity will first connect in plaintext, and then explicitly start SSL negotiation through a protocol command such as STARTTLS.
None | No SSL negotiation, no SSL security. All communication will be in plaintext mode.


Timeout Property

Timeout Property (Xmpp Activity)

A timeout for the activity.

Data Type

int

Default Value

60

Remarks

If the Timeout property is set to 0, all operations will run uninterrupted until successful completion, or an error condition is encountered.

If Timeout is set to a positive value, the activity will wait for the operation to complete before returning control.

If Timeout expires, and the operation is not yet complete, the activity fails with an error.

Please note that by default, all timeouts are inactivity timeouts, i.e. the timeout period is extended by Timeout seconds when data is successfully sent or received.

Optionally, the behavior of the activity may be changed to absolute timeouts, i.e. the activity will wait for a maximum of Timeout seconds since the beginning of the operation, without extending the timeout period during communications.

This behavior is controlled by the AbsoluteTimeout configuration setting.

The default value for the Timeout property is 60 (seconds).


ToJID Property

ToJID Property (Xmpp Activity)

A semicolon-separated list of destination nodes to receive the current message.

Data Type

string

Default Value

""

Remarks

ToJID should contain a semicolon-separated list of complete Jabber IDs in the form "User@Domain/Resource".


User Property

User Property (Xmpp Activity)

The user portion of this entity's Jabber ID.

Data Type

string

Default Value

""

Remarks

The User property is a unique username associated with this entity and set at time of registration under the field "user".


Xmpp Configuration

Configuration Settings (Xmpp Activity)

The activity accepts one or more of the following configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

XMPP Configuration Settings

AuthDomain: The domain under which the must authenticate.

This is the domain under which the current XMPP User must authenticate when logging onto the IMServer. It should be set if the domain is different than UserDomain or ServerDomain.

ParseHTML: Tells the activity to parse into a plaintext representation.

If ParseHTML is set to True, MessageHTML will be parsed and its textual contents sent in the <body> element. This behavior will be overridden if any value is found in MessageText.

ServerDomain: This is the domain of the XMPP service.

This is the domain under which the XMPP service operates. This should be set if the service domain is different than the host address or DNS name supplied in IMServer.

TreatAsHTML: Tells the activity to treat the message contents as HTML.

If TreatAsHTML is set to True, and MessageHTML is not set, the contents of the message will be treated as an HTML entity. If ParseHTML is set to True, the HTML entity will be parsed and its textual contents sent in the <body> element. This behavior will be overridden if any value is found in MessageText.

UserDomain: The domain under which the has registered with the XMPP service.

This is the domain under which the current XMPP User has register with the XMPP service. This should be set if the User's registration domain was different from the server domain.


Zip Activity

Properties Configuration Settings

The Zip activity implements a PKZip-compatible Zip compressor and decompressor.

Assembly

nsoftware.SharePoint.ZipActivities.dll

Remarks

The Zip activity is used when compressing files in SharePoint that are associated with items. The activity uses the Deflate algorithm specified in RFC 1951 for compression, and produces output compatible with PKZip, WinZip, etc.

Zip Assembler Activity

The Assembler takes a file from an item as input which contains raw data, and generates a Zip archive file as output. The ".zip" extension will be added to the existing file name.

Compression strength is regulated by the CompressionLevel property. You may also control encryption behavior by setting the Password and EncryptionAlgorithm properties on this activity.

An item must be specified by setting the UsesCurrentItem attribute for the action if using SharePoint Designer or the WorkflowProperties property if using Visual Studio.

Property List

The following is the full list of the properties of the activity with short descriptions. Click on the links for complete descriptions.

CompressionLevel | The compression level to use.
EncryptionAlgorithm | The algorithm used to encrypt a WF collection when written to the archive.
ExcludedFiles | A list of files to exclude.
ExtractToPath | A base path to decompress to.
FileMask | Specifies which files the activity should include when extracting.
LogMode | What information gets logged during activity execution.
Operation | The operation which will be executed by the ZIP task.
Other | Defines a set of configuration settings to be used by the activity.
OverwriteFiles | Whether or not to overwrite files.
Password | A password for the zip file.
ZipComment | The comment for the entire zip file.

Configuration Settings

The following is a list of configuration settings for the activity with short descriptions. Click on the links for complete descriptions.


CompressionLevel Property

CompressionLevel Property (Zip Activity)

The compression level to use.

Data Type

int

Default Value

4

Remarks

This property specifies the level of compression to be used, between 0 and 6. Higher values will cause the activity to compress better; lower values will cause the activity to compress faster. A value of 0 will store the file without compression.


EncryptionAlgorithm Property

EncryptionAlgorithm Property (Zip Activity)

The algorithm used to encrypt a WF collection when written to the archive.

Possible Values

Default(0)
AESWeak(1)
AESStrong(2)
AESMaximum(3)

Data Type

string

Default Value

0

Remarks

The algorithm used to encrypt each file written to the archive.

Note that the Password property must be set in order for the activity to encrypt files. By default the activity will use standard zip encryption if Password is set, and will not encrypt data otherwise.

The activity supports the use of AES, the Advanced Encryption Standard, as well as standard Zip encryption. The default encryption algorithm is the algorithm introduced in version 2.0 of the Zip specification, and is compatible with virtually all other zip utilities. However, this algorithm is considered weak and should not be used to protect sensitive data.

AES is a U.S. government standard cleared to protect even the most sensitive data. The file format used to create AES-encrypted files is designed to be compatible with WinZip 9.0. AES-encrypted files created by the activity may or may not be compatible with other Zip utilities.

The activity supports the use of AES with key lengths of 128, 192, or 256 bits. Note that even with the weakest (128-bit) keys, AES is much more secure than standard Zip encryption.

If you use strong or maximum AES encryption, the activity will generate a unique salt value and cryptographic key for each file encrypted. If you use weak encryption the activity will use the same salt for each file in the archive. If you are encrypting a large number of files, this will have a substantial effect on performance.

If using AES encryption it is important to choose a good Password. For 128-bit keys it is recommended that your password be 32 characters long, and for 256-bit keys, 64 characters.

Important: Note that AES encryption only encrypts the contents of encrypted files within the Zip archive; it does not prevent an attacker from reading the names of files in the archive, or from adding or deleting files to or from the archive. To prevent this consider first storing your files in an unencrypted zip file, and then storing this zipped file in another, AES-encrypted zip file.

Property values:

eaDefault | 0
eaAESWeak | 1
eaAESStrong | 2
etAESMaximum | 3


ExcludedFiles Property

ExcludedFiles Property (Zip Activity)

A list of files to exclude.

Data Type

string

Default Value

""

Remarks

This property specifies files that should be excluded when compressing or extracting a file. When either compression or extraction occurs, each file will be compared to ExcludedFiles, and each file that matches will be excluded.

This property may be set to one or more file names. These file names may be specified with or without a path, and with or without wildcards. If a path is specified, files in the indicated extraction directory will be excluded. If no path is specified but wildcards are, matching files in all directories will be excluded. If a single file name without a path is specified, it must correspond exactly to the appropriate value of a valid file name.

Directories should end with a slash ("/" or "\", as appropriate.) If a directory is specified, all files and subdirectories in the specified directory will be excluded during extraction.

A pipe character ("|") should be used to separate multiple file or directory names.

If the property is set to the empty string, no files will be excluded.


LogMode Property

LogMode Property (Zip Activity)

What information gets logged during activity execution.

Possible Values

Verbose(0)
Debug(1)
Warning(2)
Error(3)
Fatal(4)

Data Type

string

Default Value

3

Remarks

This property controls what information the activity logs. The possible values have the following affect on the activity's behavior:

Verbose | The activity will report all information regarding the transport.
Debug | The activity will report all major operations, as well as all warnings and errors.
Warning | The activity will report any conditions that could result in unpredictable behavior as well as errors.
Error | The activity will report all errors that prevent normal operations from completing.
Fatal | The activity will report only serious errors that cause the activity to completely stop functioning.


Other Property

Other Property (Zip Activity)

Defines a set of configuration settings to be used by the activity.

Data Type

string

Default Value

""

Remarks

The activity accepts one or more configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.

The Other property should be set to a line separated list of name/value pairs, e.g:

configname1=value1
configname2=value2


Password Property

Password Property (Zip Activity)

A password for the zip file.

Data Type

string

Default Value

""

Remarks

This property specifies the case-sensitive password used to encrypt or decrypt the archive file. If set to an empty string, no password is used.


ZipComment Property

ZipComment Property (Zip Activity)

The comment for the entire zip file.

Data Type

string

Default Value

""

Remarks

Specifies a global comment for the zip file. Set this property to include a comment in each zipped file the activity creates.


Zip Configuration

Configuration Settings (Zip Activity)

The activity accepts one or more of the following configuration settings. Configuration settings are similar in functionality to properties, but they are rarely used. In order to avoid "polluting" the property namespace of the activity, access to these internal properties is provided through the Other property.


Copyright & Licensing

IMPORTANT: PLEASE READ THE FOLLOWING CAREFULLY.

THE FOLLOWING IS A SOFTWARE LICENSE RELATED TO YOUR USE OF THE /N SOFTWARE INC. SHAREPOINT EXTENSIONS AND RELATED DOCUMENTATION (THE "LICENSED SOFTWARE"). BY CLICKING ON THE "YES" BUTTON OF THE INSTALL PROGRAM, OR BY OPENING THE PACKAGE CONTAINING THE CDs, YOU ARE CONSENTING TO BE BOUND BY THIS LICENSE AGREEMENT, AND THE TERMS SHALL BE BINDING WITH RESPECT TO YOUR USE OF THE LICENSED SOFTWARE. IF YOU DO NOT AGREE TO ALL THE TERMS OF THIS AGREEMENT, CLICK ON THE "NO" BUTTON, AND THE INSTALLATION PROCESS WILL CEASE, OR IF YOU HAVE RECEIVED SOFTWARE ON CDs, THEN RETURN THE PRODUCT TO THE PLACE OF PURCHASE.

/N SOFTWARE INC. - SHAREPOINT EXTENSIONS SOFTWARE LICENSE

1. LICENSE. In consideration of your payment of applicable license fees, /n software inc. ("/n software") hereby grants to you, the undersigned, and you accept, a nonexclusive, nontransferable license to install, use, and display a single copy of the Licensed Software on a single computer. You may move the Licensed Software from one computer to another, but may not have the Licensed Software resident on more than one computer unless you have paid a license for each additional computer. You may use the Licensed Software for the purpose of developing your own software applications, in accordance with the terms of Section 2, below. A copy of the Licensed Software may be made for archival or backup purposes as long as it contains all the original Licensed Software proprietary notices. You may not sublicense, rent, distribute, lease or otherwise transfer or assign any or all of your rights in the Licensed Software. You may not distribute the Licensed Software as a stand-alone product. You may use the Licensed Software solely in its original form, and may not change, alter or modify the Licensed Software, translate, reverse assemble, reverse compile, disassemble, or in any way reverse engineer the Licensed Software. This license does not grant you any right to bug, fixes, enhancements, updates or new versions, but if such are made available to and are obtained by you, then they shall become part of the Licensed Software and governed by the terms of this License. /n software reserves all rights not expressly granted to you in this License.

2. CREATING APPLICATIONS. Your rights to create and distribute your own software applications that use the Licensed Software as a runtime component ("Applications") differ based on the designation of the product licensing option you have purchased:

2(a). ROYALTY-FREE LICENSES. If the product option you have purchased is marked as a "ROYALTY-FREE" license the following terms apply:

You may freely distribute your own Applications that use Licensed Software as a runtime component without payment to /n software, if and only if the Licensed Software used by such Applications is not marked as a Free Trial or Demo Version, and the Applications: (a) contain no modifications to the Licensed Software (including alterations to the original proprietary notices); and (b) are in compiled, executable form; and (c) do not provide substantially the same functionality as the Licensed Software or have as one of their purposes to build other software that would compete with the Licensed Software; and (d) do not reproduce or distribute any portion of the documentation for the Licensed Software or document the Applications in a manner that identifies the programmatic interface to the callable routines in the Licensed Software; and (e) are subject to a license agreement that (i)limits Applications end-users use of the Licensed Software to a run-time component, (ii) restricts the Applications end-user from changing, altering or modifying the Licensed Software, creating derivative works, translations, reverse assembling, reverse compiling, disassembling, or in any way reverse engineering the Licensed Software, and (iii) prevents the Applications end-user from sublicensing, renting, distributing, leasing or otherwise transferring or assigning any portion of the Licensed Software other than as specifically permitted in this Section 2, you may not create any derivative works of the Licensed Software.

2(b). SINGLE MACHINE LICENSES. If the product option you have purchased is marked as a "SINGLE SERVER" or "SINGLE MACHINE" license, the following terms apply: you may deploy Applications that use the Licensed Software as a runtime component, if and only if the Licensed Software is licensed for all computers where the Applications are deployed and appropriate licensing fees are paid to /n software for each machine the Licensed Software is installed on. The Licensed Software must be distributed with no modifications and no alterations of any kind, including alterations to the original proprietary notices.

2(c). SINGLE CPU LICENSES. If the product option you have purchased is marked as a "SINGLE CPU" or "PER CPU" license, the following terms apply: you may deploy Applications that use the Licensed Software as a runtime component, if and only if the Licensed Software is licensed for each processor (CPU) in all computers where the Applications are deployed and appropriate licensing fees are paid to /n software for each CPU the Licensed Software is deployed on. The Licensed Software must be distributed with no modifications and no alterations of any kind, including alterations to the original proprietary notices.

2(d). SITE LICENSES. If the product option you have purchased is marked as a "SITE LICENSE", the following terms apply: you may create Applications that use the Licensed Software as a runtime component and freely distribute such Applications within the limits of a Physical Address (Building) hosting one company or other business entity (the "SITE"). All other distribution conditions specified in 2(a) also apply in this case.

2(e). ENTERPRISE LICENSES. If the product option you have purchased is marked as an "ENTERPRISE LICENSE", the following terms apply: you may create Applications that use the Licensed Software as a runtime component and freely distribute such Applications within the limits of one company or other business entity (the "ENTERPRISE"). All other distribution conditions specified in 2(a) also apply in this case.

2(f). HUB LICENSES. If the product option you have purchased is marked as a "HUB LICENSE", the following terms apply: you may create Applications that use the Licensed Software as a runtime component and freely distribute such applications as long as the Licensed Software is restricted to communicate only with a single designated server ("HUB"). The HUB may use the Licensed Software to communicate with all instances of the Licensed Software distributed according to the terms of this License. All other distribution conditions specified in 2(a) also apply in this case.

2(g). TRIAL OR EVALUATION LICENSES. If the product you have downloaded or otherwise obtained is marked as "TRIAL SOFTWARE" or "EVALUATION COPY", the following terms apply: you may install one copy of the Licensed Software for development of testing purposes for a period of 30 calendar days from the date of installation ("Evaluation Time"). Upon expiration of the Evaluation Time, the Licensed Software must be erased from the computer it was installed on and all copies destroyed. Under no circumstances should trial software be used for commercial purposes. Trial software may contain mechanisms that inhibit its ability to function at a later date. It is your responsibility to ensure that any Applications you create do not use trial software as a runtime component and their ability to function at a later date is not inhibited or diminished.

3. RIGHTS IN LICENSED SOFTWARE. You acknowledge that the Licensed Software and any copies, regardless of the form or media in which the original or copies may exist, are the sole and exclusive property of /n software; by accepting this License, you do not become the owner of the Licensed Software recorded on the media. You further acknowledge that the Licensed Software, including the code, logic and structure of the Licensed Software, contain valuable trade secrets belonging to /n software. You agree to secure and protect the Licensed Software consistent with the maintenance of /n software's rights in the Licensed Software, as set forth in this License. You agree that /n software can use the information provided during the purchase of the Licensed Software to deliver and confirm your purchase, in the marketing or promotion of the Licensed Software, or for other relevant purposes, as well as contact you again about other products, services, or offers.

4. THIRD PARTIES. You acknowledge and agree that the Licensed Software may be used to connect to or integrate with software and other technology owned and controlled by third parties. In order to connect to or integrate with any and all other such third party software or technology you may be subject to a license agreement with that third party. You acknowledge and agree that you will look solely to the applicable third party and not to /n software to enforce any of your rights with regard to such third party software or technology.

5. COPIES. The Licensed Software is copyrighted under the laws of the United States and international treaty provisions. Notwithstanding the copyright, the Licensed Software contains trade secrets and confidential information of /n software. You agree not to disclose or otherwise make available any part of the Licensed Software to any third party on any basis, other than as set forth in Section 2. You agree not to make any copies of the documentation that is provided in hard copy as part of the Licensed Software.

6. TERM. This License shall be perpetual unless you fail to observe any of its terms, in which case it shall terminate immediately, and without additional prior notice, provided, however, that copies of the run-time component of the Licensed Software that are part of the Applications licensed to third parties may be retained by such licensed third parties in accordance with this Agreement. Upon termination or expiration of this Agreement, you shall return the original and all copies, complete or partial, of the Licensed Software to /n software, and shall not access such media for the purpose of recovering any of the Licensed Software from any copies that may exist with respect to media containing regular backups of your computer or computer system. The terms of Sections 3, 4, 5, 7, 8, 9, 10 and 11 shall survive termination of this Agreement.

7. DISCLAIMER OF WARRANTY. THE LICENSED SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. FURTHER, /N SOFTWARE SPECIFICALLY DOES NOT WARRANT, GUARANTEE, OR MAKE ANY REPRESENTATIONS REGARDING THE USE, OR THE RESULTS OF THE USE, OF THE LICENSED SOFTWARE OR WRITTEN MATERIALS IN TERMS OF CORRECTNESS, ACCURACY, RELIABILITY, CURRENTNESS, OR OTHERWISE. THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF THE SOFTWARE IS ASSUMED BY YOU. NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY /N SOFTWARE OR ITS EMPLOYEES SHALL CREATE A WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THIS WARRANTY, AND YOU MAY NOT RELY ON ANY SUCH INFORMATION OR ADVICE.

8. LIMITATION ON LIABILITY. The Licensed Software may produce inaccurate results because of a failure or inaccuracy in the performance of the software, because you input incorrect data, or for many other reasons. You assume full and sole responsibility for any use you make of the output from the Licensed Software, and you bear the entire risks of there being an error in the output. You agree that regardless of the cause of any error or the form of any claim, YOUR SOLE REMEDY AND /N SOFTWARE'S SOLE OBLIGATION SHALL BE GOVERNED BY THIS AGREEMENT AND IN NO EVENT SHALL /N SOFTWARE'S LIABILITY EXCEED THE PRICE PAID TO /N SOFTWARE FOR THE LICENSED SOFTWARE. YOU EXPRESSLY AGREE THAT IN NO EVENT SHALL /N SOFTWARE BE LIABLE FOR ANY CONSEQUENTIAL, INCIDENTAL OR SPECIAL DAMAGES ARISING FROM THIRD PARTY SOFTWARE OR TECHNOLOGY, BREACH OF WARRANTY, BREACH OF CONTRACT, NEGLIGENCE, OR ANY OTHER LEGAL THEORY, WHETHER IN TORT OR CONTRACT, EVEN IF /N SOFTWARE HAS BEEN APPRAISED OF THE LIKELIHOOD OF SUCH DAMAGES OCCURRING, INCLUDING WITHOUT LIMITATION DAMAGES FROM INTERRUPTION OF BUSINESS, LOSS OF USE OF SOFTWARE, LOSS OF DATA, COST OF RECREATING DATA, COST OF CAPITAL, COST OF ANY SUBSTITUTE SOFTWARE, OR LOSSES CAUSED BY DELAY. /n software shall not be responsible for any damages or expenses resulting from alteration or unauthorized use of the Licensed Software, or from the unintended and unforeseen results obtained by you resulting from such use.

9. INDEMNIFICATION. You hereby agree to indemnify /n software and its officers, directors, employees, agents, and representatives from each and every demand, claim, loss, liability, or damage of any kind, including actual attorneys fees, whether in tort or contract, that it or any of them may incur by reason of, or arising out of, any claim which is made by any third party with respect any breach or violation of this Agreement by you or any claims based on the Applications and the Licensed Software included therein.

10. U.S. GOVERNMENT RESTRICTED RIGHTS. The Licensed Software is Commercial Computer Software provided with RESTRICTED RIGHTS under Federal Acquisition Regulations and agency supplements to them. Use, duplication or disclosure by the U.S. Government is subject to restrictions as set forth in subsection (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at DFAR 255.227-7013 et. seq. or 252.211-7015, or subsections (a) through (d) of the Commercial Computer Software Restricted Rights at FAR 52.227-19, as applicable, or similar clauses in the NASA FAR Supplement. Contractor/manufacturer is /n software inc., PO Box 13821, Research Triangle Park, NC 27709.

11. EXPORT CONTROLS. None of the Licensed Software, or underlying information may be exported, directly or indirectly, without the prior written consent, if required, by the office of Export Administration of the United States, Department of Commerce, nor to any country to which the U.S. has embargoed goods, to any person on the U.S. Treasury Department's list of Specially Designated Nations or the U.S. Commerce Department's Table of Denials. By consenting to this License you warrant that you are not located in, under the control of, or a national or resident of any such country or appear on any such list and further warrant that you will not distribute the run-time version of the Licensed Software to any entity that is located in, under the control of, or a national or resident of any such country or appears on any such list.

12. ENTIRE AGREEMENT. YOU ACKNOWLEDGE THAT YOU HAVE READ THIS LICENSE, UNDERSTAND IT, AND AGREE TO BE BOUND BY ITS TERMS AND CONDITIONS. YOU ALSO AGREE THAT THIS LICENSE IS THE COMPLETE AND EXCLUSIVE STATEMENT OF THE AGREEMENT BETWEEN /N SOFTWARE AND YOU, WHICH SUPERSEDES ANY PROPOSAL, PRIOR AGREEMENT, OR LICENSE, ORAL OR WRITTEN, AND ANY OTHER COMMUNICATIONS RELATING TO THE SUBJECT MATTER OF THIS LICENSE. This License shall be construed in accordance with the internal laws of North Carolina and all disputes shall have exclusive venue in the federal and state courts in Durham County, North Carolina, and both parties consent to the jurisdiction of these courts. If any term of this License shall be found invalid, the term shall be modified or omitted to the extent necessary, and the remainder of the License shall continue in full effect.


Delete Property

Delete Property (Email Activity)

Controls if the email is deleted after download.

Data Type

bool

Default Value

false

Remarks

If this property is set to True, each email is deleted from the server after download.


DeleteMode Property

DeleteMode Property (Email Activity)

Controls if and when the email is deleted after download.

Possible Values

Never(0)
OnSuccess(1)
OnFailure(2)
Always(3)

Data Type

string

Default Value

0

Remarks

This property informs the activity as to whether or not it should delete a email from the server after a successful download. The possible values and their meanings are as follows:

Never | The email is never deleted.
OnSuccess | The email is deleted after a successful download.
OnFailure | The email is deleted if the transfer fails.
Always | The email is deleted regardless of success or failure of the transfer.

Note: the default value is Never for data protection purposes. Unless modified, this will result in the activity continuously receiving the same data.


Filter Property

Filter Property (Email Activity)

A filter to be applied to the inbox when selecting messages.

Data Type

string

Default Value

""

Remarks

If this value is set, the activity will use it to filter out which messages to download from the server. The activity will apply the filter as a search string, and then download all messages in the message set returned by the server.

Note: this property is only valid for the stIMAP ServerType.

The exact format of the filter criteria is specified by the IMAP RFCs. The string consists of one or more search keys and their corresponding values (if any) separated by spaces, for example: "SINCE 1-Feb-1994 NOT FROM Smith".

Possible search keys include:

<message set> | Messages with message sequence numbers corresponding to the specified message sequence number set
ALL | All messages in the mailbox - this is the default initial key for AND-ing.
ANSWERED | Messages with the \Answered flag set.
BCC <string> | Messages that contain the specified string in the envelope structure's BCC field.
BEFORE <date> | Messages whose internal date is earlier than the specified date.
BODY <string> | Messages that contain the specified string in the body of the message.
CC <string> | Messages that contain the specified string in the envelope structure's CC field.
DELETED | Messages with the \Deleted flag set.
DRAFT | Messages with the \Draft flag set.
FLAGGED | Messages with the \Flagged flag set.
FROM <string> | Messages that contain the specified string in the envelope structure's FROM field.
HEADER <field-name> <string> | Messages that have a header with the specified field-name (as defined in [RFC-822]) and that contains the specified string in the [RFC-822] field-body.
KEYWORD <flag> | Messages with the specified keyword set.
LARGER <n> | Messages with an RFC822.SIZE larger than the specified number of octets.
NEW | Messages that have the \Recent flag set but not the \Seen flag. This is functionally equivalent to "(RECENT UNSEEN)".
NOT <search-key> | Messages that do not match the specified search key.
OLD | Messages that do not have the \Recent flag set. This is functionally equivalent to "NOT RECENT" (as opposed to "NOT NEW").
ON <date> | Messages whose internal date is within the specified date.
OR <search-key1> <search-key2> | Messages that match either search key.
RECENT | Messages that have the \Recent flag set.
SEEN | Messages that have the \Seen flag set.
SENTBEFORE <date> | Messages whose [RFC-822] Date: header is earlier than the specified date.
SENTON <date> | Messages whose [RFC-822] Date: header is within the specified date.
SENTSINCE <date> | Messages whose [RFC-822] Date: header is within or later than the specified date.
SINCE <date> | Messages whose internal date is within or later than the specified date.
SMALLER <n> | Messages with an RFC822.SIZE smaller than the specified number of octets.
SUBJECT <string> | Messages that contain the specified string in the envelope structure's SUBJECT field.
TEXT <string> | Messages that contain the specified string in the header or body of the message.
TO <string> | Messages that contain the specified string in the envelope structure's TO field.
UID <message set> | Messages with unique identifiers corresponding to the specified unique identifier set.
UNANSWERED | Messages that do not have the \Answered flag set.
UNDELETED | Messages that do not have the \Deleted flag set.
UNDRAFT | Messages that do not have the \Draft flag set.
UNFLAGGED | Messages that do not have the \Flagged flag set.
UNKEYWORD <flag> | Messages that do not have the specified keyword set.
UNSEEN | Messages that do not have the \Seen flag set.


IncludeHeaders Property

IncludeHeaders Property (Email Activity)

Instructs the activity to include or ignore message headers.

Data Type

bool

Default Value

false

Remarks

If IncludeHeaders is set to True, the activity will include any headers retrieved from the server in the message. This is useful for PassThrough configurations and for orchestrations that use MIME decoding message pipelines.

Note: regardless of the value of this property, there will be a "MessageHeaders" field of MessageList that contains a string with the full RFC-822 encoded original headers as retrieved from the server. This is useful for situations where it is necessary to find specific mail headers.


MailFolder Property

MailFolder Property (Email Activity)

Name of the mailbox selected on the server.

Data Type

string

Default Value

"Inbox"

Remarks

This property tells the activity which mailbox folder to check for messages when logging into an IMAP email account.

Note: this property is only valid when ServerType is set to IMAP.


MailPort Property

MailPort Property (Email Activity)

The port of the mail server (IMAP or POP3).

Data Type

int

Default Value

0

Remarks

A valid port number (a value between 1 and 65535) is required for the connection to take place. The property must be set before a connection is established by the activity

For IMAP, the default ports are 143 for a plaintext connection and 993 for an implicit SSL connection. For POP3, the default ports are 110 and 995 respectively.


MailServer Property

MailServer Property (Email Activity)

The name or address of the mail server (IMAP or POP3).

Data Type

string

Default Value

""

Remarks

The MailServer property specifies the IP address (IP number in dotted internet format) or Domain Name of the mail server.


MessageCc Property

MessageCc Property (Email Activity)

A comma separated list of addresses for carbon copies.

Data Type

string

Default Value

""

Remarks

The MessageCc property will contain the list of address for carbon copies of the message returned by the server.


MessageDate Property

MessageDate Property (Email Activity)

The date a message was sent.

Data Type

string

Default Value

""

Remarks

The MessageDate property will contain the date/time stamp of when the message returned by the server was sent.


MessageFrom Property

MessageFrom Property (Email Activity)

The email address of the sender.

Data Type

string

Default Value

""

Remarks

This property will contain the email address of the sender of the message that was retrieved from the server.


MessageId Property

MessageId Property (Email Activity)

The id of the current message.

Data Type

string

Default Value

""

Remarks

MessageId contains the Id of the message that was retrieved from the server.


MessageSize Property

MessageSize Property (Email Activity)

The size of the current message.

Data Type

int

Default Value

0

Remarks

This property specifies the size of the message that was retrieved from the server.


MessageSubject Property

MessageSubject Property (Email Activity)

The subject of the mail message.

Data Type

string

Default Value

""

Remarks

This property will contain the subject of the message that was retrieved from the server.


MessageTo Property

MessageTo Property (Email Activity)

A comma separated list of addresses for destinations.

Data Type

string

Default Value

""

Remarks

MessageTo will contain a comma separated list of addresses for destinations that was retrieved from the server for the current message.


ServerType Property

ServerType Property (Email Activity)

The type of server for your email account.

Possible Values

IMAP(0)
POP3(1)

Data Type

string

Default Value

0

Remarks

This represents the type of server from which the activity will download emails.


AfterGet Property

AfterGet Property (Ftp Activity)

A set of FTP commands to be executed after the GET.

Data Type

string

Default Value

""

Remarks

AfterGet is a script that is executed immediately following each successful FTP GET operation.

The script may contain any number of standard FTP commands.

Each line in the script is treated as a single command. By default, if the activity encounters any errors while executing a command, it will log the error message and will continue to process the script. This behavior can be turned off by inserting "ONERROR FAIL" at any point in the script, which will cause the script to terminate on error but will not interrupt the normal operation of the activity. The default behavior can be restored at any point in the script by inserting the line "ONERROR RESUME".

Valid additional scripting commands are listed below:

cd Path | Change the remote directory to the specified path.
del Filename | Delete the specified file from the remote server.
mkdir Directory | Create the specified remote directory on the server.
rn Filename NewFilename | Rename the remote file specified by Filename to the NewFilename.
move Filename NewFilename | Move the remote file located at Filename to the NewFilename.
rm Filename | Remove the specified file from the remote server.
rmdir Directory | Remove the remote directory from the server.


BeforeGet Property

BeforeGet Property (Ftp Activity)

A set of FTP commands to be executed before the GET.

Data Type

string

Default Value

""

Remarks

BeforeGet is a script that is executed immediately before each successful FTP GET operation.

The script may contain any number of standard FTP commands.

Each line in the script is treated as a single command. By default, if the activity encounters any errors while executing a command, it will log the error message and will continue to process the script. This behavior can be turned off by inserting "ONERROR FAIL" at any point in the script, which will cause the script to terminate on error but will not interrupt the normal operation of the activity. The default behavior can be restored at any point in the script by inserting the line "ONERROR RESUME".

Valid additional scripting commands are listed below:

cd Path | Change the remote directory to the specified path.
del Filename | Delete the specified file from the remote server.
mkdir Directory | Create the specified remote directory on the server.
rn Filename NewFilename | Rename the remote file specified by Filename to the NewFilename.
move Filename NewFilename | Move the remote file located at Filename to the NewFilename.
rm Filename | Remove the specified file from the remote server.
rmdir Directory | Remove the remote directory from the server.


Delete Property

Delete Property (Ftp Activity)

Controls if the remote file is deleted after download.

Data Type

bool

Default Value

false

Remarks

If this property is set to True, each file is deleted from the server after download.


DeleteMode Property

DeleteMode Property (Ftp Activity)

Controls if and when the remote file is deleted after download.

Possible Values

Never(0)
OnSuccess(1)
OnFailure(2)
Always(3)

Data Type

string

Default Value

0

Remarks

This property informs the activity as to whether or not it should delete a remote files from the server after a successful download. The possible values and their meanings are as follows:

Never | The remote file is never deleted.
OnSuccess | The remote file is deleted after a successful download.
OnFailure | The remote file is deleted if the transfer fails.
Always | The remote file is deleted regardless of success or failure of the transfer.

Note: the default value is Never for data protection purposes. Unless modified this will result in the activity continuously receiving the same data.


FileMask Property

FileMask Property (Ftp Activity)

Indicates the type of files to download from the FTP server.

Data Type

string

Default Value

"*.*"

Remarks

This property will limit what kinds of files the activity will download from the server. Only files matching the pattern specified in FileMask will be retrieved.


LocalDirectory Property

LocalDirectory Property (Ftp Activity)

The directory on the local machine to write downloaded files to.

Data Type

string

Default Value

""

Remarks

This property tells the activity where to write all downloaded files to on the local machine. The downloaded files will be written to the remote file name in the specified directory.


Operation Property

Operation Property (Ftp Activity)

The operation which will be executed by the FTP task.

Possible Values

ReceiveFiles(0)
ListDirectory(1)
DeleteFiles(2)

Data Type

string

Default Value

0

Remarks

There are three different operations that the FTP Receive activity may perform. It may download files, ask the server to return a directory listing, or delete files.

The default for this property is to receive files.


ReceivedFileDate Property

ReceivedFileDate Property (Ftp Activity)

The date of the remote file received by the FTP activity.

Data Type

string

Default Value

""

Remarks

This value contains the date of the remote file being received by the FTP activity.


ReceivedFileName Property

ReceivedFileName Property (Ftp Activity)

The name of the remote file received by the FTP activity.

Data Type

string

Default Value

""

Remarks

This is the filename returned by the server.


ReceivedFileSize Property

ReceivedFileSize Property (Ftp Activity)

The size of the remote file received by the FTP activity.

Data Type

long

Default Value

0

Remarks

This value contains the size of the remote file being received by the FTP activity.


ReceivedFileUser Property

ReceivedFileUser Property (Ftp Activity)

The user name used to by the FTP activity when downloading the remote file.

Data Type

string

Default Value

""

Remarks

This property contains the value of the User used by the FTP activity to authenticate before downloading the remote file.


LocalDirectory Property

LocalDirectory Property (S3 Activity)

The directory on the local machine to write downloaded objects to.

Data Type

string

Default Value

""

Remarks

This property tells the activity where to write all downloaded objects to on the local machine. The downloaded objects will be written to the remote object name in the specified directory.


ObjectMask Property

ObjectMask Property (S3 Activity)

Indicates the type of files to download from the S3 server.

Data Type

string

Default Value

"*"

Remarks

This property will limit what kinds of objects the activity will download from the server. Only objects matching the pattern specified in ObjectMask will be retrieved.

NOTE: This property also specifies which objects and buckets will be listed when the Operation is set to ListObjects or ListBuckets.


Operation Property

Operation Property (S3 Activity)

The operation which will be executed by the S3 task.

Possible Values

ReceiveObject(0)
ListObjects(1)
ListBuckets(2)

Data Type

string

Default Value

0

Remarks

There are three different operations that the S3 Receive activity may perform. It may download objects, ask the server to return an object listing, or ask the server to return a bucket listing.

The default for this property is to receive an object.


Overwrite Property

Overwrite Property (S3 Activity)

Whether or not the activity should overwrite files during transfer.

Data Type

bool

Default Value

false

Remarks

This property is a value indicating whether or not the activity should overwrite downloaded files. If Overwrite is false, an error will be thrown whenever the file exists before a download operation.


ReceivedObjectDate Property

ReceivedObjectDate Property (S3 Activity)

The date of the remote object received by the S3 activity.

Data Type

string

Default Value

""

Remarks

This value contains the date of the remote object being received by the S3 activity.


ReceivedObjectName Property

ReceivedObjectName Property (S3 Activity)

The name of the remote object received by the S3 activity.

Data Type

string

Default Value

""

Remarks

This is the object name returned by the server.


ReceivedObjectSize Property

ReceivedObjectSize Property (S3 Activity)

The size of the remote object received by the S3 activity.

Data Type

long

Default Value

0

Remarks

This value contains the size of the remote file being received by the S3 activity.


AfterGet Property

AfterGet Property (Sftp Activity)

A set of FTP-style commands to be executed after the download.

Data Type

string

Default Value

""

Remarks

AfterGet is a script that is executed immediately following each successful download operation.

Each line in the script is treated as a single command. By default, if the activity encounters any errors while executing a command, it will log the error message and will continue to process the script. This behavior can be turned off by inserting "ONERROR FAIL" at any point in the script, which will cause the script to terminate on error but will not interrupt the normal operation of the activity. The default behavior can be restored at any point in the script by inserting the line "ONERROR RESUME".

Valid additional scripting commands are listed below:

cd Path | Change the remote directory to the specified path.
del Filename | Delete the specified file from the remote server.
mkdir Directory | Create the specified remote directory on the server.
rn Filename NewFilename | Rename the remote file specified by Filename to the NewFilename.
move Filename NewFilename | Move the remote file located at Filename to the NewFilename.
rm Filename | Remove the specified file from the remote server.
rmdir Directory | Remove the remote directory from the server.


BeforeGet Property

BeforeGet Property (Sftp Activity)

A set of FTP-style commands to be executed before the download.

Data Type

string

Default Value

""

Remarks

BeforeGet is a script that is executed immediately before each download operation.

Each line in the script is treated as a single command. By default, if the activity encounters any errors while executing a command, it will log the error message and will continue to process the script. This behavior can be turned off by inserting "ONERROR FAIL" at any point in the script, which will cause the script to terminate on error but will not interrupt the normal operation of the activity. The default behavior can be restored at any point in the script by inserting the line "ONERROR RESUME".

Valid additional scripting commands are listed below:

cd Path | Change the remote directory to the specified path.
del Filename | Delete the specified file from the remote server.
mkdir Directory | Create the specified remote directory on the server.
rn Filename NewFilename | Rename the remote file specified by Filename to the NewFilename.
move Filename NewFilename | Move the remote file located at Filename to the NewFilename.
rm Filename | Remove the specified file from the remote server.
rmdir Directory | Remove the remote directory from the server.


Delete Property

Delete Property (Sftp Activity)

Controls if the remote file is deleted after download.

Data Type

bool

Default Value

false

Remarks

If this property is set to True, each file is deleted from the server after download.


DeleteMode Property

DeleteMode Property (Sftp Activity)

Controls if and when the remote file is deleted after download.

Possible Values

Never(0)
OnSuccess(1)
OnFailure(2)
Always(3)

Data Type

string

Default Value

0

Remarks

This property informs the activity as to whether or not it should delete a remote files from the server after a successful download. The possible values and their meanings are as follows:

Never | The remote file is never deleted.
OnSuccess | The remote file is deleted after a successful download.
OnFailure | The remote file is deleted if the transfer fails.
Always | The remote file is deleted regardless of success or failure of the transfer.

Note: the default value is Never for data protection purposes. Unless modified this will result in the activity continuously receiving the same data.


FileMask Property

FileMask Property (Sftp Activity)

Indicates the type of files to download from the FTP server.

Data Type

string

Default Value

"*.*"

Remarks

This property will limit what kinds of files the activity will download from the server. Only files matching the pattern specified in FileMask will be retrieved.


LocalDirectory Property

LocalDirectory Property (Sftp Activity)

The directory on the local machine to write downloaded files to.

Data Type

string

Default Value

""

Remarks

This property tells the activity where to write all downloaded files to on the local machine. The downloaded files will be written to the remote file name in the specified directory.


Operation Property

Operation Property (Sftp Activity)

The operation which will be executed by the FTP task.

Possible Values

ReceiveFiles(0)
ListDirectory(1)
DeleteFiles(2)

Data Type

string

Default Value

0

Remarks

There are three different operations that the FTP Receive activity may perform. It may download files, ask the server to return a directory listing, or delete files.

The default for this property is to receive files.


ReceivedFileDate Property

ReceivedFileDate Property (Sftp Activity)

The date of the remote file received by the SFTP activity.

Data Type

string

Default Value

""

Remarks

This value contains the date of the remote file being received by the FTP activity.


ReceivedFileName Property

ReceivedFileName Property (Sftp Activity)

The name of the remote file received by the SFTP activity.

Data Type

string

Default Value

""

Remarks

This is the filename returned by the server.


ReceivedFileSize Property

ReceivedFileSize Property (Sftp Activity)

The size of the remote file received by the SFTP activity.

Data Type

long

Default Value

0

Remarks

This value contains the size of the remote file being received by the FTP activity.


ReceivedFileSSHUser Property

ReceivedFileSSHUser Property (Sftp Activity)

The SSH user name used to by the SFTP activity when downloading the remote file.

Data Type

string

Default Value

""

Remarks

This value contains the SSHUser used by the SFTP activity to authenticate before downloading the remote file.


SourceAddress Property

SourceAddress Property (Smpp Activity)

The source address of the current message.

Data Type

string

Default Value

""

Remarks

The SourceAddress is the address of the originator of the message.


ValidityPeriod Property

ValidityPeriod Property (Smpp Activity)

The validity period of the current message.

Data Type

string

Default Value

""

Remarks

The ValidityPeriod is only applicable if this short message is being forwarded to another MC. When this occurs, it specifies how long the receiving MC should retain the SM and continue trying to deliver it. This will be set to NULL if the current validity period is unavailable.


ExtractToPath Property

ExtractToPath Property (Zip Activity)

A base path to decompress to.

Data Type

string

Default Value

""

Remarks

Setting the ExtractToPath property affects the opExtract Operation. Setting this property to a nonempty string will cause all decompressed files to be written to the specified path. If pathnames are given in the values of decompressed names, they will be regarded as relative to ExtractToPath.

If the specified directory does not exist, it will be created when extraction is done.

ExtractToPath should always be specified in the format native to the host operating system, and with a trailing slash or backslash. If the path is specified otherwise, it will be immediately converted and stored in the converted format. For example, "/temp" would be immediately converted to "\temp\" on a Windows system.


FileMask Property

FileMask Property (Zip Activity)

Specifies which files the activity should include when extracting.

Data Type

string

Default Value

"*"

Remarks

FileMask may be used when extracting to specify which files will be extracted from the ArchiveFile property.

The value should be a pipe ("|") -delimited sequence of one or more filenames. The filenames should be specified with paths if necessary, so that the files may be found on the local file system.

Filenames may include the wildcards '?', '*', and '< .. >'. '?' will match any single character, and '*' will match an arbitrary sequence of characters. '< .. >' may be used to match any of the characters inside, or a range, such as '<a-z>'.

During extraction, FileMask may be set to one or more filenames or directory names. Files may be specified with or without a path, and with or without wildcards.

Subdirectories will be recursed into if RecurseSubdirectories is set to true.

The ExcludedFiles may be used to limit the files to be extracted.


Operation Property

Operation Property (Zip Activity)

The operation which will be executed by the ZIP task.

Possible Values

Extract(0)
Scan(1)

Data Type

string

Default Value

0

Remarks

There are two different operations that the ZIP Disassemble activity may perform. It may extract files, or perform a scan on the entire archive specified by ArchiveFile.

The default for this property is to extract files.


OverwriteFiles Property

OverwriteFiles Property (Zip Activity)

Whether or not to overwrite files.

Data Type

bool

Default Value

true

Remarks

If this property is set to true, existing files will be overwritten when decompressing. When extracting, each file specified by the FileMask will be checked for existence. If a file exists, the files will be overwritten if OverwriteFiles is set to true.